Спецвыпуск Xakep, Содержание номера # 034

Cover 034 |
Статья | Стр.
CONNECT |
Стандарты 1-2G - Сотовые сети первого и второго поколения | 004
Сплетение двух миров - Как работает IP-телефония | 012
Технология Bluetooth во всех ее проявлениях - О чем и не мечтал герцог Синезубов | 016
Мобильное общение без границ! - Публичное вскрытие SMS и MMS-технологий | 022
Три в одном: карта, компас и часы - Система спутниковой навигации GPS | 026
Вечный интернет для мобильника - Весь GPRS: от телефона до оператора | 030
Высокоскоростной Ethernet - История, технология, перспективы | 032
Технология Ж-Ж-Ж - Cотовые сети третьего поколения | 036
COMPUTING |
Голография – фантастика или реальность? - Как делают голограммы | 040
Всемогущий Flash - История создания и принцип работы суперпамяти | 044
Размер имеет значение! - МВС1000М - русский суперкомпьютер | 048
Два глаза - не роскошь - Современные 3D-стереотехнологии | 050
Цифровая реальность - 3D-визуализация в играх и кино | 056
Выжми на полную - Алгоритмы сжатия мультимедиа-данных | 060
Полноэкранное видео без тормозов - Графические акселераторы изнутри | 064
LIFE |
От лягушки до полимера - Батарейки и аккумуляторы: технологии и тенденции | 068
Электронные деньги: делай раз, делай два... - Как устроены электронные платежные системы на основе цифровой наличности | 072
В наш комп мы целый мир засунем - Цифровая фотография от A до Z | 076
Эволюция звуковых технологий Dolby - Теория и практика многоканального звука | 080
Мониторы будущего - Плазменные панели - технология сегодняшнего дня | 084
Убереги CMYK от RGB - Полиграфия в разрезе | 088
Электронные чернила - Технология и применение | 094
Dиски Vысоких Dостоинств - Прошлое, настоящее и будущее DVD | 098
Опись, протокол, отпечатки пальцев... - Обзор технологий биометрической идентификации | 106
SPECial delivery |
Умные линки - Технологии в Интернете | 110
Glossary - Словарь терминологии | 112
HARD |
Цифровые двухмегапиксельные мыльницы! | 114
Графическая станция USN LEONARDO | 118
STORY |
Не будите Арагорна... | 120


Спецвыпуск Xakep, номер #034, стр. 034-004-1, СТАНДАРТЫ 1-2G

СТАНДАРТЫ 1-2G

Олег "2sheds" Курапов

Спецвыпуск Xakep, номер #034, стр. 034-004-1

(ok@2sheds.ru), Элдар Разроев (коммерческий директор "МегаФон-Москва", sonicduo@sonicduo.com)

Сотовые сети первого и второго поколения

В нашей стране уже около 20 миллионов абонентов сотовых сетей. Того и гляди, мобильных телефонов окажется больше, чем обычных - стационарных. Мобильник сейчас есть у каждого, а у некоторых и не один! Однако мало кто знает, как работает сеть сотовой связи, а ведь это очень интересная система.

Любая сотовая сеть состоит из нескольких базовых станций, каждая из которых обслуживает несколько ячеек ("сот") с радиусом от сотен метров до нескольких десятков километров. Базовая станция включает в себя радиопередатчик и контроллер. Вместе они отвечают за передачу, прием и управление трафиком между мобильными станциями (телефонами, сотовыми модемами и т.п.), находящимися в зоне покрытия станции, и коммутационным центром.

Коммутационный центр отвечает за авторизацию и соединение абонентов внутри сети, устанавливает соединение при входящем вызове, а также постоянно следит за местоположением подвижных мобильных станций, по мере необходимости передавая обслуживание от одной базовой станции к другой. Эта функция, называемая Hand-off или Handover, является одним из основных отличий сотовой сети от других радиокоммуникационных систем.

Принципиальная схема сотовой сети

BS - базовая станция;

MSC - коммутационный центр;

VLR - реестр перемещений;

HLR - реестр собственных абонентов;

EIR - реестр идентификации оборудования;

AC - центр авторизации;

OMC - центр управления и обслуживания.

Кроме того, в структуру сотовой сети входят системы управления, обслуживания, тарификации и т.п. Точный список и названия отдельных компонентов могут изменяться в зависимости от используемого оператором стандарта, применяемого оборудования и даже фирмы-поставщика. Более подробную техническую информацию можно без проблем найти в интернете, ключевых слов в этой статье предостаточно :).

ОСНОВНЫЕ ПОНЯТИЯ

Сотовые технологии используют принцип повторного использования частот, что позволяет увеличить максимальное количество обслуживаемых абонентов, не вызывая наложения и пересечения каналов связи. Более того, одна и та же частота может быть использована сразу в нескольких сотах. Другой важный принцип, позволяющий еще эффективнее использовать имеющуюся полосу частот – разделение каналов. В зависимости от стандарта, может использоваться частотное (FDMA), временное (TDMA) или кодовое (CDMA) разделение.

Для пояснения принципа разделения каналов можно использовать такой пример: представь себе группу людей в одном помещении, разбитую на пары, общающиеся между собой. В таком случае, частотное разделение можно представить, как если бы каждая пара собеседников была помещена в звукоизолированный бокс, чтобы не мешать остальным. Временное разделение – все находятся в одном помещении, но говорят по очереди. И, наконец, кодовое разделение – все говорят одновременно, но на разных языках.

Кроме того, для сжатия потока могут применяться различные аудиокодеки, а также алгоритмы шифрования, обеспечивающие защиту информации.


Спецвыпуск Xakep, номер #034, стр. 034-004-2, СТАНДАРТЫ 1-2G

СТАНДАРТЫ 1-2G

Олег "2sheds" Курапов

Спецвыпуск Xakep, номер #034, стр. 034-004-2

СТАНДАРТЫ СОТОВОЙ СВЯЗИ ПЕРВОГО ПОКОЛЕНИЯ

Концепция сотовой связи была впервые изложена Рингом в техническом меморандуме Bell Labs от 1947 года, а уже к концу 50-х годов прошлого века имелись все технологии, необходимые для развертывания сетей. Но, несмотря на это, дальнейшее развитие было заморожено более чем на 20 лет из-за антимонопольных ограничений, наложенных на AT&T (ей принадлежала Bell Labs), а также 10-летней (!) задержки с выделением Федеральной частотной комиссией (FCC) США частотного спектра в диапазоне 800 МГц.

С середины 60-х японская Nippon Telegraph and Telephone Company (NTT, будущей DoCoMo) также начала работы в области сотовой связи, а в 1967 году выдвинула предложение по развертыванию национальной системы мобильной радиосвязи. Тем временем в Финляндии была образована группа компаний Nokia, а Федеральная частотная комиссия США наконец-то рассмотрела поданную 10 лет назад заявку от Bell Systems относительно выделения необходимых частот. Так был заложен фундамент для будущей ожесточенной конкуренции между телекоммуникационными компаниями на рынке сотовой связи.

Старт этой "гонке вооружений" был дан в 1973 году, когда специалисты Motorola подали заявку на патент под названием "Радиотелефонная система". По легенде, Мартин Купер, один из соавторов патента и руководитель проекта, не смог устоять перед искушением продемонстрировать успехи своей команды и специально позвонил конкурентам в Bell Labs, используя один из первых прототипов мобильного телефона.

После того как FCC дала добро на широкомасштабные эксперименты, компания приступила к постройке опытной сети в Чикаго. Контракт на 2 миллиона долларов для производства первых 135 телефонных аппаратов выиграла японская Oki, что вызвало массу возмущений в США, а в самой AT&T, похоже, кто-то здорово нагрел руки.

Стандарты первого поколения:

- Advanced Mobile Phone Service (AMPS)

- Nordic Mobile Telephone (NMT)

- Total Access Communication System (TACS, имел модификации E, J, N)

- NTT, RTMS, C-450, Radiocom-200 и др.

В декабре 1978 года компания перешла к стадии маркетингового исследования, когда пользователям были предложены первые сотовые телефоны, предназначенные для установки в автомобилях. Вскоре после этого началось коммерческое использование сетей AMPS, которые стали быстро распространяться по всему миру. В декабре 1979 года в японской столице запустили систему из 88 сот на оборудовании NEC и Matsushita. В 1981 году коммерческие сети стали появляться в Европе и Северной Америке, причем Мексике удалось перещеголять США, потому что там AT&T было запрещено выходить на региональный рынок, если на нем не имелось конкурентов. Поэтому первая AMPS-сеть была открыта в Чикаго только в 1983 году, уже после разделения американского монополиста на несколько независимых компаний.

Медленный старт американских компаний в некоторой мере компенсировался сохранением единства стандартов – клиенты могли свободно перемещаться из штата в штат, пользуясь возможностью роуминга. В Европе же в это время чуть ли не в каждой стране был собственный стандарт: TACS в Великобритании, NMT в скандинавских странах, C-Netz в Германии, Radiocom 2000 во Франции, RTMI/RTMS в Италии...


Спецвыпуск Xakep, номер #034, стр. 034-004-3, СТАНДАРТЫ 1-2G

СТАНДАРТЫ 1-2G

Олег "2sheds" Курапов

Спецвыпуск Xakep, номер #034, стр. 034-004-3

Но как у каждой медали есть две стороны, так и преимущества единого стандарта обернулись для американских операторов застоем в развитии. Пока они продолжали наращивать мощности своих надежных, но бедных функционально и слабо защищенных сетей, европейские компании искали другие пути. Уже в первой половине 80-х они объединили свои силы для создания нового поколения цифровых стандартов с набором продвинутых функций и облегченным роумингом. Но до появления GSM было еще далеко, и, пока Европа боролась с проблемами роста, в Америке число подключенных клиентов неуклонно увеличивалось: с 200 тысяч в 1985 году до 1,6 миллиона в 1988! Понятное дело, что ни о каких цифровых стандартах речи не шло – чтобы перевести такую армию абонентов и не потерять прибыли, революционные методы не годились, приходилось работать с тем, что имелось в наличии.

Аналоговая сотовая связь достигла вершины своего развития в первой половине 90-х годов. AMPS был доминирующим стандартом, его использовали операторы в более чем 70 странах мира, и более половины от общего числа абонентов были подключены к этим сетям.

РОССИЙСКИЕ ОСОБЕННОСТИ

Россия отстала от цивилизованного мира больше чем на 10 лет, лишь в 1991 году в Санкт-Петербурге была создана сотовая сеть стандарта NMT. Первую AMPS-сеть запустили в 1994 году в Нижнем Новгороде. С тех пор "кирпичи" сотовых телефонов прочно вошли в наш фольклор, став неотъемлемым атрибутом лубочных "новых русских".

Лучше всего на наших просторах прижился стандарт AMPS. Он обладал лучшими, чем NMT, потребительскими качествами, а также превосходил набиравший силы GSM по соотношению области покрытия и цены, важному критерию при развертывании сотовых сетей "с нуля". Эта ситуация сохранялась до 1997 года, после чего аналоговые системы стали все быстрее сдавать позиции конкурентам из лагеря GSM.

СТАНДАРТЫ СОТОВОЙ СВЯЗИ ВТОРОГО ПОКОЛЕНИЯ

В конце 80-х уже было ясно, что мобильные телефоны пришли всерьез и надолго. В США и некоторых других странах ежегодный прирост числа абонентов достигал 100%, а потому проблема увеличения емкости сотовых сетей стала одной из главнейших для операторов и производителей оборудования.

Начавшиеся разработки аналоговых стандартов с временным разделением (EAMPS) и узкополосных (NAMPS) были быстро признаны бесперспективными, а потому основные усилия были брошены на создание и внедрение цифровых стандартов. Огромные затраты на исследования не могли окупиться на одних только локальных рынках, а потому было ясно, что этот проект должен стать по-настоящему глобальным.

GSM

Еще в 1982 году группа из 26 национальных телекоммуникационных компаний европейских стран приступила к созданию единого стандарта сотовой связи. Эта инициатива получила название GSM (Groupe Speciale Mobile, позднее переименована в Global System for Mobile Communications). С самого начала планировалось, что новый стандарт будет цифровым с рабочим диапазоном 900 МГц, хотя окончательное решение было принято в 1987 году.


Спецвыпуск Xakep, номер #034, стр. 034-004-4, СТАНДАРТЫ 1-2G

СТАНДАРТЫ 1-2G

Олег "2sheds" Курапов

Спецвыпуск Xakep, номер #034, стр. 034-004-4

В ходе экспериментов было решено, что новый стандарт должен использовать технологию временного разделения каналов (TDMA) – это предоставляло ему необходимую гибкость, а поддержка этой технологии со стороны ведущих компаний позволяла надеяться на быстрое внедрение решений на ее основе в будущем.

В 1989 году за дальнейшую разработку взялся Европейский институт телекоммуникационных стандартов (ETSI). Первые рекомендации были опубликованы в 1990 году, а в 1991 Великобритания создала на базе GSM свою вариацию под названием Digital Cellular System (DCS). Единственным отличием был используемый диапазон частот – DCS1800 работает на 1,8 ГГц.

В результате, GSM с 1997 года стал самым популярный стандартом сотовой связи в мире, перехватив знамя из слабеющих рук AMPS. К началу 2002 года его использовали 574 оператора в 171 стране, обслуживая около 630 миллионов абонентов.

Такое распределение неслучайно, GSM изначально разрабатывался именно с учетом специфики. Страны Европы имеют очень большую демографическую плотность, развитую экономику и платежеспособное население, заинтересованное в удобствах, предоставляемых сотовой связью. Все это обеспечивает европейским операторам высокую рентабельность и быструю окупаемость вложенных средств.

Востребованность сотовой связи на этом рынке заставляет операторов искать возможности увеличения имеющихся частотных диапазонов. Так появился Enhanced GSM (EGSM 900) – расширенный GSM, использующий дополнительные полосы 880-890 и 925–935 МГц. Эти частоты были выделены не во всех странах, а потому поддержка этого стандарта является задачей производителей сотовых телефонов. В зависимости от местоположения абонентов их аппараты должны сами определять наличие расширенного диапазона в локальной сети. Гигагерцовая модификация GSM, изначально использовавшаяся в Великобритании, в последние годы распространилась за ее пределы, причем в некоторых странах сотовые сети работают только в диапазоне GSM1800.

Таким образом, вместе с введенной в 1995 году американской вариацией стандарта, использующей диапазон 1,9 ГГц, ситуация с GSM-сетями опять оказалась весьма запутанной. Это вынуждает производителей создавать двух- и трехмодовые аппараты, что не может не сказываться на их стоимости, но благодаря быстрым темпам развития цены на клиентское и сетевое оборудование постоянно падают.

Каждый абонент GSM-сетей получает SIM-карту, содержащую необходимую для аутентификации информацию: индивидуальный ключ и алгоритм, с помощью которых подтверждается подлинность абонента. Для этого на телефон посылается случайный номер, в нем на основе полученных данных производятся расчеты, а затем результаты отправляются обратно. Если полученный отклик совпадает со значением, вычисленным сетью, то процедура авторизации считается пройденной, и только тогда телефону разрешается перейти к передаче информации.

Такая проверка обеспечивает достаточно надежную защиту от мошенников-двойников, которые долгие годы паразитировали на аналоговых сетях, но вот для защиты конфиденциальности GSM-сети приспособлены плохо. В принципе, имеющаяся схема шифрования с открытым ключом могла бы обеспечивать необходимый уровень безопасности, но, к сожалению, она была достаточно быстро скомпрометирована – теперь аппаратуру для подслушивания переговоров вполне может приобрести даже частное лицо, не говоря уж о спецслужбах, коммерческих организациях или преступных сообществах.


Спецвыпуск Xakep, номер #034, стр. 034-004-5, СТАНДАРТЫ 1-2G

СТАНДАРТЫ 1-2G

Олег "2sheds" Курапов

Спецвыпуск Xakep, номер #034, стр. 034-004-5

РОССИЙСКИЕ ОСОБЕННОСТИ

Заложенная при разработке ориентация на европейскую специфику не учитывала возможностей развертывания сотовых сетей с относительно малым числом абонентов и, соответственно, менее мощным коммутационным оборудованием. Во многом из-за этого российским операторам, сделавшим ставку на GSM-стандарт, сначала пришлось очень нелегко. Одной из главных трудностей на их пути стало то, что частотный спектр в области 900 МГц уже был занят под нужды аэронавигационных служб. После длительных разбирательств этой проблемы Государственная комиссия по радиочастотам выдала разрешения на ряд частотных диапазонов, достаточных для работы 3 операторов.

В 1997 году начался новый этап этого процесса, операторы взялись за внедрение GSM1800. Правда, вначале лицензии выдавались только на этот диапазон, без соответствующих разрешений на 900 МГц. Надо отметить, что в Европе операторы, работающие только в гигагерцовых стандартах, смогли достичь рентабельности только через 5-6 лет после начала развертывания сетей – сказывались огромные затраты на закупку оборудования. В условиях нашей страны, с ее огромными площадями и соответственно низкой плотностью трафика, такие условия лишали развитие таких сетей всяких перспектив. Гораздо рациональнее использовать двухдиапазонную модель, где нижний диапазон создает зону покрытия, а верхний обеспечивает локальные зоны с высокой концентрацией трафика. После разъяснения этих разногласий операторам выдавались двойные лицензии: на 900 МГц и на 1,8 ГГц. В результате, к началу 2002 года в России работало несколько сетей GSM, в которых обслуживалось порядка 6,7 миллионов абонентов. Практически во всех регионах было по три лицензиата GSM.

D-AMPS

В начале 90-х огромная абонентская база и развернутая сетевая инфраструктура буквально душили американских операторов. В крупных городах диаметр сот уменьшился до 1,5 км, что считалось пределом для технологии AMPS. Это также не давало им возможности резкой смены курса, а потому переход к цифровым технологиям должен был быть эволюционным.

При разработке D-AMPS ключевым моментом являлось сохранение совместимости с аналоговыми сетями его предшественника. Кроме того, в его основу лег ранний 2G-стандарт IS-54. После одобрения федеральной комиссией он получил официальное наименование IS-136. Работая на частотах 800/1900 МГц, D-AMPS так же, как и GSM, использует метод временного разделения каналов (TDMA). Благодаря этому несколько звонков могут быть одновременно распределены в одном канале, что позволяет увеличить эффективность использования диапазона в три раза.


Спецвыпуск Xakep, номер #034, стр. 034-004-6, СТАНДАРТЫ 1-2G

СТАНДАРТЫ 1-2G

Олег "2sheds" Курапов

Спецвыпуск Xakep, номер #034, стр. 034-004-6

Все эти возможности мало значили бы для операторов, если бы для их внедрения пришлось ждать несколько лет. Поэтому производители начали выпускать двухмодовые телефоны. Интересным последствием этого решения является то, что если D-AMPS-телефон потеряет сеть, он может автоматически переключаться в аналоговый режим, если цифровой более не доступен.

РОССИЙСКИЕ ОСОБЕННОСТИ

В условиях нашей страны D-AMPS приобрел популярность именно из-за возможности параллельного использования относительно простого и дешевого аналогового оборудования совместно с более продвинутыми и дорогими цифровыми решениями. Это позволяло российским операторам начинать расширять свою зону покрытия за счет AMPS-сетей, а затем для наращивания мощности переводить их на D-AMPS.

К началу 2002 года у нас насчитывалось 54 региональных оператора стандартов (D,N,E)AMPS, причем многие пришли в бизнес этим самым путем – от AMPS к D-AMPS. Все вместе они обслуживали около 800 тысяч абонентов (более трети из них в Москве и Подмосковье). Но дальнейшее развитие затрудняется с каждым годом, оборудование снимают с производства, возможности модернизации сильно ограничены – все это делает эксплуатацию сетей AMPS/D-AMPS менее рентабельной. Единственной возможностью для дальнейшего развития является переход к CDMA-технологии, выбранный некоторыми операторами за рубежом.

CDMA

В 1995 году семейство сотовых систем второго поколения пополнилось стандартом IS-95a, в котором был впервые применен новый метод – кодовое разделение каналов с использованием шумоподобных сигналов или просто CDMA (Code Division Multiple Access). Принципиальное его отличие от TDMA заключается в том, что каждый пользователь имеет специальный цифровой код. Передатчик использует его для кодирования информации. Со своей стороны приемник использует этот же код для расшифровки и обратного преобразования полученных сигналов.

Кстати, называть стандарт IS-95a просто "CDMA" не совсем корректно, так как это лишь название используемого им метода разделения, официальное наименование - "cdmaOne", но используется оно, пожалуй, только в официальных бумагах. Теперь поздно ломать копья, ведь главное здесь не название, а технологические преимущества:

– увеличенная в 4-5 раз по сравнению с GSM (и в 8-10 раз по сравнению с AMPS) емкость каналов передачи;

– улучшенное качество передачи звука, абоненты CDMA-сетей слышат друг друга гораздо лучше, чем те, кто пользуется GSM;

– меньшее число прерванных разговоров, используемый в сетях метод "soft handoff" позволяет решить проблему срыва звонков при передаче контроля от одной базовой станции к другой;

– упрощенное планирование и развертывание сетей за счет расширенной зоны действия и использования общего частотного диапазона для всех сот;

– повышенная секретность переговоров;

– сниженное энергопотребление абонентских устройств;

– динамическое распределение ширины канала.

Вообще отличий у CDMA едва ли не больше, чем общих черт. Это совершенно иной способ передачи информации. Раньше главной проблемой разработчиков было "втиснуть" в имеющийся диапазон максимальное число каналов. Вместо этого у CDMA они могут иметь ширину порядка единиц мегагерц. Дело в том, что закодированный поток фактически представляет собой обычный шум, который может спокойно накладываться на другие сигналы в этом диапазоне без потерь и каких-то еще неприятностей.


Спецвыпуск Xakep, номер #034, стр. 034-004-7, СТАНДАРТЫ 1-2G

СТАНДАРТЫ 1-2G

Олег "2sheds" Курапов

Спецвыпуск Xakep, номер #034, стр. 034-004-7

Есть и другие преимущества, к примеру, в отличие от аналоговых и TDMA-стандартов, смежные соты могут использовать одни и те же частоты без возникновения интерференции. Кодирование – это, конечно, хорошо, но все же недостаточно для создания рабочей схемы. Требуется обеспечить четкую синхронизацию передаваемых данных – для этого используется технология GPS. Эти же сигналы применяются в оборудовании CDMA-сетей для обеспечения четкой временной привязки.

То, что у CDMA масса преимуществ, наглядно видно по тому, что модификации этого стандарта используются в 3G-сетях. К примеру, технология voice-activity detection (VAD): в процессе любого разговора как минимум половину времени один из собеседников молчит – действительно, мы ведь разговариваем не одновременно, а по очереди. Передавать по загруженному каналу тишину – непозволительная роскошь, а потому CDMA-сети содержат оборудование, которое может динамически (измерение уровня сигнала происходит несколько раз в секунду) изменять ширину канала в зависимости от того, говорит абонент или молчит. Кстати, этот трюк также позволяет экономить энергию батарей, что всегда приятно.

Другой интересной технической особенностью CDMA является теоретически неограниченное наращивание емкости канала, ведь передаваемые сигналы по своей сути являются шумом, который по определению может иметь бесконечный спектр. На практике не все оказывается так просто.

ПЕРЕДАЧА ДАННЫХ

По большому счету, переход к использованию полностью цифровых технологий – еще не панацея. Пусть это и дает экономию частотных ресурсов, но, в конце концов, это могли предложить и более продвинутые варианты AMPS, вдобавок качество связи у аналоговых стандартов объективно выше. Важнее другое – "цифра" предоставляет широкие возможности по внедрению дополнительных сервисов, в первую очередь передачи данных. Новые сервисы и большая эффективность использования частотного спектра предопределили развитие сотовой связи в направлении цифровых стандартов.

Первоначально набор услуг совпадал с тем, который доступен через обычные телефонные сети: передача факсов, связь с сетью через модем и т.п. В дальнейшем этот список стал пополняться принципиально новыми возможностями. Наиболее популярной из них являются короткие текстовые сообщения - SMS. Это изобретение немецкой компании Materna появилось в сетях GSM. SMS-бум конца 90-х стал настоящей сенсацией, превратившись из очередного техно-акронима в сервис, ежедневно используемый миллионами людей. Каждый год по всему миру отправляются десятки миллиардов (!) сообщений. SMS стал основой отдельной субкультуры, со своими собственными правилами, контентом и даже универсальным языком.


Спецвыпуск Xakep, номер #034, стр. 034-004-8, СТАНДАРТЫ 1-2G

СТАНДАРТЫ 1-2G

Олег "2sheds" Курапов

Спецвыпуск Xakep, номер #034, стр. 034-004-8

Пользуется популярностью и голосовая почта – аналог автоответчика, но только для сотового. Если в России эта услуга мало распространена, то в Европе и Америке большинство абонентов активируют ее на своих телефонах. Попытки объединить текст, звук и графику воплотились в новом сервисе – Multimedia Messaging Services (MMS). Распространение новых моделей телефонов, оснащенных цветными дисплеями, встроенными фотокамерами и полифоническим звуком провоцирует потребителей к обмену мультимедийным контентом. Операторы полагают, что в скором будущем MMS заменит как SMS, так и голосовую почту.

В компьютерном мире интернет-бум почти совпал по времени с SMS-бумом в среде пользователей сотовой связи. Конечно же, логичнее объединить две эти популярные технологии, ведь, как показывают исследования, более половины владельцев GSM-телефонов имеют доступ в интернет. Тем не менее, многочисленные попытки объединить сотовые телефоны и интернет имели переменный успех: от почти полного забвения WAP-технологий во всех их реинкарнациях (1.0-1.2.1) до японского iMode-бума.

Одной из причин провала всех видов WAP-услуг стало вполне объяснимое нежелание абонентов пользоваться интернет-услугами по коммутируемым линиям с поминутной тарификацией. Кроме того, скорость 9600 бит/с также является недостаточной для комфортного перемещения по сайтам. Все это подтолкнуло развитие технологий пакетной передачи данных. В сетях GSM для этих целей реализуется поддержка GPRS. Телефоны, совместимые с этой технологией, обеспечивают пользователям скорость соединения, сопоставимую с хорошим модемом (около 50-60 Кбит/с). Теоретическим пределом является значение 172,8 Кбит/с, но в ближайшие год-два было бы хорошо, если бы удалось достичь скоростей хотя бы в районе 100 Кбит/с.

С увеличением скорости связана еще одна проблема – радиационная безопасность. Дело в том, что уже при скоростях от 27 до 86 Кбит/с не исключен перегрев телефона, а мощность излучения на мозг превысит предельно допустимые нормы. Проблема кроется в использовании технологии временного разделения каналов, того самого TDMA. Для обеспечения более высоких скоростей передачи данных телефоном используется несколько временных интервалов (слотов). Уже при трехслотовом подключении можно ожидать трехкратного превышения уровня излучения, создаваемого при обычной голосовой связи.

Несмотря на эти проблемы, многие специалисты связывали с технологиями пакетной передачи данных возрождение WAP – ведь именно это, по распространенному мнению, обеспечило технологии iMode популярность у более чем 40% абонентов японских сотовых сетей. Но пока позитивной динамики не наблюдается. Возможно, это связано с тем фактом, что для iMode существует огромное количество качественного мультимедийного контента, а также развитая инфраструктура и режим максимального благоприятствования со стороны операторов сотовых сетей.

ЗАКЛЮЧЕНИЕ

Тем не менее, сейчас будущее сотовой связи – это увеличение скоростей передачи данных и введение новых мультимедийных сервисов. Именно эти цели ставились перед стандартами третьего поколения. К примеру, стандарт CDMA 2000 1X, внедренный во многих странах мира, уже обеспечивает скорость до 153 Кбит/с. У GSM в рукаве тоже есть пара тузов, так что они еще повоюют нам на пользу.


Спецвыпуск Xakep, номер #034, стр. 034-004-9, СТАНДАРТЫ 1-2G

СТАНДАРТЫ 1-2G

Олег "2sheds" Курапов

Спецвыпуск Xakep, номер #034, стр. 034-004-9

ТИПОВАЯ ОРГАНИЗАЦИЯ СОТОВОЙ СЕТИ

Термин "сотовая сеть" возник не на пустом месте. Дело в том, что система сотовой радиотелефонной связи формируется из неограниченного числа территориальных ячеек, которые чаще называют сотами. При этом ячейки могут накладываться друг на друга, соприкасаться или вовсе не соприкасаться друг с другом. В идеале из ячеек должно формироваться сплошное покрытие, но ничто не бывает идеальным. Границы ячеек условны и определяются допустимым отношением сигнал/шум для радиосигнала, поступающего от антенны базовой станции к мобильному телефону и наоборот.

В каждой ячейке есть своя антенна, подключенная к соответствующей базовой станции. Если базовая станция обслуживает одну ячейку, она, как правило, снабжена антенной с круговой диаграммой направленности и находится в центре ячейки. В развитых сетях (с большим числом абонентов) используются секторные базовые станции, обслуживающие одновременно три ячейки. В этом случае базовая станция устанавливается в точке соприкосновения всех трех ячеек и имеет три направленные антенны, которые облучают соответствующие ячейки. При необходимости возможно использование более многосекторных базовых станций.

Все базовые станции (BTS) через контроллеры (BSC) и транскодеры (TC) подключаются к центру коммутации (NSS), включающему в себя один или несколько коммутаторов (MSC), регистр домашних (HLR) и гостевых (VLR) абонентов, аппаратный регистр (EIR), центр аутентификации (AuC), систему СОРМ (SORM), а также необходимые интерфейсы. Для центра коммутации сотовой сети обязательное подключение - к ТфОП (PSTN). В развитых сетях есть центр мониторинга (OMC-R). Кроме того, в современных сотовых сетях, как правило, устанавливают системы голосовой почты (VMS) и предоплаченных услуг (PPS). А в сетях 2-го поколения – системы, обеспечивающие передачу данных: SMS-центр (SMSC), WAP и GPRS (в сетях DAMPS - CDPD). При интеграции большого числа разноплановых систем целесообразно использование Mediation Device.

ОРГАНИЗАЦИЯ РАДИОКАНАЛОВ С ЧАСТОТНЫМ РАЗДЕЛЕНИЕМ

Выделенный частотный диапазон делится на полосы частот, при этом в одной полосе частот передается разговор только одного абонента. Подобный вариант используется в аналоговых сотовых стандартах NMT и AMPS. Он является наименее эффективным способом использования частотного ресурса. Передатчик в мобильных телефонах, работающих с частотным разделением, включен в течение всего времени разговора (довольно быстро подсаживая аккумулятор).

ОРГАНИЗАЦИЯ РАДИОКАНАЛОВ С ВРЕМЕННЫМ РАЗДЕЛЕНИЕМ

Сначала делается "нарезка" диапазона на полосы частот (частотное разделение), а затем в каждой полосе частот выделяются временные сегменты и закрепляются за радиоканалами. Таким образом, при временном разделении в одной полосе одновременно может передаваться разговор нескольких абонентов (3 или 6 в DAMPS и 8 или 16 в GSM).


Спецвыпуск Xakep, номер #034, стр. 034-004-10, СТАНДАРТЫ 1-2G

СТАНДАРТЫ 1-2G

Олег "2sheds" Курапов

Спецвыпуск Xakep, номер #034, стр. 034-004-10

В канале могут работать до 8 телефонов с временным разделением (как правило, цифровых), передавая короткие пакеты данных по одному и тому же каналу по очереди. Хотя максимальная выходная мощность сигнала аппарата GSM составляет 2 Вт, на практике он излучает одну восьмую этой энергии (0,25 Вт), часто она бывает еще меньше. Чтобы сэкономить энергию и увеличить число телефонов, способных одновременно работать в системе, мощность сигнала автоматически снижается до минимально необходимой для поддержания надежной связи с базовой станцией.

ОРГАНИЗАЦИЯ РАДИОКАНАЛОВ С КОДОВЫМ РАЗДЕЛЕНИЕМ

Выделенный частотный диапазон не делится на узкие полосы частот, а радиоканалам присваивается своя специфическая частотно-временная кодовая комбинация. В результате, в одном и том же частотном диапазоне кодовое разделение позволяет организовать наибольшее число не влияющих друг на друга каналов. Кроме того, в отличие от приема сигналов, передаваемых с частотной (а тем более амплитудной) модуляцией при организации каналов с частотным и/или временным разделением (в этом случае приемник всегда настроен на относительно узкий частотный спектр), прием сигналов с кодовым разделением (по определению широкополосных) менее подвержен воздействию помех (случайных или преднамеренных).

Для любой сотовой сети одной из важнейших характеристик является ее предельная емкость. Как правило, при хорошем территориально-частотном планировании сети максимально возможное число обслуживаемых в ней абонентов приблизительно в 30–50 раз больше числа организованных в сети каналов связи. Это вызвано тем, что радиоканалы жестко не закреплены за подвижными станциями, каждой из них может быть присвоен любой свободный канал из общего набора. В часы максимальной нагрузки средний абонент разговаривает не более 2 минут в час, то есть один радиоканал используется приблизительно тридцатью абонентами. Кроме того, для определения емкости сети важен коэффициент повторного использования частот применяемого в ней стандарта. Он равен отношению числа используемых в сети независимых частот к общему числу ячеек в сети. Эта величина лежит в пределах от 7 (аналоговые сети с всенаправленными антеннами) до 3 (цифровые сети с секторными направленными антеннами). Для сетей, работающих в стандарте CDMA, коэффициент повторного использования частот по определению равен единице. Чем меньше величина этого коэффициента, тем эффективнее используется выделенный частотный ресурс.

Общее число каналов связи в сотовой сети определяется формулой:

N – число каналов в сети;

C – число сот;

k – коэффициент повторного использования частот;

F – выделенный частотный диапазон;

f – разнос каналов;

n – коэффициент уплотнения (для FDMA – 1, для TDMA – соответствует числу временных слотов во фрейме, для CDMA – соответствует числу кодовых комбинаций в одной полосе частот).

При расчете теоретической емкости сети необходимо учитывать, что она зависит не только от числа организованных каналов, но и от территориального распределения трафика в часы максимальной нагрузки, а также от того, насколько хорошо ему соответствует организация сети. Однако решающее влияние на емкость сети оказывают два обстоятельства:


Спецвыпуск Xakep, номер #034, стр. 034-004-11, СТАНДАРТЫ 1-2G

СТАНДАРТЫ 1-2G

Олег "2sheds" Курапов

Спецвыпуск Xakep, номер #034, стр. 034-004-11

- диапазон выделенных частот (частотный ресурс);

- способ организации радиоканалов.

В таблице приведены данные, необходимые для расчетов емкости сети: диапазоны частот, выделенные для действующих систем сотовой связи (в том числе для нисходящих [от базовой станции к подвижной] и восходящих [наоборот] каналов), число дуплексных (двухсторонних) радиоканалов, размещаемых в этих диапазонах, коэффициенты повторного использования частот и уплотнения.

www.kunegin.narod.ru/ref.htm – рефераты о различных информационных технологиях, масса информации по CDMA, GSM (rus)

www.aboutphone.info/cellular.html – толковые статьи, связанные с телефонией (rus)

www.ixbt.com/mobile.shtml - iXBT: Мобильная связь – и этим все сказано (rus)

www.telecomwriting.com - размышления на тему сотовой связи, грамотно изложенные и с большим количеством полезных ссылок (eng)

www.ccnga.uwaterloo.ca/~jscouria/GSM/gsmreport.html – GSM, обзор технологии (eng)

www.cdg.org - CDMA Development Group (eng)

www.gsmworld.com – GSM World (eng)

Развитие сотовых сетей можно разбить на три этапа. Первому соответствуют аналоговые стандарты, в которых передача сигналов с частотной модуляцией выполнялась с использованием радиоканалов, организованных методом частотного разделения (FDMA).

Одна из главных возможностей, предоставляемая всеми сотовыми сетями – роуминг, возможность обслуживания сотовых абонентов в сетях одного стандарта, принадлежащих разным компаниям.

Сотовые технологии используют принцип повторного использования частот, что позволяет увеличить максимальное количество обслуживаемых абонентов, не вызывая наложения и пересечения каналов связи.

Россия отстала от цивилизованного мира больше чем на 10 лет, лишь в 1991 году в Санкт-Петербурге была создана сотовая сеть стандарта NMT. Первую AMPS-сеть запустили в 1994 году в Нижнем Новгороде.

В результате, GSM с 1997 года стал самым популярным стандартом сотовой связи в мире, перехватив знамя из слабеющих рук AMPS. К началу 2002 года его использовали 574 оператора в 171 стране, обслуживая около 630 миллионов абонентов.

Каждый абонент GSM-сетей получает SIM-карту, содержащую необходимую для аутентификации информацию: индивидуальный ключ и алгоритм, с помощью которых подтверждается подлинность абонента.

Интересным последствием этого решения является то, что если D-AMPS-телефон потеряет сеть, он может автоматически переключаться в аналоговый режим, если цифровой более не доступен.

В нашей стране D-AMPS приобрел популярность из-за возможности параллельного использования простого и дешевого аналогового оборудования совместно с более продвинутыми и дорогими цифровыми решениями.

То, что у CDMA масса преимуществ, наглядно видно по тому, что модификации этого стандарта используются в 3G-сетях.

"Цифра" предоставляет широкие возможности по внедрению дополнительных сервисов, в первую очередь передачи данных.


Спецвыпуск Xakep, номер #034, стр. 034-004-12, СТАНДАРТЫ 1-2G

СТАНДАРТЫ 1-2G

Олег "2sheds" Курапов

Спецвыпуск Xakep, номер #034, стр. 034-004-12

SMS-бум конца 90-х стал настоящей сенсацией, превратившись из очередного техно-акронима в сервис, ежедневно используемый миллионами людей. Каждый год по всему миру отправляются десятки миллиардов (!) сообщений.

Одной из причин провала всех видов WAP-услуг стало вполне объяснимое нежелание абонентов пользоваться интернет-услугами по коммутируемым линиям с поминутной тарификацией и скорость 9600 бит/c.

С увеличением скорости связана проблема радиационной безопасности. При скоростях от 27 до 86 Кбит/с не исключен перегрев телефона, а мощность излучения на мозг превысит предельно допустимые нормы.

Тем не менее, сейчас будущее сотовой связи – это увеличение скоростей передачи данных и введение новых мультимедийных сервисов. Именно эти цели ставились перед стандартами третьего поколения.


Спецвыпуск Xakep, номер #034, стр. 034-012-1, Сплетение двух миров

Сплетение двух миров

Докучаев Дмитрий aka Forb

Спецвыпуск Xakep, номер #034, стр. 034-012-1

(forb@real.xakep.ru)

Технология IP-телефонии

Человечество уже несколько лет одновременно использует виртуальные услуги интернета и вполне реальные телефонные переговоры. До недавнего времени люди даже не стремились объединить их. Впрочем, первые попытки были предприняты, когда организовывался dial-up-доступ в глобальную сеть.

Но потом появилась совершенно новая технология, позволяющая совершить звонок по телефону через интернет. Казалось бы, проблематично объединить коммутацию каналов (телефонные сети) и коммутацию пакетов (TCP/IP), но в наше время нет ничего невозможного!

Что это такое?

Ты, наверное, уже понял, что такое IP-телефония. Эта новая технология позволяет связать две сети – телефонную и компьютерную. Связь происходит посредством шлюза, представляющего собой отдельный компьютер, с одной стороны которого находятся телефонные провода, а с другой IP-сеть (например, интернет). Это позволяет реализовать звонки через интернет. Попытаемся разобраться, как происходит телефонный звонок.

При регистрации входящего звонка автоматическая телефонная станция перенаправляет сигнал на пограничное сетевое устройство (ПСУ или просто шлюз). Этот сигнал обрабатывается специальной картой шлюза. Используя протоколы обмена семейства H.323, ПСУ отправляет информацию уже другому шлюзу, который находится на приемной стороне IP-сети. Второй шлюз обеспечивает передачу информации на приемное телефонное оборудование. После этого происходит сквозное соединение (телефон-ip-телефон). При этом голос на входном сетевом устройстве подлежит оцифровке, кодированию стандартными алгоритмами (G.711 или G.729), сжатию и инкапсуляции в TCP-пакеты. Они передаются по назначению на удаленное устройство. После того как эти пакеты дошли до приемного шлюза, происходит обратный процесс – преобразование их в телефонный сигнал. Только по завершении этого конечный абонент получит вызов. Весь алгоритм реализуется очень быстро, поэтому потребители даже не догадываются о том, как осуществляется звонок.

Разумеется, никакого привлечения междугородней/международной АТС к организации телефонного звонка тут нет, хотя вызов может приниматься и в другом городе/стране. Огромным плюсом IP-телефонии является низкая стоимость переговоров.

Преимущества IP-связи

Раз уж мы заговорили о цене, затронем и другие преимущества этой связи. Некоторые думают, что достоинство IP-телефонии только в цене. На самом деле, это не совсем так.

1. Стоимость переговоров.

Несомненно, IP-связь в несколько (десятков) раз дешевле телефонной. Внедрение технологии VoIP (Voice over IP) в рамках вычислительной сети позволяет уменьшить суммарные расходы, связанные с ведением международных и междугородних телефонных переговоров, а также начать процесс миграции к технологиям пакетной передачи мультимедийных данных. Для сравнения, организовать обычную телефонную сеть в сто раз дороже, чем IP-связь. Кроме того, учитывая возможность выхода на городскую телефонную сеть, использование этой технологии может свести к минимуму аренду обычных телефонных линий.


Спецвыпуск Xakep, номер #034, стр. 034-012-2, Сплетение двух миров

Сплетение двух миров

Докучаев Дмитрий aka Forb

Спецвыпуск Xakep, номер #034, стр. 034-012-2

2. Улучшенное качество связи.

Цифровые технологии позволяют значительно улучшить качество переговоров. Улучшение кодирования голоса и восстановление потерянных пакетов позволило достичь уровня, когда речь понимается абонентами настолько хорошо, что собеседники не догадываются, что соединение происходит по технологии IP-телефонии. Второй проблемой связи является задержка пакетов. Известно, что для человека задержка до 250 миллисекунд практически незаметна. Существующие на сегодняшний день решения IP-телефонии не превышают этот предел, так что разговор фактически не отличается от связи по обычной телефонной сети. Кроме этого, задержки уменьшаются благодаря следующим факторам:

а) постоянное совершенствование телефонных серверов (улучшение алгоритмов работы, обновление программного обеспечения, и т.п.);

б) развитие частных (корпоративных) сетей, вследствие чего увеличивается пропускная полоса канала и, соответственно, уменьшаются задержки;

в) развитие сети интернет - современный интернет не был рассчитан на коммуникации в режиме реального времени. The Internet Engineering Task Force (IETF) вместе с операторами глобальных сетей предлагают новые технологии, такие, как Reservation Protocol (RSVP), позволяющий резервировать полосу пропускания.

3. Интеграция с интернет-доступом.

Где есть IP-связь, там есть и интернет. Таким образом, пользуясь технологией VoIP, ты можешь насладиться работой в глобальной сети с высокой пропускной способностью (естественно, за определенную плату ;)).

4. Глобальный роуминг.

IP-телефония позволяет провайдерам связи очень просто и с минимальными затратами организовать роуминг. Это особенно актуально для операторов мобильной связи - решение, построенное на технологиях IP-телефонии, на порядок дешевле традиционного и обладает гораздо большей гибкостью.

Различают несколько видов новой связи. Звонок “Телефон-телефон” (принцип которого был описан выше) является самым очевидным, но далеко не единственным сервисом, который может предоставлять оператор IP-телефонии. Используя VoIP, можно обмениваться цифровой информацией для пересылки голосовых или факсимильных сообщений между двумя компьютерами в режиме реального времени. Применение интернета позволяет реализовать эту службу в глобальном масштабе. Для IP-телефонии чаще всего используется стандарт Н.323, определяющий передачу видео и аудио по сетям с негарантированным качеством услуг, таким, как IP. Н.323 описывает несколько элементов, в том числе аудио- и видеокодеки (кодеры/декодеры), коммуникационные протоколы и синхронизацию пакетов.

На сегодняшний день реализовано четыре вида IP-телефонии. Рассмотрим подробно каждый из них и отметим, в какой отрасли он может применяться.

1. “Компьютер - компьютер”. Назвать этот вариант примером IP-телефонии можно с натяжкой, потому как голос передается только по IP-сети, без действия телефонного оборудования. Для организации передачи трафика пользователь приобретает программное обеспечение (может, даже необходимое оборудование), а также платит провайдеру за эксплуатацию канала связи. Достоинство этого вида заключается в максимальной экономии средств. Недостаток - минимальное качество связи.


Спецвыпуск Xakep, номер #034, стр. 034-012-3, Сплетение двух миров

Сплетение двух миров

Докучаев Дмитрий aka Forb

Спецвыпуск Xakep, номер #034, стр. 034-012-3

2. “Телефон - телефон”. Принцип этого вида связи был описан выше. Для его организации необходимо наличие определенных сетевых устройств и механизмов взаимодействия. Голосовой трафик передается через IP-сеть, как правило, на отдельном участке. Устройствами, организующими взаимодействие, являются шлюзы, состыкованные, с одной стороны, с телефонной сетью общего пользования (ТфОП), а с другой - с IP-сетью. Голосовая связь в таком режиме, по сравнению с вариантом “Компьютер - компьютер”, стоит дороже, однако качество ее значительно выше, и пользоваться ей гораздо удобнее. Для того чтобы воспользоваться этой услугой, надо позвонить оператору, обслуживающему шлюз, ввести с телефонного аппарата код и номер вызываемого абонента и разговаривать так же, как при обычной телефонной связи. Все необходимые операции по маршрутизации вызова выполнит ПСУ.

3. “Компьютер - телефон”. Этот вид связи находит широкое применение у корпоративных пользователей, так как чаще всего применяется корпоративная сеть, обслуживающая вызовы от компьютеров до шлюза, которые уже затем передаются по ТфОП. Корпоративные решения с использованием вида связи “компьютер-телефон” могут помочь значительно сэкономить деньги. Что примечательно, пользователю никакого дополнительного оборудования не требуется. Ему достаточно иметь под рукой телефон с возможностью тонального набора. Это нужно для того, чтобы, дозвонившись до оператора, ввести свой код в тональном режиме, а дальше действия абонента ничем не отличаются от обычных. В большинстве современных телефонных аппаратов, включая мобильные телефоны, эта функция предусмотрена.

4.“Web - телефон”. Еще одна новая услуга, которую предоставляют провайдеры IP-телефонии - это звонок с web-сайта, который может осуществляться путем выбора ссылки на имя вызываемого абонента. Решение направлено, прежде всего, на расширение возможностей электронной коммерции. Электронные звонки позволяют пользователям интернета напрямую поговорить, например, с торговым представителем или со специалистом технической поддержки интересующей его фирмы. Установка телефонного соединения происходит при нажатии курсором на ссылку, представляющую собой название компании, имя вызываемого абонента и т.д. При этом юзеру не требуется вторая телефонная линия или прерывание работы в интернете, необходимо лишь загрузить небольшое клиентское программное обеспечение, которое обычно можно найти на той же web-странице. Web-телефония позволяет представителям компаний отвечать на вопросы, демонстрировать страницы, передавать необходимую информацию, улучшая тем самым качество предоставляемых услуг.

Как видишь, вариантов IP-телефонии довольно много. Каждый из них ориентирован на определенные нужды, а в целом технология связи имеет огромное преимущество перед обычной телефонной АТС.

Устройства телефонной связи

Становится ясно, что при смене стандарта связи меняется и оборудование, обеспечивающее эту самую связь. В настоящее время лидером на рынке систем IP-связи выступает компания Cisco Systems. По ее оборудованию передается почти 92% трафика. Компания предлагает комплексный подход к созданию архитектурных систем с интеграцией голоса, видео и данных Cisco AVVID (Architecture for Voice, Video and Integrated Data), включающих сетевую инфраструктуру, клиентские места, серверные и пользовательские приложения. Поговорим об оборудовании, которое необходимо установить для правильной работы IP-связи.


Спецвыпуск Xakep, номер #034, стр. 034-012-4, Сплетение двух миров

Сплетение двух миров

Докучаев Дмитрий aka Forb

Спецвыпуск Xakep, номер #034, стр. 034-012-4

Маршрутизаторы

Для реализации IP-телефонии вида “Телефон-телефон” и “Телефон-компьютер” необходимо наличие как минимум двух маршрутизаторов. Эти устройства уже несколько лет выпускаются компанией Cisco. Конечно, существуют роутеры и других производителей, но Cisco прижилась на компьютерном рынке и славится своей надежностью и стабильностью. При постоянном совершенствовании софта и технологий, маршрутники падают в цене, поэтому их стоимость на 40% ниже, чем у конкурирующих с этой серией маршрутизаторов других производителей.

Коммутаторы

Коммутатор – специальное устройство, созданное для упрощения перехода от обычной телефонной сети к полностью цифровым устройствам и коммутируемым сетям. В настоящее время на компьютерном рынке лидируют коммутаторы Catalyst от все той же Cisco. Семество Catalyst 5000 используется у многих провайдеров, предоставляющих услуги IP-связи.

IP-телефоны

Как уже было сказано, для IP-телефонии достаточно иметь телефон с тональным набором. Но и тут компания Cisco не преминула выделиться и… предложила свое решение, выпустив специальные IP-телефоны. Эти аппараты, в отличие от обычных, подключаются уже не к оборудованию АТС, а к коммутаторам IP-связи, либо к обычному компьютеру. Разумеется, их устройство отличается от обычных телефонов.

Одним из ключевых достоинств IP-телефона Cisco является возможность осуществлять компрессию голосового трафика непосредственно в аппарате. Эта функция обеспечивает значительное преимущество, если в сеть устанавливаются продукты, совместимые со стандартом H.323. Компрессия, реализованная непосредственно в телефоне, вместе с возможностями оборудования, позволяет гибко настраивать параметры аудиокомпрессии.

Например, если IP-телефон Cisco инициирует вызов абонента, используя стандарт компрессии G.711, вызов может быть помещен на функцию удержания или вообще переведен на другой телефон Cisco. Эта возможность обеспечивает максимальную гибкость и совместимость с функциональностью АТС.

Кроме того, существует программная версия телефона для компьютеров. Софт такого виртуального телефона может быть установлен на обычный или мобильный компьютер, оснащенный звуковой картой и микрофоном.

Развитие IP-телефонии

Теперь, когда ты имеешь довольно полное представление о принципах и стандартах IP-телефонии, пришло время рассказать о ее развитии. Технология никогда не стояла на месте, старые методы заменялись более рациональными и дешевыми. “Эволюция” IP-связи происходила в три этапа. Давай рассмотрим каждый из них.


Спецвыпуск Xakep, номер #034, стр. 034-012-5, Сплетение двух миров

Сплетение двух миров

Докучаев Дмитрий aka Forb

Спецвыпуск Xakep, номер #034, стр. 034-012-5

1. Зарождение

На этом, первичном этапе, телефонией только интересовались. Программисты писали софт, позволяющий передавать голос по сети интернет. Достаточно было знать IP-адрес собеседника и иметь микрофон со звуковой картой. Конечно, качество такой связи оставляло желать лучшего, но начало было положено. На первом этапе был реализован (в примитивном варианте) вид связи “Компьютер-Компьютер”.

2. Развитие

После успешных испытаний на первом этапе, разработчики всерьез заинтересовались IP-телефонией, в которой искали реальную замену дорогостоящей телефонной связи. В итоге был разработан стандарт H.323. Разработчики этих протоколов исходили из того, что две сети (телефонная и IP) будут тесно взаимодействовать друг с другом достаточно длительное время. В стандартах H.323 определяются две группы протоколов - протоколы транспортной плоскости (transport plane), называемой также пользовательской плоскостью (user plane), и протоколы плоскости управления вызовами (call control plane). На этом этапе развития IP-телефонии сеть IP (интернет или частная) широко использовалась в качестве транзитной между двумя местными телефонными сетями. Схема реализации общедоступных услуг IP-телефонии стала популярна во всем мире. Для ее внедрения оператору связи не надо создавать собственную дорогостоящую транспортную инфраструктуру и иметь непосредственный доступ к абонентам. После принятия стандарта H.323 стали применяться такие виды телефонии как “Компьютер-Телефон” и “Телефон-Телефон”. Правда, специального оборудования для последнего варианта пока не хватало.

3. Расцвет

Как уже было сказано, в IP-телефонии активно используется оборудование от производителя Cisco. С момента, когда эта фирма стала производить устройства связи (шлюзы, коммутаторы, телефонные аппараты, программное обеспечение), стали появляться новые стандарты и виды IP-телефонии. Так, например, web-звонки стали возможными совсем недавно, а “продуманные” Ethernet-телефоны появились после успешного внедрения коммутаторов Catalyst.

Развитие этого этапа только начинается. Новая IP-сеть может поддерживать собственных абонентов и служить транзитной сетью для традиционных телефонных сетей с оказанием полного спектра услуг. В узлах IP-телефонии нового поколения произошло четкое разделение функций на три группы - транспортную, управления вызовами и прикладных сервисов. На этом этапе поддерживается весь спектр дополнительных услуг, которые могут предоставлять абонентам развитые телефонные коммутаторы городского типа, в том числе и с помощью интеллектуальной сети: переадресацию вызовов в соответствии с различными условиями, телеголосование, бесплатный звонок, звонок по специальному тарифу, сокращенный набор и т.п.

Сравнение обычной и IP-связи

Как видишь, радужные перспективы IP-телефонии налицо. Сейчас существует множество компаний, которые разрабатывают новые стандарты (интеллектуальной связи) и улучшают текущие. Будем надеяться, что потенциал IP-телефонии, набравший по многим признакам достаточную критическую массу, будет в скором времени реализован, и многочисленные пользователи смогут воспользоваться всеми ее преимуществами.


Спецвыпуск Xakep, номер #034, стр. 034-012-6, Сплетение двух миров

Сплетение двух миров

Докучаев Дмитрий aka Forb

Спецвыпуск Xakep, номер #034, стр. 034-012-6

Связь происходит посредством шлюза, представляющего собой отдельный компьютер, с одной стороны которого находятся телефонные провода, а с другой IP-сеть.

Улучшение кодирования голоса и восстановление потерянных пакетов позволило достичь уровня, когда речь понимается абонентами настолько хорошо, что собеседники не догадываются, что пользуются IP-телефонией.

Используя VoIP, можно обмениваться цифровой информацией для пересылки голосовых или факсимильных сообщений между двумя компьютерами в режиме реального времени.

Звонок с web-сайта может осуществляться простым кликаньем по ссылке на имя вызываемого абонента.

В настоящее время лидером на рынке систем IP-связи выступает компания Cisco Systems. По ее оборудованию передается почти 92% трафика.

Одним из ключевых достоинств IP-телефона Cisco является возможность осуществлять компрессию голосового трафика непосредственно в аппарате.

Программисты писали софт, позволяющий передавать голос по сети интернет. Для разговора достаточно знать IP-адрес собеседника и иметь микрофон со звуковой картой.


Спецвыпуск Xakep, номер #034, стр. 034-016-1, Технология Bluetooth во всех ее проявлениях

Технология Bluetooth во всех ее проявлениях

Елманов Олег (SpyDr@comail.ru)

Спецвыпуск Xakep, номер #034, стр. 034-016-1

О чем и не мечтал герцог Синезубов

Семимильными шагами новый стандарт Bluetooth завоевывает рынок IT. Он позволяет избавиться от вечно запутывающихся проводов и соединить друг с другом абсолютно несовместимую на первый взгляд технику.

Ты, конечно, уже слышал про него, а может, даже и опробовал. Описывать области применения Bluetooth я не буду - его можно применять везде. Для тебя важнее знать, как он работает. В этой статье рассмотрены принципы его работы, спецификации и протоколы.

В 1994 году компания Ericsson сформировала рабочую группу по разработке нового радиоинтерфейса, который позволил бы устанавливать связь между сотовым телефоном и беспроводной гарнитурой, и при этом не был бы дорогим и энергоемким.

Задумка понравилась другим акулам рынка IT, и уже в начале 1998 года компании Nokia, IBM, Toshiba, Intel присоединились к Ericsson. Эти монстры высоких технологий организовали консорциум по разработке беспроводной связи, а потом создали специальную рабочую группу (Special Interest Group - SIG) для разработки, унификации и продвижения технологии Bluetooth на рынок. Позже к этой могучей кучке присоединились и другие фирмы, как большие, так и не очень.

Этот творческий союз оказался плодотворным, и в конце 1999 года было опубликовано первое описание новой технологии. Причем сразу же было объявлено, что созданный вариант стандарта Bluetooth 1.0.B не является окончательным, и финальная спецификация должна выйти только после дополнительных проверок и доработок.

Спустя год после выпуска первого варианта стандарта, группа SIG опубликовала версию 1.1 спецификации Bluetooth. В марте 2002 года Палата стандартов IEEE-SA одобрила новый стандарт беспроводных коммуникаций, получивший обозначение IEEE 802.15.1 и созданный на основе спецификации Bluetooth 1.1.

Жестокая реальность Bluetooth

На сегодняшний день Bluetooth является одной из наиболее перспективных технологий беспроводной передачи данных. Она позволяет соединять между собой практически любые устройства. В основном же технология ориентирована на мобильную связь. Она оптимизирована для передачи по таким соединениям голоса и данных. Благодаря простоте, низкому энергопотреблению и недорогому интерфейсу, Bluetooth идеально подходит для организации персональных сетей (Personal Area Networking - PAN).

Изначально дальность действия радиоинтерфейса закладывалась равной 10 метрам, (т.е. примерно в границах одной комнаты), однако сейчас спецификациями Bluetooth уже определена и вторая зона - около 100 м - для покрытия стандартного дома. При этом нет необходимости в том, чтобы соединяемые устройства находились в зоне прямой видимости друг друга. Их даже могут разделять "радиопрозрачные" препятствия (стены, мебель и т. п.), к тому же взаимодействующие между собой приборы могут находиться в движении.

Для работы радиоинтерфейса Bluetooth используется так называемый нижний (2,45 ГГц) диапазон ISM (Industrial, Scientific, Medical), предназначенный для работы промышленных, научных и медицинских приборов. Особенностью данного диапазона является то, что почти во всех странах мира (включая Россию), он свободен от лицензирования, т.е. для использования сертифицированного передающего оборудования, работающего на этих частотах, не требуется дополнительное разрешение.


Спецвыпуск Xakep, номер #034, стр. 034-016-2, Технология Bluetooth во всех ее проявлениях

Технология Bluetooth во всех ее проявлениях

Елманов Олег (SpyDr@comail.ru)

Спецвыпуск Xakep, номер #034, стр. 034-016-2

Ширина канала для Bluetooth-устройств составляет 723,2 Кбит/с в асинхронном режиме или 433,9 Кбит/с в полностью синхронном режиме. Через Bluetooth-соединение можно также передавать аудиоинформацию - через 3 канала по 64 Кбит/сек каждый, в случае, если не передаются другие данные. Конечно, возможна и комбинированная передача (данные и голос).

В части организации обмена данными, Bluetooth соответствует спецификации стандарта локальных сетей IEEE 802 и использует сигналы с расширением спектра путем скачкообразной перестройки частоты (FHSS) по псевдослучайному закону. Модули Bluetooth работают тактами длительностью 625 мкс. Каждому модулю в пределах каждого такта назначается соответствующий частотный канал и режим передачи или приема. Таким образом, базовая частота может изменяться, принимая одно из 79 значений с интервалом 1 МГц, начиная от 2,400 ГГц и заканчивая 2,480 ГГц. Скорость перехода с одной частоты на другую может достигать 1600 Гц.

Выбор подобного режима работы радиоканала позволяет решить сразу несколько проблем, и прежде всего это относится к взаимным помехам с другими устройствами. Дело в том, что в данном диапазоне частот уже функционирует большое количество самых различных промышленных, медицинских и бытовых устройств, включая микроволновые печи, автомобильные сигнализации и т.п. Так как использование всех этих устройств разрешено на безлицензионной основе, а значит и без выполнения соответствующего частотного и территориального планирования их размещения, то выбор любой фиксированной частоты неизбежно рано или поздно приводил бы к "частотному конфликту" с другими устройствами и невозможности работы из-за взаимных радиопомех. Использование же метода быстрой смены частот приводит к тому, что поражение отдельных частот помехами будет приводить к потерям только небольших фрагментов данных, которые могут быть легко восстановлены путем применения помехозащищенного кодирования. Кроме этого, смена частот по псевдослучайному закону снижает влияние интерференционных замираний сигналов за счет переотражений от окружающих предметов, а также затрудняет перехват передаваемой информации.

Установление соединения

Одной из важнейших особенностей Bluetooth является автоматическая установка соединения между двумя находящимися в пределах досягаемости Bluetooth-устройствами. Весь процесс поиска и соединения очень прост. Первоначально все Bluetooth-устройства находятся в режиме Standby, в котором они каждые 1,28 с. прослушивают 32 фиксированные частоты. Устройство, оказавшись в незнакомом окружении, начинает посылать запросы на этих частотах.

При приеме запроса Bluetooth-устройство реагирует на него в соответствии с режимом, в котором оно находится. В режиме отклика (discoverable mode) устройство всегда отвечает на все полученные запросы. Режим ограниченного отклика (limited discoverable mode) подразумевает, что устройство может отвечать на запросы только ограниченное время или при других определенных условиях. Третий режим, отказа в отклике (non-discoverable mode), запрещает устройству отвечать на запрос.


Спецвыпуск Xakep, номер #034, стр. 034-016-3, Технология Bluetooth во всех ее проявлениях

Технология Bluetooth во всех ее проявлениях

Елманов Олег (SpyDr@comail.ru)

Спецвыпуск Xakep, номер #034, стр. 034-016-3

Кроме того, при подключении устройство может быть подключаемым (connectable mode) или недоступным (non-connectable mode). Во втором случае устройство не позволяет настроить ряд параметров соединения и обмениваться данными.

Ну вот, два Bluetooth-устройства нашли друг друга, все устраивает, и discoverable они, и с connectable у них все в порядке. Дальше-то что?

А дальше они начинают договариваться. Об используемом диапазоне частот, размере страниц, количестве и порядке смены частот (hopping channel) и других физических параметрах соединения.

Каждое Bluetooth-устройство имеет глобальный уникальный адрес (как MAC-адреса у сетевых плат), но на уровне пользователя обычно используется имя устройства, которое может быть любым и не быть уникальным. Имя может быть длиной до 248 байт и использовать кодовую страницу в соответствии с Unicode UTF-8.

Так вот, если процесс авторизации прошел успешно, то новое Bluetooth-устройство получает набор адресов доступных устройств, и за этим следует процесс выяснения всех доступных Bluetooth-устройств из этого списка.

Еще одной интересной и важной особенностью Bluetooth является автоматическое подключение устройств к службам, предоставляемым другими Bluetooth-устройствами. Поэтому после получения списка имен и адресов устройство выполняет поиск доступных услуг (service discovery). По большому счету, предоставление и получение каких-либо услуг - это то, ради чего все собственно и затевалось. Для поиска всевозможных услуг используется, соответственно, протокол поиска услуг (service discovery protocol), но об этом чуть позже.

Bluetooth-устройства могут устанавливать соединения не только типа точка-точка, но, что и является основным, многоточечные соединения. При этом они объединяются в пикосети (piconet). Процедура соединения инициируется одним, причем любым, из устройств, которое и становится главным (master) в пикосети. При этом в одной пикосети может быть не более семи ведомых (slave) устройств. Кроме активных устройств, осуществляющих обмен в пикосети, могут быть неактивные Bluetooth-устройства, которые не могут обмениваться данными с главным устройством пикосети, но синхронизированы с ним. В одной пикосети может быть всего одно ведущее устройство, однако любое из ведомых устройств в данной пикосети может являться ведущим в другой и образовывать свою пикосеть. Объединенные таким образом Bluetooth-устройства образуют распределенную сеть (scatternet). В рамках распределенной сети Bluetooth-устройства могут образовывать любые логические цепочки любого размера.

Благодаря применению радиоканала со скачками частоты, пикосети могут взаимодействовать друг с другом с минимальным риском взаимных помех. Единственным условием здесь является то, что разные пикосети одной распределенной сети должны иметь различный порядок смены каналов (hopping sequence). Настоящий вариант спецификации стандарта предусматривает 10 вариантов смены каналов - 5 с циклом 79 смен частот и 5 - с циклом в 23 смены.


Спецвыпуск Xakep, номер #034, стр. 034-016-4, Технология Bluetooth во всех ее проявлениях

Технология Bluetooth во всех ее проявлениях

Елманов Олег (SpyDr@comail.ru)

Спецвыпуск Xakep, номер #034, стр. 034-016-4

Протоколы Bluetooth

При работе устройства Bluetooth используют как специфические протоколы, так и общие, используемые в телекоммуникационных системах. Все они образуют стек протоколов. Стек протоколов Bluetooth можно разделить на 4 слоя:

- базовые протоколы (core protocols) - Baseband, LMP, L2CAP, SDP;

- протокол замены кабеля - RFCOMM;

- протокол управления телефонией - TSC binary, AT-команды;

- воспринятые протоколы (adopted protocol) - PPP, UDP/TCP/IP, OBEX, WAP, BNEP, vCARD, vCAL, IrMC, WAE.

Базовые протоколы обеспечивают физическую связь, а остальные слои ориентированы на приложения.

Основой стека служит базовая полоса (baseband) и уровень управления подключениями (Link Control Layer), которые и обеспечивают физическую радиочастотную связь между Bluetooth-устройствами. Так как технология Bluetooth является системой перестраивающейся частоты, этот уровень использует процедуры опроса для синхронизации устройств. При связи между устройствами Bluetooth на физическом уровне данные разбиваются на стандартные пакеты.

Стандартный пакет Bluetooth содержит три основных элемента. Сначала идет код доступа (72 бита), затем - заголовок (54 бита), а потом сами данные, которые могут быть до 2745 бит. В пакете необходимым является только код доступа, который используется для идентификации пакетов одной пикосети и синхронизации, остальные элементы могут отсутствовать. Код доступа состоит из идентификатора (4 бита), слова синхронизации (64 бита) и трейлера (4 бита).

* AM_ADDR - адрес активного элемента;

* TYPE - код типа данных;

* FLOW - бит управления потоком данных;

* ARQN - бит подтверждения правильного приема;

* SEQN - бит контроля корректной последовательности передачи пакетов;

* HEC - контрольная сумма.

Протокол диспетчера подключений

Протокол диспетчера подключений (LMP - Link Manager Protocol) отвечает за установление подключений между устройствами Bluetooth, контролирует режимы питания и исполнительные циклы устройств, состояние подключения того или иного прибора к пикосети. LMP имеет более высокий приоритет по сравнению с остальными протоколами, поэтому при любой необходимости передачи LMP сообщения канал освобождается. Кроме того, протокол диспетчера подключений отвечает за безопасность подключений.

Безопасность

Защита данных в Bluetooth организована за счет применения аутентификации устройств и шифрования передаваемых данных. Аутентификация базируется на алгоритме запрос-ответ, а для шифрования информации могут использоваться секретные ключи длиной до 128 разрядов. В зависимости от выполняемых задач, устройство может находиться в одном из трех режимов защиты:

- минимальная - данные кодируются общим ключом и могут приниматься любыми устройствами без ограничений;

- защита на уровне устройств - непосредственно в чипе прописывается уровень доступа, в соответствии с которым устройство может получать определенные данные от других устройств;


Спецвыпуск Xakep, номер #034, стр. 034-016-5, Технология Bluetooth во всех ее проявлениях

Технология Bluetooth во всех ее проявлениях

Елманов Олег (SpyDr@comail.ru)

Спецвыпуск Xakep, номер #034, стр. 034-016-5

- защита на уровне сеанса связи - данные кодируются 128-битными случайными числами, хранящимися в каждой паре устройств, участвующих в конкретном сеансе связи.

Второй и третий режимы могут использоваться и одновременно.

В основе системы безопасности Bluetooth, используемой в последнем случае, лежит понятие сеансового ключа, который образуется в процессе соединения двух устройств и используется для идентификации и шифрования передаваемых данных. Для генерации ключа могут использоваться самые различные составляющие, от заранее известных обоим устройствам значений до физических адресов устройств. Комбинируя защиту на уровне соединения с защитой на уровне приложений, можно создавать достаточно надежно защищенные соединения.

Протокол L2CAP

Протокол управления логическим подключением и адаптацией (L2CAP - Logical Link Control and Adaptation Protocol) - связующее звено между протоколами верхнего уровня и базовой полосой. L2CAP является базовым протоколом передачи данных для Bluetooth и работает только с асинхронными соединениями. Для многих протоколов и служб более высокого уровня L2CAP является транспортным протоколом. L2CAP достаточно простой протокол, который предъявляет минимум требований к вычислительным мощностям и размеру оперативной памяти устройств, которые его используют. Основные особенности, которые реализуют L2CAP, таковы:

1. Protocol Multiplexing. L2CAP является транспортом для многих протоколов и служб, поэтому он обеспечивает возможность определения принадлежности того или иного пакета с данными заданному протоколу службы.

2. Segmentation and Reassembly. Максимальная длина пакета для L2CAP - 64 килобайта. Однако очень часто требуется передать большие пакеты данных, поэтому L2CAP обеспечивает разбивку большого пакета на несколько более мелких и последующую сборку первоначального пакета в устройстве-получателе.

3. Quality of Service(QoS). Благодаря L2CAP Bluetooth-устройства могут отслеживать свободные ресурсы соединения и не позволять, чтобы ширина канала или временные задержки для отслеживаемой службы опускались ниже определенных критических значений.

4. Groups. L2CAP поддерживает адресацию не только одному клиенту, а сразу целой группе клиентов в пикосети.

Протокол обнаружения услуг (Service Discovery Protocol - SDP)

Обнаружение услуг (Service Discovery) является критической частью всей схемы Bluetooth. В настоящее время никто не сможет представить все возможные способы использования Bluetooth-устройств, поэтому при разработке SDP протокола пытались учесть как можно больше возможных ситуаций. Таким образом, используя протокол SDP, можно запросить информацию о самом устройстве, его услугах и о характеристиках этих услуг, а также о доступных устройствах в пикосети, их службах.

Протокол RFCOMM

Этот протокол эмулирует соединение точка-точка по COM-порту, используя L2CAP в качестве транспортного. Это качество и определяет его широкие возможности - от эмуляции Direct Cable Connection до полноценного входа в локальную сеть. В этом случае необходим прибор под названием LAN Access point, через который компьютер с Bluetooth оказывается подключенным к LAN так, как если бы он был подключен через диалап. Эта служба называется LAN Access.


Спецвыпуск Xakep, номер #034, стр. 034-016-6, Технология Bluetooth во всех ее проявлениях

Технология Bluetooth во всех ее проявлениях

Елманов Олег (SpyDr@comail.ru)

Спецвыпуск Xakep, номер #034, стр. 034-016-6

TCS - Telephony Control protocol Specification. Это чудо используется для переадресации звонков на телефонных станциях (в качестве транспортного он тоже эксплуатирует L2CAP). Причем сам TCS используется только для установки соединения, после чего управление передается Bluetooth voice, и сама речь уже передается с его помощью.

Bluetooth audio

Bluetooth audio (Voice) - одна из служб Bluetooth, которая использует синхронное соединение. Характеристики звуковых потоков могут различаться, и во многом определяются используемым приложением. Максимально звуковой поток может передаваться с точностью в 16 бит с частотой 48 кГц (для версии Bluetooth 1.0). В версии Bluetooth 1.1 добавлен протокол AVCTP-Audio/Video Transport Protocol, который позволяет передавать не только аудио, но и видеоданные.

Поддержка общеизвестных сетевых протоколов PPP, TCP/UDP/IP/OBEX

В технологии Bluetooth протокол PPP (point-to point protocol) работает "поверх" RFCOMM (как ранее упоминалось, этот протокол служит "переходником " между базовыми протоколами Bluetooth и протоколами служб, "заимствованными протоколами", такими как PPP). Соединения PPP служат средством, позволяющим перемещать IP-пакеты с уровня РРР на уровень локальных сетей.

В настоящее время семейство протоколов TCP/IP используется наиболее широко во всем мире. Стеки TCP/IP установлены на самых разных устройствах. Встраивание этих стандартов в приборы Bluetooth позволяет осуществлять связь с любым другим устройством, подключенным к интернету. Такое устройство Bluetooth, будь то гарнитура для сотового телефона или точка доступа к данным, используется затем как "мостик" к инету. TCP/IP/PPP используется во всех сценариях спецификации Bluetooth 1.0/1.1 как мостик к среде Internet, а также как транспортный механизм для протокола WAP.

Протокол IrOBEX (Infrared Objet Exchange Protocol) или, проще, OBEX, является сеансовым протоколом, разработанным ассоциацией IrDA для простого, поэтапного обмена объектами. OBEX обеспечивает функциональность, сходную с НТТР. Протокол использует клиент-серверную модель и не зависит ни от транспортного механизма, ни от транспортного API-интерфейса. На первом этапе протокол RFCOMM использовался как единственный транспортный слой для IrОВЕХ. В настоящее время OBEX поддерживает в качестве транспортного протокола не только RFCOMM, но также и TCP/IP.

Посредством протокола OBEX передаются такие форматы данных как vCard (обмен электронными деловыми карточками) и vCalendar (обмен электронными календарными данными),а также vMessage и vNote.

Модели использования

Использование Bluetooth облегчается разработкой моделей использования. Каждая модель использования сопровождается ее "профилем". Профиль определяет протоколы и их специальные свойства, поддерживающие данную модель использования.


Спецвыпуск Xakep, номер #034, стр. 034-016-7, Технология Bluetooth во всех ее проявлениях

Технология Bluetooth во всех ее проявлениях

Елманов Олег (SpyDr@comail.ru)

Спецвыпуск Xakep, номер #034, стр. 034-016-7

Наиболее распространенными являются четыре профиля "общего назначения", которые широко используются как сами, так и для организации других профилей. К ним относятся:

* GAP - типовой профиль доступа;

* SPP - профиль последовательного порта;

* SDAP - профиль обнаружения прикладных услуг;

* GOEP - профиль общего назначения для обмена объектами.

Таким образом, нижние уровни протокольного стека Bluetooth спроектированы так, чтобы обеспечить гибкую основу для дальнейшей разработки протоколов. Другие протоколы, такие как RFCOMM, получены адаптацией существующих протоколов, которые лишь слегка модифицируются для этих целей. Протоколы верхнего уровня используются без модификации. Благодаря такому подходу существующие прикладные задачи могут использоваться для работы с технологией Bluetooth с минимальными усилиями со стороны разработчиков.

На сегодняшний день Bluetooth - современная технология беспроводной передачи данных, позволяющая соединять друг с другом практически любые устройства.

Первоначально все Bluetooth-устройства находятся в режиме Standby, в котором они каждые 1,28 с. прослушивают 32 фиксированные частоты.

Ширина канала для Bluetooth-устройств составляет 723,2 Кбит/с в асинхронном режиме.

Для шифрования информации могут использоваться секретные ключи длиной до 128 разрядов.

Благодаря применению радиоканала со скачками частоты, пикосети могут взаимодействовать друг с другом с минимальным риском взаимных помех.

Благодаря L2CAP Bluetooth-устройства могут отслеживать свободные ресурсы соединения и не позволять, чтобы ширина канала или временные задержки для отслеживаемой службы опускались ниже определенных критических значений.

Обнаружение услуг (Service Discovery) является критической частью всей схемы Bluetooth.


Спецвыпуск Xakep, номер #034, стр. 034-022-1, Мобильное общение без границ!

Мобильное общение без границ!

Фленов Михаил

Спецвыпуск Xakep, номер #034, стр. 034-022-1

Публичное вскрытие SMS и MMS технологий

smirnandr@mail.ru http://www.cydsoft.com/vr-online

Помнишь времена нашей молодости, когда мы снимали трубку телефона и кричали в нее: «Барышня, Барышня, мне нужен Смольный. Смольный? Мне нужна барышня». Это была коммутируемая связь. Со временем коммутация стала автоматической, и уже не надо объяснять барышне, с кем ты хочешь поговорить. После появления коммутации в обход женского пола, технологии телефонии практически не развивались. Вернее, развитие шло, но далеко от нас с тобой. Я могу отметить только два сервиса, которые могут быть полезны простому стационарному телефону - автоответчик и определитель номера. И это все, что нам предложили операторы традиционной телефонии за сотню лет.

То ли дело сотовая связь. Тут ребята явно продвинутые, и мозги у них направлены в нужную сторону. Практически каждый год мы получаем что-то новое и действительно полезное, а простой мобильник постепенно превращается в ультранавороченный мини-компьютер. Сотовые трубки постепенно всасывают в себя все, что хорошо или плохо лежит.

Общайся коротко и ясно

Еще несколько лет назад иметь пейджер было престижно. Но время не стоит на месте, и сейчас иметь такой виброприбор на поясе - удел сантехников-водопроводчиков и прочих специалистов, нуждающихся в односторонней и дешевой связи. Обычному же человеку пейджер стал не нужен, хотя идея передавать не звук, а короткие сообщения никуда не исчезла. Со временем она вылилась в объединение совершенно разных устройств – телефона для речевого общения и пейджера для передачи текста.

Пейджер в телефоне назвали SMS (Short Message Service) – сервис коротких сообщений. Я думаю, что не открою Америку, если скажу, что это сервис, который позволяет отправлять и принимать текстовые сообщения с помощью мобильного телефона. Самое главное его преимущество - возможность отправки, чего пейджер делать не мог и из-за этого умер.

Как происходит передача сообщения в сотовом телефоне? В мобилу записывается номер сервисного центра SMS-сообщений SMSC (Short Message Service Centre). Пользователь набирает текст (не более 160 символов) и нажимает кнопку «Отправить». Сообщение отсылается на номер сервисного центра. Этот центр выступает в качестве коммутатора, который пересылает сообщение дальше (другому оператору сотовой связи).

Получив SMS, сервисный центр проверяет, находится ли пользователь в его сети. Если нет, то происходит пересылка текста другому оператору. Если да, то происходит еще одна проверка - подключен ли сейчас адресат к сети. Если телефон включен и доступен, то сообщение отсылается на телефон, иначе сохраняется в базе данных.

Недоставленное сообщение может храниться до тех пор, пока оно не будет доставлено, или пока не истечет срок хранения (а вдруг пользователь больше никогда не подключится, или, может, он сменил номер?). Срок хранения задается отправителем или действует значение по умолчанию сервисного центра.

Для передачи сообщения используется сигнальный канал, поэтому сообщение SMS может отправляться прямо во время разговора, при этом никак не влияя на речь и передаваемую служебную информацию.


Спецвыпуск Xakep, номер #034, стр. 034-022-2, Мобильное общение без границ!

Мобильное общение без границ!

Фленов Михаил

Спецвыпуск Xakep, номер #034, стр. 034-022-2

Было или не было

При передаче SMS-сообщения твой телефон может получать подтверждение, было ли доставлено сообщение адресату. Это очень важно, потому что получатель может быть долгое время отключен от сети, а ты будешь думать, что он уже прочитал твою мессагу. Представляешь, что получится, если ты пригласишь по SMS свою подругу в ресторан, а она не придет только потому, что у нее закончились деньги, и она не смогла узнать о твоем приглашении? Именно поэтому система подтверждения необходима и незаменима.

Правда, слишком надеяться на эту систему не надо, особенно если ты не уверен в своем поставщике. Разные производители делают систему подтверждения по-разному, поэтому если у тебя с твоей подругой телефоны разных производителей, то не факт, что ты получишь это самое подтверждение.

Ты мог все так же пригласить ее в ресторан и... сам не прийти только потому, что не получил ответ и подумал, что она не читала твое сообщение. А может, и читала, просто твой телефон не смог распознать подтверждение. Вот именно из-за таких ситуаций я теперь не доверяю даже полноценным сообщениям о состоянии передаваемой мессаги (их передает, например, МТС) :).

SMS+GSM=любовь

Отправка и прием SMS-сообщений есть уже практически во всех стандартах сотовой связи. Но так уж получилось, что сейчас у нас самым распространенным является стандарт GSM, который расползся по всему миру. В этом стандарте заложено два вида передаваемых сообщений – индивидуальные и вещание.

При индивидуальной передаче сообщения по схеме точка-точка (знакомое нам понятие Point-to-Point), мессага отправляется от отправителя центру сообщений, а он уже отправляет текст получателю (именно этот метод я рассмотрел выше). Тем же способом операторы связи могут отправлять сообщения на твою мобилу, и передача будет происходить от адресата к получателю.

При широковещательной передаче SMS, центр сообщений может отправлять всем своим клиентам или определенной группе одно сообщение (например, сводка погоды, курс доллара и т.д.). Такое сообщение формируется в центре широковещательных SMS (Cell Broadcast Short Message Service). Оно отправляется множеству клиентов и не требует подтверждения получения. Именно поэтому такие сообщение подаются непосредственно на контроллер приемо-передающей станции, минуя центр сообщений. Вещательные SMS передаются по одному из служебных каналов общего пользования – Broadcast Control Channel.

Вещательные пакеты не сохраняются в базе и не дожидаются, пока ты подключишься к сети, если в момент вещания тебя не было на связи. Это связано с тем, что вещание происходит, минуя центр сообщений, и сообщения сразу бросаются в эфир. Зато такие пакеты могут содержать до 16 страниц текста по 80 символов в каждой, что составляет 1280 символов. Все эти страницы имеют признаки принадлежности к какому-либо SMS-сообщению и порядковые номера, поэтому телефоны могут игнорировать повторно принятые сообщения и выстраивать из разделенных данных целый текст.


Спецвыпуск Xakep, номер #034, стр. 034-022-3, Мобильное общение без границ!

Мобильное общение без границ!

Фленов Михаил

Спецвыпуск Xakep, номер #034, стр. 034-022-3

Формат пакета

Честно признаюсь, когда я говорил о 160 символах текста для передачи индивидуального SMS-сообщения, я имел в виду размер пакета. Сам текст не сможет превысить 140 байт при использовании полного заголовка SMS’ки. Как и любой сетевой пакет, пакет сообщения должен иметь свой заголовок, в котором, как минимум, будет отображаться информация об отправителе и получателе. Центр сообщений должен знать, кому отправляется пакет, и эту информацию он берет из заголовка. Вот формат стандартного SMS-сообщения:

1. 1 байт - содержит тип сообщения.

2. 7 байт - время отправки, которое устанавливается центром сообщений и имеет формат YYMMDDHHMMSSZZ.

3. до 12 байт - адрес отправителя.

4. 1 байт - идентификатора протокола.

5. 1 байт - схема кодирования данных.

6. 1 байт - длина данных.

7. до 140 байт - сообщение.

И эти ограничения действуют, только если ты собираешься отправлять сообщения латиницей. Если тебе захочется написать что-то понятным русским языком (кириллицей), то количество символов уменьшится до 70 (это из-за кодировки Unicode, в которой один символ "весит" 2 байта, против одного в стандартной кодировке - прим. ред.).

В принципе, передавать можно и больше данных, проблема только в том, что память телефонов ограничена, и дешевые модели смогут хранить в среднем по 4 полных сообщения. Если память будет переполнена, ты не сможешь получать новые мессаги, и придется удалять уже прочитанное. На практике большинство SMS’ок не превышают 30 символов, потому что устраивать дебаты с помощью текстовых сообщений неудобно - один набор чего стоит! Так что тебе даже 70 символов в кириллической кодировке будет достаточно.

Безопасность

Для обеспечения безопасности при передаче данных в стандарте GSM используются встроенные средства криптографической защиты, которые обеспечивают защиту канала и аутентификацию сообщений. При аутентификации используется SIM-карта телефона, в которой содержатся уникальные для шифрования данные.

Благодаря встроенной криптографии, некоторые банки предоставляют своим клиентам возможность работы со счетом по SMS. Это довольно смелое решение, потому что я лично знаю людей, которые без проблем снимают PIN-коды с телефонов. Нетрудно догадаться, какие изменения могут произойти с банковским счетом владельца потерянного и попавшего в руки таких мастеров мобильника.

Расширенный текстовый сервис

Не прошло и года с того момента, как SMS завоевала широкую популярность, а производители оборудования и операторы связи обратили внимание на возможность пакетной передачи данных в стандарте GSM. Операторы задумались, а почему бы вместе с текстом не передавать изображения? Действительно, а почему бы и нет. Тут же создали новый сервис и назвали его EMS - Enhanced Messaging Service (расширенный сервис сообщений). В этот сервис вложили возможность передачи не только текста, но и простых мультимедийных вставок.

Сервис EMS нам преподнес:

1. Форматирование текста сообщений. Теперь текст может содержать символы, выделенные жирным и наклонным шрифтом, шрифтом большего размера, а также символ перехода на новую строку.


Спецвыпуск Xakep, номер #034, стр. 034-022-4, Мобильное общение без границ!

Мобильное общение без границ!

Фленов Михаил

Спецвыпуск Xakep, номер #034, стр. 034-022-4

2. Отсутствие ограничения по количеству символов (насколько я знаю, ограничение есть - 760 в стандартной латинской кодировке, 360 - "наш" Unicode - прим. ред.).

3. Сообщения с изображениями и анимацией (черно-белые, четырехцветные или 64-цветные) размером до 255х255, звуками, в том числе с предопределенными - прописанными в телефоны.

4. Поддержку форматов vCard и vCalendar: они позволяют передавать контакты и данные календаря или записной книжки.

Работа EMS построена по такому же принципу, что и SMS, поэтому нет смысла снова описывать процесс передачи сообщения.

Мультимедийный сервис

Но не успел новый сервис получить распространение, как производители почувствовали, что через год или два его будет недостаточно, и придется изобретать что-то новое. А что тянуть, сказал дядька с толстым кошельком и вложил деньги в новый сервис - MMS - Multimedia Messaging Service (сервис мультимедиа сообщений). Новинка практически не ограничена в возможностях, и может передавать изображения, звук, текст, презентации и многое другое в одном флаконе. Все это может передаваться между телефонами, с компа на трубу, с телефона на e-mail ящик.

Работа MMS построена таким же образом, как и SMS, потому что использует ту же основу – пакетную передачу данных. Разница только в содержимом сообщения, потому что теперь внутри пакета может быть не только текст, но и любые мультимедиа-данные.

В число особых прелестей MMS входят:

1. Передача изображений высокого разрешения.

2. Автоматическое конвертирование изображений, в зависимости от модели телефона получателя сообщения.

3. Получение и отправка сообщений на и с e-mail.

Для определения места, куда отправить сообщение, MMS Relay/Server использует Home Location Register. Сейчас MMS использует только WAP-соединения мобильных устройств с сервером. Но в будущем планируется расширить количество протоколов.

Отправка MMS происходит следующим образом:

1. Сначала MMS-центр посылает шлюзу уведомление, которое содержит информацию о сообщении, его отправителе и размере.

2. Шлюз-посредник отправляет короткое сообщение на мобильный телефон, сообщая о доставленной мессаге. Твоя трубка считывает эту информацию и оповещает тебя.

3. Когда ты захочешь прочитать сообщение, телефон соединится с MMS-центром по WAP, и ты сможешь увидеть то, что тебе прислали.

Единственный недостаток всей этой технологии – дороговизна реализации. Пока только дорогие и элитные мобильники имеют возможность работы с мультимедиа-информацией. Как только все это дело подешевеет, сразу можно будет говорить о постепенном замещении стандартных сообщений SMS продвинутыми мультимедийными MMS.

В принципе, уже сейчас есть возможность купить мобилу с MMS-поддержкой, но если в телефоне, на который ты отправишь сообщение, не будет поддержки MMS, то получателю будет доступен только текст, а графику он не увидит.

Перспективы

А что же дальше? Уже сейчас в телефоны встраивают FM-радио и, я думаю, что скоро в твоей трубе будет даже телевизор. Мобильники поражают своими возможностями (посмотри хотя бы на SonyEricsson P800), только они очень дороги. Правда, по законам экономики, все со временем дешевеет, если народные массы принимают новинку и активно пользуются предложенными сервисами.


Спецвыпуск Xakep, номер #034, стр. 034-022-5, Мобильное общение без границ!

Мобильное общение без границ!

Фленов Михаил

Спецвыпуск Xakep, номер #034, стр. 034-022-5

Неожиданные роды SMS

Первое SMS-сообщение с мобильника было отправлено 3 декабря 1992 года, и в качестве тестового полигона использовалась Великобритания. Так как был декабрь, то и текст сообщения был незамысловат: «MERRY CHRISTMAS». Отправителем был инженер Neil Papworth (Нейл Пэпуорс), а получателем – его коллега в Vodafone.

При разработке GSM, в стандарт была заложена возможность передачи отдельным пользователям пакетов данных. Несмотря на это, производители оборудования и операторы не знали, что делать с такой возможностью, зачем она нужна, и как вытащить из нее прибыль. Именно поэтому с 1992 по 2000 год развитие SMS шло очень медленно. Просто никто не вкладывал деньги в развитие и рекламу этого сервиса. Почему-то операторы считали, что реальный разговор с человеком лучше и удобнее. Возможно, тут сыграл роль фактор страха уменьшение прибыли: а вдруг пользователи предпочтут SMS традиционному общению. Сейчас уже трудно сказать, что именно тормозило развитие SMS.

Несмотря на отсутствие рекламы, простой народ потихоньку осваивал SMS, хотя сообщения можно было передавать только внутри одной сети, а передача между сетями была невозможна. Только в 2000 году мы смогли передавать сообщения между операторами, и сейчас я без проблем переписываюсь со своим другом, который работает в Турции. Такое общение мне обходится дешевле, чем разговор по телефону, и быстрее, чем почта (интернета у него нет).

Осторожно - вирус!!!

Совсем недавно по Сети пролетел очередной червь I-Worm.Timofonica, который был написан на уже привычном VBScript и рассылал себя по всем адресам адресбука. Помимо этого, копия каждого сообщения отправлялась на SMS-шлюз испанской сотовой сети MoviStar.

На этом приколы над SMS не закончились. В 1998 году всем британцам (точнее абонентам двух крупнейших сетей Великобритании) пришло сообщение о том, что они выиграли автомобиль, и указывался телефон, по которому надо было позвонить для получения приза. Ничего не подозревающий народ несколько дней терроризировал ни в чем не повинную текстильную фабрику. Шутника, который отправил это сообщение, смогли поймать только через год.

Ссылки по теме

http://www.ecma-international.org/publications/standards/ecma-325.htm - стандарт, определяющий протокол для поддержки SMS. Здесь ты сможешь скачать 100 страниц текста в PDF'е, чтобы ознакомится с технической стороной SMS.

http://www.vitez.it/products/sms.pdf - документ, описывающий работу программы SMS-центра Qnet SMS Center.

http://www.mport.ru/ - новинки мобильного рынка, описание новейших телефонов и их рейтинги.

Сообщение отсылается на номер сервисного центра. Этот центр выступает в качестве коммутатора, который пересылает сообщения дальше (другому оператору сотовой связи)

Разные производители делают систему подтверждения по-разному, поэтому если у тебя с твоей подругой телефоны разных производителей, то не факт, что ты получишь это самое подтверждение


Спецвыпуск Xakep, номер #034, стр. 034-022-6, Мобильное общение без границ!

Мобильное общение без границ!

Фленов Михаил

Спецвыпуск Xakep, номер #034, стр. 034-022-6

Если тебе захочется написать что-то понятным русским языком (кириллицей), длина сообщения уменьшится до 70 символов

Новинка практически не ограничена в возможностях, и может передавать изображения, звук, текст, презентации и многое другое в одном флаконе


Спецвыпуск Xakep, номер #034, стр. 034-026-1, ТРИ В ОДНОМ: КАРТА, КОМПАС И ЧАСЫ

ТРИ В ОДНОМ: КАРТА, КОМПАС И ЧАСЫ

Елманов Олег (SpyDr@comail.ru)

Спецвыпуск Xakep, номер #034, стр. 034-026-1

Система спутниковой навигации GPS

Если еще лет десять назад невозможно было представить себе поход без карты и компаса, то сейчас достаточно одного GPS-приемника. GPS-приемник используется в качестве компаса, электронной карты, умеет запоминать маршрут, вычислять скорость движения, пройденный километраж и много других полезных вещей.

РАЗВИТИЕ НАВИГАЦИОННЫХ СИСТЕМ

Если ты думаешь, что спутниковые навигационные системы пришли с развитием персоналок и КПК, то заблуждаешься. К созданию систем спутниковой навигации Советский Союз и США приступили в 1960-х годах, после запуска первого спутника. Первые радионавигационные системы: "Циклон" (6 спутников, введена в эксплуатацию в 1976 году), "Цикада" (4 спутника, 1979 год) и NNSS (Navy Navigation Satellite System), позже названная "Transit" (6 спутников, 1974 год). Они позволили с большой точностью определять координаты судов и решать различные военные задачи. Спутниковая навигация оказалась широко востребованной в оборонке и промышленности. Вслед за успехами первых навигационных систем в середине 1970-х годов стали разрабатываться системы нового поколения. В них были воплощены самые передовые технологии. Сходство задач и технических решений обусловили большую похожесть этих систем. В эксплуатацию они были введены в 1993 году (ГЛОНАСС) и в 1994 году (NAVSTAR, GPS).

GLOBAL POSITION SYSTEM

Самая известная и распространенная в мире спутниковая навигационная система - американская NAVSTAR (NAVigational Satellite providing Time and Range, навигационная система определения времени и дальности), позже получившая свое второе, коммерческое название - Global Position System (глобальная система позиционирования), сокращенно GPS.

Разработка и создание GPS велось министерством обороны США. Основные задачи новой навигационной системы - скорость и точность определения военными своих координат в любой точке мира. GPS предназначалась не только для военных нужд, поэтому разработчики системы создали два канала измерения - стандартной (Standart Position System - SPS) и высокой (Precise Position System - PPS) точности. Типовая погрешность определения координат в канале SPS изначально составляла около 100 м в любой точке Земной поверхности. Именно этот канал измерений и был в 1983 году разрешен для свободного (и бесплатного) использования. Вообще-то, достигаемая точность измерений в этом канале была несколько выше. Но для устранения этого "просчета" при создании системы, после первых ее испытаний, разработчиками был предусмотрен ввод специальных ошибок (названный "режимом селективного доступа" - Selective Availability, S/A) в сигналы ИСЗ для исключения возможности слишком точного определения координат. Сделано это было по политическим мотивам, но с 1 мая 2000 года этот режим был отменен, и в итоге точность измерений возросла вдвое.

Во время последней иракской кампании американцы обеспечили повышенную точность GPS-позиционирования. Повышения точности удалось добиться путем постоянного контроля над спутниками, отвечающими за ближневосточный регион. Усилиями Второй космической эскадрильи ВВС США, расквартированной на авиабазе Шривер в штате Колорадо, точность GPS-систем в районе Багдада достигала 2,66 м.


Спецвыпуск Xakep, номер #034, стр. 034-026-2, ТРИ В ОДНОМ: КАРТА, КОМПАС И ЧАСЫ

ТРИ В ОДНОМ: КАРТА, КОМПАС И ЧАСЫ

Елманов Олег (SpyDr@comail.ru)

Спецвыпуск Xakep, номер #034, стр. 034-026-2

Другим усовершенствованием системы GPS в военных целях стали новые антенны, невосприимчивые к сигналам "глушилок". Хотя в последней войне и не было отмечено случаев радиоподавления, военные занялись этим вопросом. Новые антенны, разрабатываемые в компании Aerospace, будут использовать адаптивные алгоритмы для выделения GPS-сигналов из шума "глушилок".

В канале PPS обеспечивается точность определения координат на порядок выше, чем в SPS, однако этот канал используется только по основному назначению системы и закрыт для доступа сторонних потребителей.

Космический сегмент системы GPS включает 24 специальных ИСЗ, равномерно размещенных на шести круговых орбитах высотой около 20000 км с наклонением их плоскостей относительно экватора 55 градусов и периодом обращения 12 часов. Такое размещение спутников дает возможность одновременного наблюдения в любой точке поверхности Земли от 4 до 8 ИСЗ системы. Координаты каждого спутника заранее вычисляются в наземном центре управления системой и передаются потребителям в цифровой форме (так называемый "альманах системы") вместе со специальными измерительными сигналами, излучаемыми на двух частотах: 1227,6 МГц и 1575,42 МГц.

ГЛОНАСС

Расшифровывается как ГЛОбальная НАвигационная Спутниковая Система. Разработка ГЛОНАСС велась с 1976 году, а в сентябре 1993 года система была официально принята в эксплуатацию. Проектирование велось по заказу Министерства обороны, но в марте 1995 года специальным постановлением правительства России система была открыта и для гражданского применения.

В ГЛОНАСС используются два канала: стандартной (СТ) и высокой (ВТ) точности, погрешности определения координат - одного порядка с GPS. Сигнал СТ доступен для всех потребителей, но в отличие от GPS, в ГЛОНАСС не используется режим дополнительных ошибок в сигнале стандартной точности. Сигналы высокой точности предназначены для военных, и обычные потребители пользоваться ими не могут. Рабочие частоты ГЛОНАСС: 1250 и 1600 МГц.

Теоретически космическая часть ГЛОНАСС также состоит из 24 спутников, но размещенных по 8 ИСЗ на трех круговых орбитах высотой около 19100 км и наклонением к экватору 64,8 градуса. Одним из достоинств выбора таких орбит является одинаковый "уход" всех спутников со своих первоначальных орбит. Вследствие этого автоматически обеспечивается максимальная долговременная стабильность взаимного положения всех ИСЗ системы.

На настоящий момент система ГЛОНАСС работает частично, на орбите находится 11 спутников из необходимых 24, причем работают из них всего 8. В интернете есть сайт центра ГЛОНАСС - www.glonass-center.ru, который посвящен этой навигационной системе. На нем можно узнать об этой системе в целом, а также в режиме реального времени о параметрах спутников системы, их количестве, работоспособности, положении, частотах и т.п.

Несмотря на различие в структуре и параметрах сигналов, заложенные требования при разработке обеих навигационных систем были одинаковы, поэтому в принципах построения и порядке работы есть много общего.


Спецвыпуск Xakep, номер #034, стр. 034-026-3, ТРИ В ОДНОМ: КАРТА, КОМПАС И ЧАСЫ

ТРИ В ОДНОМ: КАРТА, КОМПАС И ЧАСЫ

Елманов Олег (SpyDr@comail.ru)

Спецвыпуск Xakep, номер #034, стр. 034-026-3

ПРИНЦИПЫ РАБОТЫ

Ничего экстраординарного в принципах работы нет. Для того чтобы разобраться в этом, достаточно школьного курса физики. В общих словах, определение координат основано на измерении времени, за которое сигнал проходит от спутника до приемника. Координаты спутника известны, скорость сигнала равна скорости света, следовательно, по школьной формуле, расстояние есть время, умноженное на скорость света. Таким образом определяем расстояние от спутника до приемника. Если одновременно получить информацию с трех спутников, то уже можно определить точку в пространстве однозначно. По расчетам получаются две возможные точки нахождения приемника, но лишь одна из них находится на Земле или в непосредственной близости от ее поверхности. Вторая (ложная) оказывается либо глубоко внутри, либо очень высоко. Но это лишь теоретические выкладки. На самом деле, существует ряд погрешностей, которые влияют на точность определения координат, поэтому в реальности используются как минимум четыре спутника.

ПОЛОЖЕНИЕ GPS-СПУТНИКОВ

Первая трудность, которую приходится преодолевать, это определение точных координат спутников в любой момент времени. Схема определения местоположения спутника в каждый момент времени такова: на высоте 19-20 тысяч километров Земная атмосфера практически не ощущается, поэтому на спутники действует только сила притяжения, благодаря чему их орбиты заранее рассчитаны и известны. GPS-приемники имеют "альманах", размещаемый в памяти, из которого и вычисляются координаты каждого из спутников в любой момент времени. Кроме того, движение всех спутников GPS постоянно контролируется наземными станциями слежения. Обращаясь вокруг Земли с периодичностью раз в 12 часов, спутники проходят над станциями слежения дважды в сутки. Это дает возможность точно измерять их высоту, скорость и положение в пространстве. После определения параметров наземные станции передают на бортовой компьютер спутника уточненную информацию, заменяя прежнюю. Далее эти поправки будут передаваться спутником на Землю.

КООРДИНАЦИЯ ВРЕМЕНИ

Для определения местоположения необходимо знать не только координаты спутников, но и точное время, когда сигнал был отправлен со спутника. На всех GPS-спутниках установлены бортовые атомные часы с наносекундной точностью (0,000000001 секунды). Для предотвращения выхода спутника из строя из-за сбоя часов, каждый спутник имеет на борту по четверо таких часов. Все атомные часы орбитальной группировки GPS-спутников синхронизированы между собой наземными станциями слежения и GPS-приемниками. Но как приемник определит, когда сигнал был отправлен со спутника? Для этого в каждый момент времени на всех спутниках и приемниках генерируется один и тот же псевдослучайный код. Функция построения кода весьма сложна, так как именно этим обеспечивается помехозащищенность и однозначность их определения. При получении сигнала со спутника, GPS-приемник просматривает память для определения времени, когда данный код был сгенерирован. Преимуществом использования кодовых посылок является то, что измерение длительности пути сигнала может быть проведено в любой момент времени.


Спецвыпуск Xakep, номер #034, стр. 034-026-4, ТРИ В ОДНОМ: КАРТА, КОМПАС И ЧАСЫ

ТРИ В ОДНОМ: КАРТА, КОМПАС И ЧАСЫ

Елманов Олег (SpyDr@comail.ru)

Спецвыпуск Xakep, номер #034, стр. 034-026-4

В отличие от бортовых, часы GPS-приемника не столь точны. А при расхождении всего лишь на 0,01 секунды ошибка в определении расстояния будет около 3000 км. Проблема была решена следующим образом: если снимать значения с трех спутников, то при синхронизированном времени можно определить точку в трехмерном пространстве. А если снять показания еще и с четвертого спутника, то за счет него можно подкорректировать время на приемнике. Дело в том, что если часы GPS-приемника идут неточно, то принятые показания о расстоянии от приемника до спутников неверны. В случае приема данных с трех спутников происходит ошибка определения координат, а при четырех - получается интервал, в котором и находится необходимая точка. Для поиска этой точки компьютер GPS-приемника корректирует время так, чтобы минимизировать погрешность. При этом и достигается коррекция часов GPS-приемника.

Необходимость как минимум в четырех измерениях сказывается на проектировании и развитии GPS-приемников. Если нужно выполнять непрерывное определение местоположения, то следует применять приемник, имеющий не менее четырех каналов измерений. То есть с каждым из необходимых спутников постоянно работает отдельный канал приема и обработки сигналов.

АТМОСФЕРНЫЕ ПОГРЕШНОСТИ

В наибольшей степени на точность определения координат GPS-приемниками влияют атмосферные явления. Первой такой преградой является ионосфера Земли. Расположенный на высоте 120-200 километров слой заряженных частиц существенным образом влияет на скорость прохождения радиосигналов GPS и тем самым добавляет довольно ощутимые погрешности в точность определения координат.

Для уменьшения степени влияния ионосферы поступают следующим образом: во-первых, есть усредненные поправки на влияние ионосферных явлений. Во втором способе борьбы с этим явлением используется сравнение скоростей распространения двух сигналов, имеющих разные частоты несущих колебаний. Второй метод довольно сложен и применяется только в более совершенных двухдиапазонных GPS-приемниках.

Ближе к Земле на пути радиосигнала встает еще одна преграда - атмосферные явления. Их влияние практически непредсказуемо, но, к счастью, не столь велико.

ДРУГИЕ ПОГРЕШНОСТИ

Еще одним существенным фактором погрешности является так называемая лучевая интерференция. Ее суть в том, что при прохождении препятствий, природных (горы) или искусственных (здания в городе), сигналы переотражаются и задерживается до того, как достигнут GPS-приемника.

Есть и другие погрешности, но не столь значительные. Это и погрешности вычислений самого GPS-приемника, и помехи сигналов, приходящих со спутников, и т.п.

УВЕЛИЧЕНИЕ ТОЧНОСТИ

Для достижения наибольшей точности в современных GPS-приемниках используется геометрический принцип "Geometric Dilution of Precision" (GDOP - геометрический фактор снижения точности). Он заключается в том, что в зависимости от взаимного расположения GPS-спутников уменьшается степень влияния разнообразных погрешностей и увеличивается точность определения координат. Проще говоря, чем больше угол между спутниками, используемыми GPS-приемником, тем выше точность определения координат.


Спецвыпуск Xakep, номер #034, стр. 034-026-5, ТРИ В ОДНОМ: КАРТА, КОМПАС И ЧАСЫ

ТРИ В ОДНОМ: КАРТА, КОМПАС И ЧАСЫ

Елманов Олег (SpyDr@comail.ru)

Спецвыпуск Xakep, номер #034, стр. 034-026-5

Точность определения координат связана не только с расчетом расстояния от приемника до спутников и избавлением от влияния вредных факторов, но и с величиной изначальной погрешности задания местоположения самих спутников. Для контроля орбит и координат спутников существуют четыре наземных станции слежения, системы связи и центр управления. Станции слежения постоянно ведут наблюдение за всеми спутниками системы и передают данные об их орбитах в центр управления, где вычисляются уточненные элементы траекторий и поправки спутниковых часов. Указанные параметры вносятся в альманах и передаются на спутники, а те, в свою очередь, отсылают эту информацию всем работающим приемникам.

Качественно уменьшить ошибку в измерении координат позволяет режим дифференциальной коррекции (DGPS - Differential GPS). Дифференциальный режим заключается в использовании двух приемников. Один из них базовый - стационарный, называется станцией дифференциального GPS и находится в точке с известными координатами. Станция DGPS принимает сигналы со всех GPS-спутников и корректирует полученные данные. Вторым приемником является обычный мобильный GPS-приемник. Он принимает обычные данные со спутников и корректирует результат за счет информации, получаемой со станций DGPS.

В феврале 1998 года недалеко от Санкт-Петербурга компания "НавГеоКом" установила первую в России наземную станцию дифференциального GPS. Мощность передатчика станции - 100 Ватт, что позволяет пользоваться DGPS при удалении от станции на расстояние до 300 км по морю и до 150 км по суше. К настоящему моменту существует около 10 станций дифференциального GPS: в Москве, Санкт-Петербурге, Екатеринбурге, Таганроге и других городах.

Компания OmniStar предлагает использовать спутниковую систему дифференциального сервиса. Данные для коррекции передаются с нескольких геостационарных спутников компании. Пакет услуг стоит более 1500 долларов в год. Основными заказчиками дифференциальной коррекции являются геодезические и топографические службы, для частного пользователя DGPS не представляет интереса из-за высокой стоимости и громоздкости оборудования. Да и вряд ли в повседневной жизни возникают ситуации, когда надо знать свои абсолютные географические координаты с погрешностью 10-30 см :).

GPS-ПРИЕМНИКИ

Первые GPS-приемники имели довольно большой вес и габариты, что делало их пригодными для использования только на каких-либо транспортных средствах: судах, автомобилях, самолетах, вертолетах и т.п. Совершенствование радиоэлектроники привело к созданию небольших и довольно дешевых вариантов таких устройств.

В настоящее время GPS-приемники выпускаются примерно 150 компаниями по всему миру. В России известны такие приемники как Ashtech, Garmin, Magellan, Trimble (США), Sercel (Франция), Leica (Швейцария), Geotronics (Швеция) и др. Кроме того, в российских магазинах можно обнаружить совсем необычные устройства - вроде приемника GPS, вмонтированного в наручные электронные часы (модель Casio ProTrek GPS).


Спецвыпуск Xakep, номер #034, стр. 034-026-6, ТРИ В ОДНОМ: КАРТА, КОМПАС И ЧАСЫ

ТРИ В ОДНОМ: КАРТА, КОМПАС И ЧАСЫ

Елманов Олег (SpyDr@comail.ru)

Спецвыпуск Xakep, номер #034, стр. 034-026-6

Для владельцев карманных компьютеров и ноутбуков особый интерес представляют приемники GPS, подключаемые к порту USB или вставляемые в слот Compact Flash модулей. Правда, приемник, подключенный к ноутбуку, можно использовать только в качестве стационарного прибора, установленного в рубке катера или в просторной кабине грузовика. А карточку Compact Flash, подключенную к КПК, можно использовать точно так же, как и портативный приемник GPS, то есть где угодно и как угодно.

GPS В КАРМАННОМ КОМПЬЮТЕРЕ

Модули GPS выпускаются для всех распространенных платформ карманных компьютеров. Правда, изобилия здесь ожидать не приходится, но, тем не менее, что-то выбрать можно. Модули для КПК обычно выполнены в виде Compact Flash. Стоимость GPS-модулей для КПК колеблется в районе 150-300 долларов. Правда, не стоит забывать, что необходима топографическая программа с набором электронных карт, например, LaserMap (около 150 зеленых).

Семейство электронных атласов LaserMap завоевало заслуженный интерес пользователей благодаря простоте управления, надежности и высокой скорости работы, а также благодаря наличию большого количества высококачественных векторных карт, существующих в формате LaserMap.

Мощность, потребляемая приемником, около полуватта. По масштабам КПК, надо признать, просто огромная. Здесь следует обратить внимание на то, что при задании максимальной частоты обновления информации аккумулятор КПК долго не протянет, так что к этому вопросу стоит подходить аккуратно и дифференцируемо. Никто и не заставляет держать модуль GPS включенным постоянно. И максимальное значение обновления нужно далеко не всегда. В автомобиле, при питании маленького компьютера от гнезда прикуривателя - сколько угодно, в полевых условиях - только по необходимости.

Еще одним ограничением является то, что, вставив в свободный слот CompactFlash модуль GPS, лишаешься доступа к слоту. То есть модули памяти, адаптер беспроводной связи Bluetooth, фотокамеру и все прочее придется оставить в кармане.

ОСОБЕННОСТИ ИСПОЛЬЗОВАНИЯ GPS В РОССИИ

В России GPS-приемники пока являются больше игрушками, чем реальными помощниками. Дело в том, что если в Европе и Америке на общедоступные карты нанесен каждый городской переулок и пенек в лесу, то в России почти нет электронных карт для GPS. Относительно распространены карты Москвы и Питера, есть карты Подмосковья, и совсем нет карт российской глубинки, где GPS-приемник принес бы максимальную пользу.

Наконец, применение приемников GPS на территории России до последнего времени было сопряжено с некоторыми юридическими нюансами. В частности, для того чтобы приобрести GPS-приемник, частному лицу у нас в стране придется получить разрешение в органах Госгеонадзора. Дело в том, что GPS-навигаторы относятся к высокочастотным радиоэлектронным средствам (РЭС), а их ввоз, изготовление, продажа и эксплуатация на территории РФ регламентируется и контролируется Управлением Госсвязьнадзора.


Спецвыпуск Xakep, номер #034, стр. 034-026-7, ТРИ В ОДНОМ: КАРТА, КОМПАС И ЧАСЫ

ТРИ В ОДНОМ: КАРТА, КОМПАС И ЧАСЫ

Елманов Олег (SpyDr@comail.ru)

Спецвыпуск Xakep, номер #034, стр. 034-026-7

Новинкой в мире GPS является применение GPS-приемников под водой. Использование GPS под водой затруднительно по двум причинам. Первая заключается в том, что частотный диапазон 1,5 ГГц не распространяется в морской воде, а вторая - качество связи под водой весьма ограничено, а для GPS-приемников необходим большой объем данных. Это достигается переносом технологии GPS под воду, где в роли спутников выступают буи, координаты которых известны, а радиоволны заменяются акустическими.

Плюсов значительно больше. С GPS-приемником ты не заблудишься в каменных джунглях Москвы, Санкт-Петербурга и еще в тысячах зарубежных городов, городков, деревень и хуторов. При этом сможешь не только определить координаты, но и узнать свое местоположение в городе: улицу и даже номер дома, у которого стоишь. В грибных и рыбацких скитаниях приемник GPS облегчит ориентирование на местности и прокладку маршрута. Даже без карты ты не потеряешь ориентиры (только в густом тумане, который, оказывается, сбивает с толку и GPS, экранируя спутниковые сигналы).

Кроме всего вышеперечисленного, прогуливаясь в парке с девушкой, всегда можно, сделав умный вид, достать GPS-приемник и выдать приблизительно следующее: "Я тут очередной эфимерис получил. Спутник передал, координаты уточнял!" :)

GPS-приемник используется в качестве компаса, электронной карты, умеет запоминать маршрут, вычислять скорость движения, пройденный километраж и много других полезных вещей.

Другим усовершенствованием системы GPS в военных целях стали новые антенны, невосприимчивые к сигналам "глушилок".

В интернете есть сайт центра ГЛОНАСС - www.glonass-center.ru, который посвящен этой навигационной системе. На нем можно узнать об этой системе в целом, а также в режиме реального времени о параметрах спутников системы, их количестве, работоспособности, положении, частотах и т.п.

В общих словах, определение координат основано на измерении времени, за которое сигнал проходит от спутника до приемника. Координаты спутника известны, скорость сигнала равна скорости света, следовательно, по школьной формуле, расстояние есть время, умноженное на скорость света.

На всех GPS-спутниках установлены бортовые атомные часы с наносекундной точностью (0,000000001 секунды). Для предотвращения выхода спутника из строя из-за сбоя часов, каждый спутник имеет на борту по четверо таких часов.

Для достижения наибольшей точности в современных GPS-приемниках используется геометрический принцип "Geometric Dilution of Precision" (GDOP - геометрический фактор снижения точности).

В феврале 1998 года недалеко от Санкт-Петербурга компания "НавГеоКом" установила первую в России наземную станцию дифференциального GPS. Мощность передатчика станции - 100 Ватт, что позволяет пользоваться DGPS при удалении от станции на расстояние до 300 км по морю и до 150 км по суше.


Спецвыпуск Xakep, номер #034, стр. 034-026-8, ТРИ В ОДНОМ: КАРТА, КОМПАС И ЧАСЫ

ТРИ В ОДНОМ: КАРТА, КОМПАС И ЧАСЫ

Елманов Олег (SpyDr@comail.ru)

Спецвыпуск Xakep, номер #034, стр. 034-026-8

В России GPS-приемники пока являются больше игрушками, чем реальными помощниками. Дело в том, что если в Европе и Америке на общедоступные карты нанесен каждый городской переулок и пенек в лесу, то в России почти нет электронных карт для GPS.


Спецвыпуск Xakep, номер #034, стр. 034-030-1, Вечный интернет для мобильника

Вечный интернет для мобильника

Фленов Михаил

Спецвыпуск Xakep, номер #034, стр. 034-030-1

Весь GPRS: от телефона до оператора

smirnandr@mail.ru www.cydsoft.com/vr-online

Всегда быть в онлайне - мечта любого фаната информационных технологий. Уже давно Голливуд показывает в кино, как хакеры спокойно сидят в каком-нибудь парке, работают за своим ноутбуком и при этом ни к чему не подключены! О такой жизни до сих пор мечтает каждый IBM-совместимый человек.

Несколько лет назад я первый раз услышал о реальных попытках сделать сказку былью – в Великобритании осетенили один из крупных парков. Это означало, что у каждой скамейки была розетка, в которую ты мог подключить свой бук и без проблем выйти в интернет. Самое интересное, что все это было совершенно бесплатно. Мэрия города набрала кучу спонсоров и предоставила такой праздник своим жителям. Не знаю, сколько продолжался первый опыт паркового инета, но больше я об этом ничего не слышал (там сейчас бесплатный интернет даже по Wi-Fi предоставляют - прим. ред.).

Идея подключить к интернету каждый столб интересна, но не очень практична. Все равно всем не хватит и в копеечку влетит.

В интернет по мобиле

Уже давно существует реальная возможность выйти в Сеть с помощью мобильного GSM-телефона. Технология называется CSD (Curcuit Switched Data) - "звонишь" телефоном как обычным модемом. Почему же мало кто ей пользуется? Тут две причины: дороговизна и маленькая скорость. На какой скорости ты сейчас качаешь файлы из интернета? Я думаю, что не менее 30 кило в секунду. А ты согласился бы качать на скорости в 9,6 Кбод (в лучшем случае 14,4) и платить за это по 20 центов в минуту? Думаю, нет, потому что это не для слабонервных.

Дороговизна решения и низкая скорость тормозили развитие. Но все постепенно изменяется с запуском нового сервиса GPRS, основанного на GSM-сетях. С помощью этой технологии можно подключиться к Сети в любое время и в любом месте за весьма приемлемую цену.

Что такое GPRS

GRPS (General Packet Radio Service) – это служба, которая основана на коммутации пакетов в сетях GSM. Она позволяет всегда быть on-line, что не требует нудного дозвона до провайдера. Соединение происходит за считанные секунды. Скорость через GPRS может быть до 115 кило в секунду, что делает эту технологию даже лучше dial-up'а.

Самое интересное, что ты можешь беседовать по телефону и сливать с инета данные практически одновременно. Во время разговоров абонентов сотовой сети всегда есть "пустоты" в канале. Именно их и использует GPRS для передачи данных. Информация собирается в пакеты и передается в эфир, используя свободные в данный момент ресурсы голосовых каналов. Если у оператора, к которому ты подключен, перегружены линии, то "пустот" будет немного и скорость передачи окажется низкой.

Из-за практически постоянного подключения к сети, оператор устанавливает плату не за время в онлайне, а за передаваемые и/или получаемые данные. Т.е. никакой повременки нет, ты платишь только за то, что скачал. Если через модем ты стараешься скачать за положенные часы максимум web-страниц, чтобы потом рассмотреть их в off-line, то здесь ты можешь спокойно читать каждую страницу: никто тебя не будет торопить.


Спецвыпуск Xakep, номер #034, стр. 034-030-2, Вечный интернет для мобильника

Вечный интернет для мобильника

Фленов Михаил

Спецвыпуск Xakep, номер #034, стр. 034-030-2

Используемая технология пакетной коммутации канала схожа с IP и X.25: в источнике данные разделяются на пакеты и передаются по отдельности, а на приемнике собираются вместе. Маршруты следования пакетов (любой трафик IP или X.25) могут быть разные, в зависимости от свободных каналов.

Для передачи используется восемь каналов, а ширина радиополосы составляет 200 кГц. Каждый из каналов может работать на скорости 14,4 кбит, поэтому общая скорость достигает 115,2 кбит (14,4 * 8), хотя не факт, что тебе удастся достигнуть этого максимума: ведь, как и при модемном соединении, точки доступа делят множество пользователей.

Радиополосы распределяются динамически, а их распределение зависит от передаваемой информации. Согласно стандарту, когда ты получаешь/передаешь текст, скорость будет меньше, чем когда ты слушаешь музыку в формате mp3. Это значит, что трафик постоянно анализируется, и на основе этого анализа происходит динамическое выделение таймслотов - элементарных каналов связи в TDMA.

На рисунке 1 показана схема работы GPRS. Я изобразил только те компоненты, которые касаются пакетной передачи данных. GPRS состоит из следующих компонентов:

1. SGSN (Serving GPRS Support Node) - узел поддержки, контролирующий отсылку и получение пакетов. Отслеживает твое перемещение, чтобы оптимальным образом распределить ресурсы, а также принимает и пересылает в главный офис биллинговую информацию.

2. GGSN (Gateway GPRS Support Node) – шлюзовой узел, отвечающий за взаимодействие с сетями Internet. Между SGSN и GGSN данные передаются с помощью специального протокола GTP (GPRS Tunneling Protocol).

3. HLR (Home Location Register) - реестр собственных абонентов. Это база данных всех абонентах сети.

4. VLR (Visitor Location Register) - реестр перемещений. Таких реестров может быть несколько, и каждый из них отображает пользователей, которые находятся на его территории.

В будущем, если системы будут ориентироваться на мобильный интернет, возможно добавление еще одного специального узла – узел поддержки интернета IGSN (Internet GPRS Support Node).

Как все работает

Для начала передачи пакетов передающее устройство должно зарегистрироваться. За это отвечает компонент SGSN. Если эта услуга доступна, необходимые данные копируются из HLR в SGSN, и телефону выдается временный номер для пакетной передачи данных (P-TMSI или Packet Temporary Mobile Subscriber Identity). Это чем-то похоже на динамическое выделение IP при dial-up доступе. Подобный номер выдается и при передаче голосовых данных.

Системе также очень важно знать, где ты находишься относительно сети, поэтому необходим компонент VLR.

В данном случае эта информация важнее, чем при передаче голоса. При этом, чтобы не возрос служебный трафик и телефону не приходилось постоянно информировать об изменении твоего местоположения, за абонентом следят, только если он готов к приему/передаче данных. Сканирование не будет происходить, когда абонентский терминал находится вне зоны приема или если клиент долгое время не пользуется услугой GPRS.


Спецвыпуск Xakep, номер #034, стр. 034-030-3, Вечный интернет для мобильника

Вечный интернет для мобильника

Фленов Михаил

Спецвыпуск Xakep, номер #034, стр. 034-030-3

Классы телефонов

Существует три класса GPRS телефонов:

Класс А - могут одновременно работать с данными и голосом. Ты можешь с кем-то болтать по телефону, и при этом у тебя будет качаться очередной mp3-файл.

Класс В - могут передавать или данные, или голос. Одновременная работа с тем и другим не поддерживается.

Существует еще класс С, но это уже не телефоны, а просто сетевые адаптеры для получения беспроводного доступа в интернет. Они могут передавать данные, а голос - нет.

Ограничения

Несмотря на всю красоту, которую я описал, у GPRS есть несколько недостатков, о которых нельзя умолчать:

1. Объем ресурсов всегда ограничен. Голос и GPRS используют одни и те же ресурсы, и если ресурсы заняты одним, то это мешает нормальной работе другого сервиса. Эта проблема решается динамическим управлением ресурсами, но я не уверен, что решится полностью.

2. Пакеты отправляются разными маршрутами, и в радиопередаче могут быть большие потери, поэтому используемые механизмы для обеспечения гарантированной доставки могут увеличить задержки.

3. Как я уже говорил, максимальные скорости пока допустимы только теоретически. Практически, даже если ты получишь половину, то можешь считать себя богом сотового интернета. В будущем, я надеюсь, скорость улучшится, и мы сможем получить гарантированные 100 кбит/с (у меня максимально получалось примерно 6 Кбайт/с в МТС - прим. ред.).

Будущее уже не за горами

Что нас ждет в ближайшем будущем на сцене пакетной передачи? Ответ прост: третье поколение - 3G - мобильных сетей. Например, стандарт UMTS (Universal Mobile Telecommunications System) - сейчас у нас пока на дворе поколение 2.5. UMTS позволяет передавать данные на скорости до 2 Мбит/с. Чувствуешь, чем запахло?

Но я сразу тебя огорчу, потому что это теоретическая скорость в закрытом помещении. На открытой местности ты сможешь ощутить 384 кбит/с (восемь каналов по 48 кбит/с), но тоже теоретически. Практически будет немного меньше, но даже если разделить эту скорость пополам, то и в этом случае привычный dial-up отдыхает. Так что скоро у нас появится реальная возможность отказаться от этих аналогово-цифровых преобразователей - модемов (МОдулятор-ДЕМодулятор - прим. ред.) - и использовать "чисто" цифровую высокоскоростную связь.

Всегда на чеку

Настало время подумать о безопасности в GPRS. Используя эту службу, любой враг народа сможет обладать 100% анонимностью: на ближайшем развале можно купить подержанные (а вполне возможно, что и ворованные) телефоны с разблокированной SIM-картой. (Не принимай слова про анонимность близко к сердцу: местоположение абонента GSM-сети во время сеанса связи можно определить с точностью порядка сотен метров, а потом с помощью специальной аппаратуры запеленговать окончательно и выпустить по нему ракету класса воздух-земля :), к тому же номера базовых станций всегда остаются в логах оператора - прим. ред.)

Так что, если ты не хочешь, чтобы к тебе пришли сотрудники нашей доблестной милиции и предъявили обвинения в незаконных действиях, которых ты не совершал, всегда сообщай о пропаже телефона! Если пока никого не посадили по случайной ошибке, то в будущем это вполне может случиться. По крайней мере, теоретически это возможно.


Спецвыпуск Xakep, номер #034, стр. 034-030-4, Вечный интернет для мобильника

Вечный интернет для мобильника

Фленов Михаил

Спецвыпуск Xakep, номер #034, стр. 034-030-4

Удачи тебе.

Скорость через GPRS может достигать 115 килобайт в секунду!

В ближайшем будущем нас ждет очередное пришествие - стандарт UMTS (Universal Mobile Telecommunications System), который является стандартом сотовых сетей третьего поколения 3G. Эта технология грозит нам скоростями до 2 Мбит/с!


Спецвыпуск Xakep, номер #034, стр. 034-032-1, ВЫСОКОСКОРОСТНОЙ ETHERNET

ВЫСОКОСКОРОСТНОЙ ETHERNET

Красовский Тихон

Спецвыпуск Xakep, номер #034, стр. 034-032-1

(tihon@koptevo.net)

История, технология, перспективы

Большинство пользователей уже привыкли к слову Ehternet и часто называют так свою локальную сеть или выделенный канал к провайдеру. На самом деле Ethernet - это тысячи людей по всему миру, сотни лабораторий, десятки крупнейших производителей «железа». Многие связали с ним свою карьеру и кошелек. Практически это единственный выживший и до сих пор развивающийся массовый стандарт передачи данных. Ethernet как стандарт объединил большинство конкурирующих производителей и разработчиков. Ehternet - такой же стандарт для разработчиков hardware, как форма колеса для производителей автомобильной резины.

С ЧЕГО НАЧИНАЛОСЬ

Стандарт Ethernet начали разрабатывать в 70-х годах в исследовательском центре PARC (корпорация XEROX). Позже он дорабатывался совместно DEC, Intel и XEROX (сокращенно DIX). В 1980 году стандарт был опубликован как "Blue Book Standart" для Ethernet1, а в 1985 году вышел Ethernet2 (DIX). Одновременно с ним появился стандарт IEEE 802.3, устанавливающий общие правила передачи данных в локальных сетях. В 1985 году он был одобрен для стандартизации комитетом по LAN IEEE (Institute of Electrical and Electronics Engineers) и опубликован как "IEEE 802.3 Carrier Sense Multiple Access with Collision Detection (CSMA/CD) Access Method and Physical Layer Specifications".

ETHERNET

Ethernet и IEEE802.3 описывают схожие широковещательные технологии (CSMA/CD локальные сети), в которых все станции видят все фреймы (frame). Каждая станция проверяет все полученные фреймы на предмет того, является ли она пунктом назначения. Если является, то фрейм передается протоколу более высокого уровня для дальнейшей обработки. Различия между Ethenet и IEEE 802.3 есть, но незначительные.

IEEE 802.3 определяет несколько физических уровней, Ethernet - только один. Каждый физический уровень IEEE 802.3 имеет свое название, в котором зашифрованы его характеристики. К примеру, 10Base5 расшифровывается так: 10 - скорость локальной сети в мегабитах в секунду, 5 - длина сегмента (в сотнях метров), в данном случае 500 м.

Стоит отметить, что Ethernet и IEEE 802.3 поддерживаются большинством производителей, выпускающих оборудование для локальных сетей.

FAST ETHERNET

Большинству пользователей в течение пятнадцати лет было достаточно классического 10-мегабитного Ethernet, однако в начале 90-х годов пропускной способности каналов стало не хватать. Многие сегменты 10-мегабитного Ethernet перегружались, отклик серверов падал, а частота возникновения коллизий существенно возрастала, еще сильнее снижая полезную пропускную способность. То есть возникла необходимость в "новом" Ethernet, с таким же эффективным соотношением цена/качество, но с производительностью 100 Мбит/с. Специалисты в процессе разработки разделились на два лагеря, что в привело к появлению двух новых технологий - Fast Ethernet и l00VG-AnyLAN, отличающихся степенью совместимости с классическим Ethernet.

В 1992 году группа производителей сетевого оборудования из первого лагеря (3Com, SynOptics и другие) образовала некоммерческое объединение Fast Ethernet Alliance (FEA) по разработке стандарта новой технологии, с учетом особенностей технологии Ethernet. Во втором лагере были компании Hewlett-Packard и AT&T, которые предложили устранить выявленные на тот момент недостатки технологии Ethernet. Через некоторое время к ним присоединилась компания IBM, предложив обеспечить совместимость новой технологии с сетями IBM (Token Ring). Параллельно в институте IEEE была сформирована исследовательская группа для изучения технического потенциала новых высокоскоростных технологий.


Спецвыпуск Xakep, номер #034, стр. 034-032-2, ВЫСОКОСКОРОСТНОЙ ETHERNET

ВЫСОКОСКОРОСТНОЙ ETHERNET

Красовский Тихон

Спецвыпуск Xakep, номер #034, стр. 034-032-2

Предложение Fast Ethernet Alliance сохраняло метод доступа CSMA/CD и тем самым обеспечивало согласованность и преемственность сетей 10 Мбит/с и 100 Мбит/с. Союз HP и AT&T, имеющий поддержку значительно меньшего числа производителей в сетевой индустрии, предложил совершенно новый метод доступа, названный Demand Priority - приоритетный доступ по требованию. Он не вписывался в технологию Ethernet и стандарт 802.3, поэтому для его стандартизации был организован новый комитет IEEE 802.12.

Осенью 1995 года комитет IEEE 802.3 принял спецификацию Fast Ethernet в качестве стандарта 802.3u, который не является самостоятельным стандартом, а представляет собой дополнение к существующему стандарту 802.3 (главы с 21 по 30). А комитет 802.12 принял технологию l00VG-AnyLAN, которая использует новый метод доступа Demand Priority и поддерживает фреймы двух форматов: Ethernet и Token Ring.

Переход от 10Base-F(fiber) к стандарту 100Base-T для сетей на витой паре не представлял проблем, а в случае оптоволоконных сетей проблемы были. Они возникали из-за несовместимости соответствующих стандартов по длине волны: 850 нм для 10Base-F и 1300 мкм для 100Base-FX (стандарт физического уровня PHY Fast Ethernet, который обеспечивает передачу данных по одномодовому волоконно-оптическому кабелю со скоростью 100 Мбит/с с применением правил доступа к среде CSMA/CD).

Попытки создать проект в рамках группы IEEE 802.3 для решения этой проблемы оказались безуспешными, и производители, заинтересованные в разработке соответствующего стандарта, организовали группу под эгидой TIA (Telecommunications Industry Association). Группа TIA разработала свой стандарт, который назывался 100Base-SX (S обозначает short wavelength), он и был в конечном счете принят IEEE. Подробнее об этом читай на www.i2r.ru/static/380/out_11283.shtml.

ОПТИКА

Существует два основных типа оптических волокон: многомодовое и одномодовое, последнее преобладает на рынке с 70-х годов и используется в широком диапазоне сетевых технологий. В многомодовом волокне распространяющийся по сердцевине оптический сигнал представлен множеством мод, в то время как одномодовое волокно в нормальном режиме работы поддерживает распространение только одной моды. В многомодовых волокнах время распространения сигнала вдоль волокна различно для разных мод, что выражается в расширении импульсов на выходе волокна (межмодовой дисперсии). Межмодовая дисперсия ограничивает пропускную способность многомодового волокна: максимально возможную скорость передачи и максимально возможное расстояние.


Спецвыпуск Xakep, номер #034, стр. 034-032-3, ВЫСОКОСКОРОСТНОЙ ETHERNET

ВЫСОКОСКОРОСТНОЙ ETHERNET

Красовский Тихон

Спецвыпуск Xakep, номер #034, стр. 034-032-3

Одномодовое волокно, поддерживающее распространение только одной моды и поэтому не имеющее межмодовой дисперсии, имеет большую пропускную способность. Это позволяет вести передачу на большей скорости и на большие расстояния. По этой причине одномодовые волокна используются, как правило, для протяженных линий связи, городских и региональных сетей. В то же время, многомодовые волокна могут поддерживать высокие скорости передачи данных на небольшие расстояния. Больший диаметр сердцевины многомодового волокна упрощает ввод оптического излучения в волокно, а более мягкие требования к допустимым отклонениям для многомодового волокна позволяют уменьшить стоимость оптических приемо-передатчиков. Таким образом, многомодовое волокно преобладает в локальных и домашних сетях небольшой протяженности.

RADIO ETHERNET

Параллельно развивался еще один вариант стандарта Ethernet - беспроводной Radio Ethernet. Изначально он предназначался для построения локальных беспроводных сетей, но все чаще используется для подключения удаленных абонентов к магистралям. С его помощью решается проблема "последней мили" (от 100 м до 25 км). Radio Ethernet позволяет создавать защищенные беспроводные каналы для передачи любой (в том числе мультимедийной) информации и обеспечивает пропускную способность до 54 Мбит/с. Технология соответствует стандарту 802.11, разработанному IEEE в 1997 году и описывающему протоколы, которые позволяют организовать локальные беспроводные сети (Wireless Local Aria Network, WLAN).

Стандарт Radio Ethernet предусматривает организацию беспроводной связи на ограниченной территории и предоставляет нескольким абонентам равноправный доступ к общему радиоканалу.

Реализуется либо на базе сигнала в инфракрасном спектре, либо путем формирования широкополосного радиосигнала с использованием прямого расширения спектра (DSSS) или же скачкообразной перестройкой частоты (FHSS). Устройства, использующие инфракрасное излучение, устойчиво работают только в условиях прямой видимости, и характеристики этих устройств сильно зависят от погодных условий. Такой вариант больше применим для создания сетей внутри крупных помещений. Две другие технологии (DSSS и FHSS) ориентированы на работу в двух диапазонах: 915 МГц и 2,4 ГГц. Диапазон 900 МГц загружен другими потребителями (лидеры – 900-мегагерцовые телефоны), а потому устройства для этого диапазона также рекомендуется устанавливать внутри помещений. Оборудование, работающее в области частот 2,4 ГГц, можно применять как внутри, так и снаружи зданий. Применение для беспроводных внутриофисных систем диапазона 2,4 ГГц нигде, кроме России, не требует получения никаких разрешительных документов. В нашей же стране необходимо разрешение Госсвязьнадзора (кушать все хотят).

ПЛЮСЫ И МИНУСЫ

Метод DSSS позволяет достичь большей (по сравнению с FHSS) пропускной способности (2 Мбит/с на один канал и 6 Мбит/с - на три), обеспечивает более высокую устойчивость к узкополосным помехам и большую дальность связи. Однако технология DSSS требует более сложного и дорогостоящего оборудования. Поэтому гораздо больше компаний выпускают FHSS-устройства. Еще одно достоинство FHSS-устройств - способность сохранять работоспособность в условиях широкополосных помех. Правда, часто они сами создают помехи обычным узкополосным устройствам.


Спецвыпуск Xakep, номер #034, стр. 034-032-4, ВЫСОКОСКОРОСТНОЙ ETHERNET

ВЫСОКОСКОРОСТНОЙ ETHERNET

Красовский Тихон

Спецвыпуск Xakep, номер #034, стр. 034-032-4

Radio Ethernet, аналогично стандарту Ethernet, использует "коллизионный" метод доступа к общему каналу, однако в нем предусмотрена фаза предварительного резервирования канала (коллизии допустимы только при резервировании), благодаря чему передача происходит без коллизий. Основной способ доступа к среде для Radio Ethernet - многостанционный доступ с обнаружением несущей и предотвращением конфликтов (Carrier Sense Multiple Access with Collision Avoidance, CSMA/CA). Подробнее про Radio Ethernet читай на www.mka.ru/?p=40139.

СТАНДАРТЫ СЕРИИ 802.11

Базовый стандарт 802.11 ориентирован на работу в диапазоне частот 2,4 ГГц со скоростью передачи данных в 1 и 2 Мбит/с. Для него используется сотовая архитектура системы: каждая сота управляется базовой станцией, называемой точкой доступа (Access Point, AP), и обслуживает рабочие станции пользователей в пределах своего радиуса действия, образуя базовую зону обслуживания (Basic Service Set, BSS). Кроме того, стандарт предусматривает построение односотовой сети даже без точки доступа, в этом случае ее функции выполняются рабочими станциями. Оборудование (диапазон частот 2,4 ГГц) способно обеспечить связь на расстоянии до 300 метров. Допускаются любые варианты топологии сети: точка-точка, звезда, точка-много точек, каждый с каждым. Мобильность рабочих станций достигается за счет использования специальных процедур сканирования радиоканала и автоматического присоединения абонентов. Тем не менее, в стандарте 802.11 не определены спецификации для реализации роуминга.

Стандарт 802.11 предусматривает защиту информации в беспроводной сети с помощью мер (Wired Equivalent Privacy, WEP), включающих механизмы и процедуры аутентификации и шифрования.

Наиболее "широкополосный" стандарт из семейства Radio Ethernet - 802.11a, последняя редакция была утверждена в 1999 году. Предельная скорость передачи данных - 54 Mбит/с (в спецификациях определены три обязательные скорости: 6, 12 и 24 Mбит/с, а также пять необязательных: 9, 18, 36, 48 и 54 Mбит/с). Этот стандарт работает в диапазоне 5 ГГц, в качестве метода модуляции используется ортогональное частотное мультиплексирование (OFDM), позволяющее снизить до минимума межсимвольные искажения в радиоканале. Применение OFDM позволяет передавать полезные сигналы параллельно на нескольких частотах диапазона, что существенно повышает пропускную способность канала. Для оборудования, использующего диапазон частот 5 ГГц, характерна более высокая потребляемая мощность передатчиков и меньший радиус действия (около 100 м).

Стандарт 802.11b (Wi-Fi, Wireless Fidelity) ориентирован на радиочастотный диапазон 2,4 ГГц (пропускная способность до 11 Мбит/с) и практически соответствует проводному Ethernet-каналу. Базовая радиотехнология Wi-Fi - прямое расширение сигнала с помощью восьмиразрядных последовательностей Уолша. Стандарт предусматривает автоматическое понижение скорости передачи информации при ухудшении качества сигнала. Четкие механизмы роуминга в нем также не определены.


Спецвыпуск Xakep, номер #034, стр. 034-032-5, ВЫСОКОСКОРОСТНОЙ ETHERNET

ВЫСОКОСКОРОСТНОЙ ETHERNET

Красовский Тихон

Спецвыпуск Xakep, номер #034, стр. 034-032-5

Помимо перечисленных стандартов серии 802.11 рабочая группа IEEE разрабатывает также отдельные спецификации, дополняющие некоторые из стандартов серии 802.11.

GIGABIT ETHERNET

Технологии - не столбы, на месте долго не стоят. 26 июня 1999 года в IEEE-SA был единогласно утвержден документ IEEE Std 802.3ab, определяющий параметры протокола 1000Base-T Gigabit Ethernet. Устройства, совместимые с 1000Base-T, работают на большинстве установленных каналов на витой паре категории 5. Благодаря этому появились в продаже гигабитные устройства, позволяющие на порядок поднять скорость в локальной сети по старой сетевой проводке. Среди производителей устройств для организации гигабитной локалки: 3com, TrendNet, Intel, D-link и Cisco. Что же касается оптических каналов связи, то еще на год раньше (22 июня 1998 года) был принят стандарт IEEE Std 802.3z Gigabit Ethernet. Были определены параметры протоколов 1000Base-SX Gigabit Ethernet (для коротковолнового диапазона многомодовых кабелей, 850 нм) и 1000Base-LX Gigabit Ethernet (для длинноволнового диапазона многомодовых и одномодовых кабелей, 1300 нм).

ФИЗИЧЕСКИЕ ХАРАКТЕРИСТИКИ

(S) – короткая длина волны (short);

(UTP) - неэкранированная витая пара (Unshielded twisted-pairwaire);

(РК) - коаксиальный кабель;

(10GbE) - многомодовое 10 Gigabit Ethernet-волокно.

10 Gigabit Ethernet

20 июня 2002 официально утвержден стандарт 10 Gigabit Ethernet IEEE 802.3ae и полностью одобрен Ассоциацией по стандартам Института инженеров по электротехнике и электронике (IEEE-SA). Утверждение состоялось во время заседания комитета по стандартам IEEE-SA 11-13 июня в Пискэтвей (Piscataway), штат Нью-Джерси (занятное, наверное, местечко - прим. ред.). Стандарт был принят единогласно без каких-либо замечаний. Таким образом, технология и стандарт 10 Gigabit Ethernet, разработанные ведущими мировыми производителями за три года напряженной совместной работы, получили безоговорочное одобрение экспертов. Публичная демонстрация новой технологии состоялась на выставках SuperComm (июнь 2002, Атланта) и NetWorld+Interop (май 2002, Лас-Вегас).

Подробная информация о стандарте IEEE P802.3ae доступна на сайте рабочей группы IEEE 802 www.ieee802.org. Подробная информация об Альянсе 10 Gigabit Ethernet (10GEA), который был основан ведущими производителями телекоммуникационного оборудования 3Com, Cisco Systems, Extreme Networks, Intel Corporation, Nortel Networks, Sun Microsystems и World Wide Packets, доступна на сайте www.10gea.org.

ДАЛЬНЕЙШЕЕ РАЗВИТИЕ И ПЕРСПЕКТИВЫ

Уже сейчас в лабораторных условиях на оптике получены скорости в 10 Тбит\с. Но, к сожалению, уже нащупан и предел этой гонки. При распространении светового сигнала высокой интенсивности в волокне возникает множество нелинейных эффектов, которые сложным образом влияют на качество сигнала. Оценить теоретическую пропускную способность оптического волокна удалось Partha Mitra из Лабораторий Белла (Bell Labs), они рассмотрели телекоммуникационные системы, которые используют волновое мультиплексирование DWDM.


Спецвыпуск Xakep, номер #034, стр. 034-032-6, ВЫСОКОСКОРОСТНОЙ ETHERNET

ВЫСОКОСКОРОСТНОЙ ETHERNET

Красовский Тихон

Спецвыпуск Xakep, номер #034, стр. 034-032-6

В технологии DWDM по одному волокну на разных длинах волн одновременно передаются несколько оптических сигналов (информационных каналов). Чем больше мощность и пропускная способность каждого канала, тем сильнее интерференция между каналами и тем меньше каналов можно одновременно передавать по волокну. С другой стороны, чем меньше мощность сигнала, тем сильнее он подвержен влиянию шумов. Рассмотрев типичные значения длин волн и пропускных способностей каналов, ученые из Bell Labs установили, что максимальная (теоретически возможная) пропускная способность оптического волокна составляет около 100 Тбит/с. Для сравнения: общая пропускная способность современных коммерческих оптических систем составляет около 2 Тбит/с. Статья с результатами исследований опубликована в журнале Nature от 28 июня 2001 года.

Рабочая группа IEEE 802.3 и дальше развивает свое детище (Ethernet), двигаясь в направлении универсальной технологии широкополосного доступа. Принятие проекта стандарта EFM – очередной этап в процедуре стандартизации IEEE. Этот проект охватит все технические элементы, необходимые для широкополосной сети Ethernet, включая спецификации физического уровня передачи по меди, по волокну ("точка-точка" и "точка-многоточка") и общий механизм администрирования и управления работой сети, допускающий предоставление широкополосных услуг как в офисе, так и дома.

ПОЛЕЗНЫЕ ССЫЛКИ

www.tt.ru

www.free.com.ua

www.bytemag.ru

Большинство пользователей уже привыкли к слову Ehternet и часто называют так свою локальную сеть или выделенный канал к провайдеру. На самом деле Ethernet - это тысячи людей по всему миру, сотни лабораторий, десятки крупнейших производителей "железа".

Каждый физический уровень IEEE 802.3 имеет свое название, в котором зашифрованы его характеристики. К примеру, 10Base5 расшифровывается так: 10 - скорость локальной сети в мегабитах в секунду, 5 - длина сегмента (сотни метров), в данном случае 500.

Существует два основных типа оптических волокон: многомодовое и одномодовое, последнее преобладает на рынке с 70-х годов и используется в широком диапазоне сетевых технологий.

Параллельно развивался еще один вариант стандарта Ethernet - беспроводной Radio Ethernet. Изначально он предназначался для построения локальных беспроводных сетей, но все чаще используется для подключения удаленных абонентов к магистралям.

Метод DSSS позволяет достичь большей (по сравнению с FHSS) пропускной способности (2 Мбит/с на один канал и 6 Мбит/с - на три), обеспечивает более высокую устойчивость к узкополосным помехам и большую дальность связи.

Radio Ethernet, аналогично стандарту Ethernet, использует "коллизионный" метод доступа к общему каналу, однако в нем предусмотрена фаза предварительного резервирования канала, благодаря чему передача происходит без коллизий.


Спецвыпуск Xakep, номер #034, стр. 034-032-7, ВЫСОКОСКОРОСТНОЙ ETHERNET

ВЫСОКОСКОРОСТНОЙ ETHERNET

Красовский Тихон

Спецвыпуск Xakep, номер #034, стр. 034-032-7

Уже сейчас в лабораторных условиях на оптике получены скорости в 10 Тбит\с. Но, к сожалению, уже нащупан и предел этой гонки - 100 Тбит\с.

Проект стандарта EFM охватит все технические элементы, необходимые для широкополосной сети Ethernet, включая спецификации физического уровня передачи данных и общий механизм администрирования и управления работой сети.


Спецвыпуск Xakep, номер #034, стр. 034-036-1, ТЕХНОЛОГИЯ Ж-Ж-Ж

ТЕХНОЛОГИЯ Ж-Ж-Ж

Олег "2sheds" Курапов

Спецвыпуск Xakep, номер #034, стр. 034-036-1

(ok@2sheds.ru)

Cотовые сети третьего поколения

Быстрый рост популярности сотовой связи в первой половине 90-х годов подтолкнул операторов и компании-разработчики оборудования к созданию новых стандартов, переходу от имеющихся систем разных форматов к некой единой технологии. Основное направление - передача данных и мультимедиа-контента.

IMT-2000

За этой аббревиатурой скрывается ряд требований, которые были установлены в ITU (Международном союзе электросвязи) для нового семейства стандартов, охватывающих не только сотовую связь, но и другие технологии связи и коммуникаций:

– Обеспечение высокоскоростного доступа, как при коммутируемом соединении, так и в случае пакетной передачи данных:

* 2 Мбит/с и выше (мобильность абонента ограничена, в помещении);

* 384 Кбит/с (абонент перемещается с небольшой скоростью, пешеход);

* 144 Кбит/с (абонент перемещается со значительной скоростью, транспорт).

– Совместимость стандартов и роуминга.

– Единый биллинг и поддержка общих профилей для пользователей:

* стандартизированный учет статистики звонков;

* стандартизированные профили пользователей;

* передача информации о тарифах между операторами.

– Определение географических координат мобильных аппаратов с возможностью получения этой информации как сетевыми службами, так и самим абонентским устройством.

– Поддержка расширенных сервисных и мультимедиа функций:

* динамически изменяемая ширина канала (в зависимости от потребностей конкретного пользователя);

* ассиметричные скорости соединения для входящих и исходящих каналов;

* прием и передача мультимедийных сообщений;

* широкополосный доступ со скоростями до 2 Мбит/с.

IMT-2000 расшифровывается как Международная система мобильной связи, а цифра "2000" обозначает не только год начала тестирования, но и используемый частотный диапазон – 2 ГГц (более точно: 1885-2025 МГц и 2110-2200 МГц).

В соответствии с этими требованиями региональными стандартизационными организациями были предложены различные варианты реализации IMT-совместимых стандартов. К 1998 году было собрано 17 предложений, а в 1999 году все они были одобрены. Тогда же были опубликованы их спецификации. Наиболее успешные технологии:

- CDMA2000 1Х, 3X

- UMTS (W-CDMA)

- TD-SCDMA

- EDGE (UWC-136)

ИСТОРИЯ

Увеличения мощностей сотовых сетей планировалось достигнуть за счет использования дополнительных диапазонов, а также применения новых методов модуляции, более эффективно использующих имеющиеся частоты. К примеру, на самом нижнем уровне они могут использовать для кодирования данных восьмеричную систему вместо традиционной двоичной. Кроме того, намечается переход от использования систем с временным разделением каналов (TDMA, применяется в GSM и D-AMPS) к технологии CDMA (code-division multiple access, применяется в CDMAOne и CDMA2000).

Изначально за инициативами по созданию и внедрению 3G-систем стояли японские компании. Возможности расширения числа абонентов в рамках используемых ими стандартов (PDC) были тогда почти исчерпаны, а потому, чтобы не допустить кризиса на рынке, требовались радикальные перемены. На других региональных рынках проблемы наращивания мощностей тоже были насущными. Исключением были, разве что, европейские страны, где имеющиеся у GSM-сетей ресурсы еще не были исчерпаны. Но необходимость в современных технологиях передачи данных была актуальной везде.


Спецвыпуск Xakep, номер #034, стр. 034-036-2, ТЕХНОЛОГИЯ Ж-Ж-Ж

ТЕХНОЛОГИЯ Ж-Ж-Ж

Олег "2sheds" Курапов

Спецвыпуск Xakep, номер #034, стр. 034-036-2

Различия в степени проникновения отдельных стандартов в каждой конкретной стране не позволили 3G-сетям превратиться в действительно единую всемирную систему сотовой связи. Так, в Японии на замену PDC был предложен W-CDMA, а операторы Южной Кореи и США, где особенно сильны позиции CDMAOne (IS-95a), взяли курс на постепенный переход к CDMA2000. Астрономические затраты операторов на новые частные диапазоны для 3G вынуждали их искать технологии, внедрение которых позволило бы использовать существующую сетевую инфраструктуру, а также максимально быстро перейти к коммерческой эксплуатации этих сетей.

CDMA2000 1х

Первым, кто представил на рынке телекоммуникаций услуги сотовой связи третьего поколения, стал южнокорейский оператор SK Telecom. Уже 1 октября 2000 года им был запущен сервис NATE на базе переходного стандарта CDMA2000 1x. Еще через полгода были открыты еще 2 сети, принадлежащие KTF и LG Telecom. Такой отрыв корейских компаний объясняется тем, что в этой стране главенствующим стандартом является CDMAOne – единственный из 2G-семейства, основанный на CDMA. Именно поэтому его операторы имеют большое преимущество в плане внедрения 3G.

Сохранение существующей инфраструктуры и поддержка клиентов, имеющих оборудование второго поколения, вместе с обеспечением высоких скоростей соединения для современных 3G-терминалов позволяет компаниям снизить риски инвестиций и быстрее перейти к коммерческой эксплуатации новых технологий. В рамках перехода от старого стандарта к новому оператор может сам решать, в каких узлах сети нужно установить новое оборудование. То есть нет необходимости делать стопроцентный апгрейд, в конечном итоге от этого выиграют все: и потребители, и операторы, и производители оборудования.

Первая фаза CDMA2000 ограничивает максимальную скорость передачи данных величиной 153,6 Кбит/с "вверх" и "вниз" – это почти в три раза быстрее, чем обычный модем, но еще не удовлетворяет всем требованиям IMT-2000. Кроме того, примерно вдвое увеличится время работы телефонов в режиме ожидания и улучшится качество звука. Операторы же оценили возможность быстро развернуть эту технологию поверх имеющихся CDMAOne-сетей без кардинальной перестройки последних, и даже используя тот же частотный спектр (с случае, если базовая сеть использует диапазон 1900 МГц). Уже сейчас эта технология распространилась на 29 стран, а услуги связи предоставляют 53 региональных оператора. Суммарное число их абонентов, как сообщалось в июльском пресс-релизе от CDMA Development Group, превысило 50 миллионов.

CDMA2000 1xEV-DO

На этом южнокорейский пионер 3G-технологий (SK Telecom) не остановился - 28 января 2002 года, то есть меньше, чем через полтора года после запуска в коммерческую эксплуатацию своей сети на базе CDMA2000 1x, они переходят к следующему поколению CDMA-технологий. И опять им удалось опередить ближайших конкурентов на своем рынке (KTF представил аналогичные разработки лишь в начале мая того же года).


Спецвыпуск Xakep, номер #034, стр. 034-036-3, ТЕХНОЛОГИЯ Ж-Ж-Ж

ТЕХНОЛОГИЯ Ж-Ж-Ж

Олег "2sheds" Курапов

Спецвыпуск Xakep, номер #034, стр. 034-036-3

Новый стандарт (также называемый 1x-EV Phase One) отличается от всех остальных тем, что не предусматривает голосовых каналов, буквы DO в аббревиатуре обозначают "Data-only" (только данные). Для функционирования ему требуется один канал IS-95, при этом он предоставляет возможность 6-10-кратного наращивания мощностей по сравнению с CDMAOne и трехкратного по сравнению с CDMA2000. Скорость передачи данных может достигать 2,4 Мбит/с – этого вполне достаточно для передачи mp3-потоков с высоким битрейтом, а также позволяет превратить мобильники в полноценные видеотелефоны с параллельной передачей аудио- и видеоинформации.

CDMA2000 1x EV-DV

Этот стандарт (еще одно название - 1x-EV Phase Two) пока находится в разработке, но потенциально его возможностей хватит для увеличения скорости передачи данных до 3-5 Мбит/с, а буквы DV в названии указывают на добавленную (по сравнению с CDMA2000 1x EV-DO) возможность передачи голоса.

CDMA2000 3x

Еще одна перспективная разработка, отличающаяся шириной используемого частотного спектра – 5 МГц, то есть 3 раза по 1,25 МГц (стандартная ширина спектра, применяемая для CDMA2000). Эта особенность позволяет достичь скоростей в 2-4 Мбит/с. Эта версия была одобрена ITU как соответствующая требованиям IMT-2000, но до внедрения ее на практике пройдет еще несколько лет.

UMTS (W-CDMA)

Разработкой стандарта UMTS (универсальная система мобильных телекоммуникаций) занимается проект 3GPP (партнерский проект создания стандартов третьего поколения). Он должен был упорядочить и согласовать различные предложения и инициативы таких организаций как ESTI (Европейский институт стандартов электросвязи), ARIB (Ассоциация радиопромышленности и вещания) и т.п. Чтобы добиться скорейшего признания во всем мире, UMTS был представлен в виде отдельных фаз и релизов. Первая версия – Rel. '99, вышедшая в декабре 1999 года, содержала инструкции для операторов по оснащению существующих сетей GSM/GPRS дополнительным оборудованием для создания сети UMTS. В этом случае поверх имеющейся внутрисетевой технической части для беспроводной связи используется широкополосный CDMA-интерфейс (отсюда название W-CDMA, то есть Wideband CDMA) с пакетной коммутацией, хотя в стандарте предусмотрено использование на этом уровне самых различных технологий, в том числе DECT и Hiperlan/2.

При внедрении UMTS работоспособность GSM-оборудования сохраняется в полном объеме, а клиенты с телефонами нового поколения будут пользоваться всеми преимуществами широкополосного доступа (скорости до 553 Кбит/с). Правда, на первоначальном этапе эти возможности будут доступны только в тех сегментах сети, где установлены UMTS-модули, а в ближайшее время эти зоны вряд ли выйдут за границы центров крупных городов. Именно поэтому был предусмотрен режим совместимости: там, где соответствующего оборудования пока нет, 3G-телефоны все равно смогут работать, просто часть сервисов будет недоступна, и скорости передачи данных, соответственно, будут ниже (до 172 Кбит/с – это расчетный максимум для GPRS). Передача управления (handover) между ячейками 2G<->3G будет проходить без разрыва соединения, будет изменяться скорость.


Спецвыпуск Xakep, номер #034, стр. 034-036-4, ТЕХНОЛОГИЯ Ж-Ж-Ж

ТЕХНОЛОГИЯ Ж-Ж-Ж

Олег "2sheds" Курапов

Спецвыпуск Xakep, номер #034, стр. 034-036-4

Правда, для обеспечения "преемственности поколений" производителям абонентского оборудования придется включать поддержку и GSM, и W-CDMA, так что на первом этапе пользователям придется мириться с более дорогими, тяжелыми и громоздкими сотовыми телефонами, интенсивно потребляющими энергию.

Ко второму релизу (Rel. '00) аналогичные документы были подготовлены для сетей на базе IS-95 и D-AMPS. Но разработчики планируют, что в большинстве случаев будет использоваться связка W-CDMA и GSM – хотя бы потому, что GSM является самой распространенной технологией сотовой связи на данный момент.

Использование GSM в качестве основы имеет и другие преимущества – тем операторам, которые захотят выйти на рынок, построив собственные UMTS-сети "с нуля", придется очень нелегко. Астрономические цены на частотные диапазоны для 3G и на оборудование, отсутствие абонентской базы (ведь пользователям тоже придется покупать новые телефоны) могут сделать эту задачу непосильной, особенно без такого высокорентабельного источника доходов, как GSM-сети. Чтобы не допустить образования монополий и увеличить уровень конкуренции, могут потребоваться некоторые административные решения, например, новичкам могут разрешить брать в аренду имеющиеся у 2G-компаний мощности. Такой подход не уникален, в некоторых странах сети GSM1800 развивались именно путем сотрудничества с операторами GSM900.

Тем не менее, первым к использованию UMTS-технологий пришел вовсе не GSM-оператор, а японская NTT DoCoMo. В октябре 2001 года DoCoMo запустила W-CDMA-сеть под торговой маркой FOMA ("Freedom Of Mobile multimedia Access" - свобода мобильного мультимедийного доступа). Так как первая фаза CDMA2000, внедренная за полгода до этого в Корее, не соответствовала всем требованиям IMT-2000, можно сказать, что сеть FOMA стала первым "настоящим" 3G-сервисом. Именно здесь пользователям впервые была предоставлена возможность передачи видеопотока, и с самого начала для использования этой разрекламированной функции клиентам были предложены телефоны со встроенной видеокамерой.

В режиме коммутации пакетов передача данных ведется на скоростях до 384 Кбит/с, но, при желании пользователь может переключиться в режим коммутации каналов (в этом случае доступны скорости до 64 Кбит/с). Это позволит экономить деньги на счету, если есть необходимость в скачивании больших объемов данных, потому что вместо тарификации по трафику используется повременная оплата. Среди других доступных сервисов имеется, например, новая версия сверхпопулярного i-mode – мультимедийного аналога WAP-технологии.

Позднее сети этого стандарта открыли японское подразделение телекоммуникационной корпорации Vodafone, австрийский оператор Mobilkom, а также несколько филиалов Hutchinson (в Австралии, Австрии, Великобритании, Италии и Швеции). На данный момент суммарное количество подписчиков в W-CDMA-сетях превысило 700 тысяч и продолжает динамично расти.


Спецвыпуск Xakep, номер #034, стр. 034-036-5, ТЕХНОЛОГИЯ Ж-Ж-Ж

ТЕХНОЛОГИЯ Ж-Ж-Ж

Олег "2sheds" Курапов

Спецвыпуск Xakep, номер #034, стр. 034-036-5

TD-SCDMA

Этот стандарт был разработан группой китайских компаний. Аббревиатура TD-SCDMA обозначает Time Division Synchronous CDMA, то есть CDMA с синхронным кодово-временным разделением каналов. Хотя кажется, что одно противоречит другому, на самом деле этот стандарт использует для передачи данных кодовое разделение, как и подобает CDMA, а по времени разносятся входящий и исходящий каналы. Во всех остальных технологиях между ними существует разрыв полосы частот для исключения интерференции, но для TD-SCDMA становится возможным использование непарного спектра. Это позволяет рациональнее применять имеющиеся ресурсы и гибко перераспределять их между входящим и исходящим трафиком в соответствии с потребностями пользователя.

Еще одно ноу-хау, вошедшее в этот стандарт – так называемые "умные антенны", устанавливаемые на базовых станциях. Эти двунаправленные антенны представляют собой массивы элементов с программируемыми фазовыми характеристиками. Благодаря этому, а также последним наработкам в области DSP-технологий, каждое подключение мобильного телефона к базовой станции обеспечивается направленным соединением, причем количество одновременно обслуживаемых пользователей может быть очень большим. Эффективность такого подхода определяется как раз использованием непарных каналов, передающих трафик в обоих направлениях на одной частоте. Применение двунаправленных "умных антенн" позволяет увеличить радиус охвата базовых станций и, соответственно, уменьшить их количество, а также снизить межсотовую интерференцию по сравнению с традиционными технологиями, использующими постоянное излучение на 360 градусов вокруг.

Несмотря на свои преимущества, усложнения, введенные в TD-SCDMA по сравнению с остальными технологиями, требуют обеспечения определенной избыточности передаваемых данных. К примеру, у W-CDMA тоже предусмотрен подобный режим (он называется TDD – дуплексное временное разделение), но обычно по техническим причинам непарным делается лишь один из каналов, а остальные продолжают использоваться в обычном режиме (FDD – дуплексное частотное разделение). Кроме того, не во всех странах выдаются разрешения на более узкие полосы спектра, необходимые для непарных каналов, а переплачивать миллиард-другой долларов за неиспользуемые частоты операторы вряд ли станут. Но с этим стандартом нельзя не считаться, ведь рынок телекоммуникаций в КНР является лакомым куском для любой компании, работающей в этой отрасли.

EDGE

Но не все 3G-стандарты используют CDMA. Приверженцы TDMA-технологий представили EDGE (Enchanced Data Rates for GSM Evolution - "Даешь больше скорости для GSM!"). Как видно из названия, в качестве основы рассматриваются имеющиеся GSM/GPRS-сети. В отличие от UMTS этот стандарт не позиционировался как соперник для 3G-технологий на базе CDMA. Изначально планировалось, что пока операторы будут строить базу для UMTS, введение EDGE позволит им предоставить своим клиентам продвинутые технологии передачи данных, более скоростные, чем GPRS.


Спецвыпуск Xakep, номер #034, стр. 034-036-6, ТЕХНОЛОГИЯ Ж-Ж-Ж

ТЕХНОЛОГИЯ Ж-Ж-Ж

Олег "2sheds" Курапов

Спецвыпуск Xakep, номер #034, стр. 034-036-6

Эти планы изменились после того, как EDGE перешел под крыло UWCC (Консорциум универсальных технологий беспроводной связи), где был дополнительно разработан вариант перевода распространенных в США сетей D-AMPS ("Global Evolution"). В 2000 году этот проект был принят как выполняющий требования IMT-2000 и получил официальное наименование UWC-136.

При использовании той же структуры TDMA-пакетов, которая использовалась в GSM и D-AMPS, благодаря новому методу модуляции под названием 8PSK, станет возможна передача до 48 Кбит/с для каждого используемого слота, а применение нескольких слотов (как и в GPRS) позволит довести скорость до 384 Кбит/с. Вторая фаза внедрения стандарта EDGE будет включать в себя переход к технологии "Voice over IP".

ШИРОКОПОЛОСНЫЙ ДОСТУП В ИНТЕРНЕТ

Переход к IP-технологиям, огромные скорости передачи информации – все это нужно в том числе и для доступа в интернет. Уже сейчас многие зарубежные провайдеры вынуждены рассматривать мобильный доступ как серьезную угрозу. Кому будут нужны модемы или выделенные линии, если уже сейчас за 90 зеленых в месяц можно получить безлимитный доступ в интернет со скоростями, в 5-10 раз превышающими диалап, который к тому же всегда с собой: дома, на работе и в транспорте. Будущее интернета за мобильными телефонами!

ВИДЕОКОНФЕРЕНЦИЯ

Разговор по видеотелефону – не фантастика. Клиенты W-CDMA-сетей уже давно получили такую возможность. Телефоны со встроенными камерами становятся все более доступными (конечно, с поправкой на то, что 3G-телефонов дешевле 300 зеленых вообще не бывает), абоненты входят во вкус, для них открываются специальные порталы с адаптированным под низкое разрешение видеоконтентом. Сам не пробовал, но другие абоненты отзываются об этом восторженно (я пробовал, впечатляет - прим. ред.).

ГЕОПОЗИЦИОНИРОВАНИЕ

Попытки найти способ определения местоположения абонентов на основе информации от базовых станций предпринимались задолго до внедрения 3G-стандартов. Даже некоторые российские операторы начали вводить в сетях GSM подобные сервисы, хотя, по отзывам пользователей, точность у них была довольно низкой – несколько сотен метров, а этого может быть достаточно где-нибудь в горах, но не в городских условиях. Только переход к новым стандартам позволит сделать эту услугу доступной для всех пользователей.

Инициатива американских властей по интеграции сотовых сетей со службой "911", названная Enhanced 911, подтолкнула разработчиков и операторов к созданию такой системы в кратчайшие сроки. Согласно требованиям FCC (Федеральной частотной комиссии), к концу 2005 года 95% телефонов должны поддерживать передачу информации о своем местоположении.

И опять W-CDMA впереди планеты всей. Пока для пользователей стали доступны только базовые сервисы, выводящие по первому запросу карту местности с крестиком и надписью "You are here", а уже в ближайшем будущем, после создания централизованных баз данных, любой абонент сможет получить массу полезной информации о различных учреждениях, находящихся в его дельта-окрестности. Но и это лишь самые простые примеры, а сколько всего еще можно придумать: MMS-спам от каждого злачного заведения, мимо которого ты проходишь, круглосуточная слежка со стороны спецслужб и многое, многое другое :).


Спецвыпуск Xakep, номер #034, стр. 034-036-7, ТЕХНОЛОГИЯ Ж-Ж-Ж

ТЕХНОЛОГИЯ Ж-Ж-Ж

Олег "2sheds" Курапов

Спецвыпуск Xakep, номер #034, стр. 034-036-7

ЗАКЛЮЧЕНИЕ

Если на рынке персональных компьютеров работает формула "клиент покупает мегагерцы" (а теперь уже и гигагерцы), то у телекоммуникационных компаний другая мантра: "Клиент покупает не технологии, а сервисы". Любой стандарт, будь он первого поколения или третьего, хорош или плох ровно настолько, насколько привлекательны его услуги для потребителя. Правда, потом еще надо очень тщательно объяснить (а лучше навязать) клиенту, почему он не может жить без новой модели телефона, но это уже совсем другая история...

ПОЛЕЗНЫЕ ССЫЛКИ

www.itu.int (International Telecommunication Union, ITU)

www.umts-forum.com (UMTS Forum)

www.cdg.org (CDMA Development Group)

www.tdscdma-forum.org/nenglish (TD-SCDMA Forum)

www.3gpp.org (Third Generation Partnership Project)

www.3gamericas.org (EDGE)

www.3gtoday.com

www.3g-mobile.ru

Увеличения мощностей сотовых сетей планировалось достигнуть за счет использования дополнительных диапазонов, а также применения новых методов модуляции, более эффективно использующих имеющиеся частоты.

Первым, кто представил на рынке телекоммуникаций услуги сотовой связи третьего поколения, стал южнокорейский оператор SK Telecom.

При внедрении UMTS работоспособность GSM-оборудования сохраняется в полном объеме, а клиенты с телефонами нового поколения будут пользоваться всеми преимуществами широкополосного доступа (скорости до 553 Кбит/с).

Использование GSM в качестве основы имеет и другие преимущества: тем операторам, которые захотят выйти на рынок, построив собственные UMTS-сети "с нуля", придется очень нелегко.

"Умные антенны" представляют собой массивы элементов с программируемыми фазовыми характеристиками.

Но не все 3G-стандарты используют CDMA. Приверженцы TDMA-технологий представили EDGE (Enchanced Data Rates for GSM Evolution - "Даешь больше скорости для GSM!").

Кому будут нужны модемы или выделенные линии, если уже сейчас за 90 зеленых в месяц можно получить безлимитный доступ в интернет со скоростями в 5-10 раз превышающими диалап, который к тому же всегда с собой!

Разговор по видеотелефону – не фантастика. Клиенты W-CDMA-сетей уже давно получили такую возможность.

Инициатива американских властей по интеграции сотовых сетей со службой "911", названная Enhanced 911, подтолкнула разработчиков и операторов к созданию такой системы в кратчайшие сроки.

Если на рынке персональных компьютеров работает формула "клиент покупает мегагерцы" (а теперь уже и гигагерцы), то у телекоммуникационных компаний другая мантра: "Клиент покупает не технологии, а сервисы".


Спецвыпуск Xakep, номер #034, стр. 034-040-1, Голография – фантастика или реальность?

Голография – фантастика или реальность?

Андрей Смирнов

Спецвыпуск Xakep, номер #034, стр. 034-040-1

Кто изобрел робота, космический корабль или персональный компьютер? Ты скажешь, что это был какой-то ученый, инженер или, на худой конец, сумасшедший изобретатель, и будешь прав, но только наполовину.

Все самое интересное в нашей жизни изобретают, вернее, придумывают писатели-фантасты. Ученые только превращают эти "изобретения" в реальность. Есть такой человек и в истории голографии. Правда, можно ли его назвать ученым, судить тебе, потому что имя ему - Сальвадор Дали. Его голограммы Нью-Йорк увидел еще в 1972 году.

Голограмма может быть в виде световой проекции какого-то предмета или просто в виде картинки, которая выглядит трехмерной. Помнишь господина по фамилии Распутин, который на бутылке с одноименной водкой подмигивал нам одним глазом? Это голограмма. А помнишь Звездные Войны, где для передачи сообщений использовались объемные изображения человека? Это тоже голограммы.

Как получается реальное третье измерение

Для того чтобы показать отличия голограммы от других видов изображений, лучше всего сравнить ее с картиной. Изображение на картине отображает двухмерную проекцию трехмерного мира. Художники стараются показать трехмерность за счет разных уловок, типа уменьшения и размытия удаленных объектов, отображения перспективы, но все равно, это проекция и она ограничена двумя измерениями. Ты можешь смотреть на картину под любым углом, и от этого ничего не изменится.

Но картину рисует человек, и ее реалистичность зависит от мастерства художника. Поэтому лучше рассмотрим фотографию. Она тоже отражает двухмерную проекцию снимаемого объекта и так же статична под любым углом обзора. Когда ты рассматриваешь какой-нибудь пейзаж, то можешь только сказать, что один предмет находится дальше другого, но не можешь оценить расстояние между ними, если в глаза не видел снимаемой сцены.

Информация о третьем измерении сохраняется на фотографии не полностью из-за того, что пленка регистрирует лишь интенсивность света. А самое главное, фаза световой волны, которая зависит от расстояния от объектива до предмета, на фотопленке не записывается.

Когда я вплотную занялся проблемой голографии, то больше всего меня поразил человеческий глаз. Ведь изображение, которое падает на сетчатку, ничем не отличается от него же на пленке фотоаппарата, и мы, по идее, должны получать проекцию трехмерного мира на наш глаз, теряя информацию об объеме. Но этого не происходит. Весь секрет в том, что у нас (вернее, у большинства из нас ;)) два глаза и один мозг. И глаз обладает интересным свойством - аккомодацией, а мозг по малейшим изменениям картинки способен синтезировать трехмерное изображение.

Аккомодация – это возможность человеческого глаза как оптической системы изменять фокусное расстояние. Например, ты смотришь в окно, разглядываешь на улице какой-то предмет и абсолютно не замечаешь стекло. Проходит доля секунды, и ты уже смотришь на стекло, а все что дальше уходит из фокуса.

Но это еще не все, одного изменения фокуса мало. Дело в том, что изображение, переданное в мозг симметричными участками сетчатки двух глаз, слегка различается, а сами глаза постоянно совершают мелкие установочные движения - и именно эта "небольшая" разница в 2D-изображениях позволяет мозгу в конечном итоге вычислять расстояние между предметами и воспринимать мир в 3D. Это называется "стереоскопическим зрением", оно совершенствуется в течение всей жизни - пока мозг собирает и анализирует информацию о строении различных предметов.


Спецвыпуск Xakep, номер #034, стр. 034-040-2, Голография – фантастика или реальность?

Голография – фантастика или реальность?

Андрей Смирнов

Спецвыпуск Xakep, номер #034, стр. 034-040-2

Ну да хватит об анатомии, перейдем к более понятным для нас вещам - а именно физике и компьютерам. Уже существует несколько способов сделать какую-либо сцену трехмерной. В компьютерном мире используется принцип анатомии человеческого глаза, а при построении сложных голограмм используется физика. Я кратко опишу компьютерный способ создания 3D и максимально подробно остановлюсь на физических законах, причем постараюсь все объяснить доступным языком.

Первые попытки

Первые попытки создать трехмерное изображение в компьютере основывались на простейшем стереоэффекте. У человека два глаза, и для каждого из них подавалось свое отображение мира с небольшим смещением. Таким образом, наш мозг, собирая две картинки вместе, получал достаточно информации об объеме, и мы смогли увидеть игры в практически реальном третьем измерении.

Именно по такому принципу построены очки и шлемы виртуальной реальности. В самом дешевом варианте за отображение отвечает монитор, а очки просто поочередно закрывают один, а затем другой глаз. При этом у монитора должна быть частота не менее 120 Гц (по 60 на каждый глаз, потому что монитор должен показывать информацию для двух глаз, а очки уже разделяют эту инфу на левый и правый), чтобы мы могли нормально видеть сцену.

В более дорогом варианте в шлем встраиваются два экрана, которые независимо отображают картинку на оба глаза одновременно. Тут уже качество сцены зависит от разрешения и частоты обновления экрана.

3D без очков

Пока я рассказал только об основах того, как наши глаза видят мир трехмерным, и объяснил основы создания третьего измерения с помощью компьютерных примочек. Более подробно про третье измерение для своего железного друга читай в этом же номере, а я перейду к рассмотрению реальной голографии.

Изобретателем голографии считается английский физик доктор Деннис Габор (Dr. Dennis Gabor), который в 1947 году обратил внимание на один парадокс – когда мы фотографируем, постоянно приходится настраивать фокус. При этом, если фокус нестроен неправильно, изображение может быть искаженным или вообще исчезнет. Но в реальности оно никуда не исчезает. Предмет как стоял на месте, так и стоит, просто он оказался не в фокусе. Таким образом Габор пришел к выводу, что изображение в каком-либо виде находится в самой структуре световой волны, которая проходит от предмета до фотопленки.

Чтобы ты ощутил гордость за нашу родину, я просто обязан сказать, что после этого в теории голографии не происходило практически ничего интересного вплоть до 60-х годов. Именно тогда громадный вклад в эту сферу внес наш земляк Ю.Н.Денисюк, ну и, конечно же, двое ученых из далекой Америки - Э.Лейт и Ю.Упатниекс (Emmett Leith и Juris Upatnieks) из Мичиганского университета.


Спецвыпуск Xakep, номер #034, стр. 034-040-3, Голография – фантастика или реальность?

Голография – фантастика или реальность?

Андрей Смирнов

Спецвыпуск Xakep, номер #034, стр. 034-040-3

Двое американских ученых продолжили дело Габора и в результате получили первую голограмму трехмерного объекта, передаваемую лазером. Им удалось создать 3D-изображения игрушечного поезда и птицы, которые ты можешь увидеть на рисунке 3.

Физика света

Теперь, думаю, ты готов познакомится с физическими основами голографии. Сейчас мы посмотрим, что происходит с нашим восприятием света с точки зрения физики,

По современным физическим представлениям, мы "видим" физические тела (в частности, окружающие нас предметы), благодаря их способности излучать и отражать свет.

Светом - видимым оптическим излучением - называют электромагнитные волны длиной 0,38-0,76 нм (в этом диапазоне они вызывают у нас зрительные ощущения). То есть свет имеет такую же физическую природу, как и, к примеру, радиоволны. Только у последних частота находится в диапазоне приблизительно от нуля до 100 Герц, а у видимого света - в 10 миллионов раз больше: самые "медленные" из световых волн имеют частоту примерно 5*10 в 14 степени Герц. Эта частота соответствует красному цвету. Честно говоря, оптика не самый простой раздел физики, хотя бы потому, что невозможно свет "пощупать и рассмотреть со всех сторон".

Все знают, что скорость света (в вакууме) максимальна и равна 300000 км/ч. Расстояние, которое волна проходит за одно колебание, называется длиной световой волны. Длина волны - это минимальное расстояние, на котором колебания происходят в одной фазе (смотри рисунок 4).

Это самое необходимое из того, что нужно знать о свете для понимания принципов голографии. Теперь нам осталось только понять физику нашего зрения.

Рассмотрим простейший пример – монохроматическую волну (т.е. "бесконечную синусоиду", ее участок изображен на рисунке 4). Источник света точечный: его размеры столь малы, что ими можно пренебречь, а внутренняя структура несущественна при нашем рассмотрении.

Любая точка пространства характеризуется двумя величинами: амплитудой волны и ее фазой (фаза - это то, что находится под знаком синуса в волновой функции). Поверхность, в каждой точке которой фаза одинакова - поверхность постоянных фаз - называется фронтом волны.

Чтобы все вышесказанное не казалось тебе запудриванием мозгов, рассмотрим несколько примеров.

Пусть наша волна плоская, т.е. ее фронт - плоскость. Если взять какую-нибудь фиксированную точку на пути распространения волны и посмотреть на изменение амплитуды, мы увидим, что она будет изменяться по синусоидальному закону с тем же периодом колебаний. Получается, что во времени и пространстве волна движется как бы параллельно самой себе вдоль какой-то оси. Усложним задачу: пусть источник испускает волны равномерно во все стороны - типичный точечный источник. Теперь одинаковую фазу будет иметь множество точек, расположенных на одинаковом расстоянии от источника. Если помнишь школьную геометрию, такая поверхность называется сферой, а волна, соответственно, сферической. По мере удаления от источника, радиус сферы увеличивается. Для определения расстояния до источника нам достаточно определить кривизну волнового фронта (радиус сферы). Вот оно третье измерение – кривизна волнового фронта, которая, если учесть еще и анатомию человеческого глаза, дает нам полное представление об объеме. Именно эту информацию фотографии теряют и не могут отразить на фотобумаге: ведь на пленке регистрируется интенсивность излучения (средний квадрат амплитуды), а фаза - нет.


Спецвыпуск Xakep, номер #034, стр. 034-040-4, Голография – фантастика или реальность?

Голография – фантастика или реальность?

Андрей Смирнов

Спецвыпуск Xakep, номер #034, стр. 034-040-4

Бег с препятствиями

А что будет, если на пути распространения волны появится препятствие? При прохождении препятствия волновой фронт, конечно же, изменится. В подобных фазовых искажениях и амплитуде волн и "сохраняется" информация о форме предмета.

И Д.Габор решил записывать не только амплитуду, но и фазу. Тогда по сохраненным данным можно восстанавливать полное изображение предмета. Что, собственно, и было успешно проделано Габором.

Самая главная проблема, с которой боролся Габор – определение фазы высокочастотных колебаний. В те времена не существовало техники, способной ее измерить. Но решение оказалось простым: он использовал два источника света - объектный и опорный.

Сейчас для создания голограммы используется специальный носитель информации (например, фотопластина), на который записывается отражение двух световых волн: отраженный свет от объекта и специальный опорный свет от лазерного источника. Чтобы "увидеть" голограмму, нужно осветить ее таким же опорным светом, лучи которого должны идти в обратном направлении. Такой способ освещения называется «обратным ходом».

Создание голограммы

На рисунке 7 показана схема голограммы на защищенной от вибрации поверхности в абсолютно темной комнате. Эта экспозиция должна создаваться в окружении без движения и вибраций. Каждое движение изменяет волну света и предотвращает запись изображения на пленку.

Луч лазерного света оптически разделяется на два. Один луч направляется на часть пленки будущей голографии и расширяется (увеличивается диаметр) так, что свет покрывает пленку равномерно и полностью. Второй луч направляется на объект композиции и также расширяется, чтобы осветить его.

Для расширения лучей используется линза. На схеме показаны две линзы для обоих лучей.

Когда лучи объекта отражаются от предмета, они несут информацию о расположении, размере, форме и текстуре предмета. Некоторые из отраженных лучей объекта после этого встречаются с направляющими лучами на голографической пленке, создавая интерференционную модель, которая записывается на чувствительной к свету эмульсии.

Термины

Надо бы пояснить некоторые термины, чтобы тебе легче было понять схему на рисунке 7 и принцип работы записи голограммы.

Разделитель лучей - устройство, используемое для разделения света от лазера на два отдельных луча. Оно состоит из частично прозрачного зеркала, которое часть света пропускает, а часть отражает.

Пленка – может быть фотографическая или голографическая и состоит из светочувствительного химического (эмульсионного) состава на поверхности. Поскольку голографическая пленка должна иметь возможность записывать более детальную информацию, она должна иметь разрешающую способность в 50 и более раз выше, чем фотографическая пленка.


Спецвыпуск Xakep, номер #034, стр. 034-040-5, Голография – фантастика или реальность?

Голография – фантастика или реальность?

Андрей Смирнов

Спецвыпуск Xakep, номер #034, стр. 034-040-5

Лазер (LASER - Light Amplification by Simulated Emission of Radiation) - устройство, которое создает сконцентрированные лучи когерентного монохроматического света.

Линза - устройство, которое переориентирует свет. В фотографии линза применяется для фокусирования изображения на пленку. Голография использует линзу для расширения лазерных лучей для освещения всех предметов.

Лучи объекта - свет от лучей лазера, которые освещают объект и отражаются на голографической пленке.

Направляющие лучи - часть лазерных лучей, которые направляются прямо на голографическую пленку. Интерференционная модель, которая получается от лучей объекта, встречающихся с направляющими лучами на голографической пленке, записываются на пленке.

Применение

Почему голограммы так быстро развиваются в последние несколько лет? Все очень просто - для многих корпораций это отличный способ защитить свой товар от подделок. Подделать голограмму в гаражных условиях очень сложно, хотя наши умельцы делают все. Лично я видел различные подделки, которые ничем не отличались от оригинала.

С возросшей популярностью голографических технологий уменьшается стоимость и сложность производства голограмм. Оборудование для производства достать уже не так сложно, да и стоит оно не так дорого, поэтому этот способ защиты от подделок скоро станет бессмысленным. Я, конечно, могу ошибаться, но пока практика показывает именно это.

В любом случае, уже сейчас в Москве можно без проблем купить оборудование для создания голограмм, были бы деньги.

А дальше

Более детальное рассмотрение голографии требует фундаментальных познаний в физике (оптике), которая сильно завязана с высшей математикой. Если тебя заинтересовала голография, во врезке есть несколько ссылок, где можно узнать о ней немного больше. Я же показал тебе основы и постарался заинтересовать этой перспективной технологией. А будущее у голографии действительно есть, и я думаю, светлое.

На этом и остановимся. Удачи тебе в твоих голографических начинаниях.

Ссылки по теме

www.holophile.com/ - если знаешь английский, обязательно посети этот сайт фирмы Holophile, Inc., которая уже довольно известна на рынке голограмм.

http://bsfp.media-security.ru/school3/index.htm - как гласит страница, это материалы Третьей всесоюзной школы голографии. Сюда можешь идти только со знанием основ. Некоторые статьи требуют хорошего понимания физики и основ голографии, а некоторые будут полезны просто для домашнего чтения.

www.media-security.ru/ - сайт фирмы «Медиа security», где представлены образцы голограмм, с помощью которых фирмы защищают свою собственность от подделок.

www.holography.ru/holoflash.htm - виртуальная галерея голографии.

http://phys.web.ru/index.html - научно-образовательный сервер по физике. Здесь находится множество материалов по физике голограммы и о том, как работает оборудование.

Голограмма может быть в виде световой проекции какого-то предмета или просто в виде картинки, которая выглядит трехмерной. Помнишь господина по фамилии Распутин, который на бутылке с одноименной водкой подмигивал нам одним глазом? ХХХХХХХХХХХХХХХХ


Спецвыпуск Xakep, номер #034, стр. 034-040-6, Голография – фантастика или реальность?

Голография – фантастика или реальность?

Андрей Смирнов

Спецвыпуск Xakep, номер #034, стр. 034-040-6

Первые попытки создать трехмерное изображение в компьютере основывалось на простейшем стереоэффекте. У человека два глаза, и для каждого из них подавалось свое отображение мира с небольшим смещением.

Изображение на картине отражает двухмерную проекцию трехмерного мира. Художники стараются показать трехмерность за счет разных уловок, типа уменьшения и размытия удаленных объектов.

Для многих корпораций это отличный способ защитить свой товар от подделок. Подделать голограмму в гаражных условиях очень сложно, хотя наши умельцы могут все.


Спецвыпуск Xakep, номер #034, стр. 034-044-1, Всемогущий Flash

Всемогущий Flash

Докучаев Дмитрий aka Forb

Спецвыпуск Xakep, номер #034, стр. 034-044-1

(forb@real.xakep.ru)

История создания и принцип работы суперпамяти

Сегодня мы поговорим о памяти, а именно о том, как новая Flash-memory постепенно завоевывает свое законное первое место на полупроводниковом рынке.

Как известно, память бывает двух видов: энергозависимая и энергонезависимая. Так как Flash относится ко второму виду (питание необходимо лишь для процесса записи/перезаписи), рассмотрим историю развития энергонезависимой памяти.

Вначале был ROM...

Первой энергонезависимой памятью была ROM (ПЗУ) - Read Only Memory. Из названия становится понятно, что данный тип имеет единственный цикл записи. Он осуществляется сразу при производстве, путем нанесения алюминиевых дорожек между ячейками ROM литографическим способом. Наличие такой дорожки означает 1, отсутствие 0.

К сожалению, этот вид памяти не приобрел большой популярности, так как процесс изготовления микросхемы ROM занимает длительное время (от 4 до 8 недель). Но, как это ни парадоксально, стоимость памяти довольно низкая (естественно, при больших объемах производства), а информацию с нее можно стереть только молотком или паяльной лампой.

Начало положено!

Естественно, что ROM дело не ограничилось. Возникла острая необходимость в перезаписи памяти, а каждый раз выпускать ПЗУ с новыми данными было дорого и нерационально. Поэтому ROM сменила PROM (Programmable ROM). Микросхему с такой памятью можно было подвергнуть повторному (правда, единственному) прожигу с помощью специального устройства – программатора.

Дело в том, что PROM производилась немного по другой технологии. Дорожки между ячейками были заменены плавкими перемычками, которые могли быть разрушены путем подачи высокого напряжения на микросхему. Таким образом появляется единственный цикл перезаписи.

Поколение NVRWM. Рождение EPROM

Как было сказано выше, ROM и PROM относятся к виду неперезаписываемой энергонезависимой памяти. В 1971 году Intel выпускает совершенно новую микросхему памяти под аббревиатурой EPROM (Erasable Programmable ROM). Такую микросхему можно было подвергать неоднократной перезаписи путем облучения чипа рентгеновскими или ультрафиолетовыми лучами. Память, стираемая ультрафиолетом, появляется немного позднее и носит аббревиатуру UV-EPROM. В такой микросхеме имеется небольшое окошко с кварцевым стеклом. За ним находится кристалл (я уверен, ты не раз видел такие микросхемы в старых советских компьютерах ;)), который облучается ультрафиолетом. После стирания информации это окошко заклеивают.

Частичная перезапись данных по-прежнему остается невозможной, так как рентгеновские и ультрафиолетовые лучи изменяют все биты стираемой области в положение 1. Повторная запись данных осуществляется также на программаторах (как в ROM и EROM).

Вообще, EPROM была основана на МОП (металл-оксид-полупроводник) транзисторах. Запись данных в ячейки такого транзистора производилась методом лавинной инжекции заряда (о методах записи будет сказано ниже). Этот метод давал возможность неоднократно перезаписывать данные памяти (хотя количество циклов было ограниченным). Таким образом, вместе с EPROM рождается поколение NVRWM, что расшифровывается как NonVolatile Read-Write Memory. Но, несмотря на абсолютно новую технологию, этот вид был вытеснен с рынка другими видами памяти. Хочешь знать какими? Тогда читай дальше!


Спецвыпуск Xakep, номер #034, стр. 034-044-2, Всемогущий Flash

Всемогущий Flash

Докучаев Дмитрий aka Forb

Спецвыпуск Xakep, номер #034, стр. 034-044-2

EEPROM - Electronically EPROM

Через восемь лет после выхода EPROM, Intel разрабатывает новый вид памяти, которая могла быть перезаписана частями. С помощью электрического тока становилось возможным изменение данных в определенной ячейке микросхемы. Это нововведение уменьшало время программирования, а также позволяло отказаться от внешних устройств-программаторов. Для записи данных память достаточно было подключить к системной шине микропроцессора, что значительно упрощало работу с микросхемой.

За удовольствие надо платить... Поэтому стоимость EEPROM была высокой. Это неудивительно, так как технологии производства такой памяти были очень сложными. В отличие от предыдущего EPROM, увеличивалось количество циклов перезаписи информации.

Flash правит миром

Наконец в 1984 году компания Toshiba разрабатывает принципиально новый вид памяти под названием Flash. Через четыре года Intel выпускает свой вариант Flash-памяти (поэтому иногда ее создание незаслуженно приписывают этой компании).

Но обо всем по порядку. Как я уже сказал, Flash-memorу была создана в 1984 году. Сразу после этого начался интенсивный процесс развития этого вида, а на ее предшественницу торжественно забили (хотя EEPROM еще долгое время рулил на рынке).

Устройство Flash имеет довольно сложную структуру. Дело в том, что процессы перепрожига микросхемы базируются на законах квантовой механики. Если ты не прогуливал скучные пары этого предмета и внимательно слушал препода, ты меня поймешь.

В самом простом случае ячейка Flash состоит из одного полевого транзистора. Элемент включает в себя специальную электрически изолированную область, называемую “плавающим затвором”. Этот термин возник из-за того, что потенциал этой области не является стабильным, что позволяет накапливать в ней электроны (именно здесь и хранится вся информация памяти). Выше “плавающего” находится управляющий затвор, который является неотъемлемой частью при процессе записи/стирания данных памяти. Эта область напрямую соединена с линией слов. Перпендикулярно этой линии располагается линия битов, которая соединена со стоком (при записи данных из этой области транзистора появляется поток электронов). Сток разделяется с истоком специальной подложкой, которая не проводит электрический ток.

Запись данных во Flash происходит методом инжекции "горячих" электронов, а стирание – методом туннелирования Фаулера-Нордхейма. Остановимся на них подробнее.

Механические процессы во Flash

Принцип чтения микросхемы Flash довольно прост и, как я уже сказал, базируется на законах квантовой механики. При извлечении данных из памяти, заряд на “плавающем” затворе отсутствует, а на управляющий затвор подается заряд положительного направления. Под его воздействием между стоком и истоком создается канал трассировки (свободная зона на кристалле транзистора, выделенная для реализации межсоединений ячеек). Все это происходит за счет туннельного эффекта, а данные памяти затем можно считывать с истока.


Спецвыпуск Xakep, номер #034, стр. 034-044-3, Всемогущий Flash

Всемогущий Flash

Докучаев Дмитрий aka Forb

Спецвыпуск Xakep, номер #034, стр. 034-044-3

Если на “плавающем” затворе имеется заряд, то обычного напряжения (которое подается при чтении Flash) недостаточно. Поэтому при записи применяют метод инжекции электронов. Суть его заключается в следующем: на управляющий затвор и исток подается высокое напряжение (причем на затворе оно в два раза выше). Благодаря этому напряжению, электроны способны преодолеть тонкую пленку диэлектрика и попасть на “плавающий” затвор. Такой процесс получил название “инжекция горячих электронов” (термин “горячий” условен, электроны были названы так, потому что обладают высокой энергией, которой хватает для преодоления диэлектрика).

Чтобы стереть информацию из памяти, достаточно подать высокое положительное напряжение на исток. Под его воздействием отрицательные электроны с “плавающего” затвора (благодаря туннельному эффекту) переходят в область истока. Процесс продолжается до полной разрядки затвора. Ускорить метод туннелирования электронов можно путем подачи дополнительного высокого отрицательного напряжения на управляющий затвор. При этом электроны с “плавающего” затвора будут отталкиваться в сторону диэлектрика, а время эффекта значительно уменьшится.

Прогрессивное развитие Flash

Мы рассмотрели простейший случай, когда каждая ячейка Flash хранит один бит информации и состоит из одного полевого транзистора. Прогресс не стоит на месте, через несколько лет после выпуска чудо-микросхемы были проведены успешные испытания флешек, в которых ячейка хранила уже два бита. Естественно, что на такую память можно было записать в два раза больше информации. В настоящее время уже существуют теоретические разработки памяти с четырехбитными ячейками.

Как же устроена такая ячейка? Ведь из курса архитектуры известно, что наличие заряда означает 1, отсутствие 0, остальные значения представить невозможно. На самом деле, в микросхеме с MLC (Multi Level Cell) существует различие величин заряда, которые накапливаются на “плавающем” затворе. Благодаря этому различию, информация в ячейке может быть представлена различными битовыми комбинациями. Величину заряда на затворе можно определить измерением порогового (максимального) напряжения транзистора и по итогам этого измерения представить битовую комбинацию.

Перезапись и стирание Flash значительно изнашивает микросхему, поэтому технологии производства памяти постоянно совершенствуются, внедряются оптимизирующие способы записи микросхемы, а также алгоритмы, направленные на равномерное использование всех ячеек в процессе работы.

Виды доступа к Flash-memory

Различают три метода доступа к микросхеме: обычный, пакетный и страничный. Все они используются в зависимости от ситуации.

1.Обычный доступ. Тут ничего сложного. Происходит обычное асинхронное чтение определенных ячеек. Используется, когда необходимо считать малое количество информации с микросхемы памяти.


Спецвыпуск Xakep, номер #034, стр. 034-044-4, Всемогущий Flash

Всемогущий Flash

Докучаев Дмитрий aka Forb

Спецвыпуск Xakep, номер #034, стр. 034-044-4

2.Пакетный доступ. Данные при таком виде доступа читаются параллельно блочным образом. Возможно считывание блока размером от 16 до 32 бит за один раз. После чтения информации в буфер происходит синхронизация блоков, и, в конечном итоге, данные передаются уже последовательно. Такой метод значительно быстрее обычного доступа, но проигрывает ему при чтении определенных ячеек памяти.

3.Страничный доступ. По принципу напоминает пакетный вид, но данные принимаются асинхронно. Размер принимаемой страницы составляет 4-8 байт. Этот вид доступа самый быстрый. Единственный его недостаток – относительно медленное переключение между блоками.

Форматы карт Flash

В последнее время Flash реализуется только на картах. Это обусловлено тем, что этот вид памяти используется, как правило, в таких устройствах, как mp3-плееры, сотовые телефоны, электронные часы, цифровые камеры, различного рода маршрутизаторы и т.д. и т.п. Иными словами, использовать карты Flash намного рациональнее, чем отдельные микросхемы. Естественно, что форматы таких карт различны. Основная классификация дает понятие о Flash с последовательным и параллельным интерфейсом. К последним относятся PC-Card (ATA Flash), CF (Compact Flash), SmartMedia. "Последовательные" карты сейчас не менее популярны: к ним относятся MMC (MultiMedia Card и самый популярный сейчас формат SD-Card.

К сожалению, размер статьи не ползволяет мне подробно описать все эти форматы. Но подобной информации полно в Сети. Куда тебя, с позволения, и отправляю

И в заключение...

Flash-memory еще находится на стадии развития, и неизвестно, что нас ждет через несколько лет. По компьютерным прогнозам, через 5-6 лет произойдет расцвет Flash на полупроводниковом рынке, в результате которого у этого вида энергонезависимой памяти практически не будет конкурентов. Хотя утверждать что-либо с уверенностью еще рано – быть может, будут созданы принципиально новые технологии, против которых не устоит даже Flash...

У PROM дорожки между ячейками были заменены плавкими перемычками, которые могли быть разрушены путем подачи высокого напряжения на микросхему. Таким образом, появляется единственный цикл перезаписи.

В 1971 году Intel выпускает совершенно новую микросхему памяти под аббревиатурой EPROM (Erasable Programmable ROM). Такую микросхему можно было подвергать неоднократной перезаписи.

Наконец в 1984 году компания Toshiba разрабатывает принципиально новый вид памяти под названием Flash. Через четыре года Intel выпускает свой вариант Flash-памяти (поэтому иногда ее создание незаслуженно приписывают этой компании).

В отличие от обычных механических устройств, во флеш-микросхеме отсутствуют разного рода двигательные механизмы.

Процессы перепрожига микросхемы базируются на законах квантовой механики. Если ты не прогуливал скучные пары этого предмета и внимательно слушал препода, ты меня поймешь.

Запись данных во Flash происходит методом инжекции "горячих" электронов, а стирание – методом туннелирования Фаулера-Нордхейма.

Ускорить метод туннелирования электронов можно путем подачи дополнительного высокого отрицательного напряжения на управляющий затвор.


Спецвыпуск Xakep, номер #034, стр. 034-044-5, Всемогущий Flash

Всемогущий Flash

Докучаев Дмитрий aka Forb

Спецвыпуск Xakep, номер #034, стр. 034-044-5

В микросхеме с MLC существует различие величин заряда, который накапливается на “плавающем” затворе, благоря чему информация в ячейке может быть представлена различными битовыми комбинациями.

SmartMedia Flash не имеет никакого контроллера, поэтому сборка карты очень проста (при ее производстве не требуется даже пайка).

Забавно, что до сих пор неизвестно происхождение термина Flash, так как это слово имеет три различных перевода. Соответственно, существует три версии названия памяти:

1. Flash переводится как "короткий кадр". Компания Toshiba дала такое название из-за короткого по времени процесса стирания данных (In da Flash - в мгновение ока).

2. Flashing можно перевести как прожиг, засвечивание. Flash-память по-прежнему прожигается, как и ее предшественники.

3. Третье значение этого слова - блок, кадр. Запись/стирание такой памяти осуществляется блоками.

Метод инжекции “горячих” электронов определяется простыми законами и уравнениями квантовой механики, главным из которых является уравнение Фаулера-Нордгейма (именно он придумал инжекцию). Оно записывается в виде Jox=A*E^2*exp(-Eo/E), где Jox – туннельный ток инжекции, А – константы, E – напряженность электрического поля.

Хотя Flash и лидирует на компьютерном рынке, ее могут вытеснить другие новые технологии. Например, новейшая память на кремниевых нанокристаллах. Отличие такой памяти от Flash в следующем: подложка между стоком и истоком теперь состоит из кремниевых нанокристалльных сфер. Такая прослойка предотвращает передачу заряда с одного нанокристалла на другой, повышая таким образом надежность - один дефект не ведет к полному сбою, как в нынешней энергонезависимой памяти на транзисторах с плавающим затвором. Первый в мире работоспособный образец такой памяти был предоставлен компанией Motorola.


Спецвыпуск Xakep, номер #034, стр. 034-048-1, Размер имеет значение!

Размер имеет значение!

Хемуль

Спецвыпуск Xakep, номер #034, стр. 034-048-1

МВС1000М - русский суперкомпьютер

Я знаю множество людей, недовольных скоростью своих компов. Ты тоже таких встречал? А может, и сам мечтаешь о покупке очередного hi-end произведения компании Intel, отказывая себе во всем и откладывая деньги? Так вот, есть на свете люди, способные по части страданий дать тебе сто очков форы. Глубины их страданий неисчерпаемы, а горизонты желаний необъятны, как вселенная. Заявления Intel об увеличении тактовой частоты на очередной гигагерц способны вызывать у них лишь презрительную усмешку, лишний гигабайт оперативной памяти - унылое пожатие плечами, а накопитель терабайтного размера - грустные мысли о вечной нехватке дискового пространства. Кто же эти мученики высоких технологий? Кому и зачем требуются терагерцы и терабайты? Ты уже наверняка догадался... Это ученые! Каждый уважающий себя ученый имеет в своем столе пару-тройку задач, для решения которых не хватит совокупной мощи всех компьютеров планеты! И каждый тешит себя мыслью, что когда-нибудь, через десяток-другой лет скорость вычислительных машин вырастет в тысячу, нет, лучше в миллион, нет, нет, лучше в миллиард раз, объемы оперативки возрастут до умопомрачительных величин, а размеры дисков станут бесконечными, и вот тогда...

Но отчаиваться не стоит. С незапамятных времен люди знали, что если лошадь, например, не может сдвинуть с места груженую телегу, то нужно запрячь еще одну. Или двух. Эту идею можно с успехом применять и в области высоких технологий. Если с задачей не справляется один компьютер, то почему бы не поставить два? Три? Тысячу? "Легко!" - скажешь ты, и будешь неправ. Все совсем не так просто. Мало поставить несколько системников рядом, нужно объединить их в единый компьютер и заставить сообща решать одну задачу. То, что получится в результате, и называется суперкомпьютером. Вообще-то их существует несколько разновидностей, из которых нашего внимания заслуживают лишь две: SMP (симметричные) и MPP (массивно-параллельные) системы.

Симметричный суперкомпьютер

В его структуре мы видим несколько процессоров (от двух и более) на одной материнской плате, имеющих равноправный доступ к памяти. Все процессоры работают параллельно, выполняя несколько программ одновременно. Что? Твой железный друг тоже может параллельно? Не спеши искать на плате дополнительные разъемы под процессор, скорее всего, их там нет. Штука эта называется вытесняющей многозадачностью и к суперкомпьютерам имеет отношение самое отдаленное. Двухпроцессорный SMP может работать в два раза быстрее однопроцессорного только в идеале. Во-первых, операционка должна поддерживать работу на нескольких процессорах. Это умеют практически все UNIX’ы и все Windows, произошедшие от NT, как то NT 4, Windows 2000 и XP. Во-вторых, сама программа должна уметь работать на нескольких процессорах одновременно. Это значит, что FPS в Quake не вырастет с добавлением второго проца, Word быстрее запускаться не станет, интернет не ускорится совсем никак. Зачем тогда нужен SMP? Для простого пользователя это почти бесполезный наворот. Правда, и он сможет извлечь из второго процессора пользу, ведь фоновая задача в таком случае не будет мешать работе основного приложения. Ты сможешь, например, на SMP-машине играть в игрушку или смотреть кино, в то время как на втором процессоре будет крутиться перекодировщик mp3 или программа для подбора паролей.


Спецвыпуск Xakep, номер #034, стр. 034-048-2, Размер имеет значение!

Размер имеет значение!

Хемуль

Спецвыпуск Xakep, номер #034, стр. 034-048-2

С точки зрения ученого, SMP тоже хорош. Программы его часто работают с большими массивами данных, обрабатывая их последовательно. Например, как рассчитывается взрыв водородной бомбы? Все пространство, где будет происходить "виртуальный взрыв", разрезается на кубики (ячейки), время делится на маленькие кусочки (шаги), так, чтобы в течение одного шага изменения внутри кубиков были небольшими. Потом начинается счет: машина вычисляет, как должны измениться условия в каждой ячейке за время одного шага, обновляет информацию, увеличивает счетчик времени, снова вычисляет изменения и так далее. Понятно, что чем больше ячеек нарезать, чем мельче шаг по времени задать, тем точнее будет результат и меньше вероятность воплотить в жизнь анекдот о физиках, которые после испытаний ядерной бомбы в отчете написали: "Мощность взрыва: 5-10 килотонн… мы думали, что пять, а оно как рвануло...". В общем, если мы возьмем два процессора и заставим каждый из них обрабатывать свою половину ячеек, то получим ускорение в два раза, по сравнению с обычной однопроцессорной машиной. Конечно, тут тоже есть свои грабли. Не будем вдаваться в подробности, но обеспечить одновременный доступ двух процессоров к одной ячейке памяти не так просто, как кажется.

Массивно-параллельная система

Внешне MPP выглядит довольно обыкновенно. Чаще всего это набор одинаковых системников, соединенных локальной сетью. В лучшем случае все это богатство установлено на стеллажи или привинчено к стандартным 19-дюймовым стойкам. Все вместе это называется "массивно-параллельный суперкомпьютер" или "вычислительный кластер". Ты спросишь, что же тут особенного? Главное в MPP-машине не железо, хотя оно тоже бывает уникально, компьютер такого типа суперкомпьютером делает софт. Правда, на первый взгляд, софт тоже не представляет собой ничего необычного - стандартный Linux, дополненный парой программ со странными названиями: MPI, PVM, PVFS... Программы эти помогают программисту объединять процессы в единое целое. Программист делит задачу на куски, организует распределение работы между узлами, решает как, когда и в каком порядке узлы будут обмениваться данными и т.д. Начинается отладка: программа скомпилировалась и запустилась, но через две минуты падает. На самом деле, падает из-за сбоя в программе только один процесс. Остальные падают из-за потери связи с ним. Находим ошибку. Исправляем. Задача начинает считать и через несколько минут зависает. Конечно, зависает один процесс, остальные зависли из-за невозможности получить от него данные. Вставляем отладочные операторы, читаем листинги, медитируем. Задача заработала, но неправильно. Снова чешем репу... И так очень долго. Есть, конечно, отладчики, работающие на многопроцессорных системах, но жизнь они облегчают незначительно.


Спецвыпуск Xakep, номер #034, стр. 034-048-3, Размер имеет значение!

Размер имеет значение!

Хемуль

Спецвыпуск Xakep, номер #034, стр. 034-048-3

Вообще, в мире установлено и работает огромное количество суперкомпьютеров. Среди них есть маленькие (2-16 процессоров) многопроцессорные системы, используемые в основном для поддержки серьезных баз данных и крупных веб-серверов, небольшие (до сотни узлов) кластеры, на которых работают очень крупные базы данных и сервера вроде google.com или yandex.ru, а среди них возвышаются гигантские, изготовленные на заказ суперсистемы: Earth Simulator (Япония, фирма NEC), ASCII WHITE (США, фирма Hewlett-Packard), Deep Blue (IBM) и другие.

Сделано в России

Существует список 500 самых мощных суперкомпьютеров, называемый "Top-500". Этот список обновляется дважды в год и может быть найден на сайте www.top500.org. Там, на скромном 97 месте, находится машина под названием "МВС-1000М" - самый крупный (из официально известных) суперкомпьютер в России, имеющий производительность 1,3 Терафлоп. Место не самое почетное, но эта машина стоит отдельного (и весьма ласкового) слова.

Выглядит она как 6 больших 19-дюймовых стоек, под завязку заполненных оборудованием. В каждой из них размещается 64 двухпроцессорных компьютера Alpha, соединенных сетью Myrinet. На всех установлен Linux (специальная версия для Alpha). Чем же здесь гордиться, спросишь ты - ведь все эти компоненты произведены за границей, наши только установили их в стойки и подключили? На самом деле, есть чем. Дело в том, что семейство МВС имеет многолетнюю историю, включающую две современные модели - МВС100 и МВС1000. МВС100 представляла собой транспьютерную систему, состоящую не из полноценных компьютеров, а из упрощенных (транспьютеров), содержащих лишь процессор и память. Транспьютеры не отягощены такими излишествами, как, например, контроллеры дисков и сложные системы ввода/вывода и другими ненужными деталями, что делает их небольшими и, по идеее, дешевыми. Однако купить в магазине тысячу обыкновенных материнок и свинтить из них нечто большое сейчас гораздо дешевле, чем сделать на заказ тысячу транспьютеров. Такова жизнь. А раз это полноценный комп, то и в качестве операционки вполне сойдет Linux. На долю программистов Института Прикладной Математики им. Келдыша (разработавших ОС для МВС100 - "router") выпала задача написать систему управления, способную справиться с компьютером, имеющим более 700 процессоров, и активно используемую сотней-другой пользователей. И они с задачей справились! Так что повод для гордости налицо: ведь если бы не мозги наших математиков, эта собранная в России куча железа либо вообще никогда не заработала бы, либо считала бы вполсилы.

Heading for tomorrow

Будущее МВС1000-М уже решено. Эта система скоро будет заменена более мощной. Старую систему разделят на несколько меньших суперкомпьютеров и передадут в различные институты Академии наук. Новая система будет основана уже на процессорах Intel Itanium 2.

История, вообще, занятная штука. Кто знает, какое место займет в ней система МВС1000? Возможно, через десяток-другой лет то, что сейчас гордо именуется "Суперкомпьютером" запросто уместится на твоем рабочем столе? И кто знает, быть может, на нем будут выбиты три русские буквы - "МВС"?..


Спецвыпуск Xakep, номер #034, стр. 034-048-4, Размер имеет значение!

Размер имеет значение!

Хемуль

Спецвыпуск Xakep, номер #034, стр. 034-048-4

Ссылки по теме:

www.jscc.ru - Сайт Межведомственного Компьютерного Центра

www.kiam.ru - Сайте Института Прикладной Математики

www.parallel.ru - Здесь можно найти всю полезную информацию о технологиях параллельных вычислений и суперкомпьютерах в целом

Каждый уважающий себя ученый имеет в своем столе пару-тройку задач, для решения которых не хватит совокупной мощи всех компьютеров планеты!

Транспьютеры не отягощены такими излишествами, как, например, контроллеры дисков и сложные системы ввода/вывода, что делает их небольшими и дешевыми.


Спецвыпуск Xakep, номер #034, стр. 034-050-1, ДВА ГЛАЗА - НЕ РОСКОШЬ

ДВА ГЛАЗА - НЕ РОСКОШЬ

Симченко Владимир

Спецвыпуск Xakep, номер #034, стр. 034-050-1

(vr@really.ru)

Современные 3D стереотехнологии

Однажды, глядя, как ребята с крестами на груди и в коричневых балахонах с капюшонами тащат некоего Галилея в местное отделение партии "аутодафистов" для беседы на тему "нет дыма без огня", Giovanni Battista della Porta совершенно неожиданно для себя пришел к выводу, что астрономия - это бесперспективно...

Тогда, в делеком 17 веке, полностью поглощенный мыслями о перспективе жизни della Porta задумался над созданием стереопары, обеспечивающей просмотр изображения в объеме. Первая попытка визуализации информации в 3D-стереоформате была предпринята именно им.

Принцип создания трехмерного изображения полностью базируется на естественной способности человека воспринимать окружающий мир в объеме. Когда смотришь на какой-либо объект, он воспринимается глазами с различных ракурсов, в результате мозг получает информацию о двух изображениях, отличающихся друг от друга углом зрения. Сопоставление изображений дает информацию об удалении от рассматриваемого объекта. Именно это свойство и используется при создании стереоизображения.

ПАРАЛЛАКС

Наличие двух глаз, расположенных на небольшом расстоянии друг от друга, обеспечивает стереоскопичность зрения. Для большей наглядности проделай небольшой эксперимент: запусти на компьютере любую игровую программу, реализованную с помощью 3D графики (Quake, Unreal и т.д.), а теперь, поочередно закрывая левый и правый глаз, оцени изображение на мониторе. Как видишь, разницы никакой нет, потому что тригонометрическая иллюзия, которую ты наблюдаешь, это обычное плоское 2D изображение. А теперь проделай следующее: переведи взгляд на любой предмет, находящийся рядом с монитором, и снова взгляни на него, поочередно закрывая левый и правый глаз. Как видишь, ракурсы изображения получаются различные. Чтобы сильнее ощутить разницу в восприятии, взгляни на кончик пальца своей руки, вытянув ее как можно дальше перед собой. А теперь приблизь руку и, не меняя точки приложения взгляда, прикоснись пальцем к своему носу. Разница в угле зрения станет максимальной и до боли (в глазных мышцах) наглядной. Свойство глаз сфокусироваться на объекте и видеть его под различными углами, обеспечивая таким образом мозг исходным материалом для вычисления расстояния до объекта, получило название глазной параллакс (eyes` parallax). А метод разделения двух ракурсов изображений для создания эффекта объема - метод параллакс барьера (parallax barrier).

Наибольшее распространение на сегодняшний день получили следующие способы разделения двух ракурсов изображения:

Shutter (затворный) – правая и левая линза (затворы) поочередно закрываются. Когда на экран выводится изображение для левого глаза, срабатывает на закрытие правый затвор, и наоборот. Таким образом, в единицу времени можно видеть только одно изображение для левого или правого глаза. Но, так как процесс происходит достаточно быстро, глаз, в отличие от мозга, не фиксирует это обстоятельство, замечая лишь мерцание в случае использования низкой частоты смены изображений, например, при просмотре стерео DVD-фильма на телевизоре, когда на каждый глаз приходится всего 30 Гц. Что же касается компьютера, то он без проблем обеспечивает в стереорежиме на каждый глаз частоту не ниже 60 Гц, что больше, чем при просмотре телевизора (50 Гц). Так что проблема дискомфорта при использовании затворного метода полностью решена.


Спецвыпуск Xakep, номер #034, стр. 034-050-2, ДВА ГЛАЗА - НЕ РОСКОШЬ

ДВА ГЛАЗА - НЕ РОСКОШЬ

Симченко Владимир

Спецвыпуск Xakep, номер #034, стр. 034-050-2

Anaglyph (использование цветового фильтра) - разделение двух ракурсов изображения в этом случае достигается благодаря использованию двух светофильтров: красного и синего. При наблюдении синего цвета через красный светофильтр он не виден, а при наблюдении красного цвета через синий светофильтр он становится черным. Обеспеченное фильтрами преломление и создает иллюзию объемности изображения. Широкое распространение этот метод получил благодаря невысокой стоимости и простоте использования. Серьезным недостатком этого способа является резкое ухудшение цветовой гаммы, что не только существенно снижает комфорт при просмотре, но и ухудшает восприятие глубины стереоизображения.

На сегодняшний день Anaglyph и Shutter, благодаря своей доступности для большинства пользователей и поддержке разработчиками, являются самыми распространенными способами разделения ракурсов изображения для получения эффекта объемности. Что же касается форматов, то на практике при выводе стереоизображения на экран телевизора или компьютера чаще всего используются следующие стереоформаты:

- Line Blanking (композитный) - кадр изображения в этом случае содержит два ракурса стереопары. Четные строки содержат один ракурс, а нечетные - второй. Контроллер, ответственный за синхронизацию изображения с работой затворов, вычеркивает (line blanking) соответственно четные или нечетные строки, позволяя наблюдателю в единицу времени видеть только один ракурс стереопары. Преимуществом формата является высокая степень совместимости с различными системными конфигурациями и уменьшение нагрузки в стереорежиме, так как нагрузка на видеоусилитель монитора падает в два раза, по сравнению с частотой при выводе полных кадров. Недостатком формата является уменьшение разрешения по вертикали в два раза. То есть, если используется изображение 1024Х768, в стереорежиме получится 1024Х384.

- Over/Under (вертикальная стереопара, Above/Below) - стереоизображение в этом случае представляет собой два ракурса, расположенных друг над другом по вертикали. Наибольшее распространение этот формат получил на компьютере благодаря усилиям не существующей ныне компании Wicked3D. Характеризуется высоким уровнем совместимости с компьютерными играми и возможностью записи стереофильмов в стандартах сжатия MPEG без потери стереоэффекта. Ракурсы стереокадра выводятся поочередно и, синхронизируясь с работой затворов, обеспечивают восприятие объемного изображения. Разрешение изображения в этом случае составит лишь половину от полного изображения экрана.

- Page-flipping (чередующиеся страницы) - поочередное появление на экране двух ракурсов стереоизображения. При этом изображение каждого ракурса занимает всю площадь экрана. Преимуществом этого формата является высокое разрешение просматриваемого стереоизображения, а недостатком - повышенные требования к системе. На практике нагрузка на видеосистему увеличивается примерно на 40%. 6 июня 2001 года, когда NVIDIA выпустила первый стереодрайвер с поддержкой формата Page-flipping, этот формат стал самым популярным не только среди поклонников компьютерных игр, но и среди разработчиков 3D фильмов. Именно в этом формате записаны на DVD популярные стереофильмы IMAX, благодаря чему их можно просмотреть не только на телевизоре, но и на компьютере.


Спецвыпуск Xakep, номер #034, стр. 034-050-3, ДВА ГЛАЗА - НЕ РОСКОШЬ

ДВА ГЛАЗА - НЕ РОСКОШЬ

Симченко Владимир

Спецвыпуск Xakep, номер #034, стр. 034-050-3

РАЗВИТИЕ ВИРТУАЛЬНЫХ ШЛЕМОВ

Кажущиеся сегодня смешными 180000 пикселов на LCD матрицу, обеспечивавшие разрешение 263х230х3 (181479 пикселов) при 256 цветах, приводили тогдашнюю публику в восторг. Первым из борьбы за лидерство выбыл CyberMaxx VR HMD. Когда схлынули восторги, то выяснилось, что дизайн не столь успешен, как у конкурентов, регулировками пользоваться неудобно, да и сами по себе они неудачно реализованы, и, кроме того, невозможна параллельная работа виртуального шлема с монитором. Но самой большой проблемой оказалась низкая совместимость VR шлема с играми. Невзирая на большой (по тем временам) заявленный список игр, в которых устройство поддерживается, на практике оказалось, что конфликт драйверов во многих играх делает эксплуатацию невозможной.

На следующем технологическом витке вперед вырвался VFX, в своей новой реинкарнации - VFX-3. Причем название сменил уже не только шлем, но и разработчик, превратившись из "Forte" в "IIS" (Interactive Imaging Systems). Возможности LCD матрицы выросли с 180000 до 360000 пикселов, а глубина цвета увеличилась до 16 бит. И самое главное, была заявлена поддержка стереорежима для игр с API D3D. Но упиваться победой "IIS" пришлось недолго. Виртуальный шлем отказывался работать с новой версией DirectX, а не желавшие топтаться на месте разработчики не торопились его поддерживать. Разрешение в стереорежиме оказалось всего лишь 263x240, и, кроме того, шлем не работал с более комфортными форматами Page-flipping и Over/Under. А постоянные конфликты с драйверами распространенных видеокарт поставили окончательный крест на популярности устройства.

На плаву в результате осталась только I-Glasses, выпустившая на сегодняшний день целую серию виртуальных шлемов, перекрывающих большую часть этого сектора рынка. Теперь технологически "повзрослевшие" виртуальные шлемы предлагают более высокое разрешение и глубину цвета, работу с сигналами VGA, SVGA, NTSC, PAL, S-VHS и обеспечивают более высокий уровень совместимости не только с современной периферией (консоль, DVD, Notebook, PAD, TV, PC, VHS), но и с программным обеспечением. Пиком развития виртуальных шлемов стал i-Visor c ЖК-матрицей MD800G6 от MicroDisplay (www.microdisplay.com) размером 1,44 миллиона пикселов, реализующей разрешение 800Х600 (480000х3) при полноцветном изображении. Совместимость со стереодрайвером от NVIDIA сделала этот виртуальный шлем объектом мечтаний всех интересующихся виртуальной реальностью. Правда, ненадолго. Лишь до тех пор, пока не посыпались жалобы от потребителей не только на несоответствие качества заявленному уровню, но и на функциональные проблемы. Выяснилось, что заявленные для стереорежима 120 Гц достигаются далеко не на всех проданных экземплярах, а изображение не просто бледное, а обладает целым рядом артефактов, совсем не радующих глаз пользователя, выложившего за удовольствие погружения в виртуальную реальность 1800 зеленых.


Спецвыпуск Xakep, номер #034, стр. 034-050-4, ДВА ГЛАЗА - НЕ РОСКОШЬ

ДВА ГЛАЗА - НЕ РОСКОШЬ

Симченко Владимир

Спецвыпуск Xakep, номер #034, стр. 034-050-4

ПРОБЛЕМЫ И НЕДОСТАТКИ

Увы, уровень качества изображения практически всех виртуальных шлемов несопоставим с тем, что можно получить сегодня на среднестатистическом компьютере. Поэтому когда видишь, с какой гордостью i-Glasses анонсирует новую версию виртуального шлема с приставкой PRO, отличающуюся от предыдущей лишь тем, что контрастность микродисплея не 50:1, а 100:1, и имеющую цену уже не 1000, а 1500 долларов, начинаешь понимать, отчего вокруг так мало желающих приобщиться к виртуальной реальности с помощью VR HMD.

Корень бед VR-шлемов - в первую очередь, в отсутствии недорогого микродисплея, способного обеспечить высокое разрешение и приемлемое качество изображения. Это объяснимо, технология напыления тонкопленочных транзисторов интегральной схемы управления на подложку в обычном LCD-мониторе и на микродисплее - далеко не одно и то же. А поместить транзистор между строк уже не получится, и реализация того же решения обойдется значительно дороже. При желании можно, конечно, приобрести обеспечивающую более высокое разрешение модель виртуального шлема от Kaiser Electro-Optics Inc. (www.keo.com), но прогнозировать массовый спрос на VR HMD стоимостью от 20000 до 100000 у.е. - занятие малоперспективное.

ПЕРСПЕКТИВЫ

Впрочем, некая иллюзия перспективы все же имеется. Еще весной прошлого года компании Three-Five Systems (www.threefive.com) и Accupix Inc (www.accupix.com) объявили о начале совместной работы над использованием последнего достижения в области микродисплеев - Brillian(TM) Z86D-3 SVGA. Важной особенностью спецификации этой новинки является разрешающая способность в 2,6 миллиона пикселов. Результатом совместной работы должно стать создание более качественных, но при этом менее дорогих продуктов.

Простой расчет (1024х768х3 = 2359296) показывает, что матрицы 2,6 миллиона пикселов с лихвой хватает на обеспечение стандартного разрешения 1024х768, так что теоретически вполне возможно появление виртуального шлема нового поколения. А вот практически может повториться ситуация, аналогичная той, что произошла с компанией Microvision (www.mvis.com), сообщившей в начале прошлого года о начале поставок Персональной Визуальной системы (Nomad Personal Display System). Потенциальными заказчиками устройства, кроме военных, были названы авиаторы, спасатели и любители экстрима. Заявленная цена на устройство составила 1000-1500 долларов в зависимости от версии и программного обеспечения. В случае успеха предполагался выход на "игровой" рынок с удешевленным вариантом. Затем в августе 2002 года Microvision сообщила о заключении многомиллионного контракта с U.S. Army на поставки своего продукта, так что о выходе на игровой рынок уже не могло быть и речи. Поэтому, учитывая сильно возросшие за последний год не только аппетиты, но и возможности оборонных ведомств развитых стран, можно предположить, что подобная участь может постигнуть и Brillian(TM) Z86D-3. Кроме того, остается только гадать, на разработку каких изделий "уходят" уже довольно давно анонсированные Eastwood-WX (MD1280P2 - 0.82" WXGA-1280x768, 0.81"-720P 1280x720) и Eastwood-SX (MD1280P1- 0.90" SXGA 1280x1024, 0.81" 720P 1280x720). Судя по всему, после ближневосточных событий и впечатляющей демонстрации преимуществ тактики дистанционной войны, до "игрового" рынка эти матрицы доберутся еще нескоро.


Спецвыпуск Xakep, номер #034, стр. 034-050-5, ДВА ГЛАЗА - НЕ РОСКОШЬ

ДВА ГЛАЗА - НЕ РОСКОШЬ

Симченко Владимир

Спецвыпуск Xakep, номер #034, стр. 034-050-5

ЗАТВОРНЫЕ СТЕРЕООЧКИ

Разработчики VR-шлемов недостаточно серьезно отнеслись к своим ближайшим конкурентам – стереоочкам. Собственно, поначалу стереоочки и конкурентами-то не были. Ведь еще пять лет назад обладатель VR HMD с чувством превосходства взирал на владельца стереоочков, подобно тому, как владелец автомашины смотрит на водителя мопеда. Но пока разработчики VR HMD упивались славой, гадкий утенок рос и совершенствовался, как в совместимости, так и в функциональных возможностях. И вот наступил момент, когда стереоочки превратились в белого лебедя, а виртуальный шлем так и остался не повзрослевшей уткой.

Первым серьезным преимуществом стереоочков перед VR-шлемами стала возможность использовать разрешение, предоставляемое программой. Но главным козырем стал невероятно высокий уровень совместимости со всем, что работало с API D3D и OpenGL. Точкой отсчета резкого роста популярности можно считать выход в 1998 году стереоочков EyeScream от Wicked 3D (несуществующее ныне подразделение компании Metabyte), со стереодрайверами, позволяющими работать не только на популярном в те времена акселераторе Voodoo 2, но и на целом ряде видеокарт от других производителей. Но максимальный эффект достигался все же при использовании двух Voodoo 2 в режиме SLI, позволяющем реализовать разрешение 1024х1024. Кроме того, именно на Voodoo обеспечивался максимальный уровень совместимости используемого стереодрайвером режима Over/Under.

Три года спустя прочное положение сотрудников Wicked 3D пошатнулось. 6 июня 2001 года NVIDIA выпустила стереодрайвер, обеспечивающий работу в режиме Page-flipping. Этот режим был более требовательным к ресурсам, но и более комфортным для просмотра стереоизображения. Стереодрайвер работал не только на всех видеокартах с чипами от NVIDIA, но и на экзотических тогда еще стереомониторах от Dimension Technologies Inc. (www.dti3d.com). Самым большим спросом стали пользоваться стереоочки, поддерживающие Page-flipping. Впрочем, Over/Under в отличие от Wicked 3D и Voodoo, не торопился сворачиваться. Когда выяснилось, что формат удобен не только для компьютерных игр, но и для записи стереофильмов, возникла потребность в стереоочках, работающих сразу с несколькими форматами. В лидеры выбились eDimensional (www.edimensional.com) и X3D Technologies Corporation (www.x3dworld.com). Первая компания занимает первое место по продажам на внутреннем американском рынке, вторая - на международном. Предложенные стереоочки обеспечивали поддержку уже трех стереоформатов: Page-flipping, Over/Under и Interlaced. Таким образом был перекрыт весь востребованный диапазон стереорежимов. Программное обеспечение очков позволяло удобно управлять режимами и предоставляло ряд других возможностей. Так, например, после появления программного комплекта X3D TV Gateway (X3D Technologies Corporation) проигрывание стереофильмов на компьютере, обеспечивающем большую частоту просмотра, нежели телевизор, стало простым и удобным, что было тут же оценено потребителями. Отреагировавший на рыночную ситуацию IMAX тут же организовал выпуск стереофильмов на DVD, обеспечивающих более высокое качество изображения, чем стереофильмы на VHS.


Спецвыпуск Xakep, номер #034, стр. 034-050-6, ДВА ГЛАЗА - НЕ РОСКОШЬ

ДВА ГЛАЗА - НЕ РОСКОШЬ

Симченко Владимир

Спецвыпуск Xakep, номер #034, стр. 034-050-6

ПРОБЛЕМЫ И НЕДОСТАТКИ

Существует одна проблема, связанная с эксплуатацией затворных стереоочков - нежелание ATI обеспечить поддержку стерео на обычных видеокартах. В целом понятно, что это делается в пику NVIDIA. Но, во-первых, у NVIDIA тоже есть профессиональные решения в области стерео, а во-вторых, заложниками становятся обычные пользователи, которые при покупке видеокарты для "стерео", вынуждены выбирать NVIDIA. Но с недавних пор ситуация несколько изменилась после появления стереодрайвера "Е-D OpenGL" от eDimensional, предназначенного для работы с видеокартами ATI. Стереодрайвер использует режим Over/Under, работает только с API OpenGl и имеет более низкий уровень совместимости и функциональных возможностей, чем стереодрайвер от NVIDIA. Но, тем не менее, счет поддерживаемых программ идет уже на сотни.

Еще одним недостатком Е-D OpenGL стереодрайвера является то, что свободно получить его могут только покупатели очков E-D. Впрочем, это продлится, скорее всего, недолго. Дело в том, что драйвер совместим также и с X3D, и, что важно для российских пользователей, с контроллером 3DSPC2 от СТЭЛ, способным аппаратно свести Over/Under в стереокартинку, даже когда она не желает этого делать.

ANAGLYPH

Стереоочки Anaglyph, несмотря на недостатки метода, пользуются большой популярностью. Причин для такой популярности предостаточно. Во-первых, это низкая стоимость самих очков (10-15 рублей), которые при желании можно изготовить даже дома, имея под рукой два достаточно прозрачных фильтра: синий и красный. Во-вторых, это поддержка anaglyph-метода в стереодрайвере от NVIDIA, позволяющая не только просматривать имеющиеся в интернете в огромном количестве стереоизображения, но и играть в компьютерные игры с использованием стереорежима. В третьих, это наличие в интернете бесплатных программ, позволяющих на лету конвертировать стереофильм из формата Over/Under в anaglyph-формат. В результате, устроить дома (пусть и не столь впечатляющий, как в случае использования затворных (LCD) стереоочков) стереосеанс - не проблема. И наконец, это возможность подарить кому-нибудь свою стереофотографию, отпечатанную в формате anaglyph, приложив к ней стереоочки :). С затворными стереоочками такой номер не пройдет.


Спецвыпуск Xakep, номер #034, стр. 034-050-7, ДВА ГЛАЗА - НЕ РОСКОШЬ

ДВА ГЛАЗА - НЕ РОСКОШЬ

Симченко Владимир

Спецвыпуск Xakep, номер #034, стр. 034-050-7

ПРОБЛЕМЫ И НЕДОСТАТКИ

Недостатком использования anaglyph-стереоочков, как уже говорилось выше, является более низкое качество изображения из-за ухудшения цветовой гаммы. Вариант решения этой проблемы был анонсирован компанией ColorCode 3D (www.colorcode3d.com), предложившей использовать вместо красно-синих светофильтров оранжево-синие, действительно позволяющие существенно уменьшить потерю цветовой гаммы и дающие более качественное стереоизображение, но лишь по сравнению с традиционными красно-синими очками. Несмотря на имеющиеся у предложенного ColorCode 3D метода преимущества и поддержку выбора светофильтра в стереодрайвере от NVIDIA, большинство пользователей не торопятся переходить на оранжево-синюю цветовую гамму. Либо в силу инерции, либо из-за невозможности раздобыть сами светофильтры, либо потому, что за программные инструменты от ColorCode 3D необходимо выложить кровно заработанные. В то время как красно-синий вариант обходится практически бесплатно…

3D ЗАКЛЮЧЕНИЕ

Сегодня ситуация в 3D индустрии уникальна в своем роде. Существует огромное количество перспективных наработок у небольших компаний, не имеющих финансовых возможностей перерасти в новое качество, и огромные финансовые возможности у крупных игроков на компьютерном рынке, не способных в силу своей инертности предпринять какие-либо действия по изменению сложившегося положения. Потребности рынка в области визуализации информации стали настолько очевидны, что это поняли даже жители страны восходящего солнца. Поэтому именно японские компании (Sharp, Itochu Corp., NTT Data Corp., Sanyo Electric Co. Ltd. и Sony Corp) основали в марте этого года 3D Consortium (www.3dc.gr.jp), целью создания которого, как было заявлено, станет создание технических и программных стандартов для продвижения на рынок 3D дисплеев, применяемых в "desktops, laptops and cell phones".

Из "внешнего" мира к японцам присоединились Samsung, Motorola и Microsoft. Но особых иллюзий питать не стоит. Все представленные участники проекта - это всего лишь новые бинты на старые раны. Что же касается дальнейшего развития технологии, то, на мой взгляд, одной из самых перспективных в кандидаты на массовость является технология, реализованная в стереомониторе SmartrON (www.neurokoptics.com), позволяющая элегантно обойти проблемы параллакс барьера, а не продолжать упрямо долбится в него лбом, как это делает 3D Consortium. Суть используемого в SmartrON метода состоит в том, что с помощью нейросетевых алгоритмов моделируется световой поток, аналогичный световому потоку, отражаемому от объекта в реальной жизни. В результате с помощью светового поля создается непрерывная стереопара, а не отдельный ряд изображений для каждого глаза пользователя, как это происходит в случае с параллакс барьером. Это позволяет избежать проблемы с попытками глаз фокусироваться на наблюдаемом объекте и плоскости монитора одновременно. Единственное, что требуется для массового распространения этого продукта - удешевление технологии производства ЖК-дисплеев. И то, что это произойдет достаточно скоро, сомнений не вызывает.


Спецвыпуск Xakep, номер #034, стр. 034-050-8, ДВА ГЛАЗА - НЕ РОСКОШЬ

ДВА ГЛАЗА - НЕ РОСКОШЬ

Симченко Владимир

Спецвыпуск Xakep, номер #034, стр. 034-050-8

ПОЛЕЗНЫЕ ССЫЛКИ

www.stereo3d.com – обзоры, новости, форум (eng)

www.stereovision.net - форум по применению стереоустройств (eng)

www.i-glassesstore.com - стереоочки, VR HVD, программы, стереофильмы на DVD (eng)

www.slingshotent.com/index_flash.htm - IMAX стерео DVD (eng)

www.3dstereo.ru - официальный сайт СТЭЛ (rus)

www.really.ru - новости, обзоры, самая большая в интернете стереогалерея (rus)

Принцип создания трехмерного изображения полностью базируется на естественной способности человека воспринимать окружающий мир в объеме.

Свойство глаз сфокусироваться на объекте и видеть его под различными углами, обеспечивая тем самым мозг исходным материалом для вычисления расстояния до объекта, получило название глазной параллакс (eyes` parallax). А метод разделения двух ракурсов изображений для создания эффекта объема - метод параллакс барьера (parallax barrier).

Фанаты VR жанра с надеждой ждали времен, когда развитие технологии позволит не только мысленно отождествить себя с персонажем на экране, но и лично поучаствовать в казни очередного сидха, независимо от его уровня медихлориана.

Кажущиеся сегодня смешными 180000 пикселов на LCD матрицу, обеспечивавшие разрешение 263х230х3 (181479 пикселов) при 256 цветах, приводили тогдашнюю публику в восторг.

На плаву в результате осталась только I-Glasses, выпустившая на сегодняшний день целую серию виртуальных шлемов, перекрывающих большую часть этого сектора рынка.

Корень бед VR шлемов - в первую очередь, в отсутствие недорогого микродисплея, способного обеспечить высокое разрешение и приемлемое качество изображения.

Ведь еще пять лет назад обладатель VR HMD с чувством превосходства взирал на обладателя стереоочков, подобно тому, как владелец автомашины смотрит на водителя мопеда.

Первым серьезным преимуществом стереоочков перед VR шлемом стала возможность использовать разрешение, предоставляемое программой. Но главным козырем стал невероятно высокий уровень совместимости со всем, что работало с API D3D и OpenGL.

После промелькнувших на нашем рынке в далеком 1995 году стереоочков SimulEyes российский пользователь крепко подсел на стереоочки VR 100 от ASUS, которыми в этой компании комплектуются все видеокарты серии Deluxe.

Существует огромное количество перспективных наработок у небольших компаний, не имеющих финансовых возможностей перерасти в новое качество, и огромные финансовые возможности у крупных игроков на компьютерном рынке, не способных в силу своей инертности предпринять какие-либо действия по изменению сложившегося положения.


Спецвыпуск Xakep, номер #034, стр. 034-056-1, ЦИФРОВАЯ РЕАЛЬНОСТЬ

ЦИФРОВАЯ РЕАЛЬНОСТЬ

Дениc Овсянников

Спецвыпуск Xakep, номер #034, стр. 034-056-1

(www.ovideo.ru)

3D-визуализация в играх и кино

Похоже, кино начинает переживать эпоху реализма в компьютерной графике. Помимо повсеместного перехода на "цифру" в съемке, цифровые герои становятся частью реальности. Вымысел уже живет своей жизнью, приобретает отличительные черты характера и индивидуальность. Как же творят все это?

D (dimension) - измерение. Как правило, графика делится на 2D (простую, плоскую) и 3D - со всеми сложностями и прелестями реализма. 1D не существует как таковой. Принято считать одномерной точку с длиной, стремящейся к нулю.

2D

Классическим примером 2D является мультипликация. Старые рисованные мультяшки все так же радуют глаз, но выглядят картонно (плоско).

ПСЕВДО 3D

Если ты пользовался графическим редактором Adobe Photoshop и тебе известен эффект над титрами Bevel (объем), ты знаешь, что такое псевдо 3D. Стоит лишь повернуть надпись на 45 градусов, и реальность тут же меркнет.

3D

Знаменитые профессиональные программы для анимации и моделирования - 3D Studio Max и Maya. Работая в 4-экранном режиме, сразу в трех плоскостях, плюс вид с камеры, ты имеешь возможность всевозможных манипуляций по всем трем измерениям. Масштабирование, движение, вращение, изменение формы и цвета и т.п. Полностью реализовать свои фантазии позволяют дополнительные модули для моделирования воды, текстур, огня, дыма и, конечно же, пришельцев ;). Три проекции позволяют полностью построить объект, реконструировать его и работать в трех измерениях.

Maya считается наиболее удобным инструментом для 3D-моделирования.

В пакете трехмерного моделирования Maya встроены изначально большие возможности, чем в 3D Studio Max, включая реалистичные дополнительные устройства-модули по созданию, к примеру, оригинальных поверхностей меха и травы.

НА ЧЕМ ЗЕМЛЯ ВЕРТИТСЯ

Основная разница между 3D-персонажами в играх и кино заключается в том, что в играх персонажи - это программы. Основное время тратится на создание алгоритма, оживляющего персонажа, движения, фазы со всевозможными объектами, интерактивность. В игре действия персонажа и его возможности, несомненно, ограничены программой, но, в то же время, формируются пользователем благодаря интерактивности игры.

В кино же строится конкретный объект или персонаж с заранее известными действиями и практически неограниченными возможностями. Его путь четко очерчен от А до Я. Предел возможностей 3D-объекта в киновизуализации определяется фантазией и деньгами.

В программах моделирования существует немаловажный аспект - описание типа поверхности. Однако твердость тела для компьютера значения не имеет. Важна лишь видимая разница. Поверхность, описанная в среде моделирования, должна полностью совпадать по параметрам деформирования с реальными предметами (материалами). Говоря другими словами, есть три механизма описания поверхностей: полигонально (многоугольниками, чем их больше - тем лучше, но и сложнее вычисления), NURBS-поверхности (разновидность сплайнов, кривых и перпендикулярных кривых) и иерархические поверхности (гибрид первых двух способов).


Спецвыпуск Xakep, номер #034, стр. 034-056-2, ЦИФРОВАЯ РЕАЛЬНОСТЬ

ЦИФРОВАЯ РЕАЛЬНОСТЬ

Дениc Овсянников

Спецвыпуск Xakep, номер #034, стр. 034-056-2

Далее идет вид объекта, он определяется по характеристике материала и степени поглощения им света, включая такие характеристики как цвет, гладкость, блеск, прозрачность, светимость и размытие при движении. Неровность поверхности (ее неидеальность) является важным фактором придания реализма моделируемому объекту.

По своей форме все объекты делятся на сложные и простые. Примером простого объекта может служить лампочка. Сложным объектом можно считать дерево. Существует два подхода к созданию объектов: создание объектов из примитивов (простой и понятный метод, не требующий особых навыков) и рисование объектов, не прибегая к примитивам, а выполняя моделлинг при помощи лофтинга и других интересных приемов.

СОЗДАНИЕ 3D

Чтобы создать 3D, необходимо знать соответствующие компьютерные программы, иметь некоторые художественные навыки, способность геометрически мыслить и неплохое знание английского языка, чтобы свободно читать мануал к программам для профессиональной 3D-графики. Обладая этими знаниями, смоделировать что-нибудь становится достаточно просто. Для этого требуемый объект мысленно раскладывается на несколько примитивов, которые могут быть объединены друг с другом. Конечно, используя фантазию и пространственное мышление, надо представлять объект во всех его пропорциях и основных фазах. Основываясь на примитивах типа куб, сфера, пирамида или плоскость, можно создать большинство необходимых простых объектов. Далее, после приведения в соответствие с масштабом моделируемого мира, производится подборка и наложения нужного материала.

В случае моделирования сложного объекта необходимо использовать некие примитивные наброски или реальный объект для "перерисовки" его в компьютер. Помимо детальной разработки частей объекта (моделирования), их связи, расположения, возможных движений (анимации и/или деформации) тебе понадобятся системы генерации оболочек ("одежды"). Это могут быть различные материалы: ткань, дерево, мрамор, бумага, тело человека и прочие.

Из последних технологий стоит отметить Sub Surface Scattering (SSS). Она используется для создания прозрачности на пальцах. При сильном освещении даже рука человека на просвет оказывается частично прозрачной, не говоря уж о некоторых видах животных. Так вот, домовой эльф в «Гарри Поттере» был изображен именно с использованием этой технологии, в отличие от менее реалистичного персонажа в фильме "Властелин Колец".

ВИРТУАЛЬНАЯ ЛИ РЕАЛЬНОСТЬ

"Виртуальная реальность", пожалуй, началась с фильма "Газонокосильщик". Если человека не удовлетворяет эта реальность, то он вправе выдумать еще одну игрушку, "реальность в реальности", использовав все доступные средства (специальный костюм, перчатки и шлем). Достигается некое подобие осязания, видения и взаимодействия с искусственным.

Человеческая природа такова, что кроме единственной реальности он ничего иного не воспринимает, и создание "виртуальной реальности", подчиняющейся своим законам, вынужденной быть иной, имитировать реализм, очень сложно. Отсутствие обоняние и вкуса усиливает разницу.


Спецвыпуск Xakep, номер #034, стр. 034-056-3, ЦИФРОВАЯ РЕАЛЬНОСТЬ

ЦИФРОВАЯ РЕАЛЬНОСТЬ

Дениc Овсянников

Спецвыпуск Xakep, номер #034, стр. 034-056-3

Естественно, что моделирование реального Виртуального Мира перегрузит современные компьютеры с их гигагерцовыми процессорами, а подменять стереоизображение сетчатки глаз с разрешением 8000х8000 пикселов под силу только самым мощным из представителей современных суперкомпьютеров. Кроме того, необходим качественный звук окружения и множество других осязательных факторов. Действительно реалистичные "виртуалки" мы получим еще не скоро.

ВИРТУАЛКА НА ТВ

Многие телевизионщики, стремясь удешевить производство и сделать его более красочным, используют виртуальные студии. Они включают камеры, системы освещения, компьютеры и "blue room" (дословно «синяя комната»). В виртуальной студии, окруженный трехмерными декорациями (как позади себя, так и спереди) находится ведущий. На "слабых" компьютерах задний фон просчитывается заранее, на более мощных в режиме реального времени идет склейка заготовленного фона со съемкой живого персонажа.

Способ "вклеивания" основывается на использовании эффекта Chorma Key (вырезание по однородному цвету). При этом важно, если снимается план в синей комнате, чтобы на реальных предметах и персонажах не было синего цвета или близких к нему оттенков, иначе они окажутся просто "вырезанными" из конечного оригинала.

В процессе погружения в виртуальную студию используют профессиональные видеокамеры с датчиками, соединенными с ключевыми точками сцены. Также система позволяет производить операции фокусирования и масштабирования (zoom). Компьютер отслеживает положение кадра (камеры) и пересылает полученную информацию компьютеру на рендеринг. В реальном времени по мере движения камеры изображение пересчитывается 25 (!) раз в секунду.

ЛЮДИ В ЦИФРЕ

Грань между компьютерным творчеством и реальной натурой продолжает размываться. Последние блокбастеры наглядно демонстрируют мощь компьютерной техники и художников-постановщиков с дизайнерами. Особо ценится максимальный реализм (реализм до "гротескной жути", как в фильме "Ловец снов"). Движения искусственных героев уже соответствуют реальным. Осталось подкорректировать "критические" точки, разобраться с тенями и все. Однако не все так просто, как кажется на первый взгляд, из-за оригинальной и сложной формы движений у людей или животных.

Начало способам стандартизации основных проблем, возникающих при реалистичной анимации, положил фильм "Терминатор". Его оцифровывали с помощью трехмерного сканера. Пять минут требуется на перенос реального актера в цифровую копию машины. Затем к внешней оболочке (коже) добавляется (встраивается) скелет, так называемый каркас. Здесь все фиксировано по частям. При анимации людей и животных применяется технология под названием "скелетные структуры", использующая реальную кинематику (в основном для прямых, размашистых движений). В случае если требуются особо точные движения, используется обратная кинематика. Угол расчета поворотов суставов высчитывается автоматом, на основе положения целевой точки и обратной кинематики, управляющей данной конечностью. Форма поверхности (кожи) и ее деформация при движении осуществляется при использовании эффекта "скининг". Можно, конечно, снять "живые ограничения", тогда получится инопланетянин ;).


Спецвыпуск Xakep, номер #034, стр. 034-056-4, ЦИФРОВАЯ РЕАЛЬНОСТЬ

ЦИФРОВАЯ РЕАЛЬНОСТЬ

Дениc Овсянников

Спецвыпуск Xakep, номер #034, стр. 034-056-4

MOTION CAPTURE

Максимальная реалистичность движений достигается применением технологии Motion Capture. Здесь уже нет необходимости учитывать компьютерную силу тяжести и специфику походки человека. Motion Capture - программно-аппаратный комплекс, осуществляющий запись движения человека. Изменения по трехмерным координатам (3D). Существует вариант детектирования (обнаружения) по видеокамерам. Для этого используют человека, одетого в черный костюм со светящимися точками. В процессе постобработки вычисляется и воссоздается картина трехмерности по этим точкам.

Также существует вариант Motion Capture при помощи магнитного поля, когда человека помечают специальными металлическими детекторами, позволяющими отследить любые движения. Для этого может использоваться специальный костюм - экзоскелет (exoskeleton). Ключевые точки с датчиками экзоскелета согласуются с компьютерным скелетом, и компьютерная модель копируют реальные движения человека. Точность повторения всех движений зависит от количества датчиков.

C 1992 года по всему миру с помощью "родителя" SimGraphics используется система отслеживания мимики человеческого лица. Компьютерный герой Марио был испытуемым. Motion Capture была также использована в Mortal Kombat (применялась оптическая технология с 6 камерами). Реалистичная мимика Half-Life также является уделом этой технологии. В случае Motion Capture для мимики датчики прикрепляются к губам человека, и их координаты согласуются с губами компьютерного персонажа.

MOTION CONTROL

Motion Control - механизм для управления движением камеры по заранее просчитанной (подготовленной) траектории. Движением механического манипулятора, присоединенного к железной руке, управляют специальные компьютеры. Используется Motion Control для съемки сложных траекторий, многоразового прохода (съемки) для достижения эффекта двойника или клонирования персонажей.

Главное и неоспоримое преимущество роботов Motion Control - создание эффекта свободно перемещающейся камеры внутри всевозможных декораций и эффекта камеры, точно повторяющей движения реального объекта. С ее помощью можно согласовать движения реальных актеров с искусственно созданным виртуальным миром.

Motion Control использовался при создании многих фильмов: «Титаник», «Аполло 13», «Пятый Элемент», «Армагеддон», «День Независимости» и других. Возможности Motion Control часто используются в съемках музыкальных клипов Bjork, Madonna, Oasis, Kylie Minogue и всевозможных рекламных роликов.

Система Motion Control позволяет связать камеру с компьютером, записать ее движение и затем повторить это движение с помощью другой камеры. Перед повторным движением камеры надо разметить голубую комнату голубыми же метками, указывающими актерам путь и направление движения, а затем заставить актеров предельно аккуратно двигаться в виртуальном пространстве, ориентируясь по этим меткам.


Спецвыпуск Xakep, номер #034, стр. 034-056-5, ЦИФРОВАЯ РЕАЛЬНОСТЬ

ЦИФРОВАЯ РЕАЛЬНОСТЬ

Дениc Овсянников

Спецвыпуск Xakep, номер #034, стр. 034-056-5

СПЕЦЭФФЕКТЫ НОВОЙ МАТРИЦЫ

Спецэффекты для "Matrix Reloaded" и "Matrix Revolutions" создавали 7 компаний, отработав 100000000 (!) зеленых и изготовив более 2500 эффектов. Так, сцена битвы Нео с оравой агентов Смитов практически полностью смоделирована на компьютере. Оригинал - один, а остальные - его цифровые копии, совмещенные с фигурами статистов. Для достижения реализма сначала Киану Ривз и Хьюго с актерами снимают главную сцену битвы. Это основа. С помощью цифровых камер Sony HDW-900 реальное изображение в трехмере (universal capture) оцифровывается на компьютере. Компьютер анализирует введенную информацию и отслеживает перемещения всех точек на лицах актеров. Некоторые углы съемки (обзора) программа просчитывает дополнительно на основе исходных данных. Таким образом, модель Смита была использована для его клонирования (замены реальных статистов). Результат получился отличный. Процесс слияния происходил в программе Mental Ray.

ЗАМОРОЖЕННОЕ ВРЕМЯ

Наверняка многих впечатлил в первый раз увиденный эффект "замороженного времени", когда вокруг остановившихся людей и пространства происходит движение камеры и изменение их пропорций (угла просмотра в нормальной скорости). Чтобы достичь заданного эффекта, необходимо следующее. Вдоль требуемой (заданной) траектории расставляются фотоаппараты или скоростные видеокамеры, установленные на специальном железном полувогнутом каркасе. Для получения одной секунды материала требуется 25 камер. С помощью специальной лазерной технологии высочайшей точности производится юстировка так, чтобы они были направлены на одну точку. Это необходимо для получения плавного движения без рывков. В зависимости от поставленной задачи используют хромакей (вырезание натуральных оригинальных объектов из плоскости зеленого или синего цветов) или декорацию. Натурные съемки практически не используются по причине ограниченности. Например, если необходимо сделать полукруг, то уже примерно через 60 градусов пути в поле зрения попадет очередной фотоаппарат, расставленный по круговой или эллипсоидной орбите. В случае декорации или использования хромакея подобный объект просто вырезается на компьютере, как лишний для мизансцены.

В сценах "Матрицы" использован хромакей и сотня видеокамер для получения, помимо "замороженного времени", ощущения происходящего движения в это же самое время. Кроме этого, задействован механизм запуска на синхронную съемку, фотокоррекция и динамические корректоры по осям (в процессе постобработки). Процесс монтажа полученных материалов напоминает обычный пленочный. Кадры берутся последовательно, иногда требуется небольшая стабилизация. После этого на место зеленых стен съемочного павильона (применяется хромакей) достраиваются в 3D небоскребы и прочее окружение.

МАТРИЦА ОНЛАЙН

Успешный проект под названием "Матрица" продолжает собирать миллионы долларов. Куй железо пока горячо, решили там и выпустили игру "Вход в матрицу". Авторы решили сделать игру и фильм неразрывными частями своего произведения. В итоге, в игре ты увидишь дополнительные видеовставки, в которых играют те же самые актеры, что и в фильме. Трехмерные модели персонажей игры сделаны максимально похожими на свои реальные прототипы: Нео, Тринити, Морфеус, Ниоби и других персонажей "Перезагрузки". Похоже, единый мир игры и фильма получился в стиле Матрицы. Но, как мне кажется, техника "на грани фантастики", а сюжет - на уровне букваря.


Спецвыпуск Xakep, номер #034, стр. 034-056-6, ЦИФРОВАЯ РЕАЛЬНОСТЬ

ЦИФРОВАЯ РЕАЛЬНОСТЬ

Дениc Овсянников

Спецвыпуск Xakep, номер #034, стр. 034-056-6

Тебя ждет огромное количество рукопашных боев и применение всевозможных "стрелялок". Погони, перестрелки, трюки - все эффекты кинематографического качества ждут тебя в этой реальности Матрицы. Порадует и "замороженное время" при помощи клавиши "Shift". При создании игры очень активно использовались последние технологии motion capture и motion control. Рендеринг трехмерных персонажей был оптимизирован под воспринимаемое большинством пространство - чем дальше объем, тем более "треугольным" он был, соответственно, качество графики достигает максимума на крупном плане. Игра "Enter the Matrix" - один из самых дорогостоящих игровых проектов с бюджетом в 30 млн. зеленых, а розничная цена составляет 50 зеленых за 4 CD.

МАШИНА ДЛЯ СЕРЬЕЗНЫХ 3D

Все по максимуму: 2-процессорная машина с устойчивой ОС, память от 1 Гб, "сильная" видеокарта, типа GeForce 4/FX, для быстрого построения каркасов в 3D моделировании.

К примеру, приведенный кадр считался на двухпроцессорной материнской плате с Пентиумами Xeon по 2,4 МГц, 1 Гб ОЗУ, GeForce FX 128 Мб 2 часа 12 минут (!) при киношном разрешении 1920х1536.

ОБРАБОТКА 3D

Просчет всегда отнимает уйму машинного времени, особенно если учитывается всевозможное преломление света, отражения и т.п. Эффект "как в жизни" достигается путем обсчета отражающей способности каждого фотона, которые воспринимаются как маленькие лампочки. Отсюда и ощущение близости к реальности и некоторая вычурность (идеальность) результата. Для ускорения просчета используют машины, соединенные в высокоскоростную сеть.

Постобработка и совмещение просчитанного в 3D-программах и отснятого реального изображения производится преимущественно в Adobe After Effects, в котором в точках совмещения используются мягкие переходы, выбирается и устанавливается нужная тоно- и цветокоррекция.

РЕАЛИСТИЧНОСТЬ 3D В КИНО

Заменит ли 3D-визуализация живых актеров? Вряд ли. Вспомни, с появлением радио предсказывали смерть газетам, с появлением телевидения - смерть радио, с появлением компьютера - смерть телевидению и общению. Всему нашлось свое место. Найдется место и искусственному кино.

Джорж Лукас лукаво считает, что новые технологии никогда не заменят живых актеров. Находясь в Италии на съемках второго эпизода "Звездных войн", режиссер сказал: "Переход кино в цифровую эру - нормальный процесс, и роль актеров в новой среде будет такой же, какой она была во времена немых фильмов. Правда, иногда возникает вопрос: не вымрет ли актерство как вид искусства с появлением более компьютерных персонажей... Задающие его забывают, что нельзя просто создать визуальное подобие человека и заставить его играть, как бы вы ни старались. Актеры требуются, чтобы его озвучить, актеры требуются, чтобы его анимировать, актеры требуются, чтобы создать характер. По моему мнению, цифровые технологии - благо для них, которое предоставит больший объем работы большему числу актеров, а не заменит их".


Спецвыпуск Xakep, номер #034, стр. 034-056-7, ЦИФРОВАЯ РЕАЛЬНОСТЬ

ЦИФРОВАЯ РЕАЛЬНОСТЬ

Дениc Овсянников

Спецвыпуск Xakep, номер #034, стр. 034-056-7

Специалисты, работающие в области 3D-графики, считают, что существующая технология (вспомни хотя бы потрясающе красивый, но провальный в прокате компьютерный фильм "Последняя фантазия" – «Final Fantasy») будет улучшаться и стремиться к совершенству постепенно.

А лет через 10 уже будет сложно отличить реальность от виртуальности. Что ж, поживем - увидим!

Основная разница между 3D-персонажами в играх и кино заключается в том, что в играх персонажи - это программы.

Максимальная реалистичность движений достигается применением технологии Motion Capture.

Спецэффекты для "Matrix Reloaded" и "Matrix Revolutions" создавали 7 компаний, отработав 100000000 (!) зеленых и изготовив более 2500 эффектов.

Все по максимуму: 2-процессорная машина с устойчивой ОС, память от 1 Гб, "сильная" видеокарта, типа GeForce 4/FX, для быстрого построения каркасов в 3D моделировании.


Спецвыпуск Xakep, номер #034, стр. 034-060-1, ВЫЖМИ НА ПОЛНУЮ

ВЫЖМИ НА ПОЛНУЮ

Дениc Овсянников

Спецвыпуск Xakep, номер #034, стр. 034-060-1

(www.ovideo.ru)

Алгоритмы сжатия мультимедиа

"Мультимедийный компьютер" - понятие уже забытое, по причине неактуальности. Сегодня на всех современных компьютерах по умолчанию стоит хорошая видеокарта, хорошая звуковая карта, плюс колонки и скоростной CD/DVD-ROM-привод. И для каждого из устройств существуют собственные мультимедийные форматы данных.

Порой информация занимает внушительные объемы (наиболее актуально для видео), тем более если это добро хранится без компрессии, то есть без сжатия. Самый простой путь сокращения объема - использовать популярные архиваторы WinRar или WinZip. Но, увы, даже с включенной опцией "мультимедийное сжатие" при архивации видеоинформации они дают выигрыш не более 30% от исходного объема, затрачивая при этом ощутимое время на процесс компрессии. О том, как правильно и эффективно работать с цифровыми форматами, как наиболее компактно хранить информацию и что будет востребовано в ближайшем будущем, читай ниже.

MP3 (MPEG-1 Layer 3)

Большинство современных игр и мультимедийных презентаций используют компрессированный звук в mp3. Прелесть этого формата (требующего хотя бы пентиума 75 МГц) заключается в том, что это первый достаточно качественный алгоритм сжатия аудиопотока, с возможностью проигрывания без предварительной разархивации в бесплатно распространяемом WinAmp’е. Ждет ли его конкуренция с более качественным и новомодным OGG или бесславно забытым VQF форматом? Нет, несмотря на то, что BBC развернула эксперимент с интернет-вещанием потокового аудио в формате OGG Vorbis. Попытка конкурентной борьбы в ближайшем будущем выглядит столь же нелепо, как конкуренция Windows с любой другой операционкой. К тому же, у всех компьютерщиков накопились многогигабайтные архивы с музыкой в mp3. В этом формате также вещают многие радиостанции FM-диапазона. Де-факто используется битрейт 192 кбит/с, привередливые эстеты предпочитают 224 и 256 кбит/с стерео, но в большинстве случаев это только увеличивает объем и практически никак не сказывается на улучшении качества воспроизведения.

JPEG2000

Качественная картинка, за исключением черного прямоугольника, обычно занимает пару мегабайт в несжатом виде. Используя модный JPG вместо маковского TIFF, ты экономишь место, сокращая размер файла в 5-10 раз. А при использовании качественного сжатия JPEG2000, экономия места возрастает еще больше, и файл уменьшается до 100 раз и более по сравнению с bmp. При использовании компрессии JPG качество теряется всегда, это плата за уменьшение размера файла. При кодировании исходная картинка переводится в цветоразностную схему YUV, что позволяет кодировать каждый канал по отдельности, с учетом его восприятия человеком. Схема, используемая при кодировании цветов, обозначается как 4:1:1 (усредняются значения цветов по 4 пикселам), в результате объем данных сокращается в 2 раза. Человеческий глаз такой "чудовищной" потери не замечает. Полученные данные группируются в блоки размером 8х8, затем используется дискретно-косинусное преобразование (DCT). Все полученные элементы разбиваются на коэффициенты, которые округляются до целого (происходит квантование). Полученные данные сжимаются методом RLE и/или Хаффмана. JPEG2000 является продолжением обычного JPG. Основные отличия в поддержке кодирования монохромных изображений, возможность сжатия без потерь, разная степень кодирования разных блоков изображения, декодирование в реальном времени. Кроме того, JPEG2000 использует волновое преобразование (wavelet) - система фильтров, применяемая к исходнику. Правда, для просмотра JPEG2000 нужен специальный плагин.


Спецвыпуск Xakep, номер #034, стр. 034-060-2, ВЫЖМИ НА ПОЛНУЮ

ВЫЖМИ НА ПОЛНУЮ

Дениc Овсянников

Спецвыпуск Xakep, номер #034, стр. 034-060-2

JPG В ДВИЖЕНИИ

При мощности компьютера от 100 МГц и соответствующей хардовой железке (видюха для ввода/вывода) можно захватывать и просматривать (нужен быстрый винт) видео с некомпрессированным звуком. Для этого применяется специальный формат сжатия M-JPEG (motion-jpeg). Для работы в формате M-JEPG подойдут карты серий DC10/20/30/50 и AV Master. С их помощью можно записать достаточно качественный ТВ-сигнал с битрейтом в 3 Мбайт/с и выше. Но свою актуальность формат M-JEPG постепенно теряет, и уже наблюдается отказ многих производителей от его поддержки. Для применения в бытовых видеопроигрывателях стандарт M-JPEG также малопригоден из-за низкого коэффициента качественного сжатия (5:1).

У M-JPEG прямой конкурент - DV, который даже при одинаковом сжатии (5:1) значительно выигрывает у M-JEPG. Информация о цвете кадра в DV урезается перед сжатием, поэтому в DV требуется меньшее сжатие (следовательно, меньшие потери качества), чем в M-JPEG. В M-JPEG коэффициент сжатия по всему кадру одинаковый, а для DV используются несколько таблиц дискретизации, чтобы для каждого макроблока применять персональные параметры компрессии.

MPEG-1

MPEG-1 (Motion Picture Expert Group) - самый древний и долгоиграющий из ныне живущих форматов. Его разрешение по умолчанию 352х288 пикселов. И хотя в теории кадр ограничивается 4095х4095 пикселами, на практике не используется качество выше VHS (бытового видеомагнитофона). Цифра 1 в формате означает то, что это первый формат подобного рода. Для записи видео на диск необходимо иметь разумный объем этого самого видео, а, следовательно, невысокий битрейт, в MPEG-1 удалось это реализовать.

Очень удобно, что твой ролик в MPEG-1 пойдет на любой машине с операционкой от Windows 95 и выше без всяких дополнительных драйверов (включая Макинтош). Почти все бытовые плееры также без проблем проигрывают Video CD. А вот с качеством, увы, не все так гладко. Повышая битрейт, можно несколько улучшить картинку, однако размер становится сопоставимым с MPEG-2 с разрешением в 2 раза больше.

Отличие формата MPEG от M-JPEG заключается в способе сжатия кадров. В MPEG-1, 2, 4 сжимаются блоки по три кадра. Сперва выделяется основной кадр и отмечается как кадр входа (Intro), сжимается по подобию JPG. Следующий за ним кадр записывает разницу в движении, вычленяемую математически, и называется предсказанным (Predicted). После него может следовать еще один предсказанный кадр. Таким образом, объем значительно уменьшается, но могут возникать и цифровые артефакты - в случае быстрой смены видеоряда битрейта попросту не хватит и возникнет "квадратичное" изображение. Также в семействе MPEG используется кадр отличий (B) между кадрами входа (I) и предсказанными кадрами (P). Кадр отличий содержит информацию для возврата к кадру входа или перехода на предсказанный кадр. Обычно информация в MPEG-1 записывается последовательной IBBPBBPBBPBBI-структурой, 1150 Кбит/с (формат VCD).


Спецвыпуск Xakep, номер #034, стр. 034-060-3, ВЫЖМИ НА ПОЛНУЮ

ВЫЖМИ НА ПОЛНУЮ

Дениc Овсянников

Спецвыпуск Xakep, номер #034, стр. 034-060-3

MPEG-2

MPEG-2 явился дальнейшим развитием и улучшением формата MPEG-1. Особую роль в появлении нового формата сыграли телевизионщики, желающие удешевить способ распространения сигнала через спутник и, в частности, до конечного пользователя, а также получить большую устойчивость к шумам. Кроме того, появилась возможность перезаписи без потери качества и профессионального нелинейного монтажа. Первая ассоциация при использовании аббревиатуры MPEG-2 - это DVD. Прежде чем попасть в эксплуатацию, формат проектировался и тестировался в течение 3 (!) лет.

В MPEG-2 была заложена возможность использования разрешения вплоть до 1920х1080 (25 кадров в секунду, с полями и без полей, с прогрессивной разверткой) и поддержка 6-канального звука. Для воспроизведения видео в формате MPEG-2 (DVD) необходим минимум PII-350 и видеокарта AGP. Поток же стандартного разрешения 720х576 составляет от 2 до 9,6 Мбит/с, плюс звуковая дорожка.

Что касается технологии, был добавлен новый алгоритм кодирования информации, который анализирует последовательные кадры в видео и строит таблицу участков повторения (матрицу повторов). Исходные оригиналы при воспроизведении просто копируются, а дубликаты при кодировании уничтожаются. В результате размер файла значительно уменьшается, а картинка, предназначенная для профессионального просмотра, не страдает.

MPEG-2 кодирует по принципу нелинейного дискретно-косинусного преобразования. Этот процесс называется квантованием, точность которого можно изменять, что влияет на размер и качество картинки. В самом процессе кодирования изображение разбивается на блоки 16х16 пискселов, что придает ограничение размерам кадра. Оно должно быть кратно 16, а в режиме чересстрочного изображения (field-by-field) - 32.

Во время первой фазы кодирования видеопоток разбивается на три составных части: основной слой, средний и высший слой. Наиболее значимый слой кодируется максимально качественно. При этом добавляется пространственное масштабирование, которое позволяет кодировать основной слой с меньшим разрешением. Эта информация используется далее в алгоритме предсказания движения для более приоритетного слоя.

В ходе дальнейшего анализа видеопотока картинка разбивается на блоки по 64 элемента (матрицы квантования) и на 2 потока. Первый, имеющий высший приоритет, состоит из низкочастотных (критичных к качеству) компонентов, а второй - из высокочастотных данных. Здесь просматривается еще одно отличие MPEG-2 - качество динамических сцен (с быстрыми сменами мизансцены или движением) значительно выше, чем у MPEG-1.

Разные по приоритетам слои используют разные уровни кодирования качества, это реализуется при помощи алгоритма SNR (анализируется соотношение сигнала и шума).


Спецвыпуск Xakep, номер #034, стр. 034-060-4, ВЫЖМИ НА ПОЛНУЮ

ВЫЖМИ НА ПОЛНУЮ

Дениc Овсянников

Спецвыпуск Xakep, номер #034, стр. 034-060-4

А временное масштабирование позволяет у менее приоритетного слоя уменьшить количество ключевых блоков, используя для высокоприоритетного слоя дополнительную информацию, которая позволит восстановить промежуточные кадры (предсказание информации для менее приоритетного слоя).

Позже появился стандарт MPEG-2 AAC (расширенное звуковое кодирование). В нем, помимо стандартного стерео, появилась возможность использовать до 5+1 аудио-каналов (левый, центральный, правый, левый окружения, правый окружения и сабвуфер (subwoofer)), а также кодирование отличного от 48 кГц звука.

Для записи на DVD и точной синхронизации видео- и аудиопотоки объединяются. Это достигается двумя способами. Первый называется Elementary Stream (простой способ) - разбивка звукового и видеопотока на пакеты. Вторым может быть:

Program Stream (программное вещание) - используется в основном для локальных передач, в сети интернет и кабельного телевидения;

Transport Stream (транспортный поток) - для передачи транспортных пакетов (длиной 188, или 188+16 бит) через спутниковые каналы или на участках сетей, где возможно большое количество ошибок.

Стандарт DVD Main вмещает 133 (или более) минуты стандартного MPEG-2 видео с многоканальным звуком 5.1, до 8 языков звукового сопровождения, субтитры на 32 языках, возможность выбора точки обзора камеры, до 9 углов зрения (camera angles), цифровую и аналоговую защиты от копирования.

MPEG-4

Говоря об MPEG-4, мы подразумеваем DivX от Microsoft. MPEG-4 - логическое продолжение и улучшение формата MPEG-2 (MPEG-3 выпал из списка по причине узкой спецификации для телевидения повышенной четкости (ТВЧ). Основное предназначение MPEG-4 - обеспечить передачу качественных мультимедийных данных через интернет. В процессе работы кодека исходное видеоизображение делится на объекты (статические и динамические) и отслеживается их вектор перемещений. Фактический объем получаемых данных более чем в 2 раза меньше, чем у MPEG-1, а качество картинки близко к DVD. Помимо стандартного используются соотношения кадра 4:3 и 16:9. На практике многие используют этот формат, чтобы получить достаточно качественную копию DVD на CD-R.

Форматы MPEG-1 и MPEG-2 пока не обеспечивают реальной возможности трансляции видео по сети интернет, создание интерактивного телевидения на их основе также не представляется возможным. По сути, MPEG-4 ориентирован не столько на сжатие видеоинформации, сколько на создание "мультимедийного контента". С использованием тех же методов, что и MPEG-1/2, дополнительно была добавлена технология психовизуального моделирования (Human Visual System). Ее суть заключается в учитывании особенности восприятия человеком видеоряда, что позволяет без особой потери в качестве уменьшить объем видеофайла на 20% и более. Кроме того, в MPEG-4 реализован механизм прогнозирования движения в последующих кадрах. Для разных типов объектов произвольной формы используются разные субформаты компрессии, оптимизирующие получаемое качество картинки. В MPEG-4 интегрированы средства для использования созданных 2D- и 3D-объектов, включая текст и графику.


Спецвыпуск Xakep, номер #034, стр. 034-060-5, ВЫЖМИ НА ПОЛНУЮ

ВЫЖМИ НА ПОЛНУЮ

Дениc Овсянников

Спецвыпуск Xakep, номер #034, стр. 034-060-5

На сегодня формат MPEG4 представлен кодеками версий 3.xx, 4.xx и 5.0x. При кодировании можно использовать одно-, двух- и многопроходное кодирование, с установкой требуемого битрейта. По умолчанию используется 780 кбит/с, диапазон же варьируется от 28 Кб/с до 6 Мбит/с. Сжатие осуществляется динамически, что наиболее рационально.

MOV

В начале 90-х был довольно распространен формат *.mov от фирмы Apple. К сожалению или к счастью, этот формат не зашел далеко в своем развитии и остался позади конкурентов. Изначально позиционировавшийся как кодек для Макинтоша, он остался закрытым для разработчиков, поэтому мы не будем его подробно рассматривать, как морально устаревший. Однако и по сей день в интернете можно найти раритеты с разрешением для "извращенцев" типа 120х90.

DV - ДЛЯ ПРОФЕССИОНАЛОВ

Прямая запись видео в цифру была достигнута только с приходом формата Digital Video (цифровое видео). Это было настоящим прорывом в качестве, так как отпала необходимость транскодирования аналог-цифра и появилась возможность многократного копирования без потерь. Стандарт IEEE 1394 был разработан фирмой Apple и нацелен на высокоскоростную мультимедиа-периферию.

Помимо "одомашнивания" видео, этим форматом пользуются профессионалы во всем мире. По спецификации ITU-R (международного профессионального ТВ-сообщества) кадр в DV стандарта PAL содержит 720 элементов по горизонтали и 576 строк. Пиксел имеет прямоугольное соотношение 1,067 (в отличие от M-JPEG с квадратным пикселем) и персональные значения YUV (яркость и 2 цветоразностных сигнала U и V). Каждому отводится по 1 байту. При равном числе независимых значений обозначается как 4:4:4, что довольно расточительно с точки зрения ресурсов. Обычно в работе используется соотношение 4:2:2 (в 1 строке в 2 раза меньше пикселов). В DV для камер субформата DVCAM, поддерживаемого фирмой SONY, уменьшают еще и цветовое разрешение. В итоге формат работы - 4:2:0, а цветовая матрица - 360х288 пикселов. Физическое разрешение формата при матрице CCD - от 500 линий. DV-формат является альтернативой более дорогому и профессиональному аналоговому формату Betacam SP.

Хотя шкала представления графики в компьютере по RGB измеряется от 0,0,0 до 255,255,255 для каждой точки, что в совокупности и дает 16,7 млн. цветов, в DV используется ограничение. Любое изображение стандарта DV усекается в части динамического диапазона значений от 8,8,8 (черный) до 235,235,235 (белый).

Материал в DV обычно 25 Мбит/с или 3,6 Мбайт/с с несжатым стереозвуком 48 кГц и 16 бит на канал. Существует формат записи, позволяющий записать 4 аудиоканала с частотой 32 кГц и глубиной 12 бит. Достигается такая плотность записи с помощью DCT (дискретно-косинусного преобразования). Компрессия по видео имеет постоянную величину (5:1), минута DV занимает 200 Мбайт, а на стандартную видеокассету mini-DV помещается 60 минут. При использовании субформатов DVCam и DVCPro изменяется только сам способ кодирования. При записи в любом из этих субформатов DV на ленту пишется до 1/3 избыточной информации для восстановления (маскирования ошибок) исходников в случае повреждения ленты, что никак не влияет на формат представления DV в компьютере. Фактически для перегона DV в компьютер не используются никакие платы для оцифровки сигнала, происходит прямое копирование с помощью системного устройства (его цена от 20 долларов).


Спецвыпуск Xakep, номер #034, стр. 034-060-6, ВЫЖМИ НА ПОЛНУЮ

ВЫЖМИ НА ПОЛНУЮ

Дениc Овсянников

Спецвыпуск Xakep, номер #034, стр. 034-060-6

ПРИМЕНЕНИЕ

На сегодняшний день многие видеокамеры пишут либо в формате DV, либо в формате MPEG-2. К примеру, серия видеокамер MV (диск mini DVD) позволяет писать в формате MPEG-2 с фиксированным потоком 12 Мбит/с. Имея в своем распоряжении видеокассету MV размером со спичечный коробок, ты сможешь записать до 60 (!) минут.

Вещание со спутников также идет в формате MPEG-2, что позволяет на одну полосу стандартного аналогового сигнала уместить 4 цифровых с улучшенными характеристиками и возможной встроенной защитой от несанкционированного просмотра. Наземное вещание цифрового ТВ планируется в России в 2010 году, в Европе это действо запланировано на 2006 год, что, несомненно, увеличит число транслируемых каналов и значительно улучшит качество картинки. А интерактивные возможности будут многократно превосходить возможности устаревающего телетекста.

Формат DV поддерживается консорциумом 60 производителей, в числе которых Canon, JVC, Panasonic, Sharp и Sony. Три основных варианта DV - потребительский DV, DVCAM фирмы Sony и DVCPRO фирмы Panasonic - имеют некоторые различия, которые, однако, не влияют на качество изображения. Во всех трех вариантах записи стандартное качество картинки абсолютно одинаково. Именно поэтому данный формат представляется доминирующим на рынке персональных компьютеров, как минимум в ближайшее десятилетие. Вероятно, появится формат DV-2 для записи видео повышенного качества сразу в цифру.

Текущее поколение DVD плавно сменится Blue-ray DVD (или AOD, а может их жестокой помесью - прим. ред.), перезаписываемыми дисками, способными вмещать по 23 Гб в версии 1.0 и доступными уже сегодня по цене 25 евро. Эра подобных супер-DVD продолжит свое развитие. Уже сейчас Blue-ray-диск способен вместить до 2 часов видео высокой четкости, а скорость передачи данных составляет 36 Мб/с.

Что до интернета, то с увеличением повсеместной скорости доступа до 100 Мбит/с, проблема объема данных исчезнет сама собой. С удешевлением трафика появится реальное ТВ через интернет. И через несколько лет цифровые форматы будут доминировать, окончательно вытеснив все аналоговые.

Используя модный JPG вместо маковского TIFF, ты экономишь место, сокращая размер файла в 5-10 раз. А при использовании качественного сжатия JPEG2000, экономия места возрастает еще больше, и файл уменьшается до 100 раз и более по сравнению с bmp.

Для записи видео на диск необходимо иметь разумный объем этого самого видео, а, следовательно, невысокий битрейт, в MPEG-1 удалось это реализовать.


Спецвыпуск Xakep, номер #034, стр. 034-060-7, ВЫЖМИ НА ПОЛНУЮ

ВЫЖМИ НА ПОЛНУЮ

Дениc Овсянников

Спецвыпуск Xakep, номер #034, стр. 034-060-7

Основное предназначение MPEG-4 - обеспечить передачу качественных мультимедийных данных через интернет.

Наземное вещание цифрового ТВ планируется в России в 2010 году, в Европе это действо запланировано на 2006 год, что, несомненно, увеличит число транслируемых каналов и значительно улучшит качество картинки.

Ты можешь без особых проблем записать в MPEG-1 стандартный 90-минутный фильм с видеокассеты VHS на 2 диска.


Спецвыпуск Xakep, номер #034, стр. 034-064-1, ПОЛНОЭКРАННОЕ ВИДЕО БЕЗ ТОРМОЗОВ

ПОЛНОЭКРАННОЕ ВИДЕО БЕЗ ТОРМОЗОВ

Дениc Овсянников

Спецвыпуск Xakep, номер #034, стр. 034-064-1

(www.ovideo.ru)

Графические акселераторы изнутри

Эпоха CGA, EGA, VGA и даже SVGA ушла безвозвратно, 1024х768хTrue Color - минимум по умолчанию. HDTV стучится в дверь, а впереди разрешение 1920х1080. При больших разрешениях (близких к 1600х1200) многие игры с качественной графикой тормозят. Устранить тормоза позволяют современные 3D ускорители.

ВВЕДЕНИЕ

Традиционный путь отображения 3D объектов - это сетчатая структура из полигонов, обычно многоугольников. Чем больше многоугольников разной фактуры отображается, тем качественнее получается изображение. При стандартном подходе все операции по визуализации выполняет процессор. Умные люди предложили альтернативный вариант: все операции по просчету цвета и яркости, местоположения каждого пиксела и всей 3D композиции выполняет видеоускоритель. Вершины полигонов, характеристики пространства, область и место обзора, источники света и общий фон выгружаются для обработки в память 3D карты. Затем ускоритель производит оптимизацию по 3D. Процессор в это время остается свободным для выполнения других задач.

На сегодня самыми востребованными языками программирования трехмерных структур являются OpenGL и Direct3D. Графический процессор берет на себя всю "черную" работу по визуализации из графических примитивов и чертежей в самое что ни на есть реальное кино. Впрочем, есть одно но. Каждая версия Direct3D добавляет новые возможности, которые лениво перетекают в новомодные графические ускорители. Чтобы как-то сгладить этот не совсем адекватный процесс, была создана программа Шейдер. С ее помощью аниматор сможет без особых проблем конструировать новые спецэффекты, используя аппаратные ресурсы современных 3D видеоускорителей. Существует многообразие шейдеров: пиксельные шейдеры (для обработки точек), вершинные шейдеры, адресные и цветовые шейдеры. Например, вершинный шейдер может содержать 128 инструкций и использовать до 96 констант в описании.

ПИКСЕЛЬНЫЕ И ВЕРШИННЫЕ ШЕЙДЕРЫ

Пиксельный шейдер - это небольшая программа, которая изменяет атрибуты отдельных пикселов, что позволяет создавать очень реалистичное освещение и разнообразные эффекты с ним. Вершинные шейдеры занимаются модификацией вертексных данных, благодаря которым и появляются все новые и новые эффекты, типа анимированных объектов, игры света и тени, реалистичных взрывов, продвинутой анимации выражения лица с синхронизацией движений губ в такт речи и т.д.

OpenGL

Это кросс-платформенная технология, задающая стандарт 3D генерации и 3D ускорений в просчетах для программ трехмерного моделирования. Программные модули реального времени имеются во всех версиях систем Windows, Linux и Unix. Наличие аппаратной поддержки OpenGL у ускорителя позволяет значительно сэкономить ресурсы процессора.

На сегодня большинство программ, и в особенности игр, используют в своей работе огромные массивы данных, которые обрабатываются технологией OpenGL в реальном времени (аппаратным ускорителем геометрии пространства - свет, масштабирование, рендеринг). OpenGL прописывает стандарты по ускорению визуализации мелких деталей, специальные спецэффекты к изображению без ухудшения производительности, включая туман, сглаживание, текстурирование, размытие в движении, прозрачность, отражение, 3D текстуры, объем пространства в реальном времени и т.п.


Спецвыпуск Xakep, номер #034, стр. 034-064-2, ПОЛНОЭКРАННОЕ ВИДЕО БЕЗ ТОРМОЗОВ

ПОЛНОЭКРАННОЕ ВИДЕО БЕЗ ТОРМОЗОВ

Дениc Овсянников

Спецвыпуск Xakep, номер #034, стр. 034-064-2

Direct3D

Это стандартная библиотека от Microsoft DirectX, описывающая механизмы реализации трехмерных функций и процедур. Является своеобразной альтернативой OpenGL, примерно равной ей по функциональности. Применяют Direct3D в ОС Windows для работы программ с трехмерной графикой в реал-тайм. Стандарт принес с собой ряд функций трехмерной графики и ряд спецификаций. Аналогично ряд функций обрабатывается аппаратно, высвобождая ресурсы процессора. При отсутствии аппаратной поддержки все функции Direct3D могут быть реализованы программно, что обеспечивается на уровне библиотек.

DirectDraw - составная часть Direct3D, отвечающая за качественную прорисовку. DirectSound - воспроизведение аудио, включая микшеры, звуковые спецэффекты, звук окружения. Система рендеринга оптимизирует распределение 3D объектов, текстур и прочих необходимых данных для быстрого и качественного процесса визуализации.

ОСНОВНЫЕ 3D ИНТЕРФЕЙСЫ API

Direct3D API Retained Mode - высокоуровневый менеджер трехмерных графических сцен, позволяющий разработчикам работать с объектами, строить сложные движения в трехмерных сценах, не используя низкоуровневое программирование;

DirectShow API - стандартизированная архитектура потоковой передачи мультимедиа данных. Включает оцифровку, обработку и воспроизведение мультимедиа информации в сети интернет в потоковом режиме (реал-тайм);

DirectAnimation API - усовершенствованный интерфейс прикладного программирования для совмещения информации различных типов. Разработчики получают более широкие возможности доступа к структуре и взаимосвязи своих мультимедийных объектов;

DirectPlay API - высокоуровневое средство создания сетевых компьютерных игр.

КОНВЕЙЕР РЕНДЕРИНГА

Каждая стадия обработки (построения) изображения представляет собой, условно говоря, конвейер. Обычный 3D ускоритель ускоряет лишь некоторые стадии процесса. Вкратце конвейер работает так. Строится каркас сцены, затем происходит тесселяция (дробление объекта, поверхности на треугольники), масштабирование, добавление света, проецирование, растеризация - все это стадии просчета, которые могут быть оптимизированы и обработаны твоим 3D ускорителем. Естественно, шина AGP и геометрический сопроцессор должны присутствовать по умолчанию на достойных экземплярах 3D видеокарт.

РАБОТА В РЕАЛЬНОМ ВРЕМЕНИ

Ключ к получению качественной 3D графики в реальном времени заключается в создании правильной системной архитектуры, организованном доступе к памяти для быстрого просчета и правильном исключении невидимых объектов и слоев для освобождения рабочей памяти. Загрузка процессами не должна тормозить систему (не менее 30 кадров в секунду). Лучшие акселераторы позволяют оптимизировать и обработать аппаратно математические функции, которые дают основную нагрузку на процессор. Не следует забывать, что производительность ускорителя зависит и от центрального процессора, объема и скорости памяти ПК. Скорость работы видеоускорителя оценивают в количестве прорисовки треугольников в секунду и скорости прорисовки точек в секунду (fill rate). Помимо этих характеристик используются другие тесты fps (количество кадров в секунду) в 3D шутерах типа Quake 3 Arena, Doom III. При этом получаешь реальную картину работы 3D ускорителя в полевых условиях.


Спецвыпуск Xakep, номер #034, стр. 034-064-3, ПОЛНОЭКРАННОЕ ВИДЕО БЕЗ ТОРМОЗОВ

ПОЛНОЭКРАННОЕ ВИДЕО БЕЗ ТОРМОЗОВ

Дениc Овсянников

Спецвыпуск Xakep, номер #034, стр. 034-064-3

Профессиональный 3D ускоритель проделывает большую работу для того, чтобы с максимальным качеством обработать каждый пиксел, выводящийся на экран монитора. С максимальной скоростью кадр считывается полностью для вывода в буфер видеопамяти. Затем алгоритм вычисляет глубину из точки обзора всех пикселов и полигонов, основываясь на полученной информации, отсекает все перекрытые точки (лишние для данного кадра). При этом достигается большая гибкость в полученном полигональном эскизе, который позволяет объектам вливаться в полученную реальность.

Для того чтобы лучше представить, почему одни графические решения предпочтительнее других, я объясню некоторые основы 3D рендеринга. Проблема делится на 3 основных части: обработка пространства (среда окружения), геометрическая обработка и световое моделирование, генерация пикселей.

ПРОСТРАНСТВО

Все объекты в пространстве имеют трехмерные координаты, вексели. Зная угол обзора и релевантное смещение от оригинала, создается видимая картина из динамических и статических объектов. Статичные объекты - это все, включая всю территорию, здания и что-либо неподвижное во время моделирования. Текстуры обычно имеют размер 64х64, 128х128 или 256х256 пикселов. Все лишние полигоны, "вылезающие" за пределы видимого экрана, вырезаются из процесса моделирования. Это необходимо на начальной фазе построения каркаса для высвобождения максимума потенциала визуализации. Полученная виртуальная сцена из оставшихся полигонов пересылается в геометрический процессор.

ГЕОМЕТРИЧЕСКАЯ ОБРАБОТКА

Этап создания правильной геометрии объектов также проходит в режиме реального времени. Геометрический процессор обрабатывает "уцелевшие" полигоны методом векторного переноса. В процессе трансформации над перспективой можно довольно легко вращать каждый полученный вектор, перемещая его на новые координаты. На этой стадии также происходит тесселяция (разбиение геометрических моделей на многоугольники или треугольники). В параметры окружения для обработки в геометрическом процессоре включаются: интенсивность дыма/тумана и освещенность (рассеянный, окружающий, отражающий свет). Эта информация необходима для точного воспроизведение цветовой окраски и придания максимального реализма при обработке.

СВЕТОВОЕ МОДЕЛИРОВАНИЕ

Цвет полигонной вершины и координаты текстуры - важный внутренний параметр, обычно добавляется во время моделирования. Геометрический процессор может изменять значения цвета вершины согласно световой модели. Уровень света окружения может быть любым, включая темный. Качественное световое моделирование просчитывается для каждого из многоугольников, образующих поверхность. От этого напрямую зависит качество наложения текстур.


Спецвыпуск Xakep, номер #034, стр. 034-064-4, ПОЛНОЭКРАННОЕ ВИДЕО БЕЗ ТОРМОЗОВ

ПОЛНОЭКРАННОЕ ВИДЕО БЕЗ ТОРМОЗОВ

Дениc Овсянников

Спецвыпуск Xakep, номер #034, стр. 034-064-4

ПРОСЧЕТ ПИКСЕЛОВ

Рендеринг тоже продолжается в режиме реального времени. Цвета всех пикселов изображения должны быть обработаны при каждом обновлении экрана. В блоке обработки текстур вычисляется цвет пиксела, если точка видна. При просчете цвета точки используется помимо RGB цвета еще и A-альфа канал ее видимости (прозрачности). Прозрачность (видимость) каждой точки определяется с помощью Z-буфера (альфа-канала). При построении светящихся объектов, правильных источников света и огненных эффектов степень прозрачности играет важную роль в реализме картинки.

РАСТЕРИЗОВАНИЕ

Растеризование - необходимое действие для преобразования каждого полигона в частички изображения, согласно геометрической модели и с учетом индивидуального цвета, глубины, текстуры, преломлений света, тени и сглаживания. Интерполяция и сглаживание проходят в несколько этапов: устранение квадратичной структуры и устранение мелких "мерцающих" деталей в фокусе бесконечности. Самая качественная - анизотропная фильтрация. С ее помощью удается достичь максимального реализма при создании эффекта металла (металлического блеска), мрамора и всевозможных отражений.

Помимо добавления специальных эффектов, к полученному кадру может быть применен метод полноэкранного сглаживания. При этом исходная картинка рассчитывается с несколько большим разрешением, нежели конечный вариант. Итоговое изображение буквально сжимается и становится объективно лучше, без острых краев и "зазубрин".

ХАРАКТЕРИСТИКИ ЧИПСЕТА ATI RADEON 9700 PRO

* технология изготовления - 0.15 мкм;

* число транзисторов - около 110 миллионов;

* тактовая частота - 325 МГц;

* шина памяти - 256 бит DDR SDRAM;

* максимальный объем видеопамяти - 256 Мб;

* тактовая частота видеопамяти - 620 МГц;

* поддержка AGP 2X, 4X, 8X и Universal AGP 3.0 (2X/4X/8X);

* восемь пиксельных конвейеров (технология SMARTSHADER 2.0);

* один блок выборки текстур в каждом пиксельном процессоре;

* поддержка билинейной, трилинейной, анизотропной и сочетания трилинейной и анизотропной фильтрации текстур;

* четыре вершинных конвейера (технология SMARTSHADER 2.0);

* поддержка полноэкранного сглаживания (технология SMOOTHVISION 2.0);

* поддержка технологии TRUFORM 2.0;

* поддержка технологии HyperZ III;

* поддержка технологии VIDEOSHADER;

* поддержка технологии FULLSTREAM;

* аппаратная декомпрессия DVD, адаптивный деинтерлейсинг, компенсация движения;

* два CRT-контроллера;

* два RAMDAC с частотой 400 МГц.

SMOOTHVISION 2.0 является новым методом полноэкранного сглаживания, который позволяет убирать "ступеньки" на границах полигонов. Причем именно на границах, что значительно снижает нагрузку на шину памяти и увеличивает тем самым производительность в игрушках с настройками "по максимуму". Также SMOOTHVISION 2.0 может работать при любых высоких разрешениях, чем не могут похвастаться большинство современных видеокарточек.

TRUFORM 2.0 - это логическое продолжение технологии ATi TRUFORM, получающей из игрушки инфу о полигонах, а затем преобразующей кривые поверхности в гораздо более реалистичные. Персонажи и объекты в игрушках, "обработанные" TRUFORM 2.0, выглядят как настоящие.


Спецвыпуск Xakep, номер #034, стр. 034-064-5, ПОЛНОЭКРАННОЕ ВИДЕО БЕЗ ТОРМОЗОВ

ПОЛНОЭКРАННОЕ ВИДЕО БЕЗ ТОРМОЗОВ

Дениc Овсянников

Спецвыпуск Xakep, номер #034, стр. 034-064-5

HyperZ III повышает эффективность использования пропускной способности видеопамяти за счет прорисовки только тех пикселов, которые находятся в поле зрения наблюдателя.

Технология VIDEOSHADER позволяет задействовать пиксельные шейдеры для обработки видеопотока, что избавляет его от многочисленных артефактов, а также улучшает цветопередачу и подавляет шумы. А фильтрацией глюков компрессии MPEG4/DivX занимается непосредственно технология FULLSTREAM.

ТЕНДЕНЦИИ

Процесс развития 3D ускорителей, равно как и борьбы лидеров этого рынка ATI и Nvidia, к счастью для нас, закончится не скоро. Значит, будут появляться еще более продвинутые технические решения по умеренным ценам. Последняя разработка компании ATI - карта Ati Radeon 9800 Pro со 128 Мб памяти на борту. Она предназначена для быстрого GPU от ATI и является второй по производительности в линейке ATI ускорителей (у первой 256 Мб и DDR2). Не менее приятно, что по сравнению с версией 9700 она работает устойчивее. Отличительная особенность - 8-конвейерный движок вкупе с 256 Мб памяти DDR2. 256-битная память увеличивает пропускную способность для реал-тайм 3D графики и поражает кинематографическим качеством, на уровне Голливудских студий. Благодаря технологиям SmartShaderT 2.1 и SmoothVisionT 2.1 достигается безупречная четкость и чистота текстур, без падения частоты кадров и при поддержке MicrosoftR DirectXR 9.0 и OpenGLR. Технологии FullStreamT и VideoShaderT вычищают появляющиеся артефакты из трансляций видео через интернет для более качественного просмотра, синхронно улучшая картинку.

Поражают возможности новой карты GeForce FX от компании Nvidia, наглядно демонстрируемые при создании виртуальной девушки Феи Рассвета. Раньше компьютеру потребовалось бы несколько часов на просчет каждого кадра, а теперь все обрабатывается в реал-тайм и с высокой степенью детализации.

"Если посмотреть на то, как сегодня рисуются компьютерные игры, видно, что у персонажей естественный цвет кожи, у них есть глаза, нос и рот. Но им не хватает тех маленьких погрешностей, которые могли бы сделать их реалистичными. Обычно, чем ближе вы рассматриваете компьютерный персонаж, тем хуже становится качество изображения. С нашей Феей все наоборот. Чем ближе ты на нее смотришь, тем лучше она становится. Фея состоит из более чем 150 тысяч треугольников, которые связаны между собой в сетку. Контролируя эту сетку, процессор создает все те реалистичные движения, которые можно увидеть в нашем демонстрационном фильме", - сказал представитель Nvidia Эндрю Хамбар.

P.S. При написании статьи были использованы материалы bbcnews.com и intel.com.

СЛОВАРЬ ТЕРМИНОВ

3D pipeline (3D конвейер) - ряд процессов, направленных на получение единого целого при моделировании трехмерной среды и получение итоговой копии изображения на мониторе. Включает 3 основных стадии: мозаичное (многоугольное) разбиение плоскостей и объектов, геометрический блок вычислений и финальную визуализацию.


Спецвыпуск Xakep, номер #034, стр. 034-064-6, ПОЛНОЭКРАННОЕ ВИДЕО БЕЗ ТОРМОЗОВ

ПОЛНОЭКРАННОЕ ВИДЕО БЕЗ ТОРМОЗОВ

Дениc Овсянников

Спецвыпуск Xakep, номер #034, стр. 034-064-6

Alpha Buffering (альфа-буферизация) - способ присвоения получаемой точке степени прозрачности, которая может иметь значение от 0 (полностью непрозрачная) до 255 (видимая полностью).

Anisotropic filtrating (анизотропная) фильтрация - самый сложный вид фильтрации. За цвет пиксела принимается средний цвет эллипса из текселей. При генерации одного пиксела может учитываться до 32 текселей.

Bilinear filtrating (билинейная фильтрация) - в данном случае среднее значение цвета 4 смежных текселей на текстуре берется за цвет любого из них. В итоге 4 текселя закрашиваются одним и тем же цветом, что позволяет проделывать плавные (замедленные) движения без видимых искажений.

Bump mapping (рельефное наложение) - при использовании этой технологии обычная текстура становится похожа на рельефную основу (из плоского в объем).

Edge antialiasing (сглаживание краев) - фильтрация изображения целиком, либо отдельных структур с целью "удаления" видимых краев.

Tessellation (мозаика) - разбиение изображения на мелкие формы: треугольники, четырехугольники или многоугольники.

Trilinear filtrating (трилинейная фильтрация) - один из способов фильтрации текстур. Из 8 цветов (4 текселей из одного мип-уровня и 4 из другого) текселей вычисляется среднее значение цвета. Как результат, все тексели будут иметь одинаковый цвет, что позволяет избежать искажений при масштабировании изображения.

www.ixbt.com/video.shtml

www.3dnews.ru

www.radeon2.ru

www.overclockers.ru

www.3dfiles.ru

www.nvrussia.ru

www.nvworld.ru

www.anandtech.com

www.3dhardware.net

www.tomshardware.com

Каждая стадия обработки (построения) изображения представляет собой, условно говоря, конвейер. Строится каркас сцены, затем происходит тесселяция (дробление объекта, поверхности на треугольники), масштабирование, добавление света, проецирование, растеризация - все это стадии просчета, которые могут быть оптимизированы и обработаны твоим 3D ускорителем.

Все объекты в пространстве имеют трехмерные координаты, вексели. Зная угол обзора и релевантное смещение от оригинала, создается видимая картина из динамических и статических объектов.

При просчете цвета точки используется помимо RGB цвета еще и A-альфа канал ее видимости (прозрачности). Прозрачность (видимость) каждой точки определяется с помощью Z-буфера (альфа-канала).

Самая качественная - анизотропная фильтрация. С ее помощью удается достичь максимального реализма при создании эффекта металла (металлического блеска), мрамора и всевозможных отражений.


Спецвыпуск Xakep, номер #034, стр. 034-068-1, ОТ ЛЯГУШКИ ДО ПОЛИМЕРА

ОТ ЛЯГУШКИ ДО ПОЛИМЕРА

Каролик Андрей, Анисимов

Спецвыпуск Xakep, номер #034, стр. 034-068-1

(andrusha@sl.ru), (компания "AZ", GP Batteries)

Батарейки и аккумуляторы - технологии и тенденции

Первое знакомство человека с принципом, который лежит в основе работы источников тока, впервые произошло в 1798 году.

Тогда Луиджи Гальвано в эксперименте с лягушкой открыл способ преобразования химической энергии в электрическую (лягушка весело дрыгает лапками, если на нее капать кислотой). Позже (в 1888 году) Гасснер изобрел первую переносную батарейку, предложив заключить компоненты в специальную оболочку. В 1859 году Гастон Планте изобрел первый аккумулятор, появилась возможность многократной перезарядки. В 1947 был изобретен никель-кадмиевый аккумулятор, а в 1960 году на свет появилась первая алкалиновая батарейка. В 1990 году изобрели более эффективный никель-металл-гидридный аккумулятор. И, наконец, в 1999 году стала доступна последняя разработка - литиум-ион-полимерный аккумулятор. Буквально за 200 лет человечество сделало революционный прорыв вперед. Но что ты знаешь о современных батарейках и аккумуляторах? А ведь по статистике, за год в России один житель в среднем потребляет до 10 обычных батареек, следовательно, стране необходимо более 1,5 миллиарда батареек в год, что в денежном эквиваленте составляет около полумиллиарда (!) зеленых фантиков.

КЛАССИФИКАЦИЯ

Следует отметить, что изначально батарейки и аккумуляторы разрабатывались для военных нужд, начиная со времен Первой мировой войны, когда появились телеграф, автомобиль, самоходная установка, светильник, радио и т.д. Но основным толчком к развитию послужила Вторая мировая война и период холодной войны. Современные обозначения батареек и аккумуляторов пошли именно из военных стандартов.

Американский военный стандарт подразумевает обозначение латинскими буквами алфавита (кроме B, которая обозначает просто батарейку) - A, C, D, E... Обозначение A впоследствии отошло к аккумуляторам, а батарейка модифицировалась по высоте, и, чтобы отличать, ее назвали АА. В народе ее привыкли называть пальчиковой, так как по размерам она соизмерима с пальцами руки. Модифицированная по диаметру (более тонкая), она обозначается уже ААА. Есть в природе и АААА, выпускается в Штатах.

В России особо не заморачивались, называя батарейки 316, 373, 343 и т.д. То есть военные использовали просто порядковый номер изделия. Всего в СССР производилось около 20000 различных источников тока, включая промышленные.

Международная классификация, как мне кажется, более логична и включает в себя:

* количество элементов батареек (к примеру, батарейка с напряжением 4,5 В состоит из 3 элементов, а 9В - из 6 элементов);

* признак химической системы (из чего сделан источник тока);

* форм-фактор (R - круглая, F - квадратная);

* калибр.

Так, к примеру, LR6 - это щелочная батарейка (марганец-цинковая система), круглая, 6 калибра. Сейчас все новые источники тока маркируются не по калибру, а по диаметру и длине (что намного удобнее для обывателя):

* первые две цифры - диаметр;

* следующие три цифры - длина (в десятых долях миллиметра).

Пример: GR18650 (аккумулятор для ноутбука) - литий-ионный, диаметром 18 и длиной 65 миллиметров.


Спецвыпуск Xakep, номер #034, стр. 034-068-2, ОТ ЛЯГУШКИ ДО ПОЛИМЕРА

ОТ ЛЯГУШКИ ДО ПОЛИМЕРА

Каролик Андрей, Анисимов

Спецвыпуск Xakep, номер #034, стр. 034-068-2

Самый популярный типоразмер - АА, его доля составляет около 85% потребляемых батареек (из них примерно десятая часть - ААА). Чуть более 10% приходится на четыре других типоразмера: средние, большие, плоские и 9-вольтовые батарейки. Все остальные батарейки составляют не более 5%.

ТЕХНОЛОГИИ И ТЕНДЕНЦИИ

Постоянно совершенствуются технологии и материалы, повышается чистота получаемых материалов, появляются новые области применения, которые задают новые требования к источникам тока. К примеру, алкалиновые батарейки получили массовое распространение еще 10-15 лет назад. У них были прекрасные показатели, но они были значительно дороже своих аналогов, поэтому использовались редко и преимущественно в устройствах длительного пользования. Со временем появились энергоемкие устройства (фототехника, видеотехника, аудиотехника и т.п.), в основном это цифра, которой требуются источники тока большой мощности. Эту нишу и заняли алкалиновые батарейки, теперь ты периодически видишь рекламу бегающего зайчика :).

Кроме того, сейчас происходит совмещение технологий производства аккумуляторов и производства батареек, хотя они совершенно разные. Смысл совмещения заключается в том, что обычная одноразовая батарейка изготавливается по технологии аккумулятора. Напомню, что внутренности обычной батарейки - стаканчик, в который насыпан активный материал и вставлен стерженек (все разбирали в детстве батарейку об асфальт). Это простейшая конструкция, очень дешевая, но зазоры между электродами значительные и не позволяют работать на больших токах. А аккумулятор сделан рулоном, то есть два электрода свернуты трубочкой, что значительно уменьшает зазоры между ними. Совмещенный вариант - никель-цинковая батарейка, один электрод взят из аккумулятора, а другой - из батарейки. При этом форм-фактор прежний - АА. Емкость существенно не увеличилась, но срок службы при использовании на больших токах увеличился в 3-3,5 раза.

Есть, конечно, еще литиевые батарейки, емкость которых значительно выше, но литиевую батарейку нельзя сделать таких же габаритов, иначе будет несовместимость по напряжению (литиевые батарейки обычно 3-вольтовые). К тому же литий в 3 раза дороже, не говоря об экологии. Таким образом, никель-цинковая батарейка идеально подходит для использования там, где нужны очень большие токи и форм-фактор АА, работая в 3-4 раза дольше обычных батареек без перезарядки.

ВЫБОР БАТАРЕЕК

Сравнивать батарейки в лоб - не всегда корректно. Необходимо учитывать, кем сделаны сравниваемые батарейки и, что не менее важно, где они сделаны. Потому что батарейки одной торговой марки могут быть произведены на разных заводах. К примеру, Бельгия, Штаты, Япония и Китай - четыре совершенно разных завода (разное оборудование), а следовательно, четыре разных уровня качества. Хотя минимально допустимым параметрам они соответствуют (международные стандарты и т.п.), потребительские свойства у них разные.

Нельзя, к примеру, сравнивать Samsung и Panasonic, если не известно, где сделана батарейка. Panasonic для нашей страны штампует батарейки только в Бельгии, а вот Samsung делает батарейки на разных заводах, в том числе и в Китае. С другой стороны, бессмысленно сравнивать Philips и Panasonic, потому что они делают батарейки на одном и том же заводе.


Спецвыпуск Xakep, номер #034, стр. 034-068-3, ОТ ЛЯГУШКИ ДО ПОЛИМЕРА

ОТ ЛЯГУШКИ ДО ПОЛИМЕРА

Каролик Андрей, Анисимов

Спецвыпуск Xakep, номер #034, стр. 034-068-3

АККУМУЛЯТОР vs АЛКАЛИНОВАЯ БАТАРЕЙКА

Уже сейчас аккумуляторы здорово "наступают" на пятки батарейкам. Десять лет назад были широко распространены никель-кадмиевые (Ni-Cd) аккумуляторы, которые были менее емкие, нежели батарейки. К тому же кадмий считается экологически опасным и сегодня запрещен для использования в батарейках (у нас пока запрета нет). С появлением же никель-металл-гидридных аккумуляторов ситуация стала в корне меняться, масла в огонь подлила и новая технология перезарядки.

Аккумуляторы стали совместимы по размерам с батарейками, что обеспечило полную взаимозаменяемость. Хотя говорят, что напряжение батарейки 1,5 В, а аккумулятора - 1,2 В, но это напряжение без нагрузки. Если их подключить к любому прибору, то рабочее напряжение будет примерно одинаковое (под нагрузкой). Поэтому в приборах взаимозаменяемость батареек и аккумуляторов существует без ограничений.

НИКЕЛЬ-МЕТАЛЛ-ГИДРИДНЫЙ АККУМУЛЯТОР

Основной плюс этого аккумулятора заключается в том, что по емкости он в 2 раза больше предыдущих аналогов - 2,4 ампер-часа. А при использовании в устройствах с высокими токами потребления аккумулятор, благодаря своей конструкции (меньшие зазоры между электродами), работает дольше, чем алкалиновая батарейка. Для примера можно взять аккумулятор GP Batteries емкостью 2,2 ампер-часа и алкалиновую батарейку Duracell с теоретической емкостью 3,5 ампер-часа - в цифровом фото аккумулятор работает в 2 раза дольше. Причина в том, что коэффициент использования материала в аккумуляторе выше, чем в батарейке. Из-за того, что расстояние между электродами в батарейке больше, компоненты не успевают перемещаться от одного электрода к другому при больших токах потребления. В аккумуляторе электроды обычно расположены спирально, расстояния между электродами измеряются долями миллиметра, и коэффициент использования материалов в аккумуляторе равен практически 100%. Батарейка не рассчитана на подобные режимы работы (большие токи) и ее коэффициент использования не превышает 50%. То есть емкость аккумулятора очень мало зависит от того, каким током его разряжать.

НОВАЯ ТЕХНОЛОГИЯ ПЕРЕЗАРЯДКИ

У аккумулятора была еще одна существенная проблема - раньше для перезарядки требовалась как минимум ночь, что не всегда было удобно. Порой приходилось заряжать сразу несколько комплектов, при этом один комплект работал меньше, чем алкалиновая батарейка. Сейчас уже существует технология и устройства, заряжающие аккумуляторы за 0,5-1 час. Для этого в зарядном устройстве стоит специальный микропроцессор, который анализирует состояние каждого аккумулятора индивидуально и отслеживает изменения параметров, поддерживая оптимальный режим зарядки (рабочая температура и ток зарядки). Некоторые подобные зарядные устройства дополнительно снабжаются встроенными вентиляторами, чтобы охлаждать аккумуляторы, поддерживая необходимый температурный режим.


Спецвыпуск Xakep, номер #034, стр. 034-068-4, ОТ ЛЯГУШКИ ДО ПОЛИМЕРА

ОТ ЛЯГУШКИ ДО ПОЛИМЕРА

Каролик Андрей, Анисимов

Спецвыпуск Xakep, номер #034, стр. 034-068-4

Подобные устройства уже выпускают и продают GP - PowerBank (www.powerbank.ru), на подходе и другие основные игроки: Duracell, Panasonic и т.п.

ТОПЛИВНЫЕ ЭЛЕМЕНТЫ - ТЕХНОЛОГИЯ БУДУЩЕГО

Об этой технологии говорят давно, а первые топливные элементы появились 20-25 лет назад (для тех же электромобилей). Но они были единичными, так как не существовало ни соответствующих технологий производства, ни материалов, ни устройств контроля, чтобы создать относительно дешевые топливные элементы, которые проработают достаточно долго (иначе они не представляют коммерческого интереса). Сейчас это реалии завтрашнего дня, многие фирмы уже сейчас анонсируют производство ноутбуков с топливными элементами в следующем году!

Идея топливного элемента - подводить рабочие компоненты извне, постоянно их обновляя и отводя продукты, выделяемые в процессе работы. То есть создать постоянно действующий генератор, который преобразует химическую энергию напрямую в электрическую (без механических, тепловых и прочих преобразователей). Так, если преобразовывать энергию сгорания спирта напрямую в электрическую, то будет очень высокий КПД, практически 90%. Это революция в технике, а электромобиль - перспективная замена обычному автомобилю, КПД которого редко превышает 30%.

Пока технологи бьются над выбором используемых компонентов, удобных для использования, и задачей нейтрализации и утилизации продуктов, выделяющихся в топливном элементе. К примеру, спирт удобен как компонент, но среди выделяемых продуктов есть углерод, который проблематично отводить. Водород, наоборот, неудобен для использования, так как его надо как-то хранить и он пожароопасен, зато выделяемые продукты - просто вода, ее проще всего утилизовать.

Другой момент - окислитель и восстановитель. В тепловых элементах окислитель - обычно кислород воздуха, следовательно, возникает проблема подвода и отвода воздуха, чтобы обеспечить воздушный электрод. Уже есть масса наработок в данной области, и создание электродов, стабильно генерирующих электрическую энергию, уже не за горами.

ЗАКЛЮЧЕНИЕ

Проблема России - нет хорошего собственного производства обычных батареек. Да, есть попытки, но не совсем удачные, а западные компании пока не стремятся размещать производство на нашей территории, считая ее инвестиционно непривлекательной. Но все впереди.

ЭФФЕКТ ПАМЯТИ

Этим понятием пугают всех владельцев сотовых телефонов. Никто толком не знает, что это такое, но заранее боятся :). Миф состоит в том, что аккумуляторы нельзя заряжать, не разрядив полностью. Это в корне неверно.

Во-первых, эффекту памяти подвержены только щелочные аккумуляторы: никель-кадмиевые, никель-металл-гидридные (услышал в названии никель - есть эффект памяти). У литий-ионных аккумуляторов эффекта памяти нет в принципе, так как другая химия.

Во-вторых, эффект памяти проявляется в полуразряженном состоянии (20%-70% заряда) при хранении (то есть заряд зафиксирован) более 3 недель. Подобное промежуточное состояние объясняется определенным соотношением компонентов. Если же аккумулятор постоянно используется (в том же сотовом), то эффекта памяти не будет.


Спецвыпуск Xakep, номер #034, стр. 034-068-5, ОТ ЛЯГУШКИ ДО ПОЛИМЕРА

ОТ ЛЯГУШКИ ДО ПОЛИМЕРА

Каролик Андрей, Анисимов

Спецвыпуск Xakep, номер #034, стр. 034-068-5

В результате, постоянно разряжая аккумулятор полностью, ты сокращаешь срок его службы, так как количество циклов "полный заряд-полный разряд" у него в районе 500. Если же заряжать аккумулятор, не разряжая полностью (подзаряжать), то срок службы увеличивается в десятки раз.

Возможно, этот миф пустили производители аккумуляторов, им эту на руку. Просто не храни аккумуляторы в полуразряженном состоянии. Лучше заряжай их полностью и храни в холодильнике (кроме шуток). Для сотовых малопонятно, вряд ли сотовый будет без дела лежать месяц, а вот для владельцев видеокамер это актуально, так как обычно человек снимает, как ребенок пошел в школу, а в следующий раз - на Новый год.

БАТАРЕЙКА ИЛИ АККУМУЛЯТОР

Выбор определяется целью. Дело все в саморазряде. Обычная щелочная батарейка в год теряет примерно 2% своей емкости, а аккумулятор - до 15-20% в месяц (!). Поэтому, к примеру, в пульт дистанционного управления телевизором бессмысленно ставить не то что аккумулятор, но и алкалиновую батарейку. Там такие маленькие токи потребления, и так редко он используется, что дешевле купить самую простую солевую батарейку и забыть про пульт на 2-3 года. Аналогично фонарь, радио, часы, аварийное освещение и т.п. (где длительный срок использования) - однозначно батарейку, аккумулятор быстрее сядет от саморазряда. Это, кстати, одна из причин, почему батарейки никогда не будут вытеснены аккумуляторами.

ЗАЩИТА

Motorola, Siemens, Sony и некоторые другие фирмы любят оснащать практически все свои комплектующие чипами и программульками, позволяющими опознавать "свой-чужой" (особенно Motorola и Sony). К примеру, если взять аккумулятор Sony для видеокамеры этой же фирмы, то работает нормально, а если взять от третьего производителя - не будет работать в принципе, не будет даже заряжаться. Аналогично и в сотовых, чтобы защитить от подделок и окупить лицензионные разработки.

ЛИТИЙ-ИОННЫЙ АККУМУЛЯТОР

В отличие от щелочных аккумуляторов состоит из двух частей: химического источника тока и электронной части - контроллера, который контролирует состояние аккумуляторной батареи. Достаточно емкая микросхема, которая следит за следующими вещами. Нельзя, чтобы литий-ионный аккумулятор разряжался ниже, чем 2,7 В, иначе больше он работать не будет (будет глубокий разряд). Нельзя также, чтобы при заряде напряжение было больше, чем 4,2 В, возможно появление металлического лития, что приведет к взрывоопасной ситуации. Кроме того, чип контролирует температуру и защищает от короткого замыкания.

Срок годности на батарейки устанавливает завод-изготовитель, он гарантирует, что до этого срока останется не менее 90% емкости (для щелочной - не менее 80%). Срок годности на аккумуляторы не устанавливается.

По статистике, за год в России один житель в среднем потребляет до 10 обычных батареек, следовательно, стране необходимо более 1,5 миллиарда батареек в год, что в денежном эквиваленте составляет около полумиллиарда (!) зеленых фантиков.


Спецвыпуск Xakep, номер #034, стр. 034-068-6, ОТ ЛЯГУШКИ ДО ПОЛИМЕРА

ОТ ЛЯГУШКИ ДО ПОЛИМЕРА

Каролик Андрей, Анисимов

Спецвыпуск Xakep, номер #034, стр. 034-068-6

Алкалиновые батарейки получили массовое распространение еще 10-15 лет назад. У них были прекрасные показатели, но они были значительно дороже своих аналогов, поэтому использовались редко и преимущественно в устройствах длительного пользования.

Сравнивать батарейки в лоб - не всегда корректно. Необходимо учитывать, кем сделаны сравниваемые батарейки и, что не менее важно, где они сделаны. Потому что батарейки одной торговой марки могут быть произведены на разных заводах. К примеру, Бельгия, Штаты, Япония и Китай - четыре совершенно разных завода (разное оборудование), а следовательно, четыре разных уровня качества.

Сейчас уже существует технология и устройства, заряжающие аккумуляторы за 0,5-1 час. Для этого в зарядном устройстве стоит специальный микропроцессор, который анализирует состояние каждого аккумулятора индивидуально и отслеживает изменения параметров, поддерживая оптимальный режим зарядки (рабочая температура и ток зарядки).

В Штатах уже существуют образцовые электростанции на топливных элементах. Машины, автобусы и ноутбуки на топливных элементах появятся буквально в 2004-2005 году. Новое поколение источников тока, новая эра энергопотребления - вместо того, чтобы заряжать каждый раз в розетке, мы будем просто менять, как в авторучке, капсулу с новым реагентом.


Спецвыпуск Xakep, номер #034, стр. 034-072-1, Электронные деньги: делай раз, делай два...

Электронные деньги: делай раз, делай два...

Никита Сенченко

Спецвыпуск Xakep, номер #034, стр. 034-072-1

(nik@e-mail.ru) www.smslist.ru

Как устроены электронные платежные системы на основе цифровой наличности

Нет, что ни говорите, а Билл Гейтс - господин, бесспорно, умный и безмерно образованный. Нострадамус отдыхает. Еще в далеком 1995 году в своем популярном чтиве "Дорога в будущее" ("The Road Ahead") Гейтс предрекал смерть бумажным деньгам и вечную жизнь их электронным собратьям.

До полной кончины дело, конечно, пока не дошло, но, видимо, дойдет, и скоро. Наши потомки не будут знать, как это - таскать в кармане изрядно потертый бумажник, а будут носить на связке ключей эдакий микродевайс, хранящий в себе сокровенные мани. Только электронные. Или вовсе не будут ничего носить. Все покупки - только из дома, через Сеть. А как же иначе?

Впрочем, о чем я? Все это уже давно существует - и волшебные микродевайсы (в миру - смарт-карты), и электронные кошельки, и онлайн-магазины. Проблема остается только в человеческой психологии: кто-то не доверяет, кто-то не понимает. Ну и черт с ними. Оставим их наедине с их сомнениями и займемся оттачиванием собственных навыков.

Что же мы знаем об электронных платежах? Служат для расчетов между юзерами в Сети. Удобны. Проходят в считанные секунды. Зачастую анонимны или псевдоанонимны. В каждой электронной платежной системе (далее - ЭПС) используется некоторая электронная наличность, которая является эквивалентом чего-нибудь из офлайнового мира, обычно реальной валюты или драгоценных металлов. Весь объем этой наличности, находящийся в обращении в ЭПС, должен быть подтвержден "офлайновым эквивалентом". Говоря по-модному, веб-деньги должны иметь стопроцентную и моментальную ликвидность. Проще: захотел я "ввести" в систему энную сумму - без проблем ввел. Захотел "вывести" ее обратно (обналичить) - тут же без проблем вывел. Однако не будем зацикливаться на финансовых вопросах. О них тебе расскажут в другом месте в другое время. Сегодня мы поговорим о том, как технически и программно организованы ЭПС, а также вспомним некоторые факты из их истории.

Систем так много, что переварить и впитать их все в рамках одной статьи невозможно. Поэтому остановимся на трех: WebMoney (http://webmoney.ru), Яндекс.Деньги (http://money.yandex.ru) и e-port (http://eport.ru). Все эти системы инкубированы на родной русской земле, что не может не радовать.

ЭПС не имеют какой-либо общепринятой классификации, по крайней мере, в техническом понимании вопроса. Для удобства я буду разделять их по типу интерфейса взаимодействия с пользователем. Тут все просто: управление электронным счетом и осуществление операций с ним может происходить через web-интерфейс, а может - через клиентское приложение. Собственно, такая классификация тоже довольно размыта, поскольку в WebMoney, например, используются оба способа взаимодействия.

К первой категории однозначно относим e-port. Ко второй - Яндекс.Деньги. WebMoney, как уже было сказано, может сочетать в себе управление и через web (версия Light), и через программу-клиента (версия Classic).

WebMoney начинает свою историю в 1998 году. Как раз в августе этого года, если помнишь, произошел пресловутый дефолт. Рубль тогда обваливался со скоростью мешка с… хм, камнями, выброшенного с крыши 16-этажного дома. По всем законам жанра, компания эта должна была скончаться сразу после рождения. Однако этого не произошло. Благодаря продуманной и агрессивной рекламной политике, быстрому построению модных и полезных сервисов и раздаче бонусов первым пользователям, системе удалось тогда встать с колен и удержаться на ногах. Сейчас WebMoney пользуется уже более 500 тысяч человек.


Спецвыпуск Xakep, номер #034, стр. 034-072-2, Электронные деньги: делай раз, делай два...

Электронные деньги: делай раз, делай два...

Никита Сенченко

Спецвыпуск Xakep, номер #034, стр. 034-072-2

Работает она так. При своем запуске, ПО системы - WM Keeper - устанавливает соединение с серверами сертификации (речь идет о Classic-версии программы). Все операции проходят в закодированном виде, с использованием алгоритма защиты, подобного RSA, с длиной ключа более 1024 бит. Для каждого сеанса (транзакции) используются уникальные ключи сеанса, поэтому в течение транзакции никто, кроме отправителя, не имеет возможности определить назначение платежа и его сумму. Для каждой сделки используются уникальные реквизиты, а попытки применить их повторно - отслеживаются и пресекаются.

Кроме того, используются алгоритмы кодирования RC5, MD4, MD5, SSL.

Как известно, на пользовательском уровне в WebMoney реализовано несколько степеней защиты: доступ по уникальному WMID и паролю плюс обязательное наличие т.н. файла ключей (*.kwm). В этом файле хранится приватный ключ для доступа в систему; ключ зашифрован с использованием WMID и пароля. Таким образом, для того чтобы иметь доступ к своим средствам в системе, необходимо знать не только пароль к WMID, но и обладать секретным файлом *.kwm. Кража одного лишь пароля ничего не даст.

Система эта весьма надежна, и я никогда не слышал об удачных попытках прямого взлома WebMoney - сервера или самой программы WM Keeper. Зато случаев распространения троянцев, стаскивающих файлы с ключами, довольно много. Лозунги здесь обычные: "Скачайте нашу программу-кряк и генерируйте WM сколько душе угодно". Причем, чаще всего, для правдоподобности, за этот кряк нужно заплатить небольшую сумму денег. Получается, авторы такого чуда троянской мысли остаются в выигрыше при любом исходе. Если лох заплатит за программу - хорошо. Если потом не сможет защититься - еще лучше.

Видимо, понимая плачевность ситуации, в WebMoney начали реализовывать всякого рода защиту от дурака. Пользователям была дана возможность сохранять файл с ключами на смарт-карте, а также искусственно увеличивать его размер вплоть до 10 Мб. Согласись, стащить десятимегабайтное файло - это уже проблема. Кроме того, в последней версии Keeper'а введена процедура активации: на мыльник высылается специальный код, необходимый для манипуляций средствами на кошельках.

Также, по просьбам трудящихся, вебманевские программеры реализовали еще один инструмент, который теперь лежит по адресу https://security.webmoney.ru. Данный сервис позволяет заблокировать доступ к своему WMID со всех IP-адресов, кроме тех, что входят в список разрешенных.

Яндекс.Деньги появилась на свет в начале 1998 года, почти одновременно с WebMoney, но до июля 2002 года существовала под маркой PayCash. Несмотря на то, что эта система всегда считалась технологически продвинутой и защищенной, а также куда более уверенно чувствовала себя в сфере права и юриспруденции, по числу пользователей PayCash на порядок отставала от WebMoney. Это отставание объяснялось более сложными процедурами регистрации и использования ПО системы, а также запутанной финансовой схемой, осилить понимание которой может далеко не каждый, даже видавший виды, юзер. Дела ее пошли на лад около года назад, когда за ее продвижение взялся Яндекс, а система была переименована в "Яндекс.Деньги". Тогда же она получила банковское свидетельство ЦБ России.


Спецвыпуск Xakep, номер #034, стр. 034-072-3, Электронные деньги: делай раз, делай два...

Электронные деньги: делай раз, делай два...

Никита Сенченко

Спецвыпуск Xakep, номер #034, стр. 034-072-3

Схема PayCash основана на т.н. классической технологии цифровой наличности, впервые предложенной голландским разработчиком Дэвидом Чаумом (система "eCash"). Именно он создал денежный суррогат - бессрочные денежные обязательства на предъявителя, эмитированные банком или другой финансовой организацией в форме электронных сертификатов, которые могут быть использованы для расчетов через интернет.

Технология ее использует криптографические алгоритмы RSA с длиной ключа в 1024 бита и более, электронную цифровую подпись (ЭЦП), а также т.н. "слепую" электронную подпись. Сегодня я не буду подробно останавливаться на этих алгоритмах и схемах, они довольно сложны.

Для работы с Яндекс.Деньгами рядовому пользователю необходимо скачать программу-клиент под названием "Интернет.Кошелек".

E-PORT

Система e-port была основана в 1999 году. По своей сути она несколько отличается от двух уже рассмотренных нами в этом материале и построена на использовании т.н. единых карт e-port. Каждая карта может представлять собой всего лишь учетные данные - номер и PIN-код (это т.н. виртуальная карта e-port, которую можно получить online), а может иметь и вполне осязаемое физическое обличие.

Карта e-port служит неким аналогом кредиток, используемых при оплате в Сети, однако аналогом весьма отдаленным. На епортовской карте аккумулируются денежные средства (их, конечно, нужно туда зачислять), которые затем могут быть потрачены на оплату товаров и услуг в подключенных к системе магазинах, а также для покупок в Momentalno.Ru - интернет-магазине системы, который торгует товарами, не требующими физической доставки. В рамках Momentalno.Ru, e-port имеет агентские соглашения с мобильными операторами, интернет-провайдерами и провайдерами IP-телефонии, платного телевидения, а также интернет-казино. Благодаря этому ты можешь пополнить, например, свой счет на мобиле или купить карту доступа в Сеть буквально за 3 клика мышью.

Управление счетом в e-port происходит через web-интерфейс, по протоколу https, с использованием SSL версии 3.0. Никаких особых сложностей здесь нет: для каждого сеанса (сессии) используются генерируемые сеансовые SSL-ключи, которыми обмениваются клиент и сервер. После обмена ключами данные шифруются по симметричному криптографическому алгоритму RC4. Стойкость шифра - 40, 56 или 128 бит.


Спецвыпуск Xakep, номер #034, стр. 034-072-4, Электронные деньги: делай раз, делай два...

Электронные деньги: делай раз, делай два...

Никита Сенченко

Спецвыпуск Xakep, номер #034, стр. 034-072-4

Визуальных Win-приложений для управления своим счетом у e-port нет.

Прием оплаты на сайте

Фактически, простое открытие кошелька в ЭПС уже позволяет принимать платежи на своем сайте. Ведь можно это делать вручную, не так ли? Сиди себе круглые сутки и обрабатывай заказы в своем е-шопе. Но это, к сожалению, не очень удобно. Куда приятней осознавать, что процесс приема оплат на сайте происходит автоматически, без твоего участия. Ты спишь - денежки капают.

Все три системы позволяют это реализовать. Рассмотрим это на примере WebMoney, как системы наиболее продвинутой в данном аспекте. Вопросу автоматизации всего и вся WebMoney уделяет большое значение. Здесь вообще многое сделано для облегчения жизни вебмастерам и разработчикам. Так, с помощью соответствующих элементов ActiveX, вставленных на страницу, мы можем предложить юзеру запустить Keeper (и в случае его согласия сделать это автоматически) и даже побудить его начать процедуру инсталляции Keeper'а (если программа еще не установлена).

Что касается приема оплаты на сайте, то тут WebMoney предоставляет 2 способа: использование модуля аутентификации для автоматической выписки счета и использование сервиса Merchant (http://merchant.webmoney.ru).

Первый вариант - для заядлых девелоперов. Он считается уже немного устаревшим по причине некоторой сложности, однако используется все еще довольно часто. Суть его заключается в автоматической выписке счета покупателю, а затем - в проверке состояния его оплаты. Для этого необходимо скачать и проинсталить на сервере специальный модуль аутентификации, в задачи которого входит формирование ЭЦП каждой операции. Это позволяет производить операции в системе только от имени WM-идентификатора, с использованием секретных ключей которого модуль производит подпись. Инсталляция под Unix может выглядеть так:

chmod a+x ./compl.sh

./compl.sh

В дальнейшем, для автоматической выписки счета, проверки состояния его оплаты, а также автоматического перевода средств с кошелька клиента на твой кошелек необходимо использовать предлагаемые WebMoney довольно простые и понятные интерфейсы.

Данный способ, однако, имеет два недостатка. Первый - высокая вероятность сбоя или "погрешности" в работе системы, зависимость от состояния коннекта к серверу WebMoney; второй - необходимость выкладывать в открытом виде на сервере файл ключей kwm (он нужен для работы модуля аутентификации), а также специального ini-файла, который должен содержать WMID, пароль к нему и путь к ключам на сервере. Главная и единственная защитная мера - складывать все это добро на серваке как можно глубже, например, по адресу типа ./yUik3orl/9klv3AdQ/85hJKLfr/

При таком варианте наткнуться на файл с ключами сможет либо опытный шаман, либо полный дурак (которому, как известно, везет).

Второй вариант приема оплат через WebMoney куда проще. Для этого служит сервис Merchant. Тут схема такая: ты передаешь серверу WebMoney информацию о заказе (номер, сумма и проч.), пользователь проходит авторизацию (на серваке ВебМаней), после чего с его счета списывается соответствующая сумма, а пользователь перенаправляется обратно на сайт.


Спецвыпуск Xakep, номер #034, стр. 034-072-5, Электронные деньги: делай раз, делай два...

Электронные деньги: делай раз, делай два...

Никита Сенченко

Спецвыпуск Xakep, номер #034, стр. 034-072-5

Аналогичные сервисы существуют и у PayCash. И несмотря на то, что они по сравнению с разработками ВебМаней куда менее удобны и прозрачны, Яндекс.Деньги принимают сейчас к оплате более 200 магазинов, в том числе Bolero, Co@libri и аукцион Molotok.Ru.

У e-port аналогичные разработки по подключению магазинов обернулись созданием целого программного продукта, который был назван e-POS. Деньги e-port принимают на своих сайтах более 150 магазинов.

Не так давно разработчик WebMoney, компания ЗАО "Компьютерные и информационные технологии" (ЗАО "КИТ"), подготовила специальный продукт, названный DigiSeller (http://digiseller.ru). С его помощью любой вебмастер, имеющий хотя бы минимум мозгов в голове, может за несколько минут создать электронный магазин, торгующий цифровыми товарами: PIN-кодами, e-книгами, программным обеспечением, баннероместами на сайтах и другим виртуальным барахлом.

Особенностью продажи цифровых товаров является их моментальная доставка пользователю. При добавлении товара продавец должен закачать его на сервер DigiSeller'а, а когда покупатель оплачивает товар, он мгновенно получает его по внутренней защищенной почте WebMoney (если это, например, PIN-код) или ему вручается ссылка для скачивания (если это программа).

С помощью DigiSeller'а могут быть созданы магазины трех типов:

1. Агентский магазин. Существует для людей, которым нечего продавать, но имеющих раскрученный сайт. Товары для продажи им дает сам DigiSeller. Создание агентского магазина сводится к простой вставке html-кодов на сайт, а "хозяин заведения" получает отчисления за каждый проданный товар.

2. Собственный магазин. Используй этот вариант в том случае, когда у тебя есть, что продавать. DigiSeller даст тебе необходимые скрипты, которые придется установить у себя на сайте. Для облегчения процесса предусмотрен специальный конструктор. Все продаваемые товары будут располагаться на сервере DigiSeller, а ты за это (и за все хорошее) отчисляешь ему комиссионные.

3. Торговая площадка. Ее владелец не участвует в купле-продаже напрямую, а просто дает возможность продавцам продавать, а покупателям покупать через свой сайт, получая таким образом комиссию от продаж. Правда, DigiSeller’у тоже отчисляется определенный процент. За вредность.

Примером торговой площадки может служить собственный ресурс WebMoney, основанный на технологии DigiSeller - Plati.Ru (http://plati.ru). Если ты написал суперпрогу, за которую, как тебе кажется, народ будет готов выложить свои кровно заработанные мани, но при этом нет никакого желания делать ради ее продажи целый магазин, иди на Plati.Ru, регистрируйся там в качестве продавца и продавай прогу через них. С каждой продажи, правда, придется отстегивать магазину 3% комиссионных, однако результат того стоит. Plati.Ru - магазин настолько раскрученный (оборот - около $40 тыс. в месяц), что с продажами проблем не будет, если, конечно, твоя прога - не полная лажа, имеющая десяток-другой отрицательных отзывов ежедневно.


Спецвыпуск Xakep, номер #034, стр. 034-072-6, Электронные деньги: делай раз, делай два...

Электронные деньги: делай раз, делай два...

Никита Сенченко

Спецвыпуск Xakep, номер #034, стр. 034-072-6

SoftActivation

Другая модная примочка от WebMoney - Software Activation Service (SAS), предназначенный для авторов шароварных прог.

Что и говорить, интересную идейку предложили девелоперы. Логично предположить, что если ты - программист, то твое дело - писать хорошие программы, и тебе некогда задумываться, как, где и с чьей помощью их продавать. Раньше этого было не избежать, и многие пользовались услугами посредников, которые не стеснялись сдирать огромное вознаграждение за свою работу.

Но теперь бедный программер наконец-то может вздохнуть спокойно. Воспользовавшись SAS'ом, он сможет продавать свой софт напрямую конечному пользователю через систему WebMoney и, конечно, экономить кучу денег.

Мало того, ребята из ЗАО "КИТ" припасли еще один сюрприз. Как было раньше? Написал прогу, продал один регкей, а потом смотришь - и он уже продается на дисках вместе с программой. В комплекте. Обидно... Так вот, в SAS есть возможность контролировать количество инсталляций программы и, соответственно, количество использований выданного регистрационного номера. Рекомендуется разрешать 3-4 инсталляции на 1 регкей - чтобы покупатель мог сделать одну инсталляцию дома, одну на работе и еще парочку оставить на случай неизбежного падения Виндов и их последующей реинкарнации.

Секрет таких новаторских чудес заключается в том, что система WebMoney как бы интегрируется в твою программу: с помощью SAS устанавливается зависимость между прогой и WMID, с которого была произведена ее оплата. Покупка проги происходит даже без твоего участия, ты только получаешь денежки на свой счет в WebMoney.

Вот и все. Подробности о сервисе SAS можно найти на сайте www.softactivation.com. Там же можно посмотреть видеоролики, наглядно иллюстрирующие процесс покупки программы и активации регистрационного ключа.

Удачи!

Совсем недавно на сайте WebMoney появилась новость о первом судебном процессе против автора проги-троянца, ворующей ключи WebMoney с компов пользователей-жертв. Чем закончилось разбирательство, пока неизвестно.

В прошлом году оборот WebMoney составил $65,5 млн., причем количество и общая сумма операций увеличивается с каждым месяцем. За 2002 год было проведено 1,2 млн. транзакций. Темпы роста оборота с начала этого года уже намного превысили прошлогодние показатели.

Годовой оборот системы e-port в 2002 году увеличился по сравнению с 2001 в 3,7 раза и составил 44,2 млн. долларов (в том числе в IV квартале - 20,8 млн.). Общее количество эмитированных карт e-port на момент написания этого материала составило 6,6 млн.

Сделай сам!

Создать свой собственный магазин (пункт 2 нашей классификации) довольно просто – весь процесс сводится к получению необходимого html-кода, который надо разместить у себя на сайте. Сами товары хранятся на сервере DigiSeller.

Для начала необходимо пройти регистрацию. На твой WMID будут отправлены логин и пароль. Заходи на www.digiseller.ru/site/digi_login.asp и авторизируйся. Со страницы "Товары - Добавить" добавь новый товар. После этого он появится в списке "Товары - Список". Теперь перейди на страницу "Мой магазин" и создай там новую группу товаров. Затем добавь в нее уже существующий в списке товар. После этого ты будешь перенаправлен на страницу с вожделенными html-кодами. Там их два. Первый - для страницы со списком товаров, второй - для страницы описания товаров и оплаты (кстати, DigiSeller поддерживает оплату в любой валюте WebMoney, цифровыми чеками Paymer, а также с помощью Яндекс.Деньги, e-port и e-gold). Скопируй коды и вставь на соответствующие страницы. На этом все, прими мои поздравления.


Спецвыпуск Xakep, номер #034, стр. 034-072-7, Электронные деньги: делай раз, делай два...

Электронные деньги: делай раз, делай два...

Никита Сенченко

Спецвыпуск Xakep, номер #034, стр. 034-072-7

Говоря по-модному, вебденьги должны иметь стопроцентную и моментальную ликвидность.

Лозунги здесь обычные: "Скачайте нашу программу-кряк и генерируйте WM сколько душе угодно".

С его помощью любой вебмастер, имеющий хотя бы минимум мозгов в голове, может за несколько минут создать электронный магазин, торгующий цифровыми товарами.

Ты передаешь серверу WebMoney информацию о заказе (номер, сумма и проч.), пользователь проходит авторизацию (на сервере ВебМаней), после чего с его счета списывается соответствующая сумма, а пользователь перенаправляется обратно на сайт.


Спецвыпуск Xakep, номер #034, стр. 034-076-1, В наш комп мы целый мир засунем

В наш комп мы целый мир засунем

Raisan и Forb

Спецвыпуск Xakep, номер #034, стр. 034-076-1

(raisan@rambler.ru) и (forb@real.xakep.ru)

Цифровая фотография от A до Z

Еще в далеком 19 веке появилась технология получения черно-белого изображения на солях серебра. Позднее был разработан метод фиксирования этой картинки на тонкой серебристой пленке, вскоре запатентованный французским ученым Луи Жаком Даггером как способ получения фотоснимков. И тут понеслось...

Все ученые предвещали фотографии великое будущее и, как ни странно, не ошиблись. В 1855 году известный физик Максвелл открыл совершенно новый метод - цветной печати. Правда, процесс получения цветного изображения был крайне дорог и трудоемок, что не давало цветной фотопечати вытеснить черно-белые фотоснимки. Но время шло, наука развивалась, а технологии становилась совершеннее и доступнее.

Вообще, суть методов фотопечати, равно как и их зарождение, довольно интересны, и мы бы с удовольствием о них рассказали. Но на это потребовалась бы отдельная статья, так как цепочка различных способов получения бумажных фотоснимков длилась десятилетиями, и конец ее наступил лишь в начале 80-х годов.

Примерно в это же время мир был потрясен прогрессом в информационных технологиях. Microsoft и IBM, которые были вне конкуренции, радовали людей мощными (по тем временам) компьютерами и устройствами к ним. Именно благодаря расцвету информатики, изобретателям пришла в голову гениальная идея: “А не пора ли нам загнать картинку в ЭВМ? Там она была бы куда компактнее, чем на бумаге”. Сказано - сделано. После выхода уникального IBM-PC (в 1981 году) компания Sony выпустила первую в своем роде цифровуху Mavica (Magnetic Video Camera). Цифровуху - это, пожалуй, громко сказано ;), так как эта чудо-камера была суть обычной видеокамерой, которая создавала поток из 60 кадров в секунду. Но в Соньке уже была матрица на 28x104 пикселов (о качестве изображения можешь судить сам), поэтому можно с уверенностью сказать, что Mavica положила начало истории цифровой фотографии.

Время шло, технологии развивались, коммерческие компании (которых в 1980 году было не так уж и много) пытались создать конкуренцию Sony, но пока им это не удавалось. Только к началу 90-х годов появились настоящие цифровые камеры, которые уже не являлись магнитными, как Mavica. Это были Kodak DC40 (разрешение у этой цифровушки было 640х480), Sony SEPS-1000 - камера, имевшая разрешение 1,3 мегапиксела, и другие иностранные новинки. Кстати говоря, в цифровой фотографии до сих пор правят японцы. Их продукция рулит компьютерным рынком аж на 70%.

Неудивительно, что пользователь до недавнего времени не мог насладиться цифровой прелестью, ибо камера стоила огромных денег. Но к началу XXI века цены на цифровики стремительно упали (из-за удешевления технологий производства) и продолжают снижаться, все сильнее вытесняя пленочные камеры.

Ни для кого не секрет, что цифровая фотосъемка на порядки превосходит бумажную. Но не будет лишним рассказать о ее достоинствах и недостатках (да, они тоже имеются).

В большинстве случаев цифровой фотоаппарат отличается своей компактностью (я говорю о любительских цифровиках, с профессиональными все наоборот). Фотокамеру можно подключить к компьютеру и отредактировать любой кадр. Если получились плохие снимки – их можно просто удалить.


Спецвыпуск Xakep, номер #034, стр. 034-076-2, В наш комп мы целый мир засунем

В наш комп мы целый мир засунем

Raisan и Forb

Спецвыпуск Xakep, номер #034, стр. 034-076-2

К недостаткам относится, в первую очередь, цена аппарата, а также сложность вывода изображения на бумагу, поскольку качественные распечатки можно получить только на специальном цветном принтере (они тоже подешевели) или в фотолаборатории. Вообще, раз уж мы заговорили о совместимости, то следует отметить, что бумажную фотографию можно загнать в цифровой формат через сканер.

Цифровая камера. Взгляд изнутри

Если разобрать примитивную цифровуху, можно увидеть (активно используя микроскоп), что ее строение схоже с обычной мыльницей. Камера состоит из известных тебе частей: кожуха, окуляра с визиром, диафрагмы, различного рода электронных механизмов и спусковой кнопки. “Что же в ней тогда интересного?” - спросит нетерпеливый читатель. На самом деле, интересного там много, просто все микроцифровые части камеры запрятаны далеко в ее недрах и не видны невооруженным глазом. Поэтому давай проследим, что же происходит, когда ты наводишь камеру на предмет и нажимаешь на верхнюю кнопку. Поначалу все просто: открывается шторно-целевой затвор фотообъектива, в котором фокусируется изображение. Затем пучок света преодолевает разного рода “препятствия” в виде комбинации оптических линз и попадает... в матрицу.

Именно матрица отличает обычную фотокамеру от цифровой. Это не что иное, как особый вид памяти, напоминающий мини-карточку. Матрица цифровика состоит из множества ячеек, каждой из которой соответствует отдельный элемент (пиксел). Запись изображения в ячейки основана на сложных квантово-механических процессах. Хотя термин “пиксел” - весьма условный и не означает ничего революционного. Он употребляется лишь для уточнения стандартной емкости цифровика, поэтому на любой фотокамере ты можешь увидеть количество пикселов в ее памяти. Например, в фотокамере с 810000 элементами изображения и с разрешением 1024х768, легко находим количество пикселов – целых 768432 штуки ;).

Физический размер датчика определяется длиной его диагонали, которая, в свою очередь, определяет фокусное расстояние используемого объектива. Длина диагонали указывается в дюймах и составляет, как правило, 1/3, 1/2 и 2/3 дюйма. В технических характеристиках приводится уже пересчитанное для малоформатного (с шириной пленки 35 мм) фотоаппарата фокусное расстояние. Данная метрика напрямую связана с такой немаловажной вещью, как цена девайса, ведь на долю элементов изображения приходится до половины всей стоимости камеры.

Естественно, что чем больше размер матрицы, тем большее количество пикселов она содержит, а значит, изображение будет иметь большее разрешение. От разрешения, неважно оптического или интерполяционного (о видах разрешения будет сказано чуть ниже), зависит резкость изображения, наличие или отсутствие микросоставляющих, возможность большого увеличения.

Транзистор и фотопленка - брат и сестра?

Очень важно понимать, что матрица не является принципиально новым изобретением, более того, она даже в чем-то напоминает фотопленку. И в карточке, и на пленке изображение фиксируется светочувствительными зернами.


Спецвыпуск Xakep, номер #034, стр. 034-076-3, В наш комп мы целый мир засунем

В наш комп мы целый мир засунем

Raisan и Forb

Спецвыпуск Xakep, номер #034, стр. 034-076-3

Только в отличие от слоя галоидного серебра на фотопленке, в матрице используются те самые кристаллические элементы транзистора. Электронный элемент устроен так, что напряжение на его поверхности зависит от его освещенности. Чем больше света падает на элемент, тем больше его энергия, а соответственно, и выше его заряд.

После фотографирования (экспозиции) каждая такая ячейка получает определенный заряд, пропорциональный его освещенности. Таким образом формируется электрическая картинка будущей фотографии, что до слез напоминает процесс, протекающий на фотопленке.

Главной задачей после создания цифровых фотокамер было хранение информации. Следовательно, нужен был единый стандарт, чтобы не возникало конфликтов между компьютерами и цифровиками. Сохранение информации в одном формате было невозможным из-за различных матричных характеристик. Поэтому прогрессивные изобретатели решили, что прежде чем данные будут сохранены, они должны быть преобразованы в единый стандартный формат. Весь световой диапазон разбивается на 256 ступеней, или степеней (при бело-серо-черном изображении), каждая из которых соответствует определенному оттенку (если снимается черно-белое, то коэффициент ячеек матрицы может принимать только значения 1 и 0). Уровень 0 соответствует абсолютно черному цвету, 255 - абсолютно белому. Промежуточные уровни являются различными градациями серого: 127 - 50%, 63 – 75%. В таких пропорциях цифровые данные записываются на носитель информации и именно поэтому фотография называется цифровой. Таким образом формируется примитивное черно-белое изображение.

В цветных фотокамерах используются трехканальные матрицы, в которых каждый пиксел строится на основании данных с трех матриц. Каждый накопитель информации чувствителен только к одному цвету (красному, зеленому или синему - RGB). Такой эффект достигается при помощи специальных микросветофильтров.

Пять важнейших характеристик цифровой матрицы

При покупке любого товара (даже не электронного), ты всегда обращаешь внимание на его характеристики. Покупая в магазине булку второго сорта, ты прекрасно знаешь, что первый сорт будет гораздо вкуснее, хоть и дороже. Аналогично и с цифровыми камерами, каждая из которых имеет свои индивидуальные характеристики, играющие роль показателя качества устройства. Но не стоит выбирать самую навороченную камеру, если до чтения этой статьи ты и понятия не имел о цифровой съемке. Подумай, зачем тебе десятикратное увеличение и дополнительный зеркальный захват, когда ты некомпетентен в профессиональной фотографии? Чтобы сэкономить деньги и насладиться качеством любительской фотосъемки, тебе нужен компактный девайс со встроенным объективом, у которого большая часть настроек (фокусировка, установка выдержки и диафрагмы и др.) осуществляется автоматически или фиксирована. А также - придерживаться некоторых базовых характеристик камеры. Вот небольшой список свойств, на которые следует обращать максимальное внимание.


Спецвыпуск Xakep, номер #034, стр. 034-076-4, В наш комп мы целый мир засунем

В наш комп мы целый мир засунем

Raisan и Forb

Спецвыпуск Xakep, номер #034, стр. 034-076-4

1. Оптическое разрешение

Эта характеристика камеры показывает, на какое количество элементов (точек) аппаратура позволяет разбить изображение оригинала, и выражается оно в точках на дюйм - dpi (dots per inch).

Например, параметр 1200 dpi означает, что каждый квадратный дюйм картинки разбит на 1200 точек по горизонтали и 1200 по вертикали. Чем больше разрешение, тем больше информации об оригинале может быть передано в твой сундук ;).

2. Интерполяционное разрешение

При интерполяции между двумя точками изображения, снятыми матрицей, программными или аппаратными средствами "вдувается" одна или несколько дополнительных точек с усредненным значением цветов соседних точек.

Интерполяция является искусственным приближением картинки к наилучшему состоянию. Истоки ее прослеживаются еще в курсе численных методов, которые ты, возможно, изучал (или будешь изучать) в техническом вузе.

Этот метод не дает реального выигрыша в качестве при просмотре без увеличения изображения.

3. Динамический диапазон сенсора

Динамический диапазон сенсора является очень важной характеристикой, влияющей на качество изображения, и соответствует понятию фотографической широты пленки, определенной как способность точно передавать полный размах градаций яркости в сцене. Этот параметр показывает количество оттенков в оригинале, которые способен различить твой девайс: от абсолютно белого до абсолютно черного. Диапазон плотностей измеряется по логарифмической шкале от 0.0 (белый) до 4.0 (черный). Типичная фотопленка имеет минимальную плотность около 0.3 и максимальную до 3.3; разница значений или диапазон оптической плотности составляет около 3.0, хотя диапазон некоторых слайдов может достигать и больших значений (до 3.6). Если оцифровываемое изображение имеет максимальную плотность (Dmax) 3.3, а девайс слабоват и способен воспринимать лишь до 3,0, то все, что плотнее этой границы, раскрасится в черные тона.

Таким образом, динамический диапазон - это не что иное, как способность слайд-сканера фиксировать малоконтрастные детали слияния элементов изображения. Чем шире такой диапазон, тем лучше, четче, сочнее и выразительнее цветовая палитра снимка. В наше время минимально допустимым значением такой характеристики считается 3.0, а самым лучшим - 3.6. Так как еще не придуманы стандарты для определения диапазона плотностей, многие производители накручивают цену своим девайсам, приводя лишь теоретически возможную характеристику. Думаю, что после чтения этого материала ты будешь выводить таких мошенников на чистую воду ;).

4. Шум

Характеристика, очень тесно связанная с динамическим диапазоном и глубиной цвета, показывающая наличие дефектов изображения (мелких деталей, резко выделяющихся на общем фоне по тону и цвету). Природа шумов различна. Они чаще всего возникают из-за проблем в цепи аналого-цифрового преобразования, ведут к нарушению чистоты и насыщенности цвета. Возникает обычно на участках с крайними значениями плотности. Об этой характеристике тактично умалчивается в паспорте девайса, так как она индивидуальна для каждого аппарата и оценивается лишь после пробной съемки.


Спецвыпуск Xakep, номер #034, стр. 034-076-5, В наш комп мы целый мир засунем

В наш комп мы целый мир засунем

Raisan и Forb

Спецвыпуск Xakep, номер #034, стр. 034-076-5

5. Цифровой зум

Смысл цифрового зума заключается в том, что центральная часть кадра интерполируется камерой до границ полного кадра. Реальное разрешение снижается пропорционально кратности значения этого свойства. Цифровой зум не исправляет искажений перспективы, вносимых широкоугольным объективом.

Основные форматы сжатия

Настало время поговорить об основных форматах архивации изображений на фотокамере. Их великое множество, но самыми популярными являются лишь три. Остановимся подробнее на каждом из них.

1.JPEG

Формат расшифровывается как Joint Photographic Experts Group, и изначально предназначался для записи точечных изображений с компрессией. Эффективность сжатия файла от десятых долей процента до ста раз (на практике 5-15 раз). Но стоит помнить, что сжатие в этом формате происходит с потерей качества (в большинстве случаев в допустимых пределах). Этот алгоритм сжатия самый популярный среди остальных.

2.TIFF

Формат TIFF (Tagged Image File Format) был создан в качестве универсального типа сжатия для изображений с цветовыми каналами (файл с расширением .TIF). Достоинством этого формата является его переносимость на разные платформы (при сохранении ты можешь создать документ, доступный для чтения на компьютерах, совместимых с IBM PC или Macintosh), он импортируется всеми настольными издательскими системами, его можно открыть и редактировать практически в любой программе точечной графики. Этот формат имеет самый широкий диапазон передачи цветов: от монохромного до 24-битовой модели RGB.

3. RAW

В случае если изображение не подвергается сжатию, оно хранится в базовом формате RAW. Он представляет собой файл из последовательности чисел (байтов), описывающих цветовую информацию, и предназначается для передачи изобразительной информации между разными программами и платформами.

На этом заключительном этапе наша зажатая картинка направляется в свой последний путь – на носитель информации. Было бы полезно рассмотреть достоинства и недостатки самых популярных контейнеров, которые относятся к Flash-памяти. Такая память была изобретена в 1984 году компанией Toshiba. Подробно узнать о ее строении и архитектуре ты можешь в тематической статье этого номера.

Вот, собственно, и конец моего рассказа. Но история на этом не заканчивается. С каждым годом цифровые технологии будут модернизироваться, и, возможно, совсем скоро человечество отыщет новые способы цифровой фотосъемки (вспомни, что я говорил – в XIX веке одни бумажные методы фотопечати постоянно заменялись другими), и нынешний этап - далеко не предел развития электронного изображения.

Правда, в ближайшие годы этого, скорее всего, не произойдет, так как технология цифровой печати только набирает силу. Делаем выводы - настоящие методы электронных изображений и архитектура цифровухи будут рулить еще несколько лет. Только после расцвета производители будут искать принципиально новые и дешевые технологии цифровой фотографии.


Спецвыпуск Xakep, номер #034, стр. 034-076-6, В наш комп мы целый мир засунем

В наш комп мы целый мир засунем

Raisan и Forb

Спецвыпуск Xakep, номер #034, стр. 034-076-6

Здесь ты можешь ознакомиться со всеми методами сжатия цифрового изображения – от RAW до TIFF:

www.2ka.mipt.ru/~sany/sanyjpeg/main.html

Вот небольшой словарь терминов, который может облегчить тебе жизнь при изучении основных принципов цифровой фотографии.

Многократное экспонирование (Bracketing)

Многократное фотографирование одного и того же объекта с разными экспозициями в сторону их увеличения и уменьшения по отношению к измеренному значению экспозиции. За счет этого достигается получение одного снимка с точной экспозицией.

Кружок рассеяния (Circle of Confusion)

Неправильно сфокусированный свет от точек объекта съемки воспроизводится на плоскости получения изображения в виде перекрывающихся кружков. Аберрации объектива также приводят к образованию кружков рассеяния.

Темновой ток (Dark Current)

Паразитные электрические заряды, которые постепенно накапливаются в элементах матрицы без воздействия света и приводят к созданию помех или формированию в изображении пикселов с неправильной цветопередачей.

В 1855 году известный физик Максвелл открыл совершенно новый метод цветной печати. Правда, процесс получения цветного изображения был крайне дорог и трудоемок, что не давало цветной фотопечати вытеснить черно-белые фотоснимки.

В Соньке уже была матрица на 28x104 пикселов (о качестве изображения можешь судить сам), поэтому можно с уверенностью сказать, что Mavica положила начало истории цифровой фотографии.

Матрица отличает обычную фотокамеру от цифровой. Это не что иное, как особый вид памяти, напоминающий мини-карточку. Матрица цифровика состоит из множества ячеек, каждой из которой соответствует отдельный элемент (пиксел).

После фотографирования (экспозиции) каждая ячейка получает определенный заряд, пропорциональный его освещенности.

Чтобы сэкономить деньги и насладиться качеством любительской фотосъемки, тебе нужен компактный девайс со встроенным объективом, у которого большая часть настроек (фокусировка, установка выдержки и диафрагмы и др.) осуществляется автоматически или фиксирована.

Природа шумов различна. Они обычно возникают на участках с крайними значениями плотности. Об этой характеристике тактично умалчивается в паспорте девайса, так как она индивидуальна для каждого аппарата и оценивается лишь после пробной съемки.

Зависимость размера фотографии от числа пикселов не линейная, а логарифмическая, так как переход от 3 MP к 4 MP сенсору увеличивает размер изображения не на 25%, а гораздо меньше.

Очень часто фотография нужна для отправки виртуальной возлюбленной по электронной почте, где не требуется высокое разрешение, а предпочтителен небольшой размер файла.

Flash-память была изобретена в 1984 году компанией Toshiba.


Спецвыпуск Xakep, номер #034, стр. 034-080-1, Эволюция звуковых технологий Dolby

Эволюция звуковых технологий Dolby

p0r0h

Спецвыпуск Xakep, номер #034, стр. 034-080-1

(www.livejournal.com/~p0r0h)

Теория и практика многоканального звука

Одни под словом "Dolby" подразумевает объемный звук, другие - одну из многочисленных технологий, а для кого-то это всего лишь логотип на акустике или на билете в кино. Так что же оно означает на самом деле, и какие технологии стоят за ним?

История развития

Прежде чем начать говорить о технологиях компании Dolby Laboratories, стоит проследить, как вообще развивалась история многоканального звука и откуда он взялся.

Все началось в далекие 50-е годы, когда телевидение стало стремительно развиваться, а киноиндустрия, напротив, переживала не лучшие времена из-за обострившейся конкуренции с домашними "голубыми экранами". Чтобы исправить сложившуюся ситуацию, были применены новые возможности полноэкранного кино, а именно - стереофоническая звуковая дорожка. Изначально в кинотеатрах было всего несколько акустических систем, располагавшихся непосредственно перед зрителями, потом появился еще один звуковой канал - "effects channel", акустика которого находилась за спинами зрителей. Служил он для единичных эффектов, а из-за ограниченной полосы частот и ощутимого уровня шума применялся довольно редко. В широкоэкранном формате (70 мм) применялись дорожки со схожими характеристиками, поэтому "effects channel" стал использоваться гораздо чаще, что положительно сказалось на пространственном восприятии звука. Отсюда и его следующее название - "surround channel", и название акустики для него - "the surrounds". Развитие домашней техники тоже не стояло на месте, о чем свидетельствует появление в 1958 году стереозвука. К тому времени образовалось и двухканальное радиовещание (FM Stereo), так что слово "stereo" обрело большую популярность. Следующим толчком к развитию многоканального звука послужило появление в начале 70-х годов четырехканального формата - квадро. Суть его заключалась в том, что две дополнительные акустические системы размещались позади слушателя. В то же время имеющаяся аппаратура пока не позволяла передавать раздельно четыре канала, поэтому потребовались технологии для их обработки. Однако ничего революционно нового представлено не было и, как следствие, квадро-акустика не получила должного распространения. И тут на сцене появляется компания Dolby Laboratories.

Dolby Stereo

Свое восхождение на звуковой олимп компания Dolby Laboratories начала с середины 1970-х годов, представив технологию объемного звучания для кинопленок (35 мм) - Dolby Stereo. Такие пленки использовались еще с 30-х годов, но если раньше носителем звука были магнитные дорожки, то новая технология использовала оптические, а также фотоэлементы вместо прежних магнитных головок. Только теперь две стереодорожки занимали то же пространство, которое раньше требовалось одной.

Это стало возможным благодаря специальному процессору Dolby A-type Noise Reduction, обрабатывающему сигнал перед записью. Такой шаг позволил обеспечить совместимость новой стереофонической пленки со старыми проекторами.

Dolby Surround

В середине 80-х годов киноиндустрия вступила на следующий этап развития, экраны кинозалов все увеличивались, а, следовательно, увеличивались и требования зрителей. В том числе и к качеству звука. Особенно остро возникла необходимость во внедрении центральной акустической системы, прежде всего для должного восприятия пространственного звучания. Поэтому для кинозалов потребовался еще один канал - surround channel. Общая же схема объемного звука стала выглядеть так: четыре канала звука - левый (Left), правый (Right), центральный (Center) и пространственный (Surround). Чтобы соответствовать всем этим требованиям, компании Dolby Laboratories пришлось усовершенствовать схему аналогового декодера, применяющего более продвинутые алгоритмы. С этого момента появилась технология Dolby Surround, а затем и Dolby Stereo Optical. Также на рынке стали появляться простые декодеры Dolby Surround, которые позволяли прослушивать пространственный канал (surround channel) на домашней аппаратуре. Следующими декодерами стали "Dolby Surround Pro Logic", выделяющие и центральный канал (center channel). Все эти этапы и привели к появлению комплекса соответствующей акустики и аппаратуры - "домашнего кинотеатра". Причем совершенствование на этом не остановилось и продолжается до сих пор. Благо единые стандарты, контролируемые Dolby Laboratories, позволяют различным производителям акустики и сопутствующей индустрии добиваться все лучшего качества звучания.


Спецвыпуск Xakep, номер #034, стр. 034-080-2, Эволюция звуковых технологий Dolby

Эволюция звуковых технологий Dolby

p0r0h

Спецвыпуск Xakep, номер #034, стр. 034-080-2

Dolby Digital

Эра технологии записи и воспроизведения многоканального звука началась с конца 1980-х, впервые появившись на 35-миллиметровой целлулоидной пленке для кинотеатров. Причем решение Dolby Laboratories было весьма оригинальным - цифровая инфа размещалась на нерабочей части пленки, а именно между окошками перфорации. Назвали такую систему "Dolby Digital 5.1", т.к. она использует шесть каналов звука в полном диапазоне - левый, правый, центральный, пространственный правый "Right Surround", пространственный левый "Left Surround", а также канал низкочастотных звуковых эффектов "Low Frequency Effects". Акустическая система этого канала получила название "Subwoofer", обычно он располагается между системами каналов "Left" и "Center". Обозначение " .1", соответствующее ему, возникло из-за того, что для него требовалась полоса частот в десять раз меньшая, чем для других каналов. Именно появление "Dolby Digital" позволило получить в "домашнем кинотеатре" практически такое же качество звука, как и в кинозале, со всеми реалистичными ощущениями и впечатляющими эффектами. Также в "Dolby Digital" заложена возможность с помощью декодера управлять компрессией. Это позволяет повышать уровень слабо слышимых звуков или, напротив, понижать слишком сильный сигнал. Еще декодер можно настроить так, чтобы низкочастотный сигнал передавался только на те каналы, для которых имеются низкочастотные динамики - у сабвуферов или широкополосной акустики. Еще одной отличительной особенностью технологии "Dolby Digital" является масштабируемость аппаратуры, поддерживающей целый ряд аппаратно и программно совместимых декодеров. Формат "Dolby Digital" использует информационное пространство носителей или каналов связи, и если сначала системы "Dolby Digital" использовались только в кинотеатрах, то в наше время они уже применяются в цифровом спутниковом и кабельном телевидении, в DVD, в современных игрушках и т.д.


Спецвыпуск Xakep, номер #034, стр. 034-080-3, Эволюция звуковых технологий Dolby

Эволюция звуковых технологий Dolby

p0r0h

Спецвыпуск Xakep, номер #034, стр. 034-080-3

Dolby Digital EX

Эта технология является несколько усовершенствованной версией "Dolby Digital", т.к. она использует не шесть, а семь каналов звука по схеме "6.1". Из них три канала "Surround" - пространственный левый, пространственный правый (акустику для них размещают вдоль боковых стен) и пространственный центральный (дает звук на задние акустические системы). Эта технология также применялась сначала только в кинотеатрах, а теперь уже выпущены даже звуковые семиканальные карты и активная акустика для РС.

Dolby-E

Этот цифровой формат специально разработан для профессиональных приложений, требующих многократного цикла кодирования-декодирования. С "Dolby Digital" это было проблематично, т.к. он рассчитан только на один цикл и к тому же не привязан по времени к формируемому изображению. Из-за чего редактировать видеоматериалы с технологией "Dolby Digital" не очень-то легко. Поэтому "Dolby-E" должен с успехом разрулить эту проблему и позволить легко монтировать видеоматериал, не нарушая синхронности аудио и видео. Особенностью этого формата является поддержка до восьми каналов звука с полной полосой частот. Помимо этого в поток вводятся "metadata" (данные, описывающие данные). Впрочем, использование их не обязательно, но на профессиональном уровне они зачастую бывают востребованы. Еще следует отметить, что структура потока "Dolby-E" соответствует кадровой структуре видео и допускает до десяти последовательных циклов кодирования-декодирования.

Virtual Surround

Конечно, многоканальный звук - штука хорошая, но дома или на рабочем месте не всегда есть возможность установить больше двух динамиков из-за ограниченного пространства или по финансовым причинам. Однако и тут Dolby Laboratories сумела найти выход из положения, разработав оригинальную технологию - Virtual Surround. С ее помощью стало возможным прослушивать звук, кодированный в Dolby Digital или в Dolby Surround, всего лишь на двух динамиках, причем воспринимается он как объемный surround. Сам процесс выглядит так: сигналы каналов "Left" и "Right" пропускаются декодером Dolby Surround Pro Logic или Dolby Digital 5.1 без изменений, а сигнал канала "Center" понижается на 3 дБ и при этом смешивается с сигналами каналов "Left" и "Right", образуя "виртуальный" центральный канал. Сигнал пространственного канала "Surround" обрабатывается специальным процессором - virtualizer'ом и тоже складывается с сигналами "Left" и "Right". Изменения, вносимые этим процессором, создают впечатление канала "Surround", расположенного позади слушателя. В идеале получившийся Virtual Surround создает ощущения, схожие с настоящим объемным звуком, но тут есть один существенный недостаток. Дело в том, что эта виртуальная технология хорошо работает только в определенном фиксированном положении слушателя относительно двух динамиков. Поэтому если сместиться в сторону, звуковая картина будет существенно нарушена.


Спецвыпуск Xakep, номер #034, стр. 034-080-4, Эволюция звуковых технологий Dolby

Эволюция звуковых технологий Dolby

p0r0h

Спецвыпуск Xakep, номер #034, стр. 034-080-4

Кодеры/декодеры

Чтобы получить представление о процессах кодинга и декодинга многоканального звука, рассмотрим их на примере Dolby Surround. Основной принцип работы "Dolby Surround" состоит в передаче четырех каналов звука, которые должны прослушиваться одновременно, создавая пространственную звуковую картину. На входе кодера "Dolby Surround" имеются сигналы четырех каналов - Left, Right, Center и Surround, а на выходе два - Left-total и Right-total ("total" подразумевает содержание, помимо левого и правого сигналов, еще и кодированных сигналов Center и Surround). Сигналы каналов "Left" и "Right" передаются на выходы "Left-total" и "Right-total" без изменений, а сигнал "Center" предварительно уменьшается на 3 дБ, затем делится пополам и складывается с сигналами каналов "Left-total" и "Right-total". Сигнал с канала "Surround" тоже ослабляется на 3 дБ, но перед сложением с сигналами "Left-total" и "Right-total" подвергается еще целому ряду преобразований:

Полоса частот ограничивается полосовым фильтром (от 100 Гц до 7 кГц);

Сигнал обрабатывается шумоподавителем (процессором Dolby B-type Noise Reduction);

Сигнал сдвигается по фазе на +90 и -90 градусов так, чтобы его составляющие (для сложения с "Left-total" и "Right-total") оказались в противофазе друг с другом.

Таким образом, в каналах "Left-total" и "Right-total" присутствует сигнал "Center" и компоненты сигнала "Surround", находящиеся в противофазе (звук, соответствующий им, компенсируются в пространстве между акустическими системами). Отсюда звук канала "Surround" получается немного призрачным, плавающим между левой и правой колонками.

Что касается работы декодера "Dolby Surround", то понять принцип его работы можно, рассмотрев блок-схему простейшего из них (пассивного). Центральным блоком в такой схеме декодирования является обыкновенный операционный усилитель.

Входной сигнал "Left-total" проходит на выход без изменений и становится левым каналом. Аналогично и "Right-total". А так как сигналы "Left-total" и "Right-total" содержат часть сигнала центрального канала, то зрители, сидящие по центру, будут ощущать его в полной мере (в отличие от зрителей, сидящих по бокам кинозала). На выходе блока "L-R" присутствует Surround сигнал, который выделяется путем вычитания из "Lt" и "Rt". Затем полученный сигнал проходит через специальный фильтр (7 кГц, нужен для эффективного разделения каналов), акустическую линию задержки (гарантирует, что звук фронтальных каналов достигнет ушей слушателя раньше, чем звук из канала "surround") и дополнительный блок шумоподавления (от проникающих сигналов каналов "L" и "R"). Вдобавок, все перечисленное применяется, исходя из особенностей восприятия звуков человеком, что и позволяет технологии "Dolby Surround" впечатлять своими эффектами многочисленных зрителей.

"Полосатый" звук


Спецвыпуск Xakep, номер #034, стр. 034-080-5, Эволюция звуковых технологий Dolby

Эволюция звуковых технологий Dolby

p0r0h

Спецвыпуск Xakep, номер #034, стр. 034-080-5

При выборе колонок нужно проверить, сколько на ней установлено динамиков. Однополосные системы вряд ли обеспечат приличное звучание (как правило, во всех китайских пластмассовых "погремушках" всего один паршивенький динамик), двухполосная же акустика куда привлекательней и имеет более широкий диапазон воспроизводимых частот. Ну, а идеальным вариантом будут колонки с тремя динамиками (каждый динамик воспроизводит отдельно низкие, средние и высокие частоты). Еще у хороших колонок часто можно встретить фазоинвертор (специальная труба, вмонтированная в корпус), обогащающий звучание низкими частотами.

Термины

АЧХ - это амплитудно-частотная характеристика, показывающая разницу величин амплитуд выходного и входного сигналов во всем диапазоне воспроизводимых частот. Проще говоря, чем больше диапазон воспроизводимых частот, тем лучше и достовернее звучание акустики. Однако производители зачастую указывают лишь граничные частоты и неравномерность - FR (frequency response). Поэтому такая характеристика не дает полного представления о качестве звучания.

Импеданс (impedans) - это полное электрическое сопротивление переменному току, измеренное на частоте 1000 Гц. Этот параметр практически ничего не скажет о качестве звучания акустики, но его следует учитывать при подключении колонок к усилителю. Желательно, чтобы сопротивление колонок и усилка было одинаковым, иначе появятся нелинейные искажения или звук будет заметно тише, чем предусмотрено производителем.

ПОДКЛЮЧЕНИЕ

У многих могут возникнуть вопросы, о том, как лучше расположить многоканальную акустику для домашнего кинотеатра. Отвечаю :]. Сабвуфер лучше установить внизу, под столом или слева от него. Фронтальные сателлиты должны располагаться на расстоянии чуть более метра от монитора или экрана телевизора. Центральную колонку лучше выдвинуть вперед или поставить на монитор/экран, а тыловые сателлиты можно поместить сзади на пол или привинтить к стене на уровне головы. Но будет лучше, если ты сам поэкспериментируешь с расположением акустики и добьешься того, чтобы система звучала как хороший комплект, а не как разрозненные источники звука.

РАЗМЕР - имеет значение!

Не стоит думать, что колоночки небольшого размера способны нормально озвучить комнату с компьютером, т.к. диаграмма направленности у таких пищалок очень узкая и к тому же звук даже на средней громкости, скорее всего, будет с большим количеством искажений, срываясь на хрип, рык, хрюканье, бульканье и прочие малоприятные звуки. Колонки же больших размеров внушают уважение не только своим видом, но и на порядок лучшим звуком. Да, такие системы стоят немало, однако свою цену они, как правило, отрабатывают полностью, радуя слушателей объемным и более чистым звучанием.

Creative Audigy 2 - КЛЮЧЕВЫЕ ОСОБЕННОСТИ:

Поддержка 6.1 акустики в играх и фильмах + семь аналоговых выходов;

Проигрывание аудио в максимальном режиме 24 Бит/192 кГц;

Воспроизведение/запись в режиме 24 Бит/96 кГц;

Поддержка формата DVD-Audio;

Декодирование Dolby Digital EX;

Сертификат THX;

Новейшие алгоритмы обработки звука;


Спецвыпуск Xakep, номер #034, стр. 034-080-6, Эволюция звуковых технологий Dolby

Эволюция звуковых технологий Dolby

p0r0h

Спецвыпуск Xakep, номер #034, стр. 034-080-6

Улучшенное соотношение сигнал/шум – 106 дБ.

www.dolby.com

www.dolby.ru

www.ixbt.com/multimedia.shtml

www.chillout.ru

http://dev.azz.ru

http://hifiworld.boom.ru

www.aha.ru/~agregatr

http://release.narod.ru

www.hi-fi.ru

Развитие домашней техники тоже не стояло на месте, о чем свидетельствует появление в 1958 году стереозвука. К тому времени образовалось и двухканальное радиовещание (FM Stereo), так что слово "stereo" обрело большую популярность.

Свое восхождение на звуковой олимп компания Dolby Laboratories начала с середины 1970-х годов, представив технологию объемного звучания для кинопленок (35 мм) - Dolby Stereo.

Обозначение " .1" возникло из-за того, что для сабвуфера требовалась полоса частот в десять раз меньшая, чем для других каналов.


Спецвыпуск Xakep, номер #034, стр. 034-084-1, Мониторы будущего

Мониторы будущего

Докучаев Дмитрий aka Forb

Спецвыпуск Xakep, номер #034, стр. 034-084-1

(forb@real.xakep.ru)

Плазменные панели - технология сегодняшнего дня

Посвящается технологии плазменных панелей, уверенно занимающей нишу рынка плоских мониторов с диагональю более 30 дюймов.

История

Почти любая технология начинает разрабатываться только тогда, когда ее предшественники перестают соответствовать требованиям времени. Так же получилось и с плазменными панелями. Поскольку старенькие ЭЛТ не могли быть использованы для создания качественных широкоэкранных (более 30 дюймов) телевизоров ввиду своих габаритов и особенностей конструкции (низкая яркость), ученые обратились к явлению "холодной плазмы", которая до этого использовалась лишь в неоновых вывесках и лампах дневного света. «А почему бы и нет?» - подумали они. Ведь колба с неоном светится? Светится, причем ярко и, возможно, разными цветами. А что есть изображение? В сущности, это много маленьких светящихся колбочек :).

Первые плазменники были монохромными и очень дорогими, поэтому не использовались в качестве телевизоров, зато получили определенную популярность на биржах и вокзалах - благодаря большому размеру и ядовито-оранжевому цвету текста, информацию на них могли рассмотреть даже слабовидящие читатели. Но прогресс не стоял на месте, и через несколько лет этим вопросом вновь заинтересовались научные лаборатории японских компаний. Здоровая конкуренция между ними и породила то, что мы имеем на сегодняшний день.

Почему плазма?

Плазменная технология только начинает набирать обороты на компьютерном рынке, поэтому, разумеется, технологию жидкокристаллических панелей еще никто не отменял. Но ее применяют в основном для мониторов с диагональю менее 30 дюймов (недавно произвели на свет ЖК-экран с диагональю 50 дюймов - прим. ред.). "А с большими панелями что?" - спросишь ты. Вот тут как раз берет свое технология плазменников. Конечно, существует третья технология – старых электронно-лучевых трубок. Но совсем скоро она будет вытеснена ЖК-мониторами. Сейчас цены на "стеклянные" мониторы очень низкие, и производство ЭЛТ-мониторов постепенно сворачивается...

Плазменная технология прижилась на рынке лишь благодаря ряду достоинств перед своим непосредственным конкурентом – жидкими кристаллами. Рассмотрим несколько таких преимуществ.

Плазменные панели не оказывают вредного влияния на человека и домашних животных и не притягивают пыль и листы из принтера к поверхности экрана.

В отличие от ЖК, плазменные панели можно использовать не только в качестве телевизоров и мониторов компьютера. Именно благодаря размеру экрана становится возможным подвесить такой монитор в зале ожидания вокзала, например, и "вырисовывать" на нем расписание поездов. Короче говоря, технология плазменных панелей находит свое применение в области производства различных табло. А их в наше время можно увидеть где угодно (на улице в виде рекламных стендов, в аэропорту в виде информационного дисплея, на бирже в виде информации о котировках валют и т.д. и т.п.).

Изображение на плазменной панели очень напоминает живую картинку в кинотеатре. Дело в том, что плазма имеет своеобразный "кинематографический" акцент, который очень полюбился поклонникам "домашнего кино". Поэтому, как ты, наверное, догадался, в кинотеатрах высокого класса фильмы крутят только на таких вот дорогих экранах (сомнительно, скорее там используют дорогие проекторы - прим. ред.). Впрочем, цена – это уже отдельный вопрос, о котором я скажу чуть ниже.


Спецвыпуск Xakep, номер #034, стр. 034-084-2, Мониторы будущего

Мониторы будущего

Докучаев Дмитрий aka Forb

Спецвыпуск Xakep, номер #034, стр. 034-084-2

Как ни странно, но при своем огромном экране плазменные панели имеют исключительно компактные размеры и вес, поэтому без труда могут быть подвешены в любом месте.

Светотехнические параметры плазменных панелей исключительно высоки: яркость изображения свыше 300 кд/м2 при контрастности не менее 350:1. И что очень важно, нормальное изображение обеспечивается в чрезвычайно широком угле зрения по горизонтали: в 160 градусов.

Технический ресурс "плазмы" составляет не менее 30000 часов (у очень хорошего кинескопа 15000-20000 часов), а процент брака не превышает 0,2%. Поэтому можешь с уверенностью заказывать себе плазменную панель – она переживет даже твоих внуков.

Итог – я навскидку привел шесть преимуществ плазменных панелей. И это далеко не все плюсы. По неписанным законам, у каждой технологии есть как преимущества, так и недостатки. Плазменная не исключение, она имеет всего один недостаток – высокую цену. Надеемся, что это временно, и вскоре цены на плазменные панели будут значительно ниже (к этому все и идет).

И все-таки она светится!

Высокая цена связана со сложностью изготовления панелей. Настало время поговорить о производстве. Дело в том, что принцип работы плазменной панели похож на процесс, протекающий у обычной лампы дневного света, в которой излучает разреженный инертный газ, находящийся состоянии холодной плазмы. Фактически, этот газ распределен не по всей поверхности панели, а в специальных "колбочках". При воздействии на них ультрафиолетового излучения, плазма... начинает светиться.

Излучение возникает при электрическом разряде в среде сильно разреженного газа. При таком разряде между электродами с управляющим напряжением образуется проводящий "шнур", состоящий из ионизированных молекул газа (плазмы). Это обуславливает сразу два качества плазменных панелей.

1.Свое название "плазменная" или "газоразрядная" технология получила именно из-за принципа, на котором она основана.

2.Потребляемая мощность в десятки раз выше, чем у ЖК-панелей. Это обуславливается огромной энергией, которая необходима для образования проводящего "шнура".

Структурным элементом, формирующим отдельную точку изображения, является группа из трех подпикселов, ответственных за красный, зеленый и синий цвета соответственно (RGB-структура). Каждый субпиксел представляет собой миниатюрный куб, стенки которого покрыты флюоресцирующим веществом одного из главных цветов. Все пикселы находятся в точках пересечения прозрачных управляющих хром-медь-хромовых электродов, покрытых слоем диэлектрика сверху и слоем окиси магния снизу (слои защищают электрод от разрушения и выступают в роли диэлектрика). Таким образом, электроды образуют прямоугольную сетку.


Спецвыпуск Xakep, номер #034, стр. 034-084-3, Мониторы будущего

Мониторы будущего

Докучаев Дмитрий aka Forb

Спецвыпуск Xakep, номер #034, стр. 034-084-3

Запалим?

Процесс "поджигания" пиксела сопровождается целой цепочкой физических явлений. Сначала на перпендикулярные друг другу питающий и управляющий электроды подается высокое управляющее переменное напряжение. Атомы газа отдают большую часть своих валентных электронов, и газ переходит в состояние плазмы. Затем на сканирующий электрод подается импульс - происходит разряд - часть заряженных ионов отдает энергию в виде излучения "ультрафиолетовых" фотонов. Отсюда и появляется ультрафиолетовое излучение, которое порождает свет. Такое излучение очень вредно для глаз человека, но почувствовать его не представляется возможным, поскольку стенки подпикселов покрыты люминофором - и именно возбужденный люминофор излучает видимый свет.

Программируем изображение

С помощью специальной программной микросхемы подаются управляющие сигналы на электродную сеть. Сетка, как я уже говорил, нанесена на внутренние поверхности стекол панели. Схема управления PDP (Plasma Display Panel, общепринятое сокращение технологии) осуществляет соответственно "строчную" и "кадровую" развертку растра телевизионного изображения. При этом яркость каждого элемента изображения определяется временем свечения соответствующей ячейки плазменной панели: самые яркие элементы должны светиться постоянно, а в наиболее темных местах они вовсе не "поджигаются". Светлые участки изображения на PDP светятся ровным светом, и поэтому изображение абсолютно не мерцает, чем выгодно отличается от картинки на экране традиционных кинескопов.

В обычных электронно-лучевых трубках бомбардировка каждого "люминофора" происходит с частотой 25 раз в секунду. Соответственно, происходит их пульсация. А в плазменных панелях мерцание отсутствует, что сказывается положительно на зрении человека.

Применение панелей

Как было сказано выше, область применения плазменных панелей очень велика. С каждой областью связан ряд условий, которые оговариваются фирмами-производителями.

В случае, когда панель используется для просмотра эфирных программ, необходимо помнить, что плазменные панели выпускают с соотношением сторон 16:9, в то время как трансляция сигнала идет в формате 4:3. Такой формат панели необходим для ее использования в качестве домашнего кинотеатра, потому что изначально фильмы записываются на широкоформатную пленку. Благодаря тому, что технология позволяет масштабировать изображение, этот недостаток легко устраняется (но он был актуален в панелях предыдущего поколения).

Плазменные панели могут воспроизводить различные стандарты телевизионного сигнала с внешних источников (NTSC, PAL, SECAM). Наибольший интерес представляет их совместимость с телевидением высокой четкости (HTDV), возможность принимть сигналы различных форматов, как с чересстрочной, так и с прогрессивной разверткой. Что немаловажно, PDP подходят также в качестве мониторов при подключении к компьютеру. Таким образом, практически все панели имеют композитный, S-Video, компонентные входы, а также компьютерный RGB-вход. Многие также могут воспроизводить изображение с компьютера, однако не все панели имеют большое разрешение (и маленькую зернистость).


Спецвыпуск Xakep, номер #034, стр. 034-084-4, Мониторы будущего

Мониторы будущего

Докучаев Дмитрий aka Forb

Спецвыпуск Xakep, номер #034, стр. 034-084-4

Итак, прежде чем сделать покупку, стоит определиться, для каких целей панель будет использована и какое максимальное разрешение необходимо реализовать. Это обусловлено тем, что в PDP с малым разрешением графические и текстовые объекты будут "ломаться".

Развитие и перспективы

Технология сейчас находится далеко не на последней стадии своего развития. Скорее наоборот – только зарождается. В этом позволяет убедиться единственный недостаток PDP – цена. Впрочем, в скором времени ситуация изменится к лучшему.

Сама технология реализуется на рынках корейскими и японскими компаниями, которые и являются лидерами в производстве плазменных панелей. Мало того, эти компании изобретают свои технологии, основывающиеся на плазменной.

Так, например, известная компания Matsushita разработала собственную технологию TDPS (Three-Dimensional Progressive Scan). Она преобразовывает видеосигналы с чересстрочной разверткой растра в прогрессивные, свободные от артефактов движения. Благодаря этому, компания снабжает свои PDP-телевизоры встроенными двунаправленными цифровыми интерфейсами i.Link (IEEE 1394). К тому же, Matsushita славится своими нововведениями. Еще одним достоинством новых моделей PDP от этого же производителя является наличие у них встроенного адаптера (считывателя) полупроводниковых карт памяти SD (Secure Digital Memory Card). Это очень удобно для проведения презентаций, так как позволяет вывести отснятое цифровой камерой изображение на экран непосредственно с SD-карты.

Фирма Pioneer разработала специальную структуру ячеек типа DWS (Deep Waffle Structure). Дело в том, что для повышения яркости свечения экрана, помимо улучшения эффективности преобразования энергии в люминофоре, можно просто увеличить его площадь. Это достигается двумя путями: увеличивать размер или глубину ячейки. Первый, в связи с неизбежным уменьшением разрешения, неприемлем, а вот второй нашел свое применение. Именно им, несмотря на техническую сложность, и пошла фирма Pioneer. Вследствие этого яркость свечения у PDP увеличилась на 50%. Для преобразования чересстрочного растра в прогрессивный в панелях компании используется оригинальная технология HD Progressive image processing, а для отображения без потери четкости различных форматов телевизионных сигналов придуман собственный алгоритм IP Conversion Method.

Нота патриотизма

Я упоминал только иностранные фирмы-производители, но ни слова не сказал про отечественные. На самом деле такие тоже имеются. Лидером в производстве панелей является компания "Плазма", которая находится в городе Рязани. Набирают обороты и другие фирмы, которых по стране насчитывается уже больше десятка.

Конечно, хочется верить, что и Россия через десяток лет войдет в число "развитых европейских государств", где телевизоры на плоских панелях будут чуть ли не в каждом доме. Приятно отметить, что отечественные разработки в области плазменных панелей ничуть не хуже западных. Более того, цены на наши панели значительно ниже европейских. Правда в серийное производство наши панели пока не пошли. Но, по некоторым прогнозам, это случится в ближайшем будущем.


Спецвыпуск Xakep, номер #034, стр. 034-084-5, Мониторы будущего

Мониторы будущего

Докучаев Дмитрий aka Forb

Спецвыпуск Xakep, номер #034, стр. 034-084-5

Итого

Надеюсь, что материал помог тебе разобраться в PDP, и теперь ты можешь ориентироваться в панелях различных производителей. Еще раз обращаю внимание на то, что не обязательно покупать самую дорогую панель. Все зависит от области ее применения. Подробнее об этом можно узнать на сайтах производителей плазменных экранов.

Интересные ссылки:

www.plasma.com.ru – сайт рязанского НИИ "Плазма". Здесь ты можешь познакомиться с перспективными отечественными разработками в области плазменных панелей.

www.t3.ru/tn/tn01_052003/ - Tomorrow Technology Today (T3). Публикует интересные статьи о плоских экранах.

http://web.reedexpo.co.jp/ftj/english/ - Самая большая в мире выставка достижений в области плоских экранов (на английском).

Использованные сокращения:

FPD - плоский (малой толщины) экран (Flat Panel Display)

CRT - электронно-лучевая трубка (Cathode Ray Tube)

PDP - плазменная панель (Plasma Display Panel)

OLED - панели из органических светодиодов (Organic Light-Emitting Diode)

STN - разновидность монохромных жидкокристаллических панелей (Super Twisted Nematic), используется в мобильных телефонах и органайзерах

HDTV - телевидение высокой четкости (High Definition TV)

Компании, продающие плазменные панели в России:

1. Cеть компьютерных магазинов "Белый Ветер" (www.proj.ru), специализируется на панелях NEC и SONY

2. "ИНТЕЛИМПЕКС-ВИДЕО" (www.videoprojector.ru, www.inteluni.com), специализируется на панелях PHILIPS

3. Компания "Provision" (www.provision.ru), специализируется на панелях PHILIPS, FUJITSU, PANASONIC, SONY, PIONEER, NEC, THOMSON

4. Компания "CTC CAPITAL" (www.ctccapital.ru), специализируется на панелях JVC, SANYO

ЭЛТ не могли быть использованы для создания широкоэкранных телевизоров, и ученые обратились к явлению "холодной плазмы", которая до этого использовалась лишь в неоновых вывесках и лампах дневного света.

Плазменные панели можно использовать не только в качестве телевизоров и мониторов компьютера, но благодаря размеру экрана становится возможным подвесить такой экран даже в зале ожидания вокзала.

Плазма имеет своеобразный "кинематографический" акцент, который очень полюбился поклонникам "домашнего кино".

Технический ресурс "плазмы" составляет не менее 30000 часов (у очень хорошего кинескопа 15000-20000 часов), а процент брака не превышает 0,2%.

Принцип работы плазменной панели похож на процесс, протекающий у обычной лампы дневного света, в которой излучает разреженный инертный газ, находящийся в состоянии холодной плазмы.

Структурным элементом, формирующим отдельную точку изображения, является группа из трех подпикселов, ответственных за красный, зеленый и синий цвета соответственно (RGB-структура).

С помощью специальной программной микросхемы подаются управляющие сигналы на электродную сеть.


Спецвыпуск Xakep, номер #034, стр. 034-088-1, УБЕРЕГИ CMYK ОТ RGB

УБЕРЕГИ CMYK ОТ RGB

thorus (izgondurasa@pisem.net)

Спецвыпуск Xakep, номер #034, стр. 034-088-1

Полиграфия в разрезе

"Мне чтоб про химию... Но с голыми девками!"

(пожелание заказчика по оформлению перекидного календаря)

Итак, полиграфическая продукция! Как она делается? В этой статье я постараюсь осветить принцип полиграфического производства вообще и офсетного в частности. Распространяться о преимуществах, недостатках и различиях векторной и растровой графики я не буду. А вот на цвете имеет смысл остановиться подробнее.

ЦВЕТ

Основные цветовые модели, с которыми тебе придется иметь дело - это RGB и CMYK. RGB - аддитивная (излучаемая, слагаемая), CMYK - субтрактивная (отражаемая, вычитаемая). Модель RGB, как следует из аббревиатуры, состоит из трех основных цветов: Red (красный), Green (зеленый) и Blue (синий). Применяется она в основном в источниках цвета, излучающих свет (еще в электронных устройствах ввода, таких как сканеры и цифровые фотокамеры). Отсюда и термин "излучаемая". Сочетание максимальной насыщенности всех трех цветов дает (в идеале) чистый белый цвет. В каждом цвете 256 градаций: от 0 до 255. То есть белый цвет даст сочетание R - 255, G - 255, B - 255, а черный - R - 0, G - 0, B - 0. Отсюда термин "слагаемая". Работа в RGB в полиграфии абсолютно неприемлема! Есть, конечно, широкоформатные принтеры, рассчитанные на печать из-под RGB, но ты ведь не собираешься печатать рекламные буклеты или журнал на баннерном полотне шириной 6-8 м :).

Цветовая модель CMYK основана на абсолютно противоположном и вместе с тем аналогичном предыдущему принципе. Здесь тоже имеются три основных цвета: Cyan (голубой), Magenta (пурпурный) и Yellow (желтый). Эти три цвета (опять же в идеале) должны при максимальной насыщенности дать глубокий черный цвет. Однако на практике все не так гладко. Сочетание всех трех цветов может дать грязный цвет черно-коричневого оттенка.

Если тебе необходимо получить на выходе из печати густой черный цвет, то подойдет сочетание Cyan – 40-80%, Magenta – 0%, Yellow – 0% и Black – 100%. Увеличение Cyan до 80% придаст черному глубину и насыщенность. Но ни в коем случае не пытайся пускать по такой подложке белый текст (белый текст на черном фоне в полиграфии называется вывороткой). Малейшее несведение при печати приведет к тому, что края букв станут голубыми. Поверь, смотрится это не очень привлекательно. А мелкий шрифт вообще может стать плохочитаемым – "слепым".

Да и темные оттенки других цветов могут получиться несколько блеклыми. Для глубины передачи цвета в данную систему цветоделения был введен дополнительный цвет: К - черный. Почему Black обозначается буквой "К" даже не спрашивай. До сих пор не знаю сам, но есть подозрение, что буква "В" уже занята другим цветом ;). Каждый цвет CMYK имеет 100 градаций: от 0 до 100%. CMYK применяется как модель, описывающая свойства отраженного света.

Кроме двух основных цветовых моделей (RGB и CMYK) существуют и другие. Для более тонкой коррекции цвета применяется модель cie Lab, принятая в 1920 году Communication Internationale de l'Eclairage (международной комиссией по освещению). Ее редакция от 1976 года до сих пор является международным стандартом для описания преобразований цвета при переводе из одной модели в другую. Также на основе этой цветовой модели часто строятся профили устройств, описывающие цветовое пространство конкретного устройства. Например, твоего монитора, принтера или сканера.


Спецвыпуск Xakep, номер #034, стр. 034-088-2, УБЕРЕГИ CMYK ОТ RGB

УБЕРЕГИ CMYK ОТ RGB

thorus (izgondurasa@pisem.net)

Спецвыпуск Xakep, номер #034, стр. 034-088-2

Если ты видишь картинку оранжевого или синего цвета, то это означает только то, что использованная краска поглощает (вычитает) все области видимого спектра, кроме оранжевого и синего. А лучи вышеуказанных цветов благополучно возвращает нам. Отсюда термины "отражаемая" и "вычитаемая". При сочетании C - 100, M - 100, Y - 100, K - 100 получается насыщенный черный цвет (отсутствие отраженных лучей), а при значениях всех составляющих равных нулю - белый (отраженный полный спектр световых лучей). Это в идеале. Конечно, стоит учитывать такие параметры как белизна бумаги и излучаемый спектр текущего источника света. Печать в цветовой модели CMYK называется триадной.

PANTONE

Кроме того, не стоит сбрасывать со счетов цвета Pantone (pantone.ru, pantone.com). Pantone на данный момент - основная фирма, представляющая на российском и мировом рынках свои веера стандартизированных цветов. Практически все основные производители полиграфических красителей (и российские) имеют лицензию Pantone на производство красителей, отвечающих стандартам этой фирмы. Получить такую лицензию можно только при очень жестком соблюдении технологического процесса и полном соответствии заявленных индексов красителей индексам вееров Pantone. В СССР был свой аналогичный стандарт - "Радуга" ;). У Pantone есть еще библиотеки металлизированных красителей.

Веера Pantone бывают процессными (process), на которых можно заранее посмотреть, какой цвет получится в результате смешения четырех основных цветов CMYK, плашечными (solid) и веера перевода и соответствия плашка-процесс. Плашечные цвета, как следует из названия, применяются в основном для печати плашкой (четко очерченной цветовой областью со стопроцентной насыщенностью), либо растрируются в один цвет.

В CMYK-печати допускается растеризация дополнительных цветов из гаммы Pantone, но работа с ними требует дополнительных навыков, и даже печатники иногда не в состоянии заранее предвидеть результат подобных экспериментов.

ВЫБОР ПРОГРАММНЫХ ПАКЕТОВ

Я думаю, нет необходимости убеждать тебя в том, что в области работы с растровой графикой неизменным фаворитом уже на протяжении полутора десятилетий является Adobe Photoshop. С векторной графикой все значительно сложнее. Выбирать придется из трех пакетов: Adobe Illustrator, Corel Draw и Macromedia Free-Hand. Лично я, несмотря на очевидную дружественность и удобство Corel Draw, отказался от работы с ним. Слишком велика вероятность ошибок во время вывода пленок. Работа с Illustrator и FreeHand может быть менее удобна, но надежность пакетов не вызывает сомнений.

Если ты собираешься печатать не полноцветное издание, а, к примеру, визитки или бланки, то не стоит заморачиваться с системами цветоделения. Подобную продукцию, как правило, проще напечатать в два-три плашечных цвета Pantone. Веера Pantone стандартизированы, и цвет по ним можно выбрать в любой типографии. Но при этом не следует забывать о том, что красители из гаммы Pantone в большинстве своем являются кроющими, то есть плашка со стопроцентной запечаткой перекрывает все, что было напечатано в этой области раньше.


Спецвыпуск Xakep, номер #034, стр. 034-088-3, УБЕРЕГИ CMYK ОТ RGB

УБЕРЕГИ CMYK ОТ RGB

thorus (izgondurasa@pisem.net)

Спецвыпуск Xakep, номер #034, стр. 034-088-3

В чем верстать? Задай этот вопрос любому профессиональному верстальщику и в ответ услышишь: "А ты сомневаешься? Конечно Quark XPress!". Верная рабочая лошадка, не раз вытягивавшая там, где буксовали остальные. Можно возразить, что кроме Quark XPress есть и такие замечательные пакеты, как Adobe Page Maker и InDesign, но... Попробуй.

Когда планируется печать тиража на бумаге, тонированной в массе (на бумаге, имеющей цвет, отличный от белого), то помни о том, что триадные краски CMYK не являются кроющими, и во время цветокоррекции иллюстраций не забудь учесть тон бумаги.

Используя последнюю (сырую) версию программы для обработки растровой или векторной графики и верстки, ты рискуешь нарваться на проблемы во время вывода. Лучше заранее позвонить в препресс-бюро, с которым ты собираешься работать, и узнать, какие "рабочие" версии программных пакетов у них установлены.

ПОДГОТОВКА ИЗОБРАЖЕНИЙ И СКАНИРОВАНИЕ

Процесс, несомненно, ответственный и требующий тщательного подхода. Прежде всего выкинь из головы мысли о домашнем планшетнике типа Mustek’a или HP. Планшетные сканеры, которые подходят для работы в полиграфии, стоят довольно дорого, и сканирование на них соответственно тоже стоит денег. Разброс цен от доллара до пяти за один скан. В работу также должна входить цветокоррекция (хотя бы начального уровня), и лучше заранее оговаривать подобные вещи. Хороший планшетник можно найти почти в любом дизайн или препресс-бюро. Гораздо сложнее обстоит дело со сканированием прозрачных оригиналов.

Для наглядности расскажу историю, произошедшую этой весной. Некий человек, которому нужно было отпечатать тираж каталогов работ известного художника, обратился с заказом на печать в одну из московских типографий. Заодно они договорились и о том, что типография берет на себя всю предпечатную подготовку. Все работы художника были отсняты на профессиональные широкоформатные слайды швейцарским фотографом, специализирующимся на съемке произведений искусства. Каково же было удивление заказчика, когда, придя в типографию подписывать первые приладочные листы, он увидел вместо ярких, живых изображений бесплотные, белесые тени, набросанные на лист. Скандал! Типография утверждает, что таковы были слайды, заказчик (что вполне объяснимо) этому не верит. В результате привлекаются специалисты со стороны.

Если в твоей верстке присутствуют фоны полос или иллюстрации, идущие навылет (иллюстрации, перекрывающие поле полосы издания вплоть до линии обреза), то не забудь оставить припуск под обрез не менее 3,5-4 мм. В противном случае ты рискуешь заработать сильную икоту в момент резки тиража, так как резчик неоднократно помянет тебя добрым словом :). Да и на полях могут остаться тонкие белые полосы после неровной обрезки. Резчик - не бог, а резак даже с лазерной приводкой имеет допуски в районе 1-2 мм.


Спецвыпуск Xakep, номер #034, стр. 034-088-4, УБЕРЕГИ CMYK ОТ RGB

УБЕРЕГИ CMYK ОТ RGB

thorus (izgondurasa@pisem.net)

Спецвыпуск Xakep, номер #034, стр. 034-088-4

Выясняется, что незадолго до этих событий типография приобрела довольно дорогой профессиональный барабанный сканер. Посчитав, что такое дорогущее устройство может сканировать слайды так, что цветокоррекция впоследствии не потребуется, за этот сканер посадили молодого человека, который до этого был помощником печатника. Иными словами, они решили сэкономить на найме профессионала и поручили эту работу полному профану. В основе конструкции барабанных сканеров лежит прозрачный цилиндр, на который должны крепиться оригиналы (слайды). Когда оригинал закреплен, начинается вращение цилиндра, во время которого и происходит процесс сканирования. Что важно знать об этой технологии? Прежде всего то, что крепление оригинала к барабану должно происходить с помощью специальных гелей с определенными оптическими свойствами.

Делается это для того, чтобы добиться плотного прилегания слайда к барабану и отсутствия воздушной прослойки между поверхностями барабана и слайда, что помогает избежать появления на скане неуместных артефактов вроде муара или колец Ньютона. Если в том месте, куда ты отдал слайды, тебе сказали, что сканируют с гелями, а на конечных сканах ты видишь то, чего на слайде явно не было, добивайся перескана! К сожалению, многие конторы, имеющие в своем арсенале хорошие барабанные сканеры, предпочитают экономить на дорогостоящих гелях и крепят слайды к барабану с помощью обычного скотча. При возвращении слайдов внимательно осмотри их углы на предмет остатков скотча или следов клея.

Причины появления на сканах артефактов - физические. Воздушная прослойка между барабаном и слайдом неизбежна в случае крепления скотчем. Слайд вследствие центробежной силы, возникающей при вращении барабана, как бы "отстает" от поверхности, к которой прикреплен. Луч, проходя через воздушную прослойку, лишний раз преломляется воздухом и, соответственно, качество скана ухудшается. Скан, сделанный при несоблюдении технологии сканирования на данном конкретном сканере, заведомо менее качественен, чем скан, сделанный по всем правилам.

ШРИФТЫ

Разнообразие шрифтов, лежащих на лотках, огромно. Где-нибудь в Митино можно купить порядка 15000 шрифтов всего за 70 рублей, но шрифт должен правильно пониматься программой. И даже если каждый изгиб твоего любимого Helios или Petersburg кристально чисто воспроизводится монитором, это совсем не значит, что на пленках ты не получишь набор закорючек, смахивающих на какую-нибудь кодировку родом из Тайваня. Прежде всего постарайся забыть про шрифты True Type и не используй их при верстке публикаций. Только шрифты Type1! Для их подключения тебе потребуется утилита Adobe Type Manager.

Линиатура - количество линий на дюйм (lpi), с которым печатается полутоновое изображение, обычно от 55 до 225 lpi. Линиатуры от 55 до 100 lpi характерны для газетного производства. Линиатуры 133 и 150 lpi - самые популярные значения, они используются при производстве различной полноцветной представительской и журнальной продукции. Линиатуры от 175 lpi и выше применяются при печати изделий, критичных к качеству изображений и цветопередаче (например, каталоги произведений искусства).


Спецвыпуск Xakep, номер #034, стр. 034-088-5, УБЕРЕГИ CMYK ОТ RGB

УБЕРЕГИ CMYK ОТ RGB

thorus (izgondurasa@pisem.net)

Спецвыпуск Xakep, номер #034, стр. 034-088-5

Лучший способ избавиться от потенциальных проблем с кириллическими шрифтами - купить набор шрифтов у производителя. Или взять у знакомых ребят, работающих на фотовыводе, проверенный "боевой" набор. Такой набор, как правило, имеется у каждого верстальщика и дизайнера, работающего в полиграфии.

В процессе верстки очень удобна система "сетов" АТМ. То есть шрифты разбиваются по группам в произвольном порядке и используются только те шрифты, которые необходимы в данный момент. Таким образом разгружается система (отключаются и True Type, лежащие в папке fonts).

РАБОТА ЗАВЕРШЕНА?

Никогда не спеши отдавать файлы, лучше проверь, все ли картинки переведены в CMYK, имеется ли папочка со всеми шрифтами, использовавшимися в публикации, нет ли в публикации ненужных рамок (которые на мониторе можно и пропустить). Для этого пригодится Markzware Flight-Check, тестовую версию которого утягивай с markzware.com, кряки в инете.

Это маленькая утилитка, которая проверяет большинство основных форматов на корректность для использования в полиграфии. Наличие незаметных волосяных рамок, файлов начертаний шрифтов, пропорциональность и эффективное разрешение картинок, их цветовую модель и наличие алгоритмов сжатия (FlightCheck тебе прямо скажет, что не стоит использовать jpeg с компрессией 35% и разрешением 72 dpi или tiff под 300 dpi, но растянутый по размеру до 400%). Трудяжка сколлектит всю публикацию и все, что должно к ней прилагаться (картинки, файлы шрифтов, файлы верстки), в отдельную папочку, и только тогда, после внимательного изучения плодов своего труда на предмет ошибок, вези материалы на фотовывод.

ФОТОВЫВОД И ФОТОФОРМЫ

Фотовывод состоит из 3 этапов. Первая и самая ответственная стадия - это RIP (raster image processor), перевод всех твоих файлов, содержащих данные совершенно разного рода, в форму, понятную ФНА (фотонаборному автомату), на котором и будут выводиться пленки.

Сперва из программы верстки с помощью драйвера принтера будут выгнаны принтфайлы, которые и поступят на интерпретацию в RIP. А уже оттуда данные, растеризованные в высоком разрешении (обычно 2400 или 2540 dpi) напрямую потекут в фотонаборный автомат, где в масштабе 1:1 лучами лазера будет засвечиваться черно-белая фотопленка, которая затем поступит в проявочную машину.

ПРИВОДНЫЕ КРЕСТЫ

Располагаются с четырех сторон или по углам печатного листа и служат для более точной приводки цветов во время печати путем совмещения крестов друг с другом. Размещенным на макете приводным крестам и меткам реза должен быть присвоен цвет Registration.

Теперь я расскажу, что тебе необходимо знать перед походом в фирму, занимающуюся выводом пленок. Прежде всего позвони туда и выясни, с какими программами и в каких версиях этих программ работает данная фирма. Если ты, к примеру, притащишь им файл, сверстанный в 10 Illustrator, а они работают максимум с 9, то тебе могут просто дать указание на 180-градусный разворот в сторону выхода. Обращаясь в препресс-бюро, лучше уже иметь разверстанный макет печатного листа. Предварительно переговори с технологом типографии, в которой ты собираешься печатать тираж, и узнай у него, каковы параметры печатной машины, формат бумаги и печатное поле листа. Во время оформления заказа тебя, скорее всего, попросят заполнить бланк, в котором нужно будет указать разрешение вывода, линиатуру и цветность.


Спецвыпуск Xakep, номер #034, стр. 034-088-6, УБЕРЕГИ CMYK ОТ RGB

УБЕРЕГИ CMYK ОТ RGB

thorus (izgondurasa@pisem.net)

Спецвыпуск Xakep, номер #034, стр. 034-088-6

Выводящие устройства бывают двух типов. Первый тип – это уже ставшие классическими фотонаборные автоматы (ФНА), второй – относительно новые, но уже прочно закрепившиеся на рынке, устройства CTP (Computer-to-Plate). Различия их состоят в том, что на ФНА сначала изготавливают ч/б фотопленки путем засветки пленки точнопозиционированными вспышками лучей лазера (по одной пленке на каждый цветовой канал, содержащийся в макете данной полосы или листа), а затем с этих пленок засвечивают светочувствительный слой на фотоформах. Те места на фотоформах, что были засвечены, отталкивают от себя краску, а незасвеченные (находившиеся под темными областями пленки), наоборот, впитывают и отдают бумаге во время печати.

Название систем Computer-to-Plate говорит само за себя. Просто из технологического процесса убрали одно звено. Сразу изготавливают печатные формы, минуя стадию вывода фотопленок и всю связанную с ними возню. Однако пленочный процесс пока крепко держится на рынке, и его нельзя недооценивать. Дело в том, что количество экземпляров, которое можно отпечатать с одной формы, ограничено, а количество форм, которые можно делать с комплекта пленок, теоретически не ограничено (естественно, при аккуратном обращении с пленками - пленки боятся царапин и перегибов).

При получении готовых пленок рекомендую отсмотреть их внимательно на предмет "потерянных" картинок, "поехавших" шрифтов и совмещения приводных крестов по каждому комплекту. Для таких целей в препресс-бюро должен иметься стол с подсветкой. Несовмещение крестов на пленках встречается очень редко. Как правило, это бывает из-за старого протяжного механизма ФНА или нестабильной работы датчиков температурного режима в проявочной машине. Я уже давно не сталкивался с несведением после вывода, но все-таки лишний час кропотливой, нудной работы стоит гораздо меньших денег и нервов, чем потеря на "запоротом" тираже.

ТИПОГРАФИЯ

Ну, вот ты и донес до типографии кропотливо отсмотренные, еще пахнущие проявителем пленочки, с которых можно печатать тираж. Какие подводные камни ожидают на подступах к завершению эпопеи? Прежде всего определись, насколько критичен цвет и необходима ли цветопроба (пробные оттиски с тех же форм, с которых будет печататься тираж). Как правило, цветопробу следует изготавливать в том же месте, где планируется печатать тираж. Ориентируясь на подписанный тобой лист цветопробы, печатник будет открывать и закрывать те самые заветные краники, из которых проистекают четыре цвета CMYK.


Спецвыпуск Xakep, номер #034, стр. 034-088-7, УБЕРЕГИ CMYK ОТ RGB

УБЕРЕГИ CMYK ОТ RGB

thorus (izgondurasa@pisem.net)

Спецвыпуск Xakep, номер #034, стр. 034-088-7

В наше время большинство типографий, работающих с коммерческими клиентами, технически оснащены достаточно хорошо, но все же прежде чем отдавать оплату за тираж, стоит поинтересоваться, на каких машинах он будет печататься и будет ли возможность присутствовать на приладке. Сразу стоит упомянуть тот факт, что большинство фирм, принимающих заказы на печать – это не более чем простые посредники. Причем зачастую даже вторые посредники. И если ты позвонил в три "типографии" и получил примерно одинаковый порядок цен, это не значит, что это та цена, которая была выставлена реальной типографией. Именно такие посредники зачастую и отказывают в праве на участие в приладке.

Не следует забывать о возможности нечестного, корыстного отношения персонала типографии (или, что еще хуже, начальства типографии) к чужим авторским правам. Недавно в одной из типографий печатался тираж альбомов художника N. Себестоимость одного изделия получалась порядка 1000 рублей. И каково же было удивление этого художника, когда он увидел в продаже свои альбомы по цене в 2,5 раза ниже себестоимости. К сожалению, подобные случаи не так уж и редки. Застраховаться от этого можно, но достаточно сложно. Увы.

ПРИЛАДКА

Ответственный, хотя и не очень долгий процесс. Заключается он в том, что печатник закрепляет на барабанах соответствующих красочных секций фотоформы, с которых будет производиться печать. Нанесение краски на поступающие в машину листы производится в той же последовательности, в которой обозначены цвета в аббревиатуре CMYK. То есть каждый лист бумаги проходит по порядку сначала секцию с голубой краской (Cyan), затем с пурпурной (Magenta) и т.д. Во время приладки у тебя есть возможность, хоть и минимально, но повлиять на цветность того, что ты печатаешь. Современные четырехкрасочные машины, управляемые электроникой, позволяют регулировать цвет зонально. Даже не цвет, а оттенок, но этот самый оттенок может кардинально изменить ощущение от работы в целом. А твой взгляд на то, как должна выглядеть работа, может основательно отличаться от взгляда печатника. Но вместе с тем стоит помнить, что цвет, который уже "поделен" во время процесса фотовывода, то есть физического цветоделения, является определяющим, и не стоит требовать от печатника невозможного.

Процесс печати на современных офсетных машинах достаточно быстрый. Тираж в 1,5 тысячи листов "выгоняется" за час-полтора, но стопу отпечатанных листов лучше не трогать около полутора суток во избежание перетискивания влажной краски на соседние листы. Иногда, в целях ускорения высыхания тиража, во время печати применяются сиккативы – специальные порошки с определенными впитывающими свойствами. Применение сиккативов не всегда уместно ввиду того, что после высыхания мелованная бумага может стать несколько шершавой на ощупь.

В процессе печати также возможна такая опциональная процедура, как УФ-лакирование. Ультрафиолетовые лаки будут очень полезны, когда ты захочешь, например, выделить какой-то фрагмент обложки издания. Краски в областях, покрытых УФ-лаком, становятся как бы глубже и ярче. Печать лаком производится как обычной краской. Лакирование может быть как полным, так и выборочным. Вслед за лакированием отпечатанные листы поступают в специальную ультрафиолетовую сушку, где происходит высыхание и фиксация нанесенного лака. После высыхания тиража производится резка, а затем опциональные послепечатные операции, такие как бигование, фальцовка, высечка, сшивка или склейка, тиснение, конгрев и переплетные работы.


Спецвыпуск Xakep, номер #034, стр. 034-088-8, УБЕРЕГИ CMYK ОТ RGB

УБЕРЕГИ CMYK ОТ RGB

thorus (izgondurasa@pisem.net)

Спецвыпуск Xakep, номер #034, стр. 034-088-8

ЗАКЛЮЧЕНИЕ

Резюмируя вышеизложенное, могу сказать только одно. Издательская деятельность, в отличие от большинства других областей приложения компьютерной техники, требует особого, пристального внимания к работе. Здесь намного сложнее и дороже обойдется исправление допущенной ошибки, чем, например, в веб-дизайне или при изготовлении трехмерной анимации. Слишком много людей, труда и денег завязано на один, казалось бы, простенький тираж тех же буклетиков или календарей. При работе с макетом будущего тиража необходимы три вещи: внимание, внимание и еще раз внимание. Успехов тебе!

КРАТКИЙ СЛОВАРЬ ПОЛИГРАФИЧЕСКИХ ТЕРМИНОВ

Биг – рубчик на картоне или бумаге, обозначающий место сгиба и облегчающий сгибание листа или обложки.

Биговка – процесс нанесения прямолинейных углублений (бигов).

Выборочный лак – избирательно лакированные участки поверхности листа. Чаще всего выборочное лакирование применяется на обложке или переплете издания для облагораживания его внешнего вида. Очень эффектно смотрится в совокупности с ламинированием. То есть сначала проводится печать обложки, затем ламинирование, затем нанесение выборочного лака и только потом сами переплетные работы. Цвет под лаком, как правило, становится глубже и сочнее.

Высечка – высекание с помощью заточенных ножей, прикрепленных к штампу, определенной макетом изделия формы. Придание отпечатанным листам бумаги формы, которой невозможно достигнуть с помощью резки (округлой, овальной и т.п.).

Кроющие краски - краски, которые, будучи нанесены на красочный слой другого цвета, не смешиваются с ним, а полностью перекрывают своим цветом. Как правило, такие краски печатаются плашкой.

Муар – регулярные растровые артефакты, возникающие вследствие выбора неправильного угла растра при печати или при репродуцировании уже печатавшегося растрового изображения.

Стохастическое растрирование – метод растрирования, заключающийся в нерегулярном расположении точек растра, их неправильной форме и различной величине. Стохастическое растрирование исключает возможность появления муара и используется, например, в таких печатных устройствах, как струйные принтеры и плоттеры.

Тиснение – изображение, которое наносится на различные материалы путем вдавливания штампа в материал при нагреве. Тиснение бывает блинтовым (от англ. blind - слепой), а также тиснение с использованием фольги и тиснение с последующим нанесением краски на вдавленные области. Тиснение, которое приподнимает изображение над поверхностью материала, называется конгрев.


Спецвыпуск Xakep, номер #034, стр. 034-088-9, УБЕРЕГИ CMYK ОТ RGB

УБЕРЕГИ CMYK ОТ RGB

thorus (izgondurasa@pisem.net)

Спецвыпуск Xakep, номер #034, стр. 034-088-9

Фальцовка – складывание, сгибание оттиска, листа бумаги или картона.

Цветность тиража – количество красок, использующихся при печати тиража. Например, если взять стандартную почтовую открытку, то она напечатана с цветностью 4+1. То есть лицевая сторона открытки запечатана в четыре краски, а оборотная - в одну.

Эффективное разрешение при работе с растровой графикой в полиграфии составляет не менее 200 dpi (dots per inch - точек на дюйм), а оптимальное – 300 dpi.

Стандартный рекомендуемый набор "рабочих" программ: Adobe Photoshop (любой версии), Adobe Illustrator 9, Adobe Type Manager 4, Quark-XPress 4.11 Cyrillic Enable и Markzware Flightcheck.

Треппинг - в допечатной подготовке это способ компенсации неприводки красок при печати путем увеличения областей перекрытия соседствующих красок.

Registration - специальный цвет, присваивающийся служебным элементам. Например, приводные кресты и обрезные метки, которым присвоен цвет Registration, после цветоделения будут присутствовать на пленке каждого поделенного цвета.

Метки реза - служебные метки, по которым после окончания процесса печати должна производиться резка тиража. Пространство, условно находящееся внутри обрезных меток, называется обрезным форматом.

Увидев выворотку мелким шрифтом при цвете фона более одной краски или примерно такой составной черный - C-100, M-100, Y-100, K-100, технологи и печатники типографии справедливо не постесняются в выражениях в твой адрес :).

Технологи типографий и печатники, как правило, не любят браться за сложные, технологически необычные заказы, поэтому, если печатник тебе скажет, что осуществить твою задумку невозможно - знай, что это верно лишь процентов на сорок.

Офсетная печать – способ печати, где формой является пластиковая или металлическая пластина, на которой печатающие элементы воспринимают краску, а пробельные ее отталкивают.


Спецвыпуск Xakep, номер #034, стр. 034-094-1, ЭЛЕКТРОННЫЕ ЧЕРНИЛА

ЭЛЕКТРОННЫЕ ЧЕРНИЛА

Олег "2sheds" Курапов

Спецвыпуск Xakep, номер #034, стр. 034-094-1

(ok@2sheds.ru)

Технология и применение

Tablet PC называли современной заменой блокнота и карандаша, но рекламные лозунги не приблизили эту платформу к заветной цели. Трудно сравнивать громоздкую машину, напичканную дорогой электроникой, с копеечным блоком бумажных листков, который можно со спокойным сердцем мять и ронять.

При этом не надо загружать, заряжать, включать, выключать, защищать от вирусов и переустанавливать на нем упавший за 3 часа до важной встречи сами-знаете-что. "Блокнот совершил недопустимую ошибку и будет свернут", ага. Вообще, идея создания принципиально нового медианосителя бродила в умах ученых и инженеров не один десяток лет - задолго до выхода в свет Windows XP Tablet Edition. По замыслу разработчиков, он должен обладать такими традиционно "бумажными" качествами, как дешевизна, простота использования, малые габариты и (относительная) энергонезависимость. Но, в то же время, иметь и чисто "компьютерные" преимущества, вроде возможности редактирования, копирования и передачи данных, а также индексирования и поиска информации - и даже если что-то из этого списка доступно для бумажных технологий (ведь ластики, факсы и копиры пока никто не отменял), то все равно ясно, что электронный вариант хранения данных позволяет перевести эти понятия на качественно новый уровень. Эту технологию назвали электронными чернилами (или электронной бумагой - оба названия применяются одинаково широко), и кое-какие результаты мы увидим уже очень скоро - возможно, в ближайшие год-два.

Впрочем, пока рано переставлять фантастику на полку с надписью "Соцреализм" - обмакнуть электронную ручку в электронные чернила мы сможем лишь через несколько лет - они до сих пор не покидают стены лабораторий. В данном случае стоит говорить скорее о воплощении концепции "электронной бумаги", ведь основным предназначением устройств, о которых пойдет речь, является только вывод, но не ввод информации.

КОНКУРИРУЮЩИЕ КОНЦЕССИИ

Электронные чернила - это тебе не дедушка Ленин, наливавший молоко в хлебный мякиш, тут не только ноу-хау, но и большие деньги нужны. Потому-то и игроков на этом рынке – раз-два и обчелся: Gyricon Media и E Ink Corporation. Первая компания была образована на базе легендарного исследовательского центра PARC и сотрудничает с 3M, а вторая вышла из стен MIT Media Lab, и ее стратегическими партнерами являются Philips и Lucent на пару с Bell Labs.

Smart Paper (Gyricon Media, www.gyriconmedia.com)

Идея, лежащая в основе Smart Paper, была предложена еще в 1975 году физиком из PARC (Palo Alto Research Center - впрочем, тогда он еще носил имя Xerox) по имени Ник Шеридон (Nick Sheridon) в качестве замены громоздким и низкокачественным ЭЛТ-мониторам тех времен: "Зачем заменять бумагу мониторами, лучше заменить мониторы бумагой". Суть его предложения заключалась в том, чтобы заключить между слоями тонкого пластика множество разноцветных мельчайших бусинок и заставить их поворачиваться под действием электрического тока, формируя таким образом изображение. Изобретение свое он назвал "Gyricon" (лат. gyro - вращаться).


Спецвыпуск Xakep, номер #034, стр. 034-094-2, ЭЛЕКТРОННЫЕ ЧЕРНИЛА

ЭЛЕКТРОННЫЕ ЧЕРНИЛА

Олег "2sheds" Курапов

Спецвыпуск Xakep, номер #034, стр. 034-094-2

Первоначально планировалось закончить разработку к 1985 году, но на пути исследователей возник ряд проблем, неразрешимых при тогдашнем уровне развития техники. К примеру, печатные платы были хрупкими, твердыми и довольно дорогими, а потому на замену бумаге не годились в принципе. Более того, даже создание достаточно однородных "бусин" оказалось непростой задачей. Первый получившийся прототип был настолько далек от изначально задуманного Шеридоном, что он решил отложить работу над Gyricon’ом до лучших времен.

Лучшие времена настали в середине 90-х, когда ему, наконец, удалось наладить производство абсолютно идентичных сферических частиц. А открытия конца 90-х, например, токопроводящий пластик и электронные схемы, которые можно печатать прямо на листы этого самого пластика на специальных принтерах, позволили перейти к созданию реальных продуктов. В итоге, более чем через 20 лет после начала работ, была образована компания Gyricon Media.

Принцип работы "умной бумаги" довольно прост. Между двумя тонкими листами гибкого пластика, покрытого матрицей электродов, в маслянистой жидкости, снижающей трение, находятся микроскопические частицы (диаметром 100 микрон, то есть меньше крупицы речного песка), распределенные тонким слоем по отдельным ячейкам. Каждая из частиц представляет собой сферу, половины которой окрашены в один из двух цветов, например, белый и черный. Полусферы также имеют противоположный электрический заряд, а потому под воздействием слабых электрических импульсов шарики могут вращаться в своих ячейках, соответственно представляя собой закрашенный или пустой пиксел. При подаче напряжения, превышающего некоторое пороговое значение (через встроенные в ряды ячеек электроды или с помощью специального электростатического стилуса), на поверхности формируется изображение. После этого физические силы, действующие внутри системы, фиксируют изображение, причем его поддержание не требует энергозатрат, а потому оно остается неизменным в течение неограниченного времени, до тех пор, пока не будет подан следующий импульс. Более того, сила тока, необходимая для работы экрана, минимальна, важна лишь разность потенциалов (около 100 В), благодаря чему электропотребление действительно мизерное. Как написано в FAQ на сайте компании, матрице Smart Paper средних размеров достаточно трех батареек типа AA для работы в течение двух лет!

E-Ink (E Ink Corporation, www.eink.com)

В середине 90-х годов прошлого века, когда Ник Шеридон вернулся к разработке своей "умной бумаги", эта идея захватила и еще одного специалиста, Джозефа Якобсона, который в то время работал в другом крупном центре американской науки, Массачусетском технологическом институте. Он также разработал свой собственный способ создания идентичных микрочастиц, но использовал несколько иной метод формирования изображения.

В отличие от предыдущей разработки, здесь ничто никак не вращается - физические силы действуют не на сами частицы чернил, а внутри них. Впрочем, хотя этот принцип несколько сложнее для понимания, изучать законы и теоремы не потребуется, все можно объяснить и на пальцах. Типа, вот тут стоит куча хитрых штуковин, и внутри них происходят чиста конкретные взаимодействия, из-за которых они то чернеют, то белеют - короче, ты понял, полный electrophoresis, и медицина здесь бессильна :). Ну, а если серьезно, то в матрицах от E-Ink процесс тоже происходит за счет действия внешнего электрического поля на микрокапсулы, расположенные в ячейках на пластиковой подложке. Разница в том, что сами эти капсулы заполнены жидкостью, содержащей взвесь из еще более мелких субчастиц черного и белого цвета, обладающих противоположным зарядом. Они притягиваются к разным сторонам своего миниатюрного контейнера при пропускании электрического тока через электроды, проложенные сверху и снизу ячеек. Это и вызывает окрашивание соответствующего пиксела.


Спецвыпуск Xakep, номер #034, стр. 034-094-3, ЭЛЕКТРОННЫЕ ЧЕРНИЛА

ЭЛЕКТРОННЫЕ ЧЕРНИЛА

Олег "2sheds" Курапов

Спецвыпуск Xakep, номер #034, стр. 034-094-3

Особенностью этой технологии является возможность адресации на более низком уровне, чем в Smart paper, где каждая бусина может занимать только два положения, тогда как в E-Ink с помощью параметров подаваемого на электроды сигнала можно регулировать количество притягиваемых субчастиц. Так же, как и у Smart Paper, полученное изображение остается стабильным сколь угодно долго. Благодаря этому первый продукт компании, большая информационная панель Immedia, согласно спецификации, потребляет лишь 0,1 Вт электроэнергии.

Преимущества:

– высокое качество изображения;

– низкая стоимость;

– низкое энергопотребление;

– небольшой вес;

– структурная гибкость;

– интеграция с беспроводными технологиями.

Недостатки:

– современные батареи и аккумуляторы не позволяют сделать электронную бумагу действительно легкой, компактной и гибкой;

– отсутствие широкой поддержки со стороны производителей, многие предпочитают улучшать ЖК-технологии;

– возможна конкуренция со стороны OLED-дисплеев, еще одной перспективной разработки;

– трудно разрушить стереотипы и изменить привычки;

– обычная бумага сама по себе не так уж плоха;

– неясность в плане возможности переработки и утилизации.

ИМЕЮЩИЕСЯ НА РЫНКЕ ПРОДУКТЫ

Первой областью применения электронной бумаги на практике стала торговля, а именно - электронные панели, оперативно сообщающие покупателям о специальных предложениях, скидках и тому подобном. Фактически, они и остаются единственными реальными примерами использования технологии. У Gyricon это SmartSign, а у E Ink - панели Immedia и Ink-in-Motion, последние отличаются возможностью отображения "бегущей строки", мерцающего текста и прочих базовых эффектов анимации.

Но если Gyricon вполне довольна своей нишей на рынке, то у E Ink следующими на очереди стоят "бумажные" дисплеи для мобильных устройств, в первую очередь сотовых телефонов. Компания называет это приоритетным направлением своего развития, а Philips и Motorola планируют перейти к выпуску моделей на их основе уже к концу 2003 года. Но, несмотря на первые результаты, электронная бумага до сих пор продолжает оставаться технологией будущего, а значит, стоит туда заглянуть, чтобы понять, что готовят для нас разработчики.


Спецвыпуск Xakep, номер #034, стр. 034-094-4, ЭЛЕКТРОННЫЕ ЧЕРНИЛА

ЭЛЕКТРОННЫЕ ЧЕРНИЛА

Олег "2sheds" Курапов

Спецвыпуск Xakep, номер #034, стр. 034-094-4

ВАРИАНТЫ ПРИМЕНЕНИЯ

Потенциально электронную бумагу можно использовать едва ли не везде, где и обычную. Перечислить все варианты невозможно, да и не нужно - человеческая фантазия безгранична - так что ограничусь наиболее интересными направлениями.

КНИГИ И ГАЗЕТЫ

Издательский бизнес является, безусловно, самым очевидным применением для электронной бумаги, соединяя опыт многих поколений книгопечатников с последними достижениями науки. И хотя традиционные книги, в отличие от музыкальных записей, пока не испытывают угрозы со стороны компьютерных форматов, но многие специалисты объясняют относительное затишье на этом рынке отсутствием подходящего устройства для чтения электронных текстов. Ни Rocket Reader, ни eBookMan, и уж тем более ни одна модель КПК с их миниатюрными экранами не устраивают среднестатистического любителя печатного слова. Пока только ярые приверженцы новых технологий способны привыкнуть или смириться с ограничениями этих платформ, предпочитая дорогие гаджеты обычным книгам. Возможно, что именно устройства, созданные на базе электронной бумаги, смогут стать для издателей такой же серебряной пулей, как и mp3/CD-плееры для звукозаписывающей индустрии.

Не так давно в компьютерной прессе сообщалось о прототипе электронной книги, представленном Philips. Возможно, что это первый шаг на пути к созданию RadioPaper - честолюбивого плана компании E Ink, "газеты будущего", которая будет ежедневно получать свои тексты из беспроводного эфира. Еще один инвестор, крупнейший издательский холдинг Gannett, выпускающий 110 ежедневных газет, в том числе USA Today, заявляет о своих планах начать выпуск подобных устройств уже через два-три года.

ОФИСНЫЕ ТЕХНОЛОГИИ

Современный офис постоянно потребляет огромное количество бумаги, и внедрение компьютеров ничуть не уменьшило ее количество, скорее наоборот, оргтехника плодит все новые и новые экземпляры различных документов. Осознание этой проблемы привело деловые круги к идее "безбумажного офиса", заключающегося в переходе к полностью электронному документообороту.

И хотя число приверженцев этой концепции постоянно увеличивается, не менее часто можно услышать высказывания вроде "безбумажный офис настолько же реален, как и безбумажный туалет". Все же компьютерный, и тем более Web-интерфейс не настолько удобен, что приводит к снижению производительности и другим проблемам. Появление электронных заменителей традиционного листа А4 может дать положительные результаты без применения столь радикальных мер.

ОБРАЗОВАНИЕ

Еще одно непаханое поле - школьное, высшее и профессиональное образование - предоставляют столько возможностей для использования электронных чернил и бумаги, что даже беглый обзор потянет на отдельную статью, но летом, в пору отпусков и каникул, об этом даже думать не хочется. Тем более что большинству наших вузов эти технологии все равно не грозят. А жаль...

НЕТ, СЫНОК, ЭТО ФАНТАСТИКА!

За необычными вариантами применения далеко ходить не надо, фантасты уже столько нафантазировали, что впору регистрировать их идеи оптом, пока не опередили другие.


Спецвыпуск Xakep, номер #034, стр. 034-094-5, ЭЛЕКТРОННЫЕ ЧЕРНИЛА

ЭЛЕКТРОННЫЕ ЧЕРНИЛА

Олег "2sheds" Курапов

Спецвыпуск Xakep, номер #034, стр. 034-094-5

Вот пример, патентное ведомство США в 2001 году выдало патент США №6,192,890 от 27.02.2001, "Нанесение татуировок с изменяющимися под воздействием электричества изображениями методом инъекции микрокапсул или микрочастиц размером 30-150 микрон..." - знакомо, не правда ли? По сравнению с этим идеи создания молодежных коллекций одежды с динамическими вставками из электронной бумаги кажутся чем-то само собой разумеющимся, все это мы уже двадцать раз видели. Даешь экраны во всю стену, как у Арнольда в фильме "Вспомнить все"!

ПЕРСПЕКТИВЫ

Прежде чем электронная бумага займет свое место в отделах канцелярских товаров, пройдет еще не один год. Но, как мне кажется, даже если в 2010 году мы еще не будем читать свою RadioPaper за завтраком, шансы у нее все равно очень велики. Во-первых, она уже прошла испытание временем, а значит, есть надежда, что выдержит и еще лет пять-десять, пока будут совершенствоваться технологии и утрясаться стандарты. А дальше...

Не секрет, что любой магазин тратит огромные средства на постоянную перемаркировку этикеток, ценников и т.п. Ведь не случайно именно крупные американские магазины стали первыми, кто заказал у Gyricon и E Ink их продукцию. И хотя даже у нас во многих супермаркетах концентрация плазменных и ЖК-панелей на квадратный метр уже зашкаливает, к каждому йогурту дисплей не приставишь, а потому замена традиционным технологиям пока не найдена.

Но в дальнейшем применение ценников из электронной бумаги, подключенных к центральной сети магазина, позволит не только снизить затраты торговцев (за счет экономии заработной платы, оборудования и расходных материалов), но и сможет спровоцировать лавинообразное падение цен на эти дисплеи. Заказы от крупных торговых сетей, в филиалах которых продаются миллионы наименований товаров, обеспечат этому рынку немыслимые обороты.

Лицензирование технологий откроет двери на этот рынок для компаний по всему миру, а они, в свою очередь, вынуждены будут конкурировать не только между собой, но и с традиционными целлюлозно-бумажными комбинатами, а конкуренция - это всегда снижение цены и повышение качества. Кроме того, уже сейчас говорится о том, что применение пластиковых транзисторов от Lucent позволит снизить затраты на создание такой фабрики с миллиардов до миллионов долларов, что еще сильнее подстегнет борьбу за потребителя.

В конце концов, электронная бумага должна перейти из разряда высокотехнологичных устройств в категорию расходных материалов, что откроет ей дорогу к массовому потребителю и еще больше новых вариантов использования. И главное - возможно, это поможет нам спасти наши леса от вырубки и Байкал от загрязнения!

Обмакнуть электронную ручку в электронные чернила мы сможем лишь через несколько лет...

Между двумя тонкими листами гибкого пластика, покрытого матрицей электродов, в маслянистой жидкости, снижающей трение, находятся микроскопические частицы.

RadioPaper - "газета будущего", которая будет ежедневно получать свои тексты из беспроводного эфира.


Спецвыпуск Xakep, номер #034, стр. 034-094-6, ЭЛЕКТРОННЫЕ ЧЕРНИЛА

ЭЛЕКТРОННЫЕ ЧЕРНИЛА

Олег "2sheds" Курапов

Спецвыпуск Xakep, номер #034, стр. 034-094-6

И главное - возможно, это поможет нам спасти наши леса от вырубки и Байкал от загрязнения!


Спецвыпуск Xakep, номер #034, стр. 034-098-1, DИСКИ VЫСОКИХ DОСТОИНСТВ

DИСКИ VЫСОКИХ DОСТОИНСТВ

Берд Киви (kiwi@computerra.ru)

Спецвыпуск Xakep, номер #034, стр. 034-098-1

Прошлое, настоящее и будущее технологий DVD

На сегодняшний день DVD является стремительно развивающейся, набирающей все большую популярность технологией оптического хранения информации. Такой успех легко объяснить, поскольку DVDиск имеет тот же самый физический размер, что и привычный CD, читается заметно быстрее и обладает намного большей емкостью.

Это позволяет хранить и ресурсоемкие видеофайлы, и качественные аудиозаписи, и большие массивы компьютерных данных (от 4,7 Гб в однослойном одностороннем варианте до 17 Гб в двухслойном двустороннем варианте носителя). Аббревиатуру-логотип DVD сейчас принято расшифровывать как Digital Versatile Disc, то есть "универсальный цифровой диск". Хотя изначально подразумевалось Digital Video Disc, а на какой-либо официальной окончательной трактовке компетентные органы так и не сошлись, договорившись именовать технологию просто "DVD".

Благодаря универсальности DVD все чаще именуют "средой конвергенции" (т.е. "сближения", от латинского convergere - сходиться), благо технология удачно сочетает в себе качества, необходимые как для сферы домашних развлечений, так и для функций компьютерного накопителя информации. Поэтому предполагается, что со временем DVD сможет заменить CD-ROM и музыкальные CD, видеокассеты и лазерные видеодиски, а заодно и картриджи для игровых видеоприставок. Появившись в 1997, уже в начале 2001 года технология DVD имела поддержку всех ведущих фирм бытовой электроники, всех основных компьютерных компаний, всех головных киностудий и фирм звукозаписи. Благодаря беспрецедентному уровню одобрения технология DVD уже успела войти в историю как наиболее успешный продукт электронной индустрии, набравший рекордную популярность в массах всего за три года.

Несмотря на столь грандиозный успех (а может, как его следствие), вхождение DVD в повседневную жизнь сопровождается и множеством непростых проблем, связанных, прежде всего, с очень большим разнообразием плохо совмещающихся друг с другом форматов. С одной стороны, есть вполне естественное различие между дисками DVD-Video, предназначенными просто для просмотра кинофильмов с помощью плеера или телевизора, и дисками-накопителями DVD-ROM для компьютерных приводов. Понятно, что компьютер способен воспроизводить и DVD-Video, подобно тому, как привод CD-ROM способен воспринимать и аудио CD. Однако когда речь заходит не о штампованных на заводе, а о самостоятельно записываемых дисках DVD, сразу всплывают, по меньшей мере, шесть различных форматов конкурирующих друг с другом фирм и групп компаний: DVD-R Authoring, DVD-R General, DVD-RAM, DVD-RW, DVD+RW и DVD+R. Весьма похожая, хотя и не столь драматичная ситуация, сложилась и с несовместимыми форматами для музыкальных записей DVD-Audio и Super Audio CD (SACD).

Почему так вышло и, самое главное, что делать в подобной ситуации, когда покупка техники и запись DVD сопряжены с решением весьма серьезных проблем совместимости? То есть проблем, чреватых нечитабельностью приобретаемых или записываемых дисков. Разбору этих и других вопросов посвящена эта статья. Ну, а подробно обо всех аспектах технологии DVD можно почитать в ежемесячно обновляемом DVD FAQ Джима Тейлора (http://dvddemystified.com/dvdfaq.html), скромно именуемом "самым достоверным источником информации о DVD в этой галактике". Но, к сожалению, ресурс на английском языке. Краткий русскоязычный аналог - PC-DVD FAQ Командного & Кузина (www.3dnews.ru/storage/dvd), в основном упор делается на компьютерные аспекты технологии. А содержательный обзор "кинотеатральных" сторон DVD смотри на www.goldenear.ru/faq.html.


Спецвыпуск Xakep, номер #034, стр. 034-098-2, DИСКИ VЫСОКИХ DОСТОИНСТВ

DИСКИ VЫСОКИХ DОСТОИНСТВ

Берд Киви (kiwi@computerra.ru)

Спецвыпуск Xakep, номер #034, стр. 034-098-2

ТРУДНОЕ ДЕТСТВО

Комплекс технологий DVD является плодом совместного творчества множества компаний. К середине 1990-х годов, когда встал вопрос о создании нового, более емкого стандарта на оптический диск, имелось два конкурирующих предложения: формат MMCD от Sony, Philips и ряда других фирм; и формат SD, который поддерживали Toshiba, Matsushita и Time Warner со своими союзниками. Лишь благодаря вмешательству и настойчивости компьютерных фирм во главе с IBM, удалось склонить противоборствующие лагери к выработке единого стандарта и не допустить повторения неприятнейшей истории 1970-х годов с долгой войной несовместимых видеокассет VHS и Betamax. Новый единый формат оптодиска, объединивший в себе черты MMCD и SD, получил название DVD и был впервые представлен миру в сентябре 1995 года. Спецификации формата были разработаны консорциумом из 10 компаний: Hitachi, JVC, Matsushita, Mitsubishi, Philips, Pioneer, Sony, Thomson, Time Warner и Toshiba. Заметный вклад внесли представители и многих других фирм, участвуя в рабочих группах, занятых конкретными разделами спецификаций.

Поскольку у технологии нет единого владельца, в мае 1997 года на смену исходному консорциуму пришла более серьезная организация - DVD Forum (www.dvdforum.org), открытая для всех компаний и объединяющая сегодня свыше 200 членов. Она ведает лицензированием и развитием спецификаций DVD. Фактически же формат DVD контролируется целой армией фирм-гигантов из Японии, США и Европы, а значит, всем им каждый производитель DVD-плееров должен платить лицензионные отчисления с каждого девайса, плюс отдельные выплаты за звук Dolby, плюс компании MPEG LA за видеоформат MPEG-2... В общей сложности отчисления со всякого собранного устройства составляют до 20 долларов, а если учесть, что стоимость китайского плеера составляет около 70 долларов, то сумма поборов многим представляется, мягко говоря, завышенной. Как следствие, в индустрии начинают зреть мятежи недовольных.

ЛИКИ DVD

О том, что на пути технологии к успеху далеко не все было радужно и благополучно с самого начала, свидетельствуют шутливые расшифровки аббревиатуры:

Dead, Very Dead (мертвая, совсем мертвая) - от злопыхателей, предсказывавших, что DVD никогда не суждено обрести популярность;

Digital Venereal Disease (цифровое венерическое заболевание) - намек на неминуемую угрозу эпидемии пиратства и бесконтрольного копирования фильмов в цифровом формате;

Delayed, Very Delayed (задержавшаяся, очень задержавшаяся) - о сильном притормаживании голливудских кинокомпаний с выпуском кассовых фильмов на DVD из-за страха перед пиратством;


Спецвыпуск Xakep, номер #034, стр. 034-098-3, DИСКИ VЫСОКИХ DОСТОИНСТВ

DИСКИ VЫСОКИХ DОСТОИНСТВ

Берд Киви (kiwi@computerra.ru)

Спецвыпуск Xakep, номер #034, стр. 034-098-3

Diversified, Very Diversified (разнообразная, слишком разнообразная) - о распространении множества несовместимых форматов записи и других разновидностей технологии.

На фоне всех этих проблем нынешний успех DVD впечатляет настолько, что всерьез оспаривать его не берется уже никто.

DVD-AUDIO ПРОТИВ SUPER AUDIO CD

Начиная "великого раскола" 1999 года за право стать стандартом аудиозаписи нового поколения спорят две технологии - DVD-Audio от Matsushita и SACD от Sony.

Первый из претендентов, DVD-Audio, в своих характеристиках частично пересекается с DVD-Video, что вполне естественно, так как в основу аудиоформата заложены те же принципы, что и при записи звуковой дорожки DVD-фильмов. Это, прежде всего, преобразование сигнала по методу PCM, правда, с более высокой разрядностью (до 24 бит) и частотой дискретизации до 96 кГц для многоканальной записи (5.1) и до 192 кГц для стерео. Употребление "до" отмечает гибкость этого формата в отличие от старого Audio CD, где качественные параметры жестко закреплены на 16 битах и 44,1 килогерцах. Благодаря гибкости обеспечивается часто необходимый компромисс между количеством и качеством треков. Кроме несжатого PCM, формат допускает сжатие с потерями в форматах Dolby Digital и DTS. Немаловажное преимущество дисков DVD-Audio в том, что они воспроизводятся не только на внешних плеерах, но и на компьютере с любым современным DVD-ROM-приводом и современной ОС (Windows 2000 или Windows XP). На дисках с DVD-Audio нередко бывает участок, совместимый с DVD-Video, где записываются видеоклипы или звук в DD/DTS-форматах.

Альтернативный формат, Super Audio CD, изначально был разработан специалистами Sony Music для спасения музыкального архива, где магнитные мастер-ленты со временем теряют свои свойства и постепенно разрушаются. Технология кодирования DSD (Direct Stream Digital) задумывалась исключительно как профессиональный метод записи и хранения информации, однако, оценив перспективы разработки, руководство Sony решило посоветоваться с Philips. В итоге было принято совместное решение о внедрении DSD в бытовую технику в виде формата SACD, идущего на замену Audio CD, когда-то порожденного этими же фирмами. Конструктивно диск SACD идентичен DVD: здесь тот же размер питов и та же плотность размещения на дорожке, такая же оптика для чтения и 4,7 Гб полезной емкости. Но при этом, несмотря на физическую совместимость с DVD, на уровне кодирования аудиоданных SACD не имеет с DVD-Audio ничего общего, так как метод оцифровки звука DSD совершенно иной - с минимальной разрядностью в один бит и очень высокой частотой сэмплирования 2,8224 МГц. Кроме того, технология предусматривает гибридные диски, которые могут читаться и CD-приводами, для чего создается дополнительный отражающий слой. На CD-плеере, естественно, музыка с SACD звучит в прежнем качестве Audio CD.

Противоборство конкурирующих форматов продолжается, каждый из "зачинщиков" стремится привлечь на свою сторону как можно больше производителей аппаратуры и звукозаписывающих компаний. Однако "схватки насмерть" все равно не получается, коль скоро принципиальной несовместимости между стандартами все же нет, и некоторые микросхемы/проигрыватели уже сейчас декодируют и воспроизводят диски обоих видов. И раз об окончательной победе одного из форматов речи пока не идет, то покупка именно универсального аппарата будет самым дальновидным шагом в подобной ситуации. Хотя бы потому, что одних популярных исполнителей издают на SACD, а других на DVD-Audio.


Спецвыпуск Xakep, номер #034, стр. 034-098-4, DИСКИ VЫСОКИХ DОСТОИНСТВ

DИСКИ VЫСОКИХ DОСТОИНСТВ

Берд Киви (kiwi@computerra.ru)

Спецвыпуск Xakep, номер #034, стр. 034-098-4

ПРОСТО КИНО

Сравнительно долгое время наши не слишком состоятельные граждане могли приобщиться к радостям DVD в основном посредством приобретения привода DVD-ROM, стоившего, как всякая средняя писишная железяка, порядка сотни долларов. Но за последний год ситуация с DVD менялась столь стремительно, что радикально подешевело все - от болванок и пиратских дисков до плееров. Цены на последние, с подачи славной китайской фирмы BBK Electronics, опустились аж до заветной сотни долларов (столько же, сколько приводы), а стоимость домашнего кинотеатра, то есть плеера в комплекте с многоканальной акустической системой, начинается где-то от 260 долларов.

Поэтому любому человеку, считающему видеоплеер полезной и нужной вещью в доме, уже явно пора переходить с VHS на DVD. Просто потому, что эта технология превосходит видеокассеты практически по всем параметрам. Если говорить о качестве картинки, то разрешающая способность кадра DVD-Video 720х576 пикселов (у VHS в два раза хуже - 352х576). Важнейший фактор - отсутствие помех, здесь преимущества цифровой записи DVD в сравнении с видеокассетами VHS примерно такие же, как у AudioCD перед виниловыми пластинками. Произвольный доступ: как и с CD, вставив диск в плеер или компьютер, через меню на экране можно сразу перейти к нужному эпизоду. Немаловажна и долговечность. Ведь аналоговая запись на магнитной ленте довольно быстро (за несколько лет) начинает портиться, носитель сохнет, крошится, изнашивается и размагничивается. Время же эксплуатации оптических дисков намного больше и составляет, согласно оценкам специалистов, по меньшей мере, сотню лет (при аккуратном хранении, естественно). Плюс общедоступность и низкие начальные цены плееров и компьютерных приводов (от 35 долларов).

При выборе DVD-плеера в одной ценовой категории самым главным параметром является, очевидно, многофункциональность. Под этим понимается возможность воспроизведения не только дисков DVD, но также CD-R/RW и поддержка различных мультимедиа-форматов, таких как Super VCD, VCD, Audio CD, mp3, HDCD, Kodak Picture CD, JPEG. Короче говоря, имеет смысл покупать такой плеер, чтобы он не только кино воспроизводил, но и качественную музыку, и слайд-шоу из домашних фотоальбомов на экране телевизора и т.п.

На сегодняшний день уже нельзя сказать, что компьютерный вариант DVD-кинотеатра (привод DVD-ROM плюс многоканальная звуковая карта с комплектом акустики, плюс, если не хватает собственной мощности ПК, добавочная плата-декодер, вроде REALmagic Hollywood Plus) оказывается экономически выгоднее, чем покупка домашнего кинотеатра. Однако компьютер, помимо радостей просмотра DVD-фильмов, предоставляет и доступ к массе других возможностей технологии - от копирования и редактирования видеозаписей до изготовления собственных DVD-дисков.


Спецвыпуск Xakep, номер #034, стр. 034-098-5, DИСКИ VЫСОКИХ DОСТОИНСТВ

DИСКИ VЫСОКИХ DОСТОИНСТВ

Берд Киви (kiwi@computerra.ru)

Спецвыпуск Xakep, номер #034, стр. 034-098-5

СМОТРИМ DVD НА PC

CyberLink PowerDVD (www.gocyberlink.com/english/products/product_main.jsp?ProdId=28)

Один из лучших, а потому и самый популярный проигрыватель. Обеспечивает прекрасное воспроизведение картинки и звука, поддерживает многие популярные форматы, включая mp3, AC3, QuickTime и музыкальные CD. Недостаток (сегодня уже не столь критичный) - PowerDVD весьма требователен к производительности компьютера.

InterVideo WinDVD (www.intervideo.com/jsp/Products.jsp)

Еще один прекрасный проигрыватель. Среди "фирменных фишек" следует упомянуть продвинутые возможности захвата кадров из фильма, а также любопытную функцию Time Stretching, позволяющую ускорять (до 200%) или замедлять (до 50%) воспроизведение, сохраняя при этом звуковое сопровождение. Еще один существенный нюанс - интерфейс с поддержкой русского языка.

DirectDVD (www.orionstudios.com/DirectDVD.html)

Уникальную особенность данной программе придают функции переноса звуковой дорожки фильма в файл формата mp3. Звуковой составляющей DVD здесь вообще уделено повышенное внимание - проигрыватель оснащен эквалайзером и анализатором спектра. Впрочем, и качество картинки обеспечивается здесь не хуже, чем у других плееров.

Все перечисленные программы являются либо условно бесплатными, либо коммерческими. Однако в интернете сравнительно несложно найти полные, так называемые retail-версии множества самых разных программных плееров-декодеров из тех, что идут в комплекте на диске к DVD-приводу. Один из самых содержательных ресурсов подобного рода - www.dvd.da.ru.

ЗАМКИ, КЛЮЧИ И ОТМЫЧКИ

Очень высокое качество видео на DVD и принципиальная возможность его несанкционированного копирования "бит в бит" без потери качества с самого начала были главной головной болью киностудий, приложивших максимум усилий для надежной защиты контента на диске. Правда, когда речь зашла о криптографической защите файлов, то есть о шифровании, в действие вступили аргументы совсем иного, политического рода. В частности, действующие в США, Японии и Западной Европе серьезные экспортные ограничения на сильную криптографию, приравненную к стратегическому оружию. В итоге общая защита DVD получилась намного слабее, чем планировалось, и вся ее стойкость свелась к секретности используемых алгоритмов. Как только алгоритмы со временем стали известны, защита стала сугубо условной.

РЕГИОНАЛЬНЫЕ КОДЫ

Самая искусственная мера, введенная исключительно для обеспечения сверхприбылей киноиндустрии, желающей полностью контролировать сроки появления новых фильмов в разных регионах планеты. Считается, что если картина уже вышла на DVD в США, а где-нибудь в Азии еще не добралась до экранов кинотеатров, то это серьезно снижает общие кассовые сборы. А значит, DVD-фильм из Америки не должен проигрываться на плеерах, купленных в Европе, Африке или Китае. Для чего и введены региональные коды: 1 для Северной Америки, 2 для Европы и Японии, 5 для стран СНГ, ну и так далее. Эта задумка Голливуда, естественно, стала и для электронной-то индустрии обременительной, а уж для покупателей-зрителей DVD полным идиотизмом. Поэтому очень быстро появились средства для модификации соответствующих микросхем в плеерах и DVD-приводах, делающие проигрыватель всерегионным. Причем во многих странах, не только в России или в Азии, но и в законопослушной Европе, мультирегионная прошивка плееров нередко делается уже на этапе предпродажной подготовки товара, поскольку так торговля идет намного эффективнее :). Подробную информацию о трансформации плееров в мультирегионный режим смотри на www.uni-electronics.newmail.ru/dvd_upg.html, а относительно перепрошивки DVD-приводов большой инфоресурс имеется на http://forum.rpc1.org/portal.php. Для снятия региональной защиты в компьютере на программном уровне существуют разные утилиты, например DVD Genie (www.inmatrix.com/genie) и DVD Region Killer (www.3dnews.ru/download/dvd/dvdregionkiller). Имеется также программа DVD Region-Free (www.dvdidle.com/dvd-region-free.htm), позволяющая смотреть DVD любого региона вообще без перепрограммирования флеш-памяти привода.


Спецвыпуск Xakep, номер #034, стр. 034-098-6, DИСКИ VЫСОКИХ DОСТОИНСТВ

DИСКИ VЫСОКИХ DОСТОИНСТВ

Берд Киви (kiwi@computerra.ru)

Спецвыпуск Xakep, номер #034, стр. 034-098-6

ЗАЩИТА ОТ КОПИРОВАНИЯ MACROVISION

Изначально фирма Macrovision создала технологию защиты от перезаписи видеокассет VHS, которую затем доработала для цифровых систем. Суть защиты в искусственном ухудшении качества сигнала за счет существующих различий в работе ТВ и видеомагнитофона. В результате манипуляций телевизор показывает картинку еще правильно, а вот видеомагнитофон корректно записать ее уже не может, так как копии становятся заметно более тусклыми и содержат различные помехи в цвете и "полосатости" кадров. Понятно, что это проблема для тех, кто пытается записать DVD-фильм через аналоговый выход на видеокассету. Существует множество недорогих устройств, устраняющих защиту Macrovision и известных под названиями типа Video Clarifier, Image Stabilizer, Color Corrector и CopyMaster (www.videoguys.com/sima.htm). Умельцы могут изготовить и свою собственную схему, смотри http://66.40.78.100/Services/TECH_Notes/nineteen.html. В ПК то же самое делают многие программы преодоления кода региона, к примеру, DVD Region Killer.

СИСТЕМА ШИФРОВАНИЯ CSS

Для предотвращения переноса фильма с диска DVD-Video на жесткий диск компьютера (откуда его несложно копировать как угодно и на что угодно), используется система шифрования CSS или Content Scrambling System. Суть ее примерно в следующем. Плеер любой компании, будь то аппарат от Sony или программа типа WinDVD, имеет свой собственный "фирменный" ключ доступа к DVD-диску, именуемый ключом плеера. Всего существует 409 таких ключей, а на каждом DVD-диске, в свою очередь, содержится уникальный 5-байтный (40 бит) ключ диска, зашифрованный каждым из 409 ключей плеера. Другими словами, имеется 409 ячеек, в каждой из которых лежит ключ диска, который соответствующий программный или аппаратный плеер может расшифровать, благо всякому владельцу лицензии (производителю плеера) известен свой номер ячейки. Всего же на DVD-диске находятся три различных ключа: ключ аутентификации, ключ диска, а также ключ названия, расположенный в заголовке сектора данных. Каждый из 3 ключей должен обрабатываться и проверяться перед тем, как переходить к следующему. В итоге после всех проверок ключ диска комбинируется с ключом названия, чтобы "отпереть" кинофильм для воспроизведения. Хотя вся эта конструкция может на первый взгляд показаться весьма изощренной, в действительности механизм защиты CSS оказался значительно слабее, чем хотелось его разработчикам.


Спецвыпуск Xakep, номер #034, стр. 034-098-7, DИСКИ VЫСОКИХ DОСТОИНСТВ

DИСКИ VЫСОКИХ DОСТОИНСТВ

Берд Киви (kiwi@computerra.ru)

Спецвыпуск Xakep, номер #034, стр. 034-098-7

Поскольку блок дешифрования должен быть встроен в каждый программный декодер, который может проигрывать такие диски, то рано или поздно кто-то должен был сделать обратную инженерную разработку программы и разобраться в работе схемы вплоть до восстановления ключей. К октябрю 1999 года 16-летний (!) норвежский школьник-программист Йон Йохансон с коллегами по хакерской группе MoRE (Masters of Reverse Engineering) разобрали программу-плеер XingDVD и добрались до ключа доступа фирмы Xing Technologies. Ну а дальше они "развинтили" и всю остальную конструкцию, выложив в интернет программу DeCSS, которая расшифровывает данные и позволяет записывать содержимое защищенных файлов DVD-дисков в чистом виде на винчестер. История эта стала поводом для целой серии шумных судебных разбирательств, которые тянутся до сих пор (эта история во всех подробностях изложена на www.lemuria.org/DeCSS). Во многих странах программа DeCSS объявлена сейчас вне закона. Однако за прошедшее время создано множество программных средств (включая и коммерческие), которые на основе уже известной информации о CSS снимают эту защиту "на лету", не храня заранее чужие ключи доступа (формально это является посягательством на коммерческую тайну, как в случае с DeCSS).

Надо отметить, что главным поводом для преследования DeCSS стало обвинение в пособничестве видеопиратству. Хотя прекрасно известно, что в действительности пиратские DVD появились задолго до DeCSS, потому что настоящим пиратам гораздо удобнее было копировать диски целиком "один в один" безо всякой утомительной расшифровки-перекодировки, просто используя модифицированные приводы с доступом к служебным секторам диска, либо получая копию фильма множеством других способов - благодаря видеовыходу DVD-плейера, промоушн-кассетам или тайно пронесенной в кинозал видеокамере.

ПРОБЛЕМА ВЫБОРА

В течение нескольких лет задача выбора привода DVD-ROM неизменно ставила покупателя перед дилеммой - брать новый или искать постарее. Естественно, новый производительнее, но зато многие "старые" приводы, выпущенные до января 2000 года, не имели региональной защиты и проигрывали все диски без разбора. Сейчас таких приводов в продаже давно нет, так что проблема выбора разрешилась сама собой, а региональное кодирование приходится преодолевать мультизонной перепрошивкой микросхемы или программно. Главными же параметрами выбора привода остались соотношение цена/производительность, бесшумность в работе и способность читать подпорченные диски. Свежий обзор десятка дисководов DVD-ROM популярных брендов, сравниваемых по упомянутым параметрам, есть на www.ferra.ru/online/storage/20758.


Спецвыпуск Xakep, номер #034, стр. 034-098-8, DИСКИ VЫСОКИХ DОСТОИНСТВ

DИСКИ VЫСОКИХ DОСТОИНСТВ

Берд Киви (kiwi@computerra.ru)

Спецвыпуск Xakep, номер #034, стр. 034-098-8

СДЕЛАЙ САМ

На сегодняшний день имеется большой выбор совсем несложных в обращении программ, позволяющих копировать DVD на винчестер, абсолютно не вникания в подробности технологий защиты. Одна из самых популярных бесплатных программ - DVD Decrypter (www.dvddecrypter.com), реализующая всю процедуру на уровне перетаскивания пиктограмм файлов. Эта же программа умеет делать и готовые ISO-образы диска для записи собственного на пишущем DVD-приводе с помощью ходовых программ "прожига", вроде Roxio Easy CD Creator (www.roxio.com/en/products/ecdc/index.jhtml) или Nero Burning ROM (www.nero.com/en/index.html). Эти программы последних версий работают с форматами DVD фактически так же легко, как и с CD. Другая очень популярная, правда коммерческая, программа копирования DVD, VOB Instant CD/DVD (www.vob.de), часто прилагается на диске в комплекте с retail-версиями пишущих DVD-приводов.

Еще один продукт, о котором следует упомянуть - программа VLC media player (www.videolan.org/vlc), прежде известная как VideoLAN Client. Этот плеер ныне работает под всеми популярными ОС (Linux, Windows, Mac OS X и др.), а в данный раздел попал по той причине, что опирается на официально лицензированную, в этой же фирме (VideoLAN) разработанную, программную библиотеку Libdvdcss. Все это хозяйство создано в полном соответствии с духом программ с открытым исходным кодом (GNU Public License). Иными словами, может быть свободно загружено, использовано и модифицировано кем угодно, и при этом позволяет делать с контентом DVD-Video все, что душа пожелает, вплоть до потоковой трансляции в интернет. Любопытно, что, несмотря на такие вольности, у VideoLAN пока не было никаких проблем с MPAA, Американской киноассоциацией, защищающей права голливудских компаний и тягающей по судам распространителей DeCSS.

Серьезная проблема с копированием DVD в домашних условиях возникает тогда, когда размер фильма превышает 4,7 Гб, а это бывает довольно часто при длинных картинах, фабрично штампуемых на двухслойные диски. А все форматы записываемых DVD на сегодняшний день являются однослойными, поэтому приходится разбивать файлы диска-оригинала на две части. Либо прибегать к более изощренным методам ремастеринга, удаляя при копировании все "дивидишные прибамбасы" (мультимедийные меню, многоязыковую поддержку и прочие бонусы), оставляя лишь собственно фильм и его звуковую дорожку. Уже существуют и коммерческие программы для быстрой и легкой модификации подобного рода, например, DVD X Copy Express фирмы 321 Studios (www.dvd-x-copy.ca).

Наконец, одно из важнейших достоинств технологии DVD в сочетании с компьютером - это возможность удобного изготовления в домашних условиях собственных фильмов, видеопрограмм и мультимедиа-презентаций вполне профессионального качества. Наиболее содержательные русскоязычные материалы на этот счет имеются на обстоятельном сайте Михаила Афанасенкова www.afanas.ru/video (кодирование в MPEG-2, запись многоканального звука 5.1, монтаж файлов и многое другое). Также следует упомянуть "Введение в технологию DVD-R" (http://dvdhelp.narod.ru/dvdr-intro.html) и "FAQ по работе с пишущими DVD-приводами" (www.spline.ru/FAQ/faq_dvd_mastering.htm).


Спецвыпуск Xakep, номер #034, стр. 034-098-9, DИСКИ VЫСОКИХ DОСТОИНСТВ

DИСКИ VЫСОКИХ DОСТОИНСТВ

Берд Киви (kiwi@computerra.ru)

Спецвыпуск Xakep, номер #034, стр. 034-098-9

НАРЕЗАТЬ ИЛИ КУСОЧКОМ?

Чтобы понять суть проблем несовместимости дисков, приводов и плееров, придется хотя бы кратко обрисовать общую ситуацию, возникшую из-за разнообразия форматов. Самый первый формат однократной записи, DVD-R, был разработан фирмой Pioneer и во многом похож на суперуспешный CD-R. Максимум внимания разработчики уделили вопросу совместимости с приводами DVD-ROM, поэтому диски DVD-R читаются на наибольшем числе дисководов и плееров разных производителей. Правда, потом появилось две разновидности: DVD-R For Authoring (профессиональный) и DVD-R For General (бытовой), однако последних сейчас намного больше, так что на тонкостях различий останавливаться не будем.

Но вот после того, как в Pioneer создали перезаписываемый формат DVD-RW, одобренный (как и DVD-R) консорциумом DVD Forum, дела пошли значительно хуже. Во-первых, собственный перезаписываемый формат DVD-RAM уже успела создать Matsushita, владеющая брендом Panasonic. Но этот формат был несовместим с плеерами DVD-Video, а годился главным образом для компьютеров в качестве удобного средства резервного копирования. Во-вторых, что гораздо хуже, группа фирм во главе с Philips, Sony и Hewlett-Packard создала и начала продвигать альтернативный вариант перезаписываемого формата, получивший название DVD+RW. Хотя DVD Forum эту инициативу не поддержал, но запретить был не вправе, индустрию начали раздирать мощные противоречия несовместимости форматов. Серьезных проблем добавила и светоотражательная способность слоя на перезаписываемых болванках (как -RW, так и +RW), поскольку она несколько меньше, чем у просто записываемых, и намного меньше, чем у штампованных. Из-за этого многие приводы, особенно старые, совсем стали путаться. Наконец, чтобы довести ситуацию до логического конца, консорциум +RW создал еще и формат однократной записи +R, чем полностью развел сторонников форматов по разным лагерям. А для несчастных пользователей самой главной проблемой стало не покупать болванки одного формата к приводам другого.

ИГРА ЦВЕТОВ И ФАЗ

Технологии однократной и многократной записи DVD разрабатывались на базе уже хорошо освоенных технологий CD, а потому вполне естественно, что между ними много общего. Сохранены те же физические размеры диска - диаметр 120 мм и толщина 1,2 мм. Однако для существенного увеличения емкости накопителя изменена длина волны красного лазера - с 780 нанометров в CD до 650 нм в DVD, что позволило уменьшить размер питов (несущих информацию участков с измененной прозрачностью) и увеличить плотность записи слоя с 650/700 Мб до 4,7 Гб. Как и в CD-R, в дисках DVD-R информационным слоем служит специальный органический краситель, необратимо изменяющий свою прозрачность под действием импульсов лазера. Аналогично, в DVD±RW для многократной записи информации применяется вещество, в зависимости от энергии лазера обратимо меняющее свое фазовое состояние с кристаллического на аморфное (изменяя при этом и светоотражательную способность). Информационный слой в DVD имеет толщину порядка 25 микрометров и словно в сэндвиче с двух сторон обложен защитными слоями толщиной по 0,6 мм. Если диск двусторонний, то оба слоя, естественно, прозрачны.


Спецвыпуск Xakep, номер #034, стр. 034-098-10, DИСКИ VЫСОКИХ DОСТОИНСТВ

DИСКИ VЫСОКИХ DОСТОИНСТВ

Берд Киви (kiwi@computerra.ru)

Спецвыпуск Xakep, номер #034, стр. 034-098-10

В технологиях оптической записи третьего поколения (Blue-Ray и AOD) длина волны лазера стала еще короче, сместившись из красной в сине-фиолетовую часть спектра (405 нанометров). Благодаря этому один слой на диске может вмещать до 27 гигабайт. Одновременно идет активное усовершенствование многослойной конструкции диска, и уже продемонстрированы (фирмой Hitachi) образцы с толщиной слоя 0,3 микрометра, радикально изменяющие свою прозрачность при смене подаваемого напряжения. Теоретически это дает возможность создавать 100-слойные диски емкостью около 1 терабайта (триллиона байт), так как лазерная оптика получает возможность считывать информацию из любого слоя на выбор.

Подробно разбирать достоинства и недостатки конкурирующих форматов -RW и +RW сейчас вряд ли имеет смысл, поскольку за прошедшее время имевшиеся у них технологические недостатки уже подправлены. Так что на сегодня индустрии удалось примерно выровнять качества обоих стандартов. Но самое главное, что самые дальновидные компании с конца прошлого, 2002 года приступили к выпуску пишущих приводов, поддерживающих как DVD+RW, так и DVD-RW. Поэтому самое мудрое - ориентироваться именно на такие "резаки", стоимость которых больше примерно на полсотни, но уже опустилась ниже 300 долларов.

Ну, а для тем, кто успел связать свою жизнь с тем или иным форматом, для выяснения вопросов совместимости полезно заглядывать на информационные сайты. Наиболее полный из подобных списков совместимости для стационарных DVD-плееров валяется по адресу www.vcdhelp.com/dvdplayers.php, а список приводов, совместимых с DVD+RW и DVD+R, ищи на www.dvdplusrw.org/resources/compatibilitylist_dvdrom.html. Как показывает опыт, если привод DVD-ROM может читать диски DVD+RW, то он сможет прочесть и DVD-RW с DVD-R. То же самое справедливо и для последних моделей приводов DVD-R/RW относительно чтения DVD+R/RW, хотя официально эта возможность часто не декларируется. Таковы уж законы конкуренции :).

РЕЗАКИ УНИВЕРСАЛЬНЫЕ

На радость покупателям все больше фирм переходят к выпуску универсальных пишущих DVD-приводов, совместимых и с DVD-R/RW, и с DVD+R/RW. Тон задала компания Sony, выпустившая такой резак еще осенью прошлого года. Чуть позже по этому же пути пошли компании Iomega, Memorex, NEC, Plextor и TDK. Более того, преодолев неприязнь к конкуренту, универсальный привод выпустила даже фирма Pioneer, когда-то породившая формат DVD-R/RW. А LG Electronics в ближайшее время намерена выпустить привод, поддерживающий все три перезаписываемых формата, включая и DVD-RAM. Ну а пока что среди приводов "двойной ориентации", наряду с уже зарекомендовавшим себя резаком-"ветераном" Sony DRU-500A, хорошие отзывы получают дисководы Pioneer DVR-A06 и TDK IndiDVD Dual.


Спецвыпуск Xakep, номер #034, стр. 034-098-11, DИСКИ VЫСОКИХ DОСТОИНСТВ

DИСКИ VЫСОКИХ DОСТОИНСТВ

Берд Киви (kiwi@computerra.ru)

Спецвыпуск Xakep, номер #034, стр. 034-098-11

ЗАВТРА ОЖИДАЮТСЯ

Надеждам всех любителей DVD на то, что по мере развития технологии удастся прекратить войны конкурирующих стандартов, увы, явно не суждено сбыться. В конце 2002 года исполнительный комитет консорциума DVD Forum, собиравшийся на осеннюю встречу в Париже, одобрил в качестве кандидата на DVD-стандарт нового поколения технологию Advanced Optical Disc (AOD), предложенную японскими корпорациями NEC и Toshiba. Одновременно альтернативная технология Blue-Ray, несовместимая с AOD и поддерживаемая конкурирующей группой из 9 компаний (Matsushita, Philips, Sony, Hitachi, LG, Pioneer, Samsung, Sharp и Thomson) не была принята в кандидаты на новый стандарт, потому что ее разработчики не захотели делать официального представления спецификаций Форуму.

Обе новых технологии построены на основе синего лазера с длиной волны 405 нанометров, и летом 2002 года консорциум DVD сформировал две рабочие группы для изучения конкурирующих систем и поиска возможных путей их объединения. В принципе, такая надежда не оставлена и поныне, однако главным условием для достижения компромисса является готовность соперничающих сторон пойти на уступки, но именно этого достичь и не удается. Технология AOD в значительной степени опирается на уже существующие методы производства DVD, однако позволяет записывать на одну сторону однослойного диска до 20 гигабайт данных. Альтернативная технология Blue-Ray обеспечивает более высокую плотность записи, до 27 гигабайт на сторону, но обладает меньшей совместимостью с предыдущим поколением DVD.

Первые продажи DVD рекордера BDZ-S77 на основе технологии Blue-Ray компания Sony начала в апреле 2003 года по цене около 3800 долларов. Цена записываемых дисков поначалу составила порядка 30 долларов за штуку. Чуть позже, в мае нынешнего года, в рамках конференции Optical Storage 2003 (Ванкувер, Канада) корпорация Toshiba представила и первые образцы альтернативных оптических накопителей нового формата AOD. В ходе презентации Toshiba продемонстрировала двухслойные перезаписываемые болванки емкостью 36 Гб, однослойные перезаписываемые диски объемом 20 Гб, а также носители для однократной записи объемом 15 и 30 Гб.

Надо оговориться, что официальное окончательное принятие спецификаций стандарта Advanced Optical Disc состоится не раньше конца 2003 года. Соответственно, и первые устройства, поддерживающие новый формат, появятся в продаже лишь в 2004 году. Но как бы там ни было, крайне маловероятно, что конкурирующие стороны захотят пойти на мировую. А значит, война стандартов продолжается.

БЕЗДОННЫЙ ДИСК ОТ HITACHI

Японская компания Hitachi объявила в мае 2003 г. о создании еще одного формата, альтернативного грядущим AOD и Blue-Ray. Стараниями этой фирмы на рынке в обозримом будущем могут появиться диски DVD такой емкости, что всего лишь одного хватит для хранения примерно 200 фильмов стандартного формата, то есть около 400 часов видео. Новая технология разрабатывается подразделением Hitachi Maxell Ltd, специализирующимся на аудио- и видеозаписи. Гигантская плотность упаковки информации достигнута благодаря сверхмногослойной структуре диска. Коммерческая реализация DVD нового формата запланирована в Hitachi на 2007 год.


Спецвыпуск Xakep, номер #034, стр. 034-098-12, DИСКИ VЫСОКИХ DОСТОИНСТВ

DИСКИ VЫСОКИХ DОСТОИНСТВ

Берд Киви (kiwi@computerra.ru)

Спецвыпуск Xakep, номер #034, стр. 034-098-12

DVD-носитель позволяет хранить и ресурсоемкие видеофайлы, и качественные аудиозаписи, и большие массивы компьютерных данных (от 4,7 Гб в однослойном одностороннем варианте до 17 Гб в двухслойном двустороннем варианте носителя).

Однако когда речь заходит не о штампованных на заводе, а о самостоятельно записываемых дисках DVD, сразу всплывают, по меньшей мере, шесть различных форматов конкурирующих друг с другом фирм и групп компаний: DVD-R Authoring, DVD-R General, DVD-RAM, DVD-RW, DVD+RW и DVD+R.

Противоборство конкурирующих форматов продолжается, каждый из "зачинщиков" стремится привлечь на свою сторону как можно больше производителей аппаратуры и звукозаписывающих компаний.

При выборе DVD-плеера в одной ценовой категории самым главным параметром является, очевидно, многофункциональность. Под этим понимается возможность воспроизведения не только дисков DVD, но также CD-R/RW и поддержка различных мультимедиа-форматов, таких как Super VCD, VCD, Audio CD, mp3, HDCD, Kodak Picture CD, JPEG.

Очень высокое качество видео на DVD и принципиальная возможность его несанкционированного копирования "бит в бит" без потери качества с самого начала были главной головной болью киностудий, приложивших максимум усилий для надежной защиты контента на диске.

Подробную информацию о трансформации плееров в мультирегионный режим смотри на www.uni-electronics.newmail.ru/dvd_upg.html, а относительно перепрошивки DVD-приводов большой инфоресурс имеется на http://forum.rpc1.org/portal.php.

Существует множество недорогих устройств, устраняющих защиту Macrovision и известных под названиями, типа Video Clarifier, Image Stabilizer, Color Corrector и CopyMaster (www.videoguys.com/sima.htm). Умельцы могут изготовить и свою собственную схему, смотри http://66.40.78.100/Services/TECH_Notes/nineteen.html.

Всего же на DVD-диске находятся три различных ключа: ключ аутентификации, ключ диска, а также ключ названия, расположенный в заголовке сектора данных. Каждый из 3 ключей должен обрабатываться и проверяться перед тем, как переходить к следующему. В итоге после всех проверок ключ диска комбинируется с ключом названия, чтобы "отпереть" кинофильм для воспроизведения.

К октябрю 1999 года 16-летний (!) норвежский школьник-программист Йон Йохансон с коллегами по хакерской группе MoRE (Masters of Reverse Engineering) разобрали программу-плеер XingDVD и добрались до ключа доступа фирмы Xing Technologies. Ну а дальше они "развинтили" и всю остальную конструкцию, выложив в интернет программу DeCSS, которая расшифровывает данные и позволяет записывать содержимое защищенных файлов DVD-дисков в чистом виде на винчестер.


Спецвыпуск Xakep, номер #034, стр. 034-098-13, DИСКИ VЫСОКИХ DОСТОИНСТВ

DИСКИ VЫСОКИХ DОСТОИНСТВ

Берд Киви (kiwi@computerra.ru)

Спецвыпуск Xakep, номер #034, стр. 034-098-13

Серьезная проблема с копированием DVD в домашних условиях возникает тогда, когда размер фильма превышает 4,7 Гб, а это бывает довольно часто при длинных картинах, фабрично штампуемых на двухслойные диски.

В технологиях оптической записи третьего поколения (Blue-Ray и AOD) длина волны лазера стала еще короче, сместившись из красной в сине-фиолетовую часть спектра (405 нанометров). Благодаря этому один слой на диске может вмещать до 27 гигабайт.

Технология AOD в значительной степени опирается на уже существующие методы производства DVD, однако позволяет записывать на одну сторону однослойного диска до 20 гигабайт данных. Альтернативная технология Blue-Ray обеспечивает более высокую плотность записи, до 27 гигабайт на сторону, но обладает меньшей совместимостью с предыдущим поколением DVD.


Спецвыпуск Xakep, номер #034, стр. 034-106-1, Опись, протокол, отпечатки пальцев...

Опись, протокол, отпечатки пальцев...

Елманов Олег (SpyDr@comail.ru)

Спецвыпуск Xakep, номер #034, стр. 034-106-1

Обзор технологий биометрической идентификации

- Кто там?

В разных вариациях именно так звучит один из вечных вопросов человечества. Мы всегда стремимся к идентификации окружающих, хотим знать, кто вон та девушка на соседнем ряду, с кем мы общаемся вот уже второй час, и кто, собственно говоря, к нам пришел в гости.

Для идентификации, или подтверждения того, что пользователь является тем, за кого он себя выдает, используются разнообразные методы. Например, при встрече с другом ты его распознаешь по походке, внешности, манере поведения. По телефону собеседника можно определить по голосу. А вот в сфере высоких технологий все гораздо сложнее.

Как известно, серьезные информационные системы и вычислительные средства, доступ к которым есть у более чем одного человека, имеют систему защиты. Она необходима для обеспечения сохранности информации, надежной работоспособности и предотвращения несанкционированного доступа в систему. Для выполнения возложенных функций система безопасности выполняет идентификацию пользователей, проверку их подлинности и определяет их полномочия. В общем-то, ничего нового. С помощью паролей, электронных ключей, смарт-карт можно обеспечить некоторую защиту. Но стопроцентную гарантию тебе никто не даст! Например, пароль можно найти в бумажке, прикрепленной к монитору, электронный ключ будет лежать под клавиатурой, а смарт-карта случайно упадет на пол. Злоумышленник знает ровно тысячу и один способ, как получить доступ к защищаемым ресурсам.

Для более точного и однозначного определения пользователя применяют биометрическую идентификацию, которая подразумевает сбор и анализ поведенческих и физиологических особенностей человека. В качестве биометрических характеристик человека могут выступать: радужная оболочка и сетчатка глаза, отпечатки пальцев, геометрия руки, геометрия лица, голос, походка, почерк и т.д.

В отличие от традиционных систем идентификации, биометрические методы обладают рядом преимуществ - нет необходимости стараться не забыть или не потерять, его не украдут (с этим, однако, можно поспорить - прим. ред.). Кроме того, биометрические устройства отличаются удобством использования - допустим, приложил палец к детектору - и свободен.

Принципы работы биометрических систем

Все системы биометрической идентификации устроены примерно одинаково. Есть устройство снятия биометрических характеристик, определенное программное обеспечение, анализирующее и обрабатывающее биометрическую информацию, база данных биометрической информации и, наконец, встроенные алгоритмы сравнения и распознавания биометрических образов.

Алгоритм работы систем биометрической идентификации выглядит следующим образом. Первоначально пользователь регистрируется в системе. При этом вводятся контрольные значения биометрических параметров. С одной стороны, биологические характеристики человека уникальны и не повторяются, а с другой - сами они тоже не постоянны и находятся в некотором интервале. Поэтому для записи контрольного образа биометрические характеристики снимают несколько раз, обычно от 3 до 5, в зависимости от вида характеристики и метода обработки. После записи контрольных значений формируется цифровая модель снятого образа. Обычно контрольные образы представлены в таком виде, по которому максимально точно можно идентифицировать пользователя и при этом нельзя обратно восстановить первоначальные значения.


Спецвыпуск Xakep, номер #034, стр. 034-106-2, Опись, протокол, отпечатки пальцев...

Опись, протокол, отпечатки пальцев...

Елманов Олег (SpyDr@comail.ru)

Спецвыпуск Xakep, номер #034, стр. 034-106-2

Идентификация проходит следующим образом. Для входа в систему пользователь с помощью специальных приборов предоставляет о себе биометрическую информацию. Образ обрабатывается математическими алгоритмами, затем сравнивается с эталонным значением. На основании результата выносится вердикт.

Методы идентификации

Существующие методы биометрической идентификации можно разделить на две основные группы. Первую группу составляют продукты, построенные на статических (неизменяемых) образах личности, данных от рождения. Примерами могут служить устройства, построенные на анализе особенностей геометрии лица, отпечатка пальца и т.п.

Ко второй, принципиально иной группе относятся программные продукты и устройства, построенные на динамическом анализе личности. Работают они на основе анализа голоса, почерка и других параметров.

А сейчас - поподробнее о существующих методах и их применении.

Идентификация по рисунку сосудов глазного дна

Одним из первых и самых надежных методов идентификации личности является метод, использующий рисунок кровеносных сосудов глазного дна. Вены и артерии, снабжающие глаз кровью, хорошо видны при подсветке глазного дна внешним источником света. Дерево кровеносных сосудов для каждого человека уникально. Процедура идентификации личности сводится к тому, что человек наблюдает сквозь специальный окуляр удаленную световую точку. При этом осуществляется инфракрасная подсветка его глазного дна, и на нем выделяется дерево кровеносных сосудов. Оно сравнивается с эталоном.

При оценке методов биологической идентификации используются два основных параметра. Ошибки первого рода возникают при разных поворотах исследуемой поверхности по отношению к эталонной. Ошибки второго рода возникают при неполном выполнении заданных условий, в данном случае - фокусировке взгляда на удаленном источнике света.

По данным Сандийской национальной лаборатории (США) ошибки первого рода для метода составляют 0,4%. Ошибки второго рода практически невозможны. Отсутствуют данные о том, каким образом можно обмануть подобные биометрические устройства. Приборы этого класса являются одними из самых дорогих и наименее популярны. Одна из причин - предубеждение пользователей, которые считают, что используемая устройствами инфракрасная подсветка их глазного дна вредит здоровью.

Радужная оболочка глаза

Радужная оболочка глаза также уникальна для каждого человека. Уникальность ее рисунка обусловлена генотипом личности, и существенные отличия радужной оболочки глаз наблюдается даже у близнецов. Врачи используют рисунок и цвет радужной оболочки для диагностики заболеваний и выявления генетической предрасположенности к некоторым болезням.

При ряде заболеваний на радужной оболочке появляются характерные пигментные пятна и изменения цвета. В системах идентификации личности используются только черно-белые изображения с высоким разрешением, так как в зависимости от состояния здоровья цветовой компонент оболочки изменяется.


Спецвыпуск Xakep, номер #034, стр. 034-106-3, Опись, протокол, отпечатки пальцев...

Опись, протокол, отпечатки пальцев...

Елманов Олег (SpyDr@comail.ru)

Спецвыпуск Xakep, номер #034, стр. 034-106-3

Уникальность рисунка радужной оболочки глаза позволяет фирмам выпускать целый класс весьма надежных систем для биометрической идентификации личности. Этот класс систем захватывает видеоизображение глаза на расстоянии 20-30 сантиметров от видеокамеры, осуществляет автоматическое выделение зрачка и радужной оболочки. О том, можно ли изготовить устройство для подлога, данных нет, а сам я не пробовал (можно, по крайней мере, несложно обмануть общедоступные недорогие устройства: делаешь качественную фотографию и вместо глаза подсовываешь ее - прим. ред.).

Геометрия кисти руки

Системы идентификации человека по силуэту кисти руки появились одними из первых и начали серийно выпускаться фирмой Idenmat (США) более 20 лет назад. С точки зрения компактности образа этот класс систем является самым экономичным. В простейшем варианте хранится только информация о длине и ширине пальцев, и требуется всего 9 байт. Естественно, что для систем, учитывающих только длину и ширину пальцев, может быть легко изготовлен картонный муляж руки оригинала. Более сложными являются системы, измеряющие профиль руки, что включает объем кисти, пальцев, неровности ладони, расположение складок кожи на сгибах. Данные о 3D геометрии руки получают путем использования телевизионной камеры и инфракрасной подсветки руки под разными углами. Последовательное включение нескольких подсвечивающих светодиодов дают проекции кисти руки в различных плоскостях. Именно они и содержат информацию о ее объеме.

Такое технологическое решение не позволяет производить компактные устройства, так как требуется выносить источники подсветки на расстояние 10 - 15 сантиметров. Поэтому приборы данного класса весьма габаритны. Ошибки первого и второго рода для современных биометрических устройств этого класса составляют менее 0,2%. Пользователи лояльно относятся к системам идентификации личности по геометрии кисти руки. Системы этого класса не предъявляют особых требований к чистоте, влажности, температуре рук, да и не столь страшны внешне.

Папиллярный рисунок пальцев руки

Не знаешь, что это такое? Папиллярный рисунок используется в дактилоскопии, те самые "пальчики", которые снимает наша родная милиция.

Сначала немного теории. Нижний слой кожи человека образует множество выступов - сосочков (по латыни сосочек - papilla), в вершине которых имеются отверстия выходных протоков потовых желез. На основной части кожи сосочки - papillae располагаются хаотично и трудно наблюдаемы. На отдельных участках кожи, например на ладони, папилляры строго упорядочены в линии (гребни), образующие уникальные папиллярные узоры.

Системы дактилоскопической идентификации личности снимают с помощью специальных устройств. папиллярный узор с одного из пальцев пользователя и сравнивают его с эталонным рисунком. Объем хранимой эталонной информации существенно уменьшается за счет классификации папиллярных рисунков. Дело в том, что узоры на наших руках, хотя и уникальны, относятся к одному из типов. Выделяют три типа папиллярных рисунков - дуговые, завитки, круговые и два типа макро особенностей - дельты и центы. Что это такое - спроси у знакомого доктора!


Спецвыпуск Xakep, номер #034, стр. 034-106-4, Опись, протокол, отпечатки пальцев...

Опись, протокол, отпечатки пальцев...

Елманов Олег (SpyDr@comail.ru)

Спецвыпуск Xakep, номер #034, стр. 034-106-4

В современных системах этого класса отказ зарегистрированным пользователям (FRR - false rejection rate) может варьироваться в диапазоне от 0,01% до 3%, в зависимости от настройки биометрической системы. Кроме того, при использовании нескольких пальцев вероятность отказа зарегистрированным пользователям сокращается до 0,0001% даже на многомиллионных базах данных. Это самый популярный метод биометрической идентификации ввиду его простоты и дешевизны, однако не самый надежный. Иногда систему можно обойти простым "слепком пальца": ставишь свои "пальчики" на чем-нибудь вроде пластилина (лучше - силикона), и используешь вместо пальца этот слепок.

Геометрия лица

Принцип работы подобных устройств крайне прост. Миниатюрная видеокамера (подойдет и web-камера) снимает лицо человека. Изображение лица оцифровывается и загружается в компьютер. Программное обеспечение сравнивает введенный портрет с хранящимся в памяти эталоном. Весьма важным является также то, что этот класс биометрических систем потенциально способен проверять пользователя компьютера (производить аутентификацию) в течение всего сеанса его работы, что позволяет предупредить и своевременно отреагировать на несанкционированный доступ к вычислительным ресурсам.

Основными проблемами, с которыми приходится сталкиваться разработчикам таких биометрических систем, являются изменение освещенности, вариации положения головы пользователя, выделение информативной части - портрета (гашение фона). С этими проблемами удается справиться, автоматически выделяя на лице особые точки и затем измеряя расстояния между ними. На лице выделяются контуры глаз, бровей, носа, подбородка. Расстояния между характерными точками этих контуров образуют весьма компактный эталон конкретного лица, легко поддающийся масштабированию. Близнецы системами этого класса не различаются. Кроме того, наиболее распространенными являются методы двухмерного анализа изображения. В этом случае, для успешной идентификации достаточно хорошей фотографии. Трехмерные биометрические системы являются весьма сложными и дорогими. Обмануть этот класс систем можно только объемной маской, точно воспроизводящей трехмерную геометрию лица-оригинала. Хорошо работающих трехмерных систем пока не существует. На рынке преобладают двухмерные системы низкого качества.

Вены руки

Да, существуют и такие приборы. При работе используется рисунок вен тыльной стороны кисти руки, сжатой в кулак. Наблюдение рисунка вен осуществляется телевизионной камерой при инфракрасной подсветке. После ввода изображения осуществляется его бинаризация, подчеркивающая вены. Что-нибудь сказать о качестве идентификации сложно, так как это довольно редкий ее вид.


Спецвыпуск Xakep, номер #034, стр. 034-106-5, Опись, протокол, отпечатки пальцев...

Опись, протокол, отпечатки пальцев...

Елманов Олег (SpyDr@comail.ru)

Спецвыпуск Xakep, номер #034, стр. 034-106-5

Исследования в области статической биометрической идентификации ведутся полным ходом. Вполне возможно, что методы идентификации личности по запаху тела, следам пота или строению уха со временем выйдут из рамок научных исследований и станут коммерческими технологиями.

Голос

Идентификация личности по голосу весьма привлекательна. С одной стороны, можно использовать и телефон, и звуковую карту компьютера, а с другой - идентификация по голосу традиционна для людей и поэтому не вызывает психологической неприязни. Интерес к задаче идентификации личности по голосу не ослабевает на протяжении последних 30 лет. Развитие новых технологий периодически дает толчок к возобновлению интереса к этой задаче.

Общий принцип работы устройств распознавания голоса строится исходя из различной тембральной окраски голосов и индивидуальной неравномерности распределения мощности произносимой фразы по частотному спектру. В последнее время развиваются системы идентификации с линейным предсказанием речи.

Общим недостатком биометрических систем идентификации личности по голосу является то, что парольную фразу невозможно сохранить в тайне. Современные средства акустического прослушивания позволяют записать парольную фразу с хорошим качеством. Такие проблемы исключаются при использовании произвольных фраз. Правда, с коммерческими системами такого рода я пока не встречался.

По данным независимого тестирования Сандийской национальной лаборатории (США), ошибки первого и второго рода составляют для голосовых систем около двух процентов.

Рукописная подпись

А вот это - один из классических способов идентификации личности, применяемый уже несколько столетий. К тому же он еще и самый распространенный. Он применяется во всех сферах жизнедеятельности современного человека, однако...

Настоящая проверка подписи осуществляется в основном только в банковском деле. За несколько столетий подписи научились подделывать основательно, так что даже компьютер порой не сможет определить степень достоверности. Единственным выходом является наблюдение за динамикой воспроизведения подписи. Траекторию движения пера подделать уже действительно проблематично. Также, для увеличения достоверности, применяют рукописный ввод контрольного слова. Процесс росписи пользователя снимается на камеру, оцифровывается, а затем сравнивается с эталонной моделью.

Использование устройств такого рода себя не оправдывает, так как экспертная оценка специалиста дает лучший результат.

Клавиатурный почерк

А вот это уже ближе к массам! Способ был заимствован из области телеграфии, когда передавали информацию кодом Морзе. У каждого телеграфиста был свой почерк передачи сигналов. А с клавиатурным почерком все гораздо проще. Каждый человек по-своему набирает текст. Кто-то быстрее, кто-то медленнее, можно набирать одним пальцем, двумя - как умеешь. Кроме того, при наборе слов некоторые сочетания букв или слова набираются гораздо быстрее. Это имя, фамилия пользователя, слова из области интересов или профессиональной деятельности. С помощью данного способа можно не только идентифицировать пользователя, но и производить дальнейший контроль во время работы компьютера. Еще одним параметром для анализа может служить количество ошибок при вводе текста, а также их характер. Например, нажатия на соседние клавиши. Для идентификации, как правило, применяются нейросетевые алгоритмы, которые хорошо работают в условиях неформализованных и непостоянных входных данных.


Спецвыпуск Xakep, номер #034, стр. 034-106-6, Опись, протокол, отпечатки пальцев...

Опись, протокол, отпечатки пальцев...

Елманов Олег (SpyDr@comail.ru)

Спецвыпуск Xakep, номер #034, стр. 034-106-6

Работа с мышкой

Подлинность пользователя также можно определить по характеру работы с мышкой. В качестве индивидуальных биологических характеристик юзеров используется координация движений, реакция на событие, скорость и точность манипулирования мышью, особенности траектории указателя. При идентификации это трудно применимо, используется для определения достоверности пользователя во время его работы. Коммерческих продуктов такого типа я не встречал, зато игрался с экспериментальными разработками.

Рыночные дела

Биометрический рынок во всем мире характеризуется растущим спросом, в развитие отрасли вкладываются значительные деньги. Одну из главных ролей на этом рынке играют государственные организации, инициирующие множество крупномасштабных проектов по разработке систем массовой идентификации людей - в настоящий момент подобные системы занимают порядка 60% всего биометрического рынка. Эксперты обещают, что рост продаж биометрических систем к 2007 году составит около 4 миллиардов долларов.

В прошлом году объем продаж биометрических систем на базе отпечатков пальцев составил $467 млн!

Автор выражает свою искреннюю благодарность компании BioLink Technologies за

предоставленную информацию.

Наиболее точной из существующих биометрических технологий считается технология идентификации человека по сетчатке глаза, наиболее популярной - технология идентификации по отпечаткам пальцев (по оценкам консалтинговой компании International Biometric Group на 2003 год - 52,1% от общего объема продаж всех биометрических систем).

На сегодняшний день существует только один международный биометрический стандарт, технологический - это стандарт BioAPI.

В связи с тем, что Большой Восьмеркой принято решение о внедрении всеобщей биометрической паспортизации (первым этапом будет система US Visit), созданы специальные группы по определению стандартов - Лионская и Римская группы.

Европейское сообщество планирует усовершенствовать визовые документы за счет включения в список обязательных параметров отпечатка пальца владельца документа. А федеральные органы власти США разрабатывают идентификационные карты и водительские удостоверения граждан, снабженные отпечатками пальцев в цифровом виде, подделать которые крайне сложно.

В системах биометрической идентификации компании BioLink модель отпечатка пальца формируется путем удаления из полученного изображения лишних "шумов", затем изображение преобразуется в тонкие линии (толщиной 1 пиксел), определяется поле направлений, выделяются особые точки (минюции). После этого формируется цифровая модель отпечатка пальца.


Спецвыпуск Xakep, номер #034, стр. 034-106-7, Опись, протокол, отпечатки пальцев...

Опись, протокол, отпечатки пальцев...

Елманов Олег (SpyDr@comail.ru)

Спецвыпуск Xakep, номер #034, стр. 034-106-7

В Центре Речевых Технологий разработана программа VoiceKey. Она позволяет на основе анализа парольной фразы разграничивать доступ к компьютерным ресурсам. Точность распознавания 98%. Для работы программы достаточно простого Пентиума 200. Демо-версия доступна по адресу www.stc.rus.net/rus/.

В качестве биометрических характеристик человека могут выступать: радужная оболочка и сетчатка глаза, отпечатки пальцев, геометрия руки, геометрия лица, голос, походка, и даже почерк.

Миниатюрная видеокамера, подойдет и Web-камера, снимает лицо человека. Изображение лица оцифровывается и загружается в компьютер.

За несколько столетий подписи научились подделывать основательно, так что даже компьютер порой не сможет определить степень достоверности.

Первичный проход через биометрический пропускной пункт будет значительно дольше, чем проход с обычным паспортом.

Для входа в систему пользователь с помощью специальных приборов предоставляет о себе биометрическую информацию.

Процедура идентификации личности сводится к тому, что человек наблюдает сквозь специальный окуляр удаленную световую точку.

В системах идентификации личности используются только черно-белые изображения с высоким разрешением.

Подлинность пользователя можно определить по характеру работы с мышкой.

На сегодняшний день существует только один международный биометрический стандарт, технологический - это стандарт BioAPI.


Спецвыпуск Xakep, номер #034, стр. 034-110-1, УМНЫЕ ЛИНКИ

УМНЫЕ ЛИНКИ

Елманов Олег (SpyDr@comail.ru)

Спецвыпуск Xakep, номер #034, стр. 034-110-1

Технологии в инете

СЕТЕВЫЕ ТЕХНОЛОГИИ (www2.bilim.com/library)

Физическая организация ЛВС, используемые стандарты, оборудование для создания сети, практика по созданию локалок, вопросы безопасности внутри сетей и многое другое. Хорошие материалы по логике построения сетей с описанием сетевых интерфейсов. Доступно изложены вопросы маршрутизации и приведены спецификации протоколов и стандартов интернета. В основном информация представлена на русском языке, но что-то есть и в оригинале - на английском.

Дополнительную информацию по сетевым протоколам смотри на www.protocols.ru, а информацию о TCP/IP и организации локалок на основе него черпай с http://it-junior.boom.ru/ethernet/net.htm.

IP-ТЕЛЕФОНИЯ (www.comptek.ru/iptelephony/technology.html)

Рассмотрена архитектура IP-телефонии, принципы работы, используемые стандарты. Также ты найдешь описания оборудования, применяемого в компьютерной телефонии. Подробно освещены вопросы программирования приложений компьютерной телефонии.

На сайте www.computertelephony.com ты найдешь последний выпуск журнала Computer Telephony - самого серьезного издания по компьютерной телефонии в мире. Там же можно подписаться на журнал. Правда, подписка стоит 50 зеленых в год :).

CD-R - ТЕХНОЛОГИЯ ЗАПИСИ (www.media-r-us.com/technology)

Форматы компакт-дисков, структура и строение CD, отличия CD-R от штампованных дисков, технология записи компакт-диска. Подробная информация о системе коррекции ошибок, применяемой в CD, параметрах определения качества болванок и их классах. Есть софт для тестирования и определения скрытых характеристик CD.

На www.3dnews.ru/storage ты сможешь почерпнуть информацию по тиражированию компакт-дисков и технологиям защиты CD от копирования.

ТЕХНОЛОГИЯ JAVA (http://ru.sun.com/win/java)

Ресурс от производителя. Описание технологии Java, характеристики, текущие спецификации. Море руководств, книг, учебников и документации. Для разработчиков - подробный обзор Java API и Java Enterprise API. Выложена последняя версия Java Development Kit и другие программные продукты от Sun. Доступны многочисленные примеры с исходниками.

На www.javagu.ru ты найдешь учебные пособия, курсы, лекции и много необходимого для Java-софта.

LCD - МОНИТОРЫ (www.digitalware.ru/static/dwmonitors)

Информация по технологии работы жидкокристаллических дисплеев, современные цифровые дисплейные интерфейсы, основные характеристики и параметры качества. Описаны перспективные технологии - OLED, электролюминесценция, трехмерные дисплеи. Есть занятный материал о влиянии мониторов на здоровье человека.

По адресу http://itc.ua/article.phtml?ID=1457 ты найдешь подробную дополнительную информацию по архитектуре и строению жидкокристаллических дисплеев.

ПРИНТЕР ИЗНУТРИ (www.ferra.ru/online/printers)

Технологии печати. Струйная печать - пьезоструйная, термоструйная, пьезоэлектрическая. Проблемы цветопередачи, обзор технологий цветоделения. Фотопечать. Технология лазерной печати - теория и практика, устройство и эксплуатация картриджей. Обзор большого количества моделей принтеров.


Спецвыпуск Xakep, номер #034, стр. 034-110-2, УМНЫЕ ЛИНКИ

УМНЫЕ ЛИНКИ

Елманов Олег (SpyDr@comail.ru)

Спецвыпуск Xakep, номер #034, стр. 034-110-2

На www.digitalware.ru/static/dwPrinters представлены базисы технологии цветной печати - теория формирования цвета, различные практические реализации. Неплохим подспорьем в теории лазерной печати будет адресок www.ixbt.com/peripheral.shtml.

Самое подробное описание сублимационной технологии печати представлено на сайте www.sublimation.com, правда, на английском языке.

Технология плоттерной печати несколько отличается от обычной. В особенности вникай на http://dpc.en.dn.ua/technologies/plotter_tech/techbase.htm.

СИСТЕМЫ ОХЛАЖДЕНИЯ (www.3dnews.ru/cooling/ohlazhdenie)

Описаны технологии охлаждения процессоров. Рассмотрены физические аспекты охлаждения, сравниваются существующие и перспективные методы охлаждения.

О теории охлаждения также смотри на www.ixbt.com/cpu.shtml#cooltheory. А по адресу www.ferra.ru/online/supply ты найдешь кучу инфы по оригинальным способам снижения шума кулеров и экстремальному охлаждению процессоров.

СКАНЕР (www.digitalware.ru/static/dwScanners/index.asp)

Архитектура, строение, виды и типы сканеров - подробно и понятно. Также есть инфа по слайд-сканерам - устройство, особенности работы. Кроме того представлена обширная подборка материалов по технологии сканирования - приемы, настройки, цветокоррекция, улучшение качества.

ОПТОВОЛОКОННЫЕ СЕТИ (www.techno.spb.ru/products/cable_fo)

Здесь ты найдешь полную информацию по строению, составу и характеристикам оптоволокна, описаны особенности различных типов кабелей. Есть описания оборудования и технологии работы.

На www.sonet.ru/papers.html?papers_tree_CurrentElement=2&CurrentVendor=0 ты сможешь ознакомиться поподробнее с математическими и физическими принципами работы оптоволокна, спецификацией, а также с технологией его сварки.

FLASH-ПАМЯТЬ (http://i2r.rusfund.ru/static/354/out_12405.shtml)

Представлено подробное строение и техническое описание работы flash-памяти. На www.hpc.ru/lib/arts/1318 достаточно подробно описана история развития flash-памяти, а также технические описания основных ее форматов: PC Card, Compact Flash и другие.

GPRS (www.alloplus.ru/main.html?t=31)

Характеристики GPRS, технические аспекты и возможности. Тут ты узнаешь про состав, используемое оборудование и принципы работы GPRS. Подробно описано ядро протокола, рассмотрен стек протоколов.

На www.protocols.ru ты сможешь ознакомиться со спецификацией протокола (в pdf-формате).

GPS (www.gpsinfo.ru)

Много материала по технологии спутниковых навигационных систем. Строение GPS, структура, принципы работы. Устройство и технические характеристики GPS-приемников. Много статей по практическому применению приемников и обзоры всевозможных GPS-девайсов.

На www.glonass-center.ru находится сайт научно-информационного центра ГЛОНАСС, российского эквивалента американской GPS, весьма интересно.

НЕЙРОННЫЕ СЕТИ (http://generation6.narod.ru)

Много статей по теории и архитектуре современных нейросетей. Рассмотрены наиболее популярные архитектуры нейросетей, области их применения. Впечатляет наличие исходников программных реализаций и эмуляторов нейронных сетей. Представлена информация по практической реализации нейросетей.


Спецвыпуск Xakep, номер #034, стр. 034-110-3, УМНЫЕ ЛИНКИ

УМНЫЕ ЛИНКИ

Елманов Олег (SpyDr@comail.ru)

Спецвыпуск Xakep, номер #034, стр. 034-110-3

В качестве дополнительного ресурса советую http://vlasov.chat.ru. А на сайте www.module.ru смотри подробное описание строения, архитектуры и технологии работы российского нейропроцессора NM6403.

MPEG 4 (www.mpeg-4.ru/articles)

Описание стандарта, технология, практическое применение, нюансы, возникающие при работе. Можно поживиться последними версиями разнообразных плееров и кодеков.

Законодатель мод поселился по адресу www.chiariglione.org/mpeg/standards.htm, где можно найти техническое описание формата, почитать рабочие документы и разнообразную документацию. Информация представлена по всем существующим форматам mpeg.

BLUETOOTH (www.bluetooth.com)

Первоисточник, содержит кучу инфы по технологии стандарта bluetooth. Представлена общая схема построения работы данного стандарта, области его применения. Дано подробное описание спецификации, размещена подробная техническая документация по протоколам bluetooth. Там же ты найдешь примеры устройств с bluetooth-адаптером и много технологических решений на основе этого стандарта.

А на www.ferra.ru/online/networks можно на родном языке почерпнуть инфу о bluetooth-технологии, истории, спецификациях и сравнительных характеристиках bluetooth-устройств.

ТЕХНОЛОГИЯ DVD (www.planetdvd.ru/?home=dvdall)

На сайте залежи информации о технологии работы DVD, существующих стандартах, их особенностях. Что такое региональное кодирование и как с ним бороться, существующие методы защиты от копирования DVD-дисков. Есть описание стандартов DVD-R дисков и специфики их использования.

По адресу http://dv.com.ua/category/?cat=1 смотри основные аспекты работы и применения DVD, а также склад программных декодеров и других программ для работы с DVD.


Спецвыпуск Xakep, номер #034, стр. 034-112-1, Glossary - Словарь терминологии

Glossary - Словарь терминологии

Докучаев Дмитрий aka Forb

Спецвыпуск Xakep, номер #034, стр. 034-112-1

(forb@real.xakep.ru)

3D API (Applications Programmer's Interface) – интерфейс трехмерного прикладного программирования - спецификация набора функций, которую должны выдержать разработчики программного обеспечения для совместимости своих программ с соответствующими операционными системами. Его поддержка со стороны операционных систем Win9x и WinNT осуществляется набором программ Direct 3D различных версий, а также определяется наличием соответствующего 3D-ускорителя.

BlueTooth (голубой зуб) - технология, международный стандарт для беспроводных коммуникаций малого радиуса действия, давно и широко рекламируется как одна из наиболее многообещающих технологических новинок среди устройств для мобильных коммуникаций. Основное назначение “голубого зуба” - обеспечение экономичной (с точки зрения потребляемого питания) и дешевой радиосвязи между различными типами электронных устройств, причем немалое значение придается компактности электронных компонентов, что дает возможность применять Bluetooth в малогабаритных устройствах размером с наручные часы.

CDMA (Code Division Multiple Access) - принципиально иной, чем GSM (TDMA - Time Division Multiple Access), стандарт сотовой связи. Принцип его заключается в расширении спектра исходного информационного сигнала, которое может производиться двумя различными методами. Сигнал как бы "размазан" по полосе частот, благодаря этому мощность его на порядок меньше, чем в TDMA, где используются несколько узких полос. Разработан компанией Motorola и используется в “шумопонижающих” и “помехозащитных” целях. Первоначально использовался американскими военными.

Dolby – лаборатория, основанная в 1965 году в Лондоне американским инженером Рэем Долби (Ray Dolby) с целью создания систем шумоподавления для улучшения качества звука. Сейчас известна благодаря своим технологиям многоканального "пространственного" звука, создающего "эффект присутствия". Ощутить этот эффект можно как в специально оборудованном кинозале, так и в собственной квартире при наличии соответствующего оборудования.

EPROM (Erasable Programmable Read Only Memory) – вид электронной памяти, которая была основана на МОП (металл-оксид-полупроводник) транзисторах. Запись данных в ячейки такого транзистора производилась методом лавинной инжекции заряда. Этот метод давал возможность неоднократно перезаписывать данные памяти (хотя количество циклов было ограниченным).

GPRS (General Packet Radio Service) - технология пакетной передачи данных по радиосетям, позволяющая осуществлять скоростную и экономичную передачу данных с помощью мобильного телефона, оставляя при этом возможность одновременно принимать и совершать звонки, а также отправлять SMS-сообщения. Главное преимущество перед CSD (Curcuit Switched Data) - стандартной технологией передачи данных в сетях GSM - высокая скорость, пакетная коммутация, т.е. ты будешь всегда on-line через собственный мобильник, оплата по трафику.

GSM (Global System for Mobile Communications - глобальная система мобильной связи) – самый популярный стандарт сотовой связи второго поколения, основанный на технологии TDMA. Имеет частоты диапазона 900 МГц (в большинстве стран), 1800 МГц в Европе, и 1900 МГц в США.


Спецвыпуск Xakep, номер #034, стр. 034-112-2, Glossary - Словарь терминологии

Glossary - Словарь терминологии

Докучаев Дмитрий aka Forb

Спецвыпуск Xakep, номер #034, стр. 034-112-2

IP-телефония – сервис, под которым понимается технология, позволяющая использовать интернет или любую другую IP-сеть в качестве средства организации и ведения международных и междугородных телефонных разговоров и передачи факсов в режиме реального времени. IP-телефония является одним из наиболее сложных и системных приложений компьютерной телефонии.

MMS (Multimedia Messaging Service) - сервис передачи сообщений при помощи мобильного телефона, очень похожий на сервис SMS (Short Message Service), который позволяет передавать только текстовые сообщения. Технология MMS обеспечивает автоматическую мгновенную передачу личных мультимедийных сообщений с телефона на телефон или с телефона на адрес электронной почты. В работе используется протокол WAP и технология GPRS.

SD-Card – самый новый формат Flash-памяти, который был предложен компанией Matushita в 2000 году. В SD-Flash принципиально улучшена пластиковая оболочка, которая способна стойко переносить даже электрические разряды.

SMS (Служба коротких сообщений) - сервис, предоставляемый цифровым стандартом GSM. В рамках этой услуги связи абоненты могут обмениваться буквенно-цифровыми и текстовыми сообщениями в объеме до 160 знаков. Передача коротких сообщений может быть использована в чрезвычайных ситуациях или в случае перегрузки каналов речевой связи. Тарифы на передачу "коротких сообщений" значительно ниже тарифов речевой связи, поэтому данный сервис приобрел большую популярность.

Wi-Fi (Wireless Fidelity) - один из форматов передачи цифровых данных по радиоканалам, а точнее, стандарт IEEE 802.11, или просто 802.11. Вообще говоря, под числом 802.11 скрывается целое семейство стандартов: на текущий момент их восемь, а конкретно за "передачу данных" отвечают три: 802.11a, 802.11b, 802.11g. Второй в обиходе чаще всего и именуется Wi-Fi.

Алгоритм сжатия MPEG (Compression algorithm MPEG) – основной метод сжатия видеофайлов. При применении MPEG-алгоритма специальные средства позволяют при сжатии текущего кадра включать ссылки на части изображения, оставшегося неизменным от предыдущего кадра. Основной его задачей является определение вектора движения, то есть основного направления, в котором происходят изменения. Для этого на различных этапах выполнения алгоритма могут использоваться операции сравнения, а также предсказания назад и вперед, осреднения блоков и т.д.

Биометрическая идентификация – новый метод опознания подлинности по индивидуальным биологическим признакам человека – отпечаткам пальцев, глазному дну, радужной оболочке, почерку, голосу и т.п. Имеет весомое преимущество перед остальными методами, потому как, применяя биометрию, можно отказаться от различных паролей и ключей.

Виртуальная реальность - совокупность средств, позволяющих создать у человека иллюзию того, что он находится в искусственно созданном мире, путем подмены обычного восприятия окружающей действительности (с помощью органов чувств) информацией, генерируемой компьютером. Это достигается использованием трехмерной графики и специальных устройств вывода информации, имитирующих привычную связь человека с окружающим миром.


Спецвыпуск Xakep, номер #034, стр. 034-112-3, Glossary - Словарь терминологии

Glossary - Словарь терминологии

Докучаев Дмитрий aka Forb

Спецвыпуск Xakep, номер #034, стр. 034-112-3

Голограмма (holos - полный и grapho - запись) полное трехмерное изображение предмета, которое создается специальными лазерами. Голографические технологии применяются, как правило, для защиты продукции, микросхем, документов и ценных бумаг.

Литий-полимерный (Li-Pol) аккумулятор – совершенно новый вид батареи на рынке мобильных телефонов. Полные параметры аккумулятора пока не разглашаются, но известно, что он является лучшим среди всех аккумуляторов.

МВС-1000М – кластерная система, которая была запущена в России в 2000 году. Система состоит из двухпроцессорных вычислительных узлов на базе системных плат UP2000, процессоров Alpha 21264 с тактовой частотой 667 МГц и кеш-памятью второго уровня 4 Мб. На каждом узле установлена оперативная память объемом 1 Гб и жесткий диск. Узлы работают под управлением ОС RedHat Linux и связаны между собой коммуникационной сетью Myrinet. В качестве управляющей сети используется Fast Ethernet.

Система электронных платежей – сервис, предоставляемый пользователям интернета, который помогает произвести оплату товара в интернет-магазине и различных услуг в иных местах. Примером такой системы является Webmoney (Россия) и PayPal (США).

Степень контрастности фотоизображения (Gamma) - характеризует нелинейное воспроизведение яркости изображения. Глаз менее чувствителен к яркости изображения при больших уровнях освещенности, чем при низких. Мониторы реагируют на это обратным образом: при удвоении видеосигнала световой поток на выходе увеличивается примерно в шесть раз. Коррекция степени контрастности дает возможность устранить разницу между тем, как яркость изображения воспринимается глазом и устройствами для съемки, воспроизведения или получения выходных изображений.

Технологии плазменных панелей – принципиально новые разработки, в основе которых лежит свечение специальных люминофоров при воздействии на них ультрафиолетового излучения, возникающее при электрическом разряде в среде сильно разреженного газа. Яркость каждого элемента изображения определяется временем свечения соответствующей "ячейки" плазменной панели.

Электронные чернила – особый вид “чернил”, представляющий собой суспензию из черных и белых микрочастиц размером 1-5 мкм. Эта жидкость имеет вид застывшей капли взвеси диоксида титана в расплавленном полиэтилене. Такими чернилами можно писать на специальных электронных дисплеях. Технология производства E-Ink довольно новая, поэтому ее широкое внедрение планируется лишь в 2005 году.


Спецвыпуск Xakep, номер #034, стр. 034-114-1, Цифровые двухмегапиксельные мыльницы!

Цифровые двухмегапиксельные мыльницы!

test_lab (test_lab@gameland.ru)

Спецвыпуск Xakep, номер #034, стр. 034-114-1

test_lab благодарит компанию USN (т. 775-8202) за предоставленное оборудование.

CANON PowerShot A60 ($275)

CASIO Exilim EX-S2 ($282)

Fujifilm FinePix A200 ($207)

Minolta DiMAGE E223 ($219)

NIKON Coolpix 2000 ($237)

OLYMPUS C-150 ($176)

ROVERSHOT RS-2120 ($127)

Цифровые мыльницы постепенно входят в нашу жизнь, их цена становится все более разумной при неплохом качестве. Еще в прошлом году мы тестили струйные фотопринтеры и выяснили, что с двухмегапиксельной камеры можно печатать на фотобумаге на формат А4 с качеством, практически неотличимым от 35-мм пленки. Непрофессионалы не отличат. Маленькие форматы, типа 9Х13 или 10Х15, вообще печатаются идеально. Мы считаем, что для домашнего использования 2 мегапиксела сейчас в самый раз, и для подтверждения сделали этот тест!

Объектив

Лучше, конечно, брать камеру с зум-объективом, иначе тебе придется бегать туда-сюда, чтобы лучше кадрировать изображение. Автофокусный объектив лучше, чем фиксированный. Фиксированный фокус снимает быстрее, поскольку не тратит время на фокусировку, но он настроен на бесконечность. Объектив с диафрагмой F2.8 предпочтительнее, чем F9. F2.8 пропускает больше света, а значит, можно сделать выдержку короче. F9 пропускает меньше света, значит, выдержка длиннее и изображение движущегося объекта будет смазанным!

Лучше брать объектив, у которого минимальное расстояние до объекта в норме меньше, потому что ты будешь много снимать людей в городе и помещении, а там места обычно мало (46 см лучше, чем 80 см). То же касается и макросъемки: чем ближе можно приблизить объектив к мелкому предмету, тем лучше сможешь его разглядеть (5 см лучше, чем 20 см). Тебе нужен объектив, у которого угол охвата пошире, это также связано со съемкой в городе и в квартире, ведь пространство как коробочка, и хочется охватить все. Поэтому фокусное расстояние должно быть меньше (36 мм лучше, чем 48 мм) в пересчете на 35-миллиметровую пленку. Если у тебя объектив с зумом, то максимальное фокусное расстояние, наоборот, должно быть больше (114 мм лучше, чем 105 мм, хотя несущественно).

Функции

Коррекция экспозиции меняет количество света, попадающего на матрицу, то есть в автоматическом режиме меняются значения диафрагмы и выдержки. Ты можешь сделать изображение потемнее или посветлее, а камера сама все рассчитает. Если ты хочешь смазать изображение или, наоборот, остановить момент, тебе понадобится функция «приоритет выдержки». Когда ты ставишь нужную выдержку, камера считает диафрагму автоматически. Если ты хочешь сделать размытым/четким фон, то нужно играться с диафрагмой («приоритет диафрагмы»), а камера посчитает выдержку. Ну и, наконец, есть полностью ручной режим, когда ты сам ставишь выдержку и диафрагму, а камера тебе подсказывает. Для тех, кто не хочет с этим разбираться, есть готовые автоматические программы: ночная съемка, съемка быстродвижущихся объектов (спорт), съемка портрета, съемка пейзажа. Ты просто выбираешь нужную ситуацию колесиком режимов или меню, а камера сама выставляет нужную диафрагму и выдержку.

Баланс белого нужен для того, чтобы цвета выглядели естественно – синие рожи перепивших друзей были синими, а лица подружек зелеными, а не наоборот. У любой камеры есть автомат. Но ты можешь задать условия съемки: солнечно, пасмурно, лампа дневного света, желтая лампа. В некоторых продвинутых камерах можно вручную настроить баланс белого по белому листу.


Спецвыпуск Xakep, номер #034, стр. 034-114-2, Цифровые двухмегапиксельные мыльницы!

Цифровые двухмегапиксельные мыльницы!

test_lab (test_lab@gameland.ru)

Спецвыпуск Xakep, номер #034, стр. 034-114-2

Чувствительность ISO в пересчете на 35-мм пленку тебе понадобится менять, если ты собрался бороться с шумами/смазанностями. Тут пригодится и 50 единиц, и 400. Главное, чтобы можно было вручную ее менять. Хотя обычно достаточно 100 единиц.

К сожалению, подключить внешнюю вспышку ни к одной из камер этого класса, как и к мыльницам, нельзя. Так что остается только играться с настройками слабой встроенной вспышки. Будь готов к тому, что встроенная вспышка охватит не более 2-4 метров от камеры.

Canon PowerShot A60 (выбор редакции, $275)

Объектив норма: 46см

Объектив макро: 5см

Зум: 35 мм-105 мм (3х)

Диафрагма: F2.8-F4.8

Разрешение: 1600x1200

Чувствительность ISO: 50, 100, 200, 400

Память: 16 Мб Compact Flash (CF)

Самая функциональная камера в нашем обзоре для опытных фотолюбителей. Новичок, скорее всего, запутается в многочисленных настройках. Есть, конечно, и автоматические режимы – программы. Есть полуавтоматические – приоритет выдержки, диафрагмы, ручной. Кнопки и менюшка оптимальны для человека понимающего. А вот ламер сразу утонет в полупрофессиональных настройках.

У Canon PowerShot A60 есть ручка, которая отлично ложиться в руку. В ручку вставляются четыре пальчиковых батареи, благодаря чему камера неплохо сбалансирована.

Большинством настроек можно управлять с помощью кнопок, не влезая в меню. Рядом с дисплеем имеется переключатель воспроизведение/съемка, а регулировка зума расположена на кнопке спуска.

Эта камера за свою цену обладает просто космическими возможностями! Если ты пользуешься дисплеем, то камера выделяет области, на которых сфокусировалась, зеленой рамочкой, чтобы фокус был там, где тебе нужно. А если тебе этого недостаточно, то есть ручная фокусировка и ручной баланс белого. Есть подсветка автофокуса, для более точного наведения в темноте! Чувствительность можно выставить до ISO 400. Можно даже вручную регулировать мощность вспышки!

Кнопка FUNC вызывает функциональное меню, через которое можно быстро получить доступ к нужным настройкам.

Можешь снимать панорамы, при этом кусок снятого изображения подсвечивается, чтобы ты мог нормально совместить куски панорамы. Есть фотоэффекты сепия, черно-белый и т.п. Имеется пластмассовый байонет - это такая резьба, с помощью которой ты можешь крепить насадки на объектив. Жаль только, внешнюю вспышку нельзя подключить, и неудобно сделана резьба под штатив.

К фотам можно добавлять голосовые комментарии. Для этого в корпус встроены микрофон и динамик, а в комплекте шнур с видео и аудиовыходами, через которые можно смотреть фото/видео и слушать записи на телевизоре. Можно менять картинку и звук начальной заставки, звуки нажатия кнопок, затвора, автоспуска. Отдельна батарейка «таблетка» нужна для того, чтобы при доставании основных батареек АА не сбрасывался календарь! Видоискатель темноват. Экран бликует и легко пылится. Зато есть жесткая коробочка для памяти и русская инструкция немереных размеров. Canon PowerShot A60 не определяется как USB-диск, требует установки дров. В комплекте идет ПО ArcSoft Digital Camera Suite v1.2.


Спецвыпуск Xakep, номер #034, стр. 034-114-3, Цифровые двухмегапиксельные мыльницы!

Цифровые двухмегапиксельные мыльницы!

test_lab (test_lab@gameland.ru)

Спецвыпуск Xakep, номер #034, стр. 034-114-3

CASIO Exilim EX-S2 ($282)

Объектив норма: 80 см

Объектив макро: нет

Зум: 35-мм (нет)

Диафрагма: F4.2

Разрешение: 1600x1200

Чувствительность ISO: 100

Память: 12 Мб встроено, Secure Digital (SD), MultiMediaCard (MMC)

Самый компактный фотик в обзоре, его можно везде таскать с собой в кармане рубашки, поскольку он тоньше спичечного коробка. Жаль только, нет чехла и на объективе нет защитной шторки. Единственная камера с литий-ионным аккумулятором и зарядным устройством. Все остальные камеры комплектуются щелочными батарейками типа АА. Аккумулятор похож на батарею от сотового телефона. Он заряжается, когда ты ставишь CASIO Exilim EX-S2 на док-станцию, через которую заодно скачиваются фотки в комп. То есть пришел с прогулки – поставил заряжаться, заодно можешь фоты скачать с появившегося USB-диска. Единственная сложность с док-станцией - это резиновая заглушка на разъеме камеры, которая может потеряться. То есть прежде чем заряжать аккумулятор/качать фотки, придется отковырять резиновую заглушку, а потом засунуть ее назад (если не потеряешь).

Все настройки реализованы через менюшку (что весьма геморройно), среди них: автоспуск, ручной баланс белого, коррекция экспозиции, программы съемки и вспышек. Есть цифровой зум.

Режим запись/воспроизведение меняется переключателем, но группу фоток посмотреть нельзя. Джойстик нажимается, что при таких размерах фотоаппарата не очень удобно. Хотя есть большие любители нажимающихся джойстиков.

Объектив не автофокусный без макрорежима. Книжные страницы снимать, конечно, можно, но на расстоянии 80 сантиметров, что не очень клево. Удивительно, но даже у такой маленькой камеры есть оптический видоискатель, что позволяет существенно экономить заряд батарейки. CASIO Exilim EX-S2 единственная камера, которая гасит экран после нажатия на спуск. Все остальные камеры, наоборот, показывают на несколько секунд отснятую фотку, чтобы ты смог прикинуть, как все получилось.

Родственная модель - CASIO Exilim EX-M2 снабжена микрофоном и аудиовыходом для записи и проигрывания звука, а также встроенным mp3-плеером. У CASIO Exilim EX-S2 таких наворотов, естественно, нет, но в менюшке есть эти настройки, которые только мешают!

На корпусе камеры нет видеовыхода и входа под питание – чем-то приходится жертвовать ради компактности. В комплекте диск с прогами Photo Loader ver. 2.1 и Photohands ver. 1.0.

Fujifilm FinePix A200 ($207)

Объектив норма: 80 см

Объектив макро: 8 см

Зум: 36 мм (фиксированный)

Диафрагма: F4.6

Разрешение: 1600x1200

Чувствительность ISO: 100

Память: 16 Мб xD-Picture Card

Одна из самых легких камер в обзоре, кажется, что пустая!

Можно установить дату и время. Есть только цифровой зум, но его можно юзать только с монитором, через оптический видоискатель зума, естественно, не видно. Кстати, видоискатель очень удобный - большой и светлый, однако разметку (прицел) практически не видно. Рядом с видоискателем лампочка, которая показывает, что питание включено. Камера удобно врубается переключателем.


Спецвыпуск Xakep, номер #034, стр. 034-114-4, Цифровые двухмегапиксельные мыльницы!

Цифровые двухмегапиксельные мыльницы!

test_lab (test_lab@gameland.ru)

Спецвыпуск Xakep, номер #034, стр. 034-114-4

Кнопка «дисплей» включает монитор, этой же кнопкой можно разбить дисплей на зоны (с помощью специальной сетки), чтобы было удобнее кадрировать изображение. После каждого снимка на несколько секунд показывает картинку, чтобы ты видел, что получилось. При просмотре фоток умеет показывать группу картинок.

Режим просмотра, съемки и видео переключается прикольным рычагом. Пишет видео 320Х240 (1,5 минуты) либо 160Х120 (5 минут) без звука. Видеовыхода нет, зато есть вход для внешнего питания и USB-вход. Умеет зумить цифровым зумом во время записи видео.

В комплекте идет 16-меговая xD-Picture Card, на которую в нормальном качестве влезает 39 фоток, а в высоком 25, причем при выборе качества в меню показывается, сколько фоток влезет при каждой настройке.

Вспышку можно отключить или включить принудительно, есть режим защиты от красных глаз. Есть таймер съемки. В ручном режиме есть коррекция экспозиции, программы баланса белого. Меню очень удобное.

Объектив темный, без автофокуса, два положения: макро и бесконечность. Fujifilm FinePix A200 хавает всего две пальчиковых батарейки, причем она не прожорлива и отлично работала с севшими элементами питания.

Когда подрубаешь к компу, чтобы слить фотки, не определяется как USB-диск. Чтобы слить фоты, придется ставить дрова! Инструкция только на английском языке. Можно юзать для интернет-конференций.

Minolta DiMAGE E223 ($219)

Объектив норма: 60 см

Объектив макро: 8 см

Зум: 38 мм-114 мм(3х)

Диафрагма: F2.9-F3.0

Разрешение: 1600x1200

Чувствительность ISO: 100

Память: 8 Мб встроено, Secure Digital (SD), MultiMediaCard (MMC)

Одна из самых крупных и тяжелых камер в обзоре. Не очень удобно включается кнопкой, зато есть хорошие кнопочки коррекции экспозиции. Легко выбирается баланс белого. Светосильный объектив выезжает, но защищен шторкой от залапывания разными мутантами, которые тянут свои щупальца со словами: «О, какая камера! Дай посмотреть!» Трехкратный оптический и трехкратный цифровой зум. Увеличение переключается прикольной кнопкой-качалкой. Есть специальная цапа для выключения дисплея. Видоискатель маленький и темный. Есть несколько режимов вспышки.

Вспышка, коррекция экспозиции и баланс белого доступны через кнопочки, а вот остальные настройки можно включить, только порывшись в меню через «сетап» (это довольно гиморно).

Minolta DiMAGE E223 пишет видео со звуком и воспроизводит со звуком через встроенный динамик, а вот шнур почему-то только на видео, аудио нет. Меню не очень удобное, хотя переключение режимов можно сделать прикольным колесом. Несколько тормозно записывает и считывает фотки.

В комплекте идет диск, на котором куча инструкций к цифровым и пленочным камерам Minolta (среди них есть и к Minolta DiMAGE E223) на русском языке. Но бумажной инструкции нет, что сильно затруднит освоение камеры! Очень странно включаются программы, надо выбрать таймер и только потом переключать программы кнопками – это неочевидно. То есть не каждый способен додуматься без инструкции, что оказывается, под кнопкой «таймер» скрываются программы. В комплекте идет ПО: DIMAGE image Viewer Utility с возможностью коррекции фоток. При подключении Minolta DiMAGE E223 определяется как USB-диск. Одна из самых прожорливых камер, высасывает две батареи AA в момент!


Спецвыпуск Xakep, номер #034, стр. 034-114-5, Цифровые двухмегапиксельные мыльницы!

Цифровые двухмегапиксельные мыльницы!

test_lab (test_lab@gameland.ru)

Спецвыпуск Xakep, номер #034, стр. 034-114-5

NIKON Coolpix 2000 (лучшая покупка, $237)

Объектив норма: n/a

Объектив макро: n/a

Зум: 38 мм-114 мм (3х)

Диафрагма: F2.8-F4.9

Разрешение: 1632x1224

Чувствительность ISO: 50, 100, 150

Память: 8 Мб Compact Flash (CF)

Один из самых удобных фотиков для новичка! Все простые автофункции фотоаппарата доступны через кнопки, а настройки, требующие дополнительных знаний, глубоко зарыты в меню. То есть камера для тех, кто хочет нажимать на кнопку спуска и не заморачиваться со сложными настройками. При этом, конечно, не проблема выставить на колесике программу съемки, типа: портрет, ночная съемка, быстрое движение, пейзаж и т.д. Имеются также кнопки включения макрорежима, выбора программы вспышки, таймера, быстрого просмотра отснятых фот. Ты быстро научишься разбираться с кнопочками, а если захочется больше – нужно лезть в меню, которое несколько гиморно из-за большого количества шагов. Там ты найдешь ручную установку баланса белого, несколько типов замера экспозиции, пакетную съемку (когда щелкается подряд несколько кадров), Best Shot Selector (когда камера делает подряд несколько снимков, а потом выбирает несмазанные и их записывает), коррекция экспозиции, шарпенинг (когда изображение делается более жестким).

При подключении к компу NIKON Coolpix 2000 определяется как USB-драйв. В комплекте прога Nikon View 5.1.2, плакат на английском языке (помогающий быстро разобраться в кнопочках) и инструкция на русском. Видеошнур позволяет показывать фотки на телике, когда компа рядом нет.

8-мегабайтная стартовая флешка не очень радует, так как на нее влезает всего 16 снимков в нормальном качестве с разрешением 1632Х1224. В NIKON Coolpix 2000 вставляются четыре пальчиковых батарейки, что делает его довольно тяжелым. Однако эта камера достаточно экономична. К сожалению, отсутствует оптический видоискатель, потому фоткать можно только при включенном дисплее.

Olympus C-150 ($176)

Объектив норма: 50 см

Объектив макро: 20 см

Зум: 35 мм (нет)

Диафрагма: F2.8-F5.6

Разрешение: 1600x1200

Чувствительность ISO: 100, 200

Память: 16 Мб xD-Picture Card

А это цифровой аналог компактного пленочного фотоаппарата Olympus u-II. Стоит он, конечно, на 50 зеленых президентов дороже, но и умеет намного больше, чем пленочная мыльница!

Так же как у пленочной мыльницы, объектив Olympus C-150 защищен футляром. Объектив автофокусный, но его отличительная черта – наличие макрорежима! Вряд ли ты найдешь пленочную мыльницу, способную фоткать мелкие объекты с расстояния 20 см.

Можно установить программы для съемки. Как и на пленке, есть программы вспышки и таймер. И как у большинства цифровых фотиков, имеются программы баланса белого и коррекция экспозиции, а также возможность снимать короткие видеоролики без звука.


Спецвыпуск Xakep, номер #034, стр. 034-114-6, Цифровые двухмегапиксельные мыльницы!

Цифровые двухмегапиксельные мыльницы!

test_lab (test_lab@gameland.ru)

Спецвыпуск Xakep, номер #034, стр. 034-114-6

Кнопочек на камере немного, все настройки только через меню. С помощью одних и тех же кнопок можно управлять цифровым зумом, либо группировать уже отснятые фотки, рассматривать их с увеличением.

Как и на большинстве автофокусных аппаратов, нажатие на кнопку до половины – фокусировка, полностью – съемка. Рядом с оптическим видоискателем два индикатора – фокусировка и зарядка вспышки. При просмотре отснятого материала можно посмотреть краткое инфо о фотках, а также изменить размер (если места не хватает) или наложить фильтр на изображение! Можно снимать две фоты в одной и панорамные снимки.

Olympus C-150 отличается средней прожорливостью и заботливо предупреждает юзера пищанием (как радиотелефон), когда батареи садятся. Фотик очень легкий, в нем всего две батарейки АА. Есть видеовыход, вход под питало. 16-меговая xD-Picture Card определяется как USB-драйв в составе камеры. В комплекте нет русской инструкции, зато есть плакат на английском, обучающий использованию камеры. В комплекте также CAMEDIA Master 4.1 (прога с зачатками Фотошопа).

ROVERSHOT RS-2120 ($127)

Объектив норма: 80 см

Объектив макро: 20 см

Зум: 48 мм (нет)

Диафрагма: F3.3

Разрешение: 1600x1200

Чувствительность ISO: 100

Память: 8 Мб встроено, Secure Digital (SD), MultiMediaCard (MMC)

Самая доступная камера в нашем обзоре. Стоит примерно столько же, сколько и дорогая пленочная мыльница. Но умеет, как и любой цифровой фотоаппарат, конечно, гораздо больше, чем пленка. Объектив не с постоянной фокусировкой (неавтофокусный), однако макрорежим есть (включается рычажком). К сожалению, объектив ничем не защищен, то есть, нет ни крышки, ни защитной шторки, зато в комплекте есть мягкий чехольчик для фотоаппарата!

Удобное колесико переключает режимы: видео, ручной, автоматический, просмотр. Несмотря на доступность камеры, есть много очень полезных функций: пакетная съемка (когда несколько кадров щелкаются подряд), есть программы вспышек, есть черно-белый режим (если ты хочешь фоткать книжки в библиотеке), есть коррекция экспозиции. Цифровой зум пытается заменить оптический.

Правда, когда снимается видео, цифровое увеличение не работает. Видеокамера пишет со звуком с помощью встроенного микрофона. Потом умеет проигрывать его через встроенный динамик. Но к телевизору почему-то можно подключить только видеошнур с видеовыходом, аудиовыхода (чтобы проигрывать звук через динамики телевизора) нет.

Питало включается не очень удобно, т.к. надо давить на кнопку. Меню среднее, но с надписями вместо значков, так что учи английский.

Батареи вставляются неудобно (странные обозначения полярности), все время засовываешь их наоборот. Сильно жрет батарейки. Одна из самых крупных камер в обзоре. Зато камера определяется как USB-диск.

В комплекте есть русская инструкция и прога MGI Photosuite 4 SE.

Выводы

Цифровые мыльницы серьезно двигают пленочные. Причем самая слабая цифровая легко делает пленочную за счет того, что можно сразу посмотреть, как получились фотки. Большинством цифровых мыльниц можно снимать мелкие предметы в режиме макро, чему пленочные мыльницы не научатся никогда. На любом цифровом фотике имеется куча серьезных настроек, типа баланса белого и коррекции экспозиции. А некоторые, типа Canon A60, демонстрируют навороты (типа ручной фокусировки, изменения мощности вспышки и других ручных настроек), доступные только полупрофессиональным пленочным камерам. Если ты любишь показывать фотки друзьям и родне, у которых нет компа, то показывай их на экране телевизора (почти у каждой цифровой мыльницы есть видеовыход и шнур с тюльпаном под телевизор). Словом, цифровые двухмегапиксельные мыльницы стоят в полтора-два раза дороже, чем пленочные, зато умеют раз в 10 больше!


Спецвыпуск Xakep, номер #034, стр. 034-114-7, Цифровые двухмегапиксельные мыльницы!

Цифровые двухмегапиксельные мыльницы!

test_lab (test_lab@gameland.ru)

Спецвыпуск Xakep, номер #034, стр. 034-114-7

PS: Не забудь купить к своему цифровому фотику адаптер питания или зарядное устройство с аккумуляторами, чтобы камера не пылилась в углу из-за отсутствия батареек!


Спецвыпуск Xakep, номер #034, стр. 034-118-1, Графическая станция USN LEONARDO

Графическая станция USN LEONARDO

test_lab (test_lab@gameland.ru)

Спецвыпуск Xakep, номер #034, стр. 034-118-1

test_lab благодарит компанию USN (т. 775-8202) за предоставленное оборудование.

Сегодня на нашем хирургическом столе графическая станция USN LEONARDO. Почему на хирургическом? Да потому что раздраконим, как всегда, до органов, до комплектующих то есть. Выпотрошим станцию как надо, чтобы всем сразу стало понятно, с чем ее едят!

Снаружи мы видим корпус Thermaltake: Xaser II 6000 Silver, изготовленный практически целиком из алюминия. Cнаружи торчит контроллер скорости вращения вентиляторов с индикатором температуры и портами USB 2.0 и FireWire (IEEE 1394). С помощью переключателя можно пытаться бороться с шумом, при этом глядя на градусник, не перегрелись ли потроха. Люди, часто работающие с графикой, признают расположение разъемов очень удобным. Подумай сам: ставишь ты на крышу корпуса цифровую фотокамеру и переносной винчестер, а потом подключаешь их к компу через USB и FireWire интерфейсы. Передняя панель с дверью, которая закрывается на замочек от детей, родни, либо от недобросовестных коллег, чтобы никто не вздумал лезть со своими дисками в твой комп или перезагружать его. За дверью три больших установочных места 5,25” и два маленьких под дисководы или универсальные флешридеры.

Легким движением руки снимаем боковую панель, она, кстати, тоже запирается на замочек. Панель непрозрачная с вентилятором, который обдувает видеокарту и PCI-устройства. И что же мы видим? Провода аккуратно собраны, так что воздух циркулирует нормально. Сразу бросается в глаза Serial ATA винчестер Seagate 3 120026AS Barracuda 7200.7. Этот винт дает большое преимущество по случайному времени доступа (RAT – Random Access Time) благодаря своему интерфейсу SATA 150 и 8-меговому буферу. Ты сразу это заметишь при копировании большого количества небольших файлов или при верстке видео или большой иллюстрированной книжки (если у тебя в верстальной программе висит много страниц с картинками). Единственный минус - Seagate 3 120026AS Barracuda 7200.7 греется неслабо, хорошо, что рядом с ним предусмотрительно поставили большой вентилятор.

Далее взгляд упирается в Matrox Parhelia-512 Triplehead (128MB DDR). Нельзя сказать, что это игровая карта. ATI Radon 8500 или nVidia GeForce4 Ti 4200 в играх ее сделают. В графическую станцию ее поставили благодаря одновременной поддержке трех мониторов и высокому качеству работы с 2D. Ведь на больших профессиональных графических мониторах, работающих на высоких разрешениях, четкость изображения упирается в видеоадаптер. Причем речь идет именно об электроннолучевых мониторах, три LCD через DVI к этой видеокарте не подключишь (только два), однако профессиональные дизайнеры пока не признают LCD-мониторы из-за корявой цветопередачи. О Matrox Parhelia-512 можно долго спорить, так что если тебе интересно, почитай о нем в интернете: (www.ixbt.com/video2/parhelia-p1.shtml).

Системная плата Gigabyte GA-8IPE1000 на продвинутом чипсете Intel i865PE вместе с боксовым процом Pentium-4 2.4C выжимают 800 Мегагерц на шине! Более старые процы и матери тянут всего 533 смехагерца. Память тоже не подкачала - работает в дуальном режиме. То есть два модуля DDR400 по 512 метров выдают 800 Мегагерц на шине памяти! При этом остаются два свободных DDR-слота, видимо, в надежде на скорый upgrade до двух гигов оперативки. Память производства SEC (Samsung), так что можно не опасаться глюков. Мы бы все-таки поставили четыре планки по 256 метров или сразу четыре по 512. Тем более что производитель оставляет такую возможность. Такая организация триады проц-чипсет-память заточена под ресурсоемкие операции, типа разархивирования большого количества данных. Или обработку огромных графических файлов навороченными фильтрами в фотошопе. В современных играх прирост частоты «шина/память» (от 533/333 к 800/800) разницы практически не дает.


Спецвыпуск Xakep, номер #034, стр. 034-118-2, Графическая станция USN LEONARDO

Графическая станция USN LEONARDO

test_lab (test_lab@gameland.ru)

Спецвыпуск Xakep, номер #034, стр. 034-118-2

Теперь вернемся к корпусу: 360W блок питания обеспечит стабильную работу. И, внимание: внутри ПЯТЬ (!) вентиляторов! Два на задней панели, два на передней и один на боковой панели. Правда, крутятся они с частотой всего лишь 1800 оборотов в минуту, поэтому шума от них не больше, чем от обычного ATX-блока. Зато такая система позволяет буквально ПРОДУВАТЬ системный блок. А если еще учесть, что имеется ручная система регулирования активности вентиляторов, то можно не бояться за свои уши.

Выводы

USN LEONARDO – мощный компьютер, рассчитанный на оптимальную работу с гигантскими объемами двухмерной графики. Он весьма специфичен, поскольку заточен под нужды 2D-профи. Рекомендуем, прежде всего, для верстки и фотошопа, игрушки на втором плане (только в свободное от работы время).


Спецвыпуск Xakep, номер #034, стр. 034-120-1, Не будите Арагорна

Не будите Арагорна

Niro

Спецвыпуск Xakep, номер #034, стр. 034-120-1

День начался очень удачно – Кирилл умудрился спихнуть лоховатому покупателю неплохую комплектацию, пристроив внутрь бэушный винчестер, который попросил перепродать один из хороших знакомых. Пересчитав деньги после ухода крайне довольного обладателя новенького “Целика”, он с видимым наслаждением засунул в карман своих джинсов двадцать баксов.

Опустившись во вращающееся кресло за кассовым аппаратом, он положил руки на клавиатуру, запустил “Контру”. Судя по реакции, где-то в недрах мастерской через пару дверей отсюда встрепенулся дремавший с глубокого пивного бодуна Шишок – он умело, несмотря на постоянную тошноту и головную боль, подключился к игре, брякнул пару идиотских острот в своем стиле и недолго думая погиб на первых же шагах. Кирилл улыбнулся – Шишок всегда был с бодуна (пиво он любил чуть меньше, чем компьютеры), всегда погибал самым первым, но, тем не менее, играть с ним было интересно; если парню удавалось избежать прицельного огня, то его действия порой отличались непредсказуемостью, умением грамотно мыслить и удачно работать в паре.

Игра сегодня как-то не особенно захватывала Кирилла; деньги в кармане стимулировали пораньше уйти с работы, оставив за себя кого-нибудь из технической группы. Он несколько раз поймал себя на том, что смотрит на часы не то с сожалением, не то с нетерпением. Когда его убили в тринадцатый раз, он без всяких угрызений совести отключился, бросив напарника где-то рядом с кучей «терроров», и крикнул так, чтобы тот услышал его в своем закутке:

- Шишок, давай сюда, ты мне нужен!

Что-то громко скрипнуло, хлопнула дверь. Иван Шишкин ввалился - другого слова подобрать было нельзя – к Кириллу в офис с чашкой горячего кофе. На шее у него непонятно зачем висела «мышка».

Слова застряли в горле у Кирилла, едва он увидел этот болтающийся девайс. Сразу полезли на ум всякие пошлости, гадости и черный юмор. Кирилл развел руками и указал на кресло рядом с собой – на то, в котором обычно сидели покупатели в момент составления заказа.

Иван опустился в кресло с размаху – руками он за подлокотники хвататься не стал по непонятным соображениям, поэтому просто хлопнулся сверху, словно хотел раздавить в кресле какого-то мерзкого клопа. Стойка жалобно скрипнула, зашипел воздух. Чашка кофе опустилась прямо на свежую пачку прайсов, оставив на верхнем листе мокрый коричневый круг.

Кирилл прокашлялся – хотя будто могло быть иначе… Нет, с Шишком так всегда, его даже не старались выдергивать поближе к обществу из глубины сборочного цеха. Парень, которому от роду было лет шестнадцать-семнадцать (ну, в крайнем случае, возраста почти призывного), постоянно оставался крайне неряшливым, неумытым-непричесанным; во время еды всегда чавкал, как поросенок, чай втягивал из чашки с таким свистом, что рядом просто страшно было находиться; его джинсы не знали утюга и «Ариэля», волосы оставляли желать лучшего (хотя бы расчески)… Короче, контрольный выстрел три раза в день после еды еще мог каким-то образом спасти общество от этого морального урода, если бы не… Если бы не его феноменальное «чутье железа».


Спецвыпуск Xakep, номер #034, стр. 034-120-2, Не будите Арагорна

Не будите Арагорна

Niro

Спецвыпуск Xakep, номер #034, стр. 034-120-2

Парень собирал компьютеры так… Трудно подобрать нужные эпитеты. Если бы все так делали детей, как он компы – с любовью, умом, чуткостью и вниманием, то, черт возьми, общество, в котором мы сейчас живем, заметно отличалось бы в положительную сторону. Знаете, как часто говорят: «Да он с закрытыми глазами…» Вот чушь собачья! Не надо с закрытыми, ты открой их – и делай, как Шишок!

- Короче, чувак, - начал Кирилл, когда все эти мысли в одно мгновенье пронеслись у него в голове. – Во-первых, сейчас эта чашка полетит тебе в башку. Во-вторых… Вот, правильно, убери, подложи болваночку, я тут как раз одну запорол… В третьих, будем жить по принципу “Партия, дай порулить!” Порулить хочешь?

- Чем? - спросил Шишок. Кирилл на пару мгновений засомневался в своих желаниях. Может, не стоит? Но желание уйти было сильнее голоса разума:

- Конторой, - коротко бросил он.

Шишок взял кофе, отхлебнул; потом закинул “мыша” за спину, будто шарфик, и кивнул.

- Свалить надо? - спросил он у Кирилла. - А шеф?..

- Шеф не появится, - успокоил Кирилл. - Он где-то за городом, на вилле некоего представителя могущественной расы бизнесменов... Короче, на стрелке он. Деньги делят. Или делают.

Шишок кивнул так, как кивают люди однозначно “посвященные” - легонько, снисходительно, с едва заметной усмешкой. Это он умел – сделать вид, что знает гораздо больше, чем другие. И очень многие, не умея соотнести его жутковатый образ едва ли не бомжа с этой самой усмешкой, создавали о нем неверное представление... Кирилл пропустил сей факт мимо своего сознания, ибо привык к нему до невозможности. Главное было настроить Шишка на работу.

- Понимаешь, Иван, - Кирилл так хотел уйти с работы, что готов был даже вспомнить имя Шишка, - ты у меня на доверии... Да не только у меня, у всех, кто здесь работает... И у шефа...

Врал он беззастенчиво, потому что цель была великой – и эта цель по имени Наташка должна была его ждать сегодня возле института ровно через сорок минут. И если на Шишкина времени будет потрачено мало, то на метро он успевал. Почти.

- У меня – так уж получилось – сегодня очень важное дело. Настолько важное, что даже сам шеф, я думаю, проникся бы его срочностью и нужностью (чего бы еще брякнуть для важности?..). Я должен... Просто обязан уйти, - вспомнив фигуру Наташки, добавил он. - До конца рабочего дня еще почти полтора часа. Ты за сегодня собрал четыре неплохих компа под заказ, да еще штук шесть или семь готовых – на всякий случай. Ты славно потрудился (господи, что я несу!..). Было бы неплохо, если бы ты подменил меня здесь, за столом менеджера. Случись что, ты и консультацию грамотную можешь дать, и комп готовый принесешь.

Шишок, периодически поднося ко рту свой кофе, со свистом втягивал обжигающий напиток (Кирилла этот звук заставлял вздрагивать всем телом). Он будто бы не замечал, что можно обжечь губы и язык; он вообще никогда не дул на горячее, перенося его со спартанским хладнокровием. Короче, в этом человеке странностей было гораздо больше, чем можно было себе представить.


Спецвыпуск Xakep, номер #034, стр. 034-120-3, Не будите Арагорна

Не будите Арагорна

Niro

Спецвыпуск Xakep, номер #034, стр. 034-120-3

- Вот тебе ключ от сейфа, - внутренне содрогаясь от того, что делает, Кирилл протянул Шишкину брелок. – Печати внутри. Вот ключик от кассового аппарата… Но ты лучше, если будет возможность, чек не пробивай, скажешь, пусть придут завтра с утра – если кому надо.

Очередной свистящий глоток кофе. Отрыжка. Кирилл немного отклонился в сторону – он словно видел вылетевшее изо рта Шишка облачко чего-то вонючего и мерзопакостного. Когда это «что-то» его, скорее всего, миновало, Кирилл принял прежнее положение и проследил за тем, как ключи исчезли у Ивана в нагрудном кармане необъятной жилетки «Made In China».

Все. Приговор подписан. Случись что – не отмоешься. Но кто не рискует – тот не пьет шампанского. Кирилл вздохнул, опустил руку на плечо Ивана, хотел что-то сказать, но не нашел нужных слов и, молча кивнув, вышел, притворив за собой дверь.

Шишок, будто ничего и не произошло, продолжал методично отхлебывать из чашки постепенно остывающий напиток. Со стороны могло показаться, что он просто не заметил, как остался один.

Постепенно чашка опустела. Шишок стрельнул по сторонам глазами и снова опустил ее на испачканные прайс-листы. «Мышка» соскользнула с шеи на пол.

- «…щас полетит в башку!» Ой, напугал, - без особой интонации повторил слова Кирилла Шишок. Прозвучало это как в анекдоте – «Пусть я сопля зеленая, зато живым остался». Сам Иван тоже спустя несколько секунд сообразил, что выглядит не лучшим образом, убрал чашку в раковину, три верхних листа из стопки прайсов смял и выкинул в корзину для бумаг. Потом медленно, заложив руки за спину, зашагал вдоль стеклянных витрин со всякой мелочевкой типа картриджей, «мышек», болванок, мультимедии и книжек по «1С».

- Фигня все это, Кирилл Андреевич, - свысока глядя на разложенные по полочкам девайсы, нравоучительным тоном произнес Шишок. – Вот у меня в сборочной – другое дело…

Пройдя подобным образом вдоль всех витрин несколько раз и убедившись в полной бессмысленности существования Кирилла как человека, ни разу не испытавшего кайфа от погружения процессора в гнездо, Шишок вернулся в кресло и попытался возобновить предательским образом брошенную игру, но тут случилось именно то, чего боялся Кирилл, покидая рабочее место.

В контору вошли трое. Мама, папа и сыночек лет двенадцати от роду. Этакие Дурсли из небезызвестного “Гарри Поттера”. Иван, особо не жаловавший кинозалы, этот фильм не пропустил. По непонятным причинам (непонятным для сотрудников конторы, которые были несказанно удивлены) он сходил на обе части этого фильма по три раза. Что он пытался там разглядеть, осталось для всех загадкой – но факт есть факт. Трижды за время проката каждого блокбастера он разглядывал приключения этого идиота-очкарика, каждый раз делясь впечатлениями с окружающими, словно видел все это впервые. Все уже знали содержание наиболее понравившихся Ивану диалогов, были наслышаны о его пристрастиях в плане ролей, актеров, сцен и спецэффектов. Кое-кто стал поговаривать, что Шишок непонятным образом подзаряжался интеллектом от этой довольно бестолковой сказки, поскольку человек, которого в жизни интересовали только книги по сборке и модернизации компьютера, внезапно начинал говорить длинными удобоваримыми фразами, правильно употребляя падежи и переставая при этом грызть ногти. А уж если Шишок прекращал это свое суперзанятие, которому отдавался с хрустом и причмокиванием целиком и полностью все свободное время – то о воспитательном влиянии Гарри Поттера на Ивана Шишкина можно было писать докторскую диссертацию. По психологии олигофренов.


Спецвыпуск Xakep, номер #034, стр. 034-120-4, Не будите Арагорна

Не будите Арагорна

Niro

Спецвыпуск Xakep, номер #034, стр. 034-120-4

Итак, они вошли. Отец еще с порога грозным взглядом окинул довольно большое помещение конторы, оценивающе покачал головой и пихнул сына вперед. Тот просто вылетел на середину комнаты и в ужасе замер. Шишку захотелось заглянуть ему за спину – он на сто два процента был уверен, что там прячется поросячий хвостик.

- Ну, - коротко и сурово сказала мать. Мальчишка напрягся так, будто от дверей сейчас должен был прилететь подзатыльник. - Ты в этом понимаешь побольше нас с отцом. Надеюсь, что у тебя хватит ума выбрать что-нибудь подобающее твоим мозгам в двенадцатилетнем возрасте.

“Насчет возраста угадал”, - подумалось Шишку. Он медленно нащупал под столом снятые кроссовки (в очередной раз напоминая себе поменять носки, из огромных дырок в которых торчали большие пальцы) и уже мысленно потирал ладони, представляя, как завтра утрет нос Кириллу, небрежно выложив тому на стол долларов эдак семьсот-восемьсот. “Вот, понимаешь, вчера в твое отсутствие удачную сделку провернул...”

Мальчишка, шмыгнув носом, осторожно протянул руку к прайсам, взял верхний листик, бросил быстрый взгляд исподлобья на Ивана и погрузился в чтение. Губы медленно шевелились, произнося, как заклинания, названия комплектующих. Отец приблизился к сыну, заглянул через плечо в прайс, потом взял второй из стопки и махнул жене:

- Думаю, тебе тоже должно быть интересно, - и необычайно увлеченно принялся так же, как сын, шептать себе под нос – но на этот раз цены. Пауза, прерываемая покашливанием отца семейства, временами натыкающегося в тексте прайс-листа на суммы, не вписывающиеся в его понимание проблемы, затягивалась.

Шишок встал из-за стола, отошел к окну. Бормотание за спиной его мало интересовало. Обычно люди, плохо знакомые с предметом, выбирали то, что просто нельзя было совместить в корпусе по причине полной непереносимости одних деталей другими. Уткнувшись лбом в стену возле оконной рамы, Иван раздвинул вертикальные жалюзи, которые Кирилл опустил для лучшей контрастности на «жидком» мониторе. Открылся неплохой вид на огромную круглосуточную автостоянку.

Шишок любил смотреть на автомобили, когда не было работы. У него никогда не было своего средства передвижения (кроме велосипеда в детстве), но он особенно не комплексовал по этому поводу – просто его всегда радовали совершенные формы и целесообразность. Так же, как он разбирался в гигагерцах и мегабайтах, он запросто различал «Тойоту-Карину» и «Тойоту-Короллу», не заглядывая на серебристые буквы на багажнике (чего не могли сделать большинство его знакомых, видевших во всем этом «нечто на колесах»). Количество «лошадей» под капотом тоже не было для него секретом – как он безо всякого труда помнил назначение всех джамперов на материнских платах последних поколений, так и двигатели самых перспективных автомобилей были разложены по ярусам в его узконаправленном техническом мозгу.


Спецвыпуск Xakep, номер #034, стр. 034-120-5, Не будите Арагорна

Не будите Арагорна

Niro

Спецвыпуск Xakep, номер #034, стр. 034-120-5

Вот и сегодня он отметил появление возле крайней правой прожекторной стойки двух новеньких сияющих «Ауди» угольно-черного цвета. Еще без номеров, с белыми транзитными прямоугольниками за стеклами, они производили впечатление марсианских зондов. Даже с расстояния в шестьдесят-семьдесят метров Шишок был абсолютно уверен в шикарной отделке приборной панели – красным деревом с лаковой полировкой.

«Живут же люди…» - засвербела тоскливая мысль. Даже такому человеку, как Шишок, волей судьбы загнавшему себе в специфические профессиональные рамки (и не жалевшего об этом), было грустно сознавать подобные вещи. Иван потерся лбом о стену, вспомнил, что не заплачено за квартиру (причем уже два месяца) – и в этот момент его тронул за плечо Дурсль-младший.

Шишок повернулся и увидел в его глазах такую тоску, что мальчишку сразу стало жалко. Судя по всему, он явно не представлял себе, что хочет.

- Ну, - спросил он у родителей, поднявших на него глаза с нескрываемым недоверием, - какой компьютер вам нужен?

- Подешевле, - моментально среагировала мать. Сын втянул голову в плечи.

- Хм… - отец почувствовал, что так можно упасть в глазах продавца. – Не так уж чтобы очень…

Жена дернула его за рукав; он смутился и тут же отыгрался на сыне:

- Ну, а ты, оболтус, что скажешь?! Шел сюда, так хоть спросил бы у друзей в школе – может, они бы посоветовали что…

- Да я спрашивал, - попытался возразить пацан, мечтавший только об одном – скорее бы все это кончилось. И в этот момент за окном завыли «сигналки» - сразу несколько, практически в унисон. Шишок машинально отвернулся от покупателей и взглянул на стоянку. И тут же неприятно заныли скулы.

Те две «Ауди»… Их «хрустальные» огромные фары, их лобовые стекла – все было разбито вдребезги. На сверкающих зеркальных капотах были видны огромные вмятины, наталкивающие на мысль о взрыве и бородатых ваххабитах, ползущих сейчас в сторону компьютерного магазина, чтобы сравнять его с землей. Но ладно машины… В нескольких метрах от них стоял на коленях охранник (Шишок догадался по униформе и по резиновой дубинке, лежащей в паре шагов от него). Ладони его были плотно прижаты к лицу. Он раскачивался из стороны в сторону все сильнее, сильнее… Через несколько секунд он упал набок, руки ослабели и открыли лицо...

Шишок отшатнулся от окна и повернулся к покупателям. Увидев его глаза, женщина сделала несколько шагов к двери. Отец машинально встал между ней и Иваном, потом, ничего не понимая, попытался заглянуть через плечо Шишкина на улицу. Увиденное потрясло его.

- Его убили?! – чуть не крича, всплеснул он руками, отодвинул Шишка в сторону и, чтобы было лучше видно, растянул в сторону полосы жалюзи. – Надо вызвать милицию! Где телефон?


Спецвыпуск Xakep, номер #034, стр. 034-120-6, Не будите Арагорна

Не будите Арагорна

Niro

Спецвыпуск Xakep, номер #034, стр. 034-120-6

Шишок понял, что уже не владеет ситуацией. Завтра не придется говорить Кириллу об удачной сделке, не придется хвастаться вырученными долларами – да и вряд ли еще представится подобная возможность…

Тем временем мужчина трясущимися руками набирал номер, а его сын, забыв о компьютерах и раскрыв рот, смотрел на стоянку. Шишок тоже вернулся к созерцанию происходящего и увидел то, чего не заметил сразу – из-за дальнего «Ауди» были видны ноги лежащего на земле второго человека в камуфляже – еще одного охранника. Судя по неподвижности фигуры, этому пострадавшему тоже было несладко.

- Что же это такое? – прошептал Иван себе под нос, прижавшись к стене спиной.

- Алле! – орал в трубку мужчина. – Черт подери, алле! Что здесь за ерунда? – крикнул он Шишку; тот наклонил голову набок и равнодушно ответил:

- Через восьмерку…

Вновь запикали озвученные кнопки телефона. Шишок взглянул в сторону стоянки еще раз и убедился в том, что виновника всего происходящего не видно – тот, кто это сделал, быстро исчез из поля зрения.

Мальчишка тем временем прижался к матери, шепотом объясняя ей то, что он увидел и указывая на окно. Шишок отметил про себя, что звонок у отца не получался – что-то не клеилось на том конце провода, что-то не ладилось на наших суперсовременных телефонных линиях, выходящих из строя от обычного дождика. Нервная барабанная дробь, которую выбивали ногти отца по столу, не давала Ивану сосредоточиться, мешала принять какое-то решение.

Внезапно вой сигнализаций на стоянке стих – и стало ясно, что все продолжалось не больше минуты-двух, хотя сумбур, воцарившийся в умах присутствующих, тянул на пару часов какого-то террористического кошмара. И эта внезапно наступившая тишина за окном заставила всех замереть там, где они стояли – мужчина не донес телефонную трубку до аппарата, на который хотел ее швырнуть в гневе, его жена раскрыла рот в немом вопросе. Мальчишка сделал жест пальцами правой руки, что-то из дворового жаргона было готово сорваться с его языка – да так и замер с открытым ртом.

Шишок громко икнул, чем нарушил навалившуюся тишину. На него посмотрели так, будто этим звуком он мог навлечь на всех вокруг себя Гнев Господень. Иван боялся выглянуть в окно; боялся увидеть там нечто, могущее ввергнуть его в шок. Он вообще не переносил вида крови, а сегодня понял это окончательно и бесповоротно. Не впервые в жизни он видел рядом с собой чье-то физическое страдание, чью-то боль, жестокость, непонятный вандализм… Для его семнадцати с половиной лет – слишком уж много.

На лестнице, ведущей в контору, раздались шаги – медленные, уверенные. Бум, бум, бум – гудела металлическая лестница. Первый этаж, второй… Оставались еще пара десятков ступенек и площадка перед дверью.

Шишок почему-то сразу понял, что это возвращается Кирилл. Да просто больше некому было прийти сейчас сюда, только главному менеджеру. Наверное, что-то там у него обломилось, в его важном, срочном и заочно одобренном боссом деле – вот он и решил вернуться. Сейчас он войдет – и все сразу встанет на свои места, он дозвонится куда нужно, сделает что нужно. Кирилл всегда решал проблемы быстро, играючи – у него был талант обходить подводные камни, мели и рифы, наводить мосты, соединять несоединимое и договариваться с теми, с кем можно было договориться только со стволом в руках.


Спецвыпуск Xakep, номер #034, стр. 034-120-7, Не будите Арагорна

Не будите Арагорна

Niro

Спецвыпуск Xakep, номер #034, стр. 034-120-7

Шесть… Пять… Четыре… У мужчины в такт шагам стал подергиваться угол рта. Три… Два… Один… Тишина. Потом шорох перед дверью и звук, который разрушил ту идиллию, что пыталась воцариться в мозгу Ивана – звон металла. Что-то клацнуло там, на площадке, и отзвук долго и протяжно пытался исчезнуть, и все не мог, не мог… Потом дверь распахнулась – как-то сразу, внезапно. Вот она еще закрыта – а вот уже ветер ворвался в контору, шум улицы, далекий лай собаки…

На пороге возник человек. Едва увидев его, женщина, стоявшая в нескольких шагах от входа, ближе всех к вновь прибывшему, вскрикнула, шарахнулась в сторону и, зацепившись за большую коробку, упала между столами. Сын кинулся к ней, но остановился под тяжелым взглядом гостя. Шишок ощутил волнение где-то под коленками, слабость и желание провалиться сквозь землю – и чем глубже, тем лучше.

С глухим звуком упала на аппарат телефонная трубка.

Человек сделал шаг внутрь и закрыл за собой дверь.

- Мерзкие гоблины! – прошипел он сквозь зубы и красиво описал круг своим огромным сверкающим мечом, возникшим откуда-то из-за спины. Гудение воздуха заставило волну мурашек пробежать по спине Шишка; захотелось сесть на пол.

- А вы, собственно… кто? – попытался взять инициативу в свои руки мужчина, глупо и абсолютно неестественно задав этот вопрос. Голос дрожал; к жене он почему-то не кинулся.

Человек, словно не услышав вопроса, медленно сделал еще два шага, вонзил острие в пол и огляделся. Во время возникшей паузы Шишок сумел рассмотреть гостя.

Высокий мужчина, около двух метров, на голову выше Ивана; длинные волнистые неухоженные волосы схвачены тоненьким матерчатым обручем. Растительность на лице оставляла двоякое впечатление – то ли он неделю забывал побриться, то ли это была попытка стать похожим на Антонио Бандераса. Все его мощное, накачанное тело скрывалось под длинным мрачной расцветки плащом. Из-за спины был виден капюшон – большой и, судя по всему, способный выдержать неплохой ливень. На груди плащ был распахнут, под ним виднелась кожаная куртка со шнуровкой. Легкие укороченные сапоги дополняли образ Робин Гуда. Ну и, конечно же, меч. Шишок вряд ли смог бы замахнуться им выше пояса. Размеры были под стать гостю – когда он стоял, уперев острие в пол, рукоять доставала ему до пояса. Лезвие сверкало отполированной рельсовой сталью (ничего другого на ум не приходило – только блестящие в яркий солнечный день рельсы, уходящие за горизонт).

Суровый пронзительный взгляд медленно перемещался по полкам, словно оставляя людей в конторе напоследок. Человек не спешил; он внимательно рассмотрел все, ни одна мелочь не укрылась от его глаз. Губы беззвучно и неторопливо шевелились; пальцы на шарообразном противовесе рукояти периодически разжимались и снова сжимались в напряженный кулак.


Спецвыпуск Xakep, номер #034, стр. 034-120-8, Не будите Арагорна

Не будите Арагорна

Niro

Спецвыпуск Xakep, номер #034, стр. 034-120-8

У его ног тихо заверещала упавшая женщина; она не видела, где стоит вошедший, но чувствовала, что он где-то совсем рядом. Человек с мечом наконец-то позволил себе заметить ее. Он опустил глаза, приподнял меч, продолжая сжимать его крепко, до хруста в пальцах. Шишок напрягся – от макушки до пят его пронизала судорога ужаса.

- Враг близко… - едва слышно сказал человек с мечом. – Не время… Не время…

Острие вошло в пол, как гильотина – коротко, жестко. Каблук одной из туфель женщины срезало, словно бритвой. Еще секунда – и Иван готов был ощутить бегущую по ногам теплую струйку мочи…

Мужчина зачем-то вытянул перед собой руку, словно загораживаясь от этого кошмара с мечом, и попытался что-то сказать, но слова застряли у него в горле; ничего, кроме сиплых звуков, не вылетело из его рта. Он аккуратно обогнул стол, какими-то дурацкими приставными шагами приблизился к сыну и резким движением задвинул его себе за спину.

Тем временем гость остановил свой взгляд на Иване; того словно пригвоздили к стене. Глаза били наотмашь; они проникали куда-то вглубь, в душу, в мозг, в сознание. Сердце колотилось, на лбу выступили крупные капли пота.

- Ты… Неужели ты не узнал меня? – спросил у Ивана человек с мечом.

Шишок отрицательно замотал головой – так часто, что чуть не упал от головокружения. Сам факт того, что он оказался под пристальным вниманием незнакомца, вывел Ивана из зыбкого душевного равновесия; он в ужасе застыл, не отрывая глаз от гостя.

- Я так и думал, - понимающе кивнул тот в ответ на отрицание Ивана. – Судя по всему, ты находишься в услужении у этих поганцев (он кивнул в сторону папы с сыном). Немудрено… Я хочу есть, - внезапно сказал он, словно и не было никакого предисловия. – Накорми своего короля Арагорна.

Шишка будто дубиной по голове ударило. «Кто? Арагорн?.. Что происходит?» – подумал он, разглядывая фигуру, направляющуюся к ближайшему стулу.

Человек опустился на кожаное сиденье охотно принявшего его в свои объятия кресла, вытянул ноги, снял перчатки.

- Не вижу исполнительности, - коротко сказал он, ни к кому конкретно не обращаясь, но Шишок понял, что это было сказано в его адрес. – Или стоит применить силу?

И он внезапно с размаху ударил кулаком по крышке стола. Офисная мебель было явно не готова к подобным испытаниям. Дерево в том месте, куда пришелся удар мощного кулака, хрустнуло и проломилось; несколько папок с бумагами и подставка для печати провалились в образовавшуюся дыру, создав пренеприятный шум. Иван вздрогнул и на пару секунд закрыл глаза.

Он с детства не терпел всяческого насилия и криков, наслушавшись родительских скандалов, с завидным постоянством возникавших на пустом месте в течение многих лет. Были и сломанные столы, и разбитые окна, и выбитые двери… На мгновенье нахлынули воспоминания, затмившие образ Арагорна с мечом. Хруст крышки стола заставил вспомнить то, что было засунуто в самые далекие уголки памяти с грифом «Совершенно секретно!». И Шишку стало ясно, что все это добром не кончится…


Спецвыпуск Xakep, номер #034, стр. 034-120-9, Не будите Арагорна

Не будите Арагорна

Niro

Спецвыпуск Xakep, номер #034, стр. 034-120-9

Он сделал несколько неуверенных шагов к человеку, назвавшемуся Арагорном, вздохнул и сказал:

- Этот стол достаточно дорого стоит… Будете кофе?

Гость кивнул.

- Сахар? Сливки?

Еще пара кивков. Шишок посмотрел на застывшие фигуры отца и сына и коротким кивком указал на сотовый телефон, который виднелся у отца на поясе. Мужчина напрягся на секунду, не понимая, потом проследил взгляд – понял. Шишок собирался пройти мимо него, незаметно взять телефон, чтобы, выйдя с ним в другую комнату за кофе, вызвать наряд милиции.

И ему это почти удалось. Почти – потому что в тот самый момент, когда его рука протянулась к поясу за телефоном, где-то у стены громко всхлипнула женщина, которая так и не нашла в себе силы подняться. Арагорн вздрогнул, посмотрел в ее сторону – и Шишок машинально отдернул руку, опасаясь усугубить ситуацию.

- Стой! – прозвучало от разломанного стола. Иван замер. – Тебе надо выйти отсюда?

Иван кивнул, боясь оглянуться.

- Боюсь, что это сделать не удастся, - сказал Арагорн. – Даже если мне придется остаться голодным.

- А как же Ваш кофе? – осмелился спросить Шишок. – Здесь его нет…

- Я готов потерпеть… - тихо и почти доверительно произнес Арагорн. – Тебе я найду другое занятие.

Мужчина, застывший посреди комнаты, наконец осмелился сделать хоть какое-то движение в сторону своей чертовски напуганной жены. Он подошел к ней и аккуратно помог подняться. Та с трудом держалась на ногах, все время стремясь опереться о батарею отопления. Отсутствие каблука сказывалось – она, пару раз покачнувшись так, что у Ивана сердце в пятки уходило, сняла туфли и в ужасе смотрела на сидящего в кресле человека с мечом.

Тот, казалось, задремал. Шишок, ожидавший каких-то указаний от этого человека, ставшего в настоящий момент хозяином конторы и управляющим умами и эмоциями всех, кто в ней находился, несколько растерялся – никакого «другого занятия» не предлагалось.

Внезапно все присутствовавшие услышали не совсем понятный звук – то ли бормотание, то ли шепот, то ли… Все посмотрели туда, где сидел Арагорн. Он едва заметно шевелил губами, разговаривая с кем-то невидимым; постепенно он повышал голос, некоторые слова становились разборчивыми.

- Я ведь просил… Окно… Вечные сквозняки… А так хотелось отдохнуть… Орочье отродье…

- Мы можем уйти? – прервал это бормотание мужчина, осознавший, что их жизнь находится в опасности и нужно уносить ноги. – Не думаю, что нам всем имеет смысл здесь оставаться…

- А потом наступила ночь… - продолжал общаться с невидимым собеседником Арагорн. – Уйти? – вдруг очнулся он, открыл глаза и взглянул на говорившего.

Тот кивнул. Арагорн огляделся вокруг; потом встал, покрепче обхватил рукоять меча и подошел ближе. Женщина закатила глаза и стала сползать на пол.

- Никто никуда не уйдет, - коротко и жестко ответил он. – Я ведь говорил им всем: «Не будите Арагорна!» Никто никуда не уйдет!

Вернувшись в кресло, он вытянул ноги, скрестив их, вдоль ног положил меч и, вздохнув, сказал:

- Они тоже не хотели ничего понимать… Постоянно требовали… Ну почему всем всегда что-то от меня надо! Сотни лет… Я верно служил – чего скрывать. Верно, честно, преданно. Это знали все. И мой меч – уж он-то знал об этом лучше всех!


Спецвыпуск Xakep, номер #034, стр. 034-120-10, Не будите Арагорна

Не будите Арагорна

Niro

Спецвыпуск Xakep, номер #034, стр. 034-120-10

Он любовно погладил рукоять, поднес меч к губам, подышал на затуманившееся лезвие, аккуратно протер его рукавом.

- Выкованный заново - спасибо гномам - он приобрел новую красоту, новые качества. Слава богу, не так часто мне приходилось пускать его в дело. Зачем они меня разбудили?..

Плохо понимая, о чем говорит Арагорн, Шишок пытался уловить настроение человека с мечом. Где-то внутри включилась стрессовая реакция – очень хотелось остаться целым и невредимым. Ни словом, ни жестом не вызвать негативных последствий для своего здоровья – нужно было только понять, какие мотивы привели сюда этого странного гостя.

Где-то далеко за окном завыла и тут же замолчала милицейская сирена. Арагорн, к этому моменту вновь закрывший глаза, медленно поднял веки, обвел взглядом потолок, прислушиваясь к тому, что происходит на улице. Шишок не сдержался, сухо кашлянул. Пальцы на рукояти меча заметно ослабли, глаза опять закрылись, дыхание стало тише и спокойнее.

Все, кто был в комнате, не сговариваясь, переглянулись. Появился шанс исчезнуть из конторы, не дожидаясь, пока что-нибудь произойдет. Мужчина подтолкнул сына к двери и взглядом показал ему, чтобы тот шел как можно тише и незаметнее.

Мальчишка раскрыл рот, встал на цыпочки и стал осторожно пробираться к выходу. Судя по всему, опыт в делах подобного рода (в смысле ходьбы на цыпочках) у него был большой; он интуитивно выбрал такой путь к двери, чтобы под ногами не скрипнуло покрытие – почти вдоль стены, едва не касаясь ее руками. Мать, придя к этому времени в себя и закрыв рот ладонью, пыталась помочь ему хотя бы взглядом.

Когда до двери осталась всего пара шагов, Шишок поверил, что у того получится. Дверь всегда была хорошо смазана, никогда не издавала никаких щелчков, была деревянной, а соответственно – легкой, и вообще – являла собой идеал двери. Мальчишка взялся за ручку, аккуратно повернул – и столкнулся нос к носу с вошедшим Кириллом.

Менеджер, удрученный тем, что его свидание не состоялось (он прождал свою пассию почти сорок минут, пока не понял, что все-таки опоздал), просто шагнул вперед, легонько отодвинув пацана в сторону, и с грохотом затворил за собой дверь. Он бормотал себе под нос какие-то уничижительные замечания в адрес метрополитена и свой собственный, поэтому не сразу заметил, что в конторе что-то не так.

Арагорн же, напротив, среагировал с завидной скоростью. Его тело взметнулось с кресла в направлении двери, одна рука цепко схватила меч, вторая через секунду уже держала за шею Кирилла. Мальчишка же отлетел вбок, споткнулся о стул и загремел под самое окно.

Кирилл, не понимая, что происходит, ощутил на своей шее чудовищной силы хватку, поднявшую его над полом на несколько сантиметров. Вместо дыхания изо рта вырывался хрип, горло сдавил натянутый до предела воротник. Через несколько секунд верхние пуговицы с треском отлетели, воротник ослаб, и Кирилл шлепнулся на пол. Машинально он постарался отползти в сторону, но острие меча, вонзившееся рядом с его рукой, заставило замереть на месте.


Спецвыпуск Xakep, номер #034, стр. 034-120-11, Не будите Арагорна

Не будите Арагорна

Niro

Спецвыпуск Xakep, номер #034, стр. 034-120-11

- Какого черта?! – прорычал Арагорн, наклонившись к самому полу и дыша смрадом в лицо Кирилла. – Я же прошу – не будите! Не будите! ПРОКЛЯТЫЙ УРУКХАЙ!!!

Он резко выпрямился и быстро оглядел всю контору. Меч словно оказался на свободе, совершив полный круг вместе со своим хозяином. Его острие прошло в нескольких сантиметрах над головой совершенно обезумевшего от внезапно навалившегося кошмара Кирилла, тот пригнулся к полу и затаил дыхание.

- Если бы вы знали, каково это – не спать тысячи лет! – кричал Арагорн, потрясая в воздухе своим огромным мечом. – Если бы вы знали!..

При очередном взмахе кончик меча зацепил стоящий на одной из больших витрин новенький семнадцатидюймовый «жидкий» монитор. Тот покачнулся на подставке, извечный «аквариум» на экране, не миновавший, казалось, ни одного магазина по продаже компьютеров в этом мире, пошел вполне реальными волнами; Шишок машинально сделал шаг к витрине, но он явно не успевал. Монитор качнуло, и он полетел на пол.

Шнур питания, выскакивая из гнезда, издал сухой громкий треск, сопроводив падение неплохим спецэффектом. Шишок успел подумать: «Хорошо, что не стеклянный…» Но, как выяснилось, все еще только начиналось.

Увидев падение монитора, Арагорн на секунду замер и пристально вгляделся в то, что от него осталось. А в следующую секунду он резко развернулся туда, где на столе у Кирилла стоял другой, на этот раз не выставочный, монитор. Обыкновенная «труба» родом оттуда, откуда в нашей стране почти все – из Китая.

Меч красивой серебристой молнией с едва слышным гудением сверкнул в воздухе. Звук удара был глухим, похожим на громкое шуршание. Разрубив монитор пополам, лезвие развалило и стол, на котором он стоял. Арагорна качнуло вслед за мечом, будто силы на мгновение оставили его – судя по всему, он сам не ожидал такого эффекта. Экран разлетелся с противным хрустом, усеяв стеклом пространство в несколько квадратных метров вокруг себя; наружу вывалилось все, что некогда создавало на экране вполне пристойное по качеству изображение. Внутри вспыхнул ворох искр голубоватого цвета, потянуло дымком, взвившимся к потолку.

Выдернув меч из разваленной крышки стола, Арагорн описал им над головой огромный свистящий круг. Нечто, напоминающее хохот, вырвалось из его плотно сжатых губ. И тут женщина, не выдержав, совершила тот самый безумный поступок, ради которого она, наверное, жила всю свою жизнь.

Молча, безо всяких душераздирающих криков и соплей, она внезапно подхватила за руку лежащего рядом с ней сына, за долю секунды преодолела четыре больших шага, отделяющих ее от двери (даже не пытаясь при этом поставить сына на ноги), рывком распахнула дверь, швырнула туда ребенка (килограмм тридцать пять, не меньше), после чего сама выскочила на площадку.

Арагорн опоздал даже не на секунду, нет - на пару ее шагов. Он еще радовался своей глупой победе над китайским монитором, когда женщина уже выталкивала сына на свободу. Арагорн четко определил, где дверь (несмотря на то, что стоял к ней спиной) и с разворота дал мечу волю. Тот вырвался из его рук, словно живое существо – на коротком «Ха!..». Лезвие, направленное точно в дверь, устремилось в нужном направлении. В дерево оно вошло, как в воду – никто даже не услышал удара. Войдя в дверь на полметра, меч остановил свой смертоносный полет.


Спецвыпуск Xakep, номер #034, стр. 034-120-12, Не будите Арагорна

Не будите Арагорна

Niro

Спецвыпуск Xakep, номер #034, стр. 034-120-12

Мужчина коротко вскрикнул – то ли от страха, то ли от неожиданности. Мужчины вообще всегда долго выбирают варианты, женщины же руководствуются импульсом. Пока он рассуждал, как спасти себя и свою семью, жена сделала это за него. Где-то снаружи по лестнице загрохотали шаги – спотыкающиеся, торопливые; раздался то ли плач, то ли смех, несколько громких всхлипов. Потом все стихло.

В конторе повисла тяжелая, гнетущая пауза. Все, не отрываясь, смотрели на крестовину колышущегося в двери меча. Кадр был эффектным. Все молчали – потому что поняли, что по лестнице сейчас спустился ОДИН человек. Второй…

Арагорн первым вышел из ступора. Он подошел к двери, замер перед ней на некоторое время, а потом внезапно, не притрагиваясь к мечу, ударил ногой чуть пониже замка. Створка распахнулась, словно подхваченная сильным ветром. Все – и Шишок, и лежащий на полу Кирилл, и отец мальчика – все вытянули шеи, каждый со своего места, чтобы увидеть, что же там, на лестнице…

Там никого не было. Площадка перед конторой была пуста.

Арагорн хмыкнул, разочарованный. Шишок нервно переступил с ноги на ногу, хрустнуло стекло, рассыпанное, казалось, везде, где только можно. Кирилл медленно поднялся – сначала на одно колено, потер шею, потом встал во весь рост и бросил взгляд на Ивана. Тот одними губами шепнул:

- «Норд-Ост»…

Кирилл кивнул и тут же нащупал на поясе мобильник. Шишок поднес палец к губам – нажимать кнопки было опасно.

Арагорн же, скорчивший гримасу крайнего неудовольствия тем, что за дверью никого не было, взялся за ручку двери и затворил ее, после чего положил обе ладони на рукоять меча и, с шумом выдохнув, дернул его на себя.

Когда взорам всех присутствующих показалась та часть меча, что была снаружи, все поняли, что с ней что-то не так – какие-то полосы, розовый «зайчик»… А потом за дверью что-то с шумом упало – что-то очень напомнившее всем…

Мужчина закричал и кинулся на Арагорна с кулаками.

Тот успел еще повращать головой, разминая уставшие мышцы шеи, после чего очень точным движением сменил направление движения меча, продемонстрировав искусство владения холодным оружием. Оказавшись каким-то образом сбоку от нападавшего, он вроде бы ничего и не сделал – но мужчина на бегу сломался, согнулся пополам, обняв руками живот, и так и пробежал мимо Арагорна, упав у двери. Хватая воздух ртом, он очень быстро умер, даже не успев осознать, что так и не отомстил.

Когда такие вещи происходят у тебя на глазах – трудно оставаться равнодушным. Шишок вдруг понял, что уже совсем скоро или выпрыгнет с третьего этажа, или просто обделается здесь, как полугодовалый малыш от некачественного детского питания. Он оперся рукой о витрину. В ушах предательски зашумело, весь мир вдруг стал зеленым, далеким, ни единого звука не долетало до Ивана.


Спецвыпуск Xakep, номер #034, стр. 034-120-13, Не будите Арагорна

Не будите Арагорна

Niro

Спецвыпуск Xakep, номер #034, стр. 034-120-13

Внезапно в мозг застучалась мысль – что с ним будет, если он потеряет сознание? Вдруг этот безумный Арагорн добьет упавшего одним ударом? Шишок ущипнул себя за руку; боль немного отрезвила его, заставила зелень отступить.

И в этот момент зазвонил телефон. Громко, требовательно, настойчиво. Никто не рискнул сделать к нему первый шаг, ибо это было чревато нежелательными последствиями для здоровья.

Кирилл и Шишок были уверены, что звонит какой-нибудь потенциальный покупатель, стремящийся получить справку о будущей покупке. Но после двадцатого звонка они поняли, что тот, кто находится на том конце провода, каким-то неведомым образом посвящен в ситуацию, происходящую сейчас здесь. И этот кто-то жаждал поговорить с теми, кто еще остался в живых.

Глядя на телефон, все словно вступили в молчаливое соглашение друг с другом – никто не подходит, и это не осложняет им жизнь. Так бывает, когда хочется, чтобы проблемы не существовало – как дети накрываются с головой одеялом, чтобы избавиться от видений в темном коридоре. Но как ни отворачивайся от проблемы, решать ее все равно придется. Арагорн кивнул Ивану – мол, давай, поговори.

Шишок подошел к телефону и с замирающим сердцем поднял трубку.

- Да, - произнес он и тут же закашлялся; слова с трудом вылетали из глотки сквозь тугой комок страха.

- Очень рад слышать хоть кого-нибудь живого, - раздался в ответ уверенный мужской голос. – Я думаю, что вам имеет смысл передать трубку тому самому человеку, который представился Арагорном. Передайте ему, что это Саруман. Но предварительно скажите – сколько вас там и есть ли раненые?

Шишок скосил глаза на Арагорна, потом быстро шепнул:

- Нас тут двое… И еще двое тяжело ранены (он не смог произнести «убиты»). И один…

- Я знаю, - оборвал Шишка человек. – Мальчик здесь, у нас. Как понимаю, проблемы - с его родителями?

Шишок кивнул, потом понял, что надо сказать вслух, а еще через секунду догадался, что его молчание красноречивее любого ответа. Он просто протянул трубку человеку в плаще, отстраняясь в сторону:

- Это вас. Какой-то Саруман… Возьмите, пожалуйста.

Арагорн скрипнул зубами, со скрежетом вложил меч в ножны и подошел к Ивану. Парень не выдержал нервного напряжения и не стал дожидаться, когда тот возьмет трубку у него из рук – положил ее на стол и отошел на несколько шагов. Теплая трубка удобно легла в ладонь Арагорна.

- Я здесь, - бросил он собеседнику. В трубке раздалось далекое бормотание. Арагорн слушал абсолютно неподвижно, время от времени изменяя только направление взгляда. Казалось, время в конторе остановилось.

Голос в трубке был вкрадчивым, он что-то неторопливо выговаривал Арагорну, будто журил непослушного сына за детские шалости. Кирилл и Шишок ждали, что Арагорн скажет что-нибудь в ответ, но тот молчал, впитывая поток красноречия собеседника, словно губка.

Саруман говорил, говорил, говорил не переставая. По интонациям, которые можно было различить в речи, обращенной к Арагорну, было ясно, что никаких вопросов тому не задавалось. Человеку с мечом читали нотацию, объявляли выговор, чего-то требовали, констатировали какие-то факты…


Спецвыпуск Xakep, номер #034, стр. 034-120-14, Не будите Арагорна

Не будите Арагорна

Niro

Спецвыпуск Xakep, номер #034, стр. 034-120-14

И спустя пару минут подобного одностороннего общения Шишок заметил, что с Арагорном происходит что-то странное – черты его лица разгладились, из глаз исчез блеск ненависти, левая рука, постоянно лежавшая на противовесе, расслабилась и повисла вдоль туловища. Иван стал прислушиваться, стараясь понять, чему посвящен монолог, оказывающий такое странное воздействие на Арагорна. И он услышал:

- Теперь мы не только дню радоваться будем… Кончились наши страхи!.. Отдал ему свой скипетр… двинулось вверх по улицам, и все небо расцвело звездами… Так Арагорн, Великий Князь Элессар, обручился с Арвен… И кончилась их долгая разлука, и сбылись…

«Что это? – подумал Иван, пытаясь понять, о чем говорит тот, кто назвал себя Саруманом. – Какой скипетр? Кому отдал?»

Арагорн нашарил рядом с собой стол, оперся на него свободной рукой, будто силы покидали его. Но трубку от уха он не убирал, словно она была намертво приклеена. Голос продолжал говорить о каких-то неведомых Шишку людях, о событиях в их жизни, играя непонятными красивыми именами и названиями. Довольно скоро слух Ивана настроился точно на этот монолог, и Шишок не упускал ни слова.

- Запомни мои слова: если вызреет его плод, все до единого семена должны быть высажены… Род Нимлота куда древнее твоего, Государь Элессар…

Рядом с Иваном что-то скрипнуло. Шишок невольно скосил глаза в сторону, ненадолго отвлекся и посмотрел на Кирилла. Тот опустился на стул, уронил голову на руки и спал, как младенец, некрасиво выпятив губы и пуская слюни себе на рукава. Веки его были немного приоткрыты, казалось, он спит с открытыми глазами. Иван прислушался к своему собственному внутреннему состоянию.

Спать не хотелось, несмотря на то, что вкрадчивый голос Сарумана проникал куда-то в самую сущность мозга. Арагорн медленно опускался на пол (рядом с ним ни одного стула не оказалось), цепко держась за край стола, но пальцы постепенно теряли силу, разжимались. В какой-то момент он не удержался, упал на колени; меч клацнул в ножнах. Неизвестный, приковавший внимание Арагорна к своей речи, по-прежнему заставлял его вслушиваться в свои слова.

На улице в этот момент тоже что-то происходило. На фоне сумерек за окном были видны отблески сирен множества милицейских машин, взявших контору и прилегающую к ней автостоянку в полукольцо. Бесшумность этих цветных росчерков была жутковатой, но Шишок был им крайне рад. Там, на улице, была помощь – и кто-то, назвавшись Саруманом, очень грамотно и профессионально приводил в действие программу освобождения заложников при помощи загадочного способа.

Кирилл коротко всхрапнул. Арагорн не заметил этого, даже бровью не повел. Мир для него уменьшился до размеров телефонной трубки. Зрачки закатились, оставив только белки глаз; Ивану было жутко на это смотреть, но он не мог отвести взгляд – человека, впавшего в транс от загадочного разговора по телефону, он видел впервые. Да вообще все, что случилось здесь сегодня, было с ним впервые; и он надеялся, что это никогда больше не повторится, дай бог, чтобы сегодня закончилось благополучно.


Спецвыпуск Xakep, номер #034, стр. 034-120-15, Не будите Арагорна

Не будите Арагорна

Niro

Спецвыпуск Xakep, номер #034, стр. 034-120-15

Секунд через двадцать разговор Арагорна с собеседником закончился сам собой; он привалился спиной к стене, склонив голову на грудь, и тяжело задышал, как человек, которому снится что-то неприятное, но избавиться от этого нет никакой возможности. Судя по всему, монолог Сарумана продолжался у него во сне; он два или три раза шепнул это имя.

Трубка повисла на проводе возле спящего Арагорна. Гудков отбоя в ней не было слышно. Шишок осмелел и, подойдя на цыпочках к столу, подтянул ее за шнур и прижал к уху.

Голос возник внезапно, будто человек, говоривший до этого с Арагорном, знал, что трубка в руках у Ивана.

- Я вас очень прошу – НЕ БУДИТЕ АРАГОРНА, - требовательно сказал «Саруман». – Только это спасет вам жизнь. Посмотрите на потолок.

Шишок поднял глаза. Над головой, ворвавшись в окно, плясал красный зайчик лазерного целеуказателя.

- С вами ничего не случится. Если есть возможность – отойдите куда-нибудь в сторону, спрячьтесь… - успокаивающе повторил «Саруман». – Дайте нам возможность войти и забрать его. Только ни в коем случае не будите… Иначе – возможно все.

Раздумывать было некогда. Подойдя к Кириллу и легонько тронув того за плечо (будучи готовым в любую секунду зажать ему рот рукой), Иван убедился, что разбудить его невозможно. Аккуратно подняв с пола коробку с монитором, Шишок поставил ее на стол перед Кириллом – таким образом, чтобы люди, которые скоро войдут в дверь конторы, не наделали каких-нибудь глупостей со своими прицелами.

В последний раз зачем-то оглядев контору, он услышал осторожные шаги за дверью. Как ни стремились люди «Сарумана» бесшумно подобраться к офису, им это удавалось с трудом. Правда, Арагорн не шевелился, продолжая тяжело дышать.

Кирилл приоткрыл маленькую дверцу подсобки, где стояли в одной куче несколько швабр, большое ведро для мусора и маленькое – для мытья полов, протиснулся внутрь, ощутил запах плохо просушенных тряпок и пыли, спугнул несколько тараканов и опустился в большое ведро поверх пластикового мешка для отходов. Потом затворил за собой дверцу, придержав ее рукой.

Темнота окутала его, швабры окружили туманными призраками. Сквозь тонкую щель, которую никак не удавалось полностью закрыть, был виден маленький кусочек комнаты – тот самый, где спал у стены Арагорн.

Дверь в контору открылась; рядом с лицом встрепенулись тряпки, откликнувшиеся на слабенький сквознячок, убегающий в вентиляционный коллектор за спиной. Сверкнул и тут же исчез луч лазерного прицела. Через пару мгновений он появился вновь – на этот раз точно на лбу Арагорна.

Таракан, появившийся над головой Ивана, на долю секунды отвлек внимание противным шуршанием; мерзкое насекомое свалилось прямо на нос. Его чуть не стошнило от мерзости; он отпустил дверцу и смахнул ползучую тварь с лица. Дверца тоненько, еле слышно скрипнула…

Услышать этот скрип было практически невозможно. Даже сам Иван посчитал, что петли дверцы не издали ни звука. Но на этот шумок неожиданно среагировал Кирилл, который остался за пределами видимости тех, кто вошел сейчас в офис.


Спецвыпуск Xakep, номер #034, стр. 034-120-16, Не будите Арагорна

Не будите Арагорна

Niro

Спецвыпуск Xakep, номер #034, стр. 034-120-16

Внезапно раздался его голос – сонный, недовольный:

- Кто тут бродит? А это что за хреновина?

Потом противное шуршание напомнило Шишку звук, с которым он обычно двигал по полу тяжелые коробки с мониторами – громкий, неприятный скрип, а следом за ним – сильный грохот, заставивший кого-то отскочить в сторону (Шишок увидел в расширившуюся щель чью-то ногу в камуфляже).

Арагорн, не открывая глаз, вскочил с криком на непонятном Ивану языке. Руки выдернули из ножен меч; Иван смотрел на все происходящее с ужасом, ничуть не боясь за себя – он был уверен, что с ним ничего не случится в этой вонючей подсобке, полной тараканов. Меч свистнул – звук, к которому Шишок уже начал привыкать; острие метнулось куда-то за пределы видимости; раз, другой – потом удар, громкий и короткий. Во время очередного взмаха Арагорн зацепил жалюзи – они обрушились на пол, впустив в контору отблески сирен, заплясавшие на стенах.

Потом почему-то осыпалось на пол оконное стекло – сначала покрывшись чередой мелких точек, а потом обвалившись вниз, на подоконник. Шишок вначале не понял, в чем дело, но когда эта цепочка продолжилась на стене рядом с окном и в воздух полетела штукатурка, Иван догадался – кто-то стрелял из автомата с глушителем.

- Орочье… ОТРОДЬЕ! – на этот раз по-русски прорычал Арагорн и свалился следом за осколками стекла на пол – из груди его били маленькие фонтанчики крови, быстро терявшие интенсивность. Руки по-прежнему сжимали меч; но вот и они разжались. Дыхание в последний раз со свистом вырвалось из мощной груди – и замерло навсегда.

Шишок отпустил дверцу, которую успел поймать, но так и не закрыл, не в силах оторваться от происходящего. Прямо в глаз ему брызнул искрами лазерный прицел.

Иван закрылся ладонью и крикнул какую-то глупость, которую потом сам не мог вспомнить – что-то вроде: «Свои!» Двое спецназовцев в масках переглянулись, один из них поднял сжатый кулак, и они синхронно опустили на пол укороченные автоматы с навинченными на них глушителями.

Потом отдавший команду боец проговорил что-то себе под нос, обращаясь к невидимому собеседнику, после чего подошел к телу Арагорна, остановился в трех шагах, направил на него оружие и замер неподвижной восковой фигурой.

Шишок сделал несколько шагов вперед и увидел лежащую на полу коробку, ту самую коробку, что он с трудом взгромоздил на стол, а за ней… Там был Кирилл - в огромной, просто гигантской луже крови. Грудь Кирилла была наполовину разрублена пополам от плеча и почти до пояса. Он неподвижно смотрел в потолок, переливающийся яркими цветами сирен – и на его лице было написано недоумение и недовольство; он так и умер во сне, ничего не поняв…

Дверь отворилась. В контору вошел человек и голосом «Сарумана» произнес:

- Жаль… Крайне печально. Не буду желать доброго вечера – не к месту.

Потом он просто перешагнул через тело Кирилла, стараясь не наступить в кровь, и подошел к мертвому Арагорну. Глаза вошедшего прищурились; он присел перед ним на корточки, дотронулся до меча, погладил окровавленное лезвие кончиком пальца.


Спецвыпуск Xakep, номер #034, стр. 034-120-17, Не будите Арагорна

Не будите Арагорна

Niro

Спецвыпуск Xakep, номер #034, стр. 034-120-17

- Замечательный экземпляр, - тихо сказал он. Шишок понял, что это «Саруман» говорит специально для него. – В прошлом – кандидат исторических наук. Начитался Толкиена. Полюбил ролевые игры – знаете, когда собираются такие же, как он, делают себе мечи из рельсов, щиты из дерева, раздают роли, стараются играть близко к тексту… Как вариант развития событий – парафренный синдром, вообразил себя Арагорном там, где другие на его месте становятся Наполеонами, Кутузовыми… Долго был под строгим надзором, но, к сожалению…

Шишок не понимал ни слова. Он почувствовал, что просто необходимо задать вопрос, без которого все теряет смысл. Иван протянул вперед руку, заслоняясь от того, что ему объяснял «Саруман», и спросил:

- Почему он пришел сюда? К нам? Вы можете ответить?

Человек, не поворачиваясь, замолчал на полуслове. Казалось, вопрос поставил его в тупик.

- Молодой человек, вы знаете, как называется ваш магазин?

Шишок кивнул:

- «Фродо точка ком».

- Что вы еще от меня хотите? – удивился «Саруман», встал и повернулся к Ивану лицом. Тот пожал плечами.

- Да я, вообще-то, так и не понял, что это за Фродо такой, хотя на «Гарри Поттера» три раза сходил – что на первый фильм, что на второй…

- КУДА вы сходили, молодой человек? – недоуменно склонил голову «Саруман». – НА КОГО?

Шишок не решился повторить. Он понял, что сморозил какую-то глупость, но еще до конца не осознал ее масштабы.

«Саруман» внимательно посмотрел ему в глаза, потом улыбнулся:

- Ничего страшного, юноша. Ничего страшного… Вы только… не уподобляйтесь, - и он махнул рукой в сторону Арагорна. – Волшебниками в моей психиатрической больнице пока не пахнет. Поэтому – живите реалиями, молодой человек. Роль у вас своя, одна-единственная. Ради бога, не играйте в сказки. НЕ БУДИТЕ АРАГОРНА.

Он повернулся и вышел из офиса. Через минуту Арагорна и Кирилла уже выносили в мешках, наглухо закрытых «молниями». А Шишок стоял перед дверью конторы и пристально всматривался в так и не понятое им за целый год название – «FRODO.COM»…