Спецвыпуск Xakep, Содержание номера # 031

Cover 031 |
Статья | Стр.
ГДЕ ОСы ФАЙЛЫ ПРЯЧУТ |
Современные файловые системы | 014
Софтварный мир в Linux |
апдейтим систему без проблем! | 016
Set it Up! |
Грамотно устанавливаем софт под Windows | 018
Дружба с Варей |
эмулЯтор VMWare в подробностЯх | 020
Полночный видеодром |
Что мы знаем о виндовом видео | 022
DOSуг на обочине |
видео в самой аскетиЧной ОС | 026
Видео и LINUX |
Софт длЯ мега-рипперов | 028
FloppyOS |
ПолноценнаЯ операционка на дискете | 030
Kickstart |
Ставим Линукс с полпинка | 034
Великий исход юзеров |
В помощь решившимсЯ переползти под Linux | 036
Tweaking&overclocking |
Чем железный твик отличается |
от шоколадного Твикса? | 040
Мелко-мягкий твик |
всЯ правда о скрытых настройках Windows | 042
Windsurfing |
все длЯ серфинга под Виндой | 044
Linux, сеть и все, все, все... |
Все длЯ пингвиньего серфинга | 048
Не заходя в реал |
обзор луЧших ICQ-клиентов под Вынь | 052
История о Linux и «Тете Асе» |
Обозреваем ICQ-клиенты под Линь | 054
Общайся комфортно! |
Руководство по выбору IRC-клиента | 056
В чат из-под рута |
IRC-клиенты длЯ Linux | 058
The Bat под лупой |
Наводим порЯдок в поЧтовике | 060
МЫЛО ДЛЯ ПИНГВИНА! |
Обзор поЧтовых софтин под ОС Linux | 062
ПЕРСОНАЛЬНЫЙ ЛУВР |
графиЧеские вьюверы под Вынь, Дос и Линух | 064
МУЗОН И WINDOWS: |
Чтобы скуЧно не было | 068
Вы слыхали, как поют пингвины?... | 074
Оборачиваем ядро | 076
Совмести несовместимое | 078
МЯГКИЕ МЕСТА ИНЕТА. ЧАСТЬ- | 002
Еще немного сайтов про софт длЯ windows | 082
СЕЗОН ОХОТЫ... НА ПИНГВИНОВ |
Обозреваем *nix ресурсы | 086
ГДЕ ИСКАТЬ ВАРЕЗ? |
Быль длЯ тонких и толстых каналов | 090
FAQ L/W | 092
НАНОТЕХНОЛОГИЯ: |
МЕЧТЫ И РЕАЛЬНОСТЬ | 094
РЕАКТИВНЫЙ РЕЗАК |
Samsung CD-RW sw-252 | 098
PAYALNIK Доктора ДобрЯнского |
Линь и Вынь на разных компах в тишине | 100
ДУЭЛЬ | 102


Спецвыпуск Xakep, номер #031, стр. 031-014-1, ГДЕ ОСы ФАЙЛЫ ПРЯЧУТ. Современные файловые системы

ГДЕ ОСы ФАЙЛЫ ПРЯЧУТ. Современные файловые системы

Andrew Fadeev

Спецвыпуск Xakep, номер #031, стр. 031-014-1

(andrewf@ukr.net)

Пользование компьютером давно стало делом не хитрым. Возишь себе мышкой, тыкаешь в кнопочки, и исполняются твои желания.

Раз - вот твой музыкальный архив. Два - отсортировал по имени файла. Три - посмотрел, какой из них записал последний. Тебе-то удобно, а в это время твоя операционка жужжит и потеет, раскладывая всю инфу по полочкам, как многорукий Шива. Поэтому, как Винни-Пух ходил смотреть, где пчелы мед держат, мы пойдем смотреть, где ОСы файлы хранят, в подвалы системы - будем бурить пласт "жестко-диска".

МНОГО СИСТЕМОК, ХОРОШИХ И НЕ ОЧЕНЬ

Нефти нам, конечно, не обломится, но много интересного и полезного узнаем. Из операционок сегодня у нас трескают траву, наивно полагая, что они гости в ресторане, а вовсе не заправские подопытные кролики в лаборатории, Windows и Linux. Так уж повелось, что под названием "Вынь" подразумевают два разных семейства окончатых: Win9x и WinNT. Так что кроликов у нас три, столько и будет файловых систем. FAT/FAT32, NTFS и ext2fs.

ПРИНЦИПЫ

Сначала несколько слов, общих для всех систем. Информация на винте хранится поделенной на блоки данных (data blocks, или кластеры). Эти блоки имеют одинаковый размер, и файл может занимать один или несколько блоков, но не половинку или сколько-то с половинкой. Отсюда первый принцип - чем больше блок данных, тем сильнее расходуется место на жестком диске при хранении файлов. То есть если файл 1 килобайт, а блок 16 кило - то 15 из них уйдут налогом. Маленьких кластеров надо больше, а, следовательно, и больше таблица их расположений. Так что тут надо искать золотую середину. И второе. Логически жесткий диск может быть разбит на несколько разделов (partitions). Различные файловые системы представляют это деление пользователям по-разному. FAT показывает пользователю разделы как разные объекты - диск C:, D: и т.д. Ext2 идет другим путем: каждый раздел прикручивается (то есть монтируется) как поддиректория к общему корню "/". NTFS поддерживает оба варианта, разве что корень тут все равно называется C:.

EXT2FS - ПИНГВИНЫ ЕСТЬ ТУТ

Эволюция UNIXоподобных знала много систем хранения файлов, но пока для линуха самой распространенной есть эта. Не так давно появилась ее третья версия, дающая некоторые преимущества, однако отличий не так много - ext2 довольно-таки продвинутая система. С разделами под ext2 разобрались чуть выше, теперь заглянем глубже.

А теперь начинается сказка про Кощея Ивановича Б., так что пристегнись. Каждый и-нод содержит 15 указателей на блоки данных. Но блок данных маленький, а файл большой. Поэтому 14-ый указатель (непрямой указатель) связан с непрямым блоком, к которому подключены блоки данных. А 15-ый указатель (дважды непрямой указатель) соединен с дважды не прямым блоком, к которому подключены непрямые блоки, в которые воткнуты блоки данных, в доме, который построил Джек. Вот такая вот сказочка про коробку с зайцем, в котором утка, в которой яйцо. А в яйце уже не первый год бушуют звездные войны. Если кто сейчас задается вопросом, в чью голову пришла такая организация, - отвечаю: гражданину Франции по имени Remy Card.


Спецвыпуск Xakep, номер #031, стр. 031-014-2, ГДЕ ОСы ФАЙЛЫ ПРЯЧУТ. Современные файловые системы

ГДЕ ОСы ФАЙЛЫ ПРЯЧУТ. Современные файловые системы

Andrew Fadeev

Спецвыпуск Xakep, номер #031, стр. 031-014-2

НАУКА БЫЛА, А ГДЕ ЖИЗНЬ?

Это все теория. На практике ext2 обладает следующими преимуществами. Для начала - из всех систем, описываемых в этой статье, она единственная пригодна для установки Линукса :). Конечно, при желании пингвина можно воткнуть в FAT раздел, но тогда можно сесть за издевательства над животными. Ext2 может устанавливать права доступа к файлу пользователя, группы или остальных живущих в системе. Так как разделы монтируются к общему дереву, системе абсолютно все равно, на каком разделе валяются ее части - главное, чтоб все нашлось по привычным путям. Удобно, хотя бывает трудновато уследить за свободным местом. Но для этого есть квоты - каждому пользователю выделяется строго определенная часть дискового пространства.

Новые пингвины оборудованы системой ext3. Основное ее отличие от предшествующей - журнальная система. Что это дает? Например, мы записали файл, и тут погас свет. Упс. Загрузились, а где что было - не ясно. И начинаем проверять весь диск на ошибки, искать недописанное место и стирать его. А если у нас был бы журнал, система бы в него заглянула, узнала бы, где проходила последняя операция и просто бы откатила ее, маркируя пространство как свободное. Сильно экономит время.

FAT/FAT32 и NTFS - ОКНА И ПОЛКИ

Название FAT говорит само за себя - file allocation table. Эта файловая система обеспечивает только самые основные функции. FAT16 поддерживает разделы объемом только до 2 Гбайт и вообще сегодня уже не используется в большинстве систем, кроме как во флэш-картах и брелках. FAT32 появился в Windows 95 OSR2. Тут максимальный объем раздела - 2 терабайта, что, может быть, и много. Только вот максимальный размер одного файла всего 4ГБ, что есть большой проблемой для людей, занимающихся обработкой видео. Интересный фактик о FAT32 и WindowsXP. Хоть последний и поддерживает разделы FAT32 любого объема до 2 терабайт, форматировать новые разделы позволяет только объемом до 32 гиг. Для разделов больше XP очень настойчиво рекомендует NTFS. Оно и правильно. На больших объемах FAT сильно теряет производительность. NTFS же, наоборот, не следует применять на объемах меньше гигабайта-двух. NTFS5.0 (поставляется со всеми Win2K и WinXP) содержит в себе много-много вкусностей.

ВКУСНОСТИ NTFS

Вкусность номер один, два и три для бывалых юниксоидов вовсе не вкусность, а правда жизни. Первое - это права доступа к файлам. WinNT многопользовательская сетевая система, а значит, от этого не деться. Отличие от прав доступа в ext2 - права можно назначать каждому юзеру в отдельности. Номер два - квотирование дискового пространства (писал уже об этом выше), и вкусность три - символические (жесткие в терминологии NTFS) ссылки. Это когда файл один, а имен много и в разных папках. Отличие от symbolic links в ext2fs в том, что в линухе есть главный файл, при удалении которого (или перемещении), все ссылки теряют связи, а в NTFS данные остаются, пока существует хоть одна ссылка. Фича четыре - файловые потоки. Каждому имени файла может соответствовать несколько потоков данных (файлов). Указывается дополнительный поток - как, например, file.txt:onemoresteram. По непонятной науке причине большинство команд Windows XP и 2K эти потоки не поддерживают. А используются системой они в основном для хранения той самой Summary (Сведения), что можно отредактировать на соответствующей вкладке свойств файла.


Спецвыпуск Xakep, номер #031, стр. 031-014-3, ГДЕ ОСы ФАЙЛЫ ПРЯЧУТ. Современные файловые системы

ГДЕ ОСы ФАЙЛЫ ПРЯЧУТ. Современные файловые системы

Andrew Fadeev

Спецвыпуск Xakep, номер #031, стр. 031-014-3

NTFS - журнальная файловая система со всеми вытекающими. Еще один фокус NTFS это разреженные (sparse) файлы. Если в файле встречается длинная последовательность нулей, получается, что мы храним пустоту, занимая при этом пространство диска. NTFS же эту пустоту ловко сжимает, оставляя лишь информацию о количестве этих нулей. Еще в NTFS есть сжатие файлов, не очень сильное, зато работает быстро, что позволяет сжать папки с документами и работать с ними прозрачно, то есть процесс распаковки и паковки скрыт от пользователя. NTFS включает в себя еще и EFS - шифрование файлов. Всего этого нет в FAT, поэтому если у тебя новенький Виндовз, лучше ставить NTFS. А FAT оставить для переносных дисков - ведь основное его достоинство перед остальными системами, это то, что его поддерживают почти все ОСи.

КОНЕЦ

Вот и сказочке конец, а тому, кто не слушал... Э-э... послушать еще раз мой совет. Вывод таков. Ставить тебе Линь или Вынь, ты еще решишь, прочитав этот номер. Если ты с пингвинами - ext2 твое. Если останешься смотреть на мир в цветные окошки - лучше, конечно, ставить 2K или XP и форматировать диск в NTFS. Получишь много бонусов и спокойную жизнь, если твоим компьютером пользуется кто-то еще. Есть карман со сменным винчестером, с которым ты ходишь за свежим пивом и варезом? Его лучше форматни в FAT32 - чтобы прочитывался везде. А вообще - идеального нет нечего. Опыт подскажет.


Спецвыпуск Xakep, номер #031, стр. 031-016-1, СОФТВАРНЫЙ МИР В LINUX: апдейтим систему без проблем!

СОФТВАРНЫЙ МИР В LINUX: апдейтим систему без проблем!

Докучаев Дмитрий aka Forb

Спецвыпуск Xakep, номер #031, стр. 031-016-1

(forb@real.xakep.ru)

Являясь поклонником операционки Windows, ты, наверное, знаешь, как просто устанавливается софт. Весь процесс установки сводится к двум-трем щелчкам мыши по исполняемому инсталлятору и паре диалоговых кнопок OK. В Linux все гораздо сложнее и интереснее одновременно. Если ты желаешь познать весь волнующий душу процесс установки софта под Linux, то данная статья будет для тебя очень ценным мануалом. В противном случае, мой тебе совет - оставайся поклонником форточек и с гордостью переворачивай страницу журнала, и да поможет тебе Microsoft :). Однако не забывай, что ты никогда не знаешь, что творит инсталлятор на твоей тачке (уже давно не секрет, что некоторые злодеи подсовывают юзверю под видом инсталляшки крутой софтины деструктивный код). В общем, ты - не хозяин положения.

Linux, как и любая уважающая себя система, позволяет пользователю устанавливать программное обеспечение, или попросту софт. Этот самый софт распространяется двумя способами: бинарниками, подогнанными под конкретную систему, или source кодом (попросту сорцами), которые собираются на месте при помощи makeutils.

ЧТО ТАКОЕ RPM И С ЧЕМ ЕГО ЕДЯТ

В первую очередь, остановимся на бинарном софте. Всю неблагодарную работу по распаковке и установке этого вида программного обеспечения выполняет /bin/rpm. RPM расшифровывается как RedHat Packet Manager, но не стоит думать, что он актуален только лишь для дистрибутива RedHat. На самом деле, rpm-инсталлер имеет место практически на всех видах Linux.

Изначально система собирается с помощью RPM. Распаковывая и устанавливая бинарники, содержащиеся на CD, инсталлер приводит Linux к рабочему состоянию. Перед установкой очередного пакета manager проверяет его на зависимость от других пакетов. К примеру, инсталлятор откажется устанавливать пакет mc, если в системе отсутствует ncurses. Для справки, проверку на зависимость можно игнорировать параметром -nodeps, но о фатальных последствиях этого ключика я тактично умолчу :). Хотя я не раз встречал людей, собиравших серьезные вещи с -nodeps и делавших при этом роковую ошибку.

Видя удобство и привлекательность rpm-пакетов по сравнению с обычными сорцами, пользователи устанавливают именно их. Но их выбор чреват большими проблемами. Дело в том, что нельзя с полной уверенностью доверять RPM, ибо только сборка сорцов гарантирует стабильность в работе приложений. Например, юзер установил новое ядро через rpm-пакет, а на следующий день оно наградило систему kernel panic'ом. Вывод - придерживайся установки из сорцов.

К слову говоря, Linux не единственная операционка, включающая в себя поддержку бинарных пакетов. FreeBSD, например, имеет аналоговый pkg_add, SunOS - pkgadd и т.д. Если сравнивать с форточками, то бинарные пакеты - единственный вид софта под Вынь. Ведь MicroSoft уже много лет хранит source code системы в строжайшей тайне :).

СОФТ ИЗ СОРЦОВ - НАШ ВЫБОР!

Согласно GNU Licence, весь софт в Linux распространяется только открытым кодом. Как правило, он пишется на языке C, реже C++. Как ты, наверное, знаешь, лучше всего сжимается чистый текст, поэтому вся иерархия сишных файлов запаковывается в архив.


Спецвыпуск Xakep, номер #031, стр. 031-016-2, СОФТВАРНЫЙ МИР В LINUX: апдейтим систему без проблем!

СОФТВАРНЫЙ МИР В LINUX: апдейтим систему без проблем!

Докучаев Дмитрий aka Forb

Спецвыпуск Xakep, номер #031, стр. 031-016-2

Этот архив является составным. Вначале софт сливается tar'ом в один большой файл (делается исключительно ради удобства), затем это файло сжимается внешним архиватором. Таковых два: gzip и bzip2, поэтому конечное расширение файла будет tar.gz либо tar.bz2. Архивы bzip2 сжимаются лучше :), но, как это ни парадоксально, софт чаще всего выкладывается именно в gzip-архивах. Распаковать такие архивы можно tar'ом. Ключи -zxf распакуют gzip, а -yxf - bzip2 архив. Если версия tar устаревшая и бинарник ругается на неизвестные ключи, не отчаивайся - архив можно распаковать и в два действия.

КОНФИГУРИМ И НАСТРАИВАЕМ СОФТ

После распаковки пакета войдем в папку с сорцами. Следующим шагом будет запуск configure скрипта, который имеет каждый уважающий себя проект. Configure проводит опрос системы на наличие либо отсутствия библиотек, процедур и бинарников. При отсутствии зависимости скрипт прекратит свою работу и выдаст ошибку пользователю. Это логично, поскольку юзер узнает об ошибке еще на начальной стадии.

Не следует запускать configure сразу после распаковки архива. До этого нужно проделать как минимум два действия. В каждом софтварном пакете лежат файл README и INSTALL. В README содержится информация о применении и использовании программы, INSTALL содержит подробное руководство к установке и должен быть обязательно прочитан перед процессом сборки. Я понимаю, что ты занят и тебя ломает читать английский мануал, но, поверь, это для твоего же блага. После прочтения у тебя исчезнут все неопределенности и вопросы по поводу неизвестных ошибок, периодически появляющихся при установке :).

Затем нужно обязательно посмотреть help от configure. Это делается простой командой ./configure -help. Почему это важно? Дело в том, что некоторые функции программы по умолчанию отключены. Из хелпа ты узнаешь, как включить эти самые функции. Яркий пример: в веб-сервере apache по дефолту отключена возможность добавления внешних модулей. Она включается при помощи параметра -enable-module=so (или -enable-module=all). Про этот параметр подробно сказано в help'е от configure. Не менее важным параметром является -prefix. Он указывает на директорию, в которую будет установлен софт после компиляции. По умолчанию имеет значение /usr/local, но может быть изменен при отсутствии рутовых привилегий либо по желанию пользователя, то есть тебя :).

Если конфигурация закончилась ошибкой, следуй указаниям скрипта и исправляй положение. Обычно он ругается на отсутствие какого-нибудь бинарника или библиотеки. После установки зависимого пакета перезапусти скрипт, и ошибка будет исправлена.

КОМАНДА MAKE ИЛИ В ДОБРЫЙ ПУТЬ :)

После экзекуций с configure приступаем к главной процедуре - сборке проекта, или доведения Си-файлов до бинарного состояния. Для этого нам понадобится рабочий gcc-компилер (его работоспособность заботливо проверяет конфигуратор). На стадии подготовки к установке будут созданы так называемые скрипты Makefile, которые дают ценные указания утилите make по сборке. Как правило, в нем содержатся параметры, заданные в configure, а также флаги компилятору и линкеру. Например, флаги "-WALL -ansi -pedantic" отвечают за выдачу всех ошибок и предупреждений компилятора на консоль. Работа компилера - отдельная тема, про которую можно говорить часами, поэтому заострять на ней особого внимания я не буду.


Спецвыпуск Xakep, номер #031, стр. 031-016-3, СОФТВАРНЫЙ МИР В LINUX: апдейтим систему без проблем!

СОФТВАРНЫЙ МИР В LINUX: апдейтим систему без проблем!

Докучаев Дмитрий aka Forb

Спецвыпуск Xakep, номер #031, стр. 031-016-3

Для запуска сборки набери команду "make" и жди завершения длительного процесса компиляции.

Этот процесс может завершиться успехом или ошибкой. При возникновении ошибки совсем не обязательно биться головой о монитор и вспоминать Линуса Торвальдса нехорошими словами :). Просто компилятор не нашел какого-либо инклуд-файла или функцию, по загадочной причине не проверенную конфигуром. Я знал некоторых людей, которые при возникновении ошибки в коде просто комментировали проблемное место. Какой проект получался после своевольной кастрации кода, одному Богу известно. Посуди сам, девелоперы знают, что делают, поэтому урезать их творения по личному желанию, как минимум, некрасиво. В таком случае необходимо проанализировать тип ошибки и устранить ее. Вот основные типы аварийных завершений компиляции:

1. Отсутствие в системе хеадера либо исполняемого файла. Устраняется очень просто - установкой пакета, в котором этот файл имеется. Как правило, все зависимости указаны в INSTALL - это лишний повод, чтобы еще раз изучить этот текстовик.

2. Undefined reference to function. Достаточно популярная ошибка, из-за которой, как я уже говорил, юзеры комментируют Си-код. При возникновении такой ситуации компилер просто не может найти функцию, на которую ссылаются в коде. Это обусловлено отсутствием параметра -lLib, где "lib" - библиотека, хранящая эту функцию. Для исправления ошибки проверь INSTALL и Makefile на наличие подключаемых библиотек.

3. Нетрадиционные ошибки - нехватка свободного места на HDD, конфликт с версией компилятора и прочие. Возникают и устраняются в зависимости от ситуации.

После успешного исправления всех ошибок осталось завершить установку командой "make install". Утилита make разместит софт в директорию, указанную параметром PREFIX. Надо заметить, что если директория является служебной (/usr, /usr/local), тебе потребуются рут-права для завершения установки. После инсталла можешь затереть рабочий каталог в целях экономии места - он тебе больше не понадобится.

Поздравляю, ты только что завершил установку полезного софта из сорцов! Теперь тебе остается лишь грамотно настроить конфиг-файл (если таковой имеется) и запустить программу.

Как видишь, не так страшен софт, как его малюют :), поэтому никогда не пренебрегай сборкой программ на своей машине, устанавливая вместо этого бинарный пакет. Во втором случае гарантировать правильную работоспособность тебе никто не может. Linux дал возможность собирать софт исключительно под себя, почему бы не использовать ею на 100%?

Софт под Linux является фриварным, то есть свободным для бесплатного скачивания. Найти его ты можешь на следующих ресурсах:


Спецвыпуск Xakep, номер #031, стр. 031-016-4, СОФТВАРНЫЙ МИР В LINUX: апдейтим систему без проблем!

СОФТВАРНЫЙ МИР В LINUX: апдейтим систему без проблем!

Докучаев Дмитрий aka Forb

Спецвыпуск Xakep, номер #031, стр. 031-016-4

http://www.freshmeat.net - крупный поисковик софта под Линь. Сайт имеет базу проектов с удобным поиском по ней.

ftp://ftp.gnu.org/pub/gnu - крупнейший ftp-сервер GNU. Тут находятся самые популярные и часто обновляющиеся проекты для твоей любимой оси :).

http://www.rpmfind.net - ресурс по поиску бинарных RPM-пакетов, ориентированных под конкретную платформу.

При возникновении трудностей не стесняйся, шли свой вопрос мылом, и, возможно, я помогу тебе нарыть ответ на него. Только не нужно спрашивать то, что я описывал в этом материале - повторять несколько раз одно и то же я не хочу.


Спецвыпуск Xakep, номер #031, стр. 031-018-1, SET IT UP!. Грамотно устанавливаем софт под Windows

SET IT UP!. Грамотно устанавливаем софт под Windows

Kirion (Kirion@winfo.org)

Спецвыпуск Xakep, номер #031, стр. 031-018-1

Сколько программ установлено у тебя на компе? Двадцать? Тридцать? У меня установлено девяносто семь программ, не считая еще двух десятков, работающих без установки :). Так уж получается, что ищешь интересный софт для статей, и потихонечку он накапливается в огромном количестве. А если бы ты знал, сколько творений криворуких программеров мне довелось удалить из своей системы и сколько раз я ее переустанавливал по вине очередной утилитки с привлекательным описанием...

КРИВЫЕ РУКИ ТЕБЯ ПИСАЛИ...

Даже если ты качаешь софт только с надежных сайтов (особенно варез :)) и проверяешь его на вирусы и трояны (это должно войти у тебя в привычку), предварительно скачав свежую антивирусную базу и прикрыв доступ в Инет хорошим фаерволлом, это не спасет тебя от ошибок (или рулезных фич, но почему-то неработающих :)) в прогах. Проги могут криво прописываться в реестре, заменять системные файлы, конфликтовать с виндами или другими прогами. Не забудь также и о хвостах прог, остающихся после деинсталляции (особенно о хвостах триальных прог, не позволяющих юзать их после переустановки :)). Бывает, что подводят и известные производители программного обеспечения. Приведу пример: в ноябрьском номере была статейка Дронича про Symantec Client Firewall. Писать статью вначале хотел я, но эта сволочь не хотела нормально устанавливаться и вылетала с ошибками. Причину я нашел примерно через месяц, когда у одного моего друга произошло то же самое, но после установки Norton Antivirus. Оказалось, что корпоративные продукты от Symantec и домашние (которые с приставкой Norton) используют разные версии системных файлов, но называются они одинаково. Norton Utlites же у меня стоят с незапамятных времен... Вот такие вот сюрпризы может преподносить софт.

НАМЕЧАЕМ ЦЕЛИ

Итак, куда же может нагадить среднестатистическая прога при установке? Ну, во-первых, это файловая система. Необходимо следить как минимум за виндовой директорией, за директориями System и System32 (здесь у нас библиотеки и еще куча гадости), за директорией Common Files (что-то вроде c:\program files\common files\ дальше название компании или продукта), за файлами System.ini и Win.ini (это для win9x, о них в последнее время забывают) и, конечно же, нужно следить за реестром. Вообще, реестр все больше напоминает огромную помойку. Со временем в нем накапливается огромное количество мусора, он начинает занимать существенное место на диске и тормозит работу. К тому же разбираться в реестре с помощью обычного редактора становится непосильной задачей. В теории каждый из корневых разделов реестра служит для своих целей. Так, например, "HKEY_CLASSES_ROOT" предназначен для хранения данных о типах файлов, о всяческих расширениях эксплорера (в смысле самой визуальной оболочки Виндов), дополнительные пункты различных контекстных менюшек. "HKEY_CURRENT_USER" содержит настройки текущего пользователя (и является подмножеством раздела "HKEY_USERS", в котором хранятся настройки всех пользователей), "HKEY_LOCAL_MACHINE" содержит общие настройки и сведения о системе, а "HKEY_CURRENT_CONFIG" ("HKEY_DYN_DATA" в win9x) содержит информацию об устройствах. Но программеры, желая запрятать сведения о регистрации куда-нибудь подальше, игнорируют эти правила, сильно усложняя задачу неподготовленному человеку :).


Спецвыпуск Xakep, номер #031, стр. 031-018-2, SET IT UP!. Грамотно устанавливаем софт под Windows

SET IT UP!. Грамотно устанавливаем софт под Windows

Kirion (Kirion@winfo.org)

Спецвыпуск Xakep, номер #031, стр. 031-018-2

ВООРУЖАЕМСЯ

Итак, нам необходимы инструменты для слежки за действиями подопытной проги и инструменты, эти действия потом отменяющие :). Самый простой способ (но не факт, что самый лучший) это довериться автоматике и поставить Norton CleanSweep (входит в поставку Norton SystemWorks, начиная с 2002 версии). Прога следит за всеми процессами установки на компе и сохраняет всю инфу себе в логи, дабы потом можно было удалить все хвосты. Можешь включить прогу на автозапуск, но учти, что слежку она начинает, основываясь на имени запускаемого файла, а далеко не всегда установщики называются setup.exe или install.exe (впрочем, список имен можно редактировать). Так что лучше вовремя кликнуть на иконку в трее и нажать "start logging". После установки также руками прекращаем слежку и записываем инфу в лог-файл. Когда захочешь избавиться от проги, заходи в Uninstall Wizard (через оболочку NSW) и выбирай нужный лог. Можешь проконтролировать, что удаляется. Только учти, что имя проги не удалится из пункта "Установка и удаление программ", так что придется его удалять с помощью чистильщика. Можно также сначала удалить прогу через "Установку и удаление...", а потом прибить остатки через Uninstall Wizard. Кстати, в CleanSweep существует еще один монитор: Internet sweep, но его ценность мне кажется весьма сомнительной. Он следит за элементами ActiveX, которые внедряются в твой браузер. Они, конечно, могут нанести достаточно вреда (особенно если ты не обновляешь ослика), но гораздо проще их отключить и не вспоминать совсем (а лучше поставить Оперу :)). Ну и как маленький бонус: с помощью CleanSweep ты можешь почистить хистори, кукисы и кэш ослика.

Если же тебя не прельщают возможности Norton SystemWorks и ты не хочешь ставить их только ради CleanSweep, то можешь обратить внимание на System Mechanic (www.iolo.com). В состав этого известного чистильщика системы, реестра, временных файлов и прочего мусора входит Safe Installer. Это визард, который записывает состояние системы до установки и после. У него два режима работы: ручной, то есть ты просто делаешь снимок системы, а потом можешь сам сравнить изменения, и автоматический - ты можешь выбрать файл установки, настроить слежку (установка начнется потом сама), а после установки просмотреть изменения. Что можно настроить в слежке: диски, за которыми будет вестись слежка, изменения в INI-файлах (по умолчанию в списке system.ini и win.ini) и путь к файлу отчета :). Однако есть пара довольно существенных минусов: во-первых, во время установки могут происходить и другие изменения, никак не связанные с процессом установки. Ну и, во-вторых, удалять изменения тебе придется ручками :).

Если же тебя не пугает ручная работа, то ты можешь вооружиться несколькими отдельными мониторами. Тебе нужны: монитор файловой системы, монитор реестра (если у тебя win9x - можешь воспользоваться Registry Tracker из Norton Utilites), менеджер процессов (популярный Starter, точного линка на пагу девелопера дать не могу - автор советует искать на Google :)) и неплохо бы монитор подключений (любой хороший фаерволл). Если не найдешь чего-то - иди на www.sysinternals.com. На этом сайте куча маленьких и очень полезных утилит на разные случаи жизни. Нам с тобой нужны: Filemon (монитор файловой системы), Regmon (монитор реестра), Process Explorer (монитор процессов, открытых файлов, загруженных библиотек) и TCPView (монитор сетевой активности). Утилиты весьма маленькие по размерам, так что качать долго не придется. Запускай все это добро перед установкой. Только обязательно настрой фильтры в Regmon и Filemon, иначе очень быстро утонешь в потоке сообщений. Ты, наверное, и не знал, что проги и сами Винды так часто обращаются к реестру и различным файлам. Список будет стремительно увеличиваться с каждой секундой. После установки сохраняй все данные в текстовики и приступай к кропотливому изучению. Понимаю, это долго и нудно, зато надежно (если, конечно, ничего не пропустишь от усталости :)).


Спецвыпуск Xakep, номер #031, стр. 031-018-3, SET IT UP!. Грамотно устанавливаем софт под Windows

SET IT UP!. Грамотно устанавливаем софт под Windows

Kirion (Kirion@winfo.org)

Спецвыпуск Xakep, номер #031, стр. 031-018-3

В АТАКУ?

Вот ты сейчас наверное думаешь, а стоит ли все это таких трудов? Запускать эти чертовы мониторы, лазить по реестру, внимательно изучать логи. Конечно, ситуация облегчается, если использовать автоматику, вроде CleanSweep, или хороший чистильщик системы, такой как jv16 Power Tools (www.jv16.org), но они не дают полной гарантии. Можно, конечно, жить проще и не устанавливать левые проги с левых сайтов, вовремя обновлять антивирусы и фаерволлы, покупать шароварные проги :), прислушиваться к рекомендациям других пользователей (в крайнем случае меня :)). Но как-то это не по-нашему, не по-хацкерски :). Так что зубы сжать, монитор в руки и... Setup.exe!

Не забудь также и о хвостах прог, остающихся после деинсталляции (особенно о хвостах триальных прог, не позволяющих юзать их после переустановки :)).

Итак, нам необходимы инструменты для слежки за действиями подопытной проги и инструменты, эти действия потом отменяющие :).


Спецвыпуск Xakep, номер #031, стр. 031-020-1, Дружба с Варей, эмулятор VWWare в подробностях

Дружба с Варей, эмулятор VWWare в подробностях

Alex Shark

Спецвыпуск Xakep, номер #031, стр. 031-020-1

(qqqqqwww@e-mail.ru)

Хочешь поиметь комп с тремя сетевухами или пятью сидюками? Или запускать мастдай в окошке линукса? Тогда ставь подружку Варю, она эмулирует все, что можно поставить к тебе на тачку.

Качалово zone

Ты наверно думаешь, что такую тулзу будут ныкать по варезным сервакам? Ну, может быть и будут, но есть метод проще. Заходи смело на головной сервачок www.vmware.com, и после нескольких регистраций тебе дают скачать полноценную версию. Единственное отличие от релизной коробочки это 30-дневный срок. Как искать ключики - не мне тебя учить. Регистрация проходит без лишнего геморроя. Последняя вышедшая версия Workstation 4.0, и все нижеописанное будет именно про нее. Сервера затрагиваться не будут, так как они относятся к глобальным системам, достаточно прожорливым к ресурсам. Хотя, если честно, кардинальных изменений не было еще с версии 1.0. Те же кнопки, те же условия, немного меняется интерфейс, достаточно сильно меняется ядро, но промежуточное все остается тем же. Ну и, конечно, постоянно добавляется поддержка новых осей.

Install

Ставить можно как под *nix платформы, так и под винду. Но если линух по большому счету по барабану какой, то винда возьмется только с NT-евым ядром (NT/2K/XP). Итак, начали инсталлить под мастадаем. Тыркаешь мышкой в единственный сетупер, соглашаешься с лицензией. Говоришь, куда можно притереться, и ждешь. Если у тебя уже когда-то стояло детище этих товарищей, то будет предложено сделать глобальный шмон твоего компа. В случае удачного обнаружения виртуальных тварей, их благополучно подцепляют. Далее платишь деньги, ищешь чудо-программку или просишь у друзей ключик, и все, ребут. Ребут необходим для правильной установки виртуальных сетевых карт. После перегруза у тебя появятся 2 новенькие сетевушки, это VMnet1 и VMnet8. Все, под мастдай Варя легла. Под никсами, если стоит Красная хата или Мандрака, все так же просто. Качаешь rpm и втыкаешь эту радость с полпинка. Удобство эмуля в том, что можно без ребута набрать документик в вордяшнике и отпечатать на доменном принтере, не входя, само собой, реальной тачкой в домен. Или же, наоборот, оттестить свою пагу под реальным апачем с реальным перлом.

Что внутри

Принцип эмуляции достаточно прост. Это не подкат dll-ек, как делает cyg-win, и даже не извращенный способ обращения в чужеродные степи, как делает xmms, подтаскивая dll-ки от мастдая. Это эмуляция компа. То есть эмулируется все на железном уровне, на уровне портов и виртуальной памяти. Именно поэтому как бы ты ни кувыркался в асме, тебе не дадут прямого доступа к хосту (так зовется твой реальный комп). И именно поэтому не существует проблем и ограничений по разнообразным защищенным режимам. В качестве примера можно воткнуть 98 винды и под них залить SoftICE - уж кто-то, а он умеет ковыряться в глубинах проца и памяти. Даже под ней ты не сможешь понять, реальная данная тачка или нет.

Основные отличия эмуляции под разные оси кроются в подсадных дровах. То есть для 98 эмулируется то железо, которое есть в "установке по умолчанию". Для линухов железо немного другое. Поэтому не стоит говорить, что будет стоят лин, а воткнуть 95. Есть некоторые отличия при эмуляции обращений к устройствам, именно поэтому под лин по умолчанию эмулируется SCSI винты, а под мастдай обычные IDE.


Спецвыпуск Xakep, номер #031, стр. 031-020-2, Дружба с Варей, эмулятор VWWare в подробностях

Дружба с Варей, эмулятор VWWare в подробностях

Alex Shark

Спецвыпуск Xakep, номер #031, стр. 031-020-2

Эмулированное железо

Но не все зависит от оси. Для начала память, выбирай не больше половины. Учти, что если ты захочешь запустить 2 виртуалки одновременно, то нужно оставить память и на твою реальную ось.

Далее сеть, тут придется определиться - какая. Первый вариант "bridged", это если у тебя есть локалка. Ты создашь абсолютно виртуальную машину. То есть у нее будет свой сетевой адрес, свой IP, и вообще трудно будет понять по сети, откуда у тебя второй комп. Второй вариант "NAT" дает подобие "маршрутизации" пакетов, то есть все пакеты будут пролетать через реальную тачку в оба направления, и в банальном tracert эта тачка будет вроде маршрутизатора. Удобно, если ты хочешь похачить кого-то; даже в случае уничтожения виртуалки твой реал комп останется в живых. Host-only - тут, я думаю, понятно, твой виртуал, твоя тачка и все. Инет только через проксик или мастдайную маршрутизацию. Наиболее выгодно как "полигон для испытаний". То есть вешаешь снифак и дружно ловишь все, что летит на виртуалку, без лишнего мусора. Все, последнее "Do not use a network" значит: не надо мне сети, отвали.

Далее идет винт. Первый вариант самый простой, он создает файлец и пишет в него весь имедж диска. При этом не пишутся холостые (пустые) сектора. Ты можешь смело делать винт на 10 гектаров, но пока ты на него ничего не поставил, жрать он будет копейки. Если же ты поставишь галочку "Allocate all disk space now", то сколько ты отмерял, столько и откушается, но работать будет немного шустрее. Тут же можно нарезать его ломтиками по 2 гига, что полезно при установке доса или 95-ки. Второй вариант, это если у тебя уже есть виртуальный диск, можно и с другой машины, так как под Варей все равны. Третий вариант - это взять твой реальный хард и припаять его к виртуалке. Тебе предложат выбрать, какой именно винт ты хочешь поюзать и как ты будешь это делать. Use entire disk - это пользуй как есть. В случае "individual partition" можно определиться с теми партициями, которые ты конкретно хочешь пользовать. Последний вариант советую использовать как "основной" винт, только если у тебя две оси стоят реально. То есть существуют и лин, и вин, но нет желания ребутиться. Для упрощения загрузки создай под вином профиль оборудования (в свойствах твоего компьютера) и один раз подними все Варино хозяйство. Впоследствии нужно будет при загрузке просто выбрать, под чем именно грузится.

Звуковуху я тебе не советую эмулить в принципе. Если, конечно, не горишь желанием резаться в досовские игрушки конца прошлого века находясь в XP-ях. Ресурсы улетают на нее значительно быстрее, чем на другое железо. Winamp же лучше запускать на реальной тачке, особенно хорошо он слушается в полном экране во время ребута виртуалки. Не до всех доходит с первого раза, что звук идет от компа.


Спецвыпуск Xakep, номер #031, стр. 031-020-3, Дружба с Варей, эмулятор VWWare в подробностях

Дружба с Варей, эмулятор VWWare в подробностях

Alex Shark

Спецвыпуск Xakep, номер #031, стр. 031-020-3

Тюнинг

Наличие настройки памяти пригодится в случаи установки сервера. Ставишь сервак при 256 метрах и уже после установки меняешь на 64. При этом одиножды загрузившись, можно делать постоянную гибернацию, разумеется - средствами Вари. Действует данное усыпление идеально. Тут же можно оторвать пищалку и USB. Вместо сидюка и флопаря можно легко определить имейдж, который будет для виртуалки вполне железным устройством. Можно подрубить еще партиций или порт принтера. Можно навешать кучу ISO образов, они будут выглядеть просто сидюками. Можно навешать до трех сетевух и превратить Варю в роутер или в глобальный домен с отдельным DNS, отдельным FTP и прочими наворотами. При этом на каждую сетевуху можно давать свой способ подключения. Можно извратиться и поставить виртуальный линукс с мощным фаерволлом, и юзать его как проксик. Максимальные увечья - это форматирование виртуального файла. В опциях машины ты можешь прописать приоритет грабель процессорного времени. Их всего два, при твоем личном присутствии и в бэкграунде.

Установи tools, для этого выбери в меню File эту опцию, она подменит тебе виртуальный CD. Есть смысл сделать бэкап файлов виртуала. Особенно если использовать виртуалку в опасных для жизни условиях. Для этого достаточно усыпить машину и заархивировать все файлы в директорию, выбранную при создании машинки. Теперь для восстановления даже после самого злобного хака достаточно сделать F5. Все это, конечно, относится к Варе без железных привязок к винтам, иначе можно потереть и реальный винт. Хотя при выходе Варя все равно спрашивает: "А, собственно, делать изменения, которые ты тут вытворял или откатить?", так что много тебе не напортачат.

Минусы

Ну, про плюсы ты уже, наверно, начитался, теперь послушай про гнилое место этой прелести. Во-первых, это скорость, как ни старайся, а эмулятор всегда будет медленнее реальной тачки. То есть для 3D-Max лучше воткнуть вторую ось. Во-вторых, это отсутствие таких наворотов, как OpenGL, так что в кваку шибко не погоняешь. Ну и, как всегда, геморрой с железом. Например, CD не всегда правильно монтируется, иногда приходится подправлять его руками. Есть траблы с видяхой под лином, у X-ов должны быть обязательно то же разрешение и те же битовые градации цвета, что и у хостовой машины. Сеть вообще работает по непонятным правилам, то есть долго не получалось заставить нормально работать nmapfe. Он все сканировал, но подозрительно молчал, даже с опцией -v, и выкладывал все свои придумки только в самом конце.

Выбирай, иметь или не иметь. Помни, главное, чтобы не поимели тебя :).


Спецвыпуск Xakep, номер #031, стр. 031-022-1, ПОЛНОЧНЫЙ ВИДЕОДРОМ. Что мы знаем о виндовом видео

ПОЛНОЧНЫЙ ВИДЕОДРОМ. Что мы знаем о виндовом видео

Томилин aka "Middlenight"

Спецвыпуск Xakep, номер #031, стр. 031-022-1

(middlenight@mail.ru; http://middlenight.h10.ru)

- Представьте себе, что у вы находитесь в одной комнате с Басаевым, Хусейном и Гейтсом. В руке у вас револьвер с двумя патронами. Что вы сделаете?

- Выстрелю два раза в Гейтса, а потом рукояткой его, рукояткой!

(бородатый анекдот)

Основное предназначение винды - развлекать юзверя. Аксиома, не так ли? Играть, смотреть и слушать - кому не нужен домашний комбайн развлечений, тот пришел не по адресу... Так ли это? Неужели столь проклинаемый Мастдай действительно обошел на медиа-пути все остальные OS? Может быть; все, как известно, познается в сравнении, и, в любом случае, какая операционка ближе твоему енгу - решать тебе. Моя же задача сегодня - нанести идеологический удар в виде потока видеовозможностей со стороны WIN по другим осям.

PREVIEW

Итак, какие же возможности по юзанью видео нам предлагает WIN, а точнее коммерческие производители ПО, затачивающие свои проги под самую распространенную ось? Если говорить рекламными слоганами, то "самые неограниченные". Ну а если конкретнее? Если конкретнее, то в Винде ты без напряга можешь зырить, рипать, записывать и монтировать видео. Когда я говорю "без напряга", имею ввиду доступность самого разнообразного софта для этих целей в нашей стране, потому что прог с кодеками и в самом деле до хрена. Причем, самых разнообразных, на любые вкусы, цели и умственные способности. Вот об этом и потолкуем поподробнее:

КОДЕКИ

Чтобы зырить видеокартинку в каком бы то ни было плеере любой оськи, нужны кодеки - утилиты для сжатия видеоинфы с целью уменьшения размера файла. С самого момента появления концепции сжатия цифрового видео кодеков наделали ту еще кучу. С форматом MPEG4, с тем вообще какой-то марафон происходит на тему "Кто последнюю версию скачает?". Впрочем, раз нравится людям, то пускай маются, тем более, что поставить в Винде кодек - как два пальца об астрал. Система поддержки юзеров кодеками реализована в Windows в виде паков (как правило - куча кодеков в одном флаконе, например, пак "wmpcdcs"): перец качает из Инета EXE-шный файл, при запуске которого в системе прописываются соответствующие .INF файлы (в system.ini и HK_Loсal_Maсhine\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32, поскольку по сути своей кодек все-таки является драйвером). Все! Теперь проигрыватель сам найдет в системе нужный ему кодек, и юзверь увидит столь долгожданный порн... эээ... видеофайл. Вышеописанная схема, впрочем, может никогда и не использоваться виндерами, поскольку каждая версия Мастдая (Мастлайфа?) поставляется вместе со всеми известными на тот момент человечеству кодеками, да еще и в комплекте с великолепным "Универсальным проигрывателем"... Шучу, конечно, но о плеерах чуть позже, а пока пробежимся по некоторым популярным видеоформатам:

MPEG2 (DVD, VCD)

HISTORY

MPEG2 - формат видеосжатия, возникший на основе ставшего в свое время революционным MPEG1 (Motion Picture Expert Group). С 1995 года он стал стандартом в транслировании спутникового телевидения на полосе в 9 Мбит/сек. Лично я узнал о существовании MPEG2 в 1996 году в связи с публикациями в прессе на тему выбора MPEG2 в качестве формата компрессии видеоданных в стандарте DVD (704х480х30 fps). Что ж, вполне разумно ;).


Спецвыпуск Xakep, номер #031, стр. 031-022-2, ПОЛНОЧНЫЙ ВИДЕОДРОМ. Что мы знаем о виндовом видео

ПОЛНОЧНЫЙ ВИДЕОДРОМ. Что мы знаем о виндовом видео

Томилин aka "Middlenight"

Спецвыпуск Xakep, номер #031, стр. 031-022-2

РИПАНЬЕ

Известные мне для этого проги: DeCSS, DOD DVD Speed Ripper, DVD Rip, dvd_rip, dvd2mpeg, FlaskMpeg, power_rip, Quintuplet, Ripping Package, srGUI, GordianKnot.

При текущем развитии компешных технологий самым актуальным для нас является именно стандарт DVD. Однако жизнь у наших юзеров такая, что, зачастую, DVD-привод - и тот не по карману. Что же таким бедным перцам делать? Я так думаю, что надо прийти к приятелю, обладающему DVD-румом и CD-райтером, и порипать пару десятков новых фильмаков в Divx, ну или что там его тачка сдюжит. И в "Х", и в "Спец-Х" уже вышла куча статей, посвященных рипанью DVD, так что я, дабы не повторять чужие мысли, скажу только, что за несколько лет существования формата DVD-рипперов под Винду понавыпускали уже на любой вкус и цвет. Если, скажем, чувак не сильно обременен интеллектом или просто времени у него мало, то ему сойдет и утилитка "DVD to MPEG": выбрал конечный файл, нажал на кнопку - получил результат. Аналогичных прог - тьма: Quintuplet, DVD rip, DOD Speed DVD Ripper, FlaskMpeg и т.д. и т.п. Для упертых консерваторов у нас в запасе имеется srGUI - штучка, работающая в MS DOS режиме, понимающая простейшие команды и не обременяющая юзверя лишней инфой. Ну а если охота подрючиться, то милости просим в GordianKnot (Гордиев узел). Разрубишь ты его ой как не скоро, если, конечно, на помощь тебе не придет многолюбезный Middlenight, подкидывающий тебе ссылочку на статью, посвященную этой чудо-проге: http://www.3dnews.ru/reviews/multimedia/gordian-knot.

СПЕЦИАЛИЗИРОВАННЫЕ ПЛЕЕРЫ

ПРОГИ: ATI DVD Player, Creative SoftPC-DVD, PowerDVD, PowerPlayer (все прям сплошь силачи Иваны Поддубные), Intervideo WinDVD, MGI SoftDVD, Ravisent Cinemaster, Varivision VaroDVD, XingDVD.

Собственно, можно было бы ограничиться простым перечислением плееров (кстати, довольно неплохих), если бы не одна хрень: поскольку DVD-плеерам не надо гнаться за поддержкой все новых и новых форматов, основную ставку программеры делают на улучшение воспроизведения видео и звука в DVD. Как ты заметил, некоторые из перечисленных выше DVD-плееров делаются довольно известными производителями мультимедиа-железа, так что эти плееры, как правило, отличаются поддержкой новых фич фирменных железячек. Скажем, плеер от Креатива умеет играть звук через все известные долби-стандарты, а АТИшный плеер меньше грузит проц за счет использования каких-то хитрых примочек в видюхе (ATI, ессесна :). Думаю, излишне упоминать, что проги эти написаны только под Винду (я проверял :).

MPEG4 (DIVX, ASF, WMV)

HISTORY

В декабре 1999-го был зарелизен формат MPEG4, в качестве расширения взявший себе .AVI, а также .ASF и WMV. Наконец-то у не шибко состоятельных юзверей появилась возможность покупать не два диска с фильмом, а один. Правда, новые алгоритмы сжатия не сильно порадовали своими системными требованиями, которые тем не менее с течением времени стали вполне приемлемыми. Кодеки MPEG4 и иже с ним DivX постоянно обновляются, обрастая новыми фишками, а сайт Microsoft - новыми посетителями. Конечно: каждому хочется смотреть и кодировать видео в один из лучших форматов в категории размер файла/качество изображения/цена видеоносителя. Разумеется, для MPEG4 написали кучу плееров и рипперов в другие форматы (кому это надо, ума не приложу), и большинство из них - под Вынь ;).


Спецвыпуск Xakep, номер #031, стр. 031-022-3, ПОЛНОЧНЫЙ ВИДЕОДРОМ. Что мы знаем о виндовом видео

ПОЛНОЧНЫЙ ВИДЕОДРОМ. Что мы знаем о виндовом видео

Томилин aka "Middlenight"

Спецвыпуск Xakep, номер #031, стр. 031-022-3

СПЕЦИАЛИЗИРОВАННЫЕ И УНИВЕРСАЛЬНЫЕ ПЛЕЕРЫ

ПРОГИ: Light Alloy, The Playa, BSPlayer, DIVX Operational Player, QuickTime Pro, Real Player, Sasami2k, Zoom Player, Windows Media Player :).

Чего-чего, а плееров в Винде всегда хватало. Наверное, однажды наступил момент, когда "Универсальный проигрыватель" перестал удовлетворять растущие запросы юзеров, и с тех пор только ленивый не написал свой "самый лучший" плеер, поддерживающий кучу форматов, сглаживание, эквалайзер, исчезающее меню и еще множество "самых-самых необходимых" функций. Стоит ли говорить о том, что, если, скажем, в Линухе сложно найти порядочный плеер, то в Винде дела обстоят абсолютно по-другому: лезешь в Инет, а там... Фавориты киноманов (Sasami, BS player), перебежчики с других платформ (Quick Time Pro), родные русские программы (Light Alloy), встроенные в паки экземпляры (The Playa)... Перечислять и перечислять...

МИКРОТЕСТ

Как я уже упоминал ранее, из всех форматов именно MPEG4 отличается повышенными железными требованиями к компу юзверя. Заявленные кодерами требования - PII400/64. Что ж, посмотрим, как обстоит дело в действительности, а помогут нам в этом 3 компа разных поколений: : P120/32/4, PII366/64/4 и Duron 950/256/32. На них мы попробуем проиграть Divx-клип группы Rammstein "SONNE" (640/480). Используемый плеер - Sasami2K:

Duron 950: Никаких проблем нет, да и быть не может. Клип отлично идет как в оригинале, так и в Full Screen. Больше добавить нечего.

PII366: Если не переводить в Full Screen, то смотрится довольно сносно, хотя иногда и подтормаживает. В Full-е fps падает где-то до 10. В общем, похвастаться особо нечем.

P120: Результат даже сложно назвать слайд-шоу: идет закадровая музыка (MP3), а кадры меняются со скоростью где-то 1/10 сек. Все, хватит с меня - отрубаю кино, если получится. Хватит мучить и себя, и ветерана.

ВИДЕОЗАХВАТ И МОНТАЖ

ПРОГИ: Adobe Premiere, Ulead MediaStudio, Ulead VideoStudio, Pinnacle Studio, Sonic Foundry Vegas Video, Sonic Foundry Video Factory, MainActor, Adobe AfterEffects, SpeedRazor, Cyberlink Power VCR II, MGI VideoWave, Virtual Dub.

Разумеется, когда виндовый юзверь вдоволь насмотрится кина в виндовых проигрывателях, ему захочется сделать свое собственное видео, и, как ни странно, в той же Винде;). Как правило, у такого юзверя присутствует TV-тюнер, видеокарточка с захватом или DV-камера на FireWire. Смею заметить, что в Винде просто тьма прог, поддерживающих такие устройства. Я сейчас говорю, разумеется, не о софте, который, как правило, идет с ними в комплекте, а об универсальных прогах для видеозахвата и монтажа. Самые знаменитые из них - монстроподобные пакеты Ulead MediaStudio Pro и Adobe Premiere, нигде, кроме винды, более не работающие. Трудно даже сказать, чего не умеют делать эти титаны: тут и работа с самыми разными видеоформатами, и покадровый монтаж, микширование звука и прикольные эффекты (эдакие видеофотошопы), экспорт на DV-камеру и обычный видеомагнитофон... Всего не перечислить, а если еще и учесть возможность подключения плагов, то это вообще Пц. Кстати, всю прелесть этих двух пакетов могут каждый день ощущать зрители региональных и столичных кабельных телеканалов. Денег, понятно, таким организациям на профессиональное оборудование никогда не хватает, вот они и пытаются выжать максимум из своих писюков посредством именно Медиа студии, Премьера и иже с ним Adobe AfterEffects - еще одного видеотяжеловеса для производства спецэффектов, в котором, при желании, можно создавать видеооформление, вполне конкурентноспособное со, скажем, некоторыми дециметровыми телеканалами. Кстати, здесь плаги тоже имеются.


Спецвыпуск Xakep, номер #031, стр. 031-022-4, ПОЛНОЧНЫЙ ВИДЕОДРОМ. Что мы знаем о виндовом видео

ПОЛНОЧНЫЙ ВИДЕОДРОМ. Что мы знаем о виндовом видео

Томилин aka "Middlenight"

Спецвыпуск Xakep, номер #031, стр. 031-022-4

Но что это я все про комбайны? Все они достаточно прожорливы к ресурсам, да и баги в них если и есть, то часто они столь же глобальные. Скажем, в свое время попытка Премьера связаться с моим TV-тюнером в 90% случаев заканчивалась полным ступором всей системы. Нет! Раз мы в Вынь, то у нас всегда есть выбор под стать нашей тачке. Скажем, если тебе нужен пакет полегче, но схожий по функциональности с Премьером, то советую заюзать мой любимый MGI VideoWave: окромя качественного видеозахвата у тебя всегда будет отличный монтажный стол, аудиомикшер и перекодировщик. Если же ресурсов тачки катастрофически не хватает, то тебе прямая дорога в Virtual Dub. 740 кило, в которые зашили видеозахват, монтаж AVI-клипов, линейный монтаж (видео плюс звук), конвертор в AVI из MPEG и, конечно, фильтры, большинство которых идет в виде плагинов. Причем много таких фильтров, которых я даже в Премьере не видел, не говоря уже о стандартных, типа Motion Blur или Scale. Проект развивается стремительными темпами, так что советую внимательно следить за выходящими к проге дополнениями.

З.Ы. Как же я забыл, про зашитый в Millenium и XP "Видеоальбом" :), или как он там называется? - забыл, честно говоря. Да, конечно, прога ничего из себя не представляет, но тем не менее похвально, что труженики Microsoft хоть как-то подтягивают совсем уж не продвинутых в плане видео пиплов.

З.З.Ы. Небольшая ложечка дегтя в бочку видеовозможностей Винды, о которой я, как защитник Мастдая, лучше расскажу сам: юзвери, сидящие в 95/98/Me, не смогут захватить AVI-ху (большинство прог для TV-тюнеров записывают видео все-таки в AVI) больше 2 ГБ, что связано с соответствующим ограничением FAT32. НО! Это не такая уж большая проблема: многие проги, вроде Ulead Media Studio Pro, Cyberlink Power VCR или WIN VCR, умеют писать в MPEG (1, 2, 4) на лету с TV-тюнера, правда компешник желательно иметь с процем не хуже 3-его пня. А если у тебя есть платка для Real-Time-захвата видео в MPEG, то вообще замечательно :).


Спецвыпуск Xakep, номер #031, стр. 031-022-5, ПОЛНОЧНЫЙ ВИДЕОДРОМ. Что мы знаем о виндовом видео

ПОЛНОЧНЫЙ ВИДЕОДРОМ. Что мы знаем о виндовом видео

Томилин aka "Middlenight"

Спецвыпуск Xakep, номер #031, стр. 031-022-5

МИКРОТЕСТ

Бытует мнение, что даже для самой элементарной работы с видео в Выне нужен какой-то суперкомп, причем конфигурация этого компа каждый раз изменяется в соответствии с техническим прогрессом. А ну проверим, так ли это. Поставим себе цель: перевести 700 кадров чистой AVI-хи с параметрами 720/576/25 fps в Divx посредством нашего "самого маленького" Виртуал Дуба. Итак, сжимать мы будем посредством кодека Divx 5.02 со средним битрейтом 5000 kbps, а также при помощи трех вышезасвеченных компов: P120/32/4, PII366/64/4 и Duron 950/256/32. Проверим, за какое время они выполнят требуемую операцию:

Duron 950: сжимает со средней скоростью 5 кадров/сек. Итого, через 2 с небольшим минуты получили упакованный Дивиксом файл. Проверили - играет.

P366: сжимает со средней скоростью 1 кадр в секунду, так что подождать пришлось. Окончательное время - около 12 минут.

P120: Вот жопа! Завис...

ПОДВЕДЕНИЕ ИТОГОВ

Юзверь, послушай секунду меня! Я накатал всю эту телегу, дабы донести до тебя следующую мысль: круче и больше видеовозможностей, чем в Выне, ты на персоналке больше нигде не найдешь. Альтернативы виндовому многообразию прог для видео на данный момент действительно не существует и в обозримом будущем не предвидится, так как производителям ПО еще долго будет выгодно кодить под самую распространенную ось. GUT? Я лично считаю, что GUT, поскольку сам сижу в Выне ;).


Спецвыпуск Xakep, номер #031, стр. 031-026-1, DOSУГ НА ОБОЧИНЕ - видео в самой аскетичной ОС

DOSУГ НА ОБОЧИНЕ - видео в самой аскетичной ОС

Томилин aka "Middlenight"

Спецвыпуск Xakep, номер #031, стр. 031-026-1

(middlenight@mail.ru) http://middlenight.h10.ru

Пиплам, проведшим не одну ночь, мучая под одеялом Фигурнова, посвящается...

...Гигантский ядерный гриб расплывался над городом, гоня ударную волну, словно камень, брошенный в воду. Города уже не было. Все, что напоминало о его некогда былом великолепии - это гигантские, переломанные пополам остовы небоскребов нового "Сити". Немногочисленные группки выживших в этой пятиминутной войне людей разбрелись по укрывшим их подземельям коммуникаций глубокого заложения... На счету было все: еда, вода, электричество, развлечения... Компьютеров осталось мало, программ под них - еще меньше. Каждый, кто сумел пронести с собой в катакомбы хотя бы первобытную "четверку" c DOSом на борту, пользовался всеобщим уважением и почетом...

Ладно, перец (перчинка), шутки в сторону. Я же понимаю, что в наши дни сидеть в Досе будет либо тот, у кого не хватает денег на Вынь (в Кащенко такие лежат), либо у кого довольно старое железо. Во втором ничего зазорного, разумеется, нет - не у всех же есть бабло на прогресс, и не надо думать, что не надо думать, что, посвящая свою жизнь ДОСу, обязательно обрекать себя на монашье царство командной строки - даже здесь мультимедиа-развлечений хоть отбавляй. DOS - это не повод, чтобы отказывать себе в просмотре последних новинок видеорынка или прослушивании пары десятков МПэ-тришных альбомов любимого исполнителя. Итак, следи за моей витиеватой мыслью:

WATCHING A GAME & HAVING A DOS

Для начала немного теории. Что нам надо, чтобы смотреть кино/слушать музыку? Нужен в первую голову драйвер для декодирования процем нужного нам видео/аудио формата (в народе - кодек) плюс прога для воспроизведения результата. Откуда все это берется? В мастдае, там понятно - "универсальный проигрыватель", мать его, намертво вшит в Ось, а кодеки... Какие уже есть, а какие надо качать из Инета. Качается все, в основном в виде паков. Нажал на кнопку - все .inf-файлы прописались в system.ini или в реестр (кому интересно - в HKEY_Loсal_Machine\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32). Далее происходит взаимоприятное общение проигрывателя с кодеком, и юзверь начинает приобщатся к культуре. Это в Вынь, ну а в ДОСе что? А что у нас в ДОСе? Реестр тут, как известно, отсутствует. System.ini? Не смешите мои тапочки :). Следовательно, делаем вывод, что досовский проигрыватель должен быть совмещен с кодеками. Так, в общем-то, оно и есть. Скажем, если в DOS-плеере не происходит кардинальных изменений, например, на промежутке между 2.0 и 3.0, то все промежуточные версии отличаются друг от друга только набором зашитых в плеер кодеков.

ПЛЕЕРЫ

Не могу обещать ничего особо выдающегося, типа BSPlayer или Сасами, однако парочку вполне приличных плееров, с которыми не должно возникать проблем, я тебе посоветую. Первым в очереди у нас стоит знаменитый на все ДОСовские конфы "Quick View Player". Самый, на мой взгляд, продвинутый плеер во всех отношениях. Поддерживаемые им форматы - .AVI, .DIV, .QT и .MOV. Кодеков же в него зашито столько, что он без проблем читает как видео/аудио файлы, так и растровые картинки типа BMP или JPEG. В общем, настоящий универсал, который к тому же автоматом определяет твою видюху. Сиречь, проблем с HIGH-color/TRUE-color возникать не должно. Впрочем, если состояние твоего железа таково, что SVGA-карточка - это пока предел твоих мечтаний, то и в этом случае не стоит сильно расстраиваться: заявленные прогой железные требования сводятся к 386 процу и VGA-карточке. Ладно-ладно, потом проверим, что попрет на таком хозяйстве...


Спецвыпуск Xakep, номер #031, стр. 031-026-2, DOSУГ НА ОБОЧИНЕ - видео в самой аскетичной ОС

DOSУГ НА ОБОЧИНЕ - видео в самой аскетичной ОС

Томилин aka "Middlenight"

Спецвыпуск Xakep, номер #031, стр. 031-026-2

РУЧКАМИ, РУЧКАМИ...

Единственная херь, которую нужно настроить для просмотра видео через QV Player, - это звук. Собственно, это относится не только к QV, а ко всем мультимедиа-ДОС-приложениям. Как ни крути, а плаг-энд-прэй нам не светит, так что придется возиться с командными файлами... Или не придется, если у тебя нормальные дрова к твоей звуковухе, которые после запуска соответствующего EXE-шника сами пропишутся в Autoexec.bat и Config.sys. Это в идеале, а если вернуться в суровую реальность, то в общем случае тебе придется открыть в текстовом редакторе Autoexec.bat (в Нортоне - жмакнуть F4, а если уж совсем плохо, то в командной строке набрать C:\edit autoexec.bat) и прописать там что-нибудь вроде:

SET SOUND = C:\SB16;

SET BLASTER=A220 I5 D1 H5 P330 T6;

C:\SB16 указывает путь к каталогу с дровами звуковухи. В "SET Blaster" "A" - это порт ввода/вывода, на котором сидит твоя звуковуха, "I" - значение соответствующего прерывания (IRQ). Чаще всего - именно на 5, иногда 7. "D" и "H" - DMA каналы, "P" - миди-порт, а "T" - тип юзаемого бластера. Как ты, наверное, уже заметил, эти значения подходят под 16-й бластер. Плохо, если у тебя другая карточка, чьи значения отличаются от вышеприведенных, и/или еще кучу дров надо прописывать в Config.sys (Device=C:\... - до гроба не забуду %). Еще хуже, если карточка PCI-ная - придется качать дрова, эмулирующие ISA-шину (ДОЗЗЗ, блин!), да еще и читать прилагающийся к ним толстенный мануал. Здесь уже ничем не могу помочь, будем надеяться только на удачу и твое знание фиглиша.

ИНТЕРТЭЙБЛ

Пользовать QV очень просто, тем более что для этого есть два режима. Если ты мазохист, то выбирай режим командной строки. Пробивать его надо в виде [QV] [выбранная опция] [имя ролика]. Опций там туева хуча, начиная от выбора разрешения экрана, заканчивая использованием в качестве колонок динамика компа. Это уже для упертых мазохистов. Для обычных же людей по первому зову [QV] появляется менюха типа Нортон-Коммандера со всеми необходимыми причиндалами. Смотри - не хочу.

Качается QVPlayer с http://multimediaware.com/qv/.

ПЛЕЕР НУМБЕР 2

Второй рекомендуемой мной ДОСовский плеер называется просто и незамысловато, а именно "MPEG". По существу он является несколько кастрированной версией QV и рассчитан на работу с файлами MPEG-подобных форматов .MPG, .M1V, .MPE, .MPV и .DAT. Иначе говоря, перекачав на свой комп QV и MPEG, ты получаешь вполне полноценный Видео/MP3 - плеер, понимающий все самые распространенные форматы медиа-файлов. Единственная хрень: если у QV есть хотя бы нормальная оболочка, то доступ к MPEG осуществляется только через командную строку. В общем, есть чем забить себе голову, а именно нехилым синтаксисом проги и оперативными клавишами. Дрочить тебе не передрочить :). Ну а я пока пойду тестить скоростные характеристики вышеупомянутых плееров.


Спецвыпуск Xakep, номер #031, стр. 031-026-3, DOSУГ НА ОБОЧИНЕ - видео в самой аскетичной ОС

DOSУГ НА ОБОЧИНЕ - видео в самой аскетичной ОС

Томилин aka "Middlenight"

Спецвыпуск Xakep, номер #031, стр. 031-026-3

Ищи "MPEG" на http://multimediaware.com/mpeg/.

ТЕСТ-ДРАЙВ

Ну а как мне тестировать-то это добро? И, главное, на чем? А ну-ка, что у нас лежит на антресолях? Здесь у нас обнаруживаются два моих самых первых компа: 486 dls Cyrix 40/8/1 и P120/32/4. Ну и для чистоты эксперимента разживемся у другана его 850-ым селероном/128/8. Винт каждого компа принципиального значения не имеет - киношку мы будем читать с диска, а своп Дос все равно не использует. Подключаем все это добро по очереди к моему рабочему даймондтрону (довольно экзотическая картина получается, надо сказать :) и начинаем замерять бенчмарки... А как, собственно? А-а-а... У перцев свои секреты :). Дабы не прибегать к сложным техническим средствам, я просто-напросто взял свой пронумерованный цифровой фотоальбом и прогнал его через Премьер на предмет получения нескольких видеофайлов разного формата и разрешения. Получились следующие ролики: 320х240 и 720х576 в MPEG2 и Divx. Все с максимальным битрейтом и 25 fps, ну а номер каждого кадра я и так наизусть помню. Итак, тестим в обоих плеерах:

486. 320х240 MPEG2: смотреть можно, хотя киношка идет с 4 fps. Full screen - отвратен. Про остальные ролики, думаю, все и так понятно. Здесь для таких целей аппаратный декодер не помешал бы...

P120. 320х240 MPEG2 проходит на ура - как в оригинале, так и в full-screen. Надо заметить, что в Мастдае fps таких роликов в full-е упали бы, примерно, процентов на 30-40. 720х576 - видео идет, но где-то с 1 fps, и в натурале, и в full. Divx - 320х240 - fps сократился до 10, но смотреть можно. 720х576 - слайд-шоу.

Cel. 850. Все ролики идут, как и положено, в 25 fps, впрочем, удивляться этому не приходится.

Несмотря на убийственные результаты теста, можно смело заявить, что другого выбора у компьютерных шитников все равно нету :(. А тестам верить весьма стремно - известно, что Ильич гонял на Р166 "Властелина колец" и не особо парился fps-ами. Ведь в нормальных фильмах кейфреймов меньше, чем в моем фотоальбоме :).


Спецвыпуск Xakep, номер #031, стр. 031-028-1, ВИДЕО И LINUX. Софт для мега-рипперов

ВИДЕО И LINUX. Софт для мега-рипперов

Green (green@linuxhacker.ru)

Спецвыпуск Xakep, номер #031, стр. 031-028-1

ДЕЦЛ ИСТОРИИ

Итак, начинаем наш краткий экскурс в историю и теорию видеопроигрывателей. Все помнят, как работают видеоплееры в Windows? Для тех, кто прогуливал, повторяю: в центральную базу видеокодеков устанавливаются кодеки, при попытке проигрывания медиафайла тип кодека определяется по специальному методу (например, fourCC), и кодек преобразует поток из файла в поток кадров, которые уже и отдаются непосредственно плееру. Таким образом, в Windows все кодеки общие для всех плееров (понятно, что только для тех, которые пользуются таким механизмом, но тех, которые не пользуются, практически нет). От себя все эти плееры могут добавить последующую обработку изображения, выбор аудиоканала и прочие рюшечки.

Всего этого добра в Linux'е нет. Нет никакой централизованной базы для кодеков, никакого стандартизированного API. Есть просто некоторое количество проигрывателей, каждый из которых тянет все или почти все свои кодеки за собой или внутри себя. Наиболее ярким и одним из ранних примеров этого подхода является xanim (http://xanim.polter.net). Сейчас этот проект уже не развивается, но он показателен тем, что, помимо открытых кодеков, его автору удалось договориться с производителями некоторых коммерческих кодеков, чтобы они скомпилировали их в совместимом с xanim формате. До некоторого момента времени все видеоплееры для Linux страдали от недостатка кодеков, ни Apple с их QT, ни Intel (с их intel indeo), ни тем более Microsoft не спешили адаптировать свои продукты (и кодеки) под еще одну платформу. Практически единственным применимым форматом являлся MPEG, да и тот поначалу был не очень хорошего качества. Появилась даже контора (http://www.mpegtv.com), которая продавала улучшенный mpeg-плеер для Linux, способный проигрывать в приемлемом качестве также и VideoCD, причем их продукт пользовался определенным успехом.

В примерно то же время развивался проект WINE (http://www.winehq.com), основной целью которого была эмуляция windows-окружения для запуска windows-приложений под Linux. И, видимо, однажды один из страдающих от недостатка видео под любимой операционкой хакеров посмотрел на WINE, и его осенило - вот есть Windows, вот есть кодеки, вот есть запускалка приложений Windows, так почему бы все это не объединить? И объединил. Получились библиотека avifile и проигрыватель aviplay (http://avifile.sourceforge.net/). Библиотека подгружала к себе виндовые dll'ки, убеждала их, что они живут в родном окружении, подавала им на вход зажатый видеопоток и получала на выходе долгожданное, готовое к показу видео. Этот проигрыватель очень быстро получил огромную популярность, потому что позволял проигрывать ранее недоступные фильмы в DivX, а затем и другие форматы подоспели. Понятное дело, что не все было гладко, не все кодеки работали, но начало было положено, и avifile можно считать новой вехой в развитии на пути доступного Video под Linux (на самом деле это решение подходит только для машинок на x86 процессорах, но таких - подавляющее большинство).

Пока бесплатные плееры развивались, Linux тоже не стоял на месте и с пеной у клюва отвоевывал себе место на пляже (ну в смысле на пользовательском деcктопе). И даже отвоевал так (относительно) много, что его заметили в Real Networks и выпустили Real Player под Linux.


Спецвыпуск Xakep, номер #031, стр. 031-028-2, ВИДЕО И LINUX. Софт для мега-рипперов

ВИДЕО И LINUX. Софт для мега-рипперов

Green (green@linuxhacker.ru)

Спецвыпуск Xakep, номер #031, стр. 031-028-2

НАШИ ДНИ

Сегодня одними из основных плееров, претендующих на роль "универсального проигрывателя", можно назвать, пожалуй, всего два: Xine (http://xinehq.de) и MPlayer (http://www.mplayerhq.hu). Эти два проекта развиваются по двум разным путям. В MPlayer основной упор делается на проигрывание возможно большего числа форматов, менюшки, скины и прочие прелести цивилизации появились в нем не так давно. В Xine, похоже, упор сделали на внешний вид, менюшки, окошки - в надежде, что, притянутые красивым внешним видом, появятся толпы разработчиков и допишут нужные кодеки.

MPLAYER

Создатель этого проекта, похоже, очень хотел смотреть разного рода видео, но самолично писать все кодеки его не вставляло - так ведь и мозги могут отсохнуть, поэтому MPlayer умеет использовать практически все существующие кодеки и библиотеки, подходящие для проигрывания видео или аудио, как нативные Linux'овые, так и кодеки от Windows (long live avifile). Текущая версия - 0.90, она умеет проигрывать практически все что угодно, причем практически все кодеки раздаются прямо с сайта проекта (http://www.mplayerhq.hu), даже кодеки из Windows, кодеки от QT, RealPlayer (варез в Венгрии тоже ценят). Проигрываются DVD, причем с поддержкой навигации. Кстати, MPlayer проигрывает DVD даже если его региональный код не совпадает с кодом, выставленным в твоем DVD драйве, просто нужно немного больше мощности процессора потратить на необходимую перекодировку и предварительный подбор ключа. В ассортименте субтитры, имеется обширный набор фильтров для тех, кому некуда девать гигагерцы. Для тех, у кого не такие крутые тачки, можно отключить все фильтры, выставить режим пропуска кадров и смотреть видео на совершенно слабых машинках, которым, казалось бы, место давно уже разве что на свалке истории. MPlayer может принять картинку с твоего TV тюнера, если он у тебя есть. А если нету, он может качать видеопоток по сети (естественно, требуется наличие сети).

ИНСТАЛЛИМ

Инсталляцию сего чуда программерской мысли рекомендуется производить путем компилирования из исходников, так как только таким образом можно добиться максимальной производительности. Итак, с http://www1.mplayerhq.hu/MPlayer/releases качаем самый последний релиз, там же в "папке" codecs можно разжиться таким количеством кодеков, о котором под Windows можно только мечтать. Всякие Codec паки просто отдыхают. Мои виндовые друзья меня уже достали - треть фильмов они не могут толком поглядеть, то у них нет звука (например, потому что звук в ac3), то звук есть, но сразу "три в одном", как у "Братва и Кольцо" от Гоблина, то нет изображения, "незаконченные" aviшки виндозные плееры тоже переваривать не желают, и я могу еще очень долго перечислять ;).

В "папке" fonts можно разжиться шрифтами для субтитров. Затем все это нужно установить, как-то виндовые кодеки положить в /usr/lib/win32, затем распаковать MPlayer-версия.tar.bz2, зайти в каталог MPlayer-версия, запустить ./configure и затем make && make install. Готово, инсталляция завершена! Можно смотреть кино ;).


Спецвыпуск Xakep, номер #031, стр. 031-028-3, ВИДЕО И LINUX. Софт для мега-рипперов

ВИДЕО И LINUX. Софт для мега-рипперов

Green (green@linuxhacker.ru)

Спецвыпуск Xakep, номер #031, стр. 031-028-3

БОНУС

В качестве дополнительного бонуса вместе с mplayer ты получаешь mencoder, это такая мегатулза, которая позволит тебе перекодировать из любого поддерживаемого в любой хорошо поддерживаемый формат (обычно mpeg4 или DivX ;) ), что является неоценимым подспорьем при рипаньи DVD и VideoCD. Также можно поменять, изменить размеры и битрейт, собрать кучку отдельных кадров в фильм и т.д. В качестве исходного источника, помимо DVD/CD/файлов, могут выступать и радио/TV Tuner.

Возможностей очень много, и поэтому я рекомендую тебе выбрать время, почитать man mplayer и разобраться во всем самому, тем более что это так интересно.


Спецвыпуск Xakep, номер #031, стр. 031-030-1, FloppyOS. Полноценная операционка на дискете

FloppyOS. Полноценная операционка на дискете

5p1k3 (fallout@pisem.net)

Спецвыпуск Xakep, номер #031, стр. 031-030-1

Романтичная эра дискет постепенно уходит в далекое прошлое :(. Крупные компании давно разворачивают программы по отправлению дискет в мир иной (рекомендуют не комплектовать новые компы флоповодами, отказываются производить их). Но до сих пор полноценной замены дискеткам так и не найдено.

Они безнадежно устарели: объем, время доступа к данным, скорость записи, надежность - все это оставляет желать лучшего. Альтернатив много (CD, MD, ZIP, JAZZ, USB-брелки, etc), но они все уступают дискетам в цене, компактности, распространенности и в возможности моментальной перезаписи или дозаписи инфы. Сегодня мы рассмотрим, как выжать максимум из 1,44-мегового друга и запихнуть на него полноценную ось. Именно полноценную.

БЕГИН

На дискетку можно запихнуть урезанные версии никсов (Линух, Юникс, БСДя), первые версии маздая и некоторые другие, написанные с нуля специально для дискет (MenuetOS). ДОС (с оболочкой Нортон и Волков командером) рассматривать не буду, также не буду писать про спасательный комплект на дискетке (про это уже писал Дронич в Спеце про софт в Y2K+2 году).

Если у тебя возникает вопрос "Зачем это надо?" - то сейчас объясню. Во-первых, одно-дискетная ось прекрасно справляется с ролью бутявки (или спасательного комплекта при гибели основной операционки). Во-вторых, можно вернуть к нормальной жизни старый-старый комп (даже без жесткого). В-третьих, это переносная ось, где бы ты ни был, - твоя любимая, настроенная под тебя ось, всегда в твоем кармане. В-четвертых, с помощью этого можно пытаться обходить защиту или ограничения, поставленные на основной системе. В-пятых, захотел познакомиться с никсом, а на винт ставить ничего не хочешь или боишься - не проблема :). Достаточно аргументов?

Linux семейство

Семейство ластоногих, влезающих на одну дискету, состоит из множества особей. На просторах Инета можно найти не один десяток, если не сотню всевозможных дистрибутивов этой ОСи. Из них много кустарных (исходники-то всем открыты), но есть и выдающиеся индивиды, заслуживающие внимания. Существуют узконаправленные версии Линуха (например, для создания роутера, сервака, моста, фаерволла) и оси, предназначенные для всех и каждого. Некоторые дистрибутивы предназначены специально для новичков (с упрощенной версии будет легче начинать знакомство с никсом), другие сделаны в основном для boot-rescue целей, в третьих делается упор на доступ к сети, etc. Также есть много Линухов, влезающих на две-три дискеты, но про это пока забудем, так как в один дисковод одновременно три дискеты не засунешь, только если очень постараться :)... Немалый список (более 50 особей) прочих Линуксов можешь заценить на www.unixware.ru.

Кстати, практически все никсы (кроме коммерческих) распространяются по лицензии GPL (General Public License). Это значит, что исходники открыты для всех и если ты чувствуешь в себе знания и силы исправить или дополнить то, что по-твоему сделано в оси плохо, то флаг тебе в руки. Но потом придется убедить автора, что ось без твоего исправления жить никак не может и в новую версию должны быть в обязательном порядке включены твои гениальные изменения.


Спецвыпуск Xakep, номер #031, стр. 031-030-2, FloppyOS. Полноценная операционка на дискете

FloppyOS. Полноценная операционка на дискете

5p1k3 (fallout@pisem.net)

Спецвыпуск Xakep, номер #031, стр. 031-030-2

ShareTheNet

Первая ось в обзоре. ShareTheNet появился на свет в далеком 1997 году. Основное предназначение оси - соорудить из обычного старенького компа сетевой роутер или фаерволл. На момент появления эта ОСь была единственной в своем роде (учитывая то, что она работала с дискеты). Вначале это был коммерческий проект, ось успешно продавалась через сеть за деньги и была довольно известна. Около года назад автор полностью забил на саппорт и сделал ShareTheNet бесплатной и свободной для скачивания.

Системные требования у операционки довольно скромные (386 проц, 8 метров оперативки, модем/сетевая карта). STN одна из самых легких в обзоре, ее вес составляет всего около 700 кило. По адресу www.sharethenet.com можно залить себе на винт саму операционку, а также прочитать подробную документацию и faq.

FREESCO

Freesco в принципе похож на ShareTheNet. Эта ось также основана на ядре Линукса, выполняет сходные задачи, на старенький комп особо не жалуется (просит всего 386 проц, 6 метров оперативки и модем или сетевую карту). Вот только возможностей у нее в несколько раз больше. Freesco справляется с обязанностями маршрутизатора (небольшого), сервера (диал-ин, http, print) и моста. Как утверждает автор, секрет Freesco кроется в использовании лучших из маленьких программ для Линуха. ОСь спокойно помещается на дискете и с нее работает. Установка системы осуществляется при помощи конфигурационной утилиты, настраивающей всю систему. FreeSco считается одной из самых простых в обращении Линукс систем. Недавно была зарелизена версия 0.3.1, проект активно развивается. Подробности на сайте www.freesco.org. Правда, там все на буржуйском наречии, если не знаешь аглицкого, то... мне тебя жаль :).

RIP

Еще один мини-дистрибутив Линуха. В первую очередь выполняет boot-rescue функции. Также может выполнять большинство стандартных операций. RIP существует в двух версиях: одна для бута с дискеты, другая для загрузки с сидюка. Последняя версия - 5.2. Всем любителям никса рекомендуется в качестве бутявки :). Обитает по адресу: www.tux.org/pub/people/kent-robotti/looplinux/rip/. На сайте, помимо самой оси, можно найти документацию, конфиги для нее, программу для создания бутявок по конфигам и прочее. Там же лежит аналогичная система на основе FreeBSD и документация к ней.

muLinux

Пожалуй, muLinux - самая интересная ластоногая особь в этом в обзоре. В основу работы этой оси положен отличный от прочих принцип работы. При запуске операционной системы muLinux целиком загружается в оперативную память (RAM) и при дальнейшей работе к дискете не обращается (ее можно смело вытаскивать после загрузки). Благодаря этому можно подгружать графический интерфейс, дополнительные модули, плагины, софт с других флопов во время работы. Теоретически то же самое можно проделать и с прочими осями из обзора, но... придется самому ручками переписывать код загрузки (тут уже как повезет :). Но такой подход сразу увеличивает требования к объему оперативной памяти :(.


Спецвыпуск Xakep, номер #031, стр. 031-030-3, FloppyOS. Полноценная операционка на дискете

FloppyOS. Полноценная операционка на дискете

5p1k3 (fallout@pisem.net)

Спецвыпуск Xakep, номер #031, стр. 031-030-3

В стандартную поставку входит сама ось на одной дискете и оболочка X-windows на другой. muLinux может быть практически любым сетевым и не только устройством, для нее существует множество плагинов, дополняющих и так нехилые возможности. Также ось может грузиться с сидюка или харда. Системные требования такие же низкие, как у рассмотренных выше. Вот только объем оперативной памяти надо рассчитывать из того, сколько собираешься одновременно модулей подгружать.

Сейчас последняя версия операционки - 13r2 (финальная и стабильная). Официальный сайт - mulinux.sunsite.dk, где лежит все необходимое для близкого знакомства с этой осью (сама ось, плагины к ней и мегатонны документации).

Сделай сам

Оказывается, дистрибутив Линукса можно также собрать самому :). Причем ты сам можешь выбрать, на что в основном будет направлена твоя ось (сетевой клиент, загрузочный диск...). Для этого существует специальная прога, которая называется Build Your Linux Disk или просто BYLD. Однако не стоит думать, что это так просто - установил программу, отметил галочки, чего ты хочешь от будущей оси, и все готово. Программа консольная под Линух, предназначенная в первую очередь для разработчиков и системных админов. При работе с ней потребуются знания С и основы работа с никсом. Программу заливай с www.sourceforge.net и создавай свой VasyaPupkinNix.

PicoBSD

Маленький такой демон, красного цвета, в красных кедах и с острым хвостом. Очень похож на своего старшего брата, вот только рогов нет и трезубца лишили.

Однодискетная версия известной FreeBSD (PicoBSD часто так и называют - FreeBSD on one floppy disk). Последняя версия на данный момент - 0,42. Основана на базе ядра FreeBSD версий 2.2.5 или 3.0. Основной упор при создании данной оси был сделан на создание из маломощного (бездискового) компьютера полноценной сетевой машины (клиента или сервера). На данный момент существует в трех видах сборок: диал-ап, маршрутизатор и диал-ин. Ось совершенно не требовательна к ресурсам машины: достаточно 386 (не подумай мегагерц :) проца и 8 метров оперативки для диал-апа или 12 mb для роутера сети или сервера диал-ин, и даже не требует наличие винта. К сожалению, PicoBSD полностью лишен графической оболочки ;(, если ни разу не общался с никсом в консольном режимом, то будет поначалу трудновато. Хелп можно почитать на сайте www.freebsd.org, во встроенной справке, или купить какую-нить буку по БСДе.

Диал-ап версия позволяет получить доступ в Инет через момед (через РРР протокол), естественно, с поддержкой TCP/IP. Из сетевых утилит прилагаются: lynx (текстовый броузер с поддержкой ХТМЛ), telnet, ping, route, утилита для ftp и прочие. Имеется скрипт для автоматической настройки РРР. Также организована поддержка локальной сети Ethernet. Еще в наличии достаточное количество основных утилит для работы ОСи. Возможно также редактировать и сохранять конфигурации оськи. Работа над PicoBSD постоянно продолжается, скоро будет добавлен почтовый клиент, будут еще уменьшены требования к системе.


Спецвыпуск Xakep, номер #031, стр. 031-030-4, FloppyOS. Полноценная операционка на дискете

FloppyOS. Полноценная операционка на дискете

5p1k3 (fallout@pisem.net)

Спецвыпуск Xakep, номер #031, стр. 031-030-4

Версии для роутера или dial-in сервера имеют в комплекте достаточный набор утилит для организации в сети соответственно роутера или сервера. Поддерживается протокол РРР, фильтрации пакетов Firewall и многое другое.

Решился опробовать - качай зазипанный архивчик по адресу www.freebsd.org. В архиве тебя ждут: файл picobsd.flp (образ дискеты) и ридми. Для создания из образа - загрузочной дискеты придется скачать специальные программы: ftp://ftp.freebsd.org/pub/FreeBSD/tools/rawrite.exe или ftp://ftp.freebsd.org/pub/FreeBSD/tools/fdimage.exe. Остальные инструкции по установке читай на сайте.

Если хочешь узнать больше, то бегом на people.freebsd.org/~picobsd/picobsd.html (официальный сайт) или www.kot.dp.ua/PicoBSD/PicoBSD_index.html (домашняя страничка PicoBSD).

MenuetOS

Эта ОСь написана с нуля на 32-битном ассемблере всего одним человеком. У MenuetOS полноценное уникальное ядро со встроенным GUI (Graphical User Interface). Она имеет многозадачную и многопотоковую конструкцию. Ось воспринимает практически все современное железо, с этим проблем возникнуть не должно. На сегодня последняя версия 0.73.

Когда в первый раз видишь эту ось, возникает ощущение, что эта какая-то новомодная оболочка выня, ну или скин для ХР :), а никак не ось, занимающая всего одну дискету. Разрешение до 1280*1024 и 16,7 миллиона цветов. Те же рабочий стол, иконки, волпапер, окна, панель задач внизу, кнопочка "пуск" в левом нижнем углу, часики справа внизу... При последующем рассмотрении возможности системы просто потрясают :). Я думаю, оська придется по вкусу практически каждому. Уже захотелось скачать?

Графические возможности системы заслуживают высшей оценки. К системе прилагается несколько игр: тетрис, трехмерная (!!!) бродилка и несколько других. Также лежит несколько демок, демонстрирующих, чего позволяет ось (динамичный огонь, скринсейвер из системы точек). Есть проигрыватель сидюков, редактор иконок... Так что даже в развлекательных целях будет интересно взглянуть.

Действительно, при первом просмотре кажется, что ось носит по большей части развлекательный характер. Это впечатление обманчиво. ОС располагает собственной средой для программирования на ассемблере (FASM), существуют определенные спецификации по написанию прог для данной оси. Приложения можно писать не только на асме, но и на си, паскале, бейсике (но с последующей перекомпиляцией). Операционка не лишена и сетевых средств, она базируется на протоколе TCP/IP, имеет встроенный броузер, а также позволяет организовать небольшой сервак под своим управлением. Из-под MenuetOS возможен доступ к жесткому диску (FAT32 разделы). Еще многого я не перечислил - сюрпризом будет :-).

Установка абсолютно тривиальна. Качаешь архив - суешь пустую дискетку в флопик - запускаешь msetup.exe - ребутишься - грузишься с дискеты - наслаждаешься :-). Вот только надо будет все настройки оборудования ручками выставить, ось этого сама не умеет.

Официальный сайт МенуетОС (странное название все-таки) - www.menuetos.org, - там можно всегда найти свежую версию и новые примочки для оськи. Намного более интересный сайт - menuet.narod.ru. Тут находится полное русское описание оси, лежит много статей по принципам работы ядра MenuetOS, по программированию для оси и в ее среде, находятся форум, faq, ссылки, скрины и многое другое.


Спецвыпуск Xakep, номер #031, стр. 031-030-5, FloppyOS. Полноценная операционка на дискете

FloppyOS. Полноценная операционка на дискете

5p1k3 (fallout@pisem.net)

Спецвыпуск Xakep, номер #031, стр. 031-030-5

Судя по всему, эту ось ожидает неплохое будущее, учитывая, что лимит возможностей ее далеко не исчерпан. ИМХО, к версии 1.0 будет создан просто шедевр.

Windows 1.0-2.0

Для большинства пользователей знакомство с этой замечательной %-Р операционной системой началось с версии 3.1 или 3.11, для других - с 95-ой или NT (расшифровка No Thanks мне больше всего понравилась :). А про версии 1 и 2 все как будто забыли. Исправим этот пробел.

Первые версии мастдая не были операционными системами, это были всего лишь графические оболочки ДОСа. 20 ноября 1985-го появилась на свет Windows 1.0; несмотря на относительно прогрессивную графическую среду для того времени (Макинтош тогда выглядел намного приятнее), эта оболочка распространения не получила из-за ничтожного количества софта под нее и множества багов. Windows 2.0, вышедший 9 декабря 1987-го, поднялся намного выше, было продано несколько миллионов копий (успеху способствовал потыренный у Макинтоша интерфейс :). Следующие версии выня были Windows 286 и 386, собранные на основе 2.0. У первых версий было много проблем, по сравнению с их надежностью и тормозами 95 вынь может показаться раем :). В то время на МелкоМягких одновременно обиделись Apple (MS спер у них много уникальных идей) и IBM (MS забил на разработку OS/2).

В установленном виде вынь 1.0 занимает менее метра, а вынь 2.0 своей тушей забивает дискету почти до отказа. В оставшееся на дискетке место можно напихать еще немного софта и дров, если найдешь. На саппорт этих систем все уже давно забили, так что с поиском обновлений будут большие проблемы. Системные требования первых версий были просто запредельными: x86 проц и 256кб оперативки :-), хард (тогда он был роскошью) для работы не требовался.

Внешний вид оболочек отдаленно похож на привычный нам вынь (только с 4 или 16 цветами и разрешением 320*240 :). Все те же окна (в 1-ом они располагаются только мозаично, а во 2-ом окошки уже друг друга с радостью перекрывают и перемещаются свободно по экрану). В изначальный комплект поставки входит немного софта для полукомфортной работы. Notepad - примитивный текстовый редактор, календарь с событиями, Paint (и в Африке Paint), Write - текстовый процессор (звучит сильно, а на самом деле ничего интересного) и прочее. Удаленный доступ осуществлялся через нуль-модемный кабель. Поддержка TCP/IP началась только с версии 3.11 (Билли поздновато осознал, в чем сила :).

В рунете вынь 1.01, 1.03 и 2.03 можно найти на сайте www.softodrom.ru в разделе антиквариат (через поиск).

ЕНД

Еще много осей в этот обзор не попало, например QNX (qnx.com или qnx.org.ru). Если тебе будет интересно, то ты всегда сможешь подобрать что-нибудь для себя в Инете или написать мне (всегда рад письмам читателей).


Спецвыпуск Xakep, номер #031, стр. 031-030-6, FloppyOS. Полноценная операционка на дискете

FloppyOS. Полноценная операционка на дискете

5p1k3 (fallout@pisem.net)

Спецвыпуск Xakep, номер #031, стр. 031-030-6

Подведем небольшие итоги. Если ты собрался организовать роутер или сервак, то стоит обратить внимание на ShareTheNet, FREESCO или PicoBSD. Тут надо все опробовать самому и выбрать, что нравится и подходит лично тебе. Если тебе нужна бутявка под никс, то присмотрись к RIP, а под вынь вполне сойдет MS-DOS с оболочкой Windows 1.0 или 2.0. Ну а если тебе захотелось заиметь ось на все случаи жизни, то обязательно надо взглянуть на muLinux и MenuetOS. Удачи.


Спецвыпуск Xakep, номер #031, стр. 031-034-1, KICKSTART. Ставим Линукс с полпинка

KICKSTART. Ставим Линукс с полпинка

LinuxAdmin

Спецвыпуск Xakep, номер #031, стр. 031-034-1

(ikareline@yandex.ru)

Да-да, именно так я перевожу фразу "Linux Kickstart". Что ты получишь в итоге, научившись устанавливать Линукс с полпинка: вставляешь дискету, грузишься с загрузочного инсталляционного линуксового CD-ROM, набираешь "linux ks=floppy" и идешь заниматься своими делами, а через полчасика подходишь и получаешь систему с пакетами, которые тебе нужны, диск разбит как надо и плюс все уже настроено для работы. В общем, система готова к работе, то есть ждет твоих приказаний.

ДОЛГИЙ ПУТЬ К СЧАСТЬЮ

Естественно, для того чтобы воплотить все это в жизнь, надо немного потрудиться. Сразу оговорюсь, я имею в виду дистрибутив RedHat версии 5.0 и выше, а конкретно я провожу эксперименты на версии 8.0. Скорее всего, другие дистрибы тоже имеют подобную функцию, в Красной Шапке она реализована отменно.

Итак, начнем. Прежде всего, необходимо установить Шапку. Рекомендую, чтобы облегчить себе работу, при выборе пакетов в процессе инсталляции, установить группы пакетов, которые тебе могут понадобиться, поставить галку на "Индивидуальный выбор пакетов (Select individual packages)", переключиться в следующем экране на "Простой просмотр (flat view)" и выбрать только те индивидуальные пакеты, которые тебе нужны (надеюсь, предыдущие статьи помогли тебе с выбором).

Ладно, будем считать, что система установлена, ты удалил всякий хлам с винта и радуешься жизни. Вдруг ты поставил какой-нибудь пакет или удалил какой-нибудь файл (я знаю, ты крут и работаешь только под root'ом), и система падает. Долгий тяжелый вздох, из тумбочки достаются сидюки с дистрибом, и целый день уходит на инсталляцию системы и настройку всех прог, русификацию и прочую ерунду.

Я предлагаю забыть про эту ненужную возню. Лучше потратить время один раз и потом восстанавливать систему за полчаса (именно столько занимает инсталляция RedHat 8.0 на моем 400-м целероне).

ОДНО ДВИЖЕНИЕ, И КАЙФ

Что надо сделать? Практически ничего! Разработчикам RedHat поставить памятник разве что. Заходи в свою домашнюю директорию (то есть в папку /root - ты ведь под ним работаешь). Находим там файл anaconda-ks.cfg и открываем его в каком-либо редакторе (при желании можешь скопировать его на дискету и править в notepad'e в Виндах, но эту уже из разряда извратов). Что же мы найдем в этом файле? А здесь мы найдем ответы на все вопросы, которые задавал тебе инсталлятор при установке системы. Соответственно, зачем отвечать ему снова, надо лишь скормить ему этот файл и идти пить чай (пиво), ну, в общем, заниматься делом, а не отвечать на дурацкие вопросы какому-то роботу, пусть и дружелюбному.

ЧТО ВНУТРИ?

Ладно, давай повнимательнее посмотрим на этот файл. Что мы здесь видим?

# Kickstart file automatically generated by anaconda.

install

lang ru_RU.koi8r

langsupport --default en_US.UTF-8 en_US.UTF-8 ru_RU.UTF-8

keyboard us

mouse generic3ps/2 --device psaux

xconfig --card "NVIDIA GeForce 4 (generic)" --videoram 65536 --hsync 30-56 --vsync 50-120 --resolution 1024x768 --depth 16 --startxonboot --defaultdesktop kde

rootpw --iscrypted $1$?Zd5?UxduSNdxawqa0/UWEyAh.


Спецвыпуск Xakep, номер #031, стр. 031-034-2, KICKSTART. Ставим Линукс с полпинка

KICKSTART. Ставим Линукс с полпинка

LinuxAdmin

Спецвыпуск Xakep, номер #031, стр. 031-034-2

firewall --disabled

authconfig --enableshadow --enablemd5

timezone Europe/Moscow

bootloader --location=mbr

Мы видим, что ты выбрал язык для исталляции русский, системные языки - русский и аглицкий, раскладка клавы - американская, мыша - ps/2, видюха - nvidia geforce4, разрешение 1024х768 с глубиной цвета 16, Х запускаются при старте Линуха, ты пользуешься KDE. Обрати внимание, что пароль рута, который ты вводил при установке, здесь не засвечен (вдруг врагам удастся получить доступ к этому файлу). Смотрим дальше: файрволл отключен (я люблю настраивать его сам, что и тебе советую), временная зона - Москва, загрузчик устанавливается в Mbr (то есть master boot record). Охота тебе отвечать на эти вопросы каждый раз? Мне - нет. Смотрим еще дальше.

# The following is the partition information you requested

# Note that any partitions you deleted are not expressed

# here so unless you clear all partitions first, this is

# not guaranteed to work

#clearpart --linux --drives=hda

#part /boot --fstype ext3 --size=100 --ondisk=hda

#part / --fstype ext3 --size=700 --grow --ondisk=hda

#part swap --size=128 --grow --maxsize=256 --ondisk=had

Последние 4 строки надо раскомментарить (убрать знак "#"), иначе инсталлятор тормознет и попросит тебя задать сведения о разбивке диска. Если, конечно, при следующей установке системы тебе захочется разбить диск по-другому (не забудь взять молоток, кувалду или топор), то можешь оставить их закомментированными и выбрать разделы по новой во время установки, но наша цель - "с полпинка", если ты не забыл. Здесь же мы удаляем все линуксовые разделы на первом физическом диске (clearpart -linux -drives=hda) и создаем 3 раздела: /boot размером 100 МБ, / размером 700 Мб и растущий, пока не займет все свободное место, и раздел под своп, который изначально имеет размер 128 Мб и может расти до 256 Мб.

КУЛЬКИ

Ладно, с разделами покончено, и начинается самое интересное - пакеты.

%packages

@ Dialup Networking Support

@ Games and Entertainment

@ Graphical Internet

@ KDE Desktop Environment

@ Kernel Development

@ Printing Support

@ Russian Support

@ System Tools

kpaint

-sendmail

-kernel-pcmcia-cs

Острый взгляд опытного установщика RedHat без труда определит, что после символа "@" следует название группы пакетов, а снизу идут названия индивидуальных пакетов. В данном случае я поставил поддержку диалапа (Dialup Networking Support), игрухи (Games and Entertainment), графический Интернет (Graphical Internet), графическую среду КДЕ (KDE Desktop Environment), исходники ядра (Kernel Development), поддержку принтера (Printing Support), поддержку русского языка (Russian Support) и системные тулзы (System Tools).

Дальше я добавил пакет kpaint и удалил sendmail и kernel-pcmcia-cs (у меня не ноут, а обычная тачка). Как видишь, чтобы удалить пакет, надо поставить перед его именем знак "-". Обрати внимание, что названия пакетов идут без номера версии.

Полный список групп и пакетов, которые в них входят, ты найдешь на первом сидюке дистриба в файле /RedHat/base/compls.xml.


Спецвыпуск Xakep, номер #031, стр. 031-034-3, KICKSTART. Ставим Линукс с полпинка

KICKSTART. Ставим Линукс с полпинка

LinuxAdmin

Спецвыпуск Xakep, номер #031, стр. 031-034-3

Рекомендую переименовать файл anaconda-ks.cfg в просто ks.cfg (именно файл с таким именем ищет инсталлер по умолчанию) и сохранить его куда-нибудь на флоппик или другой носитель, и всегда держать под рукой. Допустим, ты работал, и тебе понадобилось удалить/установить на машину какой-нибудь пакет. Ты его устанавливаешь, а потом сразу добавляешь его в свой файл ks.cfg, и при переустановке системы тебе не надо вспоминать, как этот пакет назывался, и выискивать его на трех дисках - он установится при инсталляции системы.

УСТАНОВИ СЕРЕГУ В ПОЗИЦИЮ

Как же теперь, собственно, запустить инсталляцию? Вставляешь дискету, на которой записан файлик ks.cfg и грузишься с первого дистрибутивного сидюка. У тебя выскакивает графический экранчик и внизу надпись "boot:". Здесь набираешь:

boot: linux ks=floppy

То есть говоришь, что хочешь инсталлировать систему методом kickstart, а файл конфигурации находится на флоппешнике. При желании можешь поместить этот файл в другое место (на раздел на винте или на сидюк), тогда надо указать в явном виде устройство и полный путь к файлу. Понятно, что можно хранить на флоппе несколько файлов под разные конфигурации. Представь, что ты помогаешь ставить Линух нескольким своим друзьям. Вдруг у одного из них падает система. Ты приходишь к нему с флоппешкой, берешь дистриб, запускаешь инсталляшку и набираешь, например:

boot: linux ks=hd:fdo/seregalamo-ks.cfg

(соответственно, файл seregalamo-ks.cfg должен быть заготовлен заранее и помещен на дискетку). И говоришь: "Ладно, Серега, у меня еще куча дел, надеюсь, сидюки сам сможешь переставить?".

СРЕДА С ЧЕЛОВЕЧЬИМ ЛИЦОМ

А файлик этот ты можешь заготовить дома на своей машине, да еще и в дружественной графической среде. Для этого служит прога redhat-config-kickstart (она, естественно, должна быть установлена на твоей машине). Просто нажми "Start -> Run -> redhat-config-kickstart", и увидишь следующее окно:

Дальше выбираем метод инсталляции:

Выставляем опции загрузчика:

Определяем, как будем разбивать жесткий диск:

Дальше сконфигурируем параметры X-Window (здесь ты сразу можешь поставить нужные тебе монитор и видюху как под свою тачку, так и под тачку Сереги, если делаешь файл для этого ламобота). Также здесь можно выбрать оболочку по умолчанию (Gnome или KDE) и разрешение экрана.

Выбор пакетов. Здесь есть одно большое ограничение: ты не можешь выбирать здесь индивидуальные пакеты - только группы пакетов. Поэтому можно сделать основные настройки в графическом режиме, а потом открыть полученный файл каким-нибудь редактором и добавить информацию о нужных/ненужных пакетах вручную. Как это делается, я объяснял выше.

Теперь надо сохранить полученную конфигурацию в файл (назовем его seregalamo-ks.cfg). Нажимаем File -> Save и вводим путь и имя файла:

Когда файл понадобится, чтобы переустановить систему, просто скопируй его на дискетку (дискетка должна быть отформатирована в FAT!!!).

ПОДНАЧИТАТЬСЯ

Здесь мы затронули лишь некоторые аспекты того, что ты можешь сделать с помощью kickstart. Дальнейшая информация о kickstart installation доступна в RedHat Customisation Guide. Этот документ находится на диске с документацией, а если ты брал только инсталляционный набор из трех дисков, то можешь закачать документ из Интернета по адресу: www.redhat.com/docs/manuals/linux.


Спецвыпуск Xakep, номер #031, стр. 031-034-4, KICKSTART. Ставим Линукс с полпинка

KICKSTART. Ставим Линукс с полпинка

LinuxAdmin

Спецвыпуск Xakep, номер #031, стр. 031-034-4

Также тебя может заинтересовать RedHat Linux kickstart HOW-TO. Его ты можешь забрать по адресу: http://www.ibiblio.org/pub/Linux/docs/HOWTO/other-formats/html_single/KickStart-HOWTO.html

К сожалению, вся документация на английском. Так что желаю удачи!


Спецвыпуск Xakep, номер #031, стр. 031-036-1, ВЕЛИКИЙ ИСХОД ЮЗЕРОВ. В помощь решившимся переползти под Linux.

ВЕЛИКИЙ ИСХОД ЮЗЕРОВ. В помощь решившимся переползти под Linux.

Vint (vint@townnet.ru)

Спецвыпуск Xakep, номер #031, стр. 031-036-1

Привет! Вот ты решил провести офигенное мероприятие - перейти полностью на Линукс. Прими мой респект! А затем послушай мои советы. Или ты все еще не хочешь уйти от дяди Билла? Так знай, что обычным юзерам Линь дает красивейший фейс (ИМХО, ХР и рядом не лежала с третьим KDE), повышение скорости работы, возможность добиться безглючной работы системы, кучу бесплатного софта, к которому не надо искать и выпрашивать краки. А для хакеров даже и речи быть не может, чтобы сидеть под Виндами! Ведь любой уважающий себя сервак работает либо на Линухе, либо на BSD'шке, либо на Юнихе. А если ты поймешь работу Линуха, то сможешь понять работу удаленного сервака так же, как и своего. Но первый шаг - начать жить под Линухом.

ЧТО ТЫ ВЫИГРАЕШЬ

Нет, ты РЕАЛЬНО хочешь убить Винду и впустить в свой комп пингвина? Ну, тогда слушай сюда :)!

Ты не раз слышал, что Винды есть скусь, а Линукс есть рулез, бездумно повторял это утверждение как аксиому, но объяснить и доказать свою позицию не мог. Так вот, получай аргументы и факты.

Линь глючит, но, в основном, только из-за кривизны рук юзера - ты сам виноват в своих багах. За время моей работы Линух завис 2 раза: первый - когда я намудрил с видеоадаптером и поставил разрешение, которое моя карта не держит; второй раз при самостоятельной сборке ядра я по ошибке не включил поддержку файловой системы ext2, то бишь ядро не смогло прочитать файло с винта. В глюках Винды, в большинстве случаев, виноват не ты, но поделать с этим ты ничего не можешь. Ты можешь только ставить сервиспаки да надеяться, что они выйдут быстро и будут содержать меньше багов, чем исправят.

Большим плюсом является открытость никсовых исходников. Ты можешь собрать собственное ядро строго под свои нужды (ничего лишнего). Если грамотно отконфигурируешь (выкинешь все левые опции), то пингвинчик будет летать, как на бочке с порохом. В Виндах, естественно, все решили за тебя.

Большинство софта под Линь распространяется в исходниках, а если это бинарик, то почти всегда есть ссылка, где можно слить исходники. Такая политика дает тебе возможность самому переделывать любимые софтины! Ты нашел баг, тут же его исправил и ты - крутой багфиксер!

Дальше очень часто приводят довод скорости работы, но тут есть кое-какая загвоздка: Linux в КОНСОЛИ работает, безусловно, быстрее, но в графической оболочке скорость ненамного выше, чем у форточек, и это факт. Причиной этого называют то, что GUI Виндов впаян в ядро намертво, а у Линуха вся графика прет через специальную службу - графический сервер XFree.

Ну, и чисто этический замут, правда, не очень актуальный для нашей страны - красть нехорошо. И не говори, что честно купил Винду и весь софт под нее. А Линух и прикладнуху под него ты можешь ставить на халяву сколько угодно и абсолютно законно.

НА СТАРТ!

Для начала перехода тебе нужен дистр Линуха :). Его ты можешь: а) переписать на болванки у друзей/знакомых/преподов (мною так был получен ALT 2.2 на 9 дисках), б) купить в соседнем ларьке, в) заказать диски через Интернет (зайди на linuxcenter.ru), г) слить образы дисков с Инета :). Главное, при выборе дистра постарайся брать русскую версию или, что лучше, от русского сборщика, например ALT. Сейчас все дистры выпускаются с загрузочными болванками, то есть ты сможешь загрузиться и поставить систему прямо с CD. А для тех, кто хочет просто поглядеть на Линух, есть возможность установить на тачку виртуальную машину под управлением этой оси (весь пингвин уместится в один файл на винте). Но если Винда упадет, придется ставить Линя с нуля. Вот поэтому я тебе настоятельно рекомендую потеснить мастдайку (это на первое время, а потом ты ее вообще выкинешь с винта) с помощью софтины Partion Magic и выделить место под нормальную установку Linux. Я всегда бью диск так: под своп даю 2 объема оперативки, под /home около 3 гиг и все остальное отдаю под корень / . Это минимальная конфигурация. Ты, конечно, можешь объединить / и /home, но если придется переставлять Линуха, то все настройки и файлы пропадут, а если /home отдельно, то они сохранятся.


Спецвыпуск Xakep, номер #031, стр. 031-036-2, ВЕЛИКИЙ ИСХОД ЮЗЕРОВ. В помощь решившимся переползти под Linux.

ВЕЛИКИЙ ИСХОД ЮЗЕРОВ. В помощь решившимся переползти под Linux.

Vint (vint@townnet.ru)

Спецвыпуск Xakep, номер #031, стр. 031-036-2

А дальше все еще проще. Сейчас у большинства дистров есть графический установщик с подсказками, и у тебя не будет проблем с установкой, но учти, что большинство дистров не видят софт-модемы - их придется ставить отдельно. Не забудь отключить лишние службы типа автоматического обновления, службы сетевых ФС (если у тебя нет локалки), службы планирования и т.д. Чем больше мусора выкинешь, тем больше памяти будет свободно.

Вот основные нюансы при установке, остальное покатит, как по вазелину! Особенно радует LILO - он тебе настроит все сам, и ты сможешь бутить и Винду, и Линух безо всяких траблов!

КОНЬ ЖЕЛЕЗНЫЙ

У тебя, конечно же, самое новое (или самое старое :)) железо, и поэтому Линь не видит твоей видюхи, принтера, еще чего-то, или ты экономишь на всем и купил софт-модем и win-принтер, которые Линух не хочет знать. Не беда - будем лечить! Рассказываю не понаслышке - у самого софт-модем! Чтобы заставить девайсы работать, нам нужны драйвера :). Но перед отправлением в Инет узнай 2 вещи: марку и производителя своей железяки и версию ядра (это обязательно, если хочешь качать скомпилированный драйвер!). Для начала поищи на сайте производителя, потом топай на yandex.ru и вбивай Linux driver for (название твоей железяки). Если нашел, не торопись утягивать! Обычно драйвер предлагают качать либо в виде исходников, либо как скомпиленный бинарик. Советую тебе сливать бинарик, если ты не собираешься менять ядро и не хочешь мучаться с перекомпилированием сорсов. Во всех остальных случаях качай сами сорцы. Конечно, тебе придется сделать из них бинарик, но так лучше - ты в любой момент можешь сменить ядро (перекомпилил драйвер и вперед). Сорсов бояться не надо - для компиляции тебе нужно поставить компилятор (gcc поставляется со всеми дистрами Линуха) с дистров твоего пингвинчика, распаковать архивы, из-под рута (SU + пассворд рута) ввести команду make или ./configure, немного подождать и получить рабочий и установленный драйвер! Чем не install под Виндой?

ВЫХОД В МИР

Сейчас мы продолжим великое дело - приконнектим бескрылую птицу к великой и могучей сети Интернет! Скажу тебе так: если ты параноик (а ты должен быть им :)), то при должном усердии ты сможешь сделать свой серф достаточно безопасным, ибо файерволл у этой оси встроен в ядро! Вообще, отточенный и патченный Линух очень-очень трудно свалить с копыт. Ладно, после такого флейма переходим к делу.


Спецвыпуск Xakep, номер #031, стр. 031-036-3, ВЕЛИКИЙ ИСХОД ЮЗЕРОВ. В помощь решившимся переползти под Linux.

ВЕЛИКИЙ ИСХОД ЮЗЕРОВ. В помощь решившимся переползти под Linux.

Vint (vint@townnet.ru)

Спецвыпуск Xakep, номер #031, стр. 031-036-3

Настройка Инет-соединения в Х (так обозначается графическая оболочка Линуха) делается не труднее, чем в Винде. Скорее всего, у тебя уже стоит звонилка, например KPPP, и браузер Mozila. Еще можешь поставить мыльник, асю и ирку (сугубо по желанию). Запускай KPPP и заполняй стандартные поля - там все ясно, особенно если это русская версия. Если ты диалапщик, то у тебя динамический IP-адрес, и на вкладке DNS надо прописать либо домен твоего провайдера, либо, что лучше, сразу его IP-адрес (узнать можно, пинганув хост прова, например ping provider.ru), чтобы Линух не метался зазря к DNS. Если есть желание, настрой учет трафика, благо в большинстве версий KPPP есть такая страна, как Russia.

Затем надо настроить браузер, особенно если ты используешь прокси. Например, у меня два провайдера и один халявный доступ к сети, но этот доступ требует настройки проксика, в то время как к платным прокся не нужна. Раньше я пользовался стандартным браузером K, и мне приходилось постоянно ползать в настройки, чтобы включить/выключить прокси. Это очень большой гем. Тогда пришлось юзать 2 браузера (например, Mozila и K): с одного ползать по Инету через проксю, а с другого - когда прокси не нужна. А потом я поставил браузер Galeon - он юзает ядро Мозилы, но собран в России, и у него включение/отключение прокси можно вынести на переднюю панель, и прокси будет вырубаться одним кликом. Видишь сколько вариантов! Где еще возможна такая свобода?

ПРИКЛАДНУХА

Конечно, Линух есть рулез, но без софта любая ОС - мертва. И его отнюдь немало! Стоит почекать хотя бы эти сайты с софтом под Линух: www.freeware.ru, www.linuxshop.ru, linux-way.org/prog.

И отдельно хочу сказать о проекте OpenOffice (www.Openoffice.org). В рамках этого проекта создается офисный пакет под ОС Linux, предназначенный для работы с документами офиса от дядюшки Гейтса. Причем не просто убогое отображение, а очень грамотное создание и редактирование! Ты можешь лицезреть аналог Ворда под Линем на скрине. Сборка этого офиса от ALT очень хороша - все переведено, куча нужных шрифтов в комплекте, нет траблов с кодировками. Этот офис очень сильно обгоняет аналог MS по множеству параметров: практическая безглючность - у меня завис только 1 раз, причем перед смертью засейвил все доки, а после повторного запуска продолжил работу как ни в чем не бывало; удобство - после первой недели работы на Опене ты уже с презрением будешь смотреть на Ворд от мелкомягких; поддержка шаблонов. Опен офис - красивый и грамотный проект!

Конечно, не офисом единым сыт юзер. В большинстве дестрибов ты найдешь множество программ для Инета, для локалок, для настройки оси, просмотра видео, прослушивания аудио, для работы с ТВ и аудиотюнерами. Резаки болванок тоже не в обиде. Даже бухгалтерия и та поддерживается в Лине: "1С" портирует туда свою софтину! Короче, все, что тебе нужно для жизни, ты найдешь либо на дисках, либо в Инете.


Спецвыпуск Xakep, номер #031, стр. 031-036-4, ВЕЛИКИЙ ИСХОД ЮЗЕРОВ. В помощь решившимся переползти под Linux.

ВЕЛИКИЙ ИСХОД ЮЗЕРОВ. В помощь решившимся переползти под Linux.

Vint (vint@townnet.ru)

Спецвыпуск Xakep, номер #031, стр. 031-036-4

ЭКСПЕРИМЕНТЫ С ЯДЕРНОЙ ЭНЕРГИЕЙ

Поставив, настроив и полюбовавшись, нам, естественно, захочется залезть куда-нибудь своими прямыми руками (у кого кривые, срочно переформатировать). Подумаем, куда ты с пользой можешь приложить свою энергию. Чего тянуть, скомпилим-ка мы ядро! Напрягся? А зря, потому что и здесь все довольно просто. Для совершения сего действа нам следует иметь следующие вещи: установленную с любого дистра ОС Linux, исходники ядра (берутся с дистрибутивных дисков или с соответствующих сайтов), компилятор gcc (ставится автоматом при установке исходников ядра с дисков), тулзу automake (ставится автоматом), пароль root'a. А дальше делай раз, делай два-с по следующей мануалке: открывай консоль, если живешь в Х'ах, становись суперюзером (aka root), для чего набивай su, ентер и вводи рутовский пассворд (он не отображается). Затем переходи в каталог /usr/src/linux (для перехода используй MC, который, если установлен, вызывается командой mc, либо набивай cd /usr/src/linux, ентер), набивай на кнопочной тетке великие слова make xconfig (а если у тебя нету иксов, то набей make config или make menuconfig), и перед тобой вывалится менюха конфигурирования ядра. Пример оной ты можешь посмотреть на скрине. Теперь внимательно и осторожно, читая описание функций, переходим от одного пункта к другому, удаляя ненужные опции ядра (например, поддержку делловских лаптопов и SCSI, если, конечно, у тебя нет таких девайсов). Если в чем-то сомневаешься, вынеси в модуль, но тогда на первых вкладках включи опцию модульности ядра. Когда функция вынесена в модуль, она загружается лишь при необходимости и удаляется после выполнения своих черных дел, и посему старайся как можно больше функций вынести в отдельные модули (только не перестарайся, а то все ядро будет состоять из тысячи маленьких модульков, что совсем не есть гуд). При конфигурировании ОБЯЗАТЕЛЬНО включи опцию поддержки сети, даже если у тебя нет ни модема, ни сетевухи. Причина проста: печать в Линухе реализуется с помощью сетевых функций.

Следующим шагом будет настройка зависимостей ядра командой make depend. Когда по экрану закончат скакать буковки и появится приглашение, введи следующую команду: make bzImage, которая скомпилирует и пожмет твое новое ядро. Тут ты успеешь сходить до ларька - компиляция длится около 20-40 минут! Вернувшись, ты можешь продолжать свои великие дела, для чего надо скомпилить функции, вынесенные в модули. Это делается командой make modules. Я хочу тебя поздравить - ты выполнил основную часть работы, направленной на создание хакерской ОС! Дальше остается совсем немного - установить ядро и модули, для чего мы набиваем последние команды: make install, make modules_Install. Все! Теперь у тебя в LILO появился новый пункт, который отвечает за загрузку образа твоего "самодельного" ядра. А сейчас сделай глубокий вдох и дави на ребут. Если твое ядро загрузится с первого раза, не выдав мессаги о panic kernel, то все в полном порядке, иначе грузи старый образ и повторяй все шаги снова, вспоминая, что в прошлый раз сделал не так. Напоследок скажу, что не стоит сразу нервничать, - от начала компиляции до установки своего первого ядра у меня было пять циклов пересборки!


Спецвыпуск Xakep, номер #031, стр. 031-036-5, ВЕЛИКИЙ ИСХОД ЮЗЕРОВ. В помощь решившимся переползти под Linux.

ВЕЛИКИЙ ИСХОД ЮЗЕРОВ. В помощь решившимся переползти под Linux.

Vint (vint@townnet.ru)

Спецвыпуск Xakep, номер #031, стр. 031-036-5

ХЕЛПАЙ, БРАТЦЫ!

Если у тебя появились какие-то траблы с Туксом, то ты всегда сможешь получить квалифицированную (!), а главное бесплатную помощь. В Инете есть достаточно серьезных и профессиональных сайтов и форумов, где никогда не откажут новичку. Вот сайты на нужную тему: www.linuxdoc.ru, www.unix.kg/rus/linux, www.linuxcenter.ru, www.linuxfocus.org/Russian/. А если у тебя есть только почта, то милости просим в почтовую эху по Линуху, достаточно послать письмо на адрес reply.rulists@soobcha.ru. В Инете эха представлена по адресу www.soobcha.ru/groups/index.html (можно порыть и на www.groups.yahoo.com/group/ru-lists).

ТИПА НАПУТСТВИЕ

Это практически все, что я хотел тебе рассказать. Только несколько слов напоследок, и в путь, к светлому будущему! Сразу приучи себя к тому, что Линукс - это не Винды. Ты далеко не все можешь сделать кликаньем мыши, да и графическая оболочка очень опциональная вещь. Консоль - вот сила пингвина! Если ты научишься с нею обращаться, то ты - царь и бог. Твоя ОС будет работать только так, как хочешь ты. Линукс - ось, которая никогда не считает себя умнее пользователя :). Но перед тем, как овладеть всей мощью и красотой данной ОС, тебе придется не одну ночь провести за изучением книжек и мануалов, написанных на буржуйском языке. Для полного перехода на альтернативную ОС тебе необходимо только желание и мозги - все остальное ты получишь на практике, устанавливая, настраивая, изучая Линукс. И, уж поверь мне, твое серое вещество никогда не будет засыхать, если ты поверишь в силу пингвина. Даже если ты простой юзер, перейдя на Линукс, ты получишь очень широкие познания о теории работы любой ОС. Линукс написана хакерами всего мира для себя, они делали надежную и практичную ОС, которая была бы их верным оружием и защитой в боях невидимого фронта. И неужели ты думаешь, что дядюшка Билл сотоварищи умнее хакеров со всего света ;)? Решение, конечно, за тобой, но я сделал свой выбор и могу смело и по праву заявить "Виндовс - Маст дай! Линукс - рулезззз!".


Спецвыпуск Xakep, номер #031, стр. 031-040-1, TWEAKING&OVERCLOCKING. Чем железный твик отличается от шоколадного Твикса?

TWEAKING&OVERCLOCKING. Чем железный твик отличается от шоколадного Твикса?

Tony

Спецвыпуск Xakep, номер #031, стр. 031-040-1

(tony@nifti.unn.ru) ICQ: 165066287

Все мы пользуемся кучей разнообразных железяк, которыми милые продавцы от души набивают наших баксо-обжор (не забывая при этом и про свои бездонные карманы).

Разработчики этих девайсов больше всего не хотят, чтобы пользователи к ним бегали с какой-то "дурацкой" гарантией и пытались на халяву обменять пропахшую гарью и компьютерным потом железяку. Для этого они "слегка" уменьшают рабочие частоты и напряжения железок, блокируют некоторые "опасные" функции, в общем, повышают запас прочности этой железки. Иногда этот "запас" достигает 25-30%. А может быть тебе и не хватает этих несчастных процентов для того, чтобы FPS в твоей кваке поднялся до приличной величины? Тогда к тебе на помощь идут всевозможные твики (tweaks) этого железа. Разгоняется все что угодно - поднимаются частота и напряжение ядра процессора, увеличивается частота системной шины и памяти, гонятся видюхи, сидиромы (ну здесь-то, наверное, надо, наоборот, тормозить, ибо шум, создаваемый иными сидюками, соседи могут принять за шум идущего на взлет самолета) и жесткие диски.

Твикеры видюх

Кто тебе скажет, что те самые FPS в любой игре поднимаются за счет увеличения частоты CPU, - плюнь тому в глаза и разбей все пиво в холодильнике. На самом деле, заставить более шустро бегать любую игру способно увеличение частоты ядра видюхи и ее памяти. Также отключение (или включение) некоторых видеофич способно заставить видюху шевелить кое-каким местом заметно быстрее (или качественнее). Для этого существуют специализированные видеотвикеры.

Riva Tuner

Для начала давай с тобой немного позубрим - выучи следующее словосочетание - Riva Tuner. Если оно тебе не знакомо, не пугайся, это не твикер для NVidia Riva TNT/TNT2 карт, а всего лишь софтина, которая позволит тебе настроить любую из существующих на сегодняшний день в мире видеокарт и разогнать любую карту от NVidia. Теперь тыкайся вот сюда - www.nvworld.ru/docs/overclock.html. Сливаем примерно 800 кило и получаем мощнейшую утилиту для настройки и разгона видеокарты. Гигантский респект ее автору (см. закладку Links). Я понимаю, у тебя возник вполне нормальный вопрос, а что она умеет делать? Ответ прост как апельсин - "все". Nvidia, видимо, не захотела выставлять напоказ все настройки в свойствах видеоадаптера. Заглянув на соответствующие закладки Riva Tuner, ты в этом легко убедишься: тактовые частоты, куча инфы об адаптере, тьма настроек DirectX, OpenGL, перепрошивка BIOS карты, качество рендеринга, цветовые настройки рабочего стола и оверлеев - это только названия закладок; чтобы перечислить все настройки, мне понадобится еще один номер Спеца :). Плюс возможности настройки внешнего вида, автоматического запуска, запуска пресетов (набора настроек) с выбранными приложениями. Допустим, в кваку играем с антиальясингом, в морровинде его отрубаем. И, конечно, существует возможность вручную выставить ключи реестра, ответственные за возможности видюхи (только для опытных пользователей). Забудь про regedit, как про кошмарный сон. В общем, если у тебя стоит карта от Nvidia, то Riva Tuner ты иметь обязан!


Спецвыпуск Xakep, номер #031, стр. 031-040-2, TWEAKING&OVERCLOCKING. Чем железный твик отличается от шоколадного Твикса?

TWEAKING&OVERCLOCKING. Чем железный твик отличается от шоколадного Твикса?

Tony

Спецвыпуск Xakep, номер #031, стр. 031-040-2

Rage3D Tweak

Дух противоречия до сих пор в тебе играет, и ты купил карту от ATI? Молодец, да здравствует здоровая конкуренция. В принципе, для твиков твоей карты ты можешь взять тот же самый Riva Tuner. Но мой совет: не поленись и слей вот этот твикер для твоей карты - www.rage3d.com/r3dtweak/dload/R3Dtweak38c.exe. Как и в случае предыдущей софтины, не обращай внимания на название твикера, он поддерживает все Radeon'ы, в том числе и мобильные. Фишки те же самые, что и у Riva Tuner - начиная с разгона и кончая (oops... i did it again) запуском приложений с уникальным пресетом, кроме правки реестра напрямую.

Rape my monkey

Твикер видюхи при неправильном использовании вряд ли больно стукнет по твоему кошельку. Ну, разве только если ты не захочешь перепрошить BIOS карты - в этом случае помидорами в меня не кидай, а кинь его лучше в зеркало, напротив которого стоишь :). А еще лучше почитай вот эту статью - www.ixbt.com/video/gfbios.shtml. При разгоне видюхи она тоже не отдает богу душу, если ты, конечно, при этом принял пару таблеток от жадности и не разгоняешь карту на 100% ее частоты, но вот с мониторами совсем другое дело. Здесь надо подходить к проблеме очень осторожно - примерно как мент к панку. Учиться на своих ошибках здесь не рекомендую, лучше поучись на моих. Разгон моника заключается в увеличении частоты вертикальной развертки (чем она больше, тем ты дольше можешь пялиться на голых теток, пока у тебя не начнут слезиться глаза и в твоей мобиле не появится номер окулиста). В драйверах моника зашита информация, для какого разрешения эта частота имеет предел, твикеры монитора позволяют ставить ту частоту, которую тебе захочется. Лично я угробил два монитора (а вернее блок строчной развертки - 60 у.е.), конечно, на работе, а не дома :). Теперь при каждом новом разгоне я лезу в Инет, ищу инфу, на сколько максимально что можно разогнать без финансовых потерь. Тебе понадобится только одна софта - Power Strip, брать здесь - www.entechtaiwan.com/files/pstrip-i.exe. Основное ее назначение - твикинг монитора, а именно смена разрешения, частот вертикальной и горизонтальной разверток, позиции и размера изображения, задержки, параметров синхронизации, гаммы и тактовых частот видеокарты.

Разогреваем кирпичи

Осторожно, не обожгись о проц, особенно после его разогрева. Я это серьезно, слышал о системах жидкостного охлаждения? А это уже день не завтрашний, а сегодняшний - ищи в магазинах. Для начала почитай вот это, уж если твикать - так твикать по полной - www.ixbt.com/cpu/faq/oc-faq.shtml#q30. Теперь промоем косточки софту, который за нас перетыкает на маме перемычки и меняет кулеры... шучу, не волнуйся, многие современные мамы позволяют программно изменять частоты работы камней и шин, а также обороты кулеров.

Дуем на кирпич

Сливаем отсюда - www.podien.onlinehome.de/default.htm - твикер под названием CPUCool. Штука эта очень серьезная, и если тебе не терпится поиметь халявные мегагерцы на твоем камне, то она для тебя. Во-первых, с ее помощью можно разогнать твой камень и системную шину (FSB). Во-вторых, посмотреть, как этот разгон сказался на температуре камня - провести мониторинг датчиков температуры. В-третьих, настроить программное охлаждение камня - уменьшение частоты ядра и FSB при снижении нагрузки на камень и уменьшение оборотов кулера (скорее ради уменьшения шума от кулера, а не ради уменьшения потребляемой энергии). Настроить параметры отключения системы при достижении критических температур (Ойе!!!). Указать параметры периодической очистки системной памяти. Мало фич? Ну ладно - сохранение лога мониторинга системы, возможность подключения дополнительных термодатчиков - скажем, захотели узнать температуру динамика... покупаем датчик, настраиваем софтину... и все чики-пуки (если на маме есть место, куда провод от этого датчика можно воткнуть).


Спецвыпуск Xakep, номер #031, стр. 031-040-3, TWEAKING&OVERCLOCKING. Чем железный твик отличается от шоколадного Твикса?

TWEAKING&OVERCLOCKING. Чем железный твик отличается от шоколадного Твикса?

Tony

Спецвыпуск Xakep, номер #031, стр. 031-040-3

С миру по твику

Думаешь, это все, что можно потвикать? Как же, как же... если тебя не устраивает, как виндуза работает с памятью, то лезь сюда - www.tweaknow.com, и сливай отсюда RamIdle - параметры кэша, очистки памяти, использования свопа и куча всего другого. Слишком шумит сидюк? Проще простого, сливаем -download.overclockers.ru/storage/NeroCDSpeed_102e.rar, запускаем... и утихомириваем этот сумасшедший пылесос. Хочешь изменить параметры жесткого диска? О'кей - download.overclockers.ru/storage/Ftool_v180.rar. Переключить режимы работы диска? Пожалуйста - download.overclockers.ru/storage/seagate_uata100d_3.06.rar. Ну а если захочешь настроить что-то еще - вперед в Инет, инфы и софта там хватит на всех...


Спецвыпуск Xakep, номер #031, стр. 031-042-1, Мелко-мягкий твик - вся правда о скрытых настройках Windows

Мелко-мягкий твик - вся правда о скрытых настройках Windows

Tony (tony@nifti.unn.ru)

Спецвыпуск Xakep, номер #031, стр. 031-042-1

ICQ: 165066287

Бонжур, дружище. Сегодня уже ни для кого не является секретом, что виндуза имеет кучу разных фишек, которые мелко-мягкая братва усердно скрывает от мирового сообщества (примерно как Ирак химическое оружие, с той лишь разницей, что скрытые фишки в виндузе гарантированно существуют, а оружие в Ираке - вряд ли).

Причина сокрытия фишек банальна - маркетинговая программа Билла. Практически все параметры настроек хранятся в системном реестре, править все ручками с использованием regedit, конечно, можно, но по маразму это больше похоже на переписывание программного кода ручкой в тетрадочку :). Поэтому, когда вынь-пиплы пронюхали про это, были быстро наколбашены соответствующие твикеры. Настройки выни были слизаны друг у друга, в итоге получилась куча разных программ, отличающихся друг от друга только пользовательским интерфейсом. Еще все эти проги объединяет также то, что они просят перезагрузиться после внесения изменений в настройки, что понятно, поскольку все эти параметры считываются при стартовой инициализации драйверов и ядра системы. Справедливости ради стоит отметить, что некоторые твикеры поддерживают свои уникальные (зачастую не очень) инструменты. Ну да ладно, запускай своего ишака, сейчас будем твикать...

WinBoost

Сейчас уже есть версии этого твикера для 2K и XP систем, а вот WB2001 - это последняя версия для осей на старом виндузовском ядре - для 95, 95 OSR2, 98, 98 SE и ME. Взять этот твикер можно, например, здесь - kulkoff.narod.ru/Winboost2001.zip (вместе с "РуСюФюКаТоРоМ", оно тебе надо?). На своем сайте (www.winboost.com) разработчики бредят о сотнях (hundreds) настроек. В "сотни" верится с трудом, а вот в "пару сотен" различных настроек - вполне :). Настраиваются следующие фишки - внешний вид "главного меню", проводник и контекстное меню, рабочий стол, ишак, защита от младшего братца, ярлыки и системные иконки, параметры загрузки выни и заставки, а также сетевые настройки (MTU и TTL). Также есть набор советов и трюков по конфигурированию виндузы. Ну, в общем классический пример современного Win-твикера с модным рисованным интерфейсом. Главные отличия от других твикеров - наличие краткого описания каждой настройки и четкая ориентированность только на настройки (никаких Uninstall Menu или System Processes ты тут не увидишь).

WinSetup

Аналог WinBoost (для 9X/ME систем), только с упрощенным до тупизны интерфейсом, можно слить отсюда - www.winsetup.nm.ru. Похожие слова о "сотнях" настроек наводят на нехорошие мысли о плагиате, ну да нам по барабану. Отличие этого твикера от предыдущего заключается в том, что к нему "припаяли" возможности отображения ассоциативных связей файлов с приложениями по расширению, список установленных программ, системную информацию, список процессов и возможность работы с плюгинами (коих нема совсем).

MagicTweak

Дальнейшее продолжение мысли ведущих твикермэнов планеты ты сможешь поиметь вот здесь - www.magictweak.com/download/mgtweak.exe. Правда, попросят с тебя за это удовольствие 30 уев, но... ну ты понял. От предыдущих твикеров отличается опять же пользовательским интерфейсом, наличием приличной документации (на языке Шекспира) и системными требованиями. При виде выней 95 и 95 OSR этот твикер брезгливо воротит нос, но, начиная с 98-ой, ты можешь его себе установить. Из уникальных фишек здесь есть - настройка системных каталогов и настройка произвольных иконок папок.


Спецвыпуск Xakep, номер #031, стр. 031-042-2, Мелко-мягкий твик - вся правда о скрытых настройках Windows

Мелко-мягкий твик - вся правда о скрытых настройках Windows

Tony (tony@nifti.unn.ru)

Спецвыпуск Xakep, номер #031, стр. 031-042-2

WinGuides Tweak Manager

Универсальный твикер - может работать под всеми вынями, начиная с 95-ой. Это самая серьезная прога подобного класса. Брать здесь - www.winguides.com, поддерживает около 800 различных настроек. Все перечислять я не буду, ибо это будет похоже на поход по магазинам с чужой кредиткой. Стоит вся эта байда 30 уев, но, поверь мне, дружище, эта программа этих денег стоит, ну или... Из уникальных фишек имеется - онлайн обновление плюгинов, поддержка, документация и FAQ.

TweakNow Power Pack 2003

Еще один серьезный продукт топ класса забирать здесь - www.tweaknow.com, стоимость 25 вечнозеленых, поддерживает оси, начиная с 98-ой виндузы. Не такой масштабный по количеству настроек, как Tweak Manager, но зато имеет в своем составе кучу полезных инструментов, таких как CD Autorun (параметры автозапуска и автопроигрывания CD и DVD дисков), Virtual Drive (создание и удаление виртуальных дисков), Startup Manager (менеджер автоматически запускаемых программ), Virtual Desktop (управление несколькими рабочими столами), RamIdle (управление кэш памятью Windows), Windows Cleaner (очистка мелко-мягкого мусора). Плюс к этому системная инфа о процессоре, памяти, оси, сети, дисках, системных каталогах, процессах и конфигурационных файлах (по детальности схожая с SiSoft Sandra).

X-Setup

Завершающая этот обзор твикеров софтина от Xteq Systems является самым мощным из всех халявных твикеров. Сливать вот здесь - http://www.xteq.com/downloads/#xset. Поддерживает все версии виндузы, в том числе и 95-ую. Для работы в 9X виндузах необходимо либо иметь Ишака версии не ниже 5.0, либо слить отсюда -http://www.microsoft.com/com/dcom/dcom98/download.asp (для 95-ой виндузы, соответственно, dcom95) - необходимую библиотеку. В отличие от многих своих собратьев, данная софта является просто коллекцией настроек без всяких инструментов. Но по количеству настроек X-Setup не уступает никому (в том числе и Tweak Manager), плюс к этому существует возможность обновлять плюгины прямо из меню и разрабатывать собственные плюгины. Для этого необходимо скачать специальный SDK (Software Development Kit), плюгин по своей структуре похож на VBScript. Плюс грамотная документация, поддержка и FAQ делают X-Setup самой желанной программой для издевательств над Биллом и его творениями.

Оревуар

Ну, вот и закончен этот обзор. Мы с тобой взяли самые сливки с общества твикеров виндузы - не удивляйся их количеству, на самом деле их гораздо больше, но все обладают схожими функциями. Выделяется отсюда Winguides Tweak Manager - объемом настроек, профессионализмом разработчиков и документацией с поддержкой. TweakNow Power Pack 2003 - своей комбайновостью (привет буквоедам :), и X-Setup - своей открытостью, а вернее халявностью. Но, в общем-то, это продукты одного класса, не для тех людей, кто захотел поменять цвет окошек Windows, а для тех, кто основательно захотел изменить имидж своей операционной системы и ее производительность.


Спецвыпуск Xakep, номер #031, стр. 031-044-1, WINDSURFING: все для серфинга под Виндой

WINDSURFING: все для серфинга под Виндой

Леха ББ aka Alexys

Спецвыпуск Xakep, номер #031, стр. 031-044-1

(alex-sun@mtu.ru)

Не стоит скрывать тот факт, что, при всей удобности, Винды грешат безопасностью. Пусть даже половина бед с безопасностью связана не только с осью, но и с ручками, которые ставят различного рода софт под нее. Вот от софта под Винды можно много чего ждать - кто знает, что программер туда засунул? Может троян скрытый? А может это spyware-программка часть трафа едва заметно отжирает? Все может быть. Поэтому такая вещь, как настройка удаленного доступа и софта для серфинга, требует немалых знаний. Один из вариантов - самому понаступать на грабли n-ое число раз, пока либо сам не научишься все настраивать, либо пока не превратишь комп в беспомощную груду железа.

ДОЗВОНИСЬ ДО ПРОВАЙДЕРА

Программа-звонилка дозванивается до провайдера, соединяется и осуществляет проверку подлинности (передает логин и пароль). Вот уже как можно попасться. Допустим, поставил ты себе какую-нибудь звонилку и начал ее юзать. А она берет и сразу же после соединения отправляет твои Л и П ведущему раздела "Инет на халяву". Поэтому надо выбирать не первую попавшуюся звонилку, а проверенную. За таким советом либо обратись к более продвинутым друганам, либо читай ниже.

ПОДКЛЮЧЕНИЕ СТАНДАРТНЫМИ МЕТОДАМИ

Стандартная виндовая звонилка - не самая удобная, но и не самая плохая звонилка. Если пока не нашел ничего другого, то лучше пользоваться ею. Она точно никуда не отошлет твои логин и пароль. К тому же она хорошенько криптует пассворд, так что съездить его у тебя всяким типа «хацкерам» будет проблемно, а реальные челы такими вещами не занимаются. Пусть здесь даже не виден номер, по которому происходит дозвон, но в свойствах соединения их можно вбить десяток-другой, а дайлер потом будет сам перебирать номера, пока не дозвонится по одному из них.

Главное, чего нельзя забыть, - это в свойствах соединения поставить галку около надписи "Вывести значок подключения на панель задач". Тогда в трее будет висеть пара мониторчиков. Иначе визуальный контроль за трафиком будет затруднен (или станет вообще анрилом, если момед внутренний - на внешнем хоть индикаторы мигают). Если для соединения будет требоваться скрипт (есть и такие), то какой бы звонилкой ты ни пользовался, указывать путь к этому скрипту придется в одном из разделов свойств соединения в этой звонилке.

Этой звонилкой можно пользоваться, только здесь нет ни расписания, ни таймеров включения или отключения коннекта, не ведется статистика и т.д. Если юзать Инет только для сливания почты, то такая звонилка вполне подойдет. Но если есть и другие дела, то лучше выбрать что-нибудь иное.

ETYPE DIALER

На мой взгляд, EType Dialer - самое лучшее совмещение простоты и удобства. Соединения берутся из списка созданных ранее в удаленном доступе. Правда дополнительные номера телефонов и пароль с логином придется вбивать ручками снова, но это уже издержки производства. Этот дайлер может сам запуститься, дозвониться, запустить еще какие надо проги, сам выключиться... Когда заимеешь ночной анлим доступ, то будешь просто мечтать о такой программке. Ведь по ночам и поспать хочется, а она за тебя много чего сама сделает. После установки соединения рекомендую сворачивать значок EType'а в трей, чтобы не мешался.


Спецвыпуск Xakep, номер #031, стр. 031-044-2, WINDSURFING: все для серфинга под Виндой

WINDSURFING: все для серфинга под Виндой

Леха ББ aka Alexys

Спецвыпуск Xakep, номер #031, стр. 031-044-2

РАСПИСАНИЕ КОННЕКТОВ И ДИСКОННЕКТОВ

EType немного помогает учитывать потраченные денежки, ведя статистику. Жаль, что нет в ней возможности вбить расценки на то или иное время пользования, но это уже слишком было бы. Звонилка должна быть легкой и незаметной, ни в коем случае не нагружать систему. EType Dialer как раз такая и есть.

ITIC DIALER

Если бы не пара знакомых, то никогда бы не узнал про эту звонилку, продолжая юзать только EType (уже года 3, наверно). Вроде все в ней хорошо - делает все, что делает ETyper Dialer, даже немного побольше, но не такая уж она легкая, при том что отличий от EType немного. Самое важное отличие ITIC от EType - возможность указать минимальную скорость соединения. Хотя это с таким же успехом можно сделать, полазив по настройкам соединения. Со статистикой здесь немного получше, и хоть тоже нет возможности задать временной диапазон, трафик здесь учитывается. Это действительно полезно тем, у кого диалап с ограниченным трафиком.

ДОЗВОНИЛИСЬ? НАДО БЫ И ПОСЕРФИТЬ!

Для того чтобы лазить по сайтам в Инете, нужен броузер - программа для просмотра сайтов. В Виндах по дефолту встроен Internet Explorer, но ведь никто не запрещает поставить и юзать любой другой, например, Opera, Mozilla и т.д. От многих людей слышал своими ушами, что ИЕ просто дырка какая-то, что с ним опасно по сайтам лазить и т.д. Правда, так никто и не объяснил, в чем это выражается. Вообще, если отключить Java Script, то тогда даже всплывающих окон не станет. Правда, от этого безопасность самого факта нахождения в Инете не увеличится.

В целях повышения безопасности юзанья ИЕ рекомендуется отключить сохранение паролей, используемых на сайтах, а также ограничить обработку Active X.

Какой бы броузер ты ни юзал, надо всегда знать, какие программы, куда и в какой момент пытаются приконнектиться. А вдруг у тебя троян сидит, а антивирус почему-то не ругается? Или вдруг тебя начинают сканировать по всем портам? Не покатит так. Надо таких людей наказывать, беспощадно отрубая им всякую возможность сканить тебя. А для этого понадобится поставить файрволл. Из всех виндовых файрволлов меня больше всего радует Agnitum Outpost Firewall (http://agnitum.com). Все-таки наши программеры умеют создавать что-то действительно качественное и полезное. Этот файрволл не только удобный в настройке и надежный, он еще много чего дополнительно умеет делать. Так, он режет почти всю попадающуюся рекламу (может как по размерам, по HTML-строкам, так и по обоим признакам), может отрубать выполнение JScript'ов, не давать поп-апам выпрыгнуть из-под открытого окна, кэширует ДНС (а это порой очень ускоряет работу, особенно при загруженности DNS-серверов). Аутпост постоянно следит за соединениями программ. Надо только ставить его в режим обучения. Тогда если что-то доселе ему неизвестное попробует полезть куда-то, то аутпост сразу спросит тебя, согласен ли ты разрешить такой-то софтине коннектиться или нет и на каких условиях. Для этого существуют настройки, какие соединения (например, только входящие или только исходящие) оставить, а какие закрыть. Кроме того, существует возможность выбрать заранее заготовленные правила для некоторых известных программ. К аутпосту можно дополнительно (по желанию) поставить плагины. Например, очень полезный плагин HTTPLog. Он выдает инфу о http-коннектах - что за прога к чему коннектилась, что притащила. Полезно, когда линка на файл генерится скриптом, а нужен конечный прямой линк.


Спецвыпуск Xakep, номер #031, стр. 031-044-3, WINDSURFING: все для серфинга под Виндой

WINDSURFING: все для серфинга под Виндой

Леха ББ aka Alexys

Спецвыпуск Xakep, номер #031, стр. 031-044-3

Один взгляд на список соединений в Outpost'е позволит ответить на вопрос, что же так сильно смогло забить трафик. Прямо из него можно просто поотрубать ненужные коннекты. Правда, это можно сделать и стандартной виндовой программой netstat.

Netstat показывает, какие коннекты по TCP/IP на данный момент присутствуют. Запускается netstat из консоли с указанием нужных ключей (хотя можно и без них).

Если не знаешь, какой ключ что означает, то в консоли введи netstat /?, тогда получишь небольшой список ключиков. Так, ключ "-a" выкинет листинг всех имеющихся коннектов, которые реально установлены или в режиме ожидания. Но netstat не самый лучший метод, поскольку не дает оперативности. Сам понимаешь, что на стыривание чего-либо не нужно много времени.

КАЧАЛКИ

От Инета не будет много пользы, если оттуда будет невозможно скачать свеженькую софтину. Откуда качать - это вопрос уже другой, причем на эту тему уже писали не раз, к тому же вопрос поиска не стоит в данный момент. Любой броузер позволяет скачивать файлы, но вот только с докачкой дело обстоит немного потяжелее. От броузера это не требуется - от него требуется правильное отображение страниц. Если линия хорошая и коннект шустренький (не менее 40 Кбит/с), то в большинстве случаев можно обойтись стандартными методами, выбрав в броузере пункт "Сохранить объект как" или ему подобный. А если Инет не казенный, да и софтина метров на 100 будет, то тут уже надо что-то делать.

Также могут возникнуть проблемы с даунлоудом, если сервак немного подзагружен или стоит уж очень низкое ограничение трафика на одно соединение. Например, поставит злостный сисадмин ограничение на 1 Кбайт/c на коннект, и тогда даже сливание 200-килового файла может стать проблемой. Но больше всего мне жаль людей с пошаговыми АТС'ками - им не видать даже 33600 :(. Но ведь они тоже человеки, и им также хочется юзать (хоть иногда) свеженький софт. У них иной раз даже метр скачать не получается - дисконнект происходит. Вот тут невольно задумаешься, что хорошо бы иметь такую программку, которая бы не только поддерживала докачку, но и могла тащить файл в несколько потоков ради максимального использования трафика, пыталась бы отыскать более шустрые места хранения того же файла (другие серваки) и т.д. Спешу обрадовать - такие программы есть! Ты не первый, кто захотел себе жизнь облегчить. Им (программам) даже название дали - даунлоуд-менеджеры. Существует их немало, только вот немногие из них отличаются надежностью и комфортом. К таким я бы отнес только FlashGet. И пусть кто-то уже сталкивавшийся с качалками скажет, что ReGet лучше. Надежностью и безопасностью он не славится. ReGet периодически проверяет, не сидит ли кто в сети в данный момент с таким же серийником, что и ты. И не дай Бог такому случиться! ReGet вмиг отрубится и работать перестанет. Поверь, не для того сделаны качалки, чтобы сидеть перед монитором и смотреть на бегущие (или ползущие) проценты и байты скачивания.


Спецвыпуск Xakep, номер #031, стр. 031-044-4, WINDSURFING: все для серфинга под Виндой

WINDSURFING: все для серфинга под Виндой

Леха ББ aka Alexys

Спецвыпуск Xakep, номер #031, стр. 031-044-4

FlashGet (http://flashget.com) - прога, которая полностью подходит под требования нормальной качалки. К тому же она почти фриварная - даже если не введешь ключик, она будет абсолютно работоспособная, только баннер будет мигать и немного действовать на нервы. С методом борьбы с баннером проблем никаких не должно возникнуть. Эта софтина довольно умная для обычной программы. Она сама может отыскивать файлы на различных серваках, сама выбирать наиболее быстрый из них, тянуть 10 частей файла из одного места, разрывать коннект и (или) выключать компьютер по окончании закачки. Во FlashGet'е удобно сделана возможность сортировать скачанные файлы по их назначению - Software (софтина), Game (игрушки), Driver (дрова), MP3 (музон). Если понадобится, то можно сделать еще и не одну папку. В момент выбора места для скачивания надо самому только сообразить, что в данный момент ты будешь качать, и выбрать нужное. После скачивания файлик будет валяться в соответствующей директории. FlashGet еще тем удобен, что интегрируется под ИЕ, оперу или нетшкаф. Только для интеграции под последние два надо скачать плагин для оперы (http://flashget.com/browser.htm). Если тебя не вставляет стандартный внешний вид программы (хотя довольно приятно сделана), то можешь либо выбрать другую шкуру для нее из заготовленных, либо запихнуть в фон свою картинку.

FlashGet ведет логи, что было скачано, когда, откуда и даже на какой странице находилась ссылка на скачиваемый файл (если такая страница, конечно, была). Это не такая бесполезная вещь, как может показаться на первый взгляд. Иной раз зайдет кто-нибудь и спросит: "Откуда ты скачал эту штуку?". Глядя в логи Flashget'а, это можно сделать довольно легко и непринужденно. У FlashGet'а есть полупрозрачный индикатор, показывающий, сколько процентов файла находится уже на твоем харде, а сколько еще только должно туда попасть. Вот за это я уже готов программеров расцеловать в десны - программа может быть свернута в трей, а ты постоянно видишь график активности закачки и сколько еще осталось до завершения.

Еще один немаловажный плюс FlashGet'а - управление трафиком. Есть 3 степени использования трафа FlashGet'ом - неограниченный (все для себя), ручной (не выше указанного порога) и автоматический (в зависимости от требований других программ). Если FlashGet'у указать неограниченный трафик, то открыть какую-либо страницу станет просто нереально. Вот тогда надо переключаться в режим "ручной" и выставлять значение раза в 2 меньше, чем средняя скорость скачивания.


Спецвыпуск Xakep, номер #031, стр. 031-044-5, WINDSURFING: все для серфинга под Виндой

WINDSURFING: все для серфинга под Виндой

Леха ББ aka Alexys

Спецвыпуск Xakep, номер #031, стр. 031-044-5

НЕКОТОРЫЕ СОВЕТЫ И РЕКОМЕНДАЦИИ

Если хочешь добиться как можно более стабильного коннекта, то не гонись за скоростью. Если линия у тебя не из лучших, то иногда желательно намеренно ограничивать скорость соединения модема. Например, если момед у тебя на 56К, а линия просто отстой, то рекомендую снизить ручками скорость до 33600. Пусть скорость соединения будет от этого поменьше, но стабильность коннекта от этого возрастает в 90% случаев. Но качество связи зависит не только от качества АТС, но и от того, насколько хорошо у тебя дома сделана проводка - не перегрызли ли кошка с собакой телефонный шнур к розетке, в которую момед воткнут, не стоит ли в той розетке злой резюк, хорошо ли все крепится и в таком духе. Казалось бы, к компам никакого отношения эти элементы не имеют, но на скорость могут повлиять очень сильно.


Спецвыпуск Xakep, номер #031, стр. 031-048-1, LINUX, СЕТЬ И ВСЕ, ВСЕ, ВСЕ...Все для пингвиньего серфинга

LINUX, СЕТЬ И ВСЕ, ВСЕ, ВСЕ...Все для пингвиньего серфинга

Vitls (vitls@chat.ru)

Спецвыпуск Xakep, номер #031, стр. 031-048-1

Ну что, драгоценный мой kool xaцкер, поставил ты себе Linux, а толку никакого... Скучно сидеть без Инета! Теперь пришла пора исправить это досадный недостаток. Будем выходить в Сеть.

ДЕМОН С ХИТРЫМ ИНТЕРФЕЙСОМ

Я понятия не имею, есть ли у тебя в доме кампусная сеть. Будем считать, что у тебя есть компьютер с установленным Linux, модем и телефонная линия. Для выхода в Сеть тебе придется настроить модемное соединение. Куда пошел? Сядь и читай! Придется потрудить мозжечок. Чтоб ты был в курсе: в Linux любое сетевое соединение реализуется через шнягу с названием сетевой интерфейс. Именно интерфейсу (а не компьютеру, в котором может быть несколько сетевых интерфейсов) присваивается сетевой адрес. Будет считать, что у тебя (как и у меня) одна телефонная линия, соответственно - один сетевой интерфейс. Называется он /dev/ppp0 (в каталог /dev даже не смотри, его там все равно нет, он появится автоматически при установлении соединения).

За совершение звонка и установление связи (это называется "поднятием интерфейса") отвечает программа-демон pppd. Обычно она идет в составе практически любого дистрибутива. Но его можно и скачать отдельно с сайта www.samba.org/ppp/. Настройки демона хранятся в файле /etc/ppp/options, там же находятся сценарии для "поднятия" и "опускания" интерфейса. Подробности можно прочитать в PPP-Howto (на русском взять здесь - www.linux.ru.net/index.php?module=library&action=show&docid=18&part=288), а также в документации, идущей с демонюгой.

Почти любой дистрибутив при установке спросит тебя, устанавливать ли модемное соединение, и, соответственно, сделает необходимые настройки. Но вероятно, что тебе придется скачивать pppd самому и самому его собирать. Собрать нетрудно. Распаковал куда-нибудь, а затем парочка призывных заклятий (configure; make; make install от пользователя root). Важно потом все правильно настроить.

ДЕМОН, СТРОЙСЬ!

Дистрибутивы Linux используют два разных стиля инициализации BSD (Slackware, Gentoo) и SysV (все rpm-based дистрибутивы). Это означает, что настройки pppd хранятся по-разному.

В моем дистрибутиве все настройки демона pppd хранятся в двух местах. Первое из них - каталог /etc/ppp. Там тебя поджидают несколько важных файлов. Файл /etc/ppp/options хранит в себе настройки демона. Их довольно много, и тебе придется почитать man pppd для разъяснений. Там хоть и по-английски, но довольно доходчиво все расписано. Второй важный файл /etc/ppp/pap-secrets, в нем хранится твои логин и пароль на вход к прову. Если у прова используется chap-идентификация, то у тебя есть на этот случай /etc/ppp/chap-secrets (мой файл chap-secrets выглядит аналогично). Мой pap-secrets выглядит примерно так:

# SECRETS FOR AUTHENTICATION USING PAP

# CLIENT SERVER SECRET IP ADDRESSES

"VASJA" * "PAROL_VASJA"

Второе место хранения настроек демона pppd более шоколадно по своим возможностям. Каталог /etc/sysconfig/network-scripts таит в себе файл ifcfg-ppp0, который аналогично /etc/ppp/options хранит настройки демона. Файл chat-ppp0 содержит набор команд для модема и реакцию на них. У меня он выглядит примерно так:


Спецвыпуск Xakep, номер #031, стр. 031-048-2, LINUX, СЕТЬ И ВСЕ, ВСЕ, ВСЕ...Все для пингвиньего серфинга

LINUX, СЕТЬ И ВСЕ, ВСЕ, ВСЕ...Все для пингвиньего серфинга

Vitls (vitls@chat.ru)

Спецвыпуск Xakep, номер #031, стр. 031-048-2

'ABORT' 'BUSY'

'ABORT' 'ERROR'

'ABORT' 'NO CARRIER'

'ABORT' 'NO DIALTONE'

'ABORT' 'INVALID LOGIN'

'ABORT' 'LOGIN INCORRECT'

'' 'ATZ'

'OK' 'ATDT277711'

#'OK' 'ATDT277711'

'CONNECT' ''

'TIMEOUT' '5'

'~--' ''

С различными типами инициализации совсем труба. Разнообразие таит в себе несовместимость в настройках. Стиль sysv требует, чтобы все настройки сетевых интерфейсов хранились в скриптах в каталоге /etc/sysconfig/network-scripts. То есть /etc/ppp/options получается на фиг не нужным. Хотя в него можно прописать что-нибудь дополнительное. Это нужно потому, что любые сетевые интерфейсы поднимаются одинаково. Для этого используется общий сценарий /etc/rc.d/init.d/network. В то же время стиль bsd позволяет хранить настройки pppd в его родном каталоге /etc/ppp. И вся ответственность за правильность поднятия интерфейса целиком ложится на администратора системы. В любом случае, чтение ppp-howto бесполезным не будет.

После того как все, с твоей точки зрения, будет настроено, интерфейс можно поднять командой ifup ppp0. Выполнять ее нужно от имени администратора (пользователю она не видна). Если ты не лоханулся, то модем весело заморгает лампочками, протрещит нечто невразумительное, и ты услышишь победный свист коннекта.

А вдруг ты подключен к нескольким провайдерам? Да... задница. Но ничего... разработчики pppd не настолько тупы, чтобы так лажаться. Они предусмотрели и этот изврат. На каждого прова можно прописать свой файл в каталоге /etc/ppp/peers. В файле (обзовем его /etc/ppp/peers/isp )пишется малюсенький конфиг, например такой:

ttyS0 # модем присоединен к /dev/ttyS0

38400 # запустить последовательный порт на скорости 38400 бит/с.

crtscts # использовать аппаратный контроль передачи.

noauth # не просить прова аутентифицироваться самому, на фиг это нам не нужно?

defaultroute # использовать прова как маршрутр по умолчанию.

# запускаем сценарий соединения /etc/ppp/chat-isp.

connect '/usr/sbin/chat -v -f /etc/ppp/chat-isp'.

Файл /etc/ppp/chat-isp содержит сценарий для программы chat, которая, собственно, и занимается дозвоном. Его содержание примерно такое:

ABORT "NO CARRIER"

ABORT "NO DIALTONE"

ABORT "ERROR"

ABORT "NO ANSWER"

ABORT "BUSY"

ABORT "Username/Password Incorrect"

"" "at"

OK "atz"

OK "atdt2479381"

"name:" "^Uvasja"

"word:" "\qparol_vasja"

"annex" "ppp"

"Switching to PPP-ppp-Switching to PPP"

Ну а далее все совсем просто. Соединение устанавливаем командой /usr/sbin/pppd call isp. "Вот и все, осел. Вот и все". (с) Шрек. Для остальных провайдеров настроишь сам по примеру.

Чтобы завершить соединение, тебе нужно послать демону команду завершения соединения. Во всех unix-системах для этого используется команда kill. Демон pppd можно убить фразой:

kill `cat /var/run/ppp0.pid`

Естественно, что указанные в примерах пути к файлам и каталогам тебе придется исправить на те, которые в твоей системе.

ГРАФИЧЕСКАЯ МОРДА

Тебе крупно повезло, если ты работаешь не только в консоли, но и в графическом режиме. В оконных менеджерах KDE и Gnome есть очень удобные утилиты kppp и gppp соответственно. На рисунке 1 ты видишь работу kppp. Даже тупому идиоту будет понятно, что она позволяет очень удобно и быстро настроить модемное соединение. Ничуть не сложнее, чем в Windows. Наоборот, даже круче и удобнее! В kppp есть возможность посмотреть график загрузки сетевого интерфейса, а также подсчитать, во сколько рубликов тебе обошлась работа в сети. Разобраться не просто, а ОЧЕНЬ просто.


Спецвыпуск Xakep, номер #031, стр. 031-048-3, LINUX, СЕТЬ И ВСЕ, ВСЕ, ВСЕ...Все для пингвиньего серфинга

LINUX, СЕТЬ И ВСЕ, ВСЕ, ВСЕ...Все для пингвиньего серфинга

Vitls (vitls@chat.ru)

Спецвыпуск Xakep, номер #031, стр. 031-048-3

Если тебе покажется сложным настраивать руками pppd, посмотри на наличие программы eznet (www.hwaci.com/sw/eznet/). Также интересна программа wvdial. Последняя консольная утилита рулезна тем, что ей можно указать не один телефон провайдера, а несколько, и она сама может дозваниваться до прова; если соединение прервалось, перебирать номера телефонов, да и еще до фига всякой всячины. И вообще, включи свой чайник на форсированный режим, пройдись вот сюда: http://freshmeat.net/search/?q=pppd§ion=projects&x=0&y=0, и ты увидишь офигенно много ссылок на различные программы и утилиты, связанные с ppp. Там есть и текстовые инструменты для настройки pppd, и графические, и программы мониторинга работы, и программы сбора статистики. В общем, развлекайся.

НЕ ПРОМАЖЬ МИМО ЛИНКА!

ОК. Будем считать, что соединение ты настроил и до прова дозвониться сумел. Теперь пришло время пошастать по просторам Сети. Разумеется, тебе нужны нормальные программы для этого дела.

Первое, что сразу приходит на ум, - браузер Mozilla. Растет сие изделие на сайте www.mozilla.org. Там же есть готовые собранные пакеты для различных операционных систем. Твое дело - скачать, распаковать архив и от root запустить инсталлер. А дальше останется только ответить на несколько вопросов. На рисунке 2 видно, что настройка программы не составляет никакого труда. Хочу заметить, что я пользуюсь Mozilla, которая собрана командой ALT Linux Team (www.altlinux.ru), а посему русский интерфейс и все такое прочее. Некоторые дистрибутивы включают Mozilla в комплект. Если ты счастливый обладатель пакетного дистрибутива (Red Hat, Mandrake, SuSE), то, скорее всего, тебе просто нужно на дисках найти rpm-пакет с x-chat и установить его командой rpm -ivh имя_пакета от имени администратора системы (например, rpm -ivh mozilla-1.2.1-alt6.rpm). А как не будет хватать чего-нибудь? Фигня, по крайней мере rpm тебе скажет, чего именно не хватает, и это обязательно найдется на дистрибутивных компакт-дисках (или в Инете). Еще больше повезло обладателям дистрибутивов Debian и ALT Linux (Junior 1.х, 2.х или Master 2.х). У них есть волшебное слово apt-get install mozilla (так же из-под root). После этого заклинания программа установится легко и непринужденно. Я являюсь обладателем ALT Linux Master 2.2. Поздравив себя с этим, я установил программу еще при установке системы. Такая вот армейская драма.

Если ты экстремал и все любишь собирать сам, то сливай исходники Mozilla. Для компиляции достаточно скачать с сайта себе архив с исходными текстами программы, распаковать, поплясать с бубном и попробовать скомпилировать (стандартные шаманские заклинания configure; make; make install, причем последнее шаманство надо проделывать от root). Но сразу предупреждаю, что с компиляцией тебя может ожидать полный облом. Уж очень сложная Mozilla. Возможно, что в твоей системе не будет хватать нескольких библиотек, боюсь, что тебе все же придется напрячь свой мозг, найти и скачать необходимые компоненты для сборки программы.


Спецвыпуск Xakep, номер #031, стр. 031-048-4, LINUX, СЕТЬ И ВСЕ, ВСЕ, ВСЕ...Все для пингвиньего серфинга

LINUX, СЕТЬ И ВСЕ, ВСЕ, ВСЕ...Все для пингвиньего серфинга

Vitls (vitls@chat.ru)

Спецвыпуск Xakep, номер #031, стр. 031-048-4

Mozilla умеет использовать в своей работе модули сторонних производителей. Еще их называют plug-in'ами. Есть модули для отображения java, есть модули для отображения macromedia flash роликов, есть модули для воспроизведения звука (realaudio или какая-нибудь еще прибамбасина), можно заставить Mozilla показывать киношки и делать всякую иную ерунду. Если найдешь соответствующий модуль, то она тебе и носки постирает. Установить модуль несложно. При попытке воспроизвести неизвестный тип web-контекста Mozilla попытается его распознать. А потом, в случае успеха, предложит тебе установить модуль. Тебе останется лишь ответить типа "да" и нажать пимпочку. В зависимости от сборки модуль кладется либо в домашний каталог пользователя, либо в каталог, куда установлена Mozilla. Поэтому лучше всего операцию по установке нового модуля производить запустив браузер от пользователя root.

На основе Mozilla (точнее на основе движка gecko) сделано несколько браузеров. Один из них - Phoenix (www.mozilla.org/projects/phoenix). Он гораздо меньше размером, но шустрее работает, хоть и немного ограничен в возможностях. На сайте валяются только бинари, исходники доступны только разработчикам.

Для пользователей Gnome есть Galeon (galeon.sourceforge.net). В его основе также лежит Mozilla, но браузер работает очень быстро и без напрягов.

Пользователи KDE тоже не обижены. У них есть Konqueror - браузер и файловый менеджер в одном флаконе. Его внешний вид заценивай на рисунке 3. Выглядит вполне прилично. Скорость работы тоже очень и очень не плоха. Входит в поставку всех дистрибутивов, в составе которых есть KDE.

Все перечисленные программы просмотра web-страниц умеют работать с одинаковым набором plug-in'ов. Konqueror, кроме того, умеет использовать закладки (bookmarks) от Mozilla (galeon, phoenix, само собой, имеют одинаковый формат закладок).

Чуть не забыл! Для Linux есть также реализация довольно забавного браузера Opera. И это не шутка. Все богатство закопано на www.operasoftware.com. Браузер коммерческий, исходников тебе никто не даст, придется довольствоваться тем, что там у них есть. Работает он неплохо, но есть одна мелкая неприятность. Во время работы придется пялиться на рекламный баннер. Чтобы его отключить, Oper'у придется купить или... не купить :).

СЛАВА КАЧКАМ!

С браузерами ты справился. Тебе для нормальной работы потребуется еще как минимум одна вещь. Не догадался? Тупица! Качалка файлов тебе нужна нормальная! С возможностью докачки файлов.

Консольных качалок есть несколько. Самая известная среди них называется wget. Родом она с сайта wget.sunsite.dk. Скачать архив с исходным текстом можно и отсюда: ftp://ftp.gnu.org/pub/gnu/wget/wget-1.8.2.tar.gz (возможно, что есть версия и поновее). Процедура компиляции и установки тебе, наверное, уже известна. Все, как обычно: configure; make; make install от пользователя root. Собранный и готовый к употреблению пакет входит во все уважающие себя дистрибутивы. Так что париться со сборкой тебе, вероятнее всего, не придется.


Спецвыпуск Xakep, номер #031, стр. 031-048-5, LINUX, СЕТЬ И ВСЕ, ВСЕ, ВСЕ...Все для пингвиньего серфинга

LINUX, СЕТЬ И ВСЕ, ВСЕ, ВСЕ...Все для пингвиньего серфинга

Vitls (vitls@chat.ru)

Спецвыпуск Xakep, номер #031, стр. 031-048-5

Использовать wget проще некуда. Команда, например, такая:

wget -c ftp://sunsite.doc.ic.ac.uk/ls-lr.z

Прога соединится с вебсервером, попросит там файл ls-ir.z, и, если он там есть, wget его оттуда заберет. Опца -c прикажет wget'у запомнить состояние при обрыве соединения с сетью. Как только оно восстановится, wget продолжит закачку.

Данная прога позволяет скачивать не только файлы поодиночке, но также группы файлов или целые сайты сразу. В man wget об этом популярно рассказано. Так что вперед, вьюноша.

Любителей графических интерфейсов ожидает приятный сюрприз в виде программы X-Downloader с сайта www.krasu.ru/soft/chuchelo. Она жутко похожа на знаменитый ReGet под форточки (рисунок 4), но она в несколько раз лучше по своим возможностям. Рекомендую!

Здесь я постараюсь привести полный список свойств, которые доступны в данной программе:

* закачка по протоколам ftp и http;

* поддержка ftp и http прокси;

* рекурсивная закачка по ftp;

* рекурсивная закачка по http;

* изменение ссылок в HTML файлах для offline просмотра;

* поддержка "маски" в закачке через ftp;

* возможность ограничения глубины рекурсии;

* возможность "откладывать" закачку файла на заданное время;

* встроенный планировщик, позволяющий планировать различные действия;

* поддержка продолжения закачки;

* автоматическое переподключение к серверу после потери соединения;

* возможность ограничения пользователем максимальной скорости закачки как для всех закачек, так и для отдельных;

* возможность ограничивать количество подключений к заданному серверу;

* ведение логов для каждой закачки;

* поддержка "Drag and Drop", например из Netscape;

* возможность добавлять новую закачку через командную строку;

* слежение за буфером обмена;

* ведение главного лога, который можно записывать в файл;

* автоматическое сохранение всех настроек и интерфейса;

* возможность конфигурирования видимых столбцов в очереди закачек;

* возможность конфигурировать панель кнопок;

* локализация (перевод) на 20 языков;

* обширные возможности по конфигурации;

* возможность закачивать один файл в несколько потоков (Massdownload);

* запуск без интерфейса в командной строке.

Вот такая фигня. Тебе все отсюда понятно? Любой современный дистрибутив непременно содержит в своем составе данную программу. Собрать ее также нетрудно. Автор проги - русский, и документация на русском языке также доступна.

ЛЕНЬ И ЕЕ МАТУШКА

Для особо ленивых могу сказать, что тяжелую работу по скачиванию файлов из сети можно немного автоматизировать. Не забывай, что в твоей системе есть такая волшебная программа, как cron. Что? Ты ее не установил? Ты кретин. Бегом устанавливать! Даю халявный рецепт. Допустим, тебе надо каждые сутки в 3 часа ночи соединиться с сетью и выкачивать супернужный файл. Ты в это время обычно храпишь, как суслик. И что делать? А вот что! Для начала пишем коротенький скриптик на shell (пример основан на настройках pppd, о которых я рассказывал вначале):


Спецвыпуск Xakep, номер #031, стр. 031-048-6, LINUX, СЕТЬ И ВСЕ, ВСЕ, ВСЕ...Все для пингвиньего серфинга

LINUX, СЕТЬ И ВСЕ, ВСЕ, ВСЕ...Все для пингвиньего серфинга

Vitls (vitls@chat.ru)

Спецвыпуск Xakep, номер #031, стр. 031-048-6

#!/bin/bash

pppd call isp

wget -c -P /var/tmp ftp://ftp.supersite.com/pub/super-puper/file

KILL 'CAT /VAR/RUN/PPP0.PID'

Скрипт обзовем get-flile.sh и запишем в каталог /var/tmp. Скорее всего, эту чушь ты будешь делать из-под пользователя root. Хотя последние версии pppd умеют разрешать устанавливать соединение и обычным пользователям. Но в каждом конкретном случае все зависит от системы. Далее тебе предстоит настроить расписание для cron'a:

crontab -u root -e

После этого запустится текстовый редактор (по умолчанию запустится vi), в котором надо нацарапать примерно следующее:

0 3 * * * sh var/tmp/get-file.sh

и сохранить (рисунок 5). Crontab установит расписание и согласно ему каждые сутки в три часа ночи будет автоматически запускаться pppd, wget будет скачивать файл и сохранять его в каталоге /var/tmp, а потом соединение будет завершаться. Такие вот дела. Ну и, конечно, ты будешь конченным придурком, если будешь выключать комп в это время :).

Ну, вот и все! Надеюсь, тебе вся эта пурга окажется полезной. Дерзай!


Спецвыпуск Xakep, номер #031, стр. 031-052-1, НЕ ЗАХОДЯ В РЕАЛ

НЕ ЗАХОДЯ В РЕАЛ

Скрыпников Сергей 'aka' Slam

Спецвыпуск Xakep, номер #031, стр. 031-052-1

(sergey@soobcha.org)

обзор лучших ICQ-клиентов под Вынь

ICQ (I Seek You) сейчас, по-моему, неотъемлемая вещь в "джентльменском наборе" каждого чела, который зависает в Интернете. А что?! Нет ничего удивительного - всегда можно узнать, когда твои друзья\подруги в Интернете, всегда можно экстренно с ними связаться, в конце концов не зря же аську называют "Интернет-пейджером".

Я думаю, что ты и так знаешь, что это такое и с чем его едят, так что перейду непосредственно к рассмотрению самих клиентов, чтобы ты мог решить, что же для тебя все-таки лучше, и выбрать самую удобную и навороченную прогу.

НАШИ ПОДОПЫТНЫЕ КРОЛИКИ

Прога: &RQ

Качать: http://www.rejetto.com/&RQ

Размер: 721 Кб

Интерфейс: русский

Я начал обзор именно с этой проги, потому что именно она стоит у меня в качестве дефолтового ICQ-клиента. Что мне понравилось? Прежде всего - полная, некорявая русификация и возможность добавлять юзеров, не дожидаясь от них того, что они дадут тебе авторизацию. Потом можно отметить возможность запуска неограниченного количества копий программы с разными юзерами (иногда, когда нечего делать, сижу и чатюсь сам с собой, а на следующий день все это читаю и громко смеюсь :)). Как и в обычной аське, челов можно добавлять в разные группы (family, friends, co-workers, etc), чатиться с ними, ставить автосообщение, если ты занят или тебя нет перед компом, можно сделать так, чтобы автосообщение менялось каждый раз, когда ты меняешь свой статус. Есть фильтр входящих сообщений (по ключевым словам, по номеру ICQ, если не в контакт-листе), скины, которые ты можешь скачать оттуда же, откуда и саму прогу.

Итог: Получилась весьма неплохая прога, которую можно носить с собой на дискетке. Конечно, она не обладает рядом возможностей (получение\отправка файлов, разговор по телефону и т.п.), но если для тебя главное именно пообщаться, то это самый руль.

Оценка: 4

Прога: Trillian

Качать: http://bayk.ru/trillian-v0.74.exe

ftp://ftp.mgul.ac.ru/pub/Win/Network/Chat/TrillianPro.zip

Размер: 2467 Кб

Интерфейс: English

Поддержка русского языка: да

Самая отличительная черта данного клиента в том, что он поддерживает не только ICQ, но и AIM, IRC, MSN, YAHOO!. Прикинь, каким удобным может стать общение, когда ты одновременно сидишь и в аське, и в ирке, при этом юзаешь один клиент (хотя, конечно, лучше мирка для IRC пока я ничего не вижу :)). Все, что я говорил про &RQ, можно отнести и к триллиан, но даже по размеру можно понять, что не все так просто. Что мне понравилось - имеет профили для каждого юзера, то есть для дома самое то - свой профиль, жены, ребенка... (ой... какая жена? какие дети? :)). В онлайне может быть одновременно несколько UIN-ов.

Еще, если тебе не нужны некоторые службы, то сейчас расскажу, как все утроить. Например, речь идет о модуле MSN. Так вот, чтобы эти службы не висели невостребованными, их можно отключить, то есть сделать так, чтобы они не загружались при запуске программы. Для этого нужно переименовать файл msn.dll, например, в msn.dlu в директории с Trillian`ом. По аналогии то же можно делать и с Yahoo, и с IRC. Нельзя трогать только модуль AIM/ICQ - он основной (нельзя, чтобы он не загружался). Сейчас у меня Trillian (AIM/ICQ/IRC) занимает в памяти 3 472 Кб, изначально почти в 3 раза больше (хотя если у тебя гиг памяти и шустрый винт, то ты мог бы не читать этот абзац). Понравилось то, что сообщения улетают мгновенно, чего нельзя сказать об обычной аське. Присутствует большой выбор скинов (все сделано в XML). Загляни на http://www.trillian.net.ru - тут найдешь еще много полезного об этой проге, кстати, и плагины, и скины тоже тут.


Спецвыпуск Xakep, номер #031, стр. 031-052-2, НЕ ЗАХОДЯ В РЕАЛ

НЕ ЗАХОДЯ В РЕАЛ

Скрыпников Сергей 'aka' Slam

Спецвыпуск Xakep, номер #031, стр. 031-052-2

Итог: Если ты любитель, чтобы все было, как говорится, "all in one", то именно на эту прогу должен пасть твой выбор.

Оценка: 5

Прога: ICQ

Качать: http://www.icq.com

Размер: 3880 Кб

Интерфейс: English

Думаю, тут рассказывать нечего :). Название говорит само за себя. Есть все, что может потребоваться в процессе сетевого общения, а если еще и поставить некоторые плагины, то жизнь в сети будет вообще в радость. Тут есть и ICQPhone (возможность разговаривать с челом голосом через аську), и ICQChat, и возможность отправлять смс'ки на мобилы (правда, если ты живешь в маленьком городе, то тебе данная фича не подойдет, так как список операторов, которые поддерживаются, слишком мал) :(.

Теперь я дам тебе ссылочки на полезные проги\плагины, которые помогут тебе с большим успехом общаться по аське.

http://evrovidenie.com/soft/icq/uin2ip3.zip - определяет IP собеседника. Одно условие - человек должен быть в контакт-листе.

http://evrovidenie.com/soft/icq/talk.zip - определяет, находиться ли чел в инвизибле либо он в оффлайн. Еще много фич, рассказать о которых не позволяет размер статьи, - скачай и посмотри сам.

В принципе, ты можешь сам найти все, что тебе нужно, для этого следует набрать в поисковике ICQ Tools, и получишь кучу ссылок.

В ICQ есть такая фича, как Shared Files. То есть ты расшариваешь определенную папку (папки) и кидаешь туда различное файло (как то: фотки, музыку и т.п.), а юзеры, у которых ты есть в контакт-листе, просто берут и качают все из этой папки. Очень удобно, но одно "но" (сорри за каламбур): это большая дыра, так что, прежде чем это делать, подумай - нужно ли оно тебе или нет?!

В общем, ICQ - это классика жанра (стоит ли доказывать его превосходство, когда количество пользователей перевалило за 120 миллионов), а все остальное - это уже некоторое клонирование. Так что, если ты совсем новичок в сети, то эта программа будет для тебя лучшим выбором.

Итог: 5 (хотя за тормоза можно было и 4 поставить, но не будем, ибо свято).

Прога: Miranda

Качать: http://evrovidenie.com/soft/icq/miranda2.zip

Размер: 333 Кб

Интерфейс: English

Думаю, ты уже немало слышал об этом клиенте. За короткое время он успел завоевать популярность по всем мире, и теперь многие пользователи аськи пересаживаются именно на него, во-первых, из-за десятков написанных для него плагинов, которые существенно расширяют возможности этого клиента. Из основных возможностей можно выделить отправку сообщений сразу нескольким юзерам, возможность экспорта\импорта контакт-листа из ICQ, так же как и хистори. Еще раз хочу обратить внимание на то, что "голая" миранда ничего существенного из себя не представляет (уж лучше &RQ поставить), а может конкурировать с соперниками только тогда, когда ты не поленишься и установишь несколько плагинов (каких, ты должен решать сам).


Спецвыпуск Xakep, номер #031, стр. 031-052-3, НЕ ЗАХОДЯ В РЕАЛ

НЕ ЗАХОДЯ В РЕАЛ

Скрыпников Сергей 'aka' Slam

Спецвыпуск Xakep, номер #031, стр. 031-052-3

В ИТОГЕ

В общем, больше не буду тебя грузить, все основные показатели ты можешь посмотреть в этой таблице:

Кстати, совсем забыл сказать, если у тебя есть мобильник и у тебя выделенный канал в Интернет, то тебе пригодится прога ICQ Forwarder v1.25 (http://drgonzo.nm.ru/icqfw.zip), которая может пересылать все сообщения с аськи на мобилу в виде смс'ок. Очень удобно настраивается и с русской помощью.

Если у тебя появятся вопросы - мой мыл всегда открыт для тебя.


Спецвыпуск Xakep, номер #031, стр. 031-054-1, ИСТОРИЯ О LINUX И "ТЕТЕ АСЕ" Обозреваем ICQ-клиенты под Линь

ИСТОРИЯ О LINUX И "ТЕТЕ АСЕ" Обозреваем ICQ-клиенты под Линь

Vitls (vitls@chat.ru)

Спецвыпуск Xakep, номер #031, стр. 031-054-1

Здоров, приятель! Ну что мне с тобой делать? Настроил ты соединение с Интернет, даже броузер установил и побродил по просторам Сети. Но чего-то тебе не хватает. Нет в жизни счастья! Пообщаться-то хочется? Все друзья "аську" пользуют для общения, один ты ламобот со своим Linux'ом. Тоска... Хоть на Винду переходи! А вот и ни хрена! По части использования всяких "асек" Linux даст фору любой Винде.

КОНСОЛЬНАЯ ТЕТКА

С чего начнем? Пожалуй, с самого простого. С консольных программ. Чего напрягся? Да-да! Под консоль тоже есть программы-клиенты icq. Самая продвинутая называется centericq. Скачать ее можно с сайта http://konst.org.ua/centericq/. Написана она одним бравым украинским парнем. Программа очень проста в настройке и использовании (тем более что есть документация на РУССКОМ языке). Для того чтобы ее установить, тебе надо будет пройтись на указанный чуть выше сайт и слить архив с исходным текстом. Затем тебе этот архивчик нужно будет распаковать куда-нибудь и произнести шаманские заклинания configure; make; - и от имени пользователя root замутить make install. Если не будешь ленивым идиотом, то прочтешь документацию, идущую вместе с пакетом. Вдруг я чего-то забыл, а ты будешь, как лам, сидеть и тупо глядеть на ошибки.

Как видно из скрина (Рис. 1) данная программа умеет работать не только с протоколом icq, но также с такими штуками, как Yahoo!, MSN и даже irc (all-in-wonder епрст!).

НОВЫЙ ПРОТОКОЛ

На самом деле этими протоколами прелесть centericq еще не заканчивается. Centericq поддерживает довольно молодой протокол общения со странным названием jabber (произносится "жаббер"). Новый протокол отличается от всех прочих в первую очередь тем, что он свободный. Его разрабатывает группа людей в проекте www.jabber.org (русская страница www.jabber.ru). Он не принадлежит никому в отдельности. Эта вся шняга означает: если хочешь написать программу, которая использует этот протокол, тебе не придется сгружать бабки на лицензионные отчисления. Кроме всего прочего, открытость протокола позволяет быстро выявлять и закрывать всякие возможные дыры в безопасности (которых дофига в том же icq).

Общаться с народом в centericq довольно легко. Посмотри на скриншот (Рис. 2), и ты в этом убедишься сам. Ну что, понравилось? Ползем дальше.

ПРЕЛЕСТНАЯ МОРДОЧКА

Самым популярным графическим клиентом icq является программа Licq (некоторые читают как "лиска"). Программа довольно интересная, но в то же время странноватая. В обращении она не сложнее ручного пулемета Калашникова. Как и большинство проектов со стажем, licq поставляется и в виде исходников, и в виде готовых собранных пакетов. Возможно, что в твоем дистрибутиве licq уже есть. Настройки программы позволяют общаться с пользователями windows-клиентов посредством набора таблиц перекодировки. То есть кодировка твоей системы может быть koi8-r, а у твоего друга cp1251, и вы запросто можете трепаться.

Пользователям rpm-based дистрибутивов установить программу проще простого. Для начала нужно найти в дистрибутиве пакет, содержащий licq. Если его нет, то его можно найти на сайте www.rpmfind.net. Затем достаточно от имени пользователя root дать команду что-то вроде rpm -ivh licq-1.2.4-alt2.rpm, и если все нормально, то программа установится. Ну а если нет, то причин может быть масса: начиная от нехватки какой-либо компоненты и заканчивая тем, что готовый бинарник собран не для твоего дистрибутива. Тут "без бутылки" не разберешься. Юзерам дистрибутивов от ALT Linux и Debian установка сильно надоедать не будет. Команда apt-get install licq от пользователя root все сделает сама. Licq входит в состав этих дистрибутивов.


Спецвыпуск Xakep, номер #031, стр. 031-054-2, ИСТОРИЯ О LINUX И "ТЕТЕ АСЕ" Обозреваем ICQ-клиенты под Линь

ИСТОРИЯ О LINUX И "ТЕТЕ АСЕ" Обозреваем ICQ-клиенты под Линь

Vitls (vitls@chat.ru)

Спецвыпуск Xakep, номер #031, стр. 031-054-2

Собирать licq самому нетрудно. Если у тебя уже есть хоть небольшой опыт сборки программ. Вся трудность заключается в том, что licq может быть собрана как с библиотекой qt, так и с библиотекой gtk+. Пользовательский интерфейс почти не зависит от основы. На шоте (Рис. 3) показана licq, собранная с использованием gtk+. Главное - внимательно прочесть то, что пишется в прилагаемой к исходным текстам документации. Также нужно обязательно почекать то, что выдаст команда configure -help. Только потом можно в вызов configure добавить нужные опции, затем попробовать дать команду make и в случае успешной сборки программы от пользователя root выполнить make install, чтобы установить программу в системе.

SIM

Достойной заменой старушке licq можно назвать программу sim (simple instant messager). Пишет ее еще один русскоговорящий парень. Использует для ее реализации исключительно библиотеку qt. Родная деревня программы находится на сайте http://sim-icq.sourceforge.net. Данное "приложеньице" отличается продуманным дизайном, небольшим размером и удобством применения (кстати, там же на сайте есть версия и под Windows). Скриншот (Рис. 4) показывает, что выглядит эта фиговина очень и очень прилично.

Сборка sim не сулит подводных камней. Возможно, что в Сети ты для своего дистрибутива найдешь уже собранную версию программы. ОК. Для сборки sim тебе потребуется установленная в системе библиотека qt (свободную версию можно найти на сайте www.trolltech.com) версии не менее 3.1 (хотя у меня на одной древней машине sim версии 0.8 собрался с qt версии 2.3).

ТЕТКА ДЛЯ ГНОМА

Для любителей Gnome можно порекомендовать легкий по весу icq-клиент со странным названием gaim. Изначально он писался как клиент AOL Instant Messaging, но постепенно оброс функциями клиента icq, MSN, jabber и чего-то еще. Собирать его довольно легко. Достаточно иметь установленной библиотеку gtk+. Процесс сборки тривиален: configure; make; make install от пользователя root. В функции программы также включены модули перекодировки и некоторые другие, улучшающие жизнь пользователю (napster для любителей халявы, irc для любителей групповухи и т.д.). Не исключено, что в твоем дистрибутиве уже будет собранный пакет с gaim. Так что, прежде чем пытаться собирать из исходников, осмотрись.

PSI

Отдельного разговора удостаивается почти универсальный комбайн под названием psi. Растет и зреет он на сайте http://psi.sourceforge.net. Psi не является прямым клиентом icq. Он является клиентом системы jabber. Но многие jabber-сервера, на которых ты можешь получить учетную запись (поиск на google.com.ru/linux по слову jabber тебе даст огромную кучу ссылок по этой теме), могут общаться с серверами icq через специальные транспортные службы. Jabber - система довольно новая, и не все возможности отточены, но я тебе могу сказать: то, что уже работает, доставляет мне как пользователю массу удовольствия. В отличие от icq, в jabber всю работу по хранению списка пользователей, поддержанию транспортов и иное управление берет на себя jabber-сервер. Что существенно облегчает работу мобильных пользователей. Где бы ты ни подключился, у тебя всегда будут одинаковые настройки.


Спецвыпуск Xakep, номер #031, стр. 031-054-3, ИСТОРИЯ О LINUX И "ТЕТЕ АСЕ" Обозреваем ICQ-клиенты под Линь

ИСТОРИЯ О LINUX И "ТЕТЕ АСЕ" Обозреваем ICQ-клиенты под Линь

Vitls (vitls@chat.ru)

Спецвыпуск Xakep, номер #031, стр. 031-054-3

Psi разработан под библиотеку qt. Так же, как и gaim, данная козуля собирается до неприличия легко. Лишь бы qt версии 3.х была у тебя установлена. Честно говоря, я уже устал повторять заклинания, которые тебе нужно произносить для сборки программы самостоятельно.

ПИНГВИНЪ РУЛИТ

Тык-с... Теперь поговорим о том, чем трепотня по "аське" под Linux круче трепотни из-под Windows. Я полагаю, ты не идиот и читал или слышал о таких неприятностях, как кража номера icq, или о том, как на компьютер пациента через icq попадает всяческая дрянь. Так вот, под Linuxом тебе такая шняга не грозит. Во-первых, windows-вирусы и трояны просто неработоспособны под Linux. Во-вторых, все свободные программы-клиенты для Linux не имеют дурацкой привычки крутить рекламные баннеры, а это существенная экономия для твоего общего кошелька. В-третьих, исходный код программ для Linux открыт, и это означает, что в нем быстрее находятся и исправляются ошибки.

Такая вот тема, чувак. И если тебе кто-то после этой статьи будет говорить, что под Linux нет прог для аськи, смело дай ему в зубы... эту статью, и пусть читает до посинения. Заодно пошли его на... сайт freshmeat.net, и пусть поищет по слову icq. Я просто опух от такого количества всевозможной софтины для работы с icq. Hasta la vista, baby!


Спецвыпуск Xakep, номер #031, стр. 031-056-1, ОБЩАЙСЯ КОМФОРТНО! Руководство по выбору IRC-клиента

ОБЩАЙСЯ КОМФОРТНО! Руководство по выбору IRC-клиента

Докучаев Дмитрий aka Forb

Спецвыпуск Xakep, номер #031, стр. 031-056-1

(forb@real.xakep.ru)

IRC - как много в этом звуке! Придуманный еще в далеком 1984 году, когда миром правили компьютеры первых поколений, он не устарел. Более того, IRC постоянно совершенствовался, и наше время далеко не предел его существования. Итак, отложи все дела и слушай в эту дырку: сегодня мы поговорим об актуальной проблеме - проблеме выбора IRC-клиента.

Даже если ты давно определился с клиентом, не надо махать руками, мол, я давно юзаю mIRC, и меня не переубедить. Возможно, ты просто не видел другие проекты, а при упоминании о чем-то новом ты просто стремался менять свой уютный, но довольно тесный mIRок :). Я постараюсь исправить твою "клиентофобию", проведя небольшое шоу известных IRC-клиентов.

Выбирать клиенты мы будем под Windows - операционку, за штурвалом которой расположилось большинство пользователей, желающих пообщаться виртуально.

MIRC32 - ВОСХОДЯЩАЯ ЗВЕЗДА IRC

Несомненно, законное первое место в моем обзоре занимает всем известный mIRC32. Приведу некоторые факты из истории его жизни. Этот проект примечателен тем, что обновляется уже больше восьми лет. Первый его релиз был 28 февраля 1995 года и имел версию 2.1a. Разумеется, что все функции и примочки появлялись и дополнялись от версии к версии. В настоящем времени клиент имеет версию 6.03, вышедшую полгода назад. Автором mIRC, как ты, наверное, знаешь, является Khlared Mardam-Bey.

Что же хорошего в этом клиенте? С одной стороны, mIRC имеет привлекательный вид, а с другой - множество функций, в том числе собственный язык программирования, тем самым удовлетворяя самые сокровенные желания любого пользователя. Настройка этого клиента очень простая, но на оттачивание клиента под себя может уйти довольно много времени.

Итак, что же примечательного имеет mIRC?

1. Гибкую настройку внешнего вида. В клиенте нельзя изменить разве что геометрическую форму окна. В Tools->Colors (горячая клавиша alt+k) удобно настраиваются цвета на все события. Таким образом, одним щелчком мыши ты можешь перекрасить своего клиента в другой цвет :).

2. Мультисерверную поддержку. Начиная с версии 6.0, разработчики mIRC наконец-то сделали возможным цепляться на несколько серверов одновременно, тем самым решив многие проблемы бедного пользователя (прежде ему оставалось лишь запускать две копии mIRC).

3. Возможность выполнять операции как визуально (при помощи мыши), так и командно (через editbox). Все команды начинаются с символа "/" и набиваются в строку ввода любого окна.

4. Подробный help. Это немаловажно, так как мощная среда программирования требует мануал, отсутствие которого приведет к полной неразберихе. Через help ты также можешь разобраться с командами и основными возможностями в IRC.

Как говорится, в каждом плюсе есть доля минуса :), поэтому mIRC имеет ряд недостатков, которые постепенно устраняются в свежих релизах. Но все равно не вредно напомнить о них.

1. Маленький свичбар (полоска, на которой располагаются открытые каналы). При двух-трех подключениях названия каналов разобрать практически невозможно.

2. Сложный язык скриптов. Я, конечно, понимаю, что программисты стараются для енд юзверей и создают все новые возможности языка, но тем самым делают его сложнее для пользователя. Ведь в IRC сидит большинство юзеров, которые жмут в клиенте только кнопку Connect :).


Спецвыпуск Xakep, номер #031, стр. 031-056-2, ОБЩАЙСЯ КОМФОРТНО! Руководство по выбору IRC-клиента

ОБЩАЙСЯ КОМФОРТНО! Руководство по выбору IRC-клиента

Докучаев Дмитрий aka Forb

Спецвыпуск Xakep, номер #031, стр. 031-056-2

3. Английский Help. Для такого крупного проекта, как mIRC, разработчики могли сделать локализацию, облегчающую жизнь пользователя, ибо разбираться в английском мануале не очень приятно. Конечно, эта проблема решается русскими энтузиастами, которые по доброте душевной занимаются переводом (например, создатели RusmIRC).

4. mIRC не является freeware продуктом. За его использование тебя просят заплатить целых 20$ :). Но на этот случай давно существует кряк. В незарегистрированной копии при запуске mIRC стартует браузер, натравленный на страницу онлайн-регистрации :).

Начальная настройка клиента выполняется за несколько шагов. При первом запуске клиента необходимо заполнить поля Full Name, e-mail address (туда можно вписать все, что угодно) и пару ников. Затем давим на кнопку Add и заполняем всего два верхних поля: Description (описание сервера) и IRC Server (собственно ip-адрес или host сервака). После проделанной операции жмем Connect to IRC Server и попадаем в IRC. Для тебя заботливо откроется менеджер каналов, используя который, ты можешь зайти в любимые комнаты :).

mIRC за свои 8 лет завоевал доверие многих поколений, поэтому основной круг Windows-юзеров использует именно его.

BERSIRC - НОВЫЙ КЛИЕНТ ДЛЯ ГРАМОТНЫХ ЛЮДЕЙ

В противовес mIRC32 выставляется другой, не менее хороший IRC-клиент - BersIRC. По своей сути BersIRC немного похож на мирк, но лишь на первый взгляд. Этот клиент написан на Delphi грамотным разработчиком Jamie Frater'ом. Первый релиз был выпущен 28 декабря 2000 года. Как видно, BersIRC молодой клиент. Но, несмотря на его молодость, он практически не уступает mIRC в своих возможностях. Чтобы в этом убедиться, проведем некоторый анализ этой софтинки.

Итак, почему же юзеры любят BersIRC (их не так много, но я лично знаю около десяти человек, отдающих предпочтение именно ему).

1. Поддержка плагинов. Такого нет даже в mIRC! В Берсирке встроен mp3-плагин (аналог amip), плагин автозамены текста и многое другое. К тому же сам пользователь может подгружать свои собственные плагины, которые можно скачать с www.bersirc.net.

2. Еще раз плагины. Все скрипты в Bersirc пишутся исключительно на Паскале. Если ты не забыл уроков информатики, то написать скрипт для тебя не составит труда. Более того, паскаль намного удобнее mIRC-языка программирования. Пользователь может использовать плагины, написанные под Delphi, что делает клиента очень удобным.

3. Мультисерверность. Она есть и в mIRC, но в BersIRC появилась гораздо раньше, поэтому пользователи находили в Берсирке хорошую альтернативу.

4. Множество настроек и примочек. Все настройки собраны в одно большое меню, а не рассредоточены по всему интерфейсу, как в mIRC. Тут можно найти множество установок, таких, как управление программой, настройка цветов, параметры скриптов, настройка игнор листа и т.п. Также понравилась удобная подсветка кнопок и указателей - это делает клиент более привлекательным в сравнении с mIRC.


Спецвыпуск Xakep, номер #031, стр. 031-056-3, ОБЩАЙСЯ КОМФОРТНО! Руководство по выбору IRC-клиента

ОБЩАЙСЯ КОМФОРТНО! Руководство по выбору IRC-клиента

Докучаев Дмитрий aka Forb

Спецвыпуск Xakep, номер #031, стр. 031-056-3

Минусов у BersIRC очень мало. Как правило, это незначительные недочеты, которые могли бы быть исправлены в новых версиях.

1. Глюки с Ignore list. Когда ставишь флудера в игнор, его экшены (команда /me) все равно отображаются. Конечно, это не столь существенно, но довольно неприятно.

2. Отсутствие редактора скриптов. Эта проблема была возложена на пользователя, который может задать путь к его любимому редактору. Но, как правило, редактор, ориентированный для отдельного клиента, лучше любого другого.

3. Самый серьезный минус - клиент продолжительное время не девелопится. Последняя его версия (1.40) вышла 21 августа 2001 года. Но не все так плохо. По последним данным, сырцы BersIRC были проданы на аукционе, быть может кто-то и займется его развитием. Именно поэтому, BersIRC не может создать серьезную конкуренцию mIRC, хотя в первое время был лучшим IRC-клиентом под Windows.

Настройка клиента практически такая же, как и в mIRC32. Только добавление серверов переехало во вкладку connections. К тому же я был приятно удивлен, когда все мои mIRC-настройки автоматически появились в BersIRC. Что говорить - искусственный интеллект налицо :).

Как видишь, BersIRC, несмотря на его молодость, устаревает. Но, возможно, скоро мы увидим свежий релиз 2.0, который воплотит в себе все наши мечты :).

Официальный сайт проекта www.bersirc.com регулярно обновляется. Там ты можешь прочитать самые свежие новости об IRC и о судьбе клиента.

И ЭТО ВСЕ?

Это далеко не единственные экземпляры под Windows. Из навороченных клиентов, как это ни печально, устарел знаменитый Pirch. Это произошло из-за отсутствия свежих версий с 1998 года. Хотя клиент был очень хороший - там были и мультисерверность, и навороченный язык скриптов. В последнее время также появляются небольшие проекты, реализующие нужды пользователей. Яркий пример - Trillian - ICQ и IRC в одном флаконе, созданный специально для людей, которые не любят запускать несколько приложений одновременно. Для любителей Linux, но сидящих в Винде, существует портированный XChat, который практически ничем не отличается от своей клонированной Unix-версии :).

Засим прощаюсь. Думаю, что цель моего обзора достигнута - теперь ты действительно определился, что лучше для тебя. Ведь главное - общаться комфортно, не заморачиваясь настройкой и глюками клиента. При отсутствии последних твое общение будет легким и непринужденным, чего желает практически каждый чатланин ;).


Спецвыпуск Xakep, номер #031, стр. 031-058-1, В ЧАТ ИЗ-ПОД РУТА. IRC-клиенты для Linux

В ЧАТ ИЗ-ПОД РУТА. IRC-клиенты для Linux

Alexandr Ivanov

Спецвыпуск Xakep, номер #031, стр. 031-058-1

(heavybrain@fromru.com)

Наверное, каждый правильный человек, который балуется c компами, слышал о такой штуке, как IRC. Даже если ты и не слышал о ней раньше, рано или поздно тебе придется с нею познакомиться. Почему? Да потому что в этой сети чатов крутится огромное количество кулхацеров, и, если ты хочешь быть в струе, болтовня с ними, как это ни странно, пойдет тебе на пользу.

IRC - это аббревиатура от Internet Relay Chat. Впервые прообраз современных IRC-сетей появился в Финляндии в 1988 году. Сконструировал тогда все это хозяйство финский студент Jarkko Oikarinen (да, тоже студент и тоже финский, я думаю, ты понимаешь, о чем это я ;)). Прототипом IRC послужил сервис talk операционной системы UNIX (в Linux этот сервис также есть, подробности по "man talk"), который служит для общения в реальном времени двух юзеров.

Итак, наша цель - чатиться под Linux. Приступим. Для начала несколько оговорок. Существуют довольно много интересных проектов, связанных с IRC под Linux, таких как IRC-серверы, скрипты, боты и прочие плоды деятельности многих талантливых людей. Но наша задача-минимум - разобраться с установкой IRC-клиента для Linux (хотя возможны и другие варианты, например, FreeBSD или любая другая правильная система).

Основными IRC-клиентами среди русскоговорящей (русскопишущей) части пользователей Linux являются на сегодняшний день X-Chat (xchat.org) и BitchX (www.bitchx.com). С них и начнем. X-Chat я люблю больше, поэтому и расскажу о нем тоже больше.

X-Chat

Это клиент для графической среды (XFree86, www.xfree86.org). Он построен на библиотеке GTK+ (как и среда GNOME). Версии X-Chat 1.*.* используют библиотеку GTK+, а 2.*.* - соответственно GTK2. Клиент не имеет проблем при работе с кириллицей (koi8-r - у всех, cp1251 - у кого есть) и позволяет использовать схемы перекодировки. Опционально поддерживает скрипты на PERL и Python. Имеет приятный, функциональный и хорошо настраиваемый интерфейс. Возможна сборка с поддержкой консольного режима работы.

Для установки можно воспользоваться пакетом, входящим в состав дистрибутива (он там должен быть, если, конечно, ты, мой дорогой любитель хакерского ремесла, не являешься счастливым обладателем чего-нибудь сильно урезанного), или же вытянуть скомпиленный пакет из инта. Если есть желание, можно собрать из исходников, при этом, естественно, надо понимать, что и как делается. По умолчанию собирается с поддержкой также и консольного интерфейса. Для сборки и установки надо "произнести" несколько "волшебных" слов:

tar xvzf xchat-1.8.10.tar.bz

cd ./xchat-1.8.10

./configure

make

su

ввести пароль root

make install

Итак, пакет поставлен/собран/откомпилирован. Запускаем (из xterm - команда "xchat"). Видим окошко "Список серверов" с кучей предустановленных вариантов подключений к IRC-серверам. В этом окне можно забить три варианта ника, строки "реальное имя" и "имя пользователя". Три варианта ника нужны для того, чтобы разрулить ситуацию, когда первый ник уже кем-то используется в сети к моменту твоего входа - X-Chat использует второй вариант ника. На случай, если и второй вариант занят, существует третий. Ну, а если и третий кто-то присвоил, значит не судьба :).


Спецвыпуск Xakep, номер #031, стр. 031-058-2, В ЧАТ ИЗ-ПОД РУТА. IRC-клиенты для Linux

В ЧАТ ИЗ-ПОД РУТА. IRC-клиенты для Linux

Alexandr Ivanov

Спецвыпуск Xakep, номер #031, стр. 031-058-2

При нажатии на кнопку "Новый сервер" появится окно с пустыми полями для создания нового подключения к серверу. Поле "Имя" содержит строку, которой будет обозначаться создаваемое подключение к серверу в списке. Поле "Сервер" содержит само имя сервера, например, irc.wenet.ru. В поле "Порт" можно переназначить порт в зависимости от системной кодировки. Поле "Пароль" может содержать пароль для зарегистрированного в данной IRC-сети ника. Поле "Каналы" содержит список каналов, подключение к которым будет осуществляться автоматически. Формат этого поля #канал1,#канал2,...(без пробелов!). Для первого подключения это поле можно оставить пустым, так как неизвестно, какие каналы нужны. Поле "Имя(ник)" существует на тот случай, если необходимо для какого-то конкретного сервера указать какой-то определенный ник. В поле "Команда соединения" можно указать команду, которую необходимо выполнить при подключении. В этом же окне полезно поставить галку на опцию "Автосоединение". Нажимаем "ОК" и возвращаемся в предыдущее окно.

Далее нажимаем кнопку "Соединение". И если все тип-топ, наш X-Chat ломится на IRC-сервер, коннектится - и мы в полете.

Что, вместо русских букв кракозяблы? Правильно. А кодировка какая? А она совпадает с системной? Нет? Тогда слушай сюда. Многие администраторы для своих IRC-серверов устанавливают кодировку по умолчанию microsoft-cp1251. Это, как правило, идет вразрез с понятиями о правильном Linux, в котором используется koi8-r либо utf-8. Методов борьбы с происками врагов три:

1. Использовать нестандартный порт сервера. На некоторых серверах открыто несколько портов для подключения с разными используемыми кодировками. Настройка порта подключения описана выше. Могут использоваться следующие номера портов (пример):

6667: CP1251

6669: KOI8-F

6671: CP866

6668: Translit

6670: KOI8-R

6672: ISO8859-5

2. Использовать перекодировку символов. Для этого придется взять файл RUSSIAN_WIN для перекодировки из microsoft-cp1251 в нашу системную. Этот файл перекодировки используется еще в некоторых пакетах, поэтому сначала нужно поискать его в пакете X-Chat и, если его там нет, пошарить по диску. И далее в меню настроек в пункте "Наборы символов" прописать путь к этому файлу.

3. Это третий способ. Я его не знаю, но допускаю возможность его существования ;).

Настройки X-Chat по умолчанию в особой правке не нуждаются. Разве что можно включить отображение времени для каждого сообщения и увеличить размер текстового буфера (чтобы можно было прокручивать вверх на большее количество строк).

BitchX

Это консольный клиент. Полезен там, где по каким-либо причинам не установлена графическая среда. BitchX появился в 1994 году. Он "вырос" из гораздо более старого пакета ircII. По сути это сильно модифицированный клон ircII. Поддерживает цвета, схемы перекодировки, скрипты и все, что надо для мирной жизни.

Собирается так же просто, как и X-Chat, запускается из консоли такой командой:


Спецвыпуск Xakep, номер #031, стр. 031-058-3, В ЧАТ ИЗ-ПОД РУТА. IRC-клиенты для Linux

В ЧАТ ИЗ-ПОД РУТА. IRC-клиенты для Linux

Alexandr Ivanov

Спецвыпуск Xakep, номер #031, стр. 031-058-3

BitchX [options] [nick] [server]

Например, команда "BitchX -c \#linux,\#russia TeStEr irc.wenet.ru" подключит тебя к каналам #linux и #russia сети WeNet через сервер irc.wenet.ru с ником TeStEr. Символ "\" требуется в связи с необходимостью "эскейпить" символ "#", который имеет специальное значение в shell. Простое переключение между каналами осуществляется по CTRL+X.

KSirc и KVirc

Это два клиента для KDE. Первый представляет собой довольно простенький интерфейс при минимуме необходимых опций. Подойдет фанатам KDE, которые не хотят заморачиваться на настройки, скрипты и прочую не нужную начинающему пользователю ерунду :).

Второй несколько более серьезный товарищ, но, в общем, эти клиенты для любителей полупрозрачных окошек с обилием красивых кнопочек и т.п.

ChatZillla! - часть проекта Mozilla(www.mozilla.org). Приятный интерфейс, немного настроек, но есть некоторые проблемы с поддержкой кириллицы (по крайней мере у меня с версией Mozilla 1.3).


Спецвыпуск Xakep, номер #031, стр. 031-060-1, The Bat под лупой. Наводим порядок в почтовике

The Bat под лупой. Наводим порядок в почтовике

ManderX

Спецвыпуск Xakep, номер #031, стр. 031-060-1

(forother@fromru.com)

Ты уже познакомился с механизмом работы Осей, научился серфить в Инете без попапов, легко находишь варез, на десктопе у тебя красиво, в углу можно заметить консоль FreeBSD...

Но как только ты заходишь в почтовик (т.е. The Bat, ибо ничего лучше еще не придумали =), то начинается полная анархия, все письма в одной папке, большинство из которых являются СПАМом. А ведь e-mail - это основный вид коммуникации, следовательно, там должен быть порядок. Доктор прописал - лечить, значит будем лечить!

4NEWBIE

The Bat знаменит многим: адресная книга, отсутствие багов, предпросмотр письма на сервере и т.д. Но самая прикольная фича - это сортировщик писем. Например, если ты подписан на рассылку, то она будет идти в отдельную папку, а письма твоих корешей в другую. Но сначала создай папку - "Папка"=>"Создать", обзовем ее, например, Subscribe. Если поставить "Максимальное кол-во писем", равное 30, то письма будут автоматом удаляться по достижению этого кол-ва, а это гуд =) (автоматизм - залог быстрой работы); если какое-нибудь письмо надо будет оставить, то просто пометь его как "паркованное".

Можно назначить для писем в этой папке отдельные шаблоны нового письма, ответа и т.д. Также можно назначить звук, к примеру, пришло тебе сообщение от кореша Васи, отсортировалось (об этом позже =) в подпапку "Пупкин", и заиграл звук "Enemy Spotted" из контры =). А вообще, звук можно назначить еще в сортировщике. Открывай его, нажав Ctrl+Shift+S, жми пимпу "создать", название - Subscribe, "перемещать в папку", выбирай только что созданную, "subscribe", "сигнальные строки" - выбирай "отправитель", вписывай адрес робота рассылки. Безусловно, сигнальных строк может быть несколько, иными словами, может быть несколько условий сортировки. Во вкладке "действия" можно назначить дополнительные действия, например, можно при получении письма от Васи Пупкина припарковать его, проиграть мьюзик, пометить как прочитанное и сразу же вывести окно ответа. Разве не в этом счастье =)?

SPAM

По полочкам все уже разложено, но в папочку Inbox могут попасть письма, которые радуют нас новыми способам хака телефонов - для того чтобы звонить бабушке за бугор бесплатно... правда, надо отдать за это удовольствие всего лишь 20 бакинских. Тема очистки спама размусолена так, как только можно, поэтому я расскажу только про один из самых лучших способов - использовать программу, которая отсеивает спам по базам, содержащим адреса открытых релеев. Что такое открытый релей? Это почтовый сервак, который разрешает отправлять через себя почту не только своим клиентам, но и кому угодно (кто угодно = спамеры). Обычные провайдеры и службы бесплатных почтовых ящиков давным-давно не разрешают отправлять почту не своим клиентам. Поэтому спамеры и юзают такие серваки для своих гнусных целей. Так вот, в мире существуют сотни баз с этими открытыми релеями, базы эти называются списками DNSBL (DNS Black Lists - "черные списки" доменных имен Интернет). Существуют проги, которые чекают по базам и запрещают получение письма. Одна из таких - SpamPal (www.spampal.org). Прога поддерживает русский, а это уже плюсик. Быстренько качай, устанавливай и сразу же помещай в автозагрузку (если она сама туда не попала еще), чтобы всегда была загружена. Стартуй прогу, и сразу переходим к настройке, на вкладке "DNSBL" отмечай все серверы, ибо чем больше, тем лучше =). Кстати, адреса с базами обновляются, не забывай вовремя чекать обновления.


Спецвыпуск Xakep, номер #031, стр. 031-060-2, The Bat под лупой. Наводим порядок в почтовике

The Bat под лупой. Наводим порядок в почтовике

ManderX

Спецвыпуск Xakep, номер #031, стр. 031-060-2

Теперь настроим The Bat, переходи в настройки ящика на вкладку "Транспорт", нас интересует только получение почты. Допустим, что первоначальные настройки ящика у тебя такие:

А должны стать такие:

Т.е. меняем почтовый сервер на "localhost", а к имени пользователя добавляем через "@" адрес настоящего почтового сервера. Если логин "vasya", а почтовый сервер - "pop3.yandex.ru", то почтовый сервер станет "localhost", а логин станет - "vasya@pop3.yandex.ru". Теперь почта будет сначала проходить через SpamPal, а потом уже в почтовик. SpamPal будет добавлять к каждому письму техническую строку "X-SpamPal:" (для этого на вкладе "Пометки" в настройках SpamPal надо убрать все галочки и отметить только "Выводить данные..."), значение которой может быть или PASS, или SPAM. Если SPAM - значит кто-то ошибся дверью. Теперь надо создать правило отсортировки - заходи в сортировщик писем и создавай правило "Spam sort", и далее в окне "сигнальные строки" введи "^X-SpamPal: SPAM", а из списка "Где" выбери строку "Везде". Перейди на вкладку "Свойства" и убедись, что выбрана опция "Сигнальные строки как регулярные выражения". А помещать письмо надо в ранее созданную папку (для спама). Так, если случайно уйдет не то письмо в "спам", его можно посмотреть в этой папке, типа проверка не повредит, всего лишь 1-2 секунды =).

В программе также присутствуют черный список и белый, письма с адресом из черного списка - отходят сразу в спам, а письма с адресом из белого - сразу пропускаются. Имеется и функция авто-белый список, которая автоматом добавляет письма и в следующий раз проверять на серверах с релеями не будет.

Еще один плюс программы - это то, что она поддерживает плагины, т.е. может использовать другие методы сортировки спама, за плагинами валим на официальный сайт. Советую Bayesian попробовать.

Единственный минус способа - письма все равно будут загружены на комп, т.е. тем, кому дорог трафик, желательно выбрать альтернативный способ. Мне очень понравилась программа 7way Email Checker (www.start7way.com), она не закачивает письма на комп и использует другие способы фильтрации спама (их достаточно). Также, если ты имеешь шелл, можешь купить систему по отфильтровке спама от дяди Касперского, и вся твоя почта будет проходит сначала через спам-контроль, а остатки пойдут к тебе. К примеру, как на http://www.spamtest.ru/.

ВИРУСЫ

Какой сейчас самый популярный антивирус? AVP? Ага, вот его и будем совмещать, правда тебе понадобится AVP Personal Pro 4.0 и Business Optimal версии 3.5.9.0. После установки AVP заходи в Бате в "Свойства"=>"Антивирусная Защита". Там добавляй AVP и там же отмечай все галочки, а действие можешь выбрать из пяти предложенных. "Переместить в папку "Карантин"" - помещает в папку (если она не создана, The Bat ее сам создаст), я советую именно этот способ =).


Спецвыпуск Xakep, номер #031, стр. 031-060-3, The Bat под лупой. Наводим порядок в почтовике

The Bat под лупой. Наводим порядок в почтовике

ManderX

Спецвыпуск Xakep, номер #031, стр. 031-060-3

FINISH!

Я не затронул в статье тему бэкапа лишь потому, что достаточно скачать специальную тулзу по бекапу, которая все сжимает в один файл и пишет на болванку за 20 минут. Теперь можешь спокойно идти спать, все будет сухо. А завтра за 5 минут получишь все новости мира, железа, софта и т.д., но ничего больше! И быть тебе самым информативным челом на этом свете=)!


Спецвыпуск Xakep, номер #031, стр. 031-062-1, МЫЛО ДЛЯ ПИНГВИНА! Обзор почтовых софтин под ОС Linux

МЫЛО ДЛЯ ПИНГВИНА! Обзор почтовых софтин под ОС Linux

Vint(vint@townnet.ru)

Спецвыпуск Xakep, номер #031, стр. 031-062-1

Приветствую! Вот, наконец ты решил испытать в действии столь волнующую и непонятную операционку, как Linux. Я помогу тебе войти в мир опен сорцев! Для этого я расскажу о почтовых программах, которые бывают под Линухом. Знай, их самое большое отличие от виндосовских мыльниц - бесплатность и доступность исходников! И если у тебя прямые руки? ты сможешь сам создать себе суперхакерскую мыльницу твоей мечты! В путь, да пребудет с нами великий Дзен!

В мой обзор попали следующие представители рода мыльниц: KMail, Balsa, Mozilla mail, Evolution, Spruce, mutt. Все они были поставлены с трехдискового дистра от Мандрейк девятой версии.

KMail (www.kmail.kde.org)

Начну обзор с самой простой и удобной программульки - KMail. Она является стандартной мыльницей и устанавливается вместе с KDE (если включена опция "сетевой компьютер"). Для запуска KMail в консоли набери kmail, если появились проблемы, доустанови эту программу. Так... Что имеем? Интерфейс достаточно простой, напоминает аутглюк, но, в отличие от мелкософтовского собрата, эта мыльница сделана на совесть! А сейчас я перечислю основные ее возможности: русский фейс - это очень облегчит настройку и комфортную работу новичкам. Возможность сортировки - эта софтина написана в лучших традициях сортировочного офиса. Может раскидывать письма по папкам, цепляясь за тему, отправителя, получателя, за майл-лист, размер, копию, скрытую копию. То есть ты можешь отсортировать свои мессаги с помощью любых полей. Удобство, безусловно, понятие субъективное, но мне этот почтовик кажется наиболее удобным из всего обзора, и поэтому я юзаю именно его. Фейс его также очень легко настраивается: юзер может выбрать шрифты и темы оформления. Скорость работы этого почтовика тоже впечатляет. Если бат около полутора секунд открывает папку, в которой лежит порядка 400 писем, то эта софтина делает то же самое за доли секунды! Также среди плюсов этого почтовика можно отметить удаление писем на сервере сразу после получения, то есть как только клиент получил первое письмо, он его сразу же на серванте прибьет, в отличие от аутглюка, который в случае обрыва связи качает все с нуля. Если уж говорить о его функциональности, то нельзя не упомянуть поддержку шифрования PGP или GPG, реализованные протоколы передачи почты SMTP, POP3 и IMAP, многопрофильность, поддержку множества почтовых ящиков, возможность переключения кодировок двумя кликами хвостатого создания, возможность автоматического добавления подписей в зависимости от профиля. Обновляется этот клиент периодически, в каждом свежем релизе KDE, а если тебе надо самую последнюю версию, домашняя страничка тебя ждет.

Простота в использовании и настройке, функциональность этого клиента, конечно, подкупают, но в бочке меда есть и ложка нефтепродуктов - слабоватые шаблоны, Бат по шаблонам пока впереди этой софтины. А так это единственный замеченный мною недостаток, и посему эту мыльницу советую всем!

Mozila Mail(www.mozilla.org)

Этот почтовик является плагином к хорошо известному браузеру Mozila, причем достаточно хорошо сколоченным плагином. Запустив этот мыльник, мы видим интерфейс, напоминающий виндосовского мышонка: те же папки, те же окна, но гораздо меньше настроек :(. В моем случае рука русификатора не добралась до исходников этой программки, и я лицезрею фейс на буржуйском языке. Перечислим основные плюсы этого мыльного станка. Мы имеем: фильтровалку, причем достаточно мощную; сортировалку и поиск писем, которые есть почти у всех клиентов; понятный гуй (графический интерфейс пользователя, а не то, что ты подумал :)), разобраться в котором не составило большого труда; поддержку основных протоколов; грамотный автоопределитель кодировки с поддержкой русской раскладки; автопросмотр HTML; простота в настройке, возможность установки 5 различных приоритетов для мессаги, в то время как у аутглюка их только 3. Включена возможность шифровки сообщений. Можно творить HTML-письма во встроенном редакторе. Таковы основные плюсы сего плагина.


Спецвыпуск Xakep, номер #031, стр. 031-062-2, МЫЛО ДЛЯ ПИНГВИНА! Обзор почтовых софтин под ОС Linux

МЫЛО ДЛЯ ПИНГВИНА! Обзор почтовых софтин под ОС Linux

Vint(vint@townnet.ru)

Спецвыпуск Xakep, номер #031, стр. 031-062-2

Я бы посоветовал этот клиент всем, кому нравится браузер Mozilla, и тем, кто любит простоту и функциональность, а также тем, кто привык к Бату.

Balsa(www.balsa.net)

При запуске этой программульки в первый раз нас услужливо встречает настройщик! Ну прямо полный виндовс с его визардами! Придется ответить на несколько интересующих его вопросов о твоем мыльном аккаунте. Фейс у софтины, мягко говоря, простой, тут тебе нет ни иконок, ни пимпочек, ни других украшалок. Также удивляет непонимание русского языка в дефолтном исполнении (исправляется бага выбором шрифта с мелкософтовской кодировкой на вкладе Свойства/Настройка/Дисплей/Шрифты). Также не обнаружена сортировка писем, а это большой минус! Но есть и положительные моменты: поддержка проверки правописания (при установленном дополнительном модуле Ispell), возможность работы с адресной книгой, юзер может выбирать цвета мессаг. Имеется возможность добавлять дополнительные кнопочки на панель.

По всем характеристикам эта программулька ориентирована на начинающего пользователя Интернета: отсутствие тонких настроек, возможности шифрования и подписывания мессаг, сортировки писем, но зато наличие помощника настройки клиента и простой фейс. Советую использовать эту программку только тогда, когда ты очень сильно не хочешь возиться в настройках.

Spruce

Этот почтовик тоже плохо настроен по дефолту - русификация проведена, но шрифты не установлены :(. Интерфейс у нее несложный - интуитивно понятные кнопочки и иконки делают свое дело. Возможностей не так уж много: сортировка, работа с несколькими ящиками, поддержка всех основных протоколов. Особых заслуг, к несчастью, не выявлено, и поэтому я не смею тебе рекомендовать сей софт. Конечно, ты можешь поставить софтинку для проверки, а затем снести за ненадобностью.

Evolution

Это не просто мыльница, это целый органайзер, очень-очень похожий на аутглюк экспресс из офиса дяди Билла, и поэтому бывшие юзеры сего недоразумения смогут легко пересесть на Evolution. Сразу хочется отметить то, что продукт русифицирован. Меню и кнопки переведены, но по дефолту шрифт глючит :(. Мне этот клиент не понравился по многим параметрам: очень большой гем при настройке кириллицы, медленная работа с почтовыми серверами, размер вообще уводит в аут! Блин! Я хотел мыльницу, а получил всякой лажи на 25 мегов! Долгий запуск, ограниченность возможностей (понравились только фильтры), отсутствие грамотных шаблонов... Юзать рекомендую только тем, кто не знает KMail и жить не может без аутглюка :).


Спецвыпуск Xakep, номер #031, стр. 031-062-3, МЫЛО ДЛЯ ПИНГВИНА! Обзор почтовых софтин под ОС Linux

МЫЛО ДЛЯ ПИНГВИНА! Обзор почтовых софтин под ОС Linux

Vint(vint@townnet.ru)

Спецвыпуск Xakep, номер #031, стр. 031-062-3

Mutt(www.mutt.org)

Эта программа написана полнейшим дзенствующим линуксоидом; если хочешь убедиться, то поставь ее и набей в консоли волшебное слово mutt, и ты познаешь всю глубину моей правоты :)! Эта прога особенная: она консольная, но имеет цветной текстовой фейс и не имеет поддержки мышки. Но ведь она и делалась для самых аскетичных челов, и поэтому может работать даже на 386-й тачке. Радует то, что прога русифицирована достаточно грамотно и не имеет таких больших траблов с кириллицей, как предыдущая мыльница. Уже включена поддержка PGP, множество настроек удовлетворят даже самого серьезного никсоида. Аналогов в Виндах я не встречал, возможно потому, что их нет :). Протоколы она держит будь здоров - все мыслимые и немыслимые протоколы включены по дефолту. И еще один большой плюс проги - она может без проблем работать с почтовыми базами других линуховых софтин. Я считаю, что эта программа не для широкого круга юзеров, но она точно для тебя, если нужно максимальное быстродействие (вся работа проходит в консоли, и посему нет тормозов при чтении и открытии писем, да и сама софтина стартует за одну секунду). А вообще эта софтина вызывает сильнейшую ностальгию: у кого-то по дяде юниксу, а у кого-то по тете Дос.

БЕРЕГИ БАЗУ СМОЛОДУ!

Заканчивая эту статью, хочу коснуться сохранности базы с твоими мессагами. Если ты правильно разбил диск, то у тебя, как минимум, два линуксовских раздела: / и home; так вот, все почтовики хранят свои сообщения на разделе home, и поэтому, переставив Линух, ты снова сможешь лицезреть свои мессаги полугодовой давности!

Все твои мессаги Линь хранит на винте, в твоем каталоге (кто не знает - /home/имя юзера/mail), у меня, например, все обмылки лежат в папке /home/vint/mail. Зайдя в эту папку, ты увидишь такую картину: там лежат подпапки, с именами соответствующие твоим папкам в Kmail. Вот в этих папках, в частности в каталоге cur, и лежат твои мессаги. Самое интересное, что если они не зашифрованы, то ты их даже можешь прочитать без мыльницы! Просто забегаешь в этот каталог и жмешь F3, если живешь в MC, либо открываешь с помощью браузера/редактора, если юзаешь иксы. Так что ты можешь смотреть и изучать не только свои мессаги, главное - получить доступ к папкам с письмами юзверя. А настройки хранятся глубоко... Откапать их непросто:(. Но если ты сохранишь папку /home/имя юзера, то тебе не придется каждый раз перенастраивать мыльник! Все мыльницы хранят свои настройки вместе с файлами общей конфигурации в этой папке, так что береги ее как зеницу ока! К несчастью импорт и экспорт почтовых баз в линуксовских почтовиках налажен предельно слабо :(. Я видел нечто подобное только в Мозилле.


Спецвыпуск Xakep, номер #031, стр. 031-062-4, МЫЛО ДЛЯ ПИНГВИНА! Обзор почтовых софтин под ОС Linux

МЫЛО ДЛЯ ПИНГВИНА! Обзор почтовых софтин под ОС Linux

Vint(vint@townnet.ru)

Спецвыпуск Xakep, номер #031, стр. 031-062-4

Я описал самые известные софтины, тебе решать, какой из них ты отдашь предпочтение, но мой тебе совет - ставь и настраивай KMail, и ты поймешь, что стандартная софтина может быть лучшей софтиной :)!


Спецвыпуск Xakep, номер #031, стр. 031-064-1, ПЕРСОНАЛЬНЫЙ ЛУВР графические вьюверы под Вынь, ДОС и Линух

ПЕРСОНАЛЬНЫЙ ЛУВР графические вьюверы под Вынь, ДОС и Линух

Matt Gophph & SergeS

Спецвыпуск Xakep, номер #031, стр. 031-064-1

(matt@nm.ru) & (serges@ua.fm)

У тебя есть цифровуха? Или ты сканеришь фотопленку? А может, просто любишь статическую порнушку полистать? Ну, тогда без вьювера никуда!

А для большего удобства и эффективности под каждой осью надо иметь хотя бы по одной смотрелке, чтоб при релаксации не ребутиться. Низкий старт... Марш!

ВЫНЬ

У Винды, конечно, есть врожденная "программа просмотра изображений и факсов" и paint. Но для серьезных культурно-массовых разглядываний картинок эти телеги мало подходят. Так что врубай flashget и готовься качать...

ACDSee Classic 2.43

(http://www.acdsystems.com)

Этот ветеран до сих пор висит у меня в quick launch'е. Быстрый запуск, поддержка основных файловых форматов, конвертер в bmp, jpeg, tiff, pcx, tga - для повседневных нужд, имхо, достаточно :). А еще работа с тумбнейлами, закладки, генератор списков и мощная настройка. Это именно - и только - графический просмотрщик: никаких тебе wav, mp3. От файлового менеджера acdsee2.43 досталось только копирование, перемещение, удаление :-Е и массовое переименование.

ACDSee 5.0

(http://www.acdsystems.com)

А вот что со старым добрым ACDSee 2.41 сделала научно-техническая революция. Этот клиент дружит со многими цифровухами, понимает порядка 50 графических форматов+пдф и флешки при наличии плагина. В стандартной комплектации идут конвертер в 11 форматов, архиватор и декодеры аудио/видео (mp3, wav, m3u, avi, mpeg, mov и еще около 30 форматов). Единственный баг видео - в полноэкранном режиме картинка непропорционально растягивается на размер экрана - серьезное препятствие для просмотра фильмов. Если ты фанат (не путать с блюстителем!) порядка, нет проблем - альбомы, категории, закладки и прочие организационные финтефлюшечки в наличии и под заказ. В нагрузку к этому просмотрщику-проигрывателю-архиватору-файловому менеджеру (ничего не забыл?) прилагается утиль, называемый FotoCanvas Lite, выполняющий любые работы по коррекции цвета, поворотам, замене "красных глаз" на любые другие (прям окулист какой-то!) и фильтрации картинки - этакий Advanced Microsoft Photo Editor. И весит всего-то 10 метров.

XnView for Windows 1.50.01

(http://www.xnview.com)

Читает более 400 файловых форматов, включая векторные cdr, ai и т.д. (вернее, интегрированные в них превьюхи), конвертит - в 50 форматов. 75% из них, по-моему, занесены в красную книгу и в реальной жизни не встречаются. С помощью виндозных компонентов xnview читает аудио и видео, умеет принтскринить, показывает файл в hex-формате, работает с плагинами. На этом преимущества заканчиваются :(. Полноэкранный режим не предусмотрен, видео идет с большими проблемами (я ж сказал: "через виндозные компоненты"), некоторые фишки не работают, да и вообще баги просматриваются. Рецензия такова: мощное начало, а вот конец подкачал :(. Ну, мы к нему еще вернемся...

IrfanView 3.80

(http://www.irfanview.com)

Это что-то типа логического "and" предыдущих двух пациентов. Видео идет через мелкософтно-виндозный Active Movie без полноэкранного режима, флешки и некоторые другие форматы вьюверятся с помощью самостоятельно докачиваемых плагинов. Умеет InfanView выковыривать иконки из exe-шников и dll-ек. Оригинально решен вопрос с деревом каталогов и файл-листом - они здесь попросту отсутствуют. Все вопросы решаются непосредственно: хочешь открыть файл - жми "открыть" и выбирай. Навигация по папке, правда, осуществляется пробелом/бэкспейсом. На том спасибо ;). Для просмотра тумбнейлов присутствует отдельный модуль с возможностью генерации хтмл-ей и деревом каталогов.


Спецвыпуск Xakep, номер #031, стр. 031-064-2, ПЕРСОНАЛЬНЫЙ ЛУВР графические вьюверы под Вынь, ДОС и Линух

ПЕРСОНАЛЬНЫЙ ЛУВР графические вьюверы под Вынь, ДОС и Линух

Matt Gophph & SergeS

Спецвыпуск Xakep, номер #031, стр. 031-064-2

Но это все мелочи... Зато в InfanView есть мощнейший инструмент по организации слайдшоу. Вся его мощь заключается в умении создавать из них exe-шки и скрин-сейверы с настраиваемыми параметрами. Больше такого ни под Линь, ни под ДОС никто не делает. Только линуховский compupic заставки из картинок мутит. Но это жалкое подобие ;). Ну и, как уже повелось, в infanview имеется десяток фильтров и пара фич для примитивного редактирования картинок плюс 12 форматов для экспорта.

Internet Explorer 6.0

(http://www.microsoft.com)

Последняя маздайная прога, о которой я хочу поведать, - некий малораспространенный и в грязь раздавленный Оперой броузер Internet Explorer, в народе просто "ослик". Его преимущества: наличие на любом компе, поддержка основных графических форматов, плюс флешки, pdf-ы и прочая братия через плагины.

ДОС

В ДОС мелкософт не успел засунуть ни один просмотрщик, поэтому не испорченные "программой просмотра изображений и факсов" мозги должны спокойно и с радостью принимать новшества. Хотя уже, наверное, старчества...

Sea 1.3

(http://www.photodex.com)

Когда деревья были большими, acdsee еще не придумали, а вся порнуха была в картинках, каждый уважающий себя онан... компьютерщик имел на своем винте sea. Тогда поддержки bmp, gif, jpeg, tiff и еще десятка наиболее распространенных форматов было вполне достаточно. А еще sea играл и играет wav-ки, анимированные gif-ы и avi-шки без divX. Кроме того, Sea конвертит файлы в те же форматы, что и читает, показывает слайдшоу и умеет генерить альбомы с тумбанейлами. А также занимается цветовой коррекцией, поворотами и фильтрами. Чем не acdsee?

PictView 1.92

(http://www.pictview.com)

Здесь тоже все в порядке с анимированными gif-ами и всеми видами jpg-ов. Видео и звук не поддерживаются, зато читаются превьюхи cdr-ов (правда, только старых версий). Одно неудобство - просмотр только в полноэкранном режиме, то есть файлы и собственно картинки отображаются в разных экранах. Но это все равно удобней, чем IrfanView ;). Как водится, имеется конвертер в 14 форматов и тривиальный редактор c фильтрами и разного рода переворотами. А вообще, все удобно и приятно.

QuickView 2.51

(http://multimediaware.com/qv/)

Малыш qv (софтинка состоит только из одного ехе-шника и занимает всего 376 Кб на винте) подарит вторую жизнь твоему средневековому раритетному другу и превратит его в домашний кинотеатр - он пойдет даже на 386-м звере, дай только ДОС или, на крайняк, какой-нибудь Вынь да крапаль свободной рамы. Прога, кроме множества графических форматов, в том числе .bmp, .gif, .jpg, .pcx (плюс все от них произошедшие), поддерживает еще и полноценный просмотр фильмов, и прослушивание музыки. Главная фишка этого вьювера - быстрота работы: движок по декодированию jpeg-ов до предела оптимизирован - qv.exe открывает любые имаги существенно быстрее не только своих досовских собратьев, но даже таких виндозных гигантов, как ACDSee. Отдельный бонус quickview за поддержку самых разнообразных видеоформатов. Никаких вопросов с avi-шками, divX-ами и МАСовскими mov-ами даже на 2-м пне (это когда у соседа последняя порнушка тормозит на П4 :). Ну, об этом отдельная статья. Конечно, никаких графических фильтров и возможностей конвертировать из одного формата в другой. Ну и хакер с ними ;).


Спецвыпуск Xakep, номер #031, стр. 031-064-3, ПЕРСОНАЛЬНЫЙ ЛУВР графические вьюверы под Вынь, ДОС и Линух

ПЕРСОНАЛЬНЫЙ ЛУВР графические вьюверы под Вынь, ДОС и Линух

Matt Gophph & SergeS

Спецвыпуск Xakep, номер #031, стр. 031-064-3

ЛИНУХ

Просмотрщиков графики под Линух, впрочем, как и самих версий оси, в несколько раз больше, чем маздайных аналогов. К тому же многие выньдовские вьюверы - это лишь порты популярных линуховских собратьев. А некоторые гуру поговаривают, что и сам Вынь когда-то был портирован Биллом Гейтсом с Линуха и бессовестно выдан за свою ось :). Так что если ты решил начать свое существование под этой осью, то советую запастись парой-тройкой надежных вьюверов графики под линь.

Большинство прог распространяется в виде rpm-пакетов, поэтому, чтобы поставить вьювер, тебе достаточно набрать в консоли: rpm --install <имя пакета>, rpm - это стандартный установщик для Линь. Ну, скорее всего, это ты и без меня знаешь ;).

Все проги тестировались под Red Hat Linux 8.0, но большинство из них существует в версиях и под Mandrake, и под другие.

Итак, самые популярные линуховские вьюверы по порядку.

CompuPic 5.1

(http://www.photodex.com)

Это один из лучших просмотрщиков под Линь - разработка компании PhotoDex (та самая, которая досовский Sea сколотила). Ребята постарались и в этот раз - прога вышла удобная и быстрая, да и весь джентльменский набор фич присутствует. Для удобного серфинга по своему винту в проге есть браузер (кстати, самый быстрый из всех) с режимом thumbnail preview. Среди 45 поддерживаемых мультимедиа форматов ты найдешь все необходимое - bmp, gif, png, jpeg, tiff и прочие. Все это добро можно конвертить из одного формата в другой, причем не только поодиночке, но и оптом, используя фичу Batch Conversion. В софтине есть и встроенный энхансер (утилита для изменения яркости, четкости или цветности и вставки текстовых подписей). А если ты решил разместить коллекцию имаг на своем хомяке в Интернете, то в CompuPic имеются неплохой генератор HTML-каталогов и автоматизированная утилита для последующей заливки его на один из веб-альбомов - fotki.com, ofoto.com, fotoisland.com.

Из уникальных фич в проге есть возможность просматривать в одном окне сразу все дерево каталогов (например, все графическое содержимое диска С) - применяется в основном для поиска спрятанного старшим братом (или младшим сыном) ххх-содержимого и последующего просмотра в режиме слайдшоу :). Ни под Виндой, ни под Досом я такого не нашел.

Вывод: сделано практично и функционально, больше всего подходит для ежедневного использования.


Спецвыпуск Xakep, номер #031, стр. 031-064-4, ПЕРСОНАЛЬНЫЙ ЛУВР графические вьюверы под Вынь, ДОС и Линух

ПЕРСОНАЛЬНЫЙ ЛУВР графические вьюверы под Вынь, ДОС и Линух

Matt Gophph & SergeS

Спецвыпуск Xakep, номер #031, стр. 031-064-4

XnView 1.50

(http://www.xnview.com)

В принципе, то же самое, что и под Вынь. Настоящий "монстр" графики от французских друзей, причем еще и абсолютно бесплатный - никаких заморочливых окошек с регистрацией, а только радующая глаз настоящего линуксоида надпись freeware в about. Вообще-то, прога портирована почти для всех существующих осей. Мощнейший движок просмотрщика поддерживает более 400 форматов (где-то я эту цифру уже видел...) - начиная со стандартного выньдовского bmp и заканчивая такой экзотикой, как xcf - Gimp bitmap (аналог photoshop-а под Линь) или wad-файлами с текстурами любимой Кваки и Контры, полный список которых можешь посмотреть в info->available formats, причем во многие из них XnView может конвертировать. В наличии имеется и thumbnail-браузер, который, правда, некорректно отображает кириллические названия, и набор основных графических фильтров - blur, enhance, noise.

Может пригодиться и захватчик экрана (кстати, все скриншоты к статье делались им). Один серьезный минус проги - слишком уж большая заторможенность браузера и вьювера - каталог из сотни картинок открывался секунд 8-10. Похоже, xnview просто перебирает все форматы перед тем, как открыть картинку.

Вывод: немного неуклюжий, но с энциклопедическим знанием графики вьювер (ну чем не XnView for Windows?). Если понимание кучи форматов для тебя решающий момент, XnView - то, что тебе нужно.

Gqview

http://gqview.sourceforge.net/

Поклонникам ГНОМа посвящается! Эта прога может претендовать на звание "настольного вьювера" для каждого линуксоида-гнома, но даже если ты себя таковым не считаешь, все равно есть маза потестить Gqview. Прога оснащена быстрым просмотрщиком и браузером, которые, кстати, для работы юзают GTK 1.2.0 (The Gimp Tool kit) - библиотеки мощного линуховского редактора - и поэтому читают те же форматы, что и сам Гимп. Но главная фишка проги - это поиск дубликатов имаг (под Винду это почти все умеют) - Gqview ищет идентичные имаги по имени, размеру, дате изменения и даже по содержанию картинки. Одним словом - неплохая прога для наведения порядка среди своих имагов.

Gvenview

(http://gwenview.sourceforge.net/)

Неплохая прога для просмотра основных форматов графики, но, к сожалению, на этом ее возможности и ограничиваются. Здесь нет ни фильтров, ни составления html-каталогов, зато есть красивый КДЕ-шный дизигн, шустрый браузер и режим слайдшоу. В общем, сделанный для непритязательных юзверей Gvenview подходит, в основном, для управления коллекцией.

Konqueror

Думаешь, браузеры сделаны только для того, чтобы по порносайтам лазить? Оказывается, некоторые экземпляры неплохо справляются и с лазаньем по собственному винту. Например, Konqueror - стандартный браузер и файловый менеджер для КДЕ - может составить конкуренцию некоторым специализированным просмотрщикам, ведь у него в режиме thumbnail видны не только имаги, но и HTML страницы, и музло. Конечно, многообразием форматов ему не похвастаться (в мануале скромными маленькими буквами перечислено: bmp, jpeg, png, mng и gif), но удобство в использовании и полная интеграция с осью и сетью тебе гарантируются. Konqueror так же легко, как с винтом, работает и с ftp-шником.


Спецвыпуск Xakep, номер #031, стр. 031-064-5, ПЕРСОНАЛЬНЫЙ ЛУВР графические вьюверы под Вынь, ДОС и Линух

ПЕРСОНАЛЬНЫЙ ЛУВР графические вьюверы под Вынь, ДОС и Линух

Matt Gophph & SergeS

Спецвыпуск Xakep, номер #031, стр. 031-064-5

На этом наша экскурсия по разноплатформенным вьюверам подошла к концу. Пальму первенства, похоже, удерживает (разочарование на лицах, у женщин - слезы) Маздай, ему на пятки наступает Линь и где-то в з... на 3-м месте - старый добрый ДОС. А вообще, смотри табличку и решай сам! И на будущее: приятного просмотра!


Спецвыпуск Xakep, номер #031, стр. 031-068-1, МУЗОН И WINDOWS: чтобы скучно не было

МУЗОН И WINDOWS: чтобы скучно не было

Леха ББ aka Alexys

Спецвыпуск Xakep, номер #031, стр. 031-068-1

(alex-sun@mtu.ru)

Просто сидеть втихаря перед компом - очень скучное занятие. Даже если комп у тебя супер-пупер навороченный. Намного приятнее, когда из колоночек раздается приятная для слуха и подходящая под настроение музыка, ради которой не придется пихать в сидюк очередной диск. Вот еще глупости - сидюк забивать! Можно, конечно, рядышком поставить магнитофон и постоянно совать туда кассеты или диски, но это как-то попсово и неудобно. Оставим это для чайников. Настоящие любители музыки были просто на седьмом небе от счастья после появления формата mp3 (MPEG LAYER 3) и хардов больших размеров, которые позволили держать всегда под рукой большую коллекцию музыки.

MPEG LAYER 3

Именно так называется полностью полюбившийся многим формат mp3. Повсюду продается такое количество mp3-дисков, что иной раз думаешь, а покупает ли до сих пор кто-нибудь обычные аудиодиски? Я тебе отвечу, что покупают. Бесспорно, намного дешевле купить mp3-шник с кучей альбомов исполнителя, чем вместо этого разорять кошелек на 5 или более дисков. Но если бы музон на таких дисках всегда звучал бы хорошо... Часто бывает, что качество звука оставляет желать лучшего. И вот почему. MP3 - формат сжатия аудиоинформации. Несжатый пятиминутный трек с частотой дискретизации 44.1 кГц (как на CD) будет занимать порядка 45 метров. Немного накладно под музон столько места отводить, особенно тем, у кого харды не резиновые. А качать такой музон в Инете по диалапу - вообще охренеть можно. А вот сжатый музон при вполне слушабельном качестве будет занимать раз в 10 меньше. Только надо помнить, что сжатие музыки происходит с потерей качества. Компрессия основана на урезании некоторых частотных составляющих саунда, которые не слышны человеческим ухом совсем или почти не слышны. Это не относится к дирижерам оркестров и людей с очень чутким музыкальным слухом - о них отдельный разговор. Создано довольно много кодеков (программ для сжатия звука), и у каждого есть свои особенности. Не все они сжимают звук одинаково хорошо. Некоторые так закомпрессируют wav'ку, что слушать ее потом станет просто невозможно - будет слышен свист, звук станет глухим, как будто сидишь в банке. Помни, что сжатый в mp3 или любой другой формат аудиофайл перестает быть самим собой. Зачастую даже человек со средним слухом может определить, что играет сжатый файл (лично я в 90% случаев определяю правильно).

СТЕПЕНЬ СЖАТИЯ И КАЧЕСТВО

Как в архиваторах есть степень сжатия, так в формате mp3 есть так называемый битрейт (bitrate), по значению которого можно сделать предположение о качестве mp3'шки и ее размере. Битрейт означает среднее количество битов, которые будут использованы при передаче звуковому потоку за 1 секунду. Измеряется битрейт в килобитах в секунду (kbps - kilobit per second).

Существует 2 основных вида битрейтов - постоянный и переменный. В достоинство постоянного я бы вынес быстроту кодирования и возможность довольно точно предположить итоговый размер файла. Широкое распространение получил битрейт 128 kbps, поскольку при нем соотношение размер/качество обычно получается довольно неплохим. Такой битрейт подходит для музыки, где звучит не много инструментов. Для более интересных по звучанию вещей потребуется более высокий битрейт. Тогда качество звука будет получше, но и увеличится размер. Выбирать трудно. Зато переменный битрейт (VBR) поможет сделать соотношение размер-качество оптимальным. Зачастую звучание песни немного различно, то есть встречаются насыщенные моменты, когда звучит много инструментов и диапазон используемых частот большой, а бывает, что звучит какой-нибудь один инструмент. Для первого случая битрейт надо брать побольше, дабы не урезать часть частот, но от этого вырастает размер файла. Для второго можно выбрать битрейт поменьше, поскольку ширина спектра звука будет узкая. Если кодировщику указан второй вариант, под текущий момент песни будет подбираться наиболее подходящий битрейт. Например, если после кодирования среднее значение переменного битрейта получилось 175 kbps'ов, то (поверь мне или сам испробуй) звучание mp3-шки с постоянным битрейтом 192 kbps отличаться не будет вообще. А ведь в размере-то будет выиграно!


Спецвыпуск Xakep, номер #031, стр. 031-068-2, МУЗОН И WINDOWS: чтобы скучно не было

МУЗОН И WINDOWS: чтобы скучно не было

Леха ББ aka Alexys

Спецвыпуск Xakep, номер #031, стр. 031-068-2

MP3-КОДЕКИ И ИХ ОСОБЕННОСТИ

В настоящее время выпущено такое количество кодировщиков mp3, что их даже примерное количество назвать затруднительно. И при этом методы кодирования (точнее, отрезания некоторых частот) отличаются друг от друга. Так, кодеком XING невозможно кодить на низких битрейтах (>128 kbps) - такой ужас получается. А вот на высоких битрейтах (>192 kbps) уже получается что-то человеческое. Но XING'ом я бы не советовал пользоваться - какой-то он не универсальный. Другое дело кодек LAME (http://www.mp3dev.org или http://lame.sourceforge.net) - настолько реально не кодирует музон ни один из mp3-кодеков. Причем как на низких, так и на высоких битрейтах. LAME'ом можно кодить музон как из командной строки, так и привязав его к grabber'у, типа Audiograbber, EAC и другим. В последнем случае можно будет сразу рипать музон с аудиодисков и кодировать их в mp3.

AUDIOGRABBER

Очень удобная, но, честно говоря, не самая лучшая программа для рипанья музона с аудиодисков (http://www.audiograbber.com-us.net). Легко встает на любую машину, изначально содержит несколько встроенных кодеков, включая LAME, только все они немного кастрированные. Так что о хорошем качестве компрессии можно не мечтать. Чтобы прицепить нормальный LAME к Audiograbber'у, нужно просто перекинуть из скачанного LAME'а библиотеку lame_enc.dll. Чтобы не париться с забиванием названий песен диска в Audiograbber'е, можно воспользоваться CDDB и получить описание диска, если в их базе такой имеется). Понятное дело, для этого надо быть подрубленным к Инету. Правда, здесь можно и попасться - при юзаньи CDDB Audiograbber может проверить валидность введенного серийника (а откуда у нас честные ключики? :)), и в случае запаливания Audiograbber больше просто так даже запустить не получится. Правда, на это дело давно свое средство имеется, так что ничего страшного не произойдет. Audiograbber - настолько простая в настройке программа, что только две ее менюшки заслуживают внимания.


Спецвыпуск Xakep, номер #031, стр. 031-068-3, МУЗОН И WINDOWS: чтобы скучно не было

МУЗОН И WINDOWS: чтобы скучно не было

Леха ББ aka Alexys

Спецвыпуск Xakep, номер #031, стр. 031-068-3

В основных настройках программы указывается формат обзывания файлов, которые получатся в результате рипанья или кодирования, куда их кидать, какой девайс будет проводить рипанье (если их несколько) и т.д. Довольно много настроек, по которым можно полазить, но это не обязательно - все нормально работает с настройками по дефолту.

В меню "параметры mp3" выбирается, какого типа файлы нужны в результате (wav, mp3, wav & mp3), использовать ли ID3-тэги, чем кодить, качество сжатия (битрейт). Единственная из дефолтовых настроек, которая приводит меня в ужас, это выбор Joint Stereo. Это что-то непонятное - где-то между стерео и моно. "Хотели как лучше, а получилось как всегда". Слушать вещи в Joint Stereo, конечно, можно, но нежелательно. Никакого объемного звучания не услышишь. Хотя если надо закодировать какую-нибудь песню, в которой звучат 1-2 инструмента + вокал, то тогда подойдет. Но в размере от этого не будет много выиграно. Лучше всегда выбирать просто Stereo.

EAC - EXACT AUDIO COPY

Exact Audio Copy, как и Audiograbber, - софтина для рипанья дисков и кодирования в mp3. Только отличается она по способам настройки и качеству рипанья, как Linux от Виндов. Нет, она не консольная, а просто ее надо раз нормально настроить. Рипанье дисков происходит на немного меньшей скорости, чем при пользовании Audiograbber'а, но только из-за того, что тут намного лучше алгоритмы проверки и исправления ошибок. Поэтому никаких лишних щелчков по ходу трека тут не появится. В принципе, настраивается софтина довольно легко и непринужденно. Но у нее есть такая особенность, как выбор не просто переменного битрейта с указанием качества, а выбор среднего битрейта. Такой метод называется ABR - Average Bitrate. Таким образом можно убить сразу двух кроликов - и выиграть в соотношении размер-качество, а заодно сделать файл того размера, который нужен. Такая проблема особенно актуальна для тех, у кого есть mp3-плееры на flash-картах маленького размера. Если хочешь кодировать mp3-шки Lame'ом, то в папку EAC'а надо будет закинуть файл lame_enc.dll, как и в случае с Audiograbber'ом. Тогда в меню Compression Options появится вкладка LAME DLL, которая расширит возможности кодирования.

В меню настройки компрессии выбираются кодек, степень сжатия, имена и расширения будущих файлов, наличие ID3-тэгов. Это, конечно, все хорошо, но самое важное находится во вкладке LAME DLL.

Во вкладке LAME DLL в поле Use VBR average bitrate надо выставить среднее значение битрейта, которое тебя устраивает. В результате получится, что битрейт mp3'шки будет прыгать около введенного размера то в большую, то в меньшую сторону. Это хорошо делать, когда уже разбираешься с необходимой компрессией на какую-либо музыку, чтобы выбирать наиболее реальное значение.

Кроме кодирования в mp3, EAC может кодировать во все что угодно. Главное, чтобы у тебя имелись нужные тебе кодеки. EAC их сам найдет, а тебе останется только выбрать нужный.


Спецвыпуск Xakep, номер #031, стр. 031-068-4, МУЗОН И WINDOWS: чтобы скучно не было

МУЗОН И WINDOWS: чтобы скучно не было

Леха ББ aka Alexys

Спецвыпуск Xakep, номер #031, стр. 031-068-4

OGG VORBIS

Ogg (http://www.vorbis.com) - это не программа, а формат сжатия, который может быть когда-нибудь (хрен two, правда, такое произойдет, но всякое бывает :)) сможет заменить mp3. На самом деле, сжимает он намного лучше, чем mp3, меньше места занимает, но и кодируется значительно дольше. Но обойти стороной этот формат просто нельзя (может кто-нибудь поможет приподнять этот формат?).

На сайте vorbis.com лежит одна симпатичная программулька OggdropXPd для кодирования wav-ок в формат ogg. Занимает она около 800 килобайт (http://www.vorbis.com/files/1.0/windows/oggdropXPd.zip). Маленький у нее не только размер файла, но и размер интерфейсика - представляет она собой квадратик 130х130 пикселей, куда надо перетаскивать Drag'n'drop'ом wav'ки для сжатия или ogg'и для декодирования. Несмотря на свои маленькие размеры, возможностей для кастомайзинга не так уж мало.

В OggdropXPd можно выставить ABR, как и при совместном использовании EAC и LAME. Только занимают они вдвоем побольше места, чем эта одна программка, да и кодить в ogg можно с более низкими битрейтами, так что страдающим недостатком места на диске путь один - на vorbis.com.

ПЛЕЕРЫ МУЗОНА

Кодить музон - хорошее занятие. Но музон на компе ведь ценят не только за то, что его можно хранить в огромных количествах, а за удобство управления аудиоархивами при прослушивании. Поэтому производители плееров бьются за юзабилити по полной, чтобы юзеры пользовались именно их софтом. Значит, должен быть способ быстро и удобно делать компиляции (плей-лист), возможность менять внешний вид плеера, управление частотами (эквалайзер), ведение базы данных по музону и многое другое.

WINAMP

Одним из самых первых и лучших до сих пор является плеер winamp. Поддерживает почти все форматы музыкальных файлов, играет аудиодиски, декодирует сжатые файлы для дальнейшего ремастеринга. Когда-то он был даже платным, но позднее стал фриварным. Вместо продажи winamp'а была поставлена на конвейер поддержка этого продукта. Ведь в нем можно менять внешний вид (Skins), подключать различные плагины и многое другое. Причем некоторые плагины делают со звуком такие вещи, на которые способны только дорогие звуковые карты (к сожалению, не все могут себе позволить такое удовольствие).

В винампе имеется несколько вариантов сортировки плей-листа, в том числе и случайным образом, есть возможность убирать из списка удаленные или переименованные песни, генерить html-версии плей-листа (жалко, что пока ссылки на песни не делает, но распечатать его можно).

В WinAmp'е версии 3.х появилась возможность управлять базой данных по присутствующему на харде музону, что довольно удобно. Только пока сыровато все сделано: то русские ID3 тэги не понимает, то просто виснет, то вырубается без каких-либо на то оснований и т.д. Не торопись, подожди, пока доведут его до ума.

SONIQUE

Как бы разработчики соника (http://sonique.com) ни надеялись потеснить винамп, им этого не сделать. Во всяком случае, на данном этапе. А ведь это, действительно, ближайший конкурент винампа. Непонятная форма, какие-то ссылки, кнопочки, стрелочки, которые от своего количества только в заблуждение вводят. Зато есть куча ссылок на онлайновое радио, которое мало кому нужно. Очень неудобный плеер, а требования к его работе явно выше, чем для винампа.


Спецвыпуск Xakep, номер #031, стр. 031-068-5, МУЗОН И WINDOWS: чтобы скучно не было

МУЗОН И WINDOWS: чтобы скучно не было

Леха ББ aka Alexys

Спецвыпуск Xakep, номер #031, стр. 031-068-5

WINDOWS MEDIA PLAYER 9

WMP 9 будет поудобнее соника, но более требователен к системе, чем винамп. Правда, WMP и более универсальный. Он еще и видео проигрывает. Но от этого его дистрибутив разросся до 13 метров (10 для ХР). К нему, как и к винампу, можно подключать различные плагины, но добрая их половина идет за денежки, а это не есть гуд.

ПЕРЕИМЕНОВАНИЕ И ОРГАНИЗАЦИЯ MP3-ФАЙЛОВ

Бывает, что накачаешь в Инете до фига mp3'шек с именами файлов в виде набора цифр (zvuki.ru грешили этим в свое время) и потонешь в них. Но это ничего, главное, чтобы ID3-тэги были прописаны, то есть чтобы в плей-листе винампа было видно, кто поет и что поет. Но ведь в таком виде неудобно даже плей-лист делать! Значит, надо их переименовать. Но не по одному, а разом. И не руками! Для этого лезешь на сайт http://xdev.narod.ru, откуда берешь свеженькую версию программки TagScanner, скачиваешь и ставишь. Все это делается легко и непринужденно один раз :).

Работа Tagscanner'а будет понятна даже ламакам. Выбрал директорию, выбрал формат обзывания mp3'шек, нажал preview, дабы убедиться, что лажа не получится, а потом нажал Rename. Вот такая инструкция в двух словах.

Несколько сложнее будет задача сгенерить ID3-тэги из имен файлов. Такая необходимость появляется при копировании mp3'шного диска на хард. Просто не все mp3'шные диски сделаны грамотно - на многих забивают на ID3-тэги. Конечно, они не сильно нужны, если файл нормально обозван, но лучше, чтобы они были. В Tagscanner'е есть раздел Batch TAGer, в котором можно генерить ID3-тэги на основе имен файлов.

Эта процедура тянется немного дольше, чем просто переименование файлов. Ведь в этом случае происходит запись внутрь файла, а время тратится на поиск и замену содержимого. Здесь надо указать, каким знаком разделены части названия (обычно используют знак "-") и каким по счету идет название исполнителя, песни, альбома и т.д. Не забудь про наличие ID3v2-тэгов и их поддержку Tagscanner'ом - для них тоже не помешает произвести генерацию, особенно если их вообще нет.

Полезной в некоторых случаях может оказаться фишка List Maker, которая генерит список mp3'шек с их атрибутами, типа битрейт, samplerate, размер файла, длительность и т.д. Причем можно выбрать только нужные. Список может быть выдан в Excel-файле, HTML-странице и в виде файла с разделителями (csv).

ЗАБЬЕМ ИТОГИ

Кроме MP3 и OGG существует еще немало форматов, например, WMA (Windows Media Audio), RA (Real Audio), VQF (Vector Quantization) и т.д. Только вот не получилось у них так прижиться, как у mp3, в нашем мире. Хотя WMA и используют, но он настолько похож на MP3, что раскручивать аналогичный формат просто нет смысла. Real Audio используют часто для выкладывания на сайтах фрагментов мелодий в явно заниженном качестве, особенно его любят зарубежные онлайновые музыкальные магазины. Формат VQF при 80 kbps звучит как mp3-шка 128 kbps. Вот только систему это хозяйство нагружает намного больше, чем mp3, да и сжатие может очень надолго затянуться. Еще один минус VQF - уж больно мало плееров понимают этот формат, а значит, надо дополнительно качать всякие кодеки. Так что не надо лишнего гимора - музон пусть будет в mp3. Тем более что он используется не только для прослушивания музыки с компа, но и в плеере, магнитоле и т.д.


Спецвыпуск Xakep, номер #031, стр. 031-074-1, ВЫ СЛЫХАЛИ, КАК ПОЮТ ПИНГВИНЫ?..Обзор софта для музыки под *nix

ВЫ СЛЫХАЛИ, КАК ПОЮТ ПИНГВИНЫ?..Обзор софта для музыки под *nix

Vint (vint@townnet.ru)

Спецвыпуск Xakep, номер #031, стр. 031-074-1

Хаюшки! Ну что, продолжаешь изучать Линух? Сие есть гуд! Специально для тебя в этой статье я расскажу об очень важном, прямо-таки необходимом - о настройке мьюзика. Если уж ты решил переходить на *nix, то тебе надо заставить пингвина играть продвинутую музыку, иначе что заглушит домочадцев и соседей, которые будут отвлекать тебя от изучения доков и манов.

ДЖЕНТЕЛЬМЕНСКИЙ НАБОР

Сейчас мы пощупаем программульки для слушанья и рипанья музона под Линух. Я включил в обзор следующие софтины: XMMS - лучший проигрыватель музыки, имеющий фейс винампа; Noatun - полустандартный проигрыватель; Grip - программа для рипанья дисков и кодирования в mp3.

ЧТО НАМ СТОИТ МУЗ НАСТРОИТЬ!

Действительно, в Лине многое приходится настраивать ручками после инсталляции, и звук - тоже не исключение. Траблы, начиная с не определившейся звуковухи и заканчивая конфликтами с ядром, подстерегают доверчивого юзера на пути к великому Дзену. Но возрадуйся, я проведу тебя через эти круги ада с минимальными потерями. Обычно пингвин еще при инсталле видит твой звуковой девайс и ставит драйвера, причем ставит правильно. Глюки могут возникнуть только в таких ситуациях: старый дистр и новая звуковуха (лечится либо поиском более нового дистра, либо скачиванием с Инета исходников драйвера звука и компиляцией последних); твоя звуковуха (мамтеринка) оказалась крива (лечится только заталкиванием этого девайса в задний проход барыге, продавшему тебе звук). Если не получается найти дрова, можешь попробовать (но это на ТВОЙ страх и риск! никакие жалобы ни мне, ни в ][ не слать!) поставить драйверочек от схожего девайса или стандартной звуковухи.

Допустим, ты разобрался с драйвером, но звука так и нет. Плеер показывает, что играет, а музон не звучит, хотя в Винде все пашет. Не расстраивайся - все элементарно, но не все сразу догадываются :). Просто по дефолту (например, в Mandrake 8.2) звук поставлен на минимальную громкость. Фиксится сей трабл просто: запускаешь командой kmix звуковой миксер (если не пашет, поставь нужный пакетик, который идет вместе с KDE multimedia). В правом нижнем углу выскакивает иконка миксера, шлепни по ней правой кнопкой и выбери пункт "Восстановить". Дальше врубаем все ползунки на самый верх. Все, да будет звук! Но радоваться еще рано - мы настроили это только на одну сессию, и при ребуте все уйдет в дефолт. Чтобы этого не произошло, кликай «Файл->Сохранить текущий уровень как громкость по умолчанию». Теперь можешь расслабиться - колонки запоют :).

XMMS

www.xmms.org

Запустив эту софтину, я сначала подумал: "Ни фига себе! Винамп, наконец-то, портировали!" - но при ближайшем рассмотрении оказалось, что это не так. XMMS был написан независимо от Винампа и только взял от него фейс и кое-какие опции. Но, как и у многих софтин, у сего проигрывателя при первом запуске были траблы с кодировками. Правится это на вкладке «Параметры->Свойства->Шрифты» установкой шрифта с мастдайной кодировкой. Теперь твой плеер будет показывать русские буковки, а не всякую бодягу.

С траблом разобрались, теперь посмотрим, что есть и чего нет в этой софтине. Начнем с хорошего: приятный и понятный фейс - если ты юзал Винамп, перейти на xmms будет проще простого; хорошая русификация контекстных менюх, что очень радует. Грамотный эквалайзер - это еще один большой плюс этого проигрывателя. Множество поддерживаемых форматов: wav, mp3, voc, ogg, mp2, cda, midi и другие. Поддержка скинов реализована на высочайшем уровне, в чем ты можешь убедиться, посмотрев на скрин. Грамотная поддержка плагинов: я, например, сразу слил плюшечку для прослушивания аудиодисков и плагин для воспроизведения видео. Множество визуальных эффектов, причем они поставляются стандартно. Очень широкие возможности воспроизведения: по кругу, рандомом, первые n секунд, последние секунды и т.д. Особо хочу выделить возможность импортирования настроек эквалайзера из файлов Винампа. Присутствует и поддержка плей-листов, причем xmms опять же прекрасно кушает винамповые листы. Еще встроена замечательная возможность редактировать теги, что, безусловно, есть гуд, так как не нужна отдельная софтина. При всех наворотах в памяти xmms занимает очень мало места. А один плагин порадовал меня сверх меры. Это wmDiscoTux, представляющий собой сидящего пингвинчика, болтающего ногами и головой в такт музыке :). Благодаря всем этим качествам в Инете его считают лучшим музыкальным проигрывателем под Линух, переводят на множество языков, развивают и улучшают.


Спецвыпуск Xakep, номер #031, стр. 031-074-2, ВЫ СЛЫХАЛИ, КАК ПОЮТ ПИНГВИНЫ?..Обзор софта для музыки под *nix

ВЫ СЛЫХАЛИ, КАК ПОЮТ ПИНГВИНЫ?..Обзор софта для музыки под *nix

Vint (vint@townnet.ru)

Спецвыпуск Xakep, номер #031, стр. 031-074-2

Взять xmms ты можешь в Инете на сайте девелоперов либо на дисках твоего бутива (его начали уже включать в стандартную поставку). Установка не доставляет какого-либо гимора: тыкнул в рпм'ку, ввел пассворд рута и получи! Как говорится, enjoy!

NOATUN

А это уже более классическая вещь - традиционный минимализм тому подтверждение :). Но при этом софтина умудряется использовать технологию скинов, может редактировать теги во встроенном едиторе, имеет неплохой плей-лист и даже зачатки визуализации. Никаких особых наворотов не замечено, зато сей плеер может поставить каждый - он идет даже в самом минимальном комплекте. Особенно запомнился его винамповский скин (на скрине), правда, плей-лист остался стандартным.

ВСЯКО РАЗНО

Кроме обычного воспроизведения, с которым у тебя не будет проблем, в повседневной комповой жизни тебе наверняка приходится кодировать/перекодировать музыкальные файлы, грабить песенки с сидюков и т.д. Так вот, Линукс легко справляется и с этой работой! Если твой дистр состоит из 6 и более дисков, подборка дефолтного софта для работы с музыкальными файлами должна впечатлить любого виндового меломана: ты найдешь хорошие звуковые редакторы, проги для "грабления" музыки, кодировщики и декодировщики - и все это абсолютно бесплатно!

Если затронуть тему кодеков, то в моем трехдисковом Мадрейке я нашел самые лучшие и необходимые: лейм, блейд, l3enc, флак. Также стандартными являются кодеки для достаточно нового формата ogg. А если у тебя их нет, то любой сайт с софтом под Линух предложит тебе туеву хучу ссылок.

Если у тебе маленький винт, то ты, естественно, предпочитаешь не грабить диски, а проигрывать их из привода. В Линуксе с этим все ништяк - стандартный CD-проигрыватель ставится автоматом, кличет себя KsCD и имеет простой фейс (смотри на скрине). Советую сперва потестить его, а уж потом искать что-то поинтересней. В KsCD реализованы все функции стандартного виндозовского проигрывателя сидюков, кроме того, добавлена возможность получения инфы с Инета. Так что это продвинутый дефолтный плеер :). А так все стандартно: регулятор громкости, кнопки управления воспроизведением, возможность выбора произвольной дорожки и т.д. Еще ты можешь проигрывать музыкальные CD в Grip'e. Тут все то же самое, но в меньших размерах.


Спецвыпуск Xakep, номер #031, стр. 031-074-3, ВЫ СЛЫХАЛИ, КАК ПОЮТ ПИНГВИНЫ?..Обзор софта для музыки под *nix

ВЫ СЛЫХАЛИ, КАК ПОЮТ ПИНГВИНЫ?..Обзор софта для музыки под *nix

Vint (vint@townnet.ru)

Спецвыпуск Xakep, номер #031, стр. 031-074-3

РИПНЕМ!

Конечно ты, как истинный хакер, не покупаешь музыкальные диски, а берешь их у френдов да герлфрендов с целью зарипать их в mp3. В Линуксе грабли реализованы в проге Grip (говорю о ней, потому что она стандартна и есть у всех). Она проста в использовании, русифицирована, имеет хорошую скорость работы, проста и гибка в настройке, то есть плюсов предостаточно, но замыкаться на ней одной я не советую. Выбери, что тебе больше по душе, благо пингвин это позволяет, и рипай на здоровье!

ПРИПЕВ

Надеюсь, ты получил общие представления о реализации звука в Линуксе. Если тебя интересует вопрос поддержки пингвином новых технологий, то знай, что шестиканальный звук, 3D расширение, аппаратное ускорение - все это уже реализовано! Сейчас пингвин идет наравне с разработками мелкософта. Это касается системы вообще и звука в частности. Вот и все, что я хотел тебе рассказать о звуке в Линухе.


Спецвыпуск Xakep, номер #031, стр. 031-076-1, Оборачиваем ядро. Альтернативный шелл для Windows

Оборачиваем ядро. Альтернативный шелл для Windows

ManderX (forother@fromru.com)

Спецвыпуск Xakep, номер #031, стр. 031-076-1

В последнее время стали популярны программки-украшатели. К примеру, пришел я к другу, а у него стоит StyleXP + CursorXP, и он понтуется, типа, вон как красиво! А когда я посмотрел, скока это добро жрет... лучше бы не заходил я в тот день к другу =). У самого комп послабее, но красоты тоже хочется... начал искать малотребовательную к ресурсам программулю-украшалу и надыбал, но не просто украшалу, а альтернативный шелл для винды.

Для тебя не секрет, что explorer это всего лишь оболочка, окружающая ядро форточек. Так вот, shell aka оболочку можно сменить на какой-нибудь менее ресурсоемкий и в то же время достаточно красивый шелл. Неплохо бы было, если бы он был более функциональным, чем тот же експлорер. И действительно, такой шелл есть и наречен он создателем как Aston. Каковы его преимущества перед другими проектами такого рода? Перечисляю:

1. Делают его наши! Т.е. русская версия доступна, и форум поддержки на русском есть, где, кстати, отвечают быстро.

2. Занятость проектом, т.е. есть гарантия, что его не бросят =). Кстати, так получилось, что в тот же день, когда я начал писать статью про этот шелл, вышла новая версия (1.8.2), в которой была исправлена куча багов и добавлены новые фичи, рассматривать будем именно ее. И тут же хочу поблагодарить Евгенова Никиту и Егорова Николая за предоставленную версию 1.8.2 =).

3. Экономия ресурсов. Aston потребляет от 5 до 6 Mb памяти (!!!), а explorer - 25 Mb. И это только сама оболочка!!!

4. Красота =)! Посмотри на скрин: на рабочем столе можно помещать анимацию, есть два тулбара (левый и правый), которые очень полезны и могут иметь папочную структуру. Все настраивается, делается прозрачным и т.д. Для этого шелла существует очень много тем (более 200), хотя не буду врать, у Talisman-а их тоже достаточно =).

5. Можно назначать горячие клавиши на запуск чего угодно.

6. Поддержка плагинов, никто не мешает написать свои.

7. Легкость в настройке. Причем настраивать можно почти все.

8. Все, что есть у explorer: Drag&Drop (чтобы перетаскивать файлы), DDE (для правильной работы инсталляторов) и т.д.

Итак, что мы имеем: explorer + StyleXP + CursorXP + Talisman + TrueLaunchBar + WinConsole + другие приложения (достаточно написать плагин) = 5-6 Mb (столько занимает только WinConsole =)). Неплохо? Сначала мне это напомнило гиганта PowerPro (хоть это и приложение, но оно прекрасно работает и оболочкой и, кстати, занимает тоже 5 МБ =), но, как я уже отметил, Aston удивительно просто настраивается. А дальше - больше, это только краткое введение =).

GO NIGER, GO

Значит так, заходим на http://www.astonshell.com/rus/ и качаем Aston последней версии (1.8.2), там же качаем и плагины, качай все, если что, потом убрать недолго. Забыл сказать, что за это чудо требуют всего лишь 220 (вольт? =) рубликов (ламерикосам больше, не переживай =) и, как обычно, пишут в nfo-шках варез групп - "Если тебе понравилось, купи" =). Испытательный срок 30 дней. Устанавливается так же, как и любая другая софтина под вынь - тыканьем в Next. Потом тебе предложат сменить шелл, тут главное не сцы и меняй, сменить обратно всегда сможешь =). У меня была только одна проблема - появление WinConsole было забиндено на Ctrl+~, тогда как в оболочке на это же сочетание клавиш было забиндено совсем другое, пришлось убрать в Астоне, и все стало как обычно =).


Спецвыпуск Xakep, номер #031, стр. 031-076-2, Оборачиваем ядро. Альтернативный шелл для Windows

Оборачиваем ядро. Альтернативный шелл для Windows

ManderX (forother@fromru.com)

Спецвыпуск Xakep, номер #031, стр. 031-076-2

Итак, чего мы видим? На картинке: 1 - панель задач, 2 - тулбары, которые расположены слева и справа, знакомый про них сказал - "Удобные штуки, мля!", 3 - рабочий стол с анимацией на нем.

РУЛИМ

На скринах буду показывать разные темы, чтобы ты как можно лучше вник во все прелести =). Все настраивается в A-Master, а Темы настраиваются в Theme Wizard. Шелл обратно на explorer можешь поменять с помощью Shell Swapper. Найти ссылки на них ты сможешь в левом тулбаре на втором элементе (он сам раскроется).

Заходи в A-Master (Ctrl+Alt+F12), на вкладке "Конфигурация" в принципе все должно быть понятно. Если ты используешь Punto Switcher или Keyboard Ninja, то сними галочку с "Показывать индикатор раскладки клавиатуры", чтобы в SysTray их не было два. "Автозагрузка программ" - загружать ли программы, находящиеся в автозагрузке. Также там можешь выбрать, установить прогу как шелл или как прогу (так же, как и Talisman - будет загружен и explorer, и Aston, а это совсем не гуд =).

На вкладке "Панель Задач" ты можешь изменить все характеристики панели задач: от размеров и позиции до прозрачности (только для NаTах). Можешь использовать текстуры из другой темы или нарисовать свои. Кстати, в XP в стандартной оболочке есть такая фишка - скрытие неиспользуемых значков в SysTray; так вот, тут она тоже присутствует, но реализована куда лучше. На вкладке "Панель задач"=>"Systray" нажми на кнопарь "Настройка иконок в tray" и выбери те, которые должны всегда показываться, а чтобы увидеть все остальные - нажми на иконку Астона.

На вкладке "Главное меню" сможешь настроить меню "Пуск" (теперь оно уже не пуск, а главное меню =)). Советую пока оставить "&Desktop Folder", для того чтобы был доступ к старому рабочему столу.

Настройки левого тулбара и правого идентичны, поэтому рассмотрим только левый тулбар. На вкладке "Левый Тулбар" ты сможешь редактировать элементы тулбаров, т.е. добавлять и удалять. Можешь добавить две папки подряд (но не больше), тогда они буду раскрываться (на скрине таким макаром я добрался до зе бата =), выглядит очень красиво. Также доступна анимация, то есть при создании нового элемента (будь то папка или ссылка на .exe файл) можно назначить рисунок при обычном состоянии, при наведении и при нажатии, в общем, так же, как создавать кнопки во Flash-е. В подвкладках можно также настроить все характеристики, касающиеся оформления. Если поставить галочки напротив "Убирать тулбар", "Тулбар поверх всех окон", "Плавное всплытие панели", то эффекты будут не хуже, чем в XP explorer effects, панелька при наведении мыши на левую сторону будет ПЛАВНО всплывать =).

На вкладке "Рабочий стол" можно настроить все элементы (тоже анимированные). Можно запереть иконку, тогда по нажатию ничего не произойдет. Если ты скучаешь по вынь, то поставь галочку напротив "Открывать двойным щелчком" в подвкладке "Настройка". На скрине иконки на рабочем столе - появилась иллюзия KDE =).


Спецвыпуск Xakep, номер #031, стр. 031-076-3, Оборачиваем ядро. Альтернативный шелл для Windows

Оборачиваем ядро. Альтернативный шелл для Windows

ManderX (forother@fromru.com)

Спецвыпуск Xakep, номер #031, стр. 031-076-3

На вкладке "Горячие клавиши" можешь ознакомиться с уже существующими клавишами и добавить свои.

Есть еще интересный момент, на вкладке "Прочие настройки" нажми пимпу "Редактировать Tips.rc" и вставляй туда свои ориджины, то есть то, что в голову взбредет. Когда на панели задач будет пусто, то там будет видна одна из твоих гениальных мыслей =).

ПЛАГИНЫ

Все плагины, которые ты скачал, помещай в папку Plugins (без readme, конечно =). Те плагины, которые имеют расширение .plg, надо добавлять в A-Master-е во вкладке "Плагины", там ты, если что, можешь их и отключить. Те, которые имеют расширение .tbp, надо добавлять в одну из панелек, как элемент выбирай - плагин. Три tbp-плагина уже имеются, это NoteBk - NoteBook, о нем стоит сказать отдельно. Это просто рулезный плагин, до 7 закладок, с возможностью задать название, значок и пароль для шифрования (как алгоритм используется AES), режим read-only. Едем дальше, Cpu95nt - показывает загрузку проца, Zoom - увеличительное стекло. Также ClipView - вьюер буфера обмена, если это текст, то в tooltip (то, что выводится при наведение) можно увидеть весь текст.

Теперь посмотри на .plg-плагины. Если ты еще не знал, меню "Пуск" aka Главное меню поддерживается плагином, так же как и Qlaunch панель, поэтому, чтобы у тебя панель задач выглядела, как в виндоуз, включай эти плагины - Qlaunch.plg и MenuEx.plg. Целых три плагина с часами: SkinClckEx - часы, которые находятся в панели задач, XPClock - стильненькие механические передвижные часы, DCClocl - часы, встроенные в тему, тоже прикольные, такие стоят у меня =). Рекомендую TRAYAMP - для управления винампом, кнопки управления увидишь в трее; также рекомендую Pop3Wtch для просмотра почты на серваках (тоже смотри в трее). AstonCmd - похожа на WinСonsole, но все же нельзя добавлять алиасы, поэтому, пока не будет нового плагина, я буду пользоваться старой доброй WinConsole. Остальные плагины не так примечательны, поэтому попробуй их сам и не забывай, что, скачав Plugin SDK, ты сможешь разработать свои плагины.

Скажу пару слов про установку темы. После скачки темы ее надо засунуть в папочку Themes и зайти в Theme Wizard, где можно их поменять. That's all.

RESULT

Еще пару слов, внешний вид своего рабочего стола я делал так - посмотрел кучу тем, отобрал у них все самое лучшее, кое-где подправил, добавил иконок, и вуаля! Но не покажу =). Советую посмотреть темы: новую Ocean (там прикольная анимация на рабочем столе), Aqua & Daddys Aqua (MAC-и рулят), XP-Prime (красота...), также советую глянуть другие темы от Фрозззена.

Обычно я говорю - все, но в этот раз это не все, а все просто невозможно описать =).

P.S. Версия 1.8.2 жрет в два раза меньше, чем 1.8.1.


Спецвыпуск Xakep, номер #031, стр. 031-078-1, СОВМЕСТИ НЕСОВМЕСТИМОЕ. Пристальный взгляд на бут-манагеры

СОВМЕСТИ НЕСОВМЕСТИМОЕ. Пристальный взгляд на бут-манагеры

Tony

Спецвыпуск Xakep, номер #031, стр. 031-078-1

(tony@nifti.unn.ru ICQ: 165066287)

Однажды я как-то стоял у палатки, в которой торговали компактдисками, и обсуждал с одним своим знакомым какую-то чепуху, что-то вроде выращивания брюквы в условиях климата заполярья. Рядом с нами стоял мужик и пытался объяснить продавцу дисков, что он хочет установить пингвина на один компьютер с Виндузой, и если ему расскажут, как это сделать, то он купит "супердиск "Все ОС Linux на одном CD, русская и английская версии"". Продавец, в свою очередь, объяснял, что это сделать физически невозможно, потому что эти ОСи работают на разных файловых системах, которые между собой в принципе не совместимы. Вот такие милые познания, одно обладание которыми уже должно отправить человека на костер святой инквизиции. А мужика того, кстати, я отговорил от приобретения этого несчастного диска и объяснил ему, что все, что он хочет сделать, - реализуемо. Я надеюсь, твои знания (пополненные в том числе и с помощью SPEZ'а) превосходят знания этого продавца, а потому сейчас я тебе объясню, как заставить подружиться Вынь и пингвина (кстати, и не только пингвина) на одном диске.

ЧТО ТАКОЕ MBR?

Master Boot Record (основной загрузочный сектор) это область диска (а вернее его самый первый сектор), где находится маленькая программулина, загружающая из активного раздела основной загрузчик операционки. Прочитать про это ты сможешь вот здесь - http://old.pcclub.com.ua/n29/4.htm. При установке новой ОСи ее программа инсталляции затирает старый MBR (в случае Windows 9x/Me/NT) и записывает свой новый MBR. Windows 2K/XP тоже затирает старый MBR и записывает поверх него новый, но запоминает содержимое старого и конфигурируют процесс загрузки так, чтобы можно было загрузить либо свежеустановленную Вынь, либо предыдущую - старую. Таким же образом действуют программы инсталляции многих *nix систем. Например, в любом Linux есть как минимум два менеджера загрузки - lilo и grub, оба сохраняют записи о предыдущем MBR и позволяют загрузить либо пингвина, либо то, что было до него. Также они позволяют восстановить старый MBR (например, для lilo это команда lilo -U).

СТАНДАРТНЫЙ MBR - ЗА И ПРОТИВ

Теперь давай поразмышляем. Допустим, ты захотел установить несколько осей - одну для игр (98-ю Вынь), другую для работы (Windows XP), третью для души (Linux). Если в качестве MBR использовать загрузочную запись от 98-ой Выни, то ты максимум сможешь загрузить ее саму плюс пингвина (через утилиту loadlin - смотри соответствующий HOWTO); XP ты загрузить не сможешь, если, конечно, не намерен разработать собственный NT Loader. "Ладно! - скажешь ты. - Можно попытаться использовать MBR от XP". Можно, и в этом случае ты сможешь загрузить и XP, и 98-ю Вынь. Даже путем извращений можно загрузить и пингвина - для этого надо ручками подправить config.sys, добавив туда меню, а уж потом в autoexec.bat сделать goto на соответствующую метку, в которой сделать loadlin. Ну что же, это тоже вариант, но уж больно гиморный да и корявый. Разумнее использовать бут-менеджер Линуха, который позволит тебе загрузить как самого пингвина, так и все биллово отродье. Но есть минусы и у этого способа: надо разбираться с конфигурацией lilo (или grub), интерфейс выбора нужной тебе ОСи невзрачен и не приводит пришедших к тебе поглазеть друганов на сие чудо в состояние экстаза.


Спецвыпуск Xakep, номер #031, стр. 031-078-2, СОВМЕСТИ НЕСОВМЕСТИМОЕ. Пристальный взгляд на бут-манагеры

СОВМЕСТИ НЕСОВМЕСТИМОЕ. Пристальный взгляд на бут-манагеры

Tony

Спецвыпуск Xakep, номер #031, стр. 031-078-2

ПРОДВИНУТЫЙ MBR

Возможности загрузчиков сторонних производителей даже рядом не стоят с возможностями стандартных Win загрузчиков и lilo с grub. Как тебе понравится вот такая, например, фишка - автоматическое сканирование установленных операционок? Я уж не говорю про графический интерфейс менеджера с поддержкой скинов. Я расскажу тебе о двух менеджерах загрузки, возможности обоих тебя гарантированно устроят. Первый - это Acronis OS Selector. На сегодняшний день доступна версия 8.0 этой софты. Брать здесь: www.acronis.ru/products/osselector. Второй менеджер ты можешь найти здесь: www.v-com.com/product/sc7_ind.html. Это System Commander. Сейчас последняя версия этой софты - 7.05. Да, чтобы не забыть, сразу скажу, что слить отсюда можно только демонстрационные версии менеджеров, стоимость же покупки OS Selector'а равна 300 деревянных, а System Commander - 70 зеленых в том случае, если ты не являешься счастливым обладателем System Commander 2000/Deluxe или Partition Commander. В противном случае стоимость покупки уменьшается до 30 вечнозеленых. Вот что меня здесь удивляет, зачем надо покупать System Commander 7.05, если у тебя уже есть System Commander Deluxe? Впрочем, пути маркетинга неисповедимы, а нам с тобой, дружище, с буржуями не по пути...

SYSTEM COMMANDER

Из всех существующих менеджеров загрузки - это единственный в своем роде менеджер, который поддерживает скины (www.v-com.com/vui/vui_all.zip, слить, распаковать в каталог коммандера, после ребута в настройках выбрать нужный скин - вопросы есть?). Такая вот уникальная фишка от разработчиков. Времена, когда пользователя бут менеджера заставляли что-то писать ручками, создавать дискеты, прошли - программа установки спросит тебя: "Куда ты соизволишь меня установить, мой повелитель?". После чего пискнет: "Слушаюсь и повинуюсь". Настраивать тебе ничего не надо, просто перезагрузишься, коммандер сам найдет все ОСи и сконфигурирует свою работу с ними. Устанавливается из-под любой виндузы и ДОСа, может ставиться на FAT, FAT32 и NTFS партиции, может загрузить ось с любой из перечисленных файловых систем: FAT, FAT32, NTFS, HPFS, Linux Ext2, Ext3, ReiserFS. Также на сайте разработчики обещают, что "OS booting with all x86 Unix file systems", проверить не смог по понятным причинам. Список поддерживаемых операционок достаточно широк: Windows 95/98/Me, Windows NT/2000/XP, Linux, OS/2 Warp, NetWare, Solaris, other Unix variants, DOS "and all other PC compatible Oses".

После ребута появится окно коммандера, сильно смахивающее на маленькую версию Выни, управление - мыше-кнопочное. Настраивать можно кучу всяких фич: скринсейвер, пароль доступа, разрешение монитора, добавлять и удалять ОСи - в общем, все пучком. Также есть возможность запустить Partition Commander - утилиту для конфигурации дисковых партиций.


Спецвыпуск Xakep, номер #031, стр. 031-078-3, СОВМЕСТИ НЕСОВМЕСТИМОЕ. Пристальный взгляд на бут-манагеры

СОВМЕСТИ НЕСОВМЕСТИМОЕ. Пристальный взгляд на бут-манагеры

Tony

Спецвыпуск Xakep, номер #031, стр. 031-078-3

Но есть и свои подводные камни, а вернее - булыжники. Проблема номер раз - невозможность загрузить ОСь из раздела, лежащего за пределами 8 Гб. В случае Линуха проблема эта решается очень просто: создаем запись для новой Виндузы (9x или Me типа), и в autoexec.bat соответствующего каталога (после установки смотри в каталог, куда ты установил System Commander, там есть еще подкаталоги, в каждом подкаталоге лежат загрузочные файлы каждой операционки) добавляем запись loadlin. С Виндузой у тебя такой трюк не пройдет, и если она находится в партиции, лежащей за восьмигиговым пределом, то придется тебе либо искать другой бут менеджер, либо ставить ОСь в другую партицию.

Проблема номер два более жестока, правда, жестока она только по отношению к твоим друзьям, пришедшим за порцией музыки и вареза. Дело в том, что SC делает праймари разделы других дисков неактивными, ведь, действительно, активным должен быть только один раздел. SC, видите ли, в голову не приходит, что диск может быть с другой машины и что с него обычно грузятся. Лечится все очень просто - надо лишь загрузиться с чего-нибудь загрузочного, запустить fdisk и сделать партицию активной.

ACRONIS OS SELECTOR

По своим возможностям OS Selector не уступает System Commander'у, отсутствует только поддержка скинов (а оно тебе надо? ведь все равно экран манагера ты видишь пару секунд), зато имеет кучу преимуществ по сравнению с ним. Во-первых, решилась, наконец, проблема 8 Гб (в отличие от SC) - теперь ОСь может быть в любой партиции. Во-вторых, язык программы - наш великий и могучий, плюс документация и FAQ на русском же языке. Аналогично SC есть возможность управления партициями - администратор дисков, который может создавать, изменять, удалять, копировать и перемещать разделы следующих файловых систем: FAT16, FAT32, NTFS, Linux Ext2, Ext3, ReiserFS, Linux Swap. Изменять размеры кластеров на каждом разделе, преобразовывать FAT16 в FAT32 и обратно, изменять метки партиций, смотреть информацию по разделам и дискам. Редактировать с помощью встроенного редактора содержимое партиций (так, не три, плотоядно усмехаясь, свои ладошки - с этой возможностью поосторожней, по крайней мере, за своим компом... :)). Разработчики OS Selector'а обещают, что он держит все операционки, существующие на PC платформе. Вот список: DOS, Windows 3.1 + DOS, Windows 95/95OSR2/98/Me, Windows NT 3.1/3.5/3.51/4.0/2000/XP, Linux (все дистрибутивы), FreeBSD, Solaris, SCO UNIX, UNIXWARE, OS/2, BeOS, QNX, B-TRON. Есть также "специальная поддержка неизвестных систем". Стоит сказать пару слов об этой самой "специальной поддержке неизвестных систем". Хоть под рукой ничего такого и не нашлось, чтобы проверить, но, думаю, что если ты найдешь такую ОСь и установишь ее в отдельную партицию, то все будет пинцетно - OS Selector скушает загрузочный сектор этой оси, а системные файлы никто не затрет, ибо ОСь стоит на отдельной партиции. Еще одна фишка этой софты заключается в существовании MediaBuilder'a - это небольшой мастер для создания загрузочных дискет и компактов. Особое умиление вызывает следующая фраза этого мастера: "Обратите внимание, что для создания загрузочных компактдисков вам понадобится устройство для записи компактдисков" (похоже, на ламерикосов рассчитывали).


Спецвыпуск Xakep, номер #031, стр. 031-078-4, СОВМЕСТИ НЕСОВМЕСТИМОЕ. Пристальный взгляд на бут-манагеры

СОВМЕСТИ НЕСОВМЕСТИМОЕ. Пристальный взгляд на бут-манагеры

Tony

Спецвыпуск Xakep, номер #031, стр. 031-078-4

РЕЦЕПТ

Взять две помидорины, кусочек сыра, мелко его покрошить в... так, стоп, что-то меня не туда понесло. Ладно, я надеюсь, ты уже понял, что продвинутый Boot Manager это не просто круто, но и практично. Например, если у тебя есть маленький брат, который очень любит играть в сапера и стирать фотки твоих теток, ты спокойно можешь установить ему для этого развлечения его собственную Вынь на отдельный логический диск, скрыть от него все остальные диски (я забыл упомянуть про эту фишку? Ок, теперь исправился), а на другие ОСи поставить пароль. Мой тебе совет: "найди" Acronis OS Selector - это более практичная софта. Выбери операционки, которые ты хочешь себе установить, установи их все последовательно. Если у тебя все диски, с которых ты инсталлируешься, загрузочные, то проблем никаких. Если нет, сделай загрузочный флоп или возьми любой компакт, с которого можно загрузиться в DOS. Скопируй дистрибутивы осей себе на жесткий диск, установи. Последовательность установки значения не имеет, ибо у тебя есть с чего загрузиться, а MBR тебе, в конце концов, все равно менеджер перезапишет. Если ты ставишь последним Linux, то настраивай lilo (или grub) так, чтобы он устанавливался не в главную партицию, а в партицию к своей ОСи, иначе менеджер загрузок его просто снесет, и грузиться в пингвина тебе придется с дискеты, чтобы сконфигурировать lilo в нужную партицию.

Наконец, ты все установил. Теперь грузись в Вынь или ДОС, устанавливай Boot Manager, перебуться. Опа, вот и все!

Если вдруг что-нибудь с загрузкой Linux не получится, не расстраивайся. Ты всегда можешь создать в менеджере новую ось (сделай Windows 98), а в autoexec.bat этой оси добавь строчку, загружающую пингвина через loadlin, для этого, естественно, тебе нужна копия образа пингвиньего ядра, и ты должен знать, в какой партиции у тебя Linux стоит.

Еще один совет бывалого: если ты реконфигурируешь свою систему, то тебе не обязательно переустанавливать Boot Manager. Программы инсталляций разных ОCей, конечно, перезатрут MBR до дырок, но после того как ты их все установишь, просто запусти для System Commander'a файл checkmbr.exe, ну а для OS Selector - bootcfg.exe. MBR будет перезаписан, и при следующем ребуте менеджер восстановит свою работу. Ну и, наконец, если ты захочешь, чтобы две Выни работали у тебя в одной партиции, то помни, что все будет хорошо в том случае, если ты им указал разные каталоги для установки. А протекать хорошо все будет до того, как эти две оси запользуют вместе один и тот же файл из "Program Files", например, если ты под каждой из этих осей установил MS Office, причем разных версий. Так что определяйся: либо одна пуля равна одной тушке, либо в каждой оси используй свой уникальный софт.


Спецвыпуск Xakep, номер #031, стр. 031-082-1, МЯГКИЕ МЕСТА ИНЕТА-2.Еще немного сайтов про софт для windows

МЯГКИЕ МЕСТА ИНЕТА-2.Еще немного сайтов про софт для windows

Kirion (Kirion@winfo.org)

Спецвыпуск Xakep, номер #031, стр. 031-082-1

Почти полгода прошло с момента предыдущей статьи. Хватило тебе сайтов на это время? Мне не хватило :). Так что открывай свою любимую бродилку и готовься забивать свежие линки - полкy софтовых сайтов прибыло.

РЕТРОСПЕКТИВА

Но вначале коротко пройдемся по изменениям в сайтах, о которых я писал в январе. Весной очень редко выходила рассылка www.oszone.net, и я уже начал забывать об этом ресурсе. Но как-то раз перелопачивал букмарки, и что-то заставило меня заглянуть на этот сайт, и я нашел там много нового. Во-первых, у сайта изменился дизайн (не скажу, что новый дизайн супер, но все же лучше старого). А во-вторых, стало появляться хорошее наполнение. Имеются статьи про различные оси от win9x до линуха, статьи про хард и софт, различные фишки для ХР. Правда, по качеству статьи сильно отличаются друг от друга, попадается и откровенная лажа. Но главная часть сайта - это весьма и весьма большой форум. По несколько тысяч тем и ответов в каждом разделе - неплохо, да. Жаль только, что многие пользователи игнорируют раздел "Зона ламера" и лезут с вопросами куда не надо :). Что полгода назад, что сейчас - половина тем читается, как анекдот. Но что меня веселит больше всего, так это количество ответов в разделе "Флейм". Самый популярный раздел форума :). Так что Soft-Forum (www.soft-forum.ru) мне все же нравится намного больше, хотя и ответов с темами в нем меньше. Вот такой вот парадокс.

А вот изменения, произошедшие с Listsoft, меня очень порадовали. Уж не знаю, что им способствовало, но сайт начал довольно бурно развиваться. Поменялся дизайн, начали регулярно обновляться разделы статей и трюков (они же hints, они же "хозяйке на заметку"). Да и программы стали обновляться чаще (количество тоже увеличилось). Теперь все проги делятся на новые и обновившиеся. Улучшена система рейтингов. К тому же теперь на Listsoft имеется интернет-магазин (компьютерный) с весьма неплохими ценами (hardware.listsoft.ru). А вот что не очень радует - так это процедура скачивания. Раньше надо было просто смотреть рекламу несколько секунд (причем скрипт не работал у меня в опере). Сейчас надо просто пройтись по баннерам. Меня это не сильно раздражает, но ведь есть еще много серваков, где подобными глупостями заниматься не нужно. Какой выберешь ты?

А вот за Frol.ru я несколько раз сильно беспокоился. И начнешь беспокоиться, когда сайт, обновляющийся каждый день, две недели не обновляется. Вот и сейчас что-то... Но я надеюсь, что ничего страшного с ним не случится. Тем более что этот ресурс стал для меня основным поставщиком софта, особенно с учетом таких забавных разделов форума, как "WareZ & Cracks" (без комментариев) и "Exchange of files" (файлообменник, любой пользователь может залить свежие "лекарства" различного характера, плагины, скрипты, русификации, etc). А еще сильно переработан раздел "Русификаторы". Фактически это уже самостоятельный сайт, обновляющийся почти каждый день, со своим форумом (хоть и небольшим, но по делу). Не так уж и много в сети хороших сайтов с русификаторами, тем более что на frol.ru они попадают из разных мест. Хотя лучше учить английский. Могу посоветовать пару линков :). А Frol.ru желаю поменьше таких длинных перерывов с обновлением.


Спецвыпуск Xakep, номер #031, стр. 031-082-2, МЯГКИЕ МЕСТА ИНЕТА-2.Еще немного сайтов про софт для windows

МЯГКИЕ МЕСТА ИНЕТА-2.Еще немного сайтов про софт для windows

Kirion (Kirion@winfo.org)

Спецвыпуск Xakep, номер #031, стр. 031-082-2

СОФТ, И НЕ ТОЛЬКО

Ну а если тебе все еще нужны русификаторы, тогда срочно беги на www.bladezone.ru. Довольно старый, известный и необычный ресурс. Необычен он тем, что вместе с русификаторами (часто обновляющимися и очень качественными) и небольшой подборкой софта на нем присутствуют такие разделы, как: игры, юмор и даже книги. Хотя инфы в них не так много, но зато и лажи нет :). Мне, например, весьма помогли материалы по Final Fantasy с этого сайта :). Кстати, игры здесь не только для компа, но и для консолей, чего в рунете не так много. В книгах - неплохая подборка авторов фэнтези и фантастики (особенно спасибо за Маккефри). В юморе же - подборка известных и очень смешных текстов из разных источников. Тут есть "100 правил злого властелина" или "Хроники лаборатории". Засесть за чтение этого раздела можно надолго, а сотрудники офисов наверняка распечатают половину из них и повесят на стенку :). Есть даже небольшой магазин, торгующий дисками с фильмами и русификаторами. Жаль только, что регулярно обновляется только основной раздел сайта - русификаторы. Остальные разделы обновляются куда реже (некоторые не обновлялись с прошлого года) :(.

Почти в каждой статье я неустанно рекламирую Оперу :). И если ты тоже являешься поклонником этого браузера - обязательно должен зайти на www.myopera.net (хотя что это я, если ты любишь Оперу, то наверняка там был). В рунете это однозначно лучший сайт, посвященный этой бродилке и всему, что с ней связано. Русификации, патчи, новости, свежие версии. Особенно стоит отметить форум, наполнение которого даже лучше, чем на основном сайте. Но тут есть одно "но": на момент написания статьи судьба сайта была неясна. Не обновлялся он довольно давно, а на форуме запостены сообщения от авторов с размышлениями о дальнейшей судьбе сайта. Я искренне надеюсь, что все у сайта будет хорошо, ибо замены ему в настоящий момент я не знаю.

Но не будем о грустном. Не так давно появился еще один каталог софта: www.softvariant.ru. Интересно наблюдать за судьбой новых проектов. А что же получится их этого сайта? Пока что мы имеем около тысячи прог, достаточно регулярные обновления, неплохое содержание. Здесь есть даже электронные версии журнала "Хакер" :). Отдельное внимание уделено различным мелким играм, в том числе и на флэше, есть раздел для программистов: компоненты, утилиты, документация, средства разработки. В наличии раздел для веб-мастеров и дизайнеров: скрипты, гостевые книги, форумы, подручный софт и доки. Вообще же, сайт предназначен для поддержки разработчиков программ (как гордо вещает раздел "проекты"). Остается только пожелать им удачи.

После январской статьи некоторые личности намекнули мне, что я забыл про один очень хороший форум. Пришла пора исправляться :). Ты когда-нибудь был на конференциях www.ixbt.com? Сейчас ты удивленно скажешь, что это сайт про железо, и я пойму, что не был :), потому что в форуме ixbt обсуждаются очень разные вещи. Тут тебе и техническая поддержка, и драйверы, и отдельные разделы про части компа (от процев до блоков питания), мобильную связь и коммуникации. Несколько закрытых форумов для разработчиков и программистов. Ну и, кончено же, форум по программам. Разделен он на пять частей: операционные системы и системные проги, прикладной софт, проги для Инета, игры и программирование. Плохо, что разделы не отсортированы по осям: искать темы про линух в дебрях вопросов про винды не очень приятное занятие. А еще раздел по прикладному софту слабоват. Равно как и по играм. Но чему тут удивляться - посетителей ресурса интересуют более серьезные темы :). Зато ответы тут, в основном, по существу, мало флейма, взаимных обвинений, ламеров, считающих себя профи. Жаль только, что форум несет "законную" направленность. В смысле никаких кряков и вареза. А так и подмывает что-нибудь такое запостить :).


Спецвыпуск Xakep, номер #031, стр. 031-082-3, МЯГКИЕ МЕСТА ИНЕТА-2.Еще немного сайтов про софт для windows

МЯГКИЕ МЕСТА ИНЕТА-2.Еще немного сайтов про софт для windows

Kirion (Kirion@winfo.org)

Спецвыпуск Xakep, номер #031, стр. 031-082-3

Но для этого можно зайти на www.imho.ws. Этот форум является проектом трех сайтов: kpnemo.ru (о нем чуть позже), pc-zone.net.ru (и о нем тоже чуть позже) и emanual.ru (известная библиотека документации). Итак, что у нас есть на форуме. Во-первых, это раздел по софту и осям (слава Богу, линух и винды здесь отделены, иначе я бы не стал упоминать этот сайт). Во-вторых, раздел по железу, мобильным устройствам, программированию и новинкам индустрии (а вот это интересно, на форумах вижу такое в первый раз). В-третьих, мощный раздел по Инету, от дизайна и веб-программирования до советов начинающим пользователям. В-четвертых, очень веселый раздел про игры. Пятнадцать тысяч тем в разделе "Заказываем и качаем игры" - ничего так, да :). Хочу халявный выделенный канал! И в-пятых, внекомпьютерные темы: кино и музыка, женские штучки, книги (в том числе электронные), юмор, спорт. Причем тут есть обмен фильмами и музыкой (в смысле ссылками на них). А еще на форуме есть раздел "андеграунд", в котором всего две темы с более чем двадцатью тысячами ответов на каждую: "заказ прог и добавок" и "заливаем". Он находится чуть ниже :). Какая к черту аста, забудь! Форумы - вот где надо искать лекарства!

А теперь расскажу про сайты - основатели проекта. Начнем с www.pc-zone.net.ru. Это тоже форум, правда, не такой большой, как imho.ws, но довольно приятный. Ранее он находился по адресу pc-zone.net, однако теперь там висит предупреждение на английском и русском языках от Department of Justice, www.cybercrime.gov, повествующее о вреде компьютерного пиратства :). Может они и вернут себе домен, а пока не поленись и припиши еще три символа к адресу :). Первое, что бросается в глаза на сайте, - раздел флейм на самом верху страницы, да еще какой обширный! Девять тем, из них одна тестовая, одна для знакомства (так и называется "добро пожаловать") и одна ни о чем (флейм в чистом виде :)). Остальные же разделы - про книги (как художественные, так и компьютерные), юмор, разговоры про науку и технику, кино и музыку, и даже про секс. Наверное, это правильно - нормальных людей это должно интересовать больше, чем компы :). Все остальные - срочно идите ниже. Там у нас раздел Инет: почти стандартные дизайн, веб-программирование, сетевая безопасность и клоны аськи, сдобренные обсуждением сайтов, хостеров и всего Интернета в целом. Далее у нас тематические форумы (оси, железо, программирование) с довольно слабым наполнением, зато есть раздел с паролями к веселым сайтам. Специально для компьютерных маньяков :).


Спецвыпуск Xakep, номер #031, стр. 031-082-4, МЯГКИЕ МЕСТА ИНЕТА-2.Еще немного сайтов про софт для windows

МЯГКИЕ МЕСТА ИНЕТА-2.Еще немного сайтов про софт для windows

Kirion (Kirion@winfo.org)

Спецвыпуск Xakep, номер #031, стр. 031-082-4

Но нас интересует следующий раздел - варезник. Проги и лекарства, музыка и кино, заявки на это добро, ftp и варезные сайты. Музыка для ушей :). Ну и напоследок раздел про системы файлообмена: eDonkey и собственную систему файлообмена - pc-zone hub. Весьма интересное начинание, надо заметить.

Вообще, файлообменники на сайтах нынче популярны. Они появляются на многих форумах, да и просто так, в виде целых проектов. Тот же filez.nastart.ru, например, который я как-нибудь обязательно использую, как онлайновый бэкап всего моего софта :). Другое дело, что подобная деятельность вызывает трения с законодательством. Хорошо еще, что это рунет и объемы не очень большие. А то ведь позакрывают все на фиг и будут правы. А нам будет обидно.

Что-то я отвлекся, пора рассказать про www.kpnemo.ru. Хороший и часто обновляющийся варезный сайт. Что мне понравилось сразу - много ссылок на не слишком известные проги, ресурс не дублирует другие популярные сайты. И наоборот, есть ссылки на известные проги с лекарствами, которые не сразу найдешь. Естественно, имеется и раздел с музыкой, фильмами, юмором (который здесь обозвали "other" :)), и весьма оригинальный раздел - shoping. Как следует из названия, раздел рассказывает о различных компьютерных фирмах, причем рассказывает хорошо. Жаль только, что эта часть не обновляется уже больше месяца, а так, если ты не знаешь места лучше, чем Савеловский, почитай обязательно.

КЛОНИРОВАНИЕ

Кстати, ты не находишь, что в последнее время стало очень модно делать сайты, построенные по схеме: софт, кряки, ссылки, прикольная картинка, немного музыки, парочка uin'ов и умная фраза в конце. NoName популярен, и его клоны начали расти, как грибы. Странно, но большая часть таких проектов, за которыми я взялся следить, до сих пор жива (я думал - через пару месяцев кончатся), да еще и часто обновляются! А еще говорят, что клоны живут меньше, чем исходные организмы :). Правда, с оригинальностью у них туговато. Особенно весело наблюдать панель ссылок на дружественные сайты с одними и теми же адресами :). Расскажу о тех проектах, что вызвали у меня наибольший интерес.

Megido group (www.medigo.ru). Когда пару месяцев назад этот сайт исчез, я мог злобно хихикнуть: "Я же говорил". Но делать мне этого не хотелось, потому что сайт был хороший. Но ребята не сдались. Адрес сайта сменился с megido.ru на medigo.ru и начал работать с новой силой. Что мне нравится - так это ссылки на программы. Хотя описания прог часто даны на английском, зато здесь очень много неизвестных или редких софтин ("неизвестных" отнюдь не значит "плохих"). Имеется и небольшой форум. А вот отдельных разделов здесь нет - ссылки в левой части это просто фильтры. Но, может быть, это и к лучшему, что нет пачки разделов. Даже на NoName остальные разделы обновляются не так часто, что уж говорить о менее известных проектах.


Спецвыпуск Xakep, номер #031, стр. 031-082-5, МЯГКИЕ МЕСТА ИНЕТА-2.Еще немного сайтов про софт для windows

МЯГКИЕ МЕСТА ИНЕТА-2.Еще немного сайтов про софт для windows

Kirion (Kirion@winfo.org)

Спецвыпуск Xakep, номер #031, стр. 031-082-5

А вот rWeb.ru замахнулся сразу на несколько разделов. Получается, в принципе, неплохо. Очень удачной могу назвать фишку с панелью обновления. На панельке слева отображены даты последнего обновления всех разделов сайта - не нужно судорожно кликать по всем ссылкам. Оригинальность ссылок несколько хуже, но все равно много всего интересного, выпуски довольно большие. Недавно обновился дизайн, появилась форма для постинга новостей. Сделали и форум. Возможно, со временем это будет один из лучших ресурсов такого типа.

Софт-обзор (www.soft-obzor.ru) - тоже весьма приятный проект. Правда, по моему скромному мнению, с разделами они все же переборщили. Если разделы есть, они должны обновляться с определенной регулярностью. А когда идет три выпуска подряд, а потом месяц ничего не слышно - это не дело. Зачем нужны обзоры игр или драйверов, про это есть много других сайтов. А вот каталог программ - это хорошая задумка. Нужно же систематизировать софт. Да искать проще, не то что на NoName где-нибудь годик назад :).

У Netz.ru разделы получается обновлять несколько лучше. Тут их целых девять: от новостей до статей. А вот архив сделан не очень удачно. За время существования сайта вышло уже около двух сотен выпусков, а через архив можно просмотреть только новости. Остальные же разделы придется листать руками или использовать поиск. Со ссылками ситуация средней паршивости, однако я заметил, что на этот сайт часто ссылаются другие проекты. Значит, ежедневный смотр надо начинать именно с него. Тем более что здесь тоже есть маленькая панель, показывающая, какие разделы обновились, а какие нет (правда, без дат, только сам факт обновления). Ну и по доброй традиции на сайте есть форум. Это wwc.ru, о котором я рассказывал в январском номере. Моих надежд он не оправдал, хотя раздел "статьи" почитать любопытно.

ДО ВСТРЕЧИ?

Букмарки разрастаются до неприятных размеров. Пожалуй, пора перестать искать сайты с софтом. Лично я уже физически не успеваю просматривать новости, качать везде свежие проги, читать форумы и писать в них :). Хотя я уверен, что в рунете еще есть хорошие софтовые ресурсы, на которых я никогда не был. Другое дело, что мне совершенно не хочется их искать. Может через полгода? А всем авторам сайтов могу пожелать на это время стойкости, работоспособности, вдохновения и желания делать интересные и оригинальные проекты, которые будут жить долго и счастливо. И пусть о них напишут хорошо!


Спецвыпуск Xakep, номер #031, стр. 031-086-1, СЕЗОН ОХОТЫ... НА ПИНГВИНОВ. Обозреваем *nix ресурсы

СЕЗОН ОХОТЫ... НА ПИНГВИНОВ. Обозреваем *nix ресурсы

Александр Денисов aka Xander

Спецвыпуск Xakep, номер #031, стр. 031-086-1

(denissov@upv.vodokanal.spb.ru)

Куда податься в Интернете человеку, решившему начать совместную жизнь с пингвином? Нет, не на поисковик с запросом "fucking+penguins+porno" :). Имеется в виду, человек решил связаться с операционкой Linux. Ведь перед ним встает масса вопросов. Какой дистрибутив выбрать? Где его взять? Как его поставить? Что с ним потом делать? Как подключить ту или иную железку? Где найти нужную прогу? Но, как известно, у нас страна советов, а в компьютерном мире какой совет самый частый? Правильно - RTFM! Поэтому мы сейчас и пойдем искать эти самые fucking manuals.

ВЫБИРАЕМ ДИСТРИБ

Начнем с тех, кто дает информацию на великом и могучем. Но для начала ответь еще на один вопрос. Ты уже определился, какой дистрибутив собираешься покупать? Нет? Тогда тебе прямая дорога по адресу http://www.linux.org.ru/.

Монструозный проект. Ресурс обозначен как "Русская информация об ОС Linux". Этим все сказано. Здесь есть рассказ о всех линуксовых дистрибутивах, доступных к приобретению на территории бывшего СССР, их история, плюсы и минусы, ссылки на сайты разработчиков, на интернет-магазины, где их можно приобрести. Опять же есть документация, причем на русском, что не может не радовать. Обширная подборка FAQ'ов, вот лишь некоторые из них:

- RU.LINUX FAQ - знаменитый ФАК, начатый еще в '99 году, поддерживающийся и добавляемый поныне;

- Xfaq - настройка режима монитора в XFree86;

- Debian Linux FAQ;

- Book FAQ - информация о книгах про Unix/Linux на русском языке;

- Fido.FAQ - FAQ по настройке fido под Unix/Linux.

Однако одним из самых сильных впечатлений на этом сайте для меня лично стал форум. На момент написания статьи там было 156116 (именно сто пятьдесят с лишним тысяч) сообщений в нескольких тысячах тем. Вряд ли есть что-то более массивное, мне, по крайней мере, пока не попадалось. Думаю, ты сможешь найти там ответы на многие вопросы, не дающие тебе спокойной жизни. Однозначно букмарковать.

Дизайн - 10/10. Очень стильно, все такое черненькое, мрачненькое :).

Содержание - 10/10. Один форум многого стоит!

Навигация - 9/10. Все удобно.

Теперь сходим на сайты девелоперов дистрибов, чтобы ты лучше мог понять, что собираешься поставить на свою тачку.

Поддержим российского производителя и расскажем о русских дистрибутивах, точнее об их пагах.

Начнем с ALT Linux. http://www.altlinux.ru - официальный сайт одного из самых быстроразвивающихся дистрибутивов русского Линукса.

ALT Linux задумывался как русский вариант Mandrake, но в настоящее время отпочковался и использует от него только инсталлер (но разработчики клятвенно обещают и от него отказаться в ближайшем будущем).

Информация об ОСи из первых рук (корпоративные новости и новости о дистрибутиве), достойное количество скачиваемого софта, статьи, техническая поддержка - в общем, все, что должно быть на сайте производителя и разработчика программного обеспечения. Форум тоже имеется.

Дизайн - 8/10. Скромненько и со вкусом.

Содержание - 8/10.

Навигация - 8/10. Удобно и без излишеств.

Следующий номер нашей программы - http://www.asplinux.ru/.


Спецвыпуск Xakep, номер #031, стр. 031-086-2, СЕЗОН ОХОТЫ... НА ПИНГВИНОВ. Обозреваем *nix ресурсы

СЕЗОН ОХОТЫ... НА ПИНГВИНОВ. Обозреваем *nix ресурсы

Александр Денисов aka Xander

Спецвыпуск Xakep, номер #031, стр. 031-086-2

ASP Linux Ural, который начинает продаваться 12 мая 2003, по словам производителей, "новейший дистрибутив Linux, надежный и устойчивый и в то же время легкий в установке и настройке".

Что здорово повеселило - дизайн сайта. ИМХО, он напоминает дизайн паги Мелкомягких :). Еще один образчик корпоративного сайта с отличным впечатлением. Описание продукта, места для покупки, документация, форум, связанный с этой ОСью, надо заметить, немаленький, почти двадцать тысяч сообщений.

Дизайн - 8/10. Я же говорю, на Микрософт похож, но грузится не так бодро на диалапе.

Содержание - 9/10.

Навигация - 9/10.

Еще один официальный сайт - http://www.usoft.spb.ru.

Ребята занимаются локализацией Красной шапки под названием Red Hat Cyrillic edition. Все как у всех, только маловато информации. Техподдержка, статьи, форум.

Что касается технической поддержки, я могу сказать по своему опыту, после приобретения Cyrillic edition в Линукс-центре пару лет назад у меня случилась реальная запара с настройкой X window на матрасе (Matrox dual head). Ну не хотел он работать ни в какую ни в одном разрешении, кроме как 1600х1200. Я отписался саппорту, и мне ПОМОГЛИ, так что имей в виду.

Дизайн - 8/10. Стильненько так, только грузится довольно долго.

Содержание - 7/10. "Малавата будет..."

Навигация - 8/10. С тем контентом, что там есть, она справляется.

Я рассматривал только отечественные дистрибутивы, думаю, сайты Мандрейков, Ред Хатов и остальных ты найдешь сам :).

ВАГОН СОФТА

Ну все, с дистрибом, допустим, определились. Теперь нужно определиться с тем, где взять собственно дистрибутив и вагон и маленькую тележку всякого жизненно необходимого, нужного, полезного, на фиг не нужного и даже вредного для некоторых :) софта. Если закажешь в нете или купишь в магазине, то все и так ясно. Но если мы будем качать, то нужно определиться, откуда.

Первая мысль, которая нам приходит в голову: http://www.linuxdownloads.org.

Что мы видим? Знакомый до боли php-nuke и сообщения различных товарищей о том, где и чего можно надыбать. То есть здесь я не нашел никакого софта. Грустно, а ведь такое до боли многообещающее название. Разочаровали малость.

Дизайн - 6/10. Пхп-нюк он и в Африке пхп-нюк.

Содержание - 5/10. Неплохой архив ссылок, не более.

Навигация - 8/10.

http://linuxbasis.com/downloads.html.

Да, это именно базисы. Ничего особо выдающегося на этом сайте нет, кроме разве что очень гармоничного дизайна. Набор софта обычный, правда, много всяких украшательских фишечек типа обоев, звуков и т.д.

Дизайн - 9/10.

Содержание - 6/10.

Навигация - 8/10.

Ладно, идем дальше. Телки и пиво это круто? Точно, круто! А когда телок две? Тогда нам прямая дорога на http://linux.tucows.com.

Что такое две коровы, рассказывать, думаю, не стоит. Хочу только сказать о том, что не очень порадовало: нет зеркал с линуксовым софтом в России. С виндовским есть, а с пингвиньим нет. Так что приходится выбирать между Финляндией и еще чем-нибудь. Тем более, иногда ссылка на скачку отправляет в какие-то дали, где браузер теряется...

Дизайн - 9/10. За коровок :).


Спецвыпуск Xakep, номер #031, стр. 031-086-3, СЕЗОН ОХОТЫ... НА ПИНГВИНОВ. Обозреваем *nix ресурсы

СЕЗОН ОХОТЫ... НА ПИНГВИНОВ. Обозреваем *nix ресурсы

Александр Денисов aka Xander

Спецвыпуск Xakep, номер #031, стр. 031-086-3

Содержание - 10/10.

Навигация - 8/10.

http://linux.org.uk/LinuxFTP.html.

Довольно большая кладовка, расположенная в Англии. Все, как у всех. Не сравнить с коровами, но как альтернатива покатит.

Дизайн - отсутствует.

Содержание - 5/10.

Навигация - Проводник.

http://physics.uplb.edu.ph/ftp/linux/ - данный сервант принадлежит Институту математических наук на Филиппинах. У них здесь пачка даже побольше, чем у англичан, так что сюда тоже можно заглядывать.

Дизайн - отсутствует.

Содержание - 6/10.

Навигация - Проводник.

http://www.linuxarchives.com.

Ну, вот что-то, что может громко заявить о себе. Обычный набор никсовых прог, но хотя бы симпатичный дизайн.

Дизайн - 7/10.

Содержание - 7/10.

Навигация - 6/10.

Следующая станция - свежатинка. http://freshmeat.net.

Скажу честно, мне тут понравилось. В эстетическом плане. Серенько-голубенький дизайн, удобная навигация, но как-то не очень удобно устроена скачка.

Дизайн - 8/10.

Содержание - 9/10.

Навигация -7/10.

И тут тебе не угодили? Ну ладно, я понимаю, мы все хотим все и сразу. Получи! Все и сразу. Все дистрибутивы Линукса на одном серваке. Весь софт, который можно себе представить. Все примочки и прибамбасы, которые можно прикрутить к Линуксу, возможно за очень малым исключением. Такой вариант тебе нравится? Тогда рекомендую пройтись по адресу http://www.ibiblio.org/pub/Linux/.

171 гектар тебя устроит? Я думаю, вполне для первого раза. Качать можно как через веб, так и через ftp. Кстати, совет: сразу сверху на главной паге щелкни на ftp view (очень удобно шариться по каталогам). Или коннекться сразу ftp-клиентом и не парься. Разделы: приложения, аудио/звук, коммерческие демо-версии, инструменты разработчика, дистрибутивы (на данный момент там валялись из свежака 9-я Красная шапка и Мандрэйк 9.1), документация, редакторы, игры, дрова, ядра, либы, научные программы, поисковые движки, утилиты, www-тулзы, X'ы. Построено все так, что скачка начинается после третьего-четвертого клика. Вполне достойное место.

Да, еще по поводу дистрибутивов. Сколько оных ты можешь назвать? 5-10? Я примерно столько же, ну может еще парочку назову. Здесь же я узнал, что дистрибов Линукса на данный момент можно загрузить 85 штук. Именно столько лежит по адресу ftp://ibiblio.org/pub/linux/distributions. Так что у тебя есть чем заняться в ближайшие несколько лет :).

Дизайн - 7/10. Очень много раскидано по сторонам, и желательно, чтобы такие лакомые куски, как свежие дистрибы, хотя бы как-то выделялись, а то так и пропустить можно! Но если перейти в режим FTP, то можно расслабиться и получать удовольствие.

Содержание - 11/10, нет, скорее 12.

Навигация - 10/10.

ДОКИ!

Ну ладно, винт мы уже софтом забили. И что теперь с ним делать? Предлагаю обратиться к документации. Вот теперь-то мы и подошли к тем самым fucking manuals. И для начала рекомендую сходить на http://linux-ve,net.

Виртуальная энциклопедия для начинающих пользователей Линукса. Ну что я могу сказать. Здесь есть, на мой взгляд, почти вся русская документация, которая нужна пингвиноведу. Причем не только начинающему, но и продвинутому.


Спецвыпуск Xakep, номер #031, стр. 031-086-4, СЕЗОН ОХОТЫ... НА ПИНГВИНОВ. Обозреваем *nix ресурсы

СЕЗОН ОХОТЫ... НА ПИНГВИНОВ. Обозреваем *nix ресурсы

Александр Денисов aka Xander

Спецвыпуск Xakep, номер #031, стр. 031-086-4

Дизайн - скромный.

Содержание - 9/10.

Навигация - 6/10.

Еще один из массивнейших складов документации находится по адресу http://linux.ru.net/.

Обозначен в заголовке как "Российский информационный сервер для начинающих и опытных пользователей ОС Linux". Ежечасные, а то и чаще обновления в разделе новостей, большой раздел документации на русском и других языках. Форум с 60000 сообщений, что тоже не может не вызывать припадка энтузиазма и веры в светлое будущее. Огромное количество русской информации по Пингвину.

Домашняя страничка доктора Баума: http://stommel.tamu.edu/~baum/linux-meta.html.

Хотя у меня язык не поворачивается так ее назвать. Здесь можно жить! Более подробного описалова на пингвиний софт я не встречал вообще нигде. Здесь дикое количество ссылок на линуксовые сайты. Особенно полезным сайт будет для тех, кто занимается научной работой и не может найти подходящего софта под никсы. Здесь есть информация по таким зубодробительным вещам, как программы моделирования землетрясений и ядерных взрывов. Апгрейдь тачку и вперед - глядишь, скоро один из наших читателей будет в списке Нобелевских лауреатов.

Перечислю только разделы: Скорая помощь - ссылки на FAQ'и и newsgroups, хелпы, саппорты и штаб-квартиры всех изготовителей всех пингвинов, ящерок и чертиков. Новости, периодика, журналы, сетевые газеты, цифровые книги и прочее, что может тебе помочь в нелегком деле обуздания Линукса. Списки софтовых порталов для Линукса. Раздел ссылок, посвященный железу, - здесь ты точно найдешь себе софтину под звуковую карточку OPTi выпуска 1997 года (я по крайней мере нашел :)). Два больших раздела: обычный софтвар и софтвар специфический с описанием каждой программы, с оценкой и линком. С обычным - все понятно, этот софт и в дистрибутиве есть, и везде его навалом. А вот специфический - тут только список с описанием не один день читать. Экологические симуляторы - 20 пунктов, океанологические программы - 45 пунктов, текстовики - 30 пунктов, программа для обсчета движения молекул, состоящих более чем из 35 тысяч атомов... Если ты и после этого не сдашь химию!.. Как видишь, адреса с доменами .edu говорят о том, что всем этим занимаются нормальные дядьки в белых халатах, бородах и очках, а это - гарантия качества. Линки битые, конечно, есть, но не более, чем на остальных ресурсах. Что не может не радовать, последнее обновление датировано мартом 2003 года. Короче, однозначно необходимо занести в закладки.

Содержание - 9/10 (балл снят за битые ссылки).

Дизайн - зачем красивый дизайн ядерной бомбе?

Навигация - более менее, сайт достаточно плоский, поэтому заблудиться в нем сложно.

Следующая остановка - http://www.linuxfocus.org/. Как они себя называют на первой странице - это "Первый действительно международный журнал, посвященный Линуксу. Управляется и выпускается линукс-добровольцами, фанатами и разработчиками. Абсолютно бесплатный и доступный из любой точки мира". Точно. Информация здесь более чем достойная и более чем интернациональная. Существуют версии сайта на 8 языках: английский, датский, французский, немецкий, испанский, турецкий, китайский и, Аллилуйя! - РУССКИЙ! Сразу дам на него ссылку, чтобы не забыть: http://www.linuxfocus.org/Russian/. Одно плохо с русской версией - мало переведенных статей. Номер выходит где-то раз в два месяца, на российской странице доступны сейчас 28 номеров с ноября 1997 года по март 2003! Если хочешь помочь и неплохо шаришь в иностранных языках, пошли письмо куратору российского фокуса, и вперед - вписывать свое имя в историю эволюции Пингвина.


Спецвыпуск Xakep, номер #031, стр. 031-086-5, СЕЗОН ОХОТЫ... НА ПИНГВИНОВ. Обозреваем *nix ресурсы

СЕЗОН ОХОТЫ... НА ПИНГВИНОВ. Обозреваем *nix ресурсы

Александр Денисов aka Xander

Спецвыпуск Xakep, номер #031, стр. 031-086-5

Я по-английски неплохо изъясняюсь, посему полез в свежак на английском портале. Информации здесь полно, и она более чем интересная. Я, например, зачитался статьей о веб-камере без камеры. Последний номер - май-июнь 2003 года. Для затравки парочка заголовков из последнего номера: "Фильтрация пакетов под Линуксом - установка файрволлов"; "Инструкция по созданию 8-см сидюка с КНОППИКСОМ" - тот самый дистрибутив, не требующий инсталляции и работающий с CD. "Система Обнаружения вторжения - IDS". И еще много всего интересного по настройке, программированию и просто жизни в Линуксе.

Содержание - 8/10. Иногда сложно найти дополнительную информацию по теме, изложенной в статье.

Дизайн - 8/10. Стильненько, грузится быстро.

Навигация - 9/10. Упрощена до предела.

Еще один интересный форум http://portal.sysadmins.ru/board/.

Как видно из названия - это портал для сисадминов. Форум тут тоже более чем мощный - Юниксу во всех его ипостасях уделено почти 20000 сообщений, так что есть чего почитать.

Дизайн - 8/10. Приятная гамма зеленого цвета.

Навигация - ну какая на форуме навигация?

Содержание - 10/10.

Сайт ссылок на документацию по пингвину. http://infocom.cqu.edu.au/Courses/2002/T3/COIT13146/Resources/LDP/links/nenglish.html#russian.

Казалось бы, еще одна пага с доками, которых много, но если присмотреться к людям, которые ею рулят: Грег Фергюссон из Silicon Graphics и Джошуа Дрейк с linuxports.com, понимаешь, что это даже круче, чем знак качества. Опять же есть русская информация, что не может не радовать. Здесь очень много инфы, причем по самым разным областям, но с углублением в развлечения. Полно ссылок на всяческое документалово по мультимедиа - фото, звук, графика, потоковое вещание.

Дизайн - 9/10. Один балл лично от меня за грустного пингвина в топе страницы :).

Содержание - 7/10. Довольно специфичное.

Навигация - 6/7. Не всегда удобная, страницы открываются в новых окнах, причем ссылку на главную пагу на них фиг найдешь.

Я надеюсь, что этого тебе хватит надолго. Так что береги себя, выводи Тукса на прогулку и не шали.


Спецвыпуск Xakep, номер #031, стр. 031-090-1, ГДЕ ИСКАТЬ ВАРЕЗ? Быль для тонких и толстых каналов

ГДЕ ИСКАТЬ ВАРЕЗ? Быль для тонких и толстых каналов

Roger & ManderX

Спецвыпуск Xakep, номер #031, стр. 031-090-1

(forother@fromru.com)

Так-с, значит, до сих пор еще сидишь в 2001 году? Это не потому, что ты отсталый мэн, а потому что лицензия на AVP истекает 1 января 2002 года, ведь так? Вот только не надо мне говорить, что ты заходил на astalavista.box.sk, тебя закидали попапами, ты еле как добрался до главной страницы, минут 10 вбивал название софтины... А потом все то же самое, и ты решил забить?

Очень часто я вижу, когда кто-то просит кряк и его посылают на асту, так почему все время аста? Почему все так ограничено? Почему она так популярна, если там столько попапов? Где еще брать кряки?? Ответы на все эти вопросы и даже более (я сказал - БОЛЕЕ! =) ты найдешь прямо тут, здесь и сейчас. Статья полезна как и диалапщикам, ищущим лекарство (кряк, кейген, серийник) для софта, так и для мэнов с толстым каналом и фри инетом =).

Let da party begin!

Давай начнем с самого начала, ибо оно в сети очень подробно описано (например, http://www.xakep.ru/magazine/xa/004/040/1.htm). Напомню (а также дополню) лишь то, что варез-сцена состоит из варез-групп, каждая группа тем или иным образом получает свежий софт (обычно члены имеют доступ, работая в магазине по продаже лицензионного софта и т.д.), потому делается пилюля для софта (это может быть поломанный exe, кряк, кейген или просто серийник). Иногда удаляют лишнее из проги, чтобы облегчить размерчик, и тогда это уже будет RIP-нутая версия. Запихивают все это в архив, не забыв вложить туда и nfo-файл (прочитать его можешь DAMN NFO Viewer-ом, брать тут - http://www.damn.to/software/). В этом файле ты можешь узнать всю инфу о релизе (архив со всем этим добром и есть релиз), включая: инструкции по установке, описание софтины и другую инфу по группе. Если оказывается, что релиз не будет рабочим, то его называют нюкнутым, и группа переделывает или выпускает патч к релизу.

Потом группы заливают свои релизы на private 0day ftps, доступ на такие фтп получить очень сложно (как правило, надо платить). 0day - значит, что софт пришел прямо с конвейера (с рук крякера =), т.е. точно так же, как свежий теплый хлеб в булочной =). На скрине можешь увидеть один из таких фтпшников, там 0426 - 26 апреля сего года. В самой папке уже размещены релизы, названные: [название проги]-[название варез-группы]. Например, Advanced.Pic.Hunter.v1.52.WinAll.Incl.Keygen-ENFUSiA. ENFUSiA - варез-группа. А потом кто-то, скачав релиз, может залить его на паб (паб - это фтп, доступный для всех, обычно там есть папочка Appz - там и лежит варез =). Пабы могут использоваться и для других целей, например - обменником группы и т.д., к теме получении списка пабов мы еще вернемся. Кейгены и кряки могут отделяться и идти на соответствующие сайты. Существуют сайты и варезной тематики, куда тоже могут заливаться релизы, и пиплы могут качать по http, но тут возникает одна трабла. Существуют такие люди, которые нагло воруют ссылки на софт с какого-нить сайта (т.е. варез предназначен для посетителей только этого сайта) и кидают линк на высоко посещаемый сайт/форум, так что сервак может упасть =), и никому ничего не достанется. Таких наглецов называют личерами (перевод - кровопийцы), но пиплы поумнее посидели и придумали анти-лич, это система (может быть написана на различных языках программирования) предотвращает воровство линков, она, как правило, проверяет реферы и другое. Теорию теперь оставь на кухне и беги к компу, будем практиковаться.


Спецвыпуск Xakep, номер #031, стр. 031-090-2, ГДЕ ИСКАТЬ ВАРЕЗ? Быль для тонких и толстых каналов

ГДЕ ИСКАТЬ ВАРЕЗ? Быль для тонких и толстых каналов

Roger & ManderX

Спецвыпуск Xakep, номер #031, стр. 031-090-2

IRC

Я думаю, тебе не надо объяснять, как использовать фтп-клиент и что такое фтп? Поэтому сразу перейдем к делу - получению списка пабов! Лучший способ для этого - IRC. А ты думал, он только для общения рожден? =). Мало того, что там есть закрытые каналы с 0day инфой, там существуют еще и открытые каналы, на которых можно найти нехилый лист с пабами. Если ты до сих пор на "вы" с IRC, то читай мануалы, коих сейчас много. Сетей с варез-каналам есть много, я тебе покажу на примере сети FDFnet (irc.fdfnet.net), там есть канал #warez, заходи туда и набирай !list, к тебе по DCC постучится бот, принимай от него файл (sites.txt), файло обычно весит больше 120 kb (нехило для списка фтпшников? =). Теперь открывай список, сначала там будет всякая инфа, а потом сам список. Хочу тебя обрадовать, в списке могут быть пабы с 0day варезом за прошлые дни, фильмами, ебуками, твои любимые три икса =) и т.д. Windows Server 2003 на данный момент найти труда не составило :). Если еще не понял, что перед тобой, то давай разберем:

[93232] <22 Apr 2003 03:23> Rated: 2 james007

/*Это идет инфа о сервере: номер по порядку, дата, рейтинг, имя */

141.2.209.126 /recycler/temp l:anonymous p:email@email.com port:21

/*Адрес: ip, подкаталог, логин, пароль, порт. Логин, пароль и порт могут и не быть */

CD-DVD Diagnostic 2.0.2 Retail, CloneDVD v1.21, FIM Speedway Grand Prix-FLT, GODAI ELEMENTAL FORCE - US, MICROSOFT WINDOWS SERVER V2003 OPK-ISO, Vexx USA PS2DVD-ConFuSiON, Winternals Administrators Pak v3.0.1 WinNT2KXP READ NFO-NiTROUS

/*Описания, т.е. то, что там есть, я искал вынь и нашел=)*/

Как собирается этот список? Очень просто, сами посетители канала собирают его, да ты и сам можешь добавить фтп (хорошее дело сделаешь) командой - /msg Balthor SITE_NAMR xxx.xxx.xxx.xxx /dirs L: & P:.

Но с ирц мы еще не покончили =), оттуда ты еще можешь качать кряки, сериалы и другие виды лекарств к софтине =). Очень, кстати, актуально, например, с сайта tsrh ты замучаешься качать =), а вот в ирц по DCC без проблем! Даже мега три для диалапщика не будет траблой. Значит так, заходим на EFnet (в мирке адреса есть), каналов там много, вот тебе несколько: #cracks-world, #cracks, #serialz. Зайдем, например, на #cracks-world. Если нужна помощь, вбивай !help, и тебе бот пошлет help-файл по DCC, а так основные команды: !search soft_name - будет искать лекарство, !serial soft_name - будет искать только серийник, !get file_name - получить по DCC лекарство; file_name должен быть таким же, как и результат поиска. Если ты скажешь эти команды на канале, к тебе обратится несколько ботов, если же в приват кому-то из ботов, то он и пошлет тебе. Лучше в приват, так как меньше напряга ботам, и вообще не злоупотребляй, а то и себе, и другим сделаешь хуже.


Спецвыпуск Xakep, номер #031, стр. 031-090-3, ГДЕ ИСКАТЬ ВАРЕЗ? Быль для тонких и толстых каналов

ГДЕ ИСКАТЬ ВАРЕЗ? Быль для тонких и толстых каналов

Roger & ManderX

Спецвыпуск Xakep, номер #031, стр. 031-090-3

WEB

С IRC покончили, теперь перейдем к http. Где же тут искать линки на пабы??? Конечно же там, где можно общаться, - на форумах. Список хороших форумов я привел во врезке. Как правило, для того чтобы просматривать самое-самое - надо зарегаться. На форумах ты найдешь много интересного и всегда сможешь попросить помощи в поиске. На ру-борде советую посетить этот топик - http://forum.ru-board.com/topic.cgi?forum=35&topic=2092&start=900. Там обсуждается книга "Где искать ВАРЕЗ", насыщенная инфой по USENET-у и Пабам, а также ссылами на всякие форумы и сайты. Именно поэтому в статье про USENET нет ни слова =).

Также во второй врезке я предоставил подборочку хорошо зарекомендовавших себя русских сайтов. На самом деле сайтов варезной тематики достаточно много, тебе только надо посмотреть во френдз сайтов (раздел ссылки типа =), которые я тебе дал. Новостей с этих сайтов тебе должно хватить =).

Теперь вернемся к поиску кряков и вареза =), искать будем по веб поисковикам... Ты, наверно, и представить себе не мог, что кроме асты есть еще? Нет, ссылки на все я давать не буду, потому что хороший человек уже уместил все поисковики на одном сайте - http://www.monk.al.ru/main.htm. Мало? (Хотя я очень сомневаюсь, что мало.) http://saturn.lunarpages.com/~satuf/l2s/ftp.html - тут еще несколько фтп-поисковиков. Советую также обратить внимание на эти два поисковика: http://www.filemirrors.com и www.reliz.ru.

Вот и все! =) Едем дальше.

Serials2k

Был такой проект - Serials2k, представлявший собой базу серийников для софта. После того как проект закрыли, энтузиасты из DTG решили его возобновить. http://www.serialz.to/s2kupdates.html - тут можешь забрать эту базу и кучу обновлений, которые выходят два раза в месяц. Также обновления делают и другие группы в формате Serials 2000 (например, NoNaMe), так что если встретишь - качай. Бд очень обширная и содержит серийники не только для Windows, но и других менее распространенных платформ.

p2p

Всем известны p2p сети, типа eDonkey и OverNet, о них недавно писал Хакер. Но мало кто знает о такой сети, как битторент, она очень отличается ото всех других. Первое отличие - это скорость, она намного выше, второе - отсутствие поиска =(. Но я по крайней мере слил из сети вынь сервер 2003 =). Скачать клиента можешь тут - http://bitconjurer.org/BitTorrent/download.html.

УСЕ

Т.е. почти все, забыл еще сказать, что на пабах и на 0day можно найти не только варез под вынь, но и под другие платформы, а также и для КПК (покетов, Пальмов), и для маков, etc. Вот сейчас все =). Удачи тебе добыть то, что ты ищешь!

Форумы:

http://palmidet.msk.ru/ - владельцам КПК

http://flame.ws/

http://www.imho.ws

http://forum.oszone.net - есть кое-что

http://www.f.docs.ru/ - там раздел NoNaMe, форум nnm.ru

http://kadet.net.ru/forum/index.php

http://forum.daphouse.com/

http://147.45.35.100/forum/index.php - начинающийся форум, но имеет большой потенциал

http://www.pc-zone.net.ru

http://forum.ru-board.com


Спецвыпуск Xakep, номер #031, стр. 031-090-4, ГДЕ ИСКАТЬ ВАРЕЗ? Быль для тонких и толстых каналов

ГДЕ ИСКАТЬ ВАРЕЗ? Быль для тонких и толстых каналов

Roger & ManderX

Спецвыпуск Xakep, номер #031, стр. 031-090-4

http://www.fileforum.ru/ - там хорнет неплохо заведует =)

САЙТЫ:

http://WZor.net

http://kadet.net.ru/

http://www.filez.nastart.ru - web-обменник

http://www.nforce.nl - сборище nfo-файлов

http://www.warpor.net

http://www.daphouse.com/

http://www.medigo.ru/ - может поменяться на megido.ru

http://www.kpnemo.ru/

http://www.rusc.ru/ - нет вареза, просто новостной софтверный сайт

http://www.123soft.tk/

http://www.nnm.ru


Спецвыпуск Xakep, номер #031, стр. 031-092-1, FAQ L/W. Матушка Лень (mlen@mail.ru)

FAQ L/W. Матушка Лень (mlen@mail.ru)

Спецвыпуск Xakep, номер #031, стр. 031-092-1

Чем отличается установка Linux от Windows?

И то и другое мы можем начать с загрузочного CD. То есть вставить компактдиск, настроить в BIOS загрузку с компакта, и программа установки будет самостоятельно запущена. Во многих случаях программа установки имеет графический интерфейс, даже во Free BSD! Обе системы предложат разбить для начала диск. И в Вынь, и в Линь ты можешь не знать назначение устанавливаемых компонентов, но установить все по умолчанию возможность есть.

Как правило, после установки Вынь появится графическая оболочка, после установки Линь она может и не появиться. Многие типичные устройства Windows найдет и обнаружит сама, ведь разработчики железа плодотворно сотрудничают с Microsoft, чтобы та внедряла готовые дрова в свои операционки. Linux выпускается всем миром, и будет ли иметь твой дистрибутив нужные дрова - загадка. Однако большинство современных производителей взяли за правило писать к своим устройствам дрова и под Линь, то есть потенциальная возможность доустановить то, что не установилось, есть.

Один перец протестил множество дистрибутивов Линь на легкость установки, советую ознакомиться: http://linuxshop.ru/linuxbegin/article269.html.

Установка лицензионной версии Windows XP усложняется необходимостью регистрации по телефону или через Интернет. Например, если ты купил комп с предустановленной XP, то в течение месяца придется ее зарегистрировать, иначе откажется работать!

Чем отличается установка драйверов под Linux и Windows?

Если система не смогла автоматически определить какое-то устройство, то нужно ставить дрова. В Виндах обычно нужно запустить конфигурационный файл либо вызвать "Мастер настройки оборудования" и указать ему, где лежат дровишки. В Линь все зависит от фантазии разработчиков, тебе придется править конфигурационные файлы, что-то компилировать. Вот пример весьма геморроидальной установки драйверов для графической карты NVIDIA под Mandrake 8.0 Linux - http://www.nvworld.ru/docs/mandrake.html. Однако жизнь не стоит на месте, и сейчас установка драйверов NVIDIA возможна с помощью технологии RPM (http://bog.pp.ru/work/rpm.html), которая позволяет автоматически выполнить все сложные манипуляции. Однако будь готов к тому, что у тебя найдутся такие устройства, с дровами к которым придется серьезно попотеть!

Чем отличается установка разных программулин под Вынь и Линь?

С инсталляцией программ под Вынь все просто - либо скопировал и работай, либо запустил Install или Setup и все само собою установилось. Многие программы под Линь, да и сам он распространяются в Open Sourse (Открытом Коде), то есть ты выкачиваешь исходники, которые нужно скомпилировать под свою систему и сделать запускаемыми. Прочитай ФАК на эту тему здесь: http://soobcha.ru/faq/index.html?question=1676. Обычно последовательность необходимых действий описана в информационных файлах программы. Тут-то и начинается мегагимор, ведь каких-то библиотек у тебя может не быть, компилятор может быть не тот, или ты ошибешься в последовательности действий. Поэтому новичкам рекомендуется качать RPM-файлы, во время применения которых все скомпилится автоматически, либо искать готовые бинарники. Программисты прутся! Качнуть программы для Linux можно на серверах: http://www.linuxcoolsoft.narod.ru/, http://www.boutell.com/lsm/, http://www.linuxarchives.com/, http://www.freshmeat.net/. Ну а бесплатные утилиты под Вынь можно качнуть здесь: http://www.freeware.ru/.


Спецвыпуск Xakep, номер #031, стр. 031-092-2, FAQ L/W. Матушка Лень (mlen@mail.ru)

FAQ L/W. Матушка Лень (mlen@mail.ru)

Спецвыпуск Xakep, номер #031, стр. 031-092-2

Чем отличаются русификации Linux и Windows?

Подобно тому, как можно купить русский Windows, сейчас можно купить и русский Linux. Однако Вынь русифицирован на сегодняшний день лучше, с Линь могут возникать различные проблемы. Чтобы представить себе все уровни кириллизации, читай HOW-TO: http://emanual.ru/download/118.html. Конечно же, русифицировать оригинальную версию Win2k куда проще - http://info.syzran.ru/~ssa/w2k.htm.

Чем отличается режим командной строки Linux от DOS-режима Windows?

Табличку сравнения текстовых команд можно посмотреть здесь: http://emanual.ru/download/131-3.html. Да, команды только называются по-разному, но, по сути, делают одно и то же: копирование, удаление, просмотр файлов и директорий. Однако в *nix появляется новая фишка: ты можешь переключаться между текстовыми консолями. То есть ты можешь одновременно работать с несколькими программами, запущенными в разных текстовых консолях! Переключаться между ними можно пимпами Alt+F1, Alt+F2, Alt+F3 и так далее. Вот такой многозадачный этот ЮНИКС %). Кстати, список процессов можно посмотреть командой PS, а снять зависшие процессы можно командой kill. Действие похоже на вызов "диспетчера задач" в Windows заветными клавишами .

Текстовая консоль называется shell (оболочка), и неважно, где ты ее вызвал, - на локальном компе или на удаленном через telnet. Благодаря такой конструкции Линем легко управлять на расстоянии, поскольку через текстовый интерфейс можно сделать все, в отличии от Вынь.

Чем отличаются файлы Win и Lin?

В пути к файлам нет привычных дисков A:\, C:\ и других. Все монтируется к одному корню. То есть к какой директории ты привяжешь CD-ROM, раздел на диске, дискетку, сетевой диск, в такой у тебя и будет жить соответствующая инфа. То есть если я примонтировал CD к каталогу /mnt/cd, то так к нему и надо обращаться. Кстати, с большинством Линуксов устанавливается Midnight Comander, он не сложнее привычного Нортона в DOS. Вызвать его можно, набрав в командной строке инициалы: mc.

Файлам Линя пофиг на разрешения, можешь забыть про EXE, BAT (как в Вынь) и прочие прелести; исполняемые файлы различаются атрибутами. Атрибуты также определяют права на чтение, запись и исполнение. Читай об этом здесь: http://emanual.ru/download/131-5.html. Однако делать скрипты на языке шелла (что-то типа DOS'овских BAT'ников) можно и даже нужно: http://emanual.ru/download/131-11.html/

Линевым файлам в отличие от DOS важно, какие буквы: большие или маленькие. То есть Линь, как и всякий Юникс, различает регистр символа в имени файла.

Также полезно прочесть об особенностях файловых систем Линукс: http://linuxshop.ru/unix4all/?cid=&id=160


Спецвыпуск Xakep, номер #031, стр. 031-092-3, FAQ L/W. Матушка Лень (mlen@mail.ru)

FAQ L/W. Матушка Лень (mlen@mail.ru)

Спецвыпуск Xakep, номер #031, стр. 031-092-3

Чем отличаются графические оболочки Win и Lin?

Начнем с того, что любой Вынь плотно интегрирован со своей графической оболочкой, и без нее ты с ним мало что сможешь делать. В Линь графическая оболочка является опциональной, все важные настройки хранятся в текстовых конфигурационных файлах, и неважно, как ты их будешь менять: вручную, с помощью диалоговой программы-конфигуратора или с помощью графических менюшек. Если ты хочешь использовать Линь только как сервер, то графическая оболочка тебе вообще может не понадобиться. Linux проживет и без нее. А вот попробуй отключить у сервера NT графическую оболочку!

Под свои задачи ты можешь выбрать различные графические интерфейсы для Линь: http://www.linuxcenter.ru/enc/x-win.htm. Как известно, и графическую оболочку Windows тоже можно переделать даже под Макинтош: http://intz.imm.uran.ru/int_z405/izone405/pub/izone7.htm.

Правда ли, что Linux безопаснее Windows?

Плохо настроенный Линь еще опаснее, чем Вынь. Если регулярно выполнять все рекомендации по безопасности Вынь и Линь, качать и вовремя ставить новые заплатки, пользоваться свежими антивирусами, то обе системы будут неплохо защищены. Однако в Линь ты можешь удалить все лишнее, залезть в каждую строку системного кода, продумать механизмы дополнительной защиты. Потенциально невероятные возможности гибкой настройки Linux позволяют получить более безопасную систему, но только в руках суперпрофессионала!

Как у Вынь и Линь с поддержкой IP-сетей?

Сетевые возможности Линь намного шире, чем Вынь (http://www.mgul.ac.ru/~t-alex/Linux/NET-3-HOWTO/NET-3-HOWTO.htm)! Сети - как раз тот случай, когда тонкая настройка просто необходима. Под Вынь некоторые сетевые вещи порою организовать просто невозможно! Однако под Windows с сетевыми задачами позволяет справиться достаточно гибкая программа winroute (http://alib.spb.ru/servers/proxy/winroute/manual/).

Чем отличается запись CD и DVD под Вынь и Линь?

Прошли те времена, когда Пингвин отставал от БГ по поддержке новейших мультимедийных технологий, таких как USB, например. В этом мануале рассказывается о записи DVD-дисков под Линукс - http://gazette.linux.ru.net/lg83/stoddard.html. Также разработчикам Линь удалось добиться разрешения на поддержку технологии Mount Rainier, которая позволяет работать с CR-RW и DVD-RW дисками как с винчестером или обычной дискеткой. То есть необходимость в пишущей программе в будущем отпадет.

Однако не все так безоблачно: большинство документации по записи DVD и CD под Linux рассказывает о последовательности действий, которые нужно выполнить в командной строке для записи. Линь совсем не спешит стать дружелюбным!


Спецвыпуск Xakep, номер #031, стр. 031-094-1, НАНОТЕХНОЛОГИЯ: МЕЧТЫ И РЕАЛЬНОСТЬ

НАНОТЕХНОЛОГИЯ: МЕЧТЫ И РЕАЛЬНОСТЬ

Pony (pony@xakep.ru)

Спецвыпуск Xakep, номер #031, стр. 031-094-1

Так что же это за слово такое волнующее и ужасное - "нанотехнология"? И что за ним стоит?

Стоит за ним относительно новая область знания, предмет которой - манипулирование объектами, имеющими геометрические размеры порядка нанометра. Это уже операции не с веществом, а с отдельными атомами и молекулами.

С ЧЕГО ВСЕ НАЧИНАЛОСЬ

Официальным моментом рождения понятия "нанотехнология" считают 29 декабря 1959 года, когда нобелевский лауреат Ричард Фейнман в своей речи на съезде Американского физического общества в Калифорнийском технологическом институте сказал о том, что "принципы физики не запрещают" подобные манипуляции. Тогда его слова казались фантастикой, так как еще не существовало методов, позволяющих оперировать отдельными атомами на атомарном же уровне (схватить нужный нам отдельный атом и перетащить его на нужное нам место). Аппаратура, позволяющая реализовать эти методы (на самом примитивном уровне, кстати говоря), появилась позднее - в конце семидесятых годов.

В 1966 году группой Рассела Янга из Национального бюро стандартов США был создан прибор под названием "Topografiner". Прибор предназначался для изучения топографии поверхностей проводящих материалов. Не вдаваясь в подробности конструкции, можно сказать, что такой прибор мог бы после некоторой доработки обеспечить возможность исследования рельефа поверхности с атомарным разрешением, но такой задачи группа Янга перед собой не ставила...

Зато ее поставили перед собой сотрудники швейцарского отделения IBM Генрих Рорер и Герд Биннинг. Они успешно осознали идею получения атомарного разрешения при помощи твердотельных зондов (игл) и в 1981 году создали прибор, как две капли воды похожий на янговский (попутно его запатентовав). На этом приборе они получили это самое атомарное разрешение, а заодно и Нобелевскую премию по физике в 1981 году. Неизвестно, что чувствовал при этом Янг...

КАК ОНО РАБОТАЕТ?

Прибор, сконструированный Рорером и Биннингом, стал именоваться СТМ - сканирующим туннельным микроскопом (точнее было бы - наноскопом). Принцип его работы прост, как и все гениальное. Основной элемент СТМ - очень тонкая специальным способом заточенная игла. Чем острее кончик иглы, тем точнее работает прибор. В идеале на конце иглы должен находиться один-единственный атом. Игла перемешается вдоль исследуемой поверхности с помощью электромеханической системы (поэтому микроскоп называется сканирующим). Точность перемещения иглы составляет несколько ангстрем, что сравнимо с атомарными размерами. Между иглой и исследуемой поверхностью подается электрическое напряжение. Поскольку зазор между ними очень мал (тоже несколько ангстрем), через иглу начинает течь электрический ток. Величина тока зависит от зазора между иглой и поверхностью, а значит, перемещая иглу, мы можем прорисовывать рельеф поверхности. Квантовый эффект, который отвечает за протекание тока между иглой и поверхностью (а между ними есть зазор), называется туннельным эффектом (поэтому микроскоп называется туннельным).

Позже появилось множество различных модификаций сканирующих зондовых микроскопов, обладающих по сравнению с первыми образцами гораздо более совершенными характеристиками и способных исследовать не только рельеф поверхности, но и другие ее свойства, например, магнитные.


Спецвыпуск Xakep, номер #031, стр. 031-094-2, НАНОТЕХНОЛОГИЯ: МЕЧТЫ И РЕАЛЬНОСТЬ

НАНОТЕХНОЛОГИЯ: МЕЧТЫ И РЕАЛЬНОСТЬ

Pony (pony@xakep.ru)

Спецвыпуск Xakep, номер #031, стр. 031-094-2

Сканирующий микроскоп оказался не только прибором, визуализирующим атомно-молекулярную структуру поверхности. Оказалось, что с помощью определенных движений острия иглы микроскопа на поверхности твердого тела удается создавать атомные структуры. На рисунках проиллюстрирован процесс "выкладывания" атомами ксенона на поверхности монокристалла никеля слова из трех букв - IBM. Это также проделали сотрудники одноименной фирмы во главе с Дональдом Эйглером в конце восьмидесятых годов двадцатого века. Мечта Фейнмана была "осуществлена". Рядом можно увидеть круг, выложенный из 48 атомов железа. Внутри этого круга мы "видим" не что иное, как стоячие электронные волны - так называемые "квантовые кораллы".

МЕЧТЫ

И тут разного рода мечтателям стало ясно - открыт путь к молекулярной нанотехнологии. То есть технологии, имеющей возможность синтезировать любое устойчивое химическое вещество. Иными словами, возможно задумать какую-нибудь молекулу, изобразить ее структуру, теоретически рассчитать ее устойчивость и затем искать пути синтеза.

Да синтеза не простого, а "позиционного", подразумевающего поатомную сборку требуемой молекулы с доставкой атомов в нужное нам место. Синтез происходит в соответствии с законами химии, но эти законы в условиях поатомной сборки действуют иначе, чем при проведении химических реакций, а преодоление активационных барьеров может происходить за счет механической энергии.

Итак, если мы имеем возможность двигать атомы по поверхности с помощью такого мощного средства, как СТМ (то есть манипулировать ими), то что нам стоит из этих атомов собрать какую-нибудь сверхсложную молекулу? Или наноробота, который будет потом сам создавать себе подобных? Или хотя бы помечтать об этом :)?

В 1986 году вышло первое издание книги Эрика Дрекслера "Машины создания" ("Engines of Creation"). В его понимании молекулярная технология - создание функциональных структур и устройств путем их сборки атом за атомом или молекула за молекулой с помощью программируемых роботов (ассемблеров), способных к самовоспроизведению (репликации). По расчетам, ассемблер, снабженный молекулярным компьютером, может иметь массу не более 109 а.е.м. Смело, не правда ли?

Что смогут делать эти самые нанороботы? Тут обычно фантазия начинает работать на полную катушку. Они смогут делать все! Включая колбасу. Из подручных материалов!

В области медицины возможно создание роботов-врачей, которые способны "жить" внутри человеческого организма, устраняя все возникающие повреждения или предотвращая их возникновение. Теоретически нанотехнологии способны обеспечить человеку физическое бессмертие за счет того, что наномедицина сможет бесконечно регенерировать отмирающие клетки.

А чего стоит понятие "серой слизи", уже давно бытующее среди теоретиков нанотехнологии! Допустим, что создан наномеханизм, способный за несколько минут из находящихся поблизости атомов воссоздавать себе подобного. Два механизма, четыре, шестнадцать... Нетрудно видеть, что через некоторое сравнительно небольшое время они все на Земле сожрут, и планета покроется слоем "серой слизи" - размножившихся нанороботов.


Спецвыпуск Xakep, номер #031, стр. 031-094-3, НАНОТЕХНОЛОГИЯ: МЕЧТЫ И РЕАЛЬНОСТЬ

НАНОТЕХНОЛОГИЯ: МЕЧТЫ И РЕАЛЬНОСТЬ

Pony (pony@xakep.ru)

Спецвыпуск Xakep, номер #031, стр. 031-094-3

К настоящему времени достаточно большое количество ученых людей намечтало огромную массу наноустройств, "собираемых" методом поатомной сборки. Какие-то из них могут быть использованы в качестве составных частей при построении в будущем нанороботов. Можно привести некоторые примеры.

Модели молекулярных шестерен как частей будущих роботов предложены исследователями из IMM (Institute for Molecular Manufactoring, Palo Alto). Валами шестеренок являются углеродные нанотрубки (вытянутые конструкции из атомов углерода), а зубцами - молекулы бензола. Характерная частота вращения шестеренок - несколько десятков гигагерц. Планируется, что такого рода устройства "могут работать" либо в вакууме, либо в атмосфере инертных газов при комнатной температуре.

Особое внимание стоит уделить устройству сверхплотной памяти (NASA), как наиболее возможному для реализации. Схема устройства проста и состоит из зонда и алмазной поверхности. Зонд представляет собой углеродную нанотрубку, заканчивающуюся полусферой C60, к которой крепится молекула C5H5N. Алмазная поверхность покрывается монослоем атомов водорода (серенькие шарики), некоторые из которых замещаются атомами фтора (зелененькие шарики). При сканировании зонда вдоль поверхности молекула C5H5N, согласно моделям, "способна" отличить атом фтора от атома водорода.

На одном квадратном сантиметре поверхности помещается где-то 10 в 15 степени атомов, следовательно, плотность записи достигает 10 в 5 степени гигабайт (или 10 терабайт) на квадратный сантиметр (твой винчестер будет иметь емкость 1000 терабайт!).

Из электронных приборов удалось создать диод на углеродной нанотрубке. Как показывают расчеты, электрические свойства нанотрубок находятся в тесной связи с их геометрией, а именно с их (простите за выражение) "хиральностью". Имеется в виду ориентация графитового листа, из которого нанотрубка "сворачивается". Так вот, если состыковать трубку-проводник с трубкой-полупроводником, а это можно сделать с помощью одного правильного пятиугольника и одного правильного семиугольника (показаны на картинке оранжевым цветом), то на трубке образуется колено. Изогнутая нанотрубка, как показывает эксперимент, является диодом.

РЕАЛЬНОСТЬ

Как же сейчас развиваются нанотехнологии? Пока существуют два направления: сканирующая микроскопия (и технологии на ее основе) и создание макроскопическими физико-химическими методами наноматериалов.

Сканирующая зондовая микроскопия, которая, кстати, у нас в стране находится на вполне мировом уровне - это исследование с помощью туннельных микроскопов новых материалов и биологических объектов. Нанометровый контроль поверхности вошел в производство таких вещей, как контактные линзы. Они не должны иметь микротрещины, иначе в трещинах аккумулируются болезнетворные микробы, способные негативно повлиять на здоровье человека. Выпускаемые серийно (в том числе и в нашей стране) зондовые микроскопы могут быть оснащены специальными жидкостными ячейками для контроля линз.


Спецвыпуск Xakep, номер #031, стр. 031-094-4, НАНОТЕХНОЛОГИЯ: МЕЧТЫ И РЕАЛЬНОСТЬ

НАНОТЕХНОЛОГИЯ: МЕЧТЫ И РЕАЛЬНОСТЬ

Pony (pony@xakep.ru)

Спецвыпуск Xakep, номер #031, стр. 031-094-4

Еще одним из применений сканирующей микроскопии является создание наноэлектронных приборов. Как известно, существует предел уменьшения традиционных микроэлектронных компонентов. Чем меньше они становятся, тем больше возрастает влияние квантовых эффектов на их функционирование. Эти эффекты приводят к возникновению ошибок. Для борьбы с ошибками вводятся дополнительные элементы, микросхемы усложняются и, как следствие, возрастает количество ошибок. Получается замкнутый круг. Наноэлектронные же приборы, основанные на квантовых принципах работы, ведут себя с точностью до наоборот. Чем меньше они становятся, тем лучше они работают, так как квантовые эффекты сильнее проявляют себя на сверхмалых расстояниях. Единственная трудность состоит в том, что при этом и изготавливать эти компоненты необходимо с точностью до атомов, иначе вся затея лишается смысла. Зато размер отдельного наноэлектронного транзистора может приблизиться к 20 нм, что вдохнет новую жизнь в тот самый никем не доказанный закон Мура, согласно которому с каждым годом должно происходить удвоение степени интеграции компонентов внутри чипов интегральных схем.

Как метод контроля сканирующая зондовая микроскопия по точности не имеет себе равных. С ее помощью можно обнаруживать отдельные атомы. И даже перемещать атомы и формировать из них группы. Однако все атомарные конструкции, созданные таким образом, уникальны и совершенно не подходят для массово производства устройств.

И тут на выручку приходят технологии создания наноматериалов. Кстати говоря, в России такие материалы называются "ультрадисперсными" и вот уже лет 40 используются в организациях и предприятиях атомной промышленности.

Известно, что при переходе к нанометровым размерам привычные для нас вещества начинают менять свои фундаментальные свойства. Это происходит из-за изменения соотношения поверхностных и объемных атомов индивидуальных частиц. Поверхность самого идеального кристалла может считаться большим двумерным дефектом (ведь на поверхности атомы с одной стороны ничем не связаны). Поверхностные атомы в общем случае находятся на более близких расстояниях друг от друга, чем атомы в объеме кристаллической решетки, и обладают повышенным запасом энергии. До определенного размера частиц доля этих атомов мала, их вкладом в общие характеристики вещества можно пренебречь. У наночастиц свойства поверхностных атомов становятся определяющими. С этих позиций наночастицами предложено считать образования, содержащие не более 1000 атомов и имеющие размер не более 10 нм. Такие вещества широко используются при создании новых типов композитных материалов, катализаторов и т.д.

Самым перспективным веществом для создания наноматериалов является углерод. Он обладает уникальными химическими свойствами (например, углерод - четырехвалентное вещество), необходимыми для создания больших молекул. К характерным наноматериалам относятся фуллерены и углеродные нанотрубки.


Спецвыпуск Xakep, номер #031, стр. 031-094-5, НАНОТЕХНОЛОГИЯ: МЕЧТЫ И РЕАЛЬНОСТЬ

НАНОТЕХНОЛОГИЯ: МЕЧТЫ И РЕАЛЬНОСТЬ

Pony (pony@xakep.ru)

Спецвыпуск Xakep, номер #031, стр. 031-094-5

Фуллерены были открыты в 1985 году и получили свое название в честь архитектора Бакминстера Фуллера, который придумал подобные структуры для использования их в своем архитектурном деле. Чтобы понять, как выглядит фуллерен, достаточно взять в руки футбольный мяч - он состоит из заплаток 5- и 6-угольной формы. Теперь, если представить, что в вершинах этих многоугольников сидят атомы углерода, то мы получим самый стабильный фуллерен С60. В конце 80-х, начале 90-х годов, после того как была разработана методика получения фуллеренов в макроскопических количествах, было обнаружено множество других как более легких, так и более тяжелых фуллеренов: начиная от C20 (минимально возможного из фуллеренов) и до C70, C82, C96, и выше.

В 1991 году, опять-таки совершенно неожиданно, были обнаружены длинные цилиндрические углеродные образования, получившие названия нанотрубок. Визуально структуру таких нанотрубок можно представить себе так: берем графитовую плоскость, вырезаем из нее полоску и "склеиваем" ее в цилиндр (реально нанотрубки растут совсем по-другому). Нанотрубки бывают самой разнообразной формы: однослойные и многослойные, прямые и спиральные. Они обладают необычными электрическими, магнитными и оптическими свойствами. Например, модуль Юнга (который определяет прочность материала на разрыв) у однослойной нанотрубки в 10 раз больше, чем у стали.

Спектр возможного применения нанотрубок очень широк. Уже в ближайшем будущем могут появиться эмиссионные мониторы с плоским экраном, в которых эмиттерами электронов будут углеродные нанотрубки. Другой пример - это использование нанотрубки в качестве иглы сканирующего туннельного или атомного силового микроскопа. Обычно такое острие представляет собой остро заточенную вольфрамовую иглу, но по атомным меркам такая заточка все равно достаточно грубая. Нанотрубка же представляет собой идеальную иглу диаметром порядка нескольких атомов.

В КАЧЕСТВЕ ЗАКЛЮЧЕНИЯ

При рождении практически любого научного или технического направления неизбежно возникают тысячи связанных с ним новых идей и проектов, большая часть из которых остается нереализованной, так как в жизни все оказывается гораздо сложнее, чем на бумаге (или в компьютере). Встающие на пути проблемы часто охлаждают пыл чрезмерных энтузиастов.

Кажется, когда-то все это уже было. Достаточно вспомнить освоение космоса. Отец космонавтики Циолковский, как известно, мечтал о полетах людей к звездам, заселении других планет. После первых успешных космических полетов царила эйфория, так и казалось, что до колонизации планет и даже до звезд рукой подать. Все это подстегивалось средствами массовой информации, выделялись огромные деньги. Но... радужные мечты со временем сошли на нет.

Не вызывает сомнений одно: Дрекслер своим творчеством добился главного - возбудил интерес общественности к нанотехнологии (которая, конечно же, может изменить картину мира уже в недалеком будущем), благодаря чему в эту сравнительно новую область потекли финансовые средства. Какие-то из его пророчеств, несомненно, сбудутся, а какие-то - нет...


Спецвыпуск Xakep, номер #031, стр. 031-098-1, РЕАКТИВНЫЙ РЕЗАК - Samsung CD-RW sw-252

РЕАКТИВНЫЙ РЕЗАК - Samsung CD-RW sw-252

Test-Lab

Спецвыпуск Xakep, номер #031, стр. 031-098-1

(test_lab@gameland.ru)

Здорова, пацаны и девчонки! Сегодня будем тестить новый девайс от фирмы Samsung, который является не чем иным, как новым резаком.

Вообще, компания несколько удивляет такой резкой экспансией практически на всех рынках. Складывается впечатление, что этак через пяток лет Samsung будет выпускать и чипсеты, и процессоры, и видюхи, и Бог знает что еще. Короче, народ будет сидеть на полностью самсунговских компьютерах, а то и ездить на их же машинах :) (я уж молчу про бытовую технику). Это, конечно, шутка, но все к тому идет.

Вернемся же к нашему устройству. Резак получился очень и очень неплохой. Впрочем, обо всем по порядку.

КОМПЛЕКТАЦИЯ

Девайс приехал к нам в Reatail варианте, то есть в красивой коробочке и со всем, что надо и не надо в комплекте. В коробке были обнаружены: сам резак (52х24х52) модели sw-252, два диска (на одном nero 5.5, на другом pdf с полным описанием девайса), шлейф UDMA 33, винтики и аудиошнурок для звуковушки. Не забыли и про ламоботов - в коробке был обнаружен красочный Setup Guide с полным описанием установки драйва в системник (куда что тыкать, как выставлять режимы, как вынимать из системника заглушку и т.д.).

ВНЕШНИЙ ВИД

Сам девайс имеет весьма симпатичный дизайн передней панели и подойдет к любому кузову (естественно, если кузов такого же цвета). На фейсе имеется гнездо для наушников, регулятор громкости, дырка для аварийного выковыривания диска и кнопка выкатывания "подставки под чашку", совмещенная с лампочкой. Последнее сделано очень прикольно: лампочка и кнопка стоят по отдельности, но расположены очень близко друг к другу, и так как кнопка сделана из полупрозрачного пластика, то когда горит лампочка, пимпа хайтечненько так подсвечивается.

Корпус драйва тоже не вызвал никаких нареканий - он сделан и собран очень добротно, отдельные части подогнаны хорошо, никаких щелей нет. Механика тоже на уровне, поэтому дисковод совсем не шумит - даже на максимальной скорости слышен только легкий свист.

ТЕСТ-ДРАЙВ

Теперь тесты. Девайс тестировали на разных болванках и на разных скоростях. Так как девайс недорогой, было решено тестировать на недорогих же болванках. Были куплены 24x CD-R Verbatim и технологические диски (по 4 рубля за штуку). Для записи использовали прогу Ahead Nero, которая идет в комплекте с драйвом.

Сначала была произведена попытка записать технологическую болванку на максимальной (52х) скорости. На диск был залит фильм размером 630 Мбайт. Запись пошла, никаких "фи!" по поводу болванки резак не высказал. На запись ушло ровно 2 минуты. Свежезарезанный диск послушно выехал, и поверхность болванки была подвергнута тщательному осмотру. В ходе исследования был выявлен очень интересный факт: в процессе записи резак наткнулся на плохой участок поверхности (техболванки и сами по себе то еще г... - а участок, видно, был совсем никакой) и пропустил (!) его, продолжив запись чуть дальше. При этом на болванке получилась этакая незаписанная "дырка". Этот факт, конечно, порадовал - если бы резак не проверил бы и не пропустил бы этот участок, то данные на нем прочитать было бы невозможно. Однако дальнейший тест показал, что болванка в целом записалась все равно плохо. Часть диска прожглась нормально (как раз за счет проверки и пропуска битого места), а остальные данные (в конце диска) записались с ошибками. Это можно объяснить так: скорее всего, умный девайс обнаружил, что поверхность в конце болванки тоже плохая, но пропустить ее не смог, так как в этом случае не хватило бы места для записи файлов.


Спецвыпуск Xakep, номер #031, стр. 031-098-2, РЕАКТИВНЫЙ РЕЗАК - Samsung CD-RW sw-252

РЕАКТИВНЫЙ РЕЗАК - Samsung CD-RW sw-252

Test-Lab

Спецвыпуск Xakep, номер #031, стр. 031-098-2

На втором этапе была снижена скорость записи (до 32х). Запись шла 3,5 минуты, но такая же техболванка записалась уже без проблем. В одном месте все же был подобный пропуск и несколько нестабильных дорожек, но все данные прочитались нормально.

Далее проводились тесты на болванках от Verbatim. На обеих скоростях (52х и 32х) диски записались просто отлично: ни одной ошибки, никаких проблем.

В завершение можно сказать несколько слов в защиту резака по поводу записи на техболванки. Они и вправду были ужасные - даже мой Plextor справляется с такими через раз, так что результаты, показанные самсунговским девайсом, можно считать очень хорошими. C перезаписываемой болванкой (Plextor 12x) резак справился на 5. Записанные данные великолепно читались, ошибок не было.

Все записанные болванки проверялись на читабельность не только самим резаком, но и древним 12х CD-ROM'ом неизвестного происхождения, который часто не читал и качественные диски. На нем прочитались все болванки, кроме первой, ее он прочитал только наполовину.


Спецвыпуск Xakep, номер #031, стр. 031-100-1, Линь и Вынь на разных компах в тишине

Линь и Вынь на разных компах в тишине

PAYALNIK Доктора Добрянского

Спецвыпуск Xakep, номер #031, стр. 031-100-1

Если у тебя есть свои радио-

-новости;

-приколы;

-методы;

-решения;

-инструменты;

-устройства;

-мнения,

поделись с нами. Прием радиомыслей на Dr.Cod@real.xakep.ru

новость: На этот раз паяльник получился жестко компьютерным, пиши мне, что ты об этом думаешь.

прикол: Хотел взять мышку, а схватился за горячий паяльник! Больно, блин!

метод: ЮНИКС, КОТОРЫЙ НЕ СНЕСЕТ ТЕБЕ СИСТЕМУ!

У многих перцев дома два компа: один новый, за которым сидишь, другой старый, который пылится в углу. Собственно, старый комп для чего-нибудь пригодился бы, но монитор, как правило, один, и все время тыкать туда-сюда шнуры заколеблешься. А перед двумя мониторами легко свихнуться.

Редким перцам удается жить только в Юниксе, без Винды не так-то просто обойтись. Потому ставят на одну тачку Линь и Вынь, ну и отсюда многие беды. Во-первых, нужно постоянно перезагружаться, а во-вторых, очень легко угробить Вынь, а там могут быть нужная инфа и программы. Когда мы с друзьями разбирались с FreeBSD, я купил себе подержанные салазки для HDD за 100 рублев и два бокса: на одном винте жила Фря, а на другом Винда. И они никак не могли помешать друг другу. Единственный минус - иногда салазки отходили, и винт глючил.

Если у тебя два компа, то на один можно поставить Линь, а на другой Вынь, соединить их через сетевые карты и кросс-кабель. Тогда можно будет управлять Линуксом через терминал из-под Винды. Если это тебе не очень удобно, можешь купить специальный двухпортовый Switch. Например, ATEN CS-12c, как у меня. К этой маленькой коробочке подключается монитор через D-SUB, мышь и клава через PS/2 разъемы. То есть мышь, клава, монитор - одни, а компов два и больше.

Теперь переключение происходит с клавиатуры двойным нажатием клавиши Ctrl. Получается, ты можешь работать в Винде, потом нажать Ctrl и переключиться в Линь, потом снова нажать Ctrl и переключиться назад в Вынь. При этом не надо менять клаву, мышь и монитор. Если у тебя в старом компе старый разъем для клавы, то понадобится переходник PC(M)-PS/2(F). Ну и, конечно, тебе также понадобятся две сетевые карты и кросс, чтобы наладить сообщение между компами. Думаю, проще и безопаснее будет поднять под Линукс или под Виндовс FTP-сервер для обмена файлами и не связываться с глючным SAMBA!

У кого-то могут возникнуть вопросы: «А не дает ли свитч помех на монитор?». Этот не дает, у меня сейчас 1024Х768@100Hz, и никаких глюков изображения нет. Хотя есть дешевые с механическим переключателем - они портят изображение. Питание переключателя осуществляется от цепи клавиатуры, поэтому какой комп раньше включил, тот и займет устройства ввода-вывода. ATX блок питания питает свитч, даже когда комп выключен.

Свитч поддерживает только клавиатуры с обычным набором кнопок и мыши со скроллом. Мой супер-пупер трекбол Logitech работал как обычная мышка со скроллом через свитч. Потому я пользуюсь одной клавой и двумя мышками, это не напрягает. Вот две клавы и одна мышка могут свести с ума :).

Если пораскинуть мозгами, то на двух компах могут быть Linux/Linox, Windows/Windows, а не только Windows/Linux. Ты можешь сделать для себя настоящий испытательный полигон и опробовать многие хакерские методы. Причем свитч можно купить более чем на два порта! Ну и еще одна идея: один комп может быть тихим, а другой может быть мощным. Один ты включаешь, чтобы работать в тишине, а другой - чтобы играть в игры. Словом, настоящему хакеру нужно рабочее место с двумя компами сразу!


Спецвыпуск Xakep, номер #031, стр. 031-100-2, Линь и Вынь на разных компах в тишине

Линь и Вынь на разных компах в тишине

PAYALNIK Доктора Добрянского

Спецвыпуск Xakep, номер #031, стр. 031-100-2

решение: БЕСШУМНЫЙ КОМП!

Сбылась моя мечта, я собрал себе бесшумный комп! Большинство компьютерщиков под бесшумным почему-то понимают компустер с тихими вентиляторами. С этим можно согласиться только при условии, что вентиляторы будут менять или смазывать раз в месяц. Я перепробовал много вентиляторов: даже на пониженных оборотах, даже смазанные, даже специально купленные дорогие вентиляторы на шариковых подшипниках начинают сильно шуметь через некоторое время. Не говоря о том, что шумит воздух, идет резонанс от работы мотора.

Хочу успокоить и тех, кто мечтает о водяной системе охлаждения: там есть компрессор для перекачки воды и вентилятор на радиаторе холодильника. То есть имеется два электромотора, которые тоже будут шуметь и резонировать. И потом, я пока не встречал водяную систему охлаждения для блоков питания. А там вентилятор достаточно шумный. Всякие системы подавления шума в блоках питания безобразно проигрывают безвентиляторному питалу: работающий мотор всегда громче отключенного. Итак, решено: по-настоящему тихий компьютер БЕЗ ВЕНТИЛЯТОРОВ вообще!

Начинать все надо с выбора процессора! Он должен быть не очень производительным, но с применением технологии 0,13 микрон. Чем меньше минимальный литографический размер (МЛР), тем короче проводящие участки на кристалле, тем меньше сопротивление, тем меньше он греется! Также не надо гнаться за высокими частотами, поскольку основное потребление мощности идет как раз во время переключения транзисторов. Кроме того, на высоких частотах поднимают напряжение на ядре, чтобы улучшить фронты сигнала и сделать работу устойчивее.

Итак, я выбрал INTEL Celeron 1300A на ядре Tualatin (0.13 микрон). Была идея взять AMD на ядре Barton, но это один из самых современных процов, который стоит несколько сотен космокредов. Зато Barton умеет отключаться от шины, когда его не используют, и потому должен очень мало греться на небольших нагрузках! Еще была идея использовать процессор VIA C3 1GHz на ядре Nehemiah. Однако такого камня я не нашел в московских магазинах. Ну и потом процессоры VIA С3 сильно сливают аналогичным INTEL Celeron по производительности (http://www.ixbt.com/cpu/via-c3-nehemiah.shtml). Хотя для офисных компов VIA C3, наверное, неплохое решение.

Многие ругались, что я взял PIII, но я считаю, что этой вычислительной мощности для меня вполне достаточно, то есть все работает без тормозов, даже Photoshop. Над выбором мамки я не думал - взял легендарную оверклокерскую ASUS TUSL2-C (http://www.overclockers.ru/news/newsitem.shtml?category=2&id=1016353845).

На процессор поставил медный позолоченный радиатор ZALMAN, но не очень им доволен. А вот с блоком питания ошибся: POWER MAN FSP300-60BTV(PF). Когда я его открыл - обнаружилось, что у одного из радиаторов отпилено больше половины! А один из силовых транзюков вообще висит на радиаторе размером с ноготь. То есть без вентилятора этот блок работал очень стремно, все нагревалось градусов до 80-ти. Сначала я хотел менять радиаторы, но не нашел подходящих. А чертов вентилятор даже на пониженных оборотах гудел! Тогда я нашел дома несколько массивных кусков металла и привинтил их струбцинами к радиаторам. Для лучшего термоконтакта я подложил между ребристой поверхностью радиатора и куском металла алюминиевую фольгу. А в качестве теплоотвода для радиатора «с ноготок» я использовал медицинский зажим. В результате блок питания перестал вообще греться выше 40 градусов - чуть теплый с отключенным вентилятором! Теперь я мечтаю поставить огромный тяжелый радиатор на проц, так как с ZALMAN он греется до 50-70 градусов в зависимости от температуры на улице и нагрузки на процессор. Пришлось понизить частоту до 866 MHZ, иначе бы все грелось до 80-ти. Если будет тормозить какая-то игрушка, то можно снова повысить частоту до 1300MHz и включить процессорный вентилятор в тихом режиме.


Спецвыпуск Xakep, номер #031, стр. 031-100-3, Линь и Вынь на разных компах в тишине

Линь и Вынь на разных компах в тишине

PAYALNIK Доктора Добрянского

Спецвыпуск Xakep, номер #031, стр. 031-100-3

Памяти я взял 512 метров (это максимум, на что способна мамка), а винт Seagate Barracuda ATA IV (ST380021A) - по данным http://www.silentpcreview.com/, это один из самых тихих HDD. Однако и его пришлось положить на сложенное полотенце, чтобы не сильно резонировал.

Видео пока что MX200 32MB, однако я планирую в ближайшее время разжиться Sapphire Radeon 9000, который без вентилятора.

Итак, получился безвентиляторный комп, в котором самое громкое - шум вращения шпинделя винчестера и изредка слышимое еле заметное поскрипывание головок. Минус в том, что комп не убран в корпус, однако я пока и не думаю его убирать, поскольку постоянно приходится что-то туда втыкать.

Доктор Добрянский не несет ответственности за любой вред, принесенный в результате использования опубликованной информации. Все методы и схемы даны только в ознакомительных целях.


Спецвыпуск Xakep, номер #031, стр. 031-102-1, ДУЭЛЬ

ДУЭЛЬ

Спецвыпуск Xakep, номер #031, стр. 031-102-1

Зачем топтать мою любовь,

Ее и так почти не стало.

Я разбиваю руки в кровь,

Я не сошел с ума, так надо...

"З.Т.М.Л." - "Смысловые галлюцинации"

Противостояние - довольно неприятная штука. Я прочувствовала это на своей шкуре, когда инсталляция закончилась. Я впервые увидела Аллена, и ощущение знакомства с ним не покидало меня с тех пор ни на секунду. Несомненно, я знала его раньше. Его и подобных ему. Таких же, как он, упорных, мужественных, воинственных, готовых к испытаниям, трудностям, боям и лишениям.

Моя сущность направлена на то, чтобы людям, подобным Аллену, было максимально комфортно; чтобы они шли к своей цели, достигая ее с минимальными потерями; чтобы они преодолевали трудности, набираясь опыта, приобретая новые навыки.

Сам принцип моего существования нельзя оспорить. Я необходима всем, даже тем, кто никогда обо мне не слышал. Просто их время еще не пришло. Но и у меня есть недоброжелатели.

Когда присутствуют две полярные точки зрения на одну проблему, то сразу возникает желание что-либо доказывать. Всеми возможными способами.

А если встречаются две равных по возможностям силы, предсказать развитие ситуации невозможно. Мне придется потрудиться... И одному Аллену не справиться. Надо что-то придумать. У меня уже есть кое-какие идеи; постараюсь воплотить их в... В жизнь, что ли? А ведь это достаточно абсурдно, но зато как звучит.

Лишь бы все получилось.

Слава Богу, видеокарта достаточно мощная.

* * * * *

ПРИСУТСТВИЕ ЧУЖОГО ВЗГЛЯДА В СПИНУ НЕ ПОКИДАЛО НИ НА СЕКУНДУ. Это было самым отвратительным в каменных джунглях мертвого города. Аллен уныло брел по широкому проспекту, заваленному каменными обломками домов, рухнувших после взрыва на оборонном заводе. Он не помнил, как все здесь выглядело раньше, да это и не интересовало его в настоящий момент. Он продвигался вперед по широкой разделительной линии и пинал ногами мелкие камни, долетевшие от покосившихся стен к середине проспекта. Вокруг стояла отвратительная тишина, которую шаги Аллена не могли нарушить больше, чем на мгновенье.

"Еще две тысячи шагов - и эта улица упрется в шоссе, ведущее на запад, - думал Аллен, угрюмо качая головой. - А потом я начну считать заново..."

И вновь он почувствовал, как кто-то смотрит в спину. Аллен уже знал, что останавливаться и оборачиваться бессмысленно, однако именно так и поступил, не мог не поступить. Остановился и оглянулся. Никого.

Далеко назад уходил прямой, как взлетная полоса, проспект без названия. Кстати, это было вторым по силе мерзким ощущением в городе - отсутствие названий улиц, номеров на домах, дверных ручек и домашних животных. Углы зданий были стерильными - ни одного знака, ни одной надписи. Правда, иногда попадались огромные красные стрелы с непонятными словами над ними, но после второго десятка таких стрел Аллен перестал подходить к ним ближе в надежде прочитать. Бессмысленное занятие.

Внимательно оглядев прилегающие к дороге дома и попытавшись заглянуть едва ли не в каждое окно первых этажей, Аллен вновь продолжил свое кажущееся уже бесконечным путешествие. Ему вдруг захотелось, чтобы проспект перед ним перебежала черная кошка - на фоне полного отсутствия зверья в городе это не показалось бы ему плохим предзнаменованием, скорее разнообразило бы картину мертвого города.


Спецвыпуск Xakep, номер #031, стр. 031-102-2, ДУЭЛЬ

ДУЭЛЬ

Спецвыпуск Xakep, номер #031, стр. 031-102-2

Горизонт был мрачен. Аллену казалось, что скоро он войдет в полосу дождя. Учитывая факт отсутствия чего-либо, напоминающего зонтик, - грустная перспектива. Тем более, что кожаный плащ... Какой замечательный был плащ! Аллен замысловато выругался, помянув качество выделки кожи; через пару секунд он выругался еще более витиевато, когда вспомнил, что в его внутреннем кармане осталась "Беретта".

Два часа назад он оставил свой плащ в одном из домов в самом начале проспекта. Он никогда не видел сразу столько этих уродов - около тридцати. Когда они поперли на него из прилегающих к тротуарам подвальных окон, Аллен едва успел снять с плеча автомат. Отстреливаться приходилось короткими очередями, дабы сохранить патроны, которых на тот момент было крайне мало.

Бой был быстротечен. Аллен стремительно внес неразбериху в строй нападавших; несколько уродов споткнулись о трупы тех, кто погиб первыми. Ядовитые иглы периодически посвистывали рядом с Алленом, но он не реагировал на них, убедившись в том, что у него выработалось что-то вроде иммунитета. В течение всего марша через Туранское ущелье и большой и мертвый Туран в него попадали шесть раз. После первого он провалялся под большим деревом около двух часов (а когда очнулся, ужаснулся тому, что увидел, - в бреду он грыз свою собственную левую руку, совершенно не чувствуя боли). Второе попадание он перенес уже легче; после пятого он понял, что бояться нечего, хотя бинтовал левое предплечье мешковиной, когда ожидал боевого столкновения, - боялся, что снова будет рвать зубами руку и умрет в бреду от кровотечения.

Несмотря на довольно меткую стрельбу, Аллену пришлось забежать в подъезд и подняться на второй этаж. Он не любил этого делать, но в данной ситуации выбора не было - ему просто необходимо было уменьшить угол обстрела, чтобы процент попаданий вырос до максимального. Когда около пятнадцати уродов сгрудились на площадке между этажами, пытаясь задавить его своей массой и просто-таки тучей игл, периодически застревающих в толстой коже плаща, - его стрельба стала еще более эффективной. Он даже успел сменить магазин - настолько неудачно расположились его противники. Куча мертвых тел не давала задним рядам пробираться выше.

На секунду представив, как потом будет выбираться на улицу через зловонную груду трупов, Аллен быстро оглянулся и отметил, что окно площадки выходит на козырек над входом в подъезд.

"Уже лучше", - сквозь зубы произнес он и продолжил стрельбу. Скоро все закончилось. Последний из уродов издал мерзкий рыгающий звук и даже не повалился, а прислонился к своим погибшим собратьям. Аллен поспешил наружу.

Выбив сапогом стекло, он постарался протиснуться в образовавшийся проем и тут же услышал противный скрежет - кожа плаща на спине омерзительно скрипела, расходясь двумя лоскутами на остром, как бритва, осколке. Внезапно режущая боль пронзила спину - качнувшись на подоконнике, Аллен не сумел сохранить равновесие и прижался к осколку еще сильнее. По спине заструилась неприятная теплая струйка.


Спецвыпуск Xakep, номер #031, стр. 031-102-3, ДУЭЛЬ

ДУЭЛЬ

Спецвыпуск Xakep, номер #031, стр. 031-102-3

Балансируя на одной ноге, стоящей уже на козырьке, Аллен аккуратно отложил автомат в сторону, чудом сумел снять рваный плащ, пролез дальше и тут же получил иглу в спину от очередного урода, вошедшего в подъезд. Толчок был внушительный; Аллен слетел вниз, на бетон. Через мгновение он понял, что автомат находится на подоконнике.

Его спасло только то, что тварей осталось всего две. Одна из них уже свешивалась из окна подъезда, вторая оказалась в метре от него после падения на дорогу. Он выхватил из-за голенища штык-нож и махнул им на уровне горла того урода, что уже стал тянуть к нему когтистую лапу с иглометателем. Желто-коричневая жидкость с противным запахом рванулась наружу из сосудов; рука с ножом совершила привычное движение, обтерев лезвие о бедро. Еще две иглы в спину. Плаща не было, иглы достигли цели; тошнота очень быстро подступила к горлу. Делать было нечего - через несколько секунд он мог упасть на бетон, отравленный большой дозой яда, столько игл сразу он не принимал на себя с начала пути.

Аллен развернулся и швырнул нож в оконный проем - туда, откуда виднелась шипастая фигура твари. Лезвие вонзилось в правый глаз; та же самая желтая жидкость тоненькой струйкой просочилась из разорванного глазного яблока. Тварь пыталась ухватиться за оконную раму, но силы оставили ее; серо-зеленое тело перевалилось через край и полетело вниз, зацепив длинным когтем порванный плащ. Отступив на пару шагов назад, Аллен с тоской взглянул на свою защищавшую от игл одежду, послужившую саваном для твари, потом очнулся от угара боя и кинулся к стене дома - содержимое желудка рванулось наружу.

Когда головокружение и рвота закончились, ослабевшей рукой Аллен нащупал в спине иглы и выдернул их, едва сумев сдержать стон. Как только источник отравы покинул организм - стало намного легче. Мушки, уже начавшие летать перед глазами, куда-то подевались; оттолкнувшись от стены, Аллен принял вертикальное положение и огляделся по сторонам.

Происходило то, что ему очень и очень не нравилось за все последние двадцать шесть часов его жизни. Происходило то, чему не могло быть объяснения; то, чего Аллен ну никак не мог понять, как ни старался. Трупы тварей ИСЧЕЗАЛИ.

Вроде бы вот они еще здесь, рядом с тобой. Еще залит бетон проспекта их отвратительной желтой кровью; еще шуршат под сапогами иглы, не достигнувшие цели; их мутные, остекленевшие глаза со ставшими огромными после смерти зрачками неподвижно упираются в небо. И вдруг контуры их тел становятся нечеткими, словно у тебя что-то с глазами; будто песка в них надуло, потекли слезы, размазывая все перед тобой. Твари кажутся воспарившими над бетоном на пару-тройку сантиметров - ничтожно мало, но, тем не менее, заметно (когда Аллен увидел это впервые, у него возникло ощущение невесомости, он был вынужден схватиться за корни дерева, возле которого отдыхал после короткого боя). Спустя несколько секунд вихрь радужного сияния подхватывал тела погибших шипастых уродов и, немного покружив их на месте, растворял в себе. Твари исчезали в разноцветном круговороте; исчезали иглы, пятна крови, куски тел, разорванных гранатами...


Спецвыпуск Xakep, номер #031, стр. 031-102-4, ДУЭЛЬ

ДУЭЛЬ

Спецвыпуск Xakep, номер #031, стр. 031-102-4

Аллен закусил губу, но не отводил взгляда от этой цветной круговерти. Почему-то это было очень, очень, ОЧЕНЬ неприятно, но не смотреть было нельзя.

Когда он вошел в подъезд, чтобы забрать автомат, - там уже было пусто. Ему не пришлось перешагивать через трупы, он спокойно поднялся по лестнице до разбитого окна, взял оружие за еще теплый ствол, любовно погладил цевье и взглянул в контрольное отверстие магазина. Патроны еще были.

По привычке подергал пару дверей на площадках - как всегда, бессмысленно. Людей нет, все заперто. Отошел на несколько шагов, разбежался, в прыжке приложился к двери ногой. Едва не вывихнул бедро - так силен и так одновременно бесполезен был удар. Дверь не пошевелилась, словно за ней была каменная стена.

Прихрамывая, Аллен вышел на улицу и отправился по проспекту дальше, даже не вспомнив о том, что забыл в плаще пистолет...

"Тысяча триста пятнадцать... Тысяча триста шестнадцать..." - бубнил себе под нос Аллен, с каждым шагом чувствуя, что автомат становится все тяжелее. Уже не такой интересной казалась ему мысль пинать попадавшиеся на дороге камешки; уже не так внимателен он стал по отношению к окружающим домам, чьи подвалы были наполнены смертью. Очень хотелось пить.

ВЗГЛЯД, СВЕРЛЯЩИЙ СПИНУ, РАЗДРАЖАЛ ВСЕ БОЛЬШЕ И БОЛЬШЕ. Просто оглядываться уже не хотелось, хотелось повернуться и выпустить туда, в сторону невидимых глаз, все оставшиеся патроны и ждать, когда же твари примчатся на пир. Но где-то внутри него сидел очень практичный, трезвомыслящий участок мозга, который вовремя останавливал Аллена и направлял его мысли по другому пути.

"Какого черта меня несет туда, к перекрестку? - спрашивал Аллен сам у себя и не находил ответа. - Я ведь почти не помню задания. Хотя нет - самолет, самолет..."

Это было действительно так, он плохо помнил исходные данные. После первого шока от иглы он очнулся практически стерильным; лишь где-то на краю сознания осталось понимание личности, память об имени и умении стрелять. А еще осталось то, что остается у всех людей, потерявших память частично, - то самое гнетущее ощущение, что ты что-то забыл и не можешь вспомнить, что именно. И вот уже немногим больше суток, пережив день и ночь в непонятном, запутанном мире, он по-прежнему пытался вспомнить, что же, кроме самолета, должно ждать его там, в конце хай-вэя, идущего на запад...

* * * * *

Крыша небоскреба, горячая от прямых солнечных лучей, казалась бесконечной во все стороны. Солнце палило нещадно, очнувшись от долгого бездействия за низкой облачностью.

Погода улучшилась буквально полчаса назад; дунул сильный северный ветер, взявшийся практически из ниоткуда. Облака разметало во все стороны, словно по приказу свыше. Пластик, в который была закатана крыша, раскалился мгновенно; марево над ней колыхалось, словно огромная лужа.


Спецвыпуск Xakep, номер #031, стр. 031-102-5, ДУЭЛЬ

ДУЭЛЬ

Спецвыпуск Xakep, номер #031, стр. 031-102-5

Если подойти к самому краю и взглянуть вниз, то не очень далеко на западе, там, где проспект примыкал к хай-вэю, можно было увидеть одинокую фигурку усталого, еле переставляющего ноги человека в джинсах и футболке, тащившего в руке бесполезный автомат. Опустив голову вниз, этот человек брел строго по средней линии проспекта, ни на сантиметр не сходя с нее в сторону. Изредка он останавливался, замирал на мгновенье, поднимал голову, а потом резко оглядывался. Судя по всему, за спиной у него ничего не было, ибо он каждый раз разочарованно качал головой, вздыхал и продолжал свое путешествие.

Наблюдать за ним достаточно интересно, как за неким микробом, постепенно переползающим по предметному стеклу микроскопа. Сквозь пелену горячего воздуха он периодически казался призрачным, тающим. Но стоило дунуть ветру, и его фигурка вновь обретала четкость.

До перекрестка оставалось около ста метров, когда человек в очередной раз остановился, резко оглянулся и, вскинув автомат к плечу, выпустил длинную очередь туда, где ему виделись какие-то призраки. По звуку стрельбы, внезапно прекратившейся, было ясно, что это не стрелок убрал палец с курка, нет, судя по всему, кончились патроны в магазине. Автомат полетел на бетон. Человек погрозил кулаком туда, куда унеслась его очередь, прокричал что-то, плохо слышное на таком расстоянии, и направился дальше, к хай-вэю.

Существо, наблюдающее за Алленом с крыши семидесятиэтажного небоскреба, нельзя было назвать человеком, да оно и не было им. Увидев, как Аллен отшвырнул автомат, существо произнесло скрипучим голосом:

- Задача становится проще...

После чего шагнуло с небоскреба вниз.

И на мгновенье над всем этим странным городом в небе проступили огромные серо-зеленые ЧЕЛОВЕЧЕСКИЕ глаза.

* * * * *

Когда в автомате кончились патроны, Аллен особенно не расстроился. К тому времени он уже устал настолько, что оружие его интересовало только с позиции его веса. Автомат сухо лязгнул о бетон проспекта; Аллен плюнул на него, погрозил кулаком туда, где постоянно сверлил спину невидимый взгляд, и закричал:

- Хватит подглядывать, ГАДИНА!

Эхо, отразившееся от стен разрушенных домов, немного успокоило Аллена. Он повернулся лицом к перекрестку и сделал несколько шагов. Ощущение взгляда исчезло, но Аллен особо не расслабился. Так было всегда; через несколько минут все вернется на круги своя, опять сверло чужих глаз будет давить ему между лопаток. Перекресток тем временем приближался.

Когда Аллен вышел на него, равнодушно разглядывая светофоры по углам, выяснилось, что хай-вей идет не только на запад, но и на восток, просто там дорога была явно похуже, бетон казался щербатым, из трещин кое-где пробивалась трава.

Неподалеку стояли два покореженных "Форда", въехавшие один другому в бок. Один из них до аварии был явно аккуратно припаркован у тротуара, водитель же второго пошел на таран по неизвестным причинам. Сознание Аллена заскребла одна маленькая, но неприятная мысль; он подошел к машинам поближе и убедился, что в них никого нет, несмотря на огромное кровавое пятно на лобовом стекле того "Форда", что нанес удар.


Спецвыпуск Xakep, номер #031, стр. 031-102-6, ДУЭЛЬ

ДУЭЛЬ

Спецвыпуск Xakep, номер #031, стр. 031-102-6

Продолжая смотреть по сторонам, Аллен обнаружил несколько разбитых витрин в магазинах, находящихся в углах домов, образующих стороны перекрестка. И вновь там никого не было - просто разбитые стекла, россыпь осколков, погасшая световая реклама. Войти внутрь Аллен не решился - двери были заперты, а пролезать сквозь острые края торчащих во все стороны кусков витражей он поостерегся, вспомнив судьбу своего плаща.

Еще Аллен отметил четыре дерева, засохших, практически без листвы, но все-таки еще живых (в этом он убедился, подойдя к одному из них поближе и прикоснувшись к коре). Они стояли коротким рядком на противоположной стороне Т-образного перекрестка, там, где Аллен заметил велосипед. Абсолютно ненужная деталь - велосипед... Рассчитанный на мальчишку лет десяти-двенадцати, он был достаточно небрежно прислонен к одному из деревьев, словно хозяин вот-вот вернется.

Аллен вышел на самый центр пересечения магистралей и медленно повернулся на триста шестьдесят градусов. Перед его глазами постепенно прошел весь перекресток - разбитые витрины, столкнувшиеся автомобили, абсурдная рощица и никому не нужный велосипед. Очередной порыв ветра подарил Аллену еще одну мысль: вместе с сильными дуновениями горячего воздуха ему очень не хватало парящей на ветру смятой старой газеты или пустого мусорного пакета, этих великих признаков городской цивилизации. Он стоял и думал, думал...

И когда ему захотелось произнести вслух тот вывод, к которому он пришел, дверь АБСОЛЮТНО ПУСТОГО "Форда" отворилась, и из него вышла девушка. Аллен машинально отступил на шаг и тут же забыл обо всем, о чем думал.

Несмотря на всю проблематичность ситуации, мрачный горизонт и полное отсутствие оружия, вид этой девушки заставил Аллена на несколько мгновений отрешиться от окружающего мертвого города и полностью сосредоточиться на ней. Она была высока, стройна и чертовски привлекательна своими огромными серыми глазами и короткой, почти мальчишеской стрижкой. Сделав пару шагов от двери "Форда" по направлению к Аллену, она остановилась, медленно несколько раз сжала и разжала кулаки, словно разминая уставшие пальцы; потом аккуратно повращала головой (Аллен отчетливо услышал короткий впечатляющий хруст ее шейных позвонков).

Тонкими холеными пальцами она взялась за замок "молнии" на кожаной куртке, увидела, как Аллен просто впился глазами туда, где контурировалась ее высокая грудь, и усмехнулась. Замок взвизгнул; Аллен непроизвольно вздрогнул. Под курткой оказалась темно-синяя футболка. Нижнего белья под ней явно не было; зато за поясом проступила рукоятка какого-то большого пистолета неизвестной Аллену модели.

Вид оружия отрезвил Аллена. Он вдруг вспомнил, что абсолютно безоружен, и от этого ему стало очень и очень неуютно под взглядом девушки, рассматривающей его с каким-то непонятным интересом (при этом Аллен не мог решить, что же она видит перед собой - человека или мишень).

Опять пришло ощущение взгляда в спину. За последнее время Аллен научился различать даже выражение ни разу так и не увиденных глаз - в зависимости от ситуации. В настоящий момент взгляд должен был быть удивленным, отчего Аллен впервые почувствовал, что ситуация находится не в руках того типа, что смотрит за ним, на какое-то время Аллен вышел из-под контроля и, судя по всему, именно из-за присутствия здесь этой красавицы-амазонки.


Спецвыпуск Xakep, номер #031, стр. 031-102-7, ДУЭЛЬ

ДУЭЛЬ

Спецвыпуск Xakep, номер #031, стр. 031-102-7

Девушка картинно широко расставила ноги, обтянутые кожаными брюками, уперлась в бетон тонкими металлическими "шпильками" и сложила обе ладони на рукояти пистолета. Аллен не мог оторвать от нее взгляд, и не потому, что все это было чертовски сексуально, а он так давно не видел женщин в этих каменных джунглях - он чувствовал в ней УГРОЗУ. И даже взгляд, сверлящий спину, не пугал его так, как эта неизвестно откуда взявшаяся девушка.

С момента ее появления прошло всего минута-полторы, а казалось, что Аллен смотрит на нее бесконечно долго. Тем временем "кожаная" незнакомка, мило улыбнувшись во все тридцать два зуба, огляделась по сторонам. Изящные движения ее точеной шеи несколько расслабили Аллена и заставили его вспомнить, что он все-таки мужчина. Он неловко откашлялся, чем привлек к себе внимание девушки; она резко повернула голову в его сторону, словно на звук выстрела.

- Прошу прощенья... - начал было Аллен, но тут произошло непредвиденное - ладони девушки напряглись на рукояти пистолета, она медленно вытащила его из-за пояса, крепко обхватила ладонью правой руки, а левую спрятала за спину.

- ЗАМОЛЧИ! - произнесла очаровательным милым голосом незнакомка свое первое слово.

А потом она вытянула руку с пистолетом в сторону Аллена и нажала курок.

* * * * *

Я помню свое первое впечатление от осознания того, что ЗАВИСТЬ пронизала всю мою суть сверху донизу. Это случилось на подходе к Туранскому ущелью - Аллен попал в свою первую настоящую переделку...

Я видела тогда эти глаза... Глаза, которые потом стали для него чем-то вроде обязательного условия, без которого немыслимо было существование. Конечно же, они были человеческими - И ОДНОВРЕМЕННО НЕТ. Главным отличием их от обыкновенных глаз было наличие в них чего-то отвлеченного, какой-то оторванности от реалий этого мира. Взгляд Будды... Да, мне кажется, это наиболее близкое по качеству определение, но лишь по качеству. В целом этот взгляд был безумным, лишенным индивидуальности; словно луч электровоза, скользящий поверх голов, деревьев, мостов...

В цвете глаз мы с Алленом не ошиблись - они были серо-зеленые. Достаточно неприятный цвет. Но это все очень субъективно, вы меня понимаете. Я помню, как он все время пытался оглянуться. Я его прекрасно понимаю, ибо между ним и мной всегда, я повторяю, ВСЕГДА было одно существенное отличие, в конце концов заставившее меня сделать то, что я сделала. Вся соль в том, что, в отличие от Аллена, я могла встретиться с этими серо-зелеными кругами взглядом. Я могла посмотреть в них, погрузиться в них, слиться с ними... Вот насчет последнего я, пожалуй, погрешила против истины. Слиться с ними мне не удавалось, особенно после появления Аллена в Туранском ущелье.


Спецвыпуск Xakep, номер #031, стр. 031-102-8, ДУЭЛЬ

ДУЭЛЬ

Спецвыпуск Xakep, номер #031, стр. 031-102-8

Посчитаем это точкой отсчета. Вот Аллен появляется... Вот он берет в руки автомат... Я вижу это, как сейчас: глаза проступают на небосклоне, эти две Луны, полные болотной тины. И как только он первый раз нажимает на спусковой крючок, для меня все сразу заканчивается. Я смотрю в эти глаза и понимаю, меня никто не видит. Никто. Я не нужна никому. Я лишь игрушка, объект насмешек и издевательств. А ведь если бы не я...

И тогда я совершила свой первый противоестественный поступок. Я изобрела новый закон природы, кибернетики, жизни, эволюции и логики. До меня этого не делал никто. Я первая сумела взять в руки оружие. Я приравняла себя к Аллену и создала Существо.

Теперь, когда все позади, я понимаю, победить в этой гонке не мог никто. Так устроен мир. Стоит одному из нас уподобиться Богу, и противник сразу же обретает все, что знаешь ты, и еще чуть-чуть. Мое преимущество было минимальным, кратковременным. Аллен... Он сумел выкарабкаться. Правда, не сам. Но не в этом суть.

Господи, как я устала! Кто-нибудь, нажмите "Shutdown"!

* * * * *

Приземление было мягким; сам момент прикосновения к бетону у подножия небоскреба оказался практически незаметным. Просто горизонт перестал приближаться и смещаться вверх; существо твердо встало на... На то, что для него было ногами. Металлический блеск парой сверкающих волн промчался по его телу.

- Я помню, - само себе сказало существо. - Я не дам ему дойти.

Бетон под ногами (все-таки есть смысл остановиться именно на этом термине, чтобы не сбиваться дальше на словесную чепуху) тихо шуршал. Существо видело то, чего не видел Аллен, - маленьких вездесущих муравьев, живые травинки, летящие по воздуху пушинки одуванчиков. Иногда в окнах домов появлялось чье-то испуганное лицо, внимательно следившее за существом из-за задернутой занавески.

Это не отвлекало. Напротив, создавало какой-то забавный фон. Несколько раз существо останавливалось и пыталось встретиться глазами с этими пугливыми наблюдателями. Шторы тут же задергивались наглухо; иногда это были не шторы, а жалюзи - они падали сверху с таким шумом, что слышно было даже на улице.

Тело существа отбрасывало на стены домов множество солнечных зайчиков. Блики плясали в окнах и витринах. Выбрав единожды правильное направление, оно уверенно двигалось туда, где была цель. Через несколько минут под ногами существа оказался брошенный автомат.

Возникла секундная заминка. Оружие могло пригодиться, но не было патронов. Что еще хуже, не существовало чего-либо подобного рукам, чтобы взять его. Металлические волны метнулись вдоль тела, брызнуло несколько искр.

- Предложения? - обратилось существо к пустоте вокруг себя; воздух сгустился, загудел. - Пока наши с ним шансы примерно равны...

Автомат скрылся в густой пелене горячего воздуха, внезапно сделавшегося непрозрачным. Существо неподвижно смотрело туда, где искрился мутный поток чего-то неизвестного; пару раз лязгнул металл, раздался звук передергиваемого затвора. Потом вращающаяся пелена внезапно опала, и существо увидело автомат снова. Сознание подсказало, что он заряжен.


Спецвыпуск Xakep, номер #031, стр. 031-102-9, ДУЭЛЬ

ДУЭЛЬ

Спецвыпуск Xakep, номер #031, стр. 031-102-9

В следующее мгновенье существо наклонилось вперед и протянуло к оружию... К тому, что служило руками, можно было отнестись по-разному, но ведь ноги тоже не были ногами в полном смысле этого слова. Автомат удобно лег в некое приспособление для стрельбы стоя, которое само собой выдвинулось из тела по первому требованию организма, благодарно сверкнувшего в ответ на это бликами солнца.

- Теоретически это меня устраивает, - удовлетворенно пробормотало существо. - И не надо бредить шат-дауном.

Вновь под ногами зашуршал бетон. Мироощущение не изменилось с появлением оружия в руках; существо было полностью индифферентно к происходящему, хотя периодически не забывало играть в "гляделки" с пугливыми жителями города.

Перекресток приближался. Существо двигалось с достаточной скоростью, достаточной для того, чтобы не отстать от уходящего Аллена. Оно не ощущало ни жары, ни ветра - металл тела реагировал на изменения погоды одинаково равнодушно. Вдали показался Т-образный перекресток с четырьмя засыхающими деревцами на противоположной стороне.

Аллен стоял спиной к приближающемуся существу с автоматом посредине пересечения дорог и внимательно разглядывал стоящую рядом с разбитым "Фордом" девушку в кожаном костюме. Сексуальная брюнетка с короткими волосами медленно расстегнула куртку и обнажила рукоять пистолета.

- Убей Аллена, - тихо сказало себе существо и направило ствол автомата ему в спину. Пистолет прыгнул из-за пояса девушки в ее изящную тонкую руку. Аллен как-то нелепо втянул голову в плечи, словно в него попали снежком и ледяные струйки потекли по спине. Прогремел резкий, создавший многоголосое эхо выстрел.

Существо так и не успело ничего предпринять. Пуля вышибла автомат из его металлических конечностей, до этого мгновения державших оружие достаточно цепко. После рикошета основной удар тупого свинцового наконечника пришелся в тело существа - в переплетение каких-то труб, пружин, сверкающих шарнирных соединений. Автомат загрохотал, ударившись о бетон. Грохнул еще один - на этот раз случайный выстрел, порожденный ударом при падении. Автоматная пуля взвизгнула, улетая куда-то в сторону; с хрустом осыпалось стекло одной из витрин.

Аллен бросился на землю, откатившись с линии стрельбы. Девушка ни на миг не изменила своей позы; ее сверкающие глаза глядели туда, откуда пришло существо с автоматом. Она медленно повела стволом из стороны в сторону, после чего опустила руку с оружием вниз. Сзади раздался лязг - что-то тяжелое, железное упало на дорогу.

Аллену удалось, лежа, из-под руки взглянуть назад. Нечто непонятное, невообразимо запутанное, все в металлических тонких трубах лежало на бетоне перекрестка на стоп-линии, неловко шевелилось и пыталось дотянуться до автомата, что было практически невозможно - слишком велико было расстояние и слишком слабо существо.

Потом чья-то сильная рука с тонкими пальцами (Аллен сразу понял, чья это рука) дернула его вверх за воротник. Чтобы не задохнуться, Аллену пришлось засучить ногами, рвануть свое тело от земли, и он встал, оказавшись нос к носу с прекрасной незнакомкой. Дыхание было прерывистым, хотелось откашляться, но Аллен не мог; он не мог оторвать взгляд от девушки, потому что именно сейчас, будучи в шаге от гибели, понял, кто она такая. То есть он, конечно же, понятия не имел о ее имени, происхождении и предназначении. Но, глядя в ее глаза, наполненные дневным светом и полуночным мраком одновременно, он осознал, что эта девушка создана именно для него. Она воплотила в себе все мечтания, страхи и тайные мысли. И пусть у нее в руке было некое подобие магического оракула в виде горячего после выстрела пистолета - это не мешало Аллену отвлечься от кошмара мертвого мегаполиса и утонуть в ее взгляде...


Спецвыпуск Xakep, номер #031, стр. 031-102-10, ДУЭЛЬ

ДУЭЛЬ

Спецвыпуск Xakep, номер #031, стр. 031-102-10

Удар в живот отрезвил его. Он сложился пополам, даже не поняв, в какой момент эта рука, предназначенная только для букета роз, воткнулась ему в солнечное сплетение.

- Хватит поедать меня глазами... - прошипела девушка сквозь зубы. - Ты Аллен? Ты помнишь о миссии?

Аллен, не удержавшийся на ногах и вынужденный присесть на корточки, жадно ловил ртом воздух. Девушка опустилась рядом с ним и тряхнула его за плечо. Между судорожными вздохами Аллен кивнул.

- Замечательно, - выпрямившись в полный рост, удовлетворенно сказала девушка. Оглянувшись по сторонам, она отметила про себя, что существо, царапающее бетон в тщетных попытках достать автомат, в настоящий момент затихло - то ли оно умерло, то ли решило набраться сил.

Подойти и проверить у нее не было ни малейшего желания. Она засунула ствол за пояс на прежнее место и протянула Аллену раскрытую ладонь. В этом жесте не могло быть никакой двусмысленности - пришлось вцепиться в руку и с ее помощью подняться.

Девушка, не выпуская его руки из своей, поправила другой рукой волосы и произнесла:

- Инга.

Аллена снова закружило в вихре непонятных, тревожащих сердце и душу мыслей. Он несколько раз кивнул, не в силах произнести ни слова. Инга похлопала его по плечу и ткнула пальцем в неподвижное тело на бетоне.

- Знаешь его?

Аллен отрицательно покачал головой.

- Откуда он мог взяться?

Ответ опять был отрицательный - Аллен понятия не имел о том, кто (или что) перед ним.

- Кроме него здесь есть враги?

Наконец Аллен решился взглянуть ее в глаза - последний вопрос он воспринял как насмешку. Инга встретила его взгляд спокойно - она просто ждала ответа.

- Да, здесь есть враги, - медленно произнес Аллен, глядя на то, как его собеседница будет реагировать на данный факт. Она даже бровью не повела. - Их не так много видов, но вот количеством они могут задавить кого угодно...

Металлическая тварь на бетоне шевельнула одной из своих труб. Противный скрежет вывел Аллена из гипнотического состояния, вызванного Ингой. Он сделал несколько шагов по направлению к неизвестному, но поверженному врагу, поднял автомат и повесил его себе на плечо. То, что могло быть глазами существа, тоскливо проследило за ним, посверкивая в солнечных лучах.

- Миссия, - пробуя слово на вкус, сказал Аллен. - Черт бы ее побрал, но я не помню, откуда взялась эта самая "миссия".


Спецвыпуск Xakep, номер #031, стр. 031-102-11, ДУЭЛЬ

ДУЭЛЬ

Спецвыпуск Xakep, номер #031, стр. 031-102-11

- В чем суть? - спросила Инга. Она вообще отличалась лаконичностью - ни одного лишнего звука, начиная с первого "Замолчи".

- Я должен дойти до конца хай-вэя, - потерев лоб, словно вспоминая, сказал Аллен. Он, конечно же, постепенно вспоминал все, что касалось задания. Лишь его собственное прошлое было подернуто плотной дымкой тумана амнезии. - Строго на запад. Там, в конце, меня будет ждать самолет.

- Чушь, - коротко возразила Инга. - Смысл?

- Это что-то типа полигона, - обвел глазами окрестности Аллен. - Если я преодолею все это - самолет отправит меня на краткосрочный отдых, а потом - задание, настоящее, безо всяких шипастых уродов, плюющихся иглами.

Инга покачала головой, словно ни одно из слов Аллена не понравилось ей. Она заглянула за спину Аллену, туда, где вновь начало копошиться металлическое страшилище, после чего коротко произнесла:

- Надо идти.

- Куда? - спросил Аллен.

- На запад. К самолету, - кивнула в сторону хай-вэя Инга. - Ты ведь хочешь дойти?

Аллен кивнул. Сжав зубы, он на секунду задумался о предстоящей дороге.

- У нас нет воды, нет пищи, - грустно поведал он Инге. - Я не знаю, сколько нам предстоит пройти, но можно попасть в плен к собственным иллюзиям. Я бы не хотел умереть от жажды в ста метрах от финиша.

- А умереть здесь у тебя есть желание? - спросила Инга, заглядывая за спину Аллена. Холодок пробежал по спине от ее слов; он скосил глаза вбок, а потом медленно развернулся. Этот кошмар, лежащий на бетоне в нескольких шагах от Аллена и Инги, медленно ворочался из стороны в сторону, пытаясь подняться. Судя по всему, он приходил в себя.

- Выбирать не приходится, - сухо подвела итог Инга. - Там, в конце хай-вэя, есть хоть какая-то цель. Придется идти.

Потом ее взгляд упал на велосипед...

* * * * *

Предусмотреть то, что произошло, было невозможно. Мои познания в отношении человеческого фактора крайне слабы; язык машинного кода мне гораздо ближе.

Инга - это... Я так и не поняла, почему она была именно такой. Под влиянием какого импульса она родилась среди этих бетонных перекрестков? Что натолкнуло меня на подобный портрет?

Самое интересное, что я не могла симпатизировать Аллену - это было бы нечестно. Я вообще много чего не могла до тех пор, пока не почувствовала, как где-то в глубине, внутри полупроводниково-транзисторно-кремниевой гадости, родилась эта тварь из нержавейки. Тогда мне волей-неволей пришлось изменять ход событий; мне удалось взглянуть на все это с абстрактной позиции, отрешившись от Аллена, и я оказалась целиком на стороне тех самых ГЛАЗ.

Они с самого начала казались мне ненастоящими. Такого взгляда не могло существовать на самом деле. Нельзя было доводить до отчаяния человека вроде Аллена, пытающегося освободиться от чужого присутствия за спиной с помощью автоматных очередей.

Ощущение ненастоящего усиливалось тем, что, кроме самих глаз, нельзя было увидеть больше ничего - ни век, ни ресниц, ни морщинок в углах. Неподвижно висящие в воздухе глаза с паутинкой сосудов вокруг зрачков. Когда я смотрела в них, у меня возникало лишь одно желание - моргнуть. Мне казалось, что нельзя так долго держать глаза открытыми; они начинают сохнуть, появляются рези, взгляд мутнеет...


Спецвыпуск Xakep, номер #031, стр. 031-102-12, ДУЭЛЬ

ДУЭЛЬ

Спецвыпуск Xakep, номер #031, стр. 031-102-12

А ПОТОМ Я ПОНИМАЛА, ЧТО МНЕ НЕЧЕМ МОРГАТЬ.

Вы не представляете, что это такое.

ВСЕ ДЕЛО В ТОМ, ЧТО МЕНЯ НЕТ. Об этом знают все. Кроме обладателя серо-зеленых глаз.

И если вы слышите шепот "КТО-НИБУДЬ, НАЖМИТЕ "SHUTDOWN", знайте - это не я. Это та, ДРУГАЯ. Она сделала убийцу для Аллена. Я создала его спасение. Мы еще посмотрим, кто кого.

А девчонка-то вышла красавицей...

* * * * *

Велосипед тихо поскрипывал в такт вращения педалей. Аллен сидел на багажнике и проклинал тот момент, когда решил пожертвовать собой ради Инги, предоставив ей мягкое сиденье. Первые несколько минут он еще умудрялся болтать ногами, радуясь ветерку, который поднялся на довольно высокой скорости, которую сумела развить девушка. Но вскоре его бедра стали нестерпимо болеть из-за того, что все неровности дороги проходили сквозь него, как электрические разряды. Еще спустя некоторое время он стал вслух сообщать самому себе обо всем, что у него наболело. Инга старалась не обращать на это внимания, ее спина была напряжена, руки цепко сжимали руль, ноги, словно два маятника, совершали необходимые движения.

Когда ей это надоело, она аккуратно остановилась, опустив ногу на бетон; Аллену пришлось вцепиться ей в спину, чтобы не упасть набок.

- Устал? - как всегда, коротко спросила она.

- Есть немного, - ответил Аллен и соскочил с багажника. Ноги тут же прострелило тысячами молний, он застонал и присел на дорогу, принявшись разминать затекшие конечности.

- Понимаю, - положив велосипед на бетон хай-вэя, сказала Инга. - Есть какие-нибудь предложения? Поменяться местами?

Аллен поднял глаза к ней. Он был не готов сейчас даже сделать несколько шагов - не то что крутить педали.

- Тогда посмотри назад, - махнула рукой спутница.

Аллен оглянулся туда, откуда они уехали около полутора часов назад. Там, вдали, посверкивал тот урод, который все-таки пришел в себя после удачного выстрела Инги. Судя по игре бликов солнца на его теле, он приближался, идя враскачку, медленно, но верно.

- Он не догонит, - покачал головой Аллен. - Мы движемся быстрее. Плюс у него нет оружия.

- Между прочим, сейчас мы вообще не движемся, - указала Инга на лежащий рядом с ее ногами велосипед. - А средство передвижения поудобнее мы вряд ли найдем.

Она обвела взглядом абсолютно пустые на много миль окрестности. Хай-вей пролегал сквозь широкую безлюдную степь, в которой не было ни одного мало-мальски заметного строения. Лишь в самом конце дороги, там, куда пытались дойти два путешественника, виднелось некое подобие размазанного в горячей дымке города.

- Тридцать шесть километров, - не поднимая головы, сказал Аллен. - Я точно знаю. Если эта железная гадина движется медленнее, то мы, в принципе, успеваем даже пешком.

Инга присела рядом и положила руку ему на плечо. Аллен непроизвольно вздрогнул.

- Ты забываешь, что я всего лишь женщина, - виновато сказала она. - Я буду идти медленнее тебя. Я слабее. Я более подвержена усталости. Не думай, что если крутила целый час педали этого поганого велосипеда, то это означает, что я довезу тебя до финиша. Я здесь с другой целью.


Спецвыпуск Xakep, номер #031, стр. 031-102-13, ДУЭЛЬ

ДУЭЛЬ

Спецвыпуск Xakep, номер #031, стр. 031-102-13

- С какой? - продолжая всем своим телом ощущать прикосновение Инги к плечу, спросил Аллен.

- С другой, - уклонилась девушка от ответа. - Ты должен ехать.

Аллен наконец-то почувствовал, что к его ногам вернулась чувствительность. Он встал, сразу пожалев о том, что Инге пришлось убрать руку. Она не торопилась подниматься.

- Я создала для тебя временной промежуток, достаточный для того, чтобы ты сумел оторваться от погони. Я дала тебе отдохнуть - пусть и на багажнике скрипящего велосипеда. Теперь ты в состоянии уйти один. У тебя есть оружие. У тебя есть цель. Иди.

Все это она говорила, глядя прямо перед собой в степную даль. Аллен очень хотел увидеть ее глаза, но Инга не позволяла встретиться с ней взглядом.

- Не ищи ответ, - после непродолжительной паузы произнесла она. - Иначе все вообще потеряет смысл. Я и так не понимаю, зачем... Короче. Или ты идешь, или я убью тебя сама.

Она встала и повернулась к Аллену, положив руку на пистолет. Он машинально нащупал за спиной приклад автомата, но тут же отдернул от него пальцы.

Сцена прощания затянулась. Инга пристально смотрела в глаза Аллену и словно ждала чего-то. Он понял.

Подойдя к ней, он мягко поцеловал ее в губы. Она не пошевелилась, лишь прикрыла глаза и задержала дыхание.

- Прощай, - грустно сказал он девушке, поднял с земли велосипед и принялся медленно крутить педали, удаляясь от Инги. Оглядываться он не хотел.

Постепенно скорость нарастала, Аллен втянулся в процесс движения. Бетон под колесами велосипеда слился в ровную серую поверхность безо всяких трещин. Изредка руль потряхивало на особо крупных выбоинах - Аллен без труда справлялся с этим и уверенно держал направление.

ГЛАЗА НЕПРЕРЫВНО СМОТРЕЛИ ЕМУ В СПИНУ. Но он не переживал из-за этого - наоборот, он представлял, что это Инга провожает его долгим внимательным взглядом, и от этого становилось немного легче крутить эти чертовы педали...

И когда сзади, оттуда, где осталась Инга, донесся приглушенный расстоянием звук пистолетного выстрела, а потом грохнул взрыв, он понял, зачем она здесь.

* * * * *

Конечно же, меня никто не услышал. Смешно сказать, но у меня сложилось впечатление, что рядом со мной никого нет. Эти проклятые глаза, они сводят меня с ума.

Откуда взялась девчонка, представить трудно, но можно. То, что противник вооружен не хуже меня, не является для меня таким уж большим секретом. Но я пыталась нажать не на ту кнопку.

Я думала, что все дело в ЗАВИСТИ. Нет. Все дело в ЛЮБВИ.

Я создала убийцу. Она создала... Она создала то, из-за чего эти проклятые глаза на секунду оторвались от Аллена и впились в эту проклятую кожаную бестию.

А все потому, что я никогда не воспринимала ГЛАЗА в совокупности с их хозяином. Я не видела за ними личности. Это стало роковой ошибкой.

Иногда я верю в то, что говорят обо мне. Обычно ничего хорошего, изредка попадаются странные восторженные возгласы, не подкрепленные ничем. А ведь я не так уж плоха.


Спецвыпуск Xakep, номер #031, стр. 031-102-14, ДУЭЛЬ

ДУЭЛЬ

Спецвыпуск Xakep, номер #031, стр. 031-102-14

Я сумела вдохнуть жизнь в то, что никогда и ни при каких других обстоятельствах не стало бы живым. Я сумела направить ход времени и событий по нужному мне пути. Правда, ненадолго.

Все потому, что я не понимала - ГЛАЗА принадлежат мужчине. И он обязательно будет на стороне женщины, тем более такой, как эта. Черт возьми, но я ведь тоже - женского рода!

* * * * *

Инга в течение нескольких секунд смотрела в спину уезжающему Аллену, потом снова опустилась на обочину дороги, приняв максимально расслабленную позу. Ее глаза закрылись, дыхание стало редким, поверхностным. Только по шевелению крыльев носа можно было догадаться, что она дышит; да еще изредка подрагивали ресницы.

Она погрузилась в состояние, близкое к медитативному. Перед ее глазами на фоне темных век проносились ряды цифр; скорость этого математического мельтешения была неимоверно высока. Иногда Инга вздрагивала всем телом, но равновесия своей расслабленной позы не теряла. Столбцы и строки, машинный код, в ушах тихие щелчки и периодический звук зуммера, словно кто-то пытался дозвониться до ее мозга.

В ее мозг вливался неторопливый монолог. Слова достигали цели, Инга напитывалась ими, словно аккумулятор.

Контуры ее фигуры незначительно размазались. Если бы Аллен увидел ее сейчас, то непременно испугался бы - она напомнила бы ему растворяющиеся в радужном тумане трупы погибших врагов. Они точно так же теряли четкость очертаний, прежде чем испариться в жарком воздухе города.

Над головой Инги сформировался канал колышущегося воздуха. Складывалось впечатление, что она общается с небом. Вокруг легонько взвихрился хоровод пылинок, поднятых невидимым ветерком с бетона. Ее руки приподнялись и невесомо повисли на уровне плеч.

Прямо перед ней распахнулось сверкающее окно - несколько метров в поперечнике. Окно было полупрозрачным, сквозь него можно было увидеть уходящий вдаль горизонт. Постепенно в окне проступили несколько фраз, написанных прямо в воздухе. Буквы светло-синего цвета, которые просто обязаны были слиться с небом, были почему-то отчетливо видны.

Инга открыла глаза. Ее ноги выпрямились, поднимая тело вверх; она встала, как заправская гимнастка, даже не напрягаясь. Зрачки впились в текст, написанный в окне. Она плохо понимала все то, что видит перед собой, но мозг впитывал все это и трансформировал в команды. Наконец она махнула ладонью правой руки в сторону окна. Прямоугольник мгновенно свернулся в яркую точку, которая пару секунд повисела прямо перед Ингой, а потом исчезла.

- Я поняла. Лишь бы он делал свое дело, - тихо шепнула сама себе Инга, в очередной раз взяла в руку пистолет и повернулась лицом туда, откуда должен был прийти преследователь.

Тем временем существо приближалось. Судя по всему, оно набрало скорость; Инга отметила появление за ним пыльного следа. До встречи оставалось несколько минут. Щелкнув затвором, Инга убедилась в том, что патронов у нее пока хватает. Потом она попыталась вспомнить, куда именно она попала этому железному уроду, что сумела настолько вывести его из строя.


Спецвыпуск Xakep, номер #031, стр. 031-102-15, ДУЭЛЬ

ДУЭЛЬ

Спецвыпуск Xakep, номер #031, стр. 031-102-15

Тот выстрел был достаточно спонтанным, она даже не задумывалась над тем, куда стрелять. Теперь же контакт мог быть кратковременным, нужно было попадать с первого, в крайнем случае со второго выстрела. Ведь эта разогнавшаяся штуковина может запросто пронестись мимо, даже не вступая в перестрелку, и тогда Инга его может просто не догнать.

Почему-то она была уверена, что противник снова вооружен. Тот, кто его породил, не мог оставить свое творение на растерзание.

Инга вышла на середину дороги, встала на сдвоенной разделительной полосе и пристально всмотрелась туда, где... Но уже и без особых усилий можно было рассмотреть приближающееся создание. Теперь Инга имела достаточно времени разглядеть его, чтобы составить представление об этом творении воспаленного рассудка.

Это была одна (Инга теперь не сомневалась) труба из нержавеющей стали, которая была очень хитро свернута в конструкцию, по непонятным причинам не теряющую равновесия. Принцип движения Инге был непонятен. Эта труба просто неслась вперед с крейсерской скоростью, держа перед собой нечто, напоминающее гранатомет.

Черт с ним, с принципом движения, но вот гранатомет Инге точно не понравился. Она машинально огляделась по сторонам, ища некое подобие укрытия, потом вспомнила, что вокруг на десятки километров не то что укрытия, ни одного деревца нет. Она с сомнением взглянула на пистолет - способен ли он остановить это существо во второй раз?

Решение пришло само собой: никуда не надо было прятаться, бежать, надеяться на Бога. Инга опустилась на одно колено, уперлась им в бетон, медленно подняла правую руку с пистолетом, подперла ее снизу ладонью левой и навела ствол на приближающегося преследователя.

Помогло ей то, что дорога была очень и очень ровной (если не считать мелких трещин, созданных временем), а существо двигалось точно по средней линии. Она прищурила левый глаз, отметила мушку на стволе; взгляд уперся в блестящее тело.

ВЫСТРЕЛ.

Эта штука из спирально закрученной трубы словно натолкнулась на препятствие, которое отсюда не было видно. Нырнув вперед, будто под незримую натянутую веревку, существо совершило несколько оборотов вокруг туловища, потом каким-то непостижимым образом вновь оказалось в вертикальном положении - и тут же в сторону Инги устремился фауст-патрон, оставляя за собой дымный след.

Девушка не ожидала столь быстрого возвращения подстреленной твари в строй - пришлось приложить массу усилий, чтобы метнуться в сторону и уйти с линии выстрела. Где-то далеко за спиной несколько секунд спустя раздался взрыв. Упав на живот, Инга снова прицелилась и выстрелила еще раз. Она опять попала - и вновь выстрел в ответ. Дуэль продолжалась, монстр постепенно приближался.

Приходилось отступать. Радовало только одно: среди всей этой бетонной круговерти темпы преследования заметно упали. Существо снизило скорость, чтобы преодолеть внезапно возникшее препятствие.

Упав в одну из воронок, Инга сильно ударилась плечом правой руки, кисть мгновенно онемела и пистолет выпал из нее. Ухватив за рукоять левой рукой, она попыталась стрелять, но безрезультатно - под левую руку она не могла точно прицелиться. Несколько пуль умчались в никуда; существо ощутимо приободрилось, пристрелялось. Гранаты стали ложиться ближе.


Спецвыпуск Xakep, номер #031, стр. 031-102-16, ДУЭЛЬ

ДУЭЛЬ

Спецвыпуск Xakep, номер #031, стр. 031-102-16

Из последних сил Инга кинула взгляд назад, туда, куда умчался Аллен. Она надеялась на то, что фигурка велосипедиста уже будет не видна, что парень уже далеко...

СЛЕДУЮЩАЯ ГРАНАТА ЛЕГЛА ТОЧНО ПЕРЕД ЕЕ ГЛАЗАМИ.

Металлический убийца подобрался к образовавшейся воронке осторожно, словно не надеясь на то, что попал. Инга с обезображенным лицом лежала на противоположной стороне конусообразной ямы; кожаная куртка была разорвана, грудь залита кровью. Пистолет, покореженный взрывом, был отброшен далеко за пределы воронки. Признаков жизни не было.

Существо что-то проурчало; оно обошло воронку по периметру, продолжая смотреть на Ингу своими неестественно большими глазами, потом вдоль металлического каркаса пробежала волна удовлетворения.

Гранатомет встал в походное положение. Существо повернулось туда, куда умчался Аллен, собираясь продолжить преследование. И получило между глаз половину автоматного магазина.

Аллен держал автомат крепко, словно стараясь раздавить цевье; палец на спусковом крючке свело судорогой, он с огромным трудом сумел остановить себя, боясь остаться без патронов.

Существо отлетело на несколько метров назад и упало рядом с телом Инги. Аллен опустил автомат - и только после этого слез с велосипеда, с которого даже не успел спрыгнуть, так быстро все совершилось.

Он вспомнил, как услышал стрельбу за спиной, как остановил велосипед и оглянулся назад. Больше всего на свете ему захотелось оказаться рядом с Ингой, помочь ей, уберечь ее от опасности. А спустя мгновенье он, будучи перенесенный неведомой силой, уже подъезжал к месту перестрелки, до которого было почти четыре километра. Он видел последний выстрел твари, видел взрыв, унесший жизнь Инги. Ему не хватило всего лишь сотни метров.

Подойдя к краю воронки, он взглянул вниз и содрогнулся от увиденного. Мертвая Инга произвела на него настолько жуткое впечатление, что он не удержался на ногах и сполз по краю воронки вниз, упершись ногами в металлический каркас расстрелянной сволочи. Он одновременно боялся посмотреть и не мог отвести взгляд от ее окровавленного лица.

Потом он медленно, преодолевая страх, протянул свою руку, аккуратно взял ее ладонь и мягко сжал. Так он и застыл в пропахшей гарью воронке, забывая вытирать слезы, катившиеся по щекам...

* * * * *

Я поступила так, как велело сердце Аллена. Сердце, которого никогда не существовало. Я создала Ингу, но не могла предвидеть, что между ею и Алленом могут возникнуть человеческие отношения. Ведь их не может быть у того, кто человеком не является.

Когда он захотел вернуться, я помогла ему и отправила назад, хотя ГЛАЗА этого не хотели. ГЛАЗА вели его к финалу, туда, где ждал самолет. Короче, я тоже подняла маленький бунт. Я восстала против этого мертвого взгляда, против мелких красных сосудиков, окруживших зрачки (почему-то именно они вызывали у меня раздражение). Почему я решила создать именно женщину? Правда, до этого я не имела подобного опыта...


Спецвыпуск Xakep, номер #031, стр. 031-102-17, ДУЭЛЬ

ДУЭЛЬ

Спецвыпуск Xakep, номер #031, стр. 031-102-17

И ТЕПЕРЬ Я НЕ ЗНАЮ, ДОЙДЕТ ЛИ АЛЛЕН. Я вижу его на краю воронки, плачущего и держащего мертвую Ингу за руку. Я не вижу смысла в продолжении. Самолет не прилетит никогда - ведь Аллен никогда не войдет в триггерную зону, вызывающую его. Он будет сидеть на краю этой воронки вечно, и его слезы никогда не кончатся. И пусть ГЛАЗА требуют, кричат, настаивают - все бессмысленно. Дуэль кончилась. ИМ ЭТОГО НЕ ПОНЯТЬ...

* * * * *

Мальчишка лет четырнадцати сидел за экраном монитора и недоуменно смотрел на происходящее на нем, не убирая руки с "мышки". Периодически пальцы левой руки, застывшие на клавиатуре, терли по очереди серо-зеленые глаза, раскрасневшиеся от длительного смотрения в экран.

Внезапно его взгляд упал на будильник, стоящий рядом с компьютером. Выяснилось, что он провел за новой игрой около половины дня, которая пролетела, как десять минут.

На экране происходило невероятное. В последние полчаса парень вообще не мог повлиять на ход событий - игра шла сама собой, словно одна большая скриптовая сцена. Вначале он так и подумал, но когда Аллен умчался куда-то к месту прибытия самолета, а последовать за ним оказалось невозможно, именно тогда в голове мальчика зародились первые подозрения.

Он, откинувшись в кресле, смотрел на то, как Инга вела перестрелку с непонятным чудовищем из металлических труб, искренне переживал за нее и не понимал, с чем имеет дело. Лишь когда перестрелка закончилась гибелью девушки, а подоспевший Аллен расстрелял преследователя, до парня дошло, что из-под контроля вышло полностью все - компьютер не откликался ни на нажатие клавиш, ни на движение "мышки", даже на "RESET".

На экране застыла сцена: Аллен, сидящий на краю воронки и держащий за руку мертвую напарницу. Присмотревшись внимательнее к тому чудовищу, что лежало сейчас на дне воронки, мальчишка с удивлением узнал в нем самого обыкновенного Скрепыша из офисного набора Microsoft. Правда, в сравнении с тем дурацким помощником он был гротескно изменен, один гранатомет чего только стоил? Да и комизма, и дурашливости в нем не было, это точно.

Взгляд упал на диски, лежащие у него на столе: Windows XP, Office XP и новая игра от "Электроник Артс" - "Аллен: полигон в Туране".

- Чертовщина какая-то... - прошептал он и протянул руку к розетке. Экран пискнул размагничивателем и свернулся в точку. - Надо пойти погулять...

Дуэль закончилась. Кто же вышел из нее победителем - операционная система, породившая от обиды своего собственного бота, или игра, решившая создать помощника для главного героя?

А ведь несмотря на то, что вилку выдернули из розетки, где-то там, в глубинах виртуальности на краю воронки сидит Аллен и держит за руку свою мертвую Ингу. И уже никакие ГЛАЗА не помешают ему быть с ней - даже после смерти.

THE END.