Спецвыпуск Xakep, Содержание номера # 026

Cover 026 |
Статья | Стр.
Биты |
Что такое новый год? | 004
Команда |
Spez-Crew v 2.0 | 006
Cover-Story |
Виртуальный новый год | 018
Заспиртованный компутер | 022
Новогодние фейерверки | 024
HACKERWEAR | 026
Карнавал киберпанка | 030
Свой среди чужих | 034
Подарки нашего сервака | 036
Лучшее из серии по взлому |
Классификация DoS-атак | 040
DOS умножение | 044
Spoofing | 048
В поисках вакантных дыр | 050
htaccess и htpasswd | 054
Who is? | 056
Пожмем друг другу руки | 058
Сканеры безопасности под win | 062
Стандартные порты | 066
Разведка | 068
Атака | 070
Прикладное туннелирование | 074
haX0rz4haX0rz |
Прикольные истории про компы | 076
Паяльник |
Лазерный дальномер Прозвонкина | 080
WINformation |
Полезняшки | 082
][-desktop: взгляд в небо | 086
Мягкие места инета | 090
Update | 094
Креатив |
Меня зовут Голливуд (Part 2) | 096
Технология вышивания крестиком | 100
Новогодняя мышь креативщика | 102
TIPS OF FLASH | 104
TIPS OF WEB | 106
Relax |
Бурбуляторы | 108
Story |
Первый из рода | 112
Книжки |
Полезные буки по хаку и не только | 120
E-mail |
E-mail | 122
Комикс |
Комикс | 124


Спецвыпуск Xakep, номер #026, стр. 026-004-1, БИТЫ

БИТЫ

SpezCrew (spez@real.xakep.ru)

Спецвыпуск Xakep, номер #026, стр. 026-004-1

ЧТО ЗА МАЗА - НОВЫЙ ГОД?

О том, что же такое "новый год", задумываются немногие. Если исходить из названия, так можно охарактеризовать любой период жизни индивидуума, начальной точкой которого будут текущий день и час, а конечной - тот же час и, как это не парадоксально, значение дня, вычисленное по формуле newday=sum(month*day)i - 365, где за i принимается номер месяца, а month и day - количество дней в месяце и их порядковые номера (проникнись глубиной идеи :)). В принципе, схему расчета можно свести к двойному интегралу по d(day) d(month), но мы этого делать не будем, так как человеку свойственно ошибаться и "новым годом" массы именуют одну ночь праздника. С гордостью хочется заметить, что только в нашей стране народ пытается побороть этот парадокс и доводит время празднования до двух недель (а особо упорные и до трех). В новогоднюю ночь на территории России принято запивать водку шампанским, засыпать в неизменном тазике салата "оливье" (несчастный французский повар и не думал, что приобретет популярность таким экстравагантным способом) и наедаться апельсинами и мандаринами до полной потери сознания (возможно, именно в этот процесс корнями уходит народная мудрость "как свинья в апельсинах").

Атрибутика праздника незамысловата и до трогательности проста - гирлянды (последовательно подключенные к единой несущей низковольтовые лампы), конфетти (остатки дырокольно-подшивательской деятельности офисных работников) и, разумеется, петарды. По старинному обычаю, самого слабого и неумелого юношу, который не взорвал на празднике ни одной петарды, весной забирают работники военкомата и два года учат этому нелегкому делу. Именно поэтому молодежь в новогоднюю ночь рьяно уничтожает запасы пороховых хлопушек и петард, стараясь отпугнуть от своего дома "демонов-военкомов".

Интересна также история Деда Мороза, появляющегося в новый год с мешком подарков и некой Снегурочкой. В стародавние времена, завидев на дороге прохожего с мешком и симпатичной спутницей, лихие люди отбирали все содержимое мешка Мороза, а Снегурочку его... хм, принуждали к половым сношениям. Зато потом, раздобрев, отпаивали деда водкой и утешали потерявшую девичью честь Снегурку. В наше время этих традиций почти никто не соблюдает, поэтому Дед Мороз сам открывает мешок, предлагая желающим забрать понравившиеся им вещи, а Снегурочкой выбирают девиц не первой свежести. Без изменений осталась только питейная часть обряда, которой не пренебрегают ни в одном порядочном доме.

Но хватит рыться в тлене старых обрядов, передвинем глаз на современную ситуацию. И что мы видим? Кошмар! Старье отвалилось, а новье не выросло. Многие современные амигосы узнают о том, что где-то скоро наступит какой-то новый год из незащищенных каналов связи, как второстепенную, побочную информацию. Конечно, далеко не все, но это, однако, тенденция. И даже получив тревожные сигналы, эти продвинутые члены нашего общества не придают им большого значения. Они начинают беспокоиться только тогда, когда другие члены общества, играющие роль клиентов (родители, подруги (друзья?), знакомые) пытаются злобно ребутнуть их чем-нибуть по голове, потому что получили жирный DoS вместо сервисов под кодовыми названиями "поздравления", "подарки", "программа новогодних мероприятий". Бедняги спешно пытаются исправить error’ы, которых не понимают, но уже ничего не могут поделать, так как уже нету свободных мегамест в ночных хард-клубах, траффик через Красную площадь превышает 100 челобит, а extended магазины out of podarki. Наших гордых мэнов новой эры, которые призваны гигатоннами переваривать и отрыгивать информационные потоки, начинает клинить. Они совершают иррациональные копирования своей сущности из одной тупой пьяной тусы в другую и обратно, пытаются пробить многочелобитный траффик в центре города, ловят многочасовые лаги, застряв в отдаленных районах города, потому что прекратило работать метро и так далее. Надо что-то делать! Пора спасать будущее кибернации! Мы видим только один выход – перенести концепцию нового года в цифру. Ну, а пока этого не случилось, будем пробовать всевозможные альтернативные варианты встречи NY. Brutforce forever!!!

Содержание


Спецвыпуск Xakep, номер #026, стр. 026-006-1, Команда v 2.0

Команда v 2.0

Спецвыпуск Xakep, номер #026, стр. 026-006-1

Процесс: n0ah.

Процесс запущен с правами: root.

Всем привет! Я n0ah, главред Спеца.

Сейчас открою большой секрет – я на самом деле ни фига не n0ah. Точнее, я уже Ноа, но когда попадал в команду, им не был. Просто я взломал ящик чувака с ником Ноа (noah@inbox.ru), почитал там его переписку с Холодильником и решил занять его место ;) (так как Холод с тем чуваком в реале еще ни разу не виделись). Мало того, я еще и получил гонорар за первую статью того чувака – падонак, слов нет. Верить этой телеге или нет – дело твое :). Единственное, что могу подсказать, если действительно интересно, лапши я тебе сейчас навешал или открыл страшную тайну, найди ту самую первую мою статью (в каком номере – не скажу из вредности), внимательно ее изучи, потом загляни в братскую могилу, скажем, в этом номере и пораскинь мозгами ;).

Люблю кино: Криминальное чтиво, Четыре комнаты, Эксперимент, Леон, В китае едят собак, Нирвана (!), Хакеры (!!!), Форест Гамп, Амели и прочий рулез в том же духе. Из последних очень порадовали фильмы с Мэлом Гибсоном – Знаки и Мы были солдатами.

Не люблю кино: Остин Пауэрс (ненавижу! когда посмотрел, понял, что просто выкинул полтора часа из своей жизни, да еще и денег заплатил!), сериалы на большом экране (Звездные войны, Властелин колец (хотя массовые сцены там сняты прикольно), Гарри Поттер) – считаю это выбиванием бабла из народа в откровенной, неприкрытой форме ;).

Люблю музыку: Все с лейбла Ninja Tunes (ColdCut!!!), кое-что с лейбла Warp, а вообще всякую электронику, в основном старую, и транц, в основном свежий :).

Не люблю музыку (в смысле "вызывает отвращение"): Нашу и американскую попсу (британскую еще терпеть можно) и всякое прочее дерьмо, перечислять которое не буду, дабы не похабить недостойными буквосочетаниями клавиатуру, монитор и странички журнала ;).

Люблю книжки: "Фараон" Болеслава Пруса (очень жизненная книга), американскую научную фантастику 60-70-х годов, проявления киберпанка на бумаге, компьютерную литературу (в смысле всякие учебники по программированию, сетям и прочее).

Не люблю книжки: Ммм.., ничего в голову не приходит! Мазафака, склероз! Помню же, что недавно читал какой-то отстой и давился от злости... Что именно – не помню :(. Надо не забыть прикупить пару палок мозгов. Обязательно не забуду :).

Люблю еду: Аааа, ммм, мне, пожалуйста, порцию лингвини и бутылочку Кьянти! (с) Кройд Кренсон. На самом деле ем то, что есть. Особых пристрастий в еде нет. Ну, разве что хороший яблочный пирог с горячим шоколадом в какой-нибудь уютной кофешке.

Не люблю еду: Рыбу и прочие морепродукты (кроме кальмарового салата), суши, роллы, пунты, хунты и прочую еду наших восточных соседей, баранину, борщ.

Люблю вообще: Компы, Инет и все, что с ними хоть как-то связано, кататься на ролах и на сноуборде, море, лето, деньги (очень люблю ;)!). Еще очень нравится ощущение, когда удается разобраться в очередной технологии, и приходит понимание того, чем руководствовались ее создатели. Это относится не только к компам, но и к жизни вообще :).

Не люблю вообще: Когда мне врут, и я это вижу (люди, учитесь врать так, чтоб не было понятно!), всякого рода депресняки, отвратную погоду, идиотские мысли в голове.


Спецвыпуск Xakep, номер #026, стр. 026-006-2, Команда v 2.0

Команда v 2.0

Спецвыпуск Xakep, номер #026, стр. 026-006-2

Процесс: Ден.

Процесс запущен с правами: X.

Хай, ppl!

Для тех, кому реально интересно что-то узнать обо мне, я буду из номера в номер публиковать свои мемуары с детскими фотографиями всех своих родственников и знакомых :). Для остальных нормальных людей немного инфы прямо сейчас.

Я - арт-директор Спеца. В данный момент мне уже идет третий десяток, и учиться я уже завязал. Комп появился в начале 90-х, и я сразу же захотел стать программистом, потом программистом игр, потом просто играл в игры и ничего не хотел, потом увидел 3D Studio, потом 3D MAX, Photoshop и Illustrator, и понеслась.

Кстати, космонавтом или дворником никогда не хотел быть :(.

Маленькая история о том, как я попал в команду.

Ну, как-то раз иду я, значит, и вдруг вижу - команда. Я и говорю: "А можно с вами?". А мне отвечают: "А давай!". Вот так я и попал в команду (шутка :))). На самом деле друг детства Алик Вайнер (арт-директор Страны Игр), он же Jmurik, притащил меня в GameLand, где я теперь и обитаю, за что ему, собственно, 10х.

Люблю: свою девушку, рулить тачку, CS, кататься в супермаркетах на тележках, вкусно поесть и крепко поспать.

Не люблю: писать про себя, рано вставать, попсу, инсталлировать винды.

Из фильмов люблю: Бразилия, Матрица, Бойцовский клуб, Большой Лебовски, Амели, Криминальное чтиво, наши старые фильмы.

Музыку слушаю разную, очень люблю шансон (шутка!!!!). На самом деле нравится все, кроме попсы: от Drum'n'Bass до русского рока.

В будущем планирую заработать много денег и купить личный самолет, вертолет и покататься на всех тачках из Need For Speed в реале.

Процесс: Дронич.

Процесс запущен с правами: system.

Извлечения из логов моего существования:

Детство помнится смутно, самое яркое воспоминание - драка в детском саду с применением игрушечной машины "БелАЗ" весом в четыре килограмма, за которую я был с позором изгнан из, в общем-то, приличного заведения. Собственно говоря, эта драка и оказалась первым моим шагом к компам вообще и Спецу в частности, потому как дома я стал развлекать себя тонкой настройкой разнообразной техники, а вскоре добрался и до "трешки", стоявшей на рабочем месте моей матушки. И понеслось... Сменив за свою жизнь всего три компа, я умудрился пожить под всеми возможными версиями виндов, BeOS и даже шеллом от линукса (как-то не прижилась графическая оболочка). ][ стал читать относительно поздно - в конце 99 года, но сразу понял: это - мой журнал. И однажды, воодушевленный успешным хаком отечественного АОНа, взял да и написал статейку в любимое издание. Так и началась моя счастливая и беззаботная жизнь от дедлайна до дедлайна :). Прошел год, и теперь я, уже как заместитель главного редактора, прилагаю все усилия к тому, чтобы наш журнал стал еще лучше и еще интереснее. А попутно пытаюсь учиться на третьем курсе МЭСИ по специальности "Прикладная информатика в экономике".

На компе я ежедневно мучаюсь с виндами, креативлю техноритмы во FrootyLoops и ReBirth, пишу гневные письма авторам в TheBat'e и рисую порномультики про сокурсников во Flash'e.


Спецвыпуск Xakep, номер #026, стр. 026-006-3, Команда v 2.0

Команда v 2.0

Спецвыпуск Xakep, номер #026, стр. 026-006-3

Люблю: сбычу мечт :), девушек, ром с колой, сыр чечил, шоколад "Аленка", активный отдых на природе, пикники, волейбол, командные файлы, рулить (на машине/скутере/велосипеде), стебаться, спорить с людьми на интересные темы, гулять по центру Москвы, гаматься в GTA3.

Не люблю: военную кафедру, собирать грибы, дождь, слякоть, тупых преподов, старые анекдоты, неизбежность, вареную капусту, когда меня зовут "Андреем" (бвэээ... офицальщиной пованивает... Андрюша и Дронич гораздо приятнее :)).

А еще я люблю умных и интересных людей с чувством юмора (редко такие встречаются), кино, которое заставляет задуматься (X-files просьба не предлагать, попсово), любую музыку, кроме совсем уж экстримных noise'ов. Конкретно сейчас, например, балдею от Pizzicato Five, Cumbustible Edison, Nightwish и AK1200. Неслабый микс, правда? ;). А больше всего мне нравится изредка нажать на "Pause" и посмотреть на свою "жизнь в режиме nonstop" со стороны, в одиночестве сидя в кресле с любимым котом на коленях. Особенно эта фишка канает после сдачи очередного Спеца.

Процесс: Donor.

Процесс запущен с правами: system.

В далеком Y2k на спор взорвал Холоду мусоропровод, а Холод не обиделся (потому что мусор выносить не любил), но посадил меня в редакцию на неопределенный срок. Вот, теперь мотаю срок в камере креатиффного редуктора. Когда заложил свой мозг, уже не помню, потому что нечем, а модулей памяти всегда не хватает.

Люблю ковыряться в компе и разных интересных прогах, кино на большом экране с кучей спецэффектов, пьянки-гулянки, Countr'у в рабочее время, люблю устраивать всяки Х-предприятия и мутить разные креатиффные фишки.

Не люблю, когда вырубают электроэнергию во время форматирования винта, рано вставать, когда на утро пропадают кластеры с данными о пьянке-гулянке (значит, продукт потрачен впустую), слоноботов в любое время и в любом виде, напряги по работе и вопящих начальников.

Мечтаю о грандиозной халяве, чтобы не надо было делать то, что не хочется, но надо.

Процесс: Федор Добрянский, Dr.Cod, Матушка Лень (Matushka_LEN'[LoveTech]), Рваный Нерв, Доктор Прозвонкин, Доктор Добрянский и тому подобные...

Процесс запущен с правами: kernel.

Когда-то вместе с SINtez'ом работал в журнале "Компьютер и жизнь". В декабре 1998 года мы начали делать самый первый номер ][, который вышел в феврале 1999-го. В ][ я вел рубрики "FAQ" и "ИМПЛАНТ", а также серьезно поддерживал "Западло" и "Паяльник". Потом появился Спец, и я стал писать и фотографировать туда.

Параллельно я получил громадный жизненный и производственный опыт от учебы в био-классе гимназии, от стажировки в нейрофизиологической лаборатории ИИППИ РАН, от работы в Академии Природной Медицины "ЛАМА", от работы в крупной программисткой компании CBOOS, от стажировки в сетевом интеграторе "Информсвязь". За это время я написал модуль для Быстрых Преобразований Фурье; паял Автоматический Определитель Номера и писал софт к ниму вмести с друзьями; пытался организовать радио-клуб, но ничего не вышло; немного админил Unix и WinNT сервера; спроектировал софтварную модель сигнатурного анализатора на MicroCap; спроектировал и запаял тестер для радарного блока; запускал голос, TCP/IP и X.25 через Frame Relay на каналообразующем оборудовании Memotec и Motorola.


Спецвыпуск Xakep, номер #026, стр. 026-006-4, Команда v 2.0

Команда v 2.0

Спецвыпуск Xakep, номер #026, стр. 026-006-4

В настоящий момент я заканчиваю МИРЭА, разрабатываю контроллер памяти для нового векторного процессора в РАН, жестко тестирую железо в test_lab, пишу сложные материалы по сетям и другие статьи в Спец.

Считаю, что примитивное вагинальное сношение - лишь капля в бескрайнем море секса.

Мечтаю спаять компьютерный интерфейс для управления системой усилием воли!

Процесс: Дима.

Процесс запущен с правами: X.

дизайнер-верстальщик

Процесс: Docent (Роман Вуколов).

Процесс запущен с правами: daemon.

Как попал в команду:

Однажды, ранним пасмурным утром весны 199х (эх, склероз) года, решил я перед сном проверить почту. И в одной из рассылок прочитал, что какому-то журналу Хакер нужны авторы в рубрику по взлому игр. И почему-то решил я, что именно меня-то там и не хватает. Опыта написания статей никакого не было, зато был опыт взлома. Но, тем не менее, статейка и ее контент редакторам понравились. Еще бы - ни такого журнала, ни, тем более, такой рубрики раньше никто не видывал! Опубликовали ее, кажется, в 6-м номере... в смысле, вообще в 6-м по счету. И с тех пор понеслось. А как только появился Спец, начал в него понемногу писать и вскоре окончательно в нем обосновался.

Кого я люблю:

Себя.

Маму.

Свою девушку ДаСаду.

Кошек.

Что я люблю:

Компы, компы и еще раз компы. Кто-то однажды спросил меня: а не надоест ли так - и работа с компами, и хобби тоже с компами? НИКАДА! - ответил им я, разорвав на груди рубаху, под которой оказалась майка с надписью ROOT. Видимо и вправду - никогда. Такие вот мы - киберпанки.

Пиво. Но не много.

Путешествия. Мечтаю уехать в кругосветное путешествие, как только разбогатею...

Внедорожные мощные автомобили.

Музыку и изобразительные искусства.

Психологию и эзотерику.

Чего я не люблю (не перевариваю, ненавижу и т.д.):

Тупых людей.

Старушек с тележками и толстых крупногабаритных теток, которые прессуют меня в московском метро и заставляют уступать им место.

Мусоровоз, который ранним утром тарахтит под окном, когда я только собираюсь уснуть после неравной борьбы с компилятором и отладчиком.

Брехучих (и не очень) собак.

Жареную (вареную, сушеную и т.д.) рыбу.

Тупую отечественную попсу.

Еда: спагетти с сыром, устрицы и еще все, что сладкое.

Напитки: пиво, минералка.

Музыка: металл, рок и, как ни странно, всякая классика и этника.

Кино: киберпанк - Matrix - Forever; боевики - добрый дядя картинно мочит всяких уродов; ужастики и триллеры - и чтобы крови и ошметков побольше; комедии - как тупые американские, так и наши.

Мечта: открыть компьютерную мегакорпорацию... а вообще, когда мне будет за 70, оцифровать свое сознание, поменять постаревшее бренное тело на что-нибудь более совершенное и стать бессмертным киберменом - вечно молодым, вечно пьяным... мечты киберпанка... :).


Спецвыпуск Xakep, номер #026, стр. 026-006-5, Команда v 2.0

Команда v 2.0

Спецвыпуск Xakep, номер #026, стр. 026-006-5

Процесс: ХрымZ

Процесс запущен с правами: daemon.

Начну сей маленький рассказ собственно с того, как я попал в Spez-Crew. Произошло это, видимо, по велению Бога Джа, так как я просто фанат магазина с первых номеров и в моей голове всегда зрел план стать частью журнала. И тут вот тебе подарок божественный - уже в скором времени стою в темных подвальных помещениях редакции и получаю заветные гонорарчики :). Кстати, тот факт, что за любимое дело еще и платят, вообще пробил меня на слезу :).

Люблю:

Девушку свою - Аню.

Друзей своих и вообще людей растаманской души.

Сеть заведений О.Г.И.

Клуб "Китайский летчик Джао Да".

Кино: Нирвана, Хакеры, Бойцовский клуб etc...

Авторы: Харуки Мураками, Энтони Берджесс, Филипп Дик etc...

Музыка: Не могу точно ответить. От "Паперного ТАМ" до Radiohead...

Пиво.

Курить кальян с качественным табаком.

Не люблю:

Гопоту.

Попсу.

Шнейдера и Писарева.

Когда Инет кончается во время сдачи статьи.

Примерные планы на будущее. Хм. Продолжать работать на благо русской хак-сцены в лице сотрудника Спеца, да и вообще :). Года через четыре, наверное, буду подрабатывать на Царицынском радиорынке - собирать из дешевых деталей боевых киборгов-черепах. Поживем - увидим.

Процесс: Tony (Палагин Антон).

Процесс запущен с правами: daemon.

Известный под буквосочетанием Tony, в реальности был найден в капусте с повешенной на шею картонкой с надписью - Палагин Антон. После продолжительной и упорной борьбы с преподами физфака нижегородского университета (aka Лобок) и физическими науками остался там же и работать - на кафедре ИТФИ. В Спез-Крю попал достаточно банальным образом - написал в редакцию, сказал: "Хочу...", ответили - "Ok".

Занимаюсь:

По специфике работы - это реализация различных API и подсистем ввода/вывода, базирующихся на стандарте VXIplug&play. При этом использую очень большой спектр программных технологий, таких как C/C++, COM/DCOM, ActiveX, Java, XML, Sock и т.д.

По собственным проектам занимаюсь - nix, СУБД, DirectX, проблемами систем принятия решений и искусственного интеллекта.

По хобби интересуюсь проблемами обеспечения безопасности информационных систем, историей, философией, психологией, а также работой спецслужб и их технических средств.

Люблю:

Футбол.

Компьютерные игры, требующие использования интеллекта, а не спинного мозга. Любимые игры: Elite, X-COM, Jagged Alliance, Baldur's Gate, Fallout, Fifa 99, TES, Ghost Recon, Ил-2 Штурмовик.

Музыку всю не на русском языке (в основном это альтернатива, рок, умная попса и ньюэйдж).

Книги - первое место хит парада делят между собой "Похождения бравого солдата Швейка" Ярослава Гашека, "12 стульев" и "Золотой теленок" Ильфа и Петрова, а также "Dragon Lance" Margaret Weis & Tracy Hickman.

Не люблю:

Флуд непрофессионалов.

Шутеры и RTS.

Всю музыку на русском языке.

Люблю вкусно и плотно покушать натуральную пищу (гамбургеры Бритни в...), из фильмов предпочитаю: комедии и "Собачье сердце". Отдых с распитием нехилого количества алкогольных напитков предпочитаю проводить на природе за городом в компании друзей. Нравятся простые, открытые люди без глазного зрачка в форме $. Предпочтения в женщинах: смуглые брюнетки, главное - веселые, общительные, умные и без распальцовки. Планы на жизнь достаточно просты - собственная девелоперская контора (студия), умная жена, немецкая машина и небольшой домик на побережье бенгальского залива... господи, я ничего не забыл? :).


Спецвыпуск Xakep, номер #026, стр. 026-006-6, Команда v 2.0

Команда v 2.0

Спецвыпуск Xakep, номер #026, стр. 026-006-6

Процесс: Vadias (Вадим Мурзагалин).

Процесс запущен с правами: daemon.

Полтора года назад я окончил юрфак (red_diplom :)), поработал юристом в налоговой инспекции четыре месяца за 40 баксов в месяц, потом "пошел на повышение" - стал инженером-программистом aka верстальщиком городской газеты. Уже давно, правда на полулюбительском уровне, занимаюсь компьютерной графикой и дизайном, благодаря этому и попал в Spez-Crew, представив однажды на суд редахтуров совместную статью о моем любимом графическом редакторе FreeHand. Сейчас многие меня знают по рубрике Tips of Web, народ любит веб-дизайнить, и радует, что можно оказать ему посильную помощь :).

Написать здесь все, что я люблю, - не могу, близкие будут ругаться :). А вообще - здорово собраться за десятком кружечек пива в компании очкастой интеллигенции, праздновать день независимости Кубы, вести бесконечные разговоры о смысле жизни и о месте прессы на новом этапе перестройки. Люблю читать книжки, это очень развивает. Ну, и жену тоже люблю :).

Терпеть не могу, когда выпендриваются. Не выношу несправедливость.

Что касается кино - нравятся фильмы разных режиссеров в стиле Гая Ричи и Тарантино. Очень рекомендую тем, кто не смотрел, немецкий "Верняк", английские "Hard men", "Большой куш".

В последнее время решил более серьезно заняться цифровым рисованием и дизигном, как следует поучиться, и в обозримом будущем думаю взяться за написание книги на эту тематику. Надеюсь, получится неплохо. Еще я вынашиваю идею создания своей компьютерной игры. Это осуществимо, нужно только быть оптимистом и найти хорошую crew. Такую же, как Spez-Crew.

Процесс: Niro.

Процесс запущен с правами: daemon.

Врач-хирург, специалист в области раневой инфекции и термических поражений.

Увлечен своей женой и детьми, компьютером, чтивом (Стругацкие, Бушков, Перумов, Кинг), телевизором.

Люблю поесть: мясо с кровью, дзен-кухню, пирог с олениной.

Люблю посмотреть: триллеры, фантастику (космос, стрельба, лазерные мечи, отрезанные пиписьки), иногда тянет на драму (Чип и Дейл идут на ), бесплатный Интернет, пиво и свою работу.

Не люблю холод (зиму просто ненавижу!), зубную боль, дебилов, не люблю «Балтику» №9, уродов всяких, от которых зависишь в чем-либо. С некоторых пор не люблю, когда какой-нибудь чудак на букву «М» подрезает на поворотах.

Планы на жизнь – стать специалистом в своей профессии, написать какую-нибудь классную книгу, воспитать детей так, чтобы им не было стыдно за собственного отца.

Мечты довольно прозаические – стать не менее знаменитым, чем Стивен Кинг.

Процесс: AndrewF (Андрей Фадеев).

Процесс запущен с правами: daemon.

Это я, Андрей Фадеев. Живу я в Украине, в славном городе Одессе. Тем, кто знает это город, объяснять не надо, кто не знает - тем слишком долго рассказывать. Учусь в Академии связи имени А.С. Попова (ударение на второй слог). Там местами интересно, но всегда очень весело. Если говорить о том, как я попал в команду, то начинать надо издалека. Шел я как-то по городу (давненько) и вижу в ларьке журнал Хакер, улыбнулся, помня о том, что в большинстве журналов пишут на эту тему, и пошел дальше. Так бы я и шел, если бы домой не пришел, а там меня ждет друг с этим журналом (номера 3-ий и 4-ый были, кажется), в режиме "все листики отдельно". Почитали. Скептицизм мой ушел, а осталась радость за такой (тогда мне такое слово пришло в голову, и замену я не нашел) "дружественный" журнал. Так шло время, журнал взрослел, оставаясь "дружественным" и становясь более информативным. Пошли Спецы, которые были еще более читабельными. Их было интересно читать не только благодаря ценной информации, но и из-за стиля. Но это все присказка, а сказка началась в сентябре двухтысячного, когда в Спеце по программированию я увидел объявление о готовящемся номере о Linux. Этой ОС я увлекался уже продолжительное время к тому моменту, я и не выдержал. Написал письмо, и меня взяли. Вот и вся сказка, а дальше пошла интересная работа.


Спецвыпуск Xakep, номер #026, стр. 026-006-7, Команда v 2.0

Команда v 2.0

Спецвыпуск Xakep, номер #026, стр. 026-006-7

Сейчас я больше увлекаюсь своим профессиональным - средствами связи. Еще я очень люблю всякие high-tech игрушки. Не в плане роботов, а в плане PDA, современные мобильники и прочие радости. Новая техника не может оставить меня равнодушным. К сожалению, она не всегда вкладывается в бюджет, поэтому мой PDA и телефон не самые новые, но функциональные.

В людях я люблю открытость и прямоту, так, чтобы первое впечатление о человеке было правильным. Кино я люблю хорошее, удивил, да? Сюжет главное, игра актеров второе, спецэффекты часто бывают последним критерием оценки фильма. Для примера: Signs. Музыка - подальше от СНГ попсы. Мелодия, настоящие инструменты, а не 8-битный синтезатор, слова со смыслом, а не с рифмой в стиле "палка-селедка". Например: Robbie Williams - Sing When You're Wining. Еще люблю слушать Moby.

Жду уже окончания учебы и начала интересной работы, хотя и со студенческой жизнью расставаться не спешу. А пока у меня уже есть одна интересная работа :) - Спец.

Процесс: ilich (Бовт Илья).

Процесс запущен с правами: daemon.

Досье:

Илья Викторович я только в государственных органах и на работе. Для близких особей и в области общения, каким-нибудь боком связанного с компами, я ilich, особо приближенные иногда также кличут меня по имени.

В команду Spez-Crew попал летом 2002 года. Как попал, не помню (выпивши был). На что попал, не знаю (до сих пор пытаюсь понять, чего от меня хотят :)). Одно лишь знаю точно - Дронич меня за извращенца держит. Не за того извращенца, про которого ты, вероятно, подумал, за другого :).

Увлечения по пунктам (почти на полном серьезе):

Люблю: чтобы меня не трогали, когда я этого не хочу (и физически в том числе), т.е. жить для себя.

Не люблю: блин, все перечислить - никого места не хватит... короче, копать не люблю!


Спецвыпуск Xakep, номер #026, стр. 026-006-8, Команда v 2.0

Команда v 2.0

Спецвыпуск Xakep, номер #026, стр. 026-006-8

Пристрастия: смотрю любое красивое видео с хоть чуть-чуть развитой идеей. Типа фантастики и каких-нибудь триллеров. Также люблю поржать над тупыми комедиями америкосов. Ибо это весело. Обожаю пошаговые стратегии. Трачу на них бесценные годы своей жизни. Люблю подумать и всем окружающим этими думами портить настроение, т.к. последить за чьим-нибудь поведением, за его действиями в некоторой мной подстроенной ситуации - первый для меня кайф.

Люди: Раздражает, когда меня нагружают инфой, которая мне на фиг не нужна; когда люди меняют свои решения быстрее, чем размножаются; и самое главное, когда меня заставляют что-нибудь делать. Симпатизирует, когда людям можно верить (и они тебя не кинут); когда люди верят мне (хотя мне верить нельзя, шутка :)).

О планах:

Парням: Все! Не пью.

Не парням: неплохо было бы встретиться как-нибудь, выпить чего-нибудь...

Мечтаю... разогнать 166-ой до 2ГЦ, комнату до города, бумажник до сейфа банка, а енг - до отбойного молотка :)))))).

Процесс: Kirion (Казарьян Карен).

Процесс запущен с правами: daemon.

В настоящее время просиживаю штаны в славном Московском экономико-статистическом институте. Надеюсь, что получу диплом программиста :). А то все про винды да про винды пишу... Хотя у нас с ними долгая история любви :). Сколько помню, всегда приходилось помогать друзьям, родственникам, друзьям родственников и родственникам друзей настраивать компы. То вирь какой-нибудь залезет (убил бы того, кто написал cih), то электричество отключат. Но с кривыми руками не сравнится никакой вирь :). Так незаметно я стал выполнять частные заказы за скромную оплату. Однажды позвонил мне Дронич и попросил с компом какого-то левого чела разобраться. После пяти часов жесткого порно с компьютером я начал сильно жалеть, что мне платят не по часам. Владелец же не мог дать четкое объяснение, кто и как долго измывался над компьютером, чтобы на нем оказалось сразу столько проблем. О том, что надо мной прикололись, я узнал чуть позже, когда нашел дико смеющегося Дронича в соседней комнате. А о том, что он из Spez-Crew и это всего лишь тест, я узнал, когда гонялся за ним по квартире с целью задушить его проводом от мыши :). Так я и стал идейным WINformator'ом. А еще перестал выполнять частные заказы, нервы все-таки дороже...

Люблю отдыхать :). Хорошая компания, хорошая музыка, хорошие фильмы. Не то что бы я очень ленив :), но не люблю, когда меня заставляют что-то делать. Хотя в помощи обычно не отказываю. Я киноман, очень люблю качественное кино, желательно англоязычное. Любимый фильм - American beauty. Обожаю фэнтэзи, любимая книга - "Властелин Колец". Любимая ось - WinXP :).

Мечтаю поработать бета-тестером в MS :). Очень хочу стать хорошим программистом, только бы мне хорошо платили за то, что я умею делать (ну или учусь делать :)), причем в нашей стране. А то до silicon valley далековато ехать. Надеюсь, что мои статьи приносят пользу читателям и наша рубрика не прекратит свое существование :).

Процесс: Alexys (Алексей Беляев).


Спецвыпуск Xakep, номер #026, стр. 026-006-9, Команда v 2.0

Команда v 2.0

Спецвыпуск Xakep, номер #026, стр. 026-006-9

Процесс запущен с правами: daemon.

Немного эстетствующий по жизни человек, забивший на все предубеждения по поводу внешнего вида.

В журнал попал не совсем случайно, правда особым рвением не отличался для этого :). А вышло это вот как. Есть такой перец Dronich, который в свое время утверждал, что писать статьи в Спец не так легко, как любые реферы или отчеты в универе. Не привыкший всему верить на слово, я сказал, что, типа, прогон все это. И довелось мне летом 2002-ого попробовать... "Намного легче было бы сделать здоровенную курсовую повышенной трудности в институте!" - думал я, пока писал свою первую статью. Но "не так страшен черт, как его малютка". После небольшого тренинга и въезжания во все фишки я теперь продолжаю стараться вести компьютерно-просветительскую деятельность.

Из увлечений могу выделить следующее: игра на гитаре, веб-дизайн, компьютеры, музыку на CD и в MP3.

В плане музыки люблю послушать таких исполнителей, как Espen Lind, Richard Marx, The Calling, Nek, Darren Hayes, Savage Garden etc. Другую музыку возможно под настроение, но лишь бы она не грузила. Вообще грузиться не люблю и не люблю, когда грузят. Приветствую просмотр либо психологических фильмов (Жестокие игры 1,2, Помни, Игры разума), либо с хорошей компанией и с хорошим пивом комедии (Van Wilder - Король вечеринок, 40 дней, 40 ночей). Ужастики (кроме старых) не люблю. Не люблю шумные тусы. Обожаю прогуливаться тихим вечером и ночью, слушая в плеере что-нибудь из моих музыкальных пристрастий и раздумывая над происходящими со мной событиями.

В ближайшие планы входит закончить институт, а вот планы на длительное время строить не имеет смысла, ибо по законам Мерфи все пойдет совсем не так, как было задумано. Жениться надо будет как-нибудь, но это пока подождет :).

Процесс: Mr. False (Авдеев Иван).

Процесс запущен с правами: daemon.

Все началось с того, что я внезапно для себя родился. После этого горестного и весьма неприятного (по ощущениям) события все шло, насколько помню, своим чередом (в песочнице играл, за девочками бегал), однако первые отклонения от нормы начались, когда батяй приволок комп с работы. Этим чудом было 486SX25 с 4 метрами памяти. Да, приятель, был это далекий 1994 год, а по тем временам, надо сказать, тачка не слабая... Стоит ли говорить, что уже через пару недель у нее был низкоуровнево (через BIOS) отформатирован винт... После этого приходил злой дядька в усах, и мне, чтобы не получить по заднице, пришлось все отрицать. Уже тогда я понял главную истину этой жизни: нагадил - утекай. После наладки компа и проведения воспитательной беседы (имевшей весьма сомнительное действие) я принялся играть в игры (Дюна2, Дум2, Commander Keen, если еще кто такие помнит). Потом была первая книжка по басюку на день рождения, курсы по паскалю, книжка и MSDN по C++, ночные бдения над ассемблерным кодом (кстати, все на той же четверке), первые Blur'ы, Plasm'ы, Blobs'ы, горящие кубы (http://bmtz.bip.ru/cgi-bin/download.cgi?fname=gfxsdk.zip ;)), метания между OpenGL и Direct3D и затем полный переход на Direct3D...


Спецвыпуск Xakep, номер #026, стр. 026-006-10, Команда v 2.0

Команда v 2.0

Спецвыпуск Xakep, номер #026, стр. 026-006-10

Свой первый ][ купил в июле 1999 года и, честно говоря, даже предположить не мог, что когда-нибудь буду в него писать. Но...

Захожу однажды, летом 2000 года, на сайт ][ и вижу скромную надпись, дескать, мы ищем авторов для работы над Спецом по кодингу, предлагайте свои темы. Предложил написать про Direct3D. Со мной согласились ;).

И понеслось...

Сейчас:

В свободное время (т.е. когда хочется) занимаюсь кодингом, дизайнерством, 3д-моделлингом (только lightwave! 3dsmax - сосет надувных тюленей), неудачными попытками сбацать свой музон, прокладкой локальной сети, паянием самодельных девайсов к компу, поиском смысла жизни и распитием спиртных напитков в общественных местах.

Люблю: Девушек, витую пару, CD-RW, синий маркер, Direct3D, WinAPI, астрал, ТВ-тюнеры, Motorola V100, демки (liquid.wen by Haujobb, fr-019 by Farb-Rausch).

Не люблю: Гомосеков (на дух не переношу!), коаксиал, ATXовые блоки питания, 3Dsmax, opengl, объективную реальность, deadline, спать и есть.

Из музыки предпочитаю, в основном, электронику: Aphex Twin (Jynweythek Ylow), The Future Sound Of London (Dead Skin Cells), Orbital (Adnan's), Crystal Method (Bad Stone) и пр.

Кино (а тем более телек) по большей части не люблю, однако есть немного фильмов, которые мне понравились: "13 этаж", "Завтрак для чемпионов", Resident Evil (это надо смотреть одному часа в три ночи) и Final Fantasy (the spirits within).

Литра: Лукьяненко, Пелевин, Пирс Энтони и... ммм... Даниил Шеповалов на пару с Еленой Петровной Блаватской =).

В людях: не люблю тупых эгоистичных дебилов (привет, Серега! =). К остальным отношусь спокойно и с уважением.

Планы на жизнь: на ближайшее время - сдать сессию =) и съездить на демо-пати.

В далеком будущем - пойти работать в ИЯФ (институт ядерной физики).

Процесс: andrusha (Каролик Андрей).

Процесс запущен с правами: daemon.

Попал я в журнал совершенно случайно, не было никаких связей или друзей в редакции. Наткнулся на просторах инета (в IRC) на главного редактора ][. Разговорились, я предложил состряпать материал про IRC (мой самый первый материал), попробовал и понравилось. А потом и в Спец потихоньку перебрался. Причем никакой звездной болезни в диагнозе не было, как многие думают об авторах статей. Нравилось доходчиво и с юмором излагать свои мысли, которые потом многим пригодились, судя по отзывам, которые мне приходили. А делая интервью на разные темы (оружие самозащиты, 1С, МТУ, М9), было интересно поездить и пообщаться с совершенно разными людьми, с которыми я никогда бы в обычной жизни не пересекся. Одним словом, журналист - мое любимое хобби, дающее мне много позитивных эмоций.

Люблю: маму ;) (и всех родственников), самосовершенствоваться (во всем), быть лидером, общение, позитив, улыбаться, любить девушек :), интимный ужин при свечах (можно обед и завтрак), наблюдать природу, солнце, фантазировать, динамику, ходить в кино/театр/концертный зал (и т.п.), заниматься спортом, кататься на роликах (большой компанией), путешествовать, спотыкаться, но не падать :).


Спецвыпуск Xakep, номер #026, стр. 026-006-11, Команда v 2.0

Команда v 2.0

Спецвыпуск Xakep, номер #026, стр. 026-006-11

Не люблю: пессимизм и негатив (в любых проявлениях), долго ждать, много раз повторять, ничего не делать, свою лень, неопределенность, нерешительность, трудоголиков (алкоголиков тоже).

Планы на будущее самые прогрессивные: получить второе высшее образование (Школа менеджеров, первое было в МЭИ), найти постоянную высокооплачиваемую работу или создать свое собственное дело, не стать трудоголиком и почаще общаться со своими друзьями, любить и быть любимым, не терять свой заразительный оптимизм :). И, конечно же, радовать тебя новыми и интересными статьями.

Процесс: Alex Shark.

Процесс запущен с правами: daemon.

Стандарт совковой закваски, детский сад, школа, институт, работа. Школа обычная, если не считать уклона в английский язык. Самое страшное началось с 6-го класса, когда, заглянув в класс ИВТ, увидел святую "корвет". Потом с 8 по 11 классы городские олимпиады по информатике с переменным успехом. Первый комп дома, ZX-80, там же и первые взломы, там же и изучение ассемблера, архитектуры компа. Позже чудо советской мысли ЕС-1841, суперграфика CGA. Потом 386, дум с другом по модему, асм 8086, Qbasic. Потом долгожданный пень 75, небольшие проделки в чате miller :). Первые знакомства по аське, VB. Начало С и линуха, Slackware со всеми его (не)удобствами, MSVC и все, что с ним летит. Подарок на день варенья Селерон-266, который был в первый же день подогнан до 400, так до сих и пашет. Ныне работаю специалистом по информационной безопасности, иногда пишу софтик (не очень большой, но вроде работоспособный). С ][ познакомился довольно давно, но поначалу статьи не очень были, было все то, что я и так знал, а потому скучновато. Позже в библиотеке нарвался на журнал, почитал, понравилось. Было, что написать, написал про "Жесткий мягкий диск", после чего смотрел сайт каждый день. Позже спросил, типа, статья-то нужна или забить? Оказалось, что вышла в летнем номере, счастья было по самые уши :), так, собственно, и стал автором. Узнай мои учителя по русскому-литературе, что я пишу статьи, пристрелили бы, наверно. Увлекаюсь музой, писал сам на треккерах, из музы нравится Metallica, Prodigy, Nine Inch Nails, DDT, Nautilus, Сплин. С едой все просто, мясо в любом виде. Кино (как и книги) - люблю фантастику, но только хорошую и продуманную, комедии, но опять-таки не с тупейшим америкосовым юмором, есть фильмы, которые и у них мне нравятся, но далеко не все. В людях мне вообще мало что нравится, по большей мере воспринимаю как неизбежное зло, а поскольку людей больше, чем 1, значит с этим надо смириться, но тут, как всегда, не все йогурты одинаково полезны, бывают и в людях исключения.

Планы простые: попытаться дожить до конца, и если нельзя по правилам, то бум читить и хакать этот FullLife; как говорят - "игра тупая, но графика обалденная".

Процесс: MOOF (Андрей Петухов).

Процесс запущен с правами: daemon.

Знаком с Х очень давно, с первого номера. Было это в начале далекого 99 года: помню, иду я домой, смотрю - продается журнал с мегапопулярными тогда Бивисом и Батхедом на обложке, да и название у журнала было близкое мне по духу: "Хакер". Дай, думаю, куплю. И купил! Сперва читал, потом решил написать, благо тогда баловался написанием заметок в другие журналы. Первый блин, естественно, был комом, но потом, врубившись в тему журнала, - поехало. Потом появился Спец, который я тоже не смог обойти стороной. С тех самых пор и подсел я на этот журнал.


Спецвыпуск Xakep, номер #026, стр. 026-006-12, Команда v 2.0

Команда v 2.0

Спецвыпуск Xakep, номер #026, стр. 026-006-12

Увлекаюсь, ясное дело, компьютерами, сотовыми телефонами, прослушиванием музыки, просмотром фильмов, общением с друзьями. Интернет-маньяк ;).

Музыку слушаю абсолютно разную от рэпа до металла, под настроение. Люблю европейское кино, где основной упор делается на качество фильма, а не на спецэффекты.

Ненавижу звук будильника, понедельник, сессию. Не люблю слишком умных и правильных людей, дающих советы. Вообще многие вещи мне неприятны, если их перечислять, то формата журнала не хватит. Если кому интересно, пишите, расскажу, как сделать мне гадость :)).

Процесс: matt (Гофф Матвей).

Процесс запущен с правами: daemon.

Студент факультета прикладной математики Днепропетровского национального университета

В Spez-бригаду я попал еще в те времена, когда поголовное увлечение ][ у нас только начиналось. Будучи чуть ли ни единственным обладателем тогда еще мистического "Интернета", я залез на ксакеп.ру и увидел объяву: требуются, мол, чуваки, знающие кодинг, - будем писать статьи. Ну, будем, так будем. Оставил я заявку и через 3 недели уже сдал свою первую статью - "Справочник конспиративных квартир на VB", - которая, льстя моему самолюбию, легла на три полосы четвертого Спеца по кодингу. Потом первый гонорар! На оставшиеся от заливания гонорара материальные ценности я приобрел крутящийся стул-кресло на колесиках, на котором сейчас сижу и калякаю эту историю. Колесиков уже, правда, не осталось...

Ну вот, собственно, вся биография... творческий путь, я бы сказал.

Из всех увлечений важнейшим для нас является кампутер. Хорошо это или плохо, не рискну однозначно ответить. Факт одинокого созерцания 15' монитора иногда серьезно угнетает, и случаются кратковременные депрессии. Выходить из них помогает отечественный и калифорнийский панк. PUNK'S NOT DEAD!!! Здорово выручает меня музыка! Этим летом даже поперся за 1000 км на Нашествие 2002. Далековато, но, как по мне, оно того стоило.

Временами увлекаюсь твердотельным моделированием. Страшное слово, да? Это типа 3DS, только для конструкторов.

Если кому интересно, есть у меня любимая девушка, разбалованная собака и (пока) стипендия 39 грин., 57 коп. (в переводе на либеральные ценности ~ 7,5).

Конкретных планов на жизнь не имею. Разве что закончить универ, откосить от армии, завести семью, найти работу и купить новый Nissan Primera.

Ник: Frozen (Малашин Алексей).

Процесс запущен с правами: daemon.

Кто я есть? Да обычный чел, студент второго курса одного московского городского института, следы которого теряются в окрестностях Китай-города. Занимаюсь тем, что учусь, работаю, статьи в ксакеп пишу, а когда есть свободное время, то просто забиваю на все и страдаю фигней :). В Спец я попал очень удачно, а главное вовремя, и случился сей попадос довольно неожиданно, темным зимним холодным декабрьским вечером и, судя по всему, не на совсем трезвую голову (или совсем не трезвую - кому как больше видится :) - я тогда возвращался домой после бурно проведенного дня ;) и, с чего-то остановившись около ближайшей палатки, купил на последние деньги первый попавшийся на глаза комповый журнал, коим и оказался этот самый Spez-][. А поскольку в тот момент моя творческая энергия плескалась, бурлила и возбухала в поисках дырочки, чтобы выплеснуться наружу веселым журчащим ручейком мыслей и безумных идей, руки как-то сами, под воздействием команды из моего ЦУП aka Головной Мозг, набили несколько байтов тогдашнему редактору - товарисчу Холоду, после чего произошел аварийный shutdown всех систем жизнеобеспечения в виде крепкого, молодецкого, беспробудного сна... Я уж и забыл про ту мессагу, как на меня свалилось письмо, после чего я и стал автором в журнале, и теперь результаты моих поисков ты ежемесячно можешь лицезреть в виде обосрева книг и подборки разных сайтов а-ля haX0rz4haX0rz.


Спецвыпуск Xakep, номер #026, стр. 026-006-13, Команда v 2.0

Команда v 2.0

Спецвыпуск Xakep, номер #026, стр. 026-006-13

Увлечения: программирую всякие полезные и не очень проги, играю на гитаре, когда есть время, занимаюсь народным корейским боевым искусством - TaekWon-Do, поддерживаю свой сервак в локальной сети.

Люблю: солнышко ;), поспать утром, помучить комп компилированием новой супермегапроги или установкой полезной приблуды на сервак.

Не люблю: просто дико ненавижу тиканье часов, а особенно старых железных будильников, вставать рано утром.

Еда: до одурения люблю кокосы и сыр, особенно расплавленный.

Кино: я вообще не смотрю кино - не нравится мне это занятие :(.

Люди: люблю всех по дефолту.

Мечта: заиметь бамбуковый домик, затерявшийся где-то на вершинах Тибета.

Пингвинов (Pingvinov).

Процесс запущен с правами: daemon.

Пришел в редакцию с улицы. ][ и Спец покупал довольно часто, и журнал понравился с самого первого номера - и легким стебом, и приличным содержанием.

Ну вот, значит, обнаружив в очередном Спеце призыв "Ау, авторы!", я написал пару статей о том, в чем немного разбираюсь, и Ноа с Дроничем сказали, что это из гуд, пиши дальше. Для журнала надо придумать себе псевдоним, поэтому я решил стать Пингвиновым и Радиатором, потому что моя настоящая фамилия Альбатросов :)). То есть это не совсем та фамилия, что в паспорте, но зато она моя самая любимая, а в паспорт я стараюсь заглядывать пореже, чтобы не так огорчаться.

Дронич особо отметил, что про увлечения надо написать по пунктам. Это интересная мысль. То есть помню-то я всех, но мне кажется, что это было бы несколько невежливо, да и нескромно... Лучше я каждой посвящу по рассказу когда-нибудь :).

Еще я люблю ездить в другие города и страны, этим особенно приятно заниматься на халяву, когда отправляют в какое-нибудь интересное место в командировку. В самые классные места, правда, приходится ездить за свои :(.

Музыку люблю, но особых предпочтений нет - под настроение хорошо послушать и Вагнера, и Глена Миллера, и Эминема. В кино очень понравились "Джей и Мочаливый Боб..." и другие фильмы этой команды.


Спецвыпуск Xakep, номер #026, стр. 026-006-14, Команда v 2.0

Команда v 2.0

Спецвыпуск Xakep, номер #026, стр. 026-006-14

Заветная мечта: жить и работать на берегу Красного моря в Египте, на работу ездить по полчаса в день на велосипеде и писать в каждый номер Спеца одну-две статьи.

Процесс: Slam (Скрыпников Сергей).

Процесс запущен с правами: daemon.

В настоящий момент пробакланиваю лучшие годы в жизни человека, то есть являюсь студентом ВУЗа, учусь, кстати, на программиста.

В команду попал быстро :). До этого я печатался в обычном ][, но затем мой круг интересов расширился, и я решил попробовать себя в Спеце. Написал Ноа письмо, отослал анкету. Первой статьей была "Обзор CGI сканеров", и когда Ноа сказал, что моя статья просто супер и я должен продолжать в том же духе, то я незамедлительно воспользовался его советами, и поэтому ты видишь меня тут.

В реале я люблю ходить на дискотеки, пить пиво в компании друзей, увертывать за герлами и т.п. В общем - обычный, нормальный тинэйджер :). Естественно, все меняется, когда передо мной прорисовываются попиксельно очертания монитора... хотя... хотя это уже совсем другая история.

Люблю работу, спорт (плавание, хоккей, футбол), болтать по аське, компы (от игрушек до железа), девушек (от и до :)), музыку, учебу (хотя... может это она любит меня?!), отзывчивых людей, у которых не завышенная и не заниженная самооценка.

Не люблю молоко, ламаков, которые кричат направо и налево, что виндовз - маст дай, а никс - форева, гопников, которые строят из себя пуп земли, - много чего еще не люблю.

Пристрастия в музыке очень различные, так что слушаю почти все - и Тату, и Круга, и Linkin Park, и Кирпичи :). Любимый фильм - "Хакеры". Любимое блюдо - блины с медом (в институте - Хот-Дог :)).


Спецвыпуск Xakep, номер #026, стр. 026-018-1, ВИРТУАЛЬНЫЙ НОВЫЙ ГОД - устраиваем праздник в Сети

ВИРТУАЛЬНЫЙ НОВЫЙ ГОД - устраиваем праздник в Сети

ХрымZ (hrimz@xyligan.ru)

Спецвыпуск Xakep, номер #026, стр. 026-018-1

С наступающим тебя! Наверное, уже вовсю готовишься поднять бокал за Деда Отмороза в кругу друзей и родных. Нет, это, конечно, круто - семейный праздник и все такое. Но что делать, если ты не совсем простой перец и в Инете проводишь времени в несколько раз больше, чем в real-лайф. В этом случае стоит задуматься о том, чтобы отпраздновать очередной New-year, не отрывая задницы от любимого железного друга. О самых модных и киберпанковских способах отпраздновать 2k+3 я и поведаю тебе. Не забудь запастись анлимом, на новогоднюю ночь хотя бы. Лучше, конечно, и на весь январь, а то, знаешь ли, сетевое похмелье и все такое :).

МОДНЫЕ ТЕНДЕНЦИИ

Если хочешь весь 2003-ий ходить и пальцеваться перед пацанами и девчонками, какой ты весь из себя крутой - ровно в ноль часов жмакал на "Enter" вместе с туевой хучей корефанов по всему свету, то стоит задуматься о том, чтобы посетить мега-порталы, специально создающиеся под Новый год. Например, в прошлом году был создан достаточно оригинальный проект в рунете - виртуальные куранты! Типа рисованные часики, которые в нуль часов заливаются колокольным звоном. Только не забудь врубить звуковуху, а то проворонишь весь кайф :). Проект должен запустится за неделю до праздника или типа того и откликаться на запрос в браузере - http://2003.mosk.ru.

Еще есть возможность прикольнуться на сайтах, которые открываются практически перед самым праздником. Что-то вроде www.happynew2002year.org и так далее. Для этого года, соответственно, актуальна ссылка, только вместо второй цифры «два» нужно «три» в строку браузера вписать :). В прошлом году, говорят, там скучать не приходилось, так как праздник продуман до мелочей (хотя кто тебя знает, может ты, наоборот, любишь сумбурность и еще точно не знаешь даже, на какой планете праздновать будешь?). Устроители выкупают за нехилое количество буказоидов всякие "новогодние" красивые доменчики, а потом это все окупается на рекламе; так на Новый год в Штатах найдется куча народа, которая не прочь экстремально провести последнюю ночь в году, проливая шампанское из виртуального бокала. Ну а мы, как настоящие русские мужики из страны медведей и водки, тоже не прочь отведать заморского счастья и поэтому бежим регистрироваться по вышеуказанному линку и ждать заветной полночи... Далее выбор достаточно велик. Во время виртуального торжества ты можешь общаться в чате с охрененным количеством каналов, посмотреть через зоркий глаз не очень-то дорогой веб-камеры на центральную площадь многих городов мира. Также у тебя есть шанс присоединиться к бесконечному по размерам праздничному столу, где любые угощения и выпивка бесплатны :). Хотя как сказать, например, 100 граммов салата оливье весит килобайт 40-50, а это несколько секунд траффика на dialup`е :). То есть все равно платить придется, если, конечно, анлимом не обзавелся. Все эти салаты/бокалы/яблоки нарисованы во флэше и не всегда выглядят аппетитно. В общем, как ни крути, если хочешь хорошего праздника на таких вот проектах, то изволь сесть на выделенку, закупиться реальным хавальником и спиртным, а то не видать тебе Джингл Бэллсов и не смотреть красивого видео.


Спецвыпуск Xakep, номер #026, стр. 026-018-2, ВИРТУАЛЬНЫЙ НОВЫЙ ГОД - устраиваем праздник в Сети

ВИРТУАЛЬНЫЙ НОВЫЙ ГОД - устраиваем праздник в Сети

ХрымZ (hrimz@xyligan.ru)

Спецвыпуск Xakep, номер #026, стр. 026-018-2

ОБЩЕНИЕ

Вот еще один несложный вариант проведения Нового года в Сети. Он предназначен для настолько ленивых перцев, которым даже в лом регистрироваться на праздничных серваках. Просто врубай асю, мирк или любимый ввв и давай чесать языком все ночь. Имхо, не очень-то это весело. Лучше вначале подготовиться основательно, немного попарившись, но зато потом кайфовать все оставшееся время. Вот об этом я тебе и поведаю в конце статьи.

CraZee Old sc00l ][@c|<eЯz

Если ты настолько пробитый партнер своего железного друга в страшных ночных оргиях, что во время предвкушения оргазма из твоей пасти вырываются куски исходников tcpdump`а, то, возможно, вообще стоит забить на праздник. Ведь тогда ты потеряешь драгоценные сутки на какую-то бесполезную виртуальную пьянку вместо того, чтобы дописать никсовую версию ускорителя самогонного аппарата. Короче, если жалко тратить время на праздник, просто никак не выделяй новогоднюю ночь из других ночей, а по обыкновению посиди за компом и занимайся обычными делами. Типа всякие Снегурки тебя не втыкают, и когда еще Мороз под стол пешком ходил, ты уже управлял американскими военными спутниками и все в таком же духе. Не то что бы я противник такого варианта, но это... не мое, что ли? Да, я понимаю, что все вышенаписанное - это активная пропаганда извращении на страницах журнала, но что поделаешь, такие перцы тоже встречаются, и нужно относиться сдержанно к чужим недугам :).

КЛУБЫ

Нет, не подумай, что я буду тебя агитировать идти в "простой" клуб, все намного сложнее :). Если присмотреться к теме статьи, то можно догадаться, что речь пойдет о компьютерных клубах.

Самый стремный вариант - это просто купить себе ночь в любимом клубаке и проиграть ее в Контру или Третий Варкрафт. Но даже простое геймерство можно немного разнообразить. Например, устроить новогоднее соревнование с ценными призами. Трехлитровым ботлом абсента, например :). В Новый год, думаю, админы не будут особо возражать. Но есть вариант лучше. Практически во всех известных и крупных компьютерных клубах в ночь Деда Мороза устраиваются угарные пати, на которых можно оттянуться по-зверски. То есть компьютеров навалом. Офигенные конкурсы, дешевое спиртное, закусь, море звука и света. Главный плюс этого способа празднования в том, что ты совмещаешь реальный праздник с виртуальным. Соответственно при правильной раскладе и кайф будет удвоенный :). Короче, собирай орду и бегом серфить по официальным сайтам клубаков. Мест пять точно откопаешь. Ну, для затравки пробегись по пагам CafeMax`а или Netland`а...

САМОДЕЛКИН

Для начала набери большую тусу хороших чуваков, которые не прочь оттянуться в Инете в главную ночь. Только желательно выбирать либо давно знакомых друзей в реале, либо проверенных перцев из сети. Не стоит приглашать на приватную вечерину Машу-кашу, о существовании которой ты узнал три дня назад. Из-за таких вот Маш весь сейшен может насмарку пойти. Итак, уже пройдя жесточайший отбор, осталось 25 перцев. Ну хорошо - 20. Для начала договоритесь, чтобы в новогоднюю ночь ни у кого не было проблем с Инетом и вообще с подготовкой компа. Посему компьютерные клубы отпадают. В конце концов, Новый год - семейный (ака домашний) праздник, вот с домашней тачки и будем праздновать :). Зарегистрируй на каком-нибудь бесплатном хостинге, желательно без рекламы, прикольный домен (что-то вроде http://ourcrazeenewyearparty2003.hoha.ru, кстати, этот самый hoha.ru можешь и заюзать - вроде не очень глючно работает...) и приступай клепать сайт. Там в обязательном порядке должны быть свои мега-запароленный чат, гостевуха или, в крайнем случае, форум :). Далее в irc создавай канал и активно защищай красивое имя от нападения злобных хацкеров. Если кто-то из твоих корефанов (или ты сам) круто рубит во флэше - замутите свой неповторимый виртуальный стол. Со своим меню и т.д. Праздник все-таки - соответственно рамки стеба расширяются :). В общем, идея дана - развивай и реализуй!


Спецвыпуск Xakep, номер #026, стр. 026-018-3, ВИРТУАЛЬНЫЙ НОВЫЙ ГОД - устраиваем праздник в Сети

ВИРТУАЛЬНЫЙ НОВЫЙ ГОД - устраиваем праздник в Сети

ХрымZ (hrimz@xyligan.ru)

Спецвыпуск Xakep, номер #026, стр. 026-018-3

ОКОНЧАНИЕ

Вот и подошел к неизбежному концу мой небольшой рассказ о виртуальных празднованиях. Это, конечно, все дико модно для кого-то, но, имхо, лучший Новый год это Новый год на приватной даче, с кучей друзей, морем пива и т.д. Снежки, Дед Мороз и веселые песни. Удачного тебе 2003-го!

Линки на забугорные ресурсы по теме. Енджой!

www.firstnightintl.org

4newyear.4anything.com

www.usis.usemb.se/Holidays/celebrate/newyears.html

www.123greetings.com/events/newyear

www.greetsomeone.com/december/newyear.htm

www.geocities.com/Athens/Acropolis/1465/nyparty.html

www.patswebgraphics.com/newyear/newyear.html

www.postcards.org/postcards/cards/0340

www.geocities.com/Heartland/Plains/7214/newyear.htm


Спецвыпуск Xakep, номер #026, стр. 026-022-1, ЗАСПИРТОВАННЫЙ КОМПУТЕР - как по пьяни комп собирали

ЗАСПИРТОВАННЫЙ КОМПУТЕР - как по пьяни комп собирали

Деметрас (demetras@xakep.ru)

Спецвыпуск Xakep, номер #026, стр. 026-022-1

Дарова, малопьющие и многозакусывающие кулхацкеры! Сегодня я с перерывами на опохмел расскажу вам поучительную историю о том, как НИЗЯ собирать компутер (это опасно не только для вас, но и для окружающих).

ПОДГОТОВКА

Ну так вот, собрались мы тут как-то намедни с Девилом на Савеллово Bazar, собрать ему по случаю дня рождения новый компутер. Собрали ;). Впрочем, обо всем по порядку...

Утро, квартира Devila (коммунальная, с тараканами). Сели обсуждать предстоящий поход на рынок, через 10 мин. почувствовали, что чего-то не хватает, еще через 10 поняли, чего именно - необходимо заправиться. Сходили в ларек, купили водки, заправились. Завалились домой. Спотыкаясь о пивные бутылки, коих в квартире было великое множество, добрались до стола и сели обсуждать дальше, благо всевозможные прайсы и тесты были собраны заранее. По поводу комлектухи к консенсусу не пришли, и было решено выбирать из того, что будет.

GO-GO-GO!

Кое-как добрались до базара, жутко замерзли - пришлось еще покупать водку. Выпили, оказалось мало. Пришлось купить еще. Допив водку, купили еще по бутылке (про запас), решили, кто чего будет покупать, и договорились встретиться через час. Через час не встретились. Покупать комплектуху на пьяную морду оказалось сложно - все прайсы как-то странно плавали и не давали себя прочитать. Но я героически выполнял возложенную на меня миссию. Прохожие как-то странно посматривают вслед и шарахаются в разные стороны. В одной из палаток обнаруживаю собутыльника. Он, покачиваясь, стоит и с умным видом рассматривает прайс, хотя по глазам видно, что прайс ему уже давно по барабану, но зато обнаружилось, что он уже все купил.

ВОЗВРАЩАЕМСЯ

Как добирались домой - не помню, очнулся я уже в квартире у Девила с бутылкой водки в одной руке и кубинской сигарой в другой (откуда взялись сигары - до сих пор не знаем, но под кроватью был найден целый ящик :)). Рядом с ящиком в пакете была найдена резиновая тиотка неизвестного происхождения, но явно новая - запечатанная и с инструкцией по использованию. После короткого обсуждения тиотка была надута и закинута на балкон соседа снизу. Приступили к сборке компа.

Снизу послышались какие-то звуки, мы вышли на балкон - орала жена соседа снизу. Самыми приличными словами были "ушлепок" и "извращенец". Пришли с балкона, замерзли, пришлось пить водку. Девил стал прикручивать винт и сидюк. По моей опухшей роже сразу же растянулась плотоядная улыбка (винт падал вместе со мной где-то раз 20, а сидюк падал с Девилом раз 30, так что особой вероятности, что они заработают, не было). Тем временем я, поняв, что один он не справится, кое-как поднялся и стал предпринимать попытки поставить на мать новенький двухгигагерцовый Атлон ХР. Пытаюсь попасть процессором в сокет - руки безбожно трясутся, во попал. Теперь надо поставить кулер. Эх, что-то пружина у кулера жесткая, надо надавить посильнее. Ну и надавил! Под кулером что-то предательски хрустнуло, я прикинулся шлангом (гофрированным, ГОСТ 1987), типа ничего не заметил, после чего дал мать Девилу для последующего вкручивания в кузов. Путь Девила с матерью до кузова был полон препятствий и опасностей в виде сотен бутылок из-под разных огненных жидкостей, которые собирались тут годами. В результате двух падений мать лишилась еще пяти конденсаторов (еще 3 были выдраны мной при установке кулера). И вот компутер был собран.


Спецвыпуск Xakep, номер #026, стр. 026-022-2, ЗАСПИРТОВАННЫЙ КОМПУТЕР - как по пьяни комп собирали

ЗАСПИРТОВАННЫЙ КОМПУТЕР - как по пьяни комп собирали

Деметрас (demetras@xakep.ru)

Спецвыпуск Xakep, номер #026, стр. 026-022-2

После того как Девил, тихо матерясь, пополз от собранного компа в сторону аптечки (он чисто случайно что-то там вкрутил себе в руку), я решил совершить героический поступок: проползти к нему (ессно к компьютеру) через всю комнату и посмотреть, что он там насобирал. Когда я увидел ЭТО, меня накрыл приступ смеха, я наступил на пустую бутылку, упал и отрубился.

ШОУ МАСТ ГОУ ОН

Очнулся, Девил ползает по комнате кругами и, громко матерясь, пытается поймать какую-то Кибермуху. Ладно, пусть пока поползает, а я займусь компом. Вытряхнув все лишние конденсаторы, резисторы и какие-то катушечки (отломанные Девилом), воткнул видюху. В общем, я не знаю, как я это сделал, но пока подключал шлейф к винту, отбил на видюхе кучу всяких деталек. Звуковуха и память, как ни странно, пока оставались целые. Собрал, в это время подполз Девил и стал внимательно следить за моими действиями. Включил комп в сеть, далее диалог по ролям:

Комп: пшш!

Девил: Мля!

Деметрас: Мля-я-я-я...

Стали выяснять, кто сказал "пшш", нашли. В матери насчитали 5 дырок и 2 сгоревшие дорожки, попутно стало понятно, что при попытках прикрутить мать Девил наделал в ней дырок, хороших таких, больших дырок (в качестве отвертки использовалась совковая здоровенная дрель размером почти с компьютер). После подробного анализа пробоин выяснилось, что:

а) с гарантийкой можно сходить в сортир;

б) при желании это можно было пофиксить, вооружившись паяльником.

Перед ответственной операцией было решено еще выпить. Для восстановления ободранных дорожек на матерях (как, впрочем, и на остальных компьютерных девайсах) необходимо иметь как минимум две вещи: это паяльник мощностью не более 40 ватт с остро отточенным жалом и какой-нибудь увеличивающий девайс, например, на Митино-базаре продается специальная хрень, напоминающая с виду трехмерные очки (кои даются к некоторым видюхам), но с хорошими линзами вместо жк-матрицы, еще неплохо бы прикупить паяльную жидкость.

НАЧНЕМ-С

Края оборванных дорожек мы аккуратно на 1 мм зачистили скальпелем, после этого сверху была нанесена паяльная жидкость и края дорожек аккуратно залужены. После берется любой низковольтный проводок (например, от плеера) и зачищается, далее видим, что проводок скручен из тоненьких волосков. Так вот, распускаем энтот проводок и берем один такой волосок. Залудив, аккуратно припаиваем к одной стороне дорожки (там, где зачищали), потом, слегка натянув, припаиваем к другой стороне. Секунд через 10, когда припой затвердеет, отрезаем скальпелем лишнюю часть проводка. Все, теперь осталось аккуратно протереть пайку спиртом и замаскировать. Для этого надо найти какой-нибудь старый девайс (желательно брендовый, но без логотипов)и поискать на нем наклеечки типа "QC PASSED" или "QC OK" (что переводится как "проверка на качество прошла успешно"). Эта наклеечка аккуратно отдирается и лепится на паечку ;))). Мать готова к впариванию. Сам я включать ЭТО не решился, дал Девилу. Странно, наверно что-то я неправильно запаял - оно заработало. Ну что же, бывает и такое :). Cели отметить - решили не злоупотреблять и выпили только по литру отвертки. Вообще, хоть и кое-как, но заработало все, кроме сидюка, а на винте обнаружилось 700 мегабайт бэдов (да и видюха выдавала такое изображение, что даже под грибами в страшном сне увидеть нельзя).


Спецвыпуск Xakep, номер #026, стр. 026-022-3, ЗАСПИРТОВАННЫЙ КОМПУТЕР - как по пьяни комп собирали

ЗАСПИРТОВАННЫЙ КОМПУТЕР - как по пьяни комп собирали

Деметрас (demetras@xakep.ru)

Спецвыпуск Xakep, номер #026, стр. 026-022-3

ТОТАЛ ДЕСТРОЙ

После короткого совещания было решено к винту и видюхе применить высшую меру наказания для сдачи в сервис (тем более, что видюха оказалась не четвертым гефорсом, а вторым эмыксом). Для этого был выбран надежный и проверенный способ. Из лампового телевизора выдираем конденсатор, в принципе любой, но рассчитанный на напряжение не менее 400 вольт. Искать его стоит возле блока питания (громадный такой трансформатор). Потом, в зависимости от того, что надо убить, подбирается разъем, в нашем случае для убийства видюхи был отодран AGP слот со старой матери (это необходимо для того, чтобы на девайсе не осталось следов после замыкания). К контактам конденсатора надо примотать два проводка и с ног до головы обмотать изолентой, т.к. тебя в сервис уже никто не сдаст. Видюха была вставлена в слот, а кондер в розетку секунд на 5, после чего заряженный кондер и видюха контактировали. В итоге мы получили дохлую видюху для сдачи в сервис. Так же злостно поступили и с винтом. Выпив за упокой железа, стали собираться обратно на рынок. Кстати, забыл напомнить про одну штуку: если оторвали, к примеру, кондер, то ножки его останутся торчать во всей красе, предательски выдавая случившийся дестрой. Чтобы барыга/ламер (нужное подчеркнуть) этого не просек, надо обрезать остатки под корень с той стороны, где деталька стояла, чтобы не было заметно, что там что-то было.

В общем, видюха была тщательно замаскирована и подготовлена для обмена. Каким чудом работала мать с расколотым камнем, вообще неизвестно, правда она все равно глючила и была похожа неизвестно на что из-за огромного количества наклеек всех цветов и размеров. Ее было решено впарить там же - на рынке.

JUST DO IT! (ВПАРКУС КОРП.)

Чудом опять доехали до рынка, но нам повезло, дело было уже к вечеру (приезжать с таким железом надо попозже, перед закрытием рынка), и барыги были уставшие. Я сам работал на таком рынке и могу сказать, что к концу дня хочется только жрать и спать. Поэтому все, что могли, поменяли, и никто ничего не заметил. Поменяли все, кроме матери с процессором. Ее впарили какому-то лоху за 2/3 цены, прикинувшись наркоманами (видок у нас был уже подходящий). Он долго торговался и причитал, что денег у него мало (Ага! Мало! - в пакете у него лежал плексторовский резак и коробочный Аудиджи), его, типа, папа послал на рынок, а денег не хватает. Короче, царствие ему небесное, а комп мы будем собирать завтра, на чистую похмелившуюся голову =))). Ну все, я пошел. Звонит сосед - договариваться, когда мы сможем с ним сходить купить компьютер.


Спецвыпуск Xakep, номер #026, стр. 026-022-4, ЗАСПИРТОВАННЫЙ КОМПУТЕР - как по пьяни комп собирали

ЗАСПИРТОВАННЫЙ КОМПУТЕР - как по пьяни комп собирали

Деметрас (demetras@xakep.ru)

Спецвыпуск Xakep, номер #026, стр. 026-022-4

З.Ы. Пытаться повторять что-либо из написанного настоятельно не рекомендуется.

Весь текст (в том числе эти строчки) является плодом моего больного воображения, сам я этого никогда не делал и не буду.

З.З.Ы. Претензии по поводу "А-а-а! Мне набили морду и лишили гарантии" не рассматриваются. Думать надо своей головой, да и статью о мошенничестве еще никто не отменял.


Спецвыпуск Xakep, номер #026, стр. 026-024-1, НОВОГОДНИЕ ФЕЙЕРВЕРКИ - хай-тек солюшен

НОВОГОДНИЕ ФЕЙЕРВЕРКИ - хай-тек солюшен

Деметрас и Дронич

Спецвыпуск Xakep, номер #026, стр. 026-024-1

Клевый праздник Новый год... И он не был бы таким клевым, если бы не туева хуча разнообразной пиротехники, продающейся на каждом углу в это веселое время.

Я уверен, что ты уже закупился разнообразными ракетами, петардами и прочими взрывпакетами, но взрывать их по старинке, закидывая в форточку соседа, теперь не катит - це исть сукс. Так что будем рассматривать более продвинутые методы приколов над знакомыми гомо-сапиенсами.

ЧТО ДЕЛАЕМ В НАТУРЕ?

Самый простой способ усовершенствовать хорошую петарду - это приделать к ней электрический запал, ибо это просто, как два байта об асфальт. Сделать такую мерзость можно, как минимум, двумя способами.

СПОСОБ 1

Если петарда небольшая, диаметром с ручку или карандаш, тогда делаем так: по диаметру петарды подбираем колпачок из мягкой пластмассы (от ручки или фломастера). Вставляем в колпачок петарду до упора, чтобы сидела плотно и не вихлялась, после этого быстро соображаем, в каком месте колпачка заканчивается петарда и начинается пустое место (как это сделать, думаю, объяснять не надо). После этого вынимаем петарду на фиг, а колпачок аккуратно разрезаем вдоль длины и поперек ширины (типа напополам) до того места, где заканчивалась петарда. Теперь берем тонкий проводок, скрученный из волосков, и стержень от ручки. Выдергиваем из провода такой волосок (чем тоньше, тем лучше) и накручиваем спиралькой на стержень (5-9 витков), аккуратно снимаем получившуюся катушечку со стержня и вставляем ее в разрез так, чтобы катушечка находилась внутри колпачка (как раз в том месте, где заканчивалась петарда), а контакты торчали в разные стороны. Засовываем в эту конструкцию петарду так, чтобы та часть, которую надо поджигать, находилась впритык к катушке. Теперь приматываем к этому безобразию проводки нужной длины и заматываем скотчем, чтобы это все не развалилось. Перед тем как собирать, поэкспериментируй с катушкой, она должна хорошо раскаляться от обычной 9-вольтовой батарейки и при этом не слишком быстро перегорать.

Работает получившаяся конструкция до боли просто - при замыкании цепи (как замкнуть ее наиболее эффектно, мы еще поговорим) ток побежал по катушке, разогрел ее, от катушки воспламенился огнеопасный кончик петарды, пшшш, бах, ой, мама, скоропостижная кончина конструктора :).

СПОСОБ 2

Берем лампочку от карманного фонарика (естественно, рабочую и рассчитанную на возможно больший ток, так как чем больше ток - тем прочней спираль) и аккуратно проковыриваем в ней дырочку так, чтобы не повредить спираль (в этом деле отлично помогает бормашина, так что если есть знакомые стоматологи...). Обдираем со спичек горючую часть (назвать это серой у меня язык не поворачивается, так как это давно уже не сера, а довольно замороченный химический состав) и, растерев в порошок, засыпаем в лампочку, дырку заливаем резиновым клеем. Что будет, если эту лампочку вкрутить в фонарик/гирлянду/трубку с петардой, можно не объяснять... Только хочу предостеречь, что эта штука, то есть модифицированная лампочка, может (да и должна) очень здорово, скажем так, хлопнуть на букву Е, и стекло полетит, куда глаза глядят... Если не хочешь лишних жертв, залей слоем клея всю лампочку (правда, эффекту от этого поубавится).


Спецвыпуск Xakep, номер #026, стр. 026-024-2, НОВОГОДНИЕ ФЕЙЕРВЕРКИ - хай-тек солюшен

НОВОГОДНИЕ ФЕЙЕРВЕРКИ - хай-тек солюшен

Деметрас и Дронич

Спецвыпуск Xakep, номер #026, стр. 026-024-2

БОЕВЫЕ ДЕЙСТВИЯ

Если хорошо пошевелить мозгами, то, исходя из выше накарябанного, можно придумать кучу диких приколов. Ведь модуль номер один ака взрыватель у нас уже имеется, остается замутить модуль управления ака замыкающий ключ. Например, если взять обычную бельевую прищепку и обмотать ее лапки проводом, то получится отличный замыкатель. Представь себе такую сцену: пришел гость, сел на табуретку за стол (все бы этим гостям за стол), как вдруг его уже изрядно подвыпившее внимание привлекает висящая на скатерти прищепка с двумя проводками. Что он сделает? Правильно! Он ее снимет со скатерти и замкнет контакты. А под табуреткой приклеены ядреная петарда и батарейка. Или за его спиной проинсталлирована елка модели "бен Ладен" с модифицированными лампочками вместо обычных.

ЧЕРНЫЕ ИДЕИ

Вообще-то, существует достаточного много теоретически рабочих способов дистанционного управления или замедления взрыва, а еще больше разных хороших способов ты можешь придумать сам. Все приведенные методы основаны на электрическом запале в качестве взрывателя и оригинальных конструкциях на месте ключа. Вот лишь некоторые из них.

1. ТИК-ТАК ХОДИКИ

Замедление взрыва с помощью все той же схемы, но в качестве замыкателя будут служить стрелки механических часов. Устроить замечательный многоразовый детонатор тебе поможет старенький бабушкин будильник. Он без проблем выдержит взрыв даже самой недетской петарды в радиусе полуметра и заодно позволит использовать свой громогласный звонок в качестве предупреждающего сигнала. По-моему, достойная пьяного праздника картина: оглушительный звон будильника, за столом все замерли, молчание нарушает лишь тиканье часов, капельки пота стекают с щек невинных свидетелей... БА-БАХ! И оливье из тазика плавно сползает по стенам, радуясь скорой встрече с паркетом.

2. RADIOHEAD

Чтобы опять же избавиться от проводной системы управления, можно использовать выдранную из старых игрушек систему радиоуправления. Выделить приемник сигнала и найти его контакты будет не так уж сложно, а заюзать такую бронированную систему можно не раз и не два.

3. PUSH IT, BABY

Почти классический метод, несильно усовершенствованный со времен "дистанционного пускателя Прозвонкина": две металлические пластинки, между которыми зажат хлебный мякиш, укладываются под коврик соседу (или под колесо знакомому автолюбителю). Ежику понятно, что наши пластинки замыкают уже знакомую цепь с батарейкой и спиралькой.

4. FUCK DA BASAEFF

Практически военный метод - растяжка из бельевой прищепки. Между разведенными лапками (на которых закреплены контакты) зажимается пластиковая карточка, к которой привязана крепкая леска, натянутая где-нибудь в коридоре. Особо отъявленные фулюганы могут и второй конец лески привязать к карточке, замыкающей вторую же прищепку. Что может быть приятнее, чем попасть под артобстрел в собственном подъезде?


Спецвыпуск Xakep, номер #026, стр. 026-024-3, НОВОГОДНИЕ ФЕЙЕРВЕРКИ - хай-тек солюшен

НОВОГОДНИЕ ФЕЙЕРВЕРКИ - хай-тек солюшен

Деметрас и Дронич

Спецвыпуск Xakep, номер #026, стр. 026-024-3

5. КРОВЬЮ, КАК В МЕТРОПОЛИТЕНЕ

Если твои мозги повернуты в нужную сторону, то тебе не составит труда замутить схемку на фотоэлементах, занимающуюся подрывом при недостаточном количестве света (идеально работает в темных углах, куда под конец праздника любят стекаться всякие несознательные личности).

6. ГРЕНДАЙЗЕР

Обратный эффект предыдущего способа - самые древние читатели Спеца наверняка помнят гениальную связку из лазерной указки и фотодиода ФД 265А, опробованную Эндрю на детекторе движения. Мы же предлагаем тебе универсальную схему подрыва, радиус действия которой ограничен только длиной пучка света из лазерной указки. Достаточно поймать фотодиод пятнышком указки и... Удобно, ничего не скажешь. Стоит заморочиться и отделить петарду от батарейки с диодом, чтобы детонатор стал многоразовым. Модульная система и все такое.

Собственно, на этом наш поток сознания по поводу детонирования взрывхреновин порядком поиссяк. Детонаторы ты уже можешь собирать сам, да и всякие разные петарды, ракеты, фонтаны и разноцветные дымовые эффекты ты тоже не обязан покупать, благо в сети достаточно информации по их изготовлению. Самое главное - всегда будь осторожен, жить с нехваткой конечностей (в основном пальцев) не очень приятно.

МОЯ ХАТА С КРАЮ

И напоследок стандартная отмазка. Ничего не знаем, ни за что не отвечаем и вообще это не мы писали; перед тем как что-то делать, подумай головой - а стоит ли?


Спецвыпуск Xakep, номер #026, стр. 026-026-1, HACKERWEAR - зимний моддинг одежды

HACKERWEAR - зимний моддинг одежды

Андрей "Дронич" Михайлюк

Спецвыпуск Xakep, номер #026, стр. 026-026-1

(dronich@real.xakep.ru)

На дворе реальная зима. Снег, мороз и все такое. И пока ты сидишь дома около теплой батареи, это тебя вроде как и не касается. А ведь уличную жизнь никто не отменял.

Ладно, допустим, прогулки на свежем воздухе интересуют тебя только в виде "дом-магазин", "дом-место учебы" и "дом-машина" у особо продвинутых. Но даже во время этих коротких перебежек настоящий хакер остается хакером. Нет, он не пытается найти бумажек с пин-кодами в карманах прохожих и не хакает бабушку, продающую зелень (укроп, петрушка, а не $$$). Он практически не выделяется из толпы, но вот в одежде его запрятан настоящий киберпанк... я бы даже сказал, самопальный хайтек. Вот именно им мы сегодня и заморочимся.

БАШКА И УХИ

На нашей заснеженной родине главное - не застудить голову, ибо хацкеры с менингитом никому не нужны. Только вот наушники от любимого плеера не пролезают под шапку, заставляя скучать без музыки или втыкать в уши гадкие маленькие "затычки" (как меломан я их люто ненавижу - и звук голимый, и уши после них болят, и голоса окружающего мира полностью отсекаются). Поэтому зимой любители вечного аудиокайфа идут на компромисс - либо башку сберечь, либо музыкой насладиться. Но компромиссы - это не для нас.

Лот номер 1: ШАПКА МЕЛОМАНА

Изготовление этой нехитрой безделицы займет от силы полчаса, а отдачу от нее ты будешь чувствовать до самой весны. Итак, нам понадобится:

шапка типа "пидорка" - 1 шт.

плоские динамики - 2 шт.

нитки суровые (цвета шапки типа "пидорка") - 0,5 м

гнездо для MiniJack'ового штекера - 1 шт.

аудиокабель - 0,4 м

Работы по интеграции динамиков следует начать с калибровки. Надев шапку на голову будущего пользователя, необходимо провести контрольный замер местонахождения ушных раковин. Проще говоря, пометить центр ушей на шапке, лучше всего это делается обычными булавками. Главное - прицепить булавки не к наружной (закатанной) части шапки, а к внутренней (та, что ближе к голове). После этого хитроумного процесса шапку надо снять и раскатать на разделочном столе.

Добыча динамиков - задача непростая. Лично я для изготовления нашего модного аксессуара использовал разломанные наушники от Соньки (эти япошки настолько зажрались, что кладут в коробку с копеечным плеером качественные уши :)). Но они не совсем плоские, поэтому сверх меры увеличивали аномальные выпуклости по бокам головы. Лучше всего воспользоваться затылочными noname-ушами, которые даже не придется до конца разбирать, достаточно отломать их от дужки и отколупать заднюю крышку от динамиков (а переднюю не трогать). Ко входам динамиков надо припаять короткие (~15-20 см) проводки, а если разбирались наушники - то просто обрезать штатные на том же расстоянии.

Примерно так лучше всего пришивать динамики. Признаюсь сразу, я не Репин :). Для тех, кто не понимает рисунков таких нонконформистов, как я: серые кружочки - это места протыка иглы :), синие линии - нитки, светло-синие линии - нитки с другой стороны ткани.

Крепление динамиков к поверхности шапки при помощи суровых ниток не должно вызвать вопросов. Выходы проводов желательно направить в сторону затылка. Аккуратными стежками закрепи каждую из опор контура, и будет тебе счастье.


Спецвыпуск Xakep, номер #026, стр. 026-026-2, HACKERWEAR - зимний моддинг одежды

HACKERWEAR - зимний моддинг одежды

Андрей "Дронич" Михайлюк

Спецвыпуск Xakep, номер #026, стр. 026-026-2

Теперь пора подумать и об аудиовходе. Гнездо интереснее всего закрепить на затылке, присобачив к нему какой-нибудь стабилизатор (чтобы не болталось). В моем случае использовался кусок дужки от тех же поломанных наушников. Я выпаял дырку в пластмассе дужки и зафигачил туда аудиоразъем, получилось на удивление крепко. Дужка пришивается к шапке по уже известной тебе методике.

Вот и все дела. Осталось только достать кабель Jack2Jack и воткнуть его одним концом в плеер, а другим - в слот на затылке хозяина.

Чудо-шапка в разрезе: спереди, сбоку и сверху. Условные обозначения: 1 - динамики, 2 - стабилизатор, 3 - разъем.

Плюсы устройства: хороший звук, минимальные теплопотери.

Минусы устройства: в метро либо потеешь, либо остаешься без музыки (для автомобилистов неактуально).

Резюме: учитывая скорость и простоту создания, мастхевистый аксессуар.

МУВ ЕР БАДИ

Музыкальная шапка - это, без сомнения, круто. Но надо подумать и о более плотских вещах. О банальном согревании организма в лютые морозы, например. Если исключить самый народный способ (фляжка, стопка, бутылка и т.п.), остается только очередной хайтек.

Лот номер 2: ЭЛЕКТРОГРИЛЬ ВНУТРИПОПОЧНЫЙ

Многие владельцы отечественных и околоотечественных автомобильчиков давно балуются согреванием собственного седалища электроковриком "Емеля". Почему бы нам не отобрать у них эту полезнейшую вещицу? Прихвати с собой:

коврик "Емеля" - 1 шт.

электропровод изолированный - 1 м

тумблер или резистор (опционально) - 1 шт.

соединение "папа-мама" любой конструкции - 1 шт.

Самая трудоемкая часть работы заключается в подшивании коврика к подкладке куртки в особо мерзнущем районе твоего туловища. Тут важно не повредить нагревательный элемент и прострачивать коврик только по краям. Идеальный вариант - запрячь владеющую швейной машинкой подругу.

После того как коврик надежно закреплен, надо отмерить по проводу расстояние до кармана и безжалостно его обрезать (не карман, провод). Через проковырянную маленькую дырочку в ткани провод протягивается в карман и там крепится к "маме" ака розетке. Для надежности края дыры желательно обстрочить (снова к подруге). На этом первая стадия подготовки завершена.

Основная задача второй стадии - обеспечить нагревателю питание. Самый простой вариант состоит в добыче/покупке мотоциклетного аккумулятора, который при небольшом весе способен обеспечивать потребность в тепле в течение нескольких дней, да еще к тому же отлично перезаряжается. Второй вариант - 8 полуторавольтных батареек - подкупает возможностью равномерного распределения тяжести по телу (распихать по всем карманам). Но лично меня лишний килограмм в рюкзаке не сильно напрягает (тем более, что там чаще всего лежит трехкилограммовый ноут :))).

Когда определишься с выбором элемента питания, подрубай к нему два провода, конец которых должен упираться в "папу" от нашей "мамы". Особые эстеты могут подрубить на пути тока тумблер, чтобы не теребить разъем при каждом включении/выключении. Ну а самые умные заменят тумблер резистором и будут постоянно заниматься регулировкой температуры. Именно для них предназначена наша следующая поделка.


Спецвыпуск Xakep, номер #026, стр. 026-026-3, HACKERWEAR - зимний моддинг одежды

HACKERWEAR - зимний моддинг одежды

Андрей "Дронич" Михайлюк

Спецвыпуск Xakep, номер #026, стр. 026-026-3

Плюсы устройства: термонезависимость одежды, легкость регулировки (не жарко в транспорте, не холодно на улице).

Минусы устройства: повышенная трудоемкость в создании, цена комплектующих.

Резюме: если не жалко раскошелиться на "Емелю", всю зиму будешь кайфовать.

Лот номер 3: БОРТОВОЙ ГРАДУСНИК

Постоянная информированнность о температуре окружающей среды еще никому не мешала. А уж если необходим контроль за внутренним состоянием персонального нагревателя... Нет, без термометра нам не обойтись, однозначно. Потребуется:

термометр автомобильный - 1 шт.

герметик черный быстрозастывающий - 1 уп.

Небольшое теоретическое отступление: автомобильный термометр состоит из самоклеящейся коробочки с дисплеем и самоклеящихся же датчиков, связанных с коробочкой тонкими проводами. Таким образом, наша основная задача - закрепить все три части в идеальных для них местах и замаскировать проводку.

Крепить термометр лучше на рукаве при помощи штатной клейкой поверхности, подобрав место эмпирическим путем. Главное, чтобы табло оказалось прямо перед глазами, когда ты красиво вскинешь руку :). Датчики же придется развести по разным углам куртки - один можно закрепить прямо около корпуса термометра (а лучше - довести до задней стороны воротника), а второй - протащить под куртку через имеющуюся дыру в кармане.

Провода мы маскировать не будем, ты все-таки киберпанк, а вот надежно закрепить их надо. Для этого выдавливай по капельке герметика через каждые пять сантиметров по пути следования провода (будет здорово, если ты пустишь его прямо по швам куртки) и придавливай провод в месте контакта.

О питании: на рынках реально найти как термометры на "таблеточных" батарейках, так и требующих 12 вольт монстров. Первый вариант универсальней, зато у второго есть мощная фича - если запитать его от лежащего в рюкзаке аккумулятора, он всегда будет светиться мягким зеленым цветом. Шик!

Плюсы устройства: постоянная информированность о погодных условиях, понты.

Минусы устройства: дороговизна термометров.

Резюме: полезно :), интересно :), понтово ;), дорого :(.

СПУСКАЕМСЯ НИЖЕ

Оказывается, зима - это не только холод. Зима - это еще и гадкий снег, который постоянно пытается пробраться сквозь неплотно закрытые щели и довести до обморочного состояния все твои электронные фишки. Ты ведь таскаешь с собой мобильник, наладонник, МР3-плеер, ноут в конце концов? Я вот таскаю :), поэтому задумался о создании идеальных для них условий.

Лот номер 4: НЕПРОМОКАЕМЫЙ КАРМАН

Концепция этого устройства родилась после памятных БСМ. Именно тогда мой любимый Psion был почти убит мерзкой влагой, заполонившей карманы после исполнения мною пары приемов типа "кинь-снежок-упади-встань". Так что для обеспечения локального вакуума заюзай:

AquaPack для документов - 1 шт.

клей универсальный - 1 тюбик

Если кто-то из непродвинутых танкистов не знает, что за зверь такой AquaPack и в чем его прелести, объясняю: это есть замечательный пакетик, который наглухо закрывается поворотом двух ручек у входного отверстия. Ни вода, ни снег, ни подлые чукотские сепаратисты не доберутся до его содержимого в течение эннадцати часов. В принципе, аквапак хорош сам по себе, так что можешь просто повесить его на шею (благо шнур идет в комплекте), а клей вынюхать. Но я предлагаю пойти дальше и интегрировать его к себе в штаны.


Спецвыпуск Xakep, номер #026, стр. 026-026-4, HACKERWEAR - зимний моддинг одежды

HACKERWEAR - зимний моддинг одежды

Андрей "Дронич" Михайлюк

Спецвыпуск Xakep, номер #026, стр. 026-026-4

Если ты любишь облачиться в джинсы с боковыми карманами в районе коленных суставов, то скорее хватай клей и намертво вхерачивай паку в искомый кармашек, предварительно обработав его стенки клеем. Если тебе удастся провернуть эту миссию аккуратно, то щель аквапака будет закреплена на уровне края кармана, а рычажки фиксаторы будут доступны для скачивания... бррр... для манипуляции оными.

Если свободных карманов на теле не наблюдается, придется уродовать свой прикид в угоду кибермоде. Уродство, на самом деле, не самое страшное - всего-то прорезать дыру в штанах, подогнав ее под ширину аквапака. Затем он закладывается вовнутрь и уже знакомым тебе способом приклеивается к тыльной стороне штанины. Опять же важно оставить на улице рычажки, а то получится карман "read-only".

Плюсы устройства: сохранность денег и гаджетов в любых условиях.

Минусы устройства: надо покупать AquaPack и уродовать штаны.

Резюме: musthave, если знаешь, как обидно найти в кармане промокший PDA.

Лот номер 5: ТЕРМОБЭГ

Назначение этой хреновины почти совпадает с предыдущим лотом - защитить электронику. Меня, например, всегда напрягал тот факт, что ноутбук нельзя включать с мороза. Как понять, оттаял он или нет? Видимо, только двумя путями - включив или выждав полчасика. Первый вариант рискован, второй неприемлем в условиях дефицита времени. Так что позовем на помощь:

термопакет - 1 шт.

Термопакет отличается от обычного целлофанового только материалом и наличием пластиковой молнии для плотного закрытия. Полимер, из которого выточен наш новый друг, не пропускает тепло и холод ни внутрь, ни наружу. Так что ноутбук, положенный сначала в термопакет, а только после в рюкзак, без потерь перенесет любые пертурбации (в том числе и особо сложные, с пролегающими по двадцатиградусному морозу частями маршрута).

Плюсы устройства: оперативность и все такое.

Минусы устройства: не выявлено.

Резюме: пригодится всем мобильным юзерам.

Лот номер 6: ВСЕДОРОЖНЫЕ ШУЗЫ

Не знаю, как ты, а я обожаю большие ботинки. Camelot, Grinders, Dr.Marten's - обувка от этих брендов безусловно пронизана киберпанком, но... В последнее время даже скины забросили свои армейские боты и облачились в гриндера (Жека, хаюшки!), а причисление к бритоголовой массе вряд ли обрадует твое самолюбие (особенно после пары ночей в обезьяннике). Так что кулхацкерам остается напрягать свою фантазию моддить собственную обувь. А так как боты у нас большие, то и моддинг намечается недетский. Надыбай в обязательном порядке:

гвозди, болты, шурупы - куча;

качественные маркеры (можно фосфоресцирующие или дневного свечения).


Спецвыпуск Xakep, номер #026, стр. 026-026-5, HACKERWEAR - зимний моддинг одежды

HACKERWEAR - зимний моддинг одежды

Андрей "Дронич" Михайлюк

Спецвыпуск Xakep, номер #026, стр. 026-026-5

Но начнем мы не с украшательств, а с банальной утилитарщины. А точнее, с вечной борьбы человечества со льдом под ногами. Гололед - второй страшный враг кулхацкера после менингита, ибо тоже угрожает непосредственно вместилищу нашего CPU и RAM. Черепной коробке, то бишь. Всем известны прелести настоящих горняцких буцефалов, оснащенных шипами, грунтозацепами и прочей внедорожной атрибутикой. Конечно, чел в таких шузах будет смотреться невыносимо стильно, но вот чистый асфальт и скользкий кафель понесут от такого веара огромный урон. Да и сами шипы долго не проживут. Посему предлагаю воспользоваться патентованным методом для изготовления бот-трансформеров.

Если ты еще не въехал, мы будем творить боты с убираемыми шипами. Это так же просто, как отобрать паяльник у спящего Добрянского. Для начала необходимо определить места шиповки. То есть экспериментальным путем выявить части подошвы, наиболее подверженные проскальзыванию. Обычно опыт показывает, что это носок и боковины. Так что займемся ими, оставив в покое подъем и каблук.

Именно так рекомендуется вворачивать шурупы

Один из сложнейших этапов - определить место и угол наклона для шипа, роль которого будет исполнять обычный шуруп. Важно, чтобы в завинченном состоянии его острый конец выходил из подошвы максимум на полмиллиметра. Если ты сделаешь длину шипа больше, то при ходьбе место контакта подошвы с почвой резко сократится, а шурупы будут нагло вылезать со своих законных мест. Еще стоит постараться, чтобы шурупы выходили из подошвы примерно в середине ее секторов (смотри рисунок). Ввинтив примерно пять шурупов (этого должно хватить), ты получишь реальные мегаботы. Проведя элементарный тест на скольжение и убедившись, что ботинки крепко вгрызаются в грунт, ослабь все шурупы на четверть оборота, так чтобы шипы ушли в подошву. А теперь представь себе: ты выходишь из подъезда, народ вокруг ходит гусиным шагом, изредка чертыхаясь на льду и проклиная ЖЭКи и ДЭЗы. И только ты спокоен среди этой суеты - ты достаешь из кармана крестовую отвертку, довинчиваешь шурупы до боевого состояния и достойно направляешься... да куда угодно. Главное - у тебя есть фишка, недоступная массам, и она реально помогает тебе жить :). Не правда ли, кайф?

Места контакта шипов с поверхностью

А уж если тебе мало нескользящих ботинок, можешь заняться их дестроем. Гнутые гвозди по краям подошвы, светящиеся каббалистические знаки и куски кода на ассемблере, полосатые шнурки - это уже дело техники и фантазии.

Плюсы устройства: неоценимы.

Минусы устройства: не выявлено.

Резюме: изуродовать старые растоптанные башмаки - святое дело.

Где достать?

Коврик "Емеля" или аналогичный - 100-200 рублей на любом авторынке.

Термометр автомобильный - 300-500 рублей там же.

AquaPack - от 300 рублей на Горбушке.

Термопакет - 50 рублей в Metro Cash&Carry.

Футболка "Хакер" - www.e-shop.ru.


Спецвыпуск Xakep, номер #026, стр. 026-030-1, КАРНАВАЛ КИБЕРПАНКА: намути себе хай-тек прикид

КАРНАВАЛ КИБЕРПАНКА: намути себе хай-тек прикид

Donor&Doctor

Спецвыпуск Xakep, номер #026, стр. 026-030-1

(spez@real.xakep.ru)

Нагрянули новогодние и прочие зимние праздники, оживилась всякого рода тусовочная жизнь, клубешники полны "задвинутыми" людьми, а ты, как всегда, не готов, а значит, имеешь реальную возможность прососать. NOT GOOD!!!

А в чем, собственно, дело? В чем дело, я тебя спрашиваю? Ах, вот в чем! Фейсконтроли, дресс-коды, отсутствие финансов и прочие черти. Проблема имиджа, так сказать. Плюс ко всему праздничное время накладывает свои коррективы: N'ного количества лейбаков на заднице уже мало, карнавалы везде, понимаешь, понаустраивали. То есть Karnaval costume required, а без маскарада Karnavala Net. "Задвинутые" люди ездуют на "Мосфильм" и берут там костюмы в аренду (need бабло, да и секондхенд - фу!). Шурик, это же не наш метод! При твоем немереном потенциале ты можешь замутить эксклюзивнейшую вещь, причем на халяву и при этом вся туса просто офигеет и выпадет в осадок. Забегая вперед, скажу, что плюс ко всему еще можно и некисло повеселиться. Осталось нарыть идею, с чем я тебе сейчас незамедлительно помогу.

БЫТОВОЙ КИБЕРПАНК

Если ты постоянно зависаешь в IRC, торчишь от виртуального секса, строишь и модифицируешь свою пагу, читаешь СПЕЦ и пытаешься юзать те фичи, которые мы описываем, любишь кино, типа "Нирваны" и творений Shirow Masamune, с головой погружаешься в мир Fallout'а, то сеть имеет тебя, и киберпанковский образ жизни тебе близок. Аминь! Следовательно, ты в теме - не хватает только киберпанковского вида.

Какие там отличительные особенности киберпанка? Алчные транснациональные корпорации? Нет, не то. Неблагополучная экология? Опять не то. Модификация тела и импланты? О! То, что нужно! Будем делать из тебя киборга по бразильской системе. Нет, черепушку тебе вскрывать и позвоночник резать, конечно, не станем, но видок придадим тот еще ;).

Всех прут всякие блестящие штучки, непонятные девайсы и светящиеся лампочки. От этого и будем отталкиваться.

РАСХОДНЫЕ МАТЕРИАЛЫ

Перво-наперво, необходима основа будущего костюма. Это должны быть не новые и недорогие вещи, которые не жалко испортить: головной убор - кепка или какая-нибудь прикольная шляпа, торс - обтягивающий свитер или водолазка темного цвета, ноги - темные джинсы (чем дранее, тем лучше). Какие ботинки - не принципиально.

Теперь пройдемся по дому и поглядим, какие остатки твоей киберпанковской жизнедеятельности тут валяются. Хмм... Грязные носки в системнике? Это лишнее. А вот старые запоротые CD болванки, устилающие пол в два слоя собирай в пакет. Также выбирай из огрызков заюзанные инет-карточки. Очень пригодятся обрывки шлейфов, старый куллер, разбитая клава и прочие ошметки от великих апгрейдов. Что касается меня, то я еще нашел армированный шланг от душа и респиратор. Этого вполне достаточно. Приступаем.

БРИЛЛИАНТОВАЯ КЕПКА

Как бы ты отнесся к шапке, как будто вылепленной в 3D Max, причем материалу поставили отражение света на максимум. ИМХО, клево и очень киберпанково. Сделать это вполне реально - ведь у тебя же полный пакет ненужных компактов. Посвети на сидюк лампой, и он засияет всеми цветами радуги. Идея в том, чтобы выложить всю шапку аккуратными красивыми кусочками, нарезанными из дисков, как мозаикой. Так она приобретет грани и будет мерцать под световым оборудованием клубешника, привлекая взоры горячих дефачек.


Спецвыпуск Xakep, номер #026, стр. 026-030-2, КАРНАВАЛ КИБЕРПАНКА: намути себе хай-тек прикид

КАРНАВАЛ КИБЕРПАНКА: намути себе хай-тек прикид

Donor&Doctor

Спецвыпуск Xakep, номер #026, стр. 026-030-2

Кепка - очень сложный объект. Она вся такая изогнутая, что сделать выкройку, а потом приладить наши пластинки будет нелегко, но мы попробуем. Сперва прикладывай лист бумаги к козырьку (или полям) и обводи карандашом. Получившийся контур расчерти на несколько мелких кусочков. Это и есть будущие кусочки. То же самое проделай с одним сегментом тульи (они все одинаковые, поэтому нужен только один). Надо сказать, что поверхность изогнутая, поэтому чем мельче кусочки, тем красивее получится, хотя перебарщивать тоже не надо, а то задолбаешься резать компакты (хотя и так тоже задолбаешься :)). В общем, выкройка есть.

СИДЮКОВАЯ НАРЕЗКА

Приготовь гвоздь ржавый обыкновенный, хорошие большие ножницы, линейку и мелкую шкурку. Теперь надо перенести на компакт контуры отдельных кусочков. Клади компакт стеклом кверху и накладывай выкройку, отмечай гвоздем уголки и царапай линии по линейке. Лучше всего постараться уместить на одном диске как можно больше кусочков, причем нужно умудриться влезть между краем и средней дыркой. Ювелирная работенка.

Дальше самая ответственная часть - нарезка. Дело в том, что компакт влегкую режется обычными ножницами, если резать по прямой, но если неосторожно дернуть режиками или попытаться их развернуть, зеркальная поверхность покроется некрасивыми трещинами, что нам, естественно, не надо. Пару сидюков ты, точно, запорешь, пока не придро... э... приноровишься.

Нарезанные пластинки получатся с неровными острыми краями и углами, что не эстетично, кроме того, они будут за все цепляться. Пофиксим сей баг шкуркой. Обшкуривай края и закругляй углы шкурой. Вот теперь получились красивые фишечки, которые в руках повертеть приятно. Представь теперь, как они все вместе будут смотреться на шапке. Клево?

СТРАСТЬ ПО ЗАКРЕПЛЕНИЮ

На этом этапе ты тоже намучаешься, будь здоров, но ты же перец крепкий. Крепить пластинки к шапке можно несколькими способами. Первый и самый халтурный - двойной скотч. Одну сторону клеим к пластинке, другую - к шапке. Все держится более менее прилично только на козырьке, потому что он твердый. Второй способ - это банально приклеить "Моментом", но шапку ты убьешь безвозвратно. Другой минус этого способа в том, что пластинку нужно долго держать, пока клей не схватит. Третий способ - это приклеить скотчем с обратной стороны пластинки две проволочки и крепить их к кепке, как звездочки к погонам. Кепку ты, конечно, немного продырявишь, но вид она не потеряет, и держаться все будет крепко.

Допустим, что и с этим ты справился. Теперь надень ее и погляди на себя в зеркало. Гордость чувствуешь? Если чувствуешь, отложи шапку пока в сторону.

САМУРАЙСКОЕ ТОРСЕЙДО

Теперь подумаем, что можно сделать с твоей водолазкой. Разложи ее на полу (если в пыли не утонешь) лицевой стороной к себе и раскидай по ней ключевые элементы. Например, вентиль от куллера очень прикольно будет смотреться над сердцем, типа мотор-то пламенный, значит, надо охлаждать. В районе локтевого сгиба очень к месту придется шлейф, который как бы соединяет предплечье и руку. Я, вот, придумал перенести Num Pad с клавы в район пениса. Типа, Enter a secret code. Incorrect! Access to penis denied!


Спецвыпуск Xakep, номер #026, стр. 026-030-3, КАРНАВАЛ КИБЕРПАНКА: намути себе хай-тек прикид

КАРНАВАЛ КИБЕРПАНКА: намути себе хай-тек прикид

Donor&Doctor

Спецвыпуск Xakep, номер #026, стр. 026-030-3

Теперь подумай, какие еще фигуры тебе нужно вырезать из сидюков и приляпать к кофте, чтобы создать впечатление киборга. Например, плашки на кубики пресса, "лепестки" вокруг куллера, шевроны на плечи и плашечки на погоны. Можно даже вырезать зеркальную черепушку, но это будет нелегко.

Крепим все это дело к кофте теми же способами. Хотя есть еще один, самый гиморный, но и самый надежный: сперва приклеить плашечки и детали к кусочкам ткани так, чтобы края ткани немного выходили за границы, дать высохнуть, а потом уже пришить к одежде нитками.

Теперь основная проблема - натянуть эту инсталляцию на себя и ничего не порипать.

РАСКИНЕМ КАРТОЧКИ

Из интернетных карточек можно замутить вообще все, что душе угодно: от шарфика до плаща или туники. Все зависит от наличия карточек в наличии. Тряхни друганов в конце концов!

Итак, сверли в карточках по две дырки на каждой стороне прямоугольника (углы не трогай) и связывай их вместе люриксом (блестящая нитка такая). Первый вариант - пришпандорить получившуюся "материю" к спине свитера, получится броня. Второй вариант - сделать киберплащ-палатку и накинуть на плечи. Третий вариант - сделать защиту ног и задницы, как у самураев. Мы, исессно, выбрали последнее - в клуб идем, как никак ;).

ПАРА ДЕТАЛЕЙ

Мы не устояли и добавили к наряду нашу зло-перчатку (СПЕЦ писал про это в прошлом году). Она сделана из обычной перчатки, пяти шприцов подходящего размера, светоотражающей ткани и ярких диодов. Также в ход пошел шланг от душа. Один его конец был прикреплен к спине (как будто торчит из позвоночника), а другой - приаттачен к руке. Получилась усиленная, боевая лапа. Респиратор выкрасили серебряной краской.

Еще одним модным аксессуаром могут послужить очки, сделанные из серединок компактов и синих светодиодов. Можно просто прилепить вырезанные кружки к обычным очкам. Правда, будет плохо видно сквозь дырочки.

ЭЛЕКТРИФИКАЦИЯ ВСЕЙ БАШКИ

Естественно киберодежда должна пленительно светиться, вводя сознание всех окружающих дефачек в глубокий транс. Осторожно, малщики тоже ведутся.

ИСТОЧНИК СВЕТА

Но какой использовать свет? Простому смертному сразу же приходит в голову обвесить себя лампочками от карманного фонаря или елочной герляндой. Это не годится, так как лампы накаливания потребляют много электричества, а светят слабо. То есть тебе либо понадобиться рюкзак с батарейками, либо придется подключить шнур к розетке и тусовать рядом с нею. Не забудь, что лампы сильно греются и можно даже обжечься. Для справки, лампы накаливания - это лампочки, у которых есть нить (спираль), когда через нее проходит свет, она раскаляется и светится.

Люди поумнее вспомнят, что сейчас можно легко купить или заказать неоновую трубку или даже эластичные неоновые нити и ленты. Но не забудь о том, что неон поджигается от 100 вольт, то есть ты будешь ходить весь из себя высоковольтный, и тебя будет долбить электричеством, как только чуть-чуть вспотеешь. Зато сможешь поджарить током девушку-поклонницу нашей киберпанк-культуры, обняв ее во время медленного танца. Нельзя сказать, что одежду с применением неона сделать невозможно, однако это очень сложно и дорого. Дорого будут стоить эластичные неоновые элементы, к ним понадобиться конвертер напряжения на батарейках (чтобы разогнаться до 100 вольт), нужно будет специально заворачиваться защитой от ударов током высокого напряжения.


Спецвыпуск Xakep, номер #026, стр. 026-030-4, КАРНАВАЛ КИБЕРПАНКА: намути себе хай-тек прикид

КАРНАВАЛ КИБЕРПАНКА: намути себе хай-тек прикид

Donor&Doctor

Спецвыпуск Xakep, номер #026, стр. 026-030-4

Завсегдатаи вечеринок вспомнят люминесцентные краски, светящиеся в темноте и в ультрафиолете. Уже сегодня ты сможешь встретить на вечеринке массу людей, одетых в клубное люминесцентное шмотье. Да, это прикольно, но не оригинально. И потом такие краски светят еле-еле, а нам ведь нужен мощный свет, чтобы привлечь внимание самых продвинутых самочек!

Ответ есть - полупроводниковые технологии. Светодиоды, потребляют немного, всего несколько вольт. От такого напряжения никакая лампа накаливания нормально работать не будет, а диод будет ярко светить. Лучше всего брать красные ультраяркие светодиоды, чем толще - тем лучше. Такие диоды самые надежные, с оранжевыми, синими и зелеными бывают проблемы, а красные оптимальны. Приятно, что красные светодиоды светят направленно, в полумраке дискотеки они могут даже ослеплять оглушенных звуками музыки, подвыпивших дяфчонок, усыпляя их бдительность и развеивая иллюзию неприступности. Мы использовали как раз этот замечательный тип светодиодов, их-то ты и видишь на фото.

ПОДКЛЮЧЕНИЕ СВЕТОДИОДОВ

Если ты уже закупился нужными светодиодами в радиомагазине (кстати, там их обязательно проверяют при продаже и можно увидеть их в работе), нужно озаботиться батарейками.

Рецепт такой: светодиоды будут отлично работать от двух-трех последовательно соединенных пальчиковых батареек. Соединяй пальчиковые батарейки и пробуй самостоятельно подключить светодиод. При этом полезно знать, что длинная нога светодиода идет на плюс батарейки, а короткая нога на минус.

Светодиодов на нормальный экземпляр киберодежды уйдет 20-30 штук, конечно, такое количество будет светиться тускло от трех батареек АА, соединенных последовательно. Если все тускло и тухло, то параллельно к этим батарейкам подсоедини еще 3 последовательно соединенные батарейки, и еще 3 и так, пока яркость свечения тебя не удовлетворит. Нам понадобилось 9 пальчиковых батарей, то есть три цепочки соединенных параллельно, в каждой цепочке по три батарейки, соединенные последовательно.

Светодиоды рекомендуем соединять параллельно, то есть проводки каждого светодиода идут на плюс и на минус батарейки. Для такого количества батарей будет полезно купить лоток. Лоток это такая пластмассовая коробочка, в которую вставляют батареи, а из нее выходят провода. Если у тебя есть лоток, то не придется париться с соединением батареек. К лотку можно прикрутить переменное сопротивление для регулирования яркости свечения и переключатель. Радиоманьяки могут попробовать запустить на одежде динамические картинки с помощью запрограммированного микропроцессора. Если нашить на майку светодиодную матрицу 8Х4, то этого достаточно, чтобы высвечивать букву. Процессор может последовательно выдавать светящиеся буквы, а из них складывать матерные слова или другие заманчивые обещания для многочисленных клубных самочек, падких на все блЯстящее и светящееся.


Спецвыпуск Xakep, номер #026, стр. 026-030-5, КАРНАВАЛ КИБЕРПАНКА: намути себе хай-тек прикид

КАРНАВАЛ КИБЕРПАНКА: намути себе хай-тек прикид

Donor&Doctor

Спецвыпуск Xakep, номер #026, стр. 026-030-5

ПРОВОДКА

Эксперименты показали, что лучше всего вести проводочки прямо поверх одежды. При этом все светодиоды должны быть соединены между собой парой проводочков: плюсом и минусом от батарей. Чтобы провода не отрывались, советуем их пришивать нитками и хорошенько припаивать к ногам светодиода. Если прикручивать без пайки, то все будет отваливаться.

Рекомендуем перед пайкой гирлянды из светодиодов собрать проволочную модель. То есть в виде проволочек прикинуть, как пойдут провода по твоей одежде, где будут развилки, где будут подпаяны ножки диодов. Мы паяли прямо на водолазке и потому прожгли ее в трех местах паяльником и испачкали порошком от канифоли.

Может быть, имеет смысл делать не один центральный мощный источник питания, а несколько отдельных, отвечающих за свою группу диодов. Тогда если оборвется один, другие будут работать. Например, вместо источника три раза по три пальчиковых батареи можно использовать три источника по три батареи, и три группы светодиодов, каждая поджигается от своего источника.

LET'S TRY IT ON

Да! Пришла пора опробовать это все! Исцарапавшись и порвав несколько проводов, я напялил на себя костюм. Запаяли прямо на мне и зажгли диоды. Я себя не видел, но Доктор просто загнулся от смеха, настолько неожиданно ЭТО выглядело.

Сперва решили сфоткать меня на память и чтобы ты видел, на что подвязываешься. Я встал, приосанился, но в респираторе дышать было нелегко, поэтому я сипел, как Дарт Вейдер (Luke! I'm your father!). Доктор загнулся от смеха второй раз :). Наконец, фотки были сделаны и подшиты к делу, и мы выдвинулись в на лестничную площадку.

Сумерки уже имели наглость сгуститься, поэтому было темно, и светился только я. В этот момент как раз и вышел эксцентричный сосед Доктора (бывший подводник), чтобы продолжить под покровом ночи починку мотора от сверхсекретной подводной лодки (он хочет поставить его на "Жигули"). Как вышел так и замер :))) Наверное, подумал, что это киборг-спецназовец пришел за мотром. В общем, мы, вполне довольные результатом, прислонили соседа к стене, чтобы не падал и пошли готовиться к походу в клуб. Берегись тусовка! МЫ ИДЕМ!!!


Спецвыпуск Xakep, номер #026, стр. 026-034-1, СВОЙ СРЕДИ ЧУЖИХ - экстремальная встреча Нового года

СВОЙ СРЕДИ ЧУЖИХ - экстремальная встреча Нового года

Хвощ (hvosch@ukr.net)

Спецвыпуск Xakep, номер #026, стр. 026-034-1

Скажи мне, приятель, как ты привык встречать великий ночной праздник, в который бородатый Колотун-Бабай с мешком в одной руке и Колотун-Шалавой в другой нетрезво приветствует честной народ и одаривает всякой дрянью?

Может, ты выпиваешь глоток шампанского с предками, просишь больше не наливать и уходишь к друзьям, чтобы набухаться паленой водярой в огромную сисю? Или нет, собираешь корешей и до утра горланишь песни под окнами родного дома? А может быть, приглашаешь свою дэушку на романтическую ночь в "Прагу", где тебе до утра бьют морду пьяные братки? Так вот, запомни - все это полное фуфло. То есть, конечно, не совсем полное, но фуфло :). Пока ты молод, пока ты полон сил (относится ко всем, кому больше 14 и меньше 40 лет), не стоит прожигать жизнь на такую банальщину. Отдохнуть как все ты успеешь в любом случае, а я предлагаю тебе заняться настоящим экстримом. Да, в новогоднюю ночь ты будешь бухать, клеить теток, нескладно петь "пять минут" и аккуратно блевать под елочку. Но делать ты это будешь в десять раз смелее, а адреналину получишь в десять раз больше, потому что тех, с кем ты так беcпредельничаешь, ты увидишь в первый (и в последний) раз.

СУТЬ ДЕЛА

Да, именно так, я призываю тебя забить на устоявшиеся традиции и встретить новый год в абсолютно незнакомой компании. О том, как это реализовать на практике, мы поговорим позднее, а пока давай разгребем плюсы и минусы этого благого дела. Самый мощный плюсняк - возможность безбашенного отрыва. Даже привязав меня к стулу и опасно приблизив утюг к моему лицу, ты не убедишь меня, что можешь быть на 100% раскован в кругу близких/знакомых/друзей/собутыльников/коллег. Забудь про условности, забудь про то, что на утро ты можешь услышать "ну ты вчера и... [далее по вкусу]", и ты уяснишь, что такое настоящий отдых. Правда, сразу же вытекает минус - многие мои друзья находят больше удовольствия в последующем обсуждении беспредела, а не в его непосредственном творении. Можно, конечно, вписаться в компанию парой, но это намного сложнее и гораздо рискованней (риск дело хорошее, но остаться в 23.59 новогодней ночи под окнами в незнакомом районе - это в высшей степени неприятно). Следующий плюс - халявность мероприятия. Конечно, прихватить с собой немного съедобного стаффа просто необходимо, но его стоимость по-любому меньше входной платы в клуб или "доли" в студенческом празднике. Тем более что принесенный продукт прекрасно влияет на подозрительные умы хозяев ("Слышь, Серег, а это вот кто?" - "Да хэз, но точно свой, я на кухне был, когда он конфет принес, еще закуси какой-то... Машкин друг, по-моему". - "Ну ладно..."). Собственно, на этом положительность кончается, но ее должно хватить для образования стойкого желания. Минусов-то тоже больше нет. Так что займемся практикой нашего пенетрейшена.

МЕТОДИКИ

Классификация до боли проста - один классический метод, самый сложный и интересный, и куча его модификаций для простых смертных.

1. UNKNOWN ERROR

Классический метод, которым пользовалась еще моя матушка в годы расклешенной молодости. Есть установка: на этой хате собирается для празднования молодежь. Опознать легко, под Новый год в каждом доме найдется по две-три квартиры, куда часов с десяти начинают подъезжать машины, забитые тетками и водярой. Время действовать начинается за час до полуночи. Местоположение квартиры отслеживается, и начинается наружное наблюдение. Для прорыва в квартиру существует как минимум два верных способа, применяемых отдельно или последовательно. И оба они идут через место для курения на лестничной площадке (это уже в ночи народ начинает смолить, не отходя от кассы, а пока все цивильно дымят на лестнице).


Спецвыпуск Xakep, номер #026, стр. 026-034-2, СВОЙ СРЕДИ ЧУЖИХ - экстремальная встреча Нового года

СВОЙ СРЕДИ ЧУЖИХ - экстремальная встреча Нового года

Хвощ (hvosch@ukr.net)

Спецвыпуск Xakep, номер #026, стр. 026-034-2

а) Подниматься вверх по лестнице с сумками, остановиться около курящих.

Х: Здорово, мужики! У Лехи, что ль, гуляете?

М: Не, какой нах Леха, у Витьки!

Х: Че, Витек дома празднует? Надо зайти поздравить по-соседски...

Итог диалога - знаем имя хозяина, нас знают в лицо несколько человек из компании. Теперь можно смело просачиваться в компанию, уже есть с кем по-дружески выпить. Но лучше продолжить использовать способ "Б".

б) Дождаться, пока курящие уйдут, встать на их место и спокойно закурить, дожидаясь следующей порции курцов из целевой квартиры. Если выйдут тетки - хвала Зевсу, ты уже в компании. Иначе - модифицируй диалог для мужского пола (можешь просто обогатить матом).

Х: Привет, девчонки! Кем Витьку приходитесь?

Д: С работы мы его, в офисе одном сидим.

Х: Клево, а мы учились вместе.

Д: Здорово.

Разговор за жизнь можно продолжать до упора, а затушив сигареты, смело направляться в квартиру, теперь ты там точно свой.

Теперь советы по поведению. Не светись, не бери тосты, не чокайся со всеми. Пока все трезвы, тебя могут опознать и выгнать взашей, так что лучше отсидись на кухне или за спинами теток. Постарайся запомнить хозяина и не попадайся ему на глаза первое время - так лучше для вас обоих. Короче, шифруйся по самое не балуйся :). Но как только погасят свет и начнутся танцульки (в том числе и на столе) - вылезай из своего угла и начинай зажигать. Теперь даже хозяин не запалит тебя, потому что подкатывать ко всем с вопросом "Ты привел? [жест в твою сторону]" вместо того, чтобы веселиться - это чрезвычайнейшая глупость. Если хочешь обезопасить себя полностью, воспользуйся проверенным вариантом - знакомством с хозяином :). Экстрим еще тот :))). Надо найти кого-нибудь совсем упитого, уснувшего в кресле или еще где в нелепой позе. Выяснив имя почившего в объятьях Морфея товарища у окружающих (предположим, Вова), надо подкатить к хозяину с мазой следующего содержания.

Х: Виктор, извини, что не представился лично раньше, суматоха и все такое. Я Андрей, мы с Володькой приехали.

Хоз: Очень приятно (мля, вот Вован урод, приведет же кого попало)...

Х: Так вот, в чем проблема - допился он до чертей, ты не подскажешь, куда бы его уложить?

Хоз: Ну давай вот на тот диван (сволочь Вовка, чтоб я его еще позвал).

Все, теперь можешь отрываться как угодно, только девушку хозяина не клей :). На этом классический способ полностью исчерпан.

2. МЕТРОПОЛИТЕН

Этот способ, как впрочем и все последующие, гораздо проще, потому что тебе не придется ни скрываться от хозяина, ни тайно проникать в место празднования. Суть его в катании по центру города на метро (если в твоем городе его еще не прорыли, юзай автобусы и пешкодрал) и отлове гулящих. Куча народу выбирается к полуночи в центр, а после разъезжается по домам на продолжение банкета. Наша задача как раз и состоит в том, чтобы присовокупить свое бренное тело к их празднику жизни. Потребуются только общительность и булькающее нечто в сумке/рюкзаке. Пошути, разговори, выясни, куда едут, - и от тебя уже не смогут отделаться. Кстати, метод отлично работает при парном пенетрейшене (вдвоем с другом/подругой).


Спецвыпуск Xakep, номер #026, стр. 026-034-3, СВОЙ СРЕДИ ЧУЖИХ - экстремальная встреча Нового года

СВОЙ СРЕДИ ЧУЖИХ - экстремальная встреча Нового года

Хвощ (hvosch@ukr.net)

Спецвыпуск Xakep, номер #026, стр. 026-034-3

3. ОБЩАГА

Прорвись на Новый год в общагу. Точка. То, что происходит там в волшебную ночь, трудно описать словами. В общежитии остаются только самые отчаянные гуляки, те, кого не позвали ни в одну тусу, те, кого родные не хотят видеть дома, те, кому не хватило денег на клуб. Короче, от безысходности народ отрывается по полной. Чтобы попасть внутрь, необязательно даже иметь знакомых - достаточно незадолго до отбоя потереться у палатки с алкоголем (почему их всегда ставят ПРЯМО под общагами :)?) и угостить очередных выбежавших девушек шапуньским. Дело сделано, get inside. Особо рекомендую тереться у общежитий экономических вузов - там та-а-акой малинник :). А женский коллектив в новогоднюю ночь - это фантастика...

4. СОСЕДИ

Цепочечный способ, для реализации которого необходимо иметь безбашенных соседей. Забуриваешься к ним в тусовку, а как только кто-то собирается ехать "к Сереге/Мишке/Васе", немедленно присоединяешься к ним. В идеале за одну ночь можно позажигать в трех-четырех компаниях, причем о последней ты не будешь знать вообще ничего. А уж помнить тем более ;).

А ТЫ КТО ТАКОЙ?

Не удержусь, скажу слова предостережения. В незнакомой компании ты совершенно не в курсе, на что тут обижаются, кто чья девушка и прочее и прочее. Поэтому могут начать бить. Возможно, даже ногами. Во избежание телесных повреждений есть только один верный способ - притвориться мертвецки пьяным, не вязать лыко и лезть ко всем целоваться. Таких убогих у нас в стране по древнему обычаю не трогают. Ну, максимум - выкидывают за дверь. Так что репетируй перед зеркалом!

ОПОХМЕЛ

Вот, собственно, и все. Не суди строго, но мне такой отдых безумно нравится, возможно, он придется по душе и тебе. Если есть какие-нибудь всяко-страшно-прельстивые идеи - не стесняйся, тереби мой мылбокс, а я пока пойду. В общагу. Техникума. Текстильного. Ночью :).


Спецвыпуск Xakep, номер #026, стр. 026-036-1, ПОДАРКИ НАШЕГО СЕРВАКА

ПОДАРКИ НАШЕГО СЕРВАКА

DonoR (donor@real.xakep.ru)

Спецвыпуск Xakep, номер #026, стр. 026-036-1

ЧТО ДЕЛАТЬ?!

Вот же, млин! Опять Новый год и, как всегда, неожиданно! Деньги пропиты еще весной, а на очереди за подарками любимая мама, сестренка, тетка, а главное - Солнышко, Зайчик, Рыбка и т.д. (никогда не называй своих дефачек по именам, тогда не запалишься, назвав в порыве страсти одну именем другой). Что делать?! А где твоя хацкерская смекалка, Чернышевский? В ломбарде? Хмм... Тогда подваливай сюда, в магазин на серванте, у меня тут есть подарочки на любой вкус и на все случаи в жизни: для любимой подруги, для верного друга, а также и для недруга ;). И что самое прелестное - на халяву и с юмором.

ГДЕ БРАТЬ?

Раскопай своих завалов и хламья перетряси... (по мотивам братьев Стругацких). Не, я серьезно, "мамаша, пойдемте в закрома". Только не говори, что ты выкинул хоть одну старую комповую железку на помойку. Ну, если все же выкинул, напряги своих более разумных друзей. Итак, что мы видим на картине? Тут и старая раздолбанная мышь, и почерневшая от грязи клава, и горелая мама, и еще куча деталей, оставшихся от многочисленных апгрейдов. Да ты же богатый!

Кроме кучи компьютерного джанка, тебе понадобится различная упаковка: коробочки, бантики, футлярчики и ленточки.

ЛОТ №1. BIOS

Находи в куче мала горелую мамку и смело отковыривай от нее отверткой микруху BIOS'а. Какая милая штучка! В руках подержать приятно! А если уложить в бархатный футлярчик для колец или сережек, то просто брульент получится. Посмотри, как играют блики на фирменной голограмме. А если припаять к ножкам микросхемы маленькие колечки и привесить к ним всяких фитюлек (например, цветных сопротивлений или конденсаторов), и посадить эту конфигурацию на серебряную цепочку, то получится офигенная побрякушка, особенно если покрыть золотой красочкой.

Кому: этот подарок можно подарить своей девушке, нагнав, что это последний писк моды, стиль хай-тек от Sistemo Materini за кучу баблос. Также подарок придется по душе твоему другану - компьютерному маньяку. Согласись, BIOS от боевой мамки - это нехилый фетиш. Например, Дронич носит на шее микросхему от АОНа - она будит в нем лучшие чувства.

Эмоции: сугубо положительные.

ЛОТ №2. БАТАРЕЙКА ОТ CMOS'А

Продолжим раздраконивать многострадальную мать. Обрати внимание на батарейку от CMOS'а. В мирное непраздничное время она помогает хранить настройки твоего железного коня. Что мне в ней нравится, так это то, что она большая, тяжеленькая, кругленькая, серебристая, плоская, а главное, холодненькая. Можно к виску приложить, если башка пухнет. Опять же можно заморочиться с пайкой и посадить батарейку на цепь, а также добавить висюлек. Но здесь геморроя будет побольше - без флюса паять даже и не пытайся.

Идеальной упаковкой для этой штучки будет футляр для кольца (утащи у мамы либо купи - он дешевый).

Кому: своей дефачке.

Эмоции: Рыбка/Солнышко вполне может подумать, что ты, наконец-то, решился и даришь ей обручальное колечко (они такие наивные). Вскрыв футлярчик и обнаружив батарейку, она может прийти в неистовство от такого разочарования. Остальные последствия индивидуальны, так что сам увидишь и почувствуешь ;). В общем, еще один красивый способ бросить дефачку. "Я ей батарейку от всей души, а она... Дура!"


Спецвыпуск Xakep, номер #026, стр. 026-036-2, ПОДАРКИ НАШЕГО СЕРВАКА

ПОДАРКИ НАШЕГО СЕРВАКА

DonoR (donor@real.xakep.ru)

Спецвыпуск Xakep, номер #026, стр. 026-036-2

ЛОТ №3. ШАРИК ОТ МЫШИ

Находи свою старую глючную крысу. Самое ценное в ней - это шарик. О, сколько этих чудесных предметов было выброшено разными извергами на помойку! Шарик, тяжеленький, идеальной формы, прорезиненный, а потому теплый, - просто мечта всех мальчиков и девачков. Он похож на крупную жемчужину, его можно задумчиво катать по столу, им можно играть в карманный бильярд, в конце-то концов! Особый шик шарику от мыши придаст аккуратно написанный на нем тушью иероглиф (предварительно все-таки лучше узнать, что он означает) и мазки золотой краской. Упаковать шарик (шарики) также лучше всего в футлярчик для драгоценностей.

Кому: всем, даже подруге недруга.

Эмоции: любой из твоих друзей оценит эту фишку, особенно если шариков будет два (миниатюрные китайские яйца). Подруге недруга же такой подарок очень мило будет подарить со словами: "Забудем обиды! И пусть хоть у кого-то из вас в Новом году будут шары".

ЛОТ №4. ВИНТИКИ ОТ КОРПУСА

Вот, не поверю, что за свою долгую компьютерную жизнь ты не накопил пакетика с разными винтиками от компа. Придется расстаться с двумя ценными винтами от корпуса. Положи их в футлярчик от сережек. Правда же - винтики туда идеально вписались. Покрась их золотом, и у тебя получится еще одна модная фишка, которую можно с равным успехом выдать как за сувенирные болты, так и за модные серьги от Towero Corpusini. Стоят такие образчики дизайна наверняка бешеных денег ;).

Кому: подруге или другу.

Эмоции: друган-компьютерщик наверняка оценит всю глубину значения твоего подарка, а вот дефачка может и обидеться - она-то ждала от тебя банальных серег с изюмрэдами размером с грецкий орех. Попробуй все же уговорить ее завинтить подарок в уши - получится офигенный киберпанк.

ЛОТ №5. ПОРТЫ

Помню я времена, когда порты не были распаяны на маму, а втыкались в шину как отдельный контроллер. Да-а-авно-о-о это было! Тем не менее у многих перцев (например, у меня) порты до сих пор валяются в закромах. Не, ты только прикинь, подарить человеку запасные ПОРТЫ, перевязанные ленточкой! "Здравствуй, дорогой друг! Поздравляю тебя с праздником! Вот тебе запасные порты. Такие запасные такие порты. Порты. Теперь вытрахать тебя во все порты стало гораздо труднее :)!" Или - "Привет, дорогой начальник! Поздравляю тебя с Новым годом и дарю тебе порты. Носи их всегда с собой, и если решишь иметь меня во все порты, имей в эти". В общем, супер-фетиш! Повесить на колечко от брелка, приляпать дарственную надпись, и банзай!

Кому: другану или начальнику, но обоим с намеком.

Эмоции: друган будет искренне веселиться (если он жадный жлоб, конечно). Начальник надолго изобразит на своем челе видимость мыслительного процесса и, может (чудеса случаются), будет больше уважать тебя.

Одно время было модно дарить всякую фигню с многозначительными надписями под стеклом, презики там всякие, листики каннабиса, наборы студента и т.д. Попадаются, конечно, веселые экземпляры, но дарить ширпотреб отстойно. Замути что-то нашенское, киберпанковское!


Спецвыпуск Xakep, номер #026, стр. 026-036-3, ПОДАРКИ НАШЕГО СЕРВАКА

ПОДАРКИ НАШЕГО СЕРВАКА

DonoR (donor@real.xakep.ru)

Спецвыпуск Xakep, номер #026, стр. 026-036-3

ЛОТ №6. ЗАГРУЗОЧНАЯ ДИСКЕТКА

Не мне тебе рассказывать, что как только падает система, загрузочной дискеты, естественно, под рукой не оказывается. Вот, все есть, даже инет, а ее, собаки, нет. И ты бежишь к ближайшему другану с работающим компом с истошным криком: "Дай!". После этого ты с искренней благодарностью примешь в подарок застекленную рамку с дискеткой, на которой корявыми буковками написано "BOOT", и пусть даже в рамке написано: "Опять лохонулся? Так и быть, разбей стекло". Так что сам выкапывай из кучи грязных носков и объедков на столе какой-нибудь флопарь, подуй, пошкрябай и суй в флоповод. Format a: -s, наклеивай наклейку, пиши коряво "BOOT" и закатывай под стекло. Мега-подарок готов!

Кому: такому же раздолбаю, как и ты.

Эмоции: радостное мычание, слюнявый поцелуй и рыдания на плече собрата по несчастью.

ЛОТ №7. МОДУЛЬ ПАМЯТИ

Мозги... Мозги - это песня! Сколько ни ставь, все мало. Все тормозит, память глючит. И не дай Бог тебе закупиться дополнительным бруском и пытаться подружить его со старым. Кошмар! После многочасового тасования модулей по банкам твой друг с благодарностью примет рамку со старинным, но все же рабочим симом (ведь в твоей куче наверняка валяется несколько) и слоганом "Глючит память? Смени мозги!". Сидя вечером перед разобранным в очередной раз системником, он не раз вспомнит тебя добрым словом и, вполне возможно, решится на глобальный апгрейд.

Из сима также получится очень хороший амулет-оберег (будет отгонять глюки) или киберпанковская серьга.

Кому: маньяку-железячнику.

Эмоции: бурные, переходящие в помешательство.

ЛОТ №8. ЗАПАСНАЯ ИНТЕРНЕТ-КАРТОЧКА

Ситуация: Ночь. Улица. Фонарь. Mp3'шка уже на 98% слилась на винт... И тут - БАЦ! - подло закончились бабки на счету, и дисконнект неминуем. А еще нужно отослать важную почту. Аа-а-а!!! В такой ситуевине заплатишь за час сети втридорога, но некому - ночь на дворе. И тут ты вспоминаешь, что на стене в изголовье кровати висит рамка с карточкой на пять баксов, подаренная на Новый год святым человеком, другом Петей. Ты хватаешь молоток и с диким криком бьешь стекло, дрожащими пальцами вынимаешь карточку, карябаешь защитный слой, промахиваясь по кнопкам, вводишь ключ и... "Карта уже активирована". Подонок Петя!!! Гы-гы! А просто Петр научился снимать защитную пленку, не повреждая, и приклеивать потом на место. А если карточка на 25 уев? В общем, бери старую карточку и клей ее лицевой стороной наружу, пакуй под стекло, добавляй бумажку со слоганом (например, "Помни, инет кончается внезапно!") и неси дарить.

Кому: маньяку-интернетчику.

Эмоции: радость, перемешанная с благоговением, переходящая в ненависть.

ЛОТ №9. ЗАПАСНЫЕ КНОПКИ

Представь, пришел ты к себе, включил комп, положил руки на клаву и офигел. Нету трех пальцев (Ctrl+Alt+Del), нету Esc, нету помогалки (F1), нету Enter'а и вообще дестрой полный. Ну, пошутил кто-то. Приехали - работать и отдыхать нормально нельзя. На этот случай можно подарить своим друзьям рамку с набором этих мега-нужных кнопочек. Да и смотрится такая рамка очень стильно. Можно снабдить подарок надписями: "Запасной выход", "Осторожно! Очень горячие клавиши!", "При пожаре дави F1" и т.д. Вообще, шикарным подарком ламеру-сослуживцу будет рамочка с кнопкой, на которой будет написано "Any Key".


Спецвыпуск Xakep, номер #026, стр. 026-036-4, ПОДАРКИ НАШЕГО СЕРВАКА

ПОДАРКИ НАШЕГО СЕРВАКА

DonoR (donor@real.xakep.ru)

Спецвыпуск Xakep, номер #026, стр. 026-036-4

Кому: всем, кто хоть пару раз видел комп.

Эмоции: безудержное ржание.

ЛОТ №10. ЛЕЙБЛ

Люблю наклеить на печатную машинку совкового образца лейбл "Intel Inside" :). Что ни говори, а лейбачок у пеньков стильный. ИМХО, рамочка с таким лейбачком на зеленом бархате, например, будет смотреться тоже очень модно. И опять же запаска на случай, если какой-нибудь гопник отковыряет лого от твоего компа. Хороший нейтральный подарочек.

Кому: кому угодно.

Эмоции: умеренные.

ЛОТ №11. ШПРИЦ С ТЕРМОПАСТОЙ И КУЛЕР

В наше время процов-кирпичей и тотального оверклокинга шприц с термопастой становится прямо-таки жизненно необходимым. Все на борьбу с перегревом и глюками! Кроме того, между нами, девочками, муляжи косяков в рамочки засовывают, а вот баян (даже имитацию) - стремно, а тут все пучком. Клади в рамку под стекло, шприц, иголку и кулер, снабжай надписью "Плавятся мозги? Выдави!" или "Попробуй взрыв свежести!" и беги дарить. А ведь этот подарок может и пригодиться! Решил ты, скажем, разогнать камень. И что, теперь в магазин бежать? В общем, стильная и полезная вещь!

Кому: маньяку-оверклокеру.

Эмоции: адский огонь в глазах.

ЛОТ №12. ПРОВОДОК НА ЗВУКОВУХУ

Очень часто кто-то ставит кому-то ЦеДе-РОМ и зажимает проводок на звуковуху. Ищи свищи его потом. А музыки тем не менее нету, но очень надо. Особенно страдают от этого дефачки-секретарши. Им хочется послушать закачанные каким-то добрым дядей mp3'шки, но звука нет, и ты им объясняешь, что так просто это не пофиксить. Они так расстраиваются, бедняжки! Грустят и вянут. Подари ей на Новый год проводок в футлярчике для браслетов с маленьким серебряным сердечком, установи его вместе с ней, и девочка твоя >;). Она будет тебе так благодарна, что отдастся прямо на разобранном системнике.

Кому: маленьким сладеньким дефачкам.

Эмоции: обожание.

Надеюсь, ты воткнул, что новогодние подарки валяются у тебя буквально под ногами? Напряги мозг, выключи свою лень, заряди фантазию, и вперед! Присылай фоты своих самых оригинальных новогодних подарков СПЕЦу на мыло.


Спецвыпуск Xakep, номер #026, стр. 026-076-1, Прикольные истории про компы :)

Прикольные истории про компы :)

Frozen (frozen@real.xakep.ru)

Спецвыпуск Xakep, номер #026, стр. 026-076-1

Наверное, много, очень много всякой технически грузной информации влилось в твой управляющий комп aka головной мозг, и после такого огромного перенапряга следовало бы чуточку передохнуть перед новым приливом следующей огромной порции подробностей функционирования сетей, протоколов, программ и других всяких заумных вещей, так или иначе связанных с информатизацией нашего общества. Ну а сегодня, в качестве разгрузки и обеспечения небольшого, заслуженного отдыха для твоих уставших мозгов, представляю тебе на рассмотрение несколько линков, просматривая которые, ты сможешь хоть немного отвлечься от хака и просто развлечься и посмеяться от души :).

http://gluchit.narod.ru/

Огромный портал со всяческими шутками-приколами, анекдотами и прочими развлекалочками, коих тут найти можно просто-таки несметное количество, присутствует и нужная нам тема про компьютеры :). Прочитав пару текстовичков и скачав несколько прог с этого мегапортала %), можно устроить тотальный дестрой на вражеском компе, добавив немного адреналина его обладателю :). Но только прикалывайся осторожнее, вдруг человек готовил исследование всей своей жизни, и тут вдруг окошечко с форматированием - так и до инфаркта недалеко :).

http://prikol.pp.ru/pics/comp1.htm

Сайт со всяческими веселыми картинками (веселыми не в смысле из раздела для взрослых, а веселых aka смешных) про компы и про всяческие девайсы, пикчерсов немного, но зато они сделаны с какой-то интересной задумкой; как тебе, например, брачные игры комповых крыс или телефон с тремя кнопками Ctrl, Alt, Delete? Вот было бы побольше именно про компьютеры - вообще бы цены не было этому сайту, а так ты можешь найти еще много интересностей из жизни, не относящейся к околожелезной теме.

http://www.acma.ru/an/anshow.php

Убойный сайт, куча всяческих прикольных фраз и историй; я как только забрел сюда - не мог оторваться в течение часа, читая всяческие смешные текстовички, среди которых иногда проявляются и темы про компьютеры. Графики совершенно нет никакой, да и в менюшке сложно потеряться, все сделано максимально просто и понятно даже для незнакомого с Интернетом человека. В общем, напряга и дискомфорта при чтении ты не ощутишь никакого, а вот продление жизни тебе обеспечено (смех, однако, жизнь увеличивает ;). Вперед, к веселью ;).

http://anekdot2000.ru/show.phtml?m=41

А вот это сайт не просто со всякими хуморными историями, а с реальными рассказами, как можно веселее проводить время с пользой, скучая на работе :). Как тебе фишка с пейджером "...посылаем два сообщения: 'Идет подготовка к выключению питания пейджера' и 'Теперь питание пейджера можно отключить'". Или другой прикол "над нашим шефом -)). На пейджер высылается сообщение: 'Теперь я тамагочи! Покорми меня!'". И таких корных историй, с помощью которых ты, несомненно, поднимешь себе настроение, там присутствует достаточное количество. А наличие на том же сайте огромного количества компьютерных (и не только) анекдотов окончательно должно поднять тебе настроение на весь оставшийся день :).

http://www.tema.ru/rrr/


Спецвыпуск Xakep, номер #026, стр. 026-076-2, Прикольные истории про компы :)

Прикольные истории про компы :)

Frozen (frozen@real.xakep.ru)

Спецвыпуск Xakep, номер #026, стр. 026-076-2

Опять главное в этом сайте - куча смешных картинок, здесь выбор гораздо богаче предыдущего, и просто море пикчерсов на разные темы, начиная от табличек и вывесок и заканчивая фотографиями всяких смешных памятников и скульптур. Заряд бодрости в виде продолжительного здорового смеха гарантирован однозначно. А веселостей тут лежит огромное количество, хватит всего этого добра надолго, и лично я редко встречал так хорошо подобранные действительно смешные, до сползания под стол, приколы.

http://www.monitor.ab.ru/~monitor/07.htm

Подборка всяких прикольных и шуточных программ для твоих друзей и знакомых весьма конкретно повеселит тебя в дни деструктивно-разрушительного настроения. Присутствуют проги как для виндов, так и для тех, кто еще пользуется старым добрым дедушкой ДОСом. Переворачивание экрана, замена буковок на японские иероглифы или просто смешные ошибки типа "коврик выполнил недопустимую операцию и будет выброшен" особо порадуют твою душу, если внутри у тебя все так и вскипает при виде тупой секретарши, не знающей, где и как нажать очень важную клавишу Any Key :).

http://www.moskalyuk.com/shutki

Тут можно натолкнуться на большое количество рассказов типа "Почему компьютеры лучше мужчин" или знаменитые "Законы Мерфи в программировании". Практически все рассказы относятся к компьютерам и всяким разным штучкам, связанным с ними. Причем коллекция содержит и английские шутки, понять которые ты сможешь, только если неплохо владеешь аглицким, но, поверь, и приколов на нашем с тобой родном великом и могучем хватит сполна, чтобы сползти под стол или надорвать животик от смеха :).

http://home.univer.kharkov.ua/max/graph/blincl.htm

Ты когда-нибудь видел, как инсталлируется следующее поколение виндообразной системы версии 2010? А вот я после этого сайта уже, похоже, ничему не удивлюсь, и ясно, откуда глюки берутся в мелкософтовских программах и почему все проги работают как-то тормозззнуто и не так, как хотелось бы :). Стоит только всего лишь взглянуть на материалы, представленные по этому линку, как тут же все становится ясно и понятно, а еще странно, как еще до сих пор живет-то такая фирма - Microsoft...

http://prikol.perekur.ru/comp.shtml

Ну и напоследок еще одна порция веселых шуток и прикольных фраз вроде "И послал он свой комп на три кнопки. [Ctrl/Alt/Del]", "Узник замка If: программист". Простенько и со вкусом, никаких там анекдотов, а просто хорошие слоганы, которые можно даже поставить на свой ориджин в сообщениях. Фраз тут этих довольно много, и все они легко запоминаются и будут хорошо смотреться в качестве подписи для твоих писем, а еще лучше можно сделать, если поставить не одну, а все сразу в кукисы вампирчика, тогда при каждом новом письме будет вылезать случайная фраза :). И с такой фичей твои письма будут всегда узнаваемы.


Спецвыпуск Xakep, номер #026, стр. 026-080-1, Лазерный дальномер Прозвонкина

Лазерный дальномер Прозвонкина

Доктор Прозвонкин

Спецвыпуск Xakep, номер #026, стр. 026-080-1

(Dr.Cod@real.xakep.ru)

Сделать это простенькое устройство меня надоумил Дронич. Мне часто звонят друзья и спрашивают что-то типа: "А сложно ли собрать лазерный дальномер?". Дронич ждал какой-то заумной электронной схемы, которая отправляет и принимает лазерный импульс, прямо как в военной технике. Но я опять упростил все до трех деталей из обычного магазина.

ВСПОМИНАЕМ ШКОЛУ

Далекие объекты кажутся маленькими, а близкие большими. Например, маленькой головкой от спички, которая близко, можно заслонить гигантскую звезду, которая далеко. Чем дальше объект, тем меньше он кажется глазу. Проще всего воспользоваться этим свойством, когда у тебя много предметов одного размера.

Допустим, что ты стоишь на дороге, вдоль которой стоят столбы одинаковой высоты. Отметь на деревянной линейке карандашом кажущиеся размеры столбов и ты получишь простейший дальномер. То есть я предлагаю измерять обычной линейкой дальние объекты. Во время каждого замера ее нужно держать перед глазами, как прицел автомата.

Столбов ты уже намерился и теперь можешь упростить устройство, выкинув лишние детали. Выкидывай поскорее линейку с пометками. Столбы стоят вдоль дороги на одинаковом расстоянии друг от друга, поэтому узнать расстояние до очередного столба ты сможешь по его номеру. Если знаешь, какое расстояние между соседними столбами, то достаточно будет их пересчитать.

А теперь представь, что тебе нужно померить расстояние до деревьев, домов, машин, гор, но они все разных размеров. А твоя линейка-дальномер работает только с объектами одного размера! Что же делать? Правильно, нам нужен объект одного размера. Никогда не видел землемеров, один из которых смотрит в прибор, похожий на бинокль, а другой с размеченной красно-белой палкой бегает? С помощью такой палки они могут измерить высоту грунта и расстояние. Чем дальше убежал сотрудник с палкой, тем меньше она занимает места на шкале прибора. Так расстояние и померили.

Вот и появилась идея изготовления двуножного дальномера. Заставляешь своего приятеля откопать столб у дороги и бегать с ним до нужных объектов. Если ты не забыл, то твоя мегалинейка-дальномер отградуирована на столбы.

ГДЕ ЖЕ ТУТ ЛАЗЕР?

Ну а теперь возьмем редкий случай, когда у тебя нет тупого, накачанного, управляемого приятеля, который будет выкапывать столбы и с ними бегать по ландшафту. Вот тут и приходит на помощь людям лазер. Не обязательно таскать измерительную палку, если можно ее спроецировать. То есть ты можешь высветить размеры палки на дальнем объекте в виде двух лазерных зайчиков от лазерной указки. Однако чтобы ты мог пользоваться уже отградуированной на столбы линейкой-дальномером, нужны две лазерных указки, прикрепленные на разных концах столба. При этом лучи должны быть параллельными. Получается, что чем дальше сидят от тебя два зайчика из параллельных пучков света, тем меньше кажется между ними расстояние.

КАРМАННЫЙ ВАРИАНТ!

Заметь, лазер мы прилепили, а столб никуда не делся. Теперь вы вместе с накачанным другом таскаете столб, по краям которого привинчены две лазерных указки. Но дальномер-то у нас должен быть карманным! Неувязка. Опять нужно выкидывать лишние детали, и на этот раз выкидываем столб! Ох, фу-у-у, наконец-то к середине статьи мы выкинули столб, и больше с ним связываться не будем.


Спецвыпуск Xakep, номер #026, стр. 026-080-2, Лазерный дальномер Прозвонкина

Лазерный дальномер Прозвонкина

Доктор Прозвонкин

Спецвыпуск Xakep, номер #026, стр. 026-080-2

Теперь можешь смело скрутить указки между собой скотчем, но так, чтобы они были под углом друг к другу. Хотя скрутить их параллельно все равно не выйдет, ну а если выйдет, то вместо двух указок ты получишь одну, что тоже не нужно. Для удобства можно прикрутить указки к ногам циркуля.

И что же у нас получилось? От синего циркуля, к ногам которого примотаны скотчем две указки коричневого цвета, идут два красных лазерных луча. На черной стене дома они отбрасывают два красненьких зайчика, расстояние между зайцами ты можешь померить линейкой. Главное, не забудь держать линейку на одинаковом расстоянии от глаз при каждом замере.

Кстати, некоторые думают, что линейку нужно обязательно прикручивать к циркулю с указками. Ничего подобного. Циркуль можешь держать в одной руке, а линейку в другой.

Только вот в чем проблема: надо выкидывать разрисованную линейку и брать новую, а все потому, что теперь все вывернулось наизнанку! Теперь чем дальше лазерные зайцы, тем больше расстояние между ними! Придется заново размечать линейку, для этого нужно кинуть зайцев на первый столб, пометить карандашом расстояние между ними, на второй, и так пока глаз хватит. Ох, снова столбы!

Но теперь, если ты не будешь менять угол между указками, если не будешь менять положение линейки относительно глаз, можно будет мерить практически любые объекты, сравнивая расстояние между зайцами. Кстати, линейка-шкала показана голубым цветом, на ней видны два зайчика.

Такой дальномер хорош тем, что лазерные указки можно крепко закрепить. Например, их можно прибить гвоздями к доске или придумать иной техно-сатанизм. Но такой дальномер плох тем, что заняты две руки: в одной указки, в другой линейка. Можешь подумать, как бы прикрутить линейку с указками к голове, можно их попробовать встроить в шапку, так чтобы шкала откидывалась как прицел у боевого космонавта на шлеме. Можно попробовать нанести шкалу прямо на очки, только не ной потом, что испортил очки с моей подачи. Семь раз, как говорится, отрежь - один отмерь. Зелененьким показано расстояние от циркуля до стены, его-то мы и измеряем!

Кстати, такой дальномер можно закрепить на легковом автомобиле, а шкалу наклеить на стекло. Только не свети водителям в глаза лазером! Это очень вредно и может привести к дорожно-транспортным происшествиям, или можно просто получить по шее от водителя.

На практике циркуль лучше перевернуть вверх ногами, так чтобы лучи пересекались. Это нужно для того, чтобы легко получить небольшой угол, ведь указки толстые и закрепить их по-обычному трудно. Если угол между лучами большой, то зайцы очень быстро разбегутся и не будут влезать на линейку-шкалу. Правда, под этот дальномер придется заново размечать шкалу.

БЕЗ ЛИШНИХ ДЕТАЛЕЙ

Ты знаешь мое отношение к лишним деталям! Давай поговорим о недостатках дальномера с расходящимся пучком. Далекие объекты должны быть жирными и плоскими, чтобы оба лазерных зайчика на них попали. Идеальный объект - панельный дом, такой необъятный, ровный и плоский. Но даже если к нему ты встанешь под углом, то один заяц упадет раньше другого, и размеры исказятся.


Спецвыпуск Xakep, номер #026, стр. 026-080-3, Лазерный дальномер Прозвонкина

Лазерный дальномер Прозвонкина

Доктор Прозвонкин

Спецвыпуск Xakep, номер #026, стр. 026-080-3

Словом, мы сделали не очень удобный двуручный дальномер для определения расстояний до параллельных панельных домов.

А теперь фокус-покус. Давай возьмем дальномер на циркуле с пересекающимися лучами и будем менять угол до тех пор, пока зайчики не сольются в один, как это показано на рисунке. Зацени! Теперь не надо смотреть на зайцев через шкалу, потому что заяц один! Теперь твоя задача соединить зайцев и посмотреть и проверить угол на циркуле! Это гораздо удобнее, ведь не нужно заботиться о том, чтобы держать перед глазами линейку. А еще теперь мы можем измерять расстояние до очень маленьких объектов, на которые влезает только один заяц, а не два.

Шкала тут тоже нужна, теперь каждый раз можно мерить расстояние между ногами циркуля. Оно-то и будет говорить о дальности объекта. Либо можно взять циркуль с колесиком и считать количество оборотов колесика. Чтобы считать неполные обороты колесика, на нем можно поставить риску или сделать зазубринки напильником, чтобы чувствовать на ощупь.

ДЕТАЛИ

Для сборки лазерного дальномера нам понадобятся всего три детали: один циркуль с колесиком, я отрыл в старой готовальне, хотя его можно купить в канцелярском магазине. Две указки куплены по 60 рублей каждая. Вот и все детали. Скотч и ластик не в счет.

СБОРКА

Указки надо примотать к циркулю под углом, для этого я использовал кусочки ластика. Мотать надо потуже, потому что конструкцию не должно колбасить. Вообще, нужно подумать: как бы получше закрепить указки, может быть, стоит их привинтить стальными скобами. Очень неудобно, когда указки шатаются, они должны жестко сидеть на ногах циркуля.

После того как аппарат собран, нужно попробовать соединить два лазерных зайчика в один, для этого крепеж указок придется поправить. После того как указки уселись жестко и их лучи легко собираются в точку, можно начинать градуировку линейки или колеса. Для этого нужно найти несколько объектов, расстояние до которых ты знаешь. Такими объектами могут стать те же столбы. Рядом с любой школой ты найдешь стадион либо дорожку для бега с размеченными расстояниями.

Измерять лучше, когда темно. Благо, зимой рано темнеет. Однако днем или вечером, чтобы увеличить дальность, можно использовать бинокль или подзорную трубу, чтобы разглядеть: слились ли зайчики.

Удобнее использовать дальномер, держа его двумя руками, однако ты можешь привыкнуть делать это одной рукой. Для этого в начале измерения сведи циркуль с колесиком, разводить его будет очень легко под действием пружины, которая есть у большинства колесных циркулей.

Можешь использовать точечный дальномер, не только чтобы измерять расстояния, но и для того, чтобы размечать местность. Когда-то мы с друзьями строили модель форта с земляными валами. Наши фортификационные чертежи мы переносили на местность с помощью веревок; вот если бы у нас был такой дальномер, было бы круто! Дальномером можно быстро разметить поле для игры в снежки, можно прикинуть, сколько ехать, сколько плыть, докинешь - не докинешь и тому подобное. Например, можно замерить дальномером, как далеко ты кидаешь снежки, выставить его и рассчитывать, когда забрасывать противника. Как только лазерные зайцы слились на пузе условного врага - КИДАЙ!


Спецвыпуск Xakep, номер #026, стр. 026-080-4, Лазерный дальномер Прозвонкина

Лазерный дальномер Прозвонкина

Доктор Прозвонкин

Спецвыпуск Xakep, номер #026, стр. 026-080-4

ПОЛЕЗНАЯ ШТУКА ДАЛЬНОМЕР!


Спецвыпуск Xakep, номер #026, стр. 026-082-1, ПОЛЕЗНЯШКИ - Мелкие и полезные утилки

ПОЛЕЗНЯШКИ - Мелкие и полезные утилки

Kirion (Kirion@winfo.org)

Спецвыпуск Xakep, номер #026, стр. 026-082-1

Что отличает один дом от другого, твою комнату от комнат твоих друзей, твое рабочее место от рабочих мест твоих коллег? Ты всегда подстраиваешь его под себя, украшаешь, как нравится, делаешь его более удобным. Вещи, которые создают уют, часто незаметны, но ты настолько привыкаешь к ним, что потом не можешь себе представить, как ты обходился без них раньше. А чем комп хуже? Ведь в каком-то смысле он тоже рабочее место, а для некоторых и дом :). Можно ли твои окошки отличить от безликой массы компов других пользователей? Если ответ для тебя не очевиден - тебя ждут пять минут полезного чтения :).

ЧТО ТАКОЕ ХОРОШО И ЧТО ТАКОЕ...

Вообще-то, довольно сложно провести черту, которая отделяет утилиты, попадающие под нашу тему, от всех остальных. У разных людей разные потребности - кому-то нужны украшалки, кому-то мелкие твикеры, некоторые любят извращаться над интерфейсом, кто-то не представляет свою жизнь без довольно узкоспециализированных программ. Поэтому не удивляйся, если мои полезняшки тебе не подойдут - в этом вопросе я довольно субъективен, но мое мнение тоже чего-то стоит :) Ну что, перейдем к делу?

ИМЯ ИМ - ЛЕГИОН

С чего бы начать, вот хотя бы: Total Copy. У тебя есть локалка? А вот у меня есть. И бывает очень неприятно, когда качаешь какое-нибудь кино, а чел тебя выкинет или вообще выключит комп. Прога добавляет в контекстное меню, вызываемое при перетаскивании файла правой кнопкой мыши, два пункта: "Total Copy Here" и "Total Move Here". Воспользовавшись ими, ты сможешь копировать файлы с докачкой, а также регулировать скорость закачки. Ты всегда сможешь поставить скачку на паузу, которая также включится при невозможности скачать файл дальше (из-за недоступности узла или при отключении электричества :)). Ну и до кучи, разработчик уверяет, что копирование идет слегка быстрее, чем стандартными виндовыми средствами. Не знаю, не проверял, но и без этого прога стоит своих 92 килобайтов.

Кстати, а в твоей локалке играют в CS или Кваку? Если - да (а скорее всего, да), то обязательно зайди на www.agsm.net и скачай aGSM. Прога ищет в локалке запущенные сервера самых популярных сетевых игр. Ты можешь посмотреть ники играющих, свойства сервака, а предварительно настроив запуск игр - легко и быстро присоединяться к выбранному серверу. Отмечаешь нужные тебе игры, настраиваешь и периодически поглядываешь на трей, где живет прога, - не надо запускать лишний раз саму игру.

Веб-дизайном не увлекаешься? А скрипты тестировать тебе не приходилось? Или делать у себя на машине маленький веб-сервер для пользователей той же локалки? Необязательно ставить апач, можно поставить Small HTTP server. Это полноценный web, ftp, proxy, dns, smtp и pop3 сервер. Очень маленький (103 килобайта), быстрый, неплохо настраиваемый. Тем более, что в некоммерческих целях его можно использовать бесплатно, в других случаях регистрация стоит всего 100 рублей для СНГ и стран Прибалтики. Никогда не поздно стать админом :).

Ну и еще немножко про веб-дизайн. Если тебе приходилось делать массовые замены в HTML-файлах или менять их кодировку, то тебе, несомненно, пригодится HTMLchanger. Задаешь список файлов, что заменять - и вперед. Я на эту прогу просто молился, когда переезжал на новый хостинг и пришлось заново прописывать ссылки.


Спецвыпуск Xakep, номер #026, стр. 026-082-2, ПОЛЕЗНЯШКИ - Мелкие и полезные утилки

ПОЛЕЗНЯШКИ - Мелкие и полезные утилки

Kirion (Kirion@winfo.org)

Спецвыпуск Xakep, номер #026, стр. 026-082-2

А вместо блокнота для набивания небольших страничек и текстов обязательно попробуй Bred2. Кстати, этот текст я набивал именно в нем, лучшем заменителе виндового блокнота. Понимает достаточно много кодировок, может подсвечивать html-теги. Если же ты найдешь уж совсем экзотическую кодировку, то тут не справиться без Штирлица. Жаль только, что программа очень давно не обновляется, но со своими обязанностями справляется хорошо. Если и Штирлиц не перекодировал текст в читаемый вид, то стоит задуматься, может это и не текст вовсе, а какой-нибудь экзешник :).

Если же ты хочешь прочитать не просто текст, а книгу на компе, то советую не мучить глаза и установить программу-читалку. Могу посоветовать Bookshelf или Tom-reader. Bookshelf, конечно, красивее будет, но и ресурсов жрет больше - для работы необходим свежий IE. Обе программы понимают распространенные форматы, могут читать текст в html, читать из архивов. Главное, читай побольше, это полезно для интеллекта :).

А если вдруг нужно не почитать, а посчитать, то прямая дорога тебе на www.nlcalc.narod.ru, качай NumLock Calculator и забудь про встроенный виндовый навсегда. Пусть прога не очень красивая (все равно для нее есть скины, что-нибудь себе подберешь), но очень удобная. Сидит в трее, вызывается по нажатию NumLock (отсюда и название). Куча различных математических функций, возможность работы с переменными и программирование собственных функций - вот скромные возможности этого калькулятора. На этом же сайте можно скачать Невидимый калькулятор. Выглядит его действие так: пишешь в текстовом редакторе или где-нибудь еще формулу, выделяешь фрагмент, нажимаешь горячую клавишу - и перед тобой результат или сама формула, знак "=", результат, тут уж как настроил. Только загляни сначала в справку, чтобы узнать обозначение некоторых функций - программа умеет считать вещи и посложнее 2+2 :).

Ну вот, поработал ты за компом, уж утро на дворе, пора его выключать. Только вот у многих пользователей ХР были жалобы, что комп не хочет нормально выключаться. Видимо у автора Power off тоже были такие проблемы. Впрочем, программа быстро развивается, и из средства быстрого выключения\перезагрузки\и т.п. она превращается в некоторое подобия шедулера. Новые беты выходят чуть ли не по два раза в месяц - посмотрим, куда она придет в итоге.

МЕЖ ДВУМЯ МОРДАМИ

А теперь поговорим про различные усовершенствования виндового интерфейса. Если честно, я не очень люблю чисто украшательные программы - во мне говорит просто маниакальная страсть к экономии системных ресурсов :). Но многие из них несут ощутимое удобство в работе, о них и расскажу. Direct folders. Если честно, это первая прога, которую я захотел купить, не найдя к ней лекарство :(. Что же в ней такого хорошего? В заголовок любого окна встраиваются две кнопки рядом с системными: кнопка с изображением кнопки :) позволяет расположить окно поверх других (aka always on top), другая же оставляет от окна только заголовок, делая невидимым остальную часть окна. Можно бы было это делать по горячим клавишам - обычной командой "свернуть" я бы больше вообще не пользовался. Далее, в заголовке любого окна проводника появляются еще две кнопки: история часто открываемых папок и возможностью быстро перейти в папку программы (для проводника это c:\windows :)). Вторая кнопка дает доступ к настраиваемой менюшке папок и фильтров файлов, которую можно и нужно настроить самому. Тем более, что можно создавать подменю. Ну и, наконец, в стандартных диалогах виндов, кроме этих четырех кнопок, появляется красивая шапка с указанием полного пути к текущей папке, именами и заполнением всех дисков в системе, а само окно диалога становится изменяемого размера. А теперь о грустном, в незарегистрированном виде программа имеет ограничение на срок работы, кроме того, поддерживается создание только трех менюшек :(. В общем-то, 20 баксов это не так много... Для того же, кому такую сумму все-таки жалко (как и мне :)), могу посоветовать две небольших проги: Dirkey (http://www.protonfx.com/dirkey) и Folder Cache (www.neosoft.org). Dirkey позволяет быстро перемещаться по папкам в окне проводника или стандартных диалогах по комбинации ctrl+цифра или буква. Folder Cache же добавляет в заголовок окна кнопку с последними открытыми папками. Конечно, это не равноценная замена, зато обе они бесплатные...


Спецвыпуск Xakep, номер #026, стр. 026-082-3, ПОЛЕЗНЯШКИ - Мелкие и полезные утилки

ПОЛЕЗНЯШКИ - Мелкие и полезные утилки

Kirion (Kirion@winfo.org)

Спецвыпуск Xakep, номер #026, стр. 026-082-3

Ну и до кучи можно скачать path2clipboard. Программа добавляет в контекстное меню файлов и папок пункт "копировать путь". Причем путь копируется в нескольких вариантах, корректно копируются сетевые имена.

Ладно, не буду больше расстраивать, дальше рассказываю только про проги, для которых есть кряки :). Например, про True Launch Bar. Ты пользуешься панелью Quick launch? Все, ее пора сдавать в утиль. True Launch Bar (сокращенно TLB) позволяет группировать ярлыки в красивые выпадающие менюшки с управляемой прозрачностью, добавлять ссылки на сайты, назначать менюшкам горячие клавиши. Можно создать ссылку на папку, и у тебя будет раскрывающееся меню со всем ее содержимым. Можно создать несколько тулбаров и использовать их вместе или переменно, благо их легко переключить из контекстного меню. А еще TLB поддерживает скины и плагины. Например, проверка почты, управление звуком, часы, погода, управление Winamp и другие. На сайте разработчика можно скачать все необходимое для создания собственных плагинов. Кстати, под панели плагинов существуют отдельные скины. Не пожалей 800 кило трафика. Очень скоро ты забудешь о том, что Quicklaunch вообще существовал. Да и кряк искать не обязательно, если ты скачаешь дополнительные языки и поставишь основным русский. Мелочь, а приятно :).

А если тебе все еще мало менюшек, то прошу на w1.321.telia.com/~u32102551/. Правда страшный урл? :). Здесь обитает прога Yo!Utilites. Функция проги - делает углы экрана активным. По клику мышки появляется настраиваемая менюшка. Что удобно, пункты могут быть динамическими, можно задавать маску, что будет видно, а что не видно в меню. Прога старая, но чем-то она меня зацепила, и я ее не меняю. Может, дело в названии, йоу :). Хотя аналоги имеются.


Спецвыпуск Xakep, номер #026, стр. 026-082-4, ПОЛЕЗНЯШКИ - Мелкие и полезные утилки

ПОЛЕЗНЯШКИ - Мелкие и полезные утилки

Kirion (Kirion@winfo.org)

Спецвыпуск Xakep, номер #026, стр. 026-082-4

Далее: RunIt. При первом взгляде прога похожа на TLB, но это не так. Основная задача RunIt - ускорить запуск популярных приложений. Прога создает свой тулбар с несколькими кнопками: "recent" - недавно запускавшиеся приложения; "top" - наиболее часто запускавшиеся приложения с момента установки проги; "favorites" - это обычная выпадающая менюшка, которую ты настраиваешь сам; "run" - при первом запуске RunIt сканирует комп на наличие программ, потом из этой менюшки можно запустить любую по контекстному поиску; "Stop" - список процессов и их уничтожение по клику. Прога неплохо настраивается, ведет подробные логи всех запусков программ. Можно (и нужно) задать исключения для нужных программ, на основные действия имеются горячие клавиши. Был бы еще интерфейс посимпатичнее... А то рядом с TLB прога выглядит не очень, прямо скажем.

Что, хочешь еще? Ну ладно, ненасытный ты мой, лезь тогда на www.kc.ru/~dubok и качай оттуда Mouse Utility. Довольно простая, но удобная программка - по нажатию средней кнопки у мыши или комбинации alt+win вылезает симпатичная менюшка, содержащая два ряда кнопок. Первый ряд зашит в программу, но его можно убрать, перейдя в "сжатый вид". Второй ряд ты создаешь сам, причем можно одним кликом скопировать туда ярлыки из Quick launch панели. Есть, правда, один небольшой баг: не забудь выставить в настройках "не скрывать панель", а то будешь долго думать, почему же панель появляется только на фоне рабочего стола. На самом деле, она появляется всегда, просто под другими окнами :).

А для тех, кто с детства ненавидит менюшки и ностальгирует по ДОСу, могу посоветовать Winconsole. Прога представляет собой небольшую консоль, вылезающую по нажатию горячих клавиш. Можно создавать собственные алиасы команд, кроме того, понимаются стандартные ДОСовские команды. Автодополнение, перебор путей - все как в win2k-консоли. Прога шароварная, но для наших - регистрация бесплатная. Для полных консольных маньяков советую заглянуть на www.sysinternals.com и скачать прогу Pstools. Для тех, кто не в курсе: команда Ps в юнихе выводит список процессов. Pstools состоит из нескольких команд, которые, безусловно, пригодятся любому админу win2k: тут и список процессов, и открытые по сети файлы, и сетевые подключения, и много еще чего. Причем почти все команды могут выполняться и для удаленного компа. Кстати, на сайте разработчика можно скачать еще кучу утилит для различных виндов. Перечислять все не имеет смысла, но особо хочу обратить внимание на семейство программ-мониторов, следящих за реестром, за диском и файлами, за библиотеками и виртуальными драйверами, за портами и подключениями. А для людей, которые вообще не переваривают стандартный интерфейс виндов, могу посоветовать скачать хит сезона - модифицированный Windows commander (точной ссылки дать не могу, но в Инете находится легко). Полностью настроенный, крякнутый, с прикрученным IrfanView, русским языком и архиваторами. Осталось только установить. Кстати, уже вышла свежая версия (теперь прога называется Total commander из-за проблем с копирайтами мелко-мягких). И начали появляться подобные творения и для нее. Этакое соревнование на лучший любительский дистрибутив :).


Спецвыпуск Xakep, номер #026, стр. 026-082-5, ПОЛЕЗНЯШКИ - Мелкие и полезные утилки

ПОЛЕЗНЯШКИ - Мелкие и полезные утилки

Kirion (Kirion@winfo.org)

Спецвыпуск Xakep, номер #026, стр. 026-082-5

7Х7 ГНОМОВ

Вот такая вот маленькая армия. Причем заметь, по большей части любительская. Программисты-энтузиасты, создающие фриварный софт, что бы мы без вас делали? Я каждый день сталкиваюсь с десятками подобных прог, и 90% сразу оправляются в корзину. Но выходят новые версии, и они становятся стоящими проектами. Так что если ты программер или у тебя просто есть малоизвестная, но полезная прожка - присылай ее мне. Возможно, она появится в Полезняшках-2 или на нашем сайте :). А даже если нет - всегда смогу указать на ошибки. Главное - не сдавайся и не ленись, мы на тебя надеемся :)

P.S. Если ты хотел скачать программу Hotkey host из прошлого номера, то принимай мои извинения за нерабочую ссылку. Сайт программы переехал на www.mhpi.ru/hotkeyhost/. Спасибо разработчикам за четкую консультацию :).


Спецвыпуск Xakep, номер #026, стр. 026-086-1, ][-desktop - взгляд в небо

][-desktop - взгляд в небо

ilich (ilich@winfo.org)

Спецвыпуск Xakep, номер #026, стр. 026-086-1

Зима. Кругом замороженная вода и пониженная температура. Кому-то это нравится... Но лично я не в их числе. Я лето люблю. А в такое, как сейчас, время - по лету скучаю. Хочется солнышка, чистого светлого неба. И чтобы это было всегда. Круглый год. Днем и ночью.

ЗАТРАВКА

Кремль стоит, куранты бьют, и все, кажется, пучком. Но фон всегда остается одним и тем же, а ведь время идет. За компом-то ты сидишь, наверное, не по пятнадцать с половиной минут. Ты ни разу не ловил себя на мысли, что у тебя скучный монитор? К чему это я? Да к тому, что не плохо было бы устроить в качестве фона для Кремля веселый летний пейзажик. А раз уж мы там мутили со временем, то этот самый пейзаж мы просто обязаны сделать динамически изменяющимся в зависимости от времени суток.

Сразу предупреждаю, ресурсов твоей тачки это потребует не мало, ибо плюс к Кремлю (который и сам по себе тормозит заметно) мы добавим небо, с некоторыми присущими ему компонентами.

Открывай флешку с Кремлем. Если в прошлый раз ты делал все, что я тебе говорил, то на основной сцене у тебя должно быть четыре слоя кадров. Их мы трогать не будем, да и вообще почти все те символы, созданные в прошлый раз, мы даже не кликнем. Необходим будет лишь основной символ прошлой флешки C - Kremlin. И то лишь только для того, чтобы в скрипт для часов кое-чего добавить.

Для неба в библиотеке создай новую папочку "Sky". Все те новые символы, что мы сделаем сегодня (включая графические объекты "Tween1", "Tween2" и т.д., создаваемые Flash'ем автоматически), помещай для упорядоченности туда.

ЛЮБЛЮ ГОЛУБОЙ ЦВЕТ

Создай новый символ клипа "C - Sky". Это будет небо целиком. В нем будет четыре слоя кадров. Сверху вниз (в скобках имена слоев, которые стоят у меня): для облака (Clouds), для солнца (Sun), для неба (Blue), для ночного неба (NightStars). Заполнять эти слои мы будем не совсем в таком порядке. Начнем с самого, на мой взгляд, главного. С голубого (blue).

Не подумай ничего такого... Просто моему мозгу приятно получать от визуальных датчиков сигналы о принятии электромагнитных волн соответствующей длины. Смотрел ли ты когда-нибудь на небо? Знаю, глупый вопрос. Тогда так. Помнишь ли ты цвет неба? Не тех серых туч, что висят сейчас над тобой в атмосфере. А именно тот самый светло-голубой цвет... Хреново тебе. А я помню. Так вот, надо сделать клип "C - BlueSky". В этом клипе будет один лишь прямоугольник цвета #00ccff (по-моему, этот цвет наиболее похож на цвет летнего неба), расположенный так, чтобы верхний левый его угол был в центре рабочей области. Тащи этот клип в "C - Sky" на третий слой, задавай ему размеры X=1024; Y=768, координаты X=0; Y=0 (панель "Info") и имя "blue". Сам "C - Sky" выноси на основную сцену в специально для него приготовленный самый нижний пятый слой. Ставь координаты X=0; Y=0 и имя "sky".

Далее делаем символ графики "G - OneStar" для одной звезды. В нем рисуй ровно по центру белую звездочку размерами приблизительно 10 на 10 пикселей. В другой символ графики "G - SomeStars" перенеси таких одиночных звезд штук семь-восемь. Разнеси их там так, чтобы они были разбросаны хаотично на площади, приблизительно равной размерам экрана. Красиво выглядит небо, когда звезды на нем разного размера. Только не увлекайся с этим - звезда размером с луну выглядит отвратительно, поверь мне. Создай новый мувик "C - NightStars". Сделай в нем три слоя. На самый верхний пихай штук десять экземпляров символа "G - SomeStars", на два других слоя - по одному - по два. Ты, наверное, спросишь меня, зачем весь этот... почему бы не сделать в одном символе все звезды? А я, наверное, отвечу, что это все для того, чтобы звезды были не просто так, а мерцающие. Ну и еще для кое-чего. Растяни кадры на всех трех слоях где-нибудь на минуты две воспроизведения (при двенадцати кадрах в секунду пусть наш мувик займет 150 кадров). На втором слое жми правой кнопкой мыши на двадцатый кадр и выбирай вставку ключевого кадра. То же производи с двадцать первым. В двадцатом для символов "G - SomeStars" поставь прозрачность 95% (панель Effect). Те же операции произведи в отношении шестидесятого и шестьдесят первого кадров на третьем слое.


Спецвыпуск Xakep, номер #026, стр. 026-086-2, ][-desktop - взгляд в небо

][-desktop - взгляд в небо

ilich (ilich@winfo.org)

Спецвыпуск Xakep, номер #026, стр. 026-086-2

Выноси "C - NightStars" в "C - Sky" на самый нижний слой. Поставь его так (и/или измени расположение звезд в нем самом), чтобы звезды равномерно распределялись под "C - BlueSky".

Какая же ночь без луны? Правильно, никакая. Твори символ графики "G - Moon", в котором рисуй знакомый тебе полумесяц. Тащи его в "C - Sky", туда же, куда засунул и звезды, и располагай там в каком-нибудь из углов - так покрасивее будет. Сделали мы эту луну неподвижной и стабильной в плане формы. А ведь в жизни это не совсем так. Прочитав сей манускрипт, изучив поподробней методы флешевского объекта Date() и разузнав фазы луны, ты будешь готов к самостоятельному исправлению этого.

РАЗБОР ПОЛЕТОВ

По количеству распознаваемых в случайно взятом облаке знакомых фигур и предметов можно судить об интеллекте человека. Если такой анализ произвести на примере того облака, которое мы с тобой нарисуем, то выяснится, что нашим с тобой мозгам уже ничто не поможет. Сейчас ты поймешь, о чем я. Создай графический символ "G - Cloud".

В этом символе изобрази горизонтально овал размерами где-то 250 на 100. Только овал не простой. Во-первых, удали у него контур. Во-вторых, у него должна быть очень хитрая заливка :). Вспомни, что такое Radial Gradient, и сделай это для нашего овала с серым цветом (что-то типа #999999) в центре и белым по краям. Вспомни также, что такое модификатор Gradient Transformation инструмента Paint Bucket. При помощи этого модификатора сожми заливку до овальной формы и чуть перемести ее вниз и вбок. Если с воображением у тебя все здорово и в глюкогенах ты не нуждаешься, то у тебя создастся впечатление, что перед тобой белый "объемный" овал, освещенный сверху. Теперь, в-третьих, выдели то, что у тебя получилось, и сотвори с этим "Soften Fill Edges" шириной пикселей на двадцать из меню "Modify/ Shape/". Далее следи за моими руками очень внимательно и медленно и осторожно делай то же самое :). В новом клипе "C - Clouds" я, перетащив туда штук десять "G - Cloud" и изменяя их форму и угол наклона, сотворил бесформенное нечто, отдаленно напоминающее еще более бесформенное нечто. Короче говоря, очень похоже на кучевое облако длиной около 460 пикселей. Центр рабочей области должен быть в середине верхней границы рисунка.


Спецвыпуск Xakep, номер #026, стр. 026-086-3, ][-desktop - взгляд в небо

][-desktop - взгляд в небо

ilich (ilich@winfo.org)

Спецвыпуск Xakep, номер #026, стр. 026-086-3

Облако, состоящее из простых одинаковых объектов (один и тот же символ), запомни, жрет намного меньше места. Особенно хорошо запомнить это следует тем, кто публикует Flash - странички в Интернете. Попробуй, например, сравнить размеры fla-шки и swf-ки, которые у тебя сейчас, с теми размерами, которые будут, если все эти овальчики в облаке разбить (выдели их все, нажми Ctrl+B, кликни мышкой в рабочую область рядом с облаком - если не повиснешь, удаляй "G - Cloud" и жми Ctrl+Enter, только сохранись перед этим - это ведь как раз то, чего делать, по-моему, не стоит), и сделать облако одним большим рисунком. У меня разница в размерах swf-ки (то, что публикуется в Инете) составила 13 kb! А это от двух и больше лишних секунд загрузки (гхм... это же надо так ценить время - прим. ред.). Когда во флешке вместо одной большой однообразной картинки используется комбинация из символов ее одинаковых частей, размер фактически экономится за счет производительности машины. Хотя могу заметить, что существенных различий в скорости проигрывания флешки с символами и флешки с большой графикой я не заметил. Все дело в весе. К тому же, в случае с облаком, по-моему, составлять его из мелких овалов было гораздо проще, чем рисовать один относительно сложный рисунок (кстати, это правило относится ко всем графическим изображениям в флешке. Например, символ одиночной звезды, сделанный для последующего многократного использования, я сотворил по привычке :).

Отвлеклись мы немного. Вернемся к облаку. Тащи "C - Clouds" в "C - Sky" на самый верхний слой. Задай ему там такие координаты и размеры, чтобы оно скрылось за границей голубого неба и центр символа облака имел горизонтальную координату -310 (замечу, что координаты в панели "Info" - это координаты верхнего левого угла символа, независимо от того, где у этого символа находится центр; у меня на панели "Info" приблизительно так: X=-540; Y=100).

Дави на облаке правой кнопкой мыши и выбирай там "Actions" (Операции). Вводи там:

onClipEvent (enterFrame) {

if (_x<=-300) {

_y=Int(Math.random()*10)*30;

speed=Int(Math.random()*10);

} else if (_x>=1400) {

_y=Int(Math.random()*10)*30;

speed=-Int(Math.random()*10);

};

_x+=speed;

}

Этот скрипт делает следующее. Функция Math.random() возвращает случайное значение от нуля до единицы. Функция Int() преобразует число в скобках, оставляя от него лишь целую часть. С каждым новым кадром проверяется горизонтальная координата центра облака. Если она меньше трехсот (т.е. облако при таких размерах полностью ушло за пределы экрана влево) или больше тысячи четырехсот (облако ушло за экран вправо), устанавливается новая вертикальная координата: значения при этом могут быть 30, 60, 90 и так далее до 270. Таким же образом вычисляется скорость движения облака, которая при этом получается от единицы до девяти (с плюсом или с минусом). После этой проверки горизонтальная координата облака увеличивается на значение скорости. В случае, когда облако ушло влево, скорость становится положительной, т.е. горизонтальная координата увеличивается (облако начинает плыть вправо), когда облако ушло за экран вправо - уменьшается (облако начинает плыть влево).


Спецвыпуск Xakep, номер #026, стр. 026-086-4, ][-desktop - взгляд в небо

][-desktop - взгляд в небо

ilich (ilich@winfo.org)

Спецвыпуск Xakep, номер #026, стр. 026-086-4

ПУСТЬ ВСЕГДА БУДЕТ СОЛНЦЕ!

Как раз именно солнце в нашей флешке будет отнюдь не всегда, а лишь только днем. Создай новый символ клипа "C - Sun" для светила. Ровно в центре рисуй желтый круг, не превосходящий по размерам твою луну (если бы она была полной) - солнечный диск. Правда, солнце не совсем желтое, оно, скорее, белое - #ffffbb. На другом слое изобрази расходящиеся от солнца лучи. Нарисуй их широкими и редкими, знаешь, как в мультиках рисовали коммунисты годов семидесятых. Мудрые дядьки были. Знали, как лучи надо правильно изобразить. Прикольно выглядит также, когда эти самые лучи крутятся вокруг солнца. Помнишь, как в прошлый раз делали вращающуюся звезду на Кремль. Сделай с лучами то же самое. Только надо, чтобы они крутились не так быстро. Пусть на каждые девяносто градусов уходит кадров по двадцать. И зацикли это движение точно так же, как там.

Тащи теперь символ солнца на второй слой в "C - Sky", задавай ему имя "sun".

Располагай его так, чтобы центр его... а хотя какая разница, все в скриптах сделаем. По размерам мое светило получилось вместе с лучами где-то 150 на 150 пикселей. Скрипт для солнца и неба приведу тебе для моих размеров. Открой клип Кремля и залезь в панель "Actions" для символа часов (то бишь курантов).

И сделай там вот что...

Засунь в скрипт, который там есть, кое-что, кое-что там перенеси кое-куда, потом скопируй это и перенеси еще кое-куда, чтобы в итоге получилось следующее (новое находится между комментариями; старое всего лишь немного видоизменилось):

onClipEvent (enterFrame) {

time = new Date();

hours = time.getHours();

minutes = time.getMinutes();

seconds = time.getSeconds();

// НОВОЕ НАЧАЛОСЬ

// ДЛЯ НЕБА

if ((hours>=5)and((hours<10)or((hours==10)and(minutes<=0)))) {

ad=((hours-5)*60+minutes+1)/3;

_root.sky.blue._alpha=ad;

} else if ((hours>=17)and((hours<22)or((hours==22)and(minutes<=0)))) {

ad=((hours-17)*60+minutes+1)/3;

_root.sky.blue._alpha=100-ad;

} else if ((hours>=22)or(hours<5)) {

_root.sky.blue._alpha=0;

} else if ((hours>=10)and((hours<17)or((hours==17)and(minutes<=0)))) {

_root.sky.blue._alpha=100;

};

// ДЛЯ СОЛНЦА

if ((hours<=5)or(hours>=22)) {

_root.sky.sun._alpha=0;

_root.sky.sun._x=2;

_root.sky.sun._y=660;

} else if ((hours>=5)and((hours<22)or((hours==22)and(minutes<=0)))){

col=(hours-5)*60+minutes;

_root.sky.sun._x=2+col;

if ((hours<13)or((hours==13)and(minutes<=30))) {

_root.sky.sun._y=660-col;

} else if ((hours>14)or((hours==13)and(minutes>30))) {

_root.sky.sun._y=col-360;


Спецвыпуск Xakep, номер #026, стр. 026-086-5, ][-desktop - взгляд в небо

][-desktop - взгляд в небо

ilich (ilich@winfo.org)

Спецвыпуск Xakep, номер #026, стр. 026-086-5

};

};

// НОВОЕ ЗАКОНЧИЛОСЬ

ars._rotation = seconds*6;

arm._rotation = minutes*6;

arh._rotation = hours*30+minutes*0.5+180;

if ((minutes == 0) and (seconds == 0)and(_root._currentframe>=18)) {

if (hours>=12) {

hours -= 12;

};

ding.start(0, hours);

}

}

onClipEvent (load) {

ding = new Sound(this);

ding.attachSound("bum.wav");

}

Объясняю вначале для неба. В скрипте для тебя не должно быть ничего сложного и нового. Сутки делятся мною на четыре части: день (с десяти утра до пяти вечера), вечер (с пяти до десяти вечера), ночь (от десяти вечера до пяти утра) и, собственно, утро (с пяти до десяти утра). Теперь обо всем по порядку. Днем небо голубое :). Достигается это тем, что прямоугольник "blue" полностью непрозрачен (_alpha=100). Начинается вечер. Клип "C - BlueSky" теряет свою непрозрачность на процент каждые три минуты (отсчет процентов ведется в переменной "ad") и к десяти часам (т.е. к ночи) становится полностью прозрачным. Теперь за ним отчетливо видны месяц со звездами (хотя, на самом деле, они видны еще часов эдак с семи). Всю ночь голубой прямоугольник остается прозрачным. По звездному небу плавно прогуливается одинокая тучка. Красиво. В пять утра начинает светлеть небо, где-то часам к девяти звезды уже неразличимы. Появляется солнышко.

У солнышка алгоритм немного посложнее. Основная фишка тут в том, что днем солнце должно подниматься (до обеда) и опускаться (после обеда). Дабы максимально упростить модель поведения нашего дневного светила, я в качестве траектории его движения выбрал ломаную, состоящую из двух отрезков: по одному из них солнце поднимается, по другому - опускается.

В качестве переломного момента (времени обеда) выбрано время 13 часов 30 минут. Не подумай, что я всегда принимаю пищу строго в этот миг. Просто это середина между началом утра и концом вечера по нашему времяисчислению. Ночью, как известно, на территории нашей Родины солнца не видно. Вот и у нас во флешке ночью солнце будет невидимым (_alpha=0). В переменной "col" вычисляется, сколько минут прошло с начала утра. За неночное время солнце по горизонтали должно пройти расстояние около тысячи пикселей (через весь экран), в моем примере это тысяча двадцать - ровно столько минут между началом рассвета и концом захода. Поэтому-то горизонтальная координата солнца практически равна "col". Вертикально солнце движется по-другому. Вначале мы ставим его на высоту 660. При этом если Кремль открыт, т.е. флешка работает на полную, из-за него выглядывают лишь отдельные лучики, если же он закрыт, то солнце находится в нижней части экрана, что, в принципе, тоже приемлемо для момента его появления/исчезания. Формулы исчисления вертикальной координаты до и после обеда отличаются, т.к. до обеда, пока количество прошедших минут еще мало, а вертикальная координата солнца должна уменьшаться, после обеда - значение "col" продолжает расти, а координату уже пора увеличивать.

Когда ты поймешь, что тебе все понятно :), можешь сесть поудобнее, плавно надавить на Ctrl+Enter и начать релаксировать до наступления реального лета.


Спецвыпуск Xakep, номер #026, стр. 026-086-6, ][-desktop - взгляд в небо

][-desktop - взгляд в небо

ilich (ilich@winfo.org)

Спецвыпуск Xakep, номер #026, стр. 026-086-6

И да пребудет с тобой великий Flash!


Спецвыпуск Xakep, номер #026, стр. 026-090-1, МЯГКИЕ МЕСТА ИНЕТА - где достается софт

МЯГКИЕ МЕСТА ИНЕТА - где достается софт

Kirion (kirion@winfo.org)

Спецвыпуск Xakep, номер #026, стр. 026-090-1

Знаешь, как начинается мое обычное утро? Умывшись, надев халат и налив себе кофе, я сижу за компом и разбираю почту. Знаешь, как порой достает внимательно читать 10-15 рассылок про софт в день? Мало того, что инфа часто повторяется, вылавливать стоящие проги приходится, исключительно руководствуясь собственной интуицией. А потом быстрая пробежка по еще десятку софтовых сайтов, проверка состояния счета и нервное поглядывание на красный крестик в календаре с подписью "день зарплаты" :). А потом залезть на сайт автора проги, найти кряк, почитать хелпу (на собственном опыте могу сказать: "мануал читают только ламеры" - так только ламеры и говорят :)). Да, еще надо проверить, под какими виндами прога работает, а под какими - нет. Ну и в конце проверить, а нет ли у тебя ее предыдущей версии и, если есть, то что изменилось. Веселая работа, правда :). Зато моральное удовлетворение от хорошей и прежде неизвестной проги стоит много, даже больше, чем оплата статьи :).

ГДЕ-ТО Я ЕЕ ВИДЕЛ...

Надеюсь, что твои потребности в софтовых сайтах не такие, как мои, иначе можно и свихнуться. Чаще бывает, что ты читал о какой-нибудь программке, но в упор не помнишь, где. Или меняется адрес разработчика. Или просто лень искать в Яндексе :). А иногда ты ищешь варез на китайских серваках, которые живут два-три дня. Вот с варезом тебе помочь не могу - мне проще и дешевле сходить на Горбушку, чем оплачивать многомегабайтный трафик :). Меня интересует бесплатный и условно-бесплатный софт, ну и кряки, разумеется :). Если же тебе потребен самый свежий софт - подписывайся, как и я, на рассылки. Самостоятельных рассылок почти нет - все они привязаны к сайтам, так что рассказывать я буду о них одновременно. И еще - не верь рейтингам программ. Лучше почитай отзывы пользователей или проверь сам. Хотя есть некоторые сайты, дающие достаточно объективные отзывы. И один из них...

ЧТО В ИМЕНИ ТЕБЕ МОЕМ

И один из них www.nnm.ru. Проект NoName - один из моих самых любимых сайтов вообще. Если ты там еще не был, ты очень много потерял. Не смотри на не очень красивый дизайн - контент сайта просто первоклассный. "NoName обновляется каждый день, по крайней мере, так задумано", - copyright by d()c666, главный автор сайта. Судите сами, каждый день в новостях появляются известные и не очень проги с отличными комментариями Дока. Причем многие из них с включенными в комплект лекарствами или ссылками на лекарства :). Часто бывают ссылки на варез и варезные ftp. Каждый день пара приколов, в их числе и фраза дня. Вообще, главная страница NoName (aka news) это сборная солянка: здесь бывают и ссылки на заинтересовавшие Дока сайты, на приколы на флэше, на железные сайты. В принципе, более подробно все темы раскрываются в других разделах сайта, но обновляются они не так часто. Filez, как не трудно догадаться, целиком посвящен софту. Mobilz посвящен мобильникам и сотовой связи, design - веб- и не только дизайну. Ironz, Gamez, Moviez, Muzic - комментарии нужны? Кстати, в Muzic можно найти довольно редкие вещи, а еще FAQ по поиску музыки в Инете - must have для людей, которые не очень знакомы с Интернетом. Ну а людям, которые каждый день ищут новые и интересные сайты, прямая дорога в Webz. По стилю - типичный блог, но ссылки порой уникальны, да и обновляется раздел часто. Да, еще у NoName неплохой форум, задавай вопросы, не стесняйся. Есть только один минус во всем проекте - совершенно невменяемая система поиска. Информации на сайте очень много, и порой приходится перебирать архив за полмесяца, прежде чем найдешь нужное :(. На встроенную систему поиска надежды нет. Во-первых, она ищет не по всем разделам, да и находит далеко не все. А во-вторых, найденное сортируется непонятно как, пока найдешь самую свежую ссылку... Да, чуть не забыл, у NoName есть своя рассылка. Выходит раз в неделю и содержит в себе самые интересные программы и сайты за неделю. Мало, черт возьми! Такие рассылки должны выходить чаще :). Ибо NoName стоит того, чтобы на него заходили каждый день.


Спецвыпуск Xakep, номер #026, стр. 026-090-2, МЯГКИЕ МЕСТА ИНЕТА - где достается софт

МЯГКИЕ МЕСТА ИНЕТА - где достается софт

Kirion (kirion@winfo.org)

Спецвыпуск Xakep, номер #026, стр. 026-090-2

А если ты считаешь себя новичком в мире софта, то тебе неплохо бы зайти на www.softkey.info. Достаточно молодой сетевой журнал о программном обеспечении, редактором которого является небезызвестный Алекс Экслер (www.exler.ru, лучший homepage рунета). Достаточно неплохой подбор новостей и статей. Прочитав статьи, профи, наверное, скажет, что они все для чайников (признаюсь честно, я так тоже считаю :)), но иногда попадаются и любопытные вещи. А знакомые ламеры так вообще в восторге :). Короче, зайди сам, разберешься. Только не забудь заглянуть в каталог программ. Его отличительная особенность - законная направленность :) и постоянные скидки на покупку различных программ. Можешь попробовать, будешь потом детям рассказывать, как первый раз в жизни покупал шаровару :).

И все-таки, как бы ни хорош был NoName, как бы ни прост был Софткей, а многого нужного софта там не найдешь. Есть и более специализированные на софте сайты.

Например, www.frol.ru. Каждый день десятки новых программ. Все программы рассортированы по категориям, так что найти нужную достаточно легко. Кроме программ, на сайте часто лежат ссылки на свежие драйвера известных производителей (кстати, сам я свежие драйвера обычно качаю с fernando.darocha.free.fr; правда, он на французском :)). А еще часто появляются русификации к известным прогам. Под них даже выделен отдельный раздел. Советую заглянуть на форум - там часто появляются ссылки на достаточно редкие лекарства к прогам (которые нельзя найти даже на асте). Жаль, нет рассылки у сайта. Но я сюда и так захожу каждый день. А все потому, что проги на сайте почти все стоящие. "Воды" и чисто любительских прог среди них ты не найдешь. С одной стороны, это хорошо, но некоторые хорошие или специфические проги остаются за бортом. Но на то есть и другие сайты...

Например, старичок download.ru. Приготовься, на этом, как и на нижеописанных сайтах, придется долго искать нужные программы. И не из-за плохого поиска, просто программ тут много, а вот хороших среди них - не очень. Download.ru пишет в основном о любительском софте и софте русских программеров. И, к сожалению, далеко не все проги стоят того, чтобы о них упоминали где-нибудь, кроме домашней странички автора. Но и в мутной воде водятся золотые рыбки, ибо не раз я находил достаточно интересные и самобытные проги в рассылке Download.ru. Выходит она раз в неделю и содержит в себе все обновления за неделю (логично, да :)). Немножко скучное чтение получается - в неделю добавляется где-то полторы сотни программ. На несколько разделов сайта стоит обратить особое внимание. Во-первых, это игры. Если ты любишь различные покеры-саперы и прочее - ты не вылезешь отсюда долго. Просто рай для секретарши :). Во-вторых, это программирование. Не так много сайтов, где выкладываются компоненты для объектных языков и подручные средства для отладки, тестирования программ, составления дистрибутива. В-третьих, это раздел бухгалтерия и делопроизводство. Я во всем этом не рублю (хотя бухучет в универе вроде был :)), но на других сайтах я подобного не видел. Так что, если тебе надо выписать какую-нибудь платежку или акт, причем обязательно на компе, - ищи, каждую неделю здесь появляется два десятка бухгалтерских программ. Ну и в-четвертых, это раздел "образование, наука и техника". Здесь можно найти вообще уникальные вещи вроде географических атласов или математических программ. Что еще добавить? Загляни в раздел электронных журналов. Ты, наверное, и не знал, что в рунете существует с десяток очень приличных журналов, которые не просто печатаются в Инете, их надо скачивать отдельно и устанавливать. Выходят они, как правило, раз в неделю. Скачай как-нибудь, в них есть что почитать. Тем более бесплатно...


Спецвыпуск Xakep, номер #026, стр. 026-090-3, МЯГКИЕ МЕСТА ИНЕТА - где достается софт

МЯГКИЕ МЕСТА ИНЕТА - где достается софт

Kirion (kirion@winfo.org)

Спецвыпуск Xakep, номер #026, стр. 026-090-3

SUPERPUPERMEGASOFT.RU

Интересно следить за полетом человеческой мысли. Как он выбирает имена для своего сайта. Неужели нельзя придумать имя для сайта о программах лучше, чем "чего-нибудь там"+soft? Нет, я, конечно, не против, но имена новых сайтов становится сложно запоминать. А еще сложнее запомнить, где именно ты нашел в прошлый раз то, что тебе нужно.

Хорошо еще, если это старый добрый Listsoft.ru. Проект Дмитрия Турецкого - известной личности рунета. Когда-то один из лучших каталогов русскоязычного Интернета, теперь он просто один из многих. С одной стороны, обновления каждый день, большое количество программ. С другой - популярные программы появляются здесь с опозданием. Очень сложно узнать, насколько хороша та или иная прога. Причем на главной странице, как и в рассылке, пишется описание самого автора проги. Сам понимаешь, оно далеко от объективности. Да и система рейтингов подводит. Так, отметка cool практически ничего не стоит. Без нее оказывается только откровенное дерьмо. Очень много любительских, никуда не годных программ, но это, похоже, беда почти всех серверов бесплатного софта. Сейчас ты спросишь меня, а зачем вообще заходить на этот сайт. А я не знаю :). Если ты не такой маньяк, как я, вечно находящийся в поисках новых программ, то делать здесь, пожалуй, нечего. Хотя нет, пожалуй стоит все-таки заглянуть в раздел best of the best. Вот здесь находится действительно хороший софт, как правило, получивший Listsoft's choice. Но найти ты его можешь и в другом месте, хотя... я пока оставлю себе подписку на "Лист SOFT. Новые программы для Windows NT/2K/XP" :).


Спецвыпуск Xakep, номер #026, стр. 026-090-4, МЯГКИЕ МЕСТА ИНЕТА - где достается софт

МЯГКИЕ МЕСТА ИНЕТА - где достается софт

Kirion (kirion@winfo.org)

Спецвыпуск Xakep, номер #026, стр. 026-090-4

А ты топай дальше, на www.softodrom.ru. Скромные авторы считают, что "сайт посвящен исключительно тем программам, о которых можно сказать, что они - одни из лучших в своей категории". Ну а "программа дня" на Softodrom.ru так вообще должна стоять у каждого пользователя. Если бы это еще было правдой :). На деле среди победителей дня не так много хороших программ. Даже наоборот, лучшая прога дня часто остается незамеченной. Хотя к разделу "лучшие из лучших" (он есть и здесь) придираться сложно: здесь лежат действительно хорошие программы. А рейтинги... если не уверен в программе - посмотри отзывы пользователей и обязательно оставь свой, так надежнее. Хотя, может, ситуация и изменится к лучшему - сайт достаточно молод и быстро развивается. Не удивлюсь, если он скоро станет лучшим в рунете. Наверное, все дело в наполнении программами. Создатели научились соблюдать баланс между известными и неизвестными прогами, между бесплатными, условно-бесплатными и коммерческими программами. На сайте есть проги и на русском, и на английском языках. Здесь есть даже софт для юниха! Вполне юзабельный форум дополнился чатом (софтовый чат, гм... по мне так тот еще изврат :)). Ну и рассылки... их здесь 13. Неплохо, да? Пять общих рассылок: ежедневная, еженедельная, только бесплатный софт, только русский софт, только новый софт. Шесть тематических рассылок: "система", "Интернет и сети", "мультимедиа и графика", "образование и бизнес", "игры, развлечения, заставки", "UNIX-софт". Ну и две самые ценных рассылки - дискуссионные, то есть конференции. "Softodrom.List" посвящена программам для виндов и самим виндам, но в пределах закона :). Попросить ключ для активации WinXP ты там не сможешь :). Зато во второй творится полное беззаконие - "CrackTalk посвящена обсуждению тем, запрещенных на Softodrom.List". Еще один источник кряков, надо же дать иногда отдохнуть асте :). Ладно, что дальше-то у нас?

А дальше www.newestsoft.com. - не просто новый, а новейший софт. Не иначе, как www.newsoft.com уже занят :). Яркий пример сайта "хочу быть как взрослые ребята". Подбор программ неплох, но и не очень оперативен, причем ничего оригинального ты здесь не найдешь. Железный раздел, игры, приколы, статьи... только вот обилием содержания они не отличаются. Есть и рассылка, есть и форум, но... Я, конечно, понимаю, что сайт молодой. Я понимаю, что им занимаются непрофессионалы. Но зачем же было замахиваться на такой проект? И почему-то я сомневаюсь, что со временем что-то сильно улучшится. Будем надеяться, что я ошибаюсь.

Ведь ошибся же с www.freesoft.ru. Если ты в сети давно, должен знать такой сайтик www.freesoft.kulichki.net. Собственно, это он и есть, только на новом хостинге. Четыре года - срок большой, но сайт сохранился до наших дней в лучшем виде, чем Listsoft.ru :). Кстати, название немного лукавит: коммерческих прог здесь действительно нет, а вот шароварок предостаточно. Тяжелые времена, не иначе :). Хотя содержание не подводит. Сайт имеет свое лицо и, что важнее, уникальные ссылки на проги. Здесь есть даже фидошный софт (всем крутить фонарики полчаса)! В каждой еженедельной рассылке (а они здесь разделены на общую и тематические) я нахожу несколько прог на тестирование. Тем более, что их можно прямо с сайта заказать на почту. Единственное, что мне не нравится, это сортировка программ по разделам. Уж слишком мельчат, 26 разделов это перебор. Хотя когда в базе 3500 программ...


Спецвыпуск Xakep, номер #026, стр. 026-090-5, МЯГКИЕ МЕСТА ИНЕТА - где достается софт

МЯГКИЕ МЕСТА ИНЕТА - где достается софт

Kirion (kirion@winfo.org)

Спецвыпуск Xakep, номер #026, стр. 026-090-5

VOX POPULI

Еще один важный источник информации - форумы. Бывает так, что ты не можешь найти нужную прогу. Или даже не знаешь, как она называется. Или не уверен, что такая вообще существует :). Форумы есть почти на всех софтовых сайтах, не стесняйся, спрашивай - тебе помогут. Только сначала поинтересуйся правилами форума, а то можно и бан схлопотать. Да, и старайся соблюдать культуру общения: пиши грамотно, не груби. Не пиши транслитом: во многих форумах это запрещено. Тем более, что на хороших есть скрипты, преобразующие транслит в нормальный текст, нужно лишь писать по правилам и нажать в конце на кнопку перевода. Только если ты можешь сразу писать по-русски - зачем мучиться? Вообще, я считаю, что общение на форумах интереснее чатов (которые я ненавижу :)). К ним сильно привыкаешь.

Особенно, если он такой, как www.soft-forum.ru. Наверное, это лучший форум по прогам, осям да и еще многому чему. Когда я сюда первый раз залез - часа полтора читал обсуждения по поводу настройки WinXP, все сомневался: ставить или нет. А потом... все винды, технология .net, популярные дистрибутивы линуха, безопасность, кряки и варез. Возможный единственный минус - чайникам будет сложновато разбираться, но специально для них есть раздел "зона ламера" на форуме www.oszone.net. Сам сайт не представляет собой ничего особенного, зато форум очень приличный. Обилие нужных и интересных тем, а главное - 7 рассылок "вопросы и ответы по...". А вопросы такие: по всем виндам, по 9х, по NT/2k, по XP, по Linux. И еще вопросы и ответы по софту и железу. Все просто - задаешь вопрос, на него отвечают другие посетители форума и подписчики рассылки. Я привык читать ее как большой анекдот, иногда такие ответы попадаются... Хотя один или два нормальных ответа на вопрос все же пишут, редко бывает так, чтобы на вопрос отвечали одни придурки.

Ну а совсем недавно наткнулся на wwc.ru. На момент написания статьи форуму было всего несколько дней, так что пока не очень ясно, что из него получится. Но задел явно хороший. Основная направленность сейчас - вопросы компьютерной и информационной безопасности. Пока что обновляются в основном разделы генерального форума (на самом деле, это хитро замаскированные новости и статьи. Статьи ты можешь опубликовать здесь и сам). Ну, будут посетители - будут и обновления.

...НАВЕРНОЕ, ВО СНЕ

Вот, все мои скромные букмарки в твоем распоряжении. Практически весь софт для нашей рубрики я достаю на сайтах, перечисленных выше. Безусловно, есть и другие, но мне этого хватает. И без новых сайтов достаточно дублирования информации. В крайнем случае - весь Яндекс в твоем распоряжении :). Ну а самые ленивые могут писать мне. Только не проси меня ничего высылать. Я жадный, мне за трафик платить :).


Спецвыпуск Xakep, номер #026, стр. 026-094-1, UPDATE - новые заплатки от Microsoft

UPDATE - новые заплатки от Microsoft

Алексей Б.Б.(alexys@winfo.org)

Спецвыпуск Xakep, номер #026, стр. 026-094-1

Ожидалось, что после выпуска таких глобальных обновлений, как 3-ий сервиспак для Win2K и 1-ый SP для Windows XP, ребята из Майкрософта возьмут долгий отпуск. Возможно, так и было, но работа по доведению до ума товаров от M$ все же продолжается. Понятное дело, новые заплатки небольшие, но некоторые все же важны.

ОБНОВЛЕНИЕ Q323255

Касается всех любителей полазить по сайтам (особенно зарубежным) с крэками и порнушкой. Везде используемый в виндах язык разметки страниц HTML поддерживает компоненты управления Active X, а он, в свою очередь, дает много возможностей для влезания в комп без спроса. Причем троянов тут нет, так что антивирусники будут молчать. С помощью компонентов Active X можно вызвать переполнение буфера, и в этот момент винды могут стать очень уж беззащитными. Попасть на такие страницы можно при поиске крэков или серфинга по порнушным сайтам, а можешь просто дождаться получения HTML-письма, которое ты откроешь аутлуком :). Среди создателей таких сайтов и любителей спама полно любителей поживиться чужими паролями. Пусть даже у тебя нет кредиток, а на последние деньги ты купил журнал, который сейчас читаешь, но ты же не собираешься вешать на свой комп табличку с надписью "Welcome"? Вот и я так думаю, что не собираешься. В таком случае пора обезопасить свою (да и не только свою) систему, дабы не лазили всякие. Ведь не перестанешь же ты искать крэки к свежим прогам :).

Файлами справки в виндах (те, что с расширением .chm) являются откомпиленные HTML-файлы. В таком виде страницы архивируются и занимают меньше места. Они так же, как и обычные HTML-страницы, поддерживают Active X. И точно так же при их просмотре может быть вызвано переполнение буфера со всеми вытекающими. Если ты не качал никаких файлов справки, то можешь расслабиться и отправиться тусить, но если качал таковые, то давно пора предохраниться от возможных неприятностей. Хотфикс, закрывающий возможность переполнения буфера и стороннее вмешательство в систему, выпущен мелкомягкими для всех версий виндов. Можно скачать его, используя Windows Update, но потребуется много времени. Поэтому лучше залезть на страницу, исходя из версии твоих виндов, и скачать его оттуда. Вынужден обломать юзателей Win Me - им придется пользоваться только Windows Update'ом для добывания заплатки.

Windows 98 and Windows 98 SE: http://www.microsoft.com/windows98/downloads/contents/WUCritical/q323255/default.asp

Windows NT 4.0: http://www.microsoft.com/Downloads/Release.asp?ReleaseID=43308

Windows NT 4.0, Terminal Server Edition: http://www.microsoft.com/Downloads/Release.asp?ReleaseID=43308

Windows 2000: http://www.microsoft.com/Downloads/Release.asp?ReleaseID=40213

Windows XP: http://www.microsoft.com/Downloads/Release.asp?ReleaseID=41834

Владельцы XP смогут заинсталлить это обновление только при установленном сервиспаке (подробнее в 11-ом номере журнала). Такой вот некрасивый жест микрософта владельцам пиратских версий Win XP, которым не судьба поставить SP. На двухтысячные нужно ставить апдейт, даже если уже стоит 3-ий сервиспак. По заявлению мелкомягких, этот хотфикс войдет в 4-ый сервиспак для двухтысячных. Апдейт небольшого размера, но это не умаляет его важности. Скачал, запустил, перегрузился и почувствовал разницу.


Спецвыпуск Xakep, номер #026, стр. 026-094-2, UPDATE - новые заплатки от Microsoft

UPDATE - новые заплатки от Microsoft

Алексей Б.Б.(alexys@winfo.org)

Спецвыпуск Xakep, номер #026, стр. 026-094-2

ОБНОВЛЕНИЕ Q329048

Похоже, что проблема переполнения буфера является основной дыркой в виндах, раскрыть которую можно туевой хучей способов. Один из таких способов возможен при работе со сжатыми папками (ну это когда Zip'овые архивы используешь как обычные папки). Данная фича наличествует в ХР, 98-ых с Plus! Pack'ом и МЕлке. В WinMe и Win98 по дефолту нет возможности работы с архивами как с папками, но в целях одновременной экономии места и времени ее ставят. Буфер перестает контролироваться, если прога, будучи заархивированной, после запуска начинает экстрактиться из zip-файла. Например, зазиповал ты дистрибутив какой-нибудь программы (обновления Q329048 :)), залез в получившийся архив как в сжатую папку и запустил его. В этот момент, если ты подключен к Инету, с твоим компом могут произойти некоторые странности. Это обновление особенно полезно для любителей открывать приаттаченные файлы в письмах с пустым содержанием от непонятно кого. Навряд ли добрый дядя хакер пришлет тебе что-нибудь кроме свеженаписанного им вируса :). Также апдейт пригодится сисадминам в таких конторах, где сотрудники часто используют Инет для знакомства с девушками в чатах. Не всегда такая девушка оказывается вообще женского пола :). А от таких "мужественных" девушек можно запросто ожидать какой-нибудь бяки вместо фоток. Правда, если бы все были такими умными и знали бы про такие проделки, то хакерам было бы тяжелее жить, да и мелкомягким бы работы поубавилось. А так они вроде чем-то заняты.

За патчем обращаться по адресу:

Для Windows 98 с Plus! Pack'ом:

http://www.microsoft.com/windows98/downloads/contents/WUCritical/q329048/default.asp

Для Windows XP:

http://www.microsoft.com/Downloads/Release.asp?ReleaseID=43419

Владельцам Windows Me придется пользоваться услугами Windows Update.

ОБНОВЛЕНИЕ Q328676

Есть такой почтовый клиент Outlook Express (не путай с MS Outlook!), которым пользуется много пиплов, которым лень искать себе для этих целей что-нибудь другое. Если честно, то настолько дырявой почтовой проги, как непропатченный аутлук, надо еще постараться найти. Когда в Microsoft'е народ узнал, что можно сделать с аутлуком, то наверняка пришел в ужас. Иначе не объяснить кучу исправлений работы OE в целях повышения его стабильности и защищенности.

Outlook Express'ом поддерживается такая фишка, как цифровая подпись сообщений через S/MIME (Secure/Multipurpose Internet Mail Extensions), которая разрешает безопасно посылать и получать данные по почте. S/MIME использует следующие методы для повышения безопасности e-mail'ов: аутентификация, сохранение целостности письма при помощи цифровой подписи, шифровка данных. S/MIME очень прикольная штука, если не хочется, чтобы письмо, которое ты по пьяни послал не тому, кому хотел, не смог прочитать тот случайный чел. Когда OE получает письмо, подписанное S/MIME, то начинается проверка. Если все с письмом и подписью нормально, то все хорошо, а если все же нет, то OE генерит сообщение, что хрен 2 ты прочитаешь письмо - здесь ошибка. Вот здесь и появляется возможность переполнения буфера. Причем для этого не обязательно открывать письмо - достаточно будет просто сделать превью (предпросмотр). В этот момент тебе подобный, только по другую сторону монитора, запустит нужный ему код на твоей машине. Тебе не обязательно юзать электронные подписи - тебе достаточно получить такое письмо! Так что лезь на http://www.microsoft.com/windows/ie/downloads/critical/q328676/default.asp и качай оттуда заплатку на Outlook Express (а лучше сразу лезть на www.ritlabs.com и затариться TheBat'ом - прим. ред.).


Спецвыпуск Xakep, номер #026, стр. 026-094-3, UPDATE - новые заплатки от Microsoft

UPDATE - новые заплатки от Microsoft

Алексей Б.Б.(alexys@winfo.org)

Спецвыпуск Xakep, номер #026, стр. 026-094-3

2-ОЙ СЕРВИСПАК ДЛЯ ХРЮШНОГО ОФИСА

Как типичный сервиспак, SP2 для ХРюшного офиса - это куча маленьких и побольше заплаток, в данном случае на MS Office XP. Как всегда, он должен повышать безопасность и качество работы офисных составляющих. Наиболее важным из всего набора я бы выделил устранение возможности запуска скриптов при нажатии кнопки реплай или форвард для тех, кто пользует Outlook в качестве почтовой проги и Word как прогу для написания и редактирования писем. Это не касается тех, кто читает html-письма как обычный текст (Plain Text), а касается только любителей читать и пересылать красиво оформленные письма. С помощью этой дырки можно запустить скрипты из html-содержимого письма. После нажатия реплая или форварда скрипт из такого письма получает почти неограниченный доступ к ресурсам компа, на котором это письмо оказалось. Думайте, мальчики и девочки, хотите ли вы еще оставлять такую дырку для окружающих или пора ее закрыть? Причем можно не тащить целый сервиспак, который немного тяжеловат для диалапщиков, а просто скачать данную заплатку. У кого стоит Microsoft Word 2002 (из офиса ХР), то за патчем налево: http://office.microsoft.com/downloads/2002/wrd1003.aspx, у кого Microsoft Word 2000 (офис 2000) - направо: http://office.microsoft.com/downloads/2002/wrd0901.aspx

Если все же хочется по максимуму улучшить и обезопасить работу офиса, то скачай SP2 (http://download.microsoft.com/download/officexpstandard/sp/oxpsp2/w98nt42kmexp/en-us/oxpsp2a.exe) и наслаждайся.

Больше всего мелкомягких обновлений направлено на повышение безопасности работы программ. Интересно, кто же находит все эти дырки? И как долго это будет длиться. В свое время Билл Гейтс сказал, что пока продукция M$ не станет самой защищенной, они почти не будут работать над созданием обновлений для повышения производительности и удобства работы. Похоже, он действительно держит свое слово.


Спецвыпуск Xakep, номер #026, стр. 026-096-1, Меня зовут Голливуд (Part 2 - Декорации)

Меня зовут Голливуд (Part 2 - Декорации)

Томилин aka Middlenight

Спецвыпуск Xakep, номер #026, стр. 026-096-1

(middlenight@mail.ru)

Если кто помнит такую передачу "Детский час", на ее заставке были две настольные лампы, большая и маленькая, игравшие с мячиком. Родина этого ролика - США, а родители - семейство CGI (computer generated imagery), разработка которых началась в 1980 году.

Если в первом Юрском парке разработчиков заботил эффект отражения света кожей динозавров, то во второй части "Затерянный мир" они больше работали над эффектом поглощения света броневой шкурой протокрокодилов.

Институт Франхувера (Fraunhofer) не только придумал MP3, но и внес значительный вклад в исследования компьютерной графики. Их главный техменеджер Дэвид Зельцер хорошенько приложил лапу к разработке инверсной кинематики, систем управления виртуальными актерами и многого, многого другого.

Снова здравствуй, дорогой Спилберг. В прошлой серии мы создали персонажа и подготовкой его к анимации. Теперь настало время для гораздо более легкого, но и самого долгого процесса - создания реалистичного окружения. So, let`s kick their asses!

ЗАМУТИМ ЛАБУ

Сразу предупреждаю: чтобы сцена не тормозила, все описанные ниже детали интерьера лучше создавать в отдельных файлах, а затем уже подгружать в основную сцену посредством File -> Merge.

Начнем с создания лаборатории. По нашему сценарию - это помещение, состоящее из двух частей: в одной - находятся доктора с компом, во второй - на электрическом стуле корячится Trofimych. Пол, стены, дверь и вторую половину комнаты сделаем в одном файле, который будет в дальнейшем базовым. "Пыточную" часть лабы будем подгружать потом.

Стены, пол и потолок замутим посредством простых боксов. Двери есть в штатном наборе третьего Макса (я работаю в двух Максах), но при переносе сцены в четвертый Макс она будет бажить, так как в четвертом отсутствует dll-ка дверей. Вот и подучим механизм импорта-экспорта: выделяешь дверь, выбираешь file->export selected и сохраняешь в 3ds-файл (*.3ds) - это универсальный формат (правда, не все проги в него врубаются). Удаляй неправильную дверь и вставляй правильную (file->import). Я взял дверь sliding - отъезжающая, как в поезде (лучше всего подходит для лабы). Врезай ее в стену. В той части лабы, где есть дверь, расставляй по стенам шкафы с ящиками, как в X-files (такую хрень в инете на каждом углу надыбать можно). То же относится и к столу под компьютер, и к самому компу. Правда, комп у тебя без проводов... Провода забацаем методом лофтинга: сначала создай линии, ведущие от клавы и монитора к системному блоку и все необходимые сечения для проводов (обычные круги). Когда все готово, выделяй любой сплайн, Compound objects->loft->Pick shape и получившейся пиктограммкой тыкай в нужное сечение, и провод готов!

МАТ И МАТЕРИАЛЫ

Половина сцены уже готова. Теперь необходимо назначить нашим объектам реалистичные материалы. Зайди на Render.ru - в их галерее много работ, которые, как и наша сцена, сделаны из простых объектов, и тем не менее вызывают одобрительные отклики. Связано это с использованием в сцене правдоподобного материала и грамотным просчетом света. Что нам мешает сделать то же самое?


Спецвыпуск Xakep, номер #026, стр. 026-096-2, Меня зовут Голливуд (Part 2 - Декорации)

Меня зовут Голливуд (Part 2 - Декорации)

Томилин aka Middlenight

Спецвыпуск Xakep, номер #026, стр. 026-096-2

Сначала компьютер. В моем компе несколько частей, которым нужны разные материалы: кожух системника и монитора, винтики, клава и кнопки на ней, провода, и, наконец, экран монитора. Чтобы предметы не мешали селекту, выдели лишнее и нажми 6 - его выделение станет невозможным; чтобы предмет отмерз - нажимай 7. Начнем с консоли: дуй в редактор материалов и первому же материалу задавай тип Reytrace (o, eah!). Ставь флажок на SuperSample (тип сглаживания артефактов) и меняй цвета ambient и diffuse на желаемый цвет компа (мышино-серый или мокрый асфальт) Diffuse, кстати, можно сделать и потемнее - свет же не должен при таких материалах отражаться полностью. Параметр Reflect не трогай - если сделать цвет светлее, чем черный, то наш комп будет прозрачным. Проверить наличие прозрачности можно шахматной доской справа от шаров. Далее настроим блики: по умолчанию юзается алгоритм по Фонгу, так как блики у него наиболее яркие - не будем его менять. Размер блика меняй в Specular level, яркость - в Glossiness, мягкость - в Soften. Еще можно в Raytracer controls->Options поставить галочку напротив глобального антиальясинга. ОК! Назначаем материал кожуху, монитору и клаве. Кнопки на клаве мутим так же, только они будут чуть темнее. Провода - от клавы светлые, от монитора и блока - черные.

Стол пусть будет стеклянно-прозрачным - эдакая кибер-хреновина. Для него понадобятся два материала: первому назначай тип Double-sided и переходи ко второму. Делай из него описанное выше, плюс можешь изменить цвет reflect. Измени по вкусу параметр index of refraction (индекс преломления) - я думаю, 0,6 будет достаточно. Soften ставь на 0,3. Можешь также покопаться в настройках density. Теперь основное изменение - в Maps выбери Transparensy -> falloff (прозрачность-->затухание). Во всплывшем окне щелкни правой крысой на верхней точке графика и выбери тип Bezier-corner. Появившийся третий квадратик отведи где-то на середину графика. Таким образом, получится более-менее реальный ход луча при проходе через линзу. Теперь возвращайся к двустороннему материалу и перетаскивай наш второй замут на оба места под карту. Назначай это дело столу.

ИСТОРИЯ С ЭКРАНОМ

Остался только экран - с ним отдельная история. По сценарию там вертится голова подопытного с разными графиками и цифрами. Открывай новый файл и вставляй туда болванку для головы Трофимыча. Сделай так, чтобы лицо смотрело на тебя с одного из видов проекции, а не только с перспективы. Переходи в этот вид. Шлепай в сотый кадр и, нажав кнопу Animate, поворачивай башку на 356,4 градуса. Почему не на 360? А чтобы удалить повторяющийся кадр, дабы в цикле анимация не тормозила, как испорченный винил, и голова вертелась плавно (356,4=360-360/100). Далее в редакторе материалов делай зеленым любой скин, ставь флажок напротив Wire (сетка) и назначай голове. Не забудь про подложку под чайник: премся в Rendering->Environment и в карте выбираем материал bricks (кирпичи). В типе кладки (preset type) выбираем Stack bond, в текстуре кирпича ставим зеленый цвет и подгоняем размеры в Horizontal и Vertical count, чтобы клетки были квадратными. Color и Fade variance лучше поставить по нулям, дабы цвет клеток был равномерным. Далее идет цвет и размер прожилок между кирпичами - текстуру делаем белой, а Gorizontal и Vertical gap подбираем так, чтобы белые линии не бросались в глаза (если кирпичи - 16х16, то прожилки - 0,1).


Спецвыпуск Xakep, номер #026, стр. 026-096-3, Меня зовут Голливуд (Part 2 - Декорации)

Меня зовут Голливуд (Part 2 - Декорации)

Томилин aka Middlenight

Спецвыпуск Xakep, номер #026, стр. 026-096-3

Теперь пришло время рендерить. Щелкни правой кнопкой на ключ рядом с пимпой animate, ставь частоту кадров на custom и пиши 25 (в секунду). В Rendering->Render, ставь выходной размер картинки на Pal (720х576) и сложи ролик в отдельную диру в виде последовательности статичных картинок (советую Tiff или BMP). Дальше мы будем редактировать отрывок во Флеше, а так их потом легко импортнуть. Продвинутые могут возразить, что шестой Flash поддерживает импорт AVI. Но при сохранении ролика в AVI без потери качества файл часто глючит. А после многочисленных манипуляций с роликом (обработкой, монтажом) картинка выйдет непотребной.

СОВОКУПЛЯЕМ С ФЛЕШОМ

Запусти Флеш. В Modify->Movie ставь размер поля и частоту кадров на 720х576х25, затем File->import и щелкай на первом кадре фрагмента с крутящейся тыквой. Флеш спросит: "Импортировать ли последовательность кадров?" - отвечай "ДА!!!". На кадровой линейке появится куча ключевых кадров - советую каждый из них подвинуть влево на 3-4 пикселя, так как Флеш немного (а иногда и много) промахивается в координатах. Теперь поставь замок на этот слой и каждый новый эффект создавай в новом слое.

Первое, что нам нужно - это бегущие цифры процентов под головой. Сразу предупреждаю, чтобы без всяких там скриптов и динамического текста - последующий экспорт фильма не поддерживает все эти навороты, так что все эффекты останутся в виде статичных рисунков. Поэтому в новом слое надо сделать текстовое поле и с каждым новым кадром писать туда новые цифры и переводить их в кривые: сначала 0, потом 8, 16 и так далее. Когда значение дойдет до ста - выделяй получившиеся кадры, щелкай на них правой кнопкой и выбирай Copy frames. Вставляй их дальше, и так, пока на линейке не накопится сотня кадров. То же касается всех остальных эффектов. Еще я добавил два цветных индикатора и пару надписей.

Когда все необходимые эффекты добавлены, импортируй файл в AVI с наилучшим качеством сжатия (советую Indeo Video 5.10 на 100%). Необходимая карта для экрана готова, назначай ее любому материалу, которому поставь SelfIllumination порядка 90 или 98. После назначения материала экрану редактор материалов можно на время и закрыть.

СПАТЬ СО СВЭТОМ

Займемся светом. Я предлагаю такой вариант: вся сцена освещается тремя прожекторами, имитирующими свет свисающих с потолка ламп. В качестве источника света бери Free spot и сразу ставь галочку напротив Cast shadows (отбрасывать тени) - пиплы часто забывают про это, а потом идут вопросы, типа: "А че это все хуже, чем в комиксах?" Меняем цвет света на синий и идем в Attenuation Parameters - здесь редактируются параметры близкого свечения, при котором свет почти постоянен и дальнего свечения, где свет рассеивается. Здесь ничего конкретно сказать не могу, так как у тебя размеры сцены будут свои, могу только посоветовать, чтобы размеры дальнего света совпадали с радиусом прожектора, а тот, в свою очередь, равнялся ширине комнаты. Увеличить/уменьшить размеры прожектора можно простым scale. Не забудь расставить флажки во всех нужных тебе значениях Far и Near. Значение Decay (затухание) изменять с none не рекомендую - в данном случае это только уменьшит яркость в и так темном помещении. В группе Shadow Parameters ты можешь выбрать тип карты (я оставил Shadow map - у нее тень посочнее, но можешь взять и Ray traced Shadows - это математически более равномерная и точная, но и более светлая тень) ее цвет (тоже не меняй) и прозрачность тени (дабы от предмета не исходило одно большое черное пятно поставь на 0,9). ОК! Два раза клонируй источник света и размести клоны в центре зала у потолка (один - над дверью, второй - над компом и третий - над другой половиной лаборатории). После этого создавай направленный прожектор (Target Direct), только впритык и параллельно экрану монитора и в Directional parameters меняй форму луча на rectangle - будем делать видимые лучи от ЭЛТ. Размер прожектора лучше сделать равным размеру экрана и в параметре Projector Map назначить карту уже упоминавшееся флешовой головы - реалистичнее будет, чем просто зеленый свет.


Спецвыпуск Xakep, номер #026, стр. 026-096-4, Меня зовут Голливуд (Part 2 - Декорации)

Меня зовут Голливуд (Part 2 - Декорации)

Томилин aka Middlenight

Спецвыпуск Xakep, номер #026, стр. 026-096-4

Теперь надо придать видимость всему использующемуся в сцене свету: иди в Rendering->Environment и выбирай четыре (по количеству прожекторов) атмосферных эффекта Volume light (хотя я бы заюзал плагин Scatter VL pro - его объемный свет смотрится гораздо более эффектно). Первый будет использоваться для свечения экрана - ему в attenuation color задавай зеленый цвет, а прозрачность ставь на уровень 2 или 3. После ставь флажок на Noise (шум, или эффект пара в свете) и изменяй levels на 3, а size на 10, чтобы не было, как в бане. Разумеется, ты твои сеттингзы будут другими, и ты будешь фигачить свой собственный креатифф, а не тыкать бездумно на кнопки. В остальных трех лайтах ставь те же параметры, но Attenuation Color сделай синим, а в Start% поставь 0, чтобы свет шел от "Ламп" равномерно. Теперь назначай каждый эффект своему прожектору.

Если сцена кажется тебе слишком темной, поставь где-нибудь в пыточной половине комнаты всенаправленный источник света (omny) с такими же параметрами, как и у ламп (цвет можно взять любой), но без возможности кастирования теней - это добавит света сцене, а зритель просто ничего не заметит.

ПРОБНЫЙ ПОШЕЛ!

Если все вышло гладко, то можешь создавать в сцене первую target (направленную) камеру. Выбирай около 50 мм - чем меньше, тем приближеннее к камере выглядят объекты, но и искажаются при этом они нехило. Направляй камеру на комп. Теперь можешь провести пробную визуализацию (rendering). Советую в качестве рендера использовать Mental ray - ничего сложного в сцене нет, так что сгодится и ray. Но есть засада. Просчет хода луча - дело довольно медленное, так что средненький компа может не потянуть. В общем, если твоя тачка сильно не торопится выводить результат, иди в редактор материалов (или в свойства рендера) и назначай там в Raytracer controls->Global Parameters значение Maximum depth (глубина просчета) ниже стоящей по умолчанию девятки. Даже при шести разница особо не заметна.


Спецвыпуск Xakep, номер #026, стр. 026-096-5, Меня зовут Голливуд (Part 2 - Декорации)

Меня зовут Голливуд (Part 2 - Декорации)

Томилин aka Middlenight

Спецвыпуск Xakep, номер #026, стр. 026-096-5

ПОДЖАРЬ ТРОФИМЫЧА

Вернемся к Трофимычу. Придай ему сидячую позу с вытянутыми руками и сделай рожу посвирепее (его рожу, не твою).

Начинаем рисовать кресло aka electric chair. Переходи в вид боковой проекции и начинай прямыми линиями рисовать контур кресла, а кривыми - его обивку. Помни, что каждый контур должен в конце замкнуться. Только тогда мы сможем эффективно применить модификатор Extrude (выдавливание). В значении Ammount задай глубину экструзии так, чтобы кресло было чуть шире тазобедренной части Трофима. Добавь подлокотники и some аппаратуру. Я, например, забацал кресло из Flashback'а. Еще посредством Surface-а я добавил кандалы, торчащие из спинки кресла, а также VR-шлем (такой же, как трусы). Лазеры вокруг кресла делаешь тем же методом, что и остальной свет, только в качестве источника света лучше взять Free direct, а цвет взять какой-нибудь фиолетовый или синий. Не забудь, также, лофтом сделать трубки, идущие из за кресла к голове Трофимыча (тут будут молнии). Трубки должны оканчиваться сферами (брать в примитивах).

АППАРАТУС

Следующим шагом надо сделать аппарат, к которому подключен наш подопытный. Что главное в фантастическом девайсе? Нет, не форма, а много мигающих лампочек. Как два пальца об асфальт! Делаешь огоньку форму и назначаешь материал с Self-Illuminate равным 100, находишь в Track view в объектах наш диод и его материал с Self-Illum'ом. Выделяй этот самый иллюминейт, жми кнопку controller (назначить контроллер) и выбирай Waveform float. Контроллер - это такая хреновина, которая может менять объект, задавая математические функции для различных его свойств. Так вот, после добавления контроллера нажимай правой кнопкой на появившийся трек иллюминейта и выбирай график изменения параметра. Лучше второй - там можно изменить параметр Duty circle (соотношение между временем свечения и гашения диода). Period - это количество вспышек, а Phase (от 0 до 1) - разницу между свечением повторяющихся объектов с одним материалом - ставь по своему усмотрению.

Еще в своем девайсе я сделал насос: рычаг с повторяющимися движением вниз, вверх в прозрачной колбе (Гы!). Как сделать повтор движения, не дрючась с ключами анимации сейчас расскажу: на каком-нибудь близком к нулю кадре нажимай animate и переводи рычаг вниз. Затем опять прись в Track-view и выбирай у рычага Transform -> Position. Копируй первый кадр на графике на симметричное расстояние справа от второго кадра (зажимай shift и переноси вправо). Затем щелкаешь на Parameter Curve Out-of-Range Types (пимпа сверху над графиками) и выбирай loop (повтор). Все. Насос сосет. Такую же хренотень можно применить к костям шеи Трофима, чтобы при ударе тока его голова билась об стул.


Спецвыпуск Xakep, номер #026, стр. 026-096-6, Меня зовут Голливуд (Part 2 - Декорации)

Меня зовут Голливуд (Part 2 - Декорации)

Томилин aka Middlenight

Спецвыпуск Xakep, номер #026, стр. 026-096-6

Теперь надо сделать, чтобы в девайсе что-то текло. Иди в Particle Systems и выбирай Super Spray. Главные параметры - это speed и particle size (размер частицы). Устанавливаешь эмиттер (штуку, откуда все сыпется) у крана баллона с мутагеном параллельно полу и в том районе, где трубка изгибается создавай источник гравитации (Space Warps->Particles & Dynamics->gravity), направленный (стрелка) вниз. Привязывай к нему эмиттер (Link to space warp), изменяя параметры частиц так, чтобы жидкость лилась, согласно твоим представлениям о мутагенных аппаратах. Обычно хватает изменения size'а, speed'а и meta particles'а - это чтобы частицы склеивались (ставь Variation на 100%). Не забудь назначить жидкости какой-нибудь яркий глянцевый материал со с Self Illumination около 100%. Частицы будут исчезать при соприкосновении с гравитацией, но можно сделать еще один эмиттер в месте падения частиц и направить частицы в сторону вены Трофимыча во время (Emit start) исчезновения жидкости из предыдущего источника. Ну а когда путь Аппарат - Трофимыч будет полностью создан, нарисуй на жидкости плавную линию и лофтом сделай из нее прозрачную трубку.

МУТАНТ-ТРОФИМЫЧ

Ну и под конец: начнем видоизменять Трофима. Наша задача - чтобы при поступлении жидкости в вену рука нашего пациента (а потом и он весь) превращалась во что-то уродливое. Начнем. Клонируй Трофимыча и оставь его на месте. Начинай изменять его руку (применяй модификатор Fdd-box). Назначь его Трофиму и, перейдя в режим редактирования узловой сетки (Sub object->Set volume), перемести ее в сторону руки. Теперь выбери режим Control points и дергай за узлы сетки. Когда рука окончательно превратится в щупальце, перейди в тот кадр, где ты хочешь чтобы оно выросло из руки. Проверь, чтобы геометрический центр Трофимыча остался тем же (если нет - иди в Hierarchy->Affect pivot only) и двигай контрольную точку на прежнее место. После этого выделяй первозданного Трофима, переходи в Compound objects->Morph и, поставив флажок на Move (сделать из одного объекта другой, не оставляя при этом второго на сцене) щелкай на клон Трофимыча. Теперь подвинь первый появившийся ключевой кадр на то время, когда жидкость начинает поступать в вену и - вуаля - T1000 (Trofimych1000) is ready! В добрый путь, дети Чернобыля :). Что не понятно - пиши.

В следующей серии:

- Окончательная сборка сцены;

- Моделирование реалистичных ("вавилоновских") взрывов;

- Мания величия - логотипы и застваки;

- Комп to VHS.


Спецвыпуск Xakep, номер #026, стр. 026-100-1, ШЬЕМ КРЕСТЫ

ШЬЕМ КРЕСТЫ

Shveya-Terric

Спецвыпуск Xakep, номер #026, стр. 026-100-1

(shveya@mat_vashu.hz)

ОТ РЕДАКЦИИ

Привет, читатель! На наши мыльники очень часто валятся мессаги со слезными просьбами рассказать про вышивание крестиком. В этих мылах зачастую столько боли и экспрессии ("Вы засрали целых 4 полосы мутью! Вы бы еще про вышивание крестиком рассказали!"), что мы, наконец, сказали: "Хватит!" - и решили удовлетворить истомившееся лоно народа. Это стоило нам немалых усилий, но мы нашли супер-СПЕЦа в этом деле. Ее профессия связана с большим риском, поэтому мы пообещали не давать в журнале никаких линков и контактов, так что извиняй.

ИСТОРИЯ ОДНОЙ ВСТРЕЧИ

Недавно прошел слушок, что на заднице лучшего костюма начальника отдела кружевной безопасности фабрики "Мягкие Мелочи" магическим образом прямо перед презентацией новой версии подтяжек для носков появилась вышивка веселого чертика и надпись "MM Suxx!!!". Рисунок и надпись были вышиты КРЕСТИКОМ! Все лучшие серферы СПЕЦа флудили андеграундные конфы и каналы в IRC запросами о швейном террористе и о, удача! автор дерзкого вшива была найдена. Она долго не соглашалась написать статью, ни угрозы, ни уговоры, ни пытки не помогали. Пришлось надавить на самую маленькую часть ее тела - на совесть: "Лучшие читатели самого актуального компьютерного издания страны - ламера в вышивании крестиком! Позор!!!" Эта маза проканала, так что читай самый горячий материал номера.

ЗАКАЗ

Сидела я дома и штопала косуху жилами вола, когда мне в асю завалился какой-то кент и предложил отвалить штуку грина за пару часов работы. Бабло на мальчиков к тому моменту ушло в даун, так что я согласилась встретиться с перцем в Третьяковской галерее и выпить по бутылке пива под тремя богатырями. Заказчика я узнала сразу по полосатым красно-белым носкам и пропеллеру за спиной. Нажравшись для конспирации, мы перешли к собственно к делу. Оказалось, что клиента дико бесили голубые подтяжки для носков, поэтому он был готов отвалить пять штук грина за дефейс задницы начальника кружевной безопасности "Мягких Мелочей". Последнее, что он смог сообщить мне, перед тем, как рухнул мордой в плевательницу, это то, что специально заказанный в Тайване костюм, сшитый девственными проститутками во время оргазма, будет храниться в гардеробе-сейфе в кабинете кружевного начальника.

ВЫШИВАЛЬНЫЙ СТАФФ

Я принялась за дело. Надев недоштопаную косуху и кирзачи, я покидала в авоську пяльцы, два вида канвы, вышивальные нитки, комплект иголок, бутылку спирту и соленый огурец. Осталось только заготовить макет будущего шедевра задничного рукоделия.

Сейчас я открою тебе страшную тайну всех вышивальщиц-неформалок: вышивка крестиком - это все равно, что растровая графика. Один крестик - то же самое, что один пиксель, а цвет крестика зависит только от цвета ниток, которые ты смог нарыть. Если приглядеться, то вышивка состоит как бы из разноцветных клеточек. Чем прямее руки, тем выше разрешение вышивки и, соответственно, тем меньше размер зерна aka крестика. Ну, если ты не ламобот, то, наверное, уже просек, что макет будущей вышивки тоже должен быть в виде клеточек. По нему ты потом будешь высчитывать, какой крест в какое место задницы пришить.


Спецвыпуск Xakep, номер #026, стр. 026-100-2, ШЬЕМ КРЕСТЫ

ШЬЕМ КРЕСТЫ

Shveya-Terric

Спецвыпуск Xakep, номер #026, стр. 026-100-2

Я выпила еще баночку пива и загрузила свою боевую печатную машинку. Везет мне, моей маме приходилось рисовать макет руками на миллиметровке. Хотя некоторые готовые макеты можно отрыть в сети... швейных магазов, но там валяется тааакой атцтой, что сиськи опадают. В общем, вот какой мегарулезный макет родил мой мегадолбанный мозг.

Закусив пиво позавчерашней пицей и ее запив самогоном, я взяла авоську с причиндалами и макетом и отправилась в здание "Мягких Мелочей".

ЗАПРАВЛЯЕМ

Не буду парить тебя нудным рассказом о том, как я пробралась мимо высокотехнологичных охранных систем и обезвредила дежуривших внизу ментосов, а также о том, как взломала секьюрный код на сейфовом гардеробе - это неинтересно, и с этим справится любое ламо. В общем, я достала кружевную жопу... то есть костюм директора и разложила его перед собой. Теперь предстояла самая тяжелая часть - вставить нитку в иголку, а жопу - в пяльцы. Поэтому я открыла еще одну бутылку пива, отхлебнула немного... две трети... рыгнула и открыла авоську.

Вся фишка была в том, чтобы закрепить жопу в пяльцах так, чтобы на ней не было ни одной складки, а место инсталляции вышивки было точно посередине. После доработки пялец паяльником с этим справилась, но гадская нитка никак не хотела входить в игольное ушко. Пришлось съесть таблетку и запить ее спиртом, и нитка сразу вошла. Кстати, выбирай иголку с ушком побольше, так как вышивальные нитки довольно толстые, но не переборщи, а то после каждого стежка в ткани будут оставаться невперенные дыры.

КАНВА

Дальше на жопу требовалось наложить координатную сетку. Можно, конечно, шить на глазок, но тогда дефейс получится кривой, косой и некрасивый.

Жопная ткань была плотной и абсолютно черной, поэтому вариант, когда клеточки рисуются на ткани, а потом при первой стирке вышивки краска смывается, отпадал. Я решила воспользоваться канвой, которую в свое время наперла на швейной фабрике. Канва бывает плотная - вышивка остается прямо на ней, что в данном случае не катило, а бывает хлипкая. С хлипкой канвой труднее вышивать, но ее потом можно повыдергать из вышивки ниточку за ниточкой. Канву я тоже вставила в пяльцы поверх ткани. Теперь все было готово к нанесению на зад вышивки.

ЗАМОРОЧКИ С ЦВЕТАМИ

Конечно, когда я лепила макет, я старалась, чтобы разноцветные части можно было прошить одной ниткой соответствующего цвета, но избежать геморроя с одновременным шитьем несколькими нитками не получилось. Дело в том, что если шить сперва один цвет, потом другой, то что-нибудь обязательно переедет, поэтому пришлось заправить еще несколько иголок. Нюхнув клею, я справилась и с этой траблой.

ПОСТАВИМ КРЕСТ

Итак, из задницы теперь болтаются несколько иголок - пора поставить первый крест. Начинай с самого крайнего угла самого крайнего квадрата (например, с левого верхнего). Да, только не забудь узелок завязать. Я, например, забыла - пришлось допить одеколон и повторить действие сначала. Теперь тащи нитку в противоположный по диагонали угол (правый нижний). Протащил? Ай, молодца! С изнанки нитка пойдет через правый верхний угол. И, наконец, с лица - через левый нижний угол. Если драйвер krivie_ruki.sys у тебя версии хотя бы 1.0, то у тебя должен был получиться крестик. Заметь, нитка оказалась в том же углу следующего квадрата, но с изнанки, поэтому теперь придется перекинуть ее в правый верхний угол и начинать с него. Когда дойдешь, до области другого цвета пускай в ход второй бая... эээ... в смысле иглу. Но не увлекайся - шей рисунок строчку за строчкой или столбик за столбиком (это уж как ты там для себя решишь).


Спецвыпуск Xakep, номер #026, стр. 026-100-3, ШЬЕМ КРЕСТЫ

ШЬЕМ КРЕСТЫ

Shveya-Terric

Спецвыпуск Xakep, номер #026, стр. 026-100-3

ПОСЛЕДНИЙ УЗЕЛ

Совсем забыла, если у тебя вышивка состоит из нескольких элементов (сам рисунок и надпись), постарайся, чтобы они соприкасались и перейти с одного элемента на другой было легко без длинных стежков. Избегай навесного монтажа. В общем, сам там разберешься. Что я тебе все разжевывать должна? Надо и своей башкой поработать! Только не забудь в конце работы нитки подвязать, а то расползется твоя вышивка к чертям, как парочки по комнатам. Знаешь, как это делается-то? Продеваешь с изнанки нитку под какой-нибудь стежок и перед тем, как затянуть, протаскиваешь иголку через образовавшуюся петлю, потом затягиваешь.

Ну и наломалась же я в ту ночь! Я так устала, что забыла пару иголок, воткнутыми в штаны, так что кружевной начальник всю презентацию стоял по стойке смирно.

Ну, типа, удачи тебе! Делай, как я, и тоже станешь крутой швеей-террористкой.


Спецвыпуск Xakep, номер #026, стр. 026-102-1, НОВОГОДНЯЯ МЫШЬ КРЕАТИВЩИКА

НОВОГОДНЯЯ МЫШЬ КРЕАТИВЩИКА

Jani Ponkko

Спецвыпуск Xakep, номер #026, стр. 026-102-1

(jponkko@metku.net, www.metku.net)

перевел Vadias (painter@gameland.ru, www.freehand.str.ru)

Все хотят казаться лучше, чем они есть на самом деле, и используют для этого самые разнообразные средства. Твоя затасканная мышь - не исключение: что она чувствовала в жизни, кроме твоей потной ладони? Думаю, она заслужила право на лучшую жизнь, особенно в новогодние праздники, тем более что затраты на ее модинг куда менее накладные, чем на другие аппаратные средства. Как ты уже догадался, ей и только ей посвящается эта замечательная статья. Наряди свою крысу к NY!

ЧАСТЬ ПЕРВАЯ

ТРЕПАНАЦИЯ МЫШИНОГО ЧЕРЕПА

Итак, коллега, приступаем к операции. Для начала нам понадобятся два куска тонкого оргстекла - примерно 1-1,5 миллиметра толщиной. Это, во-первых, сделает нашу работу более легкой, а во-вторых, толщина здесь просто неуместна. Где взять такое стекло, это уже твоя головная боль :).

Наша первая задача состоит в том, чтобы согнуть оргстекло в соответствии с формой верхней части мыши - не спеши тужиться и напрягать бицепсы, это делается не грубой физической силой. Стекло сначала следует нагреть, и когда оно станет податливым, смело гни его, положив на мышь. Только не переборщи с нагреванием и не нагревай стекло, пока оно лежит на мыши, ибо крысиная поверхность может испортиться, и ты испохабишь всю идею.

Проделай это с обоими кусочками стекла. Почему их два? Об этом ты узнаешь чуть позже, а пока просто доверься мне.

Теперь обозначим периметр трепанации. Бери ручку, карандаш, фломастер или проковыряй дырку в пальце :) и аккуратно начерти на поверхности мыши фигуру нужного размера, которую собираешься вырезать. В моей мыши, которую собирали умельцы Мелкософта, возникла небольшая проблема - здесь используется приличного размера кусок пластика, который служит для удерживания кнопок на своем месте. Я поступил с ним по-еврейски: обрезал мешающую часть, а остаток как следует закрепил суперклеем.

Этот замечательный аппарат я нашел среди своих крутых инструментов. Я, конечно, понимаю, что у тебя такого может и не быть, но имей в виду, что вскрывать им мышь было настолько удобно, что я даже немного увлекся и распилил пополам свой рабочий стол. Впрочем, можешь сгонять к отцу на пилораму или взять у дядьки циркулярку :).

А на следующей картинке ты можешь видеть, какое милое отверстие я просверлил в своем грызуне. Мелкософтовский кнопкодержатель также укорочен и больше не мешает нашим планам. Как ты мог заметить, я уже прилепил один кусок изогнутого оргстекла и зафиксировал его с помощью суперклея.

Итак, один важный этап уже пройден. В принципе, самые ленивые могут остановиться здесь и не портить дальше своего маленького грызуна, если они - обладатели не обычных, а оптических мышек, где вместо шарика и "шестеренок" используется "глаз" - луч света. Свет этого луча в состоянии обеспечить забавный эффект, который ты видишь на картинке ниже. Будешь друганам заливать, что у тебя лазерная крыса.

Однако тебе стоит взять на заметку, что настоящий креатифщик никогда не останавливается на полпути. И поэтому мы с тобой должны пройти этот тернистый путь до победного конца.


Спецвыпуск Xakep, номер #026, стр. 026-102-2, НОВОГОДНЯЯ МЫШЬ КРЕАТИВЩИКА

НОВОГОДНЯЯ МЫШЬ КРЕАТИВЩИКА

Jani Ponkko

Спецвыпуск Xakep, номер #026, стр. 026-102-2

ЧАСТЬ ВТОРАЯ

ОТМОРОЗОК

Теперь нам понадобится доброволец. Интуиция подсказывает мне, что сегодня добровольцем будет вот этот парень (или девушка? - у этих фигурок Lego довольно слабо развиты половые признаки :)). Поприветствуем смельчака - сейчас он отправится туда, где еще не ступала нога человека да и Lego перца тоже. Но перед этим его ждут волшебные новогодние трансформации.

Упс! Смотри - наш волонтер потерял ноги! Все правильно - лишним частям тела не место на такой маленькой жилплощади. И потом, ты разве не читал "Повесть о настоящем человеке" про летчика Маресьева? С ногами наш герой - не герой.

Как известно, все любят диоды, так почему бы не добавить его и в этот мод? Честно говоря, в моей мышке этого добра и так навалом, но, в конце концов, это ведь мой мод :)!

Смотри внимательно на картинку ниже. Грамотное подсоединение диода - залог его правильной работы. Чтобы ты точно не запутался, комменты дает наш радиосексперт Доктор Код aka Dr. Cod.

Нулевая точка (или минус, отрицательный потенциал) должна быть справа от красного диода (на картинке это слева). Там как раз находится перемычка между дорожками (неизолированный проводочек, это называют навесным монтажом) для питания всей остальной схемы. Точка с положительным потенциалом (плюс) должна находиться на одной из ног черного конденсатора. Ты можешь определить минусовую ногу, поглядев на корпус этого черного конденсатора. Эта сторона помечена маркером "-". Тебе нужно заюзать другую ногу, она положительная.

На картинке положительная нога светодиода подфуярена к конденсатору через резюк скорее всего в 1 килоОм. А отрицательная нога подсоединена к перемычке между дорожками, торчащей из платы слева на фото. Но нафига все это автору было нужно, я не понимаю, ведь можно подфуярить новый светодиод прямо к старому, так к ногам евойным и подпаять.

Примечание переводчика. Не у всех модель мыши такая, как у нашего финского друга. Однако точно так же можно обмодить и обычную мышь, с шариком. Принцип там, как известно, таков: при движении мыши шарик вращает колесики с зазубринами, и в зависимости от того, пропускают ли эти зазубрины луч, в комп идет необходимая инфа. Глазами луч диода тебе не увидеть - он находится вне видимого спектра светового диапазона :(. Но суть не в том. Здесь тоже работает метод автора.

На неоптической мышке можно тоже найти конденсатор и подфуяриться к его плюсу через килоОмный резистор. Ну а общую (или нулевую, или землю, минус) найти легко - это самая толстая дорожка (прим. Dr. Cod).

Итак, бедный доброволец стал узником твоей мышки. Теперь злой модер добавит немного жидкого азота, хе-хе :)...

Слева ты видишь узника грызуна за чистым куском оргстекла безо всяких добавлений. Однако не слишком приятно, когда другие видят нутро твоей мыши с тараканьими испражнениями, не так ли? Поэтому на средней картинке я положил за человечка немного алюминиевой фольги. Теперь любопытный взгляд не проникнет в святая святых. Взглянув на последний рисунок, ты, наконец, поймешь, для чего вначале мы гнули не один, а два кусочка оргстекла. Верхнюю стекляшку надо немного зашкурить, оставив целым ее центр, и накрыть второй стекляшкой - тогда создается полное впечатление, что внутри - жидкий азот.


Спецвыпуск Xakep, номер #026, стр. 026-102-3, НОВОГОДНЯЯ МЫШЬ КРЕАТИВЩИКА

НОВОГОДНЯЯ МЫШЬ КРЕАТИВЩИКА

Jani Ponkko

Спецвыпуск Xakep, номер #026, стр. 026-102-3

Теперь ты можешь взглянуть на мою мышь в полной красе. Зимняя такая фишка получилась :). А еще это отличный подарок на NY.

Вот и все. Действительно легкий, дешевый и неплохо смотрящийся мод. Я не уверен, что тебе захочется запихнуть внутрь мыши именно фигурки Lego; мышь твоя, и ты можешь совать туда что угодно :). Так что - за дело, а я пока буду придумывать новые, легкие, дешевые и хорошо выглядящие моды. Ну, с финским приветом, и заглядывай на www.metku.net ;).


Спецвыпуск Xakep, номер #026, стр. 026-104-1, TIPS OF FLASH: В ЛЕСУ РОДИЛАСЬ ЕЛОЧКА

TIPS OF FLASH: В ЛЕСУ РОДИЛАСЬ ЕЛОЧКА

Iv (dembicki@narod.ru)

Спецвыпуск Xakep, номер #026, стр. 026-104-1

О ШЕФАХ И НЕ ШЕФАХ

Когда в святая святых, можно сказать - в сердце креатива фирмы, то есть в твой кабинет, вваливается возбужденно-взъерошенный шеф, ты понимаешь что на уме у него одно: потревожить твой покой. Так и есть. Какой-то нехороший человек дал ему линк на сайт, где в красе неописуемой всяко-разные данные представлены в виде модных графиков и случайному посетителю сайта толково объясняют, зачем, почем и почему нужно идти к вам в офис и расставаться со своими кровными, нажитыми непосильным трудом зелеными бумажками.

TIPS 1

Отбрыкивайся как только можешь. Ибо настанут дни, когда твоя независимость будет нагло попрана серверным программистом. И вся его лень будет суммироваться с твоей, и разносы от шефа вы будете получать в два раза чаще и в два раза больше.

Если тебе удалось убедить шефа в том, что все виденное им это сон, что это не нужно вашей фирме, что это идет вразрез с креативной концепцией и т.п., то тебя ждет большое будущее - ты умеешь оказывать влияние на людей. Смело просись в руководство фирмы. Подвинь финансового директора, например. Поверь, это будет проще, чем убедить шефа не делать взаимодействие с серверным скриптом. Поэтому дальше можешь не читать. Зачем финансовому директору знать такие веши?

КАК ВЗАИМОДЕЙСТВОВАТЬ С СЕРВАКОМ

Итак, тебя взяли на работу и требуют сделать взаимодействие с сервером в первый же день. При этом финансовый директор - бывший флэшер. Ситуация хуже некуда. Придется делать.

TIPS 2

Чтобы не налетать на грабли, расставленные серверным программистом, будь независим от него. Сделай себе файлы, можешь даже разместить их локально, и получай данные

из этих файлов.

Рассмотрим примерчик:

Создаем новое файло в Flash MX и сохраняем его под именем prices.fla. Рисуем чудную новогоднюю елку. Я не заморачивался и нарисовал ее в Paint. Импортируем, Ctrl+B (Breack Apart), после этого волшебной палочкой можно выделить белый фон и снести его. Заклинанием F8 превращаем елочку в мувиклип с именем "el_mc", отмечаем галочки Export for action script, Export in first Frame. (Рис. 1)

После всех этих манипуляций сносим с рабочего стола елочку: спи елочка, бай-бай. Пока она останется только в библиотеке. Это были подготовительные манипуляции. Цель сегодняшнего рассказа - научиться получать данные с сервака, обрабатывать и отображать их в графическом виде.

TIPS 3

Разбивай задачу на много мелких последовательных шагов. Проверяй результат каждого этапа.

В нашем случае план таков:

Сделать тестовый xml документ.

Запросить xml документ.

Создать обработчик ошибки загрузки.

Проверить xml на правильность.

Отобразить процесс загрузки xml.

Обработать xml для дальнейшего использования.

Создать объекты, соответствующие узлам xml.

Передать в объекты данные атрибутов.

Изменить объекты в соответствии с этими данными.

Изменить адрес загрузки на адрес сервера.

Идти в кассу за зарплатой.

ТЕСТОВЫЙ XML ДОКУМЕНТ

Прежде всего он должен быть корректным. И это легко проверить: достаточно открыть xml документ в Internet Explorer. Если имеется ошибка, эксплорер это отобразит.

Создаем файл my_data.xml. Содержимое файла:


Спецвыпуск Xakep, номер #026, стр. 026-104-2, TIPS OF FLASH: В ЛЕСУ РОДИЛАСЬ ЕЛОЧКА

TIPS OF FLASH: В ЛЕСУ РОДИЛАСЬ ЕЛОЧКА

Iv (dembicki@narod.ru)

Спецвыпуск Xakep, номер #026, стр. 026-104-2

<?xml version="1.0" encoding="windows-1251" ?>

<prices header="Анализ цен на елки">

<firm name="Русская ель" price="80" />

<firm name="Норвежская ель" price="190" />

<firm name="Голубая ель" price="300" />

</prices>

Сохраняем my_data.xml. Проверяем его валидность открытием в эксплорере. (Рис. 2)

По содержанию этого файла можно догадаться, что мы будем сравнивать цены на елки в нашей фирме "Русская ель" с ценами на елки в конкурирующих фирмах. И делать это будем с особым цинизмом: в графическом виде.

ЗАПРОС И ПРОВЕРКА ДАННЫХ

TIPS 4

Не ленись четко прописывать trace. Не стесняйся писать в trace много и понятно. Это поможет вовремя заметить и исправить ошибки.

Поскольку в нашем XML присутствуют русские буковки, нужно предупредить систему использовать местную кодовую страницу. Делаем это в первой же строке. Далее создаем xml объект и загружаем в него наш файл с данными. На событие загрузки проверяем, успешна ли загрузка, хорош ли xml, и сообщаем об этом в окно вывода.

Вот как это все выглядит на Action Script:

System.useCodePage = true;

XML.prototype.ignoreWhite = true;

this.input_xml = new XML();

this.input_xml.load("my_data.xml");

this.input_xml.onLoad = function(success) {

if (success) {

if (this.status != 0) {

trace("invalid xml");

} else {

trace(this);

}

} else {

trace("error opening URL");

}

};

TIPS 5

На первый взгляд избыточная проверка XML на валидность ни к чему. Ведь мы проверили его в IE. Но не забывай, в дальнейшем тебе придется получать данные от серверного скрипта, и xml будет создавать серверный программист. И если он ошибется, то ты это сразу увидишь и будешь знать виновного.

ОБРАБОТКА XML

Поскольку мы только учимся пользовать XML во флэше, то, невзирая на простоту примера, подойдем к вопросу серьезно, по полной программе. Как большие. Для начала назначим каждому узлу xml свой ID, чтобы в дальнейшем к узлам обращаться напрямую, используя синтаксис вида any_xml[ID].

TIPS 6

Есть вещи, которые нельзя позволять никому. Не доверяй никому свою машину, жену/мужа и атрибут ID в xml. Только так ты будешь уверен в том, что сможешь взять любой узел по его ID и делать с ним все что захочешь.

Чтобы задать узлам xml уникальный идентификатор, будем пользовать мою функцию nextNode, без которой просто не представляю, как бы я обходился. Советую не набирать вручную, а взять вот здесь:

http://www.layer51.com/proto/d.aspx?f=440

Если появится желание понять, как она работает, то почитать можно здесь:

http://dembicki.narod.ru/tutor/a4.htm

// (с) Ivan Dembicki, dembicki@narod.ru

XMLNode.prototype.nextNode = function() {

if (this.firstChild != null) {

return this.firstChild;

}

var n = this;

while (n.nextSibling == null) {

if (n.parentNode) {

n = n.parentNode;

} else {

return null;

}

}

return n.nextSibling;

};

TIPS 7

Создай отдельный слой для прототипных функций. Если прототипных функций много, вынеси их во внешний .as файл и инклудь в первом кадре. Но и в том и в другом случае это должно быть в верхнем кадре, поскольку функции должны быть заданы до их вызова.


Спецвыпуск Xakep, номер #026, стр. 026-104-3, TIPS OF FLASH: В ЛЕСУ РОДИЛАСЬ ЕЛОЧКА

TIPS OF FLASH: В ЛЕСУ РОДИЛАСЬ ЕЛОЧКА

Iv (dembicki@narod.ru)

Спецвыпуск Xakep, номер #026, стр. 026-104-3

TIPS 8

Не сноси авторов функций. В том, что ты пользуешь чужие функции, нет ничего позорного, скорее наоборот, умение использовать в своих целях бесплатные разработки других людей - серьезное достоинство любого программиста. Присваивать себе авторство чужих работ смешно и бессмысленно. Авторы функций указывают себя не для достижения всемирной славы, а для того, чтобы человек, использующий функцию, в случае обнаружения ошибки мог об этом ему сообщить, и если ошибка уже исправлена, то и получить исправленную версию.

Ты не потерял тему за моими советами? Если нет, то продолжим. Зададим узлам уникальный идентификатор вот этой функцией:

this.input_xml.addID = function() {

var nod, i = 0;

nod = this.firstChild;

while (nod) {

nod.attributes.ID = i++;

nod = nod.nextNode();

}

this.parseXML(this);

};

Эту функцию мы можем написать после уже написанного скрипта, поскольку событие onLoad произойдет не ранее второго кадра. Вызываем эту функцию только в том случае, если произошла успешная загрузка xml и он не содержит синтаксических ошибок. А именно перед строкой trace(this). Заодно и изменим этот трейс, чтобы продемонстрировать возможность обращения к узлу xml через его ID:

trace(this[0].attributes.header);

В результате в окне вывода должны увидеть: "Анализ цен на елки".

TIPS 9

В данном примере глубина вложенности узла не важна, поскольку у всех узлов она одинакова (за исключением первого). Однако при генерации различных меню структура и вложенность будут играть очень важную роль. Для определения глубины нужно добавить соответствующий счетчик в функции nextNode, который бы увеличивался при переходе на дочерние узлы и уменьшался при переходе на родительские. Значение глубины узла советую сохранить в самом узле как его атрибут.

СОЗДАЕМ ОБЪЕКТЫ И КОПИРУЕМ В НИХ ДАННЫЕ ИЗ XML

Итак, что мы имеем. К любому узлу можем обратиться через его идентификатор. Первый узел, содержащий все остальные узлы, имеет нулевой идентификатор. Давай это использовать. Создадим функцию, которая, имея на входе только идентификатор узла, добавит мувиклип на сцену и передаст атрибуты в переменные этого мувиклипа.

Начнем опять с посещения www.layer51.com, а именно:

http://www.layer51.com/proto/d.aspx?f=361

И возьмем там вот эту функцию:

// (c) Ivan Dembicki 2002 dembicki@narod.ru

XMLNode.prototype.copyAttributes = copyAttributes

function copyAttributes (to) {

var a = this.attributes;

var b = eval(to);

for (var vars in a) {b[vars] = a[vars];}

}

Поместим функцию в наше хранилище прототипов после функции nextNode. Затем создадим функцию добавления мувиклипов в указанное место:

this.input_xml.addMCs = function(targ) {

var mc, i;

while (this[++i]) {

mc = targ.attachMovie("el_mc", "el"+i+"_mc", i);

this[i].copyAttributes(mc);

mc._x = i*mc._width;

mc._y = 400;

mc._height = mc.price;

}

};

Вызовем функцию в событии onLoad (после вызова функции addID и трейса) с указанием, куда их размещать:

this.addMCs(_root)

delete this

Теперь можно и тестануть. (Рис. 3)


Спецвыпуск Xakep, номер #026, стр. 026-104-4, TIPS OF FLASH: В ЛЕСУ РОДИЛАСЬ ЕЛОЧКА

TIPS OF FLASH: В ЛЕСУ РОДИЛАСЬ ЕЛОЧКА

Iv (dembicki@narod.ru)

Спецвыпуск Xakep, номер #026, стр. 026-104-4

РЕЗЮМЕ

Что мы имеем в результате? Три елочки разной высоты? Не только! Мы имеем упорядоченные мувиклипы, содержащие данные, полученные из xml. Это можно увидеть в листинге переменных. Теперь с этими данными можно делать все что угодно. Более того. Тебе не нужно заботиться о том, чтобы изменять твой скрипт генерации объектов, если в xml будут добавлены новые атрибуты. Все атрибуты и их значения будут скопированы в переменные мувиклипов. А уж как задействовать их, не мне тебя учить.

С Новым годом!


Спецвыпуск Xakep, номер #026, стр. 026-106-1, TIPS OF WEB - Сайт перед Рождеством

TIPS OF WEB - Сайт перед Рождеством

Vadias

Спецвыпуск Xakep, номер #026, стр. 026-106-1

(painter@gameland.ru, www.freehand.str.ru)

Кто сказал, что под Новый год украшают только елки? Твой сайт ничуть не хуже, и сегодня мы, как и положено, добавим в него немного волшебства и декораций. А поможет нам с волшебством не кто иной, как великий и ужасный Dynamic HTML. Чтобы сразу посмотреть, какая пага из всех описываемых телодвижений должна получиться, слетай по адресу: www.freehand.str.ru/newyear, а если что неясно - просто намыль мне (только, чур, без вопросов, где найти фотки с голыми снегурочками).

TIPSA 1

Веселиться, так веселиться! Пусть вход на твой обновленный сайт будет начинаться, ни много ни мало, с микроигры. Нет, не надо закачивать третий "Doom" на бедный сервак - можно обойтись простеньким скриптом.

TIPSA 2

Итак, гама "Закликай Деда ОтМороза". Суть игры такова: когда юзер заходит на сайт, перед ним по странице туда-сюда носится Дед Мороз, и чтобы увидеть дальнейшее содержимое сайта, юзер должен щелкануть мышой по старику (его изображение является ссылкой на основную страницу).

TIPSA 3

Сперва нужно подготовить две зеркальные картинки с Морозом - одна носом вправо, другая носом влево (иначе - что будет носиться по экрану). Дай им понятные имена, я, например, назвал свои пикчи "deda-l.gif" и "deda-r.gif".

TIPSA 4

Весь скрипт нужно засунуть между новогодними тегами <head> и </head>:

<script >

var wid=window.screen.width; //здесь мы узнаем ширину экрана юзера.

var x=-80; //вводим переменную с отрицательной горизонтальной координатой, чтобы картинка уезжала за экран.

var svich=false; //с помощью этой переменной меняется направление движения.

function window_onload() { //эта функция при загрузке страницы запускает основную функцию и устанавливает таймер обновления на 5 миллисекунд.

window.setInterval("move()", 5);

}

function move() { //это функция, которая двигает картинку.

if(svich==false){

imaj.src="deda-r.gif"; //источник (source) изображения устанавливается здесь.

x=x+7; //устанавливаем, на сколько пикселей за раз сдвигается картинка.

if(x>=wid){ //видишь, когда координата по оси X становится больше или равной ширине экрана,

svich=true; //направление движения меняется.

imaj.src="deda-l.gif"; //source картинки изменяется.

}

}

else {

x=x-7;

if(x==-80){

svich=false;

}

}

deda.style.left=x+"px"; //эта строка устанавливает начальную координату картинки, равную переменной x, т.е. -80.

}

</script>

TIPSA 5

Это и был "движок" игры в Деда. Но движок надо еще запустить с толкача. Для этого после открывающего тега <body> пишем: onload="window_onload()". Также устанавливаем параметры отступа и задаем стиль курсору crosshair, то есть "прицел". Такой же стиль курсора надо установить в теге ссылки <a>. У картинки устанавливаем id, чтобы скрипт мог менять ее источник (src). Все остальное - чисто оформление.

<body onload="window_onload()" topmargin="0" leftmargin="0" style="cursor:crosshair" bgcolor="#000066">

<table width="100%" border="0" cellpadding="0" cellspacing="0">

<tr>

<td height="180px" bgcolor="#FFCC33"> </td>


Спецвыпуск Xakep, номер #026, стр. 026-106-2, TIPS OF WEB - Сайт перед Рождеством

TIPS OF WEB - Сайт перед Рождеством

Vadias

Спецвыпуск Xakep, номер #026, стр. 026-106-2

</tr>

<tr>

<td height="80px" bgcolor="#FFFFFF" valign="bottom">

<div id="deda" style="position: relative"><a href="main.htm" style="cursor:crosshair"><img id="imaj" src="" border="0"></a></div>

</td>

</tr>

</table>

</body>

TIPSA 6

В интересах юзабельности рекомендую все же поставить на эту страницу также обычную ссылку на main.htm, потому что, во-первых, не все захотят стрелять по старику, а во-вторых, не у всех браузер IE, поддерживающий эту игру :).

TIPSA 7

Итак, юзерок благополучно прошел твою первую "игру" :). Что ж, постараемся не разочаровать его далее. Надо внести некоторую живость в страницу. В левый верхний угол добавим персонажа - наиболее актуален сейчас Санта Морозович aka Дедус Клаус. Вот что можно замутить: в зависимости от положения курсора мыши персонаж будет вращать глазами.

TIPSA 8

Есть готовый скрипт, где глаза вращаются на 360 градусов (ищи на пагах по JavaScript), но его код слишком замороченный. Зачем мучиться - выберем упрощенный вариант: если курсор будет находиться справа от старика, он будет смотреть вправо, если снизу - то вниз, а если между этими двумя областями - то по диагонали. Очевидно, сначала необходимо создать три соответствующих картинки. Я назвал их east.gif, s-east.gif и south.gif.

TIPSA 9

Скрипт, как обычно, запрячем в HEAD. Весь он состоит из одной функции:

<script>

function seen() {

var mx=event.x; //объявляем переменную, которой присваивается значение положения курсора по горизонтали.

var my=event.y; //объявляем переменную, которой присваивается значение положения курсора по вертикали.

if (mx>80 && my>80) { //здесь определяется самая большая область, глаза смотрят по диагонали.

eye.src="s-east.gif";

}

else if (mx<80 && my>80) { //определяется область, находящаяся под изображением; глаза смотрят вниз.

eye.src="south.gif";

}

else { //все остальное, включая область самой картинки; глаза смотрят вправо.

eye.src="east.gif";

}

}

</script>

TIPSA 10

Не забудь в BODY воткнуть функцию, работающую при движении мыши. Вставляем в документ картинку с id="eye", по умолчанию это будет east.gif.

<body topmargin="0" leftmargin="0" onmousemove="seen()">

<img id="eye" src="east.gif">

</body>

TIPSA 11

Только этого мало! Пусть наш герой не только глядит, но и бубнит, причем со смыслом. Он будет обращаться к юзеру по имени! Сделаем так, чтобы при загрузке этой страницы вылетало окно сценария с запросом имени и полем для ответа. Но сначала нужны некоторые картинки и теги, чтобы Дед Мороз говорил, как в комиксах, "облачком" изо рта :).

TIPSA 12

Для начала нужно подготовить некоторые графические элементы. Это три картинки, ведущие в разные разделы ("открытки", "фотки" и "истории"), и еще картинка с треугольничком для комиксного облачка. Напоминаю, ты можешь посетить страницу по адресу, указанному в начале статьи, сохранить ее и рассмотреть все файлы вблизи.

TIPSA 13

Не забудь добавить этот скрипт к предыдущему, чтобы все работало одновременно (и глаза, и бубнилка).


Спецвыпуск Xakep, номер #026, стр. 026-106-3, TIPS OF WEB - Сайт перед Рождеством

TIPS OF WEB - Сайт перед Рождеством

Vadias

Спецвыпуск Xakep, номер #026, стр. 026-106-3

<body>

<script>

var namez=prompt("Представься дедушке, дружок!", "хакер");

var def="Выбери раздел, "+namez+"!";

var otkr="Здесь ты найдешь симпотные новогодние открытки";

var foto="В этом разделе - самые вызывающие рождественские фотографии";

var stories="Хочешь почитать самые волшебные и пошлые новогодние истории?"

</script>

<div id="cloud" style="padding: 0px; margin: 0px; width=120px; visibility: visible; position: absolute; left: 80px; top: 80px">

<img src="triangle.gif">

<div id=comment style="border: 1px solid #000; border-top: 0px; padding: 3px; margin: 0px">

<script>

comment.innerText=def;

</script>

</div>

</div>

<div style="position: absolute; left:100px">

<table border="0">

<tr>

<td><a href=otkr.htm><img src="otkr.gif" onmouseover="comment.innerText=otkr" onmouseout="comment.innerText=def"></a></td>

<td><a href=foto.htm><img src="foto.gif" onmouseover="comment.innerText=foto" onmouseout="comment.innerText=def"></a></td>

<td><a href=stories.htm><img src="stories.gif" onmouseover="comment.innerText=stories" onmouseout="comment.innerText=def"></a></td>

</tr>

</table>

</div>

</body>

TIPSA 14

Ну вот, все украшения готовы. Страница выглядит, как живая, и мы считаем дни до долгожданного праздника. А для тех, у кого плохо с арифметикой и кто не может сосчитать количество оставшихся суток, мы вставим эту архиполезную информацию на нашу страницу. Этот маленький кусок скрипта можно вставить в любое место между тегами <body> и </body>. Правильно показывать число дней он будет только в течение декабря, но именно поэтому он так мал и прост (Новым годом здесь считается первое января). Так что каждый месяц - Новый год :).

<script>

var nowDate=new Date();

var curDay=nowDate.getDate();

var Christmas=32;

var ostalos=Christmas-curDay;

document.write("Если твои часы не врут, до Нового года осталось "+ostalos+" дней");

</script>


Спецвыпуск Xakep, номер #026, стр. 026-108-1, БУРБУЛЯТОРЫ - оружие новогоднего растамана

БУРБУЛЯТОРЫ - оружие новогоднего растамана

SpelinblimbeR и ХрымZ

Спецвыпуск Xakep, номер #026, стр. 026-108-1

(spelinblimber@ukrpost.net), ХрымZ (hrimz@xyligan.ru)

Новый год – мероприятие, безусловно, массовое. И для того, чтобы объединить народ, не всегда нужно упиваться в смерть. Гораздо приятнее замутить ритуал американских индейцев (и международных растаманов) – трубку мира. Но поскольку мир не стоит на месте, труба его тоже преобразилась и получила в наследники хитрый прибор – бурбулятор (барбулятор ,бульбулятор, бульбик).

Smoking kills

Так уж повелось, что табак курят. Конечно, его можно употреблять и внутрь (то бишь хавать), но ритуальное курение носит еще и символический смысл - оно как бы объединяет всех участников ритуала, создает доверительную атмосферу и ощущение приобщенности к некоему таинству. Для курения используют целую кучу девайсов - от самодельных бурбуляторов, собираемых за пять минут, до высокотехнологичных промышленных вариантов. Тем не менее все это разнообразие можно разделить на две группы: девайсы, действующие по принципу трубок (тут дым нигде подолгу не задерживается и попадает прямиком в твои легкие), и девайсы, в которых дым перед попаданием в легкие всячески охлаждается и частично очищается (охлажденный дым не так сильно дерет горло, это помогает избегать неприятных приступов кашля). Кроме того, бывают барбуляторы чисто прагматического предназначения - их делают с целью побыстрее покурить, и никакой эстетической нагрузки они не несут. Правда, как для меня, гораздо приятнее сесть вокруг елки и пустить по кругу красиво и качественно сделанную трубку. Я не знаю, есть ли в России бульбуляторные магазины, могу сказать, что в Киеве их нет, а если бы и были, то цены на промышленные модели они завернули бы за небеса. Посему сперва хотелось бы рассказать про самодельные девайсы.

Шаманим в домашних условиях

Итак, закончим с нудной прелюдией и поговорим о том, какими бывают и как сотворить самому эти чудо-девайсины для ритуального курения. "Бум Шанкар!", как говорят братья-растаманы.

Для барбулятора тебе понадобятся:

1) пластиковая бутылка (в принципе, любого размера);

2) фольга (пойдет даже из-под шоколада);

3) игла или что-то колющее;

4) ну и сам табак, соответственно :).

Берешь емкость, именуемую ботлом, выпиваешь содержимое, выкидываешь на фиг пробку. Теперь работы осталось - проделать отверстия в бутылке и присобачить фольгу. Для примера возьмем тару в 0.5 литра (стандартную коку). Отступи мысленно от дна бутылки сантиметров 4-5 и колющим предметом проткни несколько раз пластик. То есть сделаем небольшую решеточку в бутылке, состоящую из маленьких дырочек (либо такой вариант из практики уличных растаманов - закури новую сигарету и, пока она еще не сильно истлела, прожги ею дырку, после некоторой практики получаются красивые круглые дырки). Размер решетки подбери под свою пасть сам - тут мы тебе не советчики :). Теперь сделай из фольги воронку в горлышке бутылки и закрепи конструкцию скотчем, а лучше изолентой. Если ты заметил, на некоторых пластиковых бутылках после снимания крышки остается кольцо; попрактиковавшись, можно научиться его снимать, затем края воронки загибаются и сверху надевается кольцо - таким макаром все и фиксируется. Можно пойти еще дальше - взять старый мамин наперсток, при помощи цыганской иглы и молоточка проделать в нем дырочки, а затем закрепить его в крышке от бутылки - устройство многоразового использования :). Затем проткни несколько раз фольгу иголкой, и простейший барбулятор готов! Заряжай ракету! В смысле - засыпай в воронку табак, поджигай, а через отверстие внизу тяни-тяни :-).


Спецвыпуск Xakep, номер #026, стр. 026-108-2, БУРБУЛЯТОРЫ - оружие новогоднего растамана

БУРБУЛЯТОРЫ - оружие новогоднего растамана

SpelinblimbeR и ХрымZ

Спецвыпуск Xakep, номер #026, стр. 026-108-2

Охлаждаемся

Это мы рассмотрели самый простой вид шайтан-трубы, а теперь соберем из ничего более сложный девайс с водяным охлаждением (а также очищением), именуемый в высших кругах общества кальяном. Отличия состоят в том, что табак, прежде чем попасть в твои чистые легкие, проходит через воду, а тянут в этом случае через трубку, которую придется постоянно держать во рту :). Приступим!

Тебе нужно иметь:

1) ЛЮБУЮ бутылку (лучше взять маленькую стеклянную от колы);

2) кусок резины;

3) две тонкие металлические трубочки (поищи в завалах квартиры - должен найти что-то похожее);

4) металлическую воронку ака чашечку (подбирай размер отверстия под размер твоих трубочек);

5) пластиковую трубочку (я, например, просто отрезал трубку от капельницы :);

6) любое колющее орудие.

Сразу предупреждаю, что я сейчас опишу устройство кальяна, а уже по нему ты сам подберешь детали для сборки. То есть главное - понять механизм, а уж как ты будешь искать воронку - твои проблемы. В редакцию с просьбой выслать не пиши - у самих не хватает :). Итак, берется кусок резины или другого материала, из которого можно сделать пробку. Можно вообще пустую бутылку из-под выпитого под Новый год вина взять вместе с родной пробкой и парой несложных движений превратить ее из бесполезной стекляшки в офигенную конструкцию. Для этого в нашей пробке делаешь два отверстия. С резиной проблем быть не должно, а вот с деревянной пробкой, возможно, придется немного потрахаться. Все зависит от кривизны твоих рук. В любом случае желаю тебе удачи :). Отверстия сделал? Ай, маладца. Теперь бери две металлические трубки и подгони их так, чтобы одна доходила практически до дна емкости, ну или хотя бы была значительно длиннее другой. В общем, в итоге должно получиться так, что длинная трубка должна быть в воде, а короткая - нет. Исходя из этого факта и рассчитывай, сколько воды (а лучше вина!) нужно залить. Теперь самая загадочная часть изготовления. Присобачивание воронки. Точного рецепта нет даже в очень умных книгах, посему подрубай фантазию и твори :). Можно заюзать какое-нибудь подобие металлического блюдца, сделать в нем отверстие и примотать изолентой к трубке. Вполне будет держать - испытывали в полевых условиях! Чашечка вроде держится, теперь просто возьми пластиковую трубочку из-под капельницы или еще откуда и натягивай на металлическую трубку, да, только обязательно на ту, что короче. Та, что длиннее, предназначалась для чашечки. Все, кальян готов. В качестве дополнительных удобств можешь сделать мундштук. Это чтобы не держать пластик во рту, если ты очень брезгливый. Да, чуть не забыл, когда в бульбик что-то залито (вода/вино), не стоит дуть в него. Только в себя тяни. Почему? А ты попробуй в качестве эксперимента :).


Спецвыпуск Xakep, номер #026, стр. 026-108-3, БУРБУЛЯТОРЫ - оружие новогоднего растамана

БУРБУЛЯТОРЫ - оружие новогоднего растамана

SpelinblimbeR и ХрымZ

Спецвыпуск Xakep, номер #026, стр. 026-108-3

На случай, если с кальяном тебе париться лень, - можно быстренько смастерить более простой девайс с водяным охлаждением, в народе он так и называется - водный. Для водного нужны две бутылки разного объема, например, на 2 и 1,5 литра. У бутылки поменьше ножом отрезаем дно, а у бутыли побольше - верхушку, нужно чтобы маленькая бутылка входила в большую. В горлышко меньшей бутылки вставляется уже знакомый нам колпачок из фольги, отличие состоит лишь в том, что в данной модели его не нужно фиксировать. Этот бульбулятор использует элементарные законы физики. В нижнюю бутылку мы наливаем воду и опускаем в воду верхнюю часть с колпачком и волшебным табаком, потом поджигаем и начинаем медленно поднимать верхнюю бутылку (только осторожно, чтобы она не выскочила из воды). Воздух извне начинает устремляться в бутылку, и она наполняется дымом; затем снимаем колпак и (уже медленно опуская бутылку) втягиваем содержимое. Конечно же, ты понимаешь, что вся эта статья предназначена только для того, чтобы ты расширил свой кругозор новыми знаниями о мире, и нечего более. Вот я лично не знаю ни одного человека, который бы курил. Даже сигареты. Честно-честно :). Ну усе, удачного новогоднего курения тебе!

Наши руки не для скуки

Но это все так, подсобные средства для курения - они легко и быстро изготовляются, но выглядят, к сожалению, не очень. До Нового года осталось еще прилично времени, так что ничего не мешает тебе немного отвлечься и заняться сооружением своего собственного бурбулятора. Это может быть просто выточенная из дерева трубка (в отличие от сигаретного табака, для курительной смеси трубка должна иметь решетку с мелкими дырками, иначе ты рискуешь задуть в себя то, что будешь курить) или прикольный кальян, или еще какая-нибудь безбашенная муть. Главное - это уникальность бульбулятора, твой элемент творчества в нем, какой-то маленький прикольчик - в этом вся суть классной Трубки Мира. Импровизируй! На сайте http://works.hop.ru обитает чел, который постоянно мутит разные прикольные бурбуляторы (на картинках они больше похожи на космические корабли). Здесь можно увидеть самые разнообразные модели с мудреными системами охлаждения и перераспределения дыма. Этот сайт интересен еще и тем, что если ты вдруг захочешь замутить нечто подобное - там же найдешь все необходимые руководства, так что дерзай. Оторвись от рутины дней и погрузись в создание собственного уникального бурбулятора, и да пребудет с тобой Джа.

Враг не дремлет

Издревле бурбулятор считался священным предметом и изготавливался шаманами вручную - таким образом шаманы передавали бурбуляторам часть своей энергии. Сегодня западное общество отошло от традиций и в извечной погоне за прибылью поставило производство бурбуляторов на конвейер. Нет, в принципе ничего плохого здесь нет, просто не нужно забывать, что каждый уважающий себя растаман обязан сделать хотя бы один бурбулятор вручную. При соблюдении этого простого правила можно эффективно использовать промышленные образцы Трубок Мира. Они имеют ряд преимуществ - отличаются высокими тактико-техническими характеристиками (т.е. удобны в использовании, практичны, не разламываются в руках в самый ответственный момент и т.п.), как правило красиво оформлены - в общем, такие штуки идеально подходят для клубов и шумных вечеринок. Западная промышленность выпускает простые трубки (как деревянные, так и металлические) и разнообразные вариации кальянов. Может видел в американских фильмах - такая здоровая труба, у которой сбоку торчит трубочка поменьше (в эту маленькую трубочку кладут курительную смесь). Бульбуляторная промышленность иногда просто удивляет своими шедеврами - страшные сны становятся явью :). А еще многие промышленные модели при курении булькают, как и должно быть :).


Спецвыпуск Xakep, номер #026, стр. 026-108-4, БУРБУЛЯТОРЫ - оружие новогоднего растамана

БУРБУЛЯТОРЫ - оружие новогоднего растамана

SpelinblimbeR и ХрымZ

Спецвыпуск Xakep, номер #026, стр. 026-108-4

Растаманы, Джа и Реггей

Если ты все-таки решил на Новый год покурить и даже смастерил или купил для этого трубку, тебе понадобится еще несколько вещей: это табак (рекомендуем яблочный), несколько друзей-растаманов (друзья не-растаманы могут негативно воспринять твою идею насчет курения, так что на время совершения обряда необходимо уединиться вместе с узким кругом посвященных) и, конечно же, магнитофон с реггей. Ты спросишь, а что это за растаманы и где их взять? На что мы ответим - растаманы, в идеале, - это черти, которые исповедуют особенную разновидность христианства, замешанную на африканских верованиях (вот такая вот гремучая смесь), и самым козырным богом у них является Джа. Не будем вдаваться в подробности - у них там много заморочек, основными свойствами растамана являются доброта и жизнерадостность. Растаманам все по кайфу, они загорают на песке, купаются, играют в футбол, курят, слушают музыку - короче, получают удовольствие от жизни, живут сами и помогают другим. Посмотри на своих друзей, найди среди них чуваков, от которых просто прет позитивом - это наверняка растаманы (кстати, растаманы совсем не обязательно должны курить). На Новый год неплохо было бы послушать и реггей. Что это за реггей такой? Реггей - это спокойная веселая музыка, обычно при первых прослушиваниях она не прет, нужно привыкнуть, а потом... Потом она просто начинает нравиться. Вот так, удачного тебе Нового года, и если ты все-таки решил покурить - будь осторожен, бери от этого позитивные ощущения и переноси их в жизнь, старайся сделать ее веселее, и, возможно, мир для тебя преобразится. Да пребудет с тобой Джа!

Ссылки...

Напоследок подкинем-ка тебе несколько ссылок:

http://works.hop.ru - спасибо этому сайту за иллюстрации и полезную инфу. Рекомендуем всем сайт, посвященный странным устройствам, именуемым в народе барбуляторами.

http://cfc.r2.ru/ - конопляный фан-клуб, кое-что интересное можно почерпнуть и здесь.

http://rasta.narod.ru/ - украинский сайт с растаманскими историями.

http://www.bobmarley.com - сайт, посвященный одному из наиболее известных реггей-исполнителей.


Спецвыпуск Xakep, номер #026, стр. 026-112-1, Первый из рода

Первый из рода

Спецвыпуск Xakep, номер #026, стр. 026-112-1

Поступь была тяжелой. Дайл услышал ее издалека - шаги приближались медленно, словно человек, шедший сюда, был либо усталым, либо о чем-то раздумывал. Коридор, освещавший сам себя через поляризованные стены, обычно скрадывал звуки - но в этот раз, наоборот, усиливал. Дайл знал, что это идет Креспин - он ведь сам отправлял Креспину жетон с золотой звездой, личный вызов Мастера. Правда, он не ожидал, что вызванный сюда рыцарь прибудет так быстро.

Из-за поворота коридора показалась мощная фигура Креспина - первого помощника Мастера, Главного Наставника Школы. Держа руку на поясе, он приближался; глаза его были опущены в пол, шаги были насколько медленны, настолько и широки. Дайл, сам того не желая, заметил, что Креспин в своих размышлениях машинально перешагивает швы в пластике, выстилающем коридор, будто находясь в плену какого-то предубеждения перед этими черными полосками.

Остановившись перед самым Дайлом, Креспин поднял на него взгляд и вопросительно посмотрел, не произнося ни слова. Пауза затянулась. Дайл не мог сдвинуться с места и открыть рот; его попытки освободиться от взгляда Наставника ни к чему не приводили. И только когда сам Креспин понял, что его глаза пригвоздили бедного секретаря к полу, это оцепенение пропало - Дайл сумел вздохнуть полной грудью и виновато улыбнулся Креспину, будто бы в чем-то была его вина.

- Мастер... - хрипло сказал Дайл, после чего закашлялся и повторил. - Мастер ждет вас, уважаемый Креспин.

Дверь, перед которой стояли Дайл и Наставник, отъехала с тихим шипением в сторону. В глубине открывшейся комнаты обнаружился стол на возвышении. За ним, спиной к двери, в лучших традициях своего отца, сидел Мастер.

Креспин, вспоминая рассказы друзей, представил себе, как много лет назад в такой же комнате встречал гостей Черный Лорд. Он всегда сидел спиной к дверям - в этом проявлялось его одновременно и презрение к входящим, и полное отсутствие страха перед тем, кто появляется за его спиной. Поговаривали, что Мастер взял эту манеру от Лорда, преследуя те же самые цели. И хотя Креспин старался подавить в себе эти мысли, его не покидала уверенность в том, что всему виной гены - сын не смог далеко уйти от своего отца.

Наставник осторожно постучал по стене рядом с дверным проемом. Мастер сделал вид, что очнулся от каких-то серьезных размышлений и развернулся лицом к вошедшему. «Как он постарел за последнее время, - машинально отметил про себя Креспин, глядя на морщинистое лицо с двумя искрами глаз. - Наверное, ему совсем недолго осталось, пару лет, не больше...»

Тем временем Мастер молча показал вошедшему на большое кресло сбоку от себя. Креспин подошел поближе и опустился в него; кресло немного пошипело, принимая форму, максимально близкую к телу Наставника, после чего успокоилось. Успокоился и Креспин, почувствовав себя поуютнее.

Мастер смотрел куда-то в сторону, за спину гостя. И хотя тот знал, что за спиной никого нет (знал тем особым «знанием», которое не подвело его еще ни разу), вновь проснулась нервозность. Тихий слабый голос прозвучал в тишине неожиданно, несмотря на то, что сил говорить у Мастера было очень мало.


Спецвыпуск Xakep, номер #026, стр. 026-112-2, Первый из рода

Первый из рода

Спецвыпуск Xakep, номер #026, стр. 026-112-2

- Найден новый Источник.

Креспин, сам того не желая, подался вперед, к Мастеру (кресло обиженно пискнуло, пытаясь перерасположить изменившийся центр тяжести). Весть о поисках Источника доходила и до него, но до последнего времени все держалось в строжайшей секретности.

- Его нашла группа, отправленная к Дальнему Пределу. Нашла уже давно...

Чувствовалось, что Мастеру тяжело говорить. После такой длинной тирады голос стал хриплым, появилась одышка; крылья носа раздувались в такт шуму, производимому легкими. Мастер увидел, что Креспин наблюдает за его состоянием, и с силой хлопнул ладонью по зеркальной поверхности стола. Наставник вздрогнул и смутился - он констатировал факт нездоровья Мастера абсолютно случайно.

- С возрастом только вакуум не меняется, - прервал Мастер размышления Креспина. - Повтори, что я сказал.

- Про вакуум?

- Про Источник, Тьма тебя побери! - крикнул Мастер.

Наставник понял, что лучше не шутить.

- Вы сказали, мой господин, что найден Источник в Дальних Пределах...

- Ты прав, - грустно произнес Мастер. - То, что мы так долго искали, находится очень и очень далеко. Условия подключения к Источнику пока неясны. Но без него мы все погибнем...

Креспин заметил, что речь Мастера стала состоять из коротких фраз - судя по этому, ему уже нужен был отдых.

- Какие будут приказания? - спросил Наставник. Ведь его вызвали сюда именно для этого, а не для того, чтобы поделиться мыслями о чрезвычайном открытии.

Мастер, опершись ладонями о стол, медленно поднялся и мягко кивнул головой кому-то незримо присутствующему. В то же мгновенье на стене, на которую он смотрел перед началом разговора, вспыхнул огромный экран с картой звездного неба. Креспин пробежал по ней глазами и не увидел ни одного знакомого созвездия. Мастер, не поворачиваясь, сказал:

- Так выглядит небо, если смотреть на него с той планеты, на которой располагается Источник. Курс уже рассчитан...

Креспин сжал зубы - его отправляют туда, к Дальним Пределам. Он удостоен великой чести - вернуть Источник всем нуждающимся. Он вскочил (кресло от неожиданности причмокнуло воздухом и тут же приняло изначальную форму).

- Я готов выполнить ваши приказания, Мастер Люк!

Люк Скайуокер, Мастер Джедай, опустился на свое место и понимающе кивнул.

- «Магритта» уже заправлена. Ты летишь один.

- Почему у меня не будет второго пилота?

- Там что-то не так... - произнес после некоторого раздумья Люк. - Я надеюсь на лучшее, но все-таки - там что-то не так...

«Он не хочет рисковать кем-то еще, - понял Креспин. - Он и так рискует своим первым помощником...»

- Иди, - кивнул в сторону двери Люк. - Четвертый причал Звездной Гавани, пропуск тебе не нужен. Дела сдай своему заместителю. И запомни - любой ценой... Любой...

Креспин вытянулся в струнку, как в былые времена, когда подчиняться по-военному было принято. После чего повернулся на каблуках и вышел в дверь, услужливо распахнувшуюся перед ним.

Когда дверь закрылась, Мастер Люк неуловимым, отнюдь не старческим движением вынул из встроенного сейфа черный шлем своего отца, положил перед собой на стол и пристально всмотрелся в глубину зеркальных стрекозиных глаз. Где-то там, внутри, был ответ...


Спецвыпуск Xakep, номер #026, стр. 026-112-3, Первый из рода

Первый из рода

Спецвыпуск Xakep, номер #026, стр. 026-112-3

Мастер тяжело вздохнул и надел шлем себе на голову. Иногда он хотел почувствовать себя Дартом Вейдером...

*********

Когда Лузянин понял, что у него получается, он откатился в кресле от компьютера на несколько метров (благо, размеры зала позволяли это), крутнулся на нем пару раз и закричал:

- Йе-е-хху!

Воинственный индейский клич, полный радости, не был услышан никем - Лузянин был один. Не с кем было разделить успех - да ученый и не стремился пока это делать. Работа была еще не закончена, однако потенциально задача решена - причем решена даже проще, чем казалось изначально, при постановке условия. Во время работы обозначился один фактор, не предусмотренный ученым, - и это перевернуло некоторые постулаты генетики, которая для Лузянина была основным полем деятельности и приносила ему хлеб насущный.

- Всего двести пятьдесят! - взбудоражено подскочив с кресла, Лузянин подошел к окну широкими, просто гигантскими шагами, отмеряя каждый будто циркулем. - Я рассчитывал, что работать надо будет еще около двух недель, что звеньев в цепи где-то около пяти тысяч, но, черт возьми!..

Эмоции захлестнули его огромной, как девятый вал, волной адреналина. Он смотрел в окно с высоты двенадцатого этажа на институтский парк и не замечал всей его красоты, думая о своей жене...

Почти десять лет назад в такой же яркий и солнечный октябрьский день подонок по прозвищу «Индиана Джонс», серийный убийца и маньяк, державший в ужасе весь Академгородок в течение трех месяцев, совершил свое последнее и самое жуткое преступление. Застрелив безо всякой причины восьмерых человек с интервалом в десять дней, он принял изрядную дозу наркотика и попытался покончить с собой, подчиняясь импульсам воспаленного рассудка - но не смог этого сделать.

Он сидел на горячей батарее в подъезде, где жил Лузянин со своей женой Кирой, - на седьмом этаже, площадкой ниже их квартиры. В день после защиты кандидатской молодой доцент собрался посетить с женой местный ресторан «У Альберта» (тот, на крыше которого горела огромная вывеска «Е=МС2»). Чета Лузяниных, выйдя из квартиры, закрыла за собой дверь; Кира шла впереди и успела сделать только три шага по лестнице вниз.

«Индиана» увидел их, когда они стали спускаться. Так они и встретились - двое молодых перспективных ученых и безумец, засунувший себе пистолет в рот. Заметив недоуменные испуганные взгляды, маньяк медленно вытащил ствол изо рта, аккуратно вытер слюну, стекавшую с него, о рукав куртки, и выстрелил несколько раз в Киру...

Она осталась жива. Осталась жить в этом мире благодаря чуду, искусству врачей и любви своего мужа. Она боролась, цеплялась за жизнь два с половиной месяца - и сумела выжить.

Грубый рубец на шее - там, где пуля вырвала кусок мышцы, - она смогла скрыть, отрастив длинные густые волосы. Хромоту тоже было практически не видно - колено заменили искусственным (правда, совсем не обнадежив тем, что срок работы протеза был не более двадцати пяти лет). Но вот две пули, которые вонзились в ее яичники и превратили их в кровавую кашу...


Спецвыпуск Xakep, номер #026, стр. 026-112-4, Первый из рода

Первый из рода

Спецвыпуск Xakep, номер #026, стр. 026-112-4

Семья Лузяниных была обречена - на бездетность. Кира, конечно, не заостряла на этом внимания, но Лузянин видел, что эта проблема стала неразрешимой, материнские инстинкты раскачивали и без того лабильную нервную систему жены, ставшую после ранения истеричной, плаксивой, легко ранимой, боящейся темноты и лестничных клеток.

И тогда он начал свою работу. Работу, которой отдал десять лет своей жизни. Сегодня она будет закончена - и у его Киры через девять месяцев будет ребенок. ИХ РЕБЕНОК.

...Ученый отвлекся от своих мыслей. Руки, сложенные на груди, нервно подрагивали. Он находился сейчас в той фазе своих исследований, когда четко знаешь, чем все закончится, знаешь каждый свой шаг на ближайшие несколько дней - и руки не успевают за мыслями, не могут догнать их, как ни стараются. И возникает боязнь не успеть, забыть, потерять, нарастает нервозность, появляются ошибки...

Лузянин знал обо всем этом, знал и о том, как это победить. Он снял с себя белый халат, повесил его на спинку стула, после чего разделся до трусов и выполнил несколько упражнений «у-шу». Дыхание стало ровнее, потные ладони высохли - он был готов на спор выбить сейчас десятку с первого раза в институтском тире.

Внутри все улеглось на свои места - Лузянин прислушался к своему организму и довольно улыбнулся. Он знал, что теперь его работа будет закончена правильно и в срок. Вернувшись в привычный образ (одевшись, накинув халат на плечи), он опустился в кресло и подъехал к компьютеру.

- Сегодня, - сказал он себе. - Двести пятьдесят фрагментов. Я сделаю это - или я бездарность, которой место в... в...

Он промучился несколько секунд, пытаясь определить свое место в этом мире в случае неудачи - не нашел, усмехнулся, скинул халат на пол и положил руки на клавиатуру.

- Ну, с богом, - произнес он и продолжил анализ генной цепочки. И гены, повинуясь компьютерной мощи, стали выстраиваться в нужном порядке, формируя хромосомы - на сегодняшний день незаконченными остались лишь две. Всего двести пятьдесят генных фрагментов. Двести сорок девять. Двести сорок восемь.

И он не замечал, что уже семьдесят часов ничего не ел...

Когда челнок Креспина вынырнул из гиперперехода вблизи орбиты Марса, Лузянину оставалось проанализировать всего лишь семнадцать фрагментов последней пары хромосом своего будущего ребенка.

*********

Внизу расстилалась голубая планета, наполовину скрытая облаками. Креспин, медленно приходивший в себя после коррекции сознания, необходимой для возвращения воспоминаний и умений, утраченных в результате воздействия изнанки пространства, попытался пошевелить руками. Пальцы повиновались с трудом.

Через несколько секунд в голову ворвалось его собственное имя. Он вспоминал, как его зовут, кто он и откуда, информация вливалась в размороженное сознание прямым мощным потоком. Над головой раздалось несколько мелодичных гудков...


Спецвыпуск Xakep, номер #026, стр. 026-112-5, Первый из рода

Первый из рода

Спецвыпуск Xakep, номер #026, стр. 026-112-5

Креспин приподнял голову. Практически из ничего в пустом пространстве кабины возникали пульт управления, экраны, оружие. Знакомые с детства приборы; привычные для глаза огоньки.

В горле застыл комок вязкой слюны. Креспин откашлялся и ощутил на своей груди ремни. И в этот момент он, наконец-то, осознал все происходящее полностью - от начала и до конца. Он, Главный Наставник школы джедаев, был направлен Люком Скайуокером в эту область Вселенной с целью найти Источник Силы и вернуть цивилизации былое могущество. И сейчас он находится где-то в непосредственной близости от этого Источника - маленький радар прямо перед глазами методично попискивал и мигал темно-фиолетовым огоньком, говоря о наличии Силы в радиусе нескольких тысяч километров.

Сердце Креспина забилось сильнее. Уже очень давно этот огонек вспыхивал только при приближении к Школе или резиденции Мастера; уже много лет джедаи не слышали этого так радующего слух звука. Наставник приказал креслу перейти в вертикальное положение; распахнутое в космос окно пилотской кабины оказалось прямо перед глазами Креспина.

Планета с орбиты казалась достаточно большой. Опытный глаз рыцаря мгновенно определил расположение материков, основных мегаполисов, магистрали сообщений и плотность загрузки околокосмического пространства. Он прекрасно понимал, что у планеты с такой плотностью населения и высоким уровнем технического развития наверняка есть способы засечь в космосе неопознанный объект, появившийся практически из ниоткуда среди подобных себе учтенных летательных аппаратов. Поэтому нужно было поторопиться.

Приборы проводили анализ заселенности планеты. Выходило, что существуют достаточно большие территории для незаметной посадки - огромные пространства были не заселены (правда, эти места были покрыты либо лесом, либо водой, но Креспина такие моменты не останавливали). Достаточно быстро техника определилась с местом приземления (учитывая расположение сигнала Источника), Наставник сверился с полученной за считанные минуты картой планеты, лежащей сейчас под ним и дал команду на посадку. Автоматика послушно направила корабль вниз...

*********

Клавиши щелкали сухо, торопливо и упорядоченно. Громче всех клацал пробел - им Лузянин разворачивал структуру очередного гена.

За окном уже давно стемнело, мрак поглотил комнату. Светившийся экран освещал порхавшие над клавиатурой руки профессора. Изредка он бросал взгляд в сторону большого лабораторного криогенератора - указатель температуры на нем полз вверх неуклонно уже третьи сутки, отмечая каждый десяток градусов густым коротким гудком.

- Сегмент номер шестнадцать-А... - бормотал Лузянин. - Переместить... Этот участок явно бракованный... Ух ты! - удивился он, услышав, как громко и нетерпеливо заурчало у него в животе. - Сегмент номер шестнадцать-Б...

Раздался очередной гудок криогенератора.

- Минус семьдесят, - удовлетворенно отметил профессор. - Через двенадцать часов будет готово. И я назову его Андреем.

О том, каким должно было быть имя их ребенка, Кира говорила часами. В такие моменты Лузянин был готов провалиться сквозь землю - настолько трагичными были подобные разговоры. Жена относилась к ним со всей серьезностью, перебирала множество вариантов - профессор чувствовал себя предателем, зная о том, что ее мечта может сбыться со дня на день, но будучи не в состоянии сказать ей всю правду, чтобы не допустить никакой утечки информации. Привыкнуть к этим разговорам Лузянин так и не смог - каждый раз с трудом сдерживал слезы, находил какой-нибудь предлог выйти из дома и прогуляться.


Спецвыпуск Xakep, номер #026, стр. 026-112-6, Первый из рода

Первый из рода

Спецвыпуск Xakep, номер #026, стр. 026-112-6

Конечно, Кира не сошла с ума, но настолько зациклилась на своей проблеме - невозможности зачать ребенка, - что временами мужу казалось, что ее рассудок может дать трещину. Лузянины вместе ходили к семейному врачу, жена занималась с психотерапевтом - подобные методы воздействия на сознание давали свои плоды, Кира прекращала разговоры о ребенке как о чем-то потенциально возможном в ее положении. Лишь длинный рубец на животе периодически напоминал ей о выстрелах «Индианы Джонс» - и Лузянин четко научился определять, когда это происходит. В такие интимные моменты он заставал ее в расстегнутом платье перед зеркалом разглядывающей побледневший послеоперационный рубец. Кира медленно гладила живот, будто представляла себя беременной (так это все казалось Лузянину), глаза ее в такие моменты блестели от слез - и через два-три дня можно было уже идти к психотерапевту.

Тяжелее всего дались ученому последние два года семейной жизни. По-видимому, материнский инстинкт включился в Кире на максимально возможную величину, она стала поговаривать о том, чтобы взять ребенка из детского дома, потом начала изучать тему суррогатных матерей (что привело Лузянина просто в ужас) - профессору пришлось провести несколько душещипательных бесед со своей женой, чтобы хоть как-то нейтрализовать все происходящее. К тому времени он уже вел работу по созданию (если можно так сказать) собственного ребенка - и ему не нужны были ни детдомовцы, ни суррогатные мамы.

Когда работа начал подходить к логическому завершению, Лузянин отправил Киру к своей матери, чтобы исключить все возможные проблемы. Дав маме указания, как себя вести в случае возникновения стандартной ситуации под названием «Материнский инстинкт», он с неспокойной душой отправился в институт, где и жил безвылазно уже в течение двух месяцев, вселяя уважение в сердца своих коллег и учеников упорством в достижении цели (о которой они, кстати, не имели никакого представления).

Работа продвигалась довольно туго - как тяжело обычно бывает первопроходцам, не знающим точного направления. Профессор, привыкший к многолетней рутине разгадывания кода ДНК, внезапно испугался, что не сумеет достойно закончить свое исследование и создать то, к чему стремился. Он стал много курить; уборщица, приходившая по утрам, выгребала за ним из пепельницы огромное количество окурков, ругалась про себя, но профессора жалела - через две недели после его добровольного заточения в институте принесла ему пепельницу побольше (в душе Лузянин понимал, что от этого выиграла только сама уборщица - ей стало удобней выносить мусор из кабинета).


Спецвыпуск Xakep, номер #026, стр. 026-112-7, Первый из рода

Первый из рода

Спецвыпуск Xakep, номер #026, стр. 026-112-7

Трижды он едва не запорол всю работу, получив сомнительные результаты и использовав их на последующих этапах без тщательной перепроверки. Но всякий раз после очередной ошибки он брал себя в руки, возвращался к исходному моменту и, прежде чем продолжить, смотрел на фотографию Киры - взгляд жены, отдающий огромное количество теплоты, вселял уверенность.

Вообще, на заключительном этапе неудачи преследовали его гораздо чаще - будто бы природа возмутилась и не хотела, чтобы результаты работы Лузянина обрели материальное воплощение. Как-то раз во время длительного расчета генома одной из хромосом в институте погас свет, похоронив итог почти двухдневного вычисления - и это отшвырнуло Лузянина на пару недель назад. Профессор сумел все восстановить - и на очередном не менее ответственном этапе заснул за компьютером с сигаретой в зубах. Пепел упал на лежащую на столе дискету с полученной тремя часами ранее формулой, расплавил чувствительную пластмассу - и Лузянин бился в истерике у окна примерно тридцать минут, поняв, что забыл сделать бэкап. Короче, жизнь била профессора - но и он не оставался в долгу.

Директор института пару раз вызывал Лузянина к себе, пытаясь выяснить, в чем дело, почему его сотрудник живет в институте, превратив лабораторию в спальню, а зал для расчетов - в подчиненный одной непонятной цели массив компьютеров. Профессор был немногословен, прикрылся чуть ли не Нобелевской премией, чем усыпил бдительность директора, и добился его расположения. С Лузянина были сняты все возможные ограничения по использованию вычислительной мощности института (когда еще найдется ученый, замахнувшийся на Нобелевку!); ученый был оставлен в покое; в ожидании результатов директор иногда заходил к Лузянину в гости, молча стоял в дверях, кивал головой, словно понимая, что здесь происходит, после чего уходил, оставаясь в таком же неведении, в каком и был.

- Где эти чертовы сигареты? - похлопав себя по карманам, выругался Лузянин. - Вечно их нет на месте!

Оставалось лишь пять фрагментов. Силы были на исходе. От гипогликемии шумело в голове, на расстоянии от Лузянина ощущался характерный запах ацетона, возникающий у людей, находящихся на длительном голодании.

- Сейчас главное - выдержать, - сказал сам себе профессор. - Надо досчитать оставшиеся - а потом я лягу спать и буду дрыхнуть до семи вечера. А к тому времени криогенератор полностью выключится, и можно будет приступать к последнему этапу.

Похлопав себя по щекам, Лузянин еще раз огляделся, нашел пачку «Мальборо» под столом, вытащил очередную сигарету и закурил. Дым от первой затяжки он машинально выпустил в монитор, на экране которого яркими красками отображалась структура последней хромосомы - выдохнул, словно в лицо злейшего врага.

- Я тебя сделаю, - коротко бросил он фразу в экран. - Я смогу.

Он бросил взгляд на стоящую на границе света и тени фотографию жены, покрепче зажал в зубах сигарету, сдвинув ее в угол рта, чтобы дым не попадал в глаза, и вновь опустил пальцы на клавиши.


Спецвыпуск Xakep, номер #026, стр. 026-112-8, Первый из рода

Первый из рода

Спецвыпуск Xakep, номер #026, стр. 026-112-8

*********

Фиолетовый огонек радара не гас ни на секунду. Сила была где-то рядом, писк стал назойливым - до такой степени, что Креспин решил его отключить, достаточно было световой индикации. Рыцарь не удивлялся информированности Люка - он уже перестал удивляться тому, чему не могло быть объяснений.

Подойдя вплотную к высокому зданию института, Креспин задрал голову вверх и посмотрел ввысь вдоль стены. Где-то там, в одном из помещений, находился Источник Силы. Не найти его было просто невозможно.

Джедай на несколько секунд отключился от окружающего мира, погрузился в себя, убедился в истинности своих собственных намерений, в их чистоте и необходимости, после чего направился к вращающемуся турникету на входе. Его шаги звучали в здешнем воздухе глухо и подозрительно; казалось, что из каждого окна на него смотрит некто, открывший его настоящую сущность...

Когда в дверях он столкнулся с человеком, на ходу вытаскивающим из кармана белого халата деньги, то не обратил на него внимания. Перед глазами лишь мелькал фиолетовый огонек, направляющий Креспина к Силе. Человек же, наткнувшись на просто-таки железное плечо рыцаря, развернулся и хотел сказать вслед что-нибудь резкое, но слова сами застряли в горле - фигура рыцаря продолжала удаляться в фойе, производя колоссальное впечатление человека, не замечающего ничего вокруг.

- Черт бы побрал всех этих проходимцев, - буркнул вслед Креспину Лузянин, вышедший в киоск за сигаретами. - Прутся, как к себе домой.

Плечо заныло и отпустило - ушиб был так себе, ничего особенного. Профессор кинул последний взгляд на незнакомца, скрывающегося в лифте, и направился к институтскому киоску, торгующему периодикой, сигаретами и канцелярскими принадлежностями. По пути он прикинул, на сколько еще ему хватит денег, попытался выкроить несколько монет на триста граммов печенья, но поскупился, взял лишнюю пачку «Золотой Явы» и пошел обратно.

Погода явно портилась, вместе с ней менялось и настроение профессора. Еще час назад решительно расправившийся с последними сомнениями Лузянин вновь вступил в борьбу с компонентами этики, застрявшими в его мозгу с детства. Вправе ли он так поступать со своей женой? Поймет ли она всю мощь эксперимента и оценит ли жертву - десятилетний труд над расшифровкой кода и созданием искусственного, синтезированного из биоматериала набора хромосом? Согласится ли вынашивать ребенка?

Профессор засомневался - и очень сильно. Подойдя к турникету, он остановился, посмотрел в пол и не решился пройти дальше. Необходимо было войти в согласие с самим собой - для этого Лузянин посчитал пульс на левом запястье, несколько раз глубоко вздохнул и принял решение прогуляться вокруг институтского корпуса. «Думаю, двух кругов будет достаточно», - решил ученый, мысленно проследил свой путь от начала и до конца, после чего сделал первые шаги. Вначале они давались ему с трудом, пытливый профессорский ум сопротивлялся, звал наверх, в лаборатории - но Лузянин переборол себя, сосредоточился на природе окружающего парка и принялся отмерять метры асфальтированной дорожки, бубня себе под нос Есенина. Постепенно он отрешился от проблемы (так, как он умел это делать в случаях, подобных сегодняшнему), начал обращать внимание на позолоченные деревья бабьего лета и несколько раз даже ответил на приветствия студентов, проходивших мимо него.


Спецвыпуск Xakep, номер #026, стр. 026-112-9, Первый из рода

Первый из рода

Спецвыпуск Xakep, номер #026, стр. 026-112-9

За спиной слышались удивленные возгласы ребят, привыкших к «неземному» образу жизни профессора, пребывающего постоянно где-то далеко отсюда, в мире своих научных фантазий. За прошедшие годы он снискал себя славу человека малообщительного, спускающегося с небес только для чтения лекций и докладов на съездах и симпозиумах; в результате его образ нелюдима ассоциировался у студентов с фундаментальной наукой вообще, что не делало ей («Науке» с большой буквы) особой чести. Студенты провожали его взглядами, в которых смешивались восхищение и удивление, уважение и насмешка, присущая молодости - той самой молодости, которой свойственно ошибаться. «Недостаток, который быстро проходит...» - думал Лузянин, прекрасно представляя, что ближайшие минут пять разговоры за его спиной будут направлены на его персону - до тех пор, пока не найдется новый повод поговорить.

Вспоминая себя молодым и полным сил студентом, он грустно улыбался. Не так хотел он прожить свою жизнь, но...

- Коней на переправе не меняют, - произнес вслух профессор и оглянулся - не подслушал ли кто вырвавшуюся из его уст фразу. - Судьба...

Вычеркнуты ли из жизни годы, потраченные на открытие законов моделирования искусственных хромосом, или они станут величайшим событием не только в его жизни, но и в жизни всего мира? Профессору очень хотелось верить в нужность происходящего; находясь на финишной прямой, нельзя сомневаться в необходимости финишировать. Это равносильно тому, как если бы бегун на стометровку в нескольких метрах от финишной ленты решил бы посоветоваться с тренером, какой ногой перешагнуть черту. Да и не было у Лузянина подобного тренера.

Профессор и не заметил, как его прогулка подошла к концу. Вновь перед ним турникет дверей; он поднялся по нескольким ступеням, ведущим к проходной, и еще издалека попытался разглядеть огонек рядом с дверью лифта - если бы тот оказался занят, можно было бы успеть выкурить на крыльце еще одну сигарету.

Огонек горел мутным желтым светом. Профессор вытащил пачку сигарет и закурил, наслаждаясь дымом так, как только мог Сократ наслаждаться чашей с ядом. Он смотрел с высоты институтского крыльца на прогуливающуюся молодежь и думал, что скоро у него будет ребенок...

*********

Стоя в лифте, Креспин пытался создать в голове образ цивилизации, с которой он сейчас контактирует. Судя по всему, уровень технологий невысок. Джедай с сожалением улыбнулся - он плохо понимал, как можно обходиться без тех прелестей прогресса, что доступны в его обществе. Медленные средства передвижения в пространстве - что может быть хуже?

Лифт скрежетал, напоминая Креспину звук, издаваемый тренировочными дроидами. Цифры достаточно быстро сменяли друг друга на табло над дверями; через минуту Креспин добрался до двенадцатого этажа, который он по какому-то наитию выбрал для себя целью.


Спецвыпуск Xakep, номер #026, стр. 026-112-10, Первый из рода

Первый из рода

Спецвыпуск Xakep, номер #026, стр. 026-112-10

Створки отползли в стороны, явив взору рыцаря довольно большой холл с огромными лиственными кустами в деревянных горшках. На противоположной от кабины стене было распахнуто окно, в котором виднелось осеннее облачное небо. Людей видно не было.

Креспин шагнул из лифта на ковровую дорожку, вытертую в нескольких местах сотнями, тысячами ног, прошедших по ней за года существования института. Посмотрел в обе стороны - коридор уходил вправо и влево на несколько десятков метров; в стенах виднелись закрытые деревянные двери.

Рука джедая по привычке нащупала на поясе меч; но опасности не было, рыцарь чувствовал это. Люди, населяющие это здание, не представляли физической угрозы для такого подготовленного к неприятностям бойца, как Креспин. Скорее, наоборот - сам джедай был опасен для них своей абсолютной нацеленностью на результат.

«Там что-то не так...» - вспомнились Креспину слова мастера Люка. Джедай не двигался с места, пытаясь определиться с дальнейшими планами. Выяснить, что здесь не так, можно было, лишь начав действовать. Но прежде чем Креспин сделал первый шаг, он ощутил в себе растущее беспокойство - у него впервые за много лет служения ордену джедаев возникло чувство, что мастер Люк ошибся.

«На ловушку это непохоже, - пытался рассуждать рыцарь. - Скорее, это напоминает заблуждение... Но мастер не заблуждается. Что тогда? Расчет? Испытание? Или решение появилось на свет в результате отсутствия полной информации - как тогда, когда мастер Йода принял в орден джедаев Энекена Скайуокера?»

В это не хотелось верить. Креспин помотал головой из стороны в сторону, прогоняя мысли, вселяющие сомнения. Нужно было действовать - цель была совсем рядом. Организм джедая, всегда настроенный на контакт с волнами Силы, уже несколько минут ощущал воздействие, исходящее из одной из комнат на этом этаже - растущее тепло в затылке, учащение пульса, все говорило о том, что рядом есть еще один джедай. Или то, что рядом Источник.

«Странно, - вдруг подумал Креспин. - Я понятия не имею, как он выглядит. Перешагнуть тысячи световых лет - чтобы не знать, что в конечном итоге является целью путешествия. Люк всегда говорил, что настоящий джедай в состоянии отличить фонарь от лазерного меча - несмотря на то, что луч света присутствует в обоих. Судя по всему, я пойму, что Источник передо мной, - надо только найти его... И самое главное - любой ценой... Неужели наши дела так плохи?»

Поборов сомнения, джедай шагнул в том направлении по коридору, которое казалось ему наиболее подходящим. Двери медленно сменяли друг друга по разные стороны коридора, одинаковые, безликие, выкрашенные в белый цвет, с номерами вверху - справа четные, слева нечетные. Креспин не спешил, хотя и предполагал, что в его распоряжении не так уж много времени; он шагал, опустив глаза в ковровую дорожку с примитивным геометрическим узором, и вслушивался в свои ощущения.

Вот за этой дверью с номером 1203 никого не было - причем уже очень давно; никто не входил и не выходил из комнаты, скрывающейся за дверной створкой несколько месяцев. Напротив, за дверью 1204, скрывались две курящие женщины молодого возраста. Через пару шагов Креспин догадался, что помещения 1203 и 1204 были туалетными комнатами, причем 1203 временно не функционировало (джедай даже сумел проследить ход санитарных коммуникаций и найти уровень засора, но в следующее мгновение пресек всякие мысли, отвлекающие его от основной задачи).


Спецвыпуск Xakep, номер #026, стр. 026-112-11, Первый из рода

Первый из рода

Спецвыпуск Xakep, номер #026, стр. 026-112-11

«Рыцарь-сантехник! - усмехнулся Креспин, подобрав слово из лексикона жителей планеты, на которой он сейчас находился. - Да хранит меня Сила от этого!»

Дальше по коридору за дверями не было практически никого, так, единичные экземпляры, занимавшиеся, в основном, разгадыванием кроссвордов. Креспин не удивлялся этому по одной простой причине - он понятия не имел, чем в действительности должны были заниматься эти люди. Да и откуда ему было понять, что такое «обеденный перерыв»...

Пару раз он бросил взгляд на фиолетовый огонек карманного радара. Интенсивность его не менялась - но уже не потому, что Креспин ошибся в выборе. Просто его способность уточнить расположение Источника в пространстве была не очень велика. Одно рыцарь знал точно - Сила была на этом этаже.

Возле предпоследней по четной стороне двери под номером 1224 Креспин остановился, словно войдя в густой туман. Его сознание заволокло пеленой, ноги с большим трудом продвигали тело вперед, преодолевая невидимую глазам преграду. Джедай остановился.

Сердце забилось быстрей, пальцы рук стали ватными - но рыцарь нашел в себе силы обхватить рукоять меча и нащупать кнопку включения. Потом медленно повернулся к двери, из-за которой бил поток Силы, и внимательно всмотрелся в нее, проникая взглядом внутрь комнаты.

Там никого не было - только аура человека, находившегося здесь около получаса назад. Креспин сделал шаг к двери и протянул руку к дверной ручке, отведя другую руку с мечом в сторону для замаха. Легкое касание, привычное басовитое гудение - меч полыхнул темно-зеленым светом, вырастив метровое энергетическое лезвие.

Дверь открылась легко - она не была заперта. С легким скрипом отворилась - и пропустила внутрь Креспина. Джедай осмотрел комнату с порога - несколько компьютеров очень древних конструкций, три стола, большое количество лабораторной стеклянной и фарфоровой посуды. В дальнем углу - диван, покрытый небрежно наброшенным пледом. В помещении сильно пахло дымом («Никотин», - вспомнил Креспин название наркотика, существующего в нескольких известных ему мирах).

В кармане плаща что-то пискнуло и громко треснуло. Креспин выключил меч, повесил его на пояс и сунул руку за пазуху. На свет был извлечен треснувший пополам радар - его корпус не выдержал потока Силы и оказался не в состоянии оценить его, не хватало запаса прочности. Креспин удивленно смотрел на испорченный радар. Такого он не ожидал найти на этой планете.

В этом помещении Сила была везде. Она била из всех углов комнаты мощными лучами, пронизывающими пространство. Она заставляла чувствовать себя жалким, ничтожным существом; она давила, мешала дышать, останавливала сердце, затуманивала разум. Она воспламенила кровь Креспина, вызвала в нем адреналиновый взрыв, подкосила ноги. Она напугала его и заставила вспомнить слова Мастера Люка: «Там что-то не так...».


Спецвыпуск Xakep, номер #026, стр. 026-112-12, Первый из рода

Первый из рода

Спецвыпуск Xakep, номер #026, стр. 026-112-12

Здесь действительно было что-то не так. Сила не могла быть такой - и одновременно это было прекрасно! Ощущать себя заново родившимся - кому не хотелось этого? Здешняя новая Сила давал именно это ощущение; старый джедай, проживший уже почти сто шестьдесят лет, радовался как ребенок. Включив меч, он сделал несколько выпадов в пустоту - и кисти его рук сумели выполнить очень сложные приемы, которые в школе рыцарей использовали хвастуны-старшекурсники, чтобы произвести впечатление на девушек из Академии. Когда-то эти упражнения с мечом были для Креспина не в диковинку - вот и сейчас Сила возвращалась к нему...

*********

...Лузянин бросил второй окурок себе под ноги, растер его, отшвырнул носком ботинка в сторону (что было очень на него не похоже - на всегда аккуратного и следующего приличиям интеллигента). После чего решительно отвел рукой турникет, войдя в него и крутанув у себя за спиной с силой шаловливого подростка. Железная вертушка издала жалобный скрип, провожая профессора к лифту...

*********

Очнувшись от собственных мыслей, Креспин обнаружил, что стоит у окна с рассыпающим искры мечом, а за спиной у него лежит на полу разрубленный надвое стол. Это окончательно вернуло Креспина к действительности. Он убрал свое оружие и опустился на стул перед включенным, но спящим компьютером. Джедай довольно быстро определил способ хранения информации, найдя аналоги в далеком прошлом («Все-таки основные вещи в этой Вселенной нерушимы...»), после чего сумел добраться до нужных файлов. И это вогнало его в ступор всерьез и надолго.

Он сидел и смотрел в экран невидящим взглядом, не замечая, как по экрану ползут строки расшифрованного кода человеческой ДНК; не замечая, как выстраиваются в строгие ряды хромосомы не рожденных еще людей; не чувствуя, как рушится весь его мир, благословленный несколько сот лет назад учителем Йодой. Он на самом деле не видел сейчас перед собой ничего, сраженный догадкой, в очередной раз подтверждающей прозорливость Люка Скайуолкера.

В ЭТОЙ КОМНАТЕ ДЕЛАЛИ ДЖЕДАЕВ.

Некто, создавший все то, что видел сейчас перед собой Креспин, обладал небывалым могуществом - он нашел способ создавать джедаев... Делать их - как вещь.

- То, что мы обретали годами упорных тренировок... - шептал Креспин. - Идеология, мифология, взлеты и падения, принципы существования! Кто этот бог, что сумел создать подобных нам? Гений? Удачливый ученый, сумевший поставить некую случайность себе на службу?

Но рассуждать было некогда. Креспин скопировал информацию, после чего собрался уходить, чтобы более тщательно проанализировать ее на корабле, но вновь увидел, какой беспорядок произвел в комнате во время упражнений с мечом - и понял, что возвращаться на «Магритту» нет смысла. Нужно дождаться того, кто все это сделал. Человек, вдыхавший здесь никотин, ушел, по-видимому, недавно и мог вернуться в любую минуту.


Спецвыпуск Xakep, номер #026, стр. 026-112-13, Первый из рода

Первый из рода

Спецвыпуск Xakep, номер #026, стр. 026-112-13

Креспин встал из-за компьютера и прошелся по комнате, пытаясь представить, о чем он будет говорить с тем, кого встретит - смогут ли они найти общий язык? Знает ли этот человек, что скрывается за выращенными им хромосомами?

На одной из стен комнаты, скрытой полосой мрака, рожденной плотными пыльными шторами, Креспин увидел фотографию в толстой полированной рамке - мужчина и женщина, державшиеся за руки, на фоне широкого чистого пруда; их улыбки были в чем-то похожи, они радовались самим себе, погоде, обычному человеческому счастью - и от снимка (Креспин чувствовал это, как никогда раньше не ощущал закрытые для простых людей эмоциональные стороны, рожденные Силой) исходила волна любви - всепоглощающей, возвышающей... И мужчина, запечатленный на фото, должен был скоро войти в эту комнату.

Еще раз внимательно оглядевшись, Креспин в ожидании хозяина опустился за компьютер и принялся просматривать структуру ДНК - ведь и его клетки были устроены подобным образом. Причудливые переплетения аминокислот создавали иллюзию какого-то фрактального узора, созданного ради развлечения. Вот первая пара хромосом, вот вторая, третья, десятая... Джедай чувствовал, что перед ним раскрывается тайна всей жизни - кто он и откуда пришел, зачем он живет и как... Никогда до сегодняшнего момента Креспин не задумывался над происхождением и влиянием Силы, пользуясь лишь ее плодами. Он, конечно, помнил о той химии в крови, что отличает его от простых людей; правда, с течением времени даже название этого вещества стерлось из памяти, но никто и никогда не забывал, как Энекен стал Черным Лордом благодаря именно этой гадости...

Что-то не понравилось ему в пролетающих мимо строчках. Креспин не смог уловить момента, когда это случилось, но его посетило ощущение мимолетного огреха в коде ДНК. Он остановил прокрутку, вернулся на несколько участков назад - безрезультатно. Рыцарь никак не мог составить впечатление о том, что именно его заинтересовало и привлекло - но это-то «что-то» было крайне важным, выпадающим из общей стройной картины генотипа джедая.

Креспин придвинул стул поближе к компьютеру, положил руки на клавиатуру (в мозгу проскочило что-то вроде яркой вспышки - и он уже понимал принцип ввода команд). Приложения, запущенные на компьютере, были, естественно, непонятны рыцарю - но он разглядывал формулы и схемы хромосом интуитивно, не вникая в возможность управления ими. Он проникал внутрь кода ДНК рыцаря-джедая - спирали аминокислот опутывали его, заставляя голову кружиться, ноги слабеть и холодеть, кончики пальцев, лежащие на клавишах, стали чужими. Пару раз Креспин проваливался в забытье, но вновь и вновь выныривал из транса, продолжая со скоростью процессора прослеживать тонкие структуры главной загадки жизни.

Он будто бы летел над вечностью. Под ним с огромной скоростью проносились века и тысячелетия, цивилизации и чудеса света, люди и... И не-люди. И везде, всюду, все упиралось в ДНК. С нее все началось - и разум, и любовь, и... Джедаю не хватало сил и возможностей выразить всю полноту эмоций, охвативших его при проникновении в глубину собственной Силы - и он отдался тому течению, что несло его, несло, несло...


Спецвыпуск Xakep, номер #026, стр. 026-112-14, Первый из рода

Первый из рода

Спецвыпуск Xakep, номер #026, стр. 026-112-14

И когда он понял, что наконец-то нашел то, что искал, его ощутимо, ФИЗИЧЕСКИ вышвырнуло из потока - удар казался реальным, возвращающим из таинственного полета, словно его «Магритта» сбита в бою с пришельцами с далекой планеты и падает вниз, вниз, вниз...

Креспин открыл глаза, которые, оказывается, были закрыты все это время. Перед ним на экране горел кусок кода, подсвеченный красным. В коде была ошибка.

За спиной скрипнула дверь. Креспин вздрогнул и обернулся, наступив на полу плаща, из-за чего его движение получилось неуклюжим и испуганным. В проеме стоял человек, в изумлении разглядывающий комнату, переводя взгляд с разрубленного стола на гостя за экраном монитора и обратно.

Встреча была неожиданной, не предусмотренная джедаем и внезапной для Лузянина. Но все выглядело так, будто Креспин ждал ученого, чтобы указать ему на ошибку. Его недоуменный жест, предлагающий профессору войти и объяснить происходящее, сказал Лузянину больше, чем какие-либо слова. Сняв халат и повесив его на маленький крючок у входной двери, Лузянин аккуратно перешагнул обгоревшие края обломков стола, словно это было для него обыденным явлением, и приблизился к Креспину.

Джедай еще даже не успел задуматься над тем, как они будут общаться, а профессор уже подошел вплотную, жестом показал Креспину, что тот стоит на собственном плаще (джедай нервно и виновато освободился и предложил Лузянину сесть на его место за компьютером). Профессор опустился на теплый после гостя стул, взглянул в экран и вопросительно посмотрел на стоящего рядом человека в плаще.

Креспин открытой кверху ладонью указал на экран. Лузянин взглянул на остановленный на мониторе участок кода - его губы тронула легкая усмешка. Все еще не понимая, с кем он имеет дело, профессор отошел к другому, дальнему столу, вытащил из-под него второй стул, подставил его Креспину и жестом попросил присесть. Джедай опустился рядом, откинув полы плаща назад, Лузянин увидел висящий на поясе металлический предмет и вопросительно взглянул на Креспина. Тот отрицательно покачал головой - что-то вроде «Не сейчас...»

Между ними шел молчаливый диалог. Люди из разных миров и времен, сидя за компьютером, решали одну задачу - правда, условие этой задачи было продиктовано для них разными причинами. Но тем не менее - они оба, не зная языков друг друга, прекрасно поняли с первого же взгляда, что требуется решить в их разговоре.

Лузянин нажал пару клавиш - код ДНК мигнул, дефектный участок изменился, из красного стал светло-синим. Креспин внимательно посмотрел на экран, губы неслышно шевельнулись. Генотип пришел в норму - норму для рыцаря. Он повернулся к профессору, в его глазах был немой вопрос: «Почему так не было с самого начала - если ты знал, как исправить ошибку?»


Спецвыпуск Xakep, номер #026, стр. 026-112-15, Первый из рода

Первый из рода

Спецвыпуск Xakep, номер #026, стр. 026-112-15

Профессор отвернулся от Креспина, что-то прошептал себе под нос, затем встал и отошел в сторону.

- Ошибка не является летальной... Как объяснить вам? - спросил он сам себя, прекрасно зная, что собеседник его не понимает. - Я ведь десять лет ждал, что кто-нибудь все-таки придет...

Он смотрел на Креспина взглядом, полным боли - но боли родом из прошлого, оставленной много лет назад и сейчас вернувшейся вновь, напомнив события десятилетней давности...

Лузянин видел все, как сейчас, - вот они с радостной улыбающейся Кирой выходят из своей квартиры, щелкает замок, он проверят по карманам, не забыл ли ключи дома, чем вызывает смех жены и несколько колких замечаний в свой адрес. Лузянин отвечает ее тем же, Кира медленно спускается по лестнице спиной вперед, глядя на мужа и держась за перила; профессор (в то время еще доцент) делает два шага вниз и замечает сидящего на подоконнике площадкой ниже молодого парня лет двадцати трех - двадцати пяти, с ног до головы одетого в грязный старый джинс. В руках он держит пистолет, который по непонятным причинам засовывает себе в рот.

Лузянин встретился взглядом с этим парнем - и сразу понял, с кем их свела судьба. Парень на подоконнике тоже не счел нужным спрятать оружие и сделать вид, что ничего не происходит - напротив, он вытащил слюнявый ствол изо рта, и его лицо перекосила ухмылка...

Когда он выстрелил в первый раз, грохот, отразившийся от стен подъезда, сразу же заложил уши. Киру подкосило, пуля пробила насквозь правое колено; Лузянин машинально пригнулся. Второй выстрел прогремел практически через мгновенье, и облачко кровяных брызг в районе шеи жены заставило Лузянина закричать - безо всяких слов и призывов о помощи, просто громко и страшно закричать, пытаясь своим криком отгородиться от происходящего кошмара. Тем временем жена упала на ступеньку и вцепилась мертвой хваткой в перила - она так и не видела того, кто стрелял, и не воспринимала происходящее вообще, лишь ужас и непонимание застыли в ее глазах. Лузянин на всю жизнь запомнил этот взгляд - взгляд человека, ожидающего внезапной и нелепой смерти.

Он успел сделать только два шага навстречу своей жене... Потом еще два выстрела - один за другим, и она вздрагивает один, но долгий раз, не успевая даже почувствовать промежуток времени между двумя входящими в ее тело пулями. А еще через долю секунду Лузянин оказался впереди Киры - на пару ступеней, но все-таки ближе к убийце.

Следующие десять секунд он постарался вычеркнуть из своей жизни, и это удавалось ему в течение десяти лет - по секунде на год. Лузянин чувствовал каким-то десятым чувством, что он просто не успеет подбежать к этому маньяку, чтобы отобрать оружие - да именно так оно и было. Парень соскочил с подоконника и, взявшись за оружие двумя руками, нажал на курок.

Лузянин просто вытянул перед собой ладонь, словно защищался не рукой, а титановым щитом. Прогремело еще четыре выстрела, о которых никто потом не спрашивал - ни следователь, ни оперуполномоченный. Потому что их следов в подъезде не было.


Спецвыпуск Xakep, номер #026, стр. 026-112-16, Первый из рода

Первый из рода

Спецвыпуск Xakep, номер #026, стр. 026-112-16

Когда прошел испуг от грохота выстрелов и Лузянин ощутил свое тело целым и невредимым, раздался негромкий металлический звук - что-то четырежды стукнулось об пол под ногами Лузянина. Они вместе с убийцей, не сговариваясь, взглянули вниз и увидели четыре пули от пистолета Макарова. Те самые пули, которые со скоростью семьсот метров в секунду только что вылетели из ствола пистолета, спокойно лежали на бетонном полу подъезда.

- Что за... - только и успел выдохнуть из себя сумасшедший стрелок. Лузянин взмахнул рукой, в силе которой внезапно уверился раз и навсегда, и убийца, нелепо разбросав руки и ноги, с криком вылетел в окно площадки седьмого этажа, так и не выпустив пистолет.

Что-то заставило Лузянина подобрать с пола четыре не долетевшие до цели пули и еще четыре гильзы, которые в данной ситуации были лишними. Проделал он все это уже после того, как отвез жену в больницу и вернулся домой, будучи выставленным из реанимации уставшими от подобных сцен врачами. Поэтому никто так и не узнал, что «Индиана Джонс» не покончил жизнь самоубийством, а был выброшен из окна неведомой Силой, принадлежащей доценту Лузянину...

Креспин наблюдал за непонятной борьбой, происходящей внутри профессора, и пытался понять его слова, обращенные, как он понял, не совсем к нему, а точнее сказать, совсем даже не к нему, а к какому-то абстрактному собеседнику. Он встал со своего места, приблизился к Лузянину и взял его за руку. В тот же момент его пронизала волна боли и грусти; джедай стал свидетелем сцены в подъезде, увидел ее с разных ракурсов и даже ощутил весь ужас летящего вниз убийцы. И понял - человек, стоящий перед ним, сам боится этой Силы.

Сам же Лузянин в момент прикосновения к своей руке понял, что человек, ставший его таинственным гостем, именно этой Силой и живет; ради нее он сейчас здесь. Предстоял трудный вечер...

Профессор вопросительно взглянул в глаза молчаливого собеседника. Креспин выжидательно смотрел куда-то в центр лба Лузянина, остерегаясь встретиться с ним взглядом.

- Что вам нужно? - спросил Лузянин, не надеясь на ответ, так как понимал, что перед ним человек, не понимающий русского языка. Креспин угадал интонацию и указал пальцем на экран.

- Формулы? Хромосомы? - уточнял профессор. Креспин пытался одновременно и утвердительно кивать, и делать непонятные жесты руками, только больше запутывая Лузянина. И тут джедай ткнул пальцем в монитор, издал серию протяжных звуков, в которой можно было угадать обращенный к профессору вопрос, и удивленно пожал плечами.

- Вы хотите узнать, откуда все это взялось? - попытался угадать Лузянин. - Откуда появилась эта ДНК?

Креспин немного наклонил голову, вслушиваясь в интонацию слов профессора, после чего кивнул (несколько неуверенно, но неоднократно). Лузянин отошел в сторону, к шкафам, накрытым вытяжной трубой, снял с одной из полок лабораторный набор и, вынув из него скарификатор, проколол себе указательный палец на левой руке. Выступившую капельку он растер на стекле, прокрасив по Романовскому, после чего еще несколько капель набрал в различных размеров стеклянные капилляры. Креспин с интересом наблюдал за происходящим, пытаясь определить, что за всеми этими процедурами скрывается.


Спецвыпуск Xakep, номер #026, стр. 026-112-17, Первый из рода

Первый из рода

Спецвыпуск Xakep, номер #026, стр. 026-112-17

Тем временем один из капилляров Лузянин выдавил в неизвестный Креспину аппарат, после чего на этом аппарате замигали лампочки, послышался низкий гул центрифуги. Профессор полностью ушел в работу, забыв на минуту о существовании гостя.

Спустя какое-то время Лузянин обернулся. Креспин стоял у окна, глядя вниз, на суетливые фигурки людей в парке Академгородка. Он со спокойствием потомственного рыцаря терпеливо дожидался ответа на свой немой вопрос, постоянно помня о тех, кто отправил его сюда и нуждался в новом Источнике, как никогда.

Когда ему на плечо легла рука профессора, Креспин даже не вздрогнул - он прекрасно знал, когда теплая усталая ладонь ученого дотронется до него, знал с точностью человека, умеющего предвидеть будущее. Рыцарь медленно обернулся - Лузянин приглашал его к компьютеру, держа в руке маленькую пробирку.

Они вернулись к столу. Профессор сделал выразительный жест - указал на свой палец, на пробирку, встряхнул ее (розовая турбулентность внутри стеклянного сосуда была самым красноречивым объяснением происходящего). Потом вставил в небольшое приспособление на столе, рядом с монитором, - пробирку защелкнуло мягкими зажимами, из тонкого капилляра в ее дне невообразимо малая толика крови просочилась в анализатор. Через десять секунд на экране появилась витая спираль ДНК - один в один совпадающая со спиралью, в которой была исправлена ошибка.

На экране появилось сообщение. Креспин даже не пытался его прочитать - он понял, что там написано. Обе ДНК были идентичными.

- Ну? - спросил Лузянин. - Теперь понятно?

Креспин продолжал смотреть на экран и мучился немым вопросом - зачем этот человек сделал в коде ошибку? Ведь исходная молекула была правильной! Он не тратил годы на то, чтобы найти испорченный участок, - его не было с самого начала! Зачем?

Креспин поднял глаза на Лузянина. Профессор развел руками, не поняв вопроса.

- Вот так вот, батенька! - гордо сказал он. - Черт знает что ношу в своих сосудах... Я вижу, вы этим заинтересованы?

Он направился к криогенератору, в котором уже примерно три года хранились замороженные яйцеклетки - их он сделал раньше, к тому времени представляя, что с его хромосомами все обстоит не так просто.

- Любой ценой, - прошептал себе под нос Креспин. - Любой ценой... Любой...

Он вынул меч и протянул палец к кнопке...

Когда за спиной Лузянина раздался низкий звук, напоминающий одновременно шипение змеи и гудение в проводах высокого напряжения, он не испугался. Просто стало немного обидно - первый по-настоящему нужный человек и сразу хватается за оружие! Он резко развернулся, увидел надвигающегося на него собеседника, сжимающего в руке темно-зеленый световой меч и недоуменно спросил:

- А это зачем?

Креспин отвел руку для удара, одновременно протягивая другую в сторону пробирки с кровью профессора.

- Да иди ты... Откуда пришел... - буркнул он в лицо нападавшему. И Креспин исчез - только воздух глухо схлопнулся на том месте, где только что стоял рыцарь.


Спецвыпуск Xakep, номер #026, стр. 026-112-18, Первый из рода

Первый из рода

Спецвыпуск Xakep, номер #026, стр. 026-112-18

Лузянин нисколько не удивился подобному результату - казалось, он ожидал его.

- Вот почему я потратил два года на то, чтобы изменить тот участок, - ответил он пустому стулу возле компьютера, на котором несколько минут назад сидел гость. - Мне нужен нормальный ребенок, без всех этих... причуд. Хватит на этом свете меня одного.

Он вытащил из морозильной камеры необходимый материал и погрузился с головой в процесс создания собственного сына. Нормального. Без всех этих...


Спецвыпуск Xakep, номер #026, стр. 026-120-1, Полезные буки по хаку и не только

Полезные буки по хаку и не только

Frozen (frozen@real.xakep.ru)

Спецвыпуск Xakep, номер #026, стр. 026-120-1

С наступающим тебя, приятель. Целый год мы напрягали тебя всякими заумными штучками, обучали всяким протоколам, нудно втирали про оси, программинг и железки всякие, пора, наконец-то, и на заслуженный ;) отдых. Ну, а куда же без хорошей книжки подеваться :), литература, особенно интересная и полезная, везде нужна :). И поэтому сегодня, специально для тебя, подборка из интересных и полезных книг. В общем, Just Do It, вперед!

Лукьяненко С. В. Атомный сон: Повести и рассказы - М.: ООО Издательство "АСТ", 2002 - 443, [5] с.

Если ты любишь фантастику и фэнтези, то ты просто не мог пройти мимо этого отечественного автора. Истории, раскрывающиеся на страницах книги, никак нельзя назвать заумной и непонятной бредятиной, написанной в порыве наркотического сна, а юмор так и струится практически из каждой строчки. Хорошее времяпрепровождение в обществе этой буки я тебе гарантирую, а если ты читал прошлую версию сборника - "Л - Значит люди", то просто обязан заиметь в своей библиотеке и эту книжечку, ведь сюда вошли многие рассказы, отсутствующие там. И еще, в виде бонуса, можно найти "то, о чем гадали, спорили и мечтали все, кто полюбил "Ночной дозор". В общем и целом, мой совет - must read, и не только именно эту книгу, я еще советую прочитать и остальные произведения этого автора; во-первых, это наш с тобой соотечественник :), а во-вторых, здорово пишет :), интересно и смешно.

Рекомендуется: уставшим от трудных хакерских будней %).

Oscar Fraley, George Sullivan. Азбука Боулинга. Рекомендации чемпионов - М.: ЗАО Изд-во Центрполиграф, 2002 - 284 с.

Я всегда думал, что боулинг - игра простая и не особо заумная, а изучив это пособие, я кардинально изменил свою точку зрения на это занятие :). Оказывается, тут есть куча всяких фишечек, уловок и хитростей, да и боулинг бывает разный и, если играть по правилам, превращается в довольно занимательный спорт, а не тупое бросание шаров. Есть даже такая организация с крутым названием "Американский Конгресс Боулинга", во, как все серьезно! Ну, а на самом деле, книга довольно полезная, и предложенная тема объясняется хорошо и с примерами в виде картинок, со схемами постановки ног, фотографиями различных фаз бросания шара и множеством советов для разных людей (есть советы для левшей, детей, женщин ;) и других жителей социума :). Особо должны порадовать твой глаз инструкции по игре, ведь бросить шар - это полдела, надо еще знать, как правильно бросить, а то так недалеко и фол заработать :). А людей, серьезно заинтересовавшихся этой игрой, особо порадуют главы "История боулинга" (оказывается, еще древние египтяне немереное количество лет назад знали похожую игру :), "Поведение и этикет" (вежливость - вот залог хорошей игры!) и "Создание собственной лиги".

Рекомендуется: если ты хочешь блеснуть перед подружкой, сделав страйк (сбив все кегли одним шаром), то есть вероятность, что тебе пригодится эта бука :).

Борман Питер. 1444 коктейля - М.: АСТ, Астрель, 2001 - 560 с. ил.

Признайся, ведь тебе очень часто хотелось удивить свою герлу, смешав пару спиртоносных напитков и получив божественный нектар? Если это так, то бука, которую я сейчас вижу перед собой, призвана тебе в этом очень сильно помочь. Мощнейшее руководство для начинающих (и не только барменов) содержит в себе неимоверное количество интересных рецептов и, что немаловажно, инструкции по смешиванию и описание нужного для создания шедевра оборудования. Как оказалось, даже у обыкновенной водки есть свои хитрости и особенности %). Ну, а освоив технологию правильного смешивания продуктов, ты сможешь готовить просто-таки потрясные вещи, сражая всех наповал своими способностями. А для тех, кто не пьянствует водку, есть раздел, посвященный не содержащим алкоголь жидкостям, из которых тоже можно приготовить хучу всяких интересных вкусностей :).


Спецвыпуск Xakep, номер #026, стр. 026-120-2, Полезные буки по хаку и не только

Полезные буки по хаку и не только

Frozen (frozen@real.xakep.ru)

Спецвыпуск Xakep, номер #026, стр. 026-120-2

Рекомендуется: будущим барменам %) или просто для ознакомления перед дружеской вечеринкой.

Кондратьева А. В. 500 праздничных салатов - М.: Рольф, 2002 - 512 с. ил. - (Страна Советов)

Впереди большой праздник - Новый год :), и к нему надо хорошенечко подготовиться, но вот мне, например, уже надоело присутствие на столе тазика с салатом "ой, ливье", пора бы и обновить коллекцию, а то все меняется, лишь закуска остается неизменной :). А удивить всех, поставив на стол что-то необычно-красивое, тебе удастся, полистав страницы этой вот книженции. Большое количество известных и не очень рецептов, начиная от "Мясного Французского" и заканчивая "Экспрессом" из фруктов, ждет тебя при изучении буки. Ну а в качестве бонуса прилагается информация о том, как украсить салат и сделать к нему соус :).

Рекомендуется: домохозяину(йке) перед встречей веселого праздника :).

В. Малланга. Камасутра - М.: Современный литератор, 2001 - 238 с.

Если ты хочешь овладеть искусством Брахмы, описанным врачом Ватьясом во втором веке до нашей эры по мотивам скульптурных изображений храма "Черная пагода" :), то непременно изучи сей эротический трактат, много нового, надо сказать, узнаешь. А если ты уже "тренированный читатель", то и для тебя найдется здесь полезная информация в виде всяческих "полезных" применений полученных знаний на практике. Так, например, "Минарет" (не путать с минетом :) - "избавляет фигуру от лишнего живота", поэтому в качестве средства для похудания можешь предложить своей подружке хм... альтернативу таблеткам и диетам :). А если учесть просто огромное количество иллюстраций в книге, помогающих освоить и рассмотреть во всех подробностях предложенные инструкции, то получится просто фундаментальное руководство, как "красотой своих роскошных рогов" не уподобится "коринфскому быку" :).

Рекомендуется: служителям культа Вишну :).

Евгений Петросян. Записные хиханьки-хаханьки. - М.: Издательство АСТ, 2001 - 382 с.

Я-то думал немного поразвлечься и посмеяться, читая эту книжку, а получилось чуть ли ни наоборот :(. Вроде бы известный человек и пытается даже людей смешить, но здесь, надо признаться, слабовато у дяди Евгения Вагановича вышло :(. Читая его так называемые записки, не было ощущения такого юмора и смеха, как ожидалось... Почему-то этой своей брошюркой он меня сильно огорчил, и не буду больше тратить на него драгоценные байты, а поставлю ему относительную оценку плохо и все.


Спецвыпуск Xakep, номер #026, стр. 026-120-3, Полезные буки по хаку и не только

Полезные буки по хаку и не только

Frozen (frozen@real.xakep.ru)

Спецвыпуск Xakep, номер #026, стр. 026-120-3

Рекомендуется: а не рекомендуется она, лучше уж почитать что-нибудь по способам построения локальных вычислительных сетей, и то веселее будет.

Редакция выражает благодарность магазину "Библио-Глобус" за предоставленные книги.


Спецвыпуск Xakep, номер #026, стр. 026-122-1,

На письма отвечал Дронич

Спецвыпуск Xakep, номер #026, стр. 026-122-1

From: Silent Killer (silent_killer@mail.ru)

To: spec@real.xakep.ru

Subj: Две стороны последнего журнала...

Дарова, ХаЦкЕрЫ! Ваш журнал просто супер! Не буду говорить, что читаю ваш журнал с самого первого номера, уж слишком стандартно получается :-). Жалко, что вы заканчиваете серию журналов про взлом. Я вот пишу, чтобы высказать свое мнение о последнем выпуске спеца (Легкий хак). С одной стороны, вы правильно сделали, что выпустили такой журнал, вы дали ответы на многие вопросы, которые я постоянно вижу в форумах и которые мне постоянно задают мои друзья, жалко, конечно, что я ничего нового не узнал...

Но! Есть и другая, плохая сторона! Вы подумали о том, что после прочтения этого журнала появится огромная толпа ламаков, возомнивших себя c00L хацкерами?! В чатах и ирке появятся откровенные гопники, валящие всех и вся с помощью SMBdie и xPING!!! А еще хуже, если такие М#ДАКИ объединятся в группы и будут валить мыльники и тырить номера аськи! Так что думайте! Возможно, вам на это глубоко забить, но я свое мнение высказал!

Всем вам большое спасибо за то, что вы создали такой рульный журнал!

З.Ы. Обращение к Niro: "Твои Story" просто RULEZZZZZ, тебе книги писать надо! Очень тебе благодарен!

To: Silent Killer (silent_killer@mail.ru)

Вай-вай-вай, как нехорошо получилось... М[решеточка]ДАКИ, вооруженные SMBdie'ем и xPing'ом, начнут грабить, убивать и насиловать ни в чем не повинных жителей сети. Волна ненависти прокатится по рунету, и не останется в нем камня на камне. Что-то ни фига мне такая картина не нравится :), на самом деле все гораздо лучше. Ведь прочитавшие этот номер вовремя залатают дыры (заметь, именно для этого мы официально работаем, загляни ради интереса на страничку с содержанием), и гнев ламья обрушится на них же самих. По-моему, мы просто запустили маленькую волну естественного отбора - кого-то Спец подтолкнет учиться дальше, а кто-то, наоборот, испугается страшных нюков и навеки исчезнет из инета. Исчезнет и никогда не будет напрягать форумы вопросами типа "Здрасьте, замыльте мне драйвер к моей видюхе. ЗаранИе спасиба". Все-таки положительного вроде больше... А нюкающего ламья и так полно (тут мне недавно сканил порты чувак, у которого на машине стоял сервер DonaldDick'a :)... чума... но это уже отдельная история).

From: Flameon (flameon@mail.ru)

To: spec@real.xakep.ru

Subj: Всем тем, кто там и не там, но читает 8)

Hi, spec!

Решился вот все-таки налить вам письмо. Номер про легкий хак - СУЩИЙ РУЛЕЗЗЗЗ! (real rulezzzz! 8). Умеете же просто и умно писать! Мне, конечно, все ваши номера нравятся, но то, что ... в общем, понятно 8). Вы все кул хацкеры, я вас уважаю и заставляю по мере возможностей других. Это письмо вы, конечно, не опубликуете, т.к. в нем нет смысловой нагрузки, но все же пусть вам будет приятно за то, что у вас есть такие вот фаны, как я!

З.Ы. Punx will never die!.. I sad punx? I mean xakepc!!! 8)

To: Flameon (flameon@mail.ru)

Шалом, златоглавая! Надеюсь, ты понял, насколько круто ты попал? Нам, конечно, приятно слышать лестные отзывы о том, как ты заставляешь нас по мере возможностей других... или нет, уважаешь других по мере возможности нас... нет, все-таки просто уважаешь и заставляешь. Нас. Или других. Млин, и этот человек сказал, что в его письме нет смысловой нагрузки...


Спецвыпуск Xakep, номер #026, стр. 026-122-2,

На письма отвечал Дронич

Спецвыпуск Xakep, номер #026, стр. 026-122-2

From: Факультет довузовской подготовки (fdp@hse.ru)

To: spec@real.xakep.ru

Subj: Фигня

Привет, мужики! Я тут решил выпить немного водочки, да одному никак. Нехорошо как-то одному пить, ну сами понимаете... Так вот, опубликуйте мое письмо (и главное - ответ на него) в своем мега-кульном Спецвыпуске мега-кульного журнала ][, и тогда я чокнусь своим стаканом с вашим ответом на мое тормозное письмо, и будет создано впечатление, будто я чокнулся и выпил с вами (особенно хочется выпить с noah'ом и donor'ом. Заранее благодарен. Potroshitel.

P.S. Поторопитесь с ответом, плз., а то сушняк долбит.

To: Факультет довузовской подготовки (fdp@hse.ru)

Зигхайль и тебе, потрошитель. Значит, Дронич в качестве собутыльника тебя уже не устраивает, да? А придется, как говорил незабвенный... этот, ну как его... забыл :(. Ладно, суть в другом - Ноа с Доном никак не смогут с тобой выпить, потому как за пару часов до этого они начали пить друг с другом. Еще через полчаса они нарыли откуда-то женщин облегченного поведения, а вот двадцать минут назад стали спаивать меня... Так что я на данный момент единственный, кто попадает по клавиатуре (о том, чтобы попасть по клавишам, речь уже не идет). Что поделаешь, тяжело время сдачи номера...

З.Ы. Интересно, а в каком ВУЗе так здорово довузовски готовят? Я хочу к вам за вторым высшим :). Сушняку - прривет. Иккк...

From: noname (degrot@mail.ru)

To: spec@real.xakep.ru

Subj: требования к журналу

Здрасте. Журнал мне нравится, особенно понравилась серия "ВЗЛОМ".

Большая просьба укоротить рубрику стори или убрать ее вообще, так как она не приносит какой-либо практической пользы и занимает значительное кол-во места в журнале, а сами рассказы не всегда бывают интересные, некоторые из них только боком касаются тематики журнала. Рубрику релакс нужно убрать совсем, потому что она не соответствует журналу и, бывает, такую глупость понапишут. Комикс полностью соответствует журналу и должен быть раза в два больше.

С уважением, ваш читатель.

To: noname (degrot@mail.ru)

Ша, хацкера! Хозяин пришел, всем сидеть тихо! Быстренько взялись за комикс и потянули, потянули, потянули... Так, харе там халтурить, пока в два раза больше не станет, жратвы не будет. Остальным за метлы - релакс от глупости чистить. Стори вообще вырезать, нефиг Ниро больше писать, и так одни респекты ему шлют. Вот и все, идеальный Спец для Нонейма готов. А вот будет ли он идеальным для всех? Стеб стебом, но к вашим мнениям мы прислушиваемся, но... постарайтесь их хотя бы аргументировать. А то напишут ведь... "Тут копать, тут не копать и молчать всем". А конструктива мы ждем всегда. С распростертыми объятьями.

From: Vladimir Snigour (l0new0lf@mail.ru)

To: spec@real.xakep.ru

Subj: Ну вы, блин, даете!

Здоровенькi булы!

Вот зашел я в клубак, дай, думаю, нацарапаю любимому спецу че-нибудь... Тем более, что вчера ознакомился с содержимым intro последнего номера... Здорово! Молодец, noah! Как я это сделал? Да просто запустил khexedit и ручками ввел все эти гигабайты "нефильтрованных мыслей"... С цензурой хорошо расправились, так ее! И вообще, ваш (и наш) спец очень улучшился за последнее время. Стал насыщеннее, интереснее и даже серьезнее, хотя не перестал быть частично развлекательным. Так держать! Ждем новогоднего дебоша...


Спецвыпуск Xakep, номер #026, стр. 026-122-3,

На письма отвечал Дронич

Спецвыпуск Xakep, номер #026, стр. 026-122-3

To: Vladimir Snigour (l0new0lf@mail.ru)

Тю, хлопци, ридным Запорожьем потянуло! То, что ты, Один0кий В0лк, интру прочитал, это хорошо. Вот для таких, как ты, мы хотели весь выпуск в хексах накалякать, но что-то удержало. И, слава богу, наверное. Кстати, ты один из немногих работавших руками (если бы мыслей и правда были гигабайты, руки бы мало помогли... :)). Так вот, нашлись-таки мудрые люди, гадавшие нашу шифровку при помощи сканера, OCR и самопальной проги на Паскакале. Респект им, и все такое. Только уговор - молитесь теперь вместе с нами, чтобы бабки, которые нас цензорят, не поставили себе линя вместе с прилагающимся khexedit'ом. Закроют ведь, изверги.

З.Ы. А дебош УЖЕ ЗДЕ-Е-ЕСЬ!