Спецвыпуск Xakep, Содержание номера # 020

Cover 020 |
Статья | Стр.
СЕКРЕТЫ СОТОВЫХ ТЕЛЕФОНОВ | 006
ФИШКИ ОПЕРАТОРОВ СОТОВОЙ СВЯЗИ | 010
Мобильники Spez-Crew | 014
ВСЕ О WAP&WML | 018
ЛЕГАЛЬНЫЙ ФРИК | 022
ДИНАМИКА ЦЕН НА УСЛУГИ СОТОВОЙ СВЯЗИ | 024
GPRS | 028
ЦифроваЯ телефониЯ vs VoIP | 032
PANAMAIL | 036
ВЫСОКАЯ МОДА ДЛЯ МОБИЛ | 040
СОФТ ДЛЯ МОБИЛ | 044
КАРТОЧКИ НА КАЖДЫЙ ДЕНЬ | 046
САМЫЕ ОЖИДАЕМЫЕ МОБИЛЫ | 050
ФРИКЕРСКИЙ ТАЛМУД | 052
МОБИЛЬНЫЕ ПИРАТЫ | 054
МОБИЛЬНЫЕ ЗВУКИ | 056
СВЕЖИЕ МОБИЛКИ В ГОСТЯХ У СПЕЦА | 060
РЕСУРСЫ КРЕАТИФФЩИКА | 064
КРЕАТИВИМ КОМПЬЮТЕРНЫЕ ИГРЫ | 072
TIPS OF WEB | 076
ИНТЕРВЬЮ С ДИМОЙ АГАРУНОВЫМ | 078
РОЛЛЫ | 082
ДЕСЯТЬ САМЫХ ДУРАЦКИХ СПОСОБОВ ЗВОНИТЬ НА ХАЛЯВУ | 086
The Matrix Fuck You | 088
FAQ | 098
Книжки | 102


Спецвыпуск Xakep, номер #020, стр. 020-006-1, СЕКРЕТЫ СОТОВЫХ ТЕЛЕФОНОВ

СЕКРЕТЫ СОТОВЫХ ТЕЛЕФОНОВ

Спецвыпуск Xakep, номер #020, стр. 020-006-1

UFO (ufo@cu-magazine.ru; www.cu-magazine.ru)

ИНТРО

Да... Были времена, когда сотовый телефон можно было увидеть довольно редко, да и то у какого-нибудь "нового русского". А сейчас? Едешь в автобусе на Москву, только отъехал от остановки, прикрыл глаза, чтобы подремать, а вот хрен тебе! Телефоны начинают звонить из всех углов, карманов, сумок, трусов и всего остального. Хорошо, конечно, что появилась большая конкуренция среди сотовых компаний, и они начали снижать свои цены на услуги, но с другой стороны это достает. Напокупали себе все телефонов, кому нужно и кому не нужно, и давай использовать их на всю катушку. Я, конечно, их тоже люблю, но мне на них не везет. Больше месяца у меня трубка не держится. Но за это время я пытаюсь узнать о ней все, что только можно или нельзя. Думаю, тебе это тоже пойдет на пользу. Ты же хочешь знать все о своем телефоне? Я прав? Тогда тебе будет очень полезно повнимательнее изучить эту статью и воспользоваться ссылками, которые я тебе предоставлю. Так что не поленись и прогуляйся. Конечно же для того, чтобы ты не перерывал все представленные сайты в поисках нужной модели, я буду перечислять тебе типы телефонов, секреты которых ты найдешь на этих страницах. Но учти, что помимо информации, посвященной определенной модели, можно найти кучу полезных советов, которых ты не отроешь в обычной инструкции. В общем, читай, смотри и наслаждайся.

СЕКРЕТЫ СОТОВЫХ/МОБИЛЬНЫХ ТЕЛЕФОНОВ

http://helpfrom.narod.ru/misc/index.htm

Стартанув свой серч по пагам с секретами телефонов, я в первую очередь споткнулся об эту страницу. Авторы сайта постарались сделать его как можно более информативным и ненапряжным. Несмотря на название паги, в ней можно найти не только секреты, но и много всего интересного. Тут тебе и разные голосования, и анекдоты, и обзоры, да что я буду перечислять. На сайте действительно очень много всего. Что самое интересное - я отрыл раздел "Phreaks", где можно зачерпнуть много интереснейшей и полезной информации. А теперь, как я и обещал, перечислю названия телефонов, секреты которых валяются на этом сайте. Alcatel, Bosch, Ericsson, Mitsubishi Trium, Motorola, Nokia, Philips, Sagem, Samsung, Simens, Sony. Ессесно, не все модели, но самые распространенные в наличии. Для любителей нетрадиционного использования мобилки есть раздел на тему «определение силы выброзвонка». Ну, и несколько типсов по спасению жертв кривых рук. Мое мнение - грех не заглянуть на этот сайтец.

YOUR ULTIMATE MOBILE/GSM GUIDE

http://mobile.box.sk

Очень хороший сайт! Просто настоящая удача! Почему я так считаю? Да все дело в том, что однажды я искал секреты для своего Panasonic'а. Обрыскал очень много сайтов, но так ничего и не нашел. Но вот сегодня, по чистой случайности, заглянул на эту страницу. Ты себе не представляешь, сколько здесь всего! Среди кучи неизвестных мне моделей нашелся и мой Panasonic :)! В общем, что бы не путать тебе мозги, перечислю все фирмы, телефоны которых ты можешь похакать напитавшись инфой с этого сайта: Alcatel, Bosch, Ericsson, Mitsubishi, Motorola, Nec, Nokia, Panasonic, Philips, Sagem, Samsung, Siemens, Sony. Не менее интересен раздел "other", в котором тусует некоторое количество эмуляторов, анлокеров, кодгенов, а также спецификаций и доков. Кстати, можешь быть уверен, что ты найдешь нужную тебе модель, так как их там огромное количество. Если ты все-таки не нашел то, что тебя интересует, то ты можешь задать вопрос Доктору Мобилу, который, по его словам, уделяет по десять минут в день, на то, что бы отвечать на вопросы посетителей. Единственное что огорчает, так это англоязычность сайта. Вся информация представленная на нем исключительно на английском языке. Так что с Русским тебе там делать будет нечего, и я с трудом представляю, как ты будешь контачить с доктором. Да! Чуть не забыл самое главное! Секреты постоянно пополняются. Автор сделал даже небольшую полосу, на которой периодически публикуются десять самых свежих пополнений. Так что скорее всего на момент выхода этой статьи страница пополнится еще немалым количеством интересных секретов. Копай!


Спецвыпуск Xakep, номер #020, стр. 020-006-2, СЕКРЕТЫ СОТОВЫХ ТЕЛЕФОНОВ

СЕКРЕТЫ СОТОВЫХ ТЕЛЕФОНОВ

Спецвыпуск Xakep, номер #020, стр. 020-006-2

MOBI: О МОБИЛЬНОЙ И ПЕЙДЖИНГОВОЙ СВЯЗИ

http://www.mobi.com.ua/

Вообще, это он-лайн каталог. Можешь скоренько чекнуть интересующие тебя мобилки и пагеры, задав соответствующие параметры, посмотреть их фотки и прошариться по прайсам. Ясно дело, на морде лента новостей, чтобы держать палец на кадыке. И по теме есть что почитать. Так, например, в разделе "полезное" можно найти описание различных стандартов как сотовых, так и пейджинговых. Есть описания кодов GSM-телефонов. Стандартных секретиков я не нашел, но думаю продвинутые фрикеры заинтересуются различным описаловом стандартов ;). А если что не понятно, можно обсудить в форуме. Вот такая вот страничка. Поблуждать можно.

УЗНАЙ БОЛЬШЕ О СВОЕМ СОТОВОМ ТЕЛЕФОНЕ!

http://www.gsmlab.com/index.htm

Очень познавательный сайт. Тут просто до фига разного рода информации о мобильниках. Среди различных кодов для телефонов Motorola, Simens, Alcatel и Mitsubishi можно найти еще множество секретов. Так, например, в подборке статей есть рассказ взломщика телефонов. Можно воспользоваться услугами адаптации телефонов стандарта GSM, снятие паролей, русификация, ремонт, добавление новых функций и смена прошивок. Если ты потерял инструкцию, которая просто необходима тебе, или купил телефон с рук, то тут ты найдешь мануалы более чем к пятидесяти различным моделям. Как и на любом уважающем себя сайте, тут есть свой форум. Но и это еще не все! Решил я заглянуть в "магазин" и нашел там полезную услугу - "Для всех обладателей сотовых телефонов Siemens С35, M35, S35 - мы предлагаем услугу вычисления кодов разблокировки, которые вводятся с клавиатуры телефона!". К сожалению услуга платная, но совсем недорогая - 35 рублей. К тому же расплатиться можно через WebMoney. И это не единственное, что предлагается сделать в магазине! Советую тебе самому туда забраться и поглядеть.

"СОТОВИК"

http://www.sotovik.ru/

Просто море информации по сотовым телефонам. Здесь, на мой взгляд, можно найти все. В процессе поиска можно даже заблудиться :). Несколько разделов новостей, огромный каталог и тут же цены и где купить. Хорошая фишка – «парад новинок». Можно сразу заценить все новоявленные извращения и тут же надругаться над ними в форуме. Сотовики также поддерживают манию народа извращаться со своими звонками. В разделе «Мелодии» можно оторвать себе «Семь сорок» или «Мурку», а то и фирменный звоночек от Вивальди. Но так как нас интересуют различные секреты, то могу сказать следующее. Глядя на некоторые статьи этого ресурса я уловил несколько материалов связанных с безопасностью телефонов, а также нежелательным доступом к ним ;). Чувствуешь чем дело пахнет? Не пожадничали умные дядьки информацией и выложили ее на всеобщее обозрение. Тебе остается только заглянуть в раздел "Библиотека" и полазать там некоторое время в поисках подходящей для тебя инфы. Вообще, удивила одна приятная возможность - "поиск телефона по заданным характеристикам". Как и полагается есть форум и ссылки. В общем, ценная страница. Смотри не пропусти!


Спецвыпуск Xakep, номер #020, стр. 020-006-3, СЕКРЕТЫ СОТОВЫХ ТЕЛЕФОНОВ

СЕКРЕТЫ СОТОВЫХ ТЕЛЕФОНОВ

Спецвыпуск Xakep, номер #020, стр. 020-006-3

HAPPY END

Ну вот. Я просто уверен, что этих сайтов тебе более чем будет достаточно, чтобы открыть недокументированные фичи твоего телефона :). Тебе остается только не полениться и почитать побольше разной инфы и мануалов по твоей мобиле. Будь уверен, на представленных сайтах ты точно найдешь нужный тебе телефон. Единственное о чем я хотел бы тебя предупредить - не особо балуйся разными секретными фичами и будь предельно осторожен, так как даже самые безобидные коды могут навредить твоему телефону. И вообще подумай, стоит ли экспериментировать со своим телефоном. А если все-таки твой кнопчатый друг загнется после твоих экспериментов, то меня пинать не надо, так как я тебя предупреждал ;). Удачи и привет тебе из далекого космоса!


Спецвыпуск Xakep, номер #020, стр. 020-010-1, ФИШКИ ОПЕРАТОРОВ СОТОВОЙ СВЯЗИ

ФИШКИ ОПЕРАТОРОВ СОТОВОЙ СВЯЗИ

Спецвыпуск Xakep, номер #020, стр. 020-010-1

n0ah (noah@reql.xakep.ru)

Под фишками подразумеваются всякие мелкие и удобные сервисы, которых особо и не видно на поверхности (при заключении контракта и тд), но которые могут здорово облегчить нам жизнь.

БИЛАЙН

У Билайна фишек вообще огромное количество. Начнем с одной из наиболее удобных, а главное наиболее халявных ;) - автодозвон. Если на твоей мобиле отсутствует функция автодозвона (или она есть, но корявая – звонит, скажем, не больше десяти раз), то эта фишка просто создана для тебя. Набираешь на своем телефоне «660» и без всяких пробелов номер чувака, которому хочешь прозвониться (например, 66089037777777). Приятный женский голос сообщит, что твоя заявка принята, и робот начнет долбиться по заданному телефону. Далее существует несколько вариантов развития событий: либо робот дозванивается до нужного человека (заниматься он этим будет в течение тридцати минут), сообщает ему о том, что сейчас будет соединять, потом звонит тебе и, если дозванивается, благополучно вас соединяет, либо робот не дозванивается до чувака – тогда он звонит тебе и печальным голосом об этом сообщает, либо робот дозванивается до чувака, но не может прозвониться тебе – в таком случае он вежливо извиняется перед чуваком и идет заниматься другими делами :). Очень удобно! Набрал номер – и больше не паришься. Снять номер с автодозвона можно точно так же, только вместо «660» надо поставить «661».

Еще одна удобность – тональный набор. Если у тебя отказала «восьмерка», ты все равно можешь позвонить абонентам Билайн, воспользовавшись альтернативным дозвоном. Звони на городской номер 105-5678 и там после сигнала вводи номер нужного тебе человека. Все, и никакой «8» не надо.

Еще одна клевая фишка у Билайна - мobile е-мail. Это сервис, позволяющий работать тебе с мылом через sms. И не только с мылом – на самом деле у этого сервиса возможности просто безграничные.., но мы начнем с мыла ;). Итак, для того, чтобы отправить мыло со своего мобильника, тебе надо набрать смску следующего формата: мыло+пробел+текст_письма и заслать ее на номер 684. Например: «pupkin@lame.net lamo!». Все, ламер-пупкин получит твою месагу на свой почтовый ящик через пару секунд. Причем, если он на нее ответит, реплей придет к тебе на мобилу в виде смски (или в виде нескольких смсок, если в одну все не поместится). Круто? Это еще не все ;). На самом деле, формат немного другой: мыло+пробел+опции+пробел+текст_письма. Доступны следующие опции:

-L - отмена преобразования в кириллицу (по дефолту, если ты пишешь транслитом, он автоматически переводится на нормальный русский язык);

-R - преобразовать в кириллицу (текст от это опции и до следующей будет преобразован из транслита в кириллицу);

-W – отправить мыло в текстовом формате (по дефолту шлются в хтмл);

-WW - отправить мыло в текстовом и упрощенном формате (без подписи, без приветствия);

. (точка) – точка перед буквой переводит ее в ВЕРХНИЙ РЕГИСТР;

.. (две точки) – две точки перед словом переводят все слово в ВЕРХНИЙ РЕГИСТР;

-n – уведомление о доставке (как только мыло будет доставлено, тебе придет смска с подтверждением).


Спецвыпуск Xakep, номер #020, стр. 020-010-2, ФИШКИ ОПЕРАТОРОВ СОТОВОЙ СВЯЗИ

ФИШКИ ОПЕРАТОРОВ СОТОВОЙ СВЯЗИ

Спецвыпуск Xakep, номер #020, стр. 020-010-2

Ок, продвинутые опции заюзали, мыло отправили – все нормально. Но этот сервис позволяет отправлять месаги не только на мыло, а также на мобильники, на пейджеры и даже на аську!!! По отдельности и всем вместе!

Формат сообщения на мобильник следующий: номер_телефона+пробел+текст месаги. Если хочешь заслать месагу на мобильник другого оператора, пиши примерно следующее: «POST TO:+79113333333 mesaga». Перед прямыми номерами надо ставить код города (например, 095).

На аську сообщения шлются следующим образом: номер_аськи+@+icq+пробел+текст. Например: «98332@icq hi».

На пейджер: номер_абонента+@+телефон_оператора+пробел+текст.

Нескольким получателям можно написать, если отделить их запятаями («,»).

Но и это еще не все! Я же говорил – сервис продвинутый :). Грубо говоря, свой аккаунт в мobile е-мail можно настраивать. Для этого существуют специальные команды. Отсылаются они на все тот же 684 в следующем формате: SYM+пробел+опции+пробел+переменная+пробел+значение. Доступны следующие переменные (им можно присваивать значения):

NICK – это твой ник, он будет высвечиваться у получателей вместо твоего телефонного номера;

NAME – твои ФИО, указывается в теле месаги, когда ты шлешь мыло;

SIGN – прикрепляется к концу текста отправляемого мыла;

MAIL – сюда можно записать твою почтовый адрес;

DISABLE-TIP – если в эту переменную записать «yes», то тебя не будут докучать всякие подсказки, если ничего не записывать или записать «no» - соответсвенно;

ENABLE-SIMPLEMAIL – то же самое, что и опция «-ww» в теле месаги, только распространяется на на одну месагу, а на все: «yes» - включить, «no» - отключить.

DISABLE-SPLIT – большие сообщения не будут разбивать на несколько маленьких смсок;

Нет, мы пока еще не закончили :) – на этом сервисе можно настраивать еще и профиль твоего мобильника. Например, ты можешь задать системе, понимает ли твой мобильник русские буквы. Делается это так: «SYM MODE -L LL». Вместо последних «LL» можно поставить «RL», «RR» и «LN», что означает:

LL – дисплей моего мобильника показывает только латинские буквы, а кнопки умеют вводить только латинские буквы;

RL - дисплей моего мобильника умеет показывать русские буквы, а кнопки умеют вводить только латинские буквы;

RR - дисплей моего мобильника умеет показывать русские буквы, и кнопки умеют вводить русские буквы;

Идем дальше: всем своим приятелям ты можешь назначить имена, чтоб не париться, вводя каждый раз их адреса. Шли на 684 смску вида: SYM+пробел+имя_приятеля+пробел+мыло приятеля. Теперь, ты можешь не париться с вбиванием длиннющего имейла - просто вводи назначенный тобой приятелю ник.

Тем же способом можно организовывать целые рассылки. Води через запятую не один адрес, а несколько (максимум - четыре), и твои месаги будут уходить сразу на все адреса. Но это ламерский способ – существует еще более продвинутый механизм объединения адресатов. Вбивай: GROUP+пробел+имя_группы. Этим ты создашь группу. Теперь надо добавить в нее народ. Для этого вводи: GROUP+пробел+имя_группы+пробел+адрес1,адрес2,адресN. Вот и все. Теперь достаточно набрать «имя_группы+пробе+текст», и все дружно получат твою месагу. Если старое название группы надоело, ее можно переименовать: REN+пробел+старое_имя_группы+пробел+новое_имя_группы.


Спецвыпуск Xakep, номер #020, стр. 020-010-3, ФИШКИ ОПЕРАТОРОВ СОТОВОЙ СВЯЗИ

ФИШКИ ОПЕРАТОРОВ СОТОВОЙ СВЯЗИ

Спецвыпуск Xakep, номер #020, стр. 020-010-3

Вот такая вот огромная фишка от Билайна - мobile е-мail. По-моему, все достаточно продвинуто.

МЕГАФОН

Самая большая фишка у этого оператора - сим меню. Когда ты вставляешь мегафоновскую симку в свой телефон, в его меню появляется дополнительный пункт – SIM menu. Войдя в него, ты увидишь кучу подменю, в которых расфасованы информационные и развлекательные услуги. Выбрав одну из них, ты в течение минуты получишь смску с требуемой инфой. Для счастливых владельцев мобильничков Nokia и некоторых моделей Samsung предусмотрена возможность скачать себе новые логотипчики, картинки, заставки и музыку. Также через сим меню доступны настройки твоего аккаунта: можно включать/выключать голосовую почту (подменю Uslugi), пополнять/проверять баланс (GSM-Light). Самые вкусные услуги – это, на мой взгляд, сервисы, связанные с твоим географическим местоположением. Например, зайдя в подменю Blizhayshie и отправив запрос из соответствующего пункта, можно получить смску с информацией о ближайших от тебя питейно/продуктовых заведениях, магазинах (любых – от продуктовых, до компьютерных ;)), автозаправках (сервисах, стоянках, шиномонтажах и пр.), кинотеатрах, клубах, банкоматах и многое-многое другое. Система определяет местонахождение твоего мобильника (а значит и твое) с точностью до пары сотен метров и, сверившись со своей базой данных, высылает инфу в виде смски. Прямо, как в фантастическом фильме ;). Также из сим меню можно получить доступ к всевозможным новостям, анекдотам, хит-парадам, тв-программам, гороскопам, биоритмам и прочим мелким радостям.

Из опций смс у мегафонов пока есть только оповещение о доставке месаги. Заюзать его можно, поставив знак вопроса (?) в самом начале смски – центр текстовых сообщений пришлет тебе оповещение, когда смска будет доставлена.

Тональный набор на мегафоне тоже есть. Позвонив на городской телефон 505-44-88, можно соединиться с счастливым владельцем мегафоновской карточки, набрав его номер в тональном режиме. Это очень удобно, если глючит «восьмерка» или если звонишь с автомата.

И еще одна фишка - на сим карте этого оператора нарисован смайлик – мелочь, но приятно ;).

Ну и, естественно, на мегафоне работают стандартные GSM-команды.


Спецвыпуск Xakep, номер #020, стр. 020-014-1, Мобильники Spez-Crew

Мобильники Spez-Crew

n0ah

Спецвыпуск Xakep, номер #020, стр. 020-014-1

Эх, был у меня Bosch DUAL S. Отличный телефон: все на месте, все удобно, привыкаешь быстро, синяя подсветка, офигительный звук. Короче, клевая мобила. Одно плохо - сдох через три месяца. Обидно, блин, - специально выбирал, чтоб не брать какое-нибудь китайское фуфло - собран в Дании. Однако умер безвозвратно. Пришлось продать на запчасти за $20. Оправившись от моральной травмы (привязался я к этому поганцу ;)), забил на эксперименты с «нестандартными» телефонами и купил панас GD95. Теперь доволен и счастлив :). А еще у меня есть древняя моторолка с включенным test-режимом - бесконечное пространство для экспериментов :).

Холод

Мобила: Митсубиши МТ-35

Я люблю большие мобильники - маленькие аппараты, похожие на зажигалки, меня раздражают. К тому же не хочу мобильник, как у всех. Поэтому постоянно отыскиваю аппараты антикварные, но прикольные. Был у меня Эрикссон DH318 DAMPS`овский, в армированном корпусе и с форсированной батарейкой, потом - Бош 909 DUAL с флипом (почетнейший аппарат!), а теперь вот - МТ-35. Из начинки имеется следующее: активный флип, виброзвонок, органайзер, телефонная книжка, броадкастер, голосовая почта, АОН, анти-АОН, SMS. Умеет работать факс-момедом. Кроме памяти сим-карты, у аппарата есть также собственная память. Батарейка - на 800 мА/ч, держит двое-трое суток, редко больше. В сети нашел кучу секретных кодов к аппарату, очень прикалывает с ними экспериментировать.

Следующим аппаратом, который куплю, скорее всего будет какой-нибудь Бенефон старый или Нокиа - с ними еще не развлекался. Попробую обязательно.

Дронич

Свою Соньку под индексом Z5 я закупил еще полтора года назад, когда в Россию их официально не поставляли. Но я так на нее запал, что пришлось напрягать друзей в Германии и доставлять обновку срочной авиапочтой :). Сначала мобила безумно нравилась, затем также безумно глючила, после чего была перепрошита и стала стабильнее Мандраки. Так что теперь я ни на что не променяю его JOG-dial с тремя степенями свободы и ме-е-е-едленно гаснущую подсветку ;). Единственный планируемый апгрейд - покупка децельной антенны для сокращения занимаемого в кармане джинсов места.

Андрюша Каролик

По жизни нравится фирма Ericsson. Первая трубка была LX588. Радовало наличие виброзвонка, который спасал на лекциях, да и просто приятно не надоедать людям. На этой модели я узнал, что такое активный флип. Не требовалось постоянно тыкать Yes и No, было достаточно открывать и закрывать крышку. Это было актуально, чтобы укладываться в волшебные девять бесплатных секунд :). Но модель эта старая, так что аккумулятор садился за сутки или даже быстрее. Терпел до поры до времени, так как SIM-карта в DAMPS`их моделях не съемная, а номер менять не хотелось. В конце концов купил себе T29 (уже стандарта GSM) и очень рад. Те же навороты LX588 и много всего нового. Аккумулятор держит четыре-пять дней. Единственное, он без поддержки GPRS.

UFO

Был у меня мобильник Panasonic GD 35. Больше всего радовал меня в нем дизайн. Маленький, компактный, удобный и, самое главное, не особо дорогой. Вот некоторые плюсы и минусы, которые мне больше всего запомнились.


Спецвыпуск Xakep, номер #020, стр. 020-014-2, Мобильники Spez-Crew

Мобильники Spez-Crew

n0ah

Спецвыпуск Xakep, номер #020, стр. 020-014-2

Плюсы:

1. Легкий, маленький, занимал немного места.

2. Высокий уровень громкости звонка и хорошая слышимость при разговоре.

3. Поддержка WAP.

4. Поддержка трех текстовых режимов.

5. Виброзвонок.

Минусы:

1. Всего одна игра.

2. Иногда происходили глюки и сбои с сим-картой (говорят, что у этой модели такое происходит часто).

3. При нормальном использовании батареи хватает примерно на полтора суток, а заряжать нужно при полной посадке батареи.

Купил я его в магазине совершенно новым. Бросился он мне в глаза практически сразу, так как искал я не особо дорогой телефон с хорошим дизайном.

Так как продал я его из-за больших проблем с деньгами, то больше всего хотелось бы вернуть его обратно :).

MyDivx

Motorola cd930

Есть все, что надо для мобилы среднего класса. Есть и подача сигнала лампочкой, и вибра, что очень полезно, т.к. я хожу в наушниках с музыкой весь день. Естественно, русифицирована. Люблю форму мыльницы и ненавижу флипы - в этом она как раз под меня. Считаю, что мобила должна быть среднего веса, чтобы чувствовалась в руке, ее 145 гр. по мне идеально - не пукалка и не гиря. Часы и записную книжку я давно с собой не ношу - все это в ней есть. Диктофон на три минуты всегда помогает без всяких карандашей. 700 mAh Ni-MH аккумулятора хватает надолго, к тому же он без эффекта памяти. Один минус меня в ней не устраивает - определитель номера срабатывает только после поднятия трубы. Остальное все как обычно - 200 номеров (100 СИМ и 100 телефон), короткое меню, GSM 900/1800, 4 строки текста + строка иконок + строка служебных пиктограмм, подсветка кнопок, память на последние 10 номеров, ответ любой кнопкой, 10 мелодий и т.д.

di

Была промозглая осенняя пора. Стремительно проносились по автодорогам машины - мчались вдаль, где их след пропадал в потемневшем от дождей горизонте. По витринам катились капли и разбивались о холодные ступени палатки. Я стояла внутри и внимала очередному продавцу, твердившему, что «САМСУНГа А200 В РОССИИ НЕТ! НЕ БУДЕТ!» и «Покупай, что дают!»... Пришлось забить и купить (признаюсь, с дрожью в сердце) Samsung A300... С того времени внутри меня просыпается трепет и что-то урчит каждый раз, как я вижу нежно-голубые щиты со стиральной машинкой, из которой раскинул ножки в синих полиэтиленовых штанишках мальчик, которому звонит «Mark» :)...

Ну ладно - Марк понятно почему звонит! А вот почему телефон понравился мне: во-первых, эти модели - «книжки», т.е. складываются пополам ,), а это просто чума - я люблю только такие модели! Во-вторых, сами по себе очень симпотные, чем вызывают неподдельную радость у своих обладателей :). В-третьих, меню хорошо продумано, есть очень нужные фишки - такие, как календарь с напоминалками, список заданий по приоритетам, несколько будильников, калькулятор и т.п. Да! В комплектацию входят два аккумулятора (один на более долгую работу), наушник и веревочка на руку (незаменимая вещь ;)!).

Правда, все-таки был один баг с этим телефоном: как только я его захотела зарядить первый раз после покупки - он отказался. Пришлось тащиться в сервисный центр - благо, там не было очередей, т.е. есть надежда, что это не повсеместно :)! Ну вот, собственно, и все - очень милый телефончик - с вибратором ,)!


Спецвыпуск Xakep, номер #020, стр. 020-014-3, Мобильники Spez-Crew

Мобильники Spez-Crew

n0ah

Спецвыпуск Xakep, номер #020, стр. 020-014-3

А Марк мне так и не позвонил!..

Др. Добрянский

У меня нет сотового телефона потому, что мне хватает домашнего. Мне постоянно кто-то трезвонит на домашний телефон. А еще меня постоянно спамят по почте. Поэтому я не хочу заводить себе сотовый и ICQ. Многие говорят, что сотовый можно отключить. Но зачем же мне тогда ходить с постоянно выключенным сотовым. А еще сотовый постоянно излучает электромагнитные волны, как микроволновка. Кто знает, что такое информационное воздействие ЭМ полей, меня поймет.

-=R0m@n AKA D0ceNT=- (siriusblack@omen.ru)

Я пользуюсь стареньким Siemens S25 уже года полтора, о чем, собственно и не жалею, и менять пока не собираюсь. Куплен был в магазине, то есть до меня его никто не юзал - не люблю поддержанные мобилы. Модель выбрал такую, потому что в то время (конец 2000 года) ни один новый телефон, который обладал таким набором необходимых мне функций (IrDA, модем, редактор мелодий, вибровызов), не стоил настолько недорого (всего около 100 бачей) - я не люблю дорогие мобилы, слишком обидно будет, если украдут или потеряю. А так получил максимальный результат при минимальных затратах - и поговорить могу, и почту почитать (с помощью Palm), притом не покупая для этого редкий и дорогой провод для подсоединения трубы к Palm'у. У меня это второй по счету телефон - до него был тоже не самый новый и дорогой Alcatel, который тоже вряд ли бы поменял, если бы с приобретением Palm'a не понадобился бы IrDA для выхода в Инет, ну и слишком большой был этот Alcatel. Да и этот буду менять, когда в моей сети GRPS начнет работать. Куплю трубу с поддержкой этой функции. Причем, скорее всего, это тоже будет Siemens - больно уж порадовала меня эта марка - ни разу меня не подвел этот телефон, хотя и падал, и тонул. Немецкое качество, блин.

Unforgiven

К сожалению, сотика нет!

Sterx aka Вячеслав Назарофф

В настоящее время являюсь умеренно счастливым обладателем Мотора в3690. Правда, кто кем периодически обладает - большой вопрос. Аппаратик, безусловно, симпатичный - маленький, легенький и крышкой умеет громко хлопать. Правда, на этом все его полезные функции практически исчерпываются. Это ужасно расстраивает. Ведь, на мой взгляд, очень не хватает ему водоплавающих способностей. Как выяснилось, без них Мотор не выдерживает купания в унитазах пафосных кабаков. Если бы выдерживал - цены бы ему не было. Тогда и в пьяном виде в WC ходить было бы не страшно...

Alex Shark

Моя первая труба была "учебной" - это минимум функций и максимум размера :). Звалось такое чудо Bosch-905. Больше всего поразил их же магазин, где все были сильно удивлены тем, что Bosch вообще производит сотки. В настоящее время имеем Nokia 3310. Выбирал по количеству возможностей и стоимости в районе 100 буказойдов. Когда я продавал винты, позвонили и попросили рассказать подробнее, тут садится батарейка, и я в выключенный телефон упорно начинаю рассказывать, какие именно у меня винты. Минут через пять, глянув на телефон, понял, что общался с выключенной соткой :))).


Спецвыпуск Xakep, номер #020, стр. 020-014-4, Мобильники Spez-Crew

Мобильники Spez-Crew

n0ah

Спецвыпуск Xakep, номер #020, стр. 020-014-4

Ильдар Валитов

Нет мобильника :(!

tSiam

Ericsson r320s

Сей аппарат мне понравился сразу, но купить его оказалось не совсем просто. Два дня я мотался по Москве, искал телефон шведского производства, а не малайзийского, и к концу второго, наконец, нашел. Хоть он и великоват (13 см), зато тонкий (около 1,5 см) и удобно держится в руке, не то что модные нынче "спичечные коробки". Экран большой, с приятной изумрудно-зеленой подсветкой, пятистрочный. Девайс понимает русский язык и отлично распознает голос. Звонок тихий и его плохо слышно в шумных, людных местах. Но его будильник умудрился меня разбудить в 6:00 утра после сильного похмелья (я защитил диплом :)) на балконе у друга, а сплю я очень крепко.

Теперь недостатки. Телефонная книга заполняется очень хитро. Если хочешь записать номер в память телефона, то надо знать, сколько ячеек в сим-карте. У меня, например, 200, и первый номер, записываемый в память телефона, надо записать в 201-ю ячейку! Немного медленное меню (с задержкой сукенды на две-три), но к нему довольно быстро привыкаешь. Подсветка только одного цвета, панельки на корпусе менять нельзя. Отверстие под микрофон в корпусе не закрыто защитным материалом, и туда может набиться всякая пыль. Этот аппарат также не подойдет любителям игр (их всего две), но лично мне оно и не надо. В общем же - надежен, удобен, функционален, и менять его я не собираюсь.

Andrew Fadeev

Мой телефон Siemens S35i Polar Silver

Он у меня недолго, но я к нему быстро привык. Купил я его новенький, сертифицированный. Вообще не люблю "серую" технику. Телефон просто отличный, я им доволен. Самая, для меня важная фича - это инфракрасный порт. Мой Palm тоже его очень любит :). Так что мой e-mail всегда со мной, я легко набираю длинные SMS, так как палмовое граффити удобнее цифровой клавиатуры. Ну и и-нет всегда под рукой.

Реально, что меня бесит во всей 35'ой серии, так это русское меню. Ведь в русских SMS, в русском WAP есть и прописные и строчные буквы, а в меню только большие. Меня это достает настолько, что я пользуюсь английским меню. Вот в 45'ой серии меню, вроде, нормальное.

Ну, как и любая мобила, моя умеет звонить не вовремя. Зато, благодаря Li-ion аккумулятору, не вовремя не выключается.

MadDoc

Мой мобильник - Nokia. И вот почему.

Первую свою трубу я купил за смешные деньги - 30$. Потертый кожаный чехольчик, потускневший дисплей; заряда батареек же хватало всего на двое суток. Осваивая его методом "научного тыка", выяснил, что всего тремя кнопками я могу выполнять 90% необходимых мне действий. Смотри:

Одна центральная кнопка выполняет роль клавиши "Enter" - на ней в каждый момент времени висит наиболее вероятное действие. То есть как только я взял телефон в руки и начал набирать цифры, то этой кнопкой я начну звонок. После этого действие поменяется - и этой же кнопкой я его закончу (не то что в некоторых других аппаратах - одна кнопка на вызов, вторая на отбой). В тяжелых же случаях (например, при написании или просмотре СМС-ок) этой клавой вызывается меню, где все предполагаемые действия пользователя - то есть меня - опять же расположены в порядке убывания вероятности.


Спецвыпуск Xakep, номер #020, стр. 020-014-5, Мобильники Spez-Crew

Мобильники Spez-Crew

n0ah

Спецвыпуск Xakep, номер #020, стр. 020-014-5

И есть еще две кнопки - банальные «вверх» и «вниз». Вниз - и пошла листаться записная книжка. Нажав в этой режиме любую букву алфавита, я получаю запись человека, имя которого начинается с этой самой буквы. Здесь опять же я могу скроллить ее вверх и вниз (вперед и назад), начав затем вызов той самой центральной клавишей. Но больше всего мне понравилось следующее: просто взяв телефон в руки и нажав "вверх", я вызываю "недавно набранные номера". Надо ли писать, что это офигенно удобно? Набрал номер, не дозвонился. Положил трубку, через полчаса перезвонил двумя кнопками - и все! Такая система управления мне не встречалась в аппаратах никакой другой фирмы (эй, обломись - почти все трубы укомплектованы такими хитростями ;) - прим. ред.).

Поэтому, когда тот аппарат был настигнут закономерным финалом (полицаи отобрали, спасибо ребятам!), я купил себе новый. Nokia, как ты понимаешь :-).

Jah!Legio

Мобила у меня - Нокиа 5120. Получил я эту штуку в подарок от подруги - чтоб всегда могла со мной связаться :). Девайс не самый навороченный, мейлы не принимает, к нету не коннектится etc. Но меня он устраивает - привык, привязался - даже имя ему дал: Чувак. Нравится в нем удобство навигации, довольно широкие возможности менюхи, сам брэнд Нокиа и, конечно, встроенные гамесы - до фига лекций в универе я посвятил рекордам в Змейке, даже чемп устраивал. Есть в Чуваке еще одна фича - его будильник разбудит кого угодно. Мерзкий писк с возрастающей громкостью до невероятного ора - только это помогает мне встать часов эдак в 7:00 утра (выключить на фиг и снова спать =)). Однажды телефон у меня упал метров с двух на асфальт - думал все, крышка. Поднял - а Чувак целый, даже экран не треснул, видимо, спецнаработки :). Единственный запар - это брать его на пьянки. Утром найти не могу, звоню на свой номер - а тел выключен, приходится искать, а ведь вечером специально самое укромное место ищу, чтоб занычить Чувака - чтоб не случилось с ним какой беды =). Помыслы о новой мобиле есть - знаю, что это будет Нокиа, рульная/навороченная модель, но мой нынешний тел я никому не отдам - это мой первый сотовый, воспоминания, память о подруге, которая уже ушла =).


Спецвыпуск Xakep, номер #020, стр. 020-018-1, ВСЕ О WAP&WML

ВСЕ О WAP&WML

TanaT (TanaT@yes.ru)

Спецвыпуск Xakep, номер #020, стр. 020-018-1

Disclaimer

Не пугайся, если слова WAP и WML тебе еще не знакомы. WAP это протокол для работы с Интернетом с помощью мобильных телефонов, а WML это язык программирования, на котором создаются "сотовые" странички. К концу этой статьи ты будешь знать не только, что это такое и с чем их едят, но сможешь сам кодить свои собственные страницы и посещать их, даже если у тебя нет мобильника!

Мы представляем твоему вниманию достаточно подробный курс молодого бойца, содержащий не только теоретические основы, но и "продвинутые" приемы, позволяющие автоматизировать процесс кодинга и сделать его приятным и удобным.

WAP

WAP (Wireless Application Protocol) буквально означает - протокол беспроводных приложений. С его помощью такие устройства, как мобильные телефоны, пейджеры и двустороннее радио (two-way radios) получают возможность доступа к различным удаленным сервисам.

Честно говоря, чтобы создавать свои собственные информационные странички, вовсе не обязательно разбираться в самом протоколе и даже знать, что это такое. Однако профессиональный кодер не должен жить в скорлупе своего языка программирования и IDE, поэтому мы все же рассмотрим аспекты WAP, связанные с Интернетом.

Протокол WAP развивается в основном благодаря компании WAP Forum (www.wapforum.org). Она занимается разработкой стандартов и спецификаций, то есть создает общие для всех "правила игры". Сам протокол поддерживается такими гигантами, как Nokia, Phone.com, Motorola и Ericsson, которые и создали WAP Forum. На сайте этой компании можно найти достаточно много дополнительной информации, вводящей в курс дела.

Давай вкратце рассмотрим принцип действия WAP. Основная идея заключается в том, что доступ к ресурсам Интернет осуществляется не напрямую, а через WAP-шлюз. Последний занимается преобразованием WML в HTML и обратно. О самом WML мы поговорим чуть позже. А сейчас надо разобраться, почему возникла необходимость в создании WAP-шлюза. Дело в том, что в каждом устройстве, использующемся для доступа по WAP, встроен микробраузер. Он обладает существенными отличиями от обычного PC браузера. Например, в нем используются всего лишь два цвета (черный и белый), что приводит к определенным трудностям в создании и размещении картинок; также окно микробраузера имеет достаточно малые размеры, вследствие чего возникают нюансы при размещении информации на странице.

Поэтому и нельзя использовать обычные, всем привычные TCP/IP и HTML для работы с сетью через мобильные средства связи. В принципе, остальные особенности WAP имеют сугубо технический характер, выходящий за рамки данной статьи. Поэтому мы плавно переходим к WML. А напоследок немного статистики. Достаточно популярный в рунете сайт www.wapgate.ru провел исследование, характеризующее популярность WAP в России. Результаты следующие: 32% исследуемых фирм имеют свой WAP-сайт, 41% - не имеет, а 27% планируют его разработку. Самым популярным средством доступа к WAP-страницам стал WAP-телефон, около 50%.

WML

WML (Wireless Markup Language) это язык, используемый для создания WAP-страниц. Неправда ли, расшифровка его аббревиатуры очень напоминает расшифровки XML (eXtensible Markup Language) и HTML (Hyper Text Markup Language)? И это не случайно. Дело в том, что WML есть некая смесь этих двух языков, спроектированная в жестких рамках требований, предъявляемых микробраузером. Для полноты рассмотрения надо отметить, что вначале для работы с WAP существовал не только WML, но еще и HDML (к сожалению, я не знаю, как расшифровывается данная аббревиатура, а сочинять не имею права). Однако HDML не прижился, и в более поздних реализациях WAP был исключен. WML является общим стандартом почти для всех микробраузеров (что-то типа HTML для PC браузеров или ANSI C++ для Windows&Unix), однако некоторые компании, занимающиеся мобильными технологиями, разработали собственные языки, поддерживаемые, естественно, только их микробраузерами. Например, компания Motorola разработала свой VoxML. Изучить весь WML в рамках одной статьи достаточно непросто, однако в этом нет необходимости, так как в этом языке очень много заимствовано из HTML. Поэтому знание этого языка очень сильно пригодится при создании WAP-страниц. К тому же существуют программы, позволяющие создавать WAP-страницы с помощью визуального интерфейса, при этом редактирование WML-кода почти не требуется, а в некоторых случаях невозможно в принципе.


Спецвыпуск Xakep, номер #020, стр. 020-018-2, ВСЕ О WAP&WML

ВСЕ О WAP&WML

TanaT (TanaT@yes.ru)

Спецвыпуск Xakep, номер #020, стр. 020-018-2

Полную спецификацию WML можно найти на www.wapforum.org или в SDK от какой-нибудь "мобильной" компании, например, Motorola. Между прочим, в рунете достаточно много переводов Motorola SDK (он самый популярный), рассказывающих в деталях и на вполне доступном языке принципы создания WML-кода. Скачать сам Motorola SDK (что, безусловно, захочется сделать любителям копаться в первоисточнике) можно с сайта компании-составителя SDK: http://developers.motorola.com/developers/wireless/tools. Однако вначале придется зарегистрироваться (это бесплатно). А вот где можно найти переводы:

- http://kunegin.narod.ru/ref2/wap/wap7.htm - введение в WML;

- http://kunegin.narod.ru/ref2/wap/wap8.htm - описание тегов WML;

- http://www.wapgate.ru/info/wml.php3 - все вместе взятое.

Мы же рассмотрим базовые концепции, лежащие в основе программирования любой WAP-страницы. Прежде всего нужно уяснить, что WML-код построен на контейнерах. Контейнер - это такой элемент (или объект), включающий в себя другие элементы (объекты). Например, весь WML-код должен размещаться между двумя тегами <wml> и </wml> (первый из них открывающий, второй закрывающий). Таким образом, wml это контейнер, который может содержать в себе бог его знает сколько еще элементов и других контейнеров.

Ты, наверное, обратил внимание, что синтаксис тегов сильно похож на синтаксис HTML? Однако WML заимствовал из HTML не только эту особенность синтаксиса. По-прежнему многие элементы могут иметь атрибуты, характеризующие какие-либо их свойства. Подробнее это мы обсудим далее. Раз уж мы заговорили о тегах, то скажу сразу, что теги бывают открывающие, закрывающие и одиночные. Первые два мы уже видели, а примером третьего может служить классический тег принудительного перехода на следующую строчку <br>. Любая WAP-страничка должна иметь расширение .wml, а каждый сервер, размещающий у себя такие страницы, должен быть правильно сконфигурирован, чтобы корректно обрабатывать WAP-запросы. Подробнее о конфигурации сервера можно почитать на сервере www.wapgate.ru в разделе "Как настроить сервер".


Спецвыпуск Xakep, номер #020, стр. 020-018-3, ВСЕ О WAP&WML

ВСЕ О WAP&WML

TanaT (TanaT@yes.ru)

Спецвыпуск Xakep, номер #020, стр. 020-018-3

Теперь посмотрим, из каких же основных частей состоит любой корректный WML-код. А состоит он из заголовка и карт, объединенных в колоды. С заголовком все достаточно просто: это три стандартные строчки, содержащие информацию о номере версии XML, идентификаторе SGML-описания языка WML и веб-адресе DTD-определения WML-документа. Чаще всего кодеры пользуются WML-редакторами, которые вставляют эти данные в страницу автоматически. Так что запоминать это не обязательно. Для полноты картины надо отметить, что заголовок обычно имеет следующий вид:

<!-- Это номер версии XML -->

<?xml version="1.0"?>

<!-- Идентификатор SGML-описания языка WML -->

<!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"

<!-- Веб-адрес DTD-определения WML-документа -->

"http://www.wapforum.org/DTD/wml_1.1.xml">

Кстати, комментарии в WML вводятся точно так же, как и в HTML: между двумя тегами <!-- и -->. Также обрати внимание на адрес: http://www.wapforum.org/DTD/wml_1.1.xml. Надеюсь, теперь ты понимаешь всю роль компании WAP Forum в организации связи между Интернетом и мобильными средствами связи :))) ?

После заголовка следуют карты, объединенные в колоды (или деки). Это уже абсолютно новые понятия, появившиеся в WML и отличающие его и от HTML, и от XML. Карта это совокупность страничек, а колода это совокупность карт, загружаемых за один раз. Зачем они нужны? Дело в том, что экран микробраузера достаточно мал, поэтому грузить страницы раздельно друг от друга просто невыгодно, так как на это будет тратиться много времени. А загружать страницы "пачками" намного быстрее. Такими пачками и являются карты. Далее поднимаемся еще на один уровень выше: карты тоже легче грузить не по одной, а колодами. В этих двух понятиях и состоит основное отличие WML-документов. Для каждого микробраузера (мобильного телефона) существует свой собственный максимальный размер колоды. Обычно он не превышает 8 кб (помни, ведь маленькие "мозги" твоего мобильника - это не CPU от Intel с КЭШами трех уровней). Все карты должны отделяться друг от друга заголовками, включающими в себя идентификатор карты и ее имя. Идентификатор служит лишь для вызова этой карты, например, из другой карты. Вот пример такого заголовка:

<!-- Пример заголовка карты -->

<card id="CardID" title="MyCard">

<!-- Здесь идет код -->

</card>

Как видишь, карта является контейнером, в котором размещаются элементы. Идентификатор карты и ее имя (в нашем примере это CardID и MyCard соответственно) являются атрибутами контейнера. Тэги форматирования практически совпадают с аналогичными из HTML (и по синтаксису, и по назначению). Например, выравнивание абзацев производится так:


Спецвыпуск Xakep, номер #020, стр. 020-018-4, ВСЕ О WAP&WML

ВСЕ О WAP&WML

TanaT (TanaT@yes.ru)

Спецвыпуск Xakep, номер #020, стр. 020-018-4

<p align="center"> - по центру

<p align="left"> - по левому краю

<p align="right"> - по правому краю

А картинки вставляются так:

<img src="Здесь идет путь к картинке" alt="Здесь идет альтернативное имя">

Гиперссылки оформляются так:

<a href="#Идентификатор">

Вместо слова "Идентификатор" должен стоять идентификатор той карты, куда указывает гиперссылка.

Теперь можно подробнее рассмотреть графику в WAP-страничках. Графикой это можно назвать с натяжкой - микробраузер понимает лишь черно-белые картинки в формате WBMP (Wireless BMP). Для того чтобы конвертировать любой графический формат (для gif, jpg и bmp точно) в wbmp, надо воспользоваться либо on-line конвертером по адресу www.teraflops.com/wbmp, либо специальным графическим редактором. Достаточно большой список таких редакторов можно найти по адресу: http://www.wapgate.ru/soft/?s=4. От себя могу добавить, что качество полученной WBMP-картинки сильно зависит от ее контрастности: чем контрастнее, тем лучше.

Вставляемая картинка может иметь следующие параметры, прописываемые в тэге: localsrc, align, height и width (alt - мы уже рассмотрели). Думаю, с align вопросов не возникнет (это выравнивание), height и width это, соответственно, высота и ширина (в пикселях) картинки. Атрибут localsrc позволяет выводить на экран картинку, специфичную для данного микробраузера. Список таких картинок должен быть подробно изложен в техническом руководстве браузера.

Есть еще некоторые тонкости, о которых не стоит забывать:

- WML различает заглавные и строчные буквы, поэтому будь осторожен.

- не все микробраузеры поддерживают русский язык, поэтому дублируй всю информацию в транслите (пиши английскими буквами русские слова), а в начале страницы предлагай выбор между русским и транслитом;

- обязательно отлаживай свою страницу в эмуляторе микробраузера, чтобы посмотреть, как она будет выглядеть на маленьком экране мобильного телефона. Такие эмуляторы можно найти в WML-редакторах (о них ниже) или на сайтах, к примеру, на www.wapgate.ru

Вот, в принципе, и все, что хотелось тебе рассказать. Теперь ты знаешь, где и как кодить, где размещать страницы и найти дополнительную информацию. Интернет ждет твоей WAP-странички!

После того как ты сделаешь свою страницу или целый узел, тебе, безусловно, захочется разместить его в сети. В таком случае пригодится список ресурсов, предоставляющих WAP-хостинг. Должен признаться, что в Интернете достаточно мало сайтов, предоставляющих такой хостинг бесплатно. Я нашел только три:

- http://wappy.to/

- http://tagtag.com/site/index.php3

- http://www.wapdrive.com/

На каждом из этих сайтов можно найти дополнительную информацию, касающуюся WAP и WAP Tools (эмуляторы и редакторы). А некоторые предоставляют также коллекцию собственных wbmp-картинок.

БЫСТРЫЙ СТАРТ

Для того чтобы начать быстро кодить свои страницы на уровне профи, созданы WML-реадкторы. Если еще год назад их было всего штук пять на весь Интернет (не рунет, а Интернет), то сейчас их не менее двух десятков. Насколько они полезны, мы сейчас разберемся. Честно говоря, обзор WML-редакторов это тема отдельной статьи. Поэтому мы рассмотрим лишь два самых лучших из них.


Спецвыпуск Xakep, номер #020, стр. 020-018-5, ВСЕ О WAP&WML

ВСЕ О WAP&WML

TanaT (TanaT@yes.ru)

Спецвыпуск Xakep, номер #020, стр. 020-018-5

DotWap (Freeware, download.inetis.com/files/DotWAP2.EXE, 696 кб)

Очень удобная штучка, этот DotWap. Помнишь, в начале статьи я рассказывал о программке, позволяющей клепать WAP-страницы без знания WAP&WML? Так вот, это она и есть. Очень понятный интерфейс (типа проводника в Windows), наличие WAP-эмулятора, автоконвертер любых графических форматов в WBMP и огромная коллекция тегов - все это делает процесс написания (даже не написания, а щелканья на пунктах разных меню) не просто удобным, а приятным. Самое интересное, что в этой программе даже нет окна, позволяющего редактировать WML-код. Зато есть различные пункты меню: добавить страницу, параграф, ссылку, рисунок. В эту программу встроена функция автоматического хостинга с сервером tagtag (второй в нашем списке бесплатных хостеров), что, безусловно, приятно, так как позволяет закачивать свои данные прямо на нужный сервер. В общем, все сделано очень удобно и, главное, понятно.

EasyPad WAPtor (Shareware, http://www.waptop.net/software/waptor3.exe, 1209 кб)

Честно говоря, вначале хотел предложить тебе ссылочку либо на crack, либо на s/n для этой программки. Однако был неприятно удивлен отсутствием ее вообще. Видимо, программка слишком молодая :(.

Что же она предлагает? В возможности этой программы входит: конвертирование графики в WBMP, эмулятор микробраузера и огромное число шаблонов. Если сравнивать ее с предыдущей, то можно придти к следующему выводу: она позволяет настраивать страницы более гибко, однако для этого требуются знания WML. Здесь напрашивается параллель: C++ Builder и MS Visual C++. Первый точно так же, как DotWap, поддерживает технику визуального программирования, а второй, как WAPtor, содержит множество шаблонов. Должен признаться, что WAPtor более мощная программа (на это косвенно указывает ее больший размер и шароварность). Ее интерфейс тоже достаточно понятен и кое-где даже более удобен, чем интерфейс DotWap. Но все же не следует забывать, что знание WML здесь является необходимым.

Резюме: если ты только начинаешь кодить свои первые странички, то без раздумий выбирай DotWap. Его маленький размер и бесплатность лишь небольшие плюсы. Главное, полностью визуальный интерфейс и много дополнительных инструментов (конвертор+эмулятор) помогут тебе втянуться и стать профи. Если ты опытный профи, знающий WML, как свои пять пальцев, то гибкий WAPtor это твоя стихия. Однако, в любом случае, тебе ничто не мешает использовать две эти программы одновременно или поочередно, в зависимости от сложившихся обстоятельств.


Спецвыпуск Xakep, номер #020, стр. 020-022-1, ЛЕГАЛЬНЫЙ ФРИК

ЛЕГАЛЬНЫЙ ФРИК

Спецвыпуск Xakep, номер #020, стр. 020-022-1

универсальные GSM-коды

Андрей «Дронич» Михайлюк (dronich@real.xakep.ru)

В наше время единственной общей чертой всех мобильников стандарта GSM можно назвать только присутствие на них цифровой клавы :). Ведь в реальности очень сложно заставить разношерстных производителей клепать стандартизированные одинаковые мобилы. Но осталось еще одна неприкосновенная фича, от которой не отказывался еще ни один мобильный магнат. Это стандартные коды для ВСЕХ телефонов, работающих в сетках GSM.

ДО ЧЕГО ЦЕ ПОТРЕБНО

С одной стороны, эти коды дублируют функции мобил, доступные и через меню. Но посуди сам, как живется менеджеру салона сотовой связи, к которому каждые десять минут пристают с просьбами «поменять ПИН». Если бы не универсальные коды, ему пришлось бы держать в голове структуру меню почти сотни моделей телефонов. Так что если ты не менеджер салона связи, обязательно ознакомься с ними - по жизни пригодится.

СТАНДАРТЫ

Все стандартные коды начинаются со звездочек или решеток. Соответственно, по началу кода можно определить его предназначение:

Если в начале кода ты видишь «*#», то этот код показывает статус фичи.

Если в начале кода «**», то данный код включает и активирует одну из фич телефона.

Если в начале «*», то он только активирует фичу (включать надо отдельно).

Если в начале «##», то данный код выключает и деактивирует одну из фич телефона.

Если в начале «#», то... ну, кто самый сообразительный? Точно, просто деактивирует :).

НЕПОСРЕДСТВЕННО ЦИФИРИ

Самый главный код, который ты просто обязан выучить наизусть, - *#06#. Этот код выведет на экран индивидуальный серийный номер мобилы. Для чего? Да так просто, попонтоваться %). Если серьезно, то этот номер можно заюзать для контроля «чистоты» твоего телефона. Если он не совпадает с нацарапанным на задней крышке - пора бить тревогу. Одно из двух: либо телефон был криво разлочен, либо его потырили у богатого дядьки, похакали и спихнули тебе :). И то и другое малоприятно, так что бди.

ПИНы и ПУКи

Смена ПИН: **04*[старый ПИН]*[новый ПИН]*[новый ПИН]#[yes]

Смена ПИН2: **042*[старый ПИН2]*[новый ПИН2]*[новый ПИН2]#[yes]

Разблокировка ПИН: **05*[ПУК]*[новый ПИН]*[новый ПИН]#[yes]

Разблокировка ПИН: **052*[ПУК2]*[новый ПИН2]*[новый ПИН2]#[yes]

ПЕРЕАДРЕСАЦИЯ ВООБЩЕ

Деактивировать все виды переадресации: ##002#[yes]

Деактивировать все условные переадресации: ##004#[yes]

Активировать все условные переадресации: **004*[номер телефона]#[yes]

И ПО ВИДАМ

Все звонки

Деактивировать и выключить переадресацию звонков на другой номер: ##21#[yes]

Деактивировать переадресацию звонков на другой номер: #21#[yes]

Задать номер и активировать переадресацию звонков на другой номер: **21*[номер телефона]#[yes]

Активировать переадресацию звонков на другой номер: *21#[yes]

Проверить статус переадресации звонков на другой номер: *#21#[yes]

Звонки без ответа

Активировать переадресацию звонков на другой номер, если абонент не отвечает: **61*[номер телефона]#[yes]

Деактивировать и выключить переадресацию звонков, если абонент не отвечает: ##61#[yes]

Деактивировать переадресацию звонков, если абонент не отвечает: #61#[yes]


Спецвыпуск Xakep, номер #020, стр. 020-022-2, ЛЕГАЛЬНЫЙ ФРИК

ЛЕГАЛЬНЫЙ ФРИК

Спецвыпуск Xakep, номер #020, стр. 020-022-2

Активировать переадресацию звонков, если абонент не отвечает: *61#[yes]

Проверить статус переадресации звонков, если абонент не отвечает: *#61#[yes]

Абонент вне зоны

Активировать переадресацию звонков на другой номер, если абонент находится вне зоны покрытия: **62*[номер телефона]#[yes]

Активировать переадресацию звонков, если абонент находится вне зоны покрытия: *62#[yes]

Деактивировать и выключить переадресацию звонков, если абонент находится вне зоны покрытия: ##62#[yes]

Деактивировать переадресацию звонков, если абонент находится вне зоны покрытия: #62#[yes]

Проверить статус переадресации, если абонент находится вне зоны покрытия: *#62#[yes]

Занято

Активировать переадресацию звонков на другой номер, если телефон занят: **67*[номер телефона]#[yes]

Активировать автоматическую переадресацию звонков, если телефон занят: *67#[yes]

Деактивировать и выключить переадресацию звонков, если телефон занят: ##67#[yes]

Деактивировать переадресацию звонков, если телефон занят: #67#[yes]

Проверить статус автоматической переадресации, если телефон занят: *#67#[yes]

Гудки до переадресации

Установить количество гудков: **61*НомерГолосовойПочты**[кол-во гудков]#[yes]

Отменить предыдущую установку ##61#[yes]

ЗАПРЕТ ВСЕХ ИСХОДЯЩИХ ЗВОНКОВ

Изменить пароль для запрета вызова: **03*330*старыйПароль*новыйПароль*новыйПароль#[yes]

Активировать запрет всех исходящих звонков: **33*Пароль#[yes]

Деактивировать запрет всех исходящих звонков: #33*Пароль#[yes]

Проверить статус запрета всех исходящих звонков: *#33#[yes]

ЗАПРЕТ ВСЕХ ЗВОНКОВ

Активировать запрет всех звонков: **330*Пароль#[yes]

Деактивировать запрет всех звонков: #330*Пароль#[yes]

Проверить статус запрета всех звонков: *#330*Пароль#[yes]

ЗАПРЕТ ВСЕХ ИСХОДЯЩИХ МЕЖДУНАРОДНЫХ ЗВОНКОВ

Активировать запрет всех исходящих международных звонков: **331*Пароль#[yes]

Деактивировать запрет всех исходящих международных звонков: #331*Пароль#[yes]

Проверить статус запрета всех исходящих международных звонков: *#331#[yes]

ЗАПРЕТ ВСЕХ ИСХОДЯЩИХ ЗВОНКОВ

Активировать запрет всех исходящих звонков: **333*Пароль#[yes]

Деактивировать запрет всех исходящих звонков: #333*Пароль#[yes]

Проверить статус запрета всех исходящих звонков: *#333#[yes]

ЗАПРЕТ ВСЕХ ВХОДЯЩИХ ЗВОНКОВ

Активировать запрет всех входящих звонков: **35*PW#[yes] или **353*Пароль#[yes]

Деактивировать запрет всех входящих звонков: #35*PW#[yes] или **353*Пароль#[yes]

Проверить статус запрета всех входящих звонков: *#35#[yes] или *#353#[yes]

ЗАПРЕТ ВСЕХ ВХОДЯЩИХ ЗВОНКОВ ПРИ РОУМИНГЕ

Активировать запрет всех входящих звонков при роуминге: **351*Пароль#[yes]

Деактивировать запрет всех входящих звонков при роуминге: #351*Пароль#[yes]

Проверить статус запрета всех входящих звонков при роуминге: *#351#[yes]

ОЖИДАНИЕ ВЫЗОВА

Активировать ожидание вызова: *43#[yes]

Деактивировать ожидание вызова: #43##[yes]

Проверить статус ожидания вызова: *#43#[yes]

ПОСЫЛКА/ЗАПРЕТ ПОСЫЛКИ НОМЕРА ВАШЕГО ТЕЛЕФОНА ПРИ ЗВОНКЕ

Запретить посылку номера телефона: #30#[номер телефона] [yes]


Спецвыпуск Xakep, номер #020, стр. 020-022-3, ЛЕГАЛЬНЫЙ ФРИК

ЛЕГАЛЬНЫЙ ФРИК

Спецвыпуск Xakep, номер #020, стр. 020-022-3

Разрешить посылку номера телефона: *30#[номер телефона] [yes]

Проверить статус посылки номера вашего телефона: *#30#

КОДЫ ДЛЯ ПОСЫЛКИ/ЗАПРЕТА ОПРЕДЕЛЕНИЯ НОМЕРА ДЛЯ ВХОДЯЩИХ ЗВОНКОВ

Запретить отображение номера звонящего на телефоне: *77#

Разрешить отображение номера звонящего на телефоне: #77#[yes]

Проверить статус отображения номера звонящего на телефоне: *#77#[yes]

Вот вроде и все. Можешь идти понтоваться перед очередными девчонками, выставляя себя продвинутым фрикером. Кстати, под телефоны определенных марок есть и свои специфические коды, так что все на Яндекс - ищите и обрящете.


Спецвыпуск Xakep, номер #020, стр. 020-024-1, ДИНАМИКА ЦЕН НА УСЛУГИ СОТОВОЙ СВЯЗИ

ДИНАМИКА ЦЕН НА УСЛУГИ СОТОВОЙ СВЯЗИ

Спецвыпуск Xakep, номер #020, стр. 020-024-1

Валитов Ильдар (ildar@arat.ru)

В качестве обследуемых возьмем двух господствующих на столичном рынке в стандарте GSM операторов: "Би Лайн" и МТС

На данный момент используется авансовая система оплаты, при которой абонентская плата взимается посуточно

Графики не покажут тебе всей сути происходящего, так как основные изменения в расценках происходили во внутренней зоне

Если тебя "недоудовлетворила" приведенная здесь статистика, смело ищи подробности в Интернете

Сотовая связь прочно обосновалась в жизни мобильной общественности. Теперь, когда с момента ее появления прошло достаточно много времени, хорошо видно, в каком русле идет развитие. Также можно разглядеть борьбу операторов за место под солнцем мобильной связи. Как правило, в конкурентной борьбе на рынке услуг выигрывает потребитель. Относится ли это к мобильной связи, а также как протекает ценовая война - вот в чем нам с тобой придется разобраться. Но прежде чем обратиться к истории мобилизации, посмотрим, что мы имеем там в настоящий момент времени.

СУХОЙ ОСТАТОК

Итак, всегда интересно знать конечный результат свершенного. С этого и начнем. В качестве обследуемых возьмем двух господствующих на столичном рынке в стандарте GSM операторов: «Би Лайн» и МТС. Имеющиеся у них тарифные планы можно классифицировать по различным параметрам, одним из таких является предпочтительный траффик, выраженный в минутах. На сайтах операторов компаний обнаружилось следующее: МТС приводит расценки на семь планов, "Би Лайн" занимается продвижением пяти.

К примеру, если ты без остановки говоришь по телефону, то тебе нужен безлимитный тариф или тот, в котором заранее оплачен некоторый минимум времени. Можешь выбрать, посмотрев на графики, тот, который тебе по душе. Сразу оговорюсь - на графиках показана условная стоимость разговоров в зависимости от конкретного тарифа, при многих допущениях, таких, как: разговоры лишь в пиковое время, учет только исходящих звонков в местной зоне оператора. Как ты заметил, не учтены авансовые схемы оплаты, гарантийный взнос: для тарифа "Супер-GSM" он составляет $195, авансовый платеж в тарифе "Эксклюзив" - $350. Также стоимость подключения будет зависеть от номера - московский или федеральный; варьируется первоначальный взнос. Однако это не все особенности, например, в "дорогих" безлимитных тарифах предусмотрены значительные скидки на междугороднюю и международную связь, упрощена система оплаты, и на нашем графике тариф "анлимитед" параллелен оси времени. В тарифах среднего ценового уровня имеется, как уже было сказано, оплаченный минимум разговоров, при превышении которого вступает в силу тот или иной тип тарификации; графики таких тарифов представляют собой ломаную, например, тарифы "Активный", "Рекорд 500". В первом случае ты проговоришь "на халяву" 300 минут, каждая последующая минута будет выливаться в отдельную сумму, во втором, как следует из названия, - 500 минут. В тарифах, выгодных при небольшом количестве разговоров, предоплата достаточно мала, графики представляют собой прямую, наклон которой зависит от стоимости исходящей связи.


Спецвыпуск Xakep, номер #020, стр. 020-024-2, ДИНАМИКА ЦЕН НА УСЛУГИ СОТОВОЙ СВЯЗИ

ДИНАМИКА ЦЕН НА УСЛУГИ СОТОВОЙ СВЯЗИ

Спецвыпуск Xakep, номер #020, стр. 020-024-2

На данный момент используется авансовая система оплаты, при которой абонентская плата взимается посуточно. На графиках эта оплата выражается в начальных точках.

Вперед! В прошлое!

Ну, теперь спокойно можно приступать к осмыслению истории. В поле нашего зрения окажутся древние тарифы тех же операторов. Однако некоторые тарифы в настоящее время либо отсутствуют, либо имеются в ограниченном виде. Около четырех лет назад появился тариф "Сити-100", "оснащенный" прямым московским номером, он "весил" $19 абонентской платы и $0.59 за дневную минуту общения. Немного "тяжелее" выглядел в то же время тариф "Сити-200" с абонентской платой уже в $39, но зато поговорить теперь можно "всего" за $0.39 в минуту. И чтобы группа была полной, имелся их старший брат тариф "Сити-300", обходившийся его обладателю в $59 в месяц, при этом независимо от времени суток минута разговора стоила $0.33. В 1999 году "Би Лайн" подарил нам три интересных тарифа: "GSM-Серебряный", "GSM-Золотой", "GSM-Платиновый". "Золотой" и "Платиновый" имели прямые московские номера, "Серебряный" - "8-901...".

Появившись, они буквально через небольшой промежуток времени (см. график) стали чуточку доступнее. Разве лишь "Серебряный" не претерпел явных изменений в цене, однако приобрел посекундную тарификацию после первой минуты и скидку 50% при звонках на сотовые телефоны сети "Би Лайн". Последнее относится и к двум другим тарифам.

В 2000 году эти тарифы лишились приставки "GSM-", при этом сделавшись более привлекательными: помимо снижения стоимости звонков они приобрели "бесплатное время" - некоторый минимум, берущийся из абонентской платы, который тратился собственно на разговоры, к тому же у них летом "народился" младший братишка - тариф "Бронзовый" с ежемесячной оплатой всего $5 и круглосуточной таксой в $0.20. Осенью того же года, когда летняя жара начала спадать, "Би Лайн" представил новую линейку тарифов: "Ты и Я", "Профессионал", "Лидер" и "Бизнес". Динамика их изменения прослеживается в течение года, если принять во внимание то, что добавилась зона "Область", цены на которую были ниже, чем в зоне "Москва". Абонентская плата за этот период также была уменьшена на $1 по всем тарифам и на июнь 2001 года составила: "Профессионал" - $4, "Лидер" - $9, "Бизнес" - $21.

Что же в это время творил МТС? Она тоже не сидела на месте и упорно экспериментировала с ценами и названиями тарифов. Исследуем и их. Так как тарифная сетка разбита по периоду звонков, мы условно разделим их на "день", "вечер" и "ночь" и для простоты рассуждений возьмем лишь данные по местным звонкам. Характерные изменения в течение длительного периода времени (2-3 года) претерпели тарифы "Молодежный" и "Локальный" (МТС), из графиков которых видно, что в большей степени скинулись расценки на ночные и вечерние тарифы, тогда как дневной либо не изменялся, либо делал это в незначительной степени. Снижение цен касалось не только оплаты времени, но и абонентской оплаты.

Опять здесь графики не покажут тебе всей сути происходящего, так как основные изменения в расценках происходили во внутренней зоне, то есть на звонках с мобильника на мобильник одного оператора или звонков в так называемую зону "Область". С учетом этого сброс цен оператором выглядит более эффектно. Некоторые аналитики давали более 30% снижения оплаты на использование телефонов, связанных именно с уменьшением тарифов внутри сети оператора.


Спецвыпуск Xakep, номер #020, стр. 020-024-3, ДИНАМИКА ЦЕН НА УСЛУГИ СОТОВОЙ СВЯЗИ

ДИНАМИКА ЦЕН НА УСЛУГИ СОТОВОЙ СВЯЗИ

Спецвыпуск Xakep, номер #020, стр. 020-024-3

Переключимся напоследок на "Би Лайн". Безлимитный тариф "Супер-GSM" начал свое существование летом 2000 года с абонентской платой $195, теперь же налицо снижение ее на $30.

Были ли снижения тарифов у обеих компаний следствием конкурентной борьбы - безусловно, были, только вот война эта была тщательно закамуфлирована рекламными кампаниями, введениями новых тарифов, привлечением инноваций. Так что сейчас, даже тогда, когда она продолжается, мы уже можем пожинать плоды этой, пусть не смертельной, битвы - более широкое распространение сотовой связи среди населения, улучшение качества обслуживания.

НАЗАД В БУДУЩЕЕ

Настало время чего-нибудь напророчить. Скорее всего, падение цен будет медленно приостанавливаться, пока не достигнет критической точки, вокруг которой и будут идти "пляски". Завлечение новых абонентов будет происходить не столько по ценовым качествам, сколько по другим - качество обслуживания, внедрение новых технологий, охват все больших территорий. Возможно, будут придумываться новые тарифы с изощренными названиями. Это мы сейчас уже наблюдаем: вовсю идет разворачивание GPRS, MMS, о WAP не слышал лишь ленивый, - примеров достаточно. Если тебя "недоудовлетворила" приведенная здесь статистика, смело ищи подробности в Интернете, благо аналитики там выше крыши. А свежие тарифы по рассмотренным операторам смотри здесь: www.mts.ru, www.beeline.ru, и, как известно, у этих фирм поднимается конкурент: www.megafon.ru, который не скупится на ценовые сюрпризы. Эти ребята, не успев появиться, растрясли весь рынок, найдя и надавив на две самые его болевые точки: безлимитка на ВСЕ входящие звонки и посекундная тарификация с ПЕРВОЙ секунды. В первых же мегафоновских тарифах («5+», «5+ СИТИ» и т.д.) все входящие звонки, включая с городских номеров, оплачивались как минута разговора, вне зависимости от его продолжительности. Чуть позже появился тариф «GSMЛАЙТ», в котором все звонки тарифицируются посекундно, начиная с первой же секунды - сколько наговорил, ровно столько и заплатил. Еще эти ребята бомбят рынок такими фишками, как несгораемые остатки на счетах (в конце месяца, при неуплате, остаток замораживается, а не обнуляется), всякими бонусами (на счет кладется больше денег, чем ты оплатил при регистрации) и прочими мелкими приятностями.

Короче, скучно нам не будет. Кстати, все цифры и расценки, упомянутые в статье, для солидности можешь покрыть налогами - они почти во всех случаях не включены в сумму.


Спецвыпуск Xakep, номер #020, стр. 020-028-1, GPRS

GPRS

Спецвыпуск Xakep, номер #020, стр. 020-028-1

к третьему поколению мобильной связи

Andrew Fadeev (andrewf@ukr.net)

Изо дня в день росла потребность в передаче данных: видео, звука, форматированного текста. Как сейчас модно говорить - «multimedia content».

Третье поколение должно обеспечить дуплексную передачу видео (видеофон), мобильную коммерцию (mCommerce), онлайн игры и нирвану по карточкам.

Возможно, плату будут взимать не за время пользования, а за количество пакетов данных, а пакеты голосовых данных маленькие, и разговоры в теории должны стать значительно дешевле. Я не знаю, как кому, но мне такие перспективы нравятся.

В каждом радиоканале имеется восемь временных отрезков, грубо говоря - каналов. Эти восемь каналов делят полосу частот шириной в 200 кГц. Пользователю предоставляется один из восьми каналов.

Система управления данными GPRS основана на протоколе угадайте-сами-каком. Правильно, IP.

ВХОД ЗДЕСЬ

Передача голоса на расстоянии из любого места в любое другое перестала быть диковинкой. Мобильная телефонная связь стала скорее необходимостью, чем возможностью. Даже в школах перед началом уроков теперь просят сдать телефоны преподавателю. Хотя последний факт связан скорее с культурой пользования (большинство людей игнорируют возможность отключения сигналов и существование виброзвонка), но масштабы иллюстрирует. До последнего времени мобила не предоставляла никаких возможностей кроме как голосовой связи и куцых текстовых сообщений. Существующие сети, так называемое второе поколение (2G), таким требованиям удовлетворяют. Но изо дня в день росла потребность в передаче данных: видео, звука, форматированного текста. Как сейчас модно говорить - «multimedia content». Итак, нам попытались дать Интернет. Вот тут 2G стала узким местом. Самая распространенная сеть в Европе GSM - Global System for Mobile communications - обеспечивала скорость передачи до 9,6 к/бит. Для существующего Интернета во всем его буйстве красок этого оказалось мало. Однако решение, казалось, было найдено. WAP - Wireless Application Protocol - должен был обеспечить подключение к Интернет низкоскоростных устройств с маленькими дисплеями. Для этого владельцу сайта нужно было сделать отдельную его версию на языке WML (Wireless Markup Language - дитя HTML и XML), а пользователю телефона со встроенным модемом и WAP программой зайти на этот сайт и наслаждаться. Нельзя сказать, что WAP провалился. Нет, он и сейчас работает, но не сыскал такого успеха, как ему предрекали. Причин много, но главные это то, что владелец сайта должен создавать отдельную версию своей страницы. Вторая причина - хоть файлы страничек получаются маленькие, 9600 - скорость катастрофически медленная, и загрузки страницы приходится ждать минуту, а то и больше. Притом, что WAP-доступ стоит в среднем в шесть раз дороже, чем полноценный доступ в Интернет, скажем, из дома (я исхожу из того, что час Интернета у среднего провайдера стоит столько, сколько десять минут пользования WAP). Но людям все равно нужен был Интернет и многое другое, так сказать, не отходя от кассы - в кармане.


Спецвыпуск Xakep, номер #020, стр. 020-028-2, GPRS

GPRS

Спецвыпуск Xakep, номер #020, стр. 020-028-2

3G - ТРЕТЬЕ ПОКОЛЕНИЕ

Когда была признана необходимость увеличивать скорости, инженеры сели работать, а PR-отделы принялись вещать о скором приходе третьего поколения. Третье поколение должно обеспечить дуплексную передачу видео (видеофон), мобильную коммерцию (mCommerce), онлайн-игры и нирвану по карточкам :). А основой всего этого должно стать тотальное повышение скоростей. Стандартов опять развели кучу, но обещают обеспечить совместимость интерфейсов. Общим можно назвать такие пункты, как высокая скорость передачи данных (в идеале до 2 Мб/с) и использование высокочастотного радиодиапазона (около 2ГГц). На нашей территории наиболее вероятно будет таки применен UMTS (Universal Mobile Telecommunication System).

UMTS. ЧЕГО НАМ ЖДАТЬ?

UMTS готовит нам много вкусненького: многочисленные услуги мультимедиа, включая высокоскоростной доступ в Интернет и передачу данных, видео, речи, факсов любому абоненту с использованием мобильного терминала, имеющего единый уникальный номер для всех сетей связи и обеспечивающего связь в любой точке, при любой скорости перемещения абонента. Также, возможно, плату будут взимать не за время пользования, а за количество пакетов данных, а пакеты голосовых данных маленькие, и разговоры в теории должны стать значительно дешевле. Я не знаю, как кому, но мне такие перспективы нравятся. Хоть я никогда не был особым любителем онлайновых посиделок, перспектива быть доступным всегда, для любого вида связи мне нравится. По обычному мобильнику не везде удобно говорить, а SMS это не ICQ. Компьютер и Интернет для меня инструмент поиска ответов на различные вопросы. Но до такой универсальной энциклопедии надо рулить домой. Немного мне помогла установка англо-русско-английского словаря и нескольких справочников на PDA, но бездонного Интернета под рукой нет. 3G обещает дать нам это. Вернемся к техническим деталям.

UMTS. НЕМНОГО ТЕХНИЧЕСКИХ ДЕТАЛЕЙ

По скорости передачи данных все эфирное пространство UTMS делится на несколько зон: пикозону (скорость передачи данных 2 Мб/с), микрозону (скорость передачи данных 384 кб/с) и макрозону (скорость передачи данных 144 кб/с). То, в какой зоне будет обеспечиваться связь терминала с базовой станцией, зависит от скорости перемещения абонента (если кто помнит, тот же CDMA отрубается при движении со скоростью 30 км/ч, в UMTS все куда сложнее). Как известно, терминал всегда держит связь с несколькими базовыми станциям. С одной на полную катушку, передавая данные, с другими в зоне действия он поддерживает связь для того, чтобы они могли перехватить терминал на себя, когда ослабнет связь с той базовой станцией, которая сейчас числится основной. При больших скоростях движения абонента процесс его переключения между базовыми станциями учащается. Увеличенные скорости передачи данных требуют более надежной связи с сотой, что уменьшает дальность приема, а значит, переключения происходят еще чаще. Скорость передачи падает - это естественное ограничение системы. Чтобы вести связь в пикозоне, нельзя двигаться быстрее, чем со скоростью 10 км/ч. Иначе абонент переходит в микрозону. Здесь связь держится при движении со скоростью до 120 км/ч. А при скоростях до 500 км/ч приходится довольствоваться услугами макрозоны.


Спецвыпуск Xakep, номер #020, стр. 020-028-3, GPRS

GPRS

Спецвыпуск Xakep, номер #020, стр. 020-028-3

МОСТ К 3G

Логика подсказывает, что скачком к сети, которая так отличается от существующей, не перейти. Переход к 3G осуществляют постепенно модифицируя существующие сети путем введения так называемых половинных стандартов (2,5G): HSCSD (High Speed Circuit Switch Data), EDGE (Enhanced Data Rates for GSM Evolution), GPRS (General Packet Radio Service).

HSCSD

Стандарт «High Speed Circuit Switch Data» был первой разработкой в области улучшения GSM. HSCSD обещает удивленным зрителям скорость до 57,6 кб/с. Как же это у него получается? Чтобы это понять, надо вспомнить принцип передачи данных в GSM. В каждом радиоканале имеется восемь временных отрезков, грубо говоря - каналов. Эти восемь каналов делят полосу частот шириной в 200 кГц. Пользователю предоставляется один из восьми каналов. Прикол HSCSD в том, чтобы объединить несколько таких каналов, увеличить пропускную способность и тем самым увеличить максимальную скорость передачи до 57,6 кб/с. Естественно, применение этой технологии требует перепрошивки оборудования оператора и терминала пользователя. Из известных телефонов, поддерживающих HSCSD, можно назвать Nokia 6210. Из операторов я могу вспомнить только «Orange». HSCSD поддерживает объединение до четырех каналов. Напомню, одна базовая станция («сота») предоставляет восемь каналов, а если, при использовании HSCSD, одному пользователю предоставляется четыре, количество обслуживаемых абонентов одной базовой станцией снижается до двух. Это повышает нагрузку на сеть и требует установки дополнительных сот. В этом скрыт провал HSCSD (в жадности операторов, хе-хе).

GPRS

GPRS принят большинством операторов Европы. Он представляет собой службу пакетной передачи данных для GSM-сетей. Разработкой оборудования для GPRS занимаются такие компании, как Alcatel, Lucent Technologies. Motorola, Ericsson, Siemens, Nortel Networks и Nokia. Как и HSCSD, GPRS использует объединение каналов, однако, в отличие от HSCSD, ему удается избежать неприятностей, связанных с уменьшением доступных ресурсов. Фишка в том, что голос и данные в начале передачи разделяются на небольшие пакеты данных. Все мобильные телефоны (не только с поддержкой GPRS, а уже давно) устанавливают связь с базовой станцией только тогда, когда необходима передача данных. Получается, что ресурсы сети задействованы только во время непосредственной передачи данных от терминала. Во время пауз (например, молчания при разговоре) ресурсы сети предоставляются в распоряжение других абонентов. При полном использовании доступной частотной полосы, оптимальных условиях приема, минимальной коррекции ошибок, полном статистическом везении и отсутствии волн с Юпитера можно достичь скорости 171,2 кб/с (объединено восемь каналов по 21,4 кб/с каждый). А это практически двойная скорость ISDN-соединения. А поскольку волны с Юпитера есть всегда, максимальной скорости тебе не видать. Как говорил один персонаж: «Clear as vodka». Также кристально ясно, что уровень сигнала и количество ошибок величина не постоянная, следовательно, скорость передачи тоже. Не следует забывать о том, что надо не только передавать, но и принимать. Обычно объединяют четыре приемных и один канал на передачу (4 downlink and 1 uplink) или два на прием и два на передачу (2 downlink and 2 uplink). Соединение 4/1 применятся в основном для мобильного Интернета - там качать надо больше, чем отправлять, а 2/2 связь для видео или обычных разговоров, хотя для болтовни часто пользуются просто GSM. Большинство операторов пока используют GPRS только для передачи данных и SMS, разговоры же идут в обычном режиме. Эксперты предсказывали среднюю скорость в 100 кб/с, однако опыт показал, что обычная скорость это 56 кб/с днем и около 64 кб/с вечером. Все это еще зависит от места пребывания абонента и от общей нагрузки на сеть. В любом случае, не так уж и плохо, учитывая, что весь тракт передачи цифровой и 56к с мобильника все равно будет лучше, чем 56к на городской сети, даже если у тебя цифровая станция - абонентская линия все равно аналоговая. Счастливчиков с ISDN трогать не будем. Да! Система управления данными GPRS основана на протоколе угадайте-сами-каком. Правильно, IP. GPRS также прост во внедрении. Операторам нужно только два новых наименования оборудования: SGSN (Serving GPRS Support Node - узел обслуживания абонентов GPRS) и IP-шлюз, называемый GGSN (Gateway GPRS Support Node - центральное шлюзовое устройство GPRS).


Спецвыпуск Xakep, номер #020, стр. 020-028-4, GPRS

GPRS

Спецвыпуск Xakep, номер #020, стр. 020-028-4

EDGE

Еще одно решение. В EDGE уже идет расчет на новые технологии модуляции сигналов. Это уже качественный, а не количественный скачок. Тут нам обещают скорости до 384 кб/с. Просим пассажиров пристегнуть ремни. EDGE дает скорости, обещанные нам в третьем поколении, работая на старых GSM частотах (900, 1800, 1900 МГц). Но пользователю нужно находиться вблизи базовой станции для того, чтобы скорости передачи начали выбивать трубку у тебя из рук. EDGE не требует никакого нового оборудования, кроме измененного приемо-передатчика на соте и программы на трубе.

Вот три технологии, ведущие нас к 3G. HSCSD оказался невыгодным, EDGE, несмотря на все свои плюсы, стоит на обочине, а по Европе с победой ходит GPRS. А что же есть сейчас?

ДОСТРОИМ WAP

Из-за медленной скорости чистого GSM - WAP обозвали Wait And Pay (жди и плати). GPRS и EDGE были призваны преодолеть этот недостаток. Однако чистый WWW все равно не годится для мобильных сетей как минимум по двум причинам. Первая - это огромное количество баннерной рекламы, больших картинок и прочей бесполезной информации, которая не только создаст огромный траффик, такой, какой сети не выдержат, но и не влезет на экран устройства, который, даже если займет всю поверхность мобилки, будет меньше ладони. Вторая - флэш-ролики, на проигрывание которых производительности мобильных устройств не хватит. Однако по своей архитектуре WAP разработан для того, чтобы в будущем передать больше чем plain text. Версия 2 обещает нам улучшенную цветную графику. Для пользователей GPRS это означает, что, кроме обычных WAP-служб, ему станут доступны видео-почта и видеоконференции. Ну и игры, куда без них? Если бы пришел EDGE, то стало бы доступно любое потоковое содержание, вплоть до радио и телевидения, а это должно было появиться только в UMTS. Возможно, поэтому EDGE остался не у дел - UMTS не нужны конкуренты. UMTS объявлен мессией.


Спецвыпуск Xakep, номер #020, стр. 020-028-5, GPRS

GPRS

Спецвыпуск Xakep, номер #020, стр. 020-028-5

ВЫХОД ТУТ

Тестовые запуски UMTS идут полным ходом, на хай-тек выставках вовсю показывают действующие прототипы 3G устройств с HiColor дисплеями и встроенными камерами. Ждать осталось недолго, скоро мы увидим будущее мобильной связи. Фантастические фильмы уже не кажутся сказкой. Видеофон каждому! Плюс интернетизация всей страны ;).


Спецвыпуск Xakep, номер #020, стр. 020-032-1, Цифровая телефония vs VoIP

Цифровая телефония vs VoIP

Спецвыпуск Xakep, номер #020, стр. 020-032-1

телефон + интернет + кабельное телевидение - 3 в 1

Андрей Каролик (andrusha@sl.ru)

Рынок телефонных операторов можно представить в виде пирамиды, в вершине которой находятся самые крупные и высокодоходные клиенты (гостиницы, бизнес-центры, мультибрендовые компании, нефтяные компании и т.д.), посередке располагаются средние и мелкие компании, которым нужна телефония в гораздо меньших объемах, а в основе пирамиды - население. Ты, я, он, она... Короче, ты понял :). Направление развития этого рынка - сверху вниз. То есть изначально операторы ориентировались в основном только на крупных клиентов, получая сверхприбыли, а постепенно с насыщением рынка стали обращать внимание на мелкие компании и работать с населением. Так как я - частичка населения :), то я, само собой разумеется, решил узнать поподробнее о возможностях телефонии и о том, что нам грозит в ближайшем будущем в этом направлении. За помощью я обратился в МТУ-Информ (www.mtu.ru) к директору по маркетингу, Дмитрию Владимировичу Дронову, чтобы он рассказал на примере их компании, как организована телефония и какие варианты построения каналов используются сегодня. На данный момент широко распространены два варианта: VoIP (Voice over IP) и цифровая телефония.

VoIP (Voice over IP)

VoIP - это решение IP-телефонии, которое позволяет в качестве основы использовать обычные медные пары. На одном конце медной пары располагается SDH-сеть (волоконно-оптическая транспортная сеть), а на другом - клиент. От ближайшего узла SDH-сети организуется канал и на стороне клиента ставится маршрутизатор с голосовым портом. Обычно это Cisco 1700 или Cisco 2600, имеющие 2 или 4 голосовых порта соответственно. Голос идет по IP-протоколу, отсюда и такое название. Для организации канала VoIP достаточно скорости 128-256 Кб/сек, а в качестве каналообразующего оборудования используются терминальные адаптеры сети передачи данных (DTU). Расстояние от ближайшего узла SDH-сети не так важно, так как компания МТУ-Информ имеет наиболее разветвленную транспортную сеть по Москве, и максимальное расстояние от любой точки до ближайшего узла обычно не превышает 2-3 километра, что не критично для современных терминальных адаптеров. Услуга VoIP - комплексная и подразумевает использование канала одновременно для телефонии (2 или 4 телефонных номера) и доступа в Интернет. Приоритет, как и в GPRS, отдается голосовым соединениям, поэтому при всех занятых телефонных номерах скорость инета падает практически до нуля. Года два назад это решение было наиболее популярным среди небольших компаний, которым требовалось не более 4-х телефонных номеров. Сейчас рынок развился, появилось больше конкурирующих телефонных операторов, и цифровая телефония по 2-х мегабитному оптоволокну (как правило, ставится оптоволокно) практически сравнялась в цене с VoIP. Но об этом ниже.

ЦИФРОВАЯ ТЕЛЕФОНИЯ

Цифровая телефония тоже базируется на SDH-сети, но схема организации канала немного другая. В качестве основы используется уже оптоволокно, а для формирования 2-х мегабитного канала ставится модем. Весь канал бьется на слоты кратностью 64 Кб/сек, которые можно использовать для передачи любых данных. Грубо говоря, один телефонный разговор занимает 64 Кб/сек. Можно сделать какое-то количество телефонных номеров, а оставшуюся часть занять под Интернет. Абонентская плата начисляется только за количество телефонных номеров и полосу, выделенную на Интернет. Поэтому изначально цифровую телефонию предоставляли крупным компаниям, которым нужно было 100 и более телефонных номеров. Но ситуация на рынке идет к тому, что стоимость этого канала резко понижается, и операторы способны отдать 2-х мегабитный канал на 5-10 телефонных номеров, работая на перспективу. То есть компания ставит себе канал, оплатив прокладку оптики, и выделяет на нем, к примеру, 15 телефонных номеров и 64 Кб под Интернет, а по мере роста компании включаются дополнительные слоты по 64 Кб под другие услуги. Получается более универсальное и перспективное решение, близкое по цене к VoIP. При этом за телефонией и Интернетом закрепляются жесткие полосы (благодаря делению на слоты по 64Кб/сек), благодаря чему занятость телефонных номеров не сказывается на скорости Интернет-соединения. А спектр услуг цифровой телефонии очень широкий:


Спецвыпуск Xakep, номер #020, стр. 020-032-2, Цифровая телефония vs VoIP

Цифровая телефония vs VoIP

Спецвыпуск Xakep, номер #020, стр. 020-032-2

- качественная телефонная связь (не сравнить с МГТС)

- голосовая почта

- переадресация

- конференц-связь

- сокращенный набор

- будильник

- доступ в Интернет

- кабельное телевидение

и т.д.

УСТАНОВКА В ДОМАХ

Тебе (как и мне) малоинтересно, что себе ставят на фирмах. Гораздо интереснее, когда цифровая телефония появится в обычных домах и сколько будет стоить. С жильем компания МТУ-информ начала работать примерно три года назад, причем инициатива исходила от застройщиков, которым нужно было телефонизировать строящиеся дома, так как стоимость жилья во многом зависит от инфраструктуры (поэтому теперь стандартно штампуют рядом еще гаражи, мойку, охрану, рестораны и т.п.). Как осуществляется прокладка линии? До здания прокладывается оптоволоконная линия связи, а в здании ставится соответствующее оборудование: мультиплексор, офисная телефонная станция, головная станция доступа в Интернет и головная станция кабельного телевидения. Внутри дома для разводки используется технология HPNA, подобная ADSL, но действующая на гораздо меньших расстояниях. Скорость доступа в Интернет - до 10 Мб/сек. Интересную информацию Дмитрий Владимирович рассказал про кабельное телевидение, которое включается в пакет услуг цифровой телефонии для жильцов дома. Кабельное телевидение делается тоже на перспективу - с обратным каналом. Зачем он нужен? Начну с того, что этапы развития кабельного телевидения в мире следующие:

1. broadcasting

2. video-on-demand

3. content-on-demand

В России кабельное телевидение пока находится на первом этапе, который позволяет реализовать одностороннюю трансляцию. Ближайшая перспектива - video-on-demand (по запросу). На втором этапе у пользователя появляется возможность заказывать из имеющейся базы данных какой-то фильм или программу и смотреть в определенное время. То есть организуется персональное вещание. На втором этапе как раз уже нужен обратный канал в кабельных сетях для передачи телевизионного канала. Не за горами и третий этап, который позволит заказывать любой контент на любой терминал в доме, подключенной к кабельной сети. То есть любые оцифрованные данные: газеты, журналы, аудио и видео данные, изображения и т.д. Но сами телефонные операторы контентом не занимаются, поэтому по логике вещей должны появиться еще компании, которые будут заниматься только контентом и сотрудничать с телефонными операторами, которые владеют технологией для реализации этих услуг. Все это здорово, но пока, к сожалению, операторов интересует более платежеспособный сегмент, куда они готовы вкладывать инвестиции - элитное жилье и жилье бизнес-класса. Но по большей части не из-за того, что услуги цифровой телефонии очень дороги, а из-за того, что процент желающих пользоваться услугами цифровой телефонии в обычных домах редко бывает выше 3-5%, в то время как в элитном жилье этот показатель примерно равен 80%. Многим привычнее платить 50 деревянных за МГТС, и они ни за что не променяют сидение с подмигивающим модемом по ночам :). Обнадеживает только то, что, по словам Дмитрия Владимировича, они готовы инвестировать деньги в дома с охватом от 15-20%.


Спецвыпуск Xakep, номер #020, стр. 020-032-3, Цифровая телефония vs VoIP

Цифровая телефония vs VoIP

Спецвыпуск Xakep, номер #020, стр. 020-032-3

РАСЦЕНКИ

Стоимость на услуги цифровой телефонии меняется в некотором диапазоне, так как подключение каждого отдельного дома - отдельный проект. Кому-то нужно положить километр оптоволокна, а кому-то нужно положить три километра оптоволокна с заныриванием в непроходимую канализацию и достроить черт знает чего :). В основном затраты телефонными операторами отбиваются установочной платой за телефонный номер, который является основной услугой телефонии. Составляет плата за установку от 600 до 2000 зеленых. А абонентская плата за пакет услуг, включающий телефонию, Интернет и 32 канала кабельного телевидения, составляет от 30 до 50 зеленых. В абонентскую плату входит уже определенный размер бесплатного трафика, а превышение оплачивается от 5 до 9 центов за мегабайт (для примера на моей выделенке превышение стоит 10 центов за мегабайт).

ЗАЩИТА

Не смог я не задать и свой профессиональный вопрос - о взломе :). В телефонии основная проблема - несанкционированное подключение к установленному оборудованию и перекачка нелегального трафика. Способов борьбы много: заваривание оборудования броней танка :), выставление охраны, ежедневная ревизия и т.д. Компания МТУ-Информ делает так - поставленное оборудование не отдается в пользование клиенту, а сдается только в аренду. Специалисты МТУ-Информ сами занимаются мониторингом оборудования, контролируя нагрузку. Если вдруг ни с того, ни с сего нагрузка на оборудовании клиента подскакивает, то скачок анализируется и принимаются меры. Причин скачка может быть всего две: либо клиент резко повысил свою активность, либо дядя Вася нелегально ведет переговоры, несанкционированно подключившись к оборудованию.

ВЫВОДЫ

Лично меня цифровая телефония заинтересовала на все сто, но придется ждать лучших времен, либо срочно переселяться в элитное жилье :). Когда снизится цена за установку телефонного номера, мне кажется, доступ в Интернет посредством цифровой телефонии станет конкурировать с выделенными каналами, так как абонентская плата почти такая же, а спектр услуг значительно шире. Ты можешь спросить, а можно ли, например, десяти друзьям из одного дома проложить себе линию, поставив 2-х мегабитный канал. Теоретически да, но практически возникает множество проблем. Во-первых, телефонному оператору не выгодно инвестировать, как я говорил выше, средства в дома с охватом менее 15-20%. Во-вторых, они готовы подключать только целые дома, подключение десяти человек - поле деятельности отдельных Интернет-провайдеров. А в-третьих, они не будут заниматься организацией распределительной сети внутри дома, сбором оплаты и билингом. К тому же вам придется выложить круглую сумму за прокладку канала. С подключением компаний проще - программисты и сетевики на фирме сами строят распределительную сеть, а счета выставляются на одно большое юридическое лицо.


Спецвыпуск Xakep, номер #020, стр. 020-032-4, Цифровая телефония vs VoIP

Цифровая телефония vs VoIP

Спецвыпуск Xakep, номер #020, стр. 020-032-4

P.S. Поживем - увидим ;).


Спецвыпуск Xakep, номер #020, стр. 020-036-1, PANAMAIL

PANAMAIL

pop3/smtp в кармане

Спецвыпуск Xakep, номер #020, стр. 020-036-1

R0m@n AKA D0ceNT (siriusblack@omen.ru), Фоменко Зоя AKA CyBer (kammi@yandex.ru)

Функция доступа к электронной почте просто обязана быть в любой трубке, так же как и SMS.

Ты онлайн и можешь принять и отправить почту с любого твоего ящика.

Никто не гарантирует, что не найдется шутников, способных найти дыры в этих мобилках и создать злобных вирусняков, которые, будучи отосланными по почте на такую трубку, порвут ее как грелку.

Привет, дружище! Значит, говоришь, маловато тебе стало SMS, да и WAP уже не устраивает? Я знаю, мне тоже эти услуги как-то не очень - собственно, SMS я юзаю редко, так как у всех моих друзей разные операторы, а они, как известно, не очень спешат вводить у себя взаимообмен SMS-сервисами (уже спешат, на данный момент можно гонять смс-ки между сетями почти всех крупных операторов - прим. ред.), и, как правило, нужный в данный момент человек пользуется другим оператором. Что же касается WAP, то этот зверь мне вообще не подходит - подавляющее большинство нужных мне сайтов не поддерживают WAP, да и дороговато пока. Но, наверняка, ты мечтал внести в свой телефон частичку Интернета. А именно - получить возможность посылать мессаги не только друзьям, юзающим ту же сеть, но и вообще куда угодно и кому угодно, то есть использовать свою трубу для работы с электронной почтой и при этом не таскать с собой для этого ноутбук или карманный компьютер. В общем, прогресс не стоит на месте, тем более, что в телефон сейчас норовят уместить все, что только можно, от телевизора до компьютера. А уж функция доступа к электронной почте просто обязана быть в любой трубке, так же как и SMS. Таких трубок сейчас начинает появляться все больше и больше. И об одной из таких трубок мы сейчас тебе и поведаем. Но не пугайся, речь пойдет вовсе не о дорогом пока что коммуникаторе, сочетающем в себе и телефон, и полноценный компьютер, и не о недоделанном у нас GRPS, а всего лишь о сравнительно недорогом агрегате (цена его колеблется в пределах 150 бачей), который не только умеет принимать почту, но и обладает кучей других интересных примочек.

Итак, знакомься - Panasonic GD95.

ТРУБА

Когда этот телефон попал мне в руки, лично у меня он не вызвал особых эмоций своим дизайном - мне он показался слишком угловатым и крупноватым на сегодняшний день (все-таки бывают и меньше), хотя и достаточно тонким и легким. Да и непривычно было как-то смотреть на большой вытянутый дисплей, занимающий чуть ли не половину всей лицевой панели трубы. Но, как говорится, не с лица воду пить, и все первоначальное мнение об этом девайсе улетучилось, как только я начал нажимать на кнопки и копаться в менюшках. Своим меню телефон напоминает карманный компьютер - все его пункты обозначены иконками. Одна беда - не хватает мышки или пера, чтобы по ним покликать, а вся навигация осуществляется, как и у большинства телефонов, кнопками. Сам дисплей может подсвечиваться любым из трех цветов: оранжевым, голубым и зеленым, по настроению. Так как дисплей большой и четкий, он позволяет отображать SMS сообщения целиком и делает общение с телефоном весьма комфортным и приятным. Звучит телефон тоже не как все - это уже далеко не примитивный пискун, издающий звуки, отличающиеся друг от друга только частотой, это почти MIDI синтезатор, способный не просто звучать, а проигрывать мелодию звонка. Иногда можно заслушаться или принять его за радиоприемник, да и не ответить на звонок. Вдобавок ко всему этому ты сможешь не только запрограммировать мелодию, но и (!) записать ее через микрофон, так что меломанам тоже есть, где оттянуться. Радует также и 100-процентное понимание телефоном русского языка. Причем, это не банальный перевод на русский элементов меню и прочей байды, а реальная возможность читать и составлять SMS и e-mail сообщения русскими буквами.


Спецвыпуск Xakep, номер #020, стр. 020-036-2, PANAMAIL

PANAMAIL

pop3/smtp в кармане

Спецвыпуск Xakep, номер #020, стр. 020-036-2

Это только основные интересные фишки этого телефона. В общем, весь перечень функций ты можешь наблюдать на врезке. Пришло время поговорить наконец о главном, ради чего, собственно, я и начал этот обзор.

О МЫЛЕ И О МЫЛЬНИЦАХ

А главное в этом интересном девайсе - это, конечно же, встроенный e-mail клиент, в общем похожий на Аутглюк и Зе Бэт, который примерно так же и настраивается. Просто указываешь параметры твоего ящика, всякие там учетные записи, pop и smtp серверы, настраиваешь телефон на передачу данных, устанавливаешь телефонное соединение с номером для передачи данных твоего сотового оператора (о том, как юзать услугу передачи данных, спроси у службы поддержки оператора), и вуаля! Ты онлайн и можешь принять и отправить почту с любого твоего ящика. Удобно? Еще бы! Но чтобы тебе было еще удобней, заботливые дяди и тети из фирмы Panasonic создали специально для тебя почтовый сервис Panamail (www.panamail.ru). Вся фишка в том, что если ты захочешь принять сообщения с какой-либо другой мыльницы вроде mail.ru или aport.ru, то тебе, во-первых, придется долго (и дорого) ждать, пока примутся сообщения (стандарт GSM не поддерживает скорость передачи данных выше, чем 9600); во-вторых, еще наверняка не удастся их прочитать, так как телефон понимает только кодировку ISO8859, а мыло тебе шлют в разных кодировках; в-третьих, телефон принимает только первые 800 символов, а мыльные мессаги и так завалены кучей сервисной инфы, рекламой и прочей байдой, из-за которых нужное тебе сообщение может быть обрезано; и, наконец, может возникнуть некоторый гимор из-за вложенных файлов. А этот самый Panamail как раз и создан для того, чтобы избавить тебя от этих неудобств, и предлагает всем пользователям телефонов Panasonic с функцией приема почты создать у них почтовый адрес вида tvoe_imya@panamail.ru, притом совершенно бесплатно (еще бы, свои баблосы ты и так уже вбухал в их трубку). А дальше можешь просто установить переадресацию со своих ящиков на этот и читать нужную тебе почту, не заботясь ни о кодировках, ни о приложенных файлах - текстовые вложения тоже можно прочитать. Предлагается доступ к твоему адресу и через WAP-интерфейс. Так же оперативно ты сможешь и отвечать на письма, примерно как ты отвечал всегда на SMS с любой другой трубы. Доставка почты из ящика на твою трубу осуществляется несколько шустрей, чем если бы ты принимал ее с другого, не Panamail-овского, ящика. Это происходит как раз благодаря отсечению сервисом лишних символов и не текстовых вложений.


Спецвыпуск Xakep, номер #020, стр. 020-036-3, PANAMAIL

PANAMAIL

pop3/smtp в кармане

Спецвыпуск Xakep, номер #020, стр. 020-036-3

При регистрации на сайте Panamail требуется указать IMEI-номер твоей трубы, номер гарантийного талона (мочи левые мобилы! :)), некоторую инфу о себе и своем телефоне, ну и, разумеется, выбрать себе название своего ящика и пароль. Кстати, таким образом тебя причисляют еще и к членам клуба Panasonic и дают возможность выигрывать какие-то там призы.

После всего этого останется только добавить в твоем телефоне новую учетную запись и настройки, которые ты узнаешь на www.panamail.ru при регистрации.

U WANT SOME MORE?

Трудно конечно сейчас сказать, как будет развиваться это направление у других производителей трубок. Подхватят ли его остальные, сделав такой же стандартной функцией, как SMS-сервис, останется ли оно привилегией только для пользователей Panasonic? Или же благополучно загнется после серии багов и взломов - никто не гарантирует, что не найдется шутников, способных найти дыры в этих мобилках и создать злобных вирусняков, которые, будучи отосланными по почте на такую трубку, порвут ее как грелку. А что стоит не только завирусовать, но и капитально заспамить такую трубу, и «обрадованный» всем этим маскарадом хозяин выкинет ее, растерзанную, в ближайшую урну? Да и скорость передачи данных в GSM-сети далека от совершенства - придет много писем, вот и качай их, а услуга-то тоже платная, причем поминутно, и время тут намного дороже, чем у любого Dial-Up-провайдера. При всей заманчивости сервиса Panamail стоит подумать, прежде чем хватать свои последние пиастры и бежать до ближайшего салона связи. Лично я все-таки подожду повсеместного внедрения многообещающего GRPS (что, видимо, случится довольно скоро) и отказываться от привычной комбинации Palm + старенький Siemens не стану - там видно будет.


Спецвыпуск Xakep, номер #020, стр. 020-040-1, ВЫСОКАЯ МОДА ДЛЯ МОБИЛ

ВЫСОКАЯ МОДА ДЛЯ МОБИЛ

самые прикольные чехлы

Спецвыпуск Xakep, номер #020, стр. 020-040-1

Rude`n`Sky (rudensky2000@yandex.ru)

МАТЕРИАЛЫ

Самым простым и дешевым является чехол, сдаеланный из ПВХ – поливинилхлорида, прозрачного пластик. Этот чехол не будет облегать твой мобильник, как кожаная перчатка, - руку, не защитит его от проникновения пыли и грязи. Его основная функция – обеспечивать минимум удобств для твоего телефона. Главное достоинство – цена такого чехла, как правило, не превышает восьми американских рублей.

Чехол из пресованой кожи – это следующая стадия развития чехла – чуть лучше, чем ПВХ, чуть хуже, чем все остальное. Здесь все как у больших - изнутри такие чехлы обычно проклеивают специфическим бархатистым материалом, который предохраняет телефон от царапин, придает дополнительную устойчивость и прочность.

Искусственная кожа - опять же, дешево и сердито – однако выглядит не таким угловатым, как предыдущий. Умрет достаточно быстро, но этого времени хватит для того, чтобы скопить, скажем, на чехол из кожи натуральной. Последняя присутствует в самых разных видах в чехлодизайне – крокодиловая, змеиная, овечья, свиная, нубук – всех и не перечислишь. В зависимости от экзотичности и степени выделки требует разных вложений. Однако, кожа - символ солидности, стабильности и еще бог знает чего, постепенно отходит в прошлое. Производство чехлов все больше и больше требует использования высоких технологий: полиуретановый пластик позволяет сделать чехол полностью герметичным, морозоустойчивым, пластичным, ну, и так далее. Неудивительно, что часто подобные чехлы стоят даже дороже, чем сделанные из натуральной кожи.

Индивидуальность странная штука. Если двадцатый век был веком массового производства, когда роботы на штамповочных линиях производили пластиковые игрушки, предметы роскоши среднего класса и себе подобных роботов, в веке двадцать первом появился другой понт – понт индивидуальности. Индивидуализируется все – дизайнерские щетки для унитазов, пепельницы и мыльницы – все обыгрывает ставшие привычными темы, все как у всех – но на самом деле совсем по-разному. Самая благодатная почва для этого – разнообразные мелочи. Впрочем, времена не те – сейчас дизайнерскими спичками никого не удивишь. Последний писк – нестандартные чехлы для мобильных телефонов – только начинают появляться на улицах. Прекрасный повод выпендриться – заказать себе броский чехол. К тому же жалко уродовать прекрасный экземпляр мобилестроения, засовывая его в убогий пластмассовый мешок.

Если лет сорок назад чехол для сотового телефона Эриксон представлял из себя огромный чемодан – с таким было в пору отправляться в командировку, и иметь для него отдельного носильщика (если есть такой). Теперь же чехол для современного мобильного чуда, вместе с самим наполнителем влезает в любой карман – либо просто крепится к поясу.

Сам же мобильный телефон постепенно всасывает в себя все возможные удобства. Иногда вообще возникает ощущение, что лет эдак через сто человек за всю свою жизнь будет делать только одну покупку – сотовый телефон. Ну, возможно, еще чехол к нему.

ЗАЩИТА ПРЕВЫШЕ ВСЕГО


Спецвыпуск Xakep, номер #020, стр. 020-040-2, ВЫСОКАЯ МОДА ДЛЯ МОБИЛ

ВЫСОКАЯ МОДА ДЛЯ МОБИЛ

самые прикольные чехлы

Спецвыпуск Xakep, номер #020, стр. 020-040-2

Первоначальная и самая важная функция чехла – защитить телефон и его владельца от всевозможных неудобств. Защитить от всего – от перепадов температур до проникновения воды. Если есть некоторое количество денег, то можно позволить себе именно такой, скажем, от финских Moduleo Oy, пожалуй, самый известный на сегодняшний день производитель экстремальных чехлов. Этот «кейс» - по другому и не скажешь - сочетает в себе несколько преимуществ и, как правило, более многофункционален, нежели чехлы «для носки в городе». Как и в любом туристско-приключенческом снаряжении – любая поверхность приспосабливается для того, чтобы впихнуть еще больше кармашков для необходимых в походе или на отдыхе мелочей. Однако, все по порядку: основная характеристика таких изделий – это класс герметичности, на него стоит обращать внимание – чем выше, тем лучше.

Как правило, такие чехлы спасают от чего угодно – от мороза, проникновения влаги, не тонет, крепится на руку, и вообще, не то, чтобы не мешает, а скорее, даже помогает жить.

Броские расцветки таких чехлов позволяют им грамотно сочетаться с, скажем, костюмом для серфинга или любым другим броским, «осиным» нарядом.

Еще одна фича, на которую стоит обращать внимание при покупке подобного, «экстремального» чехла, это устройства для крепления. Как правило, в комплекте их несколько: специальный ремешок, которым мобильник крепится на бицепсе, специальный держатель на руль велосипеда и ремень, с помощью которого он крепится на шею. Короче, современный чехол можно присобачить куда угодно –защищает от всех невзгод: мороза дождя и сотрясения.

Однако этим не исчерпывается тот список вещей, от которых должен защищать «мобильный чехол». Защита от радиации – совсем недавняя «модная тема». Ведь это же известно, что радиация, выделяемая телефоном, губительна для человека. Вполне возможно, что это был правильно спланированный рекламный ход, а может быть, у меня паранойя, н радиация выделяемая в процессе разговора по телефону действительно разжижает мозги, но после доклада опубликованного очередным медицинским институтом, во всем мире началась легкая паника. Продажи телефонов слегка упали - ничего удивительного, что лишь слегка. Поимев такое счастье, как мобильная связь, не так то просто от него отказаться. Однако, после того как бум немного схлынул и с радиацией, казалось бы, уже смирились, фирма Wild Nrg выпустила серию чехлов, по версии самой компании, должна защитить от радиации.

Конструкция состоит из некоего противорадийного материала, сделанного самой компанией, а сами чехлы, напоминают по форме более всего небольшие скафандры, уж не знаю, насколько ими удобно пользоваться.

Из подобного материала фирма выпускает не только чехлы – вполне можно купить себе даже бейсболку, которая защищает голову от электромагнитного излучения. Судя по всему, этот товар рассчитан на параноиков, точнее, излишне мнительных людей. Во всяком случае, по моему личному скромному мнению, подобного рода акксессуары – предназначены скорее для того, чтобы успокоить совесть. В любом случае выделяемая доза радиации микроскопична.


Спецвыпуск Xakep, номер #020, стр. 020-040-3, ВЫСОКАЯ МОДА ДЛЯ МОБИЛ

ВЫСОКАЯ МОДА ДЛЯ МОБИЛ

самые прикольные чехлы

Спецвыпуск Xakep, номер #020, стр. 020-040-3

МЕХОВОЙ ИНТЕРНАТ

Колокольчики, разнообразные висюльки на рюкзаках, доставшиеся в наследство от хиппи стиля, перешли в сферу чехлов для мобильных телефонов. В последнее время появилось множество подобного плана чехлов, в виде зверей, прикрепляющихся к поясу, или любой другой части тела, на которую можно что-то повесить. Идеальный тайник для мобильного, если ты не видел эти игрушки раньше, тебе никогда не придет в голову, что внутри милого, как водится, плюшевого медведя может находиться мобильный телефон. Однако он там находится – чехлы в виде плюшевых животных можно встретить на каждом пятом пузе. Пример подобных вещей четко показывает, что функциональность – дело десятое. По сравнению с high-tech монстрами, включающими в себя бездну кармашков, пять устройств, с помощью которых можно прикрепить такой чехол куда угодно, плюшевый медведь с тайником для мобильника выглядит вполне конкурентом, лишний раз доказываю то, что не стоит все усложнять.

СУМКИ

«Рюкзак с карманом для мобилы - и модно и современно!» - было написано на ларьке в окрестностях Черкизовского рынка. За несколько лет мобила превратилась из роскоши в средство, без которого уже ну никак не возможно передвигаться и вообще существовать. Рюкзаки на одной лямке со специальным кармашком для мобильного телефона, сумки с отверстием для телефона, рубашки, к которым можно пристегивать сотовый телефон – сейчас это уже символ поп-современности, и, несмотря, на то, что этим уже никого не удивишь – люди готовы потреблять подобные штуки. Многие производители одежды, наверняка, в сотый раз перечитав описание таргет-груп из маркетингового документа под грифом совершенно секретно, закладывают мобильный телефон в конструкцию той одежды, которую они производят, делая карманы под мобильник, как например, под бумажник или любой другой аксессуар.

Зоопарк[DEAD]

Кожа мертвых зверей - идеальный материал для чехла. В комплект к чемоданам, сумкам и прочим аксессуарам не так давно добавились еще и чехлы для сотовых.

В России можно даже заказать себе чехол ручной работы. Не то, чтобы это можно было сделать только у нас. Просто в России он будет стоить примерно тех же денег, что и обыкновенный, изготовленный фабричным способом. Если же хочется экзотики, а от крокодильей или змеиной кожи уже тошнит – можно попробовать что-то уж совершенно необыкновенное. Например, страусиный мех, всем хорошо – только эти чехлы можно отнести к разряду настоящей роскоши.

ТЬЮНИНГ

Когда-нибудь понятие «чехол» исчезнет совсем – уже сейчас некоторые фирмы работают над оболочкой – новым корпусом телефона, которая бы предохраняла от любых неожиданностей и телефон и его владельца. Новое увлечение фанатов мобильных телефонов – тюнинг позволяет полностью изменить дизайн и основные характеристики аппарата.

Вообще то это автомобильный термин – но владельцы телефнов, помешанные на телефонах, чем-то похожи на автомобилистов – все чем-то сильно увлеченные чем то похожи. Впрочем, к баранам. Как только ты начал что-то менять в своем телефоне – сразу просыпается какой-то странный инстинкт – и хочется в нем поменять вообще все что возможно.


Спецвыпуск Xakep, номер #020, стр. 020-040-4, ВЫСОКАЯ МОДА ДЛЯ МОБИЛ

ВЫСОКАЯ МОДА ДЛЯ МОБИЛ

самые прикольные чехлы

Спецвыпуск Xakep, номер #020, стр. 020-040-4

С антенной вообще можно делать самые разные вещи: можно удлинять – увеличивается качество приема, можно сделать так, чтобы она мигала всеми возможными цветами, подобно милицейской сирене, когда раздается звонок, можно ее вообще убрать и вставить вместо нее другую, полюбившуюся.

Не самой последней в череде тюнинговых примочек является смена программного обеспечения – существует целая порода умельцев, а иногда даже специальных фирм, занимающимися подобными вещами. Мобильный телефон меняет практически все - от мелодий, которые можно скачать на любом мобильном сайте до мощности и потребления энергии и источника питания, для чего требуются уже профессионалы. Существует множество советов по тому, как сделать это самому – но, честное слово, без наличия определенных навыков не стоит рисковать – сломать мобильник очень просто, а затюнить, иногда крайне сложно. Особо интересующиеся могут залезть на www.rote-led.de и заказать там себе, мобильник, скажем, Nokia, в котором от nokia останется лишь небольшая горсть железа. И то, она будет функционировать по-другому, нежели в исходной модели.

Да, кстати о внешнем виде: иногда жутко утомляет все тот же серебристый или черный корпус – так почему бы не сделать его каким-нибудь буро-малиновым. Сменные панели - прекрасная штука, но только в том случае, если фирма-изготовитель их выпускает. Если нет, то, вооружившись красками или балончиком, предварительно сняв заднюю/переднюю панель, можно сделать телефон того цвета, которого хочется. Опять же, гораздо безопаснее в этом случае будет обратиться к кому-нибудь, кто это дело знает. Если же наскучила сама форма корпуса, то ее даже могут изготовить на заказ. Вот, поди и узнай в этом высокотехнологичном монстре былой «эрик».

КАЖДЫЙ ХОЧЕТ ИМЕТЬ СВОИХ СОЛДАТ

Все любят играть в солдатиков – чтобы в бой, при параде, барабанщике и бронепоезде, взводами и подразделениями, независимо от сферы деятельности. В каждой крупной компании – свои солдаты, все одинаковые – с одними и теми же пепельницами, пиджаками, майками и прочей атрибутикой.

Но уж если клеймить своих сотрудников - то делать это по-масонски с хорошим вкусом, элегантными запонками, кольцами на большие пальцы или - а да – с чехлами для мобильных телефонов с логотипами компании. И глаз не режет – и сердце радуется.


Спецвыпуск Xakep, номер #020, стр. 020-044-1, СОФТ ДЛЯ МОБИЛ

СОФТ ДЛЯ МОБИЛ

hrimz (hrimz@xakep.ru)

Спецвыпуск Xakep, номер #020, стр. 020-044-1

Дарова, киберпанк! Как твоя труба поживает? Да не водопроводная, а мобильная =). Нормально все? Тогда лады, только ты никогда не задумывался над тем, что вот бы было круто добавить новые или расширить имеющиеся фичи телефона? Например, нужно разблокировать его, или еще чего. Раз у тебя есть такой архинужный девайс, как мобильный телефон, то его обязательно нужно разогнать, хакнуть, ну, в общем, разобраться в его внутренностях. Но чаще всего с помощью самого аппарата многого не добьешься, там блокировку снимешь или еще некоторые фрикерские фокусы провернешь, но вот для крупных боевых действий нужен специализированный софт. Вот о нем мы сегодня и поговорим. Есть, конечно, маза написать его самому, но это уже тема будущего разговора. Итак, начнем.

Софт бывает разный. Чаще всего для конкретной модели трубки существует конкретная утилита и максимум, что можно найти универсального - это программа для телефонов конкретной фирмы. Из всего этого следует, что описать программы для всех моделей телефонов просто нереально, но основные трубы популярных сейчас производителей здесь присутствуют. И еще. Если твой телефон, настолько новый, что в продажу поступил позавчера – тоже не надейся найти здесь утилиту для него (хотя кто знает, часто софт для предыдущей модели прекрасно работает с последующей). Теперь о подключении. Кабель для com-порта стоит в районе 400 руб. Радиорынки ждут тебя. После определения неизвестного устройства посылай плуг энд плей к чертям и работай с телефоном напрямую через прошивку.

ERICSSON

Name: Прошивка r4j для R320

Link: http://users.g.com.ua/~nuclear/service/Firmwares/Ericsson/R320/Last/320r4je1.rar

Многие профи скажут, что, дескать, на хрена это прошивка нужна, ведь в ней Wap глючит? Да, признаю, с вапиком траблы бывают (не соединяет, проблемы с настройками соединения), но в остальном r4j просто шоколадка. После заливки, смело врубаем телефон, и видим: передвижение по меню стало без задержек (владельцы Ericsson`ов поймут), sms`ки на Великом и Могучем теперь отсылаются без проблем, версия wap-браузера меняется с 1.1 на 1.2. Сам процесс прошивки проходит без проблем и особых нареканий не вызывает.

Name: Прошивка r4b для R320

Link: http://users.g.com.ua/~nuclear/service/Firmwares/Ericsson/R320/Stable/320r4be1.rar

Последняя стабильная версия прошивки. Работает просто на «ура». В отличии от r4j в этой версии проблем с wap`ом не наблюдается, но скорость работы менюшек после заливки остается прежней.

Name: Прошивка 000414 для Т10/18

Link: http://users.g.com.ua/~nuclear/service/Firmwares/Ericsson/T18/000414.rar

Прошивка работает только под эти две модели. Интерфейс мздосный, то есть практически отсутствует =). Для нормальной заливки, нужно быть подключенным к одному из операторов сотовой сети и все манипуляции совершать из-под чистого ДОСа, а не режима эмуляции. Так, что пользователи Win2k/XP придется грузиться с чего-либо. Остальное же в проге работает стабильно, поэтому можешь спокойно качать и работать.

Name: Прошивка 000615 для Т28

Link: http://users.g.com.ua/~nuclear/service/Firmwares/Ericsson/T28/000615.rar


Спецвыпуск Xakep, номер #020, стр. 020-044-2, СОФТ ДЛЯ МОБИЛ

СОФТ ДЛЯ МОБИЛ

hrimz (hrimz@xakep.ru)

Спецвыпуск Xakep, номер #020, стр. 020-044-2

Все, что было написано к 000414, относится и к этой, отличия лишь в модели трубок.

Name: Flasher от Zulea, version 5.3 - подходит к Т10/18/128; А1018; R310

Link: http://users.g.com.ua/~nuclear/service/Firmwares/Ericsson/flasher/zulea.rar

Проверенный делом flasher для телефонов вышеуказанных моделей. После скачки распакуй архив в папку с прошивкой для твой и модели, грузись мздосом, и множество новых функции откроется твоему светлому взору.

SONY

Name: Z5 Sound Manager

Link: http://users.g.com.ua/~nuclear/utilz/Sony/Z5/Z5Sound.rar

Саунд менеджер для трубок Сони. Виндовый интерфейс, хороший хелп и рекомендации разработчика – что еще нужно. Все манипуляции производятся как с mp3 плеерами. Качаешь из нета музычку в сонивском формате, подрубаешь к com-порту телефон, и вот уже Limp Bizkit тебя оповещает о входящем звонке. Дополнительную крутость проге добавляет встроенная возможность конвертировать музыку из формата Нокии и *.midi в формат Sony.

Name: Z5 Manager

Link: http://users.g.com.ua/~nuclear/utilz/Sony/Z5/Z5Manager.rar

Опять же официальный менеджер прошивок от Соньки. Работает отлично. Дает возможность увеличить количество ячеек памяти в записной книжке, проапгрейдить wap-браузер, русифицировать sms`ки, добавить поддержку новых языков в меню. В общем, клевая вещь.

SUMSUNG

Name: Easy GSM II

Link: http://users.g.com.ua/~nuclear/utilz/Samsung/EasyGSMII.zip

Программа для надругательств над трубами Самсунга, так же, как и соневский Z5 Manager масдайный, работает стабильно и позволяет расширить стандартный набор функций. Работает только с телефонами серии SGH.

SIEMENS

Name: S35_C35_M35 Explorer

Link: http://users.g.com.ua/~nuclear/utilz/Siemens/s35ex_setup.exe

Name: SL45 Explorer

Link: http://users.g.com.ua/~nuclear/utilz/Siemens/sl45expl_setup.exe

Name: ME45 S45 Explorer

Link: http://users.g.com.ua/~nuclear/utilz/Siemens/s45expl_setup.exe

Name: Sx35CZ ver.2.3.0.1

Link: http://users.g.com.ua/~nuclear/utilz/Siemens/Sx35CZ.rar

Все вышеперечисленные проги являются мастдайными и легкими в эксплатуации, посему подробно их описывать не буду – размер статьи не позволяет. К тому же грамотный хелп всегда поможет. Отмечу лишь, что последняя программа - для управления телефонами. Siemens SCM35, SC25 обладает некоторыми особенностями - она способна заставить твой М35 потерять сеть при запросе информации из него. Возможны глюки со стандартными (т.е. идущими на прилагаемом к видюхе компакте) драйверами (Версия 1.0хх) от видеокарты "Creative VideoBlaster Riva TNT-II 32 Mb Ultra" с ТВ-выходом. Выдает неустранимую ошибку (НЕ синий экран). Установка драйверов Detonator должна решить проблему. Версия DirectX роли не играет. На остальных карточках все нормально. Но прога в целом достойна внимания.

NOKIA

Name: Logomanager 1.2.5

Link: http://users.g.com.ua/~nuclear/utilz/Nokia/Logo%20Manager/LogoManager.rar

Менеджер изображений для телефонов нокиа. Присутствует возможность рисовать картинку самому – что несомненно g00d!

Name: Oxygen Phone Manager 1.7.3 for 7110, 6210 (business version)


Спецвыпуск Xakep, номер #020, стр. 020-044-3, СОФТ ДЛЯ МОБИЛ

СОФТ ДЛЯ МОБИЛ

hrimz (hrimz@xakep.ru)

Спецвыпуск Xakep, номер #020, стр. 020-044-3

Link: http://users.g.com.ua/~nuclear/utilz/Nokia/Oxygen/6210_7110/Nok7110Bus.EXE

Name: Oxygen Phone Manager 1.7.3 for 8**** (business version)

Link: http://users.g.com.ua/~nuclear/utilz/Nokia/Oxygen/8x/oxy8210.EXE

Эти две программы отличаются только версиями телефонов, для которых они написаны. А так функции одинаковы – добавлении языков, увеличение кол-ва ячеек памяти, добавления новых игр (первой змейки, тетриса и т.д.), нормальная русификация sms.

Name: Русификатор для Nokia 9210 от Paragon Software ver.1.0b

Link: http://users.g.com.ua/~nuclear/utilz/Nokia/9210/RUNOkia.zip

Переводит интерфейс Nokia 9210 с буржуйского, на родимый язык.

Предостережения: автор и редакция никакой ответственности за блокированные и сломанные телефоны не несут. Все, что ты будешь делать, руководствуясь инфой, почерпнутой из этой статьи – на твой страх и риск. Будь осторожен! К каждой прошивке дается подробный Faq и readme, так что проблем возникнуть не должно. Некоторые из представленные прошивок официальные, то есть от производителя, некоторые же хакерские, так что решать тебе. Ну, вот вроде и все, что мне хотелось рассказать. Будут какие-либо вопросы с подключением и или еще с чем (а они будут :)) – пиши. Удачи тебе.


Спецвыпуск Xakep, номер #020, стр. 020-046-1, КАРТОЧКИ НА КАЖДЫЙ ДЕНЬ

КАРТОЧКИ НА КАЖДЫЙ ДЕНЬ

Спецвыпуск Xakep, номер #020, стр. 020-046-1

Матушка Лень (MLen@mail.ru)

В нашу жизнь лихо ломанулся новый вид карточек. На них нет магнитной полосы, а внутри нет чипа. Это чистый кусок пластика с заветными цифрами pin-кода. Давай попробуем разобраться, что такие карточки тебе позволяют делать.

КАРТА ДЛЯ МОБИЛЬНИКА

Тебе не надо объяснять, что с помощью карты можно добавить времени на твою мобилку. Ты обычно покупаешь карту, стираешь защитный слой и под ним находишь pin. Чтобы добавить баблозойдов на счет твоего телефона ты набираешь специальный номер и вводишь этот секретный код (pin).

Карты для мобильника каждая телефонная компания делает для своих пользователей сама. Поэтому тут особо не повыбираешь: приходится брать карту компании, к которой подключена твоя трубка. Но есть и другие карты, которые помогут заплатить за любой телефон.

ТЕЛЕФОННАЯ КАРТА

Такая карта поможет тебе базарить по обычному телефону со всем миром или хотя бы с соседним городом. Вместо того чтобы звонить через цифру «8» и потом ждать телефонного счета, ты звонишь по обычному телефону и набираешь pin. Когда ты купил карту, ты уже заранее оплатил свои разговоры по льготному тарифу, поэтому космического счета не будет. Теперь ты можешь набирать номер своего иногороднего приятеля, разговор обойдется сильно дешевле.

КАК ВЫБРАТЬ ТЕЛЕФОННУЮ КАРТУ?

У разных телефонных карт на разные страны - разные тарифы, но ведь родственники у тебя живут в определенном месте. Вот и выбирай карту, где на нужную страну тариф меньше. Есть и другие нюансы, например, у тебя старая бабушка, которой никак не объяснить, как набрать сначала телефон, потом в тоновый режим, потом пин-код, потом код страны, города и абонента. Словом старушка свихнется, да и старый телефон тоновый набор не поддерживает. Поэтому у некоторых компаний есть телефон, куда можно позвонить и сказать цифры словами, а девушка оператор соединит. Кстати, эта фича поможет тебе позвонить с уличного автомата в другую страну.

ИНТЕРНЕТ КАРТА

Эта карта даст тебе несколько часов в Интернет. На ней обязательно есть логин и пароль, по которым ты войдешь в Интернет. На некоторых картах можно подключаться в инет сразу. На других нужно зайти сначала в гостевом режиме по гостевому логину и паролю и ввести заветный пин-код на сайте провайдера.

Но бывают и другие прикольные карты, которые могут и то и это. Могут и по телефону звонить и в Интеренет пускать, причем деньги с карты снимаются независимо, и ты можешь пользоваться обеими услугами.

КАК ВЫБРАТЬ ИНТЕРНЕТ КАРТУ

Чтобы сметить провайдера проще чем оператора сотовой связи. Купил другую карту и подключился к другой фирме. Если для тебя главное деньги, и ты точно знаешь, когда будешь сидеть в Инете, то ищи карту с низкими тарифами на твое время. Например, можно купить карту с неограниченным доступом на выходные.

Если тебе нужно быстро дозваниваться, то ищи карту со свободными телефонами. Это будет стоить дороже, за то и дозвон и связь получше. Еще тебе поможет обратный звонок, когда звонишь по всегда свободному телефону, а провайдер сам тебе перезванивает.

ПЛАТЕЖНАЯ КАРТА


Спецвыпуск Xakep, номер #020, стр. 020-046-2, КАРТОЧКИ НА КАЖДЫЙ ДЕНЬ

КАРТОЧКИ НА КАЖДЫЙ ДЕНЬ

Спецвыпуск Xakep, номер #020, стр. 020-046-2

Купив такую карту, можно забыть про все остальные, поскольку ты сможешь платить и за квартиру (газ, свет, телефон), и за покупки в Интернет магазине, и за мобилу, и за Инет. Все с этой карты. Преимущества над банковской кредитной картой в том, что можно покупать искусственные члены в Интернет магазине анонимно и то, что ты следишь за всеми расходами через удобный Интернет интерфейс. Таких карт пока очень мало и их не купишь на каждом углу, поэтому выбирать особо не придется.

ЧТО ТАКОЕ ВИРТУАЛЬНАЯ КАРТА?

Многие пластиковые карты можно купить без пластика. Достаточно купить секретный код. Такой код для многих карт можно купить через интернет за средства платежной карты (совершенно легально) или можно купить виртуальную карту через банкомат при помощи кредитки.

РАЗНЫЕ КАРТЫ

Чтобы ты мог попробовать возможности новых карт, вот тебе краткая инфа по некоторым картам. Тут как раз есть примеры с разными возможностями.

Интернет карта: Центел (Центральный Телеграф)

Сайт: http://dialup.cnt.ru/cards/

Максимальный тариф: Днем (с 9:00 - 1:00) 70 центов за час.

Минимальный тариф: Ночью (с 1:00 - 9:00) 35 центов за час

Бесплатно: почтовый ящик, страничка, личный кабинет, телеконференции.

Дозвон: с первого раза.

Купить: На каждом углу, либо с курьером.

Особенности: Не нужно регистрироваться, логин и пароль уже на карточке. Вводи в компьютер и звони. Посекундная тарификация. Если подписать с Центральным Телеграфом договор, то можно будет отправлять через Интернет реальные телеграммы и факсы, а еще получить доступ к платным базам данных. Отдельно продается телефонная карта, по которой можно звонить по межгороду и по международному.

Телефонная карта Matrix telecom

Сайт: http://www.matrixtelecom.ru/

Купить: Практически на каждом углу, с курьером.

Возможности: звонок в любую страну по низкому тарифу.

Особенности: Можно звонить с любого телефона. Тональный набор не обязателен. Говоришь голосом секретный код и телефон двушке оператору, она тебя соединяет.

Интернет карта: РОЛ (Россия Он Лайн)

Сайт: http://services.rol.ru/rus/095/cards.htm

Максимальный тариф: 60 центов за час в любое время.

Минимальный тариф: бесплатно ночью (за абонентскую плату).

Бесплатно: почтовый ящик, страничка, личный кабинет, телеконференции, перенаправление почты.

Дозвон: зависит от телефона, района и времени суток. Есть обратный звонок Callback за ту же цену.

Купить: На каждом углу, с курьером.

Особенности: чтобы получить доступ нужно сначала зайти через гостевой вход и зарегистрироваться. По карте можно сидеть в интернет кафе на Охотном Ряду. Можно послушать состояние своего счета по специальному телефону. Для Callback отдельный всегда свободный телефон.

Интернет/телефон карта МТУ

Сайт: http://dialup.mtu.ru/intel_dilers/cards.htm

Максимальный тариф: вечером (20:00-01:00) 90 центов в час

Минимальный тариф: бесплатно в выходные (за абонентскую плату)

Бесплатно: Почтовый ящик.

Дозвон: зависит от времени суток.

Купить: На каждом углу или с курьером.

Особенности: Для получения доступа нужно зарегистрироваться. Callback стоит на обычных телефонах, т.е. свободного телефона нет. Много дополнительных услуг. Можно получить доступ к платным системам и базам данных. Можно с той же карточкой звонить по межгороду и международному телефону. При этом деньги будут вычитаться с Интернет счета.


Спецвыпуск Xakep, номер #020, стр. 020-046-3, КАРТОЧКИ НА КАЖДЫЙ ДЕНЬ

КАРТОЧКИ НА КАЖДЫЙ ДЕНЬ

Спецвыпуск Xakep, номер #020, стр. 020-046-3

Интернет/телефон карта ZEBRA (Зебра Телеком)

Сайт: http://www.ztel.ru/universalcard.php

Максимальный тариф: днем (09:00-02:00) 95 центов за час

Минимальный тариф: бесплатно ночью (за абонентскую плату)

Бесплатно: почта, новости, страничка.

Дозвон: лучше утром.

Купить: почти на каждом углу или заказать с курьером.

Особенности: Можно с одного счета звонить и сидеть в инете. Можно звонить из нескольких стран мира по одной и той же карте (роуминг). Нужен телефон с тональным набором.

Интернет карта Comstar

Сайт: http://dp.comstar.ru/regman/index.html

Максимальный тариф: днем на дорогом телефоне 90 центов за час

Минимальный тариф: ночью 20 центов за час.

Бесплатно: почта, страничка, телеконференции.

Дозвон: Лучше звонить в 6 утра с хорошей звонилкой.

Особенности: Разные телефоны для доступа стоят по разному: от 70 до 90 центов за час. На дорогие модемные пулы дозвониться проще, чем на дешевые.

Платежная карта КредитПилот

Сайт: http://www.kreditpilot.com/

Минимальная карта: 360 рублей

Купить: Не видел, но можно заказать курьером.

Возможности: Платить через интернет или обычный телефон за некоторые товары и услуги.

Особенности: Можно посмотреть через интернет сколько денег на что потратил. У твоего счета нет имени, все анонимно в отличии от кредитных карт. Платить можно только за те товары и услуги, которые поддерживают систему КредитПилот. Например, ты сможешь пополнить баланс на мобилке от Мегафона, а МТС не выйдет. Т.к. пока поддерживается только Мегафон.

Платежная Карта Rapida

Сайт: http://www.rapida.ru/

Минимальная карта: 500 рублей.

Купить: В банке или можно заказать курьером.

Возможности: Платить через Интернет за все у чего есть банковские реквизиты. Можно платить за квартиру (коммунальные платежи), за сотовый телефон, за Интернет, за покупки в Интернет магазине и т.д.

Особенности: Анонимно, можно заплатить даже за штраф ГИБДД, за некоторые услуги можно платить по телефону. Некоторые платежи со скидкой, некоторые с наценкой, некоторые мгновенно, некоторые с задержкой пару дней. Вся инфа об этом на сайте.


Спецвыпуск Xakep, номер #020, стр. 020-050-1, САМЫЕ ОЖИДАЕМЫЕ МОБИЛЫ

САМЫЕ ОЖИДАЕМЫЕ МОБИЛЫ

Спецвыпуск Xakep, номер #020, стр. 020-050-1

Ильдар Валитов ildar@str.ru

Настанет время, когда такие прибамбасы сотовых телефонов, как полифония звонка, цветной дисплей, GPRS, "голубые зубья" и новые, еще не придуманные сейчас, перейдут в разряд обязательных атрибутов либо отомрут, как рудимент. Поживем - увидим. Одно верно - пока они заставляют людей набрасываться и сметать с прилавков новоиспеченные гаджеты, выделяя их из серой массы клонированных трубок. Но часть их, порой лучшая, остается недоступной до каких-то времен, красуясь на интерактивных страничках в сети, вызывая бурное слюноотделение и мурашки, бегающие по спине и ударяющие в мозг с мыслью - "Хочу!". Именно о таких, ожидаемых, желанных, "офигительных", и пойдет здесь речь, хотя не только. И чтобы окончательно не загнать тебя в эйфорию, рассмотрим лишь десяток дитяток прогресса, без всякого упорядоченья - все модели хороши. Разберем только телефоны стандарта GSM.

Philips Fisio 820

Стандарт: GSM 900/1800

Размеры: 98x47x21 мм

Вес: 85 граммов

Дисплей: 120х120 точек, 256 цветов

Аккумулятор: Li-Pol 1000 мАч (литий-полимерный)

Время работы: ожидание 400 часов, в режиме разговора до 5.5 часов

E-mail: POP3 и SMTP, 3 учетные записи

Мелодии: 30 шт. + редактор мелодий

Голосовые функции: 40 меток

Диктофон: 30 сек.

Коммуникация:

SMS, MMS, EMS

Bluetooth

GPRS (4+2)

WAP 1.2.1

IrDA

Особенности: Динамически распределяемая между органайзером и телефонной книгой память на 500 кб.

Alcatel One Touch 715

Стандарт: GSM 900/1800

Размеры: 116x43x20 мм

Вес: 88 граммов

Дисплей: 100х150 точек, 4 оттенка серого, голубая подсветка, zoom, поворот меню на 90 градусов

Аккумулятор: Li-Ion

Время работы: ожидание 260 часов, в режиме разговора до 6.5 часов

Мелодии: 16 шт., полифония, редактор мелодий

Голосовые функции: 20 команд + 20 на голосовой набор.

Диктофон: 1 мин.

Коммуникация:

SMS, EMS 4.0

Bluetooth

GPRS (4+2)

WAP 1.2.1

IrDA

Особенности: 3 игры + сетевые, 800 ячеек телефонной книги, органайзер на 1000 событий, стильный дизайн а-ля семидесятые.

Samsung SGH-V100

Стандарт: GSM 900/1800

Размеры: 88х48х23 мм

Вес: 97 граммов

2 дисплея: внутренний - 176х220 точек, до 65000 цветов; внешний - 96х64 точек, голубая подсветка

Аккумулятор: Li-Ion

Время работы: ожидание 180 часов, в режиме разговора до 8 часов

Мелодии: 20 шт., полифонических - 16 шт., редактор мелодий, 16-голосный синтезатор

Голосовые функции: 18 меток

Диктофон: 1 мин.

Коммуникация:

SMS, EMS

GPRS

WAP 1.2.1

IrDA

Особенности: поддержка кодеков MP3, AAC, поддержка анимации, возможность воспроизведения видео в формате mpeg4, загрузка через GPRS, тип телефона - книжка

LG G7000

Стандарт: GSM 900/1800

Размеры: 88х45х22.5 мм

Вес: 89 граммов

Дисплей: 128х160 точек, 256 цветов + внешний, для служебной информации

Аккумулятор: Li-Ion 820 мАч

Время работы: ожидание 200 часов, в режиме разговора до 4 часов

E-mail: POP3 и SMTP, 3 учетные записи

Мелодии: 40-тональные полифонические

Голосовые функции: 10 меток

Диктофон: 3 записи по 30 сек.

Коммуникация:

SMS (до 1024 символа), EMS, русский словарь ввода текста

GPRS Class 10

WAP 1.2.1

IrDA

Особенности: первая модель на рынке одновременно с полифонией и цветным экраном


Спецвыпуск Xakep, номер #020, стр. 020-050-2, САМЫЕ ОЖИДАЕМЫЕ МОБИЛЫ

САМЫЕ ОЖИДАЕМЫЕ МОБИЛЫ

Спецвыпуск Xakep, номер #020, стр. 020-050-2

Motorola T720

Стандарт: GSM 900/1800

Размеры: 90х47.5х21.3 мм

Вес: 100 граммов

Дисплей: 120х160 точек, 4096 цветов

Аккумулятор: Li-Ion, 550 мАч

Время работы: ожидание 165 часов, в режиме разговора до 160 минут

E-mail: POP3

Мелодии: 32 шт. + редактор мелодий

Голосовые функции: 25 номеров + 9 меток доступа к меню

Диктофон: 3 мин.

Автоответчик

Коммуникация:

SMS, EMS 5.0

GPRS (4+1)

WAP 1.2.1

Особенности: имеются сменные лицевые панели, телефонная книга на 500 записей

Nokia 8910

Стандарт: GSM 900/1800

Размеры: 103-140,5x46x20 мм

Вес: 110 граммов

Дисплей: графический дисплей, до 4 строк текста, подсветка - Pastel Blue. Динамическое изменение контрастности дисплея

Аккумулятор: Li-Ion, 750 мАч

Время работы: ожидание 100-300 часов, в режиме разговора 2-4 часа

Мелодии: 35 шт. + 5 загружаемых + редактор мелодий

Голосовые функции: 10 номеров + метки для меню

Диктофон: 3 мин.

Секундомер

Коммуникация:

SMS, SMS-Chat

Bluetooth

GPRS (3+1)

HSCSD

WAP 1.2.1

IrDA

4 игры

Особенности: динамически распределяемая память. Титановый корпус.

Panasonic GD87

Стандарт: GSM 900/1800

Дисплей: внутренний - 65000 цветов, внешний - однострочный монохромный

Аккумулятор: Li-Ion

Мелодии: 16-голосная полифония

Голосовые функции: 40 меток

Диктофон: 30 сек.

Коммуникация:

SMS, EMS, MMS

GPRS

SyncML

WAP 2.0

IrDA

Особенности: встроенная фотокамера, возможность хранения фотоальбома, связанного с телефонной книгой, тип - "раскладушка"

Sony Ericsson P800

Стандарт: GSM 900/1800/1900

Размеры: 91x50x24 мм

Вес: 95 граммов

Дисплей: сенсорный 208х320 точек (40x61мм), 4096 цветов

Аккумулятор: Li-Ion

Активный флип

E-mail: POP3 и SMTP, IMAP4

Мелодии: полифонические

Word, Excel, PowerPoint & Acrobat Reader

Коммуникация:

SMS, MMS, EMS

Bluetooth

GPRS

HSCSD

WAP 2.0

IrDA

Особенности: смартфон с 12 Мб памяти под управлением пользователя, телефонная книга 1000 ячеек, возможность закачки Java приложений и игр, операционная система Symbian 7.0, встроенная цифровая фотокамера, поддержка рукописного ввода

Samsung SGH-T200

Стандарт: GSM 900/1800

Размеры: 88.5х46.5х22.8 мм

Вес: 99 граммов

Дисплей: 128х160 точек, 4096 цветов - внутренний, 64х46 с голубой подсветкой - внешний

Аккумулятор: Li-Ion, 900 мАч

Время работы: ожидание 180 часов, в режиме разговора до 8 часов

Мелодии: 20 шт. (16 из них полифонические) + редактор мелодий

Голосовые функции: 18 меток

Диктофон: 30 сек.

Коммуникация:

SMS, MMS, EMS

Bluetooth

GPRS (3+1)

Softmodem

WAP 1.1

IrDA

Особенности: синяя подсветка клавиатуры, автоматический механизм открытия корпуса, телефонная книга на 500 записей

Siemens M50

Стандарт: GSM 900/1800

Размеры: 98x47x21 мм

Вес: 97 граммов

Дисплей: 101х64 точек, янтарная или голубая подсветка

Аккумулятор: Li-Ion, 650 мАч

Время работы: ожидание 260 часов, в режиме разговора до 6 часов

Коммуникация:

SMS, EMS

GPRS (4+1)

Особенности: сменные панели, поддержка J2ME

ВЗГЛЯД ИСПОДЛОБЬЯ

В целом представленные здесь модели, за исключением трех, имеют в своем арсенале цвет, некоторые - многоголосье, а наличие практически у каждой модели поддержки GPRS говорит о будущем повсеместном внедрении этой технологии. Остается только ждать и уповать на прогресс. Делать это лучше не с пустыми руками. В статье использованы материалы с сайтов www.sotovik.ru и www.ixbt.com.


Спецвыпуск Xakep, номер #020, стр. 020-052-1, ФРИКЕРСКИЙ ТАЛМУД

ФРИКЕРСКИЙ ТАЛМУД

Спецвыпуск Xakep, номер #020, стр. 020-052-1

The Official Phreaker's Manual

TanaT (tanat@yes.ru)

Официальный мануал фрикера начинается словами: "Warning: Use of this material may shorten your life in the free world!", что в переводе на русский звучит примерно так: "Предупреждение: использование этого материала может сократить вашу жизнь на свободе!". Эта фраза стала эпиграфом многих последующих руководств, связанных так или иначе с противозаконной деятельностью. И это весьма разумное предупреждение, потому что авторы ОРМ (The Jammer и Jack the Ripper) изложили всю суть фрикинга полностью реально, то есть, ознакомившись с этим руководством, ты можешь выходить на улицу и фрикать, фрикать, фрикать... Если бы не одно "но": современная Россия это не Великобритания 90-ых годов. Актуальности OPM в современном мире и посвящена вся эта статья.

Следует отметить тот факт, что "The Official Phreaker's Manual" не имеет аналогов в мире. Представь себе, что весь текст в "Войне и Мире" Л.Н. Толстого заменили на инфу по какой-то узкой компьютерной специальности. Очень узкой. Что получится? Полное и сверхподробное суперруководство. Именно им и является OPM. После его появления были сделаны попытки создать нечто подобное и для хакеров. Наиболее удавшуюся попытку Руководства Сетевого Хакера (на русском!) можно найти здесь: http://www.opennet.ru/base/faq/nethack.faq.txt.html. Не стоит однако питать надежды, что оно такое же всеобъемлющее, но попытка все равно достойна внимания. Что касается самого OPM, то ему нет не только альтернатив, но даже перевода на русский язык не существует. А это очень печально, так как текст руководства написан на достаточно сложном английском с использованием большой кучи старого сленга. Это затрудняет восприятие, но отнюдь не делает его невозможным.

Ровно пятнадцать лет назад была написана настоящая Библия фрикинга, не имеющая аналогов в мире. Этот документ, занимающий сотни килобайт текста, содержит информацию обо всем, что так или иначе связано с фрикингом: технические приемы, справочные данные, стиль жизни фрикеров. Весь материал, который может быть полезен как начинающим, так и профи, был объединен в данный мануал, имя которому "The Official Phreaker's Manual". Годы шли, время брало свое, а это руководство передавалось с компьютера на компьютер, с сервера на сервер. Через него прошли почти все поколения фрикеров. Сегодня пришло время снова переосмыслить OPM. Что он может дать современному фрикеру? Ведь ничто не стоит на месте: техника ушла далеко вперед, "хакерство" (в плохом смысле этого слова) признано незаконным, а в ФСБ существует специальный отдел, занимающийся отловом компьютерных нарушителей. Остается ли OPM актуальным и сегодня или ему пора на покой? В общем, не переключай канал и читай дальше :).

Помимо актуальности OPM, неплохо было бы разобраться в его структуре. Данный мануал состоит из пяти глав и нескольких приложений. Сейчас мы пробежимся по каждой главе, заглядывая внутрь, и выясним, насколько она может пригодиться в жизни.

Первая глава является вводной. Она содержит информацию общего характера (не только техническую). Очень отрадно видеть, что авторы не поленились ввести в курс дела и начинающих фрикеров. Итак, в первой главе ты найдешь немаленький :) глоссарий, содержащий все основные термины и их трактовку. Оч-чень полезная штука, научит тебя мыслить не как Вася Пупкин, а как фрикер-профессионал. Вот самый яркий пример различия мировоззрений: что такое "сигнал занято" (в телефонной трубке)? Ответы: Вася Пупкин - ну занято, значит, трубка попискивает через пару секунд. Фрикер: это звуковой сигнал частоты 480 или 620 Гц, прерываемый 60 раз в минуту. Чувствуешь разницу? И она будет проявляться во всем: обычные люди никогда не видят тех вещей, за которые взгляд фрикера цепляется мгновенно. Это и делает фрикера фрикером.


Спецвыпуск Xakep, номер #020, стр. 020-052-2, ФРИКЕРСКИЙ ТАЛМУД

ФРИКЕРСКИЙ ТАЛМУД

Спецвыпуск Xakep, номер #020, стр. 020-052-2

Идем дальше. Так же в первой главе можно найти некоторые правила "хорошего тона". Например, правила говорят, что слова freak и phreak эквивалентны. В принципе эти правила сейчас на фиг никому не нужны: ну не все равно тебе, как было принято говорить у британских фрикеров 15 лет назад? Другое дело, если ты любитель истории, тогда эта инфа тебе будет кстати. Для сегодняшней России все эти правила абсолютно бесполезны. Также в первой главе вводятся достаточно сложные понятия, используемые в дальнейшем повсеместно. Например, красные, голубые, сырные, серебряные коробки (или ящики). Каждое из этих словосочетаний имеет свое определение. Голубой коробкой называется устройство, суть которого в том, чтобы создавать звуковой сигнал, позволяющий обмануть другое устройство. Такие штуки использовались для бесплатных междугородних звонков и тому подобного. В OPM расписано не только, что называется такими коробками, но и как их создавать (то есть те частоты, которые они должны генерировать). Это добавляет материалу практическую ценность, но и повышает риск встречи с доблестной милицией, что не есть хорошо... Шутка!

Во второй главе этого руководства содержится инфа исторического характера (история Британского фрикинга и тому подобное), замечательная история под названием "Secrets of the Little Blue Box" и небольшой рассказ с нецензурным названием. В последних рассказывается не только о технике фрикинга, но и о жизни фрикеров вообще. Сами эти истории представляют собой неплохие литературные произведения, читать которые просто приятно. Вот вкратце суть одного рассказа: молодой Фрикер вычислил, что в аппаратуру некоторых офисов зашит определенный номер телефона, изменить который невозможно (аппаратура давала сбои). Ему страсть как хотелось узнать, что же скрывается на другом конце провода. Он позвонил туда (искусству вести диалог с телефонисткой, думаю, может позавидовать каждый), но был отшит в два счета. В конце концов он выяснил (через дядю, работающего в ФБР), что это был прямой номер с Президентским бомбоубежищем (дяде, кстати, дали по голове за расспросы о секретной информации). Рассказ написан достаточно просто и читается на одном дыхании. В общем, вторая глава достойна внимания.

Третья глава уже начинает рассказ о конкретных фичах и способах обхода того или иного телефонного (сетевого) механизма. Также в ней содержатся рекомендации по фрикингу карточек AT&T.


Спецвыпуск Xakep, номер #020, стр. 020-052-3, ФРИКЕРСКИЙ ТАЛМУД

ФРИКЕРСКИЙ ТАЛМУД

Спецвыпуск Xakep, номер #020, стр. 020-052-3

К сожалению, почти вся представленная инфа подходит только для буржуйских сетей. Конечно, прочесть ее и разобраться никогда не помешает - это классика. Но тратить на изучение этой части кучу времени ради получения "виртуальных знаний" (может они вообще не пригодятся?) дело рискованное. Вообще, эта глава является наиболее смысловой (куча технических решений). Прочтя ее, ты не сможешь применить знания тут же, но получишь толчок в развитии своего фрикерского мастерства точно. Также из нее можно почерпнуть сведения о том, как и где искать уязвимости в различных службах, а это немаловажно. Резюмируем: если у тебя есть время и возможность, изучи эту главу обязательно - не пожалеешь. Если же ты хочешь быстро втянуться во фрикинг, ее лучше пропустить, так как моментальных практических благ ты не получишь.

В четвертой главе ты найдешь инфу по фрикингу компании Bell. В целом почти весь Британский фрикинг есть война с этой компанией, которая, собственно говоря, никому ничего плохого не сделала. Просто фрикеры научились получать от нее кучу услуг бесплатно, а хлебное место, как известно, пусто не бывает. Что касается практического применения полученной информации, то оно внушает сомнения. Одна из подглав посвящена тому, как можно узнать информацию о человеке (организации) по номеру его телефона. Согласись, что сейчас это может сделать каждый, сидя за своим компом. Также эта глава содержит справочные данные (типа номеров телефона), которые абсолютно никому не помогут в России. Думаю, в Великобритании тоже: как никак 15 лет уже прошло, наверное, половина номеров поменялась. В общем, пропустив эту главу, ты особо много не потеряешь.

Последняя часть чем-то напоминает третью: много информации технического характера, но уже касающейся модемов и применительно к США. Эту главу - рекомендую. Во-первых, почуешь разницу между США и Великобританией, найдешь различия и сходства, а, следовательно, более глубоко разберешься в структуре сетей. Во-вторых, на модемах сейчас держится достаточно многое, так что информация не потеряла часть своей актуальности. В общем: must read.

Теперь перейдем к приложениям. Если быть честным, то почти всем из них давно пора на пенсию: никому не нужны коды городов и штатов США, номера телефонных компаний и тому подобная справочная инфа. Зато некоторые из приложений (штуки три из 10) расскажут о реально полезных вещах: конструкции разных коробок (ящиков), мы о них говорили выше, и других рулезных устройств. С этой инфой нужно ознакомиться обязательно. Только, чтобы ее понять, надо обязательно прочесть первую главу (чтобы знать, о чем идет речь) и, возможно, третью с четвертой, так как иначе может быть непонятно, почему действия конструируемых устройств приводят к желаемому результату (чтобы не быть обезьяной, надо во всем разобраться до конца).

Можно подвести итоги: OPM утратил большую часть своей актуальности за последнее время, однако некоторые его главы (какие конкретно, смотри выше) до сих пор полезны на практике. Изучение их поможет найти уязвимости в любой телефонной системе (в любой стране). Несколько приложений в конце мануала вообще на вес золота, так как являются своеобразными эксплоитами найденных уязвимостей. А если все, что написано выше, сказать в двух словах, то: настоящий фрикер должен прочесть это руководство или хотя бы ознакомиться с ним.


Спецвыпуск Xakep, номер #020, стр. 020-054-1, МОБИЛЬНЫЕ ПИРАТЫ

МОБИЛЬНЫЕ ПИРАТЫ

они могут все

Спецвыпуск Xakep, номер #020, стр. 020-054-1

n0ah (noah@real.xakep.ru)

Разлочить мобильник – плевое дело. Имея рульные проги, пираты готовы обеспечить расширенный сервис. Чел может приехать со своей мобилой и попросить залить ему новую прошивку, саунды, логотипы, заставки. Можно инстальнуть в дешевый телефон, которому по модели не полагается, такие атрибуты дорогих мобильников, как часы, калькуляторы, игры, календари и многое-многое другое.

Давай для начала разберемся, кто есть мобильные пираты, а кто есть фрикеры. Фрикер – это чел, который хорошо разбирается в телефонных сетях и способен проникать в них, получая большие полномочия, чем положено рядовому пользователю. Под заумным «большие полномочия» подразумевается, например, возможность пользоваться платными услугами на халяву, прослушивать чужие разговоры и творить прочий беспредел. А мобильные пираты – это такие барыги, которые торгуют ворованными телефонами. Естественно, что большинство таких трубок к ним поставляются в залоченном виде, поэтому они должны уметь их разлочивать. Чтоб понять, что это за угарные перцы, мы съездили к одному очень известному радиорынку и познакомились с этими ребятами, попутно поглядев на их работу и позадолбав вопросами.

СХЕМА

Судя по тому, с каким трудом ребята идут на контакт, можно сказать, что это очень закомплексованные и замкнутые люди ;). Каждое слово они обдумывают, наверное, по два раза, чтоб не сболтнуть лишнего. Тем не менее, выяснить схему их трудового дня нам удалось. Если всех грубо разклассифицировать, получится примерно две группы: менеджеры и зазывалы. Когда ты приходишь на рынок, к тебе сразу начинают приставать с предложениями купить/продать мобильник – это зазывалы. В основном, молодые, бойкие ребята. Эти-то как раз готовы и поговорить, и пообсуждать твою мобилу, и предложить что-нибудь из своего ассортимента. Но толку с них никакого – как только дело доходит до сделки с участием каких-то финансов, эти ребята бегут к менеждерам и утверждают все у тех. Например, пока мы общались, к «нашему» человеку подошел парнишка, показал мобилу и спросил: «За семьсот возьмем?». Тот ее глянул и ответил: «Нет, такую юзаную за семьсот не возьмем». Точно такие же «консультации» происходят при продаже («За семьсот отдадим?»). Денги складируются, естественно, у менеджеров. Они же могут прямо на месте произвести с мобильником «чудо»: снять любой лок, залить новую прошивку, протестить и тд. Короче, они умеют вытворять с телефоном все, что только можно представить.

ЛОК/УНЛОК

Телефон может быть заблокирован обычным кодом секьюрности данной модели, может быть закрыт на PIN (или даже на PUK), может быть залочен на определенного оператора. Обойти все виды защиты для мобильных пиратов – дело трех минут. Они, конечно, знают огромное количество кодов к чудовищному количеству моделей, они умеют включать инженерные, сервисные и тестовые меню, но все это, чаще всего не применяется, так как гиморно пиликать кнопочками на клаве телефона. Зачем? Ведь, все делается намного проще. Человек, которые взялся нам хоть чуть-чуть рассказать, предложил мне: «Хочешь глянуть?». Конечно, хочу! И мы пошли куда-то. Оказывается, к его машине. Стояла она у него в двух минутах ходьбы. Открывает машину, садится – на пассажирском сиденье лежит аккуратненький ноутбук. Привычным жестом открывает его, нащупывает рядом проводок (к ноутбуку подключен целый ворох проводов, переплетенных между собой), находит из огромного количества подходящий для требуемой модели штекер, втыкает его в гнездо телефона и запускает одну из тучи иконок на рабочем столе. Появляется dos`овское окошко и сразу исчезает. Все, мобильник разлочен! Ему даже не пришлось в проге что-то ковырять – все уже заранее готово.


Спецвыпуск Xakep, номер #020, стр. 020-054-2, МОБИЛЬНЫЕ ПИРАТЫ

МОБИЛЬНЫЕ ПИРАТЫ

они могут все

Спецвыпуск Xakep, номер #020, стр. 020-054-2

Для каждой модели (или для серии моделей) существует своя прога. Пишут их программеры, которых можно назвать фрикерами. Это грамотные люди, но на них, к сожалению, хрен выйдешь. А все эти менеджеры и зазывалы – по большому счету просто торговцы и во взломе нифига не разбираются. У них есть просто инструменты (программы), которыми, они в силу привычки, умело пользуются. Вот так вот ;). Поэтому я их и называю мобильными пиратами, а не фрикерами. Программки эти вполне реально достать и тебе, и мне – были бы деньги (в среднем, 100-200 букузоидов за одну прогу). Кстати, мы спросили, нет ли этих прог в инете. Пират ответил, что в инете такие проги есть, и он пытался их поюзать, когда только начинал, но очень быстро сообразил, попортив при этом несколько мобил, что это фуфловые проги – в инет выкладывается самый отстой, которые уже никому не продашь. Кстати, чел посетовал, что даже провода обходятся недешево – самое дешевое китайское дерьмо стоит не меньше восьми сотен деревянных.

ДОПОЛНИТЕЛЬНЫЕ СЕРВИСЫ

Разлочить мобильник – плевое дело. Имея рульные проги, пираты готовы обеспечить расширенный сервис. Чел может приехать со своей мобилой и попросить залить ему новую прошивку, саунды, логотипы, заставки. Можно инстальнуть в дешевый телефон, которому по модели не полагается, такие атрибуты дорогих мобильников, как часы, калькуляторы, игры, календари и многое-многое другое. Стоит такое удовольствие около трех сотен отечественных шевелюшек. Но наш знакомый пират по этому поводу высказался, что, мол, не до этого. Гиморное это занятие – любое неправильное движение (вынул штекер не вовремя, нажал случайно кнопку при прошивке) может грохнуть телефон безвозвратно. Поэтому лучше не париться с такими вещами, а просто скупать всякие лоченные трубки, разлочивать их и продавать в три раза дороже. Кстати, «хрупкость» мобил в софтварном плане – первый враг пиратов. Ребята нам рассказали, что за все время работы, убили столько телефонов, что и не сосчитаешь. У одного перца дома под кроватью хранится целый чемодан с такими грохнутыми болванками.

ФИНТ С ТЕСТОМ

А еще ребята продемонстрировали нам, что поколдовать могут с любым телефоном. У меня с собой была древняя, но заслуженная моторолка СтарТАК. Я ее достал и протянул пирату, отлично зная, что test-режим в ней отключен. Он ничуть не смутился, достал test-карту (это такая симка специальная для моторол, ее ремонтники используют для вхождения в test-режим), впихнул ее в телефон и спокойненько показал мне, как набирать в мотороле свои мелодии, как узнать unlock-код и security-код. Мы, конечно, тоже не ламосы и все эти фичи знали (и про тест-карту тоже), но эта фишка наглядно проиллюстрировала, что ребята подкованы и готовы ко всему (ну не мог же он знать, что я приволоку именно моторолу).


Спецвыпуск Xakep, номер #020, стр. 020-054-3, МОБИЛЬНЫЕ ПИРАТЫ

МОБИЛЬНЫЕ ПИРАТЫ

они могут все

Спецвыпуск Xakep, номер #020, стр. 020-054-3

UNLOCKED!

Вот так мы с тобой и узнали, что из себя представляют мобильные пираты. Стоит ли идти к ним апгрейдить свой мобильник или покупать новый – решать тебе.


Спецвыпуск Xakep, номер #020, стр. 020-056-1, МОБИЛЬНЫЕ ЗВУКИ

МОБИЛЬНЫЕ ЗВУКИ

Спецвыпуск Xakep, номер #020, стр. 020-056-1

Андрей «Дронич» Михайлюк & ...

ЗАГАДОЧНЫЙ ФОРМАТ

Если можно послать мелодию SMS-кой, можно ли написать такую SMS-ку руками (для того, чтобы можно было послать ее с любого SMS-гейта или с любой сотки)? Оказывается, что нет :(. В данном случае используется не простой SMS-формат сообщения, а придуманный все той же Nokia. Поэтому при попытке послать музыкальную SMS-ку на сотовый другой марки мы видим сообщение, "wrong SMS format" или что-то подобное (зависит от прошивки и модели). Если же посмотреть на дамп сообщения при отсылке (на пути двух мобил, меняющихся мелодиями, ставится комп с ИК-портом :)), то в сообщении можно увидеть всякую ерунду, больше всего похожую на внутренности EXE-файла. От самих же нокиевцев добиться вразумительного ответа про стандарт SMS сообщений с мелодией не удалось. Утверждают, что это стандартный RTTTL, но при посылке в обычном сообщении полноформатного RTTTL телефон не определяет его как мелодию, а выдает просто текстом :(. Обыдна-а-а...

МОБИЛЬНЫЙ ПРИКОЛ

На ребятами с нокийскими телефонами можно смачно приколоться, послав им мелодию по СМС. В чем прикол? После приема «муз-СМС» :) доступно две опции - "прослушать" и "сохранить". Если места под мелодии в сотовом нет (а его, как правило, нет) и сохранять в принципе некуда, многие предпочитают прослушать мелодию. И вот тут для нас главное правильно подобрать тему. Если твой (не)друг идет на экзамен, можно отправлять ему "похоронный марш"; испытания в полевых условиях показали невиданный по силе разрушений результат. Если он "зацепил" подружку и пытается проехаться по ее нежным ушкам на тракторе, можно отправить ему "марш Мендельсона"; достаточно сильно отрезвляет и приводит в чувства. Действуй по обстоятельствам, и тебя будут помнить вечно ;).

Перец, тебе не надоело дергаться при каждом звонке мобильного поблизости? Даже если у тебя есть вибратор, то ты все равно инстинктивно тянешься к мобиле, когда твои уши слышат знакомый до боли звук. Для того чтобы это вылечить, мы запишем свои мелодии в сотовый и будем ждать только звуков Nirvan-ы и Rammstein-а.

Как и положено в нашем мире компьютеров и железа, все настраивается под пользователя (почти все), телефоны в этом не исключение. Самое нехорошее западло в том, что у каждой фирмы (а иногда и просто у разных моделей) существуют свои стандарты. При этом они практически не отличаются по смыслу, поскольку новых нот еще никто не придумал, но отличаются по написанию (или способу ввода) и звучанию. Перебросить мелодию, например, с Ericsson-а на Panasonic будет довольно гиморно (особенно если это делать в метро и стоя :). Конечно, можно сделать это и онлайн-конвертером, но мало ли... На случай, если мелодия непопулярна (или вообще набита по нотам), надо уметь делать все самому, а уж разобраться с нехитрой прогой ты и сам сможешь. Так что давай для начала посмотрим на некоторые стандарты записи мелодий.

Samsung

Идеальное качество воспроизведения плюс запись по нотам, без всяких выкрутасов. Все вводится как есть: нажимаем D - получаем «ре», нажимаем F - получаем «фа». С длительностью и октавами опять-таки никаких проблем не возникает. В последних моделях Самсунга (SCH-X290, к примеру) применяется полифонический звук, то есть музыка записывается аккордами. Такая мобила может подражать целому оркестру, вводить, правда, полифонические мелодии очень сложно (если вообще возможно :)).


Спецвыпуск Xakep, номер #020, стр. 020-056-2, МОБИЛЬНЫЕ ЗВУКИ

МОБИЛЬНЫЕ ЗВУКИ

Спецвыпуск Xakep, номер #020, стр. 020-056-2

Nokia

Наиболее понятно и доходчиво написаны параметры нот, что позволяет переделывать нокиевские мелодии практически под любой телефон. Запись выглядит так: "32#d2", а значит это следующее: длительность 1/32-ая, диез (повышение на полтона), нота «ре» второй октавы (чем меньше номер октавы, тем ниже звук). Пауза вставляется в виде «8-» (длительность 1/8-ая). Длительность ноты измеряется в долях секунды, 1/1 это 1 секунда, 1/32 - одна тридцать вторая секунды.

Siemens

Не очень далеко ушел от предыдущего случая, ноты записываются в следующем формате: «d2(1/32)» ака нота «ре» второй октавы длительностью 1/32 секунды. Как видишь, перегнать мелодию из Сима в Нокию и обратно не составит труда.

Ericsson

В Эриках ноты пишутся как «D#a+D», что означает «ре» удлиненная, «ля» на полутон выше, второй октавы «ре» удлиненная. Выглядит вроде все понятно, но подобрать мелодию для данного агрегата достаточно проблематично, потому как всегда путаешься с обозначениями длительности и октав. Однако в мобилах этой фирмы функция самовбивания мелодий появилась на достаточно старых моделях, поэтому готовых мелодий и так море.

Motorola

Тут все чисто: «D2 B#8», то бишь «ре» 1/8-ая и «си»-диез 1/2. Октав, правда, задать не получится, все мелодии играются только на семи нотах. Иногда спасают полутона, а в последних моделях была обещана "поддержка" октав (хотя пока ее нет ни в одной из анонсированных Моторол).

Sony

Вид нот под Соньку: «777**** 22#**** 777**** 44#****», что означает 1/16 «си» первой октавы, 1/16 «ре»-диез второй октавы, 1/16 «си» первой октавы, 1/16 «фа»-диез второй октавы. Такой способ не очень удобен при перебивке, зато с лихвой окупает себя при забивании готовых мелодий и композиторстве (ноты и паузы наглядно отображаются на экране, а для выбора юзается JOG-dial).

Panasonic

Формат Пнасюков до боли похож на Сонькинский, соответственно - все траблы и преимущества те же. Вид нот: «44**** >22****» или 4-ая нотка («фа») длительностью 1/16 и 2-ая нотка (ре) с полутоном длительностью 1/16.

Bosch

Редкостный вид, мертворожденный. Как правило, в сотке уже забито около 30 мелодий, но вот набрать свою песенку не удастся. Можно менять мелодии только в случае трепанации черепа, то есть сливаем полностью EPROM-ку к себе в комп по кабелю и, переделав мелодии, загоняем их назад в сотку. Если шнурка нет, то можно обратиться в службу тех-поддержки (это те, которые русификацию делают и Lock снимают), но дешевле все же сменить сотку на более сговорчивую.

Заметь, что на самом деле в мобильник забивается не то, что написано на бумаге. К примеру, мелодия для Нокий «8g1 4c2 8g1 8a1 4b1 8e1 8e1 4a1 8g1 8f1 4g1» при непосредственном наборе будет выглядеть совсем по-другому (а именно «5819*5**86793836958459»). Именно в этом и заключается преимущество Сонек и Панасюков - ноты для них сразу готовы к набиванию.


Спецвыпуск Xakep, номер #020, стр. 020-056-3, МОБИЛЬНЫЕ ЗВУКИ

МОБИЛЬНЫЕ ЗВУКИ

Спецвыпуск Xakep, номер #020, стр. 020-056-3

Ну как? Немереный геморрой, правда? Но это единственный способ для метро. В домашних условиях все гораздо проще. Допустим, что мы сидим перед ноутбуком и на мобиле есть инфракрасный порт (или она подрублена шнурком на СОМ-порт). Возьмем опять же Нокию, у которой есть фича коннекта к компу (8210 сойдет). Грузим программку по управлению телефоном (например, LogoManager) и имеем полный перечень возможностей. Если мелодии хранятся в текстовике в том самом (8g1 4c2 8g1 8a1...) буквенном виде, их придется немного поправить для соответствия стандарту RTTTL (Ringing Tones Text Transfer Language). Мелодия должна выглядеть примерно так: "Welcome:d=4,o=5,b=120:8g1, 4c2, 8g1, 8a1, 4b1...". Welcome - это название мелодии, d=4 - длина ноты по умолчанию, o=5 - октава по умолчанию, b=120 - это темп проигрывания мелодии (битрейт), ноты те же, точкой обозначается "краткая" нота.

Отдельно стоит вопрос о конвертации MIDI-файлов. Для каждого производителя в сети обязательно найдутся программы, которые позволят получить из любой мидишки оригинальный звонок. Для Нокии идеальна Iguana Ring (http://www.mobilstar.ru/soft/nokia/iguanaring.zip), для Соньки - SONY CMD-Z5 Composer (подходит не только для Z5, http://mobilmusic.ru/files/sonyz5.zip), у Сименсов эту задачу выполняет многофункциональный комплекс S35 Explorer (http://mobilmusic.ru/files/s35-explorer.zip).

У телефонов Nokia есть еще одно весомое преимущество, заключающееся в пересылке мелодий по СМС. Достаточно найти на сайте твоего оператора связи (Beeonline, Megafon, MTС) или специализированном сайте типа infon.ru раздел "картинки и мелодии" и отправить себе на мобилу понравившуюся мелодию. Помни только, что это спишет с твоего мобильного счета энную сумму бабла (обычно не более 50 сантимов). Всем же любителям халявы остается качать мелодии в текстовом виде или искать проги для перепрошивки сотовых. Где? Держи пяток сайтов для начала.

mobilmusic.ru

Один из самых достойных сайтов по теме. В изобилии присутствуют русские мелодии, с импортными чуть хуже, но терпимо. Очень радует тот факт, что скачать мелодию можно под любую модель телефона - на сайте работает онлайн-конвертер, так что даже обладатели редких мобил будут не в обиде. Помимо мелодий на сайте присутствуют инструкции по вбиванию мелодий в телефон и разнообразные проги для работы с мобильниками. Расстраивает только количество баннеров, которые нам дают в нагрузку вместе с мелодией. Юзайте Оперу, и все будет чики-пуки :).

melody.org.ru

Если тебе нужен импортный музон в качестве звонка - этот сайт для тебя. Более 1000 мелодий под Сименс, Эрики и Нокию собраны в одном флаконе. Единственный минус - абсолютно разные разделы для каждой из марок. То есть если мелодия есть под Эрик, не факт, что ты найдешь ее под Нокию :(. Нас опять кормят баннерами, но уж потерпим, что делать :). Если вдруг надоест искать мелодии, можешь поиграть в игрушки на эмуляторе Нокии.


Спецвыпуск Xakep, номер #020, стр. 020-056-4, МОБИЛЬНЫЕ ЗВУКИ

МОБИЛЬНЫЕ ЗВУКИ

Спецвыпуск Xakep, номер #020, стр. 020-056-4

mu.com.ua

Братья хохлы не подкачали, количество русских (ну и украинских) мелодий на сайте просто зашкаливает. Радует, что здесь можно найти свежую музычку даже раньше, чем на mobilmusic'e, и при этом посмотреть только один баннер. Все мелодии за редким исключением присутствуют в четырех наиболее популярных форматах: Эрик, Нокия, Сименс и Моторола.

www.gsmbazar.com

Все, хватит бантиков и рюшечек! На этом сайте мелодии присутствуют только для проформы, основной его контент - проги для анлока и перепрошивки мобил. Если твоя мобила не поддерживает ручную забивку мелодий, сливай и фрикай. За последствия мы не отвечаем.

mobile.box.sk

Это сайт для любителей помучить свои мобилки и разобраться в них досконально.

Здесь можно найти разнообразный софт, секреты и документацию (как официальную, так и неофициальную) по многим телефонам. Ну и мелодии тоже присутствуют...


Спецвыпуск Xakep, номер #020, стр. 020-060-1, СВЕЖИЕ МОБИЛКИ В ГОСТЯХ У СПЕЦА

СВЕЖИЕ МОБИЛКИ В ГОСТЯХ У СПЕЦА

Спецвыпуск Xakep, номер #020, стр. 020-060-1

Андрей "Дронич" Михайлюк (dronich@real.xakep.ru)

Дабы избежать нехороших обвинений типа "да мне на такую мобилу вовек не накопить, ублюдки", сразу отсылаю таких товарищей на Х... нет, в Х №5(41), к Центнеру, на тест всякоразных мобил, в том числе и эконом-класса. А мы отрываемся по полной вместе с самыми-самыми!

Знаешь, почему я не люблю читать узкоспециализированные издания? Все очень просто - никакой наглядности и минимум полезной инфы. Заглатываешь сотню килобайт пурги, перегруженной терминами и сравнениями, а впечатления не остается ну никакого. Такое ощущение, что авторы даже издалека не видели то, что "обзирают". Обидно, да? Поэтому наш обзор топ-моделей (а как хотелось бы остановиться тут :)) мобильников написан совсем наоборот - взяли, поиграли, разобрались и рассказали. Поглощай на здоровье!

Panasonic GD95

Признаться, реклама этого телефона, развешенная по Москве, нас настолько достала, что его мы нашли первым :). Мобильник передовой, ничего не скажешь. Огромный экран практически в полтелефона нужен не только для понту - на него влезет целиком ЛЮБАЯ СМСка и большинство е-мейлов (в телефоне есть POP3/SMTP клиент, так что можно смело звонить провайдеру и снимать/посылать почту). В режиме ожидания весь экран занимает веселенький рисунок, а основная менюха вылезает в виде девяти иконок. При наведении курсора на иконку она смачно "зумится" и приобретает дополнительную резкость. А двигается курсор мягким многофункциональным джойстиком, который не используется только в... играх. Да, такая вот лажа - по менюшкам лазай, а гамайся на клавишах (а вот и нет, в головоломку можно играть джойстиком - прим. ред.). Снова обидно. Игрушки-то классные - интеллектуальные пятнашки и "Огородник" (из нор периодически высовываются червяки, которых надо колбасить тяпкой по балде). Из серьезных вещей присутствует калькулятор, на котором можно (удобно :)) считать, и неплохой ежедневник с календарем (календарь на целый месяц полностью помещается на экране). Любителям кастомизинга и украшательств понравятся сменные обои, разноцветный экран (белесый металлик и экстремальный оранжевый для оригиналов, зелень - для консерваторов) и полифонические звонки. Звонки в этом телефоне - отдельная история. Они настолько приятны на слух, что стандартный писк других мобил просто режет ухо пиплу, привыкшему к Panasonic GD95. А еще через микрофон в телефон можно загнать вообще любые звуки и использовать записанное как обычный звонок. Прикинь, когда тебе звонят, у тебя из телефона начинает петь Масяня свою «When the party is over...». Класс! Телефонная книга не очень удобная, но жить можно, тем более. что в нее встроен офигительный механизм фильтрации. Для каждого абонента (или группы) можно назначить свой звонок, вибрацию, цвет экрана при звонке - круто, короче. Единственное, что немного раздражало при работе с этим телефоном - невозможность дернуть джойстик по диагонали, а ведь иногда интуитивно хочется (что-то ты совсем зажрался - намекнула совесть Дроничу ;)).

Siemens SL42

Неплохой телефончик, полностью соответствующий сименсовским стандартам. Причем как в хорошем смысле, так и в плохом :(. Настраиваемое меню, переназначаемые функциональные кнопки, емкая записная книжка - это, конечно, несомненные плюсы. Только вот русские буквы в меню слегка кривые (милые сименсовцы, ну когда ж вы нас порадуете хорошим шрифтом?). Да и замечательная кнопа "подтвердить" (справа под экраном) и кнопа "нет" (прямо под ней) спаяны в одну, что временами вызывает... ну, скажем, раздражение (ага, когда из четвертого уровня меню выкидывает к начальному экрану из-за того, что промахнулся на полмиллиметра :)). А уж просматривать 14 полей каждой из записей книжки - просто ад :). Хотя все это мелочи, ведь главная фишка телефона - ММСшная карточка, торчащая из его бочины :). Тут тебе и музыка МР3шная, и место для записей диктофона, и даже Java-программы (!). О прогах вообще разговор особый: на демо-карточке лежало несколько JARов: от простых часов до аркадных игрушек и клона Аськи. Так что обладатель ЭсЭльки может не только еженедельно менять гамесы и чатиться по 0.15 у.е. в минуту, но и (в случае своей программерской продвинутости) писать скрипты для всяких расчетов, что есть очень актуально для студентов-технарей. Сходство данной мобилы с компом усиливает наличие полноценной справочной системы и неполноценного :) файл-броузера. Если со вторым все понятно и так (обычный просмотр содержимого карточки с возможностью удаления/копирования/перемещения), то справка вызывает двоякие чувства. С одной стороны, приятно погрузиться в мануал и досконально изучить все менюшки из чисто теоретических побуждений. А вот с другой, когда непонятно назначение пункта меню, придется искать справку именно по нему, а это уже весомые потери времени и нервов. Неоднозначный такой телефон, но как замена старенькому "Симу" пойдет вполне.


Спецвыпуск Xakep, номер #020, стр. 020-060-2, СВЕЖИЕ МОБИЛКИ В ГОСТЯХ У СПЕЦА

СВЕЖИЕ МОБИЛКИ В ГОСТЯХ У СПЕЦА

Спецвыпуск Xakep, номер #020, стр. 020-060-2

Nokia 8810

Эту мобилу мы с боем позаимствовали у Покровского :). Он упирался и отбивался ногами, но ускользнуть от конфискации так и не смог. Сейчас в Европе можно уже найти полноправного преемника этой модели - 8850, но наша редакция находится отнюдь не на Елисейских полях (а рядом с Елисеевским гастрономом :)). Хотя наш образец совсем не старый и вполне престижный. В отличие от своих "соседей" 82-ой серии, эта Нокиа обладает сдвижной панелью, прикрывающей часть клавы. Именно часть, потому что навигационные кнопки и "трубочки" Yes/No остаются снаружи, так что для настройки телефона и ответа на звонки открывать клавиатуру необязательно. Что по части программной начинки, так она вполне стандартна для "восьмерок": менюшка с анимированными картинками, средней паршивости расписание, хорошая записная книжка, несложные игры и ИК порт. Главное в этой трубке - внешность. Серебристый корпус, белесая подсветка, панелька-слайдер... Скромное обаяние оригинальности.

Sony Erricson T68i

Признаюсь, очень непривычно видеть на небольшом экране мобилы тысячи оттенков цвета. Прогресс, черт возьми! Кто-то скажет, что это неприкрытое пижонство и зверский расход аккумулятора. Ну и пусть - бюст Памелы Андерсен в качестве фона того стоит :). Шучу, конечно, хотя натянуть их на десктоп действительно не составит труда. Основное применение цветного экрана в телефоне - карточные игры и "Темы рабочего стола". Все остальное смотрелось бы так же и в четырех оттенках серого, и в монохроме. В телефон встроена рисовалка наподобие Paint'a, но справляться с ней ужасно неудобно - джойстик на панели движется только "вверх-вниз-влево-вправо". Есть прикол с выбором размера шрифта, но из предлагаемых трех читабелен только средний, а удобен для вывода на экран - мелкий (чтобы больше влезло). Очередная заковыка - локализация кривовата :(. Перевод вполне нормальный, а вот буквы пляшут: И и N, Я и R по ходу смотрятся для локализаторов одинаково :). Ну и, пожалуй, последний баг - совершенно неконкретный джойстик, который норовит уйти вверх при нажатии и нажаться при движении. По иконочному меню особо не погуляешь. Не смогли производители выехать на одном только цветном экране и массе стандартных фишек... Жаль.


Спецвыпуск Xakep, номер #020, стр. 020-060-3, СВЕЖИЕ МОБИЛКИ В ГОСТЯХ У СПЕЦА

СВЕЖИЕ МОБИЛКИ В ГОСТЯХ У СПЕЦА

Спецвыпуск Xakep, номер #020, стр. 020-060-3

Motorola V70

Безумно оригинальный телефон, стопудово привлекающий к себе внимание. Сделан не на бинарной, а на чисто женской логике. Иначе как объяснить тот факт, что мы с Ноа полчаса безуспешно искали голосовой набор, а девчонки из рекламного отдела справились с этим за полминуты :). Хотя объяснить, зачем на корпусе в закрытом состоянии специально выделены курсорные кнопки, которые не делают абсолютно ничего (!), не смогли и они (есть идеи? мыль!). Телефон просто кишит всякими неясностями, например, громкость повышается при быстром нажатии на специальную кнопу и снижается при удержании той же кнопки. Зачем? Почему не сделать простой ролик или хотя бы две кнопки? Может быть, это очередная из "оригинальностей" телефона, такая же, как и инвертированный экран (черный с серыми циферками), и подсветка клавы параллельными полосами вдоль кнопок, и встроенный радиоприемник... Женская модель, одно слово. Только вибратор почему-то слабоват :).

Samsung A300

Одна из первых «enhanced»-книжек на нашем рынке. Под enhanced подразумевается наличие второго дисплея на крышке телефона, на котором отображаются основные статусные иконки, часы и входящие номера при подключенном определителе. Все это и многое другое ты сможешь увидеть и на большом экране, если тебе не лень откинуть крышку :). Кстати, он действительно большой - семь строк по 16-17 символов, плюс выдерживает несколько градаций серого (что действительно украшает телефон). Основная менюха до жути удобная, как впрочем и все последующие: управление при помощи четырехсторонней курсорной клавиши себя оправдывает. Нас очень приколола функция просмотра значений конечных пунктов меню. Когда курсор задерживается над одной из строк, под ней всплывает подсказка с текущим значением параметра (типа «Вибратор - Вкл»). Эргономика телефона на высоте, даже курсорной пимпе не дают отдохнуть - в режиме ожидания на ней висят аж четыре функции: Инет, калькулятор, календарь и сообщения. Главный минус - минимум общих настроек, хотя для многих это будет счастьем, а не бедой :). Несмотря на относительную пухлость, которая не позволяет запихнуть мобилу в карман джинсов, она смотрится миниатюрной и идеально лежит в руке.


Спецвыпуск Xakep, номер #020, стр. 020-060-4, СВЕЖИЕ МОБИЛКИ В ГОСТЯХ У СПЕЦА

СВЕЖИЕ МОБИЛКИ В ГОСТЯХ У СПЕЦА

Спецвыпуск Xakep, номер #020, стр. 020-060-4

Как видишь, не все производители видят телефон будущего начиненным скоростным процом и большой памятью, с цветным экраном, чувствительным к нажатию, и голосовым управлением. Многие просто парятся с дизайном и выдают слегка подзабытое и надоевшее старое за ультрамодное и сверхсовременное новое.


Спецвыпуск Xakep, номер #020, стр. 020-064-1, РЕСУРСЫ КРЕАТИФФЩИКА

РЕСУРСЫ КРЕАТИФФЩИКА

Спецвыпуск Xakep, номер #020, стр. 020-064-1

Donor (donor@real.xakep.ru)

Здорово, креатиффщик! Скажи мне, как на духу, возникает ведь и у тебя застой в твоем креативе, не идут идеи и не знаешь, как что-то реализовать. Это бывает, но это не повод склеивать ласты. Ведь Инет рядом. А еще бывает, что нужно очень быстро и лучше заюзать готовое, чем пыхтеть самому. В общем, сегодня мы пойдем по он-лайн ресурсам. И не надо кривиться. То, что клип-артами и библиотеками пользуется одно ламо, - гнусный стереотип. Кулые креатиффщики тоже часто лезут по ресурсам, но юзают они их посредством башки, а не спинного мозга. Используя сей полезный девайс по назначению, можно из избитого и затасканного по самое не горюй сварганить совершенно потрясную идею. Но в поисках идеи приходится лопатить столько мусора! Вот тебе обзор ресурсов, где можно нарыть стоящих вещей. Используй их с умом, и все будет тип-топ.

ФРИШНЫЕ КАРТИНКИ

http://www.clip-art.ru/

Название говорит само за себя. Действительно, клип-арт. Как и на обычном сидюке, сидишь и роешься по категориям, абсолютно не представляя, что скрывается за тем или иным названием и сколько этого самого там скрывается. Чтобы добраться до чего-нибудь стоящего, приходится продраться через древо, но стоящее попадается, поэтому гуд. Просто и по-деловому. Имеет право быть, а мы имеем полное право юзать это на халяву.

http://www.logotypes.ru/

Говорящее название. Твоему вниманию представляется туча логотипов известных и не очень фирм в формате Illustrator`а. Конечно, не каждый день они нужны, но иногда требуются. Вот и будут у тебя всегда под рукой. Правда, ползать по этому архиву приходится через одно место, потому что организовано все крайне неудобно. Ну да с каждым кликом мозоль все крепче.

http://www.vectro.narod.ru/

Не очень большой, но довольно качественный архив векторных картинок. Хотя наполнение категорий часто оставляет желать и еще раз желать, но их много, и это радует. Встречаются прикольные, необычные рисунки и персонажи, встречаются довольно детальные и красивые картинки. Еще тут можно поживиться, так сказать, "декором", а точнее - стрелочками, бордюрчиками, кнопочками, пыхтограммками, задниками и так далее. Главное то, что можно найти что-нибудь подходящее и незаюзанное и без лишней тягомотины беззастенчиво слить для личного пользования. Чем и предлагаю заняться.

http://fantasy.lacefairy.com/

Специальный фэнтезийный клип-арт, очень прикольный. Тут есть и анимированные изображения, и просто картинки, и персонажи, и аксессуары. Скажем, понадобился тебе дракон для твоей RPG на флэше - загляни сюда. И драконов тут много, и рыцарей, а выбор фей и русалок просто поражает :). Также в изобилии маги, черепа и скелеты, котлы, факелы и свечи. Итак, ностальгирующих по сказкам прошу пройти.

http://www.oldfashionedclipart.com/clip.htm

Веселое местечко. Хотя "Старомодный клип-арт" тоже может быть полезен. Вдруг надо оформить что-то в антикварном стиле. Тогда плывем прямо сюда. Здесь берем дамочек в смешной неудобной одежде, сажаем их в старинные драндулеты или вообще на коня, захватываем с собой старую мебель и особняки позапрошлого века и идем творить. Кстати, категорий довольно много, картинок в них тоже немало. Все картинки черно-белые. Правда, годятся только для веба, так как немного мелковаты.


Спецвыпуск Xakep, номер #020, стр. 020-064-2, РЕСУРСЫ КРЕАТИФФЩИКА

РЕСУРСЫ КРЕАТИФФЩИКА

Спецвыпуск Xakep, номер #020, стр. 020-064-2

http://www.rebelartist.com/

Это большущий такой портал, где гнездятся буржуйские художники в надежде чего-нибудь продать. Здесь есть и фотографии (например, хмурых рыбок), и прикольные шрифты, но, поскольку за все хотят денег и фотографии изгаживают так называемыми водяными знаками, а шрифты просто жилят, то доступными остаются только векторные картинки. Убрать из них водяные знаки - раз плюнуть, а потому наше дело - левое. Около сотни художников, у каждого несколько десятков итемов - есть из чего выбрать. Выбираем, ползая по категориям. Чтобы переместиться между художниками, нужно юзать artist search. Вот так все сложно.

http://www.art-builders.com/

Вообще-то, здесь нам пытаются втюхнуть картинки за бабло, но нет худа без добра. Видно, в рекламных целях имеются фришные ресурсы. И, надо сказать, выбор небеден: тут можно разжиться прикольными векторными картинками на разные темы, зашибенными текстурами в огромных количествах, красивыми и прикольными обоями, а также небольшим количеством кнопочек и иконок. В общем, хоть буржуи жадные, но и они халяву дают.

http://www.clipart.com/

Это такой классический буржуйский портал, который бесит неимоверно, потому что, пока откопаешь что-нибудь стоящее, тебя наглухо закидают круговыми линками и поп-апами. И все было бы совсем хреново, если бы не два маленьких выпадающих списка, которые, как ни странно, помогают довольно быстро найти что-то нужное. Картинки черно-белые, так что раскрашивай по своему усмотрению. Также порадовало наличие фришных шрифтов, доступных для немедленного скачивания. Копайся и докопаешься.

http://www.barrysclipart.com/

Тут очень много клип-артов, еще больше ссылок. Заблудиться - раз плюнуть. Тематика, в основном, американская: американские праздники, американская символика, американские презики (президенты, в смысле). Основную часть архива составляют анимированные и неанимированные гифы разной степени паршивости. Мультяшные и немультяшные изображения валяются вперемешку. Обнаружилось немного фотографий (животные, природа, здания) среднего качества (кило по 300-500 каждая). Есть небольшой наборчик шрифтов. В общем, все, как у всех, за исключением огромной кучи ссылок, которые очень удобно разложены по категориям.

http://emilyh.tripod.com/

Ну, "Галактика изображений" - это они, конечно, загнули, но поживиться, действительно, есть чем. Тут наберется около сотни очень симпатичных трехмерных и плоских бэкграундов. Есть как небольшие по весу (для веба), так и очень большие сюрреалистичные, космические, мистические, всех цветов и оттенков (явно не для веба). Ну, как обои потянут. Хотя, если ты каким-нибудь боком связан с полиграфией, например, рекламные брошюрки шлепаешь, то может очень пригодиться.

http://www.nasa.gov/gallery/photo/index.html

Ну, где же еще можно нарыть такое количество реальных космических фоток, как не у наших любимых американских друзей из NASA! Ты только посмотри! Тут тебе и съемки звездного неба различными обсерваториями, и съемки земной поверхности из космоса, фотографии разных планет солнечной системы с искусственных спутников и фотки различных шаттлов и ракет, взлетающих с космодрома и уже тусующихся в космосе, и потешные космонавтики, ковыряющие чего-то там на орбите. В общем, если чего-то надо оформить в космической тематике, дуй сюда, и недостатка в материале не будет.


Спецвыпуск Xakep, номер #020, стр. 020-064-3, РЕСУРСЫ КРЕАТИФФЩИКА

РЕСУРСЫ КРЕАТИФФЩИКА

Спецвыпуск Xakep, номер #020, стр. 020-064-3

НЕМНОГО 3D

http://www.fontsnthings.com/

На этом сайте некто Chris выложил небольшую коллекцию трехмерных надписей и фишечек, которые он, не напрягаясь, замутил в Xara3D. Естественно, можно на халяву слить готовое, но больше всего радует то, что Chris дает тут же небольшой урок, как замутить подобную крутость, но свою. Для этого почитай наставления дядьки и скачай исходники. Вот это по-нашему - сразу исходники на бочку :)! Так что если захотел какой-нибудь рельефный дизайн в египетском стиле или под майя, дуй сюда.

http://www.render.ru

Рендер.ру - это просто-таки легендарный сайт. Здесь можно найти по 3D графике почти все и очень полные и интересные уроки, и литературу, и статьи, и форум. Также здесь можно почитать некоммерческую газету "реАнимация", посвященную 3D графике. Но нас больше всего интересует галерея трехмерных работ. Арт тут отборный, потому что его отбирают :). В галерею нельзя просто взять и добавить свое творение - сперва его просмотрят хозяева сайта. Представлены иллюстрации совершенно на разные темы (от фэнтэзи до фантастики и сюрреала), поэтому просто смотри и выбирай. Выбор есть, потому что арта здесь много.

http://avalon.viewpoint.com/

Для тех, кто интересуется созданием трехмерных моделек и графики, наши буржуйские братья меньшие приготовили вот такой ресурс. Тут лежит просто куча разных трехмерных объектов для 3Dstudio. Тут обнаружилась куча моделей самолетов и вертолетов, военной техники, реальных и выдуманных животных и даже герои и объекты из "Звездных войн" и "Стар трека". Также можно разжиться текстурами огня, кожи, камня, металла, неба, моря и земли. Так что грузи, верти, натягивай и рендери.

ДЛЯ ФЛЭШЕРОВ

http://flasher.ru/sources/

Потрясающее место для начинающих и продолжающих флэшеров. Здесь тусуются довольно сильные и коммерчески успешные флэшеры, которым по приколу выложить исходники некоторых своих работ и ответить на вопросы новичков. Тут ты найдешь игры, прикольные эффекты, серьезные элементы флэш-сайта (менюшки, кнопки, окна), примеры работы с псевдотрехмером, и все это с исходниками. Также здесь есть уроки для самых маленьких и форум, в котором можно встретить челов, выпустивших не одну книгу по флэшу на российский рынок. Унджой!

http://www.flashkit.com/

О! Это один из лучших ресурсов для флэшера. Очень большой сайт: количество итемов в разделах часто переваливает за тысячу. Огромная галерея фотоизображений, графики и бэкграундов. Немерено исходников с образцами красивых эффектов, экшен скрипта, псевдотрехмера. Выложены готовые мультфильмы, которые беззастенчиво можно заюзать на благо своей паги. Просто до фига звуковых эффектов (это всякие щелчки, писки, звонки, визги, звуки мотора реактивного самолета, удары грома, биение сердца и прочие короткие звуки) и лупов (это когда взяли фрагмент музыкальной композиции и обрезали так, чтобы конец легко перетекал в начало; если зациклить, то музыка будет играть непрерывно). Конечно, и без минусов не обошлось. Из-за размеров на этой паге запросто можно заблудиться. Кроме того, этот сервак иногда просто зверски тормозит. Но искусство требует, а потому юзать!


Спецвыпуск Xakep, номер #020, стр. 020-064-4, РЕСУРСЫ КРЕАТИФФЩИКА

РЕСУРСЫ КРЕАТИФФЩИКА

Спецвыпуск Xakep, номер #020, стр. 020-064-4

http://www.movies.dtn.ru/

Если тебе по каким-то причинам не хватило предыдущих ресурсов, то ползи сюда. Арена мувиков - это постоянно пополняющийся архив флэш-исходников. Качаешь исходники, разбираешься, делаешь что-то свое. Есть исходники, показывающие псевдотрехмерные эффекты, примеры меню, управления сайтом из мувика, примеры работы со звуком, примеры интерактивности, заставки и прелоадеры. Навигация удобная - не заблудишься.

http://www.flashheaven.de/englisch.htm

Неплохой ресурс для флэшера. Тут есть уроки и форум, но только для тех, кто шпарит по-датски. Есть такие? Зато можно разжиться исходниками, шрифтами, звуками для кнопок, звуковыми эффектами и музычкой. Есть весьма неплохие ссылки, разложенные по категориям.

АНИМАШКИ ДЛЯ МАШКИ

http://www.animationfactory.com/

Веселенький такой сайтец, где можно разжиться несерьезными такими трехмерными анимационными гифами. Они на этом специализируются. Много категорий, много подкатегорий. В каждой один-два итема, но в целом наберется несколько десятков. Попадаются даже полезные экземпляры. Например, для странички в техногенном стиле вполне подойдут местные роботы, а фэнов FreeBSD может порадовать симпотный чертик. Остальное, а именно: полную коллекцию и софт для создания подобной чуши - за бабки. В общем, если подойти с умом, не такой уж этот ресурс и отвратный :).

http://www.free-graphics.com/

Free-graphics представляет собой стандартный, довольно полный и довольно заюзанный архив всевозможной графики. Тут валяются анимационные гифы (трехмерные и плоские). Выглядят мультяшно, серьезному дизайну идут, как корове седло, но иногда могут пригодиться. Также есть наборчик стандартных бэкграундов (море, небо, земля и так далее). В изобилии всяких стрелочек и кнопочек, а для совсем уж лентяев сделали так называемые Design Sets - это наборы уже готовых кнопок меню, задников, бордюрчиков и прочего, выдержанных в одном стиле (если можно так выразиться) и цвете. Если нужно забацать что-то быстро и положить на качество, то это то, что надо. Также есть небольшой наборчик шрифтов. В общем, стандартно, но может пригодиться.

http://www.newcreations.net/3d/

Еще одна копилка для лентяев. Тут собраны всякие анимированные 3D фишечки и рюшечки для сайтов американских ламерикосов. Снежинки, звездочки, прыгающие нотки, надписи "Look Here!", "E-mail me!", "New hot stuff", "Fuck... ой, нет не то :). Ну и прочая чушь. Этот ресурс может оказаться полезным, если ты вдруг с перепоя срочно решил украсить свою пагу к Новому году или пометить обновления, но пока еще что-то крутое забабахать не успел. Пусть живет.


Спецвыпуск Xakep, номер #020, стр. 020-064-5, РЕСУРСЫ КРЕАТИФФЩИКА

РЕСУРСЫ КРЕАТИФФЩИКА

Спецвыпуск Xakep, номер #020, стр. 020-064-5

ШРИФТЫ ДЛЯ ПРОДВИНУТЫХ

http://www.coolfonts.de/index/

Неплохой датский сайтец с разными шрифтами. Дизигн приятный, менюха удобная. Шрифтов просто до фига - есть из чего выбрать. Опять же предлагают активно юзать их шрифты вместе с Xara3D для большего эффекта. Очень радует наличие шрифтов, сделанных в стиле разных известных лейбаков. Жаль только, что они все латинские и кириллицу не предусматривают. Но если интересно, можешь прогуляться по ссылкам в разделе Font Tools, загрузить соответствующие проги и исправить этот недостаток ручками. На то ты и креатиффщик.

http://www.pcfonts.com/

Рейтинг из того же кольца, что и clipart.com. Та же табличка, те же звездочки рейтинга, те же смайлики "без поп-апов". Некоторые ссылки ничего себе, некоторые - так себе. Тоже есть выпадающие менюшки с быстрым доступом к фришным шрифтам и графике. Есть прикольные экземпляры (особенно весело смотрится латиница в виде арабской вязи :)), но проблема та же: кириллица не предусмотрена.

http://www.1001freefonts.com/

Близнец-брат coolfonts'а по оформлению и очень похож по содержанию. Однако можно найти новые шрифты, которые тоже очень прикольные. Также можно скачать софтины для работы со шрифтами, тоже предлагают юзать Xara3D, но здесь еще и предлагают туториалы по клепанию своих шрифтов, но на фиглише. Также могут факнуть и хелпнуть. Основная проблема та же: о кириллице ведать не ведают.

http://webassist.big.ru/fonts_overview.html

Наш сервачок, только почему-то все на фиглише. Не патриоты эти челы! Но не в этом суть. Тут валяется больше восьмисот "регулярных" шрифтов и более ста "специальных". Специальные шрифты прикалывают особо. Это символьные шрифты на разные темы, например, на тему Бэтмена или бабочек, или индейцев. Шлепаем по клавише и получаем замысловатую картинку. Красота! Можно в курсачи и объяснительные записки кошечек, птичек и девочек втыкать :). Для веб-строительства тоже удобно - мелкие элементики можно прямо пачками грузить. Кириллица, правда, тоже есть не везде. Пользуйся!

СКРИПТЫ

http://www.dynamic-design.com.ua/develop/script/

Для приверженцев ява-скриптов добрые братья-славяне создали халявный раздел примеров на этом древнем языке. Если тебе срочно понадобилось замутить что-то на ява-скрипте, дуй сюда, качай примеры и разбирайся. Тебе помогут замутить меню и навигацию, эффекты с изображениями и текстом, замутки с часами, разобраться с дебильной прокруткой и произвести еще много издевательств над твоей бродилкой. Также помогут разобраться с CSS. Так что пользуйся, пока они добрые :).

http://www.scriptik.ru/

Любителям Perl и PHP посвящается... небольшой такой сайтик с милым названием "Скриптик.ру". Здесь валяются примеры счетчиков, гостевых книг, скриптов для обновления новостей и контента сайта, скриптов для публикации новых материалов и так далее. Качай, изучай, но не забывай, что в чужих скриптах может быть куча багов и дырок. Не забудь проверить на баги, прежде чем вываливать на свою пагу.


Спецвыпуск Xakep, номер #020, стр. 020-064-6, РЕСУРСЫ КРЕАТИФФЩИКА

РЕСУРСЫ КРЕАТИФФЩИКА

Спецвыпуск Xakep, номер #020, стр. 020-064-6

ЗВУКИ НЕ ДЛЯ СКУКИ

http://www.wav.ru/

Если ты решил замутить себе музон самостоятельно, то тебе прямая дорога на wav.ru. Здесь просто офигенное количество звуков, эффектов, сэмплов, фраз из кино и прочего барахла. Я, естественно, сразу ломанулся по мультфильмам. О! Все здесь: и Винни-Пух, и Карлсон, и "Падал прошлогодний снег" ("Нисиво не понимаю!"), и Маугли. В сэмплах тусуются джаз, техно, мелодии народов мира, ударные. В звуках тоже было много интересного, например, эротические звуки и слова (???), звуки из ужастиков и рекламы. Очень полезный ресурс. Качать тебе, не перекачать :).

http://www.vaultfx.boom.ru/

Честный архив звуков, эффектов и лупов какого-то мэна, который не очень любит русский язык :). Если поверить, что в каждом архиве - пятьдесят звуков, то в общей сложности получается около ста. Неплохо! Снизу грузится "небольшой" флэш-ролик на полмегабайта, где можно прослушать и выбрать лупы. Лупы такие все боевые :). Их ровно 33 штуки. В общем, за неимением лучшего - самое то.

http://www.beavis-butthead.ru/bsounds.html

Ну, как же можно обойти стороной звуки из "Бивиса и Бат-Хеда"? Это же рулез форевный! Звуки выложены голимо (просто несколько мегабайтных архивчиков почти без комментариев), но оно того стоит. После выкачивания ты окажешься обладателем всех "тупых ослов", "задниц", "отвали, Бивис" и "Великих Корнхулио" разом. Также очень порадовали звуки Бивиса и Бат-Хеда, играющих в Quake. А еще тебе дадут бессмертную тему из любимого сериала, ну и картинки можешь покачать. Наслаждайся, задница ;)!

http://www.webplaces.com/html/sounds.htm

Небольшой и неказистый, на первый взгляд, ресурс, но здесь можно разжиться неплохими звуковыми эффектами и звуками. Тут тебе и голоса природы, крики животных, голоса людей, тут тебе и шумы в ванной и кухне, и рокот машин и электрических инструментов, взрывы и выстрелы, звон стекла и хлопанье дверей. Попадаются звуки из кинофильмов и музыкальные темы из известных сериалов. Не так уж и много звуков, зато они часто используются.

http://www.moviesounds.com/

На этом сайте собрано n-ное количество звуков из разных известных фильмов и блок-бастеров. В списке засветились: "Властелин колец", "Звездные войны Эпизод I", "Матрица", "Люди в черном", "Без лица", "Робокоп" и так далее. Щелкаем на ссылочку и, переждав рекламу и прочую пургу, получаем долгожданные wav'ы и mp3'шки. Можем юзать на свое усмотрение. Размеры файлов разные: от сорока килобайт до мегабайта. Выдирают обычно наиболее запоминающиеся фразы. Согласись, весело приветствовать визитера словами: "As long as The Matrix exists, the human race will never be free."

POWER OFF

Вот, загрузил я тебя некоторым количеством фришных ресурсов, но учитывай, что нельзя злоупотреблять готовыми картинками, звуками, эффектами и другими кусками, иначе окажется, что твое творение - сплошной передер. Ресурсы валяются вокруг тебя. Сфоткай ржавую железку во дворе, запиши утробное урчание своей сестренки, приложи немного креатиффа, и это сможет стать крутым дизайнерским решением. Твори, мэн, креатиффь!


Спецвыпуск Xakep, номер #020, стр. 020-072-1, КРЕАТИВИМ КОМПЬЮТЕРНЫЕ ИГРЫ

КРЕАТИВИМ КОМПЬЮТЕРНЫЕ ИГРЫ

Спецвыпуск Xakep, номер #020, стр. 020-072-1

DarkBasic – мастерская игрушек

Vadias (painter@gameland.ru)

Плох тот компьютерный креативщик, который ни разу в жизни не мечтал создать свою игру, свой собственный мир, где все бы двигалось и взаимодействовало по его правилам, подчинялось его законам, в том числе и физическим; и чтобы не он один, а все геймеры планеты играли в нее, хвалили графику, преклонялись перед сюжетом и покупали лицензионные копии. С годами многие мечты исчезают, и некоторые действительно талантливые люди сходят с дистанции, узнав, сколько всего нужно изучить для создания компьютерной игры - а знать действительно нужно немало. Основная проблема состоит в том, что придумывать сюжет - дело скорее для людей с гуманитарным складом ума, в то время как его реализация - задача смекалистого технаря. Если какой-никакой сюжет могут придумать многие (но лучше им этого не делать - хреновых игр и так хватает :( ), то найти хорошего спеца-программиста довольно сложно. Неужели все кончено, и чудесные замыслы так и останутся известными лишь самим их криэйторам? Не торопись с выводами. Итак, барабаны отбивают мелкую дробь... и на арену выходит DarkBasic!

О ТОМ, КАК ДЕЛАЮТ ИГРЫ

Бэйсик, ввиду его максимальной простоты среди языков программирования, изучается в школе. В то время я, еще совсем юнец, грешным делом думал, что это единственный язык для создания программ. Как известно, у школьных учителей лучше всего получается отбивать у учеников интерес к своему предмету: уроки информатики сделали свое черное дело и со мной - охота программировать пропала начисто, о чем я не раз позже жалел.

История "просто бэйсика" берет свое начало с 1963 года, когда некий чокнутый профессор Дж.Кемени :) и его штуденты взялись за разработку простого языка для начинающих программеров. С тех пор его (язык) били, пинали, незаслуженно обзывали, но он выжил и стал очень популярным в самых разных ипостасях, приобрел немало "диалектов" и применяется в большинстве сфер программных технологий. Герой сегодняшнего рассказа также основан на бэйсике.

Сразу развею заблуждение многих, слышавших о DarkBasic и считающих, что это - игровой WYSIWYG, где мышкой перетаскиваются объекты, щелкается пара кнопок, и игра готова к употреблению. Нет, это было бы СЛИШКОМ просто, я бы даже сказал - подозрительно просто. Правда, такая программа также существует, называется она "Конструктор 3D игр", но мыслящие люди понимают, что такой способ сильно ограничивает творческую свободу, и что-либо серьезное им вряд ли сделаешь. DarkBasic, в отличие от "Конструктора" - это среда программирования, всего лишь конечный инструмент формирования игрового продукта.

Попробуем предположить, как создается приличная компьютерная игра от начала и до конца. Для начала не помешало бы определиться с жанром, коих немало - разного рода стратегии, квесты, 3D-шутеры, РПГ или что-нибудь еще. Затем пишется легенда, сюжет - их можно брать из книг, фильмов, реальных событий либо из собственной головы. Составляется описание задействованных персонажей, ландшафтов, интерьера, по которым художники, дизайнеры, трехмерщики создают бэкграунды и модели. Прямо в файлы трехмерных сцен вписываются скрипты характерных движений персонажей (повторяющиеся движения - ходьба, бег, стрельба, прыжок), колыхания деревьев и прочие декоративные движения. Нехилое значение имеет фоновая музыка и звучки, подобрать которые ох как непросто (в этой связи можно привести в пример рассказ создателей игры "Bestiary", которые для правдоподобной записи звука в intro полкилометра бежали с микрофоном за летящей по ветру газетой). Только потом в дело вступают программисты, реализующие правильное развитие хода игры, реакцию объектов на события и их взаимодействие. Различных нюансов здесь целое море, и я боюсь даже предположить, с какими трудностями приходится сталкиваться на этом этапе. В общем, создание игры - дело чрезвычайно серьезное, но, по признаниям разработчиков, овчинка стоит выделки. Во многих интервью известных игровых программистов они рассказывают о том, как затягивает креативный процесс, и что все участники забывают о таком понятии, как восьмичасовой рабочий день и сидят до самого утра за компом на кока-кольной диете, сочиняя оригинальные алгоритмы, составляя программные конструкции и отлаживая код. А потом с красными, но азартными глазами любуются цифровым зрелищем, и это чувство, сходное зрелищу рождения сына, трудно передать - его нужно пережить самому.


Спецвыпуск Xakep, номер #020, стр. 020-072-2, КРЕАТИВИМ КОМПЬЮТЕРНЫЕ ИГРЫ

КРЕАТИВИМ КОМПЬЮТЕРНЫЕ ИГРЫ

Спецвыпуск Xakep, номер #020, стр. 020-072-2

Куда более подробно и профессионально процесс создания игр описан в книге Марка Зальцмана "Компьютерные игры: как это делается". Тому, кто хочет заниматься играми, без этой книги просто не обойтись. В ней собран опыт самых матерых разработчиков мирового уровня, и затронуты практически все аспекты (художественные, технические, коммерческие) рассматриваемой темы. В конце концов, книга просто интересна, и, возможно, станет лучшим источником вдохновения и руководством к действию.

Как раз на этом самом увлекательном этапе DarkBasic может существенно облегчить жизнь опытным бойцам программинга, а для начинающих сделать возможным воплощение в жизнь своего первого проекта - именно для этого он и создавался английской компанией DarkBasic Software Ltd. Ее целью было сделать такую среду программирования, которая была бы одновременно простой и достаточно мощной, то есть удовлетворять спецов самого разного уровня. Основанный на старом добром бэйсике, DarkBasic в настоящее время поддерживает более 650 команд и использует возможности DirectX, без чего не мыслится большинство современных геймов. У DirectX несколько составляющих: DirectDraw - ускорение отображения двумерной графики, Direct3D - трехмерной, DirectSound - работа со звуком, и несколько других. DirectX - это специальная фича, придуманная почти специально для игрушек под Виндоуз, а Direct3D не даст видеоускорителям пылиться без дела :).

Настало время перейти к обследованию пациента ДаркБэйсика.

ДРУЖЕЛЮБНЫЙ ИНТЕРФЕЙС

Интерфейс программы, как говорится, дружественный, а это значит, что он повернут к пользователю лицом, а не задом. Никаких лишних наворотов и кнопочек, годящихся только на то, чтобы сбить чела с толку - только черное окно и белые буковки, как в старые добрые времена. Говорят, так было сделано, чтобы польстить старикам игровой индустрии, для которых монитор CGA в их боевые годы был невиданной роскошью, а про 3D-ускорители можно было почитать только в научно-фантастических книжках. Собственный редактор ДаркБэйсика работает в полноэкранном режиме с разрешением 640X480. Для современной молодежи, избалованной дедом Мастдаем aka Windows и привыкшей к космическим разрешениям, существует бесплатный альтернативный редактор DarkEdit, входящий в лицензионную копию DB, а его свежую версию всегда можно скачать с сайта http://darkedit.nmisoftware.com.


Спецвыпуск Xakep, номер #020, стр. 020-072-3, КРЕАТИВИМ КОМПЬЮТЕРНЫЕ ИГРЫ

КРЕАТИВИМ КОМПЬЮТЕРНЫЕ ИГРЫ

Спецвыпуск Xakep, номер #020, стр. 020-072-3

Сам по себе данный редактор работает только с исходниками, он не интерпретирует, не компилирует код и не делает exe-шников; однако если ДБ установлен на компе, эти функции становятся доступными. DarkEdit позволяет обойти некоторые ограничения ДБ: например, работа с большим, чем два, количеством проектов одновременно.

Те, кто видел прогу ДаркБэйсик в действии, наверняка заметил кнопочку CLI в правом верхнем углу, запускающую командную строку (Command Line Interface). Эту штуку на одном из английских сайтов по ДБ называют "новым оружием в битве за мир программирования". Дело в том, что для создания программы пишется последовательность команд, ее составляющих, и запустить можно только программу целиком. Таким образом, если где-то ступор, то найти неполадку иногда бывает довольно сложно. CLI позволяет обойти эту траблу: команда записывается в командной строке и тут же запускается. Результат - налицо ;). В командной строке реально написать даже простенькую игрульку (типа Quake 3 :)).

УСКОРЕННАЯ ПОМОЩЬ

Встроенная система помощи - это целая песня. Единственное, чего она не позволяет делать - это заниматься с ней любовью :). Но со своей основной задачей она справляется весьма успешно, более подробного описания я еще не видел. Поскольку прога изначально задумывалась для полных чайников, здесь есть и объяснение основных принципов программирования, и глоссарий игровых программных терминов, и описание всех операторов, а также добротная библиотека уроков, каждый из которых содержит примеры кода. Сама помощь организована так, что в любое время от чтения можно перейти к проверке полученных знаний одним кликом мыши.

Заметь, в поставку ДБ входит и бумажная книжка в 244 страницы, это отдельное пособие с дополнительной и весьма полезной инфой и подробным руководством по созданию 3D игр. Скажем, объясняется алгоритм и приводится участок кода игры от третьего лица - как и в каком положении зафиксировать камеру, как обнаруживать столкновения объектов, накладывать текстуры и т.д. и т.п. Следует отдать должное ребятам из "МедиаХауз", добросовестно переводившим весь этот объемный текстовый материал. В будущем они обещают выпускать специальные руководства и выкладывать на сайте www.darkbasic.ru.

На втором диске ДБ есть набор архиполезных утилит для подготовки составляющих игры:


Спецвыпуск Xakep, номер #020, стр. 020-072-4, КРЕАТИВИМ КОМПЬЮТЕРНЫЕ ИГРЫ

КРЕАТИВИМ КОМПЬЮТЕРНЫЕ ИГРЫ

Спецвыпуск Xakep, номер #020, стр. 020-072-4

3D Explorer - используется для просмотра 2D- и 3D-объектов;

3D Canvas - используется для редактирования 3D-объектов;

ACDSee - популярная программа для просмотра графических файлов;

Cdex - конвертор аудио-файлов;

Cool Edit 2000 - редактор аудио-файлов;

Doga - редактор объектов;

Evolution Sound Studio - редактор музыкальных файлов;

Music Master Works - редактор музыкальных файлов;

Paint Shop Pro 7 - редактор 2D растровых изображений;

... и пара архиваторов в нагрузку :).

ТЕМНАЯ СИЛА ДАРКБЭЙСИКА

Думаю, тебе небезынтересно узнать о реальных возможностях ДаркБэйсика. Возможности практически неограниченны - важно только знать, чего хочешь, и примерно представлять алгоритм работы того или иного действия. Другой вопрос, сколько придется пыхтеть над воплощением. Но для примера я хотел бы привести небольшой код, который создает и вращает куб в трехмерном пространстве по осям X и Y (этот код был на официальном сайте ДБ - www.darkbasic.com):

make object cube 1,100

for x=1 to 360

rotate object 1,x,x,0

next x

Что мы видим? Первая строка создает куб (в ДБ есть встроенные примитивы). Вторая начинает цикл, X стартует со значением 1 и будет увеличиваться с шагом 1 до 360. Третья строка поворачивает объект куб на один градус одновременно по оси X и Y. Последняя строка увеличивает значение X на один и отсылает ко второй, и вращение продолжается. Четыре строчки - а сколько радости :).

Как я уже говорил, ДБ позволяет пользоваться дарами DirectX, не вдаваясь в его детальное изучение, с помощью набора простых команд. Язык поддерживает любой графический режим, но не устаревший восьмибитовый (как объяснили разработчики, для начинающих это не дало бы ничего, кроме острого геморроя). С импортом графических форматов также все в порядке - загружаются файлы формата BMP, RLE, DIB, DDS, JPG, PCX, PNG, PSD, TGA, TIFF, есть возможность применить целый ряд эффектов: зеркальное отображение (Mirror), растяжение (Stretch), размывание (Blur) и затухание (Fade ), и такой важный эффект, как прозрачность.

Особое внимание уделено трехмерной графике. Ниже ты видишь впечатляющие 3D свойства ДБ:

Поддержка 3DS и XOF файлов

Ландшафтные преобразования

Встроенные 3D-примитивы

Динамическая модель вселенной

Проверка на корректность взаимодействия полигональных объектов

Преобразования моделей

Анимация моделей

Фильтрация текстур

Поддержка альфа-канала

Реальное взаимодействие с объектами.

Модели 3D Макса загружаются в ДаркБэйсик прямо с анимацией. Необходимость этой фичи можно показать на простом примере: если нужно реалистично изобразить персонаж, идущий по плоскости, нужно выполнить два условия: заставить его передвигать ноги и перемещать в пространстве. И если второе реализуется без проблем, то первое сделать средствами ДаркБэйсика - настоящий ад. Каждая программа должна выполнять свои четко обозначенные функции, а сложная анимация в обязанности ДБ не входит ;).

Большие сцены, такие как ландшафт местности, также можно готовить в каком-либо 3D редакторе, но можно обойтись и собственными средствами. Иногда это даже необходимо - в случае, когда требуется случайный ландшафт. Для этого создается объект матрица - она создает эффект бесконечности. Затем на нее накладывается текстура и устанавливаются объекты.


Спецвыпуск Xakep, номер #020, стр. 020-072-5, КРЕАТИВИМ КОМПЬЮТЕРНЫЕ ИГРЫ

КРЕАТИВИМ КОМПЬЮТЕРНЫЕ ИГРЫ

Спецвыпуск Xakep, номер #020, стр. 020-072-5

Чего в ДБ не было до недавнего времени - это возможности создавать многопользовательские игры. Но с появлением компакт-диска DarkMatter, содержащего апгрейд под названием DarkBASIC Enhancement Pack, эта проблема решена.

ДОБРО ПОЖАЛОВАТЬ В ОРГАНЫ, СЫНОК

Итак, ты реально оценил то, на что способен DB с твоей помощью (или ты с его :)). Самое главное - победить леность мозгов и добиваться того, о чем мечтал. Тогда то и придет то самое чувство рождения цифрового детища, о котором я писал в начале этой статьи. Знай, что ты не один, и если ты вдруг столкнулся со сложностями, просто напиши по нужному адресу, который указан на www.darkbasic.ru либо выскажись в форуме - и тебе обязательно помогут.

Интернет-ресурсов, посвященных ДБ, в настоящее время достаточно много, и думаю, скоро станет еще больше. Правда, большинство из них англоязычные (я не устану повторять - учи английский, и жизнь станет легче :)). Из сайтов отечественного производства могу назвать непосредственно родной сервер программы и www.darkbasic.narod.ru, поддерживаемый одним сообразительным парнем.

Если заглянешь на www.darkbasic.ru, наверняка обратишь внимание на сообщения о конкурсе на лучшую игру, созданную с помощью ДБ. Суть его такова: создать один полностью работающий уровень игры любого жанра и послать в любом виде в компанию "МедиаХауз". Победители получат неплохие компьютерные железяки, а главный приз... Мне кажется, тебе было бы интересно пообщаться с разработчиками "Макса Пэйна" ;)?


Спецвыпуск Xakep, номер #020, стр. 020-076-1, TIPS OF WEB

TIPS OF WEB

Спецвыпуск Xakep, номер #020, стр. 020-076-1

Vadias (painter@gameland.ru)

Вот мы и снова встретились, брат веб-дизигнер. Надеюсь, очередная порция веб-типсов сделает твой сайт более модернизированным и подготовленным. Сегодня ты немало услышишь о ссылках и их природе, о простых приемах, облегчающих жизнь и верстку страниц, о королях и капусте, и о кое-чем еще, что по сценарию должно тебе понравиться :).

Tipsa 1. Если ты делишь свою страницу на несколько колонок, помни о том, что красота и гармония напрямую зависят от соотношения высоты и ширины этих колонок. Рекомендуются простые пропорции, такие, как 1:2 и 1:3. Особо приветствуется древнее изобретение - золотое сечение (это пропорция примерно 1:0,618), которое считается наиболее законченным и правильным.

Tipsa 2. Чтобы колонки достаточно четко можно было разделить визуально, есть несколько способов: поставить между ними вертикальную линию, оставить между ними большое расстояние, выделить разные колонки разными цветами (при табличной верстке просто задается цвет ячейки).

Tipsa 3. Если страница представляет собой или содержит большой текстовый блок, следует сделать немалые отступы, чтобы его было удобно читать. Для этого можно либо заключить текст в теги <blockquote>text</blockquote>, либо указать отступы в дескрипторе BODY. Это делается так: <BODY leftmargin=100 rightmargin=100>, где leftmargin - отступ слева, а rightmargin, соответственно, справа.

Tipsa 4. Слабый контраст фона и текста сильно усложняет чтение, особенно это касается больших объемов текста.

Tipsa 5. Невредно проверять код своих страниц на HTML-валидаторах. Валидаторы входят в такие программы, как Dreamweaver, HomeSite и им подобные, но можно проверить код и в он-лайновых службах проверки (например, validator.w3.org или netmechanic.com).

Tipsa 6. Ты, наверное, встречал такой "феномен", как ссылки внутри одной страницы, когда товарищ браузер сам прокручивает пагу на нужно место. Чтобы сделать такую штучку, требуемый объект (слово, абзац или пикча), на который будем ссылаться, заключается в теги <a></a> с атрибутом "name" таким образом: <a name="x">объект в середине страницы</a>. В свою очередь, сама ссылка (если документ тот же самый) делается так: <a href=#x>ссылка в середину паги</a>. Если же ссылка в другом документе, то так: <a href=xxx.htm#x>ссылка в середину другой паги</a>.

Tipsa 7. Службы бесплатного хостинга не дают, как правило, возможности хранить на сервере файлы с такими замечательными расширениями, как .rar, .zip, .exe и другими. На народе.ру, например, такие файлосы удаляются мгновенно после закачки. Эту хитроумную систему можно обойти, изменив расширение на какое-нибудь .tmp, письменно предупредив, конечно, об этом пользователей.

Tipsa 8. Не выставляй в меню ссылок на неработающие разделы, лучше сначала доделай их. Ты можешь писать о том, что собираешься сделать, завлекая заинтересованных юзверей на будущее, но не стоит наламывать их и подрывать доверие к себе, подсовывая недействующие кнопочки.

Tipsa 9. Если ты изменил страницу, у некоторых юзверей в кэше может остаться старая версия страницы, и будет грузиться именно она. Чтобы предотвратить эту несправедливость, надо установить время устаревания страницы с помощью атрибута "expires" в дескрипторе META: <META http-equiv="expires" content="0">. В этом случае страница считается устаревшей сразу после получения клиентом.


Спецвыпуск Xakep, номер #020, стр. 020-076-2, TIPS OF WEB

TIPS OF WEB

Спецвыпуск Xakep, номер #020, стр. 020-076-2

Tipsa 10. Наиболее эффективным методом раскрутки является обмен баннерами (или ссылками) с сайтами той же тематики. Процент случайных проходимцев уменьшается, по таким ссылкам идут только заинтересованные люди. Общение с коллегами также откроет для тебя не один секрет общего дела.

Tipsa 11. Если ты хранишь в Инете какую-то секретную инфу, ты можешь запретить индексирование страницы поисковыми роботами, и никакие яндексы тебя не найдут. Для этого нужно запихнуть на страницу такой метатег: <META name="robots" content="none">. Такая вот типса для скрытных нехороших людей :).

Tipsa 12. При создании списков можно устанавливать вид их буллетов - маркеров (bullets), выставляя в теге <OL> или <UL> (это, соответственно, упорядоченный и неупорядоченный списки) атрибут "type". Это делается так: <OL type="1 | a | A | i | I | disc | square | circle">, где 1 - арабские числа, a - строчные буквы, A - заглавные буквы, i - строчные римские числа, I - прописные римские числа, disc - круг, square - квадрат, а circle - окружность. Элементы списка (теги <LI>) будут наследовать этот атрибут, если ты прямо не укажешь в них другой вид маркера.

Tipsa 13. К ссылкам так же, как и к картинкам, можно делать всплывающие подсказки. Но, в отличие от изображений, такой атрибут здесь называется не alt, а title. Пример почтовой ссылки с всплывающей подсказкой: <a href=mailto:suslik@mail.ru title="черканите письмо для суслика">e-mail</a>.

Tipsa 14. При строительстве страницы с ссылками на паги или файлы чужого сервера слишком нудно указывать длинные абсолютные ссылки типа anotherserver.ru/pics/photo1.jpg, особенно если их много. Тогда на помощь приходит дескриптор <BASE>. Вписываешь в документ строку <BASE HREF="http://anotherserver.ru/pics/"> и далее указываешь относительные ссылки типа <a href="photo1.jpg">, <a href="photo2.jpg"> и так далее.

Tipsa 15. Делая табличный дизайн с достаточно большим количеством яичек... я хотел сказать - ячеек, удобно сначала набросать макет таблицы на бумаге. Сверху и снизу рисунка пишется соответственно <table> и </table>, в начале строчки - <tr>, в конце - </tr>, внутри каждой яички... тьфу ты! - ячейки - <td> и </td>. Все становится чертовски наглядным ;) - смотри рисунок.

Tipsa 16. Если ты хранишь на своем сайте файлосы для скачивания, то всегда указывай их размеры и тип файла - людям так спокойнее, знаешь ли :). Например, так: "Скачать полную версию игры "Адвенчур" - adv.zip (900 Мегабайт)".

Tipsa 17. Dreamweaver и аналогичные программы позволяют создавать для страниц сайта шаблоны (templates). Сие очень облегчает жизнь, так как многие элементы на сайте присутствуют на каждой странице - меню навигации, окно поиска и другие. Если задумаешь поменять эти элементы, то меняешь только шаблон, а все паги, созданные на его основе, видоизменятся сами по себе.


Спецвыпуск Xakep, номер #020, стр. 020-076-3, TIPS OF WEB

TIPS OF WEB

Спецвыпуск Xakep, номер #020, стр. 020-076-3

Tipsa 18. Когда файл HTML содержит огроменный объем текстовой информации (допустим, ты запихнул в Инет "Войну и мир" Толстого), не помешает периодически по длине документа понавтыкать маленькие кнопочки "Наверх", чтобы посетитель из середины или конца документа мог попасть к меню навигации одним щелчком крысы, не трогая скроллер. Как это делается, можно догадаться, еще раз посмотрев текст типсов выше (помнишь про внутренние ссылки) ;).

Tipsa 19. Если ты не хочешь, чтобы какой-нибудь подлец сделал так, что твоя страница загружалась бы во фрейме его страницы, впиши в документ такой метатег: <META http-equiv'"window-target" content="_top">. Браузер получает задание открыть страницу в главном фрейме, и враг в обломе.

Tipsa 20. Использование каскадных листов стилей дает гораздо больше контроля над текстом (можно указывать кегль, интерлиньяж, управление шрифтами в целом также улучшено). Кроме того, листы стилей неплохо автоматизируют создание веб-страниц - ведь можно создать всего один файл с описаниями различных стилей, а во все страницы просто вставить на него ссылку, что облегчит размер страниц и облегчит управление ими. В общем, юзай CSS, не прогадаешь.


Спецвыпуск Xakep, номер #020, стр. 020-078-1, ИНТЕРВЬЮ С ДИМОЙ АГАРУНОВЫМ

ИНТЕРВЬЮ С ДИМОЙ АГАРУНОВЫМ

Спецвыпуск Xakep, номер #020, стр. 020-078-1

«Хакер» или «Домашний ресторан»?

В этом году исполняется десять лет компании (game)land, компании, которая издает твои любимые журналы Х и Спец. По этому поводу мы решили взять интервью у Димы Агарунова - директора компании и, соответственно, нашего самого большого босса :) (большого во всех отношениях - см. фото ;)). Ты, приятель, часто жалуешься в своих письмах, что мы мало рассказываем о себе, что не даем тебе информацию о том, откуда появился журнал, куда движется и кто его делает. Просто мы не хотим занимать ценное место, где может быть полезная для тебя информация, и только в свой день варенья, да еще и в такой юбилей (десять лет!) мы можем позволить себе такую роскошь :). Читай и вникай - из первых уст ты узнаешь, как появился твой любимый журнал, как магазин игрушек превратился в издательство, а трансформеры-китайцы в журналы. Поехали!

Спец: Привет, Дима! Усаживайся поудобнее - мы начинаем.

Д: Привет. Давай.

Спец: Давай начнем с традиционного вопроса: с чего начиналось все это дело? Первым журналом издательства была «Страна игр». Как вообще появилась идея издавать журнал?

Д: «Страна игр» появилась, потому что в то время была необходимость в таком журнале. Не было журналов, которые бы четко рассказывали об играх, советовали, что стоит покупать, а что нет. Те люди в России, которые интересовались играми, просто не могли получить информацию на русском языке - Интернет тогда был развит слабо. То, как они приходили в наши магазины, спрашивали... то, что вопросы были одинаковыми, проблемы одинаковыми, и то, что мы видели, как количество людей, интересующихся играми, растет, дало нам понять, что очень нужен такой журнал. Чего на рынке, к сожалению, не было. Нет, конечно, игровые журналы были, но они были полезны не для людей, а скорее для себя.

Спец: Ты упомянул какой-то магазин...

Д: Да, к моменту создания журнала у нас было несколько розничных магазинов по продаже компьютерных и видеоигр. Этим мы и занимались. А журнал был просто дополнительным проектом.

Спец: И через сколько лет после выхода «Страны игр» появился следующий журнал издательства?

Д: Он появился через два года. Это был «Official Play Station».

Спец: Наверное, по тем же причинам - не было журнала, доступно рассказывающего о приставочных играх?

Д: Ну, там была немного другая ситуация, более естественная. Sony начинала сильно развиваться, возрастали продажи игр. Мы участвовали в процессе прихода компании Sony на российский рынок, и, естественно, одной из составляющих этого процесса был журнал «Play Station».

Спец: А к этому времени «Страна игр» - и издание журналов вообще - уже было приоритетным направлением в компании?

Д: Нет. Это был важный проект, но мы тогда не думали, что будем заниматься исключительно издательством. Тогда я понимал, что, возможно, найдутся люди, которые профессионально будут заниматься изданием журналов, и что наша деятельность это такая вот временная мера.

Спец: И какой был следующий журнал?

Д: Следующий журнал у нас вышел после кризиса - это как раз был журнал Хакер. Правда, мы запланировали его еще до кризиса. Тогда же мы планировали журнал под названием «Домашний ресторан», но оставить решили только Хакер.


Спецвыпуск Xakep, номер #020, стр. 020-078-2, ИНТЕРВЬЮ С ДИМОЙ АГАРУНОВЫМ

ИНТЕРВЬЮ С ДИМОЙ АГАРУНОВЫМ

Спецвыпуск Xakep, номер #020, стр. 020-078-2

Спец: А что должен был представлять собой «Домашний ресторан»?

Д: Ну, это журнал о вкусной и качественной еде, которую можно было бы приготовить в реальных российских условиях, дома (улыбается).

Спец: Кулинарный журнал?

Д: Да.

Спец: Супер! А как ты думаешь, если бы выпустили кулинарный журнал вместо Хакера, что могло бы произойти?

Д: Он не был бы вместо Хакера. Было бы и то, и другое.

Спец: Ок, а с появлением Хакера произошел какой-то рывок в жизни компании или все шло планомерно?

Д: Да, рывок произошел, потому что журнал моментально стал суперхитом. Это стало очень большим событием, которое привлекло к нашей компании внимание и компьютерного, и молодежного рынков. Мы стали более смелыми в понимании того, что на самом деле мы намного больше разбираемся и понимаем людей, чем большинство издателей в стране. Особенно на компьютерном и молодежном рынках. Мы поняли, что наш лозунг «Делать то, что никто не делает» - это как раз правильно, что он нам подходит.

Спец: То есть Хакер получился как такой гибрид компьютерного и молодежного журнала?

Д: Да, он изначально задумывался как компьютерный журнал для молодежи.

Спец: А как ты думаешь, нет ли сейчас большего уклона в сторону одного из этих направлений?

Д: Мне кажется, что концепция как раз четко сохраняется. Она нам нравится, мы ее считаем правильной.

Спец: Дим, а сам ты читаешь Хакер?

Д: Я читаю только юмор, потому что большинство статей не понимаю - они слишком сложны для меня в техническом плане.

Спец: Вернемся к хронологии. Какой следующий журнал?

Д: Следующим мы сделали «Мобильные компьютеры». Это было силовое решение. Я увидел, как здорово развиваются мобильные, что они уже готовятся к выходу в Интернет - мне показалось, что это будет бум. Но такого супербума не произошло - это было ошибочное представление. Бум произошел на Западе, но не у нас. Тем не менее журнал занял свое место. Сейчас мы проводим в нем оздоровительные мероприятия (улыбается). Я считаю, что он будет важным и нужным, но, может быть, чуть позже - именно на волне бума мобильных компьютеров.

Спец: Вот ты упомянул Запад. Скажи, а ты когда-нибудь планируешь выпускать журналы для Запада?

Д: Нет, на ближайшие десять лет мы хотим работать только в этой стране и только для жителей России.

Спец: Сейчас (game)land планирует выпустить на рынок несколько новых проектов. Расскажи немного о них.

Д: В этом году у нас запланировано три новых журнала, два из которых мы уже выпустили - это журналы Хулиган и Computer Gaming World. CGW мы выпускаем совместно с издательством СК «Пресс». В августе стартует наш новый журнал для молодых предпринимателей. Называется он «Свой бизнес». В следующем году наши планы - это семь новых изданий.

Спец: Ок, расскажи теперь немного о себе.

Д: Я родом из Ярославля, жил в обычном рабочем районе в хрущевке, ничем таким особым не выделялся. Окончил музыкальную школу (смеется) по наставлению родителей, как и все - «из под палки». Девятый и десятый классы учился в математической школе, так как очень любил математику. А затем не поступил в МГТУ имени Баумана - получил кол по сочинению и целый год занимался с преподавателем по русскому языку, и работал на заводе токарем. До сих пор тянет в машиностроительное производство. После того как поступил в Бауманский, после первого же курса, отправился служить в армию. Два года отслужил на границе с Венгрией.


Спецвыпуск Xakep, номер #020, стр. 020-078-3, ИНТЕРВЬЮ С ДИМОЙ АГАРУНОВЫМ

ИНТЕРВЬЮ С ДИМОЙ АГАРУНОВЫМ

Спецвыпуск Xakep, номер #020, стр. 020-078-3

Спец: По собственному желанию?

Д: Нет, тогда как раз был момент, когда забирали всех в армию: учащихся и не учащихся.

Спец: А, помню-помню.

Д: На самом деле, я не то что бы жалею - я очень рад, что отслужил. Рекомендую всем армейскую службу, которая очень важна во многих планах и дает такие вещи, которые сложно получить в другом месте. В общем, вернувшись из армии, я отучился еще два курса и полностью сосредоточился на бизнесе. В 92-м году создал свою компанию, оставил институт и решил заниматься только бизнесом.

Спец: А вот интересно, ты говорил, что твой бизнес был каким-то образом связан с Китаем.

Д: Да, после того как я создал компанию, сдал все экзамены третьего курса и защитил проект... Кстати, у меня все проекты на пять баллов. Учеба мне очень нравилась. Просто я расставил приоритеты, и оказалось, что бизнесом заниматься выгоднее. Вот. Да, о Китае. У меня были друзья, которые несколько раз ездили туда и рассказывали, как выгодно покупать там товар и продавать его тут. И я решил тоже заняться этим делом. Собрал семьсот долларов - тогда это были очень большие деньги для меня - и поехал, закупил разных товаров. С одеждой я как-то не очень разбирался, поэтому решил попробовать купить игрушек. Игрушки-трансформеры. Очень классные. Таких у нас в детстве никогда не было - это эмоционально очень грело. Мне это нравилось, я чувствовал огромную радость людей, а также гигантскую прибыль в 300-500 процентов. К 93-94-м годам я уже два раза в месяц ездил в Китай и отправлял грузы, вес которых доходил до двух тонн. Вот такой вот китайский бизнес.

Спец: Такой вопрос: когда ты реально для себя ощутил, что ты можешь влиять на огромное количество людей, которые читают журнал?

Д: Наверное, где-то в 97-98-м году, когда стало приходить очень много писем в «Страну игр», в которых люди благодарили нас за журнал. Даже мамы благодарили нас, так как они очень опасались за своих детей, которые могли ввязаться в неприятности на улице. А тут все-таки хоть это и были игры, но они стимулировали общение с компьютером, с современными технологиями.

Спец: Как ты думаешь, можно ли сказать, что хакерство и вообще компьютерная безопасность - это тоже своего рода игра для читателей Хакера, которая позволяет им развиваться?

Д: Мы исходим именно из этого! Хакерство - эта такая деятельность, которая ведет за собой огромные знания, очень тонкие и очень изощренные. Как мне кажется, если ты даже показал простые знания в компьютерной безопасности, то это уже признание того, что ты человек неординарный и попадаешь в число... ну, не знаю... наверное, пяти процентов самых продвинутых людей мира.


Спецвыпуск Xakep, номер #020, стр. 020-078-4, ИНТЕРВЬЮ С ДИМОЙ АГАРУНОВЫМ

ИНТЕРВЬЮ С ДИМОЙ АГАРУНОВЫМ

Спецвыпуск Xakep, номер #020, стр. 020-078-4

Спец: Дим, а ты, издатель журнала Хакер, чувствуешь какую-нибудь борьбу, неприятие со стороны снобистски настроенной общественности, считающей, что учить ребят хакерству нехорошо и так далее?

Д: Да, я чувствую, но я даже рад этому, потому что, как я сказал, с 99-го года мы позволили быть себе самими собой и поняли, что наши желания и наши чувства очень важны. Мы делаем то, что не делают другие, и это самый правильный путь. Не из протеста, а просто мы позволяем себе делать нестандартные вещи. Конечно же, большинство людей, особенно старшее поколение - стандартные, с привычными взглядами. Если бы мы ориентировались на них, мы бы не смогли сделать никакого успешного продукта. Я понимаю, что большинство людей смотрит с опаской, с подозрением на нашу деятельность - так же, как и на всю молодежь. И здесь важно выбрать - с кем мы. Наш выбор - это молодые, активные люди. Все остальное нас беспокоит намного меньше.

Спец: Были ли какие-нибудь забавные случаи, связанные с правоохранительными органами?

Д: Все, что происходит с правоохранительными органами, я бы забавным не называл. Это огромная сила, на которой ответственность за порядок в нашей стране. И я скажу, что у нас нет целей не то что бы противодействовать, а наоборот, я считаю, что мой гражданский долг - всецело поддерживать государство. Я бы не противопоставлял хакерство и государство. Например, мы все знаем, что существует целый государственный орган - называется ФАПСИ, - где работают крутые математики, крутые хакеры, которые занимаются безопасностью данных. Аналогия: взломщик сейфов может взламывать сейфы, чтобы воровать, а может открывать сейфы, которые сломались. Или может проверять на надежность новые замки. Ни в коем случае и никогда мы не призывали и не призываем к нарушению законов этой страны. Потому что все мы живем в ней и всем нам хочется, чтоб вокруг были порядок и покой. Поэтому я бы не стал называть забавным ничего, что связанно с государственными и правоохранительными органами.

Случаев очень много бывало, и они все время происходят: в основном, это жалобы компаний и... или граждан на вред, якобы наносимый нашим журналом кому бы то ни было. Если вспомнить приятные вещи, то Федеральное Управление налоговой полиции попросило нас ежемесячно присылать им журнал, так как их сисадмин постоянно латал разные дырки на основе информации из нашего журнала. Вот, пожалуй, это можно назвать таким приятным моментом.

Спец: А как со стороны Запада? Оттуда есть какой-нибудь фидбэк?

Д: У нас есть информация, что службы безопасности крупных софтверных компаний выписывают Хакер. И, например, мое имя и имя главного редактора находится в списке тех людей, которые могут принести потенциальный вред, например, Соединенным Штатам Америки (О-о-опс! - прим. ред.). Тем не менее мне кажется, что влияние журнала на Запад очень маленькое, что это все-таки журнал на русском, распространяется он в основном среди русских. Хотя около тысячи журналов продается в Западной Европе и примерно столько же в Соединенных Штатах.


Спецвыпуск Xakep, номер #020, стр. 020-078-5, ИНТЕРВЬЮ С ДИМОЙ АГАРУНОВЫМ

ИНТЕРВЬЮ С ДИМОЙ АГАРУНОВЫМ

Спецвыпуск Xakep, номер #020, стр. 020-078-5

Бизнес-партнеры пугаются однозначно, потому что для Запада это ново, такой журнал.

Спец: То есть на Запада таких журналов нет?

Д: На западе таких журналов однозначно нет.

Спец: Расскажи, какие твои цели, к чему ты стремишься?

Д: Мои цели такие - я хочу посвятить жизнь тому, чтобы улучшить то место, где я живу. И путь для этого я выбрал - поддерживать молодых, поддерживать молодежь и тех, кто хочет чего-то добиться. Чтоб быть конкретным, я решил так: помогать в профессиональном плане - поддерживать инициативу, предпринимательство, обучение, познание технологий. Отсюда, в общем-то, и все наши журналы: «Свой бизнес» - как стартануть свое дело, Хакер - как разобраться и освоить компьютерные технологии, информационные технологии, «Мобильные компьютеры» - это тоже журнал, который помогает пользоваться самыми современными технологиями в жизни и в бизнесе. Могу сказать точно, что все наши журналы - развлекательные или обучающие - они все направлены на эту цель: развиться, опираться на себя, зарабатывать и делать свою жизнь, жизнь близких и, соответственно, жизнь этой страны намного лучше.

Спец: Скажи, пожалуйста, ты можешь назвать какой-нибудь журнал нашего издательства своим самым любимым?

Д: Да, вот сейчас, наверное, мой любимчик - это журнал «Свой бизнес», хотя он еще и не появился. В этом журнале сконцентрирован весь мой опыт в бизнесе за десять лет. На самом деле, десять лет компании, а в бизнесе я еще дольше.

Спец: Последний вопрос: все мы движемся в будущее - каким ты видишь человека будущего?

Д: Я хотел бы ограничиться не просто будущим, а будущим России и будущим на ближайшие десять-двадцать лет. Я считаю, что ключевое слово на эти двадцать лет - это «ответственность». Понимание того, что твоя жизнь принадлежит тебе, понимание того, что мы сами ее строим и можем построить такой, какой захотим. Понимание того, что все, что с нами происходит, - это следствие наших действий. Мне кажется, это должно быть на первом месте.

Я такие конкретные цели ставлю для конкретики, потому что люблю мечтать далеко, но сегодня хотел бы говорить только о реальных целях.

Спец: На этом - все. Спасибо!

Д: Пока!


Спецвыпуск Xakep, номер #020, стр. 020-082-1, РОЛЛЫ

РОЛЛЫ

Спецвыпуск Xakep, номер #020, стр. 020-082-1

n0ah (noah@real.xakep.ru)

Ну, приятель, оторвал зад от стула? Оторвал-оторвал :). Раз уж ты открыл рубрику «Relax», готовься забыть о компе минут хотя бы на пятнадцать-двадцать. Вот – примерь это. Нет, это не «беспонтовый девайс», это роллы, приятель! Настоящие роликовые коньки. Я сам вчера в первый раз встал на роллы (ну, что-то раньше было, но условно можно сказать, что в первый раз) и теперь хочу рассказать тебе все, что я о них узнал. Как выбирать роллы, где покупать, чему надо научиться в первый день, чего остерегаться, как и где кататься – все это мы сейчас с тобой перетрем.

BUY

Первый вопрос, который возникнет у тебя сразу после мысли «А не попробовать ли мне порассекать на роллах?», это - «Где взять ролики?». А если ролики у тебя уже есть, и ты хотя бы немного успел на них уже покататься, то можешь не читать эту статью – тут информация для перцев, которые только-только собираются приладить к своим ногам колеса. Итак, где взять роллы? В магазине. Желательно, в большом и солидном – так ты хотя бы обезопасишь себя от дешевых подделок и прочего хлама. Правда придется потратиться, но тут уже ничего не поделаешь. Приведу пример: Редко кто из людей, хорошенько морочащихся компом (это, типа, про нас с тобой ;)), покупает себе железо в дорогенных магазинах с огромными наценками. Если ты грамотно разбираешься в компах и железе, ты знаешь, где купить нормальный хардвар по умеренным ценам (на рынке, в магазине, который ты давно облюбовал, с рук, в конце концов), ты можешь отличить нормальную б/у`шку от раздолбанного и поюзанного хлама. А вот ламеры всякие вынуждены платить больше и покупать себе компы в дорогих магазах с грамотными консультантами (не всегда), зато купленный девайс они смогут вернуть, если что-то с ним не сладится. А пусти его на рынок или в магаз, где особо никто не консультирует, так он купит или паленное железо, или вообще девайс, к которому на его маме порта нет. Так вот, приятель, в плане роликов мы с тобой – ламо, как это ни обидно :(. Со временем, как и любые другие ламеры, мы наберемся опыта, станем хаксорами :) и, конечно, будем знать, как грамотно выбрать б/у`шные ролики на рынке, заплатив при этом мало, но получив кульный товар. А пока, я тебе советую не гоняться за дешевизной и сходить в магаз (хотя бы посмотреть). Лично я походил по магазинам, поглядел, потом, естественно, полез в инет на роллерские сайты, нашел там контакт на дилера, который продает роллы по абсолютно тем же ценам, что и в магазине, только в добавок еще предоставляет офигительный сервис при выборе – ты к нему приезжаешь, он тебе все показывает, советует, примеряет, помогает подобрать. Короче, если смотреть с точки зрения цены, то я ничего не выиграл :(. А вот консульт получил отличный.

ВЫБЕРИ МЕНЯ!

Теперь о том, как выбирать ролики. Самое главное – не покупай всякие no name`овские девайсы – это отстой! Объясняю почему: ролики – вещь очень тонкая, если ты купишь фуфловые роллы с хреновыми, плохо крутящимися подшипниками или колесами, то ты заимеешь кучу гемороя с катанием. Прикинь, ны наяриваешь, отталкиваешься десять раз ногами, а катишься полметра. Тратишь усилия, а они уходят на трение в подшипниках. А на хороших роллах ты тратишь те же усилия, но так как там качественные подшипники, меньше энергии теряется на трение, и ты свободно катишься пять-десять метров. То же самое с ботинком (мягкая часть ролика, куда нога суется): во всяких no name`ах ботинок отвратный, не вентилируется и натирает. В итоге ты получаешь не катание, а проблемы с ногами. Так что настоятельно тебе советую покупать брендовые роллы: K2, RollerBlade, Salomon, Technica, Roces, Fila, HYPNO, Ultra Wheels и т.д.


Спецвыпуск Xakep, номер #020, стр. 020-082-2, РОЛЛЫ

РОЛЛЫ

Спецвыпуск Xakep, номер #020, стр. 020-082-2

Как ты, наверное, знаешь, ролики бывают двух основных типов: агрессив и фитнес. Агрессивные – это такие с маленькими широкими колесами, крепкие, удароустойчивые ролики. Их, в основном, юзают для прыжков, трамплинов, бордюров и прочих экстримных дел. Фитнес – это обычные (более привычные) роллы с колесами большего диаметра. Пригодны для умеренно скоростного катания, для прогулок и просто развлекухи. Если ты еще ни разу не стоял на колесах, то об агрессивных роллах лучше и не думать. Все равно прыгать и кувыркаться не будешь, а учится на них сложнее, так как они приспособлены совсем для другого. А еще они медленнее фитнесовских роликов, поэтому просто кататься (грубо говоря, по прямой) на них для непривыкшего человека будет напряжно. Нет, конечно, бывалый роллер на агрессивах уделает тебя в любом случае, будь ты хоть на фитнесовских, хоть на беговых роликах :), но для опытных роллеров агрессив заметно уступает в скорости. Существуют еще и гибридные ролики – полуфитнес-полуагрессив. Их можно взять, если ты на все сто уверен, что будешь экстримальничать, и фитнесовские роллы развалятся от твоих пыток через неделю. Но опять же, если ты еще никогда не катался, как ты собираешь заниматься экстримом ;)? С такими мыслями в голове лучше вообще не вставать на колеса – можно вообще без всяких мыслей остаться, равно как и без головы. Так что гибридные роллы – это для более-менее опытных людей, которые в меру прыгают и в меру катаются, а не для абсолютных новичков, которые планируют прыгать в будущем.

Если ты после всего этого решил не экспериментировать и остановился на фитнесовских роллах, то дальше тебе предстоит сделать выбор скоростных параметров роликов. Скорость роллов, как я уже сказал, во многом зависит от подшипников. Они делятся на несколько категорий: АВЕС1, ABEC 3, ABEC 5, ABEC 7 и ABEC 9. Соответственно, чем больше циферка, тем шустрее роллы. Но не стоит гнаться за скоростью и брать самые скоростные! Помни, мы с тобой только учимся кататься! Поэтому, самые быстрые роллы – не обязательно самые хорошие для нас. Оптимальнее всего взять «трешку» или «пятерку». Неопытный чел на быстрых роллах и стоять-то спокойно не сможет, а уж кататься... Любая небольшая горка становится кошмаром, когда ролики разгоняются под тобой, а ты даже не умеешь тормозить! Я вон выбрал себе ABEC 5, но с особо шустрыми подшипниками и колесами - короче, роллы достаточно шустрые. Не скажу, что особо жалею, но некоторый дискомфорт из-за скорости чувствую. На второй день этого дискомфорта стало уже поменьше, и, видимо, на третий его станет еще меньше, но ведь могло бы и вообще не быть, если б я не упорствовал и взял роллы помедленее. Короче говоря, на мой взгляд, самый лучший вариант – взять обычные ABEC 5 без всяких наворотов и спокойно себе учиться кататься, минуя нервотрепки из-за каждого небольшого наклона.


Спецвыпуск Xakep, номер #020, стр. 020-082-3, РОЛЛЫ

РОЛЛЫ

Спецвыпуск Xakep, номер #020, стр. 020-082-3

Дальше идет рама. Рама – это то, на чем держатся колеса. Тут все просто – рамы изготавливают из разных материалов: титан, алюминий, композитные материалы (крепкая пластмасса). Рама характеризуется прочностью и жесткостью. Прочность рамы в большей степени зависит не от материала, из которого она сделана, а от того, насколько продуманно и качественно она сделана. Бывают пластиковые рамы, которые гораздо прочнее металлических. Например, на агрессивных роликах, которым приходится выдерживать много ударных нагрузок, ставятся только пластиковые рамы. Чем жестче материал, из которого сделана рама, тем лучше она передает усилие, но одновременно так же хорошо передает вибрацию от неровностей асфальта. Для прогулочного катания скорее подойдет более комфортная пластиковая рама, которая лучше гасит вибрации. Для гонок на скорость лучше использовать более жесткую алюминиевую раму, т.к. меньше усилий будет теряться при отталкивании. Для гибридного катания может подойти как пластиковая, так и алюминиевая рама. Главное, чтобы она была достаточно прочная. Для агрессивных роликов рамы делают только из пластика, т.к. металл от таких нагрузок гнется.

Ок, подошли к самому главному – ботинок. Это вещь очень индивидуальная, поэтому обязательно надо примерить роллы, прежде чем их покупать! Нога должна плотно обхватываться, но при этом ничто нигде не должно упираться и натирать. Если что-то где-то не так, сразу снимай – это не твои роллы. Я лично перемерял штук восемь разных роликов, пока нашел подходящие для себя. Когда будешь примерять, максимально толкай пятку к заднику ботинка, так как когда ты начнешь кататься, пятка сама собой туда уйдет.

По поводу креплений ничего сказать не могу, так как для меня на данном этапе все равно, что там: шнуровка, липучка или зажимы. Выбирай, что больше нравится.

Вот, в принципе, и все о выборе роллов – руководствуясь полученным мной и переданным только что тебе опытом, можешь подобрать себе вполне нормальные колеса ;).

ЗАЩИТА

Но на одних роликах гимор не заканчивается – надо выбрать еще и защиту. Защита – это налокотники, наколенники и запястья. Мой тебе совет – бери все, не пожалеешь! Я вот не взял налокотники, по глупости посчитав, что запястий и наколенников достаточно – на первый же день ободрал и оцарапал себе все локти. Пришлось экстренно докупать налокотники. Есть еще и шлем, но тебе он пока вряд ли пригодится – это опять же для прыгунов, так что забей пока на него. Что касается налокотников, наколенников и запястий, то пофигу, какими именно они будут, главное – чтоб нигде не жали, не сползали и не натирали.


Спецвыпуск Xakep, номер #020, стр. 020-082-4, РОЛЛЫ

РОЛЛЫ

Спецвыпуск Xakep, номер #020, стр. 020-082-4

Немаловажную роль играет одежда, в которой ты будешь кататься. Желательно, чтоб она была из плотной ткани темных тонов и максимально покрывала участки кожи на теле. Хотя я забил и катаюсь в широких легких шортах и какой-нибудь футболке.

Про солнечные очки и плеер забудь – вся эта фигня отвлекает, кроме того, она покрошится на куски при первом же падении.

Еще неплохо бы иметь рюкзак, пригодный для транспортировки роллов и обуви, когда ты стоишь на колесах. Желательно чтоб у рюкзака были две лямки, так как ролы можно прикрепить к ним по бокам и таскать их таким образом. У меня рюкзак на одной лямке – кроссовки туда еще кое-как влезают, а вот роллы приходится таскать в руках.

ПЕРВЫЙ ДЕНЬ

Вот мы и встали на роллы! Отлично! Можно разогнаться и поехать. Фига! Разогнаться то можно, это легко – отталкиваешься ногами и вперед (хотя поначалу ты и это будешь делать коряво ;)), но вот тормозить... Это основная проблема для всех новичков. Я вот, например, пока еще не научился нормально тормозить ногами – приходится по ходу дела хвататься за всякие столбы, перила и прочую гадость :(. Тормоз, который крепится сзади на правом ролике – туфта. С его помощью тормозить жутко неудобно, и как сказал мне друг-экстримал: «Чем раньше ты его скрутишь, тем раньше научишься тормозить». А на мой вопрос: «Когда же это обычно происходит?», он ответил: «Примерно через месяц». Так что, приятель, не надейся, что ты на второй же день будешь рассекать воздух – учиться придется долго.

Еще одна фишка, которой я научился в первый же день по настояниям моего друга – падать. Просто встаешь на асфальт и бухаешься на колени (приблизительно так же, как и во время признания в любви своей подруге). Это поможет тебе довериться защите (в данном случае - наколенникам). Также я покувыркался в травке. Когда ты падаешь, важно чтоб ты катился по асфальту, а не скользил по нему каким-нибудь одним участком тела (особенно, мордой ;)). Иначе все себе обдерешь. А когда катишься, во-первых, скорость «полета» уменьшается быстрее, во-вторых, ты получаешь кучу незначительных царапин вместо одного большего участка содранной шкуры. Техника падения такова: первый удар должен прийтись по защите, причем желательно по комбинации из защит – локти-запястья, запястья-колени, локти-колени, дальше ты должен катиться в буквальном смысле кубарем, закрывая руками лицо и стараясь по возможности соприкасаться с асфальтом опять же защитой. Самые незащищенные места – спина и зад. Спина по любому обдирается, когда катишься. Если же падать на спину, то можно ее защитить, откинув назад руки, но при этом может пострадать зад :(. Но, в общем, все это относительно. Я, например, упал в первый же день: все сделал правильно – закрылся руками, удар пришелся сначала по левому наколеннику, потом по левому налокотнику, а потом я покатился, а когда окончательно приземлился, ударился ребром об собственный же налокотник... Чуть не сломал ребро. Вот так вот.

На этом пока все :). Если тебя это дело заинтересует (пиши мне!), мы будем учиться кататься на роллах вместе :). Когда у меня накопится достаточно опыта, я выложу его тебе в этой рубрике (ну может через номер или через два ;)). До встреч!


Спецвыпуск Xakep, номер #020, стр. 020-086-1, ДЕСЯТЬ САМЫХ ДУРАЦКИХ СПОСОБОВ ЗВОНИТЬ НА ХАЛЯВУ

ДЕСЯТЬ САМЫХ ДУРАЦКИХ СПОСОБОВ ЗВОНИТЬ НА ХАЛЯВУ

Спецвыпуск Xakep, номер #020, стр. 020-086-1

как ломаются (в буквальном смысле) таксофоны :(

Солдаткин Тимур aka cherry (still@xakep.ru)

Ни в коем случае не пытайся применять ни один из этих способов на практике!!! Все они уже давно устарели и не работают. Монтеры-телефонисты тоже не дураки: ставят на таксофоны крутую защиту. А если ты решил все-таки попробовать, то эта статья поможет тебе получить порцию синяков и гематом, а также насладиться прелестями обезьянника.

Здравствуй, мой маленький перчик! Или ты перчинка? Ну ладно, это не особо важно. Итак, сегодня наша тема - таксофоны. Ага, задел за больное :)? Нужда позвонить бывает очень часто, а возможности нет. Я догадываюсь, что ты у нас ультрамодный и твоя верная мобила всегда с тобой. Но аккумулятор у тебя не вечный, да и счет с гринами может закончиться.

Что делать? Правильно, надо искать близлежащий таксофон, который оторвали еще в прошлом году ;). Над таксофоном видишь табличку, которая гласит, что бесплатно позвонить можно только по служебным телефонам. Служебными считаются только скорая, пожарка и милиция. Поскольку подружка твоя не из ментосов, в вышеуказанные службы тебе звонить не надо.

Итак, имеем: таксофон - 1 шт., светлый ум - 1 шт., грязные руки - 2 шт., вонючие ноги - 2 шт. Еще не догадался, зачем нам ноги? А вот и нет, пинать таксофон мы не будем :). Мы же не вандалы, мы - хакеры. Так что сделаем все культурненько. А ноги нужны для того, чтобы убегать от доблестной милиции, сторожей и бабушек.

Да ладно тебе, не стремайся так, я пошутил. Не придется тебе убегать. Тебя сразу поймают :).

№1

Этот способ, наверно, только америкосы не знают. Перец подходит к таксофону, снимает трубку и в наглую набирает номер. Немереная наглость, правда? Когда перец слышит "Алло", то со всей дури орет в спикер. Спикер - это то место трубки, к которому все нормальные люди прикладывают ухо. Затем перец слушает дальше. И опять орет. Минусы этого способа - малое время разговора, да и прохожие странно смотрят. А когда приходишь домой, тебе говорят, что кто-то звонил и мычал.

№2

Этот способ для физически крепких перцев, т.е. применяется брутфорс ;). Перец опять подходит к таксофону, снимает трубку и так же нагло набирает номер. Когда слышит гудок, то лупит что есть мочи по аппарату. Только не ногами! А то потом придется в обезьяннике таксофон искать, чтоб позвонить. Способ может не сработать в двух случаях - если перец разобьет таксофон на хрен (что, скорее всего, и случится) или если аппарат уже был разбит другими перцами. Минусы - если я такого перца встречу, то уши оборву точно. Потому как таким способом у меня в районе все таксофоны оторвали к чертовой матери... В общем, лажа, идем дальше.

№3

Для этого способа придется немного потратиться. Перец достает где-нибудь или покупает нормальный жетон. Аккуратненько шилом проделывает дырочку наверху жетона. Затем берет тоненькую леску и привязывает к своему дырявому жетону. Все это надо делать аккуратно, иначе можно запороть таксофон, и позвонить не удастся (ни этому перцу, ни другим). Далее перец подходит к аппарату, снимает трубку и, как нормальный чувак, опускает жетон. Затем, естественно, набирает номер телефона и спокойно болтает. Жетон он, естественно, не забывает вынуть после того, как услышит подтверждение об оплате. Все. Можно болтать, пока телефон не развалится :). Не забывая пополнять счет :). Минусы - можно запортить таксофон.


Спецвыпуск Xakep, номер #020, стр. 020-086-2, ДЕСЯТЬ САМЫХ ДУРАЦКИХ СПОСОБОВ ЗВОНИТЬ НА ХАЛЯВУ

ДЕСЯТЬ САМЫХ ДУРАЦКИХ СПОСОБОВ ЗВОНИТЬ НА ХАЛЯВУ

Спецвыпуск Xakep, номер #020, стр. 020-086-2

№4

Этот способ будет несколько попроще, чем остальные. Когда на том конце провода поднимут трубку, перец резко дергает и отпускает рычаг, на котором держится трубка. На старых телефонах может не сработать, зато на новых работает на "ура!". Вот так, дешево и практично. Минусы - надо рассчитать, с какой силой дергать, иначе ни фига не получится.

№5

Вот этот способ для истинных экстремалов. Теперь перец берет кусок провода, оголенного с двух сторон. Один конец провода втыкает в спикер, другой в железную обмотку шнура. Таким образом он обходит систему защиты таксофона и соединяется напрямую. Вуаля! Таксофон сам отдался. При соблюдении техники безопасности проблем быть не должно, т.е. током перца таксофон не одарит. Хотя и палка раз в сто лет стреляет... Минусы - работает не везде, таксофоны после такого могут и копытца откинуть.

№6

Опять же перцу придется где-нибудь достать нормальный жетон. Он со всей дури запихивает его в щель телефона, естественно, не забывая придерживать. Результат - створки таксофона не поднимутся и звук не пропадет. Минусы - если руки кривые, жетон можно потерять в недрах аппарата.

№7

Перец покупает жетон, таксофон его сжирает и поговорить не дает :). Но этот способ к фрикингу не относится, так что едем дальше.

№8

Перец достает где-нибудь толстый телефонный кабель. Берет молоток и со всей дури бьет по кабелю. Необходимо его расплющить приблизительно до толщины 0.5 миллиметров. Ножницами вырезается необходимая форма жетона (сверяется с оригиналом! Края обрабатываются напильником, чтобы не было заусенцев. Вот и готов поддельный жетон. Минусы - автомат проверяет вес жетонов, так что этот фокус может не пройти, если жетоны будут слишком легкие или тяжелые. Как известно, в нашей стране могут посадить за банку варенья на три года...

№9

Перец берет проволоку, которая плохо гнется. Нужно около 5-6 сантиметров. Плющит ее, как в предыдущем способе, но не так сильно. Загибает один конец длиной в 5-6 миллиметров. Должно быть похоже на клюшку. При соединении перец попробует нащупать этим зверским инструментом крючок, который отвечает за соединение. Если получится его нажать - таксофон дружелюбно позволит звонить на халяву. Минусы - крючок может застрять.

№10

Можно попытаться засунуть в щель монетоприемника нож или иной предмет. Если повезет, можно задеть рычажок и поговорить на халяву.

Теперь ты всосал всю народную мудрость про обычные жетонные таксофоны и готов к тому, чтобы пользоваться карточками, поскольку жетонные таксофоны разломаны и разбиты народными умельцами. Не забудь про то, что вся информация в этой статье дана только в информационных целях. Автор и редакция за сломанные таксофоны и оторванные руки ответственности не несут.


Спецвыпуск Xakep, номер #020, стр. 020-088-1, The Matrix Fuck You

The Matrix Fuck You

Спецвыпуск Xakep, номер #020, стр. 020-088-1

Если вам около двадцати - двадцати пяти лет, вы любите темноту, таинственность, запредельность, неопределенность; если при слове «кадавр» на вас не нападает дрожь и не бегут мурашки по коже, поднимая волосы вместе с кепкой; если вы не боитесь зарабатывать деньги любым способом, в том числе и крайне неприятным, то эта работа для вас.

Если у вас нет рвотного рефлекса; если вы пьете водку, но пьянеете очень мало, как Штирлиц; если вы можете поднимать тяжести больше собственного веса и не падать после этого с грыжей; если вы не боитесь крыс - эта работа для вас.

Если у вас мало друзей; если среди немногочисленных собутыльников есть люди, понимающие, что «все работы хороши»; если вы не женаты; если ваша мама не против - то эта работа для вас.

Если вы студент - это прекрасная возможность подработать. Если вы безработный - это прекрасная возможность заплатить по счетам. Если вы женщина - вам нечего там делать. Если вы абсолютно нормальный человек - можете не читать дальше.

Если вы чувствуете желание узнать, на какую же работу требуются люди с вышеперечисленными требованиями, - готовьтесь. Вы должны будете пойти в службу занятости и узнать, какие вакансии предоставляет городская больница - я уверен, что вам предложат именно эту работу, так как текучка кадров там невероятно высока в силу особенностей нашей с вами действительности. Вам назовут сумму, которую вы будете получать один раз в месяц в кассе, - соглашайтесь, не задумываясь, ибо, помимо этого, вы всегда будете иметь кучку «шевелюшек» в кармане (люди боятся вас и постараются купить ваше расположение).

Вы придете на свое рабочее место, вам выдадут спецодежду, пропахшую формалином, - надевайте ее, не смущаясь. Там, где будете вы, другого не носит никто.

Вы войдете в большой светлый зал и увидите своих подопечных. Вы еще живы? Тогда это работа - точно для вас. Вы приняты.

Вы - САНИТАР ГОРОДСКОГО МОРГА. Затяните пояс на халате, пройдите к ближайшему столу и ткните пальцем в то, что лежит там. Оно неподвижное, твердое - живой человек мягче, теплее. Не бойтесь, мертвецы не кусаются.

Проверьте, все ли холодильники работают. Убедитесь, что документация в порядке. Не забудьте проверить карманы тех, кто лежит в одежде, - там может быть много интересного, ведь их только что привезли - вот этого с автодорожки, а вон та девица вышла с шестого этажа (видишь, там нет половины черепа?).

Самое главное - нет ничего страшного в том, что ты делаешь. Ты помогаешь живым увидеть их мертвых родственников в последний раз такими, как им хотелось бы, ведь смерть никогда не бывает красивой (только идиоты-самоубийцы так думают, даже не представляя, как выглядит их тело на тротуаре, под поездом или в кресле с пулей в башке).

- Поторопись!

Да уж, изволь поторопиться - это врач-патологоанатом подгоняет тебя, потому что ты задумался, глядя на обнаженную грудь мертвой женщины. Запомни - всегда слушай врача, он твой бог. Поделись с ним, если что-то найдешь. Налей ему, если есть. Не будь с ним запанибрата, но помни - он всегда поможет (не поднести тело, нет - пережить страх, отвращение, неприязнь).


Спецвыпуск Xakep, номер #020, стр. 020-088-2, The Matrix Fuck You

The Matrix Fuck You

Спецвыпуск Xakep, номер #020, стр. 020-088-2

Ты забыл проверить вот этот труп, у двери. Смотри - человек в строгом костюме, в галстуке, дорогие туфли из рыжей кожи (у тебя какой размер?). Лицо залито спекшейся кровью, грудь неестественно ввалилась, видно, что раздавлены кости таза (что там в сопроводительном листе - а, все понятно, он въехал под КАМАЗ; судя по всему, его «Мерседес» восстановлению не подлежит, как и сам хозяин). Проверь его внутренний карман - в случае чего, вали все на похоронную команду, они и в самом деле в состоянии спереть с трупа кошелек, ключи, документы и одежду.

Рука в кармане... Пусто. Но не отчаивайся - туфли, скорее всего, подойдут. Считай, что первый рабочий день прошел не зря. Но что это за звук? Мелодия, которая вылетает откуда-то из промежности, вызывает нервный смешок у тебя. Неужели в этой мешанине из костей уцелел мобильник?

Надень перчатку, прежде чем лезть туда, где кровь, пусть и свернувшаяся (кстати, запомни - по-настоящему кровь не сворачивается, а сгущается, ты же сам говоришь «сгустки», а не «свертки»). Бойся всякой гадости, которую человек может носить в своей крови - потом из твоих сосудов ее уже не достанешь.

Итак, рука осторожно отгибает полу пиджака... Где-то в области бедер огромное кровавое пятно, на ощупь оно жесткое, как пленка. Проберись туда, где предположительно находился ремень, - вероятнее всего, мобильник так и остался в чехле на поясе, вот только где сейчас пояс?

Нашел. Снимай. Телефон все еще продолжает звонить. Ты, конечно, знаком с тем, как его включить. Нажми. Поднеси к уху.

- Да.

- Ты где, милый? - приятный женский голос. Судя по всему, длинные ноги, высокая грудь, куча золота, модельная походка, минимум мозгов. «Ты где, милый?»

- В морге.

Тишина. На том конце - обморок. Хорошая шутка. Как-нибудь на досуге подумай, что можно сделать еще, потому что без юмора здесь нечего делать - мертвецы съедят твою душу и одарят тебя нескрываемым суперцинизмом.

А телефончик оставь себе...

Все началось со звонка в конце рабочего дня. Загрохотал телефон на столе довольно неожиданно для Алексея, он уже снял халат и собирался уходить. Обычно в это время уже никто не звонил, все стремились уладить дела до обеда, чтобы к вечеру, врезав водки, помянуть того, чьим благопристойным видом они интересовались днем.

Доктор поднял массивную трубку старого советского аппарата:

- Слушаю вас.

Шумное медленное дыхание.

- Слушаю, говорите же, - Алексей начал раздражаться - одной ногой он уже был в метро, по телевизору сегодня финал чемпионата мира по хоккею, а тут какое-то баловство!

Глубокий вздох, потом тихий стон:

- Эй, ты... Слышишь меня?

- Не понял, - удивился Алексей. - Мы с вами вроде бы на брудершафт не пили...

- Плохо мне... Я тут лежу... - снова стон, - гад...

- Кто это? - начал волноваться Алексей. Тема разговора ему оставалась непонятной, но тон уже не радовал - кто-то пытался его испугать.

- Это ты, Серега? - спросил он в трубку, ожидая признания в розыгрыше (он знал за своим коллегой, с которым работал посменно, способность к достаточно убедительным и правдоподобным розыгрышам).


Спецвыпуск Xakep, номер #020, стр. 020-088-3, The Matrix Fuck You

The Matrix Fuck You

Спецвыпуск Xakep, номер #020, стр. 020-088-3

- Ну, давай быстрей говори, мне бежать пора!

- Да пошел ты... Холодно... Нога... Ногу поправь... - настойчиво долбился в мозг голос из телефона. - Иди сюда...

Дыхание в трубке стихло. У Алексея похолодело внутри. Кто это с ним сейчас разговаривает? По коже пробежала волна мурашек, застучали зубы.

- Вы... где? - тихо и очень медленно произнес Алексей, боясь нарушить тишину и надеясь, что телефон больше не издаст ни звука, одновременно беря в руку большой секционный нож.

- Ты... знаешь... где... Быстрее, - последнее слово было воспринято Алексеем как приказ. Он каким-то десятым чувством осознал, откуда пришел этот звонок. Он осторожно положил трубку - благо, на том конце провода отключились - и медленно подошел к двери, разделяющей помещение лаборатории и хранилище. За матовым стеклом двери не угадывалось ни малейшего движения. Петли тихо скрипнули, дверь открылась.

В коридоре, соединяющем лабораторию и огромные помещения с формалиновыми ваннами и холодильниками, никого не было. Коридор уходил вдаль, словно в самолете, - метров сорок - сорок пять кафельные стены отодвигались вдаль, где упирались в железные ворота. Не выпуская ножа из рук, Алексей стал потихоньку продвигаться вперед; в голове продолжал звучать вкрадчивый и одновременно требовательный голос незнакомца: «Ногу поправь...».

Вскоре доктор уперся в двери, за которыми было трупохранилище.

На базе морга размещалось краевое патологоанатомическое бюро, поэтому трупов для исследований было очень много, они занимали площадь около двух с половиной тысяч квадратных метров и лежали в нескольких формалиновых ваннах (для студентов) и в холодильных шкафах (для хранения и выдачи родственникам). Алексей приоткрыл протяжно простонавшую дверь и заглянул внутрь.

В этот самый момент далеко сзади, в его кабинете, вновь зазвонил телефон. Алексей вздрогнул, оглянулся и быстро зашел внутрь, отсекая себя от всех звуков, доносящихся из зоны врачебных кабинетов. Резкий запах формалина и гул морозильников заставил насторожиться, Алексей напрягся, ожидая каких-нибудь неприятностей.

Оглядев зал внимательным неторопливым взглядом, он сделал несколько шагов вперед и увидел, что один из холодильных шкафов по правую руку в десяти-пятнадцати метрах от него приоткрыт. Приоткрыт совсем чуть-чуть, едва заметно - но ровно настолько, чтобы пытливый взгляд напуганного человека обнаружил это.

- Здесь есть кто-нибудь? - наконец решился задать вопрос Алексей. Обычный киношный вопрос в духе Голливуда, когда человек, прежде чем умереть, должен поинтересоваться, кто же перережет ему горло через мгновенье.

Несколько шагов. Еще пара. Щель открытой двери все лучше видна. На внутренней поверхности, где моховой шапкой дымился иней, заметны следы чьих-то пальцев. Самое интересное, что на его вопрос никто не ответил.

Черная «Волга» с государственным номером:

- Мы можем его вычислить?

- Безусловно. Его звонки отслеживаются нашей навигационной системой. Мы можем определить его местонахождение с точностью до двадцати метров.


Спецвыпуск Xakep, номер #020, стр. 020-088-4, The Matrix Fuck You

The Matrix Fuck You

Спецвыпуск Xakep, номер #020, стр. 020-088-4

- Это хорошо. Он может понадобиться нам в любой момент - или он сам, или его смерть.

- Я прекрасно вас понимаю. Его сотовый - у нас на прицеле. Вот он, смотрите.

- Вот эта красная точка?

- Да.

- А рядом с ней? Вот эти, еще несколько?

- ...

- Все, я понял. Черт возьми, он не единственный с телефоном в этом городе.

- Вы правы.

- Но почему все остальные точки перемещаются, а он - нет?

- Этому существует несколько объяснений - либо он сидит сейчас в каком-нибудь кафе за чашкой кофе, либо он спит в теплой постели со своей моделью, либо присел на лавочке в парке...

- Мне кажется, что он уже довольно давно сидит на одном месте.

- Это не мешает ему общаться. Совсем недавно он разговаривал по телефону, сейчас мы отслеживаем, с каким именно абонентом.

- Его ведут?

- Сейчас нет. Он должен был сегодня встретиться с еще одним человеком из...

- Да, это так. Сегодня незачем рисковать. Хорошо работаете, Королев. Все у вас предусмотрено, разложено по полочкам. Клиент в парке на лавочке, его девочка - в теплой постельке, на мониторе - красная точка... Не проспите чего-нибудь из ряда вон... Продолжайте наблюдать.

- Слушаюсь, товарищ майор.

- Звания оставьте для мамы, ей очень нравится.

- Извините.

- И запомните - мне не нужен наш подопечный, мне нужны его контакты. Каждый его шаг по нашей с вами земле - это еще один сошедший с ума, еще один больной, еще один пропавший для своих близких человек. Так что...

- Не подведем.

- Дай Бог.

Алексей вплотную приблизился к холодильнику. Сзади послышался шорох, резко оглянулся - никого. Вариант фильма ужасов продолжал развиваться в нужном направлении.

Морозный воздух продолжал зримо струиться из приоткрытой двери на пол. Доктор медленно протянул руку и за самый краешек толкнул массивную задвижку. Дверь нехотя подалась в сторону, открыв затемненную глубину холодильника. Судя по надписи на пластиковой карте, вставленной в рамку, там, внутри, сейчас находились три тела - две женщины из автомобильной катастрофы, доставленные три дня назад, и мужчина средних лет, которого сегодня извлекли из его разбитой о КАМАЗ машины.

Алексей осторожно заглянул внутрь. Вот они, две подружки, которых вытащили через лобовое стекло их «БМВ» с уже переломанными шеями, - лежат валетом, как на пляже. А вот и...

- Что за черт! - вырвалось у доктора, и он на пару шагов отскочил назад от двери. В глубине морозильника он увидел третье тело - мужчина в дорогом костюме, босиком, с нелепо загнутой левой ногой... Но не это заставило испугаться видавшего виды патологоанатома - на груди мертвеца лежал светящийся индикаторами сотовый телефон.

- Мне только что из морозилки позвонил труп, - вслух сказал себе Алексей, чтобы убедиться, насколько абсурдно это звучит. - Это кто-то из санитаров пошутил, - тут же успокоил себя доктор, но спохватился и вспомнил, что все ушли домой еще около часа назад.

Оставлять телефон внутри было довольно глупо - если аппарат принадлежал мертвецу, то завтра объявятся родственники, которые сразу же потребуют все вещи, в том числе и телефон, обратно. Алексей решил вытащить трубку из холодильника, но покойник лежал довольно далеко от двери. Зябко передернув плечами и желая, чтобы в морге наконец-то появились выкатывающиеся из стены лотки с телами, доктор сунул нож в карман, вошел внутрь, протиснулся мимо покрытых инеем женщин и протянул руку за телефоном. В ту же секунду дверь за его спиной с лязгом захлопнулась, доктор очутился в полной темноте при минусовой температуре в компании трех мертвых тел. Кнопки телефона продолжали светиться мертвенно-зеленым светом. Доктор в ужасе застыл на месте, не в силах произнести ни звука...


Спецвыпуск Xakep, номер #020, стр. 020-088-5, The Matrix Fuck You

The Matrix Fuck You

Спецвыпуск Xakep, номер #020, стр. 020-088-5

Сюзанна полулежала на диване, положив на лоб смоченный холодной водой носовой платок. Ее немного трясло, но девушка уже начала понемногу успокаиваться после того жуткого телефонного звонка своему другу. У нее в ушах до сих пор звучал чужой голос, донесшийся из трубки: «В морге!».

После того как она очнулась на полу у телефонной стойки в коридоре и на дрожащих ногах, держась за стены, сумела добраться до дивана, прошло уже около получаса. За это время она успела и побиться в истерике, и порыдать девчоночьими слезами, и жутко хохотать, представив своего Марата в морге, - в общем, все, что душе угодно. Но с течением времени она все чаще и чаще бросала взгляды в коридор, где стоял телефон. Как преступнику хочется вернуться на место преступления, так и ей хотелось вновь набрать номер и в этот раз услышать знакомый голос и понять, что все, что случилось тридцать минут назад, - всего лишь случайность, совпадение, чья-то необдуманная шутка.

Она присела, ухватившись рукой за подлокотник, - в силу огромной внушаемости девушка все еще испытывала слабость в теле, по коже пробежала волна мурашек. Сюзанна маленькими шагами приблизилась к телефону и сняла трубку...

Серебристая «БМВ» с дипломатическим номером:

- Он не пришел.

- Это неудивительно. Вы помните, как он обычно поступает, когда выполнит очередное задание - его практически невозможно найти, он расслабляется на своих многочисленных явочных квартирах.

- Марата невозможно отследить?

- Ну почему же, нет таких задач, с которыми мне не удалось бы справиться. Просто до сих пор перед нами не было подобной цели - он всегда исправно выходил на связь.

- Надеетесь, что и в этот раз все будет как обычно?

- Нет, в этот раз все несколько иначе. Он нужен нам срочно... Очень срочно... Есть покупатель. Хороший, проверенный покупатель.

- Так найдите же Марата!

- Ищем. В его телефон вшита микросхема, которая в определенный момент времени, будучи активизирована нашим импульсом, будет издавать контрольный сигнал. Мы сможем запеленговать его. Точность не высока, но...

- Сколько у нас есть времени?

- Несколько часов. Потом Марат уже будет не нужен, покупатель не станет ждать...

Виктор сидел на полу за большим секционным столом, сделанным из блестящего под бестеневыми лампами металла, и любовался новыми туфлями из рыжей кожи. Капли крови на носках туфель были аккуратно счищены, внутрь налит спирт (туфли были на размер меньше, но ходьба в них со спиртом в течение рабочего дня уберегла санитара от мозолей). Виктор сидел и пытался из-под стола увидеть, как озабоченный и испуганный доктор приблизился к открытой двери морозильника.


Спецвыпуск Xakep, номер #020, стр. 020-088-6, The Matrix Fuck You

The Matrix Fuck You

Спецвыпуск Xakep, номер #020, стр. 020-088-6

Смех так и распирал санитара. В первый же день работы он сумел провернуть просто чумовую шутку - благо, когда-то он сумел подержать в руках сотовый телефон и умел им пользоваться!

Доктор приближался к двери. Виктор напрягся, будучи готовым выскочить из укрытия. Вот Алексей Николаевич увидел телефон, вошел внутрь (ох, уж эти человеческие слабости!).

Санитар выпрыгнул из-за стола, даже не обратив внимания на лежащий на нем труп с раскрытой грудной клеткой и, подбежав к двери, захлопнул ее и запер на задвижку. После чего он взглянул на градусник, присвистнул, вытащил из кармана пачку сигарет и пошел на крыльцо покурить, не обращая внимания на глухие крики из холодильника и стук по двери.

Напевая себе под нос «Наша служба и опасна, и трудна...», он вышел на улицу и опустился на лавочку в тени деревьев. Его интересовало, сколько времени может продержаться доктор взаперти до тех пор, пока не покроется инеем.

Алексей стоял, прижавшись спиной к холодной, очень холодной стене, оцепенев от страха. Кто-то запер его в морозильнике с минусовой температурой наедине с тремя мертвыми, обратившимися в камень от холода телами. Если в ближайшие час-два дверь не откроется - доктора ждет неминуемая гибель.

Мороз пробрался под халат очень и очень быстро; зубы стучали уже через минуту, и Алексей не разбирался, почему - то ли от страха, то ли от озноба. Снаружи через толстую дверь не долетало ни звука.

Доктор сделал несколько неуверенных шагов вдоль стены, придерживаясь за нее кончиками пальцев, по которым словно струился ток - прикосновение к металлу было болезненным. Его правый бок уперся в дверь; доктор в надежде на чудо легонько подтолкнул ее - дверь не поддалась. Он ударил посильнее, потом заколотил в нее ногами и кулаками, от чего в лицо полетели брызги инея и несколько кусочков льда. Потом он попытался подсунуть в щель секционный нож, но это ему не удалось.

- Откройте! Эй, кто там есть?! Откройте, я говорю!

Никто не отозвался, не пришел на помощь. Алексей закрыл глаза (благо, в темноте они были совсем ни к чему - светящие кнопки не приковывали взгляд). Ужас сковал его. В голове с огромной скоростью проносились мысли о смерти, о друзьях, какие-то фрагменты фильмов с закрытыми дверями и упокоенными заживо; кончики пальцев, отмороженные о дверь, тряслись. Сквозь плотно закрытые веки Алексей видел облака пара, вырывающиеся изо рта и поднимающиеся к потолку, чтобы упасть оттуда, охладившись. Мерцание кнопок телефона прокралось к нему в глаза; это был единственный источник света во тьме, и он стал доминантой.

Алексей распахнул глаза пошире, стараясь уловить хоть какой-нибудь лучик, который мог бы прорваться сквозь плотно закрытую дверь, но машинально переводил взгляд на телефон, который еле-еле освещал зеленоватое пятно на груди трупа мужчины. Через несколько минут доктор уже смог разглядеть узор на пиджаке мертвеца.


Спецвыпуск Xakep, номер #020, стр. 020-088-7, The Matrix Fuck You

The Matrix Fuck You

Спецвыпуск Xakep, номер #020, стр. 020-088-7

Он пошарил руками вокруг себя, наткнулся на ледяное лицо одной из женщин, лежащих ближе к выходу, отшатнулся и прижался спиной к стене. Затылок холодило инеем, покрывающим все вокруг, - потолок, полку, стены, трупы.

Снаружи по-прежнему не доносилось ни звука. Алексей медленно, чувствуя под ногами лед, сделал несколько шагов к телефону, протянул руку, чтобы взять его, и в это мгновенье телефон расцвел яркими цветами, и в тишине морга пропиликал вызов. Алексей нащупал на трупе телефон и деревянными пальцами нажал кнопку.

- Да... - прохрипел он, начиная замерзать уже по-настоящему.

- Алло, Марат, где ты? - взволнованный женский голос звучал в могильной тишине довольно громко и очень противоестественно. - Марат... Это ты?

- Нет, это не Марат, - быстро ответил Алексей, так как вдруг перед ним забрезжила надежда спастись. - Девушка, поверьте, я случайно взял этот телефон...

- Где мой Марат?! - закричала девушка, да так пронзительно, что доктор машинально отодвинул трубку от уха. - Что с ним? Кто это говорит?

- Девушка, слушайте, я работаю в морге и...

- В морге?!. - переспросил женский голос. Потом наступила пауза, и до чуткого уха Алексей долетел звук падения тела - на том конце провода неизвестная девушка потеряла сознание.

Алексей выругался и в сердцах стукнул кулаком по лежащему рядом трупу - судя по всему, Марата. Застывшее тело отозвалось глухим звуком. Доктор зло смотрел на телефон и думал, какую пользу можно извлечь из этой маленькой тоненькой трубки. Он не очень представлял себе, как можно позвонить, так как никогда в жизни не разговаривал по мобильному телефону до сегодняшнего дня, и лишь по какому-то наитию правильно выбрал кнопку включения при входящем звонке - она просто была больше всех.

Доктор принялся нажимать на все кнопки подряд в надежде дозвониться куда-нибудь, но тщетно - сигнал в трубке появился, однако номер по каким-то причинам не набирался. Алексей начал нервничать, телефон выскользнул из негнущихся пальцев. Доктор в страхе за то, что единственное средство общения с внешним миром может разбиться, попытался подхватить его, устроив невиданный акробатический этюд, однако трубка словно просочилась сквозь пальцы и упала на пол. Алексей нырнул за ней следом, ударился, не рассчитав во мраке расстояния, лбом о полку с телами и в оглушении повалился на иней. Руки и ноги разъехались, всем телом доктор грохнулся на металлические пластины, покрывающие дно холодильной камеры и на несколько минут потерял ориентацию.

Придя, наконец, в себя, Алексей попытался подняться и услышал под руками подозрительный хруст. Зеленоватое свечение угасало на пальцах доктора - телефон был напрочь раздавлен, его пластиковый корпус превратился в крошево, которое прилипло к ледяным рукам доктора. Последнее средство спасения превратилось в бесполезный кусок пластмассы.

Доктор на мгновенье представил себе, как через сутки его самого будут вскрывать на одном из столов в секционном зале, и мороз с удвоенной силой пробежал по его покрытой мурашками коже. Надо было что-то предпринимать.


Спецвыпуск Xakep, номер #020, стр. 020-088-8, The Matrix Fuck You

The Matrix Fuck You

Спецвыпуск Xakep, номер #020, стр. 020-088-8

Нащупав на полу выпавший секционный скальпель, Алексей решил обыскать лежащие в его «тюрьме» тела в надежде найти у них что-нибудь, что поможет ему выбраться. Вполне возможно, что кто-нибудь из мертвецов при жизни курил - тогда может найтись зажигалка, спички, чтобы увидеть, какими способами попытаться взломать дверь. Его руки, привыкшие к вскрытиям и чужим органам, начали ощупывать лежащие перед ним останки.

На первой женщине ничего не оказалось. Алексей даже забрался в нижнее белье, но больше для порядка, чтобы потом не обвинять себя в том, что пропустил нечто важное. Торчащие наружу сломанные ребра и кровавые пятна доктор старался обходить стороной, боясь всяческой заразы, но в темноте их можно было избежать, только лишь предварительно нащупав. Через несколько минут поисков Алексей плюнул на всяческие условности и свалил одну из женщин на пол, чтобы освободить второе тело. Труп шлепнулся об пол где-то под ногами у врача; Алексей не обратил на это никакого внимания и встал на его грудь, после чего при каждом движении доктора там что-то хлюпало.

В пиджаке второй женщины он нащупал пачку сигарет, что немного обнадежило его - он принялся с удвоенным старанием обыскивать погибшую, но сигаретами все и закончилось. По-видимому, дама страдала забывчивостью и прикурить просила у окружающих. В другом кармане обнаружилась связка ключей - штук пять-шесть, судя по всему, от квартиры. Как они могут понадобиться, Алексей не решил, но все-таки сунул их в карман халата.

Оттащив вдоль по полке второй труп, Алексей приступил к осмотру мужского трупа и тут же заметил, что тот лежит как-то странно - левая рука была заведена назад, грудь слегка приподнята, как будто он лежит спиной на маленькой подушке. Доктор попытался приподнять застывшее тело и вытащил окоченевшую руку наверх, с трудом поборов трупное окоченение. Тут же стало понятно неестественное положение тела - к руке наручником был пристегнут маленький плоский чемоданчик размерами с том «Советской Энциклопедии».

Доктор ощупал его руками, попутно отметив, что пальцы уже перестали ощущать тонкие структуры, и нашел большую трещину в корпусе чемоданчика. Попытался всунуть скальпель в щель и повернуть - не удалось с первого раза, очень неудобно было стоять над телом. Тогда Алексею пришла в голову другая мысль.

Не заботясь о том, что может завтра увидеть судебный исполнитель, он твердой рукой обхватил нож и методично и абсолютно точно, со всем знанием топографической анатомии отрезал Марату кисть левой руки, после чего снял наручник с запястья и передвинулся по столу на свободное место.

Довольно скоро щель на чемоданчике стала немного шире. Алексей тряхнул его, пытаясь понять, что же он пытается достать. Внутри громыхнуло что-то пластмассовое - судя по обстановке, совсем не способное помочь доктору, но тот уже был настроен вскрыть крышку во что бы то ни стало.

Его возня с чемоданчиком была борьбой не на жизнь, а на смерть. Несколько раз нож соскользнул, едва не оставив врача без пальцев. Но вскоре щель стала расширяться; доктор несколько раз стукнул чемоданчиком о стену камеры, предварительно вставив нож в нужном месте. Через пятнадцать минут крышка сдалась на милость победителя - треснула и развалилась на две части.


Спецвыпуск Xakep, номер #020, стр. 020-088-9, The Matrix Fuck You

The Matrix Fuck You

Спецвыпуск Xakep, номер #020, стр. 020-088-9

Наружу вывалилось несколько пластмассовых предметов - три или четыре. Алексей сунул нож в карман, пошарил руками вокруг себя и нащупал три пластиковых коробочки примерно восемь на шесть сантиметров. И были эти коробочки абсолютными подобиями телефона, который Алексей раздавил полчаса назад.

Доктор непонимающе держал в руках эти мобильники и пытался сообразить, на кой черт Марат таскал их в чемодане, да еще и пристегнул к себе наручниками!

Несколько минут разговоров с самими собой не принесли облегчения и не дали понимания происходящего. Алексей потыкал негнущимися пальцами в кнопки и сумел включить все телефоны. Кнопки засветились; в темноте, в которой доктор находился уже около часа, их свет казался ярким, как солнце; врач даже зажмурился на несколько секунд, чтобы адаптироваться к источнику света.

Положив их на полку с определенным интервалом, Алексей сумел осветить небольшой участок места своего заточения. Из темноты проступили контуры лица Марата с кровавой полосой вдоль лба, ноги второй женщины, нелепо выгнутые в голенях (так бывает, когда двигатель вашей машины ложится вам на ноги). Труп, лежащий на полу, остался во мраке, но до него доктору не было никакого дела.

Алексей прижался к стене, не обращая внимания на жгучий холод, и в задумчивости смотрел на три зеленоватых пятна света, пытаясь представить, какую пользу они могут ему принести. Через пару минут размышлений он решительно шагнул к телефонам и, взяв один из них в руки, принялся нажимать кнопки...

Виктор просидел на улице около часа, выкурив несколько сигарет. Был уже поздний вечер, становилось сумеречно, прохладный ветер заставил санитара пройти внутрь морга. Он поднялся, вернулся в секционный зал и проверил, закрыта ли дверь в морозильник, внутри которого сейчас замерзал врач. Естественно, все было в порядке - взломать массивную задвижку изнутри было практически невозможно, необходимо было обладать огромной физической силой, чтобы хоть на чуть-чуть поколебать толстую металлическую дверь, пригнанную просто идеально.

Санитар ухмыльнулся, представив себе покрытого инеем доктора, прошел к ближайшему столу, на котором покоилось разваленное Алексеем пополам тело умершего от инфаркта старика, взял несколько инструментов и принялся ковыряться во внутренностях.

Неожиданно до его уха донесся какой-то шум из холодильника. Виктор насторожился, застыв с чужим сердцем в руках, потом кинул его внутрь опустошенного вскрытием тела и сделал несколько шагов к двери. Шум повторился. Виктор никак не мог понять, то ли Алексей что-то делает изнутри с дверью, то ли это смех, то ли кашель. Он приложил ухо к двери, покрытой каплями измороси, и вслушался в происходящее внутри. Тишина в холодильном склепе сменялась периодическим шорохом, раздававшимся где-то совсем рядом, буквально в полуметре от головы санитара. Вдруг все стихло. Виктор напрягся, пытаясь услышать хоть какой-нибудь звук, прижался к двери всем телом, не обращая внимания на холод, тут же нырнувший к нему под одежду. Через несколько секунд до пораженного санитара донесся громкий нечеловеческий смех.


Спецвыпуск Xakep, номер #020, стр. 020-088-10, The Matrix Fuck You

The Matrix Fuck You

Спецвыпуск Xakep, номер #020, стр. 020-088-10

Виктор отшатнулся от двери на шаг и напряженно замер. Его крайне взволновало то, что происходило сейчас внутри холодильника. Судя по всему, врач достаточно быстро сошел с ума и сейчас общался с мертвецами.

Постепенно напряжение сменилось пониманием происходящего, санитар облегченно вздохнул, расслабился и вернулся на свое место у двери, вновь приложив к ней ухо, - уж очень Виктору хотелось узнать, о чем может беседовать сам с собой и с трупами сумасшедший врач. Но едва он напряг слух, в его мозг стал ввинчиваться навязчивый чужой шепот. О чем говорил ему невидимый неизвестный собеседник, Виктор не узнал - он вяло опустился по двери на пол и, закатив глаза, потерял сознание...

- Ты хоть в курсе, что Марат предлагает в этот раз?

- В общих чертах. Я в силу некоторых обстоятельств не пытаюсь прыгнуть выше головы, чтобы ее не лишиться. Поэтому напрямую никогда не интересовался тем, что держит за пазухой этот сумасшедший. Хотя... Кое-что я подозреваю.

- Например?

- Я склонен считать, что Марат занимается некими изощренными формами терроризма, в частности, биологическим - сколько, как ты думаешь, может стоить шприц, зараженный вирусом СПИДа? Или те же самые споры сибирской язвы, столь разрекламированные сам знаешь кем?

- Хочешь сказать, что в его чемоданчике могут оказаться и вирусы, и кое-что похуже?

- Само собой, я в этом не могу быть уверен до конца. Но то, что мы имеем дело с высокотехнологичным агентом, способным предложить нам супертовар, которому мы обязательно найдем применение, - это правда.

- Ты активизировал чип для пеленгации?

- Да. Недавно он разговаривал по телефону с Сюзанной, своей подругой, но почему-то оборвал разговор. Было плохо слышно, практически ничего не удалось разобрать, кроме слова «морг», произнесенного дважды.

- Морг?!

- Да. Я, само собой, успел запеленговать сигнал. И знаешь, координаты его довольно странные.

- Договаривай...

Звук мотора серебристой «BMW» заглушил дальнейший диалог двух наблюдателей Марата, курирующих его работу в России.

За последние полтора часа Сюзанна успела объехать четыре морга в округе - город был достаточно большой, каждая больница имела собственное патологоанатомическое отделение. Девушка разузнала обо всех поступивших за сегодняшний день, даже собрала в кулак всю волю и взглянула на двух неопознанных мужчин, попавших на секционные столы после автомобильных аварий. К счастью, оба они оказались ни грамма не похожи на Марата, что, впрочем, не особенно добавило оптимизма Сюзанне - поблизости было еще два морга и одно патологоанатомическое бюро на базе медицинского университета. Девушка устало опустилась на водительское сиденье «Ауди», которую ей подарил Марат, тяжело вздохнула и отправилась дальше.

Но обычно то, что ищешь, всегда находишь в последнем кармане. Сюзанна не была исключением. Морг, в котором сейчас лежал Марат, оказался в ее условном списке ПОСЛЕДНИМ.


Спецвыпуск Xakep, номер #020, стр. 020-088-11, The Matrix Fuck You

The Matrix Fuck You

Спецвыпуск Xakep, номер #020, стр. 020-088-11

Ей предстояло в ближайшие два часа присутствовать на опознании еще трех мужчин среднего возраста, разбившихся в «Мерседесах» за вчерашние и сегодняшние сутки. За это время она привыкнет к виду крови и свернутых шей, станет разбираться в дорогих костюмах по их обрывкам и перестанет падать в обморок. И ЭТИ ДВА ЧАСА СПАСУТ ЕЙ ЖИЗНЬ.

- Мы ведем машину, которая, судя по сигналам, принимаемым и переданным ею, пеленгует Марата. Товарищ майор, разрешите отслеживать ее перемещение не только путем радионаблюдения, но и визуально?

- Не спугнете?

- Обижаете, Петр Григорьевич. Плюс к этому есть все основания - уж больно целенаправленный маршрут демонстрируют те двое в «BMW».

- Вы думаете, они знают, где Марат?

- Не в моих привычках въезжать в рай на чужом горбу, Петр Григорьевич, но нас приведут прямо к Марату без каких-либо усилий с нашей стороны. Дорога к нашему подопечному обозначена сотами местной компании, как вешками.

- Действуйте, Королев. И помните - если решите стрелять, стреляйте.

Лейтенант с трудом козырнул в «Волге», быстро пересел в подъехавший сбоку «Форд», и автомобили разъехались, оставив после себя только облачко пыли...

Виктор постепенно приходил в себя. Кружилась голова (даже лежа), лампы на потолке двигались куда-то в диком хороводе, в ушах стояла ватная тишина. Он попытался приподняться, пару раз соскользнул по двери обратно на кафель, но с третьего раза сумел нетвердо встать на ноги.

Невидящими глазами он обвел секционный зал и удивленно осмотрел самого себя, сняв и ощупав наформалиненный халат и колпак, сползший на затылок. Колпак особенно поразил его - Виктор помял его в руках, после чего в испуге отшвырнул в сторону. Он выглядел сейчас человеком, полностью потерявшим память.

Трупы на столах заинтересовали его. Санитар медленно пошел вдоль ряда металлических столов с подопечными на них. Некоторые тела еще не тронул нож патологоанатома, некоторые были уже зашиты грубым швом (внутрь обычно запихивают все, что оказалось ненужным - органы в беспорядке, тряпки, мусор). Три мертвеца были вскрыты и оставлены для судебных медиков, которые обычно приходили очень поздно, практически ночью, после всех необходимых выездов с милицейскими бригадами.

Виктор прошел по одному ряду столов, одобрительно похлопывая трупы по голой холодной коже; провел рукой по обнаженному бедру дамы бальзаковского возраста с пулевым отверстием в области сердца; улыбнулся старику, умершему сегодня утром от инфаркта. На секунду он оглянулся и посмотрел на дверь, около которой он очнулся, но ничто не напомнило ему, что в данный момент там внутри замерзает врач. Взгляд скользнул с этого морозильника на следующий, на лице отразилась довольная ухмылка.

- Я всегда хотел быть Нео, но... - невпопад сказал он сам себе. - The Matrix fuck you.

После чего засмеялся и, услышав собственный смех, неожиданно испуганно замолчал. Он вдруг понял, что совсем недавно уже слышал такой же смех.


Спецвыпуск Xakep, номер #020, стр. 020-088-12, The Matrix Fuck You

The Matrix Fuck You

Спецвыпуск Xakep, номер #020, стр. 020-088-12

Из-за этого воспоминания Виктор еще довольно долго беспокойно озирался по сторонам, ожидая каких-либо неприятностей со всех сторон. Трупы уже не вызывали у него той радости, что он испытал, очнувшись. Но все-таки постепенно санитар сумел успокоиться.

Он словно не замечал тех странностей, что происходят с ним. Он не заметил, как провел кончиком указательного пальца по лужице крови, остановившейся в стоке стола, нарисовав несколько крестиков. Он не обратил внимания на то, что как-то по-особенному принюхивается к запахам секционного зала - принюхивается, хищно раздувая ноздри. Ему не пришло в голову спросить себя, зачем он остановился у одного из столов, на котором покоился вскрытый мужчина средних лет. Виктор заглянул внутрь распиленного черепа, медленно протянул к голове руку и коснулся гладкой внутренней поверхности черепных ямок, после чего поправил откинутую на глаза кожу, потянул веки вверх и посмотрел мертвецу в глаза.

- Мое имя Тринити, - тихо прошептал санитар, подошел к весам, на которых в целлофановом пакете лежало обложенное льдом сердце, разорвал пакет, поднес его к губам и спокойно откусил небольшой кусок. - Следуй за белым кроликом...

Через несколько минут от сердца не осталось и следа. Виктор вытер замерзшие губы, сплюнул на пол, после чего повернулся к мертвецу, сердце которого он только что съел, и прошептал:

- У сердца вкус сердца, ничего особенного.

На тяжелый стук из морозильника, в котором был закрыт доктор, он уже не обращал внимания. Санитар Виктор Невзоров, 28 лет от роду, никогда ничем не болевший, за последние двадцать минут необратимо сошел с ума - после того как вкрадчивый голос сквозь металлическую дверь холодильника прошептал ему необходимые для этого слова.

«BMW» притормозил у краевого патологоанатомического бюро, рядом с большими чугунными воротами, в это время суток запертыми на огромный замок. Из машины пытливым взглядом осмотрел все черноволосый человек с лицом азиата. Оглянувшись на своего спутника, сидевшего за рулем, он кивнул:

- Это где-то здесь, Джафар.

- Надо осмотреться, - произнес водитель. - Ворота, конечно, большие, но нам как-то надо туда попасть.

- Нечего рассиживаться. Если надо будет перелезть - значит, станем каскадерами. Ты прекрасно знаешь, что у нас всего несколько часов. Если твоя штучка засекла его как-нибудь не так и не там, то мы оба покойники. Можно просто остаться там внутри, лечь на столы и ждать, когда босс вскроет нас живыми.

Они вышли из машины и приблизились к воротам. Открыть замок без каких-либо приспособлений не представлялось возможным, поэтому, поплевав на руки, они взобрались по чугунным прутьям и спрыгнули на другой стороне.

Уже было довольно темно. Контуры морга угадывались нечетко; предположив, что дверь должна быть где-то посередине здания, водитель подошел к ней, оставив своего спутника на подходе к моргу. Дверь оказалась не заперта.

- Странно все это, - вслух тихо произнес Джафар, прикасаясь пальцами к двери с надписью «Здесь смерть помогает жизни». - Какого черта Марат делает здесь?


Спецвыпуск Xakep, номер #020, стр. 020-088-13, The Matrix Fuck You

The Matrix Fuck You

Спецвыпуск Xakep, номер #020, стр. 020-088-13

Он уже засомневался в точности показаний пеленгатора. Никаких оснований находиться в морге у Марата не могло быть, кроме разве что...

- Нет, не может быть! - успокоил себя Джафар, вспомнив о той куче денег, которая должна была появиться на свет после заключения контракта с агентом. - Он же звонил отсюда, значит, он жив.

Внутри было очень тихо. Лампы дневного света горели через одну-две, даже не потрескивая. Джафар продвигался по коридору туда, где, как ему казалось, должны были находиться живые люди. Миновав пару каталок со следами крови, он прошептал несколько слов на своем языке и сделал знак, будто что-то отгонял от себя. Тишина завораживала.

Вдруг где-то рядом что-то тяжелое упало на пол. Джафар прижался к стене, распластавшись на ней, и вытащил пистолет. Никаких других звуков следом не раздалось. Подождав несколько секунд, Джафар продолжил продвижение вперед, выставив перед собой на вытянутой руке ствол оружия. Его шаги не расслышала бы даже собака - он научился так ходить в Афганистане, где находился на обучении в одном из «особых» лагерей. Он знал - несмотря на все возможные преграды, он должен найти Марата и доставить его боссу, так как без агента вся дальнейшая операция не имела смысла.

Приблизились двери той половины здания, где располагался медперсонал. Джафар очень осторожно исследовал кабинеты и не нашел там никого. Никаких следов, говорящих о том, что около часа назад отсюда звонил Марат. Заглянув у выхода из кабинета в один из шкафчиков для одежды, Джафар обнаружил там одиноко висящий черный плащ и стоящие под ним легкие туфли. Судя по всему, кто-то ушел домой в сменной обуви - или все еще находится где-то в здании.

На мгновенье Джафар задумался. Здание морга было довольно большим, двухэтажным, вполне возможно, что есть и подвал. Обыскать такой дом в одиночку за небольшой промежуток времени было достаточно проблематично, поэтому Джафар решил позвать на помощь напарника и махнул ему рукой в окно. Тот быстро вбежал внутрь, так же тихо добрался до кабинета, в котором находился сейчас Джафар и вопросительно посмотрел на него.

- Он здесь, - одними губами сказал Джафар. - И он не один.

Напарник кивнул, достал пистолет и взглядом попросил указать направление. Джафар предложил ему второй этаж, а сам отправился тем же путем, каким Алексей попал в секционный зал.

Стеклянная дверь с замутненным стеклом приблизилась довольно быстро. Из-за нее до слуха Джафара донесся очень странный звук - что-то вроде заупокойного пения вперемешку с чавканьем. Осторожно приоткрыв дверь кончиком ствола, Джафар не увидел ничего, что заставило бы его насторожиться, - только ровные ряды столов и дверей холодильников. Вдруг вновь раздался тот самый звук, который Джафар слышал несколько минут назад в коридоре, - что-то тяжелое, в несколько десятков килограммов, упало на пол, причем именно в этом зале.

На краю поля зрения Джафар успел заметить, как чьи-то ноги исчезли с секционного стола, нырнув вниз на кафель. Он испуганно замер, потом проверил, снят ли пистолет с предохранителя, присел на корточки и практически вполз в секционный зал, спрятавшись за большую стойку с рядом умывальников. Чавканье раздалось вновь с прежней силой.


Спецвыпуск Xakep, номер #020, стр. 020-088-14, The Matrix Fuck You

The Matrix Fuck You

Спецвыпуск Xakep, номер #020, стр. 020-088-14

Джафар помолился про себя, прислушался к биению сердца и вдруг понял, что боялся так же, как сейчас, только в тот день, когда сдавал экзамен по допросу пленных с применением особых мер дознания.

Несколько шагов в сторону. Надо выбраться на такое место, откуда будет видно, кто же там что-то жрет. Еще несколько шагов. Кто-то невидимый в нескольких метрах за столами смачно отрыгнул, потом раздался смех, и над головой Джафара пролетело что-то, обдав его лицо брызгами. Джафар стер с лица капли и через секунду понял, что это кровь. Ему очень не хотелось оглядываться, чтобы узнать, что же там упало за спиной, но тело обернулось само. В трех шагах от Джафара, размазавшись о стену, по стене сползали чьи-то внутренности.

Еще через секунду он понял, что падает в обморок. Моментально мобилизовав сознание, Джафар выполнил несколько дыхательных упражнений из специального комплекса, сосредоточился на отвлеченных вещах и сумел удержать свое сознание на поверхности. После этого он аккуратно, без единого звука, обернулся вновь (во второй раз разорванные внутренности не произвели на бывалого Джафара никакого впечатления) и по следу, оставленному на стене кишками, точно определил, откуда они были брошены.

Тот, кто разбрасывался чужими кишками, находился неподалеку, у стены, метрах в пяти. По-видимому, этот невидимый людоед во время своей трапезы сидел на полу. Джафар почти лег на кафель и взглянул под столами в нужном направлении. То, что он увидел, вновь на несколько секунд вывело его из равновесия.

Привалившись спиной к стене, сидел человек, лица которого из такого положения Джафару было не видно. Этот человек методично запускал руки в труп, лежащий перед ним на боку, доставал оттуда что-нибудь, вертел в руках, словно примеряя под себя, после чего пытался надкусить и или продолжал есть, или засовывал обратно. Джафар поймал себя на мысли, что не может проглотить слюну - настолько жуткой была картина. Но самое фантастическое Джафар увидел под занавес - на этом человеке были туфли Марата. Их Джафар помнил очень четко - на всех фотографиях и видеонаблюдениях эти туфли из рыжей кожи всегда ярким пятном бросались в глаза и служили предметом шуток.

- О, Аллах, - прошептал Джафар. Он знал, что в данной ситуации просто не сможет подойти к Марату - слишком зловещей была обстановка. - И с этим чудовищем мы должны работать...

Но Джафар не успел сообразить, что же делать, - слева от него изнутри в одну из дверей холодильника раздался страшный удар, металлические листы выгнулись, покорежив петли и задвижку. Джафар не удержался и сел на пол. Удар повторился снова, одна из петель сорвалась, и винты, удерживавшие ее в стене, со скоростью пули пронеслись через зал и разбили несколько закрашенных белой краской окон, выходящих на улицу.

Человек, поглощавший чужие внутренности, медленно поднялся и повернулся лицом к двери морозилки. Джафар отчетливо услышал какие-то слова, произносимые им, потом людоед сделал несколько шагов, но после третьего удара в дверь остановился, словно в ожидании.


Спецвыпуск Xakep, номер #020, стр. 020-088-15, The Matrix Fuck You

The Matrix Fuck You

Спецвыпуск Xakep, номер #020, стр. 020-088-15

- The Matrix fuck you, - отчетливо услышал фразу на английском языке Джафар, после чего нервы его не выдержали, и он поднялся с пола в полный рост. Перед ним стоял человек с лицом и руками, вымазанными кровью. Кровь стекала по его рубашке, брюкам, рукавам; это был не Марат.

- Морфеус? - удивленно поднял брови неизвестный. - ТЫ ОПОЗДАЛ. Но если хочешь, присоединяйся, - и он махнул рукой на труп, лежащий на кафеле с раскрытым животом.

Джафар молча поднял пистолет и всадил людоеду пулю между глаз. Тот отлетел на несколько метров и упал прямо на свой обед, уткнувшись лицом в лужицу крови. Эхо выстрела слилось с четвертым ударом в дверь морозильника, после которого она слетела с петель и со страшным грохотом рухнула на кафельный пол...

Набрать номер удалось не сразу - человеку, раньше не сталкивавшимся с мобильными телефонами, да и пейджер видевшего только в руках у друзей, это оказалось довольно сложной задачей. Алексей нервно нажимал кнопки в надежде услышать сигнал в трубке, но что-то не ладилось в его логических схемах, он путал, какие кнопки уже нажимал, какие последовательности использовал, - в общем, ничего не получалось.

Он отложил в сторону первый телефон, взял второй и попытался поступать методичнее. Вскоре долгожданный сигнал загудел в его ухе мелодичной нотой. Тогда встал второй вопрос - куда звонить. Спасателям - такого телефона Алексей не знал. В милицию - кроме номера «02», доктор не знал других с самого детства, но имел понятие о том, что номер несколько преобразился с течением времени - то ли «002», то ли как-то еще... Друзьям, знакомым - как объяснить им, что происходит? И тут на ум пришло самое элементарное - «03». Врач врача всегда должен понять, решил Алексей. Подумав несколько минут над тем, как он все преподнесет диспетчеру, который ответит на его звонок, он набрал заветные цифры.

После первого же гудка Алексей почувствовал неладное - в глазах замерцало розовое сияние, звук из трубки отдалился на несколько метров.

- «Скорая» слушает, говорите, - донеслось до Алексея будто сквозь вату. - Говорите, вас не слышно...

- Да, сейчас, минуточку, - прошептал Алексей, чувствуя, как у него слабеют ноги. - Я врач... Мне нужна помощь...

- Говорите громче, - возмущенно ответила диспетчер. - С кем я говорю? Если это шутка, то знайте, что номер вашего телефона будет определен, и вас накажут...

- Мне нужна помощь... - повторил Алексей. - Меня закрыли в морозильном шкафу...

- Чушь какая-то, - куда-то в сторону сказала диспетчер, - ничего не слышно. Шепчет там что-то... Каждый второй звонок будто с Луны - ничего не разберешь...

Это было последнее, что услышал Алексей из мобильника, не подозревая, что назад дороги уже нет. Потом мозг заволокло пеленой, он лениво опустил телефон назад на труп Марата и, закатив глаза, распластался на ледяном столе рядом с покойниками.

- Королев, вы слышите меня?

Лейтенант незаметным движением поправил пимпочку в ухе и ответил:


Спецвыпуск Xakep, номер #020, стр. 020-088-16, The Matrix Fuck You

The Matrix Fuck You

Спецвыпуск Xakep, номер #020, стр. 020-088-16

- Да, товарищ майор.

- Где вы сейчас?

- В машине рядом с университетским моргом. «BMW» Джафара стоит в нескольких метрах от меня. В ней никого нет. Разрешите приступать к операции?

- Секунду. Есть информация. Я получил ее... Впрочем, неважно. Помнишь, Джафар назвал Марата «высокотехнологичным агентом»?

Лейтенант вспомнил последнюю прослушку, которую они вместе с майором изучали при составлении плана операции.

- Да, припоминаю, Петр Григорьевич.

- Джафар, сам того не зная, оказался очень близок к истине. Марат предлагает к продаже самые последние разработки в сфере информационных войн - технологии и их продукты, способные пригодиться профессиональным хакерам, компьютерным террористам и вообще - военным, которые ставят себе целью уничтожение противника путем информационного оружия. Сейчас Марат пошел дальше - он имеет связи с теми, кто испытывает оружие с воздействием на психику - психогенераторы малых габаритов и огромных мощностей. У него с собой должно быть нечто, в чем хранится это оружие - какие-то небольшие по габаритам предметы, способные вместить в себя маленькие генераторы поля...

- Я буду внимателен, Петр Григорьевич...

- Я не о том, Королев. Будь осторожен. Предельно осторожен. Этот человек сводит своим оружием с ума. Я бы не хотел увидеть твои мозги на асфальте, но еще меньше я хотел бы знать, что они на месте, но их хозяин перестал быть человеком. Мы отследили цепочку проникновения товара в Россию - пусть не всю, но и этого достаточно. Поэтому я, как руководитель операции, даю тебе полную свободу действий, вплоть до физического уничтожения Марата. И самое главное - ничего не трогай. Все, что принадлежит Марату - любая мелочь от заколки для галстука до его «Мерседеса» - может оказаться потенциально опасным.

Лейтенант молча переваривал полученную информацию и мягко поглаживал пистолет.

- Ты понял мой приказ, Королев?

- Да, Петр Григорьевич. Уничтожить агента любой ценой.

- Не совсем так, но... БЕРЕГИ СЕБЯ.

Лейтенант кивнул вместо ответа, вытащил наушник и, кинув его на сиденье, направился к чугунным воротам.

Первое, что осознал Алексей, очнувшись на полке рядышком, - темнота. Потом пришло понимание холода и ограниченности пространства. Доктор безумными глазами вглядывался во мрак, окружающий зеленые круги с телефонами в центре. Дрожь крупными волнами сотрясала тело, доктор шумно дышал, пытаясь определить, где он находится.

Он вел себя сейчас как пчела, которая влетела в окно и не может вылететь обратно - стучась в невидимое для нее стекло, она не понимает, почему на ее пути возникает преграда. Так и Алексей - шарил руками по стенам, тыкаясь в них локтями и коленями, как слепой котенок. Неожиданно он понял, что та стена, около которой он сейчас оказался, является выходом, пусть и крепко закрытым. Он очень обрадовался этому и громко, во весь голос, засмеялся. Смех вышел жутким, быстро угасшим в тесноте морозильника.

Доктор вернулся туда, где лежали три телефона, взял один в руки, стал его рассматривать, как обезьяна рассматривает калькулятор. Два он сунул в карман халата, третий взял в руку и принялся нажимать кнопки; из аппарата донесся гудок, потом чей-то голос произнес: «Опять с этого номера звонят, черт его подери! Это, наверное, сотовый - видите, номер не определяется... Не треплите «Скорой помощи» нервы, дорогой товарищ!».


Спецвыпуск Xakep, номер #020, стр. 020-088-17, The Matrix Fuck You

The Matrix Fuck You

Спецвыпуск Xakep, номер #020, стр. 020-088-17

Вдруг до него донесся какой-то шорох из-за двери. Он настороженно прислушался. За дверью что-то упало. Звук падения почему-то очень обрадовал доктора. Он вновь громко рассмеялся, потом ощупал руками все вокруг себя, определил границы коридорчика вдоль полок, по которому будет разбегаться (он даже не задумывался над тем, сможет ли он открыть металлическую дверь - его мозг не видел вокруг ничего невозможного, все было просто, реально, выполнимо). И в этот момент к холоду и территориальному инстинкту присоединился еще один раздражитель - голод.

Алексей провел рукой по полке, определил контуры мертвых тел, после чего вытащил из кармана секционный нож и распорол одежду на Марате...

Королев следовал путем Джафара. Он заходил в те же самые комнаты, осматривал все возможные места, где мог находиться Марат, но, так же, как и Джафар, не нашел ничего, кроме доказательств того, что в здании есть живые люди. Он попытался определить, где они могут находиться, но в голову не пришло ничего. Он вышел в коридор, постоял неподвижно, осмысливая происходящее.

Самое главное - что Марат делает в таком экзотическом месте? Зачем суперторговец со своим супертоваром забрел в морг? Кому он может предложить свои психогенераторы в этом заведении? Неужели кто-то здесь собрался ставить эксперименты на покойниках...

Королев зябко передернул плечами, с трудом представляя себе, как все это может выглядеть, после чего, крепче обхватив рукоять пистолета, сделал несколько шагов по коридору к лестнице, ведущей на второй этаж. И в этот момент за его спиной, в секционном зале, раздался жуткий металлический грохот, в котором опытный слух лейтенанта выделил звук выстрела из пистолета «ПМ».

Королев быстро прижался к стене (как будто у них школа с Джафаром была одна) и направил ствол пистолета в ту сторону, откуда донесся выстрел. Кто-то закричал - громко, пронзительно, но не по-женски - кричал мужчина, чем-то напуганный до предела.

С лестницы донеслись быстрые шаги - еще один человек мчался со второго этажа вниз на крик. Человек, выскочив с лестничной площадки и увидев лейтенанта с пистолетом, откровенно растерялся. Тот же, разглядев в руке незнакомца «ПМ», не стал долго раздумывать. Прыжок в сторону - в том месте, где он только что стоял, разлеталось облако кафельных крошек - растерянность не отразилась на стрелковых качествах противника. Кувырок, выстрел, еще кувырок, еще выстрел - для гарантии, так как уже после первого он понял, что попал. И уже стоя спиной к дверям в секционный зал, Королев понял, что они отворились...

Наелся он быстро. Его не удивлял способ утоления голода; его не удивляло виртуозное владение секционным скальпелем и знание анатомии - ничто не могло поколебать Алексея. Он вытер скальпель о халат, воткнул его в тело Марата, разбежался и плечом со всей силы ударил в запертую дверь. Ледяные иглы брызнули в лицо - он не обратил на них внимания, только понял, что дверь поддалась.


Спецвыпуск Xakep, номер #020, стр. 020-088-18, The Matrix Fuck You

The Matrix Fuck You

Спецвыпуск Xakep, номер #020, стр. 020-088-18

Алексея вообще не удивило изменение в собственном физическом статусе - он только что едва не вышиб плечом дверь, которую практически невозможно сдвинуть с места. Он просто продолжил. Со второго раза в образовавшуюся щель хлынул ярчайший свет из зала. Доктор прищурился и ударил еще раз; звук срывающихся петель обрадовал его, он довольно засмеялся, не обращая внимания на онемевшее плечо.

Когда дверь окончательно рухнула на пол, Алексей остановился в дверях, увидев перед собой человека с пистолетом. Что-то в лице этого человека заставило доктора сделать несколько шагов в глубь своей тюрьмы и выдернуть из трупа Марата секционный нож.

Именно этот жест и довел Джафара до безумного крика. Когда он увидел в проеме человека с лицом зверя - лицом, испачканным кровью, лицом, ничем не отличающимся от только что им застреленного хищника в человеческом обличье, - его нервы сдали окончательно. Он дико закричал и сделал несколько шагов назад.

Доктор вышел наружу с ножом в руках, огляделся и направился к Джафару. У него не было цели убить кричащего человека - но он очень хотел, чтобы тот замолчал.

Из коридора донесся звук нескольких выстрелов - глухих, далеких. Джафар машинально оглянулся в сторону двери - и тут же получил удар ножом в живот. Пальцы рук судорожно сжались в кулаки, пистолет в его руке сухо треснул выстрелом, и на голову Алексея осыпалась лампа дневного света.

На лице доктора отразилось сожаление - то ли по поводу вспоротого живота, то ли по поводу разбитой лампы. В очередной раз вытерев нож о халат в том месте, где уже образовалась кровавая полоса, Алексей распахнул двери в коридор.

В двадцати метрах от себя он увидел человека, стоящего к нему спиной. Алексей довольно клацнул зубами, поудобнее сжал нож и пошел вперед.

Королев, чувствуя, как его сердце готово выскочить из грудной клетки, обернулся. Он был готов ко всему, но то, что он увидел, превзошло все его ожидания. К нему направлялся окровавленный монстр со скальпелем в руках в заляпанном рыжими пятнами халате. В этом жутком облике Королев с трудом определил врача - по большому яркому бэйджу на нагрудном кармане. Самым страшным в надвигающемся кошмаре были глаза - пустые, наполненные зовом крови...

Лейтенант не стал делать предупреждающий выстрел - мушка будто сама поднялась на уровень головы врача. Остановить Алексея Королев смог только с третьего выстрела...

А потом он обыскал карманы халата...

Устав от попыток связаться с лейтенантом, майор сам с группой поддержки отправился в морг. Найденные в коридоре трупы азиата и патологоанатома заставили спецназовцев отнестись к операции со всей серьезностью - они перестроились в боевой порядок и отработали все помещения первого этажа по полной схеме.

Майору доложили, что путь свободен. Он медленными шагами ступил на кафельный пол секционного зала с нехорошим предчувствием. Командир отряда спецов уже доложил ему, что в одном из холодильников найдено тело агента, причем истинная причина смерти виду обширности повреждений тела может быть установлена только с помощью судебных медиков. «А где же Королев?» - спрашивал себя майор. Лейтенанта нигде не было.


Спецвыпуск Xakep, номер #020, стр. 020-088-19, The Matrix Fuck You

The Matrix Fuck You

Спецвыпуск Xakep, номер #020, стр. 020-088-19

Вдруг одно из тел, лежащих на столах, зашевелилось. Спецназовцы, словно по команде, отскочили в стороны и навели автоматы на поднимающегося человека. Майор закрыл ладонями лицо...

Со стола вставал абсолютно голый Королев. Глаза его отсутствующим взором обвели солдат, после чего остановились на лежащих у стены Викторе и его «жертве». Лейтенант приблизился к ним, опустился на корточки и, отвалив в сторону мертвого санитара, запустил руку в раскрытое брюхо. В другой руке он по-прежнему сжимал телефон, который вытащил из кармана Алексея, чтобы сообщить майору о выполнении операции...


Спецвыпуск Xakep, номер #020, стр. 020-098-1, FAQ

FAQ

Спецвыпуск Xakep, номер #020, стр. 020-098-1

Матушка Лень (MLen@mail.ru)

Что такое SIM-карта?

Сим-карта - это такой маленький чип, который нужно впихнуть в твою мобилу, чтобы подключить ее к сотовой сети. На этом чипе живут процессор и память. В памяти зашиты настройки твоего телефона и коды доступа к сотовой сети твоего оператора.

Не во всех телефонах есть возможность подключения такой карточки, коды доступа к сети в таких телефонах зашивают им в память через специальный шнурок.

По-простому, такая карта - сменный кусок мозга твоей мобилы, который хранит память о том, какой у тебя оператор.

Что такое база?

У любого радиотелефона должна быть база. Это такая мощная радиостанция, которая подключена к телефонной сети (проводам). У домашнего радиотелефона база стоит дома, подключенная к телефонному кабелю. Радиотелефон связывается с базой, база набирает номер и соединяет тебя с твоими друзьями для трепа.

Мобильный телефон тоже связывается со своей ближайшей базой, и его база тоже набирает номер и соединяет с другой базой - другим мобильным телефоном - либо соединяет с телефоном из городской сети.

Что такое зона покрытия?

Это такая область, в которой хорошо принимаются радиоволны. Зона покрытия бывает у спутников, у телевидения, у радио и у твоего сотового оператора. Если ты со своим мобильником вылез за пределы зоны покрытия, то связь будет хреновой или ее не будет вообще.

Покрытие зависит от количества и мощности базовых станций. Чтобы работала твоя мобилка - нужна база поблизости. Если база далеко или сигнал от нее не проходит, то связь плохая или ее нет вообще.

Что такое радиочастота?

Разные устройства работают на разных частотах. Это удобно. Меняя частоту, ты можешь настроиться на радиостанцию с помощью приемника, телевизор тоже настраивается на частоту телеканала. Сотовые телефоны тоже работают на своих частотах; чтобы связаться с сотовой базой, нужно настроиться на ее частоту.

Что такое телефонная сота?

Сотовые работают на высоких частотах. Известно, что чем ниже частота, тем дальше летит сигнал, тем лучше он огибает препятствия. Так вот, сигнал от сотовой базы летит не очень далеко, и поэтому базы стоят близко друг к другу. А чтобы не мешать друг другу, соседние базы используют разные частоты для связи с мобилками. Но частот мало, поэтому на базах, которые подальше, снова используются те же частоты. Получается чередование нескольких стандартных частот - соты. По-простому, частоты сложены в мозаику так, чтобы соседние были разными.

Можно ли по мобиле определить, где я?

Можно, но не точно. Легко определяется сота, в которой работает твоя мобила. Причем не важно, звонишь ты или нет. Если мобила включена и ждет звонка, она все равно связана с сотой. Сота - это целый район. Получается, что сотовый оператор может без труда следить за тем, в каких районах ты бываешь и даже сохранять твои перемещения. Тебе тоже есть плюсы от этих возможностей: в зависимости от соты твоя мобилка может выдавать тебе адреса ближайших клубов, магазинов, сервис центров. Но есть плюсы и для спецслужб. Правда, чтобы отыскать тебя в данном районе, нужно тебя пеленговать. А пеленговать мобилу сложнее, чем рацию или спутниковый телефон, ведь вокруг на той же частоте работает еще сотня телефонов.


Спецвыпуск Xakep, номер #020, стр. 020-098-2, FAQ

FAQ

Спецвыпуск Xakep, номер #020, стр. 020-098-2

Что такое GPS?

Global Positioning System - глобальная система позиционирования. С помощью устройства GPS можно точно определить свои координаты на местности, а дальше их прилепить на уже существующую карту. Стоит это дорого, т.к. технология спутниковая. А рассказываю я про это потому, что некоторые путают GPRS и GPS.

Что такое GPRS?

General Pocket Radio Service - пакетный радио сервис. Если этот стандарт поддерживает твой мобильник, то ты сможешь пользоваться всеми прелестями пакетной радиосвязи: передавать видео, картинки, данные и просто серфить по Инету. Это можно делать прямо с сотового телефона или через ноутбук. Причем платишь ты не за потраченное время, а за траффик.

Телефоны с этой технологией сильно дороже обычных, да и оператору сотовой связи это тоже недешево обходится. Зато скорость высокая.

Что такое WAP?

Wireless Access Protocol - протокол беспроводного доступа. По этому протоколу можно лазить в Инете через телефон. При этом телефон не требует каких-то изысков, кроме специального WAP браузера. Но лазить можно не по всем страничкам в Инете, а только по тем, которые написаны на языке WML, при этом только в текстовом режиме. За мобильный WAP Интернет ты платишь повременно. Картинки, видео и обычные сайты тебе недоступны, зато телефон дешевле.

Что такое пакетная радиосвязь?

Это когда по радио бегают данные в цифровом виде (пакеты). Получается, что звук, видео и вообще любая инфа кодится в цифровой вид. Это удобно тем, что по одному и тому же радиоканалу ты можешь передавать практически любой вид инфы. Это неудобно тем, что телефоны и коммутаторы с поддержкой пакетной радиосвязи стоят дороже обычных.

В мобилках пакетную радиосвязь стали использовать недавно, хотя в радиорелейных линиях, в радиомодемах и в радиолюбительской связи этот способ используется уже очень давно. Например, радиолюбители умеют передавать компьютерные картинки через свои радиостанции.

Зачем нужна направленная антенна?

Если ты живешь в непроходимой глуши, то направленная антенна позволит тебе достать твоей мобилкой базу на расстоянии 30 километров. Конечно, антенну нужно будет купить под конкретный телефон и правильно настроить. Размером она, скорее всего, будет с целую руку (от плеча до пальцев). А привинчивать ее придется повыше да так, чтобы никакие препятствия не мешали. Антенна должна смотреть в сторону базы.

Что такое абонентский комплект?

Это интерфейс АТС, к которому подключается другой конец провода твоего телефона. Абонентский комплект посылает тебе в трубку длинный гудок, когда свободно, и короткие, когда занято. Он заставляет твой телефон звонить и запитывает его, когда трубка на телефоне.

Многие фрикерские устройства рассчитаны на дырки в работе этого интерфейса с АТС, есть много возможностей обмануть абонентский комплект. Для разработки таких устройств фрикеры иногда эмулируют комплект на модеме. Для этого они заставляют модем вести себя как комплект.


Спецвыпуск Xakep, номер #020, стр. 020-098-3, FAQ

FAQ

Спецвыпуск Xakep, номер #020, стр. 020-098-3

Что такое бипер?

Устройство, которое генерит тональные сигналы. Практически любой современный телефон имеет тональный режим набора. Тоновые сигналы нужны для управления на расстоянии факсами, автоответчиками, телефонными карточками или взрывными устройствами, подключенными к телефону. Бипер умеет генерить эти тоновые сигналы, если его приложить к телефонной трубке. Т.е. портативный бипер используют с телефонами, у которых нет тонового набора.

Бывают биперы, которые можно программировать. С помощью такого устройства можно подделать телефонный номер. Т.е. номер будет определяться неправильно. Часто фрикеры используют в качестве бипера модем с голосовыми функциями.

Как определяется телефонный номер?

Современные АТС посылают тональную посылку. Каждый писк - цифра твоего номера. Иногда можно услышать такую тональную трель, когда снимаешь трубку на телефоне. Некоторые АТС отправляют номер только по запросу определителя номера. Чтобы номер не определился, фрикеры глушат тональные сигналы антиопределителем номера. Подделать номер проще всего, когда он вообще не определяется. Тогда можно посылать ложный номер вместо АТС. Если АТС умеет посылать номер сама, то подделать его сложнее.

Что такое прямое подключение?

Это когда фрикеры подключились к твоей телефонной лапше и звонят с нее по междугороднему. Дело это стремное, т.к. место подключения можно легко найти, пустив монтера щупать кабель. Поэтому фрикеры обычно подключаются к лапше только на время разговора. В нашей стране это сделать проще простого, т.к. телефонные коробки открыты и туда может залезть каждый. Такому фрикеру достаточно иметь телефон-трубку с двумя крокодилами на концах.

Что такое подсесть на частоту?

Если у тебя радиотелефон, то на его частоту может подсесть фрикер. И звонить в далекие страны с твоего номера. Некоторые современные телефоны имеют защиту от такого подключения, только стоят они дороже. Поэтому у большинства людей обычные радиотрубки, к которым легко подключиться. Иногда в центре крупного города можно поймать чью-то базу на обычную телефонную трубку.

Что такое сканер частот?

Такой девайс, который умеет перебирать радиочастоты. В зависимости от надобности под сканер можно приспособить радиолюбительскую станцию или компьютерный TV-tuner, или трубку от обычного радиотелефона. Сканер без компьютера вещь мало полезная. Сканер должен быть умным. Например, чтобы сесть на чью-нибудь телефонную базу, он должен послать запрос чужой базе и дождаться ответа. Или даже подобрать секретный код, если понадобится. Для этого в мобильный сканер ставят микропроцессор, а для компьютерного пишут программу. Также перебирая частоты и посылая запросы, сканер может отключить сигнализацию автомобиля.

Как защитить свой телефон от фрикеров?

Домашний телефон защитить просто: нужно поставить блокиратор цифры 8. Этот девайс легко покупается на радиорынке или в магазине. Его подключают между телефоном и розеткой, он не дает набирать восьмерку. Конечно, фрикеры смогут звонить по твоему телефону, но только в пределах твоего города.


Спецвыпуск Xakep, номер #020, стр. 020-098-4, FAQ

FAQ

Спецвыпуск Xakep, номер #020, стр. 020-098-4

Еще можно попросить телефонистов, чтобы поставили на восьмерку пароль. Тебе придется набирать его в тоновом режиме. Фрикерам будет лень ломать пароль, и они подключатся к твоему соседу.

Что такое сотовый двойник?

Когда чужие люди пользуются номером и счетом твоей мобилы с другого телефона. Раньше это было реально. Сейчас многие связисты научились с этим бороться. Можно легко определить, в какой соте твой телефон, это обязательно фиксируется. И если один и тот же телефон одновременно появится в двух сотах, то система его автоматически заблокирует.

Чем SMS отличается от сообщений на пэйджер?

SMSка - короткое текстовое сообщение, которое можно посылать с одной мобилки на другую. Разница в том, что ты не знаешь, дошла ли мессага до пэйджера. Мессага может потеряться по дороге, и никто ее не получит. SMSка будет отправляться до тех пор, пока телефон ее не примет и не подтвердит получение.

Что такое сервисное меню?

Практически на каждом умном бытовом приборе есть сервисное меню. Это меню для инженеров, которые чинят и настраивают прибор. Такое меню позволяет творить с устройством все что угодно. На любом мобильном телефоне тоже есть сервисное меню. В этом режиме телефона ты можешь вводить команды, которые разлочат телефон, добавят новые функции в обычное меню, добавят новые возможности для твоего телефона. Как войти в сервисное меню твоего телефона, нужно узнавать специально для твоей конкретной модели.

Что такое SMART карта?

Умная карта с чипом на борту. Чип - карточные мозги, как ты понял. SIM-карта - разновидность умной карты. Некоторые уличные таксофоны тоже работают на карте с чипом. На-SIM карте мобильника и на карте таксофона видны контакты, через которые можно подключиться к чипу.

Есть еще бесконтактные SMART карты. Подключение к чипу такой карты происходит по радио, бесконтактно. Такие карты используют студенты в московском метро. Чтобы пройти турникет, нужно просто приложить карту к приемнику.

Можно ли заправить таксофонную карту?

Заправить уже использованную карту нельзя, т.к. на чипе пережигаются перемычки, когда с карты снимают единицу разговора. Назад эти перемычки восстановить нельзя. Поэтому разные схемы для заправки карт из Интернет давно уже не работают.

Однако можно клонировать таксофонную карту. Для этого тебе придется заставить микропроцессор работать так же, как процессор карты. А еще тебе понадобится неиспользованная карта, для того чтобы скопировать ее на пережженную память. По-простому ты должен взять другой микропроцессор и его запрограммировать. При этом выводы микропроцессора нужно соединить с выводами таксофонной карточки. Родной процессор карты при этом придется отковырять.

Изготовление микропроцессорного клона таксофонной карты долгое и дорогое дело. И потом тебе все равно придется покупать новую карту, чтобы считать ее память в память клона.

Что такое микропроцессор?

Микропроцессор - маленький готовый компьютер в корпусе микросхемы. У него есть своя память для хранения программ, своя оперативная память для хранения переменных, свои порты. В микропроцессор может быть встроен аналоговый порт.


Спецвыпуск Xakep, номер #020, стр. 020-098-5, FAQ

FAQ

Спецвыпуск Xakep, номер #020, стр. 020-098-5

Микропроцессоры стоят в телефонах, в SMART картах и многих других девайсах, поэтому, если ты умеешь программировать микропроцессоры, то тебе будет проще фрикать разные девайсы.

Многие фрикерские устройства (сканеры, эмуляторы, биперы) делают на базе микропроцессора. Иногда можно сделать из обычного устройства фрикерский девайс, если заменить там микропроцессор или перепрограммировать его.

Что такое программатор?

С помощью этого устройства можно зашить память. Например, можно сменить микропрограмму сотового в памяти сотового телефона, и он превратится в сканер, или можно сменить микропрограмму у пагера, и он станет прослушивать все сообщения. Или можно скопировать память SMART карты и наделать клонов. Для того чтобы зашить готовую программу в память микропроцессора, тоже нужен программатор.

Для разных устройств, разных SMART карт, разных микропроцессоров нужны разные программаторы. Программатор можно купить готовый либо собрать самому. Все современные программаторы позволяют готовить и отлаживать микропрограмму на компьютере. На древних программаторах приходилось набирать адрес каждой ячейки памяти вручную.

На каком языке программируют микропроцессоры?

Микропроцессор понимает только в машинных кодах. Т.е. у каждой микрокоманды есть свой двоичный код и у каждой ячейки памяти есть свой двоичный адрес. Но поскольку программу для микропроцессора теперь пишут на компе, то теперь можно писать на Ассемблере, на СИ и даже на Паскале. Компьютерный компилятор переведет эти программы в машинные коды, и ты сможешь залить их через программатор в свой микропроцессор. Естественно, для каждого микропроцессора нужен свой компилятор.

Программы лучше писать на Ассемблере, потому что он ближе всего к машинным кодам. У микропроцессора очень маленькая скорость и очень мало памяти, поэтому толстые программы Паскаля будут работать криво.

Что такое стандарты?

Все телефонные, радио, компьютерные интерфейсы имеют стандарты. Стандарты нужны для того, чтобы интерфейсы разных фирм были совместимы. Стандарты определяют логику и электронику работы многих важных блоков в телефонии и связи.

Для того чтобы понять, как работает АТС, радиотрубка или сотовый - читай стандарты. Если ты будешь знать, как это работает, то сможешь придумать, как это фрикнуть. Обычно способы фрика придумывают единицы, которые разбираются в стандартах и в электронике. Все остальные пользуются готовыми рецептами, купленными за деньги или разведанными по знакомству. Фрикерские рецепты из Интернета обычно либо не работают, либо их давно пофиксили телефонисты. Хотя свежий рабочий секрет ты сможешь купить через сеть или на радиорынке.

Что такое закрытые стандарты?

А вот тут-то самая сложность. Некоторые фирмы сочиняют свои стандарты, и их открыто нигде не прочитаешь. Поэтому фрикеру приходится самостоятельно исследовать новый интерфейс или блок. Инфу по закрытым стандартам можно также стянуть через знакомых в сервис центре или найти в сети.


Спецвыпуск Xakep, номер #020, стр. 020-098-6, FAQ

FAQ

Спецвыпуск Xakep, номер #020, стр. 020-098-6

Чем отличаются аккумуляторы на основе никеля и лития?

Аккумуляторы на основе лития меньше по размеру, живут в несколько раз дольше и стоят дороже. Раньше литиевые аккумуляторы взрывались и портили лицо владельцу мобильного телефона, но теперь этот недостаток перебороли. Осталось добиться только того, чтобы литиевые аккумуляторы стали дешевле. Литиевый аккумулятор понадобится, если твой телефон тонкий, легкий и дорогой или если нет возможности его часто заряжать. Если твою гробоподобную мобилу есть возможность заряжать раз в два-три дня, то литиевый аккумулятор тебе не нужен.

Как воруют инфу из кабеля?

Конечно, проще просто подключиться к кабелю. Но такое подключение можно легко обнаружить. Поэтому к кабелю подключаются через трансформатор. Кусок кабеля и кусок левого провода наматывают на сердечник. Получился трансформатор, теперь нужно подключить хороший усилитель к проводу и можно слушать телефонные разговоры. Если по кабелю инфа бежит в цифровом виде, то ее нужно расшифровывать на компьютере.


Спецвыпуск Xakep, номер #020, стр. 020-102-1, КНИЖКИ

КНИЖКИ

Спецвыпуск Xakep, номер #020, стр. 020-102-1

Frozen (frozen@real.xakep.ru)

Редакция выражает благодарность магазину "Библио-Глобус" за предоставленные книги.

Книг по телефонии вышло немалое количество, но, к сожалению, только в некоторых из них можно найти реально полезную и нужную инфу. Для того чтобы тебе не пришлось использовать только что купленную буку по непрямому назначению, я постарался выискать самые интересные и информативные книги, в которых содержится достойная для твоего чтения информация.

Л.Я. Котенко, А.М. Бревда. Электронные телефонные аппараты - СПб.: Наука и Техника, 2001 - 192 с.

Эта книжка может стать полезной, если ты решил всерьез запариться над устройством и работой электронных телефонов. Вся инфа здесь делится как бы на две части: в первой тебе расскажут об общих принципах устройства этих весьма нужных аппаратов (т.е. из каких узлов он состоит, какие микросхемы за что отвечают etc...), а во второй части покажут все это на конкретных примерах. В книге содержится куча схем, так что, осилив сей талмуд, ты сможешь спаять на коленке свой собственный телефон без особого труда.

Особенно пригодится продвинутым "телефонистам" и тем, кто хочет разобраться в принципах работы электронного телефона.

Средства мобильной связи - СПб.: БВХ-Петербург, 2001 - 256 с.

В.И. Андрианов, А.В. Соколов. Сотовые, пейджинговые и спутниковые средства связи - СПб.: БВХ-Петербург, 2001 - 400 с.

Пожалуй, эти книжки могут стать основой для дальнейшего изучения устройства и работы систем сотовой связи. Здесь тебе подробно объяснят, почему телефон называется сотовым, по какому принципу происходит передача информации через спутник и как реализуется "роуминг по всему миру". Про все это рассказывается достаточно подробно и понятно, со схемами устройства сот и пролета :) спутника над Землей, так что станет ясно даже гуманитарию :). Описания работы даются общие, зато расскажут про самые известные на сей момент фирмы и их разработки в области сотовой связи. Различие между двумя экземплярами лишь в том, что во второй книге еще и рассматриваются принципы работы пейджинговой связи, а остальное все то же, что и в первой.

Рекомендуется для общего ознакомления с работой "маленького друга, который всегда с тобой" (c) by какая-то реклама.

А.В. Росляков, М.Ю. Самсонов, И.В. Шибаева. IP-телефония - М.: ЭКО-ТРЕНДЗ, 2001 - 252 с.

IP-телефония все больше входит в нашу жизнь, поэтому оставить в стороне эту тему я никак не смог. Эта книга - из раздела must read, ведь в ней тебе расскажут все по сабжу плюс куча схем работы сетей IP-телефонии (с подробными комментариями) и множество полезного про устройство различных протоколов, принятых для передачи голоса на расстояние. Также тут можно почерпнуть кучу информации про устройство электронных АТС и о том, как происходит согласование телефон-АТС-компьютер. Вся книжка написана достаточно грамотным и понятным языком, так что с поиском информации проблем возникнуть не должно.

Рекомендуется людям, у которых есть желание освоить такую современную область, как IP-сети и IP-телефония.

А.Г. Жданов, Д.А. Рассказов, Д.А. Смирнов, М.М. Шипилов. Передача речи по сетям с коммутацией пакетов (IP-телефония) - СПб.: СПбГУТ, 2001 - 148 с.


Спецвыпуск Xakep, номер #020, стр. 020-102-2, КНИЖКИ

КНИЖКИ

Спецвыпуск Xakep, номер #020, стр. 020-102-2

А вот этот экземпляр является примером того, как не надо писать книги, - сюда попытались уместить столько тем, что и для энциклопедии, наверное, много будет. Если книжка про передачу речи по сетям, то зачем впихивать столько ненужной инфы?.. Хотя я догадываюсь, зачем: практически на каждой десятой странице находится реклама какого-нибудь провайдера или фирмы, связанной с телефонией. В общем и целом, в этой книге слишком мало инфы для ознакомления, к тому же написано все как-то сыро и неясно...

Рекомендуется тем, у кого некуда деть деньги и авторам для чтения перед сном...

И. Иванов. Регистрация трубок радиотелефонов - М.: СОЛОН-Р, 2001 - 64 с.

У тебя есть радиотелефон, и ты не знаешь, как подрубить к нему дополнительную трубу? Или ты не знаешь, как установить импульсный набор номера для своего наикрутейшего панасоника? Тогда данная, и я не побоюсь этого слова, книжка поможет тебе. Хотя с книжкой я, наверное, погорячился - это скорее небольшой справочник, с помощью которого ты узнаешь, как у многих современных радиотелефонов настроить те или иные функции. Содержания в хм... справочнике нету совсем, и вся инфа представлена в виде таблиц, на уровне какую пимпу на девайсе нажать, чтобы сделать то-то. Вот в принципе и все, что об этой брошюре можно сказать.

Пригодится "начинающим радиомастерам, занятым ремонтом и обслуживанием домашних телефонов".

В.Ю. Красик. Телефон - М.: Топливо и Энергетика, 2000 - 472 с.

Фуф, пришло время отдышаться и немного передохнуть от такого обилия технической информации и терминологии, а поможет в этом следующая книжка-энциклопедия. Красиво оформленное издание представляет собой практически полный фотоархив всевозможных телефонов. На страницах можно найти как самые первые модели телефонных аппаратов - этакие большие коробки, с трубой, в которую нужно было орать, так и более современные и миниатюрные. К картинкам прилагается подробное описание, когда, где и кем был собран какой девайс. К недостаткам можно отнести только отсутствие привычных 32х бит цвета: все картинки, как на старых Электрониках, предлагаются в монохромном режиме.

Рекомендуется для общего ознакомления с историей развития телефона.

В.В. Павлов, В.И. Астрахан, В.Г. Чернега, Б.Г. Чернявский. Правительственная электросвязь в истории России - М.: Наука, 2001 - 368 с.

Ну и напоследок немного истории. В этой книге тебе расскажут, какими средствами связи пользовались руководители государства лет 50-70 назад и как они предохранялись :) от прослушивания. Много интересного можно узнать, например, о способах шифрования телефонных разговоров во время революции, когда не было таких продвинутых систем связи, как сегодня. Довольно хорошая книга, к тому же рассказывается обо всем легким и простым для восприятия языком, также имеются в наличии и фотографии с разными шифровками и шифровальными системами прошлого (теперь ты точно сможешь представить, как обменивались информацией Штирлиц и радистка Кэт).


Спецвыпуск Xakep, номер #020, стр. 020-102-3, КНИЖКИ

КНИЖКИ

Спецвыпуск Xakep, номер #020, стр. 020-102-3

Подойдет пиплам, желающим вступить в ряды ФСБ, т.к. в конце дан адрес и телефончик этой секретной академии, а там уж, наверное, точно потребуются такие знания.

Все, пишите письма, высылайте пиво...