Спецвыпуск Xakep, Содержание номера # 017

Cover 017 |
Статья | Стр.
Intro | 001
Контент | 002
ОБЗОР |
Обзор фривар и шаровар сайтов | 004
Обзор варезных серваков | 008
КРЕАТИВ |
Компьютерные трубадуры: музстудия на домашнем писюке | 012
"DivX ;) Был, есть и будет есть!" | 018
"DivX ;), MPEG-4 и DVD-фильм на одном CD" | 024
Глумимся над фото: подлый софт | 030
АПГРЕЙД МОЗГОВ |
Студтехнософт: тебе, технарь. | 034
Софт студента-гуманитария | 040
Эмулятор паяльника: софт для радиолюбителя. | 046
COVER STORY |
"1C - знай наших!" | 050
Adobe Illustrator - мегакреативный патрон в обойме дизайнера | 054
Бухгалтерия программисту по колено: как стать 1С-кодером | 060
"Работай в 3DS MAX" | 062
QuarkXPress | 064
PhotoShop | 068
Администрирование win-сетей | 072
Обзор книг | 076
Обзор курсов | 078
БОЛТЫ & ГАЙКИ |
Advanced загрузочный nix-флопарь | 080
Advanced загрузочный win-флопарь | 082
Парадный Windows: альтернативный интерфейс для win | 085
Реестр Windows: только трусы не лезут HKEY! | 092
Железки под пытками: софт под хард | 096
Замути свой аварийный CD | 098
КОДИНГ |
Софт крякера | 102
Большой шкодинг, или выбираем средство разработчика | 106
КАРМАННЫЙ СОФТ |
Целый мир в твоей ладони | 110
Кодим пальмы | 114
Карманные игры | 116
Конкурс | 126


Спецвыпуск Xakep, номер #017, стр. 017-001-1, INTRO

INTRO

Спецвыпуск Xakep, номер #017, стр. 017-001-1

Привет, амиго! У тебя в руках новый номер СПЕЦа, посвященный софту и прочим мягким составляющим компа. Но не думай, что софт – это туча мелких бесполезных прог, которые оседают у тебя на винте, захламляя реестр и отжирая кучу ресурсов, в том числе и твое время. Многие юзеры болеют софтоманией, постоянно гоняясь за новыми версиями своих любимых программ и стремясь довести свой комп до мнимого совершенства. В итоге получается, что человек тратит большую часть машинного времени на апдейт ради апдейда. Убил целый день и нечего не сделал, просто на столе появилась новая панелька или бат теперь работает, как часы. На самом же деле, софт – это, прежде всего, такие программы, которые позволяют выжать из твоего железа максимум и получить полезный результат. Ведь для хацкера комп – это рабочий инструмент. Он может принести тебе не только удовлетворение, но и деньги. Заставь железного окупать себя! Мы постарались заострить внимание именно на таком софте. С этой целью мы обзвонили несколько крупных кадровых агентств и выяснили, спецы по какому софту наиболее востребованы на рынке труда. Вот список специальностей, которые обеспечат тебя хорошей работой:

1. 1С-Бухгалтерия

2. Админ win-сетей

3. QuarkXPress

4. Adobe PhotoShop

5. 3D Studio MAX

6. Adobe Illustrator

Выбор за тобой! Читай о них в нашей Cover Story. И если что-то окажется тебе близким, развиться дальше тебе помогут специальные курсы и книги, обзор которых ты найдешь в той же рубрике.

Однако хакер всегда остается хакером, поэтому даже разделавшись с работой, он продолжает креативить. Рубрика «Креатив» поможет тебе поглумиться над фотками друзей и подруг, написать технотрансовый шедевр, порипать в DivX пару новых блок-бастеров на радость инет-сообществу.

Мобильность – одно из важнейших качеств современного чела, поэтому не забыт и твой карманный друг. Ты можешь настроить его оптимально и установить продвинутый софт, а можешь и закодить что-нибудь самостоятельно. Читай рубрику Мобильность.

И это далеко не все. Главное, мэн, работай на результат.

Donor & n0ah

Содержание


Спецвыпуск Xakep, номер #017, стр. 017-002-1, № страниц Наименование

№ страниц Наименование

01 Intro

Спецвыпуск Xakep, номер #017, стр. 017-002-1

02 Контент

ОБЗОР

04 Обзор фривар и шаровар сайтов

08 Обзор варезных серваков

КРЕАТИВ

12 Компьютерные трубадуры: музстудия на домашнем писюке

18 """DivX ;)"" Был, есть и будет есть!"

24 """DivX ;)"", MPEG-4 и DVD-фильм на одном CD"

30 Глумимся над фото: подлый софт

АПГРЕЙД МОЗГОВ

34 Студтехнософт: тебе, технарь.

40 Софт студента-гуманитария

46 Эмулятор паяльника: софт для радиолюбителя.

COVER STORY

50 """1C"" - знай наших!"

54 Adobe Illustrator - мегакреативный патрон в обойме дизайнера

60 Бухгалтерия программисту по колено: как стать 1С-кодером

62 "Работай в ""3DS MAX"""

64 QuarkXPress

68 PhotoShop

72 Администрирование win-сетей

76 Обзор книг

78 Обзор курсов

БОЛТЫ & ГАЙКИ

80 Advanced загрузочный nix-флопарь

82 Advanced загрузочный win-флопарь

85 Парадный Windows: альтернативный интерфейс для win

88 Грамотный уход за Виндами

92 Реестр Windows: только трусы не лезут HKEY!

96 Железки под пытками: софт под хард

98 Замути свой аварийный CD

КОДИНГ

102 Софт крякера

106 Большой шкодинг, или выбираем средство разработчика

КАРМАННЫЙ СОФТ

110 Целый мир в твоей ладони

114 Кодим пальмы

116 Карманные игры

120 Комикс

126 Конкурс

Содержание


Спецвыпуск Xakep, номер #017, стр. 017-004-1, ОБЗОР ФРИВАР И ШАРОВАР САЙТОВ

ОБЗОР ФРИВАР И ШАРОВАР САЙТОВ

Спецвыпуск Xakep, номер #017, стр. 017-004-1

ОбоЗреватель (maddoc@real.xakep.ru)

Первый раз на download.ru я попал случайно лет пять назад, набрав не тот домен. С тех пор его содержимое принципиально не изменилось.

Neosoft.ru поражает своим внешним видом: все выглядит высокотехнологично и продвинуто.

Freeware.ru в первую очередь подкупает простым и незамысловатым, но очень функциональным интерфейсом.

Ура! Именно на tucows.com я, наконец, обнаружил требуемую мне прогу - тот самый многострадальный "SnagIt"!

Еще много лет назад я понял - компьютер сам по себе есть бесполезная груда железа. Для его работы нужны программы (какая мысль, а!). "Митино БаЗЗаР" и подобные развалы могут помочь нам в нелегком деле борьбы за оптимизацию соотношения цена/качество буржуйских программ (ИМХО, два бакса для "мастдайки" - есть красная цена), но тратить даже такие незначительные деньги на покупку бесплатных или почти бесплатных прог представляется мне пустой их тратой. Сегодня мы пройдемся по спецсайтам, которые только и ждут посетителей, которые качнут у них пару программ, а за это посмотрят н-дцать баннеров (хе-хе, наивные). В качестве тестового задания я искал программу "SnagIt", которая чудесно сдирает скрины.

www.download.ru

Первый раз на этот сайт я попал случайно лет пять назад, набрав не тот домен. С тех пор содержимое принципиально не изменилось: в основном здесь можно найти продукцию отечественных программистов, которая не пользуется спросом где-либо еще. Искомую "SnagIt" здесь найти не удалось. Общее же количество программ, доступных для скачивания, тоже не впечатляет: на момент обзора их было числом 5560. Они разложены по разделам и подразделам и выводятся на экран списком по десять на странице; никаких возможностей по сортировке не предусмотрено. Для пробы я скачал пару утилит, которые обещали мне "показать любой пароль, скрытый звездочками". Или пароли оказались сильно зашифрованными =), или еще чего, но ожидаемого я не получил. К плюсам этого ресурса я бы отнес русскоязычность программ. Кроме того, оттуда легко перейти в довольно неплохой магазин компьютерной литературы; ну а разработчики программ имеют возможность добавить на сайт свое творение. Большинство программ находятся на том же самом серваке, связь с которым (по крайней мере, с моей дайлапы) достаточно хорошая.

Вывод: пользуйся им тогда, когда ищешь русскую программу и не можешь найти ее где-либо еще. Может быть, тебе здесь повезет? Или тебе надо чего-то уж совсем особенного: например, здесь есть "Программа для экономии чернил струйного принтера", которая "из одного цветного BMP-файла делает два: один с градациями серого, который выводится на лазерном принтере, другой с цветовыми добавками, выводимыми на струйнике. Обе картинки затем выводятся одна поверх другой" (это не мой вымысел, это описание проги с названием "Конвертор изображений RGB-RGBY" с этого ресурса).

www.neosoft.ru

Ресурс поражает своим внешним видом: все выглядит высокотехнологично и продвинуто. При этом активно юзаются фреймы, а код типа скрыт от просмотра (непонятно только, а чего прятали-то?). Совсем не смог понять такой фишки: весь сайт на русском языке, большинство программ - русскоязычные, но в одном месте все-таки встречается англицкий - в меню. Не найти там родных и понятных "Интернет", "Графика", "Игры", только "Internet", "Graphic" и "Games". Первая страница встречает новостями примерно о двух десятках недавно добавленных программ, самая старая из которых датирована ноябрем прошлого года, самая свежая - январь. На календаре у меня первое марта, так что темпы обновления ты можешь прикинуть сам. Плюсы: большинство программ из новостей снабжены скринами и описаниями, причем здесь, в отличие от предыдущего ресурса, эти комментарии явно писались авторами сайта и представляют собой не только восхваления от разработчиков прог (ну кто ж о своей-то программе плохой отзыв напишет?), а реально перечисляют как плюсы, так и минусы. Кроме того, прямо с первой страницы архива можно отправиться на хоумпагу программы или сразу скачать саму прогу. Совсем битых ссылок невооруженным глазом обнаружить не удалось. Как и искомой "SnagIt", кстати. Набор программ не впечатлил - он довольно стандартный. Некоторые версии безнадежно устарели: "Offline Explorer" предлагается в версии 1.1, в то время как у меня на компе уже давно трудится 2.1. На мой субъективный взгляд, только с графикой здесь все хорошо: одних плагинов для "Фотошопа" здесь более тридцати; кроме того, прилагаются описания известных и неизвестных растровых и векторных редакторов, просмотрщиков и так далее; есть даже описание собственно "фотожопа 6.0". Для себя здесь я нашел прогу с именем "WiseView" - просмотрщик 3D/2D графики, который, благодаря функции "Section View", "позволяет с помощью ползунка делать срез модели по любой плоскости и таким образом заглянуть внутрь 3D объектов".


Спецвыпуск Xakep, номер #017, стр. 017-004-2, ОБЗОР ФРИВАР И ШАРОВАР САЙТОВ

ОБЗОР ФРИВАР И ШАРОВАР САЙТОВ

Спецвыпуск Xakep, номер #017, стр. 017-004-2

Вывод: стоит заглянуть сюда, если требуемая тебе прога хорошо известна и есть на большинстве сборников программ (типа "Regat'a" или "Winamp'a"), тогда, скорее всего, ты здесь ее найдешь. Но не обещаю, что это будет самая свежая версия. Кроме того, зайди в поисках средств работы с графикой.

www.freeware.ru

В первую очередь ресурс подкупает простым и незамысловатым, но очень функциональным интерфейсом. Прямо с первой страницы можно перейти в любой нужный раздел и подраздел, а также посмотреть новые поступления, самые популярные программы, программы недели и новые версии. Кроме того, на самом верху представлена "Программа недели", которой на момент написания этого обзора была "Латиница" ("переводит текст с русского языка на универсальный - русские слова пишутся латинскими буквами"). Простенько и незатейливо. А тебе никогда не приходилось мучаться с набором русского языка латиницей? На той же странице есть несколько новых программ, лидеры за десять дней и опять же десяток новых версий, причем можно сразу переходить в раздел и подраздел понравившейся проги.

Содержанием сайт хоть и отличается в лучшую сторону от предыдущих, но требуемую мне "SnagIt" здесь я также не нашел. Зайдя для пробы в рубрику "Система", я увидел, что за последний месяц появилось всего три программы. Впрочем, две из них в описании утверждали, что "эта версия работает и под "Виндовз ХР"". Бегло пройдя по остальным разделам, я нашел все тот же "Offline Explorer" версии 1.3, "ослика 5.5" и так далее - ничего особо свежего или выдающегося, но большинство программ для повседневной работы на этом ресурсе есть. И, несмотря на название, есть не только бесплатные, но и условно-бесплатные проги, сразу предупреждающие об этом.


Спецвыпуск Xakep, номер #017, стр. 017-004-3, ОБЗОР ФРИВАР И ШАРОВАР САЙТОВ

ОБЗОР ФРИВАР И ШАРОВАР САЙТОВ

Спецвыпуск Xakep, номер #017, стр. 017-004-3

Вывод: тебе сюда, если прога довольно распространена. Понятно, что самая свежая версия программы всегда находится на сайте производителя, но его url часто неочевиден. А выбор здесь, ИМХО, все-таки поболе, чем на предыдущих ресурсах. А если учесть, что в кольце с этим сайтом находятся еще "Unixware", "Macware", "WinCEware", "Palmware" (с довольно удачной подборкой софта для указанных ос) и довольно неплохой книжный магазин, объединенные похожим и одинаково удобным дизайном, то этот адрес все-таки стоит запомнить.

soft.mail.ru

Немного раньше этот сайт был известен как Soflist.ru. Но, "в связи с объединением компаний, бла-бла... созданием портала Mail.ru, бла-бла-бла ..." там теперь стоит редирект. Редиректит он как раз сюда. Осмотримся?

Очень много рекламы. На видимой при загрузке части сайта уместились только рубрика "Программа недели" и одна строчка из новых поступлений, все остальное пространство занято продвижением собственно mail.ru и дочерних проектов (съехала довольно далеко вниз в том числе и колонка "Главные категории" - собственно список разделов прог). Кроме того, некоторая часть программ честно предупреждает тебя, что является демкой и не будет работать в полнофункциональном режиме ни дня. Обращает на себя внимание наличие системы рейтингов: каждая программа, типа, объективно оценена ведущими раздела, и ей выставлена, типа, объективная оценка по пятибальной шкале. Нет, я готов согласиться с тем, что тот же самый антивирус Касперского (получивший здесь три из пяти) имеет много недостатков, но все-таки свою работу он выполняет лучше, чем "Dr.Web" (получивший пять). Выбор прог по рейтингу полезен, конечно, когда ты внезапно оказался перед какой-то нестандартной задачей и ищешь совершенно неизвестную тебе прогу, но будь готов круто обломаться.

Проги чаще всего качаются с сайта производителя, битых ссылок я не нашел. Выбор опять же довольно стандартен и небогат. "SnagIt" здесь тоже не пронаблюдался, "Offline Explorer" версии 1.9 (октябрь 2001, довольно свежая). Есть чуть больший выбор (по сравнению с остальными разделами) прог для программирования и системных утилит, но общую картину это принципиально не меняет. Особых прибамбасов нет, если, конечно, не считать таковым упорно навязываемую возможность на все забить и окунуться в "Компьютерный юмор" или кликнуть на баннер "Верный способ стать желанным".

Вывод: загляни, если тебе так хочется. Прог в общем объеме меньше, чем на www.download.ru, но реально нужных и стоящих поболе; идея рейтинга тоже имеет свои плюсы, так что если ты не нашел нужную прогу на выше описанных сайтах, попробуй, здесь, может, повезет больше.


Спецвыпуск Xakep, номер #017, стр. 017-004-4, ОБЗОР ФРИВАР И ШАРОВАР САЙТОВ

ОБЗОР ФРИВАР И ШАРОВАР САЙТОВ

Спецвыпуск Xakep, номер #017, стр. 017-004-4

www.tucows.com

"Кричали женщины "Ура!" и в воздух чепчики бросали". Именно здесь я, наконец, обнаружил требуемую мне прогу - тот самый многострадальный "SnagIt"! Здесь он оказался версии 5.2.2 от сентября прошедшего года. Еще я лишний раз убедился в национальных особенностях жителей перенедоразвивавшихся стран: лидер по числу скачиваний здесь - "Irfan View 3.61" (рейтинг здесь у нее пять из пяти, как и у "SnagIt'а"). Это тоже утилитка для снятия скринов и прочей шняги, но, в отличие от "SnagIt'а", распространяется как Freeware, что, по-видимому, и обеспечивает ей более высокую популярность, несмотря на отсутствие возможности делать мультидисплейные скрины.

Здесь я столкнулся с ситуацией, когда не смог найти полный список подразделов программ или хотя бы их разделов. Есть только довольно общие рубрики типа "Детям", "Для бизнеса", "Интернет", "Игры" (общим числом восемь штук). Выбрав же на первой странице "Desktop software" ->> "Windows", я попал в "Топ десять", где на первом месте стояла та самая "Irfan View", потом шли "ослик Ие" и "тетя Ася", и где еще мне предложили ознакомиться с "Топ сто". Ах, чуть не забыл - о выборе. Выбирать можно было еще из семи вариантов консольных видеоигр, а кроме стандартных наборов софта под "Линукс" и маки, предлагались еще и проги под "BeOS", "OS/2", "QNX" и... "Windows 3.1".

Пойдя чуть дальше, я понял, что составлять полный список даже основных разделов было, действительно, бессмысленно. Объяснение писать не буду, смотри сам на втором скрине: это только рубрика "Интернет" и ее основные разделы! Такой большой объем софта, конечно, вносит некоторую пикантность и неожиданность в процесс поиска: в ответ на запрос вываливается некоторая туча абсолютно левых прог. Но иначе многие отличные, но малоизвестные проги рискуют навсегда затеряться под пластами раскрученных брэндов. Так, запрос на "Offline Explorer" выдал мне триста наименований. К счастью, первые две строчки содержали в себе ссылки на две версии искомого, причем довольно свежие.

При желании закачать какой либо продукт у тебя так ненавязчиво спрашивают страну. Затем предлагают на выбор зеркала (мне был предложен московский "Ринет" и еще какой-то ярославский провайдер). Так что при затруднении контактов с заграницей не теряйся, у нас и у самих все есть. Закачка прошла без нареканий, все очень ровно и гладко.

Единственный минус - невнятная сортировка без возможности ее изменения. Запрос "winamp" на первую строчку вывел прогу с названием "Kill winamp" от ноября прошлого года и всего с тремя коровами, затем шел пятикоровный "MooAmp Skin for WinAmp 2.3" от июня 2000-го, потом, собственно, декабрьский "ВыньАмп", а через пару строк примостился "WinAmp Screen Maker" от мая 2000 года с тремя коровами, а всего ссылок высыпалось количеством в сорок три штуки.

Вывод: если ты не боишься потеряться в ссылках и так далее - тебе сюда. Выражаю опять же личное мнение, но мне кажется, что если ты не нашел фриварной или шароварной проги здесь, то ее либо в принципе не существует, либо она далеко не бесплатна.


Спецвыпуск Xakep, номер #017, стр. 017-004-5, ОБЗОР ФРИВАР И ШАРОВАР САЙТОВ

ОБЗОР ФРИВАР И ШАРОВАР САЙТОВ

Спецвыпуск Xakep, номер #017, стр. 017-004-5

www.download.com

Это, пожалуй, единственный серьезный конкурент "Двум Дояркам" и наиболее достойный ресурс из всех описанных. Помимо удобной навигации и рейтинга по популярности (числу скачиваний) прог, а также набивших оскомину разделов с софтом под "никсы", "маки", существует рейтинг по оценкам пользователей. Здесь любой юзер имеет возможность выставить свою оценку продукту - да еще и по четырем критериям, а именно: по фичам, производительности, удобству пользования и интерфейсу. Можно оставить и более развернутые комментарии и, соответственно, ознакомиться с комментами других перед скачкой не известной тебе программы. Про то, что выбор огромен, не буду даже и упоминать; выбор источника для закачки происходит автоматически, но потом есть возможность выбрать ближайший к тебе сервант. Поиск тоже более удобен. Так, на запрос "Offline Explorer" выдается "всего" шестнадцать ссылок (в том числе и на последние версии), плюс есть еще и сортировка полученных результатов по имени, дате добавления/обновления, рейтингу пользователей и количеству закачек. Здесь же я нашел и последнюю версию "SnagIt!" за нумером шесть.ноль, что оказалась последней по времени выхода.

Вывод: собственно, именно сюда я и стремился вначале, набирая по ошибке www.download.ru. Здесь можно найти почти любую нужную шаровару или фривару, причем со всеми удобствами. А вместе с "Коровами" - это вообще суперпарочка.

ЧТО ЖЕ ДЕЛАТЬ?!

Есть, конечно, деликатный вопрос, что делать, если нужной тулзы так и не нашлось, да еще и закралось подозрение, что она абсолютно коммерческая? Тогда путь твой лежит на темную сторону: на пиратские фтпешники, на варезные серваки в ирке, в сети обмена файлом. Ищи и обязательно найдешь.


Спецвыпуск Xakep, номер #017, стр. 017-008-1, ОБЗОР ВАРЕЗНЫХ СЕРВАКОВ

ОБЗОР ВАРЕЗНЫХ СЕРВАКОВ

kosmonavt (fddx@land.ru)

Спецвыпуск Xakep, номер #017, стр. 017-008-1

Некоторые говорят, что проще купить, чем скачать, но, по-моему, закачать гораздо интереснее.

Если сервак вдруг не захочет с тобой разговаривать (такой он вот занятой), не беда, заходи попозже - должно сработать.

Тут тебе и винды, и нортоны, и графика любая, и программирование, и инет-проги.

У этих пиплов не хватало места, и они открыли еще два сайта, брата-близнеца fastdl.

Весь варез разбит по категориям и подкатегориям так, что совсем не трудно разобраться, где и что лежит.

...вторая появится, когда кликаешь Appz1 или Appz2. А чтобы увидеть третью, нужно вручную набрать «/Appz2.html». Но заморочка того стоит.

Почти весь варез лежит на одном серваке, и немного - у братьев-китайцев, так что это самое «немного» порой может глючить.

ВАРЕЗНЫЕ БУДНИ

Значит, захотелось вареза. А задумывался ли ты когда-нибудь, что он у тебя всегда был? Вряд ли ты потратил сотни зеленых рублей на винды всякие, фотошопы, офисы и прочее. Максимум - заплатил символическую сумму за пиратский диск или же вообще скачал. Не скачивал еще? Тогда вперед! Вооружаемся всякими там регетами, даунлоад акселераторами, хорошей связью и терпением :). Кстати, если тебе не хочется иметь дело с баннерами, кучами выскакивающих окон и всякой неприятной заразой aka вирусами, поставь хороший файрволл, не ленись. Сам в том году лоханулся, подцепил троянца. Ну да ладно, вернемся к нашим "варанам" :). Я вот тут немного поднапрягся и приготовил обзор нескольких варезных сайтов.

www.hot.ee/avst/soft.html

Выглядит сайт приятно: нет раздражающе ярких фонов и огромных шрифтов. Список программ, коих около двух сотен, удобен и красиво смотрится, только цвет полоски слева напоминает дорогой сердцу Рабочий Верстак от Билли. Баннерорезалка сослужит здесь хорошую службу, а вот попапов aka всплывающих окон на этом сайте нет, что опять же плюс. Весь варез разбит по категориям и подкатегориям, так что совсем не трудно разобраться, где и что лежит. В разделе "Разное" живет софт, который трудно записать в какую-либо категорию - зайди, и, может, как раз там и лежит то, что ты так давно ищешь. Все проги на 100% являются рабочими версиями - никакого шаровара или демок. Почти все они лежат на этом серваке и немного - у братьев-китайцев, так что это самое «немного» порой может глючить. Ссылки вроде бы все рабочие, а инфа об обновлениях периодически появляется в "Новостях". К довольно большой массе программ указаны ссылки на соответствующий хэлп - смотри, читай, мотай на ус :). Самая радостная фишка - категории "Запись CD-R и CD-RW", "Аудио-софт", "Видео-софт" - сразу, не морочась, находишь то, что надо.

fosi.almostbroken.net

Немолодой и довольно известный сервер. Имеет несколько редиректов, прикольно оформлен (стильно так, выдержан в синих тонах), но старомодно. Чего ты здесь не найдешь, так это "слепых" ссылок, зато имеются два-три порнушных баннера - фича всяких хакерских и варезных сайтов. Если сервак вдруг не захочет с тобой разговаривать (такой он вот занятой), не беда, заходи попозже - должно сработать. Докачка практически всегда поддерживается, так что смело пользуйся "качалкой" :). Как полагается, никаких трай-эн-бай - только полные и самые последние коробочные версии и, соответственно, отсутствие вирусов как факт. На сайт выкладывается 36 разнообразных прог за раз, и, если захочешь что-нибудь слить, сливай сразу - завтра этой проги может уже и не быть. Грамотный на этом сайте фак (в смысле FAQ :)), если есть время, советую посмотреть - серьезный чел писал. В общем, добро пожаловать!


Спецвыпуск Xakep, номер #017, стр. 017-008-2, ОБЗОР ВАРЕЗНЫХ СЕРВАКОВ

ОБЗОР ВАРЕЗНЫХ СЕРВАКОВ

kosmonavt (fddx@land.ru)

Спецвыпуск Xakep, номер #017, стр. 017-008-2

www.navnetwork.net

Это варезный портал. База там о-о-очень огромная, около 2800 ссылок. Все это добро свалено в кучу и перемешано: есть игрухи, кино и музыка, но в основном проги, проги, проги. Названия повторяются, но уже с другими ссылками, то есть можно выбирать, откуда качать. Но весь этот бардак можно исправить, набрав в поиске имя проги. Большие проги частенько разбиты на кусочки. На некоторых download page'ах указаны сд-кеи и сериалы. Попадаются глухие ссылки (в смысле сто лет ждать коннекта), но если повезет, можно скачать, например, Автокад 2002 файнал, кучу мультимедии, Детей Капитана Нортона и гвоздь программы - Windows XP PRO FINAL, свежевыложенный (качается только в путь, весит 453 МВ). Плюс еще ХР Admin pack, XP Plus pack и XP THEME 2.0. Поскольку это портал, ссылки тут в основном на другие сайты, где все это по идее должно бы лежать, но может и не лежать. Кому надо - там лежит Warcraft3 бета ISO, линк работает. Есть пара баннеров, которые все время показывают рекламу крутых солнечных очков, да при закрытии окна опять появляется проклятый попап, вот и все недостатки, так что качаем.

www.nnm.ru

Многие уже давно знают про этот сайт (проект NoNaMe), но не все. И вот тем, кто не знает, я хочу сказать, что они многое теряют. На сайте куча разделов, обновления каждый день, короче - все сделано просто и со вкусом, ничего лишнего. В силу своей простоты грузится быстро. Контент такой: ссылки, скриншоты с приколами и с прогами и, внимание, фтпшники с паролями. Все работает. А на той неделе я видел там такое фото: табличка на здании, и на ней золотыми буквами написано: "Здесь В.И.Ленин скрывался от Н.К.Крупской" :). Из всех представленных сайтов ННМ - безусловный лидер, так как он не является одноразовым, всегда что-то новое, полезное и веселое. Лично я посещаю его регулярно и очень им доволен. Советую посетить.

www.wahun.hu/madar/start.html

Похож на NavNet, только без баннеров, более убористый, да и белые символы на синем фоне смотрятся симпатичнее, чем на черном. По ссылке попадаешь сразу на даунлоад пейдж, а там уже на само файло. Набор вареза на сайте, прямо скажу, внушительный. Тут тебе и винды, и нортоны, и графика любая, и программирование, и инет-проги. Кое-где указаны сериалы. Предложенный Warcraft3 и Героев аж 5-х (так и написано) мне скачать не удалось - так конечной ссылки и не нашел... Видно, чел решил грязно поглумиться, зациклив ссылку, или решил разжиться кликами. Хотя, если есть желающие, то вперед, может что и получится :). Так что жми next и обходи стороной вот такие линки: home.no.net/kostaхх/Gameхх.html. А остальное вроде работает, докачка в порядке, но бывает трудный коннект. В общем, клевый сайт, и хотелось бы, чтобы он жил и развивался дальше и апдейтился почаще. Диагноз - в "Избранное".


Спецвыпуск Xakep, номер #017, стр. 017-008-3, ОБЗОР ВАРЕЗНЫХ СЕРВАКОВ

ОБЗОР ВАРЕЗНЫХ СЕРВАКОВ

kosmonavt (fddx@land.ru)

Спецвыпуск Xakep, номер #017, стр. 017-008-3

filez.xonix.ru

Сайт filez.xonix.ru, хочет все время отослать тебя на xonix.ru, но лучше оставаться на filez. Сайт похож на nnm.ru, но от nnm впечатление осталось получше. Обновление происходит примерно раз в два дня, но ссылки работают не все. Выкладывается список фтп. Полезно зайти в архив - там до фига ссылок, из которых имеет смысл смотреть только за этот год. Сразу скажу, работают не все - все-таки архив. Несмотря ни на что, здесь можно найти до фига всякого софта, а если еще за обновлениями следить, то точно найдешь какую-нибудь полезность.

www.fastdl.com/appz1.shtml

Простой дизайн, быстрая загрузка, поисковики, линки прямо на файл - вот и все, что для счастья надо. Оказывается, не все. У этих пиплов не хватало места, и они открыли еще два сайта, брата-близнеца fastdl. Один прикрыли злые дядьки, а другой начинается здесь: www.directdl.com/ddl/dowmloads0.html. Некоторые ссылки там ведут на другие серваки. Удивительно, но и там все работает, до всего, до чего доконнектишься, все тебе будет. И за докачку тоже можешь не беспокоиться. Правда, по названиям некоторых ссылок видно, что они ведут все к тем же братьям-китайцам, а там то ли сервак перегружен, то ли еще чего, но коннекта ждать еще лет двести (я, например, долго пытался пробиться на ftp://202.109.129.25:858 - без мазы).

Еще вот такая гадость: на www.fastdl.com есть баннер. Обычный, с порнухой. Его хочется закрыть, и на нем даже есть соответствующая кнопка, но как только ты ее нажмешь, закроется все окно. На directdl такого безобразия нет. А так местечко приятное, идем, качаем.

www.staticfree.net/sarathb

Некоторые говорят, что проще купить, чем скачать, но, по-моему, закачать гораздо интереснее. Конечно, чем быстрее у тебя подключение, тем больше вареза ты скачаешь. Но тем не менее и обычным модемщикам не стоит расстраиваться - есть много серверов, на которых спокойно можно качнуть нужную игрушку, фильм, прогу, не очень обращая внимание на скорость и время. А линки на некоторые из них ты найдешь на этом сайте - www.staticfree.net/sarathb/. Еще один варезник, по-моему, нормально сделанный, хотя автор говорит, что он ничего не шарит в веб-дизайне. Фиг с ним, с дизайном. На сайте есть три таблицы с ссылками. Сначала попадаешь на первую, и больше ты ее не увидишь, пока не нажмешь back в броузере. Вторая появится, когда кликаешь Appz1 или Appz2. А чтобы увидеть третью, нужно вручную набрать «/Appz2.html». Но заморочка того стоит. Ссылок немного, по сравнению с другими, около 150, зато все работают, держат докачку. Если выползет "сервер не найден", просто нажми на даунлоад еще раз, всегда помогало. www.warezcrawler.net. На этой странице меня привлек прежде всего варезный поисковик: ищет по нескольким разделам, находит много и все нужное :). Радует и скорость работы поисковика, грузится быстрее, чем лист.ру. В общем, кто ищет, тот всегда найдет.


Спецвыпуск Xakep, номер #017, стр. 017-008-4, ОБЗОР ВАРЕЗНЫХ СЕРВАКОВ

ОБЗОР ВАРЕЗНЫХ СЕРВАКОВ

kosmonavt (fddx@land.ru)

Спецвыпуск Xakep, номер #017, стр. 017-008-4

FTP - ТО, ЧТО ДОКТОР ПРОПИСАЛ

Есть еще позабытый некоторыми ресурс, такой как ftp. Вареза в мировых файловых хранилищах лежит просто море. Вылавливать его будет удобнее, если у тебя имеется нормальный fpt-клиент. Все бесплатные фтпшки можно условно разделить на три категории. На одни надо что-то закачать, чтобы потом скачать, то есть обменяться. Таких большинство. Чтобы попасть на вторые, надо выполнить какие-нибудь условия. Например, идешь по указанному адресу, заполняешь форму, получаешь номер, который является паролем к фтп. Или то же самое, но через письмо, которое надо подтвердить, и получить пароль. За заполнение форм хозяин сервера получает деньги. Все условия лежат на соответствующих узлах. Вот несколько таких "условно-бесплатных" адресов:

ftp://63.193.152.107:21 - содержит 90 гигов всякой всячины, разбитой по категориям apps, games, movies, music. Для получения надо региться.

ftp://warez:unlimited@64.231.120.19:21 - еще 120 гигов, но региться надо через почту.

ftp://anonymous:anonymous@217.80.7.148:21 - тоже с условием.

И немного халявы:

ftp://mmail.da.ru/ - немного музыки, прог штук 70 - на халяву. А несколько десятков фильмов сможешь скачать, если сам закачаешь один фильм. Если ты юзер TELECOM'а, то качай на халяву все.

И третьи - совсем халявные :), которых очень мало, и найти их сложно (но можно). Для этого заходи на www.ftpcrawler.net. Страница из того же проекта, что warezcrawler, но хотелось бы выделить ее особо. К чему такие почести? Но ведь эта пага предоставляет тебе огромный список живых (!) фтп-серваков с варезом. То, что серваки живые, заявляю с полной ответственностью - сам проверял. Еще такой совет: не забывай, что ситуация может измениться каждый день, сайт может закрыться, вчерашние линки не будут работать или еще чего - такая вот быстротечная у варезников жизнь. Так что качай сегодня сколько сможешь.

LEGALIZE IT!

Ну и в заключение буквально два слова о варезе. Я искренне убежден в том, что информация должна распространяться свободно и что интеллектуальная собственность по природе своей принципиально отличается от всех прочих продуктов человеческой деятельности. Мало того, я считаю, что лишать граждан России пусть даже и нелегального доступа к современным информационным технологиям - недальновидно по отношению к будущему страны. А для тех, кто мне будет грозить пальцем и говорить, что "варез - это бяка" и так далее и тому подобное, я официально заявляю, что весь скачанный мной варез будет использоваться только в ознакомительных целях. Не верите - попробуйте проверить :). Флаг вам в руки...


Спецвыпуск Xakep, номер #017, стр. 017-012-1, Компьютерные трубадуры: музстудия на домашнем писюке

Компьютерные трубадуры: музстудия на домашнем писюке

light (losi@online.ru)

Спецвыпуск Xakep, номер #017, стр. 017-012-1

Ты, конечно, слышал трек "Воскрешение" наших с тобой соотечественников (Ростов on the Дон) группы "ППК". Так вот, трек этот с помощью компа написан.

"Cakewalk Pro Audio" - один из самых мощных программных секвенсоров для создания музыки.

Конечно, сегодня в продаже имеются диски с библиотеками всевозможных звуковых файлов, но гораздо круче создать звук самостоятельно, сгенерировав его с нуля.

Самый сложный тип синтеза осуществляется с помощью встроенного в "Sound Forge" FM-синтезатора.

Имея под рукой такие мощные средства, ты сможешь воплотить в жизнь, казалось бы, самые нереальные проекты.

Френд, помнишь, как тебе советовали подарить своей девушке на день рождения тобою написанный альбом с танцевальной музыкой? Подарил? Ай, молодца! Она довольна? Замечательно! А ты? Согласись, "DanceMachine", семейство "eJay'ев" и подобные проги - не более чем игрушки. С их помощью ты сможешь лишь приятно провести время. А если ты действительно решил заняться музыкой, оставь "ДэнсДрандулет" не особо одаренным и забудь как страшный сон. Музыку писать нужно грамотно.

Реально&просто

Сомневаешься в том, что на компьютере можно создавать полноценные музыкальные произведения? Это вполне реально! Ты, конечно, слышал трек "Воскрешение" наших с тобой соотечественников (Ростов on the Дон) группы "ППК". Этот трек написан с помощью компа. Вот так-то! "ППК" юзали "Cubase", но речь сегодня пойдет не об этой программе. У "Cubase" системные требования выше Эвереста - не всем по карману такие тачки. К тому же прога эта предполагает наличие синтезатора или хотя бы MIDI-клавы. А мы с тобой без всего этого обойдемся: и без инструментов, и без сверхмощного компа.

Инструментарий

Плодотворно использовать компьютер в своем музыкальном творчестве тебе поможет программная среда, состоящая из трех прог: "Cakewalk Pro Audio", "Sound Forge" и "Rebirth RB-338". На дисках, имеющихся в продаже, чаще всего представлен весь набор.

Cakewalk Pro Audio

Эта софтина - один из самых мощных программных секвенсоров для создания музыки.

Возможности:

- 24бит/96 кГц;

- до 64 аудио треков;

- 256 виртуальных треков (MIDI\Audio);

- 64 канала эффектов реального времени;

- поддержка DirectX Plugins;

- поддержка RealAudio;

- конверсия из Pitch в MIDI;

- вставки треков;

- интерактивная расстановка маркеров;

- AVI, MPEG и QuickTime Video-синхронизация.

Это наиболее важная программа из всех, поскольку именно в ней происходит сведение результатов работы всех трех программ в единое целое. В сущности, программа "Cakewalk" является многогранным музыкальным инструментом, а как известно, перед игрой на любом музыкальном инструменте его необходимо настроить.

Настройка "Cakewalk"

При первом запуске программы на экране возникает диалоговое окно "Migrate Cakewalk Preferences" (переносимые установки), которое говорит, что возможен поиск предыдущей версии с целью заимствования всех старых настроек конфигурации проги. Если предыдущая версия софтины на компе есть, кликай "ОК", и все будет пинцетно. Если нет, дави на "Cancel".

Далее запустится мастер настройки "Cakewalk", и на экране возникнет форточка "Cakewalk Wave Profiler" (волновой настройщик) и сообщит, что "Cakewalk" может провести ряд тестов для определения характеристик звуковой карты. Это требуется, чтобы забацать наилучшую синхронизацию между MIDI- и аудиотреками. Дави "Да" и избавляйся от геморроя в будущем. После тестирования мастер настройки выдаст сообщение, что прога настроена на звукарь.


Спецвыпуск Xakep, номер #017, стр. 017-012-2, Компьютерные трубадуры: музстудия на домашнем писюке

Компьютерные трубадуры: музстудия на домашнем писюке

light (losi@online.ru)

Спецвыпуск Xakep, номер #017, стр. 017-012-2

Все. Подготовительный этап закончился, и происходит загрузка программы. После того как она грузанулась, на экране появляется главное окно и выскакивает еще один дайлог - "No MIDI Outputs - Cakewalk" (нет MIDI-портов вывода), то бишь надо выбрать MIDI-порты вывода. Дави кнопку "Choose MIDI Ports Now" (выбрать порты чичас), вскочит форточка "MIDI Ports".

В списке "Input Ports" (порты ввода) выбирай порты ввода MIDI-инфы. В данном случае выбраны оба возможных: "ESS MPU-401" (вход звуковой карты "ESS MPU-401") и "TTS Virtual Piano In" (вход виртуального пианино). К первому из них подключается MIDI-клава или любая другая MIDI-девайсина (если имеется, конечно). Второй - это порт виртуальной клавиатуры "Cakewalk". Он выбирается для того, чтобы можно было юзать программу "Virtual Piano". Эта прога позволяет в качестве MIDI-клавиатуры использовать обычную компьютерную. Затем полученную от внешних устройств (в нашем случае от кейбордины) инфу "Cakewalk" пишет в свои файлы, а также передает на устройства, подключенные к портам вывода.

В списке "Output Ports" (Порты вывода) выбирай, куда будет сливаться MIDI-информация. В данном случае выбран порт программного синтезатора. Через него MIDI-инфа поступает в синтезатор звуковой карты, набор инструментов которого соответствует спецификации "General MIDI". Все, можно вздохнуть и облегчиться - настройка закончена.

Морда "Тортошлепа"

Музыкальную композицию, написанную в "Cakewalk", можно условно разделить на две части. Первая часть - это MIDI-информация, то есть несколько последовательностей нот, которые проигрываются различными инструментами, и набор MIDI-эффектов, применяющихся к этим последовательностям. Вторая часть - это аудиоинформация, которая состоит из сэмплов (звуковых файлов) и применяемых к ним аудиоэффектов.

Итак, познакомимся с интерфейсом "Cakewalk". С панелями инструментов главного окна программы проблем не будет - там все ясно. А вот о рабочих окнах проги, пожалуй, стоит рассказать подробнее.

Окно "Track" - основная форточка любого проекта. Оно состоит из двух секций. Первая секция называется "секцией треков". В ней задаются параметры (порт вывода, номер MIDI-канала, банк MIDI-инструментов и сам MIDI-инструмент, назначенный треку) для каждого из треков, входящих в композицию (проект). Вторая секция называется "секцией клипов". В ней содержатся события, из которых состоит композиция. Событие - это самая элементарная составляющая композиции (включение и выключение нот, смена инструмента, изменение высоты тона и другая пурга). Клипом называются несколько объединенных в группу событий. На экране клипы представляются в виде прямоугольников. С ними можно проделывать всевозможные операции (удалять, копировать, переносить на другие треки и так далее).


Спецвыпуск Xakep, номер #017, стр. 017-012-3, Компьютерные трубадуры: музстудия на домашнем писюке

Компьютерные трубадуры: музстудия на домашнем писюке

light (losi@online.ru)

Спецвыпуск Xakep, номер #017, стр. 017-012-3

В окне "Staff" происходит редактирование музыки, изображенной в виде обычной нотной записи. Да, братец, от нотной грамоты никуда не денешься. Придется тебе напрячься и вспомнить музшколу. Если все помнишь, я радуюсь вместе с тобой - окно "Staff" как раз для тебя. Оно практически ничем не отличается от рабочих окон спецпрограмм для работы с нотами. Также разработчики позаботились и о тех, кто совсем далек от нот. Помнишь, я гнал про "Virtual Piano"? Именно оно и спасет тех, кто с нотками не дружит. Наиграй, а прога все нотами запишет. Чертовски удобно!

Окно "Console" - это виртуальный цифровой микшер, предназначенный для окончательного сведения композиции. С его помощью можно применять в реальном времени MIDI- и аудиоэффекты, изменять значение громкости и панорамы отдельных треков и тому подобное.

Так выглядит "Cakewalk Pro Audio". Программа эта очень мощная, о ее возможностях можно долго рассказывать. Но следует уделить внимание и другим программам.

Sound Forge

Фордж - один из лучших профессиональных редакторов звука для PC.

Возможности:

- поддержка дополнений DirectX;

- встроенный FM-синтезатор;

- пакетная обработка;

- спектральный анализ;

- полная поддержка RealAudio/RealVideo;

- множество тоновых эффектов;

- обеспечивает неразрушающую технологию редактирования.

Я уже сказал, что "Cakewalk" имеет набор функций для работы со звуковыми файлами, но их часто не хватает. Кроме того, для некоторых задач "Cakewalk" просто не катит. Например, для мастеринга собственных композиций перед записью демонстрационной кассеты (компакт-диска) или для обработки звукового файла, чтобы сварганить из него музыкальный инструмент. То есть тебе понадобится аудиоредактор - прога, специально заточенная под обработку звуковых файлов. Я предлагаю тебе "Sound Forge", так как он - наиболее универсален. Специальной настройки параметров программа не требует. Она все настраивает сама. Так что после установки можно сразу приступать к работе.

Познакомимся поближе. Перед тобой главное окно программы. Панель инструментов, график открытого звукового файла, на котором будут отображаться все его изменения, и, конечно, эквалайзер. Все предельно просто.

Для того чтобы обработать какой-либо звуковой файл, в "Sound Forge" имеются две возможности: его можно либо открыть, либо создать. Создать звуковой файл можно двумя способами: записать его с микрофона или синтезировать. С записью, думаю, все понятно, нажал "Record" - запись пошла, нажал "Stop" - прекратилась. А о том, как синтезировать звук, рассказать нужно.

Синтезируем?

Синтезирование - одна из самых интересных возможностей "Sound Forge". Конечно, сегодня в продаже имеются диски с библиотеками всевозможных звуковых файлов, но иногда хочется создать звук самостоятельно. Прикольно не просто содрать какое-нибудь файло и обработать его стандартными эффектами, а сгенерить сэмпл с нуля. Потом можно создать таким способом еще несколько звуков, сделать из них уникальные инструменты, сочинить композицию, наколдовать еще звуков и встроить их в звуковой ряд, после чего можешь гордо сказать: "Эту композицию я смонстрячил сам от и до". В общем, как бы то ни было, а возможность синтезирования звуков, в сочетании с другими достоинствами "Sound Forge", делает эту прогу мощным средством для создания новых электронных инструментов и всевозможных сэмплов. Ты даже не можешь себе представить, в какой потусторонний звук можно превратить простой шум сливного бачка, проработав над ним в "Sound Forge" каких-нибудь сорок минут.


Спецвыпуск Xakep, номер #017, стр. 017-012-4, Компьютерные трубадуры: музстудия на домашнем писюке

Компьютерные трубадуры: музстудия на домашнем писюке

light (losi@online.ru)

Спецвыпуск Xakep, номер #017, стр. 017-012-4

Синтезирование звука возможно только в том случае, если открыто какое-нибудь окно редактирования (только что созданного или готового файла) и осуществляется с помощью команд подменю "Synthesis" меню "Tools". Всего в этом подменю содержится три команды: "DTMF/MF Tones" (телефонные сигналы), "FM" (частотная модуляция) и "Simple" (простой).

Самый легкий метод синтеза осуществляется с помощью диалогового окна "Simple Synthesis", вызываемого командой "Simple".

В левой части этого окна находится ползунок, с помощью которого задается амплитуда синтезируемого сигнала. В списке "Wave shape" (форма волны) выбирается форма волны. Возможны следующие варианты: "Sine" - синусоидальная волна, "Square" - прямоугольная волна, "Saw" - пилообразная волна, "Triangle" - треугольная волна, "Noise" - шум, "Absolute Sine" - волна, график которой представляет модуль синуса (y = |sin x|). В поле "Length" задается длительность синтезируемого сигнала (от 0.001 до 60.0 секунд), а в поле "Frequency" - его частота (от 0.01 до 22 050 Гц).

Когда синтезированный сигнал встраивается в какой-нибудь файл, данные, которые содержатся в этом файле, раздвигаются, и на образовавшееся место вставляется намученный тобой звук. В списке "Insert new waveform at" (добавить новую волну в...) выбирается одна из трех возможных позиций в файле: "Cursor" - размещение, начиная с позиции, в которой находился курсор в момент применения команды "Simple". "Start of file" - в начале файла. "End of file" - в конце файла.

Следующий тип синтеза звуков осуществляется с помощью диалогового окна "DTMF/MF Tones", которое вызывается через подменю "Synthesis" меню "Tools".

Тоны

Этот дайлог предназначен для синтеза сигналов, которые используются в тоновых телефонных линиях. В строке "Dial string" - цифровая строка (1234567890ABC*#) задается последовательность символов, в соответствии с которой будет сгенерирована последовательность сигналов. Каждому символу из набора 1234567890ABC*# соответствует определенный сигнал. Если в последовательности встречается какой-либо другой символ, то он просто игнорируется. Кроме того, есть еще один распознаваемый символ - это символ, соответствующий паузе между двумя последовательностями сигналов. Задается он в поле ввода "Pause character". Если выбран переключатель "DTMF", то будут генерироваться сигналы, которые используются в обычных кнопочных телефонах, а если выбран переключатель "MF", то генерироваться будут сигналы, используемые внутри телефонных сетей. С помощью ползунка, расположенного в левой части окна, задается амплитуда генерируемых сигналов. В центральной части окна расположены три поля: "Single tone length" - длина одного сигнала, соответствующего одному символу (от 0.001 до 2 секунд), "Break length" - длина промежутка между символами в последовательности (от 0.001 до 2 секунд), "Pause length" - длина паузы между последовательностями (от 0.001 до 5 секунд). Если установлен флажок "Fade the edges of each tone" (сгладить края каждого сигнала), то в начале сигнала его амплитуда будет постепенно повышаться от нуля до значения, которое задается ползунком, расположенным в левой части экрана, а в конце сигнала она будет плавно понижаться до нуля. Это необходимо для того, чтобы избавиться от отстойных щелчков. Список "Insert new tone sequence at" поможет добавить последовательность в файл так же, как это делалось с сэмплами.


Спецвыпуск Xakep, номер #017, стр. 017-012-5, Компьютерные трубадуры: музстудия на домашнем писюке

Компьютерные трубадуры: музстудия на домашнем писюке

light (losi@online.ru)

Спецвыпуск Xakep, номер #017, стр. 017-012-5

Игры с модуляцией

Последний, самый сложный тип синтеза осуществляется с помощью встроенного в "Sound Forge" FM-синтезатора. FM-синтезатор - это набор из нескольких генераторов, каждый из которых производит волновой сигнал определенной частоты и амплитуды. Сочетание букв FM расшифровывается как "Frequency Modulation", то есть "частотная модуляция". Частотная модуляция - это периодическое изменение частоты волнового сигнала, причем график изменения частоты тоже имеет волновую форму. В FM-синтезаторе частотная модуляция осуществляется следующим образом. Один из генераторов производит волновой сигнал, который подается на второй генератор. В результате этого частота сигнала второго генератора начинает периодически изменяться в соответствии с сигналом первого генератора. В этом случае говорят, что первый генератор модулирует второй. Если ничего не понял, просто попробуй. В FM-синтезаторе "Sound Forge" - четыре генератора, которые могут соединяться в различных конфигурациях.

Для настройки параметров FM-синтезатора предназначено диалоговое окно "FM Synthesis" (FM-синтез), которое вызывается командой "FM" через "Synthesis -> Tools".

Конфигурация генераторов задается с помощью ползунка, который расположен в правой нижней части этого диалогового окна под кнопкой "Preview" (прослушивание). В конфигурацию может входить любое количество генераторов от 1 до 4. В поле "Total output waveform length" задается длительность синтезируемого сигнала (от 0.001 до 60.000 секунд). Для того чтобы настроить параметры какого-либо генератора, выбери среди переключателей группы "Current operator" тот, который соответствует нужному генератору. Количество доступных переключателей зависит от выбранной конфигурации.

Под переключателями расположено окно, в котором редактируется график огибающей амплитуды сигнала текущего генератора (попробуй повторить 5 раз подряд :)). Редактируется он очень просто: перетаскиванием узлов, изначально их два, но можно сделать восемь (щелчок левой кнопки мыши - создать узел, щелчок правой кнопки мыши - удалить узел). Если нажать кнопку "Reset", то график примет свой изначальный вид. Максимальное значение амплитуды огибающей задается с помощью ползунка "Amplitude" (Inf. To 0 dB), расположенного в левом углу окна. В списке "Operator shape" выбирается форма волны сигнала текущего генератора, а в поле ввода "Frequency" - частота (от 0.00 до 22 050 Гц). С помощью ползунка Feedback (0 to 100%) задается коэффициент обратной связи, от которого зависит уровень сигнала, подаваемого с выхода генератора на его же вход. Если этот коэффициент не равен нулю, то генератор будет сам себя модулировать. Список "Insert waveform at" здесь работает так же.


Спецвыпуск Xakep, номер #017, стр. 017-012-6, Компьютерные трубадуры: музстудия на домашнем писюке

Компьютерные трубадуры: музстудия на домашнем писюке

light (losi@online.ru)

Спецвыпуск Xakep, номер #017, стр. 017-012-6

В самом верху окна "FM Synthesis" находится список "Name", в котором можно выбрать шаблон настроек FM-синтезатора. Можно также создать свой шаблон. После того как настройка параметров FM-синтезатора закончена, нажми кнопку "Save As".

Ну все, теперь ты умеешь синтезировать звук. Держись, Планета! С обработкой звука эффектами сложностей не возникнет. Набор эффектов "Sound Forge" мало чем отличается от других аудиоредакторов. Выделяешь фрагмент файла, который хочешь обработать, ищешь в меню "Effects" нужный эффект и применяешь его.

Rebirth RB-338

Эту прогу я рекомендую, так как она является качественной программно реализованной имитацией очень популярных сегодня двух одноголосых аналоговых синтезаторов/секвенсоров "Roland TB-303" и двух драм-машин "Roland TR-808" и "Roland TR-909". Все, кто занимается альтернативными стилями танцевальной музыки, должны знать эти названия. В отличие от большинства подобных программ, "RB-338" не только хорошо работает в реальном времени даже на маломощных машинах, но и производит звук, очень близкий к имитируемым устройствам. В принципе можно записывать музыкальные произведения с помощью только этой программы, но мы будем пользоваться ею как дополнением к более мощной "Cakewalk" для создания ударных и инструментальных партий. Как и предыдущая программа, "Rebirth" не требует специальной настройки. Установила и забыла.

На синтезаторах и драм-машинах, которые имитирует программа, нельзя играть в прямом смысле этого слова (нажимая клавиши на клавиатуре). Вместо этого для каждого устройства задается последовательность действий, выполняемых при воспроизведении композиции. У каждого устройства есть набор паттернов, воспроизводимых в определенной последовательности. Паттерн состоит из шагов, каждому из которых может быть назначена нота или ударный звук. Длительность паттерна не превышает шестнадцати шагов. Программирование последовательностей паттернов, составляющих композицию, осуществляется в рабочем окне, которое появляется сразу после создания или открытия композиции.

Что на фейсе у "Rebirth RB-338"?

Вверху рабочего окна композиции торчит панель "Transport". Она содержит несколько элементов управления. Поле "Tempo" - для определения темпа. Пять кнопок ("Play", "Stop", "Rewind", "Fast Forward", "Record") - для управления воспроизведением. Переключатель между режимом "Pattern" и "Song mode". "Pattern" предназначен для программирования паттернов. При воспроизведении в этом режиме каждый из активных в данный момент паттернов воспроизводится в цикле. Режим "Song mode" предназначен для программирования композиции и позволяет записывать смену паттернов и изменение положения манипуляторов в различных тактах. В поле "Bar" вводится текущее значение временной позиции. Выключатель "Loop" убирает режим зацикливания. В поле ввода "Start" задается начальный такт. В поле "Length" - длина петли.


Спецвыпуск Xakep, номер #017, стр. 017-012-7, Компьютерные трубадуры: музстудия на домашнем писюке

Компьютерные трубадуры: музстудия на домашнем писюке

light (losi@online.ru)

Спецвыпуск Xakep, номер #017, стр. 017-012-7

Ниже расположены секции синтезаторов и драм-машин. Слева от каждой секции расположена соответствующая ей панель "Pattern". С помощью пимп "A", "B", "C" и "D" выбирается банк паттернов, а с помощью кнопок с цифрами от 1 до 8 из банка выбирается паттерн. В поле "Steps" задается длительность паттерна. Справа от любой секции тусуется соответствующая ей панель "Mix" с элементами управления: выключатель звучания секции (зеленая лампочка), вертикальный ползунок для управления уровнем сигнала, манипулятор "Pan", отвечающий за расположение звучания секции на панораме, манипулятор "Delay", задающий уровень задержки, и кнопки "Dist" (выключатель эффекта "дисторшн"), "PCF" (выключатель фильтра "PCF") и "Comp" (выключатель компрессора).

В правую часть задвинута колонка из пяти панелей. Первая панель - "Master" с ползунком для регулировки уровня суммарного сигнала всех секций. Кнопка "Comp" включает и выключает компрессор. Следующая панель - панель "PCF" - сделана для управления параметрами фильтра, который моделируется генератором огибающей, имеющим несколько десятков собственных шаблонов. Номер шаблона выбирается в списке "Pattern". Переключатель "Mode" отвечает за выбор типа фильтра и может находиться в следующих двух положениях: "BP" - звук обрабатывается полосовым фильтром с одной полосой пропускания, и "LP" - звук обрабатывается фильтром подавления высоких частот. Параметры фильтра задаются с помощью четырех вертикальных ползунков: "Freq" - средняя частота полосы пропускания (частота среза), "Q" - степень звукового воздействия фильтра на частоте, задаваемой положением ползунка "Freq", "Amt" - степень воздействия генератора огибающей на фильтр, "Dec" - длительность огибающей. Далее следует панель "Delay", предназначенная для управления параметрами задержки. В поле "Steps" задается длительность задержки. Напротив расположен переключатель, определяющий единицу измерения этой длительности. Манипулятор "Pan" определяет положение заданного сигнала на панораме, а с помощью манипулятора "F.Back" задается уровень обратной связи (уровень задержанного сигнала, вновь посылаемого на линию задержки). Панель "Dist" сделана для управления сетингсами эффекта "дисторншн". На ней имеются два манипулятора: "Amount" - степень применения эффекта, и "Shape" - определяет характер эффекта. И, наконец, последняя панель "Comp" предназначена для управления параметрами компрессора. Компрессор ослабляет звуковой сигнал, когда его уровень достигает определенного значения. Это помогает избежать перегрузки звукового тракта и возникающих при этом искажений. На панели торчат два ползунка - "Ratio" (степень ослабления сигнала) и "Thres" (порог срабатывания компрессора).


Спецвыпуск Xakep, номер #017, стр. 017-012-8, Компьютерные трубадуры: музстудия на домашнем писюке

Компьютерные трубадуры: музстудия на домашнем писюке

light (losi@online.ru)

Спецвыпуск Xakep, номер #017, стр. 017-012-8

В рабочем окне торчат две секции управления параметрами синтезаторов "Roland TB-303", которые выглядят и управляются совершенно одинаково. В левой верхней части есть переключатель для выбора формы звуковой волны. Справа от него тусуется ряд манипуляторов: "Tune" - управляет высотой звука, "Cutoff" - определяет частоту среза фильтра подавления высоких частот, "Resco" - задает уровень сигнала, который подается с выхода фильтра на его вход, "Env.Mod" - степень воздействия генератора огибающей на фильтр, "Decay" - определяет длительность огибающей, "Accent" - степень изменения акцентированных нот. Ниже валяются органы управления, предназначенные для программирования паттернов. Кнопка "Clear" делает паттерн пустым. Кнопки "Back" и "Step" служат для выбора шага, который отобразится в поле "Edit Step". С помощью виртуальной клавиатуры выбранному шагу назначается нота. Закрепляем ноту за шагом нажатием кнопки, расположенной рядом со значком паузы. Если теперь удавить "Accent", то нота будет акцентирована, а если нажать "Slide", то между нотой текущего шага и следующей нотой будет более плавный переход. Кнопка "Up" повышает ноту на октаву вверх, а кнопка "Down" понижает на одну октаву вниз. Пимпа "Pith Mode" включает режим "Pith". В этом режиме любое нажатие клавиш виртуальной клавиатуры вызывает переход к следующему шагу.

Ваяем ударные партии

Для создания партий ударных используются секции двух драм-машин. Первая из них - это секция драм-машины "Roland TR-808". Для программирования паттерна нужно сначала выбрать твой паттерн на панели "Pattern" в секции драм-машины "Roland TR-808". Ударные звуки назначаются шагам паттерна так. Сначала выбирается ударный звук манипулятором, сидящим в секции справа. Каждому ударному звуку соответствует одна из вертикальных линеек, торчащих над кнопками, соответствующими шагам паттерна, которые находятся в нижней части секции. Каждая линейка содержит несколько манипуляторов и сокращенное название ударного звука, которое лежит в нижней части линейки. Щелкай мышью по нужному ударному звуку. В линейках ударных звуков и акцента могут быть следующие манипуляторы: "Level" - уровень громкости звука, "Tone" - окраска звука, "Tune" - высота звука, "Decay" - длительность звука, "Snappy" - уровень шумовой составляющей звука "Snare Drum".

Последняя секция - это секция драм-машины "Roland TR-909". Программирование здесь осуществляется так же, как и в предыдущей секции. Ударный звук выбирается с помощью вертикальных линеек, которые содержат сокращенное название звука и манипуляторы. На линейках секции драм-машины "Roland TR-909" могут быть такие манипуляторы: "Level" - уровень громкости звука, "Tune" - окраска звука, "Tone" - длительность шумовой составляющей звука "Snare Drum", "Snap" - уровень шумовой составляющей звука "Snare Drum", "Dec" - длительность звука.

Вот мы и разделались с "Rebirth".


Спецвыпуск Xakep, номер #017, стр. 017-012-9, Компьютерные трубадуры: музстудия на домашнем писюке

Компьютерные трубадуры: музстудия на домашнем писюке

light (losi@online.ru)

Спецвыпуск Xakep, номер #017, стр. 017-012-9

Послесловие

Я показал тебе весь комплекс программ для создания цифрового музона. С этого можешь начать. Я не смогу в одной статье научить тебя лабать хиты, поэтому придется попыхтеть кое над чем самому. Имея под рукой такие мощные средства, ты сможешь воплотить в жизнь, казалось бы, самые нереальные проекты. Развивайся! Встретимся в ячейках чарта.


Спецвыпуск Xakep, номер #017, стр. 017-018-1, "DIVX ;)". БЫЛ, ЕСТЬ И БУДЕТ ЕСТЬ!

"DIVX ;)". БЫЛ, ЕСТЬ И БУДЕТ ЕСТЬ!

Спецвыпуск Xakep, номер #017, стр. 017-018-1

Сибирский Лихоман (mydivx@mail.ru, http://mydivx.da.ru, UIN 151576820)

"DivX" - это вскрытый кодек "Windows Media MPEG-4 V3". В строке "производитель" в свойствах кодека сказано - "Hacked with Joy!"

В декабре 2000 выходит заплатка к "DivX 3.11" - "VKI patch" (Virtual Keyframe Interval). Это была революция в кодировании "DivX".

В описании на свой хакнутый вариант последней строкой он признался в своих программистских способностях. Дословно: "Last recommendation: use the regular VirtualDub to edit your AVI files, this one could be fucked up by my hacks".

"FU" полностью отжирала все ресурсы машины, и параллельно нельзя было работать. Комп приходилось оставлять на время кодирования в покое.

Новая хак-версия суперпопулярной программы "Virtual Dub" (by Avery Lee) должна была дать, по мнению автора хака, "продвинутый контроль над битрейтом"

При этом фильм может содержать оригинальный DVD звук с "Dolby Digital 5.1" и субтитры на нескольких языках. А так как кодек является free, по крайней мере старые его версии (какая может быть лицензия на хакнутую программу?), то зеленая дорога открыта - кодируйте на здоровье!

Все мы юзаем дивух. И не думай тут отмазываться :)! Почти на каждом винте сейчас можно нарыть пару... десятков блок-бастеров. Тебе никогда не хотелось узнать, как так фильм, который занимает целый двдюк, вместился на обычную болванку и почти не потерял в качестве? Откуда взялся этот формат? Какие страсти-мордасти вокруг него разгорались? Хотелось? Узнай!

ПРЕДЫСТОРИЯ

В 1999-2000 годах на западе уже достаточно распространилась технология DVD, и массово стали продаваться DVD с фильмами. Есессно, не у всех хватало денег покупать двдюк каждый день, и народ научился обходить защиты DVD (CSS) и быстро стал клепать программы для рипинга видео в DVD-шном качестве. Но нужно было во что-то перекодировать суперкачественный MPEG-2, снятый с DVD, для дальнейшего хранения, переноса и просмотра. Пробовали разные кодеки - WMF (ASF), RA, "Angel Potion", "DivX", и большинство остановилось на последнем - его качество оказалось на средних потоках наилучшим, а AVI формат позволял в последующем без проблем редактировать полученный фильм (резать, перекодировать, накладывать другой звук и так далее).

Считается, что изначально "DivX" - это вскрытый кодек "Windows Media MPEG-4 V3". В строке "производитель" в свойствах кодека сказано - "Hacked with Joy!" Сама M$ в свое время решила отказаться по некоторым причинам от AVI формата при кодировании видео. Одна из них - ограничение на размер айвишника в два гига. Кодек был немного доработан (by Jerome Rota aka Gej) и выпущен в свет в сентябре 1999-го как "DivX", снова поддерживающий AVI. Впоследствии "DivX-3" включил в себя два отдельных кодека: почти оригинальную версию от M$, названную "DivX Low Motion" и кодировавшую лучше медленные сцены из фильмов и равномерные заливки, и доработанную версию, названную "DivX Fast Motion", кодировавшую лучше быстрые сцены и "зашумленные" записи.

Летом 2000 года в кодек была включена поддержка формата а-ля WMA, кодировавшего звук на низких битрейтах чище, чем mp3, правда, с ограничением потока в 64 килобит для 44 кГц/стерео. Аудиокодек был назван "DivX audio", а версия видеокодека была названа "DivX 3.11a" и являлась последней версией "DivX" из серии 3.хх. Авторы больше не захотели заниматься им, считая дело закрытым и вполне коммерческим, и начали долбить золотую жилу. Но об этом чуть позже.


Спецвыпуск Xakep, номер #017, стр. 017-018-2, "DIVX ;)". БЫЛ, ЕСТЬ И БУДЕТ ЕСТЬ!

"DIVX ;)". БЫЛ, ЕСТЬ И БУДЕТ ЕСТЬ!

Спецвыпуск Xakep, номер #017, стр. 017-018-2

ТЕХНОЛОГИЯ

"DivX" принадлежит к семейству кодеков из серии MPEG-4. Это, конечно, не полнокровный MPEG-4, в стандарт которого входит уйма приятностей. Кроме уже привычных нам субтитров, нескольких потоков разноканального звука, стандарт MPEG-4 поддерживает интерактивность, многослойность видео, графику поверх видео и еще кучу всего. А "DivX" предназначен изначально для передачи видеоданных (телеконференции, трэйлеры фильмов) со звуком по среднескоростным сетям Интернета и просмотра этих видеоданных на компьютере. Отсюда вытекают его упрощения и ограничения, которые некоторые злопыхатели пытаются ставить в вину всему стандарту MPEG-4. Дескать, и жмет он слишком сильно, и искажений больше, чем у MPEG-2 (DVD), и субтитров нет, и интерлейс записать нельзя...

Как у всех нормальных MPEG кодеков, у DivX есть ключевые кадры (КК), по-аглицки - Key Frames (KF), в которых записывается основная информация о видеопотоке, и дельта кадры (ДК), по-аглицки - Delta Frames (DF), в которых, для уменьшения потока (массы файла) записываются только изменения по отношению к предыдущему кадру. Следовательно, мы доперли до краткого описания серии MPEG стандартов: MPEG - это формат, который сжимает некий (аудио, видео) поток на основе удаления излишней информации. Как это выглядит на простом примере, показано на рисунке 1.

СОВЕРШЕНСТВОВАНИЕ ТЕХНОЛОГИИ

LM И FM

Первым усовершенствованием изначального кода M$ была попытка сделать кодек для быстрых сцен. Оригинальный код и его вскрытый собрат давали сильную грязь на местах быстрого сдвига объектов, так как, видимо, были в основном рассчитаны на неподвижно сидящего человека перед камерой для телеконференции, и его доработали до кодека "DivX Fast Motion" (FM). Это позволило кодировать фильмы с быстрыми сценами. Кодер же, изначально полученный из M$ варианта, был назван "Low Motion" (LM) - рисунок 2.

Неотъемлемое свойство этих двух кодеров - их отношение к заданному потоку. LM старается поддерживать поток на заданном уровне и может лишь чуть-чуть уменьшить или увеличить его. Скажем, абсолютно черную картинку нет смысла кодировать с большим потоком, поток из пальца не высосешь, как уж сожмется, но очень сложную картинку LM старается закодировать в пределах потока, лишь иногда немного превышая его, поддерживая при этом поток на среднем заданном уровне.

FM, в отличие от LM, старается зажать видеоинформацию по максимуму, не обращая внимания на заданный уровень, и в результате более-менее ровные заливки (стена, небо, лицо крупным планом) превращаются у него в мозаику, несмотря на то, что поток при этом меньше заданного в десятки раз! Простой пример - концерт великого тенора Паваротти. Очень статичная картинка. Конечно, ее нужно цифровать только через LM, но ради эксперимента зададим кодирование кодеком FM с потоком 3000 килобит - очень высокий поток, качества DVD. И получаем результат, посмотрите на увеличенное лицо мастера Лучиано (рисунок 3). К чести FM надо сказать, что качество движущихся объектов и сложных сцен он кодирует чище, чем LM.


Спецвыпуск Xakep, номер #017, стр. 017-018-3, "DIVX ;)". БЫЛ, ЕСТЬ И БУДЕТ ЕСТЬ!

"DIVX ;)". БЫЛ, ЕСТЬ И БУДЕТ ЕСТЬ!

Спецвыпуск Xakep, номер #017, стр. 017-018-3

ММ4

Понятно, что практически нет фильмов, включающих только быстрые или только медленные сцены. Возникла идея чередовать кодеки при кодировании разных частей фильма - медленные сцены с помощью LM, а быстрые с помощью FM, благо, что декодер для обоих кодеров один. Технология получила название "Mixed MPEG-4" (MM4), или смешанное кодирование.

Кодирование усложнялось - нужно было полностью дважды закодировать фильм обоими кодеками, а затем, с помощью специально написанных для этого программ, автоматически или вручную, выбрать медленные и быстрые сцены из обоих файлов и "смешать" их в один файл. Вариант имел два ограничения - закодированные разными кодеками файлы можно резать только по КК, так как в ДК нет полной информации о картинке, там записан только некий сдвиг, отличный от предыдущего кадра, и, порезав фрагмент по ДК, мы получим некий абстрактный "мазок". Это предусматривает большинство программ для "нарезки" фрагментов и не позволяет резать по ДК. Второе ограничение - оба фильма должны быть идентичными по параметрам видео: размер и частота кадров, которые можно случайно изменить, если на фильм при кодировании накладывались различные фильтры - обрезка кадра, шторки, изменение размера кадра или частоты кадров. Не допускается расхождение в размерах даже в 1 пиксель!

Сначала микширование ММ4 происходило вручную - фильмы, пожатые разными кодеками, просматривались в какой-то программе (скажем, "Virtual Dub"), сравнивались и выискивались фрагменты, лучше пожатые одним из кодеков, составлялась таблица КК, по которой затем нарезался из двух разных вариантов целый фильм. После этого накладывался звук. Надо сказать, что не всегда в ММ4 применяется кодирование именно двумя разными вариантами кодека (LM и FM). Иной раз можно получить гораздо лучшее качество фильма, если закодировать фильм одним кодеком (скажем, LM), но с разными битрейтами: для быстрых сцен поток повыше, чтобы ДК могли включать максимум изменений без пропуска кадров, а для медленных сцен - поток пониже, так как ровные фоны и слабые сдвиги LM сжимает намного лучше, оставляя при этом превосходное качество картинки.

Через некоторое время, в ноябре 2000, появились программы, которые позволили автоматизировать процесс ММ4, задав установки либо для получения минимального размера файла для фильма, либо, наоборот, - максимального качества. Некоторые из них позволяли проследить процесс вручную. Это были китайская программа "MakeFilm TNG" (by MI-CHI) и немецкая "Project DivX" (by Joern Thiemann). Зацени их фейс на рисунке 4.

Немецкий "Project DivX" был более наглядным (можно видеть рядом на экране оба варианта фильма), содержал автоматику (через обработку статистики кадров фильма в таблице "Oracle" с последующим сравнением на качество с оригиналом), позволял проделать процесс вручную (никакая автоматика не заменит субъективный взгляд человека на значимость артефактов), а также имел возможность локализации (отдельно лежал текстовый файл сообщений программы). Прожект позволял задать желаемый размер конечного файла для автоматической выборки, что было немаловажно для тех, кто хотел вписаться в размер CD, и предсказывал размер результирующего файла при ручной выборке. В результате "Project" прожил немного дольше, чем "MakeFilm". Оба проекта вышли первый и последний раз в конце ноября и авторами, похоже, больше не поддерживались.


Спецвыпуск Xakep, номер #017, стр. 017-018-4, "DIVX ;)". БЫЛ, ЕСТЬ И БУДЕТ ЕСТЬ!

"DIVX ;)". БЫЛ, ЕСТЬ И БУДЕТ ЕСТЬ!

Спецвыпуск Xakep, номер #017, стр. 017-018-4

VKI

Конечно, применение технологии ММ4 позволило существенно улучшить картинку, но была еще одна серьезная проблема: "грязь", "артефакты" на смене сцен. Первоначальный вариант кодека M$ и его детей имел опцию при кодировании - задание временного интервала между КК. Интервал задавался в целых секундах (от 1 до 9999), обычно применялась 1 секунда, чтобы иметь возможность нарезки фрагментов как можно ближе к сменам сцен. А парадокс заключается в том, что увеличение ключевого интервала может дать некоторое улучшение картинки при том же потоке данных.

В видеопотоке основная масса файла приходится на КК, при этом ДК играют роль бедных родственников - что останется от потока данных, то им и достанется, а следовательно, при резких сдвигах крупных объектов в кадре на кодирование этих изменений в ДК приходится очень маленький поток, и прут искажения. С увеличением же интервала между КК мы получаем уменьшение количества этих самых КК в фильме, и при том же потоке на них уходит меньше веса, и больше веса приходится уже на ДК, то есть в ДК можно закодировать ту же информацию с меньшими искажениями.

Как бы ни старались мы приблизить КК к смене сцен, сцены в фильме к секундам не привязаны. В результате при смене сцен на ДК падают очень большие изменения, которые сложно вместить в маленькую массу потока, предназначенного для ДК. И мы видим либо очень "заквадраченную" (как в сильно зажатом JPEG) картинку, либо кодек вообще выкидывает эти кадры из потока, чтобы поддержать его на заданном уровне, и объекты начинают "дергаться" - плавность движения нарушается. Длится это до следующего КК, когда картинка полностью восстанавливается, что тоже нервирует - то чисто, то грязно.

И вот в декабре 2000 выходит заплатка к "DivX 3.11" - "VKI patch" (Virtual Keyframe Interval), которая сильно облегчила жизнь, расставляя ключевые кадры не только через заданный интервал в секундах, но и в местах смены сцен (просто проверяя массу ДК и сравнивая ее с массой предыдущего КК - если дельта кадр оказывался слишком тяжелым, его заменяли на ключевой). При этом скорость кодирования практически не изменилась! Патч вышел для обоих вариантов кодека и устанавливался простой заменой соответствующих dll в каталоге "system".

Результат превзошел все ожидания. Простая установка лишних ключевых кадров в наиболее сложных местах обеспечивала резкий подъем качества. При этом размер файла иногда даже уменьшался! Это происходило оттого, что один ключевой кадр заменял собой несколько "тяжелых" дельта кадров. Теперь ключевой интервал можно было устанавливать хоть в 3 секунды (как в установках по умолчанию в патче), а хоть и в 999 секунд - ключевые кадры сами ставились в нужных местах, при этом оставалось гораздо больше места на дельта кадры, что давало дополнительное повышение качества! Это была революция в кодировании "DivX".


Спецвыпуск Xakep, номер #017, стр. 017-018-5, "DIVX ;)". БЫЛ, ЕСТЬ И БУДЕТ ЕСТЬ!

"DIVX ;)". БЫЛ, ЕСТЬ И БУДЕТ ЕСТЬ!

Спецвыпуск Xakep, номер #017, стр. 017-018-5

Как же отнеслись программы ММ4 к этому новшеству? "MakeFilm" просто отказался работать. Это случилось потому, что для проверки идентичности двух файлов, закодированных разными способами, программа сравнивала в том числе количество КК в обоих источниках. А при кодировании разными VKI кодеками количество КК в файлах, закодированных вроде бы с одного источника, очень часто различаются. Ведь задавая разный уровень потока для двух вариантов фильма, мы провоцировали кодек по-разному считать массу дельта кадров, и, кроме того, ключевые кадры тоже сжимаются при этом по-разному. Как следствие, в LM вариантах количество ключевых кадров было несколько больше. Ну а так как "MakeFilm" тормозил с развитием, ошибка в проверке идентичности параметров файлов полностью лишила его работоспособности.

"Project DivX" тем не менее сохранил свою значимость для ММ4 кодирования. Несмотря на различие в количестве ключевых кадров, он по-прежнему позволял составлять таблицу ключевых мест (таблица КК, по которым производилась нарезка фрагментов из двух файлов) и затем автоматически составлял из нужных фрагментов целый фильм. Почему же ему не мешало различие в количестве КК? А потому, что переход на следующий ключевой кадр в "Project" осуществляется по FM варианту, в котором ключевых кадров должно быть меньше, и "лишние" ключевые кадры LM варианта, попавшие в этот фрагмент, просто не замечались программой!

FRAME SERVER

Кодирование DVD в "DivX" представляет собой задачу из нескольких этапов. Некоторые программы позволяют объединить эти этапы, другие имеют больше настроек и удобнее на каком-то одном этапе. Самая популярная программа кодирования - "Virtual Dub", к сожалению, совершенно не подозревает о существовании формата MPEG-2 (DVD), и для кодирования в "Дубе" (а он позволяет накладывать на видео различные фильтры, подрезать кадр или изменить его размер) сначала приходится подготавливать видео различными способами.

Первый способ - это закодировать видео на очень высоких битрейтах, для минимума искажений изначального материала, а затем уже перекодировать его еще раз в "Дубе". Это отнимает время, но позволяет сразу создать копию с хорошим качеством, которую можно затем перекодировать на более низкие битрейты или другим кодеком для последующего микширования с помощью технологии ММ4.

Второй способ - воспользоваться фрэймсервером. Это программа, которая является посредником между MPEG-2 (VOB файлом) и программой кодирования. Она передает в кодирующую прогу кадры из исходного видео. Это позволяют VFAPI и plug-in для "FlasK MPEG - avisynth". В самом "Vdub" есть возможность фрэймсерва, скажем, можно использовать его фрэймсерв для передачи кадров из "Дуба" в "Project Divx".


Спецвыпуск Xakep, номер #017, стр. 017-018-6, "DIVX ;)". БЫЛ, ЕСТЬ И БУДЕТ ЕСТЬ!

"DIVX ;)". БЫЛ, ЕСТЬ И БУДЕТ ЕСТЬ!

Спецвыпуск Xakep, номер #017, стр. 017-018-6

КОДИРОВАНИЕ ММ4 В ОДИН ПРОХОД

В декабре 2000-го появился еще один конкурент первых двух автоматических ММ4 программ - модификация "Virtual Dub MM4". Автор этого хакнутого варианта "Дуба" использовал новую технологию в ММ4. Появилась возможность задать в одной программе нужные потоки для LM и FM (или для двух LM с высоким и низким битрейтами) и уровень потока, при котором кодирование переходило с одного кодека на другой. Сжатие всего фильма проводилось автоматически и за один раз, что было очень удобно и уменьшало количество времени примерно в полтора раза. Программа захватывала в буфер несколько кадров, проверяла, насколько хорошо они сжимаются, и, если поток превышал норму, переходила на другой кодек. Аналогично, если поток был ниже порога, переходила обратно на первый кодек. При этом в течение кодирования можно было увидеть на графике моменты перехода (рисунок 5). К сожалению, совершенно потерялась возможность подогнать готовый файл под размер CD - только перекодируя все заново с другими настройками, можно было подогнать нужный размер файла.

Появилась также возможность использования дополнительной опции, которая была в "Дубе" уже давно, - детектор смены сцен не только по критической массе дельта кадра, но и по яркостной составляющей сцены. Дело в том, что VKI patch не всегда точно отслеживал смену сцен. Нет, он справлялся со своей работой, усердно пересчитывая массы дельта кадров, но на некоторых фильмах, слишком серых или светлых, он не чувствовал эти переходы. Из-за того, что сцена менялась не контрастно, дельта кадр не превышал порога массы, так как картинка автоматически сжималась слишком сильно. Но квадратность шла, и народ жаловался.

В своем описании автор "Дуба ММ4" описал три возможности выставления ключевого кадра: в случае превышения размера дельта кадра над размером предыдущего ключевого кадра, в случае срабатывания детектора яркости сцены самого "Дуба" и в обычном случае - по временному интервалу от последнего ключевого кадра, задаваемому в установках кодека.

Жаль, что автор этого прогрессивного варианта не подписался. Могу только констатировать его национальность по слову "Abbrechen", оставшемуся в одном из диалогов "Дуба". В описании на свой хакнутый вариант последней строкой он признался в своих программистских способностях. Дословно: "Last recommendation: use the regular VirtualDub to edit your AVI files, this one could be fucked up by my hacks". ("Юзай нормальный "Дуб" - этот может быть трахнут на всю голову моим хаком" :)) Занавес.

УСЛОЖНЕННЫЙ ММ4 В НЕСКОЛЬКО КОДЕКОВ

В феврале 2001-го появилась программа "FairUse" (рисунок 6), позволяющая кодировать сразу в несколько вариантов кодека (от 2 до 10), подбирая нужный поток для заданного качества и конечного размера файла. Кроме того, имелась некая проверка качества кодирования, посредством сравнения всех кодируемых вариантов с оригиналом. Программа содержала свои собственные, хакнутые и доработанные варианты кодека "DivX", которые, по мнению автора, должны были расставлять ключевые кадры более прогрессивным способом.


Спецвыпуск Xakep, номер #017, стр. 017-018-7, "DIVX ;)". БЫЛ, ЕСТЬ И БУДЕТ ЕСТЬ!

"DIVX ;)". БЫЛ, ЕСТЬ И БУДЕТ ЕСТЬ!

Спецвыпуск Xakep, номер #017, стр. 017-018-7

"FU" позволяла кодировать прямо с DVD, предварительно рипая его на винт в своем собственном формате, требовала на диске место под рип DVD и все кодируемые варианты (то есть 2-10 раз по 600 мегов), сразу могла сделать обрезку кадра и деинтерлейс и могла вставить субтитры из VOB файла прямо в кадр. Она имела свой wizard, помогающий настроить параметры кодирования и была полностью автоматической: настроил и выключил монитор, иди спать, программа сама все закодирует, выберет, порежет и сохранит нужный вариант.

Интересный способ представления потока видеоинформации был использован автором - kbit/frame. И действительно, при обычном способе задания потока, kbit/sec, не учитывается количество кадров в секунду, а между тем, при 30 кадрах на каждый кадр упадет гораздо меньше информации, чем при 24 кадрах! Об этом, обычно, никто не задумывается, но качество картинки при одинаковом потоке у 24-кадрового фильма будет выше.

Большим недостатком проги было то, что автор так и не соизволил вставить поддержку кодирования с винта для случая, когда DVD уже списан на винт другой программой и отдан. Вторым недостатком была тяжесть процесса: "FU" полностью отжирала все ресурсы машины, и параллельно нельзя было работать. Комп приходилось оставлять на время кодирования в покое. Третьим недостатком для некоторых было время кодирования: оно увеличивалось в несколько раз по сравнению с классическими способами. Но полностью автоматический режим - рулез, и качество кодирования сразу в несколько вариантов - тоже.

SBC И КОДИРОВАНИЕ В ДВА ПРОХОДА

Лавры "FairUse" не давали покоя другим авторам, и серия "Dub MM4" была продолжена в апреле 2001-го новым продуктом - "Nandub" (by Nandos systems). Новая хак-версия суперпопулярной программы "Virtual Dub" (by Avery Lee) должна была дать, по мнению автора хака, "продвинутый контроль над битрейтом" (Smart Bitrate Control). Автор Америку не открывал: использовались технологии, уже опробованные за несколько месяцев. Это был ММ4 - его вариант, когда используется несколько кодеков в один проход с выбором порога перехода.

Главным же достоинством этого хакнутого варианта стала возможность кодирования в два прохода. Конечно, при этом увеличивалось время кодирования, но качество при очень сильном сжатии могло заметно улучшиться, а кроме того, решалась очень важная проблема - подгон размера файла точно под размер компакт-диска. Как же это происходит? За первый проход программа собирает файл статистики, насколько сильно фильм сжимается разными кодеками с разными установками, и оценивает по некоторым параметрам качество получаемого материала. Вторым же проходом осуществляется собственно кодирование по данным файла статистики.

К сожалению, автор внедрил столько новых опций в свой продукт, при этом используя одному ему понятную терминологию, что его изучение и использование, ввиду полного отсутствия какого-либо описания, превратилось в игру "Что? Где? Когда?". Сам автор извинялся примерно в следующем стиле: "Sorry guys, I haven't had a minute to prepare a decent documentation in the past few days and I feel I have to rush a bit the public release of this software because it seems many people are waiting for it. So, it goes out as is." В общем, звиняйте хлопци, времени нету, нехай плывет самотеком, сами разберетесь. Большинство пользователей тогда оттолкнуло именно это безмерное усложнение и без того уже сложного процесса кодирования. Хотя многие честно пытались разобраться.


Спецвыпуск Xakep, номер #017, стр. 017-018-8, "DIVX ;)". БЫЛ, ЕСТЬ И БУДЕТ ЕСТЬ!

"DIVX ;)". БЫЛ, ЕСТЬ И БУДЕТ ЕСТЬ!

Спецвыпуск Xakep, номер #017, стр. 017-018-8

Программа продолжала развиваться и на настоящий момент содержит несколько полезных возможностей, в том числе вставку различного типа звука в AVI и поддержку двухпотокового аудио. К чести автора, он упростил свой "Smart Control" и сделал настройки более доступными. На данный момент это наиболее популярная программа сложного кодирования.

DIVX 4

Пока шло совершенствование технологии, те, кто заварил эту кашу, усиленно хотели хорошей жизни. В 2000 году бывший администратор MP3.com и стратегический консультант "InterVU" Джордан Гринхол нашел хакера Джерома Рота (Gej) и предложил создать компанию на основе его уже популярной (двенадцать миллионов закачек с сайта) "DivX" технологии. В мае 2000-го, при поддержке третьего основателя, Джо Бездека, была создана компания "DivXNetworks, Inc.". В течение лета компания набрала команду и открыла сайт www.projectmayo.com, посвященный кодеку и новым планам на жизнь - коммерциализации проекта. Начался активный поиск инвесторов, и уже в сентябре авторам выпали первичные инвестиции (Series A) на сумму пять лимонов и шестьсот штук зеленых.

Сам знаешь, на хакнутой версии на Западе далеко не уедешь - засудят. Пришлось по-быстрому переписывать и дорабатывать код. При этом было объявлено, что кодек становится открытым проектом - "OpenDivX", и приглашались все желающие дорабатывать и совершенствовать его. Кодек должен был стать, по наивному мнению многих, народным проектом, а по мнению авторов - золотым тельцом.

В мае 2001-го компания открыла сайт divx.com, на котором собрались новости Divx-технологии, последние версии кодека, наиболее популярные программы для него, форум и примеры видеоклипов. Про старый вскрытый кодек 3.хх, конечно же, полное молчание, как будто никто ничего и не вскрывал.

Сырой четвертый кодек был выпущен в начале 2001 года, содержал интересные фичи и множество глюков. Он поддерживал двухпроходное кодирование (с созданием за первый проход файла статистики сложности), деинтерлейс, сжатие по битрейту и по процентному качеству, переменный ключевой интервал, возможность задания ключевого интервала в кадрах, а не в секундах, возможности подстройки параметров квантизации и параметров подсчета среднего битрейта. В августе 2001-го был выпущен релиз (рисунок 7), который мирно продолжал глючить.

Компания объявила своим приоритетом создание программного обеспечения "DivX Open Video System(tm)" (OVS) для поставки закодированного видео конечному пользователю (video-on-demand, VOD). Причем для этого будут использованы новейшие security-технологии для борьбы с пиратством. За что боролись, на то и напоролись. "DivX", вроде бы "Open source", теперь будет вставлять в кодируемый или транспортируемый фильм скрытые коды авторизации :(...


Спецвыпуск Xakep, номер #017, стр. 017-018-9, "DIVX ;)". БЫЛ, ЕСТЬ И БУДЕТ ЕСТЬ!

"DIVX ;)". БЫЛ, ЕСТЬ И БУДЕТ ЕСТЬ!

Спецвыпуск Xakep, номер #017, стр. 017-018-9

В общем-то, это дело компании, что они там объявляют, волноваться особенно не о чем. Наше дело - правое. Даже если кодек перестанет быть free, его все равно вскроют и будут использовать для переписи DVD. Конечно, пока эти DVD сами не станут по 5 копеек пучок. А что же нам дают последние версии кодека?

Кодек 4.х не претерпел крупных изменений с бета-версий, хотя за полгода вышло уже 12 релизов - на сегодняшний день последняя версия кодека называется "DivX 4.12". Многие глюки кодека идут с фильмами, закодированными старым, 3.хх кодеком. Скажем, в некоторых плеерах изображение может просто перевернуться вверх ногами. Поэтому рекомендации лучших собаководов - отвечать "нет" на вопрос "Проигрывать ли старые 3.хх фильмы новым кодеком?" при установке кодека и иметь установленную 3.11 версию для старых фильмов. Иногда возникают проблемы со звуком при установке "DivX 4".

ВЫВОДЫ

Кодек DivX с применением последних технологий кодирования позволяет сжимать оригинальный DVD диск в десять и более раз, вмещая его на 1-2 компаков и оставляя при этом качество фильма на очень хорошем "потребительском" уровне - намного лучше VCD или VHS. И это качество вполне приемлемо для просмотра на среднем домашнем компьютере или для вывода с компьютера на телевизор. При этом фильм может содержать оригинальный DVD звук с "Dolby Digital 5.1" и субтитры на нескольких языках. А так как кодек является free, по крайней мере старые его версии (какая может быть лицензия на хакнутую программу?), то зеленая дорога открыта - кодируйте на здоровье!

Проперся? Другую инфу о DivX и рекомендации по кодированию, а также ссылки на программы и форум по данной теме ищи на http://mydivx.da.ru.


Спецвыпуск Xakep, номер #017, стр. 017-024-1, "DivX ;)", MPEG-4 и DVD-фильм на одном CD

"DivX ;)", MPEG-4 и DVD-фильм на одном CD

Спецвыпуск Xakep, номер #017, стр. 017-024-1

Сибирский Лихоман (mydivx@mail.ru, http://mydivx.da.ru, UIN 151576820)

Первое правило, которое нужно усвоить: если хочешь смотреть фильм в DVD-качестве - плати за DVD.

В зависимости от желаний, нам нужно нацеливаться на определенный результат. В основном это связано с выбором и настройками программ и количеством кодирования.

Обычно фирменные DVD зашифрованы с помощью CSS (Content Scrambling System) технологии, возможно также применение "Macrovision кодирования" для предотвращения переписи с DVD проигрывателя.

Наиболее развитой, простой и популярной на данный момент программой для вскрытия DVD является "SmartRipper".

Оставляй место под звук, особенно если ты делаешь декодирование, и звук запишется в формате wav - под полуторачасовой wav потребуется около 1 гектара.

Если хочется получить наиболее качественный результат, то придется применить способ двойного кодирования.

ПРОЛОГ

Все программы и технологии, приведенные в статье, служат учебным целям и не предназначены для нелегального копирования лицензионных видеоданных. Автор снимает с себя ответственность за применение его учебной статьи в нелегальных целях. Понял, да?

ОБЩИЕ ПРИНЦИПЫ

Процесс кодирования DVD в "DivX" условно можно разделить на несколько этапов:

1. Рипинг DVD - вскрытие защиты, перенос VOB-файлов на винт.

2. Подготовка к перецифровке - выдирание из VOB файлов звука, субтитров, фреймсерв.

3. Оцифровка - сжатие видео в "Divx", а звука в mp3 (или АС3);

4. Монтаж - ручной или автоматический ММ4, наложение звука на видео, возможно два аудио потока, нарезка под размер болванок.

Каждый из этих этапов подразумевает наличие одной или нескольких специализированных программ, выбор и настройка которых зависит от ожидаемых результатов, а также от личных предпочтений.

ЖЕЛАЕМОЕ & ДЕЙСТВИТЕЛЬНОЕ

Чего же мы хотим от "DivX"? По-видимому, фильма DVD-качества на одном компакт-диске. Но вечного кайфа не бывает, и технологии не настолько быстро рвутся вперед, чтобы за 10 лет создать кодек, в десятки раз уменьшающий поток при том же качестве. Недаром развитие архиваторов практически остановилось: за последние 10 лет данные архивироваться особо лучше не стали. Вот и от MPEG-4 (DivX) нельзя ожидать столь революционных сдвигов по отношению к MPEG-2 (DVD).

Первое правило, которое нужно усвоить: если хочешь смотреть фильм в DVD-качестве - плати за DVD. Все рекламные заявления о таком качестве на средних битрейтах, а особенно на низких (при которых можно впихнуть 3-часовой фильм на один CD) - гонево! Чем-то приходится поступиться для того, чтобы качество осталось на более-менее приличном уровне. Скажем, уменьшить размер кадра, ухудшить звук, размыть или заквадратить картинку, уменьшить количество кадров в секунду и прочие "прелести".

Второе правило, особенно для оверклокеров: если у тебя глючит какая-то прога, попробуй сначала поставить частоту проца на номинал. Программы обработки видео очень сильно напрягают камень, и если на разогнанном процессоре не глючит "Word", это еще не означает, что и "Virtual Dub" будет работать в тех же условиях. Хотя при этом не забывай, что практически все программы для работы с DVD и "DivX" написаны хакерами и любителями, так что они вполне имеют право на глюки и неработоспособность.


Спецвыпуск Xakep, номер #017, стр. 017-024-2, "DivX ;)", MPEG-4 и DVD-фильм на одном CD

"DivX ;)", MPEG-4 и DVD-фильм на одном CD

Спецвыпуск Xakep, номер #017, стр. 017-024-2

Разобравшись с этими исходными данными, посмотрим, что же реально мы можем получить от "DivX"? Реально мы можем получить фильм, примерно в 2-3 раза уменьшенный по площади кадра, возможно - с ухудшенным звуком, несколько смазанный из-за применения фильтров сглаживания и требующий достаточно много ресурсов по сравнению с DVD и, как следствие, с возможностью подтормаживания на слабых тачках. Что мы и наблюдаем в последнее время, покупая "Real DVD quality" диски...

Есть несколько категорий любителей фильмов в формате "Divx". Одни хотят максимального возможного качества, наиболее приближенного к DVD, несмотря на количество затраченного времени и CD. Вторые хотят, по тем или иным причинам, иметь фильм обязательно на одном диске, не важно - с каким звуком и качеством изображения, лишь бы был. Есть еще третьи, кому в принципе все равно, насколько хорош будет результат, лишь бы он был побыстрее. В зависимости от желаний, нам нужно нацеливаться на определенный результат. В основном это связано с выбором и настройками программ и количеством кодирования.

РИПИНГ DVD

ЧТО ТАКОЕ DVD?

Digital Versatile Disc (DVD) содержит обычно MPEG-2 поток в виде нескольких основных, VOB файлов по 1 гигу каждый, и индексные, IFO файлы, содержащие дополнительную информацию о потоке. MPEG-2 поток может включать в себя несколько видеопотоков, несколько аудиопотоков, несколько потоков субтитров и другую информацию. Обычно фирменные DVD зашифрованы с помощью CSS (Content Scrambling System) технологии, возможно также применение "Macrovision кодирования" для предотвращения переписи с DVD проигрывателя.

Шифрованные диски приходится предварительно вскрывать DeCSS прогами. Вскрытие DVD представляет собой копирование VOB файлов на жесткий диск с одновременным удалением из них защитного кода. Это позволяют сделать "clad DVD", "DeCSS", "DVTool", "DVD Decrypter", "SmartRipper", "FlasK MPEG", "vStrip". У них разный уровень дружественности интерфейса и различные возможности для вскрытия и копирования.

Наиболее развитой, простой и популярной на данный момент программой для вскрытия DVD является "SmartRipper" (by TRON, последняя версия 2.41), позволяющая не просто дешифровать и скопировать голые VOB файлы на винт, но и предварительно выбрать главы (chapters), которые нужно копировать, звук, который нужно включать в поток, и прочие фишки (рисунок 1). Программу можно взять здесь: http://mydivx.by.ru/files/SR241.rar.

SMARTRIPPER

Вставляем DVD в драйв, запускаем программу, которая при запуске анализирует IFO файлы на DVD, затем открывается рабочее окно программы. Слева ты видишь три способа копирования содержимого DVD - "movie" (фильм), "files" (только VOB файлы) или "backup" (все содержимое диска).

Выбирай "movie" и выделяй "all chapters" (главы) основного "Title" (обычно он самый большой по размеру). Есть также возможность копировать отдельные потоки - в закладке "stream processing", в случае, если тебе нужен только звук АС3 или только видео, или только видео с субтитрами. Если после выбора способа копирования у тебя хватает места на диске, то под кнопкой "Settings" появится кнопка "Start", нажав на которую, ты начнешь процесс.


Спецвыпуск Xakep, номер #017, стр. 017-024-3, "DivX ;)", MPEG-4 и DVD-фильм на одном CD

"DivX ;)", MPEG-4 и DVD-фильм на одном CD

Спецвыпуск Xakep, номер #017, стр. 017-024-3

В процессе копирования ты сможешь наблюдать способы дешифровки, массу файлов, скорость диска в единицах DVD speed. В результате получим несколько файлов в папке по заданному пути. Это будут VOB файлы (файлы потока MPEG-2) и служебные файлы IFO. Если ты задавал копирование по главам, то в папке также окажутся файлы .lst, .txt, .idx - это служебные файлы статистики самого "SmartRipper".

Следующим шагом будет подготовка VOB файлов к кодированию в других программах. Наилучшим способом для этого является использование фрэймсервера "VFAPI". Для того чтобы передать ей управление потоком MPEG-2, нам нужно сначала создать проект, который бы она понимала. Такой проект создает "DVD2AVI" (рисунок 2). Программу можно взять здесь: http://mydivx.by.ru/files/DVD2AVI_176.zip.

DVD2AVI

Эта программа может открывать один или последовательность VOB файлов и кодировать их сразу в виде DivX; последние версии имеют встроенный ресайз, кропинг, но не имеют деинтерлейса и iVTC. "DVD2AVI" может сохранять звуковые дорожки из выбранного фрагмента или целого фильма в любом формате, включенном в VOB файлах, - АС3, МР2, LPCM WAV. Сохранять звук она может как в оригинальном виде, так и в виде декодированного wav (то есть может смикшировать 6 каналов АС3 в стерео). Звук можно переводить из 48 кГц в 44 и нормализовать (повышать громкость звука до определенного предела).

Запускай программу. File/Open. Выбирай первый VOB файл, остальные VOB из той же серии подключатся в список автоматом. Смотри меню "Audio".

Если хочешь взять оригинальный DVD звук АС3 без изменений, то включай "Channel format/Dolby Digital" и "Dolby Digital/Demux All Tracks". Если нужен MP2, включай "Channel.../MPEG" и "MPEG/Demux All". Для декодирования АС3 в стерео нужно выбрать трек в меню "Track number". Номер нужного потока смотри в "SmartRipper" (Stream processing). Можно также перевести звук 48 кГц в 44 килогерца. В случае тихого звука на DVD доступно его усиление (normalization). При переводе АС3 звука в обычный стерео можно включить опцию "Dynamic Range Control", которая позволит усилить тихие звуки, не усиливая при этом громкие.

Запускай "File/Save project". Файл проекта будет занимать совсем немного места, но звук от фильма будет записан в ту же папку - оставляй под него место, особенно если ты делаешь декодирование, и звук запишется в формате wav - под полуторачасовой wav потребуется около 1 гектара.

После создания проекта d2v и копирования звука фильма можно приступать к фреймсервингу. Для этого нам понадобится программа "VFAPI" (рисунок 3). Программу можно взять здесь: http://doom9.org/Software/mpg/VFAPIConv-1.04-EN.zip.

VFAPI

Запускай "VFAPI Reader" (Converter) и открывай проект d2v - программа выдает диалоговое окно, на которое отвечай "ОК" (обе галочки в окне должны стоять). После этого нажимай "Convert" и лови AVI файл, содержащий служебную информацию для "VFAPI Reader". С этой прогой все.


Спецвыпуск Xakep, номер #017, стр. 017-024-4, "DivX ;)", MPEG-4 и DVD-фильм на одном CD

"DivX ;)", MPEG-4 и DVD-фильм на одном CD

Спецвыпуск Xakep, номер #017, стр. 017-024-4

Следующим шагом можно приступить к оцифровке. Для оцифровки нам понадобится "Virtual Dub" (рисунок 4), официальная страница которого торчит здесь: http://www.virtualdub.org.

VIRTUAL DUB: ОБЩИЙ ВЫБОР ПАРАМЕТРОВ КОДИРОВАНИЯ

Прежде чем приступать к кодированию, тебе нужно определиться, что ты хочешь получить от фильма, и выбрать соответствующий размер кадра и битрейты для ММ4 или обычного кодирования. Отчего зависит выбор?

БИТРЕЙТ

Имеет определяющее значение для массы конечного файла. Зная длину фильма в минутах (секундах) и предельное количество места, куда планируется впихнуть потоптанный фильм, можно вычислить (с некоторой ошибкой) нужный битрейт.

Пример расчета битрейта. Скажем, у тебя есть фильм в 1 час 32 минуты. Нужно записать его на 80 min CDR. Полная длина фильма составляет 1*60+32=92 минуты или 92*60=5520 секунд. Зная емкость CDR = 700 Мб, рассчитываем битрейт: 716800 килобайт / 5520 секунд = 129.8 кб/сек или 130 * 8 = около 1040 кбит/сек. Примерно с таким битрейтом ты можешь жать этот фильм кодеком "Low Motion" (отняв от него еще битрейт звука).

КОДЕКИ DIVX 3.11 - LM и FM

Два предыдущих абзаца касаются только кодека "DivX Low Motion" (LM). У него заданный битрейт определяет средний битрейт фильма. У "Fast Motion" (FM) кодека задается верхнее значение битрейта, то есть он может при заданном битрейте 3000 кбит/сек затоптать фильм и в 900 кбит/сек, зажав все равномерные заливки "в квадратики". Это могут быть лица крупным планом или равномерные фоны, газон на футбольном поле и так далее. Зато быстрые сцены практически не будут иметь паразитных следов, свойственных LM. Кроме того, экономя на равномерных заливках, FM не пожалеет битрейта для быстрых сцен - там реальный битрейт будет как раз те самые 3000 кбит/сек, и кадр будет выглядеть более качественно.

Противоречие кодека DivX 3.хх. Топтание с помощью LM на низких битрейтах (600-900) позволит иметь ровные заливки, но при резком сдвиге камеры или объектов даст нам сильные паразитные шумы. А топтание с помощью FM на высоких битрейтах (1200-1800) даст нам качественную картинку при насыщенной деталями сцене, но запоганит все равномерные заливки.

Если тебе лень долго мучаться с фильмом (клипом), можно уяснить для себя, каких сцен больше в фильме, и выбрать соответствующий кодек. Если же хочется получить наиболее качественный результат, то придется применить способ двойного кодирования. Вкратце - фильм цифруется дважды, с LM на низком битрейте (600-900, максимум 1200) и с FM на высоком битрейте (1200-1800, максимум 2400), а затем объединяется в один AVI с переменным битрейтом вручную, на глаз выбирая наиболее хорошо пожатые сцены разными кодеками, либо автоматически, доверив это серьезное дело программе. Поток LM кодека нужно рассчитывать так, чтобы этот вариант фильма занимал около 75% предназначенного для него места, остальное место уйдет на качественные сцены FM варианта, поток которого на среднем фильме должен быть примерно в полтора-два раза выше.


Спецвыпуск Xakep, номер #017, стр. 017-024-5, "DivX ;)", MPEG-4 и DVD-фильм на одном CD

"DivX ;)", MPEG-4 и DVD-фильм на одном CD

Спецвыпуск Xakep, номер #017, стр. 017-024-5

РАЗМЕР КАДРА, ИЛИ РАЗРЕШЕНИЕ ФИЛЬМА

Это третья составляющая качества фильма наряду с битрейтом и вариантом кодека (LM, FM или ММ4). Обычно кадр фильма в формате DVD = 720х576 (варианты - 640х480 и 768х576). Кадр оригинального размера даст нам наивысшее качество (четкость деталей), особенно на высоких битрейтах (LM 6000), но фильм не войдет даже на два CD. Мало того, его размер будет приближаться к размеру DVD (около 4 гигов). Если мы хотим вместить фильм на одну-две КДшки, придется жертвовать уменьшением потока данных, а значит - искажением изображения. Чем сильнее сжатие (меньше поток), тем сильнее искажения. Но если взять размер кадра 40х30 точек, то искажений почти не будет. Зато и мы ничего не увидим, даже увеличив такой кадр на весь экран - средние, не говоря уже о мелких, детали будут полностью размыты. Значит, нужно найти баланс между размером кадра и потоком.

Пропорции фильма должны иметь соотношение 4:3 или 16:9, но на диске обычно пропорции искажены (по техническим причинам) и восстанавливаются плеером. При оцифровке стоит восстановить реальные пропорции фильма, чтобы не было искажений объектов. Обычно берут размеры, кратные сторонам реального кадра. Для 4:3 это 768*576 (полный кадр PAL и SECAM), 704*528, 640*480 (полный кадр NTSC), 576*432, 512*384, 448*336, 384*288 (полукадр PAL и SECAM), 320*240 (полукадр NTSC), 256*192, 192*144, 128*96, 64*48. С последними четырьмя разрешениями фильм конечно будет выглядеть мелковато, а разрешения 384*288 и 320*240 стоит применять только в тех случаях, если тебе не нужны мелкие детали, либо если фильм очень плохого качества и не даст большей детализации при высоком разрешении. Широкоформатные фильмы соотношения 16:9 имеют еще меньше разрешений, пригодных для оцифровки: 768*432, 640х360, 512*288, 256*144. Хотя для фильмов 16:9 можно установить шторки, приводя их в соответствие 4:3.

VIRTUAL DUB: НАСТРОЙКА КОДЕКОВ

Открывай "Vdub" и AVI файл, полученный в результате конвертирования проекта d2v через "VFAPI". Ты увидишь два окна - слева оригинальный файл, справа то, что должно получиться в результате кодирования. Переходи в параметры "Video/Compression". Если у тебя стоит кодек "Divx 3.11", то ты увидишь среди прочих кодеков два: "DivX ;-) MPEG-4 Fast-Motion" и "Low-Motion". Выбирай нужный из них и нажимай "Configure" (настройки этих версий кодека дивух не отличаются). Лови дайлог всего с тремя параметрами.

Первый параметр - расстояние между ключевыми кадрами (ключевой интервал) в целых секундах. Задавая этот параметр достаточно большим (10-999), добьешься небольшого улучшения картинки за счет расстановки минимального количества ключевых кадров в фильме (только на смене сцен) и увеличения массы дельта кадров, а следовательно, их качества. Задав же минимальные значения ключевого интервала (1-3), получишь упрощение перемотки фильма в плеерах, так как все плееры перематывают MPEG-4 фильмы только по ключевым кадрам, и чем чаще они наставлены, тем легче найти тот фрагмент, на который передвинут рычажок промотки. Если же интервал будет слишком большим, то, при попытке промотать фильм до нужного места, ты рискуешь "подвесить" плеер на несколько секунд (пока он промотает кусок от предыдущего ключевого кадра до нужного). Звук при этом может прерваться или продолжаться на фоне неподвижной картинки, это зависит от параметра "inteleaving", о котором позже.


Спецвыпуск Xakep, номер #017, стр. 017-024-6, "DivX ;)", MPEG-4 и DVD-фильм на одном CD

"DivX ;)", MPEG-4 и DVD-фильм на одном CD

Спецвыпуск Xakep, номер #017, стр. 017-024-6

Второй параметр - "Smoothness-Crispness" (сглаживание-резкость). Этот параметр задает небольшое сглаживание картинки для улучшения ее способности к сжатию. Наиболее хорошо сжимаются достаточно равномерные переходы цветов и гораздо хуже сжимаются резкие, контрастные границы. Это общее правило для JPEG-MPEG сжатия. Для чего нужен этот параметр? Если кодек не успевает за потоком - картинка слишком сложная, а поток задан слишком маленький, то кодек начинает слишком зажимать картинку до квадратности, а если и это невозможно (картинка слишком сложная - пестрая, резкая, много движения), то он начинает пропускать кадры, чтобы поддержать поток на нужном уровне. Обычно это касается LM варианта кодека. Задавая параметр резкости меньше 100%, ты разрешаешь кодеку перед сжатием немного сгладить картинку, чтобы она лучше сжималась. С одной стороны, это позволит поддержать поток и не потерять кадры на сложных фильмах, с другой - теряется резкость и так уже уменьшенного по размеру, а значит, и по резкости, кадра. Данный параметр стоит трогать только при кодировании LM кодеком на низких потоках.

Третий параметр - задание скорости потока видеоданных в килобитах в секунду. Он определяет силу сжатия и последующую скорость, с которой данные будут декодироваться. Обычно 1200 килобит достаточно для нормального качества фильма, но, чтобы вместить большой фильм на 1 CD, приходится делать кадр поменьше и поток задавать до 600 килобит. Качество при этом, ясен пень, падает. Что же касается FM кодека, то задание этого параметра на него влияет очень относительно. На быстрых фильмах он может его придерживаться, но не строго, а на медленных вообще перестает обращать на параметр внимание, сжимая по максимуму своих возможностей. Так что с этим опшеном приходится поэкспериментировать на фрагменте фильма перед кодированием.

VIRTUAL DUB: ФИЛЬТРЫ

После задания параметров кодека можно задать фильтры (Video/Filters), которые будут изменять каждый кадр фильма. "Vdub" позволяет накладывать множество фильтров, входящих в стандартную поставку и изменяющих деинтерлейс, сглаживание, резкость, яркость, шторки, размер кадра, уровни яркости, поворот и так далее. Нас интересуют в основном изменение размера кадра (resize), шторки или обрезка (letterbox, cropping) и деинтерлейс (deinterlace).

Деинтерлейс. Стандарты PAL и SECAM подразумевают вывод каждого кадра двумя полями, наложенными друг на друга через строку, - это называется интерлейсным кадром (в отличие от прогрессивного кадра, когда выводится сразу все поле на полный кадр, как, например, на мониторе). Визуально мы можем наблюдать интерлейс (чрезстрочность) при просмотре интерлейсного видео с DVD (если в проигрывателе не включен фильтр деинтерлейса), когда идет сильное смещение объектов в кадре - мы увидим "расческу" (рисунок 5). Для того чтобы избавиться от этой расчески, следует наложить фильтр deinterlace, причем еще до изменения размера кадра, так как при интерполяции кадра смещается правильное чередование строк полукадров, и деинтерлейсинг в таком случае уже будет неэффективным: расческа останется местами.


Спецвыпуск Xakep, номер #017, стр. 017-024-7, "DivX ;)", MPEG-4 и DVD-фильм на одном CD

"DivX ;)", MPEG-4 и DVD-фильм на одном CD

Спецвыпуск Xakep, номер #017, стр. 017-024-7

iVTC. Стандарт NTSC подразумевает попеременный вывод интерлейсных и прогрессивных кадров в строгой очередности со скоростью 30 кадров в секунду, которые при этом имеют избыточную информацию - дублирование пары полей с изменением четности в соседних кадрах. Эту избыточную информацию можно безболезненно удалить, применив специальный алгоритм и получив при этом уменьшение количества кадров (24 кадра в секунду), не потеряв совершенно никакой информации из фильма. Этот алгоритм заложен в "Дубе" в разделе "Video/Frame rate/inverse telecine/reconstruct-adaptive". Заметь, что алгоритм сложен, так как последовательность чередования в NTSC фильмах постоянно нарушается и до сих пор нет идеального iVTC, реализованного для программ, позволяющих кодировать "Divx". Поэтому лучше все-таки применять параллельно iVTC и старый добрый интерлейсинг, чтобы в готовом фильме не проскакивала "расческа".

Размер кадра мы уже обсосали выше. Лучше, чтобы кадр, взятый с DVD, изменялся пропорционально стандартным видеоразмерам - 4:3, 16:9. Так ты добьешься нормальных пропорций лиц и предметов при просмотре в плеерах, не имеющих возможности подгонки пропорций (скажем, "WMP" или "Playa"). Шторки (скрытие части изображения за горизонтальными или вертикальными полосами) и обрезка (отрезание части кадра) позволяют отрезать или скрыть грязь по краям кадра (особенно это касается домашних фильмов, сграбленных самостоятельно), а шторки еще и позволяют довести кадр до нужного размера (некоторые видеокарты поддерживают видеовыход на ТВ только фильмов с размером кадра, кратном 16 или 32). Применять эти фильтры можно в любой очередности.

После задания всех параметров кодирования и фильтров можно приступать собственно к кодированию, которое заключается всего лишь в выборе имени файла после "File/Save AVI".

MM4

После получения двух файлов с разным битрейтом - два LM либо FM и LM - нужно смикшировать из них один (с переменным битрейтом). А затем выбрать из двух фильмов фрагменты, наиболее качественно сжатые каждым из кодеков. Используй для этого "Project Divx" (рисунок 6). Программу можно взять здесь: http://mydivx.by.ru/files/ProjectDivX15.zip

В проге нужно выбрать "быстрый" и "медленный" (или, соответственно, "легкий" и "тяжелый" по весу, если пожато одним кодеком) варианты фильма. После этого нажимается "автовыборка" и выбираются параметры для сбора статистики. Баланс быстрых и медленных частей фильма и "чувствительность" выборки (через сколько кадров брать статистику). Лучше, конечно, юзать "Every frame". Здесь же можно ограничить массу конечного файла, задав значение в килобайтах. Не забудь оставить место под аудиопоток. После "ОК" автоматика начнет выборку.


Спецвыпуск Xakep, номер #017, стр. 017-024-8, "DivX ;)", MPEG-4 и DVD-фильм на одном CD

"DivX ;)", MPEG-4 и DVD-фильм на одном CD

Спецвыпуск Xakep, номер #017, стр. 017-024-8

По окончании автовыборки можно проверить результат и поправить данные, если ты не согласен с выбором машины. Переключение fast/low фрагментов в таблице осуществляется правой кнопкой мыши. Если ты хочешь вручную выбрать фрагменты для кодирования ММ4, то находи нужные, передвигаясь по фильму кнопками "КК" влево/вправо, и выделяй фрагмент кнопками "фрагмент", а затем добавляй его "как low" или "как fast".

После окончательного заполнения таблицы автоматически или вручную дави на кнопку "собрать фильм", задай путь и имя и жди окончания процесса создания фильма с переменным битрейтом.

После этого осталось только добавить звук.

VIRTUAL DUB: ЗВУК

Если ты хочешь вставить в фильм mp3 звук, то нужно сжать wav файл, полученный в "DVD2AVI", любым подходящим кодером mp3: "Lame", "Fraunhofer" или другими, с параметром "создавать wav заголовок". Для микширования mp3 с видео звук должен иметь расширение wav и RIFF-заголовок (оставаясь внутри все тем же mp3).

После этого нужно открыть в "Vdub" свой окончательный Divx файл, а затем в диалоге "Audio/WAV audio" выбрать твой mp3. Обязательно нужно задать в меню "Video" и "Audio" параметр "Direct stream copy", чтобы "Дуб" не пытался перекодировать заново видео- или аудиопотоки, и сохранить его как avi под другим именем. Операция пройдет достаточно быстро, так как в этом случае "Дуб" просто скопирует оба файла в заданное место, попутно их микшируя.

В случае расхождения аудио- и видеопотоков (потери синхронизации) к середине или к концу фильма, стоит выбрать параметр "Video/Frame rate/Change so video and audio duration match", что синхронизирует видеопоток под аудио.

Если же ты выбираешь оригинальный АС3 звук, то тебе понадобится один из хаков "Дуба" - "Dub AC3" - либо "NanDub", понимающие АС3 аудио. Подкладка аудио АС3 при этом ничем не будет отличаться от предыдущих действий с mp3, с той лишь разницей, что тебе не нужно иметь АС3 с wav расширением и заголовком - он остается в оригинальном виде. Единственным отличием будет обязательное задание интерливинга (Audio/interleaving). Потребуется задать в "Interleave audio every..." и "Delay audio track" параметр 160 ms в каждом.

VIRTUAL DUB: НАРЕЗКА

В случае, если ты рассчитывал разместить фильм на 2CD и вычислил его размер, исходя из этого, то готовый фильм можно порезать в "Vdub". Открывай готовый фильм в "Дубе", ставь "Direct stream copy" в меню "Video" и "Audio". Смотри на общее количество кадров, передвигай бегунок на середину фильма. Теперь подбирай ключевой кадр поближе к середине (стрелками с изображением ключа, пятая-шестая кнопки справа на рисунке 4) и запоминай номер этого кадра. Нажимай на маркер конца фрагмента (последняя кнопка справа на рисунке 4), передвигай бегунок на начало фильма (четвертая кнопка слева на рисунке 4) и жми на маркер начала фрагмента. Затем делай "File/Save AVI". "Дуб" сохранит выбранный фрагмент. После этого переходи "Edit/Move to selection end" и жми маркер начала фрагмента, "Edit/Move to end", жми маркер конца фрагмента, "File/Save AVI". В результате получай два файла примерно одинаковой длины, которые можно записывать на болванки.


Спецвыпуск Xakep, номер #017, стр. 017-024-9, "DivX ;)", MPEG-4 и DVD-фильм на одном CD

"DivX ;)", MPEG-4 и DVD-фильм на одном CD

Спецвыпуск Xakep, номер #017, стр. 017-024-9

ЭПИЛОГ

В статье приведен лишь один из нескольких способов создания Дивх фильма с применением ММ4 технологии. Более подробные статьи о применяемых программах и последних достижениях Дивх технологий читай на сайте http://mydivx.da.ru (зеркало mydivx.by.ru). Там же валяются многие проги и ссылки на проги и сайты по дивуху в Рунете. Свои вопросы вали на форум сайта или в мыльник.


Спецвыпуск Xakep, номер #017, стр. 017-030-1, Глумимся над фото: подлый софт

Глумимся над фото: подлый софт

Спецвыпуск Xakep, номер #017, стр. 017-030-1

Вадим Мурзагалин (vadias@sendmail.ru)

Люблю смеяться... над соседом

Привет, хакер-креативщик! Скажи, ты любишь карикатуры? Я тоже люблю. Естественно, кроме тех, которые нарисованы на меня. Еще я люблю фотомонтажи, но только чтобы тоже без моего участия. Так уж устроен мир, что человек любит поиздеваться и посмеяться над другими, и ничего тут не поделаешь. Хотя почему это не поделаешь? Как раз поделаешь! И в этом у нас с тобой есть верные помощники, о которых и пойдет сегодня речь.

Деформеры и другие четверорукие друзья

Начнем мы наш гига-обзор с деформеров. Это специализированные проги, которые создавались именно для наших целей - глумления над фотоизображениями, создания карикатур и прочих "дружеских" шаржей. Их разработчики уже изрядно поломали голову над тем, что можно сделать из обычной фотки, и тебе придется только реализовывать данные ими возможности.

Между прочим, проги, о которых мы будем говорить, могут служить и очень серьезным целям. Приведу ситуевину из жизни. Возможно, у тебя было желание выставить свое изображение на каком-нибудь сервере знакомств или послать его красивой виртуальной тетке, но из-за "неумелости фотографов" на всех фотках у тебя слишком тонкая шея или, наоборот, щеки не влезают в узкие рамки. Это необходимо как-то поправить, не правда ли? Стандартными средствами "Винды" aka "Paint'ом" тут явно не обойтись, и лучшим решением будет установить...

KPTX GOO

Прога "Goo" была самой первой из могикан, позволяющих преображать картинку до полной неузнаваемости, заодно давая возможность вволю посмеяться над ней. Простая и функциональная, она не могла не завоевать популярность и всеобщее признание. Кроме простого искажения в реальном времени, на основании начальной и полученной картинки здесь даже можно сделать несложную анимацию. На сегодняшний день прога существует как в виде самостоятельного приложения (и называется "SuperGoo"), так и в виде плагина для "Фотошопа". Изучим теперь ее поподробнее.

Оформлена она очень приятно, и почти все понятно с самого начала, какие тут могут быть мануалы. Разработчики называют "Goo" инструментом "пальцевого рисования", то есть работа в ней схожа и так же проста, как размазывание краски или другой вязкой субстанции по какому-либо материалу. Ниже ты видишь панель инструментов, которых восемь штук; два из них могут изменять свои функции при щелчке на них.

Все инструменты имеют пару-тройку настроек. У всех есть параметр "Brush Size" (размер кисти) и "Brush Flow" (степень текучести картинки), у некоторых добавляется еще одна опция - "Brush Animation Speed", от которой зависит, насколько быстро применяется эффект. Ниже ты видишь результаты применения креативных тулзов.

Чтобы ты оценил потенциал проги, обработаем боксера Майка Тайсона так, как этого не смог сделать даже Эвандер Холифилд: давай избавим его от лишней мышечной массы. Такой Майк нам нравится больше, не правда ли ;)?

Анимация создается так же элементарно: в стилизованной киноленте внизу экрана задаются только начальный и конечный варианты картинки, а все промежуточные кадры создаются программно. Можно сохранять непосредственно искажения, чтобы потом применять их уже к другим изображениям.


Спецвыпуск Xakep, номер #017, стр. 017-030-2, Глумимся над фото: подлый софт

Глумимся над фото: подлый софт

Спецвыпуск Xakep, номер #017, стр. 017-030-2

В общем, резюме таково: программа очень проста в употреблении, инструментов немного, но их реализация осуществлена разработчиками рульно, а качество картинок - на высоте. Архинеобходимая вещь на компе фотомонтажника. К сожалению, после ухода великого Кая Краузе из "Meta Creations" программа в своей последней ипостаси - "Kai's SuperGoo" - была продана некой фирме "Scansoft Inc." (www.scansoft.com), которая не дает скачивать ее со своего сайта. Но мир не без добрых людей :). Прога ищется и легко находится в любом "Яндексе". Всем искать и ставить!

Deformer

Программу с таким символичным названием делали наши отечественные ребята из компании "Stoik Software". Интерфейс сделан в эдаком веселеньком стиле; к сожалению, только с очень большим трудом и нестандартным мышлением можно догадаться о назначении того или иного элемента. Лично я в жизни не догадался бы, что изображение циркуля означает "открыть проект"; а некоторые метафорические предметы я попросту не узнал. К счастью, можно включить всплывающие подсказки, которые не дадут ошибиться (что, впрочем, тоже довольно спорно :)).

"Deformer" имеет много схожих функций с "Goo", но к ним добавлены и специфические. В главном окне редактора видны пять групп инструментов: "Catastrophe tools", "Toolkit", "Global tools", "Shrink tools", "Plain tools" и "Grow tools". Названия не скажут о многом, надо смотреть их в действии. Щелкнув по какому-нибудь из изображений этих групп, ты попадешь в другое окно, где сможешь выбрать непосредственно средство воздействия на жертвенную фотографию.

В общем и целом, прога довольно интересная, но имеет ряд недостатков. Во-первых, очень тяжело, особенно поначалу, ориентироваться в редакторе. Во-вторых, я так и не нашел такого важного атрибута, как точная настройка размера кисти - здесь это реализовано таким образом: каждый эффект представлен тремя инструментами, каждый из которых отличается от других только радиусом воздействия. Это довольно неудобно. И, в-третьих, некоторые функции, как бы помягче сказать... короче, высосаны из пальца руководителя компании :). Тем не менее, наловчившись, можно получить изрядное удовольствие для себя и поставить в щекотливое положение какую-нибудь неугодную тебе личность. Например, доказать всем, что он болен Базедовой болезнью в тяжелой форме (смотри скрин). Скачать прогу можно с сайта ее папиков - http://www.stoik.com/downloads/demos_main.htm.

Софт для морфинга

Другой способ поглумиться над фотографиями - это морфинг. Что такое морфинг? Только не говори, что ты его не видел - эта фишка часто используется на телевидении в рекламных роликах и фильмах. Допустим, нарисованный мужик идет и постепенно превращается в настоящего - это и есть морфинг. Другими словами, это просто плавное перетекание одного изображения в другое. Если ты, типа, умный и хочешь глубже познать этот вопрос, сходи на http://emanual.ru/download/680.html - там подробнее расписана теория. Кстати, анимация в рассматриваемых выше прогах-деформерах - тоже частный случай морфинга.


Спецвыпуск Xakep, номер #017, стр. 017-030-3, Глумимся над фото: подлый софт

Глумимся над фото: подлый софт

Спецвыпуск Xakep, номер #017, стр. 017-030-3

Чтобы получить морфинговую авишку или кучу файлов с промежуточными изображениями, предварительно надо расставить опорные точки, так как комп вряд ли почует, где на твоих картинках глаза, а где рот - он ведь не различает запахи :). И чем больше точек ты наставишь и чем грамотнее ты это сделаешь, тем качественнее будет и результат.

Программ-морферов достаточно много, и все они отличаются друг от друга числом опций. Самой распространенной в силу своего малого размера и фриварности является...

Winmorph

Эта прога присутствует на большинстве файловых архивов и весит чуть больше 700 килобайт. Конечно, ждать чего-то сверхъестественного от нее не следует - "Winmorph" он и есть "Winmorph". Выбираешь две фотографии, аккуратно ставишь точки, настраиваешь нужный тип выходного файла (mpeg, avi или группу bmp-файлов) и стартуешь! Результат смотри ниже:

Резюме: для начального знакомства с морфингом прогу следует скачать. Она хорошо демонстрирует его возможности ;).

Morph Man 2000

Этот редактор намного богаче предыдущего по возможностям, соответственно, и весит поболе - около 4 мегов. Его, между прочим, делали все те же веселые отечественные ребята из "Stoik Software" (www.stoik.com). Кроме того, что делает "Winmorph", "Morph Man" может еще создавать эффект постепенной замены картинки с участием слоя-маски, то есть заменяться будет только та часть картинки, над которой ты нарисуешь контур-маску. Можно сделать частичный морфинг:

Плюс ко всему этому - добавлен морфинг по ключевым точкам, когда морфинг делается на основании только одной картинки. Допустим, кому-то надо порвать пасть... Нет, будем мягче - лучше просто растянуть рот до ушей. Ты устанавливаешь начальное положение точек в уголках рта, затем указываешь их конечное положение - аккурат возле мочек, а дальше - дело техники (смотри скрин). Кроме видеоформатов и секвенции бмп-шек, в отличие от предыдущей проги, результаты извращений можно сохранять в Gif-файлы.

Резюме: если возможностей "Winmorph'а" стало мало, качай "Morph Man 2000" - не пожалеешь. Разобраться в нем почти так же несложно, тем более, что там присутствует хороший и последовательный туториал.

Emotion 3d Web Edition

Я никак не мог обойти вниманием эту замечательную программу. Она, как любят писать на пиратских компакт дисках, "самая динамическая и эффективная". Действительно, где еще ты сможешь заставить своего преподавателя танцевать канкан, вставать на голову и кланяться тебе в ноги? И все это делается парой кликов мыши. "Emotion 3d" имеет простой интерфейс (наверное, это судьба всех программ-приколов), процесс создания анимации тривиален: просто последовательно щелкай каждый раздел и настраивай все опции по очереди.

Чтобы создать полноценную анимашку, нужно достать фотографию чьей-нибудь фигуры в полный рост и аккуратно вырезать ее по контуру в "Фотошопе". При вставке в "Emotion 3d" белый фон вокруг фигуры автоматически станет прозрачным. Можно сообразить и задний план и затем в нужном разделе указать его. В арсенале программы присутствует более 50 различных движений, среди которых есть разные танцы, ходьба, бег, вращение и прочие. Все это в конце концов превращается в анимационный Gif-файл или последовательность любых других графических файлов.


Спецвыпуск Xakep, номер #017, стр. 017-030-4, Глумимся над фото: подлый софт

Глумимся над фото: подлый софт

Спецвыпуск Xakep, номер #017, стр. 017-030-4

К сожалению, не обошлось и без недостатков. Во-первых, неудобно организован доступ к файлам. Чтобы загрузить свою картинку, ее нужно переписать в специальную директорию. Во-вторых, максимальный размер проекта маловат - всего лишь 256 на 256 пикселей :(. И, в-третьих, программа уже не поддерживается разработчиками - "Anark Media" (www.anark.com), так что найти и взять ее стало труднее. А в целом - рулез!

Adobe Photoshop

Закончим мы обзор самой настоящей классикой - легендарным "Adobe Photoshop". Да-да, и здесь по возможностям этот старичок обскакал даже многие специализированные проги. "Фотошоп" - рай для грязного фотомонтажника и шантажиста, была бы только смекалка побольше да потолще. Думаю, у тебя нет проблем с ориентацией в этом редакторе, так что ты быстро освоишь все приемы великого папарацци. На этот раз мы с тобой рассмотрим три метода фотомонтажа.

Фотомонтаж № 1 - "Ты похож на грязного ниггера!"

Иногда бывает просто необходимо кого-нибудь очернить. С помощью этих нехитрых манипуляций мы превратим твоего знакомого в темнокожего брата. Итак, для начала загрузим фотку.

Видишь, какой бледный вид? Добавим парню загара. Сперва выделим те участки, которые подвергнутся обработке, то есть непосредственно эпидермис (кожный покров :)); одежду и волосы не трогай. Теперь выбираем инструмент Burn, делаем кисть среднего размера и аккуратно закрашиваем (старайся сильно не задевать глаза и зубы - подцепит ненароком катаракту и кариес). После такой санобработки на изображении появляются резкие переходы цветов. Чтобы ликвидировать их, берем инструмент Blur и смягчаем нужные места. И - добро пожаловать в наш квартал, нигга!

Фотомонтаж № 2 - Подстава

Ты хорошо помнишь уроки литературы? Я - нет, но припоминаю какие-то фразы про нос Ивана Ивановича, который хорошо было бы приставить к ушам Ивана Никифоровича или что-то в этом роде. В общем, жалко, что у них тогда не было "Фотошопа" :), все было бы гораздо нагляднее. Следующий метод осуществляется с помощью инструмента "Rubber Stamp" (Штамп). Берем две картинки, которые хотим совместить. Ниже ты видишь, каких представителей рода человеческого выбрал я.

Итак, открываем оба файла и выбираем инструмент "Rubber Stamp" - он пятый сверху слева панели инструментов. Чтобы задать область, с которой будет производиться клонирование, удерживаем [Alt] и щелкаем в нужное место, скажем, на нос Биллу. Теперь переходим к пикчуре с обезьянкой и начинаем плавными вращательными движениями выводить светлый образ Гейтса на месте ее физиономии. В итоге получаем примерно следующее:

Фотомонтаж № 3 - Мочилово в сортире

Следующий метод основан на подтасовке действующих лиц и места действия. В качестве действующего лица мы возьмем - ни много ни мало - нашего президента. Ну, а место действия - то, где он собирался аннигилировать отдельные преступные элементы.


Спецвыпуск Xakep, номер #017, стр. 017-030-5, Глумимся над фото: подлый софт

Глумимся над фото: подлый софт

Спецвыпуск Xakep, номер #017, стр. 017-030-5

Все делается очень легко, единственная возможная заморочка - создание тени. Но и ее создание, в общем-то, не представляет особой сложности. Для этого нужно аккуратно выделить по контуру фигуры, скопировать выделение в буфер и вставить на новый слой. Затем любым путем его следует затемнить, для пущего эффекта можно добавить полупрозрачность. Чтобы тень приняла правильную форму, ее слой надо трансформировать (Edit > Free Transform), то есть отразить по вертикали и наклонить в нужном направлении. Тень подгоняется к фигурам, все это снова выделяется, копируется в буфер и вставляется в новую картинку. Вот и все!

На опасной ноте

Да, на этой ноте мы и закончим наше повествование о фотомонтаже и других смешных и не очень грязных подтасовках. Представление о некоторых элементах арсенала представителя этой славной профессии ты получил - включай свою злость и юмор на полную катушку, и полный вперед! А я попрошу тебя только об одном: когда коренастые люди в сером с оттопыренными карманами прижмут тебя к стене, тряся перед твоим лицом смонтированными тобой же псевдофотографиями высокопоставленной персоны, постарайся изо всех сил забыть фамилию автора этой статьи и название этого журнала и никогда больше о них не вспоминать. Так будет гораздо спокойнее для всех ;).

Прога "Goo" была самой первой из могикан, позволяющих преображать картинку до полной неузнаваемости, заодно давая возможность вволю посмеяться над ней. Простая и функциональная, она не могла не завоевать популярности среди таких, как ты и я, - великих фотомонтажников.

Другой способ поглумиться над фотографиями - это морфинг. Что такое морфинг? Только не говори, что ты его не видел, - эта фишка часто используется на телевидении в рекламных роликах и фильмах. Допустим, нарисованный мужик идет и постепенно превращается в настоящего - это и есть морфинг.

Я никак не мог обойти вниманием эту замечательную программу. Где еще ты сможешь заставить своего преподавателя танцевать канкан, вставать на голову и кланяться тебе в ноги?

Да-да, и здесь этот старичок обскакал по возможностям даже многие специализированные проги. "Фотошоп" - рай для грязного фотомонтажника и шантажиста, была бы только смекалка побольше да потолще.


Спецвыпуск Xakep, номер #017, стр. 017-034-1, СТУДТЕХНОСОФТ: ТЕБЕ, ТЕХНАРЬ

СТУДТЕХНОСОФТ: ТЕБЕ, ТЕХНАРЬ

Спецвыпуск Xakep, номер #017, стр. 017-034-1

Ильдар Валитов (ildar@arat.ru)

В отличие от "MathCAD", «Maple» представляет собой консольную программу.

«Maple» не ограничивает построение графиков поверхностей только лишь декартовыми координатами, ему также под силу сферические и цилиндрические.

По сравнению с двумя вышеописанными продуктами «Grapher» менее универсален, однако со своей основной задачей - построением графиков - он справляется безупречно.

Очевидный факт - строить графики в «Grapher» очень просто.

На основе «AutoCAD» разработаны приложения для геодезии, картографии, архитектуры и некоторых других сфер деятельности, касающихся проектирования.

Самое время в очередной раз выйти в пространство. Выйдем мы не с голыми руками, а вооружившись панелями "Поверхности" и "3D Орбита".

Ты - студент-технарь, ты молод, у тебя куча интересов и разного рода занятий, но в очередной раз один преподаватель надавал тебе кучу заданий по высшей математике, другой просто завалил чертежами, третьему вдруг внезапно понадобилось построить графики функций кошмарной размерности. Знакомая ситуация? Возможно, при наличии свободного времени ты бы с большим энтузиазмом взялся за это занятие голыми ручками и, возможно, осилил бы его. Но коли время поджимает, и работа выходит за рамки твоих физических возможностей, то осуществить тебе этот труд помогут программы специального назначения, иметь которые в софтварной кладовой - хороший тон.

СОЛО НА MATHCAD

Этот программный пакет - один из самых распространенных среди математических систем. Причинами столь большой известности сего продукта являются его универсальность, гибкость, мощный математический аппарат, простота использования. Все это позволяет пользоваться им широкому кругу лиц, начиная от школьников и кончая профессионалами. В общем, классная прога. Мы с тобой не будем зарываться в глубины "MathCAD", а лишь поднимем те повседневные проблемы, которые решают среднестатистические студни, так или иначе связанные с математическими изысками. Для начала поставим себе задачи: решим уравнение, построим графики функций, "поиграемся" с их настройками. Дабы не лезть по уши в науку, возьмем в качестве уравнения sin(x)+cos(x)=1 и проведем практически все наши опыты на нем.

Все вычисления и записи в "MathCAD" ведутся на рабочей области, и достаточно кликнуть мышкой в любом месте, чтобы твой клик подтвердился красным крестиком, указывающим, где именно будет выводиться текст. Теперь можно набрать в виде текста:

Given

sin(x)+cos(x)

Не пугайся: первая набранная строчка гласит, что за ней будет следовать логическое выражение, в нашем случае являющееся равенством. Доступ к большинству символов и операторов в "MathCAD" можно получить, используя панели инструментов. Добавлять или исключать их можно из меню "Вид>Панели инструментов". Однако, если активировать панель "Математика", то доступ к остальным панелям существенно облегчается. Нажимая на кнопки последней, можно вызвать практически все остальные панели (рисунок 1).

Но, чтобы поставить знак равенства в уравнении, придется обратиться к панели "Логика" и выбрать там "булево равенство" (можно также воспользоваться горячей клавишей Ctrl+=), остается "добить" на клавиатуре единичку. Нажимай "Enter" - и уравнение готово (рисунок 2).


Спецвыпуск Xakep, номер #017, стр. 017-034-2, СТУДТЕХНОСОФТ: ТЕБЕ, ТЕХНАРЬ

СТУДТЕХНОСОФТ: ТЕБЕ, ТЕХНАРЬ

Спецвыпуск Xakep, номер #017, стр. 017-034-2

Давай решать. Существует два различных подхода к нахождению решения: первый - с помощью символьных преобразований, второй - использование численных методов. Реализуем первый. После записанного равенства запишем:

Find(x)

Далее на панели "Символические операторы" выберем стрелку (альтернативно - нажать Ctrl+"точка"). Сейчас самое время компьютеру, потрещав винтом, выдать результат, который высветится после стрелки. Так как получено два решения, то ответ выдается как вектор-строка (рисунок 3).

Есть другой способ получения такого же символьного результата, безо всяких лишних записей (типа "Given", "Find"): написав наше уже ставшее родным уравнение, необходимо поставить курсор около переменной, относительно которой будем его решать. Так как в нашем случае переменная одна, альтернативы нет. Пробираемся в меню "Символы>Переменные" и, выбрав в нем подменю "Вычислить", сразу получаем результат. Ты, конечно же, можешь возмутиться, что, мол, я заставил тебя пойти кругами к получению результата. Отнюдь, первый способ позволяет также решать системы уравнений. То есть он более универсален в применении, так как можно записать не одно, а несколько уравнений между Given и Find, например, так:

Given

Sin(x)+cos(x)=1

Sin(x)=1

Find(x)

При таком раскладе дел, после нажатия на стрелку, в качестве ответа выйдет лишь одно значение. Попробуй сам найти его на досуге, а затем сверь с результатом "MathCAD".

Зачастую, когда требуется решать сложные задачи, запись формул не ограничивается лишь простым набором текста, и приходится прибегать к так называемым шаблонам. К примеру, они имеются на панели "Операторы математического анализа". При нажатии на одну из кнопок этой панельки в рабочую область вставится шаблон, наподобие тех, которые валяются в редакторе формул "Word'a". Однако многое из того, что есть на панелях, можно получить, нажав комбинацию на клавиатуре. И чем больше "горячих клавиш" ты изучишь, тем продуктивнее будет твоя работа в этом редакторе. Но не будем отвлекаться на философствования и приступим ко второму методу решения уравнений - численному. Он необходим, когда найти решение путем символьных преобразований не представляется возможным либо достаточно сложно.

У этого способа есть особенности - он ищет не точное, а приближенное решение, и многое для достижения более точного решения зависит от тебя самого, а вернее - от выбора начального приближения. На рисунке 4 показан фрагмент рабочей области с примером численного решения уравнения. Если ты будешь изменять начальное значение переменной "х", результат также будет меняться, и иногда не в лучшую сторону. Видно, что при численном решении данным способом нарылся только один ответ.

Теперь настал черед построения графиков. В качестве подопытной функции возьмем окончательно замученную нами f(x)=sin(x)+cos(x). В рабочей области (советую тебе создать новую, комбинацией Ctrl+N) определи функцию, используя символ присваивания ":=", вставив его из панели "Арифметика". Необходимый шаблон прямоугольной декартовой системы координат возьми с панели "Графики" либо нажав [Shift+2]. Теперь впиши в шаблон "x" и "f(x)", как показано на рисунке 5, и жми "Enter". Если у тебя получилось примерно то же самое, то идем дальше.


Спецвыпуск Xakep, номер #017, стр. 017-034-3, СТУДТЕХНОСОФТ: ТЕБЕ, ТЕХНАРЬ

СТУДТЕХНОСОФТ: ТЕБЕ, ТЕХНАРЬ

Спецвыпуск Xakep, номер #017, стр. 017-034-3

Давай менять свойства графика. Для этого шлепни на график и вызови контекстное меню, и в нем выбери "Формат". Не бойся - винт твой останется целым, а вот графику в этом случае придется туго, так как мы вошли в святая святых его настроек. Здесь можно изменить сеттингзы по своему вкусу. Я же сделал так, как показано на рисунке 6. Вижу, тебе не терпится посмотреть на мое творение и отождествить со своим. Удовлетворю твое любопытство: смотри рисунок 7.

В контекстном меню, помимо подменю "Формат", имеются еще две интересные для нас вкладочки, а именно "Трассировка" и "Масштаб". Трассировка позволяет пробегать по графику, определяя значения абсциссы и ординаты точки. При установленной галочке, как на рисунке 8, трассировщик будет "прилипать" к графику, не давая тебе дрогнуть или отступить от линии.

С масштабом графика все ясно даже первокласснику, однако здесь есть подводный камень: при включенной логарифмической шкале он не функционирует. Отключив в настройках эту фишку, можешь вволю насладиться масштабированием графика. Помимо декартовых координат, на панели "Графики" имеются еще полярные координаты, которые в способе применения не отличаются от описанного мною ранее.

Настало время выйти в трехмерное пространство, говоря просто - построить график поверхности, благо на панели "Графики" имеется большой выбор трехмерных "инструментов". Ввиду того, что наша родная и любимая функция, натянутая на шаблон чуть ранее, всего лишь одномерная, придется "раздуть" ее размерность. Предлагаю сделать это так: f(x,y)=sin(x)+cos(y).

Но прежде чем построить график этой функции, здесь, в отличие от простого графика, потребуется провести некоторую подготовительную работу. Нам надо будет создать массив значений функции в некоторых точках, который и будет в дальнейшем вставлен в шаблон поверхности. На рисунке 9 показана часть процедуры составления такого массива значений.

Сначала выбирается число разбиений, определяющее число значений функции, которое нам требуется подсчитать. Далее вводятся индексы "i" и "j", которые будут участвовать в создании массива. Причем две точки между 1 и n, указывающие на диапазон изменения, вставляются из панели "Арифметика" либо нажатием ";". Область задания функции в нашем случае - это квадратная сетка со сторонами 20х20. Далее подсчитываются промежуточные значения аргументов, то есть узлов равномерной сетки. И самая главная подготовительная деталь - создается собственно массив значений функции. В нашем примере это "M" с индексами "i", "j". Чтобы ввести нижний индекс, нужно кликнуть соответствующую кнопку в меню "Матрицы". И последнее, что остается сделать, чтобы насладиться графиком поверхности, - это вставить шаблон и в требуемое пустое место вписать буковку «М» (нашу матрицу значений). Свойств и настроек графика поверхности на порядок больше, чем у простого графика, посему поле деятельности твоей фантазии здесь ограничивается лишь твоим терпением. Я же сделал пару-тройку прицельных нажатий на кнопочки и получил то, что можно увидеть на рисунке 10. Причем количество графиков по созданной матрице значений можно настрогать немереное. Кстати, остальные типы трехмерных графиков строятся по нашей матрице совершенно аналогично, причем так же быстро можно в свойствах графика поменять его тип.


Спецвыпуск Xakep, номер #017, стр. 017-034-4, СТУДТЕХНОСОФТ: ТЕБЕ, ТЕХНАРЬ

СТУДТЕХНОСОФТ: ТЕБЕ, ТЕХНАРЬ

Спецвыпуск Xakep, номер #017, стр. 017-034-4

Теперь осталась незатронутой одна интересная деталь - создание анимации. Средства «MathCAD» позволяют "оживлять" часть рабочей области и записывать ее в видеофайл. Строится процесс анимации достаточно просто, используя переменную «FRAME». И чтобы окончательно "добить" нашу функцию, я предлагаю "оживить" именно ее. Достаточно в последнем примере немного изменить нашу функцию так: f(x,y):=sin(FRAME*x)+cos(FRAME*y), где звездочка - это символ умножения. В меню "Вид" выбрать "Анимация". И теперь, выделив тот участок рабочей области, который нужно расшевелить, нажать "Анимация" (рисунок 11). Теперь главное - вовремя остановиться, потому что видеофрагменты могут заполнить твой винт под самое горлышко.

Конечно, несколько примеров не могут полностью описать все прелести и недостатки этого продукта. К примеру, незатронутыми в данной статье остались такие интересные моменты, как решение дифференциальных уравнений, счет интегралов и многое другое, позволяющее говорить, что «MathCAD» - мощное оружие против препода в руках студня.

ОТЛИЧНЫЙ ДУЭТ С MAPLE

Эта математическая система, созданная компанией «Waterloo Maple», представляет собой оригинальный программный пакет. Чтобы сразу разобраться с его местом под математическим солнцем, я проведу параллели с «MathCAD». Итак, в отличие от предыдущего продукта, «Maple» представляет собой консольную программу. То есть все, что в нее вводится, проходит через командную строку. И считать это недостатком или преимуществом невозможно, так как опытному пользователю командная строка позволяет быстро вводить требуемые формулы и значения, но зато отпугнет новичков. Теперь немного сравнений: «Maple» имеет более 2700 встроенных функций, в «MathCAD» их значительно меньше. «Maple» имеет более сильный аппарат символьных преобразований и позволяет работать со сложными структурами данных. Точность вычислений может достигать пятисот тысяч знаков. «Maple» имеет подключаемые библиотеки функций, то есть легко и нехило апгрейдится. Думаю, что этого достаточно, чтобы ты, студент, осознал мощь этой программы.

Сохраняя приверженность единому стилю описания, поставим перед «Maple» те же задачи, которые мы поставили перед «MathCAD». Так как «Maple» требует подключения библиотек при использовании той или иной команды, осуществлять мы это будем по ходу выполнения примеров. Сначала решим уравнение sin(x)+cos(x)=1. Для этого в командной строке набери следующее:


Спецвыпуск Xakep, номер #017, стр. 017-034-5, СТУДТЕХНОСОФТ: ТЕБЕ, ТЕХНАРЬ

СТУДТЕХНОСОФТ: ТЕБЕ, ТЕХНАРЬ

Спецвыпуск Xakep, номер #017, стр. 017-034-5

>solve(sin(x)+cos(x)=1);

Да, чтобы команда считалась завершенной, в конце надо ставить точку с запятой и подтвердить ее нажатием «Enter». Чтобы решить ту же систему уравнений, что и в «MathCAD», пиши:

>solve({sin(x)+cos(x)=1, sin(x)=1});

Как и в первом случае, ответ будет написан после этой команды. Вообще, команда «solve» имеет расширенный синтаксис, однако, как видно на примерах, может работать и в "урезанном" виде.

Настал черед графиков. Для этого существует команда «plot». Набери в командной строке:

> plot(sin(x)+cos(x),x=-10..10);

Заметь, что если необходимо разместить несколько графиков на одной системе координат (например, нам нужно рядом с построенной намалевать еще одну, скажем, линейную функцию), то они записываются в фигурных скобках через запятую. Работу «Maple» смотри на рисунке 12.

Теперь по плану идут пространственные графики. И здесь, оказывается, все строится очень просто. Если ты еще не забыл подготовительную работу в «MathCAD», то забудь ее! Все делается в один прием:

>plot3d(sin(x)+cos(y),x=-10..10,y=-10..10);

Полюбоваться здесь есть на что, хотя настроек графика чуть меньше, чем в «MathCAD» (рисунок 13). Если вдруг вместо обещанных графиков у тебя на экране появилось сообщение, дублирующее написанную строку, значит библиотека «plots», отвечающая за построение графиков, не загружена. Чтобы исправить эту ошибку, надо написать в командной строке «>readlib(plots);» или воспользоваться оператором «with(plots)».

Следующий этап - создание анимированного изображения. Здесь авторы программы также потрудились на славу и сделали этот процесс максимально простым и удобным в использовании. В качестве примера возьмем анимацию трехмерного изображения. Обратимся к командной строке:

> animate3d(cos(t*x)+sin(t*y), x=--10..10, y=-10..10, t=1..5);

После нажатия на «Enter» появится изображение поверхности; чтобы привести его в движение, надо кликнуть на него и в контекстном меню выбрать «Animation>Play» либо во встроенном меню воспользоваться элементами управления (рисунок 14).

«Maple» не ограничивает построение графиков поверхностей только лишь декартовыми координатами, ему также под силу сферические и цилиндрические. И завершая тему графиков, открою тебе еще один секрет: закраску поверхности можно осуществлять самостоятельно, используя функции:

>animate3d(cos(t*x)+sin(t*y),x=-10..10, y=-10..10,t=1..2,color=x^2+y^2);

«Maple» имеет множество других возможностей применения. Если у тебя появилось желание ознакомиться с ними, советую обратиться к мануалу проги. Он дает исчерпывающие ответы практически на любые возникающие вопросы.

Теперь можно смело сравнить два пакета с точки зрения нашего применения. В «MathCAD» налицо простота и визуальный интерфейс, лихо переплетенный с мощным математическим аппаратом и прекрасно реализованными инструментами графики и анимации. «Maple» с этой точки зрения держится не хуже, а порой даже превосходит своей изящностью команд, набираемых в консоли. Строить поверхности в «Maple» проще, однако набор атрибутов в нем немного беднее, нежели в «MathCAD». Одно верно - оба продукта признаны юзерами. И какой из них использовать в конкретной ситуации, зависит от тебя самого.


Спецвыпуск Xakep, номер #017, стр. 017-034-6, СТУДТЕХНОСОФТ: ТЕБЕ, ТЕХНАРЬ

СТУДТЕХНОСОФТ: ТЕБЕ, ТЕХНАРЬ

Спецвыпуск Xakep, номер #017, стр. 017-034-6

СТАРЫЙ РОЯЛЬ - GRAPHER

По сравнению с двумя вышеописанными продуктами эта программа менее универсальна, однако со своей основной задачей - построением графиков - она справляется безупречно. Несмотря на пожилой возраст (версия, которой пользуюсь я, скоро отметит свое десятилетие), она все же держится бодрячком. Приступим.

При создании нового документа (рисунок 15) программа предлагает на выбор 3 способа: собственно систему координат, электронную таблицу либо текстовый файл. Остановимся на первом, обозначенном «Plot».

Создав его, мы получаем чистый лист. Теперь лезь в меню «Graph», раздел «Function», и твоему взору предстанет диайлог, заполнить который - наш долг. Смело вписывай функцию, выставляй интервалы ее задания и выбери шаг (так, как показано на рисунке 16).

Если тебе еще не наскучили атрибуты, можешь побаловаться со стилем линии (Line Style), и, кликнув "ок", получи знакомую картину. Если тебе это показалось скучным, предлагаю получить тот же результат, изрядно попыхтев. Удовольствие тебе обеспечено. Итак, в меню «Graph» есть раздел «Line or symbol». Здесь надо определиться: набить вручную таблицу значений функции или использовать файл с расширением dat. Первая альтернатива скучна до безобразия, а вот вторая - прельщает своей загадочностью. Раскрою страшную тайну: сейчас мы немного попрограммируем. В качестве языка возьмем «Turbo Pascal». Хотя любители других языков могут сделать то же самое на своих. Нам потребуется создать файл, где через запятую будут идти координаты «x» и «y» нашего графика. Причем каждая пара координат будет разделена. Вот листинг программы:

Uses Crt;

Var y:Array[0..2000] of real;

dx: real;

n,T: integer;

f0: text;

Begin

dx:=0.01;T:=2000;

Assign(f0,'1.dat');

ReWrite(f0);

For n:=0 to T-1 do

begin

y[n]:=sin(n*dx)+cos(n*dx);

end;

For n:=0 to T-1 do

begin

writeln(f0,n*dx,' ',y[n]);

end;

close(f0);

readkey;

end.

Как ты мог заметить, в качестве функции мы снова взяли сумму синуса и косинуса. Так, теперь файл 1.dat создан, и можно вернуться к построению графика. Жми снова на «Line or symbol», найди новоиспеченный файл и подтверди его причастность к графику, нажав «Enter». Далее всплывет окно, касающееся координатных осей, - опять «Enter», так как все уже сделано в Pascal'е. А вот следующее меню изучим поподробнее. Смотри на рисунок 17 и удивляйся: «Grapher» сам все за тебя сделал (определил максимум и минимум функции, разобрался с шагом аргумента, нашел начало и конец функции). Тебе осталось только еще раз нажать «Enter». Хотя именно здесь можно изменить атрибуты графика - напротив слова «Curve» есть тоненькая полоска, которая показывает текущую толщину и цвет линии. Двойным нажатием можешь исправить положение дел, выбрав требуемые цвета и размеры графика. Чертить графики здесь очень просто.

КАДЕТСКИЙ КОРПУС AUTOCAD

Появившись в далекие "икстишные" времена, эта программа бурно развивалась, и то, что мы имеем в наше "икспишное" время, представляет собой отличное средство для проектирования. Последняя версия названа «AutoCAD 2002». В нем реализованы встроенные языки программирования «Visual LISP», VBA, C++. На основе «AutoCAD» разработаны приложения для геодезии, картографии, архитектуры и некоторых других сфер деятельности, касающихся проектирования. Данный продукт настолько многогранен, что приведенные ниже примеры лишь капля в море его возможностей. Но, как говорится: лучше один раз покликать и тут же заныкать. Я насиловал версию 15.


Спецвыпуск Xakep, номер #017, стр. 017-034-7, СТУДТЕХНОСОФТ: ТЕБЕ, ТЕХНАРЬ

СТУДТЕХНОСОФТ: ТЕБЕ, ТЕХНАРЬ

Спецвыпуск Xakep, номер #017, стр. 017-034-7

Запускай «AutoCAD». При появлении меню выбора действий создай новый документ. Поначалу поставим себе посильную задачу и сварганим чего-нибудь: например, напишем простенький текст, поработаем с двумерными объектами, выйдем в третье измерение.

Прежде чем приступать к созиданию, я бы советовал тебе разобраться с курсором и панелями инструментов. Нам понадобятся следующие панели: "Тень", "3D Орбита", "Поверхности", "Твердые Тела", "Рисование". Если они у тебя отключены, включи их, используя меню «Вид>Панели» инструментов.

Да, каждое твое действие будет отражаться в командной строке, которая по умолчанию расположена внизу экрана, и каждая команда, введенная в строке, так или иначе будет выполнять предписанное ей действие. Чтобы ты разобрался, напишем простенький текст, используя командную строку. Убедись, что она ждет тебя в распростертые объятья, подтверждая текстом "Command:", если это не так, нажми «Esc». Теперь вводи команду «text», на что консоль тебе ответит:

Current text style: "Standard" Text height: 2.5000

Specify start point of text or [Justify/Style]:

Мы же лучше ткнем в область, где требуется ввести текст, чем и удовлетворим этот командный запрос. Но неугомонная командная строка выдаст нам очередное сообщение:

Specify height < 2.5000 >:

В скобках указан размер шрифта по умолчанию, мы же поработаем мышью, переместив которую, визуально его установим, либо, если тебе очень понравилась консоль, введи размер прямо там. Остается задать направление текста, ответив на сообщение консоли:

Specify rotation angle of text <0>:

Ну, теперь можно вводить текст, результат этой операции смотри на рисунке 18.

Теперь брось свой взор на панель "Рисование" (рисунок 19), выбери "Многоугольник" и снова ныряй в консоль!

Command: _polygon Enter number of sides <4>:

Укажи количество вершин, затем способ построения многоугольника.

Specify center of polygon or [Edge]:

Выбери «Edge».

ДЕЛО МЫШИ И ТВОЕЙ ФАНТАЗИИ...

Самое время в очередной раз выйти в пространство. Выйдем мы не с голыми руками, а вооружившись панелями "Поверхности" и "3D Орбита". Создай новый документ. Не знаю как тебе, но мне из всех поверхностей на рисунке 20 приглянулся "Тор", его и принесем в жертву.

Кликни соответствующую иконку на панели и глянь, что на это скажет командная строка:

Command: _ai_torus

Initializing... 3D Объекты загружены.

Определите точку центра тора:

Теперь смело ткни мышью в понравившуюся область экрана, указав "уважаемому компьютеру" центр тора. Следующие вопросы касаются радиусов тора и трубы, которые можно задать двояко: мышью или консолью. Два последующих запроса касаются сегментации окружностей трубы и тора. Справься с ними по-быстрому, и твоему взору предстанет каркас тора (рисунок 21). Можешь поменять его ракурс, поработав с панелью "3D Орбита".


Спецвыпуск Xakep, номер #017, стр. 017-034-8, СТУДТЕХНОСОФТ: ТЕБЕ, ТЕХНАРЬ

СТУДТЕХНОСОФТ: ТЕБЕ, ТЕХНАРЬ

Спецвыпуск Xakep, номер #017, стр. 017-034-8

Теперь придадим тору фотографическое качество. Для этого войди в меню «Вид>Рендеринг>Render» и выбери «Photo Real». На выходе должно получиться так, как на рисунке 22.

Конечно, это лишь мизерное количество возможностей «AutoCAD», но со временем и практикой все фишки этой системы будут у тебя в руках.

ЗВОНОК С УРОКА

Конечно, любой может возразить, что этот список программ далеко не полон. Однако выполнение множества студенческих задач вполне можно скинуть на их мощные плечи. Что-то можно посчитать на калькуляторе, что-то вообще на пальцах пораскинуть.

Хотя иногда самому взять интеграл, построить график от руки на миллиметровой бумаге или сотворить что-либо еще не будет лишним занятием.


Спецвыпуск Xakep, номер #017, стр. 017-040-1, СОФТ СТУДЕНТА-ГУМАНИТАРИЯ

СОФТ СТУДЕНТА-ГУМАНИТАРИЯ

Спецвыпуск Xakep, номер #017, стр. 017-040-1

Фоменко Зоя AKA CyBer (kammi@yandex.ru)

Пользуясь тренажером каждый день, ты в течение месяца будешь отлично знать как правописание слов, так и верную расстановку знаков препинания, что поможет тебе быть асом не только в суперкомпьютерах, но и в русском языке.

Тренажер состоит из восьми тестиков, а также содержит различные правила орфографии и пунктуации.

Программа, бесспорно, эффективная и поможет тебе быстро научиться читать, не проговаривая про себя слова.

Если ты не хочешь уподобляться в своей речи Бивису и Батт-Хеду, то наберись терпения и приготовься тренажериться неоднократно.

В итоге ты сам себе будешь озвучивать всяческие диктанты, но потом не пеняй на то, что не успеваешь записывать за самим собой.

После установки проги на Рабочем столе появляется иконка с умильным названием "КЛАВА".

Программа очень простая и позволяет тебе читать книгу, прокручивая ее как вручную, так и автоматически. Как тренажер быстрочтения эта самая прокрутка, к сожалению, не покатит - слишком медленно.

Даров, штудент. Сегодня нам с тобой предстоит немного погрызть гранит науки, но не без помощи компа. Мы будем говорить о всяческих полезных прогах, написанных специально для тебя, гуманитарий, и призванных расширить твою грамотность и знания в различных областях. Впрочем, эти тулзы будут полезны не только для гуманитариев и не только для того, чтобы за одну ночь подготовиться к экзамену, а потом сдать и забыть все как страшный сон. Предположим, ты крутой хацкер, у тебя за плечами множество замороченного программного кода, не одна взломанная система и гора прочитанных книжек. И вот однажды ты пойдешь устраиваться на высокооплачиваемую работу. Если на собеседовании ты будешь выражаться на своем повседневном сленговом языке, то, скорее всего, тебя поймут разве что только в местном РЭУ. Да и грамматические ошибки в твоем резюме вряд ли где-либо покатят. Ну и, конечно же, всегда хочется знать еще больше, чем ты знаешь сейчас. Все книжки по твоему любимому Линуху и C++ толстеют с каждой новой версией - всего не перечитаешь :). Так что тут уже без навыков скоростного чтения совсем никуда, а иначе так и будешь до пенсии читать какие-нибудь "Новые возможности Perl для инженера-тракториста" в 2000 страниц. Примеров можно приводить еще много, но, я надеюсь, ты уже понял - все мы должны быть не только умными, но и грамотными. Итак, берем журнал в руки и начинаем читать.

"ДАЛЕКОЕ ШКОЛЬНОЕ ДЕТСТВО", ИЛИ КАК Я ТРЕНАЖЕРИЛ САМ СЕБЯ

Тренажер по русскому языку

Сайт: http://parent.fio.ru/news.php?n=2337&c=302

Сколько раз ты мучился перед тем, как отнести на экзамен готовый реферат, и сколько возникало при этом траблов. Сколько раз, записывая лекции, ты долго и упорно не мог понять, что за слово написано: "чуствоват" или все же "чувствовать". Теперь у тебя есть реальная возможность повысить уровень своей грамотности и интеллекта, взяв в руки прогу "Тренажер по русскому языку". Софтина будет полезна как для учащихся средних школ, так и для тебя, студент-гуманитарий!

Здесь собраны все правила, существующие в русском языке. Стоит только нажать кнопку запуска, и дружественный интерфейс тренажера позаботится о твоем удрученном настроении, в то время как сама тулза будет устанавливаться на твой комп.


Спецвыпуск Xakep, номер #017, стр. 017-040-2, СОФТ СТУДЕНТА-ГУМАНИТАРИЯ

СОФТ СТУДЕНТА-ГУМАНИТАРИЯ

Спецвыпуск Xakep, номер #017, стр. 017-040-2

Плюсом этой проги, несомненно, является то, что тебе предлагается восемь абсолютно разнообразных тестов, которые имеют три пункта сложности. В каждом из тестов не более сорока вопросов, которые помогут не только закрепить уже давно пройденный этап, но и оценить твой уровень на данный момент.

Еще одним достоинством этой проги является то, что при неверном ответе на вопрос всплывает окошечко, позволяющее просмотреть соответствующую орфограмму или пунктуационное правило, а при необходимости и верный вариант ответа на конкретно заданный вопрос.

Также некоторые тесты ориентированы на каждодневные тренировки, которые помогут тебе быстро усвоить и запомнить предлагаемый программой материал.

Пользуясь тренажером каждый день, ты в течение месяца будешь отлично знать как правописание слов, так и верную расстановку знаков препинания, что поможет тебе быть асом не только в суперкомпьютерах, но и в русском языке, и не опозориться ни перед собеседником, ни перед преподом, ни перед привередливым работодателем.

Сайт производителя этой софтины: http://parent.fio.ru/news.php?n=2337&c=302, но скачать тебе ее там, к сожалению, не удастся, езжай на Митино-BaZaR!

Тренажер по русскому языку v 1.1

Сайт: http://softoboz.com.ua/trenrus.htm

Размер: 627 Кб

Условия распространения: Фришка

Если ты не хочешь уподобляться в своей речи Бивису и Батт-Хеду, то наберись терпения и приготовься тренажериться неоднократно. Поэтому, чтобы не ограничиваться одной программой, лови еще один тренер по русскому языку. Системные требования очень скромные, это тебе не навороченная игрушка - даже если у тебя не клевая тачка, прога все равно пойдет. Тренер абсолютно бесплатный, и никакой регистрации для него тебе не понадобится. Он состоит из восьми тестиков, а также содержит различные правила орфографии и пунктуации. Тест содержит тридцать вопросов (попадаются довольно сложноватые) всего по трем излюбленным темам: культура речи, орфография и опять-таки пунктуация. В этом тренере своя система: за каждый правильный ответ тебе начисляют балл, а за каждый неправильный ты получаешь этим баллом по башке :). Каждый из этих тестиков имеет по три режима: два тренировочных и один контрольный. Для первой ступени сделаны специальные тренирующие проги и куча справочного материала, который поможет тебе разобраться в своих ошибках. Вторая ступень включает в себя другую кучу справочного материала и еще семь различных тестов. В контрольном тесте один балл начисляется за один вопрос, если выбраны только все верные варианты. В общем, гуманитарий, флаг тебе в руку и вперед к вершинам грамотности!

Read Assistant v13

Сайт: http://softstation.narod.ru

Размер: 354 Кб

Условия распространения: Фришка

Знаю-знаю, ты довольно часто ездишь в метро и много раз видел, как старенькие бабушки в очках с толстенными стеклами перелистывают страницу за страницей, а ты все мнешься на первом абзаце. Вся фенька в том, что этих теток в свое время заставляли зубрить советские книжечки - а-ля «Труды дедушки Ленина» по 700 страниц каждая, и они не жаловались на дурных преподов. Но тебе и волноваться не о чем, сейчас я научу тебя выходить сухим из воды. Первая прога быстрочтения называется Read Assistant. Меня она просто порадовала до глубины души. Можно расслабиться в кресле перед компьютером, уставившись в монитор. Данная софтина сделает для тебя, амиго, абсолютно все: удобная прокрутка текста со своими личными настройками (регулятор скорости), возможность читать текст, не распаковывая его из rar, zip, arj, lzh, возможность настроить язык интерфейса, индивидуальная адаптация под пользователя, реальная возможность создания закладок, смены цвета фона и шрифта и еще множество всяческих хитроумных настроек. Последнюю версию этой крошки можешь найти на указанном сайте.


Спецвыпуск Xakep, номер #017, стр. 017-040-3, СОФТ СТУДЕНТА-ГУМАНИТАРИЯ

СОФТ СТУДЕНТА-ГУМАНИТАРИЯ

Спецвыпуск Xakep, номер #017, стр. 017-040-3

SSRead v1.5

Сайт: http://kvn-.chat.ru/Kvn01.htm

Размер: 49 Кб

Условия распространения: Фришка

Следующая прога так и называется - "Ssreader Быстрое чтение (1.5)". Эта программка тоже ничего, но все же в ней присутствует явный недостаток: очень гиморно разбираться. Но, как известно, хочешь просто и быстро - используй Windows, хочешь надежно и качественно - изволь разобраться в Linux. Программа, бесспорно, эффективная и поможет тебе быстро научиться читать, не проговаривая про себя слова. В ней также присутствует многоязыковая поддержка, всяческие функции настроек, но слишком многое еще не доработано. Если тебе хочется немного погеморроиться и не быть ламаком, то вперед, к быстрочтению!

Сколько раз нам в старых советских киношках показывали, как сидит какая-нибудь тетка и в бешеном темпе долбит по древней печатной машинке. Помниться, раньше в некоторых училищах и институтах даже был (хотя и сейчас есть) такой предмет - "машинопись", в кабинете которого стояли большие и страшные печатные машины "Ятрань". На таких вот машинках студенты безостановочно под диктовку лектора или с листа, да еще и под стук метронома (это им так темп набора задавали) набирали умопомрачительные абракадабры типа "ячсм фыва йцукен шла Маша по шоссе и сосала леденец". Шум там при этом стоял, как во время битвы под Сталинградом. Зато и секретутки-машинистки из этих самых студентов-наборщиков выходили продвинутые и скорострельные. Позднее пришли компьютеры, шума стало меньше, но смысл остался тот же. Раньше, конечно, скорость печати нужна была в основном только таким вот секретуткам и секретурикам. Теперь вокруг полно компьютеров с их клавиатурами, так что этот навык нужен практически всем, кто работает на компьютере, то есть и нам с тобой. И не криви рот - думаешь, если у тебя есть сканер и ты не пишешь программы, то клавиатуру можно забросить в дальний угол шкафа? Как бы не так! Все равно когда-нибудь тебе понадобится навык скоростной печати.

Представляю тебе программки для быстрой печати вслепую.

Milton v 1.28

Сайт: http://ilch.vsmu.edu.ua

Размер: 235 Кб

Условия распространения: Фришка


Спецвыпуск Xakep, номер #017, стр. 017-040-4, СОФТ СТУДЕНТА-ГУМАНИТАРИЯ

СОФТ СТУДЕНТА-ГУМАНИТАРИЯ

Спецвыпуск Xakep, номер #017, стр. 017-040-4

Первая в нашем списке носит имя "Milton". Она предназначена, как и все подобные программки, для приобретения навыка печати текста вслепую. В проге десять этапов по девять упражнений в каждом. Довольно быстро можно расправиться с первыми тремя этапами, но в дальнейшем будет немного сложновато. Эта версия программы позволяет упражняться с русской раскладкой клавиатуры, но на том же сайте можно скачать версию для упражнения и с английской (Milton_e). Не сомневайся, после этого ты будешь печатать как по-русски, так и по-английски со скоростью 1200 слов в минуту :).

Клава

Сайт: www.download.ru

Размер: 435 Кб

Условия распространения: Фришка

Следующая не менее интересная программка, которая попалась на глаза, - это тулз по "Скорости измерения набора текста". На самом деле, очень занятная игрушка. После установки проги на Рабочем столе появляется иконка с умильным названием "КЛАВА", а в ней-то и кроется вся тайна. При открытии программы тебе представляется клавиатура с русскоязычной и англоязычной раскладками, что очень удобно. Все, что ты делаешь, - это просто набираешь текст на обычной клавиатуре так, как быстро ты можешь, а потом кликаешь на закладочку с часами, и тебе показывают личную статистику: количество предложений в тексте, количество абзацев, слов, время набора, количество символов в минуту, в секунду и еще много чего другого... Прога халявная, и залить ее можно без регистрации.

Stamina 2.3

Сайт: stamina.ru

Размер: 1,38 Мб

Условия распространения: Фришка

Данная софтина задумана и разработана только для такого, как ты, реального ветерана 139 порта. Много-много всего. Слепая машинопись и ускоренная скорость ввода. Работа с текстами, большое количество уроков и упражнений (ну, прям как в школе :)). Экстраординарное расположение пальцев на клавиатуре, а также фразы или тексты для увеличения скорости набора. Не менее интересная фишка - построение графика прогресса, то есть ты всегда сможешь увидеть, насколько ты продвинулся в своих начинаниях. А что самое замечательное, можно настроить внешний вид любыми удобными способами - это и редактор уроков, и поддержка нескольких пользователей, и качественный MP3-звук, и вкладочка "помощь" с веселыми анекдотами и логическими играми. В общем, прога для нас с вами, гуманитарные хакеры :))).

Соло на Клавиатуре v6.1

Сайт: www.softpc.ru

Размер: 1100 Кб

Условия распространения: Шароварка

Эта прога еще раз говорит нам о несовершенстве человека как такового. А вот если человек был бы роботом, то он мог бы мимолетом набирать такое огромное количество текста, что и учиться бы нам не приходилось бы. Может и не было бы на свете кул-хацкеров, подобных нам с тобой, брателло. Мир бы состоял полностью из электронно-вычислительных машин, роботов, котов и собак на батарейках, которые работают, работают и работают... Скукота. Все было бы похоже на фильм "Искусственный интеллект", где роботы только и могут, что догадываться, кто же такой этот самый человек. Но перейдем ближе к делу, а значит, мучачос, я тебе буду рассказывать о программе "Соло на клавиатуре". Интерфейс у проги русский, а системные требования, так сказать, от мала до велика: Win95/98/2000/Me/NT. После просмотра программки и прочтения всяческих "readme" сложилось довольно странное впечатление зомбирования от такой вот фразы: "Какой Вы? В чем смысл жизни?.. Вы научитесь набирать легко и радостно, испытывая при этом удовольствие..." - очень становиться интересно, удовольствие какого рода автор имел в виду? Вот так посидишь, часок-другой почитаешь подобную шнягу, да и до больницы рукой подать, где ты познакомишься с приятной компанией «Наполеона» и «Ивана Грозного». Вот где собака-то порылась, значится, теперь и программеры сходят с ума :). Софтина, на самом-то деле, никакая не глючная и не пытается "своей установкой" зомбировать общественные массы, она просто разработана с темповыми прогрессами 35-часового курса, поэтому, амиго, бояться нечего. Программка быстро поможет тебе научиться печатать вслепую опять-таки десятипальцовым методом, поэтому ты не будешь просто новым русским, а будешь уже продвинутым новорусским хакерюгой не с двумя, а с десятью пальцами.


Спецвыпуск Xakep, номер #017, стр. 017-040-5, СОФТ СТУДЕНТА-ГУМАНИТАРИЯ

СОФТ СТУДЕНТА-ГУМАНИТАРИЯ

Спецвыпуск Xakep, номер #017, стр. 017-040-5

Сколько раз на семинарах по иностранным языкам ты заявлял Марье Ивановне, что обязательным ответом на вопрос "Do you speak English?" должен быть "Ja, Ja, naturlich" - и задумчивый взгляд в потолок... Это уже какой-то детский сад получается (чего ты смеешься, а вот мне такие случаи приходилось наблюдать). Конечно, замечательно, что ты слушаешь группу Rammshtein и изучаешь иностранные языки благодаря MTV, но знать-то надо не только фразу "Du hast mich" (за такие высказывания ведь и зачета лишиться можно). Но как потом будет тебе обидно ходить и совать этой старой тетке конвертик с 50 бакинскими, которые ты припас на самый черный день, когда у тебя кончится все пиво и весь Интернет. Ан нет! Любишь кататься, люби и... правильно говорить. Чтобы помочь тебе еще раз не попасть впросак, представляю тебе следующие проги, которые помогут в дальнейшем изучении языков.

Говорящие словари и изучение слов v2.53

Сайт: www.softpc.ru

Размер: 5015 Кб

Условия распространения: Фришка

Это действительно хорошая программа для изучения слов и языков. Она говорящая! На сайте можно найти словари для семнадцати языков, которые в скором времени еще будут неоднократно пополняться. Зачем тебе толстый бумажный словарь, когда у тебя теперь комп научится говорить на английском, немецком, французском, испанском, итальянском, русском, датском, португальском, японском и других рулезных языках. Почти что бесплатная альтернатива программе English Platinum. Во-во, а скоро в тачке будет встроенный интеллект, и вы как два закадычных друга тихо вечером будете глушить пивко! Вот жизнь-то! На самом-то деле, софтина действительно замечательная. У нее есть замечательная функция создания своих собственных словарей. Причем, даже матерных - представь, как ты потом сможешь от души обложить своего препода самым отборным матом на японском языке. А если поинтересуется, что ты ему сказал, запросто можешь отмазаться, сказав, что по-японски это значит «Вы самый умный человек, профессор». Ты можешь редактировать и записывать новые слова, проблем с прогой вообще не возникнет. Интерфейс проще простого. Также ты можешь сделать поиск нужных тебе слов по словарю. Вывод в верхнем левом углу экрана слов и их перевода с заданным интервалом. А также новая супервозможность вывода слова и нумеровка вариантов перевода, из которой ты, гуманитарий, полагаясь на свой литературный склад ума, должен выбрать более подходящее значение. Также есть такие возможности и навороты: автоматический вывод слов на экран ящика для проверки знания перевода в любое время с твоими собственными настройками и интервалом. Возможность создания неограниченного количества временных наборов слов, которые ты сам выберешь себе для заучивания любым предложенным способом: "Бей ламаков, спасай Q3!". Выбранные тобой слова можно сгруппировывать и задавать время с определенной периодичностью вывода на экран или опять-таки проверки себя любимого. Благодаря рекурсивному поиску у тебя есть возможность переводить слова с одного языка на другой, абсолютно без геморроя. А также, благодаря этой, на мой взгляд, продвинутой проге, ты можешь вести свою личную статистику изучения и заучивания слов.


Спецвыпуск Xakep, номер #017, стр. 017-040-6, СОФТ СТУДЕНТА-ГУМАНИТАРИЯ

СОФТ СТУДЕНТА-ГУМАНИТАРИЯ

Спецвыпуск Xakep, номер #017, стр. 017-040-6

Сократ Персональный 4.1

Сайт: www.ars.ru/products/socrat/

Условия распространения: Шароварка

Да, амиго, эту прогу, может быть, ты и не юзал, но хоть раз в жизни точно слышал про нее, так как прога довольно известна. Так вот, она придет тебе на помощь только благодаря тому, что ты держишь в руках Х... Ставь ушки на макушку, крысу на лужайку и приготовься читать дальше. Эта софтина очень проста как в использовании, так и в описалках. У нее гибкие настройки, очень удобный интерфейс и низкие системные требования. Прога поможет тебе переводить все твои опуса как с русского на английский, так и с английского на родной русский язык, а также набирать текст не только в окне самого тулза, но и в том, который находится в буфере или файле (это уж тебе решать, мучачос). Еще одним преимуществом данной софтины является то, что она имеет модуль для MS Outlook, позволяющий переводить почтовые сообщения непосредственно в этом почтовом клиенте. В общем, ты не парься особо, прога просто все сделает за тебя, если еще вдобавок и не спросит, можно ли ей за тебя рот открывать и говорить, как «Двое из Ларца», из известного мультика.

Правописание

Сайт: http://savko.chat.ru/dict/dict.htm

Размер: 236 Кб

Условия распространения: Фришка

Амиго, не читай через строчку! Данная софтина как раз для тебя. Притом настолько простая, что проще и быть не могло. Эта прога предназначена для проверки правописания слов из словаря, который ты сам создашь. Зацени это: твой личный тичер достанет тебя и в домашних условия! Плюсом к этому является то, что все эти слова будут диктоваться твоей же собственной тачкой, будет появляться форма со строкой ввода, куда ты и будешь вписывать услышанное тобой словцо. Во как! Есть только некоторый недостаток, но чтоб особо тебе не геморроиться, я помогу советом. Тебе, амиго, сперва нужно будет создать словарь (хоть сленг, хоть ругательства). В менюшке «Словарь» ткнись в строку «создать», просто вводи любое название своего личного словаря, затем вписывай туда слова и озвучивай их. Хочешь - просто говори, хочешь, читай рэп, а можешь прорычать в микрофон текст как Мерлин Мэнсон. Для тех, кто все еще в танке: в итоге ты сам себе будешь озвучивать всяческие диктанты, но потом не пеняй на то, что не успеваешь записывать за самим собой. Все будет зависеть только от тебя, как наговоришь, такой результат и получишь. Идеальный вариант для тех, кому лень ходить на лекции и уроки и писать там диктанты.


Спецвыпуск Xakep, номер #017, стр. 017-040-7, СОФТ СТУДЕНТА-ГУМАНИТАРИЯ

СОФТ СТУДЕНТА-ГУМАНИТАРИЯ

Спецвыпуск Xakep, номер #017, стр. 017-040-7

Запомнить все 1.05

Сайт: www.download.ru

Размер: 1000 Кб

Условия распространения: Фришка

Это программа-словарь - лучший помощник гуманитария с языковым уклоном. Очень дружественный интерфейс, как в мультяшных игрушках. Тебе дается на выбор слово, которое написано на русском, и столько вариантов ответов на английском, сколько ты сам себе установишь. Конечно, телепузиков расстреливать веселей, но язык есть язык, и его нужно учить. Поэтому воспользуйся этой прогой и повысь свои уровень и кругозор. И эта программа также не требует регистрации.

КАРМАННЫЙ УЧИТЕЛЬ, ИЛИ КАК СДАВАЛСЯ ЗАЧЕТ!

Обучаться - это всегда хорошо и полезно. Но сидеть дома за компьютером и пялиться подолгу в монитор - не лучший вариант. Так что, если у тебя есть карманный компьютер семейства Palm, то самое время задействовать и его. О самих Palm'ах мы тебе как-то популярно рассказывали и о том, что это еще и хорошая шпаргалка на экзамене, и что преподы такое дело практически не замечают, ты и сам знаешь. Но сейчас поговорим о том, что с Palm'ом можно еще и учиться.

CspotRun

Сайт: www.mypalm.ru

Размер: 23 Кб

Условия распространения: Фриварка

Эта программа позволит тебе читать на своем карманном друге любые книги. И в то же время именно в нем ты сможешь открыть заранее приготовленную на компьютере шпаргалку и легко переписать это все на экзамене (о том, как занести книгу или шпаргалку в Palm, я расскажу чуть позже). Программа очень простая и позволяет тебе читать книгу, прокручивая ее как вручную, так и автоматически. Как тренажер быстрочтения эта самая прокрутка тебе, к сожалению, не поможет - слишком медленно она прокручивает текст на экране, но вот от постоянного нажимания на кнопку для перелистывания избавит.

QeD

Сайт: visionary2000.com/qed

Размер: 35 Кб

Условия распространения: Шароварка

Тут ты сможешь не только читать, но и писать книги. Так что если в тебе живет душа поэта или писателя, то это программа для тебя - муза ведь посетить тебя может внезапно, и даже в вагоне метро или на улице, но ты всегда сможешь тут же записать новую мысль. Если творить ты не умеешь, то можешь просто использовать прогу как блокнот (кстати, намного лучше Palm'овского).

Read Them All

Сайт: www.mypalm.ru

Размер: 27 Кб

Условия распространения: Фриварка

Это альтернатива CspotRun. Только интерфейс тут несколько лучше, хотя и немного навороченный. Эта программа также имеет автопрокрутку текста, причем скорость прокручивания можно регулировать. В общем, как тренажер быстрочтения - не очень, но если поднастроить скорость, может что-то и получится. Эта прога, в отличие от CspotRun, написана русским программером.


Спецвыпуск Xakep, номер #017, стр. 017-040-8, СОФТ СТУДЕНТА-ГУМАНИТАРИЯ

СОФТ СТУДЕНТА-ГУМАНИТАРИЯ

Спецвыпуск Xakep, номер #017, стр. 017-040-8

Quick Office

Сайт: www.mypalm.ru

Размер: 6,5 Мб

Глядя на размер проги, не пугайся - в твой Palm установится всего килобайт 300, а все остальное - это оболочка для Windows. Прога - почти полный аналог MS Office. В ней есть свои Excel и Word. Причем с полной совместимостью с MS Office на твоем большом компьютере - даже конвертор не нужен, все конвертации и работы по обмену документами между маленьким и большим компами выполнит оболочка, входящая в комплект. Работай и твори дома, в транспорте, на прогулке - в любом месте, где тебе удобней.

WordDocConverter

Сайт: www.mypalm.ru

Размер: 458 Кб

И вот, наконец, пару слов скажу тебе о том, как же загнать все эти твои документы с большого компа на маленький и как потом вытянуть их обратно. Для этого и создан сей конвертер. Он представляет собой макрос и встраивается в MS Word, а тебе остается только нажать на соответствующие кнопочки (они, если ты все правильно заинсталлил, появляются в панели инструментов в Word). Просто берешь свой документ в Word, жмешь на кнопку Text To Doc, и твоя электронная книжка или шпаргалка автоматически инсталлируются в Palm при следующей синхронизации. А чтобы вытащить текст из своего карманного друга обратно в Word, после синхронизации жмешь в Word кнопку Docs to Text, находишь нужный тебе документ, который обычно имеет расширение pdb, и вот он у тебя на экране. Там, если что, справка приложена, хотя вряд ли запутаешься, если знаешь, куда твой Palm сохраняет всю имеющуюся в нем инфу (настоящий хацкер всегда должен знать, где у него что хранится).

УЧИСЬ СТУДЕНТ!

Вот как бы и все на сегодня. Так что качай софт, учись, просвещайся и сдавай сессии вовремя. А Х тебе в этом поможет. Главное - не останавливайся на достигнутом. Удачи!


Спецвыпуск Xakep, номер #017, стр. 017-046-1, ЭМУЛЯТОР ПАЯЛЬНИКА: СОФТ ДЛЯ РАДИОВРЕДИТЕЛЯ

ЭМУЛЯТОР ПАЯЛЬНИКА: СОФТ ДЛЯ РАДИОВРЕДИТЕЛЯ

Спецвыпуск Xakep, номер #017, стр. 017-046-1

Доктор Прозвонкин (Dr.Cod@real.xakep.ru)

Софтина подходит любому, кто хочет быстренько научиться электронике с нуля. Подходит тому, кто хочет проверить стандартные опыты по физике и электронике. Подходит начинающему радиолюбителю.

Научиться юзать прогу можно за 5 секунд. Все понятно с первого взгляда. Но если у тебя серьезные запросы, переходи на «MicroCap».

«МикроКепка» - крутая программа моделирования для крутых радиолюбителей. Может почти все, разве что плату не разводит. Но если хочешь попроще и сразу, переползай на EWB.

Формулы, скрипты, макромодели, собственные элементы, элементы из Инета, почти все виды анализа и графиков. Подойдет студенту для курсачей по электронике, преподу для лабораторок, радиовредителю для нечеловеческих экспериментов в области стоматологии.

Довольно неприятно паять сложнейшую схему и после всех этих трудов и заморочек не суметь ее возбудить. Обидно и может отбить охоту к радиолюбительству надолго. Однако есть хороший выход: смоделировать будущий девайс виртуально. Для этого есть отличный софт.

Electronics Workbench (EWB 5.X)

ЧТО ТАКОЕ EWB?

Если ты - начинающий радиоэлектронщик и паяльник еще не шипел на твоей нежной коже, рождая запах паленого мяса; если у тебя в руках еще не взрывался электролитический конденсатор и тебе не вышибало глаз; если тебя все еще не кусал высоковольтный трансформатор и у тебя не останавливалось сердце... Короче, ты не бывал на небе, не видел, что все продвинутые челы давно перешли на «MicroCap». Потому прописываю тебе «Electronics Workbench». Самая подходящая софтина для новичка. Прежде чем паять схему, отрытую в Инете или старом радиожурнале, ты сможешь ее проверить на компьютерной модели.

Возможности компьютерного конструктора намного больше, ведь у новичка мало деталей и нет толком приборов. И мануалов нет, как этими приборами пользоваться. А нужно пробовать, нужно отрывать новые схемы, собирать их, менять их, сравнивать результаты. На компе это проще и удобнее. Тем более, что после того как ты попробовал виртуальную схему на EWB, можно спаять живую и сравнить с виртуальной.

ХОЧУ СРАЗУ!

Ох, не люблю я EWB и еще расскажу почему. Но это именно та программа, в которой МОЖНО СРАЗУ! Кликнул под мышкой мышку, и все зафундырыкало. Чтобы сильно не надрываться, можно пошарить в примерах готовых схем. К любой программе моделирования прилагается куча схем, которые должны показать "невероятные" возможности софтины. Можно выловить из этой коллекции что-нибудь знакомое и покрутить.

Под волосатую лапу как раз попался кусок детекторного приемника. Тут есть сам детектор - диод (такая стрелочка с палочкой). Еще нужны конденсатор и два резистора, на них собран фильтр. Вспоминай курс физики: детектор отрезает верхнюю часть сигнала, а фильтр ее выравнивает.

На EWB можно легко промоделировать радиосигнал. Они взяли обычный генератор АМ, то есть генератор с амплитудной модуляцией. Это когда звуковая частота накладывается на радиочастоту в виде амплитуды. Такой сигнал поступает на диод. В свойствах генератора задаются радиочастота и звуковая частота.


Спецвыпуск Xakep, номер #017, стр. 017-046-2, ЭМУЛЯТОР ПАЯЛЬНИКА: СОФТ ДЛЯ РАДИОВРЕДИТЕЛЯ

ЭМУЛЯТОР ПАЯЛЬНИКА: СОФТ ДЛЯ РАДИОВРЕДИТЕЛЯ

Спецвыпуск Xakep, номер #017, стр. 017-046-2

Чтобы видеть, что происходит в схеме, подключили осциллограф. Видны сигналы на входе и выходе. Красненький - радиосигнал, синий - звуковой на выходе. Картинка получилась как из книжки. Вообще, ты можешь брать свой учебник по физике или электронике и пробовать на EWB каждую схему. Софтина для того и сделана.

КАК С ДЕТАЛЯМИ?

Деталей в библиотеках много. Если ты непрофессионал, то тебе хватит. Только сразу забудь о русских деталях. Русских деталей нет. Можно, конечно, поискать в Инете русские библиотеки, но это неоправданный гимор. Даже если найдешь, то подключить их - целая история, и потом сделаны они, скорее всего, криво.

ЧТО ДЕЛАТЬ, ЕСЛИ Я ХОЧУ СОБИРАТЬ РУССКИЕ СХЕМЫ?

Найди справочник. Они бывают на дисках, в Инете, в виде книжки. С таким справочником ты быстро подберешь импортные аналоги отечественных элементов. Они совпадают не идеально, но работать все будет. Ты же не гонишься за тонкими нюансами, а просто хочешь, чтобы все пахало.

Если тебе нужен точный аналог, то ты запросто можешь подкрутить все параметры любого элемента. То есть ты можешь сам сделать библиотеку русских элементов. Главное, разобраться со всеми параметрами и найти их в справочнике. Но не забывай, что это легко сделать только со стандартными элементами, у которых такие параметры предустановлены. А если у тебя какая-то экзотическая микросхемища, то придется повозиться.

ЧЕМ ОТЛИЧАЮТСЯ РУССКИЕ ДЕТАЛИ ОТ ДРУГИХ?

Русские детали отличаются ценой. Они стоят обычно раз в 5 или 10 дешевле, чем другие. Еще иногда у русских микросхем больше функций, они жрут больше энергии, больше весят. Последнее время многие наши электронщики перешли на импортные детали. Поэтому ты найдешь в Интернете и радиожурналах много схем на западных элементах с русским описанием.

ПРОСТЫЕ ЭЛЕМЕНТЫ

Сопротивления, конденсаторы, заземление, батарейки особых проблем не вызывают. Ты можешь взять их мышкой в палитре и поместить на схему. На схеме ты должен соединить их проволочками и задать параметры для каждого элемента. Параметры высвечиваются рядом с элементами. Тут все настолько просто, что вопроса "русские - нерусские" не возникает. Проблемы аналогов возникнут с микросхемами и транзисторами.

КАК ПРОВЕРИТЬ РАБОТУ?

Для того чтобы ты видел, что происходит с твоей схемой, в EWB есть лампочки, светодиоды, цифровые дисплеи, измерители напряжения и тока. Лампочки даже умеют перегорать. Например, можно посмотреть, что будет с лампочкой от карманного фонаря на 12 вольт, если ее воткнуть в 220 вольтовских. В EWB она просто перегорит, а в реале она может спалить твою квартиру, ударить тебя током, обжечь, попасть в глаз. Жаль, что в EWB ничего не взрывается, не дымит и не обугливается.

Как только ты собрал схему и подключил к ней лампочки и измерители, смело можно давить на кнопку "вкл". Самый обычный выключатель в углу экрана. После этого твоя схема сразу оживет.

КАК МНЕ ПОДАТЬ СИГНАЛ НА ВЫХОД?

Часто схема бывает сложнее, и нужно подать на нее испытательный сигнал. Для этого есть генераторы испытательного сигнала. Такой генератор тоже нужно выбрать в палитре и подключить его проволочкой к схеме. Есть генераторы с разной формой сигнала: прямоугольной, синусоидальной, пилообразной. Для такого генератора ты можешь задать напряжение и частоту. Для проверки куска детекторного приемника использован генератор с двумя частотами: одна - радиочастота, другая - звуковая. Получился реальный радиосигнал, который ловят реальные приемники. Ты сможешь собрать простенький приемник и проверить его на EWB. Только ловить он будет не с антенны, а с генератора. Или задумаешь собирать мощный звуковой усилок, тоже подойдет генератор, чтобы подключить его на вход.


Спецвыпуск Xakep, номер #017, стр. 017-046-3, ЭМУЛЯТОР ПАЯЛЬНИКА: СОФТ ДЛЯ РАДИОВРЕДИТЕЛЯ

ЭМУЛЯТОР ПАЯЛЬНИКА: СОФТ ДЛЯ РАДИОВРЕДИТЕЛЯ

Спецвыпуск Xakep, номер #017, стр. 017-046-3

КАК УСТРОЕН ОСЦИЛЛОГРАФ В EWB?

Конечно, без осциллографа - как без рук. Часто бывает полезно посмотреть, что происходит в разных частях схемы, так электронщик лучше себе представляет работу всего устройства. В EWB осциллограф - точная копия настоящего.

Есть переключатели развертки и амплитуды. Чтобы на экран уместились колебания высокой или низкой частоты надо крутить развертку. Чтобы разглядеть сигналы разной амплитуды (если она слишком маленькая, то тебе покажется, что график просто линия), крути ручку амплитуды. В осциллографе EWB два луча. Ты можешь смотреть на нем сазу два сигнала, снятых из разных точек схемы, и сравнивать их.

EWB поможет тебе научиться пользоваться настоящим осциллографом. Ты хотя бы будешь знать, какие ручки искать. Правда, у настоящего осцила картинка бежит и дергается, приходится крутить еще и блок синхронизации. В EWB таких проблем нет. А еще настоящий аналоговый осциллограф не запоминает изменения картинки. Цифровые девайсы запоминают, но и стоят от 400 бакозойдов. Осцил EWB запоминает картинку, и даже после того, как ты отключил схему, можно отмотать график в любую точку, еще можно переключать размер экрана.

Все это радует новичка, который в руках не держал щуп осциллографа. Крутому спецу нужен нормальный графопостроитель с тучей настроек и немереным количеством лучей. И поэтому многие матерят EWB за поганый осциллограф. В EWB есть, конечно, и графопостроитель, но он тоже хреновый, с точки зрения бывалого электронщика.

АЧХ

Думаю, у тебя сейчас совсем снесет чердак, если я начну тебе рассказывать про амплитудно частотную характеристику, или ласково: АЧХ. Если ты задумал строить фильтр, который одни частоты пропускать будет, а другие - нет, то тебе понадобится специальный инструмент. В EWB есть такой прибамбас, который подключается к входу и выходу. Он тебе покажет график, на каких частотах фильтр пропускает, а какие глушит. Штука очень полезна для проверки входного контура приемников, фильтров усилителей и так далее.

В ЗАКЛЮЧЕНИЕ!

Прежде чем что-то тупо паять, попробуй это завести на EWB, это будет быстрее, и ты лучше разберешься в работе схемы. Однако не стоит доверять результатам EWB на все 100% - есть много нюансов, которые нельзя учесть на модели. Эмулятор танка или самолета тоже сильно отличается от реальных условий.

НАРКОТИК ДЛЯ ЭЛЕКТРОНЩИКА

MicroCap 6.XX

Учти, приятель, что я давно и плотно сижу на «МикроКепке». Я уже посадил на нее много студентов и преподов МИРЭА, своих знакомых радиофэнов. И моя миссионерская деятельность продолжается. Не обращай внимания, если я буду перехваливать эту программулину. Просто я неадекватен.


Спецвыпуск Xakep, номер #017, стр. 017-046-4, ЭМУЛЯТОР ПАЯЛЬНИКА: СОФТ ДЛЯ РАДИОВРЕДИТЕЛЯ

ЭМУЛЯТОР ПАЯЛЬНИКА: СОФТ ДЛЯ РАДИОВРЕДИТЕЛЯ

Спецвыпуск Xakep, номер #017, стр. 017-046-4

ПЕРВАЯ ДОЗА

Когда человек первый раз открывает EWB, он сразу втыкает где что и уже в первые 5 секунд может намутить простенькую схемку, а чуть сложнее - начинаются трудности. Когда человек открывает первый раз «MicroCap», то он ничего не понимает и закрывает «MicroCap» назад. Но если сесть вместе с приятелем и объяснить ему что к чему, он уже не захочет ничего другого. Вывод: первая доза «MicroCap» должна быть влита практически насильно.

ЭЛЕМЕНТАРНАЯ БАЗА

Первое, что меня спросит бывалый электронщик: "Как с деталями?". С деталями все просто волшебно. «MicroCap» полностью совместим с «PSpice», это один из самых распространенных языков моделирования электроники. Каждый уважающий себя производитель обязательно делает все модели своих элементов на «PSpice».

Качаю микросхему нужного мне производителя с Инета, подключаю к «MicroCap», и все работает.

Кто-то скажет, что к EWB тоже подключается «PSpice». Да, но ты пробовал когда-нибудь его подключать? Это сложно и неудобно. А к «MicroCap» я могу подключить PSpice-модель прямо в рабочем окошке.

ФОРМЫ ЭЛЕМЕНТОВ

«МикроКепка» имеет собственный векторный редактор элементов. Я могу сам нарисовать любой рисунок, а потом к нему прицепить либо PSpice-модель, либо макрос (схему из других элементов), либо стандартный элемент с моими настройками. Это удобно, если тебя заставляют оформлять документацию по ГОСТ. Можно легко и быстро дорисовать все элементы в соответствии с ГОСТами. Можно чертить векторами и писать прямо рядом с рабочими элементами. Потом можно все это сохранить в векторном формате и добавить в «Word», «Exel», «Illustrator». После можно печатать на плоттере на большой формат либо вывести по кускам на обычный принтер и склеить. Мы в МИРЭА так сдали туеву хучу курсачей, и все преподы были в диком восторге.

ТОЭ

Заценят «МикроКепку» и те, кто парится в институте с теоретическими основами электротехники (ТОЭ) либо с электроникой, либо с радиоэлектроникой. Предметы эти ультрагеморроидальные. А «МайкроКэп» может показать потенциалы в узлах, расставить направления и значение токов в цепях. Софтина без труда вычислит передаточную функцию и еще кучу всяких параметров, нужных студенту.

ФОРМУЛЫ

С помощью емкостей, индуктивностей, сопротивлений, источников тока и напряжения на «МайкроКэп» можно намутить физическую модель любого элемента. Все дело в том, что в параметрах любых элементов можно использовать формулы и переменные. Например, в «МикроКепке» есть модель кварцевого резонатора. Резонатор состоит из разных элементов, а их параметры зависят от трех констант: частота, сопротивление, добротность. Для резонатора нарисована фигурка, и теперь можно легко получить любой резонатор, задав три параметра нового элемента. Похожая штука сделана для радиолампы (триода). На «МайкроКэпе» свободно можно моделировать ламповые усилители.


Спецвыпуск Xakep, номер #017, стр. 017-046-5, ЭМУЛЯТОР ПАЯЛЬНИКА: СОФТ ДЛЯ РАДИОВРЕДИТЕЛЯ

ЭМУЛЯТОР ПАЯЛЬНИКА: СОФТ ДЛЯ РАДИОВРЕДИТЕЛЯ

Спецвыпуск Xakep, номер #017, стр. 017-046-5

ГЕНЕРАТОРЫ И СКРИПТЫ

Для генератора можно написать математическую формулу, можно использовать циклы. Очень удобно моделировать любой разовый или периодический сигнал. Когда мы с ребятами паяли АОН, пригодился аналоговый генератор, а когда проектировали сигнатурный анализатор, выручил цифровой генератор. Для каждого генератора был написан простенький скрипт на «PSpice». «PSpice» учить не пришлось, поскольку в «MicroCap» было много примеров работы генераторов. На цифровых генераторах можно генерить сразу несколько двоичных выходов. Причем можно менять задержки между двоичными словами. Можно увидеть, что бывает с микросхемами на больших частотах (микрухи начинают выдавать ошибки). Полезно это видеть и разгоняльщикам процессоров. Окончательно распрощавшиеся с башней электронщики могут подключить к генератору внешний файл с сигналом в виде таблицы.

Скрипты и формулы можно писать прямо рядом с фигуркой генератора или любого другого элемента либо на отдельном листочке, специально для скриптов. А можно написать один большой скрипт для всех элементов. Кстати, скрипт может заменить тот кусок схемы, который тебе лень собирать из деталей. Просто пропиши алгоритм его работы и нарисуй фигурку. Хотя все будет работать и без фигурки.

Можно сделать одну курсовую для всего курса студентов по электронике. Прописал расчетные формулы, и каждый студент подставит константы из своего задания. Курсач посчитан: наслаждайтесь.

АНАЛИЗ И ГРАФИКИ

Ой, держите меня! Сейчас я буду рассказывать про анализ. Ты можешь проводить анализ любого количества точек на схеме. После того как ты поставил на схеме точку и дал ей имя, «МикроКепка» думает, что это переменная. Через эту переменную можно узнать ток, напряжение или логическое состояние. Ну и, естественно, эти переменные можно подставлять в формулы и скрипты. Например, можно без проблем смоделировать резистор, сопротивление которого зависит от тока, можно замутить индуктивную связь между катушками и любые другие фокусы.

И уж, конечно, ты можешь строить график по переменной или по формуле. Например, можно разложить сигнал в спектр или сложить несколько сигналов между собой. Причем график получается векторный, на нем ты сможешь сделать подписи, нарисовать стрелочки, а потом экспортировать в «Ворд» или «Иллюстратор».

Если ты снимаешь инфу с многобитной шины, то удобнее будет прямо на графике выводить результаты в шестнадцатеричном или десятичном виде. Просто под каждой пачкой двоичных диаграмм будет стоять шестнадцатеричная циферка. Это здорово спасает, так как, например, в моем сигнатурном анализаторе было 4 разряда, то есть 16 двоичных диаграмм. Я долго кривился их разбирать, пока не заюзал эту фичу. Ну и, конечно, можно сохранить результаты в виде файла с массивом результатов.

АНАЛИЗ ДЛЯ ФАНАТОВ

Для любителей поэкспериментировать есть возможность подбора параметров деталей. Например, можно подобрать оптимальное сопротивление в фильтре или оптимальную емкость. «МикроКепка» сама переберет сопротивления из заданного тобою диапазона. Для каждого параметра она построит график, причем можно подбирать сразу два параметра, а график будет трехмерным. Вообще, «Майкро-Кэп» умеет строить трехмерные графики, но может построить и несколько графиков на одной плоскости. Например, реально замутить семейство кривых ВАХ (вольтамперная характеристика) транзистора или радиолампы.


Спецвыпуск Xakep, номер #017, стр. 017-046-6, ЭМУЛЯТОР ПАЯЛЬНИКА: СОФТ ДЛЯ РАДИОВРЕДИТЕЛЯ

ЭМУЛЯТОР ПАЯЛЬНИКА: СОФТ ДЛЯ РАДИОВРЕДИТЕЛЯ

Спецвыпуск Xakep, номер #017, стр. 017-046-6

УСТРОЙСТВО ИНТЕРФЕЙСА

В «MicroCap» можно загрузить сразу несколько файлов, а в EWB - только один. При открытии файлов предусмотрен предпросмотр. Спасает, если ты потерял свой любимый файл в куче хлама. Когда наводишь курсор на неоткрытый файл, «МикроКепка» его показывает. В самом файле, как в «Exel», есть листочки. Если у тебя огроменная схема, можно разбить ее на блоки и раскидать по этим листкам, назвав их соответственно содержанию.

В «MicroCap» можно вместе со схемой вводить растровые рисунки, векторные рисунки и шрифты разных размеров и цветов. Это очень любят преподы по электронике: вот тебе и рабочий лабораторный стенд, вот тебе и методичка. У «МикроКепки» много файлов с примерами и пояснениями. Это помогает разобраться с работой генераторов, в анализе, в скриптах и других нюансах.

РЕКОМЕНДАЦИИ

Советую эту софтину школьникам, студентам, преподам, радиолюбителям, которые уже нюхнули канифоли и обдолбались четырехэтажными формулами. Ученым и инженерам я бы тоже подкинул эту программулину, но они меня изобьют ногами. Обычно ученые копают очень узко и глубоко, под их задачи нужен узкоспециализированный софт. Я уже читал в Инете, как эти друзья нашли в «PSpice» какие-то баги и недочеты на сверхвысоких частотах и сверхвысоких напряжениях, где законы из учебников уже не работают. Вот и пишите сами себе программы, раз такие умные :). Хотя, может, проще скрипт и пару формул на «Micro-Cap»? А?


Спецвыпуск Xakep, номер #017, стр. 017-050-1, "1C" - ЗНАЙ НАШИХ!

"1C" - ЗНАЙ НАШИХ!

Спецвыпуск Xakep, номер #017, стр. 017-050-1

Андрей Каролик (andrusha@sl.ru)

Сама фирма "1С" была создана позже и под конкретный заказ. Пришел некий чел и сказал, что готов заказать работу на один миллион рублей.

«Symantec» был белый и немного зеленого, «Borland» был белый и чуть-чуть синего, а «Минибухгалтерия» была в папочке и черно-белая. Она сливалась с белым фоном остальных коробок, и народ ее просто не видел.

«Ил-2» на всех элитных выставках мира занял первые места, обойдя всех, включая «Microsoft Flight Simulator».

Реально найти работу в «1С» можешь и ты, нужно только подать свое резюме. Шансы некоторые есть всегда.

Я слишком часто слышу, что в нашей стране невозможно ничего делать. Невозможно жить, невозможно строить, невозможно начать свое собственное дело и честно заниматься бизнесом, невозможно создавать свои компьютерные программы, так как, якобы, задушат бюрократия, налоги, пираты и конкуренты с Запада. Но так ли это на самом деле? Фирма "1С" - чисто российская фирма, по многочисленным опросам занимающая сегодня первое место в софтверном секторе российской компьютерной индустрии. Туда-то я и отправился, чтобы из первых рук узнать и поведать тебе, как зародился подобный гигант софтостроения в нашей суровой действительности, что собой представляет, кто там работает и как они борются с проблемами и развиваются дальше. Заодно я разузнал, сможешь ли ты найти у них себе работу и что для этого тебе понадобится. Побеседовать мне удалось лично с директором фирмы "1С" Борисом Нуралиевым, который руководит фирмой со дня ее основания. Кроме этого, я побродил с фотографом по разным рабочим помещениям «1С», чтобы ты смог заглянуть внутрь и увидеть то, что другие увидеть не могут.

ОТКУДА РАСТУТ НОГИ ЖЕЛТОПУЗОЙ «1С»

В 1980 году, когда в Москве проводились Олимпийские игры, Борис успешно закончил Московский экономико-статистический институт. К моменту "перестройки" он работал в «НИПИстатинформ» - ведущем институте по автоматизации и учету в системе тогдашнего Госкомстата. Борис был одним из лучших разработчиков-программистов НИИ, и с 1988 года его назначили руководителем отдела. Этот хозрасчетный отдел уже тогда сильно напоминал фирму: Борис мог сам набирать в него людей, находить и выполнять заказы, кормить себя и сотрудников самостоятельно, не ожидая дотаций от государства. Но в 1990 году в Госкомстате сменилось начальство, а с новым начальством у Бориса возникли разногласия. Уволить его по закону не могли, да и не за что было, а вот отдела заказов лишили. Так он и попал на рынок: с незакрытым балансом и без заказов. Чтобы не сесть на пятую точку, ему нужно было с нуля и быстро найти заказы, выполнить их и закрыть баланс. Напрягся, конечно, но справился. Занимались они тем, что делали базы данных и системы электронной почты с доступом по разным коммуникационным каналам, даже по телеграфным. Интернета тогда еще не было, а спрос на онлайновые системы уже был. Сама фирма "1С" была создана позже и под конкретный заказ. Пришел некий чел и сказал, что готов заказать работу на один миллион рублей. По тем временам (начало 1991 года) это было очень много. Но с государственной конторой он работать не хотел, поэтому предложил взять их к себе на работу. Борис свою команду ценил и отдавать не хотел, тогда чел предложил им учредить частную фирму самим, а он после этого уже сделает заказ, как у частной конторы. Фирму учредили, а заказ он не сделал :). Но созданная фирма в будущем пригодилась. Рано или поздно это произошло бы, просто обстоятельства ускорили процесс. С тех пор Борис является директором фирмы "1С". Почему название именно "1С", Борис не рассказал, сославшись на военную тайну :). Но существует несколько легенд о его происхождении. Первая заключается в том, что «1С» обозначает первый сорт по аналогии с продуктами питания. К примеру, чай индийский первого сорта обозначали именно так. Вторая привязывает название к быстродействию разрабатываемой системы обработки баз данных, которая гарантировала выдачу ответа не более чем за одну секунду. Система номер один, одна секунда, отсюда и «1С». Третья легенда, видимо, пошла от компьютерщиков и заключается в том, что «С» - единственная кнопка на клавиатуре, которая совпадает на кириллической и латинской раскладках, что очень удобно. Выбирай любую или генери легенду сам :). Желтый цвет сделали фирменным тоже не случайно. В феврале 1992 года было принято решение разрабатывать тиражную бухгалтерскую программу (вначале ее назвали «Минибухгалтерия», а позже «1С: Бухгалтерия»), а в продажу она вышла уже в апреле 1992 года. Часть продукции разослали по региональным партнерам, а часть отдали в книжные магазины. Тогда компьютерных шопов практически не было, и софт продавали в книжных магазинах. Так вот, по партнерам продукция разошлась хорошо, а в магазинах почему-то покупали плохо. Борис, не долго думая, в одну из суббот пошел на разведку. Пришел в «Книжный мир» (сейчас это «Библио-Глобус»), встал в сторонке и понял, что все дело в оформлении. Игры тогда вообще мало продавались, а полка делового софта выглядела так: коробка MS-DOS 4.0.1 от «Microsoft» была белая с темно-фиолетовой полосой сверху (тогда еще MS на рынке не так доминировала, как сейчас), «Lotus» был динамовских цветов - бело-голубой, «Symantec» был белый и немного зеленого, «Borland» был белый и чуть-чуть синего, а «Минибухгалтерия» была в папочке и черно-белая. Она сливалась с белым фоном остальных коробок, и народ ее просто не видел. Было решено использовать для оформления новые цвета, которые было бы видно издалека, как куртку дорожного рабочего. Вся поверхность была покрашена желтым цветом, а уголок сделали красным с градиентом. После этого поставили опять по магазинам. Покупатель приходит и спрашивает продавца: "А это чего у тебя такое желтое появилось?". Ну, продавец отвечает: "Как, а это «Минибухгалтерия» фирмы "1С" - самая продаваемая бухгалтерская программа в стране". Малые предприятия в то время плодились как грибы. Налоги по сравнению с нынешними временами были крошечные, но каждый квартал надо было делать отчеты, чтобы отмазаться от налоговой. «1С: Бухгалтерия» стала успешно продаваться, а желтый цвет с тех пор так и остался.


Спецвыпуск Xakep, номер #017, стр. 017-050-2, "1C" - ЗНАЙ НАШИХ!

"1C" - ЗНАЙ НАШИХ!

Спецвыпуск Xakep, номер #017, стр. 017-050-2

КОНКУРЕНЦИЯ И СПОСОБЫ ВЫЖИВАНИЯ

Фирма "1С" занимается и разработкой, и дистрибуцией софта (игры, обучающие программы, системы для автоматизации предприятия и так далее). По каждому направлению есть, конечно же, конкуренты. Но конкуренции Борис не боится, объясняя это тем, что это Россия, идей у всех много, а вот руками как следует сделать мало кто умеет. Достаточно делать все нормально, по-человечески, а покупатель найдется. "Мы же не глупее конкурентов - просто нужно работать больше. Мы работаем больше, поэтому и выдерживаем конкуренцию. Конечно, мы смотрим, что делают наши конкуренты, изучаем их опыт". Постепенно "1С" стала делать бизнес-софт на очень высоком уровне и обратила свое внимание на перспективный игровой рынок. Но в 1998 году был кризис, и игры на внутреннем рынке продавать стало нерентабельно, затраты на разработку хорошей игры не отбивались. Было две альтернативы: свернуть направление или повышать свой уровень и выходить на мировой рынок. Выбрали второе. Яркий пример и огромное достижение - симулятор «Ил-2», на создание которого ушло 3 года. Он на всех элитных выставках мира занял первые места, обойдя всех, включая «Microsoft Flight Simulator». Специалисты "1С" сделали игру не просто лучшую в стране, а лучшую в своем классе в мире. Вот это нормальный подход, с которым конкуренты не страшны :).

РАБОТЯГИ "1С" И НАБОР НОВЫХ СПЕЦИАЛИСТОВ

По словам Бориса, существует два принципа построения софтовых фирм. Первый можно представить в виде регулярной армии - большая фирма с тысячным коллективом от солдата-срочника до лейтенанта-двухгодичника и выше. Всех их учат в учебке чему-то одному: кто механик-водитель, кто гранатометчик, кто радист. Второй можно представить в виде спецназа. Спецназ может решить не любую задачу, но если она по плечу, то для ее успешного решения будет достаточно роты спецназа вместо целого полка регулярной армии. В спецназе люди более грамотные, сплоченные, друг друга знают, каждый может пахать и за механика-водителя, и за гранатометчика, и за радиста. Каждый понимает, что вот сейчас он главный, принимает решения, а ему подчиняются. Через десять минут может быть наоборот - ему ставят задачу, и он должен ее выполнять, нравится ему это или нет. В профессиональном программировании это очень важно, поэтому "1С" построена в большей степени как спецназ и функционирует с высокой отдачей. Эффективность тиражной софтверной фирмы обычно оценивается объемами продаж на одного человека. "1С" уже удалось преодолеть рубеж в 100 тысяч зеленых на одного сотрудника в год (только не разгоняйся, это не зарплата сотрудника, а то, сколько он фирме приносит). Новые сотрудники проходят очень тщательный отбор, просматривается много резюме, зачастую на какие-то позиции на фирме из 100 просмотренных двух берут на испытательный срок, но только один проходит в штат. На какие-то позиции набор попроще, а на какие-то - приходится еще и дополнительно обучать, так как нет подобных специалистов или их очень мало. Многие считают, что тщательный отбор означает, что берут на работу только абсолютно готовых. Нет, так не бывает, и это не всегда очень важно. Важнее, чтобы человек подходил по моральным и психофизиологическим качествам, был работоспособным, легко обучаемым и работал с большим энтузиазмом. Благодаря этому на фирме очень низкая текучесть кадров: с 1996 года ушло не более 6% (6 человек из 100). Труднее всего приходится "свободным художникам", которым порой трудно понять, что они имеют право на свободу, но если есть проектные решения - нужно в них вписаться. Также строго с дисциплиной: если рабочий день начинается в 9:15 - будь добр, приди на работу вовремя. Сейчас на фирме "1С" работают более 250 человек. Добавляются новые направления, приходится брать на работу новых людей. Размер зарплаты на "1С" - коммерческая тайна, но она нормальная (из-за нее еще никто не уходил). Хочешь в "1С" на работу :)? Это вполне реально: нужно только подать свое резюме. Шансы некоторые есть всегда - талантливую молодежь они смотрят постоянно. Понятное дело, что если ты набиваешься к ним в художники, то ты должен уметь рисовать, если в программисты - программить, а если на линию консультации той же «1С: Бухгалтерия» - шарить в бухгалтерии. И у тебя должно быть что-то для примера, так как тебя попросят прислать или принести то, что ты наваял сам (наброски и эскизы, работающий код или кусок проекта) Конечно, не "Hello, World" :), а что-то посерьезнее. Некоторые сотрудники пришли в "1С" не только из Москвы, но и из разных регионов. Программят разработчики "1С", в основном, на С++, но что-то есть на «Delphi», что-то на «Clipper». Движок того же симулятора «Ил-2» сделан вообще на «Java». Естественно, весь софт лицензионный :). Если ты при этом где-то работал с программами "1С": на каком-нибудь конкретном предприятии, у знакомых или самостоятельно дома, то твои шансы значительно повышаются. Если даже тебя не возьмут в штат на "1С", то оторвут с руками их партнеры. Зависит, правда, напрямую от твоих познаний в прогах от «1С». Подкачал уровень? Не дрейфь - его можно поднять в учебных центрах и получить при желании сертификацию, которая даст тебе 100% трудоустройство в будущем. На самой "1С" учебных центров нет. Точнее - есть, но предназначены они для обучения своих же специалистов и повышения их квалификации. А вот авторизованных учебных центров в партнерской сети хватает. Полный их список смотри по адресу: http://www.1c.ru/rus/partners/partner-search.asp. Только по одной Москве я насчитал их целых 75 штук. Удовольствие это, конечно, не бесплатное. Чтобы найти курсы подешевле, тебе придется их обзвонить, так как далеко не все они выставляют цены на своих сайтах. Цена зависит от уровня курсов (для начинающего, для продвинутого или для программистов и администраторов) и количества академических часов, которое на тебя убьют :). Экзамен на сертификацию тоже стоит каких-то денег. Для примера глянь http://www.1s-a.ru/stud.shtml - это один из авторизованных учебных центров в Москве. Тут есть некоторые цены и план занятий по курсам, которые они ведут. Набор в ВУЗах "1С" сейчас не делает, и особого значения, что ты окончил, тоже нет. Лишь бы у тебя были требуемые знания, а где ты их надыбал - твои проблемы. Единственное, если ты - студент экономического ВУЗа, то можешь попробовать свои силы в регулярной, ежегодно проводимой олимпиаде по программированию среди студентов экономических ВУЗов, которую поддерживают фирма "1С" и журнал "Бухгалтерский учет". Если выиграешь, то получишь путевку в Париж, лавры и предложение о работе :). Информацию всасывай с http://www.1c.ru/rus/news/PRSREL/2001/Olymp2001/Olymp2001.htm.


Спецвыпуск Xakep, номер #017, стр. 017-050-3, "1C" - ЗНАЙ НАШИХ!

"1C" - ЗНАЙ НАШИХ!

Спецвыпуск Xakep, номер #017, стр. 017-050-3

ЖЕЛТЫЕ ПРОТИВ ВЗЛОМА И ПИРАТОВ

В России, порой, программу легче украсть, чем купить. С одной стороны, пиратство оказывает очень негативное влияние на нашу индустрию. При выходе на мировой рынок оно очень сильно портит имидж страны, имидж российских софтовых фирм: «А-а, вы все - пираты, у вас все нелицензионное!». На внутреннем рынке пираты душат мелкие и средние софтварные фирмы - программы воруются, и компаниям не хватает денег от продажи на то, чтобы окупиться и развиваться дальше. С другой стороны, пиратство делает конкуренцию гораздо жестче: крупные софтовые компании стремятся установить на рынке ПО безраздельное господство и диктовать цены, пиратские же цены не в пример ниже. Например, всеми нами нежно ненавидимая M$ до сих пор задирает прайсы на свои оси, явно не соответствующие качеству продукта, ну так и лицензионных «мастдаек» у народа по пальцам. В любом случае, софт-фирмам приходится защищаться. Методы защиты разные, начиная от ключей к софту и кончая хардлоками (hardlock), которые вставляются в определенный порт твоего компа, чтобы программа пахала. Защиту не любит никто (особенно пираты :)), но приходится ее ставить, иначе будут воровать.

Непосредственно технологиями защиты "1С" не занимается, а использует купленные наработки специализирующихся на этом фирм. Кроме того, каждая программа имеет уникальный регистрационный номер, по которому можно легко протрейсить весь ее путь от склада до конечного пользователя. С ворованной программой ты уже не сможешь пользоваться бесплатной поддержкой и консультациями - тебя элементарно вычислят и надают по попе :). Но любая защита ломается, появляются пираты и пиратские версии программ. С ними борются разными методами, иногда вплоть до привлечения к уголовной ответственности. Как ни странно, но один из методов борьбы - убеждение. Россия - странная страна :). Вот забавный случай. В одном форуме в Инете как-то один чел хвалится, что смог сломать игру «Ил-2» (а может, гнал очередной ламер :)). На что ему другие отвечают: "Ну и дурак ты! Нашел, чем хвалиться! Это же наши ребята делали!". То есть возникает даже своего рода патриотизм.

Однако пираты - народ циничный, и всех их не передавишь. Ну, можно закрыть какие-то точки распространения левых болванок и снести варезные архивы с крупных порталов, что, кстати, частенько сейчас делается. Но очень скоро все отрастет заново. И даже если производитель написал телегу на конкретного пирата, чтобы его приложили по 146 статье УК, весьма вероятно, что может приехать на чай внушительных размеров дядька и сказать: "Это ты написал? Ты чего, мужик? А ну-ка забери бумажку обратно". Если крупная компания, как "1С", и сможет дать отпор, то небольшие фирмы вынуждены закрывать дела, так и не начав их.

Чтобы избежать наездов от пиратов, "1С" и многие другие крупные софтовые компании России, порой прямые конкуренты между собой, собрались вместе и создали ассоциацию - некоммерческое партнерство поставщиков программных продуктов (НП ППП). Она общероссийская, и на сегодня в нее вошло около 100 членов из 36 регионов как разработчиков, так и продавцов. Теперь любой член ассоциации для возбуждения дела может писать заявление не от себя лично, а от ассоциации. И если придут разбираться, то за спиной уже будет что-то большое. Начнут давить - самих задавят :). Только за 2001 год и начало 2002 года по "1С" было возбуждено порядка 100 уголовных дел. Самым громким было дело по пиратам Фроловым, которые проходили по уголовному делу и должны выплатить гражданский иск в размере более 300 тысяч зеленых!


Спецвыпуск Xakep, номер #017, стр. 017-050-4, "1C" - ЗНАЙ НАШИХ!

"1C" - ЗНАЙ НАШИХ!

Спецвыпуск Xakep, номер #017, стр. 017-050-4

Еще одной фишкой от девелоперов является идея товарного знака, типа "софт в подлиннике" или "лицензионный софт". Члены объединения будут платить определенный членский взнос и рисовать этот знак (который будет своего рода отличительной меткой для органов) на своей продукции. В случае, если пираты скопируют софт, они и этот знак скопируют и автоматом подпадут под закон о защите товарных знаков.

Вот так, не техникой запинаем, так юристами :). Однако самым действенным методом борьбы с нашими флибустьерами (который, кстати, успешно юзает та же «1С»), ИМХО, является ценовая политика. Пиратов вышибают с рынка ценой и качеством. И это есть гут!

ПЛАНЫ НА БУДУЩЕЕ

Неужели в России можно продавать несколько миллионов программ в год? Можно. Непросто, но надо заниматься. В день через "1С" проходят закупки более 200 организаций, что составляет более 14 тысяч товарных позиций общим весом более 5 тонн! Партнерская сеть у "1С" нехилая - более 2300 постоянных партнеров в 430 городах России и странах СНГ. Сам Борис оптимистично смотрит на будущее компании: "Площади есть, деньги есть, идеи есть, страна большая, да и в соседние страны продавать можно." Не так далек тот день, когда мы заткнем америкосов :).


Спецвыпуск Xakep, номер #017, стр. 017-054-1, ADOBE ILLUSTRATOR - МЕГАКРЕАТИВНЫЙ ПАТРОН В ОБОЙМЕ ДИЗАЙНЕРА

ADOBE ILLUSTRATOR - МЕГАКРЕАТИВНЫЙ ПАТРОН В ОБОЙМЕ ДИЗАЙНЕРА

Спецвыпуск Xakep, номер #017, стр. 017-054-1

Vadim Murzagalin (vadias@sendmail.ru, www.freehand.str.ru)

"PostScript" - язык описания страницы, встроенный во многие принтеры и во все high-end печатные системы. Его первая версия представляла собой серые векторные и растровые изображения, вторая уже обеспечивала цвет в цветовых моделях RGB, CMYK и CIE. Последняя версия - "PostScript LanguageLevel 3" - работает еще и с mesh-объектами. По скромным подсчетам "Adobe", 75% коммерческих публикаций делается с использованием этого языка. Формат PDF был разработан на основе постскрипта, но предназначался не только для печати, но и для хранения материалов в электронном виде. PDF не привязан ни к какой графической программе, является кроссплатформенным, сжимает данные, инкапсулирует растровые картинки и шрифты, поддерживает гиперссылки и формы.

Язык PCL, который используется в обычных офисных принтерах, гораздо беднее по возможностям. Он не позволяет вывести цветоделение, PCL-принтер непутево работает с искаженными и повернутыми изображениями, а также не может напечатать импортированную и уменьшенную графику с высоким качеством.

Программа «Adobe Illustrator» - выбор настоящих профи, причем от слова "профессионал", а не "профан". Он имеет в рукаве далеко не один козырь против своих ближайших конкурентов - «Corel Draw» и «Macromedia FreeHand».

Немало можно наговорить и о совместимости «Иллюстратора» с остальными адобовскими прогами - сейчас это называется "тесной интеграцией". Лучше всего использовать «Иль» в паре с «Фотошопом», сурово комбинируя векторную и растровую графику. Если тебе потребуется футболить файл из проги в прогу, то можешь ничего не бояться: все слои, маски и полупрозрачность сохранятся в первозданном виде.

Нетривиальным для векторных прог является эффект бликов на линзах - «Flare tool». Преимущество перед аналогичными эффектами в растровых редакторах - то, что эту штучку в любое время можно отредактировать или убрать, поскольку она является векторным объектом.

Я помню, как сам считал кривые Безье тупой выдумкой и бессмысленной сложностью, пока не пришел к выводу, что это и есть векторная графика по своей сути. Умелое обращение с инструментом «Pen» поможет выйти победителем из большинства ситуаций.

Самая шахтерская специальность в этой сфере - художники-оформители, они же (местами) верстальщики. На их могучих плечах держится все производство, здесь нужны навыки скрупулезной работы, знание всего процесса. Помни главное: большинство дизайнеров и художественных редакторов начинают свою карьеру именно отсюда!

Мамы всякие нужны, мамы всякие важны... Но вот однажды настал момент, когда ты почувствовал, что немного подрос, раздался в плечах и животе, и апеллировать к маме стало глупым занятием - пора начать подумывать и о собственном выборе профессии и престижной работы. Профессий сейчас много, но если ты - личность творческая и одиозная, а также не боящаяся новых знаний, вряд ли тебя удовлетворит расчистка территорий от мусора и снега или однообразная возня со скучными документами. В таком случае знай: сейчас наступают неплохие времена для спецов издательского дела, полиграфии, рекламной деятельности и аналогичных творческих профессий, а у тебя есть шанс вступить в битву за место под солнцем во всеоружии.


Спецвыпуск Xakep, номер #017, стр. 017-054-2, ADOBE ILLUSTRATOR - МЕГАКРЕАТИВНЫЙ ПАТРОН В ОБОЙМЕ ДИЗАЙНЕРА

ADOBE ILLUSTRATOR - МЕГАКРЕАТИВНЫЙ ПАТРОН В ОБОЙМЕ ДИЗАЙНЕРА

Спецвыпуск Xakep, номер #017, стр. 017-054-2

ILLUSTRATOR - ВЫБОР ПРОФИ

Причем "профи" здесь - от слова "профессионал", а не "профан". Как ты уже, наверное, слышал, в сфере рекламного дизайна необходимо владеть тремя разновидностями программ: редактором векторной графики, редактором растровой графики и прогой для верстки. Рынок породил немало конкурирующих программ в каждой из этих областей, но только "Adobe" сделала в данном направлении полную линейку программ. С "Фотошопом" все ясно - его еще не скоро спихнут с верхушек чартов пользовательских симпатий, "InDesign" называют "убийцей "Quark'а"", а "Иллюстратор" - один из трех бойцов, отчаянно бьющихся за пихту первенства среди профессиональных векторных редакторов (если ты не в курсе: другие два - "Corel Draw" и "Macromedia FreeHand").

Если ты бывал на интернет-форумах, посвященных графике, или подписывался на аналогичные эхи в ФИДО, то, наверняка, встречал фразы типа "лучший редактор тот, в котором ты умеешь работать". Это, конечно, справедливо, но до тех пор, пока ты делаешь пикчуры для ВВВ или печатаешь простенькие документики на PCL-принтерах, когда не требуется сногсшибательное качество, а время терпит. В серьезных же конторах эти два критерия (время и качество) часто выходят на первый план и оказываются решающими, так что надо держать хвост пистолетом, дабы не облажаться в самый неподходящий момент.

Чтобы не быть голословными, посмотрим-ка, какие аргументы говорят в пользу "Иля" и делают его выбором настоящих профессионалов.

Главный козырь этой проги состоит в том, что перцы, которые его делали, по совместительству являются разработчиками "PostScript" - языка, на котором "говорят" мажорные профессиональные принтеры и практически все крутые фотонаборные автоматы, выпускающие печатную продукцию. Все это значит, что при выводе проекта на печать "Иль" не кинет тебя как последнего лоха. Мало того, поначалу графика "Иля" базировалась на этом языке; правда, в конце концов, это стало тормозить развитие его творческих инструментов. Начиная с девятой версии, Иллюстратор перешел на язык PDF, с чем его и поздравляем.

Благодаря тому, что "PostScript", а в последнее время и PDF, стали стандартом всего, что можно напечатать, большинство графических приложений не только понимает формат .AI, но и может экспортировать в него свои родные файлы. Это значит, что формат файлов "Иллюстратора" - самый распространенный, но логично предположить, что только он сам работает с ними полностью корректно ;).

Многие документы хранятся не только в бумажном, но и в электронном виде. Держать их исходные файлы неразумно, а самое оптимальное решение - файлы в формате PDF. Иллюстратор может открывать файлы PDF и редактировать их.

Для ВВВ можно сохранять файлы в формате SVG (Scalable Vector Graphics - масштабируемая векторная графика). Это векторный формат, который описывает картинку как совокупность форм, текста, линий и фильтров, основанный на расширяемом языке разметки (XML), которому пророчат большое будущее в сетке. И уж, конечно, не был забыт и "Flash" - он также поддерживается "Илем" в полной мере: здесь можно создавать не только статичные картинки, но и покадровую анимацию.


Спецвыпуск Xakep, номер #017, стр. 017-054-3, ADOBE ILLUSTRATOR - МЕГАКРЕАТИВНЫЙ ПАТРОН В ОБОЙМЕ ДИЗАЙНЕРА

ADOBE ILLUSTRATOR - МЕГАКРЕАТИВНЫЙ ПАТРОН В ОБОЙМЕ ДИЗАЙНЕРА

Спецвыпуск Xakep, номер #017, стр. 017-054-3

Ты думаешь, достоинства "Иллюстратора" заканчиваются на работе с разными форматами файлов и крутостью в издательском деле? Отнюдь нет: в буржуинских странах Интернет развит во много раз сильнее, чем на нашей родине слонов, и это не могло не найти отражение в графических редакторах. Кроме поддержки .SWF и .SVG, "Иль" обладает функцией "slice" (большие картинки режут на части для лучшей загрузки), а также "Image Map", когда отдельный участок изображения является гиперссылкой. Для графического текста можно выборочно выставлять анти-алиасинг, чтобы мелкий шрифт был читабельным. Для экспорта компактных файлов в меню "File" есть команда "Save for Web", вызывающая окно со множеством полезных мелких настроек оптимизации.

Немало можно наговорить и о совместимости "Иллюстратора" с остальными адобовскими прогами - сейчас это называется "тесной интеграцией". Лучше всего использовать "Иль" в паре с "Фотошопом", сурово комбинируя векторную и растровую графику. Если тебе потребуется футболить файл из проги в прогу, то можешь ничего не бояться: все слои, маски и полупрозрачность сохранятся в первозданном виде. Копирование и вставка через буфер туда и обратно также не вызовет проблем - оба они используют одинаковые механизмы при создании векторных форм. Для верстки многостраничных документов "Иль" не годится; на этот случай у "Adobe" припасен "InDesign". Тут вообще лепота: "InDesign" полностью понимает формат "Illustrator'а", так что в нем можно запросто редактировать импортированные .AI объекты. В "GoLive" - проге для веб-дизайна - файлы "Иллюстратора" вставляются в качестве "Smart Object" (смачный объект), при этом сохраняются слайсы и ссылки, а двойной щелчок по этому объекту откроет "Иллюстратор" для редактирования.

ЧТО МОЖЕТ ИЛЬ

Хватит тереть об абстрактных вещах, которые с трудом представляются визуально. Пришло время обсудить более интересные вещи - тулзы, эффекты, необычные свойства объектов - в общем, все то, что адобовцы называют "инструментами творческой свободы".

Начнем с основы основ векторной графики - кривых Безье. Линии рисуются и редактируются целым рядом инструментов. Контуры свободной формы рисуются инструментом "Pencil". Семейство этого тулза состоит из трех представителей: "Pencil tool", "Smooth tool" и "Erase tool". Если с первым все ясно, то второй и третий - довольно необычны. С помощью "Smooth tool" можно смягчать острые углы у контурных линий, а "Erase Tool" убирает ненужные сегменты кривой.

Для рисования гладких кривых Безье традиционно используется инструмент "Pen". В нагрузку к нему подброшены инструменты добавления и удаления опорных точек на кривой. Здесь позволю себе наехать: мне кажется, что не было необходимости выносить эти функции отдельно (во "FreeHand" все это делается "Pen'ом"). Зато удобно быстро менять тип опорной точки с гладкой на угловую инструментом "Convert Anchor Point", который расположен здесь же.


Спецвыпуск Xakep, номер #017, стр. 017-054-4, ADOBE ILLUSTRATOR - МЕГАКРЕАТИВНЫЙ ПАТРОН В ОБОЙМЕ ДИЗАЙНЕРА

ADOBE ILLUSTRATOR - МЕГАКРЕАТИВНЫЙ ПАТРОН В ОБОЙМЕ ДИЗАЙНЕРА

Спецвыпуск Xakep, номер #017, стр. 017-054-4

В "Иллюстраторе" также есть неплохой инструмент "Brush" (кисть), имитирующий мазки настоящей кистью. Есть четыре типа кисти. Естественно, можно редактировать существующие и добавлять свои кисти, а также импортировать их библиотеки.

Нетривиальным для векторных прог является эффект бликов на линзах - "Flare tool". Преимущество перед аналогичными эффектами в растровых редакторах - то, что эту штучку в любое время можно отредактировать или убрать, поскольку она является векторным объектом. Кроме того, по этой же причине она аккуратно выглядит при любых разрешениях. Несколько настроек позволяет расположить все элементы, получающиеся при этом спецэффекте, с высокой точностью.

Такой же необычный инструмент - "Mesh tool". С помощью него можно добиваться высокой реалистичности в изображении объемных предметов. На объект накладывается сетка, и благодаря этому удается точно манипулировать переходами цвета.

В последней, десятой версии "Adobe Illustrator" появились еще и новые оригинальные рисовальные тулзы. Это "Arc" (дуга), "Grid" (сетка) и "Polar Grid" (круглая сетка). Тому, кто не догадывается, какая удача привалила к нему в виде этих инструментов, разработчики разъясняют в руководстве: дугой ты можешь показывать направление, выделять заголовки, прямоугольной сеткой быстро создавать карты и диаграммы, а круглой сеткой удобно делать изображения прицелов, радаров и рисовать карту Антарктиды :).

Много внимания в "Adobe Illustrator 10" уделено работе с символами. Такое заботливое отношение в первую очередь объясняется все тем же уклоном в сторону веб-дизайна. Особенно это касается флэш-роликов: использование символов сильно облегчает их вес, и пага будет грузиться быстрее. Тем не менее символы находят применение и в других отраслях. Тот, кто знаком с объектно-ориентированным программированием, знает о преимуществах модульной организации проекта. Взять хотя бы те же самые карты и планы местности с какими-либо значками, обозначающими стоянки, больницы и так далее: если вдруг понадобилось поменять все эти мини-изображения на более продвинутые, нет ничего проще - меняется непосредственно сам символ, и все значки, созданные на его основе, последуют за своим вождем :). Символы находят применение в качестве множества листьев на деревьях, звезд на небе - в общем, там, где требуется изобразить большое количество однородных предметов.

Под это дело было отведено аж восемь разных инструментов: "sprayer", "shifter", "scruncher", "sizer", "spinner", "stainer", "screener" и "styler". Все они объединены в группу под романтичным названием "symbolism tools".

Пару слов об экспорте в Macromedia Flash. Кажется, только самые ленивые не включили этот вариант экспорта в свои проги; дело осталось за "Notepad'ом" :). Символы "Иля" автоматически превращаются в символы флэша. Расчетной анимации пока нет, так что приходится перебиваться покадровой. Это делается так: рисуешь группу кадров, каждый кадр помещается на отдельный слой, а при экспорте выбираешь опцию "AI Layers to SWF Frames".


Спецвыпуск Xakep, номер #017, стр. 017-054-5, ADOBE ILLUSTRATOR - МЕГАКРЕАТИВНЫЙ ПАТРОН В ОБОЙМЕ ДИЗАЙНЕРА

ADOBE ILLUSTRATOR - МЕГАКРЕАТИВНЫЙ ПАТРОН В ОБОЙМЕ ДИЗАЙНЕРА

Спецвыпуск Xakep, номер #017, стр. 017-054-5

Следующая группа возможностей, которой гордятся разработчики, называя "живыми искажениями" (это я так перевел фразу "Live distortion"), позволяет гнуть, коверкать, и прочими манипуляциями портить жизнь объектам. Фишка в том, что ты можешь в любое время менять свойства объектов вне зависимости от искажения, допустим, поменять в объекте текст. В общем, превосходство арийской расы... то есть преимущество векторной графики в данном случае налицо :). Все эти эффекты можно разделить на три подгруппы: эффекты деформации (Warp effects), эффекты с использованием оболочки (Envelope) и инструменты, придающие объектам "текучесть" (Liquify tools).

ЭФФЕКТЫ ДЕФОРМАЦИИ

В десятом «Иллюстраторе» 15 различных настраиваемых warp-эффектов, которые могут применяться к картинкам, объектам и тексту. Во время настройки в диалоговом окне опций можно врубить функцию «Preview», дабы контролировать процесс и наблюдать за изменениями в реальном времени - это неплохо экономит время. Подобные штучки хороши при создании и разработке логотипов.

ЭФФЕКТЫ С ИСПОЛЬЗОВАНИЕМ ОБОЛОЧКИ

Я не знаю, чья светлая голова изобрела оболочки, но это весьма удобная и часто используемая вещь. Если кто-то не знает, поясню: оболочка - это замкнутый контур, в который можно запихнуть любую кучу объектов. Его можно растягивать и гнуть, и все, находящееся внутри, будет податливо соглашаться. Посмотри на рисунок, чтобы увидеть оболочку в действии. Заметь, что текст, да и другие объекты также можно изменять, даже когда они в оболочке. Все это рагу превосходно работает и в комбинации с warp-эффектами.

"ТЕКУЧИЕ" ИНСТРУМЕНТЫ

Все они меняют форму объекта так, как если бы он был из полужидкого материала. В отличие от двух предыдущих групп спецэффектов, здесь нельзя искажать текст, растр и символы :(. Всего таких инструментов семь, но по названию больше всех мне понравился «Pucker». От такого жди что угодно :).

Одним из необходимых атрибутов редактора векторной графики должно быть обеспечение работы с составными контурами. Допустим, ты хочешь получить контур с дыркой. Какой бы ты ни был крутой художник, какие бы изощренные линии ни умел рисовать, простыми средствами такой фичи ты не достигнешь: дырка будет отдельной формой, которая может быть расположена либо над, либо под контуром. Тут-то и помогает так называемый составной контур, который на самом деле состоит из двух, ведущих себя как один. Иллюстратор в своей последней версии предлагает целый чемодан средств для таких форм. Все элементы управления для операций с составными контурами собраны в палитре «Pathfinder».

Здесь также работает коронная фишка «Иля»: те формы, из которых собран составной контур, редактируемы, уже будучи в нем. Другими словами, необратимых процессов здесь практически нет, и это хорошо.

Нехилые возможности дает «Иллюстратор» и в плане деловой графики, я бы даже сказал, деловых графиков :), коих можно нарисовать в избытке и в самом разнообразном виде. Девять инструментов - можно утереть нос любому специализированному офисному приложению ;).


Спецвыпуск Xakep, номер #017, стр. 017-054-6, ADOBE ILLUSTRATOR - МЕГАКРЕАТИВНЫЙ ПАТРОН В ОБОЙМЕ ДИЗАЙНЕРА

ADOBE ILLUSTRATOR - МЕГАКРЕАТИВНЫЙ ПАТРОН В ОБОЙМЕ ДИЗАЙНЕРА

Спецвыпуск Xakep, номер #017, стр. 017-054-6

Трудно назвать исчерпывающим мой короткий рассказ о возможностях могучего «Adobe Illustrator». Люди пользуются им годами и тем не менее иногда открывают для себя что-то новое - ведь все эти инструменты, трюки и эффекты можно комбинировать в бесчисленных вариациях. Любую задачу, поставленную перед дизайнером, можно решить очень многими способами, и все они будут правильными. Тем не менее ты получил свою долю инфы, которая, я надеюсь, поможет тебе определиться в нелегком выборе.

А СПЕЦ ЛИ Я?

Какими же знаниями и навыками надо обладать, чтобы считать себя полноправным членом славной дизайнерской диаспоры и знатоком «Иллюстратора» в частности? Иные считают себя доками, раза два-три запустив редактор и начертив корявую линию. Но ведь надо убедить в этом не только себя самого, но и, что важнее, потенциального работодателя. Давай прикинем, что нужно сделать, чтобы даже отдел кадров с наметанным глазом дрогнул, почувствовав твою графическую харизму.

Здесь рассказывалось, в основном, об особенностях «Иля» по сравнению с другими редакторами; их знания стоят меньше, чем базовые навыки по работе с векторной графикой. В этом все подобные программы одинаковы, отличаются лишь подходы, и то - в незначительной степени. Желательно хотя бы немного уметь рисовать в принципе; еще важнее владеть принципами фундаментального черчения (в этом отличие векторных прог, которые параллельно называются и чертежными). Не стоит жалеть времени на изучение и приобретения опыта в создании кривых Безье. Я помню, как сам считал их тупой выдумкой и бессмысленной сложностью, пока не пришел к выводу, что это и есть векторная графика по своей сути. Умелое обращение с инструментом «Pen» поможет выйти победителем из большинства ситуаций.

Иногда случается так, что логотип фирмы существует только на бумаге, и простое сканирование не принесет высокого качества. Вариант полегче - перевести отсканированную пикчу в вектор путем трассировки, вариант получше - поместить эту пикчу как основу в документ «Иля» и обрисовать ее подручными средствами.

Надо четко представлять себе, что такое объект, чем контуры отличаются от линий, в чем фишка составных контуров и как делать над ними различные операции. Особенно это касается текстовых объектов; от этих подлецов надо ожидать чего угодно, и если вовремя не дать им по рукам, можно наломать конкретных дров.

Изучай точные методы рисования: используй направляющие, сетку, панель «Info» и почаще применяй команды выравнивания - в серьезных конторах следят за миллиметрами, а не за метрами ;). Также эти и другие задачи помогают решить слои.

При обилии работы, когда поставлено на конвейер применение одних и тех же комбинаций свойств и эффектов, недурно применять стили. Время - деньги!

Все это были навыки, необходимые при допечатном процессе. Однако не надо думать, что в большом деле все так же просто, как и дома: нажал кнопочку и ждешь, пока потертый струйник выплюнет титульник для твоего реферата или курсовой. Все гораздо страшнее; тем не менее, вооруженный необходимой инфой, ты без труда пофиксишь и завалишь любую проблему. Во-первых, надо вникнуть в теорию цветовых моделей (таких как RGB, CMYK и другие), чтобы получать предсказуемые и правильные цвета при печати. Следует уметь их настраивать, а также знать, какие эффекты надо применять реже и более осторожно. Иногда при неправильном отображении на печати помогает корректировка объектов (расширение и сужение). Затем не помешает владение информацией о различных типах графических файлов и файлов «PostScript» - это ведь, как-никак, язык печати. К слову сказать, в некоторых специализированных конторах за распечатку сложных документов берут дополнительные баблы, так как даже опытные специалисты имеют с этим траблы.


Спецвыпуск Xakep, номер #017, стр. 017-054-7, ADOBE ILLUSTRATOR - МЕГАКРЕАТИВНЫЙ ПАТРОН В ОБОЙМЕ ДИЗАЙНЕРА

ADOBE ILLUSTRATOR - МЕГАКРЕАТИВНЫЙ ПАТРОН В ОБОЙМЕ ДИЗАЙНЕРА

Спецвыпуск Xakep, номер #017, стр. 017-054-7

Естественно, индивидуальные фичи «Иллюстратора» никогда не помешают. То, что многие его элементы не имеют аналогов в прогах конкурентов, должно работать на тебя ;). Ставь эксперименты, разделяй и властвуй!

КУДА ТЕПЕРЬ?

Тебя, конечно, интересует вопрос, куда может пристроиться чел, умело пользующий «Иллюстратор». Все зависит не только от владения конкретным пакетом, но и от опыта специалиста в подготовке иллюстраций и общей художественной подготовки. Тот, у кого преобладает последнее качество, может попробовать себя в качестве иллюстратора - вот такой получается каламбур :). Сфер, в которых может работать художник-иллюстратор, достаточно много. Это может быть рисование одежды, мебели или, скажем, иллюстрирование журналов либо газет. Его навыки не помешают и в более востребованной сейчас специальности - дизайнерстве, где важно иметь вкус, чтобы аккуратно расставлять элементы композиции, добавлять в нужных местах спецэффектики для наиболее эффектной подачи инфы. Наконец, самая шахтерская специальность в этой сфере - художники-оформители, они же (местами) верстальщики. На их могучих плечах держится все производство, здесь нужны навыки скрупулезной работы, знание всего процесса, чтобы выполнять задания самодовольных дизайнеров или редакторов, подгонять по долям миллиметра текстовые блоки и аккуратнейшим образом обрезать фотографии. Помни главное: большинство дизайнеров и художественных редакторов начинают свою карьеру именно отсюда!

Контор, которым нужны вышеперечисленные специалисты, не так уж и мало. Сколько типографий, дизайн-бюро, издательств и веб-студий вокруг - не теряйся ;).

БОНУСНЫЕ ИСТОЧНИКИ ЗНАНИЙ

Если ты всерьез заинтересовался нашей работой и «Иллюстратором» в частности, ты захочешь найти дополнительные материалы в тему. Лучшее решение в таком случае - книга. Я могу предложить тебе небольшой список из трех книг, которые могут тебе помочь:

Бурлаков, «Adobe Illustrator 9. Справочник», издательство "Питер", 2001 год;

Пономаренко, «Adobe Illustrator 9.0. Наиболее полное руководство», издательство "БХВ", 2001 год;

«Adobe Illustrator 9.0. Учебник», издательство "Диасофт", 2001 год.

Если найдешь книги лучше - хорошо. Единственный совет - не покупайся на дешевизну. Скупой в данном случае точно платит дважды.


Спецвыпуск Xakep, номер #017, стр. 017-054-8, ADOBE ILLUSTRATOR - МЕГАКРЕАТИВНЫЙ ПАТРОН В ОБОЙМЕ ДИЗАЙНЕРА

ADOBE ILLUSTRATOR - МЕГАКРЕАТИВНЫЙ ПАТРОН В ОБОЙМЕ ДИЗАЙНЕРА

Спецвыпуск Xakep, номер #017, стр. 017-054-8

Интернет тоже обладает некоторой инфой, хотя на русском языке, к сожалению, довольно скудной. Я рекомендую заглянуть на следующие сайты:

www.graphics.ru - это самый большой отечественный проект, посвященный 2D графике. Тут есть и форумы, и статьи - как обзорные, так и практические. Вдобавок, здесь есть хорошая галерея.

www.netdesigner.ru - красноярский ресурс, один из известных графических порталов. Есть статьи автора сайта, посвященные именно «Adobe Illustrator».

www.illustrator.ru - нет, ресурс, пожалуй, назван не по имени нашего сегодняшнего героя; тем не менее можно почитать материалы о дизайне вообще, о том, как себя вести, устраиваясь на дизайнерскую работу, и как вести себя с наглыми клиентами.

Из зарубежных, как можно догадаться, следует заглянуть на www.adobe.com., там есть галереи, в которых можно лицезреть работы известных специалистов, чтобы спереть и использовать в дальнейшем удачную идею :). На рисунке представлена одна из таких работ, выполненная известным в тамошних кругах художником чисто в «Adobe Illustrator». Слабо :)? Другой известный ресурс - www.illustrator-resources.com. Там, кстати, можно надыбать разные подключаемые модули и прочие дополнения. Удачи тебе!


Спецвыпуск Xakep, номер #017, стр. 017-060-1, БУХГАЛТЕРИЯ ПРОГРАММИСТУ ПО КОЛЕНО: КАК СТАТЬ 1С-КОДЕРОМ

БУХГАЛТЕРИЯ ПРОГРАММИСТУ ПО КОЛЕНО: КАК СТАТЬ 1С-КОДЕРОМ

Владимир (vlush@mail.ru)

Спецвыпуск Xakep, номер #017, стр. 017-060-1

Cуществует целая тусовка кодеров, которые называют себя гордо «1С-программистами».

К счастью, встроенный язык достаточно продвинутый и полностью открытый, к тому же существует возможность программировать как на русском языке, так и на английском.

В Финансовой академии при Правительстве РФ ежегодно проводятся международные олимпиады по программированию среди экономических вузов. Принять участие в олимпиаде можешь и ты.

Как стать программистом, известно всем. Для этого нужно увлекаться компьютером и торчать от кодинга, при желании можно поступить в институт на соответствующий факультет (не советую :)). А может ли кодер приложить свои ручки где-нибудь еще и получить хороший приработок, пока его софт не снискал мегапопулярность?

1С-ПРОГРАММЕР

Не вопрос! Cуществует целая тусовка кодеров, которые называют себя гордо «1С-программистами». Кто это такие? Это челы, которые имеют некоторые знания в экономике и имеют преставление о бухгалтерском учете, но, в первую очередь, знают встроенный язык программирования, используемый для конфигурирования и настройки системы «1С». Да, знание бухучета поможет тебе общаться с бухгалтером фирмы-клиента, но не является обязательным. Ты просто выполнишь поставленные перед тобой задачи. Согласись, не обязательно самому знать, как работает сердце, чтобы закодить софт для кардиологов. Вот и здесь бух сам скажет, какой журнал должен открываться по щелчку по этой пимпе и какую форму должен иметь тот или иной документ.

ВСТРОЕННЫЙ ЯЗЫЧОК

К счастью, встроенный язык достаточно продвинутый и полностью открытый, к тому же существует возможность программировать как на русском языке, так и на английском. Давай глянем на типы данных и объекты встроенного языка программы «1С: Предприятие 7.7».

Константы. Здесь хранится постоянная или условно-постоянная информация, то есть такая информация либо совсем не изменяется в процессе деятельности предприятия, либо изменяется достаточно редко.

Справочники. Они хранят списки однородных объектов. Справочники используются в тех случаях, когда необходимо исключить неоднозначный ввод информации в документах. В качестве обязательных реквизитов каждый справочник имеет код и наименование.

Документы. С их помощью организуется ввод в систему информации о совершаемых хозяйственных действиях (например, о продаже товара), ее просмотр и, если необходимо, корректировка. В большинстве своем документы являются электронными аналогами стандартных бумажных документов (например, накладных).

Журналы документов. Они обеспечивают работу с документами: ввод, просмотр, редактирование и удаление.

Перечисления. Это списки возможных значений какого-либо реквизита, например, наименования товара. Перечисления юзают, чтобы в тех случаях, когда необходимо, исключить неоднозначный ввод информации.

Планы счетов. Они предназначены для хранения информации по счетам бухгалтерского учета. Планы счетов поддерживают многоуровневую иерархию «счет - субсчета». На любом счете или субсчете можно вести количественный, валютный и аналитический учет. Проще говоря, здесь ты указываешь, какой счет с какими счетами может взаимодействовать и какие субсчета он имеет. Разобраться здесь тебе поможет только бухгалтер :).


Спецвыпуск Xakep, номер #017, стр. 017-060-2, БУХГАЛТЕРИЯ ПРОГРАММИСТУ ПО КОЛЕНО: КАК СТАТЬ 1С-КОДЕРОМ

БУХГАЛТЕРИЯ ПРОГРАММИСТУ ПО КОЛЕНО: КАК СТАТЬ 1С-КОДЕРОМ

Владимир (vlush@mail.ru)

Спецвыпуск Xakep, номер #017, стр. 017-060-2

Виды субконто. Предназначены для ведения аналитического учета. В качестве видов субконто могут выступать доступные в системе типы данных.

Отчеты. Позволяют получить отчетную информацию, используются для обобщения данных и получения итоговых результатов.

Обработки. Это алгоритмы обработки информации, реализующие выполнение различных действий над информацией.

СКОНФИГУРИМ И НАСТРОИМ

В «1С: Предприятие» используются четыре варианта запуска программы: «Предприятие», «Конфигуратор», «Отладчик» и «Монитор» (рисунок 1). В основном юзеры системы работают в режиме «Предприятие», программеры юзают конфигуратор и отладчик, режим «Монитор» используется для просмотра активных пользователей в базе данных.

Для начала надо добавить новую информационную базу данных (это делает пимпа «Добавить») и указать путь к новой базе. Далее «1С» запускается с вновь добавленной базой в режиме «конфигуратор». Первоначально конфигуратор будет выглядеть так, как показано на рисунке 2.

Объекты метаданных можно создавать, используя конструкторы, которые значительно экономят время. Список всевозможных конструкторов можно посмотреть на рисунке 3. Например, с помощью конструктора создан новый справочник «Контрагенты» и настроены его параметры (рисунок 4). Теперь можно запустить «1С» в режиме «Предприятие» прямо из конфигуратора. При этом сохраняем внесенные изменения. Теперь, если открыть меню «Операции/Справочники», ты увидишь справочник «Контрагенты». Теперь в форму уже можно вводить информацию о контрагентах (рисунок 5).

Программный код в справочнике может располагаться в «Форме элемента», «Форме группы» либо в «Форме списка». Язык программирования, на мой взгляд, напоминает объектно-ориентированный язык «Visual Basic». Каждая из таких форм содержит диалог, модуль и таблицы, но их может не быть. В диалоге настраиваются экранные формы, в которые юзверь будет вводить информацию. В модуле формы реализуются алгоритмы обработки информации управления диалогом (рисунок 6). В таблицах рисуются печатные формы, которые, в целом, похожи на табличный процессор «Excel».

Как ты видишь, весь код располагается в процедурах либо в функциях. В процессе разработки какого-либо алгоритма достаточно удобно использовать синтаксис-помощник, который помогает сориентироваться в большом количестве встроенных методов, функций и процедур во встроенном языке «1С». На рисунке 7 показан иерархический список справки по встроенному языку. Также в синтаксис-помощнике можно настроить шаблоны и конструкторы, которые тоже облегчают жизнь.

То есть освоить «1С: Предприятие» несложно, и, изучив возможности системы, даже без знания бухучета и экономики ты легко можешь нарыть работу и начать зарабатывать бабло, и впитывать ценный опыт.

КАК НАЧАТЬ

На данный момент 1С-программистов, прошедших аттестацию в фирме «1С», насчитывается 1731 человек только в Москве. И это количество все увеличивается. Многие люди осваивали эту профессию по-разному. Кто-то закончил курсы, а я принял участие в олимпиаде в своем вузе. Дело в том, что в Финансовой академии при Правительстве РФ ежегодно проводятся международные олимпиады по программированию среди экономических вузов. Принять участие в олимпиаде можешь и ты. Надо только просканировать инфу на сайте «1С» www.1c.ru и послать заявку по адресу ait@fa.ru. Я участвовал в олимпиаде три раза, и это помогло мне неплохо разобраться во внутреннем языке программы. На третий год мне удалось выиграть путевку в Париж от фирмы «1С», а также получить хорошую работу.


Спецвыпуск Xakep, номер #017, стр. 017-060-3, БУХГАЛТЕРИЯ ПРОГРАММИСТУ ПО КОЛЕНО: КАК СТАТЬ 1С-КОДЕРОМ

БУХГАЛТЕРИЯ ПРОГРАММИСТУ ПО КОЛЕНО: КАК СТАТЬ 1С-КОДЕРОМ

Владимир (vlush@mail.ru)

Спецвыпуск Xakep, номер #017, стр. 017-060-3

Если ты уже сейчас решил взяться за подготовку к контесту, то могу посоветовать тебе литературку: 1С:Предприятие Версия 7.7 «Конфигурирование и администрирование» в 2-х частях, Фирма «1С», Москва.

Итак, мэн, все зависит только от тебя. Любишь кодить - люби и кодь! Да еще и деньжат можешь срубить. Постепенно будет расти твой опыт, и, возможно, ты сможешь продвинуться по службе и стать реал кодером. Главное - начать. Удачи, программер!


Спецвыпуск Xakep, номер #017, стр. 017-062-1,

РАБОТАЙ В "3DS MAX"

Спецвыпуск Xakep, номер #017, стр. 017-062-1

Alex Duncan McKriak (impulse7@rambler.ru)

"3DS", наряду с "Maya" и "Lightwave", является самой продвинутой и широко применяемой системой трехмерного моделирования.

В комплекте с "3DS MAX" обычно поставляется куча всякой вкуснятины, типа плагина "Illustrate". Вспомни заставки всеми нами обожаемого "MTV" - это его работа.

Итак, тебе нравится 3D. Ты сам хочешь создавать сложные трехмерные модели, тебя завораживают красивые пространственные эффекты и так далее. А можно ли заработать на своем хобби? Давай разбираться.

3DS ДЛЯ РАБОТЫ

Наиболее типичные задачи в "3DS MAX" для фирмы - товарные знаки, эмблемы и прочая символика. В принципе создание подобной фигни - дело нескольких минут (в умелых руках).

"3D Studio Max" - программа построения и моделирования трехмерных объектов в двухмерной плоскости твоего монитора. Она позволяет создавать и анимировать различные объекты и строить на их основе различные виртуальные сцены. "3DS", наряду с "Maya" и "Lightwave", является самой продвинутой и широко применяемой системой трехмерного моделирования. Ее возможности ты можешь оценить, посмотрев многие сериалы американского производства, которые крутят по телевизору.

Так как применять "3DS" для наших нужд, то есть что от тебя хотят заказчики?

ТИПИЧНЫЕ ЗАДАЧИ

Обычно от тебя будет требоваться создать логотип или какую-либо статичную иллюстрацию для рекламы. Анимацией тебе вряд ли придется заниматься по причине ее большой трудоемкости и сложности. Помимо создания объектов, их придется "оживлять", что, могу сказать по своему опыту, требует времени раз в десять больше, чем процесс созидания объектов. Поскольку мы собрались в "3D Studio" работать, рассмотрим эти два основных вида задач: логотипы и иллюстрации.

ОБЕСПЕЧЕНИЕ

Для начала нам понадобится собственно сам "3DS MAX". В комплекте с "3DS MAX" обычно поставляется куча всякой вкуснятины, типа плагина "Illustrate" (вспомни заставки всеми нами обожаемого "MTV" - это его работа) или "Character Studio". На таком диске ты найдешь все, что даже теоретически может тебе понадобиться. Будем считать, что диск у тебя есть. Все, что мы дальше будем рассматривать, относится к четвертой версии "3DS MAX", но в принципе подойдет почти для любой другой ее модификации.

НЕМНОГО О ПОНЯТИЯХ

Когда запустишь "3D Studio", ты обнаружишь несколько окон с координатной сеткой. Это рабочие поля, то есть различные виды на виртуальное пространство, в котором будут создаваться все объекты. Сбоку находится панель инструментов с некоторым количеством закладок.

Все, что создается на рабочем поле, является 3D-объектом и может быть либо объемной фигурой, либо линией, созданной по точкам или формулам (spline'ы и NURBS'ы), либо вспомогательным объектом (источником света, камерой, пустышкой). Нам понадобятся объекты со вкладок "Create/Geometry" и "Create/Shapes". Поскольку мы будем заниматься созданием всяких надписей и непонятных предметов aka логотипов, то именно эти объекты интересуют нас больше всего. Здесь находятся кнопки, отвечающие за создание кубов, сфер и цилиндров ("Geometry"), линий и текста ("Shapes").


Спецвыпуск Xakep, номер #017, стр. 017-062-2,

РАБОТАЙ В "3DS MAX"

Спецвыпуск Xakep, номер #017, стр. 017-062-2

Сразу объясню принцип создания любого нестандартного объекта в "3D Studio". Он состоит в том, чтобы, используя различные методы, изменять стандартные фигуры, превращая их в то, что нам нужно. Например, для создания какой-нибудь цельной формы чаще всего используется преобразование сферы путем корректировки расположения точек, из которых она состоит.

И еще пару слов о менюшках. Из всего того, что мы видим на линеечке сверху, для нас представляет интерес всего два пункта: "File" и "Rendering". В "Rendering" нас, очевидно, интересует вкладка "Render", которая нужна для того, чтобы визуализировать твою "картину" и добавить при необходимости всяких вкусностей, типа того же "Illustrate", или выбрать, что и с какой позиции рендерить.

ИЗУЧАЕМ НА ПРИМЕРАХ

Для того чтобы понять, как работает "3D Studio", попытаемся создать логотип и какую-нибудь картинку на его основе (предположим, на календарь).

Начнем с логотипа конторы. Пусть это будет надпись "Impulse7 Ltd.", написанная каким-нибудь красивым шрифтом. Предположим, что сам логотип у нас уже есть, нарисованный на бумаге или в виде .bmp. Следующим шагом будет загрузка этого логотипа в "3D Studio". Выбирай на линейке "Views/Viewport Background", вводи путь к картинке и устанавливай флажки "Lock Zoom/Pan", "Match bitmap" и "Display background", предварительно установив "Viewport: Front", и жми "Ok" (рисунок 1).

В правом нижнем углу есть группа иконок (рисунок 2). Эти кнопки - едва ли не основной наш инструмент при создании любой сцены, так как отвечают за приближение/удаление, изменение точки зрения на сцену, передвижение плана и выбор плана основным (при нажатии на эту кнопку прочие виды убираются, а этот разрастается до размеров всего экрана). Жми на кнопку "основной план", предварительно выбрав "Front" план.

Прежде всего надо понять, как сделан логотип. Он может быть составлен из стандартных шрифтов, как в примере, или представлять собой полет фантазии художника. Если второе, то придется повозиться.

Теперь, когда картинка у тебя перед глазами, просто повторяй ее элементами "3DS MAX". Если это - стандартный текст, то выбирай "Create/Shapes/Text" и выделяй место под надпись. Размеры и шрифт надписи надо установить так, чтобы твой вариант совпадал с оригиналом как можно больше. Если же в качестве логи у тебя есть витиеватый набор линий, то выбирай "Create/Shapes/Line" и расставляй точки так, чтобы они как можно точнее соответствовали линиям на картинке, но особо не напрягайся, поскольку все недоработки можно будет исправить потом в закладке "Modify", выбрав в качестве "subobject" "vertex".

Итак, ты обвел все линии, и все они замкнуты. Теперь в меню "Modify" есть пункт "Attach". Жми на кнопку и по очереди указывай все замкнутые контуры, которые у тебя получились. Если же удалось отделаться подгонкой текста по размеру, но получилось несколько кусков, которые в принципе есть одно целое, выбери "Modify/Edit Spline/Attach" и тыкай на тех объектах, которые нужно присоединить. Теперь у нас есть объекты, которые представляют собой логотип, и с ним нужно что-то сделать. Тогда, например, попробуем сотворить нечто, похожее на эффект объемного текста в "Word'е", то есть сделаем так, как будто наши буквы выдавлены из какой-то формочки. В "3D Studio" это действие называется "лофтинг"(lofting) и заключается в том, что компьютер продолжает плоскую фигуру вдоль оси, перпендикулярной плоскости фигуры. Для этого сначала сделай линию примерно в шесть раз короче высоты наших букв, выбери тот объект, который нужно будет обработать, и топай в пункт "Create/Geometry/Compound Objects/Loft". В вывалившейся менюшке нужно кликнуть пункт "Get Path" и выбрать ту самую линию, которую ты только что сделал (рисунок 3). Получилось? То, что ты сейчас видишь, - всего лишь болванка, и в дальнейшем ее форму можно будет менять по вкусу.


Спецвыпуск Xakep, номер #017, стр. 017-062-3,

РАБОТАЙ В "3DS MAX"

Спецвыпуск Xakep, номер #017, стр. 017-062-3

Все хорошо, но смотрится как-то рублено и убого. Исправим! Для этого снова идем в закладку "Modify" и в свитках модификатора "Loft" находим пункт "Deformations Scale". То, что появилось на экране, является видом твоего объекта сверху. Контролируя форму этой кривой, ты управляешь формой объекта по оси наращивания. Здесь необходимо будет поставить две точки - почти в начало и почти в конец кривой (рисунок 4). Сами точки ставятся после нажатия кнопки "Insert Corner Point" и бывают трех типов: "Corner", "Bezier Smooth", "Bezier Corner". В точках "Corner" происходит излом, "Bezier Smooth" - точки, в которых происходит сглаживание кривой по управляемой касательной, "Bezier Corner" - почти то же самое, но вместо одной касательной здесь есть два луча, исходящие из нашей точки. Нам сейчас понадобится "Bezier Smooth", так как хотелось бы, чтобы в логотипе были гладкие линии. Для этого тыкай правой кнопкой по точке и выбирай из списка нужный тип. Поменяй параметры точки в соответствии со своим замыслом путем изменения положения самой точки и точек, привязанных к ней (рисунок 5).

Теперь для объемного текста можно сделать рамку. Сначала выбери пункт "Edit/Clone", продублируй объект и продолжай работу с клоном. Если все делалось стандартным набором шрифтов, то нужно вернутся ко вкладке "Modify", выбрать в качестве субобъекта точки ("vertex") и, выделяя их поочередно для каждой буквы, нажимать "Deattach". То же самое необходимо проделать для линий. После того как все буквы будут разделены, их нужно увеличить инструментом "Scale", находящимся на основной панели инструментов сверху (рисунок 6). После этого снова выбирай "Attach" и соединяй все буквы воедино так, чтобы каждая увеличенная буква стояла прямо перед маленьким аналогом. После повтори операции с "лофтингом" для каждой из частей (новой и старой) логотипа. Затем меньшую часть выдвинь чуть вперед. О!

Но не хватает заднего фона. Изначально задний фон отсутствует, и все рендерится на фоне черного экрана. Поместим туда какую-нибудь картинку или цвет. Это делается через "View/Viewport Background", где после ввода пути картинке выставь переключатель "Match rendering output".

Получилось недурно, но можно внести улучшения, добавив в сцену освещение и камеры. Освещение здесь бывает трех типов: "Omni", "Target Spot" и "Free Spot". "Omni" - это глобальный источник освещения, он светит во все стороны и не имеет определенного направления. "Target" и "Free Spot" - это как прожекторы, только один имеет точку, в которую нацелен, а другой - нет. Для наших целей лучше всего подойдет "Omni", так как он дает наиболее ровное освещение. Создай его, выбрав "Create/Lights/Omni". Дальше расположи появившийся ромб перед и чуть выше надписи, так, чтобы он освещал всю сцену. Теперь можно поиграть с его цветом и параметрами. Получаются крайне занимательные эффекты. И, для создания атмосферы, вставь камеру ("Create/Cameras Free Camera"), которой ты будешь снимать финальный результат, и направь ее на логотип. Теперь нажми правой кнопкой на названии плана "Perspective" и в вывалившейся менюшке измени вид на "Camera01". Далее экспериментируй, изменяя параметры камеры, ее перспективу, фокус, линзы, и не забудь при финальном рендеринге изменить "view" на "camera01".


Спецвыпуск Xakep, номер #017, стр. 017-062-4,

РАБОТАЙ В "3DS MAX"

Спецвыпуск Xakep, номер #017, стр. 017-062-4

Итак, теперь ты можешь намутить почти любой логотип и привести его в товарный вид. Этого достаточно, чтобы начать работу, в ходе которой у тебя есть возможность изучить программу более детально и заняться более серьезным 3D. Удачи!


Спецвыпуск Xakep, номер #017, стр. 017-064-1, QuarkXPress

QuarkXPress

Леонид Седов

Спецвыпуск Xakep, номер #017, стр. 017-064-1

ВСТУПЛЕНИЕ

Ты купил «СПЕЦ», значит, ты держишь в руках продукт, сделанный в «Quark'е». Большинство изданий на журнальных развалах - продукты, так сказать, той же фирмы. Почему «Кварк» так популярен? Есть ли альтернатива?

Warning!

Никогда и ни под каким видом не покупай русскую или Pan-Europe версии «Кварка». При покупке убедись, что тебе дают именно US-English версию. Используй только ее! Никогда не инсталь «Кварк» на русскую версию «Win» - проблем не оберешься. «Кварк» надежно и устойчиво работает только под версией US-English. Старайся купить диск, на котором залиты «Кварк» и его утилиты. Не рекомендую покупать подборки типа «Настольное издательство» и прочую сборную пургу. Можно получить бета-версию или trial-версию программы. Кстати, сейчас пятую версию могут всучить именно в этом виде.

Использование дополнительных функций в «Кварке», так называемых «Extentions», чревато тем, что сделанное тобой в муках творчества будет открываться только на твоей тачке, у всех остальных при загрузке твоей верстки появится грозное сообщение о невозможности работы с этим файлом. «Extensions» можно скачать с сайта www.quark.com, а также с других серваков, посвященных графике и издательству или с варезных серваков. Будь осторожен - «Extentions» работают не под всеми версиями и зачастую представляют собой битые беты (был печальный опыт работы с опцией создания PDF-файлов из «Кварка», приведший к переинсталляции программы).

Импорт файлов «Кварка», сделанных под «Mac», проходит без труда, за исключением одной мелочи: все русские шрифты превращаются в полную галиматью. Если их немного и есть распечатка с оригинала, то можно перенабрать текст. В противном случае можешь грязно выругаться в адрес синегнойной парочки «Apple» & «Microsoft».

СЛОВАРЬ ТЕРМИНОВ

Верстка - размещение текста и графики на определенном формате.

Полоса - формат, на котором ты будешь работать. Может быть любого размера.

Гарнитура - тип шрифта.

Колонка - часть текста.

Кегль - размер шрифта.

Залить текст - поместить текст в графический блок.

Интерлиньяж - расстояние между строками.

Пункт - единица измерения в полиграфии (pt). Американский равен 0.356 миллиметра.

«КВАРК» И Ко

Существует, по крайней мере, четыре программы, с помощью которых можно верстать. Это «QuarkXPress», «Adobe PageMaker» (он же «InDesign»), «Corel Ventura Publisher» и «MS Word». Давай кратко обсмотрим их и выясним особенности каждой перед разделкой самого «Кварка».

«Adobe PageMaker» («InDesign»). Хорош для верстки книг и газет. Много функций, аналогичных «Кварку». Есть текстовой редактор и даже фильтры «PhotoShop». Для верстки журналов не очень удобен.

«Corel Ventura Publisher». Можно использовать как для верстки журналов, так и книг. Достаточно заморочен и так же глючит, как и папа - «CorelDraw». Делают на нем по старинке некоторые отраслевые журналы и брошюры. Платят за это маловато.

«MS Word». Хорош для изготовления научных статей для международных конференций, так как есть формульный редактор, система гиперссылок и прочая пурга, а также неплохая графическая библиотека. Делать на нем серийные издания - муки адовы. Пробовал!


Спецвыпуск Xakep, номер #017, стр. 017-064-2, QuarkXPress

QuarkXPress

Леонид Седов

Спецвыпуск Xakep, номер #017, стр. 017-064-2

«КВАРК» AS IS

Первоначально «Кварк» был сделан под «Mac». На нем он работает «устойчиво и надежно» :). Затем появились версии под РС. Отличаются той же «надежностью» и «устойчивостью»... Впрочем, программа занимает на диске мало места (22 метра), быстро загружается и достаточно стабильно работает. Сейчас на рынке можно приобрести сразу три версии программы: третью, четвертую и пятую.

Совет. Для обучения лучше приобрести четвертую версию. Сейчас она самая популярная. Кстати, не забудь купить книжку по «Кварку». Лучше всего - перевод фирменного мануала. Наличие этой книги у профессионала - обязательно.

УСТАНОВКА НА ДИСК И НАСТРОЙКА

Инсталляция простая, но есть особенности. Прежде чем начать:

- установи в «Винде» национальную настройку US English;

- проинсталлируй «Кварк»;

- проверь его работоспособность (грузится оно вообще или нет);

- верни первоначальные национальные настройки (например, Estonian :)).

Вот и встали.

Если ты уверен, что все срослось при установке и «Кварк» открывается без скрипа, то ползи в меню «Edit/Preferences/Document». В папке «General» установи следующее:

Horizontal Measurements - Millimeters

Vertical Measurements - Millimeters

Greek Below - 2 pt.

Остальное можно не трогать. Дави «OK». Теперь переходи в папку «Edit/Preferences/Application». В папке «Display» можно установить цветность картинок, число градиентов серого цвета в черно-белых картинках, а также отображения картинки на экране. Но лучше оставь все как есть. Увеличение качества приведет к замедлению работы программы! Это вполне нормально, что в «Кварке» вся графика выглядит саксово, - на печати все будет ОК.

МЕНЮ

Обычно в «Кварке» открывают несколько основных форточек (View/нижняя треть опций). В скобках я буду приводить горячие ключи, которые открывают/закрывают меню:

Warning еще раз!

Горячие ключи работают в английском регистре! Если перейти в русский, то они могут не сработать, обратный переход в английский не исправит положения. Если лопухнулся, сохраняйся и грузи файл снова. Может, и заработают. Это один из гадких глюков «Кварка».

1 - «Tools» - инструменты (F8);

2 - «Measurements» - размеры (F9);

3 - «Document Layout» - расположение листов публикации (F4);

4 - «Color» - цвета (F12);

5 - «Style Sheets» - список стилей (F11).

Теперь разберемся с ними по порядку.

«TOOLS»

Смотри рисунок 1.

1 - перемещение любых объектов (текстовых и графических);

2 - работа с текстом и объектами;

3 - поворот объекта;

4 - увеличение/уменьшение;

5 - текстовой блок;

6, 7, 8 - графические блоки;

9 - рисовалка;

10 - наклонные линии;

11 - вертикальные, горизонтальные линии;

12 - расположение текста по прямым, наклонным и кривым линиям;

13 - связь текстовых объектов;

14 - удаление связи текстовых объектов.

«MEASUREMENTS»

Сеттингзы для текста (рисунок 2):

1 - расположение блоков относительно листа;

2 - размер блока;

3 - угол поворота блока;

4 - число колонок в блоке;

5 - зеркальное расположение содержимого в блоке по вертикали и горизонтали;

6 - расстояние между строками и буквами;


Спецвыпуск Xakep, номер #017, стр. 017-064-3, QuarkXPress

QuarkXPress

Леонид Седов

Спецвыпуск Xakep, номер #017, стр. 017-064-3

7 - выравнивание текста (влево, вправо, по центру, по колонке);

8 - тип (гарнитура) шрифта и размер (кегль);

9 - начертания шрифта;

Сеттингзы для графики (рисунок 3):

1 - расположение на листе;

2 - размер;

3 - угол поворота;

4 - скругление углов;

5 - вертикальное и горизонтальное изображение;

6 - пропорции блока;

7 - увеличение/уменьшение размеров;

8 - угол поворота изображения внутри блока;

9 - сдвиг изображения.

«DOCUMENT LAYOUT»

Смотри рисунок 4.

1 - тип полосы;

2 - уничтожение полосы;

3 - список шаблонов;

4 - расположение полос в публикации.

«COLOR»

Цени рисунок 5.

1 - цвет окантовки;

2 - цвет элемента графики или текста;

3 - цвет блока;

4 - насыщенность цвета;

5 - тип заливки блока;

6 - список цветов.

«STYLE SHEETS»

Разглядывай рисунок 6.

1 - список стилей на параграф;

2 - список тилей на букву.

Также верху и слева в рабочей области расположены линейки. Метки на них покажут точное расположение на листе курсора. В левом верхнем углу, на пересечении линеек, есть перекрестье - это начало координат. Оно, по умолчанию, находится в левом верхнем углу рабочего поля. Мышью начало координат можно переместить в любое место.

В левом нижнем углу окна находятся форточка размера (в процентах) изображения и номер текущей страницы, где находится курсор. Изменять размер можно, набрав нужную цифру процента (иногда не срабатывает!).

НАЧАЛО РАБОТЫ

РАЗМЕР И НАСТРОЙКИ ЛИСТА

Прежде чем начать работу, определись, какого размера будет лист. Для простоты выбери размер А4 (210 х 297 мм). Это стандартный размер листа для большинства принтеров (кстати, это еще и формат «СПЕЦА»). Выбирай размер (рисунок 7). Ползи в меню «File/New/Document», тыкай в «Size A4 Letter», «Orientation» ставь «Portrait». Если предполагается, что в документе будет несколько колонок, то определи их количество в «Column Guides», расстояние между колонками - в «Gutter Width». «Margin Guides» определяют рабочее поле на листе, в котором ты предполагаешь работать. Параметр «Facing Pages» предполагает, что у тебя будут как правые, так и левые полосы, то есть если развернуть журнал, слева будут левые полосы, а справа, соответственно, правые полосы. Все установки будут видны на листе в виде фиксированных линий. Если ты не хочешь, чтобы они маячили перед глазами, то поставь в «Margin Guides» нули.

Передвижение по рабочему столу осуществляется так: зажми [Alt] и выбери любой из первых двух инструментов («крест» или «лапу»). Дальше активно двигай мышью и окажешься в нужном месте ;).

БЛОЧНЫЙ ПРИНЦИП РАБОТЫ «КВАРКА»

Простота и удобство работы в «Кварке» заключаются именно в этом принципе. Имеется три типа элементов: текстовые и графические блоки, а также отдельные элементы оформления (линии). Каждый из блоков может содержать только текст или только графику. Содержание конкретного блока можно изменить через меню «Item/content». Блоки также могут взаимодействовать между собой. Например, при обтекании текста вокруг картинки блоки могут накладываться друг на друга.

ТЕКСТОВОЙ БЛОК

Текстовый блок создается инструментом «Текстовой блок» (рисунок 8). Логично? Форму можно определить, зажав мышь на ее иконке. Проявятся варианты формы.


Спецвыпуск Xakep, номер #017, стр. 017-064-4, QuarkXPress

QuarkXPress

Леонид Седов

Спецвыпуск Xakep, номер #017, стр. 017-064-4

С текстом работают инструментом «Лапа», поместив курсор внутрь блока. Залить готовый текст можно простым перемещением текстового файла из окна в блок.

В «Кварке» есть различные текстовые фильтры. Они корректно работают только с английскими текстами. Для русских лучше использовать файлы в формате «Text only» из «Word».

Параметры текста определяются из меню «Measurements». Полная аналогия с «MS Word». Элемент текста можно превратить в графику (выделить букву или строчку и заюзать меню «Style/Text to box»). Появится копия текста, которую можно раскрасить градиентной заливкой или поместить в нее любое изображение. Эта копия легко редактируется по точкам через меню «Item/Edit/Shape». Точки можно передвигать или изменять кривизну линий, их соединяющих.

Текст можно также привязать к так называемой "базовой сетке" («Baseline Grid»). Для этого лезь в меню «Style/Format», далее активизируй «Lock to Baseline Grid». Шаг сетки обычно определяется в меню «File/Preferences/Document/Paragraph/Baseline Grid», где устанавливается начало сетки от верха страницы и шаг сетки, которому будет равно расстояние между строками. Эта операция выровняет весь текст по горизонтали, то есть все строки в многоколонном блоке будут находиться на одном уровне. Впрочем, этого можно и не делать, но тогда вид вашей публикации будет выглядеть непрофессионально.

Если есть потребность поместить внутрь текстового блока какой-либо элемент (например, иллюстрацию или другой текст), то нужно сделать так, чтобы основной текст «обтекал» этот элемент. Сам посуди, разве будет красиво смотреться ничем не занятая проплешина вокруг изогнутого арта? Эта фигня устраняется так: лезь в меню «Item/ModifyText» и активизируй «Run TextAround All Sides».

Текстовой блок можно залить любым цветом, а также применить разные типы заливок. Можно определить тип окантовки и ее цвет. К сожалению, сам текст можно только окрасить в сплошной цвет.

Внимание!

При работе со шрифтами лучше всего пользоваться проверенным набором шрифтов, иначе могут возникнуть различные проблемы при распечатке текста. Решаются они обычно использованием только лицензионных шрифтов.

ГРАФИКА В «КВАРКЕ»

Графический блок создается так же, как и текстовый, соответствующими инструментами, которых несколько. Это тулзы с шестой по девятую на рисунке 1.

Иллюстрацию можно поместить в блок аналогично тексту - из соответствующей папки простым перемещением.

Внимание!

Рекомендуемые графические форматы для графики: .tif, .jpg, .eps. При этом предпочтительнее юзать .tif, но наиболее экономичный формат - .jpg. Проблемы могут возникнуть с .eps при печати на принтер. Если у принтера нет опции PS, то файл может не распечататься или иллюстрация в формате .eps будет напечатана в очень низком разрешении.

При помещении иллюстрации в блок она, как правило, оказывается или меньше, или больше него. Чтобы загнать иллюстрацию точно в блок, можно проделать следующее:

1) Изменить размеры блока, потянув за углы или середины сторон.


Спецвыпуск Xakep, номер #017, стр. 017-064-5, QuarkXPress

QuarkXPress

Леонид Седов

Спецвыпуск Xakep, номер #017, стр. 017-064-5

2) Подрегулировать размеры самой иллюстрации, изменяя в меню «Measurements» ее пропорции, или заюзать горячую комбинацию [Сtrl + Alt + Shift + < или >], что гораздо быстрее. При этом размер картинки изменяется на 5%.

3) Если пропорции иллюстрации и блока одинаковые, то воткнуть иллюстрацию в блок еще легче: [Ctrl + Shift +F].

4) Выставить по центру блока без изменения пропорций - [Ctrl+Shift +M].

ВЗАИМОДЕЙСТВИЕ БЛОКОВ

У текстового и графического блоков есть важнейшее свойство - «обтекание» («Runaround»). Включая и выключая эту опцию, можно добиться различных эффектов. Опция эта определяется в меню «Item/Modify/Runaround», где задается наличие обтекания, а также его параметры.

РИСУЕМ В «КВАРКЕ»

Создавать изображения в кварке можно несколькими способами:

1) Использовать готовые графические формы.

2) Создавать из готовых форм новые через меню «Item/Merge», объединяя, вычитая одну фигуру из другой и так далее,

3) С помощью инструмента девять с рисунка 1. В частности, если поместить в графический блок иллюстрацию с изображением, у которого четкий контур, то можно с помощью «рисовалки» аккуратно обвести его, тем самым сделать новый блок, а затем залить туда то же изображение, что обводили. Получим новое изображение нужного объекта и нужной формы.

4) Создать новые виды линий с помощью редактора (меню «Edit/Dashes & Stripes»).

КАК УЧИТЬСЯ РАБОТЕ В «КВАРКЕ»?

Учеба состоит из трех этапов:

На первом этапе нужно начать самостоятельно осваивать программу, изучив эту статью и запасшись книгой по «Кварку».

Шаг 1. Попробуй сделать копию обычной книжной страницы. Сперва с одной колонкой, потом - с несколькими колонками, далее - с колонтитулом вверху и внизу, и наконец - с иллюстрацией.

Шаг 2. Замути копию газетной страницы, например, «Ведомостей».

Шаг 3. Сделай копию журнальной страницы, допустим, «Итогов» с одной статьей, потом - с несколькими статьями.

Шаг 4. Смонстрячь копию страницы «СпецХакера». Взять лучше не самую сложную. Она должна содержать: текст, иллюстрации, графические элементы оформления.

Все эти этапы необходимо повторять несколько раз и в разных вариантах. Если есть возможность распечатать сделанное, то сравни полученное с оригиналом. У тебя все получится... когда-нибудь :). К сожалению, с этим багажом знаний найти хорошее место затруднительно. Поэтому перейдем ко второму этапу.

ОБУЧЕНИЕ У ПРОФЕССИОНАЛОВ

Лучше всего это сделать на курсах. Только не кидайся на первые попавшиеся в объявлении дешевенькие курсы. Лучше подкопи деньжат (около 100$) и запишись на курсы МГТУ имени Баумана. Это можно сделать через Интернет (www.specialist.ru). Главное - знания и сертификат, который произведет на работодателя очень хорошее впечатление.

НАПОСЛЕДОК

Учиться работать в «Кварке» придется ВСЕГДА, если ты действительно решил сделать это своей работой. Конкуренты не стоят на месте и постоянно выдают новые идеи и фишечки, которые делают издание более привлекательным. Соответственно, и ты должен развиваться и выдавать на-гора нестандартные подходы и решения, тогда шеф за тебя будет обеими лапами держаться, а ты всегда найдешь несколько сотен кредитов в своем кармане. Дерзай!


Спецвыпуск Xakep, номер #017, стр. 017-068-1, PhotoShop

PhotoShop

Леонид Седов

Спецвыпуск Xakep, номер #017, стр. 017-068-1

ВВЕДЕНИЕ

Adobe PhotoShop - один из самых удачных программных продуктов на рынке. Универсальность, простота работы, практические идеальные алгоритмы обработки изображений сделали его самым популярным инструментом для работы с графикой. Подавляющая часть изданий в мире делается при помощи PhotoShop'а.

ПОКУПКА

На рынке предлагается большое количество вариантов PhotoShop. Следует приобретать диски только с PhotoShop и дополнительными утилитами к нему (Xenofex, Eye Candy, KPT, а также набор дополнительных фильтров). Установка дополнительных утилит значительно упростит и разнообразит работу.

ИНСТАЛЛЯЦИЯ

Инсталляция PhotoShop (далее - Шоп) происходит очень просто и не требует специальных настроек, кроме параметров настройки экрана. Шоп требует достаточно высокого экранного разрешения и чувствителен к графической карте (некоторые старые карты могут не поддерживать требуемые настройки, и Шоп не установится на машину!).

Для корректного отображения на экране цветов изображений лучше всего в настройках экрана использовать цвет True Color. К сожалению, это приводит к замедлению работы программы и обновления экрана, но зато ты сможешь увидеть картинку во всей красе.

НАСТРОЙКА

Перед началом работы необходимо настроить инструменты и параметры программы. В меню Edit/Preferences (в ранних версиях - File/Preferences) активизируем пункт General:

- В General можно оставить все без изменения;

- Saving Files - без изменения;

- Display & Cursors - оба Сursors делаем Precise;

- Transparency & Gamut - без изменения;

- Units & Rules - устанавливает сантиметры, остальное не меняем;

- Guides & Grid - можно оставить как есть;

- Plug-ins & Scratch Disks - очень важная настройка. Здесь мы определим, куда будет загружаться изображение. Если винт поделен на несколько частей, то не стоит использовать диск С: для загрузки изображения, а лучше назначить для этого диск D: или любой другой (в меню - Scratch Disk/First - вводим D: или любой другой). При такой настройке изображение будет загружаться сначала в оперативную память, затем на определенный нами Scratch Disk. Отсюда вывод - чтобы Шоп работал быстро и устойчиво, необходимо иметь как можно больше оперативки - минимум 128 MB. Как раз настройке оперативки и посвящена последняя вкладка - Memory & Image Cashe.

Memory & Image Cashe - здесь необходимо установить долю в оперативке, которую будет использовать Шоп для своей работы. В Physical Memory Usage можно посмотреть размер доступной памяти и процент ее использования. Оптимальное значение - 75%.

Все настройки сохранятся только в том случае, если перезагрузить Шоп. Затем они станут постоянными для всей последующей работы. Если захочется изменить - придется повторить все манипуляции.

ИНСТРУМЕНТЫ

1. Выделение (обводка)

2. Обводка

3. Резак

4. Штамп (копирование области изображения)

5. Ластик

6. Перо (рисуем контур кривыми Безье)

7. Лапка (передвижение по изображению)

8. Указатель

9. Волшебная палочка для выделения

10. Еще одни резак

11. Кисть

12. Градиентная заливка

13. Работа с текстом

14. Пипетка

15. Увеличительное стекло


Спецвыпуск Xakep, номер #017, стр. 017-068-2, PhotoShop

PhotoShop

Леонид Седов

Спецвыпуск Xakep, номер #017, стр. 017-068-2

Остальные инструменты достаточно специфичны и осваиваются по мере работы в Шопе.

ИЗОБРАЖЕНИЯ

Существует два основных типа представления графики - растровое и векторное.

Векторное - все элементы изображения представлены в виде кривых. Можно легко менять размеры любого элемента без потери качества.

Растровое - все изображение состоит из элементов - пикселов, каждый из которых обладает своими свойствами. Изменяя размер изображения, мы изменяем количество и параметры пикселов, что может привести к качественному изменению изображения, часто к ухудшению. Поэтому при работе с растровыми изображениями существует целый ряд ограничений и специальных приемов.

Warning! При загрузке векторного изображения в Шоп оно автоматически преобразуется в растровое. Обратный процесс невозможен!

ЦВЕТОВЫЕ СТАНДАРТЫ

Существует большое количество стандартов представления цвета, но самые распространенные - RGB и CMYK. Остальные используются ограниченным числом программ и служат для выполнения специальных функций.

RGB - экранное представления цвета. Каждый пиксел описывается с помощью комбинации трех цветов - Red (красный), Green (зеленый) и Blue (синий).

CMYK - стандарт для полиграфии и некоторых типов принтеров. Пиксел описывается комбинацией четырех цветов - Сyan (голубой), Magenta (малиновый), Yellow (желтый) и Key (черный).

В Интернете подавляющее число изображений сделаны в стандарте RGB, очень редко - в CMYK.

ТИПЫ ГРАФИЧЕСКИХ ФАЙЛОВ

Растровые изображения хранятся главным образом в следующих форматах - *.tif, *.jpg, *.bmp, *.gif. Векторные - *.cdr, *.ai, *.eps. Они отличаются способом записи и размерами. Самые распространенные - *.tif и *.jpg. Чаще всего именно они используются в большинстве программ и платформ.

Формат *.jpg очень удобен для пересылки и передачи изображения на другие машины, но при достаточно большой компрессии файла происходит необратимая (!) потеря качества изображения (при большом увеличении видно, что все изображение состоит из квадратов).

РАЗМЕРЫ ИЗОБРАЖЕНИЙ

У каждого изображения есть два параметра - линейные размеры и разрешение. Разрешение - число пикселов на единицу измерения (pixel on inch). Чем больше разрешение, тем лучше качество картинки.

ИЗМЕНЕНИЕ РАЗМЕРОВ

Всегда хочется иметь размер побольше ( :) - прим. ред.). Как этого достичь? Исходим из следующего - как мы хотим использовать изображение:

1. Для использования в Интернете. Достаточно разрешения 72 pixel/inch, поэтому картинка может быть достаточно большой по размеру.

2. Для печати на принтер. Для принтера с функцией фотопечати - разрешение как минимум 150 pixel/inch, но не следует делать и большое разрешение самого принтера - качества это не улучшит, да и файл получится огромным - будешь сидеть у экрана минут по десять над каждой операцией. Для обычного принтера целесообразно использовать разрешение 150-200 pixel/inch, так как дальнейшее увеличение разрешения мало скажется на качестве печати.

3. Для печати изображения на ткани, пластике и прочем. Прежде чем начать обработку изображения, уточни у изготовителей параметры изображения (цветовой стандарт - RGB или CMYK, разрешение и линейные размеры, тип файла). Выполни изображение в соответствии с требованиями.


Спецвыпуск Xakep, номер #017, стр. 017-068-3, PhotoShop

PhotoShop

Леонид Седов

Спецвыпуск Xakep, номер #017, стр. 017-068-3

Размеры изображения меняются через меню Item/Image Size.

В блоке Print Size меняются линейные размеры и разрешение, при этом можно менять размер пропорционально - Constrain Proportions - или непропорционально, отключив эту функцию.

ИЗМЕНЕНИЕ ТИПА ФАЙЛОВ

Чтобы перейти из одного цветового стандарта в другой, необходимо из меню Image/Mode выбрать нужный. Выбрать нужный тип файла можно из меню File/Save as.

Warning! Если предполагается, что файл в конечном виде должен быть в стандарте CMYK, то все этапы работы над ним должны проходить в стандарте RGB. Перевод в стандарт CMYK должен быть последней операцией перед сохранением или печатью файла (кстати, на всякий пожарный случай имей три копии файла: первая - исходный, вторая - файл поле обработки, третья - конечный вариант). Это связано с тем, что значительная часть опций Шопа работает только в стандарте RGB. Обратные переход - из CMYK в RGB - приведет к значительному искажению цвета.

ИСТОЧНИКИ ИЗОБРАЖЕНИЙ

Существует несколько основных источников получения исходных изображений:

1. Интернет. Подавляющая часть изображений сделана в стандарте RGB; разрешение - 72 pixels on inch; стандарт - JPG, BMP.

Применять можно ограниченно - размер лучше не увеличивать, обработка стандартная - немного подтянуть цвета и изменить контрастность и яркость.

2. Библиотеки на CD-дисках. Встречаются как простые наборы картинок из Интернета, так и профессиональные библиотеки с собственным софтом, на основе которых можно делать полноценные плакаты. Как правило, изображения не обработаны (есть грязь, нечеткие края). При обработке можно делать весь комплекс операций.

3. Сканированные изображения. Возможности ограничиваются лишь параметрами сканера (размер поля сканирования и его разрешение). Можно получить изображение любого стандарта и разрешения. Не стоит увлекаться слишком большим разрешением - большинство сканеров физически делает только половинное от объявленного разрешения, остальное - за счет пересчета, что приводит к искажению цвета и контраста.

4. Изображения из цифровых камер. Последние модели камер позволяют получить высококачественные изображения, которые вполне можно растянуть на размер 420х297 мм. Качество цветов зависит от условий съемки и заточенности рук.

СЕМЬ РАЗ ОТМЕРЬ - ОДИН ОТРЕЖЬ (ВЫРЕЗАЕМ НУЖНОЕ)

Для работы используем инструменты 2 или 3 и меню Layers.

Прямоугольник, круг

Используя инструмент, обводим нужную область (зажав левую кнопку мыши), зажав Shift - получим правильный круг или квадрат, в зависимости от инструмента.

Затем копируем изображение (Ctrl + C) и размещаем или в новом окне, предварительно открыв его (Ctrl + N), или оставляем в том же окне, но в новом слое (Ctrl + V). В меню Layers появится слой с новым изображением. Основное изображение располагается внизу и именуется Background. Его нельзя перемещать, но можно изменить, выделив все изображение (CTRL + A), скопировать его и поместить туда же (Ctrl + V). Изображение станет слоем.


Спецвыпуск Xakep, номер #017, стр. 017-068-4, PhotoShop

PhotoShop

Леонид Седов

Спецвыпуск Xakep, номер #017, стр. 017-068-4

Новое изображение можно подрезать инструментом 3, затем сделать background и сохранить.

Сложный контур

Обычно используется для обводки определенного элемента изображения для полследующего его использования. Допустим, необходимо вырезать одну из фигур на фото. Есть несколько способов:

1. Если фигура находится на фоне, резко отличающемся от цвета фигуры (черный, белый, цвет). Воспользуемся инструментом Magic Wand (9), поместим его на фон и выделим. Предварительно настроим инструмент: параметр Tolerance выставим 5-10 единиц. Затем с Shift выделим все остальные области, которые не выделились первоначально. Потом из меню Select/Inverse переведем выделение из фона на контур. Скопируем выделенное и поместим или в новое окно, или в то же окно, но в новый слой (создание слоя произойдет автоматически).

2. Требуемый элемент изображения находится на сложном фоне. Воспользуемся инструментом Lasso (2) линейное. Предварительно настроим его: если нужен четкий контур, то параметр Feather = 0; если нужно получить размытый контур (обычно, если требуется монтаж изображения в другое), то параметр Feather = 1-2. Аккуратно, зажав левую клавишу мыши, обводим требуемый контур. При сложном контуре, зажав Alt при нажатой кнопке мыши, можем вырезать из полученного контура участок, а при зажатом Shift - добавить. Этот способ дает хорошие результаты для изображения с большим разрешением, так как обводится контур комбинацией прямых линий. Если делать часто перегибы, то можно добиться достаточно четкой обводки на закругленных участках.

3. Обводка с помощью кривых Безье. Позволяет создать точный контур, особенно на закруглениях. Этот способ достаточно долог и сложен, так как после обводки необходимо корректировать практически весь контур. Используется инструмент обычное Перо (6) для получения контура, а затем инструмент Галочка для коррекции контура. Затем из меню Paths (рис. menu_paths.tif) переводим контур в выделение - Make Selection. Дальнейший порядок работы - как выше.

ПИШИ-ЧИТАЙ - РАБОТА С ТЕКСТОМ

Warning! Большинство русских шрифтов некорректно работает с Шопом. Если есть возможность набрать нужный текст латиницей, то лучше сделать это таким образом. Если русский шрифт работает корректно, то, используя инструмент (13), помещаем курсор в место на изображении и начинаем набирать текст. Не забудь настроить параметры текста (размер, тип шрифта, цвет). Текст появится в виде нового слоя в меню Layers. Войдя в меню Layers при активном текстовом слое, меняем его характеристики или используем встроенные эффекты (тень и так далее).

Гораздо больше эффектов содержится в программах фильтров под Шоп.

Я УГОЛОК СВОЙ УКРАШУ ЦВЕТАМИ - РАБОТАЕМ С ЦВЕТОМ

Черно-белые изображения

Чаше всего корректируются контрастность и яркость (меню Image/Adjust/Brightness/Contrast). Перемещая движки, добиваемся нужного эффекта (рис. contrast_0.tif и contrast_end.tif). Черно-белое изображение можно тонировать одним или четырьмя цветами. В меню Image/Adjust/Mode


Спецвыпуск Xakep, номер #017, стр. 017-068-5, PhotoShop

PhotoShop

Леонид Седов

Спецвыпуск Xakep, номер #017, стр. 017-068-5

выбираем тип Duatone. Задав вверху окна меню число цветов, задаем любые нужные нам цвета и смотрим, что получается. Когда получишь нужный эффект, не забудь перевести изображение в стандарт RGB или CMYK, иначе цветное изображение не напечатается.

Цветные изображения

Обработка фото

1. Самый простой и быстрый метод. Выбираем из меню Image/Adjust/Variations. Кликая на те или иные иконки фотки, получаем тот или иной эффект. Он отображается и тут же сравнивается с исходным изображением.

2. Разгонка цвета по черной или белой точкам. Находим на фото ту область, которую мы можем считать или чисто черной, или белой. Открываем меню Image/Adjust/Curves или Ctrl + M. В окне меню есть изображение трех пипеток: черной, серой и белой. Для черной точки берем черную пипетку и точно указываем ее концом на черную точку на фото. Цвета должны откорректироваться.

3. Цветовой баланс. Находим на фото область, которая должна быть заведомо серой (тень на белом фоне, тень на белой стене, корпус компьютера). Открываем меню Info. Затем входим в меню Image/Adjust/Corol Balance. Помещаем курсор в серую область на фото. Смотрим в меню Info

в левом верхнем углу цифровые параметры против букв R, G, B. Там могут быть любые цифры - от 1 до 255. Оптимально, если эти значения будут в районе 100. Затем определяем, какие из цифр больше, и в меню Color Balance убавляем или прибавляем соответственный цвет, пока цифры в меню Info не станут примерно равными (например, в балансе указано 120, 130, 125). В меню Color Balance прибавляем немного Red, убавляем немного Green и сморит на результат, пометив курсор в серую область (желательно, в ту же точку, что и в начале).

Заключение

Я привел лишь самые простые способы работы с изображениями в Шопе. Получение сложных композиций, рисование и другие навороты получатся у тебя лишь в том случае, если работа в программе будет доставлять удовольствие и если появится желание освоить основные ее функции. Научиться можно несколькими способами:

- купить фирменное руководство (желательно с цветными вклейками) и основательно его проработать;

- освоив основные функции Шопа, поступить на курсы (желательно профессиональные);

- найти человека, у которого есть время и желание обучить тебя работе в индивидуальном порядке.

Только пройдя эти стадии обучения, можно смело появиться на рынке труда с заявлением, что ты являешься специалистом по Шопу (не забудь, что свои слова нужно подтвердить, увы, бумажкой, которую можно получить только на курсах).

Успехов!


Спецвыпуск Xakep, номер #017, стр. 017-072-1, АДМИНИСТРИРОВАНИЕ WIN-СЕТЕЙ

АДМИНИСТРИРОВАНИЕ WIN-СЕТЕЙ

aDm

Спецвыпуск Xakep, номер #017, стр. 017-072-1

...но при грамотной настройке и прямых руках, растущих из правильного места, можно заставить работать сеть под Windows, причем очень даже неплохо.

Очень удобно, когда все файлы лежат в одном месте, и каждый знает, где искать, к примеру, исходные файлы программы, которую в настоящий момент пишет фирма.

Контроллер домена - в WinNT-сетях, пожалуй, самое главное - это компьютер, который контролирует практически все процессы в сети.

Сейчас платформа Windows активно развивается: внедряются новые технологии, пишутся новые программы и исправляются ошибки в старых. Это кажется перспективным, поскольку такая активность рано или поздно должна перерасти в умопомрачительное качество софта и просто нереальную устойчивость.

Можно купить маршрутизатор Cisco, настроить его как роутер и подключиться через ISDN, но часто в мелких конторах рулят обычный модем с dial-up'ом и программа-ргоху\firewall для контроля за соединениями.

Microsoft за более чем двадцать пять лет существования успели написать аж семь операционных систем.

...если эту схему реализовать при помощи табличек MS Excel, то манагеры сойдут с ума через неделю...

Любой современный бизнес - от консалтинговой фирмы до крупного интернет-холдинга - немыслим без компьютеров. Это и компьютеры сотрудников, и сервера различных мастей, и специфические устройства типа шлюзов. За всем этим хозяйством необходимо следить и поддерживать его в работоспособном состоянии. И вся эта работа ложится на плечи системного администратора. Во-первых, все нужно тщательно настраивать, потому что само по себе, естественно, ничего не работает. Во-вторых, рано или поздно, но проблемы обязательно возникают. От банальной «Я тут файл в ворде набивала, а он куда-то пропал» до серьезных проблем типа отражения хакерских атак.

Попробуем разобраться, что представляет собой работа системного администратора и какие задачи он решает. Администратор в обычном понимании это человек, который отвечает своей головой за нормальное функционирование компьютеров, компьютерной сети и сетевых устройств. Однако на практике кроме компьютеров приходится чинить ксероксы и факсы, заправлять тонером принтеры и подключать телефоны. Ремонт оргтехники обычно сводится к тому, что проблемный девайс просто отвозится в сервис-центр, где ему делают профилактику и потребный ремонт. Больше времени занимают настройка и поддержка серверов. Да это и интереснее. Хочу показать на примере, как это все происходит.

Пусть ты хочешь стать крутейшим админом. Каждый админ, поднимаясь по своей карьерной лестнице, проходит приблизительно следующие этапы развития:

1. Маленькая фирма торгового направления. Реальнее всего, что ты будешь выполнять еще и смежные функции. Очень рекомендуется на начальных этапах развития, особенно студентам, поскольку не требуется 100% времени находиться в офисе. Обычно маленьким фирмам для нормальной работы необходимы файл-сервер (это такой компьютер, к которому имеют тот или иной доступ все сотрудники фирмы и на котором хранятся общие файлы) и сервер баз данных (обычно SQL-сервер). Помимо этого требуется настроить доступ в Интернет (это чтобы прайсы конкурентов качать, наверное, :)) и всякие приблуды - типа электронной почты, антивирусов и всяких электронных словарей. Кстати, смежные функции могут заключаться, например, в работе с базами данных - написание базы данных и их администрирование (точнее динамическое исправление ошибок). Одним словом, знание SQL и какого-нибудь языка программирования не просто приветствуется, а практически обязательно для админа такого уровня. Впрочем, на любом уровне, работая админом, полезно будет уметь писать программы и разные скрипты, но об этом позже.


Спецвыпуск Xakep, номер #017, стр. 017-072-2, АДМИНИСТРИРОВАНИЕ WIN-СЕТЕЙ

АДМИНИСТРИРОВАНИЕ WIN-СЕТЕЙ

aDm

Спецвыпуск Xakep, номер #017, стр. 017-072-2

2. Средняя фирма произвольного профиля. Обычно уже все серьезнее и круче. Тут уже не обойдешься появлениями раз в неделю - тут нужно пахать. Обычно с расширением фирмы растет нагрузка на сервера, которые постепенно превращаются в узкоспециализированных монстров с невероятной производительностью и гигантскими объемами винчестеров. Появляется необходимость защиты серверов от сбоев (что обычно проявляется в появлении источников бесперебойного питания и системы резервного копирования). В связи с этим в работе появляется некоторая рутина - нужно каждый день следить за процедурой резервного копирования критичных файлов.

Вырастает мощность почтовых служб: если в маленькой фирме можно обойтись почтовым адресом где-нибудь на фриварном сервере или у провайдера, то уже в фирме средних размеров (и выше) придется ставить и настраивать свой почтовый сервер. Аналогично могут возникнуть требования проинсталлировать и настроить web-сервер.

3. Крупная фирма или банк. В подобных конторах все еще более круто, технологично и секъюрно. Как правило, в таких организациях, помимо системного администратора, есть еще штат сотрудников IT, которые специализированы на какой-то одной функции и делают ее очень хорошо (должны, во всяком случае :-/). А администратор этим всем руководит и активно во всем участвует, направляет и корректирует, следит за безопасностью и надежностью.

Итак, более-менее с обязанностями администратора мы разобрались. Теперь о том, что необходимо знать. Фактически сейчас весь мир делится на тех, кто работает под операционными системами фирмы Microsoft и всех остальных. Про «остальных» поговорим в другой раз, а сейчас обсудим особенности работы в сетях Windows.

Немного теории и истории: Microsoft за более чем двадцать пять лет существования успели написать аж семь операционных систем, которые вроде бы друг с другом уживаются нормально, но все равно отличия есть, иногда даже очень существенные. В любом случае, сервер под управлением Windows 9x - это нонсенс и парадокс в одном флаконе. А заодно еще и море геморроя. Поэтому сервера разумно ставить под Windows NT (старая испытанная ось) либо под более современную Windows 2000 (Server или Advanced server). Не вдаваясь в детали, можно сказать, что в целом лучше ставить Windows 2000. И удобнее для работы, и всяких возможностей больше, что увеличивает гибкости системы. Соответственно, почтовым сервером у нас будет Exchange 2000, сервером баз данных - MS SQL Server 2000 и так далее.


Спецвыпуск Xakep, номер #017, стр. 017-072-3, АДМИНИСТРИРОВАНИЕ WIN-СЕТЕЙ

АДМИНИСТРИРОВАНИЕ WIN-СЕТЕЙ

aDm

Спецвыпуск Xakep, номер #017, стр. 017-072-3

ЭТАПЫ НАСТРОЙКИ

Первым делом при подъеме системы инсталлируется файл-сервер. Он же, как правило, Domain Controller (хотя бывают и исключения). Domain Controller (контроллер домена) - в WinNT-сетях, пожалуй, самое главное - это компьютер, который контролирует практически все процессы в сети. Домен (domain) - это, вообще говоря, просто список ресурсов с определенными правами доступа. Например, в этот список может входить компьютер, на котором можно работать определенному пользователю (группе пользователей). Для хранения этого списка (и сопутствующей информации) и нужен контроллер домена. Удобство такого подхода очевидно: все настройки безопасности и аудита хранятся в одном месте, и редактировать их очень удобно и приятно. Опять же, имея домен (и компьютеры сети в этом домене), можно специальными утилитами управлять компьютерами (вплоть до принудительной перезагрузки), учетными записями пользователей и прочей служебной информацией. Понятно, что этот объект очень важен, и при настройке ему нужно уделять массу внимания. Хорошей помощью будет какая-нибудь книга - типа «Windows NT\2000 для администраторов» - или что-то в этом роде. Таких книг полно в любом книжном магазине. И еще один момент: железо для этого сервера должно быть самым лучшим, какое только есть в продаже, иначе потом проблем не оберешься. Ведь если нет контроллера домена (или дублирующего контроллера домена) - нет и возможности пользователю войти в систему (авторизоваться).

В системах на базе Windows NT\2000 есть еще возможность устанавливать для разных объектов так называемые политики (policy). Это набор действий, которые разрешено или запрещено выполнять с определенными компьютерами домена. Говоря русским языком, например, можно запретить пользователям логиниться на некоторые компьютеры домена.

Настроив контроллер домена, стоит задуматься о предоставлении определенных ресурсов пользователям. Например, дисковое пространство под файлы. Очень удобно, когда все файлы лежат в одном месте, и каждый знает, где искать, к примеру, исходные файлы программы, которую в настоящий момент пишет фирма, в которой ты и работаешь. Этот процесс разбивается на этапы: вначале нужно определить, какие группы пользователей будут иметь доступ к папкам (директориям), затем выставить права доступа на эти директории в соответствии с концепцией доступа пользователей. Чтобы потом не получилось так, что секретарша случайно удалила результат четырехмесячной работы 150 программистов, как это было в одной очень известной российской компании.

Теперь у пользователя есть место, куда можно положить результаты своей работы. На всякий случай нужно учесть тот факт, что рано или поздно это дисковое пространство заполнится, и нужно будет наращивать мощности, добавляя диски.

Собственно, теперь можно добавлять пользователей в домен и давать им право делать в сети то, что им взбредет в голову в рамках разумного. Добавлять пользователей вообще-то удобно в пакетном режиме, особенно если их очень много. Например, используя такие команды:


Спецвыпуск Xakep, номер #017, стр. 017-072-4, АДМИНИСТРИРОВАНИЕ WIN-СЕТЕЙ

АДМИНИСТРИРОВАНИЕ WIN-СЕТЕЙ

aDm

Спецвыпуск Xakep, номер #017, стр. 017-072-4

NET USER boss1 password1 /ADD /MyDomain

NET GROUP megabosses boss1 /ADD

Ну, конечно, пароль, имя пользователя и название группы будут более реальными. Впрочем, вполне можно работать с пользователями из специальных программ (User Manager, Active Directory Users and Computers).

После настройки системы и начала нормальной работы чаще всего администратору приходится работать именно с пользователями: заводить новых, удалять старых, менять пароли и настройки, модифицировать права доступа. Для этого в Windows NT\2000 существуют удобные и простые средства, и обычно на этом этапе проблемы не возникают. Если же нужно одновременно поменять какие-то параметры пользователей, это можно делать либо в пакетном режиме (bat-файлы), либо с использованием скриптов на языке Visual Basic.

Следующая проблема, которая встает при настройке системы, это обеспечение сотрудников фирмы Интернетом. Конечно, можно купить маршрутизатор Cisco, настроить его как роутер и подключиться через ISDN, но часто в мелких конторах рулят обычный модем с dial-up'ом и программа-ргоху\firewall (типа WinGate или WinRoute) для контроля за соединениями. Конечно, при таких раскладах Интернет сильно не разгонишь (56К, не более), но все-таки доступ будет. Да еще и e-mail будет провайдерский, что, с одной стороны, хорошо, поскольку не надо ломать голову над настройкой почтового сервера, а с другой - плохо, поскольку все провайдерские недоработки будут касаться и настраиваемой системы. Например, отсутствие проверки почты на вирусы.

Кстати, о почте: рано или поздно возникает необходимость инсталлировать и настраивать (а затем и поддерживать) почтовый сервер. Под платформы Windows NT\2000 существует немереное количество разных почтовых серверов, и обозреть их всех нереально в данной статье. Для большего удобства лучше поставить, конечно же, MS Exchange - почтовый сервер от Microsoft. Эта программа хорошо встраивается в систему, и работать с ней легко и ненапряжно: используются готовые учетные записи пользователей из домена, удобная и простая программа для работы с почтовыми ящиками. В Windows 2000, благодаря службе Active Directory, можно еще сильнее интегрировать почтовый сервер с доменом: например, адрес электронной почты является свойством (атрибутом) и редактируется наравне с другими свойствами пользователя (например, программой Active Directory Users and Computers). Однако минусы тоже есть: даже с небольшим количеством пользователей дисковое пространство, отведенное под почтовые ящики, быстро начитает заканчиваться. Но если отвести примерно 10-20 Гигабайт, то для 100-200 почтовых ящиков должно хватить. Кроме этого, замечены минусы: тяжело (но можно!) настроить фильтрацию почты по содержанию (например, чтобы матерная ругань не ходила внутрь сети), нет возможности делать резервные копии почтовых ящиков по отдельности (можно только все ящики сразу).

Почти всегда в системе существует сервер баз данных. Обычно в Windows NT\2000 сетях выбирают в качестве этого элемента MS SQL Server. Эту программу имеет смысл ставить, когда нужно иметь высокоскоростной доступ к данным, причем многим пользователям сразу. Пусть, например, у фирмы есть какой-то список, например, наличие на складе того или иного товара, и несколько манагеров одновременно что-то в этом списке меняют. Если эту схему реализовать при помощи табличек MS Excel, то эти манагеры сойдут с ума через неделю. А с базой данных на SQL-сервере все получится надежнее, проще и понятнее. И, в целом, вполне достойно. Правда, для нормальной реализации потребуется некоторое время, но, с другой стороны, никто халяву и не обещал.


Спецвыпуск Xakep, номер #017, стр. 017-072-5, АДМИНИСТРИРОВАНИЕ WIN-СЕТЕЙ

АДМИНИСТРИРОВАНИЕ WIN-СЕТЕЙ

aDm

Спецвыпуск Xakep, номер #017, стр. 017-072-5

Ладно, предположим, ты все настроил и все работает. Казалось бы, теперь можно расслабиться и погонять врагов в Кваку либо в UT. Ан, нет! Обязательно начнутся проблемы чисто механического характера: делать резервные копии, помогать пользователям осваивать новые программы и технологии, да и просто возиться со сломанным или глюкавым железом.

Отличительная особенность работы всех Windows-систем это чувствительность к железу - малейшая неисправность может привести к аварийной остановке и последующим проблемам. Нельзя сказать, что это смертельно, но иногда чрезвычайно неприятно.

ЗЛОКЛЮЧЕНИЕ

Конечно, немыслимо в короткой статье обсудить все тонкости системного администрирования вообще и администрирования win-сетей в частности. Более детально погрузиться в этот мир можно только занимаясь этим на практике. В Интернете есть масса сайтов, посвященных настройке разных Windows, например, http://winfaq.com.ru.

Наверное, каждый хоть раз в жизни слышал анекдоты про глюкавость и ненадежность Windows и других программ от Microsoft. Практика же показывает немного другое: весь этот софт, конечно, иногда ведет себя странно (другими словами, просто глючит), но при грамотной настройке и прямых руках, растущих из правильного места, можно заставить работать сеть под Windows, причем очень даже неплохо. Производительность получаемых решений находится на достаточно высоком уровне и не требует больших усилий. Конечно, если это не банковская сеть или не сеть для эксплуатации мощного кластера распределенных вычислений. Сейчас платформа Windows активно развивается: внедряются новые технологии, пишутся новые программы и исправляются ошибки в старых. Это кажется перспективным, поскольку такая активность рано или поздно должна перерасти в умопомрачительное качество софта и просто нереальную устойчивость. Что ж, подождем - время покажет.


Спецвыпуск Xakep, номер #017, стр. 017-076-1, ОБЗОР КНИГ

ОБЗОР КНИГ

Urix (spora_2k@mail.ru)

Спецвыпуск Xakep, номер #017, стр. 017-076-1

Чем больше книжка, тем меньше у тебя шансов дочитать ее до конца.

Авторы книжек очень любят включать в содержание темы, о которых никак нельзя догадаться по названию.

Справочная информация - полезная штука. Если она не занимает больше половины книжки, которая справочником не является.

Книги для обзора предоставлены торговым домом "Библио-Глобус".

Рассел Ч., Кроуфорд Ш. Microsoft Windows 2000 Server. Справочник администратора. - М.: ЭКОМ, 2001. - 1296 с.

Весьма обширное издание о том, как подружиться с Самой Любимой Операционной Системой. Поскольку это справочник, сюда включены в основном базовые понятия по работе с системой, вроде словарей терминов и принципов функционирования. Например, расписаны типы IP-сетей и управление группами и пользователями. Или как отредактировать boot.ini здесь написано, а вот что делать, когда при установке система выдает "Hardware Malfunction" или "Inaccessible Boot Device" - нет. Хотя и даны некоторые общие советы. Так что, как ни странно, эта огромная куча бумаги больше подойдет для периода знакомства, чем для тесного общения.

Кстати, в качестве одной из причин объемистости можно отметить рекордное количество окошек, их печатать явно не стеснялись. Зачем нужно описывать окна "Первое окно мастера - нажмите Next", я понять не могу. Людям, которые не знают, что такое Next и Cancel, нужно учиться азам компьютерной грамотности. Им не стоит доверять создание разделов RAID.

Михеева В.Д., Харитонова И.А. Microsoft Access 2002: наиболее полное руководство. - СПб.: БХВ-Петербург, 2002. - 1040 с.

Еще один талмуд, предназначенный для всех и каждого. Подразумевается, что он будет полезен как новичкам, так и опытным программистам - разработчикам приложений, а также администраторам БД. Трудно сказать, что из этого получилось - на мой взгляд, это не очень хорошая идея. По крайней мере, разобраться в том, что хотели донести авторы, тяжело. В толстой книжке должна особенно четко прослеживаться единая концепция, иначе пользователем читается только часть, а в целом получается что-то неудобоваримое. На практике большие книжки вообще редко дочитываются до конца. Впрочем, они часто включают справочную информацию, так что это неудивительно.

Да, кстати. Приложения, упоминаемые в книге, распространяются на отдельном диске, не включенном в поставку. Его еще предстоит поискать.

Ратшиллер Т., Геркен Т. PHP4: разработка Web-приложений. Библиотека программиста. - СПб.: Питер, 2001. - 384 с. + CD.

Наиболее фундаментальный труд в обзоре. Первая часть посвящена принципам проектирования. Включает советы по написанию читабельного кода (хороший стиль программирования), тонкости синтаксиса PHP, а также пример разработки из жизни. Вторая часть - философия программирования под Web, разработка приложений и работа с БД. Последняя часть рассчитана на программеров, которым мало возможностей PHP, вследствие чего они хотят поковыряться в исходниках и добавить что-то свое.

Очень нужная и полезная книжка, но не для начинающих. Чтобы ее понять, надо знать синтаксис какого-либо языка высокого уровня. А также желательно иметь опыт разработки в коллективе, тогда написанное не покажется пустыми словами. Рекомендуется всем, кто программирует, не обязательно на PHP и даже не обязательно что-то связанное с Web.


Спецвыпуск Xakep, номер #017, стр. 017-076-2, ОБЗОР КНИГ

ОБЗОР КНИГ

Urix (spora_2k@mail.ru)

Спецвыпуск Xakep, номер #017, стр. 017-076-2

Active Server Pages 3.0 на примерах. - М.: Вильямс, 2001. - 352 с. + CD.

Первый раз вижу туалет на обложке книжки по программированию, да еще и выделенный пунктиром. Может, это намек авторам от оформителя? ASP тут маловато, ни синтаксиса, ни справочных данных. Термины нестрогие и, вообще говоря, не корректны. Достаточно глянуть на определение масштабируемости, чтобы понять, кто есть who. Явно рассчитано на начинающих. Если ты уже знаком с ASP и хочешь повысить свой уровень, искать в этой книжке тебе нечего. А вот для ознакомления с технологиями, начиная с элементов юзабилити и раскрутки сайта и заканчивая базами данных и объектно-ориентированным программированием, вполне подойдет. Даже введение в программирование на ASP есть :). Объяснения максимально простые и сжатые, начать писать что-то свое по ней можно очень и очень скоро. А потом можно и чего посерьезней поискать...

Яргер Р., Риз Дж., Кинг Т. MySQL и mSQL. Базы данных для небольших предприятий и Интернета. - СПб.: Символ-Плюс, 2001. - 560 с.

Из 560 страниц примерно 300 - справочные данные по SQL-диалектам MySQL, mSQL и интерфейсам программирования. Поэтому содержательная часть не очень большая и местами повторяется в приложениях. Первая часть - материал, касающийся баз данных, рассчитан на новичков. Кратко и наглядно (на примерах) даны основные понятия ER-модели. Не забыты введение в SQL и установка СУБД. Вторая часть предназначена для более продвинутых товарищей, которые решили заняться программированием БД с использованием PHP, Perl, С, С++, Python или чего еще... Естественно, синтаксиса нет (его не выдержит никакая книжка), а предполагается знание какого-либо из этих языков. В целом издание ориентировано на пользователя квалификации повыше средней, который занимался администрированием и написанием скриптов и, волей судеб (или начальника :)), занялся базами данных.

Лэммл Т., Портер Д. CCNA: Cisco Certified Network Associate. Учебное руководство. - Лори, 2001. - 640 с.

Поскольку эта книга предназначена для подготовки к экзамену, материал представлен в соответствующем виде - сначала объяснения, затем контрольные вопросы и упражнения. В конце книжки есть ответы и справочные материалы, среди которых больше сотни страниц занимает один только глоссарий (оригинальный термин - перевод - значение).

Плюсы книжек, предназначенных для подготовки к экзамену, - хорошая структура, наличие упражнений, авторы-профессионалы. Вообще говоря, упражнения - косвенный признак того, что над книжкой серьезно работали, а значит, она содержит качественный материал. Минусы - ограниченное количество информации, быстрое устаревание (экзамены меняются).

Ксенакис Д., Левисей Б. Photoshop 6 для профессионалов. - СПб.: Питер, 2002 г. - 880 стр. + CD.

Несмотря на название, описания вполне доступные, выброшены только наиболее элементарные операции типа сохранения файла или вызова контекстной менюшки. Основное направление - допечатная подготовка, а главы по ImageReady (программе, специализированной на Web-графике) вынесены на компакт-диск. Досадно, хотя и вполне логично.


Спецвыпуск Xakep, номер #017, стр. 017-076-3, ОБЗОР КНИГ

ОБЗОР КНИГ

Urix (spora_2k@mail.ru)

Спецвыпуск Xakep, номер #017, стр. 017-076-3

Приятно, что книга представляет собой нечто большее, чем сухое руководство по функциям и настройкам. Разобрано много сопутствующих тем типа повышения производительности, устранения сбоев в работе, а также способов представления изображения при вводе в компьютер и подготовке к печати. Получился не Photoshop "as is", а Photoshop в контексте рабочего применения.

Общее впечатление - неплохо, но хотелось бы еще большего в плане окружения и допечатной подготовки (раз уж об этом заговорили и заинтриговали). Какие-то уж очень маленькие получились отступления. Только начнешь читать, как глава заканчивается и начинаются фильтры, которыми битком набита любая книжка по Фотошопу. Или настройки какие-нибудь. То есть вроде что-то написано, но такое впечатление, что авторам не хватило места. Зато оформление здесь на высоте: твердая обложка, хорошая бумага, цветные вставки, продуманные компактные иллюстрации. Окошки, кстати, маковские - напоминание о том, что в издательском деле еще работают на Маках :).

Книга рекомендуется всем, кто работал с Фотошопом больше пары-тройки раз и хочет работать дальше, быстрее, выше, сильнее.

Маров М. Эффективная работа: 3ds max 4. - СПб.: Питер, 2002. - 864 с. + CD.

По сути дела это учебник по программе - от простого к сложному, начиная с меню и панелей инструментов и заканчивая текстурированием и анимацией. Последовательно выполняй практические упражнения, и все будет тип-топ, думать почти не надо. Написан он отечественным автором, так что любители поплеваться по поводу качества перевода могут быть спокойны. Язык - без детских объяснений, но и без больших сложностей. Оригинальные термины приводятся. По подаче материала, верстке и иллюстрациям нареканий нет. Единственное, чего я ожидал найти и не нашел, - отличий новой версии 3ds max от предыдущей.

Изначально книга предназначена для начинающего, но по причине солидного объема и разнообразия приемов может заинтересовать не только его.

Чистов Д.В., Слукин П.А. Учет валютных операций в "1С:Бухгалтерии 7.7". - М.: КомпьютерПресс, 2000. - 286 с.

В этой умной и серьезной книжке главная роль отводится описанию принципов и терминологии финансовых операций, а нажимание кнопок вторично. Без понимания этих самых принципов кнопки нажимать бесполезно. Объяснения довольно подробные, с упоминаниями ЦБ РФ и официальных документов. Масса табличек, схемок, справочных данных и приложений. Язык официальный, сухой.

Вряд ли ты здесь найдешь что-либо полезное для себя, книга предназначена для узкого круга специалистов.

Васильев Ю.Л. Автоматизация учета в среде 1С:Предприятие 7.7 конфигурация "Бухгалтерский учет". - КГАУ, 2001. - 116 с.

Данное руководство целиком и полностью состоит из пошаговых процедур заполнения формочек. Теории нет, о чем сказано честно и прямо. В начале каждой главы - краткая табличка: какое поле откуда берется. Дальше подробней - что оно обозначает, надо ли его заполнять или достаточно ткнуть куда-то, чтобы заполнилось само. И куда ткнуть, чтобы заполнилось. Опции расписаны не все, хотя объяснения вполне понятные.


Спецвыпуск Xakep, номер #017, стр. 017-076-4, ОБЗОР КНИГ

ОБЗОР КНИГ

Urix (spora_2k@mail.ru)

Спецвыпуск Xakep, номер #017, стр. 017-076-4

Оформлением это издание поразило меня с первой страницы. Совершенно потрясающая по стилистике ("учусь в ПТУ и хожу в дискотеку...") аннотация и не менее впечатляющее введение. Основной материал не столь силен, но тоже держится на высоте. Запятые расставлены как фишка ляжет. Вместо прямого слэша - обратный. Верстка догоняет содержание, формочки чувствуют себя отлично и вставлены и там, где это необходимо, и там, где их не ждали...

Одноразовая книжка для бухгалтера, знакомого с предметной областью, но совершенно незнакомого с компьютером.


Спецвыпуск Xakep, номер #017, стр. 017-078-1, ОБЗОР КУРСОВ

ОБЗОР КУРСОВ

Спецвыпуск Xakep, номер #017, стр. 017-078-1

Андрей Михайлюк aka Dronich (dronich@xakep.ru)

Главная тетенька в "Конструкторе" сказала: "Мы не нуждается в рекламе и системе скидок, нас знают и к нам приходят за качественным и недорогим образованием". Такая уверенность понравилась.

ВМНУЦ ВТИ - серьезное госучреждение с 25-летним стажем работы, выдающее удостоверение специалиста государственного образца.

Если ты хочешь получить бесплатный совет от профессионалов, то прогуляйся на www.softline.ru, посмотри расписание ближайших семинаров и готовь вопросы.

Сертификат ЦИТ МГУ могут получить только настоящие профессионалы (там же подготовленные :)), поэтому он котируется довольно высоко как у нас, так и на различных СП.

Под крышей "Специалиста" работает служба трудоустройства, распихивающая желающих по вполне приличным фирмам, чтобы было где применять полученные знания на практике.

Если для тебя расстаться с парой штук гриносов (или развести свое руководство на ту же сумму) - это не проблема, можешь смело отправляться на любой сертифицированный курс Цисок.

"Конструктор"

Телефоны: 156-2731, 156-2888

Этот учебный центр готовит специалистов по дизайну. Нас особо интересуют курсы по 3D-моделированию в 3DS и по PhotoShop'у. ЗДСке учат с самых азов, даже про основы правильного дизайна расскажут. Но это вовсе не значит, что ты уйдешь от них лошком, научившимся создавать вращающиеся кубики :). Занятия очень интенсивные, и в течение всех восьмидесяти часов (а именно столько и длится курс) ты будешь не только слушать, но и выполнять достаточно серьезные задания. Если ты преуспеешь в практике, то сможешь получить сертификат Autodesk, что подтвердит твои профессиональные знания. А они, по заверениям фирмы, будут носить максимально прикладной характер (то есть тебя будут учить не теоретически возможным, а профессионально полезным приемам работы). Теперь о Фотошопе. Сорокачасовой курс рассчитан на его совместное применение с CorelDraw и опять же является чисто прикладным - в программе присутствует создание электронных макетов рекламных плакатов, визиток и обложек. За этот курс просят 50 долларов. ЗДСка стоит чуть более ста, что является самым выгодным предложением по соотношению "бабло-знания". Недаром их директриса сказала мне замечательную фразу: "Мы не нуждаемся в рекламе и системе скидок, нас знают и к нам приходят за качественным и недорогим образованием". Такая уверенность мне понравилась :). Занятия проходят у станции метро «Войковская», продолжительность обоих курсов - две недели (группы по 14 человек). Для 3DSMax есть сокращенный вечерний вариант. Кстати, в том же центре можно подтянуться по AutoCAD'у на Autodesk'овый сертификат, но это на любителя.

Институт сетевых и компьютерных технологий

Телефоны: 912-7778, 911-9253

Профиль конторы, несмотря на гордое название, почти такой же, как и у "Конструктора" - дизайн и трехмерка, а вдобавок и БД. По дизайну существуют три курса - восьмидесятичасовой обзорный, в котором изучаются особенности Корела, Фотошопа, Кварка и Пейжмейкера, и парочка более узких ("дизайнерский" на шестьдесят часов и "верстальный" на сорок, по две проги на курс). 3DSMax обещают разжевать за 60 часов, причем разжевать довольно основательно, но по большей части теоретически. По базам данных нашлись "СУБД Oracle" с изучением SQL и "Администрирование СУБД" по сотне часов, оба курса очень обширные и полезные. Учиться можно либо по будням (четыре часа в день утром, днем или вечером на выбор), либо по выходным по шесть часов. Занятия проходят в очень узком кругу - в группе не больше десяти человек (в основном около семи), посему обучение получается почти индивидуальным. Цены тоже неплохие - 4250 рупий за трехмерное моделирование, 4900 за обзорный курс по дизайну, и Оракл с СекКуЕлем за 12 тысчонок (остальные курсы только-только появились, но цены обещают пропорциональные времени обучения). "Ну, нормальные", по описаниям директора, компы оказались разномастными пнями :), дизайнеров учат только на третьих, остальные используются на других специальностях (помимо БД есть еще кодинг и машинопись). Контора расположена у станции "Пролетарская" или "Крестьянская застава".


Спецвыпуск Xakep, номер #017, стр. 017-078-2, ОБЗОР КУРСОВ

ОБЗОР КУРСОВ

Спецвыпуск Xakep, номер #017, стр. 017-078-2

ВМНУЦ ВТИ

Телефоны: 245-3805, 246-4279, 246-5962, 320-9368

Под такой неслабой аббревиатурой скрывается Всероссийский межотраслевой научно-учебный центр по вычислительной технике и информатике. Это серьезное госучреждение с 25-летним стажем работы, выдающее удостоверение специалиста государственного образца, которое при устройстве на работу в российскую фирму котируется не ниже международного сертификата. Спектр профессий для освоения у них приятно удивляет разнообразием - есть почти все. Здесь тебе смогут предложить 45 часов Кварка или Фотошопа за 2400 наших деревянных, 60 часов 3DS'a за 3000 тех же, создание и администрирование сетки на 2000-х виндах на 60 часов (правда, уже за 5600 рубленых), разработку и администрирование БД на MS SQL Server (60 часов - 5400 рэ) и работу с 1с в ассортименте по 1100 рублей (20 часов). Для студентов и школьников действуют скидки. Темп обучения - не более 30 часов в неделю, то есть курс проходится за неделю-две. Группы набирают по десять человек, опять же ориентация на практическое освоение профессии. Компы имеют от вторых пней и выше. Занятия проходят у м. "Парк Культуры". Единственное "но" - курсы начинаются по мере набора жаждущих знаний, поэтому лучше насобирать десяток друзей и приходить туда готовой группой (это официальное пожелание фирмы :)).

SoftLine

Телефон: 232-0023

Учебный центр одноименной компании. У этих ребят просто туча курсов, посвященных изучению винтукея на достаточно профессиональном уровне (четыре отдельных курса только по разнообразной настройке), и два по SQL - администрирование и программирование. Вот только цены огорчают - средняя цена курса на 40 часов составляет порядка 300 зеленых вашингтонов :(. Ситуацию кое-как поправляет скидка частным лицам на 15% и оплаченные обед и кофе-брейк посреди занятий. Кстати, о скидках - если ты не частное лицо, то сможешь получить -5%, подписавшись на каталог Софтлайна; -20% - обучаясь повторно; -7% - посещая семинары Софтлайна. Семинары, между прочим, очень полезная штука, на халяву можно получить просто немерено информации - я тут позажигал на "Преимуществах ХР перед 2000-ми" и остался очень доволен. Если ты хочешь получить совет от профессионалов, то прогуляйся на www.softline.ru, посмотри расписание ближайших семинаров и готовь вопросы. Компания не дает никаких свидетельств, но готовит к фирменной MS-сертификации. На мой взгляд, эта одна из самых серьезных контор в обзоре - об этом говорит и размах проведения семинаров, и условия обучения, и низкий процент бедного студенчества на курсах :(. Дорогие (но полезные и наиболее полные) знания раздают у "Калужской" и "Ленинского проспекта"; компы, понятное дело, самые современные, а аудитории заевроремонтенные (деньги-то надо куда-то девать :)).

Центр информационных технологий МГУ

Телефон: 451-8586

Слышал ли ты о таком сайте, как www.citforum.ru? Мне думается, что слышал и даже таскал оттуда какую-нибудь полезную инфу (а ее там море). Так вот, хозяин этого самого цитфорума и есть ЦИТ МГУ. Они предлагают обучение на самом высоком уровне, сертификат ЦИТ МГУ могут получить только настоящие профессионалы (ими же подготовленные :)), поэтому он котируется довольно высоко как у нас, так и на различных СП. Количество инфы, которую они впихивают в голову за 30-40 часов, просто поражает - я надыбал у них учебный план по курсу "Основы баз данных" и прослезился, нам в универе за два семестра столько не начитали. Правда, за профессионализм приходится очень дорого платить - цены курсов колеблются в районе 400-700 USD'шек (и это за 30-40 часов) :(. Так что, если ты богатенький Буратино, милости просим, станешь настоящим профи довольно быстро. Благо, обучение проходит в группах по 5-10 человек, что канает за индивидуальный подход. Если все-таки решишься расстаться со своими кровными, знай, что в ЦИТе тебя научат и основам составления локальных сетей, и работе в Oracle на PL/SQL, и чистому SQL на должном уровне. Грызть гранит науки придется у метро "Речной вокзал", но со всеми удобствами и на быстрых компах.


Спецвыпуск Xakep, номер #017, стр. 017-078-3, ОБЗОР КУРСОВ

ОБЗОР КУРСОВ

Спецвыпуск Xakep, номер #017, стр. 017-078-3

"Специалист"

Телефоны: 232-3216, 263-6633

Крупнейший в России центр компьютерного обучения при МГТУ имени Баумана уже одиннадцать лет задает темп в преподавании софтварных и хардварных навыков. У них есть курсы почти по всем пунктам нашей сегодняшней программы, которые к тому же дифференцированы по уровням подготовки. Кстати, на их сайте есть раздел (tests.specialist.ru), посвященный онлайн-тестированию, где ты легко можешь проверить свой уровень знания по той или иной комповой тематике. По итогам теста выдаются свидетельство и рекомендации, на какой курс записаться (по уровню знания предмета, ессесно). Но вернемся к нашим баранам: из дизайна тебе предложат Фотошоп для начинающих/профи (32+16 ч. за 2970 рупий / 40+20 ч. за 5380 рэ), верстку в Кварке (48+24 за 4390), ЗДСтудио трех уровней (начинающие оторвут от сердца 3980 кровных за 48+24 часа, "совершенствующиеся" - 1790 за 16+8, профи же выложат 2650 за 24+12 часов). Странная формулировка времени расшифровывается довольно просто - после плюса идут часы, выделяемые в компьютерных классах на самостоятельную отработку очередной темы (до, после или вокруг :) основных занятий). Администрирование сетей можно изучать по авторской программе (64 часа и 10390 денег) или по сертифицированным программам микрософта, где каждая тема (вроде разработки инфраструктуры сетевых служб) вынесена в отдельный курс. Пройдя несколько из них (уже есть готовые наборы по спецценам), можно претендовать на фирменный сертификат мелкомягких (разброс времени и цен на один курс - 20-60 часов и 4-8 тысяч соответственно). Веб-программингу обучиться можно как на PHP (32 часа и 6370 рупий), так и на ASP (32+16 за 6380). Есть отличный вводный курс в SQL (Oracle) на 40 часов, правда, стоит он 12570 :(, для фанатов дядюшки Билла имеется серия курсов по MS SQL Server - от создания запросов до администрирования и программинга (от трех до восьми [с конфискацией :)] тысяч рублей). Можно легко заделаться бухгалтером на курсах по 1с, но, ИМХО, тебя больше заинтересуют админство и поддержка 1с:Предприятия (16+8 и 3270), и программирование там же (92+46 :) чуть менее чем за 16 тысяч). В общем, заучишься по самое не балуйся, тем более, все условия для этого имеются - компы не ниже третьего пня (на момент написания этой статьи они стихийно обновлялись на четвертые), умные книжки по теме входят в стоимость курса (равно как кофе-брейки и обеды), скидок тоже хватает, а подход преподы применяют сугубо прикладной - никакой воды в курсе гарантированно не будет. О скидках стоит сказать чуть подробнее - 5, 10 и 15 процентов получают прослушавшие 1, 2 или 3 курса; 40% прощают при записи на курсы по новым версиям программ, если курс по предыдущей уже прослушал; 10% вернут обучающимся днем (да, вот так просто :)), студентам Бауманки (ну, они-то уже в курсе ;)) и клиентам СофтЛайна (см. выше). Студенты и школьники традиционно получают пятипроцентный дисконт. Само обучение проходит у м. "Бауманская", "Речной вокзал", "Текстильщики", "Тушинская", "Маяковская", "Баррикадная" и "Беляево", можешь подобрать поближе к дому. Учиться можно утром, днем, вечером, есть субботние группы. По курсам от микрософта придется батрачить с 10 до 17.30. По окончании любого курса ты можешь получить свидетельство "Специалиста" (чуть ли ни единственное свидетельство частной фирмы, которое канает за показатель знания при приеме на работу, если судить по объявлениям). Да, под конец самое вкусное - под их крышей работает служба трудоустройства, распихивающая желающих по вполне приличным фирмам, чтобы было где применять полученные знания на практике. И отношение устроившихся к желавшим устроиться стремится к единице :).


Спецвыпуск Xakep, номер #017, стр. 017-078-4, ОБЗОР КУРСОВ

ОБЗОР КУРСОВ

Спецвыпуск Xakep, номер #017, стр. 017-078-4

Cisco Systems

Все мы прекрасно знаем, что специалисты по маршрутизаторам и аппаратным файрволам обычно отрываются с руками (гы, садизмом попахивает) крупными фирмами. Но, к сожалению, руководители курсов тоже это знают и ломят цены до запредельных высот. Если для тебя расстаться с парой штук гриносов не проблема, можешь смело отправляться на любой сертифицированный курс Цисок, список лучших из них ты найдешь ниже. Иначе... да мы не были бы Спец-крю, если не нарыли бы для тебя эксклюзивных студенческих курсов по вполне божеской цене. Живут они под скромным названием Cisco Networking Academy в институте МИФИ и готовят вполне реальных специалистов. Главное отличие академии от других курсов - они не зацикливаются на цисковом оборудовании, а обучают общим принципам работы сетей (но на серьезном уровне), хотя вся практика проходит именно на Цисках. Курс проводится в течение четырех семестров без отрыва от учебы/работы или всего за месяц, но каждый день с понедельника по пятницу c десяти до семи (итого девять часов в день). Стоимость обучения - по 125 бакинских за первые два семестра и по 175 за последние. Программа довольно насыщенная, поэтому даже полный кля уйдет от них образованным спецом. Учиться ладить с сетевым железом придется в сетевой лаборатории на "Каширской". Народу в группе немного - около 10 человек, компы в академии от Sun'a (да-да, на соляре :)), по окончании получишь цискин сертификат и можешь смело идти на экзамен. Телефоны их: 323-91-60 и 323-9078.

Так, буратины еще здесь? А то я обещал рассказать о дорогих цисковых курсах. Помните - для полноценного обучения там нужно иметь (помимо пачки хрустящих бумажек в кармане ;)) статус крутого системщика, так как учить азам там не будут. Если ты и являешься таковым, смело разводи свою фирму на сдачу цисковых экзаменов, за пару недель будешь щелкать Кисок как орешки. Три признанных лидера по подготовке - учебный центр CiscoTrain (т. 361-5930, м. "Авиамоторная"), Microtest (т. 787-2431, м. "Павелецкая") и Diamond (т. 956-6676, м. "Семеновская"). Все параметры у них примерно одинаковы: обучение в небольших группах, оплаченные обеды и кофе-брейки, продолжительность курсов не более двух недель, современные компы в сетевых лабораториях. Если есть деньги и желание - милости просим.


Спецвыпуск Xakep, номер #017, стр. 017-080-1, ADVANCED ЗАГРУЗОЧНЫЙ NIX-ФЛОПАРЬ

ADVANCED ЗАГРУЗОЧНЫЙ NIX-ФЛОПАРЬ

Спецвыпуск Xakep, номер #017, стр. 017-080-1

n0ah (noah@real.xakep.ru)

Прежде чем лезть в дебри пингвиньих файловых систем и kernel’ов, давай попробуем понять, зачем нам с тобой, приятель, может пригодиться advanced загрузочная nix-дискета. Ну, во-первых, в отличие от аналогичной виндовой дискетки, она способна оказать помощь при восстановлении практически любых систем, в том числе и некоторых виндовых (с NT’шными не дружит, но с ними не дружит даже обычная виндовая boot-дискета). Это очень удобно, если ты работаешь где-то админом и у тебя в парке есть как MS-машины, так и никсоидные. Во-вторых, грамотно собранный линуксовый бут-диск – это, по сути, миниатюрная Linux, установленная на дискету. Представь себе, как удобно постоянно иметь при себе свою собственную ось - куда бы тебя не занесло, среди каких компов ты бы не оказался, всегда сможешь загрузить любимую игрульку или текстовый редактор. И в гостях у приятеля, и в компьютерном клубе, и в институте. В-третьих, если специально начинить нашу nix-дискету зло-хак-программами, она может стать очень эффективным инструментом взлома при наличии физического доступа к машине. Представь, что пришел ты в какую-нибудь контору, имеющую свою внутреннюю сеть, включил машину, а там приглашение какого-нибудь NT на вход. Что дальше делать, не понятно – не знаешь ни логина, ни пароля. А тут воткнул дискету, перезагрузился и дальше в локалку (исследовать порты, сервисы) или ковырять файловую систему (пароли там какие-нибудь повыдергивать, etc). В общем, не суть важно, что ты там будешь делать, важно то, что делать ты это будешь из-под своего линуха с правами рута :).

Заполучить загрузочную дискетку можно несколькими путями:

1. Создать загрузочную дескету средствами дистрибутива.

2. Скачать готовую из инета.

3. Собрать свою собственную загрузочную дискету.

Первый способ заранее не подходит, так как будет создана boot-дискета, способная загружать только машины, на которых уже установлен линух. Такая дискета может пригодиться только в том случае, если по каким-то причинам повредился MBR и система не может загрузиться с харда. Нам сие не надо – в крайнем случае загрузимся с сидюка, войдем в rescue mode и, набрав /sbin/lilo, восстановим MBR. Если же произойдет что-нибудь более серьезное (например, полетит хард), такая дискетка нам не поможет – она не сможет загрузить машину, не найдя на винте корневую файловую систему.

Второй способ самый простой и безболезненный. Но у него тоже есть минусы: все-таки дискету собирал другой человек, и на ней может не оказаться именно той тулзы, которая как раз тебе необходима.

Ну и третий способ – именно тот, по которому мы с тобой пойдем :). Заранее предупреждаю, что гимора будет много ;). К счастью, есть документ, называемый The Linux Bootdisk HOWTO (http://www.linux.com/howto/Bootdisk-HOWTO/index.html). Сей талмуд хранит в себе практически всю необходимую для создания отдельного, самостоятельного загрузочного флопаря информацию.

Итак, давай приступим к созданию нашей кулхацкерской загрузочной дискетки. Для начала надо разобраться, из чего состоит среднестатистическая линуксовая загрузочная дискета. Структуру boot-диска условно можно разделить на следующие составляющие:


Спецвыпуск Xakep, номер #017, стр. 017-080-2, ADVANCED ЗАГРУЗОЧНЫЙ NIX-ФЛОПАРЬ

ADVANCED ЗАГРУЗОЧНЫЙ NIX-ФЛОПАРЬ

Спецвыпуск Xakep, номер #017, стр. 017-080-2

1. Ядро.

2. Корневая файловая система.

3. Утилиты.

Теперь давай определимся, на скольких дискетах мы хотим видеть свою загрузочную систему. Существует несколько вариантов:

1. Одна дискета. На один единственный флопарь упихиваются ядро, корневая файловая система, необходимые утилиты, а иногда еще и LILO. На основе более-менее свежего дистриба такую дискету создать более чем проблематично, так как с развитием Linux набирают килобайты и ядро, и библиотеки, и прочие компоненты системы – уже все на одну дискету не уместишь. Если хочется, чтоб была именно одна дискета (а очень часто хочется, так как влом таскать с собой кипу флопарей), можно взять какой-нибудь старый дистриб и наваять бут-диск на его основе.

2. Две дискеты. На одну помещается ядро, а на вторую - корневая файловая система. Утилиты умещаются в корень. Сначала загружается ядро, которое подгружает корневую файловую систему и помещает ее в оперативку. Дисковод после этого можно освободить.

3. Три и более дискет. То же самое, что и второй вариант, только утилиты выносятся на отдельную дискету (дискеты, если утилит много), которую можно использовать после загрузки корневой файловой системы в память.

Имхо, самый оптимальный вариант – второй. Тем более что корневая файловая система перед помещением на ядро сжимается и снова разжимается в память уже после загрузки – реально она может вместить больше, чем дискеточные полтора мега.

ЛЕПИМ ЯДРО

В первую очередь надо подготовить ядро. Давай подумаем, где бы нам его надыбать. Идеальный вариант - взять сорцы, сбацать подходящий конфиг и скомпилировать новое ядро. При этом ядро можно сделать максимально компактным, убрав поддержку ненужных фич. К таким я бы отнес поддержку X, звука, SCSI-хардварок, мышей, драйверов от железа, которого у тебя в помине нет и прочего экзотического барахла (которое все нормальные люди отключают, даже если компилируют просто ядро для своей системы, а не для бут-диска). Спорный вопрос – нужна ли загрузочной дискете поддержка сети? С одной стороны, конечно, нужна, так как если есть локалка, через нее удобно восстанавливать упавшие машины (а потом, помнишь, мы говорили, что если ты захочешь что-нибудь похакать при помощи своей дискеты... ;)). Да и из инета можно что-нибудь по-быстрому слить. С другой же стороны, поддержка сети жрет кучу места (которого у нас на флопаре и так мало), а для того, чтобы пофиксить накрывшийся диск, сеть на фиг не нужна. Короче, смотри, решай сам – в крайнем случае можешь наваять две разные загрузочные дискеты: одну с сетью, вторую – без.

Чтобы собрать новое ядро, переходи в каталог, где лежат исходники:

cd /usr/src/linux

вбивай:

make xconfig

Запустится утилита графического конфигурирования ядра. Скроль по окошкам, включая/выключая всякие опции. когда закончишь, можешь сохранить конфиг в отдельный файл. После чего нажимай «Save and Exit» и вводи в командной строке:

make dep

а затем:


Спецвыпуск Xakep, номер #017, стр. 017-080-3, ADVANCED ЗАГРУЗОЧНЫЙ NIX-ФЛОПАРЬ

ADVANCED ЗАГРУЗОЧНЫЙ NIX-ФЛОПАРЬ

Спецвыпуск Xakep, номер #017, стр. 017-080-3

make bzImage

Если все ок, то в папке /usr/src/linux/arch/i386/boot/ у тебя появится файлик bzImage. Это и есть новоиспеченное ядро. Я опустил фрагмент подготовки модулей ядра, так как для своей загрузочной дискеты обычно компилирую безмодульное ядро. Но если тебе нужна поддержка модулей, в хаутушке подробно описано, как это сделать.

Если влом компилить новое ядро, можно взять то, на котором запущена твоя система. Оно, вероятно, будет достаточно большим, но если ты собираешься класть его на отдельную дискетку, это не так уж и страшно.

/ - КОРНЕВАЯ ФАЙЛОВАЯ СИСТЕМА

Корневая файловая система – это всего лишь набор каталогов и файлов, необходимых для нормальной загрузки Linux. Она есть у любой линевой системы. Эта файловая система монтируется в точке «/». Мы сформируем корневую файловую систему для нашего boot-диска из минимального набора необходимых файлов и каталогов и сожмем ее, чтоб она умещалась на дискетке. Для этого нам понадобится какое-то место, где мы сможем держать все файлы до сжатия и переноса на дискету. Набирай:

dd if=/dev/zero of=/dev/ram0 bs=1k count=3000

mke2fs -m 0 -i 2000 /dev/ram0

Этим ты создал файловую систему в памяти. Теперь ее можно примонтировать и работать с ней как с отдельным диском. Вводи:

mount -t ext2 /dev/ram0 /mnt/fd_

Теперь у нас есть виртуальный диск в памяти, примонтированный в точке /mnt/fd_. Именно тут мы и будем формировать корневую файловую систему для нашего будущего бут-диска.

Минимальный необходимый набор каалогов для корневой файловой системы выглядит так: /dev, /proc, /etc, /sbin, /bin, /lib, /mnt, /usr. Создавай эти директории на нашем виртуальном диске (mkdir /mnt/fd_/dev, mkdir /mnt/fd_/proc и так далее). /proc, /mnt и /usr можно оставить пустыми, а остальные надо заполнить кое-каким файлом.

В /dev обычно хранятся файлы всяких устройств (флоповоды, диски, терминалы). Мы утянем эти файлы из /dev твоей основной корневой файловой системы, так как влом создавать их заново. Все устройства нам не понадобятся, поэтому мы возьмем только самые необходимые. Сделай

cd /dev

ls

Ты увидишь огромный список файлов. Чтобы скопировать какой-нибудь из них на наш виртуальный диск, надо набрать следующее:

cp -dpR /dev/file_name /mnt/fd_/dev/file_name

Например,

cp -dpR /dev/hda1 /mnt/fd_/dev/hda1

В Bootdisk HOWTO есть список минимальных необходимых файлов-устройств, но, повыкидывав оттуда всякий хлам (типа ленточных накопителей), я получил более компактный список. Так что выбирай. Строго обязательны следующие файлы-устройства: console, kmem, mem, null, ram, tty1. Но я тебе советую кроме них оставить еще и tty*, hd*, cua*, ram*-файлы.

Далее у нас идет /etc. Точно так же:

cd /etc

и копируй следующее файло fstab, inittab, passwd, group, shadow и каталог rc.d/* (например, cp /etc/fstab /mnt/fd_/etc). Подчисть скопированные файлы, опираясь на рекомендации из Bootdisk HOWTO.

/sbin и /bin наполняй аналогичным образом (да поможет тебе Bootdisk HOWTO :)).

Осталось заполнить /lib. /lib – это хранилище всех библиотек, необходимых бинарным, выполняемым файлам (ты их выбирал и клал в /sbin и /bin). Чтоб узнать, какому файлу какие библиотеки требуются, сделай на него


Спецвыпуск Xakep, номер #017, стр. 017-080-4, ADVANCED ЗАГРУЗОЧНЫЙ NIX-ФЛОПАРЬ

ADVANCED ЗАГРУЗОЧНЫЙ NIX-ФЛОПАРЬ

Спецвыпуск Xakep, номер #017, стр. 017-080-4

ldd file_name

Например, ldd /bin/cp. Эта команда выдаст на выход список требуемых cp’шкой библиотек. Копируй их из /lib в /mnt/fd_/lib командой, типа

cp /lib/libc-2.4 /mnt/fd_/lib

Сочувствую, но придется проделать то же самое для всех файлов из /bin и /sbin виртуальной корневой файловой системы :). Зато на этом мучения с ее формированием заканчиваются. Осталось только ее сжать:

umount /mnt/fd_

dd if=/dev/ram0 bs=1k | gzip -v9 > root.gz

В папке /mnt появится файл root.gz – это и есть сжатая корневая файловая система.

ПЕРЕНОС

Ядро есть, сжатая корневая файловая система есть – осталось только разместить их по дискеткам. Скопируй все это хозяйство в какую-нибудб темповую папку (скажем, /root/tmp) и набирай:

dd if=bzImage of=/dev/fd0 bs=1k

Ты увидишь что-то, типа

n+1 records in

n+1 records out

Запомни число n+1 – нам с ним еще предстоит гимориться :).

Теперь вводи следующее:

rdev /dev/fd0 /dev/fd0

rdev -R /dev/fd0 0

Вычисли по формуле val = n+1+49152 и набирай:

rdev -r /dev/fd0 val

Все, первая дискетка (с ядром) готова! Вытаскивай ее, вставляй вторую и сразу набирай:

dd if=root.gz of=/dev/fd0 bs=1k

Погоди, пока сжатая корневая файловая система скопируется и вытаскивай дискету. Пометь первую дискетку как boot_disk (пометь, я имею в виду бумажкой :), не пугайся), а вторую root_disk. Пихай в флоповод boot_disk и перезагружайся. Велик шанс, что ничего работать не будет ;). Но это нормально – с первого раза ни у кого не получается (прямо как в «Матрице»). Пробуй, ищи баги, испарвляй. Кстати, от загрузочной дискеты до собственного дистрибутива всего один шаг :).


Спецвыпуск Xakep, номер #017, стр. 017-082-1, ADVANCED ЗАГРУЗОЧНЫЙ WIN-ФЛОПАРЬ

ADVANCED ЗАГРУЗОЧНЫЙ WIN-ФЛОПАРЬ

Спецвыпуск Xakep, номер #017, стр. 017-082-1

Андрей Михайлюк ака Dronich (dronich@xakep.ru)

Стандартная виндовая бутявка пытается распознать все имеющиеся в наличии диски (включая ЦеДеРОМы), потом создает в оперативке виртуальный диск, на который переносит утилиты из своего комплекта.

Скажи честно, ты видел, чтобы Скандиск когда-нибудь что-нибудь грамотно восстанавливал? Я не видел, поэтому попер его с бут-диска вместе с инишкой (scandisk.ini).

Я советую остановиться на Volcov Commander'e. Что бы там ни говорили про плагиат, но так пожать Нортона - это искусство.

Самым разумным будет разместить какой-нибудь DiskDoctor от Нортона или DiskMinder из Nuts&Bolts на отдельной дискете и юзать его оттуда.

«При загрузке с использованием загрузочного диска Windows 98 в загрузочном меню имеется возможность как загрузки драйверов для устройств чтения компакт-дисков, так и обычной загрузки».

(Из справки Windows 98 о бут-диске. Вот загрузили!!!)

Винды периодически накрываются. Это аксиома. Единственное, что в наших силах, - максимально отсрочить этот момент или просто быть готовым к нему (можно, конечно, и совсем забить на мелкомягкую продукцию, но этот способ не для всех). Про эффективность латания и оттягивания я промолчу, обсудим-ка лучше методы ликвидации нехороших последствий оконного обвала с маленького, но универсального BOOT-диска. Готовность номер один... Начали!

RTFM

В былые времена я лепил бутявки на основе пустых дискет - загонял туда Доса версии 6.22 и писал вручную конфигурационные файлы. Потом на нашу голову придумали FAT32, о которой Дос не знал в принципе, и пришлось юзать виндовый флопарь как основу, выбив из него все дерьмо и залив на его место действительно нужные вещи. Этим мы с тобой сейчас и займемся. Суй чистый флоп в дисковод и заставь винды сделать из него системный (Панель управления -> Установка/удаление программ -> Загрузочный диск). Давай условимся, что я рассказываю про Win9x, поскольку они есть почти у всех (по крайней мере как вторая система). Поклонники NT/2000/ХР (если они настоящие поклонники :)) без труда повторят то же самое под своими осями. Итак, диск создан. Советую переписать его содержимое в какую-нибудь диру, ибо оно подвергнется серьезной правке. Посмотрим, что за сюрприз приготовили нам мелкомягкие.

СЕСТРА, СКАЛЬПЕЛЬ!

Немного о принципах работы MS Бутявки for Windows: она пытается распознать все имеющиеся в наличии диски (включая ЦеДеРОМы), потом создает в оперативке виртуальный диск, на который переносит утилиты из своего комплекта. Вот в эту форму мы и будем пихать новое содержание. Для начала покоцаем всякое фуфло - смело убивай drvspace.bin, он отвечает за работу со сжатыми дисками (надеюсь, ты эту фигню не юзаешь?), серию файлов aspi2dos.sys, aspi4dos.sys, aspi8dos.sys, aspi8u2.sys, aspicd.sys, btcdrom.sys, btdosm.sys, flashpt.sys (ведь у тебя не сказевый сидюк?) и ридмишку (почитать ее стоит, а на дискете хранить не рекомендую). Места поприбавилось? То-то же. Но и это еще не все - видишь файл ebd.cab? Помимо имени, подходящего к ситуации с упавшими виндами (прочтешь пару раз вслух, и на душе легче :)), он прячет в себе фирменный набор утилит. А раз набор от Micro$oft, значит есть чего из него вытрясти. Смело открывай (WinRar'ом, например) и изучай списочек. Какой тут самый большой файл? Правильно, scandisk.exe. Скажи честно, ты видел, чтобы Скандиск когда-нибудь что-нибудь грамотно восстанавливал? Я не видел, поэтому попер его из архива вместе с инишкой (scandisk.ini). Пробежимся по остаткам: attrib.exe (нужен для установки атрибутов файлов, сносим, у нас файл-менеджер для этого будет), chkdsk.exe (проверялка диска, отстой - тоже сносим), debug.exe (кому придет в голову отлаживать проги, когда надо данные спасать?), edit.com (текстовый редактор; можно оставить, пригодится), ext.exe (оболочка для extract.exe, помогает прошарить дистрибутив виндов в поисках определенного файла, оставляем), format.com (формат он и в Африке формат, удалить не вздумай! :)), mscdex.exe (поддержка сидюка под досом, пускай живет), sys.com (перенос системных файлов, нужен обязательно).


Спецвыпуск Xakep, номер #017, стр. 017-082-2, ADVANCED ЗАГРУЗОЧНЫЙ WIN-ФЛОПАРЬ

ADVANCED ЗАГРУЗОЧНЫЙ WIN-ФЛОПАРЬ

Спецвыпуск Xakep, номер #017, стр. 017-082-2

ПЕРЕСАДКА ЖИЗНЕННО ВАЖНЫХ ОРГАНОВ

Да-с, порезали знатно, надо теперь чем-то восполнять пробелы. Первое, что приходит в голову, - файл-менеджер. Он заменит мелкие (и мягкие :)) утилиты, что мы с тобой так бесцеремонно дилитнули, и облегчит работу с файлами. Выбор у нас невелик, места тоже в обрез, поэтому я советую остановиться на VC aka Volcov Commander. Что бы там ни говорили про плагиат, но так пожать Нортона - это искусство. Поэтому создаем на дискете диру "VC" и пихаем в нее Волковский екзешник. Потом мы еще его с тобой понастраиваем.

Что еще надо для счастья? Нормальные утилиты. Их будем складывать в "UTIL". Для начала архиватор - pkunzip.exe - вполне подойдет. Как показывает практика, нужный до зарезу файл может оказаться зазипованным, и будет обломно просто любоваться на него. Потом что-нибудь для работы с диском, я рекомендую две утилы - diskedit и disktool. Первая является культовой частью служебных программ от дяди Нортона, она позволяет творить с дисковым пространством все, что твоей извращенной душе угодно, - от сохранения куска памяти в файл до ручного переписывания ФАТа. В аварийных случаях diskedit - самый требуемый musthave. Только помни, хоть сам он весит немного, для полноценной работы с ним требуется библиотека nlib200.rtl (тоже водится в комплекте Нортона), не забудь и ее зашарашить на бутявку. Теперь о disktool'e: эта прога не так известна, но несет безмерную пользу при восстановлении данных. Только она может оперативно переотмечать сбойные кластеры (что иногда спасает жизнь винтам) и форматать дискету без убиения данных (а во время сбоя системы вся инфа обычно лежит на флопарях).

Как ты помнишь, скандиск мы вынесли, а замены ему пока не нашли. Имхо, ее и не надо, если все слетело глобально, то дискчекер вряд ли поможет. Хотя бывали случаи, когда винды просто висли на запускавшемся скандиске, но работали при его отключении (такой вот хитрый приемчик ;)). Так вот, мелких качественных дискчекеров нет в природе, а место на основной дискете дорого. Самым разумным будет разместить какой-нибудь DiskDoctor от Нортона или DiskMinder из Nuts&Bolts на отдельной дискете и юзать его оттуда. Тем более в больших комплексах обычно присутствует опция создания аварийной дискеты с тем самым чекером на борту.


Спецвыпуск Xakep, номер #017, стр. 017-082-3, ADVANCED ЗАГРУЗОЧНЫЙ WIN-ФЛОПАРЬ

ADVANCED ЗАГРУЗОЧНЫЙ WIN-ФЛОПАРЬ

Спецвыпуск Xakep, номер #017, стр. 017-082-3

Еще неплохо кинуть на дискету mouse.com (не утянет), а то с непривычки файл-менеджер будет казаться адом даже тем, кто под виндами сидит в ФАРе. Приучил нас Большой Билли к крысам, что поделаешь... А если у тебя на винте живет несколько систем, можно попробовать впихнуть на бутяву NTFSDOS - прогу для доступа к разделам NT из Доса.

LET'S CUSTOMIZE!

Знаешь, а ведь мы с тобой подло влезли в структуру фирменного флопаря. Нехорошо... Он-то пока думает, что он фирменный. Будем переубеждать. Берем любой приличный текстовый редактор, понимающий досовскую кодировку, и ползем править конфигурационные файлы. То, что получилось у меня, можешь наблюдать в листингах.

config.sys

Святая святых, параметры запуска доса. Займемся конструктивным вандализмом ;). Первая секция, как видно из ее названия, отвечает за меню. Здесь надо убить строку "menuitem=HELP...", нам хелпы ни к чему. Можешь поменять названия пунктов, они идут после запятой, и цвета меню (строка "menucolor"). Следующая секция - [CD], в ней мы оставим только первые две строчки, остальное коцай - это ссылки на файлы, которые мы безжалостно удалили раньше. Новый клиент - секция [HELP], ее мы убьем вместе с заголовком (ведь ее уже не существует в меню). Остальное оставим без изменений.

autoexec.bat

Аналог виндовой "Автозагрузки". Перестроим под себя, нечего Гейтсу всякое фуфло грузить ;). Для начала три строку "copy readme.txt %RAMD%:\ > NUL", ридмишки больше нет, копировать нечего. Потом уберем секцию между ":ERROR" и "GOTO ERROR", ошибок у нас быть не должно (вроде ;)). Строку "IF "%config%"=="HELP" GOTO HELP" тоже надо снести - хелпы мы убили. По той же причине коцаем все между ":HELP" и "GOTO QUIT". Все сообщения (строки с echo) можешь поменять по вкусу, не возбраняется. В самый конец файла советую дописать вызов драйвера мыши (mouse.com) и шелла (A:\vc\vc), меньше руками работать потом. И потрудись прописать в строке "path=..." все возможные пути (a:\vc; a:\util, etc.), чтобы впредь не возникало проблем с вызовом программ.

setramd.bat

По идее этот батник отвечает за создание виртуального диска в оперативе, но и в него мелкомягкие умудрились напихать мусора. Наша задача тут - убрать бестолковые ech'и и заменить их толковыми сообщениями для себя (зачем тебе пятнадцать строк, в которых говорится, что диск С: не размечен? обойдемся одной!). Остальное можно не трогать, так как там идет нормальная проверка свободных имен дисков.

Фу, вроде все. Хотя нет, особо любящим комфорт я посоветую настроить меню командира волков :). Эту мелочь обычно упускают, а польза от нее все же есть - вместо работы с командной строкой ты получишь удобную менюху с запускаемыми прогами, которая вызывается из VC по нажатию пимпы F2. Запускай Волкова и выбирай из верхней менюшки Commands - Menu File Edit и соглашайся на правку основного меню (Main). Внизу будет маячить подсказка по синтаксису, разобраться вполне реально. На всякий случай пример: повесим на букву Z указявку на то, что выделенный в коммандере файл надо раззиповать. Выглядеть это будет примерно так:


Спецвыпуск Xakep, номер #017, стр. 017-082-4, ADVANCED ЗАГРУЗОЧНЫЙ WIN-ФЛОПАРЬ

ADVANCED ЗАГРУЗОЧНЫЙ WIN-ФЛОПАРЬ

Спецвыпуск Xakep, номер #017, стр. 017-082-4

-------------

z: Unzip File

pkunzip !.!

-------------

Все! Вид менюхи смотри на скрине. Имхо, ты найдешь, чего еще напихать в меню, - пробуй. Удобства мало не бывает.

Дополнилово

Вот мы и сотворили простейшую бутявку. Ее вполне достаточно для среднестатистического падения виндов, но ты можешь добавить еще утилит. Можно убрать все файлы (кроме системных) с диска и запихнуть их в самораспаковывающийся архив, а его уже экстрактить на виртуальный диск, это сэкономит тучу места. Можно закатать загрузочный сидюк (ведь у тебя или твоих друзей есть CD-RW?) и кинуть на него дистрибутив системы. У меня вообще есть старый винт на два гига, на котором установлена BeOS (be-in-file, живет под FAT32), и именно с него я исправляю все бяки и делаю бэкапы. Придумывай, совершенствуй. Все в твоих руках, хацкер. Напоследок только скажу - не делай ОДНУ системку. Она имеет свойство портиться в самый неподходящий момент :). Когда, по известной аксиоме, падают винды.

ЗЫ: Где найти описанные проги? Или на старом сидюке с софтом, или в Инете на dronich.nm.ru/xakep/dos.htm ;). Юзай без стеснения.

Листинг 1: autoexec.bat

@ECHO OFF

set EXPAND=YES

SET DIRCMD=/O:N

set LglDrv=27 * 26 Z 25 Y 24 X 23 W 22 V 21 U 20 T 19 S 18 R 17 Q 16 P 15

set LglDrv=%LglDrv% O 14 N 13 M 12 L 11 K 10 J 9 I 8 H 7 G 6 F 5 E 4 D 3 C

cls

call setramd.bat %LglDrv%

set temp=c:\

set tmp=c:\

path=%RAMD%:\;a:\;%CDROM%:\;a:\vc;a:\util;

copy command.com %RAMD%:\ > NUL

set comspec=%RAMD%:\command.com

copy extract.exe %RAMD%:\ > NUL

:EXT

%RAMD%:\extract /y /e /l %RAMD%: ebd.cab > NUL

echo Слышь, хозяин, я все свое дерьмо покидала на %RAMD%. Разгребай иди!

IF "%config%"=="NOCD" GOTO QUIT

LH %ramd%:\MSCDEX.EXE /D:mscd001 /L:%CDROM%

echo.

GOTO QUIT

:QUIT

a:\mouse.com

a:\vc\vc

set CDROM=

set LglDrv=

Листинг 2: config.sys

[menu]

menuitem=CD, Дарагой, сидюк хочу, да?

menuitem=NOCD, Генацвали, не надо сидюка!

menudefault=CD,30

menucolor=7,0

[CD]

device=himem.sys /testmem:off

device=oakcdrom.sys /D:mscd001

[NOCD]

device=himem.sys /testmem:off

[COMMON]

files=10

buffers=10

dos=high,umb

stacks=9,256

devicehigh=ramdrive.sys /E 2048

lastdrive=z

device=display.sys con=(ega,,1)

country=007,866,country.sys

install=mode.com con cp prepare=((866) ega3.cpi)

install=mode.com con cp select=866

install=keyb.com ru,,keybrd3.sys


Спецвыпуск Xakep, номер #017, стр. 017-085-1, ПАРАДНЫЙ WINDOWS: альтернативный интерфейс для win

ПАРАДНЫЙ WINDOWS: альтернативный интерфейс для win

Спецвыпуск Xakep, номер #017, стр. 017-085-1

UFO (ufobject@mail.ru), NorTan (nortan@nortan.net)

Среди модулей LiteStep встречаются такие интересные вещи? как консоль, возможность создания анимированных ярлыков или настройка реакции на события каждой точки на рабочем столе.

На мой взгляд, Талисман - это лучшая программа в своем роде. Единственный ее недостаток - системные требования.

Какой может быть комфорт, если при очередной загрузке зеленоватого рабочего стола у пользователя возникает рефлекторная рвотная реакция? Поэтому, начиная с Windows 2000, графическое исполнение окошек начало стремительный переход к новому виду.

Будь осторожен, если захочешь поставить эти программы под Windows ME/XP, - ini-файлы оставлены в этих осях только для совместимости с древними программами. В XP эту поддержку почти убили :(.

Пускай ты сидишь под Windows, но это хоть с первого взгляда заметно не будет :).

Стандартный виндовый интерфейс надоел уже всем. Даже самым упертым и аскетичным трудоголикам, у которых на первом месте стоят функциональность, простота и комфорт. Но какой может быть комфорт, если при очередной загрузке зеленоватого рабочего стола у пользователя возникает рефлекторная рвотная реакция? Не годится. И в MS это очень хорошо понимают. Поэтому, начиная с Windows 2000, графическое исполнение окошек начало стремительный переход к новому виду. Но, в соответствии с законами рынка, там, где не успевает MS (действительно новым можно назвать разве что интерфейс XP), поспевают другие люди, и благодаря им уже сейчас существует огромное количество программ, позволяющих изменить стандартный оконный интерфейс.

Большинство этих программ просто прописывают в файл system.ini, в строке Shell=, путь на свой модуль, и тем самым вместо explorer.exe загружается другая программа, которая, в свою очередь, подгружает собственные DLL-файлы. Таким образом, при загрузке Windows его родной интерфейс меняется на другой. Будь осторожен, если захочешь поставить эти программы под Windows ME/XP, - ini-файлы оставлены в этих осях только для совместимости с древними программами. В XP эту поддержку почти убили :(.

TALISMAN

Страница тут: http://www.talisman.com

Брать тут: http://www.lighttek.com/files/talisman.zip

Первая программа, на которую я хотел бы обратить твое внимание, - Талисман. На мой взгляд, это лучшая программа в своем роде. Единственный ее недостаток - системные требования. Программе необходим как минимум P166, 32Mb оперативной памяти и видеокарта, способная держать 24 разряда. Конечно, многим эти требования покажутся просто мизерными, но для людей со слабыми машинами - это ощутимый удар по системным ресурсам (дело даже не в том, какие у программы системные требования, а, скорее, в том, сколько она отжирает ресурсов при работе - прим. ред.). Ладно, не будем заострять свое внимание на этом маленьком недостатке, а лучше разглядим ближе эту замечательную софтинку.

Талисман, пожалуй, самая красивая и удобная в настройках программа. С ее помощью ты сможешь создать множество рабочих столов и с легкостью переключаться от одного к другому. На десктопах можно располагать все что угодно и как угодно. Кнопку, которая вызывает главное меню, можно, например, поставить посередине экрана. Все элементы интерфейса (которые можно сделать даже невидимыми) могут принимать любые формы. Талисман избавит тебя от ограничений размера иконок, как это сделано в обычном интерфейсе Windows. Программа может работать в двух режимах - как установленной в качестве самостоятельной оболочки, так и под управлением Explorer'а. Есть возможность изменения вида обычных кнопок. В новых версиях Талисмана появились такие фичи, как создание движущихся форм, настройка реакций кнопок на различные действия мыши и показ видеофайлов. С помощью встроенного редактора ты с легкостью сможешь создавать свои собственные темы. Но если тебе не хочется копаться самому, то на сайте программы можно найти огромное количество уже созданных и настроенных тем. Также можно заказать себе диск, на котором находится, вместе с дистрибутивом талисмана, более двухсот готовых сценариев. К сожалению, программа требует регистрации, но это тебе выйдет не так уж и дорого - всего 150 рублей. Конечно же, всех достоинств Талисмана я рассказать тебе не смогу, так как их слишком много, а лучше посоветую скачать эту программу и вдоволь поюзать ее. Последнее, на что я хотел бы обратить твое внимание, - минимальное количество багов. В основном баги появляются на стадии создания собственных тем. При использовании стандартных серьезных ошибок обнаружено не было. В общем, бери и пользуйся!


Спецвыпуск Xakep, номер #017, стр. 017-085-2, ПАРАДНЫЙ WINDOWS: альтернативный интерфейс для win

ПАРАДНЫЙ WINDOWS: альтернативный интерфейс для win

Спецвыпуск Xakep, номер #017, стр. 017-085-2

HOVERDESK

Страница тут: http://www.hoverdesk.net/

Брать тут: http://www.hoverdesk.net/dl/en/HDsetup.zip

Еще одна программа, меняющая интерфейс окошек дяди Билли. По сравнению с Талисманом она менее удобна в настройках, но по красоте и возможностям практически не уступает. Вместе с программой поставляется пять стандартных плагинов: Recycle Bin, Clock, EyeDropper, Virtual Desktop и CPU Monitor. Recycle Bin - обычная корзина, но при этом очень удобная, к тому же с возможностью настройки внешнего вида. EyeDropper - особенно полезный модуль для художников, предназначенный для захвата RGB-значений цветов с экрана. Также неоспоримым достоинством программы является то, что она ничего не записывает в каталог Windows (зачем нам лишний мусор там :)?). Программа поддерживает возможность изменения размера кнопок с 16x16 и до 64x64. Менюшки под управлением HeverDesk принимают стиль "NextStart". Радует возможность отображать на экране в реальном времени график загруженности системных ресурсов. Панель с кнопками и меню могут свободно перемещаться по желанию пользователя из одного угла десктопа в другой. В программе имеется виртуальный менеджер рабочего стола, с помощью которого рабочее пространство заметно увеличивается. Если подольше покопаться с HoverDesk и изучить все комбинации с мышью и клавиатурой (например, зажатие шифта в комбинации с перетаскиванием курсора мыши), то можно свободно манипулировать любыми кнопками: удалять, перетаскивать или создавать новые. Программа поддерживает обновление тем рабочего стола и разные plug-ins. Основное отличие HoverDesk от ее сородичей в том, что она не заменяет Explorer, а устанавливается как обычная программа. В контекстном меню рабочего стола добавлена функция вызова меню "Пуск", что редко присутствует в программах, которые ставятся "поверх" Explorer'а. Ее можно свободно установить или удалить без лишней перезагрузки машины. И напоследок хочу добавить, что программа имеет свой собственный Taskbar и четыре виртуальных экрана. Качай и наслаждайся!


Спецвыпуск Xakep, номер #017, стр. 017-085-3, ПАРАДНЫЙ WINDOWS: альтернативный интерфейс для win

ПАРАДНЫЙ WINDOWS: альтернативный интерфейс для win

Спецвыпуск Xakep, номер #017, стр. 017-085-3

NEXTSTART

Страница тут: http://www.winstep.net/

Брать тут: http://www.winstep.net/ns2-full.zip

NextStart - еще одна удобная программа, которая украсит твою жизнь за компьютером. Отличительная черта NextStart'а заключается в ее гибкости. Ты можешь менять практически любые кнопки и меню как тебе вздумается. Радует реализация некоторых функций в отдельном окне. Например, часы, менюшки со скинами, "трей" и прочее можно переместить в любую часть экрана. Есть поддержка наложения картинок на кнопки, изменения подложек и возможность ставить горячие точки на разные участки окон или программ. С помощью NextStart можно настроить на всплывающих меню вызов таких папок, как "Мои документы", "Панель управления", кнопку "Старт" и еще много разных Windows-примочек. В этой софтине такие действия делаются с удивительной легкостью и с минимальной затратой сил :). На сайте www.skinz.org можно найти множество тем для NextStart. Одним из главных недостатков софтины является ее замедленность. Это чувствуется особенно на слабых машинах, но при наличие новейшего мегаскоростного камня ты даже и не успеешь заметить тормозa, которыми обладает программа :). В общем, качай NetStart, возможно, именно эта программа больше всего приглянется тебе.

LITESTEP

Страница тут: http://www.litestep.net/; http://www.litestep.org/; http://www.litestep.com/

Брать тут: ftp://faxe.jinr.ru/apps/LiteStep/ls-024.zip

Одна из лучших программ для обновления надоедливых окон и интерфейса рабочего стола. Программа задумана для людей, которым нравится Unix. Она требует мало ресурсов и просто блещет красотой. Установив LiteStep на свою машину, ты сможешь узнавать прогноз погоды, менять панель WinAmp'а, использовать экранную лупу, проверять почту... Для этого нужно только скачать нужный тебе DLL-модуль. Среди модулей встречаются такие интересные вещи, как консоль, возможность создания анимированных ярлыков или настройка реакции на события каждой точки на рабочем столе. LiteStep не уступает другим программам и в возможности переключения виртуальных рабочих столов (пользователь сам задает их количество), что очень помогает не запутаться во множестве открытых окон. Еще одна примечательная особенность LiteStep'а - контроль использования ресурсов. Так, например, можно оставить одну командную строку и тем самым бешено повысить производительность. Вот представь - ломаешь ты какой-нибудь архив методом перебора, а всякие ословидные експлореры ресурсы поедают, как Пэкмен. Плохо? Вот и я так думаю. Оставил одну командную строку, и скорость перебора подскочила. Для LiteStep существует огромное количество готовых тем (более тысячи!!!), но вот не все они работают идеально - некоторые темы приходится доделывать из-за кривых рук авторов. Самый большой недостаток программы - ее настройка. Все проблемы из-за того, что настраивать LiteStep нужно через файл step.rc. В принципе, ничего сложного в нем нет, но из-за его огромных размеров лезть в него страшновато. К счастью, разработчики снабдили этот файл описанием. Я надеюсь, тебя заинтересовала эта программа, и ты уже решился ее закачать к себе и опробовать по полной программе :), так как все прелести софтины расписать я не смогу, да и незачем. В общем, качай и юзай в свое удовольствие :).


Спецвыпуск Xakep, номер #017, стр. 017-085-4, ПАРАДНЫЙ WINDOWS: альтернативный интерфейс для win

ПАРАДНЫЙ WINDOWS: альтернативный интерфейс для win

Спецвыпуск Xakep, номер #017, стр. 017-085-4

P.S. В самом начале я дал три ссылки на страницы этой программы, так как по непонятным причинам один из серверов периодически накрывается. На момент написания статьи работала только эта ссылка - http://www.litestep.net.

ASTON

Страница тут: http://www.astonshell.com

Брать тут: http://www.astonshell.com/files/aston.zip

И последняя программа, которую я хотел бы представить тебе, - Aston. Она понравилась мне больше всего, сам даже не знаю из-за чего... Любовь с первого взгляда, наверное :). Ну, это, в общем, не важно. Программа представляет собой красивую и удобную оболочку. Очень приятно и оригинально сделаны подписи к ярлыкам. Видно, что разработчики подошли с душой к созданию программы. Первое, что бросается в глаза, - действительно минимальное потребление ресурсов машины. У меня это было сразу заметно по времени загрузки рабочего стола. Кстати, доступ к рабочему столу может осуществляться через HotKey, то есть не надо перемещать окна, сворачивать их, чтобы запустить что-то с рабочего стола. К сожалению, отсутствует разбивка на несколько десктопов. Интерфейс сделан так, что все нужные программы находятся под рукой. Поначалу немного раздражают огромные иконки, но потом привыкаешь ;). По обеим сторонам экрана спрятаны выезжающие менюшки, которые активируются, если на них навести мышь. Еще одна приятная вещь - график загрузки процессора. Иногда интересно понаблюдать за темпами загрузки камня при запуске разных программ и клипов :). В общем, программа очень приятная, но требует регистрации, как и большинство других стоящих программ. Регистрация Aston для жителей России и стран СНГ обойдется в 250 рублей. Единственным серьезным недостатком Aston'а является малое количество настроек. Программа, как и HoverDesk, не мусорит в Windows. Советую тебе скачать и посмотреть.

КОНЧАЮ

Ну вот. Теперь ты знаешь, как изменить свой рабочий стол до неузнаваемости. Единственное, что тебе осталось сделать, - выбрать наиболее подходящую для тебя программу, установить ее и наслаждаться обновленным интерфейсом. Если ты хочешь быстро изменить вид без особых усилий - ставь Aston. Более требовательным в настройках подойдет Talisman. Ну а если ты хочешь сделать интерфейс действительно «под себя», то твой выбор - LiteStep. Я уверен, ты проведешь не один час за скачиванием разных скинов и плугинов к понравившейся тебе программе. И, поверь мне, это принесет тебе немало удовольствия, особенно если твоя машина собрана по последнему писку Билла. В общем, качай и наслаждайся. Увидимся!


Спецвыпуск Xakep, номер #017, стр. 017-085-5, ПАРАДНЫЙ WINDOWS: альтернативный интерфейс для win

ПАРАДНЫЙ WINDOWS: альтернативный интерфейс для win

Спецвыпуск Xakep, номер #017, стр. 017-085-5

P.S.

Огромное спасибо VenouS'у (venous@smtp.ru) за помощь в поиске и тесте представленного софта.


Спецвыпуск Xakep, номер #017, стр. 017-092-1, РЕЕСТР WINDOWS: ТОЛЬКО ТРУСЫ НЕ ЛЕЗУТ HKEY!

РЕЕСТР WINDOWS: ТОЛЬКО ТРУСЫ НЕ ЛЕЗУТ HKEY!

Спецвыпуск Xakep, номер #017, стр. 017-092-1

DireX (direx@ganja.ru, odigo 6944487)

Почти всю инфу реестра собирают два раздела: HKLM и HKU. Раздел KHCU, по ходу, - часть HKU, относящаяся к данному юзеру. HKDD - это сборище инфы о производительности системы. В HKU хранятся настройки цветов, заставок, обоев и всего такого во время работы окошек. HKCC содержит настройки форточек по умолчанию, а HKCR - инфу о типах файлов (подсказки, описания), данные по OLE, d-n-d и ярлычах. В HKLM хранятся аппаратные и программные настройки, конфа форточек и других программ.

И, наконец, мой любимый REG_NONE. Означает, что параметр ничего не содержит. Я такого параметра еще не видел, но он есть :). Это доказано M$. Если найдешь - отмыль мне!

Моим любимым развлечением до недавнего времени было выставить на обои где-нибудь тетку не слишком серьезного поведения и запретить их менять. Можно ржать хоть весь день, когда видишь, как ушастый Пиноккио "прикрывает амбразуру вражеского дзота" =).

Реестр позволяет юзеру экспортировать разделы в файл *.reg. Эти файлики используются как патчи для реестра. То есть экспортировал раздел в *.reg, запустил на другом компе, и все в ажуре. И рыться нигде не надо. Быстро и практично, как и велел Х.

Сколько раз мы вгоняли в гроб "винды", пытаясь "наладить их голыми руками"? Сколько раз трояны ласкали нас сзади? И не достали ли тебя сообщения тулзов, что пора заплатить пачку хрустящих енотов студенту из Алабамы? Все! Хватит! Сегодня мы поговорим о реестре!

АЗ ЕСЬМ РЕЕСТОР! ПО ЧЕ ЗРИТЕ МЯ?

История реестра началась с решений "Win95". Тогда "майкрософтовский" гений решил заменить кучу файликов INI для каждой софтины одним бо-о-ольшим реестром. Билли сказал, что программки теперь будут писать параметры именно туда. И стало так :). И вообще-то - это хорошо =). "Винда" тоже предалась сему пороку и хранит почти все свои настройки в реестре... Хе-хе... А мы их можем исправлять. Каждому известно, что "Микрософт" крайне не любит свои маленькие радости документировать, потому как считает, что юзеру это ни к чему, а админ и сам знает. Но не следует забывать, что самая сексопильная операционка - "вынь", а самая сильная ее эрогенная зона - это, конечно, реестр.

УРОК АНАТОМИИ: С ФРЕДДИ ВЕСЕЛЕЙ!

В "Win9X" все просто: реестр хранится в двух файлах: "system.dat" и "user.dat". Есть еще один файл, отвечающий за системные политики и права юзера - "Policy.pol", он наличествует начиная с "Win98". Файло "user.dat" создается для каждого ушастого Пиноккио. Находятся эти чудеса в папочке, куда помещается "Винда". В "вынь2К" все гораздо сложнее: там чуть ли ни каждый раздел хранится в отдельном файле. Скажу лишь, что реестр "Win2K" находится в папочке C:\WINNT\system32\config, где C:\WINNT\ - папочка, где прячется "Винда". Хранится все просто: раздел, в разделе параметры и\или другие разделы. В реестре обнаруживаются шесть основных разделов: HKEY_CLASSES_ROOT, HKEY_CURRENT_USER, HKEY_LOCAL_MACHINE, HKEY_USERS, HKEY_CURRENT_CONFIG и HKEY_DYN_DATA. Для краткости имена разделов сокращают до трех-четырех букв, например, HKEY_LOCAL_MACHINE сокращается до HKLM. Почти всю инфу реестра собирают два раздела: HKLM и HKU. Раздел KHCU, по ходу, - часть HKU, относящаяся к данному юзеру. HKDD - это сборище инфы о производительности системы. В HKU хранятся настройки цветов, заставок, обоев и всего такого во время работы окошек. HKCC содержит настройки форточек по умолчанию, а HKCR - инфу о типах файлов (подсказки, описания), данные по OLE, d-n-d и ярлычах. В HKLM хранятся аппаратные и программные настройки, конфа форточек и других программ.


Спецвыпуск Xakep, номер #017, стр. 017-092-2, РЕЕСТР WINDOWS: ТОЛЬКО ТРУСЫ НЕ ЛЕЗУТ HKEY!

РЕЕСТР WINDOWS: ТОЛЬКО ТРУСЫ НЕ ЛЕЗУТ HKEY!

Спецвыпуск Xakep, номер #017, стр. 017-092-2

ДОСТАНЬ СВОЙ ИНСТРУМЕНТ!

С реестром мы будем работать стандартной утилью "виндей" - "regedit". Она прячется в каталоге окошек. Зашуршат харды, и пред тобой явится окошко, похожее на "експлорер". Слева дерево каталогов, а справа - список параметров, их типов и значений. Также в ынете существует туча всякого рода переделок и выделок "Регедита", правда, мало чем отличающихся от их праотца. На freeware.ru я отыскал одну прикольную утилу, которая позволяет работать с реестром как с папкой. В папке 6 разделов и так далее... Так вот, этот инструмент позволяет создавать и редактировать параметры реестра как файлища в "Експлорере". Задавил кнопарь крысы два раза - редактируй параметр. Захотел переименовать - фраг тебе в сумку. Делается все это через вываливающуюся менюшку. Также она позволяет создавать параметры и разделы.

ТИПЫ ПАРАМЕТРОВ В РЕЕСТРЕ

Вообще-то, разных типов туева хуча, но выделить среди них нужно четыре: REG_SZ - строковые, REG_BINARY - двоичные (в "regedit" они отображаются только в HEXах), REG_DWORD - это 32-разрядный двухсловный параметр, но чаще юзается как истинно двоичный (1\0). Буль - рулез. :). И, наконец, мой любимый - REG_NONE. Означает, что параметр ничего не содержит. Я такого параметра еще не видел, но он есть :). Это доказано M$. Если найдешь, отмыль мне! Ладно, хорош теорию рутить! Попрактикуемся, а то ручки-то у хирурга шаловливые... У-тю-тю...

PRACTICZ

Открой раздел HKLM. Там есть несколько разделов, из имен которых не сложно понять их назначение =). Самым интересным из них является "Software". Там хранятся установки программ. Пути к настройкам любого софта звучат примерно так: HKLM\Software\Фирма\Софтварь. Так, давай доберемся до настроек "Виндей". Они прячутся в HKLM\Software\Microsoft\Windows\CurrentVersion. В самом этом разделе много интересного. Директория "Винды", серийный номер и куча всякой полезной инфы, которую можно поменять. Далее в подразделах мы и найдем параметры. С разделом "Run", ты, наверное, уже знаком - туда прописываются троянчики, чтоб загружаться при запуске системы. Еще они прописываются в "RunServices". А делается это так: создается строковый параметр, в котором содержится команда (путь к экзешнику). Существуют также разделы "RunOnce" и "RunServicesOnce". Параметры там удаляются сразу после их выполнения. Самым интересным разделом в этой папке является раздел "прав и политик" - "Policies". Все параметры, указанные ниже, стопудово работают на "Win2K" и "XP", но многие пашут и на "Win9X\Me".

POLICIES AS IS


Спецвыпуск Xakep, номер #017, стр. 017-092-3, РЕЕСТР WINDOWS: ТОЛЬКО ТРУСЫ НЕ ЛЕЗУТ HKEY!

РЕЕСТР WINDOWS: ТОЛЬКО ТРУСЫ НЕ ЛЕЗУТ HKEY!

Спецвыпуск Xakep, номер #017, стр. 017-092-3

В разделе "Polisies" мы можем менять права юзера. Невольно вспоминаются радости *nix... Но здесь все куда веселее, ведь "Винды" стоят всюду! Моим любимым развлечением до недавнего времени было выставить на обои где-нибудь тетку не слишком серьезного поведения и запретить их менять. Можно ржать хоть весь день, когда видишь, как ушастый Пиноккио "прикрывает амбразуру вражеского дзота" =). Все параметры имеют тип REG_DWORD. Включено - 1, выключено - сам догадайся.

EXPLORER BY ][

Начнем с раздела "Explorer". Если его нету, то создай. Там работают следующие параметры:

NoSaveSettings - юзер задолбается переставлять значки - параметры "Екплорера" при выходе не сохраняются.

NoActiveDesktop - если у юзера "WinMe", то он может распрощаться с "Айсберг.jpg".

NoDesktop - значки с десктопа исчезают =).

NoLogoff - нельзя юзать "Завершение Сеанса".

NoClose - юзер не сможет корректно вырубить комп.

NoSetFolders - нельзя менять настройки "Панели Управления" и "Принтеров".

NoDrives - скрыть флопарьский ярлычок в "Моем Компьютере".

NoNetConnectDisconnect - запрет сетевых соединений и их разрывов. Прощай, Инет!

ИЗДЕВКИ НАД "ПУСКОМ"

Действия происходят все в том же подразделе "Explorer".

NoFavoritesMenu - "Избранное" исчезает. Прощайте, мистер Андерсон :)!

NoFind - в поисках утраченного. Из Пуска исчезает пункт "Найти".

NoRun - исчезает пункт "Выполнить".

NoSetActiveDesktop - из подменю "Настройка" исчезает пункт "Рабочий стол Active Desktop".

NoChangeStartMenu - нельзя перетаскивать ничего в меню "Пуск".

NoFolderOptions - из подменю "Настройка" исчезают "Свойства папки..."

NoRecentDocsMenu - из "Пуска" исчезает подменю "Документы".

NoRecentDocsHistory - теперь никто не узнает, что за *.avi ты смотрел. Но мы-то с тобой знаем...

ClearRecentDocsOnExit - чистить подменю "Документы" при выходе.

ACTIVEDESKTOP-ТОП-ТОП

Теперь в "Policies" создай раздел "ActiveDesktop" и юзай следующие параметры:

NoAddingComponents - нельзя добавлять элементы на десктоп.

NoDeletingComponents - нельзя их удалять.

NoEditingComponents - запретить редактирование элемента на десктопе.

NoClosingComponents - нельзя закрывать элемы на десктопе. У меня в "Win98" эти четыре параметра не пашут :(.

NoHTMLWallPaper - нельзя юзать для обоев HTMLи.

NoChangingWallPaper - становится недоступной вкладка "Фон" в "Свойствах Моники".

NoCloseDragDropBands - нельзя перемещать и гробить панельки инструментов на десктопе.

NoMovingBands - нельзя изменять размеры панелек.

DOS, ЧЕРНОЙ ПЕЛЕНОЙ...

В "Policies" создай раздел "WinOldApp". Вот возможные параметры:

NoRealMode - нельзя перезагружаться в MS-DOS.

Disabled - запретить командную строку MS-DOS.

НАСИЛУЕМ СИСТЕМУ

В многострадальных "Policies" создай раздел "System". Ну, сейчас мы ее!

DisableRegistryTools - нашкодили и запретили юзать реестр :).

NoDispCPL - вот и нету "Панели Управления". В "Win9X" не пашет.

NoDispBackgroundPage - скрыть вкладку "Фон".

NoDispScrSavPage - скрыть вкладку "Заставка".

NoDispAppearancePage - скрыть вкладку "Оформление".

NoDispSettingsPage - скрыть вкладку "Настройка".

NoSecCPL - запретить пароль для "Панели Управления". В "Win9X" не пашет.


Спецвыпуск Xakep, номер #017, стр. 017-092-4, РЕЕСТР WINDOWS: ТОЛЬКО ТРУСЫ НЕ ЛЕЗУТ HKEY!

РЕЕСТР WINDOWS: ТОЛЬКО ТРУСЫ НЕ ЛЕЗУТ HKEY!

Спецвыпуск Xakep, номер #017, стр. 017-092-4

NoPwdPage - скрыть вкладку "Изменение" паролей.

NoAdminPage - скрыть вкладку "Удаленное Администрирование".

NoProfilePage - скрыть вкладку "Профили пользователей".

NoDevMgrPage - скрыть вкладку "Диспетчер Устройств".

NoConfigPage - скрыть вкладку "Профили Оборудования".

Многие из этих парамов пашут только в осях на ядре NT (2K, XP).

ПОДРАЗДЕЛ NETWORK

NoNetSetup - запретить отображение папки "Сеть" и "Удаленный доступ к сети".

NoNetSetupIDPage - скрыть вкладку "Идентификация".

NoNetSetupSecurityPage - скрыть вкладку "Доступ".

NoEntireNetwork - не отображать значок "Вся сеть" в окне "Мое сетевое окружение".

В ЦВЕТЕ

Сейчас мы поможем юзеру поменять цвета десктопа и шрифты "Експлорера". Конечно, ты мне сейчас расскажешь про преимущества изменения цветов через "свойства монитора", но не все возможности реестра тебе еще подвластны. Так что сиди и слушай. Открой раздельчик по пути KEY_CURRENT_USER\Control Panel\Colors. Там гора строковых параметров. Все они в формате "RпробелGпробелB", где RGB-код цвета. Для тех, кто в танке: RGB - это красный (R), зеленый (G), синий (B). Выбери нужный цвет в каком-нибудь графическом редакторе, запомни RGB-код и набери его там.

ActiveTitle - цвет заголовка форточки.

AppWorkspace - цвет фона форточки.

Background - цвет десктопа.

ButtonDkShadow - тень от кнопок.

GradientActiveTitle - цвет строки заголовка с градиентной заливкой. От черного и до указанного тобой.

Scrollbar - цвет полосы прокрутки.

Там еще гора всяческих цветов, но по их названиям можно разобраться, что к чему. Теперь перейдем к размеру. Каждому ушастому Пиноккио известно, что размер имеет значение. Вот у меня размер большой. А чтоб у тебя тоже был в три обхвата, иди сюда: HKEY_CURRENT_USER\Control Panel\desktop\WindowMetrics. Параметры там такие:

BorderWidth - ширина рамки форточки.

CaptionFont - шрифт заголовка.

CaptionHeight - высота заголовка форточки.

IconFont - шрифт подписей к значкам.

IconSpacing - горизонтальный интервал между иконками на десктопе.

IconVerticalSpacing - вертикальный интервал между иконами.

MenuFont - шрифт команды меню.

MenuHeight - высота ячейки меню.

MenuWidthт - ширина ячейки меню.

MessageFont - шрифт окон сообщений.

ScrollHeight - высота горизонтальной полосы раскрутки.

ScrollWidth - ширина вертикальной полосы раскрутки.

Shell Icon BPP - глубина цвета значков в битах на пиксель (имя пишется с пробелами).

Shell Icon Size - размер икон на десктопе. Поставь 72 =). Имя пишется с пробелами.

SmCaptionFont - шрифт маленьких заголовков окон.

SmCaptionWidth - ширина ячейки символа в маленьком заголовке.

StatusFont - шрифт строки состояния.

Если здесь что-то не будет фурычить, то попробуй поставить пробелы между словами названий или, если они есть, убрать их. Чтоб изменить шрифт, надо кликнуть на параметре правой кнопью крысы и зажать "Изменить". Теперь ты видишь, что это значит в виде строки. Попробуй поменять шрифты в свойствах экрана. Так ты узнаешь двоичный код нужного шрифта.

Также юзер будет в восторге, если затормозить ему вылет меню "Пуск". Делается это так: лезь в HKCU\Control Panel\desktop, создаем параметр типа REG_SZ с именем "MenuShowDelay". Там можно выставить значение от 1 до 10.


Спецвыпуск Xakep, номер #017, стр. 017-092-5, РЕЕСТР WINDOWS: ТОЛЬКО ТРУСЫ НЕ ЛЕЗУТ HKEY!

РЕЕСТР WINDOWS: ТОЛЬКО ТРУСЫ НЕ ЛЕЗУТ HKEY!

Спецвыпуск Xakep, номер #017, стр. 017-092-5

ФАЙЛИКИ *.REG - ПАТЧИ ДЛЯ РЕЕСТРА

Реестр позволяет юзеру экспортировать разделы в файл *.reg. Эти файлики используются как патчи для реестра. То есть экспортировал раздел в *.reg, запустил на другом компе, и все в ажуре. И рыться нигде не надо. Быстро и практично, как и велел Х. Если ты большой извращенец, то можешь писать *.reg файлы сам, настраивая их, как хочешь. Можно сделать так, чтобы, если параметр существует, он не перезаписывался. Есть еще много мощных расколбасов.

Любой файл *.reg начинается со строчки REGEDIT4. Далее следует имя раздела, в который надо добавить\переписать параметры и их список в формате:

"имя"="значение"

"имя"=hex:значение

"имя"=dword:значение

в REG_SZ, REG_BIARY и REG_DWORD соответственно. В листинге нумбер ван ты увидишь пример простого *.reg-файла. Его функцией является сделать иконки размером 120x120. Но истинные возможности раскрываются, когда мы перейдем к шкодингу.

КОДИМ!

Кодить будем на "Delphi". Мой выбор - "Delphi 5", так как под него компонентов у меня горы. Создай форму, как на рисунке. Нам нужны объекты "Edit" и "Button". В "Edit" вводим размер значка (стандарт - 32). Но мы-то с тобой широкой души народ, поэтому выставь 120. Кайфешник! При разрешении 1024x768 на десктопе помещается только 20 значков :). Кнопочку жмем, чтобы воплотить в жизнь задуманное. В "Delphi" есть специальный тип для работы с реестром - "TRegistry". Чтобы описать тип, его надо добавить в раздел "Uses" без буквы T, то есть просто "Registry". Далее в описании переменных "var" опиши переменную "Reg" типа "TRegistry". В обработчике события "Button1.Click" запиши код, как в листинге. Программа простейшая, там нет проверки на ввод букв, так что постарайся их не вводить. В обработчике события нажатия пимпы "Button1.Click" мы сначала создаем объект типа "TRegistry", затем назначаем главным разделом HKCU и открываем раздел HKCU\Control Panel\Desktop\WindowMetrics. Наша цель - изменить параметр "ShellIconSize". Раз он строкового типа, то мы используем действие "WriteString". Для остальных типов тоже имеются действия.

НАПОСЛЕДОК...

Немало инфы по играм с реестром есть на пагах о "Delphi" и лично на моей. Что ж, hax0r, фраг тебе в сумку и лазить, смотреть, ковыряться. Траблы и расколбасы? Взмыль мне!

Листинги

unit Main;

interface

uses

Windows, Messages, SysUtils, Classes, Graphics, Controls, Forms, Dialogs,

ExtCtrls, StdCtrls, Registry;

type

TForm1 = class(TForm)

Panel1: TPanel;

Panel2: TPanel;

Edit1: TEdit;

Button1: TButton;

Bevel1: TBevel;

Bevel2: TBevel;

Bevel3: TBevel;

procedure Button1Click(Sender: TObject);

private

{ Private declarations }

public

{ Public declarations }

end;

var

Form1: TForm1;

Reg : TRegistry;

implementation

{$R *.DFM}

procedure TForm1.Button1Click(Sender: TObject);

begin

Reg := TRegistry.Create;

Reg.RootKey := HKEY_CURRENT_USER;

Reg.OpenKey('Control Panel\Desktop\WindowMetrics', True);


Спецвыпуск Xakep, номер #017, стр. 017-092-6, РЕЕСТР WINDOWS: ТОЛЬКО ТРУСЫ НЕ ЛЕЗУТ HKEY!

РЕЕСТР WINDOWS: ТОЛЬКО ТРУСЫ НЕ ЛЕЗУТ HKEY!

Спецвыпуск Xakep, номер #017, стр. 017-092-6

Reg.WriteString('Shell Icon Size', Edit1.Text);

Form1.Close;

end;

end.


Спецвыпуск Xakep, номер #017, стр. 017-096-1, Железки под пытками: софт под хард

Железки под пытками: софт под хард

Спецвыпуск Xakep, номер #017, стр. 017-096-1

Андрей Михайлюк ака Dronich (dronich@xakep.ru)

Казалось бы - чем слинковать друг с другом такие разные понятия комповой тематики, как Hard и Soft? Кроме дров, которые позволяют железу взаимодействовать с прогами (и то с переменным успехом ;)), в голову сразу ничего не приходит. Ан нет, есть еще арсенал полезных софтин, напрямую завязанных на хардварево. Имя им - бенчмарки, или по-девелоперски - "ПО для глубокого тестирования комплектующих". Готов потестить своего железного (вернее, силиконового :)) друга? Тогда начинаем.

Притягательная сила железок

Тестирование железа таит в себе какую-то страшную тайну, заставляющую юзеров по всему миру с завидной регулярностью гонять разнообразные Bench'и на своих компах. То возникает резкое желание помериться писюками с сокурсниками, то проскакивает недоверие к продажным журналюгам (мы в их число не входим, чесслово :)), писавшим обзоры за кучку франклинов, а то и простое любопытство гложет изнутри - как там мой "аслончик" ("пень", "дурень", "целик" - нужное подчеркнуть) пашет в сравнении с гигантами мировой индустрии? Решение всех этих спонтанных проблем лежит в кабинете у психиатра... бррр, то есть в срочном скачивании и запуске всех нужных прог и развернутом тестинге любимых железяк. Кстати, о психиатрах - я тут в автобусе с собу... курсниками обсуждал преимущества "3DNow!" по сравнению с SSE, так от нас через минуту все отсели на пару метров, а на первой же остановке предпочли освободить автобус ;). Эта цивилизация для нас устарела :). Ладно, end of лирическое отступление, давай поглядим, чем можно разжиться для полномасштабного тестирования твоего компа.

Огласите весь список, пжалста!

Все подобные проги стабильно делятся на две категории по размеру - это либо узконаправленные проги (мучают только проц, например, но зато досконально), либо комплексы, которые тестят все понемножку. Мы будем юзать двух таких монстров - "SiSoft SANDRA", от которой сильно прутся в буржундии, и мои любимые "Nuts&Bolts - Discover Pro" (не сочти за рекламу, просто это наиболее универсальный комплекс как для тестирования, так и для настройки и диагностики).

Обе проги триальны и многовесны, поэтому советую качать их с www.mitino.msk.ru $) (или альтернативных урлов в твоем городе) прямо на компакте и за 70 рэ :). "Натсы" надо поискать, а вот "Сандра" обязательно будет валяться на каком-нибудь "Реаниматоре-3000". Считаем, что гигантов ты добыл, а урлы мелких прог буду подкидывать по необходимости.

Проц и память

Тестить проц - дело нехитрое. Помнится, первая моя прога на Трубо Паскале, написанная под руководством дядьки Фаронова, занималась именно этим - побольше сложных вычислений, и все дела. Только время засекай. Ни о какой стандартизации не было и речи - каждая прога тестила по шкале, придуманной создателем (моя первая трешка занимала места от 3 до 1200 баллов :) по инфе из разных источников). Это уже потом умные люди придумали стандартные тесты, которые выполнялись одинаково, и проги стали отличаться только точностью и красотой отображения результатов.


Спецвыпуск Xakep, номер #017, стр. 017-096-2, Железки под пытками: софт под хард

Железки под пытками: софт под хард

Спецвыпуск Xakep, номер #017, стр. 017-096-2

В этой теме вызов гигантам бросит софтина с незамысловатым названием "TestCPU". Несмотря на свою компактность, она умеет выводить инфу в очень удобном виде, проводить тесты на работу с памятью (2 вида), скорость вычислений (4 вида) и всеми любимые Драй- и Ветстоуны. К тому же ты можешь узнать производительность твоей тачки в MFLOPS и MIPS. Есть в ней оригинальная фича - музей процов, который начинается с трешки, с подробным описанием и фотками. Кстати, эта прога идеальна для сравнения двух (и более) конкретных компов - все результаты теста можно скинуть в инишник и перенести друзьям. Я таким макаром собрал базу на все компы ребят своей группы. А на сайте проги можно найти готовые файлы с наиболее популярными моделями компов. Что? Ах да, адрес... Все добро валяется на www.fi.muni.cz/~xsmid4.

Большие комплексы тоже любят камни. В "Натсах" ты получишь динамичное тестирование (не забудь переключиться в режим "Advanced"), когда тест идет достаточно продолжительное время, повышая точность. Единственный минус - процы для сравнения заданы жестко, и их всего четыре штуки :(. А вот "Сандра" подкачала: только два параметра - МИПСы и МФЛОПСы, хотя ассортимент камней для сравнения побогаче (но тоже фиксирован). Тест на вычисления вынесен в отдельный модуль, мало отличающийся от основного по качеству. А еще меня очень приперла иконка для бенчмарка - дымящийся проц ;). Оптимистично.

C мозгами дела обстоят похуже: "Сандра" делает только анализ связки проц-чипсет-память (это тоже неплохо, но память отдельно потестить нельзя). "Натсы" работают повеселей: проверяют скорость записи/чтения в 16- и 32-битном режимах. Но если ты хочешь получить настоящее скрупулезное тестирование памяти, готовь дискету с чистым "досом" и качай прогу "TestMem4" (testmem.nm.ru). Она не построит красивых графиков и не сравнит твои диммы с другими, но расскажет о них абсолютно все. Если ты готов довольствоваться голыми цифрами или хочешь просто проверить банки памяти по отдельности - лучше проги не найти.

Крутятся диски

Начнем с компактов - уже давно принято гонять их в "Cdspeed". Не будем отступать от традиций, так как эта софтина умеет считать почти все: от скорости чтения конкретного компакта и стабильности работы привода до подсчета времени, необходимого на разгон или выемку сидюка :). Тесты можно гонять по очереди или все сразу, во втором случае есть возможность положить исчерпывающую инфу о ЦеДероме в текстовый файл или специфический формат проги (из которого можно и загрузить данные о чужом приводе для сравнения). Кстати, недавно появилась и новая версия для ДВДшников. Богатым буратинам рекомендуется :). Обе проги брать на www.speed2000.com.

Винты тестировать сложнее по причине их сильного использования виндами. Для получения точных результатов уйдем под дос и воспользуемся "HDDspeed" (ищи на listsoft.ru). Она гоняет пяток бенчмарков и выведывает у винта всю инфу о нем. Есть возможность построения графиков (пусть под досом, но есть) и работа со S.M.A.R.T. - системой самодиагностики современных жестяков. Для смарта строятся симпотные ASCII-шкалы, показывающие степень изношенности и прочую похожую бодягу. В общем, если тебя не смущает Object Pascal'евый ифейс, качай обязательно. Для особо любопытных в комплект входят исходники.


Спецвыпуск Xakep, номер #017, стр. 017-096-3, Железки под пытками: софт под хард

Железки под пытками: софт под хард

Спецвыпуск Xakep, номер #017, стр. 017-096-3

Печальный факт - диски тестить гиганты диагностики не умеют. "Натсы" рассказали только про скорость передачи данных и поиска, а "Сандра" вообще вывела ей одной понятный "драйв-индекс". Правда, "Сандра" умеет тестить флопики ;) и сравнивать их с винтами ;))), но очень хреново - три дискетки она мне убила :(.

Мультимедиа

Знаешь, у нас никогда не возникает вопроса: "Чем тестить видюху?". Возникает другой вопрос - "А откуда качать «3Dmark»?" ;). Действительно, тесты этой проги уже давно являются негласным стандартом измерения качества видеокарт как де-факто, так и де-юре (привет декадентам). Я не стану распинаться обо всех особенностях диагностики, просто сходи на www.3dmark.com и забери свежую версию марки. Конечно, со временем она стала тяжеловесной, но какая красота разворачивается на экране при прогоне бенча! Последние редакции проги легко показывают слайд-шоу вместо мувика даже на "Geforce3" :). Иди, ставь на закачку, это самый musthave'истый mustsee ;).

Звуковуху мы тоже никак не можем оставить без внимания. Признаться, я думал, что существуют только мегапрофессиональные проги, выдающие данные частотного анализа и прочей малопонятной для неспециалиста бяки. Но нет, нашлась неплохая прога, доступно оценивающая звук, льющийся из колонок за десять гринов по всем параметрам. Зовут ее "Sound Card Analyzer" или просто "SCAn" (хомпаги нет, валяется на freeware.ru). Анализирует действительно качественно, по крайней мере мой старенький бластер оценила правильно. Отчет о проделанной работе со всеми графиками сливается в HTML-формате, где присутствуют и профессиональные характеристики карты. К проге прилагается мануал на десять листов, содержащий помимо прикладной еще и тучу теоретической инфы. Бесплатный совет - убавь громкость перед началом теста, а то на звук начавшейся акустической войны сбегутся все соседи :).

ВазЭлин КанЭц!

ИМХО, амбиции уже удовлетворены, писюк вымерен, а продажные журналисты уличены :). Отлично! Знаний мало не бывает. Теперь ты смело можешь понтоваться фразами типа "высокая производительность моего компьютера в операциях с плавающей запятой обусловлена особенностью архитектуры блока математических операций центрального процессора" перед очередной девчонкой. А что, реальная польза от тестеров :). Мотай на ус, претворяй в жизнь, пиши при необходимости, подсоблю, чем смогу.

Раньше ни о какой стандартизации не было и речи - каждая прога тестила по шкале, придуманной создателем.

"SiSoft SANDRA" умеет тестить флопики ;) и сравнивать их с винтами ;))), но очень хреново: три дискетки она мне убила :(.

Последние редакции "3dmark" (2001se) легко показывают слайд-шоу вместо мувика даже на "Geforce3" :).


Спецвыпуск Xakep, номер #017, стр. 017-098-1, ЗАМУТИ СВОЙ АВАРИЙНЫЙ CD

ЗАМУТИ СВОЙ АВАРИЙНЫЙ CD

Спецвыпуск Xakep, номер #017, стр. 017-098-1

UFO (ufo@cu-magazine.ru; www.cu-magazine.ru)

Все, что тебе нужно, - это CD-привод с возможностью записи, чистая болванка, прямые руки, загрузочная дискета и программа для записи дисков.

Если ты создал загрузочную дискету в "Windows 95" или по каким-либо причинам при загрузке у тебя не появляется CD-ROM, то придется дополнить бутявку несколькими файлами.

Некоторые люди ленятся удалять хлам, и в итоге скапливается много ненужного барахла, которое со временем начинает тормозить систему или занимать лишнее место на диске. Им поможет "HS CleanDisk Pro".

Эта программа умеет просматривать в DOS'е разные форматы графических файлов, перегонять их из одного формата в другой и даже крутить AVI-клипы!

ПОЛЬЗУЕШЬСЯ?

Даю антенну на отсечение, что тебе не раз приходилось пользоваться разными загрузочными компактами наподобие "реаниматора" или обычными дискетами - бутявками, которые с легкостью может создать любой чайник при помощи пары щелчков мыши в "Windows". Но часто на самом диске недостает каких-нибудь программ или драйверов, и тебе приходится держать рядом еще кучу компактов. Согласись, это не совсем удобно. Намного лучше создать свой диск и поместить на него все, что тебе необходимо для восстановления системы. Сегодня я расскажу тебе про то, как сотворить свой собственный загрузочный CD, и дам несколько полезных советов по выбору софта, полезного при несчастных случаях.

ЧТО НАДО

Для создания своего диска тебе понадобятся следующие предметы: CD-привод с возможностью записи, чистая болванка, прямые руки, загрузочная дискета и программа для записи дисков. Таких программ существует очень много, но самые известные - это "Adaptec Easy CD Creator" и "NERO". Они имеют практически равное количество функций, среди которых есть и функция создания загрузочных дисков. Так как мне больше по душе "Easy CD Creator", на ее примере мы и будем рассматривать процесс создания диска. Начнем?

ЗАГРУЗ-ФЛОПАРЬ

Сначала тебе будет необходимо создать загрузочную дискетку. Топай в соответствующую вкладку в окне "Установка и удаление программ", которая находится в "Панели управления". Если ты создал загрузочную дискету в "Windows 95" или по каким-либо причинам при загрузке у тебя не появляется CD-ROM, то тебе придется дополнить бутявку несколькими файлами. Сейчас я приведу тебе пример такой дискеты.

Вот список файлов, которые должны находиться на ней: Autoexec.bat, Drvspace.bin, Command.com, Keyb.com ,Format.com, Sys.com, Mode.com, Emm386.exe, Fdisk.exe, Ega3.cpi, Mscdex.exe, Aspi2dos.sys, Aspi4dos.sys, Aspi8dos.sys, Aspicd.sys, Btcdrom.sys, Btdosm.sys, Config.sys, Country.sys, Display.sys, Flashpt.sys, Himem.sys, Io.sys, Keybrd3.sys, Msdos.sys и Oakcdrom.sys.

Проверь наличие этих файлов на дискете. Если заметил, что хотя бы одного из них не хватает, то просто поищи в папке "Windows" недостающее файло. Теперь поковыряем содержимое конфигурационных файлов, так как просто наличия драйваков мало, их нужно еще и подгрузить :). Основных конфигурационных файлов всего 2:

Config.sys и Autoexec.bat. Вот пример их содержимого:


Спецвыпуск Xakep, номер #017, стр. 017-098-2, ЗАМУТИ СВОЙ АВАРИЙНЫЙ CD

ЗАМУТИ СВОЙ АВАРИЙНЫЙ CD

Спецвыпуск Xakep, номер #017, стр. 017-098-2

CONFIG.SYS

Files=20

Buffers=20

Dos=high, umb

Stacks=9,256

Lastdrive=z

Device=himem.sys /testmem:off

Device=emm386.exe ram

Device = display.sys con=(ega,,1)

Country=007,866,country.sys

Device=oakcdrom.sys /D:MSCD001

Device=btdosm.sys

Device=flashpt.sys

Device=btcdrom.sys /D:MSCD001

Device=aspi2dos.sys

Device=aspi4dos.sys

Device=aspi8dos.sys

Device=aspi8u2.sys

Device=aspicd.sys /D:MSCD001

Install=mscdex.exe /D:MSCD001 /L:R

А вот что должен содержать файл Autoexec.bat:

Set temp=c:\

Set tmp=c:\

Mode.com con cp prepare=((866) ega3.cpi)

Mode.com con cp select=866

Keyb.com ru,,keybrd3.sys

Path=a:\;r:\

Теперь попробуй загрузиться с этой дискеты, и, если ты все правильно написал, у тебя загрузится DOS вместе с CD-ROM'ом.

ВАЯЕМ ДИСК

Теперь у тебя есть нужная загрузочная дискета, с помощью которой ты можешь без проблем загрузиться. Но цель - CD-диск, созданием которого мы сейчас и займемся. Вставь дискету в дисковод и запусти "Adaptec Easy CD Creator". Установи в "CD Layout Properties" следующие параметры: ISO9660, Mode 1: CDROM и поставь отметку на "Bootable" (загрузочный). Теперь программа настроена для создания загрузного диска. После запуска записи "Easy CD Creator" потребует вставить загрузочную дискету в дисковод. Программа создаст на CD копию твоей дискеты, и загрузка с диска будет проходить так же, как и с флопаря, только намного быстрее. Но пока тебе не следует начинать запись, так как на аварийном диске должны находиться еще и утилиты, которые помогут тебе восстановить и проверить твою систему. Настало время составить подборку таких утилит.

ПЕРВЫМ ДЕЛОМ...

Для начала тебе потребуется дистрибутив "Windows". Он должен быть на диске обязательно. Лично я закатал себе все версии "Винды", начиная от "Win 3.11" и кончая "Win ME". "XP" я не переношу из-за его наглости в пожирании ресурсов. Это просто крокодил какой-то :). Все эти дистрибутивы займут у тебя примерно 320 мегов. Теперь занеси их в лист записи. Занес? Тогда поехали дальше.

АРХИВАТОР

Теперь подбираем архиватор, так как архивами пользуются все. Ты, наверняка, не исключение. На мой взгляд, самый лучший из архиваторов - "WinRAR". Если его грамотно зарегистрировать, то он будет брать практически все архивы, включая "ZIP". Степень сжатия у него тоже нехилая, так что советую тебе юзать его для архивных целей. Версия "WinRAR 2.71" стоит у меня на компе уже долгое время, и я ни разу не наблюдал сбоев. Скачать архиватор можно тут:

http://www.alexsoft.ru/images/upload/download/502/WinRAR.zip

МЕНЕДЖЕР ЗАГРУЗКИ

Не менее полезной утилитой является программа "Boot Partition". Она позволит тебе установить несколько осей на твой винт. Программа работает под DOS и весит всего 23 килобайта. Есть возможность сохранения загрузочного сектора или восстановление его из файла.

Скачать прогу можно тут:

http://stalk.newmail.ru/plagiat/bootpa22.rar

ВОССТАНОВЛЕНИЕ ИНФЫ

Самая неприятная вещь при сбоях - потеря ценной инфы. Да и не только при сбоях файло может пропадать, некоторые люди имеют свойство по ошибке удалять именно тот файл, который впоследствии оказывается катастрофически нужным. Вот для таких случаев и существуют утилиты для восстановления стертой информации. При удалении файл не затирается с диска, просто к его имени приписывается специальный символ, и файл считается стертым. Специальные утилиты выслеживают такие файлы и восстанавливают их, если, конечно, файл не затерт другим. Одной из таких программ является "Easy Recovery". Она не только способна восстанавливать файлы, но и вылечивать FAT. Скачать программу можно тут:


Спецвыпуск Xakep, номер #017, стр. 017-098-3, ЗАМУТИ СВОЙ АВАРИЙНЫЙ CD

ЗАМУТИ СВОЙ АВАРИЙНЫЙ CD

Спецвыпуск Xakep, номер #017, стр. 017-098-3

http://derstein.ru/progs/erprofus.zip

ЧИСТКА МУСОРА

Теперь переползем к менее важным для жизни, но не менее полезным программам. Вот скажи, брат, тебе часто приходится вычищать мусор после удаления программ? Знаю, что часто. Некоторые люди ленятся удалять хлам, и в итоге скапливается много ненужного барахла, которое со временем начинает тормозить систему или занимать лишнее место на диске. Вот и задумались программисты: "А не написать ли нам программку, которая сама отслеживала бы мусор и аккуратно удаляла его?". Сказано - сделано. В результате появилось множество программ, выполняющих функцию уборки мусора на винчестерах. Одна из таки программ называется "HS CleanDisk Pro". Программа отлично справляется со своей работой и написана, на мой взгляд, довольно грамотно. Все бы хорошо, но на бесплатное пользование софтинкой тебе отводится всего 15 дней, после чего программа начинает требовать регистрацию и отказывается работать. "Вылечи" ее и пихай в список.

Качать тут:

http://204.180.195.13/files/cleandiskpro2.exe

ДЛЯ УДОБСТВА

Интересно, есть еще на свете фанаты командной строки DOS'а? Может быть, но намного легче запустить какой-нибудь "NortAn Commander" или "Volkov Сommander" и лазить по папкам, не парясь набором разных команд. Так что нам просто необходим какой-нибудь файловый менеджер под ДОС для удобства похождений в его темных коридорах. Специально для тебя я откопал ссылку на дистрибутив известной ДОС оболочки - "Volkov Commander". Она, как и множество других ей подобных, является клоном "Norton Commander'а", но весит меньше. В общем, качай и пиши на свой диск, только не забудь распаковать перед записью ;).

Качать тут:

http://www.cityline.ru/vc/vc401sw.zip

ГЛАЗА В ТЕМНОТЕ

Иногда требуется просмотреть пару картинок прямо из-под голого ДОС'а, но ничего подходящего под рукой не находится. А если приспичило глянуть AVI файл, то это вообще катастрофически сложно сделать. Вот тут тебе придет на помощь очень хорошая утилита - "SEA for DOS". Эта программа умеет просматривать в ДОС'е разные форматы графических файлов, перегонять их из одного формата в другой и даже крутить AVI клипы! Жалко, что MPEG4 она не проигрывает :). Особенно полезна будет эта утилита юзерам со слабыми машинами, так как если измерить скорость выполнения программы в DOS'е и "Windоws'е" (98-ом, например) на маломощной машине, то получается, что в ДОС'е программа работает примерно в два раза быстрее. Вывод: если у тебя тормозят AVI файлы в "Виндах", то в ДОС'е они пойдут нормально.

Катать отсюда:

http://www.photodex.com/files/Sea3.ZIP


Спецвыпуск Xakep, номер #017, стр. 017-098-4, ЗАМУТИ СВОЙ АВАРИЙНЫЙ CD

ЗАМУТИ СВОЙ АВАРИЙНЫЙ CD

Спецвыпуск Xakep, номер #017, стр. 017-098-4

ДОПОЛНЯЕМ ДИСК

Скачал софтины и принял низкий старт? Не советую тебе торопиться с записью сидюка, так как на нашем диске еще осталось очень много свободного места. Не пропадать же добру! Так что будем продолжать забивать диск утилитами. Я приведу тебе пример сборки программ, которые тебе наверняка понадобятся. Конечно же, не все их можно скачать с сети, но реально найти на разного рода сборниках, которых навалом у твоих знакомых. Все ранее перечисленные утилиты в сумме будут занимать примерно 330 мегов; соответственно, у нас осталось еще примерно 320 метров.

Первое и самое большое, что можно было бы записать на компарь, - "Corel Draw 10", который занимает примерно 109 мегабайт. Я не являюсь профессионалом в графике, но когда я пробовал работать с рисунками, мне больше всего приглянулся "Corel". Но это мое личное мнение. Вместо него можешь закачать "Фотошоп", версии не ниже пятой (примерно 57 метров).

С графикой разобрались, теперь перейдем к тексту. Какой самый известный и распространенный текстовый редактор? Конечно же, "Word". Им пользуются практически все, так как он позволяет делать с текстом все что угодно, но вот заметил я недавно одну удивительную вещь - чем больше версия, тем больше глюков. Единственная версия "офиса", которой я доверяю, - 97. Займет эта софтина примерно 62 мега. Продолжая тему текстовых прог, нельзя не затронуть "Fine Reader" и "Acrobat Reader". Если ты не в курсе, чем занимаются эти программы после запуска, то я тебе объясню. "Fine Reader" - софтина для распознания текста из графического файла (скана текста). В основном используется для сканеров, но некоторые ставят его себе, даже не имея сканера. Согласись, удобно распознать качественную фотографию документа программой, чем набивать текст руками. На момент написания статьи у меня стояла пятая версия, и особых сбоев с ее стороны не наблюдалось. Весит это чудо приблизительно 17 мегабайт. "Acrobat Reader" применяется для прочтения и составления текстовых файлов PDF. В последнее время появилось очень много документов, которые для своего прочтения требуют установку именно этой проги. Весит "Акробат" примерно 6 мегов.

Теперь отвлечемся от текста и займемся переводчиками. Один из наиболее распространенных переводчиков - "WebTranSite". На мой взгляд, эта программа хорошо справляется со своей задачей, и именно ею я пользуюсь последнее время. Занимает она около пятнадцати мегабайт.

Настало время задуматься о своей безопасности. Одна из проблем защиты информации - вирусы. Долго раздумывать по поводу выбора антивируса мне не пришлось, так как самой распространенной и всеми любимой программой для охоты на вирусы является "AVP". Тебе понадобится как DOS-версия, так и виндовая. Конечно, проверять комп на наличие вирусов в ДОС'е приходится нечасто, но иногда необходимо. Обе версии займут у тебя примерно десять метров. Ну, раз затронули безопасность, то давай подумаем и о шифровании. Уже долгое время самой надежной утилитой для шифрования инфы от посторонних глаз является "PGP". Эта программа использует криптостойкие алгоритмы и умеет шифровать практически все - от почты до дисков. Несмотря на выход седьмой версии, у меня лично стоит шестая, так как в седьмой уж слишком намудрили. Дистрибутив "PGP" займет у тебя примерно семь мегов. Найти программу можно на сайте: www.pgpi.com.


Спецвыпуск Xakep, номер #017, стр. 017-098-5, ЗАМУТИ СВОЙ АВАРИЙНЫЙ CD

ЗАМУТИ СВОЙ АВАРИЙНЫЙ CD

Спецвыпуск Xakep, номер #017, стр. 017-098-5

РАЗВЛЕКУХА

Перейдем теперь к развлекухе, а вернее сказать, к прогам, необходимым, чтобы ее забацать. Практически все современные игры требуют обязательного присутствия на компьютере "DirectX'а". Вот его, родимого, мы и закатаем на наш диск, дабы не рыскать потом по знакомым после очередного полета системы. Обязательно хотел бы подметить выбор версии. Никогда не ставь восьмую версию! Это самоубийство! Разработчики, наверное, сильно поторопились с выходом новой версии. "DirectX 8" уж слишком глюкавый, а что самое противное - удалить его проблематично. Просто наложить седьмую версию на восьмую у тебя не получится, так как программа считает, что нет необходимости менять новую версию на более старую. Умная больно! Так что лучше поставь седьмой "DirectX" и не парься. Дистрибутивчик займет у тебя всего 6 мегов. Теперь для полного счастья осталось только выбрать музыкальный софт. И опять же долго думать мне не пришлось (тупею, да!). Самой лучшей программой для прослушивания музыки на сегодняшний день была и есть всем известный "WinAmp". Мне остается только напомнить тебе ее примерный размер - два метра.

СЕТЬ

А теперь перейдем к выбору софта для комфортной работы в сети. На мой взгляд, человек, находящийся в нете, большинство времени проводит в серфинге по сайтам. Уже давно всем известно, что "IE" является не лучшим браузером для серфинга. Конечно же, каждый пользователь придерживается своих взглядов в выборе браузера, но я хотел бы посоветовать тебе юзать "Opera". Как считают разработчики, да и я тоже к ним присоединяюсь, "Opera" является самым быстрым браузером. Если не веришь, попробуй сравнить ее с другими прогами ее класса и увидишь, что работать в "Опере" намного удобнее и быстрее. Весит это удовольствие всего девять мегабайт. С браузером разобрались, теперь осталось выбрать качалку. Уже долгое время я использую "GetRight", который меня устраивает по всем параметрам. У "GetRight'а" есть множество полезных функций, например, разбивка файла на много частей и одновременная их закачка с альтернативных серверов. Конечно, все достоинства "Гетрайта" я рассказывать тебе сейчас не буду, а лучше просто посоветую тебе установить его на свою машину и разобраться хотя бы в части его функций. Я уверен практически на 100%, что ты не разочаруешься. Весит это удовольствие примерно два метра. Продолжим тему закачки. Если у тебя есть своя страничка в сети или ты только собираешься ее делать, то я посоветую тебе нарыть и поместить на компакт замечательную программу "CuteFtp". Эта софтина имеет множество возможностей и функций для работы с ftp. Весит она всего около двух мегабайт.

С качалками разобрались. Теперь давай выберем программы для общения с народом. Самый распространенный способ On-line общения - IRC и ICQ. Для IRC я посоветовал бы тебе "RusMIRC", последнюю версию которой ты сможешь скачать на сайте www.irc.ru. С ICQ дело обстоит сложнее, так как каждому юзеру нравится что-то свое. Кому-то более удобно пользоваться "ICQ 2000", а кому-то - "ICQ 2001". Лично я предпочитаю "ICQ 2001". Весит "Ася" в сумме с клиентом IRC примерно 5 мегов. И закрывает тему интернет-софта почтовый клиент вампирских кровей - "The Bat". В этот раз я не буду утверждать, что "Bat" лучше "OutLook'a", чтобы не нервировать оппозицию, хотя и очень хочется :). Исходя из того, что мне лично больше нравится "Батник", я посчитал нужным посоветовать тебе использовать именно его для своих почтовых целей. Весит "The мышь" всего 5 метриков.


Спецвыпуск Xakep, номер #017, стр. 017-098-6, ЗАМУТИ СВОЙ АВАРИЙНЫЙ CD

ЗАМУТИ СВОЙ АВАРИЙНЫЙ CD

Спецвыпуск Xakep, номер #017, стр. 017-098-6

Напоследок хотел бы посоветовать тебе поместить на твой Супер-CD замечательную программу для тестирования железа - "SiSoft Sandra Pro". Это очень мощный инструмент для проверки твоей системы. Софтина тестирует практически все, кроме коврика. Несмотря на все свои достоинства и огромное количество разнообразных тестов, "SiSoft Sandra" займет у тебя всего 3 мега.

ЗАЖИГАНИЕ

Вот и подобрался софт для твоего супердиска. Конечно же, у каждого получится своя модификация, так как каждому нравится свое, но иногда довольно сложно бывает вспомнить все, что тебе необходимо для работы. Часто бывает, что при записи аварийного диска на него пихаются совершенно ненужные программы, а потом оказывается, что самого нужного софта нет, зато есть куча мусора. И ничего уже не поделаешь. Надеюсь, я хотя бы немного облегчил тебе процесс создания твоего личного компакта. Будут вопросы, заходи на канал "Спеца" - #spez, на русском далнете. Мы тебе обязательно поможем :). Привет тебе из далекого космоса!


Спецвыпуск Xakep, номер #017, стр. 017-102-1, СОФТ КРЯКЕРА

СОФТ КРЯКЕРА

Спецвыпуск Xakep, номер #017, стр. 017-102-1

Roman AKA Docent (romanakadocent@mail.ru)

Не по-хацкерски это - платить... А свеженький и хороший софт мы с тобой тем не менее очень любим.

Разработчики ведь тоже не дураки, про все эти кряки-хрюки чего-то да знают и поэтому стараются как можно лучше защитить свои творения от шаловливых ручек и любопытных глазок вездесущих крякеров.

Подавляющее большинство программ, которые ты покупаешь на MITINO-BAZARR, были «обработаны» именно Soft Ice'ом (по крайней мере, без него точно не обошлось).

С помощью Magic Trainer Creator ты сможешь круто изменить ход игры и гаматься по своим собственным правилам.

Тебе придется хотя бы немного освоить ассемблер и некоторые функции Windows. А кто сказал, что будет легко?

Если вы хотите читать эту статью дальше, зарегистрируйтесь и вышлите нам $30. Сейчас вы читаете ее в неполном демонстрационном режиме. После оплаты и регистрации вам будут доступны все абзацы этой статьи...

Ну, тише, тише, не спеши швырять журнал в окно и писать жалобы редакторам - насчет регистрации это я, конечно, пошутил. А вот разработчики софта шутить не намерены, и приходится нам, скачав свежую софтину из сети, либо отдавать за нее свои денежки, либо расставаться с ней по истечении демонстрационного срока. Ну, или, в зависимости от жадности софт-мейкера, юзать ее в урезанном варианте и наблюдать через некоторые промежутки времени назойливые сообщения (NAG-Screen) с просьбами все же поиметь совесть и заплатить за программу. Конечно, программисты тоже люди, и кушать им периодически хочется, но, как ты знаешь, денежки наши имеют свойство очень быстро заканчиваться, и лишнее N-ное количество долларов, ограниченное опять-таки только жадностью разработчика, у нас с тобой вряд ли найдется. Да и не по-хацкерски это - платить, а свеженький и хороший софт мы тем не менее очень любим. На известной всем Асталависте не всегда можно найти ключик к новой проге, особенно если она какая-нибудь экзотическая. Придется поломать самому. Если ты это уже давно умеешь делать, то хорошо, а вот если ты новичок в крякерстве, тогда я тебе и расскажу, с помощью каких программ можно убрать все эти глупые напоминания о регистрации, сделать из demo и shareware самый настоящий и полноценный freeware. Конечно, это всего лишь обзор инструментов, а не инструкция по эксплуатации, так что, если хочешь освоить эти программы и стать крутым крякером, без особого труда сможешь найти нужную тебе информацию в Инете. Но о ресурсах мы поговорим позже.

СЕМЕЙСТВО КРЯКЕРОВЫХ

Итак, тебе понадобится несколько типов прог. Это отладчики (debugger), позволяющие наблюдать в ассемблерном виде за работой программы во время ее выполнения и вмешиваться в этот процесс, редактируя команды и добиваясь нужного результата; дизассемблеры (disassembler), приводящие запускаемый файл программы или библиотеку к ассемблерному виду; шестнадцатеричные редакторы (hex-editor), в которых ты сможешь найти и отредактировать любой байт, найденный ранее с помощью дизассемблера. Иногда еще может понадобиться программа-шпион API-функций, с помощью которой можно отследить, например, недоступную для нажатия кнопку или поле ввода в незарегистрированной программе, узнать ее адрес, а потом, изменив определенные байты по этому адресу, сделать доступной. Если собираешься ломать еще и игры, то нужно, помимо этих программ, надыбать проги для отлова адресов и меняющихся значений.


Спецвыпуск Xakep, номер #017, стр. 017-102-2, СОФТ КРЯКЕРА

СОФТ КРЯКЕРА

Спецвыпуск Xakep, номер #017, стр. 017-102-2

ТРЕПАНАЦИЯ

Soft Ice v 4.05

Размер: 5,9 Мб

Это, пожалуй, самый известный и единственный на сегодняшний день универсальный и многофункциональный инструмент для исследования программ. Изначально он был создан и предназначен для программистов, отлаживающих свои программы, но, так же как и созданные для сисадминов проги удаленного администрирования превратились в трояны и были применены хакерами для неправомерного доступа к информации, так и этот замечательный отладчик успешно нашел свое применение в руках крякеров. Подавляющее большинство программ, которые ты покупаешь на MITINO-BAZARR, были «обработаны» именно им (по крайней мере, без него точно не обошлось). Отладчик грузится прямо перед Windows и позволяет получить полный контроль над всеми процессами, происходящими в программе, и, при необходимости, отредактировать код. Таким образом, можно, например, запретить программе постоянно выводить напоминание о регистрации или отменить проверку серийного номера, так что любой введенный номер прога будет воспринимать как правильный. При взломе игр Soft Ice тоже пригодится: с ним ты сможешь заставить какой-либо параметр не меняться. Применений этому отладчику можно найти массу. Это очень мощный инструмент, который может тебе заменить несколько разных крякерских программ. Но он довольно сложный. Без хотя бы начальных знаний ассемблера, команд процессора и функций Windows тут не обойтись. А ты как думал? Знание - сила! Даже его внешний вид, чем-то напоминающий фильм «Матрица», вначале может отпугнуть новичка. Наверху у него располагаются раздел регистров и поле, в котором можно редактировать шестнадцатеричный код, в середине ты видишь ассемблерный код исследуемой программы и внизу поле для ввода команд отладчика. К сожалению, я не могу показать тебе скриншот, так как, когда отладчик запущен, - он полностью блокирует доступ ко всем другим программам и к самой оси. Да ты и сам можешь скачать и посмотреть.

ВСКРЫТИЕ ПОКАЖЕТ...

W32Dasm v 8.93

Размер: 867 Кб

Это тоже достаточно известный инструмент. С ним ты можешь взять любой запускаемый файл программы или библиотеку и посмотреть ее ассемблерный текст. Отредактировать в нем ты, конечно, ничего не сможешь, зато вот по какому адресу находится команда, отвечающая, скажем, за вывод сообщения о том, что ты ввел серийный номер неправильно, и где находится команда, выводящая сообщение об успешной регистрации, - это запросто. Для этого там предусмотрено специальное меню, где ты можешь увидеть все сообщения, которые пишутся в окнах и диалогах программы, и даже не только сообщения. Потом уже ты можешь найти все эти адреса в каком-нибудь hex-редакторе и заставить программу проглатывать любой введенный серийный номер. А иногда удается найти даже реальный серийный номер. Например, у меня как-то получилось с помощью этой программы найти ключ от диска с игрой, который почему-то забыли написать на коробке. Во как!


Спецвыпуск Xakep, номер #017, стр. 017-102-3, СОФТ КРЯКЕРА

СОФТ КРЯКЕРА

Спецвыпуск Xakep, номер #017, стр. 017-102-3

В этой софтине ты также найдешь некоторое подобие шпиона API-функций и сможешь с его помощью увидеть, где какая функция вызывается, а так же hex-редактор.

В программу встроен и собственный отладчик, но разобраться с ним до конца я так и не смог и по-прежнему использую старый добрый Soft Ice.

Hacker's View v 5.60

Размер: 164 Кб

Это тоже дизассемблер, но с куда более широкими возможностями в плане редактирования. Тут не только дизассемблер, но и hex-редактор. Программа имеет ДОСовский интерфейс, но работает под Windows. Единственный минус этой проги - это то, что в ней, как и в W32Dasm, нельзя найти диалоги и сообщения программы. Зато можно смотреть и редактировать программу как в ассемблерном, так и в шестнадцатеричном и даже ASCII виде. Так что эта программа отлично дополнит W32Dasm и Soft Ice. В любом случае рекомендую тебе держать под рукой оба этих дизассемблера.

MATRIX HAS YOU

Hex Workshop v 2.54

Размер: 746 Кб

В этой программе ты можешь редактировать шестнадцатеричный код программы. С левой стороны, как и полагается, ты видишь непосредственно сам код, а справа - ASCII-код. С hex-редактором ты сможешь отредактировать нужные тебе байты, которые ты отловил с помощью отладчика или дизассемблера. Больше тут особо ничего не скажешь: hex-редактор он и есть hex-редактор. Просто этот наиболее известный и удобный. Я использую только его.

МЕНЯ ЗОВУТ БОНД, ДЖЕЙМС БОНД

Apis 32 v 2.5

Размер: 230 Кб

Это типичный API-шпион. Софтина позволяет следить за вызовом API-функций. В ней ты можешь указать запускаемый файл исследуемой программы, а затем наблюдать за всеми API-функциями, с которыми она работает. Также можно просмотреть, какие функции, из каких библиотек Windows запускаются. Единственный минус - прога весьма глюковата. Впрочем, не думаю, что эта прога так уж жизненно необходима, чаще всего можно обойтись и без нее, но иногда бывают такие случаи, что такая софтина может здорово облегчить тебе процесс взлома.

А НЕЛЬЗЯ ЛИ ПРОЩЕ?

InqSoft Sign of Misery v 1.4

Размер: 669 Кб

Понимаю, я тоже не сразу до всего этого дорубился. И, разумеется, у тебя возник вопрос, а нельзя ли без этих навороченных прибамбасов? Чтобы нажал кнопочку «Hack It», и все твои Shareware, Evaluation и Demo тут же стали Registered без всяких там фокусов и уж, конечно же, без оплаты. В этом случае у меня для тебя две новости: хорошая и плохая. Хорошая - можно совершить незамысловатый кряк программы без дизассемблеров и отладчиков, а плохая - одной кнопкой сломать все-таки не получится. Итак, все это ты можешь осуществить с помощью InqSoft Sign of Misery. В ней ты можешь совершить некоторые действия по удалению NAG-screen'ов, устранить ограничение времени использования или количества запусков, подобрать серийный номер и даже русифицировать программу. Кроме всего этого, прога позволяет создать свой собственный патч на основе оригинального и модифицированного твоими шаловливыми ручонками EXE-шника. И это далеко не полный список возможностей программы. Но все же на серьезный хак не рассчитывай. Все-таки такие программы еще не дошли до того уровня, чтобы все сделать за тебя, так что придется тебе самому пошевелить извилинами. Да и, сам понимаешь, не по-хацкерски это как-то.


Спецвыпуск Xakep, номер #017, стр. 017-102-4, СОФТ КРЯКЕРА

СОФТ КРЯКЕРА

Спецвыпуск Xakep, номер #017, стр. 017-102-4

КОЕ-ЧТО ОБ ИГРОВОМ ВЗЛОМЕ

В игровом взломе эти программы также пригодятся, но, поскольку ломать там приходится всего лишь какие-то параметры, вроде лайфбаров или количества каких-либо ресурсов (патроны, еда, етц), то их значения нужно отслеживать с помощью специальных программ, а потом найденные адреса обрабатывать в Soft Ice и блокировать, чтобы они не менялись. Хотя игровой взлом - тема отдельной статьи, которая неоднократно поднималась в нашем журнале, но про одну программу я тебе расскажу.

Magic Trainer Creator v 1.27

Размер: 1,7 Мб

Это всем известная программа, которую ты наверняка знаешь (как-никак не одна статья по ней написана). Она позволяет отлавливать в играх изменяющиеся величины, такие как жизнь, количество каких-нибудь ресурсов и прочее. Затем ты можешь эти значения менять, замораживать или работать с ними далее в Soft Ice. Также эта программа позволяет сделать и трейнер. Таким образом, ты можешь круто изменить ход игры и гаматься по своим правилам. К сожалению, Magic Trainer Creator работает только в Windows 9x и пахать в NT, 2000 и XP не будет. Лично я вообще предпочитаю проводить всякие крякерские мероприятия под Win 98, так как новые версии Маст Дая почему-то запрещают копаться в памяти.

ГДЕ ВЗЯТЬ?

Ах, ну конечно, вот тебе несколько ссылок, на которых ты найдешь не только эти, но и множество других прог для крякинга. Это http://linux20368.dn.net/protools/ - там просто море софта! Автоматический крякатель InqSoft Sign of Misery лежит на www.cybermaniac2k.chat.ru. И еще, пожалуй - www.gamehacking.com, там есть описываемые тут программы, но так как сайт посвящен игровому взлому, то там же имеется богатый арсенал прог для копания в играх.

Если тебе недостаточно того, что я тебе порекомендовал, или ты считаешь, что существуют более удобные и функциональные проги, то ты всегда сможешь найти их и сам, воспользовавшись astalavista.box.sk или банальной altavista.com.

НУ, СКАЧАЛ Я, А ЧТО МНЕ ДАЛЬШЕ-ТО ДЕЛАТЬ?

А дальше тебе придется хотя бы немного освоить ассемблер и некоторые функции Windows. А кто сказал, что будет легко? Это тебе не в Counter Strike париться. Хотя, если привыкнуть, не все так уж и трудно. Просто поищи в Интернете разную инфу - там этого добра навалом. Ну а я только могу тебе посоветовать отличные ссылки, на которых я сам много чего почерпнул. Первая - это www.reversing.net, русский ресурс, на котором очень много всякой инфы о крякинге. А вторая - снова www.gamehacking.com, англоязычный сайт, посвященный, как это видно из названия, игровому взлому, но на самом деле там есть сведения, которые относятся и к общим вопросам крякинга программ.

И не забывай, некоторые программы практически невозможно (или просто очень сложно) сломать. Разработчики ведь тоже не дураки, про все эти кряки-хрюки чего-то да знают и поэтому стараются как можно лучше защитить свои творения от шаловливых ручек и любопытных глазок вездесущих крякеров. Но, как говорится, на каждую хитрую задницу, найдется чего-то там (вырезано цензурой) в виде штопора. Так что читай побольше и практикуйся. Удачи, крякер!


Спецвыпуск Xakep, номер #017, стр. 017-106-1, БОЛЬШОЙ ШКОДИНГ, ИЛИ ВЫБИРАЕМ СРЕДСТВО РАЗРАБОТЧИКА

БОЛЬШОЙ ШКОДИНГ, ИЛИ ВЫБИРАЕМ СРЕДСТВО РАЗРАБОТЧИКА

Tony (tony@nifti.unn.ru)

Спецвыпуск Xakep, номер #017, стр. 017-106-1

Сегодня программный код пишется для всего - начиная с вибраторов и кончая японскими туалетами и джакузи.

Я знаю полно людей, которые ни ухом ни рылом ни черта не понимают (и, видимо, уже никогда не поймут) в инкапсуляции, наследовании, полиморфизме, но тем не менее вот уже пять лет колбасятся на VC++ (привет группе 554 ННГУ).

Задачи, которые можно эффективно решить с помощью VB, это те задачи, которые крайне геморроидально решаются на VC++.

Каждый раз, как я сталкиваюсь с базами данных, мне хочется найти Билли, пристрелить его, изнасиловать труп, тушку повесить на стену до полного высыхания, потом сжечь ее и пепел развеять по ветру.

Среда разработчика VC++ предъявляет к пользователю достаточно серьезные требования как в знании самого языка С++, так и в понимании основных концепций Windows.

Visual C++ самое демократичное и универсальное из всех представленных сегодня на рынке средств разработки. Хотя бы потому, что изначально эта среда предназначалась для разработки системного софта и библиотек.

Delphi - отличное средство для разработки прикладного софта, обладающее для этого всеми необходимыми характеристиками: быстрота и удобство реализации пользовательских интерфейсов, широкий выбор элементов управления, тотальная визуальность, наконец.

Ты уже научился шкодить? Нет, я имею в виду не смотреть с умным видом на шестнадцатеричный дамп кваки, а писать самые настоящие программы. Научился или не научился - другой вопрос, самое главное - это хотеть, и если желание есть, то можно даже рано или поздно стать маленьким (а может быть, и большим) Биллом. Правда, в этом случае тебе лучше не попадаться нам в руки :).

Федя, дичь...

Ну, начнем, конечно, с виндузы. Под ней большинство из нас сидит, под ней, видимо, и умрет :). Вот ведь интересная какая вещь - уж больше грязи, чем на виндузу, ни на кого еще не выливали, но тем не менее пользуем ее все поголовно, кроме самых упертых никсоидов. Если у тебя есть желание что-то разрабатывать, то одним из самых первых для тебя возникает вопрос: "А в чем же разрабатывать? Ведь существует просто куча всяких девелоперских сред и оболочек, не говоря уж о банальном ассемблере". Не волнуйся, Х-крю тебе поможет.

БОЙ В СУПЕРТЯЖЕЛОМ ВЕСЕ

Microsoft, Borland, Sun, IBM, Oracle, Intel, AMD... Каждый из этой веселой компашки мировых монстров имеет оборот гораздо больше, чем бюджет нашей страны, и дерутся они из-за каждого куска хлеба, обильно смазанного черной икрой. Частично от этого мы имеем свои дивиденды, а частично и страдаем. Плюсы от этой грызни - широкий выбор технологий, конкуренция, а следовательно, постоянный прогресс и снижение цен. Минусы - большое многообразие стандартов, несовместимость, а следовательно - гимор. Сегодня программный код пишется для всего - начиная с вибраторов и кончая (oops, I did it again) японскими туалетами и джакузи. Возникает необходимость повышать производительность труда программеров без ущерба производительности софта. Аки гады из-под коряги вылезают новые языки, CASE и RAD средства, исполняющие платформы (Java, .Net). Тем не менее, как это ни странно, до сих пор большинство софта пишется в трех средах - это Visual C++, Delphi и Visual Basic 6.0. Почему это происходит? Почему программеры дружно не набрасываются на новомодные прибамбасы? Да все очень просто - устаканьте, господа монстры, ваши разногласия как в стандартах, так и в концепциях, дайте нам вместо десятка идеологий - одну комплексную, вмещающую в себя как новые идеи, так и все то, ради чего мы используем уже достаточно устаревшие 3GL языки.


Спецвыпуск Xakep, номер #017, стр. 017-106-2, БОЛЬШОЙ ШКОДИНГ, ИЛИ ВЫБИРАЕМ СРЕДСТВО РАЗРАБОТЧИКА

БОЛЬШОЙ ШКОДИНГ, ИЛИ ВЫБИРАЕМ СРЕДСТВО РАЗРАБОТЧИКА

Tony (tony@nifti.unn.ru)

Спецвыпуск Xakep, номер #017, стр. 017-106-2

В КРАСНОМ УГЛУ РИНГА - VISUAL C++

VC++ входит в состав огромной девелоперской среды MS Visual Studio (MSVS). Кроме сабжа, здесь еще тусуются с приставкой Visual: Java, Interdev (используется для разработки интернет-файлов: html, xml, asp и прочих), Fox Pro (для работы с базами данных), Basic (о нем чуть ниже) и куча утилей. Впрочем, речь не о них, а именно о VC++. Возможно, фанаты Delphi сейчас скривятся в кислой гримасе и побегут за тухлыми яйцами и гнилыми помидорами. Тем не менее я обязан перечислить достоинства VC++ (тем более, что за это мне платят деньги, и к несчастью, пока только редакция... ау!.. Билли! :))

БОЧКА МЕДА

Visual C++ - самое демократичное и универсальное из всех представленных сегодня на рынке средств разработки. Хотя бы потому, что изначально эта среда предназначалась для разработки системного софта и библиотек. С его помощью разрабатываются абсолютно все громадные проекты, такие как MS Office, всевозможные игры, сервера, компоненты и так далее. Любая фирма, которая занимается разработкой чего-либо крупного (исключая базы данных, но об этом чуть позже), требует при найме на работу обязательное знание VC. Программер сам волен выбирать, как ему работать - среда относится к этому монопеннисуально. Можно использовать MFC, а можно и не использовать и обращаться напрямую к функциям win32 API; линковку можно осуществлять как статически, так и динамически - это по барабану, mfc42.dll есть теперь в любой виндузе. Можно опускаться на самый нижний уровень, разрабатывая критические к скорости исполнения участки кода на ассемблере, используя инструкции MMX, SSE и 3DNow!, обращаясь напрямую к нужной области памяти, а можно работать и на уровне COM-интерфейсов, полностью абстрагируясь от платформы. Большинство библиотек, не входящих в MSVS, разрабатывается на Си* и в своей поставке, соответственно, имеет Си*'шные заголовочные файлы и шаблон библиотеки (lib); портирование для пасквиля либо вовсе не осуществляется, либо осуществляется позднее, а в худшем случае - вообще сторонними разработчиками. В нормальных условиях набора стандартных элементов (Common Controls) управления достаточно для реализации пользовательского интерфейса. Если не хватает - к услугам девелопера пара сотен элементов управления ActiveX или возможность самому разработать нужный ему уникальный контрол. Что-то хочешь сказать? А, ну да, инкапсуляция, наследование, полиморфизм... как все это сложно - VC++ не удобен для прикладного программирования. Бред! Я знаю полно людей, которые ни ухом ни рылом ни черта не понимают (и, видимо, уже никогда не поймут :( ) в этих трех терминах, тем не менее вот уже пять лет колбасятся на VC++ (привет группе 554 ННГУ). Но если серьезно, то, действительно, для нормальной работы эта среда разработчика предъявляет к пользователю достаточно серьезные требования как в знании самого языка С++, так и в понимании основных концепций Windows. Системная ориентированность среды накладывает серьезный отпечаток обуви 46-го размера на работе, и в основном пользователю приходится взаимодействовать с кодом. В общем, все это на самом деле вторично, а первично то, что С++ является системным стандартом виндузы, а object pascal (я имею в виду, конечно, Delphi и косвенно C++ Builder) таким стандартом не является и, видимо, являться уже не будет никогда. Ну да ладно, шоколада хватит, пора подавать другое вещество такого же цвета...


Спецвыпуск Xakep, номер #017, стр. 017-106-3, БОЛЬШОЙ ШКОДИНГ, ИЛИ ВЫБИРАЕМ СРЕДСТВО РАЗРАБОТЧИКА

БОЛЬШОЙ ШКОДИНГ, ИЛИ ВЫБИРАЕМ СРЕДСТВО РАЗРАБОТЧИКА

Tony (tony@nifti.unn.ru)

Спецвыпуск Xakep, номер #017, стр. 017-106-3

ЛОЖКА ДЕГТЯ

Что там скрывать, не год и не два я колбашусь в VC++ - во-первых, он лучше всего подходит для решения стоящих передо мной задач (разработка системного софта), а во-вторых, он является корпоративным стандартом той организации, где я работаю, что тоже немаловажный фактор. Тем не менее каждый раз, как я сталкиваюсь с базами данных, мне хочется найти Билли, пристрелить его, изнасиловать труп, тушку повесить на стену до полного высыхания, потом сжечь ее и пепел развеять по ветру. Нет, серьезно, того человека, который изобрел этот маразм (ODBC, DAO и ADO) убить действительно мало. Кто с этим работал, тот меня поймет. А восприятие этими мелкомягкими технологиями только курсорных методов обращения к СУБД вообще граничит с безумием. Не говоря уже о том, что DBGrid существует только в виде ActiveX элемента, который надо заполнять данными самостоятельно. Желая переложить тяжесть взаимодействия с СУБД на разработчиков драйверов, M$ преподнесла всем медвежью услугу. Если ты не разделяешь этих взглядов, напиши нам в Х-крю, мы отправим тебя на всемирную выставку железобетонных меланхоликов как самого стойкого человека в этом мире.

В СИНЕМ УГЛУ РИНГА - DELPHI

Когда на рынке стали появляться сабжи ранних версий (2 и 3), многие программеры довольно скептически косились в их сторону примерно с таким выражением лица: "Кодируете? Ну-ну...". Сегодня Delphi воспринимается как отличное средство для разработки прикладного софта, обладая для этого всеми необходимыми характеристиками: быстрота и удобство реализации пользовательских интерфейсов, широкий выбор элементов управления, тотальная (я бы сказал - тоталитарная) визуальность, наконец. Заготовку для любой софты можно сделать, вообще не прикасаясь к коду. О работе с базами данных стоит сказать отдельно - просто великолепно. Ты можешь обратиться к БД проще, чем два пальца... при этом с кодом взаимодействия практически нет. Самая потрясающая при этом вещь - это то, что выбранные из СУБД данные можно просмотреть уже в процессе программирования, а не в рантайм, интерактивно проверяя правильность SQL-запросов. BDE (для тех, кто в танке, это Borland DataBase Engine) при этом скрывает от пользователя ужасы ODBC. SQL Explorer - просто няма какая-то. Именно поэтому все фирмы, специализирующиеся на СУБД, разрабатывают весь свой софт на Delphi, будь то... ну, допустим, мастдайная клиентская часть Informix сервера под UNIX или полностью клиент-серверное решение под виндузу, благо сейчас сабж это позволяет.


Спецвыпуск Xakep, номер #017, стр. 017-106-4, БОЛЬШОЙ ШКОДИНГ, ИЛИ ВЫБИРАЕМ СРЕДСТВО РАЗРАБОТЧИКА

БОЛЬШОЙ ШКОДИНГ, ИЛИ ВЫБИРАЕМ СРЕДСТВО РАЗРАБОТЧИКА

Tony (tony@nifti.unn.ru)

Спецвыпуск Xakep, номер #017, стр. 017-106-4

Впрочем, хватит петь дифирамбы. Настало время пнуть и Delphi пару раз ногой в живот.

Приятель, ты не поверишь, но все свои тумаки Borland получает именно за простоту и желание сделать как лучше. Они хотели предоставить разработчику модифицированный вариант языка 3GL, который сочетал бы в себе простоту и надежность (имеется в виду доступ к памяти), что позволило бы избежать характерных проблем, возникающих при разработке на C++. А кроме того, язык должен был предоставлять программеру те же возможности, что и С++. А в итоге и от характерных ошибок С++ не избавились, и возможности, предоставляемые Delphi, хотя и "дублируют" С++, но до его уровня не дотягивают.

ВОКРУГ РИНГА БЕГАЕТ VB

А что же Visual Basic? А это уже другая песня. И с помощью этого средства разработки решаются совершенно другие, очень специфические задачи. VB обладает крайне тривиальным (попросту тупым) языком, сводящим на нет все возможности программера заставить программу осыпаться на ошибке доступа без использования внешних глючных компонент. Одно слово - BASIC. Пинать VB как самостоятельное средство разработки можно бесконечно долго - слабая производительность, о мультиплатформенности даже не стоит заикаться, отсутствие возможностей нормальной отладки. И это только верхушка айсберга. Обычно VB используется в паре с VC++ либо другими мелкомягкими продуктами (в частности VB в Office играет роль быстрого средства связи между различными компонентами). Задачи, которые можно эффективно решить с помощью VB, это те задачи, которые крайне геморроидально решаются на VC++. Например, один мой знакомый пишет на VB автоматизированное тестирующее приложение для своей MFC'шной софтины. И действительно, в VC++ можно заработать хронический мозговой геморрой, прежде чем такое реализуешь.

Alter_Zone

Хотели мы сначала рассказать тебе обо всех средствах разработчика понемногу - как бы с миру по нитке. Но что толку? Все равно самыми доступными, обладающими хорошей русской документацией (и туевой хучей книг) остаются три перечисленные среды. Из всех оставшихся стоит упомянуть только Intel C++ compiler, разрабатываемый сам понимаешь кем. Он используется в том случае, когда необходимо создать приложение, целиком оптимизированное под самые последние камни. Это дорогой, но постоянно обновляющийся продукт, и тебе его вряд ли имеет смысл использовать - на рынке брать не стоит, а в "магазине" цены на него кусаются (правда, если у тебя есть знакомые, которые работают в Intel, - проблем нет, бери, пригодится). Да, кстати, я пока ни словом не обмолвился о C++ Builder. Это просто потому, что все слова, сказанные о Delphi, справедливы и для него.

ВЫБИРАЕМ

Итак, я надеюсь, что к этому моменту требования к твоему будущему программному продукту, который ты создашь, уже сформировались; ты знаешь, что это будет за софт и что он будет делать. В любом случае, если ты собираешься связать свою жизнь с разработкой ПО, то тебе просто необходимо знакомство с большинством современных средств девелопера. Если ты вообще новичок в программировании, то, не задумываясь, начинай с Delphi, потом, если потребуется, для перехода на VC++ у тебя будет неплохой задел. Если ты хочешь уделить основное время разработки программированию ну... эээ... какого-нибудь математического алгоритма или физической модели, в общем, прикладному программированию - твоя дверь синего цвета, и на ней написано Delphi. Туда и только туда стучись в случае разработки баз данных. Вообще, если твой выбор Borland, то выбирай только Delphi; C++ Builder - это просто гибрид дельфи и С++, помесь бульдога с пылесосом, в общем - отстой. Ну и, наконец, в том случае, если ты серьезно решил заняться девелопингом и твоя софта гораздо сложнее, чем пара тапочек, а папочку с ее проектом не может поднять чемпион мира по гиревому спорту, твой выбор однозначен - Visual C++. С тяжелыми заболеваниями системного плана, прошу стучаться туда же.


Спецвыпуск Xakep, номер #017, стр. 017-106-5, БОЛЬШОЙ ШКОДИНГ, ИЛИ ВЫБИРАЕМ СРЕДСТВО РАЗРАБОТЧИКА

БОЛЬШОЙ ШКОДИНГ, ИЛИ ВЫБИРАЕМ СРЕДСТВО РАЗРАБОТЧИКА

Tony (tony@nifti.unn.ru)

Спецвыпуск Xakep, номер #017, стр. 017-106-5

ПАРА СЛОВ О ПИНГВИНАХ

С пингвином дело обстоит гораздо проще :). В Линухе средств разработки aka языков программирования до балды. Но, как ни странно, выбрать себе фаворита - раз плюнуть. На каком языке написана и поставляется вся система? Правильно - на Це. Значит, какой компилятор нужно заюзать? ГеЦеЦе (с мухой не путать :). Истинного мастдайщика и поклонника визуальных методов разработки от консоли и полуночного командира, естественно, не пропрет, но вот kdeveloper ему придется по вкусу. Если ты колбасился под виндузой в VC++, то твоя адаптация к kdeveloper'у займет примерно минут пять. Он действительно похож как две капли воды на VC++ 5.0. На самом деле KD это просто оболочка, которая использует в качестве компилятора и линковщика g++. Вместе с ним (KD) идет неплохая документация начального уровня по языку ANSI C, разработке KDE- и QT-приложений. Естественно, конструктор диалогов и дубаггер тоже имеются в наличии. Кроме KD, есть еще две оболочки KDEStudio и Anjuta, в общем-то, сильно смахивающие на него. Лично я выбрал для себя kdeveloper - его разрабатывает большая серьезная команда, он неплох в работе, долбаггер тоже хорош (когда я подселял к себе пингвина, честно говоря, даже не надеялся встретить там нормальные визуальные средства отладки). Документация выполнена достаточно качественно (правда, рядом с MSDN она все равно выглядит как грязный голодный котенок на выставке персидских котов). Ну не кидайте в меня помидорами, просто у меня нет времени думать о сигнатуре стандартных системных функций и перелистывать туда-сюда man-страницы, я хочу видеть эту инфу перед глазами, когда она нужна, а поэтому хочу контекстную подсказку, вы слышите, ка-девелоперы? Сайт команды KD сделан тоже вполне качественно, есть даже поддержка русского языка. Любителей Delphi пингвин тоже не разочарует - есть Kylix. На самом деле это тот же Delphi, только под линухом. А, следовательно, болезни у него все те же, что и в виндузе, причем они усугубляются четкой системной ориентированностью пингвина на Це.


Спецвыпуск Xakep, номер #017, стр. 017-106-6, БОЛЬШОЙ ШКОДИНГ, ИЛИ ВЫБИРАЕМ СРЕДСТВО РАЗРАБОТЧИКА

БОЛЬШОЙ ШКОДИНГ, ИЛИ ВЫБИРАЕМ СРЕДСТВО РАЗРАБОТЧИКА

Tony (tony@nifti.unn.ru)

Спецвыпуск Xakep, номер #017, стр. 017-106-6

Выбор? Ну, если у тебя развит дух противоречия или твои задачи никак не пересекаются с системой, то тебе стоит использовать Kylix. В остальном же приходится считаться с системой и разрабатывать на Це, и слава Туксу, что есть kdeveloper.

ЛИНКИ

Если ты хочешь колбаситься под Линухом, то тогда мои советы о том, куда сходить, тебе наверняка не нужны. Если же ты мастдайщик (прикинь, как это звучит гордо), то у тебя есть либо MSDN, либо хелповая система Delphi, и больше них тебе все равно никто не расскажет. В том случае, если у тебя возникают проблемы с чтением Шекспира в оригинале, не расстраивайся, специально для тебя существует ресурс www.rsdn.ru . Успехов тебе и большого шкодинга.


Спецвыпуск Xakep, номер #017, стр. 017-110-1, Целый мир в твоей ладони

Целый мир в твоей ладони

Спецвыпуск Xakep, номер #017, стр. 017-110-1

Andrew Fadeev (andrew@fadeev.com)

Любой, кто решился на покупку карманника, слышал о таком классе программ, как "хаки". Это маленькие программки, которые подменяют (или добавляют) какие-нибудь функции устройства.

На карте можно создавать папки, растасовывать по ним файлы и вообще творить беспредел.

Программа содержит в себе подробную политическую карту мира с огромным количеством городов и стран, озер и морей, и все в этом духе, позволяет измерить расстояние между двумя точками, узнать координату произвольной точки.

Никогда, слышишь, никогда не показывай эту игру подружке! Имеешь шанс больше никогда не увидеть свой Palm.

Ну а последний - программируется от и до на встроенном языке. Слишком он сложный, зато, если разобраться, горы можно свернуть.

Новые веяния в твоих карманах

Случается так, что в нашу жизнь входят какие-то предметы. Это может произойти незаметно, а может и с шумом. Но это не главное. Главное то, что они приходят и остаются. А потом мы уже не можем себе представить нашу жизнь без этих предметов. Так к тебе пришли компьютер и Интернет. Можешь ли ты себе представить свою жизнь, работу, учебу без этих помощников? А так ли теперь легко отказаться от электронной почты? А как бы ты обходился без MP3? Если бы не он, твоя коллекция музыки не была бы такой большой или CD бы из окон вываливались. Вот так в нашу жизнь и входят другие помощники - карманные компьютеры, КПК. Для кого-то это рабочий инструмент, для кого - помощник в учебе и развлечениях. Кто-нибудь смотрит на них в магазине и думает: "А зачем оно?". Но рано или поздно КПК станет таким же привычным в кармане, как и мобильный телефон.

Улучшим!

Что мы стремимся сделать с обычными вещами? Правильно, улучшить, получить от них максимум. Вот я и расскажу тебе об интересном софте для PalmOS совместимых компьютеров. Я не буду долго объяснять, почему я остановился на Palm. Не только потому, что они самые распространенные по статистике, но и потому, что цены на них поумереннее, что для нас с тобой немаловажно, не так ли?

Система

Начнем мы с программ, которые управляют системой Palm'а. Любой, кто решился на покупку карманника, слышал о таком классе программ, как "хаки". Это маленькие программки, которые подменяют (или добавляют) какие-нибудь функции устройства. Для работы с ними нужна программа-менеджер, например, HackMaster, которая добавит их в список программ, выполняемых системой перед запуском. Найти ее можно в любом из софт-архивов. Но у меня с детства нет доверия к программам, которые потенциально могут вызывать конфликты, поэтому я на себе поставил эксперимент: смогу ли я без хаков? Смог. Есть очень много хороших программ, дающих до фига возможностей компьютеру. Да и описывать огромное количество хаков места не хватит.

"Chrome"

http://www.twinkletwinkle.com

Основная задача пороги - менять раскраску окон. Как "Экран" в панели управления любимой винды. Но это авторы думают, что красить окошки - основная функция. Я ее использовал по-другому. Палм-то у меня монохромный, 16 градаций серого. Но по каким-то соображениям встроенный менеджер программ, "Launcher", использует только два цвета. Черный и никакого. Поэтому, хоть в форматах иконок программ есть не только цветные и черно-белые, но и шестнадцатисерные :), встроенный лончер их игнорирует. Так вот, "Chrome" позволяет исправить это и включить поддержку 4 или 16 цветов. На качестве иконок это очень сказывается. Еще зайди в "About", посмотри на логотип во всех цветах. А если у тебя двадцатимегагерцовый процессор или круче, то и экран не станет медленнее обновляться. Жалко, что после reset'а восстанавливаются родные настройки и программу приходится запускать самому для их восстановления.


Спецвыпуск Xakep, номер #017, стр. 017-110-2, Целый мир в твоей ладони

Целый мир в твоей ладони

Спецвыпуск Xakep, номер #017, стр. 017-110-2

"MegaLauncher"

http://www.megasoft2000.com/

Среди пользователей Палмов чуть ли ни войны идут из-за альтернативных лончеров (менеджеров программ). Это почти "emacs" vs "vi" у юниксоидов. Только здесь друг друга не обзывают плохими словами, а мирно уговаривают :). Лично я пользуюсь встроенным. Он меня устраивает и места не занимает. Но перепробовал я много. Кроме "MegaLauncher'а" мне понравились "LauncherIII" и "SilverScreen". Однако "MegaLauncher" продержался дольше всех, так что я расскажу про него. Во-первых, он поддерживает максимальную глубину цвета экрана, так что иконки выглядят на "отлично". Поддерживает скины. Один из них мимикрирует под Виндовз и его иконки. Имеется встроенный zip. Куча листов для записи любимых программ и быстрого их запуска. Часы, показывающие два пояса сразу. Есть "Test Center". Показывает инфу о железе, рисует цветные полосы и показывает, работают ли кнопки. Список программ можно просматривать разными способами. И все равно, ИМХО, встроенный лончер практичнее.

Батарейки

В любом файл-архиве вводи в поле поиска слово "Battery" и получишь кучу программ, которые дают более подробную инфу о батарейках, чем обычный график. Тебе скажут заряд в процентах и напряжение в вольтах. Выбирай любую программу - разницы ноль.

Для картежников

Сейчас появилось много Palm'овых компьютеров, которые поддерживают внешнюю память на карточках, через VFS работая с FAT'ом на карте. Проблема в том, что PalmOS не имеет собственного файл-менеджера. Для внутренней памяти он не нужен, так как Palm по-своему работает с RAM, а вот карточки многофункциональны. Они используются в КПК других фирм и систем, в камерах и MP3-плеерах, поэтому для карт установлен стандарт, близкий к FAT. Вот тут уже хорошо бы иметь файл-менеджер, а PalmOS показывает только папку /PALM/Launcher. Посмотрим, что нам предлагают.

"myWorkbench 2.3"

http://www.toysoft.ca/myWorkbench.html

Замечательная программка. Судя по всему, клонировали "Windows Commander" :). Шютка. Интерфейс узнаваем до слез. Две панельки, одна показывает файлы в RAM, вторая - на карточке. На карте можно создавать папки, растасовывать по ним файлы и вообще творить беспредел. Основной плюс в том, что когда ты два раза шлепаешь стилом (остроконечная палочка для писания у древних греков и римлян, ну и у пальменов) по запускаемому файлу, в RAM копируется не только он, но и все связанные базы данных. А вот это реальный бонус: если пользоваться встроенным механизмом, то данные приходится оставлять в RAM, а копировать только приложения, потому что родная оболочка связи не отслеживает. В программе я высмотрел два недостатка, и все в одном месте :). Первый: когда выбираешь файл, он подсвечивается таким цветом, что на монохромном устройстве контрастность надо выкручивать на максимум, чтобы различить, где есть выделение, а где нет. Второй недостаток заключается в том, что если нажать на файл (он выделится), а после этого нажать на другой, то он выделится тоже, но при этом выделение с первого не снимается. Может, это и удобно, но вместе с предыдущим недостатком вызывает странный эффект: выделены все файлы, кроме нужного. Спасибо, хоть кнопочка "Deselect All" есть.


Спецвыпуск Xakep, номер #017, стр. 017-110-3, Целый мир в твоей ладони

Целый мир в твоей ладони

Спецвыпуск Xakep, номер #017, стр. 017-110-3

McFile 2.0

http://www.jade.dti.ne.jp/~imazeki/palm/

Еще один файл-менеджер. Функции те же, только нет запуска программ. Прога дает только одну панель с файлами. Но зато имеет нормальный вид на монохромных дисплеях и систему выделения файла. Нажатие на папку или файл выполняет действие двойного клика, так что продалбливать дырочку в КПК не придется. Для выбора нескольких файлов надо поставить крестики перед их именем. Да, забыл. Обе программы позволяют делать бэкап на карту всех или выбранных файлов. Если садится батарейка, не надо искать компьютер.

PowerRUN

http://www.palmgear.com/software/showsoftware.cfm?prodID=15870

Эта программка - системное расширение, которое решает задачу запуска программ с карточки вместе с базами и возврат их назад, уже с изменениями и новыми базами. "PowerRUN" забирает проги на карту, а в памяти оставляет ярлычок весом в килобайт. Если при запуске ярлычка в слоте не оказалось нужной карточки (потеряли?!), "PowerRUN" вежливо попросит карточку с нужным лейблом.

Учеба

CityZen

http://www.cs.man.ac.uk/~hancockd/CityZen/

Программа содержит в себе подробную политическую карту мира с огромным количеством городов и стран, озер и морей, и все в этом духе, позволяет измерить расстояние между двумя точками, узнать координату произвольной точки. В атлас встроена игра вроде "О! Щас лифчик!". Тебе показывают город (или другой объект, в зависимости от режима), дают несколько вариантов ответа, а тебе надо выбрать правильный. Рекомендуется школьникам или ученикам ВУЗов, где есть география :).

Калькуляторы

Есть много разных математических программ, сложных и не очень. Я бы выделил бесплатный "EasyCalc" (http://easycalc.sourceforge.net), навороченный "PowerOne Graph" (www.infinitysw.com) и программируемый "CplxCalPro" (http://www.adacs.com).

Мне больше всего нравится первый. За бесплатность и такие функции, которые никому, кроме меня, не нужны (о товарище Бесселе слышал?). Все три строят графики. "PowerOne Graph" еще решает уравнения и системы. Ну а последний - программируется от и до на встроенном языке. Слишком он сложный, зато, если разобраться, горы можно свернуть.

Офис

"QucikOffice"

www.quickoffice.com

Замечательные "Word" (QuickWord) и "Excel" (QucikSheet) для Палма. Главное, почему я поставил его вместо "DocumentsToGo" с бонус-диска, - это нормальная поддержка Unicode (и русского) в "QucikWord" и возможность строить графики в "QuickSheet". В "Word" и "Excel" на компьютере добавляются менюшки "QuickOffice'а". В них открытый файл можно сохранить как копию на КПК или установить связь. То есть при изменении файла на Palm и синхронизации изменения запишутся на комп. И наоборот. Все продумано, работать с программой одно удовольствие. Разве что орфографию не проверяет.


Спецвыпуск Xakep, номер #017, стр. 017-110-4, Целый мир в твоей ладони

Целый мир в твоей ладони

Спецвыпуск Xakep, номер #017, стр. 017-110-4

AvantGo

www.avantgo.com

Что-то вроде "TeleportPro" для виндов. Эта прога умеет сливать сайт в оффлайн в Палм, попутно преобразовывая страницы и уменьшая картинки под маленький дисплей. Также уже имеется огромный список каналов. Это лайт-версии сайтов. Но можно качать любую пагу. При каждой синхронизации, если есть коннект с Инетом, контент обновляется. Ищи эту прогу на бонус-диске от Палма.

iSilio

www.isilio.com

Хорошая читалка текстов в PalmDOC и своем формате (который поддерживает картинки). Позволяет менять размер шрифта, делать закладки и читать plain text (*.txt) файлы с карточки без преобразований. Мне больше нравился "Palm Reader" (www.palm.com или бонус-диск), он корректно делит файлы на страницы и позволяет вращать экран. Это полезно, так как держать Палм горизонтально легче. Также у "Palm Reader" есть свой формат, кроме DOC. Но вот формат "iSilio" распространен в Интернете (особенно в рунете) так что выбора нет :).

Развлечения

Netmite's Audio Player

http://www.netmite.com

Смотришь на цветные "Sony" со стереозвуком и MP3 плеером? Не можешь спать по ночам? Снится твой Палм с убогой пищалкой? Заплати налоги... То есть поставь себе эту прогу. Замечательная вещь! Оказывается, "убогая пищалка" вполне годится для проигрывания восьмибитных WAV файлов с частотой дискретизации 11025 герц. Берешь любую музыку, хоть MP3, с помощью, например, "Cooledit", сохраняешь в такой WAV'ник и сдаешь конвертору проги. Затем заливаешь на Палм и слушаешь. Качество, конечно, как по телефону, но сам факт! Музычка может играть, а ты себе читать книжечку, составлять расписание на день или играть во что-нибудь. Единственный минус - файлы нельзя хранить на карточке. А восемь метров, знаете ли, не резиновые. Поэтому я пользуюсь для этих целей "TealMovie" (www.tealpoint.com). Он позволяет не только хранить музыку на карточке, но и может с нее играть не конвертированные в свой формат WAV файлы. Учитывая, что wav'ники в восемь бит, 10 килогерц занимают столько же места, как 128-килобитная MP3'шка, на 32-меговую карту минут 25 влезет. А если сохранять в родном формате проги, то получишь еще и двукратное сжатие. Но вот учитывая, что нет выхода на наушники и ущербность встроенного динамика, возникает вопрос: а может купить mp3 плеер и не извращаться? Тогда какой же ты пальмовец?!

NetWalk 2

www.beiks.com

Игра старая, как Юникс. Есть сервер с кучей выходов, много компов и сеть. Но провода разрезаны и кусочки повернуты. Задача - собрать сеть и подключить все компьютеры. Я, вообще, ярый ненавистник тетрисов и саперов, но провожу за этой игрой уйму времени. Затягивает. Этому способствует пять наборов уровней по 33 головоломки.


Спецвыпуск Xakep, номер #017, стр. 017-110-5, Целый мир в твоей ладони

Целый мир в твоей ладони

Спецвыпуск Xakep, номер #017, стр. 017-110-5

Grand Theft Auto

www.globalstarsoftware.com

"GTA", оно самое! Игра (пока только демо-версия) представляет собой первый город "GTA2" со всеми миссиями и заморочками. Не тормозит и хорошо смотрится в шестнадцати оттенках серого. Больше об игре писать нечего. Все уже написано про PC версию во многих игровых журналах.

Serious Sam: The First Encounter

www.globalstarsoftware.com

Ребята из "ГолбалСтар" всерьез взялись за перевод персоналочных игрушек под Палм. Не тормозит, аутентичные текстуры и монстры, оружие. Уровни называются так же, но вот движок похож больше на "Wolf3D" - один этаж. Но развлекает исправно. Хотя "GTA" (ИМХО) лучше вышел.

BeBop

www.dejobaan.com/bebop

Девелоперы замахнулись на "The Sims". Получилась неплохая пародия. Первое время играть интересно. Но малое количество предметов для дома после определенного времени делает игру скучной. Вместо того чтобы ходить на работу, местные "Sims" (BeBops) ходят в казино и участвуют в соревнованиях. Да! Никогда, слышишь, никогда не показывай эту игру подружке! Имеешь шанс больше никогда не увидеть свой Palm. Я отделался эмулятором Palm'а на ее компьютере :).

Итого

Конечно, я коснулся только верхушки айсберга. Я не рассказал об эмуляторе "ГеймБоя" ("Liberty", ищи на сайтах ниже) и многом другом. Походи по сайтам, которые я тебе дам. Это классно, когда ты сам находишь что-то, что делает из "Palm'а как у всех" ТВОЙ Palm.

Сайты:

"PalmInfoCenter" http://www.palminfocenter.com/ - отличный сайт с новостями на английском.

"PalmQ" http://www.palmq.net/ - сайт на русском с переводами с "PalmInfoCenter" и своими статьями.

"Palm - ладошки к солнцу" http://www.palm.com.ua/ - сайт на русском. Со своими статьями и обзорами КПК. Также имеется ежедневная короткая подборка новостей с других сайтов (в основном "PalmInfoCenter") и хороший архив программ.

"PDArcade" http://www.pdarcade.com/ - все про карманные игры.

Ну и самое главное: "PalmGear" http://www.palmgear.com/ - огромный архив программ. Все из этого обзора ты можешь найти там. Если ты скажешь мне, что просмотрел весь архив, я выпишу направление к психиатру :).

For educational purposes only!

Для шароварок на PC есть хороший сайт astalavista.box.sk. А вот для Palm'а смотри http://www.pw.zde.cz/. Там JAVA программа и часто обновляющаяся XML база. Ну, разберешься. Еще сходи на http://mrtaxi.karnt.com/download.htm. Но не думай этим пользоваться ;). Все программы стоят своих денег. Причем денег просят немало. Если бы "MS Office" стоил $15, как "QuickOffice", все бы жили счастливо. Просто многие шаровары накладывают ограничения на использования функций, чтобы определиться, нужна тебе эта прога или нет. А если понравилось, то купи обязательно. Умгу, купи... Умгу, обязательно...


Спецвыпуск Xakep, номер #017, стр. 017-114-1, КОДИМ ПАЛМЫ

КОДИМ ПАЛМЫ

Спецвыпуск Xakep, номер #017, стр. 017-114-1

Andrew Fadeev (andrew@fadeev.com)

Сейчас я покажу то, что тебе нужно для того, чтобы научиться программировать под «PalmOS».

Я выбрал графическую среду "Falch.net DeveloperStudio 2.5". Она включает в себя визуальную среду, визуальный конструктор форм и меню, компилятор с C++ и официальный «PalmOS Emulator» (POSE).

Как видишь, отличий между организацией Win/Dos PC и «PalmOS» систем достаточно. Осознание их всех важная веха в пути познания пальм:).

LOADING...

"СПЕЦ" не раз писал о кодинге. Но сейчас речь пойдет о кое-чем новом: я покажу тебе, что нужно для создания софта под "PalmOS". Эта ось стоит в карманных компьютерах "Palm", "Sony", "HandSpring" и других. Прог для "пальм" очень много, но всегда там чего-то не хватает. Выход есть: написать собственную программу. Правда, кодить под "PalmOS" сложнее, чем под "Windows", так как есть много особенностей, зато у тебя есть возможность пощупать новую молодую платформу.

CHECK LIST

Для успешного старта каждый разработчик под "PalmOS" должен зарегиться, так как каждая прога имеет четырехсимвольный номер разработчика. Дело в том, что софт записывает данные в системные базы "Saved Preferences" и "Unsaved Preferences", и, чтобы не было конфликтов, ты должен проверить, не занят ли Creator ID, и быстро его зарегить. Заходи на www.palmos.com, вверху нажимай на "Developer", слева в меню выбирай "Creator ID".

Далее надо определиться со средством разработки. В принципе есть даже компилятор с "Паскаля" (бета), но "PalmOS" - графическая ось, а "Паскаль" к этому не готов. Я выбрал графическую среду "Falch.net DeveloperStudio 2.5". Она включает в себя визуальную среду, визуальный конструктор форм и меню, компилятор с C++ и официальный "PalmOS Emulator" (POSE). Качай свежую версию с www.falch.net. Там же получай трейный ключ на 30 дней. Тебе еще нужен палмовский SDK (Software Developer Kit). Ищи его четвертую версию на www.palmos.com/dev/. Установить это счастье надо в диру "PalmDev", например: C:\Falch.net\DeveloperStudio 2.5\PalmDev. Во время установки тебя спросят, какими инструментами ты пользуешься. Выбирай "GCC PRC-Tools installation". После установки в дире "PalmDev" появится папка "sdk-4". Переименуй в "sdk-4.0".

POSE И ROM

Чтобы ты мог отлаживать программы прямо на PC, в пакет включен эмулятор. Он не будет работать без образа ROM-микросхемы, содержащей ОС и основные проги. Официально для его получения тебе нужно распечатать пару документов, подписать их и отправить в США факсом. Но есть другие выходы. Первый - это скачать образ со своего "Palm'а". Для этого в комплект эмулятора входит программа, которую ты должен залить в свой "Палм". Второй - сходить на mypalm.ru и унести парочку ROM'ов оттуда. Можно приступать. Если захочешь посмотреть встроенные примеры из "Developer Studio", не забудь зайти в "Project -> Properties" и выбрать в списке "SDK" "4.0" вместо "3.5".

ОСОБЫЕ ПРИМЕТЫ

Хоть кодить под "PalmOS" можно на привычном "Си", разница есть. Первое отличие - это название главной функции проги: "PilotMain". Второе - это ассемблерные вставки (ассм от "Моторолы" совсем другой), так что лучше без них. А главное, что требует внимания, это то, что память "Палма" - RAM, и все проги доступны ОС в любой системно важный момент. Это значит, что после резета, при включении, выключении, закрытии на пароль устройства и так далее, ВСЕ программы получают об этом уведомление. Занимается этим "System Manager" с помощью функций "sysAppLaunchCmdXXXX". В функции "PilotMain" описывается реакция на каждое событие. Неописанные игнорируются. Еще одна особенность палмовых прог - это "EventLoop". Софтины "событийно ориентированны", то есть ждут события, например - нажатия на экран, а затем на него реагируют, исполняя заданный код.


Спецвыпуск Xakep, номер #017, стр. 017-114-2, КОДИМ ПАЛМЫ

КОДИМ ПАЛМЫ

Спецвыпуск Xakep, номер #017, стр. 017-114-2

DEVELOPER STUDOI В ПРИМЕРАХ

Сейчас я разберу стандартный пример "Hello World" с изменениями. Создай проект (File->New). В окошке выбирай "PalmOS Framework Project". Жми "Next" и задавай имя проекта и директорию, куда его сохранить.

Потом попросят утвердить список форм и меню на формах. На окошке "Alerts" остановимся. "Alerts" - это обычные окошки "Да, нет, не знаю". Добавь "alMy". На следующем окне выбери четвертый SDK, введи свой CreatorID, выбери шаблон иконки и отметь "Create C++ project". Готово.

В окне "Project Explorer" выбирай "Resources" и hello.rcp. Кидай на форму компонент "FIELD" и присвой ему ID "fld" в окне "Properties", а свойству "Underlined" присвой значение "True". Теперь кидай "BUTTON", id=btn, Text=OK!. Теперь переходи к "Alerts->alMy". В поле "Message" окна "Properties" пиши "Hello ^1. Your OS is ^2!". ^1 и ^2 - это параметры. Возвращайся на форму. Выбирай нашу кнопочку и кликай на ней правой кнопкой мыши. Ползи в "Code Templates->Control Select Event".

Этим ты создал обработчик события нажатия на кнопку. Юзер вводит имя в текстовое поле, а программа выводит сообщение "Hello Vasya. Your OS is v4.0!". Для этого пиши в обработчик следующее:

FormType *formPtr = FrmGetActiveForm();

UInt16 fieldIndex = FrmGetObjectIndex(formPtr, fld);

FieldType *fieldPtr = (FieldType *) FrmGetObjectPtr(formPtr, fieldIndex);

Char *namePtr = FldGetTextPtr(fieldPtr);

Так мы сохраним в переменную "namePtr" имя, введенное в текстовое поле. Первой строчкой получили указатель на активную форму. Второй - индекс текстового поля. Третьей же - указатель на поле. А последней - указатель на текст в поле. Сложновато. Теперь надо вывести сообщение. Cначала получим версию ОС:

Char *ver = SysGetOSVersionString();

Далее вызываем сообщение:

FrmCustomAlert(alMy, namePtr, ver, NULL);

Функция вывода сообщения имеет четыре параметра. Первый - это имя окна в ресурсах. Следующие три - заменители ^1, ^2 и ^3. Но так как ^3 у нас не было, вместо него стоит NULL.

Выбирай "Debug->Run". Программа запустится в эмуляторе (сперва его надо настроить). Можешь выбрать "Install to device" и проверить прогу на железе.

ЭМУЛЯТОР

При первом запуске с тебя потребуют образ ROM. Нажимай "Open" и ищи свой файл. Если ROM верный, эмулятор сам установит правильный тип устройства. Если эмулятор был запущен из "Developer Studio", то после загрузки запустится твоя программа. Все команды эмуля сидят в меню, вызываемом по правому клику. Это: "Reset", "Install App/Database" (устанавливает прогу в эмулятор) и субменю "Settings" (настройки). Там можно сменить skin и увеличить окно эмуля вдвое. Пункт "Debugging" включает остановки по мелким ошибкам (Warnings). Подробней о работе эмулятора читай на www.palmos.com и www.palmq.ru. Я добавлю только, что под эмулем проги чаще глючат (на железе может быть все ОК), хотя полезно запускать под ним потенциально опасные софтины.


Спецвыпуск Xakep, номер #017, стр. 017-114-3, КОДИМ ПАЛМЫ

КОДИМ ПАЛМЫ

Спецвыпуск Xakep, номер #017, стр. 017-114-3

ЛИРИЧЕСКОЕ ОТСТУПЛЕНИЕ

Если ты кодил под "Вынь", то у тебя, возможно, возник вопрос: "Почему так сложно?". Да, в примере, чтобы получить текст поля ввода, мы заюзали четыре строчки кода, когда в "C++ Builder" на это ушла бы одна. Да, "C++ Builder" использует библиотеку VCL, где все эти компоненты описаны. Почему такой библиотеки нет под "Palm"? Потому что для "Palm" размер экзешника (точнее prc'шника) очень важен ввиду малого объема памяти. Но тем не менее библиотеки существуют. Они предоставляют замену стандартного интерфейса на более красочный. Разница в том, что библиотека не встраивается в исполняемый файл, а записывается отдельным файлом. Так что если у тебя две проги, юзающие эту библиотеку, то достаточно записать либу один раз. Альтернативой может служить и "Java MIDP" (мобильная "Java2"). Под нее написано достаточно интерфейсов, осталось их адаптировать, что люди с успехом делают.

ЛИРИЧЕСКОЕ ОТСТУПЛЕНИЕ 2

Исполняемый файл под "Windows" - это EXE-файл формата PE. Основная черта PE - это встроенные ресурсы. То есть все картинки, иконки и прочее прямо в экзешнике. Палмовый исполняемый PRC-файл (Palm Resource Container) страдает тем же и построен как контейнер с описанием форм, менюх, картинок, иконок. Исполняемый код в нем тоже хранится как ресурс типа "code". Документы тоже могут быть с расширением PRC, просто в нем один ресурс - текст в DOC-формате. Это еще одно отличие между Win/Dos PC и "PalmOS".

ВТОРАЯ СТОРОНА

Часто программирование под "Palm" не ограничивается написанием Palm-приложения. Может еще понадобиться написать виндовую библиотеку, которая прикручивается к "HotSync Manager" для синхронизации с ПК.

АЛЬТЕРНАТИВЫ

Чистый кодинг - не единственный путь решения своих задач. На "палме" это возможно. В этом тебе помогут следующие проги: "Satellite Forms" (www.pumatechservices.com) - это виндовое приложение, позволяющее создавать интерфейс методом "дрыг-н-дроп" для удобного ввода и просмотра данных. Подобная ей "Pendtagon Forms" (www.pendragonsoftware.com). "ThinkDB" (www.thinkingbytes.com) - это тоже база данных, позволяющая создавать формы, но тут весь процесс проходит уже на «Палме». «PocketC» или «HotPaw Basic» - «Си» и «Бейсик» для «Палма».

Есть еще он-лайн феномен на www.appartist.com. На этом сайте вроде бы можно создавать приложение для «Palm'ов», не зная языков. Подробнее рассказать не могу, так как у меня эта штука не заработала.

БРАТЬЯ НАШИ МЕНЬШИЕ

А что же «PocketPC»? Ну, «Виндовз» он и в кармане виндовз, даже если CE. Я клоню к тому, что для того чтобы писать под «PocketPC», тебе всего-то и надо «MS Visual Studio» и «MS PocketPC 2002 SDK». Последний включает в себя эмулятор и весит 67 метров в архиве.


Спецвыпуск Xakep, номер #017, стр. 017-114-4, КОДИМ ПАЛМЫ

КОДИМ ПАЛМЫ

Спецвыпуск Xakep, номер #017, стр. 017-114-4

SEE ALSO

www.palmos.com

www.appartist.com

www.falch.net

java.sun.com

http://palm.opennet.ru/ - «Palm» для админа, но там есть и про кодинг.

http://www.geocities.com/palmdevzone/index.htm - самопал про кодинг.

http://www.pw.zde.cz/ - здесь про нестандартные направления кодинга.


Спецвыпуск Xakep, номер #017, стр. 017-116-1, КАРМАННЫЕ ИГРЫ

КАРМАННЫЕ ИГРЫ

Спецвыпуск Xakep, номер #017, стр. 017-116-1

Вячеслав Назарофф (master@gameland.ru)

В игре "Поединок" любой желающий может виртуально начистить физиономию случайно выбранному сопернику.

В свое время Metalion стала первой в мире полностью трехмерной аркадной стрелялкой для карманных компьютеров.

... мужчины от мальчиков отличаются стоимостью своих игрушек.

Первым делом на новую мобильную платформу были перенесены классические игры. Конечно, речь идет о "Тетрисе" - культовом творении нашего соотечественника Евгения Пажитнова.

Главный герой приходит в сознание в подземелье и, словно заправский алкоголик, пытается узнать, кто он, зачем он, куда он, а также где в городе Архангельске лучше всего сдавать пустую посуду из-под вина.

Большим плюсом этой игры является возможность разбивать кирпичи, орудуя импровизированной ракеткой как на цветных устройствах, так и на черно-белых.

Иногда мне кажется, что любое нормальное электронное устройство предназначено для того, чтобы с его помощью можно было играть.

Дорогой, как две шоколадки "Сникерс", читатель, ты, конечно же, знаешь, чем мужчины отличаются от мальчиков? Что? И чем от девочек отличаются, тоже знаешь? Нет, дальше развивать эту тему не будем. Просто уточним, что, помимо всего прочего, мужчины от мальчиков отличаются стоимостью своих игрушек. А как еще? Весь мир играет. Даже в театре - и то играют. Но все-таки, если мир - театр, а люди в нем - актеры, то я хочу антракта и в буфет. Ну а там можно и поиграть в нормальные игры. Благо, инструменты для этого у меня есть - любимая "пальма" (Palm IIIe) и не менее любимый "мотор" (Motorola v66).

Иногда мне кажется, что любое нормальное электронное устройство предназначено для того, чтобы с его помощью можно было играть. Наконец-то, нормальными становятся и карманные компьютеры с мобильными телефонами, поддерживающими протоколы WAP и GPRS. Постепенно на "пальмы" переводятся игры, уже давно ставшие популярными на их старших братьях, а телефоны постепенно превращаются из средства связи в средство развлечения. Впрочем, связь-то самая обыкновенная, и поэтому такие тенденции только радуют. Порадуемся вместе?

ИГРУШКИ НА ПАЛЬМОВОЙ ВЕТКЕ

Давным-давно, когда еще деревья были маленькими, а компьютеры большими, люди были вынуждены развлекаться традиционными способами. Секс, наркотики, рок-н-ролл и, конечно, компьютерные игры служили средствами для культурного или не очень отдыха, в зависимости от таланта отдыхающих. К сожалению, в силу разных причин, которым не место на страницах столь солидного издания, весело проводить время получалось далеко не всегда. Но все же гомо различной степени сапиенсичности хотели развлекаться постоянно: в гулких вагонах метро, белых больничных палатах, мрачных аудиториях. Одним словом, везде. Конечно, для этого были нужны мобильные компьютеры. Желательно карманные. Долгое время люди требовали от компьютерных гениев создать им такие чудо-машинки. И, наконец, один из них с видом знатока произнес: "Я - знаток!" - и сконструировал микроскопический электронный арифмометр, который торжественно был назван Palm или просто "пальмой". И понеслось...


Спецвыпуск Xakep, номер #017, стр. 017-116-2, КАРМАННЫЕ ИГРЫ

КАРМАННЫЕ ИГРЫ

Спецвыпуск Xakep, номер #017, стр. 017-116-2

Первым делом на новую мобильную платформу были перенесены классические игры. Конечно, речь идет о "Тетрисе" - культовом творении нашего соотечественника Евгения Пажитнова. До сих пор эта игра прочно занимает первое место по количеству загрузок с сайтов, посвященных программам для "пальмовых" компьютеров. С небольшим отрывом от него следует любимая игра всех пользователей, отзывающихся на слова "барышня", "сударыня", "мадам" и даже "тетка". Разумеется, это небезызвестный проект Lines. Если взглянуть на женскую армию пользователей "пальм", то можно сделать вывод, что человек рождается для того, чтобы построить дом, посадить дерево, вырастить ребенка и выстроить из разноцветных колобков как можно больше однотонных рядов.

Конечно, прекрасная половина человечества, то есть мужчины, к вопросу развлечений подходит гораздо более серьезно. Поэтому очевидно, что карманные компьютеры никак не могли обойтись без популярного PC-ветерана по имени BrickShotter. Большим плюсом этой игры является возможность разбивать кирпичи, орудуя импровизированной ракеткой как на цветных устройствах, так и на черно-белых. Просто в последнем варианте цвета заменяются контрастными узорами. Так что, даже если "пальма" по каким-то причинам не может похвастаться цветным дисплеем, а пользователь - толстым кошельком, они все равно имеют возможность погрузиться в мир цветных кирпичей. Ведь для настоящих разрушителей стен наличие компьютера с всего лишь черно-белым дисплеем не является серьезной помехой.

Впрочем, на философский лад пользователей "пальм" настраивает великое множество других проектов. Например, культовая игра Lemmings. Честно говоря, точно определить ее жанр практически невозможно - это что-то среднее между логикой и аркадой. Скорее всего, эта когда-то новаторская идея и позволила разработчикам создать игру, которая стала одной из самых популярных в мире. Напомню, что в Lemmings на растерзание игроку выдается отряд леммингов. Именно на растерзание! А как еще можно назвать ситуацию, когда человеку, связанному с воспитанием этих существ так же сильно, как морская свинка связана с морем и свиньями, вверяется их судьба? Хотя напрямую леммингам отдавать приказания нельзя. Можно управлять ими лишь косвенно. Например, кого-то назначить землекопом, другого заставить строить лестницу, а третьего заблокировать проход. И все усилия приходится направлять на то, чтобы довести как можно большее количество забавных зверюшек к заветному выходу с уровня. Стоит отметить, что вторая "пальмовая" версия игрушки весьма популярна. В нее играют те, кто хотел бы тряхнуть стариной (не боясь, что она отвалится) или кто когда-то не успел застать леммингов на огромных персональных компьютерах. В любом случае, "пальмовые" лемминги - это бесспорный хит, который способен подарить любому игроку несколько часов приятного времяпрепровождения, ну а самим леммингам - медленную и мучительную смерть.

Тема смерти, надо признаться, весьма популярна в играх для карманных компьютеров. Боевиков для этой платформы создается великое множество. Впрочем, иногда разработчики ленятся придумывать что-то новое, прекрасно понимая, что все равно новое - это хорошо забытое старое, а свое - это хорошо украденное чужое. Так, например, компания Global Star Software по-быстрому перенесла на "пальму" одного из последних фаворитов всех любителей бескомпромиссных мочиловых - игру Serious Sam: The First Encounter. "Пальмовый" боевик, как и оригинальный проект, переносит бойцов со злом во времена древнего Египта, населенного страшными и несимпатичными чудовищами. Ну а так как существам, по сравнению с которыми нильский крокодил кажется Моной Лизой, не место в недрах компьютеров, приходится их уничтожать. Получается довольно весело. Стоит отметить, что игру, как и приснопамятный BrickShotter, можно запускать как в цветном, так и черно-белом режиме.


Спецвыпуск Xakep, номер #017, стр. 017-116-3, КАРМАННЫЕ ИГРЫ

КАРМАННЫЕ ИГРЫ

Спецвыпуск Xakep, номер #017, стр. 017-116-3

Еще одним крайне забавным проектом, в котором можно почувствовать себя супер-героем, является популярная игра Metalion. В свое время она стала первой в мире полностью трехмерной аркадной стрелялкой для карманных компьютеров. И несмотря на то, что с того момента утекло немало дней, она до сих пор остается одной из первых по популярности. Возможно, за это стоит благодарить великолепный стереозвук, который могут оценить любые владельцы стереофонических ушей, а также реалистичные цвета - ни одного фиолетового монстра в игре встретить не получится, только нормальных зеленых тварей в красный горошек. Уничтожать же злобных и сильных врагов в Metalion приходится в облике одного из трех уникальных роботов, мотающихся по космическим просторам в попытке огнем и мечом насадить в неразумные головы идеи гуманизма, пацифизма и трансцендентализма. Довольно увлекательный процесс, надо признаться. Особенно в части трансцендентализма. После такой зарядки мозгов бывает очень неплохо тут же применить полученные навыки. И карманные компьютеры предоставляют для этого все возможности хотя бы с помощью экономических стратегий.

Компания Handmark Software, например, перенесла на пальмовую платформу легендарную игру Monopoly. Стоит сказать, что больше полувека "Монополия" остается одной из самых хорошо продаваемых настольных игр и, вполне возможно, повторит свой успех и для карманных компьютеров. Если начать в нее играть, то есть шанс повторить судьбу сказочного персонажа Ивана Царевича, который скакал без передышки три дня и три ночи, пока скакалку не отобрали. Скакать в "Монополию" можно гораздо дольше. Во-первых, в ней легко вызвать на интеллектуальный поединок шесть компьютерных "личностей", каждая из которых обладает уникальным стилем игры и качествами. Во-вторых, в том случае, если уровень IQ игрока приближается к номеру его ICQ, то появляется смысл испытать свои силы в многопользовательской игре, где одновременно могут принимать участие до четырех "живых" игроков. При этом запись очков автоматизирована, состояние счета каждого бойца монопольно капиталистического фронта может быть просмотрено в любое время, в том числе после подведения итогов.


Спецвыпуск Xakep, номер #017, стр. 017-116-4, КАРМАННЫЕ ИГРЫ

КАРМАННЫЕ ИГРЫ

Спецвыпуск Xakep, номер #017, стр. 017-116-4

Вообще, итоги подводят не только компьютерные игры, но и их создатели. Так, японский производитель игровых приставок и разработчик развлекательного софта Sega объявил о своем намерении выпустить к концу года ряд игр для "пальм". По словам генерального директора Sega of America Питера Мура, в основном новые игры будут предназначены для устройств с беспроводным доступом в Интернет, и пользователи смогут загружать игры и играть в них на основе разовой оплаты или подписки на услугу. К сожалению, пока детали проекта не раскрываются. Даже информацию о предполагаемой стоимости подобных служб в Sega охраняют круче, чем охраняли бы секрет производства полосатой зубной пасты. Серьезно обломавшись со своей очень интересной игровой системой Dreamcast, компания решила бить наверняка. Более того, создание игрушек для "пальмовой" платформы в некоторой мере объясняется решением Sega отказаться от создания игровых консолей. Видимо, всему виной непосильная конкуренция со стороны таких монстров, как Sony и Microsoft. Так что теперь компания планирует заняться исключительно созданием игр, в связи с чем и был найден новый перспективный и пока еще свободный рынок. По мнению хитроумных разработчиков, популярность карманных "пальмовых" компьютеров растет быстрее, чем курс австралийской национальный валюты кенгурубля в России. В связи с этим компания планирует перенести на эту платформу практически все созданные ею хиты и их персонажей, таких как, например, ежик-мутант Соник. Если все пойдет так, как задумывают дети страны сакэ и суши, то, несомненно, этот шаг тут же сделает игры для "пальм" жутко популярными и даст импульс развитию индустрии игровых сервисов для карманных компьютеров. Ну а если в действительности все окажется не так, как на самом деле, то гордым игровым магнатам не останется ничего иного, кроме как сыграть в японскую рулетку, в которой, как известно, участвуют шесть мечей для харакири, пять из которых тупые. Впрочем, судя по всему, дело до этого не дойдет. "Пальмовые" игры представляют собой замечательное развлечение, которое всегда с тобой. И если учесть, что развлекаться в основном приходится проверенными хитами, то перед тобой оказывается самый настоящий убийца скуки, а то и целая машина времени: только начал играть - и уже завтра! Так что, запуская игру, не забудь позвонить домой и предупредить, что ты уходишь в себя и вернешься не скоро. Впрочем, вряд ли это получится... С телефоном наверняка заиграешься...

WAP!

Сыграть с помощью мобильного телефона во что-нибудь более увлекательное, чем удав, тащащийся по разбросанным по крохотному экранчику пачкам дуста, долгое время было просто невозможно. Однако с развитием WAP-протокола и даже GPRS, позволяющих подключаться к Интернету с помощью родных мобил, ситуация изменилась. Более того, крупнейшие российские операторы сотовой связи уже буквально навязывают своим клиентам весьма забавный развлекательный сервис, отказываясь брать за него деньги под предлогом тестирования услуг. Давай-ка вспомним поговорки про бесплатный сыр и про то, что хоть ранняя птичка клюет червячка, но сыр-то все равно достается только второй мышке. Поэтому сейчас предлагается стать хитрым грызуном и взглянуть, с чем же столкнулись более нетерпеливые собратья.


Спецвыпуск Xakep, номер #017, стр. 017-116-5, КАРМАННЫЕ ИГРЫ

КАРМАННЫЕ ИГРЫ

Спецвыпуск Xakep, номер #017, стр. 017-116-5

В первую очередь, конечно, речь идет о WAP-приложениях, которые можно испытать на любой мобиле, поддерживающей этот протокол. Так, ПчеЛайн может похвастаться целой кучей игр, созданных весьма симпатичной компанией "Никита". Например, любители насекомых наверняка обрадуются игре BEEWAP. В ней игрокам необходимо заботиться и ухаживать за пчелой, представляющей собой редкой наглости существо. В зависимости от ухода жужжащее создание реагирует на отношение хозяина и регулярно напоминает о себе. Хотя, глядя на то, как чувствовала себя в свое время моя подопечная, можно с уверенностью сказать, что она действительно нуждалась в моем уходе. Причем чем дальше я бы ушел, тем лучше было бы для маленькой мохнатой твари. Если насекомые тебя не прикалывают, то можно принять участие в классическом текстовом квесте "Нашествие". Игра посвящена покушению на наши святыни - Мавзолей и МакДоналдсы - стаи карлсонов-убийц. Глядя на описание ситуации и выбирая тот или иной вариант действия, можно достаточно свободно перемещаться по раскидистому дереву сюжета и даже получать некоторое удовольствие от уничтожения летающих тварей. Весьма сильно на "Нашествие" похожа игра "Путь к себе". По своей текстовой сути - это ролевая фэнтези-игра. Главный герой приходит в сознание в подземелье и, словно заправский алкоголик, пытается узнать, кто он, зачем он, куда он, а также где в городе Архангельске лучше всего сдавать пустую винную посуду. Дело, честно признаюсь, это непростое. Для того чтобы восстановить прошлое, придется прочитать огромное количество текста на крохотном телефонном дисплее. И если глаза после этого еще будут в состоянии реагировать на что-либо, обязательно стоит попытаться, пока не поздно, познакомиться с хорошенькой девушкой. В крайнем случае - с толковым мальчуганом. Но последнее я тебе не советовал! Так или иначе, но с помощью услуги "Знакомство" можно быстренько найти мобильного друга или подругу. Главное - иметь телефон и немного здорового цинизма. Телефон - чтобы завязать знакомство, а цинизм - чтобы философски отнестись к ситуации, когда к тебе на свидание явится существо, которое, если быть предельно корректным, можно сравнить с мопассановской Пышкой после напалмовой атаки.

Если после этого тебе захочется набить морду тем, кто так тебя подставил, не спеши метаться в поисках обидчиков. Гораздо проще спустить пар или что-нибудь другое, что в тебе накопилось, с помощью другой игры - "Поединок". В ней любой желающий может виртуально начистить физиономию случайно выбранному сопернику. Все что нужно - это зарегистрироваться в системе через Интернет. Впрочем, это необходимо лишь для того, чтобы набранные во время боев очки сохранялись в рейтингах. Естественно, если ты равнодушен к славе, то можешь драться анонимно. Итак, после успешного подключения ты оказываешься в основном меню игры, в котором можно выбрать одного из трех бойцов, начать игру, посмотреть справку по игре и статистику предыдущих игр и, конечно, начать схватку. На каждом этапе боя выбираются по три удара, при этом время на выбор жестко ограничено. Точно так же поступает и противник: выбирает удары, которые он собирается нанести. После того как все определились, начинается очередной раунд. Удары сравниваются по характеристикам атака-защита, после чего они отрисовываются на экране телефона. У каждого игрока есть показатель здоровья, уменьшающегося в зависимости от полученных увечий. Начальное здоровье бойца 20 пунктов, но оно уменьшается с каждым успешным ударом противника. Когда у одного из соперников здоровье уходит в ноль, бой прекращается. За каждую победу герои в обязательном порядке премируются очками. Только вот толку от них достаточно мало. Даже в казино их не проиграешь. А ведь казино-то на WAP-территории есть!


Спецвыпуск Xakep, номер #017, стр. 017-116-6, КАРМАННЫЕ ИГРЫ

КАРМАННЫЕ ИГРЫ

Спецвыпуск Xakep, номер #017, стр. 017-116-6

Любой мобильный гражданин, азарт у которого вдруг распух и зачесался, может направить такое чувство в мирное русло. Для этого вполне подходит игра "Фортуна". Она представляет собой аналог популярного игрового автомата "Однорукий Бандит". Но просто так жать на кнопку и тупо глазеть на то, сколько "яблок" или "бананов" у тебя выпадет, достаточно быстро надоедает. Поэтому серьезные люди наверняка предпочтут игру "Кости". По крайней мере, название звучит солиднее. Впрочем, и здесь тоже игра идет на виртуальные "очки". При первом заходе в игру придется начать с нуля очков. Зато потом можно сразу бросить пять костей. Не понравилось, что выпало? Берешь и перебрасываешь непонравившиеся кости! И так пока не надоест и не захочется пойти в настоящее казино. А там, глядишь, получится заработать и на новый мобильник, да и "пальму" поновее тоже можно бы завести. Ведь без таких современных игрушек сегодня не обойтись. Как же ты без них собираешься играть везде и всегда? К тому же... От мальчиков же как-то надо отличаться...


Спецвыпуск Xakep, номер #017, стр. 017-126-1, МЯГКИЙ КОНКУРС

МЯГКИЙ КОНКУРС

Спецвыпуск Xakep, номер #017, стр. 017-126-1

Итак, ты прочел еще один СПЕЦ. Очень хочется надеяться, что ты действительно просек фишку и решил чем-то заморочиться на серьезном уровне. Чтобы стать настоящим профессионалом, конечно, придется долго учиться, набираться опыта и знаний. Хочешь начать уже прямо сейчас? Отлично, тогда постарайся для начала управиться с нашим конкурсом. А дальше... а дальше мы тебе поможем ;).

Определи наметанным хацкерским глазом, десктопы каких операционных систем и под управлением каких графических сред изображены на этих пяти скриншотах. Отгадаешь и пришлешь одним из первых правильный ответ на spec@real.xakep.ru, получишь клевый приз :). А в качестве приза мы предоставим тебе возможность бесплатно пройти курс по одному из программных продуктов из нашей Cover Story в Центре Компьютерного Обучения "Специалист" при МГТУ им. Н.Э.Баумана (www.specialist.ru). Этого, конечно, не достаточно, чтобы сразу стать высокооплачиваемым специалистом, но, по крайней мере, лучшего начала для удачной карьеры придумать сложно ;).

А теперь результаты новогоднего конкурса. Если кто не помнит, мы просили самых безбашенных, самых отвязных и самых неформальных перцев запечатлеть процесс празднования Нового Года и прислать нам свои чумовые фотки. Перед тобой тройка лидеров:

1.

Больше всего нас порадовали фотки этой веселой компашки. Они (фотки) прямо пропитаны атмосферой полного раздрая и вселенского дестроя ;). Первое место!

2.

А этот амигос, видимо, решил замутить себе какой-то hell-коктейль, от которого у него сигаретные бычки из ушей полезли :). Почетное второе место!

3.

Ну, и третий призер, который даже рассказал предысторию своего новогоднего превращения в особу противоположного пола. Оказывается, перец пошел на это ради получения прав на смену топика в своем любимом чате! Можно сказать, хакнул админа ;), правда весьма экзотическим способом. Третье место!

Со всеми победителями мы свяжемся, пригласим в редакцию и одарим ценными подарками ;). Всех с новым го..., тьфу, точнее, удачного весеннего отрыва!!!

Содержание