Спецвыпуск Xakep, Содержание номера # 015

Cover 015 |
Статья | Стр.
Интра | 001
Контент | 002
Вдыхая пыль веков: прогулка по музеям без отрыва от стула. | 004
On-Gamezzz: обзор on-line игр. | 008
Как обустроить жизнь в сети. | 010
Шалости на бесплатных хостингах | 012
Net.art - похмелье вебмастера | 014
Интервью с Мэри Шелли | 016
Обзор книu по вебу | 018
Софт perl-разработчика | 020
Flash 5, сайты делаем опять. | 022
Офис через браузер | 026
Кибергеография, или Дайте мне глобус Интернета | 030
Промоушен своей паги. Как раскрутить свой сайт. | 038
Сайт с доставкой на дом: тестируем оффлайн-броузеры | 040
Грузите апельсины бочками: особенности национального download'а | 042
Сам себе сервер | 044
Реальный веб-дизайн | 048
Dreamweaver - король WYSYWIG'ов | 050
Трехмерное счастье Xara3D | 053
Взлом и защита DNS-сервера | 055
Тетя Ася приехала... с семьей | 057
Обзор счетчиков и рейтингов | 059
По ту сторону браузера | 061
Картинки в авоське: Форматы графических файлов в интернете | 062
Как замутить Shell | 064
Атака Кевина Митника | 066
Черви в паутине | 068
Комикс | 070
Варезные залежи в IRC | 074
Сетевые прелести никсов | 076
Оживи свой сайт | 078
Лего-дизайн или веб-конструкторы | 080
Новости браузеров и почтовиков | 082
Обзор и тест фаерволов | 086
Фильтры рекламы: пособие киллера | 088
Кино о сети или МЫ глазами Голливуда | 090
Мобильное западло | 092
ASP - зеркало информационной революции. | 094
Несколько слов о том, где живут mp3 | 098
Сборная CURLянка | 102
Шифруемся! Крипто в локальных сетях | 104
Оформи сайт своими ФриХэндами | 106
Сам себе мультипликатор | 111
Несколько звуков о вреде Интернета | 113
Интернет-2: фантастическая реальность или реальная фантастика? | 115
USEnet: хорошо добытое старое | 117
Tip oF zi Day: ATI-команды для мопеда | 121
Спец-самец-конкурс | 123
WAP | 124


Спецвыпуск Xakep, номер #015, стр. 015-001-1, Сеть. WWW. Интернет. Всемирная паутина

Сеть. WWW. Интернет. Всемирная паутина

Спецвыпуск Xakep, номер #015, стр. 015-001-1

Те времена, когда этими словами дети пугали своих мам, прошли. Теперь мы покупаем хлеб и компакт-диски в соседних магазинах тремя щелчками мышки, вечерком можем выбраться на экскурсию в Лувр или Эрмитаж, а для отправки письма не нужно бежать на почту за маркой. Теперь можно проводить в сети очень значительную часть своей жизни - учиться и работать, развлекаться и общаться, даже виртуально заниматься сексом. Больше того - сеть опутала почти всю планету! И теперь неважно, где ты - живешь в Москве, учишься в Гарварде, работаешь в Силиконовой Долине, общаешься с девчонкой из Перу. Удобно, правда? Жизнь стала прекрасной - а прогресс продолжает свой бег, и не такие чудеса ждут нас завтра. Но помни - у каждой медали есть и обратная сторона...

Аэропорты Америки уже оборудованы системой камер, в реальном времени снимающих лица пассажиров и сличающих их с фотками важных преступников, хранящимися на центральном сервере. Каждый твой шаг в сети отслеживается десятками счетчиков и программами-анализаторами (конечно же, мы не собираем никакой приватной информации!). Каждое твое письмо может быть перехвачено и прочитано любым заинтересованным человеком или корпорацией. Мир снова сжался до размеров маленькой деревушки, где каждый может узнать о соседе все. Скажи - ТЕБЯ это устраивает?

Как мне хочется верить, что нет! Что ты называешь себя хакером не потому, что сваял по нашим рецептам простейший вирь на VB, послал трояна другу Васе или сумел найти кряк на асталависте...

Для того чтобы быть или чувствовать себя хакером, не обязательно что-то сломать. Все намного проще - посмотри на устройство этого мира, в котором тебе предстоит жить (хочешь ты этого или нет). Читай протоколы и стандарты пакетной связи, учись пользоваться багами и фичами новейшего софта. Изучай примеры успешных атак и не менее успешных защит. Вникай в тонкости работы серверов на разных платформах и секреты оптимизации кода.

И, может быть, в какой-то день ты увидишь, что тебе вовсе не надо делать что-то особенное. Что ты можешь просто идти СВОЕЙ дорогой - дорогой, которую выберешь себе ТЫ сам. А мир - будет послушно прогибаться в такт твоим шагам.

Сеть... WWW... Интернет... Всемирная Паутина...

Удачи тебе!

Мэддок и СПЕЦ-crew

Содержание


Спецвыпуск Xakep, номер #015, стр. 015-002-1, Вдыхая пыль веков: прогулки по музеям без отрыва от стула 4

Вдыхая пыль веков: прогулки по музеям без отрыва от стула 4

On-Gamezzz: обзор on-line игр 8

Спецвыпуск Xakep, номер #015, стр. 015-002-1

Бойцы невидимого фронта 10

Шалости на бесплатных хостингах 12

Net.art – похмелье вебмастера 14

Интервью с Мэри Шелли 16

Обзор книжек по вебу 18

Софт для perl-разработчика 20

Flash номер пять, сайты делаем опять 22

Сам себе мультипликатор 26

Софт из браузера 30

Кибергеография, или дайте мне глобус Интернета 34

Построй свой домик в Интернете 36

Занимаемся промоушеном – раскручиваем свой сайт 42

Сайт с доставкой на дом – тестируем оффлайн-броузеры 44

Грузите апельсины бочками: особенности национального download’a 46

Сам себе сервер 48

Реальный веб-дизайн 52

Настрой свой модем 54

Dreamweaver – король WYSIWYG’ов 56

Трехмерное счастье Xara3D 60

Взлом и защита DNS-сервера 62

Тетя Ася приехала... с семьей 64

Обзор считалок 66

По ту сторону браузера 68

Картинки в авоське: форматы графических файлов в Интернете 70

Обвешанный Shell 72

Атака Кевина Митника 74

Черви в паутине 76

Комикс 78

Сетевые прелести никсов 82

Оживи свой сайт – вешаем халявные компоненты на хомпейдж 84

Лего-дизайн, или веб-конструкторы 88

Варезные залежи в IRC 91

Новинки браузеров и почтовиков 92

Защита огнем – тест файрволов 96

Фильтры рекламы: пособие киллера 98

Интернет-2: фантастическая реальность или реальная фантастика? 100

Кино о сети, или МЫ глазами Голливуда 102

Сборная CURLянка 106

Паранойя с открытым ключом 108

Мобильное западло в сети 110

Раз, два, три, четыре, пять, я иду искать – или несколько слов о том, где живут mp3 112

USEnet: хорошо добытое старое 116

ASP как зеркало информационной революции, или создай интерактивный сайт за полчаса 118

Оформи сайт своими ФриХэндами 122

Мобильный Интернет ака W@P 126

СПЕЦ-самец-конкурс 128

Содержание


Спецвыпуск Xakep, номер #015, стр. 015-004-1, Вдыхая пыль веков: прогулка по музеям без отрыва от стула

Вдыхая пыль веков: прогулка по музеям без отрыва от стула

Donor (donor@real.xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-004-1

Неблагодарный труд свалился на меня сегодня - прогрузить тебя виртуальными музеями и всякой мишурой, называемой самообразованием. Но ты не парься - попробовав это занятие на себе, я убедился, что не все так кисло. Наоборот, я даже проперся! Кроме того, мэн, смотри, какие бенефиты ты обретешь. Тебе не нужно ехать, скажем, в Питер, чтобы понять, прет тебя Эрмитаж или нет. Ты с легкостью составишь себе культурную программу отвисания в Париже. Ты всегда сможешь состряпать рефератец по культурологии или удивить по самое не балуйся историчку-истеричку. Твоя девчонка теперь не скажет, что ты темно-серый, потому что ты не можешь поддержать разговор об искусстве. Ты и сам сможешь прогрузить хоть толпу девиц. И вообще, интересно посмотреть в час досуга, как это все реализовано в Инете. А чтобы тебе не было тошно, буду разбавлять высокое искусство интересными фишками.

Северная Пальмира

В Питере музеев полно. Бывший центр империи как-никак. Тут куда ни пл... посмотри, везде дворцы, арсеналы, крепости, адмиралтейства и еще куча всего. Один Эрмитаж чего стоит! Обойти его полностью за один день абсолютно без мазы. Лично проверял. Чем же прославился Питер в Инете?

Эрмитаж

http://www.hermitage.ru/

Зимний дворец. Тут наши просвещенные монархи три века кряду копили разные античные фенечки, драгоценные рюшечки и прочие безделушечки. В огромных количествах представлены живопись, скульптура, драгоценности, наряды, убранство и египетские жмурики. Мэнам будет интересен раздел "арсенал". Раньше не могли сделать просто "пушку" или "перо", обязательно ваяли произведение искусства со зверем на рукоятке и золотым орнаментом на клинке. Мочишь вражину и получаешь эстетическое наслаждение. А турнирные доспехи - просто отпад! После тщательного изучения раздела "Русское искусство эпохи Екатерины II" ты сможешь грузить своей тетке инфу про Катькино мундирное платье. Жаль только, зажали где-то обнаженный портрет императрицы :). Зато можно заценить европейское искусство в виде известной "Мадонны с младенцем" Леонардо и "Данаи" Тициана. Коллекция монет Эрмитажа поистине огромна: аж 63360 штук. Ты когда-нибудь видел тетрадрахму или пентикапей? А в одном из залов восседает огромная статуя Зевса на троне. В другом крыле (тоже на троне, тоже восседает) восковая кукла Пети Первого. Это такая милая шуточка от Растрелли.

Сайт выполнен очень качественно. Еще бы, ведь суппортит это дело маленький гигант нетрадиционного секса - IBM. Тут же я отрыл суперфишку - "виртуальная экскурсия по залам Эрмитажа". На плане выбираешь зал, и к тебе на тачку грузится небольшой ролик, в котором камера, установленная в центре зала, движется вокруг своей оси. Ты как бы осматриваешься. Грузится все быстро, причем качество для веба просто отменное. Действительно, будто по дворцу пошлялся. Рекомендую!

Пивы разные

http://www.citycat.ru/beer/

В качестве нерекламной паузы заглянем в виртуальный музей... пивных этикеток. Ведь всегда интересно посмотреть, как эволюционировало твое любимое пивчанское и какими заморочками мучался производитель, чтобы привлечь твое внимание к своей бутылке. Экспозиция очень большая. Тут собраны этикетки пива со всего бСССР - даже те, которых уже нет. Представлены этикетки от самых простых до сложных и очень красивых, от советских до первых российских. Ко многим этикеткам прилагаются интересные исторические факты: кто это пиво варил, по чьей лицензии, когда его выпускали и кто пил. Хотя большинство производителей местных экспонатов тебе хорошо известны, ты будешь сильно удивлен, увидев в продаже некоторые из их марок. Образовывайся ;)! Очень много смешных этикеток типа эстонского "Сакусский черт" и "Тартусское летнее" с телевизором на этикетке. Я с удовольствием поглядел на этикетки "Клинского" совковых времен за 29 копеек... А ты видел экспортный вариант "Клинского"? Ой, а первая этикетка "Балтики"!.. Умора! Кстати, в советские времена сортов пива было не так уж и мало. Так что не пропусти. И вообще, большая кружка пива на морде - это по-нашему!


Спецвыпуск Xakep, номер #015, стр. 015-004-2, Вдыхая пыль веков: прогулка по музеям без отрыва от стула

Вдыхая пыль веков: прогулка по музеям без отрыва от стула

Donor (donor@real.xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-004-2

Его императорского величества кунштов камера

http://www.kunstkamera.ru/

Веселый человек был Петя Первый! Зубы подданным драл, уродцев коллекционировал и других на все это дело смотреть заставлял, приучая к кофе и плюшкам. Вот так и получилась Петровская кунсткамера. Ну, мы же все питаем нездоровую страсть к трупикам и формалинчику, пройти сие виртуальное представительство я не мог. Конечно, приятнее взглянуть на вскрытые черепные коробки, коллекцию зубов и мантию дикого царька из перьев калибри вживую, но за неимением этой возможности заюзаем Инет. На этом сайте тебе покажут некоторые экспонаты из довольно обширной экспозиции. Сросшиеся младенцы, скелет великана-француза, предметы обихода русских ведьм и дальневосточных шаманов. Посмертная маска Пети тоже ничего себе :). Навигация сделана в виде планов этажей кунсткамеры, на которых отмечены тематические экспозиции. Кликнув по ним, получаешь некоторое количество уродцев или редкостей. Вот, считай, в Питер и съездили.

Мани, мани

http://www.museum.com.ua/

Еще дешку отдохнем и сгоняем за границу... на Украину. Одесский музей нумизматики. Деньги любишь? Ну конечно, от пары зеленых лимонов не отказался бы! А может, они как раз и завалялись в коллекции твоего деда-нумизмата. Ты же не в курсе, что это за кусочки серебра и меди. Так что срочно изучай экспозицию! Да и просто прикольно посмотреть, какие деньги и денежные недоразумения бывают. Вот, например, на Киевской Руси деньги были ромбиком. Я же сразу вломился в раздел так называемого "независимого периода". Это в смысле, когда Союз нерушимый порушили... Это цирк! Новые независимые страны такого накуролесили :)! Как тебе два миллиона карбованцев одной монеткой? Так прямо и написано: "2 мiльйони карбованцiв". Очень интересен раздел "ХУШ век - 1991 год": можешь узнать, как выглядел всем известный червонец, а также последние совковые юбилейные деньги из платины и палладия.

Град столичный

Москва - тоже городок на историю не бедный: и захватывали уж ее и жгли дотла, так что музеев тут тоже немерено, но весь прикол в том, что сами москвичи в них часто не были. Логика зашибись - зачем идти в музей, когда он тут, рядом? Хорошо хоть можно через Инет пару глаз кинуть ;).


Спецвыпуск Xakep, номер #015, стр. 015-004-3, Вдыхая пыль веков: прогулка по музеям без отрыва от стула

Вдыхая пыль веков: прогулка по музеям без отрыва от стула

Donor (donor@real.xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-004-3

Кремль

http://www.kreml.ru/

Звиняйте москвичи, но по сравнению с Эрмитажем пага Кремля тихо сосет леденец. Сами пишут, что "Кремль - символ российской государственности", а его представительство в Инете какое-то дохлое. Может, это временный вариант? Как бы то ни было, инфы здесь нарыть можно. За кнопкой "Московский Кремль" скрылась карта, на которой помечены все его здания. По щелчку в нужный объект вываливается окошко с его фоткой. Под картой дана краткая историческая справочка по Кремлю в целом. В разделе "Экспозиции" выложена более подробная инфа по каждому зданию и что там внутри. Можно посмотреть и почитать про Царь-пушку, Царь-колокол, Успенский собор, Колокольню Ивана Великого, Оружейную палату. Странно, но про Алмазный фонд ни слова. Вломившись в Оружейную палату, я обнаружил план здания с общими фотографиями и описаниями отдельных залов, но про конкретные экспонаты ничего написано не было. Также на паге есть инфа по проходящим в Кремле выставкам. В общем, вполне можно найти материал для реферата и понять, хочешь ты сюда или нет.

Немного о политике

http://www.russianbook.ru/plakat.asp?listpage=1

Для перерыва можно заглянуть в галерею политических плакатов 1917 - 1924 годов. Очень полезное место для того, кто интересуется, почему у нас в Думе так весело. Чтобы получить ответ, достаточно изучить местные экспонаты. "Голосуйте за номер такой-то!!!", "Землю крестьянам!", "Швейцарию швейцарам!". Совсем меня добил плакат с таким мегаправильным парнем и слоганом: "Юные ленинцы - дети Ильича!" Вот, плодовитый дед был :)!

Третьяковка

http://www.tretyakov.ru/

Еще один московский мегаочаг культуры - Третьяковская галерея. Дядя Третьяков поддерживал отечественных производителей, поэтому основную часть экспозиции галереи составляют работы русских художников - от древних иконописцев до товарища Малевича с его пресловутым "Черным квадратом". Здесь ты также можешь заценить шедевры Васнецова ("Три богатыря"), Шишкина ("Утро в сосновом бору" aka мишки), Левитана, Репина, Сурикова ("Боярыня Морозова"), Айвазовского ("Черное море")... и моего любимого Петрова-Водкина ("Купание красного коня"). Третьяковка довольно обширная, поэтому, если попытаться обойти ее всю, можно получить конкретный художественный овердоз. Тут тебе поможет раздел "Залы экспозиции", где даны планы галереи с указанием, какие художники где висят... не сами, конечно, а их работы ;). Составляй маршрут и вперед. По секрету тебе шепну, что тут очень прикольно знакомиться с тетками. Они хоть и в музей пришли, но так и косят лиловым глазом на проходящих парней. Так что не зевай!

Worms forever!

http://worms.ecology.net.ru/museum.html/

Чего только не увидишь в Инете! Я просто тихо стек в тапки, когда, блуждая по сети, наткнулся вот на это. Музей дождевого червя - это стильно :). Хозяйка этого места с таким смаком описывает жизнь, поведение и... хмм... любовь червей, что я просто теряюсь... Ну, зацени пару перлов: "Норные дождевые черви - эти крупные, красивые и сильные животные с темной спинкой и уплощенным хвостом...". Про секс: "Когда я их заметила, они лежали, тесно прижавшись друг к другу. Поясок каждого был прилеплен слизью к телу другого. Кольца медленно сокращались, будто черви очень-очень медленно ползли друг по другу, однако на самом деле они не двигались с места. Всасывающими движениями они начали "целовать" половые сегменты друг друга с брюшной стороны. Тела их содрогались, сегменты напрягались...". Еще ты узнаешь, как содержать червей дома, сделать им жилище, кормить и наблюдать. А еще... Представь себе, Чарльз Дарвин тоже любил червей. Он первый просек, что роль их на Земле огромна.


Спецвыпуск Xakep, номер #015, стр. 015-004-4, Вдыхая пыль веков: прогулка по музеям без отрыва от стула

Вдыхая пыль веков: прогулка по музеям без отрыва от стула

Donor (donor@real.xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-004-4

Забугорье

Ну, если в родном городе нам мешает стуловое притяжение, то поехать за границу может помешать банальное отсутствие финансов. Здесь роль Инета переоценить сложно.

Лувр, просто Лувр

http://www.louvre.fr/

Правда, известное название? Тут хранятся всемирноизвестные Мона Лиза в комплекте со своей загадочной улыбкой и Венера Милосская. И заценить их тебе теперь вполне по силам. Лезь на сайт Лувра и атмосферься по полной программе: живопись, скульптура, древности. Смотришь и удивляешься, какие же талантливые были наши предки! Какие красивые тела выстругивали из камня древние греки и не менее древние римляне, какие реалистичные полотна рисовали испанские и итальянские художники! Картина - прямо форточка в Венецию ХУI века! И пикантные персонажи здесь попадаются ;). Например, разглядываю я статуйку спящей на перинке красавицы-богини, а под ней подпись "Спящий гермафродит", ну сын Гермеса и Афродиты. А ты говоришь: "Музеи - это скучно!".

На сайте Лувра тоже есть виртуальные экскурсии. Так же, как и на паге Эрмитажа, нужно выбрать на карте зал, и тебе загрузят большую айвишку, в которой камера этот самый зал обходит. В общем, качай и изучай.

Музей эротического искусства

http://www.opkamer.nl/amea/

В Париже есть музей секса, но его пага (http://erotic-museum.com/) на данный момент не фунциклирует. Но я же не мог оставить тебя без клубнички, поэтому нашел он-лайн музей эротического искусства. Естественно, все экспонаты (картины и скульптуры) здесь посвящены ему... сексу, но это, действительно, арт, а не банальная порнушка. Шедевры созданы в разные эпохи и выполнены в разных стилях. Можно заценить древние перуанские статуэтки теток с огромными отверстиями и неказистые парочки, спаривающиеся в разных позах. Можно посмотреть японскую графику ХУI-ХУШ веков. Очень своеобразно. Представлены шедевры европейских мастеров кисти и енга ХУI-ХIХ веков, причем среди авторов попадаются дамы. Есть и более современные, несколько примитивистские работы. Однако все это очень необычно, поэтому разглядывать и читать (хоть и на фиглише) дико интересно.

Британский музей

http://www.thebritishmuseum.ac.uk/

Наверняка ты слышал о Британском музее в Лондоне - его часто юзали в разных фильмах. Замечательно это заведение тем, что великие колонизаторы - англичане - натаскали сюда предметов древней культуры со всего света: из Египта, из Африки, из Океании, из Южной Америки - причем просто до пятой точки. Тут хранятся египетские фараоны, африканское золото, зубастая маска Тецкоатля из Мексики, ацтекские календари, фрагменты римского Парфенона и еще куча всякого джанка. А вот сайт Британского музея меня не зацепил. Тут очень много рассказывают о методах изучения и реставрации древностей, об инструментах и технологиях, но найти инфу об экспонатах почти анриал. Краткая справка об экспозиции и пара картинок. А где все? Где виртуальные экскурсии? В общем, если нужна инфа по Британскому музею, то лучше почитать статью по адресу: http://kuka.kontorakuka.ru/countries/europe/uk/culture.htm - во-первых, здесь все вместе, а во-вторых, все по-русски.


Спецвыпуск Xakep, номер #015, стр. 015-004-5, Вдыхая пыль веков: прогулка по музеям без отрыва от стула

Вдыхая пыль веков: прогулка по музеям без отрыва от стула

Donor (donor@real.xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-004-5

Коммуналка

http://komunalka.spb.ru/

Хо-хо! Рунет иногда просто поражает! Дивись: виртуальный музей коммунальных квартир. Ведь правда, коммуналки - это потрясный феномен Совка и современной Росси. Люди, загнанные в дикие условия, просто звереют и готовы за пару квадратных метров грохнуть соседей. Скупердяйство доходит до абсурда. А какие изобретения рождаются в коммуналках! И ведь многие и сейчас так живут...

В настоящее время экспозиция музея насчитывает две питерские коммунальные квартиры, но это отнюдь не мало, так как в каждой из квартир еще до фига чего посмотреть. Например, на входной двери обязательно тусуется штук -дцать кнопок с надписями типа - "Сидорову звонить 800 раз". А что ты подумаешь, если увидишь в кухне под потолком три совершенно независимые друг от друга лампочки и три отдельных выключателя для них? И почему, если кто-то в ванной, на газовой колонке в кухне висит табличка "Моются!"? Также в музее можно заценить "виды коммунальных квартир". Выбираешь на плане квартиры соответствующую камеру и получаешь потрясающий пейзаж общего толчка или черной лестницы. Отдельного упоминания заслуживают "голоса коммунальной квартиры" в mp3. Это надо слышать! В общем, мэн, радуйся, что у тебя есть отдельная квартира. И полегче там с соседями ;).

Не артом единым...

Художественные галереи - это далеко не все, что делает доступным Инет. Ведь очень много музеев посвящено естественной истории и технике.

Минералогический музей

http://www.fmm.ru/index.html/

В этом музее много нудного, типа карт месторождений, природных процессов образования минералов, их добычи и прочее, прочее... Но есть реально интересные вещи, от которых разгораются глаза, особенно у герлов. Тут собраны сумасшедшие сочетания разных пород и минералов. Прямо цветы каменные! Коллекция кристаллов поражает разнообразием форм и оттенков. 3D-Studio отдыхает! Также можно посмотреть и почитать про различные метеориты, которые долбили нашу Землю. Что представляют собой, откуда взялись, из чего состоят, где и когда их нашли. Кстати, веселые феньки! Один из них с легкостью профигачил насквозь толстенные бревна крыши зерносушилки. Также здесь можно увидеть потрясающие поделки из камня: огромные малахитовые чаши, элегантные чашки из агата работы Фаберже, фигурки солдат из разноцветного камня (причем и детали, и цвета как натуральные). А коллекция драгоценных камней семейки Фаберже наверняка заинтересует твою подружку. Можно почитать историю музея и проложить маршрут по плану залов. Вперед, Данила-мастер!


Спецвыпуск Xakep, номер #015, стр. 015-004-6, Вдыхая пыль веков: прогулка по музеям без отрыва от стула

Вдыхая пыль веков: прогулка по музеям без отрыва от стула

Donor (donor@real.xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-004-6

Паровоз open air

http://parovoz.com/pereslavl/main.html/

Это музей железнодорожного транспорта под открытым небом. Представляешь, челы из этого музея коллекционируют паровозы (куда там султану Брунея!), ремонтируют их и испытывают. Тут собрано множество локомотивов, вагонов, цистерн и вагонеток. Выставлены паровозы начала ХХ века и более современные дизельные локомотивы. Но интереснее всего специальная техника: такая, как пожарный тепловоз и танк-паровоз. Интересно взглянуть на цистерну начала века и на различные дрезины. Но особенно порадовал рельсовый автомобиль ЗиМ (ГАЗ-12). Натуральный членовоз, только шпарит по рельсам! Жаль, прокатиться нельзя.

Привет, оружие!

http://www.arms-museum.tula.ru/win/

Как истинный мэн ты просто обязан знать все об оружии! Поэтому Тульский государственный музей оружия - то, что доктор прописал. Тула всегда славилась своими мастерами. Не знаю, как тебе, - а мне всегда хотелось подержать настоящую кавалерийскую саблю или гвардейский палаш, порубить им чего-нибудь со всей дури :). Красивые эфесы, гербы на рукоятях, золотая резьба на лезвиях. От таких игрушек девчонки будут просто без ума. Согласись, захватывающе проследить развитие ружей и пистолетов от красивых, но не очень надежных ударно-кремниевых ружей до строгих и грозных винтовок и револьверов. Однако не стариной единой жив музей. Очень интересен раздел "Боевые малютки". Я просто прифигел, когда увидел микроревольвер весом всего 8,97 грамма. И он еще и стрелять как-то умудряется! Конечно же, не забыто автоматическое оружие. Тут представлен и легендарный пулемет "Максим", и героический пистолет-пулемет Шпагина, с которым воевали наши деды в Отечественной войне, и пистолет Макарова, и современные "Калаши". Также представлены авиационные пулеметы и автоматические пушки. Отдельный раздел - "Оружие спецназначения" (наши фишки ;)). Тут и малогабаритные пистолеты, и подводный автомат, и бесшумное оружие, и складной автомат, и снайперские винтовки. В общем, приятель, ты должен это видеть!

Морские волки

http://submarine.narod.ru/

А в этом виртуальном музее челы собрали экспозицию, посвященную кое-чему помощнее. Подводные лодки - это интересно! Сейчас наши рубежи охраняют гигантские подводные крейсеры размером с девятиэтажный дом, но с чего все началось? Боец, ты узнаешь это в музее подводного флота. Я, например, узнал, что первую подводную лодку в России построили еще в 1834 году. Она погружалась всего на 12 метров, а экипаж составлял 8 человек, но уже тогда малютка несла на борту... ракеты. В начале ХХ века лодки стали больше, мощнее и страшнее. Они запросто топили крейсера и ныряли уже на 100 метров. Вторую мировую войну вообще сложно представить без подводного флота, и в этом зале он представлен в избытке: тут тебе и русская "Щ-307", и немецкие "U-14" и "U-995", и американская "Salmon". Новейшая история подводных лодок также представлена очень хорошо. Наши лодки: от "Ленинского комсомола" до Проекта 949А "Оскар II" с ядерными ракетами "Гранит" на борту. Американские атомные подводные лодки "Лос-Анджелес" и "Морской волк", укомплектованный "Томагавками". Очень здорово подобран материал: кроме инфы по экспонату, представлены его схемы, рисунки и фотографии. Must see!


Спецвыпуск Xakep, номер #015, стр. 015-004-7, Вдыхая пыль веков: прогулка по музеям без отрыва от стула

Вдыхая пыль веков: прогулка по музеям без отрыва от стула

Donor (donor@real.xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-004-7

И о компах

http://old.h1.ru/index.shtml/

В Инете полно музеев, посвященных развитию компьютерной техники у нас и в мире, но большинство из них слишком замороченные на огромных старых монстрах, особенностях их архитектуры, организации ввода-вывода, командах и прочей пурге. Но это уж слишком скучно! Но в этом музее выставлены на всеобщее обозрение древние персоналки. Какие они были и как с ними жилось. Старые киберпанки смахнут кремниевую ностальгическую слезу, а ньюби наверняка узнают много интересного. Тексты легкие и снабжены иллюстрациями. Самый наглядный показатель развития персоналок - это компьютерные игры. Здесь ты найдешь скрины из наиболее известных игрушек под эти компы. Представлены БК, Львов, Микроша, Орион, SPECTRUM, AMIGA и многие другие.

Конец осмотра

Видишь, Инет - замечательная вещь, если его юзать грамотно. Сколько всего интересного можно нарыть, как здорово можно провести свободное время или подготовиться к прогулке с твоей дивч. И не скучно это совсем - по музеям ходить! Развивайся! Меняй свой серый оттенок на что-нибудь более стильное, и в собеседниках (собеседницах) недостатка не будет.


Спецвыпуск Xakep, номер #015, стр. 015-008-1, On-Gamezzz: обзор on-line игр

On-Gamezzz: обзор on-line игр

UFO (ufobject@mail.ru)

Спецвыпуск Xakep, номер #015, стр. 015-008-1

Привет, геймер! Или не геймер? А какая разница! Все мы любим иногда поиграть в игры. Некоторые мягкими игрушками кровати набивают, некоторые в тетрис играют на работе, а некоторые, играя, работают... Я, например :).

А оно надо? aka обоснуем

Но сегодня речь не об этом. В этой статье я не буду грузить тебя про всякие там DNS и RSH-атаки, здесь я устрою тебе обзор развлекухи! Зачем? Вот, например, сломал ты сервер, порадовался и решил отдохнуть. Или засандалил варез в закачку, но уйти не можешь, так как ждешь в Аське, пока твоя герла попудрит... нет, не носик, а чьи-нибудь еще мозги :). Париться инфой и доками тоже не рулит... Вот тут-то тебе и придут на помощь on-line игры! "Скукота и никакой графики," - скажут некоторые... Ну да, бывают и скучные, а бывают такие прикольные, в которых ты просто утонешь! Начнешь и прилипнешь :). Если ты мне все еще не веришь, то пробеги по всем ссылкам и сам убедишься. Ну что, начнем?

E-mail тетрис

http://www.alex-soft.net/tetmair.html

А начнем мы в порядке возрастания по шкале интереса. Первая игра, про которую я хочу тебе рассказать, - бессмертная игра Тетрис. В нее играли все без исключения: мужчины, женщины, дети, секретутки, бабушки, дедушки и их собачки. Естественно, эта игра не могла обойти стороной сеть. И вот появились online-тетрисы! Перед тобой Тетрис, в который можно играть по сети вдвоем. Строим свое светлое будущее и гадим в "стакан" соседу. Детматч, однако. В свое время я так обыгрался в "Тетрис", что от одного упоминания этого слова тошно становится, но классику надо знать. Поэтому я решил погаматься немного и... прирос. Значительно позднее нечеловеческими усилиями отодрал себя от "стакана" и пополз дальше.

Быки и коровы

http://alexp.ru/game/bull/

До того, как я нашел эту игру, я думал, что "Быки и Коровы" - это рассылка такая. Но теперь понял, что это еще и игра. На самом деле игрушка дешевая, но увлекательная. Я долго не мог от нее оторваться, все хотел угадать несколько чисел. Хреново у меня получалось, но победа, в принципе, не важна, главное - участие ;)!

Правила в игре следующие: компьютер загадывает число, а ты должен его отгадать. Если ты угадал, то тебе начисляется столько очков, сколько у тебя осталось неистраченных попыток. Соответственно, если ты не угадал, у тебя отбирают одно очко. Так что лучше отгадывать... Незаконченная игра, соответственно, тоже одно очко не в твою пользу. "А причем здесь крупнорогатый скот?" - спросят некоторые... Да при том, что если ты угадываешь цифру, которая стоит в твоем числе на том же месте, что и в числе, загаданном компьютером, то ты - БЫК (во как!), а вот если эта цифра просто встречается в числе компьютера, то ты - КОРОВА! Понял? Вот так классифицируют игроков создатели этой игры. Веселые создатели. Встречу я их в лесу связанными...

Jack Pot

http://www.gales.co.uk/fsgame.htm

Пиво любишь? По вспыхнувшей в твоих окулярах надежде вижу, что любишь :). Я тоже люблю. Так что эта игра для нас! Те, кто не пьют, пусть идут в русалочку играют. Ушли? Тогда можно продолжать. Так вот, эта игра является симулятором реального JACK POT'а из казино. Что тут можно получить реально? Да ничего. Ты ж в виртуале! Значит и пиво тут виртуальное. Выиграл виртуально, вот и напивайся виртуально. Люди с хорошей фантазией могут играть в нее бесконечно! И почки с печенью тоже виртуально сажаются :)! Так что все рулит! А если серьезно, то иногда интересно поиграть в такого типа игры. Сидишь, крутишь барабанчики, наблюдаешь, как тебя комп на пиво обувает, и ничего не надо. Зато потом из какого-нибудь притона в одних носках не выкинут. Короче, поиграй! Я уверен, тебе понравится.


Спецвыпуск Xakep, номер #015, стр. 015-008-2, On-Gamezzz: обзор on-line игр

On-Gamezzz: обзор on-line игр

UFO (ufobject@mail.ru)

Спецвыпуск Xakep, номер #015, стр. 015-008-2

Сбей баннер

http://pyva.net/play/banners.html

Вот, ты, наверное, смотришь на скриншот и думаешь: "И что ты мне эти баннеры показываешь? Я их тоннами в сети ежедневно вижу!" А вот и обломись! Это не просто рекламка - эти баннеры летать умеют! А до кучи ты их еще сшибать можешь своей боевой мышью. Прикинь, тебе за это еще и очки начисляют. Так что если надоела тебе всякая рекламная чушь, то здесь у тебя есть возможность оторваться: пострелять их из рогатки. Вот только неурядица здесь маленькая... Разработчики этой игры сильно схитрили. Когда ты попадаешь по баннеру, у тебя появляется дополнительное окошко IE, в котором ты наблюдаешь... правильно, загружающийся сайт, на который и ведет этот самый зло-банер. Зато всем весело! Сайты посещаются, юзверь веселится, разработчик бабло зашибает. Все как в сказке - чем дальше, тем страшнее. Игра для тех, кто любит рекламу - или наоборот.

Останови БГ

http://www.dndz.dp.ua/games/flash.shtml?computer

Ох, и не любят Гейтса в нашей стране и на сопредельных территориях! Ох, как не любят! Вот еще одно издевательство над бедным Биллом. Как всегда, Гейтс строит злобные планы по захвату мира и пытается овладеть твоим боевым компом. Он всеми силами старается прорваться через твой зоркий взгляд и поставить на твою машину Win2000, попутно содрав с тебя за это деньги. Вот редиска! Ты должен всеми правдами и неправдами отбиваться от него своей мышью. Как только увидишь на экране эту очкастую гамадрилу, долби по ней мышью! БГ разлетится на кусочки, и твой комп останется в безопасности.

Игра сделана просто здорово. Писалась она на Flash'е, и, соответственно, анимация хорошая. И, кстати, не пугайся, когда при попадании по этому урлу у тебя на экране появится название "ЗАКИДАЙ КЛОУНА ПОМИДОРАМИ", это просто веб-дизайнеры напутали немного. Но напутали по теме :).

Секс-телефон

http://www.dndz.dp.ua/games/flash.shtml?sextel

Перец, ты когда-нибудь занимался сексом по телефону? Знаю, знаю... Не раз подключался к телефону соседей, после чего к ним счета приходили... Но в этот раз тебе придется заняться этим делом не просто по телефону, а по мобильному телефону! Не кисло, да? Мало того, что тебе не нужно экономить на разговоре, так тебе еще и нужно как можно больше потратить бабла со счета этого аппарата! Цель игры состоит в том, что игроку нужно уйти в минус аж на 2000$! Только в этом случае перед ним должен предстать большой сюрприз! К сожалению, этого сюрпрайза я сам не видел, но разработчики распинаются, что он будет. Ну что же, придется поверить на слово. Игра написана на Flash'е, и к ней прилагается звуковое сопровождение. Как начнешь играть, не забудь включить звук!


Спецвыпуск Xakep, номер #015, стр. 015-008-3, On-Gamezzz: обзор on-line игр

On-Gamezzz: обзор on-line игр

UFO (ufobject@mail.ru)

Спецвыпуск Xakep, номер #015, стр. 015-008-3

Отстрели ламеру...

http://www.dndz.dp.ua/games/flash.shtml?lamer

И напоследок хочу познакомить тебя с замечательной игрой! Здесь тебе предоставят уникальную возможность истреблять ламера, который постоянно выглядывает из всяких непотребных мест и кричит примерно следующее: "Что такое UNIX? Полная фигня! Я люблю Windows!". Ну, за такие слова можно не только этого хитрозадого ламерюгу убить, но и разработчика до кучи! Игра представляет собой смесь игры "Утки" на "Денди" и "Дума". Главный герой постоянно выкрикивает разные фразы и пытается скрыться от руки правосудия. Ты, в свою очередь, должен стрелять в него из двустволки. При попадании кровь ламера брызгает на твой монитор, что доставляет неописуемую радость! Игра - просто рулез! Это даже приятнее, чем мочить Децела. Настоятельно рекомендую заползти по указанному урлу и погаматься вдоволь.

Хаппу енд?

Вроде все. Списывай урлы и наслаждайся! Только особо не увлекайся, а то утянет, и все... Залипнешь... Ну, и напоследок хотел бы дать тебе ооочень полезную ссылочку, на случай, если ты решишь нарыть с полсотни online-игр. Вот она: http://vesinet.narod.ru/catalog/11418.shtml. Описать их все в журнале просто нереально, так что выбери сам себе игрушку по душе. Удачи в нелегком геймерском деле!

Привет из далекого космоса, UFO.


Спецвыпуск Xakep, номер #015, стр. 015-010-1, Построй свой домик в Интернете!

Построй свой домик в Интернете!

Спецвыпуск Xakep, номер #015, стр. 015-010-1

Андрей Каролик (andrusha@sl.ru; http://www.dal.net.ru)

Привет, будущий гуру веб-дизайна! Если хочешь сделать свою домашнюю страничку, но пока не знаешь, как, то тебе стоит прочитать эту статью. Здесь я коротко и доступно поведаю тебе основы создания своего сайта. Эта статья сильно отличается от любой обычной книжки по вебу - тут нет ничего лишнего. Правда, я изрядно потужился :), чтобы уместить все нужное и полезное в отведенный мне объем. Так что если до этого ты умел только лепить куличики в песочнице и совсем не знал html, то, прочитав эту статью, ты легко и непринужденно сваяешь свою собственную домашнюю страничку. Запомни, html - это не просто, это очень просто :).

Часть I. Начинаем ваять...

Что такое HTML?

Эти четыре буковки (html) означают HyperText Markup Language, что в переводе с пингвинского - язык разметки гипертекстовых документов. То есть прежде всего это язык разметки, а не язык программирования, как многие думают по незнанию. Нет никаких массивов, циклов или процедур. Есть только тэги - специальные "метки", которыми автор страницы, собственно, и "размечает" html-файл. Тэги заключаются между угловыми скобками "<" и ">", например, так: <body> или <br>. Большинство из них имеет еще и закрывающие метки, которые заключаются между угловыми скобками "</" и ">" - так, в приведенном примере тэг <body> имеет закрывающий тэг </body>. Эти пока непривычные для тебя указатели форматирования сообщают твоему браузеру, как нужно отображать то, что находится между ними. Некоторые тэги имеют еще дополнительные атрибуты, которые ты можешь задать или не задавать вовсе, тогда они будут по умолчанию. Например, текст между тэгами <font color="#FF0000" align="center" size="2"> и </font> будет красного цвета, расположен по центру странички, а шрифт будет иметь размер два (что соответствует двенадцатому вордовскому).

В некоторых тэгах в качестве параметра можно использовать определение цвета; так - в предыдущем примере для текста указан красный. Задается он достаточно просто - с помощью трех составляющих RGB (красный, зеленый и голубой), а записывается в виде #RRGGBB (color="#FFFFF0"). Откуда взять эти составляющие? Можно - в графических редакторах (например, в Photoshop) или в специальных программах, которые позволяют для любого цвета получать их RGB составляющие. Я использую EoHex (http://vtg.org/bsmith) или смотрю в Photoshop.

Для создания страничек есть достаточно много разнообразных html-редакторов, которые упрощают их создание. Но на самом деле любую страничку можно сделать в самом обычном блокноте (NotePad), просто файл должен быть с расширением *.htm или *.html. Кстати, я делаю все только в нем :). На первых этапах советую все делать ручками, так как это поможет лучше понять html и все нюансы при работе с этой зверюгой. А html-редакторы стоит использовать только для автоматизации или выполнения однообразных действий, которые вручную выполнять очень утомительно. К тому же большинство html-редакторов очень помогают при сильном алкогольном опьянении: выделяют разным цветом разные тэги, проверяют тэги на правильность написания и ищут незакрытые тэги.


Спецвыпуск Xakep, номер #015, стр. 015-010-2, Построй свой домик в Интернете!

Построй свой домик в Интернете!

Спецвыпуск Xakep, номер #015, стр. 015-010-2

Все было вроде бы сухо и весело, но дядьки магнаты понаделали много версий браузеров, приляпав чиста свои побрякушки к софту. Возникли проблемы несовместимости кода страничек. В одном браузере все смотрелось прекрасно, в другом - "лучше не надо". Многие стали делать странички под какой-то один браузер, обрезая тем самым часть посетителей с другими смотрелками. Очень часто можно было встретить надпись навроде "Этот сайт оптимизирован под Internet Explorer". Но далеко не каждый напрягал себя установкой нескольких браузеров на комп. В результате наплодилась целая куча сайтов с надписями: "Сделано только для Ишака" или "Смотрите только в НетШкафе". Крутая организация W3C почесала одно место и решила сделать единую спецификацию, которую должны поддерживать все браузеры. Сейчас в ходу спецификация HTML 4.01, а любые выкрутасы отдельных бродилок называются уже рекомендациями. Просветиться ты можешь бесплатно и без очереди на http://www.w3.org .

Что можно поместить на свою страничку?

Практически все. Раньше скорости соединения были на уровне динозавров, и на странички клали в основном текст. Теперь скорости реактивные, и туда кладут тоннами изображения, анимацию, скрипты, pdf-документы, музыку, видео (порнуху в том числе), фильмы, клипы и так далее. Ты можешь начать с простой домашней странички, где будешь ты, твой Тузик и любимый конструктор. А постигнув все азы html, можно пойти в книжный магазинчик и прикупить книжек по Perl, CGI, MySQL, PHP, Java-Script, Java (что уже есть по сути не хтмл, а программирование). Потом сваять небольшой проектик и зарабатывать деньги на показах баннеров, параллельно рассылая свои резюме в конторы :). Специалисты в области интернет-технологий сегодня очень ценятся, на западе их просто отлавливают за... шкирку :). Простой пример - www.omen.ru. Вначале этот сайт делался простым прыщавым парнишкой, я тогда сам только попал в Инет. Выглядел он вначале примитивно - но парень явно отсидел себе все что можно и нельзя, пока забивал туда ссылки. Со временем счетчики у него стали зашкаливать. Сейчас это гиперпроект. Скорее всего, у него его выкупили, или парню капают ежемесячные проценты. Дерзай и ты :).

Список основных тэгов

Чтобы сделать страничку, тебе нужно знать, как строится страничка, какие и как тэги можно использовать. Поехали. Страничка для правильного отображения в любом браузере заключается между тэгами <html> и </html>. По этим буйкам бродилка понимает, что ты используешь формат html. Содержание самой странички заключается между тэгами <body> и </body>. Есть еще заголовок странички, который помещается между тэгами <head> и </head>. В нем размещается разнообразная информация о страничке, например, информация об авторе, титульный заголовок странички или кодировка, которую должен использовать браузер при отображении этой странички. При использовании Java-Script (об этом дальше) здесь же выполняется инициализация переменных и выполнение необходимых действий перед загрузкой странички.


Спецвыпуск Xakep, номер #015, стр. 015-010-3, Построй свой домик в Интернете!

Построй свой домик в Интернете!

Спецвыпуск Xakep, номер #015, стр. 015-010-3

Ниже я перечислю основные тэги, которые ты будешь использовать при создании своей странички. Их не так много, но вполне достаточно, чтобы создавать все странички, которые ты видишь в Интернете. Я опишу тэги не все подряд из спецификации, так как далеко не все они реально используются на практике, а только те, которые тебе будут необходимы и достаточны при создании твоих первых страничек.

<head>...</head> - тэги заголовка страницы. Туда можно забить много нужной инфы, но здесь мы рассмотрим только один из используемых там тэгов:

<title>...</title> - позволяет задать заголовок странички. Если сайт состоит из нескольких html-ек, то каждой страничке можно задать свой заголовок. Точнее, даже нужно, так как в History (посещенные html-ки) браузера они будут сохраняться именно по этим заголовкам. И, понятное дело, если он будет одинаковый у всех, то и воспользоваться History будет затруднительно. Аналогично с добавлением в Favorites (Избранные) - там тоже используется для сохранения этот заголовок. Так что пользуй его обязательно -).

<body>...</body> - определяет тело документа, в котором располагается вся информация, отображаемая на твоей страничке. Имеет следующие атрибуты:

bgcolor - задает цвет фона, чаще всего используют белый и ставят <body bgcolor="#FFFFFF">;

background - задает картинку для фона, причем если она меньше области просмотра, то будет заполнять всю видимую область, как обои в стеклянных;

text - задает цвет текста по умолчанию;

link - задает цвет ссылок;

vlink - задает цвет уже посещенных ссылок.

<center>...</center> - все, что находится между этими тэгами, центрируется. Можно отформатировать так все содержимое, а можно только отдельные куски или элементы. Некоторые тэги имеют центрирование в качестве атрибутов - но проще ставить этот тэг, чем помнить - в каких тэгах есть такой параметр, а в каких нет.

<p>...</p> - определяет абзацы или параграфы. Создает отступы до и после. В качестве атрибутов можно использовать:

align=left или =right или =center - выравнивает содержимое между тэгами по левому краю (или по правому, или по центру соответственно);

align=justify - выравнивает по ширине (недокументированная возможность).

<hn>...</hn> - определяет размер заголовков (n меняется от одного до шести, при единице будет самым большим). Практически не используется, так как проще определить размер шрифта текста в тэге <font>. В качестве атрибутов можно использовать все тот же align (ака выравнивание).

<font>...</font> - определяет параметры текста между этими тэгами. В качестве атрибутов можно использовать:

size=1...7 - задает размер текста, 7 - самый большой;

color - задает цвет текста в RGB формате;

face - задает шрифт, можно задавать сразу три шрифта на случай, если какого-то нет, например, face="Arial, Times New Roman, Symbol".

<I>...</I> - текст между этими тэгами отображается курсивом.

<B>...</B> - текст между этими тэгами отображается жирным.


Спецвыпуск Xakep, номер #015, стр. 015-010-4, Построй свой домик в Интернете!

Построй свой домик в Интернете!

Спецвыпуск Xakep, номер #015, стр. 015-010-4

<U>...</U> - текст между этими тэгами отображается подчеркнутым.

<SUP>...</SUP> - текст между этими тэгами отображается как степень.

<SUB>...</SUB> - текст между этими тэгами отображается как индекс.

<hr> - задает разделитель. В качестве атрибутов можно использовать:

align= (left, center, right) - выравнивает разделитель по горизонтали;

noshade - задает начертание без тени;

size - задает толщину разделителя;

width - задает ширину разделителя в пикселах или в процентах от общей ширины страницы.

<br> - символ переноса каретки. Используется на каждом шагу. Разделяет все и вся :).

&...; - спецсимвол, который может принимать различные значения. Все значения смотри в спецификациях на http://www.w3.org или в книжках, а тут приведу только некоторые для примера:

- пробел;

<, > - знак меньше "<" и больше ">" (если ты просто вставишь эти значки на страницу, то браузер поймет их как кусок тэгов и показывать не будет);

© - знак копирайта.

<img> - тэг, с помощью которого можно добавить картинку на страничку. В качестве атрибутов можно использовать:

src - задает адрес картинки - либо абсолютный (вида http://www.mypage.ru/images/image1.gif), либо относительный (просто /images/image1.gif);

alt - задает текст, который будет отображаться на месте картинки, пока она не загрузилась, - либо в случае, когда она вообще не грузится;

align= (left, center, right) - выравнивает картинку по горизонтали;

height - высота картинки в пикселах;

width - ширина картинки в пикселах;

border - обрамление картинки в пикселах (если она является ссылкой, обычно ставят border=0, как и в таблице);

hspace - отступы от картинки по горизонтали;

vspace - отступы от картинки по вертикали.

<a>...</a> - задает гиперссылку. В качестве атрибутов можно использовать:

name - задает поименованную ссылку, это нужно для задания якорей (ссылок внутри одной странички);

href - задает ссылку абсолютную или относительную, куда перекинет того, кто кликнет по обозначенной области;

target (_blank, _top) - задает способ открытия: _blank - в новом окне, _top - в этом же окне.

<!--...--> - задает комментарий. Когда код странички будет очень большой, с помощью комментариев ты сможешь сделать для себя пометки, которые спустя какое-то время помогут понять, что ты натворил. Реально удобно, как и в языках программирования.

Пример использования тэгов:

<html>

<head>

<title>Пример использования различных тэгов для Спецвыпуска Хакера</title>

</head>

<body text="#000000" link="#0000FF" alink="#0000FF" vlink="#0000FF" bgcolor="#FFFFFF">

<center>Использование тэга <center></center>

<p align=left><p align=left></p>

<p align=center><p align=center></p>

<p align=right><p align=right></p>

<h5 align=left><h5 align=left></h5>

<h4 align=center><h4 align=center></h4>

<h3 align=right><h3 align=right></h3>

<font face=Arial color="#FF0000" size=3><face face=Arial color="#FF0000" size=3></font>


Спецвыпуск Xakep, номер #015, стр. 015-010-5, Построй свой домик в Интернете!

Построй свой домик в Интернете!

Спецвыпуск Xakep, номер #015, стр. 015-010-5

<br><br>

<font face="Times New Roman" color="#0000FF" size=4><face face="Times New Roman" color="#0000FF" size=4></font>

<br><br>

<i><i>Италик</i></i> <u><u>Подчеркнутый</u></u> <b><b>Полужирный</b></b>

<br><br>

<sup><sup>Верхний регистр</sup></sup> <sub><sub>Нижний регистр</sub></sub>

<br><br>

<hr width="50%"> : <hr width="50%">

<br><br>

<img src="1.bmp" width="100" height="60" border="1"> <a href="http://www.xaker.ru" target="_blank"><a href="http://www.xaker.ru" target="_blank"></a></a>

</body>

</html>

<table>...</table> - задает таблицу. В качестве атрибутов можно использовать:

align (left, center, right) - выравнивает таблицу на странице по левому краю, по правому краю или по центру, но можно заключить таблицу в теги <p> или <center> и задать выравнивание с их помощью;

width - задает ширину таблицы в пикселах или в процентах от общей ширины страницы;

border - задает обрамление таблицы в пикселах. Чтобы обрамления не было, поставь 0 (что чаще всего и используется);

cellspacing - задает отступ между ячейками и от краев ячеек;

cellpadding - задает отступ содержимого внутри ячеек от краев.

<tr>...</tr> - задает строку в таблице. В качестве атрибутов можно использовать:

align (left, center, right) - выравнивает содержимое строки по горизонтали;

valign (top, middle, bottom) - выравнивает содержимое строки по вертикали.

<td>...</td> - задает ячейку в строке таблицы. В качестве атрибутов можно использовать:

nowrap - задает текст в ячейке без переноса;

rowspan и colspan - задает количество объединяемых ячеек по вертикали или по горизонтали соответственно;

align (left, center, right) - выравнивает содержимое ячейки по горизонтали;

valign (top, middle, bottom) - выравнивает содержимое ячейки по вертикали;

width - задает ширину ячейки в пикселах или в процентах от общей ширины таблицы;

height - задает высоту ячейки;

background - задает картинку для фона;

bgcolor - задает цвет фона.

Пример использования таблиц:

<html>

<head>

<title>Пример использования таблиц для Спецвыпуска Хакера</title>

</head>

<body text="#000000" link="#0000FF" alink="#0000FF" vlink="#0000FF" bgcolor="#FFFFFF">

<center>

<table width="70%" border=1>

<br><br>

<table width="70%" border=1>

<tr><td align="center">Первый ежик</td><td align="center">Второй ежик</td><td align="center">Третий ежик</td><td align="center" rowspan=2>rowspan=2</td></tr>

<tr><td align="center" colspan=2>colspan=2</td><td align="center">Бурундучок</td></tr>

</table>

<br><br>

<table width="200" border=1 cellpadding=10 cellspacing=5>

<br><br>

<table width="200" border=1 cellpadding=10 cellspacing=5>

<tr><td align="center">Первый ежик</td><td align="center">Второй ежик</td><td align="center">Третий ежик</td><td align="center" rowspan=2>rowspan=2</td></tr>


Спецвыпуск Xakep, номер #015, стр. 015-010-6, Построй свой домик в Интернете!

Построй свой домик в Интернете!

Спецвыпуск Xakep, номер #015, стр. 015-010-6

<tr><td align="center" colspan=2>colspan=2</td><td align="center">Бурундучок</td></tr>

</table>

</center>

</body>

</html>

Часть II. Едем дальше - верстка странички

Ты можешь спросить - как же с помощью такого небольшого количества тэгов делают такие классные сайты? Все очень просто - тэги служат только для разметки содержимого. Привлекательным сайт делают продуманная компоновка, контекст и графическое оформление. Компоновка реализуется именно с помощью тэгов. Узнав основные тэги и научившись их правильно использовать, ты, считай, уже наполовину сделал свою страничку.

Когда у тебя на страничке есть только фотография плюшевого мишки, ты тупо берешь тэг <img> и суешь туда своего мишку (<img src="bear.jpg" width=50 height=50 border=0>). Но когда на одной страничке много фотографий, общее меню, большое количество ссылок и текста, то возникает проблема компоновки (ака верстки) странички. Верстать можно либо с помощью фреймов, либо с помощью таблиц. Возьми любую литературу по созданию веб-страничек, там обязательно будет описание фреймов. Что они собой представляют, как их использовать, куда вставлять, даже примеры приводятся. Но я не видел ни одной книжки, в которой написали бы, что фреймы уже давно не используют, какие есть минусы при использовании фреймов и какая существует им альтернатива. Но не отчаивайся, ведь у тебя есть СПЕЦ Х :). Я тебе поведаю основные минусы использования фреймов, из-за которых все здравомыслящие веб-дизайнеры давно перешли на таблицы.

Для начала - что такое фреймы. В переводе с пингвинского (frames) это просто кадры. То есть любой из них представляет собой ни что иное, как обычный хтмл-файл. Для того чтобы использовать фреймы, ты должен сначала сделать фреймсет (еще один хтмл-файлик), в котором и определить фреймовую структуру - задав взаимное расположение кадров на страничке и их относительный (в процентах от общего) или абсолютный (в пикселах) размер. Взаимное расположение задается так же, как и в таблице: по строкам и столбцам. Размер указывается абсолютным только для тех кадров, для которых важно одинаковое отображение при разном разрешении - например, меню. Также ты указываешь хтмл-файл для каждого фрейма по умолчанию, то есть то, что будет отображаться при загрузке страницы. Фреймы можно назвать поименно, тогда в дальнейшем в любой поименованный фрейм можно грузить другой хтмл-файл. Это все замечательно, а теперь об основных минусах фреймов:

- Делая свою первую домашнюю страничку, состоящую из простого меню и содержания, конечно, проще сделать два фрейма. В первый ты заносишь меню, а второй именуешь и грузишь в него содержание. Проблема заключается в том, что меню остается всегда неизменным. А при необходимости сделать более 3-х фреймов еще и код становится трудночитабельным (тебе нужно скакать по всем хтмл-файликам, чтобы понять, где и что на странице). Браузер же при большом количестве фреймов начинает сильно кашлять :). В принципе есть даже такая заподлянка по отвисанию браузера - делаются 10 фреймов, в них еще по 10 фреймов и т.д.


Спецвыпуск Xakep, номер #015, стр. 015-010-7, Построй свой домик в Интернете!

Построй свой домик в Интернете!

Спецвыпуск Xakep, номер #015, стр. 015-010-7

- Ты без труда можешь скомпоновать с помощью фреймов информацию в пределах видимой области экрана - но как быть, если наполнение не помещается в фрейме? Тогда приходится все это дело проматывать скроллингом. Когда у тебя всего два фрейма и они расположены по горизонтали - это не проблема. А вот если у тебя два и более фреймов по вертикали... Тогда этот сайт будешь смотреть ты, ты и только ты :).

- Выкладывая на сайт информацию о своем детстве и свои фотографии на горшке, вряд ли ты ее будешь менять в будущем. А если ты делаешь сайт, на котором информация будет постоянно меняться, то при наличии множества фреймов у тебя появится гимор с переделыванием кучи хтмл-ек. Ведь сколько фреймов у тебя на странице, во столько раз и больше хтмл-ек у тебя будет создано.

- Допустим, ты все-таки осилил сайт с фреймами, но со временем решил что-то убрать или перекомпоновать. Опять возникает проблема - нужно менять размеры и взаимное положение других фреймов. И чем больше фреймов - тем больше проблем. А чем больше проблем, тем больше стрессовых перегрузок. А чем больше стрессовых перегрузок, тем хуже твоя потенция. Ну, короче, ты понял :).

- При компоновке с помощью фреймов возникает проблема с разделением отдельных блоков и графики. Сделать это без вазелина практически невозможно :). Нужно либо добавлять промежуточный фрейм, в котором будет разделитель, либо помещать его в один из граничащих кадров. Но при удалении этого фрейма выдави из тюбика еще немного вазелина и перенеси все в другой граничащий :).

- Создав любой сайт, для раскрутки тебе нужно будет поставить баннеры и счетчики. Поставить счетчик в index.html ты не сможешь, в нем определена фреймовая структура. Останется сунуть его только в один из фреймов. Но тогда при индексации в поисковике грузиться тоже будет не index.html, а этот фрейм.

Это далеко не все минусы, из-за которых отказались от использования фреймов. Но их вполне достаточно, чтобы не тратить свое драгоценное время на просмотр твоего полуфабриката :). Альтернатива - использование таблиц. Таблицы компенсируют все описанные минусы. В отличие от обычного фрейма ячейка таблицы имеет больше изменяемых атрибутов (выравнивание, отступы, размер, фон, обрамление). Но самое главное - при любом (разумном) количестве ячеек таблицы браузер чувствует себя сухо и комфортно :).

Верстка с помощью таблицы делается следующим образом. Сначала ты рисуешь эскиз всей страницы, задав требуемый размер холста. В результате рисунок получается как единое целое. Некоторые перед этим на бумаге сначала прикидывают, как это будет выглядеть. Подбираешь шрифты, цвета, взаимное расположение всех элементов. Когда эскиз будет готов, режешь его направляющими, например, в Photoshop. Получается сетка, которая делит твое хозяйство на n-ое количество прямоугольничков. Выделяя по очереди эти прямоугольные области по направляющим, вырезаешь их и сохраняешь как отдельные рисунки (обычно *.gif). Какой смысл резать? Во-первых, страница будет быстрее прогружаться. Во-вторых, ты сможешь определить области для ссылок. А в-третьих, ты сможешь выделить одноцветные области, уменьшив за счет этого общий размер файлов. При необходимости можно сделать прозрачный или чересстрочный *.gif. Закончив резку, собираешь полученные прямоугольнички в таблицу, поставив обрамление border=0. Там, где должно быть наполнение, вырезанный прямоугольничек ставишь в background, а наполнение - непосредственно в ячейку.


Спецвыпуск Xakep, номер #015, стр. 015-010-8, Построй свой домик в Интернете!

Построй свой домик в Интернете!

Спецвыпуск Xakep, номер #015, стр. 015-010-8

Аналогично фреймам размер таблицы можно задать абсолютным или относительным. При этом тебе никто не мешает использовать несколько таблиц на одной странице. Что даст тебе их использование? Каждая отдельная страница становится полностью автономной. Ее удобно индексировать в поисковиках, ставить счетчики, изменять ее содержимое. Можно поменять меню на любой страничке, не затрагивая меню для всех остальных. Возникает вопрос - а как сделать, если меню одно и то же и повторяется на многих страницах? Первый вариант: в лоб копировать и вставлять в каждый хтмл-файл, подойдет для небольших сайтов. Второй вариант: обзаведись программой типа Dreamweaver, которая позволяет помечать одинаковые блоки по всем страницам и менять их синхронно сразу везде. А веб-мастера делают еще проще: помещают изменяемую часть отдельно, а страницы собирают на лету, вставляя изменяемую часть в общий код. Но тут уже придется поучить хостинг с поддержкой ssi, cgi-скриптинг или что-то подобное. Есть и другой выход. Если ты владеешь каким-нибудь продвинутым языком программирования :), сделай программулину, которая будет вставлять введенный фрагмент кода между определенными двумя указателями, которыми заранее обозначь изменяемую часть в хтмл-ках. Сами указатели сделай в качестве комментариев.

Полезные советы при использовании таблиц

- если ты хочешь, чтобы ширина ячеек таблицы не менялась даже при атомном взрыве, просто помести в нее картинку высотой в 1 пиксел и шириной ячейки, а цвет сделай такой же, как и цвет фона;

- чтобы получить привлекательное обрамление таблицы, не используй стандартное обрамление (border=0), а добавь ячейки по периметру таблицы, поместив в них графику;

- если обрамление должно быть неизвестной высоты или повторяющимся, размести только кусок обрамления, а остальную область заполни через атрибуты bgcolor (если одноцветная заливка) или background (если рисунок);

- по возможности не совмещай в одной таблице определение размеров ячеек в пикселах и в процентах одновременно, некоторые старые версии браузеров на этом спотыкаются;

- чтобы сделать отступ до текста в таблице от ее границ, лучше не используй атрибут cellpadding, а просто нарисуй отступ графикой.

Часть III. Двигаемся еще дальше...

И напоследок о вкусностях - более продвинутые технологии пагостроения. Все они уже давно и успешно используются более-менее грамотными веб-мастерами, но вот уложить полный курс в журнал я не смогу. Впрочем, на этой основе ты сможешь начать (делать это), а уж кончить постарайся самостоятельно :-).


Спецвыпуск Xakep, номер #015, стр. 015-010-9, Построй свой домик в Интернете!

Построй свой домик в Интернете!

Спецвыпуск Xakep, номер #015, стр. 015-010-9

Что такое CSS?

При создании своей странички ты уткнешься в некоторые ограничения: не сможешь делать сложное форматирование (например, не сможешь изменить интервал между символами, не сможешь даже поставить два пробела подряд - они автоматически преобразуются в один), не сможешь сделать страничку так, чтобы она одинаково отображалась в разных браузерах или в одинаковых браузерах, но на машинах с разной конфигурацией. Почему? Потому что html изначально не предназначен для этого, он только определяет структуру странички. Умные челы придумали CSS (Cascade Style Sheet) - каскадная таблица стилей, которая позволяет управлять стилями и внешним видом паги. При этом твое творение будет одинаково выглядеть в любом браузере и с любой конфигурацией на тачке.

Определение стилей помещается между тэгами <style type="text/css"> и </style> в заголовке документа (между тэгами <head> и </head>) или непосредственно в любом тэге. Для удобства определение таблицы стилей иногда выносят в отдельный файл, тогда в заголовок нужно добавить ссылку на этот файл в виде <link rel=stylesheet type="text/css" href="style.css"> (в этом примере подключается файл таблицы стилей style.css). Все для чего? А для того, чтобы один раз прописать нужный тебе вид и дальше забыть об этом - все будет подставляться автоматически. Приведу несколько примеров определения таблицы стилей в заголовке и непосредственно в тэге:

<h1 style="color: blue">Получится синий заголовок (определение непосредственно в тэге)</h1>

А вот то же самое, но уже в "голове" страницы:

<style type="text/css">

h1 {color: blue}

</style>

Более сложный пример, определяющий всем заголовкам на странице синий шрифт, курсивное начертание и выравнивание по центру:

<style type="text/css">

h1, h2, h3, h4, h5, h6 {color: blue; font-style: italic; text-align: center}

</style>

Как видно из примеров, все достаточно просто. А теперь я перечислю свойства каскадных таблиц стилей, которые ты можешь использовать, чтобы определить различные параметры текста, фона, шрифтов, границ и полей.

Выравнивание текста

letter-spacing - определяет расстояние между символами (поддерживает только Internet Explorer);

text-decoration - позволяет создавать линии над, под и поверх текста и создавать мерцающий текст;

vertical-align - позволяет перемещать элемент вверх и вниз, выравнивания его относительно других элементов по вертикали;

text-align - определяет выравнивание текста по правому краю, по левому краю, по центру или по ширине;

text-transform - изменяет регистр символов (прописные или строчные);

text-indent - определяет отступ абзацев и других элементов;

line-heigth - определяет расстояние между строками текста.

Изменение цвета и рисунка фона

color - определяет цвет текста элемента;

background-color - определяет фоновый цвет элемента;

background-image - позволяет использовать рисунок в формате *.gif в качестве фонового изображения элемента;

background-repeat - определяет тип заполнения элемента рисунком фона: повторение по вертикали или горизонтали (поддерживает только Internet Explorer);


Спецвыпуск Xakep, номер #015, стр. 015-010-10, Построй свой домик в Интернете!

Построй свой домик в Интернете!

Спецвыпуск Xakep, номер #015, стр. 015-010-10

background-attachment - определяет статус рисунка фона при скроллинге (поддерживает только Internet Explorer);

background-position - позволяет указать расположение фонового рисунка (поддерживает только Internet Explorer);

background - позволяет указать все перечисленные выше параметры, но одним списком.

Управление шрифтами

font-family - определяет название шрифта (можно указать несколько);

font-style - определяет стиль шрифта: нормальный, курсивный или полужирный;

font-variant - определяет отображение прописных символов в нижнем регистре;

font-weigth - определяет полужирное начертание (степень полужирности указывается числовым значением);

font-size - определяет размер символов шрифта;

font - позволяет указать все перечисленные выше параметры, но одним списком.

Границы и поля

margin-top, margin-bottom, margin-left, margin-right - определяет поля элемента (в пикселах или в процентах);

margin - позволяет указать все эти поля одним списком;

width - определяет ширину элемента, например, изображения;

heigth - определяет высоту элемента;

float - позволяет создавать обтекающий элемент текста;

clear - определяет конец обтекания текстом элемента.

Более полно описание CSS смотри на www.w3.org/Style/CSS, а я тебе приведу примерчик:

<html>

<head><title>Пример использования CSS для Спецвыпуска Хакера</title>

<style>

body {color: blue}

p {text-align: center; margin-left: 20%; margin-right: 20%}

h1, h2, h3 {color: red}

ul {color: green}

</style>

</head>

<body>

<h1>Моя супергипермега страничка!</h1>

<p>Заголовок в примере красный, текст абзаца - синий. Абзац выровнен по центру с отступом 20% по бокам.</p>

<p style="color: black">А этот абзац с черным текстом, так как стиль переопределен.</p>

<ul>

<li>это список, элементы определены зеленым цветом

<li>аналогично

<li style="color: red">опять переопределение, в результате текст красного цвета

</ul>

</body>

</html>

Что за зверь Java-Script?

Еще один мощный инструмент для создания дополнительных фенек на твоей страничке - Java-Script. Это уже язык программирования, который родили в Netscape Communication Corporation (они же создали Netscape Navigator). Удобство этого языка состоит в том, что сценарии, написанные на нем, напрямую вставляются в страничку. Java-Script - интерпретируемый язык программирования. Браузер выполняет каждую строку сценария последовательно, после выполнения предыдущей. Для изучения он достаточно прост, а синтаксис сходен с Java, отсюда и название (изначально он назывался LiveScript). Я не буду описывать весь синтаксис языка - не хватит объема статьи, проще купить книжку. Но покажу парочку наглядных примеров, что можно сделать на Java-Script, и скажу, где порыть материал в Инете. А сделать можно многое:

- бегущие строки на страничках в теле, в заголовке, в строке состояния;

- вычисления в формах без использования cgi-скриптов;

- проверка форм на правильность ввода данных без использования cgi-скриптов;


Спецвыпуск Xakep, номер #015, стр. 015-010-11, Построй свой домик в Интернете!

Построй свой домик в Интернете!

Спецвыпуск Xakep, номер #015, стр. 015-010-11

- создание сообщений в виде отдельных диалоговых окон;

- анимированные изображения, в том числе анимированное меню (описываются события для действий крысы);

- определение используемого браузера и настройка странички под него;

- определение используемых плугинов;

- всплывающие меню или подсказки;

- счетчики;

- разнообразные эффекты;

- и куча всего остального...

Достаточно сказать, что ни одна страничка, кроме совсем ламерских :), не обходится без использования Java-Script. Хватит трепаться, смотри примеры. В первом я покажу, как сделать удобную навигацию по твоей паге, а во втором - как сделать анимированное меню. Оба примера я прокомментирую, и на своей страничке ты сможешь без труда их использовать.

Начнем с навигации по сайту. Когда ссылок на паге очень много, обычно делают карту сайта. Но можно сделать навигацию и с помощью Java-Script. Используй обычный раскрывающийся список, добавив обработчик событий на Java-Script. Вот что получится в результате:

<html>

<head><title>Пример использования Java-Script для Спецвыпуска Хакера</title></head>

<body>

<br><br>

<form>

<select onChange="window.open(this.options[this.selectedIndex].value,'_top')">

<option selected> Меню

<option>- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

<option value="about.html"> 1. Я

<option value="tuzik.html"> 2. Мой Тузик

<option value="murzik.html"> 3. Мой Мурзик

<option value="my_girl.html"> 3.1. Моя девушка

<option value="my_girl_about.html"> - в детстве

<option value="my_girl_normal.html"> - в штанах

<option value="my_girl_nude.html"> - без штанов

</select>

</form>

</body>

</html>

Обработчиком событий тут является onChange, и реагирует он на выбор любого пункта из раскрывающегося списка. Функция window.open() открывает новое окно. Параметр this.options[this.selectedIndex].value будет иметь значение value выбранного пункта, к примеру, если выбрать "Моя девушка -> в штанах", то value примет значение my_girl_normal.html. Обработчик событий выполнит переход по этой ссылке, открыв содержимое в том же окне, так как стоит параметр _top.

Если же менюшек не много, но хочется их оживить, то с помощью Java-Script можно их анимировать. Нужно всего лишь добавить обработчик событий, который будет реагировать на мышь (активировать и дезактивировать пункт меню). Для того чтобы все работало быстро, сделаем предварительную загрузку картинок в заголовке твоей паги. Получится следующее:


Спецвыпуск Xakep, номер #015, стр. 015-010-12, Построй свой домик в Интернете!

Построй свой домик в Интернете!

Спецвыпуск Xakep, номер #015, стр. 015-010-12

<html>

<head><title>Пример использования Java-Script для Спецвыпуска Хакера</title>

<script language="JavaScript">

about_off=new Image(); about_off.src="images/about_off.gif";

about_on=new Image(); about_on.src="images/about_on.gif";

photo_off=new Image(); photo_off.src="images/photo_off.gif";

photo_on=new Image(); photo_on.src="images/photo_on.gif";

links_off=new Image(); links_off.src="images/links_off.gif";

links_on=new Image(); links_on.src="images/links_on.gif";

</script>

</head>

<body>

<table border="0" cellspacing="0" cellpadding="0" width="745">

<tr>

<td align="left" valign="top" width="110" height="25"><a href="about.html" target="_top" onMouseOver="document.about.src=about_on.src;" onMouseOut="document.about.src=about_off.src;"><img src="images/about_off.gif" border="0" widht="110" height="25" name="about"></a></td>

<td align="left" valign="top" width="110" height="25"><a href="photo.html" target="_top" onMouseOver="document.photo.src=photo_on.src;" onMouseOut="document.photo.src=photo_off.src;"><img src="images/photo_off.gif" border="0" widht="110" height="25" name="photo"></a></td>

<td align="left" valign="top" width="110" height="25"><a href="links.html" target="_top" onMouseOver="document.links.src=links_on.src;" onMouseOut="document.links.src=links_off.src;"><img src="images/links_off.gif" border="0" widht="110" height="25" name="links"></a></td>

</tr>

</table>

</body>

</html>

В данном случае меню состоит из 3-х подменю, которые активируется, когда ты наводишь мышь (обработчик событий onMouseOver), и дезактивируется, когда ты убираешь мышь (обработчик событий onMouseOut). При клике происходит обычный переход по ссылке. Новое окно открывается на месте старого, так как определен параметр _top.

Порадовало? Где же надыбать дополнительную информацию? В первую очередь, на сайте производителя - http://developer.netscape.com/docs/manuals/ . Но там, сам понимаешь, все на забугровом. Не позаботились о тебе, свиньи :). Поэтому я нашел для тебя немного нашинских ссылок, вот наиболее интересные:

http://prog.agava.ru/lib/java/

http://www.ramblers.ru/java/

http://ftp.migsv.ru/Ftp/pub/windows/doc/java-script/

http://javascript.com/

http://kovaler.jinr.ru/library/programming/

http://webmasterclub.narod.ru/Sites/Vvedebie_v_JavaEnd/jsi/first.htm

http://www.ict.nsc.ru/rus/docs/JS/

http://www.codebrain.com/javascript/

Это еще не конец

Это, конечно, не все, что можно было сказать о создании своих страниц. За кадром остались DOM (объектная модель браузера), SSI (Server Side Includes), DHTML и много еще чего. Но, надеюсь, для начала тебе хватит - а там дело пойдет, сам будешь потихоньку все осваивать :-). Может, через пару-тройку лет будем на пару с Темой к тебе на курсы веб-дизайна ходить... Удачи!


Спецвыпуск Xakep, номер #015, стр. 015-012-1, Шалости на бесплатных хостингах

Шалости на бесплатных хостингах

suck3r (cutter@real.xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-012-1

Закончились чужые кредитные карты? Как назло, позакрывали все твои шеллы на хостингах? Прикрыли сайт, на котором ты размещал свой bouncer? В общем, полный сакс. Самое неприятное, что такое может случиться с каждым. Грустно... Но не стоит заморачиваться :). Просто сегодня мы поговорим о том, что же делать, если срочно нужно установить какую-нибудь сетевую утилитку на сервере, причем сделать все это бесплатно и вполне законно.

Регаем халяву

Все очень просто, ведь еще не перевелись на нашей планете чудные админы :). Из-за таких шедевров природы на некоторых бесплатных хостингах можно вытворять почти все то, что обычно можно делать только на платных ;). Встречайте - VirtualAvenue и Hypermart! Хочу заметить, хоть это и разные сайты, но такое ощущение, что ими занимаются одни и те же люди: весь процесс регистрации совершенно идентичен, настройки в меню одинаковые, к тому же на обоих проектах висят рекламы друг друга. Любопытно, конечно, но нам, в принципе, до этого дела нет :). В общем, заползай на какой-нибудь из этих сайтов (www.virtualave.net, www.hypermart.net) и кликай на пункт SignUp. Ознакомься с появившимися формами. Проглядев их, ты, наверное, удивишься: тебя попросят ввести номер кредитной карты :(! Не расстраивайся - да, это бесплатный хостинг! Ну, может, наполовину бесплатный ;). Просто помимо бесплатных услуг у них полно и платных, причем первые они запихнули куда подальше от пользователя... Но не тут-то было :). Ввести номер кредитной карты все равно придется - другое дело, что эти хостинги с удовольствием глотают любые заюзанные, старые, обнуленные и прочие креды. В Инете полно сайтов, где таких нерабочих кредиток навалом. Хорошо, идем дальше: в поле domain выбирай поддомен третьего уровня в зоне того хостера, которого ты предпочел. Если попытаешься захапать домен второго уровня, с тебя потребуют 20 баков - тут уже фиговая кредитка не сработает ;). Далее скажи, что ты хочешь бесплатный трафик, взамен этого на твоих сайтах будут висеть рекламные баннеры. Можешь не париться по этому поводу: так как мы не собираемся открывать и раскручивать веб-проект, вряд ли кто-нибудь еще (кроме тебя) их увидит. С остальными полями, надеюсь, разберешься сам - так что заполняй и жми на заветную кнопку Submit. Все, запрос отправлен, а всю инфу (данные о ftp-серваке, логин и пароль) тебе пришлют на мыло через несколько часов.

Пошалим?

Отлично, теперь можно уже и подумать, что будем вытворять ;). Нам надо обвешать полученный аккаунт всякими полезными сетевыми тулзами и облегчить себе жизнь. Так как хост предоставляет поддержку CGI, да еще и позволяет открывать сокеты, работать будут любые сетевые программы на перле, которые используют протоколы tcp или udp. Причем можно ставить как клиентские проги, так и серверные. За это надо отдать должное администраторам, которые "грамотно" настраивали firewall :). Я приведу пару таких полезных тулз для примера и покажу, как их запускать. Остальные утилиты ты повесишь сам - так как тебе лучше знать, какой софт тебе нужен.

Если ты постоянно сидишь в IRC, то, наверное, пользуешься bouncer'ом. К сожалению, поставить ezbounce или psyBNC не удастся :(, но ничего - на перле баунсеры тоже есть, и они почти не уступают своим сишным аналогам. Имхо, лучший из них - PimpBNC. Он поддерживает detach- и reattach-команды, есть возможность устанавливать vhost - для многих это самые юзабельные и необходимые функции. Скачать PimpBNC можно с http://pimpbnc.konge.net. На данный момент доступна только бета версия, но и она работает нормально.


Спецвыпуск Xakep, номер #015, стр. 015-012-2, Шалости на бесплатных хостингах

Шалости на бесплатных хостингах

suck3r (cutter@real.xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-012-2

Еще одна очень полезная фишка - возможность анонимно серфить по ftp и http. Тут на помощь приходят прокси-сервера. Самая простая и удобная прокся на перле - httpproxy. Скачать ее можно здесь: http://online.comtv.ru/httpproxy-1_5_3.pl. В настройках нужно изменить только порт для соединения, после чего proxy-server будет готов к запуску. Наслаждайся!

Установить и настроить проги - одно дело, но ведь их еще надо как-то запускать? Так как telnet или ssh доступа к сайту у нас нет, придется воспользоваться неким извращением под названием cgi-shell. Этот CGI-скрипт выдает HTML-форму, позволяющую вводить команды, и затем выполняет их на серваке. Получается несколько кривой shell :). Например, чтобы запустить проксю, тебе нужно загрузить браузер, открыть в нем примерно такую страницу: http://something.hypermart.net/cgi-bin/cmd.pl и ввести команду: ./httpproxy-1_5_3.pl &. После чего прокся запустится в фоновом режиме. Точно так же поступаешь и с баунсером, и со всем остальным софтом, который навешаешь. Также доступны и стандартные команды, вроде просмотра списка процессов (ps) или их убийство (kill id). В общем, этот скрипт тебе точно понадобится, а вот отсюда его можно скачать: http://online.comtv.ru/cmd.pl.

Регаем еще

Это были два лучших сервера, которых можно иметь по полной программе. Но есть и другие, например: www.lgg.ru, www.f2s.com, www.webservis.ru. На них тоже можно устанавливать сетевые утилиты, но уже с немалыми ограничениями. Если на VirtualAvenue можно ставить сервера, то здесь будут работать только клиентские программы. Скажем, irc-bouncer работать не будет, а вот бот на перле - без проблем. Еще здесь можно поставить тулзу, перекачивающую софт с одного сайта на другой, - если совсем напряжешься, то вспомни х-релиз X-Uploader. У этой программы есть WEB интерфейс, через который аплоадер работает вполне нормально.

Существуют еще и просто халявные хостинги, в том числе и отечественные, где можно использовать только CGI-скрипты, а с соединениями во внешний Internet выйдет облом. Зато на них, как правило, доступна программа sendmail (обычно это /usr/sbin/sendmail). Тебе она может очень понадобиться, если ты любишь заниматься спамными рассылочками ;). Многие спамеры постоянно ищут SMTP сервера, через которые можно свободно рассылать тысячу писем. Зачем это нужно? Ты просто можешь установить на таком сайте скрипт mail-рассылки, а вместо простых подписчиков подставить спамлист! Хостинг с удовольствием проглотит все письма. Однако после такого мощного спама твой сайт закроют :). А что стоит зарегистрироваться еще раз ;)? Вот пара таких «добрых» хостера:


Спецвыпуск Xakep, номер #015, стр. 015-012-3, Шалости на бесплатных хостингах

Шалости на бесплатных хостингах

suck3r (cutter@real.xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-012-3

http://www.agava.ru - все пинают, но сейчас они исправились, убрали рекламу, предоставили поддержку MySQL баз.

http://www.tripod.com - довольно старый сервер, поддержка CGI.

Alabanza

Все что я рассказал действительно может пригодиться на черный день, но не рассказать про еще один способ просто нечестно. Может быть, ты когда-нибудь слышал о довольно большой компании Alabanza? Эта фирма предлагает всем желающим поработать агентами по распространению хостинговых услуг. Как это происходит: тебе выделяют комп с большим каналом в Интернет, ты продаешь услуги хостинга, а часть полученных денег отдаешь Алабанзе. И тебе, и ей хорошо, но при этом соблюдаются некоторые правила. Человек, который будет покупать хостинг у этой фирмы, может бесплатно получить тестовые 14 дней! Просто нужно отправить запрос на заказ хостинга, и ничего оплачивать вперед не придется. После этого тебе будет доступен сайт, где ты можешь использовать даже программы на c/c++ - вешай что угодно! Вот небольшой список таких хостеров:

http://www.apollohosting.com

http://www.hostrocket.com

http://www.sorix.ru

Если просканировать диапазон ip'шников Алабанзы (www.alabanza.com), то можно вытащить и другие подобные сайты. Так что дерзай, и пусть тебе попадается побольше халявы в этой жизни :).


Спецвыпуск Xakep, номер #015, стр. 015-014-1, Net.art - похмелье вебмастера

Net.art - похмелье вебмастера

Спецвыпуск Xakep, номер #015, стр. 015-014-1

Даниил Шеповалов (dan@real.xakep.ru , www.danya.ru)

«В современном искусстве такое не редкость: нарисуют какую-нибудь ****ень, назовут "Жопа Маргарет Тэтчер" - так сразу все культурологи сбегаются и давай нахваливать!».

Мэри Шелли "Повсеместно протянутая некрофилия"

Man. Nature. Technology.

О, этот загадочный мир современного искусства. Одни эстеты фотографируют свалки и писающих собачек, другие вытатуировывают на своем собственном теле октябрьские речи В. И. Ленина, а третьи так вообще делают космогонические инсталляции из фекалий жирафа. По большей части это, конечно, конвейер бездарностей с претензией на оригинальность, но и здесь есть свои Мастера и Шедевры. Несколько лет назад наша планета начала переход в качественно новую форму существования - в виде IP-пакетов. Самые смелые анализы развития Сети - просто детский лепет по сравнению с объективной реальностью. Приятель, мы подписались кровью, и обратного пути нет - мир через десяток лет станет тотально информационным. Виртуальная жизнь, электронная музыка, сетевое искусство. Добро пожаловать в клуб!

Net://art

Сетевое искусство - это не "дизайн веб-страничек", не собрание оцифрованных фотографий свалок и даже не выставка "Виртуальный Эрмитаж". Сетевое искусство - это, блин, сетевое искусство, так его растак! Можно сказать, что самым первым net-художником был тот чел, который соединил в письме другу двоеточие и закрывающую скобку :), использовав тем самым терминальные символы не по прямому назначению, а для эстетического удовлетворения адресата. В человекообразных существах испокон веков живет стремление сотворить из подручных средств что-нибудь эдакое! Миллион лет назад подручными средствами были кровь мамонта и стена пещеры. Нынче же - java, flash, cgi и протокол tcp/ip.

Первыми проявлениями сетевого искусства можно назвать ANSI/ASCII-art: рисунки, составленные из символов ASCII (.nfo файлы крякерских групп, интры BBS'ок и прочее; иногда попадаются и полнометражные анимационные фильмы - например, загляни telnet'ом на towel.blinkenlights.nl - прим. ред.). В центре Net Art'а стоит именно Сеть, ее коммуникационные возможности, а всякие хтмлы и флэшы - всего лишь инструмент художника. Произведением сетевого искусства может быть интерактивная история с нелинейным сюжетом о чебурашке-камикадзе, сделанная на основе кучи web-страниц и перекрестных ссылок. А может быть и дистанционно управляемый робот, который рисует граффити на Великой китайской стене и снимает весь этот перфоманс в риал-тайме на web-камеру. Некоторые особо продвинутые товарищи (Jodi) считают, например, произведением net art'а даже процесс установки связи с провайдером, но это уже, конечно, клиника. Jodi - это голландка Джоан и бельгиец Дирк, фактически мама и папа сетевого искусства. Они начинали колбаситься в Сети еще в далеком 1994 году. На их экспериментальной площадке www.jodi.org всегда творится полный ноиз и беспредел. Эти черти буквально выворачивают Сеть наизнанку, представляя взгляду зрителя ее аппетитные внутренности. Безумный коктейль из странных символов, ссылок, исходников скриптов, картинок, сгенерированных глючной видеокартой, кусков порносайтов, скринов пакмена и борланд паскаля, icq-контактов и документации по DNS - это все Джоди. Тем не менее, они уверяют, что их работы - чистейший мэйнстрим. Что же, в таком случае альтернативу мне и представить страшно :). Неподготовленным джедаям модема подобные вещи поначалу кажутся абсолютной паранойей и бредом, но если заставить себя покликать мышкой по этому беспределу хотя бы минуту - ты застрянешь на их сайте минимум на час и поймешь, что такое Net Art. Кстати, существует красивая легенда насчет происхождения этого термина. Дескать, однажды у некого впоследствии известного сетевого художника сглючил почтовый клиент, и он получил мессагу, состоявшую из полного абсурда. Однако посреди глючного набора символов четко выделялась осмысленная комбинация "Net.Art". Так выпьем же за кибернетику!


Спецвыпуск Xakep, номер #015, стр. 015-014-2, Net.art - похмелье вебмастера

Net.art - похмелье вебмастера

Спецвыпуск Xakep, номер #015, стр. 015-014-2

Люди

Занимаются net art'ом по большей части предельно безумные люди. Творческие, так сказать, личности. Из моего персонального экспириенса: отрывок разговора с девушкой, увлекающейся сетевым искусством, которую я банально пытался развести на... ужин при свечах.

Я: Ну, так как насчет завтра встретиться?

Она: Москва, золотые купала, рыбий жир, ванильное мороженое, метро, метро, метро...

Я: Чего?

Она: Солнцеее-мореее-acid-Djazzzzz-zzz.

Я: Я говорю, завтра вечером свободен. Можно в баре посидеть, если хочешь.

Она: Ми2. Жесткотека, говорят там холодает. Дим-Димыч в Германию опять укатил.

Сам видишь, какая тут рвота вместо мозга. Товарищ, в наше электронно-оптоволоконное время надо быть теоретически подкованным и знать имена отечественных ударников сетевого арта. Хотя бы для того, чтобы блеснуть эрудицией в светском разговоре с собутыльниками!

Оля Лялина

Известна своей активной деятельностью по популяризации Net Art'а в конце прошлого века (мы говорим "Net Art" - па-а-адразумеваем "Лялина"). Профессор немецкой Академии коммуникативного дизайна. Колбасит на www.teleportacia.org. Самая известная работа: лав-стори "Мой бой-френд вернулся с войны" (http://myboyfriendcamebackfromth.ewar.ru/), на которую было сделано 13 ремиксов такими сенсеями, как Jodi, Вадим Эпштейн и Роман Лейбов. Кстати, мой сосед по лестничной площадке сходит по Оле с ума, закрываясь с ее фотографией в туалете.

Ель Зеленая

Молодая девушка, чуждая джоди-лялинского пафоса. Делает действительно доступные и прикольные вещи, не увлекаясь художественным дестроем. Обитает Зеленая на http://www.sidor.ru/elka/. Ее интерактивный фильм "Сказочка про елочку" (http://www.sidor.ru/elka/kino/1.html) заставил меня прослезиться (ай-ай-ай, убили елку, убили, ни за что, ни про что, суки, замочили!). Отец и маха-гуру всея русского веб-дизайна Артемий Лебедев (www.design.ru) как-то назвал Елку одним из шести лучших дизайнеров Рунета.

Вадим Эпштейн

Известен своим знаменитым проектом www.here.ru и склонностью к поиску чуждых вдохновений. Работы многих сетевых художников среднестатистическим серфером смотрятся максимум секунд пятнадцать, после чего произносится фраза "Вот уроды!", нажимается сочетание клавиш "Alt+F4" - и высокое искусство остается наедине с самим собой. Про культовый here.ru подобного сказать нельзя. Сайт сделан относительно доступно, можно даже сказать - попсово, и набит под завязку любопытным стаффом: от журнальных статей и мессаг из фидошных конф до фрактальной шизы и научных работ с названиями типа "Безумие достижимо: клетчатый суслик". Многих посетителей особенно порадует баннер проекта: "Здесь у вашей девочки мог бы быть мозг!".


Спецвыпуск Xakep, номер #015, стр. 015-014-3, Net.art - похмелье вебмастера

Net.art - похмелье вебмастера

Спецвыпуск Xakep, номер #015, стр. 015-014-3

Олег Пащенко (cmart)

Один из дизайнеров студии Лебедева. Безумно прославился своим высокохудожественным флэшевым проектом www.conclave.ru с колбасящимся призраком-инопланетянином без члена. Хотя сам cmart говорит, что это вовсе не инопланетянин, а член ему вообще не полагается. Ну, неважно, короче, - дела семейные. Главное, что проект действительно достойный и простому обывателю понятный. То есть непонятный, конечно, ведь повсюду латынь и флэшевые глюки. Однако зайдет простой обыватель на conclave.ru, потыкает всюду мышкой, ничего не поймет и скажет "Круто!". И будет прав!

Даня Васильев

Мой богемный тезка, творящий в восторженном нет-экстазе на www.koala.ru. Очень колоритные работы: среди коал и полумесяцев ясно прослеживаются самобытность и широта русской души, а также тлетворное влияние каталога http://dir.yahoo.com/Arts/Visual_Arts/Web_Art/Web_Installations/. Помимо этого Даня Васильев является создателем Робота Марата Гельмана-II (того самого Марата Гельмана, который "Сетевое искусство в сети"). С веб-версией данного робота можно ознакомиться по адресу http://guelman.ru/2/.

Так говорил Заратустра

Расцвет джоди-лялинского Net Art'а, состоящего из запредельной мешанины ссылок и динамических изображений, пришелся на конец 90-х годов прошлого века. Компьютерные журналы ежемесячно разрождались статьями о "модном сетевом искусстве", а особо шустрые художники даже пытались продавать свои web-творения в виде распечаток и компакт-дисков с содержимым сайтов (причем, иногда им это удавалось). Теперь же налицо явный упадок подобного олдскула. Складывается впечатление, что сетевое искусство сейчас интересует исключительно самих сетевых художников, тусующихся в Net Art-рассылках и конференциях. Сеть помолодела. Простому смертному подавай флэшовый экшн с квадро-звуком и тру-колором, ему нынче некогда щелкать по замаскированным линкам и разбираться в концептуальных, но исключительно тягомотных задумках художника. Олдскульный нет-арт сейчас бьется в смертельной агонии. И может быть именно тебе, дорогой амиго, решать, что именно придет ему на смену.


Спецвыпуск Xakep, номер #015, стр. 015-016-1, Интервью с Мэри Шелли

Интервью с Мэри Шелли

Спецвыпуск Xakep, номер #015, стр. 015-016-1

Даниил Шеповалов (dan@real.xakep.ru, www.danya.ru)

Мэри Шелли:

Автор киберпанковских романов:

"Паутина": http://www.fuga.ru/shelley/pautina/p1.htm

"2048": http://www.fuga.ru/shelley/2048/dreml-1.htm

Культовая обозревательница Рунета

Мы договорились встретиться с Мэри в баре с сомнительным названием "Саквояж для беременной шпионки". Я заранее затарился презервативами и сидел за стойкой, задумчиво теребя страничку меню "Алкогольные напитки". Внезапно в бар со скоростью метеора ворвался дядька лет 30-ти, заказал стопку водки, не глядя смахнул ее, а затем протянул мне руку и торжественно представился:

- Леха!

- Весьма польщен! - буркнул я и отвернулся от новоприбывшего психа. "Леха" обошел меня по периметру и улыбнулся:

- Ну че ты, а? Я - Мэри Шелли!

Леха Андреев:

Бывший редактор:

www.gazeta.ru

www.vesti.ru

www.lenta.ru

www.gazeta-net.spb.ru

Сейчас: заместитель главного редактора Netoscope.ru

Проекты:

Футуристическая газета www.fuga.ru

Хайку www.haiku.ru

Первая радиопрограмма о Сети: radionet.cl.spb.ru

Спец: Как вообще возникла идея создания виртуальной сетевой личности? И почему именно Мэри Шелли?

Леха: Эта идея несколько меня опередила. Просто я раньше других заметил, что во время общения в Интернете люди создают свои собственные представления о других, которые не имеют ничего общего с действительностью. Общаешься с женщиной по Сети несколько месяцев, а потом встречаешься - и она оказывается совершенно не такой, как я ее представлял, вообще не такой! Хотя и фотки видел, и все детали вроде знаешь... Ну вот, я и подумал, что надо бы этим процессом научиться управлять. В то время я как раз вернулся из Америки, из Usenet'а, где все ругались матом, и застал зачаточный Рунет, в котором все сюсюкают и дружат. К тому же тогда в Сеть приходили по большей части мужчины, девушек было очень мало. Поэтому естественно напрашивался образ этакой разбитной, но образованной девчонки без комплексов.

Спец: Какой сетевой скандал, устроенный Мэри, тебе больше всего запомнился?

Леха: Самый первый, во время расцвета культа обозревателей. 97-ой год, Паровозов, Носик и компания. Все прилично так, все друг на друга ссылочки ставят, сайты новые обозревают, короче - идиллия. А тут заваливаюсь я и пишу "Обзор обозревателей" с точки зрения девочки, которая сидит на стене и кидает вниз бутылки. Была четко просчитана реакция - и все сработало. На следующий же день везде появились гневно-восхищенные отзывы, в результате Мэри за день стала более известной, чем я за два года в Сети. Даже писать статьи в бумажный журнал InterNet сначала предложили ей, а я уж потом примазался...

Спец: Есть такая известная хохма насчет того, что две трети девчонок в Сети - это толстые, волосатые программеры. Тебе, по ходу, удалось побывать в подобной роли. Может расскажешь о своих электронных похождениях?

Леха: Ну, как я уже говорил, люди в любом случае воспринимают тебя в Сети не так. Виртуальная личность лишь добавляет удовольствие оттого, что ты кого-то накалываешь сознательно. Например, одно время я писал стихи от своего имени и от имени некого Виктора Степного. Так вот, всякие литературные чуваки отзывались обо мне так: "У тебя, конечно, хорошие стихи, но говно". А Виктору Степному они в то же время пишут, что вот, мол, наконец появился достойный человек, где вы, типа, раньше публиковались, давайте познакомимся. Или как-то раз, когда я работал у питерского писателя Житинского, он вдруг ко мне прибегает радостный и кричит: "Про меня Мэри Шелли написала!". И давай мне рассказывать, что он ей в ответ напишет, старый ловелас! Ну а я сижу и пытаюсь не заржать изо всех сил просто. Кстати, вот ты говоришь - "толстые волосатые программеры". Ерунда! Вот если бы Мэри Шелли была в натуре девушкой, ей бы знаешь как тяжело пришлось! Помнится, на награждении ТЕНЕТА-98, где Мэри Шелли заняла первое место в номинации "Виртуальная личность", мы подговорили одну знакомую выйти и от имени Мэри получить приз. Заодно и речь ей написали. Так потом к ней столько народу стало приставать! А все желтые издания типа "Время МН" и "Новый мир" сразу написали - мол, Мэри действительно оказалась клевой герлой с во-от такими большими... Короче, девушкой в наши дни быть очень опасно.


Спецвыпуск Xakep, номер #015, стр. 015-016-2, Интервью с Мэри Шелли

Интервью с Мэри Шелли

Спецвыпуск Xakep, номер #015, стр. 015-016-2

Спец: А какой-нибудь забойный случай из своего сетевого экспириенса, который народ может взять на вооружение?

Леха: Хы. Одно время группа поддержки Мэри Шелли устраивала съезды в забугорных гостевых. Представляешь, сайт какого-нибудь буржуя серьезного, он там явой занимается, все дела. А тут назначается время, в его гостевую заваливается толпа и начинает обсуждать какие-то свои проблемы на русском, для буржуя совершенно диком, языке. И потом так же неожиданно исчезает. У чувака культурный шок. Да много всего было... Вообще, меня раздражает, что в Интернете народ по большей части какой-то душный. У Сети столько возможностей, а люди ленятся их использовать...

Спец: Нет ли у тебя ностальгии по старому доброму тусовочному Рунету середины 90-х? Когда центром Вселенной были Темы Лебедевы, Иваны Поровозовы и Кати Деткины, а не медиа-корпорации. Ведь именно в то время появление Мэри Шелли стало сенсацией.

Леха: Ностальгия есть, конечно, - но, по-моему, это какая-то неправильная ностальгия. Мне как раз очень интересно, что будет дальше. Появится ли какая-нибудь молодая шпана вроде тебя, которая сотрет нас, "старичков", с лица Земли. Когда мы приходили в Интернет, там было пусто и легко. Хоть что поставь - будет прикольно, о тебе все напишут. А сейчас уже все застолблено: повсюду порталы. Да и те люди, кто 5 лет назад делал Рунет с интересом, с творческой энергией, - сейчас все эти люди как раз тормозят его развитие. Они уже постарели-потолстели, стали консерваторами, хотят сидеть дома, стричь бабки и купить себе домик в деревне, где можно спокойно умереть. И с этим сталкивается молодой народ, который заползает в Сеть. Ему волей-неволей придется многое ломать... Кстати, в России существует такая константа: число журналов про Интернет, которые отражают дух времени. Эта константа - единица. Раньше это был журнал "InterNet", теперь это "Хакер".


Спецвыпуск Xakep, номер #015, стр. 015-016-3, Интервью с Мэри Шелли

Интервью с Мэри Шелли

Спецвыпуск Xakep, номер #015, стр. 015-016-3

Спец: Как много времени ты проводишь в Интернете?

Леха: Около 9 часов в день. Ну, не то что бы я постоянно в браузере, а так - новости почитал, новости пописал, почту чекнул.

Спец: А вообще, чем для тебя прежде всего является Сеть: удобным инструментом, развлекаловкой или средой обитания?

Леха: Средой обитания точно не является - я люблю реальные жизненные проявления... (Здесь Леха опрокинул в себя еще стопарик и проводил взглядом официантку с пирсингом в пупке). И превращать Сеть в бизнес я тоже не люблю. Это вроде как взять инструмент, которым ты можешь сделать все что захочешь, и сказать: "Ну на фиг я им буду гвозди забивать, мне вообще-то кушать надо". А насчет развлекаловки... ну да, получается, что мое отношение к Сети близко к этому. Хотя это неправильный термин, скорее "игровая площадка". В плане того, что в Интернете ты можешь какие-то модели обыграть без особого риска, самообучаясь на ходу. Потом их, конечно, можно превратить в бизнес, но параллельно продолжать играть еще во что-то, экспериментировать...

Спец: В твоих романах часто упоминается такая фишка, как "цифровая кислота". Ты действительно считаешь возможным создание компьютерных наркотиков в обозримом будущем?

Леха: Хех. Вообще-то в "Паутине" много реальных фактов на эту тему - например, что ученые сравнивали картинки клеточных автоматов с кислотными глюками. Я про это знаю, потому что у меня тема диссертации была - "Распознавание образов на клеточных автоматах". И после долгого просмотра этих картинок на мониторе подобные же кислотные темы натурально начинают крутиться у тебя в голове - отсюда и идея цифровой кислоты. На самом же деле, я весьма скептически отношусь ко всяким вирусам-убийцам и прочим подобным байкам.

Спец: Каким ты видишь Интернет не через милые сердцу фантаста века и десятилетия, а, скажем, через пять-шесть лет?

Леха: Глобальный переход на мобильность. И с этим - большое количество вирусов и мусора, который будет сложнее контролировать. Сейчас-то с проводами все ясно: провайдер есть, все дела. А когда ты идешь по улице, и у тебя случайно оказался открытым инфракрасный порт, причем вокруг идет сплошной невидимый обстрел... хы-хы... Такая схема очень быстро приведет к своего рода "схлопыванию" Сети. Сейчас Сеть очень активная, очень "горячая": ты можешь попасть на сайт, которого никогда не видел, и увлечься чем-то, чем никогда не увлекался. Ты можешь сам пойти куда захочешь. А через несколько лет ты будешь ставить фильтры не только на спаммеров, а вообще на всех, кроме нескольких друзей и двух-трех рассылок. Сайты превратятся в персональные сервисы - не ты на них будешь ходить, а они на тебя. Тебя будут вылавливать, собирать о тебе информацию, чтобы потом на основе твоих пристрастий всучить тебе какие-нибудь памперсы и шоколадки.

Спец: Назови три самых посещаемых тобой сайта. Кроме pornoz.com и гестбуки на своем хомяке, разумеется =).

Леха: Гы-гы. У меня на десктопе висит страничка, на которой перечислены около двух десятков новостных сайтов, которые я ежедневно сканирую. Ну, там, DrudgeReport, The Register, New Scientist, Nature, Wired, Ananova, BBС...


Спецвыпуск Xakep, номер #015, стр. 015-016-4, Интервью с Мэри Шелли

Интервью с Мэри Шелли

Спецвыпуск Xakep, номер #015, стр. 015-016-4

Спец: Как по-твоему, на какой стадии развития находится отечественное сетевое сообщество по сравнению с теми же США?

Леха: На стадии пародии. Причем не самой успешной. Надо понимать, что даже если ты отсталая страна и копируешь чужое - следует хотя бы выбирать, что копировать. Самый простой пример - шоу "За стеклом". Фишка в том, что шум вокруг него совершенно несерьезный, держится на мелкой этической нестыковке, а не на каком-то серьезном феномене. Для США прикол таких шоу весьма понятен. Там очень развит индивидуализм, буквально до болезненности, когда каждый имеет пять комнат и десять замков. Поэтому для них подглядывать за соседом - прикольно. А у нас, где каждый второй вырос в общаге, никого этим не удивишь. То же самое с Интернетом. Сколько уже твердят о е-коммерции? Фигня все! У наших людей нет ни кредитных карточек, ни счетов с чековыми книжками. Народ привык к налику, и как ему этот налик донести до Интернета - совершенно непонятно. Даже в Штатах в прошлом году NASDAQ начал сыпаться, оправдывая железный прогноз: 70% доткомов обанкротятся в течение года. А у нас в то же время - эйфория: все строят какие-то гиперпорталы и электроные магазины, как будто ничего не происходит. Но вскоре наша нац. особенность наконец возьмет свое. На Западе еще будут пытаться выжать из Сети бабки, а у нас Интернет уже вернется к старой и доброй модели "просто большой тусовки". И это хорошо! Потому что купить презервативы можно и в оффлайне. А вот познакомиться с крутыми перцами вроде меня - это почти невозможно без Интернета.

Диагноз: Мэри... то есть Леха - совершенно чумовой дядька с ярко выраженным маниакальным синдромом. Он не замолкал ни на минуту, периодически бегал по бару, размахивая руками и что-то втирая официанткам про нейронные сети, а когда у меня в диктофоне закончилась пленка, он начал писать ответы на салфетках. И еще сказал, что знает, где упадет следующий самолет.


Спецвыпуск Xakep, номер #015, стр. 015-018-1, Обзор книжек по вебу

Обзор книжек по вебу

Urix (spora_2k@mail.ru)

Спецвыпуск Xakep, номер #015, стр. 015-018-1

Книжки по вебу можно поделить на две большие части: ползание по сайтам и их разработка. С первыми все просто - это издания для новичков, которые с Инетом только знакомятся. А вот со второй частью посложнее. Талмуды по HTML, ASP, PHP, Perl, скриптам и прочему техническому обеспечению здорово похожи друг на дружку и больше относятся к программированию, чем к разработке сайтов. Вместе с руководствами по прогам их стоит читать в последнюю очередь - когда уже ясно, что должно быть разработано и с какой целью. Хороших же книжек, которые помогают это понять, мало, и они разные, поэтому на них надо обратить особое внимание.

Часть I. Использование

Симонович С. Новейший самоучитель по работе в Интернете. - М.: ДЕСС КОМ, 2000. - 528 с.

Поначалу я не мог понять, чему же в Интернете можно учится по книжке. Спустя некоторое время я припомнил, что, во-первых, еще есть места, куда не дошло разлагающее воздействие цивилизации, а, во-вторых, люди тоже бывают разные. Некоторые не только не спят в обнимку с ноутбуком, а даже не имеют знакомого системного администратора. Вот для них и предназначена первая часть. Там пишут, как выбрать модем и провайдера, как настроить соединение и браузер, что такое адрес и где его писать, как пользоваться поиском и ходить по ссылкам, как работать с почтой и многое-многое другое. Вторая часть - создание веб-страничек, об этом мы еще поговорим.

Крупник А. Поиск в Интернете: самоучитель (знакомство, работа, развлечение). - СПб.: Питер, 2001. - 272 с.

По своей природе Интернет хаотичен, и найти нужную инфу зачастую очень тяжело. Эта книжка поможет тебе ориентироваться в мире поисковых систем и языков запросов. Сведения о механизмах поиска удобно собраны, структурированы и изложены максимально доступным языком. Сначала описывается общее устройство поисковых машин, затем рассматриваются их особенности - такие, как принципы сортировки ответа, пригодность для поиска конкретных или общих тем. Есть материал по поиску новостей, картинок, программ и музыки. Все это сдобрено ссылками и примерами, читается легко и с интересом.

Начало книжки рассчитано на человека, который видит браузер в первый раз, в целом же она подойдет более-менее опытным пользователям, которые перемещаются по страничкам, уже не задумываясь, и хотят большей свободы.

Современный самоучитель работы в сети Интернет. Самые популярные программы. Под ред. Комягина В. - М.: ТРИУМФ, 2001. - 496 с.

Занудное руководство по использованию полутора десятков программ на пяти сотнях страниц, CD-ROM с программами прилагается. Описания примерно такие: "Два раза щелкните на значке программы. Когда прочитаете сообщение, нажмите кнопку далее..." - и соответствующие скриншоты. Чтобы читать подобные тексты, надо быть или большим энтузиастом, или страдать жестокой бессонницей. Понравится такое может только продвинутому юзеру с неуемной тягой ко всему лучшему, но без знания английского языка. Хотя сомневаюсь, что подобный юзер встречается в реальной жизни, это скорее лабораторный экземпляр. Для остальных толку вообще не будет, да и интереса никакого.


Спецвыпуск Xakep, номер #015, стр. 015-018-2, Обзор книжек по вебу

Обзор книжек по вебу

Urix (spora_2k@mail.ru)

Спецвыпуск Xakep, номер #015, стр. 015-018-2

Часть II. Разработка

Нильсен Я. Веб-дизайн: книга Якоба Нильсена. - СПб.: Символ-Плюс, 2000. - 512 с.

Если хочется самому заниматься разработкой сайтов, то это - первая книга, которую стоит прочитать. То есть не просто заниматься, а получать при этом результаты, пригодные к использованию посетителями. Основная тема - создание сайта, которым удобно пользоваться. Это как раз то, от чего пользователи балдеют, влюбляются в твой сайт и прут на него толпами так, что хостинг-провайдер стонет и пишет тебе письма о необходимости перейти на коммерческую основу. А если это уже сделано, то кричать он будет о надобности в более толстом канале и сервере помощней. Тут еще, конечно, содержание играет роль, надо знать, какие инстинкты стимулировать ;). Материал книги - не абстрактная теория, а отражение профессионального опыта, поэтому подкреплен массой примеров и статистикой. Читается она вполне легко и оформлена прилично. Умный учится на чужом опыте...

Круг С. Веб-дизайн: книга Стива Круга, или "не заставляйте меня думать!". - СПб.: Символ-Плюс, 2001. - 200 с.

Третья и последняя на данный момент книга из серии "Веб-дизайн..." издательства Символ-Плюс. От предыдущих она отличается полноцветной печатью на всех листах (а не только на врезках, так что теперь не надо мусолить странички и искать нужную картинку где-то в конце) и объемом. Он таков, что можно прочитать всю книгу за один раз, стиль написания тоже этому способствует. Тексты чисто практические: сначала рассматривается психология реальных пользователей, затем способы их ублажения - растолковано, как должна быть спроектирована первая страница и навигация сайта, и, под занавес, объяснена организация юзабилити-тестирования. В конце разделов есть вопросы для самопроверки, есть и ответы на них. Оформление выше среднего, читается без труда. Настораживают обложка, противоречащая содержанию, комиксы и клипарт.

Рекомендуется не только разработчикам, но и пользователям. Изложенные принципы помогут разобраться, что же хозяин сайта хотел изобразить и как теперь этим пользоваться, и, следовательно, помогут уверенней чувствовать себя на любой паге.

Бейн С., Грей Д. Как сделать красиво в Интернете. - СПб, Символ-плюс, 1998. - 320 с.

На самом деле авторы объясняют скорее не как сделать красиво, а как сделать удобно. Раскрошено: цели - действительно ли необходим сайт, какие он даст преимущества, какими будут его содержание и структура, кто будет им пользоваться. Оформление - как лучше оформить имеющиеся материалы, какие ошибки типичны. Поскольку книжка больше ориентирована на новичков, много внимания уделяется техническим вопросам и понятиям. Типа что же выбрать: гиф или жпег, и что такое сглаживание (antialiasing). Примеры сайтов - проекты, разработанные профессионалами. Это не просто галерея скриншотов, а интервью с разработчиками - какие цели преследовались и что за технологии были использованы для их достижения.

Кирсанов Д. Веб-дизайн: книга Дмитрия Кирсанова. - СПб.: Символ-Плюс, 1999. - 376 с.


Спецвыпуск Xakep, номер #015, стр. 015-018-3, Обзор книжек по вебу

Обзор книжек по вебу

Urix (spora_2k@mail.ru)

Спецвыпуск Xakep, номер #015, стр. 015-018-3

А вот тут действительно вопросы эстетики на первом месте - рассказывается о том, как сделать красиво. Но этим дело не ограничивается: помимо дизайна как такового и примеров, сделанных автором страничек, есть также "техминимум" и, конечно, главы по вебу. Отзывы об этой книжке встречаются разные, и в основном нарекания относятся к внешнему виду. Нет, речь не о бумаге - книга по дизайну не может издаваться на туалетной бумаге. Дело в стиле, в специфичности. Напрягает оформление, какое-то оно очень самостоятельное: текст, заголовки, поля, ссылки не похожи на типовые. Язык весьма тяжелый и витиеватый - усваивается книга долго, хотя содержание того стоит. Так что если хочешь наваять что-либо красивое, придется немного напрячься. Красота требует жертв.

Белунцов В. Новейший самоучитель по разработке Web-страниц. - М.: ДЕСС КОМ, 2000. - 448 с.

Самоучители по созданию Web-страничек нужно воспринимать примерно так же, как "Вредные советы" Григория Остера. Читать можно, но всерьез не воспринимать ни в коем случае. Если книжки с описаниями программы либо среды разработки только предполагают возможность использования различных опций и описывают их все в силу необходимости, то самоучители пытаются научить создавать странички со всеми возможностями, которые есть на свете. Почитав такую книжку, одержимый жаждой творить и наносить добро юзер хватает первый попавшийся под руку редактор WYSIWYG и старательно набивает свою страничку всем, чему учился, - картинки, музыка, Flash, скрипты и счетчик до кучи. Несмотря на то, что самоучители бывают разные, результат один: бирюзовый текст на салатовом фоне, мечется по экрану что-то ужасное, и бегущие строки "падают стремительным домкратом". Можно распечатать на цветном принтере и отгонять злых духов.

Поэтому, если очень хочется поиметь свою страничку, а книжка пришлась, что называется, по больному месту, один тебе совет: не занимайся украшательством. Не яйца красят человека, а человек яйца.

Часть III. Инструментарий

Мэтьюз Р. Д. и др. Web-сервер под UNIX. - СПб.: Символ-Плюс, 1998. - 560 с.

Единственная в обзоре книжка по техобеспечению - наиболее общая. Сюда залиты все стороны создания веб-сервера, начиная со списка совместимого с ОС оборудования, ее установки и обеспечения безопасности и заканчивая HTML-тегами и CGI-скриптами. Не забыт и сам веб-сервер как приложение, расписаны его выбор (хотя выбирать сейчас особо не из чего) и настройка. Книжка получилась толстая и разномастная, сейчас она местами уже устарела, но именно из-за разнообразия материала и ориентации на Юникс ценности не потеряла. Язык нормальный, но читается с трудом, надпись "уровень подготовки читателей - выше среднего" на обложке стоит не даром. По оформлению замечание только одно - часть картинок имеют просто безобразное качество, пикселы режут глаз.


Спецвыпуск Xakep, номер #015, стр. 015-020-1, Софт для perl-разработчика

Софт для perl-разработчика

p4in (d00d13@mail.ru)

Спецвыпуск Xakep, номер #015, стр. 015-020-1

Если ты занимаешься разработкой CGI-программ на Perl'е, то, возможно, поначалу сталкивался с проблемой выбора удобного редактора. Я тоже прошел этот путь, начиная кодить в первом попавшемся эдиторе (он был встроен в FarManager ;)) и заканчивая работой с навороченным Perl Builder'ом и прочим девелоперским софтом. Именно о выборе таких тулз и будет наш сегодняшний разговор.

Perl Builder

Качать с http://www.solutionsoft.com, вес - 2,8 метра.

С сайта ты можешь взять пробную версию, которая будет работать только 14 дней. Альтернатива - заказ продукта по цене 179 буказоидов. Думаю, ты сам сделаешь выбор...

Итак, запусти Perl Builder. При первом старте тебя спросят, какой режим использовать: обычный или профессиональный. Выбирай профессиональный, так как в дополнительных фичах там есть утилита, измеряющая скорости работы скриптов. Она может тебе пригодиться, если будешь заниматься оптимизацией кода. В общем, наш выбор - профи, и вперед! После появления главного окна сразу начинаешь подозревать, что данный продукт не потянет на профессиональный perl-редактор, но так кажется только поначалу. Чтобы окончательно развеять это впечатление, мы поковыряем настройки: топай в Tools -> Options. Должно появиться окно с тремя вкладками: Locations, Preferences и CGI Wizard. В Locations прописываются пути к интерпретатору перла, к HTML-редактору и к документации. Реально понадобится только путь к Perl. Над вкладкой Preferences придется несколько задуматься: если твои скрипты будут работать под Unix, то лучше поставь галочку у "Save in UNIX format". "Auto indent based on bracket" лучше отруби - он сделан несколько кривовато. В CGI Wizard пропиши путь к перлу и к sendmail'у (они пишутся в Unix-формате). Далее придется вернуться к вкладке Preferences - в ней нажми кнопку "Editor Settings". Кстати, она также доступна через меню: Tools -> Set Editor Options and Colors. Откроется еще одно окно, в нем сразу переползай на вкладку Options. В "General Options" включай "Word wrap", если хочешь, чтобы был перенос длинных строк; отметь "Auto indent" (при переходе на новую строку будет запоминаться предыдущий отступ), поставь крестик на "Smart fill" (в новых строчках отступ будет заполняться так же, как и в предыдущих), отметь "Use tab character" (заполнять отступ табуляцией) - это признак хорошего кода, "Line numbers gutter" (выводить номер строк) и, конечно, включи "Syntax highlighting", чтобы подсвечивался синтаксис команд. Только проставь в подсветке нормальный шрифт, а то не будут выводиться русские буквы. Вкладка Key assigments (настройки горячих клавиш) - это уже дело лично твоего вкуса, так что советовать ничего не буду :). Auto correct (автоматическое исправление ошибочных слов) - тут я тоже ничего не менял. И последняя вкладка - Code templates: здесь прописываются заготовки наиболее часто используемых команд. Например, если тебя ломает каждый раз писать "if (){somecode} else {somecode}", то ты можешь настроить все так, чтобы вставлять эти строчки по нажатию заданной комбинации горячих клавиш.


Спецвыпуск Xakep, номер #015, стр. 015-020-2, Софт для perl-разработчика

Софт для perl-разработчика

p4in (d00d13@mail.ru)

Спецвыпуск Xakep, номер #015, стр. 015-020-2

С настройками разобрались, теперь перейдем непосредственно к редактированию скриптов. Код писать действительно удобно: команды приятно подсвечиваются, отступы подставляются правильно. В общем, все в шоколаде. Но как только начинаешь работу с большими проектами, нарываешься на одни разочарования :(. Если твой сайт содержит много скриптов, которые еще как-то и взаимодействуют между собой, используют дополнительные модули (а они их будут использовать), - то ты столкнешься с проблемой постоянного ползанья по директориям в поисках нужного скрипта. Нет, конечно, это проблема отчасти решена благодаря "View Module List", но уж слишком слабо и не очень удобно, так что этот большой пробел остается на совести разработчиков. Зато обнадеживает работа с debug'ом. Уж что, а вот это действительно сделано добротно! Расставляешь где нужно точки Breakpoint - на них дебагер будет останавливаться, также между ними можно измерять скорость работы программы - потом жмешь Run/Continue, Pause и смотришь, что происходит в твоей проге в любой момент времени. Очень удобно! Еще из дополнительных примочек порадовала функция "Subroutine Navigator". Она показывает список процедур в программе. Тебе это пригодится, когда код станет большой, а копаться в поисках нужных функций станет лень. Если ты будешь подключать модули (это файлы с расширением pm), то тебе понадобится кнопочка pod (pod Viewer). Вкратце: pod расшифровывается как plain old document - это документация, которая встраивается в сам код программы (обычно его запихивают во все pm-модули). В общем, жмешь на pod, и появляется очень удобный help по модулю. Если тебя часто напрягает соблюдать отступ после символов «{» и «}», то можешь воспользоваться уже встроенным скриптом, который расставляет правильные отступы. Он находится в Editor-scripts -> Fix Indentation. Кстати, этот скрипт сам тоже написан на перле, и ты можешь его перелопатить по собственному усмотрению. Например, я добавил функцию Koi<->Win - она конвертирует отлаживаемые скрипты между этими кодировками.

Итого:

Для Windows-систем это, наверное, лучший Perl-редактор. Есть некоторые недочеты в работе с большими проектами, но их можно перетерпеть :).

Collie Perl Shell

Качать с http://collie.agava.ru, вес - 1,8 мега.

Отечественная фриварная разработка среднего качества. Извините, конечно, но в ней действительно все по-обычному (да простят меня любители родного софта), и ничего такого, что могло бы ее выделить из ряда других программ, я не нашел. Несмотря на это, на русских софтверных серверах ее оценили по максимуму :-/. Ну да ладно, расскажу, что же мне в ней не понравилось.

При первом запуске несколько поражает количество различных функций, но, поработав всего несколько минут, понимаешь - все в Perl Shell предельно просто. Стандартные "Файл", "Правка" и прочее... Да, надо отдать должное грамотности программистов: такое ощущение, что на клавиатуре просто отсутствует буква «й», вместо «файлов» везде - «фаилы». Но не в этом суть :), полезем во внутренности - в настройки. Тут все стандартно: путь к бинарникам Перла и некоторые настройки редактора (отступ при табуляции, тип шрифта и формат файлов сохранения (Windows/Unix/Mac)).


Спецвыпуск Xakep, номер #015, стр. 015-020-3, Софт для perl-разработчика

Софт для perl-разработчика

p4in (d00d13@mail.ru)

Спецвыпуск Xakep, номер #015, стр. 015-020-3

Манипуляции с проектами очень напоминают Perl Builder: в них нет поддиректорий, только голый листинг файлов, что несколько напрягает. Зато работа с самими скриптами сделана по-людски: правильный отступ в новых строках, стандартная подсветка Perl синтаксиса. Также полезным может оказаться уже знакомый нам механизм Code templates. Порадовала функция для конвертации из других кодировок в cp1251. Из необычных фич я нашел "Редактор регулярных выражений" - вот это действительно извращение :). Не знаю, кто этим будет пользоваться. Просто сделана она очень неудобно - гораздо проще самому писать регулярные выражения.

В целом писать программы с Collie Perl Shell вполне удобно, но только писать. Если же ты захочешь их еще и отлаживать, то о debug-режиме можно забыть сразу. Он есть, но это просто запуск перла в дебаг-моде :(.

Итого:

Обычный редактор для Perl. Если собираешься писать небольшие перловые проекты, то такой редактор вполне сойдет.

PerlStudio

Качать с http://www.perl-studio.com, вес - 2,4 метра.

Довольно мощная среда для разработки Perl-программ под win32. Это подтверждается тем, что за PerlStudio просят немалых денег (аж сотню американских рублей). Но это не проблема - ведь у нас есть асталависта :). По интерфейсу PerlStudio очень напоминает VisualStudio. Хоть это и плагиат, зато работать удобно. Особенно приятно на первых порах: спросят, какой проект хочешь создать, в Unix-формате или в виндовом, HTML файл или Perl. В общем, с программистом общаются по-человечески. Когда переходишь к редактированию скриптов, то тут тоже все гладко. Синтаксис подсвечивается очень приятными цветами, так что глаза не устают при просмотре кода.

Как обычно, поначалу настроим редактор. Для этого заходим в View -> Preferences. Здесь прописаны стандартные пути ко многим Unix-программам. Прописывай все пути. После настроек мне сразу захотелось узнать, как здесь реализована работа с проектами. В принципе, она устроена почти так же, как и в предыдущих софтварах, но в PerlStudio список файлов вынесли в отдельную вкладку "Projects", и это, несомненно, очень удобно. Еще сильно обнадежила работа с базами данных. PerlStudio может вытянуть из HTML'ных файлов информацию о входных данных и переделать их в SQL-запросы для баз данных MySQL, MS SQL, MS Access. Если у тебя есть HTML-форма, на основе которой нужно сделать скрипт, создающий базу данных и изменяющий в ней некоторые поля, то эти фичи будут тебе очень полезны. Помимо этого, очень нужной оказалось функция обновления твоих скриптов на фтп серверах. Для меня она просто незаменима, так как мне напряжно по 100 раз открывать окно ftp-клиента и обозначать файлы, необходимые для закачки. Отлаживать программы в PerlStudio не получится :(. В нем дебаг реализован опять-таки элементарным запуском перла в debug-режиме (как уже было в Perl Shell). Это единственная отрицательная сторона PerlStudio - в остальном все ок :).


Спецвыпуск Xakep, номер #015, стр. 015-020-4, Софт для perl-разработчика

Софт для perl-разработчика

p4in (d00d13@mail.ru)

Спецвыпуск Xakep, номер #015, стр. 015-020-4

Итого:

Очень хорошая среда для разработок на Perl. Если тебе чем-то не понравился PerlBuilder, то ставь PerlStudio. Возможно, он станет твоим основным редактором.

Nedit

Если ты пишешь софт под nix'ами и при этом любишь работать в X-Window, то тебе стоит попробовать Nedit! Он использует Motif-стиль, то есть не требует наличия qt с KDE или gtk с Gnome'ом. Хватит и стандартной установки X'ов. Программа распространяется по системе OpenSource, так что ставить ее надо из исходников. Nedit понимает синтаксис Perl, PHP, C/C++. Также можно добавлять свои цветовые схемы для других языков. В остальном редактор ничем не отличается от предыдущих: отсутствует нормальная организация работы с проектами, нет хорошего debug-режима. Несмотря на это, в нем действительно удобно работать: нет ничего лишнего, все под рукой. Особенно удобно организована работа с отступом в новых строках: ты сам можешь определить, как делать отступы, после каких символов, чем их заполнять (табуляцией или пробелами). Это редактор можно посоветовать, если ты собираешься переползать на родину CGI-скриптов - в Unix-системы.

Итого:

Приятный редактор без лишних наворотов. Так как он распространяется в виде исходников, то его всегда можно перелопатить и перекомпилировать, если что-то не нравится.

Замученные дебагом

И напоследок хочу дать тебе полезный совет ;). Если будешь писать скрипты именно для веба, то отлаживать их лучше не в самом редакторе и не средствами интерпретатора, а прямо на web-сервере. Конечно, тебя может обломать перспектива постоянно upload'ить файлы на сайт. Не вопрос - поставь http-сервер у себя. Например, возьми MicroWebserver с http://www.indigostar.com. Настраивать в нем ничего не надо, просто скопируй свой проект в директорию web-сервера. Теперь надо запустить microweb, после чего автоматически откроется окно браузера с твоим сайтом. Правда, это не лучший сервер, гораздо продвинутей тот же apache или sambar. Короче, дерзай :).


Спецвыпуск Xakep, номер #015, стр. 015-022-1, Flash номер пять, сайты делаем опять

Flash номер пять, сайты делаем опять

Спецвыпуск Xakep, номер #015, стр. 015-022-1

Comrade False (mr_false@xakep.ru)

Что, приятель, ты сделал сайт - а на него никто не ходит? А если и ходит, то в переносном смысле? Нда, надо срочно что-то менять. Если с содержанием возиться не моя задача, то с внешним видом немного помочь могу. Окинь свой сайт быстрым взглядом: он похож на окаменелое грязное месиво, так и застывшее в каменном веке? Давай-ка мы оживим его. Говоришь, сложно и ява-скрипты - геморрой? А ты разве до сих пор не слышал о такой фишке, как Flash? Это легко исправить. Смотри, я расскажу тебе...

Кому оно надо?

Итак, собственно, для чего нужен флэш? Он позволяет быстро делать интерактивную анимацию достаточно малого размера, то есть как раз для Инета. Для заядлых кодеров во флэш встроен action-script (что-то типа ява-скрипт, только лучше). Но если ты не сильно шаришь в кодинге, то тоже сможешь творить достаточно крутые вещи. В общем, предлагаю считать тебя заинтересовавшимся :). Давай-ка я тебе все это покажу. Для начала бери либо сидюк с этим самым флэшем, либо топай на www.macromedia.com и лей его оттуда (около 18 Мб). Единственно, литая версия - шароварная, так что затоварься где-нибудь уткой (покрякаете вместе :). Предлагаю считать флэш вставшим, а утку коней не содержащей (а такое бывает?). Запускай!

Гонобобель Unlimited

После запуска свежедобытого флэша ты увидишь на экране такую жуть с ружьем:

Можешь не прятаться в шкаф, она тебя не съест, она тебя лишь немножко покусает. Видишь такое тонкое окошко слева - это панель инструментов. Именно ими осуществляется всякого рода рисование. Давай я тебе что-нибудь покажу. Шлепни по пимпе с бюковкой "А". Теперь надави на эту огромную белую поверхность и напиши: "Гонобобель". Что за ерунда?! Да еще и мелко! Спокойно, сейчас пофиксим. Жми "Window->Panels->Text Options", выбирай вкладку "Character" и вводи в поле, где нарисована буковка "А" со стрелками вверх-вниз, размер: 48, в поле "font" выбирай чего-нибудь с буквами "Cyr". Цвет сделай ярко-зеленым, для чего воспользуйся прямоугольником, расположенным справа от размера. Ты заметил, что зеленый "Гонобобель" не смотрится на белом фоне? Чудно! Для того чтобы задать цвет фона, воспользуйся байдовиной "Modify->Movie..." или нажми Ctrl+M. Выбери черный цвет там, где написано "Background color". В итоге ты увидишь такую картину:

Кстати, в этом же окошке можно поменять скорость кадров в секунду и размер ролика в пикселях.

2Dfx

Если тебе это показалось слишком скучным, то давай для начала сделаем этой надписи статичный эффект. Выбирай свою надпись, дави F8 и вводи "gonobobel". Этим ты переделал надпись в так называемый Movie Clip-объект. Этот самый объект ты теперь можешь всячески таскать, тянуть, вращать, применять к нему всякие эффекты, размножать ;) без создания заново. Надави Ctrl+L. У тебя появилась форточка, в которой уже есть объект gonobobel. Прекрасно! Вообще, это окно - так называемая библиотека, в ней валяются все movie-clip'ы и кнопочки, о которых речь пойдет чуть позже, а также прочая ботва. Следующую оперейшн тебе придется проделать 4 раза. Драгай и дропай один "gonobobel" из библиотеки в поле. Теперь, надавливая правой крысой на гонобобеля и, выбирая там подменюху "Panels", открывай окошки "Info", "Align" и "Effects". Зачем? А прикольно ведь! Кстати, надави на пимпу "To stage" в окне "Align", пока не забыли. Ну а теперь выделяй гонобобель черной стрелкой и при помощи пимп "Align Horizontal Center" и "Align Vertical Center" центрируй его. Затем в окошке "Info" (вкладка "Transform") ставь галочку на "Constrain" и делай так, чтобы каждый следующий гонобобель был на 5% больше предыдущего (100%, 105%, 110%, 115%). Для этого вводи в окошко цифру и дави ентер. Далее выбирай эффект "Alpha" из списочка в форточке "Effect" и проделывай то же, что и с размером: каждый следующий гонобобель должен быть на 20% прозрачнее предыдущего. Теперь выдели все гонобобели (стрелкой, удерживая пимпу крысы или давя Shift и щелкая по ним). Снова юзай F8 и вводи имя "gonobobs". Надеюсь, ты понял мою смутную мысль? В итоге у тебя будет:


Спецвыпуск Xakep, номер #015, стр. 015-022-2, Flash номер пять, сайты делаем опять

Flash номер пять, сайты делаем опять

Спецвыпуск Xakep, номер #015, стр. 015-022-2

Мне кажется, что это скучно. Давай забабахаем сюда анимацию. Как? Ну, ты попал ;)! Видишь такую полоску вверху с белыми и серыми прямоугольниками? Это полоска кадров. Каждому прямоугольнику соответствует один кадр. Как видишь, все они пронумерованы. Тыкай на 25-й кадр и дави F5. Этим ты создал все кадры до 25-го. А теперь дави на них правой крысой и выбирай "Create Motion Tween". О-о-о! Кадры посинели и срослись в один! Теперь ставь красный маркер на 13-й и 25-й кадры и делай их ключевыми. Как? Очень просто: выбираешь кадр и давишь F6, кадр метится точкой. Выбирай первый кадр и ровняй надпись по левому верхнему углу при помощи окна "Align" (там все по значкам понятно). И еще добавь эффект "Alpha" в "Effects" на 0%. На 13-м кадре ровняешь надпись по центру сверху, а на 25-м - по правому верхнему углу и альфу - в ноль. Потаскай маркер над кадрами туда-сюда.

Видишь? Дабы в полной мере насладиться этим впечатляющим зрелищем, дави F12. Эта ужасная кнопенция всего лишь заставит флэш сгенерить swf-файл, html'ку к нему и запустит все то дело в Ынтырнет Ыгплорырь. Обязательно порадуйся и не забудь сохраниться!

Итак, настал черед объяснить, что это было. Motion Tween служит для создания расчетной анимации. Все, что он делает, - это рассчитывает промежуточные фазы между ключевыми кадрами для плавной анимации. Ключевые кадры - те, в которых происходит изменение объектов и выполняются экшн-скрипты (о них ниже). Как ты заметил, tween может работать только с одним клипом. А как тогда, спрашивается, заставить целую кучу объектов двигаться в одной сцене? Для этого существуют так называемые слои. Видишь такую надпись напротив кадров: "Layer 1". Это - первый слой. При помощи кнопок, расположенных снизу окошка со слоями, их можно наклепать еще больше. Собственно, анимация в слоях происходит параллельно, видны они в таком же порядке, как и в окне: самый верхний закрывает собой нижний. Сделай еще пару слоев (листочек с плюсом), повтори для них операции с гонобобелями (сделай их разных цветов), только теперь пусть гонобобели летают по двум диагоналям. Посмотри, какой гонобобель пролетает над каким. Поменяй местами слои (просто перетащи мышкой). Опять посмотри, и со слоями все станет ясно.


Спецвыпуск Xakep, номер #015, стр. 015-022-3, Flash номер пять, сайты делаем опять

Flash номер пять, сайты делаем опять

Спецвыпуск Xakep, номер #015, стр. 015-022-3

Цапы

"Да, конечно, все это круто, но мне на сайте нужна еще и менюшка", - скажешь ты и будешь прав. Давай думать, как можно сделать кнопки. Попробуй так: выбирай в верхней менюхе "Insert->New Symbol". Имя пущай будет "Baton1", а "Behavior" - "Button". Дави "ОК" и ужаснись! Что это, куда все делось? Это всего лишь редактор кнопаря (собственно, мы попали в редактор символов, к коим относятся и кнопки, и клипы). Из всех кадров осталось только четыре, и то - обозванные странными забугорными словами. Объясняю: каждый кадр соответствует определенной фазе кнопки, "Up" - обычное состояние, "Over" - какой-то злодей навел на нее крысу, "Down" - не менее злобный чел надавил на нее, "Hit" - кнопарь срабатывает. Надо заметить, что реакцию "Hit" практически никогда не видно. Так, к бою. Надави "View->Rulers" (ну, или Ctrl+Alt+Shift+R, если тебя это прикалывает). Так ты создашь линейки по краям. Весьма полезная штучка, когда нужна точность. А нам она не сильно нужна, так что прикрой ее обратно ;). Выбирай такой круг в панели инструментов, цвет заливки поставь в черный (помечен как банка с чем-то из нее выливающимся, надо полагать - с... ладно, молчу), цвет границы в зеленый (рядом с карандашом) и нарисуй-ка мне не слишком крупный овал в центре. Готово? Ай, молодца! В центре сделай надпись зеленого цвета "Хочу!". Теперь выбирай первый кадр и выдавливай F5 ровно три раза. Затем сделай каждый кадр ключевым (надеюсь, ты еще не забыл, как это делается). Таперича выбери второй кадр (который "Over"), выдели границу овала посредством черной стрелки и сделай ее белого цвета (выбери белый рядом с карандашиком). Аналогично для "Down" цвет границы - красный, "Hit" - синий. Вот, первая цапа готова. Выбирай "Scene1" на вкладках сверху. Теперь создаем новый слой, опять придавливаем Ctrl+L и перетаскиваем наше искусство на сам ролик. Дабы проверить, дави F12. Замечательно мигает!

КодинГ

"Ну и где же твоя интерактивность?", - последует вопрос. Их есть у меня. Надо сделать так, чтобы при нажатии на кнопарь нас посылало куда-нибудь. Ну, скажем, на Х... на сайт Х. Делается это посредством экшн-скрипта. О-о-о, это весчь! Мы с тобой займемся непосредственным ее освоением. Выдавливай правый крыс на состряпанной тобою цапе и бери штурмом пункт "Actions". Если еще не выбрана вкладка "Object Actions", то сделай это прямо сейчас. Что есть этот кошмар? Смотри, слева у тебя список всех возможных функций, операторов и прочих извращений, а справа - сам код. По умолчанию, здесь тебе не дадут полноценно менять текст сырца ручками - пока ты находишься в "Normal mode". Если ты спец в скриптах, то дави Ctrl+E и переходи в Expert mode. Но начать я бы посоветовал проще - с выбора функции и приписывания ей параметров. Давай сделаем это, детка. Слева ищи функцию "Actions->on" и кликай по ней два раза подряд. О как! В появившихся внизу "чекбоксах" сними галку с "Release" и поставь оную на "Press" - надавлена то бишь. Функция "on" обрабатывает события данного объекта, в нашем случае - кнопки. Ты не знаешь, что такое события? Не вдаваясь в кучу технических подробностей, во флэше работает это следующим образом: вот некий абстрактный злобный чел навел мышу на нашу цапу и надавил на нее (произошло событие "Press"). На это безобразие флэш реагирует так: он ищет в скриптах кнопки функцию "on" с параметром "Press" и, если оная имеется, выполняет ее. Все просто! Ну вот, теперь ищи функцию "Actions->getURL", пиши в параметр "URL" следующее: "http://www.xakep.ru". Заметь, что обязательно с "http://", иначе не прокатит. Дави F12. Ну, как?


Спецвыпуск Xakep, номер #015, стр. 015-022-4, Flash номер пять, сайты делаем опять

Flash номер пять, сайты делаем опять

Спецвыпуск Xakep, номер #015, стр. 015-022-4

Согласись, не сильно понятно, чего именно надо хотеть (а хотеть можно всякого ;)). Давай сделаем подсказку, поясняющую, чего же именно. Выбирай вкладку "Text Options" в инспекторе текста... Как нет такого инспектора? Дави "Text->Options" в меню. А вот сейчас выбирай в первом, как я их называю, вывальном списке, пункт "Dynamic Text". Сие значит, что мы можем из скриптов менять текст, написанный в текстовом поле. Во втором списке выставь "Multiline" - многострочный текст. Из всех галочек поставь только "Word Wrap" (перенос по словам). Во вкладочке "Paragraph" сделай, чтобы текст центрировался. Теперь выбери в тулзах инструмент текста (буква "А") и шлепни в поле. Далее хватай мышом маленький квадратик в правом нижнем углу и растягивай рамку, иначе ничего не влезет. Затем в поле "Variable" вкладки "Text Options" обязательно введи "Info" вместо какого-нибудь "TextFild". Возьми черную стрелку и поставь ею текстовое поле в центр сцены. В итоге оно будет так:

Опять дави правой крысой на цапе и добавляй функцию "Actions->on" с параметром "onRollOver". На данный момент тебе надо найти функцию "Actions->Set Variable". Эта функция присваивает какой-либо переменной указанное значение. В поле "Variable" вводи "_root.Info". Как ты помнишь, "Info" - имя переменной, которой соответствует наше текстовое поле. А что же есть "_root"? Так вот, это класс глобальных переменных. Звучит страшно? Не бойся. Грубо говоря, класс - это объект, хранящий переменные и функции, обратиться к которым можно так: "имя_класса.имя_переменной_или_функции". В нашем случае переменная "Info" валяется в основной сцене, то есть в классе "_root" - поэтому, поместив какую-либо строку в переменную "_root.Info", ты увидишь этот текст на экране. Значение ("Value") ей присвой что-нибудь вроде "Нажмите и окунитесь в волшебный мир Гонобобеля!". Далее, надо же и убрать подсказку после того как крыса уедет с территории кнопки. За отъезд отвечает событие "rollOver". Опять так же создавай функцию "on(rollOver)", а в ней просто присвой "_root.Info" пустое значение (ничего не пиши). Этим ты сделал подсказку кнопарю. Сохранись и дави F12... Что значит, не работает подсказка? А-а-а... Понятно! Дело в том, что флэш делали буржуи, которые даже не догадывались (и не догадываются) о существовании чудесной и могучей русской буквы "Я" с кодом 0xFF (aka 255). Естественно, флэш ведь не может работать, не сругнувшись на такую замечательную буковку. Резонный вопрос, как это обойти? О, комрад, это большой изврат! Сделай вот так: удали знаки "я!", потом надави Ctrl+E. Не пугайся - абракадабра делу не помешает. Дальше у тебя должно получиться такое: "...гонобобел" add "\xFF!";" (ясен пень, без внешних кавычек). Функция "add" сольет два выражения воедино, и мы получим "...гонобобеля!". Сохранись и убедись (F12).


Спецвыпуск Xakep, номер #015, стр. 015-022-5, Flash номер пять, сайты делаем опять

Flash номер пять, сайты делаем опять

Спецвыпуск Xakep, номер #015, стр. 015-022-5

I'd like to move it, move it!

Давай теперь добавим немного анимации нашему ролику через экшн-скрипты. К примеру, сделаем простой летающий шарик, который отскакивает от стенок. Сперва надо сварганить этот самый шарик. Заходи в "Insert->New Symbol" и создавай Movie Clip с названием "Suxx". В самом clip'е пущай будет один кадр. Бери тулзу для рисования окружностей и рисуй оную в центре, но только небольшую, радиусом эдак 10 пикселей (для этого тебе пригодится вкладка "Info", где размеры можно задать цифрами). Заливка пусть будет красная градиентная, а цвет границы тоже красный.

Готово? Отлично! Теперь опять создавай новый клип с названием "megasuxx" (ты окажешься в нем) и перетаскивай свежеизготовленный "suxx" в него и центрируй. Щелкай по надписи "Scene 1" в левом верхнем углу рабочей области. Теперь выбирай слой с нашей кнопкой "Хочу!" и вытягивай на центр из библиотеки "megasuxx". Выделяй его и бей в него правой крысой, дальше "Panels->Instance". В поле "Name" вводи "Ball". Ага, отлично, только "Instance" прикрой - неприлично ведь! Теперь в правом верхнем углу рабочей области откликай цапу с треугольником, квадратом и кружком в куче и выбери наш "megasuxx". Отлично - мы опять внутри него! Шар у нас готов, осталось только догадаться, как же его двигать. Принцип этого "непростого" алгоритма такой: у нас есть скорость шарика и его координаты, и мы каждый кадр просто прибавляем к координатам скорость и получаем иллюзию движения. Но таким образом через какое-то время мы увидим, как шарик покинет пределы ролика и улетит в необъятные просторы космоса, так и не отразившись от стенок. Как быть? Да очень просто: мы с тобой должны проверять, лежит ли шарик внутри сцены или нет, а если нет, то изменять скорость на другую, то есть на противоположную по знаку. А теперь смотри, как это реализуется в скриптах: для начала создай еще два кадра (не забыл, что мы сидим внутри мегасакса?). В самом первом надо заинициализить переменные, необходимые для алгоритма, а это - vx и vy - скорости по x и по y соответственно. Делается это при помощи ключевого слова "var". Кстати, в action-script'ах все переменные бестиповые, то есть ты можешь хранить там без заморочек хоть число, хоть свое мнение о соседке. Итак, полностью объявление переменной выглядит таким образом: "var имя_переменной1 = начальное_значение1, имя_переменной2 = начальное значение2,...;" Поэтому мы переходим в режим Expert и пишем "var vx = random(5), vy = random(5);". Random - функция, которая возвращает случайное целое положительное число, меньшее указанного в скобках. Это для того чтобы наш шар не летал слишком одинаково каждый раз. Ага, отлично! Выбирай второй кадр. Здесь нам надо каким-то образом получить координаты шара. Делается это при помощи функции "getProperty". Первый параметр оной - имя объекта, в нашем случае - "../Ball" - именно в кавычках и со слешем и двумя точками! Почему? Дело в том, что нужно указать путь к объекту и его имя. Объект зовут "Ball" (мы сами дали ему это имя), а лежит он в основной сцене, или в корне, поэтому "../". А иначе флэш наш мячик не найдет, и ничего не заработает. Второй параметр - что мы хотим получить. Вообще, можно взять практически все, начиная от координат и заканчивая коэффициентом прозрачности (_alpha). Собственно, если мы хотим получить координату шара по x, то мы так и запишем: "x = getProperty("../Ball", _x);". Аналогично для y: "y = getProperty("../Ball", _y);" Теперь координаты шара у нас хранятся в переменных x и y. Дальше мы делаем, как и задумывали: прибавляем скорость к координатам: "x = х + vx; y = у + vy". А за проверку на столкновение с вертикальными границами сойдет такая байда: "if(( x > 540) or (x < 10)) { x = х - vx; vx = -vx; }". Объясняю: "if" переводится как "если". "Or" - логическое "или", то есть одно из двух условий прокатило. Итак, дословно: если x больше 540 (ширина ролика) или x меньше 10 (радиус шарика), то уменьшаем x на vx (чтобы не "заезжала" за границу) и меняем скорость (vx) на противоположную (угол падения - равен углу отражения). Ясно? То же самое надо проделать и для y: "if(( y > 390) or (y < 10)) { y = у - vy; vy = -vy; }". Как видишь, разница только в цифрах (ширина не равна высоте). А как же теперь применить наши координаты? Есть такая функция "setProperty", первые два параметра у нее такие же, как и у "getProperty" (путь/название объекта и название параметра, который хотим изменить), а третий - значение, на которое следует поменять. Как ты понял, сюда нужно подставить подходящую переменную. Итак, в конце концов мы имеем:


Спецвыпуск Xakep, номер #015, стр. 015-022-6, Flash номер пять, сайты делаем опять

Flash номер пять, сайты делаем опять

Спецвыпуск Xakep, номер #015, стр. 015-022-6

Листинг:

x = getProperty( "../Ball", _x );

x = х + vx;

if(( x > 540) or (x < 10)) {

x = х - vx;

vx = -vx;

}

y = getProperty( "../Ball", _y );

y = у + vy;

if(( y > 390) or (y < 10)) {

y = у - vy;

vy = -vy;

}

setProperty ("../Ball", _x, x );

setProperty ("../Ball", _y, y );

И в третьем кадре напиши лишь одну строчку: "gotoAndPlay(2);". Эта фигня лишь пошлет нас опять на второй кадр, и мы получим анимацию. Ctrl+s, затем - F12. Лепота! Однако может случиться конфуз: одна из скоростей, а то и обе могут случайно оказаться равными нулю, тогда шарик будет метаться по горизонтали/вертикали или вообще стоять до перезагрузки паги. Домашнее задание тебе: проапгрейдь скрипт проверкой скоростей на ноль.

Финита the комедия!

Как видишь, ничего сложного тут нет. Если какие-то функции тебе непонятны, то поюзай "Help -> ActionScript Dictionary". Осваивай, твори и созидай. Да, и не забудь посетить www.flasher.ru - там просто куча различных исходников, доков и прочего. Увидимся там, комрад флэшер!


Спецвыпуск Xakep, номер #015, стр. 015-026-1, Софт из браузера

Софт из браузера

n0ah (noah@real.xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-026-1

Иногда случается, что сидишь в инете из какого-нибудь клуба или, скажем, из института: канал выделенный, связь отличная, машина мощная, а работать нормально все равно не получается - не проинсталлирован соответствующий софт. Либо доступ к нему просто закрыт :(. Особенно это касается всяких мерзких secure desktop'ов, столь любимых админами компьютерных клубов, которые замещают виндовый рабочий стол и убивают всеми любимую кнопочку «Пуск». Единственное, что в подобных системах оставляют юзерам, - это менюшка, открывающаяся по нажатию правой кнопки мыши. Ну и, естественно, в этом меню только и висит что ярлыки на всякие игрушки (или какой-нибудь MS VC++, если это институт) да несчастный браузер... Стоп! А вот с браузером они поспешили. Погорячились ;). Во-первых, имея под рукой браузер, можно найти в сети и скачать любую мыслимую и немыслимую прогу. Но обычно это не работает, так как в компьютерных клубах бродилки специальным образом кастрируются, чтоб никакие файлы не качались. А вот во-вторых, существует куча программ, с которыми можно работать прямо из браузера!

Удаленные приложения

Их не надо ни скачивать, ни инсталлировать - ничего. Просто нажимаешь ссылочку, и в окне браузера вырисовывается соответствующая программа. Часто интерфейс программы даже не отличается от стандартного виндового GUI - такие же заголовки окон, кнопочки закрыть/восстановить/свернуть, стандартные меню полосы прокрутки и так далее. Не верится? Глянь тут: http://www.runaware.com/. Это сайт конторы, которая предлагает поюзать в онлайне всякий софт, прежде чем покупать его в реале. Там тебе дадут даже с Corel Draw поработать, не говоря уж о серьезных офисных пакетах (текстовые процессоры, таблицы, презентации - все дела).

Но виндовый GUI - это не всегда клево (тяжеловесно все-таки для сети), поэтому многие онлайновые приложения обходятся без него, жертвуя удобством и красотой в пользу скорости и производительности. Кроме того, программа, разработчики которой заморочились написанием Win GUI-подобного интерфейса, вряд ли окажется бесплатной :(. А ведь нас интересует именно халявный удаленный софт! Поэтому некоторые из прог, которые мы сегодня поюзаем, будут обладать менее характерным для виндовых приложений интерфейсом.

Почта

Любой нормальный человек, регулярно работающий в сети, так же регулярно пользуется почтой. Сидеть в нете и при этом не иметь возможности проверить содержимое своего почтового ящика - пытка та еще. Не веришь на слово - проверь :). Еще хорошо, если у ящика есть веб-интерфейс - можно его проверить из браузера, а что делать, если почта доступна только через POP3?

Полноценный почтовый клиент находится по адресу http://www.wsmmail.com/. Просто замечательная тулза! Отсюда можно работать с любым POP3-ящиком. Достаточно вбить в форме адрес POP3-сервера, логин и пароль. Дальше все очень похоже на стандартный почтовый веб-интерфейс. Письма можно читать, на них можно отвечать, форвардить, удалять. Можно создавать и отсылать новые сообщения. Радует, что, залогинившись один раз, можно постоянно проверять наличие новых мессаг нажатием всего одной кнопки - «Refresh / Check for New Messages». Достаточно грамотно построена работа с аттачами. Если к пришедшему письму есть аттач, его можно сохранить на своем харде. Точно так же можно приаттачить любой локальный файл к новому сообщению.


Спецвыпуск Xakep, номер #015, стр. 015-026-2, Софт из браузера

Софт из браузера

n0ah (noah@real.xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-026-2

При желании можно посмотреть полный хедер любого письма. Еще одно достоинство этого веб-почтовика - он умеет общаться со своими пользователями на нескольких языках: английском, французском, немецком, итальянском, испанском и японском. Короче, wsmmail.com - вещь стоящая, но, к сожалению, не полностью безглючная :(. Во-первых, он коряво работает с нетшкафом - из-за проблем с явой не пашут кнопки «Forward», «Reply», «Delete» и прочие. Получается, что почту можно только читать. Во-вторых, возникают глюки, если пытаться юзать почтовик сразу из нескольких окон. Тут он честно предупреждает, что к такого рода отношениям еще не готов, и просит либо перелогиниться, либо закрыть все окна кроме одного. В-третьих, почтовик не дружит с кириллицей в сабже и в названиях приаттаченных файлов. Сабж он будет показывать нечитаемым, а аттач просто не даст сохранить. В-четвертых, по непонятным для меня причинам, поля «Sender» и «Date/Time» в пришедших письмах всегда остаются пустыми, хотя, если открыть хедер, там все видно. И, тем не менее, wsmmail.com заслуживает уважения - не каждому дано выполнять функции полноценного почтового клиента, работая через браузер :).

Аська

Еще одна прога, без которой в сети сидеть как-то неуютно. Ребята из Мирабилиса эту проблему предусмотрели и заботливо выложили веб-версию своего клиента. Сразу радует тот факт, что веб-ICQ ни по функциональности, ни внешним видом почти не отличается от своего более привычного аналога. Хоть и называется ICQ Lite ;).

После нажатия большой кнопки «Start ICQ Lite» по адресу http://www.icq.com/icqlite/ открывается длинное окошко вдоль правого края экрана - там, где обычно живет простая ася :).

Это и есть Web Based ICQ. Схавав введенные юин с паролем, аська грузится еще некоторое время, а потом предстает перед нами во всем своем великолепии. И сразу бросается в глаза очень приятная фича - контактный лист введенного юина автоматически импортируется с сервера в ICQ Lite. Клево, ничего не придется делать руками! Вообще веб-версия аськи радует простотой и соответствием тому, что буржуи называют «ready to use». Жить можно, даже если совсем не дотрагиваться до настроек, но мы все же по ним легонько прошвырнемся ;). Первое, что сделал я, - убрал галочку у «Groups» (показывать контакт-лист разбитым на группы) и поставил ее у «Online Only» (показывать только online-юзеров). Остальные настройки лежат в меню «Settings»: игнор лист, звук, принимать мессаги только от пользователей из листа, доступ к меню левой/правой кнопкой и прочие характерные для аськи настройки. Рядом с кнопкой «Settings» находится еще одна кнопка - «Find/Add Users». Искать юзеров можно как по юину и мылу, так и по деталям (ник, возраст, пол, интересы, etc).


Спецвыпуск Xakep, номер #015, стр. 015-026-3, Софт из браузера

Софт из браузера

n0ah (noah@real.xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-026-3

Теперь о багах, которых, кстати, не очень-то и много ;). Если браузить нетшкафом, не получится переключить раскладку на русскую в окнах ICQ Lite - приходится писать транслитом. Кроме того, у меня несколько раз намертво повис комп после дисконнектов, когда были открыты какие-то окна аськи.

Ирка

Поехали чатиться дальше ;)! Следующий пункт назначения - IRC. Для того чтобы попасть в далнет прямо из браузера, надо зайти по адресу http://www.dal.net, ввести там желаемый ник и жмякнуть «Go». Сразу же выскочит окошко IRC-клиента, и он начнет коннектиться к серверу irc.dal.net. Подождав еще минуту, можно смело вводить какое-нибудь «/join #xakep» и приступать к нашему основному занятию :).

Сам клиент прост до безобразия. Все настройки прячутся за кнопочкой «Config»: ник, канал, сервер, его порт и еще кое-какие настройки. Спрашивается, кому это надо, если все можно менять простым вводом команд? :) И напоследок добавлю, что проблем с русским языком у такого способа IRC`шного общения не наблюдается. Запускай и пользуй!

Текстовый редактор

Ок, поразвлекались и достаточно - теперь будем работать. А первый рабочий инструмент любого хацкера - текстовый редактор. Без него ни скрипта не напишешь, ни дефейсную html`ку не сбацаешь, ни телефончики девушек из чата не запишешь ;). Что же делать, если усердный админ хорошо постарался и вычистил с машины даже notepad.exe? Для таких случаев существует онлайновый текстовый редактор - http://www.pote.com. Довольно продвинутая тулза! Для того чтобы начать работать, необходимо зарегистрироваться. Процесс регистрации наиэлементарнейший - вводишь имя пользователя, вводишь мыло, и через секунду пароль падает в ящик. Теперь можно залогиниться и начать работу. Сразу же нам предлагают создать новый файл, открыть уже существующий, взглянуть на список своих файлов на сервере или закачать на сервер новый файл с винта (есть ограничение по размеру - 500 кб). Выбрав один из этих вариантов, мы попадаем непосредственно в текстовый редактор: поле для отображения текста и несколько кнопочек внизу.

Пройдемся по кнопочкам:

Save - Сохранить.

Save As - Сохранить в файл.

New - Создать новый файл.

Revert - Отменить последнее действие.

Replace - Найти и заменить.

Wrap Text - Упорядочить текст по ширине окна. Очень удобная фишка :).

Select All - Выделить весь текст. Непонятно, зачем эта кнопка, если есть сочетание клавиш Ctrl-A. Хотя, кто его знает - может pote.com будут юзать какие-нибудь пользователи Маков, у которых такой комбинации клавиш может и не быть.

Spellcheck - Проверка орфографии. Спеллчик, который очень грамотно работает с текстом: спеллит только англицкий, не трогая непонятные ему знаки :).

Display - Показать файл в окне браузера. Похоже на «Предварительный просмотр» ворда.

E-Mail - Отмылить набранный текст по почте. Причем отправлена мессага будет с того мыла, которое юзер вводил при регистрации ;).

Options - Настройки. Тут можно задать размер поля редактирования (число строк/столбцов).

Close - Закрыть файл.

Log Out - Выйти из редактора. Рекомендуется всегда так выходить из системы, так как если просто закрыть окно браузера, другие пользователи компа смогут потом читать твои файлы.


Спецвыпуск Xakep, номер #015, стр. 015-026-4, Софт из браузера

Софт из браузера

n0ah (noah@real.xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-026-4

Очень удобно, что файлы хранятся на сервере: поработал из клуба, сохранил, пришел домой - еще поработал, сохранил, а на следующий день открыл уже из офиса :).

Редактор изображений

Из всех удаленных прог сложнее всего представить себе графический редактор - тем более, не обладающий win GUI-интерфейсом. Такой зверь живет по адресу http://www.myimager.com.

Для работы регистрация не требуется :). Выбираем File -> New, чтоб создать новое изображение, или File -> Open, чтоб открыть уже существующее. Можно указать картинку со своего харда либо задать URL. Лимит по размеру 200 кб, принимаются только гифы (включая анимированные) и жпеги. После загрузки файла можно приступать к работе. Все действия выполняются из меню: File, Edit, Effects, Optimize, Help. Функций очень много, так что любое изображение можно видоизменить до неузнаваемости :).

Его можно крутить-вертеть, уменьшать и увеличивать, применять различные фильтры, добавлять текст. У каждой функции куча своих опций - короче, есть где заморочиться ;). Единственное, что плохо в myimager.com - обилие рекламы, включая попапы и прочий отстой :(.

ФТПшник

Мощный ftp-клиент доступен по адресу http://www.web2ftp.com/. Это, наверное, одна из самых лучших прог обзора - ну ничем по функциональности не уступает среднестатистическому фтпшнику. Просто рулезная софтина! При входе на сайт сразу видим две формы с полями server, username, password: одна из форм передает эти данные в открытом виде, а вторая шифрует по SSL - выбирай, что больше нравится.

Если все введено правильно, то открывается окошко, подтверждающее удачное окончание процесса аутентификации, и затем мы попадаем в основное окно программы. Слева отображается содержание ftp-сервера, а справа - компа пользователя. В левом краю в узкой полоске висят все файлы и дерево директорий. Файлы в списке можно сортировать по имени, типу, размеру и дате. Если выделить файл из этого списка, рядом отобразится информация о нем: размер, дата создания, атрибуты. Там же можно его переименовать, сменить атрибуты и даже править! Представляешь, по нажатию на «edit file» открывается окошко, в котором можно изменять содержимое файла прямо на сервере (есть также кнопка «new file», нажав на которую, можно создать новый файл)! И, естественно, любой файл можно скачать. Примечательно то, что предварительно его можно зазиповать (отметив галочкой соответствующий пункт)! Молодцы ребята, подумали об уменьшении трафика в сети :).

Перейдем к изучению правой половины нашего клиента. Тут находится меню, позволяющее закачивать файлы с винта на сервер. Одновременно можно заливать до пяти файлов. Учтена даже возможность пояснить: закачиваешь ты ASCII`шные или бинарные файлы! И чуть ниже - аплоад зипарей: указываешь на локальный зипованный файл, он закачивается на сервер и только потом распаковывается ;). Кстати, все эти фишки с архивацией и прочим происходят благодаря серверу web2ftp.com: он укачивает от тебя архив себе, у себя его открывает, а на фтп-сервер шлет уже обычный файл. То же самое с даунлоадом, только наоборот: тянет с фтп нормальный файл, архивирует его у себя и только потом шлет тебе. Мне вот эта идея экономии юзерского трафика очень нравится :).


Спецвыпуск Xakep, номер #015, стр. 015-026-5, Софт из браузера

Софт из браузера

n0ah (noah@real.xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-026-5

Телнет

К сожалению, большинство телнет-клиентов, работающих через браузер, способны коннектиться только к одному какому-нибудь серверу. Причины понятны: никто не хочет давать прямой доступ к telnet через свой хост - тогда все хацкеры будут этим телнетом пользоваться и все время что-то ломать ;). Вот и на http://noisey.oise.utoronto.ca/mooca/MudClient3.html висит симпатичненький телнет-клиент, который способен соединяться только с сервером своих хозяев (какой-то игровой MUD-сервак).

Хотя, я думаю, если поискать еще, можно найти и полноценный телнетовский клиент, работающий через браузер, - инет большой, и просто не может быть, чтоб такая прога где-нибудь да не висела :). Найдешь - напиши, вместе попользуемся!


Спецвыпуск Xakep, номер #015, стр. 015-030-1, Кибергеография, или дайте мне глобус Интернета

Кибергеография, или дайте мне глобус Интернета

Спецвыпуск Xakep, номер #015, стр. 015-030-1

Алекс Целых (editor@technews.ru)

Неведомая земля, terra incognita. Вспомни день, когда ты впервые неровно ступил на ее берег. Как бросился целовать незнакомый песок, придя в себя лишь с первыми лучами солнца. Позже, обнимая затекшие ноги, ты не раз встречал здесь ни на что не похожий рассвет. Ты бродил нехожеными тропами и бредил неизведанными уголками. Ты зарос и обрюзг, ломая голову над тайнами нового бытия. Ты отдавал ей лучшее время своей жизни и никогда не жалел об этом. О, этот дивный новый мир! WWW.

Сегодня в кибермирах обитает полмиллиарда человек - десятая часть населения Планеты. Однако до сих пор о Всемирной Паутине умалчивают на уроках географии. Государства с таким названием не сыскать ни на глобусе, ни на карте. Уж не потому ли так "нежно" косятся на нас, пользователей Интернета, серьезные дяденьки и тетеньки? Многие из них продолжают считать Сеть плодом воспаленного воображения - местом, которого нет. Развеять этот гнусный миф взялись ученые-исследователи Интернета. Они представляют Паутину в наглядном географическом разрезе: рисуют карты, наносят на них виртуальные материки и океаны.

38 попугаев

Первым делом ученые справедливо задались вопросом: "В каких единицах производить измерения?". Традиционные мили, версты, километры отпали на раз. Ну не в попугаях же из любимого мультика мерить и не в количестве выкуренных трубок, как это принято у индейцев! В конце концов, разве что самый ленивый не выдвинул собственной концепции измерения расстояний в Сети.

Например, профессор Горей Кай из Пенсильвании утверждает, что расстояния в Интернете измеряются пропускной способностью каналов: "Разница в скорости подключения рождает чувство удаленности - чем медленнее соединение, тем дольше процесс получения информации и тем сильнее ощущение того, что запрашиваемый ресурс находится далеко". По этой теории для интимной близости с подругой достаточно пробросить до ее тачки оптоволокно, а зануду-сестренку можно "сослать в Сибирь", соединив компьютеры медным телеграфным проводом. Машины, не имеющие выхода в Интернет, - вовсе не из нашей Галактики, их даже в расчет не берут.

Ученые из Университета Нотр-Дам во Франции полагают, что лучшая линейка для Сети - мышиные клики. С одного сайта на другой можно попасть, сделав ограниченное число переходов по ссылкам. Чем больше кликов, тем больше расстояние между страницами. В подтверждение своей идеи французы провели целый научный эксперимент. Программный робот-агент собирал ссылки на первой случайной странице, по очереди посещал их, опять собирал ссылки и снова отправлялся в путешествие - таким необычным образом всего за 19 кликов он непременно попадал туда, куда было изначально намечено. Как говорится, куда ни ткни, везде оно!

Группа ученых компании Bell Labs под руководством Билла Чесвика, не долго думая, ввела свои единицы измерения - страшные и ужасные пукисы. В основу этой методики положена оценка скорости прохождения сетевых пакетов от одного компьютера с уникальным IP-адресом до другого. Замеры производятся раз в месяц, вся процедура занимает около 20 часов. Программа рассылает небольшие UDP-пакеты по случайным IP-адресам, слегка варьируя время жизни запросов (time-to-live). На каждом новом отрезке пути жизненные силы пакета постепенно угасают. Как только это значение достигает нулевой отметки, на сервер возвращается заключение о смерти пациента с подробным некрологом. По нему ученые судят о разветвленности того или иного сегмента глобальной Сети. Практическим путем было вычислено, что диаметр современного Интернета - 10 тысяч пукисов.


Спецвыпуск Xakep, номер #015, стр. 015-030-2, Кибергеография, или дайте мне глобус Интернета

Кибергеография, или дайте мне глобус Интернета

Спецвыпуск Xakep, номер #015, стр. 015-030-2

Атлас киберпространства

Получив в распоряжение золотой эталон длины, можно приступать непосредственно к съемкам местности и составлению карт. Процесс это творческий, и подходов к нему существует множество. Самая полная коллекция карт Интернета представлена в "Атласе киберпространства" по адресу www.cybergeography.org/atlas/. Здесь их целое море - на вкус и цвет. Одна напоминает сложную химическую молекулу или сетку кровеносных сосудов биологического органа. Другая - разноцветный фейерверк интернет-маршрутов в любую точку света. Карта экспериментального участка сети с IPv6 в Великобритании и карта почившей в бозе Гнутеллы. Карта миграции пользователей с сайта на сайт и карта интернет-погоды со всплесками активности посетителей. Карты частных интернет-владений и Паутины в целом. В общем, десятки и сотни оригинальных карт.

Все без исключения экспонаты коллекции любопытны по своей форме и содержанию. А некоторые ну так и просятся в рамку над столом. Потому-то Билл Чесвик продает постеры с картой Интернета (www.cs.bell-labs.com/who/ches/map/) по 30 долларов за штуку. Кликабельная электронная карта с выходом на базу данных и возможностью поиска, говорят, тоже неплохих денег стоит. Укрупненную топографическую съемку Сети производят по индивидуальным заказам крупных интернет-провайдеров, а также владельцев гигантских сайтов-империй. Как видишь, если представленные на карте сведения имеют коммерческую ценность, в свободном доступе ее однозначно не найти.

Для создания некоторых карт используется такое серьезное железо, как станция Sun Ultra 60 с видюхой Elite 3D и 512 Мб RAM. Обсчет данных о сотнях тысяч узлов занимает несколько дней, но результат превосходит все ожидания. Эффектная коллекция трехмерных изображений Интернета находится на сайте Caida (www.caida.org/tools/visualization/walrus/). Виртуальная абстракция еще утрет нос Дали.

Отдельного упоминания заслуживают галереи нет-арта и фантастических представлений о Паутине. Рекомендую скачать короткометражный фильм "Рыцари Сети", повествующий о напряженной внутренней работе Интернета с позиции отдельных пакетов информации. Весит эта цаца 96 метров, но удовольствие колоссальное. Какие, однако, расстояния приходится преодолевать этим маленьким труженикам, доставляя тебе очередную порцию жесткого порно! Здесь также представлены любопытные скрины из фильмов "Трон", "Джонни Мнемоник", "Хакеры", "Матрица" - альтернативный взгляд на строение и географию Сети. Наконец, ты найдешь в Кибератласе карты виртуальных миров Ultima, AlphaWorld и EverQuest. MUDы сегодня на пике популярности - сказочные города и страны растут как на дрожжах.


Спецвыпуск Xakep, номер #015, стр. 015-030-3, Кибергеография, или дайте мне глобус Интернета

Кибергеография, или дайте мне глобус Интернета

Спецвыпуск Xakep, номер #015, стр. 015-030-3

Сам себе Колумб

В домашних условиях изучать географию Интернета лучше всего при помощи визуальных трейсеров, графических аналогов tracert. Эти программы не просто трассируют путь до интересующего компьютера, но еще и привязывает его к реальным географическим координатам с точностью до страны и города. Твоему вниманию - самые яркие представители данного класса программ.

NeoTrace Pro v. 3.25 (1,607 Кб)

http://www.neoworx.com/download/

Сочетает высокую скорость работы и чрезвычайно удобный интерфейс. Степень детализации удовлетворительная. Похвально, что обращается к базе данных географических пунктов в Интернете, но за редкими исключениями флажки накалывает неверно. Зато дает исчерпывающую информацию по всем перевалочным пунктам. А за дополнительную плату предлагает фотографию сервера Мелкомягких с гражданского спутника. Поддерживает огромное количество настроек, вплоть до выбора цветовой гаммы (мой глаз порадовался схеме "кибер"). Предлагает широкие возможности экспорта карт в файлы и на веб. Прорабатывая координаты жертвы, радостно покрякивает, чем приводит окружающих в восторг. Кстати, ты не раз мог наблюдать NeoTrace в действии по телику в фильмах-армаггедонах и выпусках новостей. Полная коммерческая версия программы находится в пользовании ФБР, Интерпола и НАТО. Именно с ее помощью пасут спаммеров, педофилов - всех тех, кто нарушает закон.

VisualRoute v. 6.0b (1,192 Кб)

http://www.visualware.com/download/

Весьма динамичный и глубокий трейсер. Из неординарных опций - возможность работы в качестве сервера, выдавая результаты трассировки в браузер. При внешних сношениях через файрволл - вещь незаменимая. Демонстрационные сервера VisualRoute открыты даже в Пекине, Гонконге и на Тайване. А вот дряхленький интерфейс Java-машины - на любителя. Впрочем, это позволяет программе работать на любой платформе, под Linux и FreeBSD. Карта малоинтерактивна и некликабельна.

GeoBoy v. 1.4.7 (6,281 Кб)

http://www.ndgsoftware.com/

Раскоряченный экземпляр с нездоровым упором на графику. Маршрут пакета ложится на трехмерный глобус с городами и реками. Все это добро к тому же вращается - разве что песенку Санта-Клауса при этом не горланит. Без ляпсусов, конечно, не обошлось. Не продумана возможность задавать положение тачки вручную. Если провайдер не озаботился прописыванием информации о географии твоей машины, начинать отсчет будет просто неоткуда.

GTrace v. 1.0.0 (4,549 Кб)

http://www.caida.org/tools/visualization/gtrace/installing/

Простенький визуальный трейсер под Linux и FreeBSD. Бесстрашно оперирует географическими длинами и широтами, поэтому вспоминай, как работает компас. Карты и базы данных позаимствованы из VisualRoute. Любопытен тем, что если точное географическое положение машины неизвестно, пытается угадать его с определенной степенью доверия.

Заключение

Всемирная Паутина - сложная самоорганизующаяся структура. В ней легко попасть в пробку, сбиться с пути, заблудиться. Чтобы этого не произошло, учи географию Интернета. Ну, хотя бы запомни свой IP-адрес!


Спецвыпуск Xakep, номер #015, стр. 015-038-1, Занимаемся промоушеном - раскручиваем свой сайт

Занимаемся промоушеном - раскручиваем свой сайт

Спецвыпуск Xakep, номер #015, стр. 015-038-1

Андрей Каролик (andrusha@sl.ru; http://www.dal.net.ru)

Что бы ты ни пытался рекламировать - свою личную страничку или коммерческий сайт, - принципы раскрутки все равно будут одинаковыми. Не зная этих основ, ты не сможешь привлечь внимание к своей страничке, сколько бы ты времени и сил ни потратил. Скорее станешь слепым импотентом перед своим монитором и наживешь себе геморрой :). Цель этой статьи - уменьшить количество слепых импотентов с геморроем и научить тебя, как правильно раскручивать свой сайт в Интернете.

Для затравки немного о самом сайте. Делая сайт, учти, что его будут потом смотреть обычные живые люди. Следовательно, в первую очередь обмозгуй дизайн и навигацию. Дизайн должен быть привлекательным и не вызывать тошнотворных позывов у посетителей твоей паги. Не покатит и гиперкрасивый сайт, который грузится более одной минуты. За это время можно себе и яйца отсидеть :). А навигацию нужно делать по максимуму простой и удобной. В идеале с помощью навигации юзер должен попадать в любой уголок твоей навороченной странички не более чем за 3 клика. Если сайт достаточно обширный - сделай в обязательном порядке карту сайта, откуда можно будет попасть в любое место всего за один клик. В принципе рекламировать можно любую страницу :). Просто удержать высокий уровень посещений на кривом сайте довольно сложно, так как никто не будет на него возвращаться. Но сперва нужно еще кого-то привлечь...

Мета-тэги

Прежде чем выставлять свои прибамбасы в Интернет и регистрировать их в поисковых серверах, не забудь добавить ключевые слова и краткое описание своей странички. Делается это с помощью несложных мета-тэгов, которые добавляются в общий html-код паги. По указанным ключевым словам поисковые сервера проиндексируют твой сайт. Для чего это нужно? В дальнейшем твой сайт будет попадать в список найденных ресурсов, если кто-нибудь будет искать информацию на поисковом сервере по одному из этих ключевых слов. Описание ресурса будет показываться вместе с ссылкой на твой сайт. Для определения ключевых слов используй следующий мета-тэг: <meta name="keywords" content="ежики, дятлы, бурундучки, ...">

Можно использовать не только слова, но и словосочетания. И, если искать будут именно по словосочетанию, твоя страничка будет располагаться в списке найденных ресурсов выше тех, которые описали по отдельности оба слова, входящие в словосочетание. Количество ключевых слов полностью зависит от возможностей конкретной поисковой системы, которая будет индексировать твой сайт. Обычно требуется, чтобы все ключевые слова составили не более 200-300 символов, в противном случае превышение просто обрезается. Всегда указывай составные ключевые слова из более простых, если это возможно. Простой пример: слово кошка на английском языке - cat, множественное число - cats. Если ты напишешь во множественном числе, то твою пагу найдут и по слову cat, и по слову cats. Если же ты напишешь в ключевых словах только cat, то поиски по cats пройдут мимо тебя :). Для определения описания своей странички добавь еще один мета-тэг:


Спецвыпуск Xakep, номер #015, стр. 015-038-2, Занимаемся промоушеном - раскручиваем свой сайт

Занимаемся промоушеном - раскручиваем свой сайт

Спецвыпуск Xakep, номер #015, стр. 015-038-2

<meta name="description" content="О братьях наших меньших".>

Длина описания опять же зависит от возможностей конкретных поисковых систем, поэтому постарайся уложиться в 150-200 символов. Тогда наверняка обойдется без обрезания :). Не забудь, что оба мета-тэга нужно разместить между тэгами <head> и </head>.

Поисковые сервера

Поисковые сервера можно условно разделить на поисковые системы и на каталоги. В поисковых системах ты можешь даже не регистрировать свой сайт, рано или поздно он все равно туда попадет. На них живет специальная программа, которая называется паук (spider). Она в автоматическом режиме посещает произвольные страницы и переходит по ссылкам, которые попадаются на этих страницах. Индексация может быть на разную глубину (количество вложенных ссылок) и зависит от настроек паукообразного. Паучок потом возвращается через определенный промежуток времени (например, через неделю) и индексирует изменения, если ты их успел наваять. В разных поисковых системах есть разные пауки, поэтому результаты поиска по одному и тому же слову могут сильно отличаться. Пример поисковой системы - www.altavista.com.

В каталог информацию о сайте нужно добавлять уже самому, сама она там не появится. Для регистрации обычно нужно заполнить форму, которая отсылается в виде заявки с указанием: в какой раздел ты хочешь добавить свой сайт, какие ключевые слова использовать для поиска, какое краткое описание присобачить твоему сайту. После проверки присланной информации и сайта модератором тебе могут вообще отказать в регистрации, если сайт не пройдет цензуру или просто не понравится (модератор имеет полное право на это), добавить или добавить, но в другой раздел, или с немного измененными введенными тобою данными. Пример каталога - www.yahoo.com.

В последнее время появляются еще и гибриды, которые могут искать новые сайты в автоматическом режиме прикормленными паучками, имея при этом еще и модерируемый каталог, в который сайты добавляются простыми смертными. Разные люди - разные вкусы. Кто-то ищет в Rambler-е, кто-то в Yahoo. Поэтому для повышения эффективности регистрироваться нужно на всех возможных и известных человечеству поисковых серверах. Чтобы тебе упростить жизнь, назову адреса наиболее популярных серверов-регистраторов, которые помогут тебе зарегистрироваться одновременно в нескольких поисковых серверах:

Submit It! - http://free.submit-it.com

Add Me! - www.addme.com

Sputnik ADDER - www.sharat.co.il/adder

@Submit! - www.uswebsites.com/submit

Web Site Submission - www.smithfam.com/submission.html

ABS Easy Submit - www.scrubtheweb.com/abs/submit/index.html

TAU - www.design.ru/free/addurl

JS - www.js.ru/poisk/submit.htm

Но лично мой совет - не доверяться полностью подобным серверам-регистраторам и делать все ручками. Достаточно регистрировать только главную страницу; робот поисковой системы сам обойдет весь сайт. Но если уровень вложенности у тебя больше четырех (то есть нужно сделать более 4-х кликов, чтобы куда-то добраться), то эти далекие разделы нужно регистрировать дополнительно. Вот тебе наиболее полный список популярных забугровых и рунетных поисковых систем и каталогов:


Спецвыпуск Xakep, номер #015, стр. 015-038-3, Занимаемся промоушеном - раскручиваем свой сайт

Занимаемся промоушеном - раскручиваем свой сайт

Спецвыпуск Xakep, номер #015, стр. 015-038-3

Поисковые системы:

Rambler - www.rambler.ru

Яndex - http://yandex.ru

Апорт! - www.aport.ru

TELA - ПОИСК - http://tela.dux.ru

Alta Vista - www.altavista.com

Excite - www.excite.com

Hot Bot - www.hotbot.com

Go / InfoSeek - www.go.com

Northern Light - www.northernlight.com

WebCrawler - www.webcrawler.com

Ask Jeeves - www.askjeeves.com

Direct Hit - www.directhit.com

FAST Search - www.alltheweb.com

GoTo - www.goto.com

Google - www.google.com

Inktomi - www.inktomi.com

Каталоги:

"@Rus" - www.atrus.ru

List.Ru - www.list.ru

Russia on the Net - www.ru

Интернет Столица - www.data.ru

Up.ru - www.up.ru

Улитка - www.ulitka.ru

The List of Russian Web Servers - http://weblist.ru

Иван Сусанин - www.susanin.net

Пингвин - www.pingwin.ru

SEARCH CENTRE - http://search.centre.ru/cgi-bin/search

Yahoo! - www.yahoo.com

Lycos - www.lycos.com

LookSmart - http://looksmart.com

Snap - www.snap.com

Open Directory - http://dmoz.org

iWon - www.iwon.com

MSN Search - http://search.msn.com

Netscape Search - http://search.netscape.com

Некоторые поисковые сервера позволяют совершенно бесплатно использовать свои счетчики. Это очень удобно для учета количества посетителей и оценки твоих рекламных маневров. Кроме учета количества заходов в день, обычно есть еще и рейтинг, в который попадают наиболее посещаемые сайты. Но на первых порах тебе это не грозит :).

Баннерообменные сети

Баннерные сети позволяют взаимораскручивать сайты, зарегистрированные в них. Механизм довольно прост. Любой сайт, показав на своих страницах определенное количество баннеров системы, получает пропорционально этому некоторое число показов своего баннера на других сайтах. Сама система живет за счет удержания какого-то процента показов участников (комиссии), обычно в пределах от 10 до 50%. Эти проценты продаются рекламодателям. Главное, что в результате ты не платишь ничего :). Заманчиво, но при малом количестве посещений на твою пагу эффективность всей затеи стремится к нулю. Наибольший интерес к баннерным сетям проявляют развлекательные и новостные сайты, количество посещений которых в день упирается в потолок. Но, если на твоем сайте посещений 500 и более, смело регистрируйся в баннерной сети. Чтобы ты не метался, вот тебе список наиболее популярных в рунете:

Reklama.Ru - www.reklama.ru

InterReklama - www.interreklama.ru

Russian Link Exchange (RLE) - www.rle.ru

TheBannerNetwork - www.tbn.ru

RB1 - www.rb1.design.ru

RB2 - www.rb2.design.ru

Текстовая обменная сеть tx3 - http://tx3.design.ru

Banner.RU - www.banner.ru

The Land Banner Network (LBN) - www.land.ru

List Banner Exchange (LBE) - www.lbe.ru

Click Exchange System (CES) - http://click.ipc.ru

Hit Exchange - www.hitexchange.ru

Sitek Banner Exchange (SBE) - www.banners.ru

ОтКлик - www.kudesniki.ru/otclick

К тому же некоторые баннерные сети предлагают даже выкупать накопленные показы у сайтов участников. Но цена за показы желает лучшего, а дополнительные условия отсеивают многих желающих. В качестве условий обычно ставят определенный уровень показов на сайте в день, определенную тематику сайта, определенное расположение баннера на странице и тому подобное. И опять же игра не стоит свеч, если у тебя мало посещений.


Спецвыпуск Xakep, номер #015, стр. 015-038-4, Занимаемся промоушеном - раскручиваем свой сайт

Занимаемся промоушеном - раскручиваем свой сайт

Спецвыпуск Xakep, номер #015, стр. 015-038-4

Обмен кнопками и ссылками

Что же делать, если до баннерной системы твоя пага еще не доросла? Можно целенаправленно искать ресурсы схожей тематики для обмена кнопками или ссылками. Например, когда я ищу определенную информацию и смотрю ее на одном из найденных сайтов, я всегда просматриваю ссылки с этого места на ресурсы по той же теме. Просто мне порой быстрее перейти по указанным ссылкам, чем искать на поисковом сервере. Кнопки больше по размеру (вес файло), но зато их можно сделать анимированными, более заметными и привлекательными. Только не увлекайся, а то получится новогодняя елка, а не сайт. Когда твоя аудитория начнет расти, удаляй кнопки, с которых меньше всего переходов, и ищи новые потенциальные сайты для обмена. Придется попыхтеть, чтобы найти хорошие варианты обмена, но кто сказал, что будет легко :).

Другие виды рекламы

Рекламировать можно и там, где это не предусмотрено. Тут масса вариантов: рассылки, конференции, гостевые книги, форумы, ирк-сети, веб-чаты и так далее. Муторная работа, пожирает кучу времени, но при умелых вариациях приносит хорошие плоды. Ищи в первую очередь конференции и форумы по теме. Тогда ты сможешь отловить целевую аудиторию, а не просто зевак, которые из-за любопытства пойдут посмотреть, что там такое. Но в основном реклама в подобных местах построена на обмане, работает только на счетчик, а не на постоянных посетителей. Простой пример: находишь сайт знакомств, добавляешь анкету с грудастой блондинкой, а остальные ее фотографии по-пионерски обещаешь на своем сайте. Поверь мне, лошков на этом свете столько, что твой счетчик заклинит :).

P.S. Так что - читай, дерзай, не будь импотентом!


Спецвыпуск Xakep, номер #015, стр. 015-040-1, Сайт с доставкой на дом: тестируем оффлайн-броузеры

Сайт с доставкой на дом: тестируем оффлайн-броузеры

Спецвыпуск Xakep, номер #015, стр. 015-040-1

Андрей Михайлюк ака Dronich (dronich@xakep.ru)

Зима... Скучно. За окном метель, в универе каникулы, денег на Инет, как всегда, нет... Наверно, и загнил бы тут совсем, если бы загодя о себе не позаботился. В золотые времена ночного анлима я слил себе на винт тучу всякой инфы, тратить на которую драгоценное время онлайн не всегда хочется. Поэтому я спокойно отхлебываю из кружки горячий кофе и листаю очередной информационный сайт. И помогли мне в этом проги из обзора, который ты начал читать.

Ты еще не понял, для чего нужны оффлайн-броузеры? Ну-ну... Объясняю. Салон просторный, кузов с оцинковкой, цена - во! Понимаешь???? Так, что-то не то... Блин, опять баннеров интерактивных по ящику насмотрелся ;). Короче, их главная миссия - слить тебе сайт с сохранением его структуры так, чтобы ты мог спокойно наблюдать его в оффлайне. Причем качают обычно несколькими потоками - быстроты ради. Фишка полезная, актуальная, но только для dialup'щиков. Хотя знавал я одного чела из Строгинской сетки, который за каждый лишний байт был готов удавиться, выйти в онлайн ему просто западло. Поэтому слитые сайты ему таскал я на дискетках. Если ты из таких - то тоже можешь почитать. И сразу к психиатру, тут рядом ;).

Поехали

Опросив друзей, знакомых, проглядев все топы софта и собственный винт, я отобрал пять прог, которые мы сегодня посмотрим и потестим. В качестве теста заставим их скачать по три сайта: на классическом ХТМЛ, но на отстойном хостинге (моя пага ;)); на ASP'овых скриптах со сложной структурой и, наконец, на PHP. Как известно, это три знаменитых спотыкача для оффлайн-броузеров, именно на таких сайтах можно разжиться недокачанными пагами, белибердой в скачанной версии и просто отказом работать. Вот и проверим. Встречайте первого счастливчика.

Offline Explorer 1.9.548

ShareWare

Весит: 695 Kb

Сливаем: http://www.metaproducts.com

Скажу сразу - все общение с этой прогой состояло из одних сюрпризов - как приятных, так и не очень. О них-то я тебе и поведаю.

Мастер, сработавший при запуске проги, порадовал своей аскетичностью. Все его пять шагов можно с уверенностью запихать в одно окно, и оно не было бы перегружено. Ну да ладно. Главное, что на последнем шаге притаилась галочка "Advanced Settings". Вот уж сюрприз так сюрприз! Прокси, тайм-ауты, протоколы... Сделано все в новомодном стиле - с деревцом слева, поэтому кастомайзить очень удобно. Как опытный сливщик (сливатель?), скажу тебе, что реальная подгонка параметров под конкретный сервак - это уже полдела. А Offline Explorer позволяет сделать это с высокой точностью. Так же удобно настраиваются типы файлов для скачивания. Да и в работе софтина не спасовала - все три сайта были слиты без ошибок. Но новый сюрприз - дефолтовые настройки подойдут не всем. Мне, например, было не очень приятно наблюдать весь LinkExchange на винте - прога по умолчанию качает картинки с других сайтов. А чтобы все поменять, пришлось стопить проект - а это не есть гуд.

Интерфейс, кстати, весьма симпотный, но в большей своей части бесполезный. Слишком много дублирующих функций, просмотр страниц занимает пол-экрана, а реально полезная статистика раскидана по закладкам, смотреть которые можно только по одной. Может, кому-то это и понравится, но у меня другие представления об удобстве.


Спецвыпуск Xakep, номер #015, стр. 015-040-2, Сайт с доставкой на дом: тестируем оффлайн-броузеры

Сайт с доставкой на дом: тестируем оффлайн-броузеры

Спецвыпуск Xakep, номер #015, стр. 015-040-2

Вердикт: мощная и умная прога, подходит для монументальных сливов (типа весь Яндекс себе скачать) с соответствующей подготовкой.

TeleportPro 1.29

ShareWare

Весит: 842 Kb

Сливаем: http://www.tenmax.com

Довольно старая прожка, не потерявшая своей актуальности. В наличии спартанский, но удобный интерфейс, мастер нового проекта (единственный неотключенный мастер у меня на компе, потому как реальный, а не фуфловый) и главное - скорость работы. Teleport использует траффик по максимуму, а другим почти не мешает. Как? Скажу честно - не знаю, но факт остается фактом.

В Teleport'е ты не найдешь просмотрщика ХТМЛ-страниц, и, ИМХО, это правильно. Куда приятнее смотреть паги любимой оперой (или осликом - каждому свое). Планировщик в отличие от Offline Explorer'а не встроенный, а отдельный. То есть сначала создаешь проект в основной проге, а затем открываешь его в планировщике и назначаешь время. Мне так нравится больше - планировщик весит мало, значит, не жрет ресурсы, пока висит в фоне без работы.

Есть у этой проги и минусы. Во-первых, нет тонкой настройки типов и размера получаемых файлов. Во-вторых, все слитые файлы лежат одной огромной кучей, а не раскиданы по каталогам (по дефолту). И в-третьих - Teleport завалил тест на PHP-паги (видимо, из-за своего возраста). Вот так.

Вердикт: рабочая лошадка (ослик, бобер, гонобобель, етс.) для повседневного использования без особого геморроя.

DISCo Качалка 3.1

ShareWare

Весит: 1162 Kb

Сливаем: http://www.disco.ru

Наша российская разработка. Наиболее упорно просит денег за свое использование, хотя давать их по большому счету не за что. На настройки скупа, интерфейс отвратный, на нестабильном хостинге и сайте с PHP удачно лажанулась. И при этом она в полтора (!) раза больше Offline Explorer'а. Понравились только возможность скачивания сайта в определенной кодировке (если их несколько) и... системные сообщения. Кто-то очень мудрый их придумывал: "Отдыхаем", "Качаем", "Миссия выполнена" - шик. А так - позор на голову российских программистов. Могу рекомендовать только начинающим, но им и оффлайн-броузер вроде ни к чему, с обычным бы управиться ;). Тем более, что мастера нового проекта тоже нет, создавать его надо вручную.

Вердикт: черт его знает... поглядеть если только...

Website ExTractor 7.11

FreeWare, но...

Весит: 407 Kb

Сливаем: http://www.esalesbiz.com

Не очень известная прога, но тем не менее способная конкурировать с монстрами, захватившими винты юзеров. Первое впечатление - ужасное. Интерфейс какой-то аляповатый, настроек непонятных туча - меня наповал сразила опция "Download Files", притаившаяся в уголке окна (как выяснилось, если галку снять, прога просто составит карту сайта в своем формате). Но в работе БывшийТрактор ;) уделал всех. Со скоростью Teleport'а и качеством Offline Explorer'а он прокачал все три сайта без единой ошибки. Но только мне пришлось перед этим сильно возиться с опциями. Где-то я вспомнил Консиловский файрвол - что не прописано ручками, то не делается. Удивляет, как еще список типов файлов разработчики оставили, а то и его бы снести к едрене фене и назвать все это "суперпрофессиональным продуктом" ;).


Спецвыпуск Xakep, номер #015, стр. 015-040-3, Сайт с доставкой на дом: тестируем оффлайн-броузеры

Сайт с доставкой на дом: тестируем оффлайн-броузеры

Спецвыпуск Xakep, номер #015, стр. 015-040-3

Мастера очень не хватает, без него очень много времени уходит впустую. Планировщика тоже нет, все в традициях планеты Шелезяка. В принципе ExTractor мог бы заменить и Teleport, и Offline Explorer, если был бы более продуман. Хотя куда дальше - почти восьмая версия (что ж тогда было в первых??? ;)).

Ах да, с версиями тоже сложная ситуевина. Есть халявная русская и платная аглицкая версии. Но первую скачать с их хомпаги не удается. Нашел я ее на левом серваке, чего и тебе желаю - русский фейс поприятнее будет, тем более он не переводной, а изначальный ;).

Вердикт: неплохо, но малость недоделано; с претензией на профессиональность.

WWW Jet Triton 9.0

ShareWare

1421 Kb

Сливаем: http://www.hantay.ru

Довольно странная программа - весь интерфейс с настройками умещается менее чем на четверти экрана. И при этом не могу сказать, что она обделена функциями - только мастера и планировщика не хватает для полного счастья. Вообще Тритон штука мудреная - без бутылки не разберешься, однозначно. А все из-за нестандартности междумордия. Структура тоже особая - даунлоадер отдельно, просмотрщик отдельно. И последний, ИМХО, вряд ли кому-то нужный, кушает больше половины места в дистрибутиве. Непорядок.

Кустарность чувствуется везде - от справки с очепятками до ифейса (см. скрины). Неудивительно - Тритона разрабатывает один человек, да еще с большими амбициями (на версию посмотри ;)). И позиционирование несколько другое - прога, работающая в фоне и качающая, только когда хозяин :) в онлайне. Об автономности можно забыть.

В работе меня ждал преприятнейший сюрприз - Тритон вылетел на первой же минуте с окошком "Type mismatch". Так что тестирование я проводил на чужой машине. А не заработала она на моих 98-х и соседском Миллениуме. Только под 2000-ми запахала и прошла все тесты. Но осадок-то остался... Такую нестабильность можно простить стокилобайтной фриварке, но шароваре в полтора мега - простите. Единственное, радует - автор утешил, что в ближайшей версии (наверно, 12-ой или 13-ой ;)) эта проблема будет улажена. Посмотрим.

Вердикт: для экспериментаторов и любителей оригинальности... и неизвестности...

Итоги (без Евгения Киселева ;)):

Мнение спец-крю таково: Offline Explorer хорошо оставлять на ночь c большим заданием, Teleport - оперативно использовать в онлайне (кусок сайта быстро выкачать), ExTractor можно юзать и там и там, но разделавшись хотя бы с дефолтными настройками. Все остальное к применению не рекомендуется.

Надеюсь, ты уже определился, что нужно именно тебе? Так чего ж сидишь? Вперед, в Инет, качать, качать и еще раз качать! А я остаюсь, буду пить свой кофе и листать очередной информационный сайт... Зима все-таки...


Спецвыпуск Xakep, номер #015, стр. 015-042-1, Грузите апельсины бочками: особенности национального download'а

Грузите апельсины бочками: особенности национального download'а

Спецвыпуск Xakep, номер #015, стр. 015-042-1

Андрей Михайлюк ака Dronich (dronich@xakep.ru)

Дарова тебе, хацкер! Я думаю, ты понял, что говорить мы будем о download-менеджерах. Или, по-нашему, о качалках. Ведь времена дремучих ламеров, качающих МР3шки Експлореровским "Save as", давно прошли. Без манагера закачек теперь не обходится ни один грамотный чел - вопрос только в том, какую выбрать. А выбор нынче богатый. Итак, боец, встречай участников тестирования - четверка лидеров забугорья и заснеженной России.

Посмотрим поближе

В эксклюзивном СПЕЦ-тестировании участвуют: FlashGet v0.95, GetRight v4.5, ReGet Deluxe v2.1 и Download Accelerator Plus v5.0. Все они, несмотря на одинаковую цель (залить файло тебе на винт как можно быстрее), имеют разные наборы функций. Так что каждый может выбрать себе даунлодер по вкусу, средствам (ээээ... ну, вдруг ты не знаешь, что такое асталависта) и назначению. Итак, приступим.

FlashGet

Вес: 1,3 Мб

Урл: www.amazesoft.com

Довольно молодой даунлодер, родившийся во времена спора Гетрайта с Го!Зиллой (эх, где мои 17 лет? :)) и известный тогда под именем ДжетКара. В последнее время его популярность только растет, хотя версия FlashGet'а еще не вылезла в заветную единичку.

Что же предлагают нам разработчики? Во-первых, новомодную фишку - загрузку по частям (до 10 штук на файл). Если dialup'щиков не изведут в ближайшее время LAN'овщики (я на своей шаговой АТС буду этому только рад :)), то такая загрузка станет всеобщим стандартом - в большинстве случаев она реально ускоряет томительный процесс ожидания циферки 100 в графе "%" :). Во-вторых - организацию закачанных файлов по типу. Хотя реализована она не очень - группу (МР3, софт, дрова etc.) надо выбирать самому в начале закачки. Равно как и число частей. В общем, ручками приходится поработать достаточно, но тебе ведь не привыкать :). Зато в награду ты получишь самую удобную статистику - тут тебе и лог каждого потока, и карта закачки (рулез!), короче, полный контроль над файлом, который сливаешь. Можно переразбить его на большее/меньшее число частей, добавить зеркало (правда, только вручную). Имеется и расписание работы, и ограничение скорости, и импорт недокачанных другими файлов, и график скорости соединения - все в лучших традициях даунлодеров.

Количество настроек тебя тоже не разочарует. Кстати, это качалка с наиболее настраиваемым интерфейсом. Нет, я не про скины. Ты, например, можешь сказать проге, что делать, если ты даблкликнешь по загруженному / приостановленному / неудачному файлу. Есть еще фишка, назначение которой представляется мне очень смутно. Название ей - корзина. Это квадрат 32Х32 пикселя, болтающийся поверх всех окон и содержащий в себе график траффика :). Вообще-то на него положено таскать ссылки на файлы для загрузки, но кому это надо, если FlashGet намертво интегрируется и с ИЕ, и с Нетскапой, и с Оперой. Причем с ИЕ еще и двумя способами (цитата из FAQ: "Q: В IE5.5 не работает перехват щелчка; A: Метод 1 не работает с IE5.5? Очень хорошо. Переключитесь, пожалуйста на метод 2" :). Задавим баги мелкомягких количеством :)). Так что ценность корзины только в графике, а его лучше показывает DUmeter (смотри у Эша на www.xknows.com). Что? Качать лень? Тогда зачем ты вообще эту статью читаешь 8)?


Спецвыпуск Xakep, номер #015, стр. 015-042-2, Грузите апельсины бочками: особенности национального download'а

Грузите апельсины бочками: особенности национального download'а

Спецвыпуск Xakep, номер #015, стр. 015-042-2

Что еще вспомнить из плюсов? Удобное контекстное меню без ветвлений, да и висят там реально самые часто используемые функции. Понятные (хотя не самые стильные) значки, говорящие о состоянии закачки. Приятный оборзеватель :) сайта с грамотной фильтрацией показываемых файлов. В целом - достаточно профессиональный продукт, не обремененный лишними функциями.

GetRight

Вес: 2,06 Мб

Урл: www.getright.com

Мой первый даунлодер :). Много воды утекло с тех пор, версия подросла на 2 с половиной пункта, добавились новые фишки. Посмотрим.

В последние годы GetRight развивался очень грамотно - добавляли в него только полезные и нужные фичи. Вдобавок к имевшимся на борту расписанию (ака scheduler), обзору сайта и звонилке появились менеджер принятых файлов и закачка по частям. Менеджер - без вопросов лучший в своем роде. К примеру, сливаемая MP3шка будет присутствовать и в группе "MP3" (по месту расположения файла), и в группе "Текущие загрузки" (по статусу), и в группе "Звук и видео" (по фильтрам). Очень удобно, когда качаешь много разного файла. Причем все фильтры действуют и на уже слитое, образуя очень удобную историю загрузок. И настройка менеджера тоже на уровне - автоматическое разделение на группы по расширению (как этого не хватает FlashGet'у!), генерация имени файла на лету из адреса, даты и прочего стаффа, все 33 удовольствия. В настройке GetRight был силен всегда. И опций становится все больше (иногда загоняет в ступор :)) - в последних версиях появилась настройка уведомления об успехе закачки, от которой я сильно протащился. Прикинь, сижу в универе, а мне сливаются СМСки типа "файл такой-то успешно закачан; разрыв соединения; компьютер выключен". Пустячок, а приятно =)). И число частей для разбивки можно вычислять автоматически - в зависимости от размера файла. В общем, если любишь повозиться часиков дцать, а потом только пинать плюшки, это для тебя.

У GetRight'а оригинальная система отображения закачиваемых файлов - иконками в трее, причем показываются и точные цифры (процент слитого), и мелкий прогрессбар. Вот только если увлечься сливанием (слитием?) значимого числа файлов одновременно, трей упрется в Пуск :). И не будет у тебя таскбара. Обидно ;). Из косметики есть скины, но надо ли оно тебе? ИМХО, скорость важнее внешности. Кстати, о скорости - у GetRight'a самые плохие результаты при дефолтовых настройках. Причина в его любви к зеркалам (Нарцисс, однако). В нем существует действительно удобная система - поиск зеркал и проверка связи с каждым из них раз в энцать минут. Но удобная для ламерикосов, так как зеркала ищутся на Lycos'e . А от нас до Lycos'а пинг не всегда проходит. Отсюда и лаг. В принципе, эту систему можно и отрубить, но не так прост наш кулхацкер ;). Жалко терять фичу - возись с настройками, закон простой.

Теперь о грустном. Выудить что-то о текущей закачке, кроме банальностей типа оставшегося времени, не представляется возможным. Есть, конечно, менюшка "Детали передачи", но там только лог связи с сервером. Узнать о числе частей, которые автономно закачиваются, не представляется возможным :(. Так что он идеально подойдет людям с качественной связью, не сильно любопытным и в меру продвинутым. Да, и со знанием буржуйского, а то им на наш родной лень перевести.


Спецвыпуск Xakep, номер #015, стр. 015-042-3, Грузите апельсины бочками: особенности национального download'а

Грузите апельсины бочками: особенности национального download'а

Спецвыпуск Xakep, номер #015, стр. 015-042-3

ReGet Deluxe

Вес: 887 Кб

Урл: www.reget.com

Самый стильный даунлодер из представленных. Я говорил, что не люблю скины и прочие украшательства, но ReGet покорил продуманностью стиля. С ним действительно приятно общаться, респекты разработчикам.

Основные фичи как у всех - закачка по частям, планировщик, только обозреватель сайта несправедливо зажали :(. Настроек много, есть эксклюзивные, но разобраться в них... Они организованы в виде дерева, и пока догадаешься, в какую ветку запихнули нужную тебе опцию, проклянешь все и вся. А можно и не искать, и не разбираться. В ReGet'е предусмотрена фича типа автонастройки - тебе надо только указать тип соединения (скорость момеда etc.), и вуаля - основные параметры пофиксятся на оптимальных значениях. Звучит хорошо, но когда ты столкнешься с нестандартной ситуацией (а она по определению возникает внезапно ;)), придется или рвать волосы на за... эээ... на затылке, или же, оставаясь спокойным как скала, заниматься настройкой методом полного перебора ;).

А теперь сенсация! Разработчикам программы WinMP3Locator надоело ее распространять, и они... правильно, включили ее в состав ReGet'а, попутно научив искать и простые файлы. Таким образом, ты получаешь сразу две программы, тесно интегрированные друг в друга, что, несомненно, полезно. Единственное, чего не хватает для полного счастья - добавления поисковых систем вручную. Хотя основные наши поисковики (типа Апорта и RMP) уже есть в комплекте, прога-то написана нашими соотечественниками.

Информативность у ReGet'а на высоте. Во-первых, вся нужная инфа (размер, скорость, количество кусков, оставшееся время) доступна из таблицы закачек. Во-вторых, внизу окна постоянно мельтешит лог взаимоотношений с серваком. И, в-третьих, иконка в трее показывает всеми любимый график траффика. Бесполезно, но мило - шевелится чего-то там в уголке, и душа радуется :). Интересная фишка - менеджер сайтов. Он позволяет назначить каждому хосту свои параметры закачки, что бывает удобно, когда часто качаешь файлы с одних и тех же серваков (типа ftp.ware.ru).

В ReGet'е нестандартная система ограничения траффика: она имеет три настраиваемых уровня, переключаться между которыми можно через контекстное меню. Серфишь по инету - кооперативный режим, почту качаешь - минимальный, за пивом ушел - неограниченный. Кстати, если у тебя стоит ИЕ, то тебе понравится автонастройка траффика в зависимости от активности твоего осла (Даня, молчать!). Да, если кто юзает Оперу, советую обязательно посмотреть. В отличие от GetRight'а и FlashGet'а, ReGet поддерживает интеграцию с ней с самого начала, без установки всяческих плагинов.


Спецвыпуск Xakep, номер #015, стр. 015-042-4, Грузите апельсины бочками: особенности национального download'а

Грузите апельсины бочками: особенности национального download'а

Спецвыпуск Xakep, номер #015, стр. 015-042-4

DAP

Вес: 990 Кб

Урл: www.speedbit.com

Первооткрыватель в области многопоточных загрузок. Именно с него и началась вся эта история, выродившаяся в новый негласный стандарт.

Честно говоря, это единственный факт, заставивший меня поместить в обзор эту прогу. Почему? Просто изначально DAP - это плагин к ИЕ. И даже дойдя до пятой версии, на реальный даунлоад-менеджер он никак не тянет. Убивающий с первого взгляда дизайн (взгляни на скриншот), отсутствие всяческих тонких настроек (даже тайм-аут для FTP выставить нельзя), неудобное меню - все это не вызывает положительных эмоций. Еще одна странность - каждый закачиваемый файл открывает новое окно приличного размера (при моих 800х600 - треть экрана), в котором бoльшая часть - стильный серый фон ;). Информации же о закачке - минимум, даже лог соединения не добудешь. Зато есть поиск в Интернете (не как в ReGet'е, а на одном буржуйском серваке), функция хранения паролей (в реестре и с простейшей шифрацией ;)), планировщик (довольно неплохой, кстати) и поиск зеркал (опять же без всякой настройки). Распределение залитых файлов по типам тоже имеется, но погоды оно все равно не делает.

Я бы не рекомендовал тебе использовать ДАП в домашнем хозяйстве - уж очень он скрытный и неуклюжий =). Но для твоих подопечных ламеров (нету таких? не верю! у меня целый выводок :)) подойдет в самый раз - им удобный интерфейс ни к чему, настроек мало, путаться негде, в ИЕ встраивается: нажал - и все сливается. Да, чуть не забыл: разработчики обещают докачку на серверах, не поддерживающих ее ("always support resume" или "постоянный упор резюме", если верить моему Cтилусу :)). Говорить - говорят, а как - не объясняют. То ли ноу-хау, то ли понты ;). По крайней мере у меня не работало :(.

ИМХО напоследок

Я не буду давать тебе конкретных советов. Выбирай качалку сам, в соответствии с запросами - основной инфой ты уже владеешь. Если не понравилось ничего из перечисленного (ну ты привереда!), помни, что есть еще и нерассмотренные здесь проги - старушка Го!Зилла, ГетCмарт, НетВампир. Посмотри, может и найдешь свой идеал. Будут вопросы - пиши, а я пойду разгребать залитые при тестировании файлы. Авось чего полезное найду ;).


Спецвыпуск Xakep, номер #015, стр. 015-044-1, Сам себе сервер

Сам себе сервер

CuTTer (cutter@real.xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-044-1

Клево иметь собственный сервер. Особенно если это многопроцессорная машина с лесом оперативки и сказевыми винтами, висящая на выделенном канале. Можно, конечно, и в Кваку на такой тачке погонять ;), но обычно счастливые владельцы подобных зверюг используют их для более серьезных целей: открывают у себя какие-нибудь сервисы - web, почта, ftp или что-нибудь еще в этом роде. А нам с тобой что мешает? Те ребята, которые юзают никсы, хитро улыбнутся - уж они-то знают, что ничего не мешает открыть сервис на любой машине, хоть как-нибудь подключенной к сети. А вот с виндами... А вот об этом читай ниже.

Естественно, мы не сможем организовать на твоем диалапном целероне, живущем под win, полноценный сервис, которым будут пользоваться миллионы людей со всех концов планеты. Но нам ведь этого и не надо! Нам надо только открыть такие сервисы, которые нам самим и будут полезны. И пользоваться ими будем мы сами и ограниченный круг наших друзей!

Аська

Многие, наверное, знают (или догадываются), что ICQ реализована на механизме клиент-сервер. То, что юзеры скачивают и инсталлят себе, - это клиент. А на сервере Мирабилиса открыт соответствующий сервис, позволяющий клиентам взаимодействовать с собой. Если не ошибаюсь, его адрес - login.icq.com:5190. В клиенте аськи есть даже специальная опция настройки, позволяющая прописывать отличный от мирабилисовского сервак. А теперь представь, что у тебя есть собственный ICQ-сервер! И все твои друзья могут прописать в своих аськах твой IP'шник и коннектиться к твоему серваку. А ты как администратор сервера ;) раздаешь всем уины - 1 (ну, этот ты, наверное, себе оставишь :)), 666, 101 (LOL), 31337 и прочие. Главное, что об этом серваке будут знать только твои приятели, и никто не будет к вам ломиться и спамить всякой ерундой, типа - "перешлите это сообщение всем пользователям в своем контактном листе, а то Гитлер воскреснет и всех нагнет". Очень часто собственные ICQ-сервера организовывают в локальных сетках всяких фирм для сотрудников - экономят трафик ;). Да и в домашних локальных сетях внутренний сервак аськи очень полезен.

Неофициальных ICQ-серверов существует огромное множество: и под винды, и под никс. Мы уже договорились, что твоя машина виндовая, поэтому ставить будем win32 ICQ-сервер. Скачать его можно отсюда: http://icq.vsochi.com/downloads/icqteam.rar. Разработчиками являются многострадальные ICQTeam, сайт которых недавно прикрыла AOL. Теперь они называются UkrSoftware, и их сервер доступен по адресу www.ukrsoftware.com. Возможно, скоро там появятся уже новые версии сервера. А пока - распаковывай архивчик ;). В нем лежит еще несколько зипарей: тебе нужен оттуда только сервер. Честно говоря, я несколько удивился, увидев, что размер файла составляет всего 50 кило. Сразу возникло подозрение, что тут есть какой-то подвох, но, запустив и протестировав ICQ Server, я понял, что все ок.

Приятель, оно работает :)! Но есть некоторые ограничения: ICQ Server поддерживает только 98-ые и 99-ые аськи, так что с 2000-ой и с 2001-ой выйдет большой облом :(. Дело в том, что свежие версии клиента основаны на новых протоколах icq (7-ом и 8-ом), а сервер до них еще не дорос. Старые версии ICQ можно скачать с того же icq.vsochi.com. Владельцы nix-систем могут вообще не беспокоиться и продолжать пользоваться своими любимыми клиентами (licq, gnomicu, micq).


Спецвыпуск Xakep, номер #015, стр. 015-044-2, Сам себе сервер

Сам себе сервер

CuTTer (cutter@real.xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-044-2

При запуске сервера тебя попросят ввести серийник (он лежит в том же архиве). Появится очень скромное окошечко. Сразу заходи в настройки сервера (Servers -> Options). Здесь поставь галочку на "Save offline messages on exit" - чтобы не терялись сообщения, посланные offline пользователям. Timeout'ы я не трогал - вроде и так все работает. С портом поступил точно так же - он стандартный. Стоит отметить галочкой "Allow new UINs registrations", чтобы пользователи могли регистрировать новые юины. Вот теперь сервер совсем готов к работе :).

Административных возможностей здесь немного, но, в принципе, их должно хватить. Например, если тебя достал какой-нибудь пользователь, то ты его можешь кикнуть с сервера (Disconnect user). Также есть база данных по юинам, поэтому ты всегда успеешь удалить какую-нибудь запись. Не понравилось отсутствие функции по бану юзеров - это, конечно, можно реализовать, но только через firewall, что несколько неудобно :(.

Напоследок хочу отметить, что ICQ Server все-таки немного глючит. Почему-то у некоторых он не хочет регистрировать новые юины - приходится добавлять записи руками. В общем, сервер корявый, но работает :). Кстати, сами Mirabilis тоже сбацали свой корпоративный ICQserver. Он заточен под NT системы, так что под 9х виндами работать не будет. А вот клиент работает везде. Скачать можно здесь: ftp://ftp.vsu.ru/pub/win/network/icq/icqgwserver.exe (сервер) и ftp://ftp.vsu.ru/pub/win/network/icq/icqgwclient.exe (клиент).

Залежи FTP

Имхо, самое полезное, что может оказаться для твоих собратьев, - это большие архивы различного программного обеспечения. Если ты постоянно заливаешь себе свежий софт из Инета, то неплохо было бы поделиться им с приятелями. Особенно это актуально для локальных сетей, где за внешний трафик приходится платить. Самый удобный способ реализовать файл-архив - установить у себя FTP-сервер. Прикольно, что необязательно делать описания к программам - достаточно только грамотно построить дерево каталогов и рассортировать файлы по директориям.

Программа, которая у нас будет отвечать за FTP, называется Serv-U. Это очень гибкая в настройках прога. В ней все конфигурируется до малейших деталей, что должно понравиться пользователям Unix'а ;). Так что качай дистрибутив с www.serv-u.com (текущая версия - 3.0). Кстати, программа платная, но пускай это тебя не заботит ;).

Теперь можешь пускать Serv-U, в первый раз сработает Wizard. Он предложит настроить FTP - соглашайся. Первым делом Wizard поинтересуется у тебя, хочешь ли ты, чтобы показывались маленькие иконки в менюшках. Выбирай "да" - с ними удобней. Далее спросит, пускать ли сервер. Конечно, пускать! В следующем вопросе Wizard попросит ввести IP. Если ты не хочешь иметь жесткую привязку сервера к определенному IP, то это поле лучше оставить пустым. На следующем шаге следует задать Domain name. Тут можешь ввести все что угодно, например: d00d13's server. Дальше Wizard спросит, нужно ли автоматически стартовать FTP-сервер при загрузке компьютера. Я бы не советовал этого делать :).


Спецвыпуск Xakep, номер #015, стр. 015-044-3, Сам себе сервер

Сам себе сервер

CuTTer (cutter@real.xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-044-3

Если ты хочешь поставить сервак только как архив файлов, то включай anonymous доступ. Тогда пользователи смогут скачивать файлы, а на другие действия прав у них не хватит. Все, осталось только выбрать корневую директорию с файлами и поставить на нее Lock. Жми на Finish - отныне твой комп превращен в FTP-архив!

Можешь это проверить: коннекться на localhost или на свой IP, который ты получаешь при входе в Интернет (конечно, если ты dialup-пользователь). Сервер примет коннект, и ты попадешь в корневой каталог. Заметь, можно только скачивать. Закачать файлы, создавать директории, переименовать - ничего такого ты сделать не сможешь. Для таких действий необходимо добавить зарегистрированных пользователей с дополнительными привилегиями.

Я тебе помогу создать специальный каталог, куда твои друзья смогут заливать свежие файлы. Обычно он называется incoming - вот его и создавай в корне FTP-сервера. Теперь зайди в настройки пользователя anonymous, открой вкладку Dir Access. В ней добавь этот incoming, поставь в поле Files крестик на Write. Теперь анонимные пользователи могут заливать файлы в incoming :). Осталось только установить максимальную скорость по скачке и закачке файлов. Ставь ее в два раза меньше, чем твое соединение (ты ведь не хочешь, чтобы тебе полностью канал забили?). Также можешь ограничить максимальное количество одновременно присоединенных пользователей.

HTTP

FTP мы поставили. Теперь установим HTTP-сервер. Для чего он может понадобиться? Например, чтобы ты мог покрасоваться своим сайтом. Если у тебя выделенная линия, то можно вообще забить на всякие хостинги и размещать страницы прямо на своей машине. Это очень удобно, ничего не нужно закачивать. Все под рукой, если что-то работает не так, то ты всегда можешь это исправить. В общем, ты сам себе хозяин. Только один момент напрягает, компьютер постоянно должен быть включен :(.

В принципе в роли HTTP-сервера можно установить Apache или IIS, но я предлагаю использовать Sambar. Он ничем не уступает им по возможностям, а во многом просто превосходит. Например, помимо http, он предлагает еще и ftp, pop3, smtp, dns. Также может выступать в роли proxy или socks сервера. Но не будем заморачиваться, просто качай его с http://www.sambar.com. Бери версию 5.0, это стабильный релиз, хотя, если не боишься беты, то можно попробовать слить 5.2. Еще не забудь сходить на какой-нибудь кряк-сайт, так как для полноценной работы придется вводить лицензионный код.

В принципе Sambar и так сконфигурирован, но для удобства я предлагаю поменять некоторые настройки. В первую очередь нужно сменить каталог, где лежат документы и скрипты. Для этого открывай файл config.ini из директории config. Найди строку "Documents Directory" - это путь к html-файлам, прописывай свое. "CGI Directory" - здесь будут лежать твои скрипты. Кстати о скриптах: вместе с самбаром идет и Perl, он несколько урезанный и без дополнительных модулей, но главное - он работает :). Если нужна полная версия Perl'а под винды, то сходи на www.activestate.com. После этого раскомментируй строку "CGI Extensions". В ней содержатся расширения CGI-скриптов (.pl, .cgi). Также стоит прописать расширения файлов, где можно использовать SSI. Тебе это может понадобиться, если ты захочешь встраивать в статичные HTML-файлы CGI-скрипты или просто текстовые документы. Эти настройки находятся в "Server Side Includes". По умолчанию SSI включен только для shtml-файлов, так что лучше добавить еще html и htm.


Спецвыпуск Xakep, номер #015, стр. 015-044-4, Сам себе сервер

Сам себе сервер

CuTTer (cutter@real.xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-044-4

Все эти незначительные настройки должны привести сервер в рабочее состояние: будут включены и SSI, и скрипты. Сам сайт доступен по адресу localhost, но если ты в Интернете, то и по IP, который ты получил от провайдера. Вот теперь можно и похвастаться своим супер сайтом :).

Но опять-таки существует некоторое ограничение: сервер будет нормально функционировать, но разместить на нем ты сможешь только один сайт. Ведь если захочется добавить еще один, то придется постоянно копаться в настройках, чтобы менять директории с одного сайта на другой. Но есть и другой выход - Virtual hosts. Виртуальные хосты. Они предназначены для размещения на одном сервере нескольких сайтов. Как это реализовывается? Ты прописываешь имя домена, IP, на котором он будет размещаться, настройки для этого сайта (директория с файлами, скриптами). Сервер же будет определять по имени хоста (в HTTP-запросах передается это имя), к какой паге идет запрос. В общем, чтобы добавить новый сайт, открывай файл vhost.ini. В нем уже прописаны примеры виртуальных хостов, так что просто раскомментируй кусок и исправь на нужные параметры. Они такие же, как и в обычном config.ini: Documents Directory, Home Page, CGI Directory и прочее. Теперь ты полноценный админ :).

Спамерский рай

Юные и неумелые спамеры постоянно бродят по Инету и достают всех просьбами дать адреса рабочих SMTP-серверов, позволяющих рассылать большое количество писем. Too lame! Я расскажу тебе, как можно рассылать мега-широкомасштабный спам, да так, что никакие чужие SMTP-сервера не понадобятся. Понимаешь, к чему это я :)? Просто мы поставим на своей тачке собственный почтовый сервак и будем прямо с него спамить до тех пор, пока не надоест (или самому, или твоему прову :=)).

На вакансию почтового сервера я определил тот же Sambar 5.0, который у нас уже работал HTTP-серваком. Он может открыть на твоей машине сервисы SMTP, POP3 и IMAP. Ни POP3, ни тем более IMAP нам не пригодятся, так как принимать письма мы не собираемся ;), да и невозможно это, если ip динамический.

Чтобы включить MAIL-сервер, в файле config.ini необходимо поставить yes над пунктом "Act As Mail Server". После этого Sambar запустится как POP3 и SMTP сервер. Но отсылать письма ты все равно не сможешь :). В начальных настройках все исходящие письма перенаправляются на smtp.ix.netcom.com. Это бред, который нужно отключить: поставь ремарку (символ #) на строке POP3 Server. Теперь ты может отсылать письма - но только локально, так как Relaying писем изначально запрещен. Поэтому полезем в другой файл - mail.ini. Прописывай в нем имя сервера, например, d00d13.mail.server. В "Run SMTPD" должно стоять true. Поле "Relay FROM User" оставь пустым, тогда ты сможешь слать локально почту с любого e-mail'а. Если ты хочешь, чтоб при отсылке писем требовалась SMTP-аутентификация, то в "Relay AUTH Username" и "Relay AUTH Password" пропиши какой-нибудь логин и пароль. Так никто не сможет отправлять письма, кроме тебя :). Если тебе не нужны эти фичи, то в "Require AUTH" поставь false. Также в поле "Restrict Relay" напиши false, чтоб спамить без каких-либо ограничений :). И самое последнее: в "Local Domains" установи значение localhost, а в "Relay Domain" поставь *. Все, теперь твой мега-1337 сервер готов к бою и обороне :). Чтобы проверить его работу, открой любой почтовый клиент - например, TheBat. В его настройках пропиши SMTP-сервер localhost. Попробуй отправить письмо на свою почту. Через несколько секунд сообщение должно тихо стукнуться о дно ящика.


Спецвыпуск Xakep, номер #015, стр. 015-044-5, Сам себе сервер

Сам себе сервер

CuTTer (cutter@real.xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-044-5

eDonkey

Все знают, какая трагическая участь постигла Napster :(. Его не закрыли, но он стал платным. Это грустно. Правда, есть еще Gnutella и множество других серверов. Но все они потихоньку загибаются (вот совсем недавно Audiogalaxy начала откидывать копыта - фильтры включили)... А ты никогда не задумывался, что можно открыть свой? Поверь, это совсем несложно. Например, я подключен к сети КОМКОР-ТВ (сие есть некое подобие большой локалки). Так как с трафиком во внешний Инет у нас большие ограничения, все мы обмениваемся музыкой, софтом и другими вещами у себя локально. Но просто спрашивать у каждого пользователя про определенные файлы нам надоело, так как это довольно муторное занятие. Поэтому мы организовали свой сервер вроде Напстера прямо у себя в сети. Называется он, как ты, наверное, успел догадаться, - eDonkey. Его официальный сайт www.edonkey2000.com. Тебе нужно скачать сервер, он будет центральным, и только один, а также eDonkey-клиент. Клиентскую часть придется качать всем пользователям сети :). Так что позаботься о его распространении. А сервер желательно ставить на нормальном компе с шустрым каналом - ведь вся информация о файлах кэшируется на нем. А вот скачивание софта уже идет напрямую с пользователя. Кстати, загрузка файлов реализована нормально: в отличие от Napster'а здесь есть поддержка докачки.

Сервер распространяется в двух вариантах: одна версия под win32, вторая - под Linux, так что любители BSD пока отдыхают :). Просто разработчики зажали исходники. Ну да ладно, загружай сервер. Причем неважно, под какую систему, ведь оба варианта настраиваются абсолютно одинаково. Распаковывай архив и открывай donkey.ini. Будем настраивать :).

Первая строка конфига обязательно должна начинаться с "[server]". Следующими параметрами идут название и описание сервера: "name" и "desc". В "console" пропиши параметр true, тогда сервер запустится в консольном режиме. "maxClients" - максимальное количество пользователей, это реши сам, исходя из размера вашей сетки. В "public" устанавливается режим сервера. Если сделаешь публичным, тогда твой сервер будет высвечиваться в общих списках eDonkey's серверов. И любой чел из обычного Интернета сможет присоединиться к вашему серверу, конечно, если у вас не VPN. Дальше можешь прописать приветственное сообщение, оно будет выводиться каждому новому пользователю. Еще можно поменять порт для соединения, если ты хочешь усиленно шифроваться :). Это параметр "port" (по умолчанию - 4661-ой). С настройками все - можно запускать сервер.


Спецвыпуск Xakep, номер #015, стр. 015-044-6, Сам себе сервер

Сам себе сервер

CuTTer (cutter@real.xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-044-6

Теперь немного о работе с самим клиентом. При его инсталляции он спросит про установку дополнительного софта - лучше откажись, там одна лажа :(. После запуска можешь сразу удалить из вкладки "Servers" все сервера, так как они тормозные, а большая часть из них просто не работает. После этого можешь гордо добавить свой :). Правда перед коннектом придется еще зайти в "Options". Там проставь свой нормальный ник, чтобы пользователи могли тебя узнавать. Также ограничь максимальную скорость для Upload и Download, а то забьешь себе весь канал.

Теперь подсоединяйся к своему серверу - должно появиться приветственное сообщение. Заползай во вкладку "Search", в типе поиска поставь "Users" - так ты найдешь пользователей, которые сейчас находятся на сервере. Можно и не париться, а сразу начать искать нужную тебе информацию. Например, если нужна какая-то mp3'шка, то выбери "mp3 Search". Вот здесь проявятся самые приятные возможности eDonkey: помимо имени файлы ты можешь свободно задать название песни или группу, которая ее исполняет. В общем, поиск сделан довольно удобно. Впечатления о программе очень даже приятные, но надо признаться, продукт еще несколько сыроват: иногда проявляются небольшие глюки, программа может подвиснуть. Хотя на это можно и забить, так как подобные штуки происходят довольно редко, а польза от eDonkey очень большая. Пользуйся и наслаждайся :).

Энд

Ну вот, я надеюсь, ты заценил, как удобно иметь на своей машине некоторые сервисы. В локалке без них сидеть - вообще преступление, но и диалапщикам они частенько оказываются полезны :). Но все эти "полезно", "удобно" - фигня! Имхо, самое главное в том, что ты таким вот способом набираешься знаний. Одно дело, когда ты теоретически знаешь, что такое сервер, как работает система клиент-сервер, и совсем другое, когда ты все это видишь на примере, на практике. Так что не ленись, изучай и вникай! Читай вдумчиво!


Спецвыпуск Xakep, номер #015, стр. 015-048-1, Реальный веб-дизайн

Реальный веб-дизайн

Спецвыпуск Xakep, номер #015, стр. 015-048-1

Вадим Мурзагалин (vadias@sendmail.ru, www.freehand.str.ru)

"Что за банальная тема! Да в сети полно ресурсов по этому поводу! Сто пудов, автор - лох, сдувший статью с какого-нибудь сайта", - возможно, именно так ты и подумал, взглянув на заголовок этой страницы. Мне придется согласиться с тобой в части количества сайтов по теме: да, их много. Достаточно и книг по веб-дизайну. Мало того, их становится все больше и больше, ведь веб-дизайнер - достаточно модная нынче профессия! Однако и тебе придется согласиться со мной в том, что соотношение путевых и галимых страниц в Интернете в лучшую сторону из года в год не меняется и вряд ли изменится в ближайшем будущем. Как ты думаешь, в чем дело?

Я думаю, что одна из возможных причин такого застоя в том, что издания, предлагающие свои советы и уроки, не являются достаточно авторитетными для таких, как ты и я. Лично мне не раз приходилось наблюдать на странице, подсознательно вызывающей неудержимые рвотные рефлексы, заголовки такого рода: "Лучшая дисятка советов для мастиров веб-дезайна!". Что ж, но ведь СПЕЦ-Хакер - совсем другое дело, не правда ли ;)?

И потом абсолютное большинство таких советов посвящено технической стороне вопроса - HTML, Javascript, Dinamic HTML и прочему кодингу. Пришло время поговорить собственно о дизайне.

Простота лучше воровства

Самое первое, на что следует обратить внимание, - это сам подход к моделированию сайта и страницы. Начиная работать с чем-то новым для себя, все делают ошибки. Веб-дизайн ничем не отличается от любого другого занятия. Я делал эти ошибки, известные дизайнеры делали эти ошибки на заре своих карьер, сам Якоб Нильсен делал их - он сам сказал мне это по секрету в своей книжке.

Абсолютное большинство новичков, жаждущих известности и сверхпопулярности своего будущего мега-портала, сразу строит в мыслях громадный агрегат с десятками значков, пикчур и прочих элементов, не задумываясь, какую инфу и пользу они будут нести для юзверя. В итоге получается "не пришей везде рукав" - глупый посетитель считает всякую лишнюю пикчурку элементом навигации и наивно тычется туда своим курсором. Так что делай вывод и применяй такую концепцию: сначала - полная подготовка информационного содержания (контента), а уже потом - оформление. В идеале каждая точка на странице должна быть со смыслом :).

Цвет

Цвета - бубонная чума многих молодых сайтостроителей, у которых крутость ассоциируется с попугайской пестротой и боевой индейской раскраской. Как ты мог догадаться по моему ироничному тону, это неправильное мнение. И вообще - то, что кажется очевидным, довольно часто оказывается неправильным.

Цвет в веб-дизайне, как и в жизни, имеет весьма нехилое значение. Цветом можно воздействовать на аудиторию. Если на странице ты просто даешь какую-нибудь инфу, скажем, справочную, оптимальным будет использование черного текста на белом фоне. А если ты хочешь, чтобы сонный юзер при заходе на твой сайт мигом проснулся, используй ярко-желтый или красный текст или символ на черном фоне - такой прием иногда используется для подачи какой-нибудь крутой новости.


Спецвыпуск Xakep, номер #015, стр. 015-048-2, Реальный веб-дизайн

Реальный веб-дизайн

Спецвыпуск Xakep, номер #015, стр. 015-048-2

Теория цвета довольно сложна, и чтобы овладеть ею, нужны интуиция и опыт. Если боишься напортачить, работай с оттенками серого - не проиграешь ;). Еще одна рекомендация: пока ты не сможешь сказать себе: "Я крут в подборе цвета", используй специальные проги, показывающие совместимые цвета. Я видел такие на серверах фриварного и шароварного софта. Запомни главное: цвета текста и фона должны контрастировать, чтобы читать было легко и приятно.

Задний план

Фон страницы может быть плоскоцветным и текстурным. Плоскоцветный фон использует только один цвет и, несмотря на кажущийся примитивизм, он более популярен у профи. Текстурный фон подразумевает использование изображений, косящих под различные поверхности, либо фотографий. Я прошу тебя, не уподобляйся ламеркам от дизайна, которые, радостно брызгая слюной, делают фон "как настоящий кирпич!" и страшно гордятся этим. Если уж пошла такая пьянка, применяй фотографии, а я раскрою тебе пару-тройку хитростей, связанных с ними. Первое: не ходи на отечественные ресурсы бесплатных полупрофессиональных и любительских фоток. Ходи на зарубежные профессиональные хранилища. Одним из таких хранилищ является www.photodisc.com. В поле поиска ты вводишь ключевое слово, и специально для тебя генерируется страница с X-количеством мини-изображений, связанных с твоим запросом. Выбирай где-нибудь в середине и щелкай - получишь страницу с немного увеличенной фотографией (примерно 250x250 pix) с указанием цены на пикчу большого размера нужного формата. Но для веб-дизайна сойдет и та, 250 на 250, не так ли ;)?

Второе - просто прямоугольная картинка с резкими краями не всегда смотрится аккуратно, поэтому иногда лучше попыхтеть с графическим редактором. Навскидку могу назвать два стандартных приема. Первый - размытие краев, которое можно сделать с помощью аэрографа: ставишь цвет, как у бекграунда, и обрабатываешь по краям.

Второй прием - эффект тени под изображением (но не под всей картинкой); в разных редакторах он достигается разными путями.

Текст на страницах

Что бы там ни говорили большевики, текст остается главной составляющей содержимого всемирной сети. Собственно говоря, ради этого все и создавалось, а поэтому не надо думать, что оформление текста - ерунда по сравнению со всем остальным.

Главное правило - используй на сайте как можно меньше шрифтов, лучше всего не больше двух. Мы с тобой уже говорили, что не все то круто, что пестрит, - эта фраза уместна и здесь.

Не стоит делать полужирным шрифтом или курсивом большие блоки текста. Эти специальные виды начертания созданы для того, чтобы выделить какую-либо значимую фразу. Вспомни фразу из фильма "Крутые стволы": "Чем реже ты ругаешься, тем весомее твое ругательство" :).

Остерегайся использования вычурных шрифтов со всякими рюшечками и завитушками. Бывает, что именно они портят всю картину. Иногда текст оформляют как графические вставки.

Если твоя пага содержит несколько колонок, и они расположены достаточно близко друг от друга, проследи, чтобы строки в соседних колонках находились на одной высоте. Фиг знает почему, но в противном случае лично мне становится как-то не по себе :).


Спецвыпуск Xakep, номер #015, стр. 015-048-3, Реальный веб-дизайн

Реальный веб-дизайн

Спецвыпуск Xakep, номер #015, стр. 015-048-3

Ударный элемент и шапка сайта

Ты не задумывался, почему внешний вид некоторых сайтов с маленьким количеством информации запоминается лучше, чем фейс корпоративных сайтов с обилием оной, со множеством возможностей и функций? Я сам недавно понял: у них был путевый и запоминающийся элемент, идентифицирующий именно этот сайт среди многих других - я бы назвал его логотипом сайта. У многих компаний он совпадает с ее обычным логотипом. Располагается он, как правило, в левом верхнем углу страницы. Отсюда вывод: если хочешь, чтобы тебя помнили, постарайся сделать оригинальную графическую фишку. Придется долго возиться в редакторах, пробовать много вариантов, но это просто необходимо для удачного дизайна. Делай его без использования большого количества цветов и уж, конечно, без использования каких-либо текстур. Логотип сайта можно выносить в баннеры, на визитки, распечатывать на бумаге или вешать на стену. Он должен присутствовать на каждой странице - можешь считать его штырем сайта, на который насажены все страницы.

Кроме логотипа, немалую роль играет шапка страницы. Следующий эффект применяется на многих веб-страницах, баннерах, да и просто в полиграфии. Успешнее всего этот эффект лабается в многострадальном Фотошопе, благодаря этому и появился фразеологизм "в стиле Photoshop". Делается это так: на имеющуюся картинку накладываешь вторую, копируя ее откуда-либо через буфер (она попадает на слой выше). Затем выбираешь ластик, делаешь в нем следующие настройки: Brush - как можно больше, но не переборщи; Mode - Airbrush; Pressure - ставь поменьше, 10-30%. Теперь, аккуратно подтирая в нужном месте верхнюю картинку :), ты получишь крутую полупрозрачность.

Разбор помета

Лучший способ наращивать навыки крутого дизайнера - анализировать чужие работы. Конечно, анализ сайта твоего младшего братишки вряд ли приведет к чему-нибудь хорошему, но www-представительства производителей графического софта и профессиональных студий веб-дизайна могут научить многим интересным вещам, а также натолкнуть на свои интересные мысли. Не стоит впадать в панику на тему "я никогда так не смогу" - надо пытаться повторить то, что ты видел; размышлять, какими инструментами это достигалось, изучать литературу и постоянно повышать свой уровень мастерства.

Чтобы не оставаться голословными, давай вместе разберем главную страницу Adobe Systems. Как вылезешь в сеть, набери в адресной строке браузера www.adobe.com. Итак, какие профессиональные трючки мы тут наблюдаем? Как уже говорилось, в левом верхнем углу - фирменный логотип Adobe, использующий три цвета: белый, черный и красный, - отличное сочетание. В шапке страницы - семь ссылок: как сообщают психологи, именно такое количество однородных предметов наш мозг обрабатывает без напрягов. Заметь, что все заголовки на самом деле не текстовые, а графические. Такой ход объясняется следующими причинами: во-первых, юзер видит заголовок именно так, как хотел дизайнер - иногда случается, что на компе клиента не установлены соответствующие шрифты либо браузер отобразит заголовок по-своему; во-вторых, средствами графического редактора к тексту можно применить антиалиасинг (сглаживание), так что он будет более приятным для глаза. Идем далее: слева, как я понял, расположены анонсы с визуальным представлением. Заметил, что эти круглые пикчурки не одинаковы, хотя и представляют информацию вроде бы одинаковой значимости? Этот прием применяется в рекламе - маленький рядом с большим привлекают больше внимания, чем два средних ;). Перейдем к правой колонке: для украшения текстовых заголовков и кратких аннотаций авторы сайта добавили метафоры - маленькие пиктограммы со смыслом (тулзы для веб-дизайна - курсор в виде руки, щелкающий по ссылке, печать - листы бумаги - и так дальше). Это традиционная и рожденная Интернетом графика тоже хорошо привлекает внимание.


Спецвыпуск Xakep, номер #015, стр. 015-048-4, Реальный веб-дизайн

Реальный веб-дизайн

Спецвыпуск Xakep, номер #015, стр. 015-048-4

А дальше - сам!

Надеюсь, что эта короткая статья хотя бы немного прояснила для тебя непростую ситуацию в мире дизайна, и ты уже не считаешь меня лохом, копирующим текст с интернет-паг и вставляющим его в текстовый редактор для написания материала. Я показал тебе, в каком направлении и как надо развиваться. Если ты не умеешь работать с графикой и не собираешься учиться, а также тебе лень возиться, изучая творенья мастеров, то мои, да и любые другие советы, тебе не помогут. Но это я так, чтоб ты не зазнавался :).

Напоследок добавлю: чтобы сделать реальный дизайн, надо хорошо уметь редактировать как растровую, так и векторную графику. В векторном редакторе удобно делать макет страницы, прикидывать расположение навигации, иллюстраций и прочих элементов. Когда наступает необходимость профильтровать какую-нибудь фотку, приходит время растрового редактора. "СПЕЦ" обязательно подкинет тебе что-нибудь интересное и по этим вопросам ;).


Спецвыпуск Xakep, номер #015, стр. 015-050-1, Dreamweaver - король WYSYWIG'ов

Dreamweaver - король WYSYWIG'ов

Спецвыпуск Xakep, номер #015, стр. 015-050-1

Вадим Мурзагалин (vadias@sendmail.ru, www.freehand.str.ru)

Одним из самых больных вопросов для начинающего веб-дизайнера является выбор инструментария, способного наиболее полно отразить его творческое эго и полет мысли. Но дело не только в этом: с одной стороны, приверженцы ручного набора в Notepad'е с диким ржанием тычут в теги, недвусмысленно показывающие, что ты сделал страницу в FrontPage, а с другой - матушка-лень запрещает изучать псевдопремудрости HTML и прочих фишек. Успешно выпутаться из этого щекотливого положения тебе поможет небезызвестный в дизайнерских кругах веб-редактор Macromedia Dreamweaver.

Выбор профессионала

Самое большое преимущество Dreamweaver'а по сравнению с другими WYSIWYG'ами состоит в том, что он практически не добавляет на страницы паразитный код - поэтому-то многие опытные дизайнеры не стесняются пользоваться этим редактором. Кроме того, набор средств очень хорошо организован и легко настраивается - за это Макромедиа получала отдельные похвалы и награды. И, в-третьих, это не просто редактор отдельных страниц - он позволяет держать под контролем весь узел и весьма ловко оперировать им. Но довольно с тебя теории - давай-ка, наконец, запустим программу и проверим ее на прочность в боевых условиях! Только сразу предупреждаю: у меня третья версия DW, поскольку она пока что полностью удовлетворяет мои скромные потребности. Так что, счастливый обладатель DW 4, не пугайся, увидев незнакомые картинки :).

Интерфейс

Для начала ознакомимся с инструментами и средствами Dreamweaver'а. На рисунке ты видишь интерфейс проги; разумеется, на экран выведены не все панели, а только две, на мой взгляд, наиболее часто используемые при создании сайта.

Очевидно, что, если ты хочешь создать графический сайт с использованием всяких дополнительных медиа-объектов, то на одном Дримвивере далеко не уедешь. Приготовленные в других прогах картинки, флашки, апплеты и прочая дрянь:) вставляются с помощью панели Objects. Обращаю твое внимание, что среди таких встраиваемых объектов есть Fireworks HTML. Это ресурс, подготовленный в другой программе - специализированном графическом редакторе Macromedia Fireworks, который часто поставляется в пакете вместе с Dreamweaver'ом. Эти две проги наиболее тесно проинтегрированы между собой, и я смело рекомендую тебе использовать их вместе.

Вторая панель - Properties, в ней отображаются все свойства выделенного в текущий момент объекта - будь то текст, рисунок, ячейка таблицы и так далее. Естественно, здесь же их можно менять, делать картинки ссылками и проводить многие другие факирские манипуляции.

Иногда бывает нужно вручную подправить код HTML - в этом случае можно воспользоваться клавишей F10, и код в чистом виде к твоим услугам.

Создание сайта

Я понимаю, что тебе не терпится броситься в бой и сразу же стругать свой ресурс, но спешка может повредить качеству продукта выделения :). Вначале прогу надо настроить. Делается это через меню Preferences, вызываемую командой Edit->Preferences. Настроек много, и я назову самые существенные. Во-первых, font/encoding. Если вовремя не подсуетиться, то вместо русского языка получится поднадоевшая абракадабра.


Спецвыпуск Xakep, номер #015, стр. 015-050-2, Dreamweaver - король WYSYWIG'ов

Dreamweaver - король WYSYWIG'ов

Спецвыпуск Xakep, номер #015, стр. 015-050-2

Можно, конечно, в любое время изменить кодировку текущего документа (Modify->Page Properties), но, сделав это один раз в Preferences, париться больше не придется. Вторая важная настройка - Site FTP. Если ты хочешь забрасывать свои файлосы на сервер прямо из Dreamweaver'а, то настройка фтпэшника осуществляется именно здесь. Остальные параметры меню Preferences носят в основном характер оформления внешнего вида документов в самом редакторе и не влияют на то, как они будут отображаться в браузере.

Итак, настроились, плывем дальше. Я надеюсь, у тебя уже есть заготовки или хотя бы мысли по структуре твоего узла. В настройке, которую мы только что рассматривали (Site FTP), есть кнопоська Define Sites - нажми ее, чтобы определиться с сайтом и его структурой. После этого ты даешь проге всю инфу о своем проекте - его название, директория нахождения файлов :) и параметры закачки. В конце концов ты увидишь окошко Site, в котором и будешь осуществлять управление своим ресурсом - добавлять новые файлы, каталоги, менять названия, проверять на прочность ссылки.

Если ты вставляешь какой-нибудь объект на страницу, Дримвивер запрашивает твоего высочайшего разрешения скопировать этот файл в папку, которую ты отвел для текущего сайта. Не капризничай и соглашайся, в противном случае ничего тебе не будет - ни шашки, ни папахи, ни пайка :).

Features редактирования страниц

Вот теперь хватай инструменты и возись непосредственно с отдельными пагами, а я тихонько буду подсказывать. Начнем с глобального оформления страницы: Modify->Page Properties. Здесь есть возможность поменять титул страницы, бэкграунд, настроить цвет текста, ссылок, установить размер отступов. Кроме того, если ты полностью нарисовал пагу в графическом редакторе, то можешь использовать картинку как кальку, "обрисовывая" ее средствами Dreamweaver'а; что очень удобно, ползунком Image Transparency меняется прозрачность картинки - полезно понизить значение, если калька слишком яркая.

Теперь о навигации. Бывает целесообразнее сделать ее одной сплошной картинкой, а кнопки заставить функционировать такой технологией, как hotspots. Другими словами, наша пикчура разделена на регионы, некоторые из которых являются ссылками на другие страницы. Подготовь навигационную панель в своем любимом графическом редакторе и аккуратно вставь ее в Дримвивер. Теперь понадобится панель Properties. Сделай ее развернутой (там есть треугольничек в правом нижнем углу). Видишь слева внизу изображения прямоугольника, круга и полигона? В нашем случае понадобится круглый хотспот: выбери его и нарисуй круг прямо на картинке, акурат на изображении кнопки. В поле Link укажи соответствующий адрес. Теперь мышь при наведении на эту область в браузере будет знать, что это ссылка. Проделай эту процедуру и с остальными кнопками.

Как ты мог заметить, одна из кнопок посылает к фоткам. Здесь тебя ждет небольшой сюрприз: если у тебя установлена прога Fireworks, ты можешь автоматизированно создать Web-фотоальбом командой Commands->Create Web Photo Album, предварительно заполнив небольшую анкету пожеланиями по его оформлению. В итоге ты получишь страницу с thumbnails, то есть уменьшенными картинками, и по странице с элементами навигации на каждую пикчу.


Спецвыпуск Xakep, номер #015, стр. 015-050-3, Dreamweaver - король WYSYWIG'ов

Dreamweaver - король WYSYWIG'ов

Спецвыпуск Xakep, номер #015, стр. 015-050-3

Чтобы сделать картинку или текст ссылкой не на страницу, а на е-мейло, в поле Link панели Properties напиши mailto:адрес@почты.

Чтобы "сохранить единый стиль", который выражается в присутствующих на всех страницах одинаковых элементах (навигация, логотип, копирайт), разработчики предусмотрели использование шаблонов. Для этого, подготовив пагу с этим неизменяемым минимумом, сохрани ее командой File->Save as Template, а будущие страницы создавай так: File->New from Template.

Для некоторых целей используется конструкция Rollover Image - ты наводишь мышку на картинку, и она меняется. Ты легко найдешь эту фишку на панели Objects.

Если у тебя уже есть HTML-файл, состряпанный в Word'е, то можешь вставить его в Дримвивер и произвести зачистку лишних тегов командой Commands->Clean Up Word HTML. Я думаю, файл после этого сильно похудеет :).

Шлифовка

Иногда бывает так, что пага, блестяще выглядевшая в редакторе, превращается в скопище мутных разводов при загрузке в браузер. Виной тому обычно несоответствие шрифтов, установленных по умолчанию в Дримвивере, с одной стороны, и в ИЕ или Нетскейпе, с другой. Лучше всего заиметь привычку выставлять шрифты вручную, указывая их в тегах страницы либо в каскадных листах стилей. Для них, кстати, в DW предусмотрена отдельная панель - Windows->CSS Styles. Когда работы над страницей завершены, проверь ее в браузере командой File->Preview in Browser или кнопкой F12.

Для того чтобы установить совместимость твоих потуг с основными браузерами, есть замечательная Check Target Browsers в меню File. На выбор для тестирования предоставляются все поколения Нетскейпа и Експлорера, по окончанию выдается красочно оформленный подробный отчет о количестве ошибок с указанием оных.

Trial-версия (30 дней) этого замечательного продукта доступна для скачивания с официального сайта разработчиков - www.macromedia.com. Если есть желание более детально изучить тонкости работы с ним - дорога открыта: после Flash это, пожалуй, самый популярный продукт Macromedia в рунете. Учись, и удачных сайтов тебе, дед Макар :).


Спецвыпуск Xakep, номер #015, стр. 015-053-1, Трехмерное счастье Xara3D

Трехмерное счастье Xara3D

Matt (matt@nm.ru)

Спецвыпуск Xakep, номер #015, стр. 015-053-1

Даров, перец! Ну, признайся, часто ты испытывал оргазм или погружался в состояние нирваны при виде трехмерных кнопочек и вращающихся надписей на каком-нибудь сайте? И ты наверняка не однажды пионерил эти гифы и вставлял в свою пагу. Как нехорошо! Но теперь все, конец плагиату! Сегодня я тебе презентую рулезную программулинку для создания всей этой трехмерной красоты, которая называется Xara3D4 (четвертая версия, типа).

Was ist das?

Программка заточена под рисование трехмерного текста и больше делать ничего не умеет. Но оно тебе надо? Смотри, как она прорисовывает 3д буквы! Тебе понравится ;). Фишка в том, что при создании трехмерной надписи ты можешь менять абсолютно все параметры: цвет фона, цвет текста, цвет тени, цвет боковой грани, шрифт, его размер и все остальное. Проникся идеей? Ну, тогда поехали!

Хау ту старт?

Для начала, конечно, не мешало бы раздобыть где-нибудь эту прогу и проинсталлить ее у себя на тачке. Во-первых, ее можно найти на большинстве компактов, посвященных Интернету и веб-дизайну. Во-вторых, Ксару можно слить с ее же домашней страницы http://www.xara.com/xara3d/ и с практически любого файлового архива (freeware32.ru, ufa.com.ua). Весит она немногим более метра, так что сольется достаточно быстро. Готово? Тогда поехали дальше.

Ногу на "газ"!

Ну, вот ты уже запустил Ксару, и твоему взору предстала надпись "X3D" и невзрачненькое "4.0". Уже тащишься? Ничего, через 30 секунд там будет написано имя твоей герлы, через минуту текст будет ядовито красным, а через 3 - он будет еще и крутиться. Пристегни ремни! Понеслась, родимая!

"Газ" в пол!

Для начала в менюшке Window включи Toolbar, Text toolbar и Status Bar. Все это тебе пригодится и значительно облегчит твою участь. Перед началом своей 3д-аниматорской деятельности поднапрягись и придумай текст, который, собственно, и будет подвергнут зверским некро-педо-зоофильским опытам. Готово? Теперь нажимай на кнопку "Т" (можно и "Е") или меню Window=>Text и вводи плод своей извращенной фантазии. Если хочешь, чтоб текст шел в несколько строк, жми батон с ромбом. Как и в Ворде, можешь выделять конкретный текст и менять его свойства. Готово? Ай, молодца!

Начинаем экскременты!

Все, теперь можешь экспериментировать с надписью. На панели Text toolbar можешь изменять шрифт, его начертание, размер, горизонтальный и вертикальный интервалы между буквами и отношение высоты к ширине. ИМХО, самой интересной фичей здесь является прорисовка контура буквы (кнопка справа от "I"). Если душа просит увеличить ширину контура или другие параметры экструзии, жми Alt+E (или Window=>Extrude). Outline width - это и есть ширина контура. В этом же окне можешь поменять глубину своего текста (по оси Z) и убрать/добавить переднюю и заднюю "стенки" (но это только при выключенной прорисовке контура :-( ). Можешь также крутить-вертеть текст во всех плоскостях: просто хватайся за него мышом и тяни куда надо. Разобрался? Я горжусь тобой!

Буквы бывают разные: черные, белые, красные...

Пора, мой френд, пора сделать твою надпись ядовито-красного возбуждающего цвета. Для этого жми Window=>Color и смело воплощай все свои мечты в реальность. Здесь, я думаю, все понятно ;). Выбираешь в списке объект, цвет которого тебе хочется изменить, и здесь же, не отходя от кассы, меняешь его. Для надписи и фона можно выбрать из готовой библиотеки текстуру. Все текстуры хранятся в *.jpg, так что можешь на фон поставить фотографию себя любимого или Борьки Моисеева ;). Изменить все выставленные текстуры (плюс еще хз сколько их настроек) можно в Window=>Texture. Просто, как два пальца об асфальт! Двинули дальше.


Спецвыпуск Xakep, номер #015, стр. 015-053-2, Трехмерное счастье Xara3D

Трехмерное счастье Xara3D

Matt (matt@nm.ru)

Спецвыпуск Xakep, номер #015, стр. 015-053-2

Еще одна фича

Теперь заходи в Window=>Bevels и выбирай из 22 возможных скосов (переходов между гранями) полюбившийся тебе. Два переключателя внизу определяют, скруглять ли углы (Round - скруглять, Mited - нет). Еще ниже выбираешь размер скоса (это там, где Depth написано). Ok, чуть не окосели, но скосы организовали. Как бы еще надругаться над буковками?

Mr. Shadow

О! Дальше будем делать тень. По протоптанной тропе заходим в Window и находим там меню Shadow. Единственное, с чем могут здесь возникнуть вопросы - это с двумя последними числами. Так вот, там, где написано Transparency, - это прозрачность тени (100% - ее не видно), Blur - ее расплывчатость (0 - абсолютно четкая). При непреодолимом маниакальном желании передвинуть тень эту прихоть тоже можно осуществить, ухватившись за нее крысой и перетащив на новое место. Если при всех этих извращениях с тенями у тебя ничего так и не меняется, то растормозись слегка и сделай цвет фона и тени разными - должно помочь ;). Теперь работает? Значит, косметика овер!

Крутится, вертится...

А теперь то, ради чего ты это все читаешь - анимация. В качестве проверки усвоения изученного материала самостоятельно заходим в настройки анимации. Здесь пойдем по порядку:

1. Frames per cycle - количество кадров за цикл. То есть фактическое количество картинок, которое меняется. От этого параметра зависит размер будущего файла и качество фильма. Опять извечная дилемма: пить или не пить... в смысле, красиво, но увесисто либо саксово, но легковесно.

2. Frames per second - количество кадров за секунду. Я думаю, все понятно ;). Если ты в четвертом классе учил математику, то догадаешься, что если поделить первый параметр на второй, то получим время прохождения одного цикла. В общем, мало кадров - слайдшоу, много - слишком быстро.

3. Опции Gif. Первое - это пауза между циклами, а второе (loop) - количество оборотов. Если здесь галочку не ставить, то текст будет вращаться до посинения... или позеленения посетителя паги :).

4. Дальше выбираешь стиль анимации. Советую тебе последовательно перебрать все варианты - ничего сложного здесь нет. Потыкаешь мышкой по разным кнопкам, повводишь разные цифры и оценишь всю силу и мощь данного инструмента. Один совет: если хочешь использовать последний стиль Step, то текст нужно сделать многострочным. А до остального, я думаю, ты со своими гигагерцевыми мозгами сам дойдешь ;). Чтобы запустить анимацию и воочию созерцать всю сочиненную тобой красоту, нажимай Ctrl+пробел и радуйся возможностям современной техники.


Спецвыпуск Xakep, номер #015, стр. 015-053-3, Трехмерное счастье Xara3D

Трехмерное счастье Xara3D

Matt (matt@nm.ru)

Спецвыпуск Xakep, номер #015, стр. 015-053-3

Печем батон

Вертится? Молоток! Теперь будем учиться рисовать батоны. Наука невелика ;). Как всегда - Window=>Button (или Alt+U). В первую голову, конечно, ставь галочку напротив Button. Дальше в самом низу находи кнопку Import Button и уверенно жми на нее указателем крысы. Ну вот, ты выбрал полюбившуюся тебе извращенную форму кнопки и теперь можешь смело растягивать ее с помощью параметра Stretch (значение=ширина/высота*100%). Зачем параметр Corners, знаешь? Угадал: чтобы скруглять и заострять углы. Ну что, арбайтен?

Воплощение

Все! Нарисовал, разукрасил, вытянул, раскрутил. Теперь все это трехмерное счастье надо бы куда-нибудь сохранить, дабы можно было его безгранично эксплуатировать в своих страницах и программах. Если ты видишь перспективу изменения твоего произведения искусства, то нажимай File=>Save и сохраняй непосредственно проект Ксары. А если ты уже созрел вставлять данный шедевр в пагу, то тебе нужно File=>Export bitmap (или Export animation, соответственно).

Канецъ

Все! Краткий курс введения в специальность аниматора ты прослушал/прочитал. Теперь ты мега крут, и теперь у ТЕБЯ все будут пионерить вращающиеся надписи и трехмерные кнопки ;). И это есть гут! Усе, пишите письма.


Спецвыпуск Xakep, номер #015, стр. 015-055-1, Взлом и защита DNS-сервера

Взлом и защита DNS-сервера

UFO (ufobject@mail.ru)

Спецвыпуск Xakep, номер #015, стр. 015-055-1

Представь себе такую ситуацию: лезет твой учитель по информатике во время очередного урока на свой любимый сайт www.microsoft.com, а вместо этого попадает на www.hardporno.ru! Представил? А знаешь, что это? Это результат успешной DNS-атаки. Что, заинтересовался ;)? Тогда слушай сюда.

Служба DNS

Сначала нам с тобой придется разобраться с принципом работы DNS-серверов, а то дальше ничего не будет понятно. Вот, скажем, ты хочешь зайти на какой-нибудь сайт. Что ты делаешь первым делом? Совершенно верно - набираешь адрес, типа www.rulezsite.ru. Твой комп в это время посылает пакет с запросом на DNS-сервер, адрес которого устанавливается при настройке твоей ОС. В пакете содержится буквенный алиас ресурса, набранный тобой (иначе говоря, доменное имя - rulezsite.ru). После получения DNS-запроса DNS-сервер начинает искать в своей базе данных IP-адрес, соответствующий запрошенному тобой домену. Если такого имени в своей базе сервер не находит, он пересылает запрос другому DNS-серверу. Если нужный IP-адрес находится, то он отправляется твоей машине. Теперь браузер знает IP'шник запрошенного тобой ресурса и начинает соединение с ним. На первый взгляд, все логично и правильно, но у этой схемы имеются свои уязвимые места ;).

Атака в тепличных условиях

Первый тип DNS-атаки - это создание обманного DNS-сервера вследствие перехвата запроса. Страшно звучит :)! Но как говорится - "не так страшен Гейтс, как его Windows". Сперва я расскажу про UDP-протокол, по которому работают DNS-сервера. Этот протокол сильно уязвим по сравнению с TCP. Все дело в том, что UDP не предусматривает средства идентификации своих сообщений (в отличие от TCP). Но это еще не все... С каждым переданным запросом в поле "порт отправителя" начальное значение 1023 увеличивается на единицу. Но и это еще не все! В UDP-пакетах существует поле ID, которое является идентификатором DNS-запроса. Если ты юзаешь Windows9x или Linux, то их командный интерпретатор оставляет значение поля ID, равное единице, а вот если у тебя стоит Netscape Нафигатор, то это поле с каждым новым запросом увеличивается на единицу. Также ведет себя и DNS-сервер: увеличивает на единицу поле ID. А вот теперь начинается самое интересное :). Предположим, что некий Василий Пупкин решил перехватить DNS-запрос несчастного пользователя и перевести его трафик на себя (вернув в ложном DNS-ответе свой IP вместо настоящего). Естественно, без ложного DNS-сервера ему никак не обойтись. Вначале ему придется ждать DNS-запроса, который должен быть послан с клиентской тачки (с тачки жертвы). Василий извлекает из перехваченного пакета IP-адрес запросившего хоста. Затем он генерирует пакет, в котором представляется DNS-сервером, который был запрошен удаленным хостом. А как он это делает? Да очень просто. В этом ложном ответе, в поле IP DNS-сервера, Василий ставит свой собственный IP. Теперь запросивший хост принимает Пупкина за настоящий DNS-сервер. Когда Василий получит новый пакет с запросом от хоста, он поменяет в нем IP-адрес отправителя и перешлет этот измененный пакет на настоящий DNS-сервер. В итоге получается, что Вася является как бы посредником между DNS-сервером и обманутым хостом. Теперь настоящий DNS-сервер думает, что сам Вася посылает запросы, а хост считает, что Вася является натуральным и без консервантов DNS-сервером :). Остался только один вопрос: а как же перехватить этот запрос от атакуемого хоста? Перехват возможен только в том случае, если атакующая машина находится на пути основного трафика или в сегменте DNS-сервера. Это основной минус такого типа атак :(.


Спецвыпуск Xakep, номер #015, стр. 015-055-2, Взлом и защита DNS-сервера

Взлом и защита DNS-сервера

UFO (ufobject@mail.ru)

Спецвыпуск Xakep, номер #015, стр. 015-055-2

У нас руки длинные!

Рассмотрим теперь другой способ реализации DNS-атаки - создание ложного DNS-сервера на компьютере Василия Пупкина путем безбожного закидывания атакуемого хоста ложными DNS-ответами. Представь себе, что Василий не попал в сегмент DNS-сервера и не находится на пути основного трафика. Ну и что же теперь ему делать? Не оставлять же все как есть :)! Вот мы ему сейчас и поможем... Помнишь, я рассказывал про недостатки протокола UDP, которым пользуются DNS-сервера? Вот нам сейчас это пригодится. Вот что необходимо для того чтобы сгенерировать DNS-ответ:

1. Совпадение IP-адреса отправителя ответа с IP-адресом DNS-сервера.

2. Должны совпадать имена, содержащиеся в DNS-ответе и DNS-запросе.

3. DNS-ответ должен посылаться на тот же порт, с которого посылался запрос.

4. В пакете DNS-ответа поле ID должно совпадать с полем ID в запросе.

Это основные условия, которые необходимо соблюдать Василию Пупкину для реализации удаленной DNS-атаки. Если с первым и вторым пунктами проблем не возникнет, то с третьим и четвертым траблы будут. Как нам угадать, с какого порта посылался запрос? Естественно, сразу это сделать не получится. Остается только способ грубой силы, то есть - перебор. Эта задача облегчается тем, что науке уже давно известно, что порт отправителя запроса меняется только в положительную сторону, то есть плюсуется. Так как изначальное его значение - 1023, то просто перебираем это значение путем увеличения его на единицу. Вроде как с этим разобрались, но осталась еще одна проблема - поле ID в пакетах DNS-ответа и DNS-запроса. С этим дело обстоит немного полегче. Как уже было сказано ранее, это поле либо равно единице, либо близко к нулю (в случае использования Netscape Нафигатора). Соответственно, проблема решается таким же перебором. Ок, а что теперь-то делать? А вот теперь приступаем к самой атаке. Предположим, что некий Билл решил зайти на свой любимый сайт www.porno.ru. Василий Пупкин никак не может ему этого позволить, так как на этом сайте содержится фотография его девушки в обнаженном виде! Василий начинает в темпе генерировать пакеты с ложным DNS-ответом и посылает их непрерывным потоком на комп к Биллу. Естественно, Василий так и не узнает, когда был послан запрос на DNS-сервер, но ему это и не нужно. После того как Билл послал запрос на DNS-сервер, его комп пытается поймать DNS-ответ, но вместо этого принимает шторм ложных пакетов с хоста Василия. Все неправильно сгенерированные пакеты отметаются компьютером Билла, а принимается только тот пакет, в котором совпали номер порта отправителя и поле ID. Все. Ложный DNS-ответ принят. Теперь Билл будет посылать свои дальнейшие запросы не на DNS-сервер, а на компьютер Пупкина. Василий, в свою очередь, в ложном DNS-ответе может вставить IP-адрес любого ресурса и тем самым направить Билла не на желаемый www.porno.ru, а на любой другой сайт. Вот так вот! Сложно? Это тебе не плюшки со стола тырить :).


Спецвыпуск Xakep, номер #015, стр. 015-055-3, Взлом и защита DNS-сервера

Взлом и защита DNS-сервера

UFO (ufobject@mail.ru)

Спецвыпуск Xakep, номер #015, стр. 015-055-3

Всех положим!

Эх! Не обделил вниманием величайший хакер - Василий Пупкин - и сам DNS-сервер. Мало ему пострадавшего Билла, которому Василий не дал посмотреть любимый порносайт, так надо и всем остальным жизнь испортить. Настало время рассказать тебе историю про то, как Василий изменил маршрутную информацию на самом DNS-сервере, и теперь не только Билл не может попасть на www.porno.ru, но и все остальные пользователи DNS-сервера! Чтобы понять, как реализовать такой тип атаки, необходимо сначала понять принцип общения одного DNS-сервера с другим. Этим мы сейчас и займемся. Предположим, что некий Билл посылает запрос на ближайший DNS-сервер, в котором просит найти IP-адрес, соответствующий урлу www.lohotron.com. Допустим, что до Билла на этот DNS-сервер такого запроса никто не посылал. DNS-сервер начинает копаться в своем кэш-файле, где он хранит ответы на наиболее частые запросы и, не найдя IP-адреса, соответствующего домену lohotron.com, начинает искать его в своей базе. Не найдя ничего полезного и в базе, DNS-сервер посылает запрос на другой DNS-сервер. Эта цепочка продолжается до тех пор, пока IP либо не обнаружится, либо совсем не потеряется. В случае нахождения IP'шки по запросу хоста DNS-сервер заносит его в свой кэш-файл и в свою базу. Затем DNS-сервер передает информацию о местонахождении найденного урла соседним DNS-серверам и запросившему хосту. Вроде бы все весело и безопасно, но и здесь есть свои баги. Предположим, что Василий Пупкин захотел испортить всем жизнь и сделать так, чтобы люди попадали вместо www.lohotron.com на www.pupkin.ru. Думаешь, нереально? А зря. Очень даже реально, но, естественно, при определенных условиях. Для такого типа атаки необходимо, чтобы атакуемый DNS-сервер послал запрос на соседний DNS-сервер. Естественно, для этого нужно дождаться запроса, который поступит от любого пользователя на DNS-сервер. Эта проблема может быть решена посылкой запроса самого Василия Пупкина на атакуемый DNS-сервер. Предположим, что Василий послал нужный запрос, что делать дальше? А дальше атакующий Пупкин начинает посылать шторм пакетов UDP-протокола, в которых содержится ложный DNS-ответ якобы соседнего DNS-сервера, на который атакуемый DNS-сервер должен послать запрос. Даже при соблюдении всех тепличных условий для этого типа атаки остается одна проблема. В этой статье уже неоднократно говорилось про поле ID в UDP-пакетах для DNS-запроса и DNS-ответа. Это поле используется для проверки подлинности запросов. "А куда же делась вторая проблема с портом отправителя и получателя?" - спросишь ты. А нет ее. Дело в том, что DNS-сервера обмениваются между собой маршрутной информацией через фиксированный порт 53. Атакующему перцу остается только подобрать двухбайтный ID, и, в случае совпадения с реальным идентификатором, ложный DNS-ответ принимается атакуемым DNS-сервером как настоящий. Атакующему остается только вставить в ложном DNS-ответе тот IP-адрес, который он хочет присвоить запрошенному урлу. Вот и весь принцип атаки удаленного DNS-сервера. Так же, как и предыдущий способ атаки, это можно проделать из любой точки сети.


Спецвыпуск Xakep, номер #015, стр. 015-055-4, Взлом и защита DNS-сервера

Взлом и защита DNS-сервера

UFO (ufobject@mail.ru)

Спецвыпуск Xakep, номер #015, стр. 015-055-4

Защитим свои DNS!

Существует такое правило - чем дружелюбнее система к пользователю, тем легче ее взломать. Соответственно, чем меньше в ней наворотов, тем сложнее под нее подкопаться. Система DNS, к сожалению, исключением не является. Как ни крути, а для защиты от такого типа DNS-атак придется усложнить жизнь либо пользователям сети, либо админу. В первом случае юзерам просто придется отказаться от услуг службы DNS. Безусловно, это создает огромные неудобства: ведь намного легче запомнить домен vasilypupkin.com, чем IP-адрес 212.188.134.19. Конечно же, можно частично нормализовать эту ситуацию, создав на клиентских компах как бы собственные небольшие базы данных DNS. Но это не выход, так как юзеры смогут пользовать только те домены, которые в базе их машины имеются. А полноценную базу DNS на клиентской машине не подержишь, да и нецелесообразно все это.

Второй и, как мне кажется, более оптимальный способ избежания DNS-атак - это перевод DNS-сервера с UDP-протокола на TCP, который лучше защищен от атак. Вот тут начинаются геморрои админа :). Для реализации данного способа защиты ему придется долго и упорно копаться в ОСе и перелопачивать все своими руками ;).

Не кури и не пей, а то будешь как я :)

Не все, прочитав эту статью, смогут вот так сразу реализовать DNS-атаку, но, как я уже говорил, легко - значит коряво. Мой тебе совет: изучай кодинг, копайся в мануалах и не бойся трудностей. Это как игра, как квест! Что-то не получается, охота забить и заняться чем-нибудь еще... Но если ты все-таки упрямый и добился своего, то тебя ждет неописуемая радость ;)! Да к тому же всегда можно найти людей, которые помогут... Если только их нормально попросить ;). И вот еще что... Не советую я тебе портить жизнь обычным юзерам. Не исключено, что в один прекрасный момент в твою дверь постучатся люди с корочками, и у тебя начнутся проблемы :(. Лучше займись защитой, а не взломом - это намного сложнее, интереснее, и на этом ты можешь заработать большие деньги. В общем, привет тебе из далекого космоса!


Спецвыпуск Xakep, номер #015, стр. 015-057-1, Тетя Ася приехала... с семьей

Тетя Ася приехала... с семьей

Andrew Fadeev (andrewf@ukr.net)

Спецвыпуск Xakep, номер #015, стр. 015-057-1

Наступление

Привет, интернетчик! Давно все знают, что человек стал таким только благодаря своему умению общаться. Это умение он (мы) развил до того, что только и думает, где бы потрепаться. Появление Интернета позволило людям общаться через границы и океаны. Но вот беда, e-mail есть относительно медленный способ связи (письмо может идти аж от целой минуты до нескольких дней). Потом придумали чаты и IRC. Но и этого оказалось мало! В IRC все должны быть в онлайне одновременно, а оставить сообщение оффлайн другу можно, но эта возможность не развита.

Вася, купи пейджер!

Я не буду вдаваться в подробности развития служб обмена сообщениями, а начну свой обзор первой удачной попыткой и продолжу его другими популярными программами для общения. Как модно сейчас писать, тестирование проводилось на Windows XP Professional English. Это было сделано, чтобы проверить совместимость прог, а еще потому, что MSN Messenger 4.5 есть только под XP. Так как, кроме MSN Messenger, ни одна из программ не поддерживает новые темы Windows, был выбран интерфейс Windows Classic для того чтобы, кроме обычных кнопочек, были и обычные рамочки окон - гармония :). К обзору каждой программы будет прикладываться информация о том, для каких платформ (включая мобильные) существуют клиенты. Я имею в виду только официальные версии. Неофициальных клиентов в Интернете достаточно, в том числе универсальных. Да! Для тестирования каждой программы я создавал новый аккаунт, так что все номера уже не существуют, а по величине контакт-листа ты не определишь, какой программой пользуюсь я ;).

ICQ

Версия: 2001b

Живет здесь: www.icq.com

Платформы: Windows 3.1/9x/ME/NT3.5/CE/NT4/2K/XP; PalmOS; Java; PowerMAC; Mac 68k

Ну, что сказать? Самый известный и популярный Интернет-пейджер. Огромное количество фич, юзеров и рекламы. Вот недавно тетя Ася отмечала 5-летний юбилей. Теперь она говорит и не гадит в Windows. В программе реализован очень удобный поиск по базе юзеров. Искать собеседников можно по совпадающим интересам, а можно искать известных тебе людей по имени или мылу. Сообщения можно отправлять (принимать) не только от пользователей ICQ, но и по e-mail или даже перекидываться SMS сообщениями с мобильными телефонами! Причем тебе как пользователю ICQ присваивается номер в виде +2783142<твой номер ICQ>, то есть чтобы отправить с мобильника сообщение на ICQ, особо заморочиваться не надо: достаточно написать текст и кинуть мессагу по номеру телефона. Также возможно общение голосом, но так как это происходит через отдельный сервер и программу, надо отдельно регистрироваться, и работает это из рук вон плохо. Дополнительных функций вагон и маленькая тележка. Плохо только, что в новой версии эту тележку надо качать отдельно. То есть кликаешь на пункт меню, а она тебе: "Download?". Сейчас я опишу основные функции Аськи, которые в целом применимы для всех программ обзора, так что потом повторяться не буду. Программа позволяет перекидываться сообщениями как в онлайне, так и отправлять их до востребования юзерам в оффлайн. Можно организовывать чаты на несколько участников, можно перекидываться файлами, минуя основной сервер, то есть устанавливая прямой коннект, что, в общем, быстрее. Если ты в сети, можешь менять свой статус с "доступен" на "занят" или "вышел". Кстати, в версии 2001b появилась новая фича - огроменная дырка для хакера: механизм расшаривания файлов (типа Напстера или даже встроенного механизма виндоза).


Спецвыпуск Xakep, номер #015, стр. 015-057-2, Тетя Ася приехала... с семьей

Тетя Ася приехала... с семьей

Andrew Fadeev (andrewf@ukr.net)

Спецвыпуск Xakep, номер #015, стр. 015-057-2

Плюсы: негласный стандарт, годы отладки сделали из Аси стабильный продукт, миллионы юзеров, много функций.

Минусы: огроменное количество баннеров и прочей рекламы (в основном себя), из-за бешеной популярности странные сообщения от незнакомцев (зацени картинку с первым сообщением, которое я получил после регистрации).

Odigo

Версия: 3.1

Живет здесь: www.odigo.org

Платформы: Windows 9x/ME/NT4/2k/XP; Web-based Java; WAP-версия (для мобильников)

Следующая программа из семейства разговорчивых. Хотя основная идея осталась та же - общаться, но вот исполнение очень оригинальное. Основано оно на том, что, заходя на любой сайт, в окошке программы ты видишь всех пользователей Odigo, тусующихся на той же паге. Там же есть возможность выбрать юзера, посмотреть его карточку, поговорить с ним, зайти в комнату чата, привязанную к сайту, или оставить объявление для его посетителей. Есть также очень грамотно сделанный поиск по интересам. А вот поиск пользователей по имени можно было сделать и лучше. Благодаря тому, что прога знает, на каких сайтах сколько людей, в ней есть экранчик, где она строит график популярности Интернет-ресурсов. В своем статусе, кроме обычного доступен/занят, можно еще указать свое настроение и для чего вышел в онлайн. Да, заполняя информацию о себе, можно еще выбрать картинку, "выражающую внутреннюю сущность" тебя любимого ;). В последних версиях Odigo появились тематические каналы типа интересного видео или погоды. Также на сайте есть множество плагинов для Odigo, чтоб он мог быть еще и клиентом ICQ, MSN Messenger и других.

Плюсы: благодаря этой концепции, очень легко найти себе новых друзей; минимум рекламы; встроенная рейтинговая система сайтов, разбитая по категориям, в отличие от обычного поисковика, ты видишь, что РЕАЛЬНО популярно у пользователей; возможность сделать из Odigo универсального клиента, однако он не обеспечит всех возможностей оригинального.

Минусы: странные и назойливые звуки схемы по умолчанию.

Windows Messenger

Версия: 4.5

Живет здесь: messenger.microsoft.com

Платформы: Windows XP (версии до 3.1 под все винды), Mac, Pocket PC (WinCE)

Вот и Microsoft решила не отставать. Набор функций стандартный плюс поддержка голосовой связи и веб-камер. Прикольный интерфейс. Вся регистрация - это получение ящика на Hotmail, так что если он у тебя уже есть, то тебе осталось только скачать клиента. WM полностью интегрирован с Hotmail и Windows XP. Как только тебе приходит сообщение на почтовый ящик, из трея вылезает окошко с уведомлением. Удобно. Вот только я Хотмайлом не пользуюсь :). Хотя как поставил XP, на всякий случай зарегистрировался. Юзеры в основном американские. Поиск дурацкий, да еще добавить не дает: говорит, я обязательно должен знать e-mail, иначе - не-а, а вдруг я спамер. Из-за этого пообщаться ни с кем не удалось :(. А мне казалось - я не спамер...


Спецвыпуск Xakep, номер #015, стр. 015-057-3, Тетя Ася приехала... с семьей

Тетя Ася приехала... с семьей

Andrew Fadeev (andrewf@ukr.net)

Спецвыпуск Xakep, номер #015, стр. 015-057-3

Плюсы: если у тебя Хотмайл ящик, то это есть отличная утилита для проверки почты; полная мультимедийность; веселенький :) дизайн.

Минусы: мало активных юзеров (думаю, тотальный переход на XP это исправит), странный поиск.

Yahoo! Messenger

Версия: 5.0

Особенность: ActiveX апплет на сайте сам все скачает и установит, чтобы маленькие не боялись.

Живет здесь: messenger.yahoo.com

Платформы: Windows 9x/ME/NT4/2k/XP; Mac; Linux; Palm; Windows CE; WAP.

Еще одна попытка догнать трамвай ;). Стандартный виндовый интерфейс с закладочками. Поиск странноватый, юзеров маловато. Зато есть окошки, где можно посмотреть курсы валют, биржевые котировки, погоду и новости. Все, конечно же, берется из портала Yahoo! Из интересных функций отметим IMVironments - интерактивные фоны для высокоинтеллектуальных бесед. Ты себе говоришь, а на заднем плане плавают рыбки, играет музыка или падает снег. Таких "окружений" с сайта программы можно скачать много. Еще можно отправлять сообщения самому себе :).

Плюсы: интересный механизм IMVironments; показывает погоду; хорошая утилита для пользователей Yahoo Mail.

Минусы: мало юзеров.

AOL Instant Messenger

Версия: 4.7

Живет здесь: www.aol.com/aim

Платформы: Windows 9x/ME/NT4/2k/XP; Mac; Linux; Palm; Windows CE; WAP.

Первое, что бросается в глаза - интерфейс. Напоминает первую программу в учебниках - Hello World :). Все как обычно, ничего нового. Зато можно отправить сообщение самому себе :). Анти-спам механизм: ты не можешь отправить несколько сообщений подряд. Юзер, с которым ты разговариваешь, может послать тебе Warning, этим увеличивая твой соответствующий показатель. Как только он переваливает за некоторое значение, система тебя блокирует. Так что можно подкладывать свиней друзьям. А что, американская демократия;)! Поиск только по интересам. Юзеры американские, да и тех мало. На некоторые интересы (в других пейджерах популярные) выдает 0.

Плюсы: еще одна статья дохода для AOL.

Минусы: минимум юзеров; неудобный поиск; интерфейс в стиле "меньше едешь, тише будешь".

Ну и чего? Или выводы

Как видишь, программы в основном одинаковые. Хотя правильно - велосипед-то один:). Odigo представляет иную организацию поиска юзеров и рейтинга сайтов. ICQ - классика жанра, а творение Microsoft только набирает обороты и может выехать за счет нового поколения карманных компьютеров с ее осью и из-за впаривания программы с XP. В арсенале Yahoo красивые задники и поддержка со стороны огромного портала. AIM (имхо, аутсайдер) еще живет, так как входит в поставку программного обеспечения провайдера AOL и за счет того, что его вкладывают как дополнительный софт к Palm'ам. Хотя зачем AOL'у AIM, неясно - они же купили ICQ.

Тайна

Ладно, я все-таки скажу, кого я оставил себе. Оставил себе я ICQ, так как ею я давно пользуюсь, и Odigo. И я не удалял Windows Messenger из своей XP - пусть будет, может, вырастет. Гневные письма от поклонников "чего-нибудь другого" принимаются - буду доказывать ;). Пока!


Спецвыпуск Xakep, номер #015, стр. 015-059-1, Обзор считалок

Обзор считалок

Доджик (dodge@xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-059-1

В последнее время я стал замечать все больше и больше страниц, в нижних частях которых расположено огромное или, другими словами, немыслимое количество счетчиков. Ведь по сравнению с прошлым годом число поисковых серверов увеличилось примерно на 1/3, и их число продолжает расти в геометрической прогрессии. И если ты уже пытался сделать свою страницу, то наверняка понял, о чем я. Иначе говоря, ты столкнулся с огромным выбором, не так ли? Конечно, такие гиганты, как Rambler, Top Mail и Spy Log, находятся вне конкуренции и, соответственно, присутствуют почти на каждой странице, ибо они широко известны и авторитетны в российской сети, но тем временем мало кто знает об их огромных минусах. А помимо них есть и другие рейтинги, и их не мало. О некоторых ты уже слышал, о существовании других ты и не подозреваешь, а третьи уже давно перестали функционировать. Кажется, тебе пора обновить свою "базу данных" перед созданием своего ресурса - пригодится.

Mafia's Top 100

www.top.mafia.ru

Ресурс Mafia появился относительно недавно, но уже успел завоевать немалое количество пользователей и прочно обосноваться в Рунете. Правда, многие крупные порталы до сих пор продолжают отказываться от услуг Мафии в пользу лидеров. Отсюда следует, что в основном данный ресурс очень популярен среди создателей домашних страничек, так как занять первые места в некоторых подкаталогах, имея посещаемость порядка пятидесяти хостов в день, не составляет труда. Поэтому-то он всем и нравится - приятно ощущать себя лидером. Пускай в маленьком подкаталоге, но лидером. На момент написания статьи в рейтинге насчитывалось около 30000 пользователей. Все участники расфасованы среди 51 категории (подкаталогов) по соответствующим тематикам. Но, как это ни странно, никакого Топ 100 я здесь не нашел. При нажатии на ссылку "Top 100" ты вернешься на все тот же индекс, странно...

При регистрации своего ресурса у меня никаких проблем не возникло, а после таковой все мои ранее введенные данные редактировались без проблем. После регистрации на мое мыло должен был придти код счетчика, но ничего подобного не наблюдается уже в течение недели. Дизайн же самого счетчика, как, впрочем, и самого сайта, оставляет желать лучшего. Выбор счетчиков довольно скудный, но все-таки присутствует - только однотипные они все, различие наблюдается только в цветовой гамме. А за своей статистикой наблюдать сможет не только админ рейтинга, но и простой смертный, который догадается нажать на "плюсик" рядом с названием сайта.

Super Top

www.supertop.ru

Данный ресурс тоже не из элитных, но все-таки внимания заслуживает. Опять-таки же Super Top игнорируется "гигантами" Рунета - а значит, в рейтингах участвуют все те же любительские сайты и сомнительные порталы. В отличие от предыдущего ресурса, здесь присутствует тот самый Топ 100. Все зарегистрированные пользователи расфасованы среди 12 подгрупп для удобства поиска, а общее число участников на момент написания статьи составляло около 22600. Регистрация прошла без проблем, и уже через несколько секунд данные о моем сайте можно было редактировать, а статистику просматривать. К сожалению, она доступна всем, кто знает мой ID, а узнать его - проблем нет, просто посмотри html-код страницы. Но и это еще не все. Здесь под громоздким словом "статистика" скрывается не что иное, как просмотр количества посетителей за каждый час (за сегодняшний и вчерашний дни). С дизайном же немного лучше, чем у Мафии, - всего 3 вида счетчика, зато более-менее красивые и приятно воспринимающиеся. Сам сайт тоже довольно симпатичный и быстрый, что нельзя сказать о предыдущем.


Спецвыпуск Xakep, номер #015, стр. 015-059-2, Обзор считалок

Обзор считалок

Доджик (dodge@xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-059-2

Rambler

www.rambler.ru

Думаю, было бы глупо не включить в обзор самый известный и посещаемый рейтинг в Рунете. Согласен, что о Rambler'e слышали все, но мало кто знает о нем что-то более конкретное, чем "это очень хороший рейтинг". Все не так хорошо, как кажется в первое время. Зарегистрироваться мне удалось раза с двадцатого, так как сервер был перегружен и отказывался работать. Но я упорно настаивал на своем, и у меня все-таки получилось. При регистрации пришлось заполнить довольно большую и глупую анкету. Информация о регистрации очень быстро оказалась в моем почтовом ящике, что приятно. Но когда я полез менять свои настройки, оказалось, что я могу изменить все свои данные, кроме самого главного - адреса ресурса. Это, как мне кажется, очень существенный минус. Но все-таки у Rambler'а были найдены и плюсы. Например, дизайн сайта сделан достаточно качественно. Отдельное внимание надо уделить дизайну счетчиков - здесь 32 варианта, можно подобрать под любой фон твоего ресурса. Сам рейтинг Топ 100 внушает отдельное доверие, в нем собраны все крупные ресурсы Рунета. Кстати, на момент написания материала в системе было зарегистрировано 296000 пользователей, а разбиты они по 56 подгруппам.

Статистика сайта доступна сразу же после регистрации и представляет собой пускай не очень подробную, но весьма полезную информацию. При регистрации указывается, будет ли твоя статистика доступна всем или только тебе.

Spy Log

www.spylog.ru

Этот рейтинг появился всего 2 года назад и уже стал самым популярным и одним из самых авторитетных в сети. Возможно, именно поэтому создатели сайта почесали репу и подумали, что "неплохо было бы сделать рейтинг платным и заработать еще больше". Так и случилось. И теперь Spy Log почти весь платный. Но осталось кое-что и бесплатное, этот пакет услуг носит скромное название "кроха". Регистрация "крохи" прошла успешно, быстро и без проблем. Кстати, существование сайта здесь не проверяется, как в Rambler'e, и поэтому мне удалось зарегистрировать несуществующий сайт. А после регистрации я мог просматривать свою статистику и делать еще кучу настроек. Здесь есть масса возможностей, которых не предлагают конкуренты. Например, можно просматривать статистику отдельных рубрик сайта - таким образом ты сможешь узнать, куда именно ходят твои посетители, понять, что им нравится, а что не очень, - и сделать выводы. Очень полезная услуга. Идем дальше. Просмотр информации о своей статистике ты можешь запретить простому люду, ты можешь даже выкинуть сайт из рейтинга, а можешь его оставить просто в списке без участия в "соревнованиях". Кстати, устанавливать счетчик ты можешь не только на html-страницах, но и на SSL! Да и счетчик не стыдно устанавливать - не уродский, а весьма привлекательный с множеством креативных решений (выбор очень большой и своеобразный). А сам сайт Spy Log'a хоть и красивый, но грузится удивительно быстро, что в Рунете бывает крайне редко.


Спецвыпуск Xakep, номер #015, стр. 015-059-3, Обзор считалок

Обзор считалок

Доджик (dodge@xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-059-3

Рейтинг@mail.ru

www.top.mail.ru

Вообще-то, я направлялся на рейтинг Top List, но с удивлением обнаружил, что теперь данный ресурс под контролем Mail.ru. Но не все так уж и страшно - оказывается, сменился только хозяин, а великолепный рейтинг остался таким же, сменив лишь внешний вид счетчика, дизайн своего сайта и адрес. А остальное осталось девственно нетронутым. Но обо всем по порядку.

Регистрация прошла без проблем, не понравился только тот факт, что регистрация здесь "пошаговая". В случае с остальными рейтингами, где я мог спокойно отключиться от сети и, не торопясь, все заполнить, здесь пришлось всю операцию проводить в режиме он-лайн. Зато, зарегистрировавшись, я получил огромный выбор возможностей, связанных со статистикой своего сайта. Все эти возможности, естественно, доступны только мне (если бы я не авторизовал их для всеобщего пользования- как понимаешь, я этого делать не стал). А теперь немного о самих возможностях. Они остались такими же, как и были при старом хозяине. Кроме всяких банальных услуг ("время визитов", например), которые присутствуют абсолютно у всех рейтингов, есть еще и весьма полезные фичи. Например, с помощью данного счетчика ты сможешь узнать, из каких стран ходят к тебе посетители, какие у них браузеры, какого они пола (шутка, естественно), и многое другое. На первый взгляд, все это мелочи, но иногда может серьезно помочь - да и потом это просто интересно знать.

Но есть справедливый минус: если твой ресурс за месяц не посетит ни один человек - ты будешь с позором исключен. Правда, зарегистрироваться еще раз не составит проблем.

А дизайн счетчиков, признаться, мне не понравился - видел и получше, хотя выбор все-таки есть. Что же касается рейтинга, то он здесь достаточно огромный, но подкаталогов всего 17. Кстати, на индексе сайта присутствует "9 лучших новичков" и "9 лучших". Почему разработчики выбрали именно число девять - остается загадкой. Но всеобщий Топ тоже существует, в нем участвуют все сайты, имеющие хотя бы одно посещение в течение суток. Вот так здесь все умно придумано ;).

One.ru

www.one.ru

Ничего особенного в этом ресурсе я не заметил. Соглашусь, пожалуй, только с тем, что сайт грузится быстро и... наверное, все. На этом плюсы заканчиваются и начинаются минусы. Во-первых, мне опять-таки удалось зарегистрировать левый ресурс, которого нет в природе. Во-вторых, никаких дополнительных услуг в статистике нет: банальные хосты "по часам", "по дням", "за неделю" и тому подобное. Ничего нового. Дизайн счетчика, правда, неплохой, но толку-то от него? Дорогие разработчики, зачем делать подобный ресурс, если вы не можете предложить что-то лучшее, чем уже есть в сети?


Спецвыпуск Xakep, номер #015, стр. 015-059-4, Обзор считалок

Обзор считалок

Доджик (dodge@xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-059-4

Тем не менее регистрация прошла быстро и успешно, никаких сбоев не возникло. И уже через минуту мой вымышленный сайт участвовал в рейтинге.

UP.ru

www.up.ru

Я не понимаю людей, которые создают подобные ресурсы и кричат, что они - лучшие. И если бы это был хит-парад, я бы поставил данный рейтинг на самое последнее место! Это - действительно отстой, а не рейтинг! Я даже зарегистрироваться не смог. Сначала радовался, что это один из немногих счетчиков, который проверяет сайт на существование. Но когда начал регистрировать реальный сайт, оказалось, что это не моя вина. Возможно, это был день, когда в регистрации всем было отказано, и мне посчастливилось регистрироваться именно тогда. Ну что ж, успехов разработчикам и дальше.

Тем не менее я посмотрел хит-парад ресурса. На первых местах, как я и ожидал, оказалось что-то вроде "2000 долларов в день от В. Пупкина". Мне тут же захотелось вернуться назад, и для этого вверху страницы я нажал линк "up.ru", но попал почему-то на 55.ru - какой-то хренов интернет-магазин. Ради интереса я повторил забавную операцию и опять попал в магазин, а потом еще и еще. Круто! Сейчас еще пойду потыкаю...

Кстати, это далеко не единственный баг на сайте. Когда я пытался посмотреть статистику избранных сайтов, я все время попадал, мягко говоря, "не туда". Понятное дело, что до статистики я так и не добрался. Ну и хрен с ней.

Вердикт

Итак, пора подвести итог вышесказанному. Из чего следует выбирать рейтинг? Сначала подумай, зачем он тебе. Если ты хочешь знать, сколько людей ходит к тебе, по каким дням больше, а по каким меньше, то поставь себе один единственный счетчик. На мой взгляд, это должен быть Spy Log или Top Mail, в крайнем случае - Rambler, но никаких Mafia и ему подобных быть не должно.

Если же ты хочешь раскрутить свой ресурс за счет регистрации в рейтингах, то ставь все возможные счетчики. Но это - глупо, большого толку от этого не будет и принесет только геморрой и большой спам в ящике.

Ну, а если ты хочешь попробовать взобраться на вершину хит-парад какого-нибудь рейтинга, то пусть лучше это будет Rambler. Имхо, сотое место в Ramblere'e гораздо дороже первого в каком-нибудь Pupkin Top 100.


Спецвыпуск Xakep, номер #015, стр. 015-061-1, По ту сторону браузера

По ту сторону браузера

Спецвыпуск Xakep, номер #015, стр. 015-061-1

Mischenko Dmitry aka Kryo (kryo@xakep.ru)

Привет, дорогой мой нет-серфер! Уверен, ты уже определился с выбором подходящего браузера и полностью его под себя настроил. Казалось, вот она вся сеть, лежит перед тобой. Но ведь браузер и все что ты в нем видишь - это только зеркало нета, одна из конечных его граней. А что происходит за ним? Как получается, что вся эта информация оказывается в итоге на твоем экране? Не задумывался еще об этом? Давай задумаемся вместе ;)!

Сеть сетей

Начнем с самого низа - с определения Инета. Интернет известен как Сеть. А что такое сеть? Компьютерная сеть - это группа машин, каким-либо образом связанных между собой и имеющих возможность обмениваться информацией. "Интернет" дословно переводится с koi8-r на win-1251 :) как "межсеть". То есть это сеть сетей. Так оно и есть - Инет соединяет между собой огромное количество различных сетей. Среди них есть и большие (корпоративные сети компаний AT&T, Hewlett-Packard, сеть Пентагона), и средние (университетские и институтские сети, провайдерские сети), и маленькие (домашние локалки, интернет-клубы). Представил себе картину? Много-много сетей, объединенных между собой в одну большую сеть, - это и есть Интернет.

4.294.967.296

Поднимаемся на одну ступеньку выше: как это дело, собственно, работает? Взаимодействие всех машин в сети происходит по протоколу TCP/IP. Это два протокола, объединенных в один, поскольку независимо друг от друга они действовать не могут. Называются они, соответственно, TCP и IP (логично, не правда ли? :)). Название первого протокола расшифровывается как Transmission Control Protocol. А занимается он вот чем: согласно ему, отправляемые данные "нарезаются" на небольшие пакеты, после чего каждый пакет маркируется таким образом, чтобы в пункте назначения все они должным образом собрались. Хорошо, информация нарезана, а что дальше? Куда ей плыть? А вот тут приходит очередь протокола IP, название которого расшифровывается просто: Internet Protocol. Его называют еще адресным протоколом. Суть идеи состоит в том, что у каждого компьютера в Интернете должен быть свой уникальный адрес (IP'шник). Он выражается четырьмя байтами, к примеру: 212.9.226.183. Структура самого же протокола организована так, что каждый компьютер, через который проходит TCP-пакет, может по этим четырем числам определить, кому из своих соседей отправить пакет дальше, чтоб он быстрее дошел до адресата. Возможен и такой расклад, когда от одного компьютера к другому пакеты идут разными путями.

Если интересно, сколько всего может существовать IP-адресов, то посчитать это очень просто. В адресе 4 байта, один байт может содержать 256 различных символов. То есть всего адресов максимум 256 в четвертой степени или 4 миллиарда 294 миллиона 967 тысяч 296. Видишь, что в заголовок абзаца вынесено? Это не IP такой ;), это то число, которое мы только что вычислили :). Немало, правда :)? Вроде бы да, но скоро, говорят, хватать перестанет. И уже сейчас кое-где переходят постепенно на новый стандарт - в котором адрес кодируется аж шестью байтами. Считать не будем, ладно =)?


Спецвыпуск Xakep, номер #015, стр. 015-061-2, По ту сторону браузера

По ту сторону браузера

Спецвыпуск Xakep, номер #015, стр. 015-061-2

Итак, мы выяснили, что благодаря Инету машины, подключенные к нему, могут обмениваться между собой информацией по протоколу TCP/IP.

DNS

И еще одна ступень ;). Согласно тому, что я рассказал о TCP/IP, для того чтобы соединиться с компьютером, вроде надо знать его IP адрес. А ты много знаешь этих самых адресов? Во-во! Ты знаешь только доменные имена, типа www.xakep.ru и www.microsoft.com :). Этими именами и "занимается" DNS. Расшифровывается это дело как Domain Name System (доменная система имен). DNS сопоставляет запрошенное имя и IP-адрес соответствующего сервера. Когда ты в окошке браузера набираешь, к примеру, www.xakep.ru, то запрос идет сначала на DNS-сервер, а дальше - уже по IP'шнику (213.189.197.201, если что). Все это происходит по одноименному DNS-протоколу. Если хочешь конкретно загрузиться на тему работы DNS, зайди сюда: http://www.thestandard.ru/cw/1997/02/32.htm.

Расскажу теперь про сами домены. Они бывают разных уровней. Домен высшего уровня - это корневой домен, имени он не имеет. Домены второго уровня привязаны к разным странам или типам учреждений. Государственные домены имеют две буквы. Не буду перечислять их все, скажу только, что в России - это RU (да ты и сам, наверно, догадался :)), на Украине - это UA. Доменами в зоне RU заведует РосНИИРОС (Российский научно-исследовательский институт развития общественных сетей). Домены типов учреждений имеют три буквы (пожалуйста, без пошлых ассоциаций :)), за исключением одного домена-извращенца. Но все по порядку:

COM - коммерческие компании/частные лица (самый модный домен)

EDU - образовательные учреждения

MIL - учреждения Мин. обороны (США)

NET - сетевые организации

INT - международные организации

ORG - некоммерческие организации

И, наконец, тот самый домен-извращенец, о котором я говорил, - это TV. Не привязанный к государству и имеет всего две буквы. Я лично знаю только один сайт в этом домене: www.1plus1.tv (предупреждаю: он на украинском языке). Домен телевизионных компаний - как ты уже наверняка догадался.

Домены второго уровня принадлежат людям/компаниям, которые их зарегистрировали, они не имеют ограничений по количеству символов в имени и всегда размещаются в домене первого уровня. www.xakep.ru, например, - это домен второго уровня, расположенный в домене RU. Есть еще домены третьего уровня, которые обычно даются серверами бесплатного хостинга, например, http://vasya_pupkin.narod.ru.

Спасибо, дорогая, я кончил

И вот у нас собралась полная схема: от момента, когда ты набираешь адрес странички, и до момента, когда содержимое этой странички отображается в окне твоего браузера. Всего лишь пара ничтожных секунд, зато сколько всего за это время успевает произойти! И так каждый раз, когда ты что-нибудь браузишь :).


Спецвыпуск Xakep, номер #015, стр. 015-062-1, Картинки в авоське: форматы графических файлов в Интернете

Картинки в авоське: форматы графических файлов в Интернете

Спецвыпуск Xakep, номер #015, стр. 015-062-1

Андрей Каролик (andrusha@sl.ru; http://www.dal.net.ru)

С графикой ты сталкиваешься постоянно: в операционках, в софте, в играх, в Интернете. Всюду кишат окошки, кнопочки, бэкграунды, анимашки, иллюстрашки и so on. Но ты просто пользуешься плодами других, и тебя не парят заморочки графических форматов. Однако если ты решился оставить след своего копыта в сети, то без этого секретного знания тебе никуда.

Откуда торчат уши

Для Интернета раньше эта проблема была вообще неактуальной, так как скорости подключения к паутинке оставляли желать лучшего. На сайте размещали максимум скромный логотипчик или несколько небольших фотографий. При этом выбирали тот формат, который весил бы по минимуму, не особо обращая внимания на качество изображения. Времена меняются. Теперь найти сайт без графики - проблема. Делая свой собственный сайт, ты обязательно столкнешься с проблемой выбора: в каком формате сохранить фотографии, навигацию, разнообразные графические элементы, чтобы при этом получить максимальное качество отображения без бахромы и мусора и минимальные размеры графических файлов. Есть и еще один трабл - форматов существует море. Разные проги для работы с графикой юзают разные графические форматы. Есть общепринятые форматы, есть собственные форматы, используемые только в определенных программах и графических редакторах. Перечислять все форматы графических файлов можно достаточно долго. Вот, например: BMP, PCX, WMF, PICT, GIF, TIFF, EPS, PDF, PSD, JPEG, CDR, FH7, FH5, FH8, SCT, PS, AI, CDR, RTF. Хватит ;)? Но далеко не все из них можно использовать в Интернете, так как не все из них поймет твоя бродилка-бодрилка. Поэтому не помешало бы тебе получше узнать графические форматы, юзаемые в Инете, их фичи и баги. В общем, сейчас я тебе расскажу, что почем и что для чего пользовать на практике.

Векторная и растровая графика

Весь компьютерный графон в первую очередь делится на две большие ветви: векторную и растровую. Векторная графика - это набор геометрических примитивов (всяких кружков, квадратиков, отрезочков, дуг и прочей шняги). То есть компу, чтобы нарисовать линию, не нужно хранить все ее точки, а достаточно заныкать координаты начала и конца. Далее железный вычислит остальные точки по формуле сам "на лету". К примеру, чтобы компьютер нарисовал дугу, ему нужны концы... мда... радиус и ее цвет. Разные векторные форматы отличаются использованием своих алгоритмов при построении одних и тех же объектов. Но суть там же :).

Растровая графика устроена по-другому. Она представляет собой прямоугольную матрицу (bitmap), разделенную на маленькие квадратики - пиксели (pixel - picture element). Эдакий листок в клетку. И совершенно параллельно, квадрат там или круг - все это наборы точек. Чем больше пикселей в каждом квадратном дюйме на матрице, тем выше разрешение файла (качество картинки). Данная структура характерна для всех растровых форматов. Растровые форматы различаются между собой количеством информации о цвете, которую можно определить для каждого пикселя способом архивации и другими особенностями.


Спецвыпуск Xakep, номер #015, стр. 015-062-2, Картинки в авоське: форматы графических файлов в Интернете

Картинки в авоське: форматы графических файлов в Интернете

Спецвыпуск Xakep, номер #015, стр. 015-062-2

BMP (Windows Device Independent Bitmap)

Формат ВМР (*.bmp) является родным форматом Windows, он поддерживается всеми графическими редакторами, работающими под управлением стеклянных. Хотя существует разновидность формата ВМР и для операционной системы OS/2. На Macintosh BMP также читается и пишется без проблем. Применяется для хранения растровых изображений, предназначенных для использования в Windows. Способен хранить как индексированный (до 256 цветов), так и RGB-цвет (16,7 млн. оттенков). В Интернете можешь его использовать только в одном случае: когда тебе требуется выложить архив картинок в хорошем качестве, так как прекрасно жмется zip-ом (У! Жмот!), особенно если на картинке много однотонных областей.

JPEG (Join Photographic Experts Group)

JPEG (*.jpg) - самый популярный формат для хранения фотографических изображений. Алгоритм сжатия формата построен за счет ухудшения качества изображения, но можно выбрать такие параметры сжатия, при которых потери в качестве практически незаметны или приемлемы для нужных целей. Строго говоря, JPEG-ом называется не формат, а алгоритм сжатия, основанный не на поиске одинаковых элементов, как в RLE и LZW, а на разнице между пикселями. Кодирование данных происходит в несколько этапов. И чем выше уровень компрессии, тем больше данных отбрасывается - соответственно, тем ниже качество. Используя JPEG, можно получить файл в 10-500 раз меньше, чем ВМР. Формат аппаратно независим, полностью поддерживается на РС и Macintosh. К недостаткам можно отнести то, что JPEG не поддерживает анимацию и прозрачность, пригоден в подавляющем большинстве случаев только для публикации полноцветных изображений. JPEG-ом лучше сжимаются растровые картинки фотографического качества, чем логотипы или схемы. Лучше сжимаются и с меньшими потерями также большие изображения или изображения с высоким разрешением (200-300 и более dpi). В JPEG-е следует сохранять только конечный вариант работы, потому что каждое пересохранение приводит к новым потерям (отбрасыванию) данных и, в конечном счете, превращению исходного изображения в кашу.

GIF (Graphics Interchange Format)

Формат GIF (*.gif) применяет те же алгоритмы сжатия, что и обычные программы-архиваторы, поэтому при записи и считывании GIF-изображения никаких потерь качества изображения не происходит. При этом GIF-файлы архивируются и разархивируются автоматически и "на лету", то есть ты этого даже не замечаешь. Этот формат использует LZW-компрессию, что позволяет хорошо сжимать файлы, в которых много однородных заливок (логотипы, надписи, схемы, бэкграунды). К особенностям формата можно отнести то, что GIF-формат позволяет записывать изображение "через строчку" (Interlaced), благодаря чему, имея только часть файла, можно увидеть изображение целиком, но с меньшим разрешением. Эта возможность широко применяется в Интернете на сайтах. Сначала ты видишь картинку с меньшим разрешением, но уже можешь понять, что шня полная, и ломиться по ссылкам дальше, а можешь дождаться конца загрузки и убедиться. Это достигается за счет подгрузки сначала 1, 5, 10 и так далее строчек пикселей и растягиванием данных между ними, вторым проходом следуют 2, 6, 11 строчки и дальше в том же духе. Качество изображения как бы постепенно увеличивается. В конце концов подгружается все изображение полностью. Чересстрочная запись незначительно увеличивает размер файла, но результат стоит свеч. Кроме того, в GIF можно назначить какой-нибудь цвет прозрачным, он станет невидимым в интернетовских браузерах и некоторых других прогах. Прозрачность обеспечивается за счет дополнительных данных (Alpha-канала), сохраняемых в файле. Существует еще и GIF-анимация. Когда файл содержит не одну, а несколько растровых картинок, которые Инет бродилки могут подгружать одну за другой с указанной в файле частотой. Благодаря этому ты можешь делать анимацию aka мультики. Основное же ограничение формата GIF состоит в том, что цветное изображение может быть записано с использованием не более чем 256 цветов.


Спецвыпуск Xakep, номер #015, стр. 015-062-3, Картинки в авоське: форматы графических файлов в Интернете

Картинки в авоське: форматы графических файлов в Интернете

Спецвыпуск Xakep, номер #015, стр. 015-062-3

PNG (Portable Network Graphics)

Формат PNG (*.png) был разработан относительно недавно в качестве альтернативы устаревшему GIF-формату и именно для сети. Использует сжатие без потерь Deflate, сходное с LZW. Алгоритм PNG возник из-за патентования в 1995 году алгоритма LZW. В отличие от ограниченной 256 цветами палитры GIF, PNG-формат позволяет хранить полноцветные изображения с любой глубиной цвета вплоть до 48 бит. Сжатые PNG-файлы в 256 цветах, как правило, меньше аналогичных GIF-ов, а RGB PNG меньше соответствующего файла во многих других форматах. В PNG-формате используется более эффективный Interlaced-алгоритм (чересстрочного отображения) - двумерный Interlacing (не только строк, но и столбцов), который так же, как и в GIF-е, слегка увеличивает размер файла. Но при загрузке 1/64 файла уже можно получить представление о красивой картинке, в то время как GIF-формату нужно загрузить 1/8 файла. В отличие от двух градаций прозрачности, поддерживаемых GIF-форматом (либо есть прозрачность, либо ее нет), PNG поддерживает также полупрозрачные пиксели (в диапазоне прозрачности от 0 до 99%) за счет альфа-канала с 256-ю градациями серого. Таким образом, каждый пиксель PNG-файла, вне зависимости от его цвета и местоположения, может иметь любое значение непрозрачности от нулевой (полная прозрачность) до абсолютно непрозрачной. В файл формата PNG записывается еще и информация о гамма-коррекции. Это число, считанное из файла, позволяет ввести поправку яркости при отображении. Нужно оно для того, чтобы картинка, созданная, к примеру, на Мас, выглядела одинаково и в Windows, и в UNIX. Эта особенность помогает реализации основной идеи веба - одинаковое отображение информации независимо от аппаратуры пользователя. PNG поддерживается осликом IE, начиная с 4-ой версии. Netшкаф добавил поддержку PNG для своего браузера, начиная с 4.0.4 версии. Тем не менее до сих пор не реализована поддержка таких важных функций формата, как плавно переходящая прозрачность и гамма-коррекция. На сегодняшний день это наиболее перспективный формат для использования в Интернете, обладающий большими возможностями, но не получивший пока еще повсеместного распространения. Ждем-с!


Спецвыпуск Xakep, номер #015, стр. 015-062-4, Картинки в авоське: форматы графических файлов в Интернете

Картинки в авоське: форматы графических файлов в Интернете

Спецвыпуск Xakep, номер #015, стр. 015-062-4

FST (FAST Image Transfer)

Формат FST (*.fst) - еще один малоизвестный, но используемый в Интернете, формат. При одинаковом качестве изображения файлы этого формата имеют объем в 2-6 раз меньший, чем JPEG. Но для отображения в браузере сначала загружается java-апплет размером 22 Кбайт, который декодирует и отображает картинку на экране. Апплет поддерживается, начиная с третьих версий браузеров.

Flash - векторный формат и не только

Примером векторного формата в Инете служит Flash (.swf файлы). Этот формат был разработан компанией Maсromedia и активно продвигается на рынок и в сеть. Что ж, сия фича довольно перспективна и уже активно юзается пагостроителями всех сортов и оттенков. Flash интересен тем, что включает в себя не только графику, но и текст, звук и скрипты. Все это хранится очень компактно, поэтому подходит для юзания в Интернете. Такое объединение делает flash-формат очень удобным для разработчиков (веб-дизигнеров). Что же касается графики, то она здесь именно векторная. То есть Flash хранит изображение в виде типов примитива и параметров, что конкретно срубает размеры файла. Но недостаток векторной графики в том, что нельзя замутить размытия и тени, поэтому она серьезно проигрывает растру по качеству (фотку в ней точно не сохранишь). Поэтому Flash позволяет сохранять и битмапы - правда, очень сильно их жмет. Flash-формат поддерживается IE, начиная с четвертой версии, но перцы из Макромедии постоянно выпускают новые версии Flash-а, поэтому лучше все-таки утянуть свежий плюгин для осла с www.macromedia.com.

Вердикт

Чаще всего в вебе используются два формата: JPEG и GIF. Если нужно выложить большое изображение с количеством цветов более 256 или с высоким разрешением - используй JPEG. Если нужно делать кнопки, заливку, небольшие графические элементы или изображения с количеством цветов менее 256 - используй GIF. PNG хоть и обладает более высокими характеристиками, чем GIF, и поддерживается браузерами, начиная с 4-х версий, но встречается не особо часто в Интернете, так как не все графические редакторы включили его поддержку. Но если ты работаешь с редактором, который поддерживает PNG-формат, смело используй именно его. Для анимации подойдет GIF-формат - и уже существует полно программ, с помощью которых ты можешь сделать такую анимацию, например, Ulead GIF Animator или Microsoft GIF Animator. Если же ты хочешь сделать полную анимацию сайта, то используй Flash, так как этот формат может работать как с растровой, так и с векторной графикой. Более подробно про нюансы алгоритмов архивации и сжатия смотри, к примеру, по адресам http://www.kgg.boom.ru/pages/page01.htm и http://kunegin.narod.ru/ref1/code/index.htm.

Полезные советы

- Ограничения палитры в 256 цветов у формата GIF можно избежать, разрезав картинку на отдельные кусочки, каждый из которых использует свою палитру из цветов, характерных именно для этого кусочка. Для вывода используется таблица, каждая из ячеек которой содержит свой кусочек картинки. Этот же способ работает и при использовании 256-цветного PNG.


Спецвыпуск Xakep, номер #015, стр. 015-062-5, Картинки в авоське: форматы графических файлов в Интернете

Картинки в авоське: форматы графических файлов в Интернете

Спецвыпуск Xakep, номер #015, стр. 015-062-5

- Если тебе нужен прозрачный фон, то придется использовать GIF или PNG. При этом необходимо помнить, что сохранение в режиме сглаживания (anti-alisieng) контуров приводит к образованию заметной цветной каймы, если цвет, выбранный прозрачным, сильно отличается от цвета фона размещения картинки. Поэтому добавь на границах цветовых переходов пиксели среднего цвета.

- Усилить сжатие и уменьшить потери качества в JPG можно предварительным применением фильтра размытия (Blur), имеющегося в большинстве графических редакторов. Но тебе придется поэкспериментировать, прежде чем найдешь оптимальное сочетание параметров сжатия и размытия.

- Netscape Navigator иногда не переносит очень больших картинок с чересстрочной записью. Но можно сделать по-другому: сначала загрузить картинку такого же размера, но с меньшим разрешением или черно-белую, а потом поверх нее оригинал, сохраненный без чередования строк (если GIF) или без многократного вывода с пошаговым улучшением изображения (если progressiv JPG). Этот способ осуществляется указанием в тэге HTML <img src="..."> параметра lowsrc="..." с указанием имени файла с меньшим разрешением, который будет грузиться первым.

Приятных тебе картинок!


Спецвыпуск Xakep, номер #015, стр. 015-064-1, Как замутить Shell Обвешанный Shell

Как замутить Shell Обвешанный Shell

d00d13 (d00d13@mail.ru)

Спецвыпуск Xakep, номер #015, стр. 015-064-1

Шелл - штука клевая. Особенно если его грамотно обвешать всяким полезным для сетевой жизни софтом. Я покажу тебе, как анонимно сидеть в сети через собственный прокси, как поставить бота и защитить свой канал на ирке от перехвата, и даже как организовать на шелле собственный IRC-сервер!

Proxy & Socks

Часто бывает так, что срочно нужна анонимная прокся. Например, когда что-то кардишь или, скажем, сканируешь сайт на наличие дырявых скриптов. Чтобы не заморачиваться каждый раз поиском рабочей прокси, ты можешь просто поставить ее на своем шелле: когда надо - включил, надоело - вырубил, а логи... А логов-то и нету :). Очень удобно, тем более что установка прокси - дело двух минут.

Я предлагаю поставить какую-нибудь перловую проксю - они довольно стабильно работают, поддерживают HTTP и FTP, а настройки минимальные. Ссылки есть ниже - бери первую, думаю, ее возможностей будет достаточно. Скачал? Ок, открой файл httpproxy-1_5_3.pl и найди в нем строку "my $port = 8888;". 8888 - порт, на котором будет висеть proxy и который, скорее всего, придется поменять на что-нибудь другое, так как этот порт с большой вероятностью будет уже занят ;). Теперь закинь файл на сервер, выполни "chmod +x httpproxy-1_5_3.pl" (он стал выполняемым) и запусти его: ./httpproxy-1_5_3.pl. Вот и все, осталось только прописать в браузере новоиспеченный proxy.

Если необходима поддержка протокола SSL (https-сайты) (а она тебе очень даже может пригодиться - большинство сеансов связи, во время которых передается информация о кредах, происходит по SSL), то httpproxy-1_5_3.pl уже не катит. Если ты все равно хочешь Perl proxy, то придется ставить на сервере и OpenSSL (http://www.openssl.org), и Perl-интерфейс к нему (это модуль Net::SSLeay (http://www.bacus.pt/Net_SSLeay/). Но лучше установить socks, тогда ты сможешь анонимно ходить не только по сайтам, но и пользоваться icq, irc и прочими дарами природы. Скачивай носок nylon - он маленький, а настраивать почти ничего не нужно :). Распаковывай его - "tar xzf nylon-0.2hb.tar.gz" и конфигурируй так, чтобы он ставил себя в твой домашний каталог - "./configure --prefix=/home/blevun/socks". Теперь компилируй (make) и инсталль (make install). Сокс установлен, осталось его только запустить. Для этого заходи в директорию, где он установлен, и вводи: ./bin. Теперь сокс открыл 1080 порт - используй сколько хочешь, только следи за логами! Они пишутся в отдельный файл, так что их надо регулярно чистить.

http://online.comtv.ru/httpproxy-1_5_3.pl - обычный HTTP proxy.

http://www.jmarshall.com/tools/cgiproxy/ - HTTP & FTP с поддержкой SSL.

http://tinyproxy.sourceforge.net/ - стандартный proxy, написанный на C.

http://mesh.eecs.umich.edu/projects/nylon/ - nylon (SOCKS 4 & 5).

http://www.squid-cache.org/ - web proxy с поддержкой кэширования, SSL и многого другого.

IRC-боты

В IRC у тебя, наверное, есть свой канал, и все было бы прекрасно, но если ты сидишь в EFnet или в других бессервисных сетях, то должен знать, что такое takeover. Чтобы избежать подобных неприятностей, используют ботов. Самый популярный из них - eggdrop. Он следит за флудом на канале, дает статус опа кому нужно, держит настройки канала и заботится о многих других мелочах. Последнюю версию (1.6.6) можно утянуть с ftp://ftp.eggheads.org. Распаковывай архив - tar "xzf eggdrop1.6.6.tar.gz", пускай конфигуратор - "./configure --prefix=/home/blevun/eggdrop" (prefix указывает, в какую директорию устанавливать eggdrop'а). Теперь компилируй (make) и инсталль (make install). Все, бот установлен, осталось его настроить. Советую не страдать с конфигом, а взять самый простой - eggdrop.simple.conf. Скопируй его как blevun.conf, открывай и правь: set-nick - ник бота, set servers - сервер, куда боту нужно коннектиться. Далее идут настройки бота для каналов - я оставил их без изменения, только подставил нужные названия: set net-type - тип сети (DALnet, EFnet и другие), listen - порт для телнета (по нему ты будешь управлять ботом), set owner - владелец бота (тут поставь свой ник). Закомментируй строку die, а то eggdrop будет ругаться при запуске. Все, можно запускать: ./eggdrop -m blevun.conf. Зайди на свой канал и полюбуйся на уже висящего там бота :). Пиши ему "/msg blevun help", он тебе ответит приветствием ;). Отлично, можно задать пароль - "/msg blevun pass yourpass". С этого момента ты можешь коннектиться к боту по DCC или по телнету на установленный тобой порт. Там спросят логин и пароль - вводи их, а потом вводи .help. Бот выдаст список команд. Вот самые полезные из них:


Спецвыпуск Xakep, номер #015, стр. 015-064-2, Как замутить Shell Обвешанный Shell

Как замутить Shell Обвешанный Shell

d00d13 (d00d13@mail.ru)

Спецвыпуск Xakep, номер #015, стр. 015-064-2

.jump - выбрать IRC для бота

.+user - Nick Nick!user!some.provider.ru - добавить пользователя

.+chan #channel - зайти/выйти на канал

Об остальных командах можно почитать в доках.

IRC-сервер

Оп канала - это, конечно, клево, но ведь намного круче иметь собственный IRC-сервер! А что? Будет такой полуприватный ircd, где все пользователи - свои люди, и где админ - либо ты сам, либо твои близкие друзья. По-моему совсем неплохо, тем более что никаких привилегированных прав в системе, где ты будешь ставить IRC-сервер, не понадобится - сойдет и обычный пользователь. Главное, чтобы был доступен компилятор gcc ;). Уговорил :)? Тогда бегом за ircd! Качай сервер hybrid (www.the-project.org) - он довольно просто устанавливается, не особо сильно грузит систему, а также спокойно работает на эфнете (это уже о многом говорит :)).

Я юзал версию 6.2. Подозреваю, что в других версиях настройки идентичны. Распаковывай архив: "tar xzf ircd-hybrid-6.2.tgz" и заползай в появившуюся директорию. В каталоге include необходимо подкорректировать файл config.h. Найди в нем строку "#define DPATH /usr/local/bin/" - это каталог, в который будут устанавливаться бинарники. Так как прав root'а на шелл у нас нет, мы не сможем скопировать файлы в /usr/local/bin, поэтому будем ставить в свой домашний каталог. Например, если твое имя в системе blevun, то пропиши вот так: "#define DPATH /home/blevun/ircd/". Такой же путь пропиши во всех других PATH. В принципе уже можно собрать ircd, но тебе может не понравиться такая вещь: по умолчанию максимальная длина ника не должна превышать девяти символов. Это слишком большое ограничение, поэтому открывай файл ircd_defs.h и меняй значение в поле NICKLEN с 9 на 20. Вот теперь уже точно можно приступать к сборке - вводи "./configure", а потом - "make". Если при компиляции никаких ошибок не возникло, то копируем бинарники и прочее файло в домашний каталог - "make install".


Спецвыпуск Xakep, номер #015, стр. 015-064-3, Как замутить Shell Обвешанный Shell

Как замутить Shell Обвешанный Shell

d00d13 (d00d13@mail.ru)

Спецвыпуск Xakep, номер #015, стр. 015-064-3

Все, можно приступать к самому интересному - к настройке нашего IRC-сервера. Все конфиги лежат в файле ircd.conf. Давай смотреть, что там есть интересного:

M:blevun.org:195.10.23.4:blevun:6667

host, ip, name, порт - сервера.

A:blevun network:zablevun:admin@blevun.org

Информация об администрации сервера.

Y:1:90:2:200:100000

Максимальное количество пользователей - 200, на одном IP могут сидеть максимум 2 человека.

I:NOMATCH::*::1

Разрешаем коннектиться кому угодно.

O:*.comex.ru:eUAtatC3IPsz.:gnido:KORUGNHD:1

Логин для иркопа - gnido, зашифрованный пароль - "eUAtatC3IPsz.".

Чтобы получить зашифрованный пароль, необходимо воспользоваться утилиткой mkpasswd. *.comex.ru - маска, с этим хостом должен быть пользователь, чтобы получить статус IRC оператора.

На этом все - можно пускать irc сервер: ./ircd. Теперь коннекться на него - "/server blevun.org". Хочу заметить, что сервисов вроде NickServ, ChanServ ты не обнаружишь - для этого нужно ставить специальные тулзы и прикручивать их к гибриду. Взять софтину можно здесь - ftp://ftp.magenet.net/pub/hybserv.

Вот еще несколько ссылок, где можно достать другие сервера:

http://bahamut.dal.net - Bahamut (установлен на DALnet)

http://www.ircd-hybrid.net - Hybrid (EFnet)

http://www.monkeyircd.org - MonkeyIRCD

Let`s shell!

То, что мы успели тут посмотреть, - это одна сотая доля от всего софта, который можно понавешать на шелл. Ведь шелл - это твое представительство в сети. Когда ты оффлайн, он продолжает исправно поддерживать твои проги в рабочем состоянии. Повесь на шелл программу брутфорсера, повесь сканер дырявых цгишек, автоответчик на почту, автоответчик на аську... Такими темпами необходимость появляться в сети может отпасть полностью :). Шутка! Просто, имея шелл, можно проводить свое время в сети с максимальным комфортом. Вот и вся фишка :)!


Спецвыпуск Xakep, номер #015, стр. 015-066-1, Атака Кевина Митника

Атака Кевина Митника

UFO (ufobject@mail.ru)

Спецвыпуск Xakep, номер #015, стр. 015-066-1

Привет, нетмен! Ты слышал о Кевине Митнике? Да, глупый вопрос. О нем слышали все: дворники и уборщицы, космонавты и подводники, ламеры и хакеры. Это большая знаменитость. Про него ходит огромное количество слухов, и каждый переворачивает его историю по-своему. Некоторые говорят, что он супер-мега-специалист в сетевой безопасности, другие утверждают, что он просто человек, на которого пришелся обвал прессы, и тем самым он прославился. Да... Слухов действительно много, но сейчас я попробую развеять этот туман. Все дело в том, что я уже давно интересуюсь Митником и видел несусветное количество разных мнений и людей, приводящих совершенно разные факты. Конечно же, на 100% всю эту историю знает только сам Митник - но есть еще один человек, которому в данном случае грех не поверить. Этого человека зовут Цутому Шимомура. Если ты не в курсе, это как раз тот перец, которого натянул Кевин. В общем, слушай сюда...

Кто такая Элис?

Начну я с того, что постараюсь тебе как можно достовернее рассказать про Кевина до его поимки. Итак, с самого начала Митник интересовался фрикингом. Это была его стихия. Он пер различные секретные доки из телефонных компаний, изучал структуру телефонии и знал кучу секретов, которыми пользовался при накрутке телефонных корпораций. Поначалу вся хак-активность Митника сводилась к обыскиванию мусорных ящиков в поисках выброшенных паролей, разводу админов и подбору пассов. В то время такого рода действия еще назывались "хакерством", на данный же момент это называется "социальной инженерией". Но основная суть не в этом. Митник со временем рос и продвигался, а фрикинг так и оставался его основным занятием. Его ловили, но затем отпускали. Параллельно с этим Кевин начал заниматься более продвинутым уровнем хака. Подтверждением этого является его роковая атака на Шимомуру. Надо сказать, что Шимомура являлся специалистом в компьютерной безопасности, и успешная атака Митника нанесла огромный удар по его самолюбию. Однако совершенно непонятно, почему Шимомура дал знать об этом всему миру. Обычно взломанные компании и организации пытались максимально скрыть факт хака, так как это могло нанести большой удар по их репутации, однако в нашем случае получилось обратное: Шимомура стал известнейшим специалистом в области компьютерной безопасности, а Митник в глазах народа превратился в злого и всемогущего хакера, которого все жутко боялись. Скорее всего, это и повлияло на желание властей продержать Кевина за решеткой как можно больший срок. В общей сложности он отсидел около пяти лет и сейчас находится на свободе. Ему запретили пользоваться компьютерами, но не так давно Кевин подал на апелляцию, и ему разрешили писать в один из интернет-журналов. Вот так вкратце выглядит история известнейшего хакера планеты, а теперь я расскажу о самой атаке, из-за которой Митника засадили в тюрягу.

Доверяй, но проверяй

Атака длилась всего 16 секунд, но отнюдь не была плевым делом. Она состояла из двух частей. Первый ингредиент стал возможен благодаря излишней доверчивости... одного компа другому. Доверчивость вообще качество не лучшее, а в деле сетевой безопасности - откровенно вредное. Вот и здесь подвела именно она. Дело в том, что есть такой rsh-сервис (Remote Shell) на некоторых серверах. Чтобы заценить баг сервиса, давай сперва посмотрим на принцип его работы. Remote Shell позволяет исполнять произвольные команды на удаленной тачке. Чтобы воспользоваться его услугами, удаленный компьютер должен иметь IP-адрес, который, в свою очередь, просто обязан находиться в файле /.rhosts атакуемого компа. Это и является единственной защитой от взлома. Видимо, разработчики rsh-сервиса полностью положились на хороший уровень защищенности TCP-соединенй. Конечно же, TCP-протокол по сравнению с UDP-протоколом кажется просто неприступной крепостью, но и у него есть свои бреши. Самый большой баг Remote Shell заключается в том, что при установке TCP-соединения с rsh-сервисом не требуется обратной активности. То есть, если ты установил TCP-соединение от имени доверенного IP-хоста, то rsh сервис переходит в режим приема команд и, получив долгожданные указания, просто их выполняет. Он не шлет какой-либо запрос на подтверждение посылки команды, так как считает, что команды посланы с доверенного хоста. Единственной обратной связью с доверенным компом является посылка сообщения о завершении выполнения заданной команды. В этом прячется еще одна загвоздка для атакующего хоста. Фишка в том, что посылку таких сообщений с атакуемого компа допускать нельзя, так как эти пакеты летят прямиком на настоящий доверенный хост. Тот, получив такое сообщение о проделанной операции, выполнять которую он не просил, посылает команду RST, оповещающую о закрытии соединения. Но и это решаемо. Как? Настоящий доверенный хост просто выводится из строя атакой "отказ в обслуживании" (DoS) и не может послать RST команду. Это и есть вторая часть атаки.


Спецвыпуск Xakep, номер #015, стр. 015-066-2, Атака Кевина Митника

Атака Кевина Митника

UFO (ufobject@mail.ru)

Спецвыпуск Xakep, номер #015, стр. 015-066-2

Отказ в обслуживании

Чтобы ты полностью понял хак Митника, расскажу тебе о DoS. Причина успеха таких атак заключается в том, что при пересылке пакета с ложным IP-адресом отправителя этот пакет благополучно доходит до места назначения, и это самое место не может поставить какое-либо ограничение на прием запросов TCP-соединений. Некоторые админы пишут софт, который во время отсутствия админа на рабочем месте блокирует атакуемый порт. Но из этого редко выходит толк, так как любой грамотный человек, атакующий удаленный компьютер или сервер, просто поменяет номер атакуемого порта, и в итоге получается, что защитная прога блокирует все порты по очереди. От чего ушли, к тому и пришли.

Существует 3 типа DoS атак. Первый тип уже давно устарел и вряд ли он будет иметь успех (скорее, успех будет иметь его :)). Принцип очень прост. Давным-давно Windows 95 плохо переваривал определенную команду, посылаемую на определенный порт. Результат такой посылки - выезд окна смерти и повисание тачки. В общем, тупое до жути юзание старого бага Большого Билли.

Второй тип атаки - посылка шторма мусорных пакетов на удаленный компьютер. Смысл в том, что при попытке соединения с удаленным компьютером ОС на атакуемом компе начинает генерировать ответ на каждый из запросов и записывает все это дело в лог и в память. В результате на атакуемой тачке все ресурсы кидаются на обработку этого шквала мусора. Финал - повисание машины. Минус этой атаки заключается в том, что, если машина суперскоростная, то она будет очень быстро обрабатывать запросы, и занятость ресурсов получится мизерная. Еще одно условие, которое необходимо соблюдать при этом типе атаки, - большая пропускная способность канала хаксора, что у нас бывает редко. Бомбить сервак на выделенке с дайлупа - эта та еще комедия :).


Спецвыпуск Xakep, номер #015, стр. 015-066-3, Атака Кевина Митника

Атака Кевина Митника

UFO (ufobject@mail.ru)

Спецвыпуск Xakep, номер #015, стр. 015-066-3

Третий способ (он-то нам и нужен) - посылка десятка нормальных запросов на соединение с удаленным сервером. Если пакет запроса корректен, сервер открывает эти соединения и ставит все остальные запросы в очередь. В итоге, сервер ждет в течение 10 (!) минут любой активности по созданному TCP-соединению и, обломавшись, делает тайм-аут, то есть разрывает эти соединения. Таким образом, на десять минут сервер приводится в состояние "отказа в обслуживании". Минус этой атаки заключается в том, что при открытии соединения нужно подобрать значение ID поля в TCP пакете. Это поле генерируется в зависимости от установленной ОС на удаленном сервере.

Вот это были основные моменты, необходимые для разбора атаки Митника.

Атака Митника

Атака началась в 14:09:32 25.12.94. Сначала Митник начал зондировать атакуемый хост с целью выявления доверенных адресов. Ему это удалось: на хосте toad.com имелась запись с правами ROOT-а. Митник смог запустить команды showmount и rpcinfo. Через 6 минут с хоста 130.92.6.97 последовал шторм пакетов на 513 порт доверенного хоста. Этим атакующий добился отказа в обслуживании. Теперь повешенный доверенный хост был не в силах послать сообщение о разрыве соединения на сервер - к которому медленно, но верно подбирался Кевин. Теперь хакер мог вести удаленное соединение от имени доверенного хоста. Далее последовало 20 попыток создания соединения с удаленным хостом apollo.it.luc.edu на x-terminal.shell. Так Митник вычислял алгоритм изменения начального значения идентификатора TCP-соединения на хосте. Подбор шел не тупым брутфорсом (иначе Митник стал бы дедушкой, пока сломал бы), а по определенному направлению. В полученных от нужного сервака ответных пакетах он смотрел текущее значение ID-поля и времени. По этим данным Кевин пытался предположить, какой алгоритм юзался, и проверял это, посылая новый запрос с другим идентификатором. Отказ в обслуживании избегался периодичным разрывом соединения. После успешного вычисления алгоритма изменения начального значения идентификатора TCP-соединения Митник послал поддельный запрос на TCP-соединение с доверяющим сервером (с ломаемой тачкой). Тем самым атакующий добился возможности исполнения любых команд на удаленном сервере. После этого дело осталось за малым - Кевин послал на взломанный сервер команду "echo + + >>/.rhosts". Эта команда дополняет файл /.rhosts строчкой "+ +" - и теперь любые хосты стали доверенными. Далее Митник закрыл все ранее открытые соединения - ведь после этого он получил возможность соединяться с нужной тачкой как доверенный комп, уже совершенно без геморроя. Вот и вся любовь!


Спецвыпуск Xakep, номер #015, стр. 015-066-4, Атака Кевина Митника

Атака Кевина Митника

UFO (ufobject@mail.ru)

Спецвыпуск Xakep, номер #015, стр. 015-066-4

Встать! Суд идет!

Вот так вот и кинули специалиста по компьютерной безопасности. Во время атаки он был где-то на лыжном курорте. Вернувшись, спец обнаружил послание, оставленное Кевином. В этом послании Кевин яростно опустил Шимомуру, на что тот не по-детски обиделся :). Арестовали хакера и закрыли на долгий срок. Так что думай - повторять тебе атаку Кевина или нет. А то раз на раз не приходится: может - прославишься, может - загремишь за решетку, а может - и то и другое. В любом случае, учи TCP-протокол.

Привет тебе из далекого космоса!


Спецвыпуск Xakep, номер #015, стр. 015-068-1, Черви в паутине

Черви в паутине

UFO (ufobject@mail.ru)

Спецвыпуск Xakep, номер #015, стр. 015-068-1

Захотелось мне однажды поковырять сеть на предмет всякой живности. Например, сетевых червей. А что, эти гады ползут по всему Инету, устраивают нехилый трафик и веселую жизнь пользователям :). А главное, сами находят своих жертв. Давай теперь мы их поищем и покажем, кто тут хозяин природы и кому положено стоять во главе пищевой цепочки.

Сетевой дарвинизм

По запросу на поисковике мне вылетела целая куча ссылок. До этого я почему-то думал, что интернет-червей довольно мало, но теперь понял, что очень круто ошибался. Конечно же, девяносто процентов из тех червячков, которых я нашел, являются модификациями когда-либо созданных червей-прародителей, но попадались такие интересные модификации, что у меня антенны торчком вставали :). Единственное, что меня сильно огорчило, - это то, что нынешние вирьмейкеры не соблюдают совершенно никаких правил оптимизации своих созданий. Вот раньше, в DOS'овские времена, хорошие вирусы писались на АСМе, Паскале и иногда на C. Естественно, лучшие вирусы получались на Assembler'е, так как их скорость была максимальной, а размер - минимальным. Взять хотя бы тот же самый Win95.CIH. Его еще не одно поколение вирьмейкеров помнить будет! А сейчас? Сейчас кодеры стали до того ленивыми, что пишут вирусы на Visual Basic! Да где это видано :)? Если бы мне года два назад кто-нибудь сказал, что вири будут писаться на визуальных языках, я бы со смеху помер, а теперь это считается в порядке вещей :(. Вот такая вот эволюция... Конечно же, я не утверждаю, что вирусы - это хорошо, но уж если ты их пишешь, то пиши нормально. И еще одна вещь, которую я бы хотел высказать: больше всего меня взбесило то, что чуть ли не половина всех созданных червячков размножается через Outlook. Нашел какой-то чел способ пересылки через письма этого почтовика, и все начинают повторять за ним. Неужели сложно придумать что-нибудь свое? Что-то новое? Ну, ладно. Не буду вгонять тебя в тоску своими проповедями, а лучше расскажу про тех животных, которые активно кишат в наше время в сети. Начнем?

I-Worm.Melting

Давай для начала рассмотрим интересного с точки зрения изучения, но ламероватого в исполнении нет-червяка - I-Worm.Melting. Червь представляет собой виндовую EXE'шку, которая распространяется по мылу и занимает всего 17 Кб. Опять же страдает бедный Outlook. При активизации червь запускает встроенный в него скрин-сейвер и, пока юзверь любуется имитацией плавления своего монитора, создает письма в Outlook с сабжем "Fantastic Screensaver". Текст письма содержит следующее сообщение:

"Hello my friend!

Attached is my newest and funniest Screensaver, I named it MeltingScreen. Test it and tell me what you think.

Have a nice day my friend.

p.s.: Please install the Runtime Library for VB 5.0, before you run the ScreenSaver".

Интересен сей червь тем, что разработчики постарались и не стали банально прикреплять свое творение к письмам в виде какой-нибудь порнухи, а придумали грамотную легенду - замаскировав его под скрин-сейвер. А почему "ламероватый червяк"? Да потому, что сам вирь требует установить библиотеки для VB 5.0 (так как червь написан именно на этом языке), что есть несомненный sux - хороший вирус должен быть написан так, чтобы мог самостоятельно заражать любую среднестатистическую машину.


Спецвыпуск Xakep, номер #015, стр. 015-068-2, Черви в паутине

Черви в паутине

UFO (ufobject@mail.ru)

Спецвыпуск Xakep, номер #015, стр. 015-068-2

Sonic

Это уже более серьезный пример. Sonic был обнаружен 30 октября во Франции и в Германии. Отличительная черта этого червя заключатся в том, что он имеет функцию самообновления. На момент обнаружения вируса он был совершенно в сыром виде, но автор виря может в любое время обновить его с помощью хак-сайта, который находится на сервере "Geocities". Червь постоянно ломится на зашитый в нем урл и пытается скачать с него свои обновления. Сам Sonic состоит из двух модулей: загрузочного и основного. Функция загрузочного модуля заключается в обновлении основного модуля. Основной модуль, в свою очередь, представляет собой троян, который безбожно прет разную секретную информацию с зараженной машины. Надо сказать, что идея скрестить троянца и червя не покидает головы вирьмейкеров уже много лет :). Выгода очевидна - троян распространяется самостоятельно!

Magistr.B

Этот интернет-червь, скорее всего, является модификацией вируса Magistr.A. Почему "скорее всего"? А понимаешь, некоторые эксперты утверждают следующее: "Magistr.B написан совершенно другим программистским почерком, чем Magistr.A. Вероятно, Magistr.B был написан с целью устроить компьютерную диверсию. Не исключено, что B-модификация червя Magistr была переслана в Европу из США". Такие предположения породили мифические свойства этого вируса - Magistr.B пока гуляет только по Европе и еще ни разу не переползал через Атлантику. Еще одна отличительная черта Magistr.A от Magistr.B в том, что B-модификация при определенных условиях может полностью очистить твой хард от файлов. Вирус размножается с помощью нескольких почтовых клиентов. В их число входят Outlook, Outlook Express, Eudora, Netscape Messenger и некоторые почтовики служб Web-почты. Вирус создает письмо, в котором и сабж, и само тело письма генерируются случайным образом. К письму могут быть приаттачены файлы с различным расширением, но сам вирус хранится в файле readme.exe.

KakWorm.d

Этот интернет-червь обладает очень оригинальным свойством - он размножается только на компах, которые находятся под управлением французской версии Windows. Для размножения червь использует дыру в IE 5.0. При прочтении зараженного письма на компьютере пользователя в папке автозапуска создается файл OUT.HTA. После передачи управления этому файлу реестр маздайки правится так, что при создании нового письма в почтовом клиенте в созданное письмо вставляется невидимый кусок с телом червя. Для того чтобы не заразиться этим вирусом, достаточно просто поставить последние заплатки для пятого IE или периодически проверяться в венерической больнице :).

Code Red

А вот этот червячок превзошел сам себя. С целью собственного размножения вирус нещадно юзал дыру в серверах, использующих Microsoft Internet Information Services (IIS). Поначалу этот вирус не заметили ни Microsoft, ни лаборатория Касперского. Заговорили же о нем только после заражения более тысячи серверов. Самое интересное заключается в том, что Code Red, сканируя сервера на предмет дыр в IIS, вывел из строя кучу DSL-маршрутизаторов производства Cisco Systems. Киски Системс пока молчат по поводу причины выхода из строя их роутеров, но разгадка не за горами.


Спецвыпуск Xakep, номер #015, стр. 015-068-3, Черви в паутине

Черви в паутине

UFO (ufobject@mail.ru)

Спецвыпуск Xakep, номер #015, стр. 015-068-3

MyBabyPic

Совсем недавно появился еще один веселый вирус, который демонстрировал пользователю, запустившему его, порно-ролик со звуковым сопровождением. Вирус размножался по почте. Он генерировал письма, в сабже которых находился текст "My baby pic!!!", а сам текст письма содержал фразу "Its my animated baby picture!!". Сгенерированные письма рассылались по адресам, содержащимся в почтовом клиенте. Основная часть юзверев, к которым приходило такое письмо, думали, что это очередной спам, а мысль о заражении интернет-червем в головы им даже и не приходила :(. Мало того - те, кому понравился ролик, сами рассылали этот файл своим знакомым и коллегам. Пока ушастый юзверь наслаждался порнухой, вирь успешно располагался на его компьютере и портил кучу файлов, имеющих следующие расширения: VBS, VBE, JS, JSE, CSS, WSH, SCT, HTA, PBL, CPP, PAS, C, H, JPG, JPEG, MP2 и MP3. Сам вирус написан на Visual Basic. Дебилизм, блин.

Nimda

Совсем недавно возникла новая эпидемия интернет-червя Nimda. Это довольно грамотно написанный червяк, который размножался не с помощью одной дыры, как предыдущие вирусы, а через несколько. Этот вирь способен прыгать по тачкам, на которых установлены Окна 9x или 2000/NT. Кроме того, Nimba поражал сервера и клиентские компы с установленным сервисом IIS. И это еще не все! Он использовал своих братьев по оружию - CodeRedII и sadmind/IIS. Он заражал тачки, на которых находились эти вирусы. Если поражалась машина с установленной Windows 9x, то вирь писал себя в автозапуск и активизировался при загрузке маздая. Если заражалась Windows 2000 или NT, то он искал HTML-файлы в каталогах с уровнем вложенности до 4 по всему компу и, найдя, модифицировал их так, что через эти файлы передавалось его тело. Если же вирь заражал какой-нибудь сервер, то удалялась главная страница паги, и, при попытке захода на нее, вирус оставался жить на машинах тех пользователей, у которых оказывались открытыми используемые вирусом дыры. При попадании на машину с установленной Windows 2000 Nimba так же пытается заразить все EXE-файлы. Размножается этот зверек способом рассылки по почте своего тела в файле readme.exe, который прикрепляется к заразительному письму. Само письмо представляет собой HTML-файл, при просмотре которого автоматически запускается приаттаченный readme.exe. Это, наверное, единственный настоящий интернет-червь по сравнению с теми червями, которые мне попадались до него. Суди сам ;).

DoS.Storm

Мда... :) Бедный, бедный Билл :). Опять его обижают, но на этот раз не пользователи его продуктов, а интернет-червь под названием DoS.Storm. Этот вирь написан совершенно криво, и его очень легко обнаружить и удалить. DoS.Storm использует многострадальную щель в сервисе IIS. А чем же этот червячок обижает Билла? А тем, что он периодически устраивает DoS-атаки серверу www.microsoft.com и посылает кучу совершенно дебильных писем на один из почтовых адресов Билла Гейтса. К всеобщему сожалению, вирус очень медленно размножается из-за своих огромных багов, а атаки на почтовый адрес Билла не приносит Гейтсу совершенно никакого вреда, так как настоящий адрес Гейтса засекречен. Вирус обречен на полное вымирание. А жаль ;).


Спецвыпуск Xakep, номер #015, стр. 015-068-4, Черви в паутине

Черви в паутине

UFO (ufobject@mail.ru)

Спецвыпуск Xakep, номер #015, стр. 015-068-4

All3gro

Приятель, а ты можешь представить себе "хороший вирус"? Не в плане грамотного кодинга, а в плане помощи пользователю :)!!! Вот я себе тоже не представляю, однако такой вирус есть, и называется он All3gro. Этот вирь рассылает себя по всем адресам из адресной книги почтового клиента зараженного компьютера и пытается излечить этот компьютер от таких интернет-червей, как SirCam, Badtrans и PrettyPark. Думаешь, загон? Не-е-ет. Он на самом деле пытается это сделать, но лечит их не до конца, а мало того, еще может и переусердствовать, удалив некоторые системные файлы и нужные тебе документы :). Вирус рассылается в письме с приаттаченным файлом Antivirus.exe, в котором и находится его тело. Хороший предлог для запуска нашли :).

Салат готов, сир!

Вот, в принципе, и все, что я хотел рассказать о червях, которыми кишмя кишит сегодняшний Инет. Это были самые толстые и жирные черви (ну еще бы - под VB-то :)). Кстати, говорят, что если их грамотно приготовить, получается очень даже вкусно ;). Так что если поймаешь случайно парочку, не расстраивайся особо - просто возьми дизассемблер и выпусти червяге внутренности.


Спецвыпуск Xakep, номер #015, стр. 015-070-1, Канун Нового Года

Канун Нового Года

Спецвыпуск Xakep, номер #015, стр. 015-070-1

Я оседлал единорога! Ну что, фраги, побегаем?

Ты опять меня ухлопал!

Хех, то-то! Погамайся с мое!

Что-то я не понял... Откуда в "кваке" взялся единорог?! Он же вроде в героях только. Прикалываются что ли надо мной?

А ты чего сегодня такой грустный? Скучно гаматься?

Нет, все классно. Просто завтра новый год, а шеф на работе урезал мне зарплату. А я так хотел купить виртуальный шлем, уже даже модель подобрал... Эх.

Не бери в голову! Подумаешь, дело! Завтра же праздник!

Черт! LPT-порт мне в зад, если минуту назад обои в этой комнате не были другими! Это уже не похоже на прикол! Что происходит!?

Мальчики, я заварила чай. Будете?

Мы с нашим супер-гамером вообще-то уже собирались оставить вас наедине. Надо еще успеть подарки всем купить...

Да, так что, ребят, пока! И с наступающим вас, мы завтра к вам еще завалимся.

Ну, что ты такой грустный? Пойдем лучше елку собирать.

Дорогая, что у тебя с волосами? Мне показалось, что у них минуту назад поменялся цвет...

Цвет волос?! Глупенький, как может измениться цвет волос за минуту? Вот если хочешь, ч могу завтра сходить в салон и вернуться шикарной блондинкой.

Ок, не обращай внимания – мне, наверное, надо меньше времени проводить в инете... Пошли собирать елку!

Утро следующего дня.

Милый, ты уже проснулся? Ты не поверишь! Пока ты спал, к нам заявился настоящий Дед Мороз и принес какой-то здоровенный подарок, он стоит под елкой. Посмотри. А я пока приму ванну.

Интересно, что это такое?

Вау! Не может быть! Костюм виртуальной реальности!!

Во это да!

Прошло двадцать минут...

Кажется, я все правильно собрал и подключил. Пора испробовать эту штуку в деле!

Кажется, я в загрузочном меню... А это, что? Кнопки? Круто, никогда не нажимал на кнопки, наступая на них! Прямо как в кино.

Не понял? Виртуальная реальность подозрительно не отличается от реальной. А вы все как сюда попали?

Ура! Получилось! Макрос сработал!

Слава UNIX’у, нам удалось тебя вытащить!

Пару дней назад мы действительно подарили тебе шлем виртуальной реальности, ты в нее вошел и там застрял. Сидел тут и только дергался.

Маша позвонила нам, мы приехали. И начали ковыряться в софте, прилагающемся к шлему.

Мы долгое время не могли понять, как тебя вытащить, потом придумали: написали макрос «Деда Мороза», который подарил тебе шлем виртуальной реальности в ней же самой. Мы все так настроили, что когда ты его надел, попал уже в нормальную реальность, а не в виртуальную. Мы тебя отключили, когда ты нажал кнопку «Enter» в главном меню псевдо-виртуальной реальности.

А вы не прикалываетесь? Хотя нет, я помню, что там происходили какие-то глюки – все время менялись какие-то мелкие вещи. Да и сам виртуальный костюм был какой-то странный, уж очень совершенный.

Естественно, мы все это смоделировали!

Спасибо, ребят, что меня вытащили... Стоп! А это что такое?! На моем столе стояла обычная пкшка, а теперь Мак! Я, что, еще в виртуальной реальности?

Да, точно – как здесь оказался Мак? Значит, мы... все... в..?

Или кто-то один. А остальные это только модели... Может, сейчас в реальной реальности двое из нас пытаются вытащить третьего...


Спецвыпуск Xakep, номер #015, стр. 015-070-2, Канун Нового Года

Канун Нового Года

Спецвыпуск Xakep, номер #015, стр. 015-070-2

Да какая на самом деле разница, где какая реальность? Мы все находимся здесь, все вместе, и мы есть мы! Реальность – это то, в чем мы находимся прямо сейчас, в данный момент, а все остальное виртуальная реальность.

А раз мы все тут, значит мы можем, наконец, отпраздновать новый год! С Новым Годом!

С Новым Годом!


Спецвыпуск Xakep, номер #015, стр. 015-074-1, Варезные залежи в IRC

Варезные залежи в IRC

Спецвыпуск Xakep, номер #015, стр. 015-074-1

hurrigane[fish] (hurriganka@pisem.net), UFO (ufobject@mail.ru)

Об IRC ходит такое количество баек, что непонятно, чему верить. Часто бывает так: люди сидят в IRC, но не знают и десятой доли возможностей этой замечательной тетки ;). Вот и сейчас: перед нами открывается очередная замечательная фича ирки - обмен варезом!

FileServer

Под варезом понимаются проги, кряки и вообще все, что плохо лежит. А лежит все это на винтах юзверей. Как доставать будем? А есть такая штука, FileServer называется. Это действительно что-то вроде сервера, который позволяет обмениваться файлами через ирку. Суть сей фичи в следующем: чел через IRC открывает доступ к определенным папкам на своем винте, в которые складывает варез, порнуху, мп3шки - что в голову придет. Ты, соответственно, можешь приконнектиться к этому челу и утянуть то самое все, что плохо лежит ;). Найти такие файл-серверы можно, например, на каналe #warez буржуйского далнета - там постоянно рекламят свои файл-серверы, указывая при этом, что на них есть. На русском далнете толковых файл-серверов, к сожалению, нет :(.

Осуществить попытку коннекта можно с помощью команды, указываемой в поле Trigger в строке рекламы. Это могут быть команды, начинающиеся с "!" или просто ключевое слово. Обычно если у человека есть файл-сервер, то он старается трубить об этом всем и вся, так что если при заходе на канал ты увидишь notice-сообщение, выскочивший приват или просто приветствие с предложением зайти на файл-сервер с помощью такой-то команды - не теряйся и действуй ;). Общение с файл-сервером происходит обычно в режиме DCC-чата. Только заидентифицируйся, пожалуйста, под каким-нибудь зарегистрированным ником, прежде чем попытаешься к кому-нибудь присоединиться! Иначе в большинстве каналов ты не сможешь ничего писать и, соответственно, коннектиться к файл-серверу.

Командуй!

Зайдя на файл-сервер, ты оказываешься в некой псевдооболочке с псевдокомандной строкой :). Чем-то похоже на FTP. Есть даже свои команды. Вот их небольшой список:

dir - показывает содержимое текущей папочки (dir /w выведет содержимое в несколько столбиков).

cd - change directory, сменить директорию - например cd .. (идти в корневую директорию) или cd warez (идти в директорию warez).

get warez.exe - где warez.exe - имя файла, который ты хочешь утянуть (файл начнет скачиваться по DCC).

read warez.txt - читать текстовые файлы.

exit - выход (аналогично команде bye).

Рулесы

Скачивать-то можно, а как же закачивать? А нельзя, нет по дефолту таких команд. Правда челы, которые держат файл-сервера, обычно обходят этот запрет написанием буквально нескольких строчек скриптов - а для чего, сейчас объясню. Если ты решишь заняться поиском порнухи или вареза в IRC, тебе придется услышать термин "trade", или трейдинг (на серваках вареза он не распространен, так как закачивать туда файлы, как правило, владелец попросту не разрешает). Трейд - это обычный обмен, менная торговля ;). При коннекте на файл-сервер ты получаешь определенный лимит на то, что ты можешь скачать, в Кб. Когда-нибудь этот лимит исчерпается, а порнухи-то тебе хочется ;), поэтому хочешь - не хочешь, а придется закачать что-то на файл-сервер (прямо как BBS какой-то! =)). Соответственно, лимит твой поднимется (я сказала - лимит! =)), и ты сможешь опять тянуть порнуху.


Спецвыпуск Xakep, номер #015, стр. 015-074-2, Варезные залежи в IRC

Варезные залежи в IRC

Спецвыпуск Xakep, номер #015, стр. 015-074-2

Disconnect

Ну, вот ты и узнал, что можно утянуть с тети Ирки. Имхо, такими темпами Ирц скоро разовьется в нечто большее, чем просто сеть для общения :). И неизвестно, до чего к этому времени дорастет сам Инет ;). Все самое интересно еще вереди! А пока все дружно качаем и варез ;).


Спецвыпуск Xakep, номер #015, стр. 015-076-1, Сетевые прелести никсов

Сетевые прелести никсов

Zero Gravity (dik@taifun.ru)

Спецвыпуск Xakep, номер #015, стр. 015-076-1

Вот уже который год ты счастливо юзаешь свою винду и забот не знаешь. В то же время твой сосед-очкарик - обладатель маниакального взгляда :) - клеймит тебя позорным "ламо" и утверждает, что "Никс - рулез форева!!! А все остальное - мастдай". Все бы ничего, но, начитавшись всякого продвинутого чтива, надумали вы организовать себе сетку. И даже Инет к ней подрубить умудрились. Казалось бы, что и тут нет ничего худого, однако ж, по странному стечению обстоятельств, твой компутер стал периодически выдавать непонятные сообщения о том, что сетка не пашет, а вингейт ваш коллективный начисляет тебе подозрительно много трафика. И твой сосед-очкарик как-то странно на тебя стал посматривать, ехидно улыбаясь. Созрел? Если да, то я поделюсь с тобой парой простых истин о никсах и виндах.

Убей нежно

Для начала приведем небольшую сравнительную характеристику обеих осей. Сразу можно сказать, что сети и никсы шли бок о бок еще с давних времен. И никсы достигли высокого уровня в реализации межсетевого взаимодействия. У них сетевые функции встроены в ядро, что, конечно же, ведет к высокой эффективности и стабильности системы в целом - типа, летает все и не виснет из-за того, что ты, например, курсорчики себе анимашками заменил. Так же на уровне ядра реализована защита от самых распространенных сетевых атак - таких, к слову, как DoS. Очевидным следствием подобной реализации является более надежное сетевое соединение и гибкость настроек. Можно, конечно, сказать, что и твоя любимая винда довольно гибка в настройках, но после большинства изменений тебе необходимо ее перезагрузить, что абсолютно не нужно никсам!!! Выходит, что (как и разрекламированная мастдаевская надежность) это есть только видимость гибкости.

Теперь вернемся к поискам разгадки злобных ухмылок твоего сумасшедшего соседа-линуксоида. А вот, кстати, и простой пример сомнительной гибкости и надежности одновременно ;). Наши веселые "друзья"-мастдайцы, ваяя свою незабываемую винду, предусмотрели в ней защиту от случайного присвоения двум машинкам одного и того же IP-адреса. Система работает так, что если у одной винды есть IP 1.2.3.4, для примера, то другая такого взять уже не сможет, а на экран выведет сообщение об ошибке инициализации сетевого интерфейса. Итак, берем linux и назначаем ему тот же IP, что назначен машинке под управлением windows, находящейся в твоей сетке и имеющей открытый доступ на маршрутизаторе в нет. Для этого достаточно просто выполнить команду "ifconfig eth0 <ip убиваемых виндов>". Даже перезагрузки не потребуется! После этого у нас к eth0 привязан ip win-машины, а у мастдая на экране появится сообщение о том, что указанный адрес уже используется и сетевой интерфейс будет принудительно отключен. То есть любой, кто в обычном Ethernet сидит под linux, автоматически становится повелителем сети по отношению к win-пользователям. Не лишним будет заметить, что если попытаться сделать подобное с каким-нибудь клоном никсов, то обе машины будут настаивать на том, что они используют правильный адрес. Будет происходить постоянная борьба за адрес, но ни один интерфейс не упадет, хотя и работы у них никакой не выйдет. Теперь понял, почему этот пучеглазый любитель пингвинов при встрече тебе ухмыляется :)?


Спецвыпуск Xakep, номер #015, стр. 015-076-2, Сетевые прелести никсов

Сетевые прелести никсов

Zero Gravity (dik@taifun.ru)

Спецвыпуск Xakep, номер #015, стр. 015-076-2

Мой прокси - мой кэш!

Ладно. Допустим, что у вас сетки нет, и Инет, выделенный к вам в дом, еще не подвели (или даже есть и все подвели - читай ниже). Твой любимый сосед может оказывать на тебя и другие виды морально-психологического давления. Ситуация. Вроде и АТС у вас одна. И провайдер один и тот же. Но почему у этого прохвоста на его задрипанном Acorp 56k страницы при серфинге грузятся быстрее твоих? И вообще, ответы от удаленных машин приходят быстрее, чем на твоем трижды орденоносном зухеле иди даже курьере? И вот еще раз я тебе поведаю о секрете злорадных ухмылок!

Ты любишь путешествовать по сети. Это хорошо :). Проксю юзаешь провайдерскую? Наверняка юзаешь и именно провайдерскую. А в стандартный пакет любого никса входит такой прокси-сервер, как squid, - общемировой стандарт, вообще-то. Причем у твоего прова, скорее всего, тот же squid и стоит. Ну и зачем тогда он мне нужен, спросишь ты? Объясню. Вообще, зачем обычно нужен прокси? Главный его понт в данном случае в том, что у него есть такой таинственный кэш, который на деле хранит в себе не обновляемые компоненты часто посещаемых юзверями страниц. Зачем он на самом деле нужен прову, я не скажу - коммерческая тайна, пускай прову будет хорошо - нам не убыток с того. (А вот я скажу: просто пров покупает Инет у более крутого прова и платит за трафик. Так что ему выгоднее держать наиболее часто посещаемые страницы на локальном винте, чем отгрохать деньги за немереный трафик, который юзеры устроят, обращаясь к этим ресурсам каждый раз заново - прим. ред.) А вот юзеру он нужен для повышения скорости загрузки страниц. Но скорость между прокси прова и тобой ненамного больше скорости между тобой и сервером, который тебе нужен. Понимаешь, к чему я клоню? К тому, что, юзая прокси, установленный на своем компе, ты действительно чувствуешь плюсы использования данного сервиса, так как кэш лежит на твоем винте и грузится очень быстро. Осознал, о чем я? Вдумайся!

Кончено, для тех, кто сидит на выделенке, это не увеличит скорости серфинга, хотя денег сохранит немного, но для пользователей dial-up это даст существенный прирост в скорости. Итак, если при инсталляции linux ты выбрал установку squid, то просто набираешь команду squid -z и пишешь в настройках браузера адрес прокси-сервера 127.0.0.1, порт 3128. Все, ты уже начал накапливать свой собственный кэш! Если ты все-таки хочешь приобщить к этому делу прова, то в файле конфигурации тебе надо в параметре cache_peer указать адрес своего провайдера. После этого ты запрашиваешь данные, если их нет в твоем кэше, прокси обращается к кэшу прова. Хорошо накопленный кэш работает куда эффективнее, чем кэш браузера - особенно виндового. Он позволяет просматривать страницы с экономией трафика на 20-40%. В зависимости от твоей ситуации, это или экономия бабла на те же цифры, или прирост скорости серфинга в тех же объемах.


Спецвыпуск Xakep, номер #015, стр. 015-076-3, Сетевые прелести никсов

Сетевые прелести никсов

Zero Gravity (dik@taifun.ru)

Спецвыпуск Xakep, номер #015, стр. 015-076-3

И еще один кэш

Теперь ты сидишь и кайфуешь, юзая прокси, и думаешь, а какие у меня еще есть преимущества как у обладателя никсов? Преимуществ много! Возьмем, к примеру, службу DNS. Так как ты юзаешь никсы, соответствующий сервер у тебя уже стоит. Что тебе даст использование собственного DNS сервера? Ты, конечно же, понимаешь, что определение IP по имени - это процедура, требующая передачи запроса по сети. Это опять есть трафик и дополнительная загрузка твоего и так хиленького модемного канала. Учитывая, что запрос к DNS серверу идет при каждом твоем обращении к любому хосту, трафик накапливается немереный. Использование своего DNS-сервера ускорит процесс получения данных из сети в силу того, что DNS-сервер кэширует адреса, которые через него проходят. Помнишь мое откровение о проксях? Тут та же история. Если запрашиваемая информация есть в локальном кэше, то клиент и получает ее локально, без каких-либо обращений по сети.

Как же это все настроить? Очень просто! Для начала берем файл "/etc/resolv.conf", и добавляем в него строку "nameserver 127.0.0.1", причем если там уже есть какие-либо записи, начинающиеся с "nameserver", то наша запись должна быть самой верхней. После этого при поиске адресов первым делом система будет обращаться к локальному DNS. Если мы решили, что наш сервер будет посылать запросы корневым кэшам, а так и делается по умолчанию, то самое время набрать команду named и насладиться.

Никс - рулез форева!!!

Говоря о гибкости никсов на уровне сетевых интерфейсов, следует упомянуть и еще пару деталей. Например, если при установке PPP соединения мы запустим соответствующий сервер вот таким образом: "pppd ...ваши параметры... lcp-max-configure n", где n - число посылаемых запросов, то мы сможем повлиять на процесс согласования параметров работы канала передачи данных, реализованный протоколом LCP. По умолчанию посылается 10 запросов. Если не получен ответ, что может случиться, если на другом конце сервер медленно работает или просто перегружен, то связь рвется. Увеличивая число запросов, мы даем возможность ответить серверу и все-таки установить соединение. Дальше - больше! Посредством простейших команд в никсах для любого сетевого соединения устанавливаются такие параметры, как MRU и MTU, прямо влияющие на скорость и куда более важные, чем все вышеописанное. В мастдае этот уровень настройки соединений скрыт во мраке. Кто ищет, тот найдет, безусловно, но зачем терпеть эти очередные усложнения и скачивать многочисленные "приблуды" к мастдаю из нета для настройки таких тривиальных вещей?

Итак, резюмирую. Настроившись под никсом описанным выше способом, мы с тобой сможем добиться куда более выдающихся результатов в скорости, производительности и стабильности, чем под твоей ненаглядной виндой. И при этом на все уйдет не более пяти минут, ни одной перезагрузки компутера, и мы не встретим конфликтов, так как поддержка основных устройств либо встроена, либо тесно интегрирована с ядром системы ;). Никс - рулез форева!!!


Спецвыпуск Xakep, номер #015, стр. 015-078-1, Оживи свой сайт - вешаем халявные компоненты на хомпейдж

Оживи свой сайт - вешаем халявные компоненты на хомпейдж

Леша (frozzzen@xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-078-1

Салют тебе, пагостроитель! Сегодня мне выпала честь рассказать тебе про всякие интересные халявные скрипты, буки, чаты, которые можно найти в Сети и прикрутить к своей паге. Впрочем, прикрутить-то их полбеды: подробная инструкция для каждого компонента - на сайте производителя! =0) А вот чтоб тебе не пришлось самому искать эти самые "сайты производителей" (причем, проверенные сайты) - ву-а-ля! Прошу заимствовать.

Скрипты

Ты, наверное, не раз видел всякие красивости типа падающих снежинок, выпадающих менюшек и заполняемых форм. Так вот: все это реализуется с помощью скриптов, а значит, и ты сможешь забацать не хуже! Сейчас я объясню, как это делается. Скрипт - это по сути программа, последовательность команд. Пишут их на разных языках, в основном - на Яве (словосочетание "Ява-скрипт" слышал?). Прелесть скрипта в том, что он относительно безлик: ты можешь запросто взять чужой экземпляр и заставить его работать на своем сайте. Для этого имеются следующие сайты с бесплатными скриптами:

http://www.superbest.com/javascript/ - прекрасная коллекция всевозможных java-скриптов. Все описания на русском!

http://javascript.internet.com/ - если тебе нужен любой java-скрипт, то... он есть здесь! Сайт построен по принципу "выдели и скопируй". Загляни сюда обязательно!

http://members.xoom.com/javaapp/ - на этом сайте собрана большая коллекция разнообразных, полезных и не очень скриптов, которые ты легко можешь скопировать и поставить на свою пагу, тем самым сделав их дизайн еще более оригинальным.

http://www.anfyjava.com/index.html - много различных скриптов. Всяко-разных, пестрохвостых :).

http://www.javascripts.com/ - название говорит само за себя. Огромное количество скриптов! Аж глаза разбегаются, и не понять, какой нужен.

Счетчики

Всегда мечтал знать, сколько пиплов посетило твой порнушный сайт %)? Для этого служат счетчики. Висит такая масенькая штуковина у тебя на сайте и показывает количество посетителей с момента открытия паги.

http://counter.rambler.ru/top100/top_add.shtml.ru - самый известный счетчик. Прост в установке и банален.

http://www.spylog.ru - аналогично. Тут я выбрал тип счетчика 'КРОХА' как самый простой и бесплатный.

http://www.stars.ru/ - и снова счетчик! Необходимо зарегистрировать страницу в каталоге "Созвездие Интернет". http://counter.list.ru/ - 6 вариантов этого самого счетчика =0). Необходимо зарегистрировать страницу в каталоге "List.ru".

http://www.infoart.ru/misc/ihits.htm - подробная статистика посещаемости твоей паги. Довольно приятная система.

http://nikitad-rossmt.mega.ru/presents/count.htm - 12 вариантов счетчика, регистрация не требуется.

http://www.better-counter.com/ - заимствуй ОЧЕНЬ удобный Java-интерфейс для просмотра статистики посещаемости твоего сайта!

http://www.hitbox.com/ - твоя страница участвует в рейтинге World 1000.

Гестбуки и форумы

Неплохо было бы знать, что думают пять с половиной человек, посещающие твою пагу =0). Для этого нужна гостевуха или форум. Люди будут приходить к тебе на пагу, созерцать плоды креатива, а после дружно потопают в гестбуку - материться =0), или в форум - вопросы задавать. Кроме того, у гестбуков и форумов есть обычно экстра-возможности: например, они умеют рассылать новые сообщения по указанным тобой мыльницам или фильтровать нецензурщину. Правда, на всех халявных ресурсах обычно висит реклама - баннерок, баннерочек или баннерище...


Спецвыпуск Xakep, номер #015, стр. 015-078-2, Оживи свой сайт - вешаем халявные компоненты на хомпейдж

Оживи свой сайт - вешаем халявные компоненты на хомпейдж

Леша (frozzzen@xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-078-2

Гестбуки:

http://www.guestbook.ru - первый адрес, что пришел в мою черепную коробку. Легкая регистрация (от тебя требуется знать адрес своей паги, твое мыло и название твоей будущей гестбуки =0)), минимум наворотов.

http://www.ipclub.ru - кроме буки, включает в себя халявную статистику и поисковый ресурс. Странно, но эта пага в ДОС'овой кодировке...

http://www.ipclub.ru:8102/free/guestbook/register.html - гостевая книга. Опять же без особых прибамбасов.

http://www.ipclub.ru:8102/free/guestbook/index.html - один обыкновенный и три маленьких баннера на странице с гостевой книгой, можно редактировать записи.

http://guestbook.jettech.ru/ - отдельная страница с твоей новой гостевухой!:)

http://www.dreambook.com/ - гестбука. Из рекламы: баннер и текст, можно изменять цвет фона, текста и ссылок.

http://www.geniusweb.com/gbook/ - гостевуха, можно изменять цвет фона и текста.

http://www.theguestbook.com/ - можно изменять цвет фона, текста и ссылок, вообще довольно гибко настраивается.

Форумы:

http://www.yourbbs.com/wizard/ - ламериканский сайт YourBBS. Гибко настраиваемый форум.

www.guestbook.land.ru - простой удобный форум, быстрый, можно менять цвета, есть антимат, счетчик посещений. Как обычно - внизу баннер :(.

http://assembly.nerdworld.com/default.asp - форум в обмен на баннер и децл текстовой рекламы. Да подавитесь вы своим баннером!

http://www.beseen.com/ - баннер. Просто баннер (хотя конкретно на бисине он убирается, но как - секрет фирмы). Вообще же, бисиновский форум - один из лучших.

http://www.insidetheweb.com/ - баннер над форумом и два баннера под ним. И форума почти не видно.

http://www.yourbbs.com/ - ура, форум без рекламы! Очень удобный интерфейс, можно задавать темы для обсуждения.

Форумы реального времени =0)

Ну что, дружище, пришло время пообщаться с другими себе подобными господами и товарищами. И пусть отдельные несознательные граждане вопят, что веб-чаты - это отстой, я все же тебе о них расскажу.

Что есть чат - можно не объяснять? На кроватке был? Ну и слава Богу :). Не был? Странно. А сюда как попал?

Ну ладно, неважно. Главное - ниже.

http://chatcity.ru/chatreg.shtml - многофункциональная компания (здесь тебе и чат, и бука, и форум). Можно менять фон, размеры, положение фреймов, цвет, вставлять свои баннеры, менять регданные, создавать админов и модераторов, делать приват-чат, включать матотестер %).

http://www.null.ru - чат, мягко говоря, скромненький. Но зато регистрация сводится к вводу имени чата и кликанью по кнопке create, и никакой рекламы.

http://chat.land.ru/ - тоже чат. Из рекламы - баннер.

http://www.beseen.com/ - чат, использующий фреймы, реклама - баннер и два его маленьких брата.


Спецвыпуск Xakep, номер #015, стр. 015-078-3, Оживи свой сайт - вешаем халявные компоненты на хомпейдж

Оживи свой сайт - вешаем халявные компоненты на хомпейдж

Леша (frozzzen@xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-078-3

http://www.chatplanet.com/ - ого! Java-чат. Тормозной, но зато на Яве =). Оно тебе надо?

http://www.anes.com/ - Java-чат, интересен тем, что работает даже через firewall.

Дисконнект

В общем, вот тебе ссылочки - юзай на здоровье стандартные компоненты и не парься, как они устроены. У больших дядек этот подход называется инкапсуляцией - сокрытием данных. Так что, в некотором роде, инкапсулируйся :). Приобщайся то бишь. Удачи!


Спецвыпуск Xakep, номер #015, стр. 015-080-1, Лего-дизайн, или веб-конструкторы

Лего-дизайн, или веб-конструкторы

Спецвыпуск Xakep, номер #015, стр. 015-080-1

Вадим Мурзагалин (vadias@sendmail.ru) & MOOF (http://moof.ru; moof@real.xakep.ru)

Наверняка ты уже взломал пару десятков сайтов, поимел шестизначный номер аси и лично встретился со всеми герлами из местных чатов. Если так, то настало время увековечить себя во всемирной паутине :). Можно, конечно, сломать сайт Микрософта и сесть на долгие годы в тюрягу. После этого ты станешь популярным (среди сокамерников :)). Но есть более простой способ рассказать всем о себе: сделать сайт. Конечно, для этого можно быстренько (за пару лет) выучить HTML и начать профессионально делать сайты. Хотя лучше потратить это время на написание очередного exploit'a. Ну а про то, что «лень - двигатель прогресса», ты и без меня наслышан. Поэтому давай рассмотрим средства веб-дизайна для тех людей-"двигателей прогресса", кто не желает тратить драгоценные минуты своей великой жизни на изучение HTML и сопутствующих ему фишек, - средства, получившие меткое название "веб-конструкторы".

Тот, кто пользуется Интернетом, однозначно знает о том, что все веб-страницы пишутся в основном на языке гипертекстовой разметки - HTML. Зная средний уровень пользователей сети, службам халявных хостингов пришлось предоставить средства, позволяющие избежать копания в коде и даже изучения WYSIWYG-редакторов. С помощью этих средств страница строится визуально и очень просто. Конечно, название "веб-конструкторы" довольно громкое: ты не можешь свободно перемещать объекты и крутить их по своему желанию. Ты как бы вставляешь детали в уже подготовленные пазы - помнишь анекдот про кубик Рубика для прапорщиков :)?

Сегодня мы поговорим о том, на что способны конструкторы, предлагаемые наиболее популярными хостингами. Схема работы такая - сначала ты регистрируешься на бесплатном хостинге, потом ищешь конструктор (они называются на каждом сервере по-разному). Поработав и наконструировав вволю, ты нажимаешь на кнопочку и - наслаждаешься готовым сайтом. Итак, заходим на популярные хостинги...

www.boom.ru

Было время, когда Boom.ru держал пальму первенства среди раздатчиков халявы. Если мне не изменяет память, это на Буме впервые предложили имя username.boom.ru, в то время как на других халявных хостингах приходилось довольствоваться убогим адресом вроде domen.ru/balbes_po_imeni/username. Зарегистрировавшись, я тут же приступил к изучению бумерского конструктора (здесь он носил гордое название "дизайн-студия").

Забегая вперед, скажу, что этот конструктор мне приглянулся больше других; читая нижеследующий текст, ты сам просечешь причины. Во-первых, здесь оказались вполне симпатичные шаблоны, и я выбрал самый "стильный", по иронии судьбы носящий одноименное название - "style page".

Во-вторых, текст меняется прямо на месте: на рисунке видны фразы "создать заголовок страницы", "создать текст страницы" и другие. Когда щелкаешь по какой-либо из этих фраз, под ней появляется удобное меню, где ты вводишь текст, выбираешь его размер, начертание (полужирный и курсив) и цвет; гарнитуры, к сожалению, не оказалось - ну да ладно, положимся на подбор гарнитуры дизайнеров boom.ru.


Спецвыпуск Xakep, номер #015, стр. 015-080-2, Лего-дизайн, или веб-конструкторы

Лего-дизайн, или веб-конструкторы

Спецвыпуск Xakep, номер #015, стр. 015-080-2

Нижнюю часть страницы занимала строка со ссылками. Меня поначалу несколько смутило то, что количество ссылок не регулируется. Восемь штук для первой страницы - это многовато, и если увеличивать это количество вряд ли придет кому-нибудь в голову, то уменьшить - святое дело. Но когда я ввел только одну из ссылок и нажал "далее", чтобы страница сохранилась на узле, оказалось, что в итоговом варианте все лишние ссылки исчезли ;).

Чуть ниже находится кнопка "настроить параметры страницы" - если щелкнуть по ней, появится большое меню, где вводится титульное название страницы, выбирается фоновое изображение, цвет фона, а по желанию - даже фоновый звук! Кроме того, есть три чекбокса, чтобы использовать: гостевую книгу, счетчик посещений и счетчик TopList. И последний раздел - внешний вид ссылок.

Резюме: самый удачный, на мой взгляд, из веб-конструкторов. Интересные шаблоны; простота редактирования страницы сочетается с наглядностью и эффективностью. Результат стараний лежит по адресу http://spezxakep.boom.ru/ .

www.narod.ru

В последнее время народ.ру пользуется наибольшей популярностью - сказывается своевременное появление и грамотный маркетинг раскрутки. Но речь идет о конструкторах. Итак, я зашел на narod.ru и зарегистрировался. На этот раз предмет исследования назывался "мастерская". Может, я ничего не понимаю, но качество шаблонов здесь мне совсем не понравилось. Я даже грешным делом подумал, что хозяин сервера дал сделать эти шаблоны в качестве развлечения своему сынишке, но потом вспомнил, что narod.ru напрямую связан с yandex'ом, а yandex - с А. Лебедевым. Что ж, против таких авторитетных людей не попрешь - выходит, что шаблоны крутые :).

После выбора шаблона следует переход на страницу редактирования. Опций оказалось немного: цвет фона, поле для ввода заголовка, поле для ввода основного текста и, соответственно, опции для них: цвет, начертание и размер; далее - формы для ввода ссылок и выбор цвета для простых, активных и посещенных. Отличительная черта конструктора - кнопка "надо больше ссылок". По умолчанию их пять. То, что я получил, нажав на кнопку "Готово", меня не впечатлило.

Порадовало наличие возможности создать свой шаблон, куда я также залез. В шаблонах можно менять практически все, не зная при этом ни единого тега. Все просто и понятно: пишешь текст, выбираешь цвет текста и фона, размер шрифта, вводишь ссылки и... жмешь "готово". У меня выскочило "Ошибка в базе данных!" :). Вообще "народ" - о-о-очень загруженный сервер, и такая ошибка вываливалась у меня достаточно часто :(.

Последней моей мыслью, когда я уходил с сайта "народа", было подозрение, что разработчики нарочно сделали такой конструктор, чтобы пользователи сами учили HTML и осваивали графические редакторы. Продвинутые пользователи могут просматривать и редактировать созданные странички в виде HTML прямо через браузер или загружать свои файлы на сервер.

Резюме: довольно заурядный конструктор. Я знаю, что в веб-дизайне следует стремиться к простоте, и понимаю, что тот, кто разрабатывал данный конструктор, за минуту сделает подобную страницу в notepad'е с закрытыми глазами. Но если уж делаешь подобное средство, то следует позаботиться о тех, кто не обладает твоими знаниями, но хочет получить путевую и яркую персональную страничку.


Спецвыпуск Xakep, номер #015, стр. 015-080-3, Лего-дизайн, или веб-конструкторы

Лего-дизайн, или веб-конструкторы

Спецвыпуск Xakep, номер #015, стр. 015-080-3

Результат моего творчества можно посмотреть тут: http://spezxakep.narod.ru/ .

www.chat.ru

Этот хостинг жил королем как раз в то время, когда я только вошел в жизнь Интернета (сам считай, когда это было :)). Несмотря на некоторую глючность, популярности ему было не занимать; про веб-конструкторы я узнал именно здесь. Конструктор здесь назвали своим именем - "конструктор-создатель Интернет страниц". Некоторые из предлагаемых шаблонов показались мне неплохими, я выбрал один наугад и нажал "далее". Загрузилась страница колоссальной высоты - это заставило меня подумать, что количество опций здесь огромно. Но впоследствии оказалось, что между строками довольно большое расстояние, а устройство редактируемой страницы содержит много блоков. У меня создалось впечатление, что разработчик - бывший военный: каждая следующая опция именовалась шагом и нумеровалась. Шаблонные страницы здесь имеют более сложное устройство из-за большого количества разделов, вряд ли необходимого каждому юзеру, - у тебя, скажем, есть три потока новостей :)? Чтобы избавиться от них, надо просто сделать пустыми соответствующие поля. К каждому пункту даются понятное пояснение и инструкция: "Выберите цвет текста названия страницы", "Выберите цвет фона под подзаголовком" и тому подобное.

В конце концов, я нажал кнопку "Далее" и перешел к созданной странице. Кхе-кхе... получилось средне. Во-первых, проблемы с кодировкой. Пришлось лезть в настройки браузера и менять ее вручную. Картинка, которую я загрузил со своего компа, растянулась до "необходимых странице" размеров со всеми последствиями. Одна из ссылок, которую я указывал, почему-то не появилась, вторая не работала, после чего в голову пришла мыслишка - "а не работает ли у них цензура?".

Резюме: хотя создатели пытались сделать максимально понятный интерфейс для самых умных - все дается строго по шагам, генерируется страничка не лучшим образом. Плюс подарок - букет сопутствующих проблем. Хотя... для создания странички здесь я потратил минимум времени и получил минимальный результат: http://spezxakep.chat.ru/ :).

SiteCity.RU

Следующий ресурс "SiteCity.RU - город сайтов" не так известен, как три предыдущих участника обзора. Давай посмотрим, что же он собой представляет. Для начала проходим стандартную процедуру регистрации (куда же без этого?), проверяем почту (на нее должен прийти пароль) и заходим в панель управления. SiteCity меня порадовал продуманной панелью управления. Все разложено по своим категориям, кроме того, нет ярких раздражающих цветов Народа и Бума. Возможности визуального редактирования здесь не очень широкие, однако все очень удобно.

Кроме того что можно создавать и мучить дизайн странички, у SiteCity есть ряд дополнительных возможностей. Можно, например, запаролить доступ к сайту - то есть пускать на страничку только своих друзей, которые знают пароль. Тут же можно прописать мета-теги и поставить на сайт свои счетчики и баннеры. Отдельной похвалы заслуживает раздел статистики.


Спецвыпуск Xakep, номер #015, стр. 015-080-4, Лего-дизайн, или веб-конструкторы

Лего-дизайн, или веб-конструкторы

Спецвыпуск Xakep, номер #015, стр. 015-080-4

Резюме: Хороший сервис с множеством дополнительных возможностей. Сам же конструктор не дотягивает до высшей оценки - поставим ему 4-. На полученный сайт можно глянуть тут: http://spezxakep.sitecity.ru .

Sitemanager.ru

После первого взгляда на сайт SiteManager'a становится ясно, что сервис не для лохов :). Строгий дизайн и содержание текстов сообщают нам о том, что он предназначен в первую очередь для различных организаций. Но нас это ведь не остановит, правда? Регистрируемся и выбираем шаблон для создания сайта. Если приглядеться к изображениям шаблонов, то в заголовке можно прочесть "lamers must die" :). Поскольку сайт рассчитан на коммерческие организации, то шаблонов с цветочками, бантиками и мертвыми ламерами на черном фоне тут нету. Панель управления достаточно проста и продумана. Есть небольшой курс обучения и множество дополнительных сервисов: поиск по сайту, почта, статистика (некоторые платные). Это, конечно, все хорошо, но для изменения готового шаблона потребуется минимальное знание HTML'я. Без него тут никуда. Результат моей работы можно увидетьть на: http://spezxakep.sitemanager.ru .

Резюме: Сервис не для нас. Кроме того что некоторые услуги платные, так еще и для создания уникального дизайна нужно знать HTML.

fanat.ru

Сервер с конструктором специально для фанатских сайтов :). Панель управления сайтом достаточно продвинутая и имеет много возможностей. Отличные подсказки помогут даже тем, кто не может себе представить сайт вида: "640*480, реклама, оглавление наверху, меню в центре" :). Кроме того, есть неплохое превью. Пройдя 15 шагов, ты легко сделаешь почти уникальный сайт, совершенно не зная HTML. Кроме конструктора, есть и небольшая система обновления для созданного тобою сайта.

Резюме: Этот конструктор тоже мне очень понравился. Все здорово. Присутствует даже раздел "Регистрация в поисковых машинах". Короче говоря, есть все, что нужно и не нужно. Да, результат можно посмотреть по адресу http://spezxakep.fanat.ru .

www.geocities.com

Общеизвестно, что Россия, как это ни печально, отстает от забугорцев по многим параметрам. Являются ли веб-конструкторы одним из таких параметров - суди сам по представленным фактам и картинкам. Для создания и редактирования страницы на geocities представлены два средства - PageWizards и PageBuilder. Последнее назвать конструктором не поднимается язык :) - это оказался настоящий онлайновый WYSIWYG-редактор (правда, работать с ним на диалапе довольно утомительно). Но PageWizards - конструктор в чистом виде. Предлагаемые шаблоны ты можешь видеть на картинке: типичный американский дизайн, изысканный, как их юмор.

После выбора шаблона, в отличие от "отечественных аналогов", настройка параметров подается не на одной странице, а постепенно, чтобы ты смаковал каждый новый элемент. Слева ты постоянно видишь картинку, на которой четко обозначены все этапы "веб-дизайна", а справа - формы для заполнения. Только когда заполнишь нужные поля и нажмешь "Next", тебе дают редактировать следующий элемент страницы. Ошибиться тут тебе не дадут :). Набор функций вполне стандартный.


Спецвыпуск Xakep, номер #015, стр. 015-080-5, Лего-дизайн, или веб-конструкторы

Лего-дизайн, или веб-конструкторы

Спецвыпуск Xakep, номер #015, стр. 015-080-5

Резюме: нашим американским друзьям удалось сделать сверхпростого помощника по созданию и изменению шаблонных страниц. В целом - нормально :).

Удар ниже пояса в спину

Итак, ты просек, что такое веб-конструкторы, как они работают, и увидел некоторые из них в действии. Осталось выяснить, что целесообразнее - воспользоваться их услугами либо все же взяться за самостоятельное изучение HTML и иже с ним? Для начала определись, что тебе нужно в принципе. Если обычный персональный сайт, на котором ты предложишь публике полюбоваться на свои фотографии, рисунки и физические данные, то веб-конструктора хватит с головой. Ты сэкономишь время и нервы - что бы там ни говорили, за 24 часа всю эту кухню не освоишь. Кроме того, если ты волей случая обделен талантом дизайнера (кстати, кроме таланта необходим и некоторый опыт), то лучше, чем разработчики шаблонов, ты не сделаешь. И это нормально - быть талантом во всех областях невозможно.

Но не следует забывать, что веб-конструктор - это ограниченная система. Ты всего лишь собираешь сайт из имеющихся деталей, и повторы здесь неминуемы. Так что на оригинальность можешь уже не претендовать. В вещах же более сложных, чем просто представление текстовой и графической информации, - таких, как интерактивные элементы, динамические страницы, - веб-конструктор также не помощник. Здесь нужно тщательное и вдумчивое изучение, долгие часы над книгами и перед компьютером и сотни проб и ошибок. Что выбрать - дело твое, а мне остается лишь пожелать тебе удачи - либо в общении с конструкторами, либо с освоением секретов дизайна :).


Спецвыпуск Xakep, номер #015, стр. 015-082-1, Новинки браузеров и почтовиков

Новинки браузеров и почтовиков

n0ah (noah@real.xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-082-1

Web и почта - вот две основные сетевые службы, которыми пользуются абсолютно все. Естественно, что и развиваются они наиболее динамично и активно. Представить сложно, насколько сильно изменился web за последние, скажем, четыре года! Статичные странички с минимумом графики, разверстанные в лучшем случае во фреймах, ушли в прошлое, вытесненные мощными, интерактивными веб-программами, которые уже не просто отображают информацию, но и занимаются ее обработкой, анализом и сортировкой. И такой прогресс продолжается постоянно: одни протоколы сменяют другие, все время появляются новые спецификации, новые технологии, новые языки программирования... Естественно, что так же сильно эволюционирует и софт, призванный дать конечному пользователю возможность всей этой ерундой насладиться. В нашем случае это браузеры и почтовые клиенты. Самым последним новинкам в этой области и посвящен сей обзор.

Internet Explorer 6.0

Брать тут: http://www.microsoft.com/ie/

Самая свежая версия микрософтовского ослика. В отличие от версии 5.5, Internet Explorer 6.0 матерым ослом не назовешь - разве что осленком. Уж очень он нестабильно стоит на своих копытцах ;). Падучий, гад. Зато теперь примерно десять процентов от всех падений и зависаний сопровождаются специальным окошком, в котором Microsoft приносит нам официальные извинения за доставленные неудобства ;). Оставшиеся девяносто процентов глюков этой тулзой не отлавливаются и протекают как обычно - молча. Вот, например, один неприятнейший баг, который сразу же после установки нагло засветился на моей машине, - если открыть шестым Эксплорером какой-нибудь более-менее большой (больше ста кило) локальный jpg-файл, то браузер будет открывать его минуты две, корчась при этом в страшных муках. Со стороны все это выглядит так, как будто он конкретно завис :( - на щелчки не реагирует, в панель не сворачивается. Остается только либо ждать, пока ослик очнется, либо убивать его совсем, теряя одновременно все остальные открытые окна браузера.

Ок, достаточно о глюках - так можно все место в журнале занять ;). Давай лучше скачаем и установим ослика. Для этого необходимо утянуть маленькую программу-инсталлятор с сайта Microsoft. Многие не понимают, в чем преимущества такого, на первый взгляд, извратного способа установки, но сотрудники MS чтят его свято - и совершенно правильно делают! Просто инсталлятор позволяет выбрать и установить именно те компоненты, которые хочет пользователь, не скачивая весь дистрибутив.

Согласен, это не самый удобный способ (дисконнекты, отсутствие докачки...), но все же лучше, чем качать тридцать мегов непонятно чего ради одного только браузера. Кстати, в это "непонятно что" местами входят очень даже полезные вещи! Например: свежая версия проигрывателя Windows Media и его кодеки, проигрыватель Macromedia Flash, почтовик Outlook Express, дополнительные фишки IE и прочее. Все это желательно обновить вместе с браузером, чего не скажешь о поддержке японского, китайского и прочих экзотических языков. К слову, что мне очень нравится в Internet Explorer - это то, что он основательный, фундаментальный и всеобъемлющий :). Я имею в виду, что, единожды его установив, можно уже не беспокоиться, что на каком-нибудь сайте найдется формат, который браузер не сможет осилить: открывается и правильно отображается все - от любых наворотов явы до флеша. Так что советую не жмотиться и поставить IE без особо жестокого урезания компонентов. Больше по поводу установки сказать нечего - перейдем к настройке.


Спецвыпуск Xakep, номер #015, стр. 015-082-2, Новинки браузеров и почтовиков

Новинки браузеров и почтовиков

n0ah (noah@real.xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-082-2

Внешний вид ишака не изменился совсем - только иконку перерисовали :-\. Единственное, что подается кастомизации - это панели. Лично я сразу убил панель ссылок, а на остальных уменьшил кнопочки и убрал текст. Если нажать на панель правой кнопкой и кликнуть "Customize", можно выбрать кнопки, которые будут на этой панели жить. Настройки IE, не касающиеся интерфейса, доступны из меню Tools -> Internet Options либо из панели управления (иконка Internet Options).

Тут все осталось, как и в прежних версиях. Единственное, что изменилось - и посему представляет интерес, - закладка Advanced. Такое впечатление, что кодеры запихнули сюда все настройки, которые их заломало систематизировать и рассортировывать по разным меню :). Но все равно удобно - настроек много, и местами они очень даже гибкие, что совсем не свойственно для микрософтовского программного обеспечения. IE доступен под платформы: win32, Mac, HPUX, Solaris.

Подводя итог, хочу сказать, что браузер Internet Explorer сам по себе очень даже хорош (да, даже несмотря на то, что он маздайный и что одно время очень грязно продвигался!), но шестая его версия почти ничем не отличается от пятой, поэтому и ставить ее особого смысла нет. Кстати, если верить спайлогу, уже 92% пользователей сети юзают ишаков ;).

Netscape 6.2/Mozilla 0.97

Брать тут: http://www.netscape.com/, http://www.mozilla.org/

Я объединил эти две программы вместе, так как они практически ничем не отличаются (с точки зрения пользователя, во всяком случае). Netscape я юзаю, когда сижу под Linux, а Мозиллу скачал для разнообразия под винды. Качаются обе проги либо в виде пустых инсталляторов, либо в виде инсталляторов, укомплектованных всеми необходимыми пакетами (тогда сеть во время установки не требуется).

Первое впечатление от Netscape 6.2 - монолитный комплекс программ, призванный решить все вопросы юзера, связанные с пользованием сетью. В комплект входят браузер, почтово-новостной клиент, редактор HTML и AOL Messager. В последней версии Мозиллы AOL Messager`а нет, зато есть ChatZilla - встроенный IRC-клиент. Пользы от него мало, так как прога это еще глючная (как минимум, проблемы с кириллицей), да и неудобная какая-то :( - я ее уже попробовал. Что еще больше усиливает впечатление о тяжеловесности Нетшкафа - это нехилый промежуток времени, который успевает пройти между запуском браузера и его появлением на экране :(. С Мозиллой под винды дела обстоят чуть получше, но и то благодаря тому, что ее загружают в трей при стартапе (соответственно, она жрет память все время).

Что касается интерфейса, то у Мозиллы и Нетшкафа принята политика скинов. Тут слов нет - тот же скин Modern, поставляемый в комплекте, достоин восхищения. А сколько таких шкур можно накачать из Инета ;). В общем, по интерфейсу за Шкафом и Мозиллой не угнался еще ни один браузер. При желании также можно поиграться с панелями: я, например, сразу убрал Personal Toolbar и громоздкую Sidebar, освободив этим больше места для отображаемых сайтов.


Спецвыпуск Xakep, номер #015, стр. 015-082-3, Новинки браузеров и почтовиков

Новинки браузеров и почтовиков

n0ah (noah@real.xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-082-3

Настройки доступны через меню Edit -> Preferences. Не могу сказать, что они уж очень гибкие, но до уровня IE дотягивают... Нет, даже, пожалуй, чуть больше. Но все равно некая неповоротливость ощущается. Мозилла, кстати, намного в плане настраиваемости превосходит Netscape. Вообще, Мозилла отличается от Нетшкафа экспериментаторски-новаторским характером разработки. То есть если Шкаф предназначен для всяких офисов, интернет-клубов и прочих пользователей, которым в первую очередь необходимы стабильность и завершенность браузера, то Мозилла катит в личное пользование на домашние машины юзеров, которые не боятся некоторого количества глюков ;), но хотят за это получить самые свежие разработки.

Отдельно хочу отметить почтовый клиент, встроенный в Мозиллу/Нетшкаф. Не ахти какая удобная прога, но жить вполне можно. Похоже на помесь бата с аутглюком ;). Я ее даже юзаю для работы с USEnet.

Мозилла поддерживает просто огромное количество платформ! Среди них: win32, Mac, Linux, AIX, BeOS, FreeBSD, HPUX, NetBSD, OpenVMS, OS/2, Solaris, Tru64 Unix. Практически благодаря Мозилле теперь любая платформа обеспечена нормальным браузером и почтовиком. Netscape - чуть меньше ;).

Короче говоря, и Шкаф, и Мозилла - вполне пригодные для юзанья браузеры (и даже почтовики), но немного неудобные из-за своей тяжеловесности. Под виндами их захочет пользовать, наверное, только любитель или чел, позарившийся на красоту интерфейса, но вот под никс равных им нет. Так что если ты в душе пингвин, качай одно из двух и браузь на здоровье ;).

Opera 6.0

Брать тут: http://www.opera.com/

Opera - один из самых лучших браузеров на сегодняшний день! Легкий, быстрый, удобный, содержит огромное количество настроек. К тому же в Опере впервые были реализованы некоторые очень удобные фишки :). Например, знаменитая операшная кнопка, одним нажатием приостанавливающая загрузку изображений на странице и таким же нажатием ее возобновляющая. Или то, что все новые окна в опере открываются как новые документы в основном окне программы, а не как отдельные окна. Скачать опера можно в двух вариантах: с Java и без нее. С явой оно, конечно, побольше весит, но не отказываться же полностью от явы из-за пары мегабайт!

При первом запуске браузер выдает окошко, в котором можно выбрать стиль отображения окон: все в одном или каждое отдельно. Даже по виду этого окошка видно, что в интерфейсе браузера произошли некоторые изменения ;). И действительно - в очередной раз поменялись стандартные кнопки, а еще добавилась возможность класть в фон окна приложения любую картинку или текстуру. Если пофантазировать с этой возможностью (учитывая еще и то, что все цвета, шрифты и иконки всех кнопок в интерфейсе браузера тоже меняются по желанию), можно добиться весьма серьезных дизайнерских результатов. Сбацать, например, себе интерфейс браузера в стиле X ;). Короче, внешний вид Оперы кастомизируется досконально, и это просто классно!


Спецвыпуск Xakep, номер #015, стр. 015-082-4, Новинки браузеров и почтовиков

Новинки браузеров и почтовиков

n0ah (noah@real.xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-082-4

Еще мне очень нравится, как в Опере реализован режим полноэкранной работы. Full screen - это, блин, full screen! Без каких-либо панелей, кнопок и прочей фигни, как в IE, Mozilla и других! В Опера организован правильный full screen. Разворачиваешь браузер на весь экран и давай серфить. И никакие кнопочки не нужны - благо предусмотрена возможность использования "жестов мышкой". Это специальные движения мышом в сочетании с зажатой правой кнопкой, уловив которые, браузер выполняет те или иные действия так, как если бы была нажата кнопка. Например, зажав правую кнопку и потянув крыску влево, можно получить эффект нажатия стрелки "Left". И таких "жестов" целая куча - можно делать все что угодно! Черт, ничего более удобного я еще не видел :)! При использовании "жеста мышкой" в первый раз Опера вежливо осведомляется у пользователя об этом и спрашивает, стоит ли оставить эту функцию включенной. Конечно, стоит!!!

Все настройки браузера лежат в меню File -> Preferences. Их там огромное количество - все остальные функции Оперы поддаются настройке не хуже, чем интерфейс. Тут тебе и отображение документов, и настройка звука, и опции мультимедиа, и сетевые настройки - все, что только может в голову придти!

В Opera есть встроенные почтовый и новостной клиенты, но до совершенства им еще очень далеко. Почтовый клиент можно пользовать разве что в аварийных ситуациях, но работать с ним постоянно - просто несерьезно.

Opera работает под win32, Linux, Mac, Symbian OS, QNX, OS/2. Линуксовая версия, к сожалению, пока что больше походит на капитально покореженного инвалида, чем на нормальный браузер, и для полноценной работы не годится :(. Если в ближайшее время версия под линух дотянет по качеству до виндовой, я, скорее всего, перейду от Нетшкафа на Оперу ;).

Итак, Opera - отличный браузер, который подойдет как продвинутому веб-серферу, который любит все настраивать под себя, так и пользователю, который просто хочет поставить браузер, и чтоб все работало (хотя для последнего случая, конечно, лучше пользовать IE). Если в предыдущих версиях Оперы еще возникали какие-то проблемы с открытием тех или иных ресурсов (типов файлов, типов медиа), то теперь их практически не стало! Шестая версия - сказка, а не программа, поэтому обновляться надо обязательно ;).

The Bat! 1.53d

Брать тут: http://www.ritlabs.com/the_bat/

Вампирчик - любимый почтовик X-Crew :). И неспроста. Основное его преимущество в том, что для каждого ящика создается отдельный аккаунт. Кроме того, The Bat! очень удобен и хорошо развит. В нем предусмотрено абсолютно все, что может понадобиться при работе с почтой. Прога весит всего около мега и устанавливается из одного файла. При первом запуске предлагается создать какой-нибудь аккаунт. Очень удобно, что вся почта (вместе с аттачами), адресная книга и настройки всех учетных записей хранятся в одной директории - .\MAIL. После очередной переустановки можно просто скопировать старую папку MAIL на место новой, и тогда не придется заново вводить даже настройки аккаунтов - вводишь его название, а Бат сам все подставляет :). Кстати, раньше все аттачи к письмам хранились в поддиректории Attach, а в новой версии вампира можно выбирать: хранить их вместе с мессагами или в отдельной папке.


Спецвыпуск Xakep, номер #015, стр. 015-082-5, Новинки браузеров и почтовиков

Новинки браузеров и почтовиков

n0ah (noah@real.xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-082-5

Еще одна фишка новой версии - Connection Centre. Эта тулза занимается отправкой и доставкой почты. Она намного продвинутее, чем простенькие прогресс-бары, которые юзались на этом же месте в предыдущих версиях. Connection Centre имеет тасклист, отображающий все текущие соединения, где показывает общее количество мессаг на сервере, их размер, статус соединения и приблизительное время скачки.

Если скачать и поставить International Pack, можно будет вытянуть Бату интерфейс на любом языке (ну не на любом, конечно, но языков там много), в том числе и на русском. Можно также устроить себе русский спеллчек.

Интерфейс у Бата настраивается полностью, но только в функциональном ключе, а не внешнего вида. Например, можно полностью изменить область окна, где показывается список сообщений: задать ширину в пикселях любого поля (From, Subject), добавить/удалить любое поле и так далее. Панели в Бате плавающие, поэтому их можно пихать куда угодно ;).

Но самая главная фишка этого почтовика состоит в том, что, работая с ним, ты работаешь с архивом своей почты как с некой базой данных. Очень радует грамотный поиск, а также функции сортировки писем. Например, функция Kill dupes убивает все одинаковые мессаги в данной директории. Вот накопилось, скажем, на сервере двадцать писем, шесть из них ты скачал, потом произошел дисконнект. Ты переконнектился и скачал еще восемь (первые шесть из которых у тебя уже есть), вдруг опять дисконнект. И так несколько раз - получается, что одна мессага у тебя может оказаться в нескольких экземплярах. Ну не искать же и не удалять их все руками?! Нет, достаточно сходить в меню Folder -> Kill dupes in all folders ;). И таких удобных функций очень много!

Под занавес хочу проорать, что The Bat! - лучший почтовик из всех когда-либо мною виденных. Апгрейдиться до свежей версии стоит однозначно! Но делать это слишком часто не стоит. Просто разработчики выкладывают новую версию почти каждый месяц, а реально полезных изменений в них может и не оказаться. Поэтому я советую скачивать новенький Бат, перепрыгивая через три-четыре версии :).

Outlook XP

Брать тут: Mitin0-BazaR

Outlook XP - это не Outlook Express, который идет в комплекте с IE, а тот, который входит в состав MS Office. Считается, что он намного удобнее и продвинутее обычного аутглюка. На самом же деле он удобнее только для работы в офисе (если в конторе проложена виндовая сеть), а для домашнего пользования все его фишки практически бесполезны. Календарь, Задачи, Заметки - все это офисные прибамбасы. А вот база данных контактов - вещь удобная ;).


Спецвыпуск Xakep, номер #015, стр. 015-082-6, Новинки браузеров и почтовиков

Новинки браузеров и почтовиков

n0ah (noah@real.xakep.ru)

Спецвыпуск Xakep, номер #015, стр. 015-082-6

Сразу после установки аутглюк со свойственной всем маздайным продуктам наглостью записал на себя все почтовые файлы и возвел себя в ранг дефолтового почтовика в системе. Невоспитанный, гад :(. Юзать его к чертям неудобно, так как он перегружен всякой фигней, типа "Создать приглашение на собрание" :-/. Да и интерфейс какой-то идиотский: уползающие панели, прячущиеся кнопки... Короче, мне он не понравился. Советую Outlook XP только людям, работающим в большом офисе, где почтовый траффик достаточно велик. А так лучше уж Outlook Express юзать, если ни до чего другого руки не доходят.

Eudora 5.1

Брать тут: http://www.eudora.com/

Eudora - у буржуев считается вторым по значимости самостоятельным (имеется в виду - не входящим в браузер) почтовым клиентом. У меня он почему-то ассоциируется с детским почтовиком. Виноват в этом, наверное, интерфейс :). В принципе программа нормальная, но для действительно активной почтовой переписки не сойдет. Все основные функции почтовика имеются, но не более того. Я по крайней мере не нашел в этой программе ничего такого, что могло бы меня прельстить.

Интерфейс у Эудоры абсолютно нехарактерен для почтовика - все папки, сообщения и прочие элементы программы оформлены как отдельные документы и закладываются в нижнюю панель. Интересно, а сколько этих закладок туда может поместиться? Я открыл восемнадцать новых сообщений... На девятнадцатом Эудора повисла :-/. Хмм... Убил, запустил заново и еще раз открыл около двадцати новых писем - программа опять безвозвратно повисла :(. И так каждый раз. Ну и что можно еще сказать о проге, которая попалась на такой ерунде???

Из фишек обнаружилась возможность посылать голосовые сообщения. Насколько я понимаю, идет попытка вывести почту на качественно новый уровень. Не знаю, может, в будущем оно так и будет, но сейчас об этом думать еще рано (я представляю, если бы все мессаги, которые мне приходят, приходили в голосовом виде :) - у меня на винте столько места нет!).

Короче, могу посоветовать Eudora только тем, кому нужен простой, но достаточно мощный почтовый клиент для нерегулярной, разовой переписки.

Вот такие новости на этом фронте. Читай, вникай, делай выбор. Удачи!


Спецвыпуск Xakep, номер #015, стр. 015-086-1, Защита огнем - тест файрволов

Защита огнем - тест файрволов

Спецвыпуск Xakep, номер #015, стр. 015-086-1

MadDoc (maddoc@real.xakep.ru) и n0ah (noah@real.xakep.ru)

Как известно, лучшая защита - это нападение. Но нельзя же, каждый раз выходя в сеть, вешать все ближайшие сервера - чтобы враг точно не смог подобраться к твоему компу. Гораздо проще защитить свою машину от попыток вторжений с помощью специальных прог. А правильный выбор средств безопасности в сексе... тьфу, в сети, не менее важен, чем правильный выбор средств контрацепции. Поэтому сегодня мы рассмотрим эти программные средства ака файрволы, призванные надежно оградить твой подключенный к Интернету компьютер от внешних атак. Для тестирования на машину была установлена Windows 98 SE, ослик был проапгрейден до 5.5 SP2. Кроме того, был поставлен ftp-сервер (Serv-U, его описание ты найдешь в этом же номере). Сканеры к бою, поехали!

McAfee Personal Firewall

С сайта производителя (www.mcafeee.com) нельзя скачать даже триальную версию - предлагается сразу оформить годовую подписку за каких-то тридцать вечнозеленых. Ну-с, попробуем поюзать...

На выбор предлагается три режима работы - блокировать весь траффик (а зачем тогда в сеть лазить?), пропускать весь траффик (а зачем тогда прогу ставить?) и фильтровать его. Естественно, выбираем последний вариант.

Установив прогу, выходим в нет. По очереди появляются окошки - «программа такая-то просится в сеть, пустить?». Пускаем всех кого надо, попутно настраиваем файрвол на показ самой полной статистики.

В разделе «Unknown Traffic» меня ждал сюрприз - вон сколько попыток соединения было произведено за несколько минут! Все они были автоматически обрублены, а я поехал изучать дальше.

Как видишь, все тоже достаточно подробно. Локальный и удаленный порты, время соединения, количество принятых и посланных байтов.

Следующий тест - запуск двух троянов, любезно предоставленных для тестирования компанией... ээ, увлекся, извини. Обоих файрвол сразу отловил, и в сеть я их не пустил. Начинаем детально разбираться с защитой - запускаем фтп-сервер и просим коллегу рассмотреть мою защиту подробнее. Сначала - простое сканирование портов (с третьего по двадцать седьмой) прогой 7thSphere Port scanner. В сети сканера попался единственный открытый в этом диапазоне порт - 21-ый (на нем висел фтп-сервер Serv-U). Далее в бой пошла 7thSphere Port Fuck. Она использовалась для постоянной бомбардировки фтп-шного порта моей машины - в среднем количество открытых сокетов в единицу времени составляло около 250. То есть Port Fuck постоянно требовал открыть соединение, а моя тачка их постоянно закрывала - в результате все жутко тормозило, но работало.

Далее - следующий уровень безопасности системы. Переписываем Iexplore.exe во временную директорию, а на его место записываем telnet.exe (переименовав его в ыксплорер.еге, соответственно). Тут-то файрвол и облажался по полной. Мало того что без всяких вопросов телнет был пропущен в сеть, так и эксплорер, будучи запущен из нового места, точно так же получил свободный доступ! На скриншоте видно, что в системе появилось два приложения с одинаковым именем, и около одного из них даже стоит значок телнета.


Спецвыпуск Xakep, номер #015, стр. 015-086-2, Защита огнем - тест файрволов

Защита огнем - тест файрволов

Спецвыпуск Xakep, номер #015, стр. 015-086-2

Продолжаем издевательства. Создаем левую папку и кладем туда тот же самый телнет, переименовав его в iexplore.exe. Запускаем... Телнет без вопросов получает доступ в сеть. Рубишь фишку, да? Для обхода этого файрвола твоему трояну достаточно создать в любой директории на машине клиента файл с названием, совпадающим с именем уже наверняка выпущенной проги, и передать ей управление. Эта прога спокойно получит доступ в сеть, а автор трояна будет в шоколаде... рубить лес в солнечном Магадане. В общем, намек ты понял - ни в коем случае не пиши таких прог! Точно так же ты наверняка догадался, куда я дел этот файрвол...

Zone Alarm

Следующий подопытный - ZoneAlarm от компании ZoneLabs (www.zonealarm.com). Для тестирования мы взяли бесплатную версию - но существует еще и профессиональный вариант, в котором обещают блокирование куков, рекламы и еще до тучи всяких радостей.

Эта прога оставила намного более приятное впечатление. После установки и первого подключения к сети мне опять же в порядке живой очереди предъявлялись претенденты на выход в сеть, а я только тыкал мышкой, разрешая доступ (всем, кроме двух троянов, поставленных заранее). По окончанию опроса был составлен список приложений с полным набором правил для них - а тут возможности задания правил довольно велики. Отдельно можно ставить разрешения/запрещения работы в Интернете или локальной сети; можно пустить прогу в сеть и запретить ей работать как сервер (о чем слезно просила меня Одига).

Следующий этап - сканирование портов. Тут на меня посыпались сообщения, что «файрвол заблокировал доступ к моему компьютеру (порт такой-то) от такого-то IP (порт такой-то)». Более того - нажав на «Что это было?», можно получить более подробную инфу о злоумышленнике. Оказалось, что мой коллега сидит на одном со мной прове. При желании можно было и суппорту пожаловаться...

При активном запросе связи по фтп результат немного удивил - может, конечно, у запрашивающего лаг со связью начался, но я мог и почту принимать/получать, и по нету серфить. А вот он - нет ;-), так у него все тормозило.

Самый же приятный момент - все тот же фокус с подменой Iexplore.exe на telnet.exe. При попытке запуска файрвол сразу завопил - «программа изменилась со времени своего последнего запуска, что делать-то?». Более того, она даже была грамотно определена - что, несмотря на название, это все-таки телнет, а никакой не ишак. Точно такую же реакцию я получил при запуске IE из нового места - здесь ZoneAlarm повел себя с ним как с новой, неизвестной доселе программой, со всеми вытекающими...

Еще одна приятная фича этой проги - режим «экстренной остановки». Он реализован аж в двух вариантах - простого «замка», когда в сеть могут проникать только проги, имеющие не только «разрешение на выход», но и «спецпропуск»; и «полной блокировки» - когда уж никто... Эти функции могут пригодиться, если ты все-таки видишь следы подозрительных действий на твоей машине - спокойно отрубаешь все выходы и входы и, не выходя из нета, ведешь активное наблюдение с соответствующим разбором полетов и наказанием виновных.


Спецвыпуск Xakep, номер #015, стр. 015-086-3, Защита огнем - тест файрволов

Защита огнем - тест файрволов

Спецвыпуск Xakep, номер #015, стр. 015-086-3

Я был довольно близок к тому, чтобы назвать эту прогу лучшей, если бы не два момента. Первый - пару раз за время двухчасового тестирования она все-таки повисла, причем систему пришлось перезагружать. И второй момент - попалась мне в руки еще одна программа, о которой я расскажу ниже.

Norton Internet Security 2001 3.0

Файрвол от компании Symantec (www.symantec.com). Самое противное - скачивать прогу с сайта производителя. После заполнения формы скачиваешь себе программу-установщика, которая после этого вызывает к жизни процесс закачки основного пакета. Скачивать же тринадцать мегабайт полного пакета таким способом довольно стремно - постоянно ждешь обрыва связи. Впрочем, все нормально скачалось и установилось. Запускаем...

Сразу же попадаем в мастера настроек - последовательно проходим через несколько окошек, в которых нам предлагают настроить определенные параметры работы сразу или оставить это на потом. Оставляем все «до лучших времен» и, только слегка изменив некоторые настройки, перезагружаемся, выходим в сеть...

Сначала - обычное сканирование. Файрвол не только с честью выдержал это испытание - через некоторое время я заметил, что атаки прекратились. Оказалось, что во время первичного знакомства с прогой и настройки ее на максимальную безопасность я включил «автоблокировку опасных IP» - и после нескольких попыток доступ «злоумышленнику» был наглухо закрыт, в том числе и на работающий фтп-сервак. В разделе же статистики я мог ознакомиться с логом событий, в другом разделе была возможность вновь открыть прием для блокированного адреса.

Фокус с телнетом тоже не прошел - защитник четко определил, какая прога ломится в сеть под видом ослика, и сама же предложила его заблокировать. Запуск эксплорера из нового места вызвал схожую реакцию.

Были и здесь огорчения - после снятия автоблокировки и особо активного сканирования меня как по фтп, так и по остальным портам - файрвол завис. На экран выскочило сообщение об «ошибке сценария Internet Explorer» - я даже заподозрил безгрешного на этот раз ослика и закрыл все его окна. Нет, ошибка была не там...

Пропал список «доверенных» приложений, пропала возможность изменения любых настроек. Я уж думал, что остался совсем беззащитным - но нет, запуск трояна не прошел незамеченным, и мне предложили не пускать его в сеть. Хотя в списке приложений (теперь «не доверенных») он тоже не появился. Способность файрвола даже в таком почти упавшем состоянии «держать удар» вызвала только восхищение. Закрытые порты тоже остались невидимыми для «взломщика».

Еще здесь понравилась возможность фильтрации контента с довольно тонкой настройкой. Можно прописывать свои правила для каждого посещаемого тобой сайта (причем при установлении высокого уровня безопасности тебя каждый раз будут спрашивать - принимать ли куки с этого сайта, выполнять ли Ява-апплеты и Active-X), можно блокировать рекламу (просто бросая ее в мусорку), можно наблюдать за процессом приема/отбрасывания тех же куков в фоновом режиме. И последняя фича программы - практически вся статистика выводится здесь в одном окне, которое до боли напоминает старый @guard - смотри на скриншот.


Спецвыпуск Xakep, номер #015, стр. 015-086-4, Защита огнем - тест файрволов

Защита огнем - тест файрволов

Спецвыпуск Xakep, номер #015, стр. 015-086-4

Итого

Я понимаю, что три проги - это в принципе маловато для серьезного обзора. Но мы же не станем обозревать программы только для того, чтобы обозреть их (можно было подробно написать про BlackICE Defender, у которого вообще нет возможности фильтрации исходящего траффика - привет жителям Трои). И надеемся, что эта статья поможет тебе в нелегком деле защиты от дальнего своего - или еще в каком деле. Себе я оставил... да неважно. Вся информация у тебя есть, и выбор ты, уверен, способен сделать сам. Удачи!


Спецвыпуск Xakep, номер #015, стр. 015-088-1, Фильтры рекламы: пособие киллера

Фильтры рекламы: пособие киллера

Алекс Целых (editor@technews.ru)

Спецвыпуск Xakep, номер #015, стр. 015-088-1

Сколько себя помню, к геометрии я всегда относился с недоверием: "пифагоровых штанов" не носил, трапецию по бедрам не хлопал, медиану не опускал. Теперь представь мое состояние, когда, дорвавшись до Интернета, я на каждом шагу встречал вымеренные одной линейкой квадраты и прямоугольники. Рекламные транспаранты (баннеры) напирали со всех сторон - глаз невыносимо чесался. Дела пошли веселей, когда друзья по палате подбросили мне тоненькую брошюрку - "Практическое руководство по баннер-киллерам".

Сезон охоты открыт!

По самым скромным оценкам реклама в Интернете отъедает треть трафика и шестую часть полезной площади экрана. Похоже, это не предел. Баннеры продолжают шириться в плечах и набирать в весе пропорционально росту диагоналей юзверьских мониторов: недавно был одобрен стандарт "небоскребов" - 120x600 пикселов. С художественной ценностью и смысловым наполнением, при этом затык. Кислотные палитры, раздражающая анимация, психологические уловки - все это для сетевой рекламы в порядке вещей. Чем изощреннее пытка над юзером, тем больше шансов, что рекламу заметят. Бодреньким галопом в Интернет прискакали технологии ТВ-рекламы - огромные интерактивные баннеры, выпендривающиеся на экране. Красная клякса без спросу перекрывает текст: "Что, съел?". Пачка сигарет калечно вскарабкивается наверх и машет оттуда сухими ручонками. Монотонно долбит Nokia: "А теперь самое время для...". Тьфу ты, напасть!

Между тем, защитить себя от рекламы в Интернете достаточно просто. Даже руки марать не придется. За тебя все сделает программа-киллер. Вообще, подрядить на "мокруху" можно любой файрвол, понимающий стоп-листы. Искать жертву программа будет по ключевым словам. В первую очередь, в "черный список" заносят урлы крупных рекламных площадок, а также "говорящие" буквосочетания: "adv", "banner", "click" и другие. Обнаружив запретную комбинацию, файрвол попросту не дает браузеру сконнектиться с хостом-рекламщиком и сгрузить оттуда картинку или ресурс. Мера жесткая и, надо сказать, эффективная. Правда, есть шансы здорово проколоться. Того не подозревая, ты можешь лишить себя - нет, не девственности - удовольствия заходить на некоторые вполне безобидные сайты. Ну чем провинился центральный склад халявных ковров для мышастых www.freemousepads.com? В его названии присутствует "ads". Таких огрехов при ручной настройке файрвола всплывет ой как много.

Куда меньше геморроя со специальными фильтрами, для которых кастрация назойливой рекламы - предмет профилирующий. Почти все они работают по знакомому принципу файрвола, но, вдобавок, имеют множество дополнительных настроек. Перед тобой маститые киллеры. Рейтинг программы есть число выбитых ею очков, то бишь процент обнаруженной и изничтоженной рекламы.

AtGuard 3.22.11 (1,510 Кб)

http://stophack.net/atguard/

Секьюрити из AtGuard никудышный. Он настолько досконально изучен и описан, что сам себя защитить не может. Зато рекламу выкусывает на раз. Непревзойденной остается фишка "мусорный бак". Перетаскивай на помойку баннеры, для которых ячейки старого "дуршлага" оказались слишком просторными (стоп-листы AtGuard не обновлялись с конца 1999 года). Будь покоен, эту рекламу ты больше не увидишь. Новые правила для "гвардейца" также время от времени публикуются здесь: http://stophack.net/atguard/rule.shtml. Правила не заменяют текущих настроек, а только дополняют их, любезно встревая в хвост списка.


Спецвыпуск Xakep, номер #015, стр. 015-088-2, Фильтры рекламы: пособие киллера

Фильтры рекламы: пособие киллера

Алекс Целых (editor@technews.ru)

Спецвыпуск Xakep, номер #015, стр. 015-088-2

Рейтинг: 76/100 (баннеры), 68/100 (pop-up).

Internet Junkbuster 2.0.2 (270 Кб)

http://waldherr.org/junkbuster/

Простой и маневренный набор "умелые руки" под любую платформу. Графического интерфейса у программы нет. Чтобы запретить конкретный урл, нужно прописать его в "sblock.ini", например: www.microsoft.com. При желании можно скрыть целый домен: .microsoft.com. Или запретить каталоги на всех ресурсах: /billgates, /images/banners. Очень удобно использовать маски: /*.*/banner, /*.*/image*.gif. Тильда (~) перед правилом, напротив, исключает его из общих установок. Настроить Junkbuster с нуля - дело чести для настоящего нетчика. На запрос "sblock.ini" поисковики, вроде Гугла, выдают сотни авторских конфигураций. Пожалуй, самую внушительную я приметил здесь: http://www.waldherr.org/blocklist.

У Junkbuster открытый код, поэтому, кроме базовой, существует несколько доработанных версий программы. Широкое признание получил Junkbuster swa-style (http://ijbswa.sourceforge.net), обладающий тучей экстремальных настроек. В процессе знакомства с ним у меня родилась идея резать баннеры с пользой для мозгов. Честно делюсь с тобой находкой - занимательным способом учить иностранные слова. Для начала заготовь десятка два пустых картинок по размеру баннеров, оптимальный вариант - 468x60 пикселов. На каждой болванке большими буквами напиши иностранное слово и рядом его перевод. Теперь настрой фильтр таким образом, чтобы на месте выдернутых баннеров в случайном порядке появлялись твои изображения. В Junkbuster swa-style для этого есть готовая опция "+image-blocker{}". Продолжая париться в Интернете - без отрыва от производства, - ты на подсознательном уровне будешь усваивать новые слова. Каждую неделю меняй картинки, и результат не заставит себя ждать. Таким макаром можно не только иностранный выучить, но запомнить сложные формулы или подготовиться к сессии по любому предмету.

Рейтинг: 84/100 (баннеры).

Proxomitron 4.0 (1,395 Кб)

http://www.proxomitron.org/download.html

По сути это межконтинентальная функция "найти и заменить". С помощью специальных плагинов можно не просто тупо отключать отдельные элементы страниц, а полностью переписывать их содержимое и внешний вид. Тебя всегда раздражал красный бэкграунд? Поменяй его на зеленый! Можно заместить мигающий текст курсивом, разрешить просмотр скрытого сорца или - небесполезная фишка - показывать настоящий урл, даже если он замазан левым текстом в строке статуса. Оригинальный плагин для Proxomitron легко написать самому. С этой целью в программу встроен дебаггер. Кроме как по ключевым словам, программа ищет баннеры по их типовым размерам. Стоп-листы предусмотрены, но используются слабо. Немудрено, что вместе с баннерами программа иногда удаляет целые куски страниц. У сайта Proxomitron есть официальное зеркало в России (http://proxomitron.nm.ru/), где выложен русский FAQ и коллекция авторских плагинов.


Спецвыпуск Xakep, номер #015, стр. 015-088-3, Фильтры рекламы: пособие киллера

Фильтры рекламы: пособие киллера

Алекс Целых (editor@technews.ru)

Спецвыпуск Xakep, номер #015, стр. 015-088-3

Рейтинг: 67/100 (баннеры), 82/100 (pop-up).

AdSubtract SE 2.42 (2,825 Кб)

http://www.adsubtract.com/se/download.html

В онлайновой забаве "Убей баннер!" (http://pyva.net/play/banners.html) рекламу безжалостно расстреливают. Не из огнемета или криодеструктора, а из старой доброй рогатки. Баннеры здесь самые настоящие, поэтому релаксация наступает быстро. Эта жестокая фантазия получила свое развитие в фильтре AdSubtract. Убийство каждого баннера, по всем правилам жанра, сопровождается звуком выстрела. Одиночной стрельбы практически не слышно, чаще два-три "контрольных". На sex.com киллер выдает пулеметную очередь. AdSubtract - для тех, кто не хочет утруждать себя настройками. Даже апдейт стоп-листов - автоматический. По первым впечатлениям "цирюльник" бреет чисто и аккуратно. На русских сайтах, случается, мажет. AdSubstract в коробочном исполнении, кроме того, убивает всплывающие окна (pop-up).

Рейтинг: 59/100 (баннеры).

Ad Muncher 4.3d (70 Кб)

http://www.admuncher.com/download.shtml

Редкий пример, когда фильтр работает не как файрвол, а на системном уровне, и при этом уживается со всеми браузерами. Написан на Ассемблере, потому такой компактный. Кроме стандартного набора раздражителей, вырезает "взрослые" картинки. На испытаниях показал результат ниже среднего. Стратегия борьбы с всплывающими окнами абсолютно тупа и неэффективна.

Рейтинг: 46/100 (баннеры), 7/100 (pop-up).

Popup Ad Filter 1.1 (740 Кб)

http://www.meaya.com/download.htm

Ходить за варезами и на порносайты следует с особой осторожностью. От всплывающих окошек можно ждать чего угодно. Часто срабатывает "эффект домино": открываешь одну страницу - получаешь пять, затем еще пять по пять. Отвлекся на кухню за чаем - система висит. Я не говорю про вероятность подцепить какую-нибудь заразу в виде веб-бага или западло-скрипта. Popup Ad Filter - спец по этой части. Разработчики не допускают самой возможности прокола, гарантируя 100%-ный результат. Вроде не врут. Программа написана как примочка для Internet Explorer 5 и выше, что накладывает некоторые ограничения, зато не создает лагов при загрузке страниц.

Рейтинг: 100/100 (pop-up).

ActivatorDesk Beta 4 (13,960 Кб)

http://www.activatordesk.com/download.htm

"Безопасный браузер" на движке Internet Explorer со встроенным фильтром. Для зачистки вместо стандартного "черного списка" использует "белый", куда включены 16 тысяч заранее проверенных ресурсов. Уровень защиты можно менять вплоть до полного ее отключения. Для разных пользователей программа хранит индивидуальные настройки.

Рейтинг: 67/100 (баннеры), 54/100 (pop-up).

Заключение

Установить фильтр для рекламы в наше время просто необходимо. Конечно, для полного эффекта придется поработать ручками. Но пару часов с "гаечным ключом" - это не загубленная жизнь в отстойной яме :-).


Спецвыпуск Xakep, номер #015, стр. 015-090-1, Кино о сети, или МЫ глазами Голливуда

Кино о сети, или МЫ глазами Голливуда

Спецвыпуск Xakep, номер #015, стр. 015-090-1

Киберпанк (club@real.xakep.ru); CiberDonor (donor@real.xakep.ru)

Для многих из нас сеть стала необходимой фичей - мы находим там общение, поддержку, адреналин. Мы - нетмены, и без сети и компа чувствуем себя неполноценными, поэтому и в офф-лайне компьютерная тематика занимает значительную часть нашего времени и ресурсов. Мы создали целую субкультуру - киберпанк: жесткую, андеграундную, но в то же время захватывающую и романтическую.

Но положение дел таково, что андеграундная культура пошла в массы и стала модной, на ней стали делать деньги. Теперь уже гораздо сложнее разобраться, что есть киберпанк, а что есть попса. Мы не собираемся тебе ничего доказывать, но если ты считаешь себя киберпанком, то обязан изучить эту культуру во всех проявлениях. Книги, сцена... Сегодня речь о кино. Мы предлагаем тебе обзор наиболее известных movie, так или иначе коснувшихся темы киберпанка. Ты сам оценишь их и решишь для себя, что - находит отклик в твоем сердце, а что - всего лишь кислая пародия.

Бегущий по лезвию бритвы (Blade Runner)

Режиссер: Ridley Scott

В ролях: Harrison Ford, Sean Young

1982 год

"Блейдранер" - культовый фильм для всех киберпанков. Это кино в 1982 году популяризовало новый взгляд на развитие науки и техники и, в частности, кибертехнологий. Ближайшее будущее может быть опасным. Сюжет вкратце такой:

Действие происходит в Лос-Анджелесе двадцать первого века. Бывший полицейский космического патруля вновь оказывается за работой. На этот раз его задача в том, чтобы выследить и уничтожить вышедших из-под контроля репликантов (киборгов), которые обладают интеллектом, умеют размножаться и все более начинают походить на людей. И, следовательно, хотят избавиться от своих прежних хозяев. Конечно же, не обошлось без излюбленной голливудской дилеммы: любовь или долг. Поражает постановочный размах этого фантастического триллера, ставшего классикой современного фантастического кино.

Фильм снят по рассказу Филиппа К. Дика "Снятся ли андроидам электрические овцы?". В 1983 году фильм получает Оскар и всемирное признание, которое длится и до сих пор. Однако критики считают фильм слабым, наверное, поэтому спустя 10 лет Скотт выпустил "режиссерскую версию" "Блейдранера". Недавно фильм был выпущен на DVD.

Сеть (The Net)

Режиссер: Irwin Winkler

В ролях: Sandra Bullock, Dennis Miller

1995 год

Также один из самых известных фильмов о компьютерных технологиях. После его появления многие люди заинтересовались Интернетом, компьютерами и хай-теком. По сюжету молодая, красивая, благополучная (в общем, совсем не панковская) специалистка по компьютерам Анджелла Беннет (Sandra Bullock) случайно оказывается втянутой в опасный заговор: в ее руках дискетка с суперпрогой, документы сгорели, и по пятам следует наемный убийца. Естественно, все зависит от Анджеллы, и она побеждает всех и вся.

Поскольку фильм повествует о настоящем, а не о весьма отдаленном будущем, создателям пришлось столкнуться с множеством мелких технических деталей. Так что не удивляйся обилию забавных ляпсусов. Просто не обращай внимания - ведь это классика жанра.


Спецвыпуск Xakep, номер #015, стр. 015-090-2, Кино о сети, или МЫ глазами Голливуда

Кино о сети, или МЫ глазами Голливуда

Спецвыпуск Xakep, номер #015, стр. 015-090-2

Хакеры (Hackers)

Режиссер: Iain Softley

В ролях: Angelina Jolie, Fisher Stevens, Penn Jillette

Пожалуй, это самый популярный фильм на компьютерную тематику после "Матрицы". Примечательно, что у многих актеров, снявшихся в "Хакерах", кино-карьера начиналась с этого фильма. Еще незнаменитая Анжелина Джоули играет здесь крутую красавицу-хакершу, язвительную и стремящуюся быть во всем первой, которая, впрочем, в конце оказывается милой и нежной. Сюжет таков: молодой хакер пишет вирус, который сносит множество правительственных и корпоративных систем. Его ловят, запрещают пользоваться даже кнопочным телефоном, пока ему не исполнится 18 лет. К этому времени он переезжает в другой город и идет в другую школу, где знакомится с такими же компьютерными гениями. Перцам и перчинкам предстоит схлестнуться с ФБР и некой крупной корпорацией. Им приходится действовать сообща, чтобы достичь успехов и вывести всех негодяев на чистую воду. В перерывах между экшеном взаимная неприязнь главных героев переходит в любовь. В итоге все хорошо, все счастливы. Фильм наделал много шума и среди самих хакеров. Многие из них возненавидели этот фильм и до сих пор не признают его. Официальный сайт фильма был взломан уже на следующий день после открытия. Многочисленные ляпы в фильме, без которых не обошлось и здесь, сыграли в этом не последнюю роль. Но зато очень правильно показана атмосфера веселого, безбашенного хулиганства, стремление экстремально выпендриться друг перед другом, поэтому на несуразности внимания как-то не обращаешь. Так что фильм нравится даже хакерам, только они этого не признают ;).

Газонокосильщик 1,2 (The Lawnmower man)

Режиссер: Brett Leonard

В ролях: Pierce Brosnan, Jeff Fahey

1992/1995 год

Фильм снят по роману Стивена Кинга, а это уже говорит о многом. Лента стала популярной в считанные часы. А продолжение "Газонокосильщика" не заставило себя долго ждать, и уже в 1995 году появилась вторая часть именитой картины.

В первой части Бенджамин Трэйс, ученый на все руки, которого играет Пирс Броснан, ставит многообещающие эксперименты по повышению ментальных способностей на обезьянах. Но дела идут криво, плюс еще военные лезут со своими неблагородными целями. Ученый все чаще задумывается, а не заюзать ли в эксперименте человека? И выбирает он для всего этого умственно неполноценного, вечно ухмыляющегося газонокосильщика Джоба. Используя новые суперпрепараты в комбинации с применением виртуальной реальности, доктор добивается впечатляющих результатов. Но опять вмешались военные. В результате подопытный кретин становится гением-психопатом, и заканчивается все взрывами и гибелью тела Джоба. Однако финал открыт: виртуальный газонокосильщик выходит во всемирную паутину.

Во второй части фильма оказывается, что Джоб не погиб, а был спасен и долгие годы работал в секретном комплексе, строя микрочип своего "создателя", ученого из первой части фильма по имени Трэйс. А маленький мальчик Питер, друг Джоба, подрос и вместе с друзьями серьезно увлекся виртуальной реальностью, где снова встречает газонокосильщика, который просит его найти ученого. Когда ребятки рассказали обо всем Трэйсу, и тот узнал, что безумный гений Джоб жаждет мирового господства, что стало реально при помощи нового микрочипа виртуальной реальности, началась величайшая борьба за спасение человечества. Естественно, мир был спасен.


Спецвыпуск Xakep, номер #015, стр. 015-090-3, Кино о сети, или МЫ глазами Голливуда

Кино о сети, или МЫ глазами Голливуда

Спецвыпуск Xakep, номер #015, стр. 015-090-3

Надо отдать должное впечатляющим спецэффектам, трюкам и каскадерам. Этот фильм просто полон адреналина и энергии.

Нирвана (Nirvana)

Режиссер: Gabriele Salvatores

В ролях: Cristopher Lambert, Amanda Sandrelli

1997 год

Действие происходит в совсем близком будущем (2005 год), где царит виртуальная реальность. Джимми разработал новую игру под названием "Нирвана". Здесь можно делать все что возможно в реальности, но существует одна опасность: мозг игрока может быть травмирован. Суть игры в том, что ты можешь управлять судьбами людей, решать за них, короче говоря, управлять миром. Джимми осознает, что он крупно вляпался, создав эту игру. Он решает исправить свою ошибку, но ему пытаются помешать люди, которые имеют с игры деньги. Реальность фильма довольно жестока. Защитные программы влегкую могут изжарить мозг хаксора, глаза компьютерных маньяков уходят в ноль со скоростью мысли, и их заменяют имплантантами. Подпольные хирурги, большие корпорации, жажда наживы и благородная цель - все в комплекте. Фильм выдержан в мрачных тонах, почти нет спецэффектов, но сюжет довольно напряженный и необычный.

Джонни Мнемоник (Johnny Mnemonic)

Режиссер: Robert Longo

В главных ролях: Keanu Reeves, Dina Meyer

1995 год

Фильм снят по сценарию Ульяма Гибсона (автор "Нейромантика"). Налицо вся атрибутика киберпанка: мегакорпорации, контроль за гражданами при помощи КПП, сканирования и глобальной сети; сопротивление, виртуальная реальность в качестве интерфейса, кибердельфин-мутант, виртуальный дух-хранитель, огромные массивы информации, имплантанты. Атмосфера фильма мрачная и неблагополучная. Всем правят деньги. Отдельная жизнь - ничто. Героя Ривза - Джонни Мнемоника - курьера, у которого в голове сохранен огромный массив информации (несколько с хреном терабайт всего лишь), преследует кибер-якудза с целью эту голову отрезать. Джонни бежит от убийц, попутно пытаясь найти код к массиву и избавиться от инфы, которая вот-вот разорвет ему башку. Единственная возможность - найти повстанческую радиостанцию и слить инфу в мировой эфир, сделав всем большое добро. Финальная битва одновременно и в реальном, и в виртуальном пространстве; оптимистичный финал прилагаются.

Фильм был признан не очень удачным, но все же напряженный сюжет и киберпанковская атмосфера в наличии.

Странные дни (Strange Days)

Режиссер: Кэтрин Биджелоу

В ролях: Ральф Финнес, Анжела Бассет, Джулиет Льюис

1995 год

Фильм не связан с компьютерами, однако его все равно считают киберпанковским, так как виртуальной реальности тут очень даже много. Сюжет таков: спецслужбы разработали уникальный девайс, который одевался на голову и позволял записать ощущения и эмоции человека в той или иной ситуации - например, во время секса. Прибор попал в руки неудачника-полицейского, который решил этой штукой потрейдить. Но неожиданно в дело вмешался маньяк-убийца, который делал записи своих преступлений. Слабо почувствовать себя убийцей? А жертвой? И вот убийства виртуальные становятся убийствами реальными. В итоге всеобщее безумство на стыке тысячелетий и финальная схватка bad gay и good gay.


Спецвыпуск Xakep, номер #015, стр. 015-090-4, Кино о сети, или МЫ глазами Голливуда

Кино о сети, или МЫ глазами Голливуда

Спецвыпуск Xakep, номер #015, стр. 015-090-4

Фильм довольно тяжелый и вызывает неоднозначные ощущения.

Призрак в "Доспехе" (Ghost in the Shell)

Режиссер: Осии Мамору

1995 год

Этот фильм интересен тем, что он мультипликационный, поэтому фантазия создателей не была ограничена уровнем развития технологий в области спецэффектов. "Призрак в "Доспехе"" - экранизация манги известного японского художника Сиро Масамунэ "Опергруппа "Доспех"". "Доспех" состоит из бойцов-киборгов с уникальными способностями - так, главная героиня, красотка-киборг, умеет проникать своим сознанием в любую сеть. А главный злодей - Кукловод, сверхпрога для шпионажа, созданная министерством иностранных дел, которая однажды осознала себя самодостаточной. Технологии развиты настолько, что жизнь вне сети, вне киборга, в обычном нормальном теле уже не катит и подходит разве что для пенсионеров.

Необычный красивый мультфильм в стиле анимэ.

Матрица (Matrix)

Режиссер: Andy & Larry Wachowski

В ролях: Keanu Reeves, Lawrence Fishburne, Carrie-Anne Moss, Hugo Weaving

1999 год

Потрясающая своими спецэффектами и грамотно разрекламированная "Матрица" триумфально прокатилась по миру. Элементы киберпанка налицо: апокалиптическое будущее, власть разумных машин, порты-имплантанты у людей в голове, тотальная виртуальная реальность. На всякий случай сюжет: машины стали разумными и решили поработить человечество. Человечество начало отстреливаться ядреными бомбами с соответствующими облаками пыли и почти убило биосферу земли, уфигачив заодно и солнечный свет. Единственным источником энергии для машин остались человеческие тела, которые подсоединяют в матрицу как батарейки. Сами люди живут в привычном, но фальшивом мире виртуальной реальности. Только небольшие группы сопротивления борются с матрицей, подключая к ней свой мозг. Внутри они - супермены. Правда, враги их, независимые модули Смит, Браун и Джонс, тоже дают прикурить.

Красивые спецэффекты и напряженное действие, предатель в тылу в самый ответственный момент - что еще надо?

Это далеко не полный список фильмов в стиле киберпанк. И новые работы, несомненно, появятся, так как тема очень богатая. Но тебе должно этого хватить, чтобы почувствовать атмосферу мрачного кибер-будущего. Так что если ты чего-то еще не видел, срочно подключайся к MiTiNo BaZZaR или другому торговому терминалу и вперед!


Спецвыпуск Xakep, номер #015, стр. 015-092-1, Мобильное западло в сети

Мобильное западло в сети

Спецвыпуск Xakep, номер #015, стр. 015-092-1

MOOF (http://moof.ru; moof@real.xakep.ru)

Твой самый злобный враг обзавелся мобильным телефоном! Что может быть лучше? Всеми правдами и неправдами ты, наконец, добываешь номер его сотового и... Парочка безобидных приколов помогут снять напряжение после тяжелого дня в институте (твой враг препод? :)) или напомнить биг-боссу о своем существовании (пусть знает, зачем на самом деле нужен мобильный!). Понятно, что мы не советуем тебе применять эти приколы на практике - здесь они даны так, для общего развития =).

Западло первое: почтовое

Если твой недруг пользуется SMS оповещением о приходе письма на e-mail, то нет ничего проще, чем завалить его СМСками. Существует несколько способов это сделать.

Первое, что приходит на ум, - это подписать его на почтовые рассылки. Но не все так просто, большинство интернет-рассылок требует подтверждения подписки. Для того чтобы обойти эту защиту, нам потребуется промежуточный почтовый ящик: форвард. Для начала следует зарегистрировать форвард (пусть будет spam@forward.ru) и поставить перенаправление на свой ящик (например, moof@real.xakep.ru). После этого заходим на сайт рассылок (например, subscribe.ru) и подписываем почтовый ящик с форвардом (spam@forward.ru) на все рассылки, на которые только хватит терпения подписаться. Теперь осталось только изменить адрес в настройках форварда на e-mail адрес жертвы (bill@microsoft.com :)). Рассылок будет приходить много, и телефон просто подавиться от такого количества входящих СМС.

Можно доставать человека другим способом: присылать письма каждые 15 минут или каждый час. Для этого опять же необходимо наличие почтового ящика с оповещением о приходе письма с помощью СМС. Для того чтобы присылать письма в строго определенное время вовсе не обязательно сидеть за компом и вручную отправлять по четыре письма в час. Можно написать простой perl-скрипт и разместить его на бесплатном хостинге с поддержкой sendmail (отправлять почту) и crontab (и просто запускать наш скрипт в определенное время). Русскоязычным примером такого хостинга может быть hut.ru или h1.ru.

Итак, наш скрипт будет называться sms_spam.cgi и содержать следующее:

#!/usr/bin/perl

# путь к perl'у чаще всего он такой и есть

$email = 'sms@spam.ru';

# e-mail жертвы

open(OUT, "|/usr/sbin/sendmail -t");

# запускаем sendmail для того чтобы отправить письмо

print OUT "To: $email\n";

print OUT "From: zlobni@spammer.ru\n";

print OUT "Subject: Получи - упырь!\n\n" ;

print OUT "Тут текст письма :) \n\n";

close OUT;

exit;

Такой коротенький :). Теперь пару слов о его запуске. В unix'e есть программа cron (типа "Планировщика" в Винде) для запуска программ по расписанию. Все что тебе надо - это написать в конфигурационном файле cron'a:

0, 20, 40, * * * * sms_spam.cgi

для того чтобы отправлять письма каждые 20 минут, начиная с 12 часов ночи.

"Ну во, - слышу я, - можно завалить человека СМСками, а ведь далеко не у всех есть почтовые ящики". Да, действительно это так :(. Но, как известно, Интернет - это всемирная помойка, и чего только там не найти. Например, одно время beep.ru предоставлял возможность пересылать письма в виде СМС на телефон. Представь, ты регистрируешь почтовый ящик и указываешь номер не своего сотового, а сотовый своего врага, и подписываешь его на все рассылки. Сейчас, к сожалению, этот сервис прикрыли, но я готов подсказать несколько полезных адресов: http://email2sms.ru/ и http://www.beepost.ru/. Они тебе должны помочь :). Если этого тебе покажется мало, то существуют еще и зарубежные сервисы, их поиск будет твоим домашним заданием.


Спецвыпуск Xakep, номер #015, стр. 015-092-2, Мобильное западло в сети

Мобильное западло в сети

Спецвыпуск Xakep, номер #015, стр. 015-092-2

Западло второе: SMS убийца

Недавно новостные сайты распространили сообщение о том, что некоторые модели сотовых телефонов Nokia со старыми версиями прошивок виснут, получая определенные СМС сообщения. Причем виснут так, что для реанимации их надо нести в сервис-центр. Об этой фишке впервые стало известно на хакерской конференции Black Hat. Эксперт по компьютерной безопасности Job de Haas переписал безобидную программу sms_client. Это софтина, посылающая СМСки с компьютера через Интернет. Так вот, этот самый Job ввел в нее новую функцию, с помощью которой стало возможно посылать СМСки с нарушенным форматом заголовка (User Data Header). Не врубаясь в испорченный заголовок, телефоны (Nokia 6210, 3310 и 3330 и некоторые другие) впадали в панику и висли. Кроме того, Job ввел возможность подделывать адрес отправителя сообщения.

Переделанный sms_client можно найти в Инете, но поскольку это не совсем законная программа, ссылки на нее долго не живут, и их не имеет смысл приводить тут :(. Кстати, Nokia заявила, что знает о таких багах в софте и что во всех новых моделях они исправлены.

Существуют и банальные флудеры сотовых телефонов через СМС. Это программы SMS bomber и SMS Flooder. Они отправляют одно и то же сообщение большое количество раз через различные интернет-шлюзы. Скачать их можно по адресам: http://www.brains-hells-gate.de/progz.htm и http://www.geocities.com/allyounotneed/internet.htm .

Западло третье: вирусы

Сотовые телефоны, связанные с компьютером и Интернетом, сейчас начали получать широкое распространение. Из-за этого появилась опасность вирусов для сотовых телефонов. Памяти и возможностей телефонов пока не хватает для занесения вирей непосредственно туда, но вот зараженный компьютер может доставить неприятности владельцу трубки. Вирус I-Worm.Timofonica - это обычный интернет-червь, написанный на Visual Basic Script и распространяющийся в электронных письмах. Для размножения вирь использует Outlook и рассылает себя по всем адресам, хранящимся в его адресной книге. Как видишь, способ стандартный. Но при отправке каждого сообщения вирус отправляет СМСку через СМС-шлюз одного из сотовых операторов, указывая случайный номер телефона. Как ты понимаешь, немного его модифицировав, можно добиться отправления сообщений на какой-либо определенный номер телефона.

Но это еще полбеды. В прогрессивной Японии, где почти все мобильники подключены к Интернету, существует сервис "i-mode" (ака услуги мобильного Интернета в Японии). Им пользуются более тринадцати миллионов абонентов. Хакеры просекли эту тему и создали письмо, которое при прочтении на телефоне берет под свой контроль все основные его функции. После чего сотовый начинает звонить на номера из записной книжки и в службы спасения. Спасает от этого только полный reset телефона (вынуть, вставить аккумулятор). Хакеров, сделавших это, так и не нашли.


Спецвыпуск Xakep, номер #015, стр. 015-092-3, Мобильное западло в сети

Мобильное западло в сети

Спецвыпуск Xakep, номер #015, стр. 015-092-3

Так называемые смартфоны (два в одном: сотовый телефон и портативный компьютер-органайзер) тоже подвергаются вирусным атакам. Причем гораздо в большей степени из-за своих более широких возможностей. Уже известны вирусы (Phage, LibertyCrack и другие) для PalmOS, которые передаются через мобильные телефоны. Атакам подвержены Nokia Communicator, Ericsson R380 и Handspring VisorPhone, то есть телефоны, которые имеют возможность скачивать апдейты через Интернет.

Западло четвертое: W@P

Забудь на секунду о телефонах и вспомни браузеры на своем компьютере. Это либо IE, либо NN, либо Opera, либо что-нибудь совсем другое :)). И, как это ни покажется странным, во всех этих браузерах есть проблемы с безопасностью и всевозможные баги. Иногда зайдешь на какой-нибудь сайт, а у тебя не то что браузер выполнит недопустимую операцию, но и вся ОСь упадет (винда, например ;). WAP браузеры тоже бывают с багами. Как и в случае с СМС, есть такие WAP странички, при просмотре которых телефон может заглючить.

В первых моделях телефонов с WAPом компании Ericsson существовало ограничение на размер одной WAP страницы (оно и сейчас существует: что-то около 2000 символов, в зависимости от модели). А в случае, когда размер страницы превышал это ограничение, телефон банально вис. Но производители тоже не дураки и постоянно выпускают новые прошивки для телефонов - и дыр становится все меньше.

Помни: все написанное выше стоит использовать только для приколов над собой. Не надо проводить эксперименты над живыми людьми (они все-таки тоже люди :)), даже если они не очень хорошие. Такими приколами можно довести человека до бешенства: будет кидаться на всех, отбирать мобильники - что, согласись, неприятно.

Кстати, если придумаешь свое оригинальное западло, пиши, мы всегда тебе рады. И напоследок - несколько полезных ссылок:

http://mobile.box.sk

http://www.astalavista.com/mobile/

http://www.gsmsecretsworld.com


Спецвыпуск Xakep, номер #015, стр. 015-094-1, ASP как зеркало информационной революции, или создай интерактивный сайт за полчаса

ASP как зеркало информационной революции, или создай интерактивный сайт за полчаса

MoZ (real_moz@hotmail.com)

Спецвыпуск Xakep, номер #015, стр. 015-094-1

Сегодня, дорогой друг, твоя жизнь круто изменится. Прочитав эту статью, ты пойдешь и сотрешь надписи "Windows must die" и "Билл Гейтс - ламер" с соседнего забора. Потом ты выкинешь в помойку своего плюшевого Линукса. И затем ты расплачешься от осознания того, какая же все-таки крутая контора этот Микрософт. Это все произойдет потому, что сегодня я познакомлю тебя с такой выдающейся разработкой этой компании, как ASP. Конечно, я мог бы пойти немного дальше и сразу рассказать тебе об ASP.NET, входящий в состав Microsoft.NET, но из соображений гуманности расскажу об этом как-нибудь потом. Итак, что же такое ASP?

За знакомство!

Microsoft Active Server Pages (ASP) - это среда выполнения скриптов на стороне сервера, которую можно использовать для создания и выполнения динамических интерактивных Web-приложений. То есть, как ты понял, речь у нас тут пойдет про то, как круто с помощью ASP ты сможешь построить в Интернете сайт, динамично-интерактивно выдающий информацию в зависимости от желаний твоего посетителя. Впервые корпорация Микрософт ввела ASP в версии IIS (Internet Information Server) 3.0 и продолжила дальнейшую разработку этого продукта в IIS 4 и 5.

Кстати, если кто не знает - по распространенности в Интернете веб-серверы от Микрософт уверенно занимают второе место, уступая лишь Апачу, у которого все-таки была огромная фора. За подробностями можешь сходить на http://www.netcraft.com/survey/. Особое внимание обрати на графики роста - тенденция к увеличению процента серверов от Микрософт хоть и небольшая, но есть.

Как это работает?

IIS (сервак) исполняет asp-страницу и посылает результаты реализации сценария в формате HTML клиенту (бродилке). Так как сценарии ASP выполняются на сервере, то клиентом может быть любой WEB-браузер, без всяких специально устанавливаемых прибамбасов.

Опишу этот момент подробнее. Рассмотрим случай, когда скрипты выполняются на стороне клиента. WEB-сервер посылает страницу HTML, содержащую скрипты или даже ActiveX-компоненты, в браузер клиента, который и отвечает за выполнение всего этого барахла. Подход, при котором основной акцент делается на клиентской части приложения, возлагает на нее дополнительный груз обязанностей, что может привести к возникновению траблов, если клиентский браузер не будет в состоянии выполнить все то, что на него навалили. Напротив, страницы ASP исполняются на WEB-сервере. В ходе исполнения страницы сервак напрямую посылает клиенту код HTML и все клиентские скрипты, содержащиеся на странице ASP. Но как только сервер доходит до команды серверного скрипта ASP (выделенные тэгом <%%>), то он исполняет этот скрипт и передает клиенту в виде HTML только полученные в качестве результата выходные данные. Клиент, действия которого сводятся к использованию браузера, не видит разницы между потоком страниц HTML, порождаемым ASP, и потоком HTML, посылаемым статичными WEB-страницами. Тот факт, что ASP генерирует только поток страниц HTML, обеспечивает независимость от типа браузера клиента.

Мэн, проникнись: ASP - не язык программирования, это внутренняя технология, позволяющая объединять страницы HTML и скрипты. ASP позволяет применять любой язык написания сценариев, удовлетворяющий стандарт ActiveX. По умолчанию IIS поддерживает два скриптовых языка - VBScript и JScript. Тут все злобные хакеры должны повскакивать со своих засыпанных чипсами кресел и заорать - Бейсик Суксь! А после этого вспомнить, на чем в последнее время писались многие из самых распространенных почтовых вирусов, задумчиво поскрести по-модному помытую пивом шевелюру и сесть обратно. Если же эти языки тебя по каким-то причинам не устраивают (типа бейсик - все равно отстой, явасрипт достал), всегда есть возможность установить поддержку (script engine) и для других языков, например, для Rexx (http://wschaefer.purespace.de/rexx/rexxweb/wrw003.html), Perl (http://www.activestate.com/), Python.


Спецвыпуск Xakep, номер #015, стр. 015-094-2, ASP как зеркало информационной революции, или создай интерактивный сайт за полчаса

ASP как зеркало информационной революции, или создай интерактивный сайт за полчаса

MoZ (real_moz@hotmail.com)

Спецвыпуск Xakep, номер #015, стр. 015-094-2

Назад к юниксам?

Ну что, понравились волшебные слова - Perl, Rexx, Python? Ручки сами собой потянулись к помойке с плюшевым Линуксом? Ну, так и быть, расскажу еще одну страшную тайну - ASP бывает не только под IIS. И даже (как же мне трудно произносить эти слова!) не только под Windows. Разумеется, невиндовые версии ASP разрабатывает не Микрософт, а некие третьи фирмы, что только подчеркивает тот факт, что технология ASP получилась весьма удачной - настолько удачной, что вызвала волну зависти в мире юниксоидов. Кстати, среди этих третьих фирм засветилась и такая, как Sun Microsystems. Их дочерняя компания Chili!Soft аж в 1997 году выпустила некий продукт, который они же сами на своем сайте называют pepper (ага, именно - ПЕРЕЦ!). Официально же этот перец называется Sun Chili!Soft ASP и является честным клоном микрософтовского ASP, который к данному моменту научился работать под кучей платформ (Solaris, Linux, AIX, HP-UX, Windows 2000/NT) и с огромным числом серверов (Apache Web server, iPlanet Web server, O'Reilly Website Pro, Lotus R5, Lotus Domino 4.6, Zeus Web server, Red Hat Secure Server, IBM HTTP server, HP Apache-based Web server). Подробнее можно посмотреть тут - http://www.chilisoft.com/.

Однако компания Halcyon Software пошла еще дальше - она разработала версию ASP, работающую на любой платформе, поддерживающей Java. Мало того - на своем сайте (http://www.halcyonsoft.com/) они утверждают, что их версия ASP работает со скоростью до 50% выше, чем творение Сана.

На мой же независимый от всяких юниксов взгляд - разработка и выполнение ASP под платформами, отличными от Windows, нельзя назвать иначе, как редкой и особо изощренной формой психического помешательства. Ну, если уж сложилась твоя судьба так, что приходится разрабатывать сайт под юниксом, - то и пиши на чем-нибудь более юниксовом. А уж если так захотелось ASP (ну понял ты, наконец, что это круче и лучше) - так сделай еще один решительный шаг и работай под виндами, пользуясь всеми благами и удобствами, которые представляет тебе Лучшая Операционная Система Всех Времен и Народов.

В чем плюсы ASP?

А теперь попытаюсь вкратце рассказать, чем же так хорош ASP. Во-первых, разрабатывать приложения на ASP просто и удобно - а значит, быстро. В наше время, когда любой проект, над которым ты работаешь, обязательно должен быть завершен ко вчерашнему дню, скорость разработки выходит на первое место. И здесь у ASP мало конкурентов. Вообще говоря, для того чтобы монстрить ВЕБ-приложения средней сложности на ASP, ты не обязан быть квел кодером - настолько прост и понятен ASP (особенно с использованием VBScript).


Спецвыпуск Xakep, номер #015, стр. 015-094-3, ASP как зеркало информационной революции, или создай интерактивный сайт за полчаса

ASP как зеркало информационной революции, или создай интерактивный сайт за полчаса

MoZ (real_moz@hotmail.com)

Спецвыпуск Xakep, номер #015, стр. 015-094-3

Во-вторых, это возможность отлаживать приложение у себя дома на том же компе, на которым ты рубишься в свои любимые игры (а ведь признайся, в игрушки ты играешь точно не под *nix) и на абсолютно таком же веб-сервере, как и тот, на который ты потом будешь это приложение выкладывать, - это тоже очень приятно.

В-третьих, это коллекция встроенных объектов на все случаи жизни (Server, Request, Response, ObjectContext, Application, Session, ASPError) и большое количество компонентов от третьих фирм (впрочем, необходимость в таких "левых" компонентах возникает совсем не часто) позволяет программировать на достаточно высоком уровне, не отвлекаясь на реализацию различных мелочей. Легкое подключение и использование практически любых ActiveX-компонентов дает возможность делать все, что ты только можешь пожелать.

В-четвертых, в силу того, что сервер интерпретирует страницы ASP "на лету", ASP служит идеальным средством для встраивания результатов обработки интерактивных запросов к базе данных в WEB-страницы. Связка ASP + MS SQL Server - настолько мощная штука, что используется в проектах любой степени сложности.

Есть ли минусы?

Минусов же у АСП практически нет (а что, ты ожидал, что я сейчас расскажу, что ASP - полный отстой? =)) Конечно, стоимость построения Веб-сайта на базе Windows выше, чем на каком-нибудь бесплатном Линуксе, но, на мой взгляд, который поддерживают классики, бесплатный сыр бывает только в мышеловке. Мы не настолько богатые, чтобы покупать дешевые вещи, и все в том же духе. Да, хакеры с особой любовью и трепетом относятся к продукции Микрософт, но от этого число дыр в том же IIS стремительно уменьшается.

Пишем первое приложение

Далее я озадачу тебя примером. Сейчас мы с тобой заценим, как сделать на ASP натуральный WWW-чат, и ты убедишься, что это не так уж и сложно. А еще ты просечешь некоторые моменты в работе многих чатов. Цени мою доброту!

Наш чат не будет использовать никаких баз данных и текстовых файлов, а все необходимые переменные будет хранить, используя два волшебных объекта ASP - Application и Session.

Application может хранить глобальные переменные, связанные со всем приложением. Мы будем использовать две таких переменных приложения - Application ("UsersList"), где будем хранить список всех участников чата, и Application ("chat"), которая будет содержать все сообщения чата.

Session хранит данные о конкретном пользователе, и у нас будет использоваться только одна сессионная переменная - Session ("UserName"). В этой переменной будет храниться имя пользователя.

Сейчас мы намутим четыре файла, в которые разложим филейные части нашей болталки: edit.asp (чат собственной персоной), chat.asp (выводит каждые 10 секунд содержимое чата), users.asp (каждые 10 секунд выводит список юзеров) и global.asa (удаляет юзверя из списков после выхода).


Спецвыпуск Xakep, номер #015, стр. 015-094-4, ASP как зеркало информационной революции, или создай интерактивный сайт за полчаса

ASP как зеркало информационной революции, или создай интерактивный сайт за полчаса

MoZ (real_moz@hotmail.com)

Спецвыпуск Xakep, номер #015, стр. 015-094-4

Файло раз

<!--

edit.asp

Самая сложная часть нашего чата. По сути совмещает в себе две страницы - логина и отправки сообщений.

При этом все формы сабмитятся на одну и ту же страницу, и она сама определяет необходимые действия

-->

<html>

<body>

<%

'Записываем в локальную переменную UserName значение из формы.

'Метод Server.HTMLEncode - небольшая страховка от мелких пакостей в виде скриптов, введенных в форме.

UserName = Server.HTMLEncode(Request.Form("UserName"))

if Session("UserName")="" And UserName = "" then

' Если имени пользователя нет в сессионной переменной, и оно не передано из формы

' - то отображаем форму для ввода имени пользователя.

%>

<form action="edit.html" method="post">Ваше имя:

<input type="Text" name="UserName">

'Забацали поле для ввода.

<input type="Submit" value="Войти в чат">

'Сварганили кнопу "Войти в чат".

</form>

<%

else

if Session("UserName")="" then

'Если имени пользователя нет в сессионной переменной, но оно не передано из формы, то записываем имя пользователя в сессионную переменную UserName и добавляем его в список всех пользователей чата.

Application.Lock

'Поскольку переменные приложения общие для всех пользователей, перед их изменением необходимо выполнить метод Lock. Таким образом, в один момент времени эти переменные может менять только один пользователь.

Application("UsersList") = Application("UsersList") & UserName & "<br>"

Application.Unlock 'Освобождаем переменные приложения.

Session("UserName") = UserName

'Для записи сессионных переменных никакие блокировки не нужны, поскольку эти переменные принадлежат только одному пользователю.

end if

'А теперь идет часть для отправки сообщений.

Message = Request.Form("message")

'Если мы получили поле message из формы - добавляем сообщение в чат.

if Message<>"" then

AllChat = Application("chat")

'Здесь у нас происходит удаление старых сообщений чата. Если общий размер чата превышает 3000 символов, то мы обрезаем его до ближайшего сообщения, которое мы находим по тегу <br>

if Len(AllChat)>3000 then

AllChat=left(AllChat,instr(3000,AllChat,"<br>")+3)

end if

'А вот и непосредственное добавление в нашу главную переменную сообщения с именем пользователя и временем.

Application.Lock

Application("chat") = "<i>" & Time &"</i> <b>" & Session("UserName") & "</b>: " & _

Server.HTMLEncode(Message) & "<br>" & AllChat

Application.Unlock

end if

'А теперь выводим обычную форму для отправки сообщений.

%>

<form action="edit.html" method="post">


Спецвыпуск Xakep, номер #015, стр. 015-094-5, ASP как зеркало информационной революции, или создай интерактивный сайт за полчаса

ASP как зеркало информационной революции, или создай интерактивный сайт за полчаса

MoZ (real_moz@hotmail.com)

Спецвыпуск Xakep, номер #015, стр. 015-094-5

<textarea cols="57" rows="6" name="message"></textarea> <br> 'Задали размер поля и переменную, где будем хранить бред юзверя.

<input type="Submit" value="Отправить"> 'Кнопа "Отправить".

</form>

<script language="JavaScript">

// Рефрешим фреймы со списком пользователей и с чатом. Для этого используется обычный клиентский яваскрипт.

parent.frames[0].document.location = "chat.html";

parent.frames[1].document.location = "users.html";

</script>

<%

end if

%>

Файло два

<!--

chat.asp

Обновляясь каждые 10 секунд, выводит содержимое чата.

-->

<html>

<head> <meta http-equiv="Refresh" content="10"> </head>

<body>

<!--

Далее - самый простой способ вывести содержание любой переменной в поток HTML: знак "=" и имя переменной

-->

<% = Application("chat") %>

</body>

</html>

Файло тры

<!--

users.asp

Обновляясь каждые 10 секунд, выводит список участников чата.

-->

<html>

<head> <meta http-equiv="Refresh" content="10"> </head>

<body>

<center>

<b>Сейчас в чате:</b> <br>

<%

'Метод Write объекта Response выводит необходимые данные в поток HTML.

Response.Write Application("UsersList")

%>

</center>

</body>

</html>

Файло четыре

' global.asa - специальный файл, в котором можно описать скрипты.

' для обработки служебных событий, таких, как начало и окончание работы приложения и сессий.

' В данном случае нас интересует только одно событие - окончание сессии.

' Это событие возникает в том случае, когда пользователь уходит с нашего сайта.

<SCRIPT LANGUAGE="VBScript" RUNAT=Server>

Sub Session_OnEnd

' Данная процедура вызывается при завершении сессии и удаляет пользователя из списка участников чата.

' При желании можешь попробовать вывести сообщение о том, что такой-то пользователь нас покинул.

if Session("UserName")<>"" then

Application.Lock

Application("UsersList") = Replace(Application("UsersList"), Session("UserName") & "<br>", "", 1, -1, 1)

Application.Unlock

end if

End Sub

</SCRIPT>

Как видишь, все достаточно просто - любой хотя бы немного работавший с Visual Basic напишет такое за полчаса. Рабочий вариант этого чата ты можешь посмотреть здесь - http://www27.brinkster.com/realmoz/chat.html

Халявные хостинги

Итак, будем считать, что свою крутую страничку ты уже сделал и перед тобой стоит задача - где же ее разместить? Варианты платного хостинга ты, надо полагать, с негодованием отметаешь? Я так и знал. Вот тогда небольшой список мест, где можно попробовать на халяву разместить свой ASP-проект.

http://www.cfm-resources.com/. Несмотря на свое название и общее тяготение к ColdFusion (еще один язык для создания интерактивных веб-сайтов) - дают размещать и ASP-страницы. 30 мегов, база данных MS Access, есть доступ по FTP, дают бесплатный Email и обеспечивают техническую поддержку.

http://www.brinkster.com/. Обещают 30 мегабайт, никаких баннеров, поддержку ASP 3.0 и ASP.NET (установлен .NET Framework Beta 2), базы данных в виде MS Access. Из минусов - нет поддержки закачки файлов по FTP, придется выкладывать все через WEB-интерфейс. Однако поддержка .NET - это явный, большой и жирный плюс. Как ты заметил, страничка с примером выложена именно туда.


Спецвыпуск Xakep, номер #015, стр. 015-094-6, ASP как зеркало информационной революции, или создай интерактивный сайт за полчаса

ASP как зеркало информационной революции, или создай интерактивный сайт за полчаса

MoZ (real_moz@hotmail.com)

Спецвыпуск Xakep, номер #015, стр. 015-094-6

http://www.websamba.com/. Предлагают практически то же самое, что и описанный выше хостер. 30 мегов (меня это число уже начинает раздражать. Ну почему именно 30? А не 25 и не 40? Они там что, сговорились все?), доступ по FTP и все в том же духе.

http://www.domaindlx.com/. 15 мегов (Уррра!, хоть у кого-то не 30). Причем при достижении размера занятого места в 10 мегов ты можешь отправить письмо админам сайта, и они бесплатно добавят тебе еще 25 мегов. Доступ по FTP есть, есть еще и шесть мегов под Email, но с доступом к нему только через Web-интерфейс.

http://www.7host.com/. 50 мегов, доступ по FTP, баннер на каждой странице.

Удивлен, что нет ни одного русского хостинга? Я тоже. Платных хватает, а вот на халяву в России что-то никто ASP не дает (или, может быть, я плохо искал?). Так и быть - можете записать этот факт в минусы ASP.

Ну и если хочется поискать какие-то другие бесплатные места - добро пожаловать на http://www.free-asp-hosting.com/. Там тебя научат тому, куда еще можно сходить.

Немного полезных ресурсов

Кстати, вот еще парочка ресурсов, где можно почитать кое-что про ASP на русском языке.

http://www.activeserverpages.ru Может оказаться весьма полезным, особенно для начинающих. Довольно большая коллекция тематических статей, уроки программирования, примеры кода, форум. Большой архив дополнительных компонентов. В общем, рекомендую.

http://www.relib.com/asp Раздел на известном сайте Relib с материалами по ASP.

http://www.vbstreets.ru/default.asp?page=asp Еще можешь сходить на форум этого сайта - там тоже есть тематический раздел.

http://defaultasp.ru/ Недавно открылся, пока информации не очень много, но обещают сделать вполне приличный ресурс.

А вообще говоря, набери в любом поисковике "Active Server Pages" - информацией тебя завалит.

Светлое будущее ASP

А теперь о самом главном - о том, как ASP и Микрософт помогут сделать твою жизнь счастливой и шелковистой. Программеры, работающие с применением технологий от Микрософта, сейчас очень нужны, и в ближайшее время потребность в них будет только расти. Особенно это касается области Веб-проектов. Соответственно растут и будут расти зарплаты более-менее квалифицированных программистов, к которым будешь относиться и ты - если вовремя бросишь заниматься всякой фигней и прямо сейчас начнешь усиленно читать MSDN Library. Опять же, если ты знаком с ASP, это в какой-то степени (пусть не сильно, но все же) поможет тебе быстрее освоить и ASP.NET, которая в составе Microsoft.NET скоро станет, надеюсь, очень и очень распространенной, что принесет тебе еще большие деньги. Да и вообще, приятно чувствовать себе человеком, идущим в ногу со временем и использующим современные технологии от самой богатой и популярной софтварной компании. Аллилуйя!

Вместо З.Ы.

Многие могут удивиться: зачем писать целую статью про ASP, когда ASP.NET уже практически вышел? Отвечу: да, бесспорно, .NET - это большой шаг вперед. Однако и у традиционного ASP еще надолго останется своя область применения, а именно: простые ВЕБ-приложения, домашние страницы и все остальное, где не требуется вся мощь ASP.NET и где критична повышенная простота разработки. Ведь ASP.NET - технология, не только намного более мощная, но и требующая от разработчика серьезно бoльшей квалификации. И если проект на ASP ты можешь написать, используя исключительно "Блокнот", то с ASP.NET такой фокус уже не пройдет (крики из зала: "Пройдет! Пройдет!". Да, пройдет - но это будет уже скорее мазохизмом, чем нормальной работой).


Спецвыпуск Xakep, номер #015, стр. 015-098-1, Раз, два, три, четыре, пять, я иду искать - или несколько слов о том, где живут mp3

Раз, два, три, четыре, пять, я иду искать - или несколько слов о том, где живут mp3

Спецвыпуск Xakep, номер #015, стр. 015-098-1

hurrigane[fish] (fish@deep2k.org, icq #159212), B0P0H (BCE@ok.ru)

Мптришки в последнее время не слушает только ленивый. Или сытый гурман, которому в них "качества мало". Таким же, как мы с тобой, ничто не мешает наслаждаться музыкой в полной мере и в любое время. Остается, конечно, вопрос - а где их брать-то? Можно, конечно, купить диск любимого исполнителя и оцифровать его (мол, так удобнее в винампе большой плейлист на рандом плей поставить), но мы не совсем жители каменного века =). Поэтому брать любимые треки мы будем не где-нибудь, а в любимом Интернете. Поехали?

www.rmp.ru

Этот сайт в последнее время стал известным благодаря судебному процессу, выигранному у сайта zvuki.ru. Дизайн ненавязчивый (раздражает только поп-ап с рекламой, упорно вылезающий при заходе на сайт), навигация нареканий не вызывает - наблюдается интересная фишечка с перечислением количества песен, текстов, фоток и сообщений в форуме, относящихся к каждому исполнителю. И вот тут-то начинается подстава. Контента на этом сайте несоизмеримо мало, точнее сказать, по каждому исполнителю в частности очень мало песен - буквально по одной-две, за редким исключением. Много битых ссылок - наугад ткнула по трем ссылкам, повезло только с третьей, остальные две упорно не желали работать. Об альбомах речь не идет (ка-а-акие уж там альбомы), саундтреков не наблюдается. В общем, сайт довольно средненький, но если нужны раскрученные песни - поищи, может быть, повезет.

www.delit.net

delit.net, он же delit.ru, знают все =). Неудивительно - приятный дизайн, мало рекламы, навигация средненькая, но не раздражает. Что же касается музыки - ее здесь действительно много. Есть все, что душе угодно, - архив большой, и найти желаемое вполне реально. Есть, правда, один противный баг - mp3'шки имеют свойство оказываться совсем не теми, которые рассчитываешь скачать (персональные глюки Делита, скорее всего, вызванные неупорядоченностью контента). Те, кто сидят на выделенках, в полной мере могут ощутить на своих шкурах, что значит сидеть на модеме - скорость закачки в 3 кила со 100 мегабит - это все-таки круто =)). Вывод - приятный сайт с упором на перемешанный контент, а не на рекламу, рассчитанный на модемных юзверей.

www.myziki.net

Дизайн не перегружен графикой, сайт производит довольно-таки приятное впечатление, если не считать мешающейся и постоянно выскакивающей рекламы. Проект, кстати, не оправдывает свое название ;) - музыка тут есть аж в количестве 302 гигов (вот маньяки ;)). Соответственно, найти можно очень многое, есть поиск по исполнителю и композиции. Некоторые файлы, правда, лежат не на самом серваке, а на других - наподобие eMyz.ru. Битые ссылки не исключаются, но есть возможность сообщить о них администрации. При перелопачивании ресурсов сайта был найден один замечательнейший глюк - ни одна новостная ссылка не работает - все пути ведут в Рим, то есть на www.myziki.net!

emyz.ru

Этот сайт отличается облегченным дизигном (все грузится почти сразу). Контента много, в том числе и достаточно редкого, - здесь есть практически все. Имеются замечательные пимпы с названием SoundTracks и Видеоклипы, что наблюдается явно не на каждом сайте, но пока разделы пустуют - может быть, на момент выхода номера ситуация изменится. Так же как и у предыдущего сайта, работает поиск по композиции или исполнителю. Новости, находящиеся на главной странице, призваны улучшить работу сайта, а не нагнать хозяевам посещаемости методом ссылок исключительно на index.html. Есть чат, форум, где тоже можно обмениваться mp3'шками. еМуз оставил впечатление лаконичного сайта, не отвлекающегося от своего главного предназначения. Сейчас он, как я уже упомянула, находится в стадии бета-тестинга, поэтому не расстраивайся, если заметишь какие-то глюки - тем более что администрация, по всей видимости, настроена очень дружелюбно, и с радостью принимает все замечания и пожелания по работе сайта.


Спецвыпуск Xakep, номер #015, стр. 015-098-2, Раз, два, три, четыре, пять, я иду искать - или несколько слов о том, где живут mp3

Раз, два, три, четыре, пять, я иду искать - или несколько слов о том, где живут mp3

Спецвыпуск Xakep, номер #015, стр. 015-098-2

www.bymp3.com

Крупная белорусская поисковая система со всеми вытекающими. На одну букву A найдено 844 исполнителя - ноу комментс. Здесь, естественно, реально найти и очень редкие композиции. Дизайн, как и у большинства сайтов этого обзора, - симпатичный, грузится недолго, но навигация не самая удобная, к сожалению. Новости обновляются ежедневно, имеются также всякие примочки вроде чата, форума и иже с ними. В отличие от других сайтов, наблюдаются календарь и чарты, в том числе и белорусская топ20; кроме того, есть ссылки на mp3 плееры (Winamp, Sonique и т.д.).

search.zon.ru

Минимальный дизайн, благодаря этому быстрая загрузка. При открытии этого ресурса на тебя вывалятся нахальный баннер (возможно, не один) и ма-а-аленькая ссылочка со скромной надписью "Поиск mp3 файлов". Не так много наполнения, стандартный набор. Навигация средненькая. Просто еще один сайт с мп3шками, причем чего там больше - баннеров или треков - понять до сих пор не удалось. Хинт: при нажатии на одну не совсем понятную ссылку "База данных запросов в поиcковые системы" неожиданно вывалилось нечто пугающее, но достаточно интересное. Логин какой-то требуют, пасс еще... Так и хочется сказать: "Мы сами не местные..." ;). При дальнейшем осмотре напугавшей меня странички выяснилось следующее - за весьма умеренную плату нам пытаются впарить базу данных самых популярных запросов в поисковые системы. Какое это имеет отношение к поиску mp3, остается большой загадкой.

mp3.holm.ru

Сайт скорее специализируется не на mp3, а на всем подряд - помимо непосредственно музыки здесь наблюдается панелька с кнопочками, ведущими на сайты с разным мусором навроде скринсейверов, фоток, знакомств, анекдотов и так далее. Графикой данный ресурс не изобилует, что тоже положительно сказывается на скорости загрузки. Много не самой известной и распространенной музыки. Надо сказать, что из своего контента у них только музыка, а остальное барахло валяется у бакланов aka baklanov.net и им подобных.

mp3.rax.ru

Веселенький дизайн сайта подкрепляется кучей фишечек. Навигация, как и в большинстве случаев, на троечку, но в нашем случае выбирать не приходится - либо шашечки, либо ехать =). Мптришек насчитывается аж 601 000 штук, что позволяет предположить, что mp3.rax.ru - очередной поисковик по мп3-сайтам. Новости на сайте наблюдаются время от времени, наплывами. В глаза, кроме того, бросаются разные веселые кнопочки, больше всего заинтересовала кнопка "Аська", где так ненавязчиво предлагают ввести юин и пароль от него ;).


Спецвыпуск Xakep, номер #015, стр. 015-098-3, Раз, два, три, четыре, пять, я иду искать - или несколько слов о том, где живут mp3

Раз, два, три, четыре, пять, я иду искать - или несколько слов о том, где живут mp3

Спецвыпуск Xakep, номер #015, стр. 015-098-3

www.jazz2o.com

Этот сайт резко отличается от остальных присутствующих в этом обзоре - здесь есть музыка, которой нет практически нигде. Chillout, acid jazz, ambient, drum'n'bass и тому подобное лежит именно здесь - несмотря на название, указывающее исключительно на джаз. Очень порадовало то, что не приходится пробиваться через кучу баннеров и вылетающих окошек, чтоб добраться до нужной песенки. Все просто и элементарно. Навигация, следовательно, упрощена до предела, что есть несомненный гуд. Вообще, сайты с такой музыкой в Инете редкость, поэтому если тебя интересует электронная музыка во всех ее проявлениях - дуй сюда. Минимум рекламы и максимум музыки. То, что надо! К сожалению, при дальнейших раскопках многие ссылки оказались просто-напросто битыми. Такая вот ложка дегтя в бочку...

music.extrim.ru

Первое, что бросается в глаза - это, мягко говоря, некоторая тормознутость сайта. Не так много контента - 35 гиг (преимущественно металл и альтернатива), тем не менее присутствует лапша на ухах на тему кучи зарегенных пользователей (аж 46 с фигом тысяч). Мало того, что сначала тебя заставляют побегать по куче ссылок, так еще когда ты, наконец, с радостным воплем "Нашееел!" набредешь на нужную ссылочку, тебя ждет весьма большой облом. Многие файлы придется качать вообще вслепую, так как названия прописать никто не позаботился. Но и это еще не все ;). Шлепаешь по ссылочке - и тебя редиректит на какую-то кривую пагу регистрации, которая неизвестно для чего предназначена - пассворда не требуют, требуют мыло онли (спамлист, наверное, собирают =)). Весьма посредственный сайт. Единственное, что радует, - это отсутствие кучи выскакивающих окошек.

www.altmp3.ru

В глаза бросается дизайн стиля, модного аж в y2k. Сразу огорчает то, что в новостях рассказано о пополнении коллекции, но прямых ссылок на новинки нет - сами, значится, копайте ;). Сайт специализируется преимущественно на русской музыке. Если тебе захочется вдруг послушать Аллу Пугачеву или внезапно припрет ностальгия по "Иванушкам Интернешнл" - тебе туда. Хотя немного зарубежной музыки тоже имеется. Дизайн довольно средненький, равно как и навигация. Любителям попсы - сюда!

mp3.grammy.ru

Здесь - несмотря на то, что файлы расположены не на самом grammy.ru, а на разных серваках - битых ссылок почти не бывает. Навигация не вызывает нареканий, равно как и структура/наполнение сайта. Скачивать оттуда музыку приятно. Есть разбивка по альбомам, что встречается не на каждом сайте - также можно почитать об альбомах (что-то наподобие рецензий). На момент написания статьи сайт находился в глубоком и безвылазном дауне.

mp3.mp3s.ru

Оранжевый дизайн поднимает настроение, а циферки, показывающие количество исполнителей на ту или иную букву, поднимают настроение вдвойне ;). Еще больше поднимает настроение вылетающий баннер. Такой весь из себя положительный сайтик ;). Прямо с начальной страницы можно увидеть топ 20 и сразу же переползти на страницу закачки - радует. Сайт, по всей видимости, занимается коллекционированием не mp3, а имен исполнителей ;), то есть имена указаны, а mp3 отсутствуют =). Сайт является поисковой системой, немного глючной, но со своими фишечками (наподобие рецензий на свежевыпущенные альбомы) и быстрой загрузкой.


Спецвыпуск Xakep, номер #015, стр. 015-098-4, Раз, два, три, четыре, пять, я иду искать - или несколько слов о том, где живут mp3

Раз, два, три, четыре, пять, я иду искать - или несколько слов о том, где живут mp3

Спецвыпуск Xakep, номер #015, стр. 015-098-4

www.mp3search.ru

Одна из известнейших ссылок в Рунете. Искать mp3 cюда ходят абсолютно все. Неудивительно - поисковик осуществляет поиск по известнейшим сервакам вроде тех же allofmp3.com, grammy.ru или delit.net. Здесь есть и своя музыкальная коллекция, особенно тех треков, которые редко увидишь на других серваках. Иногда, правда, среди найденных ссылок могут оказаться уже не действующие. Администрация просит информировать о таких ссылках, присутствует даже специальная кнопочка. Несмотря на то, что к скачке файлов приходится продираться через кучу ссылок, рекламы (особенно добивает) и прочего барахла, - сайт заслуживает внимания.

www.allofmp3.com

Ууу... про этот сайт можно писать бесконечно. Все наверняка знают его печальную историю, когда из полностью бесплатного, удобного, одного из известнейших порталов с mp3 в Рунете он превратился в практически полностью платный сервак. Нет, ты только прикинь - платить за скачку mp3! На данный момент на сайте бесплатно доступна только небольшая часть архива, а самые редкие и вкусные mp3 могут качать только члены vip клуба. Членство стоит около 5 долларов - но стоит ли платить за что-то, когда можно найти то же самое бесплатно? Приятно только то, что записи выложены в очень высоком качестве (большая часть - с битрейтом аж в 384, я только здесь о таком и услышала =) - так что и гурманам есть где побаловать себя вкусненьким).

mp3.kharkov.ua

Навигация по сайту сделана наподобие импровизированного фтп с папочками и файликами. Помимо традиционной рассылки и новостей на сайте существует возможность зарегистрироваться, получив возможность голосовать за статьи, оставлять свои комментарии и тому подобное. Несколько тривиальный, но ненавязчивый и быстро грузящийся дизайн способствует приятному серфингу, а mp3 здесь много, причем абсолютно разных.

mp3files.ru

Броский разноцветный дизайн и приятная навигация, привлекающие внимание, заставляют остановиться на минутку. Помимо пресловутых mp3, среди которых можно выцепить действительно стоящие экземпляры, на сайте можно увидеть статистику, чат, дискуссии aka форум, раздел с софтом.

mp3.tomsk.ru

Сайт, как и altmp3.ru, специализируется на русской музыке. Дизайн явно сделан не профессионалом, но от души. При открытии выявилось аж 3 фрейма. С разрешением 640х480 смотреть на ЭТО стало невозможно ;). В конце концов оказалось, что лазить сюда ради контента бесполезно =( - нашлись только русские композиции в малом количестве. Радует радиостанция, оказавшаяся у этого сайта в наличии. Дальше - даже если ты и нашел Иванушек или что-то там еще, что тебе по душе из русской народной эстрады, то это еще не значит, что ты это скачаешь. Перед тобой могут возникнуть определенные проблемы с навигацией на сайте, особенно это касается новой модной фишечки - прослушать онлайн, когда становится непонятно, можно ли это скачать (можно, конечно, - на всякую хитрую попу найдется свой болт =)). Конечно же, как и везде, тут существуют битые ссылки.


Спецвыпуск Xakep, номер #015, стр. 015-098-5, Раз, два, три, четыре, пять, я иду искать - или несколько слов о том, где живут mp3

Раз, два, три, четыре, пять, я иду искать - или несколько слов о том, где живут mp3

Спецвыпуск Xakep, номер #015, стр. 015-098-5

mp3ocean.agava.ru

Первое впечатление - ужа-а-ас... Два окна с рекламой вылезают сразу, что дико раздражает, принципиальное отсутствие дизайна и нормальной навигации. Почему я включаю этот сайт в обзор? Потому что, несмотря на все отвращение, возникающее при его виде, этот сайт изобилует тем, чего нет нигде. Редчайшие треки можно найти именно здесь. Если не осталось никакой надежды - ломись искать файло именно туда. Без крайней же нужды ходить туда не советую ;) - сбережешь нервы, траффик и время.

mp3.com

Ну, это уже классика. Когда речь заходит об mp3, в первую очередь вспоминается mp3.com. Здесь есть все направления музыки и не только - все, что можно записать в mp3, от пранка до какого-нибудь acid jazz'a, лежит здесь. Навигация удобная - сайт разбит на разделы по стилям музыки, есть поиск, который ищет не только непосредственно mp3, но и радиостанции, играющие данную музыку. Если есть желание ознакомиться со стилями музыки - тебе сюда, выкачивать верхние строчки чартов.

mp3.com.au

Это наглый клон предыдущего сайта. Содрано практически все - начиная от концепции и заканчивая разделами и чартами. Тем не менее ресурс достаточно неплохой, хотя навигация немного подкачивает. Много музыки различных стилей, но все уж слишком напоминает mp3.com.

omen.ru

А вот и еще один ресурс, представленный в нашем разделе. Это довольно молодой ресурс - ему сейчас около двух лет, но за это время он проявил себя только с положительной стороны. Постоянные обновления музыкальной коллекции, можно найти редкие вещицы. Хотя и тут нужно добавить чуть-чуть дегтя. Видимо люди, составляющие музыкальный контент, не всегда в нем разбираются, поэтому можно иногда увидеть группы, помещенные в раздел "Рэйв" (например), к рейву явно не относящиеся. Второе, что дико действует на нервы, - на белом фоне авторы догадались писать желтым шрифтом. Рассылка, к которой тебя здесь не принуждают, себя вполне оправдывает, докладывая тебе о том, чего новенького появилось на ресурсе. В общем, картина вполне приятная, можно надеяться, что Омен будет расти и развиваться. Судите сами - мне понравилось.

www.360.com.ua

Ну и на закуску - забавнейший сайтик, в общем-то, тоже посвященный поиску mp3, но на украинском. Ресурсик замечательный, позволяет искать как на Украiне, так и во "Увсим свиту" (во всем мире то есть =), и в комментариях не нуждается, так что не забудь "вигравать разом з 360 та отримать пiдписку на безкоштовнi розсилки за твоiм вибором" ;))).

Зы ЕндЪ

Вот, собственно, и весь обзор сайтов с музыкой на сегодня. Музыки в Инете много, при желании найти можно практически все. Также не забывай о peer-to-peer технологии, о KaZaA и Audiogalaxy - зачастую именно с помощью них можно найти нужное, Х уже неоднократно об этом писал. На этом позволь откланяться ;), и успехов тебе в поисках!


Спецвыпуск Xakep, номер #015, стр. 015-102-1, Сборная CURLянка

Сборная CURLянка

Спецвыпуск Xakep, номер #015, стр. 015-102-1

hurrigane[fish] (fishka@gmx.net; icq #159212)

Кудрявое создание

Сколько сейчас развелось различных языков программирования, заточенных под WWW, сложно сказать даже примерно. Каждый язык выполняет определенную роль: всем известный HTML служит для разметки страниц; Perl, PHP и иже с ними позволяют лепить все что угодно - от простеньких скриптов до огромных программулин; а XML так вообще позволяет вольно определять теги самому... Я расскажу тебе еще про один язык, появившийся недавно. Язык этот родили разработчики HTML, в числе которых замечен небезызвестный "отец" Инета Тим Бернерс-Ли, - а зовется это творение Curl. Разработка этого языка началась аж в 1995 году, а первый релиз состоялся весной 2001 года, причем развитию Курла способствовали такие языки, как HTML, C++, TeX и Tcl/Tk.

А оно нам надо?

По словам разработчиков, создать этот язык их побудило то, что на данный момент в Инете используется куча технологий, облегчающих жизнь конечному пользователю, но именно это и создает обратный эффект: на разных машинах, в разных операционках и в разных браузерах одна и та же пага может выглядеть абсолютно по-разному. Кроме того, как ты знаешь, многие паги весят столько, что с твоим коннектом 2400 смотреть их просто нереально ;). Так вот, спросишь ты, а чем же этот язык отличается от остальных? Дело в том, что разработчики делают довольно смелые заявления: по их словам, Curl позволит обойтись без HTML, Java, PHP, Perl, Flash и прочего - этакая сборная Curlянка получается =). Также разработчики утверждают, что сотня килобайт кода на любом из языков программирования под веб превращается в десять килобайт на Курле. Но главное отличие Curl от остальных языков - это 3D графика, которая к тому же просчитывается в реальном времени. В этом вопросе Курл является непосредственным конкурентом Flash. Суть такова: пага на Курле отличается наличием трехмерной графики, единым кодом и для разметки текста, и для более сложных операций и при этом реально малым весом. К примеру, код обычного трехмерного шарика на Курле весит около 4 килобайт.

Это вовсе не значит, что Курл применяется только сам по себе. Он прекрасно уживается с остальными представителями веб-технологий. В чем-то он похож на Java или Flash: здесь апплеты тоже загружаются непосредственно на компьютер пользователя и выполняются не на сервере, а обрабатываются в реальном времени. Естественно, как и в случае с Java и Flash, все это дело требует установки плагина. В наличии на данный момент имеются плагины как для виндов, так и для *nix и даже для SunOs/Solaris. Хотя с плагином ребята явно переборщили: 12 мегабайт - это все-таки много =(. Плохо в этом случае и то, что инсталлер заливает тебе сначала DirectX, необходимый для всего этого дела, причем делает это без спросу, а потом уже сам плагин. Зачем это делается - хз. Может, чтобы облегчить жизнь конечному пользователю, хотя какое облегчение от выкачивания 12-14 мегов - неизвестно. А говорили, экономить на пересылке информации... В этом Curl определенно отстает от Flash с его 500-килобайтным плагином. Прога эта имеет еще одно неприятное свойство - она постоянно висит в трее. К тому же, если ты захочешь проапгрейдить плагин - тебе придется заливать его снова. Никаких патчей/апдейтов/etc пока не предусмотрено.


Спецвыпуск Xakep, номер #015, стр. 015-102-2, Сборная CURLянка

Сборная CURLянка

Спецвыпуск Xakep, номер #015, стр. 015-102-2

Как все пашет?

Работает это все так: с сервера на клиентскую машину передается код, а на ней его уже ждет плагин, который с помощью все того же DirectX (если речь идет о графике) просчитывает ее и несет в массы, то есть нам с тобой ;). При этом, как и в случае с Flash, на серваке не требуется иметь какого-то особенного программного обеспечения - все делается исключительно на машине клиента, а на серванте лежит только сам файлик с кодом и расширением .curl или .scurl. Таким образом, разработчики пытаются, якобы, уменьшить нагрузку на серверы и избавить их владельцев от излишних трат на новое железо (на то, что юзверям придется иметь достаточно неплохие железки, внимания не обращают - а между тем, все это дело страшенно тормозит, к слову говоря).

Что интересно, Курл в основном продвигают как еще один полноценный язык программирования, а не как инструмент для создания трехмерной графики. По сути, он таковым и является - чтобы наваять на нем что-либо более сложное, чем просто статичная пага с разметкой, нужно реально сечь фишку в кодинге. Так что если ты кул кодер, готовишься стать им или просто упертый, как ослик Дани Шеповалова в брачный сезон ;), - флаг тебе в руки, портрет Гейтса на шею и армию линуксоидов навстречу ;).

Чем бы дитя не тешилось, лишь бы не руками...

Для разработки чего-либо на Курле теоретически можно обойтись нотепадом, а можно взять с www.curl.com среду разработчика - Surge Lab IDE весом в 16 мегов. Почему так много? 12 с фигом мегов занимает непосредственно плюгин с директ иксом, а остальное - как раз и есть сама прога. Что интересно - написано это все тоже само на себе, то есть на Курле (помешались они там на нем, что ли? =). В прогу входят функции наподобие расстановки брейкпойнтов, что-то вроде дебаггера и сам редактор кода с подсветкой и прочими приятностями. Не знаю, как ты, а мне лично хватит и блокнота для того, чтоб помучить этот язык. Хотя, с другой стороны, не суть важно - тянуть 12 мегов плагина или 16 мегов среды разработчика с плагином.

Let's cum together!

Будущее

Продвижение Курла в массы идет очень активно: на сайте www.curl.com нас встречают приятным дизайном и не менее приятной лапшичкой на уши о том, какой наш Курл весь из себя хороший и замечательный язык, при этом хвастаясь, что их неподъемный плагин загрузили аж 170 000 раз =). На самом деле информации там реально много - преимущественно это касается документации (даже книжку предлагают купить). Второй ресурс, который стоит отметить, - это www.curlBreaker.com, сайт одноименного онлайнового журнала для разработчиков. Там преимущественно отмечаются все интересные фишки языка, язык сравнивается с другими - в целом этот ресурс я бы назвала более интересным, чем предыдущий. Ну а для тех, кто решил заняться кодингом на Курле и хочет все пощупать своими шаловливыми ручками, предлагается www.curlexamples.com - сайт с примерами, на которых гораздо интереснее изучать язык, чем в теории. Есть одно "но" - все это дело на данный момент только на буржуйском языке =(. Сайт www.curl.ru уже показал миру свою симпатичную мордашку, но на момент написания статьи на нем висел только main.htm с очередными похвалами великому и могучему Курлу и опять на буржуйском. Возможно, к выходу номера ситуация изменится, а пока спешу тебя огорчить - на русском ресурсов по Курлу просто нет, так что учи фиглиш ;).


Спецвыпуск Xakep, номер #015, стр. 015-102-3, Сборная CURLянка

Сборная CURLянка

Спецвыпуск Xakep, номер #015, стр. 015-102-3

Финиш хим!

Вот такой вот он, этот витиеватый язычок - новый, перспективный, но... к сожалению, пока не получивший широкого распространения вследствие некоторых недоработок. Пробуй, смотри - может быть, действительно имеет смысл пообщаться с ним поближе ;)). Удачи, и... RTFM!


Спецвыпуск Xakep, номер #015, стр. 015-104-1, Паранойя с открытым ключом

Паранойя с открытым ключом

Zero Gravity (dik@taifun.ru)

Спецвыпуск Xakep, номер #015, стр. 015-104-1

Многие считают, что шифровать свои письма необязательно, так как ничего секретного в них нет. Мол, кто будет читать мою почту, я же не Фокс Молдер и даже не Гомер Симпсон. Однако могу тебя уверить на сто процентов, что работники любой почтовой службы - и платной, и бесплатной - время от времени заглядывают в почту своих пользователей. Ночь, делать нечего, доступ открыт - чего бы и не почитать?

No mail for root

Хорошо, допустим, это не так уж и страшно: пользователей очень много, и вероятность того, что сонному админу под руку попадется именно твоя переписка, очень низка. Но вот что я заметил в последнее время: с продвижением Инета в массы все больше и больше я слышу историй, рассказывающих о том, что кто-то попросил еще кого-то хакнуть чье-то мыло, и у них это получилось! Раньше такое тоже бывало, но заметно реже, так как почтой-то пользовались немногие, а уж взломать ее могли вообще единицы. А теперь... А теперь девушки хотят следить за своими парнями, боссы - за служащими, мужья - за женами и так далее. Но и это еще не все ;). Нельзя обделить вниманием наших добрых друзей - доблестных сотрудников спецслужб. Я не хочу сказать, что они прямо внимательнейшим образом изучают все пользовательские письма, но того, что возможность мониторинга и фильтрации у них есть, - никто даже и не скрывает. Так что и эти черти вполне могут заинтересоваться твоей перепиской, отловив в одной из мессаг какую-нибудь ключевую фразу ("Толян, готовь пацанов - на дело пойдем!" :)).

Ходят даже слухи, что служба icq создавалась и финансировалась на деньги Моссада! То есть разведка вкладывает деньги в проект, непосредственно связанный с обменом информации личного характера, делает его популярным на весь мир и спокойненько себе занимается сбором статистики ;). Одно время я общался в Инете с девушкой из Прибалтики, которая на тот момент училась в Германии. Тонкости ее жизни мне неизвестны, но жила она на полулегальных правах и опасалась говорить об этом по аське, потому что считала это небезопасным. Может быть, это и паранойя... А может быть, и нет...

А вот уже не слух, а факт! В то время как использование "сильной" криптографии является единственным способом обеспечить неприкосновенность частной жизни при общении через компьютерные сети, правительства некоторых стран, в том числе США, Франции и теперь России, пытаются ввести законодательные ограничения на использование криптографии - под тем предлогом, что ею могут воспользоваться криминальные элементы в своих гнусных целях. 3 апреля 1995 года Президент России подписал указ, согласно которому разработка, экспорт, импорт и даже использование криптографических средств, в том числе и частными лицами, разрешается только при условии получения лицензии ФАПСИ (Федеральное Агентство Правительственной Связи и Информации). Теперь становится очевидным, что если шифрование данных не было бы столь важным, правительство не стало бы контролировать распространение крипто систем. И поэтому ты - как хакер, как бунтарь, как борец с несовершенной системой - просто обязан шифровать свои данные! И одним из оптимальных решений является открытый ключ, а в частности, система PGP, которая имеет реализации во многих операционках.


Спецвыпуск Xakep, номер #015, стр. 015-104-2, Паранойя с открытым ключом

Паранойя с открытым ключом

Zero Gravity (dik@taifun.ru)

Спецвыпуск Xakep, номер #015, стр. 015-104-2

Открытый ключ

Ты уже, наверное, не раз слышал о такой штуке, как открытый ключ. Это общее понятие, под которым имеется в виду алгоритм шифрования-дешифрования, использующий концепцию открытых и закрытых данных. Криптографы разработали такую концепцию специально и именно для того, чтоб в наличии был открытый ключ, который можно без опаски передавать кому угодно. Информация, зашифрованная открытым ключом, может быть расшифрована только владельцем соответствующего закрытого ключа (открытый ключ генерируется на основе закрытого). Поэтому такой обмен данными считается безопасным. Эта концепция шифрования прижилась и в сети. На данный момент существует огромное количество сервисов, использующих шифрование с открытым ключом. Это, например, служба SSH, протокол HTTPS и многие другие. Но об открытом ключе в сети мы поговорим позже, а сейчас давай попробуем вникнуть чуть глубже в саму технологию шифрования с открытым ключом.

RSA - влезаем глубже

Поговорим об алгоритме RSA. Это криптосистема, разработанная Ривестом, Шамиром и Эдлеманом (Rivest, Shamir, Adleman). Ее идея состоит в искусном использовании того факта, что легко перемножить два больших простых числа, однако крайне трудно разложить на множители их произведение. Вот это произведение и есть тот самый открытый ключ. Немного формул :). Берем два больших простых числа p и q, перемножаем их и получаем n (n = p*q). Потом выберем большое число d > 1, к которому надо подобрать число 1 < e < (p-1)*(q-1) , - такое, что (e*d) mod (p-1)(q-1) = 1 . Напомню, что mod дает остаток от целочисленного деления. Открытым ключом являются числа n и e, а закрытым - число d. Естественно, что для шифрования данных используются числовые значения кодов шифруемых символов. Если ASCII-код буквы A - 65, то буква A шифруется так: (65^e) mod n = X , где X - зашифрованный символ. Расшифровать это можно так: (X^d) mod n = 65. Но, если ты заметил, здесь присутствует возведение в степень. Возводя большие числа в степень, ты почти наверняка выйдешь за приделы разрядности процессора. Вот так мы наступаем на пятки прогрессу :). Кричишь ему, мол: "Прогресс, шагай с нами в ногу! Левой, левой!", а он не слышит почему-то ;). О чем это говорит? О том, что данный алгоритм сложно реализовать своими силами, то есть самому написать процедуры шифрации и дешифрации. Но если такая необходимость есть, то можно воспользоваться другими, не менее криптостойкими алгоритмами. Например, шифрование при помощи сверхрастущего вектора.

PGP

В 1990 году Фил Циммерман использовал систему RSA в своей программе Pretty Good Privacy. В США есть законы, в соответствии с которыми программа PGP классифицирована как "военное снаряжение" (то есть нечто вроде танков и напалма :)), поэтому ее экспорт из страны запрещен. Но однажды система PGP была нелегально экспортирована из Соединенных Штатов. Почти наверняка это произошло без ведома Циммермана. Тем не менее против Фила было выдвинуто обвинение, которое сейчас рассматривается Большим Жюри. Ну да черт с ней, с буржуйской бюрократией! Давай лучше посмотрим, что собой представляет сам предмет спора. PGP работает следующим образом - у каждого пользователя имеется два ключа: закрытый секретный и открытый. Секретный ключ он оставляет в тайне, а открытый сообщает всем своим приятелям. Для того чтобы организовать безопасную переписку между двумя пользователями, необходимо, чтобы они поменялись своими открытыми ключами. Первый пользователь шифрует сообщение открытым ключом второго пользователя и отправляет его (сообщение). Оно может быть расшифровано только вторым пользователем, так как соответствующий закрытый ключ есть только у него. Он получает сообщение, расшифровывает его, пишет ответ и шифрует его открытым ключом второго пользователя. Так и переписываются :).


Спецвыпуск Xakep, номер #015, стр. 015-104-3, Паранойя с открытым ключом

Паранойя с открытым ключом

Zero Gravity (dik@taifun.ru)

Спецвыпуск Xakep, номер #015, стр. 015-104-3

Знание открытого ключа не позволяет вычислить соответствующий секретный ключ. Соответственно, открытый ключ можно публиковать и широко распространять в Инете. На сайте pgp.org.ru можно найти кучу чужих и опубликовать свои открытые ключи. PGP может генерировать ключи разных размеров. Размер ключа говорит о его уровне: простой, коммерческий или военный. Размер, в свою очередь, определяется числом бит - ключ, например, может иметь длину в тысячу бит. Чем длиннее ключ, тем выше степень секретности, но платить за это придется скоростью. Причем не только в момент шифрования данных, но и в момент генерации ключей. Процесс генерации ключей может занимать от нескольких секунд до нескольких минут, в зависимости от длины ключа и производительности компьютера.

Шифрование в сети

Теперь я бы хотел узнать, по каким сайтам ты лазаешь ;)? Можешь не отвечать, это не важно. Важно то, что ты не хочешь, чтобы кто-либо знал о том, что ты посещаешь те или иные сайты и что именно ты там делаешь! Поэтому пора поговорить о протоколе SSL. Видел когда-нибудь адреса типа httpS://что-либо.ru? Наверняка видел - а значит, уже работал по шифрованным протоколам передачи данных. Стандарт SSL был разработан фирмой Netscape Communications. В его основе лежит шифрование с открытым ключом. Основная идея заключается в том, что при использовании стандартных протоколов обмена (таких как http, ftp, telnet) вся информация передается по сети в незащищенном виде. Таким образом, при прослушивании трафика одним из промежуточных узлов твои пароли, номера кредитных карт и иная конфиденциальная информация могут стать достоянием общественности. Протокол SSL оговаривает методы шифрования всей передаваемой информации прозрачно для пользователя. Он поддерживается любым современным браузером и является основным стандартом передачи зашифрованных данных между клиентом и сервером. Плохо только то, что длина открытого ключа SSL ограничена юридическими нормами (ФАПСИ и иностранные организации такого же толка). Эти ограничения дают возможность в случае необходимости взломать ключ, хотя для этого и необходимы достаточно большие вычислительные мощности.


Спецвыпуск Xakep, номер #015, стр. 015-104-4, Паранойя с открытым ключом

Паранойя с открытым ключом

Zero Gravity (dik@taifun.ru)

Спецвыпуск Xakep, номер #015, стр. 015-104-4

Сеанс работы SSL происходит на двух уровнях: Handshake Protocol и Record Layer. На уровне Handshake происходит установка соединения, обмен ключами для шифрования, сертификатами, проверка сертификатов, сообщения об ошибках. На уровне Record Layer - обмен данными. Со вторым уровнем все понятно :), поговорим о первом. Что такое сертификат? Цифровой сертификат - это документ, который выдает Сертификационный Центр каждому из взаимодействующих объектов, подлинность которых он должен удостоверить. Сертификат содержит такие данные, как, например, версия, кому выдан, кем выдан, срок действия, серийный номер сертификата, алгоритм подписи и прочее. Если какие-либо данные в сертификате сомнительны, пользователь получит предупреждение и возможность выбора: отказаться или продолжить соединение.

Диагноз - паранойя

Для тех, кто проникся паранойей ;), хочу дать пару советов. Во-первых, пользуйтесь PGP! Во-вторых, в сети есть сервера, которые позволяют анонимно путешествовать по www, причем клиент получает данные от сервера в зашифрованном виде. То есть даже если интересующий тебя сервак не работает по https, ты все равно можешь общаться с ним, шифруя трафик. Это существенно снизит скорость загрузки страниц, зато ты будешь уверен, что никто не узнает, чем ты занимаешься ;). До недавнего времени одним из таких серверов был www.safeweb.com. Но сегодня он уже не предоставляет таких услуг :(. На его месте появились другие - стоит только поискать. Найдешь, пиши в редакцию - нам таких серверов много не бывает :-)).


Спецвыпуск Xakep, номер #015, стр. 015-106-1, Оформи сайт своими ФриХэндами

Оформи сайт своими ФриХэндами

Спецвыпуск Xakep, номер #015, стр. 015-106-1

Вадим Мурзагалин (vadias@sendmail.ru) & "студент" Валитоff (ildar@arat.ru)

Сегодня, Хацкер, я открою тебе страшный секрет: в Инете можно не только ломать и хакать, но и созидать. Возможно, ты знал это и даже создавал свой собственный хоумпэйдж, вставляя туда огроменные картинки из клипарта, предварительно обработав их в Paint'е. Вечерами, анализируя счетчики, ты с восторгом обнаруживал, что сегодня на твою страницу было двенадцать заходов - одиннадцать из которых совершил ты, проверяя статистику посещений. Одна из возможных причин такой "популярности" - это то, что твой дизайн хромает, как Джон Сильвер. Ламак в подобных случаях с хныканьем забрасывает свой ресурс, но ты, как истинный Х, исправишь ситуацию. А реально помочь тебе в этом может кульный редактор Macromedia FreeHand.

Есть мнение, что не всяк хацкирь способен постичь хотя бы азы дизайна - не его это, типа, занятие. Мы с тобой попытаемся развеять этот миф-универсал средствами вышеупомянутого редактора и слепим страничку, которая станет стартовой в браузере Артемия Лебедева. Итак, начнем.

Вектор Палыч

Для начала разберемся, что есть векторная графика и зачем ее едят. Вообще говоря, векторная графика - понятие широкое. Но все же есть набор принципов, на которых она базируется. Именно по этим рулесам строится любой продукт, работающий с векторной графикой. Не избежал этого и Freehand, вот они:

Базовые элементы - линии (прямые или кривые). Во Freehand принята такая концепция: базовый элемент - линия с началом и концом, являющимися опорными точками. Любая линия описывается с помощью математических формул, а также некоторым набором атрибутов. Точек как таковых здесь не существует - их заменяет крошечная кривая, у которой начальная и конечная совпадают, и она также описывается некоей формулой.

Контур - следующее звено в иерархии, он может являть собой как базовый элемент, так и сам быть объединением нескольких элементов. Этот принцип позволяет более удобно и оперативно создавать достаточно сложные конструкции. Также у контуров бывают свои атрибуты - такие, как замкнутость, заливка, прозрачность и иже с ними.

Описание взаимного расположения объектов - следующий шаг. Говоря на житейском уровне - кому быть сверху, кому снизу (и, продолжая мысль, - кому, соответственно, выражать недовольство таким положением). Другими словами, от уровневого расположения объектов зависит, как они будут вырисовываться на экране твоего любимого монитора.

"Зачем мне эти вонючие векторы, когда у меня есть чудо-фотошоп?" - заорешь ты. Внесем ясность. Растровая графика представляет собой множество точек с координатами и цветом. Векторная же имеет в своей основе математический аппарат. Я назову два важных преимущества векторной графики перед растровой: во-первых, можно редактировать элемент рисунка, не опасаясь, что он или другие элементы безвозвратно исказятся; во-вторых, как не увеличивай масштаб, кривые линии останутся гладкими, так как меняются лишь значения в формулах, описывающих их. Не веришь - взгляни на скрин.

Кто там у нас на панели?


Спецвыпуск Xakep, номер #015, стр. 015-106-2, Оформи сайт своими ФриХэндами

Оформи сайт своими ФриХэндами

Спецвыпуск Xakep, номер #015, стр. 015-106-2

Загрузив прогу, осмотримся и изучим панели инструментов. Как и в большинстве других графических редакторов, слева ты увидишь панель "Tools". Это - стандартный набор для рисования. Сегодня ты познаешь :) только те инструменты, которые будут необходимы для нашего примера. Вообще-то, почти все инструменты интуитивно понятны. Главное, заруби себе на носу (ну, или просто запомни): многие тулзы во FreeHand настраиваются путем двойного щелчка крысы по их кнопке. Если тулзу можно настроить, то у ее кнопки справа сверху будет тусить децльный черный уголок.

Итак, будем юзать...

Pointer. Обыкновенная стрелка, которой обычно выделяются объекты. Клацай, удерживая Shift, чтобы выделить несколько объектов.

Subselect. Тоже стрелка, но, в отличие от предыдущей, эта выделяет и изменяет не весь объект, а только ту часть, по которой щелкаешь.

Text. Не маленький, сам понимаешь :)... Но параметрами текста лучше управлять через инспектор Text (о нем расскажу ниже). С текстом проходят не все трюки, поэтому иногда полезно переводить его в контуры.

Bezigon. Сие чудовищное слово есть гибрид от двух других слов - Безье и полигон. Этим инструментом рисуют ломаные и многоугольники: ты просто ставишь точки, а редактор сам их соединяет линиями. Степень и форму кривизны определяет также редактор. Ты можешь повлиять на этот процесс, но для сегодняшнего примера вполне подходят опции, стоящие по умолчанию.

Line. Пользуйся этой штукой, чтобы рисовать прямые линии. Тулза Line рисует только одиночные отрезки. Толщина линий и некоторые другие параметры устанавливаются в инспекторе Stroke.

Rectangle. Рисует прямоугольники. Щелкнув два раза по этой кнопке, ты увидишь, что тулза имеет одну настройку - угловой радиус. Это значит, что при значении, отличном от нуля (его ты можешь ввести в текстовое поле или передвинуть ползунок), края прямоугольника округлятся, а если значение равняется ста, то он вообще станет кругом. Если ты уже нарисовал прямоугольник и потом хочешь изменить коэффициент скругления, выдели его и в инспекторе Object измени значение в соответствующем поле. Чтобы точно получить квадрат, во время рисования удерживай Shift.

Ellipse. С помощью этого инструмента можно рисовать обыкновенные эллипсы и окружности, каких на Руси миллионы. Просто удерживай нажатой кнопку мыши и тащи указатель в сторону. Чтобы получилась правильная окружность, снова удерживай Shift. Заметь, что когда ты нарисовал и выделил эллипс, его опорных точек не было видно, зато была габаритная рамка - это значит, что объект сгруппирован. Делается это для того, чтоб ты не начудил чего лишнего - эдакая защитка от дурачка. Если появится такая необходимость, разгруппируй объект командой Modify -> Ungroup или сочетанием клавиш Ctrl+U (кстати, с квадратами та же фигня).

Scale. Служит для изменения размеров. Выдели нужный объект, затем заюзай эту тулзу и масштабируй себе на здоровье. Чтобы пропорции объекта сохранились, удерживай Shift. Если тебе нужно увеличить или уменьшить в определенное число раз, дважды щелкни по кнопке Scale и введи значения в текстовые поля в проявившейся форточке.


Спецвыпуск Xakep, номер #015, стр. 015-106-3, Оформи сайт своими ФриХэндами

Оформи сайт своими ФриХэндами

Спецвыпуск Xakep, номер #015, стр. 015-106-3

Rotate. А эта штучка помогает вращать объекты. При нажатой клавише Shift объекты поворачиваются на угол, кратный сорока пяти градусам. Двойным щелчком по этой кнопке можно повернуть фигуру на конкретный угол путем ввода числа.

Следующая панель - Xtra Tools. Xtra tools - это секретное оружие Freehand. Они похожи на Plugin'ы Photoshop'а, известные любому младенцу. Их объединяет то, что поначалу результат от их применения удивляет самого применителя, иногда очень приятственно. Особые эффекты получаются при комбинировании нескольких операций. Из двенадцати предложенных инструментов заюзаем два:

3D Rotation. Этим инструментом осуществляется вращение контура в пространстве. Его настройки имеют два режима - Easy и Expert, которые отличаются числом опций. Главная из них - Distance, от ее коэффициента зависит, насколько будут отличаться по размеру ближние и дальние части контура.

Smudge. Это мой любимый инструмент, представляющий собой растушевку контура. Он имеет настройки, которые тебе пока лучше не трогать :). Тут трудно что-либо объяснять, но когда ты сам начнешь пользоваться им, все станет понятно.

Товарисч инспектор

В отличие от панелей инструментов, в инспекторах отображается информация о выделенных объектах. Эту информацию можно изменять, что прямым образом отразится на самих объектах. Всего инспекторов пять: Object, Stroke, Fill, Text, Document. Включить панель инспекторов, если она отсутствует на экране, можно командой Window->Inspepctors->любой инспектор. Все они очень важны в работе, и каждый заслуживает твоего драгоценного внимания.

Object. Это общий для всех инспектор, в нем отражаются данные, неподведомственные другим инспекторам и зависящие от типа выделенного объекта, как то - текст, линия, разные виды контуров.

Stroke. Обводка. Все фигуры состоят как минимум из обводки; заливки может и не быть. Из множества параметров данного инспектора рассмотрим только некоторые. Тип обводки - верхний раскрывающийся свиток:

1-й тип - None. Обводка в данном случае прозрачная.

2-й тип - Basic. Простая сплошная линия либо различные виды пунктира. Становятся доступными дополнительные настройки, такие, как цвет линии и ее толщина. Чтобы изменить цвет линии, дважды щелкни по квадратику, черному по умолчанию, и в цветовом миксере подбери нужные цвет и оттенок. Остальные типы обводки - фуфло, забудь про них до поры до времени.

Fill. Заливка. Закрасить можно только замкнутый контур. Возня с этим участковым :) похожа на предыдущую, но здесь добавляется два интересных типа - Gradient и Lens. В нашем примере мы применим их оба. Остальные типы заливки имеют место только в полиграфии.

Text. Ты можешь менять параметры как уже написанного текста, выделив его перед этим, так и приготовить нужный шрифт для будущей надписи.

Document. Глобальный инспектор. Мы столкнемся с его использованием в самом начале.

Лютики-цветочки

Грош цена была бы Фрихэнду, если бы в нем не было бы цветов. Ясно, не васильков и лютиков, а сочной цветовой палитры. Самая удобная панель для боевой раскраски - цветовой миксер, который вызывается комбинашкой цап Ctrl+Shift+9. Слева ты видишь пять кнопок. Четыре верхние - это палитры, стандартные наборы цветов, а пятая, нижняя, добавляет полученный цвет в твой цветовой набор. Сверху вниз:


Спецвыпуск Xakep, номер #015, стр. 015-106-4, Оформи сайт своими ФриХэндами

Оформи сайт своими ФриХэндами

Спецвыпуск Xakep, номер #015, стр. 015-106-4

Палитра CMYK. Она применяется в полиграфии и называется так по составляющим ее цветам: Cyan, Magenta, Yellow, BlacK. Нужна, если дока будет печататься на бумаге.

Палитра RGB. Если же проект создается для монек, то юзай эту палитру. Она базируется на 3-х основных цветах - Red, Green, Blue.

Система выбора цвета HLS (Hue, Lightness, Saturation - спектральный цвет, яркость и насыщенность). Такая система выбора цвета более традиционна и похожа на соответствующие системы в большинстве редакторов.

Последняя - палитра цветов Windows.

Можно сразу раскрасить форму или контур, не добавляя предварительно цвет в свою палитру. Для этого придави прямоугольник за наваянным цветом и тащи прилипший к курсору цветной квадратик на нужную форму или контур. Бросай! Если этот квадратик не влезает в объект, и, как ни старайся, окрашивается только обводка, тогда стоит увеличить масштаб просмотра рисунка.

Это был, образно выражаясь, курс молодого, но крутого яйца, и, если ты все понял, смело читай дальше.

Лепим морду

А ну, давай проверим инструментарий, про который я так долго тебе рассказывал, в конкретном деле - создании морды твоего сайта. Я не буду напоминать старинную мудрость, что по дизайну встречают, а по контенту - провожают, и если в последнем я тебе не советчик, то в первом, надеюсь, через 20 минут твой уровень недосягаемо возвысится над тысячами безымянных страничек, вызывающих то слезы, то спазмы в желудке :). Чтобы ты знал, к чему ты идешь, покажу тебе во всей красе готовый пример.

Прежде чем ты приступишь к активным действиям, сообщу тебе пару-тройку вещей, незнание которых постоянно сбивает с толку новичков: во-первых, когда хочешь отредактировать объект, убедись, что он выделен, - так уж тут принято; во-вторых, в режиме просмотра Preview, который принят по умолчанию, объекты частенько выглядят ступенчато - чтобы сделать картинку гладкой, включи режим Flash Antialiasing (делай это через меню View). И еще: горячие клавиши даны в варианте Фрихэнд 9. Так что, если ты установил себе десятку, смени набор горячих клавиш через команду Edit->Keyboard Shortcuts->Keyboard Shortcuts Settings.

Создай новый документ тычком в кнопку или через меню File->New, или горячим сочетанием Ctrl+N. Теперь определись с размером своего макета. Профессионалы и защитники прав пользователя вроде Якоба Нильсена, живого бога хытымыэльщиков, советуют следующий размер: 550 на 400 пикселов. Для тех, кого устраивают эти габариты, разработчики приготовили "сюрприз" - в инспекторе Document можно выбрать этот вариант. Для этого в инспекторе Document в свитке формата страниц выбери Web. Мною тонко подмечено, что в девятке такого формата нет. Тот, кто не уважает Якоба Нильсена, может задать свои параметры: в этом же свитке выбирай Custom и заливай в поля "x" и "y" ширину и высоту страницы. Не забудь и об ориентации :) - она должна быть альбомной! После этого нажми Ctrl+Shift+W - страница займет максимум рабочего поля, так что все будет на виду.


Спецвыпуск Xakep, номер #015, стр. 015-106-5, Оформи сайт своими ФриХэндами

Оформи сайт своими ФриХэндами

Спецвыпуск Xakep, номер #015, стр. 015-106-5

Строим Васю

В первую очередь мы соорудим самый броский и тяжеловесный элемент дизайна. Нарисуй окружность с помощью инструмента Ellipse, удерживая Shift. Размер подбери сам, ориентируясь на рисунок. Затем сообрази еще одну, но поменьше. Выдели их обе и выровняй следующим образом: нажми Ctrl+Alt+A, появится панель Align; в верхнем свитке установи Align top, в нижнем - Align center.

Жми Apply, и все в порядке. Выдели только малый круг и два раза продублируй его (Ctrl+D). Тут же убери в сторону обе копии, чтобы не мешались. Выдели новоиспеченную конструкцию из большого и малого круга и слей их воедино командой Modify->Join (Ctrl+J) - мы получим один составной контур, который для удобства будем называть в дальнейшем конгломерат. Раскрась его по своему вкусу. Далее по плану у нас текст "Vasya's homepage". Нажми кнопку Text на панели Tools, щелкни в любом месте страницы и пиши этот слоган, не забыв выбрать в инспекторе Text подходящие размерчик и шрифт. Надо пустить текст по кругу? Нет ничего проще: стряхни пыль с одного из заначенных ранее малых кругов, выдели его и текст (но ничего больше!) и выполни команду Text->Attach to path (Ctrl+Shift+Y). Чтобы пустить текст внизу, под линией круга, проделай следующие манипуляции: выбери инспектор Object (само собой, надпись в это время должна быть выделена) и уточни имеющиеся там настройки так, как показано на рисунке.

Закрепим твои знания в выравнивании, попутно сделав доброе дело. Выдели "Vasya's homepage" и конгломерат (помнишь, что это?) и повтори операцию выравнивания с теми же настройками. После этого, не откладывая в долгий ящик, вновь выдели надпись и переведи ее из текста в контур командой Text->Convert to path (Ctrl+Shift+P). Не буду тратить драгоценное время, объясняя, зачем это надо - просто доверься мне :). И последний штрих: слова должны быть над конгломератом, так что выдели их и нажми Ctrl+F, либо выдели конгломерат и нажми Ctrl+B.

Настало время пустить в расход второй отложенный малый круг. Выделив его, для начала окрасим внутреннюю область. Для этого выбери инспектор Fill. По умолчанию там находится свиток с текущим значением None. Раскрой свиток и выбери тип заливки Lens. После этого появятся другие настройки. Во-первых, еще один свиток - в нем следует выбрать Transparency, он и стоит по умолчанию. Ниже ты видишь квадратик, обычно он черного цвета. Дважды щелкни по этому квадратику и выбери подходящий цвет в цветовом миксере. Я не то что бы давлю на тебя, но в примере используется синий цвет :). После того как цвет выбран, перетащи мышкой цвет из миксера внутрь круга. Как настоящий хацкер, в середину круга ты просто обязан поместить букву X. Сделай это самостоятельно, только не забудь перевести эту букву в контур. Когда справишься с этим "нелегким" заданием, выдели букву вместе с кругом и сгруппируй (Ctrl+G).


Спецвыпуск Xakep, номер #015, стр. 015-106-6, Оформи сайт своими ФриХэндами

Оформи сайт своими ФриХэндами

Спецвыпуск Xakep, номер #015, стр. 015-106-6

Наша задача далее - совместить две получившиеся группы (конгломерат с надписью про Васю и круг с буквой "X"). Для этого выдели конгломерат с "Васей", выполни команду Modify->Lock (Ctrl+L) - нам нужно, чтоб эти элементы пока оставались на месте; потом выдели "Х" с кругом и снова выполни выравнивание с все теми же настройками. Тут же, чтобы не забыть, разблокируй то, что заблокировал: просто выдели все (Ctrl+A) и выполни команду Modify->Unlock (Ctrl+Shift+L). Чуть не забыл - позаботься, чтобы круг с "X" был на переднем плане; выдели только его и нажми Ctrl+F.

Следующий этап - имитация 3D. Выдели всю конструкцию с буквой "X" во главе и с помощью инструмента 3D Rotation на панели Xtra Tools внеси перспективу и подбери лучший для себя ракурс :). Готово? Теперь придай объем: выдели только конгломерат и, плавно оперируя инструментом Smudge с панели Xtra Tools, добейся желаемого результата.

Мажем спину градиентом

Итак, главный элемент дизайна готов, самое тяжелое позади. Настала очередь поработать с бэкграундом. Как ты мог заметить, на заднем плане провисают два прямоугольника. Рисуем первый, тот, который квадрат и находится прямо за главным элементом. Бери инструмент Rectangle и, нажав Shift, докажи себе, что ты ничуть не хуже Казимира Малевича. Даже лучше, потому что ты сделаешь квадрат не черным, а градиентным, и кто знает, за какую баснословную сумму килобаксов он будет продан с аукциона через n-дцать лет. Чтобы сделать градиент, в инспекторе Fill в верхнем свитке выбери тип заливки Gradient, а с более детальными настройками можешь пошалить сам. Теперь отправь этот квадрат на задний план сочетанием клавиш Ctrl+B и подгони аккурат под главный элемент. Пока я пойду попью пивка, нарисуй второй прямоугольник, но в инспекторе Fill на этот раз выбери тип заливки Lens, а в дополнительном свитке - Invert. Вынеси его на передний план (Ctrl+F) и спозиционируй в нужное место. Добавим декораций в нашу строгую композицию. Наш проект нуждается в прожекторе, мирно висящем в правом верхнем углу, и он его получит! Для этого щелкни Pointer'ом по ребрам главного элемента и продублируй его (Ctrl+D). Надписи и крышку с буквой Х выделять не надо, нам нужна только основа. После этого уменьши копию до требуемого размера, помести в правый верхний угол и поверни его инструментом Rotate. Теперь добавим поток света от прожектора. Нам придется воспользоваться Bezigon'ом с панели Tools. Нарисуем с помощью него замкнутый пятиугольник (конечная точка должна совпасть с начальной). Чтобы свет выглядел реально, выбери тип заливки Lens, в настройках укажи Lighten. Должно получиться примерно следующее:

Самые привередливые заметят, что испускание света смотрится не вполне естественно. И они будут правы, посему подкорректируем этот момент:

Это делается инструментом Subselect с панели Tools: указатель наводится точно на редактируемый отрезок, при нажатой кнопке мыши подвергается изгибу и доводится до нужной формы. Для более точного изгиба используются так называемые "усы" (они видны на скрине).


Спецвыпуск Xakep, номер #015, стр. 015-106-7, Оформи сайт своими ФриХэндами

Оформи сайт своими ФриХэндами

Спецвыпуск Xakep, номер #015, стр. 015-106-7

Ну, вот и все, шкелет готов полностью. Остальные детали делаются совсем просто. Сделай их сам. Осталось только экспортировать картинку для дальнейшей разбивки в каком-нибудь Ulead SmartSaver, вставки в таблицы и другие издевательства, но это уже совсем другая история. Ты можешь либо просто сохранить документ, а затем вставить во Flash (сварганишь флэш-сайт), либо перевести в растр. Последнее делается через команду File->Export, но, сознаюсь, экспорт у Фрихэнда не самое сильное место, а потому лучше всего удавить волшебную кнопку Print Screen с дальнейшей вставкой в растровый редактор.

В общем, делай, думай, фантазируй, но не тормозируй :). Ведь нет предела совершенству!

Дай мне!

Итак, ты реально проперся от этого материала, у тебя чешутся руки в творческом возбуждении, в твоей голове масса гениальных идей, и единственное, чего не хватает - это самого редактора. Ты можешь скачать trial-версию с сайта разработчика (http://www.macromedia.com/software/freehand/trial/), порядка 19 мегов, и, если очень поторопишься, то успеешь сваять нечто великое за те 30 дней, которые отведены тебе для законного пользования. Про другие варианты заполучения дистрибутива я тактично умолчу - уж слишком это очевидно.

Вероятно, ты захочешь продолжить обучение, и тебя жутко интересует, какие ресурсы по нашему редактору есть в сети. Возможно, тебя обрадует, что зарубежных сайтов по этому поводу достаточно, и выйти на них можно с адреса http://www.macromedia.com/support/freehand/ts/documents/tn3642-fhwebsites.html. Но если по-английски ты знаешь только одно слово "факью", они тебе мало помогут. В Рунете, к сожалению, я знаю только один сайт, посвященный Фрихэнду, - www.freehand.str.ru. Да и его, к слову сказать, не было бы, если б я в свое время его не сделал :). Так что дерзай, изучай, ваяй свои крутые паги - а в случае чего не стесняйся обратиться за советом. Удачи!


Спецвыпуск Xakep, номер #015, стр. 015-111-1, Сам себе мультипликатор

Сам себе мультипликатор

Спецвыпуск Xakep, номер #015, стр. 015-111-1

hurrigane[fish] (fishka@gmx.net, icq #159212) & UFO (ufobject@mail.ru)

ХочИшь хочИшь?

Привет! Ты уже, конечно, слышал о такой штуке, как Flash. Это и неудивительно - ведь весь Инет сегодня кишит сайтами, сделанными с помощью этой мульки. Что это такое? Это когда все двигается, бегает, прыгает, нажимается и пищит =). Сайты, однако, - не единственное, что можно творить на Flash. Наверняка ты видел кучу мультиков, сделанных с помощью этой технологии. Они, как правило, отличаются яркой графикой, динамичностью, интересным сюжетом и при всем при этом весят очень мало. Flash - идеальная среда для приложения ручек начинающего аниматора по нужному адресу (а кто сказал, что хакер не должен творить? =). Я прямо вижу, как у тебя уже ручки чешутся замутить что-нибудь эдакое. Спешу тебя обрадовать - это несложно и, более того, безумно интересно. Придвинься ближе...

Приступим

Для начала несколько основных понятий, с которыми ты столкнешься при работе с Flash. Здесь используется векторная графика - это значит, что рисунок представляется в виде кривых (векторов), которые имеют цвет и координаты. Это замечательно тем, что ты можешь передвигать объект, менять цвет, форму, растягивать, сужать - и все это без потери качества! С растровой картинкой такое не прокатит.

Итак, за дело. Раз лабать мы будем мультики, то и без рисования нам, естественно, не обойтись. И даже не пробуй говорить, что у тебя нет художественных способностей - при работе с Flash их не требуется иметь в немереных количествах (ты же, в конце концов, не GRiF какой-нибудь ;). Сейчас ты в этом убедишься на собственном опыте. А рисовать мы будем не кого-то, а Колобка (помнишь такого мэна, который однажды, поймав нехилый глюк, сбежал от бабки с дедкой? =).

Хватай-ка в зубы карандаш...

Положим, ты высосал с www.macromedia.com 18-меговый дистриб с тулзой творца, установил, поломал... стоп! решил с пользой заюзать 30-дневный шароварный период и загрузил Flash. Слева линейка с инструментами, посередине чистый лист, сверху насыпались инспекторы (форточки такие). Рассуй инспекторов по краям. Часть из них мы вообще юзать сегодня не будем. Теперь выбери в инструментах карандаш, он же Pencil Tool. Видишь, как под инструментами, в Options, появилась кнопочка? Ткни-ка ее, да посильнее ;). Эта кнопочка отвечает за спрямление/скругление линий, которые ты будешь рисовать. Выбери Straighten и попробуй нарисовать линию. Заметил, как она выпрямилась после того, как ты отпустил кнопку мыши? Если же выбрать Smooth, то линии, которые ты будешь рисовать, станут мягче, более плавными. Есть еще такая фишка - Flash умеет распознавать геометрические фигуры, то есть если ты нарисуешь что-то отдаленно похожее на треугольник, квадрат или круг, Flash тут же приведет это в божеский вид. Впрочем, можно это делать и с помощью специальных инструментов (кнопочки с кругом и квадратом соответственно).

Черненьким курсором, который называется Arrow Tool (обзовут же =), попробуй потянуть за серединку линии. А линия-то гнется! А теперь нарисуй вторую линию, возьми ее за самый конец и подведи к концу первой. Обратил внимание на черный жирный круг, появившийся на курсоре? Если сейчас отпустить мышку, то линии, как магнитом, притянутся друг к другу. Кстати, если тебе в какой-то момент будет сильно мешать, что все липнет друг к другу и к чему не надо, то просто щелкни по "магниту" (Snap to object) внизу линейки инструментов. Если тебе нужно нарисовать очень мелкую деталь, используй масштаб - окошко в левом нижнем углу рабочей области.


Спецвыпуск Xakep, номер #015, стр. 015-111-2, Сам себе мультипликатор

Сам себе мультипликатор

Спецвыпуск Xakep, номер #015, стр. 015-111-2

Кадры решают за всех

Не забыл? Мы решили не просто рисовать, а сотворить мультипликационный шедевр. Как делают мультики? Грубо говоря, так: аниматор рисует на отдельных листках героя с различными фазами движения, потом это все переносится на кинопленку, и при быстрой прокрутке кажется, что герой движется. В Flash анимация создается точно так же: перед тобой в рабочей области не один лист, а целая стопка. На каждом следующем листке ты будешь создавать новую фазу движения героя. Перемещаться между кадрами можно с помощью линейки кадров. Эта фенька с маленькими белыми и серыми прямоугольничками и цифрами 5...10...15...20, которая торчит вверху рабочей области. Но сейчас у тебя всего один кадр - первый, поэтому первый прямоугольничек в черной рамке. Если ты в первом кадре уже чего-то нарисовал, то прямоугольник станет серым и пометится точкой.

Давай научимся стряпать кадры. Дави File/New и в первом кадре рисуй круг. Теперь ставь курсор на пятый кадр (то есть на пять прямоугольников правее) и дави F5. Таким макаром ты сварганил блок из пяти одинаковых кадров. Прямоугольник с точкой - начало блока, прямоугольник с маленьким белым прямоугольничком - конец блока. Если нарисовать или стереть что-нибудь в любом из этих кадров, то все остальные тоже изменятся. Хочешь, чтобы в следующем кадре что-то изменилось (например, Колобок поднял руку), а предыдущие остались прежними? Тогда ставь курсор на следующий кадр и щелкай F6. Получился еще один прямоугольник с точкой. В этом кадре можно подвинуть круг в сторону (Shift+стрелка), в остальных - он останется на прежнем месте. Кадры с точкой - ключевые, в них происходят изменения. Кадры без точки - простые. Они такие же, как и предыдущий ключевой кадр.

Нажми Ctrl+Enter. Видишь, твой кружок время от времени дергается в сторону. Закрой окно с фильмом. Поставь курсор на кадр с маленьким беленьким прямоугольничком и пять раз шлепни F5. Если что-то получилось не так, юзай пункт меню Edit/Undo. Опять задави Ctrl+Enter. Теперь кружок дергается реже. То есть простые кадры нужны, чтобы отмерить время до следующего изменения в фильме. Чем больше простых кадров между ключевыми, тем медленнее будет двигаться герой.

Устелем пол ровным слоем?

Слои - это еще один мощный инструмент создания сложной анимации во Flash. Юзая слои, очень удобно совмещать, например, декорации и нескольких героев. Ты можешь редактировать какой-то из элементов сцены, не затрагивая остальные, так как они лежат в разных слоях. Давай договоримся по дружбе, что у тебя бэкграунд (лес), герой (Колобок) и куст (он и в Африке куст) будут лежать в трех разных слоях. Делай новый фильм (File/New) и смотри в левый верхний угол рабочей области. У тебя пока есть только один слой (Layer 1). Щелкай по нему два раза и переименовывай в "лес". Теперь жми на маленький квадратик с загнутым уголком и жирным плюсом. Ты только что родил новый слой! Переименуй его в "куст". Убить слой можно маленькой характерной помойкой. Создай еще один слой и назови его "Колобок". В слое "лес" (выбери его) нарисуй много-много темно-зеленых кругов (цвет выбирай в форточке "Mixer", тыкнув мышом в нужный оттенок). Это будут деревья. В слое "куст" справа нарисуй пару-тройку светло-зеленых кругов. Это будет куст. В слое "Колобок" по центру нарисуй желтый круг - это Колобок. Теперь дави F6 и в новом ключевом кадре, дважды щелкнув по желтому кругу, немного сдвигай Колобка к кусту (Shift+стрелка). Опять дави F6 и немного сдвигай Колобка, и опять, и опять, пока он не наедет на куст. Теперь поставь курсор на 20 кадров левее и снова жмякни F6 (чтобы Колобок успел сделать в кустах все свои дела =). В остальных слоях тоже поставь курсор на этот же кадр и тоже щелкни F6. Это чтобы лес и куст присутствовали во всех кадрах.


Спецвыпуск Xakep, номер #015, стр. 015-111-3, Сам себе мультипликатор

Сам себе мультипликатор

Спецвыпуск Xakep, номер #015, стр. 015-111-3

Дави Ctrl+Enter. Что за дела?! Колобок не хочет идти в куст, а делает свои дела прилюдно! Это потому что слой "Колобок" лежит выше слоя "куст". Закрой окно с мультиком, ухватись за надпись "куст" и перетащи ее выше "Колобка". Снова жми Ctrl+Enter. Теперь порядок: Колобок делает свои делишки за кустом. В каждом слое могут происходить свои события независимо от других слоев, причем в конечном фильме это все будет делаться одновременно.

Символы и экземпляры

Итак, ты нарисовал много-много линий и согнул их все в дуги и бараньи рога. Теперь используй полученные знания на практике. Нарисуй Колобка. Выпученные глаза и круг вместо всего остального, ну и про шаловливые ручки не забудь ;). Глаза и руки нарисуй пока что где-нибудь отдельно от туловища. Для чего это надо? Дело в том, что во Flash не нужно рисовать каждый кадр заново - одну и ту же картинку можно использовать в фильме много раз, при этом размер конечного файла никак не изменится. Поэтому мы "разобьем" нашего Колобка на части: пузо, глаза, рот, руки - и сделаем их символами. Символ - это зафиксированная графика, которая представляет собой единый объект, а не отдельные кривые. Впрочем, символ может быть анимацией (маленький фильм в фильме) или кнопкой. Графика (Graphics) - это один кадр, поэтому она всегда одинаковая. Анимация (Movie Clip) состоит из нескольких кадров, поэтому изменяется по ходу фильма. То есть в следующих кадрах фильма анимация будет меняться в соответствии со своими внутренними кадрами (как будто две кинопленки наложили друг на друга). Символ "кнопка" (button) для мультиков нам не понадобится.

Следует, кстати, различать сам символ и его экземпляры. Символ один (он лежит в библиотеке [Ctrl+L]), а экземпляров много. Например, в один кадр можно посадить хоть три Колобка - это будут его экземпляры №1, №2 и №3 соответственно. Каждый экземпляр можно увеличить, сплюснуть, сделать поярче, но сам Колобок от этого не изменится. Но если поменять что-то в главном Колобке, то автоматически поменяются и все его экземпляры.


Спецвыпуск Xakep, номер #015, стр. 015-111-4, Сам себе мультипликатор

Сам себе мультипликатор

Спецвыпуск Xakep, номер #015, стр. 015-111-4

Бьем Колобка на части

Давай сделаем пузо нашего Колобка символом - выделяй его черной стрелкой (так же, как ты выделяешь войска в стратегии), топай в меню Insert/Convert to Symbol и выбирай тип символа Graphics. В поле "Name" пиши "пузо". Таким же образом поступи с одной рукой - это будет символ "рука". Вторую удали (и зачем ты ее рисовал?). Теперь, когда мы будем создавать анимацию, мы сможем не рисовать Колобка заново в каждом кадре, а просто вставлять его в фильм снова и снова. Глаза Колобка мы тоже сделаем символом - но уже не графикой, а анимацией. Для этого при превращении в символ выбери пункт "Movie Clip". А теперь засунем глаза на их законное место... Нет, нет, законное место находится не в нижней части Колобка, а в верхней ;). Как? Глаза уехали под тушку Колобка? Выдели ее и используй пункт меню Modify/Arrange/Send Backward. Пункт Arrange отвечает за посыл символов на задний план или вытягивание их вперед. Теперь дважды кликни Колобку в глаз - ты оказался в редакторе символов и редактируешь теперь только глаза. Пока тут только один кадр, но ты теперь знаешь, как добавлять и изменять кадры, и самостоятельно нарисуешь несколько штук, в которых глаза будут постепенно закрываться и открываться. Вернуться в основную сцену можно, дважды щелкнув в стороне от глазок. Нарисуй нашему Колобку миленький ротик, сделай его символом, прилепи куда-нибудь на серединку... Тоже сделай его "Movie Clip-ом" и отредактируй его так, чтобы он открывался, превращался в страшную пасть и закрывался (чтобы лиса перепугалась и свалила куда подальше ;).

Теперь скомпонуем Колобка. Глаза и рот у тебя вроде на пузе, а вот рука - одна. Открывай библиотеку (Ctrl+L), выбирай там символ "рука" и вытаскивай его мышкой в рабочую область. Теперь у тебя есть две, допустим, левые руки. Это нехорошо. Топай в пункт меню Modify/Transform/Flip Horizontal - рука станет правой. Приставь руки к телу. Так мы сэкономили на размере файла: чтобы не хранить 2 рисунка руки, мы использовали один рисунок 2 раза. Вот такой прием оптимизации фильма.

Оно двигается-я-я-я!

Наш Колобок готов к труду и обороне! А раз так, то научим его двигаться. Как ты помнишь, для того чтобы заставить его двигаться, нужно рисовать ключевые кадры. Для начала пусть Пузатый немного попрыгает - сделай ключевым 2 кадр, выдели все изображение в нем и чуть-чуть приподними (Shift+стрелка вверх). Повторяй это целебное действие, пока Круглый не подскочит достаточно высоко, а потом щелкни только по глазам и сделай еще пару кадров, где они подскакивают еще выше =). Дальше делай то же самое, но наоборот: сперва опусти глаза на прежнее место, а потом - всего Колобка. В результате ты получишь прыгучего Колобка с прыгучими глазами =). Только смотри, чтобы длина Movie Clip-ов с глазами и ртом не превышала длину основного фильма, а то не влезет. Дави Ctrl+Enter.


Спецвыпуск Xakep, номер #015, стр. 015-111-5, Сам себе мультипликатор

Сам себе мультипликатор

Спецвыпуск Xakep, номер #015, стр. 015-111-5

Теперь пущай, что ли, ручкой нам помашет. Пропусти несколько кадров и вставь один ключевой, потом в этом ключевом кадре выдели символ одной из лап Колобка и нажми Rotate (появившаяся кнопочка с закругленной стрелкой на линейке с инструментами). Повращай руку нашего многострадального круглого друга так, чтобы она немного приподнялась с одного боку. Чтобы более четко сопоставлять фазы движения, заюзай фишку "Onion Skin" (это вторая маленькая кнопочка вправо от помойки, удаляющей слои). Бледное изображение - это то, что было в предыдущих кадрах. Чтобы отрегулировать количество видимых фаз, подвигай границы маркера на линейке кадров. Несколько раз повтори фазы движения руки и смотри, что получилось. Колобок скачет, машет рукой, открывает рот и хлопает глазами, но тебе не пришлось прорисовывать каждый кадр, ты просто нарисовал отдельные части. Правда, здорово?

Истошные крики

Колобок, конечно, у нас весь такой из себя замечательный, только тихий какой-то =(. Сейчас исправим - будем озвучивать нашу мультяху. Лезь в File/Import, находи на своем винте подобающий колобкам звук в .WAV или .mp3. В результате он появляется в библиотеке (Ctrl+L) вместе с остальными символами. Делаем так - достаем из Window/Panels панельку Sound. Далее делай следующее: выдели первый кадр, в поле Sound выбери свежеимпортированный файл, а в Sync - Start (таким образом, наш файлик начинает воспроизводиться, как только фильм доходит до нужного кадра). Чтобы остановить воспроизведение на желаемом кадре, просто проделай ту же процедуру, но в Sync укажи Stop. В поле Effect выбери Fade Out, чтобы музон (если ты вставил именно музон, а не нежное попукивание) к концу постепенно затихал. Теперь Круглый прыгает и машет под музычку.

Доктор сказал - в морг, значит, в морг...

Вот, в общем-то, и все об анимации во Flash. Согласись, это просто, а главное, весело и увлекательно. Юзай фантазию, создай хардкорный хакерский боевик и выложи его в сеть. Напоследок хочу отправить тебя на www.joecartoon.com, www.mult.ru, kf.ee/flash/. Посмотри, что можно сотворить, имея в распоряжении мыху, клаву, прямые руки и Флеш. Если возникнут вопросы, мыль - помогу. Успехов!


Спецвыпуск Xakep, номер #015, стр. 015-113-1, Запутаться во всемирной сети

Запутаться во всемирной сети

Спецвыпуск Xakep, номер #015, стр. 015-113-1

Кирилл Меньшов aka ManU (liks@imail.ru)

Здравствуй, приятель! Сегодня я буду тебя отчаянно пугать :). Не буду говорить о том, как вредно денно и нощно сидеть перед монитором, и даже постараюсь избежать темы интернет-зависимости, тем более - не буду говорить о разврате в сети...

Ты, наверное, продвинутый юзер - облазил весь Инет, много повидал, много поломал. И теперь с восхищением размышляешь о тех гениях, которые придумали эту великую паутину, и возмущаешься, почему им не вручили Нобелевскую премию и не объявили вселенскими героями. Могу тебя обрадовать: таких, как ты, много. Но перед тем как продолжить свои восхищения и возмущения, давай посмотрим, действительно ли так полезен этот Инет...

Современный Интернет

Но сначала небольшой вопросик по истории: в каком году появился зародыш Инета?

Облом? Гы-гы. Если бы ты читал январский выпуск "Хакера", то ты бы знал, что

зародыш Инета (APRANet) появился в 1969 году в США. А теперь давай посчитаем,

сколько сейчас лет гаденышу (подсказка: сегодня 2002 год)... 33! Если наши ответы

сошлись - беги за пивом: ты потенциальный Эйнштейн. 33 - вполне зрелый

возраст для человека, но для бессмертного создания (а я уверен, что пока есть человек, будет и паутинка) - это мелочь. И за столь короткое время Инет умудрился стать всемирным. Теперь ты чувствуешь, насколько стремительно развивается эта чума (страшные глаза, в зобу дыханье сперло... =0))?

Буль-буль...

Примерно такие звуки издает тонущий в воде (или в соплях, как я сейчас) человек. А вот какие звуки издает человек, тонущий в информационном потоке, я описать не смогу - censored, так сказать. Проблема информационного завала - одна из самых явных и обсуждаемых. Интернет - это абсолютная свобода. Каждый волен делать то, что хочет. Его ограничивают только его же собственные способности, да и то не всегда. У Инета нет фильтров. Он бездумно засасывает в себя всю информацию: профессиональную, непрофессиональную, правдивую, лживую, правильную, неправильную. Без разбора. Каждый волен выложить свои "труды" на всеобщее обозрение. И все бы ничего, если бы в куче этих "трудов" не тонули по-настоящему одаренные люди. Но твою любимую сеть засоряют не только "гении", но и "копиры". "Копиры" - это подвид уродов, который занимается копированием всякой всячины в Инете. Вот, например, какой-нибудь журнал, назовем его "Х", сделал свой сайт. На нем он размещает всякие интересные статьи, а "копиры" налетают и копируют, копируют, копируют... В результате, когда нужна инфа по какой-либо теме, ты идешь на поисковик и получаешь тучу ссылок на кучу страничек. "Вот изобилие!!!" - думаешь ты и обламываешься, когда оказывается, что из всей этой кучи оригинальных файлов - пять штук, а все остальное - их копии. Вот и выходит такая фигня: при абсолютной (информационной) свободе образуется информационный вакуум. Выходит, что Инет разрастается благодаря копированию старой информации, а не получению новой.

Выход №1

Утопшим гениям уже не помочь, а тем, кому эта участь предстоит, совет: не лезь в Интернет - в нем правды нет! А проблему "копиров" должны решать поисковики. Если бы они начали фильтровать информацию на уникальность, "хоть


Спецвыпуск Xakep, номер #015, стр. 015-113-2, Запутаться во всемирной сети

Запутаться во всемирной сети

Спецвыпуск Xakep, номер #015, стр. 015-113-2

редко, хоть в неделю раз", - тогда бы не было проблем с вышеозначенными уродами.

Но Rндексам, Абортам и Румблирам нравится понтоваться числами...

Англифигация

В смысле - англификация. Этот процесс сейчас так или иначе проходит во всем мире, а Интернет ему способствует. Ты уже, наверно, заметил (ну да, ты же потенциальный Эйнштейн ;-)), что пятая часть всей читаемой информации в журналах (особенно в компьютерных)- это англифицированные словечки. Либо это чисто английские слова, либо английские слова, написанные кириллицей (адаптированные, заимствованные), либо русские слова, выбитые заморской "латиницей". Все говорят о том, что в наше время знать английский - чуть ли не важнее, чем русский. Происходит смешение культур. ВЕСЬ Инет сейчас весит около 40 терабайт, сколько это нулей - думай сам (подсказка: много больше восьми). Доля рунета в этой массе - 840 гигабайт, а Россия - не последняя по весу Инет-страна.

Получается, что англоязычных ресурсов в сети гораздо больше (и они к тому же информативней - мы-то все копируем :)... Вывод: если хочешь найти инфу и увидеть Инет во всей его красе - изучай английский. И избежать этого воздействия со стороны паутины невозможно, сеть - идеальный носитель информации. Для тебя это не важно, но не стоит быть эгоистом - отдел "Р" накажет. Представь, как будет хреново, если весь мир будет на одно лицо (а именно к этому ведет смешение культур) - даже над буржуями простебаться не удастся. Кстати, смешение уже частично произошло, мир поделился на Восток и Запад, раньше в пределах одной страны сосуществовало несколько культур, а сейчас - фиг.

Выход №2

Есть выход. Массовые самоубийства! Пусть знают! Даня, выступи организатором - у тебя есть опыт...

Скованные одной цепью

Много тысяч лет назад человечество совершило великий рывок - вышло из пещеры!

Теперь мы, погуляв вне пещер, в них возвращаемся. Ура, товарищи, ура! Только пещеры эти мы строим сами и называем их "дома" (что за глупое слово?). А кто нас загоняет в эти дыры? Конечно же, Интернет. Станислав Лем назвал этот поворот "вхождением в пещерную электронную эпоху". Первым этапом приковывания людей к дивану было телевидение, и некоторые перцы просиживали перед телеком большую часть своей жизни. Большую, но не всю - телевизор мог отчасти заменить общение, но не мог дать денег и еды, так что эта чума не смогла загнать человека в четыре стены. С Инетом же все обстоит иначе. Он не просто заменяет общение - он переводит его на новый уровень: общайся сколько и с кем угодно, будь кем угодно, можешь открыться кому угодно - ведь это не ты, а просто набор цифр. Более того, Инет может тебя кормить. Все что требуется - это овладеть нужными навыками: информационная безопасность, дизайнерство, журналистика (гы-гы)... Заработанные деньги будут переведены на твой счет (также открытый с помощью сети), а потом с помощью этого счета ты будешь их тратить в е-маркетах. Вот такая цепочка, не выходящая за рамки Интернета. Но для счастья тебе нужно нечто большее, чем набитое брюхо и общение, - тебе нужна ЖИЗНЬ, события, приключения, проблемы и их решения. И тут, слава зайцам, тебе на помощь приходят разработчики сетевых игр! Ты уже слышал про Ультиму и ей подобные ролевики? Типа "спаси дракона, убей принцессу". Сколько народа нешуточно подсело на эту игруху... Вот тебе жизнь, вот тебе приключения и все что нужно. А ведь игрушка явно староватая, уже давно можно создать более совершенную, более засасывающую. Еще пара десятилетий - и ты будешь резвиться в одной из многих матриц. И вот тебе задачка: если ты полностью (всеми своими пятью чувствами) подключен к миру машины - то как ты определишь, что ты вышел из игры? Может, это просто обман, и на самом деле ты попал в другой эпизод? Вот незадача... А теперь представь ораву квакеров, бегающих по улицам твоего родного города и мочащих прохожих с криками "Уроды - они как Паша..." с полной уверенностью в том, что они мочат компьютерные муляжи. Но это все в будущем, а пока Инет пытаются приспособить для выполнения работы, не выходя из дома: профессор читает лекцию перед веб-камерой, а ты сидишь (точнее, сажаешь свой цифровой муляж ;)) перед монитором. Или: доктор оперирует пациента, который находится в Нигерии, из своего дома в Австралии. Или... Да до фига еще этих "или".


Спецвыпуск Xakep, номер #015, стр. 015-113-3, Запутаться во всемирной сети

Запутаться во всемирной сети

Спецвыпуск Xakep, номер #015, стр. 015-113-3

Выход №3

Присоединиться к тем, кто умирает, протестуя против англификации. И дрессировать канализационных крыс, чтобы те прогрызали оптоволокно.

Виновники торжества

Ну что, ты видишь, чего стоит Инет? Нобелевку давать не будем? Да и с героями переборщили... Но как некогда безобидная сеточка переросла в такого монстра? Кто

виноват? Виноваты все, но главный виновник - капитал, желание заработать. Интернет дает возможность с огромной скоростью получать ценную информацию в любой точке земного шара, но этого недостаточно, чтобы делать на Инете действительно большие деньги. Это привлекло бы лишь профессионалов, которым требовалась информация (изначально сеть создавалась именно с такой целью). А чтобы заманить туда весь мир, нужно было засунуть в паутинку огромное количество развлечений. Капиталюги (взято из словарика околоподъездной старушки) так и

сделали. Потом все полученное залили рекламой, оповестили весь мир об "абсолютной информационной свободе" и стали получать деньги.

А малыш все растет...

...и мутирует. Теперь ты знаешь, какие проблемы несет в себе Инет и кто их возбудитель. Если немного подумать (ты еще не забыл, Эйнштейн?), то можно представить, до чего докатится Интернет в будущем. Сеть берет своей общедоступностью и развлекательностью. Значит, в дальнейшем ее развитие будет проходить через эти два плюса. Уже сейчас существуют проекты, в которых для подключения к Инету потребуются только телевизор и консоль. Это сильно ограничит возможности пользователя (тебя, мой товарищ, тебя), но отпадет

необходимость в классическом телевидении, и все, кто раньше смотрел ящик, перейдут на сторону Интернета. Присоединившиеся будут требовать больше развлечений (и новостей в том числе), а развлечения, в свою очередь, вытеснят из паутины еще существующие профессиональные ресурсы, которые создадут свою подсеть (что-нибудь типа FIDO).


Спецвыпуск Xakep, номер #015, стр. 015-113-4, Запутаться во всемирной сети

Запутаться во всемирной сети

Спецвыпуск Xakep, номер #015, стр. 015-113-4

Такие дела

Вот все, что я хотел до тебя донести. У Инета намного больше проблем, чем я описал, но эти три - основные. И в будущем просвета не видно. На первый взгляд, они мелкие, но последствия будут серьезными. Ты - тот, для кого Интернет существует, ты - тот, кто делает его таким, каков он сейчас и каким он будет. Так что выбери, что тебе нужно: куча мусора или грамотно устроенная информационная сеть. Игнорируй бесполезное и создавай полезное...


Спецвыпуск Xakep, номер #015, стр. 015-115-1, Интернет-2: фантастическая реальность или реальная фантастика?

Интернет-2: фантастическая реальность или реальная фантастика?

Спецвыпуск Xakep, номер #015, стр. 015-115-1

Андрей Михайлюк ака Dronich (dronich@xakep.ru)

Идея всей этой статьи вылезла из большого облома, который я получил, пытаясь приобщиться к "высоким интернет-технологиям". Первый раз в жизни решил поглядеть на мир сквозь призму веб-камеры. Из дома, понятное дело, не получилось - послали со словами "19200? Ты чего, мужик? Выделенку тяни!". Тянуть не стал, ответно их обматерил, а опосля поехал в универ - там стомегабитка испокон веков протянута. Законнектился, посмотрел... Мдя. Если с такой связью я лицезрел только окошко 200х200 с чем-то размытым внутри, что же тогда скрывается под ссылкой "Для 28800-модемов"??? И решил я выяснить, есть ли какие-нибудь наработки в этой области, может, лет через энцать порадуют наконец 3D-супер-видео-гипер-общением? И вообще - придет ли конец гадким лагам и сопутствующим им гадостям?

Ты не поверишь, но придет. И гораздо раньше, чем ты думаешь. Америкосы уже вовсю развивают (ты понял - не придумывают, не разрабатывают, а уже развивают!) проект Интернет-2. В процесс вовлечены более 160 университетов США и сетевых компаний по всему миру. О поддержке объявили такие фирмы, как 3Com, Alcatel, AT&T, Cisco Systems, IBM, Intel и, конечно, Microsoft (куда ж без них ;)). И вааще - это круто ;), так что слушай.

Что за?

Проектом Интернет-2 занимаются в основном в учебных заведениях Самой Шизанутой Америки ;). Причем занимаются серьезно - готовы не только программные разработки, но и технологические решения. У буржуев уже функционирует сеть поддержки, на основе которой и будет существовать "второй Bнтернет". Да, он не будет заменять существующий, не будет вытеснять NGI (Next Generation Internet), продвигаемый америкосскими вояками. Это будет просто новая плоскость со строгой спецификой, состоящая из высокоскоростных сетей, соединяющих университеты и основные сети всего мира.

Для чего?

Использоваться новая сетка будет в тех областях, удовлетворить запросы которых обычный Инет не в состоянии. Нет, не в создании супер-порносайтов-с-элементом-участия. Хотя... кто знает, что будет дальше ;). Пока же приоритеты у следующих областей:

1. Интерактивное общение

Действительно, за все время существования сетей оптимальным способом общения был и остается обычный текстовый чат. Пора менять. Теперь (то есть в Интернет-2) возможно проводить конференции с эффектом присутствия. Специальная камера высокого разрешения, такой же проектор, и - вуаля - перед тобой комната с собеседником, а перед ним - ты. И поверь мне - не за горами и полноценные 3D конференции, загляни на www.teleportec.com, ты сильно удивишься.

2. Дистанционный доступ к техническим средствам

Еще одно направление, важное для университетов. Как тебе возможность посмотреть на Большую Медведицу глазами мощнейшего телескопа из Калифорнии? Или изучать вирус, находясь за сотни километров от микроскопа? Что, тебе это на хреф не надо? А америкосские ученые тащатся. Ну ладно... Для тебя припасены возможности управления спутниками и целыми лабораториями. Рай для хакера - почувствуй себя Гордоном Фрименом ;).


Спецвыпуск Xakep, номер #015, стр. 015-115-2, Интернет-2: фантастическая реальность или реальная фантастика?

Интернет-2: фантастическая реальность или реальная фантастика?

Спецвыпуск Xakep, номер #015, стр. 015-115-2

3. Доступ к вычислительным мощностям и базам данных

Весьма полезная штукенция как для ученых, так и для простых смертных. Сейчас доступ к мэйнфрэймам далек от идеала - вся работа проходит почти без обратной связи: задал параметры, исходные данные, получил результат. То же самое и с БД - запрос не подлежит корректировке во время выполнения. Если же канал доступа будет достаточно широким, мейнфрейм будет не менее доступен, чем твой обычный комп.

4. Полноценная работа в виртуальной реальности

Добрались до самого вкусного ;). Если в данный момент организовать такую фишку, как ВР, на отдельно взятом компе не составит труда (правда, для этого нужен двухсотпроцессорный от IBM ;)), то заняться тем же виртуальным сексом с девочкой из Перу (мачо из Мехико, осликом из Питера - нужное подчеркнуть) получится вряд ли. После же широкого внедрения технологий Интернет-2 можно будет (имея соответствующую экипировку) организовывать работу полностью в виртуале для любого числа пиплов одновременно (недетская групповуха ;)). Степень важности для науки огромна - исследователи могут наблюдать за виртуальным взрывом хоть из его эпицентра и притом находиться на любом расстоянии от эмулирующего компа. Фантастика? Не-а, реальность... виртуальная :).

Как?

В технической реализации всей этой шняги нет ничего революционного - это всего лишь грамотное применение и совершенствование существующих технологий. На территории Америки расположены gigaPoP'ы (в сторону иронию - это узлы сети огромной мощности и пропускной способности), связанные первосортнейшим оптоволокном. С их помощью осуществляется координация в пределах Интернет-2, через них же идет связь с обычным Инетом. При подключении других сетей в них должен быть либо готовый гигаПоП (отменное все-таки словечко :)), либо же они связываются с существующим на правах сети низкого уровня (то есть с меньшей скоростью). Сети, соединяющие гигаПоП'ы с меньшими узлами, именуются Abilene (хоть убей, не знаю, как читается) или сетями поддержки. То есть в идеале все значимые узлы старого Инета, университеты, лаборатории или заинтересованные фирмы должны непременно подключаться к ПоПам и ставить новый софт для использования новых возможностей. Кстати, о софте. В окошках ничего особо бегать не будет, да и в Линухе тоже. Все старые технологии и протоколы передачи данных оказались безнадежно устаревшими. Представь себе одинокий Запорожец, выжимающий свои шестьдесят посреди пустынного хайвея. Примерно так смотрится получение данных по FTP в сети Интернет-2 ;). Если верить авторам проекта, все именитые корпорации уже готовятся к расширенным возможностям новой сетки. И под Линух тоже есть кое-какие наработки. Так что все очень даже серьезно.

Все софтовые разработки для Интернет-2 обязаны поддерживать новую систему работы с пакетами Quality of Service. Объясню на пальцах: мальчик Петя общается в режиме видеоконференции с девочкой Машей. В то же время инопланетный киборг КЛЯ мылит гневные письма в суппорт своей стыковочной станции, которая повисла на орбите. Пакеты от КЛИ и Пети идут на один маршрутизатор, где сортируются и отправляются по месту назначения. Но вот беда - многие пакеты теряются (тому много причин - окончившийся TTL, битый заголовок и так далее), а потому перепосылаются заново. КЛЕ все равно - эти разборки идут на уровне почтовых серверов. А вот Маша и Петя страдают из-за задержек изображения. И тут на помощь им приходит система QoS. Заключается она в следующем: каждому пакету присваивается статус важности в зависимости от приложения (высший приоритет у видеоконференций) или отправителя (пакеты В. Путина гораздо круче пакетов В. Пупкина). На маршрутизаторе происходит такая катавасия - пакеты КЛИ будут ждать в очереди, пока пройдет цепочка пакетов от Пети, и пойдут дальше, только когда канал освободится. Вот так мы победили кариес... в смысле, Маша с Петей довольны, у КЛИ поводов огорчаться тоже нет, ведь емыл не требует моментальной реакции (тем более от суппорта ;).


Спецвыпуск Xakep, номер #015, стр. 015-115-3, Интернет-2: фантастическая реальность или реальная фантастика?

Интернет-2: фантастическая реальность или реальная фантастика?

Спецвыпуск Xakep, номер #015, стр. 015-115-3

Кому все это надо?

Финансированием проекта пока занимается непосредственно правительство США, из чего следует, что работы будут идти полным ходом - америкосы не привыкли жалеть денег на свою славу. Почему на славу? Многие надеются, что Интернет-2 повторит судьбу АпраНет. Помнишь еще такую? Всемирная сеть, в которой рулят Штаты - что может быть прекрасней ;). Но возможен и обломчик - многие компании хотят подключения к новой сети и готовы дать денег на развитие. Пока частного сектора не так много, но, возможно, в будущем он займет вполне достойное место рядом с научно-исследовательским. Чего нам, собственно, и надо - это сильно приблизит момент выхода частных лиц (или попросту юзеров) в Интернет-2. А это открывает горизонты для широкой конструктивной (а равно и деструктивной ;)) деятельности.

А мы?

Теперь о грустном. Скорее всего, до рядового пользователя Интернет-2 докатится очень нескоро даже в Европе. Что уж говорить про страну медведей и балалаек? Хотя нет, говорить есть что - в Приморье вовсю идут переговоры с толстосумчатыми буржуями о перспективах подключения НАС к ИХ сети. То есть пустят кабель от Аляски (см. карту), и университеты России потихоньку подсосутся к халявной информационной шине. Может, через пару лет ты будешь рулить луноходом или пытать какие-нибудь бактерии в Америке, не выходя из аудитории? Поживем - увидим...

З.Ы. Если сам проект тебе интересен, не пожалей времени, загляни на официальный сайт www.internet2.edu - там можно разжиться не только инфой, но и демками программ под новую сеть, видеозаписями экспериментов и многим другим. Знание буржуйского required.


Спецвыпуск Xakep, номер #015, стр. 015-117-1, USEnet: хорошо добытое старое

USEnet: хорошо добытое старое

Дик (sosn@chat.ru)

Спецвыпуск Xakep, номер #015, стр. 015-117-1

Привет, хакерюга! Как дела? А был ли ты когда-нибудь в Fido? Если нет, не грусти - я тоже не был :). Просто когда у меня появился модем, в нашей стране уже был Интернет. Он завлекал меня, как наркомана: с утра до ночи только и думал, что об инете. И даже тот факт, что Fido является андеграундом, не возбуждал меня до такой степени, чтобы забить на этот сказочный разноцветный мир тогда еще редких чатов на родном языке и халявных порносайтов :). Ну, в общем, до Fido руки так и не дотянулись, тем более, что сейчас доступ к этой сети можно получить и через инет. А к чему я все это говорю? К тому, что настало время поговорить о USEnet, так как эта сеть - одно из первых средств обмена электронной информацией, дожившее до наших дней.

Откуда оно взялось?

Как появился USEnet? Обычно на вопросы подобного рода ответы находить очень трудно, но на этот вопрос ответ есть однозначный! В 1979 году два американских (к сожалению) студента решили использовать UUCP для обмена информацией между пользователями систем UNIX. Первой официальной реализацией программного обеспечения для обмена электронными новостями был пакет "A NEWS". Этот пакет мог обрабатывать не более нескольких статей в день. Очевидно, что этого было мало, и поэтому люди продолжали трудиться. В 1982 году появилась версия 2.1 пакета "B NEWS", а в 1987 году появился пакет "C NEWS", который был еще более усовершенствован. Основной характерной чертой всех этих пакетов было то, что они использовали для передачи данных сетевые каналы UUCP. Знаешь такие? Наверное, знаешь, но, я думаю, будет нелишне напомнить, что это телефонное соединение. Похоже на Fido, не правда ли? :) В 1986 году в качестве дополнительной возможности появился протокол NNTP, позволяющий передавать новости через сети TCP/IP. Благодаря этому факту мы и поныне можем пользоваться услугами этого сервиса.

Как оно работает?

Как это выглядит и зачем вообще этим пользоваться, если ты и так крут? Услугами USEnet в наши годы можно пользоваться при помощи такой популярной программы, как, например, "Аутлук" - конечно, если ты юзаешь тот самый злополучный мастдай. Заходим в Сервис/Учетные записи/Добавить/новости, вводим свой ник, мэйл и адрес сервера новостей. Серверы новостей имеют иерархическую структуру с различными полномочиями. Самый простой способ подключиться к USEnet - это использовать сервер провайдера, который взаимодействует с остальными серверами, получая от них новости и пересылая им новости, опубликованные локальными пользователями. Естественно, что это возможно в силу того, что провайдер наделен соответствующими полномочиями и каналами передачи данных. Кстати говоря, можно использовать сервер новостей почти любого провайдера, но в режиме только для чтения. Также можно использовать публичные серверы новостей, такие как, например, oak.rt.ru. Этот сервер позволяет читать несколько тысяч групп и даже писать во многие из них.

Немного о корнях

Новости сами по себе тоже имеют иерархическую структуру, визуально напоминающую систему DNS, о которой ты, наверное, не раз уже слышал. Но, в отличие от DNS, в которой рост идет от корня справа налево, иерархия новостей растет слева направо. То есть в первом случае имеем что-то.ru, а во втором - ru.что-то. Единицей такой иерархии является группа, которая может содержать подгруппы.

Зачем это?

Теперь поговорим, зачем нам нужно использовать эту систему. По существу USEnet - это всего лишь один из способов обмена информацией, и у него нет каких-либо особых преимуществ по сравнению, например, с обычным html-форумом. За исключением следующих =). Во-первых, список всех существующих групп доступен любому пользователю крупного сервера новостей, то есть в сочетании с ассоциативностью названий групп поиск нужной информации занимает минимальное количество времени. А во-вторых, так уж повелось с давних пор, что в USEnet информация наиболее достоверна. То есть если ты опубликовал вопрос и тебе на него ответили, то, скорее всего, отвечал не ламер, а человек знающий. Почему можно придти к такому выводу? Лично я не знаю в реальной жизни среди простых смертных никого, кто читает новости и уж тем более пишет. Но, несмотря на это, их все равно кто-то читает и пишет. Кто? Ответ очевиден :). Если посмотреть в файл readme какой-нибудь более-менее серьезной программы, то очень часто там можно найти название группы, в которой создатели отвечают на вопросы по функционированию их программного продукта. Но не стоит думать, что USEnet рассчитан только на людей, интересующихся софтом и программированием в целом. Существует огромное количество самых разнообразных групп, среди которых много и развлекательных, и познавательных, и любых, которые только можно придумать. Например, есть очень смешная группа, которая называется fido7.ru.sex.win95 . Как ты думаешь, что там обсуждают? Там обсуждают, как заниматься нетрадиционным сексом с операционной системой :). Причем обсуждение идет очень активно, и темы попадаются самые нетривиальные, например, вот такая тема: FAQ по "спорным" автозагружаемым программам Windows 9x ("удалять или нет?"). В USEnet любой может найти для себя развлечение в текстовом формате :). Любители современной литературы могут зайти вот сюда: fido7.ru.pelevin, и опять же увидеть весьма интересные темы. Наверное, сейчас ты думаешь: "Если USEnet такая крутая штука, почему я раньше ничего про это не слышал? Может, это и не круто вовсе?". Чтобы быстро проверить все вышесказанное, можно зайти, например, на сайт www.newsgate.ru. Здесь можно в html-формате читать новости более чем из 30 тысяч групп. Здесь есть рубрикатор и поиск по названию. Кстати о названиях, еще раз напомню про ассоциативность названий групп. Если ты хочешь читать новости про linux на русском языке, то тебе просто надо набрать fido7.ru.linux. Если ты хочешь узнать что-нибудь о хаке на русском языке, то опять же все очень просто, fido7.ru.hacker. Удивление вызывает тот факт, что в этой группе можно найти очень много ценной информации. Например, описание вечной телефонной карты. И даже если ты - геймер, все равно USEnet - это то, что тебе нужно. Потому что именно здесь валом самой разной информации по играм. В fido7.ru.game ты можешь найти кучу единомышленников - таких же крутых геймеров, как и ты. И это не единственная группа!


Спецвыпуск Xakep, номер #015, стр. 015-117-2, USEnet: хорошо добытое старое

USEnet: хорошо добытое старое

Дик (sosn@chat.ru)

Спецвыпуск Xakep, номер #015, стр. 015-117-2

USEnet уголовная

Я думаю, тебе теперь очевидно, что USEnet - это хранилище огромного количества самой разнообразной информации. А информация, как известно, бывает разного рода, в том числе USEnet содержит и незаконную информацию: от подробного описания всевозможных хаков (что очень хорошо, несмотря на незаконность) и до детской порнографии (что очень плохо). Причем меры по борьбе с последним явлением принимаются самые радикальные - в отличие от WWW. Во Франции два поставщика интернет-услуг решили отключить доступ ко всем телеконференциям USEnet, поскольку французская прокуратура пригрозила арестом директоров, несущих персональную ответственность за нарушение национальных законов Франции о детской порнографии. Также сеть USEnet активно используется различными сектами и прочими подобными организациями для вербовки людей и координации действий. И, конечно, в этой сети много спамеров, ну, оно и понятно :). Но в целом все это характеризует USEnet как мощное и эффективное средство для информационного обмена.


Спецвыпуск Xakep, номер #015, стр. 015-117-3, USEnet: хорошо добытое старое

USEnet: хорошо добытое старое

Дик (sosn@chat.ru)

Спецвыпуск Xakep, номер #015, стр. 015-117-3

Качать - не перекачать

Ты, наверное, уже подумываешь о том, есть ли возможность каким-нибудь хитрым образом получать выгоду от использования USEnet. Конечно, есть! И я тебе об этом сейчас расскажу. Есть такая прога "Newsbin Pro", которая помогает вычленить из огромной кучи именно ту информацию, которая тебе нужна. В частности, ты можешь сканировать группы на наличие в них каких-либо файлов - картинок, mp3'шников, avi'шников и всего такого. Скачать эту чудо-программку можно на официальном сайте www.newsbin.com. Весит она немного, инсталлится быстро, правда, триальная версия, но скачать все равно стоит. Этот ньюсграббер поддерживает возможность довольно тонкой настройки его работы, но нам для начала сгодятся и дефолтовые настройки. Единственное, что нам надо сделать для того чтобы начать работать - это указать адрес сервера новостей и выбрать группы, в которых будет происходить поиск. Причем прога знает основные интересы пользователей, и если ты хочешь поискать mp3-файлы, тебе просто надо поставить соответствующую галочку и нажать кнопку "GO". Прога сканит группы на наличие сообщений с вложениями файлов, составляет список этих файлов и потом начинает их скачивать. Если поставить прогу на ночь, то с утра можно сильно удивиться тому, как много интересного появилось на твоем винте. "Newsbin" - не единственное средство для достижения вышеозначенной цели. Альтернативой ей может служить программа "SBNews", которую также можно скачать с официального сайта www.newsrobot.com. Громадный плюс этого пакета в том, что он фильтрует и банит спамеров грамотно и навечно, записывая их адреса и хосты. Непосредственная работа с программой не вызывает затруднений, все то же самое: указываем адрес сервера новостей, папку, в которой будут храниться скачанные файлы, и потом выбираем нужную группу и нажимаем кнопку Connect. Процесс пошел. Если ты качаешь картинки, то их превьюхи автоматически отображаются в нижнем левом углу. Кстати, в отличие от первой программы, в "SBNews" не предусмотрены предпочтения пользователей, и по умолчанию скачиваются все приаттаченные файлы, но в подменю "Configure" ты можешь внести маски имен для файлов. Также приятно то, что с помощью этой проги можно искать не только файлы, но и сообщения с определенными словами. Вводишь что-нибудь типа «взлом icq» и наблюдаешь за тем, как прога старательно ищет введенный текст. Но и это еще не придел мечтаний! Заходим на www.news-grabber.com и скачиваем прогу "NewsGrabber". Эта программа, помимо обычных возможностей ньюсграббера, позволяет и просто читать сообщения в группах. И еще одним приятным фактом является то, что есть версия "light", которую можно использовать бесплатно и бесконечно долго. Полная же версия этой проги бесплатно может быть запущенна не более 50 раз. Опять же до боли знакомые действия по начальной настройке. И начинаем работать! Все в этой проге круто за исключением одного: она иностранная. И хотя через нее можно читать новости, она не поддерживает кодировок. Чтобы прочитать сообщение, его надо предварительно выгрузить на диск, и там, конечно же, все будет в koi8-r. Если нет специального шрифта, то и не прочтешь ничего :). Но как граббер файлов она безупречна, качает хорошо, имеет планировщик задач, регулируется количество одновременно загружаемых файлов, и прямо в нее встроен вьювер. Удобно, практично и абсолютно бесплатно :).


Спецвыпуск Xakep, номер #015, стр. 015-117-4, USEnet: хорошо добытое старое

USEnet: хорошо добытое старое

Дик (sosn@chat.ru)

Спецвыпуск Xakep, номер #015, стр. 015-117-4

Хорош болтать!

Надеюсь, что после прочтения статьи ты сразу ломанешься в сеть и сделаешь то, что должен был сделать давным-давно - а именно узнаешь адрес сервера новостей своего провайдера и приобщишься к сообществу USEnet. Удачи тебе :)!


Спецвыпуск Xakep, номер #015, стр. 015-121-1, Настрой свой мопед

Настрой свой мопед

Спецвыпуск Xakep, номер #015, стр. 015-121-1

Матушка Лень (Matushka_LEN`[LoveTech])

Заведи себе терминал

Терминал - это такая веселая программа, которая поможет тебе общаться с твоим модемом. Таких программ, скорее всего, очень много на твоем компе. В Виндах у тебя тусуется Hyper Terminal. Ты найдешь его, нажав на кнопку пуск\программы\стандартные\связь. Другой терминал живет в Norton Commander, а зовут его TeleMax. Еще есть такая старая ДОСовская программа Telex. Словом, терминал найти не проблема. Скорее всего, ты уже познакомился с ним, когда качал к приятелю файлы через модем. Когда твой мопед еще не созвонился с другим модемом, он находится в командном режиме, и ты можешь его конфигурировать. Все, что ты наберешь ему в терминал, он примет за команду.

AT DP 03 (Заставь модем позвонить)

Если ты наберешь в терминале эту команду, твой модем позвонит в 03. DP - dial pulse, то есть в пульсовый режим. Если твоя АТС поддерживает тон, то командой AT DT 03 ты позвонишь вскорую в тоновом режиме. Если в 03 тоже стоит мопед и они сконнектились, то ты уже не сможешь давать команды. В этом режиме данных все, что ты наберешь на своем терминале, модем передаст в линию.

AT S0=1 (Заставь ждать звонка)

Ребята, которые первый раз коннектятся через терминалки, часто спрашивают, как установиться в режим ожидания. Теперь, когда уже тебе позвонят твои друзья из 03, мопед почувствует звонок, сам снимет трубку и предложит соединиться. При этом он возьмет трубу после первого звонка, а если скомандовать: AT S0=2 - то со второго, а AT S0=5 - c пятого.

AT Z (Все испортил? Жми RESET!)

Ты перемудрил с командами, и ничего теперь не работает? Не расстраивайся. Просто скомандуй сбросить все настройки назад, и можно начинать сначала. Еще можно отключить компьютер или модем, при этом все настройки сбросятся, если ты их не сохранил.

AT E1 (Пропали буквы? Включай эхо!)

Если ты кликаешь на клаву, а в терминале пусто, то забыли включить эхо. Чтобы твои команды было видно, нужна AT E1. Если ты хочешь стебануться над своим приятелем, то можешь отключить AT E0. Теперь на его глазах можно переколбасить настройки мопеда. Команды подействуют, но на экране видно их не будет. Будешь набирать вслепую.

AT M0 (Отключи чертов динамик)

Обычно модемы любят громко пищать при соединении, при вызове, перед набором номера. Если тебя бесят эти звуки, просто отключи динамик вообще, и модем заглохнет. Если ты хочешь напугать приятеля, набери для его модема AT M2 и сохрани настройки. Теперь модем будет пищать всегда, даже когда сконнектился и качает данные. Один боец так отучил сестренку лазить по Интернету, через полчаса непрерывного писка у дефачки взрывались мозги.

AT L3 (Сделай погромче)

Ну, конечно, садюга-братец поставил динамик на полную громкость. Если ты хочешь, чтобы модем пищал тихонько, понадобится AT L0.

AT M2 L3 &W (Сохрани настройки)

Этой командой я сохранил в памяти модема настройки пищать всегда и погромче. Специально для сестрички со слабыми нервами. Теперь даже после перезагрузки или выключения модем будет пищать всегда и громко. Если ты решил сохранить свои настройки, воткни их в эту команду вместо M2 L3. Теперь твое вредительство не так-то просто исправить. Помни, что не все настройки можно сохранить. Но сестренке повезло: M L сохраняются во всех мопедах.


Спецвыпуск Xakep, номер #015, стр. 015-121-2, Настрой свой мопед

Настрой свой мопед

Спецвыпуск Xakep, номер #015, стр. 015-121-2

AT &F (Все испортил? Вернись к заводским настройкам!)

Если к тебе пришел приятель, начитавшийся СПЕЦА, изуродовал все настройки, сохранил их, не переживай. Это лечится просто. Специально для таких случаев у каждого модема есть набор заводских настроек по умолчанию. Этой командой их всегда можно вернуть назад.

AT &V (Посмотри настройки)

Если ты уже много всего крутил в модеме и сам уже забыл, что менял, эта команда покажет тебе состояние настроек. Там ты сразу увидишь знакомые ключи: S0, L, M, E и другие, с которыми ты уже разобрался.

AT I6 (Узнай, что за левое железо)

У тебя в завинченном, опломбированном компе какой-то левый внутренний мопед, да еще нужно искать к нему дрова. Фирма известна, но непонятно, какая модель, какие драйвера искать. Эта команда точно выдаст тебе название и версию чипсета, на котором собран неизвестный девайс. Теперь не придется все раскручивать и колдовать над микросхемами.

AT \A0 (Повысь скорость на шумной линии)

Любой современный модем снабжен протоколами сжатия и коррекции ошибок. У таких протоколов есть блоки, которыми отсылается инфа. Если в шумной линии потерялся маленький блок, это не сильно скажется на скорости, а если большой - то будет заметно. Чтобы сделать блок минимальным, скомандуй: AT \A0. В чистой линии блоки теряются редко. У каждого блока всегда есть заголовок, который помогает его восстановить. Если блоки маленькие, то таких заголовков много, и они занимают много места. Поэтому если блоки теряются редко, то их делают как можно длиннее командой AT \A3, чтобы экономить место на лишних заголовках. Есть еще команды c ключами \A1 и \A2 - это средние блоки для средних случаев. Попробуй разные и выбери тот, который эффективней.

AT %C3 (Пускай инфа жмется)

Протоколы коррекции и сжатия отключаются командой AT %C0. Попробуй отключить их и сразу увидишь, как упадет скорость прокачки инфы через мопед. Но иногда их забывают включить по умолчанию, и ты должен набрать: AT %C3. Оно подключит все возможные протоколы сжатия и проверки.

AT S91=11 (Покрути уровень сигнала)

Все ключики с буковкой S - это регистры, в них хранятся настройки модема. Этой командой мы записали в 91-й регистр 11. Значит, модем будет пищать в линию с громкостью 11Дб. От этой громкости сильно зависит качество связи. Если сделаешь ее меньше, то будет плохо слышно и полезут шумы. Если сделаешь громче, сигнал будет искажаться. Поэтому можно попробовать записать значения 10, 11, 12, 13. Подбери лучшее, и качество станет круче.

AT S107=50 S108=50 (Пусть набирает номер быстрее)

Если ты упарился ждать, пока твой модем каждый раз отбарабанит 7 цифр номера, покрути 106, 107 и 108 регистры. Мой мопед набирает номер в два раза быстрее потому, что я уменьшил время между цифрами от 1000 до 500 миллисекунд (S108=50). И еще я уменьшил время размыкания линии при наборе от 60 до 50 миллисекунд (S107=50). Будь внимателен! Не у всех модемов можно изменить скорость набора номера, и не всякая АТС потянет такую скорость. Монтеры на АТС могут обидеться на тебя за то, что ты так быстро набираешь номер! Это же не по стандартам!


Спецвыпуск Xakep, номер #015, стр. 015-121-3, Настрой свой мопед

Настрой свой мопед

Спецвыпуск Xakep, номер #015, стр. 015-121-3

AT S111=10 (Если плохо определяет "Занято")

Сигналы "занято" и "свободно" выдает АТС, это длинные и короткие гудки в линию. Если твой модем плохо распознает эти сигналы, то автоматически дозваниваться он будет отвратно. Но тут тоже надо осторожно. Если чувствительность понизить, то модем вообще перестанет слышать гудки. А если повысить, то он будет ложно срабатывать. Словом, надо выбрать лучшее значение.

AT S115=2 (Определитель номера из модема)

На современных модемах с голосовыми функциями есть встроенные определители номера. В моем мопеде такой определитель живет в регистре 115. Если я скомандую: S115=0, определитель отключится. Тогда S115=2 заставит определять номер всех звонящих на мой модем. Определенный номер я увижу в окне терминала.

Вот вкратце и все. Пробуй, экспериментируй, изучай. Отныне твоя связь - в твоих руках =).


Спецвыпуск Xakep, номер #015, стр. 015-123-1, Спец-самец-конкурс

Спец-самец-конкурс

Let us DEMONstrate!

Спецвыпуск Xakep, номер #015, стр. 015-123-1

Ты сделал это! Ты впитал тонны инфы, которая сделает тебя не праздно шатающимся по WWW трутнем, но творцом, активным, деятельным мэном. Мы гордимся тобой! Но если твой заряд позитивной энергии еще не оформился в чистые идеи, СПЕЦ предлагает тебе крутую и благородную цель.

Наверняка ты слышал о демосцене. Это состязание кодеров, способных ваять тексты на асме ради самого процесса кодинга. Они творят невозможное - умещают в ничтожные килобайты кода целые феерии. Это схватка дизигнеров, художников и 3D-моделлеров, которые устраивают пиршества форм и красок. Наконец, это турнир мастеров звуковых электронных композиций, которые демонстрируют потрясающий саунд. К сожалению, не каждый может круто кодить или писать треки и уж тем более собрать свою демогруппу, поэтому демосцена - искусство андеграундное, и доступна избранным. И следовательно, не столь популярна. Это не есть верно! Давай внесем в сей жанр дух новых технологий. СПЕЦ предлагает тебе стать демомейкером. Как? Очень просто! Ведь есть же Flash. Он объединяет в себе и графику, и саунд, и кодинг, и простоту передачи и публикации в Инете. Шаришь в скриптах? Забацай умопомрачительный расчетный эффект! Круто рисуешь? Делай красивую анимацию! Работаешь со звуком? Добавь в ролик саунд!

Итак, СПЕЦ объявляет конкурс. Выбери одну из этих композиций:

1. PPK - "Resurection"

2. Limp Bizkit - "Mission Impossible"

3. Boomfunk MC's - "Freestiler"

4. Bloodhound Gang - "Bat Touch"

Или забабахай что-то свое в том же духе. Представь, какой видеоряд проносится у тебя в мозгу, когда ты слушаешь саундтрек, и реализуй его в графике. Причем ты должен показать чудеса оптимизации, так как твоя демка должна влезать на дискету. Пришли свое творение в течение трех месяцев на адрес: spec@real.xakep.ru с пометкой "КОНКУРС ДЕМОК", и тебя ждут призы:

1. Пишуший сидюк - 1 место

2. 128 метров мозгов - 2 место

3. Оптическая мышка - 3 место

И еще 3 поощрительных приза. Кроме того, мы расскажем всем о тебе и выложим твой фейс и твою работу на нашем сайте. Время пошло!

Удачи!

Содержание


Спецвыпуск Xakep, номер #015, стр. 015-124-1, Мобильный Интернет aka W@P

Мобильный Интернет aka W@P

Спецвыпуск Xakep, номер #015, стр. 015-124-1

MOOF (http://moof.ru ; moof@real.xakep.ru)

Привет, я тебе сразу скажу: я готов поставить памятник тем людям, которые изобрели W@P, без него было бы напряженно читать свежие анекдоты и смотреть прикольные картинки на скучных лекциях. Что это такое? WAP (Wireless Application Protocol или Wireless Access Protocol) - это протокол беспроводных приложений или, проще говоря, та фича, благодаря которой мобильные устройства могут получать доступ к Интернету. В качестве такого мобильного устройства чаще всего используется мобильник :).

Немного истории

В девяностых годах прошлого тысячелетия людям надоело использовать сотик только для разговоров, им захотелось большего. Сперва появились SMS, а вслед за ними и WAP. Он был разработан по инициативе компании Phone.com специально для мобильных устройств. Новый протокол был рассчитан на эффективное сжатие информации и низкую скорость передачи данных. Также был создан специальный язык WML, с помощью которого появилась возможность создавать некие подобия html сайтов в Интернете.

Получить доступ в Интернет по WAP'у можно тремя способами. В самом начале для этого использовались обычные SMS сообщения. Пользователь посылал запрос в виде SMS, и WAP-страничка приходила ему в ответ тоже в виде SMS. Затем появилась возможность устанавливать коммутируемые соединения, то есть телефоны получили от производителей модемы и научились связываться с провайдерами напрямую, минуя SMS шлюз. На данный момент это наиболее распространенный в России способ доступа в WAP. Однако прогресс не стоит на месте, и все большее распространение получает так называемая пакетная передача данных (GPRS - General Packet Radio Service).

Кроме этого, существуют четыре версии WAP'a. Первую версию WAP 1.0 поддерживал телефон Siemens S25. Когда-то это был один из самых продвинутых телефонов с WAP'ом. Сейчас же он не имеет практически никакого смысла, так как все операторы сотовой связи поддерживают WAP версии 1.1 или выше. WAP 1.1 является на данный момент наиболее популярным стандартом, но его постепенно вытесняет WAP 1.2, который поддерживает шифрование (защищенное соединение) для совершения безопасных банковских операций прямо с мобильника. Вот оно, поле для хакерства :). Но и этот стандарт, видимо, долго не задержится. Уже в этом году увидит свет финальная версия WAP 2.0.

Как попасть в сеть?

Для начала надо купить сотовый телефон с поддержкой WAP :). Затем надо подключиться к сотовому провайдеру, который предоставляет услуги мобильного Интернета (NWGSM, MTS, Beeline и так далее). После настройки всех параметров соединения можно будет смело выходить в сеть. Мобильный Интернет ты увидишь через окно WAP-браузера - это обычная программа для обмена информацией и отображения ее на дисплее твоего телефона (типа как Internet Explorer).

Как сделать WML-пагу

WML (Wireless Mark-up Language) - беспроводной гипертекстовый язык. Специальный язык для создания страничек, которые можно будет посмотреть на мобильнике. Если ты знаком с HTML, то разобраться с WML тебе не составит труда. Кроме текстовой информации существует и возможность вставлять простейшую графику.


Спецвыпуск Xakep, номер #015, стр. 015-124-2, Мобильный Интернет aka W@P

Мобильный Интернет aka W@P

Спецвыпуск Xakep, номер #015, стр. 015-124-2

Страницы (или по-другому деки), написанные на языке WML, разбиваются на несколько блоков. Эти блоки называются карточками. Получается, что один файл (дека) может содержать несколько страничек (карточек), которые могут отображаться на экране мобильника, - и, загрузив всего один файл, можно посмотреть сразу несколько страничек.

WML страницу ты не сможешь создать во FrontPage'e и посмотреть в Explorer'e. Однако существуют визуальные WML редакторы, благодаря которым можно сделать свой собственный WAP сайт и не зная WML. Первый редактор DotWAP 2 можно скачать по адресу http://www.inetis.com/. Редактор обладает интуитивно понятным интерфейсом, и пользоваться им очень легко. Достаточно написать справа нужный текст и нажать "сохранить" - и ты получишь свою первую WML страничку. Для создания более сложных страничек в левой колонке есть дерево элементов. Ну, в общем, я думаю, ты разберешься с этим :).

Еще одна программка, которая будет тебе полезна, - это WAPtor версии 3. Ее можно скачать по адресу http://www.waptop.net/. Тут тебе придется работать с WML текстом не в визуальном режиме. Однако это не так сложно, как может показаться. Нажимаешь нужные кнопки, и WML теги вставляются, тебе останется лишь вписать текст и все. Вот, например, простейшая WML-страничка, состоящая из двух карт:

<?xml version="1.0"?>

<!DOCTYPE WML PUBLIC "-//WAPFORUM//DTD WML 1.1//EN" "http://www.wapforum.org/DTD/wml_1.1.xml">

<wml>

<card id="MainCard" title="XAKEP WAP">

<p>Welcome to XAKEP WAP PAGE<br/><br/>

<a href="#Card">Next</a></p>

</card>

<card id="Card" title="This is a second card">

<p>Second page<br/><br/>

<a href="#MainCard">Back</a></p>

</card>

</wml>

Сохрани страничку в файле с именем index.wml.

Мобильные картинки

Вроде со страничками разобрались, теперь стоит пару слов сказать про картинки. Картинки в мобильном мире, как ты понимаешь, маленькие и двухцветные. Я думаю, ты поймешь - почему, если хоть раз видел экран сотового телефона. Так вот, картинки для WAP'а имеют специальный формат: WBMP. Обычно используемые в Интернете форматы (jpeg, gif, png и т.д.) не подходят.

Ясен пень, что картинки надо как-то создавать. Для того чтобы получить WBMP картинку, надо нарисовать ее сначала в любом формате (например, в bmp) и с помощью программы ALL2WBMP конвертировать ее в формат WBMP. ALL2WBMP можно скачать тут: http://tucows.enta.net/files6/all2wbmp.zip. Если ты посмотришь на скрин, то увидишь, что интерфейс программы не отличается особенной сложностью. Все что надо сделать - это добавить в список файлы, требующие конвертации, и нажать "Go". Тут главное не переборщить с размером картинки, а то она не поместится на экране сотика :).

WAP браузеры

Теперь у нас есть страничка. Появилась проблема: как нам ее посмотреть на компе, не имея мобильника с таким крутым доступом =). Для просмотра WML файлов были придуманы эмуляторы телефонов или WAP-браузеры. Они делятся на две категории: on-line и off-line.


Спецвыпуск Xakep, номер #015, стр. 015-124-3, Мобильный Интернет aka W@P

Мобильный Интернет aka W@P

Спецвыпуск Xakep, номер #015, стр. 015-124-3

Off-line браузеры - это программы, которые ты устанавливаешь на свой комп и затем с их помощью лазаешь по WAP сайтам. Одним из лучших off-line браузеров является браузер M3Gate (http://www.numeric.ru/www_m3gate_com/m3gate/). Он, кстати, создан нашими людьми. M3Gate поддерживает скины, так что у тебя есть возможность каждый раз смотреть на странички с разных телефонов :).

On-line браузеры тебе не придется устанавливать на компьютер, они умеют работать прямо в окне обычного html браузера (например, IE). Все что тебе надо сделать для просмотра WAP сайта - это ввести адрес и нажать на кнопочку "перейти" :). Вот два адреса, на которых ты сможешь найти приличные эмуляторы WAP'a: http://www.mobilewap.com/ и http://www.dynamic-design.com.ua/mobile/wap.phtml?t=emul.

Куда деть пагу?

Ну вот, теперь твой собственный WAP сайт готов полностью, ты его посмотрел в эмуляторах, и пора разместить его в Интернете. В принципе для размещения сайта подойдет любой хостинг, поддерживающий файлы конфигурации .htaccess (например, http://hut.ru). То есть после регистрации ты должен в корневой каталог скопировать файл с именем .htaccess и содержащий следующее:

DirectoryIndex index.wml

AddType text/vnd.wap.wml wml

AddType image/vnd.wap.wbmp wbmp

Эти команды дадут понять серверу, что твои файлы предназначены для просмотра в WAP браузере. Теперь можешь заливать туда свой index.wml и любоваться им через эмулятор или прямо со своего сотика. Заливка WML файлов на сайт происходит любой ftp прогой и ничем не отличается от размещения обычного html сайта.

Естественно, что можно и не извращаться так с настройками сервера, ведь существуют специальные хостинги и для WAP сайтов. Наиболее продвинутый - http://www.wapdrive.com/. Процедура регистрации и размещения сайтов стандартная, как и везде.

Че теперь делать?

Теперь можно найти в Интернете самоучитель языка WML и научиться делать странички в блокноте :). А если серьезно, то пагу надо раскрутить, для этого существуют каталоги WAP сайтов. Там можно разместить информацию о своем творении в надежде, что это кого-то заинтересует. Кроме этого, можно просто меняться ссылками с другими WAP сайтами.

Вот, собственно, и все, что тебе надо знать о WAP'е на первых порах, а чтобы ты не скучал, держи парочку прикольных ссылок: http://sexwaps.com/wap/ и http://wap.skol.ch/pics.wml#choix . Детям до 16 сами знаете чего :).

Полезные ссылки на ресурсы, посвященные WAP'у:

http://www.wapgate.ru/

http://wap.z-y-g-o.com/

http://www.anywhereyougo.com/

http://www.wapjag.com/

http://www.wapdesign.co.uk/

http://www.wapforum.org/

http://www.iec.org/online/tutorials/wap/

http://wap.wirelessgames.com/

Полезные WAP сайты:

http://wap.aport.ru/

http://wap.yandex.ru/

http://wap.nwgsm.ru/

http://wap.mts.ru/

http://wap.beeline.ru/

http://wap.gala.net/

http://interweb.spb.ru/wap

http://wappy.to/cgames