Спецвыпуск Xakep, Содержание номера # 014

Cover 014 |
Статья | Стр.
Пришпорим или забомбим? | 004
Сетевые прелести | 008
Приватная зона для хакерского веб-проекта | 013
VMWARE. Клонируем компы | 015
Оргазм Робокопа | 018
Снимаем девочек на IRC | 020
ROL на халяву? Едем дальше! | 025
Признание в любви | 030
Хорош просиживать штаны, или даешь экстрим! | 032
Вступай в профсоюз | 036
Защити свою собственность | 040
История операционных систем | 042
20 советов по созданию настоящего Х-кода | 048
Откуда взялся Интернет | 051
Трансгрессивный киберпанк | 054
Камасутра для Виндовз | 058
Защити свою win2k | 060
Апач собственными руками | 065
Всем на пол – это захват! | 072
ЦРУ, ФБР, рояль в подъезде | 087
Джентльменский набор | 090
Варезный свежак – Windows XP | 094
Шары в Х-стиле | 098
Кто ходит в гости? | 100
Электронная кровь в кремниевых венах | 103
NMAP – сканер для конкретных пацанов | 108
Лучшие шаровары за год | 110
АОН мой – враг мой! | 117
Оборонный комплекс PGP | 119


Спецвыпуск Xakep, номер #014, стр. 014-004-1, Пришпорим или забомбим

Пришпорим или забомбим

Спецвыпуск Xakep, номер #014, стр. 014-004-1

Шпаргалки - тема, которая волнует любого студента на протяжении периода "вгрызания" в гранит науки. Научно-технический прогресс позволяет сегодня свести подготовку к экзаменам для некоторых студентов лишь к покупке и эксплуатации пейджера, сотового телефона или диктофона. Можно запросто надиктовать себе на пейджер несколько билетов или посадить в соседней аудитории доверенного перца, который будет в реальном времени снабжать тебя нужной инфой. Расходы на оплату счетов и гарнитуру скрытого ношения придется занести на свой счет.

Но самая широко используемая техника списывания заключается в заблаговременном написании собственно шпаргалок (небольших по размеру листочков бумаги, где мелким почерком отражена необходимая на экзамене информация) в их классическом исполнении.

Подготовить такую шпору не составит труда, особенно если имеется возможность воспользоваться ксероксом и просто уменьшить до приемлемых размеров курс лекций или учебник. Дальше все зависит от личного везения и склонности экзаменатора к отъему шпор на экзамене.

Некоторые студенты идут менее тривиальными путями, используя, кроме технических новинок (таких как сотовые телефоны, пейджеры, радиостанции, диктофоны и т.п.), и собственную смекалку. Лично я знаю человека, который уже на протяжении многих сессий "заболевает" хроническим насморком и активно пользуется носовыми платками, исправно служащими ему в качестве носителей информации. Пока он эти платки разворачивает да сморкается - успевает прочесть все, что ему нужно.

Другой знакомый, сидя на вступительном сочинении, кушал много шоколада. Это не возбранялось, шоколад, вроде бы, даже способствует активизации работы мозга, что само по себе уже неплохо. Кроме этого, на фольгу от шоколадок иголочкой были нанесены цитаты, удачные пассажи, даже некоторые сведения из грамматики русского языка, которыми абитуриент успешно воспользовался, не привлекая внимания экзаменационной комиссии.

Бумага - наиболее юзаемый носитель сдуваемой инфы, поэтому с нее и начнем.

Гармошка

Гармошка - самый пролетарский вид шпоры. Просто и незатейливо. Нарезай листы полосами одинаковой ширины, склеивай их скотчем и заливай на них лекции или ответы по билетам. Далее занимайся укладкой, т.е. через равные промежутки делай сгиб в одну сторону, затем - в другую и так до конца. Какие засады может устроить тебе гармошка?

1. Длина сегмента должна быть ненамного больше ширины ленты, иначе твою шпору ждут дикие расколбасы в процессе употребления. 2. Толщина сложенной гармошки и длина исходной ленты обратно пропорциональны. (О! Типа, закон.) Допустим, ты сделал тонкую, но очень длинную ленту, тогда твоя гармонь будет офигенной толщины, а отдельные сегменты будут слишком децельные. Ты не сможешь нормально разместить инфу и затрахаешься перебирать странички в процессе поиска. Сделал ленту слишком широкой - не сможешь нормально спрятать шпору. Сделал шпорку короткой - наплодишь отдельных гармошек и потеряешься в них. Так что выбирай середину-голд.

3. Заносить инфу на гармошку надо по кругу, т.е. дойдя до конца одной стороны, переверни ленту не поперек, а вдоль, иначе будешь потом лихорадочно искать, "...где же конец этого долбанного вопроса?!".


Спецвыпуск Xakep, номер #014, стр. 014-004-2, Пришпорим или забомбим

Пришпорим или забомбим

Спецвыпуск Xakep, номер #014, стр. 014-004-2

Гармошка может быть вертикальная (складывание происходит сверху вниз) и горизонтальная (складывание происходит слева направо).

Колода карт

Название говорит само за себя: это стопка карточек одинакового размера (с ладонь) из плотной бумаги. Под плотной бумагой не надо понимать картон. А то напихаешь так макулатуры в карман, и препод подумает, что ты чертовски рад его видеть. :) На карточки заносится материал, причем на один листок загоняется один билет или 1-2 вопроса. Карточки разложи по порядку и запихни стопку в карман. Теперь ежедневно тренируйся играть в карманный футбол, баскетбол и другие азартные игры, ибо ты должен без напряга на ощупь отсчитывать нужный номер. Дело в том, что в другом кармане у тебя лежит "путеводитель по шпаргалке". На этой феньке забито, какие вопросы на какой по счету карточке. Получаешь билет, достаешь путеводитель, находишь нужный номер, отсчитываешь нужную карту, достаешь и сдуваешь. Все, ты в шоколаде. Плюсы: шпора легко прячется под что угодно, потому что плоская. Профессору можно продемонстрировать пустые ручки (фокусник!). Не надо доставать всю кипу разом. На карточку легко заносить графики и таблицы. Минус: нужно овладеть навыком.

Кручу-верчу

Уже в студенческие годы нам доводилось пользоваться шпаргалками собственного изготовления, хотя идея была подсказана одним более искушенным в этом нелегком деле знакомым. Технически это осуществляется так: берешь 2-3 обычных двойных тетрадных листа в клеточку и нарезаешь их полосками, шириной 2-3 сантиметра. Затем склеиваешь из этих полосок ленту длиной не менее метра (вообще, размеры могут варьироваться в зависимости от личных предпочтений).

Затем нужно подготовить два обрезка от карандаша круглого сечения (вообще говоря, подойдут два любых обрезка круглых палочек, просто карандаш наиболее удобен). Подготовленную ленту наматываешь довольно плотно на карандашные обрезки (соответственно ширина бумажной ленты должна равняться длине карандашных обрезков). После того как ты намотал ленту на карандаши, у тебя должны получиться два плотных ролика бумаги, каждый диаметром сантиметра три. Прижав ролики один к другому, надеваешь на них подходящего диаметра узкую резинку, можно воспользоваться обычным черным обрезком велосипедной камеры, я же предпочитал прозрачный обрезок презерватива. :) И нечего тут улыбаться!!! Презерватив, он во многих делах незаменим!!!

Итак, если ты все сделал правильно, то у тебя в руках находится некий предмет, состоящий из двух плотных роликов бумажной ленты, скрепленных резинкой. Это отдаленно похоже на ленту аудиокассеты, с той лишь разницей, что ролики плотно прижаты друг к другу резинкой. Теперь попробуй промотать ролик на себя. Это просто и удобно. Как только ты это осознаешь, для тебя не составит никакого труда рассчитать, куда именно нанести текст шпаргалки. На экзамене же остается просто сидеть и совершенно бесшумно и почти незаметно перематывать по мере надобности шпаргалку до нужного места.


Спецвыпуск Xakep, номер #014, стр. 014-004-3, Пришпорим или забомбим

Пришпорим или забомбим

Спецвыпуск Xakep, номер #014, стр. 014-004-3

Окажи давление

Если ты уже сдавал экзамены в своем ВУЗе, то должен знать, какую бумагу тебе там дадут. Бери листок, похожий на экзаменационный по размеру, оттенку и фактуре. Если на листах присутствует какая-то особая маркировка, то постарайся нарыть родные листки на какой-нибудь кафедре. Подложи под этот листок другой бумаги, а сверху еще один лист. На верхний лист вгоняй материал, сильно надавливая на ручку (мельчить не рекомендую). Теперь на нужном куске бумаги появился давленный текст, который хорошо видно, если смотреть на шпору немного под углом. На экзамене незаметно меняй один лист на "заряженный" и юзай инфу.

Раскладываем пасьянсы

Разложить шпоры - треть успеха. Обязательно надевай пиджак, даже если на улице 30 градусов жары. В пиджаке и карманов до кучи, и всякие неприятные выпуклости в штанах он прикроет. Отдельные части шпор разложи по разным карманам и запомни, где какая. За пояс штанов на спину можно спрятать большие листы и даже не особо толстый учебник - пиджак не выдаст. Перчинкам рекомендуется юбка до колен и чулки (только не колготки!). За резинку чулок можно разложить шпоры (с карманами у девчонок - напряг). Едва ли преп решится залезть студентке под юбку. А таскать шпорки у такой подруги сплошное удовольствие. :) Я на экзамене иногда просто не могу сосредоточиться - сплошной стриптиз кругом.

Прячем вещдоки

Хотя бумажные шпоры довольно удобны и надежны, само их наличие на парте или у тебя в руках - суть есть палево, поэтому их надо ловко прятать. Чистим логи, так сказать. Запомни, препод не имеет права тебя обыскивать. Сунул в карман - все ОК. Однако не всегда успеешь, особенно если профессор носится по аудитории как ошпаренный. Карточку можно сунуть под листы (опять же некоторые уроды любят их перетряхивать). А вот гармошку под лист не засунешь, поэтому лучше заранее оборзеть на поле боя (ведь экзаменационная - аудитория известна). Кстати, под жопу прятать и не пытайся - поднимет тебя преп, и трындец! Бери ножик и подходи к стулу. Если стул мягкий, то прими таблетку... А лучше надрежь обивку, так чтобы было не особо заметно. Если стул из фанеры - расщепи ее с таким расчетом, чтобы в щель поместилась твоя шпора. Если стул железный, то ты в кабинете следователя... Тебе придется попортить несколько стульев (ты же не знаешь, где твое место). Также отковыряй заглушки, которые закрывают пустоты в арматуре парты. Вот в эти места в случае чего и можно заныкать шпору. Ну уж если совсем труба, то придется съесть бумажку. :)

Помни, не оставляй после себя бомбы и шпоры в партах! Ты можешь запросто подставить своих одногруппников в случае, если преподу вздумается провести соответствующий рейд на предмет списывания. Кстати, о партах. Заранее узнай, в какой аудитории будет экзамен. Посмотри, какие там парты: закрытые или открытые ("лысые"). Если они "лысые", можно сделать маленькую перестановку: перетащить из другой аудитории закрытые парты и сделать вид, что так и было. Требует организованности и аккуратности. Лучше это сделать за день до экзамена. В свое время, узнав номер аудитории, мы пробирались туда заблаговременно и наносили на светлую поверхность одной из парт критически важную на экзамене информацию. С помощью простого карандашика.


Спецвыпуск Xakep, номер #014, стр. 014-004-4, Пришпорим или забомбим

Пришпорим или забомбим

Спецвыпуск Xakep, номер #014, стр. 014-004-4

Некоторые ушлые студенты, взяв билет на экзамене, через некоторое время делали вид, что им стало плохо (в смысле здоровья) и просились выйти. Выбегая в коридор, нужно найти такого человека из своей группы, который быстро и по теме сможет ответить на вопрос билета. Здесь, кстати, нужно не забыть (от радости, что удалось вырваться из аудитории на свободу) сам вопрос билета. Также, возвращаясь назад, не забудь ответ на вопрос.

Чтобы особенно зверский препод отвлек от вас, находящихся на экзамене, свое неослабевающее внимание, можно попросить кого-нибудь (желательно с другого факультета или из знакомых работников института) вызвать препода под каким-нибудь предлогом из аудитории. Предлог должен быть правдоподобным. Достаточно на несколько секунд отвлечь, и можно доставать "вспомогательные материалы".

Вспомоги мне, вспомоги мне!

Некоторые добрые преподы делают на экзаменах послабления :), а именно, разрешают пользоваться вспомогательным материалом (словари, кодексы, справочные таблицы и т.д.). Как же, поможет тебе этот материал, если ты всю ночь бухал с друганами! Так модернизируй эту справочную ботву. Между строк карандашом (меньше бросается в глаза) мелко вписывай действительно полезную инфу. Хороший тебе совет: не пиши текст прямо на первую или последнюю страницы, отступи страниц 10 с концов, не используй самую середину книжки, т.к. именно в этих местах она откроется в первую очередь, если препод вздумает ее пролистать. После занесения посторонних надписей положи книжку под пресс (можно под кузнечный), чтобы она не открылась в руках у профессора именно там, где не надо. Уясни, любая надпись в книжке, и ты получишь жирного гуся aka пару, даже если ты использовал крипто нанайских мальчиков, и препод ни фига не понял.

Хохломская роспись

Если, перец, (о, чудо!) вам разрешают оставлять на парте в дополнение к стандартным листку и ручке еще и калькуляторы, ластики, карандаши, линейки, пеналы, то ты просто обязан приобщиться к искусству росписи этих предметов. На карандаш или линейку запросто вмещается вся тригонометрия. Для ленивых в продаже есть даже расписанные заводским методом справочные линейки. Есть одно но: я тебе советую не писать, а выцарапывать нужную инфу на линейке, т.к. это меньше бросается в глаза. Заодно освоишь профессию ювелира. В футляре калькулятора отлично маскируются бумажные шпоры, а заднюю его стенку можно исцарапать нужными формулками. Ничего страшного, потом купишь другой. Пенал, особенно мягкий, непременно нужно обезобразить нужной инфой. Только не пиши снаружи, а то препод не оценит.

Ручка - твой боевой конь

Ручка присутствует на экзамене всегда. Глупо не использовать сей факт. Затроянь ручку! Ручка должна быть довольно толстая, непрозрачная и без всяких там пружинок, с тонким стержнем. В корпусе ручки прорежь м-м-м... щель длиной сантиметров 5. Сверху проковыряй отверстие. Далее подготовь бумажную ленту и занеси на нее материал. Приклей край ленты к стержню так, чтобы при втыкании его на место лента оказалась точно на уровне прорези. Сильно помучавшись (а кто сказал, что будет легко?), выцепи край ленты из щелки. Приклей к нему планку, которая не даст ленте выскочить из прорези совсем. В отверстие вставляй шуруп и вкручивай его в стержень почти по самые помидоры. Вуаля! За кончик шпорку можно вытянуть, а шурупчиком - вкрутить обратно. Если препод пристанет, скажи, что ручка заводная, мол, заводишь ты ее так. :)


Спецвыпуск Xakep, номер #014, стр. 014-004-5, Пришпорим или забомбим

Пришпорим или забомбим

Спецвыпуск Xakep, номер #014, стр. 014-004-5

Кстати, посредством шарикового перышка можно кинуть шикарную падлу зазевавшемуся закадычному врагу. Стянул ручку, вывинтил стержень, быстро срезал полсантиметра и засунул обратно. Если этот ламер ушастый не носит запаску, то шоу обеспечено.

Бомбермен

Надеюсь, что ты не из числа клинических идиотов, которые звонят в милицию и сообщают, что Alma Mater вот-вот взлетит на воздух. Это бессмысленно и глупо, к тому же уголовно наказуемо. Так что пользуйтесь другой "бомбой", хоть это и более трудоемкий процесс.

Суть заключается в заблаговременном написании развернутых ответов на вопросы всех экзаменационных билетов. Важно написать все так, как будто ты неплохо подготовился дома и сумел воспроизвести свои знания в нервозной обстановке экзамена. Если у тебя есть достаточно экзаменационных листков, ты точно знаешь содержание билетов и твоя ловкость сравнима с искусством фокусника, делай "бомбы". Нет, ядреные фугасы тут не при чем. Бомба - это заранее написанная работа, которой в ходе экзамена подменяются экзаменационные листы. Сидишь на экзамене, пишешь галиматью, а перед концом экзамена меняешь листки и сдаешь работу. Сложности такие: сделать бомбы нужно очень похожими на нормально написанную работу, в пиджаке нужно разместить от 30 до 50 работ, а также ты должен убедить препода, что он не видит, как ты тасуешь листы формата А4.

Некоторые преподаватели имеют достаточно опасную склонность просматривать написанное на экзамене, так что излишне каллиграфический почерк и отсутствие сокращений может вызвать ненужные подозрения и за ними ряд дополнительных вопросов. Постарайтесь найти компромисс между полнотой отражения информации в "бомбе" и возможной подозрительностью преподавателя.

Использовать "бомбу" очень просто. Берешь билет, садишься готовиться и вместе с этим вспоминаешь, в каком кармане или носке лежит нужный экземпляр "бомбы". Минут через 10-15 просто достаешь домашнюю заготовку и делаешь вид, что только что "вымучил" изложенную на листке информацию. Все. Как минимум, "удовлетворительно" в зачетке.

Да, вариант с "бомбой" хорош еще и тем, что, сдав экзамен и выйдя из аудитории, ты (если не жлоб) можешь передать любовно подготовленные дома "бомбы" товарищу. Просто так, безвозмездно. Глядишь, потом пригодится! Вообще, студенческая взаимовыручка - явление внеклассовое, но это уже другая тема...


Спецвыпуск Xakep, номер #014, стр. 014-004-6, Пришпорим или забомбим

Пришпорим или забомбим

Спецвыпуск Xakep, номер #014, стр. 014-004-6

Наглеем

Метод отлично зарекомендовал себя, особенно во время написания словарных диктантов на иностранных языках. Ты берешь свою рабочую тетрадь или рабочий словарь, желательно потолще, листов, эдак, 50-90. На заднюю обложку аккуратно подклеивается бумажка с выписанными словами для диктанта (или вкладываешь оную в целлофановую обложку тетради) и приступаешь к написанию диктанта, имея тетрадь открытой.

Обычно преподаватель с легким укором просит закрыть тетрадь, что ты с легкостью исполняешь. Закрытую тетрадь кладешь непосредственно перед собой и начинаешь нагло списывать. Отлично, если текст шпаргалки написан бледным простым карандашиком так, чтобы он не бросался в глаза никому, кроме тебя. Сидишь себе и потихонечку списываешь... Повторяю, лично меня пока ни разу не ловили на этом! Тьфу, тьфу, тьфу...

Современные методы

Один перец надиктовал шпоры на кассету и пришел на экзамен в плеере. Современные плееры имеют небольшие габариты, укомплектованы мини-пультом на проводе наушника, тихо работают - в общем, вполне подходят. Главное, чтобы кассеты хватило. :) Не забудь поменять батарейки...

Еще немного тактики

Габариты шпоры, размер шрифта, графиков и таблиц должны быть такими, чтобы ты смог читать ее на расстоянии вытянутой руки. Это нужно, чтобы на экзамене препод не наблюдал твою задницу, пока ты ныряешь под стол за знаниями. По возможности делай шпоры в электронном виде и печатай на принтере. Это позволит разделить работу на несколько человек, обменяться на шпоры для другого экзамена, можно сделать шрифт помельче не в ущерб читабельности. Думай, чего заливаешь на шпоры! Если туда попадет непроверенная инфа, грош цена твоей подготовке.

Будущим поколениям... и бабло

Отслужившие свое шпоры в электронном виде выкладывай на свою пагу. Студенты твоего ВУЗа перед сессией будут валить туда валом. Брать с них бабки как-то не по-товарищески. Пусть просто кликнут по баннеру. :)

Бло-врезки

1

Шпаргалки в нашей жизни... Эти слова открывают перед нами широкие и волнующие темы. Попытаемся рассмотреть некоторые аспекты проблемы подготовки и использования шпаргалок на современном этапе, приняв во внимание бесценный опыт предыдущих поколений студенчества. Множество идей позаимствовано из студенческого фольклора многоуважаемого университета МГИМО, который и в этом деле впереди планеты всей. :)

2

Сейчас мы попытаемся рассмотреть некоторые аспекты проблемы подготовки и использования шпаргалок на современном этапе, приняв во внимание бесценный опыт предыдущих поколений студенчества.

3

Бумага - наиболее юзаемый носитель сдуваемой инфы, поэтому с нее и начнем.

Хотя бумажные шпоры довольно удобны и надежны, само их наличие на парте или у тебя в руках - суть есть палево, поэтому их надо ловко прятать. Чистим логи, так сказать.

4

Чтобы особенно зверский препод отвлек от вас, находящихся на экзамене, свое неослабевающее внимание, можно попросить кого-нибудь вызвать препода под каким-нибудь предлогом из аудитории. Предлог должен быть правдоподобным.

Некоторые добрые преподы делают на экзаменах послабления :), а именно: разрешают пользоваться вспомогательным материалом (словари, кодексы, справочные таблицы и т.д.). Как же, поможет тебе этот материал, если ты всю ночь бухал с друганами!


Спецвыпуск Xakep, номер #014, стр. 014-004-7, Пришпорим или забомбим

Пришпорим или забомбим

Спецвыпуск Xakep, номер #014, стр. 014-004-7

5

Габариты шпоры, размер шрифта, графиков и таблиц должны быть такими, чтобы ты смог читать ее на расстоянии вытянутой руки. Это нужно, чтобы на экзамене препод не наблюдал твою задницу, пока ты ныряешь под стол за знаниями.

6

Отслужившие свое шпоры в электронном виде выкладывай на свою пагу. Студенты твоего ВУЗа перед сессией будут валить туда валом.


Спецвыпуск Xakep, номер #014, стр. 014-008-1, Сетевые прелести

Сетевые прелести

Спецвыпуск Xakep, номер #014, стр. 014-008-1

Как построить собственную домашнюю сеть

Horrific (smirnandr@mail.ru)

Я думаю, тебе не нужно объяснять, что групповуха намного прикольнее онанизма. Так вот, до сих пор ты занимался онанизмом. Тихо, сам с собою, левою рукою... сжимал мышку. Пора кончать с этим вредным занятием и познать все прелести групповых гамесов и использования ресурсов сразу нескольких компов.

Да здравствует групповуха!

Для этого именно ты, а не твой ленивый сосед, должен взять на себя всю инициативу и, не стесняясь, обойти все квартиры в доме. Увидел у кого комп - предлагай групповуху :). Если не побьют, то через пару дней у тебя наберется целая толпа единомышленников, с которыми ты начнешь строить коммунизм :). А обойдется он тебе не так дорого и не такими муками, как писали господа Маркс и Энгельс.

Все в сеть

Итак, морально ты готов, и пора заняться делом. Сегодня простейшая домашняя сеть обойдется каждому участнику всего в 30 зеленых.

И за эти 30 баксов ты однозначно получишь: бессонные ночи за Квакой, дешевый iNet, обмен порнокартинками с соседями, конференции и все остальные прелести сетевой жизни. Тебе не придется бежать с дискетой в руке к соседу, чтобы забрать свежий уровень для Quake. Ты просто перекачаешь его по сетке и с этим же соседом вольешься в мир Q-реальности.

С чего же начать?

Для начала тебе нужен компьютер. Если он уже есть, то нужно купить необходимое железо для построения сети. В качестве железа нам понадобится сетевая карта (по-нашему, просто сетевуха), кабель (в народе просто жила или кишка) и некоторые приспособления, которые будут зависеть от типа кабеля. Вот с этим нам и предстоит разобраться, прежде чем приступать к построению и настройке домашней сетки.

У вас есть план мистер Х?

Существует четыре типа сети:

1. Общая шина - это самая простая сетка. В ней кабель протягивают вдоль компьютеров, последовательно соединяя их между собой. В такой сети есть одна маленькая лажа - ее не всегда удобно расширять. Но она легко монтируется, легче только детей делать. А самое главное, она дешевая!

Но есть еще более важная лажа - при значительной нагрузке сеть начинает тормозить. А самый главный косяк - если вылетит хоть один сегмент, то полсетки оказывается в дауне (может и вся). В последнем есть еще и скрытая угроза (Episode 1): раз вылетело полсетки, то трудно найти место, в котором произошел вылет. Поэтому приходится поочередно отключать каждый комп и проверять кабели.

У меня в доме сеть построена именно на "общей шине" и уже три года работает как негр на плантации без единого глюка. В сетке находится 6 компов, и проблем с перегрузкой я не ощущаю. За всю мою сетевую жизнь мне все же пришлось встретиться с проблемой вылета сети. Это было только один раз, и поиск неисправности с ремонтом занял всего 1 час в сети с 35-ю компьютерами. Как видишь, не так страшен черт, как его трезубец в заднице индейца. Вылеты бывают, но очень редко.

2. Кольцо - похоже на общую шину, но концы кабеля соединены. Перекачка больших порнокартинок уже не так сильно влияет на работу всей сетки. А вот при выходе из строя хотя бы одного сегмента вся сеть падает в даун, поэтому поиск неисправности затрудняется, приходится трезвонить всю сеть, а не ее часть. Так же как и в "общей шине", вылеты происходят очень редко, и при прямых руках исправить все очень легко.


Спецвыпуск Xakep, номер #014, стр. 014-008-2, Сетевые прелести

Сетевые прелести

Спецвыпуск Xakep, номер #014, стр. 014-008-2

Наращивать "кольцо" еще сложнее, чем "общую шину". Иногда для добавления одного компьютера приходится коммутировать заново половину кабелей.

3. Звезда - Компьютеры подключены через одну точку. В качестве такой точки часто выступают хабы (HUB) или, по-нашему, "концентраторы". Такая сеть очень легко расширяется и достаточно скоростная, но требует большего вложения зеленых бумажек. Если вылетит один кабель, то отключится только один комп, поэтому поиск и ремонт поврежденного кабеля прост как секс с симпотной девочкой.

4. Рыболовная - капроновая сеть, которой рыбаки ловят рыбу. Ее главный недостаток - абсолютно не подходит к компьютеру. Но есть одно преимущество - можно наловить много рыбы и сварить уху. Хотя динамит намного эффективнее.

Кабель

Теперь давай разберемся с кабелем. Существует три основных типа кабеля:

Коаксиальный кабель (известен также как коаксиал, коакс) - состоит из центрального проводника и внешней экранирующей оплетки. Центральный проводник может быть забодяжен в виде одной толстой кишки или нескольких тонких. Это если говорить научно, а если по-нашему, то это простой телевизионный кабель, только с волновым сопротивлением 50 Ом. Существует два варианта коаксиала - тонкий и толстый.

Максимальная длина сегмента на тонком коаксиале - 185 м. К одному сегменту можно подключить 30 сетевых устройств (компьютеров, репитеров...). Ты можешь соединить в одну сеть пять сегментов по 185 м. В этом случае общая длина сети будет 925 м, но через каждые 185 м (между сегментами) нужно ставить репитер (усилитель или повторитель). Для большей ясности смотри врезку про сегменты сети.

С коаксиальным кабелем я работаю практически каждый день и знаю их до последней молекулы. Максимальную длину 185 м я взял из спецификации, в жизни же эта величина может быть очень различной. Например, на китайских кабелях я не смог построить сеть более 150 метров. Зато на российских у меня уже год работает одна сеть длиной около 250 метров. Точную марку кабеля назвать не могу, потому что я его брал на базаре, но, кажется, он был московский.

Рекламная пауза: Наши кабеля самые кабелистые кабеля в мире! (бабки за рекламу перечисляйте на адрес редакции :))

Когда будешь тянуть коаксиал, будь осторожен, он очень чувствителен к изгибам. Когда нужно согнуть кабель, то старайся это сделать по большому диаметру. Если ты сильно перегнешь жилу, то кабель может потерять свои скоростные свойства или совсем сломаться.

Максимальная длина сегмента на толстом коаксиале - 500 м. В одну сеть ты также можешь соединить 5 сегментов, т.е. общая длина сети будет 2500 м. На одном сегменте может висеть не более 100 устройств.

Вообще-то толстый коаксиал используется очень редко. Его протягивают только когда действительно нужно расстояние больше 185 метров. В домашних условиях этот кабель - излишество, тонкого коакса достаточно.


Спецвыпуск Xakep, номер #014, стр. 014-008-3, Сетевые прелести

Сетевые прелести

Спецвыпуск Xakep, номер #014, стр. 014-008-3

А теперь маленькое отступление на тему "толстый":

Hочь. Жена: Что-то он сегодня у тебя толстый...

Муж: А я его вдвое сложил...

Витая пара (витая, витуха) - это два изолированный медных провода, скрученных между собой. Подобный кабель ты мог видеть в телефонной розетке, только в нашем случае используется 4 пары проводов (восемь проводников). Витая пара делится на экранированную (STP) и неэкранированную (UTP). Если ты собираешься протягивать сеть внутри здания, то тебе достаточно неэкранированной пары. Но если кабель будет выходить на улицу, то тут уже понадобится экран. Здесь есть одно условие, длина кабеля от центральной точки (концентратора) до компьютера не должна превышать 100 метров. Это снова по спецификации, а в жизни у меня 150 работает без соплей.

Оптоволоконный кабель состоит из двух проводов. Эти провода могут передавать данные только в одном направлении. Инфа летит по стеклянному проводу, поэтому этому кабелю электрические поля, как ежу конопля, т.е. по самый пейджер. На этом я остановлюсь, потому что ни один человек в здравом уме не потратит бешенные бабки на волокно, да и протягивание такого кабеля связано с болезнью заднего прохода. Единственное преимущество волокна, так это то, что длина его сегмента измеряется километрами (до 10 км).

Выбор сетевой карточки

С кабелем все понятно, теперь надо решить проблему выбора сетевухи. Однозначным выбором является PCI карта. Про ISA уже можно забыть, в новых матерях нет такого слота, поэтому не стоит брать эту диковину. Если ты все же взял себе ISA-карту (ну завалялся у тебя один разъемчик), то ты нарвешься на неприятности при upgrade компа. Тебе придется менять не только камень и мать, но и сетевую карту.

На сетевухах существуют четыре вида разъемов:

1. Для тонкого коаксиала - BNC

2. Для толстого коаксиала - AUI

3. Для витой пары - RJ 45

4. Для волокна - ST

Если ты строишь домашнюю сеть, то я тебе посоветую брать самые дешевые карты. Везде, где мне приходилось работать, стоят карты RL2000. Их легко можно найти по 20 баксов и меньше, а на рынке такая железка лежит по 10 зеленых. Карты достаточно надежны и имеют на борту BNC и RJ 45 разъемы. Они легко устанавливаются, хотя только Win2000 умеет их определять автоматически. С Win 9х и NT придется пошалить левою ручонкой. И все же я ни разу не встречал проблем с этим железом. RL2000 легко держит 10 МБит/С, а некоторые тянут и 100 Мбит/с (только для витухи).

Если тебе нужны простота и надежность, то тебе придется отвалить 40 зеленых и выше за 3Com. Эти карты более надежны и без особого напряга тянут на витухе 100 Мбит/С. Предупреждаю сразу: не все эти карты имеют на борту BNC и RJ 45 разъемы одновременно. Чаще всего эти звери встречаются только с RJ 45-ой дыркой.

Если тебе достаточно 10 Мбит/с, то твой выбор должен быть дешевым (дома у меня стоит карта фирмы "NoName" серии "NE2000 compatible" и работает как зверь). Но в любом случае желательно взять карту с BNC и RJ 45 разъемами на борту. Сегодня тебе нужен коаксиал, а завтра ты захочешь ускорить сеть до 100 Мбит/С. И если у тебя нет нужного разъема на борту, то придется менять сетевуху. С RL2000 и подобными у тебя таких проблем не будет.


Спецвыпуск Xakep, номер #014, стр. 014-008-4, Сетевые прелести

Сетевые прелести

Спецвыпуск Xakep, номер #014, стр. 014-008-4

Окончательное решение

Для упрощения окончательного выбора я сделал для тебя маленькую врезку "Стандарты Ethernet". В ней ты можешь увидеть название стандарта, тип используемого кабеля, скорость передачи и используемую топологию для построения домашней сетки.

Если у тебя глазки разбежались и ты не можешь выбрать, то я тебе советую остановить свои зенки на стандартах 10Base2 и 10BaseТ, т. е. тонкий коакс и витая пара. Как я уже писал, коаксиал может вызвать проблемы, но он самый дешевый и легко монтируется. При этом тебе обеспечена достаточно хорошая скорость в 10 МБит/С, которой тебе хватит на любую кваку. Витая пара немного дороже (всего лишь на сотню баксов :)), но более надежна и ее легко усилить до 100 МБит/с (прибавив к концентратору и к кабелю еще сотню баксов).

Обрати еще внимание, что для коакса должна использоваться топология "общая шина", а для витухи - "звезда". Это тоже влияет на выбор, потому что в домах достаточно тяжело тянуть "звезду".

Если ты решишь использовать в своем доме витую пару, то я могу посоветовать тебе поставить хабы на центральном этаже каждого подъезда и от них разводить весь подъезд. В этом случае один хаб будет обслуживать один подъезд и располагаться он будет на одинаковом расстоянии от первого и самого верхнего этажа. Это позволит тебе получить максимум скорости и минимум кабеля. Затем последовательно объединяешь хабы и получаешь супердом.

Если ты решил использовать коаксиал, то просто тянешь его по дому, последовательно соединяя компы. В этом случае ты сможешь сэкономить больше кабеля, чем с витухой. Прежде чем начнешь тянуть кабель, его желательно погладить. Для этого кладешь его на очаровательную ножку красивой девочки и начинаешь нежно гладить рукой. Проглаженный кабель лучше тянется и быстрей работает.

Паяльник мне в задний...

Кабель протянул, теперь нужно подключить его к компьютеру. Для этого на кабель нужно надеть специальные разъемы (эта процедура называется обжим), которые ты воткнешь в сетевуху. Конечно же, ты мог сначала замерить точную длину кабеля, потом пойти в фирму и купить там такой кусок вместе с разъемами. Если фирма солидная, то она сама бесплатно присобачит нужные разъемы на кабель. Но это не круто по двум причинам:

1. Когда приходится протаскивать кабель через стену, то надо сверлить дыру. Если кабель уже обжат, то дыра получается большой, чтобы можно было протолкнуть и разъем. А если кабель голый, то его очень легко протолкнуть в маленькую симпатичную щелочку :).

2. И вообще, покупать обжатый кабель - не круто, лучше его сделать самому. Так будет надежней.

Зажимание с коаксиальным

кабелем

Начнем мы с обжима коаксиального кабеля. Для этого нам понадобиться BNC-коннектор, T-коннектор, терминатор, ну и сам кабель.Х

Для начала нужно зачистить конец кабеля, как на рисунке. Это легко делается с помощью обжимного инструмента, который можно купить в любой компьютерной фирме или на рынке. Но такая фишка очень дорого стоит, поэтому можно воспользоваться простым ножиком.


Спецвыпуск Xakep, номер #014, стр. 014-008-5, Сетевые прелести

Сетевые прелести

Спецвыпуск Xakep, номер #014, стр. 014-008-5

После этого нужно установить BNC-коннектор.

Их существует два типа - неразборные и разборные. В любом случае он состоит из трех частей - корпус, наконечник (маленькая и тоненькая фенька) и обжимная гильза (пустой цилиндр). При неразборной конструкции используется все тот же обжимной инструмент. Если его нет, то хорошо подходят прямые руки и плоскогубцы.

Сначала на центральную жилу надевается наконечник и хорошенечко сжимается. Сжимать нужно, пока не произойдет неприятный звук из заднего прохода. Если ты будешь пользоваться плоскогубцами, то можно сначала капнуть в наконечник немного олова. После этого нагреваешь наконечник и вставляешь туда центральную жилу. Такая конструкция будет более надежна и имеет плотный контакт. Но и без этого кабель хорошо обжимается простыми плоскогубцами. Я иногда капаю олово даже при использовании обжимного, хотя это и лишнее, потому что особой разницы не замечал.

Затем нужно набросить на кабель обжимную гильзу. Она будет болтаться, поэтому просто продвинь ее на кабель подальше, чтобы она не мешалась. Далее помещаем кабель в корпус, чтобы наконечник вошел полностью. Иногда эта операция может сопровождаться щелчком, но это уже зависит от коннектора. Запомни, оплетка экрана должна остаться снаружи корпуса. Если она входит внутрь, то подчисть немного побольше. Теперь надень на корпус гильзу, закрывая оплетку экрана, и зажми плоскогубцами до свиста в ушах.

С кабелем покончено. Можно собирать сеть. Вставь Т-коннектор в сетевую плату и надень с одной стороны кабель. Если будет подключаться еще один компьютер, то его кабель ты засандалишь с другой стороны. Если уже некого подключать, то дырку надо замкнуть терминатором (простая заглушка). Запомни, никаких пустых дырок в BNC-коннекторе не должно быть, иначе сеть не будет фурычить.

Один из терминаторов в твоей сети должен быть заземлен. Запомни, "только один" и "должен". Для этого есть специальные терминаторы с цепочкой. К этой цепочке ты и приделаешь заземление. Если ты этого не сделаешь, то при работающей сети нельзя будет касаться BNC-коннектора, иначе тебя шандарахнет током. Меня часто спрашивают: "Можно ли убить коаксиальным кабелем?". Отвечаю: "Можно, если набросить его на шею и хорошенько затянуть". Электрическим разрядом от незаземленной сети убить нельзя, потому что он слишком маленький. Но заземлить все же желательно.

Обжим витой пары

Теперь на очереди витая пара. Если ты решил работать с ней, то эта часть для тебя будет проще в физическом смысле. Это значит, что не надо так сильно напрягаться. Достаточно одного небольшого усилия, и воздух испортится сам по себе :).

На рисунке ты можешь лицезреть самую натуральную витую пару из семейства RJ 45. Для начала просто счищаешь верхний слой изоляции. А дальше, в той последовательности, как ты видишь кабель на рисунке, закладываешь его в разъем и обжимаешь. Для обжима есть специнструмент, который также можно купить на базаре, среди огурцов и помидоров. Такие разъемы нужно вешать с обеих сторон кабеля. Один вставляешь в комп, а другой в хаб.


Спецвыпуск Xakep, номер #014, стр. 014-013-1, Приватная зона для хакерского web-проекта!

Приватная зона для хакерского web-проекта!

Спецвыпуск Xakep, номер #014, стр. 014-013-1

MOOF (moof@xakep.ru) http://moof.da.ru

Я смотрю, ты уже задизайнерил пагу своего Х-клана. Знаешь, что тебе теперь нужно? Освежить дыхание? Без этого также не обойтись, но я о другом: нужно сделать закрытую зону с доступом только для членов твоего мега-клана, чтобы глупые ламосы и злые дяди из ФСБ не разведали твоих революционных планов по взлому сервера НАТО и спасению никарагуанских гиббонов.

тому же, там можно создать конфу "для своих" плюс выкладывать новые релизы хакерского софта (опять же только для своих). Твой любимый Х, как всегда (прямо как Чип и Дейл :), спешит на помощь: уже садимся всей редакцией и рисуем плакаты в поддержку этих самых гиббонов.

Что нам стоит хак устроить?

Для начала тебе потребуется хостинг, на котором есть perl и Apache. Причем должна быть возможность использовать файлы ".htaccess" и ".htpasswd" для настройки Апача. Есть ли эти фишки на хостинге, ты узнаешь, прочитав FAQ или написав письмо админу. Примерами потребного нам хостинга могут быть www.holm.ru и www.virtua-lave.net.

Итак, ты зарегистрировался и получил адрес, типа: http://lamerov.nifiga.net. Молодец, можешь купить себе чупа-чупс. Теперь нужен скрипт, который избавит тебя от ковыряния в документации, написания длинных и непонятных слов в файлах конфигурации. Париться с выбором не стоит: бери "Account Manager LITE 1.05". Бесплатный скрипт, который позволяет делать много всяческих замечательностей для сокрытия каталогов на твоем сервере. О полезностях:

- Можно контролировать процесс регистрации, разрешая или запрещая доступ.

- Удобный веб-интерфейс. Весь процесс администрирования происходит в окне браузера.

- Оповещение по e-mail зарегистрированных пользователей.

- Подстройка скрипта под дизайн.

- Пара приятных фенек.

Скачать скрипт можно отсюда: http://cgi.elitehost.com. Скачанный файл должен называться как-то так: "amlite105NT.zip" или "amlite105U.zip". Распакуй архив к себе на винт. Я не буду тебя грузить всякими скучными исходниками, кто хочет, пусть сам изучает. Мы с тобой лучше внесем нужные изменения в уже готовый, скачанный скрипт.

Edit

Сейчас мы будем редактировать скрипты. Для упрощения процесса рекомендую производить процесс правки скриптов в Perl Builder`e, скрины по работе с которым размещены чуть ниже.

Узнай адрес, где на твоем сервере находится перл. Чаще всего это: "/usr/bin/perl". Теперь проверь, чтобы в файлах "acctman.pl" и "amadmin.pl" первой строчкой был адрес к перлу и перед адресом стояли значки "#!". Если все это объединить, то должно получиться что-то типа:

#!/usr/bin/perl

Подожди закрывать эти файлы - еще рано. Посмотри внимательнее на монитор и ты увидишь строку:

require "/full/directory/path/to/config.pl";

Так вот, удали все лишнее, но помни, что в итоге должно получиться:

require "config.pl";

Все, эти файлы больше редактировать не будем: их можно закрыть.

Теперь открой файл "amform.htm" и пропиши там адрес к своему скрипту. Было:

стало:

http://lamerov.nifiga.net/cgi-bin/acctman.pl" METHOD="POST">


Спецвыпуск Xakep, номер #014, стр. 014-013-2, Приватная зона для хакерского web-проекта!

Приватная зона для хакерского web-проекта!

Спецвыпуск Xakep, номер #014, стр. 014-013-2

Его тоже можешь закрывать, если не хочешь менять дизайн. Я уверен, что тебе захочется это сделать, но как это делать, рассказывать не буду (хе-хе, вот такой я вредный :). Это обычная хтмл страничка, и трудностей тут возникнуть не должно.

Каталоги

Пришло время разобраться с каталогами. Путь к твоему сайту должны были дать тебе при регистрации. Выглядит он приблизительно так:

/home/l/lamerov.nifiga.net/wwwhome/

Если его зажали, посмотри в ЧаВО, иногда там пишут, по какой формуле его вычислять, или узнай у админа.

Теперь смотри в каталог "wwwhome", копируй файл "amform.htm". Его адрес будет выглядеть следующим образом:

http://lamerov.nifiga.net/amform.htm

Это форма, заполняя которую, юзеры будут регистрироваться.

Теперь создай каталог, если его у тебя еще нет, который надо защищать паролями. Например, в каталоге "wwwhome" сделаем папку "protect". Создай пустой файл с именем ".htpasswd" и скопируй его туда. Обрати внимание: имя файла начинается с точки. Здесь сервер будет хранить пароли пользователей.

И еще один файл, который тебе надо будет создать в этом каталоге, - ".htaccess". В нем напиши:

AuthName "Пароль давай!"

AuthType Basic

AuthUserFile "/home/l/lamerov.nifiga.net/wwwhome/protect/.htpasswd"

require valid-user

где "/home/l/lamerov.nifiga.net/wwwhome/protect/.htpasswd" путь к файлу ".htpasswd".

Скопируй в каталог "protect" файлы, которые надо защитить. Это могут быть обычные хтмл странички или другие файлы, которые не должны быть заметны чужому глазу.

Теперь, если ты попробуешь зайти по адресу http://lamerov.nifiga.net/protect/, то увидишь окошко с просьбой ввести пароль.

Но пока что ты не можешь попасть в этот каталог. Ведь файл с паролями ".htpasswd" - пустой.

Конфигурим защиту

Начинается самое сложное. Можешь взять еще пива или сходить на базу :). Открой файл "config.pl" и немного подправь его. Вот что получилось у меня:

$bodyspec = "background=\"\" bgcolor=\"#FFFFFF\" link=\"#0000FF\" vlink=\"#0000FF\" TEXT=\"#000000\"";

$header = "";

$footer = "";

$fontcolor = "#000000";

$orgname = "Account Manager Demo";

Тут я ничего не трогал и тебе не советую. Потом дизайном будешь заниматься.

$orgmail = "moof\@xakep.ru";

Мыло свое написал. Не забудь поставить "\" после твоего имени на сервере, где размещена почта.

$tempdir = ".";

Это путь к временному каталогу. Пусть будет там же, где и скрипты. Точка означает текущий каталог.

$mailprog = "/usr/bin/sendmail";

путь к почтовой программе.

$closing = ".";

Путь к каталогу со служебной информацией. Тоже оставляем вместе со скриптом.

$response_subject = "Application Received";

$htaccess = "1";

Тут пока ничего не трогаем.

$memberinfo = "/home/l/lamerov.nifiga.net/wwwhome/protect";

$memaccess = "/home/l/lamerov.nifiga.net/wwwhome/protect/.htpasswd ";

Здесь надо правильно написать путь к каталогу, который требуется запаролить. В нашем с тобой случае это - "/home/l/lamerov.nifiga.net/wwwhome/protect". Его и написали.

#$LOCK_EX = "2";

Эту строку я вообще удалил.

$passfile = ".";

Пароль админа тоже будет храниться вместе со скриптами.


Спецвыпуск Xakep, номер #014, стр. 014-013-3, Приватная зона для хакерского web-проекта!

Приватная зона для хакерского web-проекта!

Спецвыпуск Xakep, номер #014, стр. 014-013-3

$subject = "ABC Member Info";

$denied_email_subject = "Application Denied";

$approved_email_subject ="Application Approved";

Это тоже не трогаем: окрашено :).

Создай файл "approved.txt". В нем напиши то, что должны получать пользователи по почте, если ты одобрил их регистрацию. Это должен быть обычный текст. И "denied.txt" - в него помещается текст, который предстоит прочитать пользователю, которого ты не удостоил чести регистрации в системе :).

Все что тебе теперь осталось сделать, это скопировать файлы "acctman.pl", "amadmin.pl", "config.pl", "approved.txt" и "denied.txt" в каталог "cgi-bin". И установить атрибуты исполняемых файлов для перловых файлов (те, которые с расширением .pl). Делается это уже знакомой тебе (я надеюсь) по предыдущим выпускам Х командой chmod 755.

К полету готов!

Теперь пришло время запускать скрипт. Открой свой любимый браузер и запусти скрипт "amadmin.pl". Он находится примерно по такому адресу:

http://lamerov.nifiga.net /cgi-bin/amadmin.pl

При первом запуске (т.е. клике по этому URL`у), если ты все сделал правильно, тебе надо будет придумать пароль администратора.

Теперь можно попробовать зарегистрировать первого клиента. Делается это из регистрационной формы http://lamerov.nifiga.net/amform.htm.

Заполнив все поля, нажми на пимпу "Submit my order". Регистрационные данные добавятся в базу. Теперь загружаешь скрипт администрирования, вводится пароль администратора. Вот мы и попали... нет, не на бабки, а в центр управления.

Вверху написано, сколько всего зарегистрированных пользователей (Active Users) и сколько пользователей ждут регистрации (Awaiting Approval). Управлять из этого центра очень просто и удобно. К примеру, чтобы зарегистрировать юзера, нужно нажать на самую верхнюю кнопку "Search". Теперь виден список злобников, которые ждут своей очереди. За тобой решение: регистрировать пользователя или нет. До вынесения вердикта можно посмотреть подробности регистрационных данных "абитуриента" :).

Разреши самому себе зарегистрироваться и лезь второй раз по адресу: http://lamerov.nifiga.net/protect/

Вводим имя пользователя и пароль, которые были выданы после недавней регистрации, и если все сделано правильно, то сервер пустит внутрь, и взору предстанут защищенные файлы.

Вот и все дела. И самое главное: не надо геморроиться, расписывая собственную бодягу, если существует такое элегантное решение, как это.


Спецвыпуск Xakep, номер #014, стр. 014-015-1, VMWARE. Клонируем компы

VMWARE. Клонируем компы

Спецвыпуск Xakep, номер #014, стр. 014-015-1

Делаем из одного компа много разных

Oznob (oznob@mail.ru)

Представь себе такую картину - ты сидишь в Виндузах третьего тысячелетия (2000) и играешь в свою любимую игру (Сапера), а в отдельном окошке у тебя пингвин (Linux) запущен. О как!

ывала ли когда-нибудь с тобой следующая шняга - желание иметь два компа? А тем, у кого два, - три? Правильно мыслишь! Но из-за неимения бабла все наши грандиозные планы по приобретению двух восьмипроцессорных ксеонов и восьми двухпроцессорных атлонов :), грубо говоря, херятся... Кто в этом виноват? Ну конечно же, Билл Гейтс и Моника Левински. Но не стоит опускать руки (и другие части тела), выход есть - можно скоммуниздить комп у соседа! ;)

Чё да как

VMware - это программа, работающая под NT/WIN2k, Linux (возможно, и под другие ОС Unix-типа, поддерживающие эмуляцию линуксовых бинариков), которая позволяет запустить, допустим, под WIN2000: Linux, FreeBSD, MS-DOS, Win3.1, Win95/98, WinNT4.0, ну и саму Win2k :). Круто? Что, не понял? Ну, типа, представь себе такую картину - ты сидишь в Виндузах третьего тысячелетия (2000) и играешь в свою любимую игру (Сапера), а в отдельном окошке у тебя пингвин (Linux) запущен. О как! Вот об этой проге и поговорим.

Для начала я скачал дистрибутив ВМваре'за с www.vmware.com к себе на твердый болт (кстати, это чудо в архиве весит всего пять с половиной метров). Сразу скажу, что для нормальной работы она требует минимум 96 (а реально - 128) метров оперативки, но я решил поэкспериментировать на 64 (не у всех есть 128). Поставил VMware под Win2000 - все пучком, инсталляция прошла гладко. Перезагрузка. Запускаем...

При первом старте прога предлагает сконфигурить твою будущую виртуальную систему. VMware покажет диалог, предлагая запустить визард, ручную настройку конфигурации или уже существующую. Выбираем первое. Тут тебе предлагают выбрать операционную систему, которую ты хочешь запустить как "гостя". Я выбрал

Windows98, т.к. он у меня уже был установлен на соседнем разделе. Далее выбираем Директорию, где будут храниться индивидуальные настройки каждой запускаемой операционной системы. Затем поступает следующее предложение - создать

виртуальный диск или использовать существующий раздел. Выбираем последнее. На следующем окне нам дадут побаловаться переключением радиокнопок - выбираем, на какие разделы может записывать инфу гостевая система. Об этом подробнее смотри ниже, а пока можешь все включить. Далее включаем поддержку CD-ROM'ов и дисководов, обильно засунутых в твой комп. Дальше очень важный пункт - использование сети. Это нужно как для обмена данными между основной и гостевой системами, так и просто постремать народ в локалке. Короче, выбирай то, что второе сверху. Ну вот вроде и все - типа настройки сохранены и загружены, теперь можно все это самое попробовать запустить :). Жми "Пауэр Он" (первая кнопка на тулбаре :). Если ты такой же мазохист, как и я, и у тебя 64 метра, то стоит ожидать, что VMware начнет вопить и жаловаться на жизнь. Смысл того можно описать двумя словами - "Пошел ты... за длинными метрами!". Не отчаивайся, тыкай в Settings, там в Global Preferences, закладка Memory, дальше жми в кнопу Advanced и снимай все галки (в количестве двух штук :). Все круто, запускаем опять - Пауэр, Капитан Пауэр (On).


Спецвыпуск Xakep, номер #014, стр. 014-015-2, VMWARE. Клонируем компы

VMWARE. Клонируем компы

Спецвыпуск Xakep, номер #014, стр. 014-015-2

Вскрытие покажет

VMware опять начнет что-то там нам говорить, но на это мы забьем, кликаем пару раз ОК на возникающих мессагах. Загрузка выглядит примерно так: в ВМваре'зном окошке происходит загрузка твоего компа заново, все по-настоящему, только

логотип Варе'зный и памяти столько, сколько ты в настройках выделил. Если вначале нажать F2, то окажешься в VMware'вском BIOS :), там, как и в обычном, можно выставить время, подключить/отключить разные девайсы, тип загрузки (с диска, с дискетки, с CD-ROM'а и по LAN), поставить пароль и разную другую шнягу :). Если у тебя была мультизагрузка, то в нее ты и попадешь, только выбирай ту систему, которую ты указал в настройках (VMware просто откажется загружать

другую). В моем случае был Win98, ну его я и стал загружать. Главный отстой не заставил меня долго ждать, как только Win98 нарисовал (построчно :) свой десктоп, Ви(а)нд(т)уз стал перебирать все устройства, имеющиеся в наличии, в том числе Шину PCI, BIOS P&P, "CMOS и часы", сопроцессор и т.д. Процесс длился минут пятнадцать, после чего все это перезагрузилось. Винды, в конце концов :), загрузились (640х480х16, никаких намеков на звук и т.д.), но меня волновал другой вопрос: что стало с тем моим '98-ым после всего этого... Потом оказалось, что ничего, кроме разрешения экрана в 98-ом, не изменилось, даже драйвера остались на месте 8)!

ОК, все прекрасно работает; если ты установил поддержку сети, то зайди в настройки и смени имя компа (и если надо - ip). Кстати, заметь, что там же в настройках появилась виртуальная сетевая карта (у меня - AMD PCNET Family Ethernet, а у тебя? :). Теперь у тебя стоит виртуальная машина, на которой можно делать все что угодно, все зависит только от крутости твоего камешка и количества метров :). Заметь, чтобы попасть в виртуальную среду, нужно просто кликнуть на ней, а

чтобы выйти - нажать CTRL+ALT+ESC. А чтобы быстро ребутнуть машину, нажми CTRL+ALT+Ins. Я однажды лажанулся - когда win98 повесился, ну я и нажал CTRL+ALT+Del, пришлось полюбовался на win2k Task Manager ;).

Ну и чё?

Чего? А ничего! Если ты правильно сконфигУрил сеть на виртуальной машине, то в сети появляется новый комп со всеми своими функциями. Как и на обычном компе, можно расшаривать ресурсы, запускать сервисы и все такое. Играть в CounterStrike сам с собой я не пробовал на 64 метрах, но, думаю, что если сунуть еще, эдак метров триста... то это даже запустится (наверное :). Короче, ты, наверное, уже понял, какие возможности открываются перед нами, к примеру: можно выйти в сеть под чужим именем (допустим - с репутацией крутого варезника) и вместо вареза выложить туеву хучу затрояненного вареза, можно сидеть под виндами и делать вид, что ты тут не причем, а в то же время всех по-черному шниффить под Linux'ом и т.д. и т.п.

Эээ... а чё это такое у нас получилось?


Спецвыпуск Xakep, номер #014, стр. 014-015-3, VMWARE. Клонируем компы

VMWARE. Клонируем компы

Спецвыпуск Xakep, номер #014, стр. 014-015-3

Сейчас я расскажу, что у нас получилось после того как мы замутили ВирМашину (о как!). О файловой системе: В моем случае (win2k и win98) все должно быть просто, но это оказалось не совсем

так. В виртуальной машине присутствуют все логические диски со всей информацией на них, как и в основной. Но тут есть маленькое НО. Все изменения, сделанные в виртуальной машине, будут записаны на диск в темповый файл, и при следующем старте виртуальной машины все изменения останутся, НО на основной машине никаких изменений не будет! Это не удобно, т.к. получается, что файлы между машинами надо пересылать через сеть или дисковод, а это крайне геморройно (все это относится к тем, кто выбрал при установке Existing Disk Partiotion). К тому же,

чтобы записать на дискету что-нибудь в основной системе, надо этот дисковод дисконнектнуть в VMware (Devices - Floppy0->A: - Disconnect), записать на дискету что надо, а после таким же макаром законнектить дисковод к гостевой системе (Devices - Floppy0(Not Connected) - Connect). Так сказать: замаунтить и размаунтить, как в Линухе.

Как сохранить файлы на диске, а не в темповом файле? Нужно перед запуском вирмашины залезть в Settings - Configuration Editor - IDE Drives - IDE 0:0 и выставить Mode в Undoable. Там же кликни на кнопку Partitions и включи те разделы, на которые будет разрешена запись (в моем случае все разделы включены на Read/Write). Теперь, чтобы применить все изменения на диске, нужно перезагрузить виртуальную машину (замечание: именно перезагрузить, а не выключить гостевую систему), во время перезагрузки нужно будет подтвердить запись на диск (Commit). Зачем такие сложности? Просто windows очень любит во время своей работы писать/изменять, как ему кажется, всякую "нужность" на диск (ScanDisk к примеру), так вот, VMware ограничивает доступ на запись для гостевой системы, т.к. это могло бы порушить основную.К CD-ROM'у доступ имеется сразу и из win2k, и из win98, так что здесь проблем быть не должно.Если у тебя более одного винчестера или CD-ROM'а, то тебе их придется вручную прописывать в Configuration Editor'e.

Сеть:

VMware установила виртуальную сетевую карту со своим MAC адресом. Все предыдущие сетевые настройки остались у win2k, а у вин98 все изменилось, вот что выдал (ipconfig):

Настройка IP для Windows 98

Главный компьютер.........: DJ_ZLOB

Серверы DNS............:

Тип узла .............: Широковещательный

Код области NetBIOS ID ......:

Переадресация IP..........: Нет

Включение WINS Proxy........: Нет

Разрешение NetBIOS через DNS...: Нет

0 Ethernet плата

Описание..............: AMD PCNET Family Ethernet Adapter

Физический адрес.....: 00-50-56-A0-00-01

Включение DHCP.......: Нет

IP-адрес.........: 10.0.0.2

Маска подсети....: 255.0.0.0

А вот что было раньше и осталось на win2000:

.......

Описание..............: NE2000 Compatible

Физический адрес......: 00-80-48-ED-08-AC

.......

Сеть на виртуальной машине работает как на отдельном компе. Я сам с собой чатился по YTalk'у, вводил в заблуждение народ по сетке, гнал о том, что ко мне второй комп приперли и т.д. Догадаться о том, что в сети вирмашина, достаточно сложно, особенно если не знаешь, что такое вообще существует... Самое интересное, что в списках производителей сетевых карт такого MAC-адреса нет (005056), да это и не важно, смысл весь в том, что можно менять МАС-адрес в реалтайме win2000, т.е. перезагружая только гостевую систему (это относится только к виндам). Правда, самому мне это не удалось, но если поскрести по сусекам интернетовским, может найдешь что-нить по смене МАС-адреса на самой виртуальной карте. Короче, ищи сам! Что, я должен все за тебя делать? =)


Спецвыпуск Xakep, номер #014, стр. 014-015-4, VMWARE. Клонируем компы

VMWARE. Клонируем компы

Спецвыпуск Xakep, номер #014, стр. 014-015-4

Как уже упоминалось, для сниффера применение виртуальной машины одно из самых крутых средств оставаться визуально видимым для остальных в сети и в то же время сниффить с одного компьютера. Достаточно запустить виртуально Linux, поставить хороший firewall, отсекающий левые запросы, и отключить использование протокола ARP на интерфейсе (ifconfig <интерфейс> -arp).

Можно, к примеру, использовать VMware в экспериментальных целях, в одной оболочке кодим и сразу на другой испытываем; забавно было наблюдать, как в окошке у Win2000 лежал в бессознательном состоянии Windows98 со своим Blue Screen of the Death ;).

Да, не забудь поставить VMware Tools. Запусти виртуальную среду, "замаунть"

дисковод, засунь дискету, затем высунь (она тебе не понадобится, т.к. будет использоваться image с диска) и кликай Settings - VMware Tools Install. Тулы содержат дополнительные настройки VMware, типа - при покидании курсора виртуальной среды он сразу отдается в управление основной системы. Также в тулы, помимо разной шняги, входят драйвера к видеокарте, чтоб глаз хацкерский радовался не 16 цветам радуги (а 17-ти :), а полноценным - 1280х1024х32. Еще могу посоветовать самому почитать нелп и полазать по сайту Разработчика (www.vm-ware.com). В общем, прога сделана качественно, жрет, правда,

много - чтобы нормально из под win2000 работал win98, нужно 128 мегабайт и проц не слабее PII-400. А если ты счастливый обладатель раритета, века так из каменного, то запускай что-нибудь полегче Вантузов. Вот такие куличи! Увидимся.

блок-врезки

1

Бывала ли когда-нибудь с тобой следующая шняга - желание иметь два компа? А тем, у кого два, - три? Правильно мыслишь!

2

Если ты правильно сконфигУрил сеть на виртуальной машине, то в сети появляется новый комп со всеми своими функциями. Как и на обычном компе, можно расшаривать ресурсы, запускать сервисы и все такое.

3

Можно и нужно использовать VMware в экспериментальных целях, в одной оболочке кодим и сразу на другой испытываем.


Спецвыпуск Xakep, номер #014, стр. 014-018-1, Оргазм Робокопа

Оргазм Робокопа

Даниил Шеповалов (dan@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-018-1

Если друг оказался вдруг...

Из брошюры центра помощи жертвам гомосексуального насилия

У меня тут родилась потрясающая идея насчет уменьшения количества дорожно-транспортных происшествий: надо всем пешеходам выдать по портативному гранатомету. Представь, переходишь ты мирно улицу на зеленый свет, никого не трогаешь, а тут вдруг какой-нибудь пончик на джипе со свистом пролетает мимо тебя на красный, причем хорошенько обдав грязью из подходящей лужи. Ты же, не говоря ни одного матерного слова, преспокойненько опускаешься на одно колено, достаешь из-за спины гранатомет, прицеливаешься хорошенько и ухреначиваешь этого мерзкого ублюдка в кровавую запеканку. По-моему, красотища! Ну и о водителях, конечно, не надо забывать: им следует раздать станковые пулеметы. Бабушка может зазевается, улицу переходя, или снежок пацан какой-нибудь в лобовое стекло бросит - короткая очередь, и у водителя снова прекрасное настроение. А уж как уверенно и аргументировано люди будут объясняться с сотрудниками ГИБДД - это просто не ходи купаться.

Также у меня есть пара рационализаторских предложений насчет введения генетического контроля рождаемости. Тут какой случай был: стою я у входа в метро, на солнышке греюсь, улыбаюсь вовсю - жду, в общем, кого-то. Подходят два парня весьма сомнительной наружности из цикла "Пацаны без мазы" и "Пятница - столица веселится", долго меня оглядывают и, наконец, задают потрясающий по своей значимости вопрос: "Ты чего тут стоишь?".

- Человека, - говорю я, - жду хорошего.

Видимо подобный ответ ребят потряс до глубины души, во всяком случае они открыли рты и минут 10 стояли молча, переваривая сказанное. Наконец, паренек посообразительнее опомнился и задал новый, еще более интеллектуальный вопрос:

- А чего лыбишься тогда?

- Ну как же, - говорю, - солнышко вот, ласточка опять же летит, может даже травка скоро под снегом зазеленеет, красотища в общем. Как же тут не улыбаться?

Новая пауза, теперь уже на 15 минут. На челе обоих отражается мощная мозговая активность. И снова крайне оригинальный вопрос:

- Ты, вообще, против нас что-нибудь имеешь?

Тут я, наконец, понимаю, чего от меня хотят:

- Нет, ребята, я вас уважаю больше, чем Гагарина, да я за вас жизнь отдам. Вы реальные пацаны! Все люди братья! Миру мир! Возлюби ближнего своего! Верните наших ребят из Вьетнама!

Внезапно из-за угла появляется троица парней еще более сомнительного вида, хватают меня за плечи и орут: "Ты чего до пацанов докопался? Жить надоело?".

Так я про что говорил-то? А, генетический контроль рождаемости. Придурков и извращенцев, в общем, сразу на удобрения пускать. Чтобы таких как я поменьше было. Или даже радикальнее можно подойти: убивать всех, кто младше 14 и старше 50. Хотя нет - тех, кто старше 50, можно еще на урановых рудниках использовать или на лесоповале где-нибудь. А младшеньких на органы пускать - молодые они ж еще, здоровые. В общем, пусть хотя бы одно поколение поживет в нормальном мире: без перенаселения, без старческого маразма, со здоровой печенью....

Однако что-то я увлекся, тема у нас сегодня абсолютно другая. Тут поступила информация, что кто-то распускает слухи обо мне, Величайшем из Величайших. Дескать, Даня Шеповалов лишился девственности в 11 лет и никогда не мастурбировал. Абсолютнейшая чушь и клевета, это я официально заявляю. Еще вчера вечером, например, мастурбировал. В гостях дело было: все по разным комнатам трахаться разошлись, ну и я к одной парочке присоединился, лег с ними на кровать (на разные ее половины). Лежу, в общем, удовольствие получаю, воображаю будто я - Бритни Спирс. Ну и молодежь по соседству тоже не теряется, увлеченно друг друга тискает. В общем, не знаю, как все произошло, может резонанс какой, частотное наложение колебаний, однако кровать подо мной сломалась. Выгнали меня с того праздника... и деньги на починку кровати еще отобрали. Фашисты.


Спецвыпуск Xakep, номер #014, стр. 014-018-2, Оргазм Робокопа

Оргазм Робокопа

Даниил Шеповалов (dan@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-018-2

А тема, еще раз повторю, у нас сегодня совершенно другая. Необычная, можно сказать, тема. А именно: как получить удовольствие от секса с женщиной. Да-да, вы не ослышались: не с мертвым маленьким осликом, не с Visual C++ и даже не с надувным резиновым Микки Маусом, а именно с женщиной. Думаете, тема несколько надумана и не заслуживает особого внимания? Ошибаетесь! Практически каждый парень, даже с предельной концентрацией мужских гормонов в крови, не получает полноценного удовольствия от самого процесса совокупления с самкой человека. Да самый убогий дельфин испытывает в такие моменты гораздо более яркие чувства, чем среднестатистический мучачос. Во время мастурбации, например, мы попадаем в идеальный мир нашего воображения и получаем максимальное удовольствие. При сексе же с женщиной... ну вы сами помните: странные движения с неясной целью, поворот к стенке и размеренный храп после окончания процесса, а также полное отвращение к самому себе, тетке и самой человеческой природе на утро. Все может, конечно, варьироваться в зависимости от влюбленности, степени алкогольного или наркотического опьянения и других факторов, однако в целом общая картина выглядит именно так.

Но Даня Шеповалов, Отец Оргазма и Кладезь Порочной Мудрости, думает 24 часа в день, а потому знает, как быть и что делать. И, как всегда, делится своим знанием с тобой! Итак, способы получения кайфа от секса с тетками:

1. Сам себе Тинто Брасс

Хорошая порнушка заводит всех. А теперь представь, что ты - главный герой крутейшего порно. Просек фишку? Правильно, снимаешь на камеру себя и тетку в момент дикой оргии, а на следующий день мастурбируешь, просматривая это видео. И на послеследующий день мастурбируешь. И на послепослеследующий. И вообще, тебе тетки больше не нужны - у тебя кассета есть. Вот черт, я ведь о сексе с женщинами обещал рассказывать, а не о мастурбации... Ладно, исправлюсь.

2. Автоматизация труда, или режим реального времени

По сути это модификация первого метода, однако какая модификация! Устанавливаешь камеру, подключаешь ее к телевизору, а сам удобно устраиваешься на диване. Берешь тетку и заставляешь ее тебе мастурбировать. Можешь попросить ласково, а можешь пистолет к ее голове приставить - это уже дело вкуса, да и не важно по сути. Главное, что ты наблюдаешь этот процесс по телевизору буквально со стороны в режиме реального времени, причем не прилагая абсолютно никаких усилий. Это тебе не на порносайтах видео смотреть при коннекте 9600.


Спецвыпуск Xakep, номер #014, стр. 014-018-3, Оргазм Робокопа

Оргазм Робокопа

Даниил Шеповалов (dan@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-018-3

3. Последний секс в твоей жизни

Знаешь, почему некоторые товарищи (Федя, я никому ничего не расскажу) любят трахаться со старушками? Правильно, потому что старушка всегда думает, что этот раз - последний, и такое вытворяет... А теперь представь во время секса с теткой, что ты трахаешься последний раз. Поклянись, например, всем богам и Фиделю Кастро лично, что отрежешь себе член сразу же после окончания этого полового акта. Гарантирую, что кончать ты не будешь часов 5-6. И попробуй только удовольствия не получить... А уж тетка на тебя молиться просто будет. В качестве варианта можно перед началом твоего последнего секса полностью скушать содержимое домашней аптечки - стоять у тебя больше никогда не будет, да и умрешь во время оргазма, если повезет.

4. Ментальная репликация

Этот способ очень сложен в реализации, однако дает просто потрясающие результаты. Во время секса с девушкой представляй, что ты трахаешь кого-нибудь другого: Чипполино, Зорро, Чингачгука, Дэвида Копперфильда или Люка Скайуокера. Особо продвинутым эстетам рекомендую представлять, что они занимаются сексом с агонизирующим Робокопом. На первых порах будет, конечно, трудно, поэтому тебе стоит надеть на подружку черную маску, ну или меч лазерный - для создания соответствующего настроения. Когда же ты достигнешь высокого уровня визуализации, тебе следует сделать еще один важный ментальный переход: представлять, что ты трахаешь самого себя. Тогда ты будешь получать двойной кайф одновременно: как тот, кто трахает, и как тот, кого трахают. То есть, по сути, найдешь свою внутреннюю женщину. Ну а там уж и до секса с Вечностью недалеко.

5. Место встречи

Широко известно, что окружающая обстановка играет немаловажную роль в качестве любовного акта. Однако твоя фантазия, как всегда, не идет дальше подъезда, машины, пляжа или клубного туалета. Это дешево, дорогой мой друг. Вот тебе пяток обалденных мест для проведения отличнейшей оргии: в Мавзолее, на cтадионе (здесь здорово бы было укутаться динамовскими шарфиками и трахаться прямо посреди толпы болельщиков Спартака), на свинцовой обкладке ядерного реактора, под столом на лекции о чистой и прекрасной любви, в кабине суперсовременного истребителя при пересечении звукового барьера. Опять же очень хорошо себя зарекомендовал метод "Летающий Элвис", когда ты одеваешься под Элвиса и садишься с подругой в кресло, к которому привязаны 370 надувных шарика с гелием.

Достаточно? Тогда действуй. О результатах пиши. Законспектируем и сохраним для потомков.


Спецвыпуск Xakep, номер #014, стр. 014-020-1, Снимаем девочек на IRC

Снимаем девочек на IRC

Иван Пинцетный (faq@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-020-1

Убийцы времени

Просиживая не менее тысячи часов за год в IRC, я пришел к выводу, что пользы от чатов может быть ровно две. Первая - деловые контакты, работа, поиск нужной инфы, обмен-трейдинг и прочие сопряженные сотрудничества. Вторая - девчонки. О пользе ИРКи для хацкера мы уже писали много и напишем столько же. Но не сейчас. В данный момент имеется предложение заострить свое любвеобильное внимание на поиске и съеме девушек непосредственно в IRC.

Кто-то возразит: какого хрена, ведь там одни мужики патлатые с мозолью на попе сидят, и девок там никогда не было?!! Возражение насколько ошибочно, настолько и логично. Я сам, познакомившись с чудным миром Internet Relay Chat`a, не строил иллюзий относительно реальных знакомств в рассматриваемом месте. Попутно убеждая знакомых пикаперов в значительно большей полезности www-chat`ов. Ох, как я ошибался!

В этой статье я бы обратил твое внимание не на переживания и эмоции, связанные с виртуальными знакомствами, а призвал бы к техничности процесса.

Даешь коннект!

Достаточно актуальный вопрос - как в первый раз законнектиться с девочкой? Про реальную версию этого действа написано немерено книг и статей, существуют целые эхо-конференции и листы рассылок. Многих привлекают сетевые знакомства именно простотой и безотказностью первого коннекта. Т.е. вроде как достаточно залезть в приват к подруге, сказав классическое "Привет, как дела?", и получить искомое. Действительно, процесс не столь сложен. Но злоупотреблять примитивностью не стоит.

Первичный "привет-привет" лучше оставить для основного окна канала или же в случае неразговорчивости объекта в channel`е - завуалировать в нечто менее банальное. Часто случается так, что дамы, уставшие от хронических попыток клея неумелыми пикаперами, просто игнорируют приветы :(. Не стоит обламывать себя и ее. Лаконичная фраза "Привет" подойдет разве что при атаке на объект с ником Hy}|{eH_My}|{uK =). Постарайся завязать высказывание по теме канала, если он тематический, естесно. Хотя большинство всяческих #russia, #moscow, #piter - нейтральны в плане направленности. Таким образом, стоит приглядеться и к тому, откуда тетка, какой идент, что написано в инфо. Например, можно изобразить необъятную заинтригованность фактом наличия идента KA3AHOBA или Kanpu3. Или же фраза из инфы - "Я ненавижу Интернет" - подскажет ни только первые фразы диалога, но и практически весь дальнейший процесс запаривания мозгов барышни :).

Основные требования к первой реплике в том, чтобы она была: а) небанальная, оригинальная; б) подразумевающая простой, а то и односложный ответ, дабы не заставлять даму активно рефлексировать над вопросом; в) написана чистым русским языком, без жаргона, измывательств над словами, типа "ну ваще йеп, ты, типа, девачка, че тут седишь, бял?". В свое время стопудовый успех имел речевой оборот, закинутый первым по счету в приват "Ti vidisch cyrillic?" или "Видно, что я пишу? Vidno chto ja pishy?". Проблема чтения кириллицы в чатах, где тусуются наши бывшие соотечественники, - более чем актуальна. И на вопрос можно получить ответ просто из транслитной взаимоподдержки :). Далее успешно вворачивается малява насчет твоего наступившего счастья от умения видеть русские буквы барышней. Не меньшими положительными эмоциями обдается и весть о совершенно случайном землячестве с собеседницей, типа "Вау, да ты из Москвы! Супер. А то все больше люди какие-то неместные, из Америк всяких попадаются. Я рад, что мы установили нашу связь".


Спецвыпуск Xakep, номер #014, стр. 014-020-2, Снимаем девочек на IRC

Снимаем девочек на IRC

Иван Пинцетный (faq@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-020-2

Опять же, особенно в первых фразах, важно сохранять вопросительную формулировку предложений, чтобы тетка могла без труда отвечать на твои вопросы, подготавливаясь к более серьезной нейро-атаке на ее наивный мозг ;).

Технические приблуды

Вот так почитаешь материал о съеме девок в журнале Х, да и заподозришь, что его продали какому-нибудь бабскому YES, хронически вещающему о том, как правильно познакомиться с правильными мальчиками. Ты думаешь, у нас все будет так примитивно? Э не, хацкеры, помимо своего красноречия и остроумия, активно юзают и порождения прогресса в процессе пикапа!

У меня имеются весомые сомнения, что тебя интересует знакомство с жительницей далекого северного города Усть-Пердынск, находящегося в 3000 километров от твоего места дислокации. Скорее нужны лишь те, что живут непосредственно в твоем городе или хотя бы там, куда ты собираешься наведаться лично. И что же, теперь придется у каждого приглянувшегося женского ника спрашивать, откуда она? На фига такой гимор, ведь один из главных плюсов ирки, по сравнению с ввв, - доступность информации по юзеру. В первую очередь - доступность информации географической. Эта инфа находится в поле host. Т.е. в user info

Zadacha is ~tanatos20@206.166.fx.dialup.city-line.ru * Vika, 206.166.fx.dialup.cityline.ru - и является искомым хостом. Из которого мы видим, что тетя пользуется провайдером Cityline, мощности которого, в данном написании хоста, расположены в Москве. _4erepashka is XarOkv3.5-@145.pool.kaluga.ru * don't know извещает, что рассматриваемый объект находится в Калуге. И так далее. Если же появляется нечто незнакомое, невиданное ранее, вроде alisika is ~alisa_bel-@belenky.pikenet.ru * alisa, будет логичным запрыгнуть на сайт ISP, под которым сидит деваха. Это уже делается проще простого - прибавлением www к последней части хоста, т.е. у нас это будет www.pik-enet.ru. Там уже имеется инфа о том, где расположен пров. С географическими доменами еще проще: ru, ua, bu. Региональные провайдеры, как в случае с Калугой, обычно обзываются в честь города: kirov, tula, primorye, kuban, etc.

А что же делать, если выпадает нечто типа Spalka is ~Sonya@208.155.68.241 * Splushka?

В пору вешаться, ведь неизвестно ни откуда объект, ни www ее прова... Тут нам на помощь приходит горячо любимый www.ripe.net

Задаешь интересующий тебя IP и получаешь подробную инфу, зайдя в раздел whois db.

Вот и получаем, практически, точную инфу о географическом расположении.

Это можно получить не только на сайте райпа, но и при помощи встроенного whois`a во всяческих Internet maniac и IP-Tools.


Спецвыпуск Xakep, номер #014, стр. 014-020-3, Снимаем девочек на IRC

Снимаем девочек на IRC

Иван Пинцетный (faq@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-020-3

Когда отговоришь по 2 часа с каждой тетей, станет понятным факт того, что 70 процентов разговоров - однотипны. Т.е. стандартные "сколько тебе лет, где учишься/работаешь, любишь ли кино, вино, театр, чего не спится в столь поздний час" и прочая байда. Понимаешь ход мысли? Именно: если ты знаком с понятием Pop-ups в IRC-клиенте, то без проблем накатаешь стандартную менюшку для Query-окна, в которой будет нехилый структурированный списочек готовых фраз. Окошки можно разбивать тематически - "Мой lifestyle", куда ты зальешь все о своем свободном времяпровождении, и "Твой lifestyle", где будет практически то же, только с вопросом на конце (по концу вопросов не будет - дело уж больно интимное :). Также удобно структурировать менюшки по мере продвижения разговора. Т.е. сначала "приветы, как дела", потом "где учишься/работаешь/как проводишь свободное время". Можно замутить специальную "философскую" менюху с уже готовыми универсальными высказываниями умных дядек и твоими эксклюзивными мыслями о смысле жизни :). Последнее особо нравится романтичным девушкам и почти всегда оказывается кстати даже при обсуждении повышения цен на садовую коноплю-пеньку :). Ну и, конечно, также потребна финальная менюшка, в которой подведется итог вашей беседы. В виде получения номера ее телефона, договоренности о встрече, намыливании мозгов о том, какая же она уникальная девушка и приятная собеседница. В общем, отсмотри десяток своих логов с девочками и выдели наиболее удачные речевые обороты. Их, в свою очередь, уже следует занести в обсуждаемые Pop-ups`ы.

Кстати, как наколбасишь уникальных фраз под твоим авторством, высылай их нам в Х. И если ты будешь одним из лучших - получишь фирменную майку Х, журнал с автографами и живую бесплатную консультацию главных специалистов Х по сетевому пикапу - Профессора Левински и Ивана Пинцетного. Свои нетленки бомби по адресу, указанному в заголовке статьи!

Галерейные девчонки

В отношении обзора внешности собеседницы существуют 2 способа: попросить фото у самой подруги или же заполучить на страничке какого-либо канала, где она часто тусуется и, вероятно, успела залить туда (на страничку) свою мордашку. Не стоит забывать про обмен фотками девчонок между представителями мужской особи канала ;). Сколько раз ко мне в приват врывался приятель с криком "Цепляй ее! Рабочий экземпляр". Да и я столько же раз перенаправлял от себя девиц на своих знакомых, которые уже занимались дальнейшей разработкой :). Это как в хацкинге: один получил рабочий шелл и передал корефану-хацкеру для дальнейшего получения рутшелла :).

Но, как видишь, заголовок статьи повествует о неких галереях... Хотя боюсь, что слово "некие" тут совершенно не подходит, ибо для многих данные очаги культуры стали едва ли ни основным источником знакомств. Главная польза галерей и директорий фоток IRC-пользователей в том, что, пользуясь встроенным поисковиком, ты можешь найти нужные контакты на теток, нужного возраста, из нужной местности, с подобающей внешностью. Неплохо такая хрень реализована в, пожалуй, наиболее перспективной www.ircdirectory.com


Спецвыпуск Xakep, номер #014, стр. 014-020-4, Снимаем девочек на IRC

Снимаем девочек на IRC

Иван Пинцетный (faq@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-020-4

Удобная навигация, частые обновления, поддержка нескольких языков, симпатичный дизайн. Главный минус - акцент не на xUSSR, а внимание нашим соотечественникам, живущим за рубежом, - в США, Израиле, Канаде и т.д. Так что в первую очередь тут легко будет найти подходящую барышню жителю Америки. А также лишь в контексте USA имеется навигация по конкретному штату. Остальным же придется, задавая критерии поиска, получать всех теток нашей необъятной Родины :). Проект развивается мощностями каналов-монстров #russia и #russian, так что, скорее всего, тут будет вполне комфортно со временем.

Ircfoto.da.ru уже менее серьезная компания. Это видно хотя бы из халявного редиректа da.ru. Зато по количеству фоток - очень привлекательная. Сам я узнал про сайт после общения с теткой, которая на классический вопрос: "А не найдется ли у прекрасной незнакомки фото?" - послала искать ее ник на IRCFOTO. Поисковик имеется, но работает как-то странно и вовсе не позволяет извлекать из базы юзверов, географически нужных нам =(.

Еще одна галерея, образованная нашим дорогим adrusha`ей :). На базе страницы канала irc.dal.net #ruschannel была образована полноценная коллекция фоток. www.irc.xxi.ru

Здесь можно обнаружить 270 человечков, некоторые из которых, увы, присутствуют без фото. Поиска по людям нету, зато основная часть имеющихся девчонок - из xUSSR.

Вполне удобная навигация по никам (разбиты алфавитно). Так что сюда удобней бегать, если уже запеленговал особу на IRC и требуется поглядеть на ейную фоту. А вот искать сначала здесь, а потом в ирку лезть - не совсем удобно.

Вот по сути 3 основные галереи. Другим источником получения фот является раздел Photos/Галерея на сайтах каналов. Практически каждый более-менее посещаемый чан имеет свою пагу. Адрес ставится в топик или же доступен по запросу на chanserv. Если ни там, ни там линка не нашел - спроси у опа.

Нехилый списочек www-представительств IRC-каналов, а также просто сайтов по нужной тематике можно найти на http://list.ru/catalog/-12661.html

На большинстве страничек каналов есть раздел фоток. Туда ты и забегаешь, выбирая интересующих тебя барышень. Стоит отсматривать не только чисто женские картинки, но и, например, отснятые на сборах канала. Страничек каналов достаточно много, и они, порой, часто обновляются. Так что советовал бы тебе завести отдельную папку в закладках браузера под тему IRC. Еще можно подписаться на новостные рассылки каналов, в которых часто указывают про обновление раздела фото.

И что же делать с полученными фотками? Ведь самих-то девушек не видно, и есть лишь их призрачные координаты... Да все очень просто! В галереях почти всегда указано, в какой IRC-сети бывает тетка и на каких каналах. На самом деле важна лишь сеть, потому как после занесения дамы в Notify List твоего IRC-клиента ты сможешь видеть, когда она появится в Нете и на каких каналах.

Собственно "взлом"

Что же такого особенного впаривают сетевые пикаперы своим жертвам, дабы морально их подготовить к полной готовности на все и всегда? :) Ведь именно здесь наш "взлом", а вовсе ни в реальной встрече, о которой сказ пойдет чуть ниже. Настоящие бойцы фронта сетевых съемщиков делают всю основную часть разработки дамы еще в сети, в нашем случае - на IRC. В этом снова плюс инетных знакомств, что ты "познаешь ее бездонную душу", не прогуливая по ресторанам и клубам, оставляя по 50-100$ за вечер, а сидя в любимом кресле, параллельно компилируя эксплойты и закупая товары по кредам :). Но чего бы ни говорили, активный пикап требует определенных усилий и затрат (времени, мозговых клеток, выпитых бутылок пива, например), так что, наметив нужную тетю, не стоит забрасывать разработку, руководствуясь наивной мыслью "новую найду - новую сыму". Женский трафик на IRC не столь глобален, так что следует держать под контролем каждую интересующую тебя женскую единицу, например, пользуясь финтом, описанным в Технических приблудах - Notify list`ом ИРК-клиента.


Спецвыпуск Xakep, номер #014, стр. 014-020-5, Снимаем девочек на IRC

Снимаем девочек на IRC

Иван Пинцетный (faq@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-020-5

Таким образом, решен первый вопрос - найдена жертва для реализации твоего словоблудия и гормонов :). Возникает следующий актуальный вопрос: о чем говорить, когда знакомство произошло/связь установлена? Да по сути все те же темы, что и в реальных беседах. Только если "с глазу на глаз" не всегда возможно придумать оперативно остроумный ответ, то в инете есть спасительное время, которое всегда можно списать на лаг, и горячо любимые поисковики-каталоги, с помощью которых можно найти ответ на любой хитропопый вопрос и слить любую инфу :).

Главное в беседах обособить себя от прочих жителей IRC: ты не такой, как все, у тебя все не так. И вообще, ты родился по радикально новому способу :). Т.е. если у барышни сложился стереотип о мужиках, как о кобелях редкостных, всеми своими речами передавай свою неповторимую чистоту и романтичность: вокруг все так пошло, а окружающие девки ни о чем, кроме денег и секса, не думают! А если же тетя привыкла общаться в инете с мямлями, которые готовы на месяца растягивать виртуал и сами не решаются на встречу, - обозначь себя эдаким героем-любовником, для которого страстные отношения - нормальное состояние. Главное - не переходи на пошлость или чрезмерную манерность в случае выбора обличия романтичного мальчика-пая.

Ну а когда ты выделил себя как личность яркую и неординарную, следует начать впаривать и о неповторимости ее души и эго. Любой человек, пусть даже самый примитивный, хранит в себе надежду на собственный "особый путь" и глобальное отличие от окружающих. Вот и ты про это не забывай и почаще упоминай о вышеобозначенном - девочке. Окупится сполна! Она подумает: вот он, пришел мой принц, вот, наконец-то, ОН понял мою хрупкую глубокую душу, нашел тонкую грань моего эго и только ОН достоин меня из всех мужчин! И прочая бодяга, навеянная женской логикой. =)

Естественно, выбранный типаж должен отображаться во всех фразах. Так, романтичный юноша не будет рассказывать о том, как бухал с друзьями на даче, а потом блевал огурцом и ходил в деревню "по бабам". Но и мачос не будет впаривать о только что прочитанном собрании сочинений Стендаля, скорее наоборот: о книгах, театре, политике и живописи будет втирать "думающий" молодой человек. В общем, я думаю, продолжение сойдет за демагогию, и ты сам сообразишь, что хочет слышать девочка и что услышит. Единственное замечу, не стоит излишне давить собеседницу своим интеллектом, выказывая свои необъятные знания и задавая вопросы, ответов на которые у тетки - нема. Старайся задавать максимум вопросов общего характера, не вызывающих особых размышлений перед ответом :).


Спецвыпуск Xakep, номер #014, стр. 014-020-6, Снимаем девочек на IRC

Снимаем девочек на IRC

Иван Пинцетный (faq@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-020-6

Реалка

Подзаголовок выбран неслучайно: как-то с таким ником меня преследовала дама, после реальной встречи с которой я долго скрывался :). Так что, помимо виртуального взлома, вспомним и о встрече в реале.

Ты уже плавно перевел ваш коннект с девочкой с пути виртуального на реальный? Нет еще? Пора, мой друг, пора. Подолгу молотить языком в приватах - дело неблагодарное и засуживающее право на жизнь в случаях исключительных. Как уже отмечалось в "Собственно взломе", идеальным соединителем виртуального с реальным является фраза "Мне кажется, мы очень позитивно с тобой пообщались. Бла-бла-бла-бла. Не подскажешь, как я мог бы увидеть тебя впредь?". Или же, прямо по ходу разговора, вы решаете забить стрелку. В любом случае конечную договоренность лучше обустраивать "по старинке" - по телефону. Это, опять же, будет лишним подтверждением ее правильной половой принадлежности :).

Полезное отличие пикапа на ирц в том, что практически любой более-менее крупный канал имеет свои, как сказали бы фидоры, поинтовки, и сами иркеры - ИНЕТКИ. Т.е. сборы канала. Когда в каком-либо очаге культуры (пив. баре, лесу, парке отдыха :) тусуется наиболее активная часть жителей чаннела. Вот тут бы и взять себе нужных девок, ведь удобно: можно заценить интересующую особу в ее физическом обличии, свободная атмосфера тусовки иркеров, возможность культурного отдыха за минимальные бабки (2 баттла пива + простейшая хавка).

Так все-таки что делать с девчонкой после ее вывода в реал? Бывали случаи, когда барышню удавалось сразу отвезти себе домой для позитивного отдыха или же отправится к ней ;). Но, к сожалению, сие случается не так часто, и порой приходится попариться над культурным досугом. Особенно если попадается манерная дама, внимательная к собственному времяпрепровождению. В таком случае примитивом романтики прогулок в парке и поездок на Поклонную гору - не возьмешь :). Тут лучше забежать на сайты, посвященные культурному отдыху. Как то www.weekend.ru или www.afisha.ru.

Предварительно стоит выяснить, что наиболее интересно барышне: кино, театр, выставки, клубы, концерты. Если тебе не претит погружение в эстетику, театр можно было бы считать оптимальным местом: если тетка не особо рубит в этом, можно вывести на спектакль, куда билеты будут стоить не дороже 100 р. за штуку. Т.е. билеты + буфет обойдутся порядка 300 р., в то время как за кино придется отвалить по 150 за каждый билет (если тусануть вечером в приличный кинотеатр), а за концерт и вообще по 200-500. Главная фича театра: создание иллюзии у барышни о твоем высоком культурном уровне. Да и отказаться от предложения сходить в театр куда сложнее, чем в кино или клуб, ибо потенциальное зажигалово прячется под маской эстетичности театра ;). Ясное дело, что сразу после вывода на выставку/кино/театр передвигать события в физиологическое русло у тебя или у нее дома - не совсем логично. Надо катализировать процесс, не без участия алкоголя, в каком-либо кафе/баре/клубе. Т.е. соблюдать ступенчатое развитие отношений. Если же ты не сторонник столь стремительных событий или дама попалась чрезмерно загруженная комплексами и понятиями, то после выхода в свет можно попрощаться и устроить дальнейший "марш-бросок" чуть позже. А вот коли ты не заморачиваешься моральными проблемами и тетка не страдает болезнью Якоря, можно устроить праздник души и тела прямо в день реального знакомства ;). Тут, в очередной раз, нам может помочь железный друг: пригласить девочку глянуть на твои супер-скрипты или самый навороченный KDE2-декстоп в Линуксе :). А в последнее время особенно рулит зазывать для записи целого CDR`a MP3`шек на твоем зло-резаке (CDR-Драйве) свежайшей коллекции выкачанной и порипанной музычки. С чуть меньшим, но все же с успехом проходят и поездки в гости ;). Короче, тут есть место для фантазии. Только не стоит увлекаться: если у тебя халявный инет или выделенка, можно вообще потерять тетку, ушедшую с головой в Нет вместо забав с тобой :).


Спецвыпуск Xakep, номер #014, стр. 014-020-7, Снимаем девочек на IRC

Снимаем девочек на IRC

Иван Пинцетный (faq@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-020-7

Ну а что делать, оказавшись у нее дома или привезя гостью к себе, я думаю, рассказывать не нужно ;). Хотя было бы неправильно сводить всяческие отношения, завязанные на IRC, к простейшим. Я лично знаю, как минимум, 10 супружеских пар, чье знакомство началось именно в ирке! Ну а про стабильные отношения "парень-девушка" я и не говорю. Хотя среди бывалых пикаперов бытует мнение, что обустраивать какие-либо длительные отношения логично с девушкой "из реала". Девушкой, не связанной постоянными узами с компом и инетом... Ну, не знаю и надеюсь на твою абсолютную логику и сознательность, которые помогут тебе принимать правильные решения, особенно в отношении девАчек :).

Автора этих строк можно почти каждый день застать на irc.dal.net и периодически на dal.net.ru. Хотя "карьера" иркера была начата в MS-chat`e и также включила в себя стажировку на Ефнете. С Ircnet`ом тесных отношений не сложилось: отсиживался тут лишь при житии в дали от Родины, в поисках местных контактов. Также иногда залетал на undernet для марш-бросков гинекологических войск, в которых принимал активное участие.

1

Подстава виртуальная

Любимая байка всех противников знакомств в инете: найти реальную девушку практически невозможно, т.к. тут сидят только дядьки с богатым волосяным покровом и разводят несчастных наивных юношей. Это однозначная правда и неправда одновременно. То, что в Интернете, и в ИРКе непосредственно, имеются разводчики - факт (лично я за первые 2 месяца сетевого пикапа сконнектился телами с 8-ю девушками - прим. профессора Левински). Но их, благо, не так много, и все-таки основную часть женских ников подкрепляют реальные женщины :). Как же различить подставу? Опытный любитель IRC вычислит такого моментально. Настоящая девушка вряд ли возьмет ник/идент типа - Sexy_girl или Big_pussy :). Под схожими масками как раз чаще прячется подстава. Аналогично и с поведением "особы": где подстава, там и излишняя активность в направлении постельных тем разговоров. Так что оптимальная провокация для выявления личины - откровенное предложение вступить в половую связь =). Это, есесно, шутка, потому что разводчик хоть и согласится на ЭТО моментально, таким образом выявив себя, но и настоящая девочка сбежит от тебя не менее моментально ;). Также полезно иметь скрипт в IRC, который бы выявлял клонов (т.е. зашедших с одного хоста) или же ручками делать whois по всем посетителям. Обычно разводящий сидит как под основным ником, так и с женским. Эта дурная привычка была принесена из www-чатов, накормивших посетителей иллюзией анонимности. В общем, как видишь, ники Vova-XAKEP и [Masha] с одного хоста, знай, что Маша и есть тот ксакеп Вова :). Исключение - люди из одной локальной сети, имеющей маскарадный IP для всех ее членов для выхода в Интернет.


Спецвыпуск Xakep, номер #014, стр. 014-020-8, Снимаем девочек на IRC

Снимаем девочек на IRC

Иван Пинцетный (faq@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-020-8

Подстава реальная

Что бы ни говорили, большинство разводок "страстными и сексуальными девчонками" как начинаются, так и заканчиваются - виртуально. И встретить при реальной встрече (зацени раздел "Реалка") злобного мужика Пахома вместо ласковой блондинки Элеоноры - маловероятно :). Чаще эта самая "блондинка" просто не приходит на стрелку. Хотя... бывают пренеприятные исключения. Так в сетях, не имеющих сервисов по закреплению ника за конкретной персоной, расцветает следующий финт. Ревнивый молодой человек заходит в ирк с ником своей барышни. И выжидает, пока ни о чем не догадывающиеся кавалеры попрут к нему в приват. И, уже в зависимости от хода разговора, решает, что делать с кавалером. Или в реал подогнать, где объяснить, что к его тетке приставать не надо, или же прямо на ИРЦе высказать все, что думает о нем и его распущенной тетке :). Но такое, опять же, случается не часто и является лишь частью горького опыта автора.

Значительно актуальней другая ситуация. У многих chat-girl`ов нет своей фотки. И на деликатный вопрос: "Слышь, чувырла, дай фоту по-бырому", не менее деликатно сообщает об ее (фотки) отсутствии. И чуть позже, когда разговор заходит о реальной встрече, покоритель дамских сердец решает рискнуть и встретиться без предварительного "осмотра" фотки :). И тут как раз частенько получается некоторый сюрприз: приходит нечто страшненькое, совсем отличное от интригующего и загадочного образа, выбранного виртуально. Отсюда мораль: без фотографии - никогда! :). Хотя таким образом ты отсекаешь весомую часть потенциальных девок для съема. Так что тут снова окажутся полезными контакты с другими активными до женских душ и тел посетителями чата. Если возникают сомнения относительно какой-либо тетки, не стесняйся просить инфы у корефанов. Может кто уже до тебя "тестил образец" и сможет порекомендовать ее или же наоборот - посоветует бежать от "образца" :).


Спецвыпуск Xakep, номер #014, стр. 014-020-9, Снимаем девочек на IRC

Снимаем девочек на IRC

Иван Пинцетный (faq@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-020-9

2

IRC-сети для пикапа

Если запрыгнуть в список сетей mIRC`a, то можно тихо умереть: от такого изобилия начинается фимоз и расслоение ногтей :). Другое дело, что половина из них мертвые - фактически нет активных, динамично развивающихся каналов, и самое главное - в них практически невозможно найти ни то что русскую девочку - вообще россиян не наблюдается! Так что вот небольшой листинг по активным крупным сетям, где можно найти российские каналы с не менее российскими девчонками!

DALnet

Irc.dal.net

Супер сеть. Тут расположен канал твоего любимого журнала - #xakep. И как ни странно, тут тоже бывают девочки, и очень даже ничего ;).

Также полно народу на классических #russia #russian #moscow. Главный плюс сети - наличие сервисов, которые, помимо своих основных функций, позволяют отслеживать: когда и во сколько появлялся интересующий тебя объект ;).

Efnet

irc.rt.ru

Сеть, про которую в контексте пикапа говорить не следовало бы. Здесь тусуются угрюмые мудрые мужчины, часто законно именующие себя хакерами. А где крутые программеры и элитарные хакерские сборы - девочкам место отведено минимальное... :) Из русскоговорящих каналов активны разве что #bytefall и #dev/ice (большой привет b00ster`у и t0nik`у). Хотя реальный эротизм удастся познать и если наехать на крутых дядей: ласково отымеют во все порты :). А если же ты ищешь менее виртуальные ласки - иди в другое место.

MS Chat

chat.msn.com

В свое время, имхо, это была наиболее популярная сеть среди русскоговорящих граждан. Все каналы непременно содержали слово russian в названии: #russian_chat, #russian_love, #russian_pivo, #russian_andybig, etc.

По сравнению с другими сетями, по личным впечатлениям, тут и девчонок было побольше. Все, в общем, было хорошо. Вплоть до того, как Микрософт откровенно забил на свое IRC-детище, посчитав его невыгодным вложением своих финансов (что вполне логично). Тут же резко понизилась посещаемость, и начался повсеместный бардак: боевые боты засрали все достойные каналы, часть чанов пошла по рукам, достойные люди ушли и остались гопники :(. Так что сюда, пусть даже за девчонками, я лазать не советовал бы.

IRCnet

irc.msu.ru

Одна из старейших сетей, со своей историей, эстетикой и культурой. Главное и классическое неудобство - отсутствие сервисов. Но зато здесь вполне активно существуют русскоговорящие каналы. Любовь россиянина к данной network`е не случайна: имеются серверы, расположенные в России, связь с которыми наиболее комфортна. Хотя явная польза от российской локации серваков была ощутима лишь года 3 назад, когда RU с Западом связывали еще не такие мощные каналы.

Из последних впечатлений - канал #xakep, на котором сидят какие-то литовские лохи, не имеющие к Х никакого отношения. 1337 t4k3ov3r cr3w.

Undernet

NewYork.NY.US.Undernet.Org

Если сгенерить аналогию, эта сеть сравнится с эдаким неуклюжим младшим братом. Братом Efnet`a: вроде и амбиции те же, и суть местами... а на самом деле младшенький :).


Спецвыпуск Xakep, номер #014, стр. 014-020-10, Снимаем девочек на IRC

Снимаем девочек на IRC

Иван Пинцетный (faq@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-020-10

Т.е. тоже изначально андернет строился как компутероориентированная сеть, а не развлекательный, как тот же DALnet. Заумные eggheads строили ирку под себя, а сделали для широких масс :). Массы, как то водится, присутствуют на всяческих #russia, #russian.

Тут также хватает женского контингента. Хотя, если ты тут собираешься оставаться надолго, огорчу: контингент статичен, и после двух недель "отсидки" трудно будет найти "новое лицо" 8). Все тут друг друга знают, и часто отсюда сбегают за новыми контактами в другие сетки. Девочки за мальчиками, мальчики за девочками. ;)

Dalnet.ru

Main.hub.dal.net.ru

Наконец-то! Полноценная российская сеть. Созданная самыми позитивными людьми, которые могут быть известны и по другим сетям: Hellman, Hetfield_, Moss и мембер X-crew - andrusha. До недавнего времени было очень удобно пользоваться русифицированными сервисами, которые даже после потери оной остались наиболее симпатичными из всех других сервисных сетей! Но, помимо технических приблуд, здесь и с "женским отделением" все в шоколаде: полно теток, чей состав постоянно дополняется/обновляется. Популярность сети обусловлена и тем, что к ней прилинкован ряд серваков, стоящих в домашних локальных сетях Москвы и других городов.


Спецвыпуск Xakep, номер #014, стр. 014-025-1, ROL на халяву? Едим дальше!

ROL на халяву? Едим дальше!

Спецвыпуск Xakep, номер #014, стр. 014-025-1

Мониторинг feat. уCCатый нянь (faq@real.xakep.ru)

Тенденция, однако...

Года три назад "Совам" был престижным iNet-провайдером, имевшим высокие цены и добротное качество связи. Два года назад контора прикупила себе "Гласнет", начав потрошить последнего unlimited`ами, которые свели на нет качество соединения. Чуть больше года назад с ярых оборотов стартовала программа Инет-кард, доступ по которой стоил 0,4$ в час с роумингом. Начался беспредел, который закончился месяц назад официальным закрытием холдинга ROL... GoldenTelecom`ом.

Все это байки для газет и ушастых юзверей, которые пытаются сэкономить копейку, прозваниваясь часами, дабы захватить халявную ночь по 20$-й карточке, заправляемой "десятками". Это тупо. Нам нужна абсолютная халява, вроде доступа в РОЛ через Спринт 4free, о котором Х писал в #4 Y2K+1. Тогда компания попалась на незнании собственного X.25 сегмента и прикрыла фришку только после того, как туда полезла толпа со всей России, закрывая акцесс нормальным sprint-юзерам. Сегодня новый этап процесса над провом, наградившим всех "высококлассной" связью за смешные деньги...

Заграница нам поможет!

Самый писк моды халявного Инета - доступ через западного провайдера, имеющего точки в России. Таковых не очень-то уж много, к сожалению. И большинство западников для обеспечения своих юзверов роумингом в RU дают доступ через уже существующего мощного прова с модемными пулами во всех более-менее крупных городах страны. Догадываешься, к кому они обратятся? Доступ через X.25 сети с PAD`ами по всем городам - накладен, ибо оплата за трафик часто оказывается недетской, нормальный же, прямой Инет в одной сети повсеместно дает лишь Совам со своим детищем RussiaOnLine.

Итак, заголовок статьи оправдан - всеми правдами и неправдами будем пробивать халявку именно у online.ru.

В чем же особенная тема, если так и так халявщик будет юзать чужие аккаунты? Все очень просто: если заюзать пароль у соседа Васи, то есть шанс ходить с пробитой головой за списанные 100$ с Васиного счета. Или же иметь гордую пометку в паспорте об условном сроке на 5 лет ;). Сейчас система мониторинга ворованных аккаунтов у российского юзера - отточена неплохо и реагирует порой молниеносно: с утреца, вместо голоса любимой девушки, в трубке слышишь угрозы от саппорта провайдера... А при работе с логином иностранца сплошная лафа: Джонну Волкеру глубоко фиолетово до 50 грин, стянутых со счета, ибо это его заработок за час, а при серьезном юзе (несколько сотен, штука баксов) полицейская заява вряд ли дойдет до активных поисков халявщика в далеком Ангарске или Астане :). Да и кто говорит о банальном захвате логинов троянами/через шары? Это только вариант. Еще есть серьезная маза покупки аккаунтов по кредиткам. Обо все по порядку.

Клубы провайдеров

Серьезным параметром при выборе буржуином прова стало наличие солидного международного роуминга по своему аккаунту. Зачем захудалому бразильскому ISP тянуть бэкбон до Москвы? Чтобы Педро Зурито смог приехать пощупать московских красавиц (1000р в час :) и проверить мейл? Нет, конечно. На подобные жертвы идут только самые смелые. Как правило, проблема решается вступлением захудалого прова в клуб себе равных. Бывает так, что клуб формируется неофициально и свое существование объявляет лишь при обращении клиента за роумингом. Но есть и открытые, общедоступные системы. Сегодня мы разбираем наиболее крупную из них - GRIC.


Спецвыпуск Xakep, номер #014, стр. 014-025-2, ROL на халяву? Едим дальше!

ROL на халяву? Едим дальше!

Спецвыпуск Xakep, номер #014, стр. 014-025-2

Мемберы системы формируют нехилый списочек из 300 провайдеров по всему миру (150 стран), запрятавшись в PDF`ку на сайте - http://www.gric.com/network/GRICtraveler-updated.pdf.

Наиболее интересным для нас оказывается наличие партнера - Sovam Telecom. Это значит, что пользователи остальных 299 провов имеют мазу международного роуминга и через ROL. Т.е. аккаунты всех провайдеров из списка могут заюзаться как обычные РОЛовские для доступа в Сеть. Откуда брать данные аккаунты?

Братья Сканеровски

Для начала нужно знать название провайдера. Через поисковик выцепляем его сайт, а через службу Whois`a - его диапазон. Чаще всего IP веб-сервера находится там же, в сабнете, т.е. при опросе whois.ripe.net получим нужную инфу, зная только URL isp. Далее выискиваются аккаунты наиболее любимым способом: кто-то запустит с шелла NMAP на поиск установленных троянов, кто-то обычный EssentialNetTools на shared-ресурсы, кто найдет веб-сервера на базе IIS (в диалапных, VPN сетях - любимая тема) и, заюзав баги, утянет PWL`ы/парольные хэши звонилок. Небольшая фишка - можно зайти в IRC на какой-нибудь канал, вроде #usa, #mp3, #sex, с максимальным трафиком буржуйского юзера, и по логам joins/parts найти нужного тебе прова: если в подсети C (10.10.10.*, к примеру 8) тусуется один юзер, то есть и другие. Короче, подсети провайдеров сканерятся, и находятся пароли. Добавлю, что недавно появился релиз Cain`a, который работает под WIN2K и достаточно шустро перебирает пароли к PWL`ам. Мои рекомендации.

Ну что, ты уже рванул действовать? Уже захапал паролей и безуспешно опробовал их в ROL`e, а автора назвал свиньей и грязным ублюдком? :) Так просто проблема не решается, далеко не на всех аккаунтах разрабатываемого прова открыт worldwide роуминг. Только на некоторых. Определить это не сложно - чаще всего в онлайн-статистике прова можно включить/отключить данную опцию. Включать роуминг имеет смысл только для солидных аккаунтов с серьезным наполнением или долгой кредитной историей, ибо 5-6$ в час (!!!), которые берет GRIC, сожрут в кратчайший срок любой дебетовый аккаунт. Но не все ж такие бедные: у крупных контор попадаются и кредитные мульти-пользовательские дела, которые для халявщика считаются солидной находкой.

Ах, это сладкое слово CC...

Чем отличается Западный е-бизнес от нашего, захудалого? Правильно: обработка кредитных карт на каждом шагу, при покупке всякой пурги. Провайдеры - не исключение. Треть провиков из списка Грика - продают свой доступ за $ по кредиткам (VISA, MasterCard, Amex, Dinners club, etc). При затоваривании следует указать: нужен роуминг или нет. Естественно, указываем, что нужен. Провы по-разному борются с фраудом, поэтому кто-то потребует высылки факса с печатями, звонка голосом (например, прямые продажи через Gric (VPM) некоторое время назад) и даже отправить фотографию водительских прав (многострадальный iPass). Но все еще живы дурачки, которые верят любой валидной инфе, залитой в форму Order`a (японский Nifty, о котором будет рассказано ниже). Естественно, о возможности покупки по убитым/генеренным CC - базара нет. Т.к. даже последние лохи сейчас верифают стабильно. Да и чего париться, ежедневно похищаются десятки тысяч номеров CC с инфой по всему миру... Причем часто через банальнейшие баги того же IIS. Короче, инфа по кредитке есть, остается найти жертву для ее (инфы) применения.


Спецвыпуск Xakep, номер #014, стр. 014-025-3, ROL на халяву? Едим дальше!

ROL на халяву? Едим дальше!

Спецвыпуск Xakep, номер #014, стр. 014-025-3

Nifty

Если верить логам, стянутым с сервера клуба провайдеров, то получится, что Nifty.com - очень популярная тема среди халявщиков: один и тот же аккаунт был замечен в одновременном пользовании в Москве, Хабаровске и Алма-Ате :). Откуда подобное счастье? Наиболее вероятно, что юзаемый аккаунт подрезан у одного из юзеров. Хотя Нифти, главным образом, имеется через CC. Основная проблема, как и в случае с любым другим провом "стран третьего мира", - все формы покупок сделаны на убогих языках, не ясных русскому человеку. В данном случае траблы вокруг японского наречия. Но искать профессионального переводчика - не стоит: дешевле будет легальный инет взять ;). Самое простое решение - поставить поддержку японского языка браузером (делается через Windows update или с дистрибутива), а дальше обрабатывать текст в специальном онлайн-переводчике. Мой выбор - babel.altavista.com. Вводишь URL, и тебе вылетает его английский эквивалент (точность Stylus`овская, но в целом понятно). Серьезная проблема в том, что не обрабатываются SSL-запросы :(, на которых построена большая часть форм Order`ов. Тут приходится построчно переводить бойду Copy-Paste`ом. Перевод - очень важный этап, на котором спотыкалась добрая половина кул-кардеров, возжелавших freeInet`a.

Теперь ты не из их числа и не дополнишь стадо вопрошающих "а чё эта значить?". Яркий пример - plala.or.jp, опять же японская контора, торговавшая Инетом через Equant (доступно по PPP в Москве, Питере, Киеве, и т.д.) за CC. С Plala было море слез вокруг перевода формочек. Почему нельзя сделать платеж в английской версии сайта? Судьба, видать, такая: там будет только портал, и никаких транзакций, продажи лишь для знатоков японского :).

Monad

Провайдер, предоставляющий доступ в Инет для оставшейся непонятой мною страны :). Видать, познания географические оказались слабее халявнических. Фишка: есть как регистрации новых аккаунтов по CC (Sign-up), так и заливка дополнительных ресурсов на счет (Pay your bill online). Второе вполне удобно, т.к. обычно за конкретный аккаунт - деньга списывается с той же карты (вроде как один юзер - одна CC), а здесь же можно оплачивать один логин с нескольких карт.

Полученный аккаунт будет работать и в России через RussiaOnLine. Особых проблем с заполнением формы - нет, все сделано на чистом английском, без специальных приблуд.


Спецвыпуск Xakep, номер #014, стр. 014-025-4, ROL на халяву? Едим дальше!

ROL на халяву? Едим дальше!

Спецвыпуск Xakep, номер #014, стр. 014-025-4

www.monad.net

VPM

Главная торговая точка Gric`a, сюда уводят линки с официального сайта системы. Здесь можно зарегать бесплатный мыл и по CC оформить полноценный аккаунт Грика. Несколько тарифных планов, все поддерживают международный роуминг: от простого доступа к мылу до строительства эксклюзивной Virtual Private Network. Кардилась с различной сложностью: от простого заполнения формы до нудных бесед с менеджерами конторы, попыток доказать, что ты Джон Волкер из штата Огайо :). Сейчас мода на закупку там аккаунтов немного улеглась, так что первое время проблем не должно возникнуть. www.vpm.com

Сорцы

Журнал часто ругают, мол, дает только готовые решения, ничему глобальному не учит, только "сладеньким" кормит, от которого у всех уже животы болят :(. Ведь это ложь! И данный подзаголовок тому лишь доказательство. Перечислять всех кардабельных ISP и их дилеров - неблагодарное дело и опять же отбивающее у читателя способность к мысли :). Поэтому далее пойдет списочек западных (японских тоже для порядка будем так называть :)) провов, работающих через Совам. Выделим самых активных, т.е. самых натягиваемых кул-хаками. Набор букв и цифр логина идет примером типичного аккаунта. Взято от балды на основе реальных ACC.

@nifty/NIFTY Corporation;Japan (mlc77666@nifty.com)

BIGLOBE / NEC Corporation;Japan (rzm20882@jp.biglobe)

Internet Way;France (bb007@roamnet.net; name@roamnet.net)

Exodus Communications K.K.;Japan (name@gol.com)

Telstra Bigpond;Australia (name@bigpond.com)

Netvision Ltd.;Israel (name@ netvision.net.il)

Nacamar;Germany (name07@global.nacamar.de)

CommUnity;United Kingdom (name@community.co.uk)

Sannet/Sanyo;Japan (ccd30330@sannet.ne.jp)

Joint Stock Company Omnitel;Lithuania (88842@omnitel.net)

Dream Net/NTT Data;Japan (name-name@mbn.or.jp)

Pronet-Inc. Kft.;Hungary (name@pronet.hu)

Netvein Corporation;Japan (xyz88855@itochu.co.jp)

Atlas Internet Limited;United Kingdom (rtenbmf@atlas.co.uk)

InfoSphere/NTT PC Communications, Inc.;Japan (p66fpjyh@ocn.ne.jp/p66fpjyh@komi.ocn.ne.jp)

So-net/Sony;Japan (name@sk9.so-net.ne.jp/fc5.so-net.ne.jp/qb4.so-net.ne.jp/etc)

Networks On-Line,Inc.;USA (name@nol.net)

CANTV Servicios,C.A.;Venezuela (name@true.net/name@cantv.net)

Neptune Internet Services Inc;Canada (name@neptune.on.ca)

America Online, Inc.;USA (csuser@cs.com)

KDDI Corporation;Japan (b50_85015047@neweb.ne.jp)

Compulink Information Exchange Ltd.;United Kingdom (name@cix.co.uk)

Pagic Net Inc;Taiwan (name@pagic.net)

Fiberlink Communications;USA (name@48sasfcc.com)

VPM Internet Services, LLC;USA (name@intl.vpm.com)

Чего видно тут интересного? ОЧЕНЬ активно юзались аккаунты японских провайдеров, это просто стало новой модой в халяве :). Интересная запись о csuser@cs.com - сие работает из некоторых союзных республик (вроде Украины и Казахстана) для акцесса по логинам AOL. Имея данный список, несложно выйти на всех провайдеров, узнать диапазоны их подсетей... и получать-таки iNet 4free.

Закупка CS`ом

Как же зарегать себе аккаунты, если не удалось их добыть перехватом? Выход есть! Быстро дуй на ftp://ftp.cs.com/cs2000/103911/cs4nt4.exe и утягивай CompuServe Classic 4.0.2. Софтина регистрации весит аж 15 мегов! Но ничего не поделаешь, придется немного попариться, чтобы фришку получить. Скачал, правда? Ну, у тебя и канал, раз за несколько сек все пришло :). С таким и халява не нужна к черту... Те же, кто долго терпел и получил-таки файлик инсталляшки, могут приступать к увлекательному заполнению формочек :). Как все будет готово, получишь аккаунт для CIS`a. Plain-text`ом данное счастье валяется в файлике cis.ini. Рубишь фишку? Правильно, если есть доступ к винту юзвера Compuserve, то не будет проблем с добычей аккаунта из папки с установленным софтом прова. Хотя, как обычно, прокатит и расшифровка pwl`ей. Самым любознательным оставлю наколку для дополнительных наработок: можно телнетом залезть на gateway.compuserve.com и увидеть интересный диалог ;).


Спецвыпуск Xakep, номер #014, стр. 014-025-5, ROL на халяву? Едим дальше!

ROL на халяву? Едим дальше!

Спецвыпуск Xakep, номер #014, стр. 014-025-5

Братья по несчастью

Тяга к халяве - неистребима, за нее идут в расход глобальные корпорации и солидные юзеры. Так не только Совам накачивает геморрой за счет своей космополитичности - под ударом другая контора, UUnet/Compuserve. Ее аккаунты широко известны бывалому пользователю Сети: в далеком 93-м их выдергивали вшитыми из компьютерных игр (типа апдейты, саппорт worldwide по инету через модем :), а позже покупали по генеренным CC. Сейчас волнения стихли. Но наведенный недавно шухер FreeInet`ом показал стойкость халявы. Начинаем прозвон.

В Москве радость, через которую можно заюзать Compuserve`овские аккаунты, прячется за модемным пулом (095)737-0097. Прозваниваемся туда, пометив, что нам надобно открыть окно терминала после соединения. Появляется стандартный диалог Login/Password. Забиваем туда dial@uupops.net как логин и dial@uupops.net как пароль (раньше работали WAN/WAN). Жмакаем дополнительно Enter и... ОБА-НА, выползает приглашение Host:. Забиваем туда CIS. Вылетает следующее приглашение - ввести Compuserve ID. У тебя нет такого? :(. Жаль. Придется надыбать. Как уже говорилось, первый путь - перехватить чей-нибудь аккаунт. Компусервовцы сидят в разных сетях, но парочку можно отметить: 212.211.*.*, 216.192.*.* и 195.232.*.*. Там есть как мертвые сабнеты, так и просто ломящиеся от шаров юзарей. Для любителей Сладких Сушек остался также глобальный баг: в софтине Compuserve Classic до сих пор осталась опция регистрации аккаунтов вида 73071,6666 (здесь цифры после запятой взяты от балды, но они имеют четкую структуру, подробнее можно прочесть в одном из доисторических номеров Phrack`a). Откачиваем чудо софт и делаем свое дело, как было описано выше. В результате должен заполучиться аккаунт. Что с ним делать - уже ясно: вводится в поле CIS ID и юзается до посинения (аккаунты долго не живут, т.к. роуминг у CS стоит нехилых бабок и ID`шки мрут как мухи). Но... не долго музыка играла, не долго хакер танцевал: ввели ограничение на количество сессий по dial@uupops.net, так что надобно поискать запасной вариант! У тебя нет случайно? Если есть, то смело замыливай - бонусы гарантируются ;). Нет? Тогда слушай шеФФа, т.е. меня :). Будем прорываться в Сеть по телефону (095)956-3037. Как и предыдущий, это полноценный V.90-пул, содержащий приличное количество линий. Только тут придется все делать через попу и в результате получить пинг под 1000! Вазелин здесь не поможет, так что придется пробивать небольшой скрипт к соединению. Вуаля, переписывай scp в файлик и сохраняй.


Спецвыпуск Xakep, номер #014, стр. 014-025-6, ROL на халяву? Едим дальше!

ROL на халяву? Едим дальше!

Спецвыпуск Xakep, номер #014, стр. 014-025-6

proc main

port databits 7

set port parity even

transmit "^M"

waitfor "terminal"

transmit "A"

waitfor "log in"

transmit "CML05^M"

waitfor "Name:"

transmit "host^M"

waitfor "UIC:"

transmit "uic^M"

waitfor "Password:"

transmit "password^M"

waitfor "}"

set port databits 8

set port parity none

delay 1

endproc

Вполне понятно, что вместо переменной host надо будет ввести нужный хост (в нашем случае CIS), далее (опять же для нашего случая), возможно, придется немного подправить скрипт под синтаксис CIS`a. Uic - заменит user id, а password - пароль, присвоенный для ID. По-моему все логично :).

Не понравились страшные лаги системы, хреновый прозвон? Не вопрос, суемся обратно в ROL. Тут как раз ребятки намутили работу с тем же логином dial@uupops.net и тем же паролем, как и в (095)737-0097. Здесь возможности значительно ШИРЕ, ибо, при всем умении забивать многотысячные пулы Sovam`a, всегда остается десяток линий для доблестных прозвонщиков. Да и лага тут не наблюдается... Главное - ввести в окне терминала, на авторизации, отмеченный выше Login/Password, и всё OK! Список пулов РОЛа у тебя, я думаю, есть. Остается только иметь CIS`ку... Но если ты все делал правильно до этого, то и она у тебя есть :).

Залетает наш ласковый мишка

Звонок с урока. Сегодняшнее занятие по FreeInet`у закончено, все могут быть свободны. У кого есть совесть и желание познания - смогут ОЧЕНЬ многое доработать, используя инфу данной статьи, выполняя специальные домашние задания, как в "Бойцовском клубе".

Конечно, кому-то info будет не ново (его авторам, например :)) и окажется повторением

увиденного ранее в мануалах провайдеров, услышанного в англоязычных helpdesk`ах и заученного со слов соседа, барыжившего Инетом :). Не без этого... Хочется совсем свеженького? Okay, жди нового номера Х, и будем зажигать дальше!


Спецвыпуск Xakep, номер #014, стр. 014-030-1, Признание в любви

Признание в любви

Спецвыпуск Xakep, номер #014, стр. 014-030-1

Петя Чмошкин (prof@norcom.ru)

есколько способов признания в любви девушке твоей мечты и столько же реакций на эти признания... Естественно, что рассматривать такие простые и банальные приемы, как цветочки, охи и вздохи около фонтана под луной, мы не будем. Мы предлагаем твоему вниманию абсолютно новый взгляд на способы выражения своих чувств (за физические, моральные и другие повреждения, полученные в попытках повторить написанное ниже, автор данной ерунды ответственности не несет!).

1) Быстро подойти мужественной походкой, взглянуть в глаза яростным взглядом и впиться ей в губы.

Реакции:

А) Она, продолжая целоваться, начинает еще более яростно срывать одежду, при этом страстно дыша и, издавая эротические вздохи и охи, опускается на пол вместе с тобой.

Б) Проделывает бросок через бедро с выходом на болевой и контрольным ударом в пах (и это в лучшем случае).

В) Слегка отталкивает, улыбается и нежно говорит: "Не здесь милый!".

Г) Делает яростные попытки вырваться, но потом в конце концов смиряется и уже пытается делать вид, что ей это нравится.

2) Пройти мимо нее и, как будто бы случайно ее встретив, сильно удивиться. Потом завести разговор на какую-нибудь отвлеченную тему и между прочим признаться ей в любви. Звучит примерно так: "Привет, а что ты тут делаешь? Впрочем, не важно... какая сегодня погода хорошая, кстати, я тебя люблю, хммм... завтра дождь будет? Ты не знаешь? Ну ладно, пока..."

Реакции:

Тут может быть две реакции: или она просто не поймет, что ты ей там наговорил, или подумает, что у тебя IQ меньше, чем у полного идиота с лоботомией 3 степени..

3) Дождаться, когда она будет поздно возвращаться домой и, подкараулив, выпрыгнуть из-за угла с криками: "Я тебя люблю, мой ПУПСИК!!!".

Реакции:

Если она после этого не останется заикой или ее не отвезут в больницу с диагнозом "Церебральный паралич всех конечностей и шок 5 степени", то она может отреагировать только ударом сумочкой в лицо, заламыванием левой руки с контрольным ударом в пах.

4) Гордо бежать на коленях за автобусом, на котором она едет домой, при этом громко выкрикивать её имя и бить себя кулаком в грудь.

Реакции:

1) Из-за сильной давки в автобусе она не то что бы услышать, она даже тебя не увидит, и тогда новые джинсы, честно украденные у соседа, будут испорчены напрасно и безвозмездно.

2) Увидев твои старания, она выдавит заднее стекло автобуса и кинется тебя целовать, говоря при этом всякие разные приятные слова (которые обычно тетки говорят в таких ситуациях).

3) Она подумает, что ты полный кретин, идиот, шизофреник и вообще антисоциальный тип, опасный для общественности и для нее в частности! Так как на улице зима, а ты на коленях ползаешь, пытаясь догнать автобус...

5) Можно подложить бомбу в один из реакторов ЛАЭС, потом позвонить ей и сказать, что если она не согласится с тобой встречаться, то будет конец света и взорвется вся галактика!

Реакции:

1) Она просто кидает трубку, говоря при этом разную ерунду, которую я лучше не буду цитировать.

2) Ее возбуждает эта идея, и она просит сказать твои координаты, чтобы вместе нажать на кнопку "ПУСК" во время оргазма на железном столе (для пущего возбуждения температура в комнате должна быть около 0 градусов).


Спецвыпуск Xakep, номер #014, стр. 014-030-2, Признание в любви

Признание в любви

Спецвыпуск Xakep, номер #014, стр. 014-030-2

3) Она определяет твой телефон, вызывает на твой адрес Омон, Спецназ, Интерпол, КГБ, ФБР, морскую пехоту, спецгруппы десантников, инопланетян, группу особо опасных террористов, маньяка-убийцу зеленых крокодильчиков и в конце приезжает сама, чтобы произвести контрольный удар в пах.

6) Можно придумать историю, про то, что, мол, в прошлой жизни ты был шимпанзе, а она антилопой и что вы полюбили друг друга еще с первого взгляда, но из-за физической несостыковки укрепить окончательно свою любовь не успели. И вот вы встретились в этой жизни (нужно обязательно намекнуть, что это судьба!), и у вас теперь одинаковые физические свойства, прекрасно подходящие для продолжения любви из прошлой жизни.

Реакции:

1) Она начинает нервно искать газовый баллончик, но не найдя его, проделывает контрольный удар в пах.

2) Начинает нервно искать газовый баллончик и, не найдя его, проделывает удар левой нагой с разворота, двойной удар в солнечное сплетения и контрольный удар в пах.

3) Зовет своего брата Васю (по кличке Бивень). Брат проделывает все, что могла проделать Маша в п.1 и 2, добавляя при этом в конце контрольный удар коленкой в пах.

4) Проделывает все п.1 и 2 самостоятельно, а потом зовет своего брата Васю, чтобы тот убрал куда-нибудь труп.

5) Начинает убегать, мотивируя это тем, что у "нас с тобой даже в этой жизни физическая несостыковка, так как ты до сих пор остался шимпанзе".

7) Около ее дома на снегу огромными буквами (примерно 20-30 метров) написать ее имя (ну ты понял, чем написать...)! Если не хватит места, то снести близ стоящие дома, чтобы продолжить этот увлекательный процесс.

Реакции:

1) Она так и не догадается, кто это сделал, так как на инициалы у тебя точно место не хватило.

2) Подумает, что это инопланетяне ночью написали ее имя, намекая таким образом, что они все про нее знают. Она пугается и уезжает жить в Файзабад (что около Северной Гваделупы).

3) Она узнает, кто это сделал, и проводит контрольный удар в уже и без того опухший и почти бесчувственный от стольких ударов пах.

4) Она узнает, кто это сделал, и, уставши тебя бить, смиряется и соглашается встречаться.


Спецвыпуск Xakep, номер #014, стр. 014-032-1, Хорош просиживать штаны или даешь экстрим!!!

Хорош просиживать штаны или даешь экстрим!!!

Спецвыпуск Xakep, номер #014, стр. 014-032-1

Экстремальный отдых вдали от компьютера

Лазькома (lazkoma@au.ru)

Слушай, а тебе когда-нибудь

приходили в мудрую голову мысли о том, что приобрести авторитет у девчонок (да и не только у них) можно не только сидя перед своим родным, со светящимся экранчиком, компьютером.

Делаем из действительного желаемое

Сидишь, понимаешь, с бутылочкой родного пенящегося напитка (неотъемлемым атрибутом сего момента обязательно явлются:

а) голые, волосатые, абсолютно замерзшие ноги без носков;

б) крошки чипсов, печенья, ну, в общем, что Бог послал накануне к пиву и друзьям, пришедшим в полном составе полюбоваться на вновь приобретенный модный девайсик;

в) полное отсутствие какого-либо присутствия порядка и чистоты, и посреди всего этого хаоса не очень-то довольная куколка, которая ну явно должна была бы быть очарована всем профессионализмом и крутостью твоих изречений и образом жизни твоей! Нда, а ты-то уже видел себя в окружении приятелей, умоляющих поделиться секретом и умением "как красоток завораживают"...

А теперь представь картину: ты, в классном прикиде, на фоне сверкающих снежных вершин (даже если сначала это будут какие-нибудь псевдо-горки типа "как это у нас называется - ямка?"), на ногах сноубординые или горнолыжные боты, а вокруг - рой восхищенных девчонок, замирающих при каждом твоем движении и взгляде. А твоему взгляду есть что окинуть и оценить: вот например, трамплин "биг-эйр" или тот склон, который кажется таким обманчиво пологим, и только тебе как известному горнолыжнику, или еще круче - фристайлеру - известны все коварные извилины и повороты! Ну, прямо рыцарь в сверкающих доспехах, да и только!

Моя цель - сделать вышеперечисленное правдой, ну или хотя бы приблизить желаемое к действительному. Конечно, не в моих силах превратить взмахом волшебной палочки тебя в крутого ски-кроссера из неспортивного, с атрофированными мышцами "типа, пацана" с умной головой на тонкой шейке. Только ты сам сможешь приблизиться к заветному идеалу, ну а я... я посоветую как сделать ЭТО, где сделать ЭТО и почём нынче быть крутым и модным.

Сразу оговорюсь: так как ты намереваешься стать самым крутым, самым экстремальным хакером, который не только пальчонками умеет в клавиатуру тыкать и умные словечки своей 90-летней бабушке за домашним (с лапшой) супчиком с умным видом выкладывать, то речь пойдет именно о них, о самых популярных зимних экстремальных видах спорта. Нет, ты не так понял - с горы на санках впятером после дружных и обильных возлияний с приятелями - это конечно тоже очень экстремально, но не с той стороны, с который мы с тобой на это смотрим. Я имею в виду настоящие экстремальные штучки, от которых дух захватывает так же... ну хорошо, почти так же, как от нового супернавороченного девайса для твоего компа. От которых вот та брюнеточка (блондиночка, рыженькая, да даже если лысенькая - кому какое дело, если она тебе нравится, ну вот нравится и все тут - никуда не денешься, хотя для такого будущего экстремала бритая чикса, как эта - даже очень прикольно), на которую ты уже ну очень давно поглядываешь, просто выпадет в осадок и помчится на крыльях любви прямиком к тебе с вопросом... с каким вопросом? Ну, например, "как пройти в библиотэку"? Для того чтобы это произошло, давай посмотрим, что мы можем сделать.


Спецвыпуск Xakep, номер #014, стр. 014-032-2, Хорош просиживать штаны или даешь экстрим!!!

Хорош просиживать штаны или даешь экстрим!!!

Спецвыпуск Xakep, номер #014, стр. 014-032-2

"Могул", "Бордер-кросс", и как их можно использовать по назначению

Итак, с чего начнем? Думаю, что для такого крутого мена, как ты, не секрет, что такое горные лыжи и сноуборд, а также зачем вообще человечество всех возрастов с сумасшедшей скоростью во всем мире носится с гор, улюлюкая, припрыгивая, да еще и успевает нарядами сверкнуть. Все это для тебя не новость, поэтому поговорим о более крутых вещах, например могуле или бордер-кроссе. Конечно, если с "бордер-кроссом" еще можно провести какие-то параллели, то с "могулом" получается не очень. Скорее всего, на ум придет нечто неприлично-хаотичное, например, что "могул" - это вообще что-то такое быстрое и мощное и верткое, хотя на самом деле все гораздо проще и круче. Не волнуйся, счас все по полочкам разложу, объясню, да так, что самый передовой из передовых не сможет лучше тебя рассказать - а зачем вообще все это нужно, ну этот, как его?? Могул, что ли?

"Могул", один из самых загадочных для нас тобой видов. Ты наверняка видел не раз по телевизору парочку таких веселеньких людей, не совсем здоровых на голову, которые стоя не просто на лыжах, а на горных лыжах, умудряются мчаться по склону казалось бы только и состоящему из бугров, смешно сгибая коленки и припрыгивая. Так вот, именно это и называется "могул" - катание на горных лыжах по бугристому, даже очень бугристому склону. Трудность этого вида заключается в том, что в отличие от гладкого склона, на котором ты можешь контролировать угол поворота, на бугристом склоне это сделать гораздо сложнее из-за тех самых пресловутых бугров. Освоив сам могул, ты сможешь продвинуться еще выше и смотреть гораздо выше на своих непродвинутых друзей, если освоишь так называемый фристайл могул - некую смесь фристайла (это ты видел, когда на лыжах кувыркаются да еще и прыгают с трамплина) с могулом - т. е. мало прыгать и вертеться, надо мчаться с горы по буграм, прыгать через трамплин, да все это еще и на время. Да еще и рядом с тобой летит такой же экстремальный товарищ.

Говоря о сноуборд бордер-кросс и сноуборд биг-эйр, можно громко и отчетливо произнести: "Все для экстрима, все для победы", потому что увидя себя, совершающим головокружительные прыжки с трамплина и несущимся по склону навстречу... (хм, вот здесь уже только от тебя зависит навстречу чему ты помчишься на огромной скорости) и заснятым на видео, ты услышишь именно эти восклицания со стороны восхищенного окружения! Бордер кросс - это ты и еще трое твоих друзей лузеров (почему лузеров? - а потому что позади тебя мчатся:)!), которые несутся по склону на сноуборде по буграм, еще и прыгая через трамплины, перегоняя друг друга. Ну а сноуборд биг-эйр - это когда ты слетаешь вниз и прыгаешь с трамплина на специальную площадку. Здесь главное - не сломать шею и проследить, хорошо ли закреплены ботинки, а то вот недавно наблюдала недавно за одним "чайником прыгающим" (это вид такой новый учеными выведен:)), так он не проверил, как все застегнуто, и во время прыжка весь гардероб по площадочке-то пресловутой и разложил - все в чем был, начиная от доски и заканчивая ботинками (вот уж их потерять очень сложно!). Но все вышеперечисленное тебе явно не грозит, так как ты товарищ внимательный и, конечно, высокопрофессиональный - уж падения так низко ты не допустишь:)).


Спецвыпуск Xakep, номер #014, стр. 014-032-3, Хорош просиживать штаны или даешь экстрим!!!

Хорош просиживать штаны или даешь экстрим!!!

Спецвыпуск Xakep, номер #014, стр. 014-032-3

Собираем снарягу

Да, спросишь ты, все это конечно круто, но вот как быть с оттянутыми на коленках от постоянного сидения перед компом трениками и полным отсутствием какого-либо снаряжения? Не переживай, для начала тебе понадобятся лишь хорошие штаны для сноуборда - мягче падать от этого не будет, зато пятую точку сохранишь в сухости без памперсов:), а по первости твоя "мягкая подружка" будет тебе очень помогать, так как сидеть придется именно на ней. А вот сверху могешь и свитерок старенький нацепить - главное, чтобы тепло было.

Для будущих знатных фристайлеров - могулистов посоветовала бы приобрести шлемак, да такой, чтобы помог сберечь голову - это у нас с вами, братья, самое ценное что имеем! Все вышеперечисленное ты можешь купить во множественных магазинах, которые предлагают огромный ассортимент для таких как ты - различную одежду, защиту, специальную обувь и прочие интересные штучки. А снаряжение ты всегда можешь взять в аренду в прокате - на всех более-менее оборудованных склонах есть прокат, как лыж, так и сноубордов с полным комплектом, т. е. с ботинками и палками (для будущих покорителей-лыжников).

И где же ты, знатный спортсмен, можешь применить свои умения? Ну, если пока тонкий кошелек не позволяет попрыгать с вертолета в Альпах или Колорадо, то обойдись для начала родными московскими горками, например, Крылатскими Холмами или горой на Нагорной, а можешь еще свалить в Подмосковье - в наверняка тебе известный Волен (в котором проводятся различного рода экстремальные турниры), Парамоново, Тарасово и другими. Цены на прокат и подъемники немного кусаются, но кто сказал, что будет просто? Экстремалы не ищут легких путей - на то они и экстремалы!

Хроники пикирующих сноубордистов

Кстати, по поводу турниров: хоть мы и не впереди планеты всей здесь, но свои кадры имеем и выставляем напоказ с очень даже большой гордостью. Подтверждением тому стал недавно проведенный праздник зимних экстремальных видов спорта в спортивном парке "Волен" под названием "X-Winter '2001". В течение всего дня можно было поахать и поохать над состязаниями сильнейших спортсменов нашей необъятной Родины (да, кстати, не только необъятной, среди сноубордистов-призеров каким-то образом затесался даже один представитель Швейцарии), которые соревновались в самых экстремальных и прогрессивных видах: фристайл могул, сноуборд бордер-кросс, сноуборд биг-эйр и других видах. Все соревнования проводились в несколько этапов, что, впрочем, не мешало завзятым лыжникам и сноубордистам, не участвовавшим в празднике, поездить в свое удовольствие.


Спецвыпуск Xakep, номер #014, стр. 014-032-4, Хорош просиживать штаны или даешь экстрим!!!

Хорош просиживать штаны или даешь экстрим!!!

Спецвыпуск Xakep, номер #014, стр. 014-032-4

После объявления мест, раздачи слонов, множественных улыбок, а также огромного количества халявного Клинского пива, "Майского чая" и музыки радио "Максимум" (еще один повод бывать на таких праздниках!) в небе расцвел фейверк. Да, кстати, как самый экстремальный и прогрессивный, Х не остался в стороне и тоже принял деятельное участие в освещении этого красочного действа.

Как упомянули организаторы этого праздника "только избранные могут считаться настоящими экстремалами, только те, кто умеет преодолеть самого себя и постоянно стремится к этому снова и снова". Вот-вот, и я об этом - не каждому дано прыгать с заснеженного склона вдоль отвесной стены, да и еще получать удовольствие, ну, может быть, только тебе.

Есть, конечно, еще такая вещь, как ледолазание, скалолазание в зимний период:) и прочее, но это пока нас не касается - это уж совсем для экстремалов, для людей, к которым мы с тобой, спасибо судьбе, не принадлежим, хотя кто знает, может, после того как ты покоришь снежную целину Приэльбрусья, а того гляди и Гималаев, то, может, и к ледолазанию проникнешься... может быть... когда-нибудь... следующей зимой!!!

Пы. Сы.

Если ты думаешь, что мы готовим сани летом или просто являемся дебилами, которые не в курсе, что снега за окном давно нет, то ты круто ошибаешься. Просто мы знаем, что настоящим экстремалам нет пределов, и встретиться с ними (и с нами) можно в Волене, на Домбае, в Альпах, Кордильерах, Андах, Пиренеях, на Рижском взморье, в Бискайском заливе, в песках Сахары и в лесах Подмосковья. А всё это оттого, что для настоящих экстремалов границы и рамки отсутствуют!

1

Изначально пугающее название. Первые рекламные плакаты и флаеры, обязательно несли образ свалки битых, старых автомобилей. Клуб акцентирует внимание на собственном


Спецвыпуск Xakep, номер #014, стр. 014-036-1, вСТУПАЙ В ПРОФСОЮЗ!

вСТУПАЙ В ПРОФСОЮЗ!

Как заджойниться

Спецвыпуск Xakep, номер #014, стр. 014-036-1

в хак-группу

LohKiller (loh.killer@pupsik.ru)

А ты записался в хак-группу? Нет? А зря! Так как хак-группа - это сила, мощь информационная. И осознавая, что ты являешься частичкой этой самой <мщи>, ты будешь чувствовать себя сухо и комфортно =).

Пытаться в одиночку поломать нелюбимый сайт, это конечно интересно и занимательно, но, как говорится в одной байке, <один в поле не перец>.

Реально, представь себе картину - канал #malaisiafeminists на IRC, там собирается веселая компаха, выбирается жертва и далее только видны короткие реплики:

<ооо /cgi-bin/xxxpx.cgi дырявый>

<цензура>

<ооооо юзер nobody мой!!>

<мат>

<оооооо готово!! su=djazizum!>

<Ну, кто тут у нас вебдезигном балуется??? Аудитория в 100 тыс. устроит? ;))>

Весело? Надо объединять усилия, тогда будет еще веселее.

Нами, т. е. сертифицированными специалистами (сертификат №XНЯ666) журнала Хакер были отобраны 5 отечественных наиболее активных и продвинутых хакерских групп, в которые наши эксперты пытались вступить. Заранее следует отметить, что мы пытались вступать в группы единовременно - 1 апреля 2001 года, что могло наложить определённый отпечаток на некоторые описанные события ;).

Итак, чей же Звёздный Час сейчас настал:

UkR - Украинские Рейнжеры

Наиболее авторитетная хакерская команда на сегодняшний момент, на счету более 100000 (короче, много) взломов (в том числе - проникновения в компьютеры ФБР, МИ6 и ФСБ), главарь UkR (Уголовные Короли России или УкРопы) и основатель XbIP - Хирург, человек при упоминании имени которого посетителей чатов и интернет-кафе бросает в холодный пот, человек который стоял у истоков развития российского Интернета, но был уволен за скачивание порнухи, озлобился, ознобился и решил мстить.

Сайт группы: http://www.ukrteam.ru

Итак, пытаемся вступить!

Заходим на их официальный канал на DalNet #ukr

хай

йо! народ, можно вступить

в вашу группу?

гы

а что ты из себя представляешь?

а зачем тебе это надо?

и кто ты?=)

(Хм, сразу много вопросов, напоминает талантливого рэпера Децла 'Кто ты?!', но это нормально и вполне объяснимо ;)), наверно, не каждый день к ним приходят и вот так сразу...)

хех, в смысле?

в прямом

хорошо знаю win95 , нюки, флу-

деры и атаки на icq и веб-чаты

да просто интересно работать в

группе, чем одному

хех

а что ты сделал?

в смысле статьи/программы/

эксплоиты?

проги есть свои на VB и html

какие?

вот недавно совсем написал

программу порт сканнер

на visual basic'e и нюкер!

гы

неплохо - под какую OS?

под Windows и ZlobiX

а лет тебе сколько?

13

хех, ровесник

(Далее меня пригласили на приватный засекреченный канал, где сидели отцы группы, которые собирались устроить мне перекрестный допрос/расспрос.)

к нам человек хочет

во

dc`` - расскажи сейчас то

что ты мне рассказал

эй, люди

хорошо знаю win95 , нюки, флу-

деры и атаки на icq и веб-чаты


Спецвыпуск Xakep, номер #014, стр. 014-036-2, вСТУПАЙ В ПРОФСОЮЗ!

вСТУПАЙ В ПРОФСОЮЗ!

Как заджойниться

Спецвыпуск Xakep, номер #014, стр. 014-036-2

dc`` - это твой ник?

dc - digital chaos ;)

dc'' хочет к нам

расспросите его

а потом я задам пару вопросов

и решим

dc - что насчет НТ?

да НТ я круто знаю, почти гуру

ok

sfer'e я уже говорил... из

релизов у меня есть свой порт

сканер и нюк

<\silence> Круто!!!!! Мы тебя возьмем!!!

<\silence> dc``, а можно ее посмотреть?

гмм куда закинуть?

dc`` я, кстати, UkR-XblP,

фаундер UkRteam =)

хых ;)

<\silence> dc`` - кинь мне

какой адрес?

давай уж тогда всем

:)

<\silence> silence@ukrteam.ru

rayd@ukrteam.ru

root@ukrteam.ru

=))

кинул

<\silence> k

ну так что?

во - идея! испытательный срок =))

хых

ага

хорошая идея

;)

короче, ты принят!

Итак, мы приняты... для вступления в эту группу необходимо иметь какие-то работы, не дефейсы, а найденные лично тобой новые баги, эксплоиты и др. программы. Хотя основные члены группы не отличаются особым знанием программирования (кроме perl'a и бейсика) ;), очевидно, они хотят, чтобы в группу вступали люди знающие больше их, для того чтобы их самих немного подучили.

IHG - Интернациональная группировка хэккеров

Данная группа, я думаю, в представление не нуждается. Наверно, все читатели знают о них по таким нашумевшим взломам, как, например, взлом http://hacker666.chat.ru и http://cablewarez.da.ru. Не меньшую популярность им принесли проги <ПортСкэнер> и <Майлбомбер>, которыми пользуется очень большое число нашего народу ;). Остается сказать, что в данный момент группа работает над новым коммерческим продуктом, имеющем рабочее название NukeXP.

Сайт группы: www.ihgroup.ru

привет! народ, вообще

реально в вашу группу

вступить?

да, если ты пройдешь

тестирование!

согласен

ладно, начнем! Серега, опроси

человека

ок, тока файл с вопросами

открою

1. что такое Linux?

операционка для ламеров

ок

2. кто придумал Интернет?

ситилайн

3. что такое %00 в перле?

нул-бит (этот баг UkR нашли)

4. как хакать сервера?

как это как? ты чо, изде-

ваешся? конечно, через

шары и Unicode баг....

5. на чем основаны атаки

типа smurf?

на использовании прото-

кола icmp и диал-апного

соединения

окей, все ответы правильные,

кроме...

WithOutBrain: ну чего, возьмем

его?

да, конечно... ну для начала ты

должен задефейсить сайт

какой-нибудь

окей - 5мин

(Быстро зайдя на netfirms.com, я зарегистрировал сайт ShopOnline.netfirms.com, закачал страницу, где было написано: <][AKED by bIzIDuk [IHG])

готово, http://ShopOnline.

netfirms.com

окей, ты принят

Nitr0gear

Эти ребята совсем недавно появились на российской хак-сцене, но уже успели зарекомендовать себя, как вполне квалифицированная команда профессионалов, отлично знающих свое дело. Наконец-то открылся сайт этой команды, где они смело (не трухая, как другие, перед ФСБ) предложили свои услуги официально и вполне за умеренную плату ;)). Постоянными клиентами этой команды стали такие известные компании, как Microsoft, Cityline, ZlobTelecom и др.


Спецвыпуск Xakep, номер #014, стр. 014-036-3, вСТУПАЙ В ПРОФСОЮЗ!

вСТУПАЙ В ПРОФСОЮЗ!

Как заджойниться

Спецвыпуск Xakep, номер #014, стр. 014-036-3

Сайт группы: http://www.nitrogear.org/

Итак, узнаем их месторасположение в ИРЦ, джоинимся на #NitrOnigga

I am nigga, who are you?

f4ck j00! Otvali gryazniy negr!

Переджоиниваемся на #NitrOgear

хай

йо

чо надо?

я хотел бы вступить в

вашу группу

а на фиг тебе?

что ты умеешь?

одному скучно - в компании

веселей

короче, кончай сопли

размазывать, говори, что

умеешь

кодить, Windows крякать,

cgi-скрипты писать, Unix

немного ... еще?

а на чем кодишь?

ты, что уснул там чтоли????

C, perl, basic (когда-то в школе)

и что ты написал?

портсканер, эксплоиды там

всякие

эксплоиды? какие, что делают?

Windows вешают, mirc слетает

да я вижу, ты гуру, кинь-ка мне

свой варез

ну как?

*** Quits: djc0ck (dj@nitrogay.org) (Ping timeout)

работает ;)

ладно, подумаем

// -= на следующий день =-

хай! так берете?

да

круто

Ну что, сложно? Немного терпения, удачи, и главное - скачать где-нить хороший нюк :).

GiN - Призраки (Гоблины) в Сети

В старые былые времена эта команда давала жару даже таким мэтрам российской сцены, как UkR и IHG, но в последние время они стали сдавать позиции в области взлома и трейдинга вареза. Это связано с тем, что главаря данной команды, z00mk1ll'a, уже около трех месяцев держат в Матросской Тишине органы правопорядка за распитие спиртных напитков в общественном месте и хулиганство.

На встречу с Призраками отправился наш проверенный мембер, член-корреспондент, отсидевший не меньший срок в районной психиатрической больнице города Урюпинска, Арви Собутылыч Ксакеп. Вот его рапорт:

Коннекчусь на #ghostinnet

h00 j00?

<-=Asx=-> что?

кто ты, твою мать?

<-=Asx=-> я крякер, хотел бы

присоединиться к вам

ты что сдурел, ща мы тебя

прям так и взяли;))))

что крякал?

<-=Asx=-> ну ACDSee, Photoshop, FAR

ты что, нас за лохов

принимаешь? FAR бесплатный!

ну ладно, что еще умеешь?

<-=Asx=-> программирую на C++

что именно

<-=Asx=-> нюкеры, портсканеры,

флудеры, трояны

это уже круче, так бы сразу

жаль, нет главного, слышь,

баклан, а ты знаешь юникс?

<-=Asx=-> немного

как немного? что такое ?

<-=Asx=-> выдает список процессов

он прав?

хз, мне главный что-то говорил -

не помню

ладно возьмем! кинь мне свой

мейл

<-=Asx=-> круто!

<-=Asx=-> asx2kHack@lohotron.ru

Миссия выполнена.

Видишь как просто, немного знаний и ты, можно сказать, в хак-группе, среди действительно крутых парней! :)


Спецвыпуск Xakep, номер #014, стр. 014-036-4, вСТУПАЙ В ПРОФСОЮЗ!

вСТУПАЙ В ПРОФСОЮЗ!

Как заджойниться

Спецвыпуск Xakep, номер #014, стр. 014-036-4

CYberHackers2k

Эти перцы известны, прежде всего, своими заморочками в области исследования сетевых технологий, и хотя их деятельность вполне легальна, известны случаи взлома крупных российских научных серверов (в основном, VAX'ы, c OS OpenVMS) с целью похищения отечественных разработок и продажи их за рубеж. Одна из таких утечек - технология передачи информации по обычным электросетям, разработанная в одном из НИИ, с очень умными, но не очень осторожными сотрудниками, впоследствии проданная англичанам. По слухам, лидер и организатор CBH4k (Mr. InReD) является единственным в России частным владельцем подержанного Cray J90, чем и гордится.

Вот чем окончилась попытка вступления в эту группу:

<их канал на Efnet'e>

zdarova pplz!

ummm ti kto?

nu ya vot hochu v vashu gruppu

vstupit', eto voobshe vozmozhno?

kakuyu eshe gruppu nah? :D

(Я - не я, и лошадь не моя ;))

nu tut est kto-nit' iz CBH4k?

eheeh, nas nashli ;]]], ladno ty

courierom ili kak? nam nuzni

T1+ siteops

muaha, ou boy!

ya vashe-to po setyam spec, hochu bit vashim memberom, horosho

znayu ustroistvo windows95 i winNT!

nu i narod walit..

*** ViruX was kicked by guest666 (otdohni)

*** guest666 sets mode: +b *!*@*.gay-pics-gateway.cityline.ru

В общем, попасть в хак-группу не такая проблема, если на твоих плечах голова, а не дырявый сифон со свалки :). Так что попробуй, и если ты добрался до этих строк, ты, можно сказать, на полпути в хак-группу. Счастливо! :)


Спецвыпуск Xakep, номер #014, стр. 014-040-1, Защити cвою собственность!

Защити cвою собственность!

Спецвыпуск Xakep, номер #014, стр. 014-040-1

Ограничение доступа к файлам, папкам и разным устройствам

Horrific (smirnandr@mail.ru; www.x-c-r.com)

Я не параноик и никогда не болел манией преследования. Но, несмотря на это, я всегда защищаю свою собственность. Особенно мой труд, за который я получаю деньги. Я не хочу, чтобы какой-нибудь чел стибрил мои документы или исходники прог, а потом использовал их в своих целях. Если ты думаешь, что тебе нечего защищать, то ты крупно ошибаешься. Комп с доступом в Инет обязательно содержит пароли. Ты же не будешь помнить все параметры соединений, когда можно создать файл и хранить все там. А Минздрав предупреждает: "Хранить пароли в файлах опасно для вашего здоровья". Но это все исправимо, если правильно защищать файлы.

Если к твоему компьютеру имеет доступ несколько человек, то защищаться нужно более бдительно. Я понимаю, что ты можешь доверять своей подруге, и она никогда не будет использовать твой приват. Но защищаться все же нужно, чтобы она случайно не испортила данные или, хуже того, не посмотрела в хистори, о чем ты болтал с другими подругами в ICQ.

Причем защищаться необходимо не только от других, но и от самого себя. За моим компьютером работают 5 человек (родители, жена, брат и я), а данные уничтожаются только по моей вине. Особенно, когда просидишь за монитором 14 часов, руки сами удаляют все что нужно и не нужно :). Если я тебя убедил, то давай посмотрим, что есть интересного в мире крутой защиты нашей не менее крутой собственности.

Boot Drive Lock

www.crashcoursesoftware.com

Я начал обзор с этой проги, потому что она защищает твой комп от загрузки. После установки Boot Drive Lock переписывает загрузочный сектор так, что он грузит сначала защиту, а уж потом ОСь. Это, конечно, хорошо, если ты не юзаешь *nix. Потому что Boot Drive Lock перезапишет LILO, и *nix ты сможешь загрузить только с дискеты.

Так что эта софтина подойдет только win-юзерам, которым "эти ваши линухи" на фиг не нужны.

Итак, когда ты запускаешь прогу, перед тобой появляется простейшее окно. В нем есть пара переключателей, чтобы включить (Boot Drive Lock Enable) и выключить (Boot Drive Lock Disabled) работу тулзы. Чуть ниже есть еще параметр: "Требовать пароль при загрузке системы" (Require password to boot system). Все. Прога проста, но работает отлично. Единственное, что может обойти прогу, так это загрузочная дискета. Но это не проблема. Ты же можешь ограничить доступ и к floppy или вообще запретить загрузку с дискеты. Примечание!!! После удаления Boot Drive Lock твой Linux сможет снова грузиться с винта, потому что Boot Drive Lock возвращает LILO на родину.

Windows Security Officer

http://members.xoom.com/winsecof/officer.html

Нехилая прога от Женьки Михайлова. Прежде чем ее расписывать, хочу предупредить, что у тебя могут возникнуть проблемы с download-адресом. В момент написания статьи существовало несколько проблем.

Во-первых, xoom.com уже переименовался в nbci.com, хотя старые адреса поддерживаются. Во-вторых, нынешний владелец халявного хостинга nbci.com стал проверять все сайты и закрывать любой warez. Меня они уже прикрыли, и Женьку может постигнуть та же участь. Так что, возможно, придется поискать прогу через www.download.com или другой поисковик. А искать нужно, потому что прога этого заслуживает.


Спецвыпуск Xakep, номер #014, стр. 014-040-2, Защити cвою собственность!

Защити cвою собственность!

Спецвыпуск Xakep, номер #014, стр. 014-040-2

Windows Security Officer состоит из двух утил: Security Officer и Lock Desktop. Lock Desktop помещается на рабочий стол. Когда ты покидаешь компьютер, кликни по иконке, и все заблокируется, пока ты не введешь пароль. Так что не надо ожидать появления хранителя экрана.

Вторая тулза - Security Officer позволяет ограничить доступ к громадному количеству параметров системы, таких как "Панель управления", "Сеть", "Настройки видео", "Принтеры". Настроек немерено, и они разнообразны. Есть такие возможности, как ограничение доступа к дискам и CD-ROM. Если у тебя к компьютеру имеет доступ несколько человек, то для каждого из них можно назначить свои настройки, т.е. создать профайлы. А главное, ты можешь указать время, в которое пользователь имеет право работать с компом. Так что Windows Security Officer наделяет твой Win9x некоторыми возможностями безопасности Windows NT.

Protector2

http://members.xoom.com/dolinaysoft/

Эта прога также наделяет Win9x некоторыми возможностями NT. У нее есть та же проблема с адресом, так что будь внимателен. Если Security Officer ограничивал доступ в основном к настройкам и дискам, то Protector2 ограничивает доступ к файлам и папкам. Хотя здесь тоже есть ограничения, схожие с Security Officer, но их очень мало. После запуска проги перед тобой появится простенькое окно с небольшим количеством кнопок. Судя по кнопкам, возможностей мало, но стоит нажать на самую большую из них - "Admin", как ты попадаешь в другое окно, богатое настройками.

Окно состоит из нескольких закладок:

User account - на этой закладке ты можешь добавлять/удалять пользователей и назначать им пароли.

UserRights - Здесь та назначаешь права на использование папок и файлов. Для этого выдели пользователя и нажми кнопку Add. В появившемся окне ты сможешь указать папку и права на ее использование.

System Policy - Политика доступа к системным переменным. Это краткий вариант настроек, доступных в Security Officer.

Preferences - Дополнительные настройки безопасности.

Folder Guard Jr

www.winability.com/fgjr/

Очень простая и удобная прога. Она предназначена для скрытия папок от постороннего взгляда. Просто выбираешь папку и жмешь Hide. После этого никто не сможет увидеть твою собственность. Если ты забыл пароль, то для таких беспамятных есть маленькая прога Reset Password в менюшке Folder Guard Jr. Запусти ее, и пароль сбросится.

Folder Guard Jr не может защитить файлы в DOS-режиме. Если загрузиться в DOS, то все файлы и папки будут прекрасно видны.

BCWipe

www.jetico.com

Прога для окончательного уничтожения файлов с винта. Ты должен знать, что при удалении файлы физически остаются на твоем винте, стирается только первая буква названия файла, и таким образом файл помечается как удаленный. Если после удаления ничего не было записано в эти кластеры, то такое файло можно восстановить (простейшим undelete). BCWipe производит окончательное удаление, затирая сектора, в которых располагался файл (этот процесс называется - wipe). После установки этой софтины при клике правой кнопкой по файлу в меню будет новый пунктик: "Delete with wiping".


Спецвыпуск Xakep, номер #014, стр. 014-040-3, Защити cвою собственность!

Защити cвою собственность!

Спецвыпуск Xakep, номер #014, стр. 014-040-3

PTS Strong Disk

www.PhysTechsoft.com/en/StrongDisk

Напоследок я оставил самую крутую прогу (на мой взгляд), которая обязана присутствовать в твоем арсенале. С помощью нее ты создаешь защищенный виртуальный диск, на котором можно будет хранить свои сокровенные данные. Виртуальный диск может шифроваться с помощью основных, доступных на сегодня алгоритмов шифрования: 3DES, CAST 128, SAFER, Blowfish. Для защиты пароля используются распространенный MD5 и SHA.

Несмотря на то, что виртуальный диск шифруется, он выглядит в системе как любой другой диск. Такой диск можно сделать доступным даже через сеть. PTS Strong Disk прост как три копейки. В нем нет ничего сложного. В окне проги есть только две кнопки: Create - для создания защищенного диска, и Mount - для монтирования его к системе. После нажатия на пимпу Create тебе предстоит ответить на несколько вопросов, и диск готов. Виртуальные диски выглядят как простые файлы с расширением grd. Что это дает? А то, что легче осуществлять резервное копирование. А главное, ты без проблем можешь перенести этот файл на другой комп и примонтировать его там. Правда, для этого на компе должен быть установлен PTS Strong Disk.


Спецвыпуск Xakep, номер #014, стр. 014-042-1, История операционных систем

История операционных систем

Topuk (torick@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-042-1

Мы продолжаем начатую в первом номере традицию ликбеза. Как ты помнишь, тогда я рассказывал тебе про то, откуда протянулся Интернет. Сегодня, приятель, ты узнаешь о том, какие операционки, когда и из-под чьих рук вышли, распространились и вообще стали известны.

Т. к. свои ОСи (особенно после появления фриварных юниксоидов) не писала только совсем уж ленивая тусовка системных программистов, то к нашему времени количество этих самых ОСей стало переваливать за рамки разумного. Поэтому мы решили отрубить расплодившихся Юниксоидов и написать про те системы, которые хоть чем-то способствовали развитию различных платформ (ставку мы все же делаем на PC). Начнем мы с наиболее древних ОСей, о которых сохранилась хоть какая-то информация...

Multics (aka MAC)

Итак, все началось в далеком 1965-м... Четыре года компания American Telegraph & Telephone Bell Labs (далее просто Bell Labs) совместно с фирмой General Electric и группой исследователей из Масачусетского технологического института творила проект OS Multics (также именуемый MAC - не путать с MacOS). Целью проекта было создание многопользовательской интерактивной операционной системы, обеспечивающей большое число пользователей удобными и мощными средствами доступа к вычислительным ресурсам. Эта ОСь основывалась на принципах многоуровневой защиты. Виртуальная память имела сегментно-страничную организацию, где с каждым сегментом связывался уровень доступа. Для того чтобы какая-либо программа могла вызвать программу или обратиться к данным, располагающимся в некотором сегменте, требовалось, чтобы уровень выполнения этой программы был не ниже уровня доступа соответствующего сегмента. Интерпретирую: если бы старый добрый Notepad находился в некой файловой/системной Зоне-2 (имеющей уровень доступа 2), а залогинившийся в систему пользователь имел доступ уровня 1, то хрен бы он ее запустил. Соответственно, сисадмин имел доступ ко всем сегментам. Также впервые в Multics была реализована полностью централизованная файловая система. То есть, даже если файлы находятся на разных физических устройствах, логически они как бы присутствуют на одном диске. В директории же указан не сам файл, а лишь линк на его физическое местонахождение. Если вдруг файла там не оказывается, умная система просит вставить соответствующий девайс. Помимо этого, в Multics наличествовал большой объем виртуальной памяти, что позволяло делать имэйджи файлов из внешней памяти в виртуальную.

Увы, но все попытки наладить в системе относительно дружественный интерфейс провалились. Было вложено много денег, а результат был несколько иной, нежели хотелось бонзам из Bell Labs. Проект был закрыт. Кстати, участниками проекта значились Кен Томпсон и Денис Ритчи, о которых мы еще вспомним.

UNICS (aka UNIX) и семейство

Считается, что в появлении Юниксоидов и Юникса в частности виновата... компьютерная игра (да, Шурик Сидоровский, именно так!). Дело в том, что Кен Томпсон непонятно чего ради создал игрушку . Он написал ее в 1969 году на компе Honeywell 635, который использовался для разработки Multics. Но фишка в том, что ни вышеупомянутый Honeywell, ни имевшийся в лаборатории General Electric 645 не подходили для игрушки. И Кену пришлось найти другую ЭВМку - 18-разрядный компьютер PDP-7. По ходу дела Кен с ребятами разрабатывал новую файловую систему, дабы облегчить себе жизнь и работу. Ну и решил, раз уж пошла такая пьянка, опробовать свое изобретение на новенькой машине. Опробовал. Просто на ура. Весь отдел патентов Bell Labs дружно радовался. Томпсону этого показалось мало и он начал ее усовершенствовать, включив такие примочки: понятие inodes, подсистему управления процессами и памятью, обеспечивающую использование системы двумя пользователями в режиме TimeSharing`а (разделения времени) и простой командный интерпретатор. Кен даже разработал несколько утилит под систему. Собственно, сотрудники Кена еще помнили, как они мучались над осью Multics, поэтому в честь старых заслуг один из НИХ - Брайан Керниган - решил назвать ее похожим именем - UNICS (Uniplexed Information and Computing System). Через некоторое время название сократили до UNIX (читается так же, просто писать лишнюю букву Настоящим Программистам во все времена было лень). Но, к сожалению, изобретение, как это часто бывает, уперлось в трудности материального плана. Во-первых, PDP-7 было арендовано отделом, а не куплено, и рано или поздно пришлось бы его отдавать, а во-вторых, операционка разрослась настолько, что системных ресурсов уже старенького по тем временам компьютера ей не хватало. Поэтому в 1971 году Кен с ребятами скинулись и купили более совершенный Digital Equipment PDP-11/20, на который и перенесли свою последнюю модификацию UNIX. Если учесть, что ОС была написана на ассемблере, а физически взять и перенести весь этот код было невозможно, ты можешь себе представить, сколько времени бедный Томпсон с друзьями писал эту чертову систему. Зато PDP-11 без проблем поддерживала большое количество залогинившихся пользователей, да к тому же позволила, наконец, написать простенький интерпретатор текстового процессора.


Спецвыпуск Xakep, номер #014, стр. 014-042-2, История операционных систем

История операционных систем

Topuk (torick@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-042-2

Вот мы и подбираемся к тому, что известно в мире как <Первая редакция UNIX>. В ноябре 1971 года был опубликован первый выпуск полноценной доки по Юниксу. В соответствии с этим и ОСь была названа <Первой редакцией UNIX>. Вторая редакция вышла довольно быстро - меньше, чем через год. Система была полностью переписана на язык B, созданный Томпсоном под влиянием существовавшего тогда BCPL. Также появились программные каналы (). Третья редакция ничем особенным не отличалась. Разве что заставила Дениса Ритчи <засесть за словари не за страх, а за совесть>, вследствие чего тот написал собственный язык, известный сейчас как C. Он позволял расширить функции своего предшественника - B, и именно на нем была написана четвертая редакция UNIX в 1973 году.

В июле 1974 года в журнале Communications of the ACM появилась статья , которой заинтересовалось огромное количество народу. А учитывая, что компания Bell Labs, которая не планировала производство системы, разрешила бесплатно распространять исходники Юникса (<вы платите только за носитель и документацию>), то UNIX, что называется, пошел в народ...


Спецвыпуск Xakep, номер #014, стр. 014-042-3, История операционных систем

История операционных систем

Topuk (torick@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-042-3

Одной из организаций, серьезно заинтересовавшихся этой осью и первой получившей <Пятую редакцию UNIX> был Калифорнийский университет города Беркли, в котором учился юноша по имени Билл Джой, будущий создатель BSD и основатель Sun Microsystems...

Выпьем пивка (<Клина> или <Мельника> - мне в связи с <Клинское-пати> стало уже по барабану) за здоровье Билла Джоя - если бы не он, фиг вам, а не <фряшная бздя>.

<Шестая редакция UNIX> (aka UNIX V6), выпущенная в 1975 году, стала первым коммерчески распространяемым Юниксом. Большая ее часть была написана на С, но увы, переносить систему на компьютеры с архитектурой принципиальной отличной от PDP`шной было весьма затруднительно. Затруднительно, но возможно.

Первый перенос был осуществлен в 1977 году. Абстрагируясь от виртуальности, можно сказать, что это был перенос из Америки в Австралию, потому что в Университете Воллонгонга, что на материке кенгуру и бумерангов, работал завкафедрой Джюрис Рейндфельдс, которого серьезно протащило от шестой редакции. Но так как позволить себе PDP-11 компьютерная кафедра универа не могла, пришлось закупать более дешевый 32-битный компьютер Interdata 7/32. Родная ОСь компа OSMT/32 не обладала нужными мультиюзерскими возможностями, поэтому пришлось профессору заняться переносом UNIX V6, заказав в Университете Беркли кучу исходников на магнитных лентах. Ему в этом поспособствовал Ричард Миллер, который к январю создал компилятор С, что и позволило в середине февраля 1977 года получить свой вариант UNIX, работавший на Интердате.

Домашнее задание: попробуй перенести Windows 98 SE на компьютеры Power Macintosh, дабы прочувствовать вкус крови и пота, сошедших с Миллера и Рейндфельдса.

Миллеровский Юниксоид работал скорее как операционная среда, ставящаяся поверх OSMT/32. Куча функций, имеющихся в <шестерке>, отсутствовала. Но это, как ни крути, был первый блин, и был он не таким уж и комом.

Миллер отправился в Bell Labs и наглядно разъяснил Кену Томпсону & Co, сколь он крут. Кен пошарил по округе, наткнулся на свежекупленный Interdata 8/32, по архитектуре схожий с замученным компьютером Университета Воллонгонга. Денис сказал: <ОК, переносим <шестерку> на Интердату>, и работа закипела. Для начала был расширен язык С, в систему которого были добавлены типы union, short integer, long integer и unsigned integer, дабы использовать особенности 32-битной архитектуры. Помимо прочего, появились средства инициализации переменных, битовые поля, макросы и средства условной компиляции, регистровые и глобальные переменные. Много позже Денис и Кен написали книгу <Язык программирования Си>, в котором конкретно и четко расписали 32-битную вариацию своего детища.

Увы, но и здесь встали препятствия. Юникс слишком привык к PDP-11, и Денису пришлось полностью переписать подсистему управления оперативной и виртуальной памятью, заодно изменив интерфейс драйверов внешних устройств. Все это позволило сделать систему легко переносимой на другие архитектуры и было названо <Седьмая редакция> (aka Unix Version 7). Помимо прочего, в дистрибутив системы входил компилятор для портации ОС на другие архитектуры, а также набор новых драйверов.


Спецвыпуск Xakep, номер #014, стр. 014-042-4, История операционных систем

История операционных систем

Topuk (torick@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-042-4

Параллельно с улучшением Юникса шла разработка системы, известной нам как (Free)BSD. Когда в 1976 году в Университет Беркли попала <шестерка>, там возникли местные юникс-гуру. Одним из них был Билл Джой.

Собрав своих друзей-программистов, Билли начал разработку собственной системы на ядре UNIX. Запихнув помимо основных функций кучу своих (включая компилятор Паскаля), он назвал всю эту сборную солянку Berkeley Software Distribution (BSD 1.0). Вторая версия BSD носила в себе попытки изнасилования (то есть частичной перезаписи ядра системы). Третья версия BSD основывалась на переносе UNIX Version 7 на компьютеры семейства VAX, что дало систему 32/V, легшую в основу BSD 3.x. Ну, и самое главное - при этом был разработан стек протоколов TCP/IP; разработка финансировалась МинБезопасности США.

Начиная с версии 4.1 (1980 год) Berkeley Software Distribution распространялась практически бесплатно - сначала среди пользователей, обладавших лицензией Bell Labs, а позже, переименовавшись в FreeBSD, и вовсе для всех на халяву.

Позже, в 1982-м Билл Джой основал Sun Microsystems, забрал себе исходники платной версии BSD и начал делать SunOS, которая в 1990-х мутировала в Solaris. Отдельные версии Solaris сейчас распространяются бесплатно.

UNIX: 1982 - 1990

Первая коммерческая система называлась UNIX System III и вышла она в 1982 году. В этой операционке сочетались лучшие качества UNIX Version 7, V/32 и других вариантов UNIX, имевших хождение в Bell Labs.

Далее Юниксы развивались примерно так:

Во-первых, появились компании, занимавшиеся коммерческим переносом UNIX на другие платформы. К этому приложила руку и небезызвестная Microsoft Corporation, совместно с Santa Cruz Operation произведшая на свет UNIX-вариацию под названием XENIX.

Во-вторых, Bell Labs создала группу по развитию Юникса и объявила о том, что все последующие коммерческие версии Unix (начиная с System V) будут совместимы с предыдущими.

К 1984-му году (Оруэлл тут ни при чем, но все равно звучит жутковато) был выпущен второй релиз UNIX System V, в котором появились: возможности блокировок файлов и записей, копирования совместно используемых страниц оперативной памяти при попытке записи (copy-on-write), страничного замещения оперативной памяти (реализованного иначе, нежели в BSD) и т. д. К этому времени ОС UNIX была установлена на более чем 100 тыс. компьютеров.

В 1987-м году выпущен третий релиз UNIX System V. Было зарегистрировано четыре с половиной миллиона пользователей этой эпической операционной системы...

Кстати, что касается твоего любимого пингвиноидного Linux`а, то он возник лишь в 1990 году, а первая официальная версия ОС вышла лишь в октябре 1991. Как и BSD, Линукс распространялся с исходниками, чтобы любой пользователь мог настроить ее себе так, как ему хочется. Настраивалось практически ВСЕ, чего не может себе позволить, например, Windows 9x.


Спецвыпуск Xakep, номер #014, стр. 014-042-5, История операционных систем

История операционных систем

Topuk (torick@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-042-5

DOS`ы (Disk Operating System)

ДОСы были всегда. Первые - от IBM, году эдак в 1960-х, они были весьма ограничены функционально. Нормальные, дошедшие и до наших времен, и пользовавшиеся относительной известностью, ведут свой счет с QDOS...

Эта менее эпическая история, нежели развитие UNIX, началась в 1980 году в фирме Seattle Computer Products. Первоначально названная QDOS, операционка была модифицирована и, переименовавшись к концу года в 86-DOS, была продана нашей всенародно любимой Micro$oft. Корпорация IBM, не будь дура, поручила MS работу над операционкой для новых моделей компьютеров <Голубого Гиганта> - IBM-PC. В конце 1981 года вышла первая версия новой ОС - PC-DOS 1.0. Проблема операционной системы была в том, что под каждую конкретную машину ее приходилось настраивать заново. PC-DOS`ом занялась сама IBM, а Микрософту досталась ее собственная модификация, именуемая MS-DOS. В 1982-м одновременно появились PC-DOS и MS-DOS версии 1.1 с некоторыми добавленными и расширенными возможностями. К 1983-му году были разработаны версии 2.0, в которых появилась поддержка винчестеров (ура-ура!), а также улучшенная система администрирования файлов. Третья версия MS-DOS, выпущенная в 1984-м году, дала лишь некоторые улучшения. Последующие версии были направлены на управление базовой и виртуальной памятью вплоть до версии 6.22, после которой появилась жутко урезанная 7.0, входящая в состав какой-то из Windows 9x. Больше Microsoft DOS`ами не занималась.

А тем временем, PC-DOS не умирала. Последняя версия включала в себя практически все, что могла MS-DOS 6.22 плюс такие фишки, как средства резервного копирования и восстановления поврежденных данных, встроенные в систему средства антивирусного контроля, обеспечение синхронизации файлов на двух компах и т. д. Еще из ДОСов была такая штука, как PTS-DOS производства одной из российских физических лабораторий. Последняя ее версия означена как 6.65. Но самой необычной и прикольной является DR-OpenDOS 7.02. Изначально эту ось разрабатывала Digital Research, но потом по каким-то причинам от нее отказалась и продала ее компании Novell. Новелл встроил в нее свои сетевые штучки и продал дальше - фирме Caldera, которая дополнила DR-DOS средствами доступа в Интернет и сейчас распространяет ее бесплатно на условиях FreeWare.

IBM Operating Systems

Все началось с операционки VM (Virtual Machine), что вышла в 1972 году. Выпущенный тогда продукт назывался VM/370 и был предназначен для поддержания сервера для определенного количества пользователей. Современная реализация системы VM/ESA 2 Release 3.0 работает на мэйнфреймах IBM линии System/390. Эта ОС, давно отметившая свой 25-летний юбилей, по истории которой можно изучать развитие технологий IBM в области серверных операционных систем и сетевых решений, является надежной и мощной базой для организации корпоративной информационно-вычислительной системы, ориентированной на многопользовательскую гетерогенную среду крупной современной фирмы. Система VM/ESA очень эффективно использует возможности аппаратного обеспечения и несколько менее требовательна к вычислительным ресурсам компьютера по сравнению с OS/390, что делает ее хорошим вариантом для использования в качестве платформы для корпоративной системы firewall, информационного сервера крупной организации или сервера в инете. Именно из VM выросла относительно известная z/OS.


Спецвыпуск Xakep, номер #014, стр. 014-042-6, История операционных систем

История операционных систем

Topuk (torick@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-042-6

Потом возникло нечто, именуемое OS. Некоторые ее версии были разработаны под специальные серверы (типа OS/390, OS/400). Ну а начиналось все, как обычно... В один прекрасный день, году эдак в 1982, кто-то в фирме IBM почесал репу и подумал: а фигли у нас до сих пор нету нормальной операционки? Вон, вроде заставили на себя Билли Гейтса пахать, но - уж полночь близится, а ДОСа-таки нет? Нет, подумал этот неизвестный, надо делать так, чтоб на совесть и на века. Да, и обязательно привлечь Гейтса!

Разработка этой операционной системы начиналась как совместный проект компаний Microsoft и IBM, нацеленный на создание операционной системы, лишенной недостатков. Первая версия OS/2 вышла в конце 1987 года. Она была в состоянии использовать развитые вычислительные возможности процессора 80286 и обладала средствами обеспечения связи с большими машинами фирмы IBM. В 1993 году фирма IBM выпустила OS/2 2.1, полностью 32-разрядную систему, обладавшую способностью выполнять приложения, созданные для Windows (о да, мы о ней еще поговорим), имевшую высокую производительность и поддерживающую большое количество периферийных устройств (все дело в волшебных драйверах). В 1994 году вышла OS/2 Warp 3. В этой реализации, помимо дальнейшего повышения производительности и снижения требований к аппаратным ресурсам, появилась поддержка работы в Интернете. Сейчас же из последних версий следует отметить лишь OS/2 Warp 4, способная работать с 64-разрядными процессорами. Кроме того, в свежаке довольно полно представлены средства взаимодействия с Интернетом, позволяющие OS/2 выполнять не только клиентские программы, но и выступать в качестве веб-сервера. Начиная c третьей версии, фирмой IBM поставляются локализованные версии OS/2 для России. Пройдя довольно большой и сложный путь, эта ОС для персональных компьютеров обладает сегодня такими особенностями, как реальная многозадачность, продуманные и надежные подсистемы управления памятью и администрирования процессов, встроенная поддержка работы в сети и дополнительные функции сетевого сервера, мощный язык программирования REXX, предназначенный для решения задач системного администрирования. Перечисленные возможности позволяют использовать OS/2 в качестве операционной системы для мощных рабочих станций или сетевых серверов.

Microsoft Windows

Сначала, как утверждает один специалист, были динозавры, а <Окошек> не было. Врет, конечно. Потому что был Apple Macintosh (1983-1984 гг - версии 1.0-1.1) с графическим интерфейсом, с которого, как утверждают, Билли Г. и слизал GUI для Windows. Более того, все началось с IBM`овской OS/2, о которой - см. выше. В общем, Windows была, наверное, первой операционкой, которую Гейтсу никто не заказывал, а разрабатывать ее он взялся на свой страх и риск. Что в ней такого особенного? Во-первых, графический интерфейс. Такой на тот момент был только у пресловутой MacOS. Во-вторых, многозадачность. Конечно, некоторые операционки позволяли в бэкграунде запускать дополнительную задачу, но уж больно они геморройно работали. В общем, в ноябре 1985 вышла Windows 1.0. Окна в нем не перекрывались, на 8086-х процессорах ядро глючило по-страшному из-за явного отсутствия оптимизации под данный камешек. Основной платформой ставились 286-е машины.


Спецвыпуск Xakep, номер #014, стр. 014-042-7, История операционных систем

История операционных систем

Topuk (torick@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-042-7

Ровно через два года, в ноябре 87-го вышла Windows 2.0, через полтора года вышла 2.10. Ничего особенного в них не было, разве что окна научились перекрываться.

И вот, наконец, революция! Май 1990-го года, времена великих свершений и свержений. Короче, вышла Windows 3.0. Чего там только не было: и ДОС-приложения выполнялись в отдельном окне на полном экране, и Copy-Paste работал для обмена с данными ДОС-приложений, и сами Винды работали в нескольких режимах памяти: в реальном (базовая 640 Кб), в защищенном (версии 80286) и расширенном (80386). При этом можно было запускать приложения, размер которых превышает размер физической памяти. Имел место быть и динамический обмен данными (DDE).Через пару лет вышла и версия 3.1, в которой уже отсутствовал геморрой с базовой памятью (если кто запускал старые игрушки, тот помнит, как те требовали то 560 кб, то еще сколько-то, хотя RAM`а могло быть и 16Мб). Также была введена новомодная примочка, поддерживающая шрифты True Type. Обеспечена нормальная работа в локальной сети. Появился Drag&Drop (перенос мышкой файлов и директорий). Появилось OLE (Object Linking & Embedding). В версии 3.11 была улучшена поддержка сети и введено еще несколько малозначительных фишек. Параллельно вышла Windows NT 3.5, которая была на тот момент сбором основных сетевых примочек, взятых из OS/2.

В июне 1995 вся компьютерная общественность была взбудоражена сообщением Microsoft о релизе в августе новой операционной системы, существенно иной, нежели Windows 3.11, но в то же время следовавшей канонам MS - окошки и еще раз окошки. 24 августа - дата официального релиза Windows-95 (другие названия: Windows 4.0, Windows Chicago).Теперь это была не просто операционная среда - это была полноценная операционная система, не требующая для загрузки дисковой операционки. 32-битное ядро позволяло улучшить доступ к файлам и сетевым фишкам. 32-битные приложения были лучше защищены от ошибок друг друга, имелась и поддержка многопользовательского режима на одном компьютере с одной системой. Множество отличий в интерфейсе, куча настроек и улучшений <под юзера> - одна лишь кнопка Start, вошедшая как притча во языцех, чего стоила... Был и апдейт специально для Windows 3.1x - OSR1, который не ставился из-под ДОСа, а просто апгрейдил <три-одиннадцатые>. Кстати, в поставку входил так называемый DOS 7.0, который, к сожалению, имел сильные отличия от DOS 6.22 и, увы, не в лучшую сторону.


Спецвыпуск Xakep, номер #014, стр. 014-042-8, История операционных систем

История операционных систем

Topuk (torick@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-042-8

Чуть позже вышла новая эНТя, с тем же интерфейсом, что и 95-е форточки. Поставлялась в двух вариантах: как сервер и как рабочая станция. Системы Windows NT 4.x были надежны аки Аэрофлот, но не столько потому, что у Microsoft Team проснулась совесть, сколько потому, что NT писали программисты, когда-то работавшие над VAX/VMS. Потом, к тому же, с момента выхода системы было выпущено 6 Service Pack`ов...

В 1996-м году вышла Windows-95 OSR2 (если не ошибаюсь, это расшифровывается как Open Service Release). В дистрибутив входил Internet Explorer 3.0 и какая-то древняя версия Outlook`а (тогда называемая просто Exchange). Из основных фишек - поддержка FAT32, улучшенный инициализатор оборудования и драйверов. Некоторые настройки (в том числе и видео) можно менять без перезагрузки. Имелась и встроенная DOS 7.10 с поддержкой FAT32.

Год 1998. Вышла Windows-98 со встроенным Internet Explorer 4.0 и Outlook. Появился так называемый ActiveDesktop, который, если честно, только мешал, но был <переходным> к Инетернетовской ОС (тогда M$ уже бредила о такой системе, полностью интегрированной с инетом). Улучшена поддержка универсальных драйверов и API DirectX. Встроена поддержка нескольких мониторов. Опционально можно было добавить замечательную утилиту по переводу жестких дисков из FAT16 в FAT32. Встроенный DOS датировался все тем же 7.10.

Через год вышла Windows 98 Special Edition. С оптимизированным инициализующим ядром Internet Explorer добрался до версии 5.0, который по большому счету мало чем отличался от 4.х. Интеграция с Всемирной Паутиной, заключающаяся в поставке нескольких слабеньких утилит типа FrontPage и Web Publisher. DOS был все тем же - 7.10.

Наше время, год назад. Выходит полная версия Windows Millenium. Интернет Експлодер стал версией 5.5, DOS вроде умер, но умные лица утверждают, что он был, но назывался 8.0. Досовские приложения просто игнорируются. Интерфейс улучшился за счет графических наворотиков и акселерации всего, что может двигаться (включая курсор мышки). Плюс пара сетевых наворотов и отсутствие winipcfg...

Ну и, наконец, 2001 год. Ждем не дождемся Whistler'а, недавно переименованного в Windows XP (в этом же номере ты можешь прочесть обзор бета-версии этой системы).

BeOS

История этой ОС начинается в далеком 1989 году, когда Стив Джобс (в свое время основавший Apple) задумывается о создании операционки для производимых его

фирмой NeXT Computers компьютеров NeXT. Написанная наподобие Юникса и начиненная при этом графической оболочкой, система была поставлена на все компьютеры NeXT, но... увы, компьютеры практически никто не покупал из-за несовместимости с другими платформами и довольно высокой цены. Но это была по-настоящему мультимедийная система. В начале девяностых о таких вещах и не слышно было. Встроенный DSP (цифровой сигнальный процессор), поддержка CD-приводов. Система NeXTStep с GUI, с которого, похоже, и был срисован Windows 9x. В общем, это должно было стать действительно РУЛЕЗНОЙ вещью. Но не стало. Хотя, по слухам, и легло в основу BeOS.


Спецвыпуск Xakep, номер #014, стр. 014-042-9, История операционных систем

История операционных систем

Topuk (torick@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-042-9

Абсолютно новая операционная система BeOS впервые появилась в 1996 году. Она использует старый добрый графический интерфейс с окошками, но при этом BeOS разительно отличается от Виндов - весь ее код написан в юниксоидном стиле, с консолью, с громадными строками команд и так далее. При всем при этом последние версии BeOS стабильно поддерживают две платформы: PowerPC и x86-ю архитектуру. Более того, Би можно поставить на один комп с Виндами и ничего тебе за это не будет :).

Архитектура BeOS строго следует канонам NeXT и вследствие этого специально оптимизирована для обработки видео и аудиоинформации. API объектно-ориентирован покруче иных ДиректЫксов.

Сейчас БеОСь развивается, ей даже посвящены отдельные сайты вроде www.benews.ru.

Сетевые операционки

SuperDOS

В середине 80-х с появлением такой мощной и популярной по тем временам машины как IBM-PC на базе процессора Intel 286 начала расти и потребность в сетевых технологиях под эту нехилую тачку. SuperDOS - это, наверное, первая мультиюзерская многозадачная ось, предназначенная для компьютеров на камне 80286 и старше. Эта операционка, разработанная фирмой Bluebird Systems, ведет свою историю с 1983 года и предназначена в основном для решения бизнес-задач. Выполнение под этой операционной системой приложения фирмы Bluebird Systems, носящего имя PC-Connect, позволяет клиентам работать с программами, разработанными для MS-DOS и Windows. Система очень нетребовательна к ресурсам, занимает в оперативной памяти около 100 Кб и способна обслуживать до нескольких десятков пользовательских терминалов.

Novell NetWare

В середине 80-х появилась SuperDOS, к сожалению, слабо работавшая в качестве мощного сервера с кучей возможностей. Сию неблагодарную работу взяла на себя фирма Novell, до этого занимавшаяся своей вариацией дисковой ОСи (DR-

OpenDOS). Фактически, Новелл была первой, кто вообще начал производить серверное ПО для персоналок. Novell NetWare 2.x уже позволяла работать в качестве файлового сервера, предназначенного для общего использования с высоким уровнем безопасности. Версия 3.х позиционировалась как операционка для <трешек>. НеТвари третьих версий были намного лучше, нежели иные операционки, использующие большой объем оперативной и дисковой памяти. Что самое забавное, некоторые из последних версий семейства 3.х до сих пор используются в наших организациях и ведомствах. Например, в Государственном Информационном Центре МВД РФ есть несколько серваков, использующих НеТварь. А все из-за так называемой SFT III - System Fault Tolerance III, то есть устойчивости к отказам третьей категории. По тем временам зеркализация серверов и дуплексирование винчестеров (это когда один винт выходит из строя, система не падает) воспринималось как нечто новейшее. Более того, в третьих версиях семейста НеТварей была такая фишка: если в сети несколько серваков, и один из них упал, то все остальные просто не обращали внимание, переключив его функции на себя.


Спецвыпуск Xakep, номер #014, стр. 014-042-10, История операционных систем

История операционных систем

Topuk (torick@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-042-10

Все вышеперечисленные феньки вошли и в Novell NetWare 4.x. Из нового в этой Си была реализована Novell Directory Services (NDS) - система управления ресурсами и сервисами сети. Подробно останавливаться на этом не буду, добавлю лишь, что в четвертые версии была включена поддержка всех процессоров от Intel, начиная от 80386 и заканчивая последними на тот момент <Пентиумами>. Это позволяло организовывать сети с различными аппаратными устройствами, а поддержка SMP еще и дала возможность увеличивать производительность серверов за счет использования нескольких процев сразу. Также была встроена возможность организации системы целого предприятия с использованием утилит, входящих в поставку Novell NetWare 4.x. Плюсом к тому явились всякие проги типа новелловского веб и фтп-сервака, сервис многопротокольного маршрутизатора, шлюз IPX/IP. В общем, Бивисам дают.

И, кстати, четвертая НеТварь была вполне совместима с третьей версией, что позволило не выбрасывать на помойку старые дистрибутивы, а пользовать их по максимуму. Представь, что в Сети стоят машины с Windows 3.11 и Windows 95 и часть функций девяностопятых доступны стареньким три-одиннадцатым! Правда, 3.11 - все-таки не столько ОС, сколько операционная среда, поэтому технически это вряд ли возможно... но было бы как минимум прикольно.

Операционные системы,

несовместимые

с архитектурой IBM-PC (позже - x86)

Русские

операционные системы

ДОС ЕС

Если ты, дорогой читатель, думал, что такое (см. заголовок) невозможно или нереально по тем или иным причинам, то ты ошибался. Все началось в 1966 году, когда сверху (ты еще помнишь, что означает понятие <сверху>?) спустили указ: в течение двух лет разработать проект, цитирую, <комплекса типовых, высоконадежных информационных вычислительных машин с диапазоном по производительности от 10 тыс. до 1 млн операций в секунду, построенных на единой структурной и микроэлектронной технологической базе и совместимых системах программирования для вычислительных центров и автоматизированных систем обработки информации>. О как! Короче, чтоб были и воркстейшны на 1Мгц, и чтоб совместимость 100-процентная, и чтоб операционка у всех одна была. Ну и в сеть их, естественно, прямо в сеть.

Долго объяснять, почему и зачем - в общем, наши програмеры взяли за основу DOS 360, написанный под машины IBM/360. ЭВМ, под которые им надо было писать ДОС, уже были созданы каким-то минским приборостроительным бюро и назывались машинами Единой Системы (ЕС). Разработка программ, сборка системы и написание документации производились коллективом все тех же минских программистов. Создание ДОС ЕС было завершено в 1971 году и тогда же начались ее поставки с машинами ЕС-1020, ЕС-1030 и ЕС-1040. ДОС ЕС 1.0 была рассчитана на крайне скромные ресурсы машин ЕС ЭВМ, могла морфироваться только под конкретную конфигурацию железа и выполняла до трех задач одновременно. Короче, первая дисковая операционная система в СССР.


Спецвыпуск Xakep, номер #014, стр. 014-042-11, История операционных систем

История операционных систем

Topuk (torick@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-042-11

Несмотря на то, что система структурно была аналогична DOS/360 MFT, переработка текста исходников привела к тому, что разработчики ДОС ЕС 1.0 ввели просто туеву хучу нововведений, объединенных в четыре основных блока: управляющая программа, системные утилиты, трансляторы, средства генерации системы. Из интересных фич было: программа <Библиотекарь>, отладочная программа <Автотест>, набор программ <Утилиты>, управляющих перемещением, копированием, вводом и выводом файлов, трансляторы с языков Ассемблер (два варианта - экономичный и быстрый), Фортран (два варианта - базисный и Фортран 4), РПГ и ПЛ /1. Позднее был добавлен транслятор с языка Кобол.

В 1975-м году вышла ДОС ЕС 2.0, в которой был введен мультизадачный режим, базисный телекоммуникационный метод доступа. В системе теперь велись логи ошибок железа и прог. Появились утилиты, обеспечивающие совместимость Единых Систем с машиной <Минск-32>. Впрочем, даже с вышедшей в 1978 году ДОС 3.0 ЕС ситуация не изменилась: В СССР эти системы распространения не получили.

СВМ

Слышал про <Роботрон>? Во времена моего колясочного детства это был самый известный комбинат по производству ЭВМ. В общем, именно его сотрудники и зарелизили в 1982-м СВМ 1.1, взяв за основу пятую редакцию Virtual Machine/370 от разнесчастной IBM. Виртуальная Машина (ВМ) занималась виртуализацией отдельных железок. Виртуальная память - слышал такое понятие? Вот оно и есть. НО! Самое главное: система предложила новый принцип параллельной работы пользователей на одной ЭВМ, когда каждому пользователю предоставляется своя виртуальная машина, функционально эквивалентная реальной ЭВМ.

Помнишь ? Вот из СВМ (VM) она и выросла. Версия СВМ 2.2 на базе <шестерки> VM/370 вышла через год. Не претендуя на лавры дисковых и простых операционок, система заняла свою нишу и потихоньку развивалась.

К 1989 году СВМ ЕС выросла до четвертой версии и успешно завоевала внимание пользователей ЕС ЭВМ-2 и ЕС ЭВМ-3, юзавших одновременно несколько операционных систем ЕС ЭВМ (например, ДОС, ОС и МОС) или несколько различных версий этих ОС. Кстати, разработчики СВМ и по сию пору работают с IBM на тему новых версий VM.

К сожалению, рассказать обо всех русских ОСях невозможно по причине нехватки места в журнале. Перечислю наиболее выделившиеся: <Операционная система ИПМ> (1967-1970), <Диспетчер-68> (1967-1968), <Новый диспетчер-70> (1970), система <Дубна> (1970), ОС ЕС (1970-73), ВК 1010 (1978), мобильная операционная система для ЕС ЭВМ ака МОС ЕС (год не выяснен), операционная система реального времени ака ОС РВ (1985), а также: система <ОКА> (1980), графическая инвариантная система ака ГРИС (1987).

Операционные системы Apple II/Macintosh

MacOS 1.1 (январь 1984-го). Графическая оконная система с интересными возможностями, включая автоматический запуск аналога M$-проводника при запихивании какого-нибудь диска/дискеты в привод.

Apple Desktop (1986) основывалась на том же коде, что и MacOS, но обладала некоторыми возможностями, которые M$ ввел лишь в Windows 95 (а иные и вообще только в 98-х/ME). Файловый менеджер был весьма и весьма информативным с достаточно большими возможностями.


Спецвыпуск Xakep, номер #014, стр. 014-042-12, История операционных систем

История операционных систем

Topuk (torick@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-042-12

GEOS (1988). Интересен хотя бы тем, что создан он компанией Berkeley Software (знакомое название, правда?). В системе имелось несколько окошек наподобие виндовой кнопки Start, откуда к файлам и приложениям вели различные ярлычки. К системе прилагалась простенькая программка для рисования и текстовый процессор.

GSOS (1993). Из не-MacOS`ов, наверное, самая крутая на тот момент. Рассчитана, правда, на улучшенный вариант Apple II под названием Apple IIGS. 16-цветовая гамма, работа со всеми доступными на тот момент приводами, возможность drag-and-drop`а прямо на десктоп, возможность кастомизации иконок папок, отличный файндер, калькулятор и вообще куча прилагающихся утилит.

Про поздние версии MacOS рассказывать бессмысленно - это мало кому интересно. Да и потом, наверняка у нас будет обзор MacOS X. Тогда все и узнаешь.

На этом все. Разреши откланяться и пойти допить пиво. Да, кстати, и не забывай посещать www.xakep.ru. Там есть что посмотреть и есть что почитать (включая творения вашего покорного слуги).


Спецвыпуск Xakep, номер #014, стр. 014-048-1, 20 советов по созданию настоящего Х-кода

20 советов по созданию настоящего Х-кода

Спецвыпуск Xakep, номер #014, стр. 014-048-1

Иван Скляров (sklyarovivan@mail.ru)

Хочешь, чтобы созданные тобой проги заслужили уважение, а не выкрики must die, и, чтобы, увидав код твоей программы, знающие люди говорили: "Это писал настоящий хакер!". Тогда всегда следуй тем двадцати советам, что ты здесь прочитаешь, и не важно, на каком языке ты кодишь - они подходят для всех существующих языков программирования. Советы эти, главным образом, посвящены оптимизации, т.е. созданию быстрого и потребляющего малое количество ресурсов (памяти, свободного места на винте и т.п.) кода, а потому и безглючного. В наше время, когда на первом месте стоит срок разработки программы, а не ее качество, оптимизация разработчикам стала не нужна. Поэтому и приходится бедным юзерам с очередным выходом форточек апгрейдить свою тачку, а также бороться с вечными глюками. Но остались еще люди - создатели Linux, Back Orifice 2000 и т.п., которым в первую очередь важны не деньги, а честь и уважение своего имени, - ты, наверное, понял, что я говорю о хакерах. Теперь и у тебя есть возможность делать как они.

Вообще, часть этих советов раньше можно было встретить в любой книге по языкам программирования для начинающих. Но современные авторы считают это лишним, наивно полагая, что современные компиляторы сами сделают все за программиста. Я согласен, что компиляторы стали более интеллектуальны, но надеяться на них я бы не советовал, тем более, есть еще и интерпретируемые языки, такие как Perl, которым оптимизация просто необходима, да и не нужно приучать новичков к дурному тону программирования.

Совет #1

Старайся писать небольшой и компактный код. Запомни: число строк и их длина прямо пропорциональны размеру скомпилированной программы. К тому же компактный код делает программы более шустрыми. У опытных программистов существует даже такая заповедь: "Нет такой программы, которую нельзя было бы уменьшить хотя бы на один оператор". Поэтому всегда внимательно смотри листинг своей программы, и ты обязательно обнаружишь места, которые можно написать короче или вообще убрать. Но это не касается комментариев, компилятор их все равно игнорирует, поэтому всегда вставляй комментарии, особенно в больших и сложных программах. Это поможет тебе легче в них ориентироваться, к тому же, если ты вдруг решишь продать тексты своих программ, то комментарии повысят им цену.

Совет #2

Хорошенько изучи IDE (интегрированная среда разработчика) языка, на котором ты кодишь. Обычно в опциях IDE имеется возможность выбирать различные типы компиляторов, а по умолчанию всегда стоит самый простой, который быстро компилирует, но создает менее оптимизированный код. Поэтому всегда устанавливай самый оптимизирующий тип компилятора, и если ты не пишешь очередные форточки, то его медленная скорость будет для тебя не особо обременительна. В крайнем случае для черновых версий своих программ можешь использовать обычный тип компилятора, а для окончательного варианта - самый оптимизирующий. Кроме того, если имеется возможность, установи компилятор в режим "предупреждений о максимальном числе ситуаций" и исправляй свою программу до полного исчезновения сообщений.


Спецвыпуск Xakep, номер #014, стр. 014-048-2, 20 советов по созданию настоящего Х-кода

20 советов по созданию настоящего Х-кода

Спецвыпуск Xakep, номер #014, стр. 014-048-2

Совет #3

Используй вставки на ассемблере. Конечно, можно посоветовать полностью писать программы на асме, но надо признать, что сделать сейчас что-то более-менее крупное на нем не так-то просто и быстро, но возможность применить в своей программе вставку на ассемблере никогда не упускай. Это значительно повысит производительность программы и уменьшит ее требовательность к ресурсам компьютера. Тем более, практически все языки высокого уровня позволяют делать это. Кстати, всемирно известный в компьютерном мире Стив Гибсон, специалист по компьютерной безопасности, всегда писал и до сих пор пишет свои программы исключительно на ассемблере. Учи ассемблер!

Совет #4

Не выделывайся - делай стандартный и простой интерфейс в своих прогах. Не нужно использовать модные сейчас окна нестандартной формы (овальные, треугольные и т.п.), необычные кнопки, оригинальные меню и т.п. Все это сильно тормозит программу, расходует огромное количество ресурсов компьютера и требует дополнительного времени на разработку. Тем более, профессионалов этим не удивишь, а простые юзеры тебя просто не поймут. Пользователю всегда удобней и легче использовать мерзкий виндовый интерфейс, чем разбираться в чем-то новом и необычном. Поэтому все твои труды могут просто пойти насмарку, да и если уж пишешь под какую-нибудь ось - смирись с ее правилами и стандартами. Вообще, под необычным и пестрым интерфейсом, как правило, авторы стараются скрыть убогость и малую функциональность своих прог, подобные интерфейсы позволительны только гамесам и развлекухам. Посмотри на тот же BO2k - все просто и стандартно, а настоящий UNIX так это вообще обычный shell - строка для ввода команд.

Совет #5

Обязательно изучи размер в байтах всех типов переменных языка, на котором ты кодишь. И не используй "большие" типы переменных, когда этого не требуется, т.к. это ведет к лишнему расходу памяти, к тому же типы переменных, занимающие большее количество памяти, работают медленнее тех, которые требуют меньше памяти. Например, в VB есть такой тормозной тип переменной, как Variant, который занимает 16 байт, хотя в большинстве случаев вместо него можно использовать другие типы переменных, например Double, требующий всего 8 байт.

Совет #6

Всегда явно указывай типы всех используемых тобой переменных, даже если язык программирования позволяет этого не делать. Например, в VB тип переменной указывается так: Dim X As Integer. Но если этого не сделать, то по умолчанию переменной X будет присвоен тип Variant (16 байт) вместо необходимого Integer, требующего всего 2 байта памяти.

Совет #7

Помни, что глобальные переменные (extern), а также статические переменные (static) работают в несколько раз медленнее и требуют больше памяти, чем локальные и автоматические переменные (автоматические переменные сохраняют свое значение, пока выполняется процедура, и теряются при выходе из нее). Локальные и автоматические переменные, как правило, объявлены по умолчанию. Поэтому вместо объявления глобальных и статических переменных лучше использовать, например, переменные уровня модуля.


Спецвыпуск Xakep, номер #014, стр. 014-048-3, 20 советов по созданию настоящего Х-кода

20 советов по созданию настоящего Х-кода

Спецвыпуск Xakep, номер #014, стр. 014-048-3

Совет #8

Старайся использовать простые арифметические операции типа сложения или вычитания, т.к. процессор выполняет их гораздо быстрее, чем, например, умножение или деление. Вообще, все арифметические операции можно разделить по скорости выполнения их процессором. Вот некоторые из них, начиная с самой быстрой:

1) присваивание;

2) сложение/вычитание;

3) умножение;

4) деление;

5) возведение в степень и др.

Для того чтобы перейти от сложных операций к более простым, сокращай выражения, например, вместо x = a*c + b*c + a*d + b*d правильнее написать x = (a + b)*(c + d). Деление заменяй умножением, например, вместо x = (a + b)/2 пиши x = (a + b)*0,5. Если тебе нужно возвести число в степень, лучше использовать произведение этого числа на само себя. Это будет гораздо быстрее, чем операция ^ в VB или функция pow(x, y) в C/C++. Например, выражение y = x * x * x будет выполнено в 7 раз быстрее, чем y = x ^ 3. Если степень высокого порядка, то ее лучше разбить с помощью временных переменных, например:

tmp = x * x * x

y = tmp * tmp * x

Это будет выполнено в 3 раза быстрее, чем x ^ 7.

Совет #9

Если позволяет твой язык программирования, используй сокращенные операции. Например, такие как в C/C++: инкремент ++ (увеличение на 1), декремент -- (уменьшение на 1), а также операции присваивания, типа += (выражение x += 3 то же самое, что x = x + 3) и т.п. Сокращенные операции выполняются быстрее, кроме того, они позволяют быстрее набивать программу, и компилятор быстрее ее компилирует.

Совет #10

Ты должен знать, что в программировании считается ламерством использовать оператор Goto. Давно доказано, что без него можно обойтись в любой ситуации. Использование этого оператора ухудшает читаемость программы и увеличивает код, правда, в некоторых ситуациях может повысить эффективность. Но даже если ты используешь его для повышения эффективности своей проги, все равно никому не показывай ее текст, т.к. любой опытный программер, увидев оператор Goto, сразу примет тебя за ламера.

Совет #11

Если в твоем коде есть константы, которые не меняются на протяжении выполнения всей программы, - не делай лишние присваивания. Например:

int x = 5, y = 7;

if (a < x && b < y)

c = x;

лучше написать так:

if (a < 5 && b < 7)

c = 5;

Таким образом, ты сократишь код, а также уменьшишь размер скомпилированной программы, сократишь время ее выполнения и освободишь память.

Совет #12

Избегай повторные вычисления одних и тех же выражений, достаточно сделать это один раз и в дальнейшем использовать полученное значение. Например:

if (a > x * 3)

b = x*3 + (1 + x*3)/(100 + x*3);

for (int i = 1; i <= x*3; i++)

c = i + b*x*3;

правильнее написать так:

y = x * 3;

if (a > y)

b = y + (1 + y)/(100 + y);

for (int i = 1; i <= y; i++)

c = i + b*y;

Это увеличивает скорость выполнения программы.

Совет #13

Внимательно следи за тем, чтобы в циклах не выполнялись операции, которые могут быть выполнены вне цикла. Например, в следующем примере:


Спецвыпуск Xakep, номер #014, стр. 014-048-4, 20 советов по созданию настоящего Х-кода

20 советов по созданию настоящего Х-кода

Спецвыпуск Xakep, номер #014, стр. 014-048-4

For i = 1 to 1000

x = x * 7

y =y + i

Next i

операция x = x * 7 будет выполняться 1000 раз, хотя она свободно может быть выполнена всего один раз вне цикла, как показано в следующем листинге:

x = x * 7

For i = 1 to 1000

y = y + i

Next i

Случаи, подобные первому примеру, сильно тормозят программу.

Совет #14

Чаще всего структуру выбора if лучше разделить на несколько блоков, например:

If x > 1 And y < 5 Then i = 0

можно разделить на два блока:

If x > 1 Then

If y < 5 Then i = 0

End If

В последнем случае второй If не выполняется, если первый оказался ложным. Это способствует повышению скорости программы, т.к. исключаются лишние проверки. По тем же соображениям в структуре выбора if /else после оператора else всегда пиши то условие, которое менее вероятно может возникнуть в реальной ситуации.

В выражениях с операцией && (логическое И, в C/C++), если отдельные условия независимы, например:

if (x = = 0 && y > 1)

на первое место всегда записывай то условие, которое вероятнее всего окажется ложным, т.к. в этом случае анализ выражения будет сразу прекращен и передан следующей строке, что сокращает время выполнения программы. А в выражениях с операцией || (логическое ИЛИ), например:

if (x >= 1 || y >= 1)

на первое место пиши то условие, которое вероятнее всего окажется истинным.

Совет #15

Операции с элементами массива (индексными переменными) всегда выполняются медленнее, чем с обычными переменными. Поэтому операция a*b будет выполнена гораздо быстрее, чем a[i]*b[j], при одинаковых значениях. Следовательно, если необходимо использовать один и тот же элемент массива неоднократно, лучше присвоить его другой переменной и затем использовать ее. В циклах повышение производительности при этом может достигать 80 процентов.

Совет #16

Обращение к элементам одномерного массива всегда быстрее, чем к элементам многомерного массива. Поэтому всегда старайся использовать исключительно одномерные массивы, например, вместо матрицы 5 на 5 сделай одномерный массив на 25 элементов.

Совет #17

Не используй в своей программе рисунки в формате BMP. Надеюсь, тебе не стоит объяснять, что BMP требует много ресурсов и долго перерисовывается, лучше использовать такие форматы, как JPEG, PCX, WMF и др. Старайся также применять минимальное количество цветов, например, 16-цветный рисунок занимает половину требуемой памяти для 256-цветного рисунка, а монохромный - одну четверть памяти, требуемой для 16-цветного рисунка. Так, если у тебя рисунок содержит только белый и черный цвета, то правильным будет сохранить его как монохромный.

Совет #18

Если твоя прога долго грузится, используй заставку. Это, конечно, скорости программе не прибавит, но юзеру будет казаться, что она грузится быстрее. Только заставка должна быть простой, чтобы еще больше не тормозила загрузку. Пример простых заставок можно посмотреть в программах MS Office (как ни странно!).

С той же целью можно использовать и индикатор загрузки. Но если ты не можешь сделать так, чтобы он во всех случаях двигался равномерно, а не как часто бывает - рывками, лучше не делай, т.к. это создаст еще большее впечатление тормознутости программы.


Спецвыпуск Xakep, номер #014, стр. 014-048-5, 20 советов по созданию настоящего Х-кода

20 советов по созданию настоящего Х-кода

Спецвыпуск Xakep, номер #014, стр. 014-048-5

Совет #19

Если ты не уверен в знании своего родного языка (а сейчас есть такая фича, что многие знают английский гораздо лучше, чем русский), то прогони свою программу в Word'e на проверку правописания. Это хотя бы минимально избавит ее от грамматических ошибок и "очепяток". Конечно, этот совет не относится к оптимизации, но грамотность в программах не менее важна, т.к. от тебя сразу все отвернуться, если увидят, например, вместо "Сохранить" - "Сохренеть" и т.п.

Это далеко не все советы, которые можно дать по оптимизации программ, а лишь их самая основная часть. Тем более по каждому отдельному языку программирования на эту тему можно говорить практически бесконечно. Поэтому я тебе дам последний - двадцатый - совет, чтобы ты действительно стал профессиональным кодером: прочитай хотя бы первый том (а всего их три) книги Дональда Кнута "Искусство программирования". Эта книга - настоящий мировой бестселлер, которую, считается, должен изучить всякий уважающий себя кодер. Кстати, сам Билли сказал, что кто прочитает все эти тома от корки до корки, может присылать ему свое резюме. Если ты умудришься таким способом попасть на службу к мелкомягким, то попытайся изменить Windows к лучшему :). Желаю удачи!


Спецвыпуск Xakep, номер #014, стр. 014-051-1, Откуда есть пошел, взялся, протянулся и вообще

Откуда есть пошел, взялся, протянулся и вообще

возник Интернет

Спецвыпуск Xakep, номер #014, стр. 014-051-1

Topuk (torick@xakep.ru)))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))))

Вот уже два года мы рассказываем, как получить Интернет, как его развести на деньги, на девчонок, на халяву. Как его выжать, и выкачать все, что только можно. Как наделать всяких гадостей, чтоб никто не заметил. В общем, учили не ждать от Инета милостей, а брать, пока дают (по крайней мере, пока не отнимают).

о, как мне кажется, настала пора провести хоть какой-то небольшой ликбез на тему "А откуда он взялся, этот загадочный добрый дядя InterNet?". Чем и займемся.

1962-1970. ARPANet, NCP, UNIX

В далекие-далекие времена, когда компьютеры были офигенно большие, а пиво "Старый мельник" не продавали на каждом углу, правительство одного заокеанского государства приняло решение поднять вопрос о военном применении компьютерных технологий. Превратив вопрос в проблему и поставив решать ее доктора Ликлидеру (J.C.R. Licklider), правительство умыло руки и стало ждать результата. Он не заставил себя ждать: была выдвинута идея объединить несколько удаленных узлов в единую сеть. Но в то время все америкосы активно готовились к атомной войне с Союзом, поэтому задача была сделать такую Сеть, чтоб если один узел вышел из строя - то остальные бы продолжали работать. Идея тут же была опробована на компьютерах TX-2 Массачусетского технологического института и Q-32 корпорации SDC (System Development Corporation) в Санта-Монике. Правда, обмена пакетами между ними в это время еще не проводилось, компы общались посимвольно.

Через пару лет на симпозиуме по компьютерной машинерии был предоставлен план создания национальной сети с использованием пакетной передачи данных. Некий Лоуренс Робертс, не будь дурак, взял да и быстренько на основе этого наклепал свой вариант, который и был признан государством за единственно верный. Так была создана сеть ARPANET (Advanced Research Projects Agency NETwork), введенная в эксплуатацию в 1969 году. Тогда были объединены четыре узла: UCLA - Центр испытаний сети, Станфордский исследовательский институт, университет Санта-Барбары и университет Юта. Через год их стало уже пятнадцать, и они использовали для обмена пакетами протокол NCP - Network Control Protocol.

На узлах использовались IMP (Interface Message Processor), разработанные корпорацией Bolt Bаranec & Newman, Inc (BBN). Появился первый RFC (Request for Comments) - "Host Software" by S. Crocker.

И, пожалуй, главное событие, отголоски которого слышны по сей день, - компания AT&T разработала операционную систему UNIX.

1971-1973. E-mail, TCP/IP, Telnet, первые международные подключения

В 1971 году было подключено уже 23 хоста ARPANet. Это, конечно, маловато по сравнению с нынешними - но на тот момент это было ого-го! Одно из основных событий того времени - изобретение Рэем Томлинсоном (Ray Tomlinson) из компании BBN программы почтовых сообщений, которые можно было передавать по сети. Университет Гавайи обзавелся собственной сеткой наподобие АРПАНет - ALONANet.

В 1972 году на международной конференции по компьютерам и связи было продемонстрировано взаимодействие TIP (Terminal Interface Processor) c 40 машинами сети - сравните это с 23-мя хостами в предыдущем году, попробуйте спрогнозировать рост ARPANet и сравните это с нынешними показателями!


Спецвыпуск Xakep, номер #014, стр. 014-051-2, Откуда есть пошел, взялся, протянулся и вообще

Откуда есть пошел, взялся, протянулся и вообще

возник Интернет

Спецвыпуск Xakep, номер #014, стр. 014-051-2

Тогда же была создана рабочая группа национальной сети - INWG (InterNetworking Working Group) под председательством профессора Станфордского университета Винтона Кирфа. На тот момент уже существовала дикая неразбериха с протоколами (не то что сейчас - PPP, SLIP да TCP/IP). Группа с удовольствием взялась за разрешение проблемы... И в итоге именно эти бравые яйцеголовые ребята разработали то, что сейчас имеет честь называться TCP/IP (32-битная адресная система, система пинга и все такое)!

Та-ак. Все резко взяли по бутылочке "Старого мельника" и распили за здоровье Кирфа, пока тот еще жив.

Продолжаем. Все в том же 1972 году была опубликована спецификация Telnet (RFC 454). Одновременно с ней появилась и первая коммерческая версия UNIX, написанная на C. Успех UNIX превзошел все ожидания (с нынешней точки зрения это вполне понятно).

Менее чем через полгода были проведены первые международные подключения к ARPANET. К сети подключились машины из Англии (University College of London) и Норвегии (Rogee Radar Establishment). Тогда же была запущена спутниковая линия связи с Гавайским университетом. Вездесущие ребята из INWG представили идеи программы управления передачи данных (Transmission Control Program).

1974-1980. UUCP. PRNET, Ethernet, SATNET. USENET

В середине 1975 года DARPA, контора, разработавшая ARPANet, пришла к выводу, что ее сеть стабильна, и управление Арпой было передано DCA (Defence Communications Agency, ныне известное как DISA - Defence Information Systems Agency).

В 1976 году Майк Леcк (Mike Lesk) из все той же AT&T разработал протокол UUCP (Unix-to-Unix Copy), и уже через год этот протокол стал поставляться вместе с UNIX версии 7; версия UUCP Berkeley была выпущена несколько позднее. Протоколами TCP/IP, после опубликования оного в 1974-м, повсеместно стали пользоваться для подключения к ARPANET.

А дальше покатились как лавина с горы СЕТИ. В 1977 году появилась THEORYNET, разработанная Л.Ландвебером (L. Landweber) из Винсконсинского университета. В сети, объединявшей около 100 специалистов по вычислительной технике, применялись электронная почта и Telnet. Тимшаре (Timshare) основал Tymnet. Состоялась демонстрация взаимодействия ARPANET и протоколов PRNET (Packet Radio Net, радиопередача данных), Ethernet (ну, это понятно) и SATNET (Satellite Network, передача данных через спутник) на базе TCP/IP. Была опубликована спецификация электронной почты (RFC 733).

В 1977 году был создан первый коммерчески-корпоративный сайт в Internet, в этом начинании отличилась DEC (Digital Equipment Corporation).

В 1979 году на базе UUCP была запущена первая сеть типа USENET, что есть само по себе немаленькое событие.

1981-1984. BITNET, CSNET. MILNET. IAB. DNS

ARPANET теперь состояла из двух пересекающихся сетей. Одна являлась рабочей для исследователей ARPA, другая служила для тестирования и разработки. Это при том, что исследовательский период ARPANET еще не прошел! Шлюзы в другие сети были раскинуты буквально на каждом узле.


Спецвыпуск Xakep, номер #014, стр. 014-051-3, Откуда есть пошел, взялся, протянулся и вообще

Откуда есть пошел, взялся, протянулся и вообще

возник Интернет

Спецвыпуск Xakep, номер #014, стр. 014-051-3

В январе 1981 года был создан Центр компьютерной безопасности министерства обороны (DSC - Defence Security Center). Он занимался определением полезности тех или иных компьютерных систем, кои теперь создавались повсеместно. Также началась эксплуатация BITNET (Because It's Time NETwork) и CSNET (Computer Science NETwork), которая существовала отдельно от ARPANET.

В январе 1982 года произошло два наиболее важных для Интернета события: а) родился ваш покорный слуга, б) DCA и ARPA постановили основными протоколами передачи данных по Интернету Internet Protocol (IP) и Transmission Control Protocol (TCP).

1 января 1983 года Министерство обороны США объявило TCP/IP своим стандартом. Было объявлено, что ARPANET закончила исследовательскую стадию, но продолжает оставаться под руководством DARPA и DCA. Введение разработанного в Висконсинском университете общего сервера имен уже не требовало от пользователей запоминать цифровой адрес той или иной машины.

В этом же году вся ARPANET была переведена с NCP на TCP/IP. Из ее состава наконец-то выделилась сеть MILNET (Military Network), предназначенная только для обмена военной информацией.

Выпущен фантастический и до ужаса реальный роман Дэвида Бишофа "Недетские игры", который должен быть прочитан каждым уважающим себя advanced user`ом, не говоря уж о хакерах и просто романтичных подростках, увлекающихся компьютерами, девушками и приключениями (если книжку достать негде - топай сюда: http://www.lib.ru/INOFANT/BIS-HOF/wargames.txt).

Появились настольные WorkStation c Berkeley UNIX, которая включала программы IP-соединения. Была создана IAB (Internet Activities Board), родственник Bulletin Board System (BBS). Очередная версия операционки UNIX Berkeley release 4.2 BSD полностью включала в себя протокол TCP/IP. Был введен в эксплуатацию шлюз между ARPANET и CSNET.

В 1984 году на СЕТЬ наконец-то обращает внимание "Академия наук" США (US National Science Foundation, NSF). Введена знаменитая система DNS (Domain Name System). Общее число хостов в сети превысило 1 000.

1985-1990. NSFNET, NNTP, Червь Морриса, первые ISP

1985 год. Началось создание центров суперкомпьютеров. В результате этого была создана сеть NSFNET с магистральной скоростью передачи данных - 56 Кбит/с. Сеть основывалась на 5 суперкомпьютерных центрах, что позволило существенно увеличить количество передаваемых данных между университетами.

В 1986-м был разработан и внедрен NNTP (Network News Transfer Protocol) для улучшения работы с новостями в Usenet.

В 1987 году число хостов превысило 10 000. Построением NSFNET стали заниматься консорциумы IBM, MCI и MERIT.

2 ноября 1988 года выпускник Корнельского университета Роберт Таппан Моррис запустил в сети свою программу, которая из-за ошибки (а может, и по злому умыслу) начала бесконтрольное распространение и многократное инфицирование узлов сети. В результате было инфицировано около 6200 машин, что составило примерно 8 процентов общей численности машин в сети. В связи с этим был сформирована CERT (Computer Emergency Response Team).


Спецвыпуск Xakep, номер #014, стр. 014-054-1, Трансгрессивный киберпанк

Трансгрессивный киберпанк

Спецвыпуск Xakep, номер #014, стр. 014-054-1

Даниил Шеповалов (oan@xakep.ru)

<Ну и что же это такое, трансгрессивный киберпанк?> - сходу спросят особо любопытные читатели. Я - без понятия. Но звучит офигительно. Я тут увидел недавно по ТВ такую рекламу: <Когда вы последний раз были в театре? А в музее? И вы считаете себя культурным человеком?>. Не, ну не дерьмо ли! Хочется спросить: <Когда вы в последний раз были на демо-пати? Или на техно-оупен эйере?> Культура ведь, как и все на свете, вещь сложная и многогранная. А потому довольно глупо считать какую-либо из субкультур, например театральную, наиболее выдающейся и важной. Прошлое - это, конечно, весьма интересно и поучительно, но нам бы с настоящим разобраться успеть. А настоящее - это суперкомпьютеры в жидком азоте, глобальные информационные сети, урбанистические биг-маки и, конечно же, люди. Люди, которым здорово повезло жить в такое захватывающее время. Ну а трансгрессивным киберпанком я называю книги обо всем этом... о нас с вами

Классики:

Это сейчас www-адрес есть чуть ли ни у каждой коммерческой палатки, торгующей сигаретами, с экрана ТВ на нас целыми днями смотрит реклама Яндекса, а добрая треть новостей по радио касается компьютерных вирусов. А помнишь, как еще несколько лет назад это была совершенно отдельная от повседневной жизни субкультура. И избранные посвященные с замиранием сердца узнавали, что они не одиноки. Что для других людей эта горстка железа тоже является культом, религией, смыслом существования. <Военные игры>, сборник , <Нейромантик> - когда я нашел это в библиотеке, моему счастью не было предела. Художественные книги о компьютерах... сетях... хакерах, нет, этого просто не может быть.

Дэвид Бишоф <Военные игры> (War Games)

Начало 80-х, все прогрессивное человечество озабочено проблемой Третьей Мировой Войны. По всеобщим ожиданиям - термоядерной. Октябрят и пионеров по одну сторону океана пугают Хиросимой. Бойскаутов по другую - атомными подводными лодками и красной угрозой в целом. В Штатах догнивают останки последних хиппи, религия нынешнего поколения тинейджеров - видео-игры и новая волна. Именно в этой тревожной атмосфере и становится бестселлером своевременное творение Дэвида Бишофа. Его герой - бледный компьютерный маньяк, среднестатистический американский школьник, Дэвид Лайтмен. Лайтмен пишет игрушки, ворует свежий софт с помощью модема и сует свой нос куда не следует. Его тошнит от родителей, учителей и дегенератов-сверстников. В общем, типичная картина из цикла <Родители меня не понимают, матрица мой дом. Мои слезы, моя печаль... е... аха>. Но вдруг парню подфартило - ему попадается девочка с большими буферами, и, выпендриваясь перед ней, наш дружок случайно активизирует жуткую программу искусственного интеллекта. Которая хочет ни много ни мало - развязать пресловутую термоядерную войну. (Ах, как я ее понимаю. Вот оно - единственное достойное будущее разумного человечества!) Сумасшедшие программисты, подбор паролей, подростковый секс в воде и 60-секундное наведение на цель перед пуском межконтинентальной баллистической ракеты - все составляющие неплохого sci-боевика смиксованы здесь в нужных пропорциях. К тому же на твоем лице не раз появятся слезы умиления после прочтения фраз вроде <Дэвид мог программировать и в машинных кодах, но эту программу проще было написать на языке Бейсик>.


Спецвыпуск Xakep, номер #014, стр. 014-054-2, Трансгрессивный киберпанк

Трансгрессивный киберпанк

Спецвыпуск Xakep, номер #014, стр. 014-054-2

Электронная версия: http://lib.ru/ INFANT/ BISHOF/wargames.txt

Джон Варли <Нажмите ВВОД> (Press ENTER)

Варли - первый, кто начал спекулировать заезженной идеей <Компьютеры погубят мир> в качественно новом формате. Все начинается с загадочного самоубийства некого ультра-мега-хакера. В его доме находят две тонны всевозможных наркотиков и семь центнеров электронно-вычислительного хлама. Для глухой американской деревушки событие из ряда вон выходящее, а потому в район боевых действий высылают тяжелую артиллерию: компьютерно озабоченную студентку-отличницу и десяток агентов ФБР. На протяжении всего повествования Варли смакует две темы:

1. Роман чокнутой студентки с неким припадочным ветераном корейской войны.

2. Непомерную крутость ультра-мега-хакера, который заставил весь мир прогнуться под него в буквальном смысле.

Копаясь в файлах усопшего бойца невидимого фронта, студентка находит тотальнейший беспредел, коды доступа к ядерным кнопкам (ну а как же без этого) и остатки деятельности некого электронного разума. Долгими ночами данная тетка и корейский ветеран не беспросветно трахаются (что непременно произошло бы у того же Бишофа), а ведут нудные разговоры на тему <Тварь я я дрожащая или право имею добавить десяток нулей к своему банковскому счету?> и <Что круче - человеческий мозг или нейро-сеть из кофеварок?>. В итоге торжествует непознанный мега-компьютерный разум, а бренные людишки погибают при загадочных обстоятельствах. Кто-то сует голову в микроволновку (автор весьма реалистично описывает процесс вылезания из орбит глазных яблок), а кто-то разносит в клочья свой мозг из служебного пистолета. В живых остается только корейский ветеран, который просекает что к чему и по телефону торжественно клянется мега-мозгу хранить молчание. Однако все его выводы можно подвергнуть серьезному сомнению, так как в конце повествования данный перец, нажравшись переамфетаминенных таблеток от спазмов, выдирает с корнем все телефонные и электронесущие кабели в своем доме, выкидывает электронные часы и вообще весьма реалистично претендует на диагноз <Шизофрения. Мания преследования>.

Электронная версия: http://lib.ru/INOFANT/WARLI/enter.txt

Уильям Гибсон <Нейромантик> (Neuromancer)

Если и существует вообще эталон киберпанка, то им может быть только <Нейромантик>. Гибсон вообще - немереный дважды отец всея сете- и хакеротуры, а также идеи Матрицы как таковой. Делать обзор <Нейромантика> - это все равно что пересказать в общих чертах Новый Завет. Разорвут ведь! Буквально разорвут на части за неуважение к махагуру и трижды сенсею научно-технической революции. Запомни главное: ты обязан это прочитать! Ты просто не имеешь никакого морального права не ознакомиться с этим шедевром! <Нирвана>, <Матрица>, <Сеть> - все это просто плагиат, спекуляции на основе непревзойденного гения Гибсона. <Матрица - консенсуальная галлюцинация, ежедневно разделяемая миллиардами пользователей со всей планеты>, - это определение дал именно он. Наиболее емко смог передать основную тему романа соавтор Гибсона, Брюс Стерлинг: <На протяжении всего повествования совершается около четырех сотен различных преступлений. Как только в книге появляются обычные люди или представители властей, их почти немедленно убивают. В результате, всех побеждает искусственный интеллект, влюбленные же, наоборот, расходятся в разные стороны>. Так и есть. Повсюду царит мрачный блэйдранеровский урбан, наркотики, нелегальные клиники, импланты, нейро-токсины и высокие технологии, полигоном для испытания которых являются герои <Нейромантика>. Это наше будущее. Без сомнения.


Спецвыпуск Xakep, номер #014, стр. 014-054-3, Трансгрессивный киберпанк

Трансгрессивный киберпанк

Спецвыпуск Xakep, номер #014, стр. 014-054-3

<Кейс работал, по уши купаясь в адреналине, продукт и молодости и сноровки, подключенный к переходнику инфопространства, трансформирующего его бестелесную сознательную сущность в череду согласованных галлюцинаций, из которых и образовывалась Матрица. Вор, он работал на других, более богатых воров, работодателей, занимающихся разработкой экзотических программных продуктов - программ для проникновения сквозь блистающие заграждения защитных систем корпораций и отпирания дверей к богатейшим информационным полям>.

<А затем они повредили его нервную систему русским боевым микотоксином. Привязанный к кровати в отеле <Мемфис>, он галлюцинировал тридцать часов подряд, а его талант выгорал из него микрон за микроном>.

Электронная версия: http://lib.ru/GIBSON/gibso01.txt

(Советую тебе также прочитать две другие части трилогии Гибсона: Mona Lisa Overdrive и Count Zero)

Виктор Пелевин <Принц Госплана>

<Ну какой же Пелевин классик? - с упреком спросишь ты. - Это ж всего лишь графоманствующий буддист с перманентным распадом личности, коих в последнее время развелось немерено>. И будешь прав, прав как всегда... Но <Принц>... <Принц Персии>. В конце 80-х - начале 90-х на этой игре торчала вся технотронно-интеллектуальная элита нашей отчизны. Закрытые НИИ и атомные станции, отделы статистики и секретные КБ - повсюду персонал клал известный девайс на свою работу и просиживал сутками напролет за Prince of Persia, Cat, Spy vs Spy... эти игры можно было пересчитать буквально по пальцам. Иногда и нам (сыновьям/племянникам/братьям) кое-что перепадало, и мы потихоньку подсаживались на захватывающий виртуальный мир по ту сторону монитора. В Госплане Пелевина странно-вложено-и-вроде-как-символично переплетается объективная серая реальность советских трудовых будней и яркие игровые образы. В метрополитене появляется кроваво-стальная разрезалка на части из <Принца>, игрушечный взрыв ракеты на экране монитора разносит в клочья сидящего перед компом игрока, а электронный самурай отрубает голову шефу одного из отделов. В общем, творится типичный пелевинский беспредел и тотальное надругательство над здравым смыслом читателя. Однако один из аспектов подобной гиперболы несомненно справедлив: компьютерная игра в Госплане полностью захватывает сознание игрока. Работники данного учреждения уже не могут обсуждать что-либо, кроме своих виртуальных похождений:


Спецвыпуск Xakep, номер #014, стр. 014-054-4, Трансгрессивный киберпанк

Трансгрессивный киберпанк

Спецвыпуск Xakep, номер #014, стр. 014-054-4

<Друзья! Мы собрались здесь по поводу, торжественному и приятному вдвойне. Сегодня исполняется двадцать лет трудовой деятельности Кузьмы Ульяновича Старопопикова в Госплане. И сегодня же утром Кузьма Ульянович сбил над Ливией свой тысячный МИГ!>

Так что если ты хочешь слегка поностальгировать по 16-разрядному детству/отрочеству/юности - это твоя книга. Ну а на излишне дзеновые смысловые текстовороты Пелевина можно с легкостью положить. Ну в самом деле, не будешь же ты вдумываться в темы вроде:

- Вы - Кузьма Ульянович Старопопиков? - громко спросил один из подошедших - по-русски он говорил с сильным акцентом и, как и второй, был курчав, черен и небрит.

- Да, - с удивлением ответил Кузьма Ульянович.

- Организация Освобождения Палестины приговорила вас к смерти, - сказал он, доставая из кармана длинный пистолет.

Электронная версия: http://lib.ru/PELEWIN/ prince.txt

И современники:

Ностальгия ностальгией, однако наш паровоз вперед летит. Быть может, лет эдак через 20-30 мы и превратимся в мудрых консерваторов с зачатками старческого маразма. Будем ворчать на отбившуюся от рук молодежь: мы, дескать, в ваши годы подружек не клонировали и электроды в мозг не вживляли... Но сейчас мы молодые, умные и красивые, а потому несемся на гребне информационного прогресса и не боимся никаких перемен.

Мэри Шелли <Паутина>

Мэри Шелли - виртуальная личность, кто-то очень известный и крутой, немереный папа, сенсей, однако скрывающийся под псевдонимом (уже очень долгое время). А <Паутина> - первый достойный русскоязычный роман на хакеро-интернетовскую тематику. Все действие происходит в недалеком будушем, на которое проецируются все отличительные черты нашего электронного настоящего. <Паутина> - шедевр, рядом с которым никто из соотечественников даже рядом не валялся. А потому я просто восторженно заткнусь и приведу несколько цитат из текста. Они говорят сами за себя.

<В 2013-м в крупнейшем амстердамском кибер-борделе самообучающаяся программа убила за один вечер трех извращенцев сразу>.

<И вот подходит к нам в кафе очередная плеченогая фея из <Нетпросвета>, и давай впаривать какие-то якобы очень крутые и запрещенные варежки. Хотя даже невооруженным лаптем видно, что все ее флэшки нафаршированы троянами УКИБа так, что вот-вот звезды на пластике проступят. Ну, мы этой козе вежливо так говорим - мол, ваша циска купила бы тампакс и заткнулась, не мешала честным кодерам иметь свою Хакнутую Мэри>.

<Да мы ему мозги сожгли. Комп ему через Сетку не вынесешь, не те вольты. Но если он себе прямо в башку наше кино качал через нейрощуп... Да с усилителем - чтоб лучше слышать... Да без фильтров-предохранителей - чтоб быстрее бегать...>

- Думаешь, из Саида сделали какого-нибудь... электроклоуна?

- Боюсь, похуже. Прямое нейрозондирование используют, когда надо из человека выкачать мемуары. В остальном оно без юза. Зато человеку - кранты, потому что мозг после такого скана нарезан слоями в тысячи раз тоньше, чем огурцы на праздник.


Спецвыпуск Xakep, номер #014, стр. 014-054-5, Трансгрессивный киберпанк

Трансгрессивный киберпанк

Спецвыпуск Xakep, номер #014, стр. 014-054-5

<КиттиДжамп - КОРМ СУХОЙ, СКАЧЕТ ПРЯМО КАК ЖИВОЙ! В каждой второй упаковке - купон на 10 часов бесплатного подключения Вашего кота к серверам сети CatNet>.

Электронная версия: http://www.fuga.ru/shelley/ pautina

Мэри Шелли <2048>

Товарищ Шелли (ведь стопудово - мужчина) совсем распустил свою заметно подпорченную психотропами фантазию и снова нарисовал нам весьма реалистичную картину ближайшего будущего. Пройдет еще несколько лет после <паутинового> мира и все области человеческого знания сплетутся в одну громадную нейро-кибернетическую сеть. На каждом человеке (даже в самом захудалом Китае-9) будет надет робо-скин (искин), обладающий гипер-мега-транс искусственным интеллектом и просто пугающими возможностями. Браузеры теперь показывают не интернет-сайты, а буквально содержимое человеческого мозга, хакеры ломают психику и эмоциональную защиту обывателей, крекеры деактивируют и перепродают искины (а людей незатейливо на органы пускают), студенты с допотопными лэптопами взрывают к чертовой бабушке космические корабли, а на мозгах среднестатистических обывателей обсчитывают свои задачи лицемерные корпорации. Короче - апокалипсис сегодня. Увлечение всех и вся - дремли, что-то типа заранее запрограммированного копьютерно-психоделического сна-трипа, полное погружение в сюжет с помощью своих мозгов и дремодема. И вдруг ведущий дремль-мастер Дремлин Студиос видит дремль без дремодема (какой ужас!). И даже без цифровой кислоты, как заботливо сообщает мастеру его искин, по-быстрому проанализировавший состояние организма. Однако автор тут же бросает не успевший еще завязаться сюжет и начинает развертывать другой. Он буквально захлебывается в событиях и лицах, так много всего хочет передать на бумаге его воспаленное воображение. Вот Рамакришна, босс-мультиперсонал Дремлин Студиос с электронными внутренностями и рассемерением (!) личности сменяется суперменским искином-призраком, который пытается захватить Сеть. Или на месте загадочной красотки с боевыми сексуальными запахами (эрекция в наличии у всего ресторана, в котором она изволит обедать) вдруг появляется охотник за искинами с механической хирурго-рукой, нейро-щупами, нано-транками и прибором инфракрасного видения в веках. Вот это шиза! Но абсолютно нельзя оторваться!!!

Электронная версия: http://www.fuga.ru/shelley/2048

Сергей Лукьяненко <Лабиринт Отражений>

Любимец всех фидошников, товарищ Лукьяненко, более консервативен, нежели Шелли. В его мире будущего ты уже не встретишь никаких нано-транков и цифровых диоксидов. Но у Сережи тоже есть своя фишка - Глубина. Глубина - это вроде как проапгрейженная версия VRML'ного Интернета. Юзер надевает виртуальный шлем (или в костюм целый запрыгивает, если в чат какой горяченький идет), включает специальную визуальную интру и его мозг уносится в мир Глубины, начинает воспринимать его как единственно реальную действительность... или действительную реальность, если хочешь. В то время как сам этот мир лишь неряшливо набросан ленивыми дизайнерами, десять полигонов здесь, двадцать там - а стимулированный хитрой прогой мозг уже сам додумывает мелкие детали и придает всему вид всамделишной заправды (ни фига себе я словосочетания генерить стал). Однако есть одна проблема - по собственному желанию из Глубины не выплыть, надо таймер ставить и надеяться на бесперебойность питания. То есть это обычным людям не выплыть: существуют особо одаренные мутанты - <дайверы>, которым это раз плюнуть. И по всему выходит так, что эти дайверы суть самые крутые глубинные хакеры, поскольку обладают столь редкой фичей. А так как подобных генетических уродов - один на сотню миллионов, разворачиваются вокруг их скромных личностей недетские бои супер-корпораций. Сюжет есть? Есть сюжет! В целом все достойно: вирусы, трояны, схватки в онлайне, планета под ударом и прочие занимательные фишки присутствуют. Слегка напрягает разве что излишний пафос и интеллигентская рефлексия автора, но это, опять же, кому как. Ну а вот чем дядь Сережа особенно порадовал, так это Лабиринтом Смерти. То есть Quake по нашему. В этом Лабиринте у Лукьянеко на протяжении доброй трети книги происходят весьма интересные кровавые разборки, что заставит сердце любого геймера биться крайне неровно. Ну где ты еще преподробнейшие литературные описания дефматчей будущего найдешь?


Спецвыпуск Xakep, номер #014, стр. 014-054-6, Трансгрессивный киберпанк

Трансгрессивный киберпанк

Спецвыпуск Xakep, номер #014, стр. 014-054-6

Электронная версия: http://www.lib.ru/LUKXQN/labirint.txt

Сергей Лукьяненко <Фальшивые Зеркала>

Продолжение <Лабиринта Отражений>. Глубина стала еще глубже, дайверов еще меньше, а у стандартного deep-скина <Грузчик>, оказывается, нет члена, чтобы хорошенько трахнуть deep-скин . Чего? Какие еще министерства? Какая цензура? А, ну ладно, больше не буду. Но ты, приятель, запомни - я, конечно, не берусь судить, как там у Лукьяненко с личной жизнью, но книжки у него не по-детски озабоченные. Однако не суть... Что меня просто восхитило - автор не забросил тему художественно-показательных дефматчей, а наоборот существенно ее расширил и углубил. Теперь Лабиринт Смерти - это Unreal. Да-да, самый что ни на есть натуральный Unreal, я его сразу же узнал. Вообще существует мнение, что дядя Сережа серьезно поехал на 3D-шутерах, коль уже не в первом и даже не во втором его произведении замечают буквально религиозное воспевание оного игрового жанра. Но, опять же, не суть: нам подобные сдвиги - сплошное удовольствие. Автор постоянно ставит перед читателем какие-то глобально-неразрешимо-устаревшие проблемы. Контакт обретающей интеллект супер-программы с человеком, конфликт любви виртуальной и реальной - как вообще можно заниматься подобным высосанным из пальца бредом? Ладно, это я, конечно, слишком суров и предвзят по отношению к Сереже. В целом же - ай, молодца! Красочные описания сетевого мира, интересные новые идеи, неожиданные образы - все это действительно очень захватывает. Но, сколько же ты еще, гад, будешь терзать нас своими интеллигентскими загонами, а? И не надо меня тут успокаивать - он первый начал! Ну хорошо, хорошо, заканчиваю. В общем, так, фэллас: <Зеркала> от <Лабиринта> отличаются так же, как и второй Fallout от первого. Да многогранней, да шире, да ярче, но идея та же самая. Так что если тебе понравилась первая книга Лукьяненко - не раздумывая, принимайся за вторую.


Спецвыпуск Xakep, номер #014, стр. 014-054-7, Трансгрессивный киберпанк

Трансгрессивный киберпанк

Спецвыпуск Xakep, номер #014, стр. 014-054-7

<Глубина, глубина, я не твой, отпусти меня, глубина!>

...определенно шизофреник...от-пу-скааа-ююю...

Электронная версия: http://www.lib.ru/ LUKXQN/mirrors.txt

Александр Лазаревич <Сеть НАНОТЕХ>

Однако... Такой шизы даже я бы не смог придумать. В общем, дело обстоит так: повcюду вокруг и внутри нас кишат миниатюрные бактерии-роботы, созданные по последнему слову (двоичному) нанотехнологии. Роботы эти размножаются с космической скоростью, жонглируют атомами, как хотят, могут хранить сотни мегабайт информации и вообще явно символизируют своим появлением конец света. Но из бутылки этих джинов выпустили совсем даже не космические захватчики, а голодные российские ученые, в руках которых остались разработки сверхсекретных нано-лабораторий. Бактерии-роботы образуют собой сеть <Нанотех>: каждая бактерия через своих соседей может связаться с любой другой бактерией-роботом на планете посредством инфракрасной связи. И администратор сети <Нанотех> буквально уподобляется богу: он может все видеть (передача визуальной информации из любой точки планеты прямо на зрительный нерв админа), управлять действиями людей, синтезировать из воздуха любые предметы (в том числе оружие и наркотики - обычные пользователи таких прав не имеют), в общем, он может фактически все. И жить бы этим российским администраторам в свое удовольствие, однако умные дяди из Массачусетского Технологического сумели разглядеть в свои туннельные микроскопы надпись <Сделано в СССР> толщиной ровно в один атом на поверхности пресловутых роботов. И понеслась. Обе сверхдержавы нанимают хакеров, нейрохирургов и черта лысого, чтобы вырвать у бедных админов их коды доступа, пароли и явки. А какой смысл: вырвут не вырвут, в любом случае мы все тут самоуничтожимся на этой отсталой планете, лежащей за миллиарды световых лет от главных интергалактических информационных супермагистралей.

<АЛ:> НАНОТЕХ

НТ:> К РАБОТЕ ГОТОВ

АЛ:> СНИЗИТЬ КРОВЯНОЕ ДАВЛЕНИЕ, НОРМАЛИЗОВАТЬ ДЫХАНИЕ,

СНЯТЬ ОБЩЕЕ ВОЗБУЖДЕНИЕ МОЗГА>

Эх, мне бы права админа в такой сеточке. Я бы уж точно кое-кому кровяное давление снизил...

Электронная версия: http://lib.ru/LAZAREWICH/nanoteh.txt

P.S. Обычно критики не любят хорошие книги. Потому что по-настоящему блеснуть интеллектом можно только на полном, извиняюсь, дерьме. И практически в любом книгофильском обзоре из 5 книг 3 обязательно окажутся отстоем. Но Х - не любой журнал. Мы советуем тебе прочитать все, о чем упоминалось в этом обзоре. Быть может, увлекшись этим чтивом ты и пропадешь на пару недель для общества, но... Но вернешься ты уже другим, полным энтузиазма и новых знаний. И тут же сладострастно опустишь свои пальцы на клавиатуру, дабы со свежими силами заняться своим любимым темным делом.


Спецвыпуск Xakep, номер #014, стр. 014-058-1, Камасутра для ВИНДОВЗ

Камасутра для ВИНДОВЗ

Даниил Шеповалов (dan@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-058-1

<То есть мы

будем все это время стоять здесь как

школьница,

которая

спустила

юбчонку, закрыла глаза и ждет,

пока ее

трахнет сзади

садовник...>

Ник Перумов,

<Не время

для Драконов>

еня очень часто спрашивают, кто такой маленький ослик Федя и почему я так часто упоминаю о нем в своих текстах. Отвечаю: однажды, листая какие-то глянцевые журналы в парикмахерской, я наткнулся на следующую фразу: <Кроме того, грудь растет, как на дрожжах, если ее регулярно натирать спермой годовалого осленка!>. Если кто не верит - откройте журнал <Птюч> №8 за 1998 год на странице 38. А большая грудь - это моя слабость. В то время у меня еще была подружка женского пола, однако ее нельзя было трахать между грудей из-за их малого размера. Ну я и приобрел у знакомого сторожа зоопарка годовалого ослика. И так он мне понравился, что я выгнал на фиг подружку. Теперь мы с маленьким осликом Федей живем душа в душу. Ну и с кошкой еще. Такая вот сентиментальная история из жизни Самого.

Однако наша тема нынче не развращение несовершеннолетних осликов и не оральный секс с личинками биомеханических насекомых, а совсем даже наоборот: эффективное и плодотворное совокупление с самой сексапильной операционной системой всех времен и народов - Windows.

При овладевании приемами тантрического изнасилования творений <Майкрософта> не следует пренебрегать созданием соответствующей интимной обстановки. Во-первых, необходимо наклеить на стены подходящие к случаю плакаты: портрет доктора Геббельса в полный рост, рекламный постер OS/2, распечатку ядра Linux и т. д. Также свой вклад в увеличение твоей ментально-электронной потенции может сделать правильно подобранная музыкальная тема. Здесь ты можешь проявить свою изощренную фантазию, ведь на вкус и цвет, как известно, товарищей не сыщешь. Разве что могу посоветовать тебе использовать музыку из фильма <Криминальное Чтиво>. Да-да, ту самую, под которую криков не слышно. Ну а особым эстетам - владельцам Windows Millenium, могу порекомендовать композицию Scooter'а . В качестве благовоний же можешь заюзать свернутые в трубочку книги и <Разбираемся с WinAPI>.

Ну а теперь описание самых эффектных поз и способов получения божественного удовольствия.

ПОЗА N0: Истинная многозадачность орально ласкает нефритовый стержень

Вытащи из компа все микросхемы памяти, кроме одной - мегабайт 16, так и быть уж, оставь. Также неплохо бы было забить весь жесткий диск тяжеловесной порнухой, дабы Windows не особо надеялась на создание файлов подкачки. Теперь выдели на рабочем столе все ярлыки и запусти их на выполнение. Было бы просто великолепно, если бы среди твоих прог нашлись настоящие монстры: 3D MAX, Visual C++, Delphi, пара-тройка 3D-шутеров и несколько старых досовских программ, написанных на асме и использующих самые недокументированные функции и наиболее левые прерывания из теоретически возможных. Ну а когда маздай с видом лопающейся лягушки будет громыхать винтом и кидаться окошками с содержимым стека и регистров, ты должен эффектно двигать тазом в духе Майкла Джексона и громко кричать <Давай-давай, не уставай!!!>.


Спецвыпуск Xakep, номер #014, стр. 014-058-2, Камасутра для ВИНДОВЗ

Камасутра для ВИНДОВЗ

Даниил Шеповалов (dan@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-058-2

ПОЗА N1: Юная FAT32 становится на колени, слегка приподняв девственную попку

Запусти несколько сессий Volcov Commander'а, желательно версии эдак 0.52 или еще древнее. В каждом из них запусти процесс копирования системных файлов Windows из каталога SYSTEM в каталог TRASH. Попутно следует также устроить дефрагментацию диска сразу пятью-шестью утилитами: стандартным Defrag'ом, NDD, левой прогой, которую тебе прислал по почте студент из Алабамы, и другими подручными средствами. Когда же маздай попросит у тебя вставить инсталляционный диск, чтобы установить потерянные файлы, ты должен надеть на член диск с дистрибутивом Windows (предварительно расширив отверстие), открыть трей CD-ROM'а и, сладострастно постанывая, пытаться засунуть туда свой орган. Во время всех этих манипуляций ты должен непременно шептать: <Да! Да! Сделай это, девочка! Возьми его...> Ну а для грандиозного финального оргазма вполне подойдет форматирование двух дискет в паре с одновременным сканированием твоей голой задницы.

ПОЗА N2: Технология PNP имеет сама себя во все порты ввода-вывода

Тебе понадобится несколько дешевых старых ISA'шных плат, желательно китайского производства и самой что ни на есть убогой сборки. Очень хорошо если это будут какие-нибудь видеобластеры времен осады Севастополя и высадки человека на Луну. Оперативно вставляй их в свободные слоты и загружай Windows. Майкрософтовский гений не оставит ей ни единого шанса - сразу же запустится автоматический поиск новых устройств. После часового скрежета винтом опущенная система выдаст тебе несколько сообщений, от <Обнаружен джойстик фирмы Lohitech, интегрированный в планшетный сканер Motorolla> до <Обнаружено фиг знает что, но у меня в запасе куча драйверов - давайте попробуем установить>. На все вопросы отвечай незатейливо: <Да> и <Принять>. Ну а после наслаждайся 24-часовой перезагрузкой, во время которой маздай будет жонглировать запросами на прерывания, каналами DMA и прочей гадостью, пытаясь автоматически настроить твои планшетные сканеры и устройства записи компакт-дисков.

ПОЗА N3: Невинная операционка наслаждается грязными базарами

Поза для извращенцев со стажем, не имеющих никаких предубеждений относительно способов получения сексуального удовольствия. Пригласи к себе домой свою подружку и попроси ее записать томным голосом несколько wav-файлов. Каждый из них должен содержать фразы вроде <Ну трахни же меня скорее, как последнюю тварь!> и <Да, да! Кончай мне прямо в порт!>. А теперь в настройках звука присвой каждому ответственному событию соответствующее звуковое сопровождение. Тут опять же присутствует широкий оперативный простор для твоей извращенной фантазии. Меня, например, после загрузки Windows встречает словами <Ну скажи, что я сучка! О, я такая порочная...>. Для усиления эффекта присутствия можешь поставить в качестве обоев фотографию какой-нибудь размалеванной девочки не особо серьезного поведения.

ПОЗА N4: Групповое изнасилование девственной системы с элементами некрофилии


Спецвыпуск Xakep, номер #014, стр. 014-058-3, Камасутра для ВИНДОВЗ

Камасутра для ВИНДОВЗ

Даниил Шеповалов (dan@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-058-3

Ты ведь не жадный перец, правда? Позволь и другим людям насладиться твоей сладенькой операционкой. А наиболее эффективно сделать это тебе позволит <глобальная компьютерная сеть Интернет>. Для начала ты должен запускать все приаттаченные к левым письмам макросы, программки и почтовые открытки - это позволит внешнему миру тщательно подготовиться к интимной встрече. Не устанавливай никаких патчей и дополнений, убери всю защиту от нюков и сканеров, будь открытым! А теперь настает звездный час для твоей системы - заходи на канал #x и посылай всех открытым текстом. Назови тамошних посетителей ламерьем и кретинами, озабоченными тинейджерами и сосунками. Скажи, что ты - бог компьютерной безопасности и никто не сможет надругаться над твоим компом. А теперь закрой глаза и представь, как десятки виртуальных членов потянулись ко всем открытым портам. Представь, как Windows начала захлебываться в цифровой сперме, как каждая ее динамическая библиотека содрогается в мучительном оргазме. Открой глаза. Синий экран. Дохлая система. Windows больше нет, детка, Windows больше нет.


Спецвыпуск Xakep, номер #014, стр. 014-060-1, Защити свою Win2k

Защити свою Win2k

Спецвыпуск Xakep, номер #014, стр. 014-060-1

Почти все о том, как сделать защищенной Windows 2000 Prof

Андрей Князев (knyazev@real.xakep.ru)

Если тебе повезло :), и ты купил прошлый номер Х, то в нем мог прочитать статью, рассказывающую о Whistler - aka Windows XP - новейшей ОСи от Micro$oft. Но пока ХР еще не зарелизена (выпуск ХР ожидается не раньше этого лета) все равно актуален вопрос о том, какую же ОСь стоит использовать для постоянного употребления :).

Не секрет, что совсем немало пользователей юзают линейку Win 9x - Win 98 или Ме. Конечно, это мультимедийные, дружелюбные, но... как бы это помягче сказать - не совсем "правильные" операционки. Линейка Win 9х никогда не отличалась ни стабильностью, ни уж, тем более, безопасностью. Конечно, в плане удобства - пресловутого usability - эти ОСи хороши, но не настолько, чтобы ради каких-то "удобств" жертвовать безопасностью своих данных. Но какие есть варианты? Windows NT 4 - хорошая система, но нужно признать честно, морально устаревшая: никаких тебе новейших игр (т. к. последний DirectX, официально поддерживаемый NT - это DirectX 3, а неофициально - DirectX 5), никакого USB и Plug'n'Play (впрочем, последнее - это скорее плюс, чем минус, хотя кому как). Windows XP же пребывает еще в состоянии бета-версии. До сих пор не вышел даже Release Candidate - кандидат на выпуск (выход RC говорит о том, что эта ОСь почти закончена, и ее финальный релиз не за самыми большими горами). Что же остается - остается Windows 2000 Professional - ядро и надежность от NT 4 + интерфейс от Win 9x. Но, к сожалению, и эта операционка не лишена определенных недостатков, в том числе и в плане безопасности. Часть этих багов восходит еще к старушке NT, часть - благоприобретенные самой win2k. Но как бы то ни было, все основные бреши закрыть можно, и тогда ты будешь вполне реально защищен.

Одно маленькое предупреждение. Конечно, я постараюсь максимально рассказать о том, как сделать win2k безопасной системой. Но каждый день обнаруживают новые дыры, которые M$ залатывает. Иногда оперативно, иногда не очень. Так что мой главный совет на будущее - посещай Microsoft.ru и периодически отгружай себе самые свежие обновления, особенно это касается Service Pack'ов - как для самой ОСи, так и для Internet Explorer'a.

И еще один warning - касательно того самого IE. Как бы ни ругали M$, но многие пользуются ее продуктами. Причем стремятся пользовать самые последние, но и самые "сырые" продукты. Использование win2k подразумевает использование IE, точнее IE5+. 5-й Internet Explorer, конечно, гораздо удобнее четвертого, но с безопасностью у него проблем гораздо больше. Т. е. помимо брешей в самой ОСи существует немало back doors внутри IE5. К сожалению, рассказ о Internet Explorer 5 находится вне темы данной статьи, но к проблеме безопасности IE5 мы еще обязательно вернемся. А пока - один простой совет, если решил заняться своей безопасностью: обязательно установи самый последний Service Pack - Service Release - и самые важные (т. е. настоятельно рекомендуемые) HotFix'ы для IE5. Иначе, даже сделав защищенной свою Ось, ты все равно будешь сидеть на "дырявой", по причине 5-го IE, машине.


Спецвыпуск Xakep, номер #014, стр. 014-060-2, Защити свою Win2k

Защити свою Win2k

Спецвыпуск Xakep, номер #014, стр. 014-060-2

Ну что же - все предупреждения сделали, пора и в путь двигаться, даешь Secured Win2k!

Установка

Первое, что необходимо сделать, если у тебя уже стоит Win2k - это поставить 1-й Пакет обновлений для Win2k - он же Service Pack 1, он же SP1.

Если же ты еще только собираешь ставить себе Win2k, то можно поступить хитрее - пропатчить "на корню" дистрибутив Win2k. Тогда Win2k поставится уже вместе с SP1 и его не придется устанавливать поверх ОСи. Тем самым ты сэкономишь себе немного времени и сил :).

Сначала тебе придется скопировать дистрибутив Win2k на хард. Например, в папку C:\Win2ki386.

Затем берется файл sp1network.exe - полная (сетевая) версия SP1, которую проще всего позаимствовать на сидюке где-нибудь в районе M1T1N0 BaZaaR. Конечно, искомое можно отгрузить себе - около 88 Мб с какого-нибудь ftp'шника, благо есть www.filesearch.ru, или непосредственно с http://download.microsoft.com/download/win2000platform/SP/SP1/NT5/RU/sp1network.exe.

После того, как файло добыли - распаковываем его в какую-нибудь временную директорию, например в C:\Win2kSP1.

Пишем - sp1network.exe -x.

Тебя спрашивают - куда (распаковываем)? Ну а ты в ответ: естественно, туда! :)

После того как сервис пак распаковался (а распаковался он все равно немного "коряво"), в C:\Win2kSP1\i386, пишем длинную команду:

C:\Win2kSP1\i386\Update\Update.exe -s:C:\Win2ki386

После такой мощной :) команды запустится инсталлятор (чуть не забыл - все эти маневры нужно делать под какой-нибудь из Виндов), который немного пошуршит, попишет, да и сольет воедино дистрибутив Win2k и SP1, после чего все это дело можно легко и непринужденно поставить на комп.

И еще один маленький установочный Tip. Win2k лучше ставить на комп, где есть минимум 2 (а лучше даже и 3) логических диска. Первый диск остается для всяких "экскрементов" :) в системе FAT16 (хотя лучше сперва поставить Win95-DOS, чтобы была не FAT16, а VFAT). Второй-третий диски, безусловно, форматируются в NTFS - фирменную Win2k (NT) файловую систему, обладающую всеми вкусностями, которых только можно ожидать.

Замечу еще, что только в Win2k у NTFS появилась давно ожидаемая функция - квотирование дискового пространства. Т. е. легким движением руки можно ограничить дисковую квоту любимого брата (сестры) в 5-10-100 мегов, а все остальное дисковое пространство оставить себе, любимому. И, главное, никто ничего не заподозрит - диск кончился. И все тут :).

Но поставить ОСь - дело не очень долгое (и хитрое). Гораздо сложнее ее потом настроить.

Настройка установок безопасности

Я думаю, что не стоит делать разницы между уязвимостью компьютера извне и снаружи. Запустив по дури (по-другому и не бывает) хорошего трояна, ты тем самым сможешь открыть доступ ко всему компу. Так что нужно быть максимально внимательным, и делать все секьюрные мероприятия по максимуму.

Для начала стоит включить опцию очистки файла подкачки (то, что называлось swap-file в Win 9x и называется page-file в Win2k, файл pagefile.sys в корне каждого или только системного диска) после завершения работы. Зачем? Все очень просто: своп - это "мусорная свалка" твоего компа. И система сбрасывает туда все мыслимые и немыслимые данные. В том числе и пароли.


Спецвыпуск Xakep, номер #014, стр. 014-060-3, Защити свою Win2k

Защити свою Win2k

Спецвыпуск Xakep, номер #014, стр. 014-060-3

(По совести замечу, что при включении этой опции, данные все равно не удаляются, в общем смысле слова. Файл подкачки - это "страничный" файл, т. е. он разбит на "страницы". При выключении питания все неактивные страницы "забиваются" нулями, а данные активных страниц памяти все равно остаются в свопе, впрочем, это не критично, т. к. все секьюрные данные эта опция позволит затереть.)

Итак, берем редактор реестра (лучше всегда пользоваться regedt32.exe), идем в ветвь:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management.

Добавляем REG_DWORD параметр с именем ClearPageFileAtShudown.

Значение параметра ставим в 1 (0 - дефолтное значение, когда ничего не очищается). Учти, что включение очистки страничного файла можем немного замедлить shutdown, но удовольствие :) того стоит.

Следующая брешь, хотя вернее сказать, дырищ-щ-ща - твой любимый Проводник - Explorer. Что есть корень диска С? Каждый, кто учил матчасть, тьфу ты, DOS, знает, именно с корня диска С система ведет поиск нужного ей файла. Можешь смеяться, можешь плакать, но такое положение дел существует и поныне. Поэтому, бегом смотрим, есть ли вдруг в корне диска С файл с именем типа explorer.exe (или каким-то еще "системным" именем). Если нет - значит пока пронесло :) и самое время поправить свою ОСь.

(Для пытливых поясню - что любая враждебная прога, будучи запущенной, безо всякого труда может положить себя в корень диска С, поскольку писать туда может кто угодно, т. к. абсолютно все пользователи - они же группа Everyone - имеют полный доступ - Full Access - к корню диска С.)

Итак, чтобы предотвратить такой трюк с explorer.exe идем в:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ WindowsNT\CurrentVersion\Winlogon

Смотрим на параметр Shell. Видим "просто" explorer.exe. Изменяем это значение, прописывая полный путь до директории, где лежит Explorer (не забудь про само имя файла - оно все равно нужно).

Ленивые товарищи могут просто прогуляться на http://www.microsoft.com/downloads/release.asp?releaseid=23359 и отгрузить там себе заплатку.

Еще одна хорошая дыра - твой любимый Screen Saver, по-русски говоря, хранитель экрана. Как это ни покажется странным, многие почему-то забывают настроить эту маленькую, но иногда такую вредную программку. Ведь и тут Uncle BillG за всех подумал. По умолчанию используется хранитель экрана с имением login.scr, который запустится, даже если Screen Saver выбран не был. Как известно - .scr файл - это фактически такой же исполняемый бинарный файл, как и любой другой. А что если вместо родного login.scr тебе фашист подложил свою гранату? То-то!

Поэтому нужно идти в HKEY_USERS\.DEFAULT\Control Panel\Desktop

Создать, если нету, параметр ScreenSaveActive, тип параметра REG_SZ, значение параметра - 0, отключено, т.е. это правильное - твое, значение 1 - значение по умолчанию, т.е. login.scr включен на автозапуск.


Спецвыпуск Xakep, номер #014, стр. 014-060-4, Защити свою Win2k

Защити свою Win2k

Спецвыпуск Xakep, номер #014, стр. 014-060-4

AutoRun - он же автозапуск. Иногда страшно удобная, а иногда страшно вредная штука. Прикинь, заходит к тебе лучший друг :), вставляет свежезаписанный диск, автоматически запускается классная демонстрашка, а тем временем, помимо просто суперских визуальных эффектов, какой-нибудь гнусный троян имеет твой комп со всеми его (компа) :) потрохами. Для того чтобы на корню извести подобные безобразия, AutoRun нужно отключить. Конечно, есть мазохистское решение - каждый раз, при загрузке CD-Rom'а держать нажатым левый Shift. Но кому нужен лишний гимор?

Поэтому иди в:

HKEY_LOCAL_MACHINE \ SYSTEM\CurrentControlSet\Services\CDRom

Шукай там параметр Autorun, чей тип должен быть REG_DWORD. Значение 0 соответствует "отключено" (что нам и надо), значение 1 - "включено", значение по умолчанию.

Не всякий может (хочет) следить за тем, не ломится ли кто на его компьютер. Но всегда лучше поберечься (все знают, кто бережет береженого). Поэтому, первейшая мера - отрубить на фиг Network Browser, чтобы отныне любой "враг", который даже если и подключится к сети, не увидел твоей машины, и не стал бы ее сканировать (конечно, зная сетевое имя компа, все равно можно на него "постучаться", но не зная - попробуй, найди :)).

Итак, иди в:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanManServer\Parameters.

Ищи здесь ключ Hidden, и меняй его значение с 0 на 1.

Хотя можно сделать чуть :) проще - набрать в консоли net config server /hidden:yes

Но отруб Network Browser'a - это еще полдела. Безусловно, стоит сделать карачун и Null-Session. Null-Session - это такая причудливая вещь, которая позволяет другому пользователю, даже не зная никаких логинов и паролей на твою систему, получить всю инфу о зашареных (share - разделенных, доступных для общего пользования) директориях, об имеющихся на компе локальных пользователях, в общем, инфу много о чем.

Чтобы убрать эту "информационную" дыру :), идем по адресу:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa

Делаем там REG_DWORD-параметр с именем RestrictAnonymous и присваиваем ему значение 1.

Помимо этого - рекомендация лучших собаководов: убить как класс шаринги на всех автоматически зашареных директориях.

Для этого нужно неспешно добраться до:

HKEY_LOCAL_MACHINE\ System\CurrentControlSet\Services\LanmanServer\Parameters

Там создать DWORD-параметр с именем AutoShareWks и присвоить ему значение 0. После чего все шаринги ручками убираются, система отправляется в перезагруз и возвращается из него с чистым и не обремененным зашареными директориями диском.

Всем отважным пользователям, бороздящим необъятные просторы Сети с помощью модема, совсем нелишне вести полный лог всех событий, которые с ним (модемом) происходят. Поэтому настоятельно рекомендую включить запись на всю активность твоего модема. Для этого идем:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Rasman\Parameters

Делаем DWORD параметр Logging, и присваиваем ему значение 1.

После этого периодически заходим в \System32\RAS\Device.LOG, и внимательно смотрим!


Спецвыпуск Xakep, номер #014, стр. 014-060-5, Защити свою Win2k

Защити свою Win2k

Спецвыпуск Xakep, номер #014, стр. 014-060-5

Ядерное восстановление

Уязвимость, а с другой стороны, сила Win2k в том, что ядро этой ОСи, с одной стороны можно-таки повредить (как в случае действий дурной программы, так и в случае неправильных действий дурной головы и шаловливых ручек). Но и восстановить ядро (а во многих случаях - и работоспособность) Win2k тоже можно. Главное только - сделать резервную копию ядра. Для этого в "хорошее" место - в директорию Win2k\System32 - надо скопировать файлы ntoskrnl.exe и hal.dll, обозвав их, например, ntoskrnlsafe.exe и halsafe.dll. Если вдруг случаются траблы, то просто правится файл загрузочной информации - boot.ini. К строке загрузки системы, обычно имеющей вид:

multi(0)disk(0)rdisk(0)partition(2)\Win2k="Windows 2000 Prof. - BG Must Die!" /fastdetect

делается (после /fastdetect) приписка :) - /kernel=ntoskrnlsafe.exe /hal=halsafe.dll.

и все - everything должно быть как в танке, т. е. работать.

Естественно, что точно также можно восстановить работоспособность системы в случае неудачной смены ядра, да и вообще многих "ядерных" поломок.

Ну, и как апофеоз: если тебе крупно повезло :) и у тебя есть постоянный IP'шник, то тогда на тебе могут легко испытать DoS. Не в смысле DOS, а DoS - отказ в обслуживании - Denial of Service. Виной всему "корявый" NetBIOS, который работает поверх всеми любимого TCP/IP (NetBT). Реализация протокола NetBIOS НЕ включает в себя проверки аутентичности, т. е. зная реальный адрес чела - его можно немного поспуфить (в итоге накроется сеть, Сеть, и, может быть, вообще вся аутентификация в домене). Для устранения этой ошибки нужен новый файл - netbt.sys, получить который можно по ссылке отсюда - http://support.microsoft.com/support/ kb/articles/q269/2/39.asp, впрочем, эта проблема решена в SP1, но все равно прочитать статейку с M$.com стоит - уж больно она познавательная.

Короткие оптимизационные советы.

Коль скоро ты решил сделать Win2k своей основной системой, нелишне ее немного доработать и в интерфейсном плане.

1. Сделай Command Prompt в *Nix стиле.

Для этого иди в HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Command Processor или в HKEY_CURRENT_USER\Software\Microsoft\Command Processor.

Затем добавь (если его нет) REG_DWORD-параметр с именем CompletionChar.

Присвой параметру значение "9". (Кстати, лучше проверить обе ветви реестра, т.к. значение CompletionChar в HKEY_CURRENT_USER более приоритетно, чем в HKLM.)

Теперь тебе будет достаточно набрать в командной строке несколько первых символов от имени, нажать Tab, и имя автоматически дополнится до полного.

Если часто пользоваться командным интерпретатором (cmd), функция автоматического дополнения - абсолютно незаменимая вещь.

2. Если тебя "достает" надпись типа "Windows 2000 Professional, build 2195" в правом нижнем углу экрана, то ее можно легко убрать, пройдя в реестр по адресу:

HKEY_CURRENT_USER\Control Panel\Desktop Registry, и изменив здесь значение параметра PaintDesktop Version с 0x1 на 0x0.

3. ATA-100 диски в Win2k работают, как ATA-66. Чтобы повысить производительность, можно или поставить BusMaster, который идет в комплекте с мамой, или получить апдейт от Microsoft (кстати, одно другого не исключает, по крайней мере, заплатка от M$ может быть более универсальной). Идем сюда: http://support.microsoft.com/support/kb/articles/q260/2/33.asp и отгружаем патч.


Спецвыпуск Xakep, номер #014, стр. 014-060-6, Защити свою Win2k

Защити свою Win2k

Спецвыпуск Xakep, номер #014, стр. 014-060-6

4. Злая шутка над пользователем Win2k.

Есть два способа устроить "салют" из 2х - 4х пальцев для пользователя Win2k:

1-й способ. Сходить в HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\CurrentVersion\Winlogon, создать здесь DWORD-параметр EnableQuickReboot и присвоить ему значение 1.

2-й способ. Прогуляться в HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters, создать здесь новый DWORD-ключ с именем CrashOnCtrlScroll и присвоить ему любое ненулевое значение, например ту же единицу.

После чего нужно, as usual, уйти в reboot, и тогда нажатие волшебных клавиш Ctrl -Alt-Shift-Del в первом случае или двукратное нажатие Scroll Lock одновременно с удержанием правой клавише Ctrl во втором будут приводить к Navy Screen of Death, или, говоря в НТ'евой терминологии - БСОДу - голубому экрану смерти (в Win2k этот экран стал морского - Navy - цвета).

Особенно эта функция полезна, когда в комнату заходит начальник или резко врываются люди в камуфляже. Вся не сохраненная инфа, улетает в dev/null почти стопроцентно (никогда не знаешь - на какого спеца можешь нарваться, а вдруг он гуру по восстановлению данных из страничного файла?).

Ну что же - теперь ты вполне предупрежден, а значит, как говаривал известный многим дон Педро Сангре, он же капитан Питер Блад, вооружен.

На этом позвольте откланяться.

Думаю, что скоро мы обязательно вернемся к защите IE-версий 4 и старше, а также проведем реальный тест на взлом Win2k, как в только что установленной версии, так и "доработанной" в плане безопасности. Обо всем этом тебе будет подробно доложено в одном из ближайших номеров Х. Следи за анонсами!


Спецвыпуск Xakep, номер #014, стр. 014-065-1, Апач собственными руками

Апач собственными руками

Спецвыпуск Xakep, номер #014, стр. 014-065-1

Nikitos aka Surgeon (nktos@rambler.ru)

Подъем!

Ты конкретно поднялся. Вместо надоевшего войдозера юзается смурф, место диалапа занял радиоканал, новый BX обрел тучу статусов на крутых IRC-каналах, прокручиваются мегабайтовые свопы CC... И постепенно становится понятно, что держать любимый сайт на халявном chat/narod/boom.ru - не круто (может сделать каждый), работать с карденным хостингом тоже не столь актуально (может сделать почти каждый). Получается, что единственным выходом станет оборудование собственного WWW-сервера. Это оказывается более чем реальным делом, если имеется выделенка: повесил в своей же системе и не думаешь о покупке отдельного железа под сервант или оплаты за солокейшен. А если еще на выделенке трафик халявный...;) Короче, сегодня особенный день, когда мы займемся оборудованием и настройкой твоего собственного WWW-сервака!

И чего?

Если ты прочитал заглавие статьи (а ты прочитал, и не вздумай спорить =), то уже нагнал, что из множества http демонов/сервисов мы остановимся на самом популярном - Apache.

По статистике netcraft.com, в сети размещено более 60% апачей от общего числа интересующих нас server`ов.

На момент написания в ходу была последняя стабильная версия - 1.3.20, а также бета - 2.0.16. Навороченные новины - дело, конечно, хорошее. В то же время в нашем случае лучше заняться ровным, стабильным вариантом. Возможно, к выходу номера объявится версия поновей, так что сразу ползи на http://httpd.apache.org/dist/httpd/ и скачивай подходящее. Там есть как win, так и nix-вариации. Глобальной разности в настройках разно-осевых серверов - нет, так что прочитав наш обзор по виндозному раскладу, осилишь и *nix. НТя была выбрана не случайно: если ты собираешься пускать сервис прямо со своего компа, то нелогично уходить в Линукс только лишь в заботе о сотне посетителей, которые вряд ли смутятся вин-системе ;). Да и если ты ставишь апач лишь для проверки работоспособности нужных скриптов, то вряд ли найдешь "10 отличий" между текущей и, очевидно, более совершенной unix-версией.

Окапываемся

По уже обозначенному линку ты сольешь свежую версию виндусного апача. Теперь закаченное инсталлируется. По умолчанию предполагается, что установка произведется не куда-нибудь, а на диск f. Если у тебя еще такого не объявилось, лучше создай - для комфортной работы (отковыриваем новый диск Partition Magic`ом). Если особенности расположения тебя не парят, можешь переправить инсталл на текущий диск.

В общем, путь для установки должен быть вот таким:

X:\usr\local\apache

Где X-диск, куда ставишь.

Next ->Next -> Finish

Что это? Предлагают переребутиться? Ну ладно тебе, не вопи, знаю я, что ты комп уже месяц не выключал. Чего только не сделаешь ради искусства :).

Ребутнулся? Отлично!

Идем дальше. Открывай в ноутпаде файл httpd.conf, расположенный в директории conf.

Все, что после # - комментарии. Их там очень много.

Порядок действий:

1) Убери "#" перед строчкой

ServerName ApacheServer

2) Найди строку, начинающуюся на "DocumentRoot". Тут указывается директория, где будут храниться HTML и PHP - документы и скрипты, соответственно.


Спецвыпуск Xakep, номер #014, стр. 014-065-2, Апач собственными руками

Апач собственными руками

Спецвыпуск Xakep, номер #014, стр. 014-065-2

У тебя должно получиться что-то вроде DocumentRoot X:\html_php

Не забудь создать саму диру.

3) Ищи блок, стартующий с "" и заканчивающийся на ""

Производим замену "

Options Indexes Includes

AllowOverride All

" (без кавычек!)

В обозначенных блоках конфигурируются установки для заданной директории и всех ее поддиректорий.

4) Ищем аналогичный блок, начинающийся на и завершающийся как обычно, т.е.

Здесь тема меняется так:

Options Indexes Includes

AllowOverride All

Order allow,deny

Allow from all

html_php заменишь на директорию, указанную в поле DocumentRoot! Не забудь!!!

5) Параметр UserDir можно обозначить как здесь: UserDir x:/home

Вполне понятно, что этим шагом мы выделяем одомашненную диру. :)

6) В разделе DirectoryIndex ты можешь обозначить имена файлов, что будут обрабатываться как индексные. Для обнаружения результата мутим:

DirectoryIndex index.htm index.html index.php3 index.php index.phtml index.cgi index.pl

7) Создай директорию cgi-bin, поработав с ScriptAlias: ScriptAlias /cgi-bin/ "x:/cgi-bin/"

8) Теперь необходимо найти следующий блок:

F смени на диск, куда и в какую позу была поставлена апача.

9) Заморочка "AddHandler cgi-script" ставится по таким понятиям: AddHandler cgi-script .pl .cgi .bat .exe

10) Дай старт AddHandler server-parsed вот так: AddHandler server-parsed .shtml .shtm .sht

11) Сохрани поправки, дополнительные комментарии кода в файло.

Клёва aka COOL!

Ты сконфигурил apache`у. Время совершить стартовый запуск: пуск->программы->apache web server->Start apache...

Запустился? Правда, что ль? Ну ты крут... Теперь надобно скопировать какую-нибудь хтмелку в x:\html_php, переименовав ее в index. Для начал тестирования набивай браузеру Localhost. Если все в шоколаде, ты увидишь нужную ХТМЛку. А не увидишь... Не судьба, читай мануал заново =).

Разгон серванта

И что, ты реально думаешь, что теперь можно расслабиться, прогуляться пива попить, а придя уже мутить локальные тестирования своих суперсайтов? Обломайся, без CGI и PHP ты ничего более-менее серьезного обработать не сможешь. Почему это прямо сейчас нельзя заюзать чудные фичи на нашем агрегате? Так сложилось, что за дополнительными опциями потребуется снова слазать на пагу donwload`a апача. Благо, смена линка в ближайшие годы не планируется =).

Все пучком, теперь напряги мозгу и вспомни, куда ставил апачу. В общем случае вот сюда: x:\usr\local\apache. Теперь создай дирку x:\usr\local\php3 и

туда перетащи скаченный файл. Запускай. Архивчик развернется, в папке появятся файлы.

Если ты ставил пэхэпэ на диск именем, отличным от f, придется открыть файлик php_iis_reg.inf

Там есть шесть путей. Где буковку F надо поменять на твою любимую.

Засейвь. Кликни правой кнопкой на файле php_iis_reg.inf и выбери "Установить".

Все :). Чуть не забыл, скопируй файл php3.ini в папку с маздаем. Почти все. Осталось настроить апачу. Отковыривай usr/local/apache/conf/mime.types


Спецвыпуск Xakep, номер #014, стр. 014-065-3, Апач собственными руками

Апач собственными руками

Спецвыпуск Xakep, номер #014, стр. 014-065-3

Именно сюда придется добавить такую строчку:

application/x-httpd-php3 phtml php3 php

Теперь открой httpd.conf и добавь в самый конец файла такие строки:

Options ExecCGI

ScriptAlias "/__php_dir__/" "f:/usr/local/php3/"

Action application/x-httpd-php3 "/__php_dir__/php.exe"

ВСЕ :))). PHP прикрутили :).

Хорошо кончаем

Проверь работоспособность конфигуренного PHP простым скриптиком:

echo "Типа, все пашет:)";

?>

Засейвь его как test.php3

Теперь помести в директорию с хтмл документами.

Запусти:

localhost/test.php3

OK.

Чтобы намутить сапорт перла, качай перл с перл тчк ком необходимые модули.

Устанавливай в директорию x:/url/local/bin/perl

Все! Перл коннектед.

Апач настроили, php/perl прикрутили. Ну что еще надо кул-кодеру? ;)

Если чего не получилось, что весьма вероятно, пиши, может чем помогу. Хотя всегда лучше въехать в суть траблы самому.


Спецвыпуск Xakep, номер #014, стр. 014-072-1, Всем на пол! Это захват!

Всем на пол! Это захват!

Спецвыпуск Xakep, номер #014, стр. 014-072-1

Мудрые мысли по поводу мирного видеозахвата

Donor (lehun@mail.ru)

В интересное время мы с тобой живём, ты не находишь? Компьютер подмял под себя уже практически всё: он тебе и офис с секретаршей, он тебе и лаборатория, и мастерская художника, и звукозаписывающая студия, и кинотеатр с телевизором и видаком в одном флаконе. И это есть хорошо, удобно и, главное, всё между собой совместимо. Как, неужели, ты не пользуешься всем этим? Тогда ты отстал от жизни. Попытаюсь тебе немного помочь. Сегодня я расскажу тебе о видеозахвате.

А о чем, собственно, речь?

Блуждая по всяким тёмным закоулкам Интернета, ты, наверное, не раз замечал, что в качестве иллюстраций к различным статьям и новостям часто выступают скриншоты из фильмов или кадры из новостных передач и репортажей. Где они их берут? Могут подрубить к компу дорогущую цифровую аппаратуру, могут закупить записи у телекомпаний, но есть способ лучше :) проще и дешевле: использовать видюху с функцией видеозахвата. Жмакнул на кнопочку, и кадр, а то и кусочек записи, у тебя на винте, и делай с ним что хочешь :).

Ладно... А мне-то это зачем?

Нет, без видеозахвата ты, конечно, не помрёшь. Но подумай, сколько классных вещей ты можешь сделать с этой феней. Выцепи из видеозаписи институтской попойки кадр, где злобный админ с голой задницей обнимает "белого коня", снабди его своим ехидным комментарием и разводи админа на шелл :). Иначе ты все это безобразие выложишь в инет, правда? А какие возможности открываются для тебя в Интернете! Теперь ты можешь украсить свою страницу героями любимого фильма, а не банальными картинками из заюзанного по самое не балуйся клип-арта. Теперь ты пошлёшь только что зацепленной в IRC перчинке не фотку из серии "я и мой кот Мурзик возле ободранного дивана", а шедевр под названием "Моя загадочная персона на фоне Нео и Морфеуса". Но все это - детские шалости, если вспомнить, что любая карта видеозахвата обычно работает и как ТВ-тюнер, и всяких входов-выходов у нее целая куча. А ты ведь давно мечтал подключить комп к телеку и смотреть фильмы в DivX на большом экране. Впрочем, ты можешь делать все, с точностью до наоборот. У тебя есть любимый фильм? Подключай видак к карте и рипай фильм в цифру, теперь все это дело можно отредактировать (если хочешь) и выкладывать в Сеть. Спорим, что популярность твоего сайта будет огромная? Все просто, люди боятся выкладывать фильмы в Сеть (закон об авторских правах), особенно российские. А желающих скачать немерено!

Фишка от моего приятеля. У него нет DVD и покупать DVD-ROM он не собирается, пока диски не подешевеют. Но и хранить всю эту тонну видеокассет ему тоже надоело. Он совершил финт ушами в Х-Стиле: порипал все фильмы платой видеозахвата, закодил все в DivX, записал все на болванки и теперь вся видеотека у него помещается на одной большой CD'шной полке. Да, забыл сказать, фильмы он смотрит на телеке, но теперь сигнал идет не с видака, а с компа (с той самой платы). Но лично мне больше всего нравится брать у него CD'юки с клипами, рипнутыми с МTV и МузТВ :). Цитата: "Хехе... перемотка в нужный кусок фильма за 2 секунды, это тебе не на видике головками шуршать!"


Спецвыпуск Xakep, номер #014, стр. 014-072-2, Всем на пол! Это захват!

Всем на пол! Это захват!

Спецвыпуск Xakep, номер #014, стр. 014-072-2

В общем, возможностей - море. Всё это хорошо, скажешь ты, но я ещё и в Кваку популять хочу. Отвечу на это так: в век глобальной интеграции тебе не придётся иметь две железки для разных целей =). Функция видеозахвата реализована на карточках от таких производителей, как ASUS и ATI, построенных на базе самых современных видеочипов с кучей памяти на борту.

И как это всё работает?

В своё время я сам закупил себе карточку от ASUSа с возможностью видеозахвата. Вот на её примере я тебе всё и обрисую. От обычной видеоплаты данная девайсина отличается наличием четырёх дополнительных дырок на скобе (in и out) и тем, что в комплект входят 2 шнура (S-Connector и тюльпан). Установка проходит как обычно: воткнули железку в AGP, закрепили болтом, поставили дрова с прилагающегося CD. Всё! Вместе с драйвером на винт установится специальная прога - ASUS Live. Из неё ты будешь управлять захватом. Втыкай в video-in тюльпан (S-Connector тебе, скорее всего, не пригодится), а на другой конец сажай видак или камеру (им втыкай в video-out). К видаку можно подсосать антенну - вот тебе TV-tuner. Теперь ты готов. Втыкай в видак кассету и запускай ASUS Live. Перед тобой нарисуется панелька управления в виде видачиной морды и малюсенькое окошко с изображением. Не пугайся, размер - дело поправимое =).

Давай разберёмся с панелью. На скриншоте я пометил соответствующие элементы цифрами. В блоке 1 расположились кнопки, переключающие режимы: левая - режим захвата, правая - режим воспроизведения.

Кнопка 2 растягивает окно воспроизведения на весь экран (чтобы вернуться, просто надави эскейп). Пимпа нумер 3 отвечает за размер окошка с видео: можно поставить от 160х120 (получится глазок =) до 720 х 480 (уже более-менее нормальная форточка). Эти установки относятся только к воспроизведению, на захват они не влияют.

4-й кнопарь открывает любой avi'шник для его последующего просмотра, в том числе и только что записанный. Кнопка 5 отвечает за настройки видеозахвата. Щелкнув её по носу, ты получишь диалог, где нужно указать директории, в которые будут складироваться тонны bmp'шек и мегатонны avi'шников. Здесь же задаётся размер bmp. Только учитывай, что чем больше размер, тем больше свободы нужно на винте. Советую также протоптать флажок "Use numbered file name" - это нужно, чтобы не прописывать каждый раз имя файла ручками. Больше настроить ничего не дадут. В блок 6 объединены пимпы, ответственные непосредственно за захват: снять один кадр, срезать несколько кадров, откусить кусок видео. Можно давить на клаву: F5, F6, F7 - соответственно. Штука номер 7 - это, типа, джог-дайл такой. Она отвечает за настройки воспроизведения. Если ты спрессуешь центральную кнопку, то в окне с видео появится менюха. Ползать по этой менюхе придётся, клацая крысой по стрелочкам вокруг, что не совсем удобно.

Первые 4 пункта - это всё косметика: Brightness (яркость) - светлее/темнее; Contrast (контраст) - подкрутим резкость; Hue (хуе... бр-р-р... оттенок, в смысле =)) - пожелтее/покраснее, Saturation (насыщение) - цвета яркие/блёклые. А вот дальше надо настроить непременно. Video Connector - это то, через что ты подсосался: если через тюльпан, то выбирай Composite, если через S-Connector, то выбирай S-Video, а если у тебя есть тюнер или TV-Box, то флаг тебе в руки, буржуй =). Video Standard (стандарт изображения) - скорее всего, будет PAL-BGHI - это обычный стандарт для видака, но можешь потыкать и другие. Кстати, SECAM не наблюдается =).


Спецвыпуск Xakep, номер #014, стр. 014-072-3, Всем на пол! Это захват!

Всем на пол! Это захват!

Спецвыпуск Xakep, номер #014, стр. 014-072-3

И что получилось?

Настроив все дела и сунув в видак "Звёздные войны", я тюкнул кнопочку "Снять кадр". В выбранной папке образовалось файло capture001.bmp заданного размера. Качество вполне приемлемое, а после того как я убрал в "Фотошопе" помехи, стало даже очень ничего. Вывод: сдирать артистов, президентов и министров, а потом извращаться над ними по-всякому вполне реально. Ждём от тебя произведения типа "Арнольд в подгузниках", лучшие шедевры (но не плагиат!) опубликуем =).

Потом я стал снимать видео. Жмакнул пимпу - прога откликнулась: "Дави эникей, когда пора!". После удавления эникея софтина слила только что проигранное на диск. Это не совсем очевидно, поэтому поясню: жмёшь F7, ждешь столько, сколько хочешь записать, жмешь чего-нибудь - файло сохраняется. Сколько секунд подождал, столько и записалось. В результате получился avi'шник очень неплохого качества, но вот от его веса я прифигел. 20 секунд потянули на 30 мегов. И параметр вес/качество изменить нельзя :(. Вывод: видео на винт сохранять можно, но для Интернета оно тяжеловато. Хотя, если использовать видеозахват по кадру, компрессовать это всё джипегом и пихать во флэш, надежда на открытие своего порносервака остается =). Это шутка, конечно. Просто после того, как ты все порипал, сразу декодируй все в DivX.

И во сколько это мне обойдётся?

Разница в цене есть, но не очень большая: примерно 20 - 40 уёв, в зависимости от модели и комплектации. Ниже я привёл некоторые цены на момент написания статьи.

32 Mb ASUS V3800 TNT2 - 117 у. е.

32 Mb ASUS V3800 TNT2 - 137 у. е.

32 Mb ASUS V6600 - 157 у. е.

32 Mb ASUS V6600 DELUXE - 179 у.е.

32 Mb ASUS V7700 GEFORCE 2 GTS DDR - 209 у. е.

32 Mb ASUS V7700 DELUXE - 249 у. е.

64 Mb ASUS V7700 GEFORCE 2 GTS DDR - 311 у. е.

64 Mb ASUS V7700 DELUXE

В общем если ты собрался менять видюху и есть немного свободного бабла, то бери с видеозахватом - не пожалеешь.

Большой З. Ы.

Ну вот, теперь ты крут. Будешь рипать клевые фильмы и кодить их в DivX - присылай УРЛ! Потусуем на твоем сайте, покачаем.


Спецвыпуск Xakep, номер #014, стр. 014-087-1, ЦРУ, ФСБ, рояль в подъезде и 44 утюга, направленных на юго-восток

ЦРУ, ФСБ, рояль в подъезде и 44 утюга, направленных на юго-восток

Спецвыпуск Xakep, номер #014, стр. 014-087-1

Всем бывшим, настоящим и будущим сотрудникам спецслужб посвящается

Автор: Макс. Просто Макс

От Автора

Эта статья поможет тебе приоткрыть таинственную завесу, скрывающую деятельность российских спецслужб в области электроники и компьютерных технологий. Хочу сразу отметить, что приведенные ниже сведения являются всего лишь познавательным материалом. Практически все названия, терминология и прочая, прочая изменены в целях соблюдения режима секретности. Откуда мне знать, что ты не шпион, подосланный злыми буржуями?

Садитесь поудобнее

С наступлением ХХI века в преступном мире произошли гигантские изменения. Появившиеся новые технологии используются реальными и потенциальными бандюганами как в мирных целях, так и в противоправных. Террористы пользуются Интернетом, киллеры - мобильными телефонами, программисты грабят банки не выходя из дома, детишки подделывают номера кредиток своих родителей. Форменный кавардак. Для того чтобы навести хоть какой-нибудь порядок, в составе МВД, ФСБ и в некоторых федеральных службах созданы специальные отделы, подразделения, занимающиеся поимкой преступников в этой новой, но уже становящейся привычной области нашей жизни. Надо отметить, что в деятельности каждой структуры есть общие для всех задачи, но есть и некоторые особенности, отличающие каждую от остальных. Поэтому дальнейшее повествование считаю целесообразным вести сухим суконным языком в форме краткого досье. Равняйсь! Смиррррнаа!

Ведомство: МВД (милиция).

Подразделение: Управление по борьбе с преступлениями в области высоких технологий и компьютерной информации (ныне распущенное, но дело их живее всех живых, оно передано другим структурам и ведомствам).

Проще говоря - управление "Р", коротко и зловеще. Сотрудники данного подразделения занимаются раскрытием преступлений, связанных с использованием компьютеров, сотовых телефонов, спутниковых средств связи и т.д. Эти люди - повелители жучков-паучков, мастера установки скрытых видеокамер и т.п. В основном они работают по заданиям других ведомств с целью документирования преступной деятельности подозреваемых.

Примером их работы может послужить такой случай: один киллер предлагал свои услуги через Интернет. Соответственно, собрать хоть какую-нибудь "доказуху" просто невозможно, т.е., как говорится, - "доказухи никакой". И вот на выручку спешно пришли Чипы и Дейлы с удостоверениями сотрудников управления "Р": нашпиговали квартиру разной электроникой, поставили прослушку на телефонную линию, пометили специальным радиомаячком машину бандита. Через некоторое время удалось установить место, в котором злодей хранил свой арсенал, а потом проследить заключение одной из сделок. Апофеозом происходившего послужило следующее: получив доступ к тайнику - брошенному строительному вагончику, сотрудники управления "Р" установили в оптическом прицеле снайперской винтовки микровидеокамеру с передатчиком. После этого можно было в реальном времени видеть, в кого в данный момент целился бандит. А целился он в другого московского бандита по имени Паша и прозвищу "Самолет". Пашу быстренько скрутили и запихнули в обезьянник, на что он ужасно обиделся и долго возмущался, а в его квартире сделали из подручного материала приманку - примерно как в фильме про Шерлока Холмса - тряпочную куклу, очень похожую на Пашу. Киллер объявился через некоторое время. Он решил стрелять с крыши соседней пятиэтажки. Пришел, расположился. Передатчик отлично показывал куклу-Пашу в перекрестии прицела. В общем, грянул выстрел, кукла в клочья, киллеру сломали два ребра, но повязали на месте, а живого и радостного Пашу отпустили. Ходит сейчас где-нибудь, ждет следующей пули. Аналогичными способами вычисляются и злостные компьютерные хулиганы :)). Любят ребята из "Р" бомбить сайты с детской порнографией, вылавливать кардеров и фрикеров. Как это они делают - профессиональная тайна.


Спецвыпуск Xakep, номер #014, стр. 014-087-2, ЦРУ, ФСБ, рояль в подъезде и 44 утюга, направленных на юго-восток

ЦРУ, ФСБ, рояль в подъезде и 44 утюга, направленных на юго-восток

Спецвыпуск Xakep, номер #014, стр. 014-087-2

Как просечь:

На себе ощутить работу этих доблестных ребят ты можешь по следующим признакам: шипение и помехи в телефоне, частые дисконнекты, навязчивые девчонки в чатах, нахваливающие твои хакерские способности и предлагающие ломануть новый банк, толстый мужик с видеокамерой в руках, свисающий с крыши на веревке напротив твоего окна, пронзительные, немигающие глаза в унитазе, смотрящие тебе прямо сам знаешь куда, периодическое легкое постукивание кувалдой и появление милицейского наряда в твоей квартире :)). Для борьбы с этими явлениями проверь разводку телефонной линии, отсоедини все провода от системного блока компа, включи глушилку Доктора Добрянского. Для пущего эффекта включи ее на полную мощность и проглоти не запивая :)). Так как принцип ее действия до сих пор неизвестен, бороться с ней невозможно.

Как попасть:

Для начала получить какое-либо среднее образование и пройти DOOM без кодов и читов. Потом окончить среднее или высшее учебное заведение МВД (средняя школа милиции - "дубовочка", Московский юридический институт, Московская Академия МВД), поступить на работу в оперативные подразделения МВД. Дальше - как распорядится судьба. При всем при этом неплохо иметь и техническое образование, как у моего хорошего друга Когтя-Пивоглота-Преображенского (привет тебе Коготь), который в свое время окончил еще и МГТУ им. Н.Э. Баумана. После получения некоторого опыта оперативной работы можно перевестись в это подразделение.

Ведомство: ФСО (Федеральная Служба Охраны).

Подразделение: по защите особо важных лиц и объектов.

Бывшее подразделение КГБ, в данный момент получившее статус отдельной службы. Из названия можно совершенно однозначно понять, что занимается эта служба охраной первых лиц государства, иногда важных чиновников, иногда жизненно важных объектов (телефонные узлы, больницы, большие заводы, системы жизнеобеспечения города), иногда программой защиты свидетелей. В общем, ребята выполняют функции государственных телохранителей. Это именно они перекрывают на несколько часов Киевскую трассу для того чтобы провезти по ней министра пельменеварения или президента республики Хакастан. "А какое они имеют отношение к электронике?" - раздраженно спросишь ты. Я отвечу: "Имеют, и самое непосредственное!"


Спецвыпуск Xakep, номер #014, стр. 014-087-3, ЦРУ, ФСБ, рояль в подъезде и 44 утюга, направленных на юго-восток

ЦРУ, ФСБ, рояль в подъезде и 44 утюга, направленных на юго-восток

Спецвыпуск Xakep, номер #014, стр. 014-087-3

Дело в том, что перед тем как провезти в лимузине по ковровой дорожке очередного дармоеда-толстопуза, они долго проверяют маршрут на наличие взрывных устройств, систем скрытого аудиовидеонаблюдения и т.д. При этом используется огромное количество сканирующих, шифрующих и других устройств, которые защищают каналы служебной связи от прослушивания, вычисляют и глушат все радиопередатчики, работающие на частотах, используемых группами сопровождения. Также некоторые сотрудники ФСО занимаются предотвращением покушений на охраняемых лиц, в том числе и с использованием высоких технологий. Они прослушивают телефонные разговоры лиц, подозреваемых в совершении заказных убийств и подготовке теракт, перехватывают сообщения, поступающие по каналам сотовой связи и оптико-волоконным линиям (если кто-то скажет мне, что это невозможно, то пусть попробует опубликовать в сети объявление типа: "Бывший спецназовец ищет любую опасную, но высокооплачиваемую работу" - и посмотрит, как у него последовательно ухудшатся: качество связи, финансовое благополучие, свобода перемещений, здоровье, доступ дневного света в жилое помещение :).

Существует также легенда о "телефонном роботе", который автоматически включается и записывает телефонный разговор, как только регистрирует ключевые слова типа "президент", "убить", "оружие", "Аллах Акбар", "Салам", "Салями", "еш-карундык", "халява", "а ты читал последний номер Х". Проверить правдоподобность этой бредятины мне так и не удалось, но задумка хорошая, и я думаю, что что-то подобное все же существует. Для опасных игр с этими серьезными дядьками существует целый арсенал глупых и не очень шуток, начиная от звонков по 02 с сообщением о готовящемся покушении и кончая дикими комбинациями петард, фейерверков, пейджеров и лазерных указок. Как все это изготовить, учить не буду (дураки не поймут, а умные не станут связываться с ФСО), но иногда эффект бывает потрясный, хотя и может растянуться на много лет. Сначала, еще до суда, могут даже показать по телеку в "Дорожном патруле" (хотя также легко могут посадить или пристрелить на месте).

Как просечь:

Если у тебя полностью побрита голова и при этом ты носишь огромную бороду и повязку с надписью "Нет бога кроме Аллаха", - то у тебя уже есть маленький шанс быть "под колпаком". Если при этом твой родной язык - чеченский, то шанс удваивается. Если же из столовых приборов ты на своем столе видишь только АК-47, Стечкина, Си-4, тринитротолуол, Оптический прицел ночного видения и гранатомет "Муха", то ФСО уже стоит у тебя под дверью. И последнее: пробежка со всем этим добром к воротам Кремля под дружественные крики "Убью, твари кремлевские" увеличивает твои шансы до 100%.

Как попасть:

Поступить в школу для нормальных детей. Окончить школу без помощи родителей, успешно отслужить в элитных войсках Красной Армии (спецназ, ВДВ, пистолетчик-самокатчик, водитель-механик полевой кухни :), потом сразу поступить на службу в ФСО или же идти через Академию ФСБ. Кандидата ожидает жесткий отбор и огромное количество проверок, пройдя которые, он получает статус государственного телохранителя.


Спецвыпуск Xakep, номер #014, стр. 014-087-4, ЦРУ, ФСБ, рояль в подъезде и 44 утюга, направленных на юго-восток

ЦРУ, ФСБ, рояль в подъезде и 44 утюга, направленных на юго-восток

Спецвыпуск Xakep, номер #014, стр. 014-087-4

Ведомство: ФСБ (Федеральная Служба Безопасности).

Подразделение: по борьбе с незаконным оборотом наркотиков, терроризмом, незаконным оборотом оружия и т.д.

ФСБ - самая большая, самая могущественная, самая крутая организация среди всех правоохранительных органов России. К ее юрисдикции относятся практически все вопросы обеспечения правопорядка и общественной безопасности в стране, поэтому электроника так часто находит свое применение в деятельности этой конторы. В наследство от КГБ она получила огромное количество подслушивающих, подсматривающих, передающих и принимающих устройств, которые не стоят без дела (если у тебя нет прогрессирующей паранойи, это не значит, что за тобой не следят :)).

Занимаясь делами государственной важности, ФСБ по разным причинам кладет большую кучу на право человека на тайну переписки, почтовых сообщений, телефонных переговоров и т.д., в общем, делает что угодно. Для того чтобы напихать в твою квартиру жучков, они могут войти туда, пока ты с друганами распиваешь около универа пиво или пьешь пиво на работе, или трескаешь за обе щеки в гостях, запивая пивом, или даже спишь с бутылкой пива под подушкой. Обычно ФСБ-шники работают по крупным преступлениям, представляющим большую опасность, чем остальные.

Хакерам следует осторожнее относиться к своим милым проделкам и шалостям. Если, не дай Бог, тобой лично серьезно заинтересуются сотрудники ФСБ, то некоторый отрезок твоей дальнейшей жизни превратится в кошмар и, как говорил Джон Сильвер из "Острова Сокровищ": "Живые позавидуют мертвым". Эти люди не любят растрачивать свои силы и время по мелочам, и уж если ты попал к ним "на крючок", то ничего хорошего из этого не выйдет. Хотя бы потому, что им будет обидно отпускать тебя просто так.

Как просечь:

Практически невозможно. Обычно ты узнаешь о важности своей персоны в глазах нашего государства только тогда, когда уже примеряешь модные браслеты. Хотя, если после очередного взлома банка на сумму с огромным количеством нулей и знаком $ ты почувствовал на своей спине колкий взгляд майора Пронина, матушка сообщила, что тебе звонили из милиции (привет передавали?), + пришла повестка из военкомата - остается всего два пути. Для начала надо решить один простой вопрос: "Я действительно круче Терминатора?". Если круче - то ты сам знаешь, что делать. Если нет, то самое первое твое действие называется FORMAT C: и далее везде по алфавиту. После этого подари свой комп кому-нибудь из дальних родственников, хотя бы на время. Далее жди. Или за тобой придут, или одно из двух.

Как попасть:

Сначала служба в родной Красной Армии, потом учебное заведение ФСБ или же сразу Академия ФСБ. Если в твоем личном деле за период "детский сад - ФСБ" не будет никаких пятен, да к тому же твои личные качества будут соответствовать стандарту "Настоящий полковник", то, возможно, тебе доверят заниматься оперативной работой, а не разбором бумажек.


Спецвыпуск Xakep, номер #014, стр. 014-087-5, ЦРУ, ФСБ, рояль в подъезде и 44 утюга, направленных на юго-восток

ЦРУ, ФСБ, рояль в подъезде и 44 утюга, направленных на юго-восток

Спецвыпуск Xakep, номер #014, стр. 014-087-5

Ведомство: Федеральное Агентство Правительственной Связи и Информации (ФАПСИ).

Подразделение: по защите особо важных объектов и коммуникационных каналов.

Еще одно бывшее подразделение КГБ, получившее статус отдельной службы. Занимается созданием, защитой и обслуживанием каналов правительственной связи, контролем чистоты радиоэфира спецслужб (милиция, пожарная служба, медицинская служба и т.д.). Также сотрудники этого подразделения неофициально следят за развитием компьютерных сетей, так как это представляет огромный оперативный интерес и способствует предотвращению правонарушений, связанных с несанкционированным доступом в закрытые информационные пространства. Объясняю проще: если какой-нибудь долбанный бауманец решит залезть из Аквариума в базу данных Главного информационного центра МВД РФ, то первыми об этом узнают сотрудники ФАПСИ.

Также они заботятся и о том, чтобы такие же долбанные бауманцы не подключали ничего к телефонным линиям больших начальников, не лазили куда не надо на телефонных узлах, а главное - ИМЕННО ОНИ БОРЮТСЯ С РАСПРОСТРАНЕНИЕМ ТЕЛЕФОННЫХ И ГАИШНЫХ БАЗ, так как данная информация имеет гриф "СЕКРЕТНО". Обычно это делается с помощью контрольной закупки партии таких дисков с дальнейшим выяснением каналов утечки конфиденциальной информации.

К тому же, именно это ведомство занимается операторами сотовой и пейджинговой связи. Именно они без труда прослушают твою мобайлу или спутниковый телефон.

Как просечь:

Обычно ФАПСИ не занимается поимкой злодеев. Они просто собирают доказательства того, что ты получил секретную информацию. Далее, в зависимости от степени секретности, тобой займется или Управление "Р" или ФСБ. Поэтому если тебе удалось взять попользоваться (хакеры не воруют) что-либо секретное, то или положи это на место как можно быстрее (малоэффективно) или выкинь как можно дальше от собственного дома. После этого реши для себя вопрос из раздела про ФСБ.

Как попасть:

Научиться делать телефон из двух спичечных коробочек и нитки, потом получить хоть какое-нибудь техническое образование, пройти курсы подготовки, стажировку - и вперед - прокладывать новые телефонные провода от одного большого начальника к другому.

Послесловие: Что бы ты ни делал, помни одно: "Быстро сп...ил и ушел - называется нашел". Не лезь куда не стоит. Если все же попался, попытайся спрятать комп по двум причинам:

1. Многие сотрудники "каких надо" органов - мастера ДАУНГРЕЙДА, апгрейда в другую сторону, после которого твой самый навороченный комп вряд ли сможет тягаться с Денди.

2. Компьютер при правильном оформлении может быть вещественным доказательством по твоему делу, но не в твою пользу (прикинь, какая подлянка - копил, копил, ночи не спал, недоедал, примочки к нему покупал, тряпочкой протирал, а он, зараза, против тебя свидетельствует).

Не стоит изображать из себя рецидивиста по кличке "Бывалый", который бреется миской, гнуть пальцы и "ботать по фене". "Там" тоже не лохи работают. Вспомни знаменитого бандюгана Фокса: "Хитры же вы, менты, с уловками вашими. Ну ничего...".


Спецвыпуск Xakep, номер #014, стр. 014-087-6, ЦРУ, ФСБ, рояль в подъезде и 44 утюга, направленных на юго-восток

ЦРУ, ФСБ, рояль в подъезде и 44 утюга, направленных на юго-восток

Спецвыпуск Xakep, номер #014, стр. 014-087-6

10 твоих ошибок, которые помогут "органам"

1. Ты трепло. А значит тебя разведут как мальчика.

2. Ты говоришь по телефону все. И имена и куда, кому и зачем подъехать, и что ты когда сделал и т.д. Пример из жизни: за человеком наблюдали, он шифровался по телефону, но по мобайле назначал встречи, называя точные адреса. На одном таком адресе всех и повязали.

3. Ты никогда в жизни не слышал о проксях, шеллах и PGP. Поэтому сбор доказательств твоей виновности ускорится в несколько раз.

4. У тебя дома нет UPS. Поэтому когда у тебя выключат свет и начнут ломиться в дверь, твой комп будет целым и невредимым, со всеми уликами.

5. Ты находишь друзей в инете, которым со временем рассказываешь все. Поэтому сотрудники спецслужб часто будут твоими "друзьями".

6. Ты падок на романы в Сети. Поэтому вопрос "как к тебе подобраться" у наших доблестных даже не возникнет.

7. Ты просто обожаешь ломать российские сайты/программы/базы и т.д. А значит интерес к твоей персоне возникает у наших спецслужб, а не у буржуйских.

8. Ты наркоман/алкоголик. Поэтому нет нужды "выбивать" у тебя признание. Просто подержат денек без дозы.

9. Ты первый и последний раз в жизни читаешь ][. А значит не в курсе, как защищать себя и свой комп.

10. Ты не параноик. Ну-ну... будь оптимистом. Надейся, что ты никому не нужен. А папка твоего дела тем временем толстеет.

P.S. Отдельная благодарность за предоставленную информацию "КОГТЮ-ПРЕОБРАЖЕНСКОМУ и 2 отделу уголовного розыска (борьба с умышленными убийствами).


Спецвыпуск Xakep, номер #014, стр. 014-090-1, Джентльменский набор

Джентльменский набор

Спецвыпуск Xakep, номер #014, стр. 014-090-1

эти проги должен иметь каждый

Антон Карпов (toxa@real.xakep.ru)

Доброздравия, приятель. Когда говорят "хацкерский софт", то понимают под этим все что угодно, тем или иным образом относящееся к взлому: начиная от банальных нюкеров, портсканеров и переборщиков паролей и кончая дизассемблерами с шестнадцатеричными редакторами. Но давай разберемся, что действительно надо такому чуваку, как мы с тобой: давно уже переставшему забавляться с нюкерами и прочей подобной ерундой, но еще не доросшему до того уровня, когда весь софт, тебя окружающий, написан исключительно под *nix и исключительно тобой самим, и ты, признанный гуру хака, из *nix'ов не вылезаешь, ибо никсы есть рулез :). Короче говоря, сейчас я поведу речь о тех программах под Win32, без которых трудно представить жизнь нормального хацкера (каково звучит - "нормальный хацкер"? ;-). Разумеется, я не претендую на объективность и всеобъемлемость обзора, ибо всяческих софтин для перебора паролей, извлечения ресурсов, сканирования удаленных машин и прочая-прочая написано так много, что для описания их всех не хватило бы даже такого объемного носителя информации, как тот, который ты сейчас держишь в руках. А посему ниже я представлю только те проги, которые уже долгое время живут конкретно у меня на моем винче и которые я активно юзаю в разные периоды своей бурной жизни. Если некоторые из них тебе приглянутся и статья подвигнет тебя на то, чтобы слить себе экземплярчик, - что ж, я буду только рад.

Что нам нужно в этой жизни?

Для начала давай определимся, что именно должно входить в понятие "джентльменский набор". Если первое, что тебе приходит на ум, это софтина под названием "нюкер", весь интерфейс которой: одно окошко - для ввода IP, и одна кнопка - "убить гада", то ты сильно не прав. Времена нюкеров прошли, и теперь замечательный листинг под названием winnuke.c можно разве что распечатать (в знак уважения) и обклеить распечатками стены ватерклозета. Я не думаю, что в Сети осталось большое количество юзеров, сидящих под дырявой версией виндов (хех, давненько я не видел в работе такое чудо, как Win95), причем без какого-либо файрвола или хотя бы банального Nuke Nabber'а. А посему позволь мне утверждать, что необходимый хацкеру минимум это:

- утилита для подбора пароля к мылбоксам и другим сетевым сервисам;

- сканер расшаренных ресурсов в локальной сети или Инете;

- редактор ресурсов для вскрытия и потрошения экзешников и dll-ок;

- утилита для выдирания паролей из соответствующих файлов :);

- сканер портов удаленной машины (группы машин);

- какая-нибудь универсальная прога для получения полезной инфы об удаленных серваках;

- дизассемблер и HEX-редактор для копания в кишочках у шаровары.

Как я уже говорил, всевозможных прог - тьма, поэтому смотри, чем пользуюсь я. Если ты предпочитаешь другие утилиты - твое дело, о вкусах, как известно, не спорят: я знавал одного чела, так он обожал поедать сливочное мороженое с сушеной редиской вприкуску и утверждал, что это мы все лохи, так как не понимаем смысла истинного вкуса.


Спецвыпуск Xakep, номер #014, стр. 014-090-2, Джентльменский набор

Джентльменский набор

Спецвыпуск Xakep, номер #014, стр. 014-090-2

Номер ноль: ломаем архивы

Ты никогда не попадал в ситуацию, когда в каком-нибудь zip или rar архиве валялся ну очень нужный тебе документ, а архив был запаролен, чтобы такие, как ты, туда почем зря не лазили? Вот поэтому мы будем юзать Advanced Archive Password Recovery, или, проще, ARCHPR. Актуальная версия (на момент написания сего труда) - 1.01.

Глупо спрашивать, что может делать эта софтина: на скриншоте видно, что количество настроек очень прилично: можно подбирать пароль как брутфорсом, так и по словарю. В первом случае можно выбирать, какие символы использовать при переборе (только буквы, буквы и цифры, с учетом регистра, без учета оного, включая спецсимволы или без них...), задавать приоритет использования прогой ресурсов машины. Также полезна опция задания максимальной и минимальной длины подбираемого пароля: если ты ломаешь собственный zip-файл по причине того, что пароль вылетел из твоей ветреной головы, но, тем не менее, ты твердо помнишь, что пасс был шестисимвольный, и никаких цифр ты не использовал, то какой смысл выставлять настройки по максимуму, увеличивая тем самым время перебора в разы. Для удобства в объемной работе прога автоматически делает сохранение текущего сеанса каждые N минут, где время между автосохранениями ты выставляешь сам, как пожелаешь. Так что пароли от арха с эксклюзивными фотографиями Лолы Лолобриджиды будут-таки доступны тебе всего лишь через до фига часов, до хрена минут, а никак не позже. Потому как даже если комп зависнет, ты будешь продолжать ломать арх с момента последнего автосохранения.

Ко всему вышеописанному добавлю, что эту прогу с отличными возможностями и удобным интерфейсом написал наш, русский чел, что окончательно убеждает нас всех в том, что данная софтина - вечный рулез, счастье хацкера, мир во всем мире, free Kevin now и все такое.

Качать тут: www.xakep.ru/post/13379/

Номер раз: сканим сеть

Те, кто регулярно читают ][, уже прониклись всеми тонкостями сканирования сети - будь то локалка или iNet. Сканим мы с тобой, естественно, ресурсы, доступ к которым (намеренно или по ошибке) открыт для всех снаружи, т.е. шАры (шарЫ сканить не надо). Как сканить - понятно, это дело нехитрое: запустил софтину, ввел диапазон айпишников, жмякнул пимпу "scan" и сиди, работай над собой. Любой юзер, имеющий Х#1 за 2001 г., справится. Однако для начала эту софтинку нужно поиметь (я имею в виду - достать и скачать, а господина Бивиса со своим обкуренным приятелем Батхедом, которые хихикают при слове "поиметь", я бы попросил удалиться). Поэтому не буду оригинальным, если скажу, что для своих корыстных целей я, как и все нормальные люди, использую релиз журнала, прогу Х-ShareZ, чего и тебе желаю. Самая свежая версия на момент написания эпохальной статьи - 2.0, однако я юзаю 1.3, и мне вполне сухо и комфортно.

Для использования этого сканера тебе необходимо включить у себя следующие сетевые сервисы: клиент для сетей и службу доступа к файлам, иначе прога будет вопить об отсутствии NetBios'а и ругаться, что ты-де не вошел в сеть, что, в общем-то, правильно. Хотя, впрочем, эти службы установлены в маздайке по дефолту, просто особо умные перцы отключают их у себя, дабы, вместо того чтобы искать жертв, ненароком не стать жертвой самим.


Спецвыпуск Xakep, номер #014, стр. 014-090-3, Джентльменский набор

Джентльменский набор

Спецвыпуск Xakep, номер #014, стр. 014-090-3

Прога написана известным челом, кандидатом в мастера спорта по художественному кодингу, хардкорным программером xPoison'ом и является настоящим ][-релизом, так что если ты поклонник ][, то юзать что-либо другое, кроме X-Sharez, просто моветон :). Шуткаю я, на самом деле эта архиполезная прога и без того завоевала массу поклонников, одним из которых является ваш покорный слуга. За более подробной инфой как об Х-шарез, так и о шарах я отсылаю тебя к январскому номеру ][ за этот год.

Сливается все по адресу www.xakep.ru/post/11565/

Номер два: разрываем проги

Многие недальновидные перцы удивляются, для чего вообще существуют такие вещи, как редакторы ресурсов. Шаровару с их помощью не сломаешь, восклицают они, а раздирать exe'шник или dll'ку только ради того, чтобы вписать в заголовок окна проги что-нибудь типа "released and cracked by kewl hacker Vasya. Yo!" или изуродовать всю геометрию интерфейса проги, это, конечно, прикольно, но не более того. Но на то они и недальновидные - правильные чуваки, вроде нас с тобой, конечно, знают, что редактор ресурсов - это вещь, а хороший редактор ресурсов - это вещь вдвойне. И уж мы найдем им применение. Поэтому я рекомендую весьма популярную прогу - редактор eXescope, версия - 6.0.

Эта софтина умеет делать все, что требуется от приличного редактора: аккуратно вскрывать файлы с расширением exe, dll, ocx, vbx и раскладывать их содержимое по полочкам: заголовки, файлы экспорта и импорта, а также самое вкусное - ресурсы файла: так выдираются, заменяются и впихиваются обратно всяческие картинки и иконки, а подвергнутая подобной обработке прога принимает неповторимый эксклюзивный вид. Ты спросишь, как же можно еще использовать eXescope? Приведу простой пример: несколько месяцев назад, когда злобный AOL решил навешать в новой версии ICQ всех достающие баннеры, по Сети то тут, то там стали раздаваться стоны: "Люди добрые, мы сами не местные, поможите, кто сколько...", тьфу ты, черт, я имею в виду стоны: "Люди! Помогите от баннеров в аське избавиться, плииииз".

Конечно, тут же нашлись умные перцы, которые посоветовали удалить пару-тройку библиотек из аськиного дистриба, но после этой операции уродливое окно когда-то баннера все равно оставалось внизу. Нет, разумеется, сразу же были написаны и тучи прог, которые избавляли от баннера одним нажатием кнопки, но, согласись, как-то это не по-хацкерски - юзать подобные софтины. И тогда нашелся еще один умный перец, который просто запустил eXeScope, перерыл все длл'ки в аськиной папке (уже достижение, учитывая то, сколько там подобных файлов) и обнаружил, что собака порылась в библиотечке под названием ICQcore.dll. Подправив нужный диалог и уменьшив высоту окна сообщения на размер баннера, мы забываем о навязчивой рекламе как о страшном сне - все истинно по-кульхацкерски. А ты говоришь, редактор ресурсов не нужен. А на скриншоте видно, как я навсегда избавляюсь от надоедливого сервиса в ICQ 2000b при помощи eXeScope.


Спецвыпуск Xakep, номер #014, стр. 014-090-4, Джентльменский набор

Джентльменский набор

Спецвыпуск Xakep, номер #014, стр. 014-090-4

И вот тебе напоследок ложка дегтя в бочку пива: я, как ни старался, не нашел официальной хоумпаги этой софтины, так что лей ее отсюда: www.xakep.ru/post/13380/

Номер три: ломаем сетевые аккаунты

Вот ты читаешь эти строки и думаешь: когда же, наконец, мы доберемся до главного: до взлома ftp и pop3 серваков, мыльных ящиков и http-форм. Что ж, ты прав, не иметь подобной проги нельзя, и я рекомендую тебе для подобных гнусных целей использовать Brutus AET2: программу, по праву снискавшую огромную популярность среди подобных себе ресурсов.

Как ты видишь на скриншоте, чтобы юзать ее, особого ума не надо (может поэтому она так хорошо зарекомендовала себя в массах? ;). Как и во всех приличных прогах подобного рода, допускается как перебор методом беспощадного брутфорса, так и последовательный аккуратный подбор пароля по словарю. Думаю, ты не маленький, и тебе не надо объяснять, что специально к таким вот программам в Инете не составляет никакого труда найти текстовый файлик с паролями мегабайта эдак на два-три. Тебе остается только прописать путь к нему, указать мишень, на которую ты натравливаешь Брутуса (мыло, форма), тип перебора, а это может быть подбор паролей по HTTP, POP3, Telnet, FTP, IMAP, опции аутентификации (если ты подбираешь пароль к мылбоксу, то это чаще всего - логин юзверя), установить время таймаута и количество попыток, вдавить, наконец, баттон START и ждать. Время подбора пароля в основном зависит от двух вещей: от того, какой сложности пасс у юзера (если это что-то типа qWm76$#0aN*, то можешь смело забить на такой способ получения пасса), и от того, с какого канала ты ведешь перебор: на диалапе, конечно, далеко не уедешь. Хотя я знаю перца, который оставляет прогу на ночь и идет спать, а на следующий день, при хорошем раскладе, ему остается только прихлебывать утренний кофе и деловито разгребать логи. Говорят, особенно резво Brutus расправляется с так называемой HTTP Basic Auth - стандартное выползающее окошко к запароленной части сайта, где требуют ввести логин и пасс. Подробнее о Брутусе писали в ][ за октябрь'Y2K, статья "Грубая Сила". Надо ли говорить, что софтина поддерживает сохранение сессии, фриварна, проста в использовании, а слить ее можно прямо отсюда: www.xakep.ru/post/10763/

Номер четыре: сканим порты

Еще одна классика жанра - сканеры портов под Win32. Вот уж где самая неблагодарная работа - рекомендовать портсканер, ибо наплодилось их сейчас... Да и в ][ они упоминались не раз и не два... Но я все же попытаюсь привить тебе любовь к тулзе под названием LANguard port scanner, или, проще, LANScan.

Почему именно LAN Scan, спросишь ты? А почему бы и нет, отвечу я :). На самом деле, для меня определяющий фактор - это удобство и отсутствие абсолютно ненужных наворотов. Выбрал тип сканирования, настройки (пинг и/или скан), ввел диапазончик айпишников, выбрал порты - и понеслась! Что тут болтать-то? Интерфейс - удобный, управление - простое, работа - надежная. Прога фриварная, сливается отсюда: www.xakep.ru/post/13381/


Спецвыпуск Xakep, номер #014, стр. 014-090-5, Джентльменский набор

Джентльменский набор

Спецвыпуск Xakep, номер #014, стр. 014-090-5

Номер пять: работаем с серваками

Иногда приходишь к выводу, что многие программы зазря занимают место на твоем винте: вместо того чтобы иметь десяток убогих софтин, выполняющих каждая свою одну функцию, хочется иметь одну, но серьезную прогу, которая позволит тебе использовать сетевые сервисы на все сто. У меня такая программа есть, я в ней души не чаю, а зовется она IP-tools и, вообще говоря, достаточно известна. На тот момент, когда я писал эти строки, последняя версия - 1.11.

Эта рулезная софтина имеет пятнадцать различных утилит для работы с TCP/IP-сетями. Только послушай: Local Info - инфа о твоем компе, Connections - текущие соединения твоей машины, NetBIOS - инфа о сетевых интерфейсах неприятельского компа, NerBiosScanner - подобие сканера расшаренных ресурсов удаленной машины, Portscan, Ping - ну это понятно, сканирование портов и запрос а-ля "ты жива ль еще, моя старушка?", Trace - обыкновенный роутер, отслеживающий, как пакеты летают от тебя и к тебе, WhoIs - запрос об интересующем тебя домене, LookUp - инфа об имени хоста и его алиасах по одному айпишнику, Telnet - встроенный Телнет-клиент, IP Monitor - показывает статистику отправленных/принятых пакетов, Hosts Monitor - пингует хосты и выдает на-гора их статус... Ты еще не устал? В общем, прога что надо.

Я думаю, вывод налицо: зачем юзать сотни мелких, убогих по функциональности прог, если можно качнуть IP tools и наслаждаться жизнью. Качать отсюда: www.xakep.ru/post/10587/. Регистрация стоит 19 зеленых рублей, но специально для граждан exUSSR - всего девять. Е-мое, софтина того стоит!

Номер шесть: потрошим пароли

Подбирать пароли к удаленному компьютеру, конечно, хорошо, но неплохо бы и о своих, локальных паролях "позаботиться" ;). Если тебе не терпится заполучить все аккаунты в твоей локалке под WinNT, то для этого существует тулза под названием L0phtCrack+, она фриварная. Так что смотри, не перепутай ее с LC3 (тоже L0pht crack, но за 250 грин :). LC+ - это аналог шароварной LC3, служащей для взлома паролей Windows NT/2000 путем все того же брутфорса. Прога выдирает хэши паролей из удаленной машины, а затем их расшифровывает, выдавая милый взору каждого хацкера логин и пасс. Важное замечание: пароли можно взламывать, даже если Винде активизирована прога SYSKEY (а в win2k она по дефолту активизирована). К сожалению, за несколько дней до того как я сподвиг себя к написанию этой статьи, мой любимый "винтукей" накрылся медным тазом, так что запустить в сто первый раз LC3, дабы сделать тебе "рабочие" скриншоты, я не смог, а win2k-сетки у меня дома нету :).

Бесплатный аналог LC3, как я уже говорил, зовется L0phtCrack+ и распространяется свободно, при этом к тому же еще и локализована, так что родной русский интерфейс радует глаз, причем переводчики явно не церемонились с тем, как будут юзать ее софтину: если официальная LC3 на сухом языке шинели зовется "Программой для аудита и восстановления паролей Windows NT", то LC+ просто и ненавязчиво предлагает тебе свою опцию: "начать взлом паролей" :). Знали люди, кто будет юзать их тулзу.


Спецвыпуск Xakep, номер #014, стр. 014-090-6, Джентльменский набор

Джентльменский набор

Спецвыпуск Xakep, номер #014, стр. 014-090-6

Все это чудо сливается: LC3 - www.atstake.com/research/lc3/, L0phtCrack+ - www.xakep.ru/post/10362/.

Номер семь: косим под крякеров

Последним номером нашего маленького обзора идут истинно крякерские софтины. Нет, рассказывать об основах ассемблера и расписывать достоинства SoftIce'а я, конечно, не буду - мы же с тобой не кул-крякеры, нам тяжелая артиллерия не нужна. Так, изредка во внутренностях проги покопаться, байтик-другой исправить. Что для этого, помимо дизассемблера, нужно? Правильно, шестнадцатеричный редактор, в простонародье - ХЕКС-эдитор. Популярных редакторов не так уж много, и рулят здесь до сих пор (кто бы мог подумать :) софтины под ДОС. Лично я всем им предпочитаю HIEW, тем паче, что название этому редактору дано не просто так - это аббревиатура фразы Hacker's View, хотя писал его наш, русский человек.

Что мне нравится в HIEW, так это то, что он позволяет открывать файлы в формате текста, HEX-формате или в режиме дизассемблера и там же их редактировать, так что все, как говорится, под рукой.

Помимо HIEW под Винды существует еще шестнадцатеричный редактор HEXPERT, мне он нравится своим удобным интерфейсом: все регистры и адреса отмечены цветом, так что картинка получается весьма наглядная, однако в нем нет встроенного дизасма, что предполагает постоянное переключение между ним и какой-либо специальной прогой, например, Win32dasm. Да и писался он в незапамятные времена, еще под Win 3.1, поэтому не удивляйся отсутствию поддержки длинных имен файлов.

Если тебе, как и мне, еще очень далеко до гуру крякинга, но ручки уже чешутся, то могу посоветовать сайт http://pilorama.nm.ru - там ты найдешь много документации по взлому прог, специальные упражнения и т.д. А вообще, помню, я в свое время делал следующий финт: писал прогу, которая требовала ввести пароль, который брала из отдельного файла, и если он был верен, то радостно "подтверждала авторизацию" (кишки проги ты видишь на скринах хекс-эдиторов), а затем пытался сам же ее сломать. Метод, конечно, чайниковский, но было забавно, рекомендую тебе тоже попробовать. А проги ты найдешь тут: HIEW (на момент написания - свежая версия была за номером 6.70) - www.xakep.ru/post/10905/, HEXPERT - www.xakep.ru/post/13382/.

Если б я жил в буржуинии...

Разумеется, приятель, ты понимаешь, что ни за какую из скачанных прог ни я, ни ты платить не собираемся. Так уж повелось, что Асталависта нам роднее, чем почтовая квитанция или кредитная карточка. Но интересно, а что бы было, если б мы жили все такие из себя честные и пользовались только лицензионным софтом? Посмотрим на примере представленных мною программ.

Из них шароварными являются: ARCHPR - 60 нерусских рублей, HIEW - 10 тех же самых бумажек, L0pht Crack - 250 бакинских (Вау! И покупают?), IP Tools - 19 зеленых (для нас с тобой - девять) и, наконец, X-Sharez - 200 родных, деревянных рублей :). Дави пуск -> программы -> стандартные -> калькулятор и считай. Итого мы "сэкономили" 400 баксов, считая дорогущую LC3, или $150 - без нее. Вместо этого мы пару раз сползали на Асталависту и потратили около семидесяти рублей, купив этот номер Х, который ты в данный момент держишь в руках. Так что поднимем бокал за здоровье мирового пиратства, как бы кощунственно это не звучало. Да шучу я, конечно, шучу.


Спецвыпуск Xakep, номер #014, стр. 014-094-1, Варезный свежак - WindowsXP

Варезный свежак - WindowsXP

Андрей Князев (knyazev@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-094-1

Что же такое WinXP?

Еще несколько лет назад Microsoft высказала <стремление> сократить свои расходы :), и перевести всех пользователей - как домашних, так и <корпоративных> с двух линий ОСей на одну - общую. И было обещано светлое будущее, когда у каждого будет только одна ОСь - устойчивая, стабильная, дружелюбная к играм, инету и злобная к врагам, желающим позариться на твое добро.

Но время шло, появились Win98 SE, WinMе, Win2k, а обещанного чуда все не было. В Microsoft по прежнему развивали направление Win 9x, готовя к выпуску новую ОСь под кодовым названием Neptune и направление NT, разрабатывая Odyssey, будущую NT6. Первая, как и всегда, была бы мультимедийной, но глюкавой, а вторая - устойчивой, но <тяжелой>. В итоге же, всем нам привалило счастье, т. к. теперь уже официально объявлено о том, что две линейки ОСей сливаются :) в одну, а проект Whistler - <Шептун>, отныне официально именуется Windows XP (о том, что значит ХР - смотри во врезке).

Что значит ХР?

Официально M$ трактует ХР как eXPerience, т. е. типа ХР - это операционка для искушенных, опытных людей. И такая трактовка конечно довольно лестна. Но аббревиатуру ХР можно толковать и немного по-другому: как eXPert - эксперт, eXPensive - затратная (ну это нам не грозит), eXtra-Perfect - супер лучшая (а это вполне может быть).

Вокруг Whistler'а - ХР уже сложился настоящий <культ> - все хакерские конфы полны криками - <хочу свежий релиз!>, <у кого есть Beta 1?> или <а у кого PreBeta 2?>. Пираты не успевают штамповать диски, так как M$ быстрее <печет> всевозможные беты, чем наши доблестные варезо-качатели успевают все это сливать в Россию и писать.

Если тебе повезло и ты имеешь толстый канал в Сеть, или устойчивый (и халявный :)) DialUp, то и ты можешь не полениться и отгрузить себе какую-нибудь свеженькую версию WinXP. Хотя, конечно, пока скачаешь - тебе придется немного попотеть.

Можно попытаться дождаться :) появления какого-нибудь из свежих билдов на алюминии или... можно прочитать эту статью (в любом случае, я думаю, инфа, которую ты здесь почерпнешь, будет тебе полезной), и быть 100% <в курсе> о том, что же такое Windows XP... В Х-тесте участвовала версия Windows Whistler Personal Build.2410.main.001208-1937

История <Проекта Шептун>. Основные вехи.

13 июля 2000 г - Windows Whistler (build 2250) Preview release

3 октября 2000 г - Windows Whistler (build 2267) interim release

19 октября 2000 г - Windows Whistler (build 2287) PreBeta 1

31 октября 2000 г - Windows Whistler (build 2296) Beta 1

4 января 2001 г - Windows Whistler (build 2410) PreBeta 2

5 февраля 2001 г - Windows Whistler (переименована в Windows XP)

9 марта 2001 г - Windows Whistler (build 2454) PreBeta 2

График выхода новых версий:

Windows XP RC (Release Candidate) 1 - апрель 2001

Windows XP RC 2 - май 2001

Windows XP Retail Release - сентябрь 2001.

Установка ХР

Я с некоторым <содроганием> приступал к установке ХР, рассчитывая на всевозможные казусы и грабли. Признаюсь сразу - мои ожидания меня не обманули, и пришлось повозиться, прежде чем ОСь встала, как полагается. Но тебе будет проще - держи готовое решение по установке.


Спецвыпуск Xakep, номер #014, стр. 014-094-2, Варезный свежак - WindowsXP

Варезный свежак - WindowsXP

Андрей Князев (knyazev@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-094-2

Серийный номер

и другая шняга

Скачать и даже начать устанавливать ХР это еще полдела. Самое важное на этапе установки - ввести правильный серийный номер. т. к. именно с билда 2410 Micro$oft, видать, опасаясь начала массовой установки читателями Х своей новейшей ОСи, ввела запрос серийного номера. И обойти эту процедуру можно... только вводом правильного номера! Причем требуемый код - это не просто <серийный номер> - это первый звоночек новой <антипиратской> технологии M$ Product Activation for Windows (сокращенно WPA). Подобное уже было использовано в Office 2000 SR1 (тут, я думаю, все легко обошли проблему). Но ввести номер не достаточно - помимо этого, мелкомягкие желают получить от тебя (используя iNet, конечно!) еще и данные о твоей системе, включая всевозможные ID установленного <продукта>, а также железа. После такой регистрации - второй раз указанный тобой номер никому использовать уже не удастся. Но выход, как обычно, был найден!

Во первых - в последних билдах ХР - система может ждать 30 дней, до того, как <отрубиться> из-за <отсутствия лицензии>. А во вторых - хотя все будущие версии ХР и будут снабжены такой защитой (по крайней мере пока планы у M$ такие), но на ОЕМ версии это распространяться не будет :). Так что никто без релизной ХР не останется (и это даже хорошо, т. к. ОЕМ версия всегда выходит раньше боксовой, т. е.... к нам релиз доедет однозначно раньше!).

Ну а в третьих... Есть способ обойти 30-ти дневное ограничение (хотя, при этом, все равно останется 180-дневное - но за полгода-то точно можно будет себе новый билд поставить :)).

Итак, для того, чтобы не посылать дядюшке Билу своей приватной инфы, после 30-ти дней работы, ты грузишься в XP Safe mode (для тех кто в танке - надо нажать F8 в начальном меню загрузки). Затем грузишься <нормально>, без всяких <командных строк>, идешь в Regedit, там шествуешь в

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon.

Ищешь ключ [Activation Required], и меняешь его значение на 0. Все! после чего рестартишь винду в штатном режиме - все работает. Откуда взять серийку говорить не буду, не маленький уже :).

Установка ХР в локалке

Важное замечание для тех, кто будет ставить ХР на машины, работающие с выделенок. Если на dial-up'е довольно просто отследить, когда <Шептун> захотел пошептаться с дядей Билом, то на выделенке можно <не успеть>, поэтому при установке следуй такой процедуре:

1. Перед установкой <обесточь сеть>, проще говоря - выдерни кабель сетки из компа.

2. Ни в коем случае НЕ используй Динамическое обновление - , когда тебя об этом спросит Setup.

3. После окончания установки, первое что тебя спросит ХР при первой же загрузке - это немедленная установка доступа в Сеть. Проигнорируй этот шаг ( т. е. НЕ настраивай сеть немедленно!).

4. Не откладывая в долгий ящик, иди в Run, и запускай regsvr32.exe -u regwizc.dll. Появится окошко с подтверждением - закрывай его.

5. Затем двигай в Regedit и иди в:


Спецвыпуск Xakep, номер #014, стр. 014-094-3, Варезный свежак - WindowsXP

Варезный свежак - WindowsXP

Андрей Князев (knyazev@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-094-3

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion

Здесь ищи ключ RegDone и меняй его значение на 1.

6. В Internet Explorer, открывай установки и меняй прописанную Default Home-Page на любую, кроме Microsoft или MSN!

7. Последнее. Уходи в reboot, подрубай и настраивай сетку. Ты в безопасности от <Большого брата>.

Насколько прожорлива ХР?

<Официальных> требований к ресурсам системы пока нет. Но очевидно, что ресурсов тебе потребуется не меньше, чем для Win2K, хотя минимально тебе надо: Пень 133 с 32 метрами памяти на борту :). Но если без шуток, то камня с частотой около 400-500 МГц с 96-128, должно хватить более-менее.

Требования к винту - не меньше 2 Гигов (интересно, а остались ли еще меньшие харды?). Для сравнения:

Установленная (без лишних сервисов, т. е.. голая) WinХР занимает порядка 900 Мб. Дистрибутив системы - около 450+ Мб.

Установленная W2k Prof. занимает порядка 700 Мб. Дистрибутив - около 300+ Мб.

Установленная WinNT4r занимает порядка 300 Мб. Дистрибутив - около 100+ Мб.

Установленная Win95 OSR2 занимает не более 100+ Мб. Дистрибутив - около 40+ Мб.

Лирическое отступление - Идеология ХР

Чтобы понимать, почему ХР так важна для M$, надо понимать идеологию этой монстрообразной компании. В Microsoft придают очень важное значение этой ОСи. И хотя Х выступал, выступает и будет выступать против <политики> этой компании - на сей раз мы должны признать - данный продукт им на 95% удался :). Ведь всегда есть что улучшить. Но в данном случае - все очень хорошо. Именно по этому, даже дядя БГ, расчувствовавшись, назвал ХР <самой важной из ОС Microsoft с момента выпуска Windows 95>.

Итоги установки

Уже на этапе установки видно, что система идет упакованная всевозможными драйверами под завязку (файл - база с драйверами весит не один десяток мегов). Поскольку ОСь новая - все драйвера пока пишутся или адаптируются самой M$, но со временем, безусловно, подтянутся и разработчики ОЕМ-драйверов - ведь теперь им будет жить гораздо проще - не придется одновременно делать несколько версий под разные системы. Как бы то ни было - все, т. е. буквально ВСЕ железо, что было у меня, <подхватилось> и заработало (причем правильно и грамотно!) после первой же загрузки системы. Видюха, звуковая карта, модем, CD-R (ведь в самой ХР теперь есть встроенная прога для того, чтобы быстренько <зажечь> диск).

Как все работает?

Пользователю - пользовательское, а админу - админовское...

Похоже, что в M$ снова <взялись за ум>, перестали <изобретать колесо>, и вернулись к хорошо выученной методе <копирования чужих идей>. Тем не менее - ХР, даже будучи единой системой, с едиными драйверами и прочим и прочим, будет выпускаться в нескольких разных версиях - Personal (она же Home Edition - <домашняя>, 32-х битная версия), Professional, Server и Advanced Server (64-х битные, <рабочие> - профессиональные версии).

Наконец-то серверные ОСи смогут работать в <безголовом> :) режиме (, т. е. без включения клавиатуры, мыши, монитора), т. е.. все управление серверами будет осуществляется через сетевой терминал. Однако во всем остальном - все системы будут 100% одинаковы. Полная интеграция с Internet Explorer 6, <встроенный> Windows Media Player 8. Полная <подгонка> под Office 10 aka Office XP (кстати, о новейших IE6 и Office XP ты сможешь прочитать в PC-Zone ближайших номеров Х).


Спецвыпуск Xakep, номер #014, стр. 014-094-4, Варезный свежак - WindowsXP

Варезный свежак - WindowsXP

Андрей Князев (knyazev@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-094-4

Совместимость

Коль скоро новая ОСь <позиционируется> (блин, какие все умные слова) как , то в M$ должны были в лепешку расшибиться, но обеспечить совместимость новейшей операционки со всеми основными предыдущими версиями - 95/98/98 SE/Me/NT/W2k.

Для запуска какого-то <непослушного> приложения есть два пути - или <довериться> самой системе (садишься за компьютер и кричишь: <природа, помоги>), или запустить приложение в <режиме эмуляции> одной из предыдущих версий Windows (95 или NT4), просто поставив соответствующую галочку в ярлыке запуска программы.

Для <устаревшей> проги система сама выдаст требуемый номер версии ОС, даст поюзать нужные ей системные папки (которых реально у ХР скорее всего не будет), если что - даже сымитирует нужные ключи реестра, и даже (о фантастика) некоторые функции API. ХР уже идет с базой ПО, для которого параметры <предыдущей версии> будут подставлены автоматически, и список этот будет пополняться. Пока же таких программ более 300 (в том числе и куча так любимых тобой игрушек).

Администрирование

Настраивать (и администрировать) учетные записи стало проще... хотя бы потому, что теперь помимо имени пользователя для визуальной идентификации можно использовать... его фотографию (которая, кстати, будет показываться в logon окошке).

Появилась такая очень приятная фишка, как <многопользовательский> вход в систему. Т. е. ты в любой момент можешь войти в систему хоть root'ом, хоть guest'ом, и потом, легко переключаться между сеансами. Теперь можно запросто <утереть нос> линуксоидам, одним из <фетишей> которых была невозможность MustDie'я работать с несколькими пользователями одновременно. Теперь количество <одновременно> :) работающих пользователей ограничено только Policy и ресурсами самой системы. Если переключившись в <основной> сеанс остальные тебе стали не нужны - их можно легко и непринужденно закрыть через Task Manager.

Внешний вид

Внешний вид не то чтобы очень сильно отличается от Ме, нет... но все равно он <другой>. Самая часто нажимаемая кнопка на Desktop'е - кнопка Start совершенно преобразилась. Теперь пусковое меню существует в виде двух колонок - слева наиболее часто юзаемые проги, а справа - <полный> список - Программы, Панели управления и все проче, причем большая часть и этого списка <скрыта в стрелочку>. Весь внешний вид системы теперь легко меняется путем выбора определенной <темы>. Пара кликов мышью - и у тебя уникальный, отличный от других desktop, еще пара кликов - и опять <стандартный w2k>. Пока что у ХР - две основные <темы> - Professional (XP-Style) и Classic (W2k-Me-Style).

Но при любой теме - две новинки остаются неизменными (впрочем, их все равно можно отключить). Первая - это группировка в task-bar'е схожих кнопок - типа окон Ie, или Word'а. т. е.. смотришь ты на работе свой любимый Х-сайт (www.xakep.ru :), и никто не докопается, что у тебя открыто 10 окон Ie - так как их все можно убрать в одну пиктограмму, и потом <из стрелочки> развернуть <по новой>. Когда приходится много серфить - эта опция по-настоящему удобна.


Спецвыпуск Xakep, номер #014, стр. 014-094-5, Варезный свежак - WindowsXP

Варезный свежак - WindowsXP

Андрей Князев (knyazev@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-094-5

Вторая <причуда> придется по вкусу... не знаю кому. Теперь в ту же <стрелочку> - в одну пиктограмму можно свернуть весь System-tray - область слева от часов. Конечно, для монстров, у которых висит по десятку иконок в трее это покажется удобным, а всем остальным - нормальным людям - у которых кроме переключателя клавиатуры, громкости звука и аськи никакого барахла в трее нет - все равно. Но пусть будет, так уж и быть :).

Панель управления также претерпела изменения. Все <апплеты> теперь сгруппированы по нескольким основным категориям. И уже только внутри каждой группы-категории находятся соответствующие конечные функции. Т. е. с одной стороны путь стал дольше, но с другой - к самым последним из используемых настроек стало добираться быстрее.

Весь дизайн (начиная от процесса установки и до shut-down'a) стал более <округлым> и <прозрачным>. Конечно прозрачные иконки на рабочем столе это не ахти какое новшество (у Apple уже давно есть Aqua) - но все равно радует.

Как финальный аккорд - менюшка завершения работы также изменила свой внешний вид на более игривый, но сути своей она от этого, конечно, не изменила.

Стабильность

А вот здесь вообще полная засада... для упертых линуксоидов. Если умеренно постаравшись NT уронить было можно, Win2k - хорошо постаравшись, то для того, чтобы уронить бету(!) ХР надо постараться очень сильно. Даже в <сыром> состоянии система демонстрирует чудеса надежности и стабильности. Я думаю, что немаловажную роль в обеспечении стабильности играет улучшенный механизм работы с памятью. Теперь у тебя даже есть возможность выбора - каким образом будет распределяться память - отдавая приоритет приложениям (как сделано в NT/W2k), либо системному кэшу (как в Win 9х).

Помимо <общих> и не очень заметных глазу функций - полностью переработан <механизм защиты>. Я было хотел написать <от дурака>, но на самом деле нет. Я не думаю, что всякие бакланы будет ставить себе ХР, они как пользовали, так и будут юзать 98-Mе. ХР - это система для экспериментаторов - для тех, кто не боится ОСи и всегда пытается сделать ее лучше, максимально разогнав и подогнав ее <под себя>. И именно для таких людей как нельзя кстати будет <многоступенчатая и глубоко эшелонированная>, а главное толковая и реально хорошо работающая система восстановления после сбоя.

Во первых, в ХР добавлена фишка PCHealth, включающая в себя System Restore (Me-users уже оценили, что это такое).

Во вторых, в ХР появилась система Windows File Protection. Теперь тебе не будет страшно даже если <полетят> все любые библиотечки (dll). Мало того, что каждое приложение теперь выполняется в <псевдочистой - защищенной> собственной среде, так еще и сохранность всех библиотек и прочих важных компонентов мониторится на уровне ОС системой Fusion. В случае реального сбоя - все поврежденные файлы будут установлены или с бэкапа на харде, или с дистрибутива (который ОСь у тебя потребует и все починит).


Спецвыпуск Xakep, номер #014, стр. 014-094-6, Варезный свежак - WindowsXP

Варезный свежак - WindowsXP

Андрей Князев (knyazev@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-094-6

Но и это еще не все! В третьих, если ты точно знаешь, что причиной сбоя стал <неправильный> драйвер, то его всегда можно <откатить>, сделав в меню свойств конкретного устройства. И этот механизм работает лучше, чем System Restore, т. к. восстанавливаются только реально <дефектные> файлы, а не все целиком.

В крайнем случае, ты сможешь прибегнуть к палочке-выручалочке в виде дружеской <ноги помощи> - системы Remote Assistant (профи без труда опознают в Remote Assistant немного урезанную версию Terminal Services). Ты просто отсылаешь своему <спасителю> по е-почте специальное письмо-приглашение, которое дает его получателю право полного контроля над системой (a'la pcAnywhere или чего-то подобного). После чего ты спокойно куришь бамбук, а <тот парень> все делает. При этом ты можешь еще и обмениваться с ним сообщениями в real-time. Правда пока что функция Remote Assistant реализована только между ХР-машинами, но на этом этапе развития ОСи нам по другому и не надо :).

Безопасность

Ядро NT/W2k - значит не только <стабильное>, но и <безопасное>. Теперь тебе не нужно особо париться для того, чтобы обеспечить приемлемую сетевую безопасность. В составе ХР идет брандмауэр ( т. е. файрвол), который можно настраивать не только на уровне протоколов, но и приложений. Но пока что родная система еще сыровата, и все равно приходится пользоваться сторонними программами.

Для тех, у кого слишком много всевозможных паролей и кому не жалко доверить их M$ - очень кстати будет система Credential Manager, позволяющая хранить в одном месте все Soft & Web - пароли и вводить их в нужном месте <на автомате>. Теперь тебе нужно только войти в свою учетную запись, ввести пароль, запомнить его - и все - больше никаких проблем. С другой стороны - так будет еще проще спереть твои пароли :(, но удобство от этой функции большое :). Так что каждый волен выбирать сам - шашечки или ехать.

Что не

понравилось

в ХР

Поскольку понравилось все, то не очень просто оказалось найти жуткие минусы. Мелочевка конечно есть, но ведь это еще бета, а вот по крупному...

Немного достала программа обновлений - Update Reminder, но ее оказалось довольно легко урезонить.

Периодически напрягал монитор свободного места на диске. Если у тебя на диске остается где-то меньше 20% от его объема (или около 200 Мб - зависит от билда), то периодически будет выскакивать напоминание - предложение очистить диск, потерев все ненужное. Но это - рабочий момент и его можно пережить.

Corporate Warning или be-in-corporated!

Так уж получилось, что Micro$oft удалось сделать самую популярную операционную систему в мире. И это самая, что ни на есть объективная реальность. Все дружно ругают это <глюкало>, но пользуются, пользовались, и будут пользоваться. Вместе с тем, не мало людей ушло на <альтернативные> ОСи - Linux, BeOS, MacOS, etc... Но все эти операционки (за исключением, пожалуй MacOS) не очень дружелюбны к пользователю. Именно простота и доступность - основное оружие мелкомягких. Общим местом стало ругать Win95/98/9x/Me. При этом большинство <ругателей> в жизни не видели других ОСей. А ведь у M$ уже больше 7 лет есть грамотно сделанная и устойчивая операционка. Самые догадливые уже давно сообразили, что я говорю о Windows NT. К сожалению, NT 4, даже со всеми шестью сервис-паками, уже морально устарела. Но поникшее знамя NT в прошлом году подхватила Win2000, хотя и не снискавшая супер-популярности. Теперь же Корпорация собирается сделать самый решительный шаг и окончательно объединить под одной <маркой> все свои ОСи. Релизная WinXP будет обладать всей устойчивостью и стабильностью WinNT и всеми <дружелюбностями> и <медийностями> от Win 9x.


Спецвыпуск Xakep, номер #014, стр. 014-094-7, Варезный свежак - WindowsXP

Варезный свежак - WindowsXP

Андрей Князев (knyazev@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-094-7

Резюме: учи матчасть - ведь для того чтобы быть реально готовым к старту WinXP, нужно хорошенько понимать WinNT/2000. Так что до даты релиза у тебя есть время как для того, чтобы лучше освоить 2000, так и для того, чтобы лучше разобраться с самой XP, установив себе какую-нибудь из бета-версий.

P.S.: WinXP - это однозначно основная ОСь этого и следующего годов, т. к. будущее обновление линейки Windows M$ планирует делать не раньше второй половины 2002 года. Проект с кодовым названием Blackcomb уже в работе. Ждем-с...

The final countdown

Была во время оно такая группа - Europe, и была у нее такая популярная песня The final countdown (впрочем - группа мертва, но песенку в mp3 ты найти можешь легко). Сейчас все мы стоим перед началом финального отсчета. И каждый делает свой выбор.

Ты можешь и дальше пользоваться таким простым, таким <легким> и таким <глюкавым> MustDie'ем и огульно ругать, почем зря M$. Или можешь сделать правильный выбор и перейти на более сложную, но и более мощную и удобную ОСь - WinXP. Я практически уверен, что через полгода - год, WinXP-пользователь будет <звучать> ничуть не менее внушительно, чем Linux-user. Нужно лишь избавиться от стереотипов... самому...

Удачи!


Спецвыпуск Xakep, номер #014, стр. 014-098-1, Шары в Х-стиле,

Шары в Х-стиле,

или Legion

Спецвыпуск Xakep, номер #014, стр. 014-098-1

по-русски

Вадим Марков aka xPoison (root@irctoolz.com), http://irctoolz.com

"Всем известны возможности ОС Windows 95 по созданию одноранговой локальной сети, позволяющие легко организовать совместное использование дисков и принтеров внутри рабочей группы. Однако лишь немногие знают о том, что эти возможности доступны и в сети Internet."

(c) 1996 Тодд Танненбаум - Network Computing.

Так как же проникают на чужие винты?

Сейчас речь пойдет снова о шарах. Говоря языком продвинутых кодеров, в контексте windows, шарами мы называем сервисы, висящие на 137-139 портах и предоставляющие юзерам возможность совместного доступа к дискам, папкам и файлам. Естественно, доступ к чужим disc`ам и файликам может быть использован не только обычным юзарем, но и хакером. Подобные идеи витали в воздухе с незапамятных времен и постепенно воплощались в таких культовых прогах, как "Legion" и "Essential Net Tools". На дворе Y2K+1 (очередной Санта-Клаус загнулся от холода), а мы рассматриваем продолжение линейки сканеров - xSHaReZ. Это фирменный релиз Х, о выходе которого ты мог прочитать в прошлом номере.

Итак, для самых маленьких, что же такое shared-ресурсы на практике? У-у-у... а ведь этот вопрос уже давно крутится в твоем незамутненном пивом мозгу? Что потребуется желающему для получения практических знаний в области share: взять пива, достать 2-3 часа доступа в Инет, а затем закачать последнюю версию xSharez с паги Х-релизов - www.xakep.ru/articles/releases. Для закрепления теоретических знаний надобно заползти в поисковик и слить найденную инфу по вопросу шаров (shares, netbios, разделяемые ресурсы, 139 порт и т.д.).

Практические занятия по поиску ламера в Инете

Поехали... Теперь мы попытаемся получить знание о том, как это юзается в Интернете. Все настройки будут рассмотрены для семейства операционных систем под кодовым названием "мастдайка" (aka Windows 95/98), ибо на данный момент они имеют наибольшее распространение у твоих потенциальных жертв.

Предположим, что в твоей конфигурации Windows 95/98 установлен стек TCP/IP, а твой комп подключен к Internet через высокоскоростной мопед. Теперь необходимо произвести следующие манипуляции: установить "Клиент для сетей Microsoft" и "Службу доступа к файлам и принтерам сетей Microsoft". Если ты в локалке с сетевой картой и модемом, и эти службы уже установлены, то стоит проверить, чтобы они были привязаны к модемному интерфейсу. Установка и привязка делаются в "Свойствах сети", в "Панели управления". Я даже не поленился и сделал 2 скрина, изображающих настройки сети на моей домашней тачке (вне работы - я заядлый диалапщик), вот один из скринов:

Для особо талантливых красными точками помечены сетевые компоненты, которые необходимо установить. После изменения каких-либо параметров система попросит ребутнуться, можно соглашаться - это не опасно.

На фиг это все? Дело в том, что у потенциальных жертв такие настройки уже сделаны (это и было их главной ошибкой, если не считать появления на свет), и для того чтобы ваши компы подружились и вообще поняли друг дружку, как раз пришлось так напрячься.


Спецвыпуск Xakep, номер #014, стр. 014-098-2, Шары в Х-стиле,

Шары в Х-стиле,

или Legion

Спецвыпуск Xakep, номер #014, стр. 014-098-2

Полдела сделано, осталось заставить Windows запускать эти службы при выходе в Интернет, это делается одним волшебным движением: заходим в свойства диалап соединения, выбираем закладку "Тип сервера" и ставим жирную галку "Войти в сеть". Эти же манипуляции проделал и я, чтобы порадовать тебя расположенной ниже картинкой.

Теперь при каждом удачном коннекте на твоем компе будут запускаться указанные выше сетевые службы, а также комп будет присваивать себе NetBIOS имя, например, "VASYA", "PUPKIN", "LAM3R" и т.д. Имя ты выбирал себе при установке мастдайки, и можешь изменить в любое время на закладке "Идентификация" в свойствах сети. Кстати сказать, если при установке операционки Виндос владелец компа ничего не выбирал, а щелкал грызуном от балды, то имя его компа будет - "OEMCOMPUTER". Это верный признак высококачественного ламера, которых в Интернете гнездится довольно много: процентов 10-15 от всей "шаровой" тусы,обнаруженной мной.

И вот начинается бой!

Ну что же, вся предвариловка завершена, и твоя операционка теперь вполне сгодится для проведения широкомасштабных атак на толпы ламерюг, населяющих просторы Интернета.

Теперь есть возможность натянуть Васю Пупкина, по IP которого расположены шары. Я заочно представляю, как ты ломишься к своей тачке в надежде поиметь Васю Пупкина. Но... Обломись: Василия уже хакнули. Да и захват диска на первом попавшемся IP может сложиться только при очень большом везении. Посуди сам: далеко не на каждом айпи висит диалапщик, далеко не каждый диалапщик вот так вот просто возьмет и установит необходимые службы, и откроет тебе доступ к своим дискам. В 9* виндах это в состоянии сделать только отборные чайники (с NT ситуация несколько лучше, но сама ось менее распространена среди интересующих нас ребят), каковых, к сожалению, очень мало.

Незаметно мы подошли к цели этой статьи - описанию небольшой программки, которая будет терпеливо перебирать IP адреса и сама отыскивать открытые ресурсы, которые ты сможешь потом использовать по своему усмотрению.

Тулзенка зовется xSHaReZ scanner, самую свежую версию ты можешь найти на паге Х-релизов: www.xakep.ru/articles/releases.

Рекомендуемый прядок действий таков: выбирается диапазон IP (для начала можно пощупать пользователей собственного прова), потом нажимается кнопа "Скан", прога сворачивается, а ты продолжаешь заниматься своими любимыми тусовками в ирцке на irc.dal.net #xakep =). В какой-то момент IRC все-таки надоест, и ты вспомнишь, что что-то там сканил. Развернув программулину, не без удивления ты, очевидно, обнаружишь несколько компов с расшаренными ресурсами. "Вот это удача!" - появятся стандартные положительные эмоции :). Пальчик, уже не стесняясь, тыкает в первый попавшийся диск.

Берем в рабство ламера

Мастдайка радостно плюется своим стандартным диалогом подключения ресурсов. И единственным легким движением ты становишься обладателем еще одного сетевого диска =). Правда, не всегда все проходит так гладко: запросто может выскочить второй диалог и потребовать пароль =(. Но тут главное не теряться, а настырно жать "о'кей" второй раз. Юзер мог закрыть паролем полный доступ к диску, а "только для чтения" оставить без пароля.


Спецвыпуск Xakep, номер #014, стр. 014-098-3, Шары в Х-стиле,

Шары в Х-стиле,

или Legion

Спецвыпуск Xakep, номер #014, стр. 014-098-3

Дело сделано, дальнейшие действия ограниченны только фантазией... Для скачиваний-закачиваний и прочих магических операций я категорически не рекомендую использовать Explorer ("Проводник", типа) и прочие тулзены, имеющие привычку отображать каталоги в виде дерева и рисовать пиктограммы к разным типам файлов. Они будут сильно тормозить весь процесс. А, кроме того, в случае, если "партнер" по ту сторону Интернета вдруг очнется и, от греха подальше, решит вырубить модем, то вся система просто подвиснет на довольно-таки продолжительное время. В свете этого оптимальным вариантом окажется FAR manager или любая другая NC-подобная прога, позволяющая вводить команды MS-DOS. Хотя особых траблов при обрыве не вызывает и народнолюбимый Windows comander.

В FAR`e же процесс выкачивания *.pwl будет выглядеть так: жмется alt+F2, переключается на подключенный сетевой диск (пусть это будет "Z:"), и сразу же видно, где там прячется Windows ("z:\windows"). Далее выкачиваются все интересные файлы - *.pwl (классика), uin.dat (асю снова трахнули), *.ini из папки IRC-клиента (пароли, запрятанные в скриптах, настройки на редирект серверы, соксы и прочее). Да и много чего еще можно стянуть другого: фантазии нет границ :).

Удачи тебе в хаке! Целуй маму, поливай фикус...

врезки

1

Что ты можешь получить,

грамотно юзая эту прогу

Чужие диалап и почтовые пароли - это 100%. Не исключено, что это будут пароли перцев, тупо гоняющих траффик на твоем же провайдере.

Пароли к более или менее симпатичным ICQ уинам, если атакуемый вдруг юзает аську.

Пароли к IRC никам и каналам - ведь ты, как и любой кул-хацкер, зависаешь в ирке каждый день.

Различную инфу, лежащую на винте у атакуемого, - да что там говорить: ВСЮ инфу, хранящуюся на винте у жертвы.

Лишение свободы на срок до 2 лет по статье 272 (неправомерный доступ к компьютерной информации) - не грейся, это маловероятно.


Спецвыпуск Xakep, номер #014, стр. 014-100-1, Кто ходит в гости?..

Кто ходит в гости?..

Kiron R (kirohn@mail.ru)

Спецвыпуск Xakep, номер #014, стр. 014-100-1

Вообще-то придти в гости - уже большое западло. Но уж если это случилось, тебя пригласили, и ты обзавелся планами хорошенько повеселиться, лучше начать подготовку дома (дня за два до часа У).

огда будешь непосредственно готовиться, перечитай эту статью, тут пара беспредельно ценных советов по выживанию среди нудно настроенных гомосапиенсов, скучной музыки и невразумительного состояния всей тусовки вообще.Специфика предстоящего мероприятия состоит в том, что за учиненную тобой проказу отвечаешь не ты один, если вообще отвечаешь. Т.е. если все пройдет удачно, то эту вечеринку будут потом долго вспоминать как внеочередную пятницу тринадцатого или четверг тридцать второго...

Но вернемся к самому мероприятию. Это праздник жизни, и всем должно быть по сценарию весело. Но только почему-то все не так, на душе скребут кошки, некуда себя деть, вокруг постные трезвые рожи...

Существует масса способов поднять настроение окружающим за счет опускания других.

Вот некоторые из них:

Приколы, проводимые самостоятельно

Тебе нужны: спички, изолента, петарды, ножницы, бумага, пакетики искусственной крови (в Детском Мире, отдел розыгрышей и приколов), пиротехническая ракетница на 8-12 ракет (где-то 10-15 р. на любом рынке), клей, хлороформ (придется искать через друзей, в аптеке просто так не продадут), противогаз (можно респиратор), рыбий корм, два сникерса и вообще все, что можно незаметно пронести.

Помни, реальный западлостроитель всегда хороший актер, если хочет жить =). И перед выходом на сцену прорепетируй перед зеркалом невинную мину на лице.

Каждый театр начинается с вешалки, как и та халупа, в которую ты ввалился. Ты как настоящий джентльмен пропустишь всех вперед и разуешься (разденешься последним). Не забыв положить искусственную кровь в обувь, смазать клеем перчатки и все, на что ляжет глаз и до чего дотянутся руки.

Поздоровавшись, цельная куча твоих друзей и не менее большое количество товарищей пойдет звонить домой мамочкам-бабушкам с целью сообщить, что, мол, добрались и все в порядке. Как бы не так! Ведь сзади притаилось само чудо розыгрыша в твоем лице. Пока кто-то говорит, подойди и сзади крикни в трубку:

- Федь (Вась, Мих, Вов...), ты там наблевал в кухне - надо убрать...

Варианты:

- ...Трусы хотя бы одень (отдай).

- Героин у тебя? Или совсем наркотиков не осталось?

- Гони стольник, раз проиграл, карты - не шутка!

- Ты обещал(а) пол-литра выпить, там налили уже...

- Проститутки приехали, иди встречать!

- Опять шприцы грязные!

- ...(Твой вариант)

Злая шутка, представь реакцию на другом конце провода. А в целом смотри по ситуации.

А потом мило попросись помогать на кухне - готовить и разносить. Думаю, не надо объяснять, зачем это нужно, ты и так самый крутой в игре "положи в еду соседу" (если читал предыдущий номер Х).

За столом

Далее традиционное застолье. Это огромное поле для деятельности ждет только тебя. Наклонясь за упавшей вилкой, можно реально вершить чужие судьбы. Например, хорошо смотрятся дерущиеся за столом человеки как раз во время очередного тоста за дружбу, которым ты склеил скотчем (изолентой) кромки штанов или смазал их клеем (в этом случае более конкретный эффект "приставания").


Спецвыпуск Xakep, номер #014, стр. 014-100-2, Кто ходит в гости?..

Кто ходит в гости?..

Kiron R (kirohn@mail.ru)

Спецвыпуск Xakep, номер #014, стр. 014-100-2

В туалете

Когда остальные пойдут в туалет, постарайся быть в числе первых. Вся санитария здесь совмещенная, и, сделав свое нехитрое дело (смазать стульчак феналгоном, подумал ты, это слишком заезжено), плесни хлороформом на полотенца и прысни по углам дезодорантом. Выпивший не слишком много ничего, кроме собственных носок, как правило, не чувствует. Выйди, пусти следующего(щюю). Жди результата минут пять-семь. Результат обычно красив - звук падающего тела - паника рядом с туалетом и минус один дверной замок.

На балконе

Ты дочитал до этого места. Значит, не убежал готовиться или уже вернулся. Продолжим.

Во время перекура на балконе возьмись за бельевую веревку и скажи соседу что-нибудь типа: "А тебе слабо такой мертвый узел связать?".

Беги на кухню. Врывайся туда с криком "Там Витя (Петя, Саша) вешается!!!" В опустевшей кухне заимствуешь бутылку масла, дрожжи, яйцо... И вообще, незачем тащить с собой из дома то, что можно позаимствовать прямо на месте.

Телевизор, монитор

Маслом надо протереть экран монитора-телевизора, сервант. Теперь на них никто не посмотрит. Но не выливай все - оно тебе еще очень пригодится. Отказавшись от попыток разглядеть что-нибудь сквозь стекло монитора, народ опять попрется в туалет (или куда ж еще?). А там ты уже положил дрожжи в ковш унитаза, полил их маслом и посыпал чем-то крупно рубленным, типа гороха. То же самое в раковине, в ванне... Итог - стопроцентная заблеванность. И если кто спустит воду в толчке, пожалеет.

Групповой приколизм

Если ты попробовал все, и никто ничего не заметил, значит можно переходить на следующий уровень - приколодеяния, совершаемые в группе, т.е., как минимум, вдвоем. Найди себе более-менее трезвого единомышленника и вперед.

Сектанты

Берем китайские - индийские - чукотские дымовые палочки (их еще ароматными называют, продаются в магазине "Путь к себе", м. Белорусская). Зажигаем. Хорошенько надымив в какой-нибудь комнате, залезаем туда вместе с сообщниками. Один самый-самый помощник идет приглашать других посмотреть. При звуке шагов начинаешь читать молитву (можно компьютерную), твои знакомые дружно имитируют выход в астрал, в шкафах звенит посуда (положи туда пейджер, включи вибрацию и пошли 20 сообщений с повтором через 2 минуты), и вот тут-то начинается полет твоей собственной фантазии: показываешь на кого-нибудь пальцем, "я знаю, кто ты на самом деле!". И все в таком духе. Повторяю, это не теория - это работает, при умелом исполнении вызывая подчас реальный страх, особенно у мало знакомых товарищей и почти у всех девушек. Особо могут помочь ритуальные знаки, письмена на открытых участках лысины, разноцветные контактные линзы и т.д. и т.п.

Шпионы

Представь ситуацию, ты мило болтаешь с какой-нибудь девушкой, сидя в небольшой компании, она замечает на твоей руке пластырь. На вопрос: в чем дело и откуда, отшучиваешься - "бандитская пуля". Отходишь за бутылкой или еще за чем. В это время заранее подговоренный приятель вешает ей сказку про суперагентов местного разлива (про тебя!!!), по его виску ползает лазерный прицел. Вернувшись и как бы невзначай заметив это, ты подкрадываешься к окну, задергиваешь штору и как ни в чем не бывало продолжаешь разговор. Девушка реагирует адекватно. При умелом подходе - девяносто процентов, что она твоя. Ингредиенты:


Спецвыпуск Xakep, номер #014, стр. 014-100-3, Кто ходит в гости?..

Кто ходит в гости?..

Kiron R (kirohn@mail.ru)

Спецвыпуск Xakep, номер #014, стр. 014-100-3

пластырь - 10 см., друг-подставник - 1 шт., секретное китайское световое оружие типа указка лазерная - 1шт., товарищ на соседнем дереве (гараже, заборе), который и будет светить - 1 шт., контрацептивы - по усмотрению (лучше побольше).

Висельник

В западлостроительном спецномере Х показывалось, как симулировать повешенье. Договорись с кем-нибудь, он будет повешенным. На вечеринке, где все пьяные (ну, если не пьяные, то подвыпившие), это производит гораздо более сильное впечатление, т.к. народ не сомневается, что либо среди них исламские террористы (это может подтвердить записка на теле), либо повешенный реально (был) пьян. Подергивания ака судороги это подтвердят. Содержание записки на теле: Ля иля иль Аллах, вариант - Аллаху акбар или даже по-русски: умри неверный, Кеша - ты следующий.

Этот трюк делается так: под одежду протягивается ремень (а не веревка) подмышками, с захватом поясного ремня. А под него один ремень через грудь-плечо, так чтобы вид был будто тебя за шею привязали... Грудной пояс - это чтобы одежду не оттопыривало.

Отдельно вяжется "галстук" - веревочная незакрепленная петля с узлом-фиксатором - чтоб не затягивалось больше чем надо. Держущая веревка крепится к плече-грудному ремню с легким захватом "галстука". Разумеется, тебя, как любого уважающего себя висельника, должно перекосить (а как иначе - наверное, видел по телеку) при повисании. Не забудь про слюни (ака пена изо рта) и подергивания (ака судороги). Да и глаза спрячь в брови - это эффектнее.

Тренироваться в присутствии 2 (двух - минимум) сильных людей и то на чучелах.

На утро

Думаю, суть ты уловил. Теперь о тех наворотах, когда все проснутся.

Самый распространенный казус: зайти в ванну, переключить на душ, навести его на себя и уйти. Все, один "умытый" есть.

Мой любимый прикол. Заходит в кухню только что проснувшийся "больной", просит чего-то, рассола наверно. Пробует рассол - а там водка, пробует обычную кипяченую воду из чайника - и там водка, Пробует какое-нибудь "Буратино" - ну тот, что с вечера заныкал, там, конечно, тоже водка, он к крану, воды нет (вентиль, перекрывающий воду, обычно находится под раковиной, да ты и сам уже догадался)... Лепота! При умелом обращении с фотоаппаратом у тебя есть шанс получить компрометирующий суперснимок: твой друг, лакающий из бачка унитаза. Ну, ты когда воду перекрывал, забыл про этот бачок.

Нужно: разбавить водкой все что можно. И заметь, разбавить, а не разлить. Кое-кто еще перца добавляет.

Кровь! Как много в этом звуке... А ведь у тебя остались еще пакетики с краской!!! Заходишь к еще спящим вповалку девушкам, аккуратно так - на цыпочках, и капаешь "кровью" на постельное белье, в районе куда дотянешься. Не волнуйся - эта кровь отстирается. А вот впечатления у проснувшихся девушек, боюсь, останутся навсегда.


Спецвыпуск Xakep, номер #014, стр. 014-100-4, Кто ходит в гости?..

Кто ходит в гости?..

Kiron R (kirohn@mail.ru)

Спецвыпуск Xakep, номер #014, стр. 014-100-4

Как сматывать удочки

Главное - успеть смотаться до начала "разбора полетов" и отклейки обуви от потолка...

Уходи как можно тише. И быстро. И не забудь замести следы. Можно веником, который потом случайно заберешь с собой, - оставшимся будет труднее убираться.

Напоследок подстава хозяина. Презервативы, если останутся, сунь на самое видное место - в мусорное ведро, именно туда заглядывают мнительные предки в первую очередь, когда возвращаются. А следы крови на постели? А мертвый узел на бельевой веревке?

Есть о чем подумать и что обсудить...

А после можно сдать фотопленку в проявку, простирнуть одежду и написать мне, что и почему не получилось. И забыть о той квартире - там еще долго ничего не будет организовываться.

Злаключение

Надеюсь, из этой статьи ты почерпнул не только новые зверства, но и бесценную информацию о том, как от них уберечься. Помни, все, что нужно, у тебя наверняка уже есть, и главное среди этого - твоя богатая фантазия-смекалка.

Напоследок рекомендуемая литература.

Мусульманину о религии. Казань., 85

Хроника серийных убийств. С-П., 97

Кама-Сутра. М., 98 (издание для военных, - с картинками)

Журнал Xakep. Спецвыпуск № 3.

З.Ы. Не пропей свое актерское мастерство.

З.Ы.Ы. Лечу запои. Мылом. Недорого. Kirohn@narod.ru


Спецвыпуск Xakep, номер #014, стр. 014-103-1, Электронная кровь в кремниевых венах

Электронная кровь в кремниевых венах

Спецвыпуск Xakep, номер #014, стр. 014-103-1

Даниил Шеповалов (dan@real.xakep.ru)

"Имидж - ничто, жажда - все!", - именно так звучит известная имиджевая реклама, ориентированная, видимо, исключительно на страдающих от обезвоживания рейверов, часами не отрывающихся от водопроводного крана. Но нам-то с тобой, приятель, ясно, что это полное дерьмо и бессмысленная промывка мозгов. Все в нашей жизни что? Чтооо? Нет, вы, товарищ из первого ряда лучше помолчите. Вот ты, да-да, ты скажи-ка, что в нашей жизни все? Чтоооо??? Так, все заткнулись, придурки, нифига вы не понимаете - лучше я сам скажу. А все в жизни - это любовь! (слышны удары тухлых помидоров и яиц о лицо Дани). То есть, извините, не любовь, а белый лимузин; чемодан, набитый до верху йенами, фунтами и грантами-франклинами; а также силиконовая девочка у тебя на коленях. Или нет - две девочки. И мальчик. И еще маленький ослик в гараже. Ну, в общем, ты понял.

А до вышеупомянутых осликов, девочек и гигабайтов космокредов будет очень трудно добраться, если ты все время шифруешься под последнего обсоса. Конечно, это я сильно сгущаю краски - американская мечта не есть последняя истина и смысл нашей жизни, но тем не менее. Тем не менее в плане того, что грамотно продуманный и спланированный ][-стиль серьезно изменит твою жизнь и сделает ее более яркой и насыщенной.

1. База

Куда ты практически каждый вечер приходишь спать? Куда??? Ннн-нда, дорогой друг, не ожидал. Ну да ладно - положим, ты все-таки приходишь спать домой. Зададимся вопросом: зачем нам еще нужен дом? Тут можно есть, здесь стоит твой любимый компьютер и сюда же обычно приводят девушек, чтобы... ну, допустим, поговорить по душам. (У-ха-ха, а некоторые с мальчиками по душам говорят... или с осликами опять же! - прим. внутреннего голоса). Неважно, не будем тут вдаваться в подробности, кто с кем и о чем разговаривает по душам, наc сейчас интересует другое: как придать своему убогому жилищу неповторимый суперурбанистический ][-стиль? Для этого следует слегка модифицировать твою скромную обитель, а также оборудовать ее рядом фишек, о которых я сейчас преподробнейше растекусь мыслью по целлюлозе.

Среда обитания

Оглянись вокруг - какая куча ненужного хлама тебя окружает! Например, диван. Ну кому в наше время может потребоваться диван? Запомни главное правило безопасности жизнедеятельности: "с пола упасть нельзя!". А вот с дивана как раз можно. Поэтому выкидывай его на помойку (или продай - как раз появятся лишние деньги на новый апгрейд), а поверхность пола застели мягкими приятными ковриками и набросай повсюду маленьких подушек. Пришел ты утром с пьянки - и где упал, там и заснул с чистой совестью. А какие оргии в таком помещении можно устраивать... это просто сказка. Осматриваемся дальше: ага, еще можно выкинуть стулья, стол, музыкальный центр и телевизор. И вместо всего этого барахла купить на толкучке советский ламповый усилитель и ТВ-тюнер. Хорошая звуковуха + мощный усилок заменят тебе дорогущую и массивную стереосистему, а ТВ прикольнее смотреть по монитору. То есть комп по ходу станет основой всей твоей домашней электроники. Ну а кому нужны стол и стулья? Встал ты утром, подполз к компу, включил, вечером выключил, отполз к ближайшей подушке и уснул. По-моему, красотища. Единственное, что стоит оставить в неприкосновенности - это шкаф. В него можно кидать грязные носки, одежду, старые компакты и горы распечаток. Очень полезная вещь! В прихожей на стенах непременно должна присутствовать пара-тройка ультрафиолетовых ламп в сочетании с легким индустриальным беспределом (трубы, блестящие металлические поверхности etc). Также будет прикольно найти на свалке несколько ржавеющих бочек, почистить их, нарисовать нитрокраской знак опасности радиоактивного заражения и написать: "Plutonium waste. Handle with care." Ну а потом ясно поставить в самых неожиданных и прикольных местах. Да, кстати, если у тебя кто из родственников работает в каком-нибудь НИИ, попроси их спереть оттуда небольшой рубиновый лазер. C этим девайсом можно провернуть следующую тему: установить его на полу в коридоре и направить на заранее установленную хитрую систему маленьких зеркал так, чтобы образовалась реальная лазерная сетка. Посетители просто офигеют. В общем, ты врубился в фишку, подобный дизайн твоей лачуги непременно создаст у твоих гостей ощущение футуристического урбана и стопроцентно повысит твой рейтинг продвинутого ][-перца.


Спецвыпуск Xakep, номер #014, стр. 014-103-2, Электронная кровь в кремниевых венах

Электронная кровь в кремниевых венах

Спецвыпуск Xakep, номер #014, стр. 014-103-2

Детектор движения

Логово настоящего Х должно быть всегда защищено от агрессивного вторжения извне. Лучше всего с этой задачей тебе поможет справиться самодельный детектор движения. Поставь около входной двери какую-нибудь дешевую цифровую камеру и подключи ее к компу. А на своем железном друге установи специальный софт, который попиксельно будет искать различие между последовательно идущими кадрами и в случае несовпадения десяти процентов изображения начнет бить тревогу. То есть на незначительные изменения обстановки (шапка с вешалки упала или потемнело из-за наступления ночи) она реагировать не будет, а на резкие переходы тут же начнет ругаться. В принципе, такую прогу самому написать нетрудно, но если тебе нереально лень - покопайся в Сети и выцепи там подобный софт специального назначения. Ты будешь более чем вознагражден за все свои старания. Представь только: приводишь ты домой новую девочку, открываешь дверь, и тут же тебя встречает отдающий металлом приятный женский голос "Сообщение системы безопасности: в секторе семь (входная дверь) замечено движение. Введите голосовой код доступа в течение десяти секунд. В противном случае данный инцидент будет расценен как вторжение, и вы будете подвергнуты термоядерной аннигиляции". Я так полагаю, новая девочка, офигев от твоей крутости, немедленно даст тебе прямо в прихожей...

ASCII/ANSI-обои

Ты наверняка не раз видел красивые ASCII/ANSI-картинки. Например, стильные заставки некоторых BBS'ок или .nfo-файлы с крутыми лого крекерских команд. Ну помнишь, прикольные имаджи, составленные из символов стандартной досовской кодировки. Подобные темы еще были очень популярны в начале 90-х в компьютерно-андеграундной тусовке, когда каждая группа считала делом чести иметь хорошего художника. Так вот, представь, что у тебя вместо тупых цветочно-узорчатых обоев на стенах будут наклеены шедевры подобной графики. Тогда любой перец, зайдя к тебе в гости, сразу просечет, что ты - реальный old scool'ный хакер. Конечно, с подготовкой рисунков придется изрядно повозиться: тебе нужно будет достать требуемый имадж в каком-нибудь графическом формате, разбить его на множество маленьких кусков, а затем уже перевести каждый из этих кусочков в ASCII специальной прогой. Далее придется распечатать все элементы рисунка отдельно и аккуратно расклеить по стенам, чтобы в итоге получилось первоначальное изображение. Ну, или, если ты немереный извращенец, можешь сам все продумать и нарисовать в AciD Draw или любом другом соответствующем редакторе по кускам. Ты только представь, как это будет круто: на одной стене висит двухметровый потрет любимой девушки, составленный из нулей и единиц, а на другой - красочный логотип твоей группы Urban Crew... ну или как там ее...


Спецвыпуск Xakep, номер #014, стр. 014-103-3, Электронная кровь в кремниевых венах

Электронная кровь в кремниевых венах

Спецвыпуск Xakep, номер #014, стр. 014-103-3

Графики жизнедеятельности

Ежедневно в течение нескольких месяцев оценивай различные показатели своей жизнедеятельности: секс, работу, гамерство, учебу и т. д. Допустим, сегодня ты 10 часов безвылазно играл в Quake. Тогда заводишь специальный параметр quake, ставишь сегодняшнее число и аккуратно рисуешь напротив этого параметра десятку. Точно так же поступаешь и со всеми остальными показателями. Ну а в конце месяца рисуешь сравнительный график твоей занятости: дескать, в начале месяца я гамил всего два часа в сутки, а в конце - уже 23 часа, что, скорее всего, связано с внеплановым выходом игры Fallout 3. А потом, ясное дело, красочно оформляешь сие творение и вешаешь его на дверцу шкафа в образцово-показательных целях. Придет к тебе, допустим, подружка и увидит, что график твоей сексуальной активности уже два месяца не поднимается выше нулевой отметки. Ну разве сможет она устоять?

MessageBox()

Повсюду в квартире следует развешать разнообразные мессаги. Например, на двери туалета - "Сделал дело, гуляй смело!", "Отливая улыбнись!" или "Не входить, работают люди!" - и тому подобные темы в самых неожиданных местах. А если умные дяди и тети будут говорить тебе, что это детский сад, юношеское самовыражение и прочее - забей, раз они разучились прикалываться и радоваться жизни, пускай не гундосят. Это клевая развлекуха и отличный способ поднять самому себе и своим гостям настроение, разнообразить нудную и скучную бытовую рутину. Кстати, скоро мы подбросим тебе несколько идей, вложив в журнал подобную наклеечку.

2. Скин

Внешний вид реального ][ очень трудно раз и навсегда четко обозначить. Допустим, лежит у тебя в кармане куча нелегальных приспособлений для фрикинга, CD с базой данных местного отделения милиции и распечатка с сотней логинов и паролей для левого доступа в инет. Я думаю, в этом случае ты не станешь надевать майку с логотипом ][ и вешать на рюкзак компакты с дискетами. А воспользуешься проверенной временем формой одежды "Обсос", дабы тебя случайно не попалили и не лишили свободы на пару-тройку суток "до выяснения". Но, тем не менее, я осмелюсь дать несколько рекомендаций по формированию элитного скина для элитных перцев. Во-первых, снимай нафиг вышеупомянутые дискеты и компакты с рюкзака. Года два назад это было клево, а сейчас подобные фишки вешают все кому не лень, включая самых убогих ламеров. В качестве рюкзака же лучше всего иметь не стандартный бэкпэк вроде Red Fox'а, а какую-нибудь размазанную по спине урбанистическо-незаметную слим-модель, с которой легче убегать от неожиданной погони. Теперь насчет футболок с логотипом ][... Несомненно, таковая должна присутствовать в обязательном порядке. Мне очень часто присылают мыло с требованием выдать по быстрому пару-тройку клевых фраз для публикации на подобной майке. Ок, включаем генератор случайных мыслей:


Спецвыпуск Xakep, номер #014, стр. 014-103-4, Электронная кровь в кремниевых венах

Электронная кровь в кремниевых венах

Спецвыпуск Xakep, номер #014, стр. 014-103-4

"Packman is back!" - такая надпись в комбинации со стилизованной мордой какого-нибудь шустрика из PACKMAN'а сразу придаст тебе вид старого компьютерного волка, который из всех игр признает только тетрис и пакмен.

"Cracked by Bill Gilbert" - и все фанаты ZX Spectrum со слезами счастья на глазах побегут покупать тебе бочонок пива. Проверено! К тому же, ты бы только видел, каким лучезарным светом озаряются их лица при взгляде на эту надпись.

"Держи курс на планету Шелезяка!" - данный слоган выполнен в лучших традициях отечественной шизофрении и моды на сэмплы из старых кино и мультфильмов.

"Взломано в СССР" - без комментариев.

"join #x" - хехе

"mailto:dan@xakep.ru" - аналогично

"Hacking in progress..." - ну это просто классика, к тому же окружающие могут подумать, что ты действительно являешься членом HIP.

"mov ax, 4ch" - и ты старый досовский кодер.

"Save the Яobotz" - и ты автоматом становишься в глазах окружающих электронно-ориентированным компьютерно-андеграундным активистом Mayday.

"www.xakep.ru" - коротко и ясно, да и на самом деле лучше вряд ли чего еще можно придумать ;-)

Вообще, в одежде лучше всего придерживаться минимализма, удобства и ни в коем случае не стремиться подражать всевозможным народным веяниям. То есть, если кто-то заявляет, что "и вообще, сейчас модно рэп, еу!" не стоит тут же бежать надевать широкие штаны и свободный балахон. Если уж ты и хочешь принадлежать к какой-либо субкультуре, то в любом случае следует хоть как-то выделяться среди стандартных ее представителей. Самый лучший скин для Х-перца - герметичный серый (или ядовито-оранжевый :) комбинезон, покрывающий все тело, с кучей тайных карманов и логотипом ][ на спине. В нем ты выживешь не только в железобетонных джунглях, но и в обычных. Ну а если ты стремишься надолго запасть в память окружающих людей, выбрей часть волос на затылке и приклей туда маленькую микросхему (непременно с маркировкой "][-2001MHz"), а также несколько золотых контактов. Киборг в оранжевом комбинезоне - это сильно.

Тут милая извращенка Каролина Брукс (Федя пол поменял) с проколотым языком хочет, чтобы я сказал пару слов насчет телесных модификаций. Ок, говорю: пирсинг моднючие ][-перцы крайне приветствуют, привыкать надо к имплантации железок. Киборги форева! К тому же болтающаяся фенечка ][ в брови- это модно. Аха, это модно. Ёу! Татуировки тоже весьма желательны, однако в разумных количествах, небольшие и стильненькие. Не стоит зафигачивать себе на всю спину громадного цветного дракона с яйцами и в панамке - лучше сбацай на плече маленький логотипчик ][ или опять же клевую фразу набей вроде "Сделано в СССР". Хотя я знал одного товарища - так у него на спине вирус в HEX'е был вытатуирован и смотрелась эта тема крайне стильно.


Спецвыпуск Xakep, номер #014, стр. 014-103-5, Электронная кровь в кремниевых венах

Электронная кровь в кремниевых венах

Спецвыпуск Xakep, номер #014, стр. 014-103-5

3. Боевой комп

А теперь самое время поизвращаться над твоим силиконовым другом. Самый очевидный изврат, который первым приходит в голову - это боевая раскраска. Пусть iMac'и сосут петушки, как говорится. Ясно дело, красить следует не только клавиатуру как в фильме "Хакеры", а системный блок, монитор, принтер и другие выступающие части писюка. И не в цвет хаки - это слишком банально. Возьми, например, баллончики с салатовой, оранжевой и красной красками, закрой глаза и сотвори из своего компа мечту Сальвадора Дали. Или позови приятеля, бывалого бомбера и попроси сбацать у тебя на системнике миниатюрную граффити. Главное, не забудь, что следует быть крайне осторожным в цветном надругательстве над фейсом компа - захочешь ты, например новый дисковод поставить и будет посреди кислотного беспредела зиять белая полоска.

Теперь насчет стилизации внутренностей. Совершенно ясно, что обои, скринсейвер и стартовый имадж в мастдае должны содержать символику ][. Тут никаких вопросов. Другое дело, что эту символику также следует запихать везде где только можно и нельзя. Например, почему иконки на твоем рабочем столе разбросаны в творческом беспорядке? Я уже давно составил из них реальный логотип ][ и мои гости практически всегда обращают на эту тему внимание.

Кстати, а твой комп понимает голосовые команды? Нет? По ходу, приятель, ты конкретно лоханулся (хе, вчера видел рекламу лекарственного препарата "Лохеин"), пора немедленно исправлять сей баг. Срочно ставь программу для распознавания голоса (Dragon Voice или что-нибудь типа того) и тщательно настраивай ее под свой хрип, учи новым командам. Конечно, ресурсов компьютера эта прога жрать будет нереально, но тебе же не круглые сутки ее использовать. Так, подружка придет, и перед ней пару раз выпендриться: "Активировать систему модемной развертки. Установить связь с Интернет..." Хе, повелитель писюка. Да и вообще, прикольно придумать личность твоему компу. Моего, например, зовут Хрюныч, он жрет деньги и ругается матом. Это офигенно клево - самому реально подобрать звуковую реакцию на различные события и потом общаться практически с искусственным интеллектом. Например, Хрюныч, когда я обращаюсь к дискете, тут же издает жуткий чавкающий звук, который заканчивается конкретной отрыжкой. А если начинаю дозваниваться до инета - он похотливо смеется и панибратски шепчет: "Чего, опять на малолеток потянуло?". В общем, очень здорово бывает пустить постороннего человека поработать c Хрюнычем, а самому наблюдать за этим процессом со стороны.


Спецвыпуск Xakep, номер #014, стр. 014-103-6, Электронная кровь в кремниевых венах

Электронная кровь в кремниевых венах

Спецвыпуск Xakep, номер #014, стр. 014-103-6

Так что если в твоих кремниевых венах течет электронная кровь, которая периодически бьет в твой кибернетический мозг, ты просто обязан всем своим видом показывать, что ты - не как все, ты - киборг!


Спецвыпуск Xakep, номер #014, стр. 014-108-1, NMAP - сканер для конкретных пацанов!

NMAP - сканер для конкретных пацанов!

Спецвыпуск Xakep, номер #014, стр. 014-108-1

Иван Назимов aka LonerX (lonerx@phreaker.net)

Who is there?

NMAP - чудо программистской мысли, что появилось на свет благодаря человеку, известному в сетевом мире под ником FYODOR. НМАП представляет собой простую аббревиатуру от Network MAPper. Что же такое кроется за этим простым названием? Постараюсь объяснить. Стоит отметить, что благодаря гадкому редактору, ты не увидел предыдущий абзац, где была отмечена суть - мы имеем дело с первоклассным сканнером портов =).

Как и всякий сетевой сканер, NMAP предназначен для сканирования машин или даже целых сетей на наличие открытых портов (надо сказать, что при обследовании сетей, NMAP, ИМХО, является наиболее быстрым сканером среди известных). Но в отличие от других сканеров, продукт дяди Федора обладает огромным количеством всевозможных наворотов и примочек, которые делают процесс сканирования не тупым стучанием в разные порты удаленной машины, а едва ли не творческим процессом. Одна из самых важных фич сканера - определение операционной системы, под которой работает интересующий тебя комп. Это достигается с помощью технологии определения OS fingerprints (отпечатков пальцев операционной системы). Не буду грузить тебя реализацией вышеотмеченной технологии, но поверь на слово - это очень полезная штука, и иной раз с ее помощью решается до 80% проблем, требующих сканирования (от прощупывания хостингового сервака до определения ОС идиота, который пытается тебя в чате "нючить").

Режим скана

Следующим бесспорным достоинством NMAP является огромное количество режимов сканирования. Что такое режим сканирования, спросишь ты? Отвечаю: режим сканирования - механизм формирования запроса удаленной машине с целью получения какого-либо ответа. Так вот сканер, о котором мы говорим, умеет создавать такие запросы, которые в 90% случаев не оставят следов в логах сканируемых компьютеров. Причем NMAP обладает целой коллекцией подобных режимов, самым известным из которых является, несомненно, TCP SYN-режим. Вдобавок ко всему, сканерюга умеет работать над такими задачами, как определение настроек файерволла, получение инфы о количестве живых хостов в сети, определение broadcast-адресов (незаменимо для любителей smurf-атаки), и т. д.

Заканчивая вступительную хвалебную песнь scanner`у NMAP, можно добавить, что результаты сканирования выдаются в очень читабельной форме. Ты уже понял, что без предложенной тулзы, ты не будешь крут в net-security? Значит, пора перейти непосредственно к получению и установке этой незаменимой боевой утилиты.

Сайт, на котором живет сия программа, называется insecure.org. Поэтому первым делом надо зайти на этот адрес и слить последнюю версию сканера.

Слив

На момент написания статьи, я слил версию 2.54BETA22. Также на сайте лежат скомпилированные бинарники, но так как мы занимается серьезным делом, то скачивать будем именно исходники, которые лежат с расширением tgz. В эти исходники включена прога nmapFE (FE=Front End), которая придает сканеру т. н. "дружественный интерфейс" в среде X-Windows.

Итак, мы скачали исходники. Можно было бы сразу развернуть боевые действия, но я предложу чуточку RTFM`ной инфы "для самых маленьких" :). Пора разжать полученный арх. Достигается это командой


Спецвыпуск Xakep, номер #014, стр. 014-108-2, NMAP - сканер для конкретных пацанов!

NMAP - сканер для конкретных пацанов!

Спецвыпуск Xakep, номер #014, стр. 014-108-2

gzip -cd nmap-VERSION.tgz | tar xvf - (nmap-VERSION.tgz,-имя закачанного архива, которое, естественно, разнится в зависимости от версии).

После переходим в новообразованную директорию с помощью команды

cd nmap-VERSION

Итак, пришла пора сконфигурировать, скомпилировать и установить программу. Это можно сделать, введя последовательно нижеследующие команды. Перед установой не забудь переключиться в режим суперпользователя, если есть такая возможность, т. к. обычному юзеру системы могут быть недоступны ряд фич (корректная установка, в первую очередь =)). Я буду описывать процесс работы из-под r00t-прав ;).

./configure

make

make install

Во время компиляции может появиться некоторое количество сообщений об ошибках. Обращать на это внимание не стоит, так как эти ошибки связаны с прогой nmapFE.

Три, два, один - СПУСК!

Готово? Великолепно! Теперь приступим к изучению работы со сканером. Общий формат запуска сканера выглядит следующим образом: nmap [режим сканирования] [опции сканирования] [адрес/сеть/маска сети].

Рассмотрим каждую составляющую по порядку. Повторюсь, что работать со сканером лучше всего с правами суперпользователя, так как некоторые (самые вкусные) режимы сканирования требуют наличия рутовских полномочий.

Итак, на первом месте стоит определение режимов сканирования. Как я уже говорил, самым популярным и часто используемым является режим TCP SYN. Задается он как -sS. Можно задать и другие режимы сканирования (или комбинацию таковых). Например, для совсем уж скрытого сканирования (или при желании пролезть через отсекающий SYN, файерволл) можно использовать режимы -sF (Stealth FIN), -sX (Xmas Tree) и (или) -sN (Null). Эти моды логируются еще реже, чем TCP SYN. Иногда появляется необходимость просто определить количество живых машин в сети. Это достигается с помощью режима -sP. Причем здесь тоже все непросто. Некоторые хосты (по типу microsoft.com) не отвечают на прямые ICMP запросы. NMAP же по умолчанию посылает запрос на 80 порт хоста и, сравнивая результаты, делает вывод - жив хост или нет. Это называется "параллельным пингом". Остальные режимы в статье рассматривать смысла не имеет, так что при нужде можно прочесть мануалку к сканеру, там все подробно описано (man nmap).

Далее идут опции... По идее, они не обязательны, но использование некоторых из них существенно облегчает жизнь. Вот наиболее используемые:

-P0 - Не пинговать хост перед сканированием. Полезно в случаях, аналогичных microsoft.com, когда ICMP-запросы просто-напросто игнорируются сервером.

-O - Аплодисменты, господа! Именно эта опция позволяет задействовать систему определения OS fingerprints, о которой я говорил выше. Всегда полезно знать, на какой оси работает потенциальный враг или жертва.

-v - Вербализация. Очень полезная штука - выдает гораздо больше информации о том, что было обнаружено при сканировании. Если эту опцию влепить дважды - эффект удваивается :).


Спецвыпуск Xakep, номер #014, стр. 014-108-3, NMAP - сканер для конкретных пацанов!

NMAP - сканер для конкретных пацанов!

Спецвыпуск Xakep, номер #014, стр. 014-108-3

-o <имя файла> - Позволяет задать имя файла, куда будут записаны результаты сканирования. Очень рекомендую, так как во время сканирования можно пойти попить кофе, а потом спокойно и с расстановкой изучать логи. Опция незаменима при сканировании больших диапазонов IP-адресов. В случае сканирования с удалённой машины, будет удобно снять результаты после покидания сканера в бэкграунде.

-p <порт/порты> - Опция, с помощью которой можно задавать конкретный номер сканируемого порта или же диапазон портов. Например, -p 23, -p 1-105 и так далее. По умолчанию просматривается диапазон с первого по 1024 порт, включая порты т. н. "известных сервисов", которые прописаны в файле, включенном в дистрибутив сканера.

-F - Тоже достаточно полезная штука. При сканировании рассматриваются только те порты, которые внесены в вышеупомянутый список "известных сервисов". Эта опция существенно ускоряет процесс сканирования.

Ну, пожалуй, об опциях сканирования сказано достаточно. Пора перейти к тому, как же задать сканеру инструкцию о том, какие адреса (или адрес) нас интересуют. Система задачи адреса (адресов) для сканирования в NMAP очень гибка, и поэтому рассмотрим ее подробнее.

Всё что не доделал Мамай!

Все, что не является опцией или аргументом, NMAP воспринимает как адрес жертвы. Самым простым способом является прямое задание адреса или имени хоста (или нескольких имен/адресов) в командной строке. При желании просканировать сабнет можно использовать маску, которую надо добавить к адресу, отделив ее слэшем (/). Напоминаю, что для сетей класса С используется маска /24; для сетей класса В маска /16 и для всего Интернета используется маска /0. Так же в NMAP предусмотрены различные способы задачи адресов, подразумевающие использование диапазонов, перечисления компонентов адреса, использование специальных символов. Для наглядности приведу несколько примеров инструкции на сканирование подсети класса В (все примеры АНАЛОГИЧНЫ, просто записаны по разному).

192.168.*.*

192.168.0-255.0-255

192.168.1-50,51-255.1,2,3,4,5-255

192.168.0.0/16

Как видно из примеров, с определением адресного пространства для сканирования можно изгаляться сколько душе угодно.

Ну вот! Основные параметры, которые могут пригодиться при запуске NMAP, описаны, перейдем к примерам.

Примерный сканер

nmap -sS -O victim.com

Пример стандартного сканирования одного хоста, с определением версии операционной системы.

nmap -sS -O -v -o victim.log victim.com

То же самое, только с повышенной вербализацией и записью в лог файл.

nmap -sS -O -p0 microsoft.com/24

Сканирование подсети класса С, в которой находится хост мелкософта. При этом хосты предварительно не пингуются.

nmap -sS -0 -p 80 *.*.5.10-15

Прекрасный пример использования гибкости системы задачи адресов. Попытайся понять сам, какие адреса будут просканированы в результате исполнения такой команды (надеюсь, то, что будет сканироваться только порт 80, ты уже заметил).

Ну вот, в общем-то, и все... Желаю успехов в освоении этого достаточно сложного, но, тем не менее, сверхмощного сканера. Если что - пиши. Только, чур, без вопросов типа "а как мне установить юних, для того чтобы сей рульный сканер поюзать" =).


Спецвыпуск Xakep, номер #014, стр. 014-110-1, Шары в Х-стиле, или Legion по-русски

Шары в Х-стиле, или Legion по-русски

Спецвыпуск Xakep, номер #014, стр. 014-110-1

Вадим Марков aka xPoison (root@irctoolz.com), http://irctoolz.com

"Всем известны возможности ОС Windows 95 по созданию одноранговой локальной сети, позволяющие легко организовать совместное использование дисков и принтеров внутри рабочей группы. Однако лишь немногие знают о том, что эти возможности доступны и в сети Internet."

(c) 1996 Тодд Танненбаум - Network Computing.

Так как же проникают на чужие винты?

Сейчас речь пойдет снова о шарах. Говоря языком продвинутых кодеров, в контексте windows, шарами мы называем сервисы, висящие на 137-139 портах и предоставляющие юзерам возможность совместного доступа к дискам, папкам и файлам. Естественно, доступ к чужим disc`ам и файликам может быть использован не только обычным юзарем, но и хакером. Подобные идеи витали в воздухе с незапамятных времен и постепенно воплощались в таких культовых прогах, как "Legion" и "Essential Net Tools". На дворе Y2K+1 (очередной Санта-Клаус загнулся от холода), а мы рассматриваем продолжение линейки сканеров - xSHaReZ. Это фирменный релиз Х, о выходе которого ты мог прочитать в прошлом номере.

Итак, для самых маленьких, что же такое shared-ресурсы на практике? У-у-у... а ведь этот вопрос уже давно крутится в твоем незамутненном пивом мозгу? Что потребуется желающему для получения практических знаний в области share: взять пива, достать 2-3 часа доступа в Инет, а затем закачать последнюю версию xSharez с паги Х-релизов - www.xakep.ru/articles/releases. Для закрепления теоретических знаний надобно заползти в поисковик и слить найденную инфу по вопросу шаров (shares, netbios, разделяемые ресурсы, 139 порт и т.д.).

Практические занятия по поиску ламера в Инете

Поехали... Теперь мы попытаемся получить знание о том, как это юзается в Интернете. Все настройки будут рассмотрены для семейства операционных систем под кодовым названием "мастдайка" (aka Windows 95/98), ибо на данный момент они имеют наибольшее распространение у твоих потенциальных жертв.

Предположим, что в твоей конфигурации Windows 95/98 установлен стек TCP/IP, а твой комп подключен к Internet через высокоскоростной мопед. Теперь необходимо произвести следующие манипуляции: установить "Клиент для сетей Microsoft" и "Службу доступа к файлам и принтерам сетей Microsoft". Если ты в локалке с сетевой картой и модемом, и эти службы уже установлены, то стоит проверить, чтобы они были привязаны к модемному интерфейсу. Установка и привязка делаются в "Свойствах сети", в "Панели управления". Я даже не поленился и сделал 2 скрина, изображающих настройки сети на моей домашней тачке (вне работы - я заядлый диалапщик), вот один из скринов:

Для особо талантливых красными точками помечены сетевые компоненты, которые необходимо установить. После изменения каких-либо параметров система попросит ребутнуться, можно соглашаться - это не опасно.

На фиг это все? Дело в том, что у потенциальных жертв такие настройки уже сделаны (это и было их главной ошибкой, если не считать появления на свет), и для того чтобы ваши компы подружились и вообще поняли друг дружку, как раз пришлось так напрячься.


Спецвыпуск Xakep, номер #014, стр. 014-110-2, Шары в Х-стиле, или Legion по-русски

Шары в Х-стиле, или Legion по-русски

Спецвыпуск Xakep, номер #014, стр. 014-110-2

Полдела сделано, осталось заставить Windows запускать эти службы при выходе в Интернет, это делается одним волшебным движением: заходим в свойства диалап соединения, выбираем закладку "Тип сервера" и ставим жирную галку "Войти в сеть". Эти же манипуляции проделал и я, чтобы порадовать тебя расположенной ниже картинкой.

Теперь при каждом удачном коннекте на твоем компе будут запускаться указанные выше сетевые службы, а также комп будет присваивать себе NetBIOS имя, например, "VASYA", "PUPKIN", "LAM3R" и т.д. Имя ты выбирал себе при установке мастдайки, и можешь изменить в любое время на закладке "Идентификация" в свойствах сети. Кстати сказать, если при установке операционки Виндос владелец компа ничего не выбирал, а щелкал грызуном от балды, то имя его компа будет - "OEMCOMPUTER". Это верный признак высококачественного ламера, которых в Интернете гнездится довольно много: процентов 10-15 от всей "шаровой" тусы,обнаруженной мной.

И вот начинается бой!

Ну что же, вся предвариловка завершена, и твоя операционка теперь вполне сгодится для проведения широкомасштабных атак на толпы ламерюг, населяющих просторы Интернета.

Теперь есть возможность натянуть Васю Пупкина, по IP которого расположены шары. Я заочно представляю, как ты ломишься к своей тачке в надежде поиметь Васю Пупкина. Но... Обломись: Василия уже хакнули. Да и захват диска на первом попавшемся IP может сложиться только при очень большом везении. Посуди сам: далеко не на каждом айпи висит диалапщик, далеко не каждый диалапщик вот так вот просто возьмет и установит необходимые службы, и откроет тебе доступ к своим дискам. В 9* виндах это в состоянии сделать только отборные чайники (с NT ситуация несколько лучше, но сама ось менее распространена среди интересующих нас ребят), каковых, к сожалению, очень мало.

Незаметно мы подошли к цели этой статьи - описанию небольшой программки, которая будет терпеливо перебирать IP адреса и сама отыскивать открытые ресурсы, которые ты сможешь потом использовать по своему усмотрению.

Тулзенка зовется xSHaReZ scanner, самую свежую версию ты можешь найти на паге Х-релизов: www.xakep.ru/articles/releases.

Рекомендуемый прядок действий таков: выбирается диапазон IP (для начала можно пощупать пользователей собственного прова), потом нажимается кнопа "Скан", прога сворачивается, а ты продолжаешь заниматься своими любимыми тусовками в ирцке на irc.dal.net #xakep =). В какой-то момент IRC все-таки надоест, и ты вспомнишь, что что-то там сканил. Развернув программулину, не без удивления ты, очевидно, обнаружишь несколько компов с расшаренными ресурсами. "Вот это удача!" - появятся стандартные положительные эмоции :). Пальчик, уже не стесняясь, тыкает в первый попавшийся диск.

Берем в рабство ламера

Мастдайка радостно плюется своим стандартным диалогом подключения ресурсов. И единственным легким движением ты становишься обладателем еще одного сетевого диска =). Правда, не всегда все проходит так гладко: запросто может выскочить второй диалог и потребовать пароль =(. Но тут главное не теряться, а настырно жать "о'кей" второй раз. Юзер мог закрыть паролем полный доступ к диску, а "только для чтения" оставить без пароля.


Спецвыпуск Xakep, номер #014, стр. 014-110-3, Шары в Х-стиле, или Legion по-русски

Шары в Х-стиле, или Legion по-русски

Спецвыпуск Xakep, номер #014, стр. 014-110-3

Дело сделано, дальнейшие действия ограниченны только фантазией... Для скачиваний-закачиваний и прочих магических операций я категорически не рекомендую использовать Explorer ("Проводник", типа) и прочие тулзены, имеющие привычку отображать каталоги в виде дерева и рисовать пиктограммы к разным типам файлов. Они будут сильно тормозить весь процесс. А, кроме того, в случае, если "партнер" по ту сторону Интернета вдруг очнется и, от греха подальше, решит вырубить модем, то вся система просто подвиснет на довольно-таки продолжительное время. В свете этого оптимальным вариантом окажется FAR manager или любая другая NC-подобная прога, позволяющая вводить команды MS-DOS. Хотя особых траблов при обрыве не вызывает и народнолюбимый Windows comander.

В FAR`e же процесс выкачивания *.pwl будет выглядеть так: жмется alt+F2, переключается на подключенный сетевой диск (пусть это будет "Z:"), и сразу же видно, где там прячется Windows ("z:\windows"). Далее выкачиваются все интересные файлы - *.pwl (классика), uin.dat (асю снова трахнули), *.ini из папки IRC-клиента (пароли, запрятанные в скриптах, настройки на редирект серверы, соксы и прочее). Да и много чего еще можно стянуть другого: фантазии нет границ :).

Удачи тебе в хаке! Целуй маму, поливай фикус...

врезки

1

Что ты можешь получить,

грамотно юзая эту прогу

Чужие диалап и почтовые пароли - это 100%. Не исключено, что это будут пароли перцев, тупо гоняющих траффик на твоем же провайдере.

Пароли к более или менее симпатичным ICQ уинам, если атакуемый вдруг юзает аську.

Пароли к IRC никам и каналам - ведь ты, как и любой кул-хацкер, зависаешь в ирке каждый день.

Различную инфу, лежащую на винте у атакуемого, - да что там говорить: ВСЮ инфу, хранящуюся на винте у жертвы.

Лишение свободы на срок до 2 лет по статье 272 (неправомерный доступ к компьютерной информации) - не грейся, это маловероятно.


Спецвыпуск Xakep, номер #014, стр. 014-117-1, АОН мой - враг мой!

АОН мой - враг мой!

Зомбируем вражескую технику

Спецвыпуск Xakep, номер #014, стр. 014-117-1

Dronich (dronich@fbi.ru)

Дарова, хацкер. Сразу вопрос в лоб - АОН у тебя есть? Ну, понятно, что встроен в момед или АСID какой-нибудь стоит. А о простых смертных ты подумал? Да, есть еще на свете люди, не испорченные сетью. И АОНы у них тоже есть. В телефон они встроены. Российская разработка, "Русь". "Ну а мне до них чего?" - спросишь ты меня. Ну, братец, есть одна оказия (с) Pushkin. Но давай по порядку.

Что там есть для нас

Как ты, наверное, знаешь, в АОНах этих - туева хуча настроек, не востребованных "рядовым пользователем". А среди них - дистанционное управление. Чуешь, к чему я клоню? Ну, прикинь, если бы в Винды встроили ВО? Вот и я говорю, что круто. Но не все так просто. Во-первых, по дефолту ДУ почти всегда отключено. Во-вторых, наши наклепали разные версии АОНов, и управление в них различается. Озадачил? Ладно, поговорим о том, как эти проблемы преодолевать. У первой - море вариантов решения. Но все они сводятся к тому, что надо набрать (заставить набрать ;)) следующую последовательность кнопок - ** 3 8 - и далее жмакать * - пока на АОНе не высветится "bEEPr.-OFF" или "b.-OFF". Ну а дальше дело техники: 1 - вкл., 0 - выкл. и # для возврата в основной режим. А версия АОНа всегда написана на его крышке. Усе. Считаем, что серверная часть ;) настроена.

Поговорим теперь о клиентской. Таковой является ЛЮБОЙ кнопочный телефон с возможностью тонового набора. Управление осуществляется следующим образом:

1. Позвонить на требуемый аппарат.

2. Переключиться в тональный режим.

3. Во время приблизительно середины длинного гудка нажать и держать 1,5-2 секунды 1 или 0 (потом объясню, что для чего).

4. Если АОН ответит громким и противным пиликаньем, то он готов к насилию над собой :).

Команды

При входе по 0:

1 - выбор режима работы

4 - установка даты/времени

5 - работа с будильниками ;)

9 - записная книжка

7/8/* - прослушивание входящих/исходящих/ за день звонков

При входе по 1:

4 - полная переадресация (набираешь телефон - 7 цифр и время - 2)

5/6 - переадресация только по времени/номеру

По поводу переадресаций - если она установлена, то всех, кто позвонит после тебя, гнусавый голос попросит перезвонить [тогда-то] [туда-то].

Практикум

Я думаю, что прослушивание звонков ты быстро освоишь :), а вот по будильникам и записной книжке дам бесплатную справку.

Пример из жизни №1: поможем товарищу встать в 5 утра ;)

1. Входим в режим работы с будильниками (см. выше)

2. 1 - выбрали номер будильника (любой) * - дальше

3. 0 5 0 0 - ввели время

4. 4 0 - выбрали режим (ежедневно и до упора :)) * - дальше

5. 1 6 - ввели номер мелодии (гимн СССР :))

6. # - выход и разрыв связи

Пример из жизни №2: меняем номер без BlueBox

В работе с записной книжкой многое зависит от модели. Поэтому договоримся - то, что в скобках, - для 23 модели, остальное - для 24-й и 25-й.

1. Входим в записную книжку (см. выше)

2. 6 - переход в служебную область (0 - задание номера ячейки)

3. 9 - повторить 17 раз для перехода в нужную ячейку (7 0 - переход в ячейку)

4. 5 ХХХХХХХ # - ввод номера (своего)

Здесь возможен глюк и отключение от линии. Если это произойдет, просто перезвони и заново войди в записную книжку и продолжай работу. То, что в квадратных скобках, надо набирать, если тебя отключило от линии.


Спецвыпуск Xakep, номер #014, стр. 014-117-2, АОН мой - враг мой!

АОН мой - враг мой!

Зомбируем вражескую технику

Спецвыпуск Xakep, номер #014, стр. 014-117-2

5. [6 - для входа в служебную область] (0 - задание номера ячейки)

6. 9 - 9 раз [или 26 раз :), если отключало] для перехода в нужную ячейку (8 0 - переход в ячейку)

7. 5 YYYYYYY # - ввод номера (для подмены)

8. # - разрыв связи

Повторять это можно многократно, меняя номера телефонов и ячеек (т.е. в первом случае вместо 17-и жать девятку 18, 19 и т.д. раз, а во втором - менять последние цифры 70 и 80 на 71 и 81 соответственно).

В отрыв

Ну что, инструктаж пройден, вперед - на очередное западло. Идей уже много - проверить, кто и когда звонил твоей девчонке, не дать преподу выспаться перед экзаменом и т.д. и т.п. Удачи тебе, хацкер, а я пойду. Очень хочется телефон одного товарища проверить на готовность к 3000 году :).


Спецвыпуск Xakep, номер #014, стр. 014-119-1, Оборонный комплекс PGP!

Оборонный комплекс PGP!

God in the shell (faq@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-119-1

Вот уж, пожалуй, реально хитовый образец софта, столь актуального нашему журналу. Сегодня мы поговорим о его свежайшей free-вариации PGP 7.0. Подробно растолкуем новые фичи, их полезность и настройку, применим узнанное на практике :).

В путь

Предварительно, как водится, надобно сдуть прогу с Инета. Делаем это по линку с сайта http://pgp2all.org.ru/, где ты также сможешь прочесть массу полезных материалов по теме.

Дистриб занимает порядка 8,5 мегов, и на диалапе скачивается меньше, чем за час. Я не даю линка на официальный сайт www.pgp.com, т. к. на момент написания статьи там валялась только платная версия, а для халявной скачки предлагалось старьё, для получения которого пришлось ещё и форму заполнять =(.

Поставь её в позу!

Итак, вся нужная байда закачана, приступаем к установке в позу... э-э-э, Installed :). Хотя и не хацкерское это дело обсуждать процесс инсталла. Если бы не одно "но", вынесенное для юзверей предыдущих версий ПГП. К этим самым "предыдущим" юзверям относился и я на момент первого инсталла 7-й версии PGP. Так что прямо с инсталляшки тебе предложат удалить предыдущий ПГП 6.X автоматически, или оставить это дело твоим загребущим ручкам. В случае выбора второго варианта инсталл прервётся. Следует предупредить, что были проблемы такого характера. ПГП выносил свою предыдущую версию, а при установке новой генерились многочисленные ошибки :(. Так что желательно иметь при себе и предыдущую версию дистрибутива PGP.

Лично я, под воздействием всяких локальных суеверий, слил содержимое моего PGP-диска и ключницы для мыльника на отдельный CDRW ;). Но, как оказалось, с моим диском "y0_niggaz pgp" ничего не случилось: после установки 7-й версии мне предложили переформатить диск в стандарт новой версии. Усё прошло успешно, и после ребута я уже вовсю юзал ресурсы, установленные на шифровике.

Итак, PGP-диск создан.

Туда следует покидать всю инфу, которая каким-либо образом может быть направлена против тебя: Аська со всеми её хисторями и Received files`ами, IRC клиент или папка его логов, если ты ведёшь стенограмму собственных базаров на ИРКе :), почтовик с письмами сомнительного содержания, не менее сомнительным аттачментом и почтовой книгой... Ну и, конечно же, следует подальше от любопытных глаз спрятать весь хакерско-хацкерский софт, как то: бэкдоры, сканнеры сетей, снифферы, проги для спама, телнет/ssh с кэшированными пассами от фрауднутых или нелигитимного происхождения, шеллов :), etc. Не забудь и про инфо "специального" содержания: доки по хаку, pwd/sam-файлы, стыренные базы данных СС и паролей на dial-up, перехваченные конфигурационные файлы httpd, ftpd, telnetd, eggdrop`ы и другие... В общем, всё, что может вызывать подозрение, запихиваем в ПГП-диск!

Если у тебя постоянно включён комп, и ты не работаешь в NT, или, работая в оной, не лочишь комп - удобно включить опцию автоматического Unmount`a aka "закрытия" диска после определённого времени бездействия.

Стань крутым, с PGP!

Главным достоинством нового ПГП, которого не было в предыдущих версиях, стал встроенный фаервол. Теперь не надо геморроиться над тем, что @guard не пашет в 2000-х, Conseal не работает на диалапе и т. д.


Спецвыпуск Xakep, номер #014, стр. 014-119-2, Оборонный комплекс PGP!

Оборонный комплекс PGP!

God in the shell (faq@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-119-2

В трее, как и прежде, появился значок конфигуратора PGP. Только если раньше он появлялся исключительно для того, чтобы ты его удалил, теперь польза будет ощутима! Короче, отжимаешь пимпу в трее и выскакивает нечто очень полезное и юзабельное.

Рассматриваемый файрвол очень симпатичен позаимствованным из *nix`a принципом: что не разрешено, то запрещено! Так что PGPnet не даст просто так пролезть в твой комп, выйти в Инет троянцу или позволить атаковать твой хост.

Так, ты можешь создавать свои виртуальные сети, то есть объединять в единое кольцо безопасности определённые компы/сети.

Это удобно если к твоей машине получают доступ с работы/учёбы или из дома. Так, быстренько объединил институтскую тачку, где хранится учебный архив, с домашней станцией и рабочим компом в офисе!

Но построенная сеть не позволит проникнуть к тебе, даже если кто-то получил доступ к одной из твоих тачек: PGP потребует идентификации личным ключом, коего у злоумышленника, скорее всего, не окажется.

Итак, после обозначения твоих приоритетов, ты становишься как бы мембером сети, в которой установлены доверительные отношения между всеми её частями.

Имеется очень полезная закладочка Intruders, что дословно обозначает "Незваные гости".

Сюда ты будешь загонять разные нехорошие хосты, с которых тебя пытались атаковать. Можно вообще поставить блок таким образом, что твой комп не будет отвечать на направленные провокации, полностью их игнорируя, или отделить себя от нечисти на некоторое время (20 минут, по умолчанию).

По атакующему можно провести trace, узнать NetBios имя, DNS запись, и прочую шнягу, которая позволит тебе выявлять потенциальные места, откуда могут атаковать. Если в тебе скрывается Павлик Морозов, то можно было бы актвизировать опцию извещения саппорта/abuse`a твоего ISP, о произведённой на тебя атаке.

Все операции PGP net можно будет отследить по вполне сносной системе логгирования.

Уделяя внимание VPN`у, я практически забыл об основной, нужной опции для домашнего пользователя - Personal Firewall`е. Всё больше и больше людей, компетентных в WIN-security, отдают предпочтение именно этому агрегату, если требуется обеспечить защиту домашнему компу.

Имеются достаточно грамотные "Настройки по умолчанию", хотя это и хацкерский способ: мы выберем Custom и настроим всю систему исключительно под собственные уникальные нужды :)

Настройка практически не вызывает проблем. Свежеустановленный защитный комплекс конфигурируется за 10 минут.

Святая святых...

Не рассказать о самой главной фиче - шифровике PGP, основанном на технологии открытого ключа, было бы неправильным.

Тыкаем всё в то же окошко, расположенное в трее. Если у тебя уже есть свой "приватный" ключик - просто добавляешь его в список своих личных ключей, также импортируешь, если были, старые наборы открытых ключей.

А коли ты только познакомился с чудесной фичей ПГП, генеришь себе свой личный key.


Спецвыпуск Xakep, номер #014, стр. 014-119-3, Оборонный комплекс PGP!

Оборонный комплекс PGP!

God in the shell (faq@xakep.ru)

Спецвыпуск Xakep, номер #014, стр. 014-119-3

Теперь у тебя есть два ключа: один спрячь подальше - он только для тебя, второй разошли друзьям, выложи на LDAP сервер проекта PGP (опция загрузки встроена) или на пагу русского ПГП, урл которой находится в начале статьи.

Сейчас все серьёзные люди/компании вывешивают свои открытые ключи, чтобы ими могли воспользоваться те, кто хочет передать тебе приватную, а то и секретную инфу...

Самое популярное место для применения ПГП - е-майл. Большинство современных почтовиков имеют поддержку шифрования PGP.

Например, наш любимый The Bat (www.thebat.net) работает с этой штукой практически со своих первых версий.

Ты просто пишешь секретное письмо, выбираешь опцию "Зашифровать/Decrypt", подбираешь нужный открытый ключик, и отправляешь письмо хозяину ключа.

ПГП также прекрасно работает с самыми обычными текстовыми файлами, также может обрабатывать отправляемые фразы в IRC.

Раньше приходилось шифровать clipboard, чтобы кинуть секретную мессагу по ICQ. К сожалению, эту опцию я тестануть не смог, т. к. на момент написания статьи не поддерживался мой билд ICQ 2000b.

Короче, иметь!

Я думаю не стоит напоминать про вездесущий СОРМ, и о примитивной админовской любознательности, которые могут стать причиной доступа к твоей инфе. Большинство людей игнорируют возможность своей "прослушки". Люди отмазываются тем, что якобы они никому не нужны. И это правда. Но вот только не все одинаково "ненужные". Так что, тебе особенно, следует позаботиться о конфиденциальности.

SINtez назвал бы людей, активно борющихся за свою privacy, параноиками :). А что, я вот лично, параноик, и этого не стесняюсь, PGP мне помогает в этом :).