Спецвыпуск Xakep, Содержание номера # 012

Cover 012 |
Статья | Стр.
Винчестеры к бою! | 005
Баги кривых рук | 008
Маленькие хитрости продавцов железа | 010
Возьми свое «добро» назад | 012
Комплектация оборудования, или упаковка подарков | 014
Три идиота и компьютер | 016
Проявка на халяву, или цифровухи против мыльниц | 020
Х - конкурс! | 025
Digital ElectronicZ: основы | 026
Фишки | 028
Клава компьютерная, не резиновая | 032
Мышь белая, компьютерная | 034
Какой принтер тебе нужен? Обзор принтеров | 036
Не пялься в Монику, или выбираем крутой монитор | 040
Лего для взрослых. Апгрейд компа - общие принципы | 046
Как я собираю комп | 049
Оптимизация BIOS | 052
Игрища с комповой жопой | 054
Компьютер в твоем кармане | 058
Вкусная картинка: видюхи под микроскопом | 062
Данные вне компьютера | 066
Лазерные блинчики | 070
Твердое и мягкое: стандарты и проблемы | 072
Монстер саунд | 074
Рабочее место для хаксора | 078
Обзор компьютерных колонок | 080
Операция "Железяка" | 084
Программы для управления железом | 086
Магазин на диване | 090
Обзор книжек по железу | 092
RAID - добро пожаловать на кластер | 094
А связь у меня никогда не обры%^NO CARRIER | 098
Куда засунуть одноглазого? | 100
Какой сканер тебе нужен? Устройство сканера | 102
СПЕЦ-crew насилует виртуальную реальность | 105
Ржавые паги: обзор сайтов по железу | 108
HARD-FAQ | 113
Анкета | 124
Made by Vasiliy Pupkin | 125


Спецвыпуск Xakep, номер #012, стр. 012-005-1, Винчестеры к бою!

Винчестеры к бою!

Спецвыпуск Xakep, номер #012, стр. 012-005-1

Andrew Fadeev (andrewf@farlep.net)

В каком месте у меня жужжит?

Привет, читатель! Жужжит твой компьютер? Особенно когда подгружает что-то? Это жесткий диск жужжит. Оплот твоей хакерской деятельности. Десять гигов порнухи, плюс еще десять с базами кредиток. Да, без харда компьютер сейчас представить сложно. А когда-то...

Жили-были - винты мутили

Ага. Сейчас будет урок истории. Без нее никуда, надо знать истоки. Детки, сядьте, отключите звуковые сигналы ваших мобильных телефонов, любая видео- и фото-съемка в зале запрещена. Итак, винчестер - девайс, появившийся в мире компьютеров далеко не первым. Пока он рождался в муках, первые компьютеры уже долго служили обогревателями в больших залах. Но проблема, куда девать награбленное, бодро стояла уже тогда.

Старшие гуру-программисты, лиц которых уже давно не видно в зарослях диких бород, еще помнят огромные стопки перфокарт (таких листочков с дырочками) и рулоны бумажных лент (прикинь, как нас пронесло!).

Позже появились магнитные ленты, барабаны и даже (!) дискеты. Потом появились монстрики, которых при желании можно назвать дедушками жестких дисков. Эти чудища употреблялись в дело пакетами по несколько штук. Размеры такого пакета были слоноподобны, а емкость - очень невелика. Вдобавок ко всем бедам, магнитные поверхности были не защищены от пыли и хакеров с топорами. И тут (пам-пам-парам!) в начале 70-х годов супер-мега-лидер компьютерного рынка того времени - компания IBM - разработала первый прототип современного жесткого диска. Спецы из АйБиЭм попытались увеличить плотность записи на единицу поверхности, а для того, чтобы это получилось, заключили сам диск в герметичный корпус. Сие было огромное 14-дюймовое устройство, на которое влезало 30 мегабайт информации на каждой стороне единственного диска. Вот так за жесткими дисками и закрепилось название "винчестер". Фишка в том, что емкость девайса 30/30 напомнила американцам название популярнейшей двустволки фирмы Winchester. Первый серийный накопитель, с названием 3340, спродуцировала та же IBM в 1973 году. Он имел емкость целых 140 мегабайт и стоил (лучше сядь поудобнее) восемь тысяч (угу, 8000) вечнозеленых долларов.

Ясное дело, что с такой ценой новорожденный предназначался для использования в крупных вычислительных центрах. Прошли годы, винчестеры стали меньше по размеру и больше по объему вмещаемой информации, но принцип их работы остался практически таким же, как и у "30/30".

Диск внутри, мы снаружи. Взгляд внутрь

Как же выглядит наш герой? Раньше контроллер и сам диск были одним целым. Но сейчас жесткий диск подключается кабелем к контроллеру на материнской плате. Еще есть внешние диски, но это тааакие тормозааа... Хотя, недавно вот появился внешний хард под названием ZiV (не путать с Zip) – подрубается через USB, умеет гонять 6 мегабайт в секунду. Вот это – уже что-то.

Ну ладно, мы отвлеклись. Самым заметным параметром внутреннего диска является форм-фактор. То есть, длина, ширина и высота корпуса. Все это зависит от диаметра самих дисков (или как их еще называют пластин, или блинов). Стандартное значение - 8 дюймов. Такие диски использовались в ЭВМ 80-х годов. Сейчас их можно найти разве что в музее достижений компьютерного хозяйства или на свалке какого-нибудь института. Ими хорошо мышцу качать - штанги и гири отдыхают.


Спецвыпуск Xakep, номер #012, стр. 012-005-2, Винчестеры к бою!

Винчестеры к бою!

Спецвыпуск Xakep, номер #012, стр. 012-005-2

Далее - 5,25 дюймов. Они еще в ходу, хотя они и большие (Quantum'овские так и назывались - BigFoot). Ну и, конечно, самые массовые - 3,5 дюйма. Такой, скорее всего, и жужжит в твоем компе. Еще есть карлсоны на 2,5 дюйма. Живут в ноутбуках. Высота винта зависит от количества используемых пластин. Для уменьшения высоты и повышения других характеристик внешние поверхности пластин не используют. Существуют промышленные стандарты в миллиметрах, но нам они неинтересны. На бытовом уровне высота измеряется в отсеках (тех, которые на морде компьютера). Например, 3,5х2, значит, что диск высотой в два 3,5 дюймовых отсека.

Железная логика

Все слышали, что винты логически форматируют, делят и прочее. Что же это за логика такая? Разберемся! Логика жесткого диска - это то, что, как бы, есть, но чего, как бы, и нет... То есть, в принципе, физически диск организован просто: стопка оладушек, между которыми шастают головки. Все заморочки начинаются, когда вводят логическую организацию. Но без нее не получилось бы хранить информацию, так как физически клеточки на винте не нарисуешь. Каждый диск считается "разбитым" на концентрические окружности, которые называются дорожками. Дорожки, расположенные на одинаковых расстояниях от центра на всех поверхностях, называют цилиндром. То есть, если в харде 3 пластины (то есть 6-2=4 поверхности. 6 - это по две на каждую пластину, минус 2 внешних), то все третьи от центра дорожки образуют третий цилиндр.

Представь себе такую конфигурацию - и сразу поймешь. На самом деле, эти дорожки существуют только в нашей богатой фантазии. Поэтому, для того, чтобы правильно позиционировать считывающие головки в нужное место, в специальные области диска на воображаемый трек записывают служебные сигналы. Делают и по-другому: выделяют одну поверхность под так называемые сервоимпульсы (а соответствующую головку называют сервоголовкой). Это возможно благодаря тому, что на каждую поверхность имеется своя головка. А движутся эти головки одинаково - то есть, всегда находятся в одном цилиндре (на одинаковых дорожках, но на разных поверхностях). В общем, головка встает на определенном расстоянии от центра, и под ней вертится блин. Получается дорожка. Естественно, дорожки не пересекаются. Получились линеечки. Далее, каждая дорожка разбита на сектора. Количество секторов на дорожке определяется при форматировании. Это клеточки. В клеточки удобно записывать инфу (биты) и потом ее искать и читать.

Вообще, существуют два уровня форматирования: низкий и логический. При низкоуровневом форматировании на диск записывается сервисная информация (сервоимпульсы и компания) и микропрограммы. Делают это на заводе. До недавнего времени это можно было делать и дома из BIOS'а, но сейчас, когда каждый производитель использует свои технологии, эта опция может убить диск, поэтому ее убрали. Логическое форматирование (разметка дорожек и секторов) выполняется... Правильно: format C:. Или другими средствами юзаемой операционки.


Спецвыпуск Xakep, номер #012, стр. 012-005-3, Винчестеры к бою!

Винчестеры к бою!

Спецвыпуск Xakep, номер #012, стр. 012-005-3

А? Что такое "разбить на логические диски"? Это когда винту сказали, что эти цилиндры у тебя [C:], а вот эти - [D:]. А он ответил: "Есть!" :).

Винтики в винте

Итак, логика - фикция, что же там на самом деле? Хард драйв состоит из нескольких пластин на одной оси. На них наносят тончайший (0,0005 мм) магнитный слой. Раньше напыляли обычную ржавчину (ладно, ладно - оксид железа), теперь используют слой кобальта. Это позволило повысить плотность записи (то есть кол-во инфы на единицу площади) и цену. Обычно все это безобразие вращается со скоростью 5400 или 7200 оборотов в минуту. Сами головки не касаются поверхности потому, что попросту сковырнут магнитный слой и убьют диск. Поэтому диски не рекомендуют трясти и ронять на пол. Головки парят над блинами на высоте в несколько микрон. Парят они из-за эффекта воздушной смазки - потока воздуха, возникающего из-за бешеной скорости вращения блинов. Чтобы обезопасить диск в выключенном состоянии, существует "landing zone" - зона посадки, ВПП. Эта зона не содержит информации, и там головки могут касаться поверхности. При выключении диска электромагнитный привод паркует туда головки ("щелк" при выключении довольно-таки заметен). Такой привод срабатывает даже при аварийном выключении.

Блинное западло

Физические поломки в винте - большое западло с его стороны. Когда начинает сыпаться магнитный слой, от винта лучше избавляться. Но очень часто забывают, что кроме самих пластин в винте еще куча электроники, расположенной на плате у него на попе. Вот у меня не так давно сгорел блок питания в компе, забрав на тот свет с собой мамку, новенькую видюху, радиотюнер и винт. Все остальное, как ни странно, осталось целым. Ну и вот, движимый слабой надеждой на чудо, вместо того, чтобы винт выкинуть, я снял с него контроллер и прицепил платку от такого же винта. Мы с другом их в одно время брали. Какова же была моя радость, когда выяснилось, что сгорела только электроника, и я всю инфу (о-о-очень ценную) на новенький хардик переписал. Жаль, плату отдать пришлось. Так что у кого есть покрытый бэдами Quantum Fireball 6.4 EX - приму в подарок ;). А если ты мне еще и денег дашь...

Интерфейсом об тейбл

Жесткие диски к компу подключают посредством специальных интерфейсов. Самые юзаемые на данный момент - IDE (в модификациях) и SCSI (различных вариантов - море). ATA (AT Attachment) и IDE (Integrated Device Electronics), по сути - одно и тоже - стандарт, предусматривающий интеграцию контроллера в саму девайсину. Дешево и сердито. Сам стандарт уже далеко немолодой и несколько раз апгрейдился. Модификация Enhanced IDE (EIDE) в основном касалась BIOS - устранили ограничение на объем в 528 мегабайт. ATAPI (ATA Packet Interface) разработан для других типов устройств: СD-ROM, DVD-ROM, ZIP, etc. ATA-2 - очередное увеличение скорости за счет введения программируемого ввода/вывода (PIO) и режимов прямого доступа к памяти (DMA). ATA-3 внес лишь поддержку самоанализа S.M.A.R.T. Самые современные и скоростные стандарты - это Ultra-ATA/66 и Ultra-ATA/100.


Спецвыпуск Xakep, номер #012, стр. 012-005-4, Винчестеры к бою!

Винчестеры к бою!

Спецвыпуск Xakep, номер #012, стр. 012-005-4

Теперь про SCSI. SCSI (Small Computer System Interface) – стандарт, используемый в высокопроизводительных рабочих станциях и серверах. Сами HDD со сказевым (т.е. SCSI) интерфейсом чаще дороже IDE-аналогов. Сам интерфейс намного более гибок. К одному контроллеру можно подконнектить до 15 девайсов, максимальная длина шлейфа 46м (против 25 IDE). Пропускная способность до 160 МБ/с. Разновидностей SCSI до фига: SCSI-I/SCSI-II, Wide-SCSI, Ultra-SCSI, Ultra Wide-SCSI, Ultra2 Wide-SCSI, Ultra-160 SCSI. Вот такая семеечка.

Живуч, однако

Почему же технология, разработанная столько лет назад, до сих пор популярна? Ее основы не менялись с конца 70-х годов. Магнитная запись - очень старая штука, а оптика шагает семимильными шагами, но не может вытеснить магнитных "дедушек". Почему? Ответ прост, как редис, и незатейлив, как грабли. Оптимальное соотношение "цена-скорость-объем". Еще живучесть HDD-шек вырастает из того факта, что, увеличивая плотность записи данных, без дополнительного геморроя можно повышать емкость и производительность дисков, снижая (!) цену одного мегабайта. А если повысить скорость вращения дисков - умножаем выгоду на 2. Ясное дело, что у этого роста есть пределы, но пока до них еще не доросли, жесткие диски останутся на сцене. Помнишь, я говорил о том, что винты лучше не ронять? Конечно, всякое бывает... Поэтому производители укутывают свои диски. Защищают диски не только от механических повреждений, но и от выхода из строя электронных компонентов. Вот фирма Seagate (реклама, реклама!) при транспортировке пакует диски в специальные пластиковые футляры, защищая их от перегрузок и сильных ударов. На сами же диски натягивают эластичные кожухи или даже металлические пластины (тоже мне, бронетемкин Поносец!).

Что дальше? HHD’s tomorrow

Дело идет к тому, что жесткие диски перестают быть атрибутом только персональных компьютеров и ноутбуков. Они отвоевывают себе места в бытовой электронике и портативных устройствах. Объем и скорость нынешних дисков достаточна для построения на их основе цифровых видеомагнитофонов. О прототипах таких устройств ты, наверное, уже слышал. В портативных устройствах у хддшек большое будущее. Стоимость одного мегабайта на HDD намного меньше, чем на Flash-памяти. Тут, правда, есть свои проблемы с вибрацией и энергопотреблением. Но все решаемо. Ярким примером этого стал диск IBM MicroDrive. Его емкость 340 МБ, а размер всего 42,8 х 36,4 х 5,0 мм. Сейчас MicroDrive выпускается серийно. Будущее не за горами. Посмотрим, чем оно обернется для жестких дисков.

Good Bye!

Вот, рассказал я тебе про винчестер как отдельный девайс. Его особенности и перспективы. Так что, оружие к бою! Вот тебе ссылка на IBM'ский флэш-ролик об их развитии: http://www-1.ibm.com/ibm/history/history/flash/archives.exe. И да прибудет с тобой великий глюк!


Спецвыпуск Xakep, номер #012, стр. 012-008-1, **********************КОНЕЦ СТАТЬИ***********************

**********************КОНЕЦ СТАТЬИ***********************

****начало блок-врезки****

Спецвыпуск Xakep, номер #012, стр. 012-008-1

****Начало блок-врезки****

Кореша отправили обратно домой с его девайсом и попросили перед попыткой обмена как следует проверять железо.

****Конец блок-врезки****

Баги кривых рук

UFO (ufobject@mail.ru)

Привет, перец! Сегодня я расскажу тебе историю о том, как некоторые люди страдают от собственных кривых рук при сборке компа. Такие случаи встречаются очень часто. Все мы когда-то страдали от собственной невнимательности или недостатка знаний при сборке точилы или ее апгрейде. Бывало, что какая-то незначительная мелочь приводила к огромным глюкам в системе или вообще убивала железо. В этой статье я попробую привести примеры, с которыми столкнулся лично. Ты считаешь себя супер-мега-профи мастером в сборке и наладке компа? Уверен в том, что если собранная тобой тачка не работает, - то только потому, что в нее поставили неисправное железо? Ты сильно ошибаешься =). Даже профессионалы ошибаются...

У меня не работает видюха!

Мой знакомый купил себе новый агрегат. В железе он шарил хорошо и поэтому при сборке кнопчатого друга не стал прибегать к посторонней помощи. Собрал за час. Включил. И... тут его ждал большой облом. На мониторе появился желто-зеленый фон, и комп перестал подавать признаки жизни. Кекс выключил тачку, подождал несколько секунд и опять включил. Результат не изменился. Первая мысль - видюха. Парень вытащил карту из матери и понес в магазин, где та была куплена. Продавец долго оглядывал бедную карточку в надежде найти хоть какой-нибудь след жестоких пыток девайса (типа рубцы от топора, след от бензопилы), но ничего такого не обнаружил. Тогда барыга решил ее проверить на рядом стоявшем компе. После нескольких минут глумления видюха была успешно воткнута в маму, и тачку включили. Через секунду на мониторе появился тест памяти и началась загрузка. Кореша отправили обратно домой с его девайсом и попросили перед попыткой обмена как следует проверять железо. Вернувшись домой, он тыкнул видеокарту в комп и опять его включил. Результат тот же: разноцветный экран и мертвый комп. Сразу последовал обзвон всех знакомых и незнакомых в поисках человека, который сталкивался с такой проблемой. Такого человека не оказалось, и кекс попросил приехать меня =). К приезду уже было готово пиво и все из него вытекающее :). Порывшись в компе, мы решили разобрать его и собрать снова - только на этот раз собирал его я. Когда дело дошло до многострадальной видюшки, я обнаружил, что она как-то странно входит в слот... Проблема была решена сильным нажатием на девайс, после чего он благополучно встал на свое место. Комп был включен, и все оказалось работоспособным. Мораль сей басни такова: кекс боялся сломать мамку сильным нажатием на карту, и из-за тучи проводов в маленьком корпусе было проблематично определить: правильно вошел девайс или нет.

Способ устранения похожих проблем: давить на девайс до хруста мамки.

Не все то Windows, что висит

Дело было так. Примерно год назад купил я себе на рынке оперативку. Продавец меня долго уверял, что она рабочая, и никаких проблем у меня с ней не возникнет. Принес я ее домой, вставил в мамку. При тесте памяти новокупленную планку БИОС не видел ни в какую :(. Я вытащил память и опять вставил - думал, что криво вошла или что-то типа того. И опять обломался :( . Эта сволочь как не тестилась, так теститься и не стала. Ну, первая мысль - как всегда - барыги виноваты. С обильным потоком татарских слов я выдрал память из мамки и унес обратно на рынок. Продавца уже не было. "Все понятно", - подумал я и порулил с памятью к другу, чтобы напиться пива с горя :). После распития первого литра к нам в головы стали приходить мысли (ого! - прим. глав. Ред.). Друг предложил запихать модуль в морозилку - мол, он слышал, что для сгоревшей оперативки это чуть ли не единственный способ воскрешения. Но мне пришла в голову более простая мысль - решил попробовать протестить модуль на компе друга (почему-то до пива эта мысль мне в голову не пришла) :). Мы вскрыли системный блок и впялили модуль в слот. Следующие 2 минуты я стоял в шоке! Оперативка работала идеально! Прошла все тесты - как в БИОСе, так и в обычном тестовом софте. Мы опять выдрали модуль и понеслись с ним ко мне домой. Но... чуда не произошло. Мой комп опять не видел память. "Может, слот не пашет" - подумали мы и, выдрав старую оперативку, на ее место сунули новую. Все заработало как в сказке! В общем, проблема была в том, что два типа модулей, имеющие одинаковую емкость и предназначенные для работы на одной и той же частоте, ни в какую не хотели терпеть друг друга. Хотя в таком баге есть и свои плюсы. Вот, например, однажды притащил мне один знакомый модуль димов на 64 метра - мол, она не пашет и вообще дура страшная, и собака у нее дура, и все такое... Я предложил ему продать димок мне, чтобы потом из него брелок сделать. Он продал мне этот модуль за литр пива! И, что самое веселое, у меня память заработала идеально :)!


Спецвыпуск Xakep, номер #012, стр. 012-008-2, **********************КОНЕЦ СТАТЬИ***********************

**********************КОНЕЦ СТАТЬИ***********************

****начало блок-врезки****

Спецвыпуск Xakep, номер #012, стр. 012-008-2

Способ устранения похожих проблем: выпить побольше пива, делиться им с друзьями.

Еще один глюк с AGP-видюшкой

Вот еще случай (этот, наверное, больше относится к багам железа). В общем, купил один перец себе видюшку, которая садилась в AGP-слот. Сунул ее на место, и все вроде хорошо заработало... но со временем стали появляться какие-то странные глюки. В некоторых играх, на самом интересном месте (как это обычно бывает), вылетал экран смерти Windows с непонятной ошибкой. Никакие переустановки маздая и глумления над настройками результата не давали. Тогда перец решил протестить видюху DirectX'овым тестом. Вот тут-то все и всплыло. Видюха оказалась малость бракованной. Пацан сильно расстроился, так как купил карту с рук, и менять ее было не у кого и не на что, но... выход нашелся. Перец просто отключил в настройках поддержку AGP4Х, и видюха заработала нормально! Причем, потерь скорости не наблюдалось.

Диагноз: засорение совести продавца.

Способ устранения проблемы: отрубить продавцу совесть вместе с яйцами.

Колонки - враг монитора!

Рассказал мне Холод интересную историю о том, как у одного его хорошего приятеля были проблемы с монитором. Пересказываю. "Купил один друг себе монитор. Привез домой, включил - ужаснулся. Жуткое искажение изображения, хоть иконы выноси! Пришлось везти этот монитор обратно к барыгам. Привезли, проверили - все работает нормально. Парень разворачивает оглобли и везет монитор обратно (между прочим, килограмм 15 + громоздкая упаковка). Дома ситуевина повторяется. Опять стремные искажения. Перец опять везет гроб с музыкой в контору. Барыги его встречают, радуются. Опять проверяют. Снова все нормально работает. Везет ящик домой. Дома снова та же канитель. Не выдержал перец, обратился за помощью к Холоду. Холод приехал и просек всю фишку цирка :). Попросил перца отвернуться и просто убрал с монитора... нонамишные колонки, которые не были экранированы и давали жуткие наводки.


Спецвыпуск Xakep, номер #012, стр. 012-008-3, **********************КОНЕЦ СТАТЬИ***********************

**********************КОНЕЦ СТАТЬИ***********************

****начало блок-врезки****

Спецвыпуск Xakep, номер #012, стр. 012-008-3

Способ устранения проблемы: позвонить Холоду :).

BIOS VS Windows

Наверное, каждый знает о существовании в БИОСе опции, которая позволяет блокировать загрузочный сектор на винте от записи. Если быть точнее, то дело так обстоит: при блокировке бута каждая попытка записи туда сопровождается мессагой, которая оповещает юзверя о попытке. На первый взгляд совершенно безобидная опция, но и с ней возникают проблемы. Как всегда, во всем виноват злобный маньяк Билл и его подельщики из шайки Microsoft. Если защита бута стоит на "Enable", то установить маздай не получается, так как при инсталляции он пытается записать свою лабудень в этот самый бут. БИОС начинает на него рычать и выводить предупредительное сообщение на экран, но злобный Windows по какой-то непонятной причине не дает вывестись этому сообщению, и комп мирно виснет...

Способ устранения проблемы: отрубить хвост Биллу Гейтсу по самые уши.

Мобила - враг компа

Вот маленький случай из жизни одной фирмы. Названия конторы я не помню, но помню, что стояла там сеть под новелловской осой. Сеть была исправна, никогда не глючила, но однажды пришел в контору работать один мужик. И тут начался полтерГеец. Во время присутствия мужика в конторе компы периодически вешались без всякой причины. Сеть давала сбои. Сотрудники стали периодически видеть в офисе голых женщин. И вообще: творилось какое-то безобразие. Через некоторое время источник основной массы проблем был выявлен. Им оказался мобильный телефон нового работника. При звонке мобила создавала огромные помехи вокруг себя, и по этой причине тачки дружно сбоили. А вот откуда в офисе голые женщины, до сих пор никто не знает. Кстати, мобильник также следует отключать при записи видео- и аудиокассет, у меня даже есть экземпляр видео кассеты, купленной на рынке, на которой отчетливо слышны помехи от мобилы. Бесплатный бонус такой :).

Способ устранения проблемы: выкинуть мобилу с балкона и познакомиться с голой женщиной =).

Неизменные настройки

Есть у меня в запасе еще один прикольный случай. У одного моего старого друга был такой же старый комп - кажется, 486. У этого агрегата были очень интересные настройки БИОСа. В этих настройках почему-то был выключен флоппик по умолчанию. При покупке продавец ему все настроил, и флопарь работал нормально. Прошло несколько лет, и комп начал бажить. А бажил он следующим образом: при включении флоп не работал. Ну, парень собственными ручками покопался в БИОСе, предварительно обучившись у более продвинутого друга, и врубил флоп. Все работало как в сказке, но наутро, включив кнопчатого друга, перец обнаружил, что флоп снова пропал. Так продолжалось довольно долго, пока кто-то не намекнул парню о том, что пора поменять... аккумулятор на мамке. Просто кмос за ночь успевал сброситься из-за недостатка питания, и наутро после включения все настройки становились дефальтными. Замена батарейки решила все проблемы.


Спецвыпуск Xakep, номер #012, стр. 012-008-4, **********************КОНЕЦ СТАТЬИ***********************

**********************КОНЕЦ СТАТЬИ***********************

****начало блок-врезки****

Спецвыпуск Xakep, номер #012, стр. 012-008-4

Способ устранения проблемы: поставить аккумулятор от уазика на мамку (или рядом с мамкой).

Еще одна история от Холода

Сдавал он как-то зачет по ТерВеру. Ну, препод у него и поинтересовался: мол, ты шаришь в компах-то? А то есть тут одна проблема: внутренний Спортстер 33.6 не желает вставать на тачку ни в какую - не видит его ось, и все. И, конечно, в Интернет выйти не удается. А куда же в наше время без Интернета? Да, собственно, никуда...

Короче, приезжает Холод к преподу. Начинается разговор автопилота с автоответчиком. Не видит тачка момед, и все тут. Час безопасного секса - и Холод начинает телефонный рейд по компетентным друзьям. Ему подсказывают: ты в биосе выключи все порты вообще, все комы в "дизабль" поставь - и попробуй. Тот крутит пальцем у виска, но делает. Через две минуты момед встает. Холоду остается только пожать плечами, порадоваться и снова включить порты в биосе...

Способ устранения проблемы: выбирать ВУЗ, где нет Теории Вероятности.

Ну, вот, в общем-то, и все. Привет тебе из далекого космоса ;)!


Спецвыпуск Xakep, номер #012, стр. 012-010-1, МАЛЕНЬКИЕ ХИТРОСТИ ПРОДАВЦОВ ЖЕЛЕЗА

МАЛЕНЬКИЕ ХИТРОСТИ ПРОДАВЦОВ ЖЕЛЕЗА

Спецвыпуск Xakep, номер #012, стр. 012-010-1

n0ah (noah@real.xakep.ru), Alex Hacker (no_mail), 4x4 (4x4@mail.ru)

Свершилось! Ты скопил денег на очередной апгрейд компа! Не знаю, что именно ты делал: таскал с места на место тяжеленные кирпичи, или сдавал в аренду местным котам свой балкон (кошка и стопарик валерьянки за счет заведения :)), но уверен: эти деньги достались тебе нелегко, и ты не захочешь просто так с ними расстаться. Тут возникает вопрос: как сделать, чтоб при покупке комплектухи тебя не кинули? Во-первых, ты можешь отлично разбираться в паре-тройке осей, кодить на дюжине языков, общаться с друганами исключительно по протоколу TCP/IP и при этом хреново разбираться в железе. В таком случае продавцу обмануть тебя проще простого. Во-вторых, ты можешь очень даже здорово разбираться в железе и быть в курсе всех последних хардварных новинок, но и при таком раскладе, обмануть тебя тоже вполне реально. Просто продавец, пытающийся тебя продинамить, заведомо лучше знает, что к чему (если ты сам, конечно, не другой такой же продавец :)). Но он еще и знаком с большим количеством способов кидания. Если с первым (знанием хардвара) все может наладиться после прочтения этого спеца целиком, то со вторым (знанием способов кидания), я надеюсь, все будет ОК после ознакомления с этой статьей :).

MITINO VS SAVELA

X решил надыбать для тебя сии пресловутые способы кидания, чтоб ты был ко всему готов, и не попадал в неприятные ситуации. С этой целью, мы, методами подкупа, шантажа и насилия, склонили пару перцев (Alex Hacker и 4x4), торгующих на двух крупнейших столичных рынках - Митинском и Савеловском - к сотрудничеству, заставив их под пытками =) рассказать нам все грязные способы кидалова. Понятное дело, что ребята сами никогда никого не кидали, и знакомы с процессом только понаслышке ;). Однако, это не помешало им посвятить меня в тайну таких изощренных способов обмана, что у меня местами фишки на лоб лезли!

Прежде чем начать, хочу, чтоб ты представил себе, чем отличаются эти два рынка. Савеловский базар на сегодняшний день выглядит более цивильно: он крытый, поделен на аккуратные офисоподобные павильончики. В самих павильонах находятся только образцы товара (типа, на витринах) - а если чего захочешь прикупить, то продавец отведет тебя на склад (совсем близко), где выдадут покупку и оформят все документы. На Митинском все намного и по-домашнему проще: каждая торговая точка представлена отдельным вагончиком-палаткой, где и свален весь наличествующий товар. Зато можно торговаться :).

Из этих, можно сказать, природных условий вытекают характерные для каждого рынка черты в кидалове: на Савелке в основном кидают, мухлюя с гарантийными документами и вольно интерпретируя их правила, а на Митьке - чаще имеют место быть всякие перепайки, разгоны и прочие манипуляции с самими девайсами.

ГАРАНТИЙКА

Очень важный документ, на долю которого приходится около 50% способов кидания. За заполнением гарантийного талона надо следить очень внимательно! Например, на Савеловском рынке характерным способом кидалова является вписывание в гарантийку несоответствующего продаваемому девайсу серийного номера. Если ты попадешься на удочку и заберешь такой девайс домой, то вернуть его уже не удастся (а он, поверь мне, будет глючить, если вообще будет работать). А теперь, представь себе, насколько легко можно провернуть такой финт с парой-тройкой девайсов, если чел пришел целый комп собирать. Но у гарантии есть, конечно же, и свои плюсы - например, имея гарантию, ты всегда можешь вернуть любой нерабочий/глючный товар, не имеющий внешних повреждений. Прикинь: ты взял камень, разогнал, спалил, и, если он с виду не горелый - можешь спокойно вернуть его обратно ;). Ладно, давай пройдемся по всем основным девайсам, и посмотрим, где нас могут подловить враги.


Спецвыпуск Xakep, номер #012, стр. 012-010-2, МАЛЕНЬКИЕ ХИТРОСТИ ПРОДАВЦОВ ЖЕЛЕЗА

МАЛЕНЬКИЕ ХИТРОСТИ ПРОДАВЦОВ ЖЕЛЕЗА

Спецвыпуск Xakep, номер #012, стр. 012-010-2

КАМНИ

С камнями попа полная :(. Первое, о чем мне рассказал 4x4 (перец с Савеловского) - это камни со сколами. Сколы - трещины на процессоре, возникающие по вине криворуких юзеров, не умеющих ставить кулер на проц. Камень со сколами непредсказуем, и может работать нормально некоторое время, глючить, или вообще не работать. Шняга в том, что эти чертовы сколы очень сложно разглядеть визуально, особенно если раньше ничего о них и не слышал. Кроме того, камни бывают еще и разогнанные. Это отлавливается программно, но только не ламероватыми покупателями. А чтоб ты понял, насколько бывают продвинутыми некоторые челы, расскажу тебе прикольный случай с Mitin0-BazaR: пришел перец и спрашивает: типа, у вас винтиков - саморезов нет? А зачем они вам? Да вот, сказали кулер надо к процессору прикручивать... 8-( )

МАМКИ

Есть одно тупейшее свойство: если у работающего компа вытащить сзади крысу, то сразу сгорает com-порт мамки. Учти, что если тебе впарят такую мать, на Савеловском рынке назад ее вернуть не удастся - там этот прикол знают все.

А вот метод кидалова с Mitin0-BazaR: перцу продают мать с камнем без MMX, но обещают, что мать MMX поддерживает, и, что он в будущем сможет поставить туда проц с MMX'ом. А на самом деле ему дают мать с горелой микросхемой поддержки MMX.

ПАМЯТЬ

Память бывает трех типов: no name, brand и brand-brand. No name - это память, произведенная неизвестной конторой. Brand - память запаянная неизвестной конторой, но с чипом хорошо известной фирмы. Brand-brand - память с чипом от брендовской фирмы с ее же запайкой. Оба наших перца в один голос орали, что покупать стоит только brand-brand память! Все остальные виды памяти - это уже заведомо кидалово :). Разница в ценах между no name и brand-brand - почти никакая (измеряется в десятках рублей!). Ок, с этим разобрались. Далее у нас идут просто глючные мозги. Alex говорит, что такие подсунуть вообще не вопрос, даже опытному покупателю. Глюки памяти ловятся всякими утилитами, типа testmem, но, к сожалению, еще ни один из покупателей не приволок с собой дискету с чем-нибудь подобным, и не догадался проверить память на месте.

ХАРДЫ

Харды - это стихия Митинского рынка. Тут все, кому не лень, занимаются починкой и продажей бушных хардов. Понятно, что некоторые делают это очень неграмотно (в отличие от нашего Alex'а ;)), и такие харды долго не живут. На Савелке покупку/продажу бушных винтов полностью отвергают, считая это бесполезным делом. Короче: если ты берешься покупать бэушный хард - молись, чтоб не словить фиговый девайс с кучей бэдов и полуубитым контролером. Если же ты покупаешь новый винчестер, то запомни одно - он обязательно должен быть в упаковке! Не в каком-нибудь целлофане, а в заводской упаковке, без следов вскрытия.


Спецвыпуск Xakep, номер #012, стр. 012-010-3, МАЛЕНЬКИЕ ХИТРОСТИ ПРОДАВЦОВ ЖЕЛЕЗА

МАЛЕНЬКИЕ ХИТРОСТИ ПРОДАВЦОВ ЖЕЛЕЗА

Спецвыпуск Xakep, номер #012, стр. 012-010-3

ЦДРОМЫ

CD'шник - это второй девайс после харда, который 4x4 вообще не советует покупать бушным. Считается, что ЦДРОМ, отработавший два года, можно уже выбрасывать :(. Но если ты все же решил взять бушный сидюк, вот тебе рецепт кидалова от Alex'а. Дохлый цдшник с нерабочим лазером впаривается следующим образом: на головке подкручивается какой-то резистор, отчего лазер начинает гореть ярче, и ЦД работает, но ровно через две недели (как раз хватит для окончания гарантии) умирает окончательно... Есть еще и глючные сидюки, которые могут нормально читать в течение пяти минут, а потом вообще перестать... Видимо, что-то в них греется :(.

ВИДЮХИ

С видюхами особо не накалывают, но на Савеловском все-таки были случаи ;). Дело в том, что если у карт, имеющих выход на TV, тюльпаны случайно подключить не к тому входу ящика, на плате сгорает именно элемент, отвечающий за TV-выход. Все остальное работает нормально. Такую карту с убитым TV-выходом очень легко загнать, а потом свалить всю вину на покупателя.

ХАБЫ

Есть приколы и с этими зверями :). На Митинском были случаи, когда покупатели пытались вернуть хабы, в которые ударила молния (!), а тамошние продавцы приноровились проверять работоспособность хаба прямо на месте: просто линкуют этот хаб с другим, и если лампочки горят - все ок.

РЕЛАКС

После бесед с Alex'ом и с 4x4, мне вообще расхотелось кода-либо апгрейдиться :(. Сложилось впечатление, что кинуть можно практически любого покупателя в любой ситуации. Но ребята меня переубедили :). Во-первых, продавцы не кидают по одной простой причине - выгоднее не заниматься сомнительным обманом, а приложить больше усилий и продать больше комплектухи. Во-вторых, продавцам тоже стремно устраивать полный беспредел: ведь если покупатель попадется геморройный - фиг потом от скандала отделаешься (клиентов-скандалистов они реально боятся). В-третьих, сами продавцы понимают, что если все время кидать людей, за рынком пойдет дурная слава - а это сулит голодную смерть :). Так что, если ты, перец, будешь внимателен - можешь ни о чем не беспокоиться. Удачного апгрейда! Пока.


Спецвыпуск Xakep, номер #012, стр. 012-012-1, Возьми свое «добро» назад

Возьми свое «добро» назад

Спецвыпуск Xakep, номер #012, стр. 012-012-1

Злобный покупатель (dodge@xakep.ru)

Ты копишь деньги на новый комп (варианты: монитор, винт, проц и т.п.), приходишь в магазин, покупаешь то, чего ты так хотел эти голодные месяцы. Бежишь домой, чтобы насладиться этой вещью, а тут облом: она бракованная или, проще говоря, не работает. Что делать? Как заставить барыг отвечать за такое хамство? Читай дальше, и ты узнаешь, как раскаять продавцов в содеянном =).

О чем надо всегда помнить

Прежде всего, всегда береги чек после оплаты покупки, а когда не дают, - ТРЕБУЙ в обязательном порядке. Чек должны давать всегда, это не зависит от того, что именно ты покупаешь. Если продавец не провел товар через кассу - значит, он не заплатит налог, а ты не получишь гарантию на товар, а это противозаконно.

Прежде чем товар упакуют, попроси по возможности, проверить товар на работоспособность. Почему "по возможности"? Потому, что вряд ли ты сможешь вот так запросто проверить материнскую плату – слишком много нюансов. А вот колонки достаточно включить в сеть, чтоб увидеть (услышать=)), что те живы. В любом случае, ты всегда имеешь право проверить товар на поверхностные повреждения и сразу же заменить брак. Кстати, обрати особое внимание на этот пункт: если ты обнаружишь повреждения дома, продавец тебя также может обвинить в неправильной эксплуатации товара. И он прав - ведь при покупке товара у тебя не было никаких претензий к внешнему виду предмета, а значит - вина твоя. Так что, хорошенько щупай, прежде чем в сумку засунуть.

Также, обрати особое внимание на место, где будешь покупать товар. Да, лучше делать покупки в фирменных магазинах, у которых много филиалов по Москве и по России. С ними всегда будет легче договориться, они не станут тебя обманывать. Это рискованно для них, для их репутации. Ведь, стоит обмануть не того, кого надо (скажем, представителя журнала "Хакер" =)) - и о недобросовестных продавцах узнает весь мир. Клиентов, по крайней мере, у них станет намного меньше – согласен? По простым подсчетам можно догадаться, что заменить тебе товар гораздо выгоднее, чем потерять сотню-другую покупателей. В некоторых магазинах, которые работают по западному образу и подобию, тебе могут поменять товар и без наличия чека, но такие случаи у нас пока редки. И я понимаю, что Митино-Базар гораздо ближе твоей душе: там и дешевле, и выбор больше... Эх, вот, пожалуй, и все плюсы рынков. Но зато вот минусы: чеков там некоторые товарищи не дают. Если у тебя вдруг что-то не будет работать, нужного продавца ты можешь и не найти (читай: больше никогда его не увидишь) - но зато еще долго будешь вспоминать его "теплыми" словами. Так что намного выгодней переплатить 5%, но получить действительно качественный, фирменный, а самое главное - работающий товар. Не экономь, иначе потом жалеть будешь!

Тебя все-таки...

Итак, несмотря на все твои предосторожности, тебя все-таки обманули. Что делать? Давай разберемся по порядку.

Прежде всего, при покупке надо установить, имеет ли твой товар гарантию. А если имеет - то на какой срок. Каждая продавец-фирма имеет свой гарантийный срок. Обычно, при обнаружении дефектов, товар можно поменять на аналогичный или сделать «манибэк» - вернуть деньги - в течение двух недель. По истечении этого срока ты можешь БЕСПЛАТНО отремонтировать товар в сервисных центрах изготовителя. Но, так или иначе, у тебя должен быть гарантийный талон – в противном случае ремонт будет стоить денег.


Спецвыпуск Xakep, номер #012, стр. 012-012-2, Возьми свое «добро» назад

Возьми свое «добро» назад

Спецвыпуск Xakep, номер #012, стр. 012-012-2

Для начала попытайся договориться с продавцом "по-хорошему" - вдруг поможет. Спроси его фамилию и потребуй жалобную книгу. Если барыга боится, что его могут уволить, - он сделает все возможное, чтобы не допустить записи в жалобной книге. Если продавец отказывается от своих обязательств, добивайся разговора со старшим человеком в магазине. Обычно, в каждом торговом предприятии есть топ-менеджер. Обращайся к нему, именно он отвечает за все, что делают его подчиненные (в том числе и продавцы), и именно его будет иметь начальство за надпись в жалобной книге. А уж он, в свою очередь, будет иметь своих подчиненных. Так что, когда будешь разговаривать с менеджером, не забывай употреблять такие слова, как «суд», «милиция», «журналист», «жалобная книга», «общество защиты прав потребителей», а самое главное – «Закон о защите прав потребителей»! Покажи ему чек и объясни, что ты хочешь поменять товар из-за его неработоспособности. Если человек не дурак, то ему ничего не останется сделать, кроме как, удовлетворить твои потребности.

Каменный цветок

Если же разговор с менеджером не вышел, попробуй следующее: дойди до ближайшего представителя правоохранительных органов и расскажи ему о случившимся. По закону, милиционер обязан тебе помочь - но это не значит, что он решит твои проблемы. Иногда появление милиции действует на продавцов - таким образом ты показываешь барыгам серьезность своих намерений. Пусть знают, в конце концов, с кем дело имеют.

Если все твои попытки разобраться на месте не увенчались успехом - переходи к более основательным попыткам. Например, подай иск в суд. Я понимаю, ты думаешь, что это сложно и, наверное, уверен, что проиграешь. Но это не так! В большинстве случаев аналогичные дела выигрывают потребители. Итак, вот что тебе надо делать. Во-первых, обязательно сохрани чек, обзаведись несколькими свидетелями, которые смогут подтвердить в суде, что продавец в лице фирмы отказывался поменять тебе товар, также не забудь о самом товаре, - сохрани его нетронутым. После этого идешь в суд (либо по своему месту жительства, либо по месту нахождения фирмы-продавца - первый вариант предпочтительней!). Обычно, в каждом суде присутствует секретарь, который максимально подробно и бесплатно объяснит тебе, что следует делать дальше (какой бланк и как заполнять, и т.п.). После этого - жди суда (самого Судебного процесса). В 90% случаев ответчик (то есть, продавец) не явится в суд, и решение судебного заседания будет вынесено в твою пользу. А дальше ты идешь с бумажкой "о решении суда", суешь ее в морду продавцу и наглым образом заставляешь его поменять тебе товар.

ОЗПП

Суд - это хлопотно. И прибегать к суду не всегда правильно - хотя, это, наверное, самый действенный способ. Что делать, если в суд обращаться не хочется – нет времени, нет возможности? На такой случай всегда есть Общества защиты прав потребителей. Для начала, отвечу на вопрос "что это?". Общества Защиты Прав Потребителей - это организации, созданные при поддержке правительства (и не только), которые проводят исследования с целью выявления некачественных товаров, и активно мешают их распространению. Основными целями таких организаций являются: помощь обманутым потребителям и распространение знаний закона среди населения "О Защите Прав Потребителей". В таких организациях тебе всегда помогут особенно быстро и эффективно - они на этом специализируются. Там, можно сказать, все под контролем. У них есть "свои" суды, где они всегда выигрывают, у них есть грамотные юристы, которые умеют использовать закон «на все сто» и заставлять барыг выплачивать огромные штрафы.


Спецвыпуск Xakep, номер #012, стр. 012-012-3, Возьми свое «добро» назад

Возьми свое «добро» назад

Спецвыпуск Xakep, номер #012, стр. 012-012-3

Напоследок

Расскажу тебе одну историю. Был у меня в районе ларек с компактами. Приходит однажды туда парнишка, лет 15-16, покупает диски. Через два часа возвращается – мол, не читается один, и все тут. Барыга – отпираться: мол, возврату не подлежит, да ты кто вообще такой, пшел вон... Мальчишка разворачивается, и уходит. Через два часа приезжает «камаз» с краном и платформой, на глазах изумленных людей крепкие парни цепляют тросами палатку вместе с продавцом (!) к крану, грузят на борт, и увозят. Больше недобросовестного барыгу у нас в районе никто не видел...


Спецвыпуск Xakep, номер #012, стр. 012-014-1, Комплектация оборудования, или упаковка подарков

Комплектация оборудования, или упаковка подарков

Matt (matt@nm.ru)

Спецвыпуск Xakep, номер #012, стр. 012-014-1

Сказка с happy end'ом

Решил я себе однажды купить cd-rw (девайс такой, который компакты записывает). Собрал денюжки и попер в магазин с громким именем, здоровой вывеской и рекламой на всех трамваях. Когда я сказал: "Дайте мне ЭТО", мне вынесли простой полиэтиленовый кулечек за 40 коп., в котором лежал девайс без коробки и компакт сомнительного происхождения с надписью маркером "Nec" (так звали железяку). На мое возмущение мне ответили, что это какая-то OEM-поставка, и что ни фига больше не прилагается. Пришел я домой, втыкнул как полагается девайс, установил управляющую программу с выданного мне диска, но записывать компакты что-то у меня не получалось. Потом было еще много приключений и, в конце концов, сказка кончилась тем, что бабки мне все-таки вернули, я купил в другой конторе такой же cd-writer, и он у меня до сих пор исправно работает. Но весь прикол в том, что первый забракованный девайс на самом деле тоже работал, просто программку надо было не обычную (которой меня сначала снабдили), а специальную поставить, что во второй фирме мне и посоветовали - к моему Nec'у только она и подходит, оказывается. И вот сижу я, записываю порнушку на компакты и не сильно расстраиваюсь, что cd-rw у меня без коробки и инструкции...

OEM

Так вот. OEM-поставка (Original Equipment Manufacturer – настоящий производитель оборудования) предназначена изначально для сборщиков компьютеров, которые комплектуют машины этими девайсами. Таким образом, устройства устанавливаются профессионалами и в достаточно массовом количестве, а не рядовым юзверем, и тем более не ламаком... Не, фигня. Получается, что я ламак, раз не смог сам cd-writer поставить. Ok. У чела, не имеющего каждый день дела с установкой именно этих устройств могут возникнуть некоторые проблемы, но это не говорит о его ламерстве!!! Ну, а компутерщики-профессионалы, которые десятками их ставят, свое дело знают, и сами могут разобраться, как установить, куда прописать и что потом с этой фигней делать. Вот поэтому OEM-поставка не включает в себя цветных инструкций, больших упаковок и кучи дисков с драйверами. Так и снижается цена. На заводе, где производятся девайсы, они десятками складываются в одну коробку (как огурцы в банку), и, в лучшем случае, к партии устройств прилагается одна инструкция или один компакт. А уж если фирма, торгующая этими устройствами, добрая попадется - то могут записать свой сидюк или дискетку с драйверами.

Retail

Retail (розница) - вариант поставки устройства в комплекте с инструкцией, драйверами, в большой коробке с рисунками и - что немаловажно - с гарантией производителя (а не торговца!). Кроме того, вместе с самим девайсом идут все необходимые кабели, шлейфы, крепежи, переходники - одним словом, все, что может понадобиться при установке (ничего вышеперечисленного мне к моему OEM-овскому Nec'у не выдали, и пришлось обходиться подручными средствами). Такая комплектация предназначена для розничной торговли, и рассчитана на то, что хоть сколько-нибудь продвинутый пользователь не без труда, но все-таки сможет самостоятельно подключить устройство, установить драйвера и разобраться во всем.


Спецвыпуск Xakep, номер #012, стр. 012-014-2, Комплектация оборудования, или упаковка подарков

Комплектация оборудования, или упаковка подарков

Matt (matt@nm.ru)

Спецвыпуск Xakep, номер #012, стр. 012-014-2

Box

Самый, пожалуй, навороченный вариант поставки - это Box (для тех, кто в первом классе шланг пинал: box - коробка по-английски). Это, в принципе, тот же Retail, но еще больше напичканный и доукомплектованный. Плюс - к самому девайсу, драйверам, крепежам и шнурам идет подробная инструкция на нескольких языках (качество перевода - не тема для спора), с цветными иллюстрациями, стрелочками, схемами и прочей красотой. Как правило, в качестве бонуса, на сидюке с дровами попадаются программы других фирм (для видеокарт - игрушки, для мам - Нортон-утилиты, антивиры и прочий софт, для модемов - звонилки и броузеры). Ну, и, конечно, гарантия, буклетики и рекламки. Короче говоря, box - это для тех, кому некуда деть деньги. Или для тех, кто немного сомневается в способности самостоятельной установки устройства, но уж очень жаждет попробовать.

Refab

Существует, в принципе, еще один вид поставки - Refab. Это девайсы, которые в свое время отказались работать, и которым в связи с этим заменили некоторые запчасти. Конечно, далеко не все МОЖЕТ идти в refab-комплектации. Как правило, это заправленные (регенерированные) картриджи, лазерные принтеры с новыми барабанами, "отреставрированные" старые компы. То есть, по большому счету, это - second hand (б/у, если хочешь), но полностью функционирующий.

Мораль басни

В общем, если ты достаточно уверен в своих силах и у тебя лимит финансов, то лучше, конечно, брать девайс в OEM-комплектации. Но я настоятельно рекомендую разузнать у продавца, как его ставить, куда втыкать, где достать драйвера, какие могут быть проблемы. Если для 100%-й гарантии работоспособности тебе не жалко никаких денег, то можешь выбирать между retail и box. Но учти, что далеко не все устройства идут и в OEM, и в retail (или box)-комплектации. А рефаб... Русская рулетка. Тут сам думай. Удачной покупки!


Спецвыпуск Xakep, номер #012, стр. 012-016-1, Три идиота и компьютер

Три идиота и компьютер

Спецвыпуск Xakep, номер #012, стр. 012-016-1

Доктор Пранк и Доктор Штейн (lapkarelief@mail.ru)

Как ты, может быть, помнишь, некоторое время назад нас упаковали в психушку. За дело, понятно - нечего было соседей по подъезду манекенами пугать. Бросаться же на санитаров тем более не стоило - после общения с персоналом больницы имени Шеповалова мы это очень хорошо поняли. С другой стороны, оказалось, что и здесь жить можно. И приколов и развлечений здесь тоже хватает.

Вот, например, привезли вчера троих. Они кричали, махали руками и убеждали всех окружающих, что они - великие сборщики компьютеров. Правда, выяснилось, что никто из них внутренностей компьютера никогда не видел. Впрочем, это не помешало добрым докторам предоставить им груду компьютерного железа - чтобы ребята могли на деле продемонстрировать свои способности. Нам осталось только тихонечко сесть в уголочке с фотоаппаратом - и вот тебе наш рассказ об этом незабываемом дне.

Для чистоты эксперимента был найден системник с отсутствующим блоком питания. Юные конструкторы всего за сорок минут догадались, что эта коробочка с проводами должна находиться внутри компа. Еще примерно столько же ушло на прилаживание его внутрь...

Можно сказать, что с первой задачей они справились довольно успешно. Дальше им предложили выбрать остальные комплектующие.

Материнка, память, процессор - пришлось все-таки подсказать ребятам названия этих деталей. Их совершенно не смутило то, что для сборки они отобрали несовместимые друг с другом чипы памяти. Они пытались решить другой вопрос - куда же надо вставить провода, идущие в диком количестве от блока питания? Поскольку нам запретили подсказывать, пришлось промолчать - а то эксперимент закончился бы у врача - проктолога...

Задумчиво изучив груду железа, самый активный сделал предположение - наверное, один из этих проводков должен идти на питание процессору. Ох, как долго они выбирали, какой именно из проводов - кто-то из них слышал где-то, что правильный выбор питания для камня - основа основ при сборке компьютера. Мол, чтобы и не перегнать, но и не недоразогнать. Промучившись двадцать минут, они убедились, что для обеспечения питанием всех ножек процессора потребуется, как минимум, еще пять блоков питания... Утренние процедуры прервали наши наблюдения.

Вернувшись, мы обнаружили, что диспозиция изменилась - вместо старой простой материнки они выкопали где-то двухпроцессорную маму. Им даже частично повезло - до этого эта материнка работала с одним камнем, и, соответственно, один процессорный слот уже был закрыт заглушкой. Но, поскольку парни догадались, что мать двухпроцессорная - стали пихать в нее второй процессор. И ведь впихнули, мерзавцы.

Но, ясное дело, не сразу. Потому что процессор не будет работать, будучи воткнут в PCI-слот. Он туда просто не влезает - как ни старайся. По крайней мере, без подручных средств - а специфика помещения исключила применение молотков, зубила и топора. У нас тут даже вилки пластмассовые.

А вот что им удалось - это воткнуть его в слот памяти. Тоже вошел - со скрипом, правда. Вдоволь натешившись плодами своих усилий, они зачем-то вытащили его обратно и стали ладить нормальный проц на положенное место.


Спецвыпуск Xakep, номер #012, стр. 012-016-2, Три идиота и компьютер

Три идиота и компьютер

Спецвыпуск Xakep, номер #012, стр. 012-016-2

Дальше ребята решили разобраться с сидюком. Понятно, что нормальный человек сначала на матери все собирает - но они-то идиоты, что тут сделаешь. Началось выяснение - какой же проводок надо воткнуть в это хитрое устройство, чтобы оно диски не пилило? Стараясь не смеяться, мы тихонько наблюдали.

Про питание тут речь и не зашла. Принцип отбора был прост, как три рубля - проводок должен быть не слишком длинным и заканчиваться другим разъемом. Повезло нам, что им все-таки не удалось использовать вместо ИДЕ ЛПТшный порт. Хотя, может, и жаль - мне всегда было интересно попробовать распечатать музыку напрямую с сидюка.

Шлейф они все-таки воткнули. Неправильно, понятно, но это к делу не относится. Поскольку на гнущиеся ноги и трещащие разъемы внимания никто не обратил - все встало "как надо". Удовлетворившись этим, ребята решили закрепить материнку в системном блоке.

"Закрепить" - это я погорячился, понятно. Ее просто положили - как легла, так и легла. О том, что ее надо как-то зафиксировать, никто и не подумал - и в самом деле, зачем? Все равно вытаскивать - после того, как ее прожжет неправильно установленный проц.

Подвести питание к матери - эта мысль посетила ребят следующей. Провода последовательно подключались к памяти, пихались в многострадальный процессор, закреплялись на джамперах и переключателях. Уж не знаю, что помешало им закрепить провода на контроллере дисковода - может быть, некоторое несоответствие в размерах?

Вдоволь наигравшись с питанием материнки, ребята нашли - таки правильный разъем. Воткнув питание на место, они похлопали сами себе в ладоши, и решили заняться подключением всего остального. Пришла очередь видеокарты (они ее, правда, называли видеофонным акселератором, но на такие мелочи внимание мы старались не обращать).

AGP-видюха на редкость удачно встала в слот ISA - настолько удачно, что даже сильно нажимать на нее не пришлось. Ну и что, что больше половины ее торчит за пределами собираемого агрегата? "В каком параграфе российской конституции написано, что видеодомофонным акселераторам нельзя торчать из компьютера?" - вопрошали друг друга наши сборщики. Но все-таки подсознание подсказало им, что что-то здесь не так. И карточку они все-таки переставили на ее законное место. Пришла очередь винчестера.

Нет, основные принципы их работы мы уловили почти сразу. В самом деле - зачем закреплять все детали, если все равно они работать не будут? Единственное, что вызывало сомнение в наших и так нездоровых умах - ребята работали так, как будто собираемый ими агрегат они собираются включать. Ну, больница - своя специфика, все понятно. Видимо, жесткий диск они собирались держать на весу все время работы компьютера - а может быть, они хотели повесить его на проводах? Тем не менее, кое-как приладив к нему шлейф и аккуратно положив его прямо на материнку, сборщики перешли к другим комплектующим.

Скажи мне, какое устройство надо подключать сразу после подсоединения винчестера? Я бы ни за что не догадался - оказалось, мышь. А ее для этого надо предварительно разобрать. К тому же, всяческие порты - это лирика. И мышь, и клава, как выяснилось, совершенно замечательно подключаются прямо к материнке. В этом им помог хитрый проводок, который подключался к LPT, а затем ветвился на клавиатурный и мышиный разьем.


Спецвыпуск Xakep, номер #012, стр. 012-016-3, Три идиота и компьютер

Три идиота и компьютер

Спецвыпуск Xakep, номер #012, стр. 012-016-3

Затем к тому же проводку почти умудрились присобачить дисковод. Ну и что с того, что замыкать клаву на дисковод нерационально? Зато смотрится впечатляюще. Точнее, смотрелось бы - если бы разъемы совпали. Но ребята не парились - они просто отложили его в сторону.

Работа кипела. Все трое, столпившись около многострадального корпуса, подпирали провода и разъемы по принципу "папа-мама". Никто не парился тем, к чему и от чего на самом деле должны идти эти конструкции. В итоге, дисковод был не только подсоединен к клавиатуре - туда же присоединили и винчестер, и мышка каким-то хвостиком затесалась. Слаженные действия нарушал только главный врач, который периодически порывался скомандовать: "Аминазин в студию!". Но все-таки любопытство и естественное желание увидеть результат пересилили его человеколюбивые помыслы.

И ребята крепили все так, как крепилось. Получившуюся конструкцию мы бы даже в ночных кошмарах не назвали компьютером - но уверенность наших сборщиков в своих силах поражала. В какой-то момент все они вдруг выпрямились, дружно глубоко выдохнули и сказали: "ну вот, почти готово".

Ну и что, что часть деталей болталась снаружи? И что провода клавы и мыши идут через ... хм, не через то что положено, в общем. Выглядит все красивенько, и обязательно заработает - убеждали они. Я даже помог им приладить на место крышку от корпуса - сам понимаешь, трех человек для этого явно недостаточно.

Крышку на место мы приладили без проблем. Поскольку из-под нее постоянно что-то падало, корпус решили обвязать вокруг. Очень кстати под руку попался длинный модемный провод, и через еще десять минут нашим глазам предстал готовый продукт.

Как ты понимаешь, нам осталось только провести полевые испытания. Сборщики же настолько переутомились, что потеряли способности к членораздельной внятной речи, и тут сердце врача не выдержало. Каждый был проведен в свою палату. Точнее сказать, даже отнесен - потому что ходить они тоже уже не могли. Что же касается включения получившегося агрегата, то никто из нас не взял на себя такую ответственность: пожар в больнице тушить - это вам не шутка. Так что в коллекции музея "Творчество душевнобольных" появился новый экспонат. А мы спокойно пошли на вечерние процедуры. С осознанием, что день прожит не зря. Просто лишний раз убедились, что защиту от дурака придумать можно - но только от дурака неизобретательного. И каждый из нас мысленно поблагодарил того человека, который помогал ему в сборке первого в его жизни компьютера.

Вот такая история. Будешь проходить мимо - занеси нам, пожалуйста, немного апельсинов и пару бананов. Да, и какую-нибудь звуковуху. И еще огнетушитель.


Спецвыпуск Xakep, номер #012, стр. 012-020-1, Проявка на халяву, или цифровухи против мыльниц

Проявка на халяву, или цифровухи против мыльниц

Чип и Дейл (illusionary@mail.ru)

Спецвыпуск Xakep, номер #012, стр. 012-020-1

Мыло версус Дигит

Здравствуй, братец! Уныло созерцаешь свой многотонный фотоальбом? Этот неуклюжий динозавр обречен на голодную смерть в топке мусоросжигательного завода. В массы сейчас с бешеной скоростью продвигается цифра. Монстры фото- и видеоиндустрии активно пропагандируют свои новации в области цифровых технологий, уделяя все меньше внимания старым аналоговым приборам, справедливо считая их пережитком прошлых лет. Более того, аналоговые девайсы в настоящее время все меньше привлекают внимание юзеров. Еще бы, управляться с цифровиками гораздо, в сотни раз, легче! Цифровухи "уделывают" мыльницы еще и тем, что последние обычно практически лишены каких-либо настроек и фич, кроме вспышки. При таких условиях каждая вторая фотография получается либо размытой (страдает фокусировка), либо с неправильной экспозицией (слишком яркая или слишком темная), либо с другими багами. Еще около 50% из меньшей "правильной" половины получаются плохими из-за фотографа, который глупо жмет на батон, не думая ни о чем. Итого: четверть хороших снимков, которые по закону бутерброда непременно станут плохими из-за печати и сканирования. Тебя устраивает такое положение вещей? Я думаю, что нет. В таком случае не пора ли двинуть за цифровушкой? И все снимки, помещенные на флеш-карту (это в цифровиках носитель инфы такой, вместо пленки), получатся превосходными, потому что "левые" ты тут же цинично потрешь. Кроме того, есть маза вскрыть твой потенциал фотографа по-настоящему. Ты сможешь пыхать фотиком по сторонам с космической скоростью, пока не сдохнут батарейки (пленки-то нет). А богатство настроек и довольно высокое качество аппарата помогут тебя бороться с разными досадными оплошностями. В общем, опыт будет расти термоядерно.

Девелоперы, ясный пень, уже сейчас переквалифицировались в управдомы и переползли на цифру. Сейчас уже все продвинутые челы измеряют фотоальбом не килограммами, а мегабайтами. Они, как известно, не подвержены коррозии, засухе, голоду, высокой влажности или воздействию прямого солнечного излучения.

О чем это я?

Точно не о сканере. Сканер не имеет к делу абсолютно никакого отношения. Он не избавит тебя от килограммов макулатуры, не позволит получить нужную фотографию в нужное время - тем более фоту, сделанную с пристойным качеством. На протяжении всей цепи "изображение > оптика > пленка > фотобумага > сканер > цифра" первоначальное изображение получает кучу искажений. Плюс - несовершенство условий фотографирования и настройки фотоаппарата. В результате через положенный срок (как правило, не меньше недели) и посредством приличной денежной суммы ты таки получаешь цифровой вариант отвратительного качества. В общем, Гейтс с ним, со сканером.

Выход есть!

Он только один: цифровая фотокамера, в народе известная как "цифровушка". Она не только с успехом заменит простой аналоговый фотоаппарат, но и позволит получить изображение зачастую лучшего качества, чем при использовании мыльницы. Кроме того, ты сможешь в любой момент сфотографировать то, что тебе надо (или что НЕ надо ;)), и спустя пару секунд увидеть изображение на экране монитора. И никаких нудных процедур с пленкой, печатью или сканированием! В любой момент ты нажимаешь на кнопку (а более продвинутые фотографы еще и настраивают камеру соответствующим образом) и получаешь фотографию. Хочешь - печатаешь на домашнем струйном принтере, хочешь - едешь в магазин с услугой "цифровая фотопечать", платишь от 5 до 10 рублей (тарифы везде разные) и любуешься картинкой, которая получится гораздо лучше, чем напечатанная стандартным способом (с пленки). И это реально и актуально уже сегодня!


Спецвыпуск Xakep, номер #012, стр. 012-020-2, Проявка на халяву, или цифровухи против мыльниц

Проявка на халяву, или цифровухи против мыльниц

Чип и Дейл (illusionary@mail.ru)

Спецвыпуск Xakep, номер #012, стр. 012-020-2

Доступность AND независимость

Простое сравнение: если раньше CDR-приводы были только у избранных богачей, то сейчас каждый второй обладатель PC записывает CDR- и CDRW-диски, приобретя перезаписывающий лазерный дисковод. Ситуация повторяется и с камерами: раньше никто даже и не мечтал о мегапиксельных аппаратах (это те, у которых разрешение в миллионах пикселей измеряется), а сейчас мегапиксельники стоят меньше 300 вечнозеленых, а магазины кишат двух- и трехмегапиксельными камерами, которые только и знают, что дешевеют и дешевеют. А народ их (так же, как в свое время CD-RW дисководы и мобильники) все покупает и покупает, фотографирует ими все подряд и без принудительных процедур с проявкой и печатью любуется снимками. У некоторых даже дух папарацци просыпается: щелкают всех и вся в самых неимоверных ситуациях и позах :).

Ложка вшей в банку с изюмом

При всех своих плюсах цифровые фотики стыдливо прячут от покупателя и несколько минусов. К сожалению, оптика у цифровиков местами слабенькая, хотя и лучше, чем у мыльниц. Аппараты с крутой оптикой, тем более "зеркалки", стоят уже значительно больше 300 уев. Таких чудес, как на отечественном "Зените", ты уж точно не достигнешь. Цифровики с жуткими темпами жрут батарейки и аккумуляторы: ведь нужно питать жидкокристаллический дисплей, механику и прочие радости. Так что если идешь в поход, бери с собой мешок батареек или генератор ;). Или будешь долго искать, куда бы воткнуть... вилочку. Вполне возможно, что тебе также придется разгрузиться на дополнительную флеш-карту, разные проводки и прочие примочки, которые стоят недешево. Готовь лопатник к серьезным финансовым потрясениям :(.

Что изучает физика?

Принцип действия огромного деревянного многопудового фотоаппарата не многим отличается от обычной мыльницы. Чтобы не грузить тебя терминами, говорю по-русски: линза уменьшает изображение, и оно остается на пленке. Принцип цифрового фотоаппарата аналогичен: линза уменьшает картинку, и она остается на фотоэлементах, считывается и попадает на флеш-карту.

Пленка VS матрица

Часто говорят, что мыльницы лучше трехмегапиксельников. Это правда: пленка содержит более 3 миллионов зерен. Чем больше зерен, тем лучше качество или, другими словами, разрешение. Когда количество фотоэлементов превзойдет количество зерен, разрешение цифровиков окажется больше. Но это всего один параметр. У мыльниц их больше и нет, а вот у наших дорогих... мда... цифровых друзей их до фига. И светочувствительность, и экспозиция (с приоритетом выдержки или диафрагмы), и ручная фокусировка, и цветокоррекция, и баланс белого, и зум - и еще столько всего того, чего ты, наверное, еще и не знаешь... Ну и не парься, а просто поприкалывайся с параметрами. Причем, это все входит в настройки обычных камер, а не профессиональных. Плюс к этому возможность без промедления получить нужное изображение на экране монитора. Все это позволяет обставить любого чудака, купившего пленочную мыльницу.


Спецвыпуск Xakep, номер #012, стр. 012-020-3, Проявка на халяву, или цифровухи против мыльниц

Проявка на халяву, или цифровухи против мыльниц

Чип и Дейл (illusionary@mail.ru)

Спецвыпуск Xakep, номер #012, стр. 012-020-3

К вопросу о качестве

Какое разрешение тебе нужно от камеры? 640х480? 1024х768? Для сайта - 320х240? Трехмегапиксельники фотографируют с разрешением 2048х1536. Чтобы тебе реально ощутить размер такого изображения на мониторе, предлагаю включить сейчас разрешение 1024х768 (надеюсь, монитор твой способен на такое) и представить, что у тебя четыре монитора с таким разрешением! Четыре монитора - вот размер одного кадра! Если твое творчество так и останется на мониторе, то 1024х768 тебе вполне хватит, такому разрешению соответствуют лучшие веб-камеры (от 150 долларов) и фотокамеры попроще (до 300 долларов). Если тебе нужна полиграфия, то тут дело обстоит серьезнее. Для 10х15 см изображений трехмегапиксельной камеры хватит с избытком - ты получишь разрешение больше 300 dpi (клякс на дюйм). С А4 дело обстоит уже немного серьезнее - 185 dpi. Но этого и того хватит, чтобы ты не смог определить, сделано ли изображение на страницах журнала суперпрофессионалом с трехсотпудовым аппаратом или простым трехмегапиксельником =). Мыльница же не может даже обеспечить качественное 10х15 изображение за неимением каких-либо настроек, печать на бумаге (особенно матовой) наложит на фотографию свой отпечаток, а сканер довершит процесс добавления жутких искажений.

Немного терминов

Матрица, как уже упоминалось, - куча мелких фотоэлементов. Заменяет кадр пленки. Аналогично, фотоэлемент - заменитель зерна пленки. То есть матрица - это то, куда попадает изображение. Разница в том, что пленка засвечивается, и изображение на ней так и остается (нужен новый кадр). А в цифровиках с фотоэлементов матрицы считывается сигнал, расшифровывается и записывается на флеш-карту в цифре. Светить на матрицу можно бесконечно.

Экспозиция - это настройка камеры под определенное освещение. Ведь понятно, что освещение в ясный солнечный день на улице не сравнится с освещением темной комнаты. В камерах есть как автоэкспозиция, так и ручная (с тремя режимами). Автоэкспозиция на основании данных электроники выбирает нужные значения выдержки и диафрагмы. При большой выдержке на фотоэлементы попадает больше света, но движущиеся объекты могут получиться размытыми, а изменение значения диафрагмы позволяет регулировать яркость и глубину резкости (расстояние, на котором предметы будут изображены с максимальной резкостью). Ручные режимы включают в себя: приоритет диафрагмы, приоритет выдержки, полностью ручной режим. В режиме приоритета одного из экспозиционных параметров один из них ставится ручками, а другой устанавливается по воле автоматики. Полностью ручной режим требует принудительного введения параметров экспозиции. Одним словом, экспозиция позволяет камере подстроиться под соответствующее освещение, в то время как мыльницы подстроены под среднее значение и исправляют все остальные с помощью банальной вспышки.


Спецвыпуск Xakep, номер #012, стр. 012-020-4, Проявка на халяву, или цифровухи против мыльниц

Проявка на халяву, или цифровухи против мыльниц

Чип и Дейл (illusionary@mail.ru)

Спецвыпуск Xakep, номер #012, стр. 012-020-4

Экспопрограммы - зашитые в память системы параметры экспозиции. Например, портрет, ночь, пейзаж, солнце, комната и т.п.

Баланс белого - изменение цветовой температуры. Ты можешь понять, что такое цветовая температура, если начнешь изменять ее значения в настройках монитора. Или просто посмотри на белый лист бумаги, положенный под лучи яркого солнца, а потом положи его под лампу накаливания. Во втором случае лист тебе покажется желтым. Изменяемый баланс белого позволяет тебе подстраиваться под нужную цветовую температуру. Мыльницы, как всегда, долбят баг вспышкой...

Цветокоррекция - ручное или автоматическое изменение параметров яркости, контрастности, света и насыщенности. Очень полезная функция - вдобавок к экспозиции и балансу позволяет подогнать изображение под идеальный вариант (можно сделать это и в Фотошопе, но тогда потеряются важные детали).

Светочувствительность - чувствительность элементов. То же самое, что и пленка "100", "200" или "400", соответствующая дневному свету, пасмурному дню или сложным условиям фотографирования. Фотокамера позволяет менять чувствительность. Обычно она варьируется от 100 до 400, но часто увеличение чувствительности приводит к появлению лишних шумов (это связано с малым размером каждого светочувствительного элемента). Лечится другими настройками.

Динамический диапазон - детализация в свете и тенях. Другими словами, "почему памятник Жукову получается черным на фоне яркого неба". Обычно производители камер не приводят значение динамического диапазона. Но тебе просто следует знать, что не надо на одном снимке совмещать яркий и темный объекты. Твой глаз, кстати, тоже имеет определенный динамический диапазон, и он тоже памятник Жукову на фоне яркого неба видит темным.

Фокусировка - наведение на резкость. Чтобы объекты на расстоянии 1 м или 1 км получались резкими, тебе нужно установить нужную фокусировку. Твой глаз тоже фокусируется на нужное расстояние - в этом ему помогает хрусталик. Тебе должно быть известно, что одновременно фотографировать изображение на расстоянии 10 см и 10 км нельзя - одно из них получится размытым. Кстати, к слову о диафрагме - ее значения позволяют не только регулировать экспозицию, но и регулировать глубину резкости, то есть ты можешь сделать так, чтобы два объекта на расстоянии 5 м и 10 м были резкими, а можешь сделать резким только один из них.

Макросъемка - съемка на близком расстоянии. Может пригодиться для фотографирования цветов, букашек-таракашек и многих других объектов. На деле 50% фотографируется с использованием макросъемки.

Зум - увеличение изображения. Есть оптический - без потери качества, и цифровой - с потерей качества. Он 100% пригодится тебе при съемке. Зум - это очень важная вещь, и чем больше оптический зум - тем лучше, при покупке камеры его значением пренебрегать нельзя.


Спецвыпуск Xakep, номер #012, стр. 012-020-5, Проявка на халяву, или цифровухи против мыльниц

Проявка на халяву, или цифровухи против мыльниц

Чип и Дейл (illusionary@mail.ru)

Спецвыпуск Xakep, номер #012, стр. 012-020-5

Видоискатель - оптический видоискатель - это такое маленькое окошко с линзами, через которое смотрят на обычной мыльнице, чтобы посмотреть на то, что получится в итоге. Как правило, в итоге получается совсем не то, на что смотришь. Поэтому современные цифровые фотоаппараты укомплектованы ЖК-дисплеем (а еще ведь и по меню удобнее ползать, видя на экране его пункты), а некоторые еще и зеркальным видоискателем. Пока ты компонуешь кадр, зеркало отражает свет, прошедший через объектив, и он попадает тебе в глаз, а когда нажимаешь на кнопку - зеркало убирается, и свет попадает на фотоэлементы. Надо сказать, зеркальные камеры - это ВЕЩЬ :)).

Обзор камер: галопом по Европам

Теперь быстро кинем глазными яблоками в наиболее интересных представителей актуального рынка цифровых фотокамер.

Nikon CoolPix 880

Матрица - 3,34 млн. пикселей

Максимальное разрешение - 2048х1536

Размер - 99х75х53 мм

Вес - 275 г без батареи

Питание - 2CR5, Li-Ion аккумулятор

ЖК-дисплей - 4,6 см

Формат записи - JPEG, TIFF

Тип носителя - CompactFlash

Интерфейс - USB, последовательный порт, видеовыход

Оптический зум - 2,5х

Цена - $590 (www.digitizer.ru)

Комментарий: камера великолепна для профессионалов и для тебя =) - она подойдет твоим глазам по качеству и твоим рукам по количеству настроек - в ней есть все необходимое. Обидно только, что на фоне стандартного 3-кратного оптического зума она обладает 2,5-кратным :)). Да! А подойдет она твоему карману по цене? Еще недорогой считается...

Nikon CoolPix 995

Матрица - 3,34 млн. пикселей

Максимальное разрешение - 2048х1536

Размер - 149х79х38

Вес - 450 г с батареей

Питание - 4 элемента АА

ЖК-дисплей - 4,6 см

Формат записи - JPEG, TIFF

Тип носителя - CompactFlash

Интерфейс - USB, последовательный порт, видеовыход

Оптический зум - 3х

Цена - $813 (www.wstore.ru)

Комментарий - от 880-ой модели отличается лишь дизайном корпуса. Несмотря на то, что все воспринимают поворотный корпус как уникально креативный дизайнерский шаг, позволяющий расширить возможности фотографа, мы не нашли в нем ничего особенного. Стоит ли она своих денег по сравнению с 880-ой моделью?

Olympus Camedia E-10

Матрица - 4 млн. пикселей

Максимальное разрешение - 2240х1680

Размер - 128х103х161

Вес - 1050 г без батареи

Питание - 4 элемента АА

ЖК-дисплей - 4,6 см

Формат записи - JPEG, TIFF, RAW

Тип носителя - SmartMedia, CompactFlash

Интерфейс - USB, видеовыход

Оптический зум - 4х

Цена - $1036 (www.nix.ru)

Комментарий - эта камера по-настоящему заслужила своих эпитетов "первая зеркальная цифровая профессиональная камера". Она имеет недюжинные возможности по контролю качества. Один вес говорит о многом... 10 подходов по 100 раз - и в тренажерный зал ходить не надо :).

Pentax EI-3000

Матрица - 3,46 млн. пикселей

Максимальное разрешение - 2000х1600

Размер - 143х90х105

Питание - Li-Ion аккумулятор

ЖК-дисплей - 5,1

Формат записи - JPEG, TIFF, DPOF

Тип носителя - CompactFlash

Интерфейс - USB, инфракрасный порт, видеовыход.

Цена: раз на раз не приходится (везде, где мы искали, была out of stock)


Спецвыпуск Xakep, номер #012, стр. 012-020-6, Проявка на халяву, или цифровухи против мыльниц

Проявка на халяву, или цифровухи против мыльниц

Чип и Дейл (illusionary@mail.ru)

Спецвыпуск Xakep, номер #012, стр. 012-020-6

Комментарий - Pentax смотрит на мир своими глазами. Кроме того, что камера сделана зеркальной, а разрешение составляет 2000х1600 пикселей, а не обычные 2048х1536, аппарат имеет самый большой в обзоре ЖК-экран и инфракрасный порт, а питание осуществляется не 4 батареями АА, а Li-Ion аккумулятором.

Casio QV-3500EX

Матрица - 3,34 млн. пикселей

Максимальное разрешение - 2048х1536

Размер - 134х80х58

Вес - 360 г с батареей

Питание - 4 элемента АА

ЖК-дисплей - 3,8 см

Формат записи - JPEG, TIFF

Тип носителя - CompactFlash

Интерфейс - USB, последовательный порт, видеовыход

Оптический зум - 3х

Цена - $535 (www.planetashop.ru)

Комментарий: модель хороша всем - и съемкой, и ценой... Если нужна хорошая камера за разумные деньги - пожалуйста. Кроме того, она прекрасно работает с IBM Microdrive (это такой маленький винт от IBM).

Epson PhotoPC 3000Z

Матрица - 3,34 млн. пикселей

Максимальное разрешение - 2048х1536 + режимы для идиотов

Размер - 107х88х65 мм

Вес - 480 г с батареей

Питание - 4 элемента АА

ЖК-дисплей - 3,8 см

Формат записи - JPEG, TIFF

Тип носителя - CompactFlash

Интерфейс - USB, последовательный порт, видеовыход

Оптический зум - 3х

Цена - $630 (www.adelon.ru)

Комментарий: с виду - обычная камера, но режим HyPict поражает своей тупостью и излишеством. Ладно еще - интерполяционное разрешение 2544х1904, но разрешение 2544х952 действительно заставляет задуматься - а кому это надо? Фотографировать высоких дистрофиков, которые в обычный кадр не помещаются?

Sony Cybershot DSC-F505V

Матрица - 3,34 млн. пикселей

Максимальное разрешение - 2048х1536

ЖК-дисплей - 4,6 см

Формат записи - JPEG, TIFF

Тип носителя - Memory Stick

Интерфейс - USB, видеовыход

Оптический зум - 5х

Цена - $795 (palmshop.ru)

Комментарий - внешний вид впечатляет, но если копать глубже, то некоторые факторы мешают купить эту камеру. 5-кратное увеличение, это, несомненно, хорошо, но цена...

Minolta DIMAGE 7

Матрица - 5,24 млн. пикселей

Максимальное разрешение - 2560х1920

Размер 116x90x112 мм

Вес - 505 г без батареи, 600 - полный комплект

Питание - 4 элемента АА/Li-Ion аккумулятор

ЖК-дисплей - 4,6 см

Формат записи - TIFF, JPEG, RAW, DCF, DPOF

Тип носителя - CompactFlash I/II

Интерфейс - USB, видеовыход

Оптический зум - 7х

Цена - $1340 (www.comp2russia.com)

Комментарий - разработчики фирмы Minolta преодолевают барьер трехмегапиксельных камер и начинают новую эру в разработке цифровой техники. Камера имеет просто целую кучу возможностей, по всем параметрам превосходит каждую камеру из всех имеющихся в обзоре - потому она и лучшая (разве что макрорежим начинается с 13 см - это не лучший показатель).

Canon PowerShot S20

Матрица - 3,34 млн. пикселей

Максимальное разрешение - 2048х1536

Размер - 106х70х34

Вес - 320 г

Питание - Ni-MH аккумулятор

ЖК-дисплей - 4,6 см

Формат записи - JPEG

Тип носителя - CompactFlash

Интерфейс - USB, последовательный порт, видеовыход

Цена - $550 (www.comp2russia.com)

Комментарий - в целом камера укладывается в стандарты, но купит ее только полуслепой слон, потому что присутствуют тааакие недостатки... Конечно, режим склейки кадров (то есть возможность сфотографировать два раза и склеить это в один) и маленький размер - это несомненные плюсы, но формат JPEG и отсутствие некоторых настроек - это уже реальный минус, который не отпугнет только самого непридирчивого покупателя, способного отдать деньги неведомо за что. Рекомендую любителям мыльниц!


Спецвыпуск Xakep, номер #012, стр. 012-020-7, Проявка на халяву, или цифровухи против мыльниц

Проявка на халяву, или цифровухи против мыльниц

Чип и Дейл (illusionary@mail.ru)

Спецвыпуск Xakep, номер #012, стр. 012-020-7

НАШ выбор

Мы тут посоветовались и решили сделать тебе подбор камер в разных ценовых категориях.

В категории веб-камер и цифровушек низшей категории победителем, по нашему весьма нескромному мнению, стала камера D-Link DSC-350, имеющая 420000 пиксельную матрицу и максимальное разрешение 640х480 (интерполяционное 1024х768). В камере есть режим макросъемки с 4-х см, возможность съемки видео, флеш-карта на 8 мб (более 200 фотографий при разрешении 640х480), USB-интерфейс, низкое энергопотребление и маленькие габариты. Свою цену она оправдывает полностью. В общем, безоговорочная победа - особенно, если учесть ее цену ВСЕГО в 160 хвойных вечнозеленых. Вне конкуренции.

В следующей весовой категории 3-мегапиксельных камер мы призадумались... Кто же лучше - Casio QV-3500EX за 530 долларов или Nikon CoolPix 880 за 600 уев? Обе камеры имеют все необходимые настройки и кучу дополнительных прибамбасов. Кроме того, Nikon поражает малыми размерами и, при этом, великолепным качеством фотографии. В общем, выбор за тобой. Если у тебя есть возможность купить какую-нибудь из этих камер, то ты будешь до конца дней своих восторгаться правильностью своего выбора.

Если кошелек позволяет тебе претендовать на личного супертяжеловеса, то бери Olympus E-10, лучшую из доступных (существуют и не совсем доступные Nikon D1 или Fuji FinePix S1 Pro) камер на момент написания статьи, или Minolta DIMAGE 7 (ее цена по сравнению с E-10 еще немного кусается - но когда ты будешь читать эти строки, она, видимо, упадет).

Рефрен

Цены падают, но время не ждет, технологии несутся вперед со скоростью истребителя. На рынок вывалилось уже несколько поколений цифровух, и уже сейчас можно найти реально крутое для твоих целей качество за вполне подъемную сумму.

А если суммы нет? Будь проще! Подожди немного. Есть маза, что к новому году ты сможешь купить себе цифровуху приличного качества уже в пределах 100 у.е. Так что терпение, друг мой, терпение...


Спецвыпуск Xakep, номер #012, стр. 012-025-1, Х - конкурс!

Х - конкурс!

Спецвыпуск Xakep, номер #012, стр. 012-025-1

Дарова, перец! Ты держишь в руках новый СПЕЦ, и это значит, что пришло время нового СПЕЦ-конкурса. Ответь на все вопросы, напиши нам письмо на spec@real.xakep.ru, окажись одним из первых - и ты можешь стать победителем! И выиграть кучу самых разных призов от нашего журнала - и не только...

1. Кто такой "гаер"?

- муж Гаечки

- внук Гаечки

- площадный шут

- недобитый фраер

2. Что значит "охинить"?

- покрыть ровным слоем хины

- обругать

- обласкать

- накормить и дать денег на дорогу

3. "Варвуля" - это ...

- ловец вармаглотов

- изобретатель таблицы Менделеева

- сорт яблок

- утренняя чашка кофе по-турецки

4. Что такое "едикуль"?

- дамская сумочка для еды

- название древнего замка

- китаец-велорикша

- небольшой пакет еды в дорогу

5. "Эхнатон" - это ...

- египетский фараон

- команда музыканту играть на тон выше

- четвертая струна на семицветной гитаре

- сухой остаток при брожении бродила

6. Кто такая "нимфа"?

- русалка-без-головы

- русалка-с-головой

- голова-без-русалки

- небольшой австралийский попугай

7. Что такое "вагалица"?

- медленно идти, ползти

- быстро перекатываться с бока на бок

- листок слюды

- пакет слюны

8. Кто такой "равендук"?

- сундук раввина

- первооткрыватель колеса

- толстая парусина

- тонкая древесина

9. Что означает глагол "орунеть"?

- ласкательно-уменьшительное от "охренеть"

- покрыться шерстью

- покрыться шерстью и уйти в монастырь

- получить доступ в РУНЕТ

10. Что такое "стуло"?

- недоделанный стул

- переделанный стул

- просто стул

- жидкий стул

Вот и все вопросы, собственно. Надеемся, они не показались тебе слишком сложными. Пиши - адрес знаешь ;-).

Содержание


Спецвыпуск Xakep, номер #012, стр. 012-026-1, Digital ElectronicZ: основы

Digital ElectronicZ: основы

Спецвыпуск Xakep, номер #012, стр. 012-026-1

Плод твоего больного воображения aka Mr. False(mr_false@xakep.ru)

Здравствуй опять, овощ хрустящий =)! Я надеюсь, ты уже прочитал большую часть спеца, и успел заценить всяческие девайсы. "Да-а-ааа..., - скажешь ты, - Девайсы, - это круто!" Но ты не задавался мыслью, как же это угрюмое нагромождение микросхем может правильно работать? Да, умные дядьки-инженеры постарались на славу! Впрочем, обо всем по порядку.

Дела давно минувших дней.

Собрались однажды оные челы пивка попить. И, видимо, после очередного контейнера их потянуло на умные мысли. Подумали они, подумали, и удумали следующую фичу: а что, если мы возьмем, да и определим некое пороговое напряжение? Где? Неважно! На контакте. Ну вот: и будем считать, если на этом самом контакте уровень напряжения выше порогового, то пусть сигнал эквивалентен логической единице, а если ниже - то логическому нолю. Мысль им эта понравилась, и они решили взяться за нее всерьез. И, веришь ли, придумали столько разных фич... Это направление в схемотехнике получило название "Цифровое" - оно фактически оперирует не с сигналами, а с цифрами, представленными ими, следуя некой логике, о которой я тебе расскажу. Но прежде чем ты прочтешь все нижеследующее, хочу чтоб ты знал: ВСЕ на свете компьютеры - абсолютно все - работают именно на основе тех логик, о которых я расскажу.

Железная логика

Обработка сигналов идет в так называемых логических элементах, кои являются фундаментом всей цифровой электроники. На них построено практически ВСЕ! И твой любимый Атлон тоже! Вся фишка этих элементов в том, что логика их работы предельно проста. Как 2*2<=31337. У всех элементов есть входы и выходы. Ты подаешь входные данные, а они тебе возвращают результат после логических операций. Составление цифровых схем - это, получается, своеобразный кодинг, только паяльником. Обычно все цифровые элементы (в т.ч. и логические) пихают в микросхемы: так они работают быстрее и надежнее. Но - обо всем по порядку.

Логическое "И"

На схемах изображается как прямоугольник со значком "&" внутри. Контакты обозначаются, как у всех элементов, входы - слева, выход - справа. Так принято. Выполняют функцию логического "И" от входных сигналов. Это значит, что каждой паре сигналов входов соответствует какой-то сигнал выхода. Такое сопоставление входных и выходных принято записывать в так называемую таблицу истинности, которая небрежно намалевана мною на имаге =). Для элемента "и" можно записать, что выходной сигнал равен единице только в случае, когда на всех входах единица. Ноль - в любом противном случае.

Кстати, входов не обязательно должно быть именно два, их бывает различное количество. В таких случаях, когда надо обозначить число входов, например, элемента "И", делается такая запись: "Элемент nИ", где n - число входовых контактов (Например: "Элемент 4И"). Если число входов явно не указано, то принято считать, что их кастрировали до двух. Пример микросхемы с элементами: К155ЛИ1. Да, и еще: обычно в микросхеме находится несколько логических элементов - например, пресловутая ЛИ1 содержит 4 элемента И. Применяется элемент, в основном, в схемах умножения (это, к сожалению, не влезет в статью). Видно явное сходство: если хотя бы один множитель = 0, то и произведение = 0.


Спецвыпуск Xakep, номер #012, стр. 012-026-2, Digital ElectronicZ: основы

Digital ElectronicZ: основы

Спецвыпуск Xakep, номер #012, стр. 012-026-2

Логическое "ИЛИ"

На схемах выглядит как тот же прямоугольник, но на сей раз в него врисована единичка. Как ты уже догадался, элемент выполняет функцию логического "ИЛИ". Это значит, что на выходе будет ноль только в случае, если на всех входах - ноль, и единица - в противном случае.

Все, что было справедливо для элемента "И" по поводу количества входов, верно и для "ИЛИ". Микросхема: К155ЛЛ1, содержит 4 элемента.

Логическое "НЕ"

Инвертор. Имеет один вход и один выход. Если на входе - 1, то на выходе 0, и наоборот. На схемах изображается так же, как и элемент "ИЛИ", только у выхода имеется небольшой кружок.

Пример: К155ЛН1. Содержит 6 элементов.

Логическое "Исключающее ИЛИ"

Это еще один логический элемент - правда, не такой распространенный.

Изображается очень хитрым образом для базовых элементов. Является нестандартным элементом, о чем свидетельствует отсутствие специальной серии микросхем. Они идут с маркировкой "ЛП" - прочие.

Логика работы следующая: если на все входы поданы одинаковые значения, то на выходе будет 0, и 1 - в противном случае. Пример: К155ЛП5, содержит 4 элемента.

Бывают, кстати, и совмещенные элементы. Например "И-НЕ" - элемент представляет собой обычный "И", выход которого инвертируется. Изображается сие чудо так же, как и элемент "И", только у выхода есть кружок. Бывают еще такие звери, как "6И-ИЛИ-НЕ". Да, а твоя любимая микросхема К155ЛА3 на поверку является сборкой элементов "2И-НЕ".

Триггеры

У всех логических элементов состояние на выходах напрямую зависит от состояния на входах. Но есть и такая белиберда, у которой состояние на выходах зависит еще и от самого себя. Имя сему - триггеры (trigger - защелка). Схема триггера показана на рисунке.

Заметь, что здесь имеет место быть такая фигня, как обратные связи - выходы каждого из элементов "ИЛИ-НЕ", составляющих триггер, соединены со входами этих же элементов, но... Нетяжко заметить, что состояния на выходах все время противоположны (отсюда и обозначение второго выхода - Q с палкой сверху, обозначает, что на этом выходе значение, противоположное Q. Еще можно изобразить как !Q ("не-ку")). Два входа триггера имеют названия R и S (Set и Reset - установка и сброс), отчего сам триггер получил название RS-триггер. Теперь давай разберемся, как же эта бубырня может работать. Но это будет сложно, готовься. Пусть изначально Q = 1, !Q = 0, а на R и S ничего не подано (на самом деле значения Q и !Q возникают случайным образом). Подадим импульс S = 1, тогда Q = 1 и !Q = 0. Теперь подадим R = 1 и получим: Q = 0, !Q = 1. Таким образом триггер является элементарной ячейкой памяти, которая может хранить 1 бит данных, хотя он не так часто применяется именно как ячейка памяти. Вообще говоря, способов его применения - великое множество, легче скорее написать, куда его засунуть нельзя ;). Но вся память, которая применяется в компах, в принципе, построена именно на триггерах! Ну, а одним из более-менее приземленных способов применения триггера является устранение так называемого "эффекта дребезга контактов". Суть этого явления в следующем: вот у тебя есть некая цапа, и когда ты на нее давишь, то приводишь в действие механические части, которые уже в свою очередь замыкают контакты. Баг зарыт именно тут: при замыкании контактов могут проскочить несколько левых импульсов длиной в наносекунды, и, если у тебя в схеме идет подсчет количества нажатий на клавишу, то будут подсчитаны и левые импульсы. А дабы этого избежать, берут и ставят между пимпой и самим девайсом RS-триггер - так, как показано на имаге.


Спецвыпуск Xakep, номер #012, стр. 012-026-3, Digital ElectronicZ: основы

Digital ElectronicZ: основы

Спецвыпуск Xakep, номер #012, стр. 012-026-3

Помимо RS-триггеров существуют еще и другие: Т-триггер, который построен на основе RS-триггера, и триггер Шмитта, который принципиально отличается по как по устройству, так и по принципу работы. Устроен он следующим образом:

Нехитрая конструкция, неправда ли? Вся ее фича в следующем: вот начинаем мы плавно повышать входное напряжение с нуля, и на каком-то определенном уровне выходной сигнал резко переключается с низкого уровня на высокий (иначе - с 0 на 1). Затем мы понижаем напряжение, и, на определенном уровне (может быть и на другом), у нас происходит обратный скачок - с 1 до 0. Такое творчество называется формированием прямоугольных импульсов из напряжения произвольной формы. Именно для этого и используют триггер Шмитта. Примеры микросхем: RS-триггер - К555ТР2, Триггер Шмитта - К155ТЛ2.

Таковы основы

За сим я вынужден закруглиться. Может, когда-нибудь в будущем я расскажу тебе о более продвинутых штуковинах, а пока... Люби бабушек, уважай девушек.. То есть наоборот: люби девушек, уважай бабушек. И, если что не понятно - не пиши, меня все равно не существует... =)


Спецвыпуск Xakep, номер #012, стр. 012-032-1, Клава компьютерная, не резиновая

Клава компьютерная, не резиновая

Mad Doctor (maddoc@online.ru)

Спецвыпуск Xakep, номер #012, стр. 012-032-1

Конечно, конечно. Компьютер может быть и без клавиатуры. Чудная машинка под названием MITS Altair 8800 не имела в своем составе ни клавы, ни мышки, ни дисплея. И долговременной памяти тоже не было. Что интересно, этот агрегат даже неплохо покупали... Но с момента его выпуска прошло почти тридцать лет, и за эти годы просто необходимым компонентом компа стала клавиатура. Вот о ней сегодня и пойдет у нас речь.

Сейчас уже невозможно сказать точно, кто первый пришел к мысли снабдить компьютеры клавой. Вместе с тем, эту идею (при всей внешней простоте) вполне можно назвать гениальной - вспомни только, что изначально общение человека и машины проходило с помощью переключения ручек и тумблеров, потом появились перфокарты - и только потом к компам стали присоединять другие устройства ввода/вывода. Возможно, что эта идея появилась по аналогии с пишущей машинкой - но мы не будем долго говорить об этом. Давай лучше посмотрим на то, как развивалась эта идея с течением времени, и к чему привела в настоящем.

Довольно долгое время выпускалось множество моделей, в которых клавиатура выполняла функции современного системного блока. То есть, вся начинка агрегата находилась под клавишами. Здесь и первые модели Atari, и Schneider Euro PC, и Commodore 64C (и еще много машин этого семейства), а еще – советские "Компаньон" и «Электроника БК 0010-01». Большинство этих клавиатур несло на борту тот же набор клавиш, что и у печатной машинки. Потом появился расширенный вариант клавы - насколько мне известно, первой была Apple со своим Macintosh Plus.

Дальше производителей компьютеров понесло, и каждая компания выпускала свой вариант клавиатуры. Общим было только одно - практически все выпускавшиеся клавиатуры для персональных компьютеров обладали раскладкой QWERTY - если ты посмотришь на верхний буквенный ряд своей клавы, то с левой стороны именно такую последовательность и увидишь.

Я намеренно опускаю большую часть истории компьютерных клавиатур. Самое интересное уже было. А про то, что на свете существовали еще пленочные и всякие другие клавиатуры, ты можешь узнать и сам - если захочешь, конечно. Хотя, может быть, мне просто очень не хочется даже вспоминать о них - два года обучения работе за компьютером БК-0010Ш именно с пленочной клавиатурой и возможностью загрузки программ с магнитофонных кассет не могли пройти бесследно для моей психики. Даже сейчас я помню наши споры: что звучит более музыкально - загрузка бейсика в машину, или запись программы на кассету. Так или иначе, давай посмотрим на многообразие доступных нам сегодня клавиатур.

FrogPad - клава для одной руки

Эта маленькая клавиатурка предназначена, в общем-то, не совсем для компов – скорее, речь тут идет о палм-компьютерах, мобильных телефонах и прочих ПДАашках. Стоит отметить, что это не просто упрощенный вариант клавиатуры (на которой, тем не менее, есть все клавиши) – появлению девайса предшествовали годы научных изысканий, в процессе которых было выяснено, что в восьмидесяти шести процентах печатных документов употребляется всего 15 букв. Соответственно, клавиши на этом девайсе расположены по частоте их употребления и по легкости перехода от одной буквы к другой. Разработчики обещают значительный рост скорости ввода информации с помощью этой штуки - и это произойдет так быстро, как только пользователь научится с ней правильно обращаться. Мне лично верится с трудом, но... кто знает?


Спецвыпуск Xakep, номер #012, стр. 012-032-2, Клава компьютерная, не резиновая

Клава компьютерная, не резиновая

Mad Doctor (maddoc@online.ru)

Спецвыпуск Xakep, номер #012, стр. 012-032-2

Клава для настоящих русских

Как ты знаешь, в России раньше была прекрасная традиция - вечерами в деревне после совместного чаепития все выходили на улицу, и там в большом кругу пели, плясали и играли на гармони. Очень приятно, что эта традиция нашла свое продолжение - теперь выпускается клавиатура в виде гармони (трудно представить? А факт!). На ней нужно работать двумя руками - но утверждается, что руки так устают намного меньше, и к тому же снижается риск заболеть артритом (заболевание суставов такое, довольно неприятная вещь).

Эргономика, блин. Под винды настроена.

Новый вид клавиатур появился относительно недавно - это клавы, заранее заточенные под определенные операционные системы. Догадайся-ка с трех раз, какая ОС у нас самая распространенная? Вот-вот, она самая. И теперь уже никто не удивляется, увидев на прилавке магазина девайс с кнопочками, обозначенными как "Пуск", "Свойства" и даже "Power" или "Sleep". По идее, две последние кнопочки из перечисленных дают возможность работать с питанием напрямую с клавы - но вот я таких систем в действии пока что не видел. Ну, а такие кнопки, как "Пуск", могут как серьезно облегчить тебе жизнь, так и серьезно ее осложнить (случайное нажатие на ту же кнопку в сеансе ДОСа приводит к серьезному приступу задумчивости у машины, во время которого она грозно шуршит винтом). В общем, знаю я людей, которые отказались от таких заморочек и поставили себе простые старые клавы - когда винды еще назывались "оболочкой дешевой", и никого это не удивляло и не обламывало. Еще к недостаткам таких эргономичных клавиатур относится более высокая цена. Один раз-то купить такую, может, и не жалко - но вот не любят они кофе и пиво, хоть тресни... А раз в месяц тратиться на такое чудо - нет уж, уволь...

Эта клава для работы требует батарейки

Вот еще вариант клавиатуры. Вся она из себя такая стандартная, вот только проводок у нее оторвался. И общается она с компом с помощью инфракрасных лучей. Соответственно, требует питания (две пальчиковые батарейки) - чтобы было чем излучать. Можно работать лежа на диване - если, конечно, тебе зрение и подружка позволяют.

Просто и почти без наворотов

Примерно такая клава подключена к моей машине. Здесь все просто, но со вкусом. Никакой тебе эргономики, никакой инфракрасности. Но - все работает. Клавиши виндов здесь, правда, присутствуют – но, в общем, не мешают. "Enter", опять же, нормального размера - сразу чувствуется, где здесь "Ввод" ;-). Подключается через стандартный разъем, или через PS/2 – по вкусу.

А здесь еще и мультимедиа

Вот еще экземпляр - тоже беспроводная (радио!) мультимедийная клава. Требует двух батареек АА, работает на расстоянии до двух метров от компа, снабжена буттонами управления мультимедиа. Чувствуется возврат к истокам - осталось туда только материнку с камнем и мозгами запихать. И получится у нас обновленный БК 0010-01 :-). Продается в комплекте с радио-мышкой =).


Спецвыпуск Xakep, номер #012, стр. 012-032-3, Клава компьютерная, не резиновая

Клава компьютерная, не резиновая

Mad Doctor (maddoc@online.ru)

Спецвыпуск Xakep, номер #012, стр. 012-032-3

Размер имеет значение...

Вот такой вариант клавиатуры выпускается фирмой MALTRON для людей с ослабленными руками. Разработчики убеждают, что здесь требуется меньше усилий для нажатий каждой клавиши. К тому же, каждая из них имеет больший, чем обычно, размер, так как предназначена еще и для людей с ослабленным зрением. Для них же - большие яркие индикаторы, дополнительный пробел, возможность легкого набора комбинаций клавиш - существует режим, при котором нажатая и отпущенная клавиша считается удерживаемой в течение определенного времени - и не надо играть в нового русского, стараясь одной рукой набрать "левый Ctrl" + "F12". Кроме того, позволяет использовать не только QWERTY, но, на выбор, еще и так называемую FOU (Frequency of Use - частота использования) - раскладку.

Еще раз для одной руки

Этот девайс выпускается для тех, кто вынужден пользоваться одной рукой для работы с машиной – причем, есть модификации как для левой, так и для правой руки. Опять же - результат долгих научных разработок. И рука должна уставать меньше, и скорость печати снижаться не должна. Требует для освоения каких-то двадцати часов, после чего пользователь обычно достигает серьезной скорости печати: 60 слов в минуту. Слушай, тебе нигде не попадались материнки с двумя клавиатурными входами? А то так глядишь: 60 слов одной рукой, 60 второй - и пойдет дело споро и с песнями...

Писк эргономики и цены

Смотришь на фотку и все-все понимаешь. Понятно, чего здесь обещают разработчики? Если вкратце - работа с такой клавой будет восприниматься тобойс таким же наслаждением и приятственными чувствами, как... ну, тут у каждого свое. После знакомства с осликом Дэнечки мои сравнения главред безжалостно убирает из всех статей, так что не буду даже нарываться. В общем, при создании этой клавиатуры учитывалось абсолютно все - и разная длина пальцев, и наиболее удобное положение рук, и... все учитывалось, короче. Для пущего комфорта здесь же и шарик мыши (трэкбол), и дополнительные клавиши вынесены в специальное место, и изогнута она так, как даже... все, молчу.

Выбор пользователя, однозначно

Нет, если бы у меня в материнке было два входа для клав - то на втором бы точно висела эта. Как сообщается, выпускается эта штука корпорацией Микрософт специально для российских пользователей. Что наводит на интересные мысли - может, и такой комбинацией клавиш пользуются только в России? А во всем остальном мире винда отлично работает и не виснет? В общем, это вопрос, с которым стоит разобраться.

Командир корабля и экипаж прощаются с вами

Вот такой кратенький обзор получился. За рамками его остались пленочные, непромокаемые, несгораемые, трижды сгибаемые, и еще много какие клавиатуры - потому, что журнал не резиновый, а места всем дай. Если же тебе попадется другой интересный экземпляр - не стесняйся, напиши мне об этом. Пока!


Спецвыпуск Xakep, номер #012, стр. 012-034-1, Мышь белая, компьютерная

Мышь белая, компьютерная

Mad Doctor (maddoc@online.ru)

Спецвыпуск Xakep, номер #012, стр. 012-034-1

Понятно, что компьютер привнес в нашу жизнь множество сопутствующих предметов. Они также прочно обосновались в нашей жизни, но мы практически не уделяем им внимания. И, соответственно, очень часто о них ничего не знаем. Точно так произошло и с таким необходимым всем нам устройством, как компьютерная мышь. Пришло время восполнить этот пробел, и специально для тебя мы провели СПЕЦ-расследование. И вот - подробная история этого девайса.

Ты помнишь, как все начиналось?

На этом рисунке-реконструкции ты видишь, как примерно выглядели самые первые мыши. К сожалению, у нас нет более точных сведений - ведь на рисунке изображена мышь такой, какой она была во времена каменного века. Конечно, сейчас нам это трудно даже представить - но в истории человечества было время, когда все (в том числе и компьютерные мыши) было деревянным или в лучшем случае каменным! В наскальных рисунках (в пещерах одной европейской страны) есть фрагмент, на котором изображен житель того века, угрожающий убить своего соперника каменным шариком от мыши - видимо, это и послужило причиной того, что впоследствии эти устройства изготавливались исключительно из дерева. Специалисты предполагают, что самые большие трудности при использовании этих мышей были обусловлены низкой гибкостью их хвостиков - несмотря на то, что они изготавливались из самых гибких пород дерева, движения таких мышей были ограничены радиусом в пять-семь сантиметров.

А еще хотели мышку в космос запустить...

По непонятным причинам прогресс довольно долго обходил стороной столь важное устройство, как компьютерная мышь. И только после изобретения джойстика и светового пера исследователи вернулись к идее усовершенствования ручного манипулятора. И вот в шестьдесят третьем году прошлого века Дагом Энгельбартом был запатентован принципиально другой его тип - компьютерная мышь, как мы ее знаем сегодня. Как ты видишь на снимке, она все-таки отличалась от современных нам мышей, к тому же механизм считывания координат основывался на двух ортогонально расположенных колесиках (а не на трех, как нынче). Строил ее инженер Билл Инглиш, а программу писал Джефф Рулифсон. Кроме того, сама работа частично спонсировалась NASA (Национальным Космическим Агентством). Но, хотя в тестах мышь показала свое абсолютное превосходство над другими манипуляторами, она была отвергнута этим агентством - так как не могла работать в невесомости =).

С тех пор прошло вот уже более тридцати лет. Семейство мышовых бурно развивалось все это время. Я не буду грузить тебя именами и последовательно рассказывать - кто придумал третье управляющее колесико, кто придумал какую форму мыши и так далее. Важнее другое - сейчас у нас есть выбор. Придумано такое невообразимое количество мышей разной формы и отделки, что просто обалдеть можно.

Linus

Выпускается компанией Gesko в Wolnzach, Бавария. Единственная компьютерная мышь (по крайней мере, в Германии), которая представляет собой смесь манипулятора и телефонного аппарата. Верхняя часть - обычная двухкнопочная мышь. Снизу же - телефонный аппарат. Зарубил пару сотен монстров в Кваке, затем поднял руку, набрал номер, поговорил с товарищем - и опять мышку на коврик, и вечный бой - "покой нам только снится". Телефон можно настроить для левшей. Стоит такой девайс 99 марок (50 бакинских примерно).


Спецвыпуск Xakep, номер #012, стр. 012-034-2, Мышь белая, компьютерная

Мышь белая, компьютерная

Mad Doctor (maddoc@online.ru)

Спецвыпуск Xakep, номер #012, стр. 012-034-2

Говорящая компьютерная мышь

Выпускается китайской компанией Guangzhou. Несет в себе два встроенных динамика по 10 ватт каждый, диапазон воспроизводимых частот составляет от 250 герц до 5,5 кГц (для симфоний Бетховена маловато, но для обычной речи достаточно). Подключается к компу через PS/2 и потребляет около одного ватта энергии.

Обратная связь, йоу!

А вот компания Logitech начала серийный выпуск мышей с обратной связью. Позволяет пользователю не только передавать движения своей руки в компьютер, но и чувствовать реакцию виртуального мира на его движения. Замочив того же монстра в Кваке, игрок чувствует отдачу от оружия - мышь вздрагивает у него в руке. А если виртуальная партнерша во время виртуальных... ээээ... забав вдруг поведет той частью... ээээ... своего интерфейса, к которому ты прикасаешься, то... эээ... ты почувствуешь это, в общем. В смысле, ее движения почувствуешь - а как же иначе?

Мышь для слепых

От израильской компании VirTouch. Я так сразу и не въехал, оказалось - правда. Для совсем слепых. У нее есть три пластины, на которые кладутся пальцы (вот такая у них распальцовка), и при попадании курсора на участки с текстом или графикой девайс сообщает пользователю об этом. Текст зачитывается вслух самой мышью, а графика передается пользователю с помощью тридцати двух небольших штыречков, полностью выдвинутое положение которых соответствует черному цвету, а полностью опущенное - белому. Среднее - серому, соответственно. Кроме того, мышь позволяет читать текст, написанный специальным шрифтом для слепых - шрифтом Брайля. Единственный недостаток такой фичи - цена. Наверное, это самая дорогая мышь из всех существующих ныне на рынке - стоит она пять тысяч буказоидов за штуку. Эксклюзив.

MouseMan Dual Optical

Двойная оптическая мышь, в общем. Имеется два оптических сенсора, что, по заверениям разработчиков (все та же компания Logitech), в два раза повышает точность и четкость работы на практически любой поверхности (разрешение сенсоров - 800 dpi). Обещается еще более плавное движение курсора и более точное позиционирование оного - даже при быстрых движениях устройства, зажатого в твоей руке (только в правой, правда).

Эмоциональная мышь

Устройство от исследовательского центра IBM Almaden Research Center. Разработана в рамках исследовательского проекта, изготовлена в единичных экземплярах. Это уже вторая модификация хитрого девайса - первая модель выглядела как обычная мышь, а нынешняя представляет собой круглую конструкцию с углублением по форме ладони. Внутри установлены инфракрасные, гальванические, механические и другие датчики. Они измеряют пульс, температуру, проводимость кожи, дрожание рук. Смысл всех этих прибамбасов в одном - мышь анализирует эмоционально-физическое состояние пользователя. Взволнованному принудительно включают заставку - например, картину водопада. А вот юзеру, разгневанному последним падением системы с сопутствующей потерей набираемого последние два часа документа, показывается анимированный ролик, в котором жестоко истязается производитель этой самой системы (ну, ты понимаешь, о ком я), после чего - тот же водопад. Как ты понимаешь, девайс может использоваться для решения более широкого круга задач - от медицинской диагностики на расстоянии до виртуальных забав, опять же.


Спецвыпуск Xakep, номер #012, стр. 012-034-3, Мышь белая, компьютерная

Мышь белая, компьютерная

Mad Doctor (maddoc@online.ru)

Спецвыпуск Xakep, номер #012, стр. 012-034-3

Мышь - дактилоскоп

Выпускается тайваньской компанией Biofinger Verification Services Co. Подключается к USB-порту и снимает отпечатки пальцев пользователя, взявшего ее в руку. Затем производится поиск в имеющейся базе данных образцов, по которой определяются права этого самого пользователя. Если же хитрый юзер решит просто отключить мышь от порта, дабы "не оставлять пальчики", то драйвер устройства принудительно завершает работу машины. Так что главное - не дергать ее слишком сильно, чтобы не выдернуть из порта - здесь никто мультиков тебе крутить не будет. Способна работать под сетевыми приложениями - вынь 2000 приводится в качестве примера.

Оптическая мышь MOP-35PU

Имеет на борту три клавиши, одно колесико, разрешение 520 dpi. Оптическая, как видишь. Полностью совместима с ДОСом и всеми версиями виндов. Дополнительной клавише можно присвоить любую команду из списка - "Backspace", "Enter", "Esc", "Удалить", "Двойной щелчок", "Закрыть приложение", "Увеличить", "Уменьшить", "Страница вверх", "Страница вниз", "Восстановить приложение", "Пуск", "Выполнить", "Найти документ", "Проводник". Кроме этого, есть фичи изменения скорости прокрутки колеса и установки полистовой прокрутки. Крепится на PS/2 и USB. Неизгладимый эффект производит, если свесить подключенный девайс с балкона второго этажа в темное время суток ;-).

Самая обычная инфракрасная мышь IRSW-25. Те же колесики и кнопочки, те же фичи дополнительной клавиши. Оптико-механическая при этом. Удобна для игры в "Lines" с другого конца комнаты - лучше всего с дивана.

Мышь тебе в пышь

Вот так расплодилось ныне семейство мышовых. На рисунках ты видишь еще прозрачные мыши, мыши с двумя колесиками и так далее. Подумать страшно - в самом начале была только одна модель, да еще к тому же деревянная, а сейчас... Хотя я думаю, что ты можешь найти и еще более вычурную конструкцию - с пятью колесиками, шестью кнопками и способную работать через Интернет на расстоянии до тридцати тысяч километров от компьютера. Только - а оно тебе надо? Если бы мне приходилось выбирать мышь сейчас, я бы взял себе простую оптическую мышь (не радио, отмечу особо) с двумя клавишами и одним колесиком. Собственно, я бы выбрал именно ту, какая и прикручена ныне к заду моей машины. Так что желаю тебе постоянства в области приручения мышей. А то, знаешь, раньше соседский кот на каждую мою новую мышу так зловредно поглядывал... А теперь - мир да покой. Правильного выбора тебе, в общем!


Спецвыпуск Xakep, номер #012, стр. 012-036-1, Какой принтер тебе нужен? Обзор принтеров.

Какой принтер тебе нужен? Обзор принтеров.

Спецвыпуск Xakep, номер #012, стр. 012-036-1

Андрей Каролик (andrusha@sl.ru; http://www.dal.net.ru)

Перед каждым, кто заимеет у себя дома персональный компьютер, рано или поздно встает (гы-гы-гы!) вопрос о выборе принтера. А в нагрузку этот чел получает еще и кучу сопутствующих вопросов. А нужен ли он в принципе? А если нужен - то какой? А чем лучше данная модель? Если дороже - значит лучше? А как проверять и на что смотреть? В конце концов, все это незнание деталей тебя конкретно достает - и ты покупаешь такой же принтер, как у твоего лучшего друга. К сожалению, подобный подход не всегда себя оправдывает. И если у друга стоит дорогой, но отстойный принтер, то ты сам можешь догадаться, какой будет у тебя :). Чтобы развеять сомнения и получить ответы на все вопросы, просто прочти эту статью - и получишь исчерпывающие сведения и полезные советы о покупке нового принтера.

Зачем нужен принтер?

Естественно для того, чтобы печатать. Текст, картинки, документы - и прочую лабуду. Для учащихся актуально делать на компе всяческие лабы, рефераты, расчеты, которые потом можно легко скинуть на принтер. Остальные распечатывают документы, объявления, просто информацию различного содержания. Некоторые, например, могут читать с монитора часами, другим проще распечатать и прочитать спокойно. Тем более, что на распечатанный вариант можно класть бутерброды с колбасой и заворачивать в него воблу :). А уж при появлении интернета принтер стал незаменим. Теперь можно легко скачать из сети (и распечатать!) любые прайс-листы, пустые бланки, которые проще заполнить дома (овир, посольство, платежные документы), последние результаты спортивных матчей (особенно тем, кто любит играть в тотализаторы), результаты виртуального опроса на наличие склонности к лунатизму и все остальное. Ну а подарить девушке открытку, которую ты сам сваял и распечатал, обойдясь при этом без матерных слов - высший пилотаж, уж это-то она оценит. Принтер нужен однозначно, тем более что цены на них сегодня более чем доступные.

Выбор принтера - важные критерии

Понятное дело, что при выборе принтера надо сравнивать их между собой по каким-то критериям. А они - следующие. Во-первых, качество программного обеспечения (прилагаемых драйверов и прилагаемого софта), поставляемого в комплекте с принтером. Если здесь все тухло, то принтер у тебя будет печатать не очень хорошо. Не лишним будет поинтересоваться, есть ли сложности при установке и деинсталяции драйверов. Лучше просто попросить посмотреть, как выглядит установленный софт, и насколько гибкие настройки печати он имеет. При этом вовсе не обязательно, что чем больше настроек - тем лучше. Важно - какие настройки есть вообще, и что они позволяют. В первую очередь тебе понадобятся настройки качества печати (расхода краски), формата и параметров бумаги, на которой ты будешь печатать, и набор сеттингзов по обслуживанию самого принтера.

Сервис

Обслуживание индивидуально для разных принтеров. Для струйников и лазерников требуется функция совмещения печатающих картриджей (если их несколько), еще -очистка печатающих картриджей. Для матричных, кстати, ничего подобного не нужно. Почти на всех последних принтерах есть встроенная функция печати контрольной страницы для проверки качества печати, и проверка связи компьютера с принтером - на случай, если что-то не фурычит, и проблема в кабеле. Если этого минимума не будет, то печатать черновые распечатки ты всегда будешь только с фотографическим качеством, а печатать на бумаге высокого качества придется как на картоне. Во-вторых, качество механики. То есть - как бережно принтер забирает бумагу из лотка. Это качество принтера иногда даже важнее, чем первое. От того, как принтер заглатывает бумагу, зависит многое. Например, то количество времени, которое тебе придется потратить на извлечение зажеванного листа :). Зависит это от конструкции механизма протяжки листа. Периодически любой принтер откровенно жует бумагу, а потом давится :). Если тебе достанется хромоногий принтер, то могу только посочувствовать. Тебе это нужно?


Спецвыпуск Xakep, номер #012, стр. 012-036-2, Какой принтер тебе нужен? Обзор принтеров.

Какой принтер тебе нужен? Обзор принтеров.

Спецвыпуск Xakep, номер #012, стр. 012-036-2

Качество

Не менее важный критерий - качество отпечатанного тестового изображения. Для проверки этого самого качества обычно печатается фотография симпатичной девушки с какой-нибудь балалайкой :). По бокам от тетки находятся градации цветов CMYK, или три градиентных шкалы основных цветов RGB и одна шкала градации черного цвета. Чтобы не заморачиваться, заранее сделай себе нужный тестовый образец и попроси распечатать именно его. Оценка тут чисто визуальная: градация должна быть равномерной и чистой, все оттенки должны нормально пропечататься, не должно быть грязи, размытости и подтеков краски. Еще лучше иметь с собой распечатки с других принтеров, между которыми ты и выбираешь - тогда достаточно будет их просто сравнить. Про эстетический аспект я молчу, так как внешне убогих принтеров почти не бывает. А если они и были – фирмы, их выпустившие, давно разорились. Если уж первые три критерия на одном уровне - можешь выбирать принтер по внешнему виду. Последний критерий, на который стоит обратить внимание - эксплуатационные расходы на принтер - то есть, стоимость расходных материалов. Как правило, этот показатель тем выше, чем дешевле приобретенное устройство. Так что не всегда выгодно брать принтер за корок сопеек. Крупные фирмы, чтобы их продукция была более конкурентоспособной, постоянно стараются уменьшить эту стоимость, и для однотипных принтеров она обычно примерно одинакова - зашкаливать может только у девайсов специфического предназначения. Что касается скорости печати - это актуально скорее в офисах, чем дома. Переплачивать только за то, что ты распечатаешь свои мемуары на несколько секунд быстрее, я думаю, не стоит.

Какие принтеры бывают?

Матричные принтеры

Времена, когда матричный принтер трещал повсюду, давно прошли. Но и сейчас в некоторых случаях их применение оправдано: если необходимо получить сразу множество копий документа под копирку, если производится печать документов на специфической бумаге (например, они стоят в сбербанке для отметки оплаты телефонных переговоров) и, наконец, если печатающему устройству предстоит работать в трудных условиях - повышенная влажность, запыленность и специфические температурные режимы. Надежность механики и устойчивость к пыли и вибрации у матричных принтеров самая высокая, что и определяет их применение в экстремальных условиях. Так что в поход бери однозначно матричный :). Такие девайсы имеют небольшие габаритные размеры, массу и цену, но и не отличаются высокой производительностью. Качество печати - среднее. Изображение в них формируется из множества точек, оставляемых ударами тупых иголок по красящей ленте. Благодаря этому, они могут выдавать на бумагу не только алфавитно-цифровую информацию, но и примитивные рисунки, графики, диаграммы и даже полутоновые изображения. Не забуду, как я тащился, когда мама принесла мне с работы полутоновую картинку какого-то танчика (мне тогда было шесть годиков =)). Обычно иголки составлены в вертикальный ряд (в высоту печатаемой строки), их может быть от 7 до 48 штук. Они прижимаются к красящей ленте электромагнитом (каждая - своим), а назад отводятся пружинками. Печатающий механизм с иголками перемещается равномерно вдоль строк бумаги. Красящая лента такая же узкая, как у пишущих машинок. Чаще всего она помещена в пластмассовую кассету. Бумага может использоваться разная: листовая, рулонная, с отверстиями или без них. Для улучшения качества изображения иногда применяется повторная печать символа с небольшим смещением иголок, тогда точки становятся почти незаметными. В некоторых матричных принтерах применяется многоцветная лента (3-4 цвета). Размеры таких агрегатов непрерывно уменьшаются, число иголок растет, а их толщина уменьшена до долей миллиметра. В графическом режиме матричные принтеры могут сплошь заполнять пространство на бумаге, формируя тем самым изображение любого содержания. Но, естественно, качество несравнимо с аналогичными струйниками и лазерниками. Наиболее распространенные среди матричных принтеров на нашем рынке - принтеры фирмы Epson.


Спецвыпуск Xakep, номер #012, стр. 012-036-3, Какой принтер тебе нужен? Обзор принтеров.

Какой принтер тебе нужен? Обзор принтеров.

Спецвыпуск Xakep, номер #012, стр. 012-036-3

Струйные принтеры

Купив струйный принтер, можно убить двух зайцев - получить качественные цветные изображения и неплохую скорость печати. Ведь струйник – это одно из самых дешевых решений проблемы. Средняя цена аппарата, печатающего со скоростью 4-6 стр./мин, составляет сейчас всего 100-200 зеленых, а качество печати вполне приличное, разрешение - 300-600 точек на дюйм. Но вот цена картриджей для них высока (до 40 зеленых за одну чернильницу), а ресурс картриджа мал - примерно 400-800 копий. Именно это делает крайне невыгодным использование струйника в качестве сетевого печатающего устройства: слишком высокой оказывается стоимость эксплуатации. Струйный принтер оправдывает себя только дома, где он подключен к локальной машине и используется для печати небольшого количества печатных материалов. Зато себестоимость печати страницы в цвете на струйнике меньше себестоимости цветной копии, сделанной на лазернике. Только надо помнить, что практически все марки цветных чернил боятся влаги - а значит, отпечаток может быть легко смазан. Есть одна довольно специфическая область применения, где технология струйной печати оказывается самой выгодной. Это печать текстов и изображений на пленках для проекционного оборудования. Я, например, не раз делал для своих курсовых и диплома чертежи на пленках - вместо того, чтобы чертить все это вручную на обычном ватмане небубенного размера :). Принцип действия струйного принтера основан на том, что жидкая краска непрерывной и очень тонкой струйкой (фактически, мелкими капельками) выдавливается из емкости на бумагу. Летящие капли отклоняются электрическим полем, которое управляется процессором. Нетрудно сделать несколько емкостей с красками разных цветов, и тем самым обеспечить многоцветное изображение. Получается устройство практически бесшумное, небольших размеров и достаточно простое. Бумага может применяться разная, но не всякая. Наждачка, к примеру, не подойдет :).


Спецвыпуск Xakep, номер #012, стр. 012-036-4, Какой принтер тебе нужен? Обзор принтеров.

Какой принтер тебе нужен? Обзор принтеров.

Спецвыпуск Xakep, номер #012, стр. 012-036-4

К недостаткам этой категории девайсов стоит отнести затраты времени, необходимого для высыхания краски, и невысокую скорость печати. Из-за того, что краска в картридже подсыхает, принтер иногда требует технического обслуживания. На рынке струйников уже давно конкурируют две фирмы - Epson cо своими Stylus и Hewlett-Packard (HP) с DeskJet. Появились еще две фирмы - Canon с принтерами серии BubbleJet и Lexmark с серией ColorJet. Более мелкие конторы не имеют такого богатого ассортимента, и отстают на порядок в своих технологиях.

Светодиодные принтеры (LED-технология)

LED (Light Emitting Diode) - светодиодная технология. Это что-то между струйниками и лазерниками, но здесь вместо лазера работает светодиодная панель. Никто не спорит, что лазерный принтер - это супер, но светодиодники подешевле будут... Есть безусловные преимущества, и есть явные недостатки. Преимущества: линейка светодиодов занимает меньше места по сравнению с лазерниками, отсутствуют подвижные части в линейке светодиодов, проста оптико-механическая система, качество изображения превосходно. Для реализации процесса лазерной печати помимо тракта протяжки бумаги принтеры содержат зеркальную систему развертки, устройства фокусировки и лазерный диод. Теперь о недостатках. Технология светодиодной печати представлена на российском рынке фирмой OKI, у которой есть линейка недорогих принтеров OKIPAGE. Но за видимой дешевизной порой скрывается большая головная боль. Владельцы этого чуда техники часто обращаются в сервис с проблемой выхода из строя барабанного картриджа. Оказывается, стоимость картриджа составляет почти половину стоимости принтера. А если картридж выйдет из строя через месяц после покупки принтера (а такое вполне может случиться), то получится, что ты отдал за твой принтер уже не 200, а все 300 зеленых, поскольку бесплатно тебе картридж никто не заменит. Картриджи относятся к расходным материалам и не подлежат возврату, а гарантия на них не распространяется. Они в этих принтерах сконструированы так, что позволяют повторно использовать тонер. Во всех известных марках и технологиях тонер является одноразовой вещью. А тут он возвращается в резервуар картриджа и используется повторно. Это называется «система рециркуляции». Поэтому принтеры с такой схемой работы требуют качественной бумаги. Тонер принтеров OKI - это то, чем девелоперы девайса сильно гордятся =). Обычный тонер - это молотый уголь, у которого много недостатков (один из которых - неровность краев). Могут появиться царапины на фотобарабане. Естественно, из строя выйдет он быстрее. Поэтому рекомендация от меня и от OKI: пользуйся только оригинальным тонером. В цветных светодиодных принтерах светодиодные линейки располагаются в четыре ряда. У каждой имеется свой барабан и свой цветной тонер-картридж. Бумага проходит последовательно под каждым из них, и за один раз формируется изображение. Получается очень даже ничего, от лазерной копии практически не отличить. Самая сильная сторона светодиодных принтеров, из-за которой многие их берут - это соотношение цена/качество. Но это - в том случае, если все работает, как надо :).


Спецвыпуск Xakep, номер #012, стр. 012-036-5, Какой принтер тебе нужен? Обзор принтеров.

Какой принтер тебе нужен? Обзор принтеров.

Спецвыпуск Xakep, номер #012, стр. 012-036-5

Лазерные принтеры

Если руководствоваться стоимостью эксплуатации и соотношением цена/качество, то в большинстве случаев оптимальным выбором окажется лазерный принтер. Их принято делить на персональные, офисные и профессиональные. Самые дешевые из них, естественно, персональные лазерные принтеры - прямые конкуренты струйников, стоят меньше 400 зеленых. Они отличаются невысокой скоростью (4-6 стр./мин) и минимальным набором дополнительных функций. Лазерники - наиболее сложные и дорогие из малогабаритных печатающих устройств. Принцип их действия основан на известном свойстве - прилипании измельченной полимерной краски (мелкодисперсная смесь) к статически заряженной полупроводниковой поверхности. В лазерном принтере поверхность цилиндра из полупроводникового материала равномерно по площади заряжается от высоковольтного источника питания. Затем меняющимся по интенсивности тонким лазерным лучом в нужных местах поверхность разряжается. С помощью специального валика (электромагнитной щетки) пылевидная краска наносится на цилиндр. В тех местах, где заряд остается (луч лазера его не коснулся), пылинки прилипают, и вращением цилиндра переносятся на бумагу. Другим электрическим полем, действующим с обратной стороны бумаги, частицы краски перетягиваются на нее. Далее под воздействием мощной лампы краска плавится и впитывается в бумагу. Оставшиеся на цилиндре заряды и краска снимаются разряжающими лампами и скребком. Луч лазера, формирующий изображение, бегает вдоль цилиндра, отражаясь от многогранного зеркала. Цилиндр и зеркало вращаются равномерно, а яркость луча меняется под управлением процессора. Точнее, вспышки луча повторяют распределение бит в специально выделенной памяти, в которой процессором формируется изображение. Размер этой памяти должен быть достаточным для построения полной страницы со всеми деталями. Дело в том, что процесс печати в лазерных принтерах имеет такую особенность: начатую страницу необходимо допечатать до конца без остановок, в противном случае на ней неизбежно появятся крупные дефекты. Печать производится следующим образом. Сначала приводятся в действие оптико-механические элементы принтера - лазер, многогранное зеркало, полупроводниковый цилиндр, источники высокого напряжения. Затем в темпе движения луча по образующей цилиндра происходит считывание бит вдоль строчек буфера. Биты-нули при этом на луч не влияют, а биты-единицы гасят (перекрывают) луч с помощью специального устройства - модулятора. Следовательно, точки на цилиндре, соответствующие битам-единицам, остаются незасвеченными, и к ним прилипают частицы краски, переходящие затем на бумагу...


Спецвыпуск Xakep, номер #012, стр. 012-036-6, Какой принтер тебе нужен? Обзор принтеров.

Какой принтер тебе нужен? Обзор принтеров.

Спецвыпуск Xakep, номер #012, стр. 012-036-6

Да! Лазерные принтеры поедают электроэнергию просто со страшной скоростью. Считай, что теперь у тебя дома появился второй электрочайник =).

Общие советы

Если хочешь брать лазерник, то советую HP LaserJet 1200 - получишь прекрасное разрешение и надежность HP. Если же напряг с баблом, но хочется всего как у больших - то можно рискнуть, купить принтер от OKI. Это самое оптимальное соотношение цена/качество, но могут возникнуть проблемы с картриджем, если будешь часто его ронять и проливать на него пиво :). Среди струйников лидирует HP - у этой фирмы самая продуманная механика, великолепная цветопередача и действительно фотореалистичное изображение. Если тебе нужен вариант подешевле - посмотри продукцию Lexmark и Epson. Технические данные я даже не буду тебе приводить, так как ты легко сможешь найти их на сайтах производителей - www.hp.ru, www.canon.ru, www.epson.ru, www.oki.ru, www.lexmark.ru.

Известные грабли струйников, на которые уже наступали

Многие говорят, что если знать все на свете - жить будет неинтересно. Может, оно и так, но кое-что знать заранее не помешает. Перед покупкой принтера прочти этот раздел - возможно, ты еще не один раз будешь благодарен сам себе за то, что не купил именно ЭТОТ девайс :)...

Грабли от Epson

Все принтеры Epson марки Stylus используют пьезоэлектрическую технологию печати. Фирменные расходные материалы значительно дешевле, чем у тех же HP. Но - все в этом мире несовершенно, и из достоинств вытекают недостатки. Пьезоголовка - вещица весьма дорогая и требующая аккуратного обращения. Выживает, только если достаточно четко следовать инструкции. Но ручки-то шаловливые, норовят все разобрать на части :). К тому же, если в целях экономии ты решишь использовать левый картридж, то имей в виду, что можешь головку попросту запороть. И в техслужбе уже ничем тогда не помогут - в инструкции к принтеру черным по белому написано: пользоваться чернилами только марки Epson. Если же принтер уже не новый, и тебе его не очень жалко - попробуй чернила марки Fullmark: они стоят в два раза дешевле фирменных при том же объеме картриджа, но расходуются быстрее. Еще один вариант - заправлять картриджи самостоятельно, так как это в два раза дешевле. Но тогда готовься, что у тебя не сразу отмоются руки, будет заляпан принтер и ковер в комнате :). К тому же, в перезаправленном картридже чернила сохнут еще быстрее и чаще, чем в запечатанном родном картридже. А что касается водостойкости чернил – так это вообще безобразие. Поэтому, советую принтером Epson Stylus пользоваться в одиночку, не доверяя его никому, и четко следовать инструкции - тогда он будет тебе безотказно служить не один год, до самой смерти механики :).


Спецвыпуск Xakep, номер #012, стр. 012-036-7, Какой принтер тебе нужен? Обзор принтеров.

Какой принтер тебе нужен? Обзор принтеров.

Спецвыпуск Xakep, номер #012, стр. 012-036-7

Грабли от Canon

В этих принтерах (Canon и HP) живут термоструйные головки, которые меняются вместе с картриджем. С одной стороны, считается, что так принтер дольше служит. С другой - многие говорят, что так выходит дороже. Вряд ли можно представить себе струйный принтер, более оптимизированный под заправку, чем Canon (Canon Bubble Jet). Струйники от Canon очень компактны, что для дома немаловажно, понимают систему команд EpsonLQ и IBM XL. Цветные чернила у них расходуются очень экономично, а вот черные почему-то льются рекой (хватает приблизительно на 300 страниц – это по сравнению с 400-500 у HP). Минусом является отсутствие выходного лотка, но это сделано опять же для компактности. А вот критичным можно считать то, что они не имеют приличной системы воздушного дренажа из-за недостатка пространства. Из-за этого в распечатках могут быть спонтанные полосы, да и сопла печатающей головки могут забиваться без видимых причин. Скорость печати у принтеров Canon достаточно низкая – но, как я говорил выше, для дома это не так критично.

Грабли от HP

Принтеры HP DeskJet отличаются собственной системой команд, поэтому в DOS-программах бывают некоторые проблемы. Но кто там печатает? Основной плюс – скорость: это быстрые принтеры. Еще они надежны и достаточно просты в эксплуатации. Есть одна отличительная черта: подача бумаги - спереди, снизу вверх с сильным перегибом листа. Не знаю даже, является ли это достоинством или недостатком, но вся рабочая зона находится спереди, принтер можно втиснуть практически в любой угол. С другой стороны - такая подача чревата тем, что жадный принтер может схватить сразу несколько листов, и парочку из них хорошенько пожевать. Поэтому тонкую бумагу следует подавать по одному листочку. Картриджи? О-о-о... Чтобы заправить картридж HP и не испачкаться - хых, так не бывает. Так или иначе, след от этой операции на тебе или твоей одежде останется. Одно радует: объем картриджа большой, будет время отмыться :). Естественно, чернила фирменные, водостойкие, отмывать придется долго. Правда, значительный объем картриджа позволяет прибегать к перезаправке не так часто: в экономичном режиме удается отпечатать 800-900 листов текста, в нормальном - вдвое меньше.

P.S. Лично у меня стоит HP DeskJet 690C уже в течение 3-4 лет. Он давно снят HP с производства. Я уже даже кузов с него снимал, чтобы промыть :). Постарел немного, иногда жует (гад!), но печатает исправно. Основная проблема - со временем смазка изнашивается и густеет. А еще механизм может стопорить пролитая и засохшая краска от картриджа. В последнем случае нужно просто все протереть спиртом - он разжижает засохшую краску. Картриджи заправлял сам, совета конкретного дать не могу, потому что всегда выходит по-разному. Последний раз измарался, как свинья, и картридж не заработал :), пришлось купить родной. Так что выбор за тобой...


Спецвыпуск Xakep, номер #012, стр. 012-040-1, Не пялься в Монику, или выбираем крутой монитор

Не пялься в Монику, или выбираем крутой монитор

Donor (donor@real.xakep.ru)

Спецвыпуск Xakep, номер #012, стр. 012-040-1

Каждый мачо рано или поздно осознает, что ЕГО размер больше не удовлетворяет возросшим потребностям. Согласись, стандарты несколько изменились. Нужно много места на рабочем столе, чтобы удобственно разложить кучу важных окошек с инфой, которую колбасит в real-time. Хочется комфортно популять в сетевой 3D-шутер с друганами, не вглядываясь в малюсенькое окошечко, а реально атмосферясь перед большой дырой в другое измерение. Тянет откинуться на спинку стула, а не высматривать каждую буковку, уткнувшись в экран носом. И цены сейчас уже не такие кусачие... Точно! Пора менять монитор.

Надолго и всерьез

Сам понимаешь, моньку поменять - не брусок мозгов в маму тыкнуть. Мониторище, в отличие от своей дежурной тетки, ты не сможешь сменить через недельку. Кроме того, надо подумать о потенции... твоих глаз, о ломоте в затылке и прочих глюках со здоровьем. Поэтому к выбору будем подходить ответственно. Сейчас я тебе обрисую, чего нужно знать о мониках вообще и каких новых фишек намутили буржуины на наши головы и лопатники. А то еще загнешь где-нибудь ненароком что-то типа: "А у этой штуки точечка 0,25, поэтому она круче!".

Кишки и здоровье

Не мне тебе объяснять, что при выборе дисплея не последнее, а скорее первое место держат показатели влияния стеклянного на твои окуляры и мозги. Думаю, твои родители в этом направлении уже поработали. Так что даже и не пытайся экономить на мониторе! Влияние зависит от технических особенностей того или иного типа монитора и от параметров конкретной модели. Параметры, само собой, зависят от кишок монитора. И каждая кишка вредит тебе по-своему. И это тоже надо учитывать.

Стеклянные старожилы

Мониторы с электронно-лучевой трубкой (ЭЛТ), или Cathode Ray Tube (CRT), живут с нами давно и, естественно, являются самыми распространенными. Скорее всего, у тебя на столе тусует один из них. Постепенно совершенствуясь, они прошли путь от монохромных чудовищ до современных эргономичных красавцев. Что ж, будем резать >:)!

Труба

Электронно-лучевая трубка - это самая настоящая радиолампа. Внутри нее вакуум. Передняя часть (экран) трубы изнутри покрыта люминофором (вещество, которое светится под воздействием электронов). Далее она постепенно сужается, и в попу ей воткнута электронная пушка (электронный прожектор). Эта пушка через специальную металлическую сетку (маску) поливает люминофор потоком ускоренных электронов, которые заставляют его светиться. То есть пушка пальнула электронами через сетку в определенное место люминофорного слоя - на экране образовалась светящаяся точка. Из этих точек строится изображение.

Производители часто привлекают юзверей "плоскими" трубками. Знай, абсолютно плоских трубок не бывает. Дело в том, что трубки на заводе вырезают из огромного стеклянного шара. Чем больше радиус такого шара, тем более плоский экран и выше цена. Так что если тебе трубку под плоское стекло спрятали, это еще не значит, что сам экран плоский. Фишка плоского экрана в том, что изображение меньше искажается.

А вот на антибликовое покрытие экрана нужно обратить особое внимание. Если монька будет бликовать, то твои глаза долго не проживут. Так что наличие этой фени обязательно, а ее качество легче всего определить... на глазок =).


Спецвыпуск Xakep, номер #012, стр. 012-040-2, Не пялься в Монику, или выбираем крутой монитор

Не пялься в Монику, или выбираем крутой монитор

Donor (donor@real.xakep.ru)

Спецвыпуск Xakep, номер #012, стр. 012-040-2

Размеры и удовлетворение

Больше размеры - больше оттяга! Размер диагонали в дюймах - очень важный параметр трубки. Стандартные размеры (15", 17", 21") - это размеры трубки вообще. Еще есть размер диагонали видимой области трубки, который пишется в скобках, например, так: 15(14). Чем вторая циферка больше, тем лучше. Сейчас стандартом считается 15 дюймов, но покупать лучше сразу 17.

Размер трубы также влияет на такую вкусную характеристику, как максимальное разрешение. Понятно, что сделать разрешение поменьше всегда можно. А вот побольше - хрен! Сколько физических элементов люминофора помещается по горизонтали и по вертикали твоей моньки, таково и будет в потенциале максимальное разрешение трубы. Вывод: хочешь большое разрешение - бери либо большую диагональ, либо большую плотность элементов.

Электронная пушка

Видел когда-нибудь телевизионную трубку? Из нее сзади торчит кончик, похожий на обычную радиолампу. На самом деле, вся трубка - это лампа, а кончик и есть наш big gun. Там стоит катод, который при нагревании испускает электроны. Далее система анодов фокусирует и разгоняет электронный пучок для дальнейшей бомбежки люминофора. В современных цветных мониках 3 пушки - по одной на каждый цвет (RGB).

Ты скажешь: "Эй! Это же радиация!". Да, поток электронов относится к ионизирующему излучению (бета-излучение), но современные трубки сделаны так, что даже если небольшая часть электронов и вылетит за пределы экрана, то они не смогут пробить твою толстую шкуру. Поэтому не верь всяким ловким буржуям, которые вешают на свои модели надпись "Low radiation". Нет там практически никакой радиации вообще!

Пушки могут стоять треугольником (дельтообразное расположение) и рядком (планарное расположение). Второй тип используется в трубках с самосведением лучей, которые меньше реагируют на изменение положения относительно магнитного поля Земли и не требуют дополнительной настройки.

Люминофорный слой и триады

Передняя часть трубки покрыта специальным веществом, которое светится, когда в него врубаются ускоренные электроны. Слой люминофора не сплошной, а состоит из микроскопических элементов. Из них, собственно, и строится изображение. Эти элементы называются триады, так как состоят из трех типов частиц, которые светятся красным, зеленым или синим (RGB). При смешении этих цветов получаются другие цвета и бесконечное число оттенков (изменяя ток, меняем интенсивность свечения частиц). А вот сколько оттенков будет реально отображаться, зависит от электроники монитора и видюхи.

О вреде свечения

Как ты понял, любой монитор является источником яркого света, что очень вредно для глаз. Это все равно, что смотреть на солнце без солнцезащитных очков. И хотя яркость можно регулировать, монька все равно будет светить ярче, чем обычный дневной свет. Ничего с этим не поделаешь. Поставь себе прогу-напоминальщик, которая будет нудить, чтобы ты срочно шел в сад, и научит нескольким упражнениям для глаз. Взять здесь: http://www.gi.ru/eyeskeeper/.


Спецвыпуск Xakep, номер #012, стр. 012-040-3, Не пялься в Монику, или выбираем крутой монитор

Не пялься в Монику, или выбираем крутой монитор

Donor (donor@real.xakep.ru)

Спецвыпуск Xakep, номер #012, стр. 012-040-3

Решетки и маски

Каждая электронная пушка должна попадать строго в "свой" тип частиц, то есть красная пушка - в красные частицы, зеленая - в зеленые, синяя - в синие, и в нужную триаду. Но дело в том, что пушка может и промазать (канонир кривой, наверное), и вместо очаровательной дефачки ты увидишь на экране первозданный хаос. Чтобы пушке было удобнее целиться, перед слоем с люминофором ставят маску. Маска - это такая решетка из инвара (сплав железа и никеля) с дырочками. Эта маска отделяет триады одну от другой и отлавливает электроны, летящие не туда, таким образом обеспечивая растровость изображения. Приглядись получше к своему монитору и ты увидишь что-то вроде сеточки. Структура маски зависит от типа кинескопа и извращенности фантазии производителя. Разные маски по-разному влияют на качество изображения.

Shadow Mask (теневая маска)

Это самая распространенная маска. Сетка состоит из однородных круглых отверстий, которые отделяют триады одну от другой. Показателем крутизны здесь является dot pitch (шаг точки) в миллиметрах. Ясно, что чем меньше, тем круче и дороже. Теневую маску юзают Hitachi, Panasonic, Samsung (кстати, просто супер!), Daewoo, LG, Nokia, Viewsonic.

Slot Mask (щелевая маска)

Тут люминофорные элементы расположены в вертикальных элептических ячейках, а в маске прорезаны вертикальные щели. Таким образом, получаются столбики, поделенные на продолговатые ячейки, в каждой из которых лежит по 3 частицы 3-х основных цветов. Крутизна определяется показателем slot pitch (шаг слота). Чем меньше цифра, тем четче порнушка ;). Эту технологию имеют NEC (под кличкой "CromaClear"), Pornoslonic (в трубках PureFlat), LG в трубках Flatron.

Aperture grille (апертурная решетка)

Эту фигню когда-то давно придумала Sonя и назвала "Trinitron". Суть в том, что тут нет триад, а есть последовательно расположенные по 3 нити из частиц одного из трех цветов. Маска от Соньки - это фольга с процарапанными тонкими вертикальными прорезями. Фольгу вешают на одну или несколько проволочек (зависит от размера моньки), которые гасят колебания. Эти проволочки отбрасывают тень на экран и видны юзверям. Так что это не брак, а такая маленькая особенность. Нравится, не нравится - жри моя красавица :). Мониторные понты здесь измеряются в strip pitch-ах (шаг полосы). Меньше - лучше. Апертурная решетка юзается в мониторах от Viewsonic, Radius, Nokia, LG (особенно классные!), CTX, Mitsubishi и, естебственно, во всех мониках от Sony.

Маски VS Решетки. Что круче?

У разных масок и решеток свои рулесы и недостатки, поэтому выбор девелопера моники делай исходя из того, чего тебе от нее надо. Мониторы с теневой маской дают более четкое и детализированное изображение, то есть лучше воспроизводят мелкие детали. Поэтому такие моньки хороши для работы с текстом и мелкой графикой. Мониторы с апертурной решеткой дают более яркое и контрастное изображение со вкусными цветами и подходят для дизигнеров и геймеров.


Спецвыпуск Xakep, номер #012, стр. 012-040-4, Не пялься в Монику, или выбираем крутой монитор

Не пялься в Монику, или выбираем крутой монитор

Donor (donor@real.xakep.ru)

Спецвыпуск Xakep, номер #012, стр. 012-040-4

Сравнивая характеристики монек, также нужно учитывать, что показатели шага в разных типах масок не эквивалентны, так как в теневых масках шаг считается по диагонали, а в апертурных решетках - по горизонтали. То есть при одинаковых показателях pitch-а труба с апертурной фигней имеет плотность элементов ниже, чем труба с маской. Например, 0,25 мм strip pitch примерно равно 0,27 мм dot pitch.

Если есть размеры шага точки (слота, решетки) в миллиметрах и размеры видимой области трубы в сантиметрах, то по хитрой формуле можно рассчитать реальную разрешающую возможность монитора. Она, как правило, меньше той, что указывают производители.

Чем рисуют моники

Явно, не тем же, чем и слоники :). Тут все немного сложнее. Луч из электронных пушек может попадать только в центр экрана, то есть светится только одна центральная точка. Чтобы попасть в другие точки, нужна отклоняющая система, которая, как ни странно, отклоняет электроны от прямой и направляет их на любой другой конкретный элемент люминофорного слоя. Получается, что точка как бы движется по экрану. Только делает она это очень-очень быстро. А глаз человека какое-то время (1/20 секунды) хранит изображение, поэтому, если луч будет пробегать последовательно по всем горизонтальным линиям экрана хотя бы 25 раз в секунду, ты увидишь равномерно освещенный экран с небольшим мерцанием. Представляешь, какие там скорости! Кстати, такой последовательный пробег по строкам называется сканированием.

Отклоняющая система

Отклоняющая система - это катушки, расположенные с боков, сверху и снизу горла трубы (катушки горизонтальной и вертикальной развертки, соответственно). Они создают электромагнитное поле и, таким образом, отклоняют пучок электронов от прямой, направляя их в конкретный элемент люминофорного слоя. Можешь поднести магнит к экрану - тогда увидишь небольшую аномалию (хотя лучше этого не делать, чтобы не ехать в мастерскую). Это электроны под действием магнитного поля изменили свои треки. Не забывай пользоваться функцией размагничивания маски или решетки своей моники. Она предусмотрена во всех современных мониторах, чтобы устранять влияние внешних магнитных полей.

Считается, что переменное электромагнитное поле потенциально может быть опасно для человека (вызывать раковые заболевания, например), но пока ни вредность, ни безвредность этой фигни учеными не доказана. Однако, на всякий случай, электромагнитное воздействие стараются делать минимальным.

Управляющая электроника

Управляющая электроника получает сигнал с видюхи, усиливает его и соответствующим образом управляет электронными пушками и отклоняющей системой. От качества электроники зависят такие важные показатели, как максимальное разрешение монитора, частота строчной развертки и частота регенерации экрана (частота вертикальной разверстки). Причем на это влияет также и видюха, и размер видеопамяти. Так что даже если у тебя крутой кинескоп "Супер-хай-тринитротолуол", но управляющая электроника моньки и видюха ни к черту, то фигня получается. Так что не ведись на трубку от Sony, а смотри характеристики.


Спецвыпуск Xakep, номер #012, стр. 012-040-5, Не пялься в Монику, или выбираем крутой монитор

Не пялься в Монику, или выбираем крутой монитор

Donor (donor@real.xakep.ru)

Спецвыпуск Xakep, номер #012, стр. 012-040-5

С чем едят частоты?

Частота горизонтальной развертки показывает тебе в килогерцах (кГц), как быстро данный монитор чертит на экране одну линию. Частота регенерации объясняет на герцах (Гц), как быстро обновляется (прочерчивается) весь экран. Чем выше эти частоты, тем лучше для твоего здоровья, так как при маленьких частотах ты видишь мерцание изображения, которое "сажает" тебе зрение. Мерцание твой глаз почти престает различать при частоте регенерации 75 Гц. Современные мониторы обычно работают на 85 Гц. Правда, даже при такой частоте "боковым" зрением ты можешь заметить мигание моньки. Поэтому стандарты рекомендуют (но никого не заставляют) частоту 100 Гц. Кстати, на 110 Гц человеческий глаз не может различить мерцания вообще. Вот такие цифры.

И рыбку съесть, и на сучек не сесть

В частотах и разрешении зарылся огромный трабл. Дело в том, что на больших частотах при большом расширении пушкам приходится бомбить больше точек и делать это быстрее, а видеокарте передавать инфу чаще. У моники существует такой параметр, как полоса пропускания (bandwidth). Он показывает в мегагерцах (мГц) минимальную продолжительность импульса, то есть сколько миллионов (!) раз может фигануть электронный пулеметчик в секунду (!). У видюх такой параметр зовется dot clock (сколько миллионов пикселей может передать видюха в секунду).

Чтобы посмотреть, потянет твоя монька такое расширение с такой частотой, нужно рассчитать необходимый bandwidth по формуле и сравнить с ее характеристиками или просто попробовать. Если по жизни не совпало, то либо понижай частоту, либо уменьшай разрешение.

Надо сказать, что, повышая частоты и разрешения, ты заставляешь отклоняющую систему работать интенсивнее, а значит, увеличивается рассеиваемая монитором мощность (тепло) и растет показатель переменного электромагнитного поля. В общем, большие разрешение и частота - это хорошо, но тогда будь готов к увеличению размеров и прожорливости девайса и его цены.

О чем нудят стандарты

Идея стандартов безопасности (чтобы производители не беспредельничали) была, конечно, хорошей, но, как все благое, ее довели до абсурда. Сейчас это такая рекламная фишка. Платим некоторой "независимой" ассоциации, шлепаем цветастую наклеечку на девайс, и ОК на Оби. Так о чем я? Шведское правительство вместе с некоммерческими организациями в заботе о здоровье своих граждан разработало стандарт безопасности для электрических приборов (не только для монек) MPR II. Он определяет максимально допустимые величины электрических и магнитных полей, создаваемые прибором при работе. Шведская Конфедерация коллективов профессиональных работников разработала еще более жесткий стандарт ТСО'92 (только для мониторов), который включал еще и ограничения по энергопотреблению. Они же разрабатывают различные тесты для приборов. Так вот, шведские стандарты - самые жесткие в мире, поэтому получили наибольшее распространение.

Сам понимаешь, монька, отвечающая стандартам, стоит дороже и конкурирует на рынке лучше, поэтому дальше стали клепать ТСО-шки одну за другой, причем тесты оборудования проводят не по всем направлениям, а выборочно, то есть так, чтобы девелоперам удобно было следовать стандартам. И волкам палки, и овцы целки ;).


Спецвыпуск Xakep, номер #012, стр. 012-040-6, Не пялься в Монику, или выбираем крутой монитор

Не пялься в Монику, или выбираем крутой монитор

Donor (donor@real.xakep.ru)

Спецвыпуск Xakep, номер #012, стр. 012-040-6

ТСО'95 распространяется на весь комп и добавляет к 92-ому требования по эргономике и экологии производственного процесса на предприятии. ТСО'99 предъявляет более жесткие требования по всем направлениям: излучение, эргономика, энергопотребление и энергосбережение, экологическая безопасность, а также требует подготовки девайса к утилизации. Это все, конечно, хорошо, но если денег маловато, то не запаривайся этим всем. Вред от электромагнитных излучений гораздо меньше, чем вред от курения. Пусть твоя монька соответствует хотя бы MPR II.

Общение и бережливость

Следующий стандарт - это DDC (Display Data Channel), разработанный VESA (Video Electronics Standard Association). Это очень хорошая фишка, которая означает, что моника умеет обмениваться данными с видюхой, то есть является Plug & Play. Система автоматом получает всю инфу о девайсе (максимальные частоты горизонтальной и вертикальной разверстки, режимы энергосбережения и т.д.) и позволяет менять настройки прямо в свойствах монитора.

Если ты видишь на моньке знакомую с детства звездочку (Energy Star), это значит, что производитель монитора следовал рекомендациям агентства по защите окружающей среды США - EPA (Environmental Protection Agency). Иными словами, твоя моника умеет переходить в ждущий режим и засыпать, значительно снижая энергопотребление, если ты отошел с двумя тетками в спальню попить кофейку. Вот такие заморочки. Чузай унд юзай.

LCD: прогресс в массы

Технологии развиваются - девайсы дешевеют, поэтому подозреваю, что если не сейчас, то очень скоро тебе вполне хватит степухи на ЛСД (в смысле, на LCD-моньку). Чтобы понять, стоит или нет, давай разберемся, что это за мулька такая.

Вся эта байда стала возможной благодаря жидким кристаллам. Жидкие кристаллы - это такие вещества, в которых молекулы, несмотря на жидкое состояние, упорядочены, поэтому вещество обладает определенными оптическими свойствами. Под воздействием напряжения молекулы меняют свою ориентацию (противные!), а заодно и свойства света, проходящего через них.

Фильтры

Глазу человека, однако, по большому счету пофиг на такие изменения, поэтому переколбашенный свет нужно еще отфильтровать специальными пленками-фильтрами. Свет с измененными свойствами проходит через фильтр, а обычный - нет. То есть в тех областях, где напряжение есть и кристаллы повернулись (на 90 градусов), экран светится, а там, где напряга нет, экран темный. В цветных моньках используют три фильтра (RGB) или очень быстро меняют напряжение, получая последовательно три оттенка. Глаз человека видит результат их смешения. Второй способ эффективнее - то есть цвета более насыщенные.

Слоеный пирог

Жидкие кристаллы зажаты между двух прозрачных слоев, на которых прочерчены параллельные бороздки (на одном - вертикально, на другом - горизонтально). Таким образом, получаются клеточки-пиксели, из которых строится изображение. Фильтр в зависимости от напряжения поглощает свет полностью или частично, регулируя интенсивность свечения ячейки.


Спецвыпуск Xakep, номер #012, стр. 012-040-7, Не пялься в Монику, или выбираем крутой монитор

Не пялься в Монику, или выбираем крутой монитор

Donor (donor@real.xakep.ru)

Спецвыпуск Xakep, номер #012, стр. 012-040-7

Электричество в ячейки подается микроскопическими электродами, расположенными в каждой из них. Чем больше ячеек и электродов девелопер умудрился разместить на экране, тем выше разрешение. Все это безобразие называется "матрица" (хэз ю!). Матрица подсвечивается сзади. Этот свет после тучи трансформаций мы, собственно, и видим. Правда, есть ограничение - угол обзора равен 120 градусам. Вышел за пределы сектора - увидишь черный экран.

Главное в этом бреде то, что в LCD-юках нет электронной пушки, разгоняющей и отклоняющей систем, а следовательно, электромагнитное излучение, потребляемая и рассеиваемая мощности гораздо ниже (где-то на 70%). Свет идет постоянно, а не короткими импульсами, что гораздо лучше для глаз.

Эктив и пэссив

Понятно, что активная матрица - рулеззз, а почему? Дело в том, что в пассивной матрице напряжение колбасит ячейки по очереди (последовательно), поэтому изображение строится медленно и мерцает. Напряг на ячейках сохраняется долго, поэтому изображение еще и колбасит. Чтобы избежать этого, юзают Dual Screen - то есть условно делят экран на 2 части и сканируют их одновременно. Скорость сканирования и качество изображения увеличиваются.

В активной матрице каждый элемент содержит микроскопический прозрачный транзюк, хранящий один бит (0 или 1), то есть свойство ячейки сохраняется до следующего сканирования. Таким образом, в активной матрице каждая ячейка управляется отдельно, поэтому ячейки реагируют быстро, изображение контрастное и не расплывается. Транзисторы представляют собой специальную прозрачную пленку, обозванную "Thin Film Transistor" (TFT), толщиной в одну сотую микрона (!). Намутить такую ботву крайне сложно, и получается очень много брака, поэтому активные матрицы такие дорогие :(.

Кстати, частота регенерации у LCD-юков ниже: 60 Гц вполне хватает для качественной картинки без мерцания.

Кручу, верчу

LCD-дисплеям жизненно необходимо "обставить" CRT-мониторы, поэтому производители борются за качество изображения. Этому способствуют всякие вывертоны с кристаллами.

STN (Super Twisted Nematic) - в таких матрицах кристаллы вращаются не на 90, а на 270 градусов, что улучшает контрастность при больших размерах моньки.

DSTN (Double STN) - 2 спаренные ячейки вращаются в противоположные стороны. Контрастность еще выше.

TSTN (Triple STN) - тут для улучшения контрастности и цветопередачи добавлено еще несколько слоев полимерной пленки.

Разрешение LCD-шек

LCD-мониторы имеют только одно нормальное разрешение, которое зовется native. Оно соответствует количеству ячеек по вертикали и горизонтали моньки. При использовании более низкого разрешения получаются траблы. Можно либо использовать меньшее число элементов (изображение центрируется, а вокруг получается черная рамка), или "растянуть" изображение, но с ухудшением резкости. Поэтому разрешение нужно выбирать сразу. Яркость и контрастность моньки определяй на глаз.


Спецвыпуск Xakep, номер #012, стр. 012-040-8, Не пялься в Монику, или выбираем крутой монитор

Не пялься в Монику, или выбираем крутой монитор

Donor (donor@real.xakep.ru)

Спецвыпуск Xakep, номер #012, стр. 012-040-8

LCD-шки поддерживают разворот экрана на 90 градусов в вертикальной плоскости с автоматическим разворотом изображения (экран стал длиннее). Экран абсолютно плоский, поэтому нет искажений.

В общем, единственное, что пока удерживает меня от замены монитора, - это высокая цена LCD-шек, хотя она и упала за последнее время очень сильно.

Другие звери: Плазма

Работает это чудо по принципу неоновой лампы. Между двумя стеклянными пластинами находится инертный газ (аргон или неон). На внутренней стороне стекла наклеены микроскопические прозрачные электроды, которые дают разряд, и газ вокруг них светится в фиолетовом диапазоне, заставляя в свою очередь светиться люминофор. Плюсом этих мониторов является высокие яркость и контрастность изображения, насыщенные цвета при отсутствии дрожания картинки даже при очень больших размерах монитора. Основные минусы: он жрет много (чем больше сам, тем больше хавает), размер элемента довольно большой, а следовательно - низкая разрешающая способность. Используется для проведения конференций, презентаций и в качестве информационных щитов. Хотя в будущем при должном развитии по этой технологии можно будет строить плоские моньки и телевизоры. Такие телевизоры, в принципе, и сейчас есть, но стоят бешенных денег.

FED (Field Emission Display)

Принцип получения изображения тот же, что и в обычных CRT-моньках, но тут, вместо 3-х больших пушек, много маленьких источников электронов, раскиданных по люминофорному слою, поэтому эта мулька очень тонкая.

LEP (Light Emission Plastics)

Ну, это вообще чума! При помощи этой технологии смогли построить небольшой пластиковый экранчик толщиной 2 миллиметра (!). Правда, он пока монохромный. Но скоро ожидается появление большого цветного пластикового дисплея. Все это стало возможным благодаря тому, что некоторые полимеры (пластики) имеют свойство проводить электричество и светиться. Ученые добились того, что значительно повысили проводимость полимеров (и даже юзают их как дорожки в платах) и заставили пластик светиться разными цветами. Теперь осталось догнать срок службы до 20000 часов (около 10 лет) и наладить производство. Интересует одно: цена...

Абзац

Надеюсь, ты не захлебнулся во всей этой инфе и еще соображаешь. Тогда морально готовься к походу за новой моникой, но теперь выбирай подружку, основываясь не на рекламных уловках и понтах соседа Васи, а на знаниях и здравом смысле. Доброй охоты! Да! Спасибо умным перцам с http://www.ixbt.com/ за грамотную и полную инфу по монькам.


Спецвыпуск Xakep, номер #012, стр. 012-046-1, Лего для взрослых. Апгрейд компа - общие принципы

Лего для взрослых. Апгрейд компа - общие принципы

Спецвыпуск Xakep, номер #012, стр. 012-046-1

Андрей Каролик (andrusha@sl.ru; http://www.dal.net.ru)

Если у тебя ненароком в комнате завалялся компутер, то тебе, скорее всего, уже знакома проблема апгрейда. Если нет - это вопрос времени. Рано или поздно составляющие девайсы начинают и морально, и физически устаревать. А пролившееся на комп пиво - только прямой катализатор такого морального компьютерного разложения :). Прошло время, и ты решился прикупить что-нибудь новенькое из железа - нашел бабок, выбрал время. А тут возникает вопрос: что тебе вообще нужно? Ты опрашиваешь друзей, у которых тоже есть подобные железяки, гробишь кучу времени, и... не всегда делаешь оптимальный выбор. В конце концов ты берешь статьи про апгрейд и штудируешь приведенные обзоры и тесты. Хорошо, если в статье будет проведен объективный анализ, а не приведено голое субъективное мнение автора. Минус многих статей про апгрейд еще в том, что в них прослеживается тенденция навязывания одной конкретной конфигурации без альтернатив. Или же другие альтернативы выбраны такими, что даже дебил выберет однозначно только один вариант. Авторы статей часто ударяются в ценовую политику, забывая объяснить: а в чем, собственно, преимущество, и на чем скажется подобная разница. В этой статье я не буду разжевывать и класть тебе в рот конкретный вариант апгрейда, а опишу, как нужно ориентироваться в многообразии железок и по какому принципу собирать своего железного монстра.

Тише едешь, дальше будешь?

Выбирая среди нескольких вариантов, ты постоянно утыкаешься в проблему компромисса между навороченностью и стоимостью железяки. Если ты не нефтяной магнат, то подобная проблема тебя ждет на каждом шагу. Приходится балансировать между выбором более дорогой одной и более дешевой другой модели. Общее быстродействие компа при этом определяет не самая дорогая и навороченная составляющая, а их общее сочетание и желание работать вместе. Поэтому не гонись за новинками ведущих фирм-монстров компьютерной индустрии. Они сами же еще не раз еще будут исправлять баги своих девайсов и скидывать цену. Куда надежнее купить железки, проверенные временем и другими нерадивыми сборщиками-самоучками. А общую конфигурацию прикидывай заранее, выбрав сразу все составляющие железки. А то некоторые умельцы сначала покупают, к примеру, маму, думая потом, что же в нее воткнуть. Потом оказывается, что она не любит звук, изображение, и у нее едет безмозговая крыша. Не удивляйся потом, почему у соседа летает Celeron300A, а у тебя тормозит PIII.

Для чего тебе комп?

Логично, что начинка железного друга во многом будет зависеть от его будущего применения. Условно использование компа можно поделить на: игры в игрушки и работу с мультимедиа. Бывают ещё рабочие лошадки без игр и мультимедиа. Реально комп может использоваться универсально для всех направлений. Ты должен представлять, чем будут отличаться все три условные конфигурации компа. Останется только прикинуть, как ты будешь использовать свою тачку, и придерживаться приведенных ниже рекомендаций.

Чтобы играть в игры?

Новые игры - новые требования. Прежде всего, к памяти. Поэтому стоит заранее запастись большим винтом и прикупить побольше мозгов, чтобы не испытывать отвращение к новой якобы кульной игрушке. Минимум? Сама система съедает от 14 (Windows 95 OSR2) до 54 метров оперативки (Windows 2000) и больше (эта цифра полностью зависит от установленной системы). Это не считая динамического дискового кэша, драйверов под различные железки, и подгруженных библиотек, которые могут потребоваться системе. Поэтому смело ставь не менее 64 метров оперативки для операционных систем семейства Windows 9х, а для работы на базе NT - не менее 128 метров. В последнее время цены на память пикируют вниз, так что не скупись. Винт стоит покупать наибольшего размера, который ты себе сможешь позволить. Во-первых, цена на мегабайт обратно пропорциональна общему объему винта, а, во-вторых, некоторые игры занимают прилично дискового места. В некоторых играх, конечно же, есть альтернатива: делать не полную установку и проигрывать часть роликов и музыки с диска, но это не лучший выход и лишние тормоза в игре. Далее следует обратить внимание на видеокарту. Самое неприятное и раздражающее в игре - тормоза графики, поэтому без графического ускорителя тебе не обойтись. Мозгов видеокарточки желательно иметь не менее 8 метров. Мощные видеоадаптеры частенько капризничают в отношении питания AGP-слота, и этот факт тоже нужно учитывать. Например, на коробках некоторых карт так и написано - не рекомендуется использовать на материнских платах с такими-то чипсетами. Чтобы видеокарточка работала, как скоростная мясорубка, нужен хороший процессор. Выбирать проц нужно сугубо по тестам среди моделей одной ценовой линейки, которая тебе доступна.


Спецвыпуск Xakep, номер #012, стр. 012-046-2, Лего для взрослых. Апгрейд компа - общие принципы

Лего для взрослых. Апгрейд компа - общие принципы

Спецвыпуск Xakep, номер #012, стр. 012-046-2

Чтобы работать с мультимедиа?

Мультимедиа-приложения - самые прожорливые к памяти. Многие программы работы со звуком требуют, как минимум, 64 или 128 метров оперативки для нормальной работы. Дизайнерам трехмерной графики требуется аж 256 метров и больше. В мультимедийных приложениях становится критичной даже скорость работы памяти. И если в играх основная нагрузка на память ложится при расчете физики движения и обработке изображения перед передачей в акселератор, то наложение эффектов на видео в реальном времени уже серьезно зависит от скорости памяти. Самой выгодной по соотношению цена/производительность остается память PC100. Понятно, что кроме памяти для обработки звука и видео нужен хороший процессор. Если для пост-обработки совсем не обязателен быстрый процессор, то для обработки в реальном времени как аудио-, так и видеоданных нужен камень частотой не ниже 400-500 МГц. Профессионалы ставят процессорные мощности на первое место и приобретают сразу пару Xeon, или что-то более крутое, чтобы собрать двухпроцессорную систему. При этом возникает проблема выбора мам, поддерживающих такую конфигурацию. Другой вопрос, что программы, ради которых ты будешь тратить кровные на двухпроцессорную систему, могут вообще не поддерживать такую конфу, поэтому узнай сие до апгрейда. Запись потокового видео или многоканального звука требует очень быстрого винчестера. Самый лучший вариант - быстрый SCSI-диск. Но он дорого стоит и зверски греется. Приходится выбирать небольшой, но оптимальный рабочий SCSI-ый винт и большой IDE-ый для архивов. Для охлаждения SCSI-го винта придется выбрать более просторный и с дополнительной вентиляцией корпус. Профессиональные графические ускорители и звуковухи стоят больших денег, но без них в работе с мультимедиа не обойтись.


Спецвыпуск Xakep, номер #012, стр. 012-046-3, Лего для взрослых. Апгрейд компа - общие принципы

Лего для взрослых. Апгрейд компа - общие принципы

Спецвыпуск Xakep, номер #012, стр. 012-046-3

Рабочая лошадка, которая не использует игры и мультимедиа?

Обычные повседневные программы не так прожорливы к ресурсам - для хорошей работы вполне подойдет система на базе AMD K6 с 64 метрами оперативки и жестким диском на 6-8 гигов. Для изображения главным становится качество 2D-картинки. Монитор стоит брать хороший, и с диагональю от 15 дюймов, главное чтобы поставленное на нем разрешение поддерживала видеокарта. Лучше купить более дешевые железяки и хороший дорогой монитор, чем покупать потом очки.

Апгрейдимся

Классический апгрейд, как правило, проходит по следующей схеме:

- замена материнской платы

- замена процессора и перепрошивка BIOS

- замена и наращивание памяти

- замена видеоадаптера

- замена звуковой платы

- замена AT-корпуса на ATX

- замена материнской платы на ATX, а клавиатуры на PS/2

- замена винчестера

- замена CD-ROM

и т.д.

А теперь подробнее.

Процы...

По возможности следует перейти с платформы Socket-7 (Pentium, Pentium MMX, K5, K6, K6-2, K6-III, Cyrix, IBM, Rise, IDT) на платформу Slot1/Socket-370 (Pentium III, Pentium II, Celeron). При одинаковых частотах и приблизительно одинаковых ценах производительность Celeron (300A и выше) по сравнению с K6-2 на 10-40% больше, не говоря уже о существующих проблемах с AGP и производительностью подсистемы памяти на материнских платах для Pentium. При выборе процессора нужно руководствоваться следующими критериями:

Rise MP6 - самый медленный процессор (не считая AMD K5).

Cyrix MII (IBM) - очень продвинутая архитектура, очень сильный нагрев, требуют питания 2,9 В. Нуждаются в усиленном охлаждении. Иногда такой может самопроизвольно перезагружаться. По целочисленным операциям процессоры Cyrix MII немного опережают процессоры Intel Pentium MMX, по операциям с плавающей точкой значительно отстают. Не рекомендуются для 3D-игр.

AMD K6-2 - очень неплохой процессор. Немного опережает Intel Pentium MMX по целочисленным вычислениям, немного отстает по вычислениям с плавающей точкой. Ориентировочно можно говорить, что в работе K6-2-333 эквивалентен Pentium166 MMX, разогнанному до 250 МГц. Почему такая разница? Причина в том, что практически все программное обеспечение оптимизировано под архитектуру Intel. K6-2 слабо греется, обычно разгоняется на одну ступень (кроме K6-2-200 и K6-2-233, примерно половина которых запросто держит разгон до 300-350 МГц). Требует питания 2,2 В, в принципе возможна работа при напряжении до 2,4 В. Хороший вариант для апгрейда, если у тебя материнская плата с поддержкой K6-2.

AMD K6-III - достаточно дорог, поэтому гораздо лучше будет перейти на Celeron.


Спецвыпуск Xakep, номер #012, стр. 012-046-4, Лего для взрослых. Апгрейд компа - общие принципы

Лего для взрослых. Апгрейд компа - общие принципы

Спецвыпуск Xakep, номер #012, стр. 012-046-4

Intel Pentium MMX - выпуск давно прекращен, но приобрести его еще можно. Рассчитан на двойное питание, но прекрасно работает при одинарном, поэтому является наилучшим вариантом для апргрейда систем с материнскими платами, не рассчитанными на двойное питание. В таком режиме рекомендуется использовать усиленное охлаждение (не обязательно). Процессоры отлично разгоняются до 250-300 МГц. В ряде случаев для такого разгона необходимо повысить напряжение ядра до 3,2-3,3 В, и здесь усиленное охлаждение превращается уже в насущную необходимость. К сожалению, большинство процессоров имеют фиксированный коэффициент умножения, что не позволяет производить разгон путем его изменения. Единственный доступный способ разгона - изменение частоты шины.

...и мамуля

Не рекомендуется продукция Zida, Tomato, Super Grace. Смело можно приобретать ABIT, Chaintech, ASUS. Последние, к сожалению, обычно слишком дорогие. На материнских платах Slot1 (Socket-370) используются модули памяти DIMM SDRAM, рассчитанные на напряжение 3,3 В. Поэтому если со старой платой использовались модули SIMM или 5-В DIMM, то придется столкнуться с необходимостью замены модулей памяти. Желательно, чтобы модули памяти соответствовали спецификации PC-100, иначе могут просто не заработать. В настоящий момент приобретение Pentium II и Pentium III является экономически нецелесообразным. В ходе многочисленных тестов выяснилось, что они не всегда выигрывают у процессора Intel Celeron. Зато в цене отличаются значительно. Безусловно, речь идет о Celeron 300A и выше. Чипсет будущего приобретения должен быть только производства Intel. После того как ты решишь, какую материнскую плату приобрести (чипсет AT или ATX, Slot1 или Socket-370), самое время смотреть прайс-листы :). Обрати внимание, что современные материнские платы имеют всего 1-2 слота ISA, а могут не иметь вовсе.

Мозги

Современные программы становятся все более требовательными к ресурсам. Модули, которые можно порекомендовать к приобретению - это SEC, Micron, Hyundai, Fujitsu, Siemens, Toshiba, Nec, Mitsubishi, Hitachi. На чипах PC-100 должна быть специальная наклейка с надписью РС100-xxx-xxx, где "х" - это некие цифры. Однако наличия наклейки не достаточно. Хорошей гарантией может служить бренд-производитель из вышеперечисленных. Известны проблемы несовместимости некоторых модулей с некоторыми материнскими платами - в основном это касается noname модулей. В любом случае перед покупкой не помешает проконсультироваться или договориться о "money back".

Видюха

Для хорошей производительности и качества в современных играх, как я сказал выше, необходим 3D-ускоритель. Существует их великое множество, но все можно разделить на два класса: Glide и OpenGL. Glide-ускорители производятся только компанией 3Dfx. Это знаменитые Voodoo. К сожалению, этот стандарт уходит с рынка под давлением Open GL, и приобретение таких ускорителей имеет смысл, только если ты собираешься играть в игры, которым необходим Glide (Unreal). Большинство игр либо умеют работать в OpenGL, либо к ним написаны патчи, допускающие такую работу. Оптимальным выбором будет Velocity 100. Более мощные Voodoo3 стоят значительно дороже, но и позволят выжать большую скорость. OpenGL поддерживают все остальные 3D-ускорители, но нормальные драйверы написаны только для карт линейки TNT. При выборе карты не стоит обращать внимание на таких производителей, как Power Color, Manli и других noname, так как для них в порядке вещей занижать тактовые частоты чипа и памяти. По производительности чипсеты серии TNT располагаются следующим образом: Vanta, TNT, TNT2 M64, TNT2, TNT2 Ultra. Несколько в стороне находится GeForce 256. Могу порекомендовать карты таких производителей, как Creative, Diamond, ASUS, Elsa.


Спецвыпуск Xakep, номер #012, стр. 012-046-5, Лего для взрослых. Апгрейд компа - общие принципы

Лего для взрослых. Апгрейд компа - общие принципы

Спецвыпуск Xakep, номер #012, стр. 012-046-5

Звуковуха

Что тебе нужно от звука? Качество при прослушивании музыки или количество эффектов в играх? Если первое, то выбирай из Diamond Sonic Impact S90, Aureal Vortex Advantage, Creative SB PCI 128 Vibra. Все эти карты обеспечивают соотношение сигнал/шум не менее 85дБ, линейную АЧХ. Первые две, кроме того, имеют аппаратную поддержку A3D (позиционирование звука вокруг слушателя с использованием всего двух колонок) и аппаратное микширование многих потоков звука CD-качества. Для игр выбирай из Aureal Vortex2 (Diamond MX300) и Creative SB Live! (любая модель). Дополнительным аргументом может служить то, что Live! для реализации своих эффектов меньше загружает работой процессор, чем MX300.

Винт

Основываясь на достаточно обширной статистике, я бы порекомендовал трех производителей: Quantum, IBM и Fujitsu. Речь о дисках с IDE-интерфейсом. Quantum, по среднестатистическим данным, обладает большой надежностью, но сильно шумит при работе. Кроме того, модели Quantum традиционно одни из самых быстрых среди IDE-винчестеров. Fujitsu работает заметно тише, но и медленнее. IBM одновременно тихий, быстрый и надежный, но стоит значительно дороже, очень требователен к качеству питающего напряжения, не любит вибрацию. Что касается WD, Maxtor, Samsung - их надежность оставляет желать лучшего. При подключении современных винчестеров к старым материнским платам, к которым давно не выходило обновление BIOS, ты можешь столкнуться со многими проблемами. Это и неправильное определение дисков емкостью более 8,4 Гбайт, и некорректная работа дисков UDMA66 (для решения этой проблемы необходимо взять на сайте изготовителя винчестера утилиту, отключающую UDMA66-режим).

CD-ROM

Приводы выше 16х на практике требуются редко. Цены на приводы для чтения DVD потихоньку спускаются с небес. Не стоит покупать модели SONY, CREATIVE, HITACHI (модель 24x), PANASONIC (модель 585), ASUS, CyberDrive, SAMSUNG, BTC. Хорошие приводы делают TEAC (например, модели 524Е, 524ЕА, 532Е-В), TOSHIBA, PHILIPS, PIONEER Slot-In (без "подставки для кофе"), PANASONIC (кроме 585-й), MITSUMI.

Вот в целом и все. Теперь ты можешь прикинуть свои возможности, оценить потребности и, изучив прайс-листы, сделать грамотный апгрейд. Удачи!


Спецвыпуск Xakep, номер #012, стр. 012-049-1, Как я собираю комп

Как я собираю комп

Спецвыпуск Xakep, номер #012, стр. 012-049-1

Horrific (smirnandr@mail.ru, www.x-c-r.com)

Прошли времена, когда комп был доступен только профессионалам. Сейчас любой чайник с сигнализацией может научиться работать за компьютером. Хотя работой это не назовешь. Максимум, что они умеют - это запустить Quake и замочить пару сотен монстров. Из-за таких чудиков постоянно происходят глюки с железом и сбои в работе.

Чтобы ты не оказался среди подобных, я собрал в этой статье ряд практических рекомендаций по настройке и установке железа. За всю свою цифровую жизнь я настроил сотню компьютеров, и многие из них =) работают как наши Российские "командирские" часы. Мой комп работает без сбоев. Не веришь? У меня стоит Win98 уже три года без переустановок. И, при этом, у меня не происходит незапланированных зависаний. По плану у меня должно происходить одно зависание каждые пол-часа :). А если серьезно - то я уже забыл, как выглядит синий экран.

Что главное в надежности?

Все хотят знать, что же самое важное при обеспечении надежности железа? Я знаю, что большинство сейчас хором закричит "СТАБИЛЬНОСТЬ ОС". Потом начнут рассказывать мне про надежность Linux и ее безотказность. Но это все хорошо, но не так важно. Безотказность Linux - это хорошо, но я тоже безотказный и не могу отказать обнаженной красавице, лежащей на белой простыне :)... Но это не значит, что я надежный, и не могу дать сбой после пятого раза :)... Особенно, если перевыполню план по употреблению чудодействующего напитка "ПИВО".

Самое важное - это железо. На дырявом железе даже linux будет глюкать так, что ты задолбаешся баги отлавливать. Так что, самое главное - с правильной стороны подойти к железу.

Мать твою

Самой важной железкой в компьютере является мать. Если она сделана на уровне, то и комп будет вести себя достойно.

В отношении матери многие боятся чипсетов от VIA. Страх тут неуместен. VIA действительно какое-то время касячила с видюхами RIVA TNT, но это было очень давно. Все последние чипсеты прекрасно фурычат с любой видюхой, и на моей памяти уже не осталось никаких глюков. Конечно же, вообще баги у мам встречаются, но только по вине производителя мазыбордов.

Единственным недостатком VIA я бы назвал обязательность установки драйверов чипсета. Если у Intel на это можно положить что угодно и годами работать без проблем, то у VIA могут возникнуть проблемы. Я вообще заметил, чем меньше дров мы ставим, тем лучше работает комп.

Среди производителей мамок для меня нет однозначного лидера. Некоторые считают таким ASUS или Abit, а для некоторых и ZIDA – супер-пупер :). Но даже у мега-гигантов есть глюки и недоработки.

ASUS

Последняя на данный момент мать от этой конторы - CUSL2 - имеет проблемы с одним PCI-слотом. Он разделяет прерывание с USB-шиной, и поэтому в него не все можно вставить. Даже при включенном в BIOSе параметре "PNP OS Installed" нельзя в этот слот вставить сетевуху. Я провоевал с этим слотом целый день, но RL2000 так и не заработала, показывая конфликт с USB. К концу дня я не выдержал, и перебросил ее на другой PCI-слот. Если ты встретился с такой же проблемой, то просто переткни карту в другой слот - и никаких проблем. Иначе придется отключать USB (что не страшно, если ты его не используешь).


Спецвыпуск Xakep, номер #012, стр. 012-049-2, Как я собираю комп

Как я собираю комп

Спецвыпуск Xakep, номер #012, стр. 012-049-2

А в остальном мать показывает достаточно стабильную работу и высокие скоростные показатели.

Abit

Самая первая мать на i815 чипсете (я уже и не помню номера) глючила по-черному. Мой кореш купил себе компьютер с такой мамой, и у него перестали запускаться игры. Всем двором мы колдовали над компьютером: танцевали, пели ему песни - но он категорически отказывался запускать игры. Пока в корпусе не оказалась более новая версия мамки, гамесы так и не запустились. Возможно, мы наблюдали процесс несовместимости с каким-нибудь железом - а может, это был откровенный глюк. Но то, что компьютер спасла только замена матери...

ZIDA

Это просто гений несовместимости и глючности. Такого произведения искусства не было на нашем рынке никогда. Даже наши формозовские матери работали намного лучше.

PC-partner

Эта мать сейчас стоит в моем домашнем компе. Я долго искал в ней глюки, и нашел только один-единственный - мамка определила мой проц Celeron 566 как Pentium 3 на 566Mz. Да я и не в обиде :)... А как же тут обижаться, если она сама мне поставила частоту шины в 126 мегагерц? Теперь мой проц действительно работает почти как Pentim 3, благодаря разогнанной шине. А в работе мать показала отличную стабильность и не подарила мне ни единого глюка.

Остальные

Остальные матери, такие как Acorp и Chaitech, я считаю золотой серединой материнского рынка. Хотя сюда надо приписать еще и мою PC-partner. Все они достаточно простые и стабильные. Ничего лишнего, и ничего особенного. Лично я стараюсь использовать железо именно этих производителей. И за всю мою сознательную жизнь, ОСи вешались на них как родные, и работали как по маслу. Эти производители не сильно зажрались, и не сильно расслабились.

Ты только плохого не подумай. Я не являюсь противником ASUS или Abit. Их матери я тоже использую. Просто мне жаль переплачивать свои кровные за какую-то дополнительную мелочь, которую я не буду использовать. А выигрыш в скорости от их использования не значителен. Поэтому я вставляю эти мамки только в сервера и особо важные компы. Простые рабочие станции работают под PC-Partner.

Короче, я сейчас вообще-то не об этом. Я не пытаюсь сравнить матери, а стараюсь указать на известные мне глюки. А выбор матери полностью лежит на твоих плечах, руках, ногах и мозгах =).

Память

Если у тебя только один модуль, то никаких проблем. Просто вставляй его, и работай на здоровье. Но если у тебя их несколько, и они разного наминала - то могут возникнуть проблемсы:

Во-первых, ты должен убедиться, что память сможет работать на одной частоте. Если один модуль – 100мхз, а другой - 133мхз, то максимум, что ты сможешь выжать - это 100 общих Mhzов.

Во-вторых, оба модуля должны иметь одинаковые параметры задержки. Если они разные, то тебе нужно будет выставить в BIOSе максимальное количество тактов отдыха. Например, у тебя один модуль на 7ns, а другой на 8ns. В этом случае работать ты сможешь только на 8ns. Это самое главное, что ты должен проверить, если не хочешь познакомится с дядькой глюканатом.


Спецвыпуск Xakep, номер #012, стр. 012-049-3, Как я собираю комп

Как я собираю комп

Спецвыпуск Xakep, номер #012, стр. 012-049-3

В-третьих, если модули разного размера, то ты должен установить в первый разъем модуль наибольшего размера, а во второй - меньшего.

Если в твоей мамке три разъема под модули памяти, то третий разъем может быть только односторонним. Это значит, что двухсторонние модули в такой разъем не впихнешь, будет ошибка буфера.

IDE устройства

Если у тебя только два IDE-устройства (сидюк и винт), то желательно повесить их на разные шлейфы. Этим ты незначительно, но прибавишь в скорости. Сии устройства - единственные железки с механикой на борту (не считая дисковода), поэтому их скорость заставляет мечтать о большем, и приходится выжимать из них каждую мелочь.

Если у тебя больше двух IDE-устройств, то на первый IDE повесь загрузочный винт, а на второй шлейф можешь вешать остальное. На первый шлейф вешай только тогда, когда второй будет загажен полностью, и вешать будет больше некуда...

Проц

Ну, что сказать... Тут желательно хорошее охлаждение = хорошая паста + хороший радиатор на вентиле. Чем лучше охлаждение, тем меньше глюков ты можешь подцепить. А больше я ничего нового здесь придумать не могу.

Сборка прошла успешно

Итак, все железки на месте, пора приступить к установке ОСи. Наверно, если бы наш журнал назывался бы не СПХ, то мне пришлось бы полностью описать этот процесс. Но мне повезло, поэтому - просто уверен, что ты справишься и без посторонней помощи =). Когда все установишь, продолжай читать дальше.

После установки окон, первым делом щелкни правой кнопкой по "Мой компьютер" и войди в свойства. Здесь ты должен на закладке "Устройства" посмотреть, все ли оборудование смогла настроить твоя супер-оконная система. Если напротив какого-то устройства появился красный или желтый значок, то это означает, что это действительно Windows :), и все путем. Если все работает нормально и никаких красных или желтых значков нет - значит ты что-то не так сделал :). Попробуй переустановить окна =).

Настройка дров

Выдели устройство обозначенное желтым значком и нажми пимпу "Свойства". На первой странице, в разделе "Состояние устройства" должно быть написано, в чем проблема. Если происходит какой-нибудь конфликт прерываний или памяти, то ты должен перейти на закладку "Ресурсы" и надавить пумпу "Ручная настройка". Если ты сделал все правильно, то увидишь окно, похожее на рисунок 4. Внизу окна, в разделе "Список конфликтующих устройств", описано из-за чего происходит ошибка. Оказывается, ресурсина, отведенная под устройство, уже используется.

Что делать в этом случае? Нужно снять галочку с "Автоматическая настройка". Чуть ниже удобно расположился выпадающий список "Конфигурация". По умолчанию установлена "Основная конфигурация 0000". Попробуй установить другие, и посмотри в описании, остаются конфликты или нет. Если ты проверил все конфигурации и все они дают конфликты, то тогда придется вручную подбирать конфликтный параметр. Для этого щелкни по нему дважды и в появившемся окне выбирай любое другое значение.


Спецвыпуск Xakep, номер #012, стр. 012-049-4, Как я собираю комп

Как я собираю комп

Спецвыпуск Xakep, номер #012, стр. 012-049-4

В окне ручного ввода значений предусмотрена защита от кривых рук. Напротив строки ввода есть две стрелочки - вверх и вниз. Выбирай значения, нажимая на эти кнопочки - тогда окошки будут подставлять только допустимые значения. Не вздумай набирать цифры ручками - можешь что-нибудь не то ввести, и тогда - прощайте окна, до следующей переустановки.

Когда подберешь бесконфликтную конфигурацию, смело дави на "ОК". Окошки будут ругаться, предупреждая тебя о том, что они умней тебя и выбранное тобой значение может быть геморным. Смело игнорируй его предупреждения, и все будет в шоколаде.

Устройство работает неверно

А что делать, если нет никаких конфликтов, и ты уверен, что ты выбрал правильный драйвер? У меня такое постоянно случается с сетевухой RL2000. Windows категорически отказывается воспринимать драйвер с первого раза.

В этом случае можно удалить драйвер, перегрузить машину, и - когда Win опознает новое устройство - переустановить драйвер. Можно пойти и другим путем - войти в свойства устройства и на закладке "Драйвер" надавить на пимпу "Обновить". Такими методами я регулярно завожу свою сетевуху RL2000 после переустановки виндов. Причем, не могу сказать, что карта плохая. Она прекрасно работает, но устанавливается с 3 - 5-го раза.

2000 на проводе

Говорят, что NT не поддерживает Plug&Play. Это действительно так, но только не для Windows 2000. В ней работа с устройствами организована даже лучше, чем в Win9x, и большинство железок ОС определяет с первого раза.

Чтобы попасть в диспетчер устройств, нудно кликнуть правой крысой по "Мой комп" и войти в свойства. Здесь перейти на закладку "Оборудование" и надавить на пимпу "Диспетчер устройств".

Вот и сказке конец

От того, как ты соберешь свой комп и настроишь его дрова, зависит стабильность работы Windows. Даже мастдай может проработать без переустановки достаточно долгое время. Главное - правильно воткнутое и сетапнутое железо.

Если ты боишься подходить к внутренностям своего железного друга, то тебе придется покупать комп из серии Brand Name. Хотя я - противник этого метода. Даже брэнды очень часто собирают откровенное фуфло. Лучший комп - собранный твоими золотыми ручонками...


Спецвыпуск Xakep, номер #012, стр. 012-052-1, Оптимизация BIOS

Оптимизация BIOS

Спецвыпуск Xakep, номер #012, стр. 012-052-1

Horrific (smirnandr@mail.ru, www.x-c-r.com)

Основа любого компьютера - это BIOS. От него зависит надежность и стойкость работы всей тачки, поэтому оптимизацию моего железного друга я всегда начинаю именно с оптимизации BIOS. Некоторые (даже продвинутые) челы боятся туда лазить. Просто они запуганы мнением, что если что-то не так сделать, то можно покалечить компьютер. Отвечаю четко - чес голимый. Испортить комп с помощью BIOS очень тяжело. Единственное, что может произойти - компьютер перестанет грузиться. Но даже в этом случае ты сможешь войти в настройки BIOS и загрузить параметры по умолчанию.

Так откуда же возник миф, что в BIOS лазить нежелательно? Эту панику подняли безрукие любители разгона. Если ты попытаешься безмозгло разогнать свой проц и не проследишь за температурой, то может сгореть что угодно. Но о безопасном разгоне читай в другом месте, а моя задача - оптимизировать BIOS, что абсолютно безопасно даже для корявых рук. Предупреждаю сразу, что не все параметры могут присутствовать в твоем BIOSе, но большинство - будет обязательно.

Настрой свой PCI слот на PNP

Первое, куда ты должен заглянуть, - раздел "настройки PCI" ("PnP/PCI configuration"). Здесь ты обязан включить параметр "PNP OS Installed". Это позволит нескольким устройствам сидеть на одном и том же прерывании. Некоторые челы считают, что это невозможно... Если ты относишься к таким, то отсылаю тебя к спецификации по PCI. Там прекрасно написано, что PCI без проблем работает с несколькими устройствами на одном прерывании.

Конечно же, проблемы могут существовать, но только в некоторых сочетаниях устройств. Например, такое сочетание: устройство + USB слот. Некоторые устройства не дружат с USB и не могут сидеть с ним на одном прерывании. Но это бывает не на всех матерях. Посмотри на рис. 1. Это моя конфигурация компьютера. На 11 прерывании сидят видюха, две сетевухи, два хост контроллера PCI-USB и звуковуха. Нехило. Так что ты просто обязан включить в BIOSe параметр "PNP OS Installed".

Резервирование прерываний

Здесь же есть параметры с именем "IRQ №N Assigned to", где N - номер прерывания. Этот параметр позволяет зарезервировать прерывание на определенное устройство. Здесь ты можешь указать одно из значений:

"Legacy ISA" (классические ISA карты) - Карты для ISA, особенно без поддержки Plug&Play. Они иногда требуют ручного назначения прерываний в соответствии с документацией.

"PCI/ISA PnP" (устройства для шины PCI или ISA с поддержкой Plug&Play) - этот параметр устанавливается только для устройств на шине PCI или ISA карт с поддержкой Plug&Play.

Вручную можно назначить и каналы DMA: для этого здесь же существуют параметры с именем "DMA n Assigned to".

С помощью этих параметров ты можешь избавиться от конфликтов в системе, настроив их вручную.

Расширенные возможности BIOS

Теперь войди в раздел "Advanced BIOS Features". Продвинутый юзер, наверное, уже не раз бывал здесь, и, возможно, он уже знает те параметры, которые я буду сейчас описывать...

Наиболее интересными здесь являются:

Virus Warning


Спецвыпуск Xakep, номер #012, стр. 012-052-2, Оптимизация BIOS

Оптимизация BIOS

Спецвыпуск Xakep, номер #012, стр. 012-052-2

"Virus Warning". Это нужно отключить (disable). Это проверка на вири, которая, на моей памяти, еще ни у кого ни разу не дала результатов. Единственное, чего ты можешь добиться включением этого антивируса, - торможение компьютера. Лучше завести себе какой-нибудь антивирусный монитор, который грызет немного больше ресурсов, но работает намного эффективнее.

Ускоренный загрузчик

Следующие два параметра позволяют ускорить загрузку компьютера. Я думаю, не нужны лишние тесты при включении, потому что все равно толку от них мало, и ни меня, ни 100 компьютеров моей фирмы они ни разу не спасали.

"Quick Power on Self Test" - нужно включить (Enabled), чтобы при включении компьютера не происходило лишнего тестирования железок. Погоды от этого тестирования никакой, особенно если ты не гонщик-спиди.

"Boot Up Floppy Seek" - поиск загрузочной дискеты при старте. Абсолютно бесполезный параметр. Если при включении компьютера до проверки памяти твой дисковод судорожно трещит - значит, нужно отключить Boot Up Floppy Seek.

Гонка кэша

"CPU Level 1 Cache" - нужно включить (Enabled). В некоторых версиях BIOS он отключен, благодаря чему ты теряешь заветные килобайты кэша. А как известно, кэш очень сильно влияет на работоспособность системы.

"CPU Level 2 Cache" - та же песня, что и с предыдущим параметром, только это уже кэш второго уровня.

"CPU Level 2 Cache ECC Check" - нужно включить (enabled), только если у тебя память с поддержкой ECC. Параметр присутствует только у процев Pentium2/3. Этот параметр включает дополнительную проверку памяти на наличие ошибок. Как ты понимаешь, чем сложнее электроника, тем больше вероятность ее сбоя. Компьютеры - это слишком сложная железка. Несмотря на то, что она достаточно надежна, вероятность сбоя все же существует, хотя и очень мала. Чтобы снизить эту вероятность, некоторые устанавливают в свой комп память с проверкой ECC.

Оптимизация проца

"Processor Serial Number (Processor Number Feature)" - показать серийный номер процессора. Номер может быть индицирован только для процессоров Pentium III. Я думаю, что ты не хочешь, чтобы кто-то узнал номер твоего проца, поэтому вырубай эту дрянь с корнями.

"CPU Fast String" - разрешить быстрые операции со строками. Разрешение этого параметра позволяет использовать некоторые специфические особенности архитектуры семейства Pentium Pro (Pentium II, Deshutes и т.п.). Если у тебя не старый и простой пень (частота проца выше 233Mz), то желательно включить этот параметр.

"Boot Up System Speed" - скорость системы после загрузки. Может принимать значения: High (номинальная скорость процессора и номинальная частота системной шины) и Low (пониженная скорость процессора и частота системной шины). Я думаю, что не надо тебе объяснять, что нужно поставить. Конечно же, HIGH.

Мой винт - моя крепость

"HDD S.M.A.R.T Capability" - включение S.M.A.R.T. диагностики винта. При включенном параметре ты можешь заранее узнать о неполадках на винте, но зато компьютер будет работать немного медленней (на глаз ты это не увидишь). Хотя винт - наверное, самое медленное место в компьютере, и лишние тормоза ему абсолютно не нужны (это единственная механическая часть во всем компе, кроме флопа и сидюка. Есть еще вентилятор, но он на производительность не влияет :)).


Спецвыпуск Xakep, номер #012, стр. 012-052-3, Оптимизация BIOS

Оптимизация BIOS

Спецвыпуск Xakep, номер #012, стр. 012-052-3

Оптимизация работы памяти

Теперь посмотрим на раздел "Chipset Features Setup". Здесь хранятся параметры, влияющие на производительность памяти. Несколько наиболее интересных параметров:

Самое первое, что тебе надо установить - правильную скорость работы (AUTO Configuration):

"60 ns", "70 ns", "Disabled" (запрещена - позволяет установить любые возможные параметры доступа к DRAM памяти). Если ты правильно выставишь скорость памяти, то она будет работать быстрее и безглючно.

Параметр "DRAM R/W Leadoff Timing". Он устанавливает время выполнения операции чтения/записи. Возможные значения:

8/7 - восемь тактов чтения и семь тактов записи.

7/5 - семь тактов чтения и пять тактов записи.

Параметр "DRAM Read Burst Timing" - количество тактов задержки памяти. Можно установить следующие - x2222 (два такта), x3333 (три такта) и x4444 (четыре такта).

Параметр "SDRAM CAS# Latency" - задержка сигнала CAS. Может быть 2 или 3 такта.

И, наконец, "SDRAM CAS to RAS Delay" - задержка между сигналами RAS и CAS. Может быть 2 или 3 такта.

Это основные параметры, влияющие на производительность памяти. Я думаю, ты догадываешься, что в этих параметрах ты должен по минимуму установить задержки, чтобы память как можно меньше времени проводила в ожидании.

Страшная история напоследок: S.M.A.R.T. в безДЕЙСТВИИ.

Ты не поверишь, но когда я дописал абзац про S.M.A.R.T. и нажал "сохранить", у меня косякнул винт. Он почему-то начал трещать и скрипеть, и компьютер ни на что не реагировал. У меня в трусах (в районе заднего прохода) чем-то сильно запахло :). Чем - точно не знаю, но запах не очень приятный :). Я резко вырубил компьютер и попытался включить снова. Треск возобновился. Я опять вырубил тачку и почувствовал, что вокруг меня начали собираться мухи, потому что запах из моих штанов стал уже невыносим. Я снял винт и поставил его в другой комп. Хард заработал. Диагноз - скорей всего, клин.

Вот она, хваленая S.M.A.R.T., которая даже не пискнула о надвигающейся угрозе! И вот она, хваленая надежность (у меня винт IBM DTLA на 20 гиг и 7200 оборотов)! Хотя я IBM не виню, потому что ничего совершенного нет, и это первый косяк, который случился с винтом этой фирмы. Но S.M.A.R.T. я теперь отключил, потому что в реальной ситуации он меня не спас, а тормозами наградил. Что делать тебе - решай самостоятельно. Возможно, S.M.A.R.T. и спасает в каких-то ситуациях, но я в них пока не бывал...


Спецвыпуск Xakep, номер #012, стр. 012-054-1, Игрища с комповой жопой: любителям хардкорного секса посвящается

Игрища с комповой жопой: любителям хардкорного секса посвящается

Спецвыпуск Xakep, номер #012, стр. 012-054-1

Donor (donor@real.xakep.ru) & Doctor (Dr.Cod@real.xakep.ru)

Когда любовь не греет...

Случается, что ты тупо сидишь перед компом, и не знаешь, чтобы еще такого с ним сделать для получения оттяга и удовлетворения. В Халфу наигрался до опупения. Аська задолбала своими истошными "Йо-ху!" - так бы и выкинул всех волосатых админов, шифрующихся под Диан, Эльвир и прочих Венер, из контакт-листа. Порно-серваки вызывают рвотные позывы. С *nix-ами сношаться лениво. Трахнуть, что ли, железного в задницу? А это мысль ;)!

Изучаем объект.

Итак, поверни своего дорогого, любимого попочкой к себе, устройся поудобнее, расстегни... Эй! Я же шучу! Давай лучше посмотрим, что там за дырочки. Какие они разные, красивые и аппетитные! А ты не находишь, что они не заняты даже наполовину? Столько свободных отверстий! То есть, ты своему другу не додаешь. Не удовлетворяешь его, так сказать. Это плохо! Исправляйся! Давай подключим к нашей девочке что-нибудь необычное?

Видеовтык

Обрати свое пристальное внимание на район видеокарты. Если кроме RGB-порта, там есть еще кое-какие отверстия, то это очень сексуальное место! Что говоришь? Откуда там еще дырки? А какую видюху ты покупал? Не помнишь, пьяный был? Ну, не суть. Главное, что они там есть! А это значит, что ты можешь устроить своему личному другу сумасшедшую свиданку с отцовским метровым телевизором и не менее отцовским видаком :).

Позиция номер 1: коннектимся с ВеКаэМом

Для этой операции на видюхе должен быть видеовход (video-in). Такую мульку на свои девайсы пихают ASUSь и ATI. Остальные пока спят в оглоблях. Коннект осуществляется веревочкой "тюльпан-тюльпан". Пропихивай один кончик в video-in видеоплаты, а второй - в video-out на видаке. Теперь все, что ВКМ сливает в видеовыход, попадет к тебе на комп. Вместе с дровами к такой видюхе полагается спецпрога, которая перехватывает сигнал с video-in, и выводит его на монитор в окошке или полноэкранном режиме. Она же позволяет "захватывать" видео и сохранять на винте скрины и avi-шки. Так что можешь заморочиться с DivX-ом. Вот тебе и карманная пиратская видеостудия ;). Видишь, какая у тебя девочка способная? А ты и не знал!

Позиция номер 2: подключаем антенну

Можно, конечно, заюзать антенный вход (если он есть), но это - неприкольно. Всякие разные внутренние ТВ-тюнеры дают не очень качественный прием, а вот у видака тюнер хороший, и экранировано там все добрее. Плюс - можешь щелкать программы ДУ-шником. Кроме того, без вопросов можно кассетку посмотреть. Так что в результате скрещивания может получиться DVD-видео-ТВ-моноблок. В общем, подключай антенну через видак. Прогой, как правило, поддерживается и PAL (в этом формате плюется видак), и SECAM (это формат отечественного ТВ-сигнала).

Позиция номер 3: истошные крики

"Эй! А мне одной картинки мало - я хочу еще и стоны послушать!" - скажешь ты и будешь далеко не первым, от кого я это слышу. Переведи свой похотливый взгляд на звуковушку. С ней можно получить невероятные ощущения, если поюзать нужную щелочку. Звуковуха получает сигнал с внешних устройств: например, с микрофона, через line-in. Вот, к нему то мы и подрубим audio-out твоего ВКМа. Для этого тебе понадобится шнур "тюльпан-джек" (продается везде, даже в аптеке). На, прости меня, конце, у джека, должно быть 3 сегмента, разделенных тонкими пластмассовыми кольцами (как на штекере микрофона). Будь внимателен, а то сделаешь звукарю козу (короткое замыкание), и он у тебя сгорит. "Тюльпан" пихай в аудиовыход видака, а джек - в line-in звукаря. Включи в системе воспроизведение с line-in-а (в окнах это делается через матюгальник в трее), включи звук погромче и наслаждайся сладострастными звуками своей железки. Теперь твои дивухи будут со звуком. Также можешь подрезать с видака или телека коллекцию звуковых эффектов и образцов речи.


Спецвыпуск Xakep, номер #012, стр. 012-054-2, Игрища с комповой жопой: любителям хардкорного секса посвящается

Игрища с комповой жопой: любителям хардкорного секса посвящается

Спецвыпуск Xakep, номер #012, стр. 012-054-2

Позиция номер 4: я всегда с собой беру...

К видюхе легко можно подключить видеокамеру. Делается это через гнездо S-Video или video-in (зависит от камеры). Если очень извернуться, можно наладить конвейер по съемке, видеозахвату и кодированию в DivX "на лету". Но будь готов, что это у тебя не получится ни с первого, ни даже с 21 раза. Опыт нужен. В общем, теперь твоя карманная пиратская студия проапгрейдилась до порностудии ;).

Позиция номер 5: шиворот-навыворот

А теперь видюха будет насиловать телевизор! Да, она это умеет! Бери "тюльпан" и суй в Video-out своего компа. Телеку же, наоборот, втыкай коннектор в Video-in. Теперь ползи в свойства desktop-а, в прокладку "Настройка". Там есть кнопарь "Дополнительно". За ним скрывается куча опциональных возможностей для реализации отдельных извращенных фантазий. Но тебе сейчас нужен "ТВ-выход". Там чузай "Dual view" и узришь свой desktop на экране огромного папиного телека. Теперь выбирай обои попорнушнее, и... вперед! Да, чуть не забыл: разрешение нужно выставить 800х600 в high color, а то кина не будет.

Звуковое изнасилование

Звук - это очень важный элемент твоего компа, но мелкие китайские колонки - это не наш размерчик. Наша попа достойна большего! Можно прикупить понтовую систему акустики со всякими суб-под-надвуферами, но если это не о тебе - слухай сюды. Как вариант, некоторые подключают музыкальный центр. Ну, а если дадди тоже хочет послушать какого-нибудь Бабаха или Страуса в другой комнате? Придется таскать туда-сюда, либо покупать второй. Фигня получается! ИМХО, самый куль вариант - это заюзать старый ламповый усилок.

Подойдет любой совковый усилитель. Причем, средняя русская аудиосистема будет круче компьютерной за 100 баков. Усилком может поработать старый проигрыватель, старая радиола, магнитола, и т.п. Обычно там имеются хорошие колонки с большим динамиком. Бывает русская техника высокого класса. Например, ламповая радиола "Эстония", когда прогреется, может задать шороху соседям на 5 квартир вправо, влево, вглубь и вширь. У многих ламповые и транзисторные реликты тусуют на чердаках, подвалах, антресолях и помойках. Самовыносом/самовывозом тебе отдаст эту фигню любой знакомый фидошник или интернетчик.

Не забудь потребовать провода. Русские аудиопровода похожи на МИДИ-кабель. Чтобы превратить русский аудиоштекер в западный Джек, надо перепаять все нафиг, но это гимор. Либо - можно купить зло-переходник. Но его придется поискать. И еще он, зараза, может в звукарь не влезть, так как у него настолько толстая зопа, что на буржуиновой аудиокарте в аудиогнезда йенг легче пропихнуть. Так что, если поиски успехом не увенчались, придется перепаивать.


Спецвыпуск Xakep, номер #012, стр. 012-054-3, Игрища с комповой жопой: любителям хардкорного секса посвящается

Игрища с комповой жопой: любителям хардкорного секса посвящается

Спецвыпуск Xakep, номер #012, стр. 012-054-3

Подключаем синтезатор

Решил побаловаться с синтюком? А знаешь, что его, вообще-то, к компу подрубать надо, иначе ты будешь его использовать процентов на 20... А это сакс. Синтезатор работает в МИДИ-формате. Это значит, что музыка записывается в виде номеров стандартных МИДИ-инструментов, нот, продолжительности и громкости звучания. Таким образом, через МИДИ-вход ты сможешь клавишами ввести нотки в компьютер. Можешь импровизировать или подбирать мелодию, а комп выдаст нотные логи. Если ты все подбираешь на своей электрогитаре, то у многих гитарных процессоров и примочек тоже есть МИДИ-выход. Комп представит всю инфу графически, и ты сможешь ее обработать. Так пишутся почти все современные композиции.

И наоборот, ты сможешь использовать компьютер как интеллектуальный синтезатор, а потом сыграть через МИДИ-выход на каком-нибудь хай-эндном супер-гипер-мега синтюке мелодию, наколбашенную на компе. Еще МИДИ-интерфейс можно подключить сразу ко всем твоим устройствам с мидивходами, и заставить их играть, как оркестр. Мегавозможность для подрастающих крэзи дирижеров! То есть, секи фишку, синтезатор надо подключать к компу и юзать его на полную.

Куда тыкать-то?

Скорее всего, у тебя нет специальных МИДИ-портов в компе (они похожи на порты от клавы или на русские аудиоразъемы). Ну и не надо! В попе твоего друга есть стандартный Game-порт. Это такой разъем на твоей звуковухе с кучей дырок. По совместительству с ним трахается джойстик (геймеры знают). Чтобы подключить туда синтезатор, тебе нужен специальный МИДИ-шнурок. Вот, с его помощью и имей свой блок синтезатором или МИДИ-клавой в порт от джойстика. Причем, бывают такие шнуры, которые при этом оставят место для самого джойстика. Так веселее ;). Шнурок этот стоит рублей 100 - 150 (так как в нем стоит микросхема: она, типа, дорогая) и продается в магазинах и на рынке. Если ты офигенно богат, то можешь подсосать к Game-порту электронное супер-гипер-ультра пианино, установить себе на комп распознавалку нот, затариться папкой с нотами, и хреначить их через сканер прямо на него.

Чтобы активировать МИДИ-выход... зайди в Окошках в "Панель управления / мультимедиа", и все сам увидишь. Не забудь также включить МИДИ-вход в настройках звука =).

Не сгорит ли все к чертям?

Опасность всегда есть ;). Вообще, Game-порт изначально был предназначен именно для джойстика, но потом додумались, как использовать его не по назначению. Объясняю на кроликах... то есть на COM-порте. COM-порт был разработан для модема, и все его ноги - цифровые, а ног питания нет. Одна из ног предназначалась для передачи данных, остальные использовались для управления модемом. Например, подается на одну из ног напряжение - модем получает запрос на установку связи. Напряг на другой ноге - запрос на передачу данных. Потом в COM-порт решили подключить мышь. Но по идее, мышь не должна была заработать, так как в ней стоит микросхема, отслеживающая движение шарика. Ее надо кормить, а кормить COM-нечем (сиськи нету). Тогда решили так: пусть нога данных используется для передачи данных, а две управляющие ноги для питания мыши. Для этого драйвер мыши подает на них напряжение постоянно, на что ноги никак не рассчитаны. Поэтому существует опасность спалить порты. Некоторые мыши в свое время даже отказывались работать с отдельными мамами.


Спецвыпуск Xakep, номер #012, стр. 012-054-4, Игрища с комповой жопой: любителям хардкорного секса посвящается

Игрища с комповой жопой: любителям хардкорного секса посвящается

Спецвыпуск Xakep, номер #012, стр. 012-054-4

В Game-порте та же фигня. Шесть из его ног отвечают за питание микрухи, которая отслеживает движение рукоятки. По одной из каждых трех ног питания использовали для передачи МИДИ-сигнала (на вход и на выход). Конечно же, ноги на это не рассчитаны, поэтому, чтобы не спалить Game-порт, в МИДИ-кабель встроена схема, понижающая нагрузку на ноги. Поэтому лучше бери МИДИ-кабель в магазине, чтобы не выжечь одну из эрогенных зон своего компа.

Вперед и с песнями

Значит, договорились: ты будешь использовать свою любимую железку... на всю катушку. Дуй в магазин, закупайся кабелями и тыкать, тыкать, тыкать! Теперь тебе некогда будет скучать. Удачного секса :)!


Спецвыпуск Xakep, номер #012, стр. 012-058-1, Компьютер в твоем кармане

Компьютер в твоем кармане

Спецвыпуск Xakep, номер #012, стр. 012-058-1

Roman AKA Docent (romanakadocent@mail.ru)

Я достаю из широких штанин... да нет, не паспорт и не то, что ты подумал!

Маленький девайс с кнопочками и экранчиком, на 2-х мегабайтах памяти которого

умещаются органайзер, толстенный рассказ Пирса Энтони "Хтон", конспект по

предмету, который я сейчас еду сдавать, арканоид, шахматы, десяток полезных в

быту программулин, а также вот эта самая статья, которую ты сейчас читаешь.

Intro

Мы как-то тебе уже рассказывали о карманных компьютерах и о том, что можно

делать с их помощью. И, возможно, в твоем кармане уже давно поселился этот

необходимый любому современному прогрессивному человеку девайс. Ну а если ты все

еще думаешь, нужно оно тебе или нет, то, надеюсь, данный материал все-таки развеет твои сомнения и позволит склониться к тому или иному решению. Как правило, новый современный карманный компьютер - вещица недешевая, так что твой карман в некоторых случаях может нехило похудеть, лишившись энного количества зеленых бумажек (если они там, конечно, есть), перед тем как вновь потолстеть, но уже от приобретенной железяки. Здесь уже надо подумать, для чего главным образом ты будешь использовать КПК. Цены на новые современные карманные компьютеры колеблются в среднем от 120 до 1000 долларов. Разумеется, на барахолках

можно найти подержанные или устаревшие модели по куда более низким ценам (иногда попадаются и настоящие динозавры) и потом гордо заявлять, что фигню я тут всякую написал и что тебе удалось купить крутой карманник с Windows CE всего за 100 баксов.

Что же, в этом случае тебе можно только позавидовать. Но при таком раскладе также есть и реальный риск приобрести тачку со скрытыми дефектами, глюками или

неполадками, которые сразу могут себя и не проявить: может быть, тот чувак, который ее продал, орехи ею колол. И еще, чаще всего такие машины могут продаваться без всяких необходимых аксессуаров - таких, как кабель синхронизации с настольным ПК, например. Если софт для него можно скачать в Инете, а адаптер купить на той же барахолке, то синхро-кабель, если тебе его и удастся найти отдельно, может обойтись еще в одну стоимость компа (а то и дороже) =(. А если КПК еще и древний или какой-нибудь экзотический - то можно вообще ничего к нему не найти. Так что лучше уж купить новый комп, чем потом переплачивать или мучаться.

Виды и цены

Цена маленьких компьютеров, как и у больших, зависит от функциональности,

технических параметров, возможности подключения различных устройств

и прочих наворотов. Самые дешевые (120-200 долларов) - это, в основном, компьютеры семейства Palm с перьевым вводом, операционной системой Palm OS, монохромным дисплеем и небольшим объемом памяти (2-4 Мб). Несколько более дорогие (200-400 долларов) - это те же Palm'ы с большим объемом памяти и более мощным процессором, а некоторые из них обладают еще и цветным дисплеем (256 цветов). В эту же категорию попадают и всяческие Palm-клоны с той же осью и теми же параметрами - такие, как Hanspring Visor, Sony и им подобные. Некоторые из Palm'ов обладают дополнительными возможностями - вроде сменных носителей на Flash-картах, встроенных микрофонов, MP3-плееров и других примочек, которые готовы отъесть от твоего бюджета дополнительные средства.


Спецвыпуск Xakep, номер #012, стр. 012-058-2, Компьютер в твоем кармане

Компьютер в твоем кармане

Спецвыпуск Xakep, номер #012, стр. 012-058-2

Примерно в тех же ценовом и техническом диапазонах оказываются и компьютеры

семейства Psion. Только от Palm их главным образом отличает наличие клавиатуры и

другая ОС - EPOC.

И, наконец, самые дорогие, уверенно перешагивающие 400-долларовый рубеж и иногда даже сравнимые по ценам с ноутбуками среднего класса - это устройства с операционной системой Windows CE или Linux (да, да, Пингвин тоже может быть ручным). Такие машины бывают как с перьевым, так и с клавиатурным вводом, сравнительно мощным процессором, оснащены цветным дисплеем (65 тыс. цветов), имеют сменные носители на Flash-картах и даже обладают полноценной звуковой системой, а некоторые еще и видеокамерами. Наиболее распространенный у нас представитель этого вида - это Casio "Cassiopeia".

В природе также существуют и КПК с собственными нестандартными

операционными системами. Некоторые из них могут быть даже дешевле 100 долларов (но это уже скорее продвинутые записные книжки, чем компьютеры), и не очень пока еще распространенные в России коммуникаторы - карманники со встроенным сотовым

телефоном. Так что все зависит от того, для чего тебе этот девайс и сколько ты готов за него выложить денег. Может быть тебе нужно всего-то телефоны своих подружек хранить и книги читать, тогда хватит и чего-то самого простого и недорогого. А может быть тебе хочется иметь мобильную игровую систему - только в этом случае подумай, может тебе вообще ноутбук купить?

Мне вполне хватает Palm m100 с монохромным дисплеем и 2 Мб памяти. Это,

кстати говоря, пожалуй, самый маленький по габаритам и самый дешевый из всех

существующих КПК. Вообще же, лучше всего отдать предпочтение именно этой платформе. И не только из-за более-менее доступных цен - для Palm и его клонов существует гораздо больше всяких устройств и программ.

Клава против пера

После этого стоит подумать насчет того, как ты будешь заносить в этот комп

всякую инфу: тыкая по кнопочкам или с помощью пера. И у того и у другого способов есть свои плюсы и минусы. Пером ты можешь быстро вводить текстовую или даже графическую информацию и кликать по иконкам на экране. Но скорость такого ввода все-таки будет значительно ниже, чем если ты будешь печатать то же самое с помощью клавиатуры. Кроме этого, придется еще привыкнуть к способу начертания символов, так как твой обычный почерк, каким бы он ни был идеальным, этот девайс все равно не распознает - ну не дошла пока еще техника до такого интеллектуального уровня. С помощью клавиатуры ввод будет осуществляться быстрей, и не придется привыкать к системе распознавания почерка или вспоминать, как ввести тот или иной символ. В трясущемся автобусе пером писать гораздо трудней, чем нажимать кнопки. Зато кнопочки у таких компов слишком малы, чтобы комфортно печатать на них всеми десятью пальцами. Кроме этого, в "походных" условиях тебе все равно придется печатать одной рукой, так как второй ты будешь держать сам комп. И вообще, я думаю, что, например, в тесноте вагона метро или на весу удобней писать пером, чем тыкать в кнопки. У клавиатуры есть еще один недостаток - она быстро засоряется и, к тому же, от частого использования постепенно стираются напыленные на резиновую основу под кнопками контакты. Впрочем, можно купить и компьютер с перьевым вводом и при необходимости


Спецвыпуск Xakep, номер #012, стр. 012-058-3, Компьютер в твоем кармане

Компьютер в твоем кармане

Спецвыпуск Xakep, номер #012, стр. 012-058-3

купить к нему складную клавиатуру (в сложенном состоянии она не больше самого КПК). Правда, цена такого устройства неоправданно высока и приближается к цене карманника с перьевым вводом. Печатать на ней будет удобней, чем даже на клавиатурных КПК, так как кнопки имеют тот же размер, что и на клаве твоего настольного компа. А вот печать стоя и на весу будет практически невозможна.

В общем, я выбрал именно перьевой ввод и ничуть об этом не жалею.

Области применения:

Органайзер

Органайзеры давно уже суют почти во все электронные девайсы - от наручных часов

и мобильников до пылесосов и кухонных комбайнов. Безусловно, электронный

органайзер намного удобней бумажной записной книжки, и без него сейчас не обойтись ни школьнику, ни бизнесмену. Про это даже писать незачем, такой фишкой можно удивить разве что неандертальца с острова Маза-Фака. Хотя, если тебе только это и нужно, зачем тратить с полсотни зеленых президентов? Купи дешевые китайские часы или простейший мобильник и радуйся жизни - в них ты, скорее всего, всегда найдешь записную книжку и калькулятор.

Электронные книги

Тебе лень идти в ближайший книжный магазин или библиотеку? Увесистый

книжный томик мешает засунуть в твой рюкзак еще один винчестер и парочку сидюков? А читать книги ты все-таки любишь. Тогда тебе просто необходим карманный компьютер. Нынче почти любую книгу можно отыскать в электронном виде в сети. Например, на сайте Мошкова, www.lib.ru, ты, скорее всего, найдешь то, что долго не мог найти в магазинах и библиотеках. Здесь есть почти все: от Пушкина до Пелевина.

Средняя книга весит от 400 до 800 килобайт. Простейшего и самого дешевого

монохромного Palm'а с 2 мегабайтами памяти тебе хватит. Хотя, если ты читаешь много и быстро и у тебя есть еще одна лишняя сотня баксов, то стоит подумать об устройстве с бoльшим объемом памяти, чем 2 мегабайта.

У электронных книг куда больше преимуществ, чем у бумажных. Во-первых, ты

сможешь всегда, не выходя из дома, найти почти любую книгу в сети. Во-вторых, некоторые книги вообще существуют только в электронном варианте и никогда не издавались в бумажном. В-третьих, такая книга не будет стоить тебе почти ничего, оплатить придется только доступ к сети и однажды потратиться на КПК. А еще электронная книга измеряется исключительно в килобайтах, а не в габаритах и весе, и ты сможешь уместить пару толстых книг у себя в кармане. Да и держать КПК в тесном транспорте удобней, чем книгу. Я уже не говорю о том, что обычную книгу ты сможешь читать только при свете, а с подсвечивающегося дисплея КПК можно читать хоть в темном купе ночного поезда, причем глаза от этого устают ненамного больше, чем от чтения текста на бумаге.


Спецвыпуск Xakep, номер #012, стр. 012-058-4, Компьютер в твоем кармане

Компьютер в твоем кармане

Спецвыпуск Xakep, номер #012, стр. 012-058-4

Шпаргалка нового поколения

Что делать, если у тебя намечается сессия, а для тебя какой-то предмет ненамного понятней китайской библии? Да ты и был-то на нем только один раз за семестр. Учить смертельно ломает, а сдавать-то все равно придется. Понятное дело, нужно стрельнуть у кого-нибудь конспект, понаделать шпор и молить Бога, Аллаха, Будду и всех, кого там только можно, чтобы тебе повезло. Это хорошо, если твой препод сговорчивый или просто добрый. А если нет? Тогда использование конспектов шпор и прочих бумажных носителей становится весьма затруднительно. Я думаю, ты меня уже понял. Лучшей шпаргалки, чем карманный компьютер, пожалуй, еще не существует. Да закладывай туда хоть целый конспект и открыто списывай с него прямо на экзамене! Главное только - не полениться все туда занести перед экзаменом. Ну, конечно, совсем-то наглеть все равно нежелательно, вдруг препод не ламерский попадется и каким-либо образом тебя раскусит. Вообще, вероятность того, что тебя засекут, очень мала - карманные компьютеры еще не распространены среди студентов, и преподы к такой фишке еще не успели привыкнуть и, скорее всего, даже и не задумываются об этом. Кроме этого, работает элементарная психология: за годы работы они так привыкли к бумажным шпаргалкам и тетрадям, что именно за ними они и будут следить и могут просто не заметить и не опознать намек на шпаргалку в мирно лежащем на столе и практически неотличимом от продвинутого калькулятора приборе. А уж калькулятор на экзамен проносить еще никто не запрещал. Хотя калькулятор на "концепции естествознания" будет выглядеть странно, но все-таки вряд ли тебе запретят держать его при себе. Главное - сохранять спокойствие и почаще делать умный и задумчивый вид.

Особенно хорош на экзамене опять тот же Palm, так как внешне он практически неотличим от калькулятора, в отличие от девайса с клавиатурой, который вполне может привлечь внимание твоего лектора и вызвать у него сомнения. А в случае с Palm'ом, если даже препод что-то и заподозрит и направится в твою сторону, ты всегда успеешь нажать на кнопку, вызывающую на экран калькулятор, и впарить слишком наблюдательному профессору, что это всего лишь навороченный китайский счетовод. Если ему не приходилось с этим сталкиваться ранее, то такая отмазка, скорее всего, покатит. Я таким образом сдавал высшую математику, и препод, хотя и проходил каждые пять минут мимо меня, выгоняя попутно некоторых засветившихся студентов, на меня внимания не обратил и даже похвалил, что я так правильно все решил :). Эх, надеюсь, что преподы наш журнал не читают.

Офис в кармане

Если твоя работа или увлечение так или иначе связаны с написанием некоторого

количества текста, то тебе также пригодится КПК. Особенно если у тебя не хватает

времени закончить работу дома или в офисе - ты сможешь делать это в пути. А если ты пишешь рассказы или стихи, то с таким девайсом ты всегда и в любом месте сможешь записать внезапно пришедшую мысль. Конечно, если тебе нужно много работать в полевых условиях с текстами - лучше подбирай себе карманник с клавиатурой. Для работы с текстами и таблицами на КПК существуют аналоги


Спецвыпуск Xakep, номер #012, стр. 012-058-5, Компьютер в твоем кармане

Компьютер в твоем кармане

Спецвыпуск Xakep, номер #012, стр. 012-058-5

Word'а и Excel'а. Вот, например, эта статья, которую ты сейчас читаешь, частично создавалась на Palm'е с перьевым вводом - я уже об этом упоминал.

Интернет и почта

Конечно, использование Инета в полевых условиях связано с использованием

сотовой связи, что является довольно дорогим удовольствием. К тому же, в наших

сотовых GSM-сетях пока что нельзя коннектиться быстрее, чем на 9600 кб/сек. Да и сайты смотреть на таком маленьком экране не очень удобно. Тем более что на КПК с монохромным дисплеем страницы будут только в текстовом виде. Зато вот почту, если очень приспичит, достать вполне реально, если, конечно, тебе никто не закинет в это время бааальшой MP3-файл =). Кроме этого, специально для Palm'ов существует версия клиента ICQ - то есть при желании можно базарить по аське со своего карманного компьютера. Также для многих КПК существуют внешние модемы на обычную телефонную линию, а в некоторых они уже встроены. Если тебе так уж необходим мобильный Интернет - приобретай КПК с модемом или вообще коммуникатор. Хотя есть и более простой способ: почти у любого карманника есть инфракрасный порт: останется только приобрести сотовую трубу с таким портом и возможностью передачи данных. Ну и, конечно, у сотового оператора надо не забыть включить соответствующую услугу. Хотя подумай: а так ли тебе оно надо? Дорого, неудобно и непрактично.

Взлом

Конечно, с этого-то как раз и стоило, наверное, начинать, но, к сожалению, пока что мало кто серьезно рассматривал КПК как платформу для взлома. Но прогресс не стоит на месте, и на некоторых хакерских сайтах уже стали появляться адекватные проги. Мне попадались только для Palm. Хотя вот вирусы для КПК уже давно существуют. А дядя Касперский уже успел разработать версию своего антивируса для Palm'а. Кроме этого, уже есть сайты по взлому и исследованию софта для КПК. Вообще, с карманником вполне можно так же хакать, как и с большим компом. Причем, с ним ты обретаешь настоящую мобильность и можешь, например, подключиться к какой-либо системе где угодно, хакнуть и быстренько смотаться, сотворив грязное дело. В некоторых случаях такой девайс даже удобней ноутбука. Возможности и перспективы тут открываются очень даже заманчивые. Почему бы, к примеру, не использовать его как программируемый эмулятор какого-нибудь электронного ключа или карточки (вспомни фильм Терминатор-2)? Кустарным девайсам, собранным на базе PIC-контроллера, и не снились такие возможности. Так что нам с тобой еще предстоит осваивать и создавать всякие хацкерские примочки и проги для карманников.

Игры

Поскольку карманные компьютеры изначально создавались в основном для работы в

полевых условиях, в них никто не планировал ставить Pentium 4 и GeForce 3. Никаких Quake 3 и Need For Speed на них, разумеется, нет. Так что, если тебе жизненно необходима мобильная игровая система, покупай лучше ноутбук. А карманник в этом плане сравним с геймбоем. Хотя существуют даже специальные джойстики для Palm. Игр для них появляется все больше и больше. Причем в последнее время стало много действительно красиво смотрящихся даже на монохромных КПК. Многие из игр


Спецвыпуск Xakep, номер #012, стр. 012-058-6, Компьютер в твоем кармане

Компьютер в твоем кармане

Спецвыпуск Xakep, номер #012, стр. 012-058-6

перекочевали на карманники с древних компов, игровых приставок и геймбоев.

Разумеется, в первую очередь это тетрисы, арканойды и шахматы. Встречаются даже

пародии на Doom, F1 и SimCity. Так что карманный комп вполне может служить в качестве геймбоя и помочь скоротать время на скучной лекции или в транспорте.

Выводы

В общем, вот тебе пища для размышления. Думай сам, нужно оно тебе или нет.

Конечно, способов применения можно найти еще немало. Как видишь, КПК может быть

почти чем угодно. Несмотря на то, что этот девайс в среднем ненамного больше пачки сигарет, это все же полноценный компьютер, который, как мобильник и наручные часы, необходим любому современному человеку, не говоря уже о таких хаксорах и киберпанках, как мы. Оглянись вокруг - в метро, на улице, в твоем институте ты наверняка заметишь хотя бы одного человека с карманным компьютером. Это уже давно перестало быть сюжетом из фантастического фильма, так может и тебе стоит обзавестись этим полезным девайсом?


Спецвыпуск Xakep, номер #012, стр. 012-062-1, Вкусная картинка: видюхи под микроскопом

Вкусная картинка: видюхи под микроскопом

Tony (tony@nifti.unn.ru)

Спецвыпуск Xakep, номер #012, стр. 012-062-1

Здорово, перец, да перестанут приставать репьи к хвосту твоего ишака. Как у тебя делищи? Наверняка уже задолбался крошить сонмы чмонстров в твоем любимом шутере? Тормозит гад, да? Сегодня я хочу тебе рассказать о том, что позволяет тебе видеть всех этих огров и асаултеров - то есть о видеокартах. А также о том, как заставить железного баксо-паразита перестать задумываться о путях Господних при появлении в зоне твоего поражения очередного десятка тварей.

Вначале было слово... машинное

В то далекое время, когда компьютеры занимали каждый по зданию со средний детсадик, а сами обладали способностями среднего детсадовца (по сегодняшним меркам), и изо всех визуальных средств программирования в наличии было только устройство для прокалывания перфокарт, умным и бесконечно загруженным дядькам даже в голову не приходило заниматься со своими "калькуляторами" какими-либо играми или прочей лабудой. Эти нехорошие дяди (и чуть более очаровательные тети) занимались вычислением траекторий полетов баллистических ракет, выращиванием новых смертоносных вирусов и прочими очень полезными делами. Данные, в которых они нуждались, выводились на километры туал... пардон, рулонной бумаги и перфокарты. Иногда нужда брала дядек (и теток) за причинные места, и им хотелось в реальном времени наблюдать инфу. В этом случае в качестве визуализаторов выступали лампочки и цифровые индикаторы, примерно как на часах в здании вокзала. Но шло время, и дядькам стало напряжно колбасить софту на перфокартах. ЭВМ (твой старичок - препод информатики - просто обожает это слово) скрестили насильственным путем с телевизором. То, чем скрещивали, получило название "видеоадаптера". Телевизор нарекли "алфавитно-цифровым монитором". Это мудреное название полностью отражает суть девайса. Люди тогда не задумывались о полезности гуевого интерфейса, кнопки "Пуск" и меню "Завершение работы..." для рядового ламера, и консоль их устраивала полностью. Ведь компьютеры в то время были уделом избранных.

Думаешь, что видеоадаптер - эта железка, вставленная в свободный разъем компа, к которой подключен монитор? Ты ошибаешься! Видеоадаптер - это, в первую очередь, микросхема RAMDAC (RAM Digital to Analog Converter). В этой самой RAMе (с форточкой и маргарином не путать! :)) хранится инфа, которую RAMDAC преобразовывает в аналоговый телевизионный сигнал (синхросмесь). Эта память называется видеопамятью. В современных понятиях - это фрейм-буфер (в то время он был одним-единственным). Еще немножко рамы уделялось изображениям отдельных, последовательно расположенных в памяти буковок, черточек и циферок. Вся эта ботва называется знакогенератором. Видеопамять физически располагалась либо на карте рядом с RAMDAC (в случае IBM PC), либо являлась отведенной частью системной памяти (например, в Спектрумах).

Нашествие писюков

Видюхи в их современном виде стали возможны благодаря появлению писюков в начале 80-х годов. Тогда на рынке тусило много платформ: Spectrum, Atari, Amiga, Apple и прочие. Но круче всех разрулились IBM-овские XT-шки, так как имели "открытую" архитектуру. Для их модернизации не надо было выпаивать из чрева большущий шмот электроники и впаивать туда другой. Нужно было только вынуть из слота одну железку и воткнуть туда другую, а старую "толкнуть". Именно поэтому почти все сдохли, а Голубой Гигант выжил.


Спецвыпуск Xakep, номер #012, стр. 012-062-2, Вкусная картинка: видюхи под микроскопом

Вкусная картинка: видюхи под микроскопом

Tony (tony@nifti.unn.ru)

Спецвыпуск Xakep, номер #012, стр. 012-062-2

Так вот: видеокарты полностью соответствовали этому принципу. Самым первым видеоадаптером писюка был MDA - Monochrome Display Adapter. Он был разработан... IBM (естественно!), работал только в текстовом монохромном режиме в разрешении 80х25 символов. Отсутствие возможности вывода графической информации побудило в 1982 г. небольшую фирму Hercules Computer Technology Inc. (вот они, прелести открытой архитектуры!) создать монохромный (с несколькими градациями серого цвета), но уже графический видеоадаптер - HGA (Херкулес график адаптер =)), к которому подключался все тот же монохромный монитор, что и к MDA. Вскоре появился адаптер, позволяющий отображать информацию как в текстовом, так и графическом виде в цвете. Им стал CGA - Color Graphic Adapter (опять шутки IBM). С помощью CGA можно было узреть 16-цветную текстовую и 4-цветную графическую инфу. Однако, он имел крайне низкую разрешающую способность - 320х200 пикселей. Эту видюху уже можно было использовать с цветными мониторами и с обычными телевизорами. Дальше "кривая роста технологического прогресса" ((с) г-н Греф) с этого момента резко пошла вверх. IBM колбасит EGA - Enhanced Graphic Adapter (Бабушка Ега! Йоу! :)), работающий с 16-ю цветами в разрешении до 640х350 пикселей и VGA (Video Graphic Adapter) - разрешение которого достигало 640х480 точек в 16-цветном режиме. Кроме того, для него появляется и новый 256-цветный режим в разрешении 320х200. С этого момента в индустрии писюков по причине открытости архитектуры наступает полный бардак: видеоадаптеры начинают выпускать все, кому не лень. Это, впрочем, есть очень большой GOOD: чем жестче конкуренция, тем выгодней конечным юзверям. Все эти девайсы втыкались в ISA-слоты.

Суп с котом?

А дальше - прогресс и ламеризация. Прорвавшиеся к компам непрофессионалы хотели картинку получше. Девелоперы не могли им отказать :). Появился стандарт SVGA - Super VGA, с разрешениями вплоть до 1024х768 пикселей и High Color/True Color (64K/16M цветов). Ограничения на разрешение и количество цветов зависели только от размера видеопамяти (фрейм буфера). Естественно, что для обработки такого потока видеоданных старой 16-ти разрядной ISA шины было уже маловато. И поэтому SVGA адаптеры использовали новую 32-битную шину PCI.

Функционально видюхи того времени были практически одинаковы и несли в себе одну лишь функцию - преобразовывать массив данных цифрового изображения в картинку на экране. Каждый из пикселов кодировался числом, имеющим размер от одного бита до 32 бит. Хотя вру - 24-х, поскольку тогда еще никто и предположить не мог, что пиксел, кроме 3 байт RGB-составляющих цвета, может обладать еще и байтом прозрачности. Видеорежимы разделяются на палитровые и непалитровые. Непалитровые режимы - это наши любимые high color (16 бит для RGB компонент: 5-5-5 или 5-6-5 бит) и true color (24/32 бита - по байту на цвет). С палитровыми режимами дело обстоит несколько сложнее. Перед активизацией нужного режима необходимо заполнить специальный массив данных - палитру (информация о RGB составляющих каждого цвета, входящего в палитру). Палитровые режимы - это режимы с количеством цветов, меньшим или равным 256. Для совместимости между собой видеоадаптеров различных производителей был придуман стандарт VESA. Это расширение возможностей (а их к этому времени сильно не хватало) стандартного 0х10 прерывания BIOS, отвечающего за работу с видюхой.


Спецвыпуск Xakep, номер #012, стр. 012-062-3, Вкусная картинка: видюхи под микроскопом

Вкусная картинка: видюхи под микроскопом

Tony (tony@nifti.unn.ru)

Спецвыпуск Xakep, номер #012, стр. 012-062-3

Новый пинок технологиям

И тут в наступление поперла игровая индустрия, накручивая сама себе требования к графике в гамесах. А также случилось еще несколько важных событий. Мелкософт почуяла запах жирного геймерского мяса и в дополнение к своему стандартному GDI - Graphic Device Interface (прорисовка форточек, рамочек, кнопочек) решила выпустить специальную графическую библиотеку для игр - GameX. Вышла она ужасно глючной. Поднатужившись еще и заюзав накопленный опыт, M$ родила удачнее и разработала первый DirectX - универсальный инструмент для разработчиков игр и графических приложений. Теперь программерам стало в лом думать об особенностях железок и дров к ним.

Параллельно веселая компашка монстров компьютерной индустрии во главе с Silicon Graphics разработала для своих нужд 3D-библиотеку OpenGL. На игровом же рынке все более популярным становился жанр псевдо-3D-шутеров (вспомни бессмертный DOOM). И тут Джон Кармак сотоварищи, проявив чудеса прозорливости, заюзал OpenGL, как никто до него не догадался, и наколбасил первую Кваку. Правда, квадратные рожи огров и мутные подземелья не многие сразу восприняли. Но те, кто вылез из танка (спрайта), догнали, что бабки кроются в треугольниках (полигонах). А вернее - в их прорисовке и количестве. И следующая революция не заставила себя долго ждать. Как гром среди ясного неба свалился на голову юзверям первый чипсет молодой компании 3DFx - "Voodoo", поддерживающий собственный API - Glide. Особенностью этой железки было то, что она вместе с SVGA-картой вставлялась в PCI-слоты и соединялась с видюхой кабелем, при этом шнурок от монитора подключался к 3D-ускорителю. Таким образом, трехмерное изображение как бы накладывалось сверху двухмерного. 3DFx состригла купоны и выпустила Voodoo-2 уже с 8 мегабайтами памяти на борту. Многие бросились ее догонять, позаимствовав OpenGL API. Появилась куча медленных и глючных 3D-видюх от Intel, ATI, S3, Permedia. Разрешения и глубина цвета росли, 3D-картинка усложнялась - а следовательно, увеличивалась нагрузка на шину PCI и требования к количеству памяти, установленной на ускорителе, под текстуры.

А теперь - ракета!

Старенькая системная PCI-шина к этому моменту уже не могла обеспечить нужной пропускной способности для графических данных, поэтому была разработана специальная шина для графики - AGP (Accelerated Graphic Port). Кроме обалденной, по сравнению с PCI, пропускной способности канала данных, эта шина обладает еще и способностью AGP-текстурирования, то есть текстуры хранятся не только в видеопамяти, но и в простой системной памяти компа. С момента создания спецификации шины AGP она претерпела два существенных изменения - AGP 2X и 4X. AGP работает на частоте 66 мегагерц, в режиме 2Х данные передаются дважды за один цикл шины, 4Х - четырежды. Таким образом, эффективная частота шины составляет, соответственно, 132 и 264 мегагерца.


Спецвыпуск Xakep, номер #012, стр. 012-062-4, Вкусная картинка: видюхи под микроскопом

Вкусная картинка: видюхи под микроскопом

Tony (tony@nifti.unn.ru)

Спецвыпуск Xakep, номер #012, стр. 012-062-4

В этот момент желтую майку 3D-лидера сдирают с 3DFx. И поделом! Вместо того, чтобы разработать новое ядро для своей карты, ребята просто клонировали Voodoo 2 и приспособили его для шины AGP. Таким образом на свет божий появился Voodoo 3, не очень существенно отличавшийся по производительности и возможностям от своего предка. А впереди оказалась NVidia со своими чипсетами TNT и TNT2. Вкусностей было много: высокая производительность, отличные драйвера, разумная ценовая политика - все это позволило занять NVidia твердое первое место. Через некоторое время на сцену выходит чипсет серии GeForce, основным отличием которого от TNT2 явилось наличие геометрического процессора (GPU). И понеслось...

Сегодня

На сегодняшний день мы имеем несколько 3D-чипсетов - NVidia GeForce 2 GTS, GeForce 2MX сотоварищи, ATI Radeon, PoverVR, KYRO 2. Эти железки, в общем, схожи по своим возможностям и скорости. Особняком стоят лишь карты на GeForce 2 GTS (своей ценой и скоростью) и KYRO 2 (своей тайловой архитектурой и отсутствием геометрического процессора). Пользователь данных девайсов останется довольным как качеством 2D картинки, так и 3D-возможностями своей карты.

Взгляд вперед

Что касается будущего 3D-технологий - то мне кажется, что до выхода нового процессора IA-64 архитектуры, особых сюрпризов не будет (ну разве что под хвост шины AGP засунут еще одну вожжу, так что она станет 8X). Вообще, сектор 3D-карт в последнее время довольно спокойно эволюционирует. И не надо покупаться на явно рекламно-пропагандистские названия новых технологий, применяющиеся, допустим, в GeForce 3. Это - просто рекламный трюк. Зачем нужен 20-25-процентный прирост производительности на толстых разрешениях типа 1600Х1200 за такие бабки?! Революций в области 3D-технологий не будет до тех пор, пока не будет разработана новая модель джойстика или мыши, позволяющая эффективно управлять движением героя в 6 степенях свободы, при этом стреляя, ведя радиообмен с ведомыми и базой. Уже сейчас реально не хватает реакции и... конечностей. Скоро будем давить на кнопки Им ;).

Тестирование видюх

Вот сначала мы всей бандой хотели тестить видюхи. А потом решили: если у тебя денег куры не клюют - ты и без нас себе ГеФорс-2 купишь... А если в кармане последние 12 буказоидов - PCI-ную S3GX2 ты тоже без нашей помощи себе выберешь.

Но про тестирование видюх вообще мы тебе все-таки расскажем.

Для начала необходимо понимать, что возможности любой видеокарты имеет смысл измерять только относительно. Абсолютного измерения не может быть в принципе. Ну, допустим, ты хвалишься подруге, что твоя Creative 3D Blaster Ultra имеет индекс 1205 или, в подругиных единицах измерения, - 7 попугайчиков. Бред, да? Поэтому, когда тестируют видюхи, всегда берут несколько карт и сравнивают их, загружая различными действиями, на одном и том же компе.


Спецвыпуск Xakep, номер #012, стр. 012-062-5, Вкусная картинка: видюхи под микроскопом

Вкусная картинка: видюхи под микроскопом

Tony (tony@nifti.unn.ru)

Спецвыпуск Xakep, номер #012, стр. 012-062-5

Тестирование видеокарт может быть разделено на два различных направления. Во-первых, тестирование производительности карты, а во-вторых - качества изображения. Оба эти направления подразумевают не совсем "честное" тестирование. Ну, просто не все карты поддерживают одинаковые возможности. Поэтому для тестирования производительности стараются выбирать карты с похожими фичами. То есть никому в голову не приходит сравнивать Voodoo 2 с GeForce2 GTS. Естественно, настройки карт стараются выставить такими, чтобы они выполняли одинаковые операции. Для тестирования производительности применяются либо специализированные тесты (например, 3DMark), либо какие-нибудь из 3D-игр, в которых есть подсчет FPS. Хорошо, если там есть среднее FPS за некоторое время, и очень здорово, если игра умеет строить график - или хотя бы создавать дамп. При тестировании производительности видюхи - помни, что тесты дают синтетические бенчмарки, в отличие от игр, которые, естественно, дают совершенно реальные. Но зато, анализируя результаты синтетических тестов, можно понять, какой блок тормозит в твоей видюхе, можно ли исправить это разгоном либо отключением какой-то 3D-возможности.

Тестирование качества изображения заранее ставит карты в неравные условия. Остается только включить все возможности по максимуму и сравнивать картинки. Также не следует забывать, что при создании драйверов разработчики и тестеры стараются обеспечить качественную работу железа прежде всего в Quake 3 и играх, сделанных на его движке. Таким образом, существует ряд довольно проблемных игр (например, MDK 2), в которых с работающей нормально (в Q3 :-\) видюхой происходят разные неприятности. Опять-таки: надо учитывать, в какие игры ты обычно гамишься и важна ли тебе хорошая работа в проблемных играх или только в Q3.

Еще один вариант тестирования направлен на проверку стабильности работы видюхи. Это нужно для изучения ее работоспособности при разгоне. Не каждое графическое ядро и не всякая видеопамять способны работать на повышенной частоте. Разгон осуществляется при помощи программ-Tweak'еров, характерных для каждой из видюх. Карты от NVidia можно разогнать прямо из "свойств адаптера", если установить специальный патч детонатора. Тестировать можно при помощи любой 3D-игры (чем картинка сложнее, тем лучше), а можно взять и 3DMark. Если все пройдет без сбоев и отмирания игры в течение некоторого времени не произойдет - все пинцетно. Также в результатах теста можно посмотреть, на сколько поднялись вожделенные FPS...

Голосуй умом

Мы уже долгое время голосуем по разным вопросам какими-то не теми частями тела. Это сакс! При выборе видеокарты призываю тебя голосовать умом. Для начала надо понять, для каких целей тебе нужно видео.


Спецвыпуск Xakep, номер #012, стр. 012-062-6, Вкусная картинка: видюхи под микроскопом

Вкусная картинка: видюхи под микроскопом

Tony (tony@nifti.unn.ru)

Спецвыпуск Xakep, номер #012, стр. 012-062-6

Если комп только бухгалтерский, то для него вообще сойдет абсолютно любое барахло, которое обеспечивает частоту вертикальной развертки монитора свыше 85 герц (т.е. 85 кадров в секунду), и разрешение 800х600. В нормальных условиях обычно встает выбор между 2D и 3D. Если на компе вообще не планируется использование 3D возможностей, а нужно очень качественное 2D изображение (например, задачи обработки в реальном времени потокового видео), то выбор видеокарты однозначен - Matrox G450. Кроме того, эта карта позволяет подключать к себе два монитора, ну а двухмерные возможности и возможности DVD декодирования не разочаруют никого.

Если комп нужен для игрулек, то возможности 3D-карты надо соотносить с толщиной кубышки. Обычного геймера полностью удовлетворят возможности карты, построенной на GeForce 2MX (можно MX400 - это чуть посовременнее и побыстрее). В случае, если ты играешь в игры (а тем более в экшн) и красоты хочется, а денег очень жалко, то купи тогда Riva TNT2 (лучше 0.22 микронную модификацию TNT2a - например, Leadtek WinFast S320-II). Хоть и старенько, но зато недорого - 30-40 вечнозеленых. И можно играть во все игры - в разрешениях 800х600 и 1024х768 при максимальном качестве и 32-битном цвете (лично я так и поступаю). Хардкорным экшн-геймерам лучше всего купить GeForce 2 GTS c DDR памятью. Лишних FPS не бывает.

Последняя категория лиц - это те, у кого пальцы веером, машина - Ferrari, а любовница - дочь миллионера. Для них выбор однозначен - чем цифирь больше, тем лучше, то есть GeForce 3, мегов 128 видеопамяти (если найдут :)) и попутного ветра в спину.

Да, дружище, если ты принадлежишь к секте гезихастов или у тебя просто развит дух противоречия\свободной конкуренции, голосуй за ATI Radeon. Этот продукт - нечто среднее между GF2 MX и GTS, хотя по производительности все-таки ближе к MX. От KYRO2 отговариваю сразу, ибо производители игр не очень учитывают при разработке особенности тайлового рендеринга, да и отсутствие геометрического камня настораживает. Но если любишь эксперименты - попробуй. Хотя лучше экспериментировать с подругой, а не с видюхой :).

Насчет памяти: спешу тебя предупредить! Ты, наверно, уже знаешь, что сейчас в видеокартах используется как SDR, так и DDR память (более быстрая). Соответственно, в картах на GeForce2 MX используется и та, и другая. Но чтобы MX не мешал продажам находящегося в более дорогой категории старшего брата - GTS, NVidia урезала шину DDR памяти для MX чипсета с 128 бит до 64. Естественно, производительность карты от этого страдает довольно круто, с DDR мозгами MX даже медленнее, чем с SDR. Вот так! Интересно было бы сравнить скорость GF2 MX с DDR 128-битной шиной и GF2 GTS. Думается, не намного бы отстал MX от брательника при цене почти в два раза меньше.

Линки?

Дружище, ты хочешь спросить, куда идти? Тсс... Это не реклама - иди на iXbt и Reactor, там ты найдешь все...


Спецвыпуск Xakep, номер #012, стр. 012-066-1, ДАННЫЕ ВНЕ КОМПЬЮТЕРА

ДАННЫЕ ВНЕ КОМПЬЮТЕРА

Спецвыпуск Xakep, номер #012, стр. 012-066-1

SpelinblimbeR (spelinblimber@chat.ru)

Может, ты смотрел фильм "Трое"? Так вот: там был момент, когда штатный хакер этой троицы достает с военного спутника на орбите копию какого-то видео фрагмента, и говорит: "Главное правило хакера - делай копии!" Согласись, правило неплохое, даже для простых смертных, а уж для хакера и подавно - мало ли чего может случиться. Винт вылетит, злобный вирус собственного производства побьет систему... Да и сам ты, дохакавшись до ручки, можешь все себе потереть нечаянно :). Простая переноска данных с одного хакерского компа на другой немало напрягает - приходится выкручивать у себя винт, тащить его через весь город к товарищу, там подключать и обнаруживать, что падение с эскалатора в метро не прошло для него даром... Вот и рассмотрим некоторые девайсы, которые призваны помогать таким как мы в нелегком деле резервного копирования и переноса больших объемов информации. Тема - внешние носители информации. На сегодняшний день на рынке существует масса подобных устройств объемом от 100 Mb до N Gb. Все эти девайсы имеют разное устройство и основаны на использовании разных физических принципов, подключаются посредством IDE, SCSI, USB и хрен еще знает чего, имеют разную скорость чтения/записи. Обзор предназначен для того, чтобы не дать бедным хаксорам потонуть во всем этом разнообразии и выложить свои кровные именно за то, что конкретно им необходимо. Каждому, как известно, свое - кому объем в ущерб скорости, кому совместимость, а кому скорость чтения/записи. Ну что ж, приступим-с...

Гибкие диски

FDD

Накопитель на гибких магнитных дисках (Floppy Disk Drive) был изобретен в конце 60-х годов челом по имени Алан Штудгарт (этот же чел впоследствии разработает Hard Disk Drive - винт). Устаревшие на сегодня флопики формата 5.25" появились в продаже уже в начале 80-годов (хотя, более допотопные накопители стали появляться в серийном производстве уже в 70-х). Емкость этих дискет поднялась с 180 Kb в начале существования до 1.2 Mb в 1984 году. Тогда же был разработан и дисковод формата 3.5" с емкостью 720 Kb, увеличенной в 1987 году до 1.44 Mb. Позднее были разработаны технологии сверхплотной записи, позволявшие записать на одну дискету до 2.88 Mb, однако данные стандарты не получили широкого распространения (отчасти из-за дороговизны самих дискет). Основными достоинствами этого накопителя является полная совместимость (у кого же нет флопика?) и дешевизна, основными недостатками - низкая плотность записи (что обусловлено низкой точностью механизма, выполняющего позиционирование читающей головки), а также низкая скорость обмена данными (что обусловлено трением читающей головки о поверхность диска) и малый объем.

Iomega ZIP

Iomega одной из первых приступила к разработке нового устройства, работающего с гибкими магнитными дисками большой емкости, способного заменить обычный 3.5" дисковод. Им стал выпущенный в 1995 году Iomega ZIP. На сегодняшний день сей девайс получил довольно широкое распространение, выпускается в нескольких модификациях, во внешнем и внутреннем исполнении. Первый ЗИП позволял записать на одну дискету диаметром 3.5" 100 Mb инфы. Зиповские дискеты очень напоминают обычные, они немного толще. Плотность размещения дорожек на диске намного выше обычных флопиков, а высокая точность позиционирования производится с помощью специальных дорожек, которые наносятся на диск еще на заводе. Кроме того, отсутствует трение читающей головки о поверхность диска, что достигается довольно интересным способом - головка как бы парит над поверхностью диска на воздушной подушке. ЗИП значительно быстрее флопика, однако все еще не так быстр, как, например, CD-ROM. Последней моделью в линейке зипов стал внешний девайс, способный работать с дискетами объемом 250 Mb. Жаль только старые 100 - мегабайтные дискеты он читать не будет. Основные достоинства Iomega ZIP - высокое быстродействие, большой объем данных, надежность в работе. Основными недостатками считаются все еще высокая стоимость дискет и самого устройства их чтения, отсутствие совместимости (зипы не могут читать обычные 3.5" дискеты).


Спецвыпуск Xakep, номер #012, стр. 012-066-2, ДАННЫЕ ВНЕ КОМПЬЮТЕРА

ДАННЫЕ ВНЕ КОМПЬЮТЕРА

Спецвыпуск Xakep, номер #012, стр. 012-066-2

Sony HiFD

"Высокоемкий" привод гибких дисков, разработанный компаниями Sony и Fuji, позволяет записывать данные на 3.5 дюймовые дискеты емкостью 200 Mb. Скорость передачи данных увеличивается не только за счет того, что читающая головка не касается поверхности диска, но и за счет значительного увеличения скорости вращения диска. Внешне дискета для Sony HiFD мало отличается от обычной дискеты, основное различие заключается в строении задвижки, закрывающей окошко для доступа головок к поверхности диска. Девайс выпускается как во внешнем, так и во внутреннем исполнении, поддерживает разнообразные интерфейсы (в том числе и FireWire) и позволяет читать и записывать данные на стандартные дискетки. Достоинства - большая емкость, высокая скорость чтения/записи, совместимость со старыми флоппи-дисками, надежность. Недостатки - некоторая экзотичность и дороговизна, что способствует слабому их распространению.

LS-120(a:drive)

Этот девайс предназначен для работы с 3.5" дисками особой конструкции. В дисках LS-120 соединились две технологии записи данных: оптическая и магнитная. На поверхность дискеты LS-120 еще при заводском форматировании наносятся высокоточные оптические дорожки, которые не несут никакой полезной информации, и используются следящей системой дисковода для высокоточного позиционирования магнитной головки. Кроме того, увеличена скорость вращения диска, что положительно сказалось на скорости чтения/записи самого дисковода. Это позволяет повысить плотность записи, а так же - за счет более быстрого позиционирования головки - скорость работы девайса. Данные наносятся на обычные магнитные дорожки, однако повышенная плотность позволяет записать на один диск до 120 Mb информации. LS-120 позволяет работать с обычными 1.44 Mb флопиками, но делает он это быстрее обычного флоповода, за счет повышенной скорости вращения диска. Основные достоинства прибора - невысокая цена, достаточно большой объем, возможность работы с обычными флопиками. Выпускается как во внутреннем, так и во внешнем исполнении. Недостатки - слабая распространенность (большинство драйвов закупаются западными брэндами для установки на свои компы вместо стандартного FDD - зажрались, однако), невысокая скорость чтения/записи (из-за того, что головки не парят над поверхностью диска как в ZIP, а скребут по ней). Тем не менее, это классная штука: из всех девайсов обзора больше всего мне нравится именно она.


Спецвыпуск Xakep, номер #012, стр. 012-066-3, ДАННЫЕ ВНЕ КОМПЬЮТЕРА

ДАННЫЕ ВНЕ КОМПЬЮТЕРА

Спецвыпуск Xakep, номер #012, стр. 012-066-3

Накопители на сменных жестких дисках

HDD Rack

Это не совсем отдельный накопитель – скорее, просто модификация обычного винта. HDD Rack представляет собой девайс формата 5.25", устанавливаемый в соответствующее гнездо на компе (в таком гнезде стоит, например CD-ROM). Сей девайс содержит в себе кулер, и подключается точно так же, как и обычный винт. Сам винт (тут выбор зависит от тебя, еще один аргумент в пользу сего способа - разнообразие возможных накопителей) помещается в специальный пластиковый футляр с контактами. Затем этот футляр берется, и – вжик! - вставляется в приемник (та часть HDD Rack, что осталась в компе), далее на него копируется необходимая информация, винт вытягивается и несется к другому компу с приемником - удобно, не нужно раскурочивать комп. Достоинства - дешевизна, большой выбор возможных носителей со всеми проистекающими отсюда последствиями - тут тебе и скорость и объем по вкусу. Недостатки - Rack есть не у всех. Кроме того, он не защищен от магнитных полей, падений и прочих механических повреждений... Но фишка полезная. Рекомендую ставить один приемник, например, на работе, а другой дома - очень удобно.

Iomega JAZ

В накопителях Iomega JAZ в качестве носителя используются специальные картриджи, построенные как обычные винты. Дискеты похожи на обычные трехдюймовки, но они несколько толще. В футляр помещается один или два жестких диска, которые обладают гораздо большей плотностью записи, чем флопики. Это позволило уже в первых моделях Джаза довести емкость носителя до 1 Gb. Винчестерные технологии позволили добиться прироста быстродействия. Руководствуясь желанием еще больше поднять скорость передачи данных, разработчики оснастили девайс лишь SCSI-интерфейсом, что не есть очень уж хорошо. На сегодняшний день существуют модели JAZ емкостью 2 Gb, а быстродействие этих девайсов остается одним из самых высоких. Недостатком Iomega JAZ, как и всех подобных накопителей, является чувствительность к магнитным полям и ударам (уронил где-нибудь - и глина данным). Кроме того, как сам привод, так и дискеты стоят далеко не дешево, что способствует слабой распространенности. Из достоинств можно выделить быстродействие и большую емкость.

Накопители SyQuest

На заре производства драйвов на сменных магнитных дисках основным конкурентом Iomeg'и была компания SyQest. Первые модели SyQuest работали с дисками формата 5.25", и имели емкость всего в 44 Mb. Однако, именно эта компания заложила основу производства девайсов на сменных носителях: жесткий картридж для чтения/записи вставляется в специальный привод, в приводе предусмотрено считывающее и позиционирующее устройства... Считывающая головка, как и в приводах от Iomeg'и, не касалась поверхности диска, а парила над ней, что существенно уменьшало время доступа и износ диска. В 1997 году SyQuest выпустила девайс под названием EZFlyer, который мог работать с картриджами емкостью 230 Mb (его конкурентом стал вышедший примерно в это же время Iomega JAZ емкостью 1 Gb - вот и подумайте теперь, почему спрос на EZFlyer был не особо велик). Далее, как ответ Iomeg'е следовал SyQuest SyJet, емкостью 1.5 с увеличенной скоростью доступа, но этот девайс был по тем временам дорог. Компания попыталась как-то спасти положение, и выпустила SparQ, уменьшив объем до 1 Gb. Так удалось снизить стоимость привода и картриджей, но было уже поздно. В середине 1998 компания попала под действие закона о банкротстве, и была куплена своим главным конкурентом - теперь достать ее произведения достаточно сложно. Основным достоинством SyJet по сравнению с джазом является то, что он выпускается внутренним и внешним, и поддерживает IDE наряду с SCSI. Кроме того, эти девайсы на сегодняшний день стоят довольно достаточно умерено - покупай, если найдешь. Недостатки тут стандартны для всех девайсов данной категории.


Спецвыпуск Xakep, номер #012, стр. 012-066-4, ДАННЫЕ ВНЕ КОМПЬЮТЕРА

ДАННЫЕ ВНЕ КОМПЬЮТЕРА

Спецвыпуск Xakep, номер #012, стр. 012-066-4

Castlewood ORB

Накопитель Castlewood ORB позволяет записать на 3.5" картридж 2.2 Mb информации, причем скорость этого драйва равна примерно 12 Mb в секунду. При всем этом девайс стоит дешевле того же JAZ'а, картриджи - тоже. Достоинств просто куча, недостатки стандартны. Выпускаются внутренние и внешние модели, поддерживаются как SCSI и IDE, так и LPT и USB. Классная штука.

Магнитооптика

Смотрел Матрицу (а кто ее не смотрел?)? Помнишь тот момент, когда к Нео домой заявляется шумная компания и начинается базар типа: "Ну что, ты достал?" - "А как же!"... А потом Нео достает из книжки маленькие прозрачные диски - это и есть MO. Вот это - чисто хакерские девайсы для хранения информации. Со следующей получки купи себе один, и тебе не стыдно будет сдавать результаты работы своему нанимателю из ЦРУ, а то бегаешь тут по городу с винтом, забитым фотографиями российских атомных разработок... Брр (о последствиях такого подхода к хранению данных читай выше)... Преимуществ куча: подумай, информация наносится на диск лазерным лучом при температуре около 200 градусов, диски не чувствительны к перепадам температуры, воздействию электромагнитных полей, ударам (в разумных пределах... не советую топтать диск ногами, а потом засовывать его в драйв), загрязнению. Производители дают гарантию, что ты сможешь перезаписывать информацию около миллиона раз, а храниться она будет в течении нескольких десятков лет. Как все это работает? Очень просто, здесь, как и в предыдущей категории используются принципы создании винчестеров - в основе "дискеты" лежит магнитный диск особой прочности, данные на нем намагничиваются и размагничиваются только при температуре около 200 градусов (это обеспечивает большую чем у обычных винтов степень сохранности данных). При записи данных диск в нужной точке сначала нагревается мощным лазером до необходимой температуры, а затем намагничивается головкой (такая точность позволяла увеличить плотность записи), при чтении все происходит несколько более запутано. Потом, в 1997, появилась технология LIMDOW: эта фишка позволяет одновременно нагревать поверхность лазером и намагничивать ее. Все дело в том, что под полупрозрачным слоем записи на диске LIMDOW находится магнитный слой. Если лазер проходит участок каким-то одним способом , то поверхность намагничивается как «0», а если другим способом - то как «1». Все это происходит значительно быстрее, чем в обычных МО. Так что скорость чтения/записи LIMDOW-драйвов уже сопоставима со скоростью винчестеров. Кроме улучшения скорости записи, LIMDOW ведёт к увеличению емкости МО дисков. Так как магнитная поверхность находится вплотную к записываемой внутри самого диска, намагничивание может быть произведено с значительно более высоким разрешением - фактически, с разрешением пятна нагревающего лазера. В будущем емкость диска может значительно увеличиться (хотя уже сейчас она находится на уровне 3 Gb). МО-диски могут быть как 3.5, так и 5.25 дюймовыми. Данные на них могут записываться с двух сторон (для получения доступа к другой стороне диск необходимо вынуть, перевернуть и засунуть обратно). Тут разбирать особо нечего, МО драйвы сейчас производит каждая уважающая себя фирма (еще один аргумент в пользу МО - эта технология не является чьей-либо собственностью, как, например, ZIP от Iomeg'и, это и позволяет ей свободно развиваться и совершенствоваться), но я рекомендую Fujitsu. Недостатков у этой технологии почти что нет, а достоинств - куча. Самое то.


Спецвыпуск Xakep, номер #012, стр. 012-066-5, ДАННЫЕ ВНЕ КОМПЬЮТЕРА

ДАННЫЕ ВНЕ КОМПЬЮТЕРА

Спецвыпуск Xakep, номер #012, стр. 012-066-5

CD-ROM/R/RW

Вероятно, самый распространенный накопитель для компа - это CD-ROM (а теперь, с ходом времени все более доступным становится и CD-RW). Сидиром есть сейчас почти на каждом уважающем себя компе, так что за совместимость можно не беспокоиться. Началась вся эта история в 1982 году, когда Sony совместно с Philips разработали спецификацию первого компакт-диска. Подумав немного, они поняли, что данные диски можно использовать не только для записи на них оцифрованного звука, но и для записи информации. Были разработаны и выпущены в свет первые драйвы (баснословно дорогие, кстати сказать). Постепенно технологии развивались, к разработке девайсов подключались все новые и новые конторы... и сиди-ром принял наконец всем нам привычный вид и приемлемую стоимость. Что же такое CD? CD представляет собой диск, одна сторона которого покрыта тончайшим слоем металла (как правило, алюминия). Над этим слоем расположен прозрачный защитный лак, он позволяет лазерному лучу работать со слоем металла и одновременно защищает болванку от повреждений и порчи данных. При записи информации поверхность компакт-диска обрабатывается лазерным лучом, выжигающим микроскопические участки – ямки. Есть ямка – «1», нет ямки – «0». Так и кодируется информация. Важно то, что ямки располагаются по спирали, как на виниловых пластинках. Начальный участок этой дорожки находится ближе к центру диска, поэтому информацию на CD-R долгое время не умели дописывать - приходилось подготавливать всю инфу заранее, а потом все скопом писать. Ну, что можно рассказать о сидюке? Все основное, думаю, тебе давно уже известно - ну там, что производительность повышается с увеличением числа оборотов диска, и все прочее. Расскажу я тебе лучше о сиди-эр'е.


Спецвыпуск Xakep, номер #012, стр. 012-066-6, ДАННЫЕ ВНЕ КОМПЬЮТЕРА

ДАННЫЕ ВНЕ КОМПЬЮТЕРА

Спецвыпуск Xakep, номер #012, стр. 012-066-6

Надоело как-то людям постоянно читать инфу с дисков, и придумали они, как ее туда в домашних условиях записывать. Посему в конце 80-х появились первые CD-R'ы, но назывались они тогда не CD-R, а CD-WORM (Write Once - Read Many). Стоили эти девайсы, как и первые сидюки, довольно дорого - их могли позволить себе лишь крупные организации и университеты. Далее появились Multisession CD-R, они позволяли дописывать инфу на диск (немножко сейчас написал, немножко потом). Важно отметить, что как CD-R, так и CD-RW имеют два существенных недостатка: первое - запись производится чрезвычайно медленно, плюс (это второе) вся работа может полететь к черту из-за малейшего сбоя (данные должны поступать в устройство непрерывным потоком, если вырубят свет - всему хана). Тем не менее, хочу заметить, что архивирование инфы с помощью CD-RW (если действительно есть такая необходимость) - идеальный вариант. Болванки стоят дешево, а прочитать ты их сможешь практически на любом компе в мире. Сидюки рулят.

DVD

ДиВиДи, по сути, является усовершенствованием обычного CD-диска, но имеет ряд существенных отличий. Во-первых, плотность записи на DVD-диск значительно выше, что достигается при помощи уменьшения размеров ямок и расстояния между дорожками. Для работы с такими размерами в DVD-ROM'е предусмотрен лазер с более короткой длинной волны, а так же - более точная оптика. Кроме того, разработана технология размещения информации на носителе в несколько слоев. При этом, верхний слой делают полупрозрачным, а под ним располагают еще один. Выбор слоя при считывании информации осуществляется путем фокусировки лазерного луча. В отличие от CD, диски DVD могут быть двусторонними. В итоге емкость DVD-диска может достигать 17 GB (два слоя, две стороны). На сегодняшний день DVD-диски используются для записи высококачественного видео и цифрового звука для домашних кинотеатров и Hi-Fi систем, в компьютерной же сфере DVD еще не так популярен. Преимушества здесь очевидны - громадный объем... но вот стоят DVD-ROM'ы пока еще далеко не дешево. Пройдет еще немало времени, пока они станут такими же популярными, как и CD. Наряду с обычным DVD-ROM'ом существует еще DVD-R, данный девайс абсолютно аналогичен по своим функциям CD-Rу, но стоит жуть сколько, и потому встречается довольно редко. Ну, что еще сказать про Сахалин? Что ДВД могут читать обычные сидюки? Я думаю, это и так известно. По-моему, время DVD для компов еще не настало. А покупать их для просмотра видео, если у тебя нет домашнего кинотеатра или монитора с диагональю 21" и звуковой системы Dolby Digitall, не имеет смысла.

PD и DVD-RAM

Система PD основана на патентованной технологии изменяемой фазы (Phase Change technology) и существует с конца 1995. PD-накопитель сочетает в себе оптическое устройство, способное работать с 650Mb дисками, и CD-ROM дисковод (обычные компакты читаются на PD Drive, а вот PD-диски на сиди-роме не прочитаешь). Это пока единственное чисто оптическое решение, позволяющее перезаписывать данные в один проход головки чтения/записи. Вся фишка в том, что рабочий слой на диске сделан из материала с обратимо изменяемыми свойствами. Этот материал может находиться в одном из двух агрегатных состояний: кристаллическом или аморфном. Очень мощный лазерный луч нагревает пятно записи данных, которое затем быстро остывает, образуя аморфную область с низким коэффициентом отражения. Следующий нагрев приведёт к кристаллизации, образуя область с высоким коэффициентом отражения. Чтение производится лазерным лучом низкой мощности. Если он попадает на кристаллическую область, то отражается без изменений, а если на аморфную - теряет интенсивность. С помощью этой технологии построен девайс под названием DVD-RAM. Замечу сразу, что этот прибор не позволяет записывать DVD, которые потом будут прочитаны в обычных DVD-ROM'ах. Диски для DVD-RAM несколько напоминают обычные дискеты, только больше (диаметром 5.25"), сам диск помещен в пластиковый футляр и является двусторонним (для доступа к разным сторонам диск нужно переворачивать). На такой диск можно записать до 6 Gb инфы.


Спецвыпуск Xakep, номер #012, стр. 012-066-7, ДАННЫЕ ВНЕ КОМПЬЮТЕРА

ДАННЫЕ ВНЕ КОМПЬЮТЕРА

Спецвыпуск Xakep, номер #012, стр. 012-066-7

Стримеры

Стримеры - накопители на магнитной ленте (магнитофонные кассеты видел? - это они и есть). Применяются такие исключительно для хранения резервных копий информации. На то есть несколько причин: последовательный доступ к данным сильно замедляет поиск данных на кассете, а скорость обмена данными между стримером и компом оставляет желать лучшего. Кроме того, ленточные накопители подвержены воздействию магнитных полей, чувствительны к изменениям температуры и влажности. Со временем магнитная лента разрушается, так что информация на кассете может быть утеряна. В стримерах подкупает лишь дешевизна и объем (несколько гигабайт).

Outroе

Итак, по моему мнению, для резервного копирования информации наиболее подходит CD-RW - достаточно дешево, вместительно. Кроме того, диски можно прочитать практически на любом компьютере в мире. Для переноса, имхо, лучше использовать винт с HDD Rack - дешево и сердито. Еще можно поставить себе LS-120 вместо стандартного флопика и MO - классная фишка. Всякие Зипы и Джазы отдыхают.


Спецвыпуск Xakep, номер #012, стр. 012-070-1, Лазерные блинчики, или оптические диски, их свойства и применение

Лазерные блинчики, или оптические диски, их свойства и применение

Спецвыпуск Xakep, номер #012, стр. 012-070-1

Matt (matt@nm.ru, http://matt.nm.ru)

Нет, думать о том, как весь этот девайс работает в то время, как какой-то урод истерично выпускает сзади в тебя всю обойму, - это перебор. Но, вообще, по жизни представлять себе принцип работы сидючков не мешало бы... Хотя нет, речь пойдет не только о CD.

Ты помнишь, как все начиналось?

А началась история лазерных дисков с совместного проекта компаний Сони и Филипс. Изначально, в начале 80-х, компакт-диски разрабатывались исключительно для записи музыки и прочих звуковых данных. Говорят, что длина диска (74 минуты) была определена прихотью директора Сони, который заявил, что компакты, прежде всего, должны отвечать запросам любителей классической музыки, а согласно социологическому опросу самым популярным классическим произведением на то время в Джопании оказалась 9-я симфония Бетховена, которая как раз 74 минуты и длилась. Вот чем занимались япошки, а ребята из Голландии в это время уже придумали формат записи, стандарт и прочие технические аспекты. Такая вот сказка.

Так оно еще и работает!

Как? Принцип работы сидюков и музыкальных центров основан на неровности поверхности компакта и на наличии "впадин" и "выступов". На самом деле понятие "выступа" относительно, потому что выступы соответствуют поверхности диска (0 м над уровнем моря :)), а вот впадины действительно представляют собой углубления в его поверхности. Компакт-диск в точности похож на наши дороги: куча выбоин в любом месте.

В отличие от магнитных дисков, на которых дорожки размещены в виде концентрических окружностей, физическая дорожка на оптических дисках только одна и представляет собой единую непрерывную спираль, идущую от внутреннего диаметра к наружному. Тем не менее, одна физическая дорожка может быть разбита на несколько логических.

В то время как все магнитные диски вращаются с постоянным числом оборотов в минуту, то есть с неизменной угловой скоростью (CAV - Constant Angular Velocity), компакт-диск вращается обычно с переменной угловой скоростью, чтобы обеспечить постоянную линейную скорость при чтении (CLV - Constant Linear Velocity). Таким образом, чтение внутренних секторов осуществляется с увеличенным, а наружных - с уменьшенным числом оборотов в секунду. Именно этим обусловливается достаточно низкая скорость доступа к данным для компакт-дисков по сравнению, например, с винчестерами. Тормозные, и все. Ну и что с ними делать?

Мотор!

Так вот. Компакт-диск вращается с постоянной линейной скоростью, зависящей от параметров сидюка (1Х=4м/с, 40Х=160м/с!!!), и в это время на него падает луч лазера. Если луч попадает на выступ, то он благополучно отражается и через линзу попадает на фотодиод, который фиксирует двоичную единицу. Если же луч лазера попадает на впадину, то он рассеивается и поглощается, ни один фотон до фотодиода не долетает - фиксируется двоичный ноль.

Таким образом определенная последовательность выступов и впадин соответствует определенной последовательности "нолей" и "единичек", что, в свою очередь, соответствует битам (то есть данным). Вроде все просто, но попробуй на 40-скоростном сидюке прочитать 6000 Кб/сек!


Спецвыпуск Xakep, номер #012, стр. 012-070-2, Лазерные блинчики, или оптические диски, их свойства и применение

Лазерные блинчики, или оптические диски, их свойства и применение

Спецвыпуск Xakep, номер #012, стр. 012-070-2

Тактико-техническая характеристика CD

Компакт-диск имеет диаметр 120 мм (4,72 дюйма, 0,129 ярда или 6,378х10^-5 морской мили), толщину 1,2 мм и вес около 14 г. Любой компакт имеет центральное отверстие диаметром 15 мм, следующую далее по радиусу зону крепления шириной 6 мм, заголовочную область (содержащую оглавление диска) и 33-миллиметровую область хранения данных. Благодаря высокой степени сжатия данных на CD вмещается 650 Мб, или 74 минуты музыки с частотой выборки стереосигналов, равной 44,1 кГц, или 600000 страниц текста. Теперь можешь понтануться перед друзьями или дефачкой ;). А вообще - забей.

Разведение в неволе

Компакты, как и все остальные оптические диски, в основном изготавливаются из пластмассы, именуемой в узких кругах поликарбонатом. Этот поликарбонат обычно представляет собой шарики диаметром несколько миллиметров. На заводах и в подвалах, где тиражируют компакты, эти шарики растираются до консистенции меда и выдавливаются в формы. А формы, в свою очередь, имеют уже выступы и впадины, соответствующие данным, записанным с помощью лазера на мастер-диск. Жидкий поликарбонат, заполняющий форму, приобретает ту же самую картину углублений. Получаемый в результате диск с поверхностью, соответствующей определенному набору данных, называется "пластмассовой подложкой". После формирования подложки на поверхность будущего компакта наносится очень тонкий (несколько сотен нанометров) отражающий слой алюминия, который в точности повторяет рельеф пластмассовой подложки. Для защиты алюминия от царапин, крайне негативно влияющих на содержимое компакта, поверх него наносится слой прозрачного лака, который без искажения пропускает лазерный луч, способный различить микроскопические отпечатки на поверхности диска. И, наконец-то, самое главное - нанесение этикетки с обратной стороны :).

CD-R и CD-RW диски

Да, кроме тиражирования на невперено дорогом оборудовании, компакт-диски можно записывать прямо у себя дома, на своем старом и добром железном друге. Для этого нужен девайс, который в народе называется просто "cd-writer". Запись при этом производится не поверх обычного компакта, а на специальные диски, называемые также матрицами. Различают два основных вида записываемых компактов: CD-R (CD-Recordable - записываемый) и CD-RW (CD-ReWritable - перезаписываемый). Думаю, уже понятно, что на первые запись можно произвести только однажды, а вторые можно очищать и записывать еще много (около 1000) раз. Структура записываемых дисков несколько отличается от структуры компактов, выпускаемых массовыми тиражами. Так, в большинстве CD-R дисков в качестве отражающего слоя используется не алюминий, а золото (толщина слоя около 70 нм, так что отскребать без мазы), которое, кроме отличных отражающих свойств, обеспечивает хорошую коррозионную стойкость. Кроме того, между поликарбонатной основой и отражающим слоем находится слой органического полимерного красителя, который, собственно, при нагревании его лазером изменяет отражающие свойства диска на данном участке дорожки.


Спецвыпуск Xakep, номер #012, стр. 012-070-3, Лазерные блинчики, или оптические диски, их свойства и применение

Лазерные блинчики, или оптические диски, их свойства и применение

Спецвыпуск Xakep, номер #012, стр. 012-070-3

Перезаписываемые (CD-RW) диски вместо органического красителя содержат два слоя диэлектрика, а между ними - регистрирующий слой, который, по аналогии с CD-R, изменяет отражающие свойства данного участка диска.

Прогрессивная визитка

Для крутых дядек с Лексусами, мобилками и ноутбуками, у которых вся информация о себе любимом на бумажную визитку размером 5х9 см никак не помещается, а также для презентации компьютерщиками своих электронных работ, придумали так называемые CD-card. СD-card - пластиковая визитка, с виду напоминающая телефонную или банковскую карточку, но на которой может храниться любая компьютерная информация весом от 20 до 50 метров в зависимости от ее физических размеров. В визитках прямоугольной формы балансировка диска осуществляется за счет четырех ножек, точно попадающих в 80-миллиметровое отверстие дисковода, ну а круглые сами благополучно ложатся в это самое отверстие.

Сам принцип записи и чтения, структура диска и остальные свойства cd-card полностью идентичны свойствам обычных компактов. Единственное отличие - размеры и форма.

Детище компакта и кассеты

В результате попыток создания носителя более компактного, чем магнитофонная кассета, и одновременно столь же удобного в обращении, как компакт-диск (с такой же длительностью и максимально близким цифровым качеством), был рожден мини-диск.

Магнитооптический мини-диск (в народе - МД) диаметром 65 мм спрятан в пластмассовом футляре размером 68х71х5 мм, который очень похож на конструкцию 3-дюймовой дискеты. Доступ к поверхности записи закрыт сдвигающейся шторкой, но в мини-диске, в отличие от флопика, предусмотрена защита от открывания вне девайса (как у VHS-кассеты). Чистые мини-диски, на которых возможна запись, выпускаются двух типов: на 74 и 60 минут. Производители МД гарантируют около 1 миллиона повторения циклов запись-воспроизведение-стирание абсолютно без потери качества. Программно-аппаратное исправление ошибок в мини-дисках реализовано за счет быстрой скорости считывания данных (так, что остается время на восстановление данных, потерянных при ударе - именно поэтому в МД-проигрывателях нет перескоков с позиции на позицию). Запись информации на мини-диски производится с помощью магнитной головки (при этом слой носителя подогревается лазером), а считывается она (инфа) лазерным лучом.

Вообще-то говоря, мини-диск является лишь одним из представителей семейства магнитооптических дисков. Кроме мини-диска на 140 Мб, существуют односторонние 3,5-дюймовые (128-230 Мб), двусторонние 5,25-дюймовые (600-650 Мб) и разработанные Maxell'ом 12-дюймовые магнитооптические диски, вмещающие до 7 Гигабайт данных.

В минидисковой аппаратуре основные функции воспроизведения cd-плееров дополняют обширные функции редактирования: стирание определенного трека или только его фрагмента, запись поверх трека, перемещение, объединение и разделение треков - все что душе угодно. Кроме того, поддерживается бегущая строка с информационным текстом о диске, записывается адрес каждого музыкального произведения, что позволяет в проигрывателе организовать практически мгновенный доступ к нему. Благодаря использованию 10-секундного буфера памяти возможна запись данных без потерь уже после начала воспроизведения источника. Но, несмотря на все это, мини-диск звучит лишь немного лучше большинства кассетных записей и значительно уступает компактам :(.


Спецвыпуск Xakep, номер #012, стр. 012-070-4, Лазерные блинчики, или оптические диски, их свойства и применение

Лазерные блинчики, или оптические диски, их свойства и применение

Спецвыпуск Xakep, номер #012, стр. 012-070-4

Последнее слово техники (DVD is coming up)

Да, компакт-диск со своими несчастными 650 метрами и 74 минутами музыки уже уходит в историю, а его место занимает оптический диск нового поколения - Digital Versatile (изначально - Video) Disc или просто DVD (цифровой многоцелевой диск). Чем отличается ДВД от старого доброго компакта? Самый простой - практически ничем. Да, самый простой однослойный односторонний ДВД имеет ту же структуру, те же слои и те же размеры. Но плотность записи информации на нем гораздо выше, что достигается за счет перевода считывающего лазера в диапазон красного света (СД работает в инфракрасном). Таким образом, на самый простой ДВД можно впихнуть 4,7 Гб информации, а это более 2,5 часов видео студийного качества или около 9 часов обычного стереозвука! Кроме того, существуют двухслойные ДВД, в которых один из отражающих слоев (наружный, соответственно) полупрозрачный. В этом случае объем информации, потенциально вмещаемой на диск, увеличивается до 8,5 Гб (полупрозрачность "наружного" отражающего слоя накладывает ограничения на его вместимость - "всего" 3,8 Гб). А Toshiba вообще предлагает использовать двусторонние двухслойные диски. Как нетрудно посчитать, на такие "пластмасски" без труда помещается 17 гиг инфы!!! Но, за счет большого количества разных слоев, уменьшается толщина каждого и, соответственно, уменьшается прочность диска :(. Кроме всего этого (а может, как следствие), на видеодисках предусмотрена поддержка широкоформатных фильмов и телефильмов на стандартных или широкоэкранных телевизорах (4:3 и 16:9), до 8 звуковых дорожек на разных языках, до 32 дорожек субтитров/караоке, до 9 углов камеры - различные точки зрения могут быть выбраны в течение воспроизведения (но это, скорее, для максимально эффективного просмотра высококачественной порнухи), многоязычный текст идентификации для имени заголовка, имени альбома, имени песни и т.д. Короче говоря, если ты покупаешь себе новую тачку, ставь сразу dvd-rom (тем более, что все прогрессивные двд-приводы в состоянии проигрывать обычные компакты) - не пожалеешь!

А завтра?

А завтра - не знаю. Точно скажу одно: у принципа хранения информации, который использовался еще в фонографе Эдисона, резерв не исчерпан. Имеются еще порох в пороховницах и ягоды в ягодицах. Глядишь - и подкинет нам сюрприз компьютерная индустрия...


Спецвыпуск Xakep, номер #012, стр. 012-072-1, Твердое и мягкое: стандарты и проблемы

Твердое и мягкое: стандарты и проблемы

Спецвыпуск Xakep, номер #012, стр. 012-072-1

Andrew Fadeev (andrewf@farlep.net)

Куйте железо, не отходя от кассы

Хэй, будущий феррет! Сейчас речь пойдет о самых передовых железках: о 3D-ускорителях графики и о пытающихся угнаться за ними платах 3D-звука. Появление этих железок вызвало в далеком 97 такой взрыв разнородных API, что расхлебать эти помои смогли только совсем недавно. Да и смогли ли?:). С 3D-звуком, например, ужасы творятся до сих пор....

Что есть железо?

Разберемся, что есть железо. Обычно, это платка с кучкой всяких микросхемок, разъемов и прочей электронной бурдой. Эта штукенция, какая бы крутая она ни была, требует управления. Сама догадаться, что делать, она не может. Вот тут на помощь приходят драйвера, или API.

Что есть API?

API - это Application Programming Interface. В нашем случае - набор программных средств для управления железякой. API - штука очень удобная. Программисту, кодящему программу, которая будет использовать, например, 3D-акссель, глубоко до Гейтса, что там именно за железка, что у нее на уме и какие команды она понимает. Он знает конкретный API и обращается к нему. API должен перевести весь этот бред, что программер накодил, бедной железяке. Правда, сама железка должна поддерживать этот API - иначе выйдет разговор немого с глухим. А это - проблемы, которые были решены корпоративным гением Майкрософта (гений у них такой: задавить, всех задавить!).

Намба Зиро: ОСы, не мухи

Были умники, кричащие DOS - rulezzz, остальное - не оси. Таких умников с каждым днем все меньше. Это и понятно. Забота ОСки - скрыть от программ геморрой работы с железом, чтобы кодерам не париться и не писать по релизу под каждую конфигурацию. А у ДОС был API только для работы с дисками. Дисковая Операционная Система, как-никак :). Со всеми остальными девайсами приходилось работать напрямую. Вот и получилось, что ВСЕ звуковые карты на аппаратном уровне совместимы с Sound Blaster 2.0. Чтобы программерам проще было, и приложения с карточками работали без проблем. Был бы API - ну кому бы это было нужно? Когда вышел Выньдос, он тоже не отличался разумностью. Только потом к нему прирос DirectX, а кодеры вообще обленились. Какой подарочек - всех под одну гребенку стричь можно!

Нумеро Уно: 3D-графика

Первые Voodoo наделали много шума. Уууу! Билинейная фильтрация! Аааа! Пикселей не видно! Вот тогда-то и началось. У 3Dfx был собственный API - Glide. Всеми любая Майкрософт уже тогда всунула в молоденький DirectX модуль Direct3D, который Вуду держал плохенько. Майкрософт закричала: "А ну, под стандарт все!", программисты ответили "Фигу! Glide лучше!". Еще со стороны "Силикон Графикс" пришел OpenGL, который продвигал Кармак - главный квакер всего мира и окрестностей. Тем не менее, Glide был всеми любим, так как вторая версия DirectX сильно бажила, а OpenGL юзал только GLQuake. Однако, кроме 3Dfx, ускорители стали производить и другие (в том числе и nVidia), а Glide был закрыт на амбарный замок. А тут и третий DirectX подоспел. Вот, все и стали его использовать.

С этого момента началось противостояние. Большинство игр все равно оптимизировалось под Glide, а остальные API в глаза знать не хотело. 3Dfx рулила, а енд-юзеры страдали. Вместо покупки железки помощнее (а NVIDIA уже тогда вырывалась вперед), приходилось раскапывать вопросы про поддержку ускорителей играми и разбираться в видах API, чтобы приобрести самый "поддерживаемый" девайс. Зато грамотность поднялась на высоты необозримые :).


Спецвыпуск Xakep, номер #012, стр. 012-072-2, Твердое и мягкое: стандарты и проблемы

Твердое и мягкое: стандарты и проблемы

Спецвыпуск Xakep, номер #012, стр. 012-072-2

Но Майкрософт не была бы Гейтсом, если бы постепенно всех не перевели на Direct3D. И опять подстава! У него (до 8-й версии) не было таких фич, как у OpenGL - extensions (расширений). То есть, если выходил новый ускоритель с новыми функциями, а D3D их не знал, то он вставал в позицию "не знаю - значит, быть не может". Однако, друзья Гейтса нашли выход - каждый год переписывать DirectX. А железки обновляются каждые полгода. Так что, покупая новую железяку, нам приходилось ждать полгода, пока от нее можно было получить полную отдачу. Но после того, как пришла NIVIDA со своими попиксельными и вершинными шейдерами, и появилась их поддержка, в 8-ом DirectX ситуация выровнялась. С их помощью можно добиться многих эффектов, пиша... пися... пишучи... в общем, созидая микропрограммы для железа.

Еще одни грабли, с которыми не раз встречались производители железа - сырые дрова. Ну, сделали они железку - а драйвера того, глючат. Этому есть объяснение: трудно писать дровишки для несуществующего железа. А когда его (железо) заканчивают, то тут же кидают на рынок - иначе устареет (помнишь, по ускорителю в полгода?). Где уж тут дрова рубить?! Главное, чтобы купили - дрова потом будут. Публика - дура. Своеобразный выход нашли специалисты из NVIDIA - их Detonatorы подходят ко всем их железкам последних поколений. Но до их появления были еще Riva128, Riva128ZX и первая ТНТ'шка (с нее и пошли Детонаторы). От этих дров волосы на ногах дыбом вставали. Да и у Detonator'ов имеются проблемы со свежими технологиями: то, что было в предыдущих картах, работает хорошо, а новье - сырое.

Но, как видишь, все закончилось хорошо. Индустрия дошла-таки до стандарта: Direct3D и OpenGL поддерживают все платы вполне прилично. Да и софт (кроме профессионального, который OpenGL уважает) в основном D3D юзает. А 3dfx-у купила NVIDIA, и Glide отмер.

Нумер Цвай: Опять 3D, но теперь - звук

Тут ситуация еще темнее. Эта индустрия развивается куда медленнее. Поэтому и процесс становления стандарта затянулся. Хотя во многом он похож на дурки с графикой. Сначала хитропопая Майкрософт вылезла со своим DirectSound3D. Вроде как, все хорошо - сразу имеем единый стандарт, мир, дружбу, братство и рай на земле. Щаз! Такого не бывает даже в сказках. Решив взять все в свои лапы, братия дяди Г. запретила алгоритмам, отличным от описанных в стандарте, использовать DS3D. Ты думаешь, производители звуковых карт были недовольны? Наивный! Они были в бешенстве! Столько лет они разрабатывали свои алгоритмы - а тут пришел Билли, и всем все запретил. Ну, его и послали. Так этот D3DS и гнил почем зря в DirectX. Фирма Aureal со своим Vortex2 предложила API A3D (позднее версии 2 и 3), а Creative - EAX (так же пару раз проапгрейдженный). Разница в том, что Aureal свой A3D закрыла на замок. А Creative открыла свой EAX для чужих наработок. У кого дела сейчас обстоят лучше, сам знаешь. Небось, новенький Live! гоняешь ;). Тезис - закрытые API дохнут, а открытые - шагают по планете, как Армстронг. Углядев такое дело, Майкрософт тоже разрешила писать адд-оны к D3DS и использовать его кому как хочется. Поэтому A3D и EAX не борются с DirectSound3D, а расширяют его. Для нас, юзверей, это уже хорошо: если программа поддерживает 3D-звук, то уже минимальный набор эффектов будет работать с любой карточкой.


Спецвыпуск Xakep, номер #012, стр. 012-072-3, Твердое и мягкое: стандарты и проблемы

Твердое и мягкое: стандарты и проблемы

Спецвыпуск Xakep, номер #012, стр. 012-072-3

Намбер сри: Таки-да внедрили

Следующая бочка дегтя посвящена USB. То есть, не USB, а ее поддержке в любимом Windowsе. В 1996 - 1997 годах стали доступны для масс такие новинки, как AGP, ACPI и USB. Вот, о последней и речь. Естественно, суперось тех времен, известная в узких кругах как МастДай 95, слыхом не слыхивала об УСБ. Самой современной модификацией этого чуда была OSR2. Вот для него был и выпущен USB supplement patch. Все хорошо, но система видела только шину, а многие устройства не признавала. Но патчик был все равно ценный - он прививал оське поддержку AGP. Чинили одно - починили другое (хорошо хоть не наломали). Короче, два таких перспективных портика торчали в компе просто так. Появление 98-х форточек решило проблему. С тех пор с USB ось работает. Но вот что смешно - такая USB не устраивает производителей веб-камер, которые уже стоят в очереди за USB 2.0. Интересно, как с ней дела пойдут?

Ньюмеро кватро: ACPI уже 4 года?!

Еще один экземпляр. ACPI означает - Advanced Configuration & Power Interface. Эта технология должна была управлять питанием компьютера, предоставляя больше возможностей, чем старичок APM. Хохма в том, что этот стандарт был внедрен в хард еще в чипсете 430TX (середина 96). Слушай дальше: устанавливали стандарт Intel, Toshiba и Microsoft. Поэтому странно, что больше всех тормозила развитие ACPI сама Майкрософт. Эта технология позволяет усыплять комп в нескольких вариантах: с записью всех регистров оборудования в оперативку или на винт. В первом случае обесточиваются только платки, а мамка с памятью под напрягом - инфу хранят. Выход из такого режима - секунды. Второй вариант загоняет все это на винт, который энергонезависим. Комп отрубается весь: хоть отключай из розетки и в другое место неси. Включается комп дольше, чем в первом варианте, но все равно быстрее, чем в обычной без ACPIной жизни. Преимуществ - море. Занимаешься креативной работой, а тут уйти надо. Можешь не закрывать все окошки и программы, а загнать компьютер в спячку с сохранением на винт. Потом, когда придешь, быстренько его оживить.

Теперь - о грустном. Не один вариант 95-х окошек об этих бонусах не знал и уже никогда не узнает. Поддержка ACPI вовсю рекламировалась в 98 виндовзе, но была оттрублена по дефолту. Включение фичи толком ничего не давало, ибо она глючила, если диск был отформатирован в свеженький FAT32. Хотели как лучше, получилось - как всегда. И вот, наконец, выходит Windows 2000. Ура, работает! И программирование кнопки включения, и Suspend to RAM (Stand By), и Suspend To Disk (Hibernate). И в Millennium работает. Только опять есть глюки (а никто и не удивился). Если драйвера оборудования (хоть один) от NT4 (есть Win2K) или от 95 (Me), то все крутости отрубаются. Но это ладно, старости несовместимы. Можно считать, что внедрили... на 4 года позже :(.


Спецвыпуск Xakep, номер #012, стр. 012-072-4, Твердое и мягкое: стандарты и проблемы

Твердое и мягкое: стандарты и проблемы

Спецвыпуск Xakep, номер #012, стр. 012-072-4

Вместо заключения - немного субъективизма

Я о технологиях, которые уже хорошо работают, но к которым я не спешу приобщаться. Например, недавно брал новый CD-ROM. А на DVD и не смотрел. Почему? Смысла нет. На дивидишках сейчас только мувисы. А их я могу и в кино посмотреть. Где обещанные Data Storage? Где гиги полезной инфы вместо привычных 650 Мб? Пока всего этого не будет, DVD я покупать не собираюсь. На вырост купить? Ага, они там чего нового придумают, и придется менять железку. Так что я подожду. Радостная новость: появились первые DVD-RAM. Хоть свои архивы поджигать можно будет.

Все фантастические фильмы конца восьмидесятых и начала девяностых бредили 3D-шлемами и очками. Сейчас этого добра - граблями греби. И что, гребут? Ни фига! И дело не в ценах - очечки недорого стоят. Просто сама девайсина напрягает юзера и настолько зависит от личных качеств его глаз, что некоторые 3D вообще не увидят. 3D-шлемы в этом смысле все-таки более универсальные, но цены на них уже не для всех. Хотя, у шлемов есть свои минусы. Для шутеров идеальными контроллерами признаны клава и мышь. А со шлемом на голове можно пользоваться только джойстиком или геймпадом.

3D-звук? Туда же. У всех ухи разные. Да и для того, что бы добиться эффекта, точнее - услышать его - нужно находиться в зоне наилучшей слышимости, а она очень маленькая. Шаг в сторону - побег. Прыжок на месте - попытка улететь. Да и вообще, как на тебя будут смотреть домашние, если ты воткнешь комп посреди комнаты?

Вот с таким скрипом развиваются стандарты, прибавляя гимора тебе и мне. То ли еще будет!


Спецвыпуск Xakep, номер #012, стр. 012-074-1, МОНСТЕР САУНД

МОНСТЕР САУНД

Спецвыпуск Xakep, номер #012, стр. 012-074-1

SpelinblimbeR (spelinblimber@chat.ru)

Волшебные звуки

Я думаю, что не стоит здесь долго говорить о том, зачем современному юзеру нужна звуковая карта... Скажу лишь, что в потребности этой можно выделить два основных направления - бытовое и профессиональное. С бытовым все ясно - mp3 послушать, насладиться предсмертными воплями монстров в Кваке, фильм какой посмотреть. А может быть, если уж совсем нет силы терпеть и жажда творчества переполняет и рвет крышу, - то и попытаться сваять что-нибудь простенькое в каком-нибудь звуковом редакторе (ничего стоящего на дешевых карточках не получится, предупреждаю сразу). Профессиональные карточки служат для разнообразной профдеятельности: написание музыки, создание звуковых эффектов, сведение композиций и т.д. Тут вроде все понятно... Перейдем непосредственно к волшебным звукам. Что есть звук? Звук является продуктом взаимодействия колебаний воздуха и твоего уха. Брр... Я хотел сказать, что звук представляет собой изменения в давлении воздуха - звуковые колебания, а колебания эти в свою очередь образуют волну. Достигнув твоего уха, колебания воспринимаются и обрабатываются твоим центральным процессором (ака головной мозг). Сами же колебания производятся динамиком - его поверхность то прогибается, то выравнивается, выгибается, снова прогибается и т.д. Для управления всеми этими выгибаниями и вгибаниями и нужны звуковые карты.

Теория

Один из аспектов компьютерного звука состоит в том, что все звуковые эффекты, которые на сегодняшний день способен воспроизводить компьютер, - музыка, вопли монстров в играх, человеческая речь - подразделяются на два больших класса. К первому относится оцифрованный звук, проигрываемый аудиоадаптером из готовых массивов данных (например, из mp3-файла на твоем винте), ко второму - синтезированный. Этот звук создается компьютером на лету на основе специальных инструкций и методов. Ясен пень, что для домашнего использования важнее качество реализации первого (почему - см. выше), а вот для студии звукозаписи, например, - второго. Если с простым проигрыванием сложностей обычно не возникает, то с синтезом все не так просто. Для создания мелодии звуковая карта должна получить что-то вроде программы - список нот, которые нужно проигрывать, их атрибутов (длительность, громкость и т.д.) и инструментов, на которых эти ноты собственно и должны исполняться. Затем, получив всю эту бодягу, специальный чип на звуковухе - синтезатор (о нем дальше в нашей программе, stay tuned) - воспроизводит нужные звуки в нужной последовательности. Делает он это через интерфейс под названием MIDI (Musical Instrument Digital Interface). Синтез MIDI-музыки можно выполнять двумя способами: методом частотной модуляции (FM-синтез) и с использованием волновых таблиц (wavetable, он же WT-синтез). Эти методы имеют существенные отличия, посему рассмотрим их отдельно:

FM-синтез - первый метод генерации звука, применяемый в звуковых картах. В 1967 году композитор Джон Чаунинг додумался, что, управляя одновременно громкостью и частотой звукового колебания и накладывая несколько таких колебаний друг на друга, можно добиться довольно точной имитации различных инструментов. В 1983-м на основе этого изобретения был разработан первый FM-синтезатор: Yamaha DX-7. Достоинства метода: синтезатор не требует заранее заготовленных сэмплов, а соответственно, и памяти для них, синтезатор выдает достаточно большое количество разнообразных звуков. Недостатки метода: низкое качество получаемого звука, крайне грубая имитация звучания реальных музыкальных инструментов.


Спецвыпуск Xakep, номер #012, стр. 012-074-2, МОНСТЕР САУНД

МОНСТЕР САУНД

Спецвыпуск Xakep, номер #012, стр. 012-074-2

WT-синтез - воспроизведение заранее записанных в цифровом виде звуков - сэмплов. Инструменты с малой длительностью звучания обычно записываются полностью, для остальных может записываться лишь начало/конец и небольшая средняя часть, которая затем проигрывается в цикле в течение нужного времени. Для изменения высоты звука фрагменты проигрываются с разной скоростью, а чтобы при этом не сильно менялся характер звучания, инструменты составляются из нескольких сэмплов для разных диапазонов нот. Достоинства метода: предельная реалистичность звучания инструментов и простота получения звука. Недостатки метода: наличие жесткого набора заранее подготовленных сэмплов, параметры которых нельзя менять в реальном времени, большие объемы памяти для сэмплов.

Вывод из вышенаписанного таков: для синтеза звучания реальных инструментов больше подходит WT-синтез, а для создания новых тембров более удобен FM, хотя его возможности сильно ограничены.

Звуковуха inside

Переходим к водным процедурам, а именно - к строению звуковой карты. Основой звуковой карты является аудиочипсет, он состоит из нескольких чипов и выполняет функции воспроизведения, синтеза и обработки звука. Основой аудиочипсета является DSP (Digital Signal Processor), он выполняет обработку цифрового сигнала, наложение спецэффектов, компрессию и декомпрессию аудиоданных, управляет записью и воспроизведением оцифрованного звука. Проследуем дальше по коридору - здесь у нас codec (от англ. COder-DECoder). Кодек состоит из двух частей. Первая из них называется ЦАП (цифро-аналоговый преобразователь, DAC по-аглицки) и отвечает за преобразование звука из цифровых данных в собственно звуковую волну. Диаметрально противоположные DAC'у функции выполняет АЦП (ADC, аналого-цифровой преобразователь) - тут, я думаю, все ясно. Идем дальше, а именно - к синтезатору. Данный девайс может быть построен на основе FM-синтеза либо на основе WT, либо на основе того и другого. Звуковая карта почти всегда обладает собственной памятью: наличествует как ПЗУ, куда загружается набор инструментов General MIDI (128 мелодических и 47 ударных инструментов), так и ОЗУ, куда подгружаются сэмплы (неплохой фишкой является возможность карточки работать с оперативкой компа: ее как-никак больше, чем собственной, - следовательно, можно загрузить больше инструментов). Из подсобных девайсов обычно присутствует блок MPU, осуществляющий прием и передачу данных по внешнему MIDI-интерфейсу, а также блок микшера, реализующий сведение используемых на карте аналоговых сигналов. Количество и состав выводов звуковой платы может варьироваться в довольно значительных пределах, однако минимальный стандартный набор разъемов присутствует всегда. На любом аудиоадаптере есть выход для подключения акустических колонок, микрофонный вход и разъем игрового порта, который также служит для подключения MIDI-клавиатуры. На хорошей звуковой карте, поддерживающей технологии трехмерного звучания, есть и гнездо для второй пары колонок. Контакты всех разъемов на недорогих картах выполняются из железа или алюминия, на более качественных - из меди, а в самых лучших моделях покрываются слоем золота: это улучшает проводимость контакта, уменьшает шумы и искажения сигнала. В дополнение к вышеописанным разъемам на высококачественных звуковых платах могут устанавливаться гнезда линейного входа и выхода, предназначенные для подключения аналоговых звукозаписывающих устройств (например, магнитофона) или усилителей. Для присоединения внешних цифровых устройств на хороших полупрофессиональных и всех профессиональных картах предусмотрен также выход S/P DIF (Sony/Philips Digital Interface). Очень часто он реализуется на дочерней плате, подключаемой к аудиоадаптеру с помощью специального шлейфа. S/P DIF - это интерфейс для вывода цифрового многоканального звука, например, в домашних кинотеатрах, или для подключения внешнего сигнального процессора. Большинство современных звуковых карт рассчитаны на работу в слоте PCI.


Спецвыпуск Xakep, номер #012, стр. 012-074-3, МОНСТЕР САУНД

МОНСТЕР САУНД

Спецвыпуск Xakep, номер #012, стр. 012-074-3

Уфф. С техникой вроде все (ну, почти все: может, еще будет, но совсем мало). А теперь...

Много истории

Как я уже упоминал, в 1983 году компания Yamaha разработала первый FM-синтезатор под названием DX-7. Врубившись в эту тему, разработчики комплектующих принялись проектировать звуковые карты. Одной из первых карт, если моя память не глючит, стала простенькая AdLib Music Synthesizer Card с поддержкой FM-синтеза, однако революция была впереди... Это свершилось в 1989 году, когда на арене появился Sound Blaster от Creative Labs. Эта карточка при всей своей простоте была первой с возможностями записи/воспроизведения и разрядностью оцифровки аж в 8 бит. Частота дискретизации при воспроизведении достигала 22 кГц (для того времени неплохо), была реализована и поддержка FM-синтеза. Стерео не поддерживалось. Впоследствии Creative Labs дополняет линейку своих продуктов новым SoundBlaster Pro, который воспроизводил звуки уже в стерео с частотой дискретизации до 45 кГц. Настоящим стандартом стала модель Sound Blaster 16, в которой запись и воспроизведение стали 16-битными. Эта карта хорошо зарекомендовала себя как в играх, так и при создании музыки (благодаря встроенной эмуляции MPU-401) и перетерпела несколько редакций (SB 16 VE, SB 16 PRO и т.д.). Популярность карт серии SoundBlaster была настолько велика, что в тени остались некоторые технологии, пытающиеся конкурировать с лидером. Например, стандарту Ultrasound компании Gravis так и не суждено было добиться всеобщего признания у пользователей и разработчиков, поскольку в это время практически все новые игры в своих системных требованиях содержали графу "SoundBlaster или полностью совместимая с ним звуковая карта". Кстати, о птичках, точнее о GUS'ях. Карты Gravis Ultrasound компании Advanced Gravis для своего времени были огромным достижением, качество звука поддерживалось на уровне 45 кГц стерео, дополнительно присутствовала куча полезных наворотов. Эти карточки, по сути, были первыми картами WT-синтеза. Последняя модель GUS'я поддерживала до 16 мегабайт памяти, стандартный набор сэмплов весил 5,3 Мб, а расширенный - до 60 Мб! Была разработана специальная система кэширования, при которой часто употребляемые сэмплы оставались в памяти, а ненужные выгружались и на их место подгружались новые инструменты. Но GUS был не полностью совместим со стандартами Sound Blaster и, следовательно, не поддерживался большинством игрушек и прикладных программ. И в 1997 году карточки были сняты с производства. (Но у меня до сих пор живет GUS Gold - и я вполне доволен. - прим. ред.) Что до Creative, то она тоже экспериментировала с WT-синтезом, результатами этого стали довольно неплохие карточки SB AWE32, SB AWE64 и семипрофессиональная карта SB AWE64 Gold.


Спецвыпуск Xakep, номер #012, стр. 012-074-4, МОНСТЕР САУНД

МОНСТЕР САУНД

Спецвыпуск Xakep, номер #012, стр. 012-074-4

Но это еще не конец. Это просто новый интерфейс!

С выходом в 1995 году всеми любимой Windows 95 возник звуковой интерфейс DirectSound API, который позволил разработчикам ПО отказаться от прямого обращения к аппаратному обеспечению и перейти к использованию в качестве своеобразной "прослойки" этого самого API. Это, в свою очередь, гарантировало правильное воспроизведение аудио на любой звуковой плате, понятие стандарта (каким раньше был SB) стало понемногу искореняться (оно и понятно - теперь не нужно было специально прописывать поддержку всех карт в программах, все решал единый интерфейс). В 1997 г. компания Diamond Multimedia, которая до этого пассивно наблюдала за успехами своего основного конкурента - Creative и глотала слюни, анонсировала новую PCI-карту Monster Sound. В Monster Sound была реализована поддержка технологии A3D компании Aureal. 3D - значит трехмерность, но на этот раз трехмерность звука, а не изображения. До этого придать объемность звуку, исходящему из колонок, пытались многие, однако особого успеха никто на этом поприще не добился. В интерфейсе A3D использовалась технология HRTF (Head-Related Transfer Functions). Фишка в том, что звуки доносятся до ушей человека с разницей в несколько миллисекунд. Благодаря этой задержке наш мозг может оценить скорость звука и примерно определить месторасположение его источника. Таким образом, эмулируя различные звуки с такими миллисекундными паузами, технология HRTF заставляет мозг поверить в то, что звуки доносятся из разных точек пространства. Благодаря этой технологии стало слышно, что монстры в играх палят по тебе с разных сторон. Можно реально услышать, что граната взрывается именно справа сзади, или слева спереди. Monster Sound стала народной игровой картой. Сегодня используется уже третья версия A3D, включающая, кроме всех предыдущих достижений, геометрический engine, механизм построения объемных источников звука (Volumetric Sources) и поддержку Dolby Digital. Не осталась в стороне и Creative. Creative Labs начали разработку формата EAX, что было эквивалентно началу 3D-войн в звуке. EAX расшифровывается как Environmental Audio eXtensions - это не отдельный интерфейс, а дополнительный модуль к API DirectSound 3D компании Microsoft. Основным достоинством этого стандарта является возможность создания реалистичного объемного эха, которое изменяет звуки в соответствии с окружающей игрока обстановкой. Ситуация на рынке звуковых карт сейчас довольно запутанная, но все мало-помалу идет к стабилизации.


Спецвыпуск Xakep, номер #012, стр. 012-074-5, МОНСТЕР САУНД

МОНСТЕР САУНД

Спецвыпуск Xakep, номер #012, стр. 012-074-5

Как выбрать карту

Сейчас я расскажу о том, на что следует в первую очередь обратить внимание при выборе звуковой карты. Первое, о чем стоит сказать, - это разрядность представления звука у карты. Бывает 8 или 16 бит. Это значит, что именно это количество бит будет использовано для кодирования одного звука. Как ты понимаешь, при использовании для кодирования одного сигнала 65536 символов (16 бит) качество оного получается много лучше, чем при использовании 256 (8 бит). На практике это означает, что на 8 бит без потерь можно закодировать только телефонные разговоры (да и то не все - Холод иногда так орет в трубку, что мембраны лопаются, какие уж там 8 бит!), а вот на 16-ти теоретически возможно добиться студийного качества звука. Заметь, что разрядность представления звука никак не связана с разрядностью системной шины для карты, хотя понятно, что карта для 32-разрядного слота PCI будет работать быстрее на запись/воспроизведение, чем карта для ISA. Обрати внимание еще вот на что: цифры в названии карт (например, SB AWE64, SB128) не имеют никакого отношения к разрядности (64 бита - это уже средняя профессиональная карта), а являются лишь максимально возможным числом одновременно звучащих инструментов. Вывод - не ведись на такую муть, а покупай карточку с реально высокой разрядностью: чем больше - тем лучше. Что еще? Обрати внимание на максимальную частоту дискретизации. Она определяет качество звука. Все просто - процесс оцифровки аналогового аудио производится с помощью фиксирования некоторых точек, по которым музыка будет преобразовываться назад в аналоговый формат - т.е. проигрываться. Понятно, что чем больше таких точек, тем точнее воспроизводится музыка. Частота дискретизации и определяет, как часто будут фиксироваться эти точки. Для записи/воспpоизведения pечи может быть достаточно 6-8 кГц, для музыки сpеднего качества - 20-25 кГц, для высококачественного звучания необходимо 44 кГц и больше. Так что с частотой дискретизации вывод тот же - чем больше, тем лучше.

Поехали далее. Параметры синтезатора определяют возможности карты в синтезе звука и музыки. Тип синтеза - FM или WT - определяет вид звучания музыки: на FM-синтезатоpе инструменты звучат очень бедно, имитация классических инструментов весьма условна, фигня, короче. На WT-синтезатоpе звучание более живое, сочное, классические инструменты звучат естественно. Подробнее об этом смотри выше. Объем ПЗУ или ОЗУ WT-синтезатоpа говорит о том, сколько разных инструментов и какого качества ты сможешь туда затолкать (память на 4 Мб может содержать до 500 инструментов среднего качества GM). Для твоего музыкального творчества большое значение имеют возможности синтезатора по обработке звука (разные специальные фишки), а также возможность загрузки новых инструментов. Тут все зависит от предназначения платы: если нужно играть и слушать музыку - сгодится FM-синтезатор, а если предполагается профессиональная музыкальная деятельность - нужно брать WT. Расширяемость определяет возможности по подключению дополнительных устройств, установке микросхем, расширению объема памяти и т.п. Эта фишка нужна преимущественно для профи, а обычным смертным она ни к чему. Сейчас еще далеко не на каждой карточке есть 26-pазpядный внутренний разъем для подключения дочерней платы, представляющей собой дополнительный WT-синтезатоp или иную плату расширения, а вот разъем для подключения CD-ROM есть везде. На профессиональных картах есть разъемы цифрового выхода (SPDIF) для подключения к студийному оборудованию. Hекотоpые звуковухи допускают установку DSP и дополнительной памяти для сэмплов WT-синтезатоpа. При покупке игровых карт следует также обратить внимание на наличие модных наворотов, типа трехмерного звука A3D от Aureal, или EAX от Creative. Ну а если ты задумал организовать себе домашний кинотеатр или мощную игровую платформу - бери карточку с поддержкой стандарта 5.1 (пять колонок и сабвуфер) - тогда, правильно разместив колонки в комнате, ты сможешь смотреть фильмы с Dolby Digital.


Спецвыпуск Xakep, номер #012, стр. 012-074-6, МОНСТЕР САУНД

МОНСТЕР САУНД

Спецвыпуск Xakep, номер #012, стр. 012-074-6

Конец, наконец

Вот, в принципе, и все - дальше уж сам решай, что тебе нужно: играть и слушать музыку или творить - и, соответственно, выбирай себе карточку. Надеюсь, что наш галоп по Европам поможет тебе сделать свой собственный выбор.


Спецвыпуск Xakep, номер #012, стр. 012-078-1, Рабочее место для хаксора

Рабочее место для хаксора

Dodge (dodge@xakep.ru)

Спецвыпуск Xakep, номер #012, стр. 012-078-1

А что это там в углу такое?

Взгляни на свой компьютерный стол. Могу поспорить, он весь завален совершенно ненужными вещами: пустыми бутылками, фантиками, огрызками, грязными носками... Короче, тебе уже трудно найти собственную клавиатуру. Или может, у тебя вообще нет стола, а твой комп стоит на картонных коробках или на подоконнике? Что ж, это будет самым лучшим вариантом, так как прямо сейчас я расскажу тебе, как правильно выбрать настоящий хаксорский стол. А может, у тебя уже есть суперстол, и ты считаешь, что он идеален? Ну ладно, дело твое.

Место расположения

Если ты думаешь, что этот параметр тебя никоим образом не трогает, то лучше забудь про наш разговор, так как поиски стола начинаются именно с выбора места под него. Итак, оглядись и реши, где будет стоять твой будущий стол. Может, его удобней всего будет поставить в углу возле окна, чтобы днем тебе было светлей? Но так как за столом ты будешь сидеть круглый год, помни: зимой у окна обычно холодно, но, зато, жарким летом окно можно открыть и наслаждаться легким ветерком или швырять в надоедливых голубей битыми флопарями. Или, может, лучше всего поставить стол рядом с дверью, чтобы удобней было в туалет сигать? В общем, не важно где (ставь его хоть по центру комнаты), главное - определиться. Как только выберешь место, не забудь измерить расстояния от пола до потолка и от стены до стены и понять, какой стол туда влезет, а какой нет, чтобы потом не бегать в магазин комплекты менять. Да! Про свет подумай! Если ты за этим столом ещё и писать собираешься - важно, чтоб у тебя источник света слева от посадочного места был. Так писать удобнее :).

Металл или дизигн?

Подумай, из какого материала ты хочешь стол. Деревянный будет впитывать в себя запах сигаретного дыма, пятна от компота и пельменей останутся навсегда, а металлический стол может не подойти к твоей настоящей мебели или заржаветь, если он плохого качества. Скажи, как будет смотреться белый стол среди дубовой мебели? Хоть я и не дизайнер, но думаю, что ужасно. Так что, обязательно прикинь еще и цвет, или заготовь побольше краски ;).

И пришел ты в магазин

Заходишь ты в отдел мебели, и глаза у тебя просто разбегаются. Что же выбрать? Чтобы дать ответ на столь сложный вопрос, надо знать следующее: для чего тебе нужен стол? Чтобы попечатать раз в год? Тогда тебе подойдет обычная тумбочка. А если ты задумал устроить на столе мини-типографию, то здесь не обойтись без огромного количества полок и ящиков. Так что задумайся над этим вопросом максимально подробно. Просто подумай, что ты собираешься поставить на стол помимо компьютера. Если у тебя уже сейчас есть некоторые внешние комплектующие для компа, не забывай о них. А если нет - учитывай, что скоро они могу появиться. И куда ты их будешь ставить? Опять на подоконник? Покупая стол, прикинь - где будет стоять твой принтер, сканер, колонки, где будет храниться твоя огромная коллекция дисков? Ответы на эти вопросы следует узнать уже сейчас, пока ты еще не расстался с финансами, а не потом, когда стафф не влезет в новую мебель.


Спецвыпуск Xakep, номер #012, стр. 012-078-2, Рабочее место для хаксора

Рабочее место для хаксора

Dodge (dodge@xakep.ru)

Спецвыпуск Xakep, номер #012, стр. 012-078-2

Идеальный стол

Вот тебе несколько обязательных примет идеального деска. Во-первых, стол должен быть широким, чтобы монитор располагался не меньше чем 20 см от глаз. Чем больше расстояние между глазами и монитором - тем меньше нагрузка на твои зрительные органы :). Рядом с монитором удобно поставить принтер (все под рукой), а по краям стола - колонки. Отсюда следует, что ширина стола должна быть не менее 70 cм, а длина – минимум 0,9-1 м. Конечно, если параметры твоей комнаты позволяют, то лучше бери себе стол, эдак, 1 х 2 метра. На таком траходроме не только моньку, блок, принтер и сканер расквартируешь, но и подругу в порыве страсти разложишь без проблем :). Лирике абзац, едем дальше.

Во-вторых, надо где-то расположить системный блок. Лучше поставить его на нижнюю полку – не важно, вертикальный он, или горизонтальный - главное, чтобы "мозг" не мешался и меньше попадался на глаза.

В-третьих, вспомни о выдвигающейся полке для клавиатуры. Такая штука у твоего стола должна быть обязательно. Причем, чем больше будет эта полка, тем лучше - мышка не будет мешаться, и руки будут меньше уставать.

Еще обрати свое пристальное внимание на подставку для сидюков. У тебя же, наверняка, огромная коллекция софта, так ведь? А софт всегда должен быть под рукой, так что будет хорошо, если все твои диски будут находиться рядом с тобой. В принципе, если не найдешь стол с подставкой - оную ты сможешь всегда купить отдельно и поставить рядом.

Не сыграй в ящик!

А теперь давай разберем вопрос ящиков, которыми, безусловно, должен быть наделен каждый приличный стол. Зачем они нужны? На первый взгляд, они на Х тебе сдались, но если подумать, им найдется хорошее применение. Скажи, куда ты собираешься положить дискеты, книги по кодингу, журналы? Впрочем, что запихнуть в ящики ты всегда найдешь - пустыми они не останутся, уж поверь. То есть, чем больше ящиков - тем лучше. Просто здорово, если ящики будут иметь роликовую систему, то есть выдвигаться на маленьких колесиках, а не скользить на рейках. Первый вариант надежней и прослужит дольше второго.

Вот ты и сгенерил стол своей мечты. Теперь ищи в магазине мебель, максимально походящую по описанию на твой фантом, оплачивай и тащи комплект домой.

Дома

А дома тебя ждет двухчасовая хардкорная оргия aka сборка стола. Я думаю, что соберешь ты его и без моей помощи, но пару советов все-таки дам (вот такой я зануда!). Во-первых, собирай спокойно, чтобы потом не удивляться: "А почему эта дощечка оказалась лишняя?" или "Эти сволочи два винтика не доложили". Никуда не торопись, почитай схему сборки, ничего не сверли, молотком не долби и гвоздями ничего не прибивай, иначе тебе пропишут пешее эротическое путешествие вместо фирменного суппорта. После того, как соберешь стол, приступай к установке компьютера и периферии. Во-вторых, делай так, чтобы провода не запутывались и при необходимости ты всегда смог бы отличить нужные тебе шнуры. Монитор не ставь вплотную к стене, так как можешь забить вентиляционные щели. Кстати, рядом с монитором рекомендую поставить цветок. Мифы Древней Греции утверждают, что он всосет в себя радиацию (Может Чернобыль кактусами закидать?). В конце концов, эстетику забацаешь.


Спецвыпуск Xakep, номер #012, стр. 012-078-3, Рабочее место для хаксора

Рабочее место для хаксора

Dodge (dodge@xakep.ru)

Спецвыпуск Xakep, номер #012, стр. 012-078-3

Каждому столу по стулу

Чтобы приятнее было работать за столом, тебе необходимо удобное кресло. Причем, ты напрасно думаешь, что оно должно быть на колесиках и с турбо-наддувом - это лишнее. Главным качеством, которым должно обладать кресло - удобство. Твой позвоночник не должен уставать, а задница - затекать и потеть от ночного пробега по сети. У твоего стула обязательно должны быть подлокотники. Это необходимо, чтобы руки не уставали. Спинка кресла не должна быть прямой, иначе на таком стуле долго не просидишь, ко всему прочему спинка должна быть еще и мягкой. Если у тебя длинный стол или вокруг много шкафов, куда ты постоянно заглядываешь - тогда тебе необходим ездовой стул (с колесиками), чтобы передвигаться без каких-либо проблем.

Где купить?

Вопрос о том, где купить стол, решается локально. Везде полно магазинов, предлагающих просто огромнейший ассортимент столов и всяких принадлежностей к ним. Но, условно говоря, есть два места, где можно купить стол: это реальный мир, и мир виртуальный. И ты, наверное, уже догадался о магазинах какого типа я буду сейчас говорить.

ИКЕА

www.ikea.ru

А начнем мы с крупнейшего производителя мебели в мире - компании ИКЕА. ИКЕА предлагает огромный выбор столов, стульев и разных дополнительных штучек. На сайте, который, кстати, имеет очень привлекательный и удобный дизайн, можно внимательно рассмотреть охренное количество столов, кресел, настольных ламп и прочей фигни. Кстати, если думаешь, что цены здесь сумасшедшие - ошибешься. Ценовая политика компании ориентирована на население со средним доходом. К примеру, замечательный стол тебе достанется за 4000 рублей. Впрочем, про цены ИКЕИ ты уже наверняка наслышан.

TranQuillita

www.tq.ru

Столы, представленные на этом сайте, безусловно, являются произведением искусства, так как имеют просто офигенный дизайн (во всяком случае, на картинках это так). Но с ценами ребята явно перестарались. Не буду оглашать, чтобы тебя не напугать - сам зайди и взгляни. В принципе, это очередное интернет-представительство магазина, так что, как и в других случаях, лучшим вариантом будет взглянуть на все вживую, посетив шоп ножками. ХХХХХХХХХХХХХХХХХХХХХ

Ergonomic Design

www.ergonomics.ru

Первое, чем был удивлен - это онлайновый каталог, в котором можно посмотреть столы в практически любом цвете, в любом ракурсе, любой модели. Тут же можно посмотреть размеры стола, его цену и вообще - найти любую информацию. Если пожелаешь, тут же можно и купить стол с доставкой на дом. Правда, ничего полезного я больше не нашел. Да и моделей столов здесь маловато, одни тумбочки. Цены понравились - они колеблются от 100 баксов и выше, но за такие столы можно было и поменьше взять. В общем, если уж денег совсем нет - здесь ты точно найдешь лучшее за меньшее количество дензнаков.

Выбрал? Езжай лучше в крупный магазин, где действительно богатый ассортимент и выбирай, щупай и еще раз выбирай, а уж потом покупай и езжай домой обмывать! Кстати, самое главное в покупке стола - хорошо его обмыть с друзьями, без этого НИКАК ;-).


Спецвыпуск Xakep, номер #012, стр. 012-080-1, Головная боль для соседей: обзор компьютерных колонок

Головная боль для соседей: обзор компьютерных колонок

Эндрю (illusionary@mail.ru)

Спецвыпуск Xakep, номер #012, стр. 012-080-1

Вообще-то, сейчас все компьютеры мультимедийные! Колонки за 2 доллара мощностью в полватта и резистором вместо усилителя (чтобы не погорели от мощности карты) и сама звуковая карта Intel i810 с интегрированной материнкой и видюхой (или наоборот - все равно штаны через голову неудобно надевать) - это и есть все составляющие мультимедийного компа. Если ты все еще лажаешься с таким звуком, смотришь DivX- или, того хуже, DVD-фильмы, играешь в Кваку и слушаешь музыку на любезно предоставленных тебе колонках - сейчас мы это исправим.

От бобра бобра не ищут

Если ты не склонен искать добра от добра, то попробуй найти его от того, что есть. Добром для нас будет являться хороший звук, а тем, что есть, - будут являться существующие колонки. Первым бобром-добром будет Квак. Поскольку я хронически не умею мочить монстров, то просто предлагаю тебе запустить свой любимый уровень, который ты уже во сне видишь, предварительно подключив музыкальный центр к компу и выставив громкость на максимум, чтобы стекла в соседнем доме дребезжали! Не правда ли, есть кое-какие отличия от крохотных колонок за два у.е.? По крайней мере, от хронического запора ты избавишься на всю жизнь и во сне будешь писаться от жуткого пронзительного крика монстров...

Вторым добром-бобром будет хороший звук в фильмах. Купи свой любимый фильм на DVD, посмотри его 200 раз на компе, чтобы выучить в нем каждый звук, а потом сходи в Hi-Fi салон и посмотри там этот же фильм... Только будь готов к тому, что испражняться в Hi-Fi салонах не принято, поэтому сразу прими средство против диареи (рекомендую прогадиться уже при игре в Квак)! И что? Когда злой герой сверлит дрелью голову своей жертве, тебе хочется посмотреть фильм 201-ый раз на своем компе? А, там ты не осознаешь всю реальность происходящего, и тебе легче убедить себя, что "это всего лишь фильм"? Некоторые люди именно поэтому и не смотрят фильмы - ведь "это всего лишь фильм"! Hi-Fi избавит тебя от этой мысли! Когда с диким воплем ты будешь убегать из салона, не забудь забрать свой диск. Все-таки DVD пока еще недешевы.

Третьим добрым бобром будет хорошая музыка. Для этого теста купи лицензионный компакт-диск своей любимой группы, где ты и так уже знаешь каждую нотку. И приходи теперь в тот самый Hi-Fi салон, затребуй поставить свою любимую песню на их парадной системе (которая играет в "свободное от работы время") с сопутствующей горой материальных ценностей в виде CD-проигрывателя, усилителя и других компонентов :)). Будь готов к тому, что через 20 секунд прослушивания тебе инстинктивно захочется подойти к колонкам и взять автограф у вокалиста - ведь даже тебе понятно, что там стоит именно он! Уж слишком реалистичен вокал! Конечно, подобная ситуация сложится только в том случае, если у тебя есть уши - ведь зачастую "ценители" музыки без ушей просто слушают ее на музыкальном центре с выкрученным на полную темброблоком и при этом как-то умудряются ею восхищаться.

Бобры

Теперь-то ты понял, что твои колонки и гроша не стоят, а вот бобры - очень ценная вещь! В связи с акциями протеста бобров рекомендую закупаться шкурками именно сейчас, потому что завтра цена за килограмм может резко возрасти.


Спецвыпуск Xakep, номер #012, стр. 012-080-2, Головная боль для соседей: обзор компьютерных колонок

Головная боль для соседей: обзор компьютерных колонок

Эндрю (illusionary@mail.ru)

Спецвыпуск Xakep, номер #012, стр. 012-080-2

Хочется сразу предупредить зазнавшихся нутрий, что компьютерные бобры не могут сравниться с Hi-Fi бобрами, но при игре в Квак, при просмотре фильмов или при прослушивании музыки ты заметишь огромную разницу между хорошими и китайскими бобрами. И не просто разницу - с хорошими колонками у тебя останутся впечатления от услышанного, чего не случается с твоими мультик-media.

Кроме того, если ты любишь Квак или фильмы на DVD, то тебе просто катастрофически необходима 5.1-звуковая карта (некоторые хвастают ценой вроде 30 долларов и при этом имеют встроенный FM-тюнер и пульт ДУ) и 5.1-акустическая система, ценовой диапазон которой начинается от 50 долларов и заканчивается суммами, нули которых упираются в небеса. Но, поверь, 5.1 звук в фильмах или играх - это вещь действительно впечатляющая! Если же ты, как и я, души не чаешь в различной инструментальной музыке, то лучше не тратиться на 5.1, а просто купить стереосистему, но хорошую, например, на основе колонок Jazz Hipster J-707 или F&D B-747A - на Митинобазаре продаются свободно. В любом случае колонки не должны просто стоять на столе - их размещение должно быть грамотным, причем ради них зачастую приходится менять обстановку в квартире. Но хорошая локализация компенсирует все лишения.

Бобровые шкурки - вид сверху

Многие люди могут просто не заметить разницу между колонками мультик-media и хорошей системой. Да, это правда - если нет ушей, то разницы не чувствуется. Это, кстати, очень важный момент при выборе акустики - если ты не замечаешь дифференс между хорошими и откровенно бездарными колонками, то нет смысла стремиться к колонкам за 100 баксов - не факт, что они тебе больше понравятся. Зато если есть нормальные уши, то лучше купить 100-долларовые колонки, чем мучиться с 30-долларовыми.

Водяные знаки: проверяйте на просвет!

Нужна хорошая система для прослушивания музыки. На музыкальный центр денег нет, а хочется слушать не очень фальшивый звук, с каким-нибудь подобием локализации (то есть ты поймешь, где барабанщик, а где - гитарист, а где - волындеры тянут свою унылую мелодию). Что выбрать?

Если звуковая карта - интегрированная или оставшаяся с 1994 года, то нужно купить хотя бы новую карточку (за 10-20 долларов) и хорошие колонки (ценой от 60 до 110) - например, упомянутые уже Jazz Hipster J-703, J-707, F&D SPS-600, SPS-611, SPS-699 (цена всего $60, а звук на все сто, если не больше!) или, если место в твоей квартире - не дефицит, то бери F&D SPS-747, SPS-757 или B-747A, под музыку которых я и пишу сейчас эту статью. Надо сказать, F&D сейчас просто завоевали весь рынок своими качественными дешевыми продуктами, поэтому, если ты хочешь хорошую систему в любом из ценовых диапазонов, то просто бери их - не ошибешься. Эти колонки играют всегда на уровне тех систем, чья цена кусается сильнее...

- Кроме музыки: хочу еще и 5.1 Квак и DVD-фильмы.

Если ты не очень требовательный, то бери звуковушку за 30 долларов и систему F&D YF-II или какую-нибудь более дешевую Genius SW-5.1 Surround c пластмассовым сабвуфером и сателлитами. А ежели ты отличаешься особой деликатностью, то бери хорошую карту, вплоть до SB Live! Platinum 5.1 и систему F&D Shov IHOO MT5.1 или Creative HomeTheater. Надо сказать, сложилась целая философия относительно IHOO. Раньше все периодические компьютерные издания кишели статьями об этой удивительной системе за 130 долларов, но ее купить было просто невозможно, а позже в отдельных фирмах она заявлялась в прайсе по цене около 200 вечнозеленых, хотя в наличии системы не оказывалось... Фирмы прогадали - система была стоящая, и спрос на нее был выше, чем на любые другие колонки. Оно и понятно, IHOO озвучивает фильмы так, что у тебя на всю жизнь останутся непередаваемые отютения :)).


Спецвыпуск Xakep, номер #012, стр. 012-080-3, Головная боль для соседей: обзор компьютерных колонок

Головная боль для соседей: обзор компьютерных колонок

Эндрю (illusionary@mail.ru)

Спецвыпуск Xakep, номер #012, стр. 012-080-3

- Я не отличаюсь особой требовательностью. Я иногда смотрю фильмы DivX, иногда - играюсь в Квак, люблю большую громкость и наличие басов (не обязательно громоподобные басы - просто чтобы были), иногда слушаю музыку в mp3.

Хорошая у тебя ситуация - бери любые колонки ценой 30-50 долларов. Могу порекомендовать Genius SP G-16, Jazz Hipster J-5508AV или самые дешевые деревянные. Если не пожалеешь 60 долларов, то получишь фантастический звук от F&D SPS-699, не только удовлетворяющий, но и превосходящий все потребности, указанные тобой!

- Я хочу сэкономить, но получить хороший звук.

А кто этого не хочет? Выход есть - собирай сам колонки. Если ты - не очень большая шишка в радиоэлектронике, то просто выпиливай деревянный корпус и привинчивай туда динамик, а на заднюю стенку выведи разъемы. Если ты кое-что соображаешь, то бери книгу и делай себе двухполосную колонку со встроенным кроссовером и усилителем (например, на основе Philips TDA1557Q - СпецХ об этом уже писал), а также выходом на наушники и даже темброблоком. Сам ты вряд ли сразу все это сумеешь собрать, поэтому лучше купить книжку и экспериментировать. Но результат превзойдет твои ожидания! Представь себе: то, что стоит 3000 рублей, ты соберешь сам намного дешевле (менее чем за 1000)! Еще ты сможешь собрать систему в стиле Х - ведь мы уже объясняли, как сделать свой мобильный СД-проигрыватель, усилитель... Теперь ты еще сделаешь сам и колонки!

- У меня уже есть мультимедийные колонки, но я хочу другие за 10 баксов!

Мда... Бери любые - например, Defender.

- Слушай, у меня есть очень хорошие старые большие деревянные колонки, но там какой-то странный разъем! Их можно подключить к компу?

Да, можно и даже нужно! Подобная ситуация сложилась у моего друга... Два года он жил со своими колонками мультик-media. Но недавно я его упрекнул в тупоголовости и предложил его старые динамосы подключить к компу. В ответ услышал: "Вилка в гнездо не влезает...". Нужно сделать кабель-переходник, и всего делов-то! Он делается очень просто, не замкни провода между собой, и все будет работать - более того, все будет стабильно работать! Играть твои старые колонки будут очень даже хорошо, лучше большинства систем за 30-40 вечнозеленых. Если ты не умеешь держать в руках паяльник или сомневаешься в своих силах, попроси друга спаять для тебя этот кабель, он все сделает за 5-10 минут! Зато потом, при прямом переключении колонок, - поймешь, какой пердеж из мультик-media ты слушал все это время! Ты просто обязан сделать этот кабель, даже если ты - тупоголовый истукан!


Спецвыпуск Xakep, номер #012, стр. 012-080-4, Головная боль для соседей: обзор компьютерных колонок

Головная боль для соседей: обзор компьютерных колонок

Эндрю (illusionary@mail.ru)

Спецвыпуск Xakep, номер #012, стр. 012-080-4

Бобровые шкурки - вид сбоку, или длина шерсти

Теперь ты понимаешь, в каком ценовом диапазоне тебе стоит выбирать колонки. Чтобы выбрать лучшую для себя бобровую шкурку, ты должен знать все характеристики колонок.

FAQ по компьютерным колонкам

Материал корпуса. Компьютерные колонки бывают двух видов - пластмассовые или деревянные (как правило, ДСП). У деревянных колонок внутренняя акустика гораздо лучше, благодаря более правильному отражению звука. Деревянный корпус колонок - это большой плюс, и, обычно, именно с деревянных колонок начинается хороший звук. Кроме того, у пластиковых колонок часто бывают неприятные резонансы, а на большой громкости они вообще не способны играть без вибраций корпуса.

Диапазон частот - диапазон, в котором колонки способны воспроизводить звук. Иногда компьютерные колонки радуют глаз диапазоном 20-20000 Гц. Это уже слишком, поскольку даже некоторые сабвуферы начинают работу только с 60 Гц, кроме того, даже некоторые Hi-Fi колонки, по объему и массе превосходящие компьютерные, тоже начинают воспроизводить бас с 75 Гц. Поэтому рассчитывать на сочный и глубокий бас у пластмассовых колонок объемом меньше литра не приходится - даже если заявлена частота в 20 Гц. Зато при 50 Гц большие деревянные колонки играют уверенно. Поэтому любителям баса особенно рекомендуются большие деревянные колонки, а вот пластмассовые колонки даже в комплекте с сабвуфером совершенно не способны воспроизводить низкие частоты. Впрочем, если ты любишь бас - бери большие деревянные или отдельный сабвуфер, если нет - то ты можешь обойтись и пластмассовыми.

Мощность - произведение силы тока на напряжение, буквально - громкость.

Люди, мнящие себя спецами, в музыкальных центрах всегда хвалят маленькую пластмассовую магнитолу с 6-см динамиками и надписью на них 1000W и ругают ее товарища по стенду - громоподобный музыкальный центр Technics c мощностью 320W, который способен в небольшой комнате (до 20 м?) сделать любого человека глухим. Собака зарыта в разных музыкальных стандартах. Магнитола несет на борту надпись PMPO (Peak Music Power Out) - это такая мощность, при которой диффузор в динамике может немного двинуться с места, после чего колонка благополучно сгорает (конечно, мощность определяется арифметическими формулами, но, вообще, PMPO - это ненормированная мощность). Но есть и другие мощности - RMS (Root Mean Squared), это мощность, при которой колонки могут играть более часа без физических повреждений. Правильная формула звучит так - среднеквадратичное значение мощности, ограниченной заданными нелинейными искажениями. На такую мощность можно смотреть прямо, это почти реальная мощность - правда, достижимая только с искажениями около 10%. 25 Вт хватит для двора, 6-10 - для любителей глохнуть дома и пугать соседей, 2 Вт - для озвучивания жилой комнаты. Как правило, на компьютере развить мощность RMS без дополнительного усилителя не получается.


Спецвыпуск Xakep, номер #012, стр. 012-080-5, Головная боль для соседей: обзор компьютерных колонок

Головная боль для соседей: обзор компьютерных колонок

Эндрю (illusionary@mail.ru)

Спецвыпуск Xakep, номер #012, стр. 012-080-5

Магнитное экранирование - экранирование магнитных полей, влияющее как на звучание самих колонок, так и на работу окружающих устройств (например, монитора). Если магнитное экранирование у колонок отсутствует, то ставить их рядом с монитором не рекомендуется. Если же экранирование присутствует, они будут влиять на изображение не больше, чем десятки проводов, пролегающих рядом с монитором, магнитные поля которых гораздо сильнее.

Активные/пассивные колонки. Активные колонки имеют встроенный усилитель и блок питания, пассивные их не имеют. Пассивные колонки подойдут только в том случае, если колонки нужны "чтобы были", поскольку без дополнительного усилителя они неспособны развить достаточную мощность и смогут озвучивать только звуки "завершение работы". Все колонки из обзора имеют встроенные усилители мощности.

Количество динамиков. Широкополосные колонки состоят из одного динамика, двухполосные - из двух, трехполосные - из трех и так далее. Разделение по частотам связано с тем, что один динамик неспособен надлежащим образом воспроизводить сразу весь диапазон частот. Часто попадаются двухполосные колонки с одним широкополосным динамиком (как правило, до 3000-4000 Гц) и одним высокочастотным (до 18-20 кГц).

Двухканальные или пятиканальные системы. Двухканальные - стерео - обойдутся тебе дешевле, на них ты сможешь слушать музыку, но не получишь полного представления об объеме звука при игре в Кваку или при просмотре DVD-фильмов. Правда, пятиканальные системы, подходящие для этих целей, часто уступают двухканальным в режиме "простого стерео". Часто колонки комплектуются сабвуфером, и если стереосистемы обычно сабвуфером не укомплектовываются, то пятиканальные - всегда, потому что в фильмах и играх бас имеет бoльшее значение, чем в музыке, где он зачастую оказывается лишним.

Последняя бобровая шкурка - расположение бобров в помещении

Если ты ставишь колонки по бокам монитора, то ты - хронический неудачник, которому хватит и мультик-media колонок. Нормальные люди ради расположения колонок могут сделать и перестановку в комнате. Надо фронтальные колонки расположить на уровне слуха, хотя бы на расстоянии 1 м по бокам от монитора. Фронтальную колонку ставят прямо на монитор, тыловые - на расстояние 1,5 метра сзади и метр по бокам, а вот с сабвуфером - отдельная история. Во-первых, басы отражаются от стен лучше всего - следовательно, расположение их источника в комнате играет огромную роль. Кроме того, давление в порте фазоинвертора здесь максимальное, поэтому он не должен упираться в стену. Часто возникают резонансы или искажения. Просто ставь его в разные места и подумай, где он играет лучше всего.

Прейскурант на бобровые шкурки

Jazz Hipster J-707

Мощность: 2х14 Вт (RMS), 2х160 Вт (PMPO)

Внешний блок питания

Частотный диапазон: 50-20000 Гц. Размеры (ШxВxГ)мм: 170x348x183


Спецвыпуск Xakep, номер #012, стр. 012-080-6, Головная боль для соседей: обзор компьютерных колонок

Головная боль для соседей: обзор компьютерных колонок

Эндрю (illusionary@mail.ru)

Спецвыпуск Xakep, номер #012, стр. 012-080-6

Цена: около $100

Замечательные колонки, полностью оправдывают свою цену. Кроме того, имеют очень даже симпатичный дизайн. Единственное субъективное неудобство - расположение органов управления на задней стенке колонки.

Jazz Hipster J-703

Мощность: 2х14 Вт (RMS), 2х160 Вт (PMPO)

Внешний блок питания

Частотный диапазон: 50-20000 Гц

Размеры (ШxВxГ)мм: 140x300x183

Цена: около $80

Колонки меньшего, чем J-707, размера с расположенными спереди органами управления. За счет габаритов и расположения фазоинвертора отличаются чуть измененным звучанием и меньшим басом.

Genius SP G-16

Мощность: 2х16 Вт (RMS), 320 Вт (PMPO)

Частотный диапазон: 20-20000 Гц

Цена: около $20

Колонки с явно завышенными характеристиками, за счет чего и завоевали в Белом Ветре надпись "Мультимедийные (!!!) Hi-Fi колонки!", а в другом магазине - "Hi-End акустические системы"! Но, вообще-то, это довольно удачная модель джениуса, завоевавшая большую популярность.

Jazz Hipster J-5508AV

Мощность: 2х7 Вт (RMS)

3" широкополосный динамик

3" высокочастотный динамик. Диапазон частот 80Hz-18KHz

Цена: около $35

Описание: Неплохие колонки среднего ценового диапазона для не очень требовательных пользователей.

Defender SPK-310

Мощность: 120 Вт (PMPO)

Диапазон частот: 150-20000 Гц

Цена: около $10

Симпатичные неплохие колонки из самого низкого ценового диапазона.

Defender SPK 376

Мощность: 4 Вт (RMS), 120 Вт (PMPO)

Диапазон частот: 60-18000 Гц

Цена: около $12

Хорошие недорогие мультимедийные колонки. Даже очень.

Altec Lansing ADA70

Мощность: 34 Вт

Диапазон частот: 35-20000 Гц

Цена: около $150

Два сателлита с сабвуфером со встроенным ЦАП, что позволяет подключать колонки посредством USB. Они имеют низкое соотношение сигнал/шум, из-за чего постоянно шипят. Стоит ли отдавать $150 долларов за шипучку в виде сабвуфера и двух динамиков ради прослушивания дешевой попсовой музыки? Не легче ли сэкономить 100 баксов и купить систему, которая сможет удовлетворить твои потребности не хуже?

ALTEC LANSING ACS43

Мощность: 5+5 Вт (RMS)

Частотный диапазон: 90-20000 Гц

Колонки ценой 50 долларов от известной фирмы. Если внешний вид нравится, то имеет смысл обратить внимание и на них. Но у меня они вызывают исключительно отрицательные эмоции.

F&D SPS-699

Мощность: 18 Вт (RMS), 300 Вт (PMPO)

Частотный диапазон: 40-18000 Гц

Материал корпуса: дерево

Цена: около $60

Замечательный выбор даже для настоящих ценителей музыки - хороший звук просто за смешные для него деньги!

F&D B-747A

Мощность: 25+25 Вт (RMS), 1500 Вт (PMPO)

Частотный диапазон: 40-18000 Гц

Цена: около $110

Я уже писал про них выше. Ежели ты хочешь смотреть фильмы на компе, то лучше взять пятиканальную YF-II, но музыка в их исполнении звучит просто божественно!

F&D YF-II

Мощность: 18 Вт + 5х15 Вт (RMS)

Материал корпуса: дерево

Цена: около $100.

Не самая дорогая, но хорошая 5.1 система. Подойдет не очень придирчивым любителям 5.1 фильмов или 5.1 игр.

F&D Shov IHOO MT 5.1

Выходная мощность: сабвуфер - 35 Вт, сателлиты - 18 Вт

Частотный диапазон: сабвуфер - 20-2000 Гц, сателлиты - 30 Гц - 20 кГц (front), 50 Гц - 20 кГц (center), 40 Гц - 20 кГц (surround)


Спецвыпуск Xakep, номер #012, стр. 012-080-7, Головная боль для соседей: обзор компьютерных колонок

Головная боль для соседей: обзор компьютерных колонок

Эндрю (illusionary@mail.ru)

Спецвыпуск Xakep, номер #012, стр. 012-080-7

Материал корпуса: дерево

Я уже выше говорил, что эта система оправдает все твои ожидания и свою цену... Но если у тебя нет хороших ушей, то бери YF-II.

Creative Desktop Theatre DTT-2500 Digital

Мощность: центральный сателлит - 21 Ватт; передние/задние левый и правый - по 7 Ватт; сабвуфер - 20 Ватт

Диапазон частот 40 Гц - 20 КГц

Цена: $250

Это уже не колонки. Это - настоящий домашний театр! Включает в себя не только акустические системы с усилителем, но и цифровой Dolby Decoder, тучу аналоговых и цифровых входов и выходов. Кому надо - бери с руками и ногами. Но, пожалуй, сами акустические системы F&D будут получше.

Genius SW-5.1 Surround

Сабвуфер: мощность - 20 Вт RMS, размеры - 150х290х200 мм, частотный диапазон - 10-300 Гц

Сателлиты: мощность - 5 Вт RMS, размеры - 90х108х115 мм, частотный диапазон - 30-20000 Гц

Цена: $60

Напоследок самая дешевая 5.1 система с симпатичным дизайном и пластмассовым сабвуфером, за корректную работу которого я не ручаюсь. Аналогично нельзя сказать, что звук системы будет впечатляющим. А ты что хотел за 60 долларов? Правильно, ты хотел купить F&D SPS-699 :)).

P.S. Отправляясь за покупкой, возьми с собой свой любимый сидючок и хорошенько послушай звучание понравившейся тебе колонки. Может быть, что она тебе совсем не подойдет.


Спецвыпуск Xakep, номер #012, стр. 012-084-1, Операция "Железяка"

Операция "Железяка"

Винни-Пух (dodge@xakep.ru)

Спецвыпуск Xakep, номер #012, стр. 012-084-1

Известно, что каким бы крутым хакером ты не был - тебе всегда найдется чему научиться. Пускай, ты знаешь все языки программирования в мире, но только у тебя заморгает монитор - тебе ничего не останется делать, как бежать к соседу и просить, чтобы тот его починил. Он усмехнется, врежет кулаком по экрану - и все станет замечательно. Так зачем же бежать к соседу и просить, когда всего лишь за три дня курсов, тебя научат куда бить? Скажешь, так не бывает? Еще как бывает! Сейчас обучить мастерству железячника тебя берутся очень многие, от частных преподавателей до весьма уважаемых и проверенных учреждений.

Кого выбрать?

Выбирать, как всегда, тебе придется с умом, а иначе можешь отдать деньги сразу мне - толку от ЗАО "Обучим быстро" будет немного. Когда начнешь искать курсы - обрати внимание, прежде всего, на дату основания учреждения. Понятно, что чем раньше оно основано - тем лучше. То есть, если это учреждение все еще работает – значит, либо у него хорошая крыша и связи в правительстве, либо там действительно хорошо обучают, и жалоб на них у народа нет. Как правило, такие учреждения являются еще и государственными или, во всяком, случае "при государстве". А ты должен понимать, что диплом государственного образца ценится гораздо больше «обычного» левака. Хотя, если смотреть правде в глаза, ценится больше всего умение, а не диплом. Диплом можно и в подземном переходе купить. Так что, если тебе, прежде всего, нужны знания "для себя" и денег ты хочешь потратить немного, то здесь лучшим вариантом будет частный преподаватель. Он наедине с тобой будет заниматься, отчего ты соответственно будешь лучше усваивать материал. И денег частнику меньше платят, и поторговаться всегда можно. Главное - опасайся объявлений, типа: "Обучу быстро и недорого" - это относится и к частникам, и к компаниям.

А теперь давай, наконец, перейдем непосредственно к обзору коммерческих курсов, которые нам удалось найти. Сразу прошу прощения, что объявлений частников здесь не будет - мы решили отложить это до следующего номера =).

Диагностика и ремонт ПК

"Мир Компьютеров" берется научить тебя ремонтировать компьютер "с нуля". Пообещали, что после обучения ты, наконец, усвоишь, что такое процессор и как выглядит жесткий диск, так как на этих курсах все наглядно покажут и расскажут. Занятия проходят каждый будний день с утра, либо в это же время по выходным. Длительность курса - 20 академических часов. Стоимость всего курса 550 рублей (практически даром). После окончания курса выдается удостоверение государственного образца (звучит солидно, но толку... :)). Ездить будешь на м. Автозаводская. Точный адрес: 1-ый Кожуховский переулок, дом 1. Далее ищешь вывеску "Орбита сервис", потом поднимаешься на 2 этаж и заходишь в комнату 23. Телефон: 275-26-10.

Диагностика и ремонт ПК №2

Либо я стормозил, либо они стормознули, но цена курсов у них - 120 баксов. Правда, название фирмы, как и цена, тоже страшное: Международный центр "Бизнес-образование". Несмотря на солидное название фирмы, длительность курсов - 2 месяца! Чему там можно учиться 2 месяца - до сих пор не пойму, но факт остается фактом. Занятия проходят, как и у всех, с утра до вечера недалеко от м. Измайловский парк. Связь по телефону: 259-00-83.


Спецвыпуск Xakep, номер #012, стр. 012-084-2, Операция "Железяка"

Операция "Железяка"

Винни-Пух (dodge@xakep.ru)

Спецвыпуск Xakep, номер #012, стр. 012-084-2

Настройка офисных и домашних компьютеров

Мне, например, совершенно непонятно, какой компьютер будет легче настраивать: тот, что в офисе стоит или тот, что дома? Может, тебе это стоит выяснить и походить на курсы "Настройка офисных и домашних компьютеров", который предлагает Центр Компьютерного Обучения при МГТУ им. Баумана. Курс рассчитан на 32 академических часа, это займет 3 недели, и угробит 2590 рублей! Зато, после окончания курсов, получишь диплом государственного образца. Телефон для справок и записи: 232-32-16. Если хочешь сразу поехать и оплатить, то тебе на ст. м. Бауманская, Госпитальный переулок, дом 4/6.

Техобслуживание и ремонт персональных ЭВМ типа IBM PC

Ну, блин, они и название дали ;). Курс опять предлагается тебе Учебным Центром при МГТУ им. Баумана, поэтому можешь быть уверен, что дураком оттуда не выйдешь. Тем более, что обучение рассчитано на целых 60 часов, и длится аж 5 недель - а за 5 недель даже макаку научат. Но не спеши соглашаться, - цена 4690 рублей! Я бы за такие деньги чему-нибудь еще научился, но решать тебе. Телефон: 263-66-33, кое-что можешь узнать на www.specialist.ru

Ремонт офисной техники и ПК

Учреждение с громким названием "Центральный Российский Дом знаний", что на м. Лубянка (есть над чем задуматься ;)), предлагает обучить тебя этому нехитрому делу. Ремонтировать начнешь уже через 100 часов, но только после того, как отдашь 3150 рублей. Занятия проходят на станции метро Лубянка - утром, днем или вечером, дело твое. Телефон для справок 924-3524 или 928-72-26.

Обслуживание ПК (обслуживание и ремонт ПК, периферийные устройства, офисные сети Windows)

Внимательно вслушайся в название учреждения, которое предлагает тебе курсы: "Межотраслевой институт повышения квалификации кадров МГТУ им. Баумана". Как же меня задолбал этот Бауман, зачем он только родился. Тем не менее, выбора у меня нет, так что читай дальше подробности. Полный курс обучения рассчитан на 90 часов и на 2700 рублей. Время занятий - обязательно вечер, а после полного курса обучения тебе выдают диплом государственного образца. Справки и запись по телефону: 176-34-39 или на www.mipk.ru

Радиомеханик (ремонт вычислительной и копировальной техники)

На радиомеханика, который почему-то ремонтирует технику, учат все в том же МИПК. Цена ужасна - 9800 рублей, но еще ужасней количество часов, на который рассчитан курс: 504 часа. Но это еще не все, ребята прикольнулись и сделали занятия только по утрам, или только в обед. Спасибо! Это очень удобно! Утешение нашел лишь в том, что после курса помимо государственного свидетельства дадут еще и разряд радиомеханика (номер разряда отказались говорить). Запись происходит на ул. Шоссе Энтузиастов, дом 29/53, этаж 7. Или по телефону: 273-24-25.

Как говорится: "Не умеешь учиться сам - заплати деньги, и тебя научат". По мне - лучше не тратиться на всякие курсы, а купить книгу по теме, прочитать ее, попрактиковаться на соседском компе... И тогда все будет пучком. Удачи тебе.


Спецвыпуск Xakep, номер #012, стр. 012-086-1, Программы для управления железом

Программы для управления железом

Urix (urix@da.ru)

Спецвыпуск Xakep, номер #012, стр. 012-086-1

Итак, компьютер мечты выбран, собран, куплен, отполирован до блеска и стоит на возвышении во всей красе. Какие тебе нужны программы для работы и безделья, ты прекрасно знаешь сам. Осталась самая малость - настройка, без которой эта куча железа будет работать вполсилы. Этого допустить никак нельзя, за что деньги-то платились? Но тут, понятное дело, голыми руками ничего не настроишь, схема "воткнул и порядок" не пройдет. Пора лезть в инет за софтом для управления железками.

Чуть не забыл! Пред тем, как что-нибудь настраивать, поставь свежие драйвера. А то жалуются ведь - то не работает, это не так... А драйвера какие ставил? - Какие такие драйвера 8-/?

Разгон системной шины и центрального процессора

Прога: SoftFSB 1.7 final

Размер в архиве: 113 Kb

Операционка: Windows

Страничка: на официальной страничке www.h-oda.com написано, что "Download & Support stopped", поэтому я закачивал отсюда: www.cpunews.cz/index.php?file=programy.php

Статус: freeware

Фичи

Попробуй угадать, какую процедуру выполняют чаще всего, чтобы на халяву повысить производительность. Конечно, разгон центрального процессора! С помощью SoftFSB можно разгонять процессор на лету, не выходя из Виндовса. Это гораздо лучше, чем невообразимым образом выворачивать руки, переставляя перемычки, которые, к тому же, вечно выпадают и непонятным образом оказываются в самом дальнем углу. И даже лучше, чем софтменю, которое, конечно, хорошая штука, но все-таки требует перезагрузок.

Хотя, конечно, на самом деле не все так радужно. Прежде чем разогнать проц, сперва нужно выбрать матплату из списка предложенных. А списочек-то не балует ассортиментом. Так что, скорей всего, немного поковыряться все-таки придется. Но только один раз. Когда раскрутишь своего железного друга, ищи генератор частот - это такая небольшая микросхемка, ставится, как правило, недалеко от процессора. На ней написаны производитель и модель. У меня, например, ICS 9248-39. По этим буковкам и циферкам во втором списке выбираешь свой генератор (в отличие от списка с матплатами, генератор найдется наверняка) и жмешь Get FSB. Верхняя появившаяся частота - текущая, нижняя - та, которая будет установлена, она регулируется ползунком. Остается только ткнуть в Set FSB. Что, все зависло? Ты поменьше частоту-то поставь, небось не жидким азотом проц охлаждается.

Интерфейс и документация

На мой взгляд, не хватает интуитивности, хотя автор тут не причем. Все-таки не все знают, что такое PLL и где его найти.

Документация на нескольких языках, английский есть, а русского нет.

Прога: CPUFSB 2.1.9

Размер в архиве: 1580 Kb

Операционка: Windows

Страничка: www.podien.de

Статус: shareware

Фичи

Программа - шароварный конкурент предыдущей. Просит за себя немного денег, но и возможностей по сравнению с SoftFSB предоставляет больше. Полнее список плат, в нем чаще встречаются последние модели. Умеет прописываться в автозагрузку и стартовать вместе с Виндовсом, а кроме того может оставаться в трее, где частоты можно менять выбором из списка.

Интерфейс и документация

Управление - практически один в один со своим аналогом, только дополнительно есть выбор частот для быстрого вызова.


Спецвыпуск Xakep, номер #012, стр. 012-086-2, Программы для управления железом

Программы для управления железом

Urix (urix@da.ru)

Спецвыпуск Xakep, номер #012, стр. 012-086-2

Все на английском, но справка прилагается, и разобраться вполне реально.

Резюме

Оверклокеры будут рады. Если не лень качать и не смущает срок годности, CPUFSB лучше, потому что свежее.

Программные кулеры

Наверное, даже младенцы уже не раз слышали о том, что современные процессоры поддерживают так называемые HLT-инструкции, позволяющие при бездействии процессора вырубать некоторые его части. И о том, что Windows 95/98/Me, в отличие от других ОС, эти инструкции использовать не умеют...

Прога: Rain 1.0/Waterfall 1.23

Размер в архиве: 123/121 Kb

Операционка: Windows 95/98

Страничка: в официальных факах написано cpu.simplenet.com/leading_wintech, но домена simplenet.com в природе не существует.

Статус: freeware (вроде)

Фичи

Две самых минималистских проги среди софткулеров - весьма старые, но других таких нет. Обе живут в трее и имеют всего одну опцию: включить/выключить. Памяти, соответственно, занимают минимум. Waterfall отличается тем, что менее производителен, зато более стабилен и позволяет следить, чем процессор занимается в свободное от работы время.

Интерфейс и документация

Документация на английском, интерфейс не предусмотрен =).

Прога: CpuIdle 5.8

Размер в архиве: 300 Kb

Операционка: Windows 95/98. Есть еще Pro версия для NT и 2000, хотя зачем она там нужна - непонятно.

Страничка: www.cpuidle.de

Статус: shareware

Фичи

Эта самодовольная прога утверждает, что она "лучшая программа в своем роде". Может в своем роде-то она и самая лучшая, я ее рода не знаю. А среди остальных кулеров она ничем не примечательна. Живет в трее, работает вроде исправно. Умеет определять тип процессора, есть индикатор нагрузки с настройкой внешнего вида, возможности автозапуска и отключения при большой нагрузке. В общем-то, на этом все и кончается, и почему она должна быть лучшей - непонятно.

Интерфейс и документация

Неудобно сделана прокрутка в меню с закладками, лучше бы ее не было. Сама программа русифицирована, но документация на английском.

Прога: CPUCooL 6.2.3

Размер: 2350 Kb

Операционка: Windows 95/98/Me/NT 4.0/2000/XP

Страничка: www.podien.de

Статус: shareware

Фичи

Вообще-то, это не совсем кулер, автор называет это многофункциональной утилитой. Похоже на кухонный комбайн. Кроме программного охлаждения, тут есть возможность смены частоты процессора, мониторинг температуры, вентиляторов и вольтажа, а также оптимизация памяти и работы процессора. Прога может находиться в трее и рядом с ним умеет рисовать маленькие графики (удобно для мониторинга). CPUCooL полностью включает в себя CPUFSB этого же автора, к тому же имеет кучу дополнительных настроек, но почему-то стоит столько же. Довольно странный подход.

Интерфейс и документация

Есть возможности настройки - маленькие или большие графики, частота обновления и прочая ботва. Язык везде английский, есть справка.

Резюме

Если ты считаешь, что экономия электроэнергии и ресурса процессора - почетное дело каждого юзера, то эти проги для тебя. Реально это может пригодиться для усмирения новомодного процессора, который жрет электричество как плита "Электра-1001" и греется примерно так же. Или на ноутбуке, хотя там бывает аппаратная возможность снижения частоты.


Спецвыпуск Xakep, номер #012, стр. 012-086-3, Программы для управления железом

Программы для управления железом

Urix (urix@da.ru)

Спецвыпуск Xakep, номер #012, стр. 012-086-3

Настройка и разгон видеоподсистемы

Прога: HZ Tool 1.4

Размер в архиве: 245 Kb

Операционка: Windows 95/98

Страничка: hem.spray.se/doxx/

Статус: freeware

Фичи

HZ Tool используется для настройки частоты обновления экрана по умолчанию. Для каждого разрешения, включая нестандартные из списка, она позволяет выставить нужную частоту.

Обычно, когда ты переключаешься в любимую игрушку или просто меняешь разрешение, Виндовс устанавливает частоту обновления по умолчанию, в большинстве случаев это 60 Гц. При 60 Гц мерцание видно очень хорошо, особенно если фон светлый. Работать так невозможно, поэтому если глаза дороги не просто как память, всякий раз, когда изменилось разрешение, приходится лезть с головой в дебри менюшек. В играх же вообще нет возможности что-либо поменять.

Так вот, чтобы избежать всех этих напрягов, и была написана данная прога. Она позволяет прописать все необходимые частоты за один раз и надолго забыть о них. Делается это очень просто - в главном окне программы надо выбрать драйвер видеокарты, отметить необходимые разрешения и выбрать для них частоты. Если нужной частоты нет в списке стандартных, можно создать свою, нестандартную.

Изменения записываются в реестр, поэтому надо сначала сохранить их, и только после этого можно выставлять разрешения.

Интерфейс и документация

Программа довольно простая, хотя русификация в любом случае не повредила бы. Справка есть, но она, как и вся программа, на аглицком.

Внешний вид весьма симпатичный, кроме программиста над программой работал и дизайнер.

Прога: Multires 1.26

Размер: 50 Kb

Операционка: Windows 95/98. Под Me кричала про ошибку.

Страничка: www.entechtaiwan.com

Статус: freeware

Фичи

Multires - переключатель режимов видеоподсистемы ПК. От встроенной утилиты Самой Любимой Фирмы его отличает более логичное расположение разрешений в списке, возможность смены частоты обновления экрана из трея и поддержка командной строки. Есть опция "подтвердить изменения", так что перезагружаться в Safe mode и восстанавливать частоты не придется - достаточно нажать Escape. Еще одна удобная возможность, которая, правда, редко используется - поддержка нескольких мониторов. Проверено - работает.

Интерфейс и документация

Переводов на русский нет, но в диалоговом режиме все предельно просто, и запутаться негде. Если нужны подробности работы в командной строке, документацию можно найти на сайте производителя.

Прога: PowerStrip

Размер архива:

Операционка: Windows 95/98/Me/NT 4.0/2000/XP

Страничка: www.entechtaiwan.com

Статус: shareware

Фичи

Самая толстая, умная и известная программа для настройки видеоподсистемы. Всегда поддерживает толпу видеокарт и мониторов, в том числе и самые последние, чем и хороша. По запросу выложит всю подноготную о железках, включая всяческие тонкие настройки. Позволяет настроить разрешение (до нескольких пикселов), частоту обновления экрана, размер и размещение картинки, гамму. Прога универсальна, поэтому многие используют ее для разгона видеокарт, мало заботясь об остальных опциях.


Спецвыпуск Xakep, номер #012, стр. 012-086-4, Программы для управления железом

Программы для управления железом

Urix (urix@da.ru)

Спецвыпуск Xakep, номер #012, стр. 012-086-4

Интерфейс и документация

Все настройки можно сохранять в профили и вызывать из трея одним-двумя щелчками мыши, а также для быстрого вызова всяких фенек поддерживаются комбинации клавиш.

Есть полная русификация (отдельный файл)! Хотя справки как таковой нет, ее заменяют хинты (всплывающие подсказки) и совет дня.

Резюме

Отличные проги, будут полезны геймерам и всем, кто не хочет воевать со стандартными средствами Виндовса для настройки экрана или имеет необходимость часто менять разрешения. Powerstrip дает максимум возможностей и возможность тонкой настройки.

Разгоним мышек

Прога: PS2 Rate Plus 0.4

Размер архива: 383 Kb

Операционка: Windows 95/98

Страничка: www.udpsoft.com

Статус: freeware

Фичи

Хвостатого грызуна тоже можно и нужно настроить. Обычно настраивают функции дополнительных кнопок, скорость прокрутки колеса, чувствительность. Но есть и еще один параметр - частота опроса порта, его тоже можно изменить.

Мыши, как известно, по подключению делятся на три типа: COM (опрос порта до 40 Гц), USB (до 100) и PS/2 (до 200). Покупать нужно именно последние, потому что они обеспечивают наибольшую плавность. Это важно в 3D-action играх, поэтому геймеры в курсе. А для разгона мышек существует специальный софт.

Этот архив включает две программы: первая - установка частоты опроса порта (до 200 Гц), вторая - проверка этой частоты. Только у меня почему-то не хотели нормально работать ни одна, ни другая: PS2 Rate на одном из компов никак не могла установить частоту, а mouserate, несмотря ни на какие ухищрения, при любых условиях показывала около 100 Гц.

Интерфейс и документация

Проблем нет, все элементарно. Язык везде английский.

Резюме

Если у тебя мышь до сих пор висит на COM-порте, пробуй PS/2, обратно возвращаться не захочется. Разница, как говорится, видна невооруженным взглядом.

Настройка чипсета и памяти

Про то, что BIOS можно настраивать, известно почти всем. Что его можно обновлять - многим. А вот о том, что параметры, которые задаются в BIOS setup, можно менять "на лету" специальным софтом, знают далеко не все.

Прога: WPCREDIT 1.20a/ WPCRSET 1.20

Страничка: www.h-oda.com. Последнее время касса закрыта и программы не выдают, поэтому попробуй www.viahardware.com/download/ - к тому же, там есть полезные доки по настройке VIA-чипсетов.

Статус: freeware

Фичи

WPCREDIT - "PCI Configuration Registers Editor", что по-русски обозначает: "редактор регистров PCI-конфигурации". Регистры прога редактирует через BIOS setup. Здесь сие происходит без перезагрузок, поэтому намного быстрее. Перезагрузиться придется только если комп не сможет работать с установленными настройками.

WPCREDIT работает с двумя основными видами файлов: *.pcr - описание битовых полей регистров, и *.rg - содержимое регистров. Чтобы загрузить описание, нужно сначала выбрать устройство (edit->device или ^D). Название файла обычно состоит из восьми циферок: используются Vendor ID и Device ID - идентификатор поставщика оборудования и идентификатор самого устройства. Если эти ID не совпадают с ID выбранного устройства, прога об этом предупреждает.


Спецвыпуск Xakep, номер #012, стр. 012-086-5, Программы для управления железом

Программы для управления железом

Urix (urix@da.ru)

Спецвыпуск Xakep, номер #012, стр. 012-086-5

Основное поле (регистры) представляет собой область памяти, где можно выбрать любой байт. Выбранный байт редактируется в нижней части экрана (кнопка edit). Чтобы изменения были задействованы, используется пимпа set. В правой части экрана - описания полей. По умолчанию подсветка описания синим цветом обозначает, что соответствующий бит имеет единичное значение, белый цвет - нулевое.

Отредактированные регистры хранятся лишь до перезагрузки, и если после отладки нет возможности их запомнить стандартными средствами, приходится идти на ухищрения. Если настройки нестандартные, другая прога - WPCRSET - помогает сохранить их и загружать автоматически.

Интерфейс и документация

Случай тяжелый. Понятно, что софт не для новичков, но интерфейс на английском, мануал на японском - перебор. Проги очень полезные, но чтобы со всем разобраться, доки придется поискать.

Прога: Tweakbios 1.53

Размер в архиве: 160 Kb

Операционка: DOS, Windows

Страничка: miro.pair.com/tweakbios/

Статус: shareware

Фичи

Эта прога занимается тем же, что и предыдущие две - на ходу изменяет регистры PCI Configuration. Только в отличие от них она платная - для сохранения и загрузки настроек просит зарегистрироваться.

Прога попроще, чем аналоги от H-Oda, но возможностей меньше, да и устарела уже.

Известные устройства распознаются автоматически, остается только указать нужное и изменять настройки. Изменить можно только те параметры, которые явно указаны.

Интерфейс и документация

Интерфейс - DOS-окно, как и сказано в доках, очень напоминает Award BIOS. Доки на английском.

Резюме

Если надо что-либо быстро проверить или отладить, эти проги - самое то. Конечно, надо знать, что можно менять, а что нет - для этого в инете придется поискать отдельные доки.

Прога: HddSpeed 2.1

Размер:

Операционка: DOS

Страничка: www.xponik.spb.ru

Статус: freeware

Прога: HDDutil 2.5

Размер:

Операционка:

Страничка: members.xoom.com/hddutility не работает, так что www.filesearch.ru.

Статус: freeware

Фичи

Вообще-то HddSpeed - "тест pеальной скоpости жестких дисков". По ходу развития в программу были добавлены всевозможные опции. И теперь, кроме характеристик диска и его производительности, программа позволят просматривать параметры SMART, изменять его статус, включать автосохранение атрибутов SMART, просмотреть дефект-лист на дисках Quantum, построить графики чтения поверхности, даже может попытаться заменить плохие сектора. HDDutil позволяет делать примерно то же самое, но обладает большим количеством функций и опций, так как изначально предназначен для ремонта и диагностики.

Интерфейс и документация

HddSpeed - DOS-окна, интерфейс на английском, но справка, фак и документация на русском.

HDDutil - все, кроме введения, на английском. Документация в архив с программой не входит.

Существует еще HDDutil 2.3 - версия под DOS, она имеет свои специфические возможности, которых нет в HDDutil версии 2.5.


Спецвыпуск Xakep, номер #012, стр. 012-086-6, Программы для управления железом

Программы для управления железом

Urix (urix@da.ru)

Спецвыпуск Xakep, номер #012, стр. 012-086-6

Резюме

Кроме включения СМАРТа в винтах нечего настраивать, а для ремонта эти проги незаменимы. Иногда есть необходимость сменить UDMA mode или задействовать acoustic management, но для этого производители дисков выпускают собственные утилиты.


Спецвыпуск Xakep, номер #012, стр. 012-090-1, Магазин на диване

Магазин на диване

Спецвыпуск Xakep, номер #012, стр. 012-090-1

UFO (ufo@xakep.ru; www.bezpredel.nm.ru)

Здравствуйте уважаемые телезрители! Вы смотрите передачу "МАГАЗИН НА ДИВАНЕ". Сегодня мы представим вам новейшие компьютерные девайсы, разработанные различными производителями. Начнем!

Лот 121. Цена: 9898.09$

Вашему вниманию представлена новейшая разработка фирмы "ВПАРкус",

250-ти скоростной CD-ROM! Его возможностям нет границ! Он пишет, читает, рубит, режет, косит и ломает! Это уникальная возможность приобрести универсальную вещь, которая заменит вам кухонный комбайн, бензопилу, газонокосилку и просто доставит много удовольствия. Привод имеет педали: "Газ", "Тормоз", "Сцепление", автоматическую коробку передач и кнопку с новой функцией "Замочить соседа текущим компакт-диском".

При покупке товара, предоставляются скидки (в 2% случаев) инвалидам, пострадавшим от уже купленных товаров фирмы "ВПАРкус". Фирма имеет большой опыт впариван... ой... извините... продажи своих товаров на мировом рынке!

ВНИМАНИЕ!!! BONUS!!!

Если вы покупаете CD-ROM в нашем магазине, вам также бесплатно достанется комплект бинтов и зеленка на случай нестабильной работы привода.

Лот 122. Цена 99.99$

Вашему вниманию предлагается струйный принтер фирмы "Hrennon". Принтер обладает широкими возможностями печати и покраски. Большое количество достоинств и универсальность делают его лидером среди новейших разработок струйных принтеров! Благодаря "Хреннон BJC-3000" вы имеете возможность распечатывать 5 рулонов туалетной бумаги всего за 1 МИНУТУ!!! Принтер поддерживает практически все форматы бумаги за исключением A4 (данный формат уже разрабатывается Хренноном и скоро его поддержка будет включена в BJН-3000). Вам надо покрасить забор на даче, разрисовать соседскую машину или перекрасить шерсть соседской кошке? "ХРЕННОН BJC-3000" решит ваши проблемы за короткое время!!! Вам нужно только запрограммировать "Хреннон BJC-3000" на нужное действие с помощью специальной программы и можете наслаждаться окраской всего, что попадется на ваши глаза! В случае, если у вас возникнут проблемы с "Хреннон BJC-3000", на корпусе принтера имеется специальная ручка для удобного вышвыривания с балкона.

ВНИМАНИЕ!!! BONUS!!!

Только сегодня! При покупки "Хреннон BJC-3000" в нашем магазине, вы приобретаете бесплатную медицинскую страховку для соседей - на случай неадекватной реакции на окраску их питомцев! По всем вопросам связанным с неполадками звоните в нашу службу технической поддержки по телефону "03".

Лот 123. Цена 81.11$

Уважаемые господа! Наш магазин предоставляет вам уникальную возможность приобрести новую разработку фирмы ABаSSUS - видео карту

" ABаSSUS AGP V3133.14DOR (Pivо TNT4 128Mb)". Эта видео-карта поддерживает огромные разрешения и очень элегантно смотрится в мусорном ведре. Возможность подключения к " ABаSSUS AGP V3133.14DOR (Piva TNT4 128Mb)" трехмерных очков, контактных линз, носков, трусов и презервативов, доставит вам наибольшее удовольствие от трехмерных игр и просмотра порно-картинок. В AGP V3133.14DOR встроен 3D-ускоритель с ручной коробкой передач и охлаждающий COOLER с двигателем от пылесоса "SЕЕMЕENS-ХЕРС". Так же имеются разъемы "TV IN", "TV OUT" для подключения телевизионной антенны, душевого шланга и холодильника.


Спецвыпуск Xakep, номер #012, стр. 012-090-2, Магазин на диване

Магазин на диване

Спецвыпуск Xakep, номер #012, стр. 012-090-2

Лот 124. Цена 5$

Вашему вниманию предлагается клавиатура фирмы "Micrososeft". Эта клавиатура обладает огромным количеством дополнительных функций, которые перечислены ниже.

Клавиша "Совершить недопустимую операцию" поможет вам совершать ошибки в программах, не дожидаясь сбоя Windows. Клавиша "Затормозить систему" предоставляет вам возможность загрузить ваш процессор до максимума, и тем самым Windows в очередной раз убедит вас в необходимости апгрейда вашего компьютера.

Также существует возможность подключения клавиатуры к таким устройствам, как "Унитаз", "Стиральная машина", "Пылесос" и "Веник". Подключив эти устройства к клавиатуре, вы навсегда забудете о спокойной обстановке в вашем доме (драйверы для каждой категории устройств продаются отдельно). С момента подключения приборы начинают работать в автоматическом режиме под управлением Microsoft Windows.

ВНИМАНИЕ!!! BONUS!!!

Доплатив всего 9999.99$ вы получаете практически бесплатно защитный скафандр для избежания смертельных повреждений от некорректного управления подключенными девайсами.

На этом наш магазин закрывается. Спасибо за внимание.

P.S.

При написании статьи не один Билл Гейтс не пострадал.


Спецвыпуск Xakep, номер #012, стр. 012-092-1, Обзор книжек по железу

Обзор книжек по железу

Urix (urix@da.ru)

Спецвыпуск Xakep, номер #012, стр. 012-092-1

Что, решил почитать книжки по железу? Гиблое это дело, скажу я тебе. Большинство этих книжек устаревает еще до того, как выходит в продажу. А ты про компьютерные журналы, газеты и инет никогда не слышал? А про конференции Fido и Usernet? Вот там и ищи свежую инфу. Ах, тебе принципы работы нужны, которые не устаревают... Уговорил, начинаем.

Жаров А. "Железо IBM 2001". - М.: МикроАрт, 2001. - 386 с.

Содержанием эта книжка напоминает лоскутное одеяло. Сомнительно, что когда-либо здесь была основная часть - скорее в ход пошло все, что было под рукой. Встречается как жуткая экзотика, так и полное отсутствие простейших вещей. Ну, да ладно - похоже, так большинство книжек пишется. Что-то дописали, заголовками объединили, версткой подвязали. Верстка, кстати, только подразумевается, подвязали так, что отыскать ее следы смогут только юные следопыты.

Отдельно надо отметить качество издания. Оно не намного выше, чем обычно получается на ксероксе. Многие фотки настолько плохо напечатаны, что понять, что же там такое фотографировали, без подписей никак нельзя. Местами плохо пропечатаны буковки - видимо, часть краски снюхали токсикоманы, и ее не хватило.

То, что получилось в результате - жуткое сочетание вкуса и цвета. Тем не менее книжка переживает уже восьмое издание и формы своей не теряет ;). Информации много разной и оригинальной, местами даже интересно. Но никакой фундаментальности или чего похожего там и близко не валялось - для обучения не пойдет. Сделанная на коленке, эта книжка на коленке будет и читаться. Читать можно, хотя язык тяжелый и нужна подготовка. Начинающему почитать тоже можно, только начинать надо не с начала, а с середины примерно. Хотя начинающим все равно, с какого места начинать, - где начнут, там и будет начало.

Рекомендуется как зеленым фанатам Митинского радиорынка, так и его закаленным боями работникам. Необходимое условие - готовность прорубаться через словесные джунгли и изыски полиграфии.

Рудометов В. Е., Рудометов В. А. "PC: настройка, оптимизация и разгон". - СПб.: БХВ-Санкт-Петербург, 1999. - 256 с.

Честно говоря, от этой книжки можно было ожидать большего. В том смысле, что никакого сакрального знания она не содержит, да и материала маловато. Описанные в ней вещи часто встречаются в других источниках и достаточно известны. Что хорошо - тут они все собраны в кучку, и ты можешь прочитать все сразу. Пожалуй, если компы - твое хобби, сделать это стоит. Но не надейся здесь найти уйму информации и глубокомысленных объяснений. Некоторые главы просто удивляют - например, настройка сети (со скриншотами ;)) - совсем не в тему. Или сотня страниц с бенчмарками. Бенчмарки обычно встречаются в инете или в периодике, потому что в книжке они выходят с опозданием, а устаревают сразу после выхода новой линейки процессоров. К тому же для того, чтобы показать, что дешевый разогнанный Celeron бывает быстрее дорогого P-2, достаточно двух-трех, а не сотни страниц.

Рекомендуется начинающим (и только) оверклокерам, а также желающим выжать из своей старенькой машинки последние соки.


Спецвыпуск Xakep, номер #012, стр. 012-092-2, Обзор книжек по железу

Обзор книжек по железу

Urix (urix@da.ru)

Спецвыпуск Xakep, номер #012, стр. 012-092-2

Пилигрим А. "Персональный компьютер: модернизация и ремонт". - СПб.: BHV-Санкт-Петербург, 2000. - 528 с.

Самая безликая и невнятная книжка во всем обзоре. Выпущена в 2000 году, но большая часть информации размазана между 1985-1998 годами и безнадежно устарела. Процессоры, например, заканчиваются P-2, на похожем уровне и все остальное. Содержание здорово перемешано само по себе, плюс добавлены главы с ПО. Чтобы разобраться в получившейся каше, нужны шеф-повар и семь поварят. Единственное, что можно сказать точно, - здесь, как и в любой книжке по модернизации, ты найдешь инфу о том, как раскрутить комп и повтыкать все эти платки, коробочки, кабелечки, джамперочки. А еще здесь написано, как раньше назывались все эти дымящиеся запчасти...

Пресс Б., Пресс М. "Ремонт и модернизация ПК. Библия пользователя". - М.: Вильямс, 2000. - 1120 с.

Тысяча сто страниц - о чем на них можно рассказать? Обо всем на свете рассказать нельзя, но авторы пытаются. Выбор очень широкий: устройство железяк, их характеристики и конкретные модели, софт и его настройка. Причем спектр устройств тоже на уровне, да и в софте не Виндовс единый. Есть раздел о портативных устройствах, чего больше нет нигде. Книга очень объемистая и сильно выходит за рамки пользовательского уровня, да и за рамки названия тоже. Она буквально напичкана инфой, и если посильнее нажать, инородные элементы типа роутеров и настройки Юниксов, которым не место в этой книжке, могут полезть наружу.

Но главная задача книжки видна невооруженным глазом - размолоть, как же работает все это удивительное цифровое барахло, которое нас окружает. Для этого есть масса схем и описаний принципов работы, случаются и фотки.

Авторы стараются постоянно быть на гребне волны, поэтому книга периодически обновляется и переиздается, описывается последнее вышедшее оборудование. Так что старого железа здесь нет, хотя есть привязка к конкретным моделям, которые постепенно устаревают.

Рекомендуется большим людям, которые считают, что хорошего должно быть много.

Мюллер С. "Модернизация и ремонт персональных компьютеров. БИНОМ", 1998. - 944 с.

Книжка здоровая и отличается какой-то основательностью, что ли. Язык простой, но описания подробные и на хорошем уровне. Чувствуется специализация на теме ремонта, поэтому встречаются довольно редкие вещи. Большая часть инфы, к сожалению, относится к динозаврам, которых на рынке нет уже лет пять. Многое устарело, но стандартов, таблиц и справочных данных здесь безмерное количество, поэтому если тебе нужна справочная информация по разъемам, здесь ты ее наверняка найдешь.

Рекомендуется продвинутым ремонтерам ПК и желающим подпаяться к собственному компу или перепаять все разъемы.

Граймз Г. "Освой самостоятельно модернизацию и ремонт ПК за 24 часа". М.: Вильямс, 2000. - 288 с.

Пожалуй, эта книжка может быть учебником начального уровня. Весьма приятное издание. По крайней мере, в отличие от других она не похожа на свалку - написано все аккуратно и последовательно, можно даже сказать, по полочкам разложено. Про железки рассказывается человеческим языком, никакого избытка технических подробностей. Описания в основном обзорные, зато девайсы самые разнообразные. Собственно говоря, пользователю больше и не нужно. Читается легко, есть алгоритмы замены деталей, фотки и ссылки на сайты в инете - все что надо, чтобы всосать основы и стать подкованным перцем.


Спецвыпуск Xakep, номер #012, стр. 012-092-3, Обзор книжек по железу

Обзор книжек по железу

Urix (urix@da.ru)

Спецвыпуск Xakep, номер #012, стр. 012-092-3

Рекомендуется всем пользователям и сборщикам на уровне "вынул плату - вставил другую", без стандартов на цепи, интерфейсов и прочих распиновок микросхем.

Рабтон Э. "Модернизация и ремонт ПК для "чайников"". Вильямс, 2000. - 352 с.

Вроде написано "для чайников" и общий стиль развлекательный, но местами можно наткнуться на совершенно несъедобные таблицы или умные фразы без всяких объяснений. Пара таких фишек - и чайник с расколотым носиком отойдет от книжки и больше ее не откроет.

Что можно посоветовать: чтобы этого не случилось, при чтении не стоит слишком напрягать мозги и пытаться что-либо понять. В мозгах что-нибудь отложится в любом случае, а если книжка написана бездарно, так ее не поймешь, сколько ни напрягайся. Так что если хочешь развлечься, таблички и прочие заморочки пропускай. А если хочешь научиться чему-либо серьезному, купи другую книжку.

Фролов А. В, Фролов Г. В. "Аппаратное обеспечение персонального компьютера". М.: ДИАЛОГ-МИФИ, 1998. - 304 с.

Книжка из серии "Библиотека системного программиста". Полностью посвящена программированию всяких периферийных устройств и описывает комп изнутри. То есть таким, каким он выглядит для разработчика системных программ. Описалова состоят из двух частей: первая - адреса, регистры, значения битов и прочая справочная инфа. Вторая - проги, которые все это используют. Например, есть листинги, где программируются таймер, порты, мышь, принтер, ну и прочая ботва.

Рекомендуется мозолезадым любителям ковыряния дебаггером в железных мозгах своего ПК.

Гук М. "Аппаратные средства PC. Энциклопедия". - СПб.: Питер Ком, 1998. - 816 с.

Нужно сразу сказать, что это книжка по схемотехнике. И разговор идет не о том, как собрать комп, а о том, как его спроектировать. Например, описывается, из чего состоят платы, какие микросхемки туда ставятся, какие у них ножки и как это работает. Ну и описания сигналов и цепей вдобавок - без них никак. Так что книжка совсем не для начинающих. И даже не для продвинутых. Она может пригодиться будущим специалистам - разработчикам девайсов, совместимых с ПК. Эти люди переварят любой винегрет из собранной в книжку инфы. И их не смутит, что в одной главе густо, аж вязко, а в другой пусто и звонко. Пожелаем им найти качественные пристяжные ремни для унитаза.

Колесниченко О. В. Шишигин И. В. "Аппаратные средства PC". СПб.: БХВ-Санкт-Петербург, 1999. - 800 с.

В некотором роде - стандартная книжка по железу. Отдельные ее черты встречаются во всех других книжках. Итак, что же вобрал в себя этот образ:

Архитектура, интерфейсы и принципы работы устройств. Внешний вид и описание конкретных моделей, их технические характеристики.

Охват по устройствам - от плат расширения до принтеров и сканеров. Охват по времени, на примере процессоров, - с былинных времен (что-нибудь вроде Intel 4004) до времени издания книжки (P-2). Иногда встречаются необходимые инструменты и довольно часто - алгоритмы сборки компа. Но все это как-то очень привычно. Видимо, чтобы разнообразить жизнь, в эту книгу поместили баннер. Он есть в нескольких местах и даже в тексте встречается. Говорят, что только самые жадные вебмастеры вешают баннер не в служебных областях, а посреди текста. Так что если отрыв от инета болезненно сказывается на твоей психике, эта книжка поможет тебя смягчить переход в реальную жизнь. Методы инет-рекламы всегда будут с тобой. А там, глядишь, купишь журнал, оторвешься от порносайтов... Жизнь-то налаживается!


Спецвыпуск Xakep, номер #012, стр. 012-092-4, Обзор книжек по железу

Обзор книжек по железу

Urix (urix@da.ru)

Спецвыпуск Xakep, номер #012, стр. 012-092-4

На сегодня все. Пишите письма.


Спецвыпуск Xakep, номер #012, стр. 012-094-1, RAID - добро пожаловать на кластер

RAID - добро пожаловать на кластер

Unforgiven (unfogi@sanet.ru)

Спецвыпуск Xakep, номер #012, стр. 012-094-1

Стремно жить на белом свете: то самолет на башку грохнется, то ракета где-то рядом рванет. Что же делать?! Как же защитить единственное, что у тебя есть?! ЕГО! Винт с наиценнейшей инфой, стоимостью в миллион... Денег? Грязных носков? Зависит от того, что ты там хранишь. Но, согласись, все равно будет обидно из-за какого-нибудь пьяного монтера потерять всю коллекцию порнухи, свой кул-арт, чумовые mp3-шники, базу номеров... эээ... телефонов окрестных старушек. В общем, ты понял. Все на защиту винтов!

Самый мощный способ оградить свой винт от шуток отечественных энергетиков - это поставить себе RAID-контроллер. Способ недешевый, но дюже крутой, так что если есть бабло, то не теряй времени. Этот девайс поможет тебе сохранить данные, увеличить производительность твоих хардов и не даст пропасть куче старых маленьких винтов, которые ты уже начал было подкладывать под ножки шкафов и комодов.

Давным-давно, в соседнем подъезде...

История... Нет, сказка. Давным-давно, кажется, в прошлую пятницу ((с) Милн) 3 перца сидели под окном Калифорнийского универа и офигевели от безделья. Надоело им в девках сидеть, и решили они потрахаться, причем жестоко. "Хотим", - говорят, "чего-то большого и твердого". Взяли наши головастые чуваки по ящику пива на брата, потом еще и еще, и решили сотворить чудо - винчестер офигительного объема. При этом, он должен был иметь повышенный уровень защиты и маленькое время доступа. А шел тогда 1987 год, и большие и жесткие были максимум мегов по 100, весили килограмм по 5 каждый и жили разве что в серваках, причем тормозззили жутко, да и особой надежностью не отличались. Догнавшись чипсами, перцы родили идею: а что если купить несколько убогих винтов маленького объема и объединить их в один большой массив? Такая система будет превосходить один большой хард, который еще надо сделать, и за который ты выложишь не одну сотню (а то и тысячу) баксов. Пораскинув мозгами еще чуть-чуть, мужики написали и опубликовали статью "A Case for Redundant Arrays of Inexpensive Disks (RAID)", то есть "Корпус для избыточных массивов из дешевых дисководов". Звали перцев Паттерсон (Patterson), Гибсон (Gibson) и Катц (Katz). Срочно вешай их портреты над своей койкой вместо Коперника, Галилея и Бруно :). Так в 1987 году родился RAID-интерфейс (Redundant Array of Independent \ Inexpensive Disks), что в переводе на отечественный язык - избыточный массив независимых \ недорогих дисков.

Где же фишка?

"А в чем вся фишка?" - спросишь ты. "Кучу старья в кузов пихать, потому что выбрасывать жалко?" И будешь неправ. Фишка в том, что скорость доступа к этим винтам при использовании RAID-интерфейса заметно увеличивается, особенно в многозадачных системах. Запись данных на диск идет, как на один винчестер, то есть Винды будут определять твои несколько дешевых винтов как один целый. А при считывании данных ты заметишь офигительный прирост производительности, так как одна прога может у тебя занять не один винчестер, а допустим, два, и при скачке ее с винта действия будут происходить параллельно сразу с двух носителей. Ты почувствуешь настоящий драйв.


Спецвыпуск Xakep, номер #012, стр. 012-094-2, RAID - добро пожаловать на кластер

RAID - добро пожаловать на кластер

Unforgiven (unfogi@sanet.ru)

Спецвыпуск Xakep, номер #012, стр. 012-094-2

Оно мне надо?

Теперь разберемся, нужен тебе этот девайс или это абсолютно бесполезная штука. Сейчас я задам тебе несколько безобидных вопросов. Случалось ли тебе экстренно качать файло с одного винта на другой, потому что на нужном не хватило места? Например, решил ты перегнать пару фильмов в DivX, и уже почти все закодилось, томительные часы ожидания позади, но вдруг - опа! - место кончилось. Тут главное, чтобы под рукой ничего тяжелого не оказалось (биты, например, бейсбольной). И сразу музыку, хорошую музыку. А потом - в парк, и гулять, гулять, гулять... А может, тебя не устраивает время доступа к твоему винту, и кажется, что эта тварь работает со скоростью флопаря? Или ты не раз терял нужную тебе инфу и теперь бэкапишь все по десять раз? А может, ты просто хочешь, чтобы твоя система была понадежней? Тогда вполне возможно, что RAID - это нехилая маза для тебя.

Так вот ты какой, серверный олень!

RAID может быть реализован по-разному (смотри на скриншоты). В основном - это платы-расширения, которые вставляются в PCI-слот. Но встречаются и залитые прямо в чипсет "материнки" (лично я юзаю такой). Обычно RAID имеет два канала IDE, на каждый из которых можно подрубить по два девайса, то есть всего на четыре девайса. После того, как воткнешь RAID-контроллер и поставишь драйваки, у тебя уже будет восемь IDE, и ты сможешь туда набить любых винтов, сидюков, и других штуковин, полезных в жизни. Неплохой прирост, однако. Продвинутые модели имеют SCSI-интерфейс. Но про них я лучше промолчу, потому что SCSI стоит немеренно, и ставить такое домой - экстрим. Лучше пару больших винтов купить. На сказийный девайс можно запихнуть до шестнадцати устройств.

Проблема выбора

RAID-ы бывают разные. Какой же тип RAID-массива выбрать? Это смотря чего ты от него хочешь. Дело в том, что RAID создавался для того, чтобы объединять мелкие винты в один большой кусок, делать харды производительней и надежней. То есть у RAID-а несколько задач. В зависимости от задачи выбирается и уровень RAID.

RAID-0. Для гонщиков

Этот тип массива - для Спиди - гонщиков. Иногда его называют "Striping" ("полосатый" или "тельняшка") по способу размещения инфы по дисководам, входящим в кластер. Запись на диски идет кусками, один блок на один диск, следующий блок на следующий диск и так далее. То есть, в этом массиве нет избыточности aka дублирования инфы и контроля четности дисков: можно и 3, и 4, и 5 винтов засандалить, и все будут юзаться. Минус в том, что авария одного диска убьет весь массив, поэтому для любителей страховать свою инфу этот массив не катит. Зато для любителей разгонять системы - это самое то, ведь чтение происходит со всех винтов разом. По данным теста Miro VIDEO EXPERT Benchmark, по сравнению с одним дисководом, массив RAID-0 из двух хардов дает прирост скорости записи/чтения на 96%, из трех хардов - на 143%. Понятно, что для создания RAID-0 нужно минимум 2 винча, а лучше - три и более. Очень рекомендую тем, кто работает с огромным количеством информации. Например, при нелинейном монтаже видео, RAID дает просто суперприрост производительности.


Спецвыпуск Xakep, номер #012, стр. 012-094-3, RAID - добро пожаловать на кластер

RAID - добро пожаловать на кластер

Unforgiven (unfogi@sanet.ru)

Спецвыпуск Xakep, номер #012, стр. 012-094-3

RAID-1. Для гонщиков-параноиков

Этот тип более известен как "Mirroring" ("Зеркалирование") - это пара хардов, содержащих одинаковую инфу и составляющих один логический диск. Запись на диски в массиве производится следующим образом: на первый винт один блок данных, на второй винт точно такой же блок данных. То есть система как бы бэкапит (backup) один хард на другой. Уровень RAID-1 избыточен на 100%. Поэтому при поломке одного винта система автоматически юзает инфу с другого, и файло в полном порядке. Запись в данном RAID-уровне остается на прежней скорости, так как записывается все по-прежнему, а вот считывание информации может идти с Х2-скоростью за счет того, что один и тот же файл может скачиваться с твоих винтов параллельно. Советую данный массив поставить параноикам, трясущимся над своей инфой, потому что практически backup будет выполнять сама система, на чем можно сэкономить немало времени и нервишек.

Для RAID-1 нужно минимум два диска или более, но четное количество, то есть если у тебя их будет три, то один просто окажется ненужным, а если у тебя их будет четыре, то получится "тельняшка", только двойная. То есть блок №1 на 1-й и 2-й винты, блок №2 на 3-й и 4-й и так далее. Такая мулька еще обозначается как RAID-0 + RAID-1, или просто RAID-10 и дает сочетание «надежность плюс скорость».

Надежность сервантам!

А теперь поговорим немного о четности и байте паритета. Ты наверно уже давно слышал про технологию ECC (Error Correcting Code - код с исправлением ошибок). Фишка технологии заключается в том, что на винт записывается не только инфа, но и еще контрольная сумма. И при каждом обращении винт автоматом проверяет эту сумму - ищет возможные ошибки. Кстати, данная технология применяется не только на винчестерах, но на всех продвинутых носителях информации, память с такой проверкой на ошибки очень дорого стоит и в домашних условиях встречается очень редко, но на серваках это - обычное дело. Надежность, надежность и еще раз она же. Поскольку RAID-интерфейс рассчитан прежде всего на серванты, следующие четыре уровня завязаны на ECC.

RAID-2,3,4,5: паранойя с вариациями

Инфа здесь хранится полосами (stripe), то есть кусками, которые, в свою очередь, поделены на блоки размером от сектора до нескольких мегов. Эти блоки пишутся последовательно на все харды кластера. Фишка этих уровней в том, что часть винтов или места на них отводится под хранение кодов коррекции ошибок (ECC). В случае отказа одного из хардов восстановление хранившейся на нем инфы возможно, если отксорить (XOR) информацию на живых винтах.

В RAID-2 эти коды по умолчанию хранятся на большинстве винтов для каждого сектора, что неэффективно. Поэтому его почти не юзают.

RAID-3 устроен несколько лучше: контрольные суммы хранятся только на одном диске. Правда, размер полосы у этого уровня - всего один сектор (полоска пишется последовательно на каждый винт по одному сектору), то есть инфа тонко намазана на все драйвы. Поэтому в RAID-3 обращение идет сразу ко всем винтам кластера, то есть он хорош для работы в приложениях с интенсивным обменом с дисками, но не катит для многопользовательской, многозадачной системы.


Спецвыпуск Xakep, номер #012, стр. 012-094-4, RAID - добро пожаловать на кластер

RAID - добро пожаловать на кластер

Unforgiven (unfogi@sanet.ru)

Спецвыпуск Xakep, номер #012, стр. 012-094-4

В RAID-4 ширина полосы (размер блока) много больше одного сектора, поэтому не надо дергать все харды. Задействуется 2 винта: с инфой и с контрольными суммами. Однако, с записью и здесь траблы, так как каждая операция должна обновить ECC - следовательно, нельзя колбасить контент одновременно.

RAID-5 дал трем предыдущим пососать по карамельке. Он может читать и писать одновременно несколько файлов. Stripe-ы у него тоже широкие, но контрольные суммы пишутся в произвольном порядке. То есть так: диск раз - блок 1, диск два - блок 2, диск тры - сумма, диск раз - инфа, диск 2 - сумма и так дальше. Облом с параллельной записью получается только, если страйп и его контрольная сумма валяются на одном диске. Но это лечится большим количеством винтов. RAID-5 очень багоустойчив.

Делайте ваши ставки!

Так что ставить-то? Чузай себе девайс по целям и средствам. Домой, конечно же, не стоит брать сверхдевайс (читай: сверхдорогой девайс), способный поддерживать все RAID-уровни. Обычные дешевые железки способны поддерживать только RAID-0, RAID-1 и RAID-10. Тут выбор стоит между "зеркалить" - не "зеркалить". Место есть - выбирай RAID-10. Если ты фэн гоночных писюков, но с местом туго, то лучше поставить в позу RAID-0. Что же касается 5-го уровня, ECC-метод конкретно экономит хардовое пространство (RAID-1 впустую жрет гигзы места), но по скорости первый уровень рвет его в клочья.

Мягкотелый суррогат

Т-с-с-с! Приятель, по секрету и только тебе скажу: есть маза попробовать дома RAID, не платя при этом ни у.я. Нужно будет просто поставить себе Windows NT 4.0 или 2k (желательно, SERVER). В этой продвинутой операционке есть не только такая крутая штука как NTFS, которая просто идеальна для твоего винта, но и возможность софтварно реализовать RAID-массив нулевого и первого уровня, а в версии Server - даже пятого. Но хочу сказать сразу, что фишка, типа, "нафига мне покупать, если можно сделать все через Винды", не пройдет. Возможности программной реализации убоги, и ты лишь сможешь воткнуть, что за мулька RAID и как его юзать. Софтверный заменитель, как всегда, обладает кучей сакса: все расчеты по RAID-алгоритму ложатся на твой проц в удвоенном объеме, и чем больше уровень массива, тем тормозней будет система. RAID-контролер же берет обработку всех логических операций связанных с диском на себя, чем дешку разгружает твой и без того уже затертый камень. У программной реализации есть еще один серьезный трабл. Если один из хардов массива в Виндах полетит, то информацию, ты уже нифига не восстановишь, к тому же замена дисков и все такое будет тебе полностью недоступна. Такова се ля ви.

Карманы и цены

Как я уже сказал, RAID - это тебе не подружка \ дружок на одну ночь, а реально крутой профи девайс, поэтому цены соответствуют. Но выбор все-таки есть. Бывают RAID-контроллеры, которые по своей сути таковыми не являются, просто в плату прошит BIOS, который отвечает за возможность создать RAID - массив. Такая железка сильно грузит процессор всякой ерундой, поэтому стоит относительно дешево (порядка 200 уев - правда, это SCSI-контроллер). Есть контроллеры, которые работают в паре с уже имеющейся у тебя IDE, то есть вся логическая структура RAID лежит на карте, а "материнка" отвечает за обмен данными. С ними бывают траблы: иногда контроллеры "мамки" и RAID-карты несовместимы. Эти девайсы обладают возможностями полноценных RAID-устройств и поэтому достаточно дороги. Существуют, ясный пень, и полноценные RAID-контроллеры. Но они нам не по карману и рассчитаны на серваки. Они имеют высокую производительность, поддерживают до трех каналов, обычно представлены лишь SCSI-вариантом, имеют встроенный RISC процессор для расчета логических операций и контрольных сумм, и встроенный кэш, для быстрого обращения к часто используемой информации. Ну, и хардкор - внешний RIAD. Это небольшая коробка, в которой размещен контроллер и все, что к нему нужно. Если ты любитель всяких фишек с лампочками, то эта штука для тебя :). Есть у него одно большое преимущество: такой девайс не зависит от операционной системы и от шины PCI, и если наступит черный день, и "матерь" полетит, он все равно останется жив. Стоит этот артефакт запредельную сумму.


Спецвыпуск Xakep, номер #012, стр. 012-094-5, RAID - добро пожаловать на кластер

RAID - добро пожаловать на кластер

Unforgiven (unfogi@sanet.ru)

Спецвыпуск Xakep, номер #012, стр. 012-094-5

Лирика

Воткнуть RAID в "мамку" мало. Надо подумать о вместительном кузове (для кучи винтов и винтиков), мощном блоке питания (250W - это минимум, а лучше - 300), а также об охлаждении твоей хардовой братии (дополнительных вентилей в кузове не избежать). В общем, нужно серьезно задуматься, нужен ли RAID под твои задачи. Если цели огромны, то RAID даст суперпреимущество. Иначе - просто купи себе хард побольше и пошустрее...

Сенксы за дружескую лапу сайту 3D News.


Спецвыпуск Xakep, номер #012, стр. 012-098-1, ... А связь у меня никогда не обры%^NO CARRIER, или немного о модемах

... А связь у меня никогда не обры%^NO CARRIER, или немного о модемах

Спецвыпуск Xakep, номер #012, стр. 012-098-1

MOOF (moof@real.xakep.ru; http://moof.ru)

Вот несколько ссылок с более подробным описанием модемов:

http://ixbt.com/communication.shtml

http://www.usrsupport.ru/

http://www.usrmodem.ru/

http://www.inpro.ru/

http://www.zyxel.ru/

Dialing

Я уверен, что ты знаешь, что такое модем. Давай немного освежим твои знания. Слово "модем" на самом деле было составлено из двух слов: МОДулятор и ДЕМодулятор. Объясняю на пальцах. Если ты хоть раз в жизни пользовался звуковыми редакторами, ну или хотя бы видел в кино как бравые американские копы обрабатывают голос плохих парней на компьютере, то представляешь, как выглядит то, что передается по телефону, когда мы разговариваем. Это такие ребристые, волнистые, угловатые линии :). Человек их легко распознает, и, как ты смог заметить, часто этим пользуется для общения с себе подобными. В отличие от биологического человека, компьютер - просто железка, и ему не дано (вероятно только на данный момент) разобраться во всем разнообразии звуков, издаваемых человеком. Да, компьютер можно научить синтезировать голос, но разобрать человеческую речь ему пока не под силу. Это потому, что в силу своей природы компьютер - вещь простая, и работает всего с двумя состояниями: «включено» и «выключено» (0 и 1). После того, как мы скомандовали компьютеру позвонить куда-нибудь, он просит об этом момед. Модем является как бы отдельным органом компьютера. Он снимает трубку, набирает номер, и привлекает к работе модулятор. Модулятор - это такая штука, которая позволяет переводить 0 и 1 в аналоговый сигнал (что-то вроде человеческого голоса), который легко можно передавать по обычной телефонной линии. Говоря языком школьного учебника физики, «изменяя во времени частоту, амплитуду и фазу, можно передавать цифровой сигнал в виде аналогового». Наверняка ты слышал, как "свистит" модем - так вот, он кодирует 0 и 1, с которыми работает компьютер. После того, как сигнал закодирован, его можно передавать по телефонной линии, на другой стороне которой должен быть установлен другой модем. Конечно, ты можешь попросить своего друга посвистеть в телефонную трубку вместо модема. Может быть, ему даже удастся установить соединение со скоростью 300 бит/с :)).

По ту сторону луны

На другом конце телефонного провода трубку снимает второй модем, и за работу берется демодулятор. Демодулятор - полная противоположность модулятору. Он слушает аналоговый сигнал (голос другого модема), и преобразует его в 0 и 1, понятные компьютеру. Для того, чтобы два момеда поняли друг друга, они должны уметь работать с одинаковыми протоколами (об этом мы поговорим чуть ниже). Но, прежде чем выбирать протокол, два модема должны договориться о скорости, на которой будет передаваться информация.

Ring

Скорость. Можно измерить количество модуляций в секунду (зачем это нам? :)) - Боды. Скорость в бодах показывает, с какой частотой модем может переключаться с одного аналогового сигнала на другой. Это не очень интересно. Гораздо интереснее – узнать, какое количество битов (один бит - это тот самый 0 или 1, понятный компьютеру) модем передает в секунду - BPS (Bits Per Second). Следовательно, чтобы два модема могли друг с другом общаться, они оба должны уметь передавать одинаковое количество BPS. Иначе, если первый модем будет работать быстрее второго, второй модем не будет успевать за первым, и карнавала не будет. При этом, за одну модуляцию модем может передать один бит, а может - сразу несколько (или даже меньше одного =)). Но для простого чайника мерить скорость в BPS слишком напряжно (ну какой чайник знает, что такое бит? :)), поэтому производители софта договорились использовать термин "символ" (character). И соответственно скорость передаваемой по модему информации решили измерять в символах в секунду, а проще - CPS (character per second). Зная скорость модема в BPS можно примерно вычислить CPS :). Если представим, что мы передаем уже заархивированные файлы (модемы тоже умеют сжимать данные, поэтому упростим работу и будем передавать архивы), то CPS будет равен: «95% от скорости в BPS разделить на 8». Например, если скорость модема - 36600 BPS, то он будет передавать примерно 4346 символов в секунду (это легко считается с помощью обычного виндовского калькулятора :)). В реальных условиях - когда на линиях помехи, и модему приходится передавать одну и туже информацию несколько раз - скорость падает. Но с другой стороны, скорость возрастает, когда информация сжимается. Из-за этого CPS может сильно меняться каждую секунду, поэтому измеряя CPS корректно брать некое среднее значение. Чем лучше линия - тем лучше CPS.


Спецвыпуск Xakep, номер #012, стр. 012-098-2, ... А связь у меня никогда не обры%^NO CARRIER, или немного о модемах

... А связь у меня никогда не обры%^NO CARRIER, или немного о модемах

Спецвыпуск Xakep, номер #012, стр. 012-098-2

Небольшое заключение: BPS - это скорость, с которой модемы общаются друг с другом, CPS - это скорость, с которой реально передаются наши данные с одного компьютера на другой. Все не так уж и сложно!

Hang up, Connect

Cо скоростью, вроде, разобрались. Уже можно соединяться. Правда, соединение будет гораздо приятнее, если заработает коррекция ошибок. Проверка передаваемой информации позволяет понять получающему модему, правильно ли он понял то, что ему пытались сказать, или это были помехи на линии. Естественно, у передающего модема есть некий орган, сжимающий информацию, а у принимающего модема - распаковщик и поверяльщик информации. На данный момент существует два наиболее популярных протокола сжатия и защиты информации: V.42bis и MNP5 (Microcom Networking Protocol уровня 5). Все современные модемы поддерживают V.42bis (на подходе V.44) и при возможности стараются его использовать. С помощью V.42bis передаваемая информация может сжиматься до четырех раз. Естественно, если мы передаем несжатую информацию (например, серфим в инете, просматривая сайты), а не качаем уже запакованные архивы. Дело в том, что алгоритмы, с помощью которых сжимается информация в протоколе V.42bis, очень похожи на используемые для сжатия в архиваторах. Но при этом протокол обладает некими интеллектуальными свойствами: видя, что информация не сжимается (уже сжата), модем может временно перестать использовать сжатие. Правда, по качеству сжатия модему, конечно, далеко до архиваторов. Ведь архиватор сжимает всю информацию сразу, а момеду приходится работать лишь с кусочками, которые отдает ему компьютер. Если принимающий модем заметил ошибку, он посылает специальный сигнал, и отправляющий повторяет тот кусочек, который был неправильно понят второй раз.


Спецвыпуск Xakep, номер #012, стр. 012-098-3, ... А связь у меня никогда не обры%^NO CARRIER, или немного о модемах

... А связь у меня никогда не обры%^NO CARRIER, или немного о модемах

Спецвыпуск Xakep, номер #012, стр. 012-098-3

CARRIER

Теперь разберемся с видами момедов. Какие они бывают, что выбрать. Первое, что бросается в глаза - модемы бывают внешние (external) и внутренние (internal). Внутренние мопеды выполнены в виде плат (ISA, PCI или AMR), и вставляются внутрь компьютера, подключаясь к системной шине. Внешние модемы выглядят как отдельная коробочка. Они подключаются к компьютеру с помощью шнурка через внешние порты (COM, USB). Какой модем выбрать - решать тебе. Чем мне не нравятся внешние модемы? Они занимают место на столе и требуют отдельного источника питания (и еще они стоят дороже :)). Но зато на внешних момедах есть лампочки «carrier detected”, “sending data” и “receiving datа” – по их активности легче определять реальное положение дел на линии связи. Со внутренними момедами часто так бывает: связь, вроде бы, есть – а реально ее уже давно нет, и линия свободна. А вот со внешними, благодаря лампочкам, такие номера не проходят – по лампочкам все видно.

Последнее время большие споры вызывают так называемые софт-модемы. Софт-модем - это девайс, некоторые функции которого (сжатие данных, проверка ошибок) выполняет не он сам (аппаратно, с помощью своего процессора), а обычная программа (драйвер).

Но софт-модемы - это еще пол - беды. Теоретически, с ними можно заставить работать любую ось, написав для нее драйвер. Гораздо хуже дело обстоит с винмодемами. Винмодем - это самое страшное творение, которое было когда-либо придумано человечеством :). Он может работать только под одной операционной системой (догадайся, с какой?). Обычно винмодемы загружают центральный процессор от 5 до 25%. Нехило, да? Короче говоря: винмодемы – для тебя, если: ты ярый поклонник виндов, у тебя отличная цифровая линия и ОЧЕНЬ мощный комп.

NO CARRIER

Вот собственно и все, что я хотел рассказать тебе о модемах. Теперь можешь пойти в компьютерный магазин, и, пристав к продавцу - консультанту, реально запарить его своими вопросами :).

Какой модем тебе все-таки выбрать домой? Могу посоветовать, если есть возможность, взять на тестирование себе несколько наиболее привлекательных девайсов, и протестировать их. Все-таки, даже на одинаковых модемах связь очень сильно зависит от качества телефонной линии....


Спецвыпуск Xakep, номер #012, стр. 012-100-1, Куда засунуть одноглазого?

Куда засунуть одноглазого?

Спецвыпуск Xakep, номер #012, стр. 012-100-1

Меньшов Кирилл aka ManU (manu@cmail.ru)

Ну, вот и пришла осень. Деревья сбрасывают старые листья, люди одевают теплую одежду, птицы летят на Юг. Некоторые хаксоры едут на Север валить лес ;). Всюду происходят изменения! Должны они произойти и в твоем железном товарище. Чуешь, куда я клоню? Нет, это не очередная статья-мануал на тему: "как сделать апгрейд"! Сейчас мы прицельно посмотрим, чем нас радует рынок вертушек для одноглазых.

Интро

Кто сейчас крутит диски в твоем компе? Тараканы? CD-ROM? Старенький 2х скоростной CD-R? Ух, перец, ну и отстал ты от жизни. Пора обновляться! Сейчас на нашем рынке ты можешь увидеть три вида дисковых накопителей (не дискеточных!): CD-ROM, CD-RW, DVD. Что касается первых - они есть у каждого, и рассказывать про них не надо. Я и не буду. А вот ДиВиДишками обладают пока немногие. Этот формат еще не очень популярен, но, по данным Cahners In-Stat Group, в 2004 году он будет занимать большую часть рынка носителей информации. Так что рано или поздно тебе придется купить дивидюк. А на сладкое я оставил... CD-RW. Эта штучка должна быть у каждого! Тем более, что за последние полгода цены на них сильно упали. Для тех, кто в танке, сообщаю: CD-RW приводы - это те, что умеют не только писать (как CD-R), но и перезаписывать.

Писалки и перезаписывалки

Сейчас на рынке пишущих CD-RW приводов рулят 3 фирмы: Teac, Ricoh и Plextor. С них и начнем.

Teac CD-516EB

Скорость записи/чтения: запись CD-RW - 10x, CD-R - 16x, чтение - 40х.

Интерфейс: IDE, PIO-Mode4.

Буфер: 2Мб.

Чтение/запись субкодов: есть.

Перепрожиг: до 89 минут.

Цена: $160.

Этот новенький агрегат от всеми любимой фирмы TEAC почти идеален по соотношению цена-качество. Отлично пишет как CD-R, так и CD-RW разных типов. Для защиты используется технология WriteProof (BurnProof), которая помогает избежать сбоев в процессе записи. Также используется фирменная технология TEAC's O.P.C. для адаптации излучения лазера. Но не все так гладко! Тик с трудом копирует защищенный диск. Да и скорость считывания явно занижена. Проблему с перепрожигом и копированием должно решить исправление прошивки.

Ricoh MP 7200A

Скорость записи/чтения: запись CD-RW - 10x, CD-R - 20x, чтение - до 40х.

Интерфейс: IDE, PIO-Mode4, UDMA2.

Буфер: 2Мб.

Чтение/запись субкодов: есть.

Перепрожиг: до 99 минут.

Цена: $240.

Один из лучших (если не лучший) привод в нашем обзоре. Начнем с того, что это первый привод с 20х скоростью записи. В нем впервые используется технология JustSpeed - перед тем, как начать писать с оптимальной скоростью, привод проверяет болванку, и проводит две контрольные записи. Используется защита буфера JustLink. Благодаря ей запись может происходить даже при сильно загруженном проце. Ricoh не только отлично пишет, но и замечательно читает - вслух и по слогам :). Недостатков почти нет (разве что трудности с копированием защищенных дисков) - хорошо продуманный и относительно дешевый привод.

PlexWriter PX-W1610A

Скорость записи/чтения: запись CD-RW - 10x, CD-R - 16x, чтение - до 40х.

Интерфейс: IDE, PIO-Mode4.

Буфер: 2Мб.


Спецвыпуск Xakep, номер #012, стр. 012-100-2, Куда засунуть одноглазого?

Куда засунуть одноглазого?

Спецвыпуск Xakep, номер #012, стр. 012-100-2

Чтение/запись субкодов: есть.

Перепрожиг: до 95 минут.

Цена: $270.

Когда я ходил по горбушке и доставал консультантов вопросами на тему самого лучшего CD-RW, большинство продавцов отвечало: "Бери Plextor, если денег много". PlexWriter PX-W1610A подтверждает высокое качество продукции этой фирмы. В нем используются все возможные способы улучшения работы. Для защиты от сбоев используется первая версия BurnProof. Для повышения качества записи впервые используется технология Powerec. Привод проверяет качество болванки, и сам подстраивает мощность. Также PlexWriter быстро и качественно читает обычные CD. Кроме субкодов поддерживает чтение из областей lead-in и lead-out. Для охлаждения привода на задней панели установлен кулер (Карлсон хренов). Одним словом, PX-W1610A продуман до мелочей. Теперь я понял, что консультанты тоже иногда бывают правы :). Единственным обидным недостатком является отсутствие UDMA-интерфейса, что сильно нагружает процессор ;(.

Так выглядит тройка лидеров, но... лидерство это непрочное. На рынке есть куча других производителей, желающих присоединиться к ним. О продукции некоторых из них я сейчас и расскажу.

Yamaha CRW2200EZ

Скорость записи/чтения: запись CD-RW - 10x, CD-R - 20x, чтение - до 40х.

Интерфейс: IDE, PIO-Mode4, UDMA33.

Буфер: 8Мб.

Чтение/запись субкодов: есть.

Перепрожиг: нет.

Цена: $220.

Первое, что бросается в глаза - это буфер. Один, но какой ;)! Причем, Yamaha не остановилась на достигнутом, и применила новую технологию - SafeBurn. Суть ее в том, что если вдруг буфера не хватает, то запись прерывается и начинается вновь после его наполнения. Но не только в буферах счастье ;). Yamaha CRW2200EZ, наравне с Ricoh MP 7200A, обладает 20х скоростью записи. К тому же, Yamaha'овский привод может менять скорость в процессе записи, чем другие похвастаться не могут. CRW2200EZ отлично читает CD-RW, но валится на обычных CD. Если бы не отсутствие перепрожига, столь малая цена выглядела бы подозрительно.

Creative RW121032E

Скорость записи/чтения: запись CD-RW - 10x, CD-R - 12x, чтение - до 32х.

Интерфейс: IDE, PIO-Mode4, UDMA2.

Буфер: 2Мб.

Чтение/запись субкодов: есть.

Перепрожиг: до 93 минут.

Цена: $110.

Ну, вот, наконец, добрались до вездесущего Creative'а. Он стоит в конце обзора и по цене и по скорости. Привод отлично пишет диски. Защиту от ошибок обеспечивает BurnProof. Тихоход отлично читает CD и CD-R. Читает все субкоды. Кроме малой скорости недостатков больше нет. Это отличная модель для бюджетников.

Готовь сани летом ...

О надвигающемся засилье DVD'шек я тебе уже намекнул. Ты, конечно, можешь сказать, что за 3 года еще многое изменится, но знать "врага" в лицо надо уже сейчас. Если же ты не хочешь ждать 2004 года, а хочешь дивидюк прямо сейчас, то помни одно: DVD-ROM - это, прежде всего, CD-ROM, и читать ты на нем будешь в основном обычные CD. Поехали...

Samsung SD-612S

Скорость чтения CD/DVD: 40x/12х.

Объем кэш-памяти: 512 КБ.

Интерфейс: Ultra-ATA/33.

Цена: $60.

Очень шустрый привод. Одинаково хорошо читает как CD, так и DVD-диски. Меня поразило очень малое время доступа (88мс). И, несмотря на внушительную скорость, привод работает очень тихо и почти не вибрирует. Это прикольно: если вздумаешь глянуть фильм на DVD, шум разогнавшегося донельзя диска не будет заглушать звуки из колонок :).


Спецвыпуск Xakep, номер #012, стр. 012-100-3, Куда засунуть одноглазого?

Куда засунуть одноглазого?

Спецвыпуск Xakep, номер #012, стр. 012-100-3

Creative DVD1241E

Скорость чтения CD/DVD: 40x/12х.

Объем кэш-памяти: 512 КБ.

Интерфейс: IDE PIO.

Цена: $80.

Кому, как не Creative'у, делать DVDюки? Эта модель легко и быстро справляется с DVD-дисками (иногда даже превышая паспортные данные). Не создают ему проблем и обычные CD. А вот время допуска - хромает (108мс). За те деньги, которые Creative просит за свой привод, можно найти что-нибудь получше. А вот если бабки для тебя не главное... то высылай их мне, а :)?

Toshiba SD-M1502

Скорость чтения CD/DVD: 48x/16х.

Объем кэш-памяти: 128 КБ.

Интерфейс: Ultra-ATA.

Цена: $90.

Если модель от Samsungа была просто шустрой, то эта модель от Toshiba – мега - скоростная. Это самый быстрый и самый дорогой привод в моем обзоре. Но – только судя по надписям на коробках. А в реальности 40-скоростной привод от Samsung крутит сидюки быстрее, чем якобы 48-скоростной Toshiba. Но зато этот привод нехило уделывает самсунг при работе с DVD. Из-за высокой скорости его немного слышно, но при проигрывании DVD-фильмов скорость автоматически снижается.

Sony DDU1211

Скорость чтения CD/DVD: 40x/12х.

Объем кэш-памяти: 512 КБ.

Интерфейс: Ultra-ATA.

Цена: $80.

Сониковский привод отлично работает с CD - скорость чтения обычного диска явно превышает паспортные данные. Но - привод долго возится с диском перед тем, как его распознать. Еще его подводит звукоизоляция - спокойно посмотреть любимый фильм или порезаться в игрушку не удастся. А о начале работы устройства все твои домочадцы смогут узнать по вибрирующему полу и качающейся люстре :).

Выводы

Я надеюсь, что смог показать тебе ситуацию на рынке CD-RW-DVD приводов. Если ты собрался покупать новый сидюк - подкопи деньжат и возьми хороший CD-RW. А если ты взял себе хороший CD-RW, то помни, что лучше не надо крутить в нем обычные диски, иначе долго он у тебя не проживет. Про DVD пока говорить рано, но если есть деньги - почему бы не взять его сейчас? Представь, как классно посмаковать самые драйвные отрывки "Матрицы" в DVD-качестве, да еще и с субтитрами для твоих глухих бабушек и дедушек ;)... Все, конец, пишите письма!


Спецвыпуск Xakep, номер #012, стр. 012-102-1, Какой сканер тебе нужен? Устройство сканера.

Какой сканер тебе нужен? Устройство сканера.

Спецвыпуск Xakep, номер #012, стр. 012-102-1

Андрей Каролик (andrusha@sl.ru; http://www.dal.net.ru)

В твою голову наверняка уже не раз приходила мысль о покупке одной весьма полезной железяки – сканера. Раньше такой девайс стоил совсем немало денег, выбор был невелик, а возможности самого агрегата не слишком радовали (качественные результаты давали только сканеры профессиональных серий, сделанные специально для типографий и дизайнерских контор - там цены были еще на порядок выше). К тому же, для поддержания конкурентоспособности своего продукта все производители выкидывали в продажу множество разных моделей с недоделанным (или не до конца протестированным) софтом. Порой хромала совместимость железа и сканера. Кто покупал такие устройства в те далекие времена - наверняка наступал на подобные грабли. Сейчас ситуация совсем другая. Появилось много новых фирм, выпускающих эти девайсы. Из-за конкуренции цены упали практически ниже пояса :). И, придя в магазин, тебе не приходится выбирать между всего двумя-тремя моделями - их уже несколько десятков. В общем, есть где развернуться. Более того – теперь, чтобы продать свой продукт, фирмы-производители вынуждены больше обращать внимания на качество механики, софт сканеров и совместимость с другими железками. К тому же, устаревшие модели очень быстро снимают с производства, выпуская доработанные, исправленные и улучшенные. Так что шансов купить совсем сырой или просто неработающий девайс у тебя практически нет. Но все-таки: перед тем, как идти в магазин за сканером, прочти эту статью. Из нее ты узнаешь принцип работы любого сканера, а также плюсы, минусы и нюансы работы разных моделей. И самое главное - ты поймешь, что искать и на что ориентироваться. Тебе останется только определиться, из какого ценового диапазона купить модель, а дальше - статью в зубы и трусцой в компьютерный магазин :).

Зачем он вообще нужен?

Резонный вопрос - особенно для тех, кто никогда его не использовал. Этот девайс позволяет переносить на компьютер изображения и текст с любой печатной продукции. Размер ограничивается только форматом сканера. Где это можно использовать? Да практически на каждом шагу! Для дублирования важных документов, для сканирования и распознавания текста с последующей правкой его на компьютере, для создания собственной электронной фотогалереи, для подготовки к пересылке любых материалов в электронном виде по сети - и так далее. Могу сказать одно: те, у кого сейчас сканер есть, без него работать уже не смогут и будут вынуждены переселиться жить к соседу. Или к соседке – лишь бы у нее был столь нужный девайс.

Как устроен сканер?

Современный сканер функционально состоит из двух частей: сканирующего механизма (engine) и программной части (TWAIN-модуля). В процессе покупки часто забывают о том, что без собственного драйвера девайс работать не сможет, так как он не является стандартным устройством. И универсальных драйверов в окошках, как для видеокарт, для сканеров нет. Наличие или отсутствие функциональных возможностей каждого конкретного агрегата полностью зависит от прилагаемого к нему софта. Прежде чем рассказать тебе о механизме сканера, скажу, что вообще девайсов существует несколько видов: ручные, протяжные и планшетные. Но рассматривать стоит только последние - планшетные. Ручные были популярны только в те времена, когда планшетные стоили бешеных денег. Но они не позволяли сканировать целый лист за один проход, давали очень низкое качество, а результат их работы сильно зависил от плавности и точности твоих движений – что, как понимаешь, связано с определенными трудностями (после ящика пива-то)... Протяжные сканеры для своего времени стали шагом вперед. Они начали применяться тогда, когда пространство около компьютера было важнее, чем качество сканирования. Некоторые модели встраивались в клавиатуру! Они уже умели сканировать лист за один проход, но были очень непрактичными в работе, да и делали все очень медленно. А еще у них были проблемы, аналогичные принтерным: перекос штанги и, как следствие, - кривое сканирование, износ протяжных валиков, прочая фигня. Как только планшетные сканеры сравнялись в цене с протяжными и стали падать дальше - про них забыли забыли, как и про ручные. Впрочем, купить ручные и протяжные сканеры сейчас можно скорее в музеях, чем в компьютерных магазинах :).


Спецвыпуск Xakep, номер #012, стр. 012-102-2, Какой сканер тебе нужен? Устройство сканера.

Какой сканер тебе нужен? Устройство сканера.

Спецвыпуск Xakep, номер #012, стр. 012-102-2

Механизм планшетного сканера

Сканируемый объект размещается на прозрачном неподвижном стекле, вдоль которого передвигается сканирующая каретка с источником света. Если сканируется прозрачный оригинал, то используется так называемый слайд-модуль - крышка, в которой параллельно сканирующей каретке сканера перемещается вторая лампа. Оптическая система сканера состоит из объектива и зеркал или призмы. Она проецирует световой поток от сканируемого оригинала на приемный элемент, осуществляющий разделение информации о цветах - три параллельных линейки из равного числа отдельных светочувствительных элементов. Еще есть трехпроходные сканеры, в которых используются лампы разных цветов или же меняющиеся светофильтры на лампе. Приемный элемент преобразует уровень освещенности в уровень напряжения - все еще аналоговую информацию. После коррекции и обработки фильтрами аналоговый сигнал поступает на аналого-цифровой преобразователь (АЦП). С АЦП информация выходит уже в двоичном коде, и после обработки в контроллере сканера через интерфейс с компьютером поступает на драйвер сканера - обычно это так называемый TWAIN-модуль, с которым уже и взаимодействуют прикладные программы. Кстати, при импортировании в тот же фотошоп ты выбираешь в меню в качестве источника именно TWAIN.

Источник света

В старых моделях стоит обычная флуоресцентная лампа. Недостаток - слабая стабильность характеристик освещения и ограниченный срок службы. В современных моделях - лампа с холодным катодом, имеющая лучшие параметры и значительно больший срок службы. Причем лампа тоже влияет на результат сканирования: при изменении характеристик источника освещения изменяется падающий на принимающую матрицу световой поток, несущий информацию о сканируемом оригинале. Если свойства лампы сильно изменяются - говорить о правильной цветопередаче сканера уже не имеет смысла. Вообще, характеристики светового потока меняются даже при прогреве сканера, но это время мало и составляет несколько секунд. А вот конструкции с тремя раздельными лампами разных цветов в этом смысле меня настораживают - ведь каждая лампа может терять свои характеристики по-своему. Качество лампы прямо в магазине оценить сложно. Но убедись хотя бы, что используется лампа с холодным катодом. Сканеры, ориентированные на профессиональную работу с цветом, помимо встроенной процедуры автоматической калибровки по интенсивности светового потока от лампы содержат еще и схемы поддержания стабильности светового потока при изменении рабочей температуры сканера.


Спецвыпуск Xakep, номер #012, стр. 012-102-3, Какой сканер тебе нужен? Устройство сканера.

Какой сканер тебе нужен? Устройство сканера.

Спецвыпуск Xakep, номер #012, стр. 012-102-3

Оптическая система (матрица)

Световой поток от оригинала проецируется на матрицу CCD, которая преобразует его в электрический сигнал. Обычно используется один фокусирующий объектив (или линза), который проецирует полную ширину области сканирования на полную ширину матрицы CCD. Требования к качеству оптики для такой задачи весьма высоки, особенно сложно обеспечить приемлемое качество проецирования краев рабочей области для цветных оригиналов. Оценить качество фокусировки и разрешающую способность оптики легко даже визуально при сканировании специальной тестовой мишени или защищенных участков любой денежки. В наиболее продвинутых (ака усиленных) моделях планшетных сканеров встречаются сменные объективы: при работе в обычном режиме оптика работает аналогично однолинзовым механизмам, а при переключении на второй (усиленный) режим используется другой объектив, который проецирует на полную ширину CCD-матрицы только часть ширины рабочего стола сканера. Это удобно для предварительного сканирования всего рабочего стола, с последующим усиленным сканированием выбранной области. Таким образом, на постоянное число приемных ячеек CCD-матрицы проецируется участок меньшей ширины и соответственно возрастает оптическое разрешение. Обычно в документации указано число ячеек CCD-матрицы. К примеру, матрицы 42-битных сканеров имеют 10600 ячеек. В однопроходных сканерах матрица имеет три параллельные линейки приемных ячеек - по одной на цвет, поэтому указывается число элементов только в одной. Поделив число ячеек на ширину поля сканирования, ты получишь оптическое разрешение сканера.

Разрешение

Вообще-то, разрешений у любого сканера целых три: оптическое, механическое и интерполяционное. Так что, увидев в рекламе супер-разрешение нового девайса, не торопись выкладывать за него бабки - сначала узнай, которое имеется в виду. Часто в рекламных целях называют наибольшее. Итак, разрешение может быть оптическим: количество элементов в линии матрицы, поделенное на ширину рабочей области. Определяется матрицей и шириной рабочей зоны. Это - меньшая из всех приводимых цифр разрешения (иногда и вовсе не приводится). Есть еще механическое разрешение: количество раз считывания информации CCD-матрицей, поделенное на длину пути, пройденного за это время сканирующей кареткой. Ты наверное видел, как при сканировании большой области с большим разрешением сканер делает короткие остановки, создавая эффект прерывистой работы. Иногда механическое разрешение тоже называют оптическим, но на самом деле это неверно. Как правило, механическое разрешение задается изготовителем в два раза больше оптического (иногда - равным ему, или в 4 раза большим). При этом, поскольку CCD-матрица не может сканировать с разрешением выше оптического, недостающие по ширине точки рассчитываются (интерполируются). Интерполяция же не только не дает никакого повышения качества при сканировании полноцветных оригиналов, но может даже ухудшить четкость и заметно снизить скорость работы. Ну, и интерполяционное разрешение: произвольно выбранное разрешение, до которого программа сканера якобы берется сама рассчитать недостающие точки. Ценность величины этого показателя сомнительна, и он не имеет вообще никакого отношения к механизму сканера. Зато именно этот параметр чаще всего фирмы-производители указывают в рекламных проспектах, чтобы наловить лошков. Цветное изображение лучше сканировать всегда без интерполяции с разрешением, равным оптическому. Если же потребуется масштабирование, то это можно сделать в графических редакторах - к примеру, в том же горячо любимом фотошопе.


Спецвыпуск Xakep, номер #012, стр. 012-102-4, Какой сканер тебе нужен? Устройство сканера.

Какой сканер тебе нужен? Устройство сканера.

Спецвыпуск Xakep, номер #012, стр. 012-102-4

Количество бит на цвет (глубина цвета или разрядность)

Обычное количество двоичной информации о цвете - 24 бита на каждую точку, то есть, по 8 бит на каждый из основных цветов RGB. Это дает свыше 16 млн. вариантов цвета этой точки. Более тонкие оттенки глаз не различает, да и устройства вывода обычно не воспроизводят. Вопрос – зачем же выпускаются 48-битные сканеры? Дело в том, что CCD-матрица в сканерах более высокой разрядности обычно более чувствительна и имеет меньший собственный шум, аналого-цифровой преобразователь качественнее и тоже меньше фонит, и все прочее тоже на уровне. К тому же, на каждом этапе преобразования информации - при гамма-коррекции, работе программы цветосинхронизации, обработке изображения в графическом редакторе, цветоделении при выводе на печать - младшие разряды теряют полезную информацию. То есть, сканеру необходимо сканировать с избыточной разрядностью, чтобы избежать влияния погрешностей и шумов.

Приемный элемент - CCD-матрица

Это один из важнейших узлов, влияющих на качество сканирования. Приводимая в документации характеристика - число элементов на линию (на цвет). Число элементов, поделенное на ширину рабочей зоны сканера, и есть оптическое разрешение – об этом, впрочем, мы уже говорили. Кроме этого параметра матрица имеет еще несколько очень важных характеристик:

- Уровень шума - ограничивает динамический диапазон и реальную разрядность.

- Разброс чувствительности от ячейки к ячейке - даже если в сканере и предусмотрена калибровка, то она выполняется по усредненным значениям с нескольких ячеек.

- Уровень перекрестных помех - здесь сказывается влияние ячеек друг на друга, которое производители стараются сделать минимальным.

- Совмещение цветов - в однопроходных сканерах цвета разделяются на три линейки CCD-матрицы: соответственно, требуется их последующее совмещение.


Спецвыпуск Xakep, номер #012, стр. 012-102-5, Какой сканер тебе нужен? Устройство сканера.

Какой сканер тебе нужен? Устройство сканера.

Спецвыпуск Xakep, номер #012, стр. 012-102-5

Контроллер сканера

Контроллер оказывает огромное влияние на скорость работы сканера и точность цветопередачи. Интерфейс контроллера может быть разным: SCSI, LPT и PCMCIA. Если ты собираешься купить сканер с интерфейсом SCSI и использовать его не с поставляемой в комплекте картой, то учти, что совместимость обычно случается только с контроллерами Adaptec. Все остальные варианты могут принести проблемы. Порой лучше жить с ISA, чем с не-Adaptec для SCSI. Размер буфера данных в SCSI-моделях варьируется от 64кБ до 3МБ, иногда бывает и больше. При интерфейсе LPT и его вариантах (с поддержкой EPP или Bi-Directional) сканеру может быть необходимо наличие одного из скоростных вариантов параллельного порта. Если EPP обычно есть всегда, то 8-бит Bi-Directional реализован не везде. Интерфейс PCMCIA (PC CARD) предназначен для подключения сканеров к ноутбукам. Не могу ничего сказать о проблемах, так как мало кто использует подобную схему работы. Узнать, понимаешь, не от кого =).

Софт

Современные программы, работающие под Windows, общаются со сканером через специальную программу - TWAIN-модуль, которая идет в комплекте со сканером (на Macintosh, кстати, модуль сканирования выполняется как Plug-In для Photoshop). Иногда возникают проблемы совместимости TWAIN-модуля сканера с некоторыми операционными системами, и при переходе на новую ось тебе могут понадобиться новые дрова.

Как же выбирать сканер?

Ответ неожиданно прост - под поставленную задачу. Попробуй сформулировать - как будет использоваться отсканированное изображение? Какими программами оно будет обрабатываться? На какие устройства выводиться? Какие требования предъявляются к качеству изображения? Какая операционная система будет использоваться на компьютере? К какому интерфейсу должен подключаться сканер? Если ты собираешься сканировать полноцветные изображения и затем печатать их - ищи сканер, предназначенный для издательской и дизайнерской работы. Для того, чтобы помещать цветные оригиналы на WEB в 256 цветах, высокое разрешение и большой динамический диапазон ни к чему, а вот стабильно работающий TWAIN-модуль и хороший фильтр - потребуются. Перед покупкой советую визуально оценить качество сканирования. Стоит проверить способность различать мелкие детали - например, концентрические линии и мелкий текст на банкноте. Правда, проверить правильность цветопередачи на незнакомом компьютере представляется малореальным =), особенно учитывая возможные искажения, вносимые неправильно настроенными системами цветосинхронизации сканера, графического редактора или операционной системы. Учитывай эти нюансы, проси настроить монитор, сканер - а образец для сканирования можешь принести свой (голую фото-тетку). Сразу отсеивай модели от относительно небольших фирм, предлагающих сканеры с гарантией менее двух-трех лет. Дело в том, что через год им может надоесть торговать сканерами, а заодно и поддерживать уже проданные =). Запомни, что без стабильно работающего драйвера (TWAIN-модуля) сканер не может быть использован по своему прямому назначению, им останется только орехи колоть. Прикрутить же к нему драйвер другого сканера не удастся, а в комплекте поставки Windows родных дров для таких устройств тоже нет. Можно попытаться взять их у владельца точно такого же агрегата. Обязательно узнай, как дружат родные драйвера с русскоязычными программами (OCR). Индикатор качества техники - пластмасса. Пока что мне не встречалась нормальная техника в корпусе из совсем плохой пластмассы ;). Разрешение? Индивидуально. Для сканирования и распознавания текста наилучшим образом подойдет 200 точек на дюйм для крупного и среднего начертания букв, и 300 точек на дюйм для мелкого текста. Для просмотра отсканированных изображений на мониторе тебе будет достаточно разрешения сканера 100 точек на дюйм, а для печати на принтере с небольшим увеличением уже потребуется 350 точек на дюйм.


Спецвыпуск Xakep, номер #012, стр. 012-102-6, Какой сканер тебе нужен? Устройство сканера.

Какой сканер тебе нужен? Устройство сканера.

Спецвыпуск Xakep, номер #012, стр. 012-102-6

Вот и все рекомендации, собственно. Выбирай, сканируй, присылай мне свои фотки. А лучше – фотки твоих подружек. Разрешение подберешь сам, ладно?


Спецвыпуск Xakep, номер #012, стр. 012-105-1, СПЕЦ-CREW НАСИЛУЕТ ВИРТУАЛЬНУЮ РЕАЛЬНОСТЬ

СПЕЦ-CREW НАСИЛУЕТ ВИРТУАЛЬНУЮ РЕАЛЬНОСТЬ

n0ah (noah@real.xakep.ru)

Спецвыпуск Xakep, номер #012, стр. 012-105-1

Когда я говорю "шлем виртуальной реальности" - вспоминаю VFX-1. Эх, какие были времена, и в какие классные игрушки можно было с ним погонять! Doom, MechWarrior2, Hexen, Heretic... Сплошная ностальгия :). Хоть разрешение и было хреноватым - с шлемом все равно играть было интереснее, чем с монитором. Не, ну если там гаматься по сети с друганами, то понятно: в шлеме тебя уделают во все места - тут, конечно, мониторы рулят. Но для получения простого удовольствия от любимой игрухи VFX-1 был просто идеален. Короче, хороший был девайс, и мы в Х по нему даже немного скучаем :). Сейчас VFX-1 на Mitin0-BazaR можно ухапать всего за каких-нибудь 400 рублей. Нет, приятель, я не опечатался: не 400 гринов, а именно 400 отечественных рублей!

Но VFX-1 - это уже прошлое, а сегодня в наши потные руки попал совсем свеженький девайс - InterSense X2 I-Glasses VR Headset. Вот это вот "VR Headset" расшифровывается как Virtual Reality Headset, что в переводе на русский означает "шлем виртуальной реальности". Звучит заманчиво, не правда ли? Что еще звучит не менее заманчиво - так это то, что стоит сия штучка около 1300 букузоидов ;). Ок-ок, прекращаю томить тебя ожиданием - давай лучше вскроем коробку и посмотрим, что там внутри.

КОПЛЕКТ

А в комплекте с шлемом у нас поставляются: сам шлем, адаптер для питания из электросети, два провода для соединения шлема с источником видеосигнала и один провод-переходник с "тюльпанов" на стандартный видеовход европейских моделей видеомафонов (такой длинненький, с штырьками). Шлем похож на большие очки, крепящиеся на затылке резинкой. Перед глазами установлена пара мониторов, над бровью несколько кнопок, по бокам - наушники.

Ну, адаптер и переходник описывать без мазы, а вот провода – можно =). Значит так: сей шлем работает от всего, что в состоянии выдавать на выход видеосигнал (телек, видак, ДВД-проигрыватель, некоторые видекарты), поэтому его провода с одной стороны втыкаются в него самого, а с другой заканчиваются коннектором для питания (сюда пихается конец от адаптера) и тремя "тюльпанами" (два на звук - левый/правый - и один на изображение).

У второго провода "тюльпан" изображения заменен на другой штырек, соответствующий выходу некоторых видеокарт.

Смотри, что следует из простейшего, но тщательного изучения только проводов соединения: можно сделать вывод, что для того, чтобы подключить такой шлем к компу и понаслаждаться любимой игрой, необходимо иметь в своем компе видюху с видеовыходом на тюльпан, или на тот самый штекер, который на втором проводе, да еще и звуковуху с левым и правым выходами на тюльпаны (этот вопрос, впрочем, решается покупкой шнурка на Митино за 25 рублей).

Поковыряв коробку еще, мы обнаружили, что отсутствует инструкция. Жаль, конечно, но хрен с ней - попытаемся разобраться без нее. Через тридцать минут таких разборок мы поняли, что в комплекте отсутствует еще один очень важный компонент - трекер. Это такой девайс, который улавливает движение головы и передает его в комп, чтоб тот мог просчитать и выслать изменившуюся с учетом этих движений картинку на мониторчики шлема. Нужно это для того, чтоб ты поворачивал голову, и твой герой в игрушке делал то же самое. У большинства нормальных шлемов трекер уже встроен в тело девайса, но у нашего подопытного его не было ни внутри, ни снаружи. Ок, это мы тоже переживем - обойдемся как-нибудь мышкой, привыкшие :-/. Тут мы усекли, что пора уже начать тестирование шлема, а то весь энтузиазм, подогретый внушительным видом и ценой девайса, очень скоро угаснет под напором мелких разочарований.


Спецвыпуск Xakep, номер #012, стр. 012-105-2, СПЕЦ-CREW НАСИЛУЕТ ВИРТУАЛЬНУЮ РЕАЛЬНОСТЬ

СПЕЦ-CREW НАСИЛУЕТ ВИРТУАЛЬНУЮ РЕАЛЬНОСТЬ

n0ah (noah@real.xakep.ru)

Спецвыпуск Xakep, номер #012, стр. 012-105-2

Проба

Первым делом подрубаем шлем к видаку, так как это проще всего ;). Подключили, впихнули кассету, напялили шлем на голову, включили, иииИИИИИ!.. И ничего особенного не произошло: объемное кино не возникло из ниоткуда, ощущение того, что ты находишься в комнате, не пропало. Нет даже эффекта кинотеатра. Просто чувствуешь себя суперменом, сидящим с надетой на голову железкой, которая банально придерживает два маленьких монитора перед глазами. И все. При этом изображение перед глазами черно-белое, прилично пикселизированное, и явно очень среднего качества. Что за дела? Что мы не так сделали? Ээээх, разрешения шлему явно не хватило. Ладно: допустим, с видаком мы что-то не разобрали (хотя там нечего разбирать), но с компом-то шлем должен работать нормально!!!

Попробовали. Ну, что тут сказать: это вам не видак. Когда в игре начинается экшен, даже без трекера перемещаться и воевать очень прикольно. Хотя, ощущения от уже упомянутого нами VFX-1 были как-то ярче. Да, сто пудов: дело в отсутствии трекера, и ничего здесь не сделаешь – без него девайс превращается в обычные очки-мониторы =(. Мы рубались в игруху «Hitman: codename 47», и ты можешь посмотреть фотку, сделанную с одного из мониторчиков шлема. Конечно, экшен затягивает – но глаза через десять минут игры просто вываливаются, мама дорогая! Впрочем, это с непривычки. Но как же не хватает трекера!

Резюме

В конце концов, наигравшись вдоволь и отпав на спинку дивана, мы задумались. С одной стороны – затягивает. С другой – глаза болят. Трекера нет – плохо. А вот если б он был...

Если б он был – уверен, про VFX-1 мы бы забыли раз и навсегда. Разница в качестве изображения (а конкретно – в разрешении изображения) – серьезная. Так что, деньги имеющим такую игрушку приобрести можно. Но только... только с трекером в комплекте :0).

Редакция выражает благодарность компании "Мультимедиа Клуб" за предоставленный на растерзание девайс.


Спецвыпуск Xakep, номер #012, стр. 012-108-1, Ржавые паги: обзор сайтов по железу

Ржавые паги: обзор сайтов по железу

d00d13 (d00d13@mail.ru)

Спецвыпуск Xakep, номер #012, стр. 012-108-1

Наступают моменты, когда появляются деньги на покупку очередной железячки-безделушки или для проведения глобального апгрейда своей машины. Это, конечно, хорошо и замечательно. Но, например, если у тебя появилось желание приобрести новую материнскую плату с процессором, то сразу может возникнуть и другой вопрос: а что лучше взять - Asus или Chaintech, Intel Pentium или AMD Athlon? Естественно, если ты гуру по железу, то никаких сомнений у тебя не возникнет, но новички могут запутаться и взять за приличные деньги какой-нибудь слив.

Во избежание этой ошибки создали специальные сайты, полностью посвященные hardware. Я же в данной статье проведу тебя по страницам разных вэб-серверов, расскажу, что на них есть полезного и информативного. А дальше ты сам выберешь, что тебе по душе, а что по барабану :).

iXBT.com

http://www.ixbt.com

Нелегко будет найти человека из сети, который не слышал бы про этот сайт. Да что тут говорить - это, наверное, самый популярный ресурс в своем роде. Что сразу кидается в глаза - так это классный дизайн. Начиная изучать сайт, понимаешь, что одним красивым дизайном дело не кончается. Здесь просто море полезной информации: ежедневные новости из мира производителей "железа", интересные статьи, постоянные обзоры и сравнения новых устройств в лаборатории iXBT и самое главное - тематическое описание всех частей компьютера (процессоры, системные платы, видеосистема, мультимедиа, носители информации).

Как и подобает многим крупным сайтам, здесь присутствует конференция. Не просто маленький форум, а ОЧЕНЬ большая конфа. Для примера: на день написания статьи было зарегистрировано около 16 тысяч пользователей, а количество сообщений уже давно превысило миллион. Интернет - юзверя ведут обсуждения обо всем: начиная с обычного flame'а и заканчивая серьезными рассуждения о написания собственных драйверов. Тебе случайно не нужен драйвер для флопаря?

Приятным дополнением оказался еще один проект iXBT: Komok.com - компьютерная барахолка. Это сайт, специально созданный для продажи и покупки комплектующих. Вот что они говорят о себе: "Здесь Вы можете разместить объявления о покупке или продаже компьютеров, комплектующих, расходных материалов...". И здесь реально можно что-то продать и купить! Я на этом сайте продал свою древнюю видеокарту Diamond Stealth 3D 2000 ;).

Если ты являешься фаном этого сайта, то его создатели предлагают купить у них фирменную футболку с логотипом iXBT. Я бы и сам с удовольствием купил ее, но цена... Как-то жалко отдавать за одну футболку 12,5 долларов.

Итого:

Просто гигантский проект от Rambler.ru. Если нужна информация о какой-нибудь новинке, то можешь смело заходить сюда - скорее всего, здесь уже есть описание нужной тебе вещички.

3DNews

http://www.3dnews.ru

"3DNews - Daily Digital Digest" - еще один портал вроде iXBT.com. Весь сайт напичкан кучей полезной информации, от которой просто глаза на лоб лезут... Сервер разделен на 4 тематических раздела: новости, обзоры, файлы, конференция.

В новостях, как и должно быть, находится самая свежая информация о железе. Особенно интересно читать "Дайджест за неделю", учитывая, что многие новости пишут в юмористическом стиле. В обзорах сосредоточена основная часть сайта - описания компьютерного оборудования (видео, мультимедиа, процессоры, периферийное оборудование, сеть). Написаны они грамотным русским языком, так что изучать эту информацию приятно и интересно. Что меня обрадовало - так это сколько силенок уделено разделу Games. Видимо, создатели сайта очень любят играться. Это не удивительно, ведь все мы в душе геймеры -).


Спецвыпуск Xakep, номер #012, стр. 012-108-2, Ржавые паги: обзор сайтов по железу

Ржавые паги: обзор сайтов по железу

d00d13 (d00d13@mail.ru)

Спецвыпуск Xakep, номер #012, стр. 012-108-2

В разделе «файлы» можно скачать драйвера, различные утилиты, тесты, патчи и демо-версии игр. Драйвера на сайте, честно говоря, не особо выделяются своим количеством, так что их лучше качать с официальных ресурсов производителей твоего железа. А вот в утилитах есть много полезного: это и разнообразный софт для разгона твоего компа, и программы для оптимизации системы.

Для форума команда 3DNews выделила целый сайт 3dclub.ru, вот его разделы: железо, 3DNews, флейм, игры, проблемы, новости. Особенно нравится заголовок флейма - "Флеймите на здоровье... Не модерируемо". Жаль, что вот интересного там почти ничего нету :(. Самые прогрессивные обсуждения идут в Железе – но, надо признать, что объем этого форума гораздо меньше, чем у iXBT.

Итого:

Очень хороший сайт, где есть множество полезной информации, а также неплохой архив программ для hardware.

FCENTER.Ru

http://www.fcenter.ru

Крупный сайт, где можно почитать интересные новости из мира Hardware. Очень понравился раздел "Статьи, обзоры". Объем этой категории просто поражает: такое ощущение, что здесь есть описание любого оборудования, которое когда-либо появлялось на нашей голубой планете :). Сюда также залита стандартная информация о комповых составляющих, и статьи об операционных системах и играх (кстати, складывается впечатление, что структура сайта заимствована с 3DNews.Ru =))

Также на сервере установлена конференция (стандартный Ultimate Board :)). Ее стоит почитать - иногда там попадается действительно полезная информация. А так - довольно обычная борда...

"Техническое описание" - вот этот ссылкин мне понравился больше всего. Например, тебе необходимо узнать скорость работы твоей видеокарты, выяснить ее максимальное разрешение и поддерживаемые интерфейсы... Вот, этот раздел - твое спасение. Тебе просто придется кликнуть пару раз по ссылкам - и нужная информация с быстротой "Скорой помощи" (то есть, где-то через час :)) появится в удобном окне.

Итого:

Еще один крупный проект с морем полезной информации. Только дизайн хромает на обе ножки :).

AKI.RU

http://www.aki.ru

Очередным сайтом, который попался моему браузеру, оказался AKI.RU "Актуальная Компьютерная Информация". Сервер как сервер - правда, с довольно низким уровнем посещаемости (около 1500 посетителей в день) и убогим дизайном. Но это вполне компенсируется количеством инфы. Сами железные новости собраны по принципу "с мира по нитке..." - вся информация содрана с чужих сайтов. Создатели этого ресурса - настолько ленивые перцы, что даже не размещают некоторую инфу у себя на серваке, а просто лепят ссылки на другие сервера. Халявщики, однако :). Но шутки - шутками, а свои копирайты ребята блюдут: мол, "копирование и размещение материалов на других сайтах не допускается", и все такое. Интересное заявление - учитывая, что у них вообще практически отсутствует свой собственный материал ;).


Спецвыпуск Xakep, номер #012, стр. 012-108-3, Ржавые паги: обзор сайтов по железу

Ржавые паги: обзор сайтов по железу

d00d13 (d00d13@mail.ru)

Спецвыпуск Xakep, номер #012, стр. 012-108-3

Итого:

Если лень бегать по сайтам в поисках нужной информации - можно зайти сюда: работу по сбору материала с других серверов AKI.RU сделала за тебя :).

HardwarePortal.Ru

http://www.hardwareportal.ru

HardWare портал - сильное название, что тут скажешь :). Но, конечно, до таких гигантов, как iXBT.com и 3DNews.Ru ему далеко.

Структура сервера самая обычная: новости, статьи, файлы, форум. В статьях попадаются интересные материалы, но, в общем, ничего принципиально нового или необыкновенного тут нет.

В разделе «файлы» можно скачать драйвера для видеокарточек, материнских плат, звуковых карт... Количество дров, правда, оставляет желать лучшего, поэтому не стоит искать здесь «драйвер грязных носков v.1.24» ;).

Имеется тут и форум - пока, видимо, для приличия, так как посетители этого ресурса не особо активно обсуждают различные темы, и как-то вяло флеймят.

Итого:

Средненький сайт с обычным дизайном и контентом. Что еще сказать? Пусть живет и процветает. Разрешаю :).

Компьютерная столица Fe

http://tech.stolica.ru

Очередной сайт, посвященный железу. Почему в заголовке сказано, что он является компьютерной столицей - непонятно. Видимо, самооценка местных криэйторов несколько "занижена" :).

Изучаем дальше, чего предлагает нам "Столица Фэ": на главной странице размещена полоса новостей о свежих поступлениях, сбоку (непонятно для чего) вывешена информация о текущей погоде – причем, почему-то, в Гонконге и США. С понтом, мол, "у нас тут инфы куча!", и все такое.

Очень порадовал раздел «Глоссарий», хотя его можно обозвать просто «переводчик английских компьютерных слов». Я попробовал разыскать объяснение слова monitor или display, но не нашел. Наверное, эти слова, скорее, из области сантехники. Зато обнаружил, что же обозначает DHCP :). В остальном, сайт ничем не отличается от других хардварных серверов, но посетить "Компьютерную столицу Фу" можно... Так, для общего развития.

Итого:

Среднестатистический сайт о среднепотолочном железе. Довольно много информации, но заметно, что проект еще очень свежий. Главное - чтобы не скис.

nvWorld.Ru

http://www.nvworld.ru

Если ты являешься счастливым обладателем видеокарты от nVidia, то тебе стоит посетить их сайт, который так и называется - "Мир nVidia". Здесь можно почитать информацию обо всех новинках этой компании, скачать драйвера, изучить статьи.

И обзоры. В одноименном разделе можно узнать, как правильно разгонять видеокарты на чипсете nVidia (правда, не пишут, как правильно загонять). Еще можно просмотреть результаты тестирования скорости работы видеокарт. После этого начинаешь понимать, что nVidia GeForce 3 - это хорошая видеокарта, а все остальное просто слив. А еще я здесь обнаружил даже описание установки драйверов под Linux. Респект!


Спецвыпуск Xakep, номер #012, стр. 012-108-4, Ржавые паги: обзор сайтов по железу

Ржавые паги: обзор сайтов по железу

d00d13 (d00d13@mail.ru)

Спецвыпуск Xakep, номер #012, стр. 012-108-4

В "Драйверах и утилитах" собраны почти все дрова, которые могут иметь хоть малейшее отношение к продукции nVidia: драйверы от nVidia, утилиты для разгона, редакторы ключей реестра, утилиты для перепрошивки BIOS, Glide wrappers (эмулирование драйверов Glide).

Если у тебя возникли какие-то проблемы с установкой или настройки видеокарты, то бегом в FAQ или в форум. Скорее всего, твою проблему уже обсосали со всех сторон!

Итого:

Отлично! Мекка для владельцев продукции nVidia. Всем срочно совершить хадж к черному камню GeForce3.

Tuner.iXBT.com

http://tuner.ixbt.com

Если у тебя ТВ-тюнер и квадратная голова по форме телека - зайди на сайт tuner.ixbt.com. На этом серванте лежат описания почти всех известных карточек, так что стоит их почитать, если ты намылился прикупить этот девайс. Можно скачать различные программы для просмотра телевидения. Например, здесь я нашел информацию о программе Borg-TV, с помощью которой можно расшифровывать кодированное изображение. Это просто наиполезнейшая фича для счастливых абонентов сети КОМКОР-ТВ. Как известно, это компания предоставляет услуги спутникового телевидения. Они, естественно, платные. Borg-TV является программой для просмотра ТВ, и, в тоже время, может декодировать изображение. Наташа уже раздвинула ножки, поручик. Намек понял? :)

Не оставили в стороне и FM-тюнеры. Есть и описание самих карточек, и софт к ним, так что качай на здоровье. Или, наоборот, на больную голову.

Итого:

Замечательный ресурс о TV- и FM-тюнерах и о софте к ним. С железом потрахаться, да еще и схалявить! Сказка!

Драйвера

Ну, прикупил ты девайсы. Это пока еще - горка бесполезной электроники. Хорошо, если они в коробочке, да с дисочком со всей фигней. А если ты брал зло-ОЕМ или вообще замшелый секондхенд? Правильно, придется шариться в поисках свежих дров. Расслабься - я уже здесь ;).

Drivers.Ru

http://www.drivers.ru

Первый адрес, пришедший мне в голову при упоминании слова «драйверы» - это drivers.ru. Честно говоря, дизайн тут просто отсутствует. Дешевенькие совковые обойки (спасибо, что не в цветочек) и, ясен дюбель, куча бесполезных баннеров. Наличествует аж целых пять ссылок, из которых нам потребна только одна - "Поиск драйверов". Search по дровам можно провести двумя способами: шмон в алфавитном порядке по производителям и поиск по типу оборудования. И опять подстава: на самом деле, поиска-то никакого нету! Просто набор (так и быть, отдам должное) удобно структурированных html-страниц. То есть, если это дело не обновлять - очень скоро будет сакс. Бинарники на серванте не размещены, но есть ссылки на официальные сайты производителей железа. В целом, девелоперов собрано большое количество, так что временами появляется необходимость посетить этот сервер.

Итого:

Забили суперский домен - отсюда высокая посещаемость. А вообще - минимальное количество информации и убогий дизайн. По-видимому, сайт специально создан для накрутки баннерных показов. Купи у них, что ль, имя и сделай цивильный ресурс! А то за Державу обидно.


Спецвыпуск Xakep, номер #012, стр. 012-108-5, Ржавые паги: обзор сайтов по железу

Ржавые паги: обзор сайтов по железу

d00d13 (d00d13@mail.ru)

Спецвыпуск Xakep, номер #012, стр. 012-108-5

Driver.Ru

http://www.driver.ru

После посещения предыдущего сайта сразу кидается в глаза более-менее нормальный дизайн, но это не столь важно. Обнадеживает другое: на этом серванте нужную софтину можно найти не через цепочку статичных html-страниц, а с помощью нормального cgi-скрипта, поэтому нудных заморочек у тебя возникнуть не должно. Правда, разочаровывает, что сама база данных по драйверам не особо выделяется своими "громадными" размерами, поэтому, если у тебя стоит железо от неизвестного производителя - сервер навряд ли сможет помочь. Есть форум, и даже сделан он довольно аккуратно (правда, это UBB), но увы - не блещет посещаемостью.

Итого:

Средненький сайт с таким же контентом. База дров слабовата.

DRV.Ru

http://www.drv.ru

"Компьютерная библиотека" - очень неплохой сайт с приятным дизайном. На главной странице есть лента новостей. Линки из нее направлены на другие сервера, что суть есть, конечно, плагиат - но зато сами ньюсы интересно почитать.

Основной частью сервера является поиск драйверов по свой базе. И, надо признаться, что база данных - очень даже ничего. Например, на ней я нашел дрова для своей древней ISA видеокарты OAK (с фиглиша – дуб :)), и этот факт не мог не порадовать.

Можно заглянуть в конференцию - но ее объемы оставляют желать лучшего. Конечно, ты можешь запостить сообщение, и на него, скорее всего, что-то когда-то ответят, но по качеству исполнения конференция не сравнится с такими гигантами, как iXBT.com и 3DNews.Ru.

Очень огорчил раздел "Статьи", их оказалось всего 13! И ни в одной я не смог найти ничего полезного :(. Зато понравился «Аукцион». И сделан он добротно, и народ на нем что-то покупает, так что держи его в голове. Вдруг захочешь какую-нибудь железячку купить или продать? А может, просто пожелаешь приколоться, перебивая цену?

Итого:

Качественный сайт с неплохой посещаемостью и довольно большой базой данных по драйверам. Так что сюда имеет смысл заползать по пятницам, если необходимо найти специфические дрова – например, дубовые =).

Пингвины

Еще одним подводным камнем при поиске драйверов для твоего железа является тип операционной системы. Если ты являешься счастливым обладателем операционной системы Windows, то поиск дров обычно сводится к посещению сайта вроде driver.ru или серванта девелопера. При этом никаких геморроев не возникает - ты просто радуешься жизни :). А вот в случае с Unix/Linux придется пострадать. Многое зависит от твоего оборудования.

Для начала тебе придется посетить официальный сайт производителя твоего железа, в надежде отыскать драйвер под эти Оси. Но еще не факт, что ты их там обнаружишь. Даже крупные компании просто отказываются писать драйверы под Linux. Поэтому в обзоре я хочу сделать акцент именно на эту ось - именно ее, а не Unix, обычно используют в домашних условиях. Например, я долгое время был подключен к сетке через кабельный модем по коаксиалу. На беду, модем оказался USB'шным. Естественно, в Windows никакой проблемы не возникло, 100% поддержка :), но линух гордо сдался, сказав что драйверов для этого оборудования просто нету (это было на RedHat 7.0 c ядром 2.2.19). Проблема оказалась в старом ядре, так что если тебе хочется использовать USB-устройство, то ставь kernel серии 2.4. Но я-то решил проблему несколько другим путем. Просто соединил кабельный модем витой парой с сетевухой =). Поэтому качай и ставь свежие ядра с ftp://ftp.kernel.org. Ладно, харош лирики! Переходим к вопросу "Где?!!".


Спецвыпуск Xakep, номер #012, стр. 012-108-6, Ржавые паги: обзор сайтов по железу

Ржавые паги: обзор сайтов по железу

d00d13 (d00d13@mail.ru)

Спецвыпуск Xakep, номер #012, стр. 012-108-6

LinuxBerg.com

http://www.linuxberg.com

Очень крупный сайт, где хранится куча различного софта, а также большой архив драйверов. Причем, настолько большой, что там имеются такие специфические дрова, которых, кажется, нету даже под Винды :). Не так давно этот сайт прикупила TuCows – интересно, что с ним может произойти? Сайт, как ты понял, на фиглише, но я чего-то не припомню стоящих сайтов с дровами для никсов на великом и могучем.

SourceForge

http://www.sourceforge.net

Еще один мега линукс-портал. Помимо готового софта здесь есть множество проектов, которые занимаются разработкой собственных драйверов под различное железо. Например, у меня была проблема с дровами для Aureal Vortex 2. Инструкция по карте послала меня на linux.aureal.com (уж послала - так послала), но такого сайта просто не было... В итоге, помог софт с Саурсфоржа. Так что сделай себе зарубку на мониторе.

Чаще ходи на хардвар - сайты, читай новости, статьи, не забывай посещать официальные сайты производителей твоего железа. И перец у тебя будет в шоколаде, а девайсы - в боевой готовности. Теперь ты сам можешь найти нужную тебе информацию на этих серваках.


Спецвыпуск Xakep, номер #012, стр. 012-113-1, HARD-FAQ

HARD-FAQ

Спецвыпуск Xakep, номер #012, стр. 012-113-1

Horrific (smirnandr@mail.ru, www.cydsoft.com/vr-online)

Дарова! Не подскажешь, что такое проц?

Это мозг компьютера. Он у него прямоугольный и тупой, но жутко быстрый. По-нашенски проц еще называют CPU или "камень". Процессоры бывают разные, но самые распространенные пошли от CPU x86 архитектуры (IBM-овские ХТ-шки), которая была разработана еще в 1978 году. В современных камнях от предков почти ничего не осталось, но все они "совместимы вверх" по исполняемым командам, то есть старинные проги написанные для "трешек" без проблем пойдут и на нынешних тачках (но не наоборот). Сейчас на рынке рулят Intel PentiumIII и AMD Athlon. Хоть их делают разные фирмы, и у каждого свои фишки, общего у них тоже навалом: винда глючит и на том, и на другом.

Угу, ясно. А почему одни процы квадратные и с "лапками", а другие - как картридж от "Денди"?

Патамушта квадратные - для "Ворда", а картридж - для игрушек. Поверил? А зря! И те, и другие работают одинаково. Там были расколбасы с технологиями: производители никак решить не могли, как лучше процы делать, поэтому столько разных реализаций. Теперь приходится вместе с процом выбирать соответствующую "мамку". Процессор должен подходить к слоту на плате. Эх, раньше все просто было: все "матери" поддерживали все.

Часто слышу, что у процов бывает кэш. Это о чем?

Эх, кто бы мне дешку кэша дал? Я б сразу на Канары... О чем я? Да. Кэш (cash) - это такая память, которая живет непосредственно в девайсе (не только в проце, но и, например, в винте). Туда грузятся наиболее часто юзаемые данные. Это очень удобно и конкретно ускоряет работу, так как камню не надо постоянно мотаться в оперативку. Ну, это как, если бы ты спер из библиотеки порнушный журнал, и тебе не надо бы было ходить туда каждый раз для занятия карманной медитацией. У проца размер кэша (для тебя - карманов) - очень важный показатель (влезет больше журналок). Чем больше кэш, тем дороже проц.

Я слышал, что кэш-память второго уровня находится вне кристалла, а где находится кэш первого уровня, нигде не говорится. Это какой-то секрет?

Конечно, секрет! Я тебе никогда не скажу, что кэш второго уровня уже давно находится на кристалле. И даже не уговаривай! Это случилось с появлением кэша на процессорах Celeron. Последний проц, где кэш был вне кристала - Двупень (Pentium 2). Там действительно кэш был вне кристалла и присоединялся отдельной шиной. Теперь это уже в прошлом. А кэш первого уровня со времен каменного века был на кристалле и никуда оттуда уходить не собирается. Тс-с-с! Только не говори никому. В Pentium 3 его размер составляет 32 кило на один проц. В Athlon - размерчик больше, а именно 128. Конкурентная борьба, однако.

Эээ... А что это за вентилятор на проце прилеплен?

Это он под Карлсона шифруется. Вообще, эта штука называется cooler (кулер). Кулер нужен, чтобы обдувать камень, который дико греется от напряженной "умственной" деятельности. Чаще всего это вентилятор с радиатором. В компьютере может быть несколько вентиляторов (на блоке питания, на центральном проце и на проце видюхи). Так вот, кулером принято называть именно процессорный вентиль. Хотя остальные - это тоже кулеры и они так же предназначены для охлаждения.


Спецвыпуск Xakep, номер #012, стр. 012-113-2, HARD-FAQ

HARD-FAQ

Спецвыпуск Xakep, номер #012, стр. 012-113-2

А сможет проц работать без кулера?

Сможет, но недолго. Особенно, если ты запустишь что-нибудь типа Quake со всеми настройками графики по максимуму. Камень от этого так возбуждается, что протянет, максимум пять минут. Только не забудь перед включением поставить рядом с собой огнетушитель и вызвать пожарников, саперов и скорую помощь :).

Что за коэффициент умножения?

Проц - штука хитрая. У него есть две частоты: внешняя и внутренняя. Внешняя частота - это частота шины. На ней камень обменивается с ней всякой фигней. А внутри он успевает за это время несколько раз переколбасить инфу. Вот, эту внутреннюю частоту и выпячивают вперед производители, пугая юзверя гигагерцами. Внутренняя частота - это внешняя частота размноженная на коэффициент умножения. Коэффициент умножения выставляется через BIOS (раньше джамперами) в соответствии с параметрами твоего камня. Но никто не мешает поставить коэффициент побольше, тогда частота камня вырастит. Если проц сможет работать в экстрим режиме, тогда ОК, а если - нет, то будут глюки и повисание писюка. Кстати, некоторые процы не гонятся. Это значит, что жадина-производитель жестко ограничил максимальное значение коэффициента умножения. Сволочь!

Оказывается, Pentium-ы 3 тоже бывают разные!

Не, ну ты представляешь! Совсем заморочила Intel бедные юзверьские головы! Но все не так уж и сложно. Первые Трипни были построены по старой архитектуре Deschutes, по которой производились еще Pentium-2. Эти процы делались по технологии 0,25 мкм, юзали шину в 66 МГц и могли работать на частоте от 350 до 450 МГц. Единственное серьезное отличие от Pentium-2 - интегрированный кэш на 128 кило. У Двупня кэш был 512 кило, зато у Pentium-3 он работал быстрее (на полной частоте проца). Поэтому смогли выкинуть к чертям дебильный картридж, ведь теперь все компоненты находились на одном кристалле. Вот так появился PPGA с разъемом Socket-370 (число здесь означает количество ножек на проце). Следующая модификация - Pentium-3 Katmai. В этом ядре появилось 70 новых инструкций (SSE), которые должны были ускорить работу с дробными числами (плавающая точка). Частота шины выросла до 100 Мгц а в некоторых случаях и до 133 (такие модели метились буквой "В"). Частота камня увеличилась до 450 - 600 Мгц. Следующим шагом стал Coppermine, который выполнен по 0,18 мкм технологии. Размерчик кеши у него уже 256 кило, а сам кэш стал круче. Шина осталась той же - 100 или 133 Мгц в зависимости от модели. На этих камнях тоже рисуют буковку "В". С таким ядром Pentium 3 скакнул до гигагерца. В общем, круче и дороже всех Coppermine 1000 Мгц, и не парься.

Да что это за "микроны" и "архитектуры" такие?!!

Перец, ты очень хочешь реально прогрузиться? Зачем тебе? Бери всегда проц с оптимальным соотношением цены и качества, юзай его до последнего и не заморачивайся. Ну, ОК. Сама виновата... Проц - это очень сложная схема, реализованная на кристалле кремния с использованием микротехнологий. Именно поэтому она такая маленькая, что влезает к тебе на ладонь. Если построить эту схему на лампах, то она займет огромный зал. От структуры и сложности схемы зависят фичи камня. Грубо говоря, схема проца - это и есть его архитектура. Схема камня строится из мельчайших элементов (полупроводников). Технология 0,18 микрон означает, что минимальный литографический размер, или по-человечески размер кусочка, из которого строятся транзюки, равен 0,18 микрометров. Чем меньше этот размер, тем больше элементов влезает в чип и тем выше максимально возможная частота работы камня. Скажу тебе по секрету, что уменьшать размер элемента бесконечно невозможно, поэтому скоро произойдет смена технологии: процы будут клепать уже не на кремнии, а на чем-то другом.


Спецвыпуск Xakep, номер #012, стр. 012-113-3, HARD-FAQ

HARD-FAQ

Спецвыпуск Xakep, номер #012, стр. 012-113-3

Что такое "разгон"? Комп же не самолет – куда ему гнать-то?

Ой, не гони ;). Разгоном (оверклокиногм) занимаются как сами производители девайсов, так и твоя соседка Маша Педалькина. Дело в том, что многие узлы компа (например, проц, память, видеочип, видеопамять) в принципе могут работать на более высоких частотах, чем указано в доках. Просто никто тебе не может дать гарантию, что все будет пахать стабильно и долго. Плюс - возникает нехилый гимор с охлаждением (перцам, разогнавшим проц до 2 Ггц, пришлось скрестить кузов с холодильником). Иногда частоту намеренно занижают, чтобы на одном конвейере делать дорогие и дешевые процы и при этом не лажать цены. Способы разгона тоже разные: от простого увеличения коэффициента умножения у проца, до использования специальных прог-твикеров.

А мне к новому девайсу дали кучу дискеток. Куда их совать?

Дискетки надо совать туда, и только туда! Любые дискетки, причем. Сунешь не в ту щель - чего-нибудь испортишь. Дискетами питается трехдюймовый дисковод (флопповод, флопарь). Флопарь зовут так, потому что в него пихают floppy disk (гибкий диск). Он очень похож на ZIP-дисковод. Так вот, если на дисководе написано "ZIP", то лучше засунь себе дискету в карман :). Из зипа твою флопушку уже не выковырнешь - она застрянет там намертво.

А че это за ZIP такой?

Zip (zipper) - это "молния" на штанах. Так что в туалете ты каждый раз анзипишь и потом обратно зипуешь свои причиндалы. Ну, да речь не об этом. ZIP-ы очень похожи на обычные дискетки, но на них влезает раз в 100 больше инфы. Естественно, для них нужен особый дисковод (может быть внешним и внутренним). Такая примочка хороша для тех, кто занимается полиграфией. У них один файл весит обычно 80 - 150 мегов. Дома и в обычных офисах такая приблуда не нужна, а стоит и дисковод, и сам носитель (дискетка) недешево, поэтому они редко у кого есть. Аналог ZIP-а - JAZZ.

Эге, понятно. А я нашел у себя в компьютере CD! Он же для музыки, или где?

Чууваааак, ты че, фишку не сечешь? CD с CD-ченджером в тачке - это ж крююто! А вообще, на сидюк не только музыку писать можно, но и любую другую инфу (только форматы разные). Инфы туда влазит 640 - 700 мегов, поэтому очень удобно хранить на дисках нужные программы, изображения, музыку в других форматах, доки и всякое такое. Некоторые CD-дисководы умеют только читать диски, другие умеют читать и записывать один раз (нужны особые диски). Есть такие, которые и читают, и пишут, и перезаписывают (нужны совсем особые диски). И потом: ты что, мастдай с дискеток устанавливал?


Спецвыпуск Xakep, номер #012, стр. 012-113-4, HARD-FAQ

HARD-FAQ

Спецвыпуск Xakep, номер #012, стр. 012-113-4

А папа сказал, что если я буду много играть, то он у меня Клаву заберет. Кто такая эта Клава?

Это тетка, которая всем дает понажимать на ее пимпочки, потрогать каждую выемку и загогулинку :). Иногда она мягкая, а иногда - с щелчком. Кому как. Обычно пимпочек у нее 101 или 102. Ну, догадался? Ага, это клавиатура.

Клавиатура – это хорошо. Но ведь печатаю я на ней, а все говорят, что печатать нужно на принтере. Принтер - это кто?

Принтер - это такая печатная машинка. Только раньше машинистка по кнопкам клацала, а теперь кнопки отрезали, машинистку выкинули и комп вместо нее поставили. То есть принтер - это печатающее устройство, которое под управлением писюка выводит на бумагу твои тексты и рисунки. Бывают матричные (устаревшие - зато жуть какие надежные) - бьют иголками по красящей ленте. Бывают ещё струйные - плюются на бумагу микрокаплями краски, и лазерные - наносят на бумагу разогретый красящий порошок и впрессовывают его туда. Матричные принтеры дико трещат и делают все медленно. Изображение получается низкого качества. Годятся только для складов - накладные печатать. Струйняки печатают значительно быстрее и качественнее, но красочку может размыть водой. Некоторые можно апгрейднуть до фотопринтера (правда, дорого). Годятся для дома, для семьи. Лазерные печатают очень быстро и качественно, и распечатка получается, как из типографии, но стоят они дорого, а цветные - вообще запредельно.

Все понял. Сколько раз можно перезаправлять картриджи от принтера HP ХХХХ?

Метишь в королевы бензоколонки? Ну-ну, будущий заправщик... Не знаю я, сколько. И никто не знает. Может быть, 5 раз, а может, и 10. Все это зависит от картриджа, чернил и быстроты твоих рук. Если аккуратно заряжать, то три раза он отработает гарантировано. Главное - не запаздывать с этим. Дело в том, что когда картридж плюется на бумагу, его сопла нагреваются. Краска кончилась - сопла выгорели. Можешь тащить чернильницу на помойку, потому что теперь она будет печатать разве что картины в стиле абстракционизма. Если в картридже осталась хоть капля чернил, и ты сразу приступил к зарядке, то вероятность успеха повышается. Если ты оставил картридж вне принтера без футляра на пару недель, то чернила могут высохнуть, и сопла забьются насмерть. Так что - к нему только на "Вы". Да, и чернила покупай лучше фирменные, а то подсунут тебе какую нибудь фигню с песком. Фирменный набор все равно стоит дешевле нового картриджа, а хватает его на несколько заправок. Лично я больше трех раз не заряжал, потому что картридж все равно изнашивается.

А как мне распечатать фотографии? Для этого же сканер нужен, нет? Сканер – это вообще что?

Это девайс для оцифровки изображений, то есть для перегона веселых картинок и безбашенных фоток в bmp-шки. Некоторые еще и живых котов цифруют ;). Раньше сканеры были ручные и выглядели, как скребок - только толстый, пластмассовый и со стеклянной панелькой на морде. Ими водили по картинкам вручную. Теперь сканеры дикие. В смысле, планшетные. Выглядят они именно, как большой пластмассовый планшет. Внутри планшета под стеклом ездит большая лампа. Кладешь на стекло фотку и закрываешь крышку. Лампа прокатывается вдоль стекла, и специальная прога выводит на экран и сохраняет на винте оцифрованное изображение.


Спецвыпуск Xakep, номер #012, стр. 012-113-5, HARD-FAQ

HARD-FAQ

Спецвыпуск Xakep, номер #012, стр. 012-113-5

Что означает словосочетание FAX-ю? И что такое ФАКС?

Что-с? Фак-с? Факс - это устройство, с помощью которое может отправлять изображения по телефонной линии. Он работает как сканер и модем в одном флаконе. Сначала факс сканирует изображение, потом сжимает его по очень сильному алгоритму (он сильнее, чем JPEG) и потом отправляет результат через телефонную линию на такое же устройство.

Ах, да... Про факс-ю я думаю ты и сам уже догадался. Или нет?

А можно использовать FAX в качестве сканера?

А можно использовать вместо йенга кактус? Все можно, но нежелательно. Изображение очень сильно сжимается, и происходят очень сильные и необратимые потери в качестве. А самое главное - ты теряешь цвет. Уж лучше заплатить 50 зеленых за простейший сканер и получить все преимущества цветного сканирования с высоким разрешением.

А "мать" – это кто?

А ты что, сам себя из глины вылепил? Мать - это мать. Она тебя родила и всю жизнь кормит, поэтому быстро respect ей! А... ты про "мамку"! Это самая большая и самая сексуальная плата в компе. В нее вставляют много других железок Она все компоненты твоего писюка воедино связывает. Любой девайс, подключенный к компутеру, коннектится либо сразу к "мамке", либо к промежуточной железке, воткнутой в нее. "Мамка" - основа, поэтому чузай ее внимательно и придирчиво.

А еще "матерью" зовут разъем, куда вставляется штекер ("папа"). Вот, такой жаргон.

Зачем компу память?

Комп - он, вообще, девайс злопамятный, но без памяти зла не помнит и отомстить не сможет. Правда, и работать не будет. Дело в том, что вся инфа, которую комп в данный момент обрабатывает, грузится в память. В одной ячейке хранятся исходные данные, в другую - складываются результаты. Все это меняется с дикой быстротой и только потом результат выводится, например, на монитор или сохраняется на винте или дискетке. Память еще называют «мозги». Сейчас писюку для бестормозной работы нужно иметь 128 мегов, а по-хорошему пора бы уже поставить 256 Мб, благо мозги сейчас дешевые.

Дядя, а какая она - память?

Не дядя, а товарищ фельдмаршал. Она длинная! Нет, правда. Это такая маленькая длинненькая платка с гребенкой контактов, на которой в рядок сидят жучки. Один чип - управляет процессом, остальные - хранят инфу, пока ток не вырубили. То есть, она энергозависимая. Поэтому, прежде чем комп вырубить, нужно все данные куда-нибудь еще положить - например, в бабушкин сундук.

На рынке памяти, как грязи, и вся разная! Что это за SDRAM-ы, DDR-ы, RDRAM-ы и другие?


Спецвыпуск Xakep, номер #012, стр. 012-113-6, HARD-FAQ

HARD-FAQ

Спецвыпуск Xakep, номер #012, стр. 012-113-6

Не боись! Взвесь себе по полкило каждой и с чайком! Красота! SDRAM - это на данный момент самые простейшие мозги - синхронная динамическая память. Модули этой памяти зовутся DIMM-ы. Эта память может работать на частоте 66, 100 и 133 МГц и имеет 168 контактов. Однако эти частоты - не предел. Практически любая память может быть разогнана, и есть реальные случаи работы на 150 МГц и выше. Но разгон делается на свой страх и риск. Никто не сможет гарантировать стабильной и долгой жизни на повышенных частотах. Эта память потихоньку вымирает, и скоро ее место займет более скоростная DDR SDRAM. RDRAM - это многообещающая замутка от Intel, но она только появилась и обычному юзеру нафиг не нужна (дорого очень).

А что крутого в RDRAM?

RDRAM - это память, на которой погорела Intel. Хотела рулить, выпустив чипсет для 4-го Пня с поддержкой только RDRAM, но обломилась: другие фирмы намутили свои чипсеты для Pentium-4 с поддержкой DDR SDRAM. Теперь сосет и догоняет. Ну, да не об Intel речь. RDRAM строится на интерфейсе Rambus Interface (фирмы Rambus). Он находится как в чипсете, так и на каждой микрухе памяти. Контроллер и микросхемы соединяются между собой по каналу Direct Rambus Channel (DRC шина из 33 проводов). Пропускная способность одного канала - 1,6 Гб/с. Это меньше, чем у RDRAM, но каналов 2 или 4, то есть до 6,4 Гб/с. Поэтому Intel и вцепилась в эти железки. RDRAM имеет более высокую частоту и меньшую длину слова, что в итоге дает большой прирост производительности. Память способна работать на частоте 400 Мгц, но за счет передачи по двум фронтам реальная скорость в два раза выше (800 Мгц). Модули памяти с RDRAM называются RIMM и имеют 184 контакта. Самое интересное, что контакты позолочены. Так что если у тебя еще простые зубы - бегом счищать себе золото с контактов RIMM. RDRAM - более дорогая, и надежды на снижения цены очень малы. Хотя за такую скорость можно переплатить любую цену, если нужен высокоскоростной сервант или рабочая станция.

В чем фишка DDR SDRAM?

Это синхронная память, только она передает данные в два раза быстрее (скорость передачи достигает 2,1 Гб/с). Количество контактов увеличилось до 184, поэтому в обычный разъем для SDRAM-а она не залезет. Правда, если под рукой есть кувалда, рубанок и напильник - то я ошибся :). Конечно же, DDR SDRAM лучше обычного SDRAM, но она и стоит дороже. Хотя на данный момент существуют "мамки", которые могут поддерживать оба типа. Но я бы не советовал их брать. Разница между SDRAM и DDR SDRAM в цене не слишком большая. Поэтому не стоит переплачивать за мамку, поддерживающую оба типа памяти, лучше сразу переплатить за DDR SDRAM.

Что такое видюха?

Это такая тетка, на которую все ведутся :). "Видюхой" на человеческом языке называют видеоадаптер (видеокарту). Это такая платочка, к которой коннектится монитор. Видюха получает инфу о картинке, сохраняет в своей бортовой памяти (видеобуфере) и по одной точке передает в RGB-порт (разъем, куда воткнут шнур моньки). Из этих точек монитор строит буковки, циферки, окошки и прочих голеньких девочек. Современные видюшки могут совершать и самостоятельные телодвижения. Например, им достаточно получить параметры форточки, а построят они ее сами. Это значительно разгружает проц.


Спецвыпуск Xakep, номер #012, стр. 012-113-7, HARD-FAQ

HARD-FAQ

Спецвыпуск Xakep, номер #012, стр. 012-113-7

Это случайно не 3D-ускоритель?

Совершенно случайно, нет. Видюха - не обязательно ускоритель, иногда она - тормозитель :). Это если у нее видеопамяти мало. Ну, так вот. Видеокарта просто выводит изображение на экран, а 3D-ускоритель (акселератор, аксель) - это специальная примочка для обработки трехмерной графики (Quake видел когда-нибудь? Там все такие квадратные, потому что трехмерные). Просто современные аксель и видюха реализованы на одной плате (или вообще в одном чипе), поэтому весь девайс для удобства называют ускорителем. Первые 3D-ускорители работали параллельно с видюхами, занимали лишний разъем и гнали данные на видеокарту через внешний кабель, а следовательно, тратили много лишнего времени. Вот их и скрестили.

У меня на видюхе нет кулера. Могут ли из-за этого быть глюки?

Могут, особенно если видюха от супер-производителя "Noname". У меня Riva TNT от Creative за целый год не показала ни одного глюка, хотя на проце стоит только радиатор. Некоторые косоглазые и косорукие производители "Noname" намеренно не ставят ни кулер, ни радиатор, чтобы сэкономить деньги. В этом случае проблемы могут возникнуть при первом же перегреве, поэтому не советую долго играть в Кваку. Так что у тебя есть два выхода: купить новую видюху с вентилем и переплатить за нее 50-100 деревянных или купить за те же бабки кулерный блок для видюхи. Хотя есть еще способ для Раком Феллеров: купить корпус с водяным охлаждением. Бабок стоит нехилых - зато, надежно, как танк.

Что такое DirectDraw и OpenGL?

Это такие 3D-интерфейсы, которые в муках борьбы за власть между M$, 3Dfx и Nvidia, наконец, окончательно утвердились на рынке 3D акселей. Оба этих фейсов есть набор библиотек, которые посредничают между кодером и 3D инструкциям, зашитыми в чип акселя. С использованием этих библиотек кодеры пишут свои проги, в основном, игры. Поэтому, чтобы не было траблов, ускоритель должен поддерживать оба интерфейса. А то вместо гамы, получишь большой кукиш.

У меня видюха с 1 метром памяти. Почему я не могу установить разрешение больше 800х600 и 16 бит цвета?

Потому, что у тебя памяти слишком мало для хранения буфера изображения. Большие буфера в тою память не влезают, понимаешь! Давай посчитаем: у тебя разрешение 800х600. Если перемножить эти числа то получишь количество точек на всем экране (480000). Теперь умножаем на 2, потому что при 16 битном цвете для хранения каждой точки в буфере нужно 2 байта, получаем 960000. У тебя всего 1000000 байт памяти, т.е. ты почти израсходовал всю память. Больше ты поставить не сможешь. Если ты хочешь увидеть разрешение 1024х800 при 16 бит цвете тебе понадобится чуть больше 1,5 Мб памяти на видюхе. Вот и вся любовь.

Зачем на видюхах ставят по 16, 32 или даже 64 мега памяти, ведь даже под самое большое разрешение достаточно 4-х?

А это для "новых хацкеров". Чиста, пацаны тоже не используют 6-литровый движок своих "Мерсов" полностью, но это канкретна понтово. Во! А если серьезно, то для простой видюхи 4 метра - потолок. Но если она умеет просчитывать 3D-графику, то тут уж памяти, как и денег, много не бывает. В свободной памяти хранится текстуры, которые потом будут накладываться на 3D поверхность. Конечно же, текстуры не единственное, что там находится, но это самое основное и самое тяжелое. Если памяти не будет хватать, то придется использовать оперативку, а это значит - лишняя нагрузка на шину AGP, тормоззза и еще одна табуретка в твоем мониторе.


Спецвыпуск Xakep, номер #012, стр. 012-113-8, HARD-FAQ

HARD-FAQ

Спецвыпуск Xakep, номер #012, стр. 012-113-8

Ага. А че это за саундбластер такой? Это то же самое, что звуковуха, или нет?

Это такой big gun, который громко орет "Пиф-паф!!!". И еще много чего: стонет, вздыхает и повизгивает. В общем, это звуковая карта (соундкард, звуковуха). Она вставляется в "мамку". Саундбластер, вообще-то – собирательное название: так называлась серия звуковух фирмы «Креатив». Других не было, и все саундкарды стали звать «бластерами».

В последнее время пошел прикол делать звуковухи, встроенные в материнку наглухо, которые для вывода звука используют центральный проц. Это самая настоящая глупость и я категорически не советую тебе использовать такие. В попке у звукаря много симпатичных дырочек: выход на колонки, линейный вход, линейный выход (сюда можно воткнуть усилок), вход для микрофона, вход для подключения джойстика (Game-port). Специальным кабельком к звуковушке цепляется CD-ROM, чтобы слушать Audio CD. В общем, все, что связано со звуком идет через этот девайс. Современные саундкарты обучены всяким хитрым фокусам, типа трехмерного звука.

Что такое винт (HDD)?

Эта та же дискетка, но только замурованная в коробку и о-очень большая по объему. Винт (жесткий диск, винчестер) живет внутри блока и жужжит. Но главное, он хранит много-много твоих файлов. Внутри диска крутятся пластины (блины), на которые с помощью магнитных головок записываются и считываются данные. Крутизну и скорострельность винта определяют по скорости вращения шпинделя (обычно 5400 и 7200 оборотов), плотности записи, объему буферов... мнэ... буфера (сейчас 2 или 4 мегабайт). Диски могут иметь один из двух интерфейсов (междумордий) - SCSI или IDE. Первый круче (юзают на серверах и графических станциях), второй - дешевле (хорош для дома).

Эй! Я же не знаю, что такое интерфейс!

Как бы тебе объяснить? Во! На тетках! Представь, что ты танцуешь с подругой и хочешь ее поцеловать. Ты перекладываешь руку на попку, нежно прижимаешь ее к себе и пристально смотришь ей в глаза. Она закрывает свои и чуть-чуть открывает ротик. Ты складываешь губы трубочкой и прижимаешься к ее губкам. Дальше в ход идут язычки... У вас получился интерфейс :). Так вот, у компьютеров так же. На девайсах есть стандартные разъемы, в них втыкаются стандартные шнуры. Разработаны правила написания программ, которые будут юзать эти девайсы. Программеры не знают, как пашет винт или сидюшник, зато, знают какие команды нужно использовать, какие данные дать на входе и какие - получить на выходе. Чем круче интерфейс, тем больше возможностей он предоставляет.


Спецвыпуск Xakep, номер #012, стр. 012-113-9, HARD-FAQ

HARD-FAQ

Спецвыпуск Xakep, номер #012, стр. 012-113-9

Мне сказали, что чтоб играть и выходить в интернет, нужен модем. Что это?

Это штука, которая полностью называется «модулятор-демодулятор». Она занимается преобразованием цифрового сигнала в аналоговый и обратно - то есть, модулирует и демодулирует. Поэтому так и называется. Такой девайс может связать два компа на разных концах света! Модем (иначе момед или мопед) преобразовывает цифровые сигналы, посылаемые компьютером, в аналоговые, воспринимаемые телефонной станцией (АТС), и передает через телефонную линию. При приеме происходит обратное преобразование. Если АТС цифровая, то скорость выше: не надо колбасить сигнал туда-сюда, и связь лучше. Скорость мопеда измеряется в килобитах в секунду. Чем больше, тем лучше и дороже. Фактический стандарт сейчас - 56 Кб/с. Мопеды бывают внутренние (просто плата) и внешние (девайс в аккуратном корпусе с лампочками). Внешний лучше, но значительно дороже.

У меня модем на 56k, но коннект с провом максимум 12000. От кореша мой модем коннектится к моему прову на 36k без проблем. Что за нафиг?!

Открой телефонную розетку, и если там стоит маленькое зло-сопротивление - убери его на три буквы, которые очень часто пишут на заборе. Эта тварь не одного тебя довела до нервного подергивания ушей. Например, мой внешний Acorp с таким сопротивлением коннектился только на 2400, а без него спокойно свистит на 42000. Так что выпаивай его к чертовой маме, папе, бабушке и дедушке. А телефонщику, который установил сопротивление, не убедившись в его надобности, паяльник в зад. Чтоб его дети телевизора боялись!

Почему, когда я тестирую модем, у меня показывает скорость 115200, а у меня внешний модем всего на 56k?

Это шутка такая, чтобы тебе приятно было. На самом деле, большинство программ для тестирования проверяют не реальную скорость передачи данных, а скорость обмена данными между модемом и компьютером. А это уже скорость порта. Большинство внешних модемов плюгинятся к COM-порту, скорость которого около 115200. Чтобы узнать реальную скорость передачи, нужно с кем-нибудь соединиться, и попробовать перекачать файло. Нормальная скорость закачки на дайлупе больше 10 Мбайт в час.

На дайлупе? Это где?

Дайл-ап (dial-up), или Дайлуп – способ связи с инетом. Это когда ты по телефону через момед к провайдеру коннектишься.

Угу, понятно. А что такое сетевуха?

Это такая плата, которую хранят в авоське. Правда, лучше тыкнуть ее в слот на "мамке", а в попу вставить специальный кабель. Если сетевуха есть еще на одном компе и до нее дотягивается второй конец кабеля, то можно намутить сеть. Все! Теперь у тебя есть собственный карманный интернет из двух компов, и ты можешь играть с другом в сетевые игры, обмениваться файлами и устраивать чаты.

А что, бывают разные провода для сетевух? Разве не пофиг?

Где б достать такого кофе, чтобы сразу стало пофиг? Вообще-то, от типа кабеля зависит то, какой крутизны, ширизны, ветвезны и скоризны будет твоя авоська. Существует три основных типа кабеля - витая пара (лапша), коаксиальный кабель (кокс) и волоконно-оптический (волокно). Ясен шпиндель, оптуха самая рулезная проволока, но и платить за нее затрахаешься. А лапша, она и в Африке - лапша: дешево и сердито.


Спецвыпуск Xakep, номер #012, стр. 012-113-10, HARD-FAQ

HARD-FAQ

Спецвыпуск Xakep, номер #012, стр. 012-113-10

Не халтурь! Что еще за коаксиал?

Коаксиальный кабель (коаксиал, кокс) - состоит из центрального проводника и внешней экранирующей оплетки. Существует два варианта коаксиала - тонкий и толстый, но оба они склепаны одинаково. Центральный проводник может быть выполнен в виде одной толстой кишки или нескольких тонких. Центральная жила помещается в изоляцию и сверху покрывается металлически гибким коаксиальным экраном (фольгой). Ты, перец, наверняка юзал что-то типа кокса - он очень похож на телевизионный кабель, только волновое сопротивление у него 50 Ом или 75 Ом. Сетевые карты в основном рассчитаны на определенное сопротивление. Это значит, что карта, рассчитанная на кабель 50 Ом, не будет работать с кабелем на 75 Ом. Вход под кокс тоже похож на антенный.

А витая пара?

Витая пара (витуха, лапша) - это два изолированных медных провода, скрученных между собой. Такой кобелина пасется в телефонной розетке, только в нашем используется 4 пары проводов (восемь проводников), а не два. Витая пара делится на экранированную (STP) и неэкранированную (UTP). Если сеть проходит внутри здания, то можно использовать неэкранированный кабель. Но если он будет выходить на улицу или еще куда, где дофига помех, то лучше заюзать экранированную витую пару. Слышал когда-нибудь слабенький радиоприем по телефону? Это лапша приняла. На сетевухе гнездо под витуху выглядит, как дырка на телефонной евророзетке, только шире.

Теперь давай про оптоволокно.

Оптоволоконный кабель (оптуха) состоит из двух проводов. Эти провода могут передавать данные только в одном направлении. Информация летит по стеклянному проводу, поэтому этому кабелю не страшны никакие электрические поля. Самый главный недостаток волокна - сложность монтажа. Вечно трезвый электрик дядя Вася тут не годится. Кабель соединяется с разъемом с точностью до микрона. Сделать такое в домашних условиях практически анреал, поэтому можно только заюзать готовые куски кабеля с установленными на заводе разъемами.

Я тут пошлялся по своему ВУЗу и заметил, что к проводам нашей сетки кроме компов подсоединены еще какие-то коробочки с лампочками. Что это?

Тревога, чувак!!! Твою сетку протроянили ламерикосские шпионы, подсосали к ней свои концы и теперь качают гигзы институтской порнухи и прочую секретную инфу. Скорее хватай молоток... нет, лучше кувалду и беги мочить эти вредные девайсы. Вернулся? Как самочувствие админа? Трынькает пальцем по губе? Замечательно! Тогда продолжим. В простой сетке из двух - трех компов никакие дополнительные девайсы не нужны: машины общаются напрямую. А вот если сетка большая, состоит из многих компьютеров, протянулась на несколько километров и включает в себя несколько сегментов (это когда отдельные маленькие сеточки, объединены в одну большую) - возникают проблемы. Решением этих траблов занимается армия сетевых устройств: повторители, концентраторы, мосты, коммутаторы и маршрутизаторы. Стоит это все немалых денег, так что строй свою сетку оптимально.


Спецвыпуск Xakep, номер #012, стр. 012-113-11, HARD-FAQ

HARD-FAQ

Спецвыпуск Xakep, номер #012, стр. 012-113-11

Что такое повторители?

Расстояние между машинами в авоське на любом кабеле имеет ограничения из-за затухания сигнала. Для тонкого коаксиального кабеля это - 185 метров, для толстого коаксиала - 500 метров и т.д. Чем длиннее кабель, тем больше затухает амплитуда сигнала и увеличивается количество помех. Если хочешь сеть длиннее, то сигнал нужно "обновлять" минимум через каждые 185 метров (для коаксиала), таким образом он достигнет до самого отдаленного участка сети без проблем. Для этого юзают повторители. Повторители бывают усиливающие и регенерирующие. Первые - просто усиливают входящий сигнал, не анализируя его, то есть и шумы тоже. Такие усилители используются при усилении аналогового сигнала, потому что там лишний шум погоды не сделает. При работе с данными такое усиление не катит. Вторые - уже не просто тупо колбасят все входящее, но и фильтруют помехи, выделяя полезную инфу, и генерят новый сигнал, идентичный исходному. За счет этого волна получается чистой от шумов. Регенерирующие повторители намного сложнее и поэтому намного дороже, но выгода от них большая.

Чем отличаются повторители и концентраторы?

Концентраторы используются для соединения нескольких сетевых сегментов. Активные концентраторы футболят приходящий сигнал на все порты кроме того, с которого ввалился сигнал. Так что получается, что концентратор - многопортовый повторитель (в основном регенерирующий). То есть, концентраторы выполняют функции повторителей, только имеют много портов. Вот она и разница.

Что такое коммутаторы?

Алле, барышня! Мне Смольный! Ну, барышня!.. девочка... женщина... У, дура старая! Коммутаторы - это сетевые устройства, которые есть помесь повторителей и мостов. В прайсах и названиях девайсов очень часто присутствует слово switch, в переводе - переключатель. Ну, да хрен редьки не слаще. В отличие от мостов, в которых только два порта под коаксиал, здесь уже может быть несколько портов, в основном 8 или 16. Поэтому, их часто юзают в сетях на витухе. Так как коммутатор может выполнять функции моста, то есть анализировать адреса пакетов, то его так же юзают для ограничения потока данных между сетями, чтобы такие, как ты, уши не грели. Иногда коммутаторы называют коммутирующими концентраторами, за счет совмещения в себе функций многопортового повторителя и высокоскоростного моста. Это, в общем, пофиг - главное, чтобы пахал.

Что такое маршрутизаторы?

Маршрутизаторы предназначены для определения пути места назначения пакета. В принципе, работа маршрутизатора похожа на работу коммутатора, только он предназначен не для соединения сегментов сети, а для соединения целых авосек. Он так же анализирует адреса получателя (но только на более высоком уровне) и отправляет пакет только в нужный порт. Маршрутизаторы юзают не просто МАС-адреса (идентификатор конкретной карты, зашитый в нее производителем) и номера портов, а целые маршрутные карты. То есть, грубо говоря, маршрутизатор рисует пакету путь следования. Эдакий гаишник - пока в лапу не дашь, пакет не сопрешь ;).


Спецвыпуск Xakep, номер #012, стр. 012-113-12, HARD-FAQ

HARD-FAQ

Спецвыпуск Xakep, номер #012, стр. 012-113-12

Что такое "мосты"?

Да, ты прав: пора, пора наводить мосты с цыпочками из соседней сетки. Мосты! Много мостов! Кгхм!.. Да... Сетевой мост - это еще один хитрый сетевой девайс. Он умнее, чем концентратор, так как способен выдирать из пакета адрес получателя и анализировать его. В итоге, мост сам решает, на какой порт нужно запульнуть полученный пакет. Если он принадлежит той же сети, откуда пришел, то мост посылает такие данные нафиг. Если пакет данных нужно редиректнуть в другую сеть, то мост отправляет его именно в тот порт, к которому подсосана нужная сеть. Все остальные сети не смогут получить не предназначенный для них пакет данных (конечно же, существуют и исключения, но я говорю о нормальной, штатной работе моста). Если концентраторы просто регенерируют все приходящее на все порты подряд, то мосты отправляют данные только получателю. Ну, да на каждый мост найдется своя баржа ;).

Один мой приятель хвалился, что у него тачка «брэнд нэйм». Это что?

Здорово, буржуй! Выражение "Brand Name" относится не только к компьютеру, но и любой другой железке. Оно означает, что эта железка сделана (или собрана) именитым производителем где-нибудь в Штатах или Европе и стоит в полтора-два раза больше безымянных (No name) аналогов. Но это не значит, что Brand Name - это всегда лучшее. Очень часто лейбл "Маде ин соседний гараж" намного дешевле и работает не хуже. Тем более, что большинство именитых ничего не производят, а только собирают. Они берут те же самые комплектующие, произведенные в Корее и Тайване, чуток их тестируют и пихают в корпуса со своим лейбаком. Кроме того, "гаражники" - тоже не ламера и прилепят тебе любой брэнд куда угодно. Я, например, видел калькуляторы фирмы "Nivea" :). В общем, наш сельский парень Вася Хаков соберет любую железку намного быстрее и лучше любого бренда.

Что такое шина? У компа же нет колес!

Шина - королева джунглей. Сидит на материнке и торчит слотами :). Это своеобразная магистраль, по которой носятся данные между различными компонентами. Разные платки (звуковуха, сетевуха, модем и т.д.) втыкаются в разъемы этой самой шины и обмениваются через нее данными. Крутобедрость шины зависит от того, сколько инфы и как быстро она перекачивает. Толщина (разрядность) у них стандартна (сейчас пока еще стандарт - 32 bit), а скорость (частота) может быть разной (66/100/133 Мгц). Сейчас наиболее распространены "матери" с частотой 100 мегагерц, но все уже начали переползать на 133 Мгц.

Что такое IDE?

Вообще-то, это интерфейс, а технически - это разъем на материнской плате. Он используется для подключения таких устройств, как винты и CD-ROM. Подключение происходит с помощью 40-контактного кабеля (шлейф). На один шлейф можно посадить 2 устройства. На "мамке" чаще всего присутствует 2 IDE - разъема, а значит, ты можешь подключить 4 IDE - устройства.

А что есть AGP, ментор?

AGP есть большое недоразумение! Геймеры настолько офонарели в своих требованиях к игрушкам, что производителям пришлось даже отдельную графическую шину выдумать. Со всеми этими "трехмерными" играми объем инфы, передаваемой между видюхой и процом, возрос настолько, что обычной системной PCI-шины перестало хватать. Поэтому между камнем и видеокартой проложили отдельную высокопроизводительную шину и назвали ее "Advanced Graphic Port". Вот. И приходилось при апгрейде старую "мамку" выкидывать, потому что все новые видюхи выходили под AGP.


Спецвыпуск Xakep, номер #012, стр. 012-113-13, HARD-FAQ

HARD-FAQ

Спецвыпуск Xakep, номер #012, стр. 012-113-13

Э... Какую мамку мне взять, с AGP 4X или AGP Pro?

У тебя деньги есть?! Дай подержать! Не дашь? Ну и ладно. Бери тогда свою AGP Pro. Такая "мамка" будет подороже, зато в нее можно будет всандалить любую видюху. Разница между этими двумя разъемами в том, что у AGP Pro есть дополнительные контакты для подачи питания на видюху. Это значит, что в AGP нельзя засунуть видео, заточенное для AGP Pro, потому что не будет контакта с питанием. Зато в AGP Pro можно засунуть, что угодно (не пойми превратно). Но подумай, стоит ли переплачивать за такую "мать"? Отдай, лучше, баблоз на благотворительные нужды, то есть мне :).

Что такое чипсет?

Любишь чипсы? Так вот, банку чипсов можно назвать чипсетом, то есть набором чипсов :). А наш чипсет - это набор микросхем (по-английски микруха - "chip"). Чипсет - это два самых больших жука с туевой хучей ног. Ты без труда найдешь их на "мамке": один тусуется где-то в районе проца и памяти и спрятался под радиатором (North Bridge aka Северный мост), другой - в районе слотов шины (South Bridge aka Южный мост). Вид чипсета является очень важной характеристикой "мамки": от этого зависит, какие фичи она поддерживает, а какие - нет. Описание чипсета ты найдешь в "User's Manual" aka Инструкции к "мазаборду". Мол, скажи мне, "мамка", куда тебе пихать, чего тебе пихать? НУ-КА, НУ-КА? Откуда ты это сказала???

А кто такой биос? Это операционка такая, по-моему...

Нет, операционка – это БеОсь =). А биос... Вспомнил! BIOS - это жук такой. Он тоже поселился на твоей "мамке", и отвечает за настройку и управление оборудованием. В BIOS-е зашита хитрая программа, которая сразу после включения питания тестирует все узлы компа, стартует его работу с выбранными параметрами и передает управление системе. Если чего-то не в порядке, BIOS пищит. Продолжительность и громкость визга зависит от того, что не в порядке. Параметры хранятся в этой же микрухе. Чтобы они не потерлись после выключения электричества, BIOS питается от батарейки (блестящая таблетка на "мамке"), поэтому, если ее вынуть, BIOS сбросится на дефолт (то бишь, на стандартные настройки).

Что значит, если BIOS не просто, а flash?

Это значит, что BIOS можно не просто, а "перепрошить". Значит так, берешь швейную машинку, иголки, нитки и дрель и... прячешь это все подальше. От соблазна. "Перепрошить" BIOS - значит поменять ту самую программу, на ее более новую версию. Эта стремная операция может добавить твоей "матери" некоторые дополнительные фичи, а может и убить ее нафиг. Поэтому не доверяй свою "маму" случайным знакомым. Это можно делать благодаря тому, что flash-память позволяет записывать и перезаписывать инфу и не требует питания для ее хранения, то есть она - энергонезависимая.


Спецвыпуск Xakep, номер #012, стр. 012-113-14, HARD-FAQ

HARD-FAQ

Спецвыпуск Xakep, номер #012, стр. 012-113-14

У меня в компьютере стали постоянно отставать часы. Может, процессор уже глючит от старости?

Что-то точно глючит и даже от старости, но не процессор, а батарейка. Та самая таблетка на "мамке". Вытащи ее, перепиши номер - и бегом в ближайшую часовую мастерскую! Там такого добра навалом, и стоит не так уж и дорого. А процессор не тронь. У меня был комп Pentium 100, так он до сих пор работает без глюков. Недавно проверял.

Что такое джампер?

Это такая перемычка на плате или устройстве для изменения основных параметров. Есть, например, на "мамке" несколько штырьков, которые, судя по инструкции, регулируют частоту шины. На два из них надет маленький пластмассовый презер. Этот контрацептив скачет по штырькам туда-сюда (не сам, конечно, ты его переставляешь), закрывая 2 из них. От того, какие 2 штырька он перекрыл, зависит, куда пойдет сигнал. Таким макаром выбирается, например, частота. Большинство современных девайсов поддерживает как джамперную, так и программную конфигурацию. При программной, настройка происходит с помощью специальных утилит. Например, сейчас частота шины обычно выставляется через BIOS. При джамперной - настройка происходит с помощью переключения джамперов. В зависимости от их положения можно установить любую конфигурацию.

Какая разница между AT и ATX? Я могу мать АТ в АТХ-корпус запихнуть?

Какая разница между попой и пальцем? Правильно, попа пукает громко. Во-первых, АТ и АТХ-компы отличаются по размерам "мамок" ("форм-фактор"), то есть АТ-шня плата в АТХ-овый корпус не встанет. Во-вторых, питание разное. АТ-плата коннектится к блоку питания двумя штекерами: причем, если не так воткнешь, все сгорит нафиг. АТХ-плата подключается одним большим штекером, в котором контакты стоят в два ряда, и их больше. Вставляется он только одним раком. Штекеры разные, потому что АТХ-стандарт включает в себя функции управления питанием. Программно можно заставить комп "заснуть" или вырубиться вообще.

А каких размеров бывают матери вообще?

Наиболее распространенные форм-факторы (размеры) ATX и AT такие:

ATX - 306x244mm.

Mini ATX - 284x208mm.

Micro ATX - 244x244mm.

Flex ATX - 229x191mm.

AT - 305x330mm.

Baby AT - 216x330mm.

У меня пятидесяти - скоростной CD-ROM. Что это значит?

Осторожно, парень! Не включай турбину, а то улетишь =)! "Скорость" - это такая единица крутизны сидюшника, которая означает, как быстро привод считывает данные с диска (а не как быстро это все вертится). Первый CD-ROM имел скорость 150 кб/с. Вот именно это значение и приняли за единицу скорости приводов. Это значит, что скорость твоей подставки под компот 150*50=7500 кб/с. Но это только теоретически. В основном скорость чтения диска зависит от качества диска. Да и не на всех участках диска скорость одинаковая. На дорожках, которые ближе к центру, максимальная скорость 20-22Х. Чем дальше от центра, тем выше скорость. На крайних дорожках на хорошем диске можно достичь 50Х (но только во сне). И вообще, эти 50Х - ошибка природы. Сперва они разгоняются, жужжа, как пила "Дружба", а потом резко тормозят, когда чего-то прочесть надо. И так постоянно. Возьми лучше 10 - 20Х, если повезет найти.


Спецвыпуск Xakep, номер #012, стр. 012-113-15, HARD-FAQ

HARD-FAQ

Спецвыпуск Xakep, номер #012, стр. 012-113-15

Что такое SXGA?

Грубо говоря - это разрешение экрана. Просто у америкосов все на рекламу завязано, поэтому они не могут сказать просто столько-то точек на столько-то, а придумывают всякие "супер-пупер графические адаптеры", а в доках пишут сокращенно. В общем, SXGA - это 1280х1024 точек, UXGA - 1600x1200, QXGA - 2048x1536. А еще есть SuxxGA - 640х480 и ниже ;). Дальше еще какую-нибудь букву придумают (например, ZXGA) - но это уже будет, наверное, экран во всю стену.

Что такое СОМ-порт?

По-научному - это коммунистический... тьфу! Уйди, бабка! ...коммуникационный порт для связи компьютера с периферийными устройствами. В файлах "Пентагона" он так же называется RS-232. Во как... А теперь то же самое, но на человеческом языке. COM-порт - это разъем компьютера, к которому ты можешь подсосать через COM-кабель какие-нибудь примочки. Например, не так давно мышки подключались через СОМ-порт. Модемы до сих пор выпускаются под СОМ, хотя уже потихонечку переползают на USB. Еще COM-порт называют параллельным.

Что такое LPT-порт?

Еще один разъем в попе у компа. Похож на COM-порт, но раза в два подлиннее. К нему подключаются, в основном, сканеры или принтеры. А можно и то и другое. LPT-порт еще называют последовательным.

Тээкс. А USB, на которое переползают модемы – это кто?

LPT и COM - это хорошо, но они тормозные. Каждое подвешенное на них устройство требует прерывания, да и на один порт не подвесишь больше 1-2 устройств (на LPT, можно повесить принтер и сканер одновременно). USB решает все эти проблемы. На один кабель можно подвесить кучу устройств, вешать можно "на горячую" (то есть не выключая компьютер), все устройства будут использовать одно прерывание, скорость прокачки около 2 мегов. Быстро качает, звереныш!

Чего, чего ты там про прерывания ляпнул? Что это за звери такие?

Звери эти в хозяйстве очень полезны. Дело в следующем: когда на устройстве происходит какое-нибудь событие (например, кончилась бумага в принтере), его нужно тут же обработать (обматерить нерадивого юзверя), иначе произойдет сбой. Для этого существуют прерывания, иначе - IRQ. Как только эта фигня сработает, процессор по пожарной тревоге бросает все дела, сохраняет свои регистры в стеке... Аааа! Не бейте! Все просто: проц себе записочку рисует. Мол, напечатал полстраницы: когда вернусь, начать отсюда. Дальше он начинает обрабатывать это событие, то есть выполняет экстренные действия (например, рисует форточку с матом). Когда событие обработано (юзверь подкинул бумажки и шлепнул "ОК") проц возвращается к выполнению текущей задачи (читает свою записку и продолжает печатать анекдоты с нужного места). Каждое IRQ имеет свой номер и ассоциируется с каким-нибудь устройством. А когда на устройстве происходит какое-нибудь событие, оно генерирует прерывание. "Эй, проц! 5-ому в туалет надо!" "Разрешить!!!"


Спецвыпуск Xakep, номер #012, стр. 012-113-16, HARD-FAQ

HARD-FAQ

Спецвыпуск Xakep, номер #012, стр. 012-113-16

Эти IRQ у меня часто конфликтуют, гады!

Да, они такие! Чуть что - сразу раз, и драка! А все почему? Потому что сейчас все прерывания расставляются автоматом, чтобы юзер вручную не мучался (подключись и молись, так ее растак). Но случается, что два девайса "по умолчанию" хотят один и тот же IRQ. Например, очень часто случается конфликт, когда втыкаешь в "мамку" хорошую звуковушку, позабыв отрубить встроенное дерьмо. Получается интересная ситуевина: 5-ый крикнул "Хочу в сортир!" - проц смотрит туда, а там двое. И кого выпускать?! Вот, и выходит, что "папу" клинит, а кто-то штаны испортил. Сбой заказывали? В случае со звукарями - это дикий ор на весь дом. Винда в силу своих скромных возможностей это дело отлавливает и метит большими восклицательными знаками (смотри конфигурацию в "Панели управления").

А что такое DMA?

Еще одна милая зверюга из нашего зоопарка. Это Direct Memory Access (прямой доступ к памяти). Получить доступ к устройству можно с помощью прерывания (дернув проц) или прямого доступа к памяти. Первое связано с большими растратами процессорного времени на сохранение текущей работы, переход на обработку прерывания и восстановление текущей работы. Прямой доступ работает намного быстрее. Берем старый добрый DOS. Если кто-то программировал под него графику, то помнит, что это возможно было двумя способами: прерывание и прямой доступ к видеопамяти. Так вот: второе работало в 100 раз быстрее. DMA тоже ассоциируются с устройствами по номерам. Они, обычно, тоже выставляются "по умолчанию". Хочешь на них посмотреть? Топай в "Панель управления", далее в "Систему", выбирай прокладку устройства, возьми чего-нибудь из списка (например, саундкарту) и поюзай цапу "Свойства". В прокладке "Ресурсы" расписаны диапазоны памяти, номер прерывания и номер канала DMA.

Почему я не могу загрузиться с винта? С дискеты и компакта комп грузится без проблем, а с винта не может.

Эй, чувак! Мы против этих самых, как их? Холод, чего мы вчера ели? В общем, перец, не надо грузиться с винта! И вообще не надо грузиться! Я тебе лучше сказку расскажу. Буквально недавно, я настраивал один комп. Я полчаса просидел над ним, решая эту же проблему. Я перековырял весь BIOS и перетасовал все шлейфы. После этого, я медленно встал со стула и быстро треснул себя по бестолковке. Надо просто запустить fdisk и выбрать активный раздел. Очень часто, когда торопишься, просто забываешь это сделать. Зато, потом перебираешь комп и находишь кучу недочетов в его сборке :).

Fdisk... Чего? Кого позвать?

Эй, космос, космос! Я вантуз! Спускайся на Землю. Я жду тебя по адресу C:\твоя_кул-дира_для_Винды\COMMAND\fdisk.exe Вот, посмотри на него. Это он! По хорошему, fdisk у тебя должен лежать на "спасательной дискетке", вместе с другими нужными утилитками, типа любимого format-а. Fdisk - это первая прога, с которой ты начнешь насиловать девственный винт. Она размечает логические разделы (C:, D:, X:, Z:) и делает один из них активным, то есть оставляет метку для BIOS-а, что систему нужно искать здесь. Только потом разделы можно форматнуть Format-ом.


Спецвыпуск Xakep, номер #012, стр. 012-113-17, HARD-FAQ

HARD-FAQ

Спецвыпуск Xakep, номер #012, стр. 012-113-17

Я воткнул себе второй винт, но он встал как slave, а я хочу сделать его мастером. Как? Может в BIOS-е поковыряться?

Ты фэн садо-мазо? Может у тебя винты в ошейниках с шипами и в намордниках :)? Не важно. Сделать из винта "ничтожество" можно специальным перемычками у него в попе. Удобно, да? Эти перемычки гнездятся между разъемом для шлейфа и розеткой для питания. Снизу винта должна быть схема, как их нужно ставить. С помощью этих перемычек сделай новый винт мастером (master), а старый - рабом (slave). Если у тебя оба винта сидят на одном шлейфе, то больше ничего делать не надо. Теперь основным будет новый большой и быстрый винт (и это правильно). Можешь смело включать комп и работать. Если у тебя стоит еще и CD-ROM (вот ужас-то!), и винты висят на разных шлейфах, то проверь, на каком висит новый хард. Он должен быть на «мастер IDE» (это написано прямо на "материнке" рядом с разъемом для IDE). Если нет - придется перевесить. А вот BIOS грязными лапами не трогай! На святое замахиваешься!

Почему у меня на винте написано "UDMA-100"? Что это значит?

Значит, что все нормально. UDMA-100 - это интерфейс у винтов такой. Проводя аналогию с дефачками, можно сказать, что такой винт целуется с шиной на скорости 100 Мгц. И это очень хорошо, так как винт работает на частоте шины (конечно, если ты еще не купил новую "мамку" с частотой 133 Мгц). Понимаешь, скоростной шины для быстрой работы компа недостаточно. Девайсы тоже должны быть быстрыми. Если устройства тормозят, то и вся система газует медленно.

Недавно я услышал, что винты тоже можно разгонять. Это правда? Что-то я не воткну, как можно гнать механику.

Ну, винт - это не сплошная механика. Из механикы там только движок, блины, да головки. Если заглянуть винту под юбку, то там полно электроники: память (ты представляешь себе механическую память?), чипчик для осуществления логики передачи данных, упреждающего чтения и куча другого барахла. В общем, винты действительно можно гнать, но больше его номинала ты все равно не выжмешь. Просто в некоторых винтах может быть понижена скорость вращения шпинделя с 7200 до 5400 оборотов, чтобы хард издавал поменьше шума. Для возвращения винта на максимальную скорость есть спец-утилы, которые без проблем можно скачать с сайта производителя винта.

У меня мамка на чипсете 440BX от Intel. Есть ли смысл покупать винт UDMA-100, если моя "мать" его не поддерживает?

Конечно же, смысл есть. Тайный, глубинный смысл. Тебе что, денег жалко? Ну, так разница в цене небольшая, а винт получишь круче. И он даже заработает! UDMA-33, UDMA-66 и UDMA-100 совместимы по разъемам (одинаковые они, и напильником работать не придется). Разница только в шлейфе. Для того, чтобы все пахало нормально на повышенных скоростях, пришлось засунуть в шлейф не 40 жил, а целых 80. Но данные передаются все теми же 40, а остальные используются как земля для создания экрана. Так что ты можешь спокойно подключать старые шлейфы к UDMA 66 или UDMA-100 винтам. Просто винт не будет работать на все сто процентов. Но ведь ты же не будешь сидеть на этой "мамке" вечно! Верь мне, лет через 5 ты ее поменяешь на новую, поддерживающую UDMA-100. Бери однозначно UDMA-100. Если сможешь, то бери и 200, и 300. Пулемет в хозяйстве всегда пригодится :).


Спецвыпуск Xakep, номер #012, стр. 012-113-18, HARD-FAQ

HARD-FAQ

Спецвыпуск Xakep, номер #012, стр. 012-113-18

Что такое северный и южный мост чипсета?

Это те самые удалые чипы, которые отвечают и контролируют работу целой "мамки". У них разделение труда. Например, в чипсете 440BX (наборчик от Intel для "мамок" под второй "Пень") северный мост (North Bridge) контролирует: проц, AGP-слот и память. Южный мост (South Bridge) отвечает за USB-, IDE-, ISA-шины. Как видишь, северный мост работает с памятью, а южный - с устройствами ввода-вывода. Поэтому начиная с i820 (следующий чипсет от Intel) мосты переименовались в Memory Controller Hub (раньше был северный мост) и I/O Controller Hub (бывший южный мост), или по-русски "Порт контроля памяти" и "Порт контроля ввода-вывода". Прогресс, однако. Как я уже говорил, "мосты" во многом определяют, что у тебя, собственно, за "мать".

Я вычитал в мануале, что у меня на "мамке" есть AMR-слот. Это что?

С виду, это маленький PCI слот, а реально - это полный сакс. В принципе, AMR есть во многих "мамках" на чипсетах i8xx. Им в южный мост встроен фуфлыжный звуковой контроллер AC97. Чтобы наделить это фуфло хоть какими-то дополнительными возможностями, сделали AMR-слот. В него можно вставить маленькую платку, которая расширит возможности AC97. Но этих плат практически нет, потому что даже с ней звук остается отстойным - он реализован программно за счет проца. Совсем забыл, в эту плату можно вставить и модем, который тоже будет работать программно (читай: голимо). Так что лучше забудь про AMR. Ничто не заменит настоящего SB-Live. А Intel надо треснуть тапком по голове - пускай вытаскивает это дерьмо из чипсета. Почему мы должны платить за него деньги?

Для чего нужен CNR?

Для того же для чего и AMR: для вытягивания бабла из юзверей. Это улучшенный вариант AMR-слота, который использовался совместно с южным мостом. Когда Intel доработала этот мост, там появись сетевые функции. Для их расширения и пришлось дорабатывать AMR до CNR. Эти слоты похожи, только CNR немного длиннее и в него можно засунуть платы расширения звука, модема и сетевухи. Даже если ты засунешь туда нечто из самых крутых плат, звук будет хуже, чем от самой дешевой полноценной звуковухи, да и твой проц опять будет излишне загружен. В общем, CNR - это вместо AMR (поменяли сакс на фуфел), но люди говорят, что видели извращения с обеими дырками на борту (кривой полет мысли производителя "мамки").

Что такое разрядность шины?

Разрядность шины - это сколько двоичных разрядов (битов) она может передать за такт. Не врубился? Ладно... Представь себе огромного грузчика Мишу. Взяли этого Мишу за яй... за ягодицы, нарядили в балетную пачку, вручили в руки большой совок. Поставили метроном. На каждый щелчок метронома Миша, отчаянно матерясь, должен совком перекладывать из одной кучи в другую единички и нули. Если к Мише добавить Колю и заставить их работать совками одновременно, то они перекинут за такт (щелчок метронома) в два раза больше единичек и нулей. Только по шине биты передаются упорядоченно в виде двоичных чисел. Чем больше двоичных разрядов влезает в шину, тем большие числа можно передать. В свое время из-за маленькой разрядности шины существовало ограничение на объем памяти в 640 Кб. Больше проц адресовать физически не мог, так как адреса ячеек просто переставали помещаться в шине. Сейчас стандартная PCI-шина передает 32 бита за такт.


Спецвыпуск Xakep, номер #012, стр. 012-113-19, HARD-FAQ

HARD-FAQ

Спецвыпуск Xakep, номер #012, стр. 012-113-19

Существуют ли 64-х разрядные PCI?

С добрым утром! Твой танк, похоже, отличается повышенной звукоизоляцией, полностью автономен и рассчитан на длительные погружения. PCI-64 уже давно уже тусуют в некоторых версиях "мамок". Но это не значит, что надо бежать, и менять свою "материнку". Устройств под эти PCI еще очень мало и производители железа не ломятся переходить на новый стандарт. А зачем усложнять себе жизнь? Можно, ведь, поднять частоту PCI-32 и срубить дополнительного бабла.

А можно ли засунуть в PCI-64 слот плату для 32-х разрядной дырки?

В принципе все можно. Были бы желание да инструменты :). 64-х разрядная версия PCI - это увеличенный вариант PCI 32, просто он немного длиннее, за счет дополнительных контактов. По конструкции они идентичны, и в PCI-64 ты без проблем засунешь, что угодно, хоть булку с маком :). По частоте, PCI-32 может быть только на 33 Мгц, а PCI-64 бывает 33 Мгц и 66 Мгц. Но это не главное. Основой несовместимости PCI является напряжение. PCI-64 может быть 3.3 вольтовой или 5 вольтовой. В 5-вольтовый слот можно засунуть любую плату, а вот 3.3 никогда не потянет 5-вольтовую карточку. Даже если тебя тошнит от доков на железо, определить, сколько потребляет твоя плата, очень легко. Если недалеко от крепежной планки есть вырез в контактах, то это плата на 5 вольтовских.

УФ! Я задал столько вопросов... Могу я теперь быть уверенным, что знаю всё о железках?

Нет, конечно. Каждые две недели новые стандарты появляются. Я тебе только самые общие вещи рассказал. Но, так или иначе, ты должен с чего-то начинать =). Так что, удачной охоты. Уверен, через пару лет ты будешь специалистом по ферруму.


Спецвыпуск Xakep, номер #012, стр. 012-124-1,

Дарова, перец! Скажи честно - тебе нравится наш журнал? А хочешь, чтобы он стал еще лучше Х? Тогда у нас к тебе одна просьба - заполни, пожалуйста, нашу анкету. В отличие от многих других журналов мы напечатали ее тут не для того, чтобы просто посчитать количество писем и выбросить их в корзину - нам действительно очень важно знать твое мнение. Потому что СПЕЦ мы делаем для тебя - а кто, как не ты сам, может знать, как сделать его еще более интересным тебе? Так что, боец, не упускай свой шанс сделать нас еще лучше - сегодня все в твоих руках. Просто ХХХ Верстальщику: начать болд ХХХ ответь ХХХ Верстальщику: закончить болд ХХХ на наши вопросы. И, конечно же, ты получишь приз: твой любимый СПЕЦ станет еще лучше!

Твой возраст

- До 10

- 10-13

- 14-15

- 16-17

- 18-19

- 20-21

- 22-23

- 24-26

- 27-30

- 30-40

- больше 40

Твой пол

- мужской

- женский

- другой _________________

Твое образование

- получаю среднее

- среднее

- среднее специальное

- получаю высшее

- высшее

- высшее специальное

- другое ______________________

Как часто ты делаешь апгрейд или что-то добавляешь к своей машине?

- раз в месяц-другой

- раз в полгода

- раз в год

- раз в два года

- еще реже

- у меня нет компьютера

Какую оценку ты бы поставил СПЕЦ-выпуску High-Tech?

- хуже некуда

- ниже среднего

- средненько

- выше среднего

- просто супер

- вообще не читал - полистал у прилавка и решил, что мне это не интересно

- не смог купить - все разобрали

Что тебе понравилось в СПЕЦ-выпуске High-Tech?

_____________________________________________

_____________________________________________

_____________________________________________

Что тебе в нем не понравилось?

_____________________________________________

_____________________________________________

_____________________________________________

То же про тот СПЕЦ, который ты держишь в руках?

- хуже некуда

- ниже среднего

- средненько

- выше среднего

- просто супер

- не хочу читать и вот-вот выкину

Что тебе понравилось здесь?

_____________________________________________

_____________________________________________

_____________________________________________

А что не понравилось?

_____________________________________________

_____________________________________________

_____________________________________________

Ты бы хотел, чтобы журнал был более (можно отметить несколько вариантов):

- информативным и познавательным

- юмористическим и развлекательным

- более компьютерным

- менее компьютерным

- таким, какой он есть

- вообще закрывайтесь на фиг

- твой вариант ответа ___________________

Каким темам нам посвятить следующие СПЕЦ-выпуски (отметь все интересные тебе)?

- эротика и порнография

- мобильность (телефоны, беспроводный инет, наладонные компы и т.д.)

- мистика, религия, эзотерика

- софт (новейшие проги для жизни и работы)

- Х - стиль (что есть и будет модно в цифровом веке)

- Х - отдых (обзоры кино, музыки, развлечений)

- новейшие технологии обработки звука и видео

- методики мелиорации и химобработки суглинков в районах крайнего Севера

Предложи свои темы номера - и весь СПЕЦ-crew собьется с ног, готовя для тебя самые эксклюзивные и интересные материалы:


Спецвыпуск Xakep, номер #012, стр. 012-124-2,

_____________________________________________

_____________________________________________

_____________________________________________

Просто выскажи нам свои пожелания:

_____________________________________________

_____________________________________________

_____________________________________________

Расскажи немного о себе:

Фамилия, имя: _______________

Ник: ___________________

E-mail: ____________________

ICQ UIN: _____________________

Home page: _____________________

Твои интересы: ________________________

___________________________________________

Ты работаешь/собираешься работать в сфере _______________

______________________________________________________

Как жизнь? _____________________________________________

_____________________________________________

Почтовый адрес (с индексом):

_____________________________________________

_____________________________________________


Спецвыпуск Xakep, номер #012, стр. 012-125-1, Made by Vasiliy Pupkin, или паяем девайс для компа

Made by Vasiliy Pupkin, или паяем девайс для компа

Спецвыпуск Xakep, номер #012, стр. 012-125-1

Иван Иваныч aka Mr. False (mr_false@xakep.ru)

Дарова, помидорчик (перец уже приелся как-то ;))! Эх, девайсы, девайсы... Целый спец забит оными творениями мозгов человеческих. А ты не пробовал сам спаять свой собственный? И не надо в меня тяпками кидаться, создание девайсов - занятие не такое уж и геморное, особенно для таких заслуженных работников паяльника и канифоли, как ты. Не веришь? Доказать? Ну, бери Хспез в руки, комп - под мышку, паяльник - в зубы, и - вперед! Задавим рынок своими поделками! =)))

Лет зе девелопинг бегин

Сперва... А сперва - не совсем интересная, хотя и обязательная вещь. Теория. Во-первых - разберемся, что же будем паять. А паять мы будем простенький девайс для ISA-слота, который будет мигать светодиодами под управлением написанной нами же проги. Ну, что приуныл? Мне просто места не хватит объяснить схемы посложнее, да и сначала нужно сварганить нечто совсем простенькое. И еще надо изучить кучу инфы по самому слоту.

ISA - аббревиатура от Industry Standard Architecture (промышленный стандарт архитектуры). Шина впервые применена в самых первых моделях PC и, по совместительству, является первой шиной расширения (т.е. такой шиной, в которую можно пихать всякие левые девайсы типа аудиоплат и прочей фигни). В XT-шках применена восьмибитная шина (с разрядностью данных 8 бит - отсюда она получила название ISA8) и разрядностью адреса 20 бит. В более поздних моделях, начиная с AT, применена модель ISA16, которая имела разрядность данных 16 бит и адреса - 24 бит. За ней следуют различные зверушки типа EISA (Extended ISA), ISA PnP (прегеморройнейшая вещь, надо заметить, хотя до геморроя PCI ей далеко)... Про PCI и VLB молчу сознательно - это штуковины из другой оперы. Инфа для общего развития: шина работает на частоте 8 Мгц, поэтому пиковая пропускная способность шины достигает для ISA8 - 4 мб/с, а для ISA16 - 8 мб/с. Также нам с тобой не обойтись без описания разъемов шин. Здесь я оные и привожу:

Вот что значат эти контакты:

+12в, +5в, -12в, -5в - питание

GND - земля

Data[7:0] - шина данных

Addr[19:0] - шина адреса

AEN - разрешение адресации портов

IOWR# - запись в порт

IORD# - чтение порта

SmemWR# - запись в память

SmemRD# - чтение памяти

IRQ9, IRQ[3:7] - запросы аппаратных прерываний (в смысл можно не врубаться =))

DRQ[1:3] - запросы каналов DMA (аналогично)

DACK[1:3]# - подтверждение запросов DMA

TC - признак завершения счетчика циклов DMA

IOCHRDY - готовность устройства

BALE - разрешение защелки адреса

Refr# - цикл регенерации памяти

IOCHK - контроль канала

Reset - сигнал аппаратного сброса

Bclock - синхронизация шины ~8Mhz

OSC - несинхронизированная частота ~14,431818 Mhz

Недвусмысленно с исподвыдпорпердом

Вот так вот, незамысловато. Как это все фурычит? Хехст, да очень просто! Есть такая инструкция процессора: "out dx, al". Именно через нее осуществляется работа с внешними устройствами. После выполнения инструкции на шине адреса появляется число, которое выставлено в регистре dx, а на шине данных - что лежит в al. Просто? Просто! Эту фиговину, как предвидится, мы вставим в свою программу (драйвер девайса, екерны бабай! =)). Что у нас виднеется на других выходах, нам не важно, не так ли ;))?


Спецвыпуск Xakep, номер #012, стр. 012-125-2, Made by Vasiliy Pupkin, или паяем девайс для компа

Made by Vasiliy Pupkin, или паяем девайс для компа

Спецвыпуск Xakep, номер #012, стр. 012-125-2

Конец моим страданиям и разочарованиям...

Собственно, производство. Что тебе придется где-нибудь скоммуниздить:

1)Руки без изгибов в непредусмотренных местах. И драйвер к ним. Смело используй свои, если они таковыми являются, или позаимствуй у товарища на время.

2)Небольшое количество сероватого (пока еще) вещества в черепной коробке (бедный товарищ... Он так вопил, когда его везли делать лоботомию...).

3)Древняя ненужная/нерабочая плата для ISA-слота. Стырь у товарища его любимую звуковушку. Или в подвальной фирме позаимствуй. Отдадут. Проверено.

4)Паяльник. Рабочий (желательно). Компонент в паре с первым дает потрясающий результат. Водится у радио(не)любителей.

5)8 светодиодов. Цвет значения не имеет. Главное, чтобы вольтаж был в диапазоне 3...5 вольт (а то попались мне однажды такие: подаешь 3 вольта - а они горят голубым пламенем =)). Радиомагазин/барахолка тебе в помощь. И децл бабла не помешает.

6)Восьмижильный шлейф, длина примерно 20 см. Помойка или IDE-шлейф в компе друга - выход из проблемы. Надеюсь, ты догадаешься, что можно взять "более жильный" шлейф и отделить от него те самые 8 проводов =)?

7)Микросхема К155ЛА3 (можно взять К155ЛН1), 2 шт. Приобретается за энное количество бабушков в радиомагазине.

8)Ножницы по металлу. Можно - ножовку по металлу. Циркулярка тоже подойдет. Или бензопила... Бери колун - не ошибешься. Добывается на даче у другана либо в кладовке у предков.

9)Комп, который было бы не сильно жалко сжечь =)))... Не дрейфь! Если у тебя действительно есть пункт н1 и н2, то ты этого с уверенностью 99% избежишь. А 1%... Ну, чего в жизни не бывает. :-\\ Во всяком случае, для таких зверских экспериментов с последним достижением науки я давно приобрел себе четверку за 400 тугриков деревянных (которая до сих пор не сгорела - это с моими экспериментальными компами случается крайне редко =)).

Будем считать, что ты человек честный ("Ну и наивный же ты, Мнимый", - подумают некоторые особо честные читатели) и все вышеперечисленное добыл.

Приступаем к изготовлению.

Терпение и труд...

Делать мы будем простенькую платку. Я бы даже сказал, не платку - а так, пучок проводов, который будет мигать светодиодами, показывая состояние шины данных. И убери подальше тухлые помидоры. Хочешь паять ультракрутой ускоритель воксельной графики - фраг тебе под ноги. А коли не можешь - слушай. Бери в одну руку древнюю/другановскую/нерабочую плату, в другую руку - ножницы по металлу и очень аккуратно отрезай от самой платы часть с контактами, которые заботливо пихаются в сам слот. Оставь жить с контактами примерно еще миллиметров пять-десять самой платы, чтобы не развалилась. Было бы замечательно, если бы ты догадался оставить с платой еще железку, которая обычно закрывает дырку в корпусе компа - так удобнее держать ее будет, поверь.

Далее нужно каким-то образом присандалить шлейф к остаткам платы с контактами. Обычно это делается паяльником и прямыми руками, а как это сделаешь ты... В общем, неважно. Важно то, чтобы ты ее присандалил куда надо. А "куда надо" - это, заметь, сторона А слота, контакты 2...9. Зри в корень. То есть в фотку:


Спецвыпуск Xakep, номер #012, стр. 012-125-3, Made by Vasiliy Pupkin, или паяем девайс для компа

Made by Vasiliy Pupkin, или паяем девайс для компа

Спецвыпуск Xakep, номер #012, стр. 012-125-3

Еще нам нужно питание. Это 5 вольт и земля, которые... Лезем в таблицу, смотрим. Ага, сторона Б, контакты 1,3. Готово? Ай, молодца! Теперь все это дело присобачь к плате. И куда надо, заметь!

Можно было бы теперь все это дело напрямую к светодиодам зафундучить, но вот тогда получится редкостный отборный рыхлый отстой. А все почему? Потому что у комповных микросхем логика КМОПовская. Шо це КМОП? Объясняю популярно. В цифровой электронике сосуществуют несколько типов логики. И среди этих типов особо выделяются два основных: ТТЛ и КМОП. Вас ист ТТЛ? Дас ист Сакс.. ТТЛ - Транзисторно-Транзисторная Логика. Все микросхемы серии 155, 555, 1533 и им подобные - именно этого типа. Отличительные черты сего: ТТЛ очень стабильна (по сравнению с КМОП): то есть ТТЛ-ные микросхемы не так легко убить статикой, механическими нагрузками. Но... Они медленные. Максимальная рабочая частота, к примеру, 1533-й серии, составляет примерно 70МГц. И поэтому - сакс. А КМОП... КМОП - тоже не подарок. Статикой бьется - это просто не ходи купаться. КМОПовские микросхемы поэтому все время заворачивают в фольгу. От греха подальше. Но зато они быстрые. Очень. Такие быстрые, что аж описаться можно со страху. Максимальная частота 1550-й серии составляет около 150МГц. Для таких древних советских штуковин это весьма неплохо. Только вот получается, что у всех типов логики разные принципы внутреннего построения - отсюда и лезет всякая шняжка. Кто сказал, что у ТТЛ и КМОП одинаковые пороговые напряжения? То-то и оно. И весь жук зарыт в следующем: пороговое напряжение КМОП достаточно высоко, чтобы удобно различать "0" и "1" по яркости светодиода. Посему мы и вынуждены пропускать сигнал с компа через инверторы (если ты купил микросхемы К155ЛН1) или И-НЕ (наши с тобой любимые ЛАТРИшки). Благо, здесь сигнал ТТЛками будет воспринят правильно ("Проверено! Насекомых нет!" =)). Зри в готовую схему:

Далее: берешь какой-нибудь провод, зачищаешь у него 2 см и паяешь, как оно есть на рисунках. И вообще, все дальнейшие твои действия - на рисунках:

Теперь то же самое проделываешь со второй микросхемой (только номера шины данных и светодиодов другие). Это была пайка для ЛА3шек, для ЛНок ничем принципиальным не отличается, лишь ноги не те, поэтому разъяснять ничего не буду. Все, проехали. Как паять светодиоды? Тоже просто. Берешь для начала один светодиод. Гнешь у него одну ногу (у которой внутренняя часть больше) на 90 градусов. Берешь второй и поступаешь с ним точно так же. Далее спаиваешь эти два светодиода гнутыми ногами. Берешь третий... И так - пока у тебя не получится такая цепочка из восьми светодиодов.

Ну, а теперь - последовательно припаиваешь оставшиеся ноги этих светодиодов к выводам микросхем. А общий паяешь на контакт GND (ряд Б, контакт 1). Хм... Все? Ай, хорошо! Тухлые помидоры в студию!! ПЛАТА ГОТОВА!!!!


Спецвыпуск Xakep, номер #012, стр. 012-125-4, Made by Vasiliy Pupkin, или паяем девайс для компа

Made by Vasiliy Pupkin, или паяем девайс для компа

Спецвыпуск Xakep, номер #012, стр. 012-125-4

Деееее - баг!

Еще раз убедись, что все спаяно правильно. И даже еще раз =). Проверь, что никакие контакты не замыкаются друг на друга. Ты уверен? Надежность - это сверхважно, ты сам понимаешь. Проверь все еще раз =). Аккуратно всунь плату в слот. Под микросхемы подложи какую-нибудь бумажку или свежий номер спеца, дабы на корпус не замыкало. Осторожно включи комп. Если в первую секунду работы не раздался взрыв и не полетели искры - то, значит, еще не все потеряно ;))! Уже сейчас, по идее, должны начать мигать светодиоды. Ежели они того не желают делать - многочасовая проверка и перепайка тебе помогут =). В противном случае можешь прыгать по всей комнате, хлопать в ладоши и помирать от внеземного счастья :))). Можешь смело нацарапать на плате что-нибудь вроде: "Made by C()0oJI ][axOp". Веселье кончилось.

Рутина: драйвер

Ну, писать мы будем не совсем драйвер, а просто прогу, которая будет управлять нашим с тобой творением. Прога сия будет представлять некий сырец на Борланд-Си для ДОСа с небольшими вкраплениями ассемблера. Собственно, вот ее исходник:

#include //Тут зарыта inport

void main() //тут начинаем

{char j=3; // это все равно что mov j, 00000011b

while (inport (0x60)!=1) //Пока не нажат ескейп

{for (unsigned int i=0; i<50000; i++) //особый вид задержки =)

{asm {//Вкрапления ассемблера

mov al,j //Заносим в al значение из j

mov dx,31337 //в dx - какой-нибудь несуществующий порт

out dx,al //выводим на плату... Хехехе... ;)))

}}

asm{ //еще вкрапления

rol j,1 //битовый сдвиг j влево

}}} //тут кончаем =).

Что это было? Ну вы, блин, даете...

Объясняю, что это было. Данная фигня, если ее набрать, закомпилить и запустить, будет показывать светодиодами нашего ультра-девайса бегущие огни =). Работает оно так: сначала в некую переменную j мы заносим значение 00000011, где единицы - это горящие светодиоды. Таким образом, у нас будут "бежать" рядом два "огонька". А далее - цикл, который повторяется, пока не нажат ескейп. Дело в том, что функция inport вводит значение из порта, указанного единственным параметром. А порт 0x60 - это порт контроллера клавиатуры. Он возвращает нажатую клавишу не в виде табличного значения, а в виде так называемого скан-кода. Ты уже просек, что скан-код ескейпа равен единице. Далее - особый вид задержки. Если бы мы сразу поставили вывод на плату, то мы бы получили беспорядочное мигание: глаз просто не успевал бы замечать, как загораются светодиоды. Как вывод сделан, я думаю, понятно. А вот что есть rol? Rol - это инструкция, которая выполняет битовый сдвиг влево. К примеру, в j лежит число 01100000, мы его сдвигаем, получаем 11000000, далее 10000001, а затем 00000011. Теперь ясно? Вот и славно. Компиль, запускай, наслаждайся ;))!

Засим я и закругляюсь

Вот так, теперь у тебя есть твоя собственная плата для компа. Можешь повесить ее на стенку и молиться на нее по утрам =). Все! Я пошел спать! =))))

З.Ы. Ушел. И обещал вернуться! =))

З.З.Ы. Слабо сделать еще проверку на адрес платы? =)