Спецвыпуск Хакер, Содержание номера # 006

ЖУРНАЛ ХАКЕР
Cover 006 |
Статья | Стр.
ПАЯЛЬНИК |
МЕТАЛЛОискатель по-новому | 004
Антиаон | 009
Зюзюкайдер | 010
Карманный лазерофон | 014
Снежная баба солюшненз | 016
Тяжело в учении - легко в очаге поражения |
Министерство обороны | 018
Почтовые бомбы | 022
Министерство путей сообщения | 026
Сканируя сеть | 030
Наш ответ РС магазин | 032
Как мне впарили трояна | 036
Дружба Аси и Линукса | 038
Генератор зла | 040
Вечерний звон | 044
Клип? Легко! | 048
Как добываются пароли | 052
Сетап легальный убивец | 054
Крякер инета | 056
Бест оф уеар | 059
Запахумор |
18 способов автозападла | 076
Новогодние подарки |
Порноссылки | 078
Кока-кола и её конкурсы | 081
Таксофоны | 082
Халявный нет легально | 086
Социум |
Как стать Дедом Морозом | 088
Трансформер | 090
Мозговые стимуляторы | 092
Я механист | 094
Лучшие шаровары за год | 096
Х-гороскоп | 125


Спецвыпуск Хакер, номер #006, стр. 006-004-1, Статья: найди танк у себя на даче.

Статья: найди танк у себя на даче.

Спецвыпуск Хакер, номер #006, стр. 006-004-1

Технические решения Доктора Добрянского (Dr.Cod@online.ru)

Почему надо собирать этот металлоискатель?

Да потому, что это единственный металлоискатель, который работает. Ты, наверное, видел много схем в интернете и в разных книжках. Они либо слишком сложные, либо содержат сложные элементы: подстроечные катушки, переменные емкости... Словом, там нечего делать без осциллографа. Обычно в таких схемах очень мало пояснений и нет никакой уверенности в том, что это чудо когда-нибудь зафурыкает.

Мой прибор проверен и собран мною лично в нескольких вариантах. Он прошел испытания в боевых условиях при участии членов редакции. Каждый шаг объяснен - подробнее не бывает. Все схемы и модели рисовал лично я с работающих экспонатов. Ошибок нет! Проверено! Но в любом случае я на связи по почте, отвечаю в тот же день. Ничего не надо настраивать, не нужно никаких сложных приборов. Если даже ты не рубишь в электронике вообще, у тебя есть возможность собрать работающий прибор. Исключение для тех, у кого уши на языке - таких я буду консультировать лично. Ну а если ты и вовсе родился с паяльником ВМЕСТО...(бедная мама), то тебе не составит никакого труда собрать эту простую схему.

Чем надо запастись:

Электронные компоненты.

1. Пальчиковые батарейки 1,5 вольта -4шт. (4х5руб.)

2. Твоя любимая микросхема 155 ЛА3. -2шт. (2Х5руб.)

3. Конденсатор 10nf (наноФарад), 12в (вольт) - 3шт. (бесплатно на помойке либо 3х3руб.)

4. Конденсатор 15nf, 12в -2 шт. (помойка/ 3Х3руб.)

5. Конденсатор 68nf, 12в -2шт. (помойка/ 3Х3 руб.)

6. Регулятор, резистор 470 (Ом) - 2шт (помойка/2Х5руб)

7. Любой стеклянный диод из старого лампового телевизора - 2шт. (помойка/ 2Х3 руб.). Можно какой-нибудь КД-409, главное кремневый и высокочастотный.

8. 62 метра лакированной медной проволоки диаметром 0,2-0,4 мм. (абсолютно бесплатно) (см. ниже)

9. Наушник от плеера - 1шт. (сосед)

10. Шнур от телефонной пружинкой -1шт. (сосед)

11. 3 метра телевизионного провода или шнур от магнитофона (см. ниже). (3Х2руб./ сосед)

12. Электропереключатель (тумблер) - 1 шт. (12 руб./помойка).

13. Разноцветные телефонные проволочки, из которых дети плетут колечки (дети/помойка).

Неэлектронные компоненты.

1. Скотч или пластырь. (до 3х руб./медпункт)

2. Мыльница (для мыла) квадратная - 1 шт. (6 руб./ванная)

3. Черенок для швабры деревянный - 1 шт. (20 руб./уборщица)

4. Пяльцы для вышивания 16-20 см пластмассовые - 1 шт. (14-20руб./бабушка)

5. Пластиковая бутылка - 1 шт. (ближайшая палатка)

Инструменты.

1.Паяльник 40 ватт 220 вольт с возможностью регулирования подогрева.

2. Напильник, кусачки, пинцет, плоскогубцы, канцелярский нож.

3. Флюс, для работы с жестью.

4. Вольтметр (необязательно).

Датчик.

Датчик будет в виде катушки. Удобней всего катушку мотать на пяльцах. Пяльцы для вышивания - это два обруча, вставленные один в другой, с возможностью зажима. Раньше девушки натягивали в них ткань и вышивали. Сейчас девчонки ходят по дискотекам, так что пяльцами воспользуемся мы.

На внутреннем обруче есть желобок. Туда очень удобно наматывать тонкую проволоку. Проволоку можно найти, разобрав трансформатор, вентилятор, электробритву или другое устройство, в котором есть мотор. Я просто выломал катушку из телика на помойке. Хватило витков на 30. После того как катушка смотана, надеваем внешний обруч и затягиваем его. Выводы катушки должны торчать наружу.


Спецвыпуск Хакер, номер #006, стр. 006-004-2, Статья: найди танк у себя на даче.

Статья: найди танк у себя на даче.

Спецвыпуск Хакер, номер #006, стр. 006-004-2

ХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХ

Фотография: "Пяльцы в сборе"

Фотография: "Пяльцы в разборе"

ХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХ

Пяльцы удобно с помощью горлышка от пластиковой бутылки закрепить на черенке от швабры. Такая катушка хорошо обнаруживает предметы размером от крупной монеты до танка на большом расстоянии.

Как подсоединить катушку?

От катушки до мыльницы с прибором должен идти экранированный кабель. Экран- это такая металлическая оплетка, которая предотвращает помехи. У катушки должно отходить два телевизионных кабеля. Жилы припаяй к двум выходам катушки. А оплетку нужно будет припаять к минусу батарейки. Вместо телевизионного кабеля удобно использовать экранированный стерео кабель от старых магнитофонов.

Чтобы припаять медную проволоку к катушке, нужно снять с нее сначала лак. Это можно сделать ножом или напильником. Будет удобно, если ты как я припаяешь к катушке два маленьких разъема от автомобильного аудио. Тогда катушка будет съемной.

Наушник.

Определять металл ты будешь на слух. Если есть что-то металлическое, то звук либо изменится, либо пропадет вообще. Чтобы это все услышать, нужен наушник. Я припаял обычный банан от плеера к проводу от телефонной трубки. На вид это выглядит просто космически.

Сборка устройства.

После того, как ты собрал катушку и наушник, можно приступать к сборке самого прибора.

Возьми мыльницу и прорежь канцелярским ножом в боковой стенке три круглых отверстия для регуляторов и тумблера. Эти детали надо выломать из старого телевизора на помойке. Тумблер может быть любым. Реостаты должны быть графитовые 470 Ом. Еще бывают проволочные, они более грубые. Если ты нашел реостаты только на 1К (килоОм), 2, 3 или 20, то можешь просто параллельно припаять к каждому по сопротивлению 510 Ом. Главное, чтобы реостаты были одинаковые, одного номинала.

Батарейки нужно спаять последовательно (одна за другой). Для этого необходим специальный флюс. Флюс - это присадка к припою (олову). Обычной канифолью (это тоже флюс) ты не сможешь припаять провод к жестяной бляшке батарейки. Специальный флюс можно купить в любом радиомагазине. Все поверхности надо перед пайкой зачищать напильником.

Чтобы не мучиться с припаиванием, можно купить держатель для батареек. Он очень дорогой, так что лучше его достать из какой-нибудь детской игрушки.

После того, как батарейки, регуляторы и тумблеры ты закрепил в мыльнице можно приступать к спайке схемы. Я припаивал микросхемы прямо на попец к реостатам с помощью специального флюса. При этом попа была минусом, вместо проволоки. Т.е. я припаивал к жестянке ноги 7, 11, 12, 13 каждой микросхемы.

ХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХ

Фотография: "Металлоискатель внутри"


Спецвыпуск Хакер, номер #006, стр. 006-004-3, Статья: найди танк у себя на даче.

Статья: найди танк у себя на даче.

Спецвыпуск Хакер, номер #006, стр. 006-004-3

ХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХ

Если мыльница из толстого пластика, то ты можешь разогревать паяльником медную телефонную проволоку и утапливать ее в пластмассе. Все будет держаться очень прочно и не надо никаких печатных плат.

ХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХ

Объемная модель: "Металлоискатель внутри" (met__1.jpg)

ХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХ

Алгоритм сборки схемы.

Удобно использовать при сборке схемы телефонную проволоку такого же цвета как н объемных моделях.

ХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХ

Объемная Модель: "Обозначения" (met__2.jpg)

ХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХ

У тебя есть две микросхемы, к ним подводим питание. Нога 14 - плюс через тумблер, ноги 7, 11, 12, 13 - минус. Ноги начинают считать слева от метки.

ХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХ

Объемная модель: "Питание микросхемы" (met__3.jpg)

Схема: "Питание микросхемы"

ХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХ

Теперь к минусу и ноге 8 припаиваем зеленый конденсатор 68nf. Этот конденсатор съедает помехи. К восьмой ноге припай один вывод переменного резистора. Два других вывода реостата соедини с ногой 1. Ноги 3, 4, 5 спаяй вместе. Это проделай с обеими микросхемами.

ХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХ

Объемная модель: "Подсоединение резистора" (met__4.jpg)

Схема: "Подсоединение резистора"

ХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХ

К первой микросхеме подсоедини красный конденсатор 15nf к ногам 1, 2 и ногам 6, 9, 10 (их удобней отогнуть вверх). Получился задающий генератор.

ХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХ

Объемная модель: "Задающий генератор" (met__5.jpg)

Схема: "Задающий генератор"

ХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХ

Ко второй микросхеме подсоедини такой же конденсатор к ногам 6, 9, 10. Другой выход конденсатора нужно соединить с катушкой. Вторая жила катушечного провода соединяется с ногами 1, 2 микросхемы. Катушка будет влиять на генератор, изменяя его частоту в зависимости от присутствия металла.

ХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХ

Объемная модель: "Чувствительный генератор" (met__6.jpg)

Схема: "Чувствительный генератор"

ХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХ

Нога 8 - выход каждого генератора. Соедини выходы генераторов коричневыми конденсаторами 10nf. Это нужно для того, чтобы сравнивать колебания задающего генератора, с колебаниями измененными катушкой-датчиком.

ХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХ

Объемная модель: "Соединение генераторов" (met__7.jpg)

Схема: "Соединение генераторов"

ХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХ

Теперь надо услышать эту разницу колебаний, для этого ставим два диода - детектора. И фильтр - третий коричневый конденсатор. Подсоедини наушник. Я даже не знаю, как зовут эти диоды - они очень старые, я нашел их в телевизоре на помойке. Такие, обычно бывают в металлических коробочках с катушкой. Они стеклянные с черным колечком на плюсе. Можешь использовать КД409 или любые другие стеклянные диоды найденные на свалке - главное, одинаковые. Чтобы узнать где плюс, а где минус, померь сопротивление в разные стороны. Диод пропускает ток только в одну сторону.


Спецвыпуск Хакер, номер #006, стр. 006-004-4, Статья: найди танк у себя на даче.

Статья: найди танк у себя на даче.

Спецвыпуск Хакер, номер #006, стр. 006-004-4

ХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХ

Объемная модель: "Полная схема" (met__8.jpg)

Схема: "Полная схема"

ХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХ

Теперь проверь все ли правильно припаяно. Пошевели все провода, не должно быть никаких расколбасов. Все должно быть жестко, проводки должны быть как можно короче. Вместо катушки соедини провода между собой и, покрутив регуляторы, добейся звука в наушнике. Если звука нет, то поздравляю, ты чего-то припаял не туда.

Если все ОК, то подсоединяем катушку, крутим ручки, и слышим звук. Теперь на улицу - испытывать устройство. С помощью ручек надо добиться самого низкого звучания, на нем больше чувствительность. Теперь, когда ты будешь подносить катушку к металлическим предметам, звук будет меняться, а потом вовсе пропадать.

ХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХ

Фотография "прибор в сборе" ХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХХ


Спецвыпуск Хакер, номер #006, стр. 006-009-1, Бутаритарский Анти Определитель Номера.

Бутаритарский Анти Определитель Номера.

Спецвыпуск Хакер, номер #006, стр. 006-009-1

В Бутаритарии (такая маленькая страна в тихом океане) среди местных хакеров очень популярна милая игрушка. Островитяне паяют такие на коленке из компонентов, найденных в мусоре, принесенном теплым волнами. Одно из таких вредоносных устройств изъяли у юного бутаритарского школьника работники Бутаритарской АТС.

По старой дружбе телефонисты попросили Х оказать помощь властям, объяснить как это работает и как это устроено. Ты уже понял, что срочно была создана техническая комиссия, под руководством сам знаешь кого.

Заключение комиссии

Для создания устройства необходимо три простейших элемента. Нужна кнопка на размыкание, реле с малым током срабатывания, и конденсатор.

Кнопку ставят в разрез обычной бутаритарской телефонной линии. Когда контакты замкнуты, устройство находится в нетерпеливом ожидании близости с пальцем. Как только жмешь на кнопку, контакты размыкаются, ток течет через реле. Реле срабатывает, отключает само себя от линии и опять срабатывает вновь и вновь, пока не отпустишь кнопку. Получается генератор зла. Конденсатор ставят, чтобы изменить частоту.

Хакеры звонят своей жертве и сразу после набора номера давят на пимпу. Реле выдает дикую помеху в линию, определить номер не удается. АнтиАОН срабатывает в 88% случаев. Все зависит от своевременности нажатия на цапу. Главное, чтобы вражеский АОН не успел определить номер, до или после генерации зла в линию. Также нужно подобрать правильную частоту помех с помощью конденсатора.

Данное устройство приносит большой вред оборудованию бутаритарских телефонных станций. АТС часто ломаются, и сами хакеры остаются без телефона. После чего входят в полугодовую депрессию, т.к. не могут слать своим подружкам, живущим на соседнем острове, открытки через интернет....

Да здравствует ИНТЕРНЕТ, гомосексуализму НЕТ!

Содержание


Спецвыпуск Хакер, номер #006, стр. 006-010-1, Оральный свет.

Оральный свет.

Спецвыпуск Хакер, номер #006, стр. 006-010-1

Подозреваемый #155ТВ1.

Имя: Донор.

Место жительства: lehun@mail.ru

Особые приметы: Прилично одет, причесан, побрит, делает вид, что воспитан. Уступает бабушкам место в общественном транспорте, т. к. не убивает на людях. В улыбке четко видны два клыка.

Характер: Всегда вежлив и обходителен, скрытен, изобретателен. Дела обделывает с едва заметным маниакальным удовлетворением. Падок на молоденьких девственниц, проявляет к ним серьезные гастрономические интересы.

Род деятельности: Вампиризм, охота на бабушек, шутки со смертельным исходом, шоковая терапия по адресу слабого пола, дизайн нервных тиков, повышение мощности визга.

Подозревается: В организации производства и распространения зизюкайдеров.

Мера пресечения: исправительные работы нянечкой в младшей группе детского сада.

Подозреваемый #155ЛА3

Доктор Код, он же Др. Добрянский

Место жительства: Dr.Cod@xakep.ru.

Особые приметы: Беспокойно бегающие сумасшедшие глаза, провода в неожиданных местах, пронзительный голос.

Характер: Вспыльчив, агрессивен, набрасывается на людей без видимых причин и делает им лоботомию бормашиной. Испытывает нежные чувства к паяльникам, радиодеталям и осциллографам с частыми вспышками женоненавистничества. Обладатель мирового рекорда по дисциплине "рытьё в радиопомойках".

Род деятельности: Электроника, психотроника, НЛО, полтергейст и пр. В свободное время трудится над созданием антистервина (лекарства от стерв).

Подозревается: В разработке и сборке Зизюкайдеров.

Мера пресечения (высшая): пожизненный запрет на доступ к радиодеталям, принудительное строгание матрёшек и роспись их под хохлому.

Плаг ит ин

Хэй, перец! Я точно знаю, что ты не раз мечтал с помощью какой-нибудь крутой девайсины мгновенно и без напряга стать суперсильным, пуперловким и гиперсексуальным. Но почему-то скряги-девелопперы не торопятся изобрести такую штуку, а тем более отдать её тебе за твою степуху. Приятель, да ты сам всё можешь сделать, и гораздо круче! А мы тебе поможем: без особых затрат и без хирургического вмешательства мы оборудуем тебя зизюкайдером.

Что такое зизюкайдер?

Это маленький но очень мощный фонарик, который легко помещается во рту и светит ярко-красным светом. Устройство крайне простое, но оно способно сделать тебя звездой вечеринки или дискотеки. А может быть, ты мечтаешь стать асом пикапа? Становись зизюкаером - суперчелом с кровавой радиоактивной улыбкой, и любая девчонка стремительно потеряет свои тонкие трусики от одного взгляда на тебя.

Как это было?

Вечер. На улице полумрак. Всё готово к охоте....

Бредёт себе по парку парочка, вяло как-то бредёт. Добавим немного адреналина! Слева и справа пристраиваются зизюкаеры, заходят немного вперёд, резко оборачиваются и... О ужас! "Вампи-и-иры!!!" Какие объятья! Эй, братишка, не задуши там её :).

Модяво прикинутый тусовщик выпендривается перед девчонками. Сейчас мы проверим, насколько ты крут. Загляни мне в глаза! Эй, куда ты? Какая "новая опасная болезнь"? Ты о чём?...

Навстречу в полутемной арке Александровского Сада дефилирует жирный форейнер aka иностранка. Вежливые зизюкаеры приветливо улыбаются заморской гостье... Сдавленный крик: "Oh, mine god!!!" Ну, поднимите же её кто-нибудь! Вся лужа из берегов вышла!


Спецвыпуск Хакер, номер #006, стр. 006-010-2, Оральный свет.

Оральный свет.

Спецвыпуск Хакер, номер #006, стр. 006-010-2

Какая удача: две бесхозные тётки гуляют по парку совершенно без присмотра! Грустные такие. Девчонки, что вы делаете сегодня вечером?... О мои барабанные перепонки! Откуда в этих тётках столько визга? :)

А эти две важные стервочки сначала столкнулись лбами, а потом одна процедила: "Вам очень идет".

На эскалаторе метро "Охотный ряд", проверяя оборудование, зизюкаеры отбили у перца даму сердца. Она, тряся кудряшками, долго орала в след: "Ребята, какие вы классные".

После серии экспериментов среди теток четко выделились три категории:

1) Фригидные, которым наплевать на все вокруг.

2) Эмоциональные, которые пугались, взвизгивали, подпрыгивали, отскакивали, бледнели.

3) Игривые, которые хихикали, строили глазки, и кончали при виде космической улыбочки.

Донор более симпатизировал эмоциональным, мечтая, что какая-нибудь обдуется со страха. Доктор отдавал предпочтение игривым, пытаясь наладить контакт между цивилизациями.

Как это сделать?

Электрическая схема - проще не бывает. Вся сложность тут в эргономике. Постарайся как можно внимательнее прочитать эти инструкции.

Прежде всего, подготовь пластмассовое киндер яйцо. Чтобы оно легко влезало в рот, его надо укоротить. Обрежь каждую половинку на полсантиметра, как на картинке.

Тебе понадобятся всего 5 деталей.

Два ультраярких светодиода на 2,5 вольта такие светодиоды стоят по 9 рублей, зато светят как мощные фонари и дают красные пятна на стенах.

Двойной дип-переключатель, какие ставят на модемы и компьютерный хлам, он стоит 6 рублей. Это единственный переключатель, который устойчиво работает в мокрых оральных условиях.

Батарея 9 вольт GP10A. Эта батарейка раза в три меньше пальчиковой и поэтому свободно помещается в яйцо. Многие думают, что диод просто сгорит от такой батарейки. У меня не сгорел ни один, зато они очень ярко светят. Стоит это 26 рублей.

Сначала проделай отверстия для переключателя и диодов. Рассчитай, чтобы переключатель оказался за передними зубами. Так он не будет мешаться и царапаться, не будет подмокать, и ты всегда сможешь незаметно переключить его рукой. Светодиоды должны сильно выступать по бокам, их выводы ты зажмешь зубами. Не бойся, током тебя не ударит.

Теперь собери простенькую схему. Трудность только в том, чтобы все аккуратно спаять внутри. Хотя можно и просто прикрутить скотчем. Длинная нога светодиода должна идти на плюс батареи. Если ты все собрал правильно, то зизюкайдер комфортно разместиться у тебя во рту. В крайнем случае, можно подогнуть светодиоды.

Поскольку переключатель двойной, можно сделать два режима яркости. Для этого на вторую половину переключателя поставь сопротивление в 7 килоОм. В этом режиме светодиоды не будут просвечивать сквозь щеки, и твоя улыбка будет внезапной.

В киндер яйце еще остается много места, в него можно запихнуть зуммер и еще одну батарейку. Таким образом ты будешь издавать оральный техногенный звон. Мы с Донором делали проще: зуммер прикалывали на булавке к воротнику. Незаметный провод шел через рукав к кнопке с батарейкой. Это позволило сильно сэкономить на деталях.


Спецвыпуск Хакер, номер #006, стр. 006-010-3, Оральный свет.

Оральный свет.

Спецвыпуск Хакер, номер #006, стр. 006-010-3

Тактика

План А. "Радиоактивные Прыщи". Врубай Зизюкайдер на полную мощность, и в рот! Теперь захлопни варежку, сделай очень серьёзную мину и прогуляйся по ночному городу. Спорим, за твоей спиной долго будут обсуждать, заразны ли радиоактивные прыщи? Плюсы: минимум напряга для тебя, абсолютно безопасно. Минусы: некоторым хоть кол на голове теши - не заметят.

План Б. "Голливудская улыбка". Ставь Зизюкайдер на малую мощность. Через щёки ничего не просвечивает. Выбирай, кто тебе приглянулся, и одари его своей лучезарной улыбкой. Плюсы: неожиданность, на такие любопытные фишки клюют тётки :). Минусы: необходимо как-то привлечь к себе внимание, сильного эффекта не жди.

План В. "Тошнотики". Включи мощный режим. Теперь прикрой рот рукой, чтобы не светился. Приближайся к жертве и резко оскалься. Плюсы: не заметить тебя невозможно, эффект бывает просто потрясающий. Минусы: чел с зажатым ртом выглядит подозрительно, Зизюкайдер мешает поржать вволю :).

План Г. "Вампирский". Зизюкайдер на полную. Найди укрытие рядом с траекторией полёта жертвы. Скалясь, выскакивай прямо перед ней. Можно высунуться частично. Чем ближе к жертве, тем лучше. Плюсы: жертву просто рвёт на части. Минусы: можно схлопотать осиновый кол в сердце.

План Д. "Плач малютки привидения". Поюзаем звучащую часть девайса. Приготовься: нащупай пимпу на звучалке. Теперь потренируйся: мимика должна совпадать со звуком. Рот раскрыл - пи-и-и! Иди в подземный переход, где тепло, сухо, а главное - гулко. Выбирай одинокую жертву. Дави на кнопель - жертва услышит напряжный звук, нервно обернётся и узрит ТЕБЯ :). А ты ей ещё пару ласковых пропищи. Плюсы: всеобъемлющий террор. Минусы: плохо работает в толпе (непонятно откуда звук, да и мало ли у кого там сотовый звонит).

План Е. "Зомби". Зизюкайдер на мощный режим. Выбери жертву и подходи к ней со спины. Только тихо! Сложи глаза в кучу и устреми свой отрешённый взгляд вдаль, оскаль рот. Теперь похлопай жертву по плечу. Пусть обернётся. А потом резко поворачивай голову в её (его) сторону с бешенным взглядом и можешь порычать для убедительности. Плюсы: план Е всегда поможет произвести резкую очистку организма... от грустных мыслей, да и вообще от мыслей. Минусы: инфарктники, откинувшие по твоей милости коньки, будут являться тебе по ночам и мешать спать.

Ну, я вижу, ты уже всё понял. Больше тебе сочных тёток, зашуганных ламерков и море веселья :) Вперёд!!!


Спецвыпуск Хакер, номер #006, стр. 006-014-1, Карманный Лазерофон Прозвонкина

Карманный Лазерофон Прозвонкина

Спецвыпуск Хакер, номер #006, стр. 006-014-1

Семинар в стиле Х

На семинаре сидит парень, в ушах бананы. Они всегда у него в ушах, все уже привыкли. Отличник на другом конце аудитории что-то шепчет в рукав, совсем заучился приятель. Вряд ли тупому преподу по физике может прийти в голову, что студенты собрали карманный лазерофон и сейчас отпускают в ее адрес грязные словечки. Да даже если ему дать его в руки, он не поймет, что это такое...

Историческая справка

Никогда не пробовал собрать что-то по схеме из книжки? Какой-нибудь придурочный звонок на 20 микросхемах? Два месяца ты ищешь детали, месяц все это паяешь, и ничего в результате не работает...

Но однажды после выхода очередного Х все дружно принялись глушить (нет, не водку) телеки... Мне пришла куча писем: одни хвалили глушилку, другие просто не верили, что такое может работать. Надеюсь, что до кого-то все-таки доперло, что крутые устройства можно собрать просто из подручных средств.

Наш СамГлавРед Покровский это понимает отлично. Еще бы! Он старый радиолюбитель, сам ZX-Spectrum паял (свой первый компьютер). Поэтому подошел он ко мне и сказал: “Надо, Федя, надо”. Нужны простые устройства, которые обязательно будут работать, и мы будем печатать именно такие. Ура, товарищи!

Детали лазерофона

1) Лазерная указка, которая тебе уже надоела.

2) Прокладка для водопроводного крана (и никаких крылышек).

3) Шуруп. Его закрути себе в лоб, чтобы задница не отвалилась.

4) Угольный микрофон от старого телефона.

5) Четыре пальчиковых батарейки.

6) Солнечная батарея от калькулятора или часов.

7) Старый плеер с наушниками.

8) Провода, скотч, чистые руки, которые растут откуда надо, а не откуда обычно.

Как сделать передатчик

Прежде всего надо подключиться к лазерной указке. Для этого вставь шуруп в водопроводную прокладку как показано на рисунке. Теперь засунь его шляпкой на пружину внутрь указки вместо батареек. Один провод засунь между резинкой и корпусом указки, другой прикрути к шурупу.

Скрути четыре пальчиковых батарейки скотчем и соедини их последовательно проводами. Осталось подсоединить между указкой и батарейками мембрану от телефона. Чтобы указка всегда светила, прикрути к ее кнопке скотчем спичку. Минус батарейки должен подаваться на шуруп, а плюс через микрофон на корпус.

Работает это очень и очень просто. Когда ты говоришь, меняется сопротивление угольного микрофона и яркость светодиода в указке.

Как сделать приемник

Принимать сигнал лучше на солнечную батарею от калькулятора, в нее легче попасть из указки на большом расстоянии. Если жалко калькулятор, отпили напильником шляпку у транзистора и свети указкой на кристалл, так транзистор будет работать как солнечная батарея. Как усилитель можешь использовать плеер, просто подсоедини выходы солнечной батареи к выводам его головки.

Конструкторское исполнение

Можешь подсоединить в цепь небольшой переключатель, чтобы включать и выключать указку. Все провода лучше припаять, но если с этим плохо, лучше просто прикрути их, а где не получится, добавь немного скотча (старого доброго английского скотча внутрь). Придумай, как закрепить мембрану на рукаве и куда деть связку с батарейками. Все это на твой личный вкус.


Спецвыпуск Хакер, номер #006, стр. 006-014-2, Карманный Лазерофон Прозвонкина

Карманный Лазерофон Прозвонкина

Спецвыпуск Хакер, номер #006, стр. 006-014-2

Факинг мануал

Нужно попасть зайчиком от указки на солнечную батарею. Когда ты говоришь в телефонную мембрану, твой приятель слышит твой голос в наушниках очень четко. Для этого его плеер должен быть включен. Специально для космонавтов: “Нажми кнопку PLAY!”. Передается отлично даже шепот. Вообще лучше положить указку и солнечную батарею на подставку, хотя если потренироваться, можно держать все это на весу. Если тебе удастся хорошо прицелиться, то ты сможешь трепаться со своим приятелем или приятельницей в доме напротив через окно.

Ответственность

Редакция и Прозвонкин не несут ответственности за сожженные указки, плееры и раскуроченные калькуляторы. У меня все это работало и продолжает работать, и я не виноват в том, что у кого-то при инсталляции руки с ногами перепутали или мозги недопатчили.


Спецвыпуск Хакер, номер #006, стр. 006-016-1, Снежная Баба V.1.0. ОЕМ solution

Снежная Баба V.1.0. ОЕМ solution

Спецвыпуск Хакер, номер #006, стр. 006-016-1

Александр '2poisonS' Сидоровский (2poisonS@xakep.ru)

Привет тебе, мой маленький неопохмелившийся друг! Или уже опохмелившийся? Как еще не пил? Новый год же... Праздник. Новый Миллениум, старый Линолеум. А в конце концов - не так уж и важно, наступил этот гребаный Линолеум или не наступил - проблема 2001 года нам вроде бы не грозит. А вот конкретные баги после всего выпитого в новогоднюю ночь - это неизбежно как счет провайдера, и с этим надо бороться. Бороться мы будем путем изготовления хацкерского девайса под названием Баба Снежная v1.0. Специально для тебя мы приготовили нижеследующую подробную инструкцию.

Читайте доки, они рулез!

Итак, для инсталляции девайса Баба Снежная V.1.0. в стандартной ОЕМ-комплектации нам понадобятся:

1. Снег - 1-1,5 м?.

2. Морковь - 1 шт.

3. Шарики от манипулятора типа "мышь" - 2 шт.

4. Метла или швабра - 1 шт.

Из инструментов и расходных материалов нам понадобятся:

1. Руки прямые - 2 шт. (можно четыре, допускаются одна или три).

2. Пиво охлажденное - мин. 4 л. (лучше - больше, то есть много).

Количество комплектующих дано из расчета на одну Бабу Снежную.

Рекомендации по отбору комплектующих девайса

Снег желательно брать чистый, свежий, характерного белого цвета. Запомни! Никогда не используй для изготовления Бабы Снежной снег желтого цвета! Это может привести к крайне нежелательным последствиям как для изделия, так и для тебя. Проверь снег на наличие посторонних инородных предметов и, при обнаружении таковых, удали их, не пробуя на вкус или цвет. Перед тем как начать изготовление Бабы Снежной, протестируй снег следующим образом. Возьми небольшое (100-150 гр.) количество снега и попытайся с помощью Рук Прямых сделать из него сферообразный объект. Если снег легко принял желаемую форму и сохраняет ее в течение долгого времени - это означает, что материал пригоден для изготовления Бабы Снежной. Если же сферу сделать не удалось, нужно заменить либо снег на более липкий, либо руки на более прямые.

Морковь должна быть довольно крупной, прямой и очищенной. Напоминаю - требуется только ОДНА морковь, поскольку мы изготавливаем снежную бабу, а не мужика. При недоступности необходимого материала допускается использование джойстиков, фаллоимитаторов и других предметов в форме моркови. Ботву с овоща перед изготовлением необходимо удалить (на джойстиках и фаллоимитаторах ботву можно оставить).

Шарики от манипулятора типа "мышь" подойдут любые. Фирма-производитель манипулятора, страна-производитель, а также порт подключения в данном случае роли не играют. Нам поступали сообщения о том, что лучше всего при изготовлении Бабы Снежной себя показали шарики от мышей на USB, но проверить эту информацию оказалось весьма затруднительно. Перед использованием шарики нужно протереть спиртом, оставшимся после Нового года, - это придаст Бабе Снежной неотразимый блеск в глазах.

Инструкция по сборке и подключению Бабы Снежной v.1.0

1.0. Использовать внутрь компонент ПИВО.

1.1. Повторно использовать внутрь компонент ПИВО.

1.2. Выйти на улицу и выбрать подходящую площадку для инсталляции девайса Баба Снежная V.1.0. Площадку нужно выбирать с учетом доступности материала для изготовления Бабы и точек для освобождения от отработанного компонента ПИВО. Сооружение Бабы Снежной можно легко превратить в западлостроение, если в качестве площадки выбрать проезжую полосу, особенно в том месте, где наш снежный девайс окажется неожиданным для водителя.


Спецвыпуск Хакер, номер #006, стр. 006-016-2, Снежная Баба V.1.0. ОЕМ solution

Снежная Баба V.1.0. ОЕМ solution

Спецвыпуск Хакер, номер #006, стр. 006-016-2

1.3. На листке бумаги сделать набросок предполагаемого дизайна Бабы Снежной. Если ты не помнишь, какой дизайн бывает у баб, распечатай несколько джипегов с любого порносайта - там возможные варианты дизайна представлены довольно разнообразно.

Теперь, когда ты приблизительно представляешь себе, как выглядит существо женского пола (а именно им и является наше будущее изделие), уясни несколько основных принципов анатомии Бабы Снежной. На распечатанной картинке с порносайта найди ноги и все что выше, до талии. Обычно это самая длинная часть тела у женщин. Так вот: эта часть будет представлена у нас самым большим снежным шаром. Меньшим шаром будет представлен кусок туловища от талии до шеи, и, наконец, самым маленьким снежным комом у нас будет голова. Других физиологических подробностей мы касаться не будем, так как собираем Бабу Снежную V.1.0. в стандартной ОЕМ-комплектации. Если ты хочешь изменить условия сборки и долепить что-нибудь еще - пожалуйста, особенно если к этому располагает скачанная тобой картинка.

1.4. Скатать первый (самый большой) ком (возможно параллельное использование остатков компонента ПИВО). Ком - это большой эллипсоид круглого вида, похожий на шар (style (с) by Dr.Dobryansky). Ком должен получиться округлый (чем круглее, тем лучше) и нерассыпчатый. На этом этапе сборки конструкцию можно модифицировать. Берешь несколько кирпичей или аналогичных тяжелых предметов, складываешь их в полиэтиленовый пакет (и то и другое можно взять на ближайшей помойке) и облепляешь снегом. Потом уже из этой основы скатываешь снежный ком. Этот небольшой твикинг рассчитан на деструктивных ублюдков-приколистов, любителей пнуть изо всех сил ногой любое произведение snow-мейкерского искусства. После нашей небольшой оптимизации Бабы Снежной любая такая попытка несанкционированного пинка наткнется на небольшой троян.

1.5. Повторить пункт 1.4., то есть создать еще один ком, но поменьше. Его величина будет зависеть от размера первого шара (или ног, как угодно) и должна составлять 60% от объема шара-основания. Так как наша Баба Снежная будет стоять, а не лежать (независимо от того, что делает ее прототип с инетовского джипега), второй шар устанавливается на первый. Это грудь. Красиво? Не расслабляйся, у женщин бывает еще и голова. Выпей оставшееся пиво, сборка близится к завершению.

1.6. Слепить последний, самый небольшой шар, который у нашей Бабы Снежной будет символизировать голову. Инсталлируй голову на предыдущую комплектующую и убедись, что она крепко держится. Грубая работа завершена, осталось придать подруге индивидуальность.

1.7. Возьми два шарика от мышей и морковь. Прикинь, где у нашей Бабы будут глаза, а где нос. Убедительная просьба - коннектить шарики и морковку только к верхнему (головному) шару. Если на той картинке, которой ты руководствовался при определении дизайна, морковка органично вписывалась в другую область тела, убедись, что ты зашел на правильный порносайт, а также в традиционности своей сексуальной ориентации. Как только ты определил места расположения финальных комплектующих, инсталлируй их, и можешь считать процесс завершенным. А вообще - юз ё имаджинейшн.


Спецвыпуск Хакер, номер #006, стр. 006-016-3, Снежная Баба V.1.0. ОЕМ solution

Снежная Баба V.1.0. ОЕМ solution

Спецвыпуск Хакер, номер #006, стр. 006-016-3

2.0. Притащи из дома фотоаппарат, щелкни Бабу Снежную в разных ракурсах и пришли фотки к нам в журнал. Самые прикольные снежные бабы будут вывешены на нашем сайте www.xakep.ru. С Новым годом! Удачного снего-бабо-строительства.


Спецвыпуск Хакер, номер #006, стр. 006-018-1, Министерство обороны

Министерство обороны

Спецвыпуск Хакер, номер #006, стр. 006-018-1

Макс Зелененко ( maxx@xakep.ru )

Михаил Терехов ( stranger@xakep.ru )

Детство героя

Когда мы с тобой, братишка, были мелкими и противными, то жуть как любили поиграть в войнушку. Что, запамятовал, как кричал "дых-дых-дых - ты убит"? А когда сосед Вован преследовал тебя с пластмассовой саблей, и ты упал в канаву с крапивой, и животик был бо-бо, помнишь? Да я понял, что тебе это уже все параллельно, ведь ты реально проявился во время разделения сфер влияния в дворовой песочнице! Тогда ты отбил у врага два совка, куклу без бошки и палку-копалку. Я горд за тебя!

Потом всех врагов забрали в детсад имени Кащенко, в математические спец школы и в армию. Но куда адреналин девать?! А вот тут в твои шаловливые ручки попал комп с Инетом. Поначалу просто офигев, ты начал тусить в чатах. И подготовленный профессором Левински, принялся кадрить всех девочек. И вот уже дела идут неплохо, девочка ведется... но враги не спят, они сидят и думают, как бы тебе весь кайф обломать. И вот ты уже достал все нюки, бомберы и принялся учить жизни негодяев. Но девочку-то ты нормальную, не из Физтеха, разводил, и она от тебя свалила, испугавшись, что ты ее саму ненароком замочишь в порыве сперматоксикозной страсти. Это не есть гуд. Успокойся. Возьми еще бутылочку Балтики и продолжай развод этой чиксы. А усмирением назойливых придурков - займется твое личное министерство обороны. Так что, братан, сними на время руку со сладких бедер подруги и подбери себе достойную оборону, а мы тебе в этом поможем. Мы подберем тебе рулезные проги, которые обезопасят твой комп и будут яростно отражать все атаки врага, пока ты занят разводом девок и просмотром обновлений на порно-серверах.

Вообще эти проги, кроме того что защищают тебя от нападений злобного кул хацкера, частенько занимаются многими другими приятными и полезными делишками. Это уничтожение троянов, убийство баннеров, закрывание всяких выскакивающих окошечек. Ну и все из этой оперы.

АТ Гвардия его Величества!

Одной из самых известных прог в области защиты компа юзера является AT-Guard. Сегодня в Рунете его юзает огромное количество хацкеров. Увидев эту прогу, ты просто подсядешь на нее, и желание чего-нибудь другого исчезнет, как презервативы из аптеки. Приятный интерфейс, да и вообще все понятно сразу. Понятно еще то, что во время работы она рожает на экране специальную менюшку, на которой до фига разных индикаторов, лампочек и тумблеров.

ХХХХХХ (вставить screen01) ХХХХХХХ

Вот так сидишь и думаешь, что попал в центр управления полетами. Тут тебе и активность трафика, и инфа об устраненных заподлянках.

Первоначально прога была сделана для борьбы с баннерами, кукисами, выскакивающими окошками, ява апплетами и прочими вражескими происками. Но потом создатели встроили в нее фаервол, который на сегодняшний день очень прилично реализован. Прога с этого дня защищает тебя от нюка, от подкинутых троянов, а также других подлостей. Кроме твоей защиты, программа умеет вести статистику и логи. Еще удобно то, что в саму прогу можно попасть кликнув правой пимпой твоего мышака на ее панели.


Спецвыпуск Хакер, номер #006, стр. 006-018-2, Министерство обороны

Министерство обороны

Спецвыпуск Хакер, номер #006, стр. 006-018-2

ХХХХХХХ (вставить screen02) ХХХХХХХ

Бей коней!

Если тебя думать совсем ломает, то есть очень удачные встроенные настройки, подключив которые, ты сразу почувствуешь себя в безопасности. А если хочется сделать элитарную настройку, эксклюзивно для себя, а думать все равно не захотелось, то тебе поможет удобный хелп. Для начала мы втроем защитимся от липких троянов, которые почтой прут твои пароли и отдают твой комп в лапы "администратора удаленной системы". С БО и Нетбасом прога разберется и без тебя, а вот о троянах, которые отсылают пароль от аськи, и прочих подстав - придется подумать самому. Чтобы отморозок, который подсунул трояна, попал в Обломинск, неплохо бы заткнуть открытые порты твоего компа. Для этого и думать не придется, ведь как только ты врубил фаервол, то все основные порты твоей машины закрыты. Вот теперь твои враги вместо халявного Инета пойдут мусорник выбрасывать, чтобы мама дала копейку на Инет. С этого момента ни одна прога не сконнектится с Сетью без твоего разрешения! Для начала мы с тобой оживим мылер, который с этого момента ничего не отсылает и уж точно - не получает. Для этого идем в Settings,

ХХХХХХ вставить screen03 ХХХХХХХ

в закладку firewall, и обнаруживаем рулесы для фаервола (Firewall Rule). Находим кнопочку "Добавить"(Add) и, нажав на нее, работаем...

ХХХХХХ вставить screen04 ХХХХХХХ

В закладке Applications выставляем адрес проги на винте. Закатываем название правила (матом, чур, не ругаться :)) и выдаем распоряжение фаерволу, чтобы пропускал трафик выбранной проги - Permit (пропускать). Ставим, когда выполнять правило - на входе Inbound или выходе Outbound (последнее нам сейчас подойдет). В случае с мылером выбираем протокол TCP. В закладке Service в подразделе Remote Service указываем Single Service и добавляем порт или сервис, на котором висит прога. Для мылера - pop3 (110) или smtp (25). Можно и сразу вместе (List of Service), но, например, у mail.ru серваки SMTP и POP3 - разные, и нужны две инструкции на получение и отправку отдельно. В закладке Address, подразделе Remote Address, в разделе Host Address - закатываем имя почтового сервака (в зависимости от того, что настраиваешь - прием или отправку почты). Остальное содержимое окошка оставляем без изменений или меняем по мере личных потребностей, жмем ОК и с криками беременного слона наконец получаем любимую почту. Эту операцию в разных вариациях тебе придется повторить со всеми прогами, которые ты собираешься использовать в Инете, иначе пахать у тебя они не будут. Только визжать от радости после 23-00 мы тебе не советуем, а то в милицейском рафике будешь рассказывать о защищенном трафике ;).

Если ты все же опасаешься за оборону, то почаще смотри в Статистику программы (Statistics в выпадающем меню),

ХХХХХ вставить screen05 ХХХХХ

там есть список всех открытых портов на твоем компе. Обнаружив нестандартные - лучше сразу выруби их инструкциями в фаерволе. Вырубить любой порт можно так: юзаем кнопочку "Добавить"(Add) и начинаем работать в появившемся окне. В графе название рулеса загоняешь фразу типа: "Вот вам... твари". Затем выбираешь выполняемое действие - Block (Блок - это по-нашему ;), в предписании когда выполнять - Either (любая операция), протокольчик, естественно, ставишь по вкуcу, после чего переходишь в закладочку Service, где под строкой Local Service ставишь закладочку на Single Service и загоняешь имя закрываемого порта. Оставляешь все остальное в покое и юзаешь ОК. Ты натянул их, братишка, а особо наивных - и порвал :)! Ту же операцию ты можешь повторить с любым стремным портом, который открыт, но тобой не юзается, и может служить дыркой для нападения. Кстати, если ты сел на измену, защищая 6-ти значную асю или логин у крутого прова, то можешь вообще забить наглухо 25 порт и отправлять почту отключая рулес, снимая с него галку Enable в Settings. Операция может повторяться с любым портом, который тебя беспокоит. Заметили мы, что обычно беспокоит 139 порт. Жизнь-то и так суетная, поэтому забей его тоже покрепче. А то зачем нам незваные нюкеры?


Спецвыпуск Хакер, номер #006, стр. 006-018-3, Министерство обороны

Министерство обороны

Спецвыпуск Хакер, номер #006, стр. 006-018-3

Голубой банщик

Теперь разберемся с баннерами, вылезающими окошками и другими напастями типа этих. Весь этот отстой можно сгноить в настройках, т.е. в Settings, но уже в закладке Web.

ХХХХХХ вставить screen06 ХХХХХХ

Там ты можешь поставить блокировку всего рекламного дерьма, причем их для тебя уже ввели заранее, а ты можешь уже менять действия, осуществляемые над ними. Если охота что-нибудь добавить, то просто юзаешь пимпу Add и добавляешь строку текста HTML или адрес сайта (reklama.ru; design.ru; bzlink.ru; linkexchange.ru), занимающийся обменом баннерами, от которых тебя тошнит на экран и которые необходимо блокировать. Ты можешь создать отдельный список блокировок для каждого из своих любимых сайтов, но на каждый из них изначально действует дефолтовый список программы. Это удобно, а то захотел подбить бабла с сети, и раскидал баннера спонсоров по своей паге. Но только если их тоже заблокировать, то кто же их накручивать будет, кроме тебя? Поэтому закинь адрес своей паги, где живет реклама спонсора.

Ява, ява - бабка ух, разява...

При желании ты можешь заблокировать все Ява скрипты на странице или только скрипты всплывающих окон. Это нужно, а то, бывает, зайдешь на порно сервак, а там тебя закидывают сотней окон со спамерской рекламой. Юзерам IE и прочей дырявости - советуем поставить защиту от подлостей в ActiveX, на которых спотыкается ехплорер, и другие. Делается это в закладке WEB в подразделе Active Content.

ХХХХХХ вставить screen07 ХХХХХХ

Здесь же ты можешь поставить лимит на анимированные гифы, чтобы глаза не мозолили. А перекатившись в подраздел Privacy, сможешь заблокировать кукисы и прочую чисто конфиденциальную инфу. А это бывает важно, когда тебе надо абсолютно анонимно оставить мессагу на борде или защититься от игнора во многих www-чатах.

Мне эта прога очень нравится, и умеет она еще очень много всего. Качай и поработай с ней. Оргазм гарантирован!

Вес: 1438kb

Снимем прогу:

http://hotfiles.lycos.com/cgi-bin/texis/swlib/lycos/info.html?fcode=000TWI


Спецвыпуск Хакер, номер #006, стр. 006-018-4, Министерство обороны

Министерство обороны

Спецвыпуск Хакер, номер #006, стр. 006-018-4

Домашняя страница: www.atguard.com (тут только платная версия)

Ученый консилиум

Второй прогой, о которой я тебе расскажу, будет не менее стильный фаервол - Conseal. По мнению многих экспертов эта прога является одним из наиболее мощных фаерволов, которые только существуют во вселенной. Он предоставляет возможность контролировать все порты и сервисы, которые использует твой комп при связи с Инетом. Начнем с внешнего вида. В общем-то, видок не очень красив, но с теми функциональными возможностями, которые дает эта прога, ты забываешь про кривой дизигн.

ХХХХХХ вставить screen08 ХХХХХХ

К сожалению, бороться с баннерами, кукисами и ява апплетами при помощи этого оборонного комплекса ты не сможешь. Но ты сможешь натянуть десятки хитрозадых нюкеров и прочих засранцев. Кстати, любитель сетевых разборок - SINtez - сам защищался именно ею, поэтому не вздумай пропустить ее! А то во все порты тебя чих-пых ;). Консил - это очень мощный комплекс, позволяющий полноценно защититься, но и требующий от тебя повозиться с настройками именно под твой комп. Особенность Консила заключается в том, что эта программа позволяет перекрывать не только порты и сервисы, но и протоколы, причем можно перекрывать части в составе протокола! Так же как и в Гварде, все содержимое твоего компа перекрывается по установленным рулесам. Но тебе необходимо сформировать разрешающие правила относительно твоих прог для Инета, а также заблокировать опасные порты. Если тебе не хочется напрягать мозги, а грамотно настроить - необходимо, то лучше врубить службу помощи, которая включается в Rules/All Network Devices - Automatic Rule Learning и Checked.

ХХХХХХ вставить screen09 ХХХХХХ

Если ты забыл занести какую либо прогу в рулесы разрешенных, то тебе автоматом предложат внести прогу в белый лист, а если в Инет пытался выйти троян, то забить в ненасытное чрево черного листа. Для открытия ресурсов конкретной программы необходимо залить ее название в соответствующей закладке. Прога имеет дефолтовую защиту от нюка и закрывает Netbios от доступа извне. А ты что хотел, чтобы хренов нюкер обломал кайф склейки новой девочки, а также попер твое расшаренное хистори аськи? Настройка проги не для ламахов. Тут не все так просто, и попотеть придется изрядно. Но это как Мастдай и Юникс: хочешь, чтобы все было просто - юзай Мастдай, хочешь реальной крутости и качества - не ленись настраивать. Но ты-то не тормоз, поэтому хелпы почитаешь, часа три повозишься и все настроишь. И вот тогда у тебя на компе будет стоять мега-система обороны, которую не пробьет никто! Братан, это наш выбор. Наша прога.

Вес:818kb

Снимем прогу: http://www.signal9.com

Врагу в хрюк, а не нюк!

Nuke Nabber - дикие крики бис и браво. Стоны "хочу еще, хочу еще" и удовлетворенные вздохи бывалых инетчиков. Мы знаем, что ты пацан занятой и мог пропустить это чудо, но только для тебя и по секрету - эта прога неизвестна только чувакам, которые залезли в танк лет 10 назад. И выходят в Инет через момед в 2400, из под M$ DOS-а, но, к счастью, их немного, плюс таким и защита-то не нужна вовсе. Народ из сетевых профи на этом месте начинает гудеть, кряхтеть и неприятно пахнуть: это же даже не фаервол, в натуре! Братан - спокойно, мы с тобой полностью согласны. Но эта прога будет просто необходима чертям, которые сели на измену, подозревая, что им грозит нюк.


Спецвыпуск Хакер, номер #006, стр. 006-018-5, Министерство обороны

Министерство обороны

Спецвыпуск Хакер, номер #006, стр. 006-018-5

ХХХХХХ вставить screen10 ХХХХХХХ

Или любой другой вид атаки через твои открытые штаны, тьфу - порты. К примеру, какой-нибудь придурок может тебя гнусно зафлудить, и твоего мастдая стошнит синим экраном смерти. NN - следит за всеми установленными тобой портами, фиксирует попытки коннекта на них. А увидев, что кто-то ломится - сразу отрубит его, защитив твою тачку от этих напастей. Относительно каждого вида нападения программа пишет логи, в которых указывает время нападения, а также IP-адрес нападающего. Прога очень пригодится тебе, если ты подолгу зависаешь на IRC. И если всякие отморозки выкидывают тебя оттуда, кидая мусор на порт, открытый mIRC-ом, то с такими подставами NukeNabber справляется просто виртуозно. У тебя остался айпишник этого урода? Ты, конечно, можешь выбить его из сети, но неплохо было бы и узнать: а кто же на самом деле этот козел? Так вот, поставив в настройках раздела General - поддержку твоего IRC клиента, ты увидишь ник нападающего ублюдка.

ХХХХХ вставить screen11 ХХХХХ

Можно, конечно, перебрать айпишники всех чатских, но что делать, если ты сидишь на таком крутом канале, как #xakep, что на DALnet? Поверь нам - делать это вручную - затрахаешься.

Вес: 750kb

Снимем прогу: http://www.dynamsol.com/puppet/

Мыло Safeguard и ты защитят твои порты

eSafe Protect - эта прога относится к числу антивандальных систем. Она защищает твой комп от загрузок вирусов, троянских коней, Java-апплетов, элементов ActiveX.

ХХХХХ вставить screen12 ХХХХХ

Для изоляции опасных программ, полученных через Интернет, eSafe Protect использует фичу "Песочница" (сито и совочек высылаются по заказу на родной странице :)). Эта хрень впечатляет тем, что вместо того чтобы запрещать загрузку программы (или постоянно спрашивать "Загружать или нет?"), eSafe позволяет загрузить объект, но изолирует его в специальной защищенной зоне твоего винта, называемой "песочницей". Опосля программа запускается и проводится мониторинг ее операций в соответствии с твоими заданными рулесами. Помимо изоляции потенциально враждебного софта, прога позволяет управлять доступом к имеющимся файлам и каталогам. В проге также ведется список неблагонадежных FTP и HTTP, которые отобраны на собственном горьком опыте фирмы eSafe Technologies. В этом списке ты можешь делать изменения, что-то дополнить, что-то убрать... ведь там частенько стоят адреса твоих любимых порносайтов, а также некоторые хацкерские сайты. Нас также порадовало то, что можно ставить в игнор - айпишники твоих врагов, чтобы они вообще и не думали лазать к тебе на машину.

Как играть в песочнице?

Изначально существует много полезных настроек, необходимых в защите. Например, в "Дополнительных параметрах настройки" ты можешь задать параметры для защиты ресурсов системы, фильтрации полученной по сети инфы, борьбы с вирусами и троянами.


Спецвыпуск Хакер, номер #006, стр. 006-018-6, Министерство обороны

Министерство обороны

Спецвыпуск Хакер, номер #006, стр. 006-018-6

ХХХХХХ вставить screen13 ХХХХХХХ

Поболтаем о вкладках этих настроек, так как они в полной мере раскроют все возможности программы. Менюшка "Песочница" дает возможность назначить доступ к файлам для любого каталога винта. Хорошая настройка раздела "Администратор" предотвратит доступ подозрительных программок к указанным тобой каталогам. Здесь ты сможешь создать для каждого юзера отдельные профили, со своими правами допуска к каталогам винта (себе рута взять не забудь ;). Утилита "Персональный брендмауэр" позволит тебе создать ограничения конкретных портов и протоколов, например, ФТП, Netbios и других, а затем ввести диапазон айпишников, на который будет распространяться действие каждого фильтра. Наш тебе совет - залей весь диапазон, чтобы вообще не думать о защите, а спокойно работать. Еще одна полезная утилитка дает возможность создавать список запрещенных для передачи слов. Не дай Бог, если кто-нибудь из твоих домашних поставит себе эту прогу! Тогда на чате ты не сможешь объяснить отморозкам про твои половые акты с ними, с их пустыми мозгами и их уродским компом :)! В общем, держи скачанную прогу где-нибудь подальше, а то жизни никакой не будет.

Подводя итоги, скажем: очень хорошая программка и, как нам показалось, наиболее многофункциональная. Позволяет проверять и защищать очень многое, плюс - русифицирована. Недостатки... Достаточно высокие требования к системе. Некоторая неповоротливость антивируса - трудно отключить режим поиска вирусов в real time, а модуль поиска по требованию непригоден для проверки отдельных файлов.

Вес: 10239kb

Снимем прогу: http://www.esafe.com

Это, бабка, не изъян. Это новенький троян!

Jammer - еще одна кульная прога, но уже для борьбы с BackOrifice и NetBus. Во время работы ведет проверку всех портов на вышеуказанные программы при помощи анализа всех пакетов, которые приходят и уходят при работе с Инетом. Так что даже последние версии этих противных программ, где порт определяется пользователем, не прорвутся к управлению твоим компьютером.

ХХХХХ вставить screen14 ХХХХХ

И знай, что при обнаружении БО или Нетбаса на твоей тачке - они будут уничтожены. Хотя в халявной версии эта фича отключена :(. Заметив атаку на комп, программа определяет IP нападающего и его прова. Может сразу отправить письмо администратору сети, откуда появился нападающий засланец, а также направить сообщение засланцу о том, что данная машина находится под мощной защитой. Типа, "ты щедро опекаем КГБ!". Программу практически невозможно заглушить пакетами, а это есть несомненный плюс. Любителям отечественного сообщу, что прогу заколбасила команда русских ребят. Хотя то, что они хотят бабла за свое творение - обыкновенная жадность...

Вес: 1624kb

Снимем прогу: http://jammer.comset.net/

Министерство Обороны предупреждает...

Сетевые разборки опасны для вашего здоровья ;)! Но если ты все же кинулся в боевые операции против обморози, то твоя защита также должна быть отменной. И тебе хотелось, чтобы мы посоветовали чего-то одно, наиболее кульное? Давай подумаем. Если тебе нужны сразу несколько типов защиты, то оптимально подойдет AT-Guard и eSafe Protect. Для граждан, обожающих однонаправленные, но мощные продукты, подойдет, соответственно, Conseal, Jammer и NukeNabber. Хотя надо отметить, что все эти программы по своему хороши, и их можно юзать совмещая. Совместив, ты будешь подготовлен к боевым действиям. Что же тебе еще сказать? Теперь тебе надо достать вооружение для ведения войны. Об этом ты сможешь прочитать в этом же номере. И перед тем как задавать нам вопросы - помни, что мы ребята мирные и поможем тебе защититься. А про нападение - к нашим злобным хацкерам ;).


Спецвыпуск Хакер, номер #006, стр. 006-022-1, Почтовые бомбы

Почтовые бомбы

Спецвыпуск Хакер, номер #006, стр. 006-022-1

SideX (sidex@xakep.ru)

В пролетевшей предвыборной гонке было принято цитировать политических деятелей нашего времени, но неоправданно забыли столь яркую и неоднозначную фигуру, как дедушка Ленин. Он много говорил. Но особенно мне запомнилась фраза “Вначале мы возьмём почту, телеграф и мосты”. Во как закрутил. А как поживают твои классовые враги? Телеграф уже уничтожен, т.е. аська находится в убитом состоянии. Мосты? Тачка запингована по самое оно, и канал твоего врага тоже забит, и кроме почты он ничего не может и не успевает скачать. А вот лысый дедушка сказал, что “возьмём почту”. И он не врал, он знал, что для этого существует как куча прог, так и куча способов. Начнем с прог.

Aenima V.2.0

The Resurrection

Вообще, если дословно слить название проги, то оно будет “Жмина”, потому как автор проги — грек. Но это не важно. Важно то, что эта прога реально написана для сетевого воина. Но не того, что сидит на выделенном канале 2 mb, а обычного — на дайлапе. А у такого юзера — канал не резиновый, и для полноценной бомбёжки приходится пренебрегать скачиванием прог и вообще тратить тучу времени на бомбинг. Поэтому в этой проге предусмотрена возможность составления листов с общедоступными SMTP.

Но не просто списка обычных серваков, типа маил.ру, а реально пропускающих тучу писем. И можно составить такой список, чтобы на отсыл писем уходило как можно меньше времени. В проге уже есть неплохой набор серваков, но ты можешь его патчить, добавляя новые. Или составить отдельные листы под каждого прова, потому как одно дело рассылать письма через какого-нибудь монстра, типа “ПТУ — Информ”, при коннекте 48 Кб/c. А совсем другое — через “МОЛь”, при коннекте 21,6.

А теперь перейдем к заполнению заказа на убийство :).

Number of mails — количество писем, которыми будет забиваться ящик жертвы. Если здесь поставить 1000, то прога отошлет 1000 писем. Прикинь, сколько нужно времени, чтобы все это удалить! А если письма не пустые, а с 50-ти киловым аттачем, что будет с ящиком жертвы? :)

Bombing until stoping — ставишь галку, и прога будет бомбить ящик до потери пульса. Сама прога пульс не потеряет, а вот враг — точно откинется, когда вместо утренних картинок с порно сервера, получит пять тысяч писем c сабжем “DIE LAMER!” :).

А если он полезет в хидер (header) письма, то там также получит по самое оно, увидев, что его уничтожили, используя мылер под названием “AntiLame”. В общем, ты можешь сам составить полный заголовок отсылаемых бомб. О процессе устранения мыла ты увидишь из счётчика, где, помимо количества засланных писем, показывается скорость, правда, измеряется глупо: Мегабайт/час. Но всё равно — это удобно, когда надо грамотно распределить свой трафик. Хотя, как ты знаешь, обычно, если трафик таки и резиновый, то также прилагается статический IP, который подставлять ну никак нельзя, поэтому данная прога — поддерживает бомбинг, сквозь ремейлеры (твой айпишник стирается наглухо).

Digital dominance

-=Global kOS=-

Мне всегда нравились различные органайзеры, записные книжки, блокноты. Потому как с их помощью можно полноценно организовать свою работу. Но когда я увидел этот бомбер, то понял, что и забивание чужой почты — тоже должно быть максимально удобным. А главное, организованным. Т.е. когда усмирением ублюдков ты занимаешься постоянно, то весь боевой софт должен быть под рукой и помечен горячими клавишами. Так и здесь, однажды настроив прогу, ты забудешь про проблемы. Ты можешь составить “лист гнева”, где будут адреса ненавистных тебе людей, а “Aemina” составила тебе полноценный лист серваков, которые могут перекачивать бомбы. И вся прелесть в том, что все это можно загрузить в Global kOS. Только если у тебя есть постоянные клиенты “листа гнева”, то многие из них уже вооружились различными фильтрами, скидывая в трэш все твои бомбы. А это не есть гуд. Поэтому в Global kOS есть возможность засылки писем с разными сабжами, взятыми из специального листа.


Спецвыпуск Хакер, номер #006, стр. 006-022-2, Почтовые бомбы

Почтовые бомбы

Спецвыпуск Хакер, номер #006, стр. 006-022-2

Я же, в борьбе с отечественными ламерами, пропатчил лист с субжами, чтобы жертва знала про моё эякулирующее чувство юмора. Ведь скучно отсылать только бомбы с сабжем “DIE LaMeR”. Хочется разнообразия.

Но я, например, сделал круче — вставил вместо этих шаблонов тексты с www.fuck.ru, а для особых извращенцев — с www.stulchik.list.ru.

HakTek Anti-Lamer Warfare

Ещё один яркий пример проги по типу “шампунь 2 в 1”. От перхоти тебе это не поможет, но поможет конкретно снести башку врагу. Здесь не надо каждый раз вводить мыльник врага. Для этого заносишь его один раз в раздел Target и, запустив бомбер, — закидываешь. Как ты знаешь, многие ставят фильтры на приаттаченные файлы, весом больше мегабайта, и чтобы забомбить — приходится вставлять огромедные куски текстов. Это реально напрягает. Так вот, в этой проге есть функция генерации мусорных тестов.

Помимо мыла, в раздел Target ты можешь залить айпишник врага — и прога его насмерть запингует, зафлудит.

Да много чего можно, например, просто просканить порты, но это уже не по теме, хотя удобно, что всё на месте, и не надо по разным прогам лазать в поисках инструментов для усмирения ламерков. В общем, неплохая программка.

Перевод стрелок

Представим, что тебе в лом тратить Инет на закидывание юзера флудом. Значит надо заставить тратить Инет кого-нибудь другого. Тем более, зачем флудить человека самому, если этим и так занимается куча разных людей, причем абсолютно легально! И имя этому флуду — рассылки новостей!

Технология проста: заводится почта на халявном серваке, типа usa.net, хотя лучше выбрать какой-нибудь сервис из наших, отечественных. Потому как функция Форварда (Forward), т.е. возможность пересылки писем на твой другой адрес, будет просто необходима, а на западных серваках она не всегда есть. Наши же chat.ru и mail.ru с удовольствием форвардят всю входящую почту. Поэтому нужно мыло типа vasia cool bomber@mail.ru.

Но надо ещё придумать, чем закидать. Да этих рассылок по самое не хочу, и найти их без проблем. Итак, ты нашёл таковую и в разделе Subscribe вводишь мыло, которое ты только что зарегил. Т.е. vasia cool bomber@mail.ru. Подписался? Потом влетаешь в это же мыло vasia cool bomber@mail.ru и ищешь письмо от службы рассылки. Оба — на! А вот и пароль, по которому будет открыта рассылка на данный адрес. Ломишься обратно на сайт службы рассылки и, введя пароль, — выбираешь тематические рассылки, которые будет читать жертва 24 часа в сутки, загнивая от этого бешенного спама. Обычно около наименования рассылок стоит периодичность выхода. Я понимаю, что ты подпишешь врага сразу на все, но в одной буржуйской службе рассылки я столкнулся с тем, что на одно мыло можно подписывать не более 50 тематических мейлеров.


Спецвыпуск Хакер, номер #006, стр. 006-022-3, Почтовые бомбы

Почтовые бомбы

Спецвыпуск Хакер, номер #006, стр. 006-022-3

Ну а теперь самое главное. Адрес подписан, рассылка началась, теперь можно зайти на mail.ru и в настройках поставить “Пересылать почту не сохраняя”. А куда пересылать? На деревню дедушке? Ни фига — тут ставишь мыло жертвы, т.е. lamer@hotmail.com. Все. Теперь этот ящик можно не трогать, он будет работать сам, пересылая тонны писем бедному ламеру. Причем, ежедневно гуляя по Сети и натыкаясь на всякие рассылки (типа “Свежее порно каждое утро! Введите свой e-mail и уже завтра получите супер-экстра-мега голых тетек”), ты, естественно будешь продолжать подписывать своего Васю Кул Бомбера. :) Единственное, что нужно будет делать — залезать иногда в этот ящик и подтверждать подписку.

Если же у жертвы мощнейший канал, то можно настроить несколько мыл на закидывание рассылками, т.е. создать мыльницы vasia cool bomber1@mail.ru, vasia cool bomber2@mail.ru, vasia cool bomber3@mail.ru и т д. Более грамотно это метод реализуется путём более хитрой настройки форварда и ремейлеров. Этот момент хорошо осветила ХакЗона (http://www.hackzone.ru/articles).

Разведка

Не секрет, что при проведении боевых операций немаловажную роль играет разведка. Можно узнать массу важной инфы о противнике, но разведку также применяют для нахождения стратегических целей, которые ты должен уничтожить. Какое это имеет отношение к сетевым войнам? На первый взгляд — условно косвенное, но на самом деле... Тебе что, не приходилось видеть у всяких лохов мыльники с названиями pisma@na.derevnju.dedush.ke? Да знаю, что видел, но реально ли существует такая почта, как @eto.kru.to. Поэтому во время ковровых бомбардировок по врагу — ты можешь словить конкретный ХЗ, разбираясь: а реальное ли мыло или динамо? Короче, я тебе расскажу про прогу, которая позволит тебе быть уверенным в существовании убиваемого мыла. Серия данных прог называется Mail Validators. Самая популярная из них, пожалуй, Mail List Verify.

В основном эта прога используется для проверки листов рассылки на наличие мёртвых мыл. Хотя она вполне подойдёт и для проверки твоего небольшого “листа гнева”. Адреса, которых вообще не существует, будут помечены как No Exist. Если результат проверки неизвестен — Unknown. Но если тебе было в лом составлять “лист гнева” — предусмотрена возможность проверки одного адреса. Для этого есть фича Check single mail.

По сути, проверка почты этой прогой анонимна, но всё же случается так, что админы SMTP серваков ведут логи на запросы. И если ты будешь проверять мэйл лист, составленный по одному прову — то супорт может сильно удивиться, увидев несколько тысяч запросов с одного айпишника. А оно тебе надо? Поэтому есть возможность анонимной настройки, для этого надо полазать по меню Settings, а конкретно в папке Proxy.


Спецвыпуск Хакер, номер #006, стр. 006-022-4, Почтовые бомбы

Почтовые бомбы

Спецвыпуск Хакер, номер #006, стр. 006-022-4

В общем, прога эта — откровенный и неприкрытый рулез! Обязательно скачай. http://www.elcomsoft.com/amv.html.

Защита

А если воин вовсе не ты? А ты — обычный перец, которого враги решили завалить. Вот для такого случая стоит основательно подготовить оборону. Самый простой способ устранить последствия почтовых бомб — пользоваться настройкой, которая поддерживается почти в любой халявной почте, т.е. Block Sender. Ты можешь запретить принятие почты от определённого человека, с определённым сабжем, содержащий определённый текст. Но это всё — фуфло. Помогает только если ты выловил начало партии бомб. Также, как ты знаешь, кул хацкер будет пытаться закидать тебя мессагами, в которых сабжи будут генериться сами собой. Поэтому остаётся только один метод — ручное устранение. Проще всего — скачать всю эту помойку. Но если хакер тебе прислал 5000 писем весом в 100 кил каждое? Тут тебя спасут проги, которые принято именовать Mail checkers. Про одну из них я тебе расскажу. Этот шедевр будет называться Email era.

На мой взгляд, самый продвинутый инструмент для борьбы с бомбами. Для того чтобы весь присланный мусор был уничтожен, используются фильтры, которые ты легко настроишь.

Можно поставить “Удалять сообщения”, и все мессаги, подпадающие под игнор фильтра — будут затёрты на хрен. Но более грамотно — ставить “Удалять дубликаты”. Вот это как раз та фишка, которая тебя обезопасит от заброса тысячами одинаковых писем. “Удалять сообщения” — лучше ставить, если гадский спамер настроил убийство твоей почты различными рассылками, рекламой порно серверов и прочей шняги, что имеет характерный субж или стабильного отправителя. В общем, разберёшься, поколдуешь и поймёшь, что данная софтина — просто обалденно нужна сетевому воину. Короче, беги на сайт www.vcw.ru и скачай!

А что делать, если спамер выслал тебе много мегабайтовое файло? Можно, конечно, удалить его этой же прогой, но я тебе расскажу про чисто юниксойдную методу борьбы с таким гиморром! Для этого врубаешь свой телнет, можно стандартный, мастдайный.

Итак, удалять бомбы мы будем с mail.ru. Поэтому набиваешь в поле Host — pop.mail.ru, а в Port — 110 (POP3 то бишь).

Теперь набиваешь следующие команды:

User <твой логин на маил.ру>

в моём случае:

User sidex

Далее выскочит сообщение:

+Ok password required for user <твой логин>

Набрал пароль (qwerty ессно ;) и выскакивает сообщение:

+Ок <твой логин>`s maildrop has <кол-во сообщений и общий объём сообщений>

Далее набиваешь команду List и видишь около номеров сообщений — их объём. Ты уже разглядел 2-х мегабайтовую бомбу? Тогда набиваешь следующее:

del <номер сообщения>

И твой ящик снова чист от такой шняги, как почтовая бомба, что тебе закинул хакер. Чтобы выйти из сессии с серваком — набиваешь quit. Вот и всё! Я понимаю, что специальной прогой удалить эти файлы проще, но зато так по-хацкерски ;)


Спецвыпуск Хакер, номер #006, стр. 006-022-5, Почтовые бомбы

Почтовые бомбы

Спецвыпуск Хакер, номер #006, стр. 006-022-5

Повоевали? Отбой!

Ну, всё мужик! Я тебя проинструктировал по полной. Теперь можешь смело уничтожать почту врага, а вместе с почтой и его самого. Ты также теперь в силах держать оборону против наездов на твоё мыло, в которое посмел вторгаться противник. В общем, простор открыт. А сейчас ОТБОЙ! Завтра подъем в 6:30 по боевой тревоге!


Спецвыпуск Хакер, номер #006, стр. 006-026-1, Министерство путей сообщения — сообщайте!

Министерство путей сообщения — сообщайте!

Спецвыпуск Хакер, номер #006, стр. 006-026-1

Михаил Терехов (stranger@xakep.ru) Макс Зелененко (maxx@xakep.ru)

Помнишь рекламу, где чувак сидит в туалете, и только он там вздыхать начинает, только у него что-то начинает получаться, и тут ТРЯМ-ТАРАРАМ — телефон. Он быстрее, со спущенными штанами и торчащим перцем, несется к телефону и только подбегает, как тот замолкает. Облом. Знакомая ситуация? Так вот, в той рекламе нам советовали прикупить себе радиотелефон и обещали, что все сразу будет в шоколаде. Радиотелефон это, конечно, стильно, но трепаться с кем-то в момент, когда ты со своей девушкой занят изучением особенностей женского организма и кульминация уже рядом, занятие не из приятных. Значит надо заводить автоответчик — пусть все кому надо оставляют мессагу, а ты ее потом послушаешь. И все бы ничего, завели бы себе каждый по автоответчику, да вот есть в них одна загвоздка — за них лавэ платить надо. Копить на него бабло это, конечно, выход, но как же твой любимый комп? Ведь с такими расходами апгрейд до третьего пня откладывается на срок настолько неопределенный, что аж волосы дыбом встают... Нет! Бабло на всякие второстепенные девайсы сливать — это не по кул-хацкерски, поэтому мы все эти приборы будем эмулировать. Момед у тебя есть? Есть. А значит его надо юзать на 100%, т.е. не только ночью, в Инете, но и днем, в качестве автоответчика или АОНа (или и того и другого, и можно без хлеба).

Advanced Call Center

Эта прога занимает одно из первых мест по количеству поддерживаемых момедов. В число которых, скорее всего, попадет и твой. Но самого лучшего результата ты, конечно, добьешься, если у тебя стоит... модем типа ЮСР, Зухель и другие типа этих. Прога имеет определитель номера, причем определяет номер в двух стандартах. Во-первых, в американском CID стандарте (видать, прога делалась на экспорт), во-вторых, в формате АОН (безынтервальный пакет) российских и европейских АТС.

Настройка АОНа очень разнообразна и для тебя она может быть одной, а для твоего приятеля другой. В настройках ты указываешь, из скольких цифр состоит телефон, количество сигналов в запросе и максимальное число запросов. Правда, очень уж много в этих настройках умных слов написано, но разговор сейчас не об этом. Нам же с тобой нужен автоответчик, а не определитель номера. Берешь себе любой войсовый модем и микрофон, записываешь сообщение типа: “Я сейчас очень занят взлетами и падениями и не могу оторваться, так что прошу оставить мне мессагу и я тебе перезвоню, как освобожусь”. И можем смело браться за дело, он все остальное за тебя сделает, будь уверен (я о телефонии, а не о взлетах :)).

Прога преспокойненько сидит в трее и никому не мешает. При входящем звонке программа активизируется и выдает звуковой сигнал, если у тебя, конечно, включены колонки. Но все эти звуки можно легко убрать и жить спокойно без них. А можно и поставить и сообщение для себя. Типа: “Слышь, ты, засранец, подними свою задницу с дивана и возьми трубку, мать твою!”.

Есть среди чего выбирать. Можно поднять трубку, положить трубку, включить автоответчик, начать запись разговора и т.д. и т.п. Также все эти действия можно сделать так, чтобы они происходили и после определения номера. Записанные сообщения можно проигрывать как через модем, так и через звуковую плату. Можно создать свою записную книжку. Она будет храниться в текстовом виде и может быть в любое время отредактирована тобой.


Спецвыпуск Хакер, номер #006, стр. 006-026-2, Министерство путей сообщения — сообщайте!

Министерство путей сообщения — сообщайте!

Спецвыпуск Хакер, номер #006, стр. 006-026-2

При первом запуске программа пытается определить порт, на котором находится твой момед. Но она может его и не найти. А чему ты удивляешься, может ты его пропил совсем недавно. Вот в такой ситуации придетс

Таких конфигураций с различными музыкальными файлами ты можешь создать сколько тебе будет нужно, чтобы, позвонив, человек каждый раз нарывался на разный репертуар и мог вволю с телефоном потанцевать.

Программа после загрузки и до скончания веков сидит в трее. Вытащить ее оттуда можно двумя способами: 1) двинуть туда свою крысу и пару раз нажать на нее;

2) если ты в танке, можешь ждать, пока кто-нибудь позвонит, и она сама вылезет из трея.

Самый лучший способ, чтобы ее оттуда вытащить, на мой взгляд, это позвонить кому-нибудь из друзей и попросить тебе перезвонить, так как плохо слышно.

По умолчанию, программа записывает только шестьдесят секунд, но если у тебя не слишком разговорчивые друзья, которые любят потрепаться с автоответчиком, то тебе этого времени хватит. Если хочешь послушать, что тебе там наговаривает твой дружок, то просто включи динамик модема при записи сообщения.

В программе есть спикерфон. Если у тебя микрофон с очень хорошей чувствительностью, то ты можешь разговаривать с челобреком на том конце провода, расхаживая по комнате. Громкость у спикерфона регулируется (как и чувствительность микрофона).

В проге имеется “очередь звонков”. Если номер оказался занят, то перед следующей попыткой выдерживается определенная пауза. В эту очередь ты можешь внести еще несколько номеров.

Что-то вроде “не дозвонюсь к этой, так получится к другой”. Также программа ведет за тобой журнал. Кто тебе звонил и куда ты звонил. Иногда это помогает при склерозе (но не помогает при разборках со своей подругой :)). Из этого журнала ты можешь многое почерпнуть. Например, прослушать сообщения, которые тебе поступили в интересующий тебя день. Есть возможность работы в проге на буржуйском языке, если тебе вдруг надоест этот русский.

Но у программы есть один недостаток, иногда она зависает. Иногда, считай, как раз в полчаса. Иногда из программы просто нельзя выйти. Она, видите ли, слушает линию, и выключить ее можно только нажатием трех любимых клавиш (т.е. Ctrl+Alt+Reset).

Venta Fax & Voice

Эта программа, как ты можешь догадаться по названию, может принимать и отправлять факсы. Прием и передача факс-сообщений производится как в ручном, так и автоматическом режимах. Очень легко провести прием или передачу факсимильных сообщений. При передаче достаточно перетащить пиктограмму документа в открытое окно программы. Но ты же не на работе, и не всегда оно нам нужно. Поэтому забросим эту функцию проги куда подальше и продолжим разговор об автоответчиках. Все голосовые сообщения, используемые в ВентаФакс, имеют формат .wav, поэтому при помощи микрофона ты можешь сделать себе кучу таких сообщений и менять их раз в неделю, а можно и почаще. Только можешь не усердствовать слишком сильно. Не имеет смысла подготавливать сообщения в стерео режиме, ведь телефонная линия у тебя этого не поддерживает. Так что имей ввиду и особенности телефонной линии и своего момеда. Свои сообщения ты можешь записывать и при помощи встроенного в прогу редактора wav файлов. Это окно делится на две части: первая половина — запись, вторая — воспроизведение.


Спецвыпуск Хакер, номер #006, стр. 006-026-3, Министерство путей сообщения — сообщайте!

Министерство путей сообщения — сообщайте!

Спецвыпуск Хакер, номер #006, стр. 006-026-3

Полученное сообщение можно прослушать через телефонную трубку, наушники, которые надо подключить в разъем на задней панели модема или через колонки.

Главная панель управления может появляться на экране как в виде факс-аппарата, так и без всякого вида в режиме простого окошка.

Программа может работать как в качестве полноценного автоответчика, так и в качестве автоматического информатора, когда человек, дозвонившись, будет иметь возможность прослушать оставленное тобой сообщение, после чего трубка будет положена, несмотря на все его матюки в твой адрес!

Имеется определитель номера. Но настройка АОНа имеет экспериментальный характер, так что придется тебе, дружок, маленько повозиться с параметрами в закладке АОН. Среди экспериментальных настроек тебе встретятся “Сигнал запроса” к телефонной станции для определения номера абонента, “ответный сигнал станции”, который записывается и анализируется, а также можно настроить “имитацию сигнала вызова”, чтобы чел, который тебе звонил, не догадался, что у тебя стоит определитель номера. Если прога определила номер телефона, то она в специальном окне выведет данные об этом человеке, если он есть у тебя в базе данных (даже его фото, если оно туда внесено). Если номер определен частично, то вместо неизвестных цифр номера будут выведены буквы Х (наш человек прогу писал :)).

Эта шикарная прога просто находка для склеротика, которому очень эффективно поможет журнал соединений. В нем записываются дата соединения, его продолжительность и как прошел сеанс.

RapidComm Voice.

Сразу замечу, что если у тебя модем не от 3Com, то можешь спокойно читать окончание статьи, а эту ее часть пропустить. Все дело в том, что прога писалась специально под USRobotics и поставляется на диске к нему же. Программа может получать и передавать факсимильные сообщения (короче, факсы отправляет), причем она реально работает. Имеет собственное окно для просмотра вышеназванных сообщений. Но не о факсах у нас разговор, а значит, к нашим баранам. Ну, в смысле автоответчику встроенному. Начнем с того, что рыться в настройках в течение суток не придется — их просто почти нет. Настроив их за несколько минут, ты обнаружишь, что все работает, а после этого получишь огромное удовольствие от юзания данной проги. В проге изначально закатан целый ряд стандартных сообщений, жаль, но лишь на англицком — так что их придется сменить. Сделать это очень легко, их нужно просто записать и сделать стандартными.


Спецвыпуск Хакер, номер #006, стр. 006-026-4, Министерство путей сообщения — сообщайте!

Министерство путей сообщения — сообщайте!

Спецвыпуск Хакер, номер #006, стр. 006-026-4

По умолчанию, автоответчик начинает свою работу после второго гудка в линии, но количество гудков до снятия трубки можно и изменить на любое желаемое. Характерно, что сообщение, которое тебе оставляют, вовсе не ограничено временем, а лишь только местом, которое осталось у тебя на диске. Так что если у твоего злейшего врага стоит эта прога, ты можешь позвонить ему и замусорить весь диск, забив его до отказа своим сообщеньицем в виде трехчасовых восхищений его персоной, а также прогнозом относительно ее будущего. Любое оставленное тебе сообщение ты можешь прослушать как через колонки, пристегнутые к звуковухе, так и через телефонную трубку (вот уж забава для извращенцев, если у тебя колонки есть). Все файлы сообщений в программе имеют собственное стандартное расширение .gsm, так что прослушивать на бис оставленное твоей девчонкой сообщение на тему какой ты тигр в постели, тебе придется только в самой проге. В целом надежная, простая прога, и писать вроде больше нечего, хотя вот еще...

Меня очень порадовало, что в проге имеется собственная терминалка со стильным окошком. Если у тебя стоит эта прога, тебе больше никогда не потребуется встроенная терминалка ВинГлюка. Можно подключить микрофон к модему и использовать функцию спикерфона.

А доктор сказал —

все будет хорошо!

Не расстраивайся, если у тебя не заработал автоответчик. В настоящее время не существует единого стандарта набора голосовых команд, и именно поэтому нынешние автоответчики не могут обеспечить правильную работу голосовых функций с любым голосовым модемом. Если программа вовсе не обнаружит голосовых функций в твоем голосовом модеме, это не глюк, просто в настоящее время набор его голосовых команд неизвестен. В принципе, если ты хорошо знаешь команды своего момеда или умеешь читать описания, то можешь в самой проге махнуть не работающие команды на реальные команды твоего момеда (соответствующие функции встроены в каждой проге). Теперь те, кому сильно не повезло, могут рукавом маминого халата утереть слезы и, сев с бутылкой пива рядом с компом, начать ждать момента, когда команды и их момеда будут встроены во все автоответчики.

А для тех, у кого все совпало и кто все же решил установить себе какой-либо автоответчик, я могу посоветовать лишь две проги. Для тех, у кого имеется момед USRobotics, выбор очевиден... Это RapidComm Voice. Несмотря на то, что прога базарит только по-англицки, все равно ее надо 100% ставить. Потому как язык надо учить, а по количеству функций и работоспособности она превосходит все остальные на голову.

Вторая прога — это, несомненно, Venta Fax. Она работает практически на любом момеде, говорит на русском языке, да и хелп к ней накатан настолько недетский, что не разобраться в ней практически невозможно. Единственным камнем в ее огород будет только большое количество настроек, которые, к слову, и в дефолте классно работают, так что менять почти ничего не придется. Классный выбор для тех, кто язык учить не собирается и любит русского производителя поддержать. Ребята-то ее нашенские сделали!


Спецвыпуск Хакер, номер #006, стр. 006-026-5, Министерство путей сообщения — сообщайте!

Министерство путей сообщения — сообщайте!

Спецвыпуск Хакер, номер #006, стр. 006-026-5

Несомненно, выбор за тобой, а я покатил, а то на автоответчике сообщения не прослушанные есть. Вдруг что-нибудь интересное?


Спецвыпуск Хакер, номер #006, стр. 006-030-1, Сканируя СЕТЬ

Сканируя СЕТЬ

Спецвыпуск Хакер, номер #006, стр. 006-030-1

Zелененко Махх (maxx@xakep.ru)

Главное в начале атаки на комп врага — выяснение точной инфы о противнике. Инфа нужна очень разнообразная, и одна из вещей, которую тебе нужно будет знать — какие порты на вражеской машине открыты, а какие нет. Например, открыт где-то порт 31337, значит, там уже висит BO2K, которым ты можешь воспользоваться. Открыт 21 порт, значит, там возможно есть ftp-сервер. Ну и так далее. Для того, чтобы узнать эту инфу, народ придумал соответствующий софт — портсканеры. Раньше эти проги только сканировали порты, сейчас же они обладают поистине многофункциональностью и могут делать немереное количество вещей. Впрочем, как раз об этом я и хочу рассказать.

Internetmaniak

Одна из наиболее распространенных прог этого жанра в российском Инете. Достаточно давно не обновлялась, но была написана человеком, у которого руки росли оттуда, откуда надо, а не оттуда, откуда всегда ;). Работать с программой легко — загоняешь IP, ставишь количество портов, которые необходимо проверить, и юзаешь кнопочку Scan. Глюков и подвисаний не замечено даже когда для сканирования задаются большие диапазоны адресов или энное количество портов. Одна из особенностей проги — при работе с большим количеством адресов она требует указания одного конкретного порта. При попытке указать несколько портов прога просто останавливается и ничего не делает, пока число портов не уменьшится до одного.

Резко не понравилось в программе то, что при сканировании удаленной машины невозможно указать список конкретных портов и все время приходится ждать, когда софтина прокатает все немереное количество портов. Ну что ж, идеального софта не бывает :). Зато, кроме сканера, здесь есть целый ряд таких полезных функций, как Ping, Traceroute, Whois, Time и даже POP3 — фишка, позволяющая проверить наличие писем на твоем ящике, даже не открывая почтовик. Прога шароварная, но полнофункциональная и без ограничения даты. Искренне советую скачать эту софтину каждому (тем более качать недолго — вес проги 54 кило).

Скачать: http://new.russian.net.ru

/program/in_maniac.zip

Advanced Administrative Tools

Прога также известна как AATools и предназначена для использования продвинутыми пользователями — только не указано, в каких целях, так что юзай как хошь :))). Из нужных и необходимых сетевых функций доступны Portscanner, Proxy и CGI анализаторы. Из менее нужных замечены Whois, E-mail verificator (софтина определяет, существует ли введенный мэйл) и Links analizator (без комментариев — попробуй догадайся, что делает :)). В проге включен целый ряд фич, относящихся к твоей машине: статистика сетевых соединений, инфа о запущенных процессах и детальная информация о системе.

Теперь поговорим подробнее о самом сканере программы. Для удобства сканирования в прогу введен принцип листов сканирования, где наряду с одиночными IP можно указывать целый диапазон адресов. Так как сканирование в большинстве случаев требуется произвести оперативно, прога предусматривает создание списков сканируемых портов. Все сохраненные списки портов вносятся в меню на передней панели программы и позволяют быстро между ними переключатся. Таким образом, распределив списки портов по цели сканирования, ты сможешь за короткое время выяснить всю необходимую информацию относительно компьютера(ов) и приступить к реализации карательных мер.


Спецвыпуск Хакер, номер #006, стр. 006-030-2, Сканируя СЕТЬ

Сканируя СЕТЬ

Спецвыпуск Хакер, номер #006, стр. 006-030-2

Удобно то, что прога может производить сканирование не только напрямую, но и через прокси — это позволяет тебе маскироваться вплоть до самого момента нападения, так что оно происходит с самой неожиданной для жертвы стороны. Вердикт — очень интуитивная удобная прога, нужна тем, кто собирается сканировать часто и по большому количеству параметров. Вес проги — 1056 кило.

Скачать:

http://www.glocksoft.com/cgi-bin/

down.cgi?aat40.zip

IP Ultra Scan 2000

Как видно из названия — это обыкновенный сканер, но очень мощный. Предназначен как для сканирования в Инете, так и для сканирования локальных сетей по большим диапазонам. Результаты могут сохраняться в виде базы данных. Прога позволяет внести в лист сканирования как одиночные адреса, так и области, но при этом лист сканируемых портов будет для всех один. Если сканирование идет по всему листу, то для удобства возможно исключение как отдельных машин, так и диапазонов. Прога понравилась мне тем, что при вводе большого количества сканируемых адресов она не подвисает и не вызывает замедления системы, чем страдают многие проги обзора в подобных условиях.

Немного не понравилось то, что управление осуществляется при помощи контекстных меню, выпадающих по щелчку правой кнопки мыши — я сам минут двадцать тщетно пытался найти где-нибудь сверху кнопки, позволяющие начать сканирование или активизировать другие функции софтины. Зато сколько было радости, когда искомое нашлось :).

Лично мне эта прога очень нравится и находится в числе моих фаворитов. Она удобна, функциональна и фактически бесплатна — то есть она шароварна, но полнофункциональна и без ограничения даты (плюс никаких напоминаний). Единственный камень в ее огород — специфические требования, для своей работы она требует наличия Visual Basic 6.0 runtime (http://support.microsoft.com/download/support/mslfiles/VBRUN60.EXE) и Microsoft MDAC 2.1 (http://www. microsoft.com/data/download_250rtm.htm), но, поверь мне, прога того стоит. Вес ее — 1922 кило.

Скачать:

ftp://ftp.cdrom.com/pub/win95

/winsock/ipus216.zip

NetInfo

Неплохая прога, которая включает в себя большое количество утилит, как имеющих отношение к сети, так и не имеющих такового. В сети она бродит очень давно и заслужила достаточно широкую известность. Включает в себя такие модули, как Ping, Connections, Local Info, Whois, Lookup и другие.

Сканеры — их в проге целых два. Просто Scanner — поначалу можно проколоться, приняв его за искомое, но на самом деле это не так. Сия фича занимается всего лишь сканированием диапазонов адресов и выяснением жизнеспособных. А сканированием портов занимается другой модуль — Services. Несмотря на внешнюю простоту, он отличается редкостным неудобством.

Во-первых, отсутствие возможности сканирования по диапазонам — пашет только по одиночным адресам. Во-вторых, для того чтобы изменить список сканируемых портов, необходимо залезть в самый дальний угол меню Options. Так что если тебе часто нужно изменять список сканируемых портов, то ты потрахаешься вдоволь. Единственный понравившийся мне момент — это классные логи, которые ведутся софтиной по результатам сканирования.


Спецвыпуск Хакер, номер #006, стр. 006-030-3, Сканируя СЕТЬ

Сканируя СЕТЬ

Спецвыпуск Хакер, номер #006, стр. 006-030-3

Короче, если ты сканируешь много адресов и хочешь делать это по разным наборам портов, то можешь забыть про эту прогу. А вот если ты собираешься запускать ее раз в год, чтобы полюбоваться, то можешь скачать — для разглядывания она просто супер :). Вес проги — 1497 кило.

Скачать:

http://www.netinfo.co.il/downloads

/netinfo.zip

InterNetView

Своеобразный такой софт — всего несколько функций, но в их число входит сканер открытых портов. Отличается очень необычным интерфейсом и оригинальными принципами работы со сканируемыми адресами. Прога работает как с одиночными адресами, так и с их диапазонами. При вводе айпишника или их диапазона в окне Network Map появляются все доступные в данный момент компьютеры, соединенные линиями. Для сканирования портов того или иного компа необходимо щелкнуть правой кнопкой мыши на его иконке и просто выбрать подпункт Scan Ports.

Результаты сканирования выводятся в отдельное окно Scan Window. Вообще, эта софтина потрясающе удобна для тестирования локальных сетей, так как визуализирует ее иерархию, обновляя информацию о сети прямо на лету. Мне понравилась возможность сбора данных по каждой машине сети через Netbios и отличная работа с DNS.

В общем, неплохая прога. Вес проги — 1165 кило.

З.Ы. Производитель проги — не какой-то там John Smith, а наши ребята.

Можно скачать: ftp://sun.tsu.ru/pub/stuffs/windows

/inv.exe

PortScan

Не самая маленькая, но самая простая прога обзора — ничего не умеет кроме сканирования портов. Может сканировать как одиночные адреса, так и их диапазоны. Листинг портов создается пользователем, предусмотрена возможность их сохранения и быстрого подключения в момент наибольшей необходимости.

Прога оптимальна для работы без присмотра пользователя, так как пишет потрясающе удобные логи и предусматривает возможность сканирования в соответствии со скриптами.

Вес проги — 243 кило.

Скачать:

http://blueglobe.com/~cliffmcc/files

/portscan.zip

IP-Tools

По-моему мнению — это лучшая программа обзора. Она содержит в себе все утилиты, которые только могут понадобиться сетевому жителю от Telnet’a и Netbios’a до сканера портов и сканера зашаренных ресурсов. Все очень удобно и просто, никаких глюков при работе с ней замечено не было. Сканер позволяет сканировать как большие диапазоны адресов, так и одиночные адреса. По заверениям автора, можно заставить программу отсканировать хоть весь Инет сразу.

Не очень удобно, но список портов для сканирования приходится изменять через главное меню проги, хотелось бы, чтобы он находился где-то рядом, на передней панели модуля. Ну да ладно, не так и страшно, потерпим. Софтина, в отличие от других, не циклится на выполнении одной функции и позволяет параллельно запустить сразу несколько процессов. Поэтому ты сможешь устроить глобальный сбор информации о твоем недруге с целью насолить ему так, чтобы он после встречи с тобой вообще в Инет боялся заходить :).


Спецвыпуск Хакер, номер #006, стр. 006-030-4, Сканируя СЕТЬ

Сканируя СЕТЬ

Спецвыпуск Хакер, номер #006, стр. 006-030-4

Вес проги — 947 кило.

З.Ы. Автор опять же наш, русский.

Скачать:

http://free.prohosting.com/~kssoft

/download/ipt109.exe


Спецвыпуск Хакер, номер #006, стр. 006-032-1, Удаленное администрирование, или наш ответ PC MAGAZINE

Удаленное администрирование, или наш ответ PC MAGAZINE

Спецвыпуск Хакер, номер #006, стр. 006-032-1

Терехов Михаил (stranger@xakep.ru) & Zелененко Махх (maxx@xakep.ru)

Сегодня мы со всей своей серьезностью сосредоточимся на высокотехнологичном программном обеспечении, направленном на администрирование удаленных компьютеров.

Вы спросите: а зачем это нужно нам? Ну что же вы, милые мои. Все на самом деле так же просто, как экспроприировать чужую шоколадку. Цель первая — получение паролей и логинов, дающих возможность входить в сеть Интернет по коммутируемой телефонной линии в режиме dialup с использованием протокола TCP/IP. Цель вторая — собственно удаленное администрирование, то есть настройка компьютера другого пользователя в соответствии с вашими нуждами и потребностями, а также помощь в работе владельцу контролируемого компьютера. В виде организации для него вынужденного отдыха от работы в Интернет, а возможно и вообще от работы с компьютером. Попутно — закрепление у пользователя четких навыков в области восстановления операционной системы. Естественно, список бесконечен и может дополняться некоторыми другими пунктами.

Все продукты официально лицензированы и распространяются, как правило, в коробочных версиях, а значит, ощущают за своей спиной поддержку заводов и крупных корпораций. В связи с чем нам пришлось с максимальной серьезностью отнестись к их тестированию.

Для создания у вас объективного представления об условиях, в которых оно проводилось, немного расскажем о “железе”, которое использовалось, а также

условиях работы в Интернет. При тестировании предоставленных продуктов нам потребовалось два компьютера, типа PC, с предустановленной ОС Windows 98. Компьютеры типа PC были построены на основе процессоров Intel(c) Pentium 3 с тактовой частотой 450 МГЦ на материнской плате чипсета BX440. Соединение происходило по коммутируемой аналоговой линии связи.

ПРИНЦИПЫ ОТБОРА

Лаборатория XAKEP Labs по приведенным ниже жестким критериям отобрала и протестировала шесть систем удаленного администрирования, о которых вы можете прочитать чуть ниже. Первым требованием была работа по протоколу TCP/IP или UDP. Вторым — наличие файлового менеджера для работы с файлами и приложениями удаленного сервера. Третьим — наличие дополнительных функций для обработки поступающей информации, таких как функция Print Screen, Key Log, microphone&video spy.

Back Orifice 2000

Одна из наиболее известных и многофункциональных программ. BO2000 функционирует столь у многих, что при негативном мнении о ней возникает страх за свое здоровье и здоровье близких. Принцип работы с этим программным обеспечением таков. Для начала вы конфигурируете сервер, а потом посылаете его пользователю, компьютер которого нуждается по вашему мнению в администрировании.

Совершенно необходимо обосновать причину, по которой он должен принять и запустить это программное обеспечение, так как осуществление несанкционированного морально-психологического воздействия на личность недопустимо. Для соединения с сервером, установленном на удаленном компьютере пользователя, вам необходимо узнать динамический адрес IP, который пользователь получил при установке соединения с компанией, предоставляющей коммутируемый доступ к сети Интернет. После введения IP-адреса в клиентской части вы получаете полнофункциональный доступ к администрируемому компьютеру по любому из двух протоколов на выбор — TCP или UDP, с возможностью выбора порта, к которому производится подключение. Теперь вы можете преступать к работе.


Спецвыпуск Хакер, номер #006, стр. 006-032-2, Удаленное администрирование, или наш ответ PC MAGAZINE

Удаленное администрирование, или наш ответ PC MAGAZINE

Спецвыпуск Хакер, номер #006, стр. 006-032-2

Программа предоставляет возможность узнать системную информацию пользователя, его пароли для доступа в Интернет. Сотрудникам тестовой лаборатории особенно понравилась функция организации анонимного ФТП сервера (из морально-этических соображений большая просьба не путать с организацией анонимных алкоголиков).

После организации этого сервера вы сможете просмотреть дерево каталогов, создать или удалить каталоги; переименовать несколько файлов, перенести различные файлы. Кроме этого, доступно еще огромное количество функций. Боюсь, что единственный камень в огород этой программы — некоторая сложность в использовании. Тем не менее, это выбор профессионалов.

Donald Dick

Сотрудники концерна, создавшего эту программу, явно любили мультики про замечательного героя Диснея Дональда Дака. Но по каким-то причинам сотрудники не смогли правильно перенести название на полиграфическую продукцию и интерфейс пользователя.

Это программное обеспечение функционирует только на компьютерах, где установлены многозадачные операционные системы Windows 9X и Windows NT 4.0 от компании Microsoft. Программное обеспечение состоит из двух частей: клиента и сервера. Для установки сервера на компьютере, который вы собираетесь администрировать, необходимо просто произвести двойной щелчок по кнопке мыши.

Клиентская часть Donald Dick поставляется в двух вариантах, различающихся набором функций. Первый — GUI, для работы через OS Windows 9*/NT4, а второй — command line, что существует через строку ДОС и управляется при помощи различных ключей. К сожалению, достаточно удобный Windows-клиент программы далеко не полнофункционален, вследствие чего пользователю в полной мере приходится хлебнуть прелестей с командной строкой ДОС. Для соединения клиентской части с сервером могут использоваться два протокола — SPX или TCP. В целях предотвращения неправомерного использования вашего удаленного сервера на серверную часть программы может устанавливаться пароль. С этим условием любое стороннее подключение исключается.

С помощью этой системы удаленного администрирования вы сможете: просматривать дерево каталогов; стирать, переименовывать, скачивать и закачивать файлы; ставить файлам дату и время; запускать приложения; поставить приоритеты для происходящих процессов; смотреть, создавать и удалять параметры и ключи из реестра; перезагрузить, “повесить” систему, отключить питание системного блока; получить системную информацию, в которой указаны все закэшированные пароли; делать “скриншоты” и пересылать сообщения; прочитать и записать что-нибудь новое в CMOS; отключить на клавиатуре какие-либо кнопки, самому напечатать текст и даже посмотреть, что печатает человек, физически подключившийся к серверу; управлять его манипулятором мышь; выдвинуть или задвинуть лоток проигрывателя дисков; включить и выключить монитор; проиграть разнообразные wav’ы.


Спецвыпуск Хакер, номер #006, стр. 006-032-3, Удаленное администрирование, или наш ответ PC MAGAZINE

Удаленное администрирование, или наш ответ PC MAGAZINE

Спецвыпуск Хакер, номер #006, стр. 006-032-3

Важной отличительной особенностью этой системы удаленного администрирования от других аналогичных систем является то, что она является полиморфной. Т.е. в установленном виде сервер каждый раз разный, что усложняет процесс его идентификации антивирусными средствами.

Net Sphere

Очень хорошая система удаленного администрирования, которая не уступает ни одной другой системе по количеству функций, а по удобству их использования превосходит. Имеет привлекательный интуитивный графический интерфейс, который никого не оставит равнодушным. После запуска сервера программа создает основной файл nssx.exe в c:\windows\system и еще несколько других файлов.

Одна из особенностей программы — возможность запуска сервера с ключом /visible.

В этом случае сервер загружается в видимом режиме и позволяет контролировать количество пользователей, подключенных в данный момент к компьютеру, а также операции, которые на нем производятся. Так что если вы очень любите обмениваться файлами с друзьями, то можете поставить себе серверы и, обменявшись паролями, скачивать друг у друга все что угодно. А если приятель решил у вас незаконно получить дистрибутив Windows 98, можно ему и kick устроить.

Теперь немного о клиенте. Для удобного опознавания при каждом запуске конфигурируется имя и комментарий, которые будут отображаться на сервере (если он видимый) или других таких же клиентах.

Все операции над удаленным компьютером осуществляются через систему контекстных меню, где все функции удобно распределены по функциональным признакам. В меню Tools можно проверить качество связи с данным сервером с помощью Ping’a, а также посмотреть статистику соединения с ним. После подсоединения к серверной части становится доступной кнопка меню Target. С активизацией нажатием вы получите возможность выбора операций, осуществляемых над администрируемой машиной. С помощью Applications

вы сможете узнать, какие процессы запущены на администрируемом сервере, и немного подкорректировать их, придавая некоторую пикантность виртуальному существованию. Keyboard: с помощью этой функции можно следить за всеми нажатиями на клавиши клавиатуры — так можно при определенном стечении обстоятельств получить пароль доступа к серверу сервиса ICQ под иным номером UIN. В разделе Mouse можно поменять местами кнопки мыши, включить шлейф курсора при движении. Пункт меню Screen поможет вам получить “скриншот” рабочего стола, сменить разрешение экрана или же удаленно выключить или включить монитор. Если компьютер администрируется вами тайно (т.е. вы не официально получаете заработную плату за администрирование), из клиента можно установить пароль для подключения к серверу. Также здесь можно установить наименование e-mail, куда будет приходить сообщение о том, что сервер подключен к сети и готов к плодотворной работе. Самые высококлассные функции находятся в разделе Shutdown. Здесь можно выключить компьютер, выйти из сеанса текущего пользователя. Также тут содержится интересная функция kill CPU, применяемая для физического устранения процессора, например, для дальнейшего апгрейда.


Спецвыпуск Хакер, номер #006, стр. 006-032-4, Удаленное администрирование, или наш ответ PC MAGAZINE

Удаленное администрирование, или наш ответ PC MAGAZINE

Спецвыпуск Хакер, номер #006, стр. 006-032-4

А в System находится самая важная для вас информация. Отсюда вы узнаете все необходимые пароли, системную информацию, а также будет доступна функция редактирования и обновления реестра. Например, для ускорения работы компьютера с установленной серверной частью будет полезно устранить записи раздела Software.

Sub Seven Gold

Известная, можно сказать заслуженная, система удаленного администрирования. Предыдущие версии данного приложения отличались наличием порядочного числа программных ошибок. Но с версии 2.1 были исправлены все ошибки, которые мешали нормальной работе программного обеспечения. Немного подумав, разработчики назвали эту версию “Золотой”... не зря! Управление программой вызывало только положительные эмоции, т.к. данное приложение имеет приятный и удобный интерфейс. Программа обладает хорошим инструментом конфигурирования собственной серверной части. Для проведения конфигурации необходимо запустить файл EditServer.exe с диска, на котором расположен дистрибутив программы. После двойного щелчка перед вами появится окно настроек.

В нем необходимо указать метод загрузки сервера: через реестр или через win.ini, а также порт, через который будет производится подключение к нему. Здесь же можно указать почтовый адрес, на который будет приходить оповещение о том, что компьютер с установленным сервером в “онлайне”. Для того чтобы ваш сервер остался недоступным “взломщикам”, группа разработчиков рекомендует поставить пароль. После конфигурирования необходимо нажать на сохранение и получить в результате сервер с заданными параметрами. Далее вы можете преступить к поискам компьютера, который будете удаленно администрировать.

После запуска клиента и ввода IP-адреса производится подключение к серверной части. После соединения с удаленной системой желательно получить информацию об удаленном компьютере. Это можно сделать с помощью нажатия кнопки “get pc info”. Если вам необходим более серьезный контроль над удаленным компьютером, то советую выбрать в левом фрейме закладку advanced. Также обратите внимание на закладку miscellaneous, с помощью содержимого которой можно просмотреть весь диск в поисках командных файлов. Далее желательно удалить, по вашему мнению, ненужные файлы для очистки дискового пространства.

Следующей остановкой в нашем путешествии по закладкам данного продукта будет закладка fun manager. Здесь вы вправе немного пошутить, ведь вы знаете, что смех продолжает жизнь.

Тут имеется снятие “скриншота” с рабочего стола, переворот экрана на 180 градусов и распечатывание текста на удаленном принтере. Также, если вам интересно, возможно изменить разрешение экрана на удаленном компьютере.

Последняя и самая богатая инструментами закладка — это extra fun. Вот здесь-то и раскроются все ваши гениальные планы по управлению отдаленным компьютером. Для начала откроем панель CD-ROM и поменяем местами кнопки на мыши (для большей эргономики). Мало? Немножко похулиганим, уподобившись так называемым “хакерам”, спрятав курсор мыши и напоследок перезагрузив компьютер, предварительно запустив клавиатурного шпиона, который будет работать и в “офф-лайне”. После того как человек зайдет в сеть, мы просто посмотрим, что он там совсем недавно набирал. В этих данных, возможно, будет заключен пароль от Dial-up соединения.


Спецвыпуск Хакер, номер #006, стр. 006-032-5, Удаленное администрирование, или наш ответ PC MAGAZINE

Удаленное администрирование, или наш ответ PC MAGAZINE

Спецвыпуск Хакер, номер #006, стр. 006-032-5

Girl Friend

Эту систему называют “подружкой” и, как это ни пошло звучит, именно с ней вы проведете незабываемое время, особенно если вам установили серверную часть. Она [ваша новоявленная “подруга”] умеет почти все... готовить, стирать, убирать и т.д. и т.п. Это единственная программа обзора, с помощью которой удалось получить легкомысленно забытые пароли, находившиеся в “не кэшированном” виде. Были определены пароли в почтовом клиенте The Bat! и пароль для входа в сеть Интернет. Кроме этой приятной и полезной функции, с помощью “подружки” вы сможете посылать системные сообщения на удаленный компьютер, демонстрировать картинки в формате bmp, сопровождая проигрыванием приятных мелодий, записанных в музыкальные файлы в формате wav и mid. Запускать любые ехе файлы, работать с файлами и подкаталогами, используя файловый менеджер и совершая любые операции над файлами и файловой структурой.

О возможностях программы мы рассказали, а теперь немного о том, как происходит процесс работы. Для начала требуется узнать IP-адрес удаленного компьютера и, введя его, нажать на кнопочку connect. После соединения мы можем делать то, что захотим, а, в общем-то, что позволит клиент. Первым делом после соединения советуем нажать на show passes, записав искомый пароль и имя пользователя для доступа в Интернет. Нажав на custom, вы сможете вводить текстовые команды, количество которых достаточно велико. Среди них есть такие важные вещи, как удаленное нажатие клавиши RESET. А введя команду HELP, вы сможете увидеть подробно е, удобно устроенное руководство пользователя. Теперь вам доступен полный список всех команд, адаптированных для текстового ввода. Очень приятный момент в организации работы: данное приложение можно минимизировать, оставив иконку на системной панели, путем нажатия клавиши F12.

Deep Throat

Ну, если позволите, это классика. Находящаяся на таком же высоком уровне, как и широко известный Back Orifice (по заключению профессионалов). Но... сотрудникам тестовой лаборатории она понравилась больше, чем Back Orifice. Огромное количество функций и удобная система управления, в работе оказавшаяся абсолютно интерактивной. Программа умеет все или почти все. Ищет на жестком диске пароли и выдает их вам, показывает всю информацию об удаленном компьютере, вплоть до ключа операционной системы Windows. DT поможет вам организовывать ФТП сервер на администрируемом компьютере и позволит редактировать реестр. Для проведения вашего досуга предусмотрены функции развлекательного плана. Такие, как открытие CD-Rom, заморозка курсора манипулятора, включение шлейфа курсора и обмен кнопок манипулятора местами.


Спецвыпуск Хакер, номер #006, стр. 006-032-6, Удаленное администрирование, или наш ответ PC MAGAZINE

Удаленное администрирование, или наш ответ PC MAGAZINE

Спецвыпуск Хакер, номер #006, стр. 006-032-6

Как у программного обеспечения хорошего класса — естественно, имеется возможность поставить пароль на сервер. Так что различные темные личности, называющие себя “хакерами”, не смогут помешать вашей административной работе. Это наш выбор, выбор авторитетной тестовой лаборатории.


Спецвыпуск Хакер, номер #006, стр. 006-036-1, Как мне впарили трояна...

Как мне впарили трояна...

Спецвыпуск Хакер, номер #006, стр. 006-036-1

Слушал ламера, соболезновал, записывал SideX (sidex@xakep.ru)

Детство

Тогда не было троянов, по крайней мере, я о них не знал. И основными “вредоносными программами” являлись вирусы. Приходил ко мне приятель, прихватив дискеточку 5,25. Где находились чудные игры, программки, какие-то файлы странные. Почему-то смущал меня мой корефан, когда расплывался лукавой улыбкой, наблюдая за тем, как я запускаю файл game.exe.

Еще больше он улыбался, когда я рассказал, что у меня потерло все на винте, а при загрузке вылезает надпись “Привет с того света”. Смешно ему было, что дядька ламер купился на чудо-игру, в которую толком-то и поиграть не успел. А что поделаешь? Времена-то были тяжелые, и достать достойный софт и гамесы было не просто. Особенно часто я стал загребать вирусы, скачав файлики с ББСок. Где хранились суперигры, типа дума и еретика, имевшие объем в 5К. :) И как ты понял, меня разводили на том, что очень хотелось погамиться. Но время шло, и постепенно возросли ставки: теперь злодеи хотели лишить меня честно купленного Инета, выкрав пароли троянцами.

Супер проги

Так исторически сложилось, что трояны содержатся в исполняемых файлах. Ровно, как и все остальные, не такие ужасные проги. И увидев sex.exe, я ничуть не смущался, полагая, что в файле находится очень ценная программа. А что за программа? Этим вопросом задавались многие хацкеры, пытавшиеся меня поиметь. Для них сообщу, что меня очень интересовали проги с различными волшебными возможностями, среди которых было немало хакерских. Разберемся по порядку.

Нюки. Атака на отказ — одно из совершеннейших явлений хакинга. Вот и мне захотелось получить софт, запустив который, я смогу расправляться со злодеями, выкинув их из сети. И встретив обещание “Супер нюк убивает любую систему”, обязательно скачивал предлагаемый файл.

Файл: NUKE2000.EXE

Крякер паролей. Ламерам тоже хочется чего-нибудь похакать. Они тоже люди. Вот и я нашел как-то ПО для взлома любого сервера или любого пользователя сети. Там было такое обещание: “Введите адрес сервера и через 2-3 минуты вы получите все содержащиеся пароли”. Вот мне и захотелось что-нибудь взломать этой программой. Для хака обычного юзера там прилагался дополнительный модуль, описанный хацкерами так: “Введите IP адрес жертвы, и вы сможете получить пароль от Интернета, а если пожелаете — можете испортить компьютер или отключить его от сети”.

Файл: PASSWORDHACK.EXE

Генератор. Я как-то слышал про кардеров, и мне тоже захотелось получать товары по кредитной карте, не заплатив ни копейки. Тогда я стал искать генераторы номеров. Но находил только левые какие-то. Совсем обыскался, пока не обнаружил новый ген. Его автор сообщал следующее: “Теперь вы можете получать номера кредитных карт системы VISA в любом количестве, причем полученные номера будут исключительно рабочими, и вы сможете производить покупки в онлайн магазинах”. Вот такой чудо-генератор.

Файл: GENERATOR.EXE

Другой генератор. С недавних пор стало модно вводить оплату за Инет по карточкам, например, как у МТУ, Ситилайна, РОЛ, ОРЦ. На покупаемой карточке находятся ключ и код, которые требуется ввести для получения доступа. Только я подумал, что можно эти номера генерировать, как мне попался такой нужный инструмент:


Спецвыпуск Хакер, номер #006, стр. 006-036-2, Как мне впарили трояна...

Как мне впарили трояна...

Спецвыпуск Хакер, номер #006, стр. 006-036-2

“С новой программой вы сможете получить постоянный доступ в сеть Интернет, получив сгенеренные коды”. Всего было несколько программ, рассчитанных под каждого провайдера. Я скачал и запустил все.

Файл: MTUPASSWORD.EXE

Ускорители. Как-то мне предложили скачать ускоритель браузера, позволяющий работать в 5 раз быстрее! Но я не поверил, т.к. знал, что настолько сильно ускорить соединение нельзя. Я был уверен, что можно максимально достигнуть ускорения вдвое или втрое. И нашел реально работающий ускоритель: “Вам не надоело дожидаться загрузки страниц в браузере? Хватит. Теперь с помощью

SPEED браузер будет работать в 3 раза быстрее!!!”. Но что-то ускорения я не почувствовал и стал искать модемный акселератор. И нашел специальный девайс, позволяющий соединяться на скорости 115 КБ в сек! Это быстрее, чем на выделенке, представляешь! Человек, предложивший мне эксклюзивно протестировать новинку, объяснил это новое явление так:

“В условиях российских телефонных сетей работать в Интернет практически невозможно. Требуется корректировка и фильтрация сигналов. Учитывая множественные просьбы и заявления пользователей Интернет, оборонной промышленностью был разработан радикально новый метод очистки телефонных сетей, заключенный в небольшую программу. Теперь вы сможете значительно ускорить работу в Интернет, достигнув небывалого качества связи — 115 КБ/С.”. От таких предложения не отказываются.

Файл: SPEED.EXE, FASTMODEM.EXE

Защита. Ну, кому бы ни хотелось почувствовать себя в безопасности? Я — не исключение, и почувствовав опасность со стороны хакеров, стал заниматься своей обороной. Например, я очень боялся за свой компьютер в период Милленниума. Ты же сам, наверное, слышал про всякие вирусы, активизирующиеся с наступлением 2000 года. Не стоит забывать и о проблеме 2000-ого года, которой я опасался не менее. И, видно, были услышаны мои молитвы — прислали под Новый год мне исправитель проблемы 2000. Кажется, из кампании Negrosoft, для устранения проблемы в их операционной системе Walls 98 и Walls NT. Проблему я устранил, но опасения относительно вирусов не пропали. Наверно, так и сейчас бы боялся, кабы ни получил патч от вирусов “Лариса” и “Вынь чих”. Установив защиту от вирей, я попросил выслать мне защиту от вируса Happy, но мне так и не ответили. :( Очевидно пишут эксклюзивную защищалку для меня!

Файл: BUG2000.EXE, ANTIVIRUS.EXE

Разгон. Это что-то из серии ускорения, но нечто более железное. Однажды я прознал про такое понятие, как “разгон”, позволяющее увеличить скорость работы за компом в несколько раз! Но, как мне объяснили, надо лазать внутрь машины и еще что-то крутить в биосе. Это отстой, и для более простого решения я обнаружил девайс, с помощью которого можно сделать из моего P200 — P3 450!

Файл: UPGRADE.EXE

Женщины

Так уж повелось, что я увлекся сетевыми знакомствами и в определенный момент времени предлагал обменяться с девушкой фотками. Относительно моих фотографий — промолчу, т.к. это тебе не интересно. Куда более затейливы девочки инетчицы, со своими фотками. Стал я замечать, что девки сами стали давать... пардон, давать фотки. Поначалу я их брал и запускал, но потом, поняв подвох, стал настороженно относиться к столь темпераментным дамам. Короче, меня разводили более грамотно — кормили разговорами в течение минут 20, пока я ни доходил до нужной кондиции и сам ни просил фоту. Отсюда вывод, что на слишком быстрые предложения лицезреть мордаху новой знакомой не обязательно поведется ламак типа меня. Потом я узнал, что злодей, который давал мне вредоносные программы под видом фотки, параллельно так же общался еще с 5-ю такими же чайниками, как я.


Спецвыпуск Хакер, номер #006, стр. 006-036-3, Как мне впарили трояна...

Как мне впарили трояна...

Спецвыпуск Хакер, номер #006, стр. 006-036-3

Однажды мне предложили запустить файл foto.exe. Но даже несмотря на мою компьютерную неграмотность, я не повелся на это дело: какого, спрашивается, хрена фотки стали паковать в исполняемые файлы? Ну, мне и объяснили, что это самораспаковывающийся архив, который даме сделал старший братик, чтобы арх весил меньше. И что самое интересное — такое объяснение я получил чуть ли ни от трех “девиц”, дававших foto.exe. Потом смотреть фотки стало интересней, т.к. они стали находиться в загадочном варианте — foto.jpg.............................exe. И весили ~ 30К. Бывало и так, что после запуска фотки у меня выскакивало сообщения об ошибке или вообще ничего не было. :( После моего вопроса девицы обычно исчезали, и у аськи загорался красный цветочек. Не судьба, видать.

А как-то ко мне в аську залезла такая любвеобильная дама, что предложила взглянуть на ее чудное личико из файла весом в 500К. “Наверно, в ней столько любви и страсти”, — подумал я, и закачал файл sexylena.bmp.......................exe. Кабы это был файл в JPG, то ни в жизнь не поверил бы, а тут БМП, славящийся своей изрядной толщиной. Запустив, никакой особой любви не получил: на фотке был негр с надетым чехлом на половой инструмент. :) Шутница попалась. Как попалась, так и исчезла через 5 минут, сказав, что пошла почту проверять. До сих пор оттуда не вернулась. :)

Но потом с моего счета у провайдера ежемесячно стало списывать порядка 300-500$, и я стал экономить, и вместо прежних 40 минут в день выходил в Инет на полчаса. И вместо аськи прибег к услугам служб знакомств онлайн, таких как fortune.ru, kiss.ru, dating.ru. Где оставлял свое объявление с предложением к знакомству. Писем было не так много, как я ожидал, но вот фоток пришло прилично: наверно, я такой красивый был, что мне с первого же письма фотку кинули. :) Тут приходили все те же photo.jpg..........................................exe, с комментариями типа: “Мои откровенные фотографии только для тебя. Пожалуйста, когда посмотришь фотки, обязательно напиши мне или перешли своим друзьям. Целую”. Вот как лихо завернула! Но мне не понравился такой момент: письмо этого содержания и наполнения пришло не только мне, но и еще 20 мужикам, занесенным в раздел Carbon Copy.


Спецвыпуск Хакер, номер #006, стр. 006-036-4, Как мне впарили трояна...

Как мне впарили трояна...

Спецвыпуск Хакер, номер #006, стр. 006-036-4

В дальнейшем я открывал письма, только адресованные мне, учти это, хацкер.


Спецвыпуск Хакер, номер #006, стр. 006-038-1, Дружба Аси и Линукса

Дружба Аси и Линукса

Спецвыпуск Хакер, номер #006, стр. 006-038-1

Delta (delta@caravan.ru)

На сегодняшний день уже трудно представить себе человека, сидящего в Инете без маленького зелененького цветочка в нижнем правом углу (для фанатов LiteStep’a — в левом ;) ) — аська настолько плотно вошла в обиход, что ее можно увидеть запущенной и у маленького 7-летнего братца, и на компе у декана (сам видел :) ). До недавнего времени аська работала исключительно под виндами — все юниксоиды сидели, грызли ногти и ждали “официальной версии” от Mirabilis... которая все еще находится в стадии разработки. Терпение у народа кончилось, и на свет появилось большое количество клонов и аналогов виндовой аськи. Уже, наверно, всем ясно, что этот обзор о них :).

Консоль

micq

micq — одна из наиболее распространенных текстовых асек. Существует версия и под Win32 — фанаты ставят ;). Поддерживает контакт лист, прием/отправку простых мессаг, урлей, поиск и добавление новых юзеров, а также регистрацию новых UIN`ов. Шифрование пароля, возможность его введения каждый раз при загрузке — в общем, по возможностям почти полный аналог виндовской версии. В настоящий момент пока еще нет icq-chat’a, но это лишь вопрос времени.

Homepage: http://phantom.iquest.net/micq/

Требует: кроме unix-type операционки — ничего ;). (размер — 67кб)

zicq

Еще одна консольная аска — zicq. Основное отличие от micq — более удачный псевдографический интерфейс (впрочем кому как: мне, например, “интерфейс” micq больше нравится). Любителям текстовых окошек и кнопочек — ставить обязательно ;). Есть поддержка “send URL” и звукового оповещения событий. Чата пока тоже нет ;(.

Homepage: http://

asenteck.

com

/~ted23

/computing

/zicq/

Требует: ncurses (есть на любом дистрибутиве Linux, и не только).

cicq

cicq — еще один клон. Упор сделан на командную строку, но получилось хуже, чем в micq. Немного другой принцип работы — в отличие от micq, cicq сидит как background job и всплывает только при получении мессаг, освобождая таким образом консоль.

Homepage:

http://uhura.cc.

rochester.edu

/~ab012f/cicq/

Требует: cicq static glibc2 source/binary, libicq 0.20

Иксы

gnomeicu

gnomeicu (Gnome’s Internet Communication Utility) — одна из лучших иксовых асек. Поддерживается почти все: чат (долгожданный ;) ), обработка мессаг, файлов, урлей, добавление юзеров в контакт лист и их переименование, поддержка разных онлайн режимов (away,d’n’d, N/A и т.д.) и еще много чего ;). Тем, кто не хочет особо напрягаться с настройкой, — ставить однозначно.

Homepage: http://gnomeicu.gdev.net/

Требует: X11R6, gnomelibs

ICQnix

Настоящее подобие виндозовой версии — ICQnix. Интерфейс привычен и удобен... но вот возможностей явно маловато: отсутствует чат, регистрация новых юзеров (первый раз придется регистрить UIN из-под виндов или в другом клоне). Сама по себе gicq проста в использовании — еще не отвыкшим любителям форточек самое то.

Homepage: http://icqnix.learnrespect.org/

Требует: X11R6, Qt

licq

Хорошая по функциональности альтернатива gnomeicu — licq. Есть чат, прикольные звучки, менюшки, правда, кривоваты, но пойдет и так ;).

Homepage: http://licq.wibble.net/


Спецвыпуск Хакер, номер #006, стр. 006-038-2, Дружба Аси и Линукса

Дружба Аси и Линукса

Спецвыпуск Хакер, номер #006, стр. 006-038-2

Требует: X11R6, Qt

kicq, kxicq

Тем, у кого в качестве основного интерфейса стоит KDE, — можно поставить kicq или kxicq. Kicq копирует внешний вид родной версии от mirabilis и пока еще находится в стадии альфа тестинга — большинство функций не работает или работает криво ;), тем не менее такие базовые фичи, как посылка мессаг или добавление коефанов (корефанок ;) ) в контакт лист, работают. Kxicq отлажена получше, имеет работающий чат, удобный контакт лист, прием/посылку файлов и стандартнейший KDEшный вид ;).

kicq

Homepage: http://www.cn.ua

/~denis/kde/kicq.html

Требует: X11R6, Qt, KDE

kxicq

Homepage: http://www.caiw.nl

/~herwinjs/

Требует: X11R6, Qt, KDE

Фишки

Кроме просто icq-клиентов есть еще несколько просто прикольных и полезных программок:

icqmail

icqmail — висит на шелле в бэкграунде и форвардит icq-мессаги на е-мыл. Если извратиться, то можно настроить отправку сообщений себе на сотовый/пэйджер \m/ \m/.

Homepage:

http://www.crocodile.org/software.html

Требует: icqlib

icqtech

icqtech — типа icq маршрутизатор-файрвол ;). Если кто присылает мессагу, в зависимости от содержащегося в ней текста, может либо ее пропустить, либо развернуть. Причем самая забавная возможность этого демона — его можно настроить так, чтобы он посылал в ответ юзерам мессаги с дополнительными вопросами по удостоверению личности ;)) — anti-lame protection (c). Можно организовать техпомощь по icq, когда по разным ключевым словам в тексте сообщения оно перенаправляется на различные UIN’ы.

Homepage:

http://hnm.zzweb.com/utils/icqtech/

Требует: icqlib

That’s all folks.

P.S. icqlib-0.1.3 лежит по адресу http://www.cn.ua/~denis/kde

/icqlib-0.1.3.tar.gz


Спецвыпуск Хакер, номер #006, стр. 006-040-1, Генератор Зла

Генератор Зла

Спецвыпуск Хакер, номер #006, стр. 006-040-1

The Hound Of Winter (thow@ireland.com)

После того, как рубрика перешагнула полугодовой рубеж и вступила во взрослую жизнь, редактор решил взяться за нее по-крупному. «Давай, — говорит, — порадуем читателя нужным материалом о виргенах». Ну, а что бы и не порадовать? :-) Тем более, когда редактор уже тянет свои дрожащие короткие ручки к моей чистой шее и исходит злобным ехидным смехом... :-E Брр... Надо меньше пить. :-) Для тех, кто не понял, — это мне такой кошмар приснился. Вот до чего работа в журнале доводит, ведь “работа наша и опасна, и трудна, хоть на первый взгляд она и не видна”. :-))) А идея и правда хорошая — так что ее и реализовываю.

ДОСЬЕ

ИМЯ: Генератор вирусов. Также известен как конструктор вирусов.

АВТОР: Почти всегда чукотские вирмейкеры...

ВОЗРАСТ: Первые появились около 7 лет назад. С тех пор некоторые деградировали до младенческого возраста, а некоторые пытались эволюционировать. Удачно.

НАЗНАЧЕНИЕ: Быстрая сборка каркаса или вируса целиком из отдельных независимых частей в единое целое. Целое и неделимое — это не то, что так боятся потерять некоторые девушки. Гы-гы-гы. :-) Это либо бинарник, либо исходник вирия.

ЦЕЛЬ: 1) Скрыть вирус от программы антивируса. Для этого комбинируемые части могут перемешиваться, кодироваться и т.д. 2) Ускорить процесс написания вируса, поскольку в большинстве вирусов, по сути, используются один и тот же код для различных процедур. Поиска файлов, к примеру. Так вот, чтобы не копаться вручную с кусками кода, можно пользовать вирген, который загенерит не вирий сразу в бинарнике, а исходный его код. Потом ручками то, что надо, вписывается, и все OK.

ПОСЛУЖНОЙ СПИСОК: Отметились целыми семействами вирусов во всех крутых антивирусах, так что виргены — это сила. Особенно для начинающего.

ХАРАКТЕР: Нордический, конечно. То есть большинством виргенов можно управлять задавая им ЦУ (ценные указания) через командную строку. Но есть и более умеренного темперамента, которые имеют приятный дружественный интерфейс.

СЕМЕЙНОЕ ПОЛОЖЕНИЕ: Иногда исходники производятся на языках высокого уровня (ЯВУ), но много чаще на ассемблере. Хотя есть даже для BATCH-файлов под тетю ДОСю.

ИМЯ: Virus Creation Laboratory (VCL)

АВТОР: Nowhere Man//NuKE

ВОЗРАСТ: Вышел в свет в конце лета 1992

года.

НАЗНАЧЕНИЕ: VCL известен как самый первый в мире вирусный генератор-конструктор.

ФИШКИ: Помимо того, что этот конструктор был первым, он имел несколько замечательных черт, таких как:

Все идет одним архивом-package. В архиве даже есть инсталлятор и документация с описанием кусков кода и т.п. стаффом (stuff — всякой всячиной в смысле).

Генерирует вирусы практически всех возможных типов:

Overwriting вирусы

Appending вирусы

Companion (spawning) вирусы

Каркасы для троянцев и логических бомб

Возможность задания свойств генерируемого кода. Код оптимизируется (!). При желании можно добавить в него антиотладочные и антидизассемблерные вставки.

ПОСЛУЖНОЙ СПИСОК: Однако, несмотря на все свои положительные качества, VCL не вызвал очень большой волны свежих вирусов и не снискал широкой популярности. Причин этому было много, но, скорее всего, главной была высокая уязвимость сгенерированных вирусов для антивирусных продуктов. Большинство антивирусов стали обнаруживать вирусы, сделанные с помощью VCL, еще до выхода его в свет (вероятно, по восьми тестовым вирусам, отправленным на свободу задолго до самого VCL).


Спецвыпуск Хакер, номер #006, стр. 006-040-2, Генератор Зла

Генератор Зла

Спецвыпуск Хакер, номер #006, стр. 006-040-2

ХАРАКТЕР: Дружественное междумордие имеет даже крысиную поддержку и хелп-файл. Сделано по типу ТрупоВижна от Багланда C++ 3.11. Настраиваемость среды. Настраиваемые цвета, пополняемая библиотека процедур для воспроизведения эффектов и определения условий срабатывания.

НЕДОСТАТКИ: Довольно невысокое качество ассемблерного кода. Некоторые антиотладочные вставки просто не работают или завешивают комп, а иногда ассемблерный код вообще не компилируется. :-(

В апреле 1994 года Firecracker (затем вступивший в NuKE) выпустил VCL Mutator, заменяющий характерные участки кода VCL-вирусов на аналогичные, не обнаруживаемые (тогда) антивирусами.

ИМЯ: Phalcon-Skism Mass Produced

Code Generator

АВТОР: Dark Angel//Phalcon/SKISM

НАЗНАЧЕНИЕ: Является намного более мощным и качественным продуктом, нежели VCL.

ФИШКИ: С помощью PS-MPC можно создавать полноценные вирусы со следующими свойствами:

Поражение COM и EXE файлов.

Резидентный и нерезидентный код.

Два разных алгоритма обхода для нерезидентных вирусов.

Несколько способов размещения в памяти резидентного кода.

Исключение COMMAND.COM из поражаемых файлов.

Генерируемый обработчик критических ошибок.

Случайно генерируемый алгоритм шифрования кода вируса.

Компактный, чуть лучше (чем в VCL) оптимизированный код.

Исходники замечательно откомментированы.

Примечательной особенностью этого конструктора является то, что он распространяется в исходных кодах (Turbo C), что было побуждением для многих авторов выпустить свои измененные версии компилятора. Это привело к еще большему увеличению числа вирусов, произведенных с его помощью.

ПОСЛУЖНОЙ СПИСОК: PS-MPC оказался гораздо более продуктивным инструментом, нежели VCL. С его помощью было создано несколько сотен вирусов, и многие из них имели широкое хождение. После того, как Aristotle (NuKE) выпустил Metric Buttload of Code Generator, генерировавший десятки слегка модифицированных PS-MPC вирусов, количество таких вирусов выросло еще больше.

ХАРАКТЕР: Полное отсутствие красивого интерфейса. Идеология P/S заключается в том, что “настоящий профессионал работает с командной строкой”. Конфигурация создаваемого вирусного кода задается опциями из текстового конфигурационного файла.

Сам по себе PS-MPS не генерирует каких-либо деструктивных функций, но предоставляет очень понятный и отлично откомментированный код, так что понимание и изменение вирусного кода не представляет никакого труда.

ИМЯ: G2

АВТОР: Dark Angel//Phalcon/SKISM.

НАЗНАЧЕНИЕ: G2 или G в квадрате — своеобразный символ от “Second Generation in virus creation”.

ФИШКИ: Очень напоминает PS-MPC, но гораздо мощнее. Выпущен в единственном варианте, хотя автор заявил, что будет выпускать апдейты. Для этого вся информация о вирусах была вынесена в отдельный файл, который потом (и только он один) заменялся бы на более новый. Отличительной особенностью является наличие возможности специальной модификации кода генерируемых вирусов.


Спецвыпуск Хакер, номер #006, стр. 006-040-3, Генератор Зла

Генератор Зла

Спецвыпуск Хакер, номер #006, стр. 006-040-3

ПОСЛУЖНОЙ СПИСОК: С помощью G2 создано несколько десятков реальных вирусов.

ХАРАКТЕР: Такой же, как и у PS-MPC. G2 совместим снизу вверх с PS-MPC по формату конфигурационных файлов.

ИМЯ: Biological Warfare.

АВТОР: MnemoniX.

ФИШКИ: Генерируемые вирусы имеют следующие характеристики:

Могут быть как резидентными, так и не резидентными.

Поражают EXE и COM файлы.

Шифрование — как простое, так и с помощью Biological Warfare Mutation Engine. Это небольшой полиморфный генератор, который несколько затрудняет обнаружение вирусов.

Наличие антитрассировочных приемов.

Поражение COMMAND.COM — опционально.

Обработчик Int24 (критической ошибки DOS).

Два уровня Stealth.

Плюс способ обхода каталогов, проверка оверлеев.

ХАРАКТЕР: BW, как и все вирускомпиляторы, генерирует исходный код (разумеется, ассемблер) вируса в соответствии со спецификациями, заданными пользователем. Задание опций генерации происходит интерактивно, то есть в виде вопросов и ответов.

ИМЯ: NuKE Randomic Life Generator.

АВТОР: Azrael//NuKE.

ФИШКИ: Компилятор позволяет задать набор свойств вируса, среди которых противодействие резидентным антивирусам, уничтожение файлов контрольных сумм, процедуру шифровки/дешифровки. Помимо этого NRGL предлагает набор деструктивных функций, которые можно внедрить в код создаваемого вируса, таких как уничтожение MBR, файлов и случайных секторов. Код, генерируемый NRGL, не отличается читабельностью, хотя человек, неплохо знающий ассемблер, может в нем разобраться.

ХАРАКТЕР: Выполненный в лучших традициях инструментов NuKE — с красочной IDE, этот компилятор тем не менее не пользовался большой популярностью среди вирусного сообщества, хотя и известны несколько десятков NRGL-вирусов.

ИМЯ: Virus Construction Set.

АВТОР: Verband Deutscher Virenliebhaber (Ассоциация Любителей Вирусов).

ФИШКИ: Вирусы, созданные этим компилятором, имеют одинаковые характеристики:

Поражение только COM-файлов.

Количество поражаемых файлов фиксировано.

Результатом активации является уничтожение autoexec.bat и config.sys и вывод заданного при генерации текста. Единственной “изюминкой” конструктора является наличие в создаваемых вирусах средств маскировки под антивирус FluShot.

ПОСЛУЖНОЙ СПИСОК: Известно несколько VCS-вирусов.

ХАРАКТЕР: VCS не отличается особой изощренностью. VCS запрашивает текст, появляющийся в теле вируса, и количество поколений вируса, после которого наступает активация. Затем VCS создает файл virus.com, содержащий вирусный код.

ИМЯ: Virus Creation 2000.

АВТОР: Havoc The Chaos.

ФИШКИ: Содержит антиантивирусный код:

Блокирует клавиатуру при попытке трассировки кода.

Обходит ThunderBYTE TBClean.

Завешивает Turbo Debugger.

Противодействие ThunderBYTE TBSCANX.

Код для борьбы с F-Prot.

ПОСЛУЖНОЙ СПИСОК: The Virus Creation 2000 System, сокращенно называемая VC2000, довольно неплохая система генерации вирусного кода. Распространяется в виде одного файла размером около 25K.


Спецвыпуск Хакер, номер #006, стр. 006-040-4, Генератор Зла

Генератор Зла

Спецвыпуск Хакер, номер #006, стр. 006-040-4

ХАРАКТЕР: Перед созданием вируса необходимо специфицировать его свойства, такие как:

Резидентность или нерезидентность вируса.

Дописывание или записывание поверх кода жертвы.

Проверка внутренней структуры поражаемых файлов.

Проверка размеров COM-файлов.

Буферизация DTA-области на время поиска.

Оригинальный метод поиска жертв.

Обработка Int24 прерывания на предмет критических ошибок.

Примечательно, что вместе с вирусом может быть сгенерирован код определения наличия генерируемого вируса в памяти. Для удобства работы при генерации ассемблерного кода также генерируется и пакетный файл MAKEVIR.BAT, продуцирующий двоичный код вируса.

ИМЯ: Instant Virus Production Kit.

АВТОР: Youngsters Against McAfee.

НАЗНАЧЕНИЕ: Американская группа YAM выпустила в свет IVP как очередную попытку выпустить удачный вирусный компилятор. Но попытка эта не увенчалась успехом — продукт вышел очень и очень слабый. Даже по сравнению с более ранними VCL или PS-MPC в IVP отсутствует возможность создавать резидентные вирусы.

ПОСЛУЖНОЙ СПИСОК: Есть порядка сотни IVP-вирусов.

НЕДОСТАТКИ: Схема шифрования IVP вирусов ужасающе слаба. В дополнение ко всему код, вырабатываемый IVP, зачастую просто не работает.

ИМЯ: GenVir.

АВТОР: J.Struss.

ФИШКИ: Первый shareware (!!!) вирус-генератор. Интересно, а будут ли коммерческие версии вирусов? :-) Написан во Франции для оценки качества антивирусных продуктов. Конструктор выполнен на французском языке, а в состав дистрибутива входит даже форма для заказа коммерческой версии!

ПОСЛУЖНОЙ СПИСОК: Известно не более двадцати GV-вирусов.

ИМЯ: Virus Kit.

АВТОР: Stalker-X//NuKE.

НАЗНАЧЕНИЕ: Первый компилятор Windows-вирусов.

ФИШКИ: Вирусы, создаваемые VKIT, поражают Windows 3.1 EXE-файлы. При генерации можно задать строчку, помещаемую в тело вируса, и счетчик, влияющий на скорость распространения вируса. Позднее был преобразован в Windows Virus Engine.

ИМЯ: LAboratorio de Virus.

АВТОР: Father Mac.

ФИШКИ: LAboratorio de VIrus, также называемая LAVI — вирусный конструктор, в целом использует те же принципы, что и VCL. В дополнение к этому содержит библиотеку деструктивных функций Mass Destruction Library, выпущенную американской группой Evil Avatar.

ПОСЛУЖНОЙ СПИСОК: Существует пара десятков LAVI-вирусов.

ИМЯ: Virus Lab Creations.

АВТОР: Trixter.

ФИШКИ: Довольно неуклюжий комплект размером более мегабайта, включающий в себя компилятор TurboC, Turbo линкер, собственно генератор кода и набор C-библиотек. VLC генерирует исходные тексты вирусов на C, что само по себе оригинально, хотя и сомнительно с точки зрения получения хорошего кода.

ИМЯ: Batch Virus Generator.

АВТОР: Wavefunc.

НАЗНАЧЕНИЕ: Оригинальная разработка — генератор вирусов на командном языке DOS (BAT-файлы).

НЕДОСТАТКИ: Вирусы, созданные этим конструктором, легко обнаруживаются и уничтожаются.

Большинство из представленных вирус-конструкторов можно найти на сайтах, где есть вирий-архивы. Например, vx.netlux.org — просто рай как для начинающего, так и опытного вирмейкера.


Спецвыпуск Хакер, номер #006, стр. 006-044-1, Вечерний звон!

Вечерний звон!

Спецвыпуск Хакер, номер #006, стр. 006-044-1

Автор: Zелененко MaXX (zelu@mail.ru)

Хороший провайдер - мертвый провайдер

Не знаю, как у тебя, приятель, а лично у меня при упоминании названия моего провайдера со словосочетаниями типа "хороший и прекрасный" начинают сжиматься кулаки, возникает неадекватное желание что-нибудь разрушить или, по крайней мере, хоть кого-нибудь убить. Именно ему я обязан потерей нервных клеток в ситуации, когда я прихожу домой и после тяжелого рабочего дня пытаюсь попасть в родной Инет - звонишь и получаешь то сигналы "занято", то сообщение, что "удаленный компьютер не отвечает". Продолжается это от 5 минут до нескольких часов, причем, несмотря на все попытки, никакой закономерности вычислить мне не удалось. Все это, помноженное еще на явно упрощенный интерфейс в службе удаленного доступа в "Форточках 98", который, по-моему, построен по схеме ННВКС (Нажми На Все Кнопки Сам), и целью имеет просто убить тебя бесконечными нажатиями клавиш, вообще кого угодно в гроб загонит. И скончаться бы мне совсем молодым или сесть в тюрьму за хулиганство, а может, и за убийство, если бы однажды в бесцельных скитаниях по Сети я ни наткнулся на свое спасение.

Олицетворением чуда в масштабах московской квартиры стал тусняк небольших прог, задача которых описывается предложением: "Долбить их звонками, пока не подключат!!!" Прог такого типа на серваках по Инету - хоть ушами ешь, и я, как истинный хацкер, ни за что не подскажу, какую выбрать (типа, сам репу чеши). Ну ладно, не ной уж, в конце (если дочитаешь) скажу, что сам выбрал, да и по ходу выводы сделаю.

Чтобы мне не повторяться, а тебе сорок раз не читать: почти все проги freeware (shareware будут отмечены), каждая из них имеет голос для оповещения об установке и разрыве связи, все умеют становиться додельными (читай: системными) и существовать в трее. Ну, типа, вперед и с песней! Да не выть, а петь, я сказал.

Hidialer

Стильная прога для любителей всякого рода проигрывателей, она уменьшается до размеров маленькой полоски (типа CD player) и угодливо показывает тебе, сколько сейчас времени (корректирует системное время через Инет) и сколько ты, дружок, уже насидел сегодня. На той же панельке кнопочки коннект и дисконнект, название подключения. В скрытой панельке настроек имеет свой таймер, отслеживает закрытие окошек и разрывает соединение (если ты уснул и не заметил, хотя на фиг ты такой сонный в Сеть залез). Ведет подсчет суммы, на которую ты попал, и логи по каждому соединению. Запускает другие проги при подключении, восстанавливает соединение при разрыве. Номеров может включать несколько, и при подключении ими пользоваться. Написали ее наши ребята, но язык почему-то не наш.

Недостаток: у меня прога почему-то отказалась работать как автономная звонилка, но прекрасно работала, используя соединения "форточек". Подойдет тем, кому 100% не грозит злонамеренный хак.

Качнем: www.download.ru

Quick Dialer

Неплохая, но какая-то серенькая программулька, все в ней как-то обычно, и стиля особого не замечено, зато маленькая. Помогает одним нажатием кнопки мыши подключиться к Инету, перебирает все введенные номера провайдера. Включает другие проги при входе в Сеть, восстанавливает связь при обрыве. Приглядывает за временем соединения, ведет какую-то свою статистику. Подрабатывает на полставки бухгалтером и, вообще, ведет себя как налоговый инспектор (столько настроек для обсчета!). Автор русский - слова заморские, но не сложные. Хорошо то, что при размере в 197КВ она предоставляет достаточно широкий набор функций. Недостатки: 1) Отсутствует таймер. 2) Прога shareware, 30 дней, и шлите деньги переводом (50 дер. (наши любимые деревянные)).


Спецвыпуск Хакер, номер #006, стр. 006-044-2, Вечерний звон!

Вечерний звон!

Спецвыпуск Хакер, номер #006, стр. 006-044-2

В общем, если ты любишь обычность, миниатюрность, неплохой набор функций и оплаченность за все это добро, то это твой выбор. Подойдет людям с недостатком места на харде.

Качнем: www.listsoft.ru

Muxasoft Dialer

Это вам не МУКСАсофт - автора зовут Михаил! Одна из самых классных прог обзора. Миха, парень ее написавший, вставил в нее почти все, о чем только можно мечтать ленивому юзеру. Система дозвона предусматривает перебор не только номеров, но и соединений; пароль программа запоминает автоматически и установки флажков не требует (вот это я вам скажу - кайф). Умеет запускать проги при коннекте, закрывать при дисконнекте и реагирует на закрытие окон отслеживаемых прог разрывом соединения. Естественно, умеет перезванивать при обрыве. Интуитивно сделаны настройки, так что копаться в них долго не придется. Очень классно в виде таблицы сделана система подсчета затраченной суммы, она позволяет установить несколько тарифов для разного времени суток и автоматически их учитывает. Ведет статистику. Самая классная примочка программы - наличие быстрых клавиш для установки (F11) и разрыва (F12) связи, лично мне это очень понравилось возможностью не ерзать мышью по экрану, а заниматься своими делами пока раб звонит. Слегка ошарашило то, что в программе отсутствует таймер, возможность ведения логов (последнего реально не хватает, видно, у Миши был анлимит). Приговор - красивая и хорошо сделанная прога, очень удобна (если ты ленив, как я, то это твой выбор). В скором времени автором обещается выпуск обновления.

Качнем: www.softlist.ru

Bob Connect

Программа хорошая, но вся на басурманском. Вот я не завидую тому, кто его не знает. Очень приятная в использовании. Имеет прекрасный интерфейс. Единственная из всех, кто имеет возможность установления минимальной скорости соединения, что полезно для наших линий, так как если скорость меньше установленной, то над твоим соединением пролетит розовая птица обломинго. Не стоит говорить о том, что она в состоянии дозваниваться по нескольким номерам и перезванивать много раз. Ведет логи и статистику, причем последнюю с учетом трафика, и можно одну на все соединения. Почему-то отсутствует таймер, не запускаются при установке соединения программы и не отслеживается закрытие окон. Поздновато реагирует на установку соединения, соображает о том, что соединение установлено через несколько секунд, а может и минут или даже часов (про минуты и часы - это шутка :)). Программка шароварная, но раскошелиться на нее я посоветовал бы любителям лицензионного софта и тем, кто существует в Инете по часам (и те и другие со знанием языка).


Спецвыпуск Хакер, номер #006, стр. 006-044-3, Вечерний звон!

Вечерний звон!

Спецвыпуск Хакер, номер #006, стр. 006-044-3

Качнем: www.download.ru

SP Dialer

Самая маленькая звонилка из всех, что я на сегодняшний день перепробовал (107КВ). Красива, а маленькие размеры достигнуты небольшим набором функций, но есть все, что необходимо для дозвона. Дозванивается и перебирает несколько номеров. Допускает переопределение имени пользователя и пароля. Ведет логи по соединениям и статистику по времени соединения с учетом суммы по тарифному плану хозяина. На этом все функции оной звонилочки заканчиваются - кстати, она единственная не обладает гласом для оповещения об установке и разрыве связи. Не имеет конкурентов по быстроте. Если тебе нужно что-то красивое, просто звонить и звонить побыстрее, забирай ее себе и радуйся. Заметь, что и место на харде она тебе сбережет.

Качнем: www.download.ru

EType Dialer

На мой взгляд, почти идеальное произведение этого класса. В визуальном плане ничего особенного, но сделана добротно и симпатично. Умеет дозвон и перебор нескольких номеров, сохраняет логины и пароли. Имеет хорошую статистику, недостаток которой только в отсутствии системы подсчета суммы. Имеет систему запуска приложений при установке соединения, в которой наблюдается куча полезных функций. Можно запустить одно приложение из списка, а можно все или, если все заколебало, вообще ничего из него не запускать. Классный таймер с заданием только на сегодня или на каждый день. Режим перезвона в случае обрыва с выбором вариантов поведения (плохо, хорошо и т.д.). Хорошо сделан хелп, что иногда тоже важно. Ведет логи по каждому соединению, журнал соединений. Скоро ожидается новый вершн проги. Нравятся надежные, умные проги, где есть почти все что нужно и на халяву? Вот и мне нравятся.

Качнем: www.enet.ru/~gorlach/edialer/

Alexf Dialer

Вот она - стильная прога настоящего работящего (интересно, где такие есть?) хацкера. Имеет графический интерфейс, но поддерживает режим работы в командной строке (RULEZZ) и потому способна существовать автономно. Запоминает и перебирает несколько телефонов провайдера. Умеет создавать, удалять и редактировать соединения, причем для коннекта можно поставить минимальную скорость соединения, минимальное количество трафика за определенное время (ежели меньше, то коннектимся снова), задать максимальное время, отведенное для установки соединения (этой фиговине цены нет, если момед сигнал "пошел на фиг" не ловит). Умеет делать "ping" на сервер провайдера через установленный юзером промежуток и рвать или не рвать связь при выходе (при повторном заходе понимает, что связь была установлена извне). Ведет логи, показывает время за текущий сеанс и все наработанное время по соединению. Показывает в цифре и графиком количество принятого, посланного, демонстрирует скорость, на которой это осуществлялось. Запускает проги при коннекте, при снятии трубки и уже в онлайне. Посылает автокомментарии из about прямо самому автору, который согласен на доработки. Первой доработкой на его месте я бы сделал перевод проги на русский язык. Если тебе нужны красота, хорошие настройки соединения и хороший набор функций, то это твой выбор.


Спецвыпуск Хакер, номер #006, стр. 006-044-4, Вечерний звон!

Вечерний звон!

Спецвыпуск Хакер, номер #006, стр. 006-044-4

Качнем: www.softlist.ru

Dialup Prof

Вот уж где автор на графике оторвался! Программка получилась очень красивая, но вот никаких из ряда вон выходящих функций он в нее не внес, окромя показа трафика (сколько принял да послал). Вообще, конечно, круто то, что он собрал в свою прогу все настройки, которые ты можешь найти в службе удаленного доступа под форточками, и добавил к ним дозвон по нескольким номерам с запуском заданных приложений. Позволяет создавать, удалять и редактировать соединения. Есть инфо по соединению, поддерживает сценарии для них (соединений). Мне показалось, что прога не особо интуитивна и удобна, но, возможно, найдутся люди, которым она понравится и будет нужна. У меня почему-то отказался работать автодозвон, причем, несмотря на все ухищрения, заставить его работать мне не удалось, но, может, это просто особенности моего компа. Короче, над прогой еще работать и работать, но автор и не отрицает того, что будет это делать, а мы подождем и посмотрим, что в нее добавят.

Приговор: облагороженный вариант службы удаленного доступа с хорошим междомордьем (интерфейсом) и несколькими примочками, которых в службе удаленного доступа нет. Нужность определи для себя сам.

Качнем: www.softlist.ru

Advanced Dialer

Одна из самых красивых и многофункциональных прог обзора. Правда, в результате наличия оного она стала также самой большой прогой все того же обзора. В наличии есть все функции, необходимые и не очень существующему в сети годами человеку. Умеет создавать, удалять и редактировать соединения, позволяет установить максимальное время, необходимое для установки соединения. Создает скрипты для соединения и делает "ping" на сервер провайдера, имеет классный таймер, где можно задать список соединений на 2 мая 2002 года (надеюсь, проблему 2000 года ты уже решил) и систему запуска, закрытия предложений (в смысле приложений), для которых, кстати, море опций и действий, для них осуществляемых. Ведет классные логи и, что важно, имеет очень хороший дисплей состояния коннекта. Копирует в буфер IP адреса и может восстанавливать или не восстанавливать соединение при разрыве. О том, что в ней есть, можно говорить долго, так что скачай и тестани. Программка шароварная и на английском, но поюзать ее я посоветовал бы любому. Единственная прога обзора, на которую у меня возникло желание раскошелиться.

Качнем: www.kagi.com/yellow/

Качать!

Ну вот и все, я закончил свое черное дело, а ты давай думай обо всем написанном и принимай решение. Знай, или ты поюзаешь такую прогу, или твой прови поюзает тебя при помощи майкросаксовской службы удаленного доступа. Главное в жизни - это спокойствие и комфорт, ведь нервные клетки не восстанавливаются. А ежели ты еще и ФТП-ешник хороший для комплекту себе поставишь, то можешь к компу даже не подходить, когда файлы качаешь. Сиди себе, пивко прихлебывай с братвой, а комп и без тебя все сделает при разумной организации рабочего процесса (во, блин, сказал - аж самому понравилось :)).


Спецвыпуск Хакер, номер #006, стр. 006-044-5, Вечерний звон!

Вечерний звон!

Спецвыпуск Хакер, номер #006, стр. 006-044-5

Кстати, об обещаниях: я, поразмышляв, выбрал для себя две проги: Muxasoft Dialer и Advanced Dialer. Гляну, что выйдет в обновлении к EType Dialer, и, быть может, перейду на нее, так как это одна из лучших русскоязычных программ.


Спецвыпуск Хакер, номер #006, стр. 006-048-1, Клип! Легко!!! Софт для создания демок

Клип! Легко!!! Софт для создания демок

Спецвыпуск Хакер, номер #006, стр. 006-048-1

Макс Зелененко (maxx@xakep.ru) Михаил Терехов (stranger@xakep.ru)

Как и многие другие, с того момента, как в мои шаловливые ручки попал комп, я хотел создать компьютерный клип, хотя бы немножко похожий на те, что показывают по ящику и проецируют на экраны, стены, а также другие ровные (и не только) поверхности в крутых дискотеках. Дело было давно, и в тот момент создание чего-либо подобного человеком, не разбирающимся в таких пакетах, как Autodesk и 3D-Studio, было практически невозможно. После года непрерывной работы над оной фичей все было заброшено в дальний угол винта как затея безнадежная и невыполнимая для такой бездарности в плане графики, как я. Но каким бы я был кул хацкером, если бы сразу сдался и не оставил в своей маленькой душонке надежды на лучшее. Ведь каждый из нас уверен, что он гениален во всех областях (посмотри на наших певцов — половина петь не умеет а все туда же, на сцену), не стал исключением и я. Облажав оба вышеназванных пакета за чрезмерную сложность, требовательность к ресурсам и так далее, я немедленно начал искать чего-нибудь попроще и понародней.

Очень долго ничего не находилось, но однажды в одном из ночных серфов по Инету меня занесло на пагу http://www.arkaos.be/, откуда я и снял классную прогу для работы с графикой. Называется она X<>pose IT и является графическим сэмплером реального времени. Прога дает возможность создать качественный клип (можно порно :)), причем сделать это в сочетании с музыкой, так как поддерживается работа с CD-треками и wav-файлами. Делается он при помощи внесения в прогу некоторого количества картинок и фотографий, над которыми осуществляются разные 2D-3D извращения, офигенное количество которых уже есть в программе. Характерно, что все вносимые тобой изменения ты сразу видишь на экране, а не ожидаешь полдня их рендера, исходя на слюни от желания увидеть сделанное. Действия могут осуществляться одно за другим без перерыва, причем одновременно возможно проигрывание музыки, для которой этот клип создается. Это дает возможность при хорошем овладении эффектами проги добиться полной гармоничности того, что происходит на экране с тем, что звучит в колонках.

Кабина, руль и кое-что еще!

Вся юзверская работа по созданию “величайшего шедевра” клипмейкерского искусства протекает в небольшом таком анимированном окошке, которое состоит всего из четырех частей: окно просмотра, виртуальная клавиатура, окно картинок, ну и, конечно, окно эффектов. Чем мне понравилась прога, так это тем, что в ней, в отличие от других, не наблюдаются лишние части, но наряду с этим нет и недостающих. Необходимость каждой выверена, а функция четко определена. Грустно, но небольшие размеры окошка не позволяют удобно разместить даже четыре компонента, а если вспомнить, что перестановка компонентов в окне осуществляется лишь в пределах, заданных авторами, то ситуация складывается просто клин. Несмотря на все попытки распределить все так, чтобы это действительно было удобно для работы, мне так и не удалось этого сделать. Мое личное пожелание к авторам — увеличить рабочее поле программы, после этого изъянов в ней уже не будет.


Спецвыпуск Хакер, номер #006, стр. 006-048-2, Клип! Легко!!! Софт для создания демок

Клип! Легко!!! Софт для создания демок

Спецвыпуск Хакер, номер #006, стр. 006-048-2

Семплирование графики в проге осуществляется только при помощи твоей клавиатуры (щелкнешь мышью — записи каюк :( ), которая в данном случае выступает в роли диджейского пульта. Так как картинки, вносимые для работы, и эффекты над ними осуществляемые всегда разные, то для каждого клипа клавиатура программируется по-своему. Для удобного и быстрого ее программирования в проге даже существует отдельный модуль — виртуальная клавиатура. Виртуальная клава является полной копией реальной клавы, то есть каждой кнопке на реальной соответствует такая же кнопка на виртуальной.

Все программирование осуществляется при помощи перетаскивания иконок эффектов и картинок из соответствующих модулей проги на определенные тобой кнопки, после чего на них появляются идентифицирующие иконки. Мне она понравилась тем, что во время записи проекта, если ты еще не разобрался с кнопками, именно она позволяет создать нечто связное, а не какофонию графических эффектов, рядом с которой ядерный взрыв с его визуальными последствиями просто отдыхает. Плюс простота и наглядность конфигурирования кнопок.

Перед тем как что-нибудь куда-нибудь потащить, любую картинку или эффект можно просмотреть в окне просмотра и четко решить, стоит ли это вообще брать.

Ты только это, смотри, со своими вкусами одних голых баб туда, как всегда, насуешь, и будет у тебя порнофильм классический со спецэффектами. Интересно, что если попробовать эффект с картинкой, находящейся в этот момент в окне просмотра, и перетащить его на клаву, то он все равно будет осуществляться с любой картинкой. А для привязки эффекта именно к этой картинке нужно сначала оттащить на клаву картинку, а потом на ту же картинку поместить нужный эффект. Запись твоего проекта и его проигрывание также производятся именно в этом окошке, но могут осуществляться и в полноэкранном режиме.

Для проигрывания это просто супер, а вот чтобы записываться на полном экране нужно либо иметь электронную память и все кнопки запоминать с первого раза, либо работать с этой прогой очень давно. Кстати, по краю именно этого окошка расположены кнопочки “запись”, “проигрывание” и “остановка” (для чего они нужны, догадайся :) ).

Все картинки и эффекты расположены в проге в отдельных окошках. Начнем с окошка картинок — именно в нем при помощи соответствующих кнопок происходит внесение нужных для проекта картинок, которые могут быть в двух форматах jpg и bmp.

Перед тем как перетащить иконку картинки на клаву, ее можно просмотреть, щелкнув по ее миниатюре в этом окошке, а где она появится в нормальном размере, я думаю, ты уже прочитал выше. Заклинаю никогда не пробовать переключаться между картинками щелчком во время записи клипа, так как запись немедленно остановится :((( — все переключения между картинками в это время делаются только с клавиатуры. А ручонки ведь тянутся, я таким манером клипов пять сгубил и полголовы волос в результате себе вырвал.

Окно эффектов — в этом окошке расположены все те фишки, ради которых ты эту прогу снял.


Спецвыпуск Хакер, номер #006, стр. 006-048-3, Клип! Легко!!! Софт для создания демок

Клип! Легко!!! Софт для создания демок

Спецвыпуск Хакер, номер #006, стр. 006-048-3

В ней расположены иконки эффектов, при нажатии на которые ты сможешь лицезреть приглянувшийся на выбранной картинке. На сегодняшний день их встроено 36 штук. Слышу я — народ разочарованно загудел... Спокойно, ребята, у каждого из них при нажатии появляется всплывающее меню, где может быть до пяти пунктов, определяющих интенсивность и принципы эффекта. Так что реально их гораздо больше, а так как все они вставляются в программу в качестве плагинов, то возможно написание собственных или установка чужих найденных на буржуйских сайтах. Не знаю, кто как, а мне пока и этих хватает, я в них-то путаюсь, бывает! И вообще, сначала посмотри, а потом уже свои вокальные данные мне тут показывай.

Сделали... посмотрели... Долго молчали

Короче, прогу посмотрели, кнопочки распределили, а теперь пора и за дело приниматься! Если ты записываешь клип в этой проге в первый раз, то лучше это делать в окне просмотра при участии виртуальной клавиатуры в качестве подсказки. Если же охота все же на полном, то стоит переписать хотя бы на листок, что где находится. Напоминаю для тех, кто невнимательно читал, что кнопки записи, проигрывания и остановки находятся на кромке окна просмотра. При нажатии на кнопку записи или проигрывания перед тобой появится одно и то же окно, лишь последствия нажатия кнопки “старт” будут различаться. Для записи у тебя будет спрошено, где находится музыкальный файл, для которого создается клип — это по умолчанию компакт и трек номер один. Ты можешь сменить трек или поставить название звукового файла в wav формате, причем последний может находиться где угодно (только с дискетами не вяжись, уж больно долго читает :)). В обязательном порядке тебя заставят написать название записываемого клипа и комментарий к нему. Выбрав режим — полноэкранный или нет, при помощи соответствующей галочки, тебе нужно махнуть на старт и показать все свои незаурядные (нереализованные) способности в области графики. Делается это при помощи последовательного применения всех тех эффектов, которые ты выбрал для своего клипа. По окончанию записи нужно щелкнуть на стоп или, если ты в полноэкранном режиме, просто щелкнуть мышкой. Сохраняемся... Вуаля, первый клип готов!

Теперь быстро идем по дому, собираем всех домашних и, щелкнув на кнопку “проигрывать” (не забудь поставить флаг “в режиме полного экрана”), наслаждаемся минутой сладкого триумфа, пока все остальные обсуждают, насколько ты гениален. Единственное, если ты туда и правда баб голых насовал, то показывать это лучше только друзьям, а то родители отправят тебя к сексопатологу после просмотра оного произведения, а комп ты вообще никогда больше не увидишь.

Везде был — все видел!

Изрядно помучавшись до появления действительно качественного продукта, я дам тебе несколько советов по ходу творческого процесса. Внимательно прослушай композицию, для которой ты собираешься делать клип (желательно несколько раз) и четко представь себе, что бы ты хотел видеть. Тщательно подбери исходные картинки, причем советую выбирать как можно более многоцветные, так как при многократном применении эффектов на картинку, содержащую, например, только темные цвета, она переходит в однотонный черный экран (показать при этом итоге просто нечего). Советую также ни в коем случае не подбирать эффектов одного класса, так как зрелище, получаемое в результате использования 4 эффектов, настолько грустное, что после этого отпадает всякое желание пробовать еще раз. И, наконец, искренне советую хорошо продумать расположение используемых кнопок, это немаловажно при создании классного клипа.


Спецвыпуск Хакер, номер #006, стр. 006-048-4, Клип! Легко!!! Софт для создания демок

Клип! Легко!!! Софт для создания демок

Спецвыпуск Хакер, номер #006, стр. 006-048-4

Заключение,

пожелания,

перспектива...

В заключение материала хочу отметить, что прога эта очень стильна, и попробовать ее стоит каждому. Типа, вдруг способности откроются к этому делу. В первый момент она может показаться сложной, но если в ней поковыряться, то понимаешь, что все очень просто. Единственное, что некоторые принципы работы не очень интуитивны, и выяснить их можно только на практике, так как в проге отсутствует даже намек на нормально написанный хелп (иногда он нужен). Но так как все используемые принципы работы описаны в этом материале, то он тебе и не понадобится, а от себя попросил бы авторов все же добавить его в прогу. Прискорбно, что требовательность к ресурсам графических прог эта софтярина переняла в полной мере и требует комп не менее чем с 32 метрами оперативки, а также неплохо чтобы имелся хотя бы слабенький графический акселератор для получения классных цветов.

Теперь о способах применения — если у тебя уже имеется большой опыт по созданию клипов в этой программе, и ты спокойно записываешься на полном экране. Ты можешь устраивать для друзей целые шоу в реальном времени. Эти клипы очень внушительно смотрятся на больших мониторах и, возможно, проекционных экранах (у меня его нет, проверить не удалось), так что ты можешь продемонстрировать эти шоу на дискотеке или создать новое прямо на глазах у кучи народа под играющую в этот момент музыку. Вот народ выпадет-то!

Хочу сказать, что идея, засунутая в эту прогу, очень классная, и за развитием проги надо внимательно следить. Старт очень хорош, будем ожидать продолжения.

Я на сегодня юзаю прогу версии 1.0, и эта же версия лежит на сайте программы, адресок которого ты найдешь выше. Весит она 8 мегов, оттуда ее можно скачать единым архивом или кусками (там уже есть разбивка).

Короче, все, качай, юзай и бывай, братишка!


Спецвыпуск Хакер, номер #006, стр. 006-052-1, Как добываются пароли

Как добываются пароли

Спецвыпуск Хакер, номер #006, стр. 006-052-1

MOOF (MOOF@XAKEP.ru)

Give it to me, baby:::::::::::::::::::::::::::

Ты, конечно же, уже слышал много способов, как утянуть пароли у глупых юзеров, используя различные хитрые и навороченные программки. А ты знаешь, как это делают настоящие хакеры? Нет?! А ведь они сами не пользуются никакими специальными программами (да, они их пишут, но не для себя)!!! А знаешь, как они достают пароли пользователей? Опять, нет? Оказывается, глупые юзеры сами готовы рассказать всем свои пароли!!! Для этого им нужен лишь маленький толчок (иногда пинок). Сейчас ты услышишь удивительную историю о том, как хакеры проводят этот самый пинок.

Уно::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

Для начала хакеры выбирают свою жертву. Это может быть сосед по лестнице или друг по чату, или еще кто-нибудь. Выбрав жертву, хакер старается узнать как минимум две вещи, а именно: название провайдера, через которого подключается его жертва, и его логин. Благо обе эти вещи сильно никем не скрываются, и поэтому диалог:

- А кто твой провайдер?

- Я подключаюсь через провайдера Super Internet Provider.

не вызовет никакого подозрение. Теперь, зная провайдера, хакер узнает логин юзверя. Часто (читай почти всегда) логин пользователя такой же, как и адрес мыла, т.е. если электронный адрес пользователя выглядит так: LAMMER@super-provider.ru, то его логин, с вероятностью в 99%, будет — “LAMMER”. Теперь, когда хакер знает провайдера и логин юзера у этого провайдера, настает время узнать ё-mail службы поддержки у этого провайдера. Чаще всего этот адрес выглядит как support@super-provider.ru или admin@super-provider.ru . И еще, если есть возможность, следует посмотреть хотя бы одно письмо от этой самой службы поддержки, чтобы знать форму обращения к юзеру и всякие стандартные приветствия типа “Здравствуйте, дорогой наш пользователь *LAMMER* !!!” и прощания (“Пока, сральник!...”). Нам пригодятся.

Дос:::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

Когда хакер знает весь необходимый минимум, приходит время для ... (голос из телика) А СЕЙЧАС НА НАШЕМ КАНАЛЕ РЕКЛАМА. МЫ ВЕРНЕМСЯ К ВАМ ЧЕРЕЗ НЕСКОЛЬКО МИНУТ... нет, не для этого, а для того, чтобы... (все тот же голос) ВЫПИТЬ ЧАШЕЧКУ ЭТОГО ЗАМЕЧАТЕЛЬНОГО... Короче, хакер создает почтовый адрес на каком-нибудь халявном серваке (многих прет ZMAIL (http://www.zmail.ru ), т.к. оттуда до 2000 года можно будет забирать почту на халяву, не звоня провайдеру, и потому, что можно получить адрес с доменом @ru.ru, но это уже детали). Но создавать адрес надо не от балды. Не надо называть свой ящик fuck you lammers@... ,а надо скромненько написать support-super-provider@... или admin-super-provider@... или что-нибудь в этом роде (содержащее или название провайдера, или слова: admin или support).

Трэ::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

Итак, сделав все вышеописанное, хакер приступает к самой ответственной части: к написанию письма глупому юзверю. В принципе в письме они могут писать любую чушь, типа:


Спецвыпуск Хакер, номер #006, стр. 006-052-2, Как добываются пароли

Как добываются пароли

Спецвыпуск Хакер, номер #006, стр. 006-052-2

“Уважаемый

пользователь!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

К сожалению, на Вашем счету был обнаружен факт двойного доступа к нашему серверу, т.е. в одно и то же время, используя Ваш аккаунт, в систему вошли 2 (два) пользователя. Вследствие чего возникла необходимость в смене Вашего текущего пароля доступа к нашей сети.

Вам необходимо ответить на это письмо, используя следующий формат:

log: ваш логин

op: ваш старый пароль

np1: ваш новый пароль

np2: ваш новый пароль

em: ваш e-mail

Эти сведения должны находиться в начале Вашего сообщения. Обратите внимание на то, что новый пароль должен быть повторен дважды! Это необходимо для точной идентификации Вашего аккаунта. Рекомендуется прислать свои сведения до 13.06.1999, т.к. по истечении этого срока возможно отключение Вашего аккаунта.

Желаем Вам

успехов!!!!!!!!!!!!

С уважением,

администрация сервера http://www.super-internet-provider.ru .”

Но поверили?

Тогда так::::

“Уважаемый пользователь!

Я вынужден сообщить вам неприятную новость :(. В нашей компании, Super Internet Provider, в пятницу 13 апреля имело место незаконное хищение нескольких файлов с данными о наших пользователях. После нелегального копирования данные были уничтожены. На данный момент мы не можем сказать, содержались ли в похищенных файлах ваши данный или нет. Таким образом, мы предлагаем вам заполнить приложенную к письму анкету и, нажав “Ответить” (“Replay”), отправить письмо с приложенной анкетой обратно.

В качестве компенсации мы дарим вам дополнительные пять часов доступа к Интернету.

Спасибо за поддержку!

-=begin анкета=-

Имя _____________________

Адрес ___________________

Индекс __________________

Домашний телефон _______

Старый пароль ___________

Новый пароль ____________

-=end анкета=-”

Главное, что пишется все это убедительно, так, что у юзера не возникает желание позвонить голосом в службу поддержки и все выяснить.

Кварто:::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

После того как текст письма готов, хакер начинает скрупулезно подделывать заголовок письма. В принципе все очень просто: в строке “от” пишем

From: “Super Provider Support” support@super-provider.ru.

Если юзверь вздумает посмотреть, от кого пришло письмо, он увидит РЕАЛЬНЫЙ адрес службы поддержки. Дальше в строке “кому” пишем

To: .

И теперь самое интересное: в строке “ответить туда-то” пишем следующее:

Reply-To: “ Super Provider Support” support-super-provider@ru.ru.

Видите, “support-super-provider@ru.ru” — это адрес вашего мыла (который вы создали), и при ответе почтовая программа ответит именно по этому адресу.

В теме письма можно написать что-то типа

Subject: “Внимание”.

И в целом заголовок письма будет выглядеть следующим образом:

Reply-To: “ Super Provider Support”

From: “Super Provider Support”

To:

Subject: Внимание.

Date: Tue, 13 Jun 2000 13:13:13 +0000

MIME-Version: 1.0

Content-Type: text/plain; charset=”koi8-r”

Content-Transfer-Encoding: 8bit

Дальше идет служебная информация (гы-гы).


Спецвыпуск Хакер, номер #006, стр. 006-052-3, Как добываются пароли

Как добываются пароли

Спецвыпуск Хакер, номер #006, стр. 006-052-3

And all girly say, I’m pretty fly (for a white guy)

Вот и все, что мне нашептали на мыло хакеры... Теперь осталось запечатать письмо, привязать его к почтовому голубю и... ждать. Ах да, вот еще что: пароли можно добывать не только у провайдера. Как говорится: “легко изменив текст письма”, можно “попросить” пользователя выслать пароли от своего почтового ящика, етс. Для достижения наилучшего результата советуют рассылать письма не одному адресату, а нескольким — кто-нибудь да клюнет.

ЗЫ: От автора:::::::

Я сам вообще никогда не пользовался этим!!! И не знаю я, что такое Интернет!!! И вообще, я боюсь компьютеров :).


Спецвыпуск Хакер, номер #006, стр. 006-054-1, Setup - легальный убийца!

Setup - легальный убийца!

Спецвыпуск Хакер, номер #006, стр. 006-054-1

Автор: or@NGE (orange-303@mail.ru; http://www.hackcity.org)

Setup и что за это бывает

Короче: типичного blablabla в начале статьи не будет. Давай сразу к делу - мы ж с тобой хацкеры, а не чат-гёлз какие-нибудь. Итак, когда ты покупаешь (скачиваешь, нелегально приобретаешь) прогу, то в большинстве случаев для ее установки требуется запустить файл setup, где сначала тебе дают почитать лицензионное соглашение, потом выбрать директорию и все такое. Обычно, чтобы сделать такую установочную приблуду, программеры используют какой-нибудь install maker. Я упражнялся с Vise Installer (это как раз программка такого типа), поэтому все, что тут написано, относится к нему... Эта полезная штучка, предназначенная, на первый взгляд, для сугубо мирных целей, в умелых руках становится мощным оружием (как булыжник в руках пролетариата :)).

Первым делом скачиваешь (или находишь где-нибудь на сборнике) Vise (www.mindvision.com - там надо заполнить разную регистрационную шнягу, но это уже мелочи). Ломать ее, конечно, надо, но как, пояснять не буду (И НЕ СПРАШИВАЙ).

Надо работать!

Маскируешь свое детище под дистрибутив какой-нибудь очень полезной проги, указываешь это в Screens. Всячески хвалишь и рекламируешь, добавляешь красивые картинки (настройка экранов осуществляется в меню screen посредством кнопки add screen). Самое простое - это запаковать в инсталлер твоего любимого трояна и в конце установки предложить юзверю его запустить или же создать в меню "пуск" ярлычок с красивой иконкой для запуска все того же трояна. Не правда ли - эстетично? Все для удобства пользователя :), все для него, для ламера ушастого :).

Но троян - это, если честно, прозаично, а ведь можно придумать что-нибудь повеселее :). Ведь в процесс установки можно добавлять разный аction (типа создания директории, удаления директории, внесения изменений в реестр и т.д.). Вот с этим и можно поприкалываться от души :).

Смело жмешь "add\delete action" и выбираешь там то, что будешь ампутировать жертве... Количество вариантов ограничено только твоей фантазией :). В качестве мелкой пакости можно стереть все ярлыки из главного меню, в качестве большой заподлянки - директорию Windows, или autoexec.bat (config.sys, msdos.sys, io.sys...). Никто не помешает тебе подправить win.ini на свое усмотрение. Ты сможешь забить вражеский винт всяким дерьмом по самые уши используя copy action. Можно даже загадить registry (тут придется попотеть, для каждого типа файлов надо будет добавлять Register file type, причем, надо не забывать ставить в опциях галочку на "Dont ask user to replace if already registred", а то жертва начнет подозревать...). А каково будет изумление юзверя, когда при открытии *.txt или *.wav файла у него будет запускаться что-нибудь не относящееся к делу :)! Одним словом - почва для вендетты любого масштаба тебе просто прописана, все ограничивается только извращенностью твоей фантазии. Ну а для того, чтобы юзверя окончательно хватил дядька Кондратий, можно предложить ему в процессе установить DirectX 2.0 или показать какую-нить картинку с www.ob.da.ru :). В конце установки можно предложить на выбор обычное или низкоуровневое форматирование всех дисков, включая сетевые и CD-ROM. Да, кстати, можно создавать также и Uninstaller'ы, причем неумело созданный анинсталлер убивает regestry :), так вот...


Спецвыпуск Хакер, номер #006, стр. 006-054-2, Setup - легальный убийца!

Setup - легальный убийца!

Спецвыпуск Хакер, номер #006, стр. 006-054-2

Что? Ты еще сомневаешься? Нет, парень, это точно твой случай - неужели ты никогда не мечтал ненавязчиво пошутить над каким-нибудь ламерком? Давай, хватай Вайс Инсталлер, и вперед - творить, работать и создавать шедевры западлостроения :).

Защита

А нет ее. Нет и все тут. Конечно, если ты в setup впаяешь трояна, то AVP его рюхнет, а вот если будешь делать гадости через сам сетап, то ни один антивирус ничего не унюхает :). Ну что, господа разработчики, об этой фишечке Вы не задумывались никогда :)? Вот теперь подумайте :). Удачи!


Спецвыпуск Хакер, номер #006, стр. 006-056-1, Крякер ИНЕТА

Крякер ИНЕТА

Спецвыпуск Хакер, номер #006, стр. 006-056-1

Key Lord [key_lord@ru.ru]

Привет, кул хацкер! Наверно, ты уже много слышал про такую рульную прогу, как крякер Интернета. Я уверен, что некоторые уже даже успели пообщаться с этим чудом прогресса. :) Давай я угадаю, чем это закончилось:

1) у тебя весь винт оказался заражен вирем вин-чих;

2) у тебя каким-то макаром сам отформатировался винт;

3) крякер шел в битом .ехе архиве.

Ну и, конечно же, никакого Инета на халяву ты не поимел. :( Короче для тех, кто в танке: все крякеры Инета являются троянами/вирями в открытом виде. Как ты, надеюсь, понял, раздавать троянов напрямую под видом Inet Cracker мы не будем. Это, типа, не в стиле Х. Если мы уж и будем делать взломщик Инета, то профессионально, и чтоб он не вызывал и у юзверей ни капли подозрения.

Делаем фейс

На этом этапе тебе понадобятся минимальные познания в программировании, т.к. сейчас мы займемся написанием собственно самого крякера. ;) Не надо задумчиво чесать репу и листать журнал дальше. :) От тебя потребуется умение лишь слепить красивый фейс + оживить всякие кнопели, менюшки и др. детали твоей мега проги. Дальнейшие примеры я буду приводить на Delphi.

Самые азы тебе уже рассказал KurT в Х #10 за 99-й год, так что сразу File ->New Application и в бой. Сначала слепи приятный и красивый интерфейс проги. Делается это все мышкой, и особого ума здесь не надо. Вот тебе пара советов: налепи от балды побольше всяких фенечек, где надо вводить... ну там телефон прова, желаемый логин, сколько надо поиметь пассвордов, ну и все такое. Да, и не забудь навешать в прогу всяких там умных слов, типа Net Mask, Default Port, DNS, MAC&IP address и т.д. Но, смотри, не сделай перебора и не напори полной фигни, а то ведь даже полные ламаки поймут, что их хотят поиметь. А это не есть гуд. :)

Я впихнул компонент Tmemo (mmCom), в котором будут выводиться комментарии по ходу процесса взлома Инета и другая лапша. Также я не забыл выложить батон About, после нажатия на который будет выводиться “инфа от разработчика”: типа кто же написал такую рульную прогу и кого за это чудо благодарить. Кстати, я советую не писать свой реальный ник в крякере.

Ну что, справился? Надеюсь, да. Идем дальше. Помимо демонстрации красивого интерфейса, наша прога должна подавать и какие-то признаки жизни, создавать видимость усиленной работой над взломом Инета. :) Ну, короче, своими действиями показывать, что что-то реально делает, и внушать юзверям доверие. Поэтому я предлагаю повесить на событие OnChange (или OnEdit) в TEdit-ах присвоение Tag-у этого же тэдита значение 1. Потом после старта процесса взлома проверяем значение Tag-а у каждого TEdit-а. Если все они равны 1, то все ОК, и делаем все что положено, а если нет, то говорим юзверю, что, типа, баклан, не гони беса и введи все как надо.

if (edPool.Tag=1) and (edUrl.Tag=1) then {делаем все что положено} else ShowMessage (‘Hey! Backlan enter your data!’);

Если кто не въехал, то это заставит жертву заполнить своими данными все бланки в проге, а не, бегло осмотрев прогу, нажать Start Cracking и ждать халявного Инета. :))


Спецвыпуск Хакер, номер #006, стр. 006-056-2, Крякер ИНЕТА

Крякер ИНЕТА

Спецвыпуск Хакер, номер #006, стр. 006-056-2

Итак, кое-что уже сделали. Теперь делаем самое главное, кернел всей проги - процесс эмуляции взлома Инета. :-)))) Как я уже говорил, в моем примере я вставил компонент TМemo, в котором и будет идти крякание. :) После нажатия на батон Start Cracking и проверки введенных данных я запускаю лохотрон:

Небольшой комментарий. Сначала мы вырубаем кнопель Start Cracking и меняем мышака на песочные часы. Могу поспорить, все, не знающие прикола, подумают, что прога начала обрабатывать кучу данных, производить ХЗ (Хакер Знает) какой степени сложности вычисления. :) Ну ладно, типа пусть так и думают. В 3-й строке я добавляю в лохотрон (mmCom) первую порцию лапши на обвислые уши ламака. Пусть он думает, что крякер пытается законнектиться с серваком прова. Для создания тормозов служит строка for i:=1 to {ого-го} do;. Чем больше ого-го, тем дольше будет тормозная пауза. Но чем быстрее камень, тем она будет меньше, учитывай и это. Потом я ставлю ~13% в полосе “осталось до халявного Инета”. Дальше поступаешь аналогично. Все зависит от твоей фантазии, а от нее зависит, поверит ли тебе юзверь или нет. При хорошем раскладе и продуманных сообщениях лохотона ламак может пару раз прогнать взломщик на своем компе, и если Инет ломануть не получится (хе-хе), то запустит прогу на машине своего другана-ламака (типа может это мой маздай глючит, а у другана все заработает).

Как видишь, в конце прога возвращает Start Cracking в исходное состояние и включает таймер. Вся штука в том, что после срабатывания таймера окно проги исчезает и выводится сообщение об ошибке в kernell32.dll. Перед включением таймера можешь вставить код, выводящий какую-нибудь туфту, типа крякнутых пассвордов, и т.п. Ясен пень, что эти пассворды берутся чисто научным способом “от балды”, хотя ты можешь каждый раз генерить разные пароли. Сам прикол в том, что посмотреть, запомнить и записать на бамажку пароли ламак не сможет, т.к. интервал таймера маловат (1-3 сек. Кстати, вводятся они в милисеках, т.е. надо вводить 1000-3000). А после его срабатывания прога выводит сообщение о глюке в кернел32.длл. Вот и опаньки ламаку. :)) Даю тебе 100 пудовую гарантию, что ламак пару раз прогонит прогу, надеясь, что ошибки не произойдет, и все-таки можно будет поиметь халявный Инет (типа, как же так? Все прошло хорошо, даже появились пароли. Может еще раз попробовать? Или запустить у моего друга Васи Пупкина).

Короче, пошевели мозгами, загрузи в верхний отдел правого полушария драйвера prjamye_ruki.sys, fantazi.sys, и все будет ОК. При разработке проги не забудь слепить для нее новую иконку. Для того, чтобы после компиления проги она имела эту самую иконку, запихни ее в Project->Options->Application (icon).

Может я и не сказал про создание проги все, что тебе надо (и вообще, откуда я знаю, чего тебе надо, :)) поэтому можешь забрать полную версию исходников моей проги с http://www.chat.ru/~inet_crk/. Но не забывай об индивидуальности и используй их лишь как образец. А то разведется щас по рунету куча одинаковых взломщиков Инета, :) и никто на эту фишку не будет клевать, или, может, занесут ее в вирусную базу AVP, что тоже не кульно. Тем более что особых программерских способностей тут не надо. Короче, если ты не тормоз, то все должно пройти хорошо.


Спецвыпуск Хакер, номер #006, стр. 006-056-3, Крякер ИНЕТА

Крякер ИНЕТА

Спецвыпуск Хакер, номер #006, стр. 006-056-3

P.S.: Если хочешь вывешивать Inet Cracker на своей паге, то распиши его как супер-пупер-мега-квадро-руллез прогу и для подтверждения своих слов повесь там рядом ее скриншот. Только не забудь про мои слова - не сделай перебора, а то ведь этим скриншотом можно и спугнуть народ.

Отламываем Инет

Надеюсь, сам крякер у тебя уже готов. Но какой же крякер Инета обходится без трояна? Значит, пора его наживить. :) Для этих целей хорошо подходит прога Joiner (см. Х#5 за 99 год, “Шаровары”). Но в последнее время народ стал много возмущаться и говорить, что джоинер вусмерть затрояненный, чуть ли ни троян в голом (ой!) виде.

Делаю небольшое отступление. Летом, когда Joiner вышел, никакому там AVP или DrWeb-у в голову не могло прийти, что это троян или вирь. Joiner предназначался

для мирных целей. :) Но со временем многие стали прилеплять Joiner-ом ко всему и вся троянов (а что, удобно ж ведь!). Доктору Вебу и Кашперскому это надоело, и они дуэтом занесли сам файл Joiner.ехе к разряду троянов. Ну а если говорить о самом джоинере, то он просто берет две проги и сливает их в один файл, а потом поливает сверху все своим распаковщиком, который после старта заджоинеренной проги извлекает два файла в %windir% и запускает их. Ну так вот, распаковщик называется Joiner.1 или Joiner.2. Это - простые переименованные экзешники. Недавно AVP стал еще и по этим вот распаковщикам клеймить всю прогу трояном, вирем и вообще поливать дерьмом. :( И это даже если в ней нет ни троянов, ни вирев. Ай-яй-яй! Нехорошо!

Но есть и правда на этом свете! Автор Joiner-а выложил все его исходники у себя на сайте (он написан на Delphi) по адресу http://blade.slak.org/main.html.

А теперь гвоздь программы (не проги) - обход антивиров!!! Т.к. все антивиры находят виров по узко заданным параметрам, то стоит только перекомпилить распаковщик в другой версии Delphi (не трогая кода 8-)), и его не поймает ни один AVP!!! Поэтому скачиваешь исходники Joiner-а и открываешь в Дельфе файл Stub.dpr. Скорее всего, Blade (автор) компилил свою прогу в Delphi 4.0, поэтому тебе достаточно поставить себе Дельфу выше, чем 4.0. Могу поспорить, что ты видел на варезных CD Дельфи ver 4.1, 4.2, 4.3 и т.д. (наши пираты еще и не такое умеют. :) А ведь даже в Борланде про такие системы и не догадываются. :) Это та же самая Delphi 4.0, но с некоторыми изменениями. А главное - они дают разные скомпиленные проги по одному и тому же исходнику, а это нам и надо. ;] Я перекомпилил в ver 4.5, и все круто работало! Кстати, кто рубит в паскале, может кое-что там подправить в коде (что я и сделал), т.к. в нем не все стерильно... Ясен пень, что все это можно сделать и в Delphi 5.0 и выше. Да, скомпиленная прога сохраняется в c:\final, так что создай такую папку, а то ничего не заработает.


Спецвыпуск Хакер, номер #006, стр. 006-059-1, События года

События года

Спецвыпуск Хакер, номер #006, стр. 006-059-1

Хак года: взлом Микрософт трояном 14 октября (следы, хе-хе, вели в Питер)

Авантюра года: запуск Международной Космической Станции

Фильм года: Титан А.Е.

Пластинка года: E-Z Rollers "Weekend World"

Западло года: Зизюкайдер

Клуб года: Китайский Летчик Джао Да

Вирь года: I love you

Снегурочка года: Доктор Добрянский

Содержание


Спецвыпуск Хакер, номер #006, стр. 006-076-1, 18 способов нагадить соседу-автолюбителю

18 способов нагадить соседу-автолюбителю

Спецвыпуск Хакер, номер #006, стр. 006-076-1

Автор: Ипполит Максимилианович Столпников, заслуженный лауреат международной выставки бобров

Е-майл: (lapkarelief@mail.ru)

Уродам, оторвавшим спойлер с "Бешеной Антидевственницы", посвящается.

Если у вас нет собаки...

...то ее не отравит сосед. Или что-то вроде этого. А вот если твой сосед - козлина, то это надобно лечить. Особенно, если он козлина-автомобилист, приезжает ночью без глушителя, неаккуратно оставляет машину у подъезда или громко слушает дешевую хренотень типа "Серафима Удавкина - диск года "Ты меня не тебя". Купил себе, небось, супер-пупер маза-факин перезатюненный и прибамбахнутый запор со спойлером, да еще и сигналку гиперчувствительную, на дыхание реагирующую и орущую чуть что благим матом поставил и болезненно кончает при первом ее вопле. Ты понимаешь, что я имею в виду? Точно! Ему надо срочно прописать сеансов -дцать беспрецедентного автозападлостроения. Ну а если соседушка, кроме того что козлина, является еще и тупицей, и сам по себе с головой не дружит, то все 20 способов, приведенные ниже - точно для тебя и для него. :)

Fucking Не Надо!

Прежде чем мы с тобой начнем дебоширить, стоит решить, чего потенциально делать не надо:

Не надо отламывать всякие детали (спойлеры и прочие бамперы) и бить оптику - кроме дикой злобы и милицейского наезда во двор ничего не будет.

Не надо пихать в замочные скважины спички - это пошло и пахнет деревней. Есть способ лучше!

Не надо снимать дворники - если попадешься, то тебя еще и в нелепом воровстве обвинят.

Не надо прокалывать шины - зло, неоригинально, и, кроме того, неизвестно, когда теперь этот хрен сможет убрать свою машину из-под окон.

Не надо расписывать автомобиль баллончиком или маркером - если хочешь написать где-нибудь слово из трех букв, сделай это у себя на лбу.

А что же можно делать? - спросишь ты... Хехе! Наблюдай! Прислушивайся и впитывай.

Способ нулевой

Нулевой - значит простейший, наибанальнейший, но - действенный. Тебе не нравится машина соседа под окном? Продай ее! И неважно вовсе, что эта развалюха тебе не принадлежит. Главное - знать телефон владельца тачки и хотя бы марку машины (цвет ты, я думаю, разглядишь без моей помощи). Берешь купон "Из рук в руки" или любой другой похожей газеты и заполняешь. Например: "продам автомобиль ВАЗ-2106, цвета "бежевый удав", в отличном состоянии, цена 150$". И вписываешь телефон соседа для ответа. Относишь купон на почту - и можешь не сомневаться, уже через неделю после выхода газеты твой сосед будет на седьмом небе от счастья.

Способ первый

Предположим, сосед на своем кандибобере постоянно приезжает к тебе во двор в три часа ночи с орущей музыкой типа "Ноги Вниз!" и, громко бибикая, паркуется, поднимая на ноги весь подъезд. На таких перцев очень хорошо действует следующий простой рецепт. Покупается десятка три маленьких дешевых петард, и затем они последовательно запихиваются соседу в глушитель (желательно какой-нибудь палочкой пропихнуть их в резонатор - иначе их выбьет выхлопом, и только-то). Машина заводится, стартует, температура в глушаке постепенно растет... Эффект (особенно в отечественных автомобилях) - громоподобный.


Спецвыпуск Хакер, номер #006, стр. 006-076-2, 18 способов нагадить соседу-автолюбителю

18 способов нагадить соседу-автолюбителю

Спецвыпуск Хакер, номер #006, стр. 006-076-2

З.Ы. ВНИМАНИЕ!!! Глушак может и разорвать, и тогда, если узнают, что это ты - порвут как грелку. Способ экстремальный и подходит только как "в крайнем случае".

Способы второй, третий, четвертый и пятый - взаимосвязанные

Покупается некоторое (в зависимости от целей) количество суперклея - с его помощью можно много полезного с соседским автомобилем сделать. Здесь только четыре варианта, остальное додумай сам.

Суперклей вливается в максимально возможных объемах в замочные скважины автомобиля - владелец долго пытается понять, почему его ключ больше не подходит.

Суперклеем приклеиваются дворники (без комментариев).

Счастливому обладателю спойлера на этот самый спойлер суперклеем приклеиваются: одноразовый стаканчик, тарелка, вилка и нож. В стаканчик наливается пиво, на тарелку кладется арбуз. Красиво и эстетично.

АХТУНГ! Последний способ из сей категории годится для отечественных авто, у которых крышка горловины топливного бака не закрывается на ключ. Скручиваем крышку, намазываем резьбу суперклеем. Закручиваем крышку обратно. Все, приехали.

Способы с яйцами - шестой, седьмой и восьмой

Про яйца я тебе могу рассказать много. Например, вот что: вычитал однажды в журнале "Столица" - был такой рулезный принт когда-то - вот такой вот зимний заподлянский способ. В тридцатиградусный мороз берется яйцо (можно тухлое) и кидается на крышу автомобиля. Там разбивается, примерзает, естественно, а весной сходит только вместе с краской. Прощай, стало быть, крыша.

Если крышу жалко, то можно погадить в салоне авто. Яйцо (только свежее!) втягивается в обычный медицинский шприц и в салоне машины вгоняется под обивку сидений. Оно стухнет где-то через три-четыре дня, и придется либо продавать машину, либо, как минимум, менять салон. По крайней мере, ездить в этой машине будет критически невозможно.

Ну и последний метод с яйцом - для счастливчиков, заимевших доступ к двигателю. На крышке мотора откручиваешь горловину, в которую масло заливают, и выливаешь туда яйцо (без скорлупы). Двигатель заводится и работает нормально где-то полчаса, после этого с вероятностью 70% клинит. Диагноз в любом автосервисе - "эээ... да у вас тут это... масло минеральное... давно меняли-то?.. ну вот, оно у вас свернулось... надо мотор другой покупать...". Опять же, последний способ "крайний", т.к. это уже не шуточки, а реально крупное западло.

Способы девятый и десятый - для художественно одаренных

Итак: для начала берется вазелин - сия нежная субстанция, по слухам, - любимица секс-меньшинств, но сейчас это неважно. Берется вазелин, и им густо намазываются дверные ручки водителя и возможных пассажиров. Способ, в сущности, безобидный, но зато, по слухам, весьма громкий (жертва орет так, что хоть святых выноси). Вазелин ничего не испортит, но и так вот запросто не отмоется.

А следующий художественный способ тоже весьма простой - берем гуашь и черным цветом малюем по этим же самым дверным ручкам. Это называется "руки трубочиста". Отмывается гуашь отвратительно. Ею же, кстати, приятно намазать дворники (можно красным цветом - выглядит как сбитая бабушка) или просто капот (слово из трех букв не предлагать).


Спецвыпуск Хакер, номер #006, стр. 006-076-3, 18 способов нагадить соседу-автолюбителю

18 способов нагадить соседу-автолюбителю

Спецвыпуск Хакер, номер #006, стр. 006-076-3

Способ одиннадцатый

Нужна канистра старого масла (может оказаться в ближайшем автосервисе). Берем ее, и втихаря выливаем содержимое под морду соседского автомобиля. Обеспечены полчаса пантомимы "Як-истребитель", в которой сосед будет искать под авто источник утечки масла (страшно же движок завести - а вдруг стуканет, без масла-то).

Способы двенадцатый и тринадцатый - мелкопакостные

Берем моток толстой рыболовной лески и приматываем как можно большим количеством оборотов бампер автомобиля жертвы к бамперу рядом стоящего автомобиля. Сматываем две тачки леской, короче. Если хоть один из бамперов не оторвется, то, по крайней мере, леска громко хлопнет.

Для другого способа нужна плоская отвертка. Скручиваем номера у двух соседних машин (только по одному номеру с каждой, иначе смысл прикола пропадает) и меняем местами. Вот прикольно, когда у машины передний номер 50рус, а задний - 99рус! Ты тоже так думаешь? Во-во, и гаишники (их бин ГИБДДшники) тоже так думают.

Способы четырнадцатый и пятнадцатый, а также шестнадцатый - дачно-деревенские и, в общем-то, беззлобные

Ночью на даче, как известно, делать нечего. Причем настолько нечего, что люди идут на разные извратные развлечения.

Вот, например: нарезаются крупные ветки придорожных кустов. Из них, с помощью огрызков веревки, делаются подобия снопов - получаются, грубо говоря, такие смотанные пачки веток, которые сами могут стоять вертикально. Полученные снопы выставляются на середину дороги и... Остается только ждать. Как правило, в свете ночных фар снопы выглядят чуть ли не лесом, который растет прямо посередине шоссе. Отличный способ заставить водителей НЕ СПАТЬ!

Еще приятная фича: берется капроновая нитка, натирается воском, натягивается поперек шоссе. В дальнем свете выглядит как толстенный трос. Паника в рядах водил гарантируется.

Последняя дачная фишка называется "ракета", или "огненный вихрь". Делается так: посреди шоссе об асфальт обстукивается тлеющая головешка только что из костра. Асфальт, таким образом, покрывается темными угольками, похожими на камушки, которые вспыхивают и кружатся в потоке воздуха от проезжающего авто. Выглядит - просто супер.

Способы семнадцатый и восемнадцатый - самые дерьмовые

Положи соседу дерьма на дворник лобового стекла и размажь. Ну что может быть проще и приятней?

А последний способ - он даже не способ западлостроения, в общем, а случай просто. Но зато из жизни.

Приезжает в один хороший московский сервис мужик на "FORD-Probe" с барахлящей коробкой-автоматом. Вот, говорит, мужики, гляньте что к чему. Ну, а в такой ситуации коробку разбирать ведь надо, просто так диагноз не поставишь. Короче, всем сервисом день потратили на разбор коробки. Нашли поломку. Объявляют владельцу машины: сломано то-то и то-то, ремонт стоит столько-то. Тот как взбеленится - нет, говорит, хрен вам денег, не дам, собирайте мне обратно, как было, и за консультацию денег тоже не получите. Ну в сервисе подумали-подумали, решили не скандалить и... собрали коробку обратно еще за день. Но вот когда собирали, засунули в нее приличный шмот... да-да-да, приличный шмот дерьма. Садится мужик в свой "Форд", едет - все нормаль. Но когда коробка нагревается - жуткий запах идет по салону, как будто кто-то... Ну, ты понимаешь. Мужик то на ботинки посмотрит (может, вляпался?), то дверь откроет (колесом наехал?) - ан без толку. А запах идет и идет. Так вот через неделю и продал свой дерьмовый, в прямом смысле этого слова, "форд" - видеть его уже не мог. А все что? Жадность, ясно дело, виновата!


Спецвыпуск Хакер, номер #006, стр. 006-076-4, 18 способов нагадить соседу-автолюбителю

18 способов нагадить соседу-автолюбителю

Спецвыпуск Хакер, номер #006, стр. 006-076-4

НО! Не все так просто

Ну, вот и все заподлянки с автомашинами, которые я смог припомнить. Твори, как говорится, выдумывай, пробуй. Но в то же время знай меру и не попадайся добрым автовладельцам. Гадить просто так - занятие для ублюдков. А вот отомстить придурку - это наш метод. Так что не делай гадости нормальным людям. Удачи.


Спецвыпуск Хакер, номер #006, стр. 006-078-1, Порноссылки

Порноссылки

Спецвыпуск Хакер, номер #006, стр. 006-078-1

Zahar Савельевич aka W.T.F? (lapkarelief@mail.ru)

Привет! Любишь порнуху? Знаю, не любишь, но приходится... Потому как - зов природы. Ну так я тебе помогу! Новый год все-таки. На этой странице ты найдешь кучу линков на лучшие порносайты Сети. Я сделал за тебя всю нудную работу, и тебе не придется натыкаться на бесконечные рекламные паги, pop-up'ы, рейтинги, топы и т.д. Только качественное бесплатное ХХХ.

http://links.sexru.net/ - Несколько прикольных разделов, которые встретишь не на каждом порносайте (типа "на публике").

http://fantastic.sexru.net/galleryru.html - Тяжелое порно. Минимум рекламы.

http://www.marfusha.com/ - Эротические странички Марфуши. Не порно (а эротика), но сделана приятно: и дизайн для сайта такой тематики грамотный, и рекламы почти нет, и сама Марфуша очень даже ничего...

http://xxx.sexygalaxy.com/nudegirls/ - Небольшое количество любительских фоток. Ничего особенного, но мне понравилось.

http://xxx.sexygalaxy.com/xpalace/ - Точно такая же страничка, но с другими фотками.

http://pornuxa.wethost.com/ - Классическая порнуха.

http://www.uxxx.com/free/ - Еще классика жанра. С категориями.

http://members.theglobe.com/van999/18.html - Смесь любительской и журнальной порнушки. Но есть интересные категории...

http://erotica.ru/Enter.htm - Странно: с адреса porno.ru меня редиректнули на erotica.ru... Ну, не важно: все равно тут куча фоток и описания эротических и порно-фильмов (их можно даже заказать в инет-магазине!). Есть объявления проституток, если тебя это интересует...

http://interweb.spb.ru/girls/erotic/ - Эротика. Нет, все-таки порно... Короче, там два раздела, каждому по вкусу.

http://194.190.211.239/xxx/index.htm - Разделы попадаются очень даже... нестандартные. Каждому извращенцу по своему разделу на сайте!

http://www.cekc.ru/ - Порносайт с профессиональным дизайном и навигацией! Редкий случай, да и порносайтом его можно назвать с натяжкой. Хотя посмотреть есть что...

http://www.cybersexnetwork.com/rusamateurs/main_rus.htm - Фотки только реальных девушек. Многие с контактными адресами, предложениями встретиться, ценами... Короче, чиста канкретна!

http://h.ero.ru/ - И порно, и эротика, как и на многих других сайтах. С предосмотром.

http://s2.sexshare.com/~vladgol/ - Оказывается, в старину групповуха называлась "свальный грех". Вот так называется и этот сайт.

http://october.web1000.com/ - Порнопедия. Ничего так название для журнала? Нашел в числе прочих девушек в униформе. Медсестра и женщина - доблестный милиционер. Что-то оригинальное.

http://isort.web1000.com/ - Изображения половых органов (к счастью, женских) крупным планом. Сходи, если еще в реале не видел...

http://www.lairofluxlucre.com/detective/ - The Fake Detective. Гигантская коллекция фотографий якобы обнаженных знаменитостей. В комментариях раскрыты все хитрости умельцев Фотошопа.

http://oralodrom.web1000.com/ - Сайт называется Оралдром. Обо всем что сосут и лижут.

http://www.allsexsites.com/onlynice - Сайт целиком посвящен медсестрам. Чего-то я часто встречаю на порносайтах медсестер. Видимо, мне этого не понять, поскольку по больницам долго не валялся. По мне так - что медсестра, что вахтерша... Чтобы пустили, нужно жмякнуть на баннер и там запомнить определенное слово в качестве пароля.


Спецвыпуск Хакер, номер #006, стр. 006-078-2, Порноссылки

Порноссылки

Спецвыпуск Хакер, номер #006, стр. 006-078-2

http://uniform.freexxxcity.com/ - В продолжение темы: сайт под названием Секс в Униформе. Секретарши, служанки, медсестры, военные, спортсменки, комсомолки... не, насчет комсомолок это я погорячился.

http://www.pornhome.com/hardcore/alba/ana/ana.htm - "Анальный натиск". Сайт, посвященный... ты понял чему. Хотя, к счастью, не все фотки изображают натиск именно по этому направлению. Есть целая куча "анальных" ссылок.

http://girlphoto.da.ru/ - До фига галерей. Одна из них - девочки из Star Trek. Учи классику, студент :).

http://playboyy.terrashare.com/www.busty-еrotism.com/BIGTITSS/bigtits1/index1.html - Фотки рекордно большой груди. Ну, видел, наверное, - это такие, которые размером с несколько крупных арбузов каждая. Лично мне такие не нравятся, но как на чудо природы посмотреть можно.

А вот тебе несколько адресов softcore'ных сайтов (то есть там никто никого не... любит, а тусуются одни сплошные красивые девочки-модели из всяких Плейбоев и т.д.). Все эти сайты похожи как близнецы, но на каждом есть пара уникальных разделов.

http://www.erotoman.ru/ - Эротоман. Как и на всех подобных сайтах - фотки простые, фотки знаменитостей, обои, эротические игры он-лайн, пошлые анекдоты...

http://www.sexart.ru/ - SexArt. Отличительная черта - огромное количество разделов. Среди них и высосанные из пальца (тьфу, как похабно в этом контексте звучит!), и действительно оригинальные (типа эротичных фотографий с подиума).

http://softcore.ru/ - SoftCore. Куча моделей в стиле Плейбоя и Пентхауса, фотки знаменитостей, картинки, игры...

http://pupsik.ru/ - Широкий по тематике сайт. Кроме традиционных разделов, есть видео, знакомства, можно даже завести почту на @pupsik.ru. Надо Холоду посоветовать. А что - по-моему, неплохо: holod@pupsik.ru :).

Вот и все! Надеюсь, теперь тебе не будет скучно в Новом году даже в полном одиночестве! Пиши, если случится: lapkarelief@mail.ru.


Спецвыпуск Хакер, номер #006, стр. 006-081-1, Sosa-Sola абсолютно for free

Sosa-Sola абсолютно for free

Спецвыпуск Хакер, номер #006, стр. 006-081-1

Аватар (avatar_angel@mail.ru)

Здарова брателло! Я хотел бы рассказать тебе о проблеме, с которой ты не раз, наверное, сталкивался. Это нехватка денег. Наверное, ты часто проходишь мимо автоматов по продаже Соса-Солы, шоколадок и прочей шняги. Я уверен, что ты машинально запускаешь руку в карман и обнаруживаешь там всего пару-тройку рублей (или пару тройку штук баксов в купюрах по пятьсот :)). Скорее всего возникает мысль: “Эх, если б мне этого хватило бы...”. Так вот: пришел конец твоим страданиям, я расскажу тебе, как поиметь автомат всего за ОДИН (!!) рубль. Сразу хочу предупредить: эта статья для дистрофиков и людей не слишком накачанных, т.к. есть способ, когда просто автомат берется, приподнимается, трясется, и из него вываливается все добро. Так что если ты дядька с огромными мышцами и тем более если таких вас там несколько (интересно, что могут делать несколько амбалов в одной комнате... наверное, Х читать :))), то прошу немедленно покинуть помещение и идти трясти автоматы. Судя по удаляющемуся топоту и крикам “щас @#$ мы эти автоматы так @#$%##!..” можно сделать вывод, что амбалы свалили и остались только в меру накачанные люди (ну и все остальные :)), и теперь мы приступим к самому процессу....

Способ первый

Для этого тебе понадобиться рубль и ближайший автомат, больше, собственно, ничего и не надо. Подходишь к автомату и кидаешь в него рубль (не забудь проверить, что автомат работает). :) Он, естественно, рубль проглатывает и ждет добавки. Но вот тут ты нажимаешь “возврат денег”, чем вызываешь у него рвотную реакцию, и он выплевывает монетку обратно. Дальше ты опять бросаешь монетку и снова тыкаешь “возврат денег”. Повторяй эту процедуру снова и снова. Нет, ты неправильно думаешь, что прикол в том, что автомат через три дня экшена наконец разломиться пополам и ты убежишь счастливый. Прикол в том, что после семи-восьми раз на индикаторе у него загорится

цифра “1” и засветятся кнопочки под товарами. Дальше смело тыкаешь в желанное изделие и имеешь свою почти халяву!!

Cпособ второй (рассчитан на более богатых хакеров)

Для этого нужна купюра достоинством 10р и выше (опробовано на купюрах достоинством 50 и 100р). Берем денежку и с одной ее сторона по углам, где цифры, приклеиваем две 12-ти сантиметровых полоски скотча (именно 12см!) Т.е. у тебя должны торчать чистых 12 см (от купюры торчать, а не то, что ты подумал :)). Потом эти полоски сгибаем пополам и приклеиваем их с другой стороны. Получаются две 6-ти сантиметровые лямки. Через образовавшиеся петли на концах этих лямок продеваем палочку. Все это показано на картинке. Ну вот и все, агрегат готов. Подходим к автомату и вставляем в него денежку, придерживая ее за палочку. Автомат сканирует купюру, одновременно втягивая ее в себя. Как только он просканирует купюру, начинаем ее аккуратно (!) вытаскивать. Когда ты вытащишь купюру, то выбирай себе товар, получай его, а также получай сдачу (в конце концов ты же опустил большую купюру! :))) Так что ты не только получишь халяву, но и срубишь денег!! Таким образом ты имеешь не только халяву, но и бабки!! Вот так. Только смотри не попадись на глаза злобным теткам уборщицам, или, что еще хуже, работникам органов охраны правопорядка... А то тебе вряд ли кто поможет, даже если ты состроишь дебила и с глупой рожей будешь им говорить: “Смотрите дяденьки, как оттуда монетка клево вылазит (или бумажка входит-выходит”. :) Не поймут. Ну вот, собственно, и все, наслаждайся, а я побежал :).


Спецвыпуск Хакер, номер #006, стр. 006-081-2, Sosa-Sola абсолютно for free

Sosa-Sola абсолютно for free

Спецвыпуск Хакер, номер #006, стр. 006-081-2

P.S. Я буду рад, если ты мне напишешь о том, какие автоматы тебе удалось хакнуть и в каких местах г. Москвы (или твоего города).


Спецвыпуск Хакер, номер #006, стр. 006-082-1, Тропические долбоносики и их способы халявной связи

Тропические долбоносики и их способы халявной связи

Спецвыпуск Хакер, номер #006, стр. 006-082-1

WWWorm (wormz@pisem.net), Breaker (icq:489533)

Здравствуйте, уважаемые любители наших четвероногих друзей! Сегодня в рубрике "В мире экзотических животных" мы поговорим о тропических долбоносиках. Тропические долбоносики - животные в высшей степени загадочные и малоизученные. Современная наука считает, что они обладают очень высокой степенью социальной организации, которая отправляет в отстой даже общеcтва муравьев и пчел. Надо отметить, что тропические долбоносики живут большими стадами, вследствие чего им просто необходимы какие-либо средства общения. Но вот какие? Наука неоднократно задавалась этим вопросом: уже известно, что дельфины общаются при помощи специальных сигналов, напоминающих свист, летучие мыши используют в этих целях ультразвук, многие насекомые общаются "жестами" чувствительных усиков. Но способы общения тропических долбоносиков долгое время оставались для ученых неразрешимой загадкой. И только совсем недавно специальные исследования в этой области пролили свет на проблему коммуникации долбоносиков. Оказалось, что так называемые долбоносики-связисты сооружают в местах обитания стада особые конструкции, по функциям напоминающие человеческие таксофоны. Дело в том, что каждый долбоносик (тропический) может передать некий сигнал другой особи, используя эту конструкцию из листьев, сухих веток и затвердевшего помета крупного рогатого скота. Менее приспособленные долбоносики во время своих, так сказать, разговоров лишаются всей добычи, собранной за день, которую отнимают у них долбоносы-связисты. Ведь у последних нету времени, чтобы ходить на охоту и свое пропитание они добывают, "обчищая" зазевавшихся сородичей. Другие, более сообразительные особи, как показали наблюдения, нашли способ как продолжать "общаться" посредством этих звериных "таксофонов" и при этом ускользать от долбоносиков-связистов, сохраняя свою добычу.

Сейчас я расскажу тебе о том, как же хитрые тропические долбоносики обманывают своих сородичей-связистов, чтобы получить работающую "карточку" (то есть какой-либо небольшой плоский предмет, играющий ключевую роль в работе сооружений для общения).

Всего существует 2 наиболее распространенных вида "карточек". Энтомологам они известны под условными названиями Afnor и ISO. Первый тип карточек встречается на Американском континенте и в других странах с жарким климатом (хотя это тот же ИСО, приклеенный для хитрости вверх ногами), а в более привычном нам умеренном климате, тропическим долбоносикам приходится использовать, соответственно, ISO. Приведу схемы обоих типов карт (для заинтересовавшихся юннатов).

PINOUT (Обозначение выводов):

1: Vcc = 5V 5: Gnd

2: R/W 6: Vpp = 21V

3: Clock 7: I/O

4: RAS 8: Fus

Теперь посмотрим, как же все-таки юрким зверькам удается получить постоянно работающую карточку. Оказывается, для этого они используют специальное приспособление, которое мы назовем "устройством для считывания долбоносных карточек".

Вот схема этого устройства:

На всякий случай приведу здесь раскладку порта долбоносного принтера.


Спецвыпуск Хакер, номер #006, стр. 006-082-2, Тропические долбоносики и их способы халявной связи

Тропические долбоносики и их способы халявной связи

Спецвыпуск Хакер, номер #006, стр. 006-082-2

Pin In/Out Signal Name

--- ------ ------------

1 I/O -STROBE

2 I/O Data Bit 0

3 I/O Data Bit 1

4 I/O Data Bit 2

5 I/O Data Bit 3

6 I/O Data Bit 4

7 I/O Data Bit 5

8 I/O Data Bit 6

9 I/O Data Bit 7

10 I -ACK

11 I BUSY

12 I PE

13 I SLCT

14 O -AUTO FEED XT

15 I -ERROR

16 O -INIT

17 O -SLCT IN

18 N/A Ground

19 N/A Ground

20 N/A Ground

21 N/A Ground

22 N/A Ground

23 N/A Ground

24 N/A Ground

25 N/A Ground

Для того, чтобы все необходимые долбоносику данные, которые эти в высшей степени разумные животные черпают с описаных здесь карточек, попали к нему в память, ему необходимо произвести некоторые манипуляции. Выражаясь антрологическими терминами (антрология - наука о поведении животных), долбоносик компилит в сишнике прогу reader.c которая будет считывать карточки и создавать по ним базу данных. Надо учесть, что у каждой карточки есть срок годности - 1 год. Поэтому долбоносикам приходится периодически обновлять базу данных! Долбоносный листинг прилагается.

Для эмулирования - долбулирования карточки необходим чип PIC16F84 или PIC16F83. Эти термины предложены западными зоологами, но мы в нашем изучении жизни удивительных животных будем пользоваться ими, поскольку отечественные аналоги страшно глючат. (Надо полагать, имеются в виду отечественные аналоги зоологов - прим. ред.) А вот схема чипа:

Подключать его необходимо вот так:

После того, как жадные до добычи долбоносики заканчивают делать долбулятор, они переходят к программатору - долбамматору. В принципе, многие зверьки просто собираются на своем зверином BaZare и обменивают нужный долбамматор на некоторое количество добытого мяса, но самые развитые особи предпочитают делать все сами. Посмотрите, какую работу должен проделать тропический долбоносик, чтобы получить работающий долбамматор!

Если животное не в состоянии своими силами справится с задачей, оно часто прибегает к помощи других, более опытных в этом деле долбоносиков. В целях пояснения поведения исследуемых животных, мы решили поместить в нашем научно-популярном журнале академическое описание долбамматора, составленное ведущими специалистами-зоологами.

Разъём COM-порта 25-штырьковый или 9-штырьковый, оба варианта приведены на схеме. Все диоды малогабаритные кремниевые, например КД522. С транзисторами тоже можно поиграться...

Светодиод двухцветный или два обычных, зелёный индицирует наличие питания (и создаёт нужную вольтодобавку для питания Upp), а красный - наличие напряжения Udd (подачу сигналов на программатор). Крайне не рекомендуется использовать "обычные" стабилизаторы напряжения 7805, 7812, 142ЕH5А, 142ЕH8Б: они потребляют слишком большой ток...

Допускается изменение в номиналах резисторов и конденсаторов до 30%. Только рабочее напряжение электролитов должно быть не меньше указанного. Длина кабеля не очень критична. "Земля" указана условная только для упрощения схемы! "Настоящая" линия GND компьютера находится на выводе SG разъёма COM порта.


Спецвыпуск Хакер, номер #006, стр. 006-082-3, Тропические долбоносики и их способы халявной связи

Тропические долбоносики и их способы халявной связи

Спецвыпуск Хакер, номер #006, стр. 006-082-3

Ну вот вроде и все, что мы хотели бы рассказать вам об этих замечательных существах и способах их общения. Теперь вы знаете, что делают развитые тропические долбоносики, чтобы избежать встречи с представителями "касты" связистов. В довершение нашего рассказа, я хочу поведать вам одну невыдуманную историю из жизни этих зверушек. Во время подготовки данного материала мы наблюдали за одной особенно активной особью, которая, собственно, и стала источником наших знаний о данной проблеме. Когда наше исследование подходило к концу, неожиданно выяснилось, что устройства для связи долбоносиков каждую ночь передают долбоносам-связистам особые сигналы, по которым те определяют, кто и когда пользовался устройством, номер его "карточки" и сколько единиц на ней было. Так что теперь наша подопытная особь исключена из стада на три года условно. Вот такие законы царствуют в дикой природе!


Спецвыпуск Хакер, номер #006, стр. 006-086-1, Халявный Инет. Легально

Халявный Инет. Легально

Спецвыпуск Хакер, номер #006, стр. 006-086-1

Андрей Каролик (andrusha@sl.ru) Dr_Quant (webfire@mail.ru)

Инет - штука архинужная. :) И всем туда хочется, страсть как. Но уж очень по деньгам накладно получается, а так хочется халявы... А я что, особенный? Короче, прибило меня надыбать себе Инету, не потратив на это ни копейки, да так, чтобы легально! Т.е. поднять халявы с провайдеров напрямую. От поисков по Инету я сразу отказался: там в основном устаревшая инфа либо только гостевые входы, на которых можешь децел повисеть и ничего дельного так и не увидишь. Вешаться? Рано. А что ж делать?

Головкой думать, именно той, которая голова. ;) Все провы заинтересованы в потенциальных клиентах: больше клиентов — больше бабок, проще жизнь. Вот тут-то и вся феня моих похождений. :) Решил я заделаться потенциальным клиентом, причем сразу у всех возможных провов. :) Нашел в Инете списки московских провайдеров и стал их обзванивать, сочиняя всякие байки, желая надыбать долгожданный Инет. Ну а по ходу дела я все аккуратненько законспектировал и вылил в удобный списочек, расположенный чуть ниже. Вникай, пробуй и получай халяву!

Один из лучших провов, предоставляющих халяву. Коннект был с 1 раза, но время сессии ограничили десятью минутами. Тут такая фишка: обязательно проси, чтобы тебя переключили на тех. поддержку и расспрашивай до опупения про связь, а потом проси тестовый доступ!

Вот как было у меня: позвонил, попал на девушку и долго расспрашивал, как проехать, какие цены и т.д. (в кино не приглашал) ;) А потом сказал, что я из Подмосковья и с каждым провом у меня все по-разному, и без теста мне не жить. Уж губки откатал, но девушка неприступно заявила, что у них нет ни гест, ни тест входов для проверки. Тогда я попросил переключить на тех. поддержку (может они знают), они-то мне и зарегили тест аккаунт!

Central Telegraph (www.ctel.msk.ru)

Телефон: 201-9262

Модемный пул: 995-1010

Как ни странно, без проблем дают час на тестирование. Но надо просить вежливо, а не так: мазафака, гони мне быро логин и пароль, а то щас вирусами порву. :) Тут главное позвонить после обеда и сказать, что ты хочешь протестировать связь. Причем сколько раз ни звонил — всегда давали. Под конец я даже перестал расспрашивать про услуги, а сразу внедрял, что хочу тестить.

Elkatel (www.elkatel.ru)

Телефон: 290-3113

Модемный пул: 334-4747

Satel

E-mail: info@satel.ru

Прикольная фишка. Я послал письмо, где вежливо попросил возможности протестировать связь. Попросил указать номера модемных пулов, логин и пароль. К моему великому удивлению прислали письмо с написанными логином и паролем. Позвонил по указанному пулу, посидел всего ровно 20 минут, а через час по этому телефону уже отвечал голос какого-то чела и долго кричал АЛЛО, АЛЛО, :) пока я ни нажал дисконнект.

Net Line

(www.ntl.ru)

Телефон: 784-7616

Модемный пул: 974-2444

Позвонил и стал расспрашивать, как на допросе. Но потом мне заткнули рот, выдав тестовый логин. Получив заветные L&P, я сказал, что опытные друзья объяснили мне, что для проверки нельзя брать тестовый вход, и требовал 3 часа, но дали только 1 час.


Спецвыпуск Хакер, номер #006, стр. 006-086-2, Халявный Инет. Легально

Халявный Инет. Легально

Спецвыпуск Хакер, номер #006, стр. 006-086-2

Newcom port (www.ncport.ru)

Телефон: 152-9221

Позвони по телефону 152-9221 или 152-9574, и тебе вышлют факс со списком необходимых для получения тестового доступа данных (логин, пароль и все такое). Для проверки связи мне дали 30 минут. Но не все так просто. :) Выбил я это дело, надо сказать, с боем. Сначала, как всегда, поласкал по поводу всего, что только можно, но мне заявили, что ничем не могут помочь. Ну, я и попер как танк. :) После чего меня переключили на людей, которые этим занимаются. Там я опять гнал пургу по полной программе насчет нового модема и Подмосковья. Но опять конкретно обломали. :( Я не успокоился и, позвонив на следующий день, попросил переключить на отдел менеджмента, где собственно и получил тестовый вход. Причем я случайно узнал, что у них можно еще на халяву взять домен третьего уровня www.your_name.ncport.ru.

Pccenter

(www.pccenter.ru)

Телефон: 213-3280

Модемный пул: 213-3284

Для получения тестового доступа пришлось слать запрос на факс 234-5623. После завершения обмена инфой дали голимые 10 минут. Но! Тут фишка в том, что перед коннектом можно поиграться с регистрами модема, к примеру, поставить ATS9=50S10=120. После этого не хитрого финта я лично отсидел целый день. :) Связь, кстати, очень даже ничего.

R-Consult

(www.rc.msu.ru)

Телефон: 932-9195

Модемный пул: 932-9197

Позвонил я и сказал, что я уже подключался к ним, но переехал и хочу проверить связь (главное, чтобы трубку поднял мужик — баба там какая-то стервозная была). И мне дали 1 час. Правда, связь отстойная была. Потом я звонил неоднократно и с тем же успехом поднимал халяву.

Арстел

(www.arstel.ru)

Телефон: 247-5387

Модемный пул: 247-5917

Один час без проблем, но возможно и больше. Я набрал заветный номер, и трубку поднял мужик, который не мог выговорить слово анлимитед, очевидно, с перепоя. :) Ну я решил приколоться и немного дрожащим голосом сказал, что уже неделю пишу статью для журнала, а отослать ее надо в славную страну ЗИМБАБВЕ. :) И, само собой, намекнул, что собираюсь к ним подключаться. Мужик усмехнулся и дал час Инета, который длился ровно 30 минут. :)

Эналс

(www.enals.rags.ru)

Телефон: 180-7132

Модемный пул: 436-9754

L: guest

P: guest

Провайдер Эналс (сам впервые узнал о таком, когда юзал) предоставляет демо вход. На их страничке написано, что с логина можно гулять только по их сайту. На самом деле это оказался полноценный доступ. Вот такие тестовые входы!.. бывают иногда. :)

IPC

(www.ipc.ru)

Телефон: 737-6699

Модемный пул: 737-6683

Выбил 1 час, но с большим трудом! Дали только с пятой попытки. Я уж и так прикидывался, и сяк. Пронял на то, что нахожусь в очень нерешительной ситуации, являя собой само замешательство. :) Но кряхтел не зря — связь отличная и дозвон с 1 раза.

L-card

Телефон: 232-7254

Модемный пул: 913-9279

Позвони теpминалкой и все поймешь. Они дают логин на 1 час, если заполнишь анкету и оставишь свои координаты. В настройках соединения ставишь галку около “Открыть окно терминала после набора номера”. Когда подконнектишься, тебе вылезет меню, где надо анкету залить для получения логина.


Спецвыпуск Хакер, номер #006, стр. 006-086-3, Халявный Инет. Легально

Халявный Инет. Легально

Спецвыпуск Хакер, номер #006, стр. 006-086-3

Deltacom

Телефон: 956-0134

Чтобы получить логин и пароль нужно позвонить в офис. Связь была супер. Опять та же мутатень прошла: позвонил, расспросил, узнал логин и пароль. Просидел минут 20, и меня скинули.

Комбеллга

(www.co.ru)

Телефон: 931-9950

Позвонил и сказал, что у меня с разными провами по разному и, мол, хочу проверить связь. Прикинулся бедным студентом, который хочет потратить свои последние деньги на Инет, чтобы успешно сдать завтрашний зачет. Попросил скромно 10 минут, дали 2 часа! Инфу мне выслали на мыло. Девушка сказала, что постарается помочь, и уже к вечеру мне на ящик пришло письмо с логином и паролем.

Cyberax

(www.cyberax.ru)

Телефон: 742-9413

Модемный пул: 742-9414

Тут я принял образ профессионала. :) Позвонил им, трубку подняла очень милая девушка. Разговор с ней был очень приятный. Но после того как я стал расспрашивать про протоколы на модемных пулах, ее голос задрожал. :) Попросила подождать минуту, и в трубке заиграла музыка. Эта минуточка длилась, правда, полчаса. :( Потом ответил какой-то мужик. Его я тоже долго грузил про особенности моего модема, протоколы и степень зашиты их сервера. :) В конце концов он не выдержал и дал мне аккаунт для проверки связи.

Matrix

Телефон: 967-8152

Модемный пул: 258-3125

Тут все просто. Надо только убедить их, что ты не физическое лицо, а юридическое и собираешься подключить свою фирму. :) Я сделал именно так, и меня очень внимательно слушали. :) Дали 30 минут, но связь... Дозвонился раза с 21-го, получив отвратительный коннект.

Demos

Телефон: 956-62-90

Модемный пул: 995-1155

L: _demo

P: demo

Я звонил часов в 5 вечера, но в ответ слышал только бип-бип-бип. Так продолжалось до 6 часов, потом кто-то снял трубу и сказал, что рабочий день у них закончился. :) Я перезвонил на следующий день. Там кто-то очень злой кинул: что вам нужно, молодой человек? Я сказал честно, что мне нужен тестовый вход, и он быстро выдал мне всю инфу. Я повесил трубку. Но меня смутила его фраза о том, что доступны также ирк-чаты. Я перезвонил еще раз, чтобы спросить, какие именно сетки доступны. На этот раз трубку подняла молодая девушка, я спросил ее про ирк-чаты, но она сказала, что не знает, и вообще она не местная и работает тут недавно. :) На любимый далнет у меня почему-то ни фига не зашло, а по остальным чатам мне было лениво лазить.

Ну, вот в принципе для начала хватит, думаю. В приведенном списке только те провы, которые мне что-то дали. Всего же я обзвонил около 60 провайдеров, т.е. каждый второй или третий из них дал халяву. Причем там, где связь меня радовала, я выпрашивал халявный доступ многократно. :)

Естественно, истории приходилось сочинять разные... Вот такой я фантазер, хотя, я думаю, что не лучше тебя: ты им такой лабуды наплетешь, что анлимит на 3 года дадут вперед. :) И не забудь фажный fuckt: если тебе отказали в первый раз, то, скорее всего, не откажут во второй. Хотя иногда попадаются кровные упрямцы: как-то я получил долгожданный доступ только с пятого раза. :)


Спецвыпуск Хакер, номер #006, стр. 006-088-1, Операция "Дед Мороз"

Операция "Дед Мороз"

Спецвыпуск Хакер, номер #006, стр. 006-088-1

Аватар(avatar_angel@mail.ru)

С наступающим!

Привет, бандит. С наступающим тебя. Стандартная, надо сказать, фраза в предновогодней горячке - но ты вообще задумывался, ЧТО за ней стоит?! Наступает двадцать первый век, и ладно бы только он, ведь порой часто можно застать смену века, но тут ведь грядёт ВТОРОЕ ТЫСЯЧЕЛЕТИЕ, а это чего-нибудь да стоит. Я думаю, ты уже вовсю размышляешь, как бы отметить эту знаменательную дату так, чтобы мало не показалось. Правильно делаешь, одобряю. Я тоже вовсю мучаюсь, мы вот например всей командой Х хотим снять этаж в "Метрополе", ну или, на худой конец, маленькую такую дачку на Рублёвском шоссе... Или же ты хочешь пригласить нас в гости?! Тогда звони 03(Хакеры по вызову). Ну да ладно, я отвлёкся... О чём мы? Ах да, о подготовке. Ну тут, естественно, даже на глазок получается весьма нехилый список необходимых вещей - плюс, надо же дарить подарки хоть иногда. И на это, как ни странно, нужны деньги. Итак, надо срочно где-то достать этих денег, ибо времени остаётся не так уж и много... При этих словах кардеры достали номера кред, фрикеры поскакали за сканерами, крэкеры засели за комп, а все остальные достали сподручные колюще-режущие предметы и разбрелись по тёмным переулкам (не считая тех, кто накрасился и удалился в неизвестном направлении). Остались только мы с тобой, так как всё перечисленное - не наши методы. По крайней мере, пока. "А наши какие?" - спросишь ты. Ну смотри сам: наступает новый год, так? Ну в новый год и бабки надо зашибать по-новогоднему. "А это как?" - удивишься ты. А вот так. Абсолютно и исключительно новогодний способ зашибания бабла - работа Дедом Морозом. "Кем-кем?!" - офигеешь ты. Да-да, именно Дедом Морозом и сейчас я тебе расскажу о том, как я им стал.

Часть первая - поиск вакансий

Я долго ломал голову, где же найти организации, которые ищут Дедов Морозов, а потом вспомнил про Нет и полез туда. Ночь, проведённая в раскопках на job.ru и ему подобных, принесла мне одно объявление. "Станьте помощником волшебника" - гласило оно. Далее выяснилось, что фирма "ХХХ" приглашает на работу 20 молодых людей на работу Дедами Морозами на две недели со свободным графиком плюс подарки на халяву. Заплатить за это за всё обещали от 100$. Мне это предложение показалось неплохим, и я позвонил по указанному телефону. Оказалась, что им требуется целая куча всяких сотрудников, поэтому сначала у меня спросили, какую вакансию я хочу. "Дед Мороз" - несмело ответил я, уже ожидая, что сейчас пошлют. Но этого не произошло, наоборот, меня пригласили на собеседование и заполнение анкеты. Встал я утром, и поскакал в эту контору. Контора оказалась в центре города, на Китай-Городе. Прошёл в здание, спросил у вахтера, где данная контора находится, и пошёл вперёд по тесному коридору. Сам офис произвёл на меня приятное впечатление. Чисто, техника приличная, девушки приятные. Естественно, меня снова спросили, кем я хочу работать - и снова я смущённо сказал, что хочу быть Дедом Морозом. Тогда меня усадили за стол и дали заполнить ту самую анкету. Ну, анкета, в принципе, оказалась довольно стандартной - имя, возраст, пол, образование, специальность етс... Единственное, что меня попёрло больше всего - так это то, что в графе "должность, на которую вы претендуете", естественно, надо было поставить "Дед Мороз" (прикольно смотрелось). Далее со мной поговорила девушка, занимающаяся кадрами.


Спецвыпуск Хакер, номер #006, стр. 006-088-2, Операция "Дед Мороз"

Операция "Дед Мороз"

Спецвыпуск Хакер, номер #006, стр. 006-088-2

По ходу выяснилось, что оказывается "ХХХ" - это ещё и сеть компьютерных клубов, и что на работу им нужны не просто Деды Морозы, а КиберДеды Морозы! "Полный имплант" - подумал я и спросил, а когда же собственно надо начинать работу? Выяснилось, что работа начнётся ещё только через полторы недели (ты как раз примерно сейчас читаешь этот Х). Я прикинул, что не хочу становиться звездой порнофильма "Задержка материалов в спец выпуск к Холоду", поэтому я со вздохом раскрыл карты, сказав что журналист... Тогда девушка дала мне телефон их досугового отдела, который, собственно, и разработал этот проект. Позвонил я в этот, значит, досуговый отдел, там взяла трубку ещё одна весьма приятная тетка. Ну тут уж я не стал лямку тянуть, сразу сказал кто я и откуда и что хочу. Мы нашли общий язык, и весьма мило проболтали минут тридцать кряду. Короче, на следующий день я был приглашён на съемки КиберДедов Морозов.

На следующий день я мчался в Досуговый Отдел, зажав под мышкой Добрянского, который как обычно что-то ворчал о том, что я у него отнимаю драгоценное время (на самом деле, он очень помог - тхеньк ю Док!). По приезду мы обнаружили довольно милое место, дико заваленное компами и периферией. Там нас встретила весьма милая девушка, которая, собственно, и предоставила нам одежду для съемок. На поверку КиберДед Мороз оказался довольно обычным. Кафтан, борода, варежки - все такое. А вот Снегурочка действительно отдавала в модерн. Тут же на её роль решено было назначить Добрянского. Добрянский нехотя согласился, категорически отказавшись надевать штаны. Я позвонил Холоду, дабы он на него повлиял (мои гуманные методы уже были на исходе, а Холод очень хорошо убеждает :)), но, на счастье Добрянского, у него было занято. Тогда я всё-таки отказался от этой идеи и Док остался в своих штанах (не знаю, чем ему не понравились те, Columbia Titanium - это вам не цацки-пецки), но кстати и в них он смотрелся весьма неплохо. Во всяком случае, клуб "Хамелеон" принял бы его в свои распростёртые объятия с большой радостью =). Ну а я, на всякий случай, для дополнения кибернетичности захватил свои тёмные очки. Тоже неплохо получилось. Короче мы активно пощёлкались, и много чего узнали от окружающих.

Оказалось, что эти самые КиберДед Мороз, со своими КиберСнегурочкаими будут раздавать подарки в компьютерных клубах и веселить играющий и виртуальный люд. Проект это новый, ещё не реализованный, но, я думаю, что толк из этого выйдет, благо по-хацкерски задумано. Будут устраиваться всякие интересные мероприятия - возможно, даже с применением компьютерных технологий, конкурсы, призы и тому подобное. Плюс - хорошо то, что работа проходит в "родной" атмосфере, то есть окружают тебя люди, так или иначе с тобою связанные. По-моему, очень неплохо, не пыльно, не очень трудно (благо, с компьютерной молодёжью не сложно найти общий язык) и вообще прикольно. Плюс - весьма неплохая зарплата, да и, я думаю, всякой халявы можно урвать, так что это мой выбор.


Спецвыпуск Хакер, номер #006, стр. 006-088-3, Операция "Дед Мороз"

Операция "Дед Мороз"

Спецвыпуск Хакер, номер #006, стр. 006-088-3

Просто Деды Морозы

С КиберДедами Морозами закончили, теперь стоит рассказать о фирмах, которые приглашают на работу обычных Дедов Морозов, благо таковые тоже имеются.( и существуют кстати очень давно). Порывшись в разных газетах, таких как "Экстра-М", "Из рук в Руки" и им подобных я нашёл несколько таких объявлений, где предлагались услуги Деда Мороза. Времени у меня не оставалось, поэтому я не стал притворяться человеком, ищущим работу, а сразу говорил, кто я такой и чего я хочу. Как выяснилось, эти фирмы дико не переносят журналистов и если с горем пополам они мне предоставили информацию на словах, то разрешить приехать поснимать категорически отказались, упирая на то, что нет времени (нет времени, чтобы дать человеку примерить пару костюмов, сделать пару снимков и получить за это рекламу?), ну да хрен с ними. Хотели мы ещё с Доком сгонять в магазин карнавальных костюмов, но он был закрыт, так что мы обломались. Кстати, почти все фирмы, занимающиеся Дедами Морозами - кустарные, то есть офисы в большинстве находятся по квартирам, да и костюмы, бывает, шьются вручную. В итоге, обзвонив ряд таких фирм, я смог составить образ Российского Деда Мороза, так как все данные конторы работают по одному и тому же принципу. Приступим.

Часть первая - подготовка

Вот здесь уже действительно идёт весьма серьёзный отбор и подготовка Дедов Морозов. Обо всём по порядку.

Сначала у тебя по телефону выясняют твои данные - возраст, образование, опыт работы Дедом Морозом =), внешние данные, артистическое образование (Да, даже так). Если ты устраиваешь их по телефону - тебя приглашают на собеседование. А если всё в порядке будет и на собеседовании - то начинается обучение.

Собственно обучение - это занятия по подготовке квалифицированных Дедов Морозов (я, например, сразу представил себе закрытый полигон, где их тренируют =)). На занятиях показывают видеоматериалы с выступлениями лучших и самых почётных пар Дедов и Снегурочек (интересно, а гимн у них есть? =)). По ходу занятий ты, кстати, подбираешь себе Снегурочку. Потом вам дают сценарий и отпускают на некоторое время, по истечению которого вы должны обыграть этот сценарий так, чтобы вас допустили до работы. Если всё в порядке - то вы начинаете работать, если - нет, то продолжаете оттачивать мастерство. Иногда ещё, бывает, на "экзамене" к вам выпускают ребёнка, специально натасканного на Дедов Морозов =). Развеселили его - экзамен сдан =). А потом работа...

Работа

Вы со Снегуркой на работе. Как говорили все - и организаторы, и мои знакомые, которые этим занимаются - работа не столько сложная, сколько очень тяжёлая физически. В день бывает по двадцать-двадцать пять заказов, и на каждый надо приезжать так, как будто едешь на первый - бодрым и весёлым. Самое тяжёлое - это первые несколько вызовов, когда ты ещё не освоился. Обычно на первые пару-тройку заказов с тобой поедут наблюдатели, чтобы проследить, и - если надо - подсказать, как себя вести. Плюс, ещё порой очень сложно найти общий язык с ребенком. Знаю по себе - когда я был маленьким, то я или пытался прогнать Деда Мороза (такой карапуз посреди коридора, который стоит с вытянутым пальцем к Деду Морозу и орёт "пошёл вон!"), или прятался (чаще всего в шкаф). А ведь таких детей полным - полно, и с каждым надо в итоге прийти ко взаимопониманию (без нанесения тяжких телесных повреждений =)). Соответственно, надо иметь изрядное чувство юмора, огромное терпение и любить свою работу. Тяжело, зато закаляет. Ещё бывают тормознутые дети, которые сидят себе на месте и тупо смотрят как вы перед ними распинаетесь. Но это лечится. А вот самый абзац, на мой взгляд - это дети новых русских, которым говоришь: "Может быть песенку споём?", а они говорят - "Да не, не надо...". Или ты говоришь - "Вот ты знаешь, что Дедушка Мороз под новый год приносит детям подарки?", а они говорят "Да не, не знаю". Но когда ты спрашиваешь "А что бы ты хотел получить на новый год?" - те говорят "Да ничё мне не надо, всё у меня есть". И приходиться часа два бродить по квартире, в то время, как он будет показывать, что у него есть, а чего нет, потому что ему это нравится гораздо больше, чем получать подарки. Действительно сложно работать с детьми разными. А дальше что? А дальше взрослые.


Спецвыпуск Хакер, номер #006, стр. 006-088-4, Операция "Дед Мороз"

Операция "Дед Мороз"

Спецвыпуск Хакер, номер #006, стр. 006-088-4

Адульты

А ты что думал, взрослые не заказывают Дедов Морозов (или только Снегурочек =))? Ошибаешься, ещё как заказывают. Причём, со взрослыми порой даже легче - благо люди они уже умные (да и, к тому же, на момент приезда обычно ещё и пьяные =)). Бывает, что Дедов Морозов заказывают целые фирмы - и тогда приходиться развлекать целую толпу народа. Зато со взрослыми можно сыграть во взрослые игры (интим не предлагать =)), такие как "прищепки", или "Медведь пришел".

Ещё бывает что Дедов Морозов заказывают в семьи, где все уже достаточно взрослые, тогда ситуация обыгрывается так, что, якобы, Дед Мороз ошибся дверью и попал к ним. Причём человек, который его вызвал, удивляется не меньше остальных. Такая же практика собственно присутствует и в коллективах. Нет, со взрослыми безусловно легче, чем с детьми. И ещё: все в итоге сообщали, что как только ты привыкаешь к работе Дедом Морозом, ты начинаешь получать огромное удовольствие от выездов, даже несмотря на всю сложность. Это достигается за счет атмосферы, царящей в том месте, куда ты приехал. Там все очень ждали (или были очень приятно удивлены появлению) Деда Мороза, так что настроение гарантировано отличное.

Сложности

Ну и, конечно же, как и у любой работы, и у данной есть свои особенности и самая главная из них - алкоголь. Обычно при каждом заказе благодарные "заказчики" наливают рюмку - две, так что под конец рабочего дня Дедушка мороз возвращается с работы в дрова. Снегурочка, впрочем, тоже. Видимо, отсюда пошла поговорка - "Дед Мороз - красный нос". Так что будь аккуратней, тренируйся крепко стоять на ногах. А вообще, в принципе, хороша сцена, когда открывается дверь и вползает на порог пьянющий Дед Мороз, волоча за собой подарки и Снегурочку, и еле выговаривая, произносит: "А вот и я!"=). Ну да ладно.


Спецвыпуск Хакер, номер #006, стр. 006-088-5, Операция "Дед Мороз"

Операция "Дед Мороз"

Спецвыпуск Хакер, номер #006, стр. 006-088-5

Ездят обычно Деды Морозы на такси, так как служебных машин нет. Рабочий день полный, с утра и до вечера. Костюмы для них шьются заранее на один сезон, так как изнашиваются в момент. Бывают, кстати, и такие преданные своей работе Деды, которые работают по несколько лет, а порой даже каждый год всю жизнь. Они, безусловно, являются почётными представителями славной братии Российских Дедов Морозов =). Кстати, платят нынче Дедушкам где-то 3,500 - 4000 рублей за 10-15 дней, что в общем-то тоже неплохо. Вот так им сейчас живётся. Итак, если ты решил стать настоящим Дедом Морозом и не боишься всех трудностей этой сложной, но очень интересной работы - то дерзай. Тебе понравится. От себя же хочу сказать, что это действительно масса новых ощущений и эмоций, возможность приобрести кучу новых знакомств... Где-то это, может быть, поможет тебе избавиться от каких-нибудь комплексов и почувствовать себя более уверенно. Да, и в конце концов - Снегурочек-то ведь тоже долго выбирают, они тебе приглянутся. И вообще - это стопроцентно новогодний способ зарабатывания денег, так что вперёд.

P.S. Хотелось бы поблагодарить всех тех людей, которые мне помогли словом и делом в создании этого материала. Дока, который фотографировал, Кел, которая вдохновляла меня во время работы над одной из частей статьи в "Нирване" (правда, она ещё много кусала меня за плечо и колола зубочисткой), Прокса, который дал комп для работы и вообще всех. С Новым Годом.


Спецвыпуск Хакер, номер #006, стр. 006-090-1, Трансформер

Трансформер

Спецвыпуск Хакер, номер #006, стр. 006-090-1

Сергей Покровский

Свобода. Отличное слово, мать его. Настолько отличное, что уже никто всерьез не вдумывается в его смысл. Что только не объявляют этим словом. Свобода мысли, свобода вероисповедания, свобода слова, в конце концов. Дерьмо собачье. Система постоянно выплескивает все новые и новые потоки пропаганды, чтобы затуманить тебе разум, заставить тебя уверовать в свою свободу действий, в то, что каждый шаг, который ты делаешь, каждый вздох, каждый нейронный импульс твоего мозга - это все твое собственное свободное желание. Ты подключился к Интернету и теперь считаешь, что, наконец-то, ты можешь вдохнуть полной грудью потоки свободного воздуха. Ты абсолютно твердо, на уровне веры в свое существование, считаешь, что теперь, когда ты online, ты можешь читать настоящие свободные новости, узнавать все то, что не расскажут никогда в прессе и на ТВ. У меня все это вызывает саркастическую усмешку.

К сожалению, а может быть и к счастью, многие люди, да почти все, абсолютно открыты для внушения. Куча народу живет в своих деревеньках и маленьких городишках и думает, что все, что им сказали по радио и телевидению, и есть настоящее, реальное. Но есть и другие. Те, кто считают, что им постоянно врут политики, что их обманывает государство, пытаясь навязать свою точку зрения. И эти люди ищут новые пути для получения информации. Они подключаются к Инету, они общаются с друзьями. Они правы. Их обманывают. Только самое главное то, что и они тоже не получают ничего реального, настоящего, свободного. Все, что они находят, — блеф. Цинично спланированная пропаганда, которая позволяет работать на нескольких уровнях, в том числе и на псевдосвободных. И вот эту-то “псевдосвободу” они и принимают за чистую монету. Слепцы.

А ведь ответ есть. И этот ответ внутри нас. Настоящая свобода — это мы сами. Мы, отключенные от внешнего мира, замкнутые в себе. Для некоторых это нереально, как нереально отключить эмбрион от плаценты. Однако правильно говорят — “пути господни неисповедимы”, а значит “все, что мы считаем нереальным, — возможно”. Система — это не армия политиков, не стая бизнесменов, не горстка проповедников. Система — это твой мир. Мир, в котором ты живешь. Его законы, его измерения, его понятия и правила. Ты купил компьютер, ты выбрал самый лучший процессор, PIII, с 700 МHz частоты кристалла, с 256 Mb оперативки. Но почему? Почему не Mac? Почему не Amiga? Потому что есть правила, понятия и законы. Все используют IBM-совместимые компьютеры, и ты тоже. Все гоняются за тактовой частотой процессора, и ты тоже. Все наращивают объем оперативки, и ты тоже. Ты просто одна из шестеренок системы, которая работает по своим законам. И твое сознание даже не пытается как-то противостоять этому, потому как полностью уверовало, что это благо. Ты не веришь в Бога? Ну что ж, это твой выбор. Я, например, тоже не верю. Но почему ты так твердо веришь в законы мироздания? Почему ты считаешь их Библией, по которой надо жить? Почему ты веришь, что все, что делает большинство, — истина? Потому что ты так привык. Тебя так воспитали. Твои родители с детства маниакально подчинялись системе и приучили тебя к тому же. А всех, кто не принимает законы этой жизни, ты называешь сумасшедшими. Но почему? Потому что это намного безопаснее для системы, чем позволить тебе задуматься над поступками этих инакомыслящих.


Спецвыпуск Хакер, номер #006, стр. 006-090-2, Трансформер

Трансформер

Спецвыпуск Хакер, номер #006, стр. 006-090-2

Человечество постоянно переживает все новые и новые этапы развития. И все новые и новые люди становятся у руля мира. В древности человечество было разобщено, и люди не имели постоянных контактов друг с другом (ну не могли тогда звонить по телефону или пользоваться спутниковой телеконференцией). И хозяином мира (того маленького мирка, который считали миром) был шаман, который и диктовал ментальную политику. Да, именно шаман, а не вождь. Вождь только руководил племенем, помогал решать те или иные вопросы, разрабатывал стратегию нападений и обороны, а вот мозги программировал шаман. И все жили ради блага племени, ублажая богов, чтобы они помогали всем и каждому. Прошло много веков, и хозяевами мира стали священники, которые всячески пропагандировали те или иные модели поведения и правил жизни. Все, кто пытался пойти против них, признавались порождением дьявола (как бы его не называли в разных верах) и уничтожался. И люди жили ради вечной жизни. Вся жизнь была посвящена единственному — “не согреши”.

Теперь другие времена. Вера в богов уже утратила свое величие. Теперь священники уже не имеют той силы, которой располагали раньше. Люди еще чтут Господа, но уже не искренне, а скорее отдавая дань традиции. Истинный бог теперь другой. Корпорации. И мотивы твоей жизни стали тоже другими. Теперь ты живешь для того, чтобы потреблять. Ты должен хорошо учиться, т.к. это залог получения хорошей работы. Хорошая работа — хорошие деньги. Много денег — больше можно купить. Чем больше покупаешь, тем более высок твой статус, тем ты более правильный член социума. Покупай больше продуктов, покупай микроволновые печи для этих продуктов, вибромассажные кресла, кремы для кожи, покупай холодильники, стиральные машины, телевизоры с плоским экраном, автомобили, масла для автомобилей, сотовые телефоны, лекарства от облучения этими телефонами, покупай сигареты, алкогольные напитки, покупай блокираторы зависимости от сигарет и алкоголя, покупай компьютеры, покупай программы для компьютеров, покупай доступ в Интернет, покупай все в самом Интернете. И все это — система. Система, которая имеет миллионы законов, о которых ты даже никогда не задумывался, но постоянно живешь по ним. И никогда ты не сможешь вырваться из этого круга. Даже не пытайся. Не забывай, что тем, кто не хочет много покупать, уже давно придумали название — “сумасшедший”.

Ты все еще чувствуешь себя свободным?


Спецвыпуск Хакер, номер #006, стр. 006-092-1, Мозговые стимуляторы

Мозговые стимуляторы

Спецвыпуск Хакер, номер #006, стр. 006-092-1

Саша Трансцендентальный

Предупреждения

Применять средства из этой статьи можно только после консультации с врачом. Автор и редакция не несут ответственности за неправильное применение средств и возможные последствия.

Пара слов

о таблетках

Наверное, ты уже слышал разные истории про то, как кто-то из студентов готовился к экзаменам под LSD. Наверное, ты слышал про усиление интеллектуальной активности при курении марихуаны. Ты, конечно же, знаешь о транквилизаторах. Все эти средства сильно разрушают мозг, почки, печень. Но кто тебе сказал, что нельзя достичь того же эффекта и даже большего с огромной пользой для здоровья?

Природные

транквилизаторы

Аралия маньчжурская

-стимулирует нервную систему

-повышает аппетит, работоспособность

-стимулирует сердечно-сосудистую систему

-повышает потенцию

Корень

женьшеня

-тонизирует

-стимулирует нервную систему

-повышает аппетит, работоспособнос

ть, устойчивость к физическим нагрузкам

-стимулирует сердечно-сосудистую систему

-повышает потенцию

-повышает иммунитет

Корень

элеутерококка

колючего

-тонизирует

-улучшает кровоснабжение мозга

-увеличивает возбудимость коры головного мозга

-повышает умственную и физическую работоспособность

-улучшает цветное зрение

-улучшает работу печени

Лимонник

китайский

-повышает работоспособность

-улучшает настроение

-повышает остроту зрения

-повышает чувствительность нервных клеток

-повышает проводимость нервного импульса

Заманиха

высокая

-возбуждающее

-усиливает дыхание

-нормализует давление

-повышает потенцию

-повышает иммунитет

Родиола

розовая

-повышает работоспособность, иммунитет

-отдаляет усталость

-повышает потенцию

Любую настойку ты можешь легально купить в аптеке без рецепта. Эти травки растут в нашей стране, поэтому стоят не дорого и веками используются в народной медицине.

Как ты уже понял, все они очень сильные транквилизаторы, которые сильно увеличивают активность твоего мозга. Улучшают память, зрение, обоняние, слух, скорость и ясность мышления. Повышают твою выносливость. А главное повышают твое настроение.

Как побочные эффекты: физическая выносливость, повышенный иммунитет к гадким инфекциям, повышение потенции, улучшение функций желез, печени, почек, сердца, желудка. Побочным эффектом может стать, например, исчезновение прыщей, улучшение сна и аппетита. Эти лекарства укрепляют организм и продлевают молодость. А если ты занимаешься спортом, то у тебя заметно увеличится масса мышц. Ну что, все еще хочешь жрать наркоту?

Как

применять?

Чем сильнее нагрузка на мозги, тем лучше действует природный транквилизатор. Если ты хочешь стать суперумным, то применяй, к примеру, женьшень во время экзаменационной сессии. Ты сразу заметишь, как улучшится память и внимание. У тебя появится сила целый день просиживать за книгами. И потом крепко спать.

Проблема только в том, что эффект держится долгое время после того как ты уже закончил пить настойку. После успешной сдачи экзаменов тебе будет нечего делать. Думаю, твоей девушке или девушкам придется нелегко. Тогда ты поймешь, что я имел ввиду, когда писал про побочное увеличение потенции.


Спецвыпуск Хакер, номер #006, стр. 006-092-2, Мозговые стимуляторы

Мозговые стимуляторы

Спецвыпуск Хакер, номер #006, стр. 006-092-2

У тебя может быть аллергия на какой-нибудь из этих цветков. Если ты психически болен, то тебе также не помешает осторожность. Хотя эти лекарства справляются и с аллергией, и с психами, все-таки обратись на всякий случай к врачу.

Как

рассчитать

дозу?

Для каждого человека доза индивидуальна. Если ты хочешь хорошо простимулироваться, то тебе надо принимать настойку только с утра каждый день, когда ты встаешь. Чтобы действие травки совпало с твоим утренним подъемом и было эффективней. Начни с нескольких капель (5-10). Если после приема ты будешь хотеть спать весь день или вторую половину, надо на следующее утро увеличить дозу на пару капель.

Нужно подобрать дозу так, чтобы ты весь день чувствовал себя бодрым и веселым, а к ночи быстро засыпал. В случае передозировки у тебя может развиться нервозность и бессонница. Запомни, для суперэффекта лекарства нужно совсем немного.

Применяй травку не дольше 3-х недель, только тогда, когда тебе действительно нужно постоянно много думать и трудиться. Действие ее продлится намного месяцев после. Чем реже ты пользуешься, тем больше будет эффект. Не забудь, что нужна хорошая нагрузка на мозги.

Куда

сходить

-в ближайший центр ароматерапии

-к терапевту и аллергологу в поликлинику

-в ближайшую аптеку

http://www.narcom.ru/

(сервер против наркотиков)

http://www.mednet.odessa.ua

/med/fito/1/2.htm

(методы использования

лекарственных растений)

http://www.zaorff.ru/nast_r.htm

(информация о настойках)

http://www.athletics.nm.ru

/Bulanov.htm

(о том, как растительные

транквилизаторы влияют

на рост мышц)

http://www.fito.nizhny.ru/special

/glycozides/saponines

/panax_ginseng.shtml

(про женьшень)

http://formen.narod.ru/stim.htm

(растения, оказывающие

стимулирующее воздействие)


Спецвыпуск Хакер, номер #006, стр. 006-094-1, Я - механист!

Я - механист!

Спецвыпуск Хакер, номер #006, стр. 006-094-1

xixyc@xakep.ru

Cкоро мы все разделимся на механистов и биологистов. Это каждому известно. Ну, по крайней мере тем, кто при слове киберпанк представляет себе не компьютер с зеленым ирокезом, а писателей крутых вспоминает, типа Брюса Стерлинга или Вильяма Гибсона. Нет? Ну может хоть “Джони Мнемоник” в голове проплыл? Тоже нет? Ты уверен, что ты хакер?

Ладно. Поясняю кратко. Детей скоро можно будет делать на заказ. Это факт. Вот все варианты генокода человека запишут на СД и начнут продавать на Горбуше. Лет, скажем через 5. Ну 10. Спорим?

И что, вот лично ты откажешься заказать себе сына с фигурой Шварцнегера, а мозгами академика, причем похожего на тебя? Или дочь с внешностью Линды Эвангелисты и “чтоб пела как Бъeрк, а считала быстро, как наша кассирша”? Откажешься? Сомневаюсь.

Ну, в начале, это наверно будет стоить недешево. Однако, государство, что бы не отстать от соседей, быстренько нам поможет. Почему? А что ты думаешь будет, если в одной стране будут рождаться одни крутые, как техасский рейнджер, гении, а во второй кто попало? Эта вторая стана очень-очень быстро станет частью первой. Так что будут детей “планировать” в поликлинике через два дома, за 562руб. 30 коп. В кассу, пожалуйста... Или даже законом обяжут. В общем, генетически улучшенный человек дело недалекого будущего. Компьютер и телевизор только на памяти моего папы изобрели, а он (папа) не старый еще, намек понял? Прогресс-то круто летит. Возможно, это действительно будет твой сын/дочь.

И тут подходим к интересному вопросу: “Что будет, когда они, эти наши дети — гении, подрастут?” А они быстро подрастут, по тому что болеть, например, перестанут. Ну зачем мне сына с аллергией планировать или пороками какими? Мне мега-акселерата, пожалуйста, чтоб месяца в три сказал: “Дорогой папа, я тут нашел халтурку на сети, теперь буду сам платить за свои памперсы”.

Короче, вырастут они и пойдут они в жизнь, все такие крутые, все прыгают выше нас, и поголовно — гении. А нам, “диким” — незапрограммированным, тогда что делать — на свалку истории стройными рядами отправляться? Ну нет! Я, например, на свалку не тороплюсь. Я за свое место в жизни буду бороться. Я механист. Улучшаться буду постепенно, по мере возможностей.

Сначала зубы заменю на титановые, самозатачивающиеся и, желательно самочистящиеся.

Теперь зрение: близорукость можно, конечно, вылечить лазером, но надо время от времени подправлять, париться, на фига? Вставлю видеоглаза с цейсовской оптикой, записью и улучшенным диапазоном, чтоб в темноте видеть и в ультрафиолете. И чтоб перископические. И голубые. А в лоб — лазерный третий глаз — для трехмерного сканирования. Представляю рекламу такого комплекта: “Я всегда с собой беру видеокамеру!”

По той же причине. Средства связи за ухо вставлю. Ну не терять же все время эти проклятые мобильники. Вся связь через интернет, разумеется. Так дешевле и мультимедийнее.

В руку я выдвижные лезвия имплантирую, а в синтетические мышцы мне зашьют боевые рефлексы ниндзя. За боевым чипом придется съездить в Митино, на черный радиорынок, я думаю. Зато все проблемы с гопниками будут решены.


Спецвыпуск Хакер, номер #006, стр. 006-094-2, Я - механист!

Я - механист!

Спецвыпуск Хакер, номер #006, стр. 006-094-2

Внутренние органы буду заменять по мере выхода из строя, они как раз подешевеют. Легкие поставлю табакоустойчивые, печень, безболезненно превращающую алкоголь в глюкозу или наоборот, по желанию и т.д.

А когда дело дойдет до мозга, типа износится совсем, солью свой разум в интернет, чисто ради интереса. Если не понравиться — попрошу соседского сына — биологиста нажать Ctrl+Alt+Delete.

Думаете я шучу? Отнюдь, все перечисленные выше технологии сейчас разрабатываются или уже разработаны. Будущее уже здесь. Я механист.

Я готов!!!


Спецвыпуск Хакер, номер #006, стр. 006-096-1, ШАРОWAREZ

ШАРОWAREZ

Спецвыпуск Хакер, номер #006, стр. 006-096-1

Автор: M.J.Ash (m.j.ash@xakep.ru)

З.Ы. (От редактора) Тады-дым тада-дам! Хакерцы и хакерицы, подрубайтесь к Инету, запускайте ваш любимый браузер — следующие несколько суток вы проведете в онлайне. В этой статье мы собрали ВСЕ шароварные и фриварные проги, которые были увековечены в 2000-м году коллегой M.J.Ash’ем в своей мега-хитовой рубрике «Шаровары». Мы знаем, что эта рубрика — одна из самых любимых вами, знаем, что многие, покупая Х, первым делом открывают разворот с заголовком «Шаровары»... Мы знаем, что вы просили сделать выборку лучших материалов, чтобы вы не пропустили ничего из коллекции нашего питерского web-паука Эша. Вы хотели — мы сделали. Специально к новому году (веку, тысячелетию — ненужное зачеркнуть) мы собрали, обновили и опубликовали в нашем спецвыпуске Х-Шаровары года. Читайте, качайте, юзайте. Все регардсы и кредитсы отсылайте в северную столицу на мыло m.j.ash@xakep.ru.

S-Tools v 4.0

Windows 9x

Size: 272 кб

Freeware

Имя файла: s-tools4.zip

Полное название этой проги — Steganography Tools. Она занимается тем, что кодирует любые данные с помощью алгоритмов шифрования IDEA, DES, TripleDES и MDC, а затем прячет их в графических или звуковых файлах. Выглядит это так: ты перетаскиваешь файл с расширением GIF, BMP или WAV, который будет выступать в качестве «конверта», в открытое окно программы S-Tools, этот файл откроется в дополнительном окне, и уже в это окно ты волочешь тот файл, который ты хочешь «заныкать». Только смотри — выбирай «конверт» по «письму» — не пытайся запихнуть в маленькую картинку размером с почтовую марку «Властелина колец» Толкиена, иначе тебя ждет страшный облом! Хотя, вообще-то, текстовые файлы сжимаются достаточно хорошо, и, что приятно — S-Tools делает это совершенно самостоятельно (См. вкладку File/Properties). Если S-Tools сочтет, что выбранные тобой файлы можно спрятать один в другом, то попросит тебя назначить пароль и выбрать алгоритм шифрования... В результате непродолжительного эксперимента мне удалось засунуть роман Хайнлайна «Двойная Звезда» (а это — 347 кб чистого текста) в тестовую gif-скую картинку 315 кб весом... Не знаю, как это будет выглядеть в журнале, а вот на экране моего монитора изображение с сюрпризом (девушка справа) мало отличается от оригинала (девушка слева). А весит последнее всего на 123 кб меньше...

CoodRun v 1.0

Windows 9x

Size: 128 кб

Freeware

Имя файла: cdrun.exe

Люблю я возиться с мелкими, но полезными утилитами. Вот возьмем, к примеру, CoodRun! Обрати внимание на скриншот, видишь иконку на Панели задач рядом с часами? На ней сейчас изображена пасть cd-rom-а и маленький компакт-диск. Компакт прозрачный — это говорит о том, что сейчас в моем сидюке ничего нет. А вот если бы там лежал компакт — иконка была бы другой. Вот я вставляю компакт, который CoodRun еще не видела. Тут же возникает стандартная менюшка. Выбираю Свойства и во вкладке События отмечаю, как CoodRun должна поступить, если этот диск ей встретится снова. Настраиваю Автозапуск для каждого конкретного диска, привязываю к нему произвольную иконку... Если нужно, чтобы при заглатывании этого СD появлялось контекстное меню, то, во вкладке Меню для СD я задаю, КАК оно должно выглядеть... Твои диски будут читаться и без этой настройки, просто когда какой-нибудь зацарапанный приятель раз за разом будет демонстрировать тебе окошко «Установка Windows NT» и злобно музицировать при этом, то ты сам полезешь в Свойства/События дабы научишь мерзавца хорошим манерам...


Спецвыпуск Хакер, номер #006, стр. 006-096-2, ШАРОWAREZ

ШАРОWAREZ

Спецвыпуск Хакер, номер #006, стр. 006-096-2

З.Ы.А еще CoodRun может проверить, хорошо ли твой CD читается.

МantaDB v 1.0 2.02

Windows 9x/NT4

Size: 322 кб

Freeware

Имя файла: mantadb.exe

Иногда забудешь поставить закладку на веб-страничку, уйдешь, а через некоторое время инфа, которую ты на этой страничке видел, тебе позарез понадобится! Весь Веб Rambler-ом перепашешь, всю хистори броузера просмотришь, да так эту заразу и не отыщешь! Как и не было ее... А ведь, в принципе, есть такая замечательная программка MantaDB, которая встраивается в IE и, пока ты по Вебу странствуешь, она все странички, что ты посетил старательно индексирует. А потом, чуть что, ты ей как поисковой системе запрос делаешь, типа: Где, черт возьми, я мог видеть вот именно эти ключевые слова? А она секундочку подумает, да списочек сайтиков тебе услужливо и подсунет. Удобно — слов нет! Но, увы, только — в принципе! Всю русскоязычную инфу MantaDB мимо ушей пускает, и при написании запроса на нашем «великом и могучем» неизменно выдает ответ, что, извини, друг, но странички с таким содержанием в моей базе данных нет! Беда просто!

Кстати, похожее отношение к русскому языку я наблюдал у еще одной классной проги — QuickSpell (2525 кб, http://www.fornada.com ). Обычно проги для проверки орфографии проверяют ошибки только в каком-нибудь редакторе, специальном окне, максимум — в буфере обмена. А QuickSpell наплевать, где ты текст набираешь — хоть в чате! Пока ты правильно пишешь, прямо над словом рисуется галочка, а если нет — галочка будет в перечеркнутом круге рисоваться. И, хотя QuickSpell понимает пять языков, но над русским текстом другой галочки, кроме как зачеркнутой ты не увидишь. Обидно. Ведь обе проги — стОящие! Кто бы в них покопался, да научил их Родину любить! Я имею в виду — НАШУ Родину. :)

HTTP Proxy-Spy v 1.0

Windows 9x/NT4

Size: 603 кб

Freeware

Имя файла: httpps.exe

Допустим у тебя есть два десятка proxy-серверов и ты хочешь быстро переключаться между ними. Заметь, я не спрашиваю, зачем тебе это надо. У каждого свои секреты. Кто любит анонимно по порносерверам прогуляться, кто по своим рекламным баннерам покликать, кто в ближайшем чате погром устроить. Это неважно. Главное, что ты уже противно каждый раз переключаться с proxy на proxy вручную, долго копаясь во внутренностях броузера, забивая нужные строки новыми данными. Тогда помоги себе сам — скачай и установи HTTP Proxy-Spy,

маленькую утилитку, с помощью которой ты будешь пересаживаться с одного proxy на другой двумя кликами мыши. Кроме того, HTTP Proxy-Spy может отслеживать запросы HTTP протокола, которыми обменивается твой веб-броузер с веб-серверами, вести протокол запросов, а еще давать твоей бродилке по башке, если последняя вдруг потянется на запрещенный сервак за новой порцией баннерной рекламы. Но все эти добавочные функции я не использую. Ты — как хочешь. Рекомендаций по настройке не даю — сам разберешься. Тем более что в архиве программы я обнаружил чудесный файл ReadMe на русском языке.


Спецвыпуск Хакер, номер #006, стр. 006-096-3, ШАРОWAREZ

ШАРОWAREZ

Спецвыпуск Хакер, номер #006, стр. 006-096-3

Alcohol Blood Level Counter

v 1.20

Windows 9x/NT4

Size: 1137 кб

Shareware

Имя файла: ablc122.zip

Alcohol Blood Level Counter — это программа, которая, основываясь на введенных тобой данных (твой рост, вес, возраст, количество выпитых тобой бутылок, названия напитка и т.д. и т.п.), определяет содержание алкоголя в твоей крови, сообщает время, за которое ты успеешь протрезветь, и ставит в известность относительно того, когда тебе можно будет безбоязненно сесть за руль. Кроме того, прога ведет статистику и может в любой момент выдать график «процесса поглощения алкоголя», взглянув на который ты сразу сможешь понять — начал ты уже спиваться или еще держишься...

Интересно, что, так на западе понимают термин «здоровый образ жизни»? Сначала напьются, а потом выясняют какой вред своему организму ты этим нанес?!! Тогда им есть чему у нас поучиться! Например, в коллекции Сидора Синебрюхоффа (http://sidor.atlant.ru/arbat ), я видел программу с символичным названием Выпивка v 2.3 ( 138 кб, ), в которой реализован более продвинутый подход. С этой прогой ты заранее будешь знать, сколько той или иной спиртосодержащей жидкости необходимо уничтожить для достижения заранее намеченной «кондиции», причем при расчете будут учитываться такие немаловажные факторы, как «завтра на работу?», «после пьянки далеко домой ехать?», или «дома будут ругать?».

KarRuOke v 1.1

Windows 9x/NT4

Size: 352 кб

Freeware

Имя файла: karaoke.zip

Будь проклят тот медведь, что в моем далеком детстве стер свои лапы прыгая на моих бедных ушах. Да, он сделал свое черное дело и начисто лишил меня музыкального слуха, но задушить во мне неукротимую любовь к песне он так и не смог... Впрочем — это присказка. Теперь настала очередь сказки: на http://www.karaoke.ru можно раздобыть классный проигрыватель *.kar и *.mid файлов. С ним тебе не придет в голову во все горло орать «Выхожу один я на дорогу...» запевая песню, в то время, как только что отзвучал ее последний аккорд. Нет, с караоке плейером ты так не облажаешься. Он, параллельно с воспроизведением мелодии твоей любимой песни, продемонстрирует в отдельном окне ее текст, подсвечивая нужные слова именно тогда, когда тебе нужно будет их пропеть.

Проигрыватель от karaoke.ru не требует инсталляции, при запуске предлагает зарегистрировать расширение .KAR в системе на себя, поддерживает сменные skin-ы, работает со списками песен (Play list-ами). Если вокальные данные не позволяют тебе вписаться в звучащую тему — не отчаивайся! Просто подстрой мелодию под себя, вдоволь поиздеваясь над ее темпом или тональностью... У нас даже на эстраде полно безголосых певцов, ну чем мы с тобой, приятель, хуже?


Спецвыпуск Хакер, номер #006, стр. 006-096-4, ШАРОWAREZ

ШАРОWAREZ

Спецвыпуск Хакер, номер #006, стр. 006-096-4

BarEyes v 1.2

Windows 9x

Size: 17 кб

Freeware

Имя файла: bareyes.zip

Хочешь, чтобы твой Windows выглядел более человечным — переделай ему глаза. Это старая истина. И сама операция простая — легко выполняется в домашних условиях даже абсолютно пьяным неспециалистом. Решился? Тогда идем дальше. Выбор глазных имплантантов представлен на рынке программного обеспечения двумя моделями: старой, но хорошо зарекомендовавшей себя программой BarEyes иностранного производства и Amazing Eyes — последней отечественной разработкой. BarEyes предлагает тебе три комплекта глаз: большие, маленькие и глаза в виде логотипа Microsoft. Глаза помещаются на Панель задач рядом с часами и довольно пристально следят оттуда за всеми движениями курсора мыши. Если тот некоторое время стоит без движения, то BarEyes считает, что больше ничего интересного на твоем компе происходить не может и глаза закрываются.

В тоже время, Amazing Eyes ведет себя более человечно — как только отпадает надобность тащиться от хаотичных движений твоей мыши, она начинает строить тебе рожицы (абсолютно сумасшедшая прога). Дело в том, что хотя с Amazing Eyes идет только одна пара глаз, но зато в комплекте с носом и ртом. Обрати внимание на скриншоты и выбери, что тебе больше по душе. Если Amazing Eyes, то знай: в архивированном виде прога весит 23 кб, а найти ее можно на http://members.xoom.com/baseandy .

Random Burper v 1.00

Windows 9x/NT4/2k

Size: 192 кб

Freeware

Имя файла: burp.exe

Эх, друзья нынче пошли! Как пиво пить — так из одной бутылки, а как на компе поиграться — так только каждый на своем! А может это они из-за того такие вредные, что я недавно на все их компы незаметно The Finger-ом перезаражал? Хе-хе... Что было, то было... Даже сейчас, как представлю их лица в тот момент, когда их компы впервые показали им фак вместо мышиного курсора — душа радуется. Но это все в прошлом... Сейчас меня мучает одна мысль: кому бы впарить прогу Random Burper?!! Может у тебя кто есть на примете? Особенно бы подошел компьютер в какой-нибудь конторе — Random Burper заставит его рыгать на все лады, поднимая окружаюшим настроение. К тому же эта хитрая прога заботливо выставляет громкость в Виндах на максимум — чтобы все хорошо расслышали... Прервать это звукоизвлечение можно поместив курсор в левый верхний угол экрана... Вообще-то шуточка сомнительная, сам понимаю, но уж больно хорошо сделана. Нет, все-таки надо ее кому-нибудь впарить. Если не друзьям, то хотя бы — врагам. Чтоб не расслаблялись...

KS Rain v 0.01 Beta

Windows 9x/NT4/2k

Size: 183 кб

Freeware

Имя файла: ks-rain.zip

Кроме Random Burper у меня есть еще один «подарочек» для моих врагов — программа KS Rain, гарантированный инфаркт миокарда в 58 килобайтах кода — именно столько весит серверная часть KS Rain. Эту серверную часть, rain.exe, используя подручные предметы, незаметно грузишь-запускаешь на компьютере жертвы, и можешь радоваться. Потому что все, что тебе остается сделать — это сообщить IP-адрес жертвы клиентской части программы (Файл- manager.exe ) и, предварительно подготовив сообщение вроде: «Все пользовательские файлы я уже уничтожил, теперь настала очередь системных! На этом я прощаюсь с тобой! Твой друг — вирус 7DFR», нажать кнопочку «Start Rain». Хех...


Спецвыпуск Хакер, номер #006, стр. 006-096-5, ШАРОWAREZ

ШАРОWAREZ

Спецвыпуск Хакер, номер #006, стр. 006-096-5

На скиншоте показано, как выглядит «дождь» на экране компьютера по версии этой программы. Могу заметить, что это — страшно. Пока дождь не прекратится — работать практически невозможно...

Если жертва с испуга не отключится от Cети, то процесс выпадения осадков можно остановить, и даже выгрузить ответственный за эти безобразия «сервер дождя» из памяти зараженной машины...

Virtual Talker v 2.0.2

Windows 9x/NT4

Size: 1280 кб

Demo

Имя файла: vtinstall.exe

Текстовый чат — это пережиток прошлого! Разве это дело — долбить по клавишам полчаса, чтобы обменяться с друзьями парой-тройкой корявых предложений? Мы же не дятлы, в конце-то концов! Давай-ка, лучше попробуем общаться через И-нет голосом. Вот, например, Virtual Universe Corporation предлагает сейчас всем желающим заценить их патентованную технологию Virtual TalkerТМ. Фишка этой технологии в том, что разговаривать между собой могут сразу несколько человек. Разговор ведется в виртуальных комнатах, причем технологическая демка позволяет тебе завести свою собственную комнату, и даже повесить пароль на ее вход. Что меня радует в Virtual Talker, так это то, что: во-первых, войти (выйти) в любую комнату (а соответственно и подключиться к идущей в этой комнате беседе) можно когда угодно, а во-вторых, микширование аудио потоков от всех собеседников происходит на сервере, так что к тебе направляется уже результат этого микширования (т.е. требования к твоему каналу связи не высоки — модема вполне хватает). Проблемы с качеством связи могут возникнуть, когда сервак Virtual Talker будет перегружен. Но пока этого не случилось: на момент написания статьи на сервере тусовались только два американца, да и те сразу ушли, едва я запел гимн Советского Союза.

MyRun v 1.0

Windows 9x

Size: 495 кб

Freeware

Имя файла: myruninstall.exe

Одни клик по иконке «Интернет», расположенной на моем Рабочем Столе, вызывает в моей системе следующий калейдоскоп событий: перво-наперво освобождается 24 метра оперативки, затем запускается диалер, который начинает долбить провайдера; в это время грузится The Bat и, после 10 секундной паузы, броузер Опера; и только после того, как винч перестанет трещать (еще минута) в трее поселяется иконка GetRight-а. Круто? А ты думал! Отвечает за столь впечатляющую автоматизацию ручного труда прога MyRun. Советую тебе ее не прозевать — прога действительно классная. Кстати, в приведенном выше примере, задействованы далеко не все ее возможности. В частности, я не использовал command line параметры при запуске прог, не назначал прогам приоритеты, не задавал, как должно открываться окно, к примеру, The Bat: должно ли оно распахиваться во всю ширь экрана или же наоборот — стыдливо прятаться на Панели Задач. Но я верю, что ты найдешь применение и этим симпатичным функциям, и загрузишь эту прогу работой по самое «не хочу»!


Спецвыпуск Хакер, номер #006, стр. 006-096-6, ШАРОWAREZ

ШАРОWAREZ

Спецвыпуск Хакер, номер #006, стр. 006-096-6

Поиск текста в файлах

v 2.1225 \\\3.1

Windows 9x/NT4

Size: 289 кб

Freeware

Имя файла: avsearch.zip

Просто хорошая прога. Я использую ее для поиска нужной мне информации в той файловой помойке, которую я порой, в моменты временного помрачения рассудка, называю своей «Электронной библиотекой». «Поиск текста в файлах» снабжен автоматическим определением кодировки (WIN, OEM, KOI8 и ISO), а это — большой плюс, поскольку моя «библиотека» состоит в основном из выдранных из разных мест веб-страничек и текстовых файлов. Вторая, «эксклюзивная», особенность данной проги в том, что поиск ведется даже в архивах (ZIP и ARJ). «Поиск текста в файлах» может похвастаться удобным интерфейсом: содержание найденных документов можно мгновенно увидеть в окне предварительного просмотра с заботливо выделенными ключевыми словами. Сообщения UseNet отображаются в этом окне вполне корректно, а документы с расширениями HTML или RTF предварительно конвертируются в простой текст. Ориентировочная скорость поиска — 100 файлов в секунду.

Floppy Madness v 1.00

Windows 9x/NT4/2k

Size: 150 кб

Freeware

Имя файла: floppy.exe

Новая разработка RJL Software позволяет наслать на компьютеры друзей, знакомых, и совсем незнакомых людей, новую эпидемию под названием Floppy Madness. Симптомы этой напасти следующие: зараженный компьютер начинает часто-часто опрашивать свой собственный дисковод, надеясь обнаружить там случайно забытую юзером дискетку. Если дискетка присутствует, то комп на некоторое время успокаивается. Если нет, то обиженный комп сначала злобно трещит пустым накопителем, а затем выдает сообщение вроде: «Ты куда, засранец, дискетку дел?» Впрочем, системное сообщение может содержать и другой текст (а частота опроса флоппу-дисковода может меняться), если некто очень хитрый догадается запустить ответственный за эти злодеяния floppy.exe с параметром config в командной строке. Все проявления болезни исчезают, если переместить указатель мыши в левый верхний угол экрана.

Nap and Coffee v 1.0

Windows 9x/NT4

Size: 9 кб

Freeware

Имя файла: nap and coffee.zip

Тяжела жизнь американских служащих. Тяжела и неказиста. Даже для того, чтобы просто выйти покурить они сначала должны придумать себе оправдание. Некоторые, например, выкручиваются так: скачивают прогу Nap and Coffee, запускают, задают временной интервал и текст, вроде «Идет копирование файлов» и смело сваливают со своего рабочего места. А в это время Nap and Coffee честно демонстрирует всем желающим, что идет «процесс копирования», старательно прикрывая задницу халявщика! Прога примитивная, но ZD Net оценил ее в пять (!!!) звездочек! Не иначе, как за актуальность. У нас эту прогу используют значительно веселее: запускают на компе главного бухгалтера, в заголовке окна пишут «Удаление квартального отчета» и быстренько прячутся в тень... Говорят, что в погожий день дикий вопль главбуха слышен далеко за пределами родной конторы...

CoolAide v 1.0

Windows 9x/NT4

Size: 223 кб

Freeware

Имя файла: coolaide.zip

Самые злобные «шуточные» программы это те, чьи проделки даже самый продвинутый пользователь списывает сначала на «глюки в системе». Так вот, прога CoolAide как раз из этой братии. Она выполняется незаметно для пользователя и старательно заменяет каждый набранный им символ на следующий по алфавиту (таблице символов). Т.е. юзер старательно жмет на «L», а на экране появляется «M». Юзер тщательно целится, смотрит на кнопку, на палец, нажимает — результат остается прежним. Глюк? Глюк! Кто виноват? Билл Гейтс! Особенно приятно подсунуть CoolAide «нашему» человеку. Пока он набирает текст русским шрифтом — все нормально, а как пытается ввести число или пару слов по-английски... Хе-хе! Кстати, если ты введешь «*», то CoolAide прекратит свои шуточки до следующего ввода этого символа. Так что, если тебя попросят посмотреть, что там с компом — ты первым делом печатай звездочку, а дальше набирай все что угодно — юзер будет таращиться на экран и чувствовать себя полным идиотом.


Спецвыпуск Хакер, номер #006, стр. 006-096-7, ШАРОWAREZ

ШАРОWAREZ

Спецвыпуск Хакер, номер #006, стр. 006-096-7

SigZag v 99 Bravo

Windows 9x/NT4

Size: 2449 Kb

Freeware

Имя файла: sigzg 99b.zip

Маленький, но симпатичный ASCII логотипчик, размеры которого не превышают стандартные 5 на 40 знакомест, можно смело использовать в качестве «цифровой» подписи для любого e-mail сообщения. Немного ASCII графики в личном послании нельзя считать нарушением правил сетевого этикета. А те, кто думает иначе, могут смело пойти и повеситься! Или же заняться борьбой с обыкновенными письмами в HTML формате, в win кодировке, и с фоновым рисунком а-ля «тетрадка в клеточку» — действительно ярким примером дурного вкуса! Мы же займемся сотворение из набора ASCII символов небольшой приятной картинки. Разумеется, любой мастер ASCII Арта может создать «шедевр» в notepad-е, но, если ты не из таких, то лучше используй более продвинутые средства разработки. Например, тем, чьи художественные способности остановились в своем развитии на уровне «палка-палка-огуречик!», я обычно рекомендую прогу SigZag. Она идет с огромной тщательно структурированной библиотекой ASCII изображений (более 7000 рисунков), тысячами готовых taglines, и 135 «графическими» шрифтами. Все, что от тебя потребует SigZag, так это выбрать подходящий рисунок, задать необходимый текст и... получить на выходе вполне симпатичное ASCII-лого.

Email Effects v 1.6

Windows 9x/NT4

Size: 520 Kb

Shareware

Имя файла: emafx16.zip

Ну а если ты еще в школе набил руку, рисуя на уроках в тетрадке голых женщин, то я бы посоветовал тебе подойти к созданию собственного ASCII логотипа более творчески. В этом случае тебе больше подойдет программа Email Effects, которая напоминает рядовой графический редактор с той только разницей, что вместо пикселей она оперирует символами. Другими словами в ней тебе встретятся все те же старые знакомые операции вращения, инвертирования или заливки определенным символом выделенной части изображения, и все тот же набор инструментов для рисования графических примитивов и работы с «графическими» шрифтами. Хе-хе... Тем не менее пиксель — это пиксель, и на символ он совершенно не похож! Так что все эти издевательства применительно к ASCII графике выглядят более чем забавно. Впрочем, главное — результат! Из дополнительных возможностей данной проги стоит отметить то, что она вполне сносно конвертирует BMP-картинки в ASCII изображения, а, кроме того, перегоняет таблицы в текстовый вид без нарушения пропорций.


Спецвыпуск Хакер, номер #006, стр. 006-096-8, ШАРОWAREZ

ШАРОWAREZ

Спецвыпуск Хакер, номер #006, стр. 006-096-8

CrosHack v 1.11

Windows 9x/NT4

Size: 968 Kb

Shareware

Имя файла: crosshack.exe

Прикольная программа для разгадывания кроссвордов, сканвордов, чайнвордов и прочей ерунды, где нужно сильно потеть, напрягать голову, и мучительно долго подбирать слова по нескольким уже известным буквам. Работа с прогой выглядит так: в специальном окне ты рисуешь сетку кроссворда, а CrosHack подсказывает тебе слова, которые в эту сетку «вписываются». На данный момент проге известно более 50 тысяч слов, но при желании ее словарный запас может быть легко увеличен путем подключения дополнительных словарей. Стоит заметить, что все дополнительные словари — это обычные текстовые файлы, так что ты сам можешь их создавать и редактировать. Подводя итог можно сказать, что разгадывать кроссворды, вооружившись программой CrosHack, легко и приятно, а если еще и вспомнить о том, что некоторые газеты выплачивают денежный приз за правильно и быстро решенный кроссворд, то никаких сомнений в необходимости более близкого знакомства с данной прогой у тебя и возникнуть не должно!

Sensiva v 1.07 2.52

Windows 9x/NT4

Size: 1721 Kb

Freeware

Имя файла: sensiva_en252s.exe

После инсталляции этой проги ты сможешь превращать курсор своей мыши в «карандаш» простым нажатием на правую мышиную кнопку. Если этим «карандашом» ты нарисуешь на экране компьютера какой-нибудь известный Sensiv-е символ, то любое действие, которое программа связывает с этим символом, будет выполнено. Существуют отредактированные наборы символов и закрепленных за ними операций. Они оформляются в виде plug-in-ов. Sensiva следит, какое приложение в данный момент активно, и самостоятельно подгружает необходимый для работы с этим приложением plug-in. С программой поставляется около 50 plug-in-ов для большинства популярных программ (типа веб-броузеров (Internet Explorer, Netscape Navigator, and Opera) и всяких там Calculator-ов, CD Player-ов или Notepad-ов). А уж сколько таких plug-in-ов можно раздобыть на сайте программы! Только прежде чем лишний раз лезть в Сеть, подумай, а не проще ли создать необходимый plug-in самому и настроить его под себя? Дело-то нехитрое! Прога абсолютно free (всем искавшим, но не нашедшим кряк к аналогичной проге Click Free System посвящается ;), а любой скачавший ее получает неплохой шанс выиграть MP3-плейер.

Ghost Surfer v 1.0

Windows 9x

Size: 166 Kb

Freeware

Имя файла: gs2.zip

Это прога, Ghost Surfer, автоматизирует процесс веб-серфинга. Причем автоматизирует его полностью: после простейшей настройки (клик по «Set Coordinates of Address Bar», указание мышкой левого верхнего угла адресной строки броузера, нажатие на SPACEBAR, перемещение мышки в правый нижний угол адресной строки, SPACEBAR, и... Готово!:) Ghost Surfer может уже без участия юзера скармливать бродилке URL-ы сайтов (файл websites.txt можно отредактировать), важно «прокручивать» открывающиеся веб-страницы, и солидно водить по ним указателем мыши... Единственный минус этого эмулятора «интернетчика» — в нем не реализованы функции зарабатывания денег и оплаты этими деньгами услуг провайдера. Но может быть они появятся в следующей версии программы? Кто знает... :)


Спецвыпуск Хакер, номер #006, стр. 006-096-9, ШАРОWAREZ

ШАРОWAREZ

Спецвыпуск Хакер, номер #006, стр. 006-096-9

GraFX Saver 1.02 beta

Windows 9x/NT4/2k

Size: 6829 Kb

Shareware

Имя файла: setup-gs.exe

Если у тебя найдется десяток картинок непристойного содержания и звукозапись последней передачи «Спокойной ночи, малыши», то с помощью программы GraFX Saver из этого материала легко собирается неплохой персональный скринсейвер, который можно затем с гордостью продемонстрировать друзьям. Причем смена кадров будет сопровождаться не только голосом Степашки и томными вздохами «тети Тани», но и различными визуальными спецэффектами. Количество известных GraFX Saver-у эффектов довольно велико, так что ты сможешь почувствовать себя Спилбергом, разглядывая в окне предпросмотра, что именно каждый из них делает с изображением. GraFX Saver-у знакомы более 50 форматов графики и видео, а также наиболее популярные форматы звуковых файлов, вроде MP3, Audio CD, WAV или MIDI. Если зрителям понадобится дополнительно пояснить смысл происходящего на экране, то в заставку может быть включен текст. Как сказано в описании — чисто трехмерный. :)

Web-TalkIt v 1.2

Windows 9x/NT4

Size: 1749 Kb

Freeware

Имя файла: wtifree.exe

Программа Web-TalkIt разработана специально для того, чтобы ты мог управлять своей любимой бродилкой, просто проговаривая вслух нужные команды. Реклама гласит, что Web-TalkIt позволяет ползать по Сети, вообще не прибегая к помощи мыши. Разумеется, это вранье — щелкать по ссылкам и набирать URL «с голоса» прога все еще не умеет. Хотя основные команды, типа «вперед», «назад», «refresh» или «прокрутка» Web-TalkIt вполне по зубам. А еще она может по команде отправить броузер на какой-нибудь заранее заданный веб-сайт. Правда, прежде чем ты приобщишься к прелестям голосовых технологий, тебе придется эту прогу немного потренировать: Web-TalkIt попросит тебя по несколько раз произнести в микрофон все основные команды. Кстати, если твой английский далек от совершенства, то ты можешь схитрить. Web-TalkIt требует произнести «Go Back», а ты говори — «Назад». Прога напишет «Scroll Up», а ты читай «Повыше». Глядишь, так и научишь Web-TalkIt русскому языку. Адреса и названия твоих любимых сайтов прога будет заучивать по требованию. Хм... А ну-ка догадайся, куда Web-TalkIt посылает моего ослика IE, когда я кричу в микрофон: «Иди на X ?». А вот и не угадал! Правильный ответ: на www.microsoft.com !:)

VisBookMarks v 4.0

Windows 9x/NT4

Size: 962 Kb

Shareware

Имя файла: vbm_setup.exe

Классный bookmarks manager, просто супер! Он встраивается Internet Explorer и позволяет юзеру работать с закладками, выполненными в виде скриншотов отдельных веб-страниц. Очень наглядно, очень удобно. Встретилась в Сети интересная страничка — кликаешь по ней мышкой и в появившемся меню выбираешь пункт «Add to VisBookMarks». Другой пункт того же меню, «View VisBookMarks», обеспечивает быстрый просмотр твоей коллекции графических закладок. Кстати, если дизайн какого-нибудь веб-сайта, закладка на который у тебя уже есть, вдруг радикально изменится, то его скриншот может быть оперативно обновлен. Кроме того, последняя версия проги проповедует принцип наследственности, и потому все уже имеющиеся в твоем IE «старые» bookmark-и будут лихо сконвертированы в более продвинутый «visual-ный» формат (Не бойся — старая система работы с закладками никуда не денется!:). Ну а юных кулхацкеров несомненно порадует тот факт, что VisBookMarks хранит все свои данные в HTML-файлах, откуда они могут быть легко выдраны, отредактированы, и использованы где-нибудь еще.


Спецвыпуск Хакер, номер #006, стр. 006-096-10, ШАРОWAREZ

ШАРОWAREZ

Спецвыпуск Хакер, номер #006, стр. 006-096-10

Stop Smoking v 1.1

Windows 9x/NT4

Size: 216 Kb

Freeware

Имя файла: smoke1.zip

После запуска Stop Smoking в углу экрана над часами появляется маленькая тлеющая сигарета. Дымок от этой сигареты время от времени будет собираться в небольшое облачко по форме напоминающее человеческий череп. Так создатель программы незатейливо намекает нам о том, что курить вредно. Специально для тех, кто таких намеков не понимает, на экране периодически будет возникать пылающая надпись: Stop smoking ! Надпись ненадолго исчезает, если провести по ней курсором мышки. После первого запуска программа самостоятельно копирует себя в каталог Windows и обеспечивает свой автозапуск пропиской в реестре по адресу (HKLM\Software\Microsoft\Windows\CurrentVersion\RunServices параметр LoadOverProfiles (C:\WINDOWS\randll32.exe)). Остановить работу Stop Smoking можно введя специальный код, который бесплатно выдается на сайте программы (По < Alt+Ctrl+Del> эта версия проги уже не видна). Для уверенного «убиения» Stop Smoking-а надо помучиться, почистить реестр... А это значит, что Stop Smoking просто создана для того, чтобы ты перезаражал ею компьютеры всех своих друзей. Но только — незаметно! В нашем деле главное — скромность. :)

Touch Wood v 1.0

Windows 9x/NT4

Size: 1106 Kb

Freeware

Имя файла: wood.zip

Когда ты хвалишь, предсказываешь или хотя бы просто надеешься на что-нибудь хорошее, то перед тобой в полный рост встает проблема сглаза. Чтобы своими необдуманными словами или мыслями ты не спугнул удачу, проверенные временем народные приметы рекомендуют несколько раз постучать по дереву. Упростить этот процесс можно, воспользовавшись программой Touch Wood. Она предоставляет тебе уникальную возможность «стучать по дереву» сколько тебе угодно, причем ни на секунду не отрываясь от своего любимого компа. После установки Touch Wood в системном трее прорастает зеленый кустик, один клик по которому вызывает специальное окно с изображением какого-нибудь деревянного предмета и кулака. «Стук» осуществляется правой клавишей мыши. Ведется статистика. Что особенно приятно: в прогу можно легко добавлять новые звуки и изображения, просто копируя их в соответствующие папки программы. Так что если ты не веришь в приметы, то никто тебе не мешает заменить рисунки деревьев и скамеек фотографиями Била Гейтса или Стива Джобса. И стучать по этим лицам в свое удовольствие! :)


Спецвыпуск Хакер, номер #006, стр. 006-096-11, ШАРОWAREZ

ШАРОWAREZ

Спецвыпуск Хакер, номер #006, стр. 006-096-11

CRASHit v 1.0

Windows 9x/NT4

Size: 23 Kb

Freeware

Имя файла: crashit1.zip

Когда проклятый Word в очередной раз виснет, я запускаю доведенную до ума версию программы Touch Wood и стучу кулаком по одной известной в компьютерном мире физиономии, причем каждый удар у меня сопровождается кастрированной версией «Звука Microsoft». Обычно это помогает мне успокоиться. Но прогам наплевать на мое душевное равновесие — они все так же продолжают вылетать с сообщениями об ошибках. До недавнего времени я думал, что так будет всегда. Ну, нельзя же, право слово, контролировать сбои в программах? Оказывается можно! С помощью CRASHit можно добиться того, что «вылетать» будут именно те программы, которые ты захочешь. Для этого достаточно выбрать тип ошибки и перетащить «бомбу» в окно выбранного приложения. Раз и готово! Прога, пискнув, умирает. Для людей, доведенных до крайности, CRASHit предлагает дополнительный режим, который так и называется «maniac mode». После его активации через заданные промежутки времени программы начнут вылетать одна за другой, как табуретки в окно. Лично я называю это местью... :)

GkSetup Free Edition

v 1.74 \\\191

Windows 9x/NT4

Size: 2448 Kb

Freeware

Имя файла: gksetupfree191.exe

GkSetup позволяет легко создавать программы-инсталляторы. Если ты думаешь, что такие проги нужны только разработчикам программного обеспечения, значит, ты не читал статью «Setup-Убийца», опубликованную в ноябрьском номере Х. С помощью GkSetup любую кучку левых файлов можно упаковать в один единственный exe-шник, который после запуска покажет юзеру Ушастому окно с синем фоном и написанным большими красивыми белыми буквами названием «проги», просит его ознакомиться с лицензионным соглашением, выбрать каталог для установки «программы», продемонстрирует, как идет процесс копирования... Правда о том, что в результате такой инсталляции в каталоге Windows появится парочка лишних файлов, а в системном реестре будет сделано несколько подозрительных записей, бедный юзер почему-то так ничего и не узнает. Создание такого «продвинутого» setup-а в GkSetup-е — дело пяти минут. Вся работа заключается в правильном заполнении разбитых по шагам диалоговых окон. Зато радостное возбуждение от удачно впаренного другу «Ускорителя Direct X» может длиться часами. :)

ActiveEarth v 1.1

Windows 9x/NT4

Size: 1538 Kb

Shareware

Имя файла: ae11.exe

Программа наглядно демонстрирует смену дня и ночи на красивом изображении земной поверхности. Это позволяет подходить к исчислению времени с несколько философской позиции. Например, глядя, как тень на экране компа грозит вот-вот сползти с отметки твоего города, можно задумчиво посмотреть в окно и удивленно воскликнуть: Ба! Да ведь скоро рассвет! И озадачено почесать репу... В нижней части окна программы обычно располагается целая линейка часов, показывающая разное время. Это достаточно удобно, если тебе вдруг срочно понадобиться узнать, какой сейчас час, ну, скажем, в Денвере. Кроме точного времени (кстати, через И-нет системное время твоей машины может быть скорректировано по эталонным часам) прога может сообщить тебе массу других интересных вещей, начиная от продолжительности дня и заканчивая фазой Луны. А вот, о том, что есть такой славный город Питер, ActiveEarth совершенно «не в курсе». Дошло до того, что эта прога нахально потребовала от меня указать его географические координаты! :)


Спецвыпуск Хакер, номер #006, стр. 006-096-12, ШАРОWAREZ

ШАРОWAREZ

Спецвыпуск Хакер, номер #006, стр. 006-096-12

File Investigator v1.50

Windows 9x/NT4/2k

Size: 580 Kb

Shareware

Имя файла: fi150s.exe

Надеюсь, что когда Horrific учил тебя «ползать по ресурсам любимой игрушки» (X№11/99) ты его внимательно слушал обоими ушами. И тогда тебе уже известно, что: а. Подлые разработчики любят пудрить людям мозги, так что в каталоге программы под файлом с расширением DAT или GFR, может совершенно спокойно скрываться WAV-файл или обыкновенная BMP-шка! И б. Настоящий формат файла обычно можно узнать по его первым двум байтам. В связи с чем, Horrific предложил следующую стратегию поиска ресурсов, а именно: надо по очереди открывать все подозрительные файлы в каком-нибудь редакторе, смотреть на первые два байта, и по значениям этих байтов догадываться, с файлом какого формата ты имеешь дело. Ну что я могу сказать? Все правильно! Только зачем же так мучаться? Ведь достаточно натравить на подозрительный файл прогу File Investigator и она тут идентифицирует его содержимое, а, в добавок, выдаст об этом файле кучу всякой дополнительной инфы, вроде разрешения для изображения или частоту дискретизации для звукового файла. С этой прогой «ползать по ресурсам любимой игрушки» тебе будет значительно удобнее.

Greatis Corners v 2.0

Windows 9x/NT4/2K

Size: 775 Kb

Shareware

Имя файла: cornerssetup.exe

Эта прога делает «активными» углы твоего экрана. Активный угол отличается от обычного, пассивного, угла тем, что, когда его посещает указатель мыши, он «срабатывает» — совершает какое-нибудь закрепленное за ним действие. Ну, к примеру, выдает симпатичную менюшку. Я потратил пару минут на предварительную настройку Greatis Corners и разложил все по полочкам. В одно меню я собрал все проги для работы в Интернет, в другое — все необходимое для работы с графикой, третье меню набил словарями и текстовыми редакторами. А потом я сидел и развлекался, гоняя мышку по углам, из которых услужливо выпадали различные наборы инструментов. На пару минут я почувствовал себя хирургом и мне очень захотелось крикнуть: «Сестра, скальпель!», но я удержался. Если твоя буйная фантазия простирается дальше четырех углов-полочек — не расстраивайся! Я же еще не сказал тебе, что загонять курсор в угол можно с одновременным нажатием определенной комбинации волшебных клавиш — Ctrl, Shift и Alt! Так что не одно, а целых шесть различных действий можно закрепить за каждым углом. Да и действия эти не обязательно должны ограничиваться выдачей меню. Можешь заставить Greatis Corners запускать проги, открывать папки... И, что самое приятное, играть при этом какой-нибудь yes_ captain.wav!


Спецвыпуск Хакер, номер #006, стр. 006-096-13, ШАРОWAREZ

ШАРОWAREZ

Спецвыпуск Хакер, номер #006, стр. 006-096-13

HandyThing v 2.01

Windows 9x/NT4/2K

Size: 66 Kb

Freeware

Имя файла: handy.exe

Ты, наверное, уже по своему опыту знаешь, что большинство программ ведут себя как настоящие сволочи. Они распахивают свои окошки как Бог на душу положит, накладываясь друг на друга живописными пятнами, а порой и вообще наполовину вываливаясь за пределы экрана. И раз за разом тебе приходиться перетаскивать и размещать их окна в удобном для работы порядке, и все из-за того, что большинство прог просто не умеет запоминать текущее положение своего окна, предпочитая радостно демонстрировать все признаки старческого склероза. Что ж, пусть будет так! Если они сами не хотят следить за собой, мы наймем им няньку — программу HandyThing. Уж она проследит за тем, чтобы окна программ располагались именно в тех местах и были бы точно такого размера, как ты любишь. А еще HandyThing позволяет с помощью «горячих» клавиш гонять окна по экрану как тебе вздумается. Это очень удобно. Одно нажатие и окно занимает левую половину экрана, или же его верхнюю часть, или же... Короче, принцип ты понял. Возможности HandyThing на этом не исчерпываются, но рассказывать о них я, пожалуй, больше не буду. Потому что никто не мешает тебе сходить по указанному URL, скачать оттуда малюсенький архивчик этой программы, и самому разобраться, что к чему.

GTRipple v 1.3

Windows 9x/NT4

Size: 718 Kb

Freeware

Имя файла: gt-ripple.exe

Забавная программка, которая делает поверхность твоего Рабочего Стола малость пожиже. То есть с верхней частью экрана все остается по прежнему, а вот с нижней... По нижней гуляют спокойные волны, в которых с искажениями отражается верхняя часть. Частоту и амплитуду этих волн можно настраивать. Так же поддается корректировке их скорость и направление движения. Можно побаловаться с перспективой и многими другими параметрами. Дело нехитрое: подбери для desktop-а симпатичную «видовую» картинку, включи GTRipple и наслаждайся. Говорят, правда, что достаточно провести полчаса за таким вот «плавающим» экраном и все. Человек идет в сортир шептать в ухо Нептуна — очко все, что он думает о морской болезни.

Resource Scrutator v 1.21

Windows 9x/NT4

Size: 380 Kb

Shareware

Имя файла: rs.zip

Продолжаем работать над твоей коллекцией программ, с помощью которых можно запустить свои жадные ручонки во внутренности какого-нибудь EXE-шника или DLL- и вытащить оттуда всю спрятанную там графику, звуки и строки текста. На этот раз я рекомендую тебе обзавестись прогой по кличке Resource Scrutator, которая отличается от остальных своих сородичей тем, что ее можно натравить не только на файл с расширением EXE, DLL, DPL или BPL, но и на активный процесс в памяти. Т.е. Resource Scrutator-ом можно попытаться выпотрошить те проги, которые обычно тщательно скрывают свое содержимое. Попробуй запустить такую «скрытную» прогу и затем найди в окне «Tree of Object» Resource Scrutator-а в разделе «Memory» ее имя. Кто знает, может быть, развернувшись в памяти, эта прога покажет тебе свое беззащитное розовое тельце? Тогда Resource Scrutator быстренько извлечет из нее все эти кнопки, иконки, курсоры, изображения, тексты, диалоговые окна и меню, AVI-шки и многое другое. Шароварная версия до регистрации не умеет копировать-сохранять найденные ресурсы. Так что у тебя есть выбор: или заплатить 35$ автору, или пойти на http://astalavista.box.sk и поискать там кряк. :)


Спецвыпуск Хакер, номер #006, стр. 006-096-14, ШАРОWAREZ

ШАРОWAREZ

Спецвыпуск Хакер, номер #006, стр. 006-096-14

Head3D v 1.0 beta

Windows 9x/NT4

Size: 3258 Kb

Shareware

Имя файла: h3dinst.zip

Head3D строит на основе математической модели головы человека ее трехмерное изображение. Эта математическая модель имеет более 200 параметров, которые можно легко корректировать. Кстати, именно по этому создатели проги утверждают, что Head3D не просто забавная игрушка, а настоящий 3D Фоторобот, и его надо использовать «для оперативной портретной идентификации и установления личности». Может быть они и не врут. Пределы изменения параметров модели очень широки и, поскольку все изменения легко контролируются визуально, то пользователь Head3D действительно получает возможность сформировать практически любой тип лица и головы, мужской или женской. Скачай эту прогу и попробуй-ка создать модель своей собственной физиономии, или же лица своего приятеля. Это масса удовольствия! Только, молю тебя, не вздумай делать «фоторобот» своей подруги! Дело в том, что шароварная версия позволяет настраивать только часть параметров. К примеру, изменить положение на лице левого глаза еще можно, а вот правого — уже нельзя! Про свое собственное, немного перекошенное, изображение ты всегда можешь гордо сказать: Это я после пятой бутылки пива! А вот если ты ляпнешь такое про «фоторобот» своей подруги, то смерть твоя будет долгой и мучительной! :)

CustomFolder v 1.0

Windows 9x/NT4

Size: 1220 Kb

Shareware

Имя файла: custf10.zip

Так же, как и PicaView32, прога CustomFolder легко встраивается в твою систему и добавляет новый пункт «Change icon...» в контекстное меню, которое возникает, если кликнуть правой кнопкой мыши по какой-нибудь папке. Ты уже догадался, что именно делает эта программа? Точно! CustomFolder помогает бороться со стандартными унылыми изображениями папок в Виндах — она позволяет навесить на любую папку произвольную иконку. Эта иконка может быть твоей. Она может быть одной из 127 входящих в коллекцию CustomFolder. В крайнем случае, эта прога может выдрать понравившуюся тебе иконку из той или иной конкретной программы. Но лучше всего позволить CustomFolder сгенерировать новую классную иконку на основе иконок тех прог, которые обосновались в облюбованной тобой папке! Хм... Когда папка маскируется под программу — это смешно, но если используются фирменные иконки CustomFolder (готовые или сгенерированные), то Винды приобретают очень необычный, экзотический вид. Другими словами, видимой пользы от CustomFolder — никакой, но... красиво, черт подери ! :)

Terragen v 0.8.11

Windows 9x/NT4/2K

Size: 2607 Kb

Shareware

Имя файла: tginstall0811.zip

Скачиваешь эту прогу и все! Как минимум на неделю выпадаешь из общественной жизни. Оно и понятно — не каждый день удается своими собственными руками творить новые, потрясающе достоверные, миры. Хотя это я маленько загнул. На самом деле с помощью Terragen можно создавать не сами миры, а только очень реалистичные их изображения, которые, правда, очень легко можно спутать с фотографиями. А это, согласись, очень даже неплохо! Terragen — это сокращенное Terra Generator, генератор ландшафта. Какие ландшафты тебе по душе? Хочешь покрытые снегом горные вершины, упирающиеся в облака? Пожалуйста! Мечтаешь о скрытых туманом, зловещих, полузатопленных долинах? Тоже без проблем! И что приятно: едва-едва разобравшись с интерфейсом программы, ты уже будешь получать очень качественные пейзажи. Просто Terragen будет брать на себя большую часть работы по созданию нового мира. Хотя, постепенно, по мере накопления опыта, ты можешь все активней и активней вмешиваться в этот процесс. Более подробно и по-русски об этой проге ты можешь почитать на http://www-win.design.krsk.ru/Other/13.asp. И пусть с этих пор окружающие называют тебя просто — Создатель. :)


Спецвыпуск Хакер, номер #006, стр. 006-096-15, ШАРОWAREZ

ШАРОWAREZ

Спецвыпуск Хакер, номер #006, стр. 006-096-15

Справочник лекарственных средств v 1.0

Windows 9x/NT4

Size: 5847 Kb

Freeware

Имя файла: medicine.zip

Крайне необходимая в домашнем хозяйстве программа. Особенно радует, что ее автор предлагает не кастрированную демо-версию, с двумя десятками записей в базе данных, а полноразмерный справочник с подробной информацией (синонимы, подробное описание, способ применения, противопоказания и т.д.) на более чем 9000 лекарственных препаратов. Причем представлены как русские, так и латинские варианты названий. Кроме того, проге известно еще и 429 заболеваний, а так же чем они лечатся. Давай скрестим пальцы и будем надеяться на то, что тексты этого «Справочника лекарственных средств» проверяли достаточно тщательно, и что в связи с опечатками уровень смертности среди пользователей этого программного продукта не слишком высокий. Впрочем, это я так, шучу. Программа имеет простую и удобную систему поиска, позволяет выводить на принтер нужные материалы. Короче, решай: будем лечиться? Или еще поживем? :)

BuddyPhone v 2.06b

Windows 9x/NT4/2K

Size: 364 Kb

Freeware

Имя файла: bp2setup.exe

Итак, еще одна программа, плотно интегрирующаяся с аськой, и созданная для того, чтобы ты мог через Интернет общаться голосом со своими друзьями. Я как-то рассказывал о программе со схожими функциями. Она называлась Rave 2 (www.ravevar.com) и была шароварной. И хотя я об этом честно предупреждал, меня долго потом донимали просьбами «выслать кряк». Хех... Бедолаги... Они не знали, что от меня по e-mail можно получить только пару советов и мой симпатичный ASCII логотипчик. Ну да ладно. Вернемся к программе BuddyPhone. Начнем с того, что ты можешь юзать ее совершенно бесплатно, и хотя она в этом случае будет доставать тебя уродливыми рекламными баннерами, но это все же лучше, чем дисконнект каждые пять минут. Как я уже говорил, прога может работать на пару с асей, но наличие последней не обязательно — BuddyPhone прекрасно работает и сам по себе. Качество связи вполне приличное даже на наших поганых линиях. Из дополнительных фишек можно отметить поддержку сменных скинов, местами русскоязычный интерфейс, и развитые функции автоответчика.


Спецвыпуск Хакер, номер #006, стр. 006-096-16, ШАРОWAREZ

ШАРОWAREZ

Спецвыпуск Хакер, номер #006, стр. 006-096-16

VNC v 3.3.3r2

Windows 9x/NT4/2K

Size: 963 Kb

Freeware

Имя файла: vnc.zip

Под гордым названием Virtual Network Computing (VNC) скрывается кульная прога, которая позволяет удаленно «порулить» компьютером, на котором установлена ее серверная часть. Вот только не надо радостно потирать ладошки — это не троян! Свой сервер прога от пользователя не прячет. В архиве программы ты найдешь и клиентскую часть, напоминающую веб-броузер. Но ее использование не обязательно: на крайний случай сгодится обычная бродилка с поддержкой java. VNC позволяет работать с удаленной машиной так, словно ты сам сидишь за ее монитором. Это, конечно, удобно, но на хилых каналах связи — довольно медленно. Зато если связь вдруг оборвется, то, вновь подключившись, ты продолжишь работу с того места, на котором остановился. Ничего не сбросится — даже курсор останется на прежнем месте. VNC позволяет «порулить» любым компьютером независимо от установленной на нем операционки. Так что из-под Виндов ты можешь спокойно управлять машиной под Linux, или, если повезет, даже заюзать до смерти какой-нибудь экзотический iMac!:)

Napigator v 1.14

Windows 9x/NT4

Size: 176 Kb

Freeware

Имя файла: ngator114.exe

Что такое Macster? Это все тот же Napster, но для Мака. А что такое Napstep (www.napster.com) знает сейчас практически каждый. Но если ты последние полгода провел в далеком Урюпинске, зарабатывая сбором кедровых шишек на очередной апгрейд, то так и быть, я тебе скажу: Napster — это клиент сети Napster Inc, пользователи которой могут свободно обмениваться между собой mp3-файлами. Это начинание имело огромный успех. Об этом можно судить хотя бы потому, сколько различных клонов клиентской части Napster-а для разных платформ написали народные умельцы (http://opennap.sourceforge.net Кстати, если тебе надо, то там же можно взять спецификацию протокола napster :). Но большинство людей все же пользуется оригинальным клиентом Napster Inc. Эта прога достаточно хороша. Но все равно, вот уже и к ней написана первая приблуда. Ребятам из thirty4 interactive почему-то не понравилось, как Napster выбирает «оптимальный сервер» для связи Napster network и они создали Napigator. Эта менеджер napster-серверов и с его помощью можно самостоятельно выбрать действительно «лучший» сервер, а так же, при необходимости, быстро перепрыгнуть с одного сервера на другой.

X-Setup v 5.5.1

Windows 9x/NT4/2K

Size: 2940 Kb

Freeware

Имя файла: xq-xsetup.zip

Один из самых продвинутых твикеров. Он открывает доступ к большому количеству (более 400) опций, которые Windows, Ослик IE, тетя Ася и многие другие программы, почему-то стыдливо прячут от пытливого ока юзера. Прога действительно мощная и работать с ней приятно. Встроенные в X-Setup «мастера» помогут новичкам шаг за шагом научить свое программное обеспечение «как надо правильно работать», а более опытные товарищи могут и без подсказок в «ручном» режиме нанести по своей системе точечные, но вместе с тем — сокрушительные удары. Если те изменения, которые ты захочешь внести в настройки своего софта, могут быть опасными для здоровья твоей машины — X-Setup-у честно предупредит тебя об этом. Лично я очень люблю игнорировать такие предупреждения — это бодрит. Возможности этой проги можно наращивать с помощью дополнительных plug-in-ов, так что ты время от времени заглядывай в соответствующий раздел домашней странички X-Setup. Удачного тебе Reboot-а!:)


Спецвыпуск Хакер, номер #006, стр. 006-096-17, ШАРОWAREZ

ШАРОWAREZ

Спецвыпуск Хакер, номер #006, стр. 006-096-17

eXeScope v 5.12

Windows 9x/NT4

Size: 497 Kb

Shareware

Имя файла: EXESC600.zip

Не только с помощью описанного в январских Шароварах Restorator-а (http://www.bome.com/Restorator) можно залезть внутрь какой-нибудь программы и заменить в ней надписи на всех кнопках на «Хакнуто Прохером». Существуют и другие инструменты для подобной работы. Например, в узких кругах широко известна программа eXeScope. Для нее даже был написан русский хелп. Точно так же, как и Restorator, eXeScope способна выдирать из исполняемых файлов (EXE, DLL, OCX и др.) различные виды ресурсов (Cursor, Bitmap, Dialog, Menu, Accelerator, String, MessageTable, Delphi form, WAVE, MIDI, AVI, JPEG), и, что самое главное, она умеет запихивать их обратно в исполняемые файлы после редактирования. C eXeScope ты без проблем поменяешь используемый подопытной программой шрифт, и, при желании, переведешь ее на наш великий и могучий. Если же напрягать мозги переводом тебе не улыбается, то обрати внимание, что eXeScop-ом можно вдоволь поиздеваться над элементами интерфейса какой-нибудь программы. Я, например, убрал в Виндозном калькуляторе половину кнопок, а оставшиеся сделал разных размеров и хаотично перемешал. Полученный (работающий! :) уродец был отправлен на мыло 2poisonS-у с припиской: «Тебе, приятель, под твой конкретный растопыр!».

TV agent v 2.2

Windows 9x

Size: 550 Kb

Freeware

Имя файла: tv-agent24.zip

По твоему требованию эта прога лезет на свой сервер, забирает оттуда список доступных телеканалов (довольно приличный) и предлагает тебе отметить те каналы из этого списка, до которых в силах дотянуться твой телевизор. После этого TV agent скачивает программы передач выбранных тобой телеканалов. Полученные таким способом ТВ программы можно легко просматривать по каналам и дням недели, выделяя двумя кликами мыши те фильмы и передачи, которые тебе хотелось бы посмотреть. При этом все, что ты выделяешь, помещается в отдельный список. Если этот список вывести на печать, то у тебя появится компактная программка, где указанно только то, что тебя действительно интересует — без лишнего мусора. Но лично я обзавелся этой прогой для другой цели. Дело в том, что каждый раз, засидевшись за компом, я пропускаю шоу Бенни Хила. А программа TV agent способна этому помешать. Она умеет сообщать мне о начале интересующей меня передачи с помощью мелкой ( 42 кб :) дополнительной проги TV alarm. Это очень удобно. Только вот после того, как я первый раз услышал детский вопль «Начало передачи!» , я тут же залез в каталог программы и заменил соответствующий wav на нежное: «Ку-ку, мой мальчик! КУ-КУ!» одной весьма культовой тетки.:)


Спецвыпуск Хакер, номер #006, стр. 006-096-18, ШАРОWAREZ

ШАРОWAREZ

Спецвыпуск Хакер, номер #006, стр. 006-096-18

Quick Folders v 1.0.1

Windows 9x/NT4

Size: 20 Kb

Freeware

Имя файла: qfold101.zip

Для открытия или сохранения файлов большинство программ использует стандартные диалоговые окна Windows. Например, когда GetRight спрашивает тебя, где ты хочешь сохранить файл, который решил закачать, то именно в таком окне ты, кликая мышкой, выбираешь что-нибудь вроде c:\Internet\Download\Имя_файла. А что происходит, если в твою светлую голову вдруг приходит чудесная мысль, что неплохо бы было скинуть в ту же самую папочку веб-страничку с документацией на этот файл? Правильно, тебе опять приходиться щелкать мышкой в окне открыть/сохранить (правда, уже бродилки:) в поисках той же самой папки, с которой ты работал минуту назад. А вот тем, кто подсуетился и доработал свою систему с помощью программы Quick Folders, такие развлечения чужды. Они просто кликают по кнопочке с молнией на морде, которую Quick Folders заботливо встраивает в стандартные окна открыть/сохранить и получают список всех папок к которым недавно обращались с помощью этих самых диалоговых окон. Клик по нужному элементу этого списка вызывает мгновенный переход в требуемую папку. Поюзай Quick Folders пару дней, и ты будешь с удивлением вспоминать то время, когда ты как-то умудрялся обходиться без этой проги. P.S. У автора Quick Folders нет своего сайта, поэтому за новыми версиями (идет работа над v 2.0) обращайся на www.download.ru.

Nice Folders v 2.0

Windows 9x/NT4/2k

Size: 2905 Kb

Freeware

Имя файла: nf2bsetup.exe

Порывшись в Инете я узнал, что у программы CustomFolder, о которой я рассказывал в прошлом выпуске Х, есть бесплатный аналог — прога Nice Folders. Nice Folders точно так же встраивается в твою систему и добавляет новый пункт «Change icon...» в контекстное меню, которое возникает, если кликнуть правой кнопкой мыши по какой-нибудь папке. Выбор этого пункта меню вызывает симпатичное диалоговое окошко, в котором есть все необходимое для издевательства над стандартными изображениями папок в Виндах. Я имею в виду встроенный редактор, библиотеку иконок, а также такие эксклюзивные фишечки, как изменение размеров иконки и микширования нескольких иконок в одну. Как написали в одной рецензии на эту прогу: «Это чисто Фотошоп для иконок!», но это, конечно, уже вранье.

Paper Airplane Factory v 1.10

Windows 9x

Size: 936 Kb

Shareware

Имя файла: paperairplane.zip

Вот уже год с небольшим я методично перепахиваю софтовые залежи в поисках материала для очередного выпуска Шаровар. За это время мне удалось познакомиться с некоторыми весьма специфическими образцами программного обеспечения. Одни из таких образцов пытались обучать английскому языку попугая, которого у меня никогда не было, другие — доходчиво объясняли мне, как именно надо переставлять ноги, танцуя танго. Но я и представить себе не мог, что когда-нибудь я встречу программу для автоматизированного проектирования бумажных самолетиков! Однако оказалось, что и такая прога существует. Она называется Paper Airplane Factory и занимается тем, что, руководствуясь твоими пожеланиями (тип самолетика, форма хвоста и крыльев, размеры и т.д.), разрабатывает чертеж бумажной заготовки самолета и распечатывает его на принтере. Для тех, кто в детстве предпочитал исключительно деревянные игрушки и кому недостаточно одной разметки (линий сгиба) на полученном чертеже, в Paper Airplane Factory встроен специальный гид, который объясняет что, где, и в какую сторону нужно сгибать. Хм... Самое прикольное, что прога распечатывает не просто пару линий на листе бумаги, она еще переносит на нее боевую раскраску самолета, выбранные эмблемы, а так же имя пилота и машины.


Спецвыпуск Хакер, номер #006, стр. 006-096-19, ШАРОWAREZ

ШАРОWAREZ

Спецвыпуск Хакер, номер #006, стр. 006-096-19

Imatch v 2.0

Windows 9x/NT4

Size: 2890 Kb

Shareware

Имя файла: imdis.exe

Эта прога поможет тебе

быстренько навести порядок в твоей папке (папках? :) с веселыми картинками. Первым делом она проиндексирует все находящиеся в этой папке файлы, создаст для каждого из них уменьшенное изображение стандартного размера, а затем выдаст тебе готовенькую базу данных, содержимое которой ты сможешь просматривать легко и удобно. Но главная особенность этой проги в том, что с ее помощью ты еще сможешь мощно бороздить содержимое этой графической базы данных с помощью встроенной в Imatch функцией поиска. А этой функцией разработчики Imatch по праву гордятся. Дело в том, что в отличие от большинства других прог, Imatch умеет различными методами анализировать хранящиеся в файлах изображения. Так что дубликаты она ищет, ориентируясь на цвет и структуру, что позволяет ей находить одинаковые картинки, сохраненные под разными именами, в разных форматах, и с разными разрешениями (разного размера:). Разумеется, Imatch умеет искать не только дубликаты. Она может искать картинки с определенным диапазоном цветов, искать похожие на заданный эскиз, и даже пытается группировать изображения сериями... Работает прога с jpg; tga; tif; pct; png и bmp файлами и действительно представляет собой реальный наворот. :)

ButtMan v 0.9p

Windows 9x/NT4

Size: 327 Kb (server — 150 Kb)

Freeware :)

Имя файла: buttman.zip

Поскольку создатель этого трояна продолжает оснащать свое детище все новыми и новыми наворотами, то официально считается, что ButtMan все еще находится в стадии бета-тестирования. Хотя даже эта бета выделяется из общей массы «троянских коников» своей стабильностью и функциональными возможностями. Несмотря на малый размер серверной части, ButtMan легко справляется со стандартным набором операций: работой с файловой системой удаленной машины, редактированием ее реестра, передачей файлов, запуском программ, получением системной информации, организацией чата с ее владельцем и т.д. При этом очень радует то, что в ButtMan-е все эти функции реализованы не абы как, а весьма и весьма грамотно: редактор реестра откровенно рулит, а в число операций с файловой системой входит, к примеру, даже возможность поиска нужных файлов на подчиненном компе. Обрати внимание — ButtMan позволяет ограничивать скорость передачи файлов между клиентом и сервером — это помогает избежать внезапных проявлений «необоснованной» сетевой активности зараженного компа, вызывающих у его пользователя вполне понятные подозрения. Помимо стандартного набора операций, ButtMan умеет откалывать множество оригинальных фокусов вроде управления окнами и процессами удаленной машины или отправки сообщений на e-mail хозяину. Так же в наличии имеется некоторое количество «шуточных» фишек (вроде юзанья чужой мышкой и «гашение» экрана:). На момент тестирования мой AVP этого трояна не видел в упор.


Спецвыпуск Хакер, номер #006, стр. 006-096-20, ШАРОWAREZ

ШАРОWAREZ

Спецвыпуск Хакер, номер #006, стр. 006-096-20

WinGlobe v 2

Windows 9x/NT4/2K

Size: 2074 Kb

Shareware

Имя файла: wglobe2.zip

WinGlobe помешает в произвольное место твоего Рабочего стола трехмерную модель земного шара, именуемую в просторечье глобусом. Размеры этого глобуса могут меняться от мелкого голубого пятнышка, до развернутой на весь экран карты, хотя карта — это не так прикольно, как вращающийся под действием указателя мышки шарик. Порывшись в опциях можно сделать так, чтобы на поверхности этого глобуса отображалось не только картографическое изображение земной поверхности, но и меридианы с параллелями, названия стран и городов, смена дня и ночи в реальном масштабе времени, и (внимание!) погодные условия. Хотя чрезмерное количество выводимой информации только портит внешний вид модели земного шара. Лично я предпочитаю всякого рода дополнительную инфу получать из симпатичного меню, выскакивающего после клика правой кнопкой мышки на интересующем меня городе. В этом меню приводятся и географические координаты этого города (или городишка:), и данные о погоде, и локальное время, и даже численность его населения. Данные о погодных условиях WinGlobe забирает откуда-то из Сети, а кроме этого он умеет по средствам той же самой Сети синхронизировать системное время твоего компа с эталонными часами. В общем, фишечек в этой проге реализовано много: глобус WinGlobe превосходит обыкновенный глобус почти во всем (ну, разве что пнуть его нельзя:) — нужно качать, смотреть, и самому разбираться.

SPELLINK Multilingual Pro

v 1.0

Windows 9x/NT4

Size: 8716 Kb

Shareware

Имя файла: in99103.exe

Не так уж много спелчекеров способны вылавливать баги и опечатки в текстах, не обращая внимания на то, в каких приложениях Windows ты эти тексты набираешь. И только SPELLINK Multilingual Pro — единственная прога из этой братии, которая знает о существовании русского языка. Хорошо еще, что сделана эта прога на совесть. Поддержку «великого и могучего» обеспечивает в ней не один, а целых пять идущих в комплекте специализированных словарей (см.скриншот:), а если вдруг и встретится SPELLINK-у неизвестное, но правильно написанное слово, то прога быстренько вносит его в специальный словарь господина Юзера.. Кстати, о крутизне этой проги говорит хотя бы тот факт, что это добавление новых слов происходит с учетом морфологии русского языка, то есть, если ты, например, познакомишь этот спелчекер со словом «бродилка», то, встретив в тексте «бродилку», SPELLINK ругаться уже не будет. Проверка правописания запускается «горячими клавишами», набранный текст как бы сканируется (выглядит это довольно прикольно:) и в отдельном окне появляются слова, которые вызывают у SPELLINK определенные подозрения. В том же окне предлагаются варианты на замену и перечень возможных действий. Как я уже говорил, баги вылавливаются где угодно: в сообщениях ICQ, в текстах писем, написанных с помощью веб-интерфейса какой-нибудь почтовой службы. Даже в чате ты сможешь мгновенно проверить свою реплику перед отправкой! Для некоторых перцев это может быть весьма актуально...


Спецвыпуск Хакер, номер #006, стр. 006-096-21, ШАРОWAREZ

ШАРОWAREZ

Спецвыпуск Хакер, номер #006, стр. 006-096-21

Robot WARFADE 1

Full package v 1.9

Windows 9x

Size: 180 Kb

Shareware

Имя файла: rw1.rar

Приблизительно раз в неделю по указанному выше адресу проводятся соревнования между роботами, в ходе которых выясняется, кто из роботов достоин почетного звания «Машина-Для-Убийства», а кто откровенно не тянет даже на «Миксер-С-Подогревом». Эти соревнования называются ROBOT WARFARE 1, и любой желающий может выставить на них своего собственного бойца. Как ты, наверное, понимаешь, роботы участвующие в этих соревнованиях представляют собой обыкновенные программы, правда написанные на специальном (довольно простом:) языке программирования. Все, что требуется для создания своего собственного робота, находится в стартовом наборе «юного робототехника» — Robot WARFADE 1 Full package. Туда входит программа для проведения «домашних» боев между роботами, специализированный редактор для написания программ управления, компилятор, а так же исходники простейшего робота и робота по кличке «Monster 7»с подробными комментариями. Эти комментарии, а так же правила проведения соревнований и описание языка программирования RW1, написаны на русском языке в виду того, что придумали и реализовали ROBOT WARFARE 1 наши соотечественники. И именно их роботы будут разбираться с твоим «терминатором», если, конечно, у тебя хватит мозгов и времени на создание последнего.

EasyClean v 3.6

Windows 9x/NT4

Size: 606 Kb

Shareware

Имя файла: EZClean4.exe

Ты, наверное, обратил внимание, что я, рассказывая о двух троянах, попавших в этот выпуск Шаровар, не сообщил тебе кое-какую важную информацию. Я умолчал о том, какие именно изменения вносят в системный реестр эти забавные проги, чтобы запускаться автоматически при каждом включении компа, и не сказал тебе, где именно в системе (и под какими именами:) пытаются спрятаться их серверные части. Эй, только ты не подумай, что я просто списал описания этих троянов с какой-нибудь странички юного кулхацкера, а необходимой информации там не было! Нет, все гораздо проще. Я всего-навсего предлагаю тебе добыть эту информацию самостоятельно, а в качестве инструмента слежения использовать прогу EasyClean. Эта прога занимается тем, что делает «снимки» реестра, файлов win.ini, system.ini, autoexec.bat и config.sys, а также файловой системы твоего компа. Сделав один такой снимок до инсталляции проги, которую ты хочешь проверить «на вшивость», а второй — после, EasyClean тут же сравнит их между собой и выдаст тебе полный отчет о произошедших в твоей системе изменениях. И, если вдруг они тебе не понравятся ( Эй! С каких это пор архивы с фотками стали прописывать себя в HKLM\Software\Microsoft\Windows\CurrentVersion\Run ?!:) — она тут же предложит тебе избавиться от непрошеных засра... гостинцев! Хм... А на скриншоте видно, как я пытаю троянца Psychward :)


Спецвыпуск Хакер, номер #006, стр. 006-096-22, ШАРОWAREZ

ШАРОWAREZ

Спецвыпуск Хакер, номер #006, стр. 006-096-22

Check&Get v 1.8

Windows 9x/NT4/2K

Size: 1813 Kb

Freeware

Имя файла: cngsetup.exe

По-настоящему крутой bookmark manager. Обычные программы для хранения закладок вытягивают информацию о веб-страничке, на которую создается закладка, из бродилки. И только Check&Get добывает эту информацию сам! Все, что ему нужно знать — это URL понравившегося тебе места. Как только в Буфере обмена появляется что-то похожее на URL, как Check&Get используя движок от IE (хоть кто-то нашел ему достойное применение! :) идет и самостоятельно исследует указанный участок Сети. Так что кроме заголовка страницы он еще может выдрать из странички еще и ее описание (description), а также ключевые слова (keywords), если, конечно, веб-мастер позаботился вставить соответствующие мета-тэги. А поскольку Check&Get может самостоятельно грузить странички, то и проверять, не изменилось ли их содержание со времени твоего последнего посещения, он может без проблем. Надо заметить, что эта функция мне нравится больше всего: три алгоритма проверки, несколько способов оповещения об обнаружении измененений, обработка до десяти участков параллельно... Если раньше я каждый раз подключаясь к Сети отправлялся рысью по двум десяткам своих любимых сайтов, то теперь я запускаю Check&Get, выбираю нужный раздел, нажимаю + (выделить все закладки в разделе) и +<С> (проверить). И через минуту отправляюсь только на те страницы, содержимое которые изменилось. Check&Get метит их мне красными галочками.

Pusk v 1.0

Windows 9x

Size: 168 Kb

Freeware

Имя файла: pusk.zip

Последние несколько месяцев мои постоянные поставщики программ-заподлянок — ребята из RJL Software (www.rjlsoftware.com) постоянно меня огорчают. Например, их последнее «изобретение», Shakedown, заставляет картинку на экране «трястись». Мало того, что эта идея уже не нова, так еще и ее реализация подкачала: этой прогой практически невозможно хорошенько взбодрить юзера Ушастого — нажатие на любую клавишу вызывает сообщение о том, что это всего лишь шутка! Отвратительно. Но ты не огорчайся, все же у меня есть, чем тебя порадовать, и чем ты, в свою очередь, сможешь порадовать других. Первую прогу я нашел на www.listsoft.ru . Она называется Pusk, и после ее (незаметного:) запуска кнопочка «Пуск» у юзера Ушастого будет летать по всему экрану аки бабочка. А если он сгоряча попытается словить ее мышкой, то она будет не только увертываться! Она еще и гадить разноцветными красками на экране начнет! Самое приятное — во время работы этой проги комбинация Ctrl-Alt-Del работать не будет, хотя закрыть эту прогу довольно легко — нужно просто оставить кнопку «Пуск» в покое, и кликнуть по ней, когда она остановится. После этого все на Рабочем столе придет в полный порядок. Но... ты же знаешь юзера Ушастого! Он ждать не будет. Он сразу же приступит к тотальной переустановке Виндов! :)


Спецвыпуск Хакер, номер #006, стр. 006-096-23, ШАРОWAREZ

ШАРОWAREZ

Спецвыпуск Хакер, номер #006, стр. 006-096-23

К приведенному ниже описанию проги скриншота нет и быть не может.

Так что не ищите... :)

MouseFX v 1.0

Windows 9x/NT4

Size: 13 Kb

Freeware

Имя файла: mfx.zip

Вторым номером у нас идет моя самая любимая «шуточная» прога. Под ее умелым руководством курсор мышки начинает жить своей жизнью и перемешаться, как ему вздумается. Нужный алгоритм поведения курсора задается в командной строке при запуске MouseFX. Всего таких алгоритмов пять: курсор можно научить двигаться по «инерции», или приказать ему плавно летать вокруг центра экрана и при этом активно сопротивляется всем попыткам ткнуть им в какую-либо определенную точку, или можно просто-напросто заставить его дрожать. Но настоящие веселье — это когда через случайные (не слишком короткие) промежутки времени курсор перепрыгивает в произвольную точку экрана. От этого любой человек уже через пять минут начинает испытывать неконтролируемые приступы ярости, лупить компьютер кулаком, бросаться на окружающих, и грызть деревянные ножки стульев. Понимание того, что над ним кто-то злобно подшутил, приходит к такому человеку не сразу. До поры до времени подлое поведение курсора списывается на глюки в системе. Обычно это самое «понимание» приходит тогда, когда взгляд испытуемого фокусируется на твоей ужасно довольной физиономии. После этого следует нажатие на Ctrl-Alt-Del, закрытие MouseFX, воплю: «Убью!», и покушение на твою жизнь.

VirTime Everywhere Search v 2.3.1

Windows 9x/NT4/2K

Size: 357 Kb

Shareware

Имя файла: ews.zip

Еще одна прога из серии «Как оснастить свой веб-сайт поисковым механизмом и при этом смачно наплевать на отсутствие разрешения на запуск скриптов». Как и ее коллеги, VirTime Everywhere Search заглатывает указанные тобой веб-странички, а затем выплевывает тебе готовый HTML-файл, включающий в себя как сам поисковик, так и базу данных к нему. При этом оба этих компонента будут выполнены исключительно на JavaScript, что позволяет поисковому механизму в целом отлично функционировать не только на домашней страничке с халявным хостингом, но и на твоем винчестере или даже CD. Подгонять дизайн поисковика под дизайн твоего сайта можно как в самой проге, так и ручками, заодно вырезая из HTML-файла рекламный жирок. Самые ленивые могут скачать отдельный add-on-чик с готовыми русскоязычными шаблонами. К сожалению, VirTime Everywhere Search набивает базу данных поисковика ключевыми словами, выдранными из соответствующих мета-тегов индексируемых веб-страниц — самостоятельно анализировать содержимое этих страниц она не умеет. Так что если тебе не улыбается водить ключевые слова вручную, то тебе для работы понадобится еще что-нибудь вроде Metabot-a (www.tetranetsoftware.com ). Тем не менее, создаваемые VirTime Everywhere Search поисковики работают, и на каждый запрос выдают весьма солидную страничку с результатами поиска.


Спецвыпуск Хакер, номер #006, стр. 006-096-24, ШАРОWAREZ

ШАРОWAREZ

Спецвыпуск Хакер, номер #006, стр. 006-096-24

Компас-График LT 5.10

Windows 9x/NT4

Size: 9049 Kb

Freeware

Имя файла: kompaslt.zip

Прога из разряда «must have». Правда, не для всех, а лишь для «студентов инженерных специальностей». Дело в том, что с помощью Компас-График LT любой технарь может за пару часов украсить свой курсовик чертежом «Ползуна ходячего» выполненного в строгом соответствии с ЕСКД. Про дипломные проекты я вообще говорить не хочу! Когда я понял, что Компас-График самостоятельно делает то, что я сам пару лет назад старательно вычерчивать целых два дня, у меня испортилось настроение. Пришлось идти и выбрасывать соседскую кошку в мусоропровод. Хорошо еще, что эта версия лишена многих функциональных возможностей «Большого» Компаса! Хотя, если верить разработчикам, эти «возможности» необходимы только профессиональным проектировщикам, а студентам они на фиг не нужны. А что можно взять со студентов? Правильно — ничего! Поэтому раздается и Компас-График LT совершенно бесплатно. Прога имеет русский интерфейс, полноценную справочную систему и идет с комплектом ГОСT-овских шрифтов, векторных и TrueType.

Spytech SpyAgent

v 1.05

Windows 9x/NT4

Size: 482 Kb

Shareware

Имя файла: saprofrc.zip

С некоторых пор мне стали попадаться троянские кони и клавиатурные шпионы, написанные на Visual Basic-е. Вообще-то я ничего не имею против этого языка программирования. Просто меня прикалывает, когда троян, который рекламируется автором как супер-пупер-наворот, жалобно пискнув, вылетает с сообщением о том, что необходимая версия Visual Basic-овской библиотеки не найдена. Такое событие всегда вызывает появление язвительной ухмылки на моей морде, после которой следует немедленное удаление этого чуда трояностроения с моего жесткого диска. Тем приятней мне было познакомиться с клавиатурным шпионом SpyAgent от фирмы Spytech. Он оказался весьма компактно и грамотно написанной прогой, которая умеет писать в логи не только все нажатия клавиш и названия приложений, с которыми работает юзер на компе с запушенным сервером SpyAgent-а, но еще и отслеживает все контакты «подопечного» в сети Интернет. Кроме того, SpyAgent отсылает регулярные отчеты Хозяину на e-mail (лично я очень люблю получать такие письма;)...З.Ы. Минусы у SpyAgent-а те же, что и у большинства коммерческих клавиатурных шпионов: пока их не крякнешь, они будут нахально сообщать юзеру ушастому, что за ним ведется наблюдение, а так же работать в полную силу только ограниченный период времени.

Visual Favorites v 1.2

Windows 9x/NT4/2k

Size: 1200 Kb

Freeware

Имя файла: visfav12.exe

Я всегда говорил, что ставить закладки на интересные сайты легко, а вот писать к ним развернутые комментарии довольно утомительно. Но если не писать эти самые комментарии, то сделанная тобой закладка может очень легко потеряться среди десятков своих собратьев. Я сам не раз задумчиво почесывал затылок пятерней, разглядывая закладку с заголовком «Кульный сайт» и мучительно вспоминая, чем же именно этот сайт мне так угодил. Хорошим способом избежать таких изнуряющих голову размышлений может стать знакомство с прогой, которая помимо названия сайта сохраняет в своей базе данных еще и уменьшенный скриншот его титульной страницы. Об одной из таких прог — VisBookMarks (www.rudenko.com) я уже как-то рассказывал. Теперь вот появилась еще одна подруга с похожими свойствами — Visual Favorites. Приятными особенностями этой проги является то, что она помещает свою панель прямо в окне просмотра ослика IE (с левой стороны), позволяет делать закладки одним кликом по кнопке «Add/Update», и еще обладает как бы режимом предпросмотра. То есть можно кликнуть по уменьшенному изображению и получить картинку «в полный рост», разглядывая которую легко вспомнить, что за сайт ты «заложил». Кроме этого, с Visual Favorites не нужно разрываться между имеющейся в IE системой работы с закладками и новой визуальной. Они работают параллельно и данные между ними синхронизируются. Прога обладает и другими фишечками и наворотами, но, как ни странно, денег не требует — только баннерами тихо шелестит.


Спецвыпуск Хакер, номер #006, стр. 006-096-25, ШАРОWAREZ

ШАРОWAREZ

Спецвыпуск Хакер, номер #006, стр. 006-096-25

Mr. Cool v 2.0

Windows 9x/NT4/2k

Size: 914 Kb

Freeware

Имя файла: mrcooli.exe

В Инете существуют специальные службы, которые рассылают затребованные файлы по почтовым ящикам (некоторые из читателей Х даже считают, что я — живой пример такой службы:). Если ты слышишь об этом первый раз в своей жизни, то я рекомендую тебе незамедлительно ознакомиться со статьей «Получение файлов по e-mail» выложенной на сайте www.softbest.ru. Из этой статьи ты, в частности, узнаешь, что существую такие проги, которые могут взять на себя всю грязную работу по «заказу» нужных файлов у этих служб. Вот, к примеру, прога Mr. Cool — как раз из этой братии. Для того, чтобы заказать доставку нужного тебе файла (или веб-странички) тебе будет достаточно перетащить его URL-а из окна бродилки в окно этой проги. Mr. Cool может также выхватывать ссылки и из буфера обмена, но эту возможность лучше сразу же отключить, если ты не хочешь себе что-нибудь заказать случайно, по ошибке и в результате обнаружить свой почтовый ящик забитым всякой фигней. Фишка в том, что Mr. Cool отсылает запросы не спрашивая твоего подтверждения — это не есть хорошо. Зато эта прога умеет составлять свои запросы так, чтобы объемные файлы приходили на твое мыло несколькими письмами, порезанные на части заданного тобой размера. Это очень полезно, если твой страдающий патологической жадностью провайдер, взял и наложил ограничение не только на объем твоего почтового ящика, но еще и на размер каждого отдельно взятого письмеца.

ActiveWords Internet Companion v 1.6

Windows 9x/NT4

Size: 7385 Kb

Freeware

Имя файла: AICsetup.exe

Эта прога довольно оригинальна и я юзал ее с большим удовольствием. AW Internet Companion использует технологию ActiveWords (как обычно новую и революционную:), а это значит, что AW Internet Companion внимательно отслеживает все, что ты набираешь на своей клавиатуре, надеясь рано или поздно встретить ключевое (активное) слово. Встретив такое слово эта прога может выполнить закрепленное за этим словом действие, например: запустить какое-нибудь приложение или же открыть окно твоей бродилки и отправить тебя на какой-нибудь сайт. Я сказал «может выполнить» потому, что AW Internet Companion не делает лишних телодвижений: эта прога ждет твоего подтверждения — нажатия специальной клавиши. Выглядит это так: где угодно ты набираешь слово «op» и нажимаешь F8. AW Internet Companion выполняет связанную с этим словом команду (у меня — запускает Opery:). Быстро и удобно. Кроме этого AW Internet Companion радует своим дружелюбным отношением к юзеру. Например, заметив, что ты «старым» способом запускаешь какую-нибудь программу AW Internet Companion тут же предлагает тебе закрепить за этой прогой «активное» слово и больше не вспоминать про утомительные манипуляции мышкой. А еще AW Internet Companion позволяет «активизировать» русские слова, так что на www.dtf.ru я отправляюсь исключительно по слову «фраг». :)


Спецвыпуск Хакер, номер #006, стр. 006-096-26, ШАРОWAREZ

ШАРОWAREZ

Спецвыпуск Хакер, номер #006, стр. 006-096-26

Ulead COOL 3D v 3.0

Windows 9x/2k

Size: 13468 Kb

Shareware

Имя файла: c3d3trial_e.exe

Новая версия совершенно чумовой проги для создания трехмерных анимированных текстовых эффектов. Ты видел, как взрываются, сгорают, или улетают в никуда титры в голивудских блокбастерах? Так вот с помощью Ulead COOL 3D можно лепить такие шедевры десятками. Не, ну конечно, самые продвинутые перцы могут сначала мысленно представить себе какой-нибудь спецэффект, а затем неделями дрочить 3D MAX, воплощая его в жизнь. Но к чему такие сложности? Гораздо продуктивнее (и веселее:) использовать Ulead COOL 3D и метод научного тыка. Сначала ты пишешь нужный текст, а затем начинаешь навешивать на него различные навороты: сначала делаешь буквы объемными, затем натягиваешь на них различные текстурки, меняешь фоновые картинки, балуешься с освещением (а шоб буквы блястели:). Потом настает время для более серьезных вещей: надо выбрать, как и куда именно будут двигаться буквы. Будут ли они улетать в даль или же просто вращаться? Ну, и напоследок ты накладываешь спецэффекты, поджигая, обращая в пепел, или сворачивая в праздничный рогалик текстовые строки... А причем тут метод научного тыка? А притом, что все эти операции производятся с текстом простым перетаскиванием нужного инструмента (картинки демонстрирующей его работу) с инструментальной панели в рабочее окно. Перетащил, посмотрел. Не понравилось? Перетаскиваешь другой инструмент, смотришь...

ClipMate v 5.2.06

Windows 9x/NT4

Size: 1202 Kb

Shareware

Имя файла: clipmate 5206.exe

Эта прога работает вместе с Windows Clipboard, довольно успешно борясь с хроническим склерозом последнего. Для этого ClipMate постоянно отлавливает всю инфу, которая попадает в этот «буфер обмена» и бережно помещает ее в свою базу данных. И хотя порой размеры этой базы могут достигать весьма внушительных размеров, поиск нужного тебе в данный момент куска информации это не затрудняет — все захваченные данные ClipMate хранит в хорошо просматриваемом виде. Выбираешь нужную тебе запись, и она тут же перемещается в «буфер обмена» — бери и пользуйся. Все захваченные данные легко можно упорядочить, просто распихав их по разным разделам в самой ClipMate. Ты можешь даже редактировать тексты и обрывки веб-страниц — прога имеет встроенный text/HTML редактора. Можно даже склеивать различные записи между собой. И в любой момент выделенные записи из любого раздела могут быть сброшены на винч. Так что ClipMate не только расширяет возможности стандартного «буфера обмена», а еще и предлагает новый очень быстрый и простой способ сбора информации. Ну, и самое главное — ClipMate не достает тебя своими наворотами. Ты работаешь с «буфером обмена» как обычно, а в окошко ClipMate лезешь только тогда, когда тебе действительно надо.


Спецвыпуск Хакер, номер #006, стр. 006-096-27, ШАРОWAREZ

ШАРОWAREZ

Спецвыпуск Хакер, номер #006, стр. 006-096-27

Search Maker Pro v 2.0.3

Windows 9x/NT4/2k

Size: 2383 Kb

Shareware

Имя файла: searchmp21.zip

Я раньше думал, что без использования скриптов оборудовать веб-сайт поисковым механизмом невозможно. Я ошибался. Оказывается с помощью программы Search Maker Pro поисковик можно присобачить к любому сайту. Причем — без особого труда! Для этого достаточно натравить Search Maker Pro на свой веб сайт, или, скажем, на набор веб-страничек, сваленных в каком-нибудь каталоге на твоем винче, а затем правдиво отвечать на вопросы Мастера. И через несколько минут у тебя на руках окажется один единственный HTML-файл, включающий в себя индекс ( куски текста, с указаниями, откуда именно они были выдраны:) и JavaScript-код, который умеет этот индекс лопатить. Достаточно пристроить этот файл на свой веб-сервер, и вот уже у тебя есть реальный поисковый механизм, который понимает запросы на русском языке и выдает очень приятные и развернутые ответы (см. скриншот:). Подогнать его дизайн, под дизайн твоего сайта труда не составит. А поскольку этот поисковик не использует скрипты, то он будет работать, даже если ты запишешь свой сайт на CD.

Brain (Natrificial) v1.74

Windows 9x/NT4/2k

Size: 2272 Kb

Shareware

Имя файла: brain1.74.exe

Графический органайзер по кличке «Мозг». Как и положено Мозгу, он оперирует «мыслями». Правда, под этим термином скрываются более осязаемые вещи: документы, таблицы, графические изображения, ярлычки, или веб-страницы. Но фишка в том, что все «мысли» в Brain-е являются еще и узлами логической сети, связи между которыми ты задаешь сам, ассоциативно. В центре главного окна программы всегда отображается текущая «мысль»-узел и все ее связи. Переход от узла к узлу сопровождается анимацией и выглядит весьма впечатляюще. Работа с этой программой, не смотря на столь пугающее описание, проста и приятна. К примеру, я взял и мышкой вытянул из узла «Работа» новую связь в никуда. Тут же Brain создал новый узел, который я обозвал «Хакером». Одним кликом мышки я сделал этот узел текущим, после чего перетащил в окно программы текстовый файл с телефоном и другими личными данными моего приятеля Ядовитого. И вот уже к «Хакеру» прицепилась первая мысля — «2poisоnS». Но ведь Ядовитый — не только мой коллега, он еще и мой друг! Поэтому я дополнительно связываю узел «2poisonS» с узлом из другой ветви «Личное» — «Друзья». Поверь мне, не каждый органайзер позволит так вольно обращаться с хранящимися в нем данными. Так что мое «итого» по этой проге звучит так: отличная реализация оригинальной концепции пользовательского интерфейса, отягощенная тучей дополнительных наворотов, о которых у меня просто нет никакой возможности тебе рассказать. Must have, однозначно!


Спецвыпуск Хакер, номер #006, стр. 006-096-28, ШАРОWAREZ

ШАРОWAREZ

Спецвыпуск Хакер, номер #006, стр. 006-096-28

BrainWave Generator v3.1

Windows 9x/NT4/2k

Size: 1177 Kb

Shareware

Имя фа

йла: bwgen31.exe

Я не думаю, что наш журнал может заинтересовать взрослого дядю в слюнявчике, который больше всего любит мазать манной кашей соседскую кошку или надувать пузыри из соплей. Однако и нормальный чел может в определенные моменты своей жизни испытывать досадное угасание мозговой активности. Вот, к примеру, один мой приятель постоянно превращается в идиота, стоит ему только заметить девчонку покрасивее. Поэтому, когда я на днях наткнулся на прогу, которая занимается стимуляцией мозговой активности, я решил на всякий случай сунуть ее в свою рубрику. Авось кому она и пригодится! А теперь — технические детали. Итак: стимуляция головного мозга осуществляется с помощью специально генерируемых звуков, а в случаи частичной глухоты пациента — с привлечением дополнительных визуальных эффектов в виде мигающего разными цветами экрана. Кроме примитивного ускорения мыслительных процессов, BrainWave Generator (по словам разработчиков:) способствует расслаблению человека, оказывает снотворное действие, борется с похмельем, и облегчает головные боли. Тип требуемого воздействия задается в настройках программы, выбором звуковой схемы. В комплекте с программой поставляется более 20-ти таких схем на все случаи жизни. Тем же, на кого чужие заготовки требуемого воздействия не окажут, BrainWave Generator предлагает воспользоваться встроенным в него редактором, позволяющим создавать «мозговые волны» на любой вкус, слух, и цвет. Нет, ты только подумай, а вдруг разработчики этой не врут?!! Только представь себе: пять минут гудения и свиста и ты — ГЕНИЙ! Ну разве это не замечательно?!! :)

Stamp v0.51

Windows 9x/NT4/2k

Size: 82 Kb

Freeware

Имя файла: stamp062. zip

Не у каждой проги есть свой девиз, но вот у Stamp-а он имеется, и звучит так: «Замути печать и живи спокойно!». Первая часть этого высказывания легко объяснима, поскольку с помощью Stamp-а действительно можно без труда «замутить», или попросту говоря — подделать практически любую круглую печать. Для второй же части девиза такого же четкого объяснения мне найти не удалось. Нет, ну, в самом деле! Нельзя же понимать слова «и живи спокойно», как призыв к использованию сделанных в Stamp-е изображений-оттисков для массового изготовления фальшивых больничных листов?!! Хотя, если подумать... Печати-то у этой проги получаются почти как настоящие!

Stamp создает печати с текстами как на русском, так и на английском. В проге присутствует три шрифта: Arial, Times, Courier. Размер букв задается. Текст выводится как справа налево, так и наоборот. В центре печати может быть помещен любой рисунок в формате BMP, а в комплекте уже есть готовые изображения гербов России и Украины. Если вместо рисунка в центре должна быть какая-нибудь надпись — тоже без проблем. Цвет готовой печати можно подкорректировать, дабы он более походил на настоящий. Для этой же цели, изображение можно даже слегка смазать. Хотя, чего я тебе тут объясняю?!! Запусти файл DEMO.BAT при первой встрече с этой прогой, и она сама тебе все расскажет и покажет.


Спецвыпуск Хакер, номер #006, стр. 006-125-1, Так говорил Заратустра

Так говорил Заратустра

Спецвыпуск Хакер, номер #006, стр. 006-125-1

Клим Собакин-Звездуницкий, известный звездочет и книгочей Ея императорского Величества

ОВЕН (21 марта - 20 апреля)

Типичные представители: Centner

Стройными рядами Овны первыми войдут в очередной долгожданный Миллениум. И будет им счастье в паре с необыкновенной легкостью бытия. Овны будут замечены в попытках обогнать всех остальных. Гнать Овны умеют и любят. Овнам, то есть баранам, нужно опасаться всеразличных ворот. Ворота их просто-таки выводят из себя и приковывают к себе пристальные овновьи взгляды. Овны постоянно производят взрывоопасное впечатление на окружающих, они вулканоподобны и центростремительны. Лучший подарок для Овна - ящик просроченного динамита и свежие драйвера системы Detonator для Riva TNT.

Профессиональное заболевание: пиромания.

ТЕЛЕЦ (21 апреля - 21 мая)

Типичные представители: MOOF

Телец, и тут нет ничего удивительного, наступивший Миллениум пропустит из-за того, что будет, как обычно, телиться. Телиться он будет не один, а в компании со Стрельцом. Телец обладает одним очень интересным даром. То есть недаром. В общем, он умеет притягивать деньги и вещи, чревовещать и вызывать местных духов в лице Букарры. Не умеющие вызывать - научатся. Сила Тельца в его работоспособности и тяге к земле, природе. Так что астрологи в моем лице рекомендуют Тельцам работать поменьше и не употреблять спиртных напитков в период посевной, уборочной, а так же во время уборки прилегающей территории. В паре со Стрельцом Телец получает несколько бонусов: он может кастить файрболы, танцевать джигу и одновременно правдоподобно кричать чибисом. Как говорят в таких случаях - Телец да Стрелец, вот и сказочке конец!

Профессиональное заболевание: общая хроническая медлительность.

БЛИЗНЕЦЫ (22 мая - 21 июня)

Типичные представители: SideX

Близнецы больше известны в России как Однофамильцы. Особенно удачным Новый год будет для Однояйцевых Близнецов. Генная инженерия, шагающая семимильными шагами по планете, наконец-то избавит Однояйцевых Близнецов от одного яйца на двоих. Близнецы будут основательно пересматривать все свои привычки. В частности - здорово увеличат количество времени, проводимого во сне на рабочем месте. Стихия Близнецов - пиво. Близнецы-Однофамильцы частенько питают нездоровую, подчас однополую любовь к Рыбе и Ракам. Все что касается морепродуктов вообще - является своеобразным допингом для Близнецов.

Бонус Близнецов - скиллы пофигизм и боевая невменяемость.

Профессиональное заболевание: яйцеголовость и виртуальная отечность.

РАК (22 июня - 23 июля)

Типичные представители: zLOB, TERRANO

Раку в Новом году суждено, наконец-то, свистнуть. Не присвистнуть, а именно свистнуть, да так, что у многих уши позакладывает. Но ничто не дается Раку так дешево, как хотелось бы, и, к тому же все, кто примчится на посвист Рака, останутся без последних штанов. Раку нужно держаться Рыбы, недаром говорят, что на безрыбье и Рак Рыба. Рак никогда не сдается, но частенько отступает. Раки - отличные рассказчики. Если не прерывать их беседу, то Раки насвистят вам такого, что ни в сказке сказать...


Спецвыпуск Хакер, номер #006, стр. 006-125-2, Так говорил Заратустра

Так говорил Заратустра

Спецвыпуск Хакер, номер #006, стр. 006-125-2

Бонусы Раков неопределенны и расплывчаты. Классификации поддаются слабо, поэтому здесь рассмотрены не будут.

Профессиональное заболевание: посвист молодецкий и бытовой вылуп глаз.

ЛЕВ (24 июля - 23 августа)

Типичные представители: CuTTer, KurT, Epsilon, Horrific

Ну, тут все понятно. Кто Лев, тот и прав. Несгибаемый, неподкупный, пламенный борец за обыкновенные денежные знаки, Лев проявляет все свои самые положительные качества в момент, когда близкие просят одолжить "пару рупий". Льву присуща необыкновенная щедрость в день получения зарплат и единовременных выплат.

Бонус Льва - правдолюбие и предрасположенность к вечной молодости.

Профессиональное заболевание: точных данных нет, замечена склонность к наполеономании.

ДЕВА (24 августа - 23 сентября)

Типичные представители: 2poisonS, Даниил Шеповалов, ALEXX

Год у Дев будет легким и незамысловатым. Играючи они будут произносить магические слова: "Курица не птица...". Девам нужно как можно быстрее подготовить к длительной эксплуатации все наличные телеги и сани. Основная проблема Девы - отсутствие чувства меры в уходе за своим Х. За хозяйством, в смысле. Девы незаменимы в момент, когда нужно организовать массовые беспорядки, акции неповиновения и локальные крестьянские бунты. Все Девы - величайшие гуманисты всех времен и народов. Доброта Дев безгранична в разумных пределах. Бонус Дев - сногсшибательное чувство юмора и pofigizm resistance.

Профессиональное заболевание: хронический педантизм на фоне общей запасливости.

ВЕСЫ (24 сентября - 23 октября)

Типичные представители: Jakie

Весы, они и в Африке весы. Продуманность, взвешенность решений никак не мешает Весам становиться организаторами совершенно безобразных хулиганских выходок, оканчивающихся милицейской дракой и общественным порицанием. Весам свойственна склонность к проведению массовых сексуальных игр на рабочем месте. Весы обладают хорошим вкусом. И сожрать могут изрядно.

Могут достичь значительных успехов в искусстве, дизайне, моде. А могут и не достичь. Ну, например, если обламывает достигать значительных успехов, можно остановиться на незначительных и как следует все взвесить. Весы склонны к бесцельному раскачиванию в момент осмысления и понимания величия всего происходящего. Стихия Весов - тестирование разнообразного малозначительного компьютерного железа и оценка полученных результатов. Бонус Весов - тщательность и выносливость.

Профессиональное заболевание: недосып и перевес.

СКОРПИОН (24 октября - 22 ноября)

Типичные представители: SINtez, M.J.Ash

Скорпиону в новом тысячелетии незнакомые добрые люди подарят новый Х. И с этим новым Х Скорпион окунется в невероятный водоворот событий. Скорпиону нужно опасаться женщин на деревянной ноге и беречь свой новый Х. Несмотря на выносливость Скорпиона, ему придется туго в этом году. Производители вино-водочных изделий и миловидные дамы - вот основные препятствия Скорпионов на пути к счастью. Скорпионам показаны экстремальные виды спорта - домино, шашки, преферанс. Самый подходящий для Скорпиона подарок - гипсовая настольная модель (под хохлому) будущего тестя с масштабе 1:4. Бонус Скорпиона - способность к непрерывной верстке.


Спецвыпуск Хакер, номер #006, стр. 006-125-3, Так говорил Заратустра

Так говорил Заратустра

Спецвыпуск Хакер, номер #006, стр. 006-125-3

Профессиональное заболевание: хвостизм пополам с прогрессирующей амнезией.

СТРЕЛЕЦ (23 ноября - 21 декабря)

Типичные представители: Mal

Для Стрельцов наступивший Новый год обещает быть трудным и сложным. Стрельцам призывного возраста будут постоянно, но последовательно сниться повестка, проводы, призывной пункт, присяга, дембель. Любимый фильм Стрельца - "ДМБ". Стрелец знаменит тем, что интересуется древними культами. Стрельцы склонны к длительным размышлениям на тему идентичности калибра обыкновенной сигареты и автомата Калашникова. Лучший друг Стрельца, как уже говорилось выше, Телец. Стрелец в паре с Тельцом немедленно приобретает новый скилл "Молодец", позволяющий с гордым выражением лица пройтись вокруг да около.

Лучший подарок для Стрельца - пулемет Максим и военно-морские трусы за рубль сорок.

Профессиональное заболевание: магическое косоглазие.

КОЗЕРОГ (22 декабря - 20 января)

Типичные представители: Доктор Добрянский, Торик

Козерог - реалист. Но только ранним утром и только наедине с самим собой. Козерог - любитель одиночества и не очень любит, когда всякие там Львы и Рыбы пристают с глупостями. Крендель, рожденный под этим знаком, восприимчив к всевозможным внушениям. Ему постоянно слышны посторонние (или потусторонние) голоса, бывают видения, дежа вю, так сказать. Козерог неустанно заботится о здоровье, как о своем, так и о чужом. Заботится до тех пор, пока предмет его забот не отбросит конёчки.

Сила Козерогов в уникальной способности мгновенно включать и прогревать сорокаваттные паяльники. Заполучив в свои руки любой доступный в данный момент электроприбор, Козерог получает бонус: удвоение выносливости и +60 процентов одиозности. Осциллограф в руках Козерога при данных обстоятельствах равносилен шестикратному употреблению спелла "Берсерк".

Профессиональное заболевание: электровелосипедизм.

ВОДОЛЕЙ (21 января - 19 февраля)

Типичные представители: Delta

Водолеи имеют по большей части гуманитарные интересы. В домашнем хозяйстве всему предпочитает ремонт самостоятельно сломанного нехитрого скарба. Водолей плохо переносит холод и шум. Холод! Руки прочь от Водолеев!

Водолеи тяготеют к использованию альтернативного программного обеспечения. В быту немногословны, но на собраниях жилищных комитетов получают несколько уникальных бонусов: публичная неустрашимость и термоядерное словоблудие.

Профессиональное заболевание: интернет-сомнамбулия, общий пингвинизм.

РЫБЫ (20 февраля - 20 марта)

Типичные представители: Холод

Рыбам нужно встречать новое тысячелетие во всеоружии. Любовь к беззащитным сиротам, безалкогольному пиву и хладоагрегатам может стать на пути к достижению долгожданного высшего образования. Рыбам категорически необходимо поддерживать дружеские контакты с Раками и пивзаводами. Рыбы - существа многословные, просто-таки болтуны. Пристают к окружающим с многочисленными неприличными предложениями, бурчат, напевают, периодически выкрикивают политически непродуманные лозунги а-ля "Рыбу - детям!" Рыбы постоянно отпускают разные шуточки, да и сами шутку понимают быстро - правда, при этом не обязательно правильно. Лучший подарок для Рыбы - кошка отечественная малогабаритная.


Спецвыпуск Хакер, номер #006, стр. 006-125-4, Так говорил Заратустра

Так говорил Заратустра

Спецвыпуск Хакер, номер #006, стр. 006-125-4

Профессиональное заболевание: морская болезнь и водобоязнь.