Спецвыпуск Хакера, Содержание номера # 005

ЖУРНАЛ ХАКЕР
Cover 005 |
Статья | Стр.
Сайты о Линуксе | 004
ФАК по Юниксам | 010
Парад десктопов | 014
ОБИТАТЕЛИ NIX'ОВ | 018
The Gimp | 022
NIX'ОИДНЫЕ ИГРУШКИ | 026
За что я люблю Юникс | 028
За что я ненавижу Линукс!!! | 029
ТЕКСТОВЫЙ РЕДАКТОР ДЛЯ NIX'ОИДА | 030
Сага о пингвинах | 033
Основные команды операционной системы UNIX | 040
Оптимизация Линукса | 044
Софт для Линукса | 048
Ставим Линукс | 056
Логгеры Траффика - узнай своих врагов в лицо | 062
LiteSTEP: совсем как юних | 066
Обзор дистрибутивов Linux | 070
Поднятие Инета из-под юникса | 073
Настройка сети под линукс | 076
Игры с пингвинами | 078
Пингвин-IRC | 082
Снос Linux'a (как это сделать грамотно) | 084
Староффис, и с чем его едят | 086
Firewall под Юниксами - настройка и использование | 088
Mp3-зация юниксоида | 092
Майлеры под Никсы | 094
Боевой софт под Юникс | 096
Два слова о юниксоидах | 099
Вяленый пингвин, или пингвиньи архиваторы | 100
Дерево, на котором живут Пингвины | 104
UNIX: книжный обзор | 106
ЧТО ТАКОЕ UNIX? | 108
10 мифов о линукс | 110


Спецвыпуск Хакера, номер #005, стр. 005-004-1, Сайты о линуксе

Сайты о линуксе

Спецвыпуск Хакера, номер #005, стр. 005-004-1

MOOF (MOOF@xakep.ru ; http://moof.da.ru)

Решил, значит, линукс поставить? Ну, молодец, раз решил. Ну, мы тебе, конечно, в этом поможем. Прежде чем ставить - походи по сайтам, почитай документацию, скачай кой-какой софт. Чтение документации помогает очень часто избежать подводных граблей, на которые наткнулись другие. А где достать документацию и просто разную полезную информацию, я тебе сейчас... это... поведаю, во.

Linux.ru

Итак, передо мной браузер, и задание сделать обзор сайтов по линуксу. Первый адрес, который приходит мне в голову, - это "Linux.ru". Что же, поехали.

"Научно-популярный сервер о линуксе" встретил меня новостями. Новости на сайтах о линуксе - это вообще отдельная тема, о которой стоит упомянуть особо. Почти каждый сайт про эту операционную систему считает своим долгом показать посетителям как можно больше новостей из пингвиньего мира. Это, наверное, считается дурным тоном, если на сайте нет колонки ньюсов. Причем, новостные мессаги самые разнообразные и не всегда напрямую связаны с линуксом. А создатели linux.ru сайта пошли еще дальше и дали возможность пользователям еще и обсуждать эти самые новости. Если ты любитель пофлеймовать на тему линукс vs виндовс или apache vs iis, то этот сайт - то, что тебе нужно ;).

Далее вкратце по разделам. Раздел "Weekly" содержит множество обзоров и текстов на тему крутости линукса и отстойности виндов. Текстовики достаточно интересные и полезные не только начинающим, но и матерым линуксоидам.

Прочитав парочку статей и поняв, что линукс это рулез, а все остальное - отстой, я перешел к разделу "Документация". Он встретил меня огромным количеством ФАКов, хау-ту и прочих манов. Причем часть из них переведена на язык Пушкина, Лермонтова и Холода ;).

В разделе "Software", как ты можешь догадаться, лежит софт для линукса, предварительно разложенный в несколько категорий. Нужно новое ядро? Пожалуйста. Нужен эмулятор? Качай - не хочу.

Если ты кул-админ и решил подумать о безопасности, то раздел "Безопасность" - специально для тебя. Однако многие документы там на буржуйском языке. И если ты его (язык) не знаешь, то делать там тебе почти нечего. Хотя пообсуждать можно и так.

И вот, наконец, мой любимый раздел "Форум" aka "Конференция". Это как раз то место, где ты можешь задать любой (относящийся к линуксу, а не "где накачать халявного порно?") вопрос и можешь быть уверенным, что тебе на него ответят.

Итого:

Отличный сайт, пойдет как для начинающего пользователя, так и для профессионала. Есть все что нужно, но не слишком много. Приятный дизайн, удобная навигация, наличие возможности поиска по серверу.

Однако попробуй посмотреть его в lynx ;).

Linux.org.ru

Следующий сайт, который попал в окно моего браузера, - это "Linux.org.ru - Русская Информация об ОС Linux". И, как было замечено выше, опять новости. Опять возможность оставлять свои комментарии к новостям и, что порадовало, "Список наиболее обсуждаемых тем месяца". Глядя на этот список, можно понять, зачем же все-таки нужна ОС линукс и какие проблемы волнуют пользователей этой операционки больше всего.


Спецвыпуск Хакера, номер #005, стр. 005-004-2, Сайты о линуксе

Сайты о линуксе

Спецвыпуск Хакера, номер #005, стр. 005-004-2

Если глянуть чуть ниже, то обнаружится "Галерея десктопов". Манера подсматривать за другими и выставлять свои рабочие столы всем напоказ появилась очень давно, точнее - после выхода MSPlus для Windows 95. Тогда это было последним писком моды: мериться крутостью и красивостью своих рабочих столов. Сейчас нечто похожее наблюдается и с линуксом. Множество скриншотов, которые не попали на первую страницу, лежат в разделе "Галерея".

Черный фон сайта поначалу меня сильно огорчил, но оказалось, что существует несколько различных цветовых схем, и каждый может выбрать наиболее близкое для себя решение. Рекомендую тебе тему "white2", хотя дефолтная схема выглядит наиболее проработанной и удобной. Ну да пингвин с ним, с дизайном. Посмотрим, что тут есть еще.

Раздел "О Linux" содержит маленький текстик, поясняющий, что же все-таки такое линукс и с чем его едят. Кроме этого, в разделе нету ничего путевого, поэтому я быстренько перешел в раздел "Форум". Вот это действительно хорошо: форум разделен на несколько групп по интересам. Проблемы с установкой - иди в "Linux Install", интересуешься безопасностью - дуй в раздел "Security", ну а если любишь поиграть - для тебя раздел "Games".

В разделе "Дистрибутивы" ты можешь прочитать коротенькое резюме по каждому дистрибутиву и выбрать то, что тебе покажется ближе. Тут представлены все наиболее популярные дистрибутивы. Ну а если твоего линукса не оказалось в этом списке, ты можешь его добавить.

Для чего предназначен раздел "Документация", я объяснять не буду - и так все понятно. Скажу лишь, что вся документация рассортирована по разделам и представлена исключительно на русском (рулез). Адреса англоязычных документов и других ресурсов о линуксе лежат, как ты можешь догадаться, в разделе "Ссылки".

Итого:

Неплохой сайт для начинающих пользователей. Наличие тематических форумов и неплохой контент позволяют надеяться на светлое будущее этого сайта.

www.linuxcenter.ru

Совершенно свеженький "Путеводитель в мире Linux" был открыт в очередном окне моего браузера. Сразу бросается в глаза дизайн сайта. Видно, что над ним трудились профессионалы. Причем поработали неплохо.

Что еще порадовало - так это отсутствие длинной колонки новостей, как на остальных сайтах, и наличие лишь Одной Новости. Кроме новостей и статей о линуксе, на сайте есть он-лайн магазин, в котором всегда можно купить последние книги о линуксе и дистрибутивы любимой ОС. Кроме пингвинчиков, на сайте рассматриваются чертики (BSD) и вообще - все *nix системы в целом.

Но самое главное, что есть на этом сайте, - "Виртуальная энциклопедия Linux". Это постоянно пополняющийся архив информации. Будет интересен начинающим и продвинутым пользователям, а вот профессионалы вряд ли найдут что-то новое для себя.

Итого:

Такое впечатление, что создатели решили заработать на беспомощности новичков, продавая им книги и завлекая в свою партнерскую программу. Однако, несмотря на это, энциклопедия выглядит достаточно прилично.

Linux.ru.net

Что это за сайт, становится понятно сразу из его названия: "Российский Информационный Сервер для начинающих и опытных пользователей ОС Linux". И вот сайт с таким нешуточным названием встречает нас очередной колонкой с заголовками новостей. Конечно, тут же есть и опросы, ссылки на форум и скриншоты рабочих столов. Это сразу мне напомнило сайт Linux.org.ru. Однако дизайн и представление информации на этом сайте стоит на ступень выше прочих.


Спецвыпуск Хакера, номер #005, стр. 005-004-3, Сайты о линуксе

Сайты о линуксе

Спецвыпуск Хакера, номер #005, стр. 005-004-3

Раздел "Библиотека" содержит документацию по линуксу. Но самой документации почему-то очень мало. А в разделе "Софт" софта не оказалось совсем. Кроме этого, пустым оказался раздел "Энциклопедия".

За что стоит любить этот сайт - так за раздел "Настройки". Только авторы этого сайта подумали о пользователях Lynx'a. Специально для них можно убрать всю графику (и баннеры тоже!) и наслаждаться голым текстом.

Итого:

К сожалению, рассматривать пока стоит только как сайт новостей, поскольку все остальные разделы либо еще не готовы, либо содержат такое мизерное количество информации, что не стоит даже терять время, просматривая ее.

Очень порадовала возможность настроить вид сайта "под себя".

www.linuxrsp.ru

"Linux RSP Web Site. Все об операционной системе Linux на русском языке." - вот так просто и незатейливо называется очередной сайт моего обзора. Обычная для линукс-сайтов колонка новостей (кроме собственно новостей, содержит анонсы различных статей линукс-тематики). Надо отметить, что большинство аналитических (и не только) статей на русском языке сперва появляются именно на этом сайте и лишь потом на других.

Набор разделов опять же стандартный, ставший нам с тобой привычным: документация, ссылки, форум. На них я останавливаться не буду, скажу лишь, что раздел "Статьи" содержит множество действительно интересных и полезных статей, которые стоит прочесть (если не все, то хотя бы часть).

В левой колонке, кроме стандартного голосования, есть список новинок среди популярного софта. Причем ссылки ведут не на какой-нибудь каталог программ для линукса, а непосредственно на сайты производителей этого софта.

У сайта есть рассылка, и если ты не любишь каждый день заходить на один и тот же сервак, чтобы узнать, что новенького появилось за это время, подпишись - и будешь получать информацию о последних обновлениях голубиной почтой.

Итого:

Интересный аналитический сайт. Будет интересен абсолютно всем, даже поклонникам форточек.

www.opennet.ru

"Проект OpenNet - все о бесплатных unix системах..." - действительно, все о Linux и всевозможных BSD. Все новости о *nix вынесены в отдельный раздел, что, на мой взгляд, выгодно отличает этот сайт от всех остальных. Основное место тут занимают каталоги программного обеспечения, документация, статьи и ссылки на всевозможные сайты. Не обошлось тут без конференции и чата. Наверное, самый большой по объему полезной информации сервер, вот только медленный какой-то и не слишком красивый.

Сайт регулярно обновляется и пополняется новыми материалами, что, несомненно, не может не радовать. Хорошо, что все-таки есть такие проекты, которые не только живут, но и развиваются.


Спецвыпуск Хакера, номер #005, стр. 005-004-4, Сайты о линуксе

Сайты о линуксе

Спецвыпуск Хакера, номер #005, стр. 005-004-4

В целом получился большой качественный портал, полностью посвященный всевозможным *никсам. Начинать свое путешествие я бы советовал именно с него. Ну а если не начинать, то заканчивать точно ;).

Итого:

Это именно тот сайт, на котором можно найти практически все, что надо для успешной работы с любой *никс системой, в том числе и линуксом.

LinuxNews.ru

"Все о Linux по-русски!". Сайт о линуксе из серии "Все об ОС по-русски!". Стандартный джентльменский набор для сайтов о линуксе: новости, документация, общение. Неплохие новости, русские доки... Эту самую факин мануалку я долго и упорно читал, и, ты знаешь, - мне понравилось :). Есть рассылка ньюсов. Хорошая.

Итого:

Рассылка - вот что главное у этого сайта. Подписавшись, будешь в курсе основных новостей. А так... ничего особенного.

http://ru.linuxstart.com

"Linux Start. Отсюда начинается ваше Linux-путешествие!". Ну, для нас с тобой оно не начинается, а продолжается. LinuxStart - это русский перевод аналогичного англоязычного сервера. Что же тут можно найти? Во-первых, это каталог (по виду очень похож на list.ru, но это мелочи ;)) сайтов, посвященных линуксу. Во-вторых, это поисковая система. В-третьих, бесплатная электронная почта для любителей иметь кучу почтовых адресов. Ну а самое главное - это наличие пошагового учебника по линуксу для новичков.

Естественно, не обошлось без новостей и событий мира линукс. А для любителей поболтать есть чат.

Итого:

Неплохой каталог сайтов по линуксу (конечно, адреса большинства этих сайтов можно найти в разделах "Ссылки", но все равно приятно, когда все собрано в одном месте).

linuxdoc.chat.ru

Сайт "О Линуксе по-русски" полностью оправдывает свое название. На нем действительно можно найти тонны документации по этой ОС. Причем все документы на русском языке и рассортированы по категориям. Так что проблем с поиском необходимого RTFM не будет :). Вот, собственно, и все, что есть на этом сайте: документация.

Итого:

Просто сайт с документацией.

http://www.iplabs.ru/Linux/

"Software is like sex it's better when it's free. Linus Torvalds". Вот так! Это тебе не пиво через соломинку пить. А сайт этот принадлежит одному из разработчиков русифицированных версий всевозможных разновидностей линуксов (Debian, SuSE, Mandrake, Black Cat etc...). На сервере, кроме новостей, относящихся к русифицированным дистрибутивам, есть документация и софт для линукса.

Ну и, конечно, ответ на извечный вопрос: "Почему линукс?".

Итого:

Если еще не решил, какой дистрибутив ставить, зайди сюда - может чего понравится. Сразу вспомнилась поговорка: "лучший дистрибутив - это тот дистрибутив, который стоит у ближайшего гуру".

http://linux.webclub.ru

Новости тут особенные: специфические софтовые. Полазав по сайту, я обнаружил, что в разделе "Архив" много полезной и интересной документации. Наличие форума также является достоинством сервака. Кроме всего прочего, на сайте есть каталог софта, который лежит тут же.

Итого:

Еще один неплохой сайт про это. В смысле - про линукс. Ничего особенного.


Спецвыпуск Хакера, номер #005, стр. 005-004-5, Сайты о линуксе

Сайты о линуксе

Спецвыпуск Хакера, номер #005, стр. 005-004-5

www.apache.ru

Рассказывая о сайтах, посвященных линуксу, я не мог не упомянуть о сайте, посвященном такому веб-серверу, как Апаче. Если ты из своей машины решил сделать веб-сервер, то этот сайт специально для тебя. А если тебе просто интересно, как правильно настроить сервер и потренироваться в его хаке, этот сайт тебе тоже будет полезен. Большое количество документации и различных статей удачно соседствуют.

Итого:

Рекомендуется всем, кто интересуется Интернетом, серверами и прочими браузерами с майлерами.

unixware.ru

"UnixWare - для тех, у кого есть компьютер". Наконец-то бедные пользователи линукса дождались появления нормального русскоязычного каталога программного обеспечения для этой самой ОС. Первое, что бросается в глаза, это дизайн - он, прямо так скажем, не для lynx'a. Скорее, для горячо любимого юниксоидами IE, хотя в Netscape сайт тоже смотрится очень даже неплохо. И правильно: кто серфит с помощью lynx'a, тот сам может написать любой софт! :)

Возвращаясь к контенту: все программы, как подобает настоящему каталогу, разделены на группы. Среди этих групп запутаться достаточно сложно, даже если очень захотеть. Все предельно просто и понятно. Кроме стандартных групп по тематике программ, можно посмотреть несколько последних добавленных или самых популярных прог на сайте.

На лицевой странице три раздела: программа недели, новые программы и лидеры за 10 дней. И опять же несомненным плюсом я считаю наличие поиска по сайту.

Все проги подробно описаны, многие имеют скриншоты. Некоторые особо популярные софтины можно скачать прямо с сервера unixware, что очень положительно сказывается на скорости скачивания.

Итого:

Если нужен софт для линукса, поиск стоит начинать отсюда.

www.freshmeat.net

Раз мы уж заговорили о софте, то нельзя не рассказать об этом сайте. Freshmeat - поистине король всех софтовых сайтов для *никсов. Тут есть все: начиная с простеньких Perl-скриптов и заканчивая навороченными приложениями для X-Window. Все новинки сперва появляются именно тут. Регулярные обновления в сочетании с простым текстовым дизайном делают сайт очень привлекательным. Ко всем программам есть описания и еще куча таких фишек, как лицензия, инфа об апдейтах етс. Есть одно "но": для того чтобы получить доступ ко всему огромному содержимому этого сервера, тебе придется зарегистрироваться. Не страшно, поверь мне, и стоит того :).

Из недостатков могу отметить очень большую первую страницу, которая долго грузится, потому что содержит полное описание всех последних добавленных программ, хотя можно было бы обойтись и названиями с коротенькими описаниями. Ну да ладно, сайт отличный, и эти маленькие недочеты, на мой взгляд, его совсем не портят.

Сайт, естественно, весь на буржуйском, но, как я уже писал, прост и понятен каждому.

Итого:

Легендарный сайт с софтом для *никсов. Если тебе нужна какая-либо экзотическая программа а ее нигде нет, и ты уже собираешься писать ее сам, зайди на Freshmeat - тут ты ее точно найдешь.

www.themes.org

Как следует из адреса следующего сайта нашего обзора, он целиком посвящен темам рабочего стола, или, если говорить по-другому, - скинам. Тут есть скины практически для всех популярных менеджеров: начиная Afterstep'ом и заканчивая wm'ом.


Спецвыпуск Хакера, номер #005, стр. 005-004-6, Сайты о линуксе

Сайты о линуксе

Спецвыпуск Хакера, номер #005, стр. 005-004-6

Сайт сделан достаточно приятно, и лазать по нему - одно удовольствие. К сожалению, язык сайта английский, но все чрезвычайно просто и понятно.

Итого:

Если хочешь, чтобы твой линукс выглядел по-особенному, то этот сайт специально для тебя.

www.linux.com

Чем дальше в лес, тем партизаны жирнее. Это я про сайты: чем ближе мы подходим к концу обзора, тем круче становятся ресурсы. Linux.com, я думаю, один из самых популярных англоязычных ресурсов на тему пингвинчиков. Тут есть все: чат, документация, софт, ссылки - всего и не перечислить.

Жалко, что на русском нет такого портала, - взять бы и объединить все русскоязычные сайты по линуксу - вот тогда это была бы тема :).

Итого:

Что тут говорить: linux.com - и есть linux.com. Если дружишь с английским, то сайт может показаться тебе полезным. Если не дружишь - зайди так просто, ради интереса.

Естественно, это далеко не все сайты, посвященные никсам. Но для начала их вполне хватит (и даже будет много). А если чего понадобится - заходишь на altavista и пишешь в строке для поиска слово "linux". На момент написания этой статьи поисковик находил 9,818,413 ссылок.

Удачи и поменьше тебе "designed for IE" сайтов на пути :).


Спецвыпуск Хакера, номер #005, стр. 005-010-1, ФАК по Юниксам

ФАК по Юниксам

Спецвыпуск Хакера, номер #005, стр. 005-010-1

Noah (noah@inbox.ru)

Delta (delta@xakep.ru)

Avalanche (kolyan@rnc.ru)

Да! Вопросы, вопросы, вопросы. По-другому не бывает. Когда в твоей жизни появляется новая девушка, то возникает естественный вопрос - "какая у нее грудь на ощупь?", а когда появляется новая операционная система - вопросы, вроде "я только что все сделал, как мне все вернуть обратно?" и "пустите меня, где тут выход?". Короче: вопросы - это всегда нормально. Вопросы разные: простые, сложные, не очень сложные... Вот, короче, и знакомство с новой осью у тебя началось с вопросов. Задавай, пингвиныч! А мы, соответственно, попробуем тебе поотвечать.

1. Что такое shell?

Дословно shell переводится как "оболочка". Это программа, которая принимает команды юзера из командной строки, преобразует их в понятную для операционки форму и выводит ответ операционки в понятной для юзера форме :). Другое название shell - командный интерпретатор. Вот несколько наиболее юзабельных shell'ов: bash, sh, csh, tcsh, psh. Отличаются они тем, что у каждой shell свой язык для написания скриптов (у родственных шеллов они почти одинаковые, как у bash и sh).

Еще они отличаются по функциональности: некоторые позволяют редактировать вид командной строки. Почти у каждого шелла есть свои встроенные переменные. Если не знаешь, какой у тебя шелл, вводи команду echo $SHELL. Если хочешь поменять свой дефолтовый шелл, вводи команду chsh.

2. Что такое shell-скрипт?

Скрипт шелла (или сценарий) - это интерпретируемая прога, написанная на языке того или иного шелла. Вспомни перл: там тоже исходник не компилируется, а интерпретируется. В нашем случае в роли интерпретатора выступает шелл. Шелл-языки обычно обладают свойствами обычных структурно-ориентированных языков (си, паскаль и т.п.). То есть в них имеются типичные структуры выбора (if), повторения (while). Например, язык шелла Csh очень похож на язык программирования C. Зачем это нужно? Ну, простой пример: тебе надо каждый раз при входе в систему набирать какую-нибудь команду - так вот, чтоб не настукивать ее руками, ты пишешь небольшой скрипт, ставишь ему атрибут выполняемого файла и прописываешь его в файле автозапуска.

3. Что такое консоль?

Консоль, или системная консоль, - это клава и монитор, подключенные непосредственно к машине, где установлена система (ось). Вот если ты себе поставил линуху, то твои клава и монитор вместе составляют консоль. Также консолью (консольным режимом) называют текстовый режим работы с nix-осями.

4. Что такое терминал?

Так как все nix'ы - многопользовательские оси, к одному компу можно подключить не только один монитор и одну клаву (консоль), а несколько, через последовательные порты. Вот эти вот пары мониторов и клав и называются терминалами. Не путать с системной консолью! Она одна, и за ней обычно восседает админ :).

5. А что такое виртуальные консоли?

Для удобства юзеров в nix'ах реализован механизм виртуальных консолей.

Это дает тебе следующие преимущества: ты можешь залогиниться в систему одним именем, начать какую-то работу, потом нажать Alt+F2, снова


Спецвыпуск Хакера, номер #005, стр. 005-010-2, ФАК по Юниксам

ФАК по Юниксам

Спецвыпуск Хакера, номер #005, стр. 005-010-2

залогиниться (можно под другим именем) и работать во второй консоли, в

то время как первая чем-то занята. Если хочешь вернуться обратно,

нажми Alt+F1. Нужна еще консоль? Ок, жми Alt+F3. По дефолту виртуальных

консолей четыре, но их количество можно увеличить до двенадцати.

6. Как и где хранятся пароли юзеров в nix'ах?

Сразу чувствуется, что ты - хацкер :). Раньше все пароли хранились в

знаменитом файле /etc/passwd в зашифрованном виде алгоритмом DES или (в более продвинутых системах - например, OpenBSD) в MD5 или Blowfish. Шифровка

производится так, что, не зная исходный пароль, расшифровать ее нельзя.

Пароль может быть найден только методом подбора - то есть слово из словаря

шифруется и сравнивается с шифрованным оригиналом. Для таких целей существует

множество программ: например, Crack или John The Ripper. А так как доступ к файлу /etc/passwd должен быть открыт для всех, взлом системы становится несложным занятием. Но сейчас в ответ появилась новая система хранения паролей - shadow. Теперь на большинстве nix'ов пароли хранятся в файле /ect/shadow (естественно, в зашифрованном виде, в *BSD /etc/master.passwd), доступ к которому закрыт всем, кроме рута. Получается, что для того чтобы получить пароль рута, нужен /etc/shadow, а для того чтобы получить /etc/shadow, нужен пароль рута. Опять замкнутый круг :). Ох уж эти админы.

7. Что такое X-Window System?

X-Window System почти всегда называют просто X. X - это графический интерфейс юзера. Реализует работу юзера с осью при помощи окошек, рабочего стола, мыша... Ну, сам подумай, какая в принципе разница, что ты делаешь: вводишь команды из командной строки или кликаешь мышом по окошкам и кнопочкам. Нет, ну понятно, что это удобнее, в этом вся соль, но, так или иначе, ты посылаешь оси какие-то

команды, а она тебе отвечает. В случае с командной строкой твои команды (в виде последовательности символов) обрабатывает шелл, а здесь их (в виде кликов на всякие графические объекты) обрабатывает X.

8. Что такое ядро (kernel)?

Ядро - это программа, собственно являющаяся осью. Что такое Линух вообще? Это ядро и куча всяких прог. Ты знал, что если урезать почти весь инструментарий, линуху можно установить на дискетку? Да, можно, там будет ядро и несколько мелких утилит. Тем не менее, основные функции будут работать.

9. Что такое модули ядра?

Модули - это куски кода, которые не являются частью ядра, но по мере

надобности могут в него загружаться. При этом перезагрузка не требуется. Иногда приходится устанавливать модуль, если ты хочешь включить поддержку нового устройства. Для загрузки нового модуля ядра используется команда insmod, для удаления модуля из ядра - rmmod, для вывода списка загруженных модулей - lsmod или cat /proc/modules.

10. Что значит "перекомпилировать ядро"?

Это значит добавить в ядро какой-то новый фрагмент кода. Надо взять исходники ядра (они поставляются в дистрибутиве) и откомпилировать их вместе с нужным тебе новым кодом. Можно просто проапгрейдить ядро, скачав свежие исходники и откомпилировав их.

11. Что такое дистрибутив?


Спецвыпуск Хакера, номер #005, стр. 005-010-3, ФАК по Юниксам

ФАК по Юниксам

Спецвыпуск Хакера, номер #005, стр. 005-010-3

Дистрибутив - это поставка линуха от той или иной программерской конторы. Они пишут прогу, которая облегчает процесс установки линухи на твоем компе, - инсталлятор. Еще они подбирают всякий полезный софт для тебя. А теперь представь, что было бы, если бы не было дистрибутивов. Тебе бы пришлось самому находить все дрова под свое железо, самому компилить у себя исходники ядра, самому скачивать всякий софт, самому настраивать X, самому настраивать все остальные параметры системы. Короче, ад.

12. Что такое bootloader?

Bootloader - это прога-загрузчик, которая обычно записывает себя в Master Boot Record (MBR) твоего жесткого диска. После загрузки компа BIOS передает управление тому, что записано в MBR, - а там как раз и сидит наша прога, которая в свою очередь спрашивает у тебя, какую из установленных на твоем компе осей ты хочешь загрузить. В зависимости от твоего ответа она передает управление дальше. Юзабельными bootloader'ами можно назвать LILO (супер! поставляется с линухой), loadlin (тоже идет с линухой), PM Boot (Partition Magik Boot).

13. Что такое виртуальные экраны?

Когда ты работаешь в X, ты можешь включить поддержку виртуальных экранов. Эта идея напоминает механизм виртуальных консолей, но, в отличие от последних, виртуальные экраны далеко не так полезны :(. Суть их состоит в том, что ты можешь переключаться между десктопами. Открыл какое-нибудь окно на одном десктопе и ушел на другой - новый. Но, млин, ведь на то и есть оконный режим, что ненужное пока окно можно свернуть на фиг. Зачем тогда эти экраны? Есть еще одна фича, которая лично меня бесит: если ты включишь поддержку "смежных краев", то при поднесении курсора к краю десктопа ты будешь перескакивать на соседний виртуальный экран. This sux! Напрягает конкретно!

14.Что значит "примонтировать/размонтировать"?

Примонтировать - подключить, сделать доступной файловую систему на

том-то физическом или логическом устройстве. Когда ты пихаешь дискетку

в флоповод или сюдюк в соответствующее место, или просто хочешь

полазать по виндовому разделу харда, ты должен примонтировать эти

устройства, чтоб получить доступ к файлам на них. Кекс, только не

говори, что ты не знал об этом! Делается это командой

mount <путь к файлу монтируемого устройства> <путь к директории, куда монтируется "чужая" файловая система>

Например:

mount /dev/hda1 /mnt/win

После этого у нас в папке /mnt/win аккурат появятся файлы первого раздела первого харда. Закончил работу с этими файлами? Неплохо бы ради приличия размонтировать устройство (например, сидюк тебе просто не удастся вытащить, пока ты его не размонтируешь :)) командой umount <путь к директории, куда замонтировано устройство>. Заметь! Именно umount, а не uNmount! Ну, чего погрустнел? Не бойся, тебе не придется все время вводить эти команды руками - существует много всяких прог, которые за тебя все сделают, ты только возьми дистрибутивчик посвежее.

15. Так, я прогрузился. А что, собственно, вообще такое - файловая система?

Файловая система - это определенный способ организации хранения информации на устройстве. Когда ты форматируешь диск, ты форматируешь его в какую-то файловую систему. Их много (FAT, NTFS, NFS, ext2 и т.д.), и это из-за того, что каждая ось предпочитает юзать свою собственную файловую систему. Но это не страшно - линуха поддерживает несколько файловых систем.


Спецвыпуск Хакера, номер #005, стр. 005-010-4, ФАК по Юниксам

ФАК по Юниксам

Спецвыпуск Хакера, номер #005, стр. 005-010-4

16. Я поставил себе Linux, но у меня не работает звук. Что делать?

Набери команду sndconfig. Там тебе дадут послушать всякие звучки и

спросят, слышал ли ты их. Очень часто бывает так, что никаких звучков

не слышно, но, тем не менее, если соврать и нажать "Ок", все начинает

работать. Если же ты используешь дистрибутив, не имеющий автоматической

программы конфигурации звука, скачай с linuxdoc.org файл Sound-HOWTO, где

имеется список поддерживаемых звуковых карт. Обычно для задействования

драйвера звуковой карты тебе требуется командой insmod загрузить драйвер

(поставляемый в виде модуля ядра) с аппаратными параметрами устройства.

17. Ладно, мне понравился X, но как мне вернуться обратно в консольный

режим?

Выбери в меню пункт log out, в появившемся окошке поставь галочку у

log out, и тебя выкинут в консоль. Расскажу тебе пару секретов: нажми

Ctrl+Alt+backspace... Тебя опять выкинуло в консоль! Это, якобы, аварийный выход из X, но многие его юзают все время :). Так удобнее.

Теперь вернись в X и нажми Ctrl+Alt+ (+/- на цифровой клаве). Типа, ты

переключился между графическими режимами. Юзай на здоровье - это не

опасно :), это тебе не мастдай.

18. Что такое демон (daemon)?

Демоном называется программа, работающая в фоновом режиме (background)

и не имеющая контрольного терминала. Резидентка, короче :0).

19. Что такое SUID/SGID программы?

SUID/SGID называются программы, которые изменяют эффективный идентификатор

пользователя/группы при выполнении. То есть, проще говоря, они позволяют тебе делать через себя какие-то действия, которые по умолчанию может делать только админ :0). Например, пингануть кого-нибудь: пинг как раз относится к программам такого класса.

20. Что такое эксплоит?

Допустим, один хацкер нашел дыру в вышеупомянутом демоне. Теперь он пишет небольшую прогу (эксплоит), которая реализует юзанье этой дыры. Делается это для того, чтобы облегчить и ускорить процесс взлома и чтобы другие хацкеры тоже могли поюзать найденную дырку. Эксплоиты обычно поставляются в виде исходников.

21. Что значит "залогиниться в систему"?

Это значит - ввести свои логин и пароль, после чего система проверяет их

правильность и впускает тебя. Все, теперь ты залогинился в систему :0).

22. Что такое extended partition?

Это логический раздел жесткого диска, содержащий другой логический раздел. Прямо как матрешки (медведи на улицах, мужики, выпивающие с медведями на улицах, балалайка, Boris Eltzin c балалайкой, выпивающий с мужиками и медведями на улицах). :)

23. Что такое своп (swap)?

Это раздел харда, который линуха создает для свопинга. То есть запустил

ты какое-нибудь приложение, но пока его не используешь. Если линухе не хватает оперативки - она аккуратно запишет это приложение на своп, а мозги, занимаемые им, освободит для других нужд. Потом, когда ты обратишься к этому приложению, она достанет его обратно в память.


Спецвыпуск Хакера, номер #005, стр. 005-010-5, ФАК по Юниксам

ФАК по Юниксам

Спецвыпуск Хакера, номер #005, стр. 005-010-5

24. Что такое диспетчер окон?

Диспетчер окон - это прога, работающая под X и занимающаяся рисованием окон (только наружной части - рамки, грубо говоря). Диспетчер окон отвечает за адекватную реакцию окон на закрывание, перетаскивание, уменьшение, растяжение. Все что происходит внутри окна, диспетчера не касается.

25. Что такое графическая среда (GNOME/KDE)?

Графическая среда организует рабочий стол: менюхи, панельки, бэкграунды, оформление стандартных кнопочек, менюшек... Только за окна не отвечает - это работа диспетчера. На самом деле диспетчер окон сам является частью графической среды, просто в nix'ах он реализован как отдельная программа.

26. Как сделать скриншот в X?

Что, решил похвастаться перед подругами :)?

Кнопарь PrintScreen в линухах не работает. Для этих целей существуют специальные проги, такие как kSnapshot (очень удобная). The Gimp тоже умеет делать скрины.

27. Мне надоела графическая среда GNOME. Как поменять на KDE или

AnаotherLevel ?

Смотри: идешь в меню KDE -> System -> Desktop Switching Tool. Дальше легко

разобраться. Эта утилитка меняет дефолтовую графическую среду.

28. Блин, что я наделал!!! Как вернуть GNOME обратно?

Хе-хе :). Забрел неведома куда? Не бойся, где бы ты там ни был - везде

найдется доступ к xTerm (или к другой проге, эмулирующей консоль).

Запускай его и вводи в нем команду switchdesk. Вот она, родная утилитка :).

29. Почему после изменения в *BSD /etc/master.passwd ничего не меняется?

На самом деле система читает данные не из /etc/master.passwd, а из /etc/pwd.db и /etc/spwd.db. Для того чтобы конвертировать /etc/master.passwd в нужный формат, тебе следует набрать следующее: pwd_mkdb /etc/master.passwd

30. Как мне получить доступ к cdrom'у?

Эх! Я же про монтирование рассказывал. Ну вот, смотри. Наберем: dmesg | grep CDROM. Ответ: hdc: CD-224E, ATAPI CDROM drive. Как видим, наш cdrom имеет название hdc. Теперь, чтобы примонтировать его, пишем 'mount /dev/hdc /mnt/cdrom, где /mnt/cdrom - папка, в которую ты хочешь примонтировать его.

31. Как подмонтировать vfat разделы, чтобы русские имена были видны?

В файл /etc/fstab добавим, например, такую строчку:

/dev/hda1 /mnt/win vfat noexec,rw,umask=002, codepage=866, iocharset=koi8-r,gid=100 0 0

Если же нужно на время примонтировать раздел, то введем следующую команду:

mount /dev/hda1 /mnt/win -t vfat -o codepage=866, iocharset=koi8-r

32. Надписи на консоли появляются так быстро, что я не успеваю все прочесть.

Как же прочесть их?

Это очень просто. Если ты хочешь прочесть информацию, выводимую при загрузке

системы, просто набери dmesg | more. Если же ты хочешь просто прочесть

то, что ушло за границы экрана, нажми комбинацию клавиш: Shift + PgUP/PgDn.

33. Как заставить работать pcmcia-устройства под Linux'ом?

Чтобы установить pcmcia-устройства, тебе необходимо получить последнюю

версию набора pcmcia-модулей для Linux с сайта http://pcmcia.sourceforge.org


Спецвыпуск Хакера, номер #005, стр. 005-010-6, ФАК по Юниксам

ФАК по Юниксам

Спецвыпуск Хакера, номер #005, стр. 005-010-6

и на всякий случай посмотреть, есть ли твое устройство в списке поддерживаемых. А вот если даже там его нет, то, возможно, оно... все равно будет работать :). Далее для установки выполни следующие операции:

разархивируй дистрибутив

make config (необходимо указать параметры конфигурации)

make all и make install

По умолчанию при загрузке менеджер PCMCIA-устройств запускается и пробует все драйверы. При необходимости можно отредактировать файл /etc/pcmcia, оставив только нужные драйверы.

34. Я забыл пароль root'a! Что делать?

Если ты работаешь в Open/Free/NetBSD, то тебе следует сделать следующее. Загрузись в Single User Mode (boot: -s), а затем, когда получишь командную строку, напиши:

'fsck -p / && mount -u /' и 'fsck -p /usr && mount /usr'

В этом случае мы монтируем корневой каталог и /usr, если он находится на отдельном разделе. Теперь просто наберем passwd и введем новый пароль для root'a.

Если же ты работаешь на Linux'e, то делаем вот что:

Загружаем линукс с параметром -s (boot: linux -s) и после окончания

загрузки меняем пароль root'a (или грузимся следующим образом - boot: linux init=/bin/sh, и исполняем команду mount -n -o remount -t ext2 /dev/hda2 / - это необходимо, потому что файловая система в данный момент смонтирована в режиме только чтения).

35. Значит, теперь моя бабушка сможет, не зная пароль рута, найти мою порнушку?!

Да ;). Но от этого можно очень просто защититься. Если ты работаешь на Linux'e,

то в биосе установи загрузку только с жесткого диска и поставь пароль на биос -

затем, в конфгурации lilo (/etc/lilo.conf), добавь запись следующего вида:

password = MyPassword

С данной опцией будет требоваться пароль на любой вид загрузки. Если же ты хочешь установить запрос пароля на загрузку со специальными параметрами для ядра, то перед предыдущей строкой добавь слово restricted (не забудь после внесения изменений набрать от root'a 'lilo').

Для операционных систем Open/Free/NetBSD поступаем так:

уберем из ядра возможность использования UKC - User Kernel Config (тем самым еще и запретим загрузку системы в single user mode), для этого закомментируем в конфиге ядра строчку:

option BOOT_CONFIG # add support for boot -c

36. Как заставить WinModem работать под линуксом?

До недавнего времени любой линуксоид сказал бы тебе, что WinModem'ы не работают под линуксом, но недавно для них, наконец, появились драйверы, которые можно получить с сайта: http://www.close.u-net.com/ или http://www.linmodems.org

37. Да, кстати. А как мне отформатировать дискету?

Хе-хе :0). Просто набирай:

fdformat /dev/fd0H1440

mkfs -t fat16 -m 0 /dev/fd0H1440 1440

38. Я скачал программу в исходниках, но не знаю, как ее установить!

Если программа состоит из одного исходника (например, zlob.c), то просто набери gcc -o zlob zlob.c.

Но это может не сработать, если в программе используются функции не из glibc, и тогда для компиляции понадобится подключение динамических библиотек - например, если в программе есть функции для работы с библиотекой curses, используемой для создания графического консольного интерфейса, то она (прога) должна быть скомпилена следующим образом: gcc -o zlob zlob.c -lcurses


Спецвыпуск Хакера, номер #005, стр. 005-010-7, ФАК по Юниксам

ФАК по Юниксам

Спецвыпуск Хакера, номер #005, стр. 005-010-7

Обычно все поставляемые GNU-программы в исходниках имеют скрипт конфигурации configure, который мы запускаем, а затем набираем make, если скрипт выполнил работу без ошибок. Если же в программе есть еще какие-то специальные опции для инсталляции - читаем файлы README или INSTALL, поставляемые с программой.

39. Как сделать, чтобы я мог обращаться к машинам через сеть по именам, не прописанным на dns-серверах?

В файл /etc/hosts добавь запись следующего формата:

[IP адрес машины] [Желаемое имя машины]

Например:

192.168.0.2 underworld

Действительным такое имя для машины будет только там, где ты сделал такую запись.

40. Windows после переустановки снесла lilo из mbr! Че делать-то?

Не парься, сейчас все исправим. Загрузи с диска или с дискеты ядро с параметром root=/dev/hda2 (/dev/hda2 - раздел диска, на котором находится корень твоей системы). Далее зайди в систему под root'ом и просто набери lilo, после чего lilo, прочитав свой конфиг, перезапишет mbr.


Спецвыпуск Хакера, номер #005, стр. 005-014-1, Парад десктопов

Парад десктопов

Спецвыпуск Хакера, номер #005, стр. 005-014-1

Ruben aka Noah (noah@inbox.ru,UIN 983332)

Интро

Дарова, перец! Ну как, поставил уже себе линуху? И как? Нравится консоль? Красивая, правда? Черненькая вся такая, с белыми буковками :). А если серьезно, без мазы говорить, красота компа или красота на экране для нас - для хацкеров - вещь абсолютно не важная. Это и так всем известно (другое дело - женская красота). Мы - люди, привыкшие к командной строке и к простому, ненавязчивому оконному интерфейсу. Большего нам для работы не надо. Но здесь есть одна оговорка: для работы-то не надо, а как же понты??? Представь себе, приедет к тебе твоя подружка и попросит продемонстрировать рабочее место. Не покажешь же ты ей консоль! Что она о тебе подумает на фоне того, что комп она в последний раз видела в каком-нибудь навороченном фильме, а они там, как известно, представляются этакими монстрами с трехмерным графическим интерфейсом. Это во-первых. А во-вторых, мы же не проклятые, чтоб все время только работать за компом - надо ведь и погамиться немного, и по Инету полазать. В конце концов, приятно сделать себе десктоп идеальной красоты, откинуться в кресле и просто полюбоваться им минуты две (а потом перейти в консоль и продолжить свои мучительные копания в чужом коде или опрокинуть уругвайский сервачок :)).

Десктопы

Итак, я уговорил твое величество, а твое величество уговорило свою лень отпустить тебя на полчасика поковыряться в X-Window System :0). На самом деле мы будем копаться, в основном, в настройках GNOME и нескольких диспетчерах окон. Если ты устанавливал линуху с дистрибутива RedHat 6.0, то графическая среда GNOME и диспетчер окон Enlightenment должны быть у тебя установлены и выбраны по дефолту (не экономический дефолт, а "по умолчанию"). Именно с этими двумя мы и будем больше всего работать... ой! развлекаться, конечно же :).

Если ты находишься в консоли, набери startx, а если уже в X, то посмотри на то, что перед тобой предстало: рабочий стол, пара иконок на нем и панель внизу. Начнем с иконок. Если это иконки, образовавшиеся после установки линухи (всякие там RedHat homepage, Online documentation и пр.), выделяй их все, кроме "Home directory" (эта пускай остается - полезная), левым мышом, дави на любую из них правым и жми "delete" - не нужны они нам, все равно не будешь юзать. Теперь определись, на какие из всего ассортимента nix'овых прог ты хочешь иметь launcher'ы (shortcut, или ссылка по-маздайному) на своем десктопе. Если уже определился, дави правым мышом на десктоп и в появившейся менюшке выбирай New -> Launcher. Перед тобой должно выскочить окошко "Desktop entry properties". В поле Name вводи все что душе угодно, в Comment можешь ничего не вводить, а вот в поле Command придется ввести команду, по которой запускается твоя прога. Если не знаешь команду, найди эту прогу в System Menus, открой правой кнопкой ее Properties и посмотри там. На случай, если ты к тому же не в курсе, что это за System Menus такое - это то, что открывается по нажатию на симпатичную пятку на панели. Теперь в поле выбора Typе поменяй directory на application. Пришло время выбирать иконку: дави на кнопку No icon, и перед тобой возникнет окно "Choose an icon", после недолгих тормозов которого ты сможешь выбрать себе одну из этих классных иконок (ты где-нибудь в маздае видел такие красивые иконки? Я - нет). Жми Ok в обоих окнах и... here we go!!! Проделай то же самое для всех прог, которые тебе нужны.


Спецвыпуск Хакера, номер #005, стр. 005-014-2, Парад десктопов

Парад десктопов

Спецвыпуск Хакера, номер #005, стр. 005-014-2

Теперь очередь панельки. Так, что ты на ней видишь? Какие-то кнопки, две стрелки по бокам и календарь-совмещенные часы. Ткни в одну из стрелок левым крысиным батоном. Понял, зачем эти стрелки нужны? Если не понравилось, не переживай - их можно убрать на фиг. Все эти кнопки и часы называются applets (часы понятно почему, а вот кнопки, которые на самом деле launcher'ы...). Их можно удалять, добавлять новые и двигать вдоль панели. Надави на любой апплет правым мышом и посмотри на появившееся меню. Теперь надави тем же батоном на саму панель. Нас интересуют следующие пункты появившегося меню:

Add applet - можно выбрать из списка, рассортированного по категориям, маленькую апплет-утилитку и выставить ее на панель. Среди предложенных апплетов есть как абсолютно бесполезные, так и очень полезные.

Add new panel - добавить еще одну панель, можно по краю (как наша) или угловую (в виндах таких не бывает).

Convert to corner panel - преобразовать нашу панель в угловую.

Add main menu - добавить апплету с пяткой, как start в виндах.

Add drawer - добавить своеобразный разветвитель панели. Добавь и посмотри, что это такое, если интересно.

Add log out button - здесь ничего пояснять не надо.

Add swallowed app - добавить приложение "внутри" панели. Ерундистика, нам не надо.

Add new launcher - можно добавить launcher прямо на панель.

This panel properties - свойства данной панели. Можно выбрать расположение панели (справа, слева, сверху, снизу), можно выбрать "автоматическое прятанье" (знаешь, что это - по панели маздайного офиса, ну, или по самой маздайной панели), можно убрать стрелки, которые по бокам панели (причем, можно убрать как стрелки, так и сами кнопки, на которых эти стрелки нарисованы), можно выбрать фоновый цвет или картинку панели.

Global properties - свойства всех панелей. Куча настроек, на которые у нас не хватит времени. Впрочем, как говорят, там все "интуитивно понятно для пользователей Windows". Так что проблем быть не должно. Изврати панель, как тебе больше нравится, и мы приступаем к основному.

Рабочий стол - это прежде всего background (эээ... типа :)). У тебя на панели где-то должен быть launcher с ящиком инструментов. Если ты его убил, то я тебе сочувствую, а если нет - жми на него (если ты его действительно убил, ищи в System Menus папку Settings, а в ней GNOME Control Center). Тэк-с, перед нами окошко, поделенное на две части: слева - меню, справа - пустота. Выбирай слева Desktop -> Background. Далее жми на кнопку Browse. Мы находимся в директории /usr/share/pixmaps/backgrounds. Кликай слева на space/ и выбирай справа файл с именем marsglobe1.jpg. Можешь полюбоваться картинкой в Preview, а потом нажать Ok. Тебе не кажется, что этот Марс какой-то уж слишком круглый? Поставь галку перед Scaled - так прикольнее. Кстати, Scaled означает "растянуто", Scaled (keep aspect) - "растянуто с сохранением пропорций" (типа 90-60-90 :)), Centred - "расположено по центру", Tiled - "размножено". Жми Ok. Обратим свое внимание на менюшку слева: Desktop -> Theme Selector. Тут имеется меню с выбором Available Themes. Найди в нем тему под названием Pixmap и жми Ок. Все, от гнома нам больше ничего не надо. Идем мучить Enlightenment. Надави на средний мышиный батон (или на левый и правый батоны сразу, если ты эмулируешь трехкнопочную крысу). В появившемся меню выбери Themes -> eStep_New. Теперь можешь открывать всякие окошки и любоваться красотой :). У тебя получилось нечто очень похожее на это:


Спецвыпуск Хакера, номер #005, стр. 005-014-3, Парад десктопов

Парад десктопов

Спецвыпуск Хакера, номер #005, стр. 005-014-3

Ё-мое, что ж я сделал-то...

Ты не понял, что мы делали??? Ну, ничего страшного - сейчас проведем небольшой ликбез. Когда всякие там преподы проводят ликбез среди нас - это хреново, а когда мы сами среди себя ликбез проводим - это рульно и немного весело. Так что не парься и читай дальше.

Enlightenment - диспетчер окон, стало быть, он отвечает за окна. За их реакцию на перемещение, свертывание, развертывание, изменение размера, закрывание, открывание и - что самое главное для нас - за оформление заголовков окон. Тема eStep_New, которую мы выбрали в Enlightenment, нарисовала нам черную панельку с кнопкой "свернуть" слева и кнопкой "закрыть" справа. GNOME - графическая среда, он отвечает за очень многое, в том числе и за панельки, менюшки, десктоп и многое другое. Естественно, что GNOME отвечает за оформление всей этой дребедени, и когда мы выбрали тему Pixmap, мы заставили его оформить все кнопки, панельки, менюхи и пр. соответствующими 3D текстурами желтоватого цвета. Также GNOME позволяет выбирать разные диспетчеры окон. Это значит, что Enlightenment'у есть альтернатива (привыкай, в nix'ах незаменимых прог не существует), его можно убрать и поставить вместо него другой диспетчер окон. Я еще расскажу об этом. А сейчас давай проводить настоящий парад десктопов. Я тут наделал для тебя целую кучу :0) (десктопов!). Запомни только две вещи:

1. Все бэкграунды, заюзанные в оформлении, не поставляются с линухами, но я уверен, что ты найдешь кучу всяких, им подобных, в Инете (я оттуда все слил).

2. Перед каждым скриншотом я буду приводить такую шапку: GNOME theme - <имя темы, выбранной в Control Center GNOME> (то есть оформление внутри окон) и Enlightenment theme - <имя темы, выбранной в Enlightenment> (то есть оформление заголовков окон).

Другой диспетчер

Надоел Enlightenment (а мне как надоело это длиннющее слово!!!)? Будем менять его. Иди в GNOME Control Center -> Desktop -> Window Manager. Там у тебя должно быть два диспетчера: Enlightenment (current) и Window Maker. Выделяй второй и жми Ok. Ну как? По-моему, полнейшая фигня. Но главное мнение за твоим компом - твое.

Хочешь еще диспетчер? Не вопрос! Лезь опять туда же... Опа, их же всего два! Ничего, мы еще добавим :). Так и жми - add, и в новом окошке пиши в поле Name fvwm2 и то же самое в поле Command. Жми два раза Ok и наслаждайся! Перед тобой чисто UNIX'вые окна - диспетчер fvwm2 эмулирует UNIX Motif интерфейс.


Спецвыпуск Хакера, номер #005, стр. 005-014-4, Парад десктопов

Парад десктопов

Спецвыпуск Хакера, номер #005, стр. 005-014-4

Еще? Ладно. Add -> name=twm, command=twm. Исключительно отвратительный диспетчер! Добавляет свои противные зеленые заголовки ко всему, что находит на рабочем столе. Я его просто ненавижу. Поработай в нем тридцать минут, и ты тоже возненавидишь его такой лютой ненавистью, что я и слова-то подобрать не могу... Хотя могу! Помнишь фильм "Каттон Клуб" про гангстерский Чикаго? Там Ричард Гир спрашивает у главной героини: "Злишься?". А та отвечает: "Да! Аж соски сводит!" :)

И еще. Add -> name=fvwm, command=fvwm. Симпатичный. И вообще, мне нравится? как прорисованы заголовки окон. Между прочим, fvwm и fnwm2 произошли от twm...

В следующих директориях ты найдешь много разных текстур и wallpaper'ов для своих извращений.

/usr/share/pixmaps/backgrounds/

/usr/share/wallpapers

Учти, что существует еще и графическая среда KDE, и тьма разных диспетчеров. Хочешь? Иди в Sytem Menus -> KDE Menus -> System -> Desktop Switching Tool. Там выбирай KDE (а можешь и Another Level), жми Ok и перезагрузи X. Тебя ждет масса неповторимых ощущений :).

Енд

Ну вот и все с оформлением X Window System. Теперь, после всех этих экспериментов, можешь со спокойной совестью вернуться к черно-белой командной строке :). Если захочешь, конечно ;).

Представь себе, приедет к тебе твоя подружка и попросит продемонстрировать рабочее место. Не покажешь же ты ей консоль! Что она о тебе подумает на фоне того, что комп она в последний раз видела в каком-нибудь навороченном фильме, а они там, как известно, представляются этакими монстрами с трехмерным графическим интерфейсом...

Enlightenment - диспетчер окон, стало быть, он отвечает за окна. За их реакцию на перемещение, свертывание, развертывание, изменение размера, закрытие, открытие и, что самое главное для нас, за оформление заголовков окон.

Поработай в нем тридцать минут, и ты тоже возненавидишь его такой лютой ненавистью, что я и слова-то подобрать не могу... Хотя могу! Помнишь фильм "Каттон Клуб" про гангстерский Чикаго? Там Ричард Гир спрашивает у главной героини: "Злишься?". А та отвечает: "Да! Аж соски сводит!" :)


Спецвыпуск Хакера, номер #005, стр. 005-018-1, ОБИТАТЕЛИ NIX'ОВ

ОБИТАТЕЛИ NIX'ОВ

Спецвыпуск Хакера, номер #005, стр. 005-018-1

Ruben aka Noah (noah@inbox.ru,UIN 983332)

14 октября 2027 года.

Токио, секретная база Комитета

Безопасности M$.

В затененное помещение по очереди входят около десяти мужчин и

женщин. Человек в серой форме с нашивками подполковника встает у

небольшого экрана, встроенного в стену.

Подполковник Комитета Безопасности M$:

Приветствую вас, господа офицеры. Присаживайтесь, пожалуйста, занимайте свои места. Итак, господа, наше сегодняшнее секретное совещание полностью посвящается важнейшей области деятельности нашего комитета - разработке плана по уничтожению nix-подобных систем. Как вам всем хорошо известно, nix'ы на протяжении уже многих десятков лет являют собой прямую угрозу существованию нашей корпорации. В последние годы мы пытались кардинально изменить сложившуюся ситуацию с помощью

огромных финансовых затрат - стандартная политика M$, но в данном случае эта тактика не принесла даже сотой доли желаемого результата. Эти люди не реагируют на рекламу, какой массированной она бы ни была, они не обращают внимания на все различные усовершенствования наших продуктов, они только скромно улыбаются, когда речь заходит о нашей новой системе технической поддержки пользователей. Мы называем их обитателями nix'ов, или nix'оидами, - художники, кодеры, админы,

веб-мастера, юзеры, геймеры и, естественно, хакеры. Это - устоявшееся и стабильное общество. Общество со своими понятиями, этикетом, правилами, законами, первоначально основанными, как это ни странно, на двух смежных механизмах, реализованных в nix'ах: механизме разделения пользователей и механизме доступа к информации (к файлам, в более узком смысле). Наши люди из отдела психологии считают, что в основе наших неудач лежит моральная привязанность nix'оидов к своей системе. Для них работа в многопользовательской nix-сети стала второй жизнью - виртуальной жизнью. Наличие глобальной информационной сети Internet усугубило ситуацию. Небольшие сети, из двадцати-тридцати машин, объединяются в огромные сети. Таким образом, nix'оиды получают

возможность общаться между собой по всему миру. Опишу вполне реальную

ситуацию: несколько программистов, художников, тестеров общаются в

конференции, кто-то подкидывает идею, кто-то механизм реализации, и

вот: они все вместе принимаются за разработку программного обеспечения,

заранее зная, что не получат никакой материальной пользы от проделанной работы. Я понимаю, для вас это звучит более чем странно. Мы даже пытались перенять этот опыт - заставили общаться наших программистов посредством конференций. В итоге этого эксперимента качество наших продуктов ухудшилось еще на порядок. Я думаю, теперь вы полностью оценили ту опасность, которую несет в себе общество

обитателей nix'ов.

Господа, нашей корпорацией было принято решение во что бы то ни стало подорвать это сообщество. Но у нас все еще слишком мало информации о них. Для разработки детального плана нам необходимо вникнуть в самую суть их общества, их отношений. Вам предстоит внедриться в ряды nix'оидов и добыть необходимую нам информацию.


Спецвыпуск Хакера, номер #005, стр. 005-018-2, ОБИТАТЕЛИ NIX'ОВ

ОБИТАТЕЛИ NIX'ОВ

Спецвыпуск Хакера, номер #005, стр. 005-018-2

Естественно, сейчас вы пройдете инструктаж, составленный на основе имеющихся у нас разведданных. Господин инструктор, я попрошу вас по возможности излагать материал в разговорном стиле, принятом у nix'оидов - нашим агентам необходимо привыкнуть к обстановке. Приступайте.

Инструктор:

Ну, типа, привет, ребята, и все такое (на этом месте один из агентов - лысый здоровяк - инстинктивно полез за пушкой, но потом овладел собой и продолжил внимательно слушать)! Информации достаточно много, так что напрягите свои лбы. Любой nix - многопользовательская и многозадачная ось. Это означает, что к одному компу можно подключить несколько терминалов (клава + монитор), и несколько юзеров смогут одновременно юзать этот комп. Для того чтобы юзер мог залогиниться в систему и работать в ней, у него должна быть своя учетная запись.

Учетные записи всех юзеров системы хранятся в файле /etc/passwd. Они включают в себя следующее:

username - имя пользователя;

password - пароль юзера;

UID (user ID) - уникальный идентификационный номер юзера;

GID (group ID) - уникальный идентификационный номер группы юзеров, к

которой он принадлежит;

full name - полное реальное имя юзера;

home directory - домашняя директория юзера;

login shell - шелл, который будет по умолчанию запускаться для юзера

при входе в систему.

Не все пункты обязательны. Например, full name может быть пустым. Самым главным перцем в системе является root. Это учетная запись юзера, который имеет право делать с системой все что ему захочется. Паролем рута обычно владеет админ системы и никому его не дает (разве что другому админу). Кстати, если админ работает под другим логином (не рут) и ему в ламе перелогиниваться, он может работать под своим логином с правами рута. Для этого надо набрать команду su, а потом ввести пароль рута. Очень удобно, если систему админит несколько челов - сразу видно, кто из них то-то, когда-то и там-то испортил :).

Для того чтобы добавить нового юзера в систему (новую учетную запись), админ должен залогиниться с правами рута и ввести команду useradd <имя юзера> (или adduser, в зависимости от версии nix'а, который юзается). Каждому юзеру назначается его UID - обычное число, которое админ (рут) может потом поменять (обычно в этом не бывает необходимости). Для того чтобы поставить пароль юзеру (у новоиспеченных юзеров пароля нет - можно залогиниться в систему, введя

username и нажав enter) или поменять существующий, админ должен набрать passwd <имя юзера>, а потом два раза ввести пароль. Или же сам юзер может выбрать себе пароль, залогинившись в систему и введя просто passwd, без имени юзера. Удалять юзеров может только рут (userdel <имя юзера> или deluser <имя юзера>). По умолчанию домашний каталог юзера создается в директории /home/<имя юзера>. В домашнем каталоге юзера хранится всякое барахло: его мыло, его настройки и

прочее файло. Там же юзер может создавать всякие файлы, читать их, писать в них, короче - работать. И еще один важный момент: все юзеры системы объединены в группы. Например: admins, users, testers, coders. Каждой группе соответствует ее GID. Сейчас мы будем говорить о правах доступа к файлам, и все вы поймете, зачем нужны группы.


Спецвыпуск Хакера, номер #005, стр. 005-018-3, ОБИТАТЕЛИ NIX'ОВ

ОБИТАТЕЛИ NIX'ОВ

Спецвыпуск Хакера, номер #005, стр. 005-018-3

Все это время в вентиляционной трубе, проходящей под потолком комнаты, поджав под себя ноги по-турецки, сидел молодой парнишка в широких штанах и непомерно огромных ботинках, подошвы которых очень напоминала автомобильные шины. На его левой скуле красовалась черная тату, гласящая "[ZqN]Plum-Cake". Сдвинув узкие солнечные очки на нос, парень смотрел на дисплей, лежащего на его коленях темно-синего ноутбука. Его пальцы в это время бесшумно бегали по клавиатуре. Свет, попадающий в трубу из комнаты через решетку, отражался от обтекаемой поверхности ноутбука и от солнечных очков.

Инструктор:

Вы все, наверное, думаете, что при таком раскладе один юзер системы может, случайно или специально, попортить файлы другого или вообще системные файлы и что nix'ы до сих пор существуют только благодаря крайней миролюбивости и аккуратности юзеров. А вот и нет! Обломитесь :).

Всем файлам в nix'е назначаются свои атрибуты, в зависимости от которых формируются права доступа различных юзеров к этим файлам. Права доступа бывают всего трех видов: право на чтение (юзер может только читать файл), право на запись (юзер может записывать в файл) и право на выполнение (имеет значение только для выполняемых файлов, то есть для прог, шелл-скриптов и прочих). Кроме того, каждый файл должен иметь своего владельца. Владельцем файла становится юзер, который создал этот файл. Для файла все юзеры делятся на три типа: хозяин, или владелец (о, Создатель мой!!!, сохрани и благослови!!!), юзеры, состоящие в одной группе с владельцем, и все остальные юзеры (те, кто не является владельцем этого файла, и те, кто не состоит с ним в одной группе). Учтите, что директории и все системные устройства в nix'ах тоже являются обычными файлами. Тот же самый /dev/fd0 никакой не флоповод, а всего лишь файл, связанный с флоповодом. Поэтому если рут запретил юзеру доступ к этому файлу, тот не сможет юзать флоповод (та

же самая ситуация с мышами, момедами, хардами и т.д.). С директориями дела обстоят так: если юзер имеет право на чтение, значит, он может только войти в каталог, если же он имеет право на запись, значит, он может создавать и удалять файлы в этом каталоге. Право на выполнение роли не играет - все равно каталог запустить невозможно. Владельцем всех системных файлов является рут. Он же имеет право забирать файлы у одного юзера и отдавать их другому (менять владельца).

Делается это так (тут инструктор подошел к экрану, и тот засветился консольными строками):

chown <имя нового владельца> <имя файла>

Для передачи каталога надо вводить

chown -R <имя нового владельца> <имя каталога>

Изменить права доступа к файлу может либо его владелец, либо рут.

Делается это командой chmod. Существует две формы представления прав

доступа: символьная и числовая.

Сначала разберемся с символьной. Если войти в любой каталог, где

есть файлы, и набрать


Спецвыпуск Хакера, номер #005, стр. 005-018-4, ОБИТАТЕЛИ NIX'ОВ

ОБИТАТЕЛИ NIX'ОВ

Спецвыпуск Хакера, номер #005, стр. 005-018-4

ls -l

то появится список всех файлов в этом каталоге и права доступа к ним в символьной форме (так называемая строка прав доступа). Строка прав доступа состоит из десяти символов. Выстроились, блин :). Первый символ указывает тип файла: "d" - директория, "-" - обычный файл. Три последующих - права доступа владельца к этому файлу. Если первый символ из этих трех "r", владелец имеет право читать этот файл, а если "-", то не имеет. Следующие два символа: "w" - писать и "x" - выполнять (aka запускать). Если вместо них стоит "-", значит, владелец этих прав не имеет. Еще три символа - права доступа группы, еще три - права всех остальных (по тем же правилам "r","w","x" и "-" вместо них, если

запрещено). Давайте смотреть примеры:

drwxrwxrwx - директория, к которой все имеют любые права доступа;

-rwxr--r-- - обычный файл, владелец может делать все, а все

остальные - только читать;

-rwxr-xr-- - обычный файл, владелец может делать все, группа -

читать и выполнять, а все остальные - только читать;

-r-------- - обычный файл, который только владелец может читать.

С правами доступа в символьной форме chmod работает так:

chmod <тип пользователей><+ или -><тип права доступа> <имя файла>

Здесь: тип пользователей: u - владелец, g - группа, o - остальные,

a - все, "+" - добавить пользователям этого типа право доступа,

"-" - отнять, тип права доступа: "r", "w", "x".

Примеры:

chmod u+w text.txt - дать владельцу право на запись в text.txt;

chmod o-r text.txt - отнять у остальных право на чтение;

chmod a-x text.txt - отнять у всех право на выполнение.

Теперь права доступа в числовой форме. Для некоторых эта форма может показаться более простой. Надо запомнить только следующее:

400 - владелец имеет право на чтение

200 - владелец имеет право на запись

100 - владелец имеет право на выполнение

40 - группа имеет право на чтение

20 - группа имеет право на запись

10 - группа имеет право на выполнение

4 - остальные имеют право на чтение

2 - остальные имеют право на запись

1 - остальные имеют право на выполнение

Теперь осталось только просуммировать числа, соответствующие тем правам

доступа, которые мы хотим поставить файлу. Примеры:

400+200+100+40+4=744

chmod 744 text.txt - владелец может делать все, а все

остальные - только читать;

400+40+4=444

chmod 444 text.txt - все имеют право только на чтение;

400+100+10+1=611

chmod 611 text.txt - владелец может читать и выполнять,

остальные - только выполнять.

Все, с этим мы покончили, теперь еще кое-что...

На этом слове инструктора оборвал противный вой сирены, и механический женский голос произнес: "Внимание!!! Всему персоналу! На территории обнаружен чужак! Внимание!!! Всему персоналу!..". Откуда-то сверху, со стороны вентиляционной трубы, послышался глухой стук. В воцарившейся тишине прогрохотали три мощных выстрела - это лысый КБM$'шник стрелял в потолок. Большинство КБM$'шников


Спецвыпуск Хакера, номер #005, стр. 005-018-5, ОБИТАТЕЛИ NIX'ОВ

ОБИТАТЕЛИ NIX'ОВ

Спецвыпуск Хакера, номер #005, стр. 005-018-5

повскакало с мест и ринулось к выходу, опрокидывая мебель. Сирена внезапно умолкла, зато ожил экран, рядом с которым стоял подполковник. На нем большими буквами мигала надпись: "Kick yourself,

ламерюги, kick yourself!!!" ;)...

Спустя сорок минут подполковник принимал рапорт у лысого.

- Вы его взяли?

- Нет, одна из пуль задела его, но, видимо, легко. Он вышел наружу и

смешался с толпой.

- Это был хакер?

-Нет, сэр, судя по тому, как он ориентировался в наших запутанных коридорах, и судя по тому, как быстро он удирал, это был геймер, - лысый кивнул в сторону экрана в стене. - Зато хакеры поработали вот здесь. Если бы они не добрались до нашей системы безопасности, мы бы схватили парня.

- А как вы думаете, он записывал все, о чем здесь говорилось?

- Еще хуже, сэр. Мы нашли его ноутбук - этот гад транслировал наш разговор на восемнадцать различных серверов сразу.

- Да, видимо, нашу корпорацию ждет очередной скандал. Старик будет недоволен нашим комитетом.

- Да уж...


Спецвыпуск Хакера, номер #005, стр. 005-022-1, The GIMP

The GIMP

Спецвыпуск Хакера, номер #005, стр. 005-022-1

Ruben aka Noah (noah@inbox.ru,UIN 983332)

GIMP'УЙ ДЕВЧОНОК!!!

Ты уже отрастил бороду? Что значит "упс, забыл"? Мы же договаривались,

что будем косить под крутых художников-дизайнеров, а какой художник без

бороды и длинных волос... Нет, я так не играю :(. Иди отращивай бороду,

обломист... Постой-ка, есть идея. Мы будем косить под графитчиков! Они

ведь тоже художники :). Только без бород - как раз то, что нам надо. И

выглядят почти как мы. Все, уладилось :). Я надеюсь, ты не забыл, что мы -

еще и крутые nix'оиды (тут-то нам косить не надо)? Ну, типа, имидж мы себе

напридумывали :), не вопрос. Имидж - ничто!? Вот ты сказанул... Имидж - это мегаважно!

Что, не догнал? Да, млин, с таким имиджем - художника-nix'оида - ВСЕ

герлзы будут нашими! Хе-хе, сразу вижу, как ты заинтересовался ;). Только

учти, что имидж мало придумать, его надо еще суметь поддержать. Так что

придется посидеть полчасика за компом с Х в руках и с The GIMP'ом на

мониторе. А уж потом топай к ближайшей тусовке и кидай там мегапонты.

GIMP'УЙ Х!

GIMP - GNU Image Manipulation Program. Одна из самых основных прог для

nix'оидного художника. Не буду долго тянуть резину - скажу сразу, The GIMP

очень похож на хорошо знакомый тебе Adobe PhotoShop и ничем ему не

уступает. Если ты работал в фотошопе, то с GIMP у тебя проблем не будет. А

если не работал, проблем все равно не будет :) - Х поможет. Чтобы ты

научился работать с гимпом, мы возьмем какой-нибудь один рисунок и

немного поизвращаемся с ним. Не против, если этим рисунком будет лого

нашего Х (утягивай с сайта)? Погимпуем Х, так сказать :).

Для начала надо запустить GIMP. Найти на него launcher не составит

труда, да и команду угадать несложно (gimp) :). Если ты запускаешь GIMP в

первый раз, то перед тобой выскакивает окошко с предложением инсталльнуть

его. Жми install и подожди сек, пока прога создаст свои папки в твоей

домашней директории (на самом деле это не инсталл, а установка настроек

для конкретного юзера). В следующем окошке жми Сontinue. Теперь GIMP

загружается. Выскакивает окно с прикольной рожей, содержащее подсказку

дня, и главное окно гимпа, которое, по сути, является панелью

инструментов.

"И вот это вот маленькое поганое окошко претендует на высокое

звание конкурента фотошопа!?" - скажешь ты. Да! :) Потерпи, скоро мы

откроем и остальные окошки. И первым из них будет окно с изображением,

над которым мы собираемся проводить наши жестокие эксперименты. Для

открытия нового файла надо жать File -> New, но мы договорились работать

с готовым файлом, поэтому File -> Open.

Режим этого файла - Indexed, нам его надо поменять на RGB: жми

правой кнопкой прямо на окно с файлом, появится главное рабочее меню

гимпа - выбирай Image -> RGB. И давай-ка немного увеличим размер холста,

а то так неудобно работать. Вызывай главное меню (правый клик), Image ->

Resize, вводи новые значения длины или ширины (ширину или длину,

соответственно, гимп посчитает сам :)). Наше лого пока прозрачное, стоит

добавить к нему белый фон. Для этого надо открыть окошко работы со слоями

(layers): главное рабочее меню, Dialogs -> Layers&Channels.


Спецвыпуск Хакера, номер #005, стр. 005-022-2, The GIMP

The GIMP

Спецвыпуск Хакера, номер #005, стр. 005-022-2

Как видишь, у нас пока только один слой. Для добавления нового жми на

кнопарь с изображением листа бумаги с загнутым углом. Появится окно опций

нового слоя.

В Layer Name можешь писать что угодно, а вот тип заполнения слоя выбери

белым: Layer Fill Type -> White. Что, пропал любимый Х? Он просто оказался

под только что созданным слоем. В окне слоев нажми кнопку со стрелкой

вниз. Этим ты толкнешь новый слой под слой с Х. Вот, теперь все правильно.

GIMP'УЙ СЕБЯ!

Сейчас будем тебя гимповать :). Точнее, твои мозги - знакомимся с менюхами

и окошками. Давай начнем с главного окна. Ну, обычная панель инструментов,

знакомых тебе с младенческих лет. Селектор цветов: главный цвет и фоновый цвет.

Единственное, что может тебя покоробить - нет инструмента для рисования прямой.

Делается это так: выбирай карандаш или кисточку, рисуй точку, зажимай Shift и

рисуй еще одну точку. Они соединятся прямой :). Еще по поводу инструментов: жми

даблкликом на любой из них, должны открыться настройки этого инструмента. И еще:

открой из рабочего меню Dialogs -> Brushes.

Здесь настройки насадок на кисточку и другие рисовальные инструменты (air

brush, например). Так, с инструментами ОК. Обрати свой взор к меню File

главного окна. Там имеется подменю Preferences. Открой, почитай и настрой

по своему вкусу. Вроде все. Нет, чего-то не хватает... А, вот! Хочешь много

всяких текстур? Иди в главное меню Dialogs -> Patterns. Там их кучи. Теперь

действительно все. Приступаем к самой полезной для кидания понтов (и не только)

части :).

СКРИПТУЙ И ФИЛЬТРУЙ Х!!!

Самое веселое занятие - извращаем изображение фильтрами. Только не

вздумай так выразиться при подружках! Хороший nix-художник скажет:

добавляем визуальные эффекты. В GIMP есть два средства для создания

эффектов: фильтры и Script-Fu (фуууу...). Ну, про фильтры ты наверняка

знаешь по фотошопу. Script-Fu - это механизм, позволяющий запомнить некую

последовательность действий с возможностью последующего их выполнения. Я

знаю, что ты ни фига не понял - я бы и сам не понял, если бы мне так

объяснили. Объясняю по-человечески. Представь себе, что один крутой

художник придумал (создал) свой эффект. Ну, там-то, на изображении, что-то

залил, что-то скопировал, создал новый слой, там цвет поменял, здесь

что-то пририсовал, пофильтровал немного, и в итоге получился искомый

красивый эффект. Сам-то он помнит, в какой последовательности и что надо

делать, чтоб получить такой эффект, но не может же он каждому желающему

повторять этот эффект, объяснять, где, что кликать, чем фильтровать... На

этот случай и создан механизм Script-Fu. Художник заставляет GIMP

запомнить все что он делал с изображением и записать это в один

файл. Другие юзеры могут скормить этот файл своим гимпам, и все действия

для получения искомого эффекта произведутся автоматически. ОЧЕНЬ

похожий механизм имеется и в фотошопе (мало кто о нем слышал и знает... ), :( только название другое - Actions. Не буду тебя долго мучить: вызови

правым кликом на изображении рабочее меню гимпов. В самом низу имеются эти


Спецвыпуск Хакера, номер #005, стр. 005-022-3, The GIMP

The GIMP

Спецвыпуск Хакера, номер #005, стр. 005-022-3

самые Filters и Script-Fu. Попробуй некоторые из них на нашем

видоизмененном лого. Особо рекомендую следующие:

Filters:

Artist -> Apply Mosaic, Combine -> Film, Distort -> PageCure,

Distort -> Whirland Pinch, Light Effects -> Flame FX,

Light Effects -> Super Nova, Map -> Map Object, Render -> Plasma.

Script-Fu:

Decon -> Add Bevel, Decon -> Coffe Stain, Decon -> Lava,

Decon -> Old Photo, Decor -> Xach - Effect,

Animators -> Rippling, Alchemy -> Clothify, Shadow -> Drop Shadow,

Render -> Line Noav.

Еще немного Script-Fu ты найдешь в меню Xtns главного окна гимпов (панели

инструментов). Они немного другой ориентации :) - не работают с твоим

изображением, а рисуют полностью свое: кнопочки, всякие феньки и прочее

барахло.

На этом - все. Экспериментируй, рисуй, твори. Не забывай поддерживать

имидж!!! Свои творения заливай в Инет в виде сайтов и показывай их подругам.

Удачи! Пока.

Ты уже отрастил бороду? Что значит "упс, забыл"? Мы же договаривались,

что будем косить под крутых художников-дизайнеров, а какой художник без

бороды и длинных волос... Нет, я так не играю :(. Иди отращивай бороду,

обломист...

Для начала надо запустить GIMP. Найти на него launcher не составит

труда, да и команду угадать несложно (gimp) :).

"И вот это вот маленькое поганое окошко претендует на высокое

звание конкурента фотошопа!?" - скажешь ты. Да! :)

Самое веселое занятие - извращаем изображение фильтрами. Только не

вздумай так выразиться при подружках! Хороший nix-художник скажет:

добавляем визуальные эффекты.


Спецвыпуск Хакера, номер #005, стр. 005-026-1, NIX'ОИДНЫЕ ИГРУШКИ

NIX'ОИДНЫЕ ИГРУШКИ

Спецвыпуск Хакера, номер #005, стр. 005-026-1

Ruben aka Noah (noah@inbox.ru,UIN 983332)

Привет! Сейчас мы будем проводить обзор ("обозревать", а не "обосревать"). Хорошие вещи мы не обосреваем, такому действию подвергается только отстой. А обозревать мы будем игрушки, поставляемые в дистрибутивах вместе с линухами. Только не надейся увидеть здесь кваку! Все игрульки маленькие, аркадно-логические, но хорошие! Я практически не играю ни в какие гамы на компе, кроме червяков (Worms 2/3:Armageddon), а в линуксоидные гамки я гамаюсь. Причем, с удовольствием :). Ну, ты меня понимаешь - ностальгия по временам Атари, и все такое ;). Поехали. Да, нечто важное: в скобках, после названия гамки, команда, при помощи которой можно игрульку запустить, если не можешь найти на нее ссылку в меню.

Gnome Tetravex (gnotravex)

Простая и маленькая игрулька-головоломка. Даются квадратики с циферками у каждой стороны. Надо умудриться разложить их так, чтобы циферки соседствующих сторон у всех квадратов совпадали. Думаешь, легко? А ты выбери поле 6х6 (менюха settings) :)!

AisleRiot (sol)

Любителям пасьянсов от GNOME. В этой одной проге содержится куча пасьянсов (в том числе и виндовый "Солитер", и наш пасьянс "Одесса"). Выбрать пасьянс можно, нажав кнопку select. А по нажатию на кнопку hint гама подскажет ход. Сделанные ходы можно отменять.

Mines (gnomine/kmines)

Хорошо известный всем сапер. Есть версия и GNOME, и KDE (гном лучше). В гномовской версии очень прикольная рожа :0).

xBoard (xBoard)

Шахматы на основе шахматной проги GNU Chess. Время учитывается.

Куча настроек. Можно заставить комп играть против самого себя,

но по дефолту ты играешь против него... Блин, мне так и не удалось

выиграть у этого кретина!!! А он сделал меня раз пять подряд... Селерон все-таки.

xGammon (xgammon)

В нарды играл когда-нибудь? Вот-вот. В принципе, играет неплохо, но

выиграть у него можно. В принципе, могли бы и покрасивее все

оформить. В принципе... ну ладно, хрен с ним. Проехали. В принципе :).

Same (same-gnome/ksame)

Очень неплохая гама. Существует версия как под GNOME, так и под KDE.

Советую тебе гномовскую - она красивее. Перед тобой окно, до отказа

забитое разноцветными шариками. Когда ты держишь мышу на

каком-нибудь из шариков, все соседние шарики такого же цвета начинают

вертеться. Если топнуть по батону, они всем скопом исчезнут. Твоя

цель - спровадить все шарики как можно быстрее и возможно большими

партиями в никуда. Прорисована гама отлично.

Mahajongg (mahajongg)

Что-то непонятное, но многие тащатся. Перед тобой наши родные домино, но с китайскими иероглифами. Ты должен находить одинаковые, не запертые с обеих сторон, и удалять их путем обоюдного выделения (клик). Есть версия KDE, но она, как водится, убого прорисована.

Sokoban (ksokoban)

Супер-гама!!! Просто супер. Смысл игры очень простой, и ты, наверное, когда-то гамался хоть в одну игру из этого жанра. Ты играешь за некого перца, который без устали носится по темным лабиринтам и таскает на свои законные места камешки (кристаллы), разбросанные по всему уровню. Играть надо так, чтоб не замуровать себя и чтоб случайно не подвинуть булыжник вплотную к стене - потом его оттуда хрен вытащишь :). Хоть и кажется, что играть в эту гаму невероятно просто, - это не так. Если честно, наоборот: в нее невероятно сложно играть!!! Я не смог


Спецвыпуск Хакера, номер #005, стр. 005-026-2, NIX'ОИДНЫЕ ИГРУШКИ

NIX'ОИДНЫЕ ИГРУШКИ

Спецвыпуск Хакера, номер #005, стр. 005-026-2

пройти даже восьмой уровень :(. Если ты - настоящий гамер (а не такой полулевый,

как я), дай мне знать, как проходить этот чертов восьмой, а? Игра прорисована хорошо. Только главный герой какой-то дегенеративный, но это ничего, особо не напрягает :). В игре имеется куча настроек, в том числе и возможность выбора различных наборов уровней - например, облегченный вариант для всяких мелких детей :). Обрати внимание на менюху bookmarks: типа, там можно сейвиться.

xBoing (xboing)

Термоядерная игрушка!!! Если хочешь стать таким же, как Ден Шеповалов

(комментарии излишни), гамься в нее не менее трех часов подряд ежедневно. Мутация гарантирована! Лично меня xboing пробил насквозь. По сути это гибрид арканоида и настольного тенниса, но какой! Совершенно кислотный - отлично

прорисован. Адреналину выделяется куча. А знаешь, почему? Ты играешь в нее некоторое время, и твой бедный мозг привыкает, что мячик по некоторым правилам скачет туда-сюда, туда-сюда, а упустить его - ни-ни. И вдруг ты попадаешь в какой-нибудь призовой блок, и на тебе! - все правила меняются в течение секунды, возникает угроза посеять мячик. Получается искусственно созданная экстремальная ситуация. Чтоб ты окончательно представил себе игру, просто приведу несколько

призовых блоков: исчезновение стен, уменьшение ракетки, немедленная смерть, реверс управления (тянешь крысу вправо, ракетка идет влево), multiball - два мяча сразу (вот это самые прикольные ощущения!). Игра довольно быстрая и идет на время. Радует то, что непонравившийся блок можно отстрелить. Правда, по закону подлости, не успеваешь выстрелить, сразу попадаешь в свой мяч (shit!!!). Единственное, что напрягает в игре - так это вылезающий все время из игрового окна курсор. Мало того, он еще и полноценно работает на десктопе и в других

окнах!!! А хотя черт его знает - может, так даже лучше. Прикинь, ты гамишься себе, и вдруг, в самый ответственный момент, у тебя начинают открываться всякие менюхи и окна!

xBill (xbill)

Самая лучшая гама этого обзора!!! Первое место, золотая медаль, цветы, аплодисменты и любовь девушек (а среди гамесов бывают девушки?)!!! Когда ты в первый раз увидишь эту гаму, то подумаешь, что я - полный ноль и ничего не понимаю в игрушках. Оформление у игры более чем убогое, весь игровой процесс состоит только в быстром топтании крысиных кнопарей, короче - полный отстой. Но это не так! И стоит мне рассказать предысторию гамы, как ты полюбишь ее как родного отца.

Буквально следующее (правда, на буржуйском) ты сам можешь прочесть в хелпе игры: "И снова судьба планеты в твоих руках! Злой хакер, известный под ником Билл, создал вирус, способный превратить твой комп в тостер (о Боже!). Билл клонировал себя до нескольких биллионов экземпляров, и теперь их (Биллов) цель - распространить свой гнусный вирус, замаскированный под популярную ось. Ты как


Спецвыпуск Хакера, номер #005, стр. 005-026-3, NIX'ОИДНЫЕ ИГРУШКИ

NIX'ОИДНЫЕ ИГРУШКИ

Спецвыпуск Хакера, номер #005, стр. 005-026-3

сисадмин должен предотвратить это безобразие!". Теперь ты понял, о чем речь в этой гаме? Понял, кто такой Билл и что это за ось такая популярная, способная превратить комп в тостер? На каждом уровне в твоем ведении небольшая сетка с компами и установленными на них хорошими осями: маки, полумухи, биосы и всякие nix'ы. И каждый раз целая туева хуча чуваков в очках и с дебильной прической, несущих на своих горбах винды и силящихся затроянить машины, атакует твою

сеть. Тебе надо их.. давить! Давить! ДАВИТЬ!!! Убей, убей их всех!!!

Я оторвался по полной программе и дошел до четырнадцатого уровня. Отомстил Биллу абсолютно за все мучения и моральные травмы. Наслаждение неописуемое! Играть интересно на более-менее высоких уровнях - биллов становится так много, что напрягаться приходится порядочно. Кстати, если некоторое время погамаешься в xBill, будешь щелкать мышой со сверхзвуковой скоростью - все друзья будут завидовать.

Все, что мы тут успели посмотреть, приблизительно четвертая часть от всех гам, обычно идущих с линухами. Главное - не забудь при установке отметить пункт "Гамесы для Иксов"!!! Кстати, существует еще и пункт "Гамесы для консоли". Советую заглянуть и туда :). Только не ругайся потом, что я тебе совсем старье подсунул. Все, пока.


Спецвыпуск Хакера, номер #005, стр. 005-028-1, За что я люблю Юникс

За что я люблю Юникс

Спецвыпуск Хакера, номер #005, стр. 005-028-1

Andrew Fadeev (mika@farlep.net)

Здарова тебе, начинающий Юниксоид! Вот сидишь ты, журнальчик читаешь и, наверное, думаешь: и чего это они на этих Линуксах и прочих BSD'ях помешались... Вот у меня стоит Windows - и ничего, работает себе (иногда :)). Но, поверь мне, недолго ему осталось. Когда ты этот журнал прочитаешь, у тебя уже будет стоять идеально работающий Линукс. Впрочем, здесь я не буду рассказывать тебе про всякие технические штуки и настройки, а расскажу, за что я и многие другие любят Юникс.

Причина намбер ван - распальцовочная

Многие считают, что такая повальная любовь к Юниксам всех мастей - это следствие нежелания пользоваться продуктами МелкоСофт. Может быть, такие тоже есть, я не спорю - когда пишешь большой документ и Окна глюкают так, что его потом не восстановишь, можно до чего угодно дойти :). Правда, большинство виндо-ненавистников переходят на Юникс не потому, что они не могут более переносить творение Большого Б, а просто чтобы картинно раскинуть пальцы перед друзьями. Под мастдайкой, мол, одни ламаки сидят, настоящие кул-хацкеры юзают исключительно *никсы! Но настоящими Линуксоидами становятся по-другому. Это мучительный процесс, сопровождаемый потерями данных, испорченными нервами и бессонными ночами, проведенными в попытках определить, почему же ничего не работает ;).

Причина намбер ту - разрыхлительная

Я люблю Линукс за то, что в отличие от Виндов, где все спрятано как можно дальше, здесь все для людей. Все файлы настроек в текстовом формате, с пояснениями. Вместе с самой системой (и большинством программ) поставляются исходники. Вот уж поле для бурной деятельности! От простого "здесь был Василий Пупкин" до реальных изменений в системе под себя. Средств разработки и различных компиляторов под Linux достаточно. Среди них встречались названьица, о которых я до знакомства с Пингвином и не слышал :). Для любителей стильных "междомордий" приготовлены классные графические интерфейсы. То, что может GNOME, окошкам-от-Билла и не снилось. Максимум, что ты можешь изменить в винде, это цвета, шрифты и иконки. А вот ГНОМ (или KDE) могут измениться до неузнаваемости. Прикольно - у каждого на компьютере совершенно другой, но абсолютно удобный интерфейс. Только вот проблемы с совместимостью. Приходишь к другу, а куда нажимать :)?

Причина намбер сри - протокольная

Так, мы же Хакеры? А что хакеру делать без Сети? Для ЮНИКС'ов TCP/IP - родной. То есть с тем же провайдером на той же линии ты будешь иметь чуть более быструю скорость прокачки. Ведь вместо глючного Winsock'а здесь нормальная поддержка протокола. Да и системы безопасности куда лучше. Через 139 порт не достанут, трояны обламываются, а вирусов под Линукс почти нет. Так что в IRC я всегда под Linux сижу. Мне ICMP кривой пошлют, а система его профильтрует (фильтруйте базар, господа-товарищи! ;)).

Причина намбер фор - не"зависящая".

А вот мы подобрались к самому интересному - к тому, что я, наверное, больше всего люблю в Линуксе. Это практически полная непотопляемость. Если какая-то программа и повисла настолько сильно, что заблокировала консоль (дисплей Иксов), то у меня всегда есть еще одна консоль, и я могу корректно завершить программу или перезагрузить так, чтобы потом не было проблем. И никаких тебе "голубых экранов"! Линукс для меня - такая крепость, в которой я себя чувствую безопасно и в сети, и при работе с глючными программами. В Линуксе все сделано для меня, а не так, как было проще программистам. Новичков часто пугают слабой поддержкой железа - неправда. Я еще не встречал железяки, для которой не было бы "драйверов" под Линукс. Надо только искать.


Спецвыпуск Хакера, номер #005, стр. 005-028-2, За что я люблю Юникс

За что я люблю Юникс

Спецвыпуск Хакера, номер #005, стр. 005-028-2

Причина намбер файв - ГАМЕРическая

Мультимедиа тоже на высоте. Линукс не так требователен к железкам, поэтому MP3'шки можно играть и на слабенькой машине. Да и гамеру тоже хорошо жить с Пингвином. Для многих популярных игрушек написаны бинарники под Линукс. А игры, разрабатываемые специально под эту систему, тоже очень интересны и оригинальны. Ну и, в конце концов, как можно плохо относиться к системе, у которой в качестве логотипа такое дружелюбное животное - пингвин? Или FreeBSD - замечательный Чертенок. Не то что творение БГ (не получается без сравнений), такое тебе тюремное окошечко-решеточка :), навевающее воспоминания о бессмертном стихотворении Пушкина...


Спецвыпуск Хакера, номер #005, стр. 005-029-1, За что я ненавижу Линукс!!!

За что я ненавижу Линукс!!!

StF [StF@mail.ru]

Спецвыпуск Хакера, номер #005, стр. 005-029-1

Возникает вопрос - чем же мне Линукс не нравится? И почему я его все еще использую (и буду использовать!)? Что же, расставлю все точки над ё.

Костыляндия

Первое, что не устраивает меня, - так это неудобство установки. Именно неудобство, а не недружелюбность. Имхо, недружелюбность - это когда из текстовой строки линкусовым fdisk работаешь. Особенно это, конечно, в первый раз напрягает. «В чем же неудобство установки?» - спросишь ты? Вроде и графическая, и конфигурацию сама определяет, и вообще в режиме новичка (я о Mandrake) вопросов по минимуму задает. НО! После установки всего необходимого жесткий диск похож, скорее, на структурированную свалку, чем на рабочее место. Все честно по каталогам, конечно, разложено - базара нет, но места это занимает более гига после "отшлифовки". Много в Линуксе "однотипных" по производимым задачам программ. Ну зачем нужно несколько Windows Managers, простеньких редакторов картинок и прочих фекалек, - причем, схожих по возможностям! Каждая программа использует свою библиотеку - в итоге свободное место на диске уходит сквозь пальцы. «Так ведь это же альтернатива, - скажешь ты, - свобода выбора, так сказать...» И будешь прав. Частично. Я не против мирного существования кучи прог (Боже упаси!), пущай существуют - но не на моем винте! Неужели так сложно сделать установку по умолчанию, чтобы инсталлились функционально - необходимые программы в ЕДИНСТВЕННОМ числе. Одна программа для чтения почты, одна для редактирования изображений... Если мне будет надо - то я смогу удалить/доставить нужный мне софт. Какой же критерий должны выбрать составители дистрибутива при подборе такого набора прог? Их функциональность. Причем, если сделать несколько видов установки (например, как в Suse - только можно побольше) и по каждому типу установки написать по категориям программ дополнительную инфу, то удобнее и быстрее будет устанавливать. Ну, на крайняк, можно поставить ядро, шелл и минимум, необходимый для ручной установки пакетов.

Бесхозяйственность

И нормального офиса нету! Под нормальным я подразумеваю тот, который понимает документы word97, word-6.0, rtf. К сожалению, только последний формат понимается более менее широко - это редакторы Ted, Word perfect 7.0, 8.0, StarOffice, Applixware. Для трех последних необходимо ставить win1251 шрифты, если надо сделанные в них документы таскать в M$-WIn. Ибо в мастдайном Excel очень забавно смотрится таблица в KOI-8, сделанная в старофисе :0). Разве что о Koffice ничего плохого/хорошего пока сказать не могу, ибо он under development.

Такое малое количество редакторов объясняется в первую очередь (опять же имхо) сложностью формата. Я на днях посмотрел описание формата rtf-файлов - так чуть в обморок не упал, это тебе не txt (прочитать любопытных отсылаю к http://www.halyava.ru/document/ind_form.htm - описание форматов разных файлов). Конечно, некоторые особо продвинутые люди могут вспомнить про славную прогу wv-, позволяющую конвертировать doc2html, но и тут облом. Когда я в MandrakeRE попытался ею сконвертить файл с описанием rtf-формата (скачанный по ссылке, написанной выше, он около ~600 кило весит!), то получил html размером 2 мега, но и это цветочки. Ягодки полезли, когда я его посмотрел в браузере, - все шрифты просто уплыли в никуда. В общем, он был далек от оригинала.


Спецвыпуск Хакера, номер #005, стр. 005-029-2, За что я ненавижу Линукс!!!

За что я ненавижу Линукс!!!

StF [StF@mail.ru]

Спецвыпуск Хакера, номер #005, стр. 005-029-2

Картинки

Пойдем дальше - графический редактор. Да, Gimp - это, конечно, клево, но я

ХОЧУ фотошоп. Потому что я к нему привык, там "все на своем месте" - ну, ты

меня понимаешь :0). Это такая же болезнь, как vi&emacs. Но в моем случае

фотошоп еще и более функционален.

И сама ты дура, и собака у тебя грязная

Ну ладно, ладно... Софт, может, нормальный напишут, но вот чтобы его

анинсталлить - надо постараться. Обычно почти сразу после установки начинается

вычищение ненужных прог (из 1000 пакетов всегда что-нибудь лишнее да пролезет!), и это затягивается надолго (после первой установки Линуха я в течение полугода выкидывал лишнее, ибо по жадности своей выбрал полную установку :0) ).

А вообще - проблема с однотипными прогами хорошо описана на linux.org.ru, посему я этот ресурс процитирую. Предположим, что после установки у нас на харде оказалось 20 калькуляторов (редакторов, e-mail-клиентов, еtс). Ну зачем нам 20 калькуляторов? Предлагаю пользоваться одним, а 19 - убить... :0)

"Проблема решается просто, если эти калькуляторы независимы. Сносишь 19 -

оставляешь себе тот, который нравится. Проблемы начинаются, когда модный

нынче rpm соберут так, что пяток калькуляторов взаимно зависит еще от тучи

библиотек, и те, в свою очередь, еще на что-нибудь перекинуты. Но это уже проблемы rpm и тех, кто их собирает (RedHat). Линукс как ядро тут ни при чем."

В последней фразе и есть сакрально-монументальный смысл - именно благодаря качеству ядра я до сих пор Линукс и юзаю. Надежность и стабильность - это да. Напоследок могу оставить пару ссылок - фильдеперсовые линуксоиды этому будут рады:

1. ftp://metalab.unc.edu/pub/linux/distributions - разного рода дистрибутивы - размером от 1 дискеты до нескольких сидюков.

2. http://www.linuxfromscratch.org/ - как сделать дистрибутив САМОМУ. Минимальные требования для этого:

a: свободное время

b: девайс - руки прямые PnP.

Я давно собирался написать подобную статью - но не доходили руки. А иногда просто наталкивался на статьи типа "Чем Линукс плох" (смотри, например, http://inter.net.ru/18/11.html), и меня пропирало на веселуху, ибо по-другому такие тексты действовать на психику не могут (спросите у Дока Добрянского ;-)). Так, о чем это я?


Спецвыпуск Хакера, номер #005, стр. 005-030-1, ТЕКСТОВЫЙ РЕДАКТОР ДЛЯ NIX'ОИДА

ТЕКСТОВЫЙ РЕДАКТОР ДЛЯ NIX'ОИДА

Спецвыпуск Хакера, номер #005, стр. 005-030-1

Ruben aka Noah (noah@inbox.ru,UIN 983332)

Священная война

Идет война. Нет, не между Россией и Украиной :). Жестокая, кровопролитная война идет среди nix'оидов. Я это тебе совершенно серьезно говорю! Разъяренные nix'оиды, объединившись в несколько крайне враждебных друг к другу группировок, готовы в буквальном смысле порвать на куски все, что еще шевелится и имеет смелость не соглашаться с их собственным мнением. А знаешь, в чем причина? В софтярных пристрастиях. Это довольно распространенное явление в рядах людей, часто юзающих комп. Нечто подобное тебе знакомо по войнам между юзерами двух самых слоновых браузеров: Нетшкафа и маздайного Ишака.

В нашем же случае война идет по поводу текстовых редакторов. Конечно, среди nix'оидов происходит много различных войн: по поводу разных шеллов, по поводу разных дистрибутивов, по поводу GNOME и KDE... Но война текстовых редакторов, пожалуй, самая острая и напряженная. Наверное, потому, что текстовый редактор - абсолютно необходимая для nix'оида вещь. Практически любая работа так или иначе связана с редактированием текста: настройка оси (nix в идеале настраивается отладкой конфигурационных файлов), написание скриптов, прог, мыла и прочее. На сегодняшний день основные боевые действия ведутся между юзерами редакторов vi и emacs. Но, кроме них, есть еще целая куча других представителей "семейства редакторовых" :). И практически все они поставляются вместе с линухой. Если, не дай Бог, дистрибутивщики забудут включить в свой дистрибутив хоть один мало-мальски известный редактор, его приверженцы завоют голодными волками и будут так долго и упорно обкладывать этот дистрибутив фекальками, что он под конец действительно в них утонет. Тебе, амиго, я посоветую ради эксперимента сотворить следующее: читай эту статью до конца, выбери себе какой-нибудь редактор, возьми из чулана лом/гвоздодер/кувалду, выходи на улицу и начинай размахивать инструментом и выкрикивать хвалебные фразы в пользу своего редактора. Скоро к тебе присоединится еще несколько тебе подобных, а чуть позже перед вами выстроится такая же группа товарищей, только уже за другой текстовый редактор. А дальше, let's Quake!!! Выброс адреналина в кровь гарантирован. Но это позже, а сейчас давай смотреть редакторы. Многие из них очень сложные, поэтому я для каждого редактора буду объяснять, как открыть существующий файл,

как создать новый, как сохраниться и как выйти.

Vi (vim, elvis)

Авторитетнейший и очень древний текстовый редактор. Наверное, не ошибусь, если скажу, что большая половина nix'оидов все-таки юзает vi. В линухе нет "чистого" vi, так как это коммерческая прога. Зато есть клоны vim и elvis (зависит от дистрибутива), которые отличаются от vi только дополнительными возможностями и фичами. Освоить vi непросто. Он работает в двух режимах: режим команд и режим редактирования (это характерно для многих nix'овых редакторов). Введи команду

vi <имя файла>

Если файл с таким именем уже есть, то он откроется перед тобой, а если нет, то перед тобой откроется новый файл с этим именем. Ты в режиме команд. Чтобы перейти в режим редактирования, нажми кнопарь "i" на киборде. Теперь можешь вводить всякий текст, править, удалять. Скролить можно батонами курсора. Заметь, что при вводе текст автоматически не переводится на новую строку. Для этого надо в конце каждой строки жать Enter. Для сохранения файла или выхода надо перейти в режим команд - жми Esc. Вводишь двоеточие, потом команду.


Спецвыпуск Хакера, номер #005, стр. 005-030-2, ТЕКСТОВЫЙ РЕДАКТОР ДЛЯ NIX'ОИДА

ТЕКСТОВЫЙ РЕДАКТОР ДЛЯ NIX'ОИДА

Спецвыпуск Хакера, номер #005, стр. 005-030-2

:q! - выйти из vi

:w <имя файла> - сохранить файл

:wq <имя файла> - сохранить и выйти

:u (можно без ":") - отменить последнее действие

Это далеко не все команды, но для повседневных нужд хватит. Существует версия vi для X. Отличается наличием менюхи, с которой можно работать мышом.

Emacs

Еще один зачинщик войн. Намного моложе vi. Emacs работает под X, но есть версия и для консоли. В отличие от vi имеет меню, из которого можно выполнять почти все команды. Поводи крыской по этим менюхам для ознакомления. Там всякие Open File, Undo, Print, Copy, Past, Clear, Exit и прочее. Так как ты работаешь в X, можно не вводить команду (как в консоли), а запустить emacs, найдя его launcher в системной менюхе. Теперь выбери File -> Open File. В командной строке редактора (внизу окна) введи имя директории, из которой хочешь открыть файл. В окне появятся все файлы из этой директории со своими атрибутами. Установи курсор на имя нужного файла и жми Enter. Сохраниться, создать новый файл и выйти можно из меню. В emacs можно работать с несколькими файлами сразу. Открой еще один файл из менюхи, выбери File -> Split Window. Emacs знает (умеет подсвечивать синтаксические элементы) языки C, Lips, TeX (о TeX'е позже). Если поставишь свеженькую версию, он будет знать еще и перл с питоном. Освоить базовые возможности emacs несложно, но... Там столько всяких наворотов и функций, что без долгой практики работы с этим редактором полностью его не взъюзнешь.

Jed

Если ты занимаешься кодингом, то этот редактор твой! Знает кучу всяких языков - даже перечислять не буду. Есть и консольная версия, и версия для X. В командной строке набирай Jed (можно с именем файла). Если нажать Esc, а потом, зажав Shift, два раза стукнуть по батону "?", наверху откроется меню. Нажимая цифры, соответствующие пунктам меню, можешь передвигаться по нему. Вернуться на позицию выше - Space. Jed умеет косить (эмулировать) под разные другие редакторы (emacs, Brief, WordStar, EDT). Осваивается легко.

Ed

Еще более древний редактор, чем vi. Вокруг него почти нет шумихи. Наверное, потому, что все его истинные приверженцы либо умерли от старости, либо стали настолько опытными nix'оидами, что впали в нирвану, и теперь им совершенно по фиолетовому барабану, где, как, чем, в чем редактировать текст и редактировать ли его вообще. Про то, как осваивается ed... А оно тебе надо, как он осваивается? Забей, эта прога свое уже отжила. Да и вообще, тебе надо набирать какой-то текст? Зачем? И какая на фиг разница - в чем? Брось это дело! Давай лучше примем пятую ассану из брахма-пранаямы и воссоединимся с космосом!!! :)


Спецвыпуск Хакера, номер #005, стр. 005-030-3, ТЕКСТОВЫЙ РЕДАКТОР ДЛЯ NIX'ОИДА

ТЕКСТОВЫЙ РЕДАКТОР ДЛЯ NIX'ОИДА

Спецвыпуск Хакера, номер #005, стр. 005-030-3

Pico

Очень хороший и простой в обращении текстовый редактор. Ты его освоишь за пятнадцать минут. Очень советую, если ты недавно поставил себе линуху. Внизу менюха. Жми Ctrl и букву для доступа к соответствующему пункту менюхи. Когда нужно открыть новый файл, аккуратный список с содержанием директории выпадает в нижней части экрана. Млин, все так просто, что я тебе и рассказывать ничего не буду. Просто запусти его командой pico (можно с именем файла) и делай свою работу - никаких проблем не возникнет.

GXEdit и GEdit

Два очень похожих редактора под X. Присутствуют все виндовые примочки. Вообще это довольно мощные редакторы: поиск, замена, копирование, выделение - все в ассортименте. Естественно, можно работать с мышом. На мой взгляд, GEdit получше, чем GXEdit, но выбирать предстоит тебе. В GEdit очень приятно реализована работа с несколькими файлами: сколько файлов - столько закладок в левой части окна, нажал на закладку - получил желаемый файл. Зато в GXEdit под рукой все функции, связанные с мылом и конфами. Бери один из этих редакторов, если ты пришел в линуху из маздая и тебе неохота менять привычки.

TeX

Это не текстовый редактор. Юзай TeX, если тебе надо верстать сложные математические и другие формулы, таблицы, сопроводительную документацию

к софту и прочие серьезные вещи. TeX используют во всяких издательствах - например, для верстки научной литературы. TeX называют языком программирования текста. Он немного похож на html. Юзают TeX следующим образом: пишешь в обычном текстовом файле всякие тег-подобные команды, потом пропускаешь этот файл через TeX и на экране получаешь отформатированный текст. Короче говоря, вещь это весьма сложная, и за два дня ее не освоить. Но если тебя прямо-таки пробило на TeX и никакие текстовые редакторы не удовлетворяют - мыль, помогу тебе разобраться в нем.

Ispell

Еще пару слов о ispell, и я ухожу. Ispell - это прога для проверки орфографии. Натрави ее на текстовый файл, и она тебе выдаст слова, которые на ее взгляд содержат ошибки, ну и, как водится, предложит выбрать правильные варианты. Ispell можно запускать почти из всех текстовых редакторов (из меню), но на всякий случай дам тебе команду:

ispell <имя файла>

Жми Space для того чтобы пропустить слово, циферку - для замены на соответствующее из списка предложенных, "x" - для выхода.

Вот и вся любовь

Вот такие пироги! Надеюсь, хоть чуть-чуть помог тебе разобраться в куче эдиторов-редакторов, и теперь ты сможешь выбрать для себя что-то. Пиши, если что - помогу. До встречи.


Спецвыпуск Хакера, номер #005, стр. 005-033-1, Сага о пингвинах

Сага о пингвинах

Спецвыпуск Хакера, номер #005, стр. 005-033-1

Холод (holod@xakep.ru)

Рука помощи "Хохломе"

За окном падал теплый снег. Зима в этом году началась рано, и как-то мягко - город был укутан белизной с головы до ног, гололеда не было, соль на улицы сыпать наконец-то перестали. Мы с Покровским сидели в "Китайском Летчике", и тянули кофе. Было тепло и уютно, играл какой-то мексиканский народный ансамбль, вокруг слонялись - нам, впрочем, ничуть не мешая - разные пьяные и талантливые люди.

- Во, Холод, видал? - Покровский протянул мне очередной газетный лист. - Опять про них! Уже, по-моему, во всех московских газетах написали!

Я взял газету. На первой полосе, огромным шрифтом было написано:

"Грандиозные полярники Чук и Гек на научно-исследовательском судне "Хохлома" терпят бедствие во льдах Антарктики! Экспедиция ООН по спасению пингвинов под угрозой!". И ниже, маленьким шрифтом: "Источник массовой пропажи пингвинов в снегах Антарктики так и не удалось обнаружить! Единственная экспедиция терпит крушение и вынуждена зимовать во льдах! ООН в панике".

- Вот тебе и на, - сказал Серега грустно. - Тоже мне, отпуск взяли. "Мы поедем, посмотрим живых пингвинов в природных условиях"! Чучи. В зоопарк ходить надо! И что нам теперь делать? У меня номер горит!

- Вот у тебя номер горит, а им там, наверное, жрать нечего. - Я старался казаться серьёзнее. - Ну ладно, я тебя понял. Ты, Серега, лети за ними в Антарктику со спасательной экспедицией, а я, так и быть, пригляжу за журналом...

- Не, Холод, я не могу. Вот... всю жизнь мечтал Антарктику посмотреть - а сейчас не могу. У меня совещание в понедельник. И вообще, я собирался машину ремонтировать - ей уже шестнадцать лет, и у неё... - тут он сделал убедительную паузу - ...коробка передач отвалилась. Вчера прямо. Так что завтра я её на трос, и - в гаражи, к умельцам. Аки бурлак, в одну лошадиную силу. А ты не расстраивайся, с тобой Центнер поедет, наш самый добрый редактор...

- Погоди, Серега. Поедет КУДА? - я поежился, предчувствуя очередные приключения на свою задницу.

- Ну как куда? Что ж теперь, Чуку и Геку зимовать в Антарктике? Ставлю вам с Центнером ответственную задачу: добраться до Антарктиды, забрать Чука и Гека, и вернуть их сюда. Да, кстати. Ты теплое пиво любишь?

- Нет. - я представил себе теплое пиво, и мне почему-то не понравилось.

- А к женщинам летом на южных курортах пристаешь?

- Серег, ты обалдел? Я ж женатый человек!

- Значит, не пристаешь. И Центнер, наверняка, тоже не пристает. Тогда сейчас в Антарктиде как раз ваш сезон! Очень хорошо! Засчитываю вам эту поездку, как отпуск. - Покровский явно был доволен собой.

Еще через пару часов мы с Центнером ака Климом Собакиным созвонились, и договорились о встрече. Он, сославшись на то, что в Антарктике холодно, пообещал взять с собой восемь банок тушенки, две банки сгущенки, два тулупа, валенки, санки, и ватные штаны. На мне же лежала не менее ответственная задача: раздобыть пачку соли, пачку чая, пакетик сахара (кубиками), взять восемь коробков спичек, и - на всякий случай - пулемет Дегтярева, чтобы отбиваться от воинственных туземцев-оленеводов (его мы выкопали ещё ранней осенью на Центнеровском дачном огороде под Волоколамском, не без помощи металлоискателя Доктора Добрянского), если таковые отыщутся. Пулемет был старый, ржавый, с гнутым дулом, патронов к нему не было, и неизвестно, можно ли было из него стрелять, но зато выглядел он крайне угрожающе. Правда, возникала проблема: как пронести эту штуку через таможню в Шереметьево-2, но Центнер сказал, что это он берет на себя. Ещё, памятуя о чистосибирском прошлом моих предков, я прихватил с собой огромный шмат сала. Встречу на пороге аэропорта мы назначили в восемь утра следующего дня.


Спецвыпуск Хакера, номер #005, стр. 005-033-2, Сага о пингвинах

Сага о пингвинах

Спецвыпуск Хакера, номер #005, стр. 005-033-2

Как с помощью пива решить все проблемы

Без четверти восемь я вылез из машины, подошел ко входу в зал ожидания, и, притопывая, чтоб не замерзнуть, принялся ждать. Центнер должен был появиться с минуты на минуту. За моими плечами бултыхался огромный рюкзак, из которого неуклюже торчал замотанный в целлофан ствол пулемета Дегтярева. Через дверь туда-сюда сновали местные забулдыги в ободранных пальто и с синими мордами, бегали грязные босые дети в тюбетейках - по виду, беженцы из какой-то очередной горячей точки.

- Ну что, поехали? - Клим Собакин появился неожиданно, и как-то незаметно, что было довольно странно при его комплекции - парня крупнее и мощнее на вид я как-то раньше не встречал, а гигантский рюкзачище за плечами только прибавлял ему серьёзности, к тому же, в одной руке он держал санки, а в другой ящик пива, неуклюже перемотанный проволокой. - Ты уже в билетных кассах был?

- Нет ещё. Слушай, а туда вообще-то самолеты летают? Я что-то не припомню такого рейса: "Москва - Антарктида".

- Ща узнаем. - Центнер был, как всегда, спокоен. - Пошли в кассы.

Мы вошли в зал ожидания, и направились к билетным кассам. Увиденное и услышанное там нас сильно разочаровало: во-первых, молоденькая кассирша поведала нам, что первый раз слышит о прямых рейсах в Антарктиду из Москвы, а во-вторых, она даже не представляет, во сколько обойдется частный рейс на этот Богом забытый материк. Правда, в её словах было и кое-что обнадеживающее: в частности, выяснилось же, что рейсы частных авиакомпаний всё-таки практикуются даже на Антарктиду.

Через пару минут мы уже стояли у окошка кассы частной авиакомпании "Вопящий Орел". Слоган над рекламой авиакомпании гласил: "Вопящий Орел - мы доставим вас в любую точку мира на наших сверхсовременных самолетах с уникальным качеством сервиса! Цены договорные"...

- Куда-куда? В Антарктиду? Это я не знаю, если пилота уговорите. - страшная как крокодил, кассирша "Вопящего Орла" была явно заинтригована. - Вы каким классом хотите лететь?

- Нам бы чего попроще, - объяснил я. - Денег мало.

- Тогда точно к пилоту. У нас сейчас всё равно только один человек свободен. Коляяя!!! - завопила она полубасом куда-то внутрь помещения. - К тебе люди пришли! - она снова обернулась к нам. - Второй пилот сейчас занят - повез отару страусов в Сибирь - а этот свободен. Он странный немного, но вы на это не смотрите. Хороший пилот, лучший самолет в аэрокомпании. У нас, правда, их всего два, но это не важно. Они оба хорошие самолеты, с крыльями там, и вообще. Хотите семечек?


Спецвыпуск Хакера, номер #005, стр. 005-033-3, Сага о пингвинах

Сага о пингвинах

Спецвыпуск Хакера, номер #005, стр. 005-033-3

Мы дружно отказались.

- Ну ладно, тогда проходите сюда. - Кассирша открыла нам дверь рядом с окошком в кассу, и мы прошли к ней в каморку. - Сейчас он подойдет. Вообще-то, он стриптизер по профессии, ну там, в клубах танцует, но и пилот - вполне...

Неожиданно внутренняя дверь в каморку открылась, и вошел на удивление знакомый гражданин, ростом с небольшого дядю Степу.

- Аватарыч! - я выдохнул и потерял дар речи. Собакин тоже выглядел обескураженным.

Да, это был Аватар. Облаченный в кожаные штаны, косую кожаную куртку, летный шлем и почему-то сапоги на высоких каблуках, он выглядел весьма неординарно.

- Тээкс, граждане, куда летим? Ой... Холод? Центнер? Вам тут чего?

Последовала небольшая пауза. Первым заговорил Центнер.

- А мы и не знали, что ты у нас летчик. И вообще...

- Эгей, ребята! Вот уж не подумал бы, что придется вас катать! Ну, что за рейс? Круг вокруг аэропорта? Или в Волоколамск, на конспиративную дачу?

- Нам бы, Аватар, в Антарктиду... - я старался показаться многозначительным. - Там, понимаешь, наши Чук и Гек терпят бедствие... а мы - спасательная операция.

Аватар остолбенел.

- Да. Знаю. Читал. Но чтоб вы... туда... Да ещё со мной... Ну ладно. Разберемся сейчас.

Мы повеселели.

- Значит, так. - Аватар нахмурился, взял бумажку, ручку, сел, и стал считать. - Топлива одного - две тонны, а я только что полные баки залил, плюс амортизационные расходы, страховка, то-се, ещё пожрать надо с собой купить... Много денег получается, парни! И для самолета - знаете, какая нагрузка? Офигеть можно!

Тут я понял, что во-первых, столько денег мы всё равно с ходу не добудем, а во-вторых, если срочно не сделать чего-нибудь этакого, спасательная экспедиция накроется медным тазом. А Центнер вдруг сказал:

- Аватар, деньги - вопрос третий. Есть у нас деньги. - я обалдел, а Центнер продолжал говорить. - И пиво у нас есть. Пойдем, покажешь самолет, а заодно пивка попьем, и маршрут обсудим. - Он тряхнул ящиком пива в огромной лапе, и бутылки звякнули. У Аватара загорелись глаза.

- Я сейчас, Маш, - сказал он кассирше, та понимающе кивнула. Аватар встал, и жестом пригласил нас следовать за ним.

Через небольшую дверь мы попали в длиннющий коридор, который вел через здание аэропорта к летному полю. Первым шел Аватар, за ним - я, а за мной - Центнер, который при этом ковырялся в моем рюкзаке, что-то оттуда явно вытаскивая. Хрустел целлофан.

Мы вышли к самолетам, и я почему-то сразу угадал, на каком нам предстоит лететь. Старый и ободранный "Ан-2", который, по-моему, ещё восстание Сипаев помнил, стоял у самого края парковочной площадки. Номера самолета, естественно, располагал к приятному полету - "013 во". Аватар взобрался внутрь по крохотному трапу, и пригласил нас за собой. Я вскочил наверх, вслед грузно протиснулся Центнер.

- Ну что, и как же пиво? - Аватар присел на одно из шести пассажирских кресел, и с вопросом посмотрел на нас.

- Щас будет тебе пиво, - со спокойной интонацией сказал Центнер, и достал из-за спины пулемет Дегтярева.


Спецвыпуск Хакера, номер #005, стр. 005-033-4, Сага о пингвинах

Сага о пингвинах

Спецвыпуск Хакера, номер #005, стр. 005-033-4

Аватар покачнулся, и упал в обморок.

- Холод, заводи. Двигаем, пока этот не проснулся. А то там, наверное, Чук и Гек совсем замерзли. - Центнер совершенно спокойно уложил Аватара в проход между креслами, снял рюкзак, и занял место второго пилота. Я, все ещё ошарашенный, сбросил с плеч свой, и пролез на кресло командира, принявшись изучать множество переключателей, пытаясь методом тыка завести двигатель. Клим тем временем обнаружил на заголовнике кресла комбо из наушников и микрофона, и нацепил на себя, а затем нажал на первую попавшуюся кнопку на штурвале.

- Да, Николай? - из интеркома раздался уже знакомый голос, и я понял, что Центнер только что вышел на связь с центром управления полетами, и, по совместительству, билетной кассой "Вопящего Орла". - ЦУП и Маша тебя слышат хорошо! Прием?

- Маш, а Маш? Ну, мы тут договорились, - Центнер скривил и повысил голос (теперь, через все аэродромные и эфирные помехи его можно было запросто принять за Аватаровский) - идем на Антарктиду, деньги будут. Да, кстати, Маш, я тебя целую и люблю! И когда вернусь - выходи за меня замуж!

- Коль, тебя какая муха-то укусила? - Маша на другом конце эфира была вне себя от счастья. - Коль, я согласна! Возвращайся скорее!

Центнер выключил связь, и мы дружно заржали. Неожиданно завелся двигатель. Я подергал туда-сюда сектор газа, нащупал педали, и потихоньку стал выруливать на взлетную полосу...

Скатертью дорога

Шел десятый час полета на юг. Сразу после взлета нас попытались догнать два истребителя, но Центнер показал им в иллюминатор пулемет, и они сразу отстали. До южной границы России мы добрались без приключений, дальше тоже прошли по счастливому стечению обстоятельств незамеченными. "Аннушка", как я сразу окрестил наш Ан-2, оказалась удивительно капризной - вне зависимости от ветра её все время потягивало влево, и машине все время приходилось радикально помогать держать курс - рычагов управления триммерами я так и не нашел. Ящик с пивом (точнее, теперь уже из-под пива) опустел, по всей кабине пилота катались из стороны в сторону пустые пивные бутылки - знатный напиток кончился ещё над южной Африкой. Правда, еще пол-ящика мы в Египте выменяли на дозаправку, чтобы гарантированно дотянуть до Антарктиды и вернуться. Правда, последнюю бутылку пива Центнер не отдал мне, и не допил сам - припас её в один из своих огромных карманов, на всякий случай.

Мы с Центнером уже окончательно освоили управление самолетом (хехе, точь-в-точь, как в Flight Unlimited), и потихоньку летели на юг. Океан под нами где-то далеко внизу казался безбрежным, но постепенно горизонт мутнел, завязывался во что-то неопределенное, и вот показался, наконец, вдалеке берег того материка, что до сих пор считается одним из вовсе неизученных человеком.

Аватар икнул и проснулся.

- Это мы уже где? - поинтересовался он. - Вы меня не убьете?

- Нет, - сказал Центнер. - Так, попинаем немного, и без парашюта выкинем. А если уж сам убьешься по дороге - мы не виноваты.


Спецвыпуск Хакера, номер #005, стр. 005-033-5, Сага о пингвинах

Сага о пингвинах

Спецвыпуск Хакера, номер #005, стр. 005-033-5

Мы недружно засмеялись. Аватар вздрогнул, ещё раз икнул и уполз в дальний угол салона. По-моему, он там заснул - по крайней мере, до самого конца пути он молчал в тряпочку и не высовывался.

К тому времени Антарктида уже лежала под нами во всей своей ледяной красе. Всё под крылом было ровным, белым и чистым. Михин включил радио, и начал крутить какие-то, ему одному понятные, ручки.

- О, нашел. - сказал он. - Холод, я их SOS нащупал - ну, "Хохломской". Сейчас дам курс, по моим прикидкам до них километров двести всего.

Центнер дал мне курс, и машина, повинуясь, плавно развернулась. Я снизился до пары сотен метров, и начал разглядывать горизонт. Видимо, мы шли над предполагаемым побережьем материка - кругом лежали льды. Вскоре вдали показались мачты корабля - именно с той стороны, с которой мы и ожидали их увидеть. Правда, километрах в двух от судна с воздуха были четко видны ещё какие-то огни, но по мере того, как мы двигались к "Хохломе", они терялись, и, в конце концов, пропали совсем - как если б их притушили специально. Мы развернулись над мачтами "Хохломы", и пошли на посадку.

Тайна Полярной Экспедиции

- Пусто. - заключил Центнер, когда мы осмотрели корабль. - Передатчик молотит SOS на последнем издыхании, и никого. Странно. Давненько отсюда все свалили - ни еды, ни воды...

- Ага. И ни Чука, ни Гека. - заключил Аватар. После посадки он успокоился, и даже согласился ("ну, раз уж такие дела") осмотреть "Хохлому" вместе с нами. Высоченные каблуки здорово мешали ему передвигаться по снегу, да и на палубе он чувствовал себя, как корова на льду. - Ну, что делать будем?

- Ну что-что? - сказал я. - Ты, Аватар, как наименее мобильный, со своими каблучищами, останешься караулить самолет. А мы с Центнером пойдем, и изучим, что это за огни в километре отсюда мы видели на подлете.

На том и порешили, и покинули пустую "Хохлому". Аватар засел караулить свою "Аннушку", а мы с Центнером, переодевшись в тулупы и валенки, поперлись в сторону предполагаемого расположения пресловутых огней.

Идти пришлось недолго. Через полкилометра я наткнулся на занесенную снегом колючую проволку.

- Похоже на происки Американской Военщины. - сказал Центнер. - Что дальше?

- Идти надо, - грустно сказал я.

И мы пошли дальше - тем временем, местность становилась какой-то на удивление холмистой. На одном из белоснежных холмов темнело странно серое пятно. При ближайшем рассмотрении оно оказалось дверью с электронным замком. Вокруг было здорово натоптано. Звонка, естественно, не было, и мы решили просто постучать. Открыл щуплый мужик в форме, по виду - охранник, и, ничуть не удивившись нашему появлению, по-английски заявил:

- Плиз, интер ё логин анд пассворд.

Логин - Центнер, пассворд - гонобобель. - сказал Центнер грозно.

- Юзер анонимус. - скромно заявил охранник.

- Анонимус? А вот я тебе сейчас дам - анонимус! - грозно заявил Михин.

- Донт андерстенд, - промямлил секьюрити, но было поздно. Центнер мягко дал ему по голове кулаком. Охранник тихо охнул и упал.

Мы зашли внутрь, и втащили за собой тело. Центнер обыскал его. Перед нами оказались: зажигала "Zippo", пачка "Беломора (с логотипом Х - явно из запасов, находящихся ранее на борту "Хохломы"!), презервативы "Blue Moon" (да, женщин в Антарктиде явно не хватало), и брелок со странной связкой пронумерованных электронных ключей - каждый с эмблемой "Микрософт", что повергло нас в недоумение.


Спецвыпуск Хакера, номер #005, стр. 005-033-6, Сага о пингвинах

Сага о пингвинах

Спецвыпуск Хакера, номер #005, стр. 005-033-6

От двери внутрь снежного холма вел длинный коридор с бетонными стенами. Мы старались идти тихо, но каждый шаг отдавался в стенах гулом. Вдали горела единственная лампочка.

- Холод, ты только глянь на это! - Михин уже стоял под ней, и глядел куда-то вниз. Я подошел, и заглянул ему через плечо.

Под нами была тюрьма - точнее, решетчатая крыша камеры. А в камере на нарах сидели ободранные, грязные но живые - Чук и Гек, полярники - экспедиторы!

- Эй, ребяты! Алле! - зашипел я вниз. Посмотрите наверх!

Те оглянулись.

- Упс, Чук, канаем на нары - баги полезли, не иначе! Уже и на хазе, поганые, цепляют! Пырни ребут! - Чук и Гек, явно приняв нас на первый взгляд за плоды своего больного воображения, жутко испугались, и поползли на другую сторону камеры.

- Сюда смотрите, раздолбаи! - голос Центнера произвел на Чука и Гека оздоровляющее впечатление. - Мы за вами приехали!

- Центнер, ты что ли? - Чук пришел в себя первым. - А с тобой кто? Холод?

- И Аватар в самолете! - тихо шикнул им в ответ я. Мы вас домой заберем! Где вход в камеру?

- Здесь, внизу, только ключи нужны! - завопили радостные пленники. - Мы уже месяц тут сидим! Что так долго не прилетали-то?

Центнер кинул вниз связку ключей охранника. Чук и Гек кинулись на неё одновременно, и стукнулись лбами.

- Харош там внизу шуршать, вылезайте! - крикнул я. - Как нам к вам пройти?

- Дальше по коридору! Там лестница есть! - хором крикнули пленники, пробуя ключи.

Мы с Центнером ринулись вниз. И вправду, вход в камеру оказался там, а рядом стояли жутко довольные Чук и Гек.

- Ну что, уходим? - поинтересовался я. - Чего ждем-то? Бегом наверх, и к самолету!

- Подожди! - крикнул Гек. - Так просто уйти нельзя. Тут ещё полно пленных!

- Это каких же это пленных? - поинтересовался Центнер. - Кроме вас на Хохломе никого не было!

- Черт возьми, ребята, у них тут половина всей популяции Антарктических Пингвинов! - Чук был вне себя от гнева. - Мы приехали, чтобы узнать, куда деваются птицы, и вот что мы теперь знаем...

И рассказал удивительную историю.

Оказалось, что Микрософт ещё в восьмидесятых годах построила в Антарктике лабораторию по изучению пингвинов. Дело в том, что структура операционной системы Юникс, которую Микрософт жутко ненавидит, была построена по образу и подобию системы кровообращения антарктического пингвина - именно поэтому эта нелетающая птица стала символом некоторых разновидностей Юникса. Микрософт очень хотела узнать секрет популярности Юникса, и не без основания полагала, что он базируется именно на особенностях строения, заимствованных у живых пингвинов. Но убивать животных в целях изучения в Америке, как и во многих других странах, запрещено. Так и возникла эта лаборатория. Здесь каждый день гибли сотни пингвинов, которых спецтранспортом доставляли со всей Антарктики. Основной целью руководителей проекта было создание пингвина - киборга, работающего под управлением Windows CE. Однако пока, к счастью, эта работа не увенчалась успехом. И естественно, когда ООН решила узнать, что происходит, и прислала в Антарктику Чука и Гека, их судьба была предрешена. Их взяли живыми, сняли с корабля и посадили в камеру - те едва успели включить SOS...


Спецвыпуск Хакера, номер #005, стр. 005-033-7, Сага о пингвинах

Сага о пингвинах

Спецвыпуск Хакера, номер #005, стр. 005-033-7

- А ещё нас пытали, - добавил Гек. - Заставляли смотреть на дохлых пингвинов в лаборатории и в питомнике, и ещё тестировать Микрософтовские игры.

Это и впрямь было ужасно. Центнер побледнел. У меня в голове, тем временем, созрел план.

- Ок. Чук, ты знаешь дорогу к питомникам? Много там ещё живых пингвинов?

- Тысячи, Холод! И охраны сегодня никого - их всех увезли на презентацию Windows ME! Удачный денек, правда?

- Точно. Ведите нас в питомник!

Чук с Геком, казалось, только того и ждали. Они сорвались с места, и понеслись куда-то в коридор, в темноту. Нам с Центнером оставалось только последовать за ними.

Множество ответвлений коридора уходило в стороны, а мы бежали только прямо. Неожиданно коридор кончился, и мы оказались в огромной пещере без освещения. Вдоль стен стояло огромное количество клеток. Все они были до отказа наполнены живыми пингвинами. Несмотря на то, что птиц было целое море, вокруг стояла тишина - видимо, все пернатые находились в состоянии глубокого шока.

- Там центральный пост! - крикнул Чук, и указал пальцем в глубину зала.

Там, в нише у стены, стоял маленький терминал без кресла. Я подошел, и ткнул пальцем в кнопку включения монитора. На экране появился план помещения с пингвинами, где сейчас находились мы. Я ткнул пальцем в опцию "Door Lock Control", а потом - "Emergency Open All Doors". И тут двери клеток начали открываться - медленно и бесшумно. Потом часть дальней стены поднялась вверх - открылся огромный выход наружу, в снежную пустыню. На нас дохнуло морозом. Птицы, почуяв волю, заорали, затопали, и ринулись наконец к выходам из клеток, и огромным нескончаемым живым потоком побежали к выходу из помещения. Мы, с трудом держась на ногах из-за этой живой массы, едва передвигаясь, пошли к выходу.

Агент Сидоровский

Воздух пьянил нас - после вонючей пингвиньей тюрьмы было здорово оказаться на огромной равнине, пронизываемой ледяным ветром.

- Пошли к самолету, - гаркнул Центнер, перекрикивая ветер. - А то замерзнем!

Мы поняли вдруг, что ситуация осложнилась. Никто из нас толком не знал, где теперь по отношению к нам находится самолет, и в какую сторону идти. А ветер становился всё сильней и сильней - явно приближался буран. И тут...

Из-за ближайшего холма послышался звон бубенчиков, он всё нарастал, рос, и появилась наконец оленья упряжка. Управлял нартами некто, закутанный в национальные нанайские одежды, и обутый в унты. Упряжь подъехала к нам, и остановилась.

- Такси, однако. Спички, соль, спирт, однако есть? Куда едем, однако?

- Ты самолет видел? - я кричал во весь голос - ветер стал уже совсем сильным, и иначе ничего не было слышно.


Спецвыпуск Хакера, номер #005, стр. 005-033-8, Сага о пингвинах

Сага о пингвинах

Спецвыпуск Хакера, номер #005, стр. 005-033-8

- Железная птица, однако? Большой, однако, с номером 13?

Раздумывать было некогда. Мы плюхнулись в нарты, и заорали:

- Гони!

- А оплата, однако? - абориген не торопился. - Сало, однако? Пиво?

- На. - и Центнер протянул местному колхознику последнюю, заботливо им припасенную, бутылочку пива. - Гони, брателло!

Выяснилось, что по коридорам мы побегали прилично. Ехали до самолета с полчаса. Буран приближался, надо было срочно взлетать. Приблизившись к самолету, мы дружно спрыгнули с нарт, поблагодарили туземца, и побежали к трапу. Аватар уже прогревал двигатель, видно, заметив нашу упряжку вдалеке. Мы прыгнули на трап, влезли внутрь, и уже собрались втащить его за собой, как вдруг...

- Эо, братцы, а я как же? - у порога самолета стоял, обутый в унты, 2poisons в национальном нанайском костюме...

А дома лучше

В "Китайском Летчике" было тепло.

- Да, про Сидоровского я вам зря не сказал. - Покровский смотрел в окно, и отхлебывал кофе. - ФСБ его туда отправило за пол-года до Чука и Гека, но с того момента - ни слуху, ни духу. А тут сразу после вашего отлета выяснилось, что он внедрился в Микрософтовские структуры, и уже готовит эвакуацию пингвинов. В день вашего прибытия в Антарктиду он должен был, замаскировавшись чукчей, подъехать к базе Микрософт и освободить птиц. Но тут вы вмешались...

Мы с Центнером засмущались. Чук и Гек заржали. Ядовитый заулыбался.

- Да ладно, - сказал он, - главное - дело сделано, все дома, всё хорошо... Давайте ещё кофейку возьмем, а?

А за окном падал теплый снег, и кутал столицу в необъяснимые белоснежные шубы...


Спецвыпуск Хакера, номер #005, стр. 005-040-1, Основные команды операционной системы UNIX

Основные команды операционной системы UNIX

zlobnik

Спецвыпуск Хакера, номер #005, стр. 005-040-1

У некоторых пользователей, перешедших на UNIX с Windows и мало работавших до этого времени в dos'e, развивается консолефобия: они стремятся быстрее убежать из командной строки, работать только в mc и иногда вместе обычного login'a вешают gdm для входа в систему. На самом деле человек, знающий в совершенстве все команды UNIX, может гораздо быстрее и эффективнее выполнять некоторые задачи, чем пользователи, работающие с графическим интерфейсом. В этой статье ты познакомишься со стандартным набором команд, которые ты найдешь почти в любой UNIX системе и которые используются пользователями почти при каждом сеансе работы. Приготовься - будет сложно. Ты же мечтал быть настоящим крутым консольным юниксоидом? Ну вот и напросился :). А начну я с самой, на мой взгляд, используемой команды:

ls - печать содержимого каталога.

Флаги команды:

-a вывод списка всех файлов (без этого флага файлы, имя которых начинается с точки, не выводятся);

-l вывод полной информации: режим доступа, количество ссылок на файл, имена владельца и группы, размер в байтах и последней модификации.

-F если файл является каталогом, то выдавать после его имени '/'; если файл является выполняемым, то выдавать после его имени символ '*', если это ссылки, то выдается после имени '@'.

cat - простейший текстовой редактор.

Использование: cat [файлы].

Пример: прочтем файл cat zlob.c

Содержимое файлов zlob1.c и zlob2.c запишем в superzlob.c: cat zlob1.c zlob2.c > superzlob.c

find - поиск файлов.

Использование: find [каталоги] [выражение].

Важные флаги команды:

-name шаблон для поиска;

-perm поиск с файла с заданным режимом доступа;

-type поиск определенного типа (d - каталог, f - файл, l - ссылка);

-user поиск файла, принадлежащего определенному пользователю;

-group поиск файлов, принадлежащих определенной группе;

-size поиск файлов с определенным размером, по умолчанию размер в блоках; если после числа стоит символ 'c' то размер в байтах, если перед числом символ '-' или '+', то, соответственно, ищется файл, размер которого меньше или больше указанного.

-print данный флаг необходим, если ты работаешь не с GNU версией find. Без него команда не будет выводить имена найденных файлов.

Пример использования команды: Найдем все файлы, принадлежащие группе goblins, размер которых более 500 байт: find / -group goblins -size +500c

Найдем все каталоги с режимом доступа 777: find / -type d -perm 777

cp - копирование файлов.

Важные флаги команды:

-R если директория копируется с этим флагом, будут скопированы все поддиректории и их содержание.

rm - удаление файлов.

Важные флаги команды:

-f команда не выдает сообщений, когда удаляемый файл не существует, не запрашивает подтверждения при удалении файлов, на запись в которые нет прав. Если нет права и на запись в каталог, файлы не удаляются. Сообщение об ошибке выдается лишь при попытке удалить каталог, на запись в который нет прав.

-r удаление всех каталогов и подкаталогов, перечисленных в аргументах. Подтверждение при удалении файлов, на запись в которые нет прав, не запрашивается.


Спецвыпуск Хакера, номер #005, стр. 005-040-2, Основные команды операционной системы UNIX

Основные команды операционной системы UNIX

zlobnik

Спецвыпуск Хакера, номер #005, стр. 005-040-2

rmdir - удаление директорий (команда может удалять только пустые директории).

mv - перенос файлов.

Важные флаги команды:

-f не запрашивать подтверждение на переписывание файлов.

du - информация использования дискового пространства.

Использование команды:

-s выдается только общая сумма для каждого заданного файла (даже если он является каталогом);

-a для каждого файла, встретившегося при обходе, выдается строка, содержащая число блоков и имя файла.

exit - выход из системы.

who - вывод информации о том, кто в данный момент работает в системе.

chmod - изменение режима доступа к файлам.

Использование: chmod [режим доступа] [файлы].

Режим доступа задается как в числовом виде в восьмеричной системе, так и в символьном.

r - чтение

w - запись

x - исполнение

u - для владельца

g - для группы

a - для всех остальных

s - при выполнении изменяется действующий идентификатор пользователя или группы.

Пример использования:

Разрешим модификацию файла для группы: chmod g+w zlob.c

Запретим исполнение файла для всех остальных пользователей: chmod a-x zlob

chgrp - изменение группы владельца файла.

Использование: chgrp [новая группа] [файлы].

chwon - изменение владельца файла.

Использование: chown [новый владелец] [файлы].

ln - создание ссылки.

Использование: ln [флаги] файл1 [файл2 ...] целевой файл.

Важные флаги:

-s создание символической ссылки, по умолчанию без этого флага создается жесткая ссылка.

df - вывод информации о дисках.

Использование: df [флаги] [файловая система] [каталог].

Важные флаги команды:

-k вывод размеров в килобайтах;

-h вывод размеров с символьными обозначениями размерности.

ps - вывод информации о процессах в системе.

Важные флаги команды:

-a вывод информации о процессах всех пользователей;

-с не выводит полное имя процесса;

-m сортировка процессов по размеру используемой каждым памяти;

-U вывод информации о процессах, принадлежащих определенному пользователю;

-x вывод информации о демонах;

-p вывод информации о процессе с определенным идентификатором (PID);

-u вывод подробной информации о процессе.

kill,killall,zap - посылка сигнала процессу.

Использование: kill [-сигнал, заданный номером или по имени] [номер процесса (PID)].

killall [-сигнал, заданный номером или по имени] [номер процесса (PID), процесс также может быть задан по имени].

zap [-s сигнал, заданный номером или по имени] [номер процесса (PID), процесс также может быть задан по имени]

SIGALRM - 14 - Наступление тайм-аута таймера сигналов генерируется функцией alarm().

SIGHUP - 1 разрыв связи с управляющим терминалом/перезапуск процесса.

SIGINT - 2 Прерывание процесса генерируется нажатием клавиш Contrl + C.

SIGKILL - 9 Уничтожение процесса (данный сигнал процесс не может игнорировать)

SIGQUIT - 3 Выход из процесса.

SIGSTP - 18 Остановка процесса.

SIGTERM - 15 Завершение процесса (по умолчанию посылается командой kill).

tail - вывод хвостовой части файла.

-n вывод последних n строк;

-с вывод последних n байт;

-b вывод последних n блоков.

head - вывод первых строк файла.

-n вывод первых n строк.

joe/pico - простые и привычные для пользователя консольные текстовые редакторы.


Спецвыпуск Хакера, номер #005, стр. 005-040-3, Основные команды операционной системы UNIX

Основные команды операционной системы UNIX

zlobnik

Спецвыпуск Хакера, номер #005, стр. 005-040-3

wc - подсчет количества символов, слов и строк в файле.

Важные флаги:

-l вывод только числа строк;

-w вывод только числа слов;

-c вывод только числа символов.

grep - фильтровка строки по заданному шаблону.

Использование: grep [шаблон] [файл].

В шаблон могут входить обыкновенные символы, представляющие сами себя, а также - спецсимволы, выполняющие служебные функции шаблона: . * ^ $ [ ]

. - означает любой произвольный символ;

* - "множитель" (предыдущий символ любое число раз);

.* - любая последовательность символов;

^шаблон - привязываем шаблон к началу строки;

шаблон$ - привязываем шаблон к концу строки;

[символы] - ровно один символ из тех, что стоят в скобках.

Важные флаги:

-n перед каждой строкой ставить ее номер в файле;

-c выдавать только количество успешно сопоставленных строк;

-i при сопоставлении не различать большие и малые буквы;

-v выдавать только строки, не удовлетворяющие шаблону;

-l выдавать только имена файлов, в которых есть успешно сопоставленные строки, разделяя имена переводами строк.

tar - Архиватор.

Создаем архив zlob.tar и добавляем в него два файла и одну директорию.

tar -cvf zlob.tar zlob1.c zlob2.c dir1

Разархивируем zlob.tar

tar -xvf zlob.tar

Добавим файл zlobik.c в архив.

tar -avf zlob.tar zlobik.c

Извлечем отдельный файл из архива.

tar -xvf zlob.tar dir1/zlobnik.c

telnet - обычный telnet-клиент.

ftp - обычный ftp-клиент, похожий на стандартный Windows'вский.

mkdir - создание директории.

pwd - вывод имени текущей директории.

echo - выдача аргументов командной строки на стандартный вывод.

man - чтение страниц руководства.

Пример использования:

Получим справку по команде tar : man tar

Страницы делятся на несколько разделов. Иногда одной и той же теме соответствует несколько man страниц на разные темы.

1 - основные команды

2 - системные вызовы

3 - функции в С-библиотеках

4 - специальные файлы (драйверы устройств)

5 - форматы файлов

6 - игры

7 - различная информация

8 - поддержка системы и системные команды.

Например, если набрать 'man 1 printf', ты получишь страницу руководства по команде printf, которая осуществляет форматированный вывод в стандартный поток, а если ты наберешь 'man 3 printf', то получишь руководство по функции printf из языка Си.

write - написать сообщение пользователю, находящемуся в данный момент в системе.

Использование: write [ttyN] [имя пользователя].

ttyN - терминал, к которому подключен пользователь (его имя можно получить командой who).

mc - консольный менеджер файлов, похожий на Norton Commander для dos.

gzip/gunzip - архиватор/разархиватор файлов.

Пример использования: добавим файл в архив 'gzip zlobotron.c'

Затем извлечем его 'gunzip zlobotron.gz'

su - получение прав другого пользователя.

Использование: su [флаги] [имя пользователя]

Важные флаги:

-c исполнение заданной после этого флага команды.

Например: Исполним команду joe /etc/passwd с правами пользователя root 'su root -c 'joe /etc/passwd'

sh - простейший интерпретатор командной строки, который ты найдешь в любой UNIX системе.


Спецвыпуск Хакера, номер #005, стр. 005-040-4, Основные команды операционной системы UNIX

Основные команды операционной системы UNIX

zlobnik

Спецвыпуск Хакера, номер #005, стр. 005-040-4

Используемые специальные символы:

* ? [ ] - Эти метасимволы позволяют указывать сокращенные имена файлов при поиске по шаблону.

& - Означает, что команда будет выполняться в фоновом режиме.

; - Точка с запятой разделяет команды в командной строке.

\ - Отменяет специальное значение символов, таких как *, ?, [, ], &, ;, <, >, |.

'...' - Одиночные кавычки отменяют значение пробела как разделителя и специальное значение всех символов.

"..." - Двойные кавычки отменяют значение пробела как разделителя и специальное значение всех символов за исключением $ и \.

> - Перенаправляет вывод команды в файл.

< - Перенаправляет ввод для команды из файла.

>> - Перенаправляет вывод команды, который должен быть добавлен в конец существующего файла.

| - Создает канал, направляющий вывод одной команды во ввод другой команды.

`...` - Используется в паре; позволяет использовать вывод команды как аргументы в командной строке.

$ - Используется с позиционными параметрами и определенными пользователем переменными; также используется по умолчанию в качестве подсказки shell.

Встроенные переменные:

CDPATH - Путь поиска для команды cd. Смотри раздел ВСТРОЕННЫЕ КОМАНДЫ (Special Commands), команда "cd".

HOME - Аргумент по умолчанию (входной каталог) для команды cd.

РATH - Путь поиска команд (список директорий, где интерпретатор будет искать введенную вами команду).

MAIL - Если эта переменная определяет имя почтового файла, то интерпретатор shell информирует пользователя о прибытии почты в указанном файле.

TMOUT - время бездействия юзера в системе, через которое он автоматически будет отключен.

PS1 - Первичный вид интерпретатора командой строки по умолчанию "$".

PS2 - Вторичный вид интерпретатора командой по умолчанию ">".

SHELL - Имя используемого шелла.

Ну вот и все, ну почти все команды, которые могут понадобиться тебе в процессе изгнания демонов и дрессировки пингвинов. Если зверюги слушаться не будут или еще какие проблемы возникнут - пиши, помогу ;).


Спецвыпуск Хакера, номер #005, стр. 005-044-1, Оптимизация Линукса

Оптимизация Линукса

StF (StF@mail.ru)

Спецвыпуск Хакера, номер #005, стр. 005-044-1

Бредисловие

В последнее время в разного рода конференциях по линуксу возникает флейм по поводу того, что линукс типа сакс, отстой и полные тормоза и что винда была, есть и будет форева. Ярые сторонники этой мысли при скромном вопросе - а вы линух-то свой оптимизировали вообще? - тут же замолкают и спрашивают, на фига это надо - дескать, и без этого грузится вроде, но тормозит... Не стоит наивно полагать, что в конфигурации по умолчанию все прооптимизировано, ибо она настроена так, чтобы работать как на твоем Пентиуме III с кучей прибамбасов, так и на старой трешке. Я не затрону в этой статье "железной" оптимизации (...из нашей статьи вы не узнаете о том, что вешать на один шлейф CD-ROM и хард нехорошо :o)) - я лишь поговорю об оптимизации на уровне софта. Так что вперед - оптимизировать, оптимизировать и еще раз оптимизировать... :-))

Установка

Возможно, у тебя линукс уже установлен, однако этап установки является одним из важных шагов по оптимизации. В первую очередь, скорость работы зависит от дистрибутива, коих на рынке сейчас великое множество. Каждый из них имеет свои особенности, достоинства и недостатки. Наиболее быстроходным, по моему мнению, является дистрибутив Mandrake, наиболее тормозным - SuSe Linux (как это ни печально). Ядро Mandrake оптимизировано для процессоров Пентиум, так что по сравнению с RedHat он быстрее где-то на 10-15% (по моим субъективным оценкам).

Во время установки (в принципе это можно сделать и после, набрав в командной строке ntsysv) можно убрать ненужные сервисы из автоматического старта, тем самым уменьшая время загрузки линукса. Например, из всего что есть в списке, у меня остались сервисы: cron, atd, network, xfs, xfstt.

Также еще один важный момент - это использование свапа и его размер. Я думаю, все знают, что когда заканчивается оперативная память (и даже несколько раньше ;-)) при запуске очередной проги, неактивная в данный момент программа свапуется, то есть OS копирует память, занятую этой прогой на хард, очищает память и загружает в нее свежезапущенную программу. Ну так вот, важно правильно выбрать размер свапа: если у тебя 16...32 Mb памяти, то размер свапа должен быть в 3-4 раза больше размера памяти, при 32...64Mb размер свапа где-то в 1.25-2 раза больше объема памяти, при количестве памяти более 64 Mb свап уже включают по желанию. Короче: чем меньше памяти, тем больше должен быть свап. Могу сказать, что у меня, при 128 Mb ОЗУ, свап потребовался только ОДИН раз, и обычно ВСЕГДА где-то 20Mb пребывают свободными.

Также попробуй расположить свой своп-диск ближе к началу IDE диска. Hачало жесткого диска физически расположено на внешней части цилиндра. Головка чтения/записи в этом случае cможет покрыть большую область за один оборот диска. Это значит, что может быть записано/считано больше данных за один оборот. У меня разница составляет 3MB/сек в зависимости от местоположения логического диска на IDE устройстве.

Раз мы уж заговорили про память, скажу пару слов о "прожорливом" софте.

Самые памятелюбивые под линухом (в порядке убывания): StarOffice - 128Mb,


Спецвыпуск Хакера, номер #005, стр. 005-044-2, Оптимизация Линукса

Оптимизация Линукса

StF (StF@mail.ru)

Спецвыпуск Хакера, номер #005, стр. 005-044-2

Mozilla M1* - 96 Mb, Kde & Gnome - 64 Mb, Netscape 4.x - 32Mb. Так что даже

не пытайся поставить староффис на пень с 32 мегами - встать-то он встанет,

но пока будет запускаться - успеешь кофе сварить :-(.

Ядро

Ядро, устанавливаемое по умолчанию, содержит в себе много ненужных для тебя опций, цель которых - заставить его работать почти на любой конфигурации. У

нас есть 2 задачи: выкинуть из него все лишнее совсем и выложить то, что нужно для твоего компа, в отдельные модули. Дело в том, что при работе Linux ядро - единственный кусок памяти, который не свапуется, поэтому логично сделать его меньше. Что же выкидывать из ядра? Тут сложно продвинуть конкретные рекомендации - все зависит от конфигурации твоего компа. Но несколько советов я могу дать:

- Установи семейство процессоров в PPro/6x86MX для Pentium II/III систем.

- Разреши MTRR для PentiumPro/II/III и AMD K6-2/3 систем.

- Запрети багофиксы для чипсетов, которых у тебя нет. Пример: CMD640 и RZ1000.

- Разреши Generic PCI bus-master DMA поддержку и использование DMA по

умолчанию (Use DMA be defaults).

- Разреши поддержку чипсета, который у тебя есть. Пример: VIA82C586 для VIA

VP2/3 и MVP3 материнских плат.

- Разреши ТОЛЬКО специфичные SCSI контроллеры, которые у тебя есть.

Пример: Adaptec AIC7xxx.

- Запрети ВСЕ сетевые устройства, поддержка которых тебе не нужна.

- Установи максимальное число Unix98 PTYs в 128.

- Установи 'persistant dma buffer' в конфигах звука.

- Запрети все файловые системы, за исключением: ISO 9660 CDROM,VFAT, Second

extended fs, /dev/pts и /proc поддержка.

- Запрети все сетевые файловые системы (NFS).

- Запрети все консольные драйвера. Исключение: VGA text console.

- Запрети Enhanced Real Time Clock поддержку.

- Запрети поддержку ISDN.

- Запрети поддержку IPv6.

- Запрети поддержку Amateur Radio.

- Запрети поддержку инфракрасных устройств (IrDA subsystem).

- Запрети поддержку джойстиков (Joysticks).

- Запрети все Ftape.

Попробуй другие вещи. Отредактируй /usr/src/linux/Makefile: найди

строку 'MAKE =make' и измени ее на 'MAKE =make -j5' - так будет использоваться несколько копий make, с которыми на некоторых системах будут быстрей компилироваться программы. Потом измени: 'CFLAGS

= -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer' на 'CFLAGS

= -Wall -Wstrict-prototypes -O7 -fomit-frame-pointer -fno-exceptions', что

включит использование оптимизирующих фишек, которые могут работать или не

работать со всеми ядрами (оптимизация кода при компиляции).

Ядро желательно брать посвежее и стабильное, например, 2.2.17 - последний

стабильный релиз ядра из серии 2.2.* на данный момент.

Компиляция его осуществляется командами:

make menuconfig (или xconfig, если компилить из-под X [*] - данный параметр ядра будет скомпилирован встроенным в него [M], - означает, что он будет

откомпилирован в качестве отдельного модуля, загружаемого по необходимости)

make dep

make bzlilo

make modules

make modules_install

Необходимо также заметить, куда скомпилилось новое ядро (у меня это всегда корень), и добавить в файл /etc/lilo.conf строки, дающие возможность загрузить старую версию ядра, если эта криво скомпилена или просто глючит (и такое бывает!):


Спецвыпуск Хакера, номер #005, стр. 005-044-3, Оптимизация Линукса

Оптимизация Линукса

StF (StF@mail.ru)

Спецвыпуск Хакера, номер #005, стр. 005-044-3

image=/vmlinuz #путь к новому ядру

root=/dev/hda3 #путь к корню, пишем тот же, что и для установленного системой ядра

read-only

label=linux_new #название нового типа загрузки

Далее ставим эти 4 строчки ПЕРЕД кодом старого загрузчика (обычно

начинающегося с image=/boot/vmlinuz), чтобы твое ядро грузилось первым по

умолчанию, и ребутимся. Вуаля! Все должно работать!

Жесткий диск

Здесь оптимизацию можно разделить на две части: оптимизация производительности харда и оптимизация свободного места на нем. Скажу сразу - лучше устанавливать

программы по минимуму, а то потом будешь просто офигевать, заглядывая в папку /../bin и думая, что тебе со всем этим делать. Ибо проще доставить НУЖНУЮ тебе прогу, чем потом удалять кучи прог, которые ты не использовал, освобождая место на винте.

Благодаря особенностям файловой системы ext2fs, используемой в линуксе, диск менее подвержен фрагментации, но она все же имеется (у меня она составляет максимум 10%). Если у кого-то она очень большая, то можно скачать дефрагментатор с ftp://metalab.unc.edu/pub/linu/system/filesystems.

Далее. Несмотря на стабильность линуха, некоторые проги все-таки падают, давая прибавление на харде в несколько мег путем образования файла core - дамп памяти, с которой работала упавшая программа (они это делают для удобства отладки).

Если тебе надо ограничить максимальный размер образа ядра в tcsh - используй команду 'limit'. Hабранная сама по себе, она покажет текущее значение для данного шелла.

Также core-файлы могут представлять угрозу для безопасности системы, так как могут содержать куски памяти, содержащие пароли и другую важную информацию.

Для отключения сохранения образа ядра при сбоях используй 'limit coredumpsize 0' или добавь в файл конфигурации bash (~/bash_profile) строку 'ulimit -c 0'.

Вообще, можно попробовать использовать ReiserFS - журналируемую файловую систему - 'самоизлечивающуюся' при потерях кластеров, связанных с некорректным выходом из системы (кнопка power off?) или перебоях с электропитанием.

И, наконец, оптимизация производительности харда. Для этого есть хорошая команда 'hdparm'. Запустив ее hdparm -t <имя раздела или диска>, можно померить производительность данного раздела (или диска в целом). У этой команды есть много ключей - вот самые интересные:

-d [0|1] включение DMA

-c [1|2|3] 16/32bit общение с диском

-m количество секторов, считываемое за раз

-k сохранение параметров.

Не все из этих опций смогут работать на твоей машине, могут добавиться и другие к моменту чтения тобой этой статьи, но могу сказать одно: поиграв с ними и

написав 'hdparm -d 1 -c 3 /dev/hda' и 'hdparm -k /dev/hda', я повысил скорость работы своего диска под линуксом с 3Mb/sec до 12Mb/sec. Типа, апгрейд подождет!

Диск - IBMDTTA351010. После того как наиграешься с параметрами и добьешься результатов, создай простой скриптик, вписав в него все, что ты поменял, а потом, сделав его запускаемым, скопируй его в /etc/rc.d/local, чтобы он при каждом старте системы срабатывал автоматически.


Спецвыпуск Хакера, номер #005, стр. 005-044-4, Оптимизация Линукса

Оптимизация Линукса

StF (StF@mail.ru)

Спецвыпуск Хакера, номер #005, стр. 005-044-4

X-Windows

Не секрет, что для иксов лучше иметь не менее 16 мег оперативки. Такого же мнения придерживаются и несколько Desktop & Windows менеджеров :0). Самые навороченные из них это AfterStep, WebMaker, IceWM, BlackBox. Что касается моего любимого KDE - то он несколько не торопится при старте на слабой машине. Есть шанс ему помочь, найдя стартовый скрипт - startkde (у меня он лежит в /usr/bin) - и закомментировав строчки "'sleep 2'", говорящие о паузе в две секунды между стартами разных KDE сервисов. Что касается Gnome+Enlightment, то здесь явно ничем хорошим не пахнет, так что лучше не мучить себя и компьютер. На 32 метрах памяти все вышеперечисленное в этом разделе работает весьма сносно.

Видеокарта

Для ускорения видеокарты в Х можно использовать следующую фичу: требуется процессор pentium pro :0).

Смотрим в /proc/pci (cat /proc/pci) :

VGA compatible controller: S3 Inc. ViRGE/DX or /GX (rev 1).

Medium devsel. IRQ 7. Master Capable. Latency=40. Min Gnt=4.Max Lat=255.

Non-prefetchable 32 bit memory at 0xf8000000 [0xf8000000].

Видим нашу видеокарту. Теперь мы попробуем увеличить скорость записи в

Устройство, используя 'write-combining'. Команда, разрешающая 'write-combining' в 4-х меговую область, начинающаяся с 0xf8000000 : 'echo \"base=0xf8000000 size=0x400000 type=write-combining\" >> /proc/mtrr'.

Теперь в /proc/mtrr мы видим следующую новую строчку:

reg02: base=0xf8000000 (3968MB), size= 16MB: write-combining, count=1 .

Если понадобится, можно запретить использование 'write-combining': 'echo \"disable=2\" /proc/mtrr'. Более подробно об этом можно посмотреть в

/usr/src/linux/Documentation/mtrr.txt.

Также можно поиграть с нестандартными разрешениями карточки, выжав из

нее все - но тут я не советчик, ибо этого САМ не пробовал. Понятно, что перед

этим неплохо почитать доку на свою карточку.

В общем и целом

В оставшейся части я дам несколько общих советов для ускорения Linux'a.

1) Отредактировать inittab, уменьшив число виртуальных консолей - особенно, если можно запускать X-terms. Я еще не видел человека, который бы работал одновременно с шестью консолями и X-Window.

Найти следующую строчку:

c1:1235:respawn:/sbin/agetty 38400 tty1 linux

(Обычно их 6 с c1 по c6) и закомментировать ненужные (только случайно

не закометируй все ;))

2) Убрать из /dev все ненужные записи - особенно эту тьму разных pty.

Кому это надо, когда есть PseudoTerminal Miltiplexor.

3) Отключить inetd/xinetd - зачем он нужен, если нет насущной потребности, скрываясь от полиции в Интернет-кафе "Зимбабве", стереть с жесткого диска важный налоговый документ, подключившись по telnet.

4) Убрать лишние шрифты XFree86, поставить шрифты 75dpi, 100dpi,

Speedo, PEX, Type1, misc, cyrillic. Реально IMHO нужны 75dpi, misc,

Type1. Шрифты cyrillic - вообще довольно низкого качества, гораздо лучше Cyr-RFX (75dpi, misc со встроенной кириллицей).

5) Отключить все ненужные сетевые сервисы: sendmail, nfsd, httpd.


Спецвыпуск Хакера, номер #005, стр. 005-044-5, Оптимизация Линукса

Оптимизация Линукса

StF (StF@mail.ru)

Спецвыпуск Хакера, номер #005, стр. 005-044-5

Ну и, напоследок, несколько ссылок:

1) ftp://ftp.chg.ru/pub/benchmark - разнообразные проги для замера

производительности под линукс.

2) Если ты хочешь себе купить к компу какую-нить новую железку и не знаешь, будет ли она поддерживаться твоим ядром, то обратись сюда:

http://cdb.suse.de/cgi-bin/scdb?HTML=ENGLISH/cdb_listtemplates/menu.htm&LANG=ENGLISH

PS: При написании этой статьи были использованы ресурсы http://www.linux.org.ru

и http://www.opennet.ru


Спецвыпуск Хакера, номер #005, стр. 005-048-1, Софт для Линукса

Софт для Линукса

Спецвыпуск Хакера, номер #005, стр. 005-048-1

MOOF (MOOF@xakep.ru ; http://moof.da.ru)

Kcommander

Вес: 332Kb

http://www.codewizards.org/kcommander/

Прикольный файловый менеджер. Если ты переползаешь на линукс с виндов и хочешь в линуксе видеть любимые виндовские проги, то Kcommander для тебя. Интерфейс один в один как у WindowsCommander'a. Да и функции те же: работа с разнообразными архивами (zip, rar, tgz etc), поддержка множества языков, автомонтирование дисков и работа с файлами, естественно... Интерфейс программы KDE. К сожалению, еще мало функций, но программа постоянно развивается, и можно надеяться на то, что Kcommander наконец-то дорастет до своего виндобрата.

Explore2fs

Вес: 1.5Mb

http://uranus.it.swin.edu.au/~jn/linux/explore2fs.htm

Это не линуксовая программа, а виндовская. Но она чрезвычайно полезна будет первое время... Да и не только первое, а все время, пока у тебя будет стоять две операционки. С ее помощью ты можешь работать из виндовс с дисковыми разделами линукса. Ну разве не об этом ты мечтал всю жизнь? Если об этом, то твоя мечта сбылась. Прога без проблем поддерживает диски больших размеров. Ну и стандартные феньки форточек типа Drag&Drop тоже присутствуют.

kArchiveur

Вес: 509Kb

http://david.bieder.free.fr/karchiveur_en.shtml

Еще одна прога для ностальгирующих по виндам. Если ты не можешь работать с архивами из файл-менеджера, а привык пользоваться WinZip'ом, то kArchiveur поможет тебе. Как ты понял, это графический интерфейс к архиватору. Поддерживает туеву хучу архивов разнообразных форматов - начиная зипом и заканчивая таром. Интерфейс KDE.

FreeCraft

Сайз: 2.8Mb

http://freecraft.org/

Воу! Хоть это и не прога, а игруха, не упомянуть о ней я не мог. Клон WarCraft2 (такая игра для доса была, если не знаешь :)). Если ты забыл - напоминаю: реал-тайм стратегия, люди против орков. Игра чрезвычайно интересная, вот только графику не мешало бы подправить чуть-чуть. Есть версия и для beos. Если вдруг схватит ностальгия по старым игрушкам, поиграй в FreeCraft - может, отпустит.

Freeciv

Вес: 3.4Mb

http://www.freeciv.org/

Да, опять игра. Опять эпическая. Еще один клон. На этот раз - Цивилизация 2. Правда, как утверждают разработчики, Цивилизация вообще не имеет никакого отношения к Freeciv. Врут, понятно дело, мерзавцы. Игрушка убивает кучу полезного времени, но поиграть очень хочется.

3Dwm

Размер: 265Kb

http://www.3dwm.org/

Необычный оконный менеджер. Если тебе надоел плоский двухмерный рабочий стол, то 3Dwm специально для тебя. Он добавит немного трехмерности на рабочий стол, и твой сверхплоский экран станет чуть-чуть трехмерным. Первое время, конечно, будет не по себе, захочется стошнить, но потом привыкнешь и полюбишь :).

KMatrix

Весит: 490Kb

http://members.internettrash.com/kmatrix/

Если ты - безумный фанат матрицы, то эта прога тебе понравится. Она занимается тем, что во время твоей работы показывает на рабочем столе эффект ТОГО САМОГО матрикса. Признаюсь честно: сильно утомляет, но перед девчонками повыпендриваться можно, типа: "Вот, матрицу хакнул, теперь у меня в мониторе живет". С помощью кучи опций ты действительно легко сможешь настроить матрицу под себя.


Спецвыпуск Хакера, номер #005, стр. 005-048-2, Софт для Линукса

Софт для Линукса

Спецвыпуск Хакера, номер #005, стр. 005-048-2

FreeAmp

Длина: 1.3Mb

http://www.freeamp.org/index.html

Один из популярных mpeg-проигрывателей. Понимает mpeg1, 2 и 2.5. Кроме версии для линукса, есть версия для виндов, соляриса и еще чего-то. Поддерживает скины, коих на сайте целое море. Есть скин, имитирующий интерфейс winamp'a. Отличный проигрыватель!

Gnapster

Масса: 93Kb

http://www.faradic.net/~jasta/index.html

Напстер для никсов. Умеет скачивать, выкачивать, искать файлы. Можно задать порядок воспроизведения песен в собственном плеере. Чрезвычайно прост и удобен в использовании. Интерфейс Gnome.

Koffice

Качать придется: 5.3Mb

http://koffice.kde.org/

Как ты догадался по названию, это офис для KDE. Кроме KWord (текстовый редактор), тут есть KSpread, KPresenter, KIllustrator, KImageShop, Katabase, KFormula, KChart и KImage. И все это весит чуть больше пяти метров. Для работы требуется куча библиотек, которые ты можешь скачать там же. Но все они небольшие и не сильно увеличат размер офиса.

Slowo

Ширина: 15Kb

http://www.gambit.msk.su/~wolf/dic/index.html

Англо-русский и русско-английский словарь для линукса. Чрезвычайно похож на Лингво для виндов. Есть несколько дополнительных специализированных словарей. Прога, понятное дело, бесплатная и написана нашим челом.

FreeMWare

Вес: 225Kb

http://www.plex86.org/lang/russian/info.html

Эмулятор компьютера. Аналог VMware, только бесплатный. Позволяет запускать проги, как на обычном компьютере. Соответственно, эмулирует память, процессор, диски и всякие другие периферийные устройства. Вроде как, говорят, даже работает :).

Partition Image

Масса: 192Kb

http://partimage.sourceforge.net/

С помощью этой утилиты ты сможешь делать образы любых разделов жесткого диска. Понимает fat16, fat32, ntfs, ext2fs. Если ты решил поэкспериментировать над своим жестким диском, то сделай его образ, а потом экспериментируй. Если чего сломаешь, потом из образа легко восстановишь.

Instant Mounter

Аж целых 16Kb

http://guills.linuxatwork.at/instant.html

Очень удобная и чрезвычайно полезная утилитка. С ее помощью можно монтировать диски одним щелчком мыши. Естественно, требует наличия таких прог, как mount и unmount. Интерфейс программы KDE.

USB Viewer

Весит: 55Kb

http://www.kroah.com/linux-usb/

Если у тебя на компьютере куча USB-устройств, но работают они под линуксом как-то не так, то с помощью этой проги ты сможешь все как следует настроить. USB Viewer выводит на экран полную информацию о всех USB устройствах и их характеристики. Это значительно облегчит твою задачу.

IMWheel

Сливаем: 370Kb

http://jonatkins.org/imwheel/

Ты являешься счастливым обладателем мыши с разнообразными колесиками? И тебя бесит, что линукс не понимает, зачем они нужны? Точнее, не понимал... Теперь с помощью программы IMWheel ты сможешь заставить работать крысу на полную мощность. Прокручивать окна сверху вниз\слева направо, а также наискосок и в другие стороны будет так же легко, как листать этот журнал.

Quanta

Качаем: 575Kb

http://quanta.sourceforge.net/

HTML-редактор для кул-дизигнеров. Подсвечивает html-теги, есть превю. Что еще нужно? Все просто и удобно. Интерфейс программы KDE.


Спецвыпуск Хакера, номер #005, стр. 005-048-3, Софт для Линукса

Софт для Линукса

Спецвыпуск Хакера, номер #005, стр. 005-048-3

Bluefish

Объемыч: 387Kb

http://bluefish.openoffice.nl/

Еще один HTML-редактор, но более навороченный, чем предыдущий. Понимает каскадные таблицы стилей (css) и ssi. Можно использовать как редактор для PHP3, потому что это тоже понимает ;).

ScriptEditor

Масса: 230Kb

http://scripteditor.mozdev.org/

Еще одна программа для редактирования html-файлов. Кроме, собственно, гипер-текста, умеет работать с javascript, css, php и еще с кучей других скриптовых языков. А секрет этой программы в том, что она для своей работы использует ядро Mozilla M15, и на любой операционке, куда портированна Mozilla, ScriptEditor будет работать просто запросто :).

X-Chat

Размер: 388Kb

http://www.xchat.org/

Чрезвычайно приятный и удобный irc-клиент. Работает, естественно, под x11 и имеет все функции, присущие irc клиенту. Можно писать скрипты на его скриптовом языке. Понимает всевозможные плагины.

Balsa

Сливаем: 1.7Mb

http://www.newton.cx/balsa/

Почтовый клиент для любителей АутГлюка. Интерфейс чрезвычайно похож на своего виндовс-брателло. Имеет множество настроек и различных функций. Умеет работать с pop, smtp, imap протоколами.

W3Mail

Взвешиваем: 18Kb

http://www.w3mail.org/

Полезная программа, которая лазает по твоим почтовым серверам, используя протокол POP3, и в твоем браузере отображает всю почту, которая к тебе пришла. Для своей работы прога использует стандартный httpd-сервер, а значит, будет работать не только на линукс-машине, но и на различных видах юниксов.

Pan

Неподъемная: 615Kb

http://www.superpimp.org/

Программа для работы с конференциями usenet. Имеет все необходимые для этого функции и даже больше. Умеет искать в сообщениях разную фигню. Интерфейс программы GNOME.

FreeWRL

Совсем много весит: 3Mb

http://www.crc.ca/FreeWRL/index.html

Браузер для просмотра VRML-миров. Поддерживает JavaScript, Perl, Java. Для запуска необходимо скачать jclasses - это примерно 45Kb. Работает не только в линуксе, но и в солярисе, ириксе и других подобных операционках.

Dial2net

Объем: 7Kb

http://dial2net.sourceforge.net/

Звонилка для линукса. С ее помощью ты сможешь легко настроить большинство параметров твоего провайдера. Поддерживает протоколы pap и chap авторизации.

X-ISP

Масса: 1.2Mb

http://users.hol.gr/~dbouras/

Еще одна звонилка. Умеет перебирать телефонные номера, менять имя и пароль пользователя. Может вести статистику соединения.

DialMon

Размер: 176Kb

http://www.quaking.demon.co.uk/dialmon.html

И еще одна звонилка, умеющая дозваниваться до провайдера. Удобный интерфейс и множество настроек. Имеет возможность вести подробную статистику соединения и выбирать необходимую учетную запись из нескольких существующих. Есть версия для виндов.


Спецвыпуск Хакера, номер #005, стр. 005-056-1, Ставим Линукс

Ставим Линукс

Спецвыпуск Хакера, номер #005, стр. 005-056-1

LonerX (lonerx@crosswinds.net)

Дубель раз

История началась порядочное время назад, когда я сидел под операционной системой Windows, играл в игрушки, кое-как ползал по просторам WWW (естественно, при помощи непревзойденного Експлорера) и считал, что все просто отлично!!! Чуть позже я стал играть меньше, ползать по Сети больше, и наступил момент, когда я осознал, что МазДай уже не выполняет те задачи, которые я пытаюсь перед ним поставить. Оказалось, что многое из того, что я хотел сделать в Инете, на машине под управлением Windows сделать или невозможно, или настолько проблемно и чревато глюками, что лучше об этом и не задумываться :). Как раз в то время я услышал о том, что есть такая операционная система Линукс, которая хоть и является клоном Юникс (слово, которое в те времена вызывало благоговейный трепет и мысли о Кевине Митнике), но, тем не менее, довольно-таки проста в использовании (о молодость, о глупость!). И когда Експлорер в очередной раз повис из-за какой-то ошибки в Ява-скрипте, а потом, сидя в чате, я вылетел раз пять подряд (наверное, коннект был плохой :)), мне все это жутко надоело, я отправился в ближайший магазин и купил первый попавшийся мне на глаза дистрибутив Линукс. Этим дистрибутивом оказался Red Hat (версии 5 с чем-то). Окрыленный осознанием фундаментальности покупки, я прилетел домой, откупорил бутылку пива и, радостно потягивая из стакана "Балтику", сел ставить долгожданного Пингвина. Но тут-то меня и поджидал первый крутой облом. Программа инсталляции с первых же шагов обматерила меня кучей непонятных слов. Я просто не знал, что мне делать с какими-то hda1, hda2 и прочими psAux!!! Когда же я увидел на экране призыв определиться с тем, каких демонов надо запускать при загрузке (зачем демоны??? куда запускать???), я понял, что все, труба... Инсталляция была прервана. Загрузившись в Windows (как все привычно и знакомо!!!), я полез в сеть за инструкциями. Инструкций (в виде всяческих Installation Guide и разных доморощенных сайтов) я накопал целый вагон. Вроде бы многое встало на свои места, и я снова, уже более ответственно, уселся за установку Линуха.

Дубель два

Провозившись очень долгое время, я, наконец-то, добрался до конца процесса инсталляции и с радостью дал машине команду перезагрузиться. Уж теперь-то, думал я, все будет в порядке. Как бы не так!!! Единственным более или менее осмысленным действием, на которое я оказался способен, было введение логина и пароля. На этом моя работа с Линукс закончилась :). Снова МазДай, снова Инет, снова документация... Ну и, конечно же, переустановка Линуха... просто так, для уверенности :). Прежде чем я смог по-настоящему освоить операционную систему Linux, этот порочный цикл повторился раз десять!!! И хоть сейчас я работаю исключительно под Линуксом, наслаждаюсь каждой минутой работы и все больше и больше проникаюсь уважением к этой операционной системе, воспоминания о тех днях, когда я устанавливал Пингвина, руководствуясь тем взглядом на компьютерный мир, который привил мне Билл Гейтс своим гениальным творением (альтернативы просто не было), вызывают дрожь в коленях и желание выпить валерьянки :).

Будет не трудно, а очень трудно

Ты спросишь, к чему я рассказываю все это??? Да к тому, что каким бы супер-пупер спецом ты бы ни был, моментальный и безболезненный переход от операционной системы Windows к операционной системе Unix НЕВОЗМОЖЕН!!! Усек? Так что приготовься сразу - сперва будет трудно. И не просто трудно, а очень трудно. И большую часть работы по получению навыков и опыта работы с Линуксом тебе придется проделать самому. Это касается и получения информации, и выбора из этой самой информации той ее части, которая может тебе реально помочь. Но некоторые неприятные этапы адаптации к Пингвину можно (и нужно) свести к минимуму. В общем-то, для этого я и написал те килобайты текста, которые ты сейчас читаешь. Просто я хочу, чтобы ты не натыкался по несколько раз на те грабли, на которые наступал я в твоей ситуации. Естественно, я не смогу рассказать тебе о всех нюансах, связанных с установкой и началом работы в Linux. Но кое-что я для тебя сделать смогу. Я покажу тебе, как правильно установить Линух на твой компьютер, загрузить его, включить графический интерфейс (и не говори мне о режиме командной строки - тебе для этого не одну книгу прочитать придется), настроить подключение к провайдеру и заставить твою систему понимать русские шрифты и раскладки клавиатуры. Так что пристегни ремни, приятель, поехали!!!


Спецвыпуск Хакера, номер #005, стр. 005-056-2, Ставим Линукс

Ставим Линукс

Спецвыпуск Хакера, номер #005, стр. 005-056-2

Пристегните ремни и приведите спинки кресел в вертикальное положение

Первым делом давай определимся, что тебе нужно для установки Linux. Конечно же, без дистрибутива самой OS тебе не обойтись, а так как эту статью я пишу об установке Red Hat, то и дистрибутив тебе нужен именно этот - Linux Red Hat 6.2. Также я предлагаю тебе не убивать Windows, а позволить двум операционным системам мирно сосуществовать рядом, на одном винте. Для этого тебе понадобится программа для "нарезки" жесткого диска, а также прога, позволяющая загружать разные операционки. Для этих целей я могу порекомендовать две утилиты от PowerQest - Partition Magic и Boot Magic. Как только все это окажется в твоих руках - ты готов к установке Пингвина.

Теперь, когда ты приобрел все нужное, необходимо подготовить твою машину к предстоящей инсталляции. Сперва надо выделить около 1 гигабайта свободного места на винте - туда ты воткнешь Linux. Для этого воспользуйся вышеупомянутой утилитой Partition Magic. Программа достаточно проста, и, немножко поиграв с Resize Partitions, ты добьешься того, что тебе нужно. После подобных манипуляций мой диск, к примеру, выглядел следующим образом:

C:-FAT32-2996Mb (тут у меня живет Windows98)

D:-FAT32-1011Mb (здесь я храню различные виндовые архивы, дистрибутивы и прочее)

Free Space-2165Mb.

После того как ты поделишь свой винт подходящим тебе образом, можно доставать дистрибутив Red Hat 6.2 и переходить непосредственно к установке.

Инсталлировать Линукс можно несколькими способами. Это значит, что программа инсталляции может установить систему с:

1. локального CD-ROM

2. локального HARDDISK (то бишь винта)

3. удаленного сервера.

Так как у тебя есть дистрибутив на CD-ROM, то мы воспользуемся именно первым способом установки. Red Hat 6.2 поставляется на загрузочном диске, поэтому для запуска инсталляционной программы достаточно вставить CD в привод, выставить в настройках BIOS (раздел BIOS FEATURES SETUP) загрузочную последовательность, начинающуюся с CD-ROM, и перезагрузить компьютер. Если ты все сделал правильно, то после перезагрузки ты увидишь экран с текстом на черном фоне и надписью (в самом верху) Welcome To Red Hat Linux 6.2. Вот теперь-то и начинается самое интересное!!!


Спецвыпуск Хакера, номер #005, стр. 005-056-3, Ставим Линукс

Ставим Линукс

Спецвыпуск Хакера, номер #005, стр. 005-056-3

Жми Enter. По экрану побегут строчки - это программа инсталляции проверяет конфигурацию твоей машины (тип жесткого диска, процессор и прочее железо). Этот процесс не должен занять много времени. После проверки конфигурации запустится графический интерфейс, и ты увидишь логотип Red Hat (собственно, размытая физиономия в КРАСНОЙ ШАПКЕ :). Логотип повисит секунды две, и инсталляция перейдет в фазу конфигурирования устройств ввода/вывода. С этого момента читай внимательно - я начинаю рассказывать о важных вещах!!!

Перво-наперво тебе будет предложено выбрать язык, на котором будет происходить инсталляция и который будет прописан в твоей системе как основной. Выбирай English (да-да, ты не ослышался - именно английский, русификацией займемся позже). Выбрал??? Жми на пимпу Next. Следующим пунктом идет конфигурация клавиатуры. Тебе надо выставить такие настройки:

Model: Generic 101-key PC

Layout: US English

Dead Keys: Disable dead keys.

В пустой строчке, под надписью "Test your selection here", ты можешь проверить, все ли клавиши реагируют на нажатие как полагается. Снова жми Next.

Теперь пора определиться с мышью. Посмотри внимательно на список мышей и выбери ту, что нужно. Если ты своей мыши не обнаружил, то не расстраивайся. В списке есть раздел под названием Generic. Выбери из этого раздела мышь, которая больше всего похожа на твою (я имею ввиду количество кнопок и порт, к которому присоединена хвостатая). Например, для трехкнопочной мыши, воткнутой в PS/2 порт (кругленький такой разъем), подходит следующий пункт - 3 Button Mouse (PS/2). Ежели случилось так, что на твоем девайсе две, а не три кнопки, - проверь состояние пимпы Emulate 3 buttons (эмулировать 3 кнопки) - эта пимпа должна быть нажата!!! Готово? Если да - то Next :).

Конфигурирование устройств ввода/вывода закончено. На экране снова должен появиться логотип Красной Шапки с надписью System Installer. Это значит, что инсталляция переходит в фазу установки системы. Немного полюбовавшись на уже знакомую физиономию, жми Next.

Упс! Начинаются непонятности. Но не бойся, просто программа установки предлагает тебе выбрать тип инсталляции. Это значит, что ты можешь установить Linux с упором на функции рабочей станции (два варианта - KDE и Gnome) или сервера. Но так как мы ребята свободные и того, что нам предлагают по умолчанию, не любим, отмечай Custom (в этом случае ты сам будешь определять, что тебе нужно). А теперь вдохни поглубже и нажми Next. Пора заняться по-настоящему серьезными делами.

Сейчас тебе предстоит изменить структуру твоего винта. Если точнее, то тебе надо добавить разделы файловой системы ext2, на которой базируется Линукс. В программе инсталляции это осуществляется с помощью утилиты Disk Druid. Давай рассмотрим ее поподробнее. На экране ты видишь два окошка. В одном из них (верхнем) отображается количество уже существующих разделов, а во втором (нижнем) - общая информация о жестком диске. На моем компьютере вид верхнего окна был приблизительно следующим:

hda1 2996M 2996M WIN98/FAT32

hda5 1011M 1011M WIN98/FAT32

Что это значит? Параметр сообщает о том, что точка монтирования (слова непонятные, но не огорчайся - со временем я дойду и до этого) раздела не обозначена. Для разделов FAT32 это и не нужно. Понятия hda1 и hda5 обозначают непосредственно разделы харда (в моем случае hda1 соответствует тому, что в windows называется "С:", а hda5 - ни что иное, как логический диск "D:"). Две цифры, следующие за hda*, указывают затребованный и актуальный размеры разделов. Для windows-разделов они совпадают. И на последнем месте стоит непосредственно тип файловой системы. С верхним окошком разобрались, перейдем к нижнему. В нижнем окошке тебе следует обратить внимание исключительно на данные об имеющемся свободном (free) пространстве. Если ты на предыдущих этапах все сделал правильно, то свободного места должно быть достаточно. У меня было около 2165M, то есть столько, сколько я освободил программой Partition Magic. Разобрался? Отлично! Теперь давай изменим эту картинку. Сперва добавим раздел свопинга (swap partition). В этом разделе Линукс будет создавать необходимые swap-файлы (как только ни переводили термин swap - и виртуальная память, и файл подкачки... :)). Для этого жмем на кнопку Add под окошком разделов. В появившемся окне конфигурации выбираем - Rartition Type = Swap Partition; Size(Megs) = 32. Раздел Mount Point трогать не нужно. Жмем ОК. В окне разделов должна появиться строка hda6 * * Linux Swap (на месте звездочек будут стоять цифры). Получилось? Поехали дальше. Перед тем как добавить основной Linux раздел, тебе необходимо понять основы файловой системы Пингвина. Дело в том, что Линух не оперирует понятиями типа "основной диск, логический диск, CD-ROM". Все файловые системы, находящиеся на разделах винта и других носителях, объединяются в единое файловое дерево. Основой этого дерева является так называемый "корневой раздел" (root partition), который обозначен знаком "/". Все остальные разделы (включая съемные накопители информации) должны быть особым образом присоединены (или ПРИМОНТИРОВАНЫ) к корневому разделу для того чтобы образовать то самое единое файловое дерево. Для правильного монтирования раздела (носителя, файловой системы, устройства) нужно указать точку монтирования этого раздела (носителя, файловой системы, устройства). Например, у меня есть CD-ROM, на котором находятся две папки (пусть будут "папка1" и "папка2"). В качестве точки монтирования я укажу папку cdrom, находящуюся в директории mnt на корневом разделе диска (/mnt/cdrom). Тогда после монтирования путь к каталогу "папка1" будет выглядеть следующим образом: /mnt/cdrom/папка1. Трудно? Я знаю, что трудно, но ничего тут не поделаешь... Для работы с Юникс системами просто необходимо научиться разбираться в этих вещах. Но сейчас тебе надо просто добавить ext2 раздел и обозначить его как корневой (root). Для этого снова жми Add и вводи следующие параметры: Mount point = / (то самое обозначение корневого раздела); Partition Type = Linux Native; Size(Megs) = тут введи цифру, наиболее близкую к оставшемуся количеству свободного места. Вдобавок к этому нажми кнопку Grow to fill disk - это позволит разделу занять все оставшееся свободное место на диске. Ввел? Жми ОК. В окне разделов должна появиться соответствующая строка.


Спецвыпуск Хакера, номер #005, стр. 005-056-4, Ставим Линукс

Ставим Линукс

Спецвыпуск Хакера, номер #005, стр. 005-056-4

Когда ты будешь выбирать Mount Point, ты увидишь, что, кроме "/", можно выбрать еще несколько вариантов (/usr, /home и т.п.). Сейчас не задумывайся о том, для чего это нужно... Когда ты толком разберешься с архитектурой Линукс - а это придет только с опытом, - тогда ты и начнешь пользоваться этими опциями. Ну что, готово??? Великолепно! Жми Next!


Спецвыпуск Хакера, номер #005, стр. 005-056-5, Ставим Линукс

Ставим Линукс

Спецвыпуск Хакера, номер #005, стр. 005-056-5

После того как ты победил disk druid, предложение отметить разделы для форматирования кажется просто чепухой, не так ли? Тем более, что тебе надо отметить всего лишь раздел под названием "/". Других просто нет (Swap не в счет). Если хочешь, чтобы при форматировании отсеклись поврежденные блоки жесткого диска, отметь опцию Check for bad blocks... Готово? Next!

Теперь ты добрался до конфигурирования системного загрузчика LILO (Linux Loader). Чтобы долго тут не задерживаться, сделай все так, как скажу я. Опции Create boot disk и Do not install LILO должны быть отключены (не перепутай). В подразделе Install LILO boot record on отметь First sector of boot partition (повторяю, именно эту опцию - это ОЧЕНЬ важно). Все остальное можно оставить неизмененным. Снова Next.

Мне кажется, что с установкой временной зоны у тебя проблем не возникнет. Тем более, эта часть инсталляции оформлена довольно весело - можно поиграть с картой земного шара :). Когда вдоволь наиграешься, отметь свою временную зону, уверься, что опция System clock uses UTC отключена, и жми... сам знаешь, какую кнопку :).

Следующие два этапа посвящены конфигурированию аккаунта суперпользователя root и, по выбору, нескольких аккаунтов пользователей. Так как на самом деле пользовательские аккаунты - та еще штука, то рекомендую на этом этапе оставить их в покое и не трогать до тех пор, пока ты не освоишь основы администрирования и распределения прав доступа. Так что просто введи пароль, который будет использоваться как пароль суперпользователя (Root password), и следующим шагом отметь опции Enable MD5 passwords и Enable shadow passwords. После этого переходи к следующему разделу установки.

Сейчас тебе придется выбрать пакеты программного обеспечения, которое будет поставлено на твой компьютер. Что за пакеты, ты хочешь спросить? Отвечаю - наиболее распространенной формой поставки софта для Red Hat являются так называемые RPM-пакеты. В этих пакетах содержатся уже скомпилированные программы и инструкции по их установке. В целом, установка RPM-пакета многим похожа на установку софта для Windows. Так же в Red Hat ведется база данных по установленным пакетам, а средства управления пакетами (например, GnoRPM) обладают гибкими и удобными инструментами установки, удаления и апгрейда программного обеспечения. Для удобства пакеты собраны в группы. Каждая группа отвечает за какой-то определенный вид софта. Например, существуют такие группы, как Applications/Games (тут собраны игры), Applications/Internet (содержит программы, имеющие отношение к Интернет) и т.п. При инсталляции Линуха поставляемое ПО тоже объединено в группы, и, хотя эти группы несколько отличаются от тех, с которыми ты столкнешься после установки, разобраться с ними не трудно. Но так как ты ставишь систему в первый раз, я помогу тебе определить, какие группы RPM-пакетов надо выбрать. Потом, когда ты научишься работать с базой данных RPM и определять, какие пакеты тебе нужны, а какие нет, ты сможешь убрать из своей системы все лишнее и поставить то, что кажется тебе необходимым. Ну а пока слушай :). Я сейчас не буду подробно объяснять назначение каждой группы ПО, с этим ты сам потом разберешься, а просто назову те из них, которые ты должен отметить. Вот этот список:


Спецвыпуск Хакера, номер #005, стр. 005-056-6, Ставим Линукс

Ставим Линукс

Спецвыпуск Хакера, номер #005, стр. 005-056-6

Printer Support

X Window System

Gnome

KDE

Mail/WWW/News Tools

DOS/Windows Connectivity

Graphic Manipulation

Multimedia Support

Networked Workstation

Dial Up Workstation

Development

Utilities

Эти группы будут необходимы при приобретении первых навыков работы с Linux. Впоследствии, если ты решишь переинсталлировать систему, обрати внимание на опцию Selеct individual packages - она позволяет вручную отметить каждый пакет, который ты хочешь поставить. Как только ты закончишь с этим, переходи к финальной стадии конфигурации - настройке графического интерфейса.

Настройка графического интерфейса очень проста и состоит из двух стадий. На первой стадии ты должен выбрать из списка тип своего монитора. Linux поддерживает очень большое количество различных мониторов, поэтому проблем с этим возникнуть не должно. После этого ты переходишь к выбору видеокарты (тоже огромнейший список) и опций графического интерфейса. На этой стадии, после выбора видеокарты и количества видеопамяти, обязательно (!!!) нажми кнопку Test this configuration. При этом должен запуститься тестовый режим GUI. Если все в порядке (а так и должно быть), то отключи все три оставшиеся опции (что-то про configure, graphical login и skip) и жми кнопку Next.

Ура!!! Конфигурирование системы для инсталляции закончено. Перед тобой рисунок разлетающегося вдребезги компьютера (на заднем фоне мелькает рука с гаечным ключом - наш подход, хакерский :)) и невинное приглашение в очередной раз нажать уже надоевшую пимпу Next. Так и сделай. После этого можешь пойти попить кофе (пиво не пей - работы еще немерено). Установочная программа начнет форматировать вновь созданные разделы, копировать софт и прописывать конфигурационные файлы. Это должно занять достаточно много времени. При этом, в течение всего процесса, на экране будет висеть индикатор прогресса инсталляции, так что ты всегда сможешь определить, стоит ли налить еще одну чашку :).

Итак, процесс установки завершился! На экране нарисовался целехонький комп, и на экране этого компа нарисована уже знакомая физиономия типчика в шляпе :). Рядом с этим рисунком начертан поздравительный текст, призывающий перезагрузить компьютер. Откладывать это дело не стоит, поэтому жми Exit (наконец-то. хоть какое-то разнообразие) и перезагружайся. При перезагрузке не забудь вынуть CD-ROM и выставить в настройках BIOS нормальную загрузочную последовательность.

Мигая и покряхтывая, комп перезагружается... перезагружается... в Windows! Да, не удивляйся и не пугайся, так и было задумано! Теперь настал черед программы Boot Magic. Просто запусти Setup, и утилита установится. После установки она протестирует твой винт и выдаст список обнаруженных операционных систем. Жми Save/Exit и перезагружайся еще раз :). Теперь вместо надписи Starting Windows98 ты увидишь Loading Boot Magic, после чего тебя выкинет в меню загрузки. Наводи курсор на Linux и дави на левую кнопку мыши. После появления на экране монитора надписи LILO boot... нажми Enter и наслаждайся. Сперва по экрану поползут надписи тестирования железа, после этого загрузчик начнет запускать системные сервисы. Успешный запуск очередного сервиса будет отмечаться цветным OK. Очень скоро это закончится, экран очистится, и появятся две строчки с названием операционной системы (то бишь Red Hat 6.2), чуть ниже которых ты увидишь приглашение к входу в систему. Введи логин root (ты входишь как суперпользователь, обладая неограниченными правами) и на следующее приглашение (password) - пароль, который ты назначил при инсталляции. Не удивляйся тому, что при вводе пароля экран не отображает никаких звездочек, это сделано в целях безопасности. Если ты все ввел правильно, то перед тобой появится приглашение командной строки следующего вида:


Спецвыпуск Хакера, номер #005, стр. 005-056-7, Ставим Линукс

Ставим Линукс

Спецвыпуск Хакера, номер #005, стр. 005-056-7

[root@localhost /root]#

Теперь можно перейти в графический режим. Для этого набери команду startx. Запустится менеджер окон Gnome. Пока что тебе Гном не нужен, поначалу лучше работать в KDE, поэтому щелкни по значку меню (левый нижний угол) и выбери KDE menus -> Red Hat -> System -> Desktop Switching Tool. В открывшемся окне выбери KDE и нажми OK. Теперь надо выйти из Гнома (меню -> logout) и снова набрать startx.

Теперь загрузится уже KDE - чрезвычайно надежная и удобная графическая среда. Внешний вид KDE очень легко настроить по своему вкусу. Как это сделать - прочитай сам, у KDE очень хорошая документация. Сейчас самое важное - выйти в Интернет и добыть программу, которая заставит твой Линух понимать русский язык. Поэтому займись настройкой соединения с провайдером. Для этого выйди в меню и запусти Internet -> kppp. Настроить kppp очень просто - во вкладке Device укажи порт, на котором висит твой момед (виндосовские COM порты в Линуксе называются, соответственно, ttyS1, ttyS2 и так далее), во вкладке Modem выбери Modem Commands и замени ATDT на ATDP (это обеспечит пульсовый набор), во вкладке РРР обозначь галочками все, кроме Minimize window on connect, и во вкладке Account выбери New. Введи номер телефона твоего провайдера, название нового соединения (типа SuperProvider). Autentification обозначь как PAP (подходит для 99% провайдеров). Готово. В главном окне введи имя пользователя и пароль и жми Connect. Если возникает проблема с подключением, можешь попробовать немного снизить установки скорости соединения. Как только установится коннект, окошко программы свернется и спрячется в панель. Теперь запускай Netscape (иконка на панели) и набирай адрес http://linuxrulz.newmail.ru/X11/Xrus/. Отсюда нам нужна программа CyrillicX-1.6-1.i386.rpm. Да-да, это именно RPM-пакет. Как только программа скачается, запусти меню -> Gnome -> System -> GnoRPM. Это программа управления RPM-пакетами. Интерфейс программы очень прост, и я думаю, что ты сам можешь установить скачанный пакет. Установил??? Теперь надо перезагрузить KDE. Это делается через тот же logout. Но перед тем как снова запустить GUI, необходимо внести поправки в файл конфигурации сервера графического интерфейса (Испугался? Попросту - Х сервера.). Набери команду mc. Запустится программа, очень похожая на Norton Commander. Перейди в папку /usr/lib/X11 и с помощью клавиши F4 открой для редактирования файл XF86Config. В нем найди строку

XkbDisable #Xcyrsytup

и удали ее. F2 - сохранить, F10 - выйти. Можно смело набирать startx. Снова загрузится KDE, только теперь твой GUI умеет читать по-русски! :) Осталось добавить русскую раскладку клавиатуры. Это можно сделать с помощью программы International Keyboard Layout (KiKbd), которая запускается через меню -> System. Просто добавь раскладку Russian-koi8, и отныне ты сможешь печатать русскими символами :).


Спецвыпуск Хакера, номер #005, стр. 005-056-8, Ставим Линукс

Ставим Линукс

Спецвыпуск Хакера, номер #005, стр. 005-056-8

Ну вот, я рассказал тебе, как установить операционную систему Linux, выйти в Интернет и заставить Пингвина понимать русские шрифты. Теперь все зависит от тебя. Дочитывай спец, ищи в Инете документацию, читай ее, приобретай опыт работы в Линухе. Если возникнут какие-то проблемы - пиши письма, по возможности отвечу. Но сразу предупреждаю - первые шаги в Linux могут показаться ОЧЕНЬ трудными. Не отступай, и скоро Пингвин станет твоим лучшим другом. :) Удачи!


Спецвыпуск Хакера, номер #005, стр. 005-062-1, Логгеры Траффика - узнай своих врагов в лицо

Логгеры Траффика - узнай своих врагов в лицо

Спецвыпуск Хакера, номер #005, стр. 005-062-1

LonerX (lonerx@crosswinds.net)

Ура, началось

Ну вот, наконец-то свершилось! Ты поставил долгожданный Линукс, настроил РРР и начал активную деятельность на просторах Инета. Ты научил XChat и Kicq понимать русский язык, твой Нетшкаф оброс всевозможными плугинами, и ты испытал радость общения с ИнтерСетью при помощи программ интерфейса командной строки (я имею ввиду незабвенные Lynx, ftp, telnet, BitchX и Micq). При проверке почты тебе теперь не надо испуганно ждать результатов работы Детища Дяди Касперского, а любая попытка выкинуть твою машину из сети с помощью нюка оказывает на тебя такое же действие, как известная дробина на не менее известного слона ;). Казалось бы, что можно уже и расслабиться, но что-то все равно не дает долгожданного покоя и мешает получить то удовольствие, на которое ты надеялся, когда затевал всю эту муть с установкой и настройкой своего UNIX'a.

Для того чтобы понять причины этой неудовлетворенности, необходимо вспомнить старые добрые времена, когда ты вылезал в сеть из-под операционной системы Windows и боялся всего на свете, а в особенности злобных троянских коней и не менее злобных любителей засветить на твоем дисплее "Синий Экран Смерти". Естественно, ты пытался защититься от подобных посягательств на твою сетевую жизнь с помощью различных программ, которые не только не позволяли злоумышленникам порушить твою машину, но и заботливо сообщали тебе о тех IP, с которых эти злоумышленники пытались испортить тебе жизнь. И как же приятно было не только (и не столько!) осознать провал очередной попытки вынести тебя из сети или прилепиться к порту 12345, но и увидеть адрес того лоха, который пытался это проделать :). Так что даже теперь, когда ты вспоминаешь о творении Билли Гейтса с гримасой отвращения, и твой компьютер превратился из дырявых, сквозящих форточек в монолитную стену UNIX, тебе не хватает именно того злорадного ощущения ОСВЕДОМЛЕННОСТИ, которое приносил, например, лог Nuke Nabber'a. И ты с теплотой и ностальгией вспоминаешь знакомые надписи типа "udp connection attempt to port 31337 from ***.***.***.***, где вместо звездочек стоял IP того деятеля, который пытался (наивный!) выставить тебя последним дятлом.

Ты, наверное, уже понял, к чему я веду весь этот разговор... Правильно, в этой статье я собираюсь рассказать о том, как поставить и настроить программы, которые помогут тебе выявить попытки сетевого наезда и адреса тех умников, которые решили на тебя побычить. Несмотря на огромное количество различных утилит, выполняющих подобные функции, я решил остановиться только на двух из них. Установка и настройка этих программ не очень сложна, но тем не менее они (программы) выполняют (и перевыполняют) свои обязанности. Я говорю о прогах iplog и portsentry. Но начнем по порядку.

Айпилог

Итак, первая утилита, которую тебе стоит занести в список "полезных вещей", носит "говорящее" название iplog. Эта программа занимается тем, что фиксирует TCP, ICMP и UDP трафик, проходящий через твой РРР-интерфейс. Помимо тупого логирования, iplog имеет несколько очень полезных функций, как то: встроенное кэширование DNS, распознавание UDP, port, null, FIN сканирования и определение нескольких распространенных видов сетевых атак. Iplog настраивается с помощью редактирования конфигурационного файла или аргументов командной строки. Для компиляции программы необходимо наличие библиотеки libpcap. Покопайся в своих RPM, и если эта библиотека не установлена, то ты сможешь найти ее на диске с дистрибутивом. Если ты сидишь под BSD, то можешь даже не дергаться, libpcap установлена по умолчанию :).


Спецвыпуск Хакера, номер #005, стр. 005-062-2, Логгеры Траффика - узнай своих врагов в лицо

Логгеры Траффика - узнай своих врагов в лицо

Спецвыпуск Хакера, номер #005, стр. 005-062-2

Теперь тебе надо скачать исходники iplog. Адрес официальной страницы программы - http://ojnk.sourceforge.net. Там же ты найдешь и ее последнюю версию (на момент написания статьи 2.2.1). Скачав архив, помести его в выбранную тобой для подобных дел директорию и разархивируй, введя команду tar zxvf iplog-2.2.1.tar.gz. После этого остается перейти в образовавшийся каталог (cd iplog-2.2.1) и приступить к процессу конфигурирования и компиляции. Для подготовки исходников к компиляции достаточно набрать "./configure" в командной строке... Но!!! По умолчанию скомпилированные файлы устанавливаются в /usr/local, и если ты хочешь поместить их в /usr (как это сделал я), то тебе придется запустить конфигурационный скрипт следующим образом - "./configure --prefix=/usr". После этого можешь на какое-то время расслабиться и смотреть на экран... Если скрипт завершит работу без сообщений об ошибках, то первую половину дела можно считать завершенной ;). Итак, предположим, что все закончилось нормально (а так и должно быть!), теперь смело набираем "make"... Придется подождать подольше... Если конфигурирование прошло успешно, то и компиляция не создаст проблем. Тем не менее не забывай внимательно следить за ходом всего процесса и отсекать сообщения об ошибках. Если таковых не возникло, то считай, что все готово! Ура, наконец-то!!! Теперь заходим под root (если ты не сделал этого с самого начала :0)) и торжественно набираем "make install"... Все, программа iplog скомпилирована и готова к работе.

Осталось запустить новоскомпилированную утилиту :). Для этого набираем в окне терминала "iplog -l iplog" (программа, запущенная с этой опцией, пишет отчет в файл iplog в текущей директории). Для вывода лог-файла воспользуемся программой tail (набираем "tail -f iplog"). Ура! - по окошку терминала пополз отчет о трафике. Приведу несколько примеров сообщений о различных акциях:

- попытка наезда типа flood ping

Sep 11 05:27:55 ICMP: ping flood detected from dialup-27131.dialup.ptt.ru

Sep 11 05:29:08 ICMP: ping flood mode expired for dialup-27131.dialup.ptt.ru - received a

total of 403 packets (25792 bytes)

- smurf атака

Sep 11 05:33:07 ICMP/UDP: smurf attack detected from 137.154.113.0

Sep 11 05:34:04 ICMP/UDP: smurf attack mode expired for 137.154.113.0 - received a total of 41

packets (328 bytes)

- попытка убийства с помощью teardrop и последующий ping для проверки состояния

Sep 11 07:29:34 Duplicate IP fragments from 192.168.250.250


Спецвыпуск Хакера, номер #005, стр. 005-062-3, Логгеры Траффика - узнай своих врагов в лицо

Логгеры Траффика - узнай своих врагов в лицо

Спецвыпуск Хакера, номер #005, стр. 005-062-3

Sep 11 07:29:34 last message repeated 3 times

Sep 11 07:29:34 Overlapping IP fragments from 192.168.250.250

Sep 11 07:29:34 ICMP: echo from ns.worldsfinest.net (64 bytes)

Sep 11 07:29:34 last message repeated 5 times

- попытка "заморозить" машину посредством joilt2

Sep 11 07:34:40 Duplicate IP fragments from ns.worldsfinest.net

Sep 11 07:35:09 last message repeated 1423 times

И это отнюдь не весь перечень возможных сообщений, генерируемых программой! Как видишь, теперь любой злодей не пройдет незамеченным, и твое право решать - простить лоха и ламера или, зловеще ухмыляясь, набрать в окошке терминала "ping -s 65000 dial-up25.lamerhere.org" ;).

Портсентри

Теперь перейдем ко второй утилите. Если iplog просто занимается логированием трафика и дает тебе возможность своевременно среагировать на действия "удаленного злоумышленника", то portsentry (так называется вторая программа нашего обзора) более активно реагирует на нежелательные проявления сетевой активности. Основная задача этой проги - отслеживание попыток сканирования системы. Ты спросишь, зачем это надо? Отвечаю - любой компьютерный взломщик (в народе - хакер ;)) при выборе потенциальной жертвы первым делом проверит наличие открытых портов на удаленной системе и определит версии висящих на них сервисов. И проделает он это именно при помощи сканирования. Так что можно с уверенностью сказать, что сканирование твоей (да и любой) системы является прелюдией к более серьезным действиям со стороны сканирующего. Вот для того, чтобы своевременно и адекватно реагировать на эти "маленькие звоночки смерти", и нужна программа portsentry. Она определяет факт сканирования и (по выбору) реагирует на него следующими действиями:

1. Регистрирует событие при помощи syslog()

2. Автоматически прописывает адрес сканирующего в файл /etc/hosts.deny

3. Перенастраивает систему так, что весь трафик с вражеского адреса перекидывается на т.н. "мертвый" хост, что создает эффект "исчезновения" твоего компьютера из сети.

4. Все IP пакеты, поступающие с "опасного" хоста, начинают прогоняться через локальный фильтр IP пакетов (попросту - файерволл).

От других утилит, выполняющих подобные действия, portsentry отличается более гибкой системой реакции на "ощупывание" системы и улучшенным механизмом распознавания stealth-сканирования. Программа располагает несколькими методами stealthscan-распознавания, но основными являются следующие два. Первый метод заключается в том, что portsentry "пасет" определенные порты и начинает действовать при попытке "воткнуться" в них. Второй метод можно назвать "обратным" или, как назвал его автор программы, "инверсивным". В этом случае программа прослушивает ВСЕ порты определенного диапазона за исключением портов, на которых висят демоны. Последний метод, конечно, более эффективен в плане защиты, но также чреват большим количеством ложных тревог.

Кажется, я уже наговорил достаточно о возможностях и преимуществах portsentry :). Теперь приступим к скачиванию, установке и запуску этой великолепной программы. Итак, первым делом отправляемся на http://www.psionic.com. Это официальная страница проекта, который занимался разработкой нужной нам утилиты. Там мы хватаем файл под названием portsentry-***.tar.gz, скачиваем его, помещаем в папку, которую мы отвели для архивов, и разжимаем c помощью команды tar zxvf portsentry-***.tar.gz. Затем переходим в новообразовавшуюся папку и начинаем колдовать :). Прежде всего мы открываем файл Makefile и меняем строку CC=cc на СС=egcs и строку INSTALLDIR=/usr/local/psionic на INSTALLDIR=/usr/psionic. После этого открываем файл portsentry_config.h и там производим замену #define CONFIG_FILE "/usr/local/psionic/portsentry/portsentry.conf" на #define CONFIG_FILE "/usr/psionic/portsentry/portsentry.conf". Основная подготовка исходников к компиляции готова. Теперь вводим make linux. После того как закончится компиляция, набираем make install. Программа установлена, но теперь ее надо отконфигурировать и запустить. Конфигурирование portsentry производится с помощью файла /usr/psionic/portsentry/portsentry.conf. Откроем этот файл и посмотрим, что же в нем написано. Ага!!! Мы видим огромное количество закомментированных строк с очень пространными пояснениями к ним. Все что нам надо сделать - это избавить нужные нам строки от знака комментария "#". Внимательно прочитай пояснения к строкам перед тем как убирать знак "#" с каких-либо из них. Ниже я привожу пример готового конфигурационного файла (нужные строки раскомментированы, ненужные просто удалены).


Спецвыпуск Хакера, номер #005, стр. 005-062-4, Логгеры Траффика - узнай своих врагов в лицо

Логгеры Траффика - узнай своих врагов в лицо

Спецвыпуск Хакера, номер #005, стр. 005-062-4

#######################

# Port Configurations #

#######################

TCP_PORTS="1,11,15,79,111,119,143,540,635,1080,1524,2000,5742,6667,12345,12346,20034,31337,

32771,32772,32773,32774,40421,49724,54320"

UDP_PORTS="1,7,9,69,161,162,513,635,640,641,700,32770,32771,32772,32773,32774,31337,54321"

###########################################

# Advanced Stealth Scan Detection Options #

###########################################

ADVANCED_PORTS_TCP="1023"

ADVANCED_PORTS_UDP="1023"

ADVANCED_EXCLUDE_TCP="113,139"

ADVANCED_EXCLUDE_UDP="520,138,137,67"

######################

# Configuration Files#

######################

IGNORE_FILE="/usr/psionic/portsentry/portsentry.ignore"

HISTORY_FILE="/usr/psionic/portsentry/portsentry.history"

BLOCKED_FILE="/usr/psionic/portsentry/portsentry.blocked"

##################

# Ignore Options #

##################

BLOCK_UDP="1"

BLOCK_TCP="1"

###############

# TCP Wrappers#

###############

KILL_HOSTS_DENY="ALL: $TARGET$"

#####################

# Scan trigger value#

#####################

SCAN_TRIGGER="0"

######################

# Port Banner Section#

######################

PORT_BANNER="** UNAUTHORIZED ACCESS PROHIBITED *** YOUR CONNECTION ATTEMPT HAS BEEN LOGGED. GO AWAY."

Поясню этот файл поподробнее. В разделе Port Configurations отмечены те порты, которые будут прослушиваться программой. (Тут все просто.) Переходим к Advanced Stealth Scan Detection Options. Этот раздел отвечает за параметры "навороченного" определения stealth сканирования. ADVANCED_PORTS_TCP и ADVANCED_PORTS_UDP определяют верхние значения диапазонов прослушиваемых портов. Программа будет следить за портами, номера которых ниже указанных. Из этих диапазонов необходимо исключить несколько портов, которые могут быть "прощупаны" удаленными клиентами по ошибке и не должны вызывать тревогу. Это осуществляется с помощью значений ADVANCED_EXCLUDE_TCP и ADVANCED_EXCLUDE_UDP аргументов. Раздел Configuration Files содержит пути к конфигурационным файлам (ими займемся позже). В Ignore Options мы можем установить, будет система откликаться на прощупывание TCP и UDP или нет (система не будет отвечать при значении параметров "0"). TCP Wrappers задает формат строки, которая будет вставлена в /etc/hosts.deny файл в ответ на попытку сканирования. Опция SCAN_TRIGGER="*" устанавливает количество попыток соединения, после которого программа начнет блокировку. Со значением "0" программа отреагирует немедленно. И последний раздел, Port Banner Section, определяет текст, который будет показан удаленному хосту при попытке коннекта.


Спецвыпуск Хакера, номер #005, стр. 005-062-5, Логгеры Траффика - узнай своих врагов в лицо

Логгеры Траффика - узнай своих врагов в лицо

Спецвыпуск Хакера, номер #005, стр. 005-062-5

Хочется отметить, что приведенный файл конфигурации является ПРИМЕРОМ, и для того чтобы твоя программа заработала по-настоящему, тебе придется подумать своей головой :).

Теперь нам необходимо отредактировать /usr/psionic/portsentry/portsentry.ignore файл. Это просто. Надо всего лишь добавить туда 127.0.0.1 и 0.0.0.0.

Уффф... Львиная доля работы закончена! Но это еще не все (да уж, iplog попроще был :)). Теперь нам надо этот самый portsentry запустить. Все дело в том, что программа может быть запущена в ШЕСТИ режимах (для каждого протокола и для каждого типа мониторинга свой отдельный режим). Режимы работы portsentry задаются аргументами командной строки при запуске программы, и для каждого из них необходимо запустить отдельный процесс. Сейчас я расскажу тебе об этих режимах по порядку.

portsentry -tcp

portsentry -udp

Эти два режима предназначены для простого прослушивания обозначенных в конфигурационном файле портов. Это значит, что программа при запуске прочтет файл, откроет обозначенные порты и начнет ждать попытки соединения. Эти режимы очень хороши для эмуляции присутствия в системе троянских коней :). Для этого достаточно при настройке обозначить стандартные порты, занимаемые троянами, и ждать какого-нибудь ламера, сканирующего сеть на наличие, к примеру, открытых elite (31337) портов (для тех, кто не знает - порт 31337 по умолчанию открывается серверной частью BackOrifice). Как только этот лох с радостным предчувствием попытается приконнектиться к найденному порту, он будет грубо послан (вспомни, мы задействовали опцию port banner), и все его последующие попытки соединиться (если у него останется такое желание) будут обречены на провал :).

portsentry -stcp

portsentry -sudp

Эти режимы предназначены для выявления попыток stealth-сканирования. После запуска с указанными аргументами программа будет использовать raw socket для мониторинга ВСЕХ приходящих пакетов, и, если поступивший пакет предназначается для какого-либо из отмеченных в конфигурационном файле портов, portsentry заблокирует хост, от которого этот пакет пришел.


Спецвыпуск Хакера, номер #005, стр. 005-062-6, Логгеры Траффика - узнай своих врагов в лицо

Логгеры Траффика - узнай своих врагов в лицо

Спецвыпуск Хакера, номер #005, стр. 005-062-6

portsentry -atcp

portsentry -audp

При работе в этих режимах программа также займется отслеживанием stealth-сканирования. Отличие от двух описанных выше режимов заключается в том, что при запуске portsentry создаст список ВСЕХ портов, которые по значению ниже цифры, отмеченной в Advanced Stealth Scan Detection Options, затем исключит из этого списка те номера, которые мы отметили как ADVANCED_EXCLUDE_TCP(UDP), и займется мониторингом оставшихся в списке портов. Это наиболее чувствительный режим. Исходя из этого, он обеспечивает наилучшую защиту, но также провоцирует большее по сравнению с другими режимами количество ложных тревог.

К бесспорным достоинствам portsentry можно, несомненно, отнести "интеллект" этой программы. Например, при FTP соединении клиент открывает огромное количество портов, начиная с порта 1024, после чего сервер соединяется с любым из них. На подобную акцию portsentry мог бы ответить блокированием удаленного хоста :), но вместо этого программа проанализирует характер устанавливаемого соединения и, определив, что это именно временное FTP соединение, разрешит удаленному хосту соединиться с твоим компьютером.

Ну вот, я рассказал тебе о программе portsentry. То, как ты решишь ее использовать, зависит целиком и полностью от тебя. Возможно, тебе придется перелопатить большое количество документации для того чтобы полностью реализовать потенциал этой утилиты. Тут уж думай своей головой :).

Пользуйся

Ты познакомился с двумя программами, которые помогут тебе в нелегкой сетевой жизни :). Но учти, я рассказал об этих программах лишь вкратце... Для наиболее эффективного их использования тебе надо поднапрячься и прочитать прилагающуюся к ним документацию. Надеюсь, ты сможешь перебороть естественную природную лень и сделать это ;). В любом случае тебе доставит удовольствие тот факт, что отныне ты в состоянии вычислить всех злобных ламеров, которые надеются вынести тебя из сети или вломиться в твою машину :). Так что приятного времяпрепровождения, а я пойду просканирую еще пару хостов...

Помимо тупого логирования iplog имеет несколько очень полезных функций, как то: встроенное кэширование DNS, распознавание UDP, port, null, FIN сканирования и определение нескольких распространенных видов сетевых атак.

...теперь любой злодей не останется незамеченным, и твое право решать - простить лоха и ламера или, зловеще ухмыляясь, набрать в окошке терминала "ping -s 65000 dial-up25.lamerhere.org" ;).

Любой компьютерный взломщик (в народе - хакер ;)) при выборе потенциальной жертвы первым делом проверит наличие открытых портов на удаленной системе и определит версии висящих на них сервисов. И проделает он это именно при помощи сканирования. Так что можно с уверенностью сказать, что сканирование твоей (да и любой) системы является прелюдией к более серьезным действиям со стороны сканирующего.

Эти режимы очень хороши для эмуляции присутствия в системе троянских коней :). Как только лох с радостным предчувствием попытается приконнектиться к найденному порту, он будет грубо послан (вспомни, мы задействовали опцию port banner), и все его последующие попытки соединиться (если у него останется такое желание) будут обречены на провал :).


Спецвыпуск Хакера, номер #005, стр. 005-066-1, LiteSTEP: совсем как юних

LiteSTEP: совсем как юних

Zlob

Спецвыпуск Хакера, номер #005, стр. 005-066-1

После хотя бы одного часа использования любого юниксового менеджера окон стандартные убогие виндусовые окошечки и кнопочки (особенно самая мерзкая - "Пуск") вызывают, мягко говоря... неприязнь. Если ты один из таких юниксово-пробитых перцев или если тебя просто достал виндовый интерфейс, специально для тебя создана реальная альтернатива мастдайскому междумордию - Litestep.

Was ist das? Litestep - это заменитель эксплорера (в обычном понимании, не Internet ака Ослик ИЕ), который без особенных насилий над виндами тем не менее радикально преображает их внешний вид. Основные отличия - как и в юнихе, возможность полного переконфигурирования почти всех настроек под себя, несколько десктопов, system tray вверху слева по желанию ;) - в общем, об отличиях особенно много и не скажешь, их слишком много. LiteSTEP является "официальным" клоном известного юниксового window менеджера Afterstep, а это говорит о многом. Короче, must have installed однозначно!

А теперь - как же все это делается и с чем сервируется.

Инсталляция

Для начала хорошо бы этот litestep скачать. Последняя версия (на данный момент 0.24.5) всегда есть на http://www.litestep.net - официальный сайт. Дистрибутив поставляется в виде архива, так что распаковываем его в C:\TEMP (пока), потом запускаем install.exe и имеем все готовое в C:\LITESTEP.

Никаких приписок в регистре, все изменения - это добавление в system.ini строчки:

shell=C:\LITESTEP\LITESTEP.EXE

Отсюда хинт - если что пошло не так или л-степ не понравился (зло!), удалить его просто: стираем установочную директорию (С:\LITESTEP) и строчку в system.ini

Для выбора шелла при загрузке есть очень удобная прога SHELLSW, которая делает все изменения в ini-файле автоматом.

С инсталляцией вроде все должно быть ясно, переходим к настройке.

Настройка step.rc

Здесь начинается самое интересное: как правило, только что установленный litestep работать отказывается, и это правильно! После его установки и _до_ перезагрузки надо обязательно настроить step.rc, который представляет собой обычный текстовый файл с кучей параметров. Тем, кого пугает сама мысль о редактировании конфигурационных файлов, могу посоветовать LSCP или LiteStep Configuration Panel. Эта прога сама вносит все исправления в step.rc в зависимости от потребностей юзера, мы же будет все менять собственноручно - только так можно получить доступ ко всем фишкам. Большинство прелестей liteStep открывается только тем, кто провел за правкой step.rc не менее часа ;).

В самом начале step.rc обычно располагаются все основные и общие для системы настройки:

PixmapPath C:\LITESTEP\IMAGES\

Адрес, по которому хранятся все иконки, бэкграунды, картинки для wharf'a и т.д.

ThemeFile [file name]

Путь к .thm - файлу. На www.litestep.net около 1700 фриварных тем! Все картинки от темы должны лежать в директории PixmapPath.

SystrayOrientation [сторона]

Например, SystrayOrientation left - трей будет внизу слева. При отключенном taskbar'e можно вообще расположить его снизу вверх (vertical).

SystrayWrapCount [число]

Количество значков в систем трее, после которого они будут переноситься на следующую строчку. То есть если там 4 значка и в SystrayWrapCount стоит 2, то у нас будет приятный квадратик ;).


Спецвыпуск Хакера, номер #005, стр. 005-066-2, LiteSTEP: совсем как юних

LiteSTEP: совсем как юних

Zlob

Спецвыпуск Хакера, номер #005, стр. 005-066-2

TrayIconSize [число]

Задает размер значков в трее. 16 по умолчанию, попробуй поставить 64 - говорят, в 1600х1200 помогает.

TaskBarSkin [.bmp]

Скин к таскбару. Серую одноцветную панельку - в утиль!

MSTaskBar

TaskBarStartButton

No, no! Ведь ты не станешь добавлять эти строчки в свой step.rc - правда?

StripTaskBar

Обрезает таскбар так, чтобы он не перекрывался слишком длинным Wharf'ом (о Wharf'е чуть позже) или десктопными значками. В 99% случаев эту строчку добавлять надо.

LSTaskBarText [цвет]

Изменить цвет шрифта, которым будут выводиться названия приложений в таскбаре. Цвет здесь, как и в любом другом месте, записывается в виде шестнадцатиричного RGB (как и в HTML), то есть чтобы задать светло-голубой текст:

LSTaskBarText FFFF1F

Настройка десктопа и popup меню

Popup - это меню, которое выскакивает при нажатии правой клавиши мыши в любом месте десктопа или Wharf'a. В основном оно содержит ссылки на наиболее часто используемые программы, но никто не запрещает засунуть туда линки на 5 самых убойных трэков Blind Guardian или кривой линк на корень диска Ё, по которому можно лазить до посинения ;). В step.rc popup секция выглядит так:

HotListName "заголовок"

Надпись, которая будет выводиться над самим меню.

PopupTitlePix name.bmp

PopupEntryPix name.bmp

PopupSelEntryPix name.bmp

Картинки фона для заголовка, обычной и выделенной надписи в popup меню соответственно.

PopupTitleColor [цвет]

PopupEntryColor [цвет]

PopupSelEntryColor [цвет]

То же самое для выбора цвета шрифта в popup меню.

PopupSubMenuHeight [num]

Высота (размер) самого popup меню. Если число слишком большое, то между пунктами меню будет неприятный промежуток. Значение лучше подбирать вручную, по умолчанию там стоит 20.

PopupFontFace "Helvetica"

PopupFontHeight 20

Задает тип и размер шрифта надписей в popup'е. Так что не существует проблемы русификации как таковой - во всех местах можно делать надписи по-русски, лишь бы был указан фонт с отечественными буквами.

minpopupwidth [num]

Минимальный размер (в ширину) меню. Эта опция нужна, если есть куча мелких менюшек, и их необходимо как-то подогнать под один размер.

NoPopupBevel

Снять "тень" с меню. Не стоит по умолчанию, поэтому иногда довольно трудно понять, откуда берутся эти белые полосы по краям надписей: это тень, оказывается, такая.

Все это были "косметические" настройки, элементы же самого popup меню выглядят так:

*Popup Inet Folder

*Popup Edial c:\progs\edial\edialer.exe

*Popup TerraTerm C:\PROGS\TTERM\ttermpro.exe

*Popup DimaTerm "C:\PROGS\Dima Mallof\tn.exe"

*Popup Mirc C:\PROGS\MIRC\mirc32.exe

*Popup ~Folder

Ключевое слово Folder означает вложенное подменю с заголовком до слова Folder, то есть в данном примере описывается подменю Inet с встроенными элементами. Сами же элементы описываются просто:

*Popup name "filename"

Имя файла необходимо заключать в двойные кавычки, если оно содержит пробелы. Вместо имени файла можно написать одну из внутренних команд LiteStep'a:


Спецвыпуск Хакера, номер #005, стр. 005-066-3, LiteSTEP: совсем как юних

LiteSTEP: совсем как юних

Zlob

Спецвыпуск Хакера, номер #005, стр. 005-066-3

!Recycle - Перезагружает LiteStep и считывает заново все настройки из step.rc. Вообще, после любых изменений в этом файле надо делать Recycle, чтобы в текущей конфигурации отразились все изменения.

!Shutdown - Выводит табличку "Завершение работы с WindowS".

!Logoff - То же самое, что и "Войти в систему под другим именем".

!Run - Запуск приложения (стандартное виндовое окно).

!Gather - Собирает все окна со всех виртуальных десктопов в текущий (об этих виртуалах см. чуть ниже - forward reference).

!ToggleWharf - Включить/выключить, втянуть/вытянуть Wharf.

!Quit - Выйти из LiteStep'a (в чистый TaskManager). Или в эксплорер, если степ был загружен из него. Но этого я делать не советую - половина функций не работает вообще, другая половина просто глючит.

!Popup - Вывести на экран popup menu.

Или вот еще несколько полезных команд:

"explorer /root,,::{20D04FE0-3AEA-1069-A2D8-08002B30309D}" - это аналогично значку "Мой Компьютер".

"explorer /root,,::{20D04FE0-3AEA-1069-A2D8-08002B30309D}\::{21EC2020-3AEA-1069-A2DD-08002B30309D}" - а это "Панель управления".

Все эти специальные команды можно вызывать в любом месте, где встречается имя файла.

Настройка Wharf

Wharf - это такая выползающая шняга (на скринах фиолетово-серого цвета), которая содержит в себе еще большее количество выползающих шняг ;)). В общем, это что-то вроде popup меню, но с картинками. Структура у него почти такая же:

*Wharf "System Folder" b24_sys.bmp Folder

*Wharf "Recycle" b24_recycle.bmp !Recycle

*Wharf "Step.rc" b24_folder.bmp notepad C:\LITESTEP\step.rc

*Wharf MS-DOS b24_dos.bmp command.com

*Wharf Explorer b24_explorer.bmp explorer.exe

*Wharf Logoff b24_logout3.bmp !Logoff

*Wharf "Shutdown Windows" b24_shutdown.bmp !Shutdown

*Wharf ~Folder

Как видно, добавился только файл картинки (все они должны быть в директории, указанной в PixmapPath).

Так же как и popup меню, Wharf может содержать вложенные элементы (они определяются так же).

Hotkeys

Заданный в step.rc хоткей будет работать везде где только можно, так что не стоит делать простые комбинации типа Alt-0 или Ctrl-1. Хоткей задается так:

*Hotkey {модификатор} {клавиша} {имя файла}

В качестве модификаторов можно указать Ctrl,Alt,Shift,Win (Это та самая "бесполезная" кнопка на microsoft-style клавиатуре. Хоть сюда-то ее можно пристроить.). Или их комбинации через знак +.

Клавиша - любая буква или цифра. Вместо файла можно использовать команду:

*Hotkey Ctrl+Alt W !ToggleWharf - Задает вползание/выползание Wharf'a при нажатии ctrl-alt-w.

Desktop

Понятия свободно разбросанных значков на "рабочем столе" в LiteStep'е как такового нет. Все значки жестко задаются своими координатами и параметрами:

*Shortcut {"имя"} {x} {y} {image1.bmp} {image2.bmp} {image3.bmp} {команда}

х и у - это смещение картинки относительно верхнего левого угла экрана. Можно использовать отрицательные значения, тогда смещение будет производиться от нижнего правого угла.

Первая картинка - это просто изображение значка, она заменяется на вторую, когда над значком проезжает мыша, и переходит в третью, если на значке был произведен клик.


Спецвыпуск Хакера, номер #005, стр. 005-066-4, LiteSTEP: совсем как юних

LiteSTEP: совсем как юних

Zlob

Спецвыпуск Хакера, номер #005, стр. 005-066-4

Вот пример лампочки в нижней части экрана, при клике на которую вызывается NC:

*Shortcut "NC" -64 -64 b24_scdos1.bmp b24_scdos2.bmp .none c:\litestep\pif\nc.pif

Виртуальные столы

Одной из приятных особенностей litestep является заимствование из юниксовых графических менеджеров всей системы виртуальных десктопов. Их, правда, всего четыре, но, я думаю, для начала хватит. Идея проста: пространство рабочего стола расширяется в четыре раза, позволяя переключаться между ними с помощью специального модуля VWM (Virtual Window manager). VWM описывается в секции wharf, только имя файла заменяется на адрес к библиотеке менеджера:

*Wharf "VWM" b24_vwmbg.bmp @C:\LITESTEP\lsvwm.dll

Таким образом задается местоположение окна VWM. У него есть несколько специфичных настроек:

VWMNoAuto

VWMVelocity 300

VWMSecurityDistance 5

Эти параметры определяют возможность автопереключения десктопов с помощью мыши. Если подвести мышь к левому краю экрана, то менеджер переключит десктоп на соседний, создавая иллюзию расширенного рабочего стола. Десктопы также можно переключать, кликая в нужный на самом окне VWM или с помощью стандартных хоткеев Alt-стрелка.

Все! В заключение хочется отметить, что хотя Litestep и может сначала показаться громоздкой и непродуманной системой, но после хорошей настройки "под себя" и месяца работы только в нем типичный эксплорер будет казаться ортодоксом. Попробуй! Полюбишь...


Спецвыпуск Хакера, номер #005, стр. 005-070-1, Обзор дистрибутивов Linux

Обзор дистрибутивов Linux

Warlock (warlock22@male.ru)

Спецвыпуск Хакера, номер #005, стр. 005-070-1

Интродакшн

Привет тебе, о начинающий линуксоид. Ты, надо понимать, уже проникся нежными чувствами к линухам и прочим унихам и теперь ощущаешь острую потребность оснастить своего железного коня этой могучей ОСью. И тут... Ага, точно! Посетив Митино-BazaaR, ты понял, что тех самых линухов на сидюках - вагон и маленькая тележка. И чего ставить - неясно. У продавцов спрашивать - дохлый номер, они сами не знают, чего продают. Поэтому в ответ на вопрос - а чем ЭТО отличается от ТОГО? - они тебе популярно перескажут надписи на обложке компакта. Однако установка Линукса - дело более чем серьезное, и если ты не хочешь в дальнейшем поиметь целую кучу разных геморроев и рвать волосы на попе по поводу отсутствия наличия чего-либо или узнать о принципиально невозможной русификации Star Office за два дня до сдачи какого-нибудь особо важного тугамента на сто листов преподу (начальнику), - давай провентилируем эту тему. Дистрибутивы Линукс - что к чему и почему.

Основные дистрибы

Тут вопрос философский :))). Смотря чего тебе от Линукса, собственно, надо. Если ты мощный корифей всяких *nix ОС-ов, то тебе проще поставить и настроить один дистриб, а если только начинаешь пользоваться кульно-хацкерской осью - то другой. На том, собственно, и основано разнообразие дистрибутивов. Итак...

Моей любимой версией дистриба Линуха (и не только моей) является BlackCat Linux 6.2.

xxxxxxxxxxxxxxxxx

BlackCat.jpg

xxxxxxxxxxxxxxxxx

И не просто так, поверь! Перво-наперво, ты получишь удовольствие от самого процесса установки - все четко и понятно как строевая подготовка. Нет колупаний со всякими fdisk-ами, которые каждый пишет как хочет. Все нужные разделы ты сделаешь с максимальным удобством - мышом и клавой. Причем, можно все сделать минимумом нажатий на кнопки - все уже установлено, типа, оптимально. Все партиции нужного раздела, и все такое. Далее процесс протекает быстро и гладко. Был у меня, правда, случай - все-таки вывалился при инсталляции в голографик шелл, но, как потом выяснилось, диск кривой был. Сей дистриб не сильно отличается от RedHat 6.2, каковым и является по сути. НО!!! У Черной Кошки есть одно (но КАКОЕ!) преимущество - она без проблем русифицируется, что ты оценишь в полной мере, поимев долгие недели нетрадиционного секса с Мандрэйком и Красной Шапкой версии ниже 6.0. В пакете с BC Linux идет StarOffice и куча всяких прилад для Инета. Типа, веб/ньюс/ftp-сервер, прокси и прочее. Иксы (XWindows) конфигурируются без проблем классной утилитой XConfigurator, так что если у тебя на компе нет какой-нибудь дикой экзотики, то все у тебя заведется сразу после инсталляции. Ядро системы - версии Linux 2.2.14 glibc-2.1.3. Строго и четко работают KDE/GNOME. Да, для гарных хлопцiв с Украины - ЕСТЬ ПОДДЕРЖКА УКРАИНСКОГО языка (koi8-u)! В плане дырявости - любимый wu-ftpd и wu-pop3d заменили на ftpd-BSD и popa3d :)))))), так что любителям поломать через дырявых демонов почты и ftp - обломится. Живет на 4 компактах, из которых 1 - установка, 1 - доки, сырцы, 1 - СтарОфис и 1 - всякие прилады и приблуды. Слить всю эту кучу можно тут: ftp://ftp.chg.ru/pub/Linux/blackcat


Спецвыпуск Хакера, номер #005, стр. 005-070-2, Обзор дистрибутивов Linux

Обзор дистрибутивов Linux

Warlock (warlock22@male.ru)

Спецвыпуск Хакера, номер #005, стр. 005-070-2

Второй по любимости и удобству дистр - это тот самый Red Hat 6.2, который Красная Шапка.

Не знаю я, чего в нем нашли хорошего, кроме Анаконды (anaconda - инсталлятор а-ля винды, графический, с кнопусечками и всеми делами). Нет, я ничего не имею против графических инсталляторов, но какой-то он на всю голову раненый. Местами (например, указание дисков, с которых ставить будешь) - удобен весьма (не в пример FreeBSD, геморрой еще тот!!!), местами - чувствуешь себя стоящим на асфальте и обутым в лыжи... Если тебе повезет и все поставится без проблем (в два этапа - подготовка и установка), то не спеши радоваться. В Красной Шапке две здоровенные засады - русификация и принтеры. Поставив себе RedHat, я уже потирал шаловливые ручонки и готовился к ходовым испытаниям многочисленных нюкеров и эксплоитов на врагах, как вдруг обнаружил, что "в реальности все не так, как на самом деле". Ну, СтарОфис 5.0 у меня поставился без особых проблем. А вот потом началось самое интересное - ну не понимает этот офис ttf-шрифтов. Я вскопал пол-Инета в поисках инфы по этому вопросу, однако был жестоко обломан в самых святых чувствах - не работают все советы. Оборвав последние волосы на голове и прочих местах, я наткнулся на RedHat 6.2 Cyrillic Edition. После установки этого дистра все завелось со свистом, только принтер работать упорно не хотел. Я уж было хотел плюнуть тягучей пролетарской слюной на это дело и печатать из-под МастДая, однако один кульный хацкер рассказал мне страшную тайну - оказалось, дрова от Хапуг (HP) - кривые, а надо скачать third-party драйверы, и все станет здорово. Помогло. :))))

В целом дистриб понравился - легко ставить, легко настраивать. Иксы пашут без глюков, консоль русифицирована - полный шоколад. В комплекте идут Иксы, Апачи, русский ТеХ. Размер - 3 компакта (нужен один). Слить можно тут: ftp://ftp.redhat.com/pub/redhat/

Следующий - Mandrake Linux 7.0.

Вау! Это круто, перец! Оно такое!!! Мне понравилось. Особо буйную радость вызывает наличие версии RE - Russian Edition, что есть несомненный гут. Установщик прост и понятен, ставится все на раз. Причем: есть возможность установки в существующий раздел виндов 9х, что тоже хорошо, мало ли... Установщик/конфигуратор DrakeX - действительно рульная штука. Сам оценишь, если задумаешь поставить. Если ты только начал знакомство с Линуксом, очень рекомендую начать с Linux Mandrake. Не так тяжко протекает миграция с Форточек за счет всяких там DrakeX, KDE 1.1.2 и прочих October GNOME. Russian Edition полностью понимает русский язык, 1251 кодировку (по-моему, единственный на сегодняшний день). Плюс следует целая куча софта типа графического редактора fltk, русифицированного текстового редактора Ted (кстати, он умеет даже переносы правильно ставить в русских словах). Если сильно надо, говорят, можно поставить украинский и белорусский языки, но сам я не ставил, сказать не могу. Плюс прилагается куча всяких асек - типа licq, micq и gnomeicu. Еще раз повторяю - однозначно грамотный дистр для новичков в Линухе. ТТХ такие: - ядро 2.2.14, GNU Compiler Collection 2.95.2, GNU C Library 2.1.2, XFree86 - 3.3.6. Для работы нужен проц не ниже Pentium 120, 16MB Ram, 1Gb HDD. Качать тут: ftp://ftp.cee.odu.edu/pub/CEE/linux/mandrake/iso/ или тут: ftp://ftp.twoguys.org/mandrake/iso/


Спецвыпуск Хакера, номер #005, стр. 005-070-3, Обзор дистрибутивов Linux

Обзор дистрибутивов Linux

Warlock (warlock22@male.ru)

Спецвыпуск Хакера, номер #005, стр. 005-070-3

Debian GNU/Linux 2.0

Дистрибутив мало-мало замороченный. Я тебе так скажу: если ты раньше с Линухом дела не имел, то сильно не рекомендую начинать с него. Ставить его ты замучаешься, и мучения начнутся еще с самого начала, когда кернел чего-нибудь не найдет и не подмаунтит. Fdisk, которым ты будешь делать разделы, писал человек со странным чувством юмора. Также я долго ходил загруженным по поводу создания загрузочных дискет к Дебиану (в дистре образов дискет нет, что весма фигово). Говорят, бывает так, что инсталляция запускается с CD, только, наверное, у меня CDROM неправильный... Пишет/поддерживает его целая толпа народу. Это и хорошо, и плохо сразу. Хорошо тем, что в комплекте к нему поставляется целая куча разнообразного софта различного назначения - от текстовых процессоров до графических пакетов. Плохо тем, что именно твой релиз дистрибутива по закону подлости окажется тем, что линуксописатели именуют словом "нестабильный релиз", и хрен ты поставишь всю эту кучу дополнительного софта. Типа, есть там такая утилита, dselect, ей ты все и поставишь... Только так бывает не всегда. В общем, и тут засада. Иксы (x-Windows Debian Group) работают вроде ничего, особенно радует какой-то хитрый менеджер Debian Package Management System, который проверяет ПЕРЕД установкой прикладного софта - все ли нужные пакеты есть в системе и совместима ли устанавливаемая софтина с тем, что уже есть в системе. Однако если тебе посчастливилось его поставить, ты протащишься с дизайна, как удав по щебенке. Чувствуется, что над интерфейсом работали люди с классным чувством меры и вкуса. ТТХ: ядро 2.0.35, 386 камень (у тебя есть? :)))) или мощнее, 16 метров памяти, 100 мег на харде (лучше 200). Живет на трех компактах. Качать тут: ftp://ftp.debian.org

Slackware Linux 3.6

Если ты крут и продвинут в линухах по самое не балуйся, то это для тебя. Я не столь крут и не принадлежу к стану поклонников Слаквары, хотя и ругать не хочу. Хотя есть масса людей, которые за свой любимый Шлак готовы порвать любого на ремешки и доказать, что все остальное вообще не линукс, а происки мастдая для ламеров. Первый загруз тебя ждет, когда ты будешь делать бутовые диски. Образов дисков до безобразия много, и все, типа, заточены под конкретную аппаратную конфигурацию. Честно тебе говорю, разбираться там можно до морковкина разговения, но мне повезло, и образ с именем bare.i мне подошел. Если ты все грамотно настроил и прописал, установка проходит пинцетно: если чего-нибудь забыл - не боись, если не свалится в процессе, то все недоставленное попросит тебя доставить, послав письмо на твое мыло. Во всяком случае должен посылать, судя по доке. В плане дырявости - довольно дыряв, написана и гуляет по сети туева хуча разновсяческих эсплоитов специально для Слаквары. Основная фишка Слаквары в том, что в комплекте сидюков есть один с установленным Линухом и иксами. Прямо на сидюке. Так что и Линух можно не ставить, а так посмотреть, как оно будет жить. Живет на четырех компактах, ядро версии 2.0.36, тачка с 386 (и мощнее) камнем, 16 метров памяти, 200 мег на HDD (для полной инсталляции - 500). Качать тут: ftp://ftp.cdrom.com/pub/linux/slackware


Спецвыпуск Хакера, номер #005, стр. 005-070-4, Обзор дистрибутивов Linux

Обзор дистрибутивов Linux

Warlock (warlock22@male.ru)

Спецвыпуск Хакера, номер #005, стр. 005-070-4

Minilinux

Если ты не совсем еще определился с выбором операционки и хочешь попробовать на зуб, чего там такого есть крутого и запредельного в этом Линухе, - поставь себе Минилинукс. Мини - он и есть мини. Максимум информации при минимуме затрат. Ставится легко и непринужденно, есть образ готовых дискет и простая утилита для их создания с маленькой (мини) придурью: я штук 10 дискет испохабил - утилита начинает делать дискету, а потом говорит, типа, плохая. Всем остальным операционкам дискета - хорошая, а тут, понимаешь... Ну, как сам шаришь, минимальность - штука серьезная, так что хрен ты чего к ней добавишь. Пакетов для инсталляции чего-нибудь нужного НЕТУ! Сильно напоминает кастрированный старинный SlackWare, которым, по-моему, и является. Да, кстати: по дефолту настроен французский язык. В общем, познакомиться, пощупать-попробовать - самое то, работать надо на чем-то другом. ТТХ: комп 386 и выше, 8 мег памяти, 10 мег ХДД. Качать тут:

ftp://ftp.superant.com/pub/smalllinux

Ну, и на закуску Linux SuSE 6.3

Этот дистрибутив меня от души порадовал. Первое, что ты оценишь, так это его размер. Шесть компактов, как тебе? Причем инсталлятор (кстати, очень неплохой и в двух вариантах, графический или текстовый) не особенно утруждается спрашивать тебя, чего ставить, а чего не ставить. Он все больше сам разбирается. Режимов инсталляции ровно два: автоматическая и ручная. Если ты не корифей, советую выбрать автоматическую. Там тебя меньше будут напрягать глупыми вопросами. Если ты думаешь, что в режиме ручной инсталляции ты сможешь лучше настроить систему, - ну, флаг тебе в руки. Я, например, не смог отучить yast (инсталлятор СуС-и) ставить Xwindows и KDE в полном варианте. Надо понимать так: создатели дистрибутива решили, что человек в здравом уме и твердой памяти не способен отказаться от такой крутой штуки, а, следовательно, - чего его спрашивать? При всем этом конфигуратор хороший, грамотно продумано расположение всего-всего: от кнопок до стрелок... Особенно умиляет разбивка харда под систему: типа, ручками или я само? А само - это на весь винт или на какую-то его часть. Вот когда на весь винт - тогда тебе поставят все, чего есть за душой у этого дистриба. :)))) Например, мне наставилось почти 9 гигов. И я так понял - это не предел. Когда ты начнешь все это ставить, тебя по ходу дела просветят, что теперь у тебя загрузчик lilo и чего надо делать, если надо не lilo. Потом дистр найдет твою видюху и тоже попросит настроить... А вот потом! Тебе покажется, что все повисло. Не спеши проклинать долбанных программеров и китайцев, которые все это записали на кривые диски. На самом деле процесс установки в разгаре. Просто тихий он такой. Подождав некоторое время, ты будешь вознагражден надписью типа "все, молоток, логинься!". Пароль рута тебя тоже спросят по ходу установки. Кстати, тебя там же спросят про настройки системы в плане языка, региональных настроек и прочего. Не спеши выбирать русский! Все потом легко меняется yast-ом, а вот на этапе установки могут быть глюки, если неправильно выберешь раскладку клавиатуры (их там 3 штуки). Насчет русификации - говорят, особых проблем нету, но сам не пробовал. После установки можешь уже работать. Никаких дополнительных настроек не надо. Ну, если у тебя какая-то экзотическая сетевуха или видеокарта, там yast-ом настроишь. Все просто, были бы дриверы. В целом дистр понравился %).


Спецвыпуск Хакера, номер #005, стр. 005-070-5, Обзор дистрибутивов Linux

Обзор дистрибутивов Linux

Warlock (warlock22@male.ru)

Спецвыпуск Хакера, номер #005, стр. 005-070-5

Финиш

Ну вот, мы и добрались до конца этой статьи. Только не думай, что это все дистры, существующие на свете. Сколько их всего на самом деле - не знает никто. Уж больно вещь хорошая. Может и ты со временем смонстрячишь какое-нить суперпуперкульное ядро версии ОГО-ГО!!!! - и будет дистр имени Васи Пупкина, кульного хацкера форева. И еще не забывай, что у каждого дистра есть воооот такая книженция-мануал. При работе с Линухом RTFM - это стиль жизни, так что читай. Одни мануалы более бестолковы, другие - менее, но во всех есть полезная информация. Помни про то, что у тебя есть твой острый глаз, шаловливые ручонки и весь мир, который ляжет к твоим ногам!


Спецвыпуск Хакера, номер #005, стр. 005-073-1, Поднятие Инета из-под юникса

Поднятие Инета из-под юникса

Спецвыпуск Хакера, номер #005, стр. 005-073-1

AvaLANche (kolyan@rnc.ru)"

Дарова, peretz! Поздравляю, ты поставил себе Linux (или другой *nix). Настроил систему, вбил нужный софт, поднял по необходимости сетевые сервисы. Но все равно тебя тревожит мысль, что чего-то не хватает... Порывшись еще на диске с дистрибутивом, ты увидел адрес конторы, которая его собрала. Обрадовавшись, что там может быть что-то интересное, ты запустил нетшкаф или lynx, ввел адрес, нажал Enter и... ОБЛОМ! О, ужас! Нет Инета! Что делать? Поднимать его!

ЗАЧЕМ?

Даже если полезностей на серваке дистрибутива (на самом деле не всегда так бывает :)) и всех других благ Инета тебе недостаточно, чтобы выложить за него пару зеленых президентов, тебе все равно придется его поставить :). Если, конечно, ты собираешься юзать Linux (о нем, в основном, речь дальше и пойдет). Линукс - система, полностью разрабатываемая через Интернет. Все с ней связанное, свежее, малоглючное (относительно, естественно :0)) можно найти только в Сети: багфиксы, последний софт, дистрибутивы etc. Ты, конечно, можешь сбегать на M1T1N0-bAzAr и надыбать парочку "кульных" дисков с дистро и софтом. Но то, что ты купишь, тебя мало порадует: это, скорее всего, будет старый глючный, находящийся в кривом виде софт, который может не скомпилиться или не пахать. Так что если у тебя до сих пор нет Инета, а ты поставил Linux (или собираешься), чтобы его юзать, то есть собираешься изучить на практике, что такое ядро и где находятся демоны и прочие программные потоки, надо срочно Инет надыбать. Без него ты будешь грузить Линукс исключительно на день рождения Линуса Торвальдса (что, не слышал про такого?) и для пущего понта перед тетками: "Типа, я - теперь линуксоидом стал, всех имею нюками с эксплоитами и ломаю Пентагон по выходным!". Да и, конечно, сможешь пофаршиться перед друзьями кул-хакерами своим дырявым софтом и старыми дистрибутивами. :)) Не знаю, убедил ли я тебя, выбор остается за тобой!

"ДАЙТЕ МНЕ ТОЧКУ ОПОРЫ, И Я ПЕРЕВЕРНУ ЗЕМЛЮ!" (С)

Архимед был не очень кульным хакером. Он забыл посчитать, что для поднятия Земли на 1 см ему понадобилось бы всего тридцать биллионов лет :). Нам для поднятия Инета столько времени, сил и длинных плеч не нужно. Все необходимое ты найдешь в любом дистрибутиве. Первое, что нужно - это мозги :), второе - текстовый редактор и третье - ppp-демон. Если не стоит :), инсталль с диска, качай с ftp://ftp.redhat.com. При всем этом я надеюсь, что еще не перекомпилил ядро, не забыв при этом отключить в нем поддержку ppp, tcp/ip или своего винта! Ладно, больше грузить не буду. За дело!

Сначала посмотри, есть ли у тебя pppd. Это прога-демон, позволяющая создавать ppp-соединение (Point to Point Protocol). Этот протокол используется для передачи tcp/ip-пакетов через телефонные линии - не зря же ты момед купил :). Раньше, в доисторическое время, когда все рубились в digger и были готовы убить за книгу по васику, народ юзал другой протокол - slip. Но после появления ppp он постепенно отошел как более лажовый. Pppd ищется командой "whereis pppd". В результате ты получишь /usr/sbin/pppd или /sbin/pppd. Если нет - ставь с диска или качай. Самое трудное сделано. :)


Спецвыпуск Хакера, номер #005, стр. 005-073-2, Поднятие Инета из-под юникса

Поднятие Инета из-под юникса

Спецвыпуск Хакера, номер #005, стр. 005-073-2

Переходим к настройке dns. Эта система (Domain Name System) отвечает за домены, т.е. позволяет тебе набирать при запросе просто pornokruto.nu вместо голимых цифр 212.181.91.6. Если не хочешь учить заново цифры, придется поработать пальцами :). За dns отвечают 3 файла: /etc/nsswitch.conf, /etc/resolv.conf и /etc/hosts.conf. Первый трогать не будем, а вот остальные придется подредактировать. Открываем /etc/resolv.conf (если нет такого, создай). Нацарапай в нем следующее:

### /etc/resolv.conf ###

domain твой_домен

nameserver ip_адрес_dns_сервера1

nameserver ip_адрес_dns_сервера2

### Конец /etc/resolv.conf ###

По порядку: в domain нужно указать твой домен (если у тебя он динамический, как и ip-адрес, - то забей); в nameserver - айпишник dns-сервака твоего прова (понасилуй немного тетку из тек-суппорта :0)), первичный ака главный и вторичный - не обязательный. Сохраняй и закрывай файло. В /etc/host.conf нужно прописать две строки:

order hosts, bind

multi on

Они отвечают за порядок поиска адресов. Voila, теперь можно юзать dns, система готова для коннекта. Делов-то было - это же Линукс! Будем дозваниваться.

DIAL-UP

Консоль меня больше радует, чем глючные и томозные иксы, так что я могу и в ней прожить. А для дозвона поэтому юзаю консольные фичи. С них и начнем. Вообще, сейчас мы разберем самый кул-хакерский способ: все пашет автоматически, а главное - сделано своими руками! Приступим! Заюзаем три bash-скрипта, которые почти все за тебя и сделают. Создай файл /usr/local/bin/ppp-on такого содержания:

#!/bin/bash

#

# ppp-on

# Cкрипт для установки ppp-соединения

#

# Это основные параметры, которые надо редактировать

#

MODEM=/dev/ttyS0

TELEPHONE=5555555 # По этому номеру будет идти дозвон

ACCOUNT=vasya # Твой логин

PASSWORD=qwerty # Твой пароль

LOCAL_IP=0.0.0.0 # Твой айпишник (если не знаешь, пиши 0.0.0.0)

REMOTE_IP=0.0.0.0 # IP-адрес удаленной системы (оставь 0.0.0.0)

NETMASK=255.255.255.0 # Маска подсети (оставь такую или прова терроризируй)

# Переменные для работы `ppp-on-dialer'

#

export TELEPHONE ACCOUNT PASSWORD

# Полный путь `ppp-on-dialer'

#

DIALER_SCRIPT=/usr/local/etc/ppp-on-dialer

# Самое главное - запуск pppd

# Для набора номера и аутентификации будет использоваться другой

# скрипт - `ppp-on-dialer'

#

exec /usr/sbin/pppd debug lock modem crtscts $MODEM 38400 \

asyncmap 20A0000 escape FF kdebug 0 $LOCAL_IP:$REMOTE_IP \

noipdefault netmask $NETMASK defaultroute connect $DIALER_SCRIPT

## Конец ppp-on

Тут все должно быть понятно, кроме порта модема :). Секи мазу: /dev/ttyS0 - com1 под винды, /dev/ttyS1 - com2 под винды, /dev/ttyS2 - com3 под винды etc. С момедом вообще отдельный разговор. Ты, наверное, уже слышал, что лучше всего под Линукс юзать внешние хардовые модемы. Ни о каких win-модемах и не думай. Так что лучше тебе потратить зеленых президентов, чем иметь большой геморрой с настройкой таких чудо-девайсов.


Спецвыпуск Хакера, номер #005, стр. 005-073-3, Поднятие Инета из-под юникса

Поднятие Инета из-под юникса

Спецвыпуск Хакера, номер #005, стр. 005-073-3

Теперь создай файл /usr/local/etc/ppp-on-dialer. Он должен быть таким:

#!/bin/bash

#

# ppp-on-dialer

# Выполняет работу по дозвону и аутентификации

#

exec /usr/sbin/chat -v \

TIMEOUT 3 \

ABORT '\nBUSY\r' \

ABORT '\nNO ANSWER\r' \

ABORT '\nRINGING\r\n\r\nRINGING\r' \

'' \rAT \

'OK-+++\c-OK' ATH0 \

TIMEOUT 30 \

OK ATDP$TELEPHONE \

CONNECT '' \

ogin:--ogin: $ACCOUNT \

word: $PASSWORD

## Конец ppp-on-dialer

Здесь используются просто супертехнологии биоалгебры, микровалеологии и квантовой философии: одна команда "/usr/sbin/chat" :). Эта прога занимается "общением" с модемом. Вся ее командная строка - диалог типа "ждать - послать". Например, ожидаем "CONNECT", посылаем пустую строку (два апострофа); ждем "login:", посылаем твой логин ($ACCOUNT - переменная из ppp-on; так же, как $TELEPHONE и $PASSWORD) etc. Весь этот диалог также можно запихнуть в отдельный скрипт. В общем, в принципе то же самое, что и в виндовских скриптах *.scp, только проще все гораздо. В файле "ppp-on-dialer" править ничего не надо, кроме, конечно, самого главного: если прога эта, chat, отсутствует у тебя, нужно ее проинсталлить или путь поменять к ней, если она у тебя установлена не в /usr/sbin.

Третий и последний скрипт - /usr/local/bin/ppp-off. Он будет устраивать дисконнект :). Его тоже не правь: там все нормально.

#!/bin/bash

#

# ppp-off

# Вырубает ppp-интерфейс - дисконнектит

#

# Узнаем, какой девайс отрубить

#

if [ "$1" = "" ]; then

DEVICE=ppp0

else

DEVICE=$1

fi

# Если у ppp0 pid-файл существует, значит программа запущена. Тормозим ее.

#

if [ -r /var/run/$DEVICE.pid ]; then

kill -INT `cat /var/run/$DEVICE.pid`

#

# Если kill не пашет, значит для этого pid`а нет запущенного процесса

# Вдобавок может быть останется lock-файл. Может понадобится потереть

# lock-файл прямо тут же.

#

if [ ! "$?" = "0" ]; then

rm -f /var/run/$DEVICE.pid

echo "ОШИБКА: Убран выдохшийся pid-файл"

exit 1

fi

# Круто. Зачем мучиться будем? Пусть pppd сам и мусор за собой выносит.

#

echo "PPP-связь к $DEVICE отключен."

exit 0

fi

# Процесс ppp не запущен для ppp0

echo "ОШИБКА: PPP-связь не активна на $DEVICE"

exit 1

## Конец ppp-off

Осталось разобраться с правами. Чтобы всякие ушастые приятели не скоммуниздили у тебя аккаунт, даем право на чтение "ppp-on" только владельцу файла, т.е. тебе:

chmod 400 /usr/local/bin/ppp-on

Но это у нас скрипт, а значит, он выполняться должен. Не вопрос:

chmod 500 /usr/local/bin/ppp-on

"ppp-off" достаточно дать 755, т.к. там ничего важного нет, а исполняться он все равно должен:

chmod 755 /usr/local/bin/ppp-off

Ну а "ppp-on-dialer" можешь оставить с правами "по умолчанию". :) Теперь поставь SUID-бит на pppd, чтобы его можно было использовать не только руту, если ты собрался юзать Инет под другими логинами на своей системе:

chmod 4755 /usr/bin/pppd


Спецвыпуск Хакера, номер #005, стр. 005-073-4, Поднятие Инета из-под юникса

Поднятие Инета из-под юникса

Спецвыпуск Хакера, номер #005, стр. 005-073-4

Вот мы и пришли к заветной цели: командой "/usr/local/bin/ppp-on" звоним прову, а с помощью "/usr/local/bin/ppp-off" отрубаемся. Если ломает вводить /usr/local/bin и его нет в PATH`е, т.е. на просто "ppp-on" шелл ругается, пропиши в нем эту директорию. В bash`е, например, нужно поправить ~/.bashrc.

ЗВОНИЛКИ ПОД LINUX

И, напоследок, неплохо было бы узнать о парочке популярных дайлеров под Линукс.

WvDial (KWvDial)

Как пишут создатели, это интеллектуальный дайлер. Это означает, что он звонит мопедом к прову и запускает ppp, чтобы подрубиться к Инету :)). Судя по этому веселому объяснению, все звонилки суперинтеллектуальны. Эта прога наподобие chat, за исключением того, что она юзает эвристику (слышал про такую? :), чтобы догадаться, как звонить и логиниться на сервак, а chat`у надо писать скрипты. После дозвона wvdial ждет ppp-пакетов. Если таковые не приходят, прога всячески пытается этому способствовать: посылает логины/пароли, отвечает на ожидания ввода (ppp - дефолтный ответ), etc. Если все эти потуги безуспешны, wvdial просто запускает pppd и надеется на лучшее :)). Конфигурится прога командой "wvdialconf ". Все что не конфигурится, придется вводить ручками в wvdial.conf :0). Есть возможность задания нескольких "соединений": в них можно указать, например, другой телефон, логин/пароль или параметры дозвона. Есть у wvdial гуевая версия, писанная под KDE: kwvdial. В общем, довольна неплохая прога.

Скачать: http://www.worldvisions.ca/wvdial/index.html

mkconnect

Скриптовая (для bash`а) звонилка. Настраивается в интерактивном режиме. Поддерживает PAP/CHAP и скриптовую аутентификацию. Для нормальной работы последней нужно точно знать все запросы dialup-сервака прова. Дозвон включается командой типа "mkconnect аккаунт", а дисконнектится - "mkconnect off". Короче, управляется сие чудо программерской мысли через командную строку. Радует, что не забыл автор написать скрипт для инсталляции. А то пришлось бы ручками бэкапить старые системные настройки, создавать системную пользовательскую группу "ppp"...

Скачать: http://mkconnect.virtualave.net

Kppp

Дайлер под KDE. По сути напоминает виндовский "Удаленный доступ". Немного круче по функциАнальности (по крайней мере, по сравнению с удаленкой win9x). Радует возможность написания скрипта для аутентификации прямо в окне kppp, нажав крысой на кнопке "Настройка". В МД скрипт приходится самому ваять в ноутпаде. Все связанное с сетевыми и аппаратными настройками можно сделать там же, потыкав в окошке конфигурации: от настроек момеда до сетевых параметров. К сожалению, у этой проги нет возможности перебора номеров, это огорчает. Короче, если ты юзаешь KDE и когда-нибудь запускал в win "Удаленный доступ", ты разберешься в kppp и даже, может быть, будешь его постоянно юзать.

Скачать (это софтина, идущая с KDE): http://www.kde.org

QuickPPP

Простая тулза, устанавливающая ppp-соединение с твоим провайдером. По заявлению автора, она примитивная, но не защищенная от использования ушастыми кадрами, так что вводить придется правильные данные :). Юзает она PAP-аутентификацию, так что будет прекрасно работать с туевой хучей буржуйских ISPs (Internet Service Provider - пров по-нашенски :). Вся ее работа состоит в сборе у тебя инфы о соединении. Потом она лепит свои /etc/resolv.conf, /etc/ppp/pap-secrets и /etc/ppp/options, и /etc/ppp/chatscript. И все! :) Звонить она не умеет, это придется делать командой "pppd".


Спецвыпуск Хакера, номер #005, стр. 005-073-5, Поднятие Инета из-под юникса

Поднятие Инета из-под юникса

Спецвыпуск Хакера, номер #005, стр. 005-073-5

Скачать: http://www.freshmeat.net

dialer_applet

Апплет для Gnome`омвской панели. Появляется в ней с помощью команды "dialer applet" или после добавления себя в панель через менюшки. Все междумордие представляет собой две пимпы: Старт/Пауза и Стоп (Вкл и Выкл :). Первая запускает /etc/ppp/ppp-on, а вторая - /etc/ppp/ppp-off :). Как ты, наверное, :) уже понял, это наши любимые скрипты. Кого-то эта фича прет :).

Скачать (идет вместе с GNOME): http://www.gnome.org

Ек

Вот и все. Теперь ты сможешь попробовать весь боевой софт под *nix, о котором много слышал, и заюзать нормальный телнет и прочие юниксовские сетевые фени. Удачи, xakep!

Дарова, peretz! Поздравляю, ты поставил себе Linux (или другой *nix). Настроил систему, вбил нужный софт, поднял по необходимости сетевые сервисы. Но все равно тебя тревожит мысль, что чего-то не хватает...

Вообще, сейчас мы разберем самый кул-хакерский способ: все пашет автоматически, а главное - сделано своими руками! Приступим!


Спецвыпуск Хакера, номер #005, стр. 005-076-1, Настройка сети под линукс

Настройка сети под линукс

Спецвыпуск Хакера, номер #005, стр. 005-076-1

ppnmrv (рpnmrv@gagarinclub.ru)

Ну что, перец! Вижу я, что ты внимательно читал старые номера Х и, собрав-таки команду людей в своем доме, решил делать сетку, то бишь LAN. Купил и проложил кабели, купил пачку сетевых карт. Это, конечно, клево, но вот беда: ты вчера снес винду и поставил вместо нее линух - и теперь ломаешь голову, как под ним сеть настроить. Не дрейфь, моя статья тебе поможет это сделать, и после ее прочтения ты сможешь настраивать сеть прямо с закрытыми глазами!

Во-первых

Первое, что надо узнать о карточке - это ее название и производителя :-). Прочти на коробке или на самой карте. Далее лезь на сайт

http://cdb.suse.de/cgi-bin/scdb?HTML=ENGLISH/cdb_listtemplates/menu.htm&LANG

=ENGLISH

и ставь точку около Network Adapter, далее (по желанию) можешь ввести

имя производителя (Manufacturer), и вуаля - там табличка с инфой по

производителям, точным названиям карт и поддерживается карта под линухом или

нет. Но и это еще не все! Если теперь кликнуть на названии карты (name), то

появится еще табличка, по которой можно узнать, какой из драйверов ее

благополучно подцепит и будет с ней работать. Запомним это!!!

После того как это все проделано - грузимся в линукс. Необходимо также

знать топологию сети, то есть надо знать свой IP-адрес, адрес гейтвея,

ближайшего к тебе, и адрес DNS. Если ты строишь LAN без выхода в Инет, то

тебя из всего этого интересует лишь IP. Если вдруг случится, что провайдер

предоставит тебе канал - то он и сообщит тебе адрес гейтвея и DNS. Замечу

лишь, что IP лучше брать нереальные (типа 10.*.*.* или 192.168.*.*). Вместо

звездочек ставь числа, какие больше понравятся, но без гейтвея ты будешь

видеть только членов своей сети, то есть всех, у кого первые три цифры

IP-шника совпадают с твоими.

Настройка-стройка-стройка-чебум-бурум-бурашка

Прелестно. Есть два способа настройки сети - первый через командную

строку и редактирование файлов, а второй - через прогу linuxonf (или netcfg,

если под Х-ы). Я расскажу про второй способ, попутно говоря, в каких файлах что

лежит. Это тебе поможет получше узнать линукс.

Запускаем linuxconf и выбираем из меню пункт Networking, а затем Basic Host Information (или, соответственно: Сеть-> основные настройки сети). После

этого появляется некоторое подобие таблицы, в которую надо написать информацию о своем хосте:

- Host name (имя компьютера) - имхо, имеет смысл, если в локалке есть DNS (что вряд ли) и если это имя тебе дал провайдер вместе с IP-шником. Если у тебя просто LAN, то это поле заполнять необязательно.

- Ставим галочку напротив Adapter1 - Enabled, и тип настройки -

Manual(ручная)

- Primary name + domain - это тоже необязательно

- Aliases - аналогично, не требуется

- IP address - тут вводишь свой ip, например, 10.20.30.1

- Netmask - обычно 255.255.255.255

- Net Device - если это единственная сетевуха в компе, то пиши eth0,

если это вторая карта - то пиши eth1, и так далее.

- Kernel Module - вспоминаешь имя модуля и пишешь его сюда! Модуль -

это файл с расширением *.o, хранящийся в /lib/modules. Если ты оттуда ничего


Спецвыпуск Хакера, номер #005, стр. 005-076-2, Настройка сети под линукс

Настройка сети под линукс

Спецвыпуск Хакера, номер #005, стр. 005-076-2

не удалял и не перекомпилил ядро, то там есть ВСЕ скомпиленные модули для

сетевых карт (в директории net).

Делов-то было - всего ничего...

Это все! Жмешь accept и попадаешь обратно, в меню настройки сети. Далее, если надо, можешь прописать DNS путем выбора из пункта меню Name Server Specification и gateway путем выбора пункта routing & gateway ->Set Default (тут, естественно, вводишь IP твоего гейтвея). Далее жмем Accept, Quit, Quit, Activate the changes, Quit (уфф, кажется, ничего не забыл). После этого пишем в командной строке ntsysv - и появляется менюшка со списком автоматически запускающихся сервисов. Важно, чтобы напротив сервиса network (слева) стояла звездочка. Далее выходим из этого меню и пишем:

/etc/rc.d/init.d/network/restart - рестартнем сетевой сервис.

Пишем в командной строке ifconfig - в результате мы должны увидеть сводку по установленным интерфейсам такого вида: слева название интерфейса, справа абзац текста с его описанием. Должно быть 2 интерфейса - eth0 и lo. Если они оба есть, то все клево и настало время пингануть кого-нить из своих друзей, чтобы узнать, как работает сеть.

Если что-то пошло не так

Здесь уже потребуется вся твоя смекалка и сноровка. Чтобы заставить эту

глючно-долбанную карту работать, приведу несколько основных команд, советов

и описаний.

Полезные файлы:

/etc/sysconfig/network-scripts/ifcfg-eth0 (или просто eth0) - файл, в

котором есть имя интерфейса (eth0), IP, Netmask, Network, Broadcast и еще

куча параметров, смысл которых до меня так и не дошел :-).

/etc/resolv.conf - ip-шники DNS-серверов записаны в виде "nameserver

IP".

/etc/sysconfig/network - имя хоста, имя домена, ip гейтвея.

/etc/conf.modules - список загружаемых модулей (например, твоя сетевая карточка в нем прописана как alias eth0 <имя модуля>).

Обычно карточки продаются настроенными в так называемом PCI-режиме - это когда они сами себе выбирают свободное прерывание и адрес ввода-вывода. Однако на некоторых мамах наблюдаются занятные явления (о них позже), для которых эти карты надо перевести в JumperLess режим. Делается это из доса с помощью софта производителя данной карточки (обычно дается на дискете в магазине).

Команды:

Если необходимо вручную загрузить модуль, то это делается командой insmod <имя модуля> или modprobe <имя модуля>. Чтобы посмотреть список загруженных модулей - есть команда lsmod, чтобы удалить модуль из памяти - команда rmmod <имя модуля>.

Прочие опасности

Теперь о проблемных мамах. Мне так и не удалось заставить работать ни RTL8139 не Ne-2000 совместимую карточку на маме Cyrix-Media-GXM-ALL-in-one. Выдавались забавные сообщения: 'Timeout waiting for Tx-RDC' где-то раз в минуту. Однако 3с-509(3COM) работают без проблем по сей день, что вновь доказывает: 3com - рулеззз!


Спецвыпуск Хакера, номер #005, стр. 005-078-1, Игры с пингвинами

Игры с пингвинами

Спецвыпуск Хакера, номер #005, стр. 005-078-1

Александр '2poisonS' Сидоровский (2poisonS@xakep.ru)

Привет тебе, друг-юниксоид! Уже заинсталлил себе самую анти-маздайную ось в мире? Круто! Могу поспорить, что все твои друзья писают кипятком от зависти и пьют успокоительное вперемешку со слабительным. Билл Гейтс наконец потерял в твоем лице еще одного пользователя, а злобные нюкеры счищают с себя помет пролетевшей над ними птицы los pinguinos. Короче, все зашибись. НО! Если под форточками ты привык ежедневно упражняться в гамесах - например, погонять в Кваку или забить сценарий-другой в какую-нибудь стратегию, то в UNIX'е ты будешь чувствовать себя как инвалид, у которого отобрали костыли... По крайней мере, пока не привыкнешь к "особенностями национального пингвиньего геймоиграния".

Особенности

Во-первых, успокойся. Третья Квака под Юникс есть :).

Все хорошо? Поехали дальше. Как ты, наверное, уже знаешь, все юниксовские игры делятся на две категории: портированные с Виндов и свои, "домашнего приготовления". Каждый тип имеет свои странности. Например, форточные игры портируются далеко не все и далеко не сразу (и к тому же далеко не всегда самые лучшие). А родные гамесы в силу ряда причин вообще застряли в эпохе двухмерных скролл-шутеров и головоломок для детей и секретарш. Впрочем, ситуация меняется и довольно быстро. Если сейчас еще никто всерьез не станет воспринимать *никсы как полноценную игровую платформу, то уже в скором будущем это может кардинально измениться. Ну а пока, раз уж мы, крутые хакеры, решили установить себе эту гипер-мега-ось будущего (и правильно сделали, что решили), придется немного ее напрячь в плане удовлетворения нужд геймера обычного (в просторечии gamerus vulgarius).

Ридми фёрст!

Инсталлить и запускать игры как под Виндами: нажатием нескольких кнопок - удел ламеров. Мы пойдем другим путем. Для начала убедись, что у твоего железа не случится несварение желудка, когда ты попытаешься скормить ему очередной FPS, RTS, SMS и прочий КПСС. Недавно nVidia зарелизила драйвера для своих видеокарт под Linux. Что было до этого, я не знаю - к счастью, времена неподдерживаемого железа я не застал. У 3Dfx ситуация чуть лучше, ее девайсы уютно чувствуют себя в обществе пингвинов уже довольно давно. Но даже если Линух держит твою видюху так же крепко, как Винни-Пух (известный хакер осиных гнезд) держал свой шарик в момент внедрения трояна Тучка v1.0, это еще не значит, что драйвера у тебя встанут как... э-э-э, короче встанут без проблем. Дело в том, что ритуал укладывания дров в Юникс сильно отличается от аналогичного процесса в Окнах им. Деда Мастдая. Если в Виндах ты привык инсталлить драйвера нажатием привычной последовательности Yes-Next-Next-Finish-Restart, то в *никсах тебе придется проявить несколько больше терпения. Тебе нужно будет компилить и перекомпиливать, редактировать кучу настроек в текстовом формате, вручную рассовывать файлы по нужным каталогам, сдавать внеочередную сессию в институте и водить любимую бабушку на все тусовки с друзьями. Впрочем, может быть, я в чем-то и переборщил...


Спецвыпуск Хакера, номер #005, стр. 005-078-2, Игры с пингвинами

Игры с пингвинами

Спецвыпуск Хакера, номер #005, стр. 005-078-2

Когда драйвера наконец будут установлены, ты узнаешь, что именно ЭТА версия дров не подходит к именно ТВОЕЙ версии дистрибутива Линуха и именно для ЭТОЙ модели железа релиз нужных драйверов не планируется в ближайшие 16 столетий. Но не отчаивайся: ведь, как известно, в Сети можно найти все что угодно, даже драйвера для красной кастрюли с гороховым супом в холодильник Минск под управлением Windows CE :).

Ready... Steady... GO!!!

Переносом игр на платформу Linux занимается много компаний, компашек и компашечек. Но самая плодовитая из них, без сомнений, - Loki Games. Этот монстр зарелизил на Линухе почти все, что есть для этой ОС-ки такого, во что мог бы играть хардкорный виндовый геймер. Но, увы, если ты думаешь, что сможешь найти в списке ее продуктов свой любимый Eye of The Beholder III или Warcraft II: Beyond The Dark Portal, - ты ошибаешься. Выбор не так уж и велик. На момент написания этой статьи Loki предлагал на своем сайте следующие игры: Civilization: Call to Power, Myth II: Soulblighter, Railroad Tycoon II, Eric's Ultimate Solitaire, Heretic II, Heroes of Might and Magic III, Quake 3: Arena, Heavy Gear II, Descent 3, SimCity 3000 Unlimited, Soldier of Fortune, Sid Meier's Alpha Centauri (Alien Crossfire expansion pack), Mind Rover, Unreal Tournament, Kohan: Immortal Sovereigns.

Как видишь, выбор небольшой, но по большей части грамотный. А теперь поиграем в русскую народную телевизионную игру: Oh, shit! (сливчик).

Вопрос: Отличаются ли Linux-версии виндозных игр от своих прототипов?

Варианты ответов: да, нет, отмена.

У вас есть три подсказки: можно убрать два неправильных ответа, спросить мнение зала и позвонить двоюродному брату тещи в Житомир. Готовы? А вот и неправильно! Правильный ответ: вообще-то нет, но все-таки чуть-чуть отличаются.

Конечно, менять черных драконов на черно-белых пингвинов в HoMMIII никто не станет - ясно, что изменения в играх касаются не геймплея или элементов дизайна, а чисто технических сторон. К тому же, многое зависит от того, кто делает порт: программеры из самой Loki (ну или другой конторы, издающей игры для Linux) или разработчики, которые создали оригинальный вариант игры. Ладно, не парься, мы с тобой из всех этих тонкостей заметим разве что отсутствие привычного по Виндам Setup'а: прога, аналогичная Install Shield, в *никсах отсутствует, поэтому все игры (да и вообще все проги) инсталлируются по-разному. Да, это гимор, согласен, зато мозги у юзверя не расслабляются ;).

Что касается производительности линуховых портов, то часто они уступают оригиналам. Квака бегает помедленней, у Myth большие проблемы с мышью (независимо от модели грызуна) и т.д. При этом некоторые игры (Civilization: Call to Power) умудрились не только не опозорить гордого пингвиньего лица, но и, наоборот, проявить чудеса стойкости и неЗАВИСимости. А по некоторым неподтвержденным данным эта игра еще и демонстрировала слайд-шоу с фотографиями человека, похожего на Билла Гейтса, с голыми тетками в бане.

For penguins only!


Спецвыпуск Хакера, номер #005, стр. 005-078-3, Игры с пингвинами

Игры с пингвинами

Спецвыпуск Хакера, номер #005, стр. 005-078-3

Впрочем, много писать о портированных на Linux играх смысла не имеет, про Кваку и Анрыл, надеюсь, ты слышал, объяснять, что это такое, не надо. А вот посмотреть, какие гамесы рулят на UNIX-сцене из своих, доморощенных шедевров надо обязательно. Тем более что рулят там довольно странные, по форточным меркам, вещи.

FreeCiv

www.freeciv.org

Одна из самых популярных, если не самая популярная, игр под Линух, это ни что иное, как банальный клон Civilization. Свобода, равенство, халява - вот принципы, которые лежат в основе идеологии юниксоидов. Поэтому Civ под *никсами превратился в FreeCiv. Правильно, это означает, что гамеса распространяется безвозмездно, то есть даром.

Геймплей похож на творение легендарного Сида за номером один. Нет, не Сида за номером один, а творения, то есть на самую первую Civilization, которая появилась на свет еще когда все Дюки Нюкемы и Лары Крофт ходили под стол пешком и писались в памперсы. Для тех наших читателей, которые ходили под стол вместе с Ларой Крофт и там медленными эротичными движениями стягивали с нее памперсы, чтобы проверить сухость кожи, я объясню. Civilization (в просторечии Civ, откуда и пошло название FreeCiv) - это походовая стратегическая игра, где ты прикидываешься лидером древнего государства и начинаешь клепать города, армии, мутить дипломатию, завоевывать новые территории, изобретать всякие... э-э-э... изобретения и делать все остальное, чем занимается во время своего развития любая нормальная цивилизация. Игруха в свое время была культовой, и, как показало время, до сих пор находятся перцы, которые ее юзают (по крайней мере ее линуксовский клон). Тут надо отметить, что FreeCiv - это не порт Civilization, не ее копия, иначе Microprose сразу засудила бы обнаглевших авторов. Но отличия настолько минимальные, что чел, никогда не видевший обе эти игры, наверняка принял бы их за одну.

Короче, если под виндами ты не наигрался в Цив или родился слишком поздно, чтобы застать времена расцвета походовых стратегий - наверстывай упущенное под Линухом. Да, я забыл сказать самое главное: у нее есть мультиплеер! И еще... еще... я уже говорил, что она бесплатная?

NetHack

www.nethack.org

Несмотря на такое явно хакерское название, это всего лишь rogue RPG, причем даже однопользовательская! Причем тут тогда Net - вообще непонятно, ну да ладно... Цель игры невероятно оригинальна и до безобразия неожиданна: пройти весь dungeon до конца, найти там амулет бессмертия и вернуться живым. Вау! Вот это сюжетец! Толкиен отдыхает! Но это еще не все, больше всего в этой игре меня поразило то, что в ней... нет графики! Думаешь, это текстовая ролевка? Не-а. Это игруха в ASCII-символьной графике. У меня в детстве был такой комп, назывался Спектр, там тоже все игры только из ASCII состояли... Но тетрис или змейка это одно, а РПГ, извините, совсем другое! При этом NetHack это не древнее ископаемое, по многим рейтингами эта игра занимает второе (!!!) место по популярности на Unix'е, после FreeCiv. Я даже слышал об игре такое мнение: "NetHack это лучшая игра из тех, которые были созданы на сегодняшний день под любую платформу. Diablo 2 отдыхает!" Как тебе такое, а? Чтобы понять, что же это за шедевр такой, вот тебе текстовый "скриншот" из игры:


Спецвыпуск Хакера, номер #005, стр. 005-078-4, Игры с пингвинами

Игры с пингвинами

Спецвыпуск Хакера, номер #005, стр. 005-078-4

The bat bites!

------

|....| ----------

|.<..|####...@...$.|

|....-# |...B....+

|....| |.d......|

------ -------|--

Player the Rambler St:12 Dx:7 Co:18 In:11 Wi:9 Ch:15 Neutral

Dlvl:1 $:0 HP:9(12) Pw:3(3) AC:10 Exp:1/19 T:257 Weak

В середине "скриншота", как ты понял, карта подземелья, на которой и происходят все приключения в этой увлекательнейшей игре. Справедливости ради надо заметить, что для "продвинутых" компов существует версия, где вместо ASCII используются картинки, но сути дела это не меняет.

Flight Gear

www.flightgear.org

Летайте самолетами Аэрофлота! - призывала нас известная реклама советских времен. Как будто мы могли летать еще на чем-то. Вот если бы мы могли прийти в аэропорт Внуково со своим самолетом, своей аппаратурой и своими стюардессами, вот это было бы круто! Мы бы и самолет собрали понадежней, побыстрее и просторнее, и стюардесс бы пригласили из модельных агентств, и вообще, ну его на фиг, это Внуково - полетим со своего аэродрома. Так или примерно так рассуждали разработчики, которые создали Flight Gear Flight Simulator - бесплатный open-source'овый авиасим. Код проги доступен для свободного скачивания, и все желающие приглашаются к активному творчеству на благо развития и улучшения "всеобщего" авиасимулятора. Нет, на этот раз игра идет не в ASCII графике и не клонирует покрытую пылью классику - это вполне современно выглядящая игра, которая довольно шустро бегает под управлением OpenGL. Может быть, по графике и широте возможностей она и не дотягивает до MS Flight Simulator, например, но зато ты можешь сам все изменить, дорисовать и в конечном итоге заставить Майкрософт краснеть за свою поделку. Очень юниксовский подход, я тебе скажу.

glTron

www.gltron.org

Ну и напоследок один представитель любимой народом забавы под названием multiplayer 3D action. Правда, это будет не FPS (толковых шутеров я на Линухе так и не нашел), а бои на футуристических мотобайках. Заезды происходят на аренах, количество текстур которых можно сравнить с количеством хакеров в Ямало-Ненецком автономном округе. Смысл игры в следующем: ты едешь на своем байке, за которым остается полупрозрачный непроходимый след ака стена. Твоя задача - окружить противника или каким-либо образом заставить его врезаться в твои железобетонные выхлопы. Вот так - простенько и со вкусом. Есть и сингловый режим, и, разумеется, многопользовательский, под который игра и заточена. Графика почему-то на уровне начала девяностых - видимо, здесь так принято. Зато эта игра получила пять пингвинов от Linuxberg, пять звезд от Linux Game Tome и пять смайликов от Rocket Download. Так что если ты решил обзавестись играми под Линух, не забудь скачать glTrone - по тамошним меркам это просто шедевр, не меньше.


Спецвыпуск Хакера, номер #005, стр. 005-078-5, Игры с пингвинами

Игры с пингвинами

Спецвыпуск Хакера, номер #005, стр. 005-078-5

Ну а я как старый, опытный, простреленный во все места геймер посоветовал бы тебе юзать UNIX с приложениями в Инете, еще где-то... Но не в играх. Поставь себе лучше Винды в дополнение к Юниксу, они у тебя будут выделенной игровой платформой. Юникс, конечно, рулез форева, но не для геймеров. По крайней мере, пока.

Вопросы, замечания, предложения? Пишите по адресу 2poisonS@xakep.ru с пометкой "Какого фака ты наехал на наш любимый Линух!?" Заранее спасибо.


Спецвыпуск Хакера, номер #005, стр. 005-082-1, Пингвин-IRC

Пингвин-IRC

Спецвыпуск Хакера, номер #005, стр. 005-082-1

Zlobot (lapkarelief@mail.ru)

ОбЧаться!

Что бы там монашеский народ ни говорил, но без общения, пусть даже и виртуального, - не жизнь. Кто-то часами сидит в ICQ-шных чатах и имеет список добавленных юзеров на энное количество экранов прокрутки, кто-то не вылезает из веб-чатов, а кто-то уже давно все свои вопросы решает на каналах IRC. Существует огромное количество ирк-клиентов под все операционные системы, но юних в данном случае выигрывает: ведь ирк?и зародились именно там. Я расскажу о наиболее известных и распространенных линуксовых ирк-клиентах.

X-Chat

Имеет полностью графический интерфейс, написанный под GTK (Gnome), так что и используется он в основном теми, у кого Gnome как раз и стоит. В этом есть свои плюсы и минусы - антигноменцы должны будут ставить GTk, в дополнение к своим основным библиотекам икс'ов, зато все темы и чисто Gnom'овские примочки прекрасно уживаются с X-chat'ом. Помимо отличного интерфейса, этот ирц-клиент обладает еще некоторыми уникальными возможностями, как, например, автоисправление опечаток (English only, к сожалению), поддержка плагинов и скриптов на perl'е. Ну и плюс всякие мелочи типа URL-catcher в довесок. Установка проста - X-chat есть практически в любом нормальном дистрибутиве и ставится как IRC-клиент по умолчанию.

Kvirc

Как видно по первой букве из названия - этому клиенту живется нормально только под KDE. Kvirc, хотя и не является клоном mIRC'a, но, тем не менее, по внешнему виду и по возможностям они очень похожи. Правда, в скором времени мирк будет проигрывать по всем статьям - чего стоит только один IBM Via Voice plugin - система распознавания и синтезирования голоса! Скоро можно будет вообще чатиться без клавиатуры ;).

Инсталляция:

После скачивания архива и растаривания/распаковки его делаем стандартные действия:

./configure

make kvirc

make install

Если все же что-то пошло не так, то проблема, как правило, лежит на поверхности:

- Не хватает библиотек Qt или версия Qt меньше 2.0.0 (это можно проверить, набрав:

$ find / -name libqt*

Если не найдено ни одного файла - придется качать Qt с ftp://ftp.troll.no/

- Криво прописаны пути к Qt: надо запустить конфигуратор с параметрами

./configure --with-qt-library-dir="/usr/mylibs/qt/lib" --with-qt-include-dir="/usr/mylibs/qt/include"

Пути, ясен пень, надо подставить свои.

Настройка родного языка не требует особых усилий - Kvirc определяет язык по переменной LANG:

# export LANG="am" (am-армения ;)) - главное, чтобы все шрифты были закружены!)

Zircon

Особенность этого клиента - он целиком написан на Tcl/Tk. Это накладывает на него ряд некоторых ограничений (таких, например, как возможность настройки только через .Xresources). Отсутствие системы скриптов как таковой, конечно, сильно снижает возможности настройки, однако полностью открытый и _понятный_ (tcl все-таки) исходный код устраняет этот недостаток. Вообще, этот клиент рекомендуется в качестве пособия по Tcl/Tk - гораздо интересней копаться в исходниках полезной проги, чем разбирать надуманные примеры.

Консольные клиенты

IRCii

Один из самых первых ирк-клиентов. В далекие времена его создания о всяких графических наворотах и не помышляли - все делалось в родной консоли. В комплект поставки входит очень большое количество скриптов, и еще большее количество было написано потом фанатами. Вообще-то, IRcII уже устарел - есть и EPIC, и BitchX, но из-за большого количества уже написанных _именно_ под IRcII скриптов многие все еще его используют. Ньюбисам ставить не рекомендуется.


Спецвыпуск Хакера, номер #005, стр. 005-082-2, Пингвин-IRC

Пингвин-IRC

Спецвыпуск Хакера, номер #005, стр. 005-082-2

BitchX

Однозначно самый распространенный консольный клиент. Это, впрочем, вполне понятно - возможностей у него... многовато ;). Изначально основанный(-ая) на IRcIШ, BitchX обросла огромным количеством фич, до которых GUI-шным клиентам еще очень далеко!

Установка и Настройка:

Делаем дир и распаковываем туда весь комплект. Далее:

./configure

make (или) make install

В случае каких-нибудь глюков на этой стадии есть смысл посмотреть файл include/defs.h - там нужно откомментировать некоторые опции, в зависимости от конфигурации системы. make install сразу перемещает бинарник в /usr/local/bin - для этого нужны рутовые права.

После установки и первой проверки, что все работает нормально, можно засесть за компом надолго, редактируя все конфигурационные файлы. Это весьма прикольное и приятное занятие. Настройку лучше всего начать с файлов BitchX.reasons и BitchX.quits. В первом содержатся причины выкидывания юзера с канала (kick), а во втором - quit-лайны. Файлы поражают своим размером и разнообразием (Yo momma's like McDonald's, Over One Million Served! - это мирное высказывание оттуда), но лучше все же писануть туда что-нибудь свое, для оригинальности.

Список серверов, к которым BitchX коннектится по умолчанию, а также дефолтный ник задаются переменными шелла:

$ setenv IRCSERVERS="irc.rt.ru:6667 irc.blackend.com:6666"

$ setenv IRCNICK="zlobot2"

Эти переменные работают не только с BithcX, но и со всеми IrcII-основанными клиентами - ircII, EPIC, Sirc и т.д. Гораздо удобней вставить все это в профайл, чем каждый раз набирать это или запускать BitchX с параметрами. Кстати, о параметрах:

$ ./BitchX [ключи] [ник] [сервер]

Список возможных ключей:

-c #goblinhakaz - зайти на канал #goblinhakaz после коннекта.

-q скипнуть загрузку bx-rc или irc-rc.

-r brain.serv - список серверов для коннекта в файле brain.serv.

-v показать версию BitchX.

-l gob-rc - загрузить файл gob-rc вместо bx-rc.

BitchX загружает два конфигурационных файла при старте - ~/.bitchxrc и ~/.ircrc. В этих файлах содержатся параметры настройки клиента (их также можно задавать в качестве переменных окружения).

BitchX понимает все стандартные irc-команды и дополняет их кучей своих. Вот некоторые из них:

4OP [ник] - опает 4 раза подряд (для понту).

ADDFORWARD [ник или #канал] - перенаправляет все поступающие мессаги конкретному юзеру или на другой канал.

CDDC - это семейство команд позволяет организовать что-то типа ирцэшного файл-сервера, раздающего файлы по DCC.

Подсемейство CDCC (/cdcc [команда]):

CHANNEL - задает имя канала.

DESCRIBE - задает имя(описание) пака.

DOFFER - убирает пак из списка доступных для скачивания.


Спецвыпуск Хакера, номер #005, стр. 005-082-3, Пингвин-IRC

Пингвин-IRC

Спецвыпуск Хакера, номер #005, стр. 005-082-3

LIST - выводит список всех паков (текущему юзеру).

NOTICE - выводит список всех паков (всему каналу).

OFFER - загружает конкретный пак в лист.

MINSPEED - задает минимальное ограничение скорости перекачки (кб/сек).

QUEUE - смотрит, кто что заказал, и кому в данный момент шлются файлы.

SAVE - пишет список всех добавленных паков на диск (по умолчанию список идет в файл .cdcc.save).

SEND - отсылает пак юзеру (без его запроса).

RESUME - досылает битый файл (mircовская фича).

NOTE - описывает пак.

STATS - показывает статистику скачиваний.

SECURE - паролит пак.

Подсемейство DCC-команд(/dcc [команда]) - такое же, как и в любом другом ирц-клиенте. Просто /dcc - выводит список всех возможных команд (основные, конечно, будут SEND и GET).

FTP - открывает встроенный фтп-клиент. Помимо простого набора этой команды, фтп можно сразу открыть с помощью /msg -ftp.ru: здесь знак "-" является признаком фтп-адреса.

SET - устанавливает один из внутренних параметров. Их существует просто огромное количество, и перечислить все нет никакой возможности. Однако очень хочу всем посоветовать все же поставить себе другой REALNAME по умолчанию!!! А то каждый третий на /whois счастливо пишет: * I'm to lame to read BitchX.doc * ;).

Кстати, существуют еще две недокументированные команды - FUCK и FUCKEM... что бы они значили??? ;))

Это не конец

Я еще не о всех клиентах рассказал! Их существует раза в три больше, чем перечислено в этой статье... но для начала хватит и этих. А теперь: сhat on!


Спецвыпуск Хакера, номер #005, стр. 005-084-1, Снос Linux'a (как это сделать грамотно)

Снос Linux'a (как это сделать грамотно)

StF (StF@mail.ru)

Спецвыпуск Хакера, номер #005, стр. 005-084-1

Дарова еще раз, коли не виделись! Вижу я, надоел тебе линукс, ох надоел.

Ломает тебя изучать новые команды, привыкать к новому интерфейсу, не хочется напрягаться по поводу поиска необходимого софта, а может просто на винте место закончилось, а тут друг принес супер-мега-кульную-игрушку размером в 1 гиг, и тебе хочется ее попробовать. Это не важно. Важно лишь, что у тебя при каждой загрузке вместо запуска виндов появляется навязчивое LiLo boot, и 1 гиг занят не пойми чем.

Килл!

Сейчас я расскажу тебе, как снести линукс, при этом оставив все остальные свои разделы в целости и сохранности. Для начала берем системную дискету (она у тебя есть, я знаю :-)) или, в крайнем случае, диск Reanimator'a. Или даже можешь через lilo загрузиться в винду; главное, что тебе нужно - это командная строка и две команды - fdisk & format. Их ОБЯЗАТЕЛЬНО брать той версии, какой у тебя винды: то есть, если у тебя 98SE, то надо брать эти проги только из этого

дистрибута виндов. Особенно это касается fdisk. Нет-нет, здесь речь идет не

о больших дисках, поддержка которых появилась давно. Дело в том, что у fdisk есть секретный ключ /mbr, который заменяет содержимое 1 сектора жесткого диска и вместо линуксового lilo ставит туда виндовый. Теперь понятно, что 98SE надо грузить именно его родным загрузчиком, а не от 95.

Добро пожаловать домой в мастдай

Отлично, теперь винда грузится без проблем ;-), но свободного места ни на бит не прибавилось. Что ж, запускаем fdisk и выбираем Delete Partitision or Logical Dos Drive -> Delete Non Dos Partitision. Вообще-то, если у тебя только дос и линукс на харде, то такая фишка прокатит, но вот если кроме этого у тебя есть еще и NT с файловой системой NTFS или OS/2, то... лучше воспользоваться прогой Partitision Magic 5.0. После этого с помощью того же fdisk'a создаем новый DOS-раздел, выходим из fdisk и видим: появился новый логический диск в системе, на который мы не можем зайти, - это и есть созданный fdisk'om новый раздел. Мы его берем и форматируем. Вот, собственно говоря, и все. Да, вот еще что: по-моему, в Partitision Magic есть такая фича, как конвертация раздела в FAT - ее и надо использовать, и удалять раздел совсем не обязательно.

Слазь, приехали

Теперь ты можешь смело ставить свою гиговую игрушку и наслаждаться 3D-Sound и 4D-dimension. Усе!!! :-)) Всяческих козинаков. А когда надоест гамиться - возвращайся в Линух! Мы ждем тебя...

Содержание


Спецвыпуск Хакера, номер #005, стр. 005-086-1, Староффис, и с чем его едят

Староффис, и с чем его едят

Спецвыпуск Хакера, номер #005, стр. 005-086-1

Круглов Олег ака zLOB (webmaster@zlob.org) www.zlob.org

Немного Теории

Пакет StarOffice был разработан немецкой фирмой Star Division GMBH (www.stardivision.com), но в последний день августа 1999 г. компания Sun Microsystems объявила, что приобретает контору Star Division и, соответственно, права на ее основную разработку - офисный пакет StarOffice, к тому моменту уже существовавший в версии 5.1. Теперь любой желающий сможет получить этот продукт с сервера Sun (www.sun.com), причем без вложения каких-либо средств, похожих на деньги!

Star Office - очень интересный добротный офисный пакет, включающий в себя все самое необходимое для офисной работы - например, средства для подготовки текста, проведения табличных вычислений, поиска информации в Интернете, обмена сообщениями по электронной почте. Включает в себя StarDesktop - менеджер файлов, StarWriter, StarWriter/Web - текстовый редактор/броузер, StarCalc - электронная таблица, StarBase - база данных, StarMail, StarDiscussion - электронная почта и новости, StarChart - средство построения диаграмм, StarImage - графический редактор, StarImpress - средство создания презентаций. StarOffice существует для нескольких платформ - Sun Solaris, OS/2, Win9x/NT, Linux. Linux-версия бесплатна для персонального некоммерческого пользования, о ней-то и пойдет речь сегодня. Любители Windows - отдыхают =).

Как скачать и правильно зарегистрировать StarOffice 5.0?

Как я уже сказал, StarOffice 5.2 можно получить абсолютно фор фри анд фор фан для некоммерческого использования. Однако регистрация может вызвать некоторые затруднения. Так что слушай внимательно, как правильно зарегистрировать StarOffice 5.0.

Начинать можно с www.stardivision.com или сразу отправиться на их страницу Download (support.us.stardivision.com/Registration/Download.asp). Там тебе предложат заполнить форму. Выбери свою OS - Linux и внимательно заполни поля "First name", "Second name" и "E-Mail". Запомни, что было вписано в эти три поля, - именно относительно них будет сгенерирован ключ для твоего староффиса. После заполнения формы тебя попросят подтвердить правильность ввода, после чего покажут ключ и список серверов FTP, с которых можно скачать файл so50_01.tar (so50_49.tar - немецкоязычная версия). Ключ нужно сохранить (делаем copy/paste). Теперь выбирай понравившийся сервер FTP и запускай свой любимый pornodownloader :). На сервере Sun предлагается на выбор два варианта: скачать весь установочный пакет в виде одного файла объемом 86 МБ или в виде девяти отдельных файлов по 10 МБ. Я посоветовал бы тебе второй вариант =).

После успешного вытягивания архива можно разворачивать его и запускать ./setup. Никакие дополнительные библиотеки для систем Red Hat 5.1, 5.2 не нужны. Если у тебя стоит KDE, необходимо выбрать пункт "custom install" и включить поддержку KDE. При пользовательской инсталляции тебя попросят ввести персональный ключ, а потом заполнить форму с личными данными. Внимание! First name, Second name и E-Mail нужно ввести точно так, как при получении ключа на сайте StarDivision, иначе регистрация будет невозможна. Знак "#" является недопустимым! При первом запуске StarOffice появится табличка, сообщающая, что эта копия не зарегистрирована и через 30 дней она перестанет работать. Если ты сидишь в онлайне, можешь сразу же жать кнопку "Register". Без подключения к Интернет регистрация невозможна (если, конечно, нет заранее полученного customer id и registration key, соответствующих персональным данным). В принципе, если все поля были заполнены правильно, проблем с регистрацией возникнуть не должно. Но если они все же возникнут, возможно, придется снова прошвырнуться на страницу download и получить ключ еще раз. При любом изменении персональных данных понадобится повторная регистрация.


Спецвыпуск Хакера, номер #005, стр. 005-086-2, Староффис, и с чем его едят

Староффис, и с чем его едят

Спецвыпуск Хакера, номер #005, стр. 005-086-2

Установка

19 июня сего года на нескольких новостных серваках появилось сообщение о выходе версии 5.2 этого пакета, причем даже в вариантах для нескольких языков, ВКЛЮЧАЯ РУССКИЙ. Естественно, я сразу же попытался скачать русифицированный вариант. Установка прошла без всяких проблем. Да, да, сейчас расскажу.

Версия 5.2 пакета StarOffice предъявляет следующие требования к компьютеру и операционной системе:

- процессор Pentium или выше;

- минимум 32 МБ оперативки (рекомендуется 64 МБ);

- не менее 180 МБ свободного места на жестком диске (в зависимости от типа инсталляции может потребоваться до 250 МБ);

- монитор VGA или выше с 256 цветами и разрешением не

ниже 800x600;

- дисковод CD-ROM (это требование относится к тем, кто устанавливает StarOffice с CD-ROM-диска);

- ядро Linux версии 2.0.х или выше;

- должна быть установлена система X-Window с одним из оконных менеджеров;

- должен быть установлен X-сервер, обеспечивающий не менее 256 цветов или градаций серого;

- должна быть установлена библиотека GLibc версии 2.1.1 или выше.

После того как ты скачал весь архив, необходимо перейти в каталог, в котором записаны все полученные файлы и дать права на запуск этих файлов с помощью команды: chmod 777 *.bin. Если ты скачал пакет в виде одного файла, нужно дать в том же каталоге команду: so-5_2-ga-bin-linux-ru.bin, а если перекачаны 9 отдельных сегментов, то команду: so-5_2-ga-bin-linux-ru-000.bin.

В руководстве по инсталляции, которое можно скачать одновременно с установочным пакетом (правда, только на басурманском), говорится, что если StarOffice будет использоваться несколькими пользователями, то необходимо провести (даже на отдельно стоящем компьютере) сетевую инсталляцию (которую производит администратор), после чего каждый пользователь должен еще провести пользовательскую инсталляцию, чтобы создать собственный вариант настроек. В руководстве настоятельно рекомендуется, чтобы суперпользователь тоже провел для себя пользовательскую инсталляцию и ни в коем случае не запускал StarOffice непосредственно из серверной инсталляции. Для того чтобы запустить серверный вариант инсталляции, необходимо запустить программу установки setup с параметром /net. Поскольку в нашем случае запускается so-5_2-ga-bin-linux-ru-000.bin, то, возможно, здесь тоже можно использовать эту опцию... Короче, полный геморрой. Я провел установку без задания дополнительных опций, причем войдя в систему с правами root-а, и... ошибся. Поскольку теперь могу запускать StarOffice только войдя как суперпользователь. Дело в том, что я согласился с предложением инсталлятора установить StarOffice в каталог /root/soffice52/, к которому другие пользователи, в том числе и я сам, когда вхожу непривилегированным пользователем, доступа не имеют (я теперь обхожу это затруднение, становясь сначала суперпользователем с помощью команды su, а затем запуская файл /root/soffice52/program/soffice). Прокололся, короче :).


Спецвыпуск Хакера, номер #005, стр. 005-086-3, Староффис, и с чем его едят

Староффис, и с чем его едят

Спецвыпуск Хакера, номер #005, стр. 005-086-3

А сама установка... Тут все стандартно: главное для инсталла выбрать такой каталог, на который у тебя есть полные права. Вот, типа того, учись на моих ашыпках.

Первые опыты работы с пакетом

После перезапуска графической среды KDE в меню KDE появился пункт "StarOffice" (хотя можно, конечно, запустить программу, непосредственно вызывая на исполнение файл /root/soffice52/program/soffice). Грузится программулина довольно долго, даже на "рекомендованных" 64 МБ оперативной памяти. Так что если у тебя всего 32 метра мозгов, прога будет тормозить не по-детски (хотя тормозить - не значит глючить). При первом пуске программы появится предложение запустить автопилот инсталляции Интернета. Если оно тебе надо - инсталь. Если нет - ну его на фиг.

Рабочий стол СтарОффиса содержит Проводник (Explorer), the Beamer и рабочую область. Ниже рабочей области находится поле советов, которое можно убить, щелкнув по крестику в его левом верхнем углу. А чтобы оно не появлялось при следующем запуске, поставь предварительно галочку возле надписи "Советы больше не показывать". Но на первых порах стоит их читать, тем более что они даны на русском языке, поэтому просто закрывай это окно после прочтения очередного совета. Обрати также внимание на значок с треугольником вершиной вниз, расположенный в левом верхнем углу окна с советами. Такой значок имеется на многих окнах пакета. Пользуясь им, можно временно свернуть окно. Треугольник на значке перевернется, и повторным щелчком по нему можно снова развернуть соответствующее окно. Но вернемся к основному окну - рабочему столу. На него выведены иконки основных компонентов пакета. Отсюда можно получить доступ ко всем функциям StarOffice: вызвать адресную книгу, редактировать базу данных или создать новый документ. Функция Drag&Drop - точно как в мастдае. В нижней части экрана - кнопка "Пуск". StarOffice - программа "с претензиями", она считает, что может заменить собой графическую оболочку. А поэтому в меню, вызываемом по кнопке "Пуск", можно найти все пункты, которые есть в меню оболочки KDE. Кстати, если в пункте "Вид" главного меню (самая верхняя строка окна StarOffice) щелкнуть по строке "Во весь экран", то окно StarOffice займет весь экран. Только в левом верхнем углу появится маленькое окошко, пользуясь которым, можно вернуть StarOffice в предыдущее состояние.

Жизнь без Windows

У юзверей MS Ворда не будет сложностей с переходом к СтарОффису, его текстовый редактор без труда открывает и сохраняет в формате *.doc, то есть имитирует Ворд. И все же взаимодействие с MS Word обеспечивается не в полном объеме (Cтар не умеет читать таблицы Word 97 и не может корректно сохранять файлы в формате MS Office 97). И потом, лично мне недостает в нем некоторых мелочей, упрощающих редактирование - таких, как возможность выделить фрагмент текста, подцепить его крысой и перетащить в другое место документа.


Спецвыпуск Хакера, номер #005, стр. 005-086-4, Староффис, и с чем его едят

Староффис, и с чем его едят

Спецвыпуск Хакера, номер #005, стр. 005-086-4

Но это не значит что StarOffice плохой - он просто другой. У двух аналогичных прог не может быть абсолютно одинакового набора функций, иначе создателей одной из них просто засудят за плагиат. И пусть у Стара нет кое-чего, к чему мы привыкли под Окнами, зато в нем есть многое такое, чего Большой Билли в свой мелкомягкий офис забыл или не захотел ставить. Да, и не забывай - ведь СтарОффис - это абсолютно бесплатный ака халявный софт. Так что удачной тебе работы! И читай доки, они рулез (c) Fido =).


Спецвыпуск Хакера, номер #005, стр. 005-088-1, Firewall под Юниксами - настройка и использование

Firewall под Юниксами - настройка и использование

Спецвыпуск Хакера, номер #005, стр. 005-088-1

MegaBoklan <mb@policeoffice.com>

В этой статье мы поговорим о двух Firewall'aх, которые присутствуют в большинстве современных некоммерческих ЮНИКС-систем. А именно: о прогах IPFilter и IPChains. Вот расшифровка некоторых терминов, которые мы будем юзать в этой статье или которые просто тебе понадобятся, если ты хочешь работать с firewall'ами.

Firewall - программа, выполняющая фильтрацию сетевого трафика по заданным правилам.

IP - Internet Protocol.

ICMP - Internet Control Message Protocol.

UDP - User Datagram Protocol.

TCP - Transmission Control Protocol.

IGMP - Internet Group Management Protocol.

broadcast - адреса для широковещательных запросов x.x.x.0 и x.x.x.255

Сетевой интерфейс - физическое устройство (сетевая карта) или псевдоустройства, PPP интерфейс.

IPFilter

Данный Firewall по умолчанию присутствует в системах OpenBSD, FreeBSD и NetBSD, он также доступен для систем Linux, Solaris и IRIX. Он представляет собой фильтр пакетов семейства TCP/IP. IPFilter может быть установлен как в виде отдельного модуля ядра, загружаемого при необходимости, так и в виде компонента, встроенного в само ядро. В пакет IPFilter входят следующие программы:

ipf - выполняет чтение правил из файла или из командной строки и добавляет их в ядро.

ipfstat - выполняет вывод детальной статистики фильтра пакетов.

ipftest - читает правила из файла и затем для каждого создает примерный пакет для тестирования.

ipmon - выполняет чтение логов ipf.

ipsend - создает пакеты с заданными параметрами и выполняет их отсылку.

ipresend - выполняет чтение сохраненных пакетов из файла (snoop, tcpdump, etherfind) и посылает их снова.

iptest - программа для тестирования надежности TCP/IP стека.

Домашняя страница IPFilter находится по адресу: http://coombs.anu.edu.au/~avalon/.

Если ты работаешь на OpenBSD, FreeBSD или NetBSD, то для того чтобы включить IPFilter, тебе потребуется внести изменения в файл конфигурации /etc/rc.conf. Открой его твоим любимым текстовым редактором и найди следующую строчку:

ipfilter=NO

и вместо NO напиши YES :). Для того чтобы активировать ipf без перезагрузки, набери:

# ipf -Fa -f /etc/ipf.rules -E

По умолчанию файл, содержащий список правил для IPFilter'a, находится по адресу /etc/ipf.rules. По желанию это можно изменить путем модифицирования файла /etc/rc.conf. Просто пропиши новый адрес в этой строке:

ipfilter_rules=/etc/ipf.rules # Rules for IP packet filtering

Впервые открыв файл с правилами, ты найдешь в нем нечто подобное:

pass in from any to any

pass out from any to any

Эти две строчки разрешают все входящие и все исходящие соединения. Каждое правило должно начинаться с ключевого слова 'pass' - пропустить, или 'block' - блокировать. Ключевое слово 'in' означает входящие пакеты, а 'out', соответственно, исходящие. Далее следуют условия для этого правила. Во время работы IPFilter начинает чтение правил для поступившего пакета сверху вниз. Например:

block in all

pass in all

Первое правило говорит, что следует блокировать все пакеты, однако IPFilter продолжает чтение правил дальше и в данном случае пропустит пакет, потому что последнее правило это позволяет.


Спецвыпуск Хакера, номер #005, стр. 005-088-2, Firewall под Юниксами - настройка и использование

Firewall под Юниксами - настройка и использование

Спецвыпуск Хакера, номер #005, стр. 005-088-2

Иногда, когда в твоем файле правил содержится большое количество условий, то будет возникать задержка при проходе пакетов из-за того, что IPFilter будет просматривать все строчки до конца. Чтобы этого избежать, можно использовать ключевое слово 'quick':

block in quick all

pass in all

Если пакет удовлетворяет правилу и в правиле присутствует ключевое слово 'quick', то IPFilter не будет продолжать дальнейшее чтение, а сразу применит к пакету заданное правило.

Фильтровка по IP-адресам

Для фильтровки по заданным адресам существуют ключевые слова 'from' и 'to'. Слово 'any' подразумевает любой возможный IP-адрес. Пример правила:

block in quick all from 192.168.0.0/16 to any

Фильтровка по протоколам

Для фильтровки пакетов по протоколам используется ключевое слово 'proto'. Эта фича очень полезна для предотвращения некоторых типов атак. Вот пример блокировки ICMP пакетов:

block in quick proto icmp any to any

Такое правило будет блокировать ВСЕ ICMP пакеты, что не очень правильно, так как ICMP выполняет много важных задач в работе сети. Нам требуется запретить только ICMP пакеты типа Echo Request (8), которые чаще всего используются для флуд-атак. Для решения этой задачи существует ключевое слово 'icmp-type':

block in quick proto icmp from any to any icmp-type 8

Теперь пинга от нас никто не дождется ;). Далее следует неполный список основных типов и кодов ICMP пакетов, а также их описание.

0 - echo reply (ответ на ping)

3 - цель не доступна

3 (код 0) - сеть не доступна

3 (код 1) - узел не доступен

3 (код 2) - протокол не доступен

3 (код 3) - порт не доступен

4 (код 4) - временная приостановка передачи

5 - перенаправление

5 (код 0) - перенаправление для сети

5 (код 1) - перенаправление для узла

8 - echo request (запрос на ping)

Код для типа ICMP-пакета задается ключевым словом 'code'. В качестве примера запретим пакеты 5-го типа с кодом 1. Дело в том, что в атаке Winfreez используется флуд ICMP пакетами именно этого типа и кода с адреса маршрутизатора. При этом у атакуемого хоста быстро изменяется таблица маршрутизации, результатом чего является подвисание машины. Итак, наше запрещающее правило будет выглядеть следующим образом:

block in quick proto icmp from any to any icmp-type 5 code 1

Фильтровка по интерфейсам

Данная возможность позволяет фильтровать пакеты, идущие с разных сетевых интерфейсов. Для этого существует ключевое слово 'on':

block in quick on ppp0 proto igmp from any to any

Данное правило запретит все IGMP пакеты, идущие с сетевого интерфейса ppp0.

Если ты не знаешь имена своих сетевых интерфейсов, воспользуйся командой ifconfig:

[zlob]: ifconfig -a

lo0: flags=8009<UP,LOOPBACK,MULTICAST> mtu 32972

inet 127.0.0.1 netmask 0xff000000

de0: flags=8863<UP,BROADCAST,NOTRAILERS,RUNNING,SIMPLEX,MULTICAST> mtu 1500

media: Ethernet 10baseT

status: active

inet 192.168.0.1 netmask 0xffffff00 broadcast 192.168.0.255

ne0: flags=8863<UP,BROADCAST,NOTRAILERS,RUNNING,SIMPLEX,MULTICAST> mtu 1500


Спецвыпуск Хакера, номер #005, стр. 005-088-3, Firewall под Юниксами - настройка и использование

Firewall под Юниксами - настройка и использование

Спецвыпуск Хакера, номер #005, стр. 005-088-3

media: Ethernet manual

inet 192.168.1.1 netmask 0xffffff00 broadcast 192.168.1.255

sl0: flags=c010<POINTOPOINT,LINK2,MULTICAST> mtu 296

sl1: flags=c010<POINTOPOINT,LINK2,MULTICAST> mtu 296

ppp0: flags=8010<POINTOPOINT,MULTICAST> mtu 1500

ppp1: flags=8010<POINTOPOINT,MULTICAST> mtu 1500

tun0: flags=10<POINTOPOINT> mtu 3000

tun1: flags=10<POINTOPOINT> mtu 3000

bridge0: flags=0<> mtu 1500

bridge1: flags=0<> mtu 1500

Фильтровка пакетов по портам

Этот метод чаще всего используется администраторами для запрещения использования некоторых сетевых сервисов из внешнего мира. Например:

block in quick on de0 proto tcp from any to server1 port = 23

pass in quick on ne0 proto tcp from 192.168.0.0/24 to server1 port = 23

Данное правило запретит все соединения, идущие с интерфейса de0 с протоколом tcp на 23 порт (telnet) и разрешит подключения с интерфейса ne0 из локальной сети на сервер, сетевое имя которого в нашем примере server1, на 23 порт. Возможные операции для определения порта: = , != , > , < , <= , =>.

Также возможна фильтровка по диапазонам портов:

порт1 <> порт2 вступит в силу, если пакет идет на порт больше значения порт1 и меньше значения порт2.

порт1 >< порт2 вступит в силу, если пакет идет на порт меньше значения порт1 и больше значения порт2.

Например:

block in quick from any to any port 137<>139

Это правило запретит все входящие соединения на порты 137,138,139.

Ответ на блокируемые пакеты

При обычном сканировании TCP портов, если идет попытка подключения на блокируемый нами порт, результатом будет timeout подключения. В нормальной же ситуации, если бы на этом порту ничего не было и мы не блокировали бы его, система, которая пыталась подключиться к нам, получила бы обратно TCP пакет с RST флагом. Чтобы достичь такого же эффекта, используется ключевое слово return-rst. В следующем примере на попытку подключения на 23 порт (telnet) с интерфейса ppp0 мы возвращаем TCP пакет с флагом RST - это будет являться для сканирующей системы знаком, что порт якобы закрыт:

block return-rst in quick on ppp0 proto tcp from any to any port = 23

Такая возможность существует и для возврата заданных типов ICMP пакетов на блокируемые пакеты:

block return-icmp(3) in quick proto icmp from any to any icmp-type 8

В данной ситуации ICMP-пакет будет послан с обратным адресом системы, на которой установлен firewall, а не той системы, которой предназначался пакет. Если же необходимо послать icmp-пакет с обратным адресом системы, которой предназначался пакет, то используется ключевое слово return-icmp-as-dest:

block return-icmp-as-dest(3) proto udp from any to 20.20.20.0/24 port = 111

Запись пакетов в лог

Как и в любом firewall'е, в IPFilter предусмотрена возможность записи пакетов в лог, используя ключевое слово 'log':

block in quick log from proto tcp any to any port = 139

Теперь все TCP пакеты, идущие на 139 порт, будут блокированы и записаны в лог.

В следующем примере мы блокируем и записываем в лог все пакеты, идущие на broadcast адреса с ppp0 интерфейса. Это правило может быть использовано для предотвращения использования твоей сети для smurf атак.


Спецвыпуск Хакера, номер #005, стр. 005-088-4, Firewall под Юниксами - настройка и использование

Firewall под Юниксами - настройка и использование

Спецвыпуск Хакера, номер #005, стр. 005-088-4

block in log quick on ppp0 from any to 195.34.1.0/32

block in log quick on ppp0 from any to 195.34.1.255/32

Если после внесения изменений в файл правил IPFilter'a потребуется активировать новые правила, юзай следующую команду: ipf -Fa -f /etc/ipf.rules.

Для полного описания использования и возможностей IPFilter рекомендую тебе прочитать IPF-HowTo на http://www.obfuscation.org/ipf/

IPChains

Chain по-английски значит "цепочка". Этот firewall по умолчанию присутствует в Linux-системах с ядром 2.1.102+ и 2.2.*. Он пришел на смену ipfwadm, который сидит в Линуксах с ядрами серии 2.0.*. В свою очередь, ipfwadm являлся переписанной версией ipfw с FreeBSD.

Для работы IPChains в конфигурации ядра должны быть обязательно отмечены следующие опции:

Networking Options:

-Packet Socket

-Network firewalls

-IP: firewalling

Новые правила в ipchains добавляются из командной строки, но существует возможность сохранения внесенных правил в файл и затем их загрузки при необходимости. Это делается следующим образом:

# ipchains-save > /etc/ipchains.rules

Правила сохранены в файле etc/ipchains.rules. Для того чтобы загрузить их снова - например, после перезагрузки, набери:

# ipchains-restore < /etc/ipchains.rules

В IPChains есть три встроенные цепочки: input (входящие пакеты), ouput (исходящие пакеты) и forward. Я опишу основные опции, используемые для конфигурации ipchains:

-N создание новой цепочки

-X удаление пользовательской цепочки

-P изменение параметров встроенной цепочки

-L вывод списка всех используемых цепочек и правил

-F удаление правил из всех цепочек

-A добавление правила к цепочке

-D удаление заданного правила из цепочки или заданного номера правила

-R замена заданного номера правила в цепочке

-I вставить новое правило в определенную позицию цепочки

-p протокол может быть задан как словом, так и по номеру

-s исходящие адрес пакета и порт

-d адресат пакета и порт

-icmp-type типа ICMP пакета может быть задан как словом, так и номером

-i сетевой интерфейс

-j действие фильтра (ACCEPT, DENY, REDIRECT (порт), MASQ)

-l запись пакета в лог

-y TCP пакеты с флагом SYN

-v вывод детальной информации

Фильтровка по IP-адресам, портам и протоколам

Для фильтровки по адресам используются флаги: -s (исходящие адрес/порты) и -d (адресованные адрес/порты). Чтобы задать любой возможный IP-адрес, используется маска 0/0. Например, запретим все подключения на порт 514 (syslog) по протоколу udp (для задания любого протокола используется слово all):

# ipchains -A input -j DENY -p udp -s 0/0 -d 0/0 514

Или, например, разрешим использование только WWW сервиса из нашей локальной сети:

# ipchains -A output -j DENY -p tcp -s 192.168.0.0/24 -d 0/0 ! www

Фильтровка по интерфейсам

Предположим, что наша машина имеет два сетевых интерфейса: eth0 и eth1. Один смотрит в сторону локальной сети, а другой - в сторону Интернета. Нам требуется запретить ICMP пакеты типа 8, идущие с интерфейса eth1:


Спецвыпуск Хакера, номер #005, стр. 005-088-5, Firewall под Юниксами - настройка и использование

Firewall под Юниксами - настройка и использование

Спецвыпуск Хакера, номер #005, стр. 005-088-5

# ipchains -A input -j DENY -p icmp -s 0/0 -d 0/0 -i eth1 --icmp-type echo-request

Ну и напоследок немного того, что буржуи называют "eye candy". Для этого firewall'a существует большое количество графических оболочек, которые значительно упрощают составление новых правил. Вот некоторые из них:

ХХХХХХХХХХХХХХХХХХХХ

Картинка: main.jpg

Подпись: gfcc (http://icarus.autostock.co.kr/)

XXXXXXXXXXXXXXXXXXXXXX

Программа gfcc с графическим интерфейсом GTK+ : http://icarus.autostock.co.kr/

Guarddog c KDE графическим интерфейсом: http://www.simonzone.com/software/guarddog/

ХХХХХХХХХХХХХХХХХХХХХ

Картинки: screen1.png, screen2.png

Подпись: Guarddog (http://www.simonzone.com/software/guarddog/)

ХХХХХХХХХХХХХХХХХХХХХ

Консольная программа конфигурации ipchains: http://www.pmfirewall.com/PMFirewall/

А официальная страница IPChains находится по адресу: http://www.rustcorp.com/linux/ipchains

Вот и все, что тебе может понадобиться знать для работы с firewall'ами под Юникс. Теперь ты можешь с чистой совестью сказать: мой комп - моя крепость.


Спецвыпуск Хакера, номер #005, стр. 005-092-1, Mp3-зация юниксоида

Mp3-зация юниксоида

Спецвыпуск Хакера, номер #005, стр. 005-092-1

AvaLANche (avalanche@yandex.ru)

Консольные штучки

mpg123

Хомяк/где скачать: http://www.sfs.nphil.uni-tuebingen.de/~hipp/mpg123.html

Имхо, самый популярный и распространенный на сегодня консольный mp3-плеер среди линуксоидов. Управляется из командной строки. Поддерживает форматы MPEG 1.0/2.0 (layers 1, 2 и 3). МыПыГы123 читает файл[ы] или урл[ы] и выводит их (декодировав предварительно, конечно :) на аудиодевайс (по дефолту или в стандартный вывод). Есть поддержка прокси - на случай, если указан урл для проигрывания. Туева хуча всяких фишек для воспроизведения: вдвое увеличенная/уменьшенная скорость, выбор девайса для вывода, случайное проигрывание, режим повтора etc. Можно поиздеваться и над процессом декодинга твоего супер-мега-mp3-хита: задается выводной буфер, можно указать, сколько фрэймов декодить за раз, сколько пропустить... Есть у проги и тестовый режим, когда аудиопоток декодится, но никуда не выводится :). Короче, разбираться со всеми фичами тебе, перец, предстоит аж до следующего номера X. :)

Mp3Blaster

Хомяк/где скачать: http://www.stack.nl/~brama/

Интерактивный, консольно-графический mp3-плеер. Имеет одну важную особенность: есть встроенный файловый браузер. Состоит из трех частей: ходилка-бродилка aka браузер, редактор плэйлиста и сам плеер (режим проигрывания). В лист можно добавлять файлы или урлы. Редактор листа по возможностям не уступает винамповскому, а может и превосходит его. Плеер имеет все фичи стандартного проигрывателя. Можно задать аудиодевайс, количество фрэймов для декодирования за раз, понизить частоту звуковых колебаний :) etc. Есть встроенный микшер, такой же идет рядом отдельной прогой (nmixer).

В общем, неплохая, мощная прога. Попробуй - может быть, полюбишь :).

playmp3list

Хомяк/где скачать: http://rucus.ru.ac.za/~urban/playmp3list.html

Это ни что иное, как текстовое "графическое" междумордие для mpg123. Частично основано на сорцах mp3blaster`а, которые юзает ncurses. Представляет собой, как и Mp3Blaster, подобие эксплорера: браузит mp3шки на твоем винте или в плэйлисте. Где и что браузить, узнает от тебя, если ты любезно скажешь playmp3list`у это в командной строке. Поддерживает ID3-тэги версии 1, упорядочение плэйлиста в алфавитном порядке. Есть встроенные фичи для регулирования громкости, можно задать режим случайностей и повторностей (есть еще автошафл и авторепит). В playmp3listrc можно задать цветовую схему и "что будет, если нажать на эту пимпу" :). Вывод: если ты юзаешь консоль и хочешь больше удобств, чем при написании длинной командной строки mpg123, то эта прога - для тебя.

Иксовые штучки

Kmp3

Хомяк/где скачать: http://www.kmp3.org

KDEшный mp3-плеер. Становится все более навороченным от версии к версии. Кроме стандартных плеерных фич - таких, как случайное проигрывание, повтор, плэй/стоп :), регулировки громкости, баланса и быстрого поиска, есть также куча рулезных фишек. Во-первых, поддержка ID3-тэгов - причем, не просто поддержка, а с возможностью настройки отображения названия песни (как в XMMS/WinAmp`е). Во-вторых, можно для kmp3 забацать скин, и он будет работать! :) А можно и винамповский поставить. Не забыли авторы и редактирование плэйлиста возможным сделать - вот только попробуй с первого раза найти, где этот лист находится и как открывается. :) А так - все просто. Идем дальше... ОЧЕНЬ полезная фишка для тех, кто таскает русские (местные аборигенские песни) mp3шки из Инета или лепит свои в виндах - возможность перекодировки символов. Полезно, когда файл у тебя в win-1251, а шрифты для отображения названия песни под Линуксом только под koi8-r. Прога ко всему еще и плагины может юзать! В общем, довольно неплохой функционально плеер. Похоже, ребята, писавшие kmp3, хотели забацать что-то типа WinAmp`а. Скоро, наверное, это у них получится окончательно :).


Спецвыпуск Хакера, номер #005, стр. 005-092-2, Mp3-зация юниксоида

Mp3-зация юниксоида

Спецвыпуск Хакера, номер #005, стр. 005-092-2

eMusic

Хомяк/где скачать: http://www.icom.net/~smelecat/emp3/

Плеер, задизигненный в стиле XMMS (а-ля WinAmp). Играет MP3, MOD, WAV, AU, музыкальные КД, потоки по HTTP/SHOUTcast для mp3, au и wav`ов... Как говорит автор, архитектура плагинов легка для использования и аккуратна. Конвертит winamp`овые (только новый формат 2.0) шкуры к eMusic-схемам. Юзает для проигрывания esound (может использовать также esound-серверы). Довольно стандартный набор функций: случайное и аппаратное воспроизведение, повтор, редактор плэйлиста, поиск в файле... Возможен запуск без загрузки ГУИ: просто играет файл и отрубается (полезная очень, наверное, фича :)).

XMMS (X MulitMedia System)

Хомяк/где скачать: http://www.xmms.org

СУПЕР! Супер-прога. Просто WinAmp под *nix. Раньше она даже "x11amp" называлась :). Все, что может ВинАмп, может и XMMS. Поддерживаемые форматы: MP2- и MP3-потоки, WAV/AU; через модули (плагины): mod, xm, s3m, med, it, 669, amf, dsm, far, gdm, imf, m15, mtm, stm, stx, ult, uni. И еще: киношки от ID aka cin, музыкальные КД, shout/icecast. Все фичи не опишешь, вот только некоторые: поиск в файлах, случайная игра, повтор, редактор плэйлиста, анализатор спектра (Spectrum Analyzer), однострочный режим а-ля WindowShade в ВинАмпе, многофункциональный таймер, поддержка плагинов, эквалайзер, поддержка WinAmp`овских скинов, поддержка аутентификации на прокси и еще, еще, еще... Одним словом - рулез! :)

Пальцы веером

Ну, скажешь, плеерами загрузил, а как mp3шки достать или слепить, не сказал. Ничего подобного! Ты просто до конца не дочитал еще. :) Вот тебе до кучи несколько прог для отыскивания и создания mp3`шников.

NotLAME

Хомяк/где скачать: http://www.sulaco.org/mp3

Энкодер, основанный на алгоритме LAME. Это всего-навсего самый быстрый алгоритм кодирования MP3. :) Лепит он mp3шники быстрее, чем ты награбить (не наворовать, а с КД награбить:)) успеешь wav`ы.

GoGo

Хомяк/где скачать: http://homepage1.nifty.com/herumi/gogo_e.html

Ничем особенным не примечательная кодилка mp3шек, основанная на том же LAME. "GoGo" называется. Мэйд ин жопен, как говорится. Отличительная особенность: работает в два раза быстрее, чем обычный LAME-кодер. Фишек больше, чем в NotLAME. Для компилирования этой проги тебе понадобится nasm (ассемблер бесплатный). Лежит он здесь: http://www.web-sites.co.uk/nasm/.


Спецвыпуск Хакера, номер #005, стр. 005-092-3, Mp3-зация юниксоида

Mp3-зация юниксоида

Спецвыпуск Хакера, номер #005, стр. 005-092-3

BladeEnc

Хомяк/где скачать: http://www.fsf.org

Старый добрый BladeEnc. Популярнейший кодер. Простой, небольшой и быстрый. Раньше я только его и юзал. Весь набор фишек стандартного энкодера (и даже больше).

TkNapster

Хомяк/где скачать: http://www.tucows.com

Название говорит само за себя :). Иксовый вариант Napster`а, написанный на tk/tcl. Позволяет делить с ушастыми буржуями и искать mp3шки так же, как и виндовский. (Не забудь опять поставить в настройках, что у тебя T1-канал. :))

XMMS-KJ

Хомяк/где скачать: http://www.dgs.monash.edu.au/~timf/xmms

Ты юзал K-Jofol под виндами? Это который на http://www.k-jofol.org лежит. Некоторые скины к нему гораздо круче, чем винамповские. Кому-то это не понравилось :), и этот кто-то написал эту прогу. Она может быть скомпилирована как отдельная программа: запускаешь XMMS, грузишь ее, и она управляет твоей ИКСсовой МультиМедиа Системой. Правда, может и как плагин для визуализации под иск-эм-эм-эс работать - тоже неплохо. В любом случае, одна цель и один результат: сделать для XMMS дизигн K-Jofol`я! В общем, геморроя у тебя с этим делом много будет. Фанаты, за работу! :) Остальные отдыхают.

Вот и все. Ты вооружился по самые помидоры стаффом, необходимым для твоих пакостных деяний с mp3шниками. :) Удачи!

В наши дни супертехнологий трудно найти кул-хакера, работающего за компом над поиском очередной дыры в хотмыле или еще где-нибудь и не слушающего музыку. Музыка вдохновляет... :) А без вдохновения у тебя ничего нормально не получится! (Во, как загрузил! :)) Ты перешел на *nix... Как же в нем заставить музу кул-хакера снизойти до твоих высот "чайку попить"? :) Грузи плеер и слушай свои любимые mp3-шки. Если нечего грузить, не спеши ставить первую попавшуюся прогу: сейчас разберемся что к чему. А если плеером ты уже обзавелся, я тебе помогу подобрать получше. :)


Спецвыпуск Хакера, номер #005, стр. 005-094-1, Майлеры под Никсы

Майлеры под Никсы

Спецвыпуск Хакера, номер #005, стр. 005-094-1

LonerX (lonerx@nettaxi.com)

Писюльки

Привет. Ну как у тебя дела с освоением недавно установленной UNIX системы? Не очень? А-а, понятно... Ты, как и многие в свое время, столкнулся с проблемой выбора софта. Прекрасно тебя понимаю, так как софта для UNIX действительно много, и иной раз трудно разобраться, что стоит выбрать, а что нет. Тем более если дело касается специфических программ, например, программ для работы с сервисами Интернет. Но это дело поправимое, со временем ты разберешься с тем что тебе надо, а что не очень, и для тебя определится круг программ, которые наиболее подойдут твоим целям и задачам. Но чтобы тебе не тратить свое личное время, которое, как известно, лишним не бывает, я вкратце поведаю о семействе тех утилит, которые очень важны в жизни каждого UNIX пользователя и значимость которых трудно преувеличить. Я говорю о программах, отвечающих за отправку/получение электронной почты. Да, про мылеры :). Чем эти программы столь особенны? Да хотя бы тем, что почтовые клиенты для UNIX появились гораздо раньше всяческих The Bat, Outlook Express и прочих Netscape Messenger'ов. И развитие их шло по своей специфической линии, что, в итоге, обусловило уникальность этих программ и их отличие от выполняющих аналогичные функции утилит для Windows. Так что новичку, только что слезшему с продукции MS и перешедшему на UNIX, зачастую трудно сходу разобраться с почтовыми программами и, следовательно, извлечь максимальный КПД от их использования. Приготовься внимательно слушать и запоминать!

Классическое Мыльце

E-mail утилит для *nix существует множество. Чтобы в этом убедиться, достаточно посетить сайт типа tucows.com и просмотреть разделы, посвященные этим программам. Но, несмотря на огромный выбор, есть несколько экземпляров почтовых клиентов, признанных классическими (если такое слово допустимо) и основополагающими инструментами обращения с почтой. Вот о них-то я и хочу рассказать в этой статье. И начну я свой рассказ с программ, предназначенных для консоли.

Перед тем как начать обзор консольных E-mail клиентов, необходимо упомянуть о тех программах, которые осуществляют собственно транспортировку электронной почты. Передача сообщений в сети осуществляется с помощью протокола пересылки почты SMTP (Simple Mail Tranport Protocol). Наиболее распространенным транспортным агентом (electronic mail transport agent) для этих целей является программа sendmail. Именно она отвечает за безошибочную доставку почтового сообщения адресату по протоколу SMTP. Так что для отправки писем тебе понадобится установленный и запущенный sendmail daemon. К счастью, sendmail поставляется со многими дистрибутивами UNIX и автоматически настраивается при инсталляции системы. Поэтому на этом останавливаться я не буду и перейду к следующему пункту.

Скорее всего, у тебя есть зарегистрированный почтовый ящик на каком-либо удаленном сервере, типа mail.ru, или сервере твоего провайдера... В этом случае тебе необходима программа, забирающая почту с удаленного сервера, так как программы для чтения/отправки электронной почты этой функции не выполняют. Одной из самых распространенных утилит такого типа является программа fetchmail, забирающая сообщения с другого сервера и передающая их в распоряжение локальных почтовых служб (например, той же sendmail). После этого почта становится доступной для чтения с помощью утилит, к рассказу о которых я скоро перейду.


Спецвыпуск Хакера, номер #005, стр. 005-094-2, Майлеры под Никсы

Майлеры под Никсы

Спецвыпуск Хакера, номер #005, стр. 005-094-2

Самый простой формат команды fetchmail выглядит так:

fetchmail -u <user> mail.*******.com

После ввода этой строки fetchmail запросит пароль указанного пользователя к его удаленному почтовому ящику и приступит к процессу затребования и скачивания сообщений. Об использовании программы fetchmail тебе больше расскажет команда man fetchmail, ну а я перейду непосредственно к почтовым клиентам.

Босс, к вам Клиент!

Самым простым средством для обмена электронной почтой является программа Mail. Эта утилита была создана для BSD Unix и названа просто... mail :). В версиях Unix System V эта утилита была модифицирована и переименована в mailx, но простое название "почта" так и осталось за этой программой. Для отправки сообщения достаточно набрать команду mail с адресом получателя в качестве аргумента. После этого программа считывает со стандартного ввода строки, которые будут включены в сообщение, и отправляет сообщение адресату. Процесс отправки письма показан на рисунке 1.

Прием и чтение писем с помощью mail тоже является простым и несложным процессом. Для этого достаточно набрать команду mail, и на экран выведется список новых сообщений, пришедших в твой почтовый ящик, после чего появляется командное приглашение программы mail в виде амперсанта (&). Для прочтения нужного письма достаточно ввести цифру, соответствующую его номеру. Выход из программы осуществляется с помощью ввода символа "q". На рисунке 2 продемонстрирован короткий пример чтения письма с помощью mail.

Я упомянул, что у mail имеется собственный командный интерпретатор, приглашение которого обозначается знаком амперсанта. С помощью команд этого интерпретатора над поступившими сообщениями и их списком можно проводить различные действия, облегчающие чтение писем и управление их списком. Например, с помощью команды <р> с именем пользователя в качестве опции на экран будет выведен список сообщений от этого пользователя. Команда <h> повторно выводит на экран список писем, который был отображен при запуске программы, и так далее. На письма также можно отвечать с помощью команды <r> с номером письма. На рисунке 3 показан цикл чтения писем из файла mbox и ответа на одно из них. К слову - все письма по умолчанию сохраняются в файле mbox в директории, откуда была запущена mail.

Количество возможностей описанной почтовой утилиты значительно больше, чем я рассказал, но в них лучше разбираться самому. Несмотря на свою простоту, программа mail является очень популярным средством оперирования электронной почтой и незаменима при написании различных скриптов, предназначенных для работы с e-mail.

Кошмары на улице Эльмов

Следующая консольная почтовая утилита, о которой пойдет речь, называется elm. Ее основным, на мой взгляд, отличием от mail является наличие гораздо более удобного пользовательского интерфейса. Программа запускается с помощью ввода команды elm, выдавая список новых сообщений, как это делала mail. На рисунке 4 показан внешний вид elm после запуска. Как видишь, в отличие от mail с ее интерфейсом командной строки, elm использует экранный интерфейс, значительно облегчающий работу с электронной почтой. Для обработки сообщений предлагается вводить однобуквенные команды, аналогичные командам редактора Vi. Прочитать сообщение не просто, а очень просто - достаточно выделить его и нажать <Enter> (смотри рисунок 5). Ответить на письмо тоже не трудно - достаточно ввести команду <r> при выделенном сообщении. Написать и отправить мыло так же просто, как и в mail. Для этого надо либо запустить elm с адресом получателя, либо ввести команду <m> в поле command. После нескольких вопросов о теме письма и адресах получателей копий программа запустит стандартный редактор (обычно Vi) для редактирования сообщения. После этого письмо может быть отослано.


Спецвыпуск Хакера, номер #005, стр. 005-094-3, Майлеры под Никсы

Майлеры под Никсы

Спецвыпуск Хакера, номер #005, стр. 005-094-3

Аттачики

Отдельного разговора требует проблема передачи по электронной почте двоичных и архивированных файлов. Дело в том, что с помощью операций e-mail в Интернет можно передавать только текстовые файлы. Поэтому для того чтобы передать программу, картинку или архив, надо перевести их из двоичного формата в текстовый. Это можно сделать с помощью программы uuencode. Формат нужной для этого команды следующий - uuencode "file""name", где "file" это имя исходного файла, а "name" - имя, которое будет присвоено файлу после обратной перекодировки в двоичный формат. Результат перекодирования в текст передается в стандартный вывод, поэтому надо перенаправить его в файл. Тогда полный формат команды для перекодировки, например, рисунка я могу задать следующим образом - uuencode ***.gif ***.gif > file_to_be_sent. В результате файл file_to_be_sent и будет тем документом, который можно послать по почте. Для обратной декодировки используется программа uudecode, которая вызывается одноименной командой с именем раскодируемого файла в качестве аргумента. То есть результатом выполнения команды uudecode file_to_be_sent будет двоичный файл ***.gif.

На этом, пожалуй, краткий обзор консольных E-mail клиентов можно закончить. Конечно же, реальное количество подобных программ выходит далеко за пределы двух, но так как я описал наиболее популярные и широко используемые клиенты, то после работы с ними освоение других аналогичных программ будет делом пяти-десяти минут. Так что сейчас я перейду к рассказу о почтовых утилитах для Xwindows.

И снова окна

E-mail клиентов для графического интерфейса на сей день существует множество. Есть почтовые программы как для самой среды Xwindows, так и для наиболее популярных оконных менеджеров - KDE и GNOME. Выделить среди этих программ какую-то отдельную и описать ее подробно не составляет труда, но и особого желания делать это тоже нет :). Поэтому я ограничусь тем, что просто опишу основные особенности этих мейлеров. Ну, во-первых, графические e-mail клиенты гораздо более просты в использовании, нежели консольные. Просто к интерфейсу менюшек и кнопок мы все привычны еще со школьных уроков информатики, и разобраться в нем не составляет труда. Во-вторых, настройка почты под Xwindows зачастую проста, но тем не менее отличается большой гибкостью. Например, в моем любимом мейлере для Х - kmail - при настройке предлагается выбрать механизм отправки почты (sendmail или SMTP протокол), настроить отдельные папки для писем, приходящих на разные адреса, и многое другое. Так же многие графические клиенты легко и непринужденно обрабатывают файловые attachments, не заставляя пользователя прибегать к различным дополнительным программам. На рисунке 6 показан общий вид мейлера kmail. Так как специальных команд для графических редакторов не существует, а в меню и кнопках мы все разбираемся благодаря MS Windows, то дальше по поводу GUI почтовых клиентов я распространяться не буду. На этом и остановимся =).


Спецвыпуск Хакера, номер #005, стр. 005-094-4, Майлеры под Никсы

Майлеры под Никсы

Спецвыпуск Хакера, номер #005, стр. 005-094-4

Смываться!

Ну вот, собственно, и все, что я хотел рассказать. Выбор за тобой. Но предупреждаю сразу - для того чтобы выбрать свою любимую программу, тебе придется попробовать не один и не два, а несколько вариантов, примериться к каждому и уже после сравнения выносить окончательный вердикт: мое - не мое. Так что удачных поисков и хороших результатов =). Если что - пиши письма.

Самый простой формат команды fetchmail выглядит так:

fetchmail -u <user> mail.*******.com

Почтовые клиенты для UNIX появились гораздо раньше всяческих The Bat, Outlook Express и прочих Netscape Messenger'ов. И развитие их шло по своей специфической линии, что, в итоге, обусловило уникальность этих программ и их отличие от выполняющих аналогичные функции утилит для Windows. Так что новичку, только что слезшему с продукции MS и перешедшему на UNIX, зачастую трудно сходу разобраться с почтовыми программами и, следовательно, извлечь максимальный КПД от их использования.


Спецвыпуск Хакера, номер #005, стр. 005-096-1, Боевой софт под Юникс

Боевой софт под Юникс

Спецвыпуск Хакера, номер #005, стр. 005-096-1

LonerX (LonerX@nettaxi.com)

Привет! Ты уже разобрался со своим UNIX? Понял - разобрался... То есть ты все настроил, пропатчил, проапгрейдил и оптимизировал :). Так что теперь ты со спокойной душой выходишь в чат, смеешься над ламерами и то и дело с ухмылкой просматриваешь логи, где зафиксированы попытки влезть на порт 31337 или завалить твою машину каким-нибудь нюком. Это хорошо... Это правильно. Только скучно, тебе не кажется? Как же так: ты сидишь под крутой, навороченной операционкой, народ вокруг тусуется в основном на Windows, а уважения к тебе никто не проявляет!!! То есть когда ты на очередную попытку сканирования спрашиваешь заделавшего ее лоха: "Типа, это что было?", он мало того что просто внаглую спрашивает: "Ну и что?", но и откровенно посылает тебя... Что делать? Ответ простой - нючить, флудить и вообще портить жизнь :). Но как? В сети везде лежат нюки, заточенные под маздай, а они в UNIX не пашут, и поэтому приходится сидеть обтекаючи и на всякую дрянь отвечать экзистенциальным "сам дурак". Тебя такая ситуация устраивает? Меня - нет. Так что придется напрячься и разобраться с нужным софтом для UNIX платформ, ибо такой есть, его много, и нужно просто приложить некоторое количество усилий для того чтобы его найти и научиться использовать :). Ну а я как раз хочу помочь тебе с этим. Добро пожаловать на мой КМСБ (курс молодого сетевого бойца =))!

Warfare

Как я уже сказал, боевые программы под *nix в природе есть, и их действительно много. И количество таких программ гораздо больше, чем количество аналогичного софта для Windows, так как на самом деле большинство нюкеров изначально создаются именно юниксоидами и уж потом портируются под форточки (если вообще портируются), и зачастую результаты этого весьма плачевны. Так что приготовься прочитать о программах, о которых ты и помыслить не мог, пока был честным поклонником Microsoft. Но попутно (не забывай про то, что ты на КМСБ) я буду строить и грузить тебя по поводу терминологии, которую принято употреблять при разговоре об интересующих нас в данный момент программах. И начну я, пожалуй, с того, что порекомендую оставить слово "нюк" в далеком виндосном прошлом или, на крайний случай, для разговоров с людьми детсадовского возраста. А в мире больших дядь и операционной системы UNIX бытует словосочетание "DoS атака". DoS это не название любимой операционной системы :), это аббревиатура от Denial Of Service, и это значит, что целью такой атаки является не проникновение в чужой компьютер (для кражи информации в виде порнокартинок, например =)), а выведение компьютера из строя. После этого сайты перестают работать, электронная почта не снимается, а неприятель в чате после некоторого молчания исчезает со зловещей надписью Ping Timeout. Запомнил? Это тебе пригодится для последующих самостоятельных поисков инфы по таким программам, ибо слово "нюк" ты нигде не встретишь. Ну, хватит со вступлениями, перейдем к делу!

Как я уже говорил, большинство программ нюкеров, которых ты встречал в виндах, изначально были написаны под UNIX. И для того чтобы не показаться пустословом, я начну с рассказа о прототипе знаменитого нюкера под названием voidozer. Да-да, широко известная войдоза родилась из DoS attack программы под названием kod.c (все эксплойты, в том числе и DoS, поставляются не в виде исполняемых файлов, а в виде исходного текста). В основу действия эксплойта легла ошибка в стеке TCP Win9*. Благодаря этой ошибке, при получении фрагментированных IGMP пакетов выньдос ложится на спину и показывает до боли знакомый синий экран смерти :). Так что хватай свой ftp-клиент и лети на ftp.technotronic.com. Оттуда сливай файл под названием kod.c (я думаю, ты сможешь его там найти, иначе читать эту статью не имеет смысла) и помещай его в директорию, созданную для подобных программ. Теперь файл надо откомпилировать. Набирай команду gcc -o kod kod.c. Программа скомпилирована под именем kod. Осталось найти жертву и приказать ей долго жить :). Для того чтобы убить комп недруга, надо переключиться в root (это нужно для работы программы) и набрать ./kod -p -t , где это айпишник жертвы, , соответственно, атакуемый порт и - количество пакетов, которое надо отослать. Весь вышеописанный процесс показан на рисунке.


Спецвыпуск Хакера, номер #005, стр. 005-096-2, Боевой софт под Юникс

Боевой софт под Юникс

Спецвыпуск Хакера, номер #005, стр. 005-096-2

Правда, при попытке атаковать удаленный компьютер таким образом может возникнуть очень серьезная проблема - твой провайдер может не поддерживать роутинг IGMP пакетов, а это значит, что злобные кусочки информации, призванные подвесить машину врага, просто не дойдут до жертвы :(. Но тут уж ничего не поделаешь, придется читать дальше.

Следующая прога для убиения многострадальных форточек называется jolt2.c. Результатом действия этой программы является резкий перерасход использования памяти, что ведет либо к зависанию компьютера, либо к существенному замедлению его работы. Основной механизм действия атаки заключается в посылке вражескому хосту неверно фрагментированных ICMP или UDP пакетов. Исходник эксплойта лежит на том же ftp.technotronic.com, откуда ты сливал kod.c. После скачивания эксплойта откомпилируй его уже знакомым образом - gcc -o jolt2 jolt2.c. После этого переключись в root, найди жертву (обычно жертвы не заставляют себя долго ждать и вылезают сами =)) и запусти полученную в результате компиляции программу. Формат запуска проги следующий - ./jolt2 <-s src_addr> -p , где - адрес, от которого будут приходить пакеты (тебе ведь не надо, чтобы тебя вычислили), - номер порта, на который будет производиться атака, и - адрес непосредственно жертвы. Все эти шаги показаны на рисунке.

Если при запуске программы обозначить номер порта, то атака будет осуществляться посредством UDP пакетов, при отсутствии опции в дело вступает ICMP. Ну, с этим, пожалуй, закончили. Едем дальше.

Говоря о плохой обработке "порченых" пакетов нельзя не упомянуть об эксплойте под названием teardrop.c. Основа действия этого эксплойта состоит в посылке частично совпадающих пакетов. Уязвимыми системами являются Windows и ранние версии Линукс. Результат атаки - брутальное зависание системы. Чтобы завести в своем арсенале такую полезную программу, лети... лети... правильно - опять на ftp.technotronic.com. Когда teardrop.c перельется на твой жесткий диск, не спеши его компилировать. Дело в том, что в скачанном файле помимо непосредственно исходника находится патч для Линукс, позволяющий залатать уязвимость, и пространное вступление автора эксплойта. Патч и вступление надо просто вырезать с помощью любого текстового редактора. После этого эксплойт скомпилится без проблем. Как это сделать, я надеюсь, ты помнишь :). Использовать эксплойт следует в таком формате : ./teardrop -s -t -n . Как несложно догадаться, и обозначают, соответственно, отправляющий "адрес" и адрес жертвы, и - порт, посылающий пакеты, и порт, которому пакеты предназначаются; - количество пакетов, которое следует отослать. На скриншоте показан процесс использования teardrop.c от компиляции и до запуска.


Спецвыпуск Хакера, номер #005, стр. 005-096-3, Боевой софт под Юникс

Боевой софт под Юникс

Спецвыпуск Хакера, номер #005, стр. 005-096-3

Я думаю, что об эксплойтах, использующих кривую обработку неправильно слепленных TCP/IP пакетов, сказано достаточно. Существуют различные вариации и модификации описанных программ, а также некоторое количество эксплойтов, идентичных описанным по принципу действия. Их много, и рассказывать обо всех смысла не имеет. Разобравшись с этими и поюзав их, ты сможешь сам найти описания и исходные тексты аналогичных перлов программистского труда :). Основным источником исходников в данном случае является пресловутый ftp.technotronic.com.

Flood'em up!

Теперь я хочу рассказать тебе о другом варианте DoS атаки. Если, как было отмечено, вышеописанные программы используют в качестве метода отсылку неправильно сгенерированных пакетов, вызывая этим сбой работы жизненно важных программ на удаленном компьютере, то средства сетевого наезда, о которых я хочу сказать сейчас, работают на совершенно ином принципе. Этот принцип заключается в том, что атакуется не конкретно операционная система на удаленной машине, а сам канал связи этого компьютера с сетью Интернет. То есть если заполнить этот канал ненужной информацией, причем дать информации гораздо больше, чем то количество, на которое канал рассчитан, то связь по этому каналу либо оборвется, либо существенно ухудшится. Самым простым примером такого наезда может послужить ping floog, то есть посылка ICMP-ECHO (ping) пакетов с такой скоростью, что канал связи удаленного компа просто не в силах вместить что-то еще. Самым замечательным свойством такого типа атак является то, что результат атаки не зависит от операционной системы на вражеском компе. Но есть и существенный недостаток - тем же пингом можно атаковать только с серьезного канала с хорошей пропускной способностью, ибо ты получаешь столько же мусора, сколько и отправляешь :). Но злые дядьки хацкеры не носили бы такое гордое имя, если бы не сумели эти проблемы обойти... Интересно - как??? Вот сейчас и узнаешь. Напрягись, ибо мы подошли к изучению воистину тяжелой артиллерии =).


Спецвыпуск Хакера, номер #005, стр. 005-096-4, Боевой софт под Юникс

Боевой софт под Юникс

Спецвыпуск Хакера, номер #005, стр. 005-096-4

Стандартная архитектура сети подразумевает наличие двух особых адресов - так называемые "адрес подсети" и "сетевой адрес". При посылке какого-либо сигнала на такой адрес отвечают все компьютеры подсети. То есть если в подсети работает сорок компов, то в ответ на ping-запрос по какому-нибудь из таких адресов тот, кто этот запрос сделал, получит сорок ответов. Когда-то это использовалось при тестировании сетей на наличие сбойных компьютеров. Такие хитрые адреса маркируются обычно как x.y.z.0 и x.y.z.255. В Интернете, как правило, использование таких обращений к подсетям (их называют еще broadcast, или широковещательные обращения) не разрешается, но так как сети, входящие в Инет, конфигурируются людьми, а люди склонны совершать ошибки, то до сих пор в Интернет остались (и даже появляются) сетки, отвечающие на broadcast запросы. Теперь представь, что в такой сети сорок компов. Ты пингуешь их с модемного соединения в 28.8 kbps. Какой ответный трафик будет генериться такими запросами? Посчитай - 28.8*40=1152.0 kbps. Не слабо, правда? Ну а если взять не одну сеть, а около сотни? Количество ответов от каждой из них не 40, а больше 100! Хана коннекту называется! А теперь осталось заменить "обратный адрес" во всех отсылаемых пакетах на адрес вражеского компьютера. Ура, противник лежит и не шевелится. Такая атака получила название Smurf (аплодисменты, господа). Программ, осуществляющих смурф атаку, много, но мне лично нравится одна из последних, под названием Smurf6. Я точно не помню, есть ли она на ftp.technotronic.com, но знаю, что эту прогу можно найти на packetstorm.securify.com под именем smurf6-linux+LPG.c. Так что вперед, на поиски!

На деревню дедушке

Но, кроме всего прочего, тебе понадобится список адресов сетей, отвечающих на broadcast запросы. Такой список еще называют Broadcast List. Самому искать такие адреса - дело долгое и нудное. Но, слава Богу, есть сайт, на котором публикуются регулярно обновляемые списки неправильно сконфигурированных сетей. Так что вбивай в броузер http://netscan.org и сливай инфу оттуда. Готов? Теперь пора научиться пользоваться программой.

Usage

Про компиляцию я рассказывать не буду, так как этому ты уже должен был научиться. Так что перейду к рассказу о том, как получившуюся программу поюзать. У Smurf6 много опций, позволяющих выбрать режим атаки. От этих опций зависит: количество пакетов для отсылки (по умолчанию unlimited), временная задержка между пакетами, протокол (по умолчанию ICMP) и многое другое. Но самым простым вариантом запуска smurf является следующий - ./smurf ... Расшифровывать, думаю, не нужно. Процесс убивания коннекта противника запечатлен на скриншоте.

Вагончик тронется - перрон останется

Ну вот, пожалуй и все, что нужно для Молодого Сетевого Бойца :). Осталось сказать несколько слов напоследок. Перед тем как грохать кого-нибудь в чате - десять раз подумай и постарайся выяснить, что это за человек и стоит ли с ним связываться. А то отдача может оказаться такой, что мало не покажется. Ну и, конечно, никогда не выкидывай из сети ради прикола или ради проверки эксплойта. Это недостойно. Но когда наткнешься на наглого ламера или тупого лоха, юзай описанные средства без сомнения - сеть должна быть чище! Вот и все, удачного хака.


Спецвыпуск Хакера, номер #005, стр. 005-099-1, Два слова о юниксоидах

Два слова о юниксоидах

Спецвыпуск Хакера, номер #005, стр. 005-099-1

Михаил Михин (centner@xakep.ru)

- Ты кто?

- Фармацевт.

- А-а-а, лекарства делаешь..

- Не-е-е, диск C:\ форматирую

НЕ ТАК СТРАШЕН PROGRAMMER, КАК ЕГО SOFTWARE

Если ты дочитал до этого места и все равно продолжаешь упорно читать и осмысливать прочитанное - что ж, поздравлю тебя, ты всего лишь в нескольких шагах от важного, поистине мужского решения - расстаться с ламерской девственностью и стать настоящим крутым мужиком, ИМЕЮЩИМ ВСЕХ и UNIX.

Должен тебя предупредить: после того как ты станешь юниксоидом, жизнь твоя круто изменится, появятся множественные сложные обязанности, дадут о себе знать профессиональные заболевания (в числе наиболее изученных - программизм и острый онлайнизм) и случатся другие страшные напасти, как, например, "ПолтерГейтс". Типичный случай: по всей комнате летают диски, залетают в CDROM и постоянно устанавливают Windows. Готов ли ты к таким испытаниям или только думаешь, что готов? На всякий случай я поведаю тебе некоторые интересные факты и приметы из жизни славного и беспокойного племени юниксоидов. Многие из фактов были почерпнуты в трудах истинных корифеев отечественного программизма, но преимущественно являются плодами обычной наблюдательности. Итак - вперед!!!

ШУТКА ЮМОРА

Для начала попытаюсь тебя огорошить интересным фактом. Как сообщают ведущие мировые информационные агентства - "Создатели Cи и UNIX признают, что разыграли весь мир. В заявлении, потрясшем весь компьютерный мир, Кен Томпсон, Деннис Ричи и Брайан Керниган признали, что операционная система UNIX и язык программирования Си, созданные ими, - тщательно спланированный первоапрельский розыгрыш. Создатели даже планировали продать свои шедевры программистской мысли Советскому Союзу, "чтобы отбросить развитие их компьютерного дела на 20 лет назад". Не знаю, хочешь ли ты еще ставить на свой комп UNIX, но, по крайней мере, теперь ты точно знаешь, кто виноват "в том хаосе, путанице и действительно скверном программировании, причиной которых явилась неудачная шутка столько лет тому назад." Все еще хочешь быть похожим на таких вот горе-юниксоидов?

ДЕТИ КАМПУЧИИ ВСЕ ЕЩЕ НЕДОЕДАЮТ

Знай, что настоящий программист-юниксоид вечно голоден или недоедает, но, вместе с тем, он еще месяц сможет питаться едой, выковырянной из-под кнопок клавиатуры.

Юниксоид - существо набожное. Он свято верит в то, что после процедуры UNINSTALL программы копируются в компьютер, который стоит на небе и никогда не зависает. Юниксоид частенько произносит несложные заклинания типа: "Онлинь, диалуп! Setup..."

Дети юниксоидов, уже частично мутировавшие в юниксоидов, учатся в специальных школах, где изучают потусторонние науки. Им часто рассказывают ужасные сказки: "Жила-была девочка Оля. И поставила она себе Norton Utilities. И Norton Disk Doctor нашел у нее ошибки и вирусы. И она умерла."

Программистский алфавит выглядит как "Й, Ц, У, К, Е, Н, Г...". На просьбу преподавателя назвать несколько круглых чисел называют 2, 4, 8, 16. Среди единиц измерения, знакомых программисту, имеются килобайт - 1024 байта, и килобаба - 1024 бабы.


Спецвыпуск Хакера, номер #005, стр. 005-099-2, Два слова о юниксоидах

Два слова о юниксоидах

Спецвыпуск Хакера, номер #005, стр. 005-099-2

Зарабатывает юниксоид немного. Зато отдыхает часто и преимущественно в Минске. А что ты ржешь? Отличный холодильник!

Среднестатистический юниксоид любит и ценит секс, особенно в извращенной форме. Да и как его не любить, если на экране монитора то и дело появляются надписи а-ля "Девица не готова - Device not ready", что любого заставит нервно вздрагивать. Частенько оргазм наступает при появлении надписи "Connect 33600". Голо-систые девки способны свести с ума любого представителя программерского племени, но особое сексуальное влечение и упорство у юниксоида вызывают технические новинки. Например, любой мало-мальски уважаемый работник софта и железа хотя бы раз изощренно трахался с вонючим принтером, мерзкой видеокартой или малознакомым Момедом, так что можно смело заявлять, что юниксоид би-техно-сексуален. Если же юниксоиду выпадает возможность познакомиться с живой Device в реальной жизни, то происходит это примерно так:

- Пошли ко мне домой!

- Еще чего, у нас даже нет общих знакомых.

- Гейтса знаешь?

- Конечно!

- Пошли!

Бывают среди юниксоидов убежденные правонарушители. Их называют hacker-ы (убедительно прошу не путать понятия hacker и fucker!) или, на знакомом тебе языке, - ксакепы. Это обычно гадкие, нехорошие компьютерные хулиганы. Их ловят за... ну, за... короче, за что надо и навсегда отправляют в увлекательный мир установки Windows 95.

Юниксоиды любят животных. Особенную привязанность у них вызывают мыши. О мышах заботятся, содержат их в домиках и отпускают пастись только на коврики. Хотя есть отдельные индивидуумы, которые неровно дышат и к семейству кошачьих. Вот такой диалог между двумя ксакепами мне удалось подслушать на днях:

- Слышь, у тебя кошка есть?

- Есть.

- С собой?

ИТОГО

И еще напоследок кратенько: настоящий юниксоид уверен, что Windows95 совместим только с одним форматом: "format C:"; четко знает, что по-английски BEGIN значит НАЧАЛО, END - КОНЕЦ, а DEBUGGER - аналог отечественного дихлофоса; понимает, что пиво - рулез, а MEGABYTE - американское название килобайта; его мама, которой часто вынимают мозги, живет в тачке; юниксоид запоем читает полное собрание компьютерных программ; средний уровень интеллекта (IQ) - 486; никогда не использует дисковод в качестве обеденного столика из-за раздражающей вибрации устройства; обожает хороший "Крепкий наезд" (Hard Drive); рассказывает всем вокруг, что СИ++, ПАСКАЛЬ 6.0 и выше - примерно то же самое, что молоток и плоскогубцы; зарплату получает в шестнадцатиричной системе счисления; пьет кофе прямо из кофейника, греющегося на системном блоке; запросто может насвистывать на 9600/ARQ; заставляет себя по несколько часов свопиться или аплодить в сортире; живет по принципу "Лучше переесть, чем недоспать"; обожает перекуры, пережоры и переустановку Windows; самое жуткое ругательство звучит как "Магнит тебе в сумку!"; способен начисто задавить лень глубоким сном; с детских лет помнит, что UNIX - у "них", а у "нас" - Васик; всегда имеет при себе полное руководство по MS-DOS; в жизни настоящего юниксоида однажды наступает ситуация, когда чистые носки проще купить; любимый программистский сайт - www.yahoo.eu, а любимое времяпрепровождение - под сенью струй (от струйного принтера); к числу истинных программистских ценностей относятся дискеты HIGHёвой плотности и сборник юмористических рассказов "Особенности релиза операционной системы Windows 2000"; друзей юниксоиды выбирают по принципу "Скажи мне, кто такой Билл Гейтс, и я скажу, кто ты"; может "разогнать" обычную 16-кг гирю до 57 кг; а выбить юниксоида из колеи можно только одним вопросом: "Какой командой процессора колобок ест черта в Packman-e?".


Спецвыпуск Хакера, номер #005, стр. 005-100-1, Вяленый пингвин, или пингвиньи архиваторы

Вяленый пингвин, или пингвиньи архиваторы

Спецвыпуск Хакера, номер #005, стр. 005-100-1

CroN (cron@hotmail.ru)

Хао, пингвин! :) Или ты красная шапочка? Неважно, короче, кто ты! Главное - у тебя стоит любимый дистрибутивчик Линуха, все себе понастраивал, в общем - живешь себе в кайф. Стопудово, ты много раз встречал всякое файло с

расширением типа .tar.gz, .tar.bz2, .gz, .z. Вот с ними и с прогами,

создающими их, мы сейчас и будем разбираться. Говорить мы с тобой будем не

только об экстракте, но и об, ясен пень, упаковке (место надо экономить!). Все, отхлебнули и поехали!

В Линухе тебе чаще всего будут нужны Gzip, Bzip2 и Tar, а также заточенные

под определенные типы файлов анпакеры, типа gunzip, bunzip2, unzip, unrar,

unarj и прочее. В принципе, без анпакеров можно и обойтись, если у тебя есть

соответствующий архиватор, но с ними все же лучше (читай: проще и удобнее), хотя тебе решать.

Gzip (GnuZIP)

Очень рулый архиватор! Только вот придется тебя огорчить - он не может

зажимать диры с файлами, но об этом читай ниже. Жмет он хорошо, даже иногда

(зависит от файла, который ты жмешь) делает RAR. Да и всяких прикольных команд

у него хватает... Стоп. Немного истории. Первый gzip - gzip1.0 - появился в феврале 1993-го и сразу стал широко использоваться в силу своей крутости, так как порядком делал своих предков - compress и pack. Не поверишь, но сам алгоритм, который юзает gzip, замутили всего два крутых чела - Д.Зив и А.Лемпель (J. Ziv, A. Lempel) еще в 1977 году. Мда, тогда многие из нас еще были в коннекшене со своими мамами (не теми, которые компьютерные :)) и знали только один надежный девайс - "Грудь молочная PRO". Ну да ладно. Короче: крутые парни назвали свой алгоритм LZ77, что надо понимать как первые буквы их фамилий и год издания этого алгоритма. Кстати, о птичках: этот же алгоритм юзают pkzip и zip.

Итак, синтаксис:

gzip [-команда] [-S суффикс] [файл]

Давай позырим, что за опции могут стоять после gzip:

-d --decompress

Ну, собственно говоря, распаковка (гениально :0)). Кстати, этой же командой можно анпакать файло, зажатое pack'ом, compress'ом, zip'ом и pkzip'ом. Только вот при этом у тебя могут возникнуть проблемы, связанные с файлами, зажатыми pkzip'ом и zip'ом, так как gzip не сможет анпакнуть архив, если в нем находится более одного файла, созданного методом deflate'а (да никто его не дефлорировал, просто метод так называется ;)).

-h --help

Это какая-то странная команда - наверное, помогает бабулькам переходить через дорогу :).

-l --list

Просмотреть содержание архива.

-L --license

Забей, это не для нас!!!

-n --no-name

Не сохранять, не восстанавливать имя и временную отметку.

-N --name

Команда, обратная предыдущей.

-q --quiet

Забить на предупреждения (м-да, чиста по нашему ;).

-r --recursive

Жать или анпакать, включая подкаталоги.

-S .suf --suffix .suf

Юзать суффикс. Вот эта фишка меня очень радует. Ты можешь зажать файло и при этом добавить в окончание имени файла любой суффикс. Например: введя вот такую команду:

gzip -S .fuck pornuha.rar ,

ты получишь файл pornuha.rar.fuck .

-t --test

Тест на беременность - проверить, не битый ли архив.

-v --verbose

К каждому действию при архивации gzip будет выводить комментарий.


Спецвыпуск Хакера, номер #005, стр. 005-100-2, Вяленый пингвин, или пингвиньи архиваторы

Вяленый пингвин, или пингвиньи архиваторы

Спецвыпуск Хакера, номер #005, стр. 005-100-2

-1 --fast

Быстрое сжатие.

-9 --best

Более качественное сжатие - с максимальной компрессией.

Если не хочешь париться при упаковке файла, то можешь сделать так:

gzip [имя файла]

Например:

gzip gemorroy.jpg

После этого ты получишь архивчик gemorroy.jpg.gz . Все вводится без скобок,

естественно (это так, если найдутся танкисты ;)). Как я уже писал выше, gzip не

может жать диры с файлами, но и с этим мы с тобой разберемся! Вводи вот так:

gzip -r [имя каталога]

Например:

gzip -r /home/pornuha

В результате ты получишь дир, в котором все файло упаковано. Еще можно

сначала сделать из дира .tar файл, а потом зажать gzip'ом. Вот так!

Думаю, если ты не урюпинский сапер, то должен был во все вышеописанное

въехать. Въехал? Молодец! Едем дальше.

Bzip2

Вообще, Bzip2 похож на gzip, только этим архиватором ты сможешь зажать уже

более одного файла. Вот что мне в нем нравится - так это то, что если архив

побился, то он сможет восстановить те части входящих в него файлов, которые не

были повреждены. Большинство команд у него такие же, как у gzip'а, только

обозначаются по-другому. Так, синтаксис:

bzip2 [-команда] [файл]

Вот его специфические команды:

-z --compress

Аналог команды -f, типа забить на ВСЕ и компрессить.

-k --keep

Не удалять входящее файло.

-s --small

Юзать меньше памяти.

-1... -9

Установить размер блока от 100кб до 900кб.

Для упаковки, например, можно сделать так:

bzip2 penguin.gif

В результате получишь архив penguin.gif.bz2. Если захочешь восстановить битый архив, то юзай утилитку bzip2recover. Синтаксис вот такой:

bzip2recover [имя файла].

Например:

bzip2recover zopka.jpg

Так, с этим, надеюсь, ты тоже разобрался! Далее...

Tar (Tape ARchiver)

Вот без этой штуковины тебе не обойтись, так что если у тебя ее нет, то немедленно добудь!!! Вообще, Tar не совсем архиватор, так как сам по себе он ничего не сжимает. Он объединяет нужные тебе файлы в нечто вроде набора, а потом жмет все это дело gzip'ом или bzip'ом2 - в общем, тем, что ты выберешь. Также tar объединяет в себе два предыдущих архиватора и имеет кучу собственных наворотов. Кстати, команду или набор команд тут можно писать без тире! Tar имеет (причем круто имеет ;)) следующий синтаксис:

tar [опция] [имя файла]

Опций у tar'а просто туева хуча, так что писать про все не имеет смысла,

т.к. ты многими вряд ли когда-нибудь воспользуешься. Ну, зачем тебе, например, делать архив формата POSIX или V7? Так что будем говорить о реальном:

-x, --extract, --get

Анпакнуть архив или выдрать отдельный файл. Кстати: если ты не укажешь, куда класть файло, то обрабатываться будет архив целиком.

-c, --create

Ну, собственно говоря, создать архив. Причем диры будут архивиться вместе с их содержимым.

-d, --diff, --compare

Интересная и довольно полезная опция. Делает она следующее: сравнивает диры и файлы, указанные в пути с содержанием архива. Кстати, если путь не указан, то проверяться будет весь архив. Все различия будут выведены на дисплей. Во!

-r, --append

Очень нужная команда! Ею ты можешь добавить в уже созданный архив один или несколько файлов.


Спецвыпуск Хакера, номер #005, стр. 005-100-3, Вяленый пингвин, или пингвиньи архиваторы

Вяленый пингвин, или пингвиньи архиваторы

Спецвыпуск Хакера, номер #005, стр. 005-100-3

-u, --update

Команда похожа на предыдущую, только вот в архив будет добавлено только файло, которого в нем нет, или то, которое было изменено после помещения в архив. Удобно, да?

-A, --catenate

Этой командой ты можешь добавить в существующий архив .tar'овое файло, то есть совмещать созданные архивы. Полезная вещь, однако!

--concatenate

То же самое, что и -A.

--delete

Удаление из архива.

-k, --keep-old-files

Сохранение старых файлов, т.е. при анпаке архива существующее файло не будет перезаписано.

-m, --modification-time

Этой командой ты запряжешь tar экстрактить файло с учетом даты и времени.

-p, --same-permissions

Файло будет экстрактиться с учетом прав доступа и со всей защищающей инфой.

-f [файл], --file=ARCHIVE

Этой командой ты укажешь имя файла, в котором хотел бы сохранить архив. Вообще, очень удобно, если ты хочешь писать архив, например, на дискету - можно спокойно ввести путь к флопу и сидеть - попивать пывко!

-L [длина], --tape-length=NUM

Установить максимальный размер архива (указывать в кило!).

-b [номер], --blocking-factor=BLOCKS

Команда, устанавливающая величину блока. Дефолтное значение - 20 секторов,

а так... Можешь менять от 1 до 24.

-v, --verbose

Все тот же вывод комментов, описанный выше.

--checkpoint

Выводить имена диров при работе с архивом.

--totals

Показывать во время создания архива, сколько байтов уже записано.

Ну что, все понял? Не совсем? Не бойся, ведь у тебя в руках Х, а это значит, что не должно остаться ничего недопонятого! Смотри, вот пример:

tar cfv bigelda.tar bigelda.bmp

Получаем файл bigelda.tar. Если же ты хочешь архивнуть файл, например, gzip'ом, то делай так:

tar cfvz bigelda.tar.gz bigelda.bmp

В результате получаем файл bigelda.tar.gz. Ну вот, ферштейн? Примеры я тебе дал, дальше разбирайся сам, а так ничему и не научишься, понимашь!

CompressCompress очень похож на gzip, только имеет меньше команд, но при сжатии большого по размеру файла может его уделать. А вообще, жмет он хуже. Команды один в один, как у gzip'а, но есть одна особенная: -b. Фишка команды в том, что ты можешь задать количество (от 9 до 16) бит, используемых для кодировки повторов, но тебе это вряд ли пригодится. Не думаю, что у тебя на компе стоит меньше чем 512 кило мозгов! Ну, на всякий случай, вот тебе синтаксис:

compress [команда] [-b значение] [файл]

Вот так-то!

Анпакеры

Так, теперь давай посмотрим, что у нас там с анпакерами! «Зачем козе баян, а мне - анпакер, если можно запустить сам архиватор с параметром распаковки»? - спросишь ты. Вот и я тоже не понимаю :0). Но, в принципе, идея правильная: вынести отдельно часто юзаемую команду и дополнить ее несколькими полезными фишками. Уловил мыслю?

Gunzip

Что есть gunzip? Gunzip - то же самое, что и gzip, запущенный с параметром -d. Чтобы анпакнуть файло, делай так:

gunzip [файл]

В общем, ничего заковыристого!

Uncompress

Uncompress аналогичен compress -d. "И все?" - спросишь ты. А я скажу: "Ага!".

Х-овые

Что касается X-овых архиваторов, то для КДЕ и Гнома их довольно много, как входящих в дистрибутивы, так и валяющихся в Нете. Так что это совсем другая история. Ты спокойно в них разберешься - они очень похожи на мастдаевские и ничего сложного собой не представляют!


Спецвыпуск Хакера, номер #005, стр. 005-100-4, Вяленый пингвин, или пингвиньи архиваторы

Вяленый пингвин, или пингвиньи архиваторы

Спецвыпуск Хакера, номер #005, стр. 005-100-4

Тестирование

У всех "больших" журналов бывает тестирование чего-нибудь. Вот я и решил: надо протестить архиваторы - это будет круто и сразу же прояснится, какой круче. Тестировалось все на дире весом в 42,789,601 байт, в котором содержалось

1382 файла, причем он был сначала заделан tar'ом . Заметь, что в таблице я привел сравнение с результатами архивации того же каталога rar'ом, который, по-моему, является самым крутым архиватором. Все вышеперечисленное можно взять здесь: http://freshmeat.net.

Злаключение :0)

Вот теперь ты крутой архиваторщик - вот и пойди заархивируй какую-нибудь девушку! В этом уж я тебе не помогу.


Спецвыпуск Хакера, номер #005, стр. 005-104-1, Дерево, на котором живут Пингвины

Дерево, на котором живут Пингвины

Спецвыпуск Хакера, номер #005, стр. 005-104-1

Андрей Фадеев (mika@farlep.net)

Привет! Сегодня мы поговорим о файловой системе Ext2fs (Extended2 File System), которую использует Linux. Вообще-то, большая часть написанного относится к любой файловой системе (а их много, почти каждая ОС'ка имеет свою). Но я остановлюсь поподробнее на особенностях Ext2.

Что такое файловая система?

Представь себе, что у тебя на столе есть куча бумажек с записями, или еще хуже - одна большая с тучей записей :). Говоришь, чего представлять - вот она кучка, рядом? Дык вот. Твой жесткий диск и есть такая длинная бумажка с записями. Естественно, никто не хотел ползать по всему диску в поисках инфы, ведь чтобы найти что-то, надо было просмотреть все записи :(. И вот в один солнечный день какому-то программеру (эх, нобелевскую премию бы ему, а его имени уже и не сыщешь) залезла в голову мысля, что нехило бы все это дело как-то систематизировать. И придумал он файловую систему. Посмотрел на это и подумал: "Хех, какой я умный!" ;). А на следующий день пил он с друзьями пиво, и с тех пор все люди в этот день отдыхают :). Но я отвлекся. Вот эта FS (File System - файловая система, по-нашему) представляет собой структурное образование... Ну, она на дерево похожа, из корня растет ствол, от него - ветки-директории, от них -

веточки-поддиректории, а уже на них - листья-файлы.

Файлы и директории

Собственно, основа файловой системы - это директории - папки, в которых лежат твои файлы, и сами файлы - ячейки информации. Наверняка в школе, когда из тебя хотели сделать ламера (гы, наивные 8)), тебе говорили, что файлы - это ячейки информации, имеющие разные форматы: текстовый, графический и т.д. Конечно, это так, но, запомни, файловой системе это строго фиолетово, ей файлы - просто блоки ценной инфы. Форматом интересуются уже конечные программы. В Линуксе директории растут так:

/ - это корневой каталог (директория). Все растет из него.

/directory1 - это одна из директорий.

/directory1/sub1 - это поддиректория. Таких подуровней может быть очень много.

/directory1/sub1/file.txt - это уже файл, мельчайшие ячейки информации. Запомни! В одной директории не может быть несколько файлов с одинаковым именем! А то путаница начнется, глюки, и прощай твои данные :). Линукс сам тебя предупредит при создании файла, если в каталоге есть уже файл с таким именем, так что испортить что-нибудь тебе вряд ли удастся. Как ты уже понял, при указании пути к файлу директории и файлы отделяются символом "/". Бывшие пользователи Windows часто путают :0).

Имена файлов и каталогов

Чтобы назвать свой файлик (или директорию) каким-нибудь классным именем, надо помнить следующие правила:

1. Имена файлов могут содержать буквы, цифры, черточки и прочие пробелы, но нельзя юзать специальные символы: "& ! ~ "

2. Если имя файла содержит скобки или пробелы, то при обращении к нему его имя надо брать в двойные кавычки ("file one.png"). Отсюда следует, что одинарные и двойные кавычки в названии файла лучше не использовать.

3. Хоть имя и может содержать до 255 символов, для Линукса имеют значение только первые 64. Так что если имена различаются только последней 255-й буквой, для системы они одинаковые. И, по моему, не очень удобно стучать по клаве название в 255 букв. Разик набрал, и на Mitino-BaZZarr, за новой клавой :).


Спецвыпуск Хакера, номер #005, стр. 005-104-2, Дерево, на котором живут Пингвины

Дерево, на котором живут Пингвины

Спецвыпуск Хакера, номер #005, стр. 005-104-2

Также существуют специальные символьные последовательности (а что, звучит :)). Например, "~" означает твой домашний каталог (Линукс - многопользовательская система, и у каждого юзера свой каталог, где хранятся его данные), "." - текущий каталог (тот, в котором ты сейчас работаешь), ".." - родительский каталог (т.е. тот, из которого вырос текущий). А вот если имя файла начинается с точки, например, ".hide"), то он считается "скрытым", и так просто его не увидишь. У-у, я смотрю, в твоих кулхацкерских мозгах уже появились интересные мысли ;).

Операции над файлами

Скальпель можешь положить на место, Склифосовский ;)! Сейчас ты поймешь, как файлы копировать, удалять, etc.

Смотри и внимай

Чтобы скопировать файл, тебе нужна команда "cp". Например, тебе надо скопировать file1 в file2. Пиши (без кавычек) "cp file1 file2". Просто? Проще некуда :). Если тебе надо скопировать файл в другую директорию, пиши "cp file1 path/to/another/dir/file2". Чтобы переместить файл - все то же самое, только вместо "cp" пиши "mv". Чтобы удалить файл - "rm <имя файла>". Для создания каталога пользуй "mkdir <имя директории>". А если надо удалить каталог со ВСЕМИ подкатологами и файлами в нем, то "rm -R <имя каталога>". Так как это UNIX, то регистр букв (большие-маленькие) имеет значение!!! То есть, "File1" и "file1" для Линукса - разные файлы! В операциях с файлами можно использовать символы-заместители - "*" замещает сколько угодно букв, а "?" только одну.

Диски

Рано или поздно ты захочешь записать что-нибудь на дискетку, переписать с компакта на хард и ты столкнешься с особенностью файловой системы Линукса. Если ты работал с ДОС'ом или Windows'ом, ты знаешь, что там каждый логический или физический диск обозначается одной буквой. То есть, на каждый диск свое

дерево каталогов. В Линуксе все не так. Дерево тут одно (а стучать надо чаще ;)) и, как ты помнишь, начинается с "/". Другие диски к нему МОНТИРУЮТСЯ. В большинстве релизов CD-ROM монтируется к /mnt/cdrom. Для того чтобы примонтировать диск, нам нужен "монтер" :). Итак, команда "mount". Набирай команду "mount -t iso9660 /dev/cdrom /mnt/cdrom". Параметр "-t" означает, что дальше идет название подключаемой файловой системы, в данном случае

"iso9660" - стандарт CD-ROM. "/dev/cdrom" - это твой сидюк, а /mnt/cdrom - "точка монтирования". Теперь содержимое CD-ROM - подкаталог файловой системы. Для более подробной информации смотри "man mount". Звание Юниксоида требует от тебя привычки читать доки и большого плаката над кроватью "RTFM!".

Права доступа к файлам

Вот еще одна очень интересная тема. Как я уже говорил, Линукс - многопользовательская система, то есть с одной машиной одновременно могут работать много человек. А это значит, что каждый имеет свои личные данные и хочет спрятать их от других. Каждый файл имеет три группы свойств, в каждой из которых по три элемента (во завернул :)). Первые три - это права для владельца:


Спецвыпуск Хакера, номер #005, стр. 005-104-3, Дерево, на котором живут Пингвины

Дерево, на котором живут Пингвины

Спецвыпуск Хакера, номер #005, стр. 005-104-3

r - читать, w - записывать, x - исполнять (если файл запускаемый).

Вторая троица - то же самое, только для управления правами для пользователей из группы, в которой работает владелец файла. Третья часть - опять оно же, только для всех остальных юзеров. Чтобы сменить права, есть команда "chmod" (отсюда и термин "отчмодить" :)).

Использование: chmod MODE[,MODE] FILE. Каждый MODE представляет собой комбинацию из одного или более символов u,g,o в начале и один из символов + (разрешение), - (запрет), затем одна или несколько букв r,w,x. Где u - владелец, g - группа, o - остальные, r - читать, w - запись, x - исполнение. Например: чтобы позволить себе запись, группе - чтение, а остальным, не входящим в твою группу, запретить

писать в file1.txt - пишем "chmod u+w,g+r,o-w file1". Если ты не владелец, но принадлежишь группе владельца, то ты можешь менять только свойства серии "g". А вот если ты вообще слева пришел, то можешь смотреть и облизываться, поменять тебе не дадут. Для смены владельца используй "chown user:group". Если ты администратор (т.е. root), то тебе плевать на всякие там права владельцев. Ты - главный, и перед тобой все без прав :).

Права доступа - сложная тема, но стоит немного потренироваться - и станет ясно

и понятно, что Linux - rulezz ;).

Символические ссылки

Символические ссылки - друг веб-дизайнера, и не только. Они позволяют экономить место на диске и обходить привязку программ к определенной директории. Вот тебе пример из жизни. Есть такая программа - органайзер, эмулятор PalmPilot. Это обычный Perl-скрипт, который генерирует странички, сохраняет и показывает данные. Так вот, он хочет работать только из директории "/usr/local/bin", но HTTP-сервер запускает скрипты из своей директории и ничего другого знать не

желает. Вот такая неувязочка... И тут Чип и Дейл спешат... Увлекся :). И тут нас выручают символические ссылки. В каталоге cgi-bin сервера создаем ссылку на исполняемый файл, и порядок! Сервер считает, что скрипт лежит в его каталоге, скрипт, запустившись, естественно, находит себя там, где хотел, и все довольны. И только файловая система знает, в чем фокус :). Но это только пример, а использовать это можно как угодно. Просто ты получаешь кучу файлов в разных директориях, с разными именами, но являющимися указателем на один и тот же файл

физический. Как же работать с ссылками? Просто, почти так же, как копировать файлы. Вспоминай команду "cp". Все так же, только добавляется ключ "-s": типа, "cp -s file1 file2". Файл "file2" - это не настоящий файл, а ссылка на "file1". Это как твой ник - имя другое, а содержание то же ;).

Что, где, зачем?

Здесь я расскажу, что где хранит среднестатистический Пингвин.

/bin - Основные программы системы. То, без чего Линуксоиду не прожить.

/boot - Ядро системы и основные загрузочные файлы.

/dev - Виртуальные файлы, представляющие собой устройства компьютера.

Благодаря такой организации, очень просто осуществить прямой доступ к устройствам - рай ;).


Спецвыпуск Хакера, номер #005, стр. 005-104-4, Дерево, на котором живут Пингвины

Дерево, на котором живут Пингвины

Спецвыпуск Хакера, номер #005, стр. 005-104-4

/etc - Всевозможные файлы конфигурации и настройки. В текстовом формате, с комментариями. Все для людей :).

/home - Дом родной ;). Личные каталоги юзверей.

/lib - Библиотеки (для программ) и другие модули.

/lost+found - Сюда программа проверки дисков сваливает битые файлы.

/misc (/opt) - Программы. Просто.

/mnt - Сюда обычно подключают другие файловые системы.

/proc - Виртуальные файлы, представляют собой запущенные программы. В них хранится информация про количество пожираемой оперативки и процессорного времени.

/root - Домашний каталог администратора.

/sbin - Системные программы.

/usr - Каталог с программами для пользователей.

/usr/X11R6 - Здесь живет графическая оболочка.

/usr/bin - Сами бинарники.

/usr/doc - RTFM, уважаемый! Документация.

/usr/games - Гамесы, они же игры.

/usr/local - Программы, устанавливаемые юзерами.

/usr/man - RTFM, часть 2. Страницы руководства, выводимые командой "man".

/usr/share - Файлы, используемые программами. Картинки, иконки, etc.

/usr/src - Исходники.

/var - Логи (админы - читать!:)) и прочие базы данных системы.

/tmp - Временный хлам. Продукт жизнедеятельности Пингвинов ;). Фекальки.

Вот и все

Я рассказал тебе только основы. Дальше копай сам. И повторю: главное правило Юниксоида... Правильно! RTFM!

Так как это UNIX, то регистр букв (большие-маленькие) имеет значение!!! То есть,

"File1" и "file1" для Линукса - разные файлы!

Есть такая программа - органайзер, эмулятор PalmPilot. Это обычный Perl-скрипт, который генерирует странички, сохраняет и показывает данные. Так вот, он хочет работать только из директории "/usr/local/bin", но HTTP-сервер запускает скрипты из своей директории и ничего другого знать не желает. Вот такая неувязочка... И тут Чип и Дейл спешат... Увлекся :).


Спецвыпуск Хакера, номер #005, стр. 005-106-1, UNIX: книжный обзор

UNIX: книжный обзор

Спецвыпуск Хакера, номер #005, стр. 005-106-1

Авторы скрываются под никами Urix&Fedix от мстительных производителей и продавцов дебильных книжек.

Мыло: SPOra_2k@mail.ru

Книга для кодера-маньяка, который одной ногой в психушке.

Максвелл С. Ядро Linux в комментариях. ДиаСофт, 2000. - 488 с. - CD.

Думаю, ты кончишь уже после первой половины книги, где даны листинги ядра Линуха. Испытав первый оргазм, можешь приступить к подробным комментариям со ссылками на код. Неплохо дана архитектура системы. Думаем, ты не раз еще кончишь, изучая прилагающийся диск с закомментированными исходниками системы. Внимание, Минздрав предупреждает, что авторы и редакция не несут ответственности за здоровье читателей.

Загрузная книжка для админа-программера, который решил заняться теорией.

Дунаев С.Б. UNIX-сервер. Настройка, конфигурирование, работа в операционной среде, Internet-возможности. - М.: Диалог-МИФИ. Т. 1: Общее руководство по системе - 1999. - 304 с. Т. 2: Системное администрирование - 1999. - 304 с.

Архитектура системы дается вперемежку с листингами. Множество картинок со всякими сетевыми прибамбасами. Рекомендуем любителям заворачивать себе мозги.

Книга для продвинутого перца, который хочет все знать и уметь.

Робачевский А.М. Операционная система UNIX: Учебное пособие. - СПб: BHV, 1999. - 528 с.

После первой главы ты будешь знать, как работает система: что, куда, зачем и на кой черт вообще это нужно. Далее идут архитектура и подробная анатомия протоколов. От глупости, конечно, сложно вылечить, но ты хотя бы будешь представлять, что происходит на твоей тачке. Книжка написана нормальным языком, но чтобы дочитать ее до конца, потребуются стальные нервы и гуттаперчевые яйца.

Общие учебники-справочники для любого юзера

Розен К., Розински Р. Введение в UNIX System V Release 4. - М.: Лори, 1999. - 726 с.

Кью П. Использование UNIX. - М.: Вильямс, 1999. - 624 с.

Куча всяких табличек, подробно расписаны все основные понятия и утилиты. Хорошо структурирован, мало воды. Можно быстро найти любую инфу.

Книга для пользователя, который хочет и догнаться, и оставить на потом.

Пик Д. UNIX: Инструментальные средства. - BHV, 1999. - 941 с. - CD.

Он уже знает основные команды и теперь хочет узнать о них все... Если он разберется в этой кипе макулатуры, скоро знакомые админы будут задавать ему свои вопросы! :)

Книга для начальника, который не любит платить кучу денег за админскую лапшу на ушах.

Карлинг М. Системное администрирование Linux: Учебное пособие. - Вильямс, 2000. - 319 с.

Руководство для настоящего шефа-садюги. Упор сделан на разработку требований, стратегию, управление ресурсами и планирование. Проще говоря, книга научит твоего босса посчитать до копейки зряплату, сэкономить на железе и на трафике в сети. Кроме этого, кратко, с примерами даны основы администрирования (чтобы админ не заговаривал зубы). Пригодится опытным администраторам, которые любят порядок, но не знают, как его навести.

Книжка для пользователя, который решил поставить Unix дома и хочет стать администратором.

Рэй Д. Освой самостоятельно системное администрирование UNIX за 21 день. - Вильямс, 2000. - 607 с.


Спецвыпуск Хакера, номер #005, стр. 005-106-2, UNIX: книжный обзор

UNIX: книжный обзор

Спецвыпуск Хакера, номер #005, стр. 005-106-2

Отличная книга для начинающего, который хочет стать большим злым дядькой и терроризировать пользователей. Есть приемы и быстрые рецепты администрирования. Объясняется, как настроить железо под Юникс для младенцев. Есть фотки, где показано, какой джампер на сетевухе переставить :). Суперадмином за месяц ты, конечно, не станешь, но чему-то научишься. Во всяком случае, в этой книге есть все необходимое: начиная с того, как подмонтировать дискетку к файловой системе, и заканчивая маршрутизацией сети.

Книга для сетевого админенка

Кирх О. Linux для профессионалов: Руководство администратора сети. - СПб.: Питер, 2000. - 362 с.

Написано, что для профессионалов, но уровень явно начинающего. Считается, что ты уже разобрался в системе. Теория сетей, протоколы, листинги настроек. Все это объясняется на пальцах. Для новичка это здорово - в трех соснах не заблудишься.

Ты понял структуру Unix и хочешь изучить тонкости?

Немет Э., Снайдер Г. и др. Unix: Руководство системного администратора. - К.: BHV, 2000. - 832 с.

В этом издании подробно описаны конфигурационные файлы, различия между основными версиями системы и прочие заморочки. Подробно даны практические приемы администрирования - вплоть до психологии. Книга переводная и немного занудная, рассчитана не на чайника.

Книги для юзера, которому друзья рассказали, что Линух это ультракруто. Чел его как-то поставил, но засыпает после первых двух слов любых объяснений.

Рассел Ч. UNIX и Linux. Книга ответов. - СПб.: Питер, 1999. - 296 с.

Вопросы и ответы по UNIX. Сост. и пер. с англ. А. Крупника. - М.: МикроАрт, 1998. - 223 с.

В этих двух книжках собраны ФАКи по разным разделам системы. Написано кратко и прикольно. Весело читать, и в мозгу что-то остается. Нет занудных поэтапных объяснений. Потом ты меньше будешь напрягать идиотскими вопросами друзей. Такая книга даст тебе общее представление, но ничему толком не научит.

Книга за 24 часа

Болл Б. Освой самостоятельно Linux за 24 часа: Руководство для начинающих. - М.: Вильямс, 1999. - 479 с.

Про 24 часа они, конечно, пошутили. Не обращай внимания. Главное, что в этой книге собрана куча практических рецептов, которые можно быстро попробовать. Описаны разные приложения: от графического редактора до веб-сервера. За эту книжку хорошо браться, начитавшись факов - когда ты знаешь, что тебе надо от системы.

Книги для сумасшедших домохозяек, перезрелых школьниц и старых маразматиков.

Бурк Р. и др. UNIX для системного администратора. Энциклопедия пользователя. - ДиаСофт, 2000. - 864 с.

Питтс Дэвид. и др. Red Hat Linux 6. Энциклопедия пользователя. - ДиаСофт, 2000. - 864 с.

Бывают домохозяйки, которые любят толщину. Для них сделали кучу всяких энциклопедий. Что такое энциклопедия по Юниксу? Это тонны бумаги, где, на первый взгляд, собрано практически все. Тетка смотрит в оглавление - глаза разбегаются. Сколько ни листай, все время находишь что-то не то. Рекомендуем для тренировки пальцев онанистам. В такой помойке очень сложно ориентироваться, особенно если книга отвратительно сверстана. Авторы, видимо, знали, что дамочке просто нечего читать, поэтому снабдили текст большим количеством воды. Полезно чтение энциклопедии на ночь, после просмотра очередной мыльной оперы.


Спецвыпуск Хакера, номер #005, стр. 005-106-3, UNIX: книжный обзор

UNIX: книжный обзор

Спецвыпуск Хакера, номер #005, стр. 005-106-3

Масенькая книга

Ивановский С. Операционная система Linux для начинающих и не только. Познавательная книга. - 1999. - 192 с.

Школьницы любят книжки за компактность, чтобы помещались в сумочку вмести с губной помадой и карамелькой чупа-чупс. Им совсем не важно, что там на 50-ти страницах написано. Главное, что в названии присутствует Linux. Такие книги рассчитаны на очень продвинутых школьниц. Опытный администратор вряд ли сможет там разобраться.

Настольные книжки маразматика

Пасечник А. Red Hat 6.2 Linux. Учебный курс. - Питер, 2000. - 560 с. - CD: Red Hat Linux 6.2

Фолькердинг П. Установка и конфигурация Linux. Учебный курс. - Питер, 1999. - 496 с. - 2 CD: Slackware Linux и приложения.

Особо старым маразматикам можно предложить книжки с дисками. Зачем книжка? В ней написано, как установить содержимое компакта на винт. Рекомендуем для развития геморроя холодными осенними вечерами. Хотя, если удастся где-то стырить бесплатно диск без книжки, приложения с него могут оказаться вполне полезными.

Справочники

Если окончательно разбил маразм и забылись остатки английского, а слово man ты набираешь около трех минут, можешь приобрести еще любой справочник по командам, вроде этих:

Рейчард К. Linux: Справочник. - СПб.: Питер, 1998. - 480 с.

Рейчард К. Unix: Справочник. - СПб.: Питер, 1998. - 374 с.

Дайсон П. Операционная система UNIX. Настольный справочник. - Лори, 1997.

После того как ты всосешь всю cуперполезную инфу, нарытую Холодом с командой, тебе понадобится что-то более мощное. Нужна хорошая книга для углубления твоих знаний. Но какую купить? Чтобы ответить на этот вопрос, мы перерыли тонны бумажных помоев. Вот тебе их квинтэссенция.


Спецвыпуск Хакера, номер #005, стр. 005-108-1, ЧТО ТАКОЕ UNIX?

ЧТО ТАКОЕ UNIX?

Спецвыпуск Хакера, номер #005, стр. 005-108-1

Михаил Михин (centner@xakep.ru)

ЭТО СКАЗКА!

Что, не верится? ДА! Ты дорвался. Теперь ты, наверное, уже поставил себе Красную Шапку и стал неимоверно крутым. Но учти - надо еще и историю учить. Ты знаешь, откуда взялась Юникс? А кому она принадлежит? Что, скажешь - халявная - значит ничья? Ни фига! Слово ЮНИКС является торговой маркой, принадлежащей компании AT&T.

ОС Unix - полноценная, изначально многопользовательская, многозадачная и многотерминальная операционная система. Точнее, это целое семейство систем, почти полностью совместимых друг с другом на уровне исходных текстов программ.

В нашем же случае это целый букет операционных систем, сотворенных по образу и подобию операционной системы UNIX. Из всех существующих на данный момент ОС UNIX - это старшая, наиболее развитая платформа, вобравшая в себя за время своего существования опыт нескольких поколений специалистов. Помимо названия для целого семейства ОС, слово UNIX служит для обозначения стиля жизни нескольких поколений программистов, это целая культура со своим языком, укладом жизни, историей и правилами поведения.

ОСОБЕННОСТИ НАЦИОНАЛЬНОГО ПРОГРАММИРОВАНИЯ

Тебе, вероятнее всего, из всех UNIX-подобных ОС наиболее известна ОС Linux. Linux - это свободно распространяемая версия UNIX, разработанная горячим финским парнем Линусом Торвальдсом

(torvalds@kruuna.helsinki.fi - не забудь лично поблагодарить автора!) в Университете Хельсинки в 1990 году.

Наш финский друг постановил, что Linux должна быть полностью свободной, и решил сделать исходники ОС доступными любому желающему. Автор не стал патентовать или иным образом ограничивать распространение новой ОС. Наоборот, он опубликовал исходные коды своей системы в Интернет (17 сентября 1991 года), и к развитию системы подключилось большое число независимых разработчиков, которые много чего напортачили и продолжают свою кропотливую работу и по сей день. Благодаря этому на сегодняшний момент Linux - самая современная, многообразная, устойчивая и быстроразвивающаяся система, почти мгновенно вбирающая в себя самые последние технологические новшества.

КОГДА КОМПЬЮТЕРЫ БЫЛИ БОЛЬШИМИ, или откуда взялась ОС Юникс

Однажды, когда еще компьютеры были большими, а про Microsoft никто и слыхом не слыхивал, назрела в мире необходимость в операционной системе для полноценного обслуживания межкомпьютерной связи. Без операционной системы, как известно, компьютер вообще таковым не является, представляя собой ящик с электронной начинкой внутри. Для того чтобы этот ящик оживить и позволить работать с ним многим пользователям, и была разработана система UNIX. Кем? Хе-хе, ребятами из подразделения Computing Science Research Group фирмы Bell Labs в штате Нью-Джерси в США. Их ОС должна была стать мобильной, т.е. легко переносимой на другие компьютеры и поддерживающей множественные процессы и одновременную работу нескольких сотен пользователей на одной машине. Сказано - сделано! И новая ОС получила название UNICS (Uniplexed Information and Computing Service - однофункциональный информационный вычислительный сервис), сокращенное вскоре по звучанию до UNIX.


Спецвыпуск Хакера, номер #005, стр. 005-108-2, ЧТО ТАКОЕ UNIX?

ЧТО ТАКОЕ UNIX?

Спецвыпуск Хакера, номер #005, стр. 005-108-2

Перенести код ОС на новые платформы было довольно сложно, посему мудрые программисты крякнули и создали платформенно-независимый язык программирования. На основе разработанного ранее языка "B" (Би) был создан компилятор языка "C" (Си), который стал одной из стандартных компонент системы, что значительно облегчило перенос системы на другие аппаратные платформы и стало залогом большой популярности UNIX в последующем. Большая часть ядра Linux написана на языке Си, благодаря чему система достаточно легко переносится на различные аппаратные архитектуры. Ныне официальное ядро Linux работает на платформе Intel (начиная с i386), Compaq (ex. Digital) Alpha, Motorolla 68k, MIPS, PowerPC, Sparc, Sparc64, StrongArm, Intel Italium (IA-64).

Программисты из Bell Laboratories на протяжении ряда лет поддерживали линию основной версии UNIX, периодически выпуская новые ее редакции вплоть до 10. В 1976 году была выпущена версия 6, которая бесплатно распространялась в университетах и послужила основным толчком к росту популярности ОС. Вот отсюда-то и растут ноги сегодняшнего разнообразия, если не сказать - хаоса в стройных рядах UNIX-клонов.

Забавно отметить такой факт - популярность версии 7 оказалась настолько высока, что тогда еще молодая и неокрепшая компания Microsoft, едва успев выпустить более-менее рабочую версию своей операционной системы MS DOS 2.0 для компьютеров IBM PC, хватается за разработку собственной версии UNIX - Xenix. При этом делаются рекламные заявления о том, что именно эта ОС является стратегическим курсом компании, поскольку UNIX - будущее операционных систем :)). И это - МИКРОСОФТ! Прикинь!

Но вернемся к UNIX. Отдельной, фактически самодостаточной и ни от чего не зависящей ветвью UNIX-подобных ОС является Linux - это я уже говорил, да?. Считается, что Linux - это не совсем UNIX. История Linux началась с создания профессором Хельсинского университета Эндрю Танненбаумом программы Minix, демонстрирующей различные возможности UNIX. Студент факультета вычислительной техники того же университета Линус Торвальдс решил на ее основе разработать эффективную версию UNIX для платформы IBM PC, которую он назвал Linux. В 1991 году была опубликована версия 0.1. Получив большое распространение в Интернет и доработанная многими энтузиастами, эта ОС доросла к 1994 году до версии 1.0. И пошло - поехало!

У ВСЕХ СТОИТ! А У ТЕБЯ?

Врать не буду - лично я не люблю UNIX по ряду причин. Хотя поводы для любви есть, и их немало. Но у меня ОН не стоит. Возможно, пока :)).

Если ты еще не поставил Юникс на скорую руку после листания этого спеца, то давай попробуем вместе решить - ставить на твой домашний комп UNIX-like ОС или нет - на конкретных примерах. Я буду пытаться тебя напугать или наоборот - завлечь в мир *NIX, а ты уж сам решай, бояться тебе или бежать на рынок за невиданной доселе ОС, которую уже лет 30 совершенствуют и шлифуют.

HOW MUCH IS THE FISH?

Одна из самых важных причин выбора UNIX - его бесплатность и открытость. Но на бесплатности нас не проведешь, мы ведь не буржуины какие-нибудь, да и народная тропа на MITINO-BAZAAR пока не заросла, и купить там можно практически все что угодно. А на счет открытости исходников - сколько раз ты пытался найти и, возможно, купить исходники, например, Виндов? "А ано нам нада???" (с).


Спецвыпуск Хакера, номер #005, стр. 005-108-3, ЧТО ТАКОЕ UNIX?

ЧТО ТАКОЕ UNIX?

Спецвыпуск Хакера, номер #005, стр. 005-108-3

КТО ЕЛ ИЗ МОЕЙ МИСКИ?

Важным свойством Unix является его многотерминальность, много пользователей могут одновременно запускать программы на одной Unix-машине. Если не требуется использовать графику, можно обойтись дешевыми текстовыми терминалами (специализированными или на базе дешевых PC), подключенными по медленным линиям. Очевидно, что в случае с WINDOWS такие перспективы выглядят довольно призрачно :)).

ЛЕБЕДЬ И ЩУКА РАКОМ

Cвободное бесплатное распространение Linux имеет и обратную, негативную сторону - любой сторонний разработчик может запросто "прицепить" к официальной версии все что угодно. Вот и пишут программеры всевозможные дополнения "кто во что горазд". Дистрибутивы... ну очень сильно отличаются друг от друга, и о единой системе версий Linux говорить вообще не приходится. Опять же - как именно ты собираешься выбрать оптимальный для твоей машины дистрибутив из, как минимум, десятков имеющихся? У UNIX имеется существенный недостаток - отсутствие единой концепции развития. Вот поэтому "лучшую" версию выбирают по принципу: лучшая та, которая стоит у твоего знакомого программера, на голову больного Юниксом...

А если ты выбираешь Windows, то точно знаешь, что такое W95-W98-W2000 и прочие. Попробовал бы кто-нибудь добавить в дистрибутив Windows 98 пару мегов "отсебятины" :)) или целиком переработать оконный интерфейс.

СТАРЕНЬКИЙ, ВИДАВШИЙ ВИДЫ PENTIUM III...

Некоторые UNIX-like ОС можно запросто установить на безобразно устаревшее "железо", они нетребовательны к вычислительным ресурсам. Работать эта штука будет не быстро, но стабильно. Запусти-ка сервер под управлением WINDOWS на 386 компе с 8 мегами памяти!

То-то же! А ты знаешь о существовании специальных версий Linux, которые работают даже на 8086 процессоре с 512 кило памяти? Да, это, конечно, экстрим, но не экстрим ли то, что 486 процессор и 16 метров памяти с полугигабайтным винтом - это вполне приемлемая конфигурация для машины под управлением *NIX? Теперь неплохо бы вспомнить о реальной минимальной конфигурации для WIN98 :).

Занятно и то, что с переходом на ОС *NIX отпадает само собой естественное желание постоянно апгрейдить систему. Это желание неразделимо с понятием Windows :).

СТАРЫЙ ДРУГ ЛУЧШЕ НОВЫХ ДВУХ

Linux совершенствуется с каждой новой версией. Насколько часто выходят новые версии того же Линукса? Часто? А у тебя есть время осваивать каждые 3-4 месяца новую версию ОС, искать документацию и перманентно наслаждаться лавинообразными обновлениями и читать кипу документов о работе исправлений и дополнений?

Не проще ли спокойно установить старые добрые винды и переустанавливать их (если повезет) пару раз в год? Хотя когда мы говорим UNIX - подразумеваем реальную многозадачность и жесткое разделение памяти, и обеспечение высокой надежности функционирования системы в целом.


Спецвыпуск Хакера, номер #005, стр. 005-108-4, ЧТО ТАКОЕ UNIX?

ЧТО ТАКОЕ UNIX?

Спецвыпуск Хакера, номер #005, стр. 005-108-4

Напомню, что вероятность работы Linux без перезапусков в течение недель и даже месяцев значительно выше, чем у Windows NT, например. Но, с другой стороны, не секрет, что интерфейс Windows NT более дружественен пользователю, а пользователям Linux нравится необыкновенно высокая степень контроля, которую они имеют над своей ОС.

БАМБАРБИЯ? КИРГУДУ!

Над кириллическими кодировками даже в WINDOWS приходится поломать голову, но справиться все же реально. С *NIX ситуация и вовсе катастрофическая. Гарантий правильного отображения кириллических шрифтов в прикладных программах никто не дает. Вот и приходится маяться с кодировками в UNIX, выбирая между KOI8, UNICODE, CP866, ISO8859-5, CP1251...

НЕСЛОЖНЫЙ ВЫВОД

Теперь тебе остается лишь сделать простой выбор.

Аргументы виндусоида: я еще не дорос до желания стать крутым системным администратором, у меня нет времени на вникание в тонкости работы *NIX, нет денег на покупку многих томов литературы, посвященной бесплатной надежной и многопроцессорной ОС, мой персональный домашний компьютер и WINDOWS с лихвой покрывают мои же запросы, и словосочетание "Билл Гейтс" не вызывает у меня приступов тошноты. Я хорошо помню, что нужные мне программы можно раздобыть в привычных местах и вероятность их корректной работы под управлением моей ОС все же очень велика.

Аргументы линуксоида: я устал от постоянных зависаний и перезагрузок, устал, что все рычаги управления осью спрятаны от меня как спички от маленького ребенка. Я хочу получить надежную, мощную и быстроразвивающуюся систему и готов заплатить за это часами, днями, возможно, неделями, проведенными за книгами, скриптами, настройками... В конце концов, я просто не хочу быть как все остальные! И вообще - Windows Mustdie, UNIX Rulezz Forever!

Если ты все же решился, то загляни сюда в поисках бесплатного русского дистрибутива:

http://blackcatlinux.com

http://linux.geon.donetsk.ua.

http://www.ksi-linux.com

http://linux-ve.chat.ru/book/www.magister.msk.ru/tech/linux/rh-rus.htm

http://www.usoft.spb.ru

http://www.linuxhq.com


Спецвыпуск Хакера, номер #005, стр. 005-110-1, 10 мифов о Linux

10 мифов о Linux

SideX sidex@xakep.ru

Спецвыпуск Хакера, номер #005, стр. 005-110-1

Сколько было криков: «Ура! Я себе линукс поставил! Да у меня теперь не винды течные, а ШАПКА стоит! Вы-то ламаки, а я со своим пингвином крут!». Или же: «Да не... это только сисадминам всяким, программистам надобно... хаксорам крутым, а мне как обыкновенному юзеру - на фиг не надо. Да там же сплошная консоль и text-mode, никакого гуя!». «Я бы поставил... да вот софта под Линух совсем нету, да и с драйверами напряги...»

Короче, сравнительно молодая OS Linux успела породить массу слухов и небылиц, которые будут тщательно подобраны и опровергнуты в данной статье. Все надуманное - обзову мифами. Их будет 10.

1. Там вообще нет интерфейса - сплошная строка; не хочу обратно в ДОС!

Миф о том, что вся работа происходит в консоли, популярен у людей, едва знакомых с рассматриваемой осью, и у очень продвинутых, знающих все команды и избегающих визуализации, а также у обладателей супердревних компов, где о GUI`е не может быть и речи. Так вот, реальность в том, что при помощи графических оболочек (возьмем наиболее популярные и распространенные) KDE и GNOM`a можно вытворять такую красоту, что самым причесанным виндам в "Талисмане" и не снилось! Посмотреть на это в журнале можно в статье о различных Х-виндах под линукс. Короче, набрав волшебное startx, ты попадаешь в совершенно другой мир "Рабочего стола", недоступный win. И это при достаточно умеренных потребностях в ресурсах (тот же "Талисман" в момент пожирает юзерские 32 мешка ;)). Существует туча тем под Х-windows - как с больших сайтов о *nix, так и на юзерских страничках, написать свою тему вполне реально. Хотя говорить, что визуализация Linux проходит бесследно, без жора ресурсов - лукавство. Если машинка действительно слабая, то порой лучше ограничиться консолью с ее различными псевдографическими приложениями. Более подробно о мифе удовлетворенности пингвина малым - в следующем пункте >:).

2. Поставил Линукс: на "четверке" летает быстрее, чем виндос на P3!

Изначально *nix разрабатывался как серверная ОС. А где серверы, там... 5 винтов на SCSI, 2-4х процессорные матери с детишками, набитыми по 1-2 мега кэшем L2 каждый, с 512 мегами мозгов на всех =). Понятно, что на твою домашнюю систему никто не собирается ставить одновременно почтовый, ftp, telnet, news, etc - демонов, к которым производится по 5 обращений от разных юзеров одновременно %), но сам факт "непотребности в ресурсах" - отсутствует. Т.е. поставить пингвина на 486-ую машину с 8-16 мегами оперативы - реально, но очень гиморно как в плане конфига, так и в дальнейшем пользовании. Были разговоры о том, что даже на слабых машинах Linux прекрасно вытягивает MPEG/DVD видео. Так вот скажу, что видел лично: сие был не фильм "Угнать за 60 секунд", а азбука общения для кривоязыких заик с текстовыми пояснениями :). Хотя порой линух показывает выдающиеся финты при работе с 3D-графикой на маломощных системах. Но лично я знаю лишь парочку профессиональных 3D-дизайнеров, работавших с графикой в *nix. Да и то было на крутом, профессиональном железе. Так что ставить *nix с перспективой его мультимедийного (хех, лет 5-6 назад xtra-популярное слово было =)) и визуального использования - лучше на машину с процом, поддерживающим L2, памятью не менее 32-х метров (_не менее_, т.е. комфорт работы в графике можно почувствовать, начиная с 64-х), винтом на не менее 5400 оборотов (хоть линукс не имеет особой привычки свопить, но и память лишним гимором лучше не грузить). А вообще, понятие "комфорта работы" - чисто субъективное, так что выбирай конкретно под себя.


Спецвыпуск Хакера, номер #005, стр. 005-110-2, 10 мифов о Linux

10 мифов о Linux

SideX sidex@xakep.ru

Спецвыпуск Хакера, номер #005, стр. 005-110-2

3. Я же маньяк железа - как мне с Linux дружить, если там драйверов-то нету?!!

Избаловались же вы, товарищи! Люди, поюзав Win c ее тотальным Plug`n`Play`ем, - обленились вконец. И забыли те времена, когда под свежекупленную звуковуху драйвер искался по всем московским ббскам и пиратским дискам "1000 и 1 драйвер". И находился-то не всегда. Итак, говорите, что под Линукс драйверов железа нет? Есть. Другое дело, что не всегда можно найти официальный/референсовый драйвер под рассматриваемую систему. А самопальных драйверов - немерено. Как распространяемых отдельно от устанавливаемой ОС, так и в комплекте таковой. Убедиться в этом я смог, устанавливая FreeBSD (я помню, что мы говорим про Linux, но набор drv в той и другой системах - схожий) на ноутбук: в комплекте с 4.0 шел нехилый набор драйваков под достаточно редкую версию моей Cyber-видео карточки. Там было даже обеспечение для тех вариаций карточки, что официально не поддерживаются производителем и для коих не имеется официальных драйверов под винды вообще ;). Естественно, никакого "Плуг`н`Плэя" нету: приходится выбирать необходимую железку из списка. Но, зная названия необходимого hardware, - отыскать несложно. А если в списках не значится, то без особых проблем можно нарыть в Инете на сайтах, посвященных Linux, в конфах, эхах, мэйл листах, у людей в LUG`ах. Реальный гимор, как показывает практика, возникает с SCSI-адаптерами, поддержкой в видеокартах финтов, потребных в гамесах, ряда USB-девайсов и, ясный пень, soft modem`ов >:). Хотя, имхо, USB пока не столь популярен (увы), SCSI-девайсов тоже не так много, а отстойные софт-модемы не стоит покупать изначально. Короче, если есть Инет, то найти необходимые drv под Линь - не станет большой трудностью.

4. Если поставишь Linux - тебя никогда не хакнут!

Достаточно грубо сформулированный миф, ибо вокруг "Да все вы ламаки, а я в Линуксе" очень распространен и принимает разные формы, две из которых вынесены в разные пункты. Так что там насчет неломаемой ОС? ;) Да то, что если взять статистику (например, attrition.org) по взломанным системам, с учетом установленной там системы, получится, что самые хакаемые станции находятся под руководством Windows NT и Linux. Это к тому, что как серверная OS - Linux не является признанным бастионом безопасности на фоне более стабильного Solaris`a, Free/Open/Net BSD. А как пользовательская - пожалуй, тоже. Возможно, Линух станет стеной на защиту от ряда D.O.S атак, вроде oob; igmp; багов из серии con/con, etc. Но без грамотной настройки файрвола не защитит от никем не отмененных грубых ICMP-атак. Понятно, что, даже впарив тебе троянца "Позови соседа", недоброжелатели ничего не поимеют (гы-гы, они поимеют все с помощью password.c ;), да от бомбежек любимым войдозером последствий не будет... В общем, иммунитет Linux к нападкам кул-хацкеров находится не на столь высоком уровне. Крипто? Стандартными средствами вряд ли можно шифровать что-либо серьезное, потому что существует более стабильный GNU/PGP (заметим, что у последних имеются как *nix, так и win-версии). Также не стоит забывать про постоянные баги в новых kernel`ах, и переполнение буфера в ряде популярных продуктов (я лично поимел неслабый гимор в Linux при пользовании дырявым BitchX irc-клиентом). А про кривые mount`ы и безрукое конфигурирование samba`ы я вообще молчу. Понятно, что, погиморроившись, можно сделать из Linux вполне безопасную систему, но лишь погиморроившись, а не проехав на постоянном Plug`n`Play`е >:).


Спецвыпуск Хакера, номер #005, стр. 005-110-3, 10 мифов о Linux

10 мифов о Linux

SideX sidex@xakep.ru

Спецвыпуск Хакера, номер #005, стр. 005-110-3

5. У меня 98-ые стоят, потому что под них до фига прог, в отличие от Линуха!

Хех, стандартная отмаза людей, не способных/ленящихся поставить *nix. Понятно, что официального релиза ICQ под *nix - не было и вряд ли будет. Что любимый The Bat! существует только в win-версии, а Midnight commander вряд ли заменит Far или Wincmd... Но ведь то, что под Linux нету хорошего софта, - наглая ложь. Софт есть, просто он другой. Чтобы убедиться в этом, достаточно заглянуть на мой любимый сайт о Linux софте - www.linuxberg.com . Куча софта под консоль, X11, KDE, GNOM. А одних асек-то сколько... Столько, что не все вошли в обзор ICQ под Linux в Х#7 00. Есть где развернуться. Здесь меньше вариаций из серии "улучшенный интерфейс и повышение качества визуализации", т.е. если прога становится массово известной, то это значит, что в ней имеется нечто действительно новое/нужное. Если приглядеться к сотне вариаций почтовых клиентов под win, выделится лишь 10 более-менее разных/нужных, в то время как из 20 под Линукс - уже 10 будут нести что-то интересное. Итого, девизом пользовательского софта под *nix могла бы быть любимое лысым дедушкой - "Меньше, да лучше".

Другое дело - профессиональный софт, используемый, например, в издательском деле: win`дозный софт для верстки, дизайна, работы с видео и фото, порой разнообразнее *nix`овского (а то и вообще присутствует лишь в win-версиях). Но чтобы укомплектовать домашнюю машину "джентльменским" набором - вполне достаточно существующей подборки Linux-софта.

6. Как же я буду работать с Linux, если мне и винды нужны одновременно???

Года два назад я пользовался именно этой отмазкой, когда рьяно защищал свою НТю от гнусных провокаций корефанов, предлагавших поставить шапку. Хотя я и раньше точно знал, что на одной тачке свободно уживаются 2 и более ОС. Именно пользуясь этим мифом, я отложил установку Linux в собственную тачку на полгода... В то время как LILO (LILO boot) позволяет свободно выбрать: загружаться в DOS (а дальше уже в НТ/98/ и прочие win) или Linux. На одной из моих машин уживаются без особых проблем - FreeBSD 4.0 и NT 4.0, а на другой - Redhat 6.02, 98-ые и 2000-ые (NT 5.0). Просто разные ОС можно выбрать из списка или прогрузить нажатием на hotkey-клавишу. Отконфигурить загрузчик в Linux (тот же LILO хотя бы) не сложнее, чем прописать инфу в win`овких boot-файлах.


Спецвыпуск Хакера, номер #005, стр. 005-110-4, 10 мифов о Linux

10 мифов о Linux

SideX sidex@xakep.ru

Спецвыпуск Хакера, номер #005, стр. 005-110-4

7. Кроме понтов "у меня ваще шапка стоит!", реальному хакеру не нужен Linux!

Один мой знакомый пытался поставить Слак. Не разобравшись в том, где живет "точка монтирования" и чем отличается Ext2fs от FAT32, он стал прогонять отстой по теме, что не поставил себе пингвина исключительно потому, что супер-пуперс хакерам эта ось на фиг не нужна! Понятно, что в большинстве случаев крики о ненужности линукса от ни разу его не ставившего - пустое и обсуждения недостойное дело >:). Лучше припомнить, сколько ценного хакерского софта прописано исключительно под *nix или компилируется/используется с большим комфортом в этой ОС. Ты когда-нибудь видел сканер WUFTPD 2.6.0, QPOP 2.53 под винды? Да и большинство win-реализаций военных эксплойтов, вроде smurf.c/land.c/портсканер scan.c, на порядок хуже их оригинальных *nix-релизов. Я и не говорю про преимущество юниксовых компиляторов, вроде gcc, перед виновыми... Если есть какие-то сомнения - просмотри постинги Bugtraq`a с инфой о вышедших эксплойтах и убедись.

8. Все хакеры пользуются Linux, а сраные ламосы - WINDOWS! Ламосы MUST DIE!

Миф, противоположный предыдущему. Вот уж, мама дорогая, сложился нелепый стереотип... в понимании "настоящих" хакеров :). Если уж делать опровержение сказанного, то стоит начать с самих хакеров - точнее с того, какие ОС у них в фаворе. Так вот, правда в том, что в узких кругах рассматриваемых ребят Linux имеет тот же авторитет, как Windows 98 перед Windows NT 4.0/5.0: облегченная игрушка для детей. Т.е. Linux, по сути, не является хакерской ОС на фоне FreeBSD, OpenBSD, NetBSD, Солярки, etc. Была даже известная карикатура, где черт OpenBSD пялит пингвина или разрывает его своим злобным трезубцем в другой интерпретации =).

Если у человека стоит win вместо *nix`a - это не значит, что он лам, как и не значит обратное: существует масса людей, повязанных с виндой рабочим софтом, специфическим железом, объективно не потребных в Linux`e. А если человек и поставил Линух - это говорит лишь о том, что он внимательно прочитал факин мануаль ;). Существует огромное количество юзеров, которые криво маунтят, устанавливают левые сервисы и проги, неумело настраивают ipchains`ы, в результате чего попадаются как дети >:). Ну не поднимается рука противопоставить их "ламерам", искусно пользующимся виндами... Как говорится у админов: "Главное не что админится, а кем и как!".

9. Nafig mne Linux: tam netu russkih bukv! :(((

Очень популярная байка! Ужасы рассказывают про e-mail клиенты, в которых русские буквы шифруются, IRC, где дрякозяблы пляшут, текстовые редакторы с зюзюками... Действительно, нерусифицированные оригинальные Linux`ы в большинстве случаев не поддерживают кириллицу по дефолту и требуют ручной, и не очень, русификации. Но русифицирование консоли, X-windows, офисного софта, IRC/e-mail клиентов достаточно просто. И имеется 1001 одна дока howto по этому вопросу (даже Х писал об этом неоднократно). А для тех, кого ломает учить русскому пингвина ручками, предусмотрено несколько локализованных "русских" дистрибов - Black Cat, Linux Mandrake Russian edition, русифицированный "Star office" и т.д. Установив такого пингвинчика, тебе не придется кричать в чате: Pishite po eng! Ja ne vizhu russkih bukv!!! :).


Спецвыпуск Хакера, номер #005, стр. 005-110-5, 10 мифов о Linux

10 мифов о Linux

SideX sidex@xakep.ru

Спецвыпуск Хакера, номер #005, стр. 005-110-5

10. Линух слишком сложен для меня! I`m too chicken to install linux :(.

Бытует мнение, что система сложна до чертиков (чертиков BSD, очевидно ;)) как в настройке, так и в дальнейшем пользовании. Так вот: могу утверждать, что для человека, проработавшего не менее двух лет в другой ОС, не будет проблемой пересесть на крепкие плечи пингвина Тукса =). Сложности при первых шагах возникают, в основном, в трех-четырех метафизических состояниях: загрузка-установка Linux, попадание/навигация в text-mode вместо привычных окошек, русификация и проблемы с настройкой dial-up`a. Если морально подготовить себя к этим и другим проблемам (которые, в основном, подробно разрешены в горячо любимых FAQ`ах), то можно смело ставить на закачку кернел и сопутствующие или вставлять одноглазого в ненасытный CD-ROM :).

P.S. Название данной статьи не оригинально: на сайте дистрибутива Linux Black Cat (www.blackcatlinux.com) имеется точно такая же директория. Разность лишь в том, что тамошние мифы разрушаются исключительно с лозунгом "Ставь! Ставь! Ставь скорее наш Линукс!". Я же хотел показать проблему не столь однобоко, открыв также слабые стороны пингвина, развеяв миф о его крутости и недоступности (ишь, мессия нашелся, учить он нас тут правде будет! =)). Помни, что это не более чем обычный клон *nix, просто другая ОС, а вовсе не религия, как это пытаются подать юзеру. Ну все, удачи, пойду помолюсь :).